eygle Eygle.
Internal 2005-10-24

ORA-00600 2662错误解决

继续上一个测试,使用隐含参数_ALLOW_RESETLOGS_CORRUPTION后resetlogs打开数据库后,我们说很多时候你会遇到ORA-00600 2662号错误,这个错误的含义是:

A data block SCN is ahead of the current SCN.
The ORA-600 [2662] occurs when an SCN is compared to the dependent SCN
stored in a UGA variable.
If the SCN is less than the dependent SCN then we signal the ORA-600 [2662]
internal error.

在测试中,很容易模拟这个错误:

Thu Oct 20 10:38:27 2005
            SMON: enabling cache recovery
            Thu Oct 20 10:38:27 2005
            Errors in file /opt/oracle/admin/conner/udump/conner_ora_31607.trc:
            ORA-00600: internal error code, arguments: [2662], [0], [897694446], [0], [897695488], [8388697], [], []
            Thu Oct 20 10:38:28 2005
            Errors in file /opt/oracle/admin/conner/udump/conner_ora_31607.trc:
            ORA-00600: internal error code, arguments: [2662], [0], [897694446], [0], [897695488], [8388697], [], []
            


如果SCN相差不多,可以通过多次重起数据库解决。

也可以通过内部事件:
alter session set events 'IMMEDIATE trace name ADJUST_SCN level 1';
来解决。

我这里通过几次重起就解决了问题:)
也可以参考ORA-00600 [2662]错误解决过程

进一步的说明及复制情况处理,请参考:Oracle Diagnostics:How to deal with ORA-600 2662 Error 。

By eygle 2005-10-24 11:45 评论 (4)
eygle
eygle

前Oracle ACE Director,云和恩墨创始人。技术为骨,历史为脉,人文为魂。

返回首页 →

4 Comments

这个level 1批的是每次打开不行的话将scn推进1百万

可以根据trace中的信息, 将level调高一些.

强哥
标题好像写错了ORA-00600 2262错误解决
2262 应该是2662吧

强哥
标题好像写错了ORA-00600 2262错误解决
2262 应该是2662吧