Oracle9i SQL Reference

Oracle® Database Error Messages
10g Release 1 (10.1)
Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback

资料来源

资料来源：Oracle OTN 文档库

收集整理：Snowywolf

整理时间：2004-05

适用版本：Oracle 10g

版权声明

您可以自由地将此文档复制发行，但请保留此声明页。

请勿将此文档用于任何商业用途。

联系作者

ITPUB号：Snowywolf

E m a i l：lisj@supermap.com

姓 名：李绍俊

雪狼 作品
Oracle
Copyright © 2003, Oracle Corporation
All Rights Reserved


Oracle® Database

Skip Headers

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

Oracle® Database

Error Messages

10g Release 1 (10.1)

Part No. B10744-01

December 2003

Oracle Database Error Messages, 10g Release 1 (10.1)

Part No. B10744-01

Copyright © 2003, Oracle. All rights reserved.

The Programs (which include both the software and documentation) contain proprietary information; they are provided under a license agreement containing restrictions on use and disclosure and are also protected by copyright, patent, and other intellectual and industrial property laws. Reverse engineering, disassembly, or decompilation of the Programs, except to the extent required to obtain interoperability with other independently created software or as specified by law, is prohibited.

The information contained in this document is subject to change without notice. If you find any problems in the documentation, please report them to us in writing. This document is not warranted to be error-free. Except as may be expressly permitted in your license agreement for these Programs, no part of these Programs may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose.

If the Programs are delivered to the United States Government or anyone licensing or using the Programs on behalf of the United States Government, the following notice is applicable:

U.S. GOVERNMENT RIGHTS Programs, software, databases, and related documentation and technical data delivered to U.S. Government customers are "commercial computer software" or "commercial technical data" pursuant to the applicable Federal Acquisition Regulation and agency-specific supplemental regulations. As such, use, duplication, disclosure, modification, and adaptation of the Programs, including documentation and technical data, shall be subject to the licensing restrictions set forth in the applicable Oracle license agreement, and, to the extent applicable, the additional rights set forth in FAR 52.227-19, Commercial Computer Software--Restricted Rights (June 1987). Oracle Corporation, 500 Oracle Parkway, Redwood City, CA 94065

The Programs are not intended for use in any nuclear, aviation, mass transit, medical, or other inherently dangerous applications. It shall be the licensee's responsibility to take all appropriate fail-safe, backup, redundancy and other measures to ensure the safe use of such applications if the Programs are used for such purposes, and we disclaim liability for any damages caused by such use of the Programs.

Oracle is a registered trademark of Oracle Corporation and/or its affiliates. Other names may be trademarks of their respective owners.

The Programs may provide links to Web sites and access to content, products, and services from third parties. Oracle is not responsible for the availability of, or any content provided on, third-party Web sites. You bear all risks associated with the use of such content. If you choose to purchase any products or services from a third party, the relationship is directly between you and the third party. Oracle is not responsible for: (a) the quality of third-party products or services; or (b) fulfilling any of the terms of the agreement with the third party, including delivery of products or services and warranty obligations related to purchased products or services. Oracle is not responsible for any loss or damage of any sort that you may incur from dealing with any third party.

Go to previous page
Previous 		Go to next page
Next
Oracle
Copyright © 2003, Oracle Corporation
All Rights Reserved.


Send Us Your Comments

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

Send Us Your Comments

Oracle Database Error Messages, 10g Release 1 (10.1)

Part No. B10744-01

Oracle welcomes your comments and suggestions on the quality and usefulness of this publication. Your input is an important part of the information used for revision.

  • Did you find any errors?

  • Is the information clearly presented?

  • Do you need more information? If so, where?

  • Are the examples correct? Do you need more examples?

  • What features did you like most about this manual?

If you find any errors or have any other suggestions for improvement, please indicate the title and part number of the documentation and the chapter, section, and page number (if available). You can send comments to us in the following ways:

  • Electronic mail: infodev_us@oracle.com

  • FAX: (650) 506-7227 Attn: Server Technologies Documentation Manager

  • Postal service:

    Oracle Corporation
    Server Technologies Documentation
    500 Oracle Parkway, Mailstop 4op11
    Redwood Shores, CA 94065
    USA

If you would like a reply, please give your name, address, telephone number, and electronic mail address (optional).

If you have problems with the software, please contact your local Oracle Support Services.

Go to previous page


Preface

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

Preface

This manual describes error messages that may appear while using products that are part of the Oracle Database. Each message listing in the manual contains the message statement, an explanation of the probable causes of the message, and a recommended action. If the message is a warning or indicates that an error occurred, the message listing indicates a corrective action.

This preface contains these topics:

  • Intended Audience

  • Documentation Accessibility

  • Related Documents

  • Conventions

Intended Audience

Oracle Database Error Messages is intended for all Oracle users.

Documentation Accessibility

Our goal is to make Oracle products, services, and supporting documentation accessible, with good usability, to the disabled community. To that end, our documentation includes features that make information available to users of assistive technology. This documentation is available in HTML format, and contains markup to facilitate access by the disabled community. Standards will continue to evolve over time, and Oracle is actively engaged with other market-leading technology vendors to address technical obstacles so that our documentation can be accessible to all of our customers. For additional information, visit the Oracle Accessibility Program Web site at

http://www.oracle.com/accessibility/
Accessibility of Code Examples in Documentation

JAWS, a Windows screen reader, may not always correctly read the code examples in this document. The conventions for writing code require that closing braces should appear on an otherwise empty line; however, JAWS may not always read a line of text that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation

This documentation may contain links to Web sites of other companies or organizations that Oracle does not own or control. Oracle neither evaluates nor makes any representations regarding the accessibility of these Web sites.

Related Documents

For more information, see these Oracle resources:

  • Oracle Database Concepts for general information about the Oracle Database and how it works

  • Oracle Database Administrator's Guide and Oracle Database Backup and Recovery Basics for information about administering the Oracle Database

  • Oracle Database Application Developer's Guide - Fundamentals, PL/SQL Packages and Types Reference, Oracle Database Application Developer's Guide - Large Objects, and Oracle Streams Advanced Queuing User's Guide and Reference for information about developing database applications within the Oracle Database

  • Oracle Database Upgrade Guide for the procedures for upgrading the Oracle Database

  • Oracle Database SQL Reference for information on Oracle's SQL commands and functions

  • Oracle Database Utilities for information about the utilities bundled with the Oracle Database, including Export, Import, and SQL*Loader

  • Oracle Net Services Administrator's Guide for information about Oracle Net Services

  • Oracle Advanced Security Administrator's Guide for information about data encryption, external authentication services, and Oracle DCE integration, all included in the Oracle Advanced Networking Option

  • For information specific to the Oracle Database working on your host operating system, see your operating system-specific Oracle documentation (specific book titles vary by operating system) and system release bulletins, if available.

Many of the examples in this book use the sample schemas of the seed database, which is installed by default when you install Oracle. Refer to Oracle Database Sample Schemas for information on how these schemas were created and how you can use them yourself.

Oracle error message documentation is only available in HTML. If you only have access to the Oracle Documentation CD, you can browse the error messages by range. Once you find the specific range, use your browser's "find in page" feature to locate the specific message. When connected to the Internet, you can search for a specific error message using the error message search feature of the Oracle online documentation.

Printed documentation is available for sale in the Oracle Store at

http://oraclestore.oracle.com/

To download free release notes, installation documentation, white papers, or other collateral, please visit the Oracle Technology Network (OTN). You must register online before using OTN; registration is free and can be done at

http://otn.oracle.com/membership/

If you already have a username and password for OTN, then you can go directly to the documentation section of the OTN Web site at

http://otn.oracle.com/documentation/

Conventions

This section describes the conventions used in the text and code examples of this documentation set. It describes:

  • Conventions in Text

  • Conventions in Code Examples

  • Conventions for Windows Operating Systems

Conventions in Text

We use various conventions in text to help you more quickly identify special terms. The following table describes those conventions and provides examples of their use.

Convention | Meaning | Example
Bold | Bold typeface indicates terms that are defined in the text or terms that appear in a glossary, or both. | When you specify this clause, you create an index-organized table.
Italics | Italic typeface indicates book titles or emphasis. | Oracle Database Concepts Ensure that the recovery catalog and target database do not reside on the same disk.
UPPERCASE monospace (fixed-width) font | Uppercase monospace typeface indicates elements supplied by the system. Such elements include parameters, privileges, datatypes, RMAN keywords, SQL keywords, SQL*Plus or utility commands, packages and methods, as well as system-supplied column names, database objects and structures, usernames, and roles. | You can specify this clause only for a NUMBER column. You can back up the database by using the BACKUP command. Query the TABLE_NAME column in the USER_TABLES data dictionary view. Use the DBMS_STATS.GENERATE_STATS procedure.
lowercase monospace (fixed-width) font | Lowercase monospace typeface indicates executables, filenames, directory names, and sample user-supplied elements. Such elements include computer and database names, net service names, and connect identifiers, as well as user-supplied database objects and structures, column names, packages and classes, usernames and roles, program units, and parameter values. Note: Some programmatic elements use a mixture of UPPERCASE and lowercase. Enter these elements as shown. | Enter sqlplus to start SQL*Plus. The password is specified in the orapwd file. Back up the datafiles and control files in the /disk1/oracle/dbs directory. The department_id, department_name, and location_id columns are in the hr.departments table. Set the QUERY_REWRITE_ENABLED initialization parameter to true. Connect as oe user. The JRepUtil class implements these methods.
lowercase italic monospace (fixed-width) font | Lowercase italic monospace font represents placeholders or variables. | You can specify the parallel_clause. Run old_release.SQL where old_release refers to the release you installed prior to upgrading.

Conventions in Code Examples

Code examples illustrate SQL, PL/SQL, SQL*Plus, or other command-line statements. They are displayed in a monospace (fixed-width) font and separated from normal text as shown in this example:

SELECT username FROM dba_users WHERE username = 'MIGRATE';

The following table describes typographic conventions used in code examples and provides examples of their use.

Convention Meaning Example
[ ]
Brackets enclose one or more optional items. Do not enter the brackets.
DECIMAL (digits [ , precision ])

{ }
Braces enclose two or more items, one of which is required. Do not enter the braces.
{ENABLE | DISABLE}

|

A vertical bar represents a choice of two or more options within brackets or braces. Enter one of the options. Do not enter the vertical bar.
{ENABLE | DISABLE}
[COMPRESS | NOCOMPRESS]

...
Horizontal ellipsis points indicate either:

  • That we have omitted parts of the code that are not directly related to the example

  • That you can repeat a portion of the code

CREATE TABLE ... AS subquery;

SELECT col1, col2, ... , coln FROM employees;

.
 .
 .
Vertical ellipsis points indicate that we have omitted several lines of code not directly related to the example.
SQL> SELECT NAME FROM V$DATAFILE;
NAME
------------------------------------
/fsl/dbs/tbs_01.dbf
/fs1/dbs/tbs_02.dbf
.
.
.
/fsl/dbs/tbs_09.dbf
9 rows selected.
Other notation You must enter symbols other than brackets, braces, vertical bars, and ellipsis points as shown.
acctbal NUMBER(11,2);
acct    CONSTANT NUMBER(4) := 3;

Italics
Italicized text indicates placeholders or variables for which you must supply particular values.
CONNECT SYSTEM/system_password
DB_NAME = database_name

UPPERCASE
Uppercase typeface indicates elements supplied by the system. We show these terms in uppercase in order to distinguish them from terms you define. Unless terms appear in brackets, enter them in the order and with the spelling shown. However, because these terms are not case sensitive, you can enter them in lowercase.
SELECT last_name, employee_id FROM employees;
SELECT * FROM USER_TABLES;
DROP TABLE hr.employees;

lowercase
Lowercase typeface indicates programmatic elements that you supply. For example, lowercase indicates names of tables, columns, or files.

Note: Some programmatic elements use a mixture of UPPERCASE and lowercase. Enter these elements as shown.

SELECT last_name, employee_id FROM employees;
sqlplus hr/hr
CREATE USER mjones IDENTIFIED BY ty3MU9;

Conventions for Windows Operating Systems

The following table describes conventions for Windows operating systems and provides examples of their use.

Convention | Meaning | Example
Choose Start > | How to start a program. | To start the Database Configuration Assistant, choose Start > Programs > Oracle - HOME_NAME Configuration and Migration Tools > Database Configuration Assistant.
File and directory names File and directory names are not case sensitive. The following special characters are not allowed: left angle bracket (<), right angle bracket (>), colon (:), double quotation marks ("), slash (/), pipe (|), and dash (-). The special character backslash (\) is treated as an element separator, even when it appears in quotes. If the file name begins with \\, then Windows assumes it uses the Universal Naming Convention.
c:\winnt"\"system32 is the same as C:\WINNT\SYSTEM32
C:\> Represents the Windows command prompt of the current hard disk drive. The escape character in a command prompt is the caret (^). Your prompt reflects the subdirectory in which you are working. Referred to as the command prompt in this manual.
C:\oracle\oradata>
Special characters The backslash (\) special character is sometimes required as an escape character for the double quotation mark (") special character at the Windows command prompt. Parentheses and the single quotation mark (') do not require an escape character. Refer to your Windows operating system documentation for more information on escape and special characters.
C:\>exp scott/tiger TABLES=emp QUERY=\"WHERE job='SALESMAN' and sal<1600\"
C:\>imp SYSTEM/password FROMUSER=scott TABLES=(emp, dept)

HOME_NAME
Represents the Oracle home name. The home name can be up to 16 alphanumeric characters. The only special character allowed in the home name is the underscore.
C:\> net start OracleHOME_NAMETNSListener
ORACLE_HOME and ORACLE_BASE In releases prior to Oracle8i release 8.1.3, when you installed Oracle components, all subdirectories were located under a top level ORACLE_HOME directory that by default used one of the following names:

  • C:\orant for Windows NT

  • C:\orawin98 for Windows 98

This release complies with Optimal Flexible Architecture (OFA) guidelines. All subdirectories are not under a top level ORACLE_HOME directory. There is a top level directory called ORACLE_BASE that by default is C:\oracle. If you install the latest Oracle release on a computer with no other Oracle software installed, then the default setting for the first Oracle home directory is C:\oracle\ora nn, where nn is the latest release number. The Oracle home directory is located directly under ORACLE_BASE.

All directory path examples in this guide follow OFA conventions.

Refer to Oracle Database Platform Guide for Windows for additional information about OFA compliances and for information about installing Oracle products in non-OFA compliant directories.

 Go to the ORACLE_BASE\ORACLE_HOME\rdbms\admin directory.


1 Using Messages

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

1 Using Messages

This chapter gives you general information and helpful tips about error messages. This chapter covers the following topics:

  • Locating Message Documentation

  • Accuracy of Messages

  • Message Format

  • Recognizing Variable Text in Messages

  • Message Stacks

  • Contacting Oracle Support Services

  • Oracle Exception Messages

  • Trace Files

  • The Alert File

Locating Message Documentation

This section describes how to locate message documentation when given an error message.

Oracle error message documentation is only available in HTML. If you only have access to the Oracle Documentation CD, you can browse the error messages by range. Once you find the specific range, use your browser's "find in page" feature to locate the specific message. When connected to the Internet, you can search for a specific error message using the error message search feature of the Oracle online documentation.

Oracle Database Messages

These messages are generated by the Oracle Database when running any Oracle program. This manual documents messages that are common across Oracle products and tools.

Product Specific Messages

These messages are specific to one product and are documented in manuals for that product. For example, if you are working with Oracle Enterprise Manager, you would need to refer to the messages contained in the Oracle Enterprise Manager Messages Manual.

Operating System-Specific Messages

These messages are specific to one operating system. A range of message code numbers are reserved for each operating system. For example, the range ORA-07500 to ORA-07999 is reserved for DEC VAX/VMS messages; these messages are listed in the appropriate operating system-specific documentation.

The prefix of the message indicates where to find information about the message. For example, some messages in this manual have the prefix "ORA". If you encounter a message without a prefix, first check the manuals for the release of Oracle you are using, then check this manual.

Accuracy of Messages

The accuracy of the messages in this manual is our primary concern. Occasionally, an enhancement to a message is not incorporated into the Oracle software. Should you encounter a message generated on your system that differs from the message in this book, be assured the improved message text is usually incorporated in the next release of the software. If you should encounter a discrepancy, then please contact us using the information contained in the Reader Comment Form at the front of this manual.

Message Format

All messages displayed are prefixed by text that indicates which program issued the message. For example, the prefix "ORA" shows that the message was generated by the Oracle products. The location of messages in this book depends on the prefix of the message.

All messages are listed in order by the message code number. To look up a message, use the message code number.

Recognizing Variable Text in Messages

To help you find and fix errors, Oracle embeds object names, numbers, and character strings in some messages. These embedded variables are represented by string, number, or character, as appropriate. For example:

ORA-00020: maximum number of processes (number) exceeded

The preceding message might actually appear as follows:

ORA-00020: maximum number of processes (50) exceeded

Message Stacks

Occasionally, you may see a message stack. This is simply a series of related messages issued at different levels of Oracle.

The following message stack is a generic example:

ORA-06502: PL/SQL: numeric or value error
ORA-06512: at "SCOTT.VALUE_ERR", line 1
ORA-06512: at line 1

The following message stack is a VAX/VMS example:

ORA-01034: Oracle not available
ORA-07625: smsget: $MGBLSC failure
%SYSTEM-W-NOSUCHSEC, no such (global) section

In this example, notice that the message at the bottom of the stack is issued by the VMS operating system. Seeing the messages at each level in the system may help you trace the originating event. For example, in this case, Oracle may not be available simply because it has not been started, and consequently there is no system global area (SGA). If you need the help of Oracle Support Services, then be sure to report all the messages in the stack.

Contacting Oracle Support Services

Some messages recommend contacting Oracle Support Services to report a problem. When you contact Oracle Support Services, please have the following information available:

  • The hardware, operating system, and release number of the operating system on which Oracle is running

  • The complete release number of the Oracle Database (for example, release 9.2.0.1.0 or release 9.0.1.1.2)

  • All Oracle programs (with version numbers) in use when the error occurred. For example, SQL*Net V2.0 or SQL*Forms V3.0

  • If you encountered one or more error codes or messages, then the exact code numbers and message text, in the order they appeared

  • The problem severity, according to the following codes:

    1 = Program not usable. Critical impact on operations.

    2 = Program usable. Operations severely restricted.

    3 = Program usable with limited functions. Not critical to overall operations.

    4 = Problem circumvented by customer. Minimal effect, if any, on operations.

You will also be expected to provide the following:

  • Your name

  • The name of your organization

  • Your Oracle Support ID Number

  • Your telephone number

Oracle Exception Messages

Oracle's extensive self-checking helps detect internal errors. Oracle uses the following catchall message for Oracle internal exceptions:

ORA-00600: internal error code, arguments: [number], [number], [], [], [], []

An actual message might appear as follows:

ORA-00600: internal error code, arguments: [1042], [3], [upilam], [], [], []

The message text can be followed by up to six arguments, which indicate the origin and attributes of the error. The first argument is the internal error number. Other arguments are various numbers, names, and character strings. Empty brackets may be ignored.

In addition to being returned to the user, internal errors are also written to the Alert file along with additional information about the event causing the message. The Alert file also lists any trace files that may have been generated because of an internal error. See the following sections for descriptions of the trace and alert files.

If you receive an ORA-00600 message, report it to Oracle Support Services.

Trace Files

A trace file is created each time an Oracle instance starts or an unexpected event occurs in a user process or background process. The name of the trace file includes the instance name, the process name, and the Oracle process number. The file extension or file type is usually TRC, and, if different, is noted in your operating system-specific Oracle documentation. The contents of the trace file may include dumps of the system global area, process global area, supervisor stack, and registers.

Two initialization parameters are used to specify the location of the trace files.

  • The BACKGROUND_DUMP_DEST initialization parameter specifies the location of trace files created by the Oracle background processes PMON, DBWR, LGWR, and SMON.

  • The USER_DUMP_DEST initialization parameter specifies the location of trace files created by user processes such as SQL*Loader or Pro*C.

The Alert file also describes the location of trace files generated when internal errors occur. See the next section for a description of the Alert file.

You may need to format the trace file before using it to diagnose problems. To format a trace file, use the DUMPFMT utility, which is available on most systems and is described in your operating system-specific Oracle documentation. Oracle Support Services may ask you for a formatted trace file to help solve a problem.

See Also:

Oracle Database Administrator's Guide for more information about trace files

The Alert File

The Alert file is a log file that records information about internal errors and administrative activities, such as backups. When an internal error occurs, the message is sent to the terminal screen as well as written to the Alert file. Oracle also writes additional information about internal errors to the Alert file, such as the location and name of any trace files generated because of the error.

The name of the Alert file is operating system-specific. The location of the Alert file is the same as the location of the background process trace files. This location is specified by the BACKGROUND_DUMP_DEST initialization parameter. For more information, see your Oracle operating system-specific documentation.

If your system uses an operator's console, some messages from Oracle may appear on the console. All important messages are written to the Alert file as well as the operator's console. Because non-Oracle messages also appear on this console, the Alert file is a better record for tracing all Oracle administrative activity and errors than the console log.

The Alert file also records information about administrative activities, such as backups and archiving online redo log files.

See Also:

Oracle Database Administrator's Guide for more information about the Alert file


2 ORA-00000 to ORA-00830

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

2 ORA-00000 to ORA-00830

ORA-00000: normal, successful completion
Cause: Normal exit.
Action: None.
ORA-00001: unique constraint (string.string) violated
Cause: An UPDATE or INSERT statement attempted to insert a duplicate key. For Trusted Oracle configured in DBMS MAC mode, you may see this message if a duplicate entry exists at a different level.
Action: Either remove the unique restriction or do not insert the key.
ORA-00017: session requested to set trace event
Cause: The current session was requested to set a trace event by another session.
Action: This is used internally; no action is required.
ORA-00018: maximum number of sessions exceeded
Cause: All session state objects are in use.
Action: Increase the value of the SESSIONS initialization parameter.
ORA-00019: maximum number of session licenses exceeded
Cause: All licenses are in use.
Action: Increase the value of the LICENSE MAX SESSIONS initialization parameter.
ORA-00020: maximum number of processes (string) exceeded
Cause: All process state objects are in use.
Action: Increase the value of the PROCESSES initialization parameter.
ORA-00021: session attached to some other process; cannot switch session
Cause: The user session is currently used by others.
Action: Do not switch to a session attached to some other process.
ORA-00022: invalid session ID; access denied
Cause: Either the session specified does not exist or the caller does not have the privilege to access it.
Action: Specify a valid session ID that you have privilege to access, that is either you own it or you have the CHANGE_USER privilege.
ORA-00023: session references process private memory; cannot detach session
Cause: An attempt was made to detach the current session when it contains references to process private memory.
Action: A session may contain references to process memory (PGA) if it has an open network connection, a very large context area, or operating system privileges. To allow the detach, it may be necessary to close the session's database links and/or cursors. Detaching a session with operating system privileges is always disallowed.
ORA-00024: logins from more than one process not allowed in single-process mode
Cause: Trying to login more than once from different processes for ORACLE started in single-process mode.
Action: Logoff from the other process.
ORA-00025: failed to allocate string
Cause: Out of memory.
Action: Restart with larger sga heap.
ORA-00026: missing or invalid session ID
Cause: Missing or invalid session ID string for ALTER SYSTEM KILL SESSION.
Action: Retry with a valid session ID.
ORA-00027: cannot kill current session
Cause: Attempted to use ALTER SYSTEM KILL SESSION to kill the current session.
Action: None.
ORA-00028: your session has been killed
Cause: A privileged user has killed your session and you are no longer logged on to the database.
Action: Login again if you wish to continue working.
ORA-00029: session is not a user session
Cause: The session ID specified in an ALTER SYSTEM KILL SESSION command was not a user session (for example, recursive, etc.).
Action: Retry with a user session ID.
ORA-00030: User session ID does not exist.
Cause: The user session ID no longer exists, probably because the session was logged out.
Action: Use a valid session ID.
ORA-00031: session marked for kill
Cause: The session specified in an ALTER SYSTEM KILL SESSION command cannot be killed immediately (because it is rolling back or blocked on a network operation), but it has been marked for kill. This means it will be killed as soon as possible after its current uninterruptable operation is done.
Action: No action is required for the session to be killed, but further executions of the ALTER SYSTEM KILL SESSION command on this session may cause the session to be killed sooner.
ORA-00032: invalid session migration password
Cause: The session migration password specified in a session creation call was invalid (probably too long).
Action: Retry with a valid password (less than 30 chars).
ORA-00033: current session has empty migration password
Cause: An attempt was made to detach or clone the current session and it has an empty migration password. This is not allowed.
Action: Create the session with a non-empty migration password.
ORA-00034: cannot string in current PL/SQL session
Cause: An attempt was made to issue a commit or rollback from a PL/SQL object (procedure, function, package) in a session that has this disabled (by 'alter session disable commit in procedure')
Action: Enable commits from PL/SQL in this session, or do not attempt to use commit or rollback in PL/SQL when they are disabled in the current session.
ORA-00036: maximum number of recursive SQL levels (string) exceeded
Cause: An attempt was made to go more than the specified number of recursive SQL levels.
Action: Remove the recursive SQL, possibly a recursive trigger.
ORA-00037: cannot switch to a session belonging to a different server group
Cause: An attempt was made to switch to a session in a different server group. This is not allowed.
Action: Make sure the server switches to a session that belongs to its server group.
ORA-00038: Cannot create session: server group belongs to another user
Cause: An attempt was made to create a non-migratable session in a server group that is owned by a different user.
Action: A server group is owned by the first user who logs into a server in the server group in non-migratable mode. All subsequent non-migratable mode logins must be made by the user who owns the server group. To have a different user login in non-migratable mode, the ownership of the server group will have to be changed. This can be done by logging off all current sessions and detaching from all existing servers in the server group and then having the new user login to become the new owner.
ORA-00040: active time limit exceeded - call aborted
Cause: The Resource Manager SWITCH_TIME limit was exceeded.
Action: Reduce the complexity of the update or query, or contact your database administrator for more information.
ORA-00041: active time limit exceeded - session terminated
Cause: The Resource Manager SWITCH_TIME limit was exceeded.
Action: Reduce the complexity of the update or query, or contact your database administrator for more information.
ORA-00050: operating system error occurred while obtaining an enqueue
Cause: Could not obtain the operating system resources necessary to cover an oracle enqueue. This is normally the result of an operating system user quota that is too low.
Action: Look up the operating system error in your system documentation and perform the needed action.
ORA-00051: timeout occurred while waiting for a resource
Cause: Usually due to a dead instance.
Action: Check for any dead, unrecovered instances and recover them.
ORA-00052: maximum number of enqueue resources (string) exceeded
Cause: Ran out of enqueue resources.
Action: Increase the value of the ENQUEUE_RESOURCES initialization parameter.
ORA-00053: maximum number of enqueues exceeded
Cause: Ran out of enqueue state objects.
Action: Increase the value of the ENQUEUES initialization parameter.
ORA-00054: resource busy and acquire with NOWAIT specified
Cause: Resource interested is busy.
Action: Retry if necessary.
ORA-00055: maximum number of DML locks exceeded
Cause: Ran out of DML lock state objects.
Action: Increase the value of the DML_LOCKS initialization parameter and warm start.
ORA-00056: DDL lock on object 'string.string' is already held in an incompatible mode
Cause: An attempt was made to acquire a DDL lock that is already locked.
Action: This happens if you attempt to drop a table that has parse locks on it.
ORA-00057: maximum number of temporary table locks exceeded
Cause: The number of temporary tables equals or exceeds the number of temporary table locks. Temporary tables are often created by large sorts.
Action: Increase the value of the TEMPORARY_TABLE_LOCKS initialization parameter and warm start.
ORA-00058: DB_BLOCK_SIZE must be string to mount this database (not string)
Cause: DB_BLOCK_SIZE initialization parameter is wrong for the database being mounted. It does not match the value used to create the database.
Action: Fix the value of the DB_BLOCK_SIZE parameter or mount a database that matches the value.
ORA-00059: maximum number of DB_FILES exceeded
Cause: The value of the DB_FILES initialization parameter was exceeded.
Action: Increase the value of the DB_FILES parameter and warm start.
ORA-00060: deadlock detected while waiting for resource
Cause: Transactions deadlocked one another while waiting for resources.
Action: Look at the trace file to see the transactions and resources involved. Retry if necessary.
ORA-00061: another instance has a different DML_LOCKS setting
Cause: The shared instance being started is using DML locks, and the running instances are not, or vice-versa.
Action: Ensure that all instances' INIT.ORA files specify the DML_LOCKS parameter as 0 or all as non-zero.
ORA-00062: DML full-table lock cannot be acquired; DML_LOCKS is 0
Cause: The instance was started with DML_LOCKS = 0, and the statement being executed needs a full-table lock (S, X, or SSX).
Action: Restart the instance with DML_LOCKS not equal to zero, and reexecute the statement.
ORA-00063: maximum number of LOG_FILES exceeded
Cause: LOG_FILES initialization parameter value exceeded
Action: Increase the value of the LOG_FILES initialization parameter and warm start. The parameter needs to be as large as the highest number of log files that currently exist rather than just the count of logs that exist.
ORA-00064: object is too large to allocate on this O/S (string,string)
Cause: An initialization parameter was set to a value that required allocating more contiguous space than can be allocated on this operating system.
Action: Reduce the value of the initialization parameter.
ORA-00065: initialization of FIXED_DATE failed
Cause: The FIXED_DATE string was not in date format yyyy-mm-dd:hh24:mi:ss.
Action: Make sure the initialization parameter is in the correct date format.
ORA-00066: LOG_FILES is string but needs to be string to be compatible
Cause: The maximum number of log files supported by this instance is not the same as for the other instances. All instances must be able to open all the files any instance can open.
Action: Change the value of the LOG_FILES initialization parameter to be compatible.
ORA-00067: invalid value string for parameter string; must be at least string
Cause: The value for the initialization parameter is invalid.
Action: Choose a value as indicated by the message.
ORA-00068: invalid value string for parameter string, must be between string and string
Cause: The value for the initialization parameter is invalid.
Action: Choose a value as indicated by the message.
ORA-00069: cannot acquire lock -- table locks disabled for string
Cause: A command was issued that tried to lock the table indicated in the message. Examples of commands that can lock tables are: LOCK TABLE, ALTER TABLE ... ADD (...), and so on.
Action: Use the ALTER TABLE ... ENABLE TABLE LOCK command, and retry the command.
ORA-00070: command string is not valid
Cause: An invalid debugger command was specified.
Action: Type HELP to see the list of available commands.
ORA-00071: process number must be between 1 and string
Cause: An invalid process number was specified.
Action: Specify a valid process number.
ORA-00072: process "string" is not active
Cause: An invalid process was specified.
Action: Specify a valid process.
ORA-00073: command string takes between string and string argument(s)
Cause: An incorrect number of arguments was specified.
Action: Specify the correct number of arguments. Type HELP to see the list of commands and their syntax.
ORA-00074: no process has been specified
Cause: No debug process has been specified.
Action: Specify a valid process.
ORA-00075: process "string" not found in this instance
Cause: The specified process was not logged on to the current instance.
Action: Specify a valid process.
ORA-00076: dump string not found
Cause: An attempt was made to invoke a dump that does not exist.
Action: Type DUMPLIST to see the list of available dumps.
ORA-00077: dump string is not valid
Cause: An attempt was made to invoke an invalid dump.
Action: Try another dump.
ORA-00078: cannot dump variables by name
Cause: An attempt was made to dump a variable by name on a system that does not support this feature.
Action: Try the PEEK command.
ORA-00079: variable string not found
Cause: An attempt was made to dump a variable that does not exist.
Action: Use a valid variable name.
ORA-00080: invalid global area specified by level string
Cause: An attempt was made to dump an invalid global area.
Action: Use level 1 for the PGA, 2 for the SGA, and 3 for the UGA. Use <extra + level> to dump global area <level> as well as <extra> bytes for every pointer; <extra> must be a multiple of 4.
ORA-00081: address range [string, string) is not readable
Cause: An attempt was made to read/write an invalid memory address range.
Action: Try another address or length.
ORA-00082: memory size of string is not in valid set of [1], [2], [4]stringstringstringstringstring
Cause: An invalid length was specified for the POKE command.
Action: Use a valid length (either 1, 2, 4, or possibly 8).
ORA-00083: warning: possibly corrupt SGA mapped
Cause: Even though there may be SGA corruptions, the SGA was mapped.
Action: Use the DUMPSGA command to dump the SGA.
ORA-00084: global area must be PGA, SGA, or UGA
Cause: An attempt was made to dump an invalid global area.
Action: Specify either PGA, SGA, or UGA.
ORA-00085: current call does not exist
Cause: An invalid attempt was made to dump the current call heap.
Action: Wait until the process starts a call.
ORA-00086: user call does not exist
Cause: An invalid attempt was made to dump the user call heap.
Action: Wait until the process starts a call.
ORA-00087: command cannot be executed on remote instance
Cause: Cluster database command issued for non cluster database ORADEBUG command.
Action: Issue the command without the cluster database syntax.
ORA-00088: command cannot be executed by shared server
Cause: Debug command issued on shared server.
Action: Reissue the command using a dedicated server.
ORA-00089: invalid instance number in ORADEBUG command
Cause: An invalid instance number was specified in a cluster database ORADEBUG command.
Action: Reissue the command with valid instance numbers.
ORA-00090: failed to allocate memory for cluster database ORADEBUG command
Cause: Could not allocate memory needed to execute cluster database oradebug.
Action: Reissue the command on each instance with single-instance oradebug.
ORA-00091: LARGE_POOL_SIZE must be at least string
Cause: The value of LARGE_POOL_SIZE is below the minimum size.
Action: Increase the value of LARGE_POOL_SIZE past the minimum size.
ORA-00092: LARGE_POOL_SIZE must be greater than LARGE_POOL_MIN_ALLOC
Cause: The value of LARGE_POOL_SIZE is less than the value of LARGE_POOL_MIN_ALLOC.
Action: Increase the value of LARGE_POOL_SIZE past the value of LARGE_POOL_MIN_ALLOC.
ORA-00093: %s must be between string and string
Cause: The parameter value is not in a valid range.
Action: Modify the parameter value to be within the specified range.
ORA-00094: %s requires an integer value
Cause: The parameter value is not an integer.
Action: Modify the parameter value to be an integer.
ORA-00096: invalid value string for parameter string, must be from among string
Cause: The value for the initialization parameter is invalid.
Action: Choose a value as indicated by the message.
ORA-00097: use of Oracle SQL feature not in SQL92 string Level
Cause: Usage of Oracle's SQL extensions.
Action: none
ORA-00099: timed out while waiting for resource, potential PDML deadlock
Cause: The resource needed by the transaction was busy. The PDML transaction could not acquire the resource within the specified amount of time. This indicates potential deadlock involving this PDML transaction and other transactions currently running in the system.
Action: Increase the the value of the PARALLEL_TRANSACTION_RESOURCE_TIMEOUT parameter; then retry the operation.
ORA-00100: no data found
Cause: An application made reference to unknown or inaccessible data.
Action: Handle this condition within the application or make appropriate modifications to the application code. NOTE: If the application uses Oracle-mode SQL instead of ANSI-mode SQL, ORA-01403 will be generated instead of ORA-00100.
ORA-00101: invalid specification for system parameter DISPATCHERS
Cause: The syntax for the DISPATCHERS parameter is incorrect.
Action: Refer to the manual for correct syntax.
ORA-00102: network protocol string cannot be used by dispatchers
Cause: The network specified in DISPATCHERS does not have the functionality required by the dispatchers.
Action: Refer to the manual on network protocols supported by the dispatchers.
ORA-00103: invalid network protocol; reserved for use by dispatchers
Cause: The network specified in the SQL*Net connect string is reserved for use by the dispatchers.
Action: Specify other network protocols in the connection string.
ORA-00104: deadlock detected; all public servers blocked waiting for resources
Cause: All available public servers are servicing requests that require resources locked by a client which is unable to get a public server to release the resources.
Action: Increase the limit for the system parameter MAX_SHARED_SERVERS as the system will automaticaly start up new servers to break the deadlock until the number of servers reaches the value specified in MAX_SHARED_SERVERS.
ORA-00105: too many dispatcher configurations
Cause: Too many dispatcher configurations have been specified. No more can be added.
Action: Consolidate the dispatcher configurations if possible.
ORA-00106: cannot startup/shutdown database when connected to a dispatcher
Cause: An attempt was made to startup/shutdown database when connected to a shared server via a dispatcher.
Action: Re-connect as user INTERNAL without going through the dispatcher. For most cases, this can be done by connect to INTERNAL without specifying a network connect string.
ORA-00107: failed to connect to ORACLE listener process
Cause: Most likely due to the fact that ORACLE listener has not been started.
Action: Start ORACLE listener if it has not been started. Or else contact your ORACLE representative.
ORA-00108: failed to set up dispatcher to accept connection asynchronously
Cause: Most likely due to the fact that the network protocol used by the the dispatcher does not support aynchronous operations.
Action: Contact your ORACLE representative.
ORA-00109: invalid value for attribute string: string
Cause: The value specified for the attribute was incorrect.
Action: Refer to the manual for the proper values.
ORA-00110: invalid value string for attribute string, must be between string and string
Cause: The value specified for the attribute was incorrect.
Action: Specify a value within the range allowed.
ORA-00111: invalid attribute string
Cause: The specified attribute was not recognized.
Action: Refer to the manual for the proper keyword to use to specify a dispatcher attribute.
ORA-00112: value of string is null
Cause: The attribute was specified with no value.
Action: Specify a non-null value.
ORA-00113: protocol name string is too long
Cause: A protocol name specified in the DISPATCHERS system parameter is too long.
Action: Use a valid protocol name for the DISPATCHERS value.
ORA-00114: missing value for system parameter SERVICE_NAMES
Cause: No value was specified for the SERVICE_NAMES system parameter, nor for the DB_NAME parameter.
Action: Add an SERVICE_NAMES or DB_NAME definition to the INIT.ORA file. By default, SERVICE_NAMES is the value of DB_NAME unless SERVICE_NAMES is explicitly specified.
ORA-00115: connection refused; dispatcher connection table is full
Cause: A connection request was refused by a dispatcher because the dispatcher cannot support any more connections.
Action: Connect to a different dispatcher, or use a dedicated server.
ORA-00116: SERVICE_NAMES name is too long
Cause: A service name specified in the SERVICE_NAMES system parameter is too long.
Action: Use a shorter name in the SERVICE_NAMES value (<= 255 chars).
ORA-00117: PROTOCOL, ADDRESS or DESCRIPTION must be specified
Cause: PROTOCOL, ADDRESS or DESCRIPTION was not specified.
Action: Use one of the attributes: PROTOCOL, ADDRESS or DESCRIPTION to specify the listening address for dispatchers.
ORA-00118: Only one of PROTOCOL, ADDRESS or DESCRIPTION may be specified
Cause: More than one of PROTOCOL, ADDRESS or DESCRIPTION was specified.
Action: Use only one of the attributes: PROTOCOL, ADDRESS or DESCRIPTION to specify the listening address for dispatchers.
ORA-00119: invalid specification for system parameter string
Cause: The syntax for the specified parameter is incorrect.
Action: Refer to the Oracle Reference Manual for the correct syntax.
ORA-00122: cannot initialize network configuration
Cause: ORACLE could not initialize SQL*Net version 2.
Action: Check the error stack for detailed information.
ORA-00123: idle public server terminating
Cause: Too many idle servers were waiting on the common queue.
Action: This error is used internally, no action is required.
ORA-00125: connection refused; invalid presentation
Cause: The PRESENTATION in the CONNECT_DATA of the TNS address DESCRIPTION is not correct or is not supported.
Action: Correct the PRESENTATION specified in the TNS address.
ORA-00126: connection refused; invalid duplicity
Cause: The DUPLICITY in the CONNECT_DATA of the TNS address DESCRIPTION is not correct or is not supported.
Action: Correct the DUPLICITY specified in the TNS address.
ORA-00127: dispatcher string does not exist
Cause: There is currently no dispatcher running with the specified name.
Action: Retry with a name of the form "D###" denoting an existing dispatcher process.
ORA-00128: this command requires a dispatcher name
Cause: Wrong syntax for ALTER SYSTEM SHUTDOWN
Action: Use correct syntax: ALTER SYSTEM SHUTDOWN [ IMMEDIATE ] 'dispatcher name'
ORA-00129: listener address validation failed 'string'
Cause: An error was encountered while validating the listener address.
Action: Resolve error or contact your ORACLE representative.
ORA-00130: invalid listener address 'string'
Cause: The listener address specification is not valid.
Action: Make sure that all fields in the listener address (protocol, port, host, key, ...) are correct.
ORA-00131: network protocol does not support registration 'string'
Cause: The specified protocol does not support async notification.
Action: Refer to the manual for information on supported network protocols.
ORA-00132: syntax error or unresolved network name 'string'
Cause: Listener address has syntax error or cannot be resolved.
Action: If a network name is specified, check that it corresponds to an entry in TNSNAMES.ORA or other address repository as configured for your system. Make sure that the entry is syntactically correct.
ORA-00133: value of string is too long
Cause: The value specified for the attribute was too long.
Action: Use shorter names and keywords or remove unneeded blanks.
ORA-00134: invalid DISPATCHERS specification #string
Cause: The syntax for the n-th DISPATCHERS specification was incorrect.
Action: Refer to the Oracle Reference Manual for the correct syntax.
ORA-00150: duplicate transaction ID
Cause: Attempted to start a new transaction with an ID already in use by an existing transaction.
Action: Check your application.
ORA-00151: invalid transaction ID
Cause: The specified transaction ID does not correspond to an existing valid transaction.
Action: Check your application.
ORA-00152: current session does not match requested session
Cause: The current session is not the same as the session that was passed into a upixado() call.
Action: Check your application.
ORA-00153: internal error in XA library
Cause: The XA library could not access thread-specific pointers.
Action: Contact customer support.
ORA-00154: protocol error in transaction monitor
Cause: The transaction monitor returned TMJOIN on an AX_REG call but the transaction was locally suspended.
Action: Contact the transaction monitor customer support.
ORA-00155: cannot perform work outside of global transaction
Cause: The application tried to perform some work on either an Oracle 7.3 server or an Oracle8 server with local transactions disabled while outside of a global transaction.
Action: Check if the application is connected to an Oracle 7.3 server. The Transaction monitor must not return a NULL XID on an AX_REG call when the resource manager is Oracle 7.3. If the application is connected to an Oracle8 server, either set nolocal=f in the xa_open string or start a global transaction prior to attempting the work.
ORA-00160: global transaction length string is greater than maximum (string)
Cause: An external global transaction ID with a too large length field was passed in.
Action: Report the problem to your external transaction coordinator vendor.
ORA-00161: transaction branch length string is illegal (maximum allowed string)
Cause: An external transaction branch ID with a length either too large or 0 was passed in.
Action: Report the problem to your external transaction coordinator vendor.
ORA-00162: external dbid length string is greater than maximum (string)
Cause: An external database name with too large a length field was passed in.
Action: Report the problem to your external transaction coordinator vendor.
ORA-00163: internal database name length string is greater than maximum (string)
Cause: An internal database name with a too large length field was passed in.
Action: Report the problem to your external transaction coordinator vendor.
ORA-00164: distributed autonomous transaction disallowed within migratable distributed transaction
Cause: A request was made by the application to start a distributed autonomous transaction when the application was in a migratable distributed transaction.
Action: Roll back or commit the current distributed transaction first.
ORA-00165: migratable distributed autonomous transaction with remote operation is not allowed
Cause: A request was made by the application to start a migratable distributed autonomous transaction with remote operation.
Action: none
ORA-00166: remote/local nesting level is too deep
Cause: Too many remote table operations required a reverse trip back to the local site, for example to execute a local function on a remote table.
Action: Rearrange the query or co-locate the functions with the tables.
ORA-00200: controlfile could not be created
Cause: It was not possible to create the controlfile.
Action: Check that there is sufficient disk space and no conflicts in filenames and try to create the controlfile again.
ORA-00201: controlfile version string incompatible with ORACLE version string
Cause: The controlfile was created by incompatible software.
Action: Either restart with a compatible software release or use CREATE CONTROLFILE to create a new controlfile that is compatible with this release.
ORA-00202: controlfile: 'string'
Cause: This message reports the name file involved in other messages.
Action: See associated error messages for a description of the problem.
ORA-00203: using the wrong controlfiles
Cause: The mount ID in the controlfile is not the same as the mount ID in the controlfile used by the first instance to mount this database. The controlfiles are for the same database but they are not the same files. Most likely one instance is using a backup controlfile.
Action: Check that the correct controlfiles were specified.
ORA-00204: error in reading (block string, # blocks string) of controlfile
Cause: A disk I/O failure was detected on reading the controlfile.
Action: Check if the disk is online, if it is not, bring it online and try a warm start again. If it is online, then you need to recover the disk.
ORA-00205: error in identifying controlfile, check alert log for more info
Cause: The system could not find a controlfile of the specified name and size.
Action: Check that ALL controlfiles are online and that they are the same files that the system created at cold start time.
ORA-00206: error in writing (block string, # blocks string) of controlfile
Cause: A disk I/O failure was detected on writing the controlfile.
Action: Check if the disk is online, if it is not, bring it online and try a warm start again. If it is online, then you need to recover the disk.
ORA-00207: controlfiles are not for the same database
Cause: The database ID in the controlfile is not the same as the database ID in the controlfile used by the first instance to mount this database. Most likely one of the mounts used the wrong controlfile or there are two databases with the same name.
Action: Check that the controlfile is for the correct database and is not an old version.
ORA-00208: number of controlfile names exceeds limit of string
Cause: An attempt was made to use more controlfiles than Oracle supports.
Action: Shut down Oracle. Reduce the number of controlfiles specified in the CONTROL_FILES parameter in the initialization parameter file, and restart Oracle. Delete usused files.
ORA-00209: control file blocksize mismatch, check alert log for more info
Cause: The block size in the control file header does not match the size specified in the DB_BLOCK_SIZE parameter.
Action: Look at the alert log for more information.
ORA-00210: cannot open the specified controlfile
Cause: Cannot open the controlfile.
Action: Check to make sure the controlfile exists and is not locked by some other program.
ORA-00211: controlfile does not match previous controlfiles
Cause: A controlfile was specified that belongs to another database.
Action: Find and install the correct controlfile.
ORA-00212: block size string below minimum required size of string bytes
Cause: The block size specified was too small. Space for the system overhead is required.
Action: Specify a larger block size and retry the operation.
ORA-00213: cannot reuse controlfile; old file size string, string required
Cause: To reuse a controlfile, it must be the same size as the one previously used.
Action: Either do not specify REUSE, or specify a matching combination of MAXDATAFILES, MAXLOGFILES, MAXLOGMEMBERS, MAXLOGHISTORY, and MAXINSTANCES clauses in the CREATE DATABASE or CREATE CONTROLFILE statement.
ORA-00214: controlfile 'string' version string inconsistent with file 'string' version string
Cause: An inconsistent set of controlfiles, datafiles/logfiles, and redo files was used.
Action: Use a consistant set of controlfiles, datafiles/logfiles, and redo log files. That is, all the files must be for the same database and from the same time period.
ORA-00215: must be at least one controlfile
Cause: No controlfile is specified or the controlfile specified does not exist.
Action: Specify at least one valid controlfile and retry the operation.
ORA-00216: controlfile could not be resized for migration from 8.0.2
Cause: Controlfiles created by release 8.0.2 were missing some records. These records are automatically added by resizing the contolfile when attempting to run a later release. The resize failed.
Action: Look in the alert log for the reason that the resize failed. If it can be fixed by giving the controlfile more space, then do that. Otherwise, use the CREATE CONTROLFILE script dumpped to the trace file to create a new controlfile.
ORA-00217: controlfile could not be resized for migration from 9.0.1
Cause: Controlfiles created by release 9.0.1 were missing some records. These records are automatically added by resizing the contolfile when attempting to run a later release. The resize failed.
Action: Look in the alert log for the reason the resize failed. If it can be fixed by giving the controlfile more space, then do that. Otherwise, use the CREATE CONTROLFILE script dumpped to the trace file to create a new controlfile.
ORA-00218: block size string of controlfile 'string' does not match DB_BLOCK_SIZE (string)
Cause: The block size as stored in the controlfile header is different from the value of the initialization parameter DB_BLOCK_SIZE. This might be due to an incorrect setting of DB_BLOCK_SIZE, or else might indicate that the controlfile has either been corrupted or belongs to a different database.
Action: Restore a good copy of the controlfile. If the controlfile is known to be clean set the DB_BLOCK_SIZE to match controlfile headers block size value.
ORA-00219: required controlfile size string exceeds maximum allowable size string
Cause: An invocation of CREATE DATABASE, CREATE CONTROLFILE, cfileCalcSizeList, or cfileCalcSizeArray was executed specifying a combination of parameters that would require the controlfile size in blocks to exceed the maximum allowable value.
Action: In the case of CREATE DATABASE or CREATE CONTROLFILE, use a different combination of MAXDATAFILES, MAXLOGFILES, MAXLOGMEMBERS, MAXLOGHISTORY, and MAXINSTANCES clauses. In the case of cfileCalcSizeList() or cfileCalcSizeArray(), use a different combination of record type counts.
ORA-00220: controlfile not mounted by first instance, check alert log for more info
Cause: The specified controlfile has a different mount ID than the other controlfiles that are being mounted. This means that the first instance to mount the database did not use this controlfile.
Action: Find and install the correct controlfile.
ORA-00221: error on write to controlfile
Cause: An error occurred when writing to one or more of the controlfiles.
Action: See accompanying messages.
ORA-00222: operation would reuse name of a currently mounted controlfile
Cause: The filename supplied as a parameter to the ALTER DATABASE BACKUP CONTROLFILE command or to cfileSetSnapshotName matches the name of the specified currently mounted controlfile.
Action: Retry the operation with a different filename.
ORA-00223: convert file is invalid or incorrect version
Cause: An Oracle7 to Oracle8 convert file contains invalid data or was created with an different version of the migration utility. This error can also be caused by incorrect ORACLE_HOME environment variable when ALTER DATABASE CONVERT command is issued.
Action: Use a correct version of the convert file or regenerate it with the migration utility. Make sure that the migration utility is the same version as the Oracle8 RDBMS executable and that the ORACLE_HOME environment variable is properly set.
ORA-00224: controlfile resize attempted with illegal record type (string)
Cause: An attempt was made to expand or shrink the controlfile by calling cfileResizeSection using an invalid value for the RECORD_TYPE parameter.
Action: Use a value for the RECORD_TYPE parameter that specifies a valid record type other than type 0 (valid range is 1-16).
ORA-00225: expected size string of controlfile differs from actual size string
Cause: The expected size of the controlfile as stored in its header was different than the actual operating system file size. This usually indicates that the controlfile was corrupted.
Action: Restore a good copy of the controlfile.
ORA-00226: operation disallowed while alternate controlfile open
Cause: The attempted operation could not be executed at this time because this process had an alternate controlfile open for fixed table access.
Action: Retry the operation after calling cfileUseCurrent.
ORA-00227: corrupt block detected in controlfile: (block string, # blocks string)
Cause: A block header corruption or checksum error was detected on reading the controlfile.
Action: Use the CREATE CONTROLFILE or RECOVER DATABASE USING BACKUP CONTROLFILE command.
ORA-00228: length of alternate controlfile name exceeds maximum of string
Cause: The specified filename, which was supplied as a parameter to cfileSetSnapshotName or cfileUseCopy, exceeds the maximum filename length for this operating system.
Action: Retry the operation with a shorter filename.
ORA-00229: operation disallowed: already hold snapshot controlfile enqueue
Cause: The attempted operation cannot be executed at this time because this process currently holds the snapshot controlfile enqueue.
Action: Retry the operation after calling cfileUseCurrent to release the snapshot controlfile enqueue.
ORA-00230: operation disallowed: snapshot controlfile enqueue unavailable
Cause: The attempted operation cannot be executed at this time because another process currently holds the snapshot controlfile enqueue.
Action: Retry the operation after the concurrent operation that is holding the snapshot controlfile enqueue terminates.
ORA-00231: snapshot controlfile has not been named
Cause: During an invocation of cfileMakeAndUseSnapshot or cfileUseSnapshot it was detected that no filename for the snapshot controlfile had previously been specified.
Action: Specify a name for the snapshot controlfile by calling cfileSetSnapshotName.
ORA-00232: snapshot controlfile is nonexistent, corrupt, or unreadable
Cause: The snapshot controlfile was found to be nonexistent, corrupt, or unreadable during an invocation of cfileUseSnapshot.
Action: Call cfileMakeAndUseSnapshot again (or for the first time).
ORA-00233: copy controlfile is corrupt or unreadable
Cause: The specified copy controlfile was found to be corrupt or unreadable during an invocation of cfileUseCopy.
Action: Before retrying cfileUseCopy, use the ALTER DATABASE BACKUP CONTROLFILE command and specify the same filename that was specified for cfileUseCopy.
ORA-00234: error in identifying or opening snapshot or copy controlfile
Cause: A snapshot or copy controlfile of the specified name could not be found or opened during an invocation of cfileUseSnapshot, cfileMakeAndUseSnapshot, or cfileUseCopy.
Action: Re-create the snapshot or copy controlfile using cfileMakeAndUseSnapshot or ALTER DATABASE BACKUP CONTROLFILE, respectively.
ORA-00235: controlfile fixed table inconsistent due to concurrent update
Cause: Concurrent update activity on a controlfile caused a query on a controlfile fixed table to read inconsistent information.
Action: Retry the operation.
ORA-00236: snapshot operation disallowed: mounted controlfile is a backup
Cause: Attempting to invoke cfileSetSnapshotName, cfileMakeAndUseSnapshot, or cfileUseSnapshot when the currently mounted controlfile is a backup controlfile.
Action: Mount a current controlfile and retry the operation.
ORA-00237: snapshot operation disallowed: controlfile newly created
Cause: An attempt to invoke cfileMakeAndUseSnapshot with a currently mounted controlfile that was newly created with CREATE CONTROLFILE was made.
Action: Mount a current controlfile and retry the operation.
ORA-00238: operation would reuse a filename that is part of the database
Cause: The filename supplied as a parameter to the ALTER DATABASE BACKUP CONTROLFILE command or to cfileSetSnapshotName matches the name of a file that is currently part of the database.
Action: Retry the operation with a different filename.
ORA-00250: archiver not started
Cause: An attempt was made to stop automatic archiving, but the archiver process was not running.
Action: No action required.
ORA-00251: LOG_ARCHIVE_DUPLEX_DEST cannot be the same destination as string string
Cause: The destination specified by the LOG_ARCHIVE_DUPLEX_DEST parameter is the same as the destination specified by an ALTER SYSTEM ARCHIVE LOG START TO command.
Action: Specify a different destination for parameter LOG_ARCHIVE_DUPLEX_DEST, or specify a different destination with the ALTER SYSTEM command.
ORA-00252: log string of thread string is empty, cannot archive
Cause: A log must be used for redo generation before it can be archived. The specified redo log was not been used since it was introduced to the database. However it is possible that instance death during a log switch left the log empty.
Action: Empty logs do not need to be archived. Do not attempt to archive the redo log file.
ORA-00253: character limit string exceeded by archive destination string string
Cause: The destination specified by an ALTER SYSTEM ARCHIVE LOG START TO command was too long.
Action: Retry the ALTER SYSTEM command using a string shorter than the limit specified in the error message.
ORA-00254: error in archive control string 'string'
Cause: The specified archive log location is invalid in the archive command or the LOG_ARCHIVE_DEST initialization parameter.
Action: Check the archive string used to make sure it refers to a valid online device.
ORA-00255: error archiving log string of thread string, sequence # string
Cause: An error occurred during archiving.
Action: Check the accompanying message stack for more detailed information. If the online log is corrupted, then the log can be cleared using the UNARCHIVED option. This will make any existing backups useless for recovery to any time after the log was created, but will allow the database to generate redo.
ORA-00256: cannot translate archive destination string string
Cause: The destination specified by an ALTER SYSTEM ARCHIVE LOG START TO command could not be translated.
Action: Check the accompanying message stack for more detailed information. Then, retry the ALTER SYSTEM command using a different string.
ORA-00257: archiver error. Connect internal only, until freed.
Cause: The archiver process received an error while trying to archive a redo log. If the problem is not resolved soon, the database will stop executing transactions. The most likely cause of this message is the destination device is out of space to store the redo log file.
Action: Check archiver trace file for a detailed description of the problem. Also verify that the device specified in the initialization parameter ARCHIVE_LOG_DEST is set up properly for archiving.
ORA-00258: manual archiving in NOARCHIVELOG mode must identify log
Cause: The database is in NOARCHIVELOG mode and a command to manually archive a log did not specify the log explicitly by sequence number, group number or filename.
Action: Specify log by filename, by group number or by thread and sequence number.
ORA-00259: log string of open instance string (thread string) is the current log, cannot archive
Cause: An attempt was made to archive the current log of an open thread. This is not allowed because the redo log file may still be in use for the generation of redo entries.
Action: Force a log switch in the instance where the thread is open. If no instances are open, open the database so that instance recovery can recover the thread.
ORA-00260: cannot find online log sequence string for thread string
Cause: The log sequence number supplied to the archival command does not match any of the online logs for the thread. The log might have been reused for another sequence number, it might have been dropped, the sequence number might be greater than the current log sequence number, or the thread might not have any logs.
Action: Check the ARCHIVE statement, then specify a valid log sequence number. Specify a valid log sequence number.
ORA-00261: log string of thread string is being archived or modified
Cause: The log is either being archived by another process or an administrative command is modifying the log. Operations that modify the log include clearing, adding a member, dropping a member, renaming a member, and dropping the log.
Action: Wait for the current operation to complete and try again.
ORA-00262: current log string of closed thread string cannot switch
Cause: The log cannot be cleared or manually archived because it is the current log of a closed thread, and it is not possible to switch logs so another log is current. All other logs for the thread need to be archived, or cleared, and cannot be reused.
Action: Archive another log in the same thread first, or complete the clearing. See attached errors for the reason the switch cannot be completed.
ORA-00263: there are no logs that need archiving for thread string
Cause: An attempt was made to manually archive the unarchived logs in this thread but no logs needed archiving.
Action: No action required.
ORA-00264: no recovery required
Cause: An attempt was made to perform media recovery on files that do not // need any type of recovery.
Action: Do not attempt to perform media recovery on the selected files. Check to see that the filenames were entered properly. If not, retry the command with the proper filenames.
ORA-00265: instance recovery required, cannot set ARCHIVELOG mode
Cause: The database either crashed or was shutdown with the ABORT option. Media recovery cannot be enabled because the online logs may not be sufficient to recover the current datafiles.
Action: Open the database and then enter the SHUTDOWN command with the NORMAL or IMMEDIATE option.
ORA-00266: name of archived log file needed
Cause: During media recovery, the name of an archived redo log file was requested, but no name was entered.
Action: Mount the correct redo log file and enter its name when it is requested.
ORA-00267: name of archived log file not needed
Cause: During media recovery, the name of an archived redo log file was entered, but no name was requested.
Action: Continue media recovery, but do not enter a new log name.
ORA-00268: specified log file does not exist 'string'
Cause: The given redo log file does not exist.
Action: Check the spelling and capitalization of the filename and retry the command.
ORA-00269: specified log file is part of thread string not string
Cause: The given redo log file is not part of the given thread
Action: Check that the thread of the redo log file matches the thread on the command line. If not, use a redo log file from the appropriate thread. Retry the command after correcting the error.
ORA-00270: error creating archive log string
Cause: An error was encountered when either creating or opening the destination file for archiving.
Action: Check that the archive destination is valid and that there is sufficient space on the destination device.
ORA-00271: there are no logs that need archiving
Cause: An attempt was made to archive the unarchived redo log files manually, but there are no files that need to be archived.
Action: No action required.
ORA-00272: error writing archive log string
Cause: An I/O error occurred while archiving a redo log file.
Action: Check that the output device is still available and correct any device errors that may have occurred. Also, make certain that sufficient space for archiving is available on the output device.
ORA-00273: media recovery of direct load data that was not logged
Cause: A media recovery session encountered a table that was loaded by the direct loader without logging any redo information. Some or all of the blocks in this table are now marked as corrupt.
Action: The table must be dropped or truncated so that the corrupted blocks can be reused. If a more recent backup of the file is available, try to recover this file to eliminate this error.
ORA-00274: illegal recovery option string
Cause: An illegal option was specified for a recovery command.
Action: Correct the syntax and retry the command.
ORA-00275: media recovery has already been started
Cause: An attempt was made to start a second media recovery operation in the same session.
Action: Complete or cancel the first media recovery session or start another session to perform media recovery.
ORA-00276: CHANGE keyword specified but no change number given
Cause: The CHANGE keyword was specified on the command line, but no change number was given.
Action: Retry the command using a valid change number after the CHANGE keyword.
ORA-00277: illegal option to the UNTIL recovery flag string
Cause: Only CANCEL, CHANGE and TIME can be used with the UNTIL keyword.
Action: Correct the syntax.
ORA-00278: log file 'string' no longer needed for this recovery
Cause: The specified redo log file is no longer needed for the current recovery.
Action: No action required. The archived redo log file may be removed from its current location to conserve disk space, if needed. However, the redo log file may still be required for another recovery session in the future.
ORA-00279: change string generated at string needed for thread string
Cause: The requested log is required to proceed with recovery.
Action: Please supply the requested log with "ALTER DATABASE RECOVER LOGFILE <file_name>" or cancel recovery with "ALTER DATABASE RECOVER CANCEL".
ORA-00280: change string for thread string is in sequence #string
Cause: This message helps to locate the redo log file with the specified change number requested by other messages.
Action: Use the information provided in this message to specify the required archived redo log files for other errors.
ORA-00281: media recovery may not be performed using dispatcher
Cause: An attempt was made to use a dispatcher process for media recovery. Memory requirements disallow this recovery method.
Action: Connect to the instance via a dedicated server process to perform media recovery.
ORA-00282: UPI string call not supported, use ALTER DATABASE RECOVER
Cause: The given UPI call is no longer supported.
Action: Use the ALTER DATABASE RECOVER command for all recovery actions.
ORA-00283: recovery session canceled due to errors
Cause: An error during recovery was determined to be fatal enough to end the current recovery session.
Action: More specific messages will accompany this message. Refer to the other messages for the appropriate action.
ORA-00284: recovery session still in progress
Cause: An error during recovery was determined to be minor enough to allow the current recovery session to continue.
Action: More specific messages will accompany this message. Refer to the other messages for the appropriate action.
ORA-00285: TIME not given as a string constant
Cause: UNTIL TIME was not followed by a string constant for the time.
Action: Enter the time enclosed in single quotation marks.
ORA-00286: no members available, or no member contains valid data
Cause: None of the members of a redo log file group are available, or the available members do not contain complete data.
Action: If a member is temporarily offline, attempt to make it available. Make sure that the correct filenames are being used, especially if the redo log file is being accessed from a remote location.
ORA-00287: specified change number string not found in thread string
Cause: The given change number does not appear in any of the online redo logs for the given thread.
Action: Check the statement to make certain a valid change number is given. Perhaps try to use the NEXT option for archiving logs.
ORA-00288: to continue recovery type ALTER DATABASE RECOVER CONTINUE
Cause: During media recovery, a new log is not required but the continuation command is necessary to do a checkpoint and report errors.
Action: Type ALTER DATABASE RECOVER CONTINUE and recovery will resume.
ORA-00289: suggestion : string
Cause: This message reports the next redo log filename that is needed, according to the initialization parameters LOG_ARCHIVE_DEST and LOG_ARCHIVE_FORMAT. This message assumes that LOG_ARCHIVE_DEST and LOG_ARCHIVE_FORMAT are the same now as when the required redo log file was archived.
Action: Consider using this filename for the next log needed for recovery.
ORA-00290: operating system archival error occurred. See error below
Cause: While attempting to archive to a redo log file, the server encountered an unexpected operating system error.
Action: Correct the operating system error given in the messages and retry the operation. See also your operating system-specific Oracle documentation.
ORA-00291: numeric value required for PARALLEL option
Cause: A recovery command was specified incorrectly. The PARALLEL option must be followed by a numeric argument that specifies the degree of parallelism.
Action: Re-enter the command with a numeric argument specifying the degree of parallelism desired.
ORA-00292: parallel recovery feature not installed
Cause: A parallel recovery was requested when the parallel recovery option is not installed.
Action: Delete the PARALLEL clause from the RECOVER command. Also, delete the RECOVERY_PARALLELISM parameter in the initialization file.
ORA-00293: controlfile out of sync with redo log
Cause: The redo log file and controlfile are out of sync because a non-current controle file was specified when the instance was started.
Action: Retry the RECOVER command using the current controlfile, or retry the RECOVER command using the USING BACKUP CONTROLFILE clause.
ORA-00294: invalid archivelog format specifier 'string'
Cause: An invalid format specifier was found in the LOG_ARCHIVE_FORMAT initialization parameter. The only characters permitted following the % symbol are s, S, t, and T.
Action: Correct the initialization file and re-start the instance.
ORA-00295: datafile/tempfile number string is invalid, must be between 1 and string
Cause: An invalid file number was specified.
Action: Specify a valid datafile or tempfile number and retry the operation.
ORA-00296: maximum number of files (string) exceeded for RECOVER DATAFILE LIST
Cause: The RECOVER DATAFILE LIST command specified more datafiles than are allowed by the DB_FILES initialization parameter. This error occurs when doing recovery with Recovery Manager, and the instance has been started with a DB_FILES parameter specifying fewer datafiles than recovery manager needs to recover to satisfy the user's RECOVER command.
Action: Re-start the instance with a higher value for DB_FILES.
ORA-00297: must specify RECOVER DATAFILE LIST before RECOVER DATAFILE START
Cause: The RECOVER DATAFILE START command was issued, but no RECOVER DATAFILE LIST commands had been issued. This only happens when doing recovery with Recovery Manager, and is an internal error in Recovery Manager, because Recovery Manager should always issue RECOVER DATAFILE LIST before RECOVER DATAFILE START.
Action: Contact customer support
ORA-00298: Missing or invalid attribute value
Cause: A non-zero integer value is required when the following keyword attributes are specified: TIMEOUT, EXPIRE, DELAY, NEXT
Action: Correct the syntax and retry the command.
ORA-00299: must use file-level media recovery on data file string
Cause: The control file does not contain an entry for this file, so block media recovery cannot be done.
Action: Restore the data file and perform file-level media recovery.
ORA-00300: illegal redo log block size string specified - exceeds limit of string
Cause: The specified block size of the redo log is greater than the maximum block size for the operating system.
Action: Create the redo log on a device with a smaller block size
ORA-00301: error in adding log file 'string' - file cannot be created
Cause: The creation of the redo log file failed
Action: Check: 1) there is enough storage space on the device 2) the name of the file is valid 3) the device is online 4) an IO error occurred Also, it is possible REUSE was specified on the command line and a file of the incorrect size exists. Either do not specify REUSE or use a file of the correct size.
ORA-00302: limit of string logs exceeded
Cause: The maximum number of redo log files has been exceeded. There is a limit, set at database creation, on the number of redo log files (typically 16).
Action: Use the CREATE CONTROLFILE command with a larger value for MAXLOGFILES.
ORA-00303: cannot process Parallel Redo
Cause: A redo log containing Parallel Redo has been detected. The current Oracle release cannot process this format of redo.
Action: Use a later release that supports Parallel Redo. to process this log.
ORA-00304: requested INSTANCE_NUMBER is busy
Cause: An instance tried to start by using a value of the initialization parameter INSTANCE_NUMBER that is already in use.
Action: Either a) specify another INSTANCE_NUMBER, b) shut down the running instance with this number c) wait for instance recovery to complete on the instance with this number.
ORA-00305: log string of thread string inconsistent; belongs to another database
Cause: The database ID in the redo log file does not match the database ID in the controlfile. This redo log file is not from the current database.
Action: Specify the correct redo log file, then retry the operation.
ORA-00306: limit of string instances in this database
Cause: Starting this instance would exceed the maximum number of instances allowed for this database. This message occurs only with STARTUP shared and multiple instances.
Action: You cannot start more than the lower of a) port-specific limit as to the number of instances b) the number of instances specified at create-database time
ORA-00307: requested INSTANCE_NUMBER out of range, maximum is string
Cause: The initialization parameter INSTANCE_NUMBER specified a number that was out of range.
Action: Change INSTANCE_NUMBER to a valid range and restart the instance. The minimum value is one and the maximum value is the lower of the operating system-specific maximum or the MAXINSTANCES option specified in the CREATE DATABASE statement. See also your operating system-specific Oracle
ORA-00308: cannot open archived log 'string'
Cause: The system cannot access a required archived redo log file.
Action: Check that the off line log exists, the storage device is online, and the archived file is in the correct location. Then attempt to continue recovery or restart the recovery session.
ORA-00309: log belongs to wrong database
Cause: The system cannot access the archived redo log because it belongs to another database.
Action: Specify the correct redo log file, then retry the operation.
ORA-00310: archived log contains sequence string; sequence string required
Cause: The archived log is out of sequence, probably because it is corrupted or the wrong redo log filename was specified
Action: Specify the correct redo log file; then retry the operation.
ORA-00311: cannot read header from archived log
Cause: An I/O error occurred when attempting to read the log file header from the specified archived redo log file.
Action: Other messages will accompany this message. See the associated messages for the appropriate action to take.
ORA-00312: online log string thread string: 'string'
Cause: This message reports the filename for details of another message.
Action: Other messages will accompany this message. See the associated messages for the appropriate action to take.
ORA-00313: open failed for members of log group string of thread string
Cause: The online log cannot be opened. May not be able to find file.
Action: See accompanying errors and make log available.
ORA-00314: log string of thread string, expected sequence# string doesn't match string
Cause: The online log is corrupted or is an old version.
Action: Find and install correct version of log or reset logs.
ORA-00315: log string of thread string, wrong thread # string in header
Cause: The online log is corrupted or is an old version.
Action: Find and install correct version of log or reset logs.
ORA-00316: log string of thread string, type string in header is not log file
Cause: The online log is corrupted or is an old version.
Action: Find and install correct version of log or reset logs.
ORA-00317: file type string in header is not log file
Cause: This is not an archived log file.
Action: Find the correct file and try again.
ORA-00318: log string of thread string, expected file size string doesn't match string
Cause: On header read the file size indicated in the control file did not match the file size contained in the log file.
Action: Restore correct file or reset logs.
ORA-00319: log string of thread string has incorrect log reset status
Cause: Check of log file header at database open found that an online log has log reset data that is different from the controlfile. The log is probably an incorrectly restored backup.
Action: Restore correct file or reset logs.
ORA-00320: cannot read file header from log string of thread string
Cause: The file is not available.
Action: Restore the log file.
ORA-00321: log string of thread string, cannot update log file header
Cause: Cannot write to the log file.
Action: Restore the access to the file.
ORA-00322: log string of thread string is not current copy
Cause: Check of log file header at database open found that an online log appears to be an incorrectly restored backup.
Action: Restore correct file or reset logs.
ORA-00323: Current log of thread string not useable and all others need archiving
Cause: Attempt to open thread failed because it is necessary to switch redo generation to another online log, but all the other logs need to be archived before they can be used.
Action: Archive the logs for the thread then retry open.
ORA-00324: log file 'string' translated name 'string' too long, string characters exceeds string limit
Cause: the translated name for a log file is too long.
Action: Choose a untranslated name that yields a shorter translated name.
ORA-00325: archived log for thread string, wrong thread # string in header
Cause: The archived log is corrupted or for another thread. Can not use the log for applying redo.
Action: Find correct archived log.
ORA-00326: log begins at change string, need earlier change string
Cause: The archived log supplied for recovery was generated after the log that is needed. Can not yet use the log for applying redo.
Action: Find correct archived log.
ORA-00327: log string of thread string, physical size string less than needed string
Cause: A log file has shrunk in size. This is likely to have been caused by operator or operating system error.
Action: Restore the log file from backup. If backup is not available, drop this log and re-create. If the database was shut down cleanly, no further action should be required; otherwise incomplete recovery may be required.
ORA-00328: archived log ends at change string, need later change string
Cause: The archived log supplied for recovery was generated before the log that is needed. Can not use the log for applying redo.
Action: Find correct archived log.
ORA-00329: archived log begins at change string, need change string
Cause: The archived log is not the correct log. An earlier log is needed.
Action: Restore the correct log file.
ORA-00330: archived log ends at change string, need change string
Cause: The archived log is not the correct log. A later log is needed.
Action: Restore the correct log file.
ORA-00331: log version string incompatible with ORACLE version string
Cause: The log was written by incompatible version of Oracle.
Action: Recover the database with the compatible software, shut it down cleanly, then restart with current software.
ORA-00332: archived log is too small - may be incompletely archived
Cause: The log is smaller than the space allocated in it. May be the result of a shutdown abort while it was being written by the archiver.
Action: Get a complete version of this log and use it for recovery. There should either be an online version of it or a copy that was successfully archived.
ORA-00333: redo log read error block string count string
Cause: An IO error occurred while reading the log described in the accompanying error.
Action: Restore accessibility to file, or get another copy of the file.
ORA-00334: archived log: 'string'
Cause: Reporting filename for details of another error
Action: See associated error messages
ORA-00335: online log string: No log with this number, log does not exist
Cause: Reporting filename for details of another error
Action: See associated error messages
ORA-00336: log file size string blocks is less than minimum string blocks
Cause: The log file size as specified in create database is too small.
Action: Increase the log file size.
ORA-00337: log file 'string' does not exist and no size specified
Cause: An attempt to add a log found neither an existing file nor a size for creating the file.
Action: Specify a size for the log file.
ORA-00338: log string of thread string is more recent than controlfile
Cause: The controlfile change sequence number in the log file is greater than the number in the controlfile. This implies that the wrong controlfile is being used. Note that repeatedly causing this error can make it stop happening without correcting the real problem. Every attempt to open the database will advance the controlfile change sequence number until it is great enough.
Action: Use the current controlfile or do backup controlfile recovery to make the controlfile current. Be sure to follow all restrictions on doing a backup controlfile recovery.
ORA-00339: archived log does not contain any redo
Cause: The archived log is not the correct log. It is a copy of a log file that has never been used for redo generation, or was an online log being prepared to be the current log.
Action: Restore the correct log file.
ORA-00340: IO error processing online log string of thread string
Cause: An IO error occurred on the named online log.
Action: Restore accessibility to file, or restore file from backup.
ORA-00341: log string of thread string, wrong log # string in header
Cause: The internal information in an online log file does not match the controlfile.
Action: Restore correct file or reset logs.
ORA-00342: archived log does not have expected resetlogs SCN string
Cause: Recovery was given a log that does not belong to current incarnation or one of the parent incarnation. There should be another log that contains the correct redo.
Action: Supply the correct log file.
ORA-00343: too many errors, log member closed
Cause: The maximum number of errors on this log member has been exceeded.
Action: Correct the underlying problem by referring to the other error messages found with this one.
ORA-00344: unable to re-create online log 'string'
Cause: An I/O failure occurred when attempting to re-create an online as part of either ALTER DATABASE OPEN RESETLOGS or ALTER DATABASE CLEAR LOGFILE command.
Action: Correct the file/device as indicated by accompanying errors.
ORA-00345: redo log write error block string count string
Cause: An IO error has occurred while writing the log
Action: Correct the cause of the error, and then restart the system. If the log is lost, apply media/incomplete recovery.
ORA-00346: log member marked as STALE
Cause: A log file member no longer is complete.
Action: Correct the underlying problem by referring to the other error messages found with this one.
ORA-00347: log string of thread string, expected block size string doesn't match string
Cause: On header read the blocksize indicated in the control file did not match the blocksize contained in the log file.
Action: Restore correct file or reset logs.
ORA-00348: single-process redo failure. Must abort instance
Cause: A failure occurred during a critical portion of the log code during single process operation. This error does not occur during normal multi-process operation.
Action: Shutdown abort and warmstart the database.
ORA-00349: failure obtaining block size for 'string'
Cause: The operating system was unable to determine the blocksize for the given filename.
Action: Consult the accompanying error message, and correct the device or specify another filename.
ORA-00350: log string of instance string (thread string) needs to be archived
Cause: The command cannot be done because the log has not been archived, and media recovery has been enabled.
Action: Archive the log or disable media recovery. If the command supports an UNARCHIVED option then it can be used. However this may result in making backups unuseable, and forcing the drop of some offline files.
ORA-00351: recover-to time invalid
Cause: The time specified in a recover-until statement must be after January 1st 1988.
Action: Specify a time after January 1st 1988.
ORA-00352: all logs for thread string need to be archived - cannot enable
Cause: Attempting to enable a thread with all logs needing to be archived, and media recovery has been enabled. There is no log that can be made the new current log for the thread.
Action: Archive a log for the thread or disable media recovery.
ORA-00353: log corruption near block string change string time string
Cause: Some type of redo log corruption has been discovered. This error describes the location of the corruption. Accompanying errors describe the type of corruption.
Action: Do recovery with a good version of the log or do incomplete recovery up to the indicated change or time.
ORA-00354: corrupt redo log block header
Cause: The block header on the redo block indicated by the accompanying error, is not reasonable.
Action: Do recovery with a good version of the log or do time based recovery up to the indicated time. If this happens when archiving, archiving of the problem log can be skipped by clearing the log with the UNARCHIVED option. This must be followed by a backup of every datafile to insure recoverability of the database.
ORA-00355: change numbers out of order
Cause: A change number found in the redo log is lower than a previously encountered change number. The log is corrupted in some way. The corruption may be at the earlier change or at this one.
Action: Do recovery with a good version of the log or do time based recovery up to the indicated time.
ORA-00356: inconsistent lengths in change description
Cause: A change record in the redo log contains lengths that do not add up to a consistent value. The log is corrupted in some way.
Action: Do recovery with a good version of the log or do time based recovery up to the indicated time.
ORA-00357: too many members specified for log file, the maximum is string
Cause: An add logfile or add logfile member command would result in a log with too many members. The number of members is set when the database is created.
Action: Use fewer log file members.
ORA-00358: Too many file members specified, the maximum is string
Cause: A create or alter statement specified too many members in a parenthesised file list.
Action: Specify a number of file members that is within the port-defined limit.
ORA-00359: logfile group string does not exist
Cause: An add logfile member or drop logfile request specified a logfile group number that does not exist.
Action: Check the configuration of the log files and reissue the command.
ORA-00360: not a logfile member: string
Cause: A filename was given to drop logfile member that is not a part of the database, or which is a data file.
Action: Supply a valid logfile member name.
ORA-00361: cannot remove last log member string for group string
Cause: An attempt has been made to remove the last member of a log file group.
Action: If desired, delete the entire log, by using DROP LOGFILE.
ORA-00362: member is required to form a valid logfile in group string
Cause: A request to drop a logfile member was denied because it would remove data required to form a complete logfile.
Action: If desired, delete the entire log (after archiving if required), by using DROP LOGFILE;
ORA-00363: log is not the archived version
Cause: d by failing to list the current log of an enabled thread in a CREATE CONTROLFILE command.
Action: Find the archived version of the log and supply its name. If this is media recovery immediately following a CREATE CONTROLFILE, be sure the current log for this thread was included.
ORA-00364: cannot write header to new log member
Cause: An i/o error occurred when attempting to write the header to a log member that is being added to an existing group.
Action: See accompanying errors. Fix problem or use another file.
ORA-00365: the specified log is not the correct next log
Cause: The specified log failed to pass checks to ensure it corresponds to the log that was just applied. This is probably the result of using a log that was generated against a cold backup image of the database.
Action: Find the log that was generated by this copy of the database and give that filename to recovery.
ORA-00366: log string of thread string, checksum error in the file header
Cause: The file header for the redo log contains a checksum that does not match the value calculated from the file header as read from disk. This means the file header is corrupted
Action: Find and install correct version of log or reset logs.
ORA-00367: checksum error in log file header
Cause: The file header for the redo log contains a checksum that does not match the value calculated from the file header as read from disk. This means the file header is corrupted
Action: Find the correct file and try again.
ORA-00368: checksum error in redo log block
Cause: The redo block indicated by the accompanying error, is not vaild. It has a checksum that does not match the block contents.
Action: Restore correct file or reset logs.
ORA-00369: Current log of thread string not useable and other log being cleared
Cause: Attempt to open thread failed because it is necessary to switch redo generation to another online log, but all the other logs are being cleared or need to be archived before they can be used.
Action: If the ALTER DATABASE CLEAR LOGFILE command is still active then wait for it to complete. Otherwise reissue the CLEAR command. If there are other online logs for the thread, that are not being cleared, then archive the logs.
ORA-00370: potential deadlock during kcbchange operation
Cause: Error code used internally by software. Should never be reported
Action: Treat as internal error. See error 600.
ORA-00371: not enough shared pool memory, should be atleast string bytes
Cause: Init.ora parameter shared_pool_size is too small
Action: Increase the parameter value
ORA-00372: file string cannot be modified at this time
Cause: attempting to modify the contents of a file that cannot be modified. The file is most likely part of a read only tablespace but may be in the process of going offline, or the database may be in the process of closing.
Action: check the status of the file and its tablespace
ORA-00373: online log version string incompatible with ORACLE version string
Cause: The online log was written by incompatible version of Oracle. Can occur when the log file was created by either a new or older version of Oracle.
Action: Recover the database with the compatible software, shut it down cleanly, then restart with current software.
ORA-00374: parameter db_block_size = string invalid ; must be a multiple of string in the range [string..string]
Cause: invalid value for db_block_size parameter
Action: adjust parameter and restart
ORA-00375: unable to get default db_block_size
Cause: the system was unable to determine the default db_block_size
Action: see accompanying system specific error. As a workaround, specify the blocksize in the INIT.ORA file.
ORA-00376: file string cannot be read at this time
Cause: attempting to read from a file that is not readable. Most likely the file is offline.
Action: Check the state of the file. Bring it online
ORA-00377: Frequent backups of file string causing write operation to stall
Cause: Backups are occurring too frequently on this file. Each time a new backup is started for a file, any writes which have been previously issued (but not completed) have to be re-issued. If hot backups are started very, very frequently, it is possible that some writes will be re-issued repeatedly and never complete.
Action: Increase the interval between begin hot-backup commands for this file.
ORA-00378: buffer pools cannot be created as specified
Cause: Either the number of buffers or the number of lru latches is too small to satisfy the specified buffer pool configuration.
Action: Either increase the number of buffers and/or number of lru latches or configure smaller buffer pools.
ORA-00379: no free buffers available in buffer pool string for block size stringK
Cause: All buffers in the specified buffer pool for the specified block size are in use and no free buffers are available.
Action: Increase the number of buffers in the specified pool for the specified block size
ORA-00380: cannot specify db_stringk_cache_size since stringK is the standard block size
Cause: User specified the parameter db_nk_cache_size (where n is one of 2,4,8,16,32), while the standard block size for this database is equal to n Kbytes. This is illegal.
Action: Specify the standard block size cache using db_cache_size (DEFAULT pool) (and db_recycle_cache_size, db_keep_cache_size if additional buffer pools are required). Do NOT use the corresponding db_nk_cache_size parameter for the standard block size.
ORA-00381: cannot use both new and old parameters for buffer cache size specification
Cause: User specified one or more of { db_cache_size , db_recycle_cache_size, db_keep_cache_size, db_nk_cache_size (where n is one of 2,4,8,16,32), db_cache_advice } AND one or more of { db_block_buffers, buffer_pool_keep , buffer_pool_recycle }. This is illegal.
Action: Use EITHER the old (pre-Oracle_8.2) parameters OR the new ones. Don't specify both. If old size parameters are specified in the parameter file, you may want to replace them with new parameters since the new parameters can be modified dynamically and allow you to configure additional caches for additional block sizes. Cache advisory can only be enabled with the new cache parameters.
ORA-00382: %s not a valid block size, valid range [string..string]
Cause: User specified a value for db_nk_cache_size where n is one of {2, 4, 8, 16, 32}, but nk is not a valid block size for this platform.
Action: Remove corresponding parameter from the "init.ora" file and restart the instance.
ORA-00383: DEFAULT cache for blocksize string cannot be reduced to zero
Cause: User attempted to reduce db_cache_size to zero, or attempted to to reduce db_<n>K_cache_size to zero while there were still online tablespaces with blocksize <n>K. Note that since the SYSTEM tablespace cannot be taken offline, it is always illegal to set db_cache_size to zero.
Action: Offline any tablespaces with the corresponding blocksize and then perform the operation again.
ORA-00384: Insufficient memory to grow cache
Cause: The system could not allocate sufficient memory to grow the cache to the specified size.
Action: Attempt a smaller increase in the value of the parameter.
ORA-00385: cannot enable Very Large Memory with new buffer cache parameters
Cause: User specified one or more of { db_cache_size , db_recycle_cache_size, db_keep_cache_size, db_nk_cache_size (where n is one of 2,4,8,16,32) } AND use_indirect_data_buffers is set to TRUE. This is illegal.
Action: Very Large Memory can only be enabled with the old (pre-Oracle_8.2) parameters.
ORA-00390: log string of thread string is being cleared, cannot become current log
Cause: An attempt to switch to a new online log for the redo thread failed because no reusable log could be found. This log is being cleared and will be useable when the clearing completes. The command that began the clearing may have terminated without completing the clearing.
Action: If the clear command is still executing then wait for its completion. If it terminated then reissue the clear command, or drop the log.
ORA-00391: All threads must switch to new log format at the same time
Cause: An attempt to switch the current log of a single thread is not allowed because the compatiblity requirements force a new log format version number. When changing log formats, all threads must switch to the new format at the same time.
Action: Open the database to cause the coordinated log switch. If that is not possible then return to the same software version and compatibility setting last used to open the database.
ORA-00392: log string of thread string is being cleared, operation not allowed
Cause: An operation encountered this online log in the middle of being cleared. The command that began the clearing may have terminated without completing the clearing.
Action: If the clear command is still executing then wait for its completion. If it terminated then reissue the clear command, or drop the log.
ORA-00393: log string of thread string is needed for recovery of offline datafiles
Cause: Log cannot be cleared because the redo in it is needed to recover offline datafiles. It has not been archived so there is no other copy available. If the log is cleared the tablespaces containing the files will have to be dropped.
Action: Archive the log then repeat the clear command. If archiving is not possible, and dropping the tablespaces is acceptible, then add the clause UNRECOVERABLE DATAFILE at the end of the clear command.
ORA-00394: online log reused while attempting to archive it
Cause: It has been detected that an online log that is being archived has been reused
Action: Cannot archive the logfile anymore since it has been overwritten
ORA-00395: online logs for the clone database must be renamed
Cause: A clone database open forces logfile renaming to avoid overwriting the primary logfiles
Action: Rename the logfiles manually or using the log_file_name_convert initialization parameter
ORA-00396: error string required fallback to single-pass recovery
Cause: The indicated error caused two-pass instance or crash recovery to fail. Recovery was retried with an alternate (slower) method to avoid the error.
Action: Correct the cause of the indicated error (also recorded) so that future instance or crash recovery can succeed with the two-pass algorithm. This usually requires making more main memory available to the recovery process.
ORA-00397: instance recovery process terminated with error
Cause: The foreground process doing instance recovery died.
Action: Check the foreground trace file for the cause of recovery failure.
ORA-00398: abort thread recovery due to reconfiguration
Cause: Global enqueue service reconfiguration occurred during instance/crash recovery.
Action: This is used internally, no action is required.
ORA-00399: corrupt change description in redo log
Cause: A change vector in the redo log failed validation checks.
Action: Do recovery with a good version of the log or do time based recovery up to the indicated time.
ORA-00400: invalid release value string for parameter string
Cause: The release level given for the specified init parameter is invalid.
Action: Correct the parameter value in the parameter file and retry.
ORA-00401: the value for parameter string is not supported by this release
Cause: The value specified cannot be supported by this release of the software.
Action: Choose an appropriate value, or remove the parameter value to use the default value.
ORA-00402: database changes by release string cannot be used by release string
Cause: Changes have been made to the database that require a newer software release or that violate the compatibility parameters.
Action: Use a version of the software that can understand the changes or relax the compatibility requirements in the init file.
ORA-00403: %s (string) is not the same as other instances (string)
Cause: Another instance has set the compatible or compatible no recovery parameters differently than this instance.
Action: Change the parameters of the current instance to match other instances already running.
ORA-00404: Convert file not found: 'string'
Cause: The file used for converting the database from V7 to V8 could not be found.
Action: Verify that the migration process has been started on this database and that the convert filename is accessable.
ORA-00405: compatibility type "string"
Cause: Reporting a type associated with another error.
Action: See accompanying error
ORA-00406: COMPATIBLE parameter needs to be string or greater
Cause: The COMPATIBLE initialization parameter is not high enough to allow the operation. Allowing the command would make the database incompatible with the release specified by the current COMPATIBLE parameter.
Action: Shutdown and startup with a higher compatibility setting.
ORA-00407: rolling upgrade from release string.string to string.string is not allowed
Cause: Another instance executing software at a different point release already has the database mounted.
Action: Shutdown all instances then startup with the new software.
ORA-00408: parameter string is set to TRUE
Cause: Reporting the parameter that resulted in the compatibility error.
Action: Shutdown and startup with a higher compatibility setting.
ORA-00409: COMPATIBLE needs to be string or higher to use AUTO SEGMENT SPACE MANAGEMENT
Cause: This is due to migrating from an older release of Oracle with tablespaces created using AUTO SEGMENT SPACE MANAGEMENT. To open the database, the COMPATIBLE parameter needs to be set to the specified value.
Action: Shutdown and startup with the specified compatibility setting.
ORA-00437: ORACLE feature is not licensed. Contact Oracle Corp. for assistance
Cause: ORACLE feature is not licensed.
Action: Contact ORACLE for assistance.
ORA-00438: %s Option not installed
Cause: The specified option is not installed.
Action: Purchase and install the option.
ORA-00439: feature not enabled: string
Cause: The specified feature is not enabled.
Action: Do not attempt to use this feature.
ORA-00443: background process "string" did not start
Cause: The specified process did not start.
Action: Ensure that the executable image is in the correct place with the correct protections, and that there is enough memory.
ORA-00444: background process "string" failed while starting
Cause: Usually due to a bad (or non-existent) background process image.
Action: Get a good background process image.
ORA-00445: background process "string" did not start after string seconds
Cause: The specified process did not start after the specified time.
Action: Ensure that the background did not die and leave a trace file.
ORA-00446: background process started when not expected
Cause: The background process specified started up AFTER the RDBMS was already running.
Action: If nobody at your site started the process, then this is an internal error.
ORA-00447: fatal error in background process
Cause: One of the background processes died unexpectedly.
Action: Warm start the system.
ORA-00448: normal completion of background process
Cause: One of the background processes completed normally (i.e. exited). The background process thinks that somebody asked it to exit.
Action: Warm start the system.
ORA-00449: background process 'string' unexpectedly terminated with error string
Cause: A foreground process needing service from a background process has discovered the process died.
Action: Consult the error code, and the trace file for the process.
ORA-00450: background process 'string' did not start
Cause: The specified process did not start.
Action: Consult the error code, and the trace file for the process.
ORA-00470: LGWR process terminated with error
Cause: The log writer process died
Action: Warm start instance
ORA-00471: DBWR process terminated with error
Cause: The database writer process died
Action: Warm start instance
ORA-00472: PMON process terminated with error
Cause: The process cleanup process died
Action: Warm start instance
ORA-00473: ARCH process terminated with error
Cause: The archive process died
Action: Warm start instance
ORA-00474: SMON process terminated with error
Cause: The system cleanup process died
Action: Warm start instance
ORA-00475: TRWR process terminated with error
Cause: The system tracing process died
Action: Warm start instance
ORA-00476: RECO process terminated with error
Cause: The distributed transaction (two-phase commit) recovery process died.
Action: Warm start instance
ORA-00477: SNP* process terminated with error
Cause: A materialized view refresh process died
Action: PMON will restart SNP process shortly. If SNP process does not get started, contact Oracle support.
ORA-00478: SMON process terminated due to error string
Cause: SMON was unable to service the requests due to error in cleanup of resources
Action: Warm start instance
ORA-00479: RVWR process terminated with error string
Cause: The RVWR process died
Action: Warm start instance
ORA-00480: LCK* process terminated with error
Cause: A system lock process died
Action: Warm start instance
ORA-00481: LMON process terminated with error
Cause: The global enqueue service monitor process died
Action: Warm start instance
ORA-00482: LMD* process terminated with error
Cause: A global enqueue service daemon process died
Action: Warm start instance
ORA-00483: During shutdown a process abnormally terminated
Cause: One of the background processes did not exit normally at or near the time of shutdown.
Action: Use shutdown abort.
ORA-00484: LMS* process terminated with error
Cause: A global cache service process died
Action: Warm start instance
ORA-00485: DIAG process terminated with error string
Cause: A global diagnostic process died
Action: Wait for process to restart
ORA-00486: ASMB process terminated with error
Cause: An ASM background process died.
Action: Warm start instance. Also check that ASM Instance is running.
ORA-00487: CTWR process terminated with error
Cause: The change tracking process died
Action: Warm start instance
ORA-00488: RBAL process terminated with error
Cause: The ASM rebalance coordinator process died.
Action: Warm start instance.
ORA-00489: ARB* process terminated with error
Cause: An ASM rebalance worker process died.
Action: Wait for process to restart.
ORA-00568: Maximum number of interrupt handlers exceeded
Cause: User specified too many ^c handlers
Action: Remove some old handlers.
ORA-00600: internal error code, arguments: [string], [string], [string], [string], [string], [string], [string], [string]
Cause: This is the generic internal error number for Oracle program exceptions. This indicates that a process has encountered an exceptional condition.
Action: Report as a bug - the first argument is the internal error number
ORA-00601: cleanup lock conflict
Cause: PMON process runs into lock conflict trying to recovery processes
Action: This is trapped internally, no action necessary
ORA-00602: internal programming exception
Cause: Internal programming exception
Action: Report as bug
ORA-00603: ORACLE server session terminated by fatal error
Cause: An ORACLE server session is in an unrecoverable state.
Action: Login to ORACLE again so a new server session will be created
ORA-00604: error occurred at recursive SQL level string
Cause: An error occurred while processing a recursive SQL statement (a statement applying to internal dictionary tables).
Action: If the situation described in the next error on the stack can be corrected, do so; otherwise contact Oracle Support.
ORA-00606: Internal error code
Cause: A call to deferred upi functions was made in non deferred mode
Action: Report as a bug.
ORA-00607: Internal error occurred while making a change to a data block
Cause: An internal error or memory exception occurred while Oracle was applying redo to a data block.
Action: call Oracle Support
ORA-00608: testing error [string] [string] [string] [string] [string]
Cause: Internal error reserved for testing.
Action: call Oracle Support
ORA-00701: object necessary for warmstarting database cannot be altered
Cause: Attempt to alter or drop a database object (table, cluster, or index) which are needed for warmstarting the database.
Action: None.
ORA-00702: bootstrap verison 'string' inconsistent with version 'string'
Cause: The reading version of the boostrap is incompatible with the current bootstrap version.
Action: Restore a version of the software that is compatible with this bootstrap version.
ORA-00703: maximum number of row cache instance locks exceeded
Cause: There are not enough row cache enqueues.
Action: Increase the row cache enqueue parameter and warm start the system.
ORA-00704: bootstrap process failure
Cause: Failure in processing bootstrap data - see accompanying error.
Action: Contact your customer support representative.
ORA-00705: inconsistent state during start up; shut down the instance, then restart it
Cause: A previous attempt to start an instance was terminated.
Action: Shut down the instance completely, then restart it.
ORA-00706: error changing format of file 'string'
Cause: An attempt to change the block0 format of the specified file failed because the file is read-only or offline.
Action: Make the file read-write or bring the file online and set the BLK0_FMTCHG event.
ORA-00710: new tablespace name is the same as the old tablespace name
Cause: An attempt to rename a tablespace failed because the new name is the same as the old name.
Action: No action required.
ORA-00711: new tablespace name is invalid
Cause: An attempt to rename a tablespace failed because the new name is invalid.
Action: Choose a valid new name and retry the command.
ORA-00712: cannot rename system tablespace
Cause: An attempt to rename the system tablespace failed.
Action: No action required.
ORA-00720: ALTER DATABASE RESET COMPATIBILITY command has been de-supported
Cause: ALTER DATABASE RESET COMPATIBILITY command has been de-supported since Oracle 10i.
Action: No action required.
ORA-00721: changes by release string cannot be used by release string
Cause: An attempt to import a tablespace failed because the tablespace contains changes that require a newer software release or that violate the compatibility parameters.
Action: Use a version of the software that can understand the changes or relax the compatibility requirements in the initialization parameter file.
ORA-00722: Feature "string"
Cause: Reporting name of the feature for details of another error.
Action: See associated error message.
ORA-00723: Initialization parameter COMPATIBLE must be explicitly set
Cause: Oracle detected that the initialization parameter COMPATIBLE was not explicitly specified, and the compatibility of the database is lower than the default value of the COMPATIBLE parameter. In order to use the new compatible setting, the intialization parameter must be explicitly set by the user.
Action: Explicitly set the value of COMPATIBLE parameter either in PFILE or SPFILE, whichever is used.
ORA-00724: ALTER DATABASE CONVERT command has been de-supported
Cause: ALTER DATABASE CONVERT command has been de-supported since Oracle 10i.
Action: No action required.
ORA-00740: datafile size of (string) blocks exceeds maximum file size
Cause: The user specified datafile size exceeded maximum file size.
Action: Please check REFERENCE for maximum size. Reduce the size and retry.
ORA-00741: logfile size of (string) blocks exceeds maximum logfile size
Cause: The user specified logfile size exceeded maximum logfile size.
Action: Please check REFERENCE for maximum size. Reduce the size and retry.
ORA-00750: database has been previously mounted and dismounted
Cause: The instance has already mounted and dismounted the database, which is only allowed once in its lifetime.
Action: Shut down the database.
ORA-00820: Specified value of sga_max_size is too small, needs to be at least stringM
Cause: The specified value of sga_max_size is too small for the SGA to accommodate all of the necessary SGA components such as the log buffer, buffer pools, shared pool, etc.
Action: Set sga_max_size to the recommended value or reduce the values of any SGA component size parameters you have specified.
ORA-00821: Specified value of sga_target is too small, needs to be at least stringM
Cause: The specified value of sga_target is too small for the SGA to accommodate all of the necessary SGA components such as the log buffer, buffer pools, shared pool, etc.
Action: Set sga_target to the recommended value or reduce the values of any SGA component size parameters you have specified.
ORA-00822: MMAN process terminated with error
Cause: The Memory Management process died.
Action: Warm start instance
ORA-00823: Specified value of sga_target greater than sga_max_size
Cause: The specified value of sga_target is greater than sga_max_size.
Action: Increase sga_max_size to match up with sga_target or decrease sga_target to match up with sga_maxsize.
ORA-00824: cannot set sga_target due to existing internal settings
Cause: Unable to set sga_target due to current parameter settings.
Action: See alert log for more information.
ORA-00825: cannot set db_block_buffers if sga_target set
Cause: sga_target set with db_block_buffers set.
Action: Do not set sga_target or use new cache parameters and do not use db_block_buffers which is a old cache parameter.
ORA-00826: cannot set sga_target for an ASM instance
Cause: sga_target set for an ASM instance.
Action: Do not set sga_target.
ORA-00827: could not shrink sga_target to specified value
Cause: Attempted to shrink the SGA to the specified value but did not succeed because the SGA components could not be shrunk as they were already at their minimum sizes.
Action: Do not set sga_target to a value below the current value without first shrinking the individual SGA components.
ORA-00828: specified value of shared_pool_reserved_size inconsistent with internal settings
Cause: Unable to set shared_pool_reserved_size to specified value if sga_target set, either because the specified value is too small, or because it is too large for the current internal size of shared pool. More details can be found in the alert log.
Action: If possible, do not set shared_pool_reserved_size without setting shared_pool_size if sga_target set. Examine the alert log for information about current internal size of shared pool, and valid range of values for shared_pool_reserved_size.
ORA-00830: cannot set statistics_level to BASIC with auto-tune SGA enabled
Cause: The user attempted to set statistics_level to BASIC with auto-tune SGA enabled which cannot be done because auto-tune SGA cannot work with statistics_level set to BASIC.
Action: Disable auto-tune SGA and try setting the statistics_level to BASIC again.


3 ORA-00910 to ORA-01497

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

3 ORA-00910 to ORA-01497

ORA-00910: specified length too long for its datatype
Cause: for datatypes CHAR and RAW, the length specified was > 2000; otherwise, the length specified was > 4000.
Action: use a shorter length or switch to a datatype permitting a longer length such as a VARCHAR2, LONG CHAR, or LONG RAW
ORA-00911: invalid character
Cause: identifiers may not start with any ASCII character other than letters and numbers. $#_ are also allowed after the first character. Identifiers enclosed by doublequotes may contain any character other than a doublequote. Alternative quotes (q'#...#') cannot use spaces, tabs, or carriage returns as delimiters. For all other contexts, consult the SQL Language Reference Manual.
Action: none
ORA-00953: missing or invalid index name
Cause: An index name of the form [ <identifier> . ] <identifier> is expected but not present. If OIDINDEX clause, index name must be <identifier>
Action: Enter an appropriate index name.
ORA-00956: missing or invalid auditing option
Cause: AUDIT or NOAUDIT statement contains an invalid auditing option.
Action: Use a valid option.
ORA-00960: ambiguous column naming in select list
Cause: A column name in the order-by list matches more than one select list columns.
Action: Remove duplicate column naming in select list.
ORA-00962: too many group-by / order-by expressions
Cause: The group-by or order-by column list contain more than 1000 expressions.
Action: Use 1000 or less expressions in the group-by or order-by list.
ORA-00964: table name not in FROM list
Cause: The table name referred in the select list is not specified in the from list.
Action: Make sure the name is correctly specified and matches one of the names in the from list.
ORA-00965: column aliases not allowed for '*'
Cause: The statement is trying to alias the * expression in the select list which is not legal.
Action: Remove the alias.
ORA-00972: identifier is too long
Cause: An identifier with more than 30 characters was specified.
Action: Specify at most 30 characters.
ORA-00976: LEVEL, PRIOR, or ROWNUM not allowed here
Cause: LEVEL, PRIOR, or ROWNUM is being specified at illegal location.
Action: Remove LEVEL, PRIOR, or ROWNUM.
ORA-00977: duplicate auditing option
Cause: AUDIT or NOAUDIT statement specifies an option more than once
Action: Either use ALL with no other auditing options or make sure no option is listed more than once.
ORA-00981: cannot mix table and system auditing options
Cause: Table and system-wide auditing options were specified in the same AUDIT or NOAUDIT statement.
Action: You must issue table and system options in separate statements.
ORA-00991: only MAC privileges may be granted to procedures
Cause: Object privileges or non-MAC system privileges were granted to the procedure.
Action: Only grant MAC privileges using the PROCEDURE clause.
ORA-01002: fetch out of sequence
Cause: This error means that a fetch has been attempted from a cursor which is no longer valid. Note that a PL/SQL cursor loop implicitly does fetches, and thus may also cause this error. There are a number of possible causes for this error, including: 1) Fetching from a cursor after the last row has been retrieved and the ORA-1403 error returned. 2) If the cursor has been opened with the FOR UPDATE clause, fetching after a COMMIT has been issued will return the error. 3) Rebinding any placeholders in the SQL statement, then issuing a fetch before reexecuting the statement.
Action: 1) Do not issue a fetch statement after the last row has been retrieved - there are no more rows to fetch. 2) Do not issue a COMMIT inside a fetch loop for a cursor that has been opened FOR UPDATE. 3) Reexecute the statement after rebinding, then attempt to fetch again.
ORA-01010: invalid OCI operation
Cause: One of the following: 1) You attempted an invalid OCI operation. 2) You are using an Oracle client application linked with version 7.1 (or higher) libraries, the environment variable ORA_ENCRYPT_LOGIN is set to TRUE, and you attempted to connect to a version 7.0 (or lower) Oracle Server. 3) You are connected to a version 7.1 (or higher) Oracle Server, the initialization parameter DBLINK_ENCRYPT_LOGIN is set to TRUE, and you attempted to use a database link pointing to a version 7.0 (or lower) Oracle Server. 4) You are connected to a version 9.0.2(or higher) Oracle Server and you attempted to use a database link pointing to a version 9.0.1(or lower) Oracle Server for distributed autonomous transaction.
Action: For the above causes: 1) Do not use the invalid OCI operation. 2) If you do not wish to use encrypted connect passwords in your distributed database, set ORA_ENCRYPT_LOGIN to FALSE. If you wish to use encrypted connect passwords, you must upgrade all Oracle Servers to version 7.1 (or higher). 3) If you do not wish to use encrypted database links in your distributed database, set DBLINK_ENCRYPT_LOGIN to FALSE. If you wish to use encrypted database links, you must upgrade all Oracle Servers to version 7.1 (or higher). 4) Do not attempt distributed autonomous transaction on version 9.0.1(or lower) Oracle Server.
ORA-01016: This function can be called only after a fetch
Cause: Cursor in an invalid state.
Action: Make sure that the oci/upi function is called after fetch.
ORA-01019: unable to allocate memory in the user side
Cause: The user side memory allocator returned error.
Action: Increase the processes heap size or switch to the old set of calls.
ORA-01022: database operation not supported in this configuration
Cause: The attempted database operation does not conform to the user programming interface (UPI) for the two communicating ORACLE servers.
Action: You may need to upgrade one or more of your ORACLE servers or re-link your user side application with new libraries. Report the problem to Worldwide Customer Support.
ORA-01023: Cursor context not found (Invalid cursor number)
Cause: The cursor number is not a valid open cursor.
Action: Make sure that the cursor is open.
ORA-01025: UPI parameter out of range
Cause: An integer parameter to a upi function is out of range.
Action: This usually indicates an error in a tool built on top of the oracle dbms. Report the error to your customer support representative.
ORA-01026: multiple buffers of size > 4000 in the bind list
Cause: More than one long buffer in the bind list.
Action: Change the buffer size to be less than 4000 for the bind variable bound to a normal column.
ORA-01027: bind variables not allowed for data definition operations
Cause: An attempt was made to use a bind variable in a SQL data definition operation.
Action: Such bind variables are not allowed.
ORA-01028: internal two task error
Cause: Received send long message but don't have the cursor context.
Action: Report as a bug.
ORA-01029: internal two task error
Cause: Received a request to send the long again when there is no long
Action: Report as a bug
ORA-01030: SELECT ... INTO variable does not exist
Cause: The SELECT... INTO specified in the bind call does not correspond to a variable in the SQL statement.
Action: If it is not possible to correct the statement, call customer support.
ORA-01031: insufficient privileges
Cause: An attempt was made to change the current username or password without the appropriate privilege. This error also occurs if attempting to install a database without the necessary operating system privileges. When Trusted Oracle is configure in DBMS MAC, this error may occur if the user was granted the necessary privilege at a higher label than the current login.
Action: Ask the database administrator to perform the operation or grant the required privileges. For Trusted Oracle users getting this error although granted the the appropriate privilege at a higher label, ask the database administrator to regrant the privilege at the appropriate label.
ORA-01032: no such userid
Cause: This is an internal error message related to Export/Import.
Action: Contact customer support.
ORA-01033: ORACLE initialization or shutdown in progress
Cause: An attempt was made to log on while Oracle is being started up or shutdown.
Action: Wait a few minutes. Then retry the operation.
ORA-01034: ORACLE not available
Cause: Oracle was not started up. Possible causes include the following:

- The SGA requires more space than was allocated for it.

- The operating-system variable pointing to the instance is improperly defined.

Action: Refer to accompanying messages for possible causes and correct the problem mentioned in the other messages. If Oracle has been initialized, then on some operating systems, verify that Oracle was linked correctly. See the platform specific Oracle documentation.
ORA-01035: ORACLE only available to users with RESTRICTED SESSION privilege
Cause: Logins are disallowed because an instance started in restricted mode. Only users with RESTRICTED SESSION system privilege can log on.
Action: Request that Oracle be restarted without the restricted option or obtain the RESTRICTED SESSION system privilege.
ORA-01036: illegal variable name/number
Cause: Unable to find bind context on user side
Action: Make sure that the variable being bound is in the sql statement.
ORA-01037: maximum cursor memory exceeded
Cause: Attempting to process a complex sql statement which consumed all available memory of the cursor.
Action: Simplify the complex sql statement.
ORA-01038: cannot write database file version string with ORACLE version string
Cause: Attempting to write datafile headers in an old format. The new format can not be used until after the database has been verified as being compatible with this software version.
Action: Open the database to advance to the new file formats, then repeat the operation. If the operation is required before the database can be opened, then use the previous software release to do the operation.
ORA-01039: insufficient privileges on underlying objects of the view
Cause: Attempting to explain plan on other people's view without the necessary privileges on the underlying objects of the view.
Action: Get necessary privileges or do not perform the offending operation.
ORA-01040: invalid character in password; logon denied
Cause: There are multibyte characters in the password or some characters in the password are not in US7ASCII range.
Action: Resubmit password with valid characters.
ORA-01041: internal error. hostdef extension doesn't exist
Cause: Pointer to hstdef extension in hstdef is null.
Action: Report as a bug
ORA-01042: detaching a session with open cursors not allowed
Cause: An attempt was made to detach a seesio n which had open cursors.
Action: Close all the cursors before detaching the session.
ORA-01043: user side memory corruption [string], [string], [string], [string]
Cause: The application code corrupted some of the usr memory used by oracle
Action: Make sure that the application code is not overwriting memory.
ORA-01044: size string of buffer bound to variable exceeds maximum string
Cause: An attempt was made to bind a buffer whose total size would exceed the maximum size allowed. Total array size for arrays is calculated as: (element_size)*(number of elements)
Action: Reduce buffer size.
ORA-01045: user string lacks CREATE SESSION privilege; logon denied
Cause: A connect was attempted to a userid which does not have create session privilege.
Action: Grant the user CREATE SESSION privilege.
ORA-01048: Couldn't find the specified procedure in the given context
Cause: The procedure user specified in deferred RPC doesn't exist.
Action: Check to make sure that the procedure exists and is visible to the replication process.
ORA-01049: Bind by name is not spupportted in streamed RPC
Cause: A newer version of server is talking with this version requesting an operation not supported in this version.
Action: none
ORA-01051: deferred rpc buffer format invalid
Cause: The deferred rpc data in sys.def$_call is corrupted.
Action: Contact your customer support representive.
ORA-01052: required destination LOG_ARCHIVE_DUPLEX_DEST is not specified
Cause: A valid destination for parameter LOG_ARCHIVE_DUPLEX_DEST was not specified when parameter LOG_ARCHIVE_MIN_SUCCEED_DEST was set to two.
Action: Either specify a value for parameter LOG_ARCHIVE_DUPLEX_DEST, or reduce the value for parameter LOG_ARCHIVE_MIN_SUCCEED_DEST to one.
ORA-01058: internal New Upi interface error
Cause: Attempt to delete non existant hstdef extension.
Action: Report as a bug.
ORA-01059: parse expected before a bind or execute
Cause: The client application attempted to bind a variable or execute a cursor opened in a PL/SQL block before the statement was parsed.
Action: Ensure the statement is parsed before a bind or execute.
ORA-01060: array binds or executes not allowed
Cause: The client application attempted to bind an array of cursors or attempted to repeatedly execute against a PL/SQL block with a bind variable of type cursor.
Action: Bind a single cursor or execute the PL/SQL block once.
ORA-01061: cannot start up a V8 server using a V7 client application
Cause: You are using an Oracle client application linked with version 7 (or lower) libraries and you attempted to start up a V8 (or higher) server.
Action: Use a client application linked with V8 (or higher) libraries.60
ORA-01062: unable to allocate memory for define buffer
Cause: Exceeded the maximum buffer size for current plaform
Action: Use piecewise fetch with a smaller buffer size
ORA-01070: Using an old version of Oracle for the server
Cause: Using pre 7.0.10.1 version of oracle for server
Action: Upgrade server to post 7.0.10.1 version
ORA-01071: cannot perform operation without starting up ORACLE
Cause: Obvious
Action: none
ORA-01072: cannot stop ORACLE; ORACLE not running
Cause: Obvious
Action: none
ORA-01073: fatal connection error: unrecognized call type
Cause: An illegal internal operation was attempted.
Action: Contact your customer support representative.
ORA-01074: cannot shut down ORACLE; inside a login session - log off first
Cause: Obvious
Action: none
ORA-01075: you are currently logged on
Cause: Attempt to login while logged in.
Action: none
ORA-01076: multiple logons per process not yet supported
Cause: Obvious
Action: none
ORA-01077: background process initialization failure
Cause: Failure during initialization of ORACLE background processes.
Action: Further diagnostic information should be in the error stack or in the trace file.
ORA-01078: failure in processing system parameters
Cause: Failure during processing of INIT.ORA parameters during system startup.
Action: Further diagnostic information should be in the error stack.
ORA-01079: ORACLE database was not properly created, operation aborted
Cause: There was an error when the database or controlfile was created.
Action: s to recreate the database or a new controlfile.
ORA-01080: error in shutting down ORACLE
Cause: Failure during system shutdown.
Action: Further diagnostic information should be in the error stack.
ORA-01081: cannot start already-running ORACLE - shut it down first
Cause: Obvious
Action: none
ORA-01082: 'row_locking = always' requires the transaction processing option
Cause: "row_locking = always" is specified in INIT.ORA file. This feature is not supported by ORACLE without the transaction processing option.
Action: Remove it from INIT.ORA file or set it to "default" or "intent".
ORA-01083: value of parameter "string" is inconsistent with that of other instances
Cause: The value of the given parameter is required to be the same for all instances in the cluster database configuration. ROW_LOCKING and SERIALIZABLE are 2 examples.
Action: Change the value of the parameter in INIT.ORA file to match that of other cluster database instances.
ORA-01084: invalid argument in OCI call
Cause: The failing OCI call contains an argument with an invalid value.
Action: Use valid argument values. For more information, see the Programmer's Guide to the Oracle Call Interfaces and the appropriate programming language supplement.
ORA-01085: preceding errors in deferred rpc to "string.string.string"
Cause: Errors were encountered when the named procedure was executed as a deferred remoted procedure call.
Action: Correct the cause of the preceding errors.
ORA-01086: savepoint 'string' never established
Cause: Trying to roll back to a save point that was never established.
Action: none
ORA-01088: cannot shut down ORACLE while active processes exist
Cause: Users are still logged into the instance.
Action: Either wait for all users to logoff or use SHUTDOWN IMMEDIATE.
ORA-01089: immediate shutdown in progress - no operations are permitted
Cause: The SHUTDOWN IMMEDIATE command was used to shut down a running ORACLE instance, so your operations have been terminated.
Action: Wait for the instance to be restarted, or contact your DBA.
ORA-01090: shutdown in progress - connection is not permitted
Cause: The SHUTDOWN command was used to shut down a running ORACLE instance, so you cannot connect to ORACLE.
Action: Wait for the instance to be restarted, or contact your DBA.
ORA-01091: failure during startup force
Cause: Unable to destroy the old SGA.
Action: Manually remove the old SGA and reissue the STARTUP command
ORA-01092: ORACLE instance terminated. Disconnection forced
Cause: The instance this process was connected to was terminated abnormally, probably via a shutdown abort. This process was forced to disconnect from the instance.
Action: Examine the alert log for more details. When the instance has been restarted, retry action.
ORA-01093: ALTER DATABASE CLOSE only permitted with no sessions connected
Cause: There is at least one more session other than the current one logged into the instance. ALTER DATABASE CLOSE is not permitted.
Action: Find the other sessions and log them out and resubmit the command
ORA-01095: DML statement processed zero rows
Cause: During a call to OTEX, an update, delete, or insert statement being executed processed zero rows. The execution of statements by OTEX was halted at this point.
Action: none
ORA-01096: program version (string) incompatible with instance (string)
Cause: A program is trying to connect to an instance using a different version of code than the database was started with. This is not allowed.
Action: Either relink the program with the same version as the database or restart the database using the old version of code.
ORA-01097: cannot shutdown while in a transaction - commit or rollback first
Cause: Obvious
Action: none
ORA-01099: cannot mount database in SHARED mode if started in single process mode
Cause: Obvious
Action: none
ORA-01100: database already mounted
Cause: A database is already mounted in this instance.
Action: none
ORA-01101: database being created currently mounted by some other instance
Cause: Some other instance has the database of same name currently mounted and you are trying to create it.
Action: Either change the database name or shutdown the other instance.
ORA-01102: cannot mount database in EXCLUSIVE mode
Cause: Some other instance has the database mounted exclusive or shared.
Action: Shutdown other instance or mount in a compatible mode.
ORA-01103: database name 'string' in controlfile is not 'string'
Cause: The database name in the controlfile does not match your database name.
Action: Either find the correct controlfile or change your database name.
ORA-01104: number of controlfiles (string) does not equal string
Cause: The number of controlfiles used by this instance disagrees with the number of controlfiles in an existing instance.
Action: Check to make sure that all controlfiles are listed.
ORA-01105: mount is incompatible with mounts by other instances
Cause: An attempt to mount the database discovered that another instance mounted a database by the same name, but the mount is not compatible. Additional errors are reported explaining why.
Action: See accompanying errors.
ORA-01106: database must be closed before dismounting
Cause: Obvious
Action: none
ORA-01107: database must be mounted for media recovery
Cause: An attempt to perform media recovery was made but the database is not mounted.
Action: Mount the database.
ORA-01108: file string is in backup or media recovery
Cause: Either media recovery is actively being applied to the file, or it is being backed up while the database is in NOARCHIVELOG mode. It cannot be used for normal database access or crash recovery.
Action: Complete or cancel the media recovery session or backup.
ORA-01109: database not open
Cause: A command was attempted that requires the database to be open.
Action: Open the database and try the command again
ORA-01110: data file string: 'string'
Cause: Reporting file name for details of another error
Action: See associated error message
ORA-01111: name for data file string is unknown - rename to correct file
Cause: The data file was missing from a CREATE CONTROLFILE command or backup controlfile recovery was done with a controlfile that was saved before the file was created.
Action: Rename the MISSING file to the name of the real file.
ORA-01112: media recovery not started
Cause: An attempt to continue media recovery is being made but media recovery was not started.
Action: None.
ORA-01113: file string needs media recovery
Cause: An attempt was made to online or open a database with a file that is in need of media recovery.
Action: First apply media recovery to the file.
ORA-01114: IO error writing block to file string (block # string)
Cause: The device on which the file resides is probably offline. If the file is a temporary file, then it is also possible that the device has run out of space. This could happen because disk space of temporary files is not necessarily allocated at file creation time.
Action: Restore access to the device or remove unnecessary files to free up space.
ORA-01115: IO error reading block from file string (block # string)
Cause: Device on which the file resides is probably offline
Action: Restore access to the device
ORA-01116: error in opening database file string
Cause: Usually the file is not accessible.
Action: Restore the database file.
ORA-01117: adding file 'string' with illegal block size: string; limit is string
Cause: An attempt was made to add a database file with a block size that is greater than the maximum block size allowed.
Action: Retry the DDL command with a smaller block size.
ORA-01118: cannot add any more database files: limit of string exceeded
Cause: There is no more room in the controlfile for adding database files.
Action: Resize the controlfile or drop other tablespaces.
ORA-01119: error in creating database file 'string'
Cause: Usually due to not having enough space on the device.
Action: none
ORA-01120: cannot remove online database file string
Cause: Attempting to drop a datafile when it is online
Action: Take file offline before dropping.
ORA-01121: cannot rename database file string - file is in use or recovery
Cause: Attempted to use ALTER DATABASE RENAME to rename a datafile that is online in an open instance or is being recovered.
Action: Close database in all instances and end all recovery sessions.
ORA-01122: database file string failed verification check
Cause: The information in this file is inconsistent with information from the controlfile. See accompanying message for reason.
Action: Make certain that the db files and controlfiles are the correct files for this database.
ORA-01123: cannot start online backup; media recovery not enabled
Cause: An attempt to start backup of an on-line tablespace failed because media recovery is not enabled.
Action: Enable media recovery and retry this operation.
ORA-01124: cannot recover data file string - file is in use or recovery
Cause: An attempt to do media recovery found that the file was not available for recovery. Either it is online and the database is open in some instance, or another process is curently doing media recovery on the file.
Action: Do not do media recovery.
ORA-01125: cannot disable media recovery - file string has online backup set
Cause: An attempt to disable media recovery found that an online backup is still in progress.
Action: End the backup of the offending tablespace and retry this command.
ORA-01126: database must be mounted in this instance and not open in any instance
Cause: Obvious
Action: none
ORA-01127: database name 'string' exceeds size limit of string characters
Cause: Obvious
Action: none
ORA-01128: cannot start online backup - file string is offline
Cause: An attempt to start an online backup found that one of the files is offline.
Action: Bring the offending files online and retry this command or do a cold backup.
ORA-01129: user's default or temporary tablespace does not exist
Cause: The user's default or temporary tablespace was dropped.
Action: Reassign the default or temporary tablespace.
ORA-01135: file string accessed for DML/query is offline
Cause: Attempted to access a data file that is offline
Action: Bring the data file back online
ORA-01136: specified size of file string (string blocks) is less than original size of string blocks
Cause: A file size was specified in the AS clause of ALTER DATABASE CREATE DATAFILE, and the size was smaller the the size needed
Action: Create the file with a larger size.
ORA-01137: data file string is still in the middle of going offline
Cause: It was not possible to get the lock for a file that is offline when attempting to bring it online. The most likely cause is that the lock is still held by the instance that is took it offline.
Action: Wait a bit and try to online the file again.
ORA-01138: database must either be open in this instance or not at all
Cause: The requested operation can not be done when the database is mounted but not open in this instance, and another instance has the database open.
Action: Execute the operation in an open instance, open the datbase in this instance, or close the database in the other instances.
ORA-01139: RESETLOGS option only valid after an incomplete database recovery
Cause: The RESETLOGS option was given in ALTER DATABASE OPEN, but there has been no incomplete recovery session.
Action: Retry the ALTER DATABASE OPEN without specifying RESETLOGS
ORA-01140: cannot end online backup - all files are offline or readonly
Cause: All the files were found to be offline or readonly when attempting to end an online backup.
Action: None. Online backup does not need to be ended for this tablespace.
ORA-01141: error renaming data file string - new file 'string' not found
Cause: An attempt to change a data file's name in the controlfile failed because no file was found with the new name.
Action: Make sure that the data file has been properly renamed by the operating system and retry.
ORA-01142: cannot end online backup - none of the files are in backup
Cause: None of the files were found to be in online backup when attempting to end an online backup.
Action: None. Online backup does not need to be ended for this tablespace.
ORA-01143: cannot disable media recovery - file string needs media recovery
Cause: An attempt to disable media recovery found a file that needs media recovery, thus media recovery cannot be disabled.
Action: Recover the offending file or drop the tablespace it belongs to and retry this command.
ORA-01144: File size (string blocks) exceeds maximum of string blocks
Cause: Specified file size is larger than maximum allowable size value.
Action: Specify a smaller size.
ORA-01145: offline immediate disallowed unless media recovery enabled
Cause: ALTER TABLESPACE ... OFFLINE IMMEDIATE or ALTER DATABASE DATAFILE ... OFFLINE is only allowed if database is in ARCHIVELOG mode.
Action: Take tablespace offline normally or shutdown abort. Reconsider your backup strategy. You could do this if you were archiving your logs.
ORA-01146: cannot start online backup - file string is already in backup
Cause: When starting an online backup it was noticed that an online backup was already started for one of the data files.
Action: End the first backup before beginning another.
ORA-01147: SYSTEM tablespace file string is offline
Cause: A file belonging to the SYSTEM tablespace has been marked offline by the DBA. The database cannot be started until all SYSTEM tablespace files are online and openable.
Action: Bring the file online.
ORA-01149: cannot shutdown - file string has online backup set
Cause: An attempt to shutdown normally found that an online backup is still in progress.
Action: End the backup of the offending tablespace and retry this command.
ORA-01150: cannot prevent writes - file string has online backup set
Cause: An attempt to make a tablespace read only or offline normal found that an online backup is still in progress. It will be necessary to write the file header to end the backup, but that would not be allowed if this command succeeded.
Action: End the backup of the offending tablespace and retry this command.
ORA-01151: use media recovery to recover block, restore backup if needed
Cause: Error 1172 occurred.
Action: This is additional information for error 1172.
ORA-01152: file string was not restored from a sufficiently old backup
Cause: An incomplete recovery session was started, but an insufficient number of logs were applied to make the database consistent. This file is still in the future of the last log applied. The most likely cause of this error is forgetting to restore the file from a backup before doing incomplete recovery.
Action: Either apply more logs until the database is consistent or restore the database file from an older backup and repeat recovery.
ORA-01153: an incompatible media recovery is active
Cause: Attempted to start an incompatible media recovery or open resetlogs during media recovery or RMAN backup . Media recovery sessions are incompatible if they attempt to recover the same data file. Incomplete media recovery or open resetlogs is incompatible with any media recovery. Backup or restore by RMAN is incompatible with open resetlogs
Action: Complete or cancel the other media recovery session or RMAN backup
ORA-01154: database busy. Open, close, mount, and dismount not allowed now
Cause: Some operation is in progress that expects the opened/mounted state of this instance to remain the same.
Action: Wait for the operation to complete then retry. If attempting to do a shutdown, SHUTDOWN ABORT will work. If this is a shutdown of a standby database that is operating in NO DATA LOSS mode, you must shutdown the primary database first.
ORA-01155: the database is being opened, closed, mounted or dismounted
Cause: The requested operation needs the instance to be in a particular state but the state is being changed.
Action: Wait for the open, close, mount, or dismount to complete then retry the operation. If necessary, a SHUTDOWN ABORT will always work.
ORA-01156: recovery in progress may need access to files
Cause: Either media recovery or instance recovery is in progress. It may need the files this operation is being applied to.
Action: Wait for recovery to complete.
ORA-01157: cannot identify/lock data file string - see DBWR trace file
Cause: The background process was either unable to find one of the data files or failed to lock it because the file was already in use. The database will prohibit access to this file but other files will be unaffected. However the first instance to open the database will need to access all online data files. Accompanying error from the operating system describes why the file could not be identified.
Action: Have operating system make file available to database. Then either open the database or do ALTER SYSTEM CHECK DATAFILES.
ORA-01158: database string already mounted
Cause: Another instance has a database by this name mounted.
Action: Find which instance is still running. Perhaps you have not lost the controlfiles after all.
ORA-01159: file is not from same database as previous files - wrong database id
Cause: Not all of the files specified in CREATE CONTROLFILE are from the same database. The database ID of this file does not match that from the first file specified.
Action: Please double check the list of files provided to the CREATE
ORA-01160: file is not a string
Cause: The named file in the DATAFILE or LOGFILE section of the CREATE CONTROLFILE command does not appear to be as stated.
Action: Please double check the mentioned file.
ORA-01161: database name string in file header does not match given name of string
Cause: The database name given at the command line does not match the database name found in the file header.
Action: Chance are good that the database name specified at the command line is incorrect. Resolve the descepency, and resubmit the command. If you are attempting to change the database name, be sure to use the SET DATABASE option.
ORA-01162: block size string in file header does not match configured block sizes
Cause: CREATE CONTROLFILE discovered that the block size for this file is incompatible with any of the configured cache blocksizes in the INIT.ORA file.
Action: Configure the appropriate cache for this block size using one of the various (db_2k_cache_size, db_4k_cache_size, db_8k_cache_size, db_16k_cache_size, db_32K_cache_size) parameters.
ORA-01163: SIZE clause indicates string (blocks), but should match header string
Cause: The size specified in bytes in the SIZE clause of the CREATE CONTROLFILE statement does not equate to the number of blocks recorded in the header.
Action: Specify the correct filename and size ( in bytes ).
ORA-01164: MAXLOGFILES may not exceed string
Cause: MAXLOGFILES specified on the command line too large.
Action: Resubmit the command with a smaller MAXLOGFILES
ORA-01165: MAXDATAFILES may not exceed string
Cause: MAXDATAFILES specified on the command line too large.
Action: Resubmit the command with a smaller MAXDATAFILES
ORA-01166: file number string is larger than string (string)
Cause: File mentioned in CREATE CONTROLFILE has a file number which is larger than that specified for MAXDATAFILES or MAXLOGFILES.
Action: Increase the maximum specified on the command line.
ORA-01167: two files are the same file/group number or the same file
Cause: There is an overlap of file numbers in the files specified on the command line or the same file is specified twice. If they are not the exact same file then one is likely to be a backup of the other. If they are two members of the same log they must be specified together in a group file spec. This message will also appear if the same controlfile appears more than once in the control_files p parameter in the init.ora file. If this happens, check for additional error messages.
Action: Confirm that the file mentioned is not a repeat of a file already mentioned in the command. If they are different files then omit the earlier backup. If they are members of the same log, insure they are in the same group file specification. If this message appears because of a duplicate controlfile, check the control_files parameter in the init.ora file and see if a file is specified more than once. If all files names appear to be unique, check to make sure that the actual controlfiles themselves are unique. For example, in UNIX check for a symbolic or a hard link to another controlfile in the list.
ORA-01168: physical block size string does not match size string of other members
Cause: The file is located on a device with a different physical block size than the other members in the group
Action: Use a physical device with matching block size.
ORA-01169: DATAFILE number 1 not found. Must be present
Cause: Datafile number 1 was not specified in a CREATE CONTROLFILE command.
Action: Locate datafile number 1 and resubmit the CREATE CONTROLFILE command.
ORA-01170: file not found 'string'
Cause: ALL datafiles and, if NORESETLOGS, ALL logfiles MUST be accessible by the process for CREATE CONTROLFILE.
Action: The file specified probably contains a typing error. Double check command and the existance of all files and then resubmit.
ORA-01171: datafile string going offline due to error advancing checkpoint
Cause: The checkpoint in the file header could not be advanced. See accompanying errors for the reason. The datafile will be taken offline the same as for a write error of a data block.
Action: See accompanying errors for details. Restore access to the file, do media recovery, and bring it back online.
ORA-01172: recovery of thread string stuck at block string of file string
Cause: Crash recovery or instance recovery could not apply a change to a block because it was not the next change. This can happen if the block was corrupted and then repaired during recovery.
Action: Do a RECOVER DATAFILE for the file containing the block. If this does not resolve the problem then restore the file from a backup and recover it.
ORA-01173: data dictionary indicates missing data file from system tablespace
Cause: Either the database has been recovered to a point in time in the future of the controlfile or a datafile from the system tablespace was omitted from the create controlfile command previously issued.
Action: For the former problem you need to recover the database from a more recent controlfile. For the latter problem, simply recreate the controlfile checking to be sure that you include all the datafiles in the system tablespace.
ORA-01174: DB_FILES is string buts needs to be string to be compatible
Cause: The maximum number of database files supported by this instance is not the same as for the other instances. All instances must be able to open all the files any instance can open.
Action: Change the value of the DB_FILES parameter to be compatible
ORA-01175: data dictionary has more than the string files allowed by the instance
Cause: The data dictionary is found to have more files than that which can be supported by this instance.
Action: Shutdown the instance and restart with a larger number of db_files
ORA-01176: data dictionary has more than the string files allowed by the controlfie
Cause: After a CREATE CONTROLFILE, the data dictionary was found to have more datafiles than that supported by the controlfile.
Action: Recreate the controlfile with a larger MAXDATAFILES.
ORA-01177: data file does not match dictionary - probably old incarnation
Cause: When comparing the controlfile with the data dictionary after a CREATE CONTROLFILE or OPEN RESETLOGS, it was noted that this datafile was inconsistent with the dictionary. Most likely the file is a backup of a file that was dropped from the database, and the same file number was reused for a new file. It may also be that an incomplete recovery stopped at a time when this file number was used for another datafile.
Action: Do a CREATE CONTROLFILE with the correct file or none at all.
ORA-01178: file string created before last CREATE CONTROLFILE, cannot recreate
Cause: Attempted to use ALTER DATABASE CREATE DATAFILE to recreate a datafile that existed at the last CREATE CONTROL file command. The information needed to recreate the file was lost with the controlfile that existed when the file was added to the database.
Action: Find a backup of the file, and recover it. Do incomplete recovery to time before file was originally created.
ORA-01179: file string does not exist
Cause: During datafile recovery, a file was listed which was not part for the database.
Action: Recheck the datafile name. Remember to use double quotes at the SQLDBA command line and remember that the file name is translated in the environment of the SQLDBA.
ORA-01180: can not create datafile 1
Cause: Attempting to create datafile 1 using ALTER DATABASE CREATE DATAFILE.
Action: Recover file from a backup or recreate database.
ORA-01181: file string created before last known RESETLOGS, cannot recreate
Cause: Attempted to use ALTER DATABASE CREATE DATAFILE to recreate a datafile that existed before the last known RESETLOGS.
Action: Find a backup of the file, and recover it. Do incomplete recovery to time before file was originally created.
ORA-01182: cannot create database file string - file is in use or recovery
Cause: Attempted to use ALTER DATABASE CREATE DATAFILE to recreate a datafile that is online in an open instance or is being recovered.
Action: Close database in all instances and end all recovery sessions
ORA-01183: cannot mount database in SHARED mode
Cause: Some other instance has the database mounted exclusive.
Action: Shutdown other instance then mount shared.
ORA-01184: logfile group string already exists
Cause: An ALTER DATABASE ADD LOGFILE command specified a log number for the new log which is already in use.
Action: Specify a different logfile number, or let the database choose an unused value.
ORA-01185: logfile group number string is invalid
Cause: An ALTER DATABASE ADD LOGFILE command specified a log number for the new log which is too large.
Action: Specify a correct logfile number.
ORA-01186: file string failed verification tests
Cause: The data file did not pass the checks to insure it is part of the database. See the accompanying error messages for the reason the verification failed.
Action: Make the correct file available to the database. Then, either open the database, or execute ALTER SYSTEM CHECK DATAFILES.
ORA-01187: cannot read from file string because it failed verification tests
Cause: The data file did not pass the checks to insure it is part of the database. Reads are not allowed until it is verified.
Action: Make the correct file available to the database. Then, either open the database, or execute ALTER SYSTEM CHECK DATAFILES.
ORA-01188: Block size string in header does not match physical block size string
Cause: A log file member given to CREATE CONTROLFILE is on a physical device that has a different block size than the device originally used to create the log.
Action: Move the file to a device with the correct block size or use the RESETLOGS option to CREATE CONTROLFILE.
ORA-01189: file is from a different RESETLOGS than previous files
Cause: In a CREATE CONTROLFILE command either this file or all previous files were backups from before the last RESETLOGS. This may also occur if this is a file that is offline and has been offline since before the last RESETLOGS.
Action: If the file was taken offline normal before the last RESETLOGS, and is still offline, omit it from the CREATE CONTROLFILE command. Rename and online the file after the database is open. Otherwise find the version of the mentioned file consistent with the rest of the datafiles and resubmit the command.
ORA-01190: controlfile or data file string is from before the last RESETLOGS
Cause: Attempting to use a data file when the log reset information in the file does not match the controlfile. Either the data file or the controlfile is a backup that was made before the most recent ALTER DATABASE OPEN RESETLOGS.
Action: Restore file from a more recent backup.
ORA-01191: file string is already offline - cannot do a normal offline
Cause: When attempting to do a normal tablespace offline it was discovered that one of the files in the tablespace was already offline.
Action: Either bring the datafile online first, or use another tablespace offline option.
ORA-01192: must have at least one enabled thread
Cause: You must specify at least two logfiles from at least one thread at the create contolfile command line.
Action: Find the missing logfiles and resubmit the command with the newly found logfiles included in the command line.
ORA-01193: file string is not the same file seen at start of recovery
Cause: A different copy of the file was accessed the last time media recovery looked at the file header. A backup of the file was restored or the meaning of the file name changed during recovery.
Action: Ensure the correct file is available, then retry recovery.
ORA-01194: file string needs more recovery to be consistent
Cause: An incomplete recovery session was started, but an insufficient number of logs were applied to make the file consistent. The reported file was not closed cleanly when it was last opened by the database. It must be recovered to a time when it was not being updated. The most likely cause of this error is forgetting to restore the file from a backup before doing incomplete recovery.
Action: Either apply more logs until the file is consistent or restore the file from an older backup and repeat recovery.
ORA-01195: online backup of file string needs more recovery to be consistent
Cause: An incomplete recovery session was started, but an insufficient number of logs were applied to make the file consistent. The reported file is an online backup which must be recovered to the time the backup ended.
Action: Either apply more logs until the file is consistent or restore the database files from an older backup and repeat recovery.
ORA-01196: file string is inconsistent due to a failed media recovery session
Cause: The file was being recovered but the recovery did not terminate normally. This left the file in an inconsistent state. No more recovery was successfully completed on this file.
Action: Either apply more logs until the file is consistent or restore the backup again and repeat recovery.
ORA-01197: thread string only contains one log
Cause: During CREATE CONTROLFILE all threads represented in the logs must be represented by at least two logs. A "last log" and a second log. The named thread does not contain two such logs.
Action: Either find more logs from the named thread. Or use the RESETLOGS option to CREATE CONTROLFILE.
ORA-01198: must specify size for log file if RESETLOGS
Cause: File sizes must be given for all logfiles if doing a CREATE CONTROLFILE with the RESETLOGS option.
Action: Resubmit the command with the appropriate logfile size.
ORA-01199: file string is not in online backup mode
Cause: Attempting to end an online backup for a file that is not in online backup.
Action: Do not enter command since it is not needed.
ORA-01200: actual file size of string is smaller than correct size of string blocks
Cause: The size of the file as returned by the operating system is smaller than the size of the file as indicated in the file header and the controlfile. Somehow the file has been truncated. Maybe it is the result of a half completed copy.
Action: Restore a good copy of the data file and do recovery as needed.
ORA-01201: file string header failed to write correctly
Cause: An I/O error was reported for the file header. The error was trapped and a second attempt will be made.
Action: The file probably will require recovery. Further error messages will indicate what is needed.
ORA-01202: wrong incarnation of this file - wrong creation time
Cause: The creation time in the file header is not the same as the creation time in the controlfile. This is probably a copy of a file that was dropped.
Action: Restore a current copy of the data file and do recovery as needed.
ORA-01203: wrong incarnation of this file - wrong creation SCN
Cause: The creation SCN in the file header is not the same as the creation SCN in the controlfile. This is probably a copy of a file that was dropped.
Action: Restore a current copy of the data file and do recovery as needed.
ORA-01204: file number is string rather than string - wrong file
Cause: The file number in the file header is not correct. This is probably a restored backup of the wrong file, but from the same database.
Action: Restore a copy of the correct data file and do recovery as needed.
ORA-01205: not a data file - type number in header is string
Cause: The file type in the header is not correct for a data file. This is probably a log file or controlfile. If the type is not a small non-zero positive number then the header is corrupted.
Action: Restore a copy of the correct data file and do recovery as needed.
ORA-01206: file is not part of this database - wrong database id
Cause: The database ID in the file header does not match the database id in the controlfile. The file may be from a different database, or it may not be a database file at all. If the database was rebuilt, this may be a file from before the rebuild. Note that if you see this error when the file is supposed to be plugged in from another database via the Transportable Tablespace feature, it means the database ID in the file header does not match the one expected.
Action: Restore a copy of the correct data file and do recovery as needed.
ORA-01207: file is more recent than controlfile - old controlfile
Cause: The controlfile change sequence number in the data file is greater than the number in the controlfile. This implies that the wrong controlfile is being used. Note that repeatedly causing this error can make it stop happening without correcting the real problem. Every attempt to open the database will advance the controlfile change sequence number until it is great enough.
Action: Use the current controlfile or do backup controlfile recovery to make the controlfile current. Be sure to follow all restrictions on doing a backup controlfile recovery.
ORA-01208: data file is an old version - not accessing current version
Cause: The checkpoint in the file header is less recent than in the control file. If opening a database that is already open by another instance, or if another instance just brought this file online, the file accessed by this instance is probably a different version. Otherwise, a backup of the file probably was restored while the file was in use.
Action: Make the correct file available to the database. Then, either open the database, or execute ALTER SYSTEM CHECK DATAFILES.
ORA-01209: data file is from before the last RESETLOGS
Cause: The reset log data in the file header does not match the control file. If the database is closed or the file is offline, the backup is old because it was taken before the last ALTER DATABASE OPEN RESETLOGS command. If opening a database that is open already by another instance, or if another instance just brought this file online, the file accessed by this instance is probably a different version. Otherwise, a backup of the file probably was restored while the file was in use.
Action: Make the correct file available to the database. Then, either open the database, or execute ALTER SYSTEM CHECK DATAFILES.
ORA-01210: data file header is media corrupt
Cause: The file header block is internally inconsistent. The beginning of the block has a header with a checksum and other data for insuring the consistancy of the block. It is possible that the last disk write did not operate correctly. The most likely problem is that this is not a datafile for any database.
Action: Have operating system make correct file available to database. If the trace file dump indicates that only the checksum is wrong, restore from a backup and do media recovery.
ORA-01211: Oracle7 data file is not from migration to Oracle8
Cause: The file is not a copy of the file LAST used under Oracle7. This datafile is either a backup taken from before the migration, or the database was opened by Oracle7 after the migration utility was run. When converting a database from Oracle7 to Oracle8, the migration program MUST be the LAST utility to access the database under Oracle7. Only the datafiles that were current when the migration was done may be accessed by Oracle8.
Action: Have operating system make correct data file available to database, or repeat the Oracle7 to Oracle8 migration. Make sure that database is NOT opened after migration utility is run.
ORA-01212: MAXLOGMEMBERS may not exceed string
Cause: MAXLOGMEMBERS specified on the command line too large.
Action: Resubmit the command with a smaller MAXLOGMEMBERS
ORA-01213: MAXINSTANCES may not exceed string
Cause: MAXINSTANCES specified on the command line too large.
Action: Resubmit the command with a smaller MAXINSTANCES
ORA-01214: MAXLOGHISTORY may not exceed string
Cause: MAXLOGHISTORY specified on the command line too large.
Action: Resubmit the command with a smaller MAXLOGHISTORY
ORA-01215: enabled thread string is missing after CREATE CONTROLFILE
Cause: A CREATE CONTROLFILE statement was given which did not list all the enabled threads for the database.
Action: Reissue the CREATE CONTROLFILE statement, including all enabled threads.
ORA-01216: thread string is expected to be disabled after CREATE CONTROLFILE
Cause: A thread that was given during CREATE CONTROLFILE is enabled, but the datafiles indicate that it should be disabled. This is probably because the logs supplied to the CREATE CONTROLFILE are old (from before the disabling of the thread).
Action: This thread is not required to run the database. The CREATE CONTROLFILE statement can be reissued without the problem thread, and, if desired, the thread can be recreated after the database is open.
ORA-01217: logfile member belongs to a different logfile group
Cause: A member of a multiple-member logfile group specified in a CREATE CONTROLFILE is not part of the same group as previous members.
Action: Group together the correct members for the CREATE CONTROLFILE command.
ORA-01218: logfile member is not from the same point-in-time
Cause: A member of a multiple-member logfile group is from a different point in time. One of the members specified may be an older (backup) copy of the log.
Action: Find the correct version of the log, or leave it out of the CREATE CONTROLFILE command.
ORA-01219: database not open: queries allowed on fixed tables/views only
Cause: A query was issued against an object not recognized as a fixed table or fixed view before the database has been opened.
Action: Re-phrase the query to include only fixed objects, or open the database.
ORA-01220: file based sort illegal before database is open
Cause: A query issued against a fixed table or view required a temporary segment for sorting before the database was open. Only in-memory sorts are supported before the database is open.
Action: Re-phrase the query to avoid a large sort, increase the values of the SORT_AREA_SIZE and/or SORT_AREA_RETAINED_SIZE initialization parameters to enable the sort to be done in memory.
ORA-01221: data file string is not the same file to a background process
Cause: When the database writer opens the data file, it is accessing a different physical file than the foreground doing the recovery. The timestamp set in the file header by the foreground was not found by the background. It may be that the background process could not read the file at all.
Action: Look in the DBWR trace file for the error it recieved when attempting to read the file header. Reconfigure the operating system as needed to have the file name successfully access the same file when opened by a background process.
ORA-01222: MAXINSTANCES of string requires MAXLOGFILES be at least string, not string
Cause: Attemping to create a database or controlfile that does not have room for at least two logs per thread of redo. A thread of redo must have two online logs in order to be enabled. It does not make sense to allow more redo threads than can be supported by the logs.
Action: Either reduce the MAXINSTANCES argument or increase MAXLOGFILES.
ORA-01223: RESETLOGS must be specified to set a new database name
Cause: The SET database name option was specified to CREATE CONTROLFILE, but RESETLOGS was not specified. The database name can only be changed when opening the database with RESETLOGS.
Action: Either add the RESETLOGS option or drop the SET option to CREATE CONTROLFILE.
ORA-01224: group number in header string does not match GROUP string
Cause: Group number specified at CREATE CONTROLFILE does not match the group number stored in the header. Most likely the specification is wrong.
Action: Omit the GROUP option or give the correct one.
ORA-01225: thread number string is greater than MAXINSTANCES string
Cause: The log is for a thread greater than the MAXINSTANCES argument.
Action: Increase the value for MAXINSTANCES and resubmit the command.
ORA-01226: file header of log member is inconsistent with other members
Cause: The log file member in the accompanying error is for the same group as the previous members, but other fields in the header are different. Either a file header is corrupted, or some file is a member of a deleted log.
Action: Find the correct log member or omit this member from the command.
ORA-01227: log string is inconsistent with other logs
Cause: The log file in the accompanying error is inconsistent with the contents of other logs given in the CREATE CONTROLFILE command. Either a file header is corrupted, or some file is an old copy rather than the current version. The problem may not be with the log listed since all that can be detected is that there is an inconsistancy. All log files listed in the command must be the current versions of the online logs.
Action: Find the correct online logs or use the RESETLOGS option.
ORA-01228: SET DATABASE option required to install seed database
Cause: The SET DATABASE option was not included in the CREATE CONTROLFILE command when installing a seed database. The database does not have a database ID because it is intended to be installed at multiple sites, and each site needs to be a different database with its own database id. Both the SET DATABASE and RESETLOGS options must be specified to create the controlfile for this database.
Action: Resubmit command with the SET DATABASE and RESETLOGS options.
ORA-01229: data file string is inconsistent with logs
Cause: The data file in the accompanying error is inconsistent with the contents of the logs given in the CREATE CONTROLFILE command. The most likely cause is that one or more of the online logs was missing from the command. It is also possible that one or more of the logs is an old copy rather than the current version. All online log files must be listed in the command and must be the current versions of the online logs.
Action: Find the correct online logs or use the RESETLOGS option.
ORA-01230: cannot make read only - file string is offline
Cause: An attempt to make a tablespace read only found that one of its files is offline.
Action: Bring the file online and retry this command.
ORA-01231: cannot make read write - file string is offline
Cause: An attempt to make a tablespace read write found that one of its files is offline.
Action: Bring the file online and retry this command.
ORA-01232: cannot start online backup - file string is being made read-only
Cause: An attempt to start an online backup found that one of the files is in transition to read-only mode.
Action: Wait for the transition to complete and then retry the command, if this is an ALTER DATABASE BEGIN BACKUP command, or take the backup without any begin or end commands, if this is an ALTER TABLESPACE BEGIN BACKUP command.
ORA-01233: file string is read only - cannot recover using backup controlfile
Cause: An attempt to do media recovery using a backup controlfile found that one of the files is marked read only. Read only files do not normally need to be recovered, but recovery with a backup controlfile must recover all online files.
Action: If the file really is read only, take it offline before the recovery, and bring the read only tablespace online after the database is open. If the file does need recovery use a controlfile from the time the file was read-write. If the correct controlfile is not available, use CREATE CONTROLFILE to make one.
ORA-01234: cannot end backup of file string - file is in use or recovery
Cause: Attempted to end an online backup of file when the file is busy. Some operation such as recovery or rename may be active, or there may still be some instance that has the database open with this file online.
Action: If there is an instance with the database open then the backup can be ended there by using the ALTER TABLESPACE command. Otherwise wait for the completion of the other operation.
ORA-01235: END BACKUP failed for string file(s) and succeeded for string
Cause: One or more of the files in an end backup command failed. Some other files given in the same command may have succeeded.
Action: See the accompanying error messages for the reason the backups could not be ended. Any files not listed in the error messages were successful.
ORA-01236: Error string occurred during initialization of file header access
Cause: The indicated error occurred while doing initialization processing of file headers.
Action: The error indicated should be corrected. An attempt is made to recover from this error by using a slower access algorithm.
ORA-01237: cannot extend datafile string
Cause: An operating system error occurred during the resize.
Action: Fix the cause of the operating system error and retry the command.
ORA-01238: cannot shrink datafile string
Cause: An operating system error occurred during the resize.
Action: The error is ignored, operation continues normally.
ORA-01239: database must be in ARCHIVELOG mode to use external cache
Cause: An online file uses an external cache, but the database is in NOARCHIVELOG mode. Since an external cache may require media recovery this can not be allowed.
Action: Change database to be in ARCHIVELOG mode or do not use an external cache.
ORA-01240: too many data files to add in one command
Cause: The command specifies adding more data files than can be done in one command. It is necessary to fit all the file names into one log entry, but that would make the entry too large.
Action: If this is a CREATE TABLESPACE command, create with fewer files then add the other files later. If this is an ADD DATAFILE command, break it up into multiple commands.
ORA-01241: an external cache has died
Cause: The external cache may have been restarted.
Action: Take the file mentioned in the error stack offline, perform media recovery, bring the file online, and retry the attempted operation. You may also restart all instances to make sure they access all data files through consistent external caches.
ORA-01242: data file suffered media failure: database in NOARCHIVELOG mode
Cause: The database is in NOARCHIVELOG mode and a database file was detected as inaccessible due to media failure.
Action: Restore accessibility to the file mentioned in the error stack and restart the instance.
ORA-01243: system tablespace file suffered media failure
Cause: A system tablespace file was detected as inaccessible due to media failure.
Action: Restore accessibility to the file mentioned in the error stack and restart the instance.
ORA-01244: unnamed datafile(s) added to controlfile by media recovery
Cause: Media recovery with a backup controlfile or a controlfile that was rebuilt, encountered the creation of a datafile that was not in the controlfile. An entry has been added to the controlfile for the new datafiles, but with the file name UNNAMEDnnnn, where nnnn is the file number. Attached errors describe the file names that were originally used to create the files.
Action: Rename the files to valid file names and resume recovery. If necessary the command ALTER DATABASE CREATE DATAFILE may be used to create a file suitable for recovery and do the rename. If the file is not going to be recovered then take it offline with the FOR DROP option.
ORA-01245: offline file string will be lost if RESETLOGS is done
Cause: Attempting to do an OPEN RESETLOGS with a file that will be lost because it is offline. The file was not taken offline with the FOR DROP option.
Action: Either bring the file online and recover it, or take it offline with the FOR DROP option.
ORA-01246: recovering files through TSPITR of tablespace string
Cause: The files named in the accompanying errors are backups that were made before a tablespace point in time recovery of this tablespace. They cannot be recovered to a time after the point in time recovery.
Action: Restore more recent backups and recover them.
ORA-01247: database recovery through TSPITR of tablespace string
Cause: Recovery of the whole database encountered redo indicating there was a point in time recovery of the tablespace. The new version of the files in the tablespace should be included in the recovery, but that was not done.
Action: If the tablespace should not be recovered, take its file offline for drop. If it should be recovered, then restore or rename as needed and restart the recovery.
ORA-01248: file string was created in the future of incomplete recovery
Cause: Attempting to do a RESETLOGS open with a file entry in the controlfile that was originally created after the UNTIL time of the incomplete recovery. Allowing such an entry may hide the version of the file that is needed at this time. The file number may be in use for a different file which would be lost if the RESETLOGS was allowed.
Action: If more recovery is desired then apply redo until the creation time of the file is reached. If the file is not wanted and the same file number is not in use at the stop time of the recovery, then the file can be taken offline with the FOR DROP option. Otherwise a different controlfile is needed to allow the RESETLOGS. Another backup can be restored and recovered, or a controlfile can be created via CREATE CONTROLFILE.
ORA-01249: archiving not allowed in a clone database
Cause: Attempting to archive an online redo log or enable archiving for a clone database.
Action: Do not attempt to archive from a clone. The archive log destination could easily be the same as the primary database destroying its archived logs. If archiving is needed then recreate database as not a clone.
ORA-01250: Error string occurred during termination of file header access
Cause: The indicated error occurred while terminating the processing of file headers. The error was other than a write error.
Action: The indicated error should be corrected.
ORA-01251: Unknown File Header Version read for file number string
Cause: Read of the file header returned a record but its version cannot be identified. Either the header has been corrupted, or the file is not a valid database file.
Action: Have the operating system make the correct file available to the database, or recover the file.
ORA-01252: cannot prevent writes - file string in recovery manager backup
Cause: An attempt to make a tablespace read only or offline normal found that a recovery manager proxy backup is in progress. If the file is made offline or read-only, then the file header cannot be updated when the backup is complete.
Action: Wait for the Recovery Manager backup to complete and retry this command.
ORA-01253: cannot start online backup - file string in recovery manager backup
Cause: The specified file is being backed up by Recovery Manager.
Action: Wait for the Recovery Manager proxy backup to complete before starting another backup.
ORA-01254: cannot end online backup - file string in recovery manager backup
Cause: The specified file is being backed up by Recovery Manager.
Action: Wait for the Recovery Manager proxy backup to complete. Recovery Manager backup mode cannot be initiated or terminated manually.
ORA-01255: cannot shutdown - file string in recovery manager backup
Cause: An attempt to shutdown normally found that a Recovery Manager backup is still in progress.
Action: Wait for the Recovery Manager proxy backup to complete and retry this command.
ORA-01256: error in locking database file string
Cause: The file is in use by another database instance.
Action: Determine which database instance legitimately owns the file.
ORA-01257: cannot reuse database file string, unknown file size
Cause: The size of the raw partion cannot be determined
Action: Add the datafile/logfile by specifying the size parameter.
ORA-01258: unable to delete temporary file string
Cause: A DROP TABLESPACE INCLUDING CONTENTS AND DATAFILES or ALTER DATABASE TEMPFILE DROP INCLUDING DATAFILES operation was not able to delete a temporary file in the database.
Action: Subsequent errors describe the operating system error that prevented the file deletion. Fix the problem, if possible, and manually purge the file.
ORA-01259: unable to delete datafile string
Cause: A DROP TABLESPACE INCLUDING CONTENTS AND DATAFILES operation was not able to delete a datafile in the tablespace.
Action: Subsequent errors describe the operating system error that prevented the file deletion. Fix the problem, if possible, and manually purge the file.
ORA-01260: warning: END BACKUP succeeded but some files found not to be in backup mode
Cause: END BACKUP completed successfully for all files that were in online backup mode. However one or more modifiable files were found not to be in online backup mode. Backup of those files (if it was done) can be invalid and, if restored, can result in an inconsistent database.
Action: Check the alert log for a list of the files that were found not to be in backup mode. If there is a possibility that those files have been modified during online backup, then replace their backups with new ones.
ORA-01261: Parameter string destination string cannot be translated
Cause: The value for the specified parameter contained a destination string that could not be translated.
Action: Use a valid destination string in the specified parameter.
ORA-01262: Stat failed on a file destination directory
Cause: Unable to get information about an Oracle managed files destination directory.
Action: Check the permissions on the directory or use a different directory name.
ORA-01263: Name given for file destination directory is invalid
Cause: The name given for an Oracle managed files destination does not correspond to a directory.
Action: Use a different name.
ORA-01264: Unable to create string file name
Cause: Unable to create an Oracle managed file name.
Action: , if possible, and retry the command.
ORA-01265: Unable to delete string string
Cause: An error prevented the file from being deleted.
Action: See the subsequent error messsages that describe the operating system error that prevented the file from being deleted. If possible, fix the problem and manually delete the file.
ORA-01266: Unable to create unique file name
Cause: Unable to create a unique file name for an Oracle managed file. Oracle tried several names but each file name was already in use in the default destination directory for the file type.
Action: Retry the operation. If that fails, also, it may be necessary to change the default destination directory for the file type and then retry.
ORA-01267: Failure getting date/time
Cause: Could not get date/time when trying to create unique file name.
Action: Internal error - contact Oracle Customer Support.
ORA-01268: invalid TEMPFILE clause for alter of permanent TABLESPACE
Cause: A TEMPFILE clause was specified for an ALTER TABLESPACE for a permanent tablespace.
Action: Retry with a DATAFILE clause.
ORA-01269: Destination parameter string is too long
Cause: The value for DB_CREATE_FILE_DEST, DB_CREATE_ONLINE_LOG_DEST_n or DB_RECOVERY_FILE_DEST parameter was too long.
Action: Replace the destination value for the specified parameter with a shorter character string.
ORA-01270: %s operation is not allowed if STANDBY_PRESERVES_NAMES is true
Cause: An operation that renames or adds/drops a file was attempted at a standby database and STANDBY_PRESERVES_NAMES is true.
Action: Set STANDBY_PRESERVES_NAMES false if the operation must be performed.
ORA-01271: Unable to create new file name for file string
Cause: During standby database recovery an error occurred when trying to create a new file name for the indicated file.
Action: Use the ALTER DATABASE CREATE DATAFILE command with a new unique name and then resume the standby database recovery.
ORA-01272: REUSE only allowed when a file name is provided.
Cause: The REUSE parameter was specified in a command without a file name.
Action: Either supply a file name or remove the REUSE parameter.
ORA-01273: STANDBY_FILE_MANAGEMENT = AUTO needs COMPATIBLE = string or higher
Cause: Automated standby file management was disabled, so an added file
Action: Restart the instance with COMPATIBLE set to the correct release.
ORA-01274: cannot add datafile 'string' - file could not be created
Cause: Automated standby file management was disabled, so an added file could not automatically be created on the standby. The error from the creation attempt is displayed in another message. The controlfile file entry for the file is 'UNNAMEDnnnnn'.
Action: Use the ALTER DATABASE CREATE DATAFILE statement to create the file, or set STANDBY_FILE_MANAGEMENT to AUTO and restart standby recovery.
ORA-01275: Operation string is not allowed if standby file management is automatic.
Cause: An operation that renames, adds, or drops a file was attempted at a standby database and STANDBY_FILE_MANAGEMENT was set to AUTO.
Action: Set STANDBY_FILE_MANAGEMENT to MANUAL if the operation must be performed.
ORA-01276: Cannot add file string. File has an Oracle Managed Files file name.
Cause: An attempt was made to add to the database a datafile, log file, control file, snapshot controlfile, backup controlfile, datafile copy, controlfile copy or backuppiece with an Oracle Managed Files file name.
Action: Retry the operation with a new file name.
ORA-01277: file 'string' already exists
Cause: An ALTER DATABASE BACKUP CONTROLFILE TO TRACE AS 'filename' command specified a file name which is already in use.
Action: Either specify a different file name, or add the REUSE parameter to the command to overwrite the existing file.
ORA-01278: error creating file 'string'
Cause: An operating system error occurred while attempting to create a trace file specified in the command ALTER DATABASE BACKUP CONTROLFILE TO TRACE AS 'filename'.
Action: Check the error stack for more detailed information.
ORA-01279: db_files too large
Cause: db_files has been set too high to be supported by the system.
Action: Decrease the number of db_files.
ORA-01280: Fatal LogMiner Error.
Cause: An internal error has occurred inside LogMiner.
Action: none
ORA-01281: SCN range specified is invalid
Cause: StartSCN may be greater than EndSCN, or the SCN specified may be invalid.
Action: Specify a valid SCN range.
ORA-01282: date range specified is invalid
Cause: startTime may be greater than endTime. startTime or endTime may be greater than year 2110. startTime may be less than year 1988.
Action: Specify a valid date range.
ORA-01283: Options specified is invalid
Cause: The specified options parameter is invalid for the procedure.
Action: Specify valid Options parameter.
ORA-01284: file string cannot be opened
Cause: The file or directory may not exist or may be inaccessible. Pathname exceeds 256 characters.
Action: Ensure that the file and the directory exist and are accessible.
ORA-01285: error reading file string
Cause: The file or directory may not exist or is inaccessible.
Action: Specify valid file or directory. Make sure that file and directory are accessible.
ORA-01286: start interval required
Cause: Options were supplied which require a starting time or starting SCN
Action: Specify a starting interval (time or SCN).
ORA-01287: file string is from a different database incarnation
Cause: The logfile is produced by a different incarnation of the database.
Action: Add a logfile that is produced by the same incarnation.
ORA-01288: file string is from a different database incarnation
Cause: The logfile is produced by a different incarnation of the database.
Action: Add a logfile that is produced by the same incarnation.
ORA-01289: cannot add duplicate logfile string
Cause: The logfile specified has already been added to the list of logfiles.
Action: Specify a different logfile.
ORA-01290: cannot remove unlisted logfile string
Cause: The user attempted to remove a logfile that is not present in the list.
Action: Specify a valid logfile.
ORA-01291: missing logfile
Cause: Not all logfiles corresponding to the time or scn range specified have been added to the list.
Action: Check the v$logmnr_logs view to determine the missing scn range, and add the relevant logfiles.
ORA-01292: no log file has been specified for the current LogMiner session
Cause: No logfile has been specified for the LogMiner session.
Action: Specify atleast one log file.
ORA-01293: mounted database required for specified LogMiner options
Cause: Options were specified which required the database to be mounted
Action: Specify different options or mount the database.
ORA-01294: error occurred while processing information in dictionary file string, possible corruption
Cause: The dictionary file is corrupt.
Action: Get a new dictionary file.
ORA-01295: DB_ID mismatch between dictionary string and logfiles
Cause: The dictionary file is produced by a database that is different from that produced the logfiles.
Action: Specify a compatible dictionary file.
ORA-01296: character set mismatch between dictionary string and logfiles
Cause: The character set of the database that produced the dictionary file is different from the charatcter set of the database that produced the logfiles.
Action: Specify a dictionary file with the same character set.
ORA-01297: redo version mismatch between dictionary string and logfiles
Cause: The redo version of the database generating the dictionary is different from the one generating the logfiles.
Action: none
ORA-01298: conflicting dictionary option
Cause: More than one dictionary source was specified or DDL_DICT_TRACKING was specified with DICT_FROM_ONLINE_CATALOG.
Action: none
ORA-01299: dictionary string corresponds to a different database incarnation
Cause: The dictionary file was extracted from a different incarnation of the database.
Action: Specify a dictionary file extracted from the correct database incarnation.
ORA-01300: writable database required for specified LogMiner options
Cause: Options were specified which required the database to be writable.
Action: Specify different options or open the database for write access.
ORA-01301: error writing to file during flat file build
Cause: Error writing to file during flat file build
Action: none
ORA-01302: dictionary build options missing or incorrect
Cause: Missing dictionary build options or incorrectly specified options
Action: Specify either a build to redo log or to flat file. If build to flat file, specify filename and directory.
ORA-01303: subordinate process error: number. Check alert and trace logs
Cause: A process subordinate to this Logminer process has exited with this error status.
Action: Search for this error in the alert log and trace files for additional information.
ORA-01304: subordinate process error. Check alert and trace logs
Cause: A process subordinate to this Logminer process has exited with an error condition.
Action: Look in the alert log and trace files for additional information.
ORA-01306: dbms_logmnr.start_logmnr() must be invoked before selecting from v$logmnr_contents
Cause: A select was issued from v$logmnr_contents without first invoking the dbms_logmnr.start_logmnr() procedure.
Action: Invoke the dbms_logmnr.start_logmnr() procedure before issuing a select from the v$logmnr_contents view.
ORA-01307: no LogMiner session is currently active
Cause: A select was issued from v$logmnr_contents without first invoking the dbms_logmnr.start_logmnr() procedure. Otherwise, dbms_logmnr.end_logmnr() was called without a prior call to dbms_logmnr.start_logmnr() or dbms_logmnr.add_logfile()
Action: Invoke the dbms_logmnr.start_logmnr() procedure before issuing a select from the v$logmnr_contents view.
ORA-01308: initialization parameter utl_file_dir is not set
Cause: utl_file_dir is not set in the initialization file.
Action: Set utl_file_dir to the appropriate directory.
ORA-01309: invalid session
Cause: The specified Logminer session ID or session handle is invalid.
Action: Use a valid Logminer session ID or session handle.
ORA-01310: requested return type not supported by the lcr_mine function
Cause: The return type requested by the user is not supported by lcr_mine"
Action: Pick a return type supported by the lcr_mine function"
ORA-01311: Illegal invocation of the mine_value function
Cause: An attempt was made to use mine_value function on a column other than redo_value or undo_value columns of SYS.X$LOGMNR_CONTENTS or SYS.V$LOGMNR_CONTENTS fixed table/view.
Action: Rewrite the SQL statement with a legal invocation of mine_value
ORA-01312: Specified table/column does not exist
Cause: The table/column specified in the lcr_mine call does not exist at the the specified SCN. The table/column definition has to exist at the start SCN specified for lcr_mine to be able to identify the table/column correctly.
Action: Create a LogMiner session at a start SCN at which the table definition is available.
ORA-01313: LogMiner dictionary column type different from specified type
Cause: The return type specified for the column in lcr_mine call is different from the actual type of the column.
Action: Rewrite the lcr_mine invocation with the right return type.
ORA-01314: Name of the column to be mined should be a string literal
Cause: The fully qualified name of the column to be mined by the LogMiner functions should be string literal.
Action: If the fully qualified name of the column to be mined is a.b.c.d, enclose the column name in quotes as in 'a.b.c.d'.
ORA-01315: Log file has been added or removed during select
Cause: A redo log file has been added or removed while selecting on the v$logmnr_logs fixed view.
Action: Re-issue the SQL select statement on the v$logmnr_logs view.
ORA-01316: Already attached to a Logminer session
Cause: A Logminer attach session was issued while already attached to a Logminer session.
Action: Detach from the current Logminer session and attach to the requested session.
ORA-01317: Not attached to a Logminer session
Cause: A command or procedure was issued which requires an attached Logminer session.
Action: Attach to a Logminer session before issuing the command or procedure.
ORA-01319: Invalid Logminer session attribute
Cause: A session attribute was supplied which is invalid.
Action: Re-issue with valid session attribute.
ORA-01320: Invalid Logminer dictionar attribute
Cause: A Logminer dictionary attribute was supplied which is invalid.
Action: Re-issue with valid dictionary attribute.
ORA-01322: No such table
Cause: An non-existent table was supplied to Logminer include_src_tbl() or exclude_src_table().
Action: Re-issue with valid table name.
ORA-01323: Invalid state
Cause: A Logminer routine was called from the wrong state.
Action: none
ORA-01324: cannot add file string due to DB_ID mismatch
Cause: The logfile is produced by a different database than other logfiles already added to the list.
Action: Specify a logfile produced by the same database.
ORA-01325: archive log mode must be enabled to build into the logstream
Cause: Database does not have archivelog mode enabled.
Action: Mount the database, then issue commands to enable archivelog mode. startup pfile=init.ora mount alter database archivelog alter database open
ORA-01326: compatability of 9.0 or greater required to build into the logstream
Cause: Compatibility mode set to some value less than 9.0
Action: Ensure that init.ora parameter establishing a compatability of 9.0 or greater is set. For example: compatible=9.0.0.0.0
ORA-01327: failed to exclusively lock system dictionary as required by build
Cause: Other users are performing DDL operations.
Action: none
ORA-01328: only one build operation may occur at one time
Cause: Another processes is simultaneously attempting to run build();
Action: Wait until the other processes completes.
ORA-01329: unable to truncate require build table
Cause: The table may be missing, or locked by another user.
Action: none
ORA-01332: internal Logminer Dictionary error
Cause: Unexpected error condition
Action: Check trace and/or alert logs
ORA-01333: failed to establish Logminer Dictionary
Cause: No previously established Logminer Dictionary is available and a complete gather of a source system data dictionary was not found in the logstream. build() may not have been run to force the gathering of a source system data dictiony. Or add_log_file() may not have been called to add all log files which contain the complete gathered system data dictionary.
Action: If build() was not employed prior to this mining session the Logminer Ad Hoc user may elect to employ an alternate dictionary such as the current system catalog or a previously built flat file dictionary. Other Logminer clients must run build() prior to mining. If build() has been run, ensure that all logfiles which comprise the gathered system dictionary have beed added. The following query, run on the system which build() was run, can be helpful in identifying the requried files. select DICTIONARY_BEGIN, DICTIONARY_END, name from v$archived_log; Minimally a set of files beginning with one which has DICTIONARY_BEGIN = 'YES' and all following log files through one marked DICTIONARY_END = 'YES' must be added.
ORA-01334: invalid or missing logminer dictionary processes context
Cause: Unexpected internal error condition
Action: none
ORA-01336: specified dictionary file cannot be opened
Cause: The dictionary file or directory does not exist or is inaccessible.
Action: Make sure that the dictionary file and directory exist and are accessible.
ORA-01337: log file has a different compatibility version
Cause: The logfile has a different compatibility version then the rest of the logfile in the session"
Action: Make sure that the logfile has the same compatibility version as the rest of the logfiles in the session.
ORA-01338: Other process is attached to LogMiner session
Cause: Can not do this when other process is attached to LogMiner session.
Action: none
ORA-01339: logfile is too old
Cause: Attempt to add an already processed logfile.
Action: none
ORA-01340: NLS error
Cause: Could not load NLS package.
Action: none
ORA-01341: LogMiner out-of-memory
Cause: The logfiles to be analyzed in the current LogMiner session require more system resources than what is currently available.
Action: Reduce the number of logfiles to be analyzed for a given LogMiner session and try again.
ORA-01342: LogMiner can not resume session due to inability of staging checkpointed data
Cause: Logmnr can not resume session because there is not enough SGA memory available to read in checkpointed data. Logminer periodically checkpoints data to enable faster crash recovery.
Action: Specify a bigger max_sga for the given LogMiner session and try again.
ORA-01343: LogMiner encountered corruption in the logstream
Cause: Log file is missing a range of scn values.
Action: Verify the contiguity of the scn range reprented by the log files added to LogMiner.
ORA-01344: LogMiner coordinator already attached
Cause: A coordinator process is already attached to the specified logminer context.
Action: Detach from the active coordinator session and retry the attach.
ORA-01345: Supplemental log data must be enabled to build into the logstream
Cause: Supplemental log data must be enabled on this database instance.
Action: Enable supplemental log data.
ORA-01346: Dependent LogMiner sessions relying on supplementally logged data exist
Cause: LogMiner sessions exist on this database instance which rely on the existance of supplemental log data.
Action: Destroy all LogMiner sessions on this instance which are mining log files from this same instance then reissue the command.
ORA-01347: Supplemental log data no longer found
Cause: The source database instance producing log files for this LogMiner session was altered to no longer log supplemental data.
Action: Destroy this Logminer session. Re-enable supplemental log data on the source system and create a new LogMiner session.
ORA-01350: must specify a tablespace name
Cause: Invocation failed to specify a valid tablespace
Action: Reformat invocation of DBMS_LOGMNR_D.SET_TABLESPACE to include the name of a valid tablespace.
ORA-01351: tablespace given for Logminer dictionary does not exist
Cause: The tablespace name given as a parameter to DBMS_LOGMNR_D.SET_TABLESPACE does not exist.
Action: Check spelling of the tablespace name. If spelling is correct verify that the named tablespace has already been created. DBMS_LOGMNR_D.SET_TABLESPACE does not create a tablespace.
ORA-01352: tablespace given for Logminer spill does not exist
Cause: The tablespace name given as the parameter to DBMS_LOGMNR_D.SET_TABLESPACE does not exist.
Action: Check spelling of the tablespace name. If spelling is correct verify that the named tablespace has already been created. DBMS_LOGMNR_D.SET_TABLESPACE does not create a tablespace.
ORA-01353: existing Logminer session
Cause: An attempt was made to execute DBMS_LOGMNR_D.SET_TABLESPACE while a Logminer session(s) was active.
Action: First cause all Logminer sessions to be closed. A Logminer session can exist as a result of executing DBMS_LOGMNR.START_LOGMNR or as the result of using Oracle features such as Data Guard SQL Apply or Streams which use Logminer. Next, execute DBMS_LOGMNR_D.SET_TABLESPACE.
ORA-01355: logminer tablespace change in progress
Cause: The tables used by logminer are in the process of being moved to another tablespace.
Action: Wait until the move is complete and try again.
ORA-01356: active logminer sessions found
Cause: Logminer sessions are currently active.
Action: End all logminer sessions and retry.
ORA-01370: Specified restart SCN is too old
Cause: specified restart scn is too old, logmnr could not find a proper checkpoint.
Action: Specify a bigger restart SCN to try again
ORA-01371: Complete LogMiner dictionary not found
Cause: One or more log files containing the LogMiner dictionary was not found.
Action: Add into LogMiner all log files containing the dictionary.
ORA-01372: Insufficient processes for specified LogMiner operation
Cause: The number of processes requested by the caller can not be allocated
Action: Increase number of parallel servers allocated to the instance
ORA-01373: insufficient memory for staging persistent LogMiner session
Cause: The maximum number of concurrent persistent LogMiner sessions allowed is limited by LOGMNR_MAX_PERSISTENT_SESSIONS parameter. Not enough memory has been set aside at instance startup to allocate the new LogMiner session.
Action: Increase LOGMNR_MAX_PERSISTENT_SESSIONS and restart instance.
ORA-01374: _log_parallelism_max greater than 1 not supported in this release
Cause: LogMiner does not mine redo records generated with log_parallelism set to a value greater than 1
Action: none
ORA-01409: NOSORT option may not be used; rows are not in ascending order
Cause: Creation of index with NOSORT option when rows were not ascending. For non-unique indexes the rowid is considered part of the index key. Therefore, if you create an index nosort and two of the rows in the table have the same key and are stored in ascending order, but get split accross two extents where the dba of the first block in the second extent is less than the dba of the last block in the first extent, then the create index nosort may fail.
Action: Create the index without the NOSORT option, or ensure table is stored in one extent.
ORA-01411: cannot store the length of column in the indicator
Cause: Tried to fetch a column of size more than 64K and couldn't store the length of the column in the given indicator of size 2 bytes.
Action: Use the new bind type with call backs to fetch the long column.
ORA-01412: zero length not allowed for this datatype
Cause: The length for type 97 is 0
Action: Specify the correct length.
ORA-01413: illegal value in packed decimal number buffer
Cause: The user buffer bound by the user as packed decimal number contained an illegal value.
Action: Use a legal value.
ORA-01414: invalid array length when trying to bind array
Cause: An attempt was made to bind an array without either a current array length pointer or a zero maximum array length.
Action: Sepcify a valid length.
ORA-01415: too many distinct aggregate functions
Cause: The query contains more distinct aggregates than can be processed. The current limit is 255.
Action: Reduce the number of distinct aggregate functions in the query.
ORA-01417: a table may be outer joined to at most one other table
Cause: a.b (+) = b.b and a.c (+) = c.c is not allowed
Action: Check that this is really what you want, then join b and c first in a view.
ORA-01422: exact fetch returns more than requested number of rows
Cause: The number specified in exact fetch is less than the rows returned.
Action: Rewrite the query or change number of rows requested
ORA-01424: missing or illegal character following the escape character
Cause: The character following the escape character in LIKE pattern is missing or not one of the escape character, '%', or '_'.
Action: Remove the escape character or specify the missing character.
ORA-01425: escape character must be character string of length 1
Cause: Given escape character for LIKE is not a character string of length 1.
Action: Change it to a character string of length 1.
ORA-01426: numeric overflow
Cause: Evaluation of an value expression causes an overflow/underflow.
Action: Reduce the operands.
ORA-01429: Index-Organized Table: no data segment to store overflow row-pieces
Cause: No overflow segment defined.
Action: Add overflow segment.
ORA-01451: column to be modified to NULL cannot be modified to NULL
Cause: the column may already allow NULL values, the NOT NULL constraint is part of a primary key or check constraint.
Action: if a primary key or check constraint is enforcing the NOT NULL constraint, then drop that constraint.
ORA-01453: SET TRANSACTION must be first statement of transaction
Cause: self-evident
Action: commit (or rollback) transaction, and re-execute
ORA-01456: may not perform insert/delete/update operation inside a READ ONLY transaction
Cause: A non-DDL insert/delete/update or select for update operation was attempted
Action: commit (or rollback) transaction, and re-execute
ORA-01463: cannot modify column datatype with current constraint(s)
Cause: An attempt was made to modify the datatype of column which has referential constraints; or has check constraints which only allows changing the datatype from CHAR to VARCHAR or vise versa.
Action: Remove the constraint(s) or do not perform the offending operation.
ORA-01466: unable to read data - table definition has changed
Cause: Query parsed after tbl (or index) change, and executed w/old snapshot
Action: commit (or rollback) transaction, and re-execute
ORA-01469: PRIOR can only be followed by a column name
Cause: Attempting to specify "PRIOR <something>" where <something> is not a column name.
Action: Only a column name can follow PRIOR. Replace with a column name.
ORA-01470: In-list iteration does not support mixed operators
Cause: Constants of different types are specified in an in-list.
Action: Use constants of same type for in-lists.
ORA-01478: array bind may not include any LONG columns
Cause: User is performing an array bind with a bind variable whose maximum size is greater than 2000 bytes.
Action: Such bind variables cannot participate in array binds. Use an ordinary bind operation instead.
ORA-01479: last character in the buffer is not Null
Cause: A bind variable of type 97 does not contain null at the last position
Action: Make the last character null
ORA-01480: trailing null missing from STR bind value
Cause: A bind variable of type 5 (null-terminated string) does not contain the terminating null in its buffer.
Action: Terminate the string with a null character
ORA-01481: invalid number format model
Cause: The user is attempting to either convert a number to a string via TO_CHAR or a string to a number via TO_NUMBER and has supplied an invalid number format model parameter.
Action: Consult your manual.
ORA-01482: unsupported character set
Cause: The character set used to perform the operation, such as the CONVERT function, is not a supported character set.
Action: Use one of the supported character sets.
ORA-01483: invalid length for DATE or NUMBER bind variable
Cause: A bind variable of type DATE or NUMBER is too long.
Action: Consult your manual for the maximum allowable length.
ORA-01484: arrays can only be bound to PL/SQL statements
Cause: You tried to bind an array to a non-PL/SQL statement.
Action: none
ORA-01485: compile bind length different from execute bind length
Cause: You bound a buffer of type DTYVCS (VARCHAR with the two byte length in front) and at execute time the length in the first two bytes is more than the maximum buffer length (given in the bind call). The number of elements in the array and the current number of elements in the array cannot be more than the maximum size of the array.
Action: none
ORA-01486: size of array element is too large
Cause: You tried to bind a data value which was either too large for the datatype (for example, NUMBER) or was greater than 4000 bytes (for example, VARCHAR or LONG).
Action: none
ORA-01487: packed decimal number too large for supplied buffer
Cause: An impossible request for decimal to oracle number conversion was made
Action: This conversion cannot be performed
ORA-01488: invalid nibble or byte in the input data
Cause: An impossible request for decimal to oracle number conversion was made
Action: This conversion cannot be performed
ORA-01489: result of string concatenation is too long
Cause: String concatenation result is more than the maximum size.
Action: Make sure that the result is less than the maximum size.
ORA-01490: invalid ANALYZE command
Cause: Incorrect syntax specified
Action: Retry the command
ORA-01491: CASCADE option not valid
Cause: The CASCADE option is only valid for tables or clusters.
Action: Do not specify CASCADE
ORA-01492: LIST option not valid
Cause: The LIST option is only valid for tables or clusters.
Action: Do not specify LIST
ORA-01493: invalid SAMPLE size specified
Cause: The specified SAMPLE size is out of range
Action: Specify a value within the proper range.
ORA-01494: invalid SIZE specified
Cause: The specified histogram SIZE value was out of range.
Action: Specify a value within the proper range.
ORA-01495: specified chain row table not found
Cause: The specified table either does not exist or user does not have the proper privleges.
Action: Specify the correct table to use.
ORA-01496: specified chain row table form incorrect
Cause: The specified table does not have the proper field definitions.
Action: Specify the correct table to use.
ORA-01497: illegal option for ANALYZE CLUSTER
Cause: The FOR COLUMNS <column-list> clause may not be used with ANALYZE CLUSTER.
Action: Retry with a legal syntax.


4 ORA-01500 to ORA-02098

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

4 ORA-01500 to ORA-02098

ORA-01500: failure in getting date/time
Cause: During create database or alter tablespace, there was a failure in getting the date and time.
Action: Contact your customer support representative.
ORA-01501: CREATE DATABASE failed
Cause: An error occurred during create database
Action: See accompanying errors.
ORA-01502: index 'string.string' or partition of such index is in unusable state
Cause: An attempt has been made to access an index or index partition that has been marked unusable by a direct load or by a DDL operation
Action: DROP the specified index, or REBUILD the specified index, or REBUILD the unusable index partition
ORA-01503: CREATE CONTROLFILE failed
Cause: An error occurred during CREATE CONTROLFILE
Action: See accompanying errors.
ORA-01504: database name 'string' does not match parameter db_name 'string'
Cause: The name in a database create or mount does not match the name given in the INIT.ORA parameter db_name.
Action: correct or omit one of the two names.
ORA-01505: error in adding log files
Cause: During create or alter database, error(s) occurred when adding new log files.
Action: Check error stack for detailed error information.
ORA-01506: missing or illegal database name
Cause: No db_name INIT.ORA aprameter was specified.
Action: The database name must be given in the db_name INIT.ORA parameter.
ORA-01507: database not mounted
Cause: A command was attempted that requires the database to be mounted.
Action: If you are using the ALTER DATABASE statement via the SQLDBA startup command, specify the MOUNT option to startup; else if you are directly doing an ALTER DATABASE DISMOUNT, do nothing; else specify the MOUNT option to ALTER DATABASE. If you are doing a backup or copy, you must first mount the desired database. If you are doing a FLASHBACK DATABASE, you must first mount the desired database.
ORA-01508: cannot create database; error in file 'string' at line string
Cause: CREATE DATABASE was unable to process the specified file.
Action: Check the offending line in the specified file.
ORA-01509: specified name 'string' does not match actual 'string'
Cause: The database name specified in ALTER DATABASE does not match the name of the currently mounted database.
Action: Correct the database name spelling or DISMOUNT the mounted database.
ORA-01510: error in deleting log files
Cause: During ALTER DATABASE, an error occurred while dropping log files.
Action: Check the error stack for detailed error information.
ORA-01511: error in renaming log/data files
Cause: An error occurred during the ALTER DATABASE RENAME FILE command.
Action: Check the error stack for detailed error information.
ORA-01512: error renaming log file string - new file string not found
Cause: An attempt to change a log file's name in the controlfile failed because no file was found with the new name.
Action: Make sure that the log file has been properly renamed by the operating system and retry.
ORA-01513: invalid current time returned by operating system
Cause: The operating system returned a time that was not between 1988 and 2121.
Action: Correct the time kept by the operating system.
ORA-01514: error in log specification: no such log
Cause: A log file name, or list of member names, did not correspond to an existing log.
Action: Specify an existing log file.
ORA-01515: error dropping log group string: no such log
Cause: ALTER DATABASE is attempting to drop a log file which is not known to the database controlfile.
Action: Specify the name of an existing log file.
ORA-01516: nonexistent log file, datafile, or tempfile "string"
Cause: An attempt was made to use ALTER DATABASE to rename a log file, datafile, or tempfile; or to change attributes of a datafile or tempfile (e.g., resize, autoextend, online/offline, etc.); or to re-create a datafile. The attempt failed because the specified file is not known to the database's control file or is not of a type supported by the request.
Action: Specify the name or number of an existing file of the correct type, as appropriate. Check the relevant V$ table for a list of possible files.
ORA-01517: log member: 'string'
Cause: Used to print member names
Action: See top level error for information
ORA-01518: CREATE DATABASE must specify more than one log file
Cause: Only one log file was specified in the CREATE DATABASE statement.
Action: Specify at least two log files.
ORA-01519: error while processing file 'string' near line string
Cause: CREATE DATABASE encountered a problem while processing specified file. The specified file is bad.
Action: Retry your system installation procedure or contact your customer support representative.
ORA-01520: number of data files to add (string) exceeds limit of string
Cause: CREATE TABLESPACE statement specifies more files than is permitted for this database.
Action: Use fewer files or re-create the database with a larger value of MAXDATAFILES.
ORA-01521: error in adding data files
Cause: During CREATE or ALTER TABLESPACE, an error was detected while adding data files.
Action: Check the error stack for detailed error information.
ORA-01522: file 'string' to be renamed does not exist
Cause: During ALTER TABLESPACE RENAME, a file to be renamed was not found in the database controlfile.
Action: Specify the correct file name.
ORA-01523: cannot rename data file to 'string' - file already part of database
Cause: During ALTER DATABASE RENAME or ALTER TABLESPACE RENAME, the new name of a file is already present in the controlfile.
Action: Rename the file to a name not already being used as part of the database.
ORA-01524: cannot create data file as 'string' - file already part of database
Cause: During ALTER DATABASE CREATE DATAFILE, the new name of a file is already present in the controlfile.
Action: Create the file as a name not already being used as part of the database.
ORA-01525: error in renaming data files
Cause: An error occurred when renaming files as part of ALTER TABLESPACE.
Action: Check the error stack for detailed information. All files are renamed except for those mentioned in the error stack.
ORA-01526: error in opening file 'string'
Cause: CREATE DATABASE was not able to open the specified file. This is probably due to a system installation error.
Action: Retry your system installation procedure or contact your customer support representative.
ORA-01527: error while reading file
Cause: CREATE DATABASE was not able to read the specified file. This is probably due to a system installation error.
Action: Retry your system installation procedure or contact your customer support representative.
ORA-01528: EOF while processing SQL statement
Cause: CREATE DATABASE unexpectedly hit EOF while reading the specified file. The sql.bsq file is bad.
Action: Retry your system installation procedure or contact your customer support representative.
ORA-01529: error closing file 'string'
Cause: CREATE DATABASE was not able to close the specified file.
Action: Retry your system installation procedure or contact your customer support representative.
ORA-01530: a database already mounted by the instance
Cause: During ALTER DATABASE MOUNT, an attempt is being made to mount a database on an instance in which a database is or has previously been mounted.
Action: If you wish to mount the database, shutdown the instance and then startup the instance and retry the operation.
ORA-01531: a database already open by the instance
Cause: During ALTER DATABASE, an attempt was made to open a database on an instance for which there is already an open database.
Action: If you wish to open a new database on the instance, first shutdown the instance and then startup the instance and retry the operation.
ORA-01532: cannot create database; instance being started elsewhere
Cause: During CREATE DATABASE, another user appears to be simultaneously altering the instance.
Action: Make sure no one else is simultaneously altering the instance. If no one is, contact your customer support representative; otherwise, retry the operation.
ORA-01533: cannot rename file 'string'; file does not belong to tablespace
Cause: During ALTER TABLESPACE RENAME, a file to be renamed was not found in the argument tablespace.
Action: Specify the correct file name or the correct tablespace name.
ORA-01534: rollback segment 'string' doesn't exist
Cause: During ALTER or DROP ROLLBACK SEGMENT, the specified rollback segment name is unknown.
Action: Use the correct rollback segment name.
ORA-01535: rollback segment 'string' already exists
Cause: Specified rollback segment already exists.
Action: Use a different name.
ORA-01536: space quota exceeded for tablespace 'string'
Cause: The space quota for the segment owner in the tablespace has been exhausted and the operation attempted the creation of a new segment extent in the tablespace.
Action: Either drop unnecessary objects in the tablespace to reclaim space or have a privileged user increase the quota on this tablespace for the segment owner.
ORA-01537: cannot add data file 'string' - file already part of database
Cause: During CREATE or ALTER TABLESPACE, a file being added is already part of the database.
Action: Use a different file name.
ORA-01538: failed to acquire any rollback segment
Cause: Failed to acquire any rollback segment during startup in shared mode
Action: Startup in exclusive mode to create one more public segment or specify available private segments in the INIT.ORA parameter rollback_segments_required, then startup in shared mode
ORA-01539: tablespace 'string' is not online
Cause: Failed to either make a tablespace read only or offline because it is not online. A tblespace must be online before it can become read only or offline normal.
Action: Check the status of the tablespace. Use IMMEDIATE or TEMPORARY options to force all files offline. Bring the tablespace online before making it read only.
ORA-01540: tablespace 'string' is not offline
Cause: Failed to bring a tablespace online because it is not offline
Action: Check the status of the tablespace
ORA-01541: system tablespace cannot be brought offline; shut down if necessary
Cause: Tried to bring system tablespace offline
Action: Shutdown if necessary to do recovery
ORA-01542: tablespace 'string' is offline, cannot allocate space in it
Cause: Tried to allocate space in an offline tablespace
Action: Bring the tablespace online or create the object in other tablespace
ORA-01543: tablespace 'string' already exists
Cause: Tried to create a tablespace which already exists
Action: Use a different name for the new tablespace
ORA-01544: cannot drop system rollback segment
Cause: Tried to drop system rollback segment
Action: None
ORA-01545: rollback segment 'string' specified not available
Cause: Either: 1) An attempt was made to bring a rollback segment online that is unavailable during startup; for example, the rollback segment is in an offline tablespace. 2) An attempt was made to bring a rollback segment online that is already online. This is because the rollback segment is specified twice in the ROLLBACK_SEGMENTS parameter in the initialization parameter file or the rollback segment is already online by another instance. 3) An attempt was made to drop a rollback segment that is currently online. 4) An attempt was made to alter a rollback segment that is currently online to use unlimited extents. 5) An attempt was made to online a rollback segment that is corrupted. This is because the rollback is specified in _corrupted_rollback_segments parameter in initialization parameter file.
Action: Either: 1) Make the rollback segment available; for example, bring an offline tablespace online. 2) Remove the name from the ROLLBACK_SEGMENTS parameter if the name is a duplicate or if another instance has already acquired the rollback segment. 3) Bring the rollback segment offline first. This may involve waiting for the active transactions to finish, or, if the rollback segment needs recovery, discover which errors are holding up the rolling back of the transactions and take appropriate actions. 4) Same as 3). 5) Remove the name from the _corrupted_rollback_segments parameter.
ORA-01546: tablespace contains active rollback segment 'string'
Cause: Tried to make a tablespace that contains active rollback segment(s) offline or read only
Action: Shutdown instances that use the active rollback segments in the tablespace and then make the tablespace offline or read only
ORA-01547: warning: RECOVER succeeded but OPEN RESETLOGS would get error below
Cause: Media recovery with one of the incomplete recovery options ended without error. However, if the ALTER DATABASE OPEN RESETLOGS command were attempted now, it would fail with the specified error. The most likely cause of this error is forgetting to restore one or more datafiles from a sufficiently old backup before executing the incomplete recovery.
Action: Rerun the incomplete media recovery using different datafile backups, a different controlfile, or different stop criteria.
ORA-01548: active rollback segment 'string' found, terminate dropping tablespace
Cause: Tried to drop a tablespace that contains active rollback segment(s)
Action: Shutdown instances that use the active rollback segments in the tablespace and then drop the tablespace
ORA-01549: tablespace not empty, use INCLUDING CONTENTS option
Cause: Tried to drop a non-empty tablespace
Action: To drop all the objects in the tablespace, use the INCLUDING CONTENTS option
ORA-01550: cannot drop system tablespace
Cause: Tried to drop system tablespace
Action: None
ORA-01551: extended rollback segment, pinned blocks released
Cause: Doing recursive extent of rollback segment, trapped internally by the system
Action: None
ORA-01552: cannot use system rollback segment for non-system tablespace 'string'
Cause: Tried to use the system rollback segment for operations involving non-system tablespace. If this is a clone database then this will happen when attempting any data modification outside of the system tablespace. Only the system rollback segment can be online in a clone database.
Action: Create one or more private/public segment(s), shutdown and then startup again. May need to modify the INIT.ORA parameter rollback_segments to acquire private rollback segment. If this is a clone database being used for tablspace point in time recovery then this operation is not allowed. If the non-system tablespace has AUTO segment space management, then create an undo tablespace.
ORA-01553: MAXEXTENTS must be no smaller than the string extents currently allocated
Cause: The number of extents allocated is greater than the MAXEXTENTS specified.
Action: Specify a larger MAXEXTENTS value.
ORA-01554: out of transaction slots in transaction tables
Cause: Too many concurrent transactions
Action: Shutdown the system, modify the INIT.ORA parameters transactions, rollback_segments or rollback_segments_required, then startup again
ORA-01555: snapshot too old: rollback segment number string with name "string" too small
Cause: rollback records needed by a reader for consistent read are overwritten by other writers
Action: If in Automatic Undo Management mode, increase undo_retention setting. Otherwise, use larger rollback segments
ORA-01556: MINEXTENTS for rollback segment must be greater than 1
Cause: Specified MINEXTENTS of less than 2 for rollback segment
Action: Specify larger MINEXTENTS
ORA-01557: rollback segment extents must be at least string blocks
Cause: Specified extent of less than minimum size for rollback segment
Action: Specify larger extents
ORA-01558: out of transaction ID's in rollback segment string
Cause: All the available transaction id's have been used
Action: Shutdown the instance and restart using other rollback segment(s), then drop the rollback segment that has no more transaction id's.
ORA-01559: MAXEXTENTS for rollback segment must be greater than 1
Cause: Specified MAXEXTENTS of less than 2 for rollback segment
Action: Specify larger MAXEXTENTS
ORA-01560: LIKE pattern contains partial or illegal character
Cause: like pattern is not formed correctly
Action: make sure like pattern is specified correctly
ORA-01561: failed to remove all objects in the tablespace specified
Cause: Failed to remove all objects when dropping a tablespace
Action: Retry the drop tablespace until all objects are dropped
ORA-01562: failed to extend rollback segment number string
Cause: Failure occurred when trying to extend rollback segment
Action: This is normally followed by another error message that caused the failure. You may take the rollback segment offline to perform maintainence. Use the alter rollback segment offline command to take the rollback segment offline.
ORA-01563: rollback segment is PUBLIC, need to use the keyword PUBLIC
Cause: Did not use the keyword PUBLIC to identified public rollback segment
Action: Use the keyword PUBLIC when identifying public rollback segment
ORA-01564: rollback segment is not PUBLIC
Cause: The rollback segment segment identified is not public
Action: Do not use the keyword PUBLIC when identifying private rollback segment
ORA-01565: error in identifying file 'string'
Cause: An error occurred while trying to identify a file.
Action: Check the error stack for detailed information.
ORA-01566: file specified more than once in DROP LOGFILE
Cause: The list of files supplied to DROP LOGFILE contains at least one duplicate.
Action: Remove the duplicate file specification and retry.
ORA-01567: dropping log string would leave less than 2 log files for instance string (thread string)
Cause: Dropping all the logs specified would leave fewer than the required two log files per enabled thread.
Action: Either drop fewer logs or disable the thread before deleting the logs. It may be possible to clear the log rather than drop it.
ORA-01568: cannot set space quota on PUBLIC
Cause: Trying to set space quota on a tablespace for PUBLIC.
Action: If trying to grant system-wide or tablespace-wide space priviledges to all users, use GRANT RESOURCE [ON <tablespace>] TO PUBLIC.
ORA-01569: data file too small for system dictionary tables
Cause: The datafile specified during creation of the database is too small to hold the system dictionary tables.
Action: Recreate the database by specifying a larger file or more files.
ORA-01570: MINEXTENTS must be no larger than the string extents currently allocated
Cause: The number of extents allocated is smaller than the MINEXTENTS specified.
Action: Specify a smaller MINEXTENTS value.
ORA-01571: redo version string incompatible with ORACLE version string
Cause: This software version can not read the current redo logs, and either crash recovery is required or there are offline database files that need media recovery. If a file name is listed then it needs media recovery.
Action: Shutdown and startup using the compatible software. Do any required media recovery, and open the database. Shutdown and then startup using current software. If the file is going to be dropped then take it offline with the DROP option to skip this check.
ORA-01572: rollback segment 'string' cannot be brought online, string extents exceeded
Cause: The number of extents in the rollback segment exceeds the hard limit. It cannot be brought online for writing.
Action: Drop and recreate the rollback segment.
ORA-01573: shutting down instance, no further change allowed
Cause: Some process tries to make changes while the db is being shutdown
Action: None
ORA-01574: maximum number of concurrent transactions exceeded
Cause: the limit on the number of concurrent transactions has been hit
Action: shutdown the system, increase the INIT.ORA parameter 'transactions' , and then restart the system.
ORA-01575: timeout waiting for space management resource
Cause: failed to acquire necessary resource to do space management.
Action: Retry the operation.
ORA-01576: The instance string is not enabled
Cause: The thread associated with instance is not enabled.
Action: Enable the thread associated with the instance using ALTER DATABASE ENABLE INSTANCE command.
ORA-01577: cannot add log file 'string' - file already part of database
Cause: During CREATE or ALTER DATABASE, a file being added is already part of the database.
Action: Use a different file name.
ORA-01578: ORACLE data block corrupted (file # string, block # string)
Cause: The data block indicated was corrupted, mostly due to software errors.
Action: Try to restore the segment containing the block indicated. This may involve dropping the segment and recreating it. If there is a trace file, report the errors in it to your ORACLE representative.
ORA-01579: write error occurred during recovery
Cause: A write error occurred during recovery
Action: Consult trace files for the nature of the write error, and correct error.
ORA-01580: error creating control backup file string
Cause: An operating system error occurred while attempting to create a controlfile backup.
Action: Check the error stack for more detailed information
ORA-01581: attempt to use rollback segment (string) new extent (string) which is being allocated
Cause: Undo generated to extend a rollback segment run out of current undo block space and is attempting to write into the new extent which has not been completely allocated.
Action: The rollback segment extending will be rollbacked by the system, no more extension will be possible untill the next extent is freed up by rolling back or committing other transactions.
ORA-01582: unable to open controlfile for backup
Cause: An operating system error occurred while attempting to open a controlfile for backup.
Action: Check the error stack for more detailed information
ORA-01583: unable to get block size of controlfile to be backed up
Cause: An operating system error occurred while attempting to get the block size of a controlfile for backup.
Action: Check the error stack for more detailed information
ORA-01584: unable to get file size of controlfile to be backed up
Cause: An operating system error occurred while attempting to get the file size of a controlfile for backup.
Action: Check the error stack for more detailed information
ORA-01585: error identifying backup file string
Cause: An operating system error occurred when attempting to identify the file to be used for controlfile backup.
Action: Check the error stack for more detailed information
ORA-01586: database must be mounted EXCLUSIVE and not open for this operation
Cause: Attempting to DROP DATABASE when the database is not mounted EXCLUSIVE.
Action: Mount the database in EXCLUSIVE mode.
ORA-01588: must use RESETLOGS option for database open
Cause: An earlier attempt to open the database with the RESETLOGS option did not complete, or recovery was done with a controlfile backup, or a FLASHBACK DATABASE was done.
Action: Use the RESETLOGS option when opening the database.
ORA-01589: must use RESETLOGS or NORESETLOGS option for database open
Cause: Either incomplete or backup controlfile recovery has been performed. After these types of recovery you must specify either the RESETLOGS option or the NORESETLOGS option to open your database.
Action: Specify the appropriate option.
ORA-01590: number of segment free list (string) exceeds maximum of string
Cause: storage parameter FREELIST GROUPS is too large.
Action: Reduce storage parameters FREELIST GROUPS
ORA-01591: lock held by in-doubt distributed transaction string
Cause: Trying to access resource that is locked by a dead two-phase commit transaction that is in prepared state.
Action: DBA should query the pending_trans$ and related tables, and attempt to repair network connection(s) to coordinator and commit point. If timely repair is not possible, DBA should contact DBA at commit point if known or end user for correct outcome, or use heuristic default if given to issue a heuristic commit or abort command to finalize the local portion of the distributed transaction.
ORA-01592: error converting Version 7 rollback segment (string) to Oracle 8 format
Cause: Look at the accompanying internal error; Version 7 database may not have shutdown cleanly.
Action: Investigate the internal error; may have to reload the Version 7 database (from backup) and shutdown the database cleanly.
ORA-01593: rollback segment optimal size (string blks) is smaller than the computed initial size (string blks)
Cause: Specified OPTIMAL size is smaller than the cumulative size of the initial extents during create rollback segment.
Action: Specify a larger OPTIMAL size.
ORA-01594: attempt to wrap into rollback segment (string) extent (string) which is being freed
Cause: Undo generated to free a rollback segment extent is attempting to write into the same extent due to small extents and/or too many extents to free
Action: The rollback segment shrinking will be rollbacked by the system; increase the optimal size of the rollback segment.
ORA-01595: error freeing extent (string) of rollback segment (string))
Cause: Some error occurred while freeing inactive rollback segment extents.
Action: Investigate the accompanying error.
ORA-01596: cannot specify system in string parameter
Cause: The system rollback segment is specified in the INIT.ORA parameter referred to in the error message
Action: change the INIT.ORA parameter
ORA-01597: cannot alter system rollback segment online or offline
Cause: Tried to online or offline the system rollback segment
Action: None
ORA-01598: rollback segment 'string' is not online
Cause: Could have been taken offline before by DBA or cleaned up by SMON.
Action: Check the status of rollback segment in undo$ or dba_rollback_segs to make sure the rollback segment is actually online.
ORA-01599: failed to acquire rollback segment (string), cache space is full
Cause: the amount statically allocated is not enough based on max_rollback_segments parameter.
Action: For now take another rollback segment offline or increase the parameter max_rollback_segments
ORA-01600: at most one "string" in clause "string" of string
Cause: The INIT.ORA parameter was mis-specified.
Action: Correct the INIT.ORA parameter and restart the instance.
ORA-01601: illegal bucket size in clause "string" of string
Cause: The bucket size was invalid for this parameter.
Action: Correct the INIT.ORA parameter and restart the instance.
ORA-01603: illegal grouping size in clause "string" of string
Cause: The grouping size was invalid for this parameter.
Action: Correct the INIT.ORA parameter and restart the instance.
ORA-01604: illegal number range in clause "string" of string
Cause: The number range was invalid for this parameter.
Action: Correct the INIT.ORA parameter and restart the instance.
ORA-01605: missing numbers in clause "string" of string
Cause: The numbers were missing for this parameter.
Action: Correct the INIT.ORA parameter and restart the instance.
ORA-01606: gc_files_to_locks not identical to that of another mounted instance
Cause: The gc_files_to_locks parameters were different on two instances.
Action: Modify the INIT.ORA parameter gc_files_to_locks and restart.
ORA-01607: cannot add logfile to the specified instance
Cause: The limit on the number of instances supported by the controlfile has been reached.
Action: Use an instance name supported by the controlfile, or resize the thread record and/or checkpoint progress record secions of the controlfile.
ORA-01608: cannot bring rollback segment 'string' online, its status is (string)
Cause: Could have been brought online before by DBA or left as a result of process crash.
Action: Check the status of rollback segment in undo$ or dba_rollback_segs
ORA-01609: log string is the current log for thread string - cannot drop members
Cause: A member of the current log for a thread cannot be dropped.
Action: If the thread is opened, request a log switch by the instance that is using it. If it is not open, disable the thread, manually archive the log, or clear it.
ORA-01610: recovery using the BACKUP CONTROLFILE option must be done
Cause: Either an earlier database recovery session specified BACKUP CONTROLFILE, or the controlfile was recreated with the RESETLOGS option, or the controlfile being used is a backup controlfile. After that only BACKUP CONTROLFILE recovery is allowed and it must be followed by a log reset at the next database open.
Action: Perform recovery using the BACKUP CONTROFILE option.
ORA-01611: thread number string is invalid - must be between 1 and string
Cause: A thread number in a command is greater than the number of threads supported by the controlfile.
Action: Use a thread number that is valid, or resize the thread record and/or checkpoint progress record sections of the controlfile.
ORA-01612: instance string (thread string) is already enabled
Cause: An attempt was made to enable a thread that is already enabled.
Action: Either use this thread or enable another thread.
ORA-01613: instance string (thread string) only has string logs - at least 2 logs required to enable.
Cause: The thread cannot be enabled because it only has two online log files associated with it.
Action: Add logs to the thread or pick another thread to enable
ORA-01614: instance string (thread string) is busy - cannot enable
Cause: The mount enqueue for the thread could not be acquired when attempting to enable the thread. This probably means that another process has already started enabling this thread.
Action: Wait and try again, or find another thread to enable.
ORA-01615: instance string (thread string) is mounted - cannot disable
Cause: Some instance, possibly this one, has allocated the thread for its use. The thread can not be disabled while in use.
Action: Shut the instance down cleany using the thread.
ORA-01616: instance string (thread string) is open - cannot disable
Cause: The thread is not closed. The last instance to use the thread died leaving the thread open. A thread cannot be disabled until it is closed. It is still required for crash or instance recovery.
Action: If the database is open, instance recovery should close the thread soon - wait a few minutes. Otherwise open the database - crash recovery will close the thread.
ORA-01617: cannot mount: string is not a valid thread number
Cause: The INIT.ORA parameter "thread" is not between 1 and the number of threads allowed by the controlfile.
Action: Shut down the instance, change the INIT.ORA parameter and startup, or resize the thread record and/or checkpoint progress record sections of the controlfile.
ORA-01618: redo thread string is not enabled - cannot mount
Cause: The INIT.ORA parameter "thread" requests a thread that is not enabled. A thread must be enabled before it can be mounted.
Action: Shutdown the instance, change the INIT.ORA parameter and startup mounting a different thread. If the database is open in another instance then the thread may be enabled.
ORA-01619: thread string is mounted by another instance
Cause: The INIT.ORA parameter "thread" requests a thread that has been mounted by another instance. Only one instance may use a thread.
Action: Shutdown the instance, change the INIT.ORA parameter and startup mounting a different thread.
ORA-01620: no public threads are available for mounting
Cause: The INIT.ORA parameter "thread" is zero, its default value. There are no threads which have been publicly enabled, and not mounted.
Action: Shutdown the instance, change the INIT.ORA parameter to a thread which is privately enabled and not mounted. If the database is open in another instance, then a thread may be publicly enabled.
ORA-01621: cannot rename member of current log if database is open
Cause: This is a rename command for a member of the current log for an open thread. If the database is open anywhere, the log may be in use, so the rename cannot be done.
Action: Wait until the log is not current, or mount the database exclusively.
ORA-01622: thread number must be specified - default not specific
Cause: The thread was not specified when adding a log, and the currently mounted thread was chosen by default at mount time. Since the current thread was not specified explicitly the user cannot know which thread the log will be added to.
Action: Explicitly specify the thread number either in the INIT.ORA parameter "thread", or in the add command.
ORA-01623: log string is current log for instance string (thread string) - cannot drop
Cause: A thread's current log cannot be dropped even if the thread is closed. A disabled thread usually does not have a current log, but a half completed disable may need to be disabled again.
Action: If the database is not open then disable the thread. If the database is open and an instance has the thread open, then the instance can be requested to switch logs. If the database is closed the log can be archived or cleared to force a switch.
ORA-01624: log string needed for crash recovery of instance string (thread string)
Cause: A log cannot be dropped or cleared until the thread's checkpoint has advanced out of the log.
Action: If the database is not open, then open it. Crash recovery will advance the checkpoint. If the database is open force a global checkpoint. If the log is corrupted so that the database cannot be opened, it may be necessary to do incomplete recovery until cancel at this log.
ORA-01625: rollback segment 'string' does not belong to this instance
Cause: Trying to shrink or take a rollback segment offline that does not belong to this instance.
Action: none
ORA-01626: rollback segment number 'string' cannot handle more transactions
Cause: Too many transactions in this segment.
Action: Choose a different rollback segment, or reduce the number of concurrent transactions.
ORA-01627: rollback segment number 'string' is not online
Cause: Could have been taken offline before by DBA or cleaned up by SMON.
Action: Check the status of rollback segment in undo$ or dba_rollback_segs to make sure the rollback segment is actually online.
ORA-01628: max # extents (string) reached for rollback segment string
Cause: An attempt was made to extend a rollback segment that was already at the MAXEXTENTS value.
Action: If the value of the MAXEXTENTS storage parameter is less than the maximum allowed by the system, raise this value.
ORA-01629: max # extents (string) reached saving undo for tablespace string
Cause: Save undo for the offline tablespace at max extents
Action: Check the storage parameters for the system tablespace. The tablespace needs to be brought back online so the undo can be applied .
ORA-01630: max # extents (string) reached in temp segment in tablespace string
Cause: A temp segment tried to extend past max extents.
Action: If maxextents for the tablespace is less than the the system maximum, you can raise that. Otherwise, raise pctincrease for the tablespace
ORA-01631: max # extents (string) reached in table string.string
Cause: A table tried to extend past maxextents
Action: If maxextents is less than the system maximum, raise it. Otherwise, you must recreate with larger initial, next or pctincrease params
ORA-01632: max # extents (string) reached in index string.string
Cause: An index tried to extend past maxextents
Action: If maxextents is less than the system max, raise it. Otherwise, you must recreate with larger initial, next or pctincrease params.
ORA-01633: Real Application Clusters Option needed for this operation
Cause: System doesn't have Real Application Clusters configured
Action: Obtain Real Application Clusters option
ORA-01634: rollback segment number 'string' is about to go offline
Cause: The rollback segment specified was marked to go offline by DBA.
Action: Bring the rollback segment online first.
ORA-01635: rollback segment #string specified not available
Cause: (same as 1545)
Action: (same as 1545)
ORA-01636: rollback segment 'string' is already online
Cause: The instance is trying to online an already online RS
Action: none
ORA-01637: rollback segment 'string' is being used by another instance (#string)
Cause: The instance is trying to online a RS already in use by another instance
Action: none
ORA-01638: parameter string does not allow ORACLE version string to mount cluster database
Cause: The recovery compatible parameter is set too low to allow this software version to mount in cluster database mode.
Action: Either use an earlier software release or advance the recovery_compatible parameter. If this happens when no recovery_compatible parameter has been specified then set it to the current software release.
ORA-01639: instance string has no thread assigned to it
Cause: There is no mapping from instance to thread for this instance in the controlfile.
Action: Make sure that this instance has a thread assigned to it by adding logfiles to this instance or by starting the instance with an existing thread which will automatically create a mapping.
ORA-01640: cannot make tablespace read only with active transactions
Cause: Attempting to make a tablespace read only while there are active transactions in the database. All transactions must commit or rollback to insure that there is no undo for a tablespace before it can be made read only. This includes in doubt distributed transactions.
Action: Prevent any more transactions from being started. Putting the database in restricted mode usually helps. If there are any in doubt transactions they must also be resolved.
ORA-01641: tablespace 'string' is not online - cannot add data file
Cause: Attempting to add a datafile to a tablespace that has been set to read only or offline.
Action: Make the tablespace online and read write then add the datafile.
ORA-01642: begin backup not needed for read only tablespace 'string'
Cause: Attempting to begin or end a backup for a tablespace that has been set to read only.
Action: Take the backup without any begin or end commands. The files are not being modified so the backup will be consistent.
ORA-01643: system tablespace can not be made read only
Cause: Attempting to set the system tablespace to read only. The system tablespace must remain read write for database operation.
Action: Leave system tablespace read write.
ORA-01644: tablespace 'string' is already read only
Cause: Attempting to make tablespace read only that is already read only.
Action: Leave tablespace read only, or make read write then make read only again.
ORA-01645: previous attempt to make read write is half complete
Cause: A failure while making the tablespace read write left it read only, but the checkpoint was advanced. The tablespace will not be useable after a resetlogs if its files are offline.
Action: Repeat the command to make the tablespace read write.
ORA-01646: tablespace 'string' is not read only - cannot make read write
Cause: Attempting to make a tablespace read write that is not read only. It may be either online or offline.
Action: Leave tablespace read write.
ORA-01647: tablespace 'string' is read only, cannot allocate space in it
Cause: Tried to allocate space in a read only tablespace
Action: Create the object in another tablespace
ORA-01648: log string is the current log of disabled instance string (thread string)
Cause: An attempt to enable the thread failed after it was half completed. This log was left as the current log even though the thread is still disabled. Since a log switch cannot be done until the thread is enabled, the log can not be cleared or archived.
Action: Complete the thread enable by issuing the enable command again.
ORA-01649: operation not allowed with a backup controlfile
Cause: An attempt is being made to perform a command that does not make sense when the controlfile is a restored backup.
Action: Wait until after the database has been opened and try again.
ORA-01650: unable to extend rollback segment string by string in tablespace string
Cause: Failed to allocate an extent for rollback segment in tablespace.
Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-01651: unable to extend save undo segment by string for tablespace string
Cause: Failed to allocate an extent for saving undo entries for the indicated offline tablespace.
Action: Check the storage parameters for the SYSTEM tablespace. The tablespace needs to be brought back online so the undo can be applied.
ORA-01652: unable to extend temp segment by string in tablespace string
Cause: Failed to allocate an extent for temp segment in tablespace.
Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-01653: unable to extend table string.string by string in tablespace string
Cause: Failed to allocate an extent for table segment in tablespace.
Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-01654: unable to extend index string.string by string in tablespace string
Cause: Failed to allocate an extent for index segment in tablespace.
Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-01655: unable to extend cluster string.string by string in tablespace string
Cause: Failed to allocate an extent for cluster segment in tablespace.
Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-01656: max # extents (string) reached in cluster string.string
Cause: A cluster tried to extend past maxextents
Action: If maxextents is less than the system maximum, raise it. Otherwise, you must recreate with larger initial, next or pctincrease params
ORA-01657: invalid SHRINK option value
Cause: The specified value must be an integer.
Action: Choose an appropriate integer value.
ORA-01658: unable to create INITIAL extent for segment in tablespace string
Cause: Failed to find sufficient contiguous space to allocate INITIAL extent for segment being created.
Action: Use ALTER TABLESPACE ADD DATAFILE to add additional space to the tablespace or retry with a smaller value for INITIAL
ORA-01659: unable to allocate MINEXTENTS beyond string in tablespace string
Cause: Failed to find sufficient contiguous space to allocate MINEXTENTS for the segment being created.
Action: Use ALTER TABLESPACE ADD DATAFILE to add additional space to the tablespace or retry with smaller value for MINEXTENTS, NEXT or PCTINCREASE
ORA-01660: tablespace 'string' is already permanent
Cause: Attempting to make tablespace permanent that is already permanent.
Action: Leave tablespace permanent.
ORA-01661: tablespace 'string' is already temporary
Cause: Attempting to make tablespace temporary that is already temporary.
Action: Leave tablespace permanent.
ORA-01662: tablespace 'string' is non-empty and cannot be made temporary
Cause: Tried to convert a non-empty tablespace to a temporary tablespace
Action: To drop all the objects in the tablespace.
ORA-01663: the contents of tablespace 'string' is constantly changing
Cause: The contents of the tablespace is always changing between PERMANENT and TEMPORARY.
Action: To decide what the tablespace contents should be and stay with it.
ORA-01664: Transaction which has expanded the Sort Segment has aborted
Cause: Internal Error.
Action: Contact Oracle Support.
ORA-01665: controlfile is not a standby controlfile
Cause: Attempting to mount, recover or activate a standby database without a standby controlfile.
Action: Create a standby controlfile before attempting to use the database as a standby database.
ORA-01666: controlfile is for a standby database
Cause: Attempting to mount, recover, or open a standby database without the appropriate command option to designate a standby database.
Action: Use the standby option or appropriate commands, or mount with the primary controlfile.
ORA-01667: cannot add any more tablespaces: limit of string exceeded
Cause: There is no more room in the controlfile for adding tablespaces.
Action: Resize the controlfile or drop other tablespaces.
ORA-01668: standby database requires DROP option for offline of data file
Cause: Attempting to take a datafile offline in a standby database without specifying the DROP option. Files that are offline in a standby database are not recovered, and are likely to be unusable if the standby is activated. Note that specifying DROP does not prevent bringing the file online later.
Action: Specify the DROP option or leave the file online.
ORA-01669: standby database controlfile not consistent
Cause: Attempting to activate a standby database with a controlfile that has not been recovered to the same point as the data files. Most likely the controlfile was just copied from the primary database and has not been used for recovery.
Action: Recover the standby database until all the files are consistent.
ORA-01670: new datafile string needed for standby database recovery
Cause: Standby database recovery noticed that a file was added to the primary database, but is not available on the standby.
Action: Either copy the file from the primary database or do an ALTER DATABASE CREATE DATAFILE command on the standby to create a file to recover.
ORA-01671: controlfile is a backup, cannot make a standby controlfile
Cause: The currently mounted controlfile is a backup controlfile, and attempting to create a controlfile for a standby database.
Action: Complete any needed recovery and open the database with the resetlogs option.
ORA-01672: controlfile may be missing files or have extra ones
Cause: Attempting to create a standby controlfile, but the controlfile was either recently created via CREATE CONTROLFILE or an incomplete recovery has been done. Thus the datafiles in the controlfile and the ones in the data dictionary may not match.
Action: Open the database, then retry the operation.
ORA-01673: data file string has not been identified
Cause: This data file was not in the controlfile after an incomplete recovery or CREATE CONTROLFILE. Since information from its header is needed for standby database recovery, we can not create a standby controlfile.
Action: Find the file and bring it online. If desired it may be taken offline again. If you intend to drop this file, then taking it offline with the DROP option will avoid this error.
ORA-01674: data file string is an old incarnation rather than current file
Cause: Recovery encountered redo that indicates this file was dropped from the database and another file was added using the same file number. This implies that a CREATE CONTROLFILE command was given the old file which was dropped rather than the latest file.
Action: Rebuild the controlfile using CREATE CONTROLFILE, and give the correct file.
ORA-01675: max_commit_propagation_delay inconsistent with other instances
Cause: The max_commit_propagation_delay INIT.ORA parameter is inconsistent with those in other instances.
Action: Make sure all instances have the same max_commit_propagation_delay.
ORA-01676: standby file name convert of 'string' exceeds maximum length of string
Cause: When the given file name is converted to the name used for the standby database, the converted name is bigger than the maximum allowed file name.
Action: Change initialization parameter DB_FILE_STANDBY_NAME_CONVERT or LOG_FILE_STANDBY_NAME_CONVERT to convert to a valid file name.
ORA-01677: standby file name convert parameters differ from other instance
Cause: The DB_FILE_STANDBY_NAME_CONVERT or LOG_FILE_STANDBY_NAME_CONVERT initialization parameters are not the same as in other instances that already have the database mounted.
Action: Change initialization parameters DB_FILE_STANDBY_NAME_CONVERT and LOG_FILE_STANDBY_NAME_CONVERT to match other instances.
ORA-01678: parameter string must be pairs of pattern and replacement strings
Cause: The initialization parameter does not have even number of strings for its value. The odd numbered strings are patterns to be found in file names. The even numbered strings are used to replace the corresponding patterns when found in file names.
Action: Specify even number of strings for the parameter, or omit the parameter.
ORA-01679: database must be mounted EXCLUSIVE and not open to activate
Cause: An attempt to activate a standby database was made when the database was not mounted EXCLUSIVE or was already open.
Action: Mount the database EXCLUSIVE and retry the ACTIVATE command.
ORA-01680: unable to extend LOB segment by string in tablespace string
Cause: Failed to allocate an extent for a LOB segment in tablespace.
Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-01681: max # extents (string) reached in LOB segment in tablespace string
Cause: A LOB segment tried to extend past max extents.
Action: If maxextents for the tablespace is less than the the system maximum, you can raise that. Otherwise, raise pctincrease for the tablespace
ORA-01682: read-only DB cannot allocate temporary space in tablespace string
Cause: Temporary space (usually for sorting) could not be allocated in either main storage or a tempfile. An attempt was made to allocate the space from the tablespace named, but the database is opened read-only. The database open requires a sort work space.
Action: Either allow sufficient workspace in main storage (SORT_AREA_SIZE initialization parameter), or create a temporary tablespace before making the database read-only. Use ALTER TABLESPACE ADD TEMPFILE statement to add temporary files to the temporary tablespace.
ORA-01683: unable to extend index string.string partition string by string in tablespace string
Cause: Failed to allocate an extent for index segment in tablespace.
Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-01684: max # extents (string) reached in table string.string partition string
Cause: A table tried to extend past maxextents
Action: If maxextents is less than the system maximum, raise it. Otherwise, you must recreate with larger initial, next or pctincrease params
ORA-01685: max # extents (string) reached in index string.string partition string
Cause: An index tried to extend past maxextents
Action: If maxextents is less than the system max, raise it. Otherwise, you must recreate with larger initial, next or pctincrease params.
ORA-01686: max # files (string) reached for the tablespace string
Cause: The number of files for a given tablespace has reached its maximum value
Action: Resize existing files in the tablespace, or partition the objects among multiple tablespaces, or move some objects to a different tablespace.
ORA-01687: specified logging attribute for tablespace 'string' is same as the existing
Cause: Attempting to change the tablespace default logging attribute (LOGGING or NOLOGGING) to be the same as the existing logging attribute
Action: Change the specified logging attribute
ORA-01688: unable to extend table string.string partition string by string in tablespace string
Cause: Failed to allocate an extent for table segment in tablespace.
Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-01689: syntax error in clause "string" of string
Cause: There was a syntax in the INIT.ORA parameter.
Action: Fix the syntax error and restart the instance.
ORA-01690: sort area size too small
Cause: sort area size too small to fit two records in memory
Action: increase sort_area_size
ORA-01691: unable to extend lob segment string.string by string in tablespace string
Cause: Failed to allocate an extent for lob segment in tablespace.
Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-01692: unable to extend lob segment string.string partition string by string in tablespace string
Cause: Failed to allocate an extent for lob segment in tablespace.
Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-01693: max # extents (string) reached in lob segment string.string
Cause: A lob segment tried to extend past maxextents
Action: If maxextents is less than the system max, raise it. Otherwise, you must recreate with larger initial, next or pctincrease params.
ORA-01694: max # extents (string) reached in lob segment string.string partition string
Cause: A lob segment tried to extend past maxextents
Action: If maxextents is less than the system max, raise it. Otherwise, you must recreate with larger initial, next or pctincrease params.
ORA-01695: error converting rollback segment string to version 8.0.2
Cause: Version 8.0.1 database may not have shutdown cleanly
Action: May have to reload the 8.0.1 database and shutdown cleanly
ORA-01696: controlfile is not a clone controlfile
Cause: Attempting to mount, a database as a clone when it is already mounted by another instance not as a clone or attempting to use a current controlfile for a clone.
Action: Mount without the clone option or use a backup controlfile and shutdown the other instances before mounting as a clone.
ORA-01697: controlfile is for a clone database
Cause: Attempting to mount a clone database without the appropriate command option to designate a clone database.
Action: Use the clone option or appropriate commands, or mount with the primary controlfile.
ORA-01698: a clone database may only have SYSTEM rollback segment online
Cause: Attempting to online a rollback segment in a clone database.
Action: Do not use this command.
ORA-01699: tablespace 'string' is being imported for point in time recovery
Cause: Attempting to online a tablespace or begin another point in time import while a point in time import is already in progress
Action: Wait until the import complets
ORA-01704: string literal too long
Cause: The string literal is longer than 4000 characters.
Action: Use a string literal of at most 4000 characters. Longer values may only be entered using bind variables.
ORA-01715: UNIQUE may not be used with a cluster index
Cause: An attempt was made to create a cluster index with the UNIQUE attribute.
Action: Remove UNIQUE from the CREATE INDEX statement.
ORA-01716: NOSORT may not be used with a cluster index
Cause: An attempt was made to create a cluster index using the NOSORT option.
Action: Remove NOSORT from the CREATE INDEX statement.
ORA-01718: BY ACCESS | SESSION clause not allowed for NOAUDIT
Cause: Attempt to specify BY ACCESS | SESSION in a NOAUDIT statement.
Action: Remove BY ACCESS | SESSION.
ORA-01719: outer join operator (+) not allowed in operand of OR or IN
Cause: An outer join appears in an or clause.
Action: If A and B are predicates, to get the effect of (A(+) or B), try (select where (A(+) and not B)) union all (select where (B)).
ORA-01720: grant option does not exist for 'string.string'
Cause: A grant was being performed on a view and the grant option was not present for an underlying object.
Action: Obtain the grant option on all underlying objects of the view.
ORA-01721: USERENV(COMMITSCN) invoked more than once in a transaction
Cause: The USERENV('COMMITSCN') function can only be used once in a transaction.
Action: Re-write the transactioin to use USERENV('COMMITSCN') only once
ORA-01724: floating point precision is out of range (1 to 126)
Cause: Self-evident.
Action: Self-evident.
ORA-01725: USERENV('COMMITSCN') not allowed here
Cause: The function USERNEV('COMMMITSCN') is only allowed as a top-level expression in the VALUES clause of an INSERT statements, and on the right hand side of an assignment in an UPDATE statement.
Action: Correct the use of the function.
ORA-01734: illegal parameters - EXTENT MIN higher than EXTENT MAX
Cause: A wrong value is specified for the parameter.
Action: Correct the parameter and reissue the statement.
ORA-01742: comment not terminated properly
Cause: The indicated comment or hint begun with the /* token did not have the terminating */.
Action: Properly terminate the comment or hint with a */.
ORA-01743: only pure functions can be indexed
Cause: The indexed function uses SYSDATE or the user environment.
Action: PL/SQL functions must be pure (RNDS, RNPS, WNDS, WNPS). SQL expressions must not use SYSDATE, USER, USERENV(), or anything else dependent on the session state. NLS-dependent functions are OK.
ORA-01751: Invalid dump undo option
Cause: An invalid option is specified in the ALTER DUMP UNDO command.
Action: Correct and reissue the command.
ORA-01752: cannot delete from view without exactly one key-preserved table
Cause: The deleted table either had no key perserved tables, had more than one key-preserved table, or the key-preserved table was an unmerged view or a table from a read-only view.
Action: Redefine the view or delete it from the underlying base tables.
ORA-01754: a table may contain only one column of type LONG
Cause: An attempt was made to add a LONG column to a table which already had a LONG column. Note that even if the LONG column currently in the table has already been marked unused, another LONG column may not be added until the unused columns are dropped.
Action: Remove the LONG column currently in the table by using the ALTER TABLE command.
ORA-01755: Must specify an extent number or block number
Cause: Expecting an extent or block number but something else was specified.
Action: Correct the error and reissue the command.
ORA-01757: Must specify an object number
Cause: Expecting an object number but something else was specified.
Action: Correct the error and reissue the command.
ORA-01761: DML operation does not map to a unique table in the join
Cause: The primary table is the base table against which the update, insert or delete operation is finally being done. For delete either there is no primary table in the join query or there is more than one. For update or insert the columns specified map to more than one base table.
Action: Change the join specification.
ORA-01763: update or delete involves outer joined table
Cause: For deletes, the table being deleted from is outer joined to some other table. For updates, either the table being updated is outer- joined to some other table, or some table reachable from the primary table is being outer joined to a table not reachable from the primary table.
Action: Change the join specification.
ORA-01764: new update value of join is not guaranteed to be unique
Cause: A row of a join query table is being updated using a row of a table that is not guaranteed to have exactly one value for the row being updated.
Action: Change the join specification.
ORA-01769: duplicate CLUSTER option specifications
Cause: During a CREATE of a clustered table, the user attempted to specify more than one CLUSTER option.
Action: Remove the extra CLUSTER option.
ORA-01771: illegal option for a clustered table
Cause: During a CREATE or ALTER of a clustered table, the user attempted to enter one or more of the following options: INITRANS, MAXTRANS, PCTFREE, PCTUSED, STORAGE, TABLESPACE. These options may only be specified for the cluster itself.
Action: Remove the illegal option(s).
ORA-01772: Must specify a value for LEVEL
Cause: Expecting the value of LEVEL but something else was specified.
Action: Correct the error and reissue the command.
ORA-01774: Dump undo option specified more than once
Cause: The same option for ALTER DUMP UNDO was specified twice.
Action: Remove the redundant options and reissue the command.
ORA-01776: cannot modify more than one base table through a join view
Cause: Columns belonging to more than one underlying table were either inserted into or updated.
Action: Phrase the statement as two or more separate statements.
ORA-01779: cannot modify a column which maps to a non key-preserved table
Cause: An attempt was made to insert or update columns of a join view which map to a non-key-preserved table.
Action: Modify the underlying base tables directly.
ORA-01781: UNRECOVERABLE cannot be specified without AS SELECT
Cause: UNRECOVERABLE was specified in a CREATE TABLE statement without also specifying a populating subquery with an AS clause.
Action: Do not specify UNRECOVERABLE.
ORA-01782: UNRECOVERABLE cannot be specified for a cluster or clustered table
Cause: A CREATE CLUSTER, or clustered CREATE TABLE statement specified UNRECOVERABLE.
Action: Do not specify UNRECOVERABLE.
ORA-01783: only one RECOVERABLE or UNRECOVERABLE clause may be specified
Cause: RECOVERABLE was specified more than once, UNRECOVERABLE was specified more than once, or both RECOVERABLE and UNRECOVERABLE were specified in a CREATE TABLE or CREATE INDEX or ALTER INDEX REBUILD statement.
Action: Remove all but one of the RECOVERABLE or UNRECOVERABLE clauses and reissue the statement.
ORA-01784: RECOVERABLE cannot be specified with database media recovery disabled
Cause: A CREATE TABLE or CREATE INDEX statement specified RECOVERABLE when the database was running in NOARCHIVELOG mode. Since logs are not being archived, they will be overwritten and the object being created cannot be recovered from a backup taken before the object was created.
Action: Do not specify RECOVERABLE, or restart the database with media recovery enabled.
ORA-01792: maximum number of columns in a table or view is 1000
Cause: An attempt was made to create a table or view with more than 1000 columns, or to add more columns to a table or view which pushes it over the maximum allowable limit of 1000. Note that unused columns in the table are counted toward the 1000 column limit.
Action: If the error is a result of a CREATE command, then reduce the number of columns in the command and resubmit. If the error is a result of an ALTER TABLE command, then there are two options: 1) If the table contained unused columns, remove them by executing ALTER TABLE DROP UNUSED COLUMNS before adding new columns; 2) Reduce the number of columns in the command and resubmit.
ORA-01799: a column may not be outer-joined to a subquery
Cause: <expression>(+) <relop> (<subquery>) is not allowed.
Action: Either remove the (+) or make a view out of the subquery. In V6 and before, the (+) was just ignored in this case.
ORA-01804: failure to initialize timezone information
Cause: The timezone information file was not properly read.
Action: Please contact Oracle Customer Support.
ORA-01841: (full) year must be between -4713 and +9999, and not be 0
Cause: Illegal year entered
Action: Input year in the specified range
ORA-01854: julian date must be between 1 and 5373484
Cause: An invalid Julian date was entered.
Action: Enter a valid Julian date between 1 and 5373484.
ORA-01858: a non-numeric character was found where a numeric was expected
Cause: The input data to be converted using a date format model was incorrect. The input data did not contain a number where a number was required by the format model.
Action: Fix the input data or the date format model to make sure the elements match in number and type. Then retry the operation.
ORA-01859: a non-alphabetic character was found where an alphabetic was expected
Cause: The input data to be converted using a date format model was incorrect. The input data did not contain a letter where a letter was required by the format model.
Action: Fix the input data or the date format model to make sure the elements match in number and type. Then retry the operation.
ORA-01861: literal does not match format string
Cause: Literals in the input must be the same length as literals in the format string (with the exception of leading whitespace). If the "FX" modifier has been toggled on, the literal must match exactly, with no extra whitespace.
Action: Correct the format string to match the literal.
ORA-01862: the numeric value does not match the length of the format item
Cause: When the FX and FM format codes are specified for an input date, then the number of digits must be exactly the number specified by the format code. For example, 9 will not match the format specifier DD but 09 will.
Action: Correct the input date or turn off the FX or FM format specifier in the format string.
ORA-01863: the year is not supported for the current calendar
Cause: The year is not supported for the current calendar.
Action: Please check the documentation to find out what years are supported for the current calendar.
ORA-01864: the date is out of range for the current calendar
Cause: Your calendar doesn't extend to the specified date.
Action: Specify a date which is legal for this calendar.
ORA-01865: not a valid era
Cause: Era input does not match a known era.
Action: Provide a valid era on input.
ORA-01866: the datetime class is invalid
Cause: This is an internal error.
Action: Please contact Oracle Worldwide Support.
ORA-01867: the interval is invalid
Cause: The character string you specified is not a valid interval.
Action: Please specify a valid interval.
ORA-01868: the leading precision of the interval is too small
Cause: The leading precision of the interval is too small to store the specified interval.
Action: Increase the leading precision of the interval or specify an interval with a smaller leading precision.
ORA-01870: the intervals or datetimes are not mutually comparable
Cause: The intervals or datetimes are not mutually comparable.
Action: Specify a pair of intervals or datetimes that are mutually comparable.
ORA-01871: the number of seconds must be less than 60
Cause: The number of seconds specified was greater than 59.
Action: Specify a value for seconds that is 59 or smaller.
ORA-01873: the leading precision of the interval is too small
Cause: The leading precision of the interval is too small to store the specified interval.
Action: Increase the leading precision of the interval or specify an interval with a smaller leading precision.
ORA-01874: time zone hour must be between -12 and 13
Cause: The time zone hour specified was not in the valid range.
Action: Specify a time zone hour between -12 and 13.
ORA-01875: time zone minute must be between -59 and 59
Cause: The time zone minute specified was not in the valid range.
Action: Specify a time zone minute between -59 and 59.
ORA-01876: year must be at least -4713
Cause: The specified year was not in range.
Action: Specify a year that is greater than or equal to -4713.
ORA-01877: string is too long for internal buffer
Cause: This is an internal error.
Action: Please contact Oracle Worldwide Support.
ORA-01878: specified field not found in datetime or interval
Cause: The specified field was not found in the datetime or interval.
Action: Make sure that the specified field is in the datetime or interval.
ORA-01879: the hh25 field must be between 0 and 24
Cause: The specified hh25 field was not in the valid range.
Action: Specify an hh25 field between 0 and 24.
ORA-01880: the fractional seconds must be between 0 and 999999999
Cause: The specified fractional seconds were not in the valid range.
Action: Specify a value for fractional seconds between 0 and 999999999.
ORA-01881: timezone region id number is invalid
Cause: The region id referenced an invalid region.
Action: Please contact Oracle Customer Support.
ORA-01882: timezone region string not found
Cause: The specified region name was not found.
Action: Please contact Oracle Customer Support.
ORA-01883: overlap was disabled during a region transition
Cause: The region was changing state and the overlap flag was disabled.
Action: Please contact Oracle Customer Support.
ORA-01890: NLS error detected
Cause: An NLS error was detected.
Action: Look for additional error messages and take appropriate action. If there are no additional errors, call Oracle Worldwide Support.
ORA-01891: Datetime/Interval internal error
Cause: Internal error.
Action: Please contact Oracle Worldwide Support.
ORA-01898: too many precision specifiers
Cause: While trying to truncate or round dates, extra data was found in the date format picture
Action: Check the syntax of the date format picture and retry.
ORA-01900: LOGFILE keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01901: ROLLBACK keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01902: SEGMENT keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01903: EVENTS keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01904: DATAFILE keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01905: STORAGE keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01906: BACKUP keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01907: TABLESPACE keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01908: EXISTS keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01909: REUSE keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01910: TABLES keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01911: CONTENTS keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01912: ROW keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01913: EXCLUSIVE keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01914: invalid auditing option for sequence numbers
Cause: AUDIT or NOAUDIT on a sequence number specifies an auditing option that is not legal for sequence numbers.
Action: The following options may not be used for sequence numbers and should be removed: COMMENT, DELETE, INDEX, INSERT, LOCK, RENAME, UPDATE, REFERENCES, EXECUTE
ORA-01915: invalid auditing option for views
Cause: AUDIT or NOAUDIT on a view specifies an auditing option that is not legal for views.
Action: The following options may not be used for views and should be removed: ALTER, INDEX, REFERENCES, EXECUTE
ORA-01916: keyword ONLINE, OFFLINE, RESIZE, AUTOEXTEND or END/DROP expected
Cause: An expected keyword was not used for datafile/tempfile clause
Action: Use correct syntax.
ORA-01917: user or role 'string' does not exist
Cause: There is not a user or role by that name.
Action: Re-specify the name.
ORA-01918: user 'string' does not exist
Cause: User does not exist in the system.
Action: Verify the user name is correct.
ORA-01919: role 'string' does not exist
Cause: Role by that name does not exist.
Action: Verify you are using the correct role name.
ORA-01920: user name 'string' conflicts with another user or role name
Cause: There is already a user or role with that name.
Action: Specify a different user name.
ORA-01921: role name 'string' conflicts with another user or role name
Cause: There is already a user or role with that name.
Action: Specify a different role name.
ORA-01922: CASCADE must be specified to drop 'string'
Cause: Cascade is required to remove this user from the system. The user own's object which will need to be dropped.
Action: Specify cascade.
ORA-01923: CASCADE aborted, objects locked by another user
Cause: Cannot drop the user's objects; someone has them locked.
Action: Use the lock monitor to determine who has the objects locked.
ORA-01924: role 'string' not granted or does not exist
Cause: Set role can only be performed with roles granted directly to your account. (e.g. a sub-role cannot be enabled)
Action: Don't try to set the role.
ORA-01925: maximum of string enabled roles exceeded
Cause: The INIT.ORA parameter "max_enabled_roles" has been exceeded.
Action: Increase max_enabled_roles and warm start the database.
ORA-01926: cannot GRANT to a role WITH GRANT OPTION
Cause: Role cannot have a privilege with the grant option.
Action: Perform the grant without the grant option.
ORA-01927: cannot REVOKE privileges you did not grant
Cause: You can only revoke privileges you granted.
Action: Don't revoke these privileges.
ORA-01928: GRANT option not granted for all privileges
Cause: In order to grant a privilege, you must first have the privilege with the grant option.
Action: Obtain the privilege with the grant option and try again.
ORA-01929: no privileges to GRANT
Cause: "ALL" was specified but the user doesn't have any privileges with the grant option.
Action: Don't grant privileges on that object.
ORA-01930: auditing the object is not supported
Cause: AUDIT or NOAUDIT was specified for an object that cannot be audited.
Action: Don't attempt to AUDIT the object.
ORA-01931: cannot grant string to a role
Cause: UNLIMITED TABLESPACE, REFERENCES, INDEX, SYSDBA or SYSOPER privilege cannot be granted to a role.
Action: Grant privilege directly to the user.
ORA-01932: ADMIN option not granted for role 'string'
Cause: The operation requires the admin option on the role.
Action: Obtain the grant option and re-try.
ORA-01933: cannot create a stored object using privileges from a role
Cause: An attempt was made to create a stored object using privileges from a role. Stored objects cannot use privileges from roles.
Action: Grant the privileges required to the user directly.
ORA-01934: circular role grant detected
Cause: Roles cannot be granted circularly. Also, a role cannot be granted to itself.
Action: Do not perform the grant.
ORA-01935: missing user or role name
Cause: A user or role name was expected.
Action: Specify a user or role name.
ORA-01936: cannot specify owner when creating users or roles
Cause: Users and roles do not have owners.
Action: Don't specify an owner.
ORA-01937: missing or invalid role name
Cause: A valid role name was expected.
Action: Specify a valid role name.
ORA-01938: IDENTIFIED BY must be specified for CREATE USER
Cause: Cannot create a user without specifying a password or "IDENTIFIED EXTERNALLY".
Action: Specify one of the password clauses.
ORA-01939: only the ADMIN OPTION can be specified
Cause: System privileges and Roles can only be granted with the admin option. The grant option cannot be used with these privileges.
Action: Specify the admin option.
ORA-01940: cannot drop a user that is currently connected
Cause: Attempt was made to drop a user that is currently logged in.
Action: Make sure user is logged off, then repeat command.
ORA-01941: SEQUENCE keyword expected
Cause: keyword missing
Action: supply missing keyword
ORA-01942: IDENTIFIED BY and EXTERNALLY cannot both be specified
Cause: A user cannot be specified to have and not have a password.
Action: Specify only one of the options.
ORA-01943: IDENTIFIED BY already specified
Cause: The identified clause has been given twice.
Action: Use only one identified by clause.
ORA-01944: IDENTIFIED EXTERNALLY already specified
Cause: The identified externaly clause has been given twice.
Action: Use only one identified clause.
ORA-01945: DEFAULT ROLE[S] already specified
Cause: The default roles clause has been given twice.
Action: Use only on default role clause.
ORA-01946: DEFAULT TABLESPACE already specified
Cause: The default tablespace clause has been given twice.
Action: Use only one default tablespace clause.
ORA-01947: TEMPORARY TABLESPACE already specified
Cause: The temporary tablespace clause has been given twice.
Action: Use only one temporary tablespace clause.
ORA-01948: identifier's name length (string) exceeds maximum (string)
Cause: A name has been specified that is too long. For example, dbms_session.is_role_enabled() specifies a role name that is too long.
Action: Change the application or command to use a correct identifier.
ORA-01949: ROLE keyword expected
Cause: The role keyword is required here.
Action: Specify the role keyword.
ORA-01950: no privileges on tablespace 'string'
Cause: User does not have privileges to allocate an extent in the specified tablespace.
Action: Grant the user the appropriate system privileges or grant the user space resource on the tablespace.
ORA-01951: ROLE 'string' not granted to 'string'
Cause: The role you tried to revoke was not granted to the user.
Action: Don't try to revoke a privilege which is not granted.
ORA-01952: system privileges not granted to 'string'
Cause: A system privilege you tried to revoke was not granted to the user.
Action: Make sure the privileges you are trying to revoke are granted.
ORA-01953: command no longer valid, see ALTER USER
Cause: The syntax for assigning quotas on tablespaces has changed. The ALTER USER command is now used to perform the functionality
Action: Use the alter user command instead.
ORA-01954: DEFAULT ROLE clause not valid for CREATE USER
Cause: Default roles cannot be specified for create user.
Action: Grant and alter the user's default roles after creating the user.
ORA-01955: DEFAULT ROLE 'string' not granted to user
Cause: The user being altered does not have the specified role granted directly to the user. Note, sub-roles cannot be used in the default role clause.
Action: Grant the role to the user.
ORA-01956: invalid command when OS_ROLES are being used
Cause: This command cannot be used when the INIT.ORA parameter OS_ROLES is TRUE.
Action: Grant the role to the user in the operating system.
ORA-01967: invalid option for CREATE CONTROLFILE
Cause: An invalid CREATE CONTROLFILE option is present.
Action: Specify only valid CREATE CONTROLFILE options.
ORA-01968: Only specify RESETLOGS or NORESETLOGS once
Cause: The keyword RESETLOGS or NORESETLOGS has appeared more than once
Action: Be sure to specify RESETLOGS or NORESETLOGS exactly once.
ORA-01969: You must specify RESETLOGS or NORESETLOGS
Cause: Missing a RESETLOGS or a NORESETLOGS
Action: Be sure to specify RESETLOGS or NORESETLOGS exactly once.
ORA-01970: You must specify a database name for CREATE CONTROLFILE
Cause: Missing a database name
Action: Retype CREATE CONTROLFILE command with the DATABASE keyword.
ORA-01973: Missing change number
Cause: Keyword "CHANGE" found but change number not specified.
Action: Fix command line and resubmit
ORA-01974: Illegal archive option
Cause: Not a valid option to the "ALTER SYSTEM ARCHIVE" command
Action: none
ORA-01977: Missing thread number
Cause: Keyword "THREAD" found but thread number not specified.
Action: Fix command line and resubmit
ORA-01978: Missing sequence number
Cause: Keyword "SEQUENCE" found but sequence number not specified.
Action: Fix command line and resubmit
ORA-01979: missing or invalid password for role 'string'
Cause: An attempt was made to enable a role without giving
Action: Use the "identified by" clause in set role to specify the correct password.
ORA-01980: error during OS ROLE initialization
Cause: An OS error occurred while loading a users OS ROLES.
Action: Check the OS error.
ORA-01981: CASCADE CONSTRAINTS must be specified to perform this revoke
Cause: During this revoke some foreign key contraints will be removed. In order to perform this automatically, CASCADE CONSTRAINTS must be specified.
Action: Remove the constraints or specify CASCADE CONSTRAINTS.
ORA-01982: invalid auditing option for tables
Cause: AUDIT or NOAUDIT on a table specifies an auditing option that is not legal for tables.
Action: The following options may not be used for tables and should be removed: REFERENCES, EXECUTE
ORA-01983: invalid auditing option for DEFAULT
Cause: AUDIT or NOAUDIT on a DEFAULT specifies an auditing option that is not legal for DEFAULT.
Action: The following options may not be used for DEFAULT and should be removed: REFERENCES
ORA-01984: invalid auditing option for procedures/packages/functions
Cause: AUDIT or NOAUDIT on a DEFAULT specifies an auditing option that is not legal for procedures, packages, or functions.
Action: The following options may not be used for procedures, packages, and functions and should be removed: all but EXECUTE
ORA-01985: cannot create user as LICENSE_MAX_USERS parameter exceeded
Cause: Maximum users in the database license limit exceeded.
Action: Increase license limit.
ORA-01986: OPTIMIZER_GOAL is obsolete
Cause: An obsolete parameter, OPTIMIZER_GOAL, was referenced.
Action: Use the OPTIMIZER_MODE parameter.
ORA-01987: client os username is too long
Cause: A client's os username is too long for the os logon to succeed.
Action: Use a shorter os username.
ORA-01988: remote os logon is not allowed
Cause: Remote os login attempted when not allowed.
Action: Use a local client, or use the remote_os_authent system parameter to turn on remote os logon.
ORA-01989: role 'string' not authorized by operating system
Cause: The os role does not exist, is not granted to you, or you did not provide the correct password.
Action: Re-attempt the SET ROLE with a valid os role and password, if necessary.
ORA-02001: user SYS is not permitted to create indexes with freelist groups
Cause: user tried to create an index while running with sys authorization.
Action: none
ORA-02004: security violation
Cause: This error code is never returned to a user. It is used as a value for column, audit_trail.returncode, to signal that a security violation occurred.
Action: None.
ORA-02007: can't use ALLOCATE or DEALLOCATE options with REBUILD
Cause: Allocate or deallocate storage and rebuild index are not compatible.
Action: Choose one or the other.
ORA-02009: the size specified for a file must not be zero
Cause: A value of zero was specified in a SIZE or RESIZE clause of a file specification.
Action: Use correct syntax, or, if allowed, omit the SIZE or RESIZE clause.
ORA-02020: too many database links in use
Cause: The current session has exceeded the INIT.ORA open_links maximum.
Action: Increase the open_links limit, or free up some open links by committing or rolling back the transaction and canceling open cursors that reference remote databases.
ORA-02021: DDL operations are not allowed on a remote database
Cause: An attempt was made to use a DDL operation on a remote database. For example, "CREATE TABLE tablename@remotedbname ...".
Action: To alter the remote database structure, you must connect to the remote database with the appropriate privileges.
ORA-02022: remote statement has unoptimized view with remote object
Cause: The local view is unoptimized and contains references to objects at the remote database and the statement must be executed at the remote database.
Action: Create a similar view on the remote database and modify the violating view in the SQL statement with the new view@remote.
ORA-02024: database link not found
Cause: Database link to be dropped is not found in dictionary
Action: Correct the database link name
ORA-02025: all tables in the SQL statement must be at the remote database
Cause: The user's SQL statement references tables from multiple databases. The remote database is not Oracle V7 or above, and can perform updates only if it can reference all tables in the SQL statement.
Action: none
ORA-02026: missing LINK keyword
Cause: keyword missing
Action: supply missing keyword
ORA-02027: multi-row UPDATE of LONG column is not supported
Cause: A bind variable with length greater than 4000 bytes is being used to update a column, and the update statement updates more than one row.
Action: You may only update a single row with such a bind variable.
ORA-02028: fetching an exact number of rows is not supported by the server
Cause: The server does not support UPIALL, so the fetch of an exact number of rows cannot be emulated on the user side.
Action: Connect to a valid server or do not use an exact fetch.
ORA-02029: missing FILE keyword
Cause: keyword missing
Action: supply missing keyword
ORA-02030: can only select from fixed tables/views
Cause: An attempt is being made to perform an operation other than a retrieval from a fixed table/view.
Action: You may only select rows from fixed tables/views.
ORA-02031: no ROWID for fixed tables or for external-organized tables
Cause: An attempt is being made to access rowid from a fixed table or from a external-organized table.
Action: Do not access ROWID from a fixed table or from a external-organized table.
ORA-02032: clustered tables cannot be used before the cluster index is built
Cause: User attempted to perform a DML statement on a clustered table for which no cluster index has yet been created.
Action: Create the cluster index.
ORA-02033: a cluster index for this cluster already exists
Cause: A cluster index already exists for the cluster.
Action: None.
ORA-02034: speed bind not permitted
Cause: Speed bind not allowed with supplied bind variables. Trapped internally by the system.
Action: none
ORA-02035: illegal bundled operation combination
Cause: User requested that the UPI bundled execution call perform an an illegal combination of operations.
Action: See documentation for legal operation combinations.
ORA-02036: too many variables to describe with automatic cursor open
Cause: User requested that the UPI bundled execution call perform automatic cursor open and close on a describe operation. There were too many select-list items or bind variables to do this.
Action: open and close cursor explicitly
ORA-02037: uninitialized speed bind storage
Cause: User attempted a UPI bundled execution call containing a standalone execute operation without first performing a UPI bundled execution call containing a bind operation.
Action: perform a UPI bundled execution call with bind before performing a bundled execution call with execute
ORA-02038: define is not allowed for array type
Cause: User attempted to define a select list variable of type "array". Arrays may only serve as host bind variables.
Action: none
ORA-02039: bind by value is not allowed for array type
Cause: User attempted to bind an array host variable by value. Arrays may only be bound by reference.
Action: none
ORA-02040: remote database string does not support two-phase commit
Cause: the database was potentially updated but does not support prepare to commit (as determined by its logon transaction traits). The transaction was rolled back.
Action: Do not attempt to update the remote database unless it is the only database updated in one transaction.
ORA-02041: client database did not begin a transaction
Cause: internal error
Action: contact support
ORA-02042: too many distributed transactions
Cause: the distributed transaction table was full because too many distributed transactions were active.
Action: Run fewer transactions. If you are sure you don't have too many concurrent distributed transactions, this indicates an internal error and support should be notified. Instance shutdown/restart would be a work-around.
ORA-02043: must end current transaction before executing string
Cause: a transaction is in progress and one of the following commands commands is issued: COMMIT FORCE, ROLLBACK FORCE, or ALTER SYSTEM ENABLE DISTRIBUTED RECOVERY in single process mode.
Action: COMMIT or ROLLBACK the current transaction and resubmit command.
ORA-02044: transaction manager login denied: transaction in progress
Cause: a remote transaction manager tried to log in while a distributed transaction is in progress.
Action: end the current transaction (this is a protocol error from a remote transaction manager)
ORA-02045: too many local sessions participating in global transaction
Cause: too many sessions at this site for this transaction.
Action: use an existing link so another session need not be created.
ORA-02046: distributed transaction already begun
Cause: internal error or error in external transaction manager. A server session received a begin_tran RPC before finishing with a previous distributed tran.
Action: none
ORA-02047: cannot join the distributed transaction in progress
Cause: Either a transaction is in progress against a remote database that does not fully support two phase commit, and an update is attempted on another database, or updates are pending and and an attempt is made to update a different database that does not fully support two phase commit.
Action: complete the current transaction and then resubmit the update request.
ORA-02048: attempt to begin distributed transaction without logging on
Cause: client program must issue a distributed transaction login.
Action: contact support.
ORA-02049: timeout: distributed transaction waiting for lock
Cause: exceeded INIT.ORA distributed_lock_timeout seconds waiting for lock.
Action: treat as a deadlock
ORA-02050: transaction string rolled back, some remote DBs may be in-doubt
Cause: network or remote failure in 2PC.
Action: Notify operations; remote DBs will automatically re-sync when the failure is repaired.
ORA-02051: another session in same transaction failed
Cause: a session at the same site with same global transaction ID failed.
Action: none necessary, transaction automatically recovered.
ORA-02052: remote transaction failure at string
Cause: error in remote transaction at given DBLINK
Action: retry
ORA-02053: transaction string committed, some remote DBs may be in-doubt
Cause: network or remote failure in 2PC.
Action: Notify operations; remote DBs will automatically re-sync when the failure is repaired.
ORA-02054: transaction string in-doubt
Cause: network or remote failure in 2PC.
Action: Notify operations; DBs will automatically re-sync when the failure is repaired. Monitor pending_trans$ for final outcome.
ORA-02055: distributed update operation failed; rollback required
Cause: a failure during distributed update operation may not have rolled back all effects of the operation. Since some sites may be inconsistent, the transaction must roll back to a savepoint or entirely
Action: rollback to a savepoint or rollback transaction and resubmit
ORA-02056: 2PC: string: bad two-phase command number string from string
Cause: two-phase commit protocol error.
Action: recovery of transaction attempted. Monitor pending_trans$ table to ensure correct resolution. Contact support.
ORA-02057: 2PC: string: bad two-phase recovery state number string from string
Cause: internal error in two-phase recovery protocol
Action: contact support
ORA-02058: no prepared transaction found with ID string
Cause: no transaction with local_tran_id or global_tran_id found in the pending_trans$ table in prepared state.
Action: check the pending_trans$ table.
ORA-02059: ORA-2PC-CRASH-TEST-string in commit comment
Cause: This is a special comment used to test the two phase commit.
Action: Don't use this special comment (%s a number 1-10)
ORA-02060: select for update specified a join of distributed tables
Cause: tables in a join with the for update clause must reside at the same DB.
Action: none
ORA-02061: lock table specified list of distributed tables
Cause: tables in a lock table statement must reside at the same DB.
Action: issue multiple lock table commands.
ORA-02062: distributed recovery received DBID string, expected string
Cause: a database link at a coordinator no longer points to the expected database. Link may have been redefined, or a different DB mounted.
Action: restore link definition or remote database.
ORA-02063: preceding stringstring from stringstring
Cause: an Oracle error was received from a remote database link.
Action: refer to the preceding error message(s)
ORA-02064: distributed operation not supported
Cause: One of the following unsupported operations was attempted:

1. array execute of a remote update with a subquery that references a dblink, or

2. an update of a long column with bind variable and an update of a second column with a subquery that both references a dblink and a bind variable, or

3. a commit is issued in a coordinated session from an RPC procedure call with OUT parameters or function call.

Action: simplify remote update statement
ORA-02065: illegal option for ALTER SYSTEM
Cause: The option specified for ALTER SYSTEM is not supported
Action: refer to the user manual for option supported
ORA-02066: missing or invalid DISPATCHERS text
Cause: A character string literal was expected, but not found, following ALTER SYSTEM SET DISPATCHERS
Action: place the string literal containing the dispatcher's specification after ALTER SYSTEM SET DISPATCHERS
ORA-02067: transaction or savepoint rollback required
Cause: A failure (typically a trigger or stored procedure with multiple remote updates) occurred such that the all-or-nothing execution of a previous Oracle call cannot be guaranteed.
Action: rollback to a previous savepoint or rollback the transaction and resubmit.
ORA-02068: following severe error from stringstring
Cause: A severe error (disconnect, fatal Oracle error) received from the indicated database link. See following error text.
Action: Contact the remote system administrator.
ORA-02069: global_names parameter must be set to TRUE for this operation
Cause: A remote mapping of the statement is required but cannot be achieved because global_names should be set to TRUE for it to be achieved
Action: Issue alter session set global_names = true if possible
ORA-02070: database stringstring does not support string in this context
Cause: The remote database does not support the named capability in the context in which it is used.
Action: Simplify the SQL statement.
ORA-02071: error initializing capabilities for remote database string
Cause: Could not load a remote-specified capability table.
Action: Contact support for the remote SQL*Connect product.
ORA-02072: distributed database network protocol mismatch
Cause: This should never happen between different PRODUCTION releases of ORACLE, but may happen between alpha and beta releases, for example.
Action: Upgrade the older release.
ORA-02073: sequence numbers not supported in remote updates
Cause: Sequence numbers may not be used in INSERTS, UPDATES, or DELETES on remote tables.
Action: none
ORA-02074: cannot string in a distributed transaction
Cause: A commit or rollback was attempted from session other than the parent of a distributed transaction.
Action: Only commit or rollback from the parent session.
ORA-02075: another instance changed state of transaction string
Cause: A commit force or rollback force was issued from a session in another instance.
Action: Check if another Oracle instance is performing recovery of pending transactions. Query DBA_2PC_PENDING to determine the new state of the transaction.
ORA-02076: sequence not co-located with updated table or long column
Cause: all referenced sequences must be co-located with the table with the long column.
Action: none
ORA-02077: selects of long columns must be from co-located tables
Cause: if a select returns long columns from multiple tables, all the tables must be co-located
Action: none
ORA-02079: no new sessions may join a committing distributed transaction
Cause: A call to UPI2BG was issued in a session for a transaction that has begun to commit in a different branch; that is, a call to upi2en was issued for a branch of the same transaction in another session. This can only happen when using an external transaction manager.
Action: Contact support.
ORA-02080: database link is in use
Cause: a transaction is active or a cursor is open on the database link given in the alter session close database link <link> command.
Action: commit or rollback, and close all cursors
ORA-02081: database link is not open
Cause: dblink given is not currently open.
Action: none
ORA-02082: a loopback database link must have a connection qualifier
Cause: attempt to create a database link with the same name as the current database.
Action: a loopback database link needs a trailing qualifier, e.g. MYDB.DEV.US.ORACLE.COM@INST1 - the '@INST1' is the qualifier
ORA-02083: database name has illegal character 'string'
Cause: supplied database name can contain only A-Z, 0-9, '_', '#', '$' '.' and '@' characters.
Action: none
ORA-02084: database name is missing a component
Cause: supplied database name cannot contain a leading '.', trailing '.' or '@', or two '.' or '@' in a row.
Action: none
ORA-02085: database link string connects to string
Cause: a database link connected to a database with a different name. The connection is rejected.
Action: create a database link with the same name as the database it connects to, or set global_names=false.
ORA-02086: database (link) name is too long
Cause: database/database link name can have at most 128 characters.
Action: none
ORA-02087: object locked by another process in same transaction
Cause: A database link is being used in the cluster database environment that loops back to the same instance. One session is trying to convert a lock that was obtained by the other session.
Action: Get the more restrictive lock first. For example, if session 1 gets a share lock and session 2 gets an exclusive lock on the same object, get the exclusive lock first. Or, simply use the same session to access the object.
ORA-02088: distributed database option not installed
Cause: Remote and distributed updates and transactions are a separately priced option in ORACLE V7.
Action: none
ORA-02089: COMMIT is not allowed in a subordinate session
Cause: COMMIT was issued in a session that is not the two-phase commit global coordinator.
Action: Issue commit at the global coordinator only.
ORA-02090: network error: attempted callback+passthru
Cause: internal error.
Action: none
ORA-02091: transaction rolled back
Cause: Also see error 2092. If the transaction is aborted at a remote site then you will only see 2091; if aborted at host then you will see 2092 and 2091.
Action: Add rollback segment and retry the transaction.
ORA-02092: out of transaction table slots for distributed transaction
Cause: The transaction is assigned to the system rollback segment and is trying to get into the PREPARED state, but the required number of non-PREPARED slots are not available, hence the transaction is rolled back.
Action: Add a rollback segment and retry the transaction.
ORA-02093: TRANSACTIONS_PER_ROLLBACK_SEGMENT(string) more than maximum possible(string)
Cause: Value of parameter specified is greater than allowed on this port.
Action: Use default or reduce it to less than max.
ORA-02094: replication option not installed
Cause: The replication option was not installed at this site. Updatable materialized views, deferred RPCs, and other replication features were, therefore, unavailable.
Action: Install the replication option. The replication option is not part of the Oracle Server product and must be purchased separately. Contact an Oracle Sales representative if the replication option needs to be purchased.
ORA-02095: specified initialization parameter cannot be modified
Cause: The specified initialization parameter is not modifiable
Action: none
ORA-02096: specified initialization parameter is not modifiable with this option
Cause: Though the initialization parameter is modifiable, it cannot be modified using the specified command.
Action: Check the DBA guide for information about under what scope the parameter may be modified
ORA-02097: parameter cannot be modified because specified value is invalid
Cause: Though the initialization parameter is modifiable, the modified value is not acceptable to the parameter.
Action: Check the DBA guide for range of acceptable values for this parameter.
ORA-02098: error parsing index-table reference (:I)
Cause: An incorrect index-table (:I) syntax was encountered.
Action: This syntax is for oracle internal use only.


5 ORA-02140 to ORA-04099

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

5 ORA-02140 to ORA-04099

ORA-02140: invalid tablespace name
Cause: An identifier does not follow ALTER TABLESPACE.
Action: Specify a tablespace name following ALTER TABLESPACE.
ORA-02141: invalid OFFLINE option
Cause: An option other than NORMAL or IMMEDIATE follows OFFLINE.
Action: The user must either specify no option following OFFLINE or one of the options NORMAL or IMMEDIATE.
ORA-02142: missing or invalid ALTER TABLESPACE option
Cause: A valid option was not present.
Action: Use one of the valid options: add, rename, default, online, offline, read only, read write, begin, end, no, force, retention guarantee and retention noguarantee.
ORA-02143: invalid STORAGE option
Cause: An option other than INITIAL, NEXT, MINEXTENTS, MAXEXTENTS, or PCTINCREASE was specified in the STORAGE clause.
Action: Specify only valid options.
ORA-02144: no option specified for ALTER CLUSTER
Cause: No ALTER CLUSTER options are specified.
Action: Specify one or more of the following options: pctfree, pctused, size, storage.
ORA-02145: missing STORAGE option
Cause: No STORAGE options were specified following STORAGE (
Action: Specify one or more STORAGE option between the parentheses.
ORA-02146: SHARED specified multiple times
Cause: The SHARED option was specified in a CREATE DATABASE statement multiple times.
Action: Only specify the SHARED option once.
ORA-02147: conflicting SHARED/EXCLUSIVE options
Cause: Both the SHARED and EXCLUSIVE options were specified in a CREATE DATABASE statement.
Action: Specify SHARED or EXCLUSIVE, but not both.
ORA-02148: EXCLUSIVE specified multiple times
Cause: The EXCLUSIVE option was specified in a CREATE DATABASE statement multiple times.
Action: Only specify the EXCLUSIVE option once.
ORA-02149: Specified partition does not exist
Cause: Partition not found for the object.
Action: Retry with correct partition name.
ORA-02150: invalid new tablespace name
Cause: The new tablespace name specified in ALTER TABLESPACE RENAME TO statement was invalid.
Action: Retry with a valid new tablespace name.
ORA-02151: invalid tablespace name: string
Cause: Oracle cannot create a tablespace whose name starts with '_$deleted$'.
Action: Try a different tablespace name.
ORA-02152: Invalid ALTER TABLESPACE ... RENAME option
Cause: An option other than DATAFILE or TO follows by ALTER TABLESPACE ... RENAME.
Action: The user must specify either DATAFILE or TO following ALTER TABLESPACE ... RENAME.
ORA-02153: invalid VALUES password string
Cause: An encoded password string does not follow the VALUES clause.
Action: Place a proper encoded password string after the VALUES clause.
ORA-02154: a tablespace with the name 'string' is found
Cause: An attempt to rename a tablespace to a new name failed because the new name is already used by some other tablespace.
Action: Retry with a different new name.
ORA-02155: invalid DEFAULT tablespace identifier
Cause: An identifier does not follow DEFAULT TABLESPACE.
Action: Place a tablespace name after DEFAULT TABLESPACE.
ORA-02156: invalid TEMPORARY tablespace identifier
Cause: An identifier does not follow TEMPORARY TABLESPACE.
Action: Place a tablespace name after TEMPORARY TABLESPACE.
ORA-02157: no options specified for ALTER USER
Cause: No options were specified.
Action: Specify at least one ALTER USER option.
ORA-02158: invalid CREATE INDEX option
Cause: An option other than COMPRESS, NOCOMPRESS, PCTFREE, INITRANS, MAXTRANS, STORAGE, TABLESPACE, PARALLEL, NOPARALLEL, RECOVERABLE, UNRECOVERABLE, LOGGING, NOLOGGING, LOCAL, or GLOBAL was specified.
Action: Choose one of the valid CREATE INDEX options.
ORA-02159: installed DLM does not support releasable locking mode
Cause: The parameter file specified gc_* parameters that allow locks to be release by the LCK process when not in use. This mode requires additional support from the DLM that is not available.
Action: Specify configuration parameters that do not require the additional function.
ORA-02160: index-organized table can not contain columns of type LONG
Cause: A column of type LONG defined for index-organized table.
Action: Do not use columns of type LONG in index-organized tables.
ORA-02161: invalid value for MAXLOGFILES
Cause: A number does not follow MAXLOGFILES.
Action: Specify a number after MAXLOGFILES.
ORA-02162: invalid value for MAXDATAFILES
Cause: A number does not follow MAXDATAFILES.
Action: Specify a number after MAXDATAFILES.
ORA-02163: invalid value for FREELIST GROUPS
Cause: A number does not follow FREELIST GROUPS.
Action: Specify a number after FREELIST GROUPS.
ORA-02164: DATAFILE clause specified more than once
Cause: The CREATE DATABASE command contains more than one DATAFILE clause.
Action: Specify at most one DATAFILE clause.
ORA-02165: invalid option for CREATE DATABASE
Cause: An invalid CREATE DATABASE option is present.
Action: Specify only valid CREATE DATABASE options.
ORA-02166: ARCHIVELOG and NOARCHIVELOG specified
Cause: Both ARCHIVELOG and NOARCHIVELOG are specified in a CREATE DATABASE statement.
Action: Specify at most one of these two options.
ORA-02167: LOGFILE clause specified more than once
Cause: The CREATE DATABASE command contains more than one LOGFILE clause.
Action: Specify at most one LOGFILE clause.
ORA-02168: invalid value for FREELISTS
Cause: A number does not follow FREELISTS
Action: Specify a number after FREELISTS
ORA-02169: FREELISTS storage option not allowed
Cause: The user attempted to specify the FREELISTS storage option. This option may only be specified during create table or create index.
Action: Remove these options and retry the statement.
ORA-02170: FREELIST GROUPS storage option not allowed
Cause: The user attempted to specify the FREELIST GROUPS storage option. This option may only be specified during create table and when allow_freelist_groups INIT.ORA is specified.
Action: Remove this option and retry the statement or set the allow_freelist_groups INIT.ORA parameter.
ORA-02171: invalid value for MAXLOGHISTORY
Cause: A number does not follow MAXLOGHISTORY
Action: Specify a number after MAXLOGHISTORY
ORA-02172: The PUBLIC keyword is not appropriate for a disable thread
Cause: The PUBLIC keyword was specified for a disable.
Action: Remove the keyword and resubmit.
ORA-02173: invalid option for DROP TABLESPACE
Cause: Either a token other than INCLUDING was found following the tablespace name or some text was found following INCLUDING CONTENTS.
Action: Place nothing or only INCLUDING CONTENTS after the tablespace name.
ORA-02174: Missing required thread number
Cause: Must specify thread number after THREAD keyword
Action: none
ORA-02175: invalid rollback segment name
Cause: In the CREATE or DROP ROLLBACK SEGMENT statements, an identifier was not found following ROLLBACK SEGMENT.
Action: Place the segment name following ROLLBACK SEGMENT.
ORA-02176: invalid option for CREATE ROLLBACK SEGMENT
Cause: An invalid option was specified in a CREATE ROLLBACK SEGMENT statement.
Action: Specify one of the valid options: TABLESPACE and STORAGE.
ORA-02177: Missing required group number
Cause: Must specify group number after GROUP keyword
Action: none
ORA-02178: correct syntax is: SET TRANSACTION READ { ONLY | WRITE }
Cause: There is a syntax error in the user's statement.
Action: Correct the syntax as indicated.
ORA-02179: valid options: ISOLATION LEVEL { SERIALIZABLE | READ COMMITTED }
Cause: There is a syntax error in the user's statement.
Action: Correct the syntax as indicated.
ORA-02180: invalid option for CREATE TABLESPACE
Cause: An invalid option appeared.
Action: Specify one of the valid options: DATAFILE, DEFAULT STORAGE, ONLINE, OFFLINE, FORCE, RETENTION.
ORA-02181: invalid option to ROLLBACK WORK
Cause: A token other than TO follows ROLLBACK [WORK].
Action: Place nothing or TO SAVEPOINT <name> after ROLLBACK [WORK].
ORA-02182: savepoint name expected
Cause: An identifier does not follow ROLLBACK [WORK] TO [SAVEPOINT].
Action: Place a savepoint name following TO [SAVEPOINT].
ORA-02183: valid options: ISOLATION_LEVEL { SERIALIZABLE | READ COMMITTED }
Cause: There is a syntax error in the user's statement.
Action: Correct the syntax as indicated.
ORA-02184: resource quotas are not allowed in REVOKE
Cause: In a revoke statement, a resource quota was specified.
Action: Specify resource privilege without the quota.
ORA-02185: a token other than WORK follows COMMIT
Cause: A token other than WORK follows COMMIT.
Action: Place either nothing or WORK after COMMIT.
ORA-02186: tablespace resource privilege may not appear with other privileges
Cause: An attempt was made to grant or revoke a resource quota in the same statement in which other privileges are granted or revoked.
Action: Use a separate grant or revoke statement for the resource quota privilege.
ORA-02187: invalid quota specification
Cause: In a grant or revoke statement, the user attempted to grant a tablespace quota above the upper limit.
Action: Grant a smaller tablespace quota.
ORA-02188: Cannot enable instance publicly
Cause: An attempt was made to publicly enable a thread associated with an instance.
Action: Leave out the PUBLIC keyword.
ORA-02189: ON <tablespace> required
Cause: In a grant or revoke statement, the user specified a tablespace quota but did not follow it with the ON <tablespace> clause.
Action: Specify the tablespace on which the quota is to be applied with the ON <tablespace> clause.
ORA-02190: keyword TABLES expected
Cause: The keyword TABLES is expected following DROP CLUSTER <name> INCLUDING.
Action: Place TABLES after INCLUDING.
ORA-02191: correct syntax is: SET TRANSACTION USE ROLLBACK SEGMENT <rbs>
Cause: There is a syntax error in the user's statement.
Action: Correct the syntax as indicated.
ORA-02192: PCTINCREASE not allowed for rollback segment storage clauses
Cause: pctincrease was specified in a create or alter rollback segment
Action: reissue statement without the pctincrease clause
ORA-02194: event specification syntax error string (minor error string) near 'string'
Cause: There is a syntax error in an event specification.
Action: Fix the error.
ORA-02195: Attempt to create string object in a string tablespace
Cause: The object type is inconsistent with a tablespace contents.
Action: Create an object in a different tablespace, or change the user defaults.
ORA-02196: PERMANENT/TEMPORARY option already specified
Cause: In CREATE TABLESPACE, the PERMANENT and/or TEMPORARY options were specified more than once.
Action: none
ORA-02197: file list already specified
Cause: In CREATE TABLESPACE, more than one DATAFILE/TEMPFILE clause was specified.
Action: Merge the DATAFILE/TEMPFILE clauses into a single clause.
ORA-02198: ONLINE/OFFLINE option already specified
Cause: In CREATE TABLESPACE, the ONLINE and/or OFFLINE options were specified more than once.
Action: Specify at most one of ONLINE or OFFLINE.
ORA-02199: missing DATAFILE/TEMPFILE clause
Cause: A CREATE TABLESPACE statement has no DATAFILE/TEMPFILE clause.
Action: Specify a DATAFILE/TEMPFILE clause.
ORA-02200: WITH GRANT OPTION not allowed for PUBLIC
Cause: An attempt was made to GRANT to PUBLIC WITH GRANT OPTION.
Action: Remove the WITH GRANT OPTION clause.
ORA-02201: sequence not allowed here
Cause: An attempt was made to reference a sequence in a from-list.
Action: A sequence can only be referenced in a select-list.
ORA-02202: no more tables permitted in this cluster
Cause: An attempt was made to create a table in a cluster which already contains 32 tables.
Action: Up to 32 tables may be stored per cluster.
ORA-02203: INITIAL storage options not allowed
Cause: The user attempted to alter the INITIAL storage option of a table, cluster, index, or rollback segment. These options may only be specified when the object is created.
Action: Remove these options and retry the statement.
ORA-02204: ALTER, INDEX and EXECUTE not allowed for views
Cause: An attempt was made to grant or revoke an invalid privilege on a view.
Action: Do not attempt to grant or revoke any of ALTER, INDEX, or EXECUTE privileges on views.
ORA-02205: only SELECT and ALTER privileges are valid for sequences
Cause: An attempt was made to grant or revoke an invalid privilege on a sequence.
Action: Do not attempt to grant or revoke DELETE, INDEX, INSERT, UPDATE, REFERENCES or EXECUTE privilege on sequences.
ORA-02206: duplicate INITRANS option specification
Cause: INITRANS is specified more than once.
Action: Specify INITRANS at most once.
ORA-02207: invalid INITRANS option value
Cause: The INITRANS value is not an integer between 1 and 255 and less than or equal to the MAXTRANS value.
Action: Choose a valid INITRANS value.
ORA-02208: duplicate MAXTRANS option specification
Cause: MAXTRANS is specified more than once.
Action: Specify MAXTRANS at most once.
ORA-02209: invalid MAXTRANS option value
Cause: The MAXTRANS value is not an integer between 1 and 255 and greater than or equal to the INITRANS value.
Action: Choose a valid MAXTRANS value.
ORA-02210: no options specified for ALTER TABLE
Cause: No ALTER TABLE option was specified.
Action: Specify at least one alter table option.
ORA-02211: invalid value for PCTFREE or PCTUSED
Cause: The specified value for PCTFREE or PCTUSED is not an integer between 0 and 100.
Action: Choose an appropriate value for the option.
ORA-02212: duplicate PCTFREE option specification
Cause: PCTFREE option specified more than once.
Action: Specify PCTFREE at most once.
ORA-02213: duplicate PCTUSED option specification
Cause: PCTUSED option specified more than once.
Action: Specify PCTUSED at most once.
ORA-02214: duplicate BACKUP option specification
Cause: The BACKUP option to ALTER TABLE is specified more than once.
Action: Specify the option at most once.
ORA-02215: duplicate tablespace name clause
Cause: There is more than one TABLESPACE clause in the CREATE TABLE, CREATE INDEX, or CREATE ROLLBACK SEGMENT statement.
Action: Specify at most one TABLESPACE clause.
ORA-02216: tablespace name expected
Cause: A tablespace name is not present where required by the syntax for one of the following statements: CREATE/DROP TABLESPACE, CREATE TABLE, CREATE INDEX, or CREATE ROLLBACK SEGMENT.
Action: Specify a tablespace name where required by the syntax.
ORA-02217: duplicate storage option specification
Cause: A storage option (INIITAL, NEXT, MINEXTENTS, MAXEXTENTS, PCTINCREASE) is specified more than once.
Action: Specify all storage options at most once.
ORA-02218: invalid INITIAL storage option value
Cause: The specified value must be an integer.
Action: Choose an appropriate integer value.
ORA-02219: invalid NEXT storage option value
Cause: The specified value must be an integer.
Action: Choose an appropriate integer value.
ORA-02220: invalid MINEXTENTS storage option value
Cause: The specified value must be a positive integer less than or equal to MAXEXTENTS.
Action: Specify an appropriate value.
ORA-02221: invalid MAXEXTENTS storage option value
Cause: The specified value must be a positive integer greater than or equal to MINEXTENTS.
Action: Specify an appropriate value.
ORA-02222: invalid PCTINCREASE storage option value
Cause: The specified value must be a positive integer.
Action: Specify an appropriate value.
ORA-02223: invalid OPTIMAL storage option value
Cause: The specified value must be an integer.
Action: Choose an appropriate integer value.
ORA-02224: EXECUTE privilege not allowed for tables
Cause: An attempt was made to grant or revoke an invalid privilege on a table.
Action: Do not attempt to grant or revoke EXECUTE privilege on tables.
ORA-02225: only EXECUTE and DEBUG privileges are valid for procedures
Cause: An attempt was made to grant or revoke an invalid privilege on a procedure, function or package.
Action: Do not attempt to grant or revoke any privilege besides EXECUTE or DEBUG on procedures, functions or packages.
ORA-02226: invalid MAXEXTENTS value (max allowed: string)
Cause: The MAXEXTENTS specified is too large for the database block size. This applies only to SYSTEM rollback segment.
Action: Specify a smaller value.
ORA-02227: invalid cluster name
Cause: A cluster name of the form [ <identifier> . ] <identifier> is expected but not present.
Action: Enter an appropriate cluster name.
ORA-02228: duplicate SIZE specification
Cause: The SIZE option is specified more than once.
Action: Specify the SIZE option at most once.
ORA-02229: invalid SIZE option value
Cause: The specified value must be an integer number of bytes.
Action: Specify an appropriate value.
ORA-02230: invalid ALTER CLUSTER option
Cause: An option other than PCTFREE, PCTUSED, INITRANS, MAXTRANS, STORAGE, or SIZE is specified in an ALTER CLUSTER statement.
Action: Specify only legal options.
ORA-02231: missing or invalid option to ALTER DATABASE
Cause: An option other than ADD, DROP, RENAME, ARCHIVELOG, NOARCHIVELOG, MOUNT, DISMOUNT, OPEN, or CLOSE is specified in the statement.
Action: Specify only legal options.
ORA-02232: invalid MOUNT mode
Cause: A mode other than SHARED or EXCLUSIVE follows the MOUNT keyword in an ALTER DATABASE statement.
Action: Specify either SHARED, EXCLUSIVE, or nothing following MOUNT.
ORA-02233: invalid CLOSE mode
Cause: A mode other than NORMAL or IMMEDIATE follows the CLOSE keyword in an ALTER DATABASE statement.
Action: Specify either NORMAL, IMMEDIATE, or nothing following CLOSE.
ORA-02234: changes to this table are already logged
Cause: the log table to be added is a duplicate of another
Action: Don't add this change log to the system; check that the replication product's system tables are consistent
ORA-02235: this table logs changes to another table already
Cause: the table to be altered is already a change log for another table
Action: Don't log changes to the specified base table to this table; check that the replication product's system tables are consistent
ORA-02236: invalid file name
Cause: A character string literal was not used in the filename list of a LOGFILE, DATAFILE, or RENAME clause.
Action: Use correct syntax.
ORA-02237: invalid file size
Cause: A non-integer value was specified in the SIZE or RESIZE clause.
Action: Use correct syntax.
ORA-02238: filename lists have different numbers of files
Cause: In a RENAME clause in ALTER DATABASE or TABLESPACE, the the number of existing filenames does not equal the number of new filenames.
Action: Make sure there is a new filename to correspond to each existing filename.
ORA-02239: there are objects which reference this sequence
Cause: the sequence to be dropped is still referenced
Action: Make sure the sequence name is correct, or drop the referencing constraint/object
ORA-02240: invalid value for OBJNO or TABNO
Cause: A number does not follow either OBJNO or TABNO.
Action: Specify a number after OBJNO or TABNO.
ORA-02241: must of form EXTENTS (FILE <n> BLOCK <n> SIZE <n>, ...)
Cause: bad extent storage clause
Action: respecify
ORA-02242: no options specified for ALTER INDEX
Cause: No options specified.
Action: Specify at least one of REBUILD, INITRANS, MAXTRANS, or STORAGE.
ORA-02243: invalid ALTER INDEX or ALTER MATERIALIZED VIEW option
Cause: An option other than INITRANS, MAXTRANS,or STORAGE is specified in an ALTER INDEX statement or in the USING INDEX clause of an ALTER MATERIALIZED VIEW statement.
Action: Specify only legal options.
ORA-02244: invalid ALTER ROLLBACK SEGMENT option
Cause: The STORAGE option is expected but not found.
Action: Specify the STORAGE option.
ORA-02245: invalid ROLLBACK SEGMENT name
Cause: An identifier was expected, but not found, following ALTER [PUBLIC] ROLLBACK SEGMENT.
Action: Place a rollback segment name following SEGMENT.
ORA-02246: missing EVENTS text
Cause: A character string literal was expected, but not found, following ALTER SESSION SET EVENTS.
Action: Place the string literal containing the events text after EVENTS.
ORA-02247: no option specified for ALTER SESSION
Cause: The option SET EVENTS was expected, but not found, following ALTER SESSION.
Action: Place the SET EVENTS option after ALTER SESSION.
ORA-02248: invalid option for ALTER SESSION
Cause: Obvious.
Action: see SQL Language Manual for legal options.
ORA-02249: missing or invalid value for MAXLOGMEMBERS
Cause: A valid number does not follow MAXLOGMEMBERS. The value specified must be between 1 and the port-specific maximum number of log file members.
Action: Specify a valid number after MAXLOGMEMBERS.
ORA-02250: missing or invalid constraint name
Cause: The constraint name is missing or invalid.
Action: Specify a valid identifier name for the constraint name.
ORA-02251: subquery not allowed here
Cause: Subquery is not allowed here in the statement.
Action: Remove the subquery from the statement.
ORA-02252: check constraint condition not properly ended
Cause: The specified search condition for the check constraint is not properly ended.
Action: End the condition properly.
ORA-02253: constraint specification not allowed here
Cause: Constraint specification is not allowed here in the statement.
Action: Remove the constraint specification from the statement.
ORA-02254: DEFAULT <expression> not allowed here
Cause: Default value expression is not allowed for the column here in the statement.
Action: Remove the default value expression from the statement.
ORA-02255: obsolete 7.1.5
Cause: Was that defaults must not conflict with not null constraints
Action: none
ORA-02256: number of referencing columns must match referenced columns
Cause: The number of columns in the foreign-key referencing list is not equal to the number of columns in the referenced list.
Action: Make sure that the referencing columns match the referenced columns.
ORA-02257: maximum number of columns exceeded
Cause: The number of columns in the key list exceeds the maximum number.
Action: Reduce the number columns in the list.
ORA-02258: duplicate or conflicting NULL and/or NOT NULL specifications
Cause: Self-evident.
Action: Remove the duplicate or conflicting specification.
ORA-02259: duplicate UNIQUE/PRIMARY KEY specifications
Cause: Self-evident.
Action: Remove the duplicate specification.
ORA-02260: table can have only one primary key
Cause: Self-evident.
Action: Remove the extra primary key.
ORA-02261: such unique or primary key already exists in the table
Cause: Self-evident.
Action: Remove the extra key.
ORA-02262: ORA-string occurs while type-checking column default value expression
Cause: New column datatype causes type-checking error for existing column default value expression.
Action: Remove the default value expression or don't alter the column datatype.
ORA-02263: need to specify the datatype for this column
Cause: The required datatype for the column is missing.
Action: Specify the required datatype.
ORA-02264: name already used by an existing constraint
Cause: The specified constraint name has to be unique.
Action: Specify a unique constraint name for the constraint.
ORA-02265: cannot derive the datatype of the referencing column
Cause: The datatype of the referenced column is not defined as yet.
Action: Make sure that the datatype of the referenced column is defined before referencing it.
ORA-02266: unique/primary keys in table referenced by enabled foreign keys
Cause: An attempt was made to truncate a table with unique or primary keys referenced by foreign keys enabled in another table. Other operations not allowed are dropping/truncating a partition of a partitioned table or an ALTER TABLE EXCHANGE PARTITION.
Action: Before performing the above operations the table, disable the foreign key constraints in other tables. You can see what constraints are referencing a table by issuing the following command: SELECT * FROM USER_CONSTRAINTS WHERE TABLE_NAME = "tabnam";
ORA-02267: column type incompatible with referenced column type
Cause: The datatype of the referencing column is incompatible with the
Action: Select a compatible datatype for the referencing column.
ORA-02268: referenced table does not have a primary key
Cause: The referenced table does not have a primary key.
Action: Specify explicitly the referenced table unique key.
ORA-02269: key column cannot be of LONG datatype
Cause: Self-evident.
Action: Change the datatype of the column, or remove the column from the key.
ORA-02270: no matching unique or primary key for this column-list
Cause: A REFERENCES clause in a CREATE/ALTER TABLE statement gives a column-list for which there is no matching unique or primary key constraint in the referenced table.
Action: Find the correct column names using the ALL_CONS_COLUMNS catalog view
ORA-02271: table does not have such constraint
Cause: Self-evident.
Action: Make sure the specified constraint name is correct.
ORA-02272: constrained column cannot be of LONG datatype
Cause: Self-evident.
Action: Change the datatype of the column, or remove the constraint on the column.
ORA-02273: this unique/primary key is referenced by some foreign keys
Cause: Self-evident.
Action: Remove all references to the key before the key is to be dropped.
ORA-02274: duplicate referential constraint specifications
Cause: Self-evident.
Action: Remove the duplicate specification.
ORA-02275: such a referential constraint already exists in the table
Cause: Self-evident.
Action: Remove the extra constraint.
ORA-02276: default value type incompatible with column type
Cause: The type of the evaluated default expression is incompatible with the datatype of the column.
Action: Change the type of the column, or modify the default expression.
ORA-02277: invalid sequence name
Cause: The specified sequence name is not a valid identifier name.
Action: Specify a valid identifier name for the sequence name.
ORA-02278: duplicate or conflicting MAXVALUE/NOMAXVALUE specifications
Cause: Self-evident.
Action: Remove the duplicate or conflicting specification.
ORA-02279: duplicate or conflicting MINVALUE/NOMINVALUE specifications
Cause: Self-evident.
Action: Remove the duplicate or conflicting specification.
ORA-02280: duplicate or conflicting CYCLE/NOCYCLE specifications
Cause: Self-evident.
Action: Remove the duplicate or conflicting specification.
ORA-02281: duplicate or conflicting CACHE/NOCACHE specifications
Cause: Self-evident.
Action: Remove the duplicate or conflicting specification.
ORA-02282: duplicate or conflicting ORDER/NOORDER specifications
Cause: Self-evident.
Action: Remove the duplicate or conflicting specification.
ORA-02283: cannot alter starting sequence number
Cause: Self-evident.
Action: Don't alter it.
ORA-02284: duplicate INCREMENT BY specifications
Cause: Self-evident.
Action: Remove the duplicate specification.
ORA-02285: duplicate START WITH specifications
Cause: Self-evident.
Action: Remove the duplicate specification.
ORA-02286: no options specified for ALTER SEQUENCE
Cause: Self-evident.
Action: The statement is meaningless without any options.
ORA-02287: sequence number not allowed here
Cause: The specified sequence number (CURRVAL or NEXTVAL) is inappropriate here in the statement.
Action: Remove the sequence number.
ORA-02288: invalid OPEN mode
Cause: A token other than RESETLOGS appears following ALTER DATABASE <name> OPEN.
Action: Either nothing or RESETLOGS should be placed following OPEN.
ORA-02289: sequence does not exist
Cause: The specified sequence does not exist, or the user does not have the required privilege to perform this operation.
Action: Make sure the sequence name is correct, and that you have the right to perform the desired operation on this sequence.
ORA-02290: check constraint (string.string) violated
Cause: The values being inserted do not satisfy the named check constraint.
Action: do not insert values that violate the constraint.
ORA-02291: integrity constraint (string.string) violated - parent key not found
Cause: A foreign key value has no matching primary key value.
Action: Delete the foreign key or add a matching primary key.
ORA-02292: integrity constraint (string.string) violated - child record found
Cause: attempted to delete a parent key value that had a foreign key dependency.
Action: delete dependencies first then parent or disable constraint.
ORA-02293: cannot validate (string.string) - check constraint violated
Cause: an alter table operation tried to validate a check constraint to a populated table that had nocomplying values.
Action: Obvious
ORA-02294: cannot enable (string.string) - constraint changed during validation
Cause: While one DDL statement was attempting to enable this constraint, another DDL changed this same constraint.
Action: Try again, with only one DDL changing the constraint this time.
ORA-02295: found more than one enable/disable clause for constraint
Cause: a create or alter table specified more than one enable and/or disable clause for a given constraint.
Action: only one enable or disable may be specified for a given constraint.
ORA-02296: cannot enable (string.string) - null values found
Cause: an alter table enable constraint failed because the table contains values that do not satisfy the constraint.
Action: Obvious
ORA-02297: cannot disable constraint (string.string) - dependencies exist
Cause: an alter table disable constraint failed becuase the table has foriegn keys that are dpendent on this constraint.
Action: Either disable the foreign key constraints or use disable cascade
ORA-02298: cannot validate (string.string) - parent keys not found
Cause: an alter table validating constraint failed because the table has orphaned child records.
Action: Obvious
ORA-02299: cannot validate (string.string) - duplicate keys found
Cause: an alter table validating constraint failed because the table has duplicate key values.
Action: Obvious
ORA-02300: invalid value for OIDGENERATORS
Cause: A number was not specified for the value of OIDGENERATORS.
Action: Specify a number for OIDGENERATORS.
ORA-02301: maximum number of OIDGENERATORS is 255
Cause: A number greater than 255 was specified for the value of OIDGENERATORS.
Action: Make sure the number specified for OIDGENERATORS does not exceed 255.
ORA-02302: invalid or missing type name
Cause: An invalid or missing type name was entered in a statement.
Action: Enter a valid type name in the statement and retry the operation.
ORA-02303: cannot drop or replace a type with type or table dependents
Cause: An attempt was made to drop or replace a type that has dependents. There could be a substitutable column of a supertype of the type being dropped.
Action: Drop all type(s) and table(s) depending on the type, then retry the operation using the VALIDATE option, or use the FORCE option.
ORA-02304: invalid object identifier literal
Cause: An attempt was made to enter an object identifier literal for CREATE TYPE that is either:

- not a string of 32 hexadecimal characters

- an object identifier that already identifies an existing object

- an object identifier different from the original object identifier already assigned to the type

Action: Do not specify the object identifier clause or specify a 32 hexadecimal-character object identifier literal that is unique or identical to the originally assigned object identifier. Then retry the operation.
ORA-02305: only EXECUTE, DEBUG, and UNDER privileges are valid for types
Cause: An attempt was made to GRANT or REVOKE an invalid privilege (not EXECUTE, DEBUG, or UNDER) on a type.
Action: GRANT or REVOKE only the EXECUTE, DEBUG, or UNDER privilege on types.
ORA-02306: cannot create a type that already has valid dependent(s)
Cause: An attempt was made to create a type that already has some valid dependent(s) (these dependents depend on the fact that the type does not exist).
Action: Drop the dependents first before creating the type, or do not create the type.
ORA-02307: cannot alter with REPLACE option a type that is not valid
Cause: An attempt was made to ALTER with REPLACE option a type that is not valid.
Action: Use the CREATE OR REPLACE TYPE command to modify the type.
ORA-02308: invalid option string for object type column
Cause: An attempt was made to specify an invalid option, such as PACKED or UNPACKED, for the object type column.
Action: Remove the invalid option from column specification and retry the operation.
ORA-02309: atomic NULL violation
Cause: An attempt was made to acess the attributes of a NULL object instance.
Action: Ensure that the object instance is non-NULL before accessing.
ORA-02310: exceeded maximum number of allowable columns in table
Cause: The attributes in the object type column exceeded the maximum number of columns allowed in a table.
Action: Specify fewer attributes for the object type and retry the operation.
ORA-02311: cannot alter with COMPILE option a valid type with type or table dependents
Cause: An attempt was made to ALTER with COMPILE option a type that is valid and has type or table dependents.
Action: No need to perform this operation.
ORA-02313: object type contains non-queryable type string attribute
Cause: The specified object type contains a nested attribute whose type is non-queryable.
Action: Use an object type with queryable attribute types.
ORA-02314: illegal use of type constructor
Cause: The statement contains an illegal use of a type constructor.
Action: Refer to the SQL Reference manual for the correct statement syntax.
ORA-02315: incorrect number of arguments for default constructor
Cause: The number of arguments specified for the default constructor doesn't match the number of attributes of the object type.
Action: Specify the correct number of arguments for the default constructor and retry the operation.
ORA-02320: failure in creating storage table for nested table column string
Cause: An error occurred while creating the storage table for the specified nested table column.
Action: See the messages that follow for more details. If the situation they describe can be corrected, do so; otherwise contact Oracle Support.
ORA-02322: failure in accessing storage table of the nested table column
Cause: An error occured while performing DML on the storage table of the nested table column.
Action: If the situation described in the following messages can be corrected, do so; otherwise contact Oracle Support.
ORA-02324: more than one column in the SELECT list of THE subquery
Cause: More than one column was selected in the THE subquery.
Action: Specify only one column in the SELECT list of the THE subquery and retry the operation.
ORA-02327: cannot create index on expression with datatype string
Cause: An attempt was made to create an index on a non-indexable expression.
Action: Change the column datatype or do not create the index on an expression whose datatype is one of VARRAY, nested table, object, LOB, or REF.
ORA-02329: column of datatype string cannot be unique or a primary key
Cause: An attempt was made to place a UNIQUE or a PRIMARY KEY constraint on a column of datatype VARRAY, nested table, object, LOB, FILE or REF.
Action: Change the column datatype or remove the constraint. Then retry the operation.
ORA-02330: datatype specification not allowed
Cause: An attempt was made to specify the data type in the column constraint specification of an object table.
Action: Remove data type specification and retry the operation.
ORA-02331: cannot create constraint on column of datatype string
Cause: An attempt was made to create a constraint on a column posessing a non-constrainable datatype -- VARRAY, nested table, object, LOB, FILE, or REF.
Action: Change the column datatype, or remove the constraint.
ORA-02332: cannot create index on attributes of this column
Cause: An attempt was made to create an index on an attributes of an object type column.
Action: Do not specify the index on the attribute.
ORA-02333: cannot create constraints on attributes of this column
Cause: An attempt was made to create a constraint on an attribute of an object type column.
Action: Remove the constraint or change the object type.
ORA-02334: cannot infer type for column
Cause: A datatype was not declared for this column (in the CREATE TABLE) and an attempt was made to create a constraint on an attribute of this column.
Action: Declare a datatype for the column.
ORA-02335: invalid datatype for cluster column
Cause: An attempt was made to declare a CLUSTER column of datatype object, REF, nested table, VARRAY, LOB, or FILE.
Action: Remove the CLUSTER column or change the datatype of the column.
ORA-02336: column attribute cannot be accessed
Cause: An attempt was made to extract an attribute of an object type column.
Action: Change the object type for the column and retry the operation.
ORA-02337: not an object type column
Cause: An attempt was made to use dotted notation on a non-ADT column; that is, "a.b.c" where "a" is not an object type.
Action: Either change the column type to an object type or do not perform this operation.
ORA-02338: missing or invalid column constraint specification
Cause: A column constraint was not specified.
Action: Remove the column specification or specify a column constraint. Then retry the operation.
ORA-02339: invalid column specification
Cause: An attempt was made to specify the PACKED or UNPACKED keyword for a non-object type column.
Action: Remove the PACKED or UNPACKED keyword in the column specification and retry the operation.
ORA-02340: invalid column specification
Cause: An attempt was made to specify an UNPACKED column within a packed table.
Action: Remove the UNPACKED keyword in the column specification.
ORA-02342: replacement type has compilation errors
Cause: The use of the ALTER...REPLACE statement on a valid type caused a compilation error.
Action: Use the ALTER...REPLACE statement to replace the type with a valid type which does not cause compilation errors.
ORA-02344: cannot revoke execute on a type with table dependents
Cause: An attempt was made to revoke execute on a type that has dependents.
Action: Drop all table(s) depending on the type, then retry the operation, or use the FORCE option.
ORA-02345: cannot create a view with column based on CURSOR operator
Cause: A CURSOR operator was used as one of the SELECT elements in the subquery of a CREATE VIEW or CREATE TABLE ... AS SELECT statement.
Action: Remove the CURSOR operator and replace it with the CAST operator.
ORA-02347: cannot grant privileges on columns of an object table
Cause: An attempt was made to grant privileges on the columns of an object table.
Action: none
ORA-02348: cannot create VARRAY column with embedded LOB
Cause: An attempt was made to create a column of a VARRAY type which has an embedded LOB attribute. The LOB could be an attribute of a subtype of the declared type of VARRAY's element.
Action: Remove offending attribute from type. If it is a subtype attribute then declare the VARRAY column NOT SUBSTITUTABLE.
ORA-02349: invalid user-defined type - type is incomplete
Cause: An attempt was made to use an incomplete type definition as a column or table datatype.
Action: Complete the type definition and retry the operation.
ORA-02351: internal error: string
Cause: An unexpected error condition was detected.
Action: Call Oracle Customer Support.
ORA-02352: file truncated error
Cause: A truncated file was used for the load operation.
Action: Verify unload operation completed successfully.
ORA-02353: files not from the same unload operation
Cause: Files used for the load operation were not from the same unload operation.
Action: Verify the files used are from the same unload operation.
ORA-02354: error in exporting/importing data string
Cause: An error has occurred in a stream export or import operation. This message will be followed by another message giving more details about this error.
Action: See export/import documentation for an explanation of the second error message.
ORA-02355: error opening file: string
Cause: An attempt to open the specified file for data export/import failed.
Action: Review the error message. Resolve the problem and retry the the operation. Contact Oracle Support Services if the problem cannot be resolved.
ORA-02356: The database is out of space. The load cannot continue
Cause: The load was discontinued due to space exhaustion in the database.
Action: Add space for the specified table.
ORA-02357: no valid dump files
Cause: None of the dump files for the operation were valid. A minimum of one valid dump file is expected.
Action: Check that the dump files exist and are openable.
ORA-02358: internal error fetching attribute string
Cause: An attempt to fetch information about an internal object failed.
Action: Contact Oracle Support Services.
ORA-02359: internal error setting attribute string
Cause: An attempt to set information about an internal object failed.
Action: Contact Oracle Support Services.
ORA-02360: fatal error during data export/import initialization
Cause: An unexpected error occurred during initialization for data export/import.
Action: Contact Oracle Support Services.
ORA-02361: error while attempting to allocate number bytes of memory
Cause: d by insufficient memory.
Action: Reconnect to the instance and retry the operation.
ORA-02362: error closing file: string
Cause: An attempt to close the specified file for data export/import failed.
Action: Review the error message. Resolve the problem and retry the the operation. Contact Oracle Support Services if the problem cannot be resolved.
ORA-02363: error reading from file: string
Cause: An attempt to read from the specified file for data export/import failed.
Action: Review the error message. Resolve the problem and retry the the operation. Contact Oracle Support Services if the problem cannot be resolved.
ORA-02364: error writing to file: string
Cause: An attempt to write to the specified file for data export/import failed.
Action: Review the error message. Resolve the problem and retry the the operation. Contact Oracle Support Services if
ORA-02365: error seeking in file: string
Cause: An attempt to seek to the specified position in file failed.
Action: Review the error message. Resolve the problem and retry the the operation. Contact Oracle Support Services if
ORA-02366: The following index(es) on table string were processed:
Cause: The table had some indexes which were loaded if there were no errors.
Action: none.
ORA-02367: file truncated error in string
Cause: A truncated or incomplete file was used for the load operation.
Action: Verify unload operation completed successfully.
ORA-02368: file string is not valid for this load operation
Cause: The specified file could not be used for this load because the internal header and/or table metadata of this file were not consistent with those of the first file listed in the DUMPFILE clause.
Action: Verify all the files listed in the DUMPFILE clause are from the same unload operation.
ORA-02371: Loader must be at least version string.string.string.string.string for direct path
Cause: The loader being used is incompatible with this version of the kernel.
Action: Upgrade your loader to at least the specified version or use the conventional path.
ORA-02372: data for row: string
Cause: A conversion error occurred while loading data into a table. The message shows values for the field in the row that had the conversion error.
Action: None. This is only an informational message.
ORA-02373: Error parsing insert statement for table string.
Cause: self-evident.
Action: Check the error given below this one.
ORA-02374: conversion error loading table string.string
Cause: A row could not be loaded into the table because there was a conversion error for one or more columns in a row.
Action: See the message that follows for more information about the row that could not be loaded. To avoid this error, make sure the definition of the table being imported matches the definition of the table being exported.
ORA-02375: conversion error loading table string.string partition string
Cause: A row could not be loaded into the table because there was a conversion error for one or more columns in a row.
Action: See the message that follows for more information about the row that could not be loaded. To avoid this error, make sure the definition of the table being imported matches the definition of the table being exported.
ORA-02376: invalid or redundant resource
Cause: a create, or alter profile command which names a resource not yet defined, or try to specify same resource twice.
Action: define resource first
ORA-02377: invalid resource limit
Cause: specifying limit of 0
Action: specify limit > 0
ORA-02379: profile string already exists
Cause: Try to create a profile which already exist
Action: none
ORA-02380: profile string does not exist
Cause: Try to assign a user to a non-existant profile
Action: none
ORA-02381: cannot drop PUBLIC_DEFAULT profile
Cause: Try to drop PUBLIC_DEFAULT profile
Action: none
ORA-02383: illegal cost factor
Cause: Negative or UNLIMITED cost for this resourc
Action: none
ORA-02391: exceeded simultaneous SESSIONS_PER_USER limit
Cause: An attempt was made to exceed the maximum number of concurrent sessions allowed by the SESSION_PER_USER clause of the user prfile.
Action: End one or more concurrent sessions or ask the database administrator to increase the SESSION_PER_USER limit of the user profile.
ORA-02396: exceeded maximum idle time, please connect again
Cause: as stated
Action: none
ORA-02397: exceeded PRIVATE_SGA limit, you are being logged off
Cause: Only when using TP monitor
Action: expand limit
ORA-02398: exceeded procedure space usage
Cause: Stored procedured used up too much space in SYSTEM Tablespace
Action: Use less stored procedure
ORA-02399: exceeded maximum connect time, you are being logged off
Cause: As stated
Action: none
ORA-02401: cannot EXPLAIN view owned by another user
Cause: The view specified in the SQL statement belongs to another user and cannot be explained.
Action: Create a view with the same definition that belongs to current user.
ORA-02402: PLAN_TABLE not found
Cause: The table used by EXPLAIN to store row source information does not exist in the current schema.
Action: Create a plan table in the current schema or use the INTO clause of the statement to put the results of the explain command in an existing plan table.
ORA-02403: plan table does not have correct format
Cause: The explicit plan table does not have the appropriate field definitions.
Action: Redefine the plan table to have the appropriate field definitions.
ORA-02404: specified plan table not found
Cause: The specified plan table does cannot be found.
Action: Create the specified plan table or use an existing plan table.
ORA-02420: missing schema authorization clause
Cause: the AUTHORIZATION clause is missing from a create schema statement.
Action: Preceed the schema authorization identifier with the AUTHORIZATION keyword.
ORA-02421: missing or invalid schema authorization identifier
Cause: the schema name is missing or is incorrect in an authorization clause of a create schema statement.
Action: If the name is present, it must be the same as the current schema.
ORA-02422: missing or invalid schema element
Cause: A statement other than a create table, create view, or grant privilege appears in a create schema statement.
Action: Self-evident.
ORA-02423: schema name does not match schema authorization identifier
Cause: a table definition with a schema name prepended to the table name does not match the schema name provided in the authorization clause of a create schema statement.
Action: make sure the schema names match.
ORA-02424: potential circular view references or unknown referenced tables
Cause: the create schema statement contains views that depend on other views in the containing create schema statement or they contain references to unknown tables.
Action: create the dependent views in a separate create schema statement and make sure all referenced tables are either defined in the create schema statement or exist outside the statement.
ORA-02425: create table failed
Cause: a create table statement failed in the create schema statement.
Action: the cause for failure will be presented below this error message. Follow appropriate action(s) as suggested by the subsequent error message.
ORA-02426: privilege grant failed
Cause: a grant privilege statement failed inthe create schema statement.
Action: the cause for failure will be presented below this error message. Follow appropriate action(s) as suggested by the subsequent error message.
ORA-02427: create view failed
Cause: a create view statement failed in the create schema statement.
Action: the cause for failure will be presented below this error message. Follow appropriate action(s) as suggested by the subsequent error message.
ORA-02428: could not add foreign key reference
Cause: could not add a foreign key reference because of error in declaration. Either referenced table does not exist or table does not have an unique key.
Action: make sure referenced table exists and/or has unique key
ORA-02429: cannot drop index used for enforcement of unique/primary key
Cause: user attempted to drop an index that is being used as the enforcement mechanism for unique or primary key.
Action: drop the constraint instead of the index.
ORA-02430: cannot enable constraint (string) - no such constraint
Cause: the named constraint does not exist for this table.
Action: Obvious
ORA-02431: cannot disable constraint (string) - no such constraint
Cause: the named constraint does not exist for this table.
Action: Obvious
ORA-02432: cannot enable primary key - primary key not defined for table
Cause: Attempted to enable a primary key that is not defined for the table.
Action: Need to add a primary key definition for the table.
ORA-02433: cannot disable primary key - primary key not defined for table
Cause: Attempted to disable a primary key tht is not defined for the table.
Action: None
ORA-02434: cannot enable unique(string) - unique key not defined for table
Cause: attempted to enable a unique key that is not defined for the table.
Action: None
ORA-02435: cannot disable unique(string) - unique key not defined for table
Cause: attempted to disable a unique key that is not deined for the table.
Action: None
ORA-02436: date or system variable wrongly specified in CHECK constraint
Cause: An attempt was made to use a date constant or system variable, such as USER, in a check constraint that was not completely specified in a CREATE TABLE or ALTER TABLE statement. For example, a date was specified without the century.
Action: Completely specify the date constant or system variable. Setting the event 10149 allows constraints like "a1 > '10-MAY-96'", which a bug permitted to be created before version 8.
ORA-02437: cannot validate (string.string) - primary key violated
Cause: attempted to validate a primary key with duplicate values or null values.
Action: remove the duplicates and null values before enabling a primary key.
ORA-02438: Column check constraint cannot reference other columns
Cause: attempted to define a column check constraint that references another column.
Action: define it as a table check constriant.
ORA-02439: Unique index on a deferrable constraint is not allowed
Cause: attempted to enable a deferrable primary key/unique constraint that has an existing unique index on the constraint columns.
Action: Drop the index on the constraint columns or make the constraint not deferrable.
ORA-02440: Create as select with referential constraints not allowed
Cause: create table foo (... ref. con. ...) as select ...;
Action: Create the table as select, then alter the table to add the constraints afterwards.
ORA-02441: Cannot drop nonexistent primary key
Cause: alter table drop primary key - primary key does not exist.
Action: None
ORA-02442: Cannot drop nonexistent unique key
Cause: alter table drop unique (<col list>) - unique specification does not exist.
Action: make sure column list for unique constraint is correct.
ORA-02443: Cannot drop constraint - nonexistent constraint
Cause: alter table drop constraint <constraint_name>
Action: make sure you supply correct constraint name.
ORA-02444: Cannot resolve referenced object in referential constraints
Cause: attempted to define foreign key referencing an object which cannot be resolved to a base table reference
Action: referential constraints can only be defined on objects which can be resolve to base table reference
ORA-02445: Exceptions table not found
Cause: the explicity or implicity declared exceptions table does not exist.
Action: Create the table then issue the enable command again.
ORA-02446: CREATE TABLE ... AS SELECT failed - check constraint violated
Cause: An attempt was made to use a CREATE TABLE ... AS SELECT statement when some rows violated one or more CHECK constraints.
Action: Do not select rows that violate constraints.
ORA-02447: cannot defer a constraint that is not deferrable
Cause: An attempt was made to defer a nondeferrable constraint
Action: Drop the constraint and create a new one that is deferrable
ORA-02448: constraint does not exist
Cause: The named constraint does not exist
Action: Stop trying to do something with a nonexistant constraint
ORA-02449: unique/primary keys in table referenced by foreign keys
Cause: An attempt was made to drop a table with unique or primary keys referenced by foreign keys in another table.
Action: Before performing the above operations the table, drop the foreign key constraints in other tables. You can see what constraints are referencing a table by issuing the following command: SELECT * FROM USER_CONSTRAINTS WHERE TABLE_NAME = "tabnam";
ORA-02450: Invalid hash option - missing keyword IS
Cause: Missing IS keyword.
Action: Specify HASH IS option.
ORA-02451: duplicate HASHKEYS specification
Cause: The HASHKEYS option is specified more than once.
Action: Only specify the HASHKEYS option once.
ORA-02452: invalid HASHKEYS option value
Cause: The specified HASHKEYS option must be an integer value.
Action: Specify an appropriate value.
ORA-02453: duplicate HASH IS specification
Cause: The HASH IS option is specified more than once.
Action: only specify the HASH IS option once.
ORA-02454: Number of hash keys per block (string) exceeds maximum of string
Cause: The SIZE argument is too small.
Action: Increase the SIZE argument.
ORA-02455: The number of cluster key column must be 1
Cause: When specifing the HASH IS option, the number of key columns must be 1.
Action: Either do not specify the HASH IS option or reduce the number of key columns.
ORA-02456: The HASH IS column specification must be NUMBER(*,0)
Cause: The column specification must specify an integer.
Action: Specify the column definition as type NUMBER(precision, 0).
ORA-02457: The HASH IS option must specify a valid column
Cause: The HASH IS column name is not specified in the cluster definition.
Action: Specify a valid column name.
ORA-02458: HASHKEYS must be specified for a HASH CLUSTER
Cause: The HASHKEYS option must be specified when creating a HASH CLUSTER.
Action: Specify the HASHKEYS option.
ORA-02459: Hashkey value must be a positive integer
Cause: The value of the hash key was not a positive number.
Action: Specify a positive integer.
ORA-02460: Inappropriate index operation on a hash cluster
Cause: An attempt to create a cluster index was issued on a hash cluster.
Action: Do not attempt to create such an index.
ORA-02461: Inappropriate use of the INDEX option
Cause: This option is only valid for non hash clusters.
Action: Do not specify this option.
ORA-02462: Duplicate INDEX option specified
Cause: The INDEX option is specified more than once.
Action: Only specify the INDEX option once.
ORA-02463: Duplicate HASH IS option specified
Cause: The HASH IS option is specified more than once.
Action: Only specify the HASH IS option once.
ORA-02464: Cluster definition can not be both HASH and INDEX
Cause: The cluster can either be a hash or indexed cluster - not both.
Action: Remove either the HASH IS or INDEX options.
ORA-02465: Inappropriate use of the HASH IS option
Cause: This option is only valid for clusters
Action: Do not specify this option
ORA-02466: The SIZE and INITRANS options cannot be altered for HASH CLUSTERS.
Cause: An attempt was made to change the SIZE and INITRANS options after the hash cluster was created.
Action: Do not specify this option.
ORA-02467: Column referenced in expression not found in cluster definition
Cause: A column in the hash is expression was not present in cluster definition.
Action: Recreate the cluster and correct the error in hash expression.
ORA-02468: Constant or system variable wrongly specified in expression
Cause: A constant or system variable was specified in the hash expression.
Action: Recreate the cluster and correct the error in hash expression.
ORA-02469: Hash expression does not return an Oracle Number.
Cause: Result of evaluating hash expression is not an Oracle Number.
Action: Recreate the cluster and correct the error in hash expression.
ORA-02470: TO_DATE, USERENV, or SYSDATE incorrectly used in hash expression.
Cause: TO_DATE, USERENV and SYSDATE are not allowed in hash expressions.
Action: Recreate the cluster and correct the error in hash expression.
ORA-02471: SYSDATE, UID, USER, ROWNUM, or LEVEL incorrectly used in hash expre\ssion.
Cause: SYSDATE, UID, USER, ROWNUM, or LEVEL are not allowed in hash expression\s.
Action: Recreate the cluster and remove the offending keywords.
ORA-02472: PL/SQL functions not allowed in hash expressions
Cause: A PL/SQL function was used in the hash expression.
Action: Recreate the cluster and remove the PL/SQL function.
ORA-02473: Error while evaluating the cluster's hash expression.
Cause: An error occurred while evaluating the clusters hash expression.
Action: Correct the query and retry.
ORA-02474: Fixed hash area extents used (string) exceeds maximum allowed (string)
Cause: The number of extents required for creating the fixed hash area exceeds the maximum number allowed.
Action: Reduce the number of extents required by increasing the extent allocation sizes within the STORAGE clause.
ORA-02475: maximum cluster chain block count of string has been exceeded
Cause: The number of blocks in a cluster chain exceeds the maximum number allowed.
Action: Increase SIZE parameter in CREATE CLUSTER statement or reconsider suitability of cluster key.
ORA-02476: can not create index due to parallel direct load on table
Cause: A parallel direct load is occurring to the specified table.
Action: Retry statement after load is complete.
ORA-02477: can not perform parallel direct load on object string
Cause: A parallel direct load is not possible because an index is is being created on the table.
Action: Retry load after index creation is complete.
ORA-02478: merge into base segment would overflow MAXEXTENTS limit
Cause: Merge of temporary segment into base segment failed because MAXEXTENTS was larger than the total in the temp and base segments
Action: Use a larger value for MAXEXTENTS on the base segment or make the extents in the temporary segments larger
ORA-02479: error while translating file name for parallel load
Cause: An invalid file name was specified to load data into.
Action: Specify a valid database file.
ORA-02481: Too many processes specified for events (max string)
Cause: Too many processes specified than allowed per event.
Action: Enter fewer processes by using ranges or wildcards if possible.
ORA-02482: Syntax error in event specification (string)
Cause: Illegal event string
Action: Enter a legal event string
ORA-02483: Syntax error in process specification (string)
Cause: Illegal process string
Action: Enter a legal process string
ORA-02484: Invalid _trace_buffers parameter specification (string)
Cause: Bad process or size in _trace_buffers INIT.ORA parameter.
Action: none
ORA-02485: Invalid _trace_options parameter specification (string)
Cause: Bad syntax for _trace_options INIT.ORA parameter.
Action: none
ORA-02486: Error in writing trace file string
Cause: Error occurred in creating/writing the file.
Action: Check file name and make sure it is constructed properly. Also, check permissions for directories.
ORA-02487: Error in converting trace data
Cause: Incompatible binary trace data was specified.
Action: Check the format of the input data.
ORA-02488: Error encountered when accessing file [string] for trace conversion
Cause: An attempt was made to open or access the trace file during a trace conversion.
Action: Check the permissions for both input and output files. Also, check the file compatibility for the trace conversion.
ORA-02490: missing required file size in RESIZE clause
Cause: No value was specified for the RESIZE clause.
Action: Use correct syntax.
ORA-02491: missing required keyword ON or OFF in AUTOEXTEND clause
Cause: The keyword ON or OFF was not specified for the AUTOEXTEND clause.
Action: Use correct syntax.
ORA-02492: missing required file block increment size in NEXT clause
Cause: No value was specified for the NEXT clause.
Action: Use correct syntax.
ORA-02493: invalid file increment size in NEXT clause
Cause: A non-integer value was used for the NEXT clause of the DATAFILE list.
Action: Use correct syntax.
ORA-02494: invalid or missing maximum file size in MAXSIZE clause
Cause: UNLIMITED was not specified, or an invalid integer value was specified, for the MAXSIZE clause in the DATAFILE file list. The MAXSIZE value cannot be smaller than the SIZE value.
Action: Use correct syntax.
ORA-02495: cannot resize file string, tablespace string is read only
Cause: An attempt was made to resize a data file in a tablespace that is read only.
Action: Change the tablespace to read/write and retry the resize operation.
ORA-02700: osnoraenv: error translating ORACLE_SID
Cause: Two-task driver could not find the value of ORACLE_SID in the environment.
Action: Make sure that the ORACLE_SID environment variable has been properly set and exported.
ORA-02701: osnoraenv: error translating oracle image name
Cause: ORACLE_HOME environment variable not set.
Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported.
ORA-02702: osnoraenv: error translating orapop image name
Cause: ORACLE_HOME environment variable not set.
Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported.
ORA-02703: osnpopipe: pipe creation failed
Cause: The pipe driver failed to create pipes for communications with the orapop process.
Action: You have probably exceeded the maximum number of open file descriptors per user or the system file table is full. Note the operating system error code and contact your system administrator.
ORA-02704: osndopop: fork failed
Cause: The two-task driver could not fork orapop.
Action: Verify that there are enough system resources to support another process. The user or system process limit may have been exceeded, or the amount of free memory or swap space may be temporarily insufficient.
ORA-02705: osnpol: polling of communication channel failed
Cause: The pipe driver failed while polling the communications channel.
Action: Contact your customer support representative.
ORA-02706: osnshs: host name too long
Cause: The length of your host-string specified by the TWO_TASK environment variable exceeds the ORACLE system-imposed limit.
Action: Contact your customer support representative.
ORA-02707: osnacx: cannot allocate context area
Cause: The invoked Unix two-task driver could not allocate heap space for the context area.
Action: Contact your customer support representative.
ORA-02708: osnrntab: connect to host failed, unknown ORACLE_SID
Cause: The invoked Unix two-task driver failed to find an entry in oratab for the sid you supplied.
Action: First, check whether you have read access to oratab, and see if the desired sid is there. Add an entry to oratab for the desired sid, if necessary.
ORA-02709: osnpop: pipe creation failed
Cause: The pipe driver failed to create pipes for two-task communications with the oracle shadow process.
Action: You have probably exceeded the maximum number of open file descriptors per user or the system file table is full. Note the operating system error code and contact your system administrator.
ORA-02710: osnpop: fork failed
Cause: The pipe driver could not fork the oracle shadow process.
Action: Verify that there are enough system resources to support another process. The user or system process limit may have been exceeded, or the amount of free memory or swap space may be temporarily insufficient.
ORA-02711: osnpvalid: write to validation channel failed
Cause: The pipe driver failed to write to the orapop process.
Action: Contact your customer support representative.
ORA-02712: osnpop: malloc failed
Cause: The pipe driver failed to allocate enough heap space for its context area buffers.
Action: Contact your customer support representative.
ORA-02713: osnprd: message receive failure
Cause: The pipe driver failed to read a message from the communications channel.
Action: Contact your customer support representative.
ORA-02714: osnpwr: message send failure
Cause: The pipe driver failed to write a message to the communications channel.
Action: Contact your customer support representative.
ORA-02715: osnpgetbrkmsg: message from host had incorrect message type
Cause: The pipe driver received a message having an unrecognizable message type.
Action: Contact your customer support representative.
ORA-02716: osnpgetdatmsg: message from host had incorrect message type
Cause: The Pipe driver received a message having an unrecognizable message type.
Action: Contact your customer support representative.
ORA-02717: osnpfs: incorrect number of bytes written
Cause: The Pipe driver sent a message that was apparently successful, but the number of bytes transmitted did not match the number of bytes furnished to the driver.
Action: Contact your customer support representative.
ORA-02718: osnprs: reset protocol error
Cause: The two-task driver could not reset the connection.
Action: Contact your customer support representative.
ORA-02719: osnfop: fork failed
Cause: The fast driver could not fork the oracle shadow process.
Action: Verify that there are enough system resources to support another process. The user or system process limit may have been exceeded, or the amount of free memory or swap space may be temporarily insufficient.
ORA-02720: osnfop: shmat failed
Cause: When the fast driver was invoked, processes failed to attach to the shared memory buffer. You probably supplied an illegal shared memory attach address, or the system ran out of data space to accomodate the buffer.
Action: Try invoking the Fast driver later, or use the default attach address.
ORA-02721: osnseminit: cannot create semaphore set
Cause: The Fast driver failed to get a semaphore set.
Action: The system-imposed limit on semaphores or semaphore identifiers may have been exceeded. Read the returned operating system error code and check with your system administrator.
ORA-02722: osnpui: cannot send break message to orapop
Cause: The Pipe driver could not send a break message to orapop.
Action: Contact your customer support representative.
ORA-02723: osnpui: cannot send break signal
Cause: The Pipe driver could not send a break message to the ORACLE shadow process.
Action: Contact your customer support representative.
ORA-02724: osnpbr: cannot send break message to orapop
Cause: The Pipe driver could not send a break message to orapop.
Action: Contact your customer support representative.
ORA-02725: osnpbr: cannot send break signal
Cause: The Pipe driver could not send a break message to the ORACLE shadow process.
Action: Kill system call failed. Check errno and contact customer support.
ORA-02726: osnpop: access error on oracle executable
Cause: The Pipe driver could not access the oracle executable.
Action: Check the permissions on the ORACLE executable and each component of the ORACLE_HOME/bin path.
ORA-02727: osnpop: access error on orapop executable
Cause: The Pipe driver could not access the orapop executable.
Action: Check the permissions on the orapop executable and each component of the ORACLE_HOME/bin path.
ORA-02728: osnfop: access error on oracle executable
Cause: The Fast driver could not access the oracle executable.
Action: Check the permissions on the ORACLE executable and each component of the ORACLE_HOME/bin path.
ORA-02729: osncon: driver not in osntab
Cause: The driver you have specified is not supported.
Action: Check with your database administrator which drivers are supported.
ORA-02730: osnrnf: cannot find user logon directory
Cause: The driver you have specified could not find your logon directory while searching for your local .sqlnet file.
Action: Set and export the HOME environment variable to identify your home directory. Check with your system administrator to make sure that your uid and home directory are correct in the /etc/passwd file.
ORA-02731: osnrnf: malloc of buffer failed
Cause: The specified driver could not find enough heap space to malloc a buffer.
Action: Contact your customer support representative.
ORA-02732: osnrnf: cannot find a matching database alias
Cause: Database alias specified was not identified in either $HOME/.sqlnet or /etc/sqlnet.
Action: Create the alias in a file called .sqlnet in your home directory for personal use or ask your system administrator to create the alias in /etc/sqlnet for system-wide use.
ORA-02733: osnsnf: database string too long
Cause: While converting a database alias to a database ID, the resulting database ID string exceeded the ORACLE system-imposed limit.
Action: Contact your customer support representative.
ORA-02734: osnftt: cannot reset shared memory permission
Cause: The Fast driver was unable to reset shared memory permissions.
Action: Contact your customer support representative.
ORA-02735: osnfpm: cannot create shared memory segment
Cause: The Fast driver failed to create a shared memory segment for two-task communication.
Action: Check whether the system-imposed limit on shared memory identifiers has already been reached for your system.
ORA-02736: osnfpm: illegal default shared memory address
Cause: The Fast driver failed to establish a default shared memory address.
Action: Contact your customer support representative.
ORA-02737: osnpcl: cannot tell orapop to exit
Cause: The Pipe driver failed to send orapop the command to exit.
Action: Contact your customer support representative.
ORA-02738: osnpwrtbrkmsg: incorrect number of bytes written
Cause: The pipe driver apparently sent an imcomplete break message.
Action: Contact your customer support representative.
ORA-02739: osncon: host alias is too long
Cause: The alias used for a sqlnet host is longer than 161 characters.
Action: Use a shorter alias.
ORA-02750: osnfsmmap: cannot open shared memory file ?/dbs/ftt_<pid>.dbf
Cause: The Fast driver failed to create a shared memory file for two-task communication.
Action: Check the permissions on the directory ?/dbs
ORA-02751: osnfsmmap: cannot map shared memory file
Cause: The Fast driver failed to map a shared memory file for two-task communication.
Action: Contact your customer support representative.
ORA-02752: osnfsmmap: illegal shared memory address
Cause: The Fast driver failed to attach shared memory at the expected location.
Action: Contact your customer support representative.
ORA-02753: osnfsmmap: cannot close shared memory file
Cause: The Fast driver cannot close the shared memory file.
Action: Contact your customer support representative.
ORA-02754: osnfsmmap: cannot change shared memory inheritence
Cause: The Fast driver could not alter the inheritence attributes of the shared memory.
Action: Contact your customer support representative.
ORA-02755: osnfsmcre: cannot create chared memory file ?/dbs/ftt_<pid>.dbf
Cause: The Fast driver failed to create a file for shared memory.
Action: Check the permissions on the directory ?/dbs
ORA-02756: osnfsmnam: name translation failure
Cause: The Fast driver encountered an error translating the shared memory filename ?/dbs/ftt_<pid>.dbf.
Action: Contact your customer support representative.
ORA-02757: osnfop: fork_and_bind failed
Cause: The Fast driver failed to fork a process onto the desired cluster and node number.
Action: Check the desired node number in sercose[0] and cluster ID in sercose[1]. If these seem valid, contact customer support.
ORA-02758: Allocation of internal array failed
Cause: The package was unable to allocate memory for an array because the system ran out of memory.
Action: Either reclaim memory by killing other processes or reboot the machine with more memory.
ORA-02759: Not enough request descriptors available
Cause: All of the package's request descriptors are in use performing other requests.
Action: Either wait until enough requests are done, or shut the package down and re-initialize it with more request descriptors.
ORA-02760: Client close of file failed.
Cause: The client was unable to close a file after forking the servers.
Action: This is a system problem - contact your System Administrator.
ORA-02761: File number to be canceled is negative.
Cause: The file number contained with the sfiov structure is less than zero.
Action: This may be a programming error. If it is not, contact ORACLE support.
ORA-02762: file number to be cancelled is greater than the maximum.
Cause: The file number contained with the sfiov structure is greater than the maximum.
Action: This may be a programming error. If it is not, contact ORACLE support.
ORA-02763: Unable to cancel at least one request
Cause: No requests were found that could be cancelled.
Action: This error can occur if all the requests dealing with that file number have already been filled.
ORA-02764: Invalid package mode
Cause: The mode of the package can only be parallel or duplex.
Action: See sfa.h for the correct values.
ORA-02765: Invalid maximum number of servers
Cause: The number of servers given was less than or equal to zero.
Action: Use a number greater than zero.
ORA-02766: Invalid maximum of request descriptors
Cause: The number of request descriptors was less than or equal to zero.
Action: Use a number greater than zero.
ORA-02767: Less than one request descriptor was allocated per server
Cause: The package requires that the number of request descriptors be greater than or equal to the number of servers used.
Action: Use a higher number
ORA-02768: Maximum number of files is invalid
Cause: The maximum number of files to be used by the package was less than or equal to zero.
Action: Use a positive number.
ORA-02769: Setting of handler for SIGTERM failed
Cause: The package was unable to set up handling by the server for the termination signal. This is an internal error.
Action: Contact ORACLE support.
ORA-02770: Total number of blocks is invalid
Cause: The total number of blocks to be allocated for use by the package was not greater than zero.
Action: Use a positive number.
ORA-02771: Illegal request time out value
Cause: The number was not a positive number.
Action: Use a positive number.
ORA-02772: Invalid maximum server idle time
Cause: The time given was not a positive number.
Action: Use a positive number.
ORA-02773: Invalid maximum client wait time
Cause: The time given was not a positive number.
Action: Use a positive number.
ORA-02774: Invalid request list latch time out value
Cause: The time given was not a positive number.
Action: Use a positive number.
ORA-02775: Invalid request done signal
Cause: The signal number was not a positive number.
Action: Use a positive number.
ORA-02776: Value for request done signal exceeds maximum
Cause: The value sent to the package for use as the "request done" signal exceeds the maximum allowed by the operating system.
Action: none
ORA-02777: Stat failed on log directory
Cause: The package was unable to get information about the directory in which the log files are to reside.
Action: Check the permissions on the directory or use a different directory name.
ORA-02778: Name given for the log directory is invalid
Cause: The name given for the directory in which the logs are to be kept does not correspond to a directory.
Action: Use a different name.
ORA-02779: Stat failed on core dump directory
Cause: The package was unable to get information about the directory into which the servers are to dump core in the event of an exception.
Action: Check the permissions on the directory or use a different directory name.
ORA-02780: Name given for the core dump directory is invalid
Cause: The name given for the directory in which the server processes are to dump core in the event of an exception does not correspond to a directory.
Action: Use a different name.
ORA-02781: Invalid value given for the timing wanted flag
Cause: The value given was not TRUE or FALSE.
Action: none
ORA-02782: Both read and write functions were not specified
Cause: To ensure that the functions act symmetrically, pointers to both the read and write functions must be given.
Action: Either specify both functions or specify neither. The package will supply its own functions.
ORA-02783: Both post and wait functions were not specified
Cause: To ensure that the functions act symmetrically, pointers to both the posting and waiting functions must be given.
Action: Either specify both functions or specify neither. The package will supply its own functions.
ORA-02784: Invalid shared memory ID specified
Cause: The ID of the segment specified for use as the shared buffer region was invalid.
Action: Use a different ID, or let the package specify its own.
ORA-02785: Invalid shared memory buffer size
Cause: The size given for the shared memory segment to be used as the shared buffer region was less than or equal to zero.
Action: Use a positive number.
ORA-02786: Size needed for shared region is greater than segment size
Cause: The size of the shared segment that was specified for the shared buffer region is less than the number of bytes required. The first field of the "additional information" field is the size needed. The second is the size of the segment.
Action: Use a larger size segment or let the package allocate its own.
ORA-02787: Unable to allocate memory for segment list
Cause: The package cannot allocate memory for an internal segment list because the system has run out of memory. The "additional information" field is the amount of memory that the package attempted to allocate.
Action: none
ORA-02788: Unable to find kernel process pointer in async process array
Cause: Internal error - Contact ORACLE support.
Action: none
ORA-02789: Maximum number of files reached
Cause: The maximum number of files that can be used for asynchronous I/O has been reached.
Action: Shut down the servers and re-initialize the package with a higher number.
ORA-02790: File name is too long
Cause: The length of the name of a file that is being opened for asynchronous I/O is longer than the maximum. The "additional information" field is the maximum length.
Action: Use a shorter name.
ORA-02791: Unable to open file for use with asynchronous I/O
Cause: The package could not open file for some reason.
Action: Check the file name.
ORA-02792: Unable to fstat() a file being used for asynchronous I/O.
Cause: The fstat(2) call on a file being used for asynchronous I/O failed.
Action: Check the file name.
ORA-02793: Close of asynchronous I/O failed.
Cause: The client was unable to close a file being used for asynchronous I/O.
Action: Contact ORACLE support - this should not happen.
ORA-02794: Client unable to get key for shared memory
Cause: The client was unable to get a key so that it obtain shared memory for use with shared memory.
Action: Contact ORACLE support - this is an internal error.
ORA-02795: Request list is empty
Cause: The client was signalled by a server that it was done with a request but the "done" list was empty.
Action: Internal error - contact ORACLE support.
ORA-02796: Done request is not in correct state
Cause: A request is not in the right state.
Action: Internal error - contact ORACLE support.
ORA-02797: No requests available
Cause: No free request descriptors are available.
Action: Wait until some requests are filled and then retry the request, or shutdown the servers and initialize the package with a higher number of requests.
ORA-02798: Invalid number of requests
Cause: The number of operations sent to either sfard() or sfawrite() is less than zero.
Action: This is a user programming error.
ORA-02799: Unable to arm signal handler
Cause: The arming of a signal handler for the "done" signal failed.
Action: Internal error - contact ORACLE support.
ORA-02800: Requests timed out
Cause: Some of the requests for asynchronous input or output were not serviced in the required amount of time.
Action: If the load on the system is high, it is possible that the timeout limit is too low. Reset it with sfainit(). If the server processes are dying due to unexpected signals, this is an internal error, and ORACLE support should be contacted.
ORA-02801: Operations timed out
Cause: Some asynchronous operations timed out in kernel mode.
Action: Internal error - contact ORACLE support.
ORA-02802: No idle servers available in parallel mode
Cause: Internal error.
Action: Contact ORACLE support.
ORA-02803: Retrieval of current time failed
Cause: Internal error.
Action: Contact ORACLE support.
ORA-02804: Allocation of memory failed for log file name
Cause: The client was unable to allocated a buffer for the name of the log file.
Action: Contact your System Administrator.
ORA-02805: Unable to set handler for SIGTPA
Cause: Internal error.
Action: Contact ORACLE support.
ORA-02806: Unable to set handler for SIGALRM
Cause: Internal error.
Action: Contact ORACLE support.
ORA-02807: Allocation of memory for I/O vectors failed.
Cause: The client was unable to allocate memory for the array of I/O vectors that the servers are to use.
Action: Contact your System Administrator.
ORA-02808: Allocation of memory of open files array failed.
Cause: The client was unable to allocate memory for an array of flags that the servers are to use.
Action: Contact your System Administrator.
ORA-02809: Jump buffer not valid
Cause: Internal error.
Action: Contact ORACLE support.
ORA-02813: Unable to make temporary file name in order to get key
Cause: Internal error.
Action: Contact ORACLE support.
ORA-02814: Unable to get shared memory
Cause: Shmget(2) failed.
Action: Check the UNIX number. If you are unsure about what it means, contact ORACLE customer support.
ORA-02815: Unable to attach shared memory
Cause: Shmat(2) failed.
Action: Check the UNIX number. If you are unsure about what it means, contact ORACLE customer support.
ORA-02816: Unable to kill a process
Cause: A server did not die after being sent a kill signal.
Action: The process may be a runaway - contact ORACLE customer support.
ORA-02817: Read failed
Cause: A server could not read a requested amount of data.
Action: Check the call to sfard(). An incorrect file descriptor may have been sent to sfard(). The number in the "additional information" field is the starting block number of the data segment being read in.
ORA-02818: Less than the number of blocks requested was read in
Cause: A server could not read in the request amount of data. The first number in the "additional information" field is the block number being read in. The second is the actual number of bytes that was read in.
Action: This is a programming error.
ORA-02819: Write failed
Cause: A server was unable to perform a write. The number in the "additional information" field is the starting block number of the data segment being written out. The first number in the "additional information" field is the block number being written out. The second is the actual number of bytes that was written out. The disk may have filled up.
Action: Check the UNIX error number.
ORA-02820: Unable to write the requested number of blocks
Cause: A server could not write the requested amount of data out to disk. The disk may have run out of space.
Action: Check the UNIX error number.
ORA-02821: Unable to read the requested number of blocks.
Cause: A server could not read the number of blocks that was requested. The end of the file may have been read.
Action: Check the file on disk.
ORA-02822: Invalid block offset
Cause: A server was unable to seek to the designated block.
Action: Check the UNIX error number.
ORA-02823: Buffer is not aligned.
Cause: The buffer on which an I/O is being done is not on the correct boundary.
Action: Check the calling program.
ORA-02824: Request free list is empty
Cause: The list from which the package allocates request descriptors is empty because all of the descriptors is in use.
Action: Wait until some become free, or initialize the package with a higher number of request descriptors.
ORA-02825: Request on free list was not free
Cause: Internal error.
Action: Contact ORACLE support.
ORA-02826: Illegal block size
Cause: A negative number was given for the I/O block size to be used by the asynchronous I/O package.
Action: This is a programming error - use either a positive number or zero to get the default value.
ORA-02827: Invalid file number
Cause: The file number upon which an operation is to done is either less than zero or greater than the maximum number of files than can be open.
Action: This is a programming error. Since the calling program should not touch this number, this is a programming error.
ORA-02828: Segment free list is empty
Cause: No segments are available to allocated.
Action: Free some segments or shut down the package and re-initialize it with a higher number of segments.
ORA-02829: No segment of the proper size is available
Cause: No segment of the proper size is ready for use by the caller.
Action: Free some segments and try again.
ORA-02830: Segment could not be split - no free segments available
Cause: A segment that is larger than that desired could not be split because no free segment was available.
Action: Free some segments and try again.
ORA-02831: Segment deallocation failed - empty segment list
Cause: The caller attempted to deallocate a segment but the "in use" list was empty. This is a programming error.
Action: Check the calling program.
ORA-02832: Segment deallocation failed - segment not on list
Cause: The caller attempted to deallocate a segment that was not on the "in use" list. This is a programming error.
Action: Check the calling program.
ORA-02833: Server was unable to close file
Cause: A server was unable to close a file being used for asynchronous I/O.
Action: See the UNIX error number for more information.
ORA-02834: Server unable to open file
Cause: The server was unable to open a file for use with asynchronous I/O.
Action: Check the UNIX error number for more information.
ORA-02835: Server unable to send signal to client
Cause: Internal error.
Action: Contact ORACLE support.
ORA-02836: Unable to create temporary key file
Cause: Internal error.
Action: Contact ORACLE support.
ORA-02837: Unable to unlink temporary file
Cause: Internal error.
Action: Contact ORACLE support.
ORA-02838: Unable to arm signal handler for the alarm signal
Cause: The arming of a signal handler for the alarmsignal failed.
Action: Internal error - contact ORACLE support.
ORA-02839: Sync of blocks to disk failed.
Cause: The server was unable to flush its writes out to disk.
Action: Check the UNIX error number.
ORA-02840: Open of log file by client failed
Cause: The client process was unable to open its log file.
Action: Check the UNIX error number for more information.
ORA-02841: Server died on start up
Cause: A server exited during its initialization process.
Action: Check the servers' logs for more information.
ORA-02842: Client unable to fork a server
Cause: The client could not spawn a server. A possible reason is that the operating system has reached its limit on the number of processes that it can spawn.
Action: Either reduce the number of servers that are to be used, or reconfigure the operating system so that it can handle more processes.
ORA-02843: Invalid value for kernel flag
Cause: An illegal value was given for the kernel flag in the information structure. Only TRUE and FALSE are permitted.
Action: This is a programming error - check the calling routine.
ORA-02844: Invalid value for the leave open flag
Cause: A value was given for the flag that determines whether a file is to be left open after the client checks it to see if the servers can use it. Only TRUE and FALSE are supported.
Action: This is a programming error - check the calling routine.
ORA-02845: Invalid value for the timing wanted flag
Cause: A value was given for the flag that indicates that operations are to be timed out. Only TRUE and FALSE are supported.
Action: This is a programming error - check the calling routine.
ORA-02846: Unkillable server
Cause: A server would not respond to the termination signal. The first number is the number of the server. The second is its UNIX process number. This is an internal problem.
Action: This is an operating system problem.
ORA-02847: Server did not terminate when posted
Cause: A server did not respond to a posted request to shutdown. The first number is the number of the server. The second is its UNIX process number. This is an internal problem.
Action: Contact ORACLE support.
ORA-02848: Asynchronous I/O package is not running
Cause: An operation using the asynchronous I/O package was attempted without first initializing the package using sfainit().
Action: Call sfainit() before using the package.
ORA-02849: Read failed because of an error
Cause: A server could not read the requested amount of data from disk.
Action: Check the UNIX error number.
ORA-02850: File is closed
Cause: A file upon which an asynchronous I/O operation is to be performed has already been closed by the package.
Action: This is a programming error.
ORA-02851: Request list is empty when it should not be
Cause: This is an internal problem.
Action: Contact ORACLE support.
ORA-02852: Invalid critical-section time out value
Cause: The time given was not a positive number.
Action: Use a positive number.
ORA-02853: Invalid server list latch time out value
Cause: The time given was not a positive number.
Action: Use a positive number.
ORA-02854: Invalid number of request buffers
Cause: The value given for "db_slave_buffers" in your INIT.ORA file is less than 0.
Action: Use a number that is greater than or equal to 0.
ORA-02855: Number of requests is less than the number of slaves
Cause: The value given for "db_slave_buffers" in your INIT.ORA file is less than the number specified for the number of slaves, "db_slaves."
Action: Specify a number that is greater than that given for "db_slaves" Alternatively, specify 0. The kernel will supply the appropriate number.
ORA-02875: smpini: Unable to get shared memory for PGA
Cause: Stated in errno.
Action: Resolve the problem.
ORA-02876: smpini: Unable to attach to shared memory for PGA
Cause: Stated in errno.
Action: Resolve the problem.
ORA-02877: smpini: Unable to initialize memory protection
Cause: The adspcinit program has not been executed.
Action: Execute the adscpinit program as shown in your Installation and Users' Guide. If the problem persists, try rebooting your computer.
ORA-02878: sou2o: Variable smpdidini overwritten
Cause: The variable smpdidini was overwritten, probably by client code.
Action: Verify client code, e.g. Pro*C, for illegal memory access. If the problem occurs outside Single Task operation, contact your customer support representative.
ORA-02879: sou2o: Could not gain access to protected memory
Cause: This is an internal error, note error code in errno.
Action: Report to your customer support representative. Restarting your application or your computer may cure the problem.
ORA-02880: smpini: Could not register PGA for protection
Cause: This is an internal error, note error code in errno.
Action: Report to your customer support representative. Restarting your application or your computer may cure the problem.
ORA-02881: sou2o: Could not revoke access to protected memory
Cause: This is an internal error, note error code in errno.
Action: Report to your customer support representative. Restarting your application or your computer may cure the problem.
ORA-02882: sou2o: Could not register SGA for protection
Cause: This is an internal error, note error code in errno.
Action: Report to your customer support representative. Restarting your application or your computer may cure the problem.
ORA-02899: smscre: Cannot create SGA with Extended Shared Memory feature
Cause: The environment variable EXTSHM was set before starting oracle.
Action: Unset the environment variable EXTSHM and startup oracle.
ORA-03001: unimplemented feature
Cause: This feature is not implemented.
Action: None.
ORA-03002: operator not implemented
Cause: This is an internal error.
Action: Contact your customer support representative.
ORA-03007: obsolete feature
Cause: User attempted to use a feature which is no longer supported.
Action: None.
ORA-03008: parameter COMPATIBLE >= string needed for string
Cause: An attempt was made to use a feature for a later Oracle version, than the setting of the initialization parameter, COMPATIBLE.
Action: Set COMPATIBLE to the value in the message (or higher), and retry the command, but be aware that this will limit your downgrade options.
ORA-03112: a server linked as single-task cannot use SQL*Net
Cause: A statement containing a SQL*Net connect string was issued to the single-task server. For example, a database link was used in a SQL statement.
Action: Do not use SQL*Net connect strings in a single-task environment.
ORA-03113: end-of-file on communication channel
Cause: The connection between Client and Server process was broken.
Action: There was a communication error that requires further investigation. First, check for network problems and review the SQL*Net setup. Also, look in the alert.log file for any errors. Finally, test to see whether the server process is dead and whether a trace file was generated at failure time.
ORA-03119: two-task detected inconsistent datatype specification
Cause: There was both a datatype, and an anonymous datatype declaration found.
Action: Correct the specification.
ORA-03122: attempt to close ORACLE-side window on user side
Cause: This is an internal error.
Action: Contact your customer support representative.
ORA-03123: operation would block
Cause: This is a status code that indicates that the operation cannot complete now.
Action: None; this is not an error. The operation should be retried again for completion.
ORA-03124: two-task internal error
Cause: Internal error.
Action: Contact your customer support representative.
ORA-03125: client-server protocol violation
Cause: The application received a bad escape sequence from the server and may indicate a problem with the client application user code.
Action: Contact your customer support representative.
ORA-03126: network driver does not support non-blocking operations
Cause: A non-blocking operation was attempted and the network driver does not support non-blocking operations.
Action: Use default blocking operations or use a driver supporting non-blocking operations.
ORA-03127: no new operations allowed until the active operation ends
Cause: An attempt was made to execute a new operation before the active non-blocking operation completed or a new operation was attempted before all the pieces of a column were inserted or fetched.
Action: Execute the new operation after the non-blocking operation completes. If piecewise binds/defines were done, execute the new operation after all the pieces have been inserted or fetched.
ORA-03128: connection is in blocking mode
Cause: The OCI test for non-blocking mode on a connection indicates that the connection is in blocking mode.
Action: If non-blocking mode is required use appropriate OCI calls to change the mode.
ORA-03129: the next piece to be inserted is required
Cause: The application performed a piecewise bind on a column.
Action: Provide the next piece of this bind variable.
ORA-03130: the buffer for the next piece to be fetched is required
Cause: The application performed a piecewise define on the column.
Action: Provide the next buffer for the next piece to be retrieved.
ORA-03131: an invalid buffer was provided for the next piece
Cause: The application either provided the length of the buffer for the next piece to be zero or provided a null pointer.
Action: Verify if the buffer pointer for the next piece is null or if the length is zero.
ORA-03132: two-task default value overflow
Cause: The default value specified for a record field was too large.
Action: Change the default value to fit the field size.
ORA-03134: Connections to this server version are no longer supported.
Cause: An attempt was made to connect to an Oracle server of older version.
Action: Please refer to documentation for more details.
ORA-03200: the segment type specification is invalid
Cause: segment type is not TABLE, INDEX, or CLUSTER
Action: use a correct segment type
ORA-03201: the group number specification is invalid
Cause: the freelist group number was either negative or larger than the the number of freelist groups in the segment
Action: use a correct group number
ORA-03202: the scan limit specification is invalid
Cause: the scan limit did not have a positive integer value the number of freelist groups in the segment
Action: use a correct scan limit
ORA-03203: concurrent update activity makes space analysis impossible
Cause: high volume of user updates interfere with the space analysis
Action: retry the command or lock the underlying objects
ORA-03204: the segment type specification should indicate partitioning
Cause: partition name is specified for the space analysis, but the object type does not indicate parttitioning
Action: specify PARTITION in the segment type, if the object is partitioned, otherwise, omit the partition name
ORA-03205: partition name is required when partitioned type is specified
Cause: partition name is not specified for the space analysis, but the object type indicates parttitioning
Action: specify partition name, if the object is partitioned, otherwise, specify a non-partitioned type
ORA-03206: maximum file size of (string) blocks in AUTOEXTEND clause is out of range
Cause: The maximum file size for an autoextendable file has exceeded the maximum number of blocks allowed.
Action: Reduce the size and retry.
ORA-03207: subpartitioned type must be specified for composite object
Cause: partition type is specified for the space analysis, but the object type indicates composite partitioning
Action: specify subpartition name and subpartition type
ORA-03208: partitioned type must be specified for a non-composite object
Cause: subpartition type is specified for the space analysis, but the object type indicates non-composite partitioning
Action: specify partition name and partition type
ORA-03209: DBMS_ADMIN_PACKAGE invalid file/block specification
Cause: The value of file number or block number is outside of limits or inconsistent
Action: Fix the file number/block number value
ORA-03210: DBMS_ADMIN_PACKAGE invalid option specification
Cause: The value of one of the option parameters is incorrect
Action: Fix the option value
ORA-03211: The segment does not exist or is not in a valid state
Cause: The segment specified in the DBMS_SPACE_ADMIN or DBMS_SPACE operation does not exist or is not in a state appropriate for this operation
Action: Fix the segment specification, or put the segment in the appropriate state.
ORA-03212: Temporary Segment cannot be created in locally-managed tablespace
Cause: Attempt to create a temporary segment for sort/hash/lobs in in permanent tablespace of kind locally-managed
Action: Alter temporary tablespace of user to a temporary tablespace or a dictionary-managed permanent tablespace
ORA-03213: Invalid Lob Segment Name for DBMS_SPACE package
Cause: The Lob Segment specified in the DBMS_SPACE operation does not exist.
Action: Fix the Segment Specification
ORA-03214: File Size specified is smaller than minimum required
Cause: File Size specified for add/resize datafile/tempfile does not allow for the minimum required of one allocation unit.
Action: Increase the specification for file size
ORA-03215: File Size specified for resize is too small
Cause: File Size specified for resize datafile/tempfile causes bitmap control structures to overlap
Action: Increase the specification for file size
ORA-03216: Tablespace/Segment Verification cannot proceed
Cause: Corruptions detected during verification whch cannot be dealt with
Action: Do manual verification
ORA-03217: invalid option for alter of TEMPORARY TABLESPACE
Cause: invalid option for alter of temporary tablespace was specified
Action: Specify one of the valid options: ADD TEMPFILE, TEMPFILE ONLINE, TEMPFILE OFFLINE
ORA-03218: invalid option for CREATE/ALTER TABLESPACE
Cause: invalid option for create/alter tablespace of type locally-managed
Action: Specify one of the valid options.
ORA-03219: Tablespace 'string' is dictionary-managed, offline or temporary
Cause: Operation which is only applicable to permanent, online, locally-managed tablespaces is specified for a tablespace which is either dictionary-managed, offline or temporary
Action: Reissue operation for a different tablespace, mount the tablespace or do not issue it at all, since it does not apply for the given tablespace
ORA-03220: DBMS_ADMIN_PACKAGE required parameter is NULL or missing
Cause: Some of the procedures was called with missing or NULL parameters
Action: Specify the missing parameter
ORA-03221: Temporary tablespaces and temporary segments must have standard block size
Cause: An attempt was made to do one of the following : (1) create a temporary tablespace with a non-standard block size or, (2) alter an existing permanent tablespace of non-standard block size to a temporary tablespace or, (3) issue a DDL statement that would result in the creation of a temporary segment in a tablespace of non-standard block size.
Action: (1) If creating a temporary tablespace, do not specify a block size different from the standard block size. (2) If altering an existing permanent tablespace to a temporary tablespace, ensure that it is of standard block size. (3) Ensure that the user's temporary tablespace is a tablespace having the standard block size.
ORA-03222: average row size and row count must be greater than zero
Cause: Either a bad value passed to dbms_space.create_table_cost() or explain plan did not pass through size information.
Action: Check the row size parameter in dbms_space.create_table_cost(). For explain plan, make sure statistics have been computed for all source tables in the CREATE TABLE AS SELECT statement.
ORA-03230: segment only contains string blocks of unused space above high water mark
Cause: Attempt to preserve too many blocks.
Action: reduce the KEEP amount.
ORA-03231: the INITIAL extent may not be deallocated
Cause: Attempt to deallocate space from the segment which was truncated prior to the 7.3 release.
Action: increase the KEEP amount, or truncate the segment, and reissue the command.
ORA-03233: unable to extend table string.string subpartition string by string in tablespace string
Cause: Failed to allocate an extent for table subpartition segment in tablespace.
Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-03234: unable to extend index string.string subpartition string by string in tablespace string
Cause: Failed to allocate an extent for index subpartition segment in tablespace.
Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-03235: max # extents (string) reached in table string.string subpartition string
Cause: A table subpartition tried to extend past maxextents
Action: If maxextents is less than the system maximum, raise it. Otherwise, you must recreate with larger initial, next or pctincrease params
ORA-03236: max # extents (string) reached in index string.string subpartition string
Cause: An index subpartition tried to extend past maxextents
Action: If maxextents is less than the system max, raise it. Otherwise, you must recreate with larger initial, next or pctincrease params.
ORA-03237: Initial Extent of specified size cannot be allocated in tablespace (string)
Cause: Too large a size for an initial extent due to freelist group specification
Action: Reduce number of freelist groups specified for segment
ORA-03238: unable to extend LOB segment string.string subpartition string by string in tablespace string
Cause: An attempt was made to allocate an extent for LOB subpartition segment in tablespace, but the extent could not be allocated because there is not enough space in the tablespace indicated.
Action: Use the ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.
ORA-03239: maxextents (string) reached in LOB segment string.string subpartition string
Cause: A LOB subpartition segment tried to extend past maxextents.
Action: If maxextents is less than the system maximum, raise it. Otherwise, recreate the subpartition with larger INITIAL, NEXT, or PCTINCREASE parameters.
ORA-03240: User's temporary tablespace same as tablespace being migrated
Cause: Users default temporary tablespace must be different from the tablespace being migrated.
Action: alter users default temporary tablespace to be different.
ORA-03241: Invalid unit size
Cause: User specified an invalid unit size for the tablespace
Action: Specify the correct unit size. To estimate unit size please refer to Oracle Server Administrator's Guide.
ORA-03242: Tablespace migration retried 500 times
Cause: For migration to complete, temporary segments should not be present in the tablespace at the time of migration.
Action: Avoid migrating the tablespace when there is heavy temporary segment creation going on as with object drops.
ORA-03243: destination dba overlaps with existing control information
Cause: Cannot overlap control information during relocation
Action: Please chose another destination address
ORA-03244: No free space found to place the control information
Cause: During migration of tablespace found no place to put the control information. If during bitmaps relocation, found no space at the specified destination.
Action: If during migration, add more space to the tablespace and retry migration. If during bitmaps relocation, specify a destination address where there is enough free space.
ORA-03245: Tablespace has to be dictionary managed, online and permanent to be able to migrate
Cause: Tablespace was not dictionary managed or online or permanent.
Action: Make sure the tablespace is online, permanent and dictionary managed
ORA-03246: Invalid block number specified
Cause: Control information cannot be placed at the specified dba either because the block number specified is beyond the file end or the file is not large enough to accomodate the control information at that location
Action: specify a correct block number
ORA-03247: Invalid block number specified
Cause: Relocation of bitmaps to the said destination will make the tablespace self descriptive
Action: Choose another destination dba.
ORA-03248: Too much of segment creation activity during migration
Cause: Temporary segments were attempted to be created during migration
Action: The error is signalled after retrying migration for 500 times. Run migration when there is less of segment creation activity is going on.
ORA-03249: Uniform size for auto segment space managed tablespace should have atleast string blocks
Cause: For the given blocksize, uniform size specified is insufficient
Action: Specify larger extent size and retry
ORA-03250: Cannot mark this segment corrupt
Cause: This segment cannot be marked corrupt because it contains data dictionary objects
Action: Check the segment information and reissue the command.
ORA-03251: Cannot issue this command on SYSTEM tablespace
Cause: It is not permitted to migrate SYSTEM tablespace from locally managed format to dictionary managed format or relocate bitmaps.
Action: Check the tablespace name and procedure name
ORA-03252: initial extent size not enough for LOB segment
Cause: Fatblock size of LOB segment is too big to fit into the initial extent.
Action: Specify a smaller fatblock size or create the LOB segment in other tablespaces with bigger initial extent size.
ORA-03274: both ALLOCATE EXTENT and DEALLOCATE UNUSED options are specified
Cause: The DEALLOCATE option and the ALLOCATE option are specified in the same command.
Action: Choose one of the options or issue two separate commands.
ORA-03275: duplicate DEALLOCATE option specification
Cause: The DEALLOCATE UNUSED option to ALTER TABLE or ALTER INDEX is specified more than once.
Action: Specify the option at most once.
ORA-03276: duplicate ALLOCATE EXTENT option specification
Cause: The ALLOCATE EXTENT option to ALTER TABLE or ALTER INDEX is specified more than once.
Action: Specify the option at most once.
ORA-03277: invalid SIZE specified
Cause: The specified value must be an integer.
Action: Choose an appropriate integer value.
ORA-03278: duplicate ALLOCATE EXTENT option specification
Cause: An option (DATAFILE, SIZE or INSTANCE) was specified more than once.
Action: Specify each option at most once.
ORA-03279: invalid INSTANCE specified
Cause: The specified value is not recognized as a valid instance name.
Action: Use a valid name.
ORA-03280: invalid DATAFILE filename specified
Cause: A character string literal is expected, but not found.
Action: Specify filenames using character string literals.
ORA-03281: invalid ALLOCATE EXTENT option
Cause: An option other than DATAFILE, SIZE or INSTANCE was specified.
Action: Remove invalid option and retry the command.
ORA-03282: missing ALLOCATE EXTENT option
Cause: No ALLOCATE EXTENT options were specified.
Action: Specified one or more of the following options: DATAFILE, SIZE or INSTANCE.
ORA-03283: specified datafile string does not exist
Cause: The datafile does not exist
Action: Retry the option with the correct datafile
ORA-03284: datafile string is not a member of tablespace string
Cause: The specified datafile does not belong to the tablespace that the object resides in.
Action: Retry the option with the correct datafile.
ORA-03286: ALLOCATE EXTENT not valid for HASH CLUSTERS
Cause: The cluster is a hash cluster, and can not use the allcoate extent option.
Action: none
ORA-03287: invalid FREELIST GROUP specified
Cause: The specified FREELIST GROUP number is invalid
Action: Choose a number between 1 and # freelist groups for this object
ORA-03288: both FREELIST GROUP and INSTANCE parameters may not be specified
Cause: Both FREELIST GROUP and INSTANCE were specified in clause
Action: Remove one of the two parameters
ORA-03289: partition name and segment type do not match
Cause: Partition name and segment type specified for space analysis do not match
Action: Specify type PARTITION if the object is partitioned, specify SUBPARTITION if the object is composite
ORA-03290: Invalid truncate command - missing CLUSTER or TABLE keyword
Cause: Invalid object specification given.
Action: Either specify TRUNCATE CLUSTER or TRUNCATE TABLE
ORA-03291: Invalid truncate option - missing STORAGE keyword
Cause: Expected STORAGE keyword
Action: Either specify DROP STORAGE or REUSE STORAGE
ORA-03292: Table to be truncated is part of a cluster
Cause: The table being truncated is a member of a cluster.
Action: Either use TRUNCATE CLUSTER or DROP TABLE
ORA-03293: Cluster to be truncated is a HASH CLUSTER
Cause: Only INDEX CLUSTERS can be truncated.
Action: Drop and recreate the HASH CLUSTER instead of using truncate.
ORA-03296: cannot resize datafile - file string not found
Cause: The specified datafile is not available for resizing.
Action: Ensure that the datafile name is valid, and if so, ensure the file is accessible.
ORA-03297: file contains used data beyond requested RESIZE value
Cause: Some portion of the file in the region to be trimmed is currently in use by a database object
Action: Drop or move segments containing extents in this region prior to resizing the file, or choose a resize value such that only free space is in the trimmed.
ORA-03298: cannot shrink datafile - file string is under hot backup
Cause: Attempt to shrink a datafile while it is under hot backup. This is not allowed.
Action: Retry shrinking the file after the hot backup completes.
ORA-03299: cannot create dictionary table string
Cause: A dictionary table is created upon the first execution of the command 'alter database datafile autoextend on' for a database. This operation did not succeed. The most probable cause for this is insufficient space in the system tablespace.
Action: See action for next error message in error stack.
ORA-04000: the sum of PCTUSED and PCTFREE cannot exceed 100
Cause: the sum of PCTUSED and PCTFREE for a cluster or table exceeds 100
Action: create the table/cluster specifying values whose sum is <= 100
ORA-04001: sequence parameter string must be an integer
Cause: %s (a sequence parameter) specified was not an integer
Action: create the sequence, giving the specified parameter an integer value
ORA-04002: INCREMENT must be a non-zero integer
Cause: a sequence increment was specified to be zero
Action: specify the increment to be a non-zero value
ORA-04003: sequence parameter string exceeds maximum size allowed (string digits)
Cause: %s (a sequencer parameter) had too many digits
Action: specify the parameter with the allowed number of digits
ORA-04004: MINVALUE must be less than MAXVALUE
Cause: MINVALUE was specified to be greater than or equal to MAXVALUE
Action: specify a MINVALUE that is less than MAXVALUE
ORA-04005: INCREMENT must be less than MAXVALUE minus MINVALUE
Cause: the INCREMENT specified is >= MAXVALUE-MINVALUE
Action: specify an INCREMENT that is < MAXVALUE-MINVALUE
ORA-04006: START WITH cannot be less than MINVALUE
Cause: the given starting value is less than MINVALUE
Action: make sure that the starting value is >= MINVALUE
ORA-04007: MINVALUE cannot be made to exceed the current value
Cause: the given MINVALUE would be greater than the current value
Action: always make sure that MINVALUE is <= the current value
ORA-04008: START WITH cannot be more than MAXVALUE
Cause: the starting value would be larger than MAXVALUE
Action: make sure that the starting value is less than MAXVALUE
ORA-04009: MAXVALUE cannot be made to be less than the current value
Cause: the current value exceeds the given MAXVALUE
Action: make sure that the new MAXVALUE is larger than the current value
ORA-04010: the number of values to CACHE must be greater than 1
Cause: the value in the CACHE clause was one
Action: specify NOCACHE, or a value larger than one
ORA-04011: sequence string must range between string and string
Cause: the value specified for one of the sequence parameters exceeds limits
Action: specify parameter within these limits
ORA-04012: object is not a sequence
Cause: the object specified cannot have sequence ddl's performed on it
Action: re-enter the statement being careful with the spelling of the name
ORA-04013: number to CACHE must be less than one cycle
Cause: number to CACHE given is larger than values in a cycle
Action: enlarge the cycle, or cache fewer values
ORA-04014: descending sequences that CYCLE must specify MINVALUE
Cause: sequences that cycle must have their wrap-wrap specified
Action: re-create the sequence, specifying its wrap-value
ORA-04015: ascending sequences that CYCLE must specify MAXVALUE
Cause: sequences that cycle must have their wrap-wrap specified
Action: re-create the sequence, specifying its wrap-value
ORA-04016: sequence string no longer exists
Cause: sequence was dropped while processing its next value.
Action: re-create the sequence
ORA-04017: invalid value string (length = string) for parameter max_dump_file_size
Cause: neither did the string supplied for max_dump_file_size parameter match the "UNLIMITED" string value nor did it represent a base 10 integer.
Action: reassign a proper value to this parameter.
ORA-04018: invalid value string for parameter _scn_scheme
Cause: The value specified for init.ora parameter _scn_scheme is not recognized as one of the defined schemes.
Action: reassign a proper value.
ORA-04019: SCN scheme incompatible with other instances
Cause: Either different instances are running incompatible Oracle releases or different values have been assigned to the _scn_scheme init.ora parameter on different instances.
Action: Make sure the _scn_scheme init.ora parameter is set to the same value on all instances.
ORA-04020: deadlock detected while trying to lock object stringstringstringstringstring
Cause: While trying to lock a library object, a deadlock is detected.
Action: Retry the operation later.
ORA-04021: timeout occurred while waiting to lock object stringstringstringstringstring
Cause: While waiting to lock a library object, a timeout is occurred.
Action: Retry the operation later.
ORA-04022: nowait requested, but had to wait to lock dictionary object
Cause: Had to wait to lock a library object during a nowait request.
Action: Retry the operation later.
ORA-04027: self-deadlock during automatic validation for object string.string
Cause: An attempt was made to validate an invalidated object but it failed because of a self-deadlock.
Action: , e.g. compile the invalidated object separately.
ORA-04028: cannot generate diana for object stringstringstringstringstring
Cause: Cannot generate diana for an object because of lock conflict.
Action: Please report this error to your support representative.
ORA-04029: error ORA-string occurred when querying stringstringstring
Cause: The table or view being queried might be missing. The error number indicates the error.
Action: Fix the error.
ORA-04030: out of process memory when trying to allocate string bytes (string,string)
Cause: Operating system process private memory has been exhausted
Action: none
ORA-04031: unable to allocate string bytes of shared memory ("string","string","string","string")
Cause: More shared memory is needed than was allocated in the shared pool.
Action: If the shared pool is out of memory, either use the dbms_shared_pool package to pin large packages, reduce your use of shared memory, or increase the amount of available shared memory by increasing the value of the INIT.ORA parameters "shared_pool_reserved_size" and "shared_pool_size". If the large pool is out of memory, increase the INIT.ORA parameter "large_pool_size".
ORA-04032: pga_aggregate_target must be set before switching to auto mode
Cause: attempt to set workarea_size_policy to AUTO while pga_aggregate_target is not specified
Action: before setting workarea_size_policy, set pga_aggregate_target to a value representing the total private memory available to the instance. This total is generally the total physical memory available in the system minus what is needed for the SGA minus what is needed for the operating system (e.g. 500MB)
ORA-04033: Insufficient memory to grow pool
Cause: The system had insufficient memory to grow the pool to the specified size.
Action: Specify a smaller value to grow the pool.
ORA-04034: unable to shrink pool to specified size
Cause: The pool could not shrink to the specified size as it could not free memory.
Action: Specify a larger value to which to shrink the pool to.
ORA-04041: package specification must be created first before creating package body
Cause: Attempt to create a package body before creating its package specification.
Action: Create the package specification first before creating the package body.
ORA-04042: procedure, function, package, or package body does not exist
Cause: Attempt to access a procedure, function, package, or package body that does not exist.
Action: Make sure the name is correct.
ORA-04043: object string does not exist
Cause: An object name was specified that was not recognized by the system. There are several possible causes:

- An invalid name for a table, view, sequence, procedure, function, package, or package body was entered. Since the system could not recognize the invalid name, it responded with the message that the named object does not exist.

- An attempt was made to rename an index or a cluster, or some other object that cannot be renamed.

Action: Check the spelling of the named object and rerun the code. (Valid names of tables, views, functions, etc. can be listed by querying the data dictionary.)
ORA-04044: procedure, function, package, or type is not allowed here
Cause: A procedure, function, or package was specified in an inappropriate place in a statement.
Action: Make sure the name is correct or remove it.
ORA-04045: errors during recompilation/revalidation of string.string
Cause: This message indicates the object to which the following errors apply. The errors occurred during implicit recompilation/revalidation of the object.
Action: Check the following errors for more information, and make the necessary corrections to the object.
ORA-04046: results of compilation are too large to support
Cause: Attempt to compile and store a large stored procedure that results in compilation data that is too large for the system to support or store.
Action: Reduce the size of the store procedure by splitting it into smaller stored procedures.
ORA-04047: object specified is incompatible with the flag specified
Cause: The object type implied by the flag does not match the type of object specified.
Action: Specify the correct object, or use the appropriate flag
ORA-04050: invalid or missing procedure, function, or package name
Cause: The required procedure, function, or package name is invalid or missing.
Action: Specify a valid name.
ORA-04051: user string cannot use database link string.string
Cause: During forwarding of a remote object access, an attempt was made to use a non-existent database link or one owned by a user other than the logon user or PUBLIC.
Action: Change your database link structure so that all indirect remote accesses are done from the same userid that originates the request.
ORA-04052: error occurred when looking up remote object stringstringstringstringstring
Cause: An error has occurred when trying to look up a remote object.
Action: Fix the error. Make sure the remote database system has run KGLR.SQL to create necessary views used for querying/looking up objects stored in the database.
ORA-04053: error occurred when validating remote object stringstringstringstringstring
Cause: An error has occurred when trying to validate a remote object.
Action: Fix the error. Make sure the remote database system has run KGLR.SQL to create necessary views used for querying/looking up objects stored in the database.
ORA-04054: database link string does not exist
Cause: During compilation of a PL/SQL block, an attempt was made to use a non-existent database link.
Action: Either use a different database link or create the database link.
ORA-04055: Aborted: "string" formed a non-REF mutually-dependent cycle with "string".
Cause: This compilation was aborted because the library unit that was compiled would have formed a non-REF mutually-dependent cycle with some other library units. This happens when an attempt is made to compile types that have attributes of other types that may participate in a cycle with this type. Example: create type t1; create type t2 (a t1); create type t1 (a t2);
Action: Break the cycle (possibly by adding a REF or by using another type).
ORA-04060: insufficient privileges to execute string
Cause: Attempt to execute a stored procedure without sufficient privileges.
Action: Get necessary privileges.
ORA-04061: existing state of string has been invalidated
Cause: Attempt to resume the execution of a stored procedure using the existing state which has become invalid or inconsistent with the stored procedure because the procedure has been altered or dropped.
Action: Try again; this error should have caused the existing state of all packages to be re-initialized.
ORA-04062: %s of string has been changed
Cause: Attempt to execute a stored procedure to serve an RPC stub which specifies a timestamp or signature that is different from the current timestamp/signature of the procedure.
Action: Recompile the caller in order to pick up the new timestamp.
ORA-04063: %s has errors
Cause: Attempt to execute a stored procedure or use a view that has errors. For stored procedures, the problem could be syntax errors or references to other, non-existent procedures. For views, the problem could be a reference in the view's defining query to a non-existent table. Can also be a table which has references to non-existent or inaccessible types.
Action: Fix the errors and/or create referenced objects as necessary.
ORA-04064: not executed, invalidated string
Cause: Attempt to execute a stored procedure that has been invalidated.
Action: Recompile it.
ORA-04065: not executed, altered or dropped string
Cause: Attempt to execute a stored procedure that has been altered or dropped thus making it not callable from the calling procedure.
Action: Recompile its dependents.
ORA-04066: non-executable object, string
Cause: Attempt to execute a non-procedure.
Action: Make sure that a correct name is given.
ORA-04067: not executed, string does not exist
Cause: Attempt to execute a non-existent stored procedure.
Action: Make sure that a correct name is given.
ORA-04068: existing state of packagesstringstringstring has been discarded
Cause: One of errors 4060 - 4067 when attempt to execute a stored procedure.
Action: Try again after proper re-initialization of any application's state.
ORA-04070: invalid trigger name
Cause: An invalid trigger name was specified.
Action: Verify that trigger name is not a reserved keyword.
ORA-04071: missing BEFORE, AFTER or INSTEAD OF keyword
Cause: The trigger statement is missing the BEFORE/AFTER/INSTEAD OF clause.
Action: Specify either BEFORE, AFTER or INSTEAD OF.
ORA-04072: invalid trigger type
Cause: An invalid trigger type was given.
Action: Specify either INSERT, UPDATE or DELETE.
ORA-04073: column list not valid for this trigger type
Cause: A column list was specified for a non-update trigger type.
Action: Remove the column list.
ORA-04074: invalid REFERENCING name
Cause: An invalid name was given in the referencing clause.
Action: Verify the referencing name is not a reserved word.
ORA-04075: invalid trigger action
Cause: An statement was given for the trigger action.
Action: Re-specify the trigger action.
ORA-04076: invalid NEW or OLD specification
Cause: An invalid NEW or OLD specification was given for a column.
Action: Re-specify the column using the correct NEW or OLD specification.
ORA-04077: WHEN clause cannot be used with table level triggers
Cause: The when clause can only be specified for row level triggers.
Action: Remove the when clause or specify for each row.
ORA-04078: OLD and NEW values cannot be identical
Cause: The referencing clause specifies identical values for NEW and OLD.
Action: Re-specify either the OLD or NEW referencing value.
ORA-04079: invalid trigger specification
Cause: The create TRIGGER statement is invalid.
Action: Check the statement for correct syntax.
ORA-04080: trigger 'string' does not exist
Cause: The TRIGGER name is invalid.
Action: Check the trigger name.
ORA-04081: trigger 'string' already exists
Cause: The TRIGGER name or type already exists.
Action: Use a different trigger name or drop the trigger which is of the same name.
ORA-04082: NEW or OLD references not allowed in table level triggers
Cause: The trigger is accessing "new" or "old" values in a table trigger.
Action: Remove any new or old references.
ORA-04083: invalid trigger variable 'string'
Cause: The variable referenced in the trigger body is invalid.
Action: See the manual for valid trigger variable types.
ORA-04084: cannot change NEW values for this trigger type
Cause: New trigger variables can only be changed in before row insert or update triggers.
Action: Change the trigger type or remove the variable reference.
ORA-04085: cannot change the value of an OLD reference variable
Cause: Old values can only be read and not changed.
Action: Do not attempt to change an old variable.
ORA-04086: trigger description too long, move comments into triggering code
Cause: The trigger description is limited to 2000 characters (for dictionary storage reasons). The description does not include the text of the "when" clause or the text of the pl/sql code executed for the trigger.
Action: If the trigger description contains a large comment, move that
ORA-04087: cannot change the value of ROWID reference variable
Cause: Rowid's can only be read and not changed.
Action: Do not attempt to change an rowid value.
ORA-04088: error during execution of trigger 'string.string'
Cause: A runtime error occurred during execution of a trigger.
Action: Check the triggers which were involved in the operation.
ORA-04089: cannot create triggers on objects owned by SYS
Cause: An attempt was made to create a trigger on an object owned by SYS.
Action: Do not create triggers on objects owned by SYS.
ORA-04090: 'string' specifies same table, event and trigger time as 'string'
Cause: Trigger is of duplicate event and trigger time.
Action: Combine the triggering information into one trigger which is fired at the given time.
ORA-04091: table string.string is mutating, trigger/function may not see it
Cause: A trigger (or a user defined plsql function that is referenced in this statement) attempted to look at (or modify) a table that was in the middle of being modified by the statement which fired it.
Action: Rewrite the trigger (or function) so it does not read that table.
ORA-04092: cannot string in a trigger
Cause: A trigger attempted to commit or rollback.
Action: Rewrite the trigger so it does not commit or rollback.
ORA-04093: references to columns of type LONG are not allowed in triggers
Cause: A trigger attempted to reference a long column in the triggering table.
Action: Do not reference the long column.
ORA-04094: table string.string is constraining, trigger may not modify it
Cause: A trigger attempted to modify a table that was constraining for some referential constraint of a parent SQL statement.
Action: none
ORA-04095: trigger 'string' already exists on another table, cannot replace it
Cause: Cannot replace a trigger which already exists on a different table than the one being replaced.
Action: Drop the trigger with the same name and re-create it.
ORA-04096: trigger 'string' has a WHEN clause which is too large, limit 2K
Cause: A trigger's 'when' clause is limited to 2K for dictionary storage reasons. The trigger being created exceeded that size.
Action: Use a smaller 'when' clause. Note, the trigger body could be used to perform the same limiting action as the 'when' clause.
ORA-04097: DDL conflict while trying to drop or alter a trigger
Cause: An attempt was made to concurrently perform two DDL operations on a trigger or trigger table.
Action: Investigate the new state of the trigger and retry the DDL operation, if still appropriate.
ORA-04098: trigger 'string.string' is invalid and failed re-validation
Cause: A trigger was attempted to be retrieved for execution and was found to be invalid. This also means that compilation/authorization failed for the trigger.
Action: Options are to resolve the compilation/authorization errors, disable the trigger, or drop the trigger.
ORA-04099: trigger 'string' is valid but not stored in compiled form
Cause: A trigger was attempted to be retrieved for execution and was found to be valid, but not stored. This may mean the an upgrade was done improperly from a non-stored trigger release.
Action: Alter compile the trigger to create the trigger in stored form. Also, you may want to review that a proper upgrade was done.


6 ORA-04930 to ORA-07499

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

6 ORA-04930 to ORA-07499

ORA-04930: open sequence number failed or initial state is valid
Cause: Either Shared Sequence Number OS component was not installed properly, or an MC hardware failure may have occurred or a previous instance was not shut down properly.
Action: Verify that there are no background or foreground Oracle processes from a previous instance on this node using the OS command ps -ef|grep <instance_name>. Verify that there are no shared memory segments belonging to the user which owns the Oracle installation by isuing the ipcs -b OS command. If there are shared memory segments or processes still on the system, use svrmgrl to shutdown the instance with the abort option. If the instance is not up, verify that the cluster software and/or the hardware is installed and working. Log in as superuser and issue the cnxshow command. Are all of the nodes in the cluster listed? Are they members of the cluster? Is the communications between nodes okay? If the answer to any of these questions is false, contact Digital's customer support organization.
ORA-04931: unable to set initial sequence number value
Cause: A call to the SSN failed to set the sequence number to its initial value, possibly caused by an MC hardware problem.
Action: Verify that the MC hardware is functioning properly. If it is not, contact Digital's customer support organization. If it is, contact Oracle support.
ORA-04932: increment or adjust of sequence number failed
Cause: A call to the SSN failed to increment the sequence number.
Action: Verify that the MC hardware is functioning properly. If it is not, contact Digital's customer support organization. If it is, contact Oracle support.
ORA-04933: initial service identifier is non-zero
Cause: A valid service identifier existed before the sequence number service was opened.
Action: Verify that the instance is completely shut down.
ORA-04934: unable to obtain the current sequence number
Cause: A call to the SSN failed to return its current value. Either there are many errors occurring on the MC hardware, or the sequence number has become invalid and cannot be validated.
Action: Verify that the MC hardware is functioning properly. If it is, contact Oracle Support.
ORA-04935: unable to get/convert SCN recovery lock
Cause: A process has timed out trying to get or convert the SCN recovery lock. Another process probably has the lock in EX or SHR mode, but is not releasing it.
Action: Contact Oracle Support.
ORA-04940: unsupported optimization of Oracle binary, check alert log for more info
Cause: ORACLE binary has been optimized with unsupported options or a required option has not been used.
Action: Check the documentation for a list of supported and required flags for the optimizing utility that you used to optimize ORACLE. Shutdown the instance, optimize ORACLE again with supported combination of options and restart the instance.
ORA-06000: NETASY: port open failure
Cause: Autologin unable to open port
Action: Check log file for OS-specific error code
ORA-06001: NETASY: port set-up failure
Cause: Autologin unable to change port attributes
Action: Check log file for OS-specific error code
ORA-06002: NETASY: port read failure
Cause: Autologin unable to read from port
Action: Check log file for OS-specific error code
ORA-06003: NETASY: port write failure
Cause: Autologin unable to write to port
Action: Check log file for OS-specific error code
ORA-06004: NETASY: dialogue file open failure
Cause: Autologin unable to open dialogue file
Action: Check connect string for accuracy/typos
ORA-06005: NETASY: dialogue file read failure
Cause: Autologin unable to read dialogue file
Action: Check log file for OS-specific error code
ORA-06006: NETASY: dialogue execute failure
Cause: Expected response never received
Action: None
ORA-06007: NETASY: bad dialogue format
Cause: Dialogue file contains syntax error
Action: Correct the dialogue file
ORA-06009: NETASY: dialogue filename too long
Cause: Full file spec for dialogue file exceeds 64 bytes
Action: Amend connect string accordingly
ORA-06010: NETASY: dialogue file too long
Cause: Dialogue file exceeds 768 bytes in length
Action: Simplify dialogue (e.g. remove comments, redundant white space), or split into two and link with "more" command
ORA-06011: NETASY: dialogue too long
Cause: One of two:

1. Dialogue contains more than 24 exchange blocks

2. Dialogue send string exceeds 84 bytes in length

Action: Simplify dialogue or split into two and link with "more" command
ORA-06017: NETASY: message receive failure
Cause: Async driver gets I/O error while doing network read operation
Action: Check log file for OS-specific error code and contact your customer support representative.
ORA-06018: NETASY: message send failure
Cause: Async driver gets I/O error while doing network write operation
Action: Check log file for OS-specific error code and contact your customer support representative.
ORA-06019: NETASY: invalid login (connect) string
Cause: Syntax error in login string.
Action: Resubmit with correct string.
ORA-06020: NETASY: initialisation failure
Cause: Async driver unable to complete initialisation
Action: Check log file for OS-specific error code
ORA-06021: NETASY: connect failed
Cause: Async driver unable to establish connection with partner
Action: Check log file for OS-specific error code
ORA-06022: NETASY: channel open failure
Cause: no free channel [should never happen]
Action: Contact your customer support representative.
ORA-06023: NETASY: port open failure
Cause: Async driver unable to open port
Action: Check log file for OS-specific error code
ORA-06024: NETASY: VTM error
Cause: Virtual Terminal Manager unable to read/write to port
Action: Check log file for OS-specific error code
ORA-06025: NETASY: Configuration error
Cause: Async driver genned for server-only, but client service requested
Action: Contact your customer support representative.
ORA-06026: NETASY: port close failure
Cause: Async driver unable to close port
Action: Check log file for OS-specific error code
ORA-06027: NETASY: channel close failure
Cause: Async driver unable to close channel
Action: Check log file for OS-specific error code
ORA-06028: NETASY: unable to intialise for logging
Cause: Async driver unable to initialise for logging I/O
Action: Contact your customer support representative.
ORA-06029: NETASY: port assignment failure
Cause: Async driver unable to assign port to channel [should never happen]
Action: Contact your customer support representative.
ORA-06030: NETDNT: connect failed, unrecognized node name
Cause: Node name specified in host string is unknown (probably misspelled)
Action: Retry with correct node name
ORA-06031: NETDNT: connect failed, unrecognized object name
Cause: Host string contains reference to object (which doesn't exist): @d:<node>-<obj> => object is ORDN<obj>; when <node> is VMS, the object is ORDN<obj>.COM when <node> is UNIX, the object is ORDN<obj> @d:<node>::"task=<obj>" => object is <obj>; when <node> is VMS, the object is <obj>.COM when <node> is UNIX, the object is <obj>
Action: Retry with correct object name or create the required object on host node
ORA-06032: NETDNT: connect failed, access control data rejected
Cause: Host string contains invalid username/password
Action: Retry with correct username/password
ORA-06033: NETDNT: connect failed, partner rejected connection
Cause: Connection with partner was made but was rejected.
Action: Contact your network administrator.
ORA-06034: NETDNT: connect failed, partner exited unexpectedly
Cause: Connection with host node was made but partner aborted
Action: Make sure object (see 06031, above) is working (for VMS run the command file and make sure that the ORACLE server process starts up); sometimes happens when the network/node is under stress - in this case a retry often works.
ORA-06035: NETDNT: connect failed, insufficient resources
Cause: Insufficient system resources are available to complete the connection; for example, all DECnet channels are in use.
Action: Contact your network administrator.
ORA-06037: NETDNT: connect failed, node unreachable
Cause: Host node is down.
Action: Contact your network administrator.
ORA-06039: NETDNT: connect failed
Cause: Connect failed for unexpected reason (see OSD error).
Action: Contact your customer support representative.
ORA-06040: NETDNT: invalid login (connect) string
Cause: Syntax error in login string.
Action: Resubmit with correct string.
ORA-06041: NETDNT: disconnect failed
Cause: Driver gets error while doing network close operation
Action: Contact your customer support representative.
ORA-06042: NETDNT: message receive failure
Cause: Driver gets I/O error while doing network read operation
Action: Contact your customer support representative.
ORA-06043: NETDNT: message send failure
Cause: Driver gets I/O error while doing network write operation
Action: Contact your customer support representative.
ORA-06044: NETDNT: connect failed, byte count quota exceeded
Cause: Connect failed because of insufficient byte count quota.
Action: Increase byte count quota.
ORA-06102: NETTCP: cannot allocate context area
Cause: Insufficient dynamic memory available for connection context area.
Action: Contact your customer support representative.
ORA-06105: NETTCP: remote host is unknown
Cause: Host name specified in the login (connect) string is unknown.
Action: Check spelling; make sure name is in the TCP/IP HOST file.
ORA-06106: NETTCP: socket creation failure
Cause: Process open file quota probably exceeded.
Action: Contact your customer support representative.
ORA-06107: NETTCP: ORACLE network server not found
Cause: No entry in SERVICES file for ORACLE server.
Action: Add ("orasrv") entry to the TCP/IP SERVICES file.
ORA-06108: NETTCP: connect to host failed
Cause: Connection attempt to remote host has failed. Probably means that the SQL*Net TCP/IP server on the remote host is not up, or the host itself is not up (check the latter by targeting it with Telnet).
Action: Start the SQL*Net TCP/IP server process on the remote host.
ORA-06109: NETTCP: message receive failure
Cause: I/O error occurred while attempting network read operation.
Action: Contact your customer support representative.
ORA-06110: NETTCP: message send failure
Cause: I/O error occurred while attempting network write operation.
Action: Contact your customer support representative.
ORA-06111: NETTCP: disconnect failure
Cause: Error occurred while closing a socket.
Action: Contact your customer support representative.
ORA-06112: NETTCP: invalid buffer size
Cause: The buffer size specified in the login string exceeds the allowed maximum (of 4096).
Action: Re-submit with valid buffer size.
ORA-06113: NETTCP: Too many connections
Cause: The maximum no. of concurrently open connections has been reached.
Action: Exit an application with an open connection which is no longer required.
ORA-06114: NETTCP: SID lookup failure
Cause: From the remote host's SQL*Net TCP/IP server: the database SID, specified in the login (connect) string, was not recognized.
Action: Add the appropriate SID entry to the CONFIG.ORA file on the remote host (and restart the SQL*Net TCP/IP server).
ORA-06115: NETTCP: unable to create ORACLE logicals
Cause: The host's SQL*Net TCP/IP server was unable to create the necessary logicals required by the ORACLE server process. See the SQL*Net TCP/IP server log file for more details.
Action: Contact your system administrator.
ORA-06116: NETTCP: unable to create ORASRV process
Cause: The host's SQL*Net TCP/IP server was unable to create the ORACLE server process. See the SQL*Net TCP/IP server log file for more details.
Action: Contact your system administrator.
ORA-06117: NETTCP: unable to create ORASRV: quota exceeded
Cause: The host's SQL*Net TCP/IP server was unable to create the ORACLE server process because of quota depletion.
Action: Increase quota allocations to the SQL*Net TCP/IP server process.
ORA-06118: NETTCP: unable to complete handshake with ORASRV
Cause: The ORACLE server process was started but failed to complete its initialization.
Action: Contact your customer support representative.
ORA-06119: NETTCP: spurious client request
Cause: The host's SQL*Net TCP/IP server was unable to recognize this connection request. See the SQL*Net TCP/IP server log file for more details.
Action: Contact your customer support representative.
ORA-06120: NETTCP: network driver not loaded
Cause: The TCP/IP network driver is not loaded.
Action: Check that the TCP/IP driver is loaded correctly.
ORA-06121: NETTCP: access failure
Cause: The host's SQL*Net TCP/IP server was unable to test the accessibility of the SID mapping file (specified in CONFIG.ORA) associated with this connection request. See the SQL*Net TCP/IP server log file for more details.
Action: Contact your customer support representative.
ORA-06122: NETTCP: setup failure
Cause: The host's SQL*Net TCP/IP server was unable to set up the appropriate environment to service this connection request. See the SQL*Net TCP/IP server log file for more details.
Action: Contact your customer support representative.
ORA-06123: NETTCP: cannot set KEEPALIVE
Cause: The host's SQL*Net TCP/IP server was unable to set the socket KEEPLIVE option. See the SQL*Net TCP/IP server log file for more details.
Action: Contact your customer support representative.
ORA-06124: NETTCP: timeout waiting for ORASRV
Cause: The ORACLE server process was started but failed to respond after N secs.
Action: For heavily loaded systems this is not an uncommon occurrence. Increase the value of N (the default is 30) by placing the following entry in the CONFIG.ORA file: SQLNET ORASRV_WAIT = <no. of secs> which will come into effect the next time the SQL*Net TCP/IP server is started.
ORA-06125: NETTCP: ORASRV exited unexpectedly
Cause: The ORACLE server process was started but exited unexpectedly. Possible causes:

1. Insufficient quotas to run ORASRV

2. ORACLE is not installed See the ORASRV output file for more details; the file will be in the ORA_SQLNET directory and will have a name of the form: ORA_SRVTnn_<SID>.OUT

Action: If appropriate action is not obvious from the ORASRV output file then contact your customer support representative.
ORA-06126: NETTCP: ORASRV unable to open network connection
Cause: The ORACLE server process was started but was unable to open the socket passed to it by TCPSRV.
Action: Contact your customer support representative.
ORA-06127: NETTCP: unable to change username
Cause: The host's SQL*Net TCP/IP server could not establish a PROXY LOGIN connection because the client username is unknown (to the host OS).
Action: Create new user account on host.
ORA-06128: NETTCP: unable to create mailbox
Cause: The host's SQL*Net TCP/IP server was unable to create a mailbox (needed for IPC communication with the ORACLE server process). See the SQL*Net TCP/IP server log file for more details.
Action: Contact your customer support representative.
ORA-06129: NETTCP: unable to transfer socket ownership to ORASRV
Cause: The host's SQL*Net TCP/IP server was unable to transfer the network communication handle to the ORACLE server process. See the SQL*Net TCP/IP server log file for more details.
Action: Contact your customer support representative.
ORA-06130: NETTCP: host access denied
Cause: The host's SQL*Net TCP/IP server rejected this connection request because the client node does not have access privilege - as determined by the contents of the Valid Node Table (VNT), a component of the host's CONFIG.ORA.
Action: To grant access, add appropriate entry to the host's VNT.
ORA-06131: NETTCP: user access denied
Cause: The host's SQL*Net TCP/IP server rejected this connection request because the client user(name) does not have access privilege - as determined by the contents of the Username Mapping Table (UMT), a component of the host's CONFIG.ORA.
Action: To grant access, add appropriate entry to the host's UMT.
ORA-06132: NETTCP: access denied, wrong password
Cause: The host SQL*Net TCP/IP server rejected this connection request because the client password did not match the host password.
Action: To grant access, get passwords in sync.
ORA-06133: NETTCP: file not found
Cause: The host's SQL*Net TCP/IP server could not find the SID mapping file (specified in CONFIG.ORA) associated with this connection request.
Action: Check CONFIG.ORA for spelling; make correct entry.
ORA-06134: NETTCP: file access privilege violation
Cause: The host's SQL*Net TCP/IP server did not have READ/ EXECUTE permission for the SID mapping file (specified in CONFIG.ORA) associated with this connection request.
Action: Change protection on SID mapping file.
ORA-06135: NETTCP: connection rejected; server is stopping
Cause: The host's SQL*Net TCP/IP server rejected this connection request because it is in the process of stopping.
Action: Re-start SQL*Net TCP/IP server.
ORA-06136: NETTCP: error during connection handshake
Cause: Network I/O failure occurred while communicating with the host's SQL*Net TCP/IP server. See the SQL*Net TCP/IP server log file for more details.
Action: Contact your customer support representative.
ORA-06137: NETTCP: error during connection handshake
Cause: Network I/O failure occurred while communicating with the host's SQL*Net TCP/IP server. See the SQL*Net TCP/IP server log file for more details.
Action: Contact your customer support representative.
ORA-06138: NETTCP: error during connection handshake
Cause: Network I/O failure occurred while communicating with the host's SQL*Net TCP/IP server. See the SQL*Net TCP/IP server log file for more details.
Action: Contact your customer support representative.
ORA-06140: NETTCP: no such user
Cause: A proxy login connect attempt failed because the client username has no counterpart on the host.
Action: none
ORA-06141: NETTCP: no privilege for user
Cause: A proxy login connect attempt failed because the SQL*Net TCP/IP server had insufficient privileges to access the proxy account.
Action: Change account protection; change server privilges.
ORA-06142: NETTCP: error getting user information
Cause: A proxy login connect attempt failed because the SQL*Net TCP/IP server was unable to access the proxy account. See the SQL*Net TCP/IP server log file for more details.
Action: Contact your customer support representative.
ORA-06143: NETTCP: maximum connections exceeded
Cause: The connect failed because the maximum conncurrent connections supported by the host's SQL*Net TCP/IP server has already been reached.
Action: Wait for a short period and re-try.
ORA-06144: NETTCP: SID (database) is unavailable
Cause: The database administrator on the host has varied the SID offline.
Action: Wait for it to be varied back on-line.
ORA-06145: NETTCP: unable to start ORASRV: images not installed
Cause: The host's SQL*Net TCP/IP server was unable to start the ORACLE server process because the ORACLE protected images were not installed.
Action: Install the images.
ORA-06250: NETNTT: cannot allocate send and receive buffers
Cause: Two-task driver could not allocate data buffers.
Action: There is insufficient memory to run your program. Kill off other processes to free up memory.
ORA-06251: NETNTT: cannot translate address file name
Cause: ORACLE_HOME environment variable not set.
Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported.
ORA-06252: NETNTT: cannot open address file
Cause: The NTT two-task driver could not open a file containing address information.
Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported. Make sure the instance you are attempting to connect to is actually up and running.
ORA-06253: NETNTT: cannot read arguments from address file
Cause: The NTT two-task driver could not read addressing information from its addressing file.
Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported. Make sure the instance you are attempting to connect to is actually up and running.
ORA-06254: NETNTT: cannot share connection to cube
Cause: The NTT two-task driver could not share a connection to the cube.
Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported. Make sure the instance you are attempting to connect to is actually up and running.
ORA-06255: NETNTT: cannot read pid of remote process
Cause: An error occurred while reading the NTT communications link.
Action: Contact your customer support representative.
ORA-06256: NETNTT: remote fork failed
Cause: The Oracle listener process on the cube could not fork off a shadow process.
Action: The instance you are trying to connect to probably doesn't have enough memory to run another shadow process. Ask someone else to log off, or connect to a different instance.
ORA-06257: NETNTT: cannot send command line to shadow process
Cause: An error occurred while writing the NTT communications link.
Action: Contact your customer support representative.
ORA-06258: NETNTT: cannot allocate context area
Cause: Two-task driver could not allocate data buffers.
Action: There is insufficient memory to run your program. Kill off other processes to free up memory.
ORA-06259: NETNTT: cannot read from remote process
Cause: An error occurred while reading the NTT communications link.
Action: Contact your customer support representative.
ORA-06260: NETNTT: cannot write to remote process
Cause: An error occurred while writing the NTT communications linke.
Action: Contact your customer support representative.
ORA-06261: NETNTT: nrange() failed
Cause: The call to 'nrange()' failed while attempting to establish a connection.
Action: Contact your customer support representative.
ORA-06262: NETNTT: nfconn() failed
Cause: The call to 'nfconn()' failed while attempting to establish a connection.
Action: Contact your customer support representative.
ORA-06263: NETNTT: out of memory in pi_connect
Cause: Two-task driver could not allocate data buffers.
Action: There is insufficient memory to run your program. Kill off other processes to free up memory.
ORA-06264: NETNTT: data protocol error
Cause: The NTT two-task driver received an unexpected message type."
Action: Contact your customer support representative.
ORA-06265: NETNTT: break protocol error
Cause: The NTT two-task driver received an unexpected message type."
Action: Contact your customer support representative.
ORA-06266: NETNTT: bad write length
Cause: The NTT two-task driver failed on an internal consistency check.
Action: Contact your customer support representative.
ORA-06267: NETNTT: bad state
Cause: The NTT two-task driver failed on an internal consistency check.
Action: Contact your customer support representative.
ORA-06268: NETNTT: cannot read /etc/oratab
Cause: The NTT two-task driver could not read configuration information from /etc/oratab.
Action: Make sure /etc/oratab exists and is readable. This error may occur if the file is incorrectly formatted. It also may occur if the driver has run out of memory.
ORA-06300: IPA: Disconnect failure
Cause: A fatal error occurred during the disconnect from the server. This was probably caused by inaccessible message queues.
Action: If there is no message queue, restart the SQL*Net IPA servers using ipactl. Otherwise contact your customer support representative.
ORA-06301: IPA: Cannot allocate driver context
Cause: The memory pool is exhausted.
Action: Check the circumstances and try to allocate less memory in your program or adjust the init parameters in your INIT.ORA file and retry.
ORA-06302: IPA: Cannot connect to remote host
Cause: found.
Action: Check sequentially for the above causes and eliminate the actual
ORA-06303: IPA: Message send error
Cause: The SQL*Net IPA driver could not write the message into the message queue.
Action: Make sure that the message queue exists and is accessible. If necessary rerun ipactl.
ORA-06304: IPA: Message receive error
Cause: The SQL*Net IPA driver could not read a message from the message queue.
Action: Make sure that the message queue exists and is accessible. If necessary rerun ipactl.
ORA-06305: IPA: Illegal message type
Cause: The communication between user and ORACLE is out of synchronization. This message should not normally be issued.
Action: Contact your customer support representative.
ORA-06306: IPA: Message write length error
Cause: The IPA driver tried to write a message in the queue that was too big for the queue.
Action: Contact your customer support representative.
ORA-06307: IPA: Cannot reset connection
Cause: A fatal error occurred during the resetting of the connection.
Action: Contact your customer support representative.
ORA-06308: IPA: No more connections available
Cause: You have exhausted all your connections.
Action: Try again when some of the current users have logged off.
ORA-06309: IPA: No message queue available
Cause: The SQL*Net IPA servers have not been started.
Action: Run ipactl.
ORA-06310: IPA: Environment variable(s) not set
Cause: Environment variable(s) not set correctly.
Action: Check and correct.
ORA-06311: IPA: Maximum number of servers reached
Cause: Maximum number of servers reached.
Action: Shutdown and restart with an increased maximum number of servers. Note that database links consume one server per link. Be sure to start up enough servers to support database links.
ORA-06312: IPA: Incorrect outgoing service name supplied
Cause: Incorrect outgoing service name supplied.
Action: Check and correct the service name.
ORA-06313: IPA: Shared memory failed to initialise
Cause: The shared memory has not been set up correctly.
Action: Contact your system manager.
ORA-06314: IPA: Event set up failure
Cause: Fatal interprocess communication error.
Action: Contact your system manager.
ORA-06315: IPA: Invalid connect string
Cause: The connect string is malformed.
Action: Check and correct.
ORA-06316: IPA: Invalid database SID
Cause: The SID is unknown at the remote side.
Action: Either the database does not exist, is not running, or there are no reserved servers for that SID.
ORA-06317: IPA: Local maximum number of users exceeded
Cause: The maximum number of simultaneous users of SQL*Net IPA has been exceeded on the local side.
Action: Wait for free connections to become available. If the problem persists, contact your system manager.
ORA-06318: IPA: Local maximum number of connections exceeded
Cause: The maximum number of simultaneous connections that SQL*Net IPA can handle to different hosts has been exceeded on the local side.
Action: Wait for free connections to become available. If the problem persists, contact your system manager.
ORA-06319: IPA: Remote maximum number of users exceeded
Cause: The maximum number of simultaneous users of SQL*Net IPA has been exceeded on the remote side.
Action: Wait for free connections to become available. If the problem persists, contact your system manager.
ORA-06320: IPA: Remote maximum number of connections exceeded
Cause: The maximum number of simultaneous connections that SQL*Net IPA can handle from different hosts has been exceeded on the remote side.
Action: Wait for free connections to become available. If the problem persists, contact your system manager.
ORA-06321: IPA: Cannot reach the remote side
Cause: There has been a timeout on an attempt to connect to a remote server the reason for which is most likely to be the remote SQL*Net IPA software is not running. An alternative reason could be that the remote initiator service name is incorrect.
Action: Check and start the remote SQL*Net software. Check that it is started with the correct service names supplied.
ORA-06322: IPA: Fatal shared memory error
Cause: An internal error has occurred in the shared memory handling.
Action: Contact customer support.
ORA-06323: IPA: Cause event error
Cause: Fatal interprocess communication error.
Action: Contact your system manager.
ORA-06400: NETCMN: No default host string specified
Cause: There was no default host string specified in the configuration and the user didn't specify any explicit connect string.
Action: Either reconfigure the system specifying a default connect string or use an explicit connect string.
ORA-06401: NETCMN: invalid driver designator
Cause: The login (connect) string contains an invalid driver designator.
Action: Correct the string and re-submit.
ORA-06402: NETCMN: error receiving break message
Cause: Error occurred while attempting to read a break message.
Action: Contact your customer support representative.
ORA-06403: Unable to allocate memory.
Cause: System unable to allocate needed virtual memory.
Action: Configure more memory, reduce load, or simply try again.
ORA-06404: NETCMN: invalid login (connect) string
Cause: Syntax error in login string.
Action: Correct string and re-submit.
ORA-06405: NETCMN: reset protocol error
Cause: Unable to reset out of break state.
Action: Contact your customer support representative.
ORA-06406: NETCMN: error sending break message
Cause: Error occurred while attempting to send a break message.
Action: Contact your customer support representative.
ORA-06407: NETCMN: unable to set up break handling environment
Cause: Error occurred while attempting to set up asynchronous handlers for in-coming, out-of-band break messages.
Action: Contact your customer support representative.
ORA-06408: NETCMN: incorrect message format
Cause: Message from partner contains bad header.
Action: Contact your customer support representative.
ORA-06413: Connection not open.
Cause: Unable to establish connection.
Action: Use diagnostic procedures to ascertain exact problem.
ORA-06416: NETCMN: error on test
Cause: Error occurred while testing I/O status of the network connection.
Action: Contact your customer support representative.
ORA-06419: NETCMN: server can not start oracle
Cause: The remote server was unable to start an ORACLE process on behalf of the client.
Action: Make sure permissions on the remote ORACLE program are correctly set. Contact your system administrator.
ORA-06420: NETCMN: SID lookup failure
Cause: From the remote host's server: the database SID, specified in the login (connect) string, was not recognized.
Action: Add the appropriate SID entry to the CONFIG.ORA or oratab file on the remote host (restarting the remote server may be needed).
ORA-06421: NETCMN: Error detected in the read-in data
Cause: Error found during recomputation of checksum or CRC.
Action: Possible hardware failures of communication nodes. Contact system administrator immediately.
ORA-06422: NETCMN: Error in sending data
Cause: Unable to transmit data to remote host.
Action: Try reconnect to remote host, and contact your system administrator.
ORA-06423: NETCMN: Error in receiving data
Cause: Unable to receive data from remote host.
Action: Try reconnect to remote host, and contact your system administrator.
ORA-06430: ssaio: Seals do not match
Cause: A function was called with an invalid argument.
Action: Contact your Oracle Customer Support Representative.
ORA-06431: ssaio: Invalid Block number
Cause: The file block number is out of range of the file. The additional information returns the block number.
Action: Verify that the block number is correct. Run dbfsize and check if the block number is in that range. Contact your Oracle Customer Support Representative.
ORA-06432: ssaio: Buffer Not Aligned
Cause: The I/O buffer was not aligned on a 2K boundary.
Action: Contact your Oracle Customer Support Representative.
ORA-06433: ssaio: LSEEK error, unable to seek to requested block.
Cause: The additional information returns the block number
Action: Look up the additional information returned in your operating system reference manual. Verify that the block number is correct.
ORA-06434: ssaio: read error, unable to read requested block from database file.
Cause: The read system call returned an error.
Action: The additional information indicates the block number. Look up the additional information returned in your operating system manual.
ORA-06435: ssaio: write error, unable to write requested block to database file.
Cause: The write system call returned an error.
Action: The additional information indicates the block number. Look up the additional information returned in your operating system manual.
ORA-06436: ssaio: asynchronous I/O failed due to incorrect parameters.
Cause: The Asynchronous I/O system call returned an error.
Action: The additional information indicates the block number. Look up the additional information returned in your operating system manual.
ORA-06437: ssaio: the asynchronous write was unable to write to the database file.
Cause: The Asynchronous I/O system call returned an error.
Action: The additional information indicates the block number. Look up the additional information returned in your operating system manual.
ORA-06438: ssaio: the asynchronous read was unable to read from the database file.
Cause: The Asynchronous I/O system call returned an error.
Action: The additional information indicates the block number. Look up the additional information returned in your operating system manual.
ORA-06439: ssaio: the asynchronous write returned incorrect number of bytes
Cause: This write call may have been truncated. The additional information returns the block number and number of bytes.
Action: Verify that the block number and the number of bytes written are correct.
ORA-06440: ssaio: the asynchronous read returned incorrect number of bytes
Cause: This read call may have been truncated. The additional information returns the block number and number of bytes.
Action: Verify that the block number and the number of bytes read are correct.
ORA-06441: ssvwatev: Incorrect parameter passed to function call
Cause: Either the ORACLE process id, or wait time or event ID is invalid.
Action: The additional information indicates the process id, time and event id.
ORA-06442: ssvwatev: Failed with unexpected error number.
Cause: Some system problems may exists on your system, please check error logs.
Action: The additional information indicates the error number. Look up the additional information returned in your operating system manual.
ORA-06443: ssvpstev: Incorrect parameter passed to function call
Cause: An invalid event ID is passed in to this routine.
Action: The additional information indicates the event id.
ORA-06444: ssvpstev: Failed with unexpected error number.
Cause: Some system problems may exist on your system, please check error logs.
Action: The additional information indicates the error number. Look up the additional information returned in your operating system manual.
ORA-06445: ssvpstevrg: Incorrect parameters passed to function call
Cause: An invalid event id, or the low and high event ID do not exist.
Action: The additional information indicates the error number. It also contains the event id, low boundary and high boundary.
ORA-06446: ssvpstevrg: Failed with unexpected error number.
Cause: Some system problems may exist on your system, please check error logs.
Action: The additional information indicates the error number. Look up the additional information returned in your operating system manual.
ORA-06447: ssvpstp: Incorrect parameter passed to function call
Cause: Invalid oracle process ID is passed in to this routine.
Action: The additional information indicates the process id.
ORA-06448: ssvpstp: Failed with unexpected error number.
Cause: Some system problems may exists on your system, please check error logs.
Action: The additional information indicates the error number. Look up the additional information returned in your operating system manual.
ORA-06449: The list IO or the sysvendor is not installed.
Cause: ORACLE tries to use the sysvendor interface (INIT.ORA parameter use_sysvendor=true) but the UNIX kernel does not have the ORACLE sysvendor interface linked in.
Action: Set use_sysvendor=false in INIT.ORA, if you don't want to use this interface or link the UNIX kernel with this interface so that ORACLE can use it.
ORA-06503: PL/SQL: Function returned without value
Cause: A call to PL/SQL function completed, but no RETURN statement was executed.
Action: Rewrite PL/SQL function, making sure that it always returns a value of a proper type.
ORA-06504: PL/SQL: Return types of Result Set variables or query do not match
Cause: Number and/or types of columns in a query does not match declared return type of a result set variable, or declared types of two Result Set variables do not match.
Action: Change the program statement or declaration. Verify what query the variable actually refers to during execution.
ORA-06505: PL/SQL: variable requires more than 32767 bytes of contiguous memory
Cause: A PL/SQL variable was declared with a constraint which required more than 32767 bytes of memory. PL/SQL does not currently support allocations of contiguous memory greater than 32767 bytes.
Action: Consider reducing the constraint in the variable declaration. If that is not possible, try changing the database or national character set to such, that requires less memory for the same constraint. Note: changing the character set will impact execution of all PL/SQL code.
ORA-06510: PL/SQL: unhandled user-defined exception
Cause: A user-defined exception was raised by PL/SQL code, but not handled.
Action: Fix the problem causing the exception or write an exception handler for this condition. Or you may need to contact your application administrator or DBA.
ORA-06511: PL/SQL: cursor already open
Cause: An attempt was made to open a cursor that was already open.
Action: Close cursor first before reopening.
ORA-06512: at stringline string
Cause: Backtrace message as the stack is unwound by unhandled exceptions.
Action: Fix the problem causing the exception or write an exception handler for this condition. Or you may need to contact your application administrator or DBA.
ORA-06513: PL/SQL: index for PL/SQL table out of range for host language array
Cause: An attempt is being made to copy a PL/SQL table to a host language array. But an index in the table is either less than one or greater than the maximum size of the host language array. When copying PL/SQL tables to host language arrays, the table entry at index 1 is placed in the first element of the array, the entry at index 2 is placed in the second element of the array, etc. If an table entry has not been assigned then the corresponding element in the host language array is set to null.
Action: Increase size of host language array, or decrease size of PL/SQL table. Also make sure that you don't use index values less than 1.
ORA-06514: PL/SQL: The remote call cannot be handled by the server
Cause: The remote call has parameters that are cursor variables or lob variables. This cannot be handled by stored procedures on your server.
Action: Avoid using cursor variables or lob variables as parameters for stored procedures on this server or upgrade your server to a version that supports this.
ORA-06515: PL/SQL: unhandled exception string
Cause: An exception was raised by PL/SQL code, but not handled. The exception number is outside the legal range of Oracle errors.
Action: Fix the problem causing the exception or write an exception handler for this condition. Or you may need to contact your application administrator or DBA.
ORA-06516: PL/SQL: the Probe packages do not exist or are invalid
Cause: A Probe operation, probably an attempt to initialize the ORACLE server to debug PL/SQL, could not be completed because the Probe packages were not loaded or have become invalid.
Action: DBA should load the Probe packages. This can be done by running the pbload.sql script supplied with the RDBMS.
ORA-06517: PL/SQL: Probe error - string
Cause: An error occurred while passing a Probe operation to the server for execution.
Action: Refer to the entry for the embedded error message.
ORA-06518: PL/SQL: Probe version string incompatible with version string
Cause: The current version of Probe is incompatible with the version on the ORACLE server.
Action: Refer to the documentation to ensure that this degree of compatibility is supported.
ORA-06519: active autonomous transaction detected and rolled back
Cause: Before returning from an autonomous PL/SQL block, all autonomous transactions started within the block must be completed (either committed or rolled back). If not, the active autonomous transaction is implicitly rolled back and this error is raised.
Action: Ensure that before returning from an autonomous PL/SQL block, any active autonomous transactions are explicitly committed or rolled back. ----------------------------------------------------------------------- 06520 through 06529 reserved for Foreign function errors
ORA-06520: PL/SQL: Error loading external library
Cause: An error was detected by PL/SQL trying to load the external library dynamically.
Action: Check the stacked error (if any) for more details.
ORA-06521: PL/SQL: Error mapping function
Cause: An error was detected by PL/SQL trying to map the mentioned function dynamically.
Action: Check the stacked error (if any) for more details.
ORA-06522: %s
Cause: ORA-06520 or ORA-065211 could stack this error with a system specific error string.
Action: This error string should give the cause for errors ORA-06520 or ORA-065211
ORA-06523: Maximum number of arguments exceeded
Cause: There is an upper limit on the number of arguments that one can pass to the external function.
Action: Check the port specific documentation on how to calculate the upper limit.
ORA-06524: Unsupported option : string
Cause: The option specified is an unsupported feature for external procedures.
Action: Correct the syntax in the external specification
ORA-06525: Length Mismatch for CHAR or RAW data
Cause: The length specified in the length variable has an illegal value. This can happen if you have requested requested a PL/SQL INOUT, OUT or RETURN raw variable to be passed as a RAW with no corresponding length variable. This error can also happen if there is a mismatch in the length value set in the length variable and the length in the orlvstr or orlraw.
Action: Correct the external procedure code and set the length variable correctly.
ORA-06526: Unable to load PL/SQL library
Cause: PL/SQL was unable to instantiate the library referenced by this referenced in the EXTERNAL syntax. This is a serious error and should normally not happen.
Action: Report this problem to customer support.
ORA-06527: External procedure SQLLIB error: string
Cause: An error occurred in sqllib during execution of a Pro* external procedure.
Action: The message text indicates the actual SQLLIB error that occurred. Consult the Oracle Error Messages and Codes manual for a complete description of the error message and follow the appropriate action.
ORA-06528: Error executing PL/SQL profiler
Cause: An error occurred in during execution of a PL/SQL profiler procedure.
Action: Check the stacked errors for more details.
ORA-06529: Version mismatch - PL/SQL profiler
Cause: The PL/SQL profiler package (dbmspb.sql, prvtpbp.plb) does not match the version of the code in the server implementing the profiler.
Action: Run the package profload.sql in $ORACLE_HOME/rdbms/admin to load the correct version of the PL/SQL profiler packages
ORA-06530: Reference to uninitialized composite
Cause: An object, LOB, or other composite was referenced as a left hand side without having been initialized.
Action: Initialize the composite with an appropriate constructor or whole-object assignment.
ORA-06531: Reference to uninitialized collection
Cause: An element or member function of a nested table or varray was referenced (where an initialized collection is needed) without the collection having been initialized.
Action: Initialize the collection with an appropriate constructor or whole-object assignment.
ORA-06532: Subscript outside of limit
Cause: A subscript was greater than the limit of a varray or non-positive for a varray or nested table.
Action: Check the program logic and increase the varray limit if necessary.
ORA-06533: Subscript beyond count
Cause: An in-limit subscript was greater than the count of a varray or too large for a nested table.
Action: Check the program logic and explicitly extend if necessary.
ORA-06534: Cannot access Serially Reusable package string
Cause: The program attempted to access a Serially Reusable package in PL/SQL called from SQL context (trigger or otherwise). Such an access is currently unsupported.
Action: Check the program logic and remove any references to Serially Reusable packages (procedure, function or variable references) which might happen in PL/SQL called from sql context (trigger or otherwise).
ORA-06535: statement string in string is NULL or 0 length
Cause: The program attempted to use a dynamic statement string that was either NULL or 0 length.
Action: Check the program logic and ensure that the dynamic statement string is properly initialized.
ORA-06536: IN bind variable bound to an OUT position
Cause: The program attempted to bind an IN bind variable to a statement that was expecting an OUT bind variable at that position.
Action: Make sure that an OUT or IN OUT bind mode is specified for the bind argument.
ORA-06537: OUT bind variable bound to an IN position
Cause: The program attempted to bind an OUT bind variable to a statement that was expecting an IN bind variable at that position.
Action: Make sure that an IN or IN OUT bind mode is specified for the bind argument.
ORA-06538: statement violates string RESTRICT_REFERENCES pragma
Cause: The program attempted to execute a dynamic statement which does not meet the purity level specified (in the pragma RESTRICT_REFERENCES directive) for the module executing the statement.
Action: Ensure that the dynamic statement meets the purity level specified for the module executing the statement.
ORA-06539: target of OPEN must be a query
Cause: The program attempted to perform an OPEN cursor operation on a dynamic statement that was not a query.
Action: Ensure that the OPEN cursor operation is done on a dynamic query statement. -------------------------------------------------------- 06540 through 06549 reserved for pl/sql error handling
ORA-06540: PL/SQL: compilation error
Cause: A pl/sql compilation error occurred. However, the user generally will not see this error message. Instead, there will be accompanying PLS-nnnnn error messages.
Action: See accompanying PLS-nnnnn error messages.
ORA-06541: PL/SQL: compilation error - compilation aborted
Cause: A pl/sql compilation error occurred and the compilation was aborted; but the compilation unit was written out to the backing store. However, unlike ora-06545, the user generally will not see this error message. Instead, there will be accompanying PLS-nnnnn error messages.
Action: See accompanying PLS-nnnnn error messages.
ORA-06544: PL/SQL: internal error, arguments: [string], [string], [string], [string], [string], [string], [string], [string]
Cause: A pl/sql internal error occurred.
Action: Report as a bug; the first argument is the internal error nuber.
ORA-06545: PL/SQL: compilation error - compilation aborted
Cause: A pl/sql compilation error occurred and the compilation was aborted completely without the compilation unit being written out to the backing store. Unlike ora-06541, the user will always see this error along with the accompaning PLS-nnnnn error messages.
Action: See accompanying PLS-nnnnn error messages.
ORA-06546: DDL statement is executed in an illegal context
Cause: DDL statement is executed dynamically in illegal PL/SQL context.

- Dynamic OPEN cursor for a DDL in PL/SQL

- Bind variable's used in USING clause to EXECUTE IMMEDIATE a DDL

- Define variable's used in INTO clause to EXECUTE IMMEDIATE a DDL

Action: Use EXECUTE IMMEDIATE without USING and INTO clauses to execute the DDL statement.
ORA-06547: RETURNING clause must be used with INSERT, UPDATE, or DELETE statements
Cause: EXECUTE IMMEDIATE with a RETURNING clause is used to execute dynamic UPDATE, INSERT, or DELETE statements only.
Action: use RETURNING clause in EXECUTE IMMEDIATE for INSERT, UPDATE, or DELETE statements only. For other statements, use USING clause instead.
ORA-06548: no more rows needed
Cause: The caller of a pipelined function does not need more rows to be produced by the pipelined function.
Action: Catch the NO_DATA_NEEDED exception is an exception handling block.
ORA-06549: PL/SQL: failed to dynamically open shared object (DLL): string
Cause: One possible cause might be there are too many DLLs open at the same time.
Action: --------------------------------------------------------
ORA-06550: line string, column string: string
Cause: Usually a PL/SQL compilation error.
Action: none
ORA-06554: package DBMS_STANDARD must be created before using PL/SQL
Cause: The DBMS specific extensions to PL/SQL's package "STANDARD" are in package "DBMS_STANDARD". This package must be created before using PL/SQL.
Action: Create package "DBMS_STANDARD". The source for this PL/SQL stored package is provided with the distribution.
ORA-06555: this name is currently reserved for use by user SYS
Cause: You tried to create a package named "STANDARD", "DBMS_STANDARD" or "DEBUG_IO". These are currently reserved for use by user SYS.
Action: Choose another name for your package.
ORA-06556: the pipe is empty, cannot fulfill the unpack_message request
Cause: There are no more items in the pipe.
Action: Check that the sender and receiver agree on the number and types of items placed on the pipe.
ORA-06557: null values are not allowed for any parameters to pipe icd's
Cause: Internal error from the dbms_pipe package.
Action: none
ORA-06558: buffer in dbms_pipe package is full. No more items allowed
Cause: The pipe buffer size has been exceeded.
Action: none
ORA-06559: wrong datatype requested, string, actual datatype is string
Cause: The sender put different datatype on the pipe than that being requested (package 'dbms_pipe'). The numbers are: 6 - number, 9 - char, 12 - date.
Action: Check that the sender and receiver agree on the number and types of items placed on the pipe.
ORA-06560: pos, string, is negative or larger than the buffer size, string
Cause: Internal error from the dbms_pipe package.
Action: none
ORA-06561: given statement is not supported by package DBMS_SQL
Cause: Attempting to parse an unsupported statement using procedure PARSE provided by package DBMS_SQL.
Action: Only statements which begin with SELECT, DELETE, INSERT, UPDATE, LOCK, BEGIN, DECLARE or << (PL/SQL label delimiter) are supported.
ORA-06562: type of out argument must match type of column or bind variable
Cause: Attempting to get the value of a column or a bind variable by calling procedure COLUMN_VALUE or VARIABLE_VALUE of package DBMS_SQL but the type of the given out argument where to place the value is different from the type of the column or bind variable that was previously defined by calling procedure DEFINE_COLUMN (for defining a column) or BIND_VARIABLE (for binding a bind variable) of package DBMS_SQL.
Action: Pass in an out argument of the correct type when calling procedure COLUMN_VALUE or VARIABLE_VALUE. The right type is the type that was provided when defining the column or binding the bind variable.
ORA-06563: top level procedure/function specified, cannot have subparts
Cause: The name to be resolved was specified with three parts (a.b.c) but the a.b part resolves to a top level procedure or function (which don't have nested procedures). This can also happen with a two-part name, a.b, where a is a synonym for a top level package or procedure.
Action: Specify a procedure/function within a package, or a top level procedure/function.
ORA-06564: object string does not exist
Cause: The named object could not be found. Either it does not exist or you do not have permission to access it.
Action: Create the object or get permission to access it.
ORA-06565: cannot execute string from within stored procedure
Cause: The named procedure cannot be executed from within a stored procedure, function or package. This function can only be used from pl/sql anonymous blocks.
Action: Remove the procedure from the calling stored procedure.
ORA-06566: invalid number of rows specified
Cause: An invalid number of rows was specified in a call to the procedure DEFINE_COLUMN in the package DBMS_SQL. For a given parsed statement in a given cursor, all columns must be defined to have the same number of rows, so all the calls to DEFINE_COLUMN must specify the same number of rows.
Action: Specify a number that matches that for previously defined columns.
ORA-06567: invalid number of values specified
Cause: An invalid number of values to be bound was specified in a call to the procedure BIND_VARIABLE in the package DBMS_SQL. In order to execute a given parsed statement in a given cursor, the same number of values must have been bound for all bind variables, so when EXECUTE is called, the latest calls to BIND_VARIABLE must must have specified the same number of values to be bound for all bind variables.
Action: Make sure that the same number of values have been bound for all of the bind variables.
ORA-06568: obsolete ICD procedure called
Cause: An obsolete ICD procedure was called by a PL/SQL program. The PL/SQL program was probably written for an eralier release of RDBMS.
Action: Make sure that all PL/SQL programs have been upgraded to the latest release of the RDBMS. This can be accomplished by following upgrade instructions in the README file, or by running the catproc.sql script supplied with the RDBMS.
ORA-06569: Collection bound by bind_array contains no elements
Cause: A collection with zero elements was bound to a bind variable in a call to procedure BIND_ARRAY in the package DBMS_SQL. In order to execute a bind of a collection, the collection must contain at least one element. If no elements are present then at execute time there will be no value for this bind and the statement is meaningless.
Action: Fill the collection with the elements you want to bind and try the bind call again.
ORA-06570: shared pool object does not exist, cannot be pinned
Cause: The specified shared pool shared cursor could not be found, therefore it cannot be pinned.
Action: Remove the procedure from the calling stored procedure.
ORA-06571: Function string does not guarantee not to update database
Cause: There are two possible causes for this message:

* A SQL statement references a packaged, PL/SQL function that does not contain a pragma that prevents the database from being updated.

* A SQL statement references a stand-alone, PL/SQL function that contains an instruction to update the database.

Action: If the referenced function is a packaged, PL/SQL function: Recreate the PL/SQL function with the required pragma; be certain to include the 'Write No Database State' (WNDS) argument in the argument list of the pragma. If the referenced function is a stand-alone, PL/SQL function: Do not use the function.
ORA-06572: Function string has out arguments
Cause: A SQL statement references either a packaged, or a stand-alone, PL/SQL function that contains an OUT parameter in its argument list. PL/SQL functions referenced by SQL statements must not contain the OUT parameter.
Action: Recreate the PL/SQL function without the OUT parameter in the argument list.
ORA-06573: Function string modifies package state, cannot be used here
Cause: There are two possible causes for this message:

* A SQL statement references a packaged, PL/SQL function that does not contain a pragma containing the 'Write no Package State' (WNPS).

* A SQL statement references a stand-alone, PL/SQL function that modifies a package state. A stand-alone, PL/SQL function referenced by a SQL statement cannot modify a package state.

Action: If the function is a packaged, PL/SQL function: Recreate the function and include a pragma containing the 'Write no Package State' (WNPS). If the function is a stand-alone, PL/SQL function: Delete the function from the SQL statement.
ORA-06574: Function string references package state, cannot execute remotely
Cause: There are two possible causes for this message:

* A remote, packaged function or a remote-mapped, local, packaged function that does not contain a pragma with the 'Write no Package State' (WNPS) and 'Read no Package State' (RNPS) arguments references a package state.

* A remote, stand-alone function or a remote-mapped, local, stand-alone function contains a reference to a package state (reads or writes a package variable). Only local functions that are referenced in a SELECT list, VALUES clause of an INSERT statement, or SET clause of an UPDATE statement can modify a package state.

Action: If the function is a packaged function: Recreate the function and include a pragma containing the 'Write no Package State' (WNPS) and 'Read no Package State' (RNPS) arguments. If the function is a stand-alone function: Do not call the function.
ORA-06575: Package or function string is in an invalid state
Cause: A SQL statement references a PL/SQL function that is in an invalid state. Oracle attempted to compile the function, but detected errors.
Action: Check the SQL statement and the PL/SQL function for syntax errors or incorrectly assigned, or missing, privileges for a referenced object.
ORA-06576: not a valid function or procedure name
Cause: Could not find a function (if an INTO clause was present) or a procedure (if the statement did not have an INTO clause) to call.
Action: Change the statement to invoke a function or procedure
ORA-06577: output parameter not a bind variable
Cause: The argument corresponding to an IN/OUT or OUT parameter for a function or a procedure or a function return value in a CALL statement must be a bind variable.
Action: Change the argument to a bind variable
ORA-06578: output parameter cannot be a duplicate bind
Cause: The bind variable corresponding to an IN/OUT or OUT parameter for a function or a procedure or a function return value in a CALL statement cannot be a duplicate bind variable.
Action: Change the bind variable to be unique
ORA-06579: Bind variable not big enough to hold the output value
Cause: The bind variable specified by the user is not large enough to hold the output returned by the function or a procedure.
Action: Specify a bind variable of larger size.
ORA-06580: Hash Join ran out of memory while keeping large rows in memory
Cause: Hash Join reserves 3 slots (each slot size = DB_BLOCK_SIZE * HASH_JOIN_MULTIBLOCK_IO_COUNT) for a row. If a row is larger than that, this error will be raised.
Action: Increase HASH_JOIN_MULTIBLOCK_IO_COUNT so that each joined row fits in a slot. HASH_AREA_SIZE may also need to be increaed.
ORA-06592: CASE not found while executing CASE statement
Cause: A CASE statement must either list all possible cases or have an else clause.
Action: Add all missing cases or an else clause.
ORA-06593: %s is not supported with natively compiled PL/SQL modules
Cause: Specified feature is not yet supported for natively compiled PL/SQL modules yet.
Action: Recompile the relevant PL/SQL modules in non-native mode by setting the parameter plsql_compiler_flags to INTERPRETED.
ORA-06600: LU6.2 Driver: SNA software is not loaded
Cause: The SNA software is not running.
Action: Start the SNA software and try again.
ORA-06601: LU6.2 Driver: Invalid database ID string
Cause: The database string in the connect was invalid.
Action: Provide a valid database string, as defined in documentation.
ORA-06602: LU6.2 Driver: Error allocating context area
Cause: Context area failure.
Action: Contact your local service representative.
ORA-06603: LU6.2 Driver: Error allocating memory
Cause: Operating system refused request for memory.
Action: Contact you local service representative.
ORA-06604: LU6.2 Driver: Unable to allocate session with remote LU
Cause: Allocate system call failed.
Action: Ensure that the SNA software is running and that sessions are free. If this is the case, then check your SNA configuration data for errors. You may have entered an incorrect parameter.
ORA-06605: LU6.2 Driver: Unexpected line turnaround
Cause: SNA software switched from send to receive unexpectedly.
Action: Check the SNA configuration data, particularly parameters associated with a session.
ORA-06606: LU6.2 Driver: Unexpected response from SNA
Cause: A parameter in an SNA call returned an unexpected value.
Action: Attempt to reproduce problem, debug and record the value of the 'what' data parameter at the time of error. Then contact your service representative.
ORA-06607: LU6.2 Driver: Reset occurred in send state
Cause: A reset was issued whilst in send state.
Action: Check the SNA LOG data, if relevent, for further information.
ORA-06608: LU6.2 Driver: Reset occurred in receive state
Cause: A reset was received from the partner whilst in receive state. This may be because the partner deallocated.
Action: Check the SNA LOG data, if relevent, for further information.
ORA-06610: LU6.2 Driver: Failed during deallocation
Cause: LU6.2 driver was unable to deallocate gracefully.
Action: Check the reason for deallocation. Consult the SNA LOG data.
ORA-06616: LU6.2 Driver: Attach to LU failed
Cause: The SQL*Net LU6.2 driver was unable to attach to the LU specified in the connect string, or was unable to attach to the default LU.
Action: Check that the LU name specified in the connect string, or the default LU name if no LU was specified, is correctly configured and operational.
ORA-06622: LU6.2 Driver: Unable to attach to SNA
Cause: The SQL*Net LU6.2 driver could not attach to the SNA software on your machine. The most likely cause is that the SNA software is not operational.
Action: Check the status of the SNA software, ensure that it is operational and then try again.
ORA-06700: TLI Driver: incorrect message type from host
Cause: TLI received a message with an unrecognizable message type.
Action: Contact your customer support representative.
ORA-06701: TLI Driver: incorrect number of bytes written
Cause: TLI sent a message that was apparently successful, but the number of bytes transmitted did not match the number of bytes supplied to the driver.
Action: Contact your customer support representative.
ORA-06702: TLI Driver: cannot allocate context area
Cause: TLI could not allocate heap space for the context area.
Action: Contact your customer support representative.
ORA-06703: TLI Driver: send break message failed
Cause: TLI failed to send a break message across the connection.
Action: Contact your customer support representative.
ORA-06704: TLI Driver: receive break message failed
Cause: TLI failed to receive an expected break message.
Action: Contact your customer support representative.
ORA-06705: TLI Driver: remote node is unknown
Cause: TLI could not find your remote host information.
Action: Make sure you specified the hostname correctly on the command line. (Also, check your capitalization and spelling.)
ORA-06706: TLI Driver: service not found
Cause: TLI could not find service information for the specified service name.
Action: If you specified the service name on the command line or with the environment variable TLI_SERVER, make sure you specified it correctly. If the service name is not in the SERVICES file for your protocol, ask your system adminstrator to add it.
ORA-06707: TLI Driver: connection failed
Cause: TLI failed to establish the connection to a SQL*Net TCP/IP server due to an error encountered by the remote server, which has supplied a string describing the remote error.
Action: See the SQL*Net TCP/IP User's Guide section "orasrv Messages" for the specific cause and action.
ORA-06708: TLI Driver: message receive failure
Cause: TLI encountered an error receiving a message from the communication channel.
Action: Contact your customer support representative.
ORA-06709: TLI Driver: message send failure
Cause: TLI encountered an error sending a message across the communication channel.
Action: Contact your customer support representative.
ORA-06710: TLI Driver: send interrupt break message failed
Cause: TLI failed to send a break message while handling an interrupt signal from the user.
Action: Contact your customer support representative.
ORA-06711: TLI Driver: error on bind
Cause: TLI failed to assign a network address to the communication channel.
Action: Contact your customer support representative.
ORA-06712: TLI Driver: error on accept
Cause: TLI failed to accept a connection request from the client.
Action: Contact your customer support representative.
ORA-06713: TLI Driver: error on connect
Cause: TLI failed to connect the client to the remote server. The network line to the remote host may be down.
Action: Use other network login programs to make sure that the remote host is accessible.
ORA-06720: TLI Driver: SID lookup failure
Cause: The database SID supplied in the database login string was not recognized by the remote host.
Action: Ask your system administrator to add the appropriate SID entry to oratab on the remote host.
ORA-06721: TLI Driver: spurious client req
Cause: The remote TLI server received an undefined request.
Action: Contact your customer support representative.
ORA-06722: TLI Driver: connection setup failure
Cause: The remote TLI server rejected the connection request, and the client was unable to retrieve an error code or message.
Action: Contact your customer support representative.
ORA-06730: TLI Driver: unable to open clone device
Cause: TLI failed to open the Streams clone device associated with the transport provider.
Action: Contact your customer support representative.
ORA-06731: TLI Driver: cannot alloc t_call
Cause: TLI cannot allocate space for the client's connection information.
Action: Contact your customer support representative.
ORA-06732: TLI Driver: cannot alloc t_discon
Cause: TLI cannot allocate space for the client's disconnection information.
Action: Contact your customer support representative.
ORA-06733: TLI Driver: failed to receive disconnect
Cause: TLI failed to receive an expected disconnection message during connection release.
Action: Contact your customer support representative.
ORA-06734: TLI Driver: cannot connect
Cause: TLI failed to connect the client to the remote server.
Action: Check that the remote TLI server is running.
ORA-06735: TLI Driver: client failed to close error conn
Cause: TLI failed to properly close a connection after an error was received.
Action: Contact your customer support representative.
ORA-06736: TLI Driver: server not running
Cause: TLI timed out while attempting to connect to the remote TLI server.
Action: Check that the remote TLI server is running with the status utility for the transport provider you are using. If it is not, ask your system adminstrator to start it.
ORA-06737: TLI Driver: connection failed
Cause: TLI could not establish a connection to the remote TLI server.
Action: Check that the remote TLI server is running with the status utility for the transport provider you are using.
ORA-06741: TLI Driver: unable to open protocol device
Cause: The TLI server failed to open the Streams device associated with the transport provider.
Action: Contact your customer support representative.
ORA-06742: TLI Driver: cannot alloc t_bind
Cause: The TLI server cannot allocate space for its requested network address.
Action: Contact your customer support representative.
ORA-06743: TLI Driver: cannot alloc t_bind
Cause: The TLI server cannot allocate space for its actual network address.
Action: Contact your customer support representative.
ORA-06744: TLI Driver: listener cannot bind
Cause: The TLI server failed to assign the correct network address on which to listen for connections.
Action: Contact your customer support representative.
ORA-06745: TLI Driver: listener already running
Cause: The network address on which the TLI server awaits connection requests is in use, possibly because the server is already running.
Action: Ensure that the TLI server is not already running. If it is not running and this error message recurs, contact your customer support representative.
ORA-06746: TLI Driver: cannot alloc t_call
Cause: TLI cannot allocate space for the TLI server's connection information.
Action: Contact your customer support representative.
ORA-06747: TLI Driver: error in listen
Cause: The TLI server encountered an error while listening for connection requests.
Action: Contact your customer support representative.
ORA-06748: TLI Driver: cannot allocate t_discon
Cause: TLI cannot allocate space for the TLI server's disconnection information.
Action: Contact your customer support representative.
ORA-06749: TLI Driver: option not allowed across network
Cause: The requested TLI server command must be issued from the same host on which the server is running.
Action: Log in to the remote host and try again.
ORA-06750: TLI Driver: sync failed
Cause: The ORACLE process started by the TLI server was unable to synchronize its inherited connection.
Action: Contact your customer support representative.
ORA-06751: TLI Driver: bound addresses unequal
Cause: The osn check server address failed. The bound server address was not the same as the requested binding address.
Action: Contact your customer support representative.
ORA-06752: TLI: error in signal setup
Cause: A call to sigaction() returned with a system error.
Action: Contact your customer support representative.
ORA-06753: TLI Driver: name-to-address mapping failed
Cause: For SVR4, the netdir_getbyname() call failed for some unknown reason.
Action: Contact your custumer service representative.
ORA-06754: TLI Driver: unable to get local host address
Cause: The name of the remote host to connect to was not specified, and the name of the local host cannot be retrieved from the HOSTS file.
Action: Contact your system administrator.
ORA-06755: TLI Driver: cannot close transport endpoint
Cause: The TLI server was unable to close a connection after passing it to an ORACLE process.
Action: Contact your customer support representative.
ORA-06756: TLI Driver: cannot open oratab
Cause: The TLI server could not open the file used to define the locations of remotely accessible databases.
Action: Ask your system administrator to check that the file exists and has the correct permissions.
ORA-06757: TLI Driver: server got bad command
Cause: The TLI server received an invalid command.
Action: Contact your customer support representative.
ORA-06760: TLI Driver: timeout reading orderly release
Cause: TLI was not able to retreive an expected disconnect message while closing the communication channel.
Action: Contact your customer support representative.
ORA-06761: TLI Driver: error sending orderly release
Cause: TLI encountered an error sending a disconnect message closing the communication channel.
Action: Contact your customer support representative.
ORA-06762: TLI Driver: error reading orderly release
Cause: TLI encountered an error receiving an expected disconnect message while closing the communication channel.
Action: Contact your customer support representative.
ORA-06763: TLI Driver: error sending disconnect
Cause: TLI encountered an error sending a disconnect message closing the communication channel.
Action: Contact your customer support representative.
ORA-06764: TLI Driver: error reading disconnect
Cause: TLI was not able to retreive an expected disconnect message while closing the communication channel.
Action: Contact your customer support representative.
ORA-06765: TLI Driver: error awaiting orderly release
Cause: TLI encountered an error awaiting a disconnect message while closing the communication channel.
Action: Contact your customer support representative.
ORA-06766: TLI Driver: close failed during release
Cause: TLI failed to close the communication channel after receiving a disconnect message.
Action: Contact your customer support representative.
ORA-06767: TLI Driver: alloc failed during release
Cause: TLI cannot allocate space for disconnection information while closing the communication channel.
Action: Contact your customer support representative.
ORA-06770: TLI Driver: error sending version
Cause: TLI encountered an error while sending its version information during connection establishment.
Action: Contact your customer support representative.
ORA-06771: TLI Driver: error reading version
Cause: TLI encountered an error while awaiting the expected version information during connection establishment.
Action: Contact your customer support representative.
ORA-06772: TLI Driver: error sending command
Cause: TLI encountered an error while sending a command message during connection establishment.
Action: Contact your customer support representative.
ORA-06773: TLI Driver: error reading command
Cause: TLI encountered an error while awaiting the expected command message during connection establishment.
Action: Contact your customer support representative.
ORA-06774: TLI Driver: error sending break mode
Cause: TLI encountered an error while sending break-mode message during connection establishment.
Action: Contact your customer support representative.
ORA-06775: TLI Driver: error reading break mode
Cause: TLI encountered an error while awaiting the expected break-mode message during connection establishment.
Action: Contact your customer support representative.
ORA-06776: TLI Driver: error sending parms
Cause: TLI encountered an error while sending the connection parameters during connection establishment.
Action: Contact your customer support representative.
ORA-06777: TLI Driver: error reading parms
Cause: TLI encountered an error while awaiting the expected connection parameter message during connection establishment.
Action: Contact your customer support representative.
ORA-06778: TLI Driver: error sending ccode
Cause: TLI encountered an error while sending the completion status message during connection establishment.
Action: Contact your customer support representative.
ORA-06779: TLI Driver: error reading ccode
Cause: TLI encountered an error while awaiting the expected completion status message during connection establishment.
Action: Contact your customer support representative.
ORA-06780: TLI Driver: recv error code failed
Cause: TLI encountered an error while awaiting an expected error message during connection establishment.
Action: Contact your customer support representative.
ORA-06781: TLI Driver: error reading negotation string
Cause: TLI encountered an error while awaiting the expected negotiation message during connection establishment.
Action: Contact your customer support representative.
ORA-06790: TLI Driver: poll failed
Cause: TLI was unable to poll the communication channel for possible incoming messages.
Action: Contact your customer support representative.
ORA-06791: TLI Driver: poll returned error event
Cause: TLI received an unexpected event while polling the communication channel for possible incoming messages.
Action: Contact your customer support representative.
ORA-06792: TLI Driver: server cannot exec oracle
Cause: The remote TLI server was unable to start an ORACLE process on behalf of the client.
Action: Note the operating system error message or number and contact your system adminstrator. The permissions on the remote ORACLE program may be set incorrectly.
ORA-06793: TLI Driver: server cannot create new process
Cause: The remote TLI server was unable to start an ORACLE process on behalf of the client.
Action: Note the operating system error message or number and contact your system adminstrator. The remote host may be unable to create any new processes due to a full process table.
ORA-06794: TLI Driver: shadow process could not retrieve protocol info
Cause: The ORACLE process either failed to allocate memory to store the protocol information record, or the protocol rejected the request for some unknown reason.
Action: Contact your customer support representative.
ORA-06800: TLI Driver: SQL*Net SPX client went away during reconnect
Cause: The client process was aborted by the system or the user, and was unable to complete the connection establishment with the server listener process.
Action: Determine cause of client exit, and reattempt connection.
ORA-06801: TLI Driver: listen for SPX server reconnect failed
Cause: An unknown event occurred on the client's listening socket.
Action: Contact your customer support representative.
ORA-06802: TLI Driver: could not open the /etc/netware/yellowpages file
Cause: The /etc/netware/yellowpages file does not exist, or is not readable by the TLI listener process.
Action: Insure the file exists and is readable. Make sure that the server machine's node name, network number, ethernet address, and listening socket number are encoded in the file.
ORA-06803: TLI Driver: the IPX device file could not be opened
Cause: The /dev/ipx file does not exist, or the driver has not been installed in the kernel correctly.
Action: Reinvoke the Oracle root installation. If problem continues, contact your customer support representative.
ORA-06804: TLI Driver: could not bind an IPX address at initialization
Cause: The IPX driver has not been correctly installed.
Action: Reinvoke the Oracle root installation. If problem continues, contact your customer support representative.
ORA-06805: TLI Driver: could not send datagram SAP packet for SPX
Cause: The socket endpoint for sending SAP packet was corrupted for some unknown reason.
Action: Contact your customer support representative.
ORA-06806: TLI Driver: could not complete protocol initialization for SPX
Cause: A step in the SPX/IPX protocol initialization failed.
Action: Check the previous error reported, and follow corrective action.
ORA-06807: TLI Driver: could not open ethernet device driver file
Cause: The file /dev/eth does not exist, or the driver it references could not be opened.
Action: The system's real ethernet device file, for example /dev/wd, for the Western Digital ethernet driver, should be linked to the file /dev/eth. If this has been done, insure that the ethernet driver has been installed by completing the TCP/IP installation on your system, and testing a connection. If problem continues, contact your customer support representative for a list of supported ethernet drivers.
ORA-06808: TLI Driver: could not link IPX and ethernet streams
Cause: Either the ethernet driver has not been installed in the system correctly, or the ethernet driver is not supported.
Action: Insure that the ethernet driver has been installed by completing the TCP/IP installation on your system, and testing a connection. If problem continues, contact your customer support representative for a list of supported ethernet drivers.
ORA-06809: TLI Driver: could not clear the IPX ethernet SAP at init
Cause: The IPX driver has not been correctly installed.
Action: Reinvoke the Oracle root installation. If problem continues, contact your customer support representative.
ORA-06810: TLI Driver: could not set the IPX ethernet SAP at init
Cause: The IPX driver has not been correctly installed.
Action: Reinvoke the Oracle root installation. If problem continues, contact your customer support representative.
ORA-06811: TLI Driver: could not set the IPX network number at init
Cause: The IPX driver has not been correctly installed, or the network number encoded in the /etc/netware/yellowpages file is invalid.
Action: The network number in the yellowpages file should match the four-byte network number of your Novell file server. If this is configured correctly, reinvoke the Oracle root installation. If problem continues, contact your customer support representative.
ORA-06812: TLI Driver: could not read the ethernet driver's node address
Cause: The ethernet driver is not installed correctly, or does not support this operation.
Action: Contact your customer support representative for a list of supported ethernet drivers.
ORA-06813: TLI Driver: the configured ethernet address is incorrect
Cause: The node address read from the ethernet driver does not match the value encoded in the /etc/netware/yellowpages file for this server.
Action: Confirm the correct ethernet node address for your LAN card, and enter this value in the yellowpages file.
ORA-06814: TLI Driver: the SPX device file could not be opened
Cause: The /dev/nspxd file does not exist, or the driver has not been installed in the kernel correctly.
Action: Reinvoke the Oracle root installation. If problem continues, contact your customer support representative.
ORA-06815: TLI Driver: could not link SPX and IPX streams
Cause: The SPX driver has not been correctly installed.
Action: Reinvoke the Oracle root installation. If problem continues, contact your customer support representative.
ORA-06816: TLI Driver: could not set the SPX SAP address
Cause: The SPX driver has not been correctly installed.
Action: Reinvoke the Oracle root installation. If problem continues, contact your customer support representative.
ORA-06817: TLI Driver: could not read the Novell network address
Cause: The file $ORACLE_HOME/spx/address could not be opened for reading and writing.
Action: Make sure ORACLE_HOME is set, and the permissions on the ORACLE_HOME are read, write. If this file has been unintentially deleted, run spxctl (net option) to reset the configured Novell network number for SQL*Net SPX.
ORA-06900: CMX: cannot read tns directory
Cause: CMX is not started on your system.
Action: Install and/or start CMX on your system.
ORA-06901: CMX: no local name assigned to local application
Cause: Local application oracmx has no local name assigned
Action: Enter unique local name for oracmx in the tns directory
ORA-06902: CMX: cannot attach to cmx subsystem
Cause: ccp-xxxx is not started
Action: start your ccp software on the communication controller
ORA-06903: CMX: cannot read transport address of remote application
Cause: remote application not entered in tns directory
Action: enter remote application in tns directory
ORA-06904: CMX: no transport address available for remote application
Cause: no local name assigned to remote application
Action: assign local name to remote application
ORA-06905: CMX: connect error
Cause: remote partner not listening
Action: make sure remote node has CMX installed and running make sure oracmx is running on remote host
ORA-06906: CMX: cannot get maximum packet size from CMX
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06907: CMX: error during connect confirmation
Cause: remote partner aborted
Action: contact your customer support representative
ORA-06908: CMX: error during transfer of ORACLE_SID
Cause: remote partner aborted
Action: contact your customer support representative
ORA-06909: CMX: error during acknowledge of ORACLE_SID
Cause: remote partner aborted
Action: contact your customer support representative
ORA-06910: CMX: Cannot start oracle process on remote machine
Cause: oracle process not found or wrong mode (should be 4751)
Action: change /etc/oratab or set mode to 4751
ORA-06911: CMX: t_event returns ERROR
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06912: CMX: write error in datarq
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06913: CMX: error during redirection of connection
Cause: oracmx has been stopped, or user process has been aborted
Action: contact your customer support representative
ORA-06914: CMX: unexepected event during start of oracle
Cause: connect sequence out of sync
Action: contact your customer support representative
ORA-06915: CMX: unknown t_event in datarq
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06916: CMX: error in data read (t_datain)
Cause: remote partner aborted
Action: contact your customer support representative
ORA-06917: CMX: error in data read (too many bytes read)
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06918: CMX: T_NOEVENT during wait for read event
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06919: CMX: error during write request (unknown event)
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06920: CMX: getbrkmsg illegal datatype
Cause: received packets are corrupted
Action: contact your customer support representative
ORA-06921: CMX: getdatmsg illegal datatype
Cause: received packets are corrupted
Action: contact your customer support representative
ORA-06922: CMX: bad write length
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06923: CMX: illegal break condition
Cause: break handling out of sync
Action: contact your customer support representative
ORA-06924: CMX: wrong break message length
Cause: received packets are corrupted
Action: contact your customer support representative
ORA-06925: CMX: disconnect during connect request
Cause: partner is not responding
Action: make sure partner is up and running and reachable
ORA-06926: CMX: T_ERROR during read data
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06927: CMX: T_DATAIN received before all data written
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06928: CMX: wrong ORACLE_SID
Cause: ORACLE_SID is not entered in remote oratab
Action: add ORACLE_SID to remote oratab
ORA-06929: CMX: error when sending ORACLE_SID
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06930: CMX: error when checking ORACLE_SID
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06931: CMX: error during read_properties for server
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06932: CMX: error in local name
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06933: CMX: error during attach
Cause: internal error in CMX
Action: contact your customer support representative
ORA-06950: No error
Cause: SQL*Net AppleTalk error codes base. This is not an error.
Action: None.
ORA-06951: Operating system call error
Cause: AppleTalk API received error in VMS system service.
Action: Contact Oracle Customer Support representative.
ORA-06952: Remote end of the communication issued a forward-reset packet.
Cause: Peer program may have aborted
Action: Investigate network problems and try again.
ORA-06953: Not enough virtual memory
Cause: Not enough memory available.
Action: Check VMS process quotas and/or sysgen parameters
ORA-06954: Illegal file name
Cause: Erroneous file name
Action: Check path name for server output file, or SQL*Net Appletalk Logical names and symbols.
ORA-06955: Number of database servers exceed limit
Cause: Too many database connections.
Action: Check ATKSRV_MAXCONparameter in configuration file.
ORA-06956: Failed to get local host name
Cause: Unable to get Appletalk host name.
Action: Check Appletalk configuration.
ORA-06957: No SID is currently available
Cause: Incoming SQL*Net connection specified invalid SID name.
Action: Specify correct SID in connect string and retry.
ORA-06958: Failed to access configuration file
Cause: Unable to access CONFIG.ATK
Action: Check file protections.
ORA-06959: Buffer I/O quota is too small
Cause: Buffered I/O quota exceeded.
Action: Increase BIOlm using AUTHORIZE utility and retry.
ORA-06960: Failed to access log file
Cause: SQL*Net Appletalk listener could not create log file.
Action: Check directory path and protections.
ORA-06970: X.25 Driver: remote host is unknown
Cause: Host name specified in the login (connect string) is unknown.
Action: Check spelling; make sure name is in the X.25 HOST file.
ORA-06973: X.25 Driver: invalid buffer size
Cause: The buffer size specified in the login string must be between 5 and 4096.
Action: Re-submit with valid buffer size.
ORA-06974: X.25 Driver: SID lookup failure
Cause: From the remote host's SQL*Net X.25 server: the database SID, specified in the login (connect) string, was not recognized.
Action: Add the appropriate SID entry to the CONFIG.ORA file on the remote host (and restart the SQL*Net X.25 server).
ORA-06975: X.25 Driver: connect to host failed
Cause: Connection attempt to remote host has failed. Probably means that the SQL*Net X.25 server on the remote host is not up, or the host itself is not up.
Action: Start the SQL*Net X.25 server process on the remote host.
ORA-06976: X.25 Driver: endpoint creation failure
Cause: Process open file quota probably exceeded.
Action: Contact your customer support representative.
ORA-06977: X.25 Driver: X.25 Level 2 failure
Cause: X.25 level 2 is down. X.25 link is not working.
Action: Run system checks to verify functioning of X.25 software. Contact your hardware vendor.
ORA-06978: X.25 Driver: Too many callback tries
Cause: Call back address probably same as called address.
Action: Verify that callback address and called address are different.
ORA-06979: X.25 Driver: server cannot start oracle
Cause: The remote X.25 server was unable to start an ORACLE process on behalf of the client.
Action: Make sure permissions on the remote ORACLE program are correctly set. Contact your system administrator.
ORA-07200: slsid: oracle_sid not set.
Cause: The environment variable $(ORACLE_SID) is not set.
Action: Set ORACLE_SID environment variable.
ORA-07201: slhom: oracle_home variable not set in environment.
Cause: $(ORACLE_HOME) environment variable not set.
Action: Set ORACLE_HOME.
ORA-07202: sltln: invalid parameter to sltln.
Cause: The sltln name translation routine was called with invalid arguments. The input, or output stings were either NULL or 0 length.
Action: Probable internal oracle error. Contact customer support.
ORA-07203: sltln: attempt to translate a long environment variable.
Cause: A string was passed to sltln containing a long environment variable. sltln accepts environment names of 30 or less characters.
Action: Shorten environment variable name to less than 30 characters.
ORA-07204: sltln: name translation failed due to lack of output buffer space.
Cause: The sltln routine is given a maximum length buffer to expand the name into. An overflow of this buffer occurred.
Action: Possible internal error. Check output buffer length stored in sercose[0]. Pathnames are limited to 255 characters.
ORA-07205: slgtd: time error, unable to obtain time.
Cause: Time() system call returned an error. Possible OS error.
Action: Check additional information returned. Contact customer support.
ORA-07206: slgtd: gettimeofday error, unable to obtain time.
Cause: Gettimeofday() system call returned an error. Possible OS error.
Action: Check additional information returned. Contact customer support.
ORA-07207: sigpidu: process ID string overflows internal buffer.
Cause: The sigpidu routine is given a maximum length buffer to hold process ID string. An overflow of this buffer occurred.
Action: Internal error. Contact customer support.
ORA-07208: sfwfb: failed to flush dirty buffers to disk.
Cause: The fsync system call returned an error. Possible OS error.
Action: Check additional information returned. Contact customer support.
ORA-07209: sfofi: file size limit was exceeded.
Cause: The size of the file to be opened exceeded the OS limit imposed on this process.
Action: Run osh to increase the file size limit.
ORA-07210: slcpu: getrusage error, unable to get cpu time.
Cause: Getrusage system call returned an error. Possible OS error.
Action: Check additional information returned. Contact customer support.
ORA-07211: slgcs: gettimeofday error, unable to get wall clock.
Cause: Gettimeofday system call returned an error. Possible OS error.
Action: Check additional information returned in OS reference manual. Contact customer support.
ORA-07212: slcpu: times error, unable to get cpu time.
Cause: times system call returned an error. Possible OS error.
Action: Check additional information returned. Contact customer support.
ORA-07213: slgcs: times error, unable to get wall clock.
Cause: times system call returned an error. Possible OS error.
Action: Check additional information returned in OS reference manual. Contact customer support.
ORA-07214: slgunm: uname error, unable to get system information.
Cause: uname system call returned an error. Possible OS error.
Action: Check additional information returned in OS reference manual. Contact customer support.
ORA-07215: slsget: getrusage error.
Cause: Getrusage system call returned an error. Possible OS error.
Action: Check additional information returned. Look for information in OS reference. Contact customer support.
ORA-07216: slghst: gethostname error, unable to get name of current host.
Cause: gethostname system call returned an error. Possible OS error.
Action: Check additional information returned in OS reference manual. Contact customer support.
ORA-07217: sltln: environment variable cannot be evaluated.
Cause: getenv call returned a null pointer.
Action: Set the environment variable and try again.
ORA-07218: slkhst: could not perform host operation
Cause: Unix system() call failed
Action: Examine system error message
ORA-07219: slspool: unable to allocate spooler argument buffer.
Cause: Malloc failed to allocate space to hold spooler arguments.
Action: Check additional information returned in OS reference manual. The process may have run out of heap space. Contact customer support.
ORA-07220: slspool: wait error.
Cause: Wait returned an error, when waiting for spool job to complete. Possible spooler program error.
Action: Check additional information returned. Refer to OS reference manual. Contact customer support.
ORA-07221: slspool: exec error, unable to start spooler program.
Cause: Exec failed when starting line printer spooler command. Likely that either the default line printer command, or ORACLE_LPPROG, is incorrectly set.
Action: Verify default line printer command and ORACLE_LPPROG are set correctly. Set ORACLE_LPPROG to working line printer spooler.
ORA-07222: slspool: line printer spooler command exited with an error.
Cause: The line printer spooler exited with a non-zero return value. This probably indicates an error in spooling file.
Action: Verify that line printer spooler is up. Verify that ORACLE_LPPROG, and ORACLE_LPARG are set properly. Check exit value returned as additional informatin.
ORA-07223: slspool: fork error, unable to spawn spool process.
Cause: Fork system call failed to create additional process. Probable resource limit reached.
Action: Check additional information returned. Retry operation. Contact system administrator.
ORA-07224: sfnfy: failed to obtain file size limit; errno = string.
Cause: The ulimit system call returned an error.
Action: Check errno and contact customer support.
ORA-07225: sldext: translation error, unable to expand file name.
Cause: Additional information returned is error returned from sltln.
Action: Check additional information.
ORA-07226: rtneco: unable to get terminal mode.
Cause: The ioctl call returned an error. Possible OS error.
Action: Check additional information for errno. Contact customer support.
ORA-07227: rtneco: unable to set noecho mode.
Cause: The ioctl call returned an error. Possible OS error.
Action: Check additional information for errno. Contact customer support.
ORA-07228: rtecho: unable to restore terminal to echo mode.
Cause: The ioctl call returned an error. Possible OS error.
Action: Check additional information for errno. Contact customer support.
ORA-07229: slcpuc: error in getting number of CPUs.
Cause: error in mpcntl system call
Action: check errno and contact system administrator
ORA-07230: slemcr: fopen error, unable to open error file.
Cause: Fopen failed to open file.
Action: Try to determine which file was not opened. Check that file exists and is accessible.
ORA-07231: slemcc: invalid file handle, seals do not match.
Cause: Function was called with an invalid argument. The file handle used was not obtained be slemcr.
Action: Internal error. Contact customer support.
ORA-07232: slemcc: fclose error.
Cause: An error was encountered when closing the file. Possible OS error.
Action: Contact system administator.
ORA-07233: slemcw: invalid file handle, seals do not match.
Cause: Function was called with an invalid file handle. File handle was not obtained by slemcr.
Action: Internal error. Contact customer support.
ORA-07234: slemcw: fseek error.
Cause: Unable to seek to desired position in file. Possible OS error. Possible internal error.
Action: Verify that error message file is intact. Try to regenerate error message file. Contact customer support.
ORA-07235: slemcw: fwrite error.
Cause: Unable to write item to file. Possible OS error. Possible permissions problem.
Action: Retry operation.
ORA-07236: slemop: open error.
Cause: Unable to open error file. Possible permissions problem.
Action: Verify permission on error message file. Check additional information for errno.
ORA-07237: slemcl: invalid file handle, seals do not match.
Cause: Function was called with an invalid file handle. Handle was not obtained by previous call to slemop.
Action: Internal error.
ORA-07238: slemcl: close error.
Cause: Unable to close file. Possible OS error.
Action: Contact system administator. Check additional information for errno.
ORA-07239: slemrd: invalid file handle, seals do not match.
Cause: Function was called with invalid file handle. Handle was not obtained by call to slemop.
Action: Internal error. Contact customer support.
ORA-07240: slemrd: seek error.
Cause: Unable to seek to desired position in file. Possible OS error.
Action: Check that error file is still intact. Verify space on device. Contact system administrator. Check additional information for errno.
ORA-07241: slemrd: read error.
Cause: Unable to read file. Possible OS error.
Action: Verify that error file is intact. Regenerate error message file. Contact customer support. Check additional information for errno.
ORA-07242: slembfn: translation error, unable to translate error file name.
Cause: Additional information indicates error returned from sltln.
Action: Check additional information.
ORA-07243: supplied buffer not big enough to hold entire line
Cause: supplied buffer was not big enough
Action: Internal error. Contact customer support. Additional information indicates how big the supplied buffer was.
ORA-07244: ssfccf: create file failed, file size limit reached.
Cause: An attempt was made to create a file that exceeds the process's file size limit.
Action: Run osh to raise the file size limit.
ORA-07245: sfccf: unable to lseek and write the last block.
Cause: An attempt was made to move and write to a bad device address.
Action: Check errno. Possible lack of space on device.
ORA-07246: sfofi: open error, unable to open database file.
Cause: sfofi returns an error.
Action: This is an oracle internal error.
ORA-07247: skgfrfms, skgfrnms: read error, unable to read block from database file
Cause: The ioctl() system call returned an error doing VOL_READ_MIRRORS.
Action: Check errno.
ORA-07248: sfwfb: write error, unable to write database block.
Cause: sfwfb returns an error.
Action: This is an oracle internal error.
ORA-07249: slsget: open error, unable to open /proc/pid.
Cause: The open() system call returned an error.
Action: Check that /proc has the right permissions.
ORA-07250: spcre: semget error, unable to get first semaphore set.
Cause: An error occurred when trying to get first semaphore set.
Action: Check errno. Verify that system is configured to have semaphores. Verify that enough semaphores are available. Additional information indicates how many semaphores were requested.
ORA-07251: spcre: semget error, could not allocate any semaphores.
Cause: Semget failed to even allocate a single semaphore. Either they are all in use or the system is not configured to have any semaphores.
Action: Check to see if all semaphores are in use. Check to see if system is configured to have semaphores. Check errno.
ORA-07252: spcre: semget error, could not allocate semaphores.
Cause: Semget system call returned an error. Possible resource limit problem.
Action: Check errno. Verify that enough semaphores are available in system. If additional errors occur in destroying the semaphore sets then sercose[0] will be non-zero. If this occurs, remove the semaphore sets using ipcrm.
ORA-07253: spdes: semctl error, unable to destroy semaphore set.
Cause: Semctl system call returned an error.
Action: Check semaphore sets. May require manual cleanup. Check additional information returned. Consult OS reference manual.
ORA-07254: spdcr: translation error while expanding ?/bin/oracle.
Cause: An error occurred while translating the name of the oracle executable.
Action: Check sercose[0] for error returned from sltln. Perhaps $(ORACLE_HOME) is not set correctly.
ORA-07255: spini: cannot set up signal handler.
Cause: System failed to set up signal handler.
Action: Check errno and sercose[0] for the signal number that failed.
ORA-07256: sptrap: cannot set up signal handler to catch exceptions.
Cause: System failed to set up signal handler to catch exceptions.
Action: Check errno and sercose[0] for the signal number that failed.
ORA-07257: spdcr: translation error expanding program name.
Cause: Error ocurred when expanding program name ora_PNAME_@. The result of this translation is put in argv[0] of oracle process.
Action: Check error returned by sltln returned in sercose[0].
ORA-07258: spdcr: fork error, unable to create process.
Cause: An error occurred when creating a new process.
Action: Check errno. Perhaps a system limit on the number of processes has been exceeded.
ORA-07259: spdcr: exec error, detached process failed in startup.
Cause: An oracle detached process died shortly after startup. Wait() indicated that a child process terminated.
Action: Check ?/dbs directory for trace or core files. Check errno.
ORA-07260: spdcr: wait error.
Cause: Wait system call returned an error.
Action: Check errno.
ORA-07261: spdde: kill error, unable to send signal to process.
Cause: Kill system call returned an error. Possibly an attempt to destroy an already gone process.
Action: Check errno.
ORA-07262: sptpa: sptpa called with invalid process id.
Cause: This is an internal error.
Action: This is an oracle internal error.
ORA-07263: sptpa: kill error.
Cause: Kill system call returned an error. Possible OS error.
Action: Check errno. Additional information indicates the process ID tested.
ORA-07264: spwat: semop error, unable to decrement semaphore.
Cause: Semop system call returned an error. Semaphore set may not exist.
Action: Check errno. Semaphore ID is returned in sercose[0]. Verify semaphore set exists. A possible cause for this error is that a "shutdown abort" was done while this process was running.
ORA-07265: sppst: semop error, unable to increment semaphore.
Cause: Semop system call returned an error. Semaphore set may not exist.
Action: Check errno. Semaphore ID is returned in sercose[0]. Check semaphore set existence. A possible cause for this error is that a "shutdown abort" was done while this process was running.
ORA-07266: sppst: invalid process number passed to sppst.
Cause: Function was passed an invalid oracle process id.
Action: Internal error.
ORA-07267: spwat: invalid process number.
Cause: Function was passed an invalid oracle process id.
Action: Internal error. Additional information indicates the invalid process id.
ORA-07268: szguns: getpwuid error.
Cause: Getpwuid() could not find an entry in the passwd file for a user.
Action: Add an entry for the user in the passwd file.
ORA-07269: spdcr: detached process died after exec.
Cause: Detached process succesfully execed, but died shortly thereafter. Additional information indicates exit code, and termination status.
Action: Check termination code for information as to why process exited. Check for core dump or trace file.
ORA-07270: spalck: setitimer error, unable to set interval timer.
Cause: An error occurred while trying to set an interval timer. Probable porting problem.
Action: Check errno.
ORA-07271: spwat: invalid oracle process number.
Cause: Function was called with an invalid oracle process number (0).
Action: Internal oracle error.
ORA-07272: spwat: invalid semaphore set id.
Cause: Semaphore ID fetched from SGA was not initialized to valid value. Additional information returned is semaphore set index, and oracle process number.
Action: Oracle internal error. Check semaphore set index. Check oracle process number.
ORA-07273: sppst: invalid semaphore id.
Cause: Semaphore ID fetched from SGA contained an invalid value. Additional information returned is semaphore set index, and oracle process number.
Action: Oracle internal error. Check semaphore set index. Check oracle process number.
ORA-07274: spdcr: access error, access to oracle denied.
Cause: Unable to access "oracle" program. Verify ?/bin/oracle or $ORABCKPRG exist, and are executable.
Action: Check errno returned.
ORA-07275: unable to send signal to process
Cause: The kill system call returned an error. Possibly an attempt to signal a process which does not exist.
Action: Check errno.
ORA-07276: no dba group in /etc/group.
Cause: A group has not been set up for dba users.
Action: Contact system administrator. Set up dba group in /etc/group.
ORA-07277: spdde: illegal pid passed as argument.
Cause: A 0 pid was passed to spdde.
Action: Internal error. .
ORA-07278: splon: ops$username exceeds buffer length.
Cause: Splon constructed an ops$username logon which exceeded the alloted buffer space.
Action: Use a shorter Unix username, or use an oracle username. Contact customer support.
ORA-07279: spcre: semget error, unable to get first semaphore set.
Cause: An error occurred when trying to get first semaphore set.
Action: Check errno. Verify that system is configured to have semaphores. Verify that enough semaphores are available. Additional information indicates how many semaphores were requested.
ORA-07280: slsget: unable to get process information.
Cause: The ioctl call returned an error. Possible OS error.
Action: Check additional information for errno. Contact customer support.
ORA-07281: slsget: times error, unable to get cpu time.
Cause: times system call returned an error. Possible OS error.
Action: Check additional information returned. Contact customer support.
ORA-07282: sksaprd: string overflow.
Cause: The internal buffer is not big enough to hold the archive control string.
Action: Internal restriction. Try a shorter archive control string.
ORA-07283: sksaprd: invalid volume size for archive destination.
Cause: An invalid volume size was specified.
Action: Specify a valid volume size in archive control string.
ORA-07284: sksaprd: volume size specification not terminated properly.
Cause: Some non-numeric text follows the volume size specification.
Action: Enter a correct archive control string.
ORA-07285: sksaprd: volume size should not be specified for a disk file.
Cause: Volume size was specified for a disk file.
Action: If you are archiving to a disk file, do not specify its volume size.
ORA-07286: sksagdi: cannot obtain device information.
Cause: Stat on the log archiving device failed.
Action: Check the returned OSD error for the reason of failure.
ORA-07287: sksagdi: unsupported device for log archiving.
Cause: Log archiving to this device is unsupported.
Action: Try log archiving to a supported device.
ORA-07290: sksagdi: specified directory for archiving does not exist.
Cause: The specified pathname is not a directory.
Action: Verify that the archive destination directory exists.
ORA-07303: ksmcsg: illegal database buffer size.
Cause: The database buffer size must be a multiple of the database block size, and less than the maximum block size.
Action: Verify that the db_block_size parameter is correct in INIT.ORA.
ORA-07304: ksmcsg: illegal redo buffer size.
Cause: The redo buffer size must be a multiple of machine block size.
Action: Verify that the log_buffer INIT.ORA parameter is correctly set.
ORA-07305: ksmcsg: illegal database buffer size.
Cause: The database buffer size must be a multiple of the extended cache mapping size for indirect data buffers to be used.
Action: Verify that the db_block_size parameter is correct in INIT.ORA, or disable the use_indirect_data_buffers parameter.
ORA-07324: smpall: malloc error while allocating pga.
Cause: Malloc library routine returned an error.
Action: Check errno. Possibly out of swap space.
ORA-07327: smpdal: attempt to destroy pga when it was not mapped.
Cause: Smpdal was called when the PGA had not been previously created.
Action: Internal error.
ORA-07339: spcre: maximum number of semaphore sets exceeded.
Cause: The internal buffer is not big enough to hold the number of semaphore set identifiers requested.
Action: Reconfigure OS to have more semaphores per set.
ORA-07345: The datafile name must not contain the string '..'.
Cause: The specified datafile name contains '..'.
Action: Correct the datafile name and retry the operation.
ORA-07346: slnrm: normalized file name is too long
Cause: After normalizing the specified file name, the resulting file name was too long.
Action: Specify the shorter file name and retry the operation.
ORA-07390: sftopn: translate error, unable to translate file name.
Cause: An error occurred while expanding the file name to open. Additional information returns error generated in translation routine.
Action: Lookup additional error code for further information.
ORA-07391: sftopn: fopen error, unable to open text file.
Cause: Fopen library routine returned an error.
Action: Verify existence and permissions.
ORA-07392: sftcls: fclose error, unable to close text file.
Cause: Fclose library routine returned an error.
Action: Possible internal oracle error.
ORA-07393: unable to delete text file
Cause: An error occurred while deleting a text file.
Action: Verify that the file exists and check additional errors.
ORA-07394: unable to append string to text file
Cause: An error occurred while performing a string put operation.
Action: This is an internal error. Check additional information.
ORA-07400: slemtr: translated name for the message file is too long.
Cause: The name for the message file overflows internal buffer.
Action: Try making the complete path-name of the message file shorter by reorganizing the directory hierarchy.
ORA-07401: sptrap: cannot restore user exception handlers.
Cause: The system failed to restore user exception handlers.
Action: Check errno and sercose[0] for the signal number that failed.
ORA-07402: sprst: cannot restore user signal handler.
Cause: The system failed to restore user signal handlers.
Action: Check errno and sercose[0] for the signal number that failed.
ORA-07403: sfanfy: db_writers parameter not valid.
Cause: The db_writers parameter in INIT.ORA exceeds the system-dependent maximum or is less than 0.
Action: Change the db_writers parameter in INIT.ORA.
ORA-07404: sfareq: Timeout occurred waiting for request to complete.
Cause: The master database writer timed out waiting for a write or close to complete. One of the database writers may have stopped running.
Action: Check all database writer trace files. Shut down the database and try to warm start.
ORA-07406: slbtpd: invalid number.
Cause: An impossible request for binary to decimal conversion was made.
Action: This conversion cannot be performed.
ORA-07407: slbtpd: invalid exponent.
Cause: An impossible request for binary to decimal conversion was made
Action: This conversion cannot be performed.
ORA-07408: slbtpd: overflow while converting to packed decimal.
Cause: An impossible request for binary to decimal conversion was made.
Action: This conversion cannot be performed.
ORA-07409: slpdtb: invalid packed decimal nibble.
Cause: An impossible request for decimal to binary conversion was made.
Action: This conversion cannot be performed.
ORA-07410: slpdtb: number too large for supplied buffer.
Cause: An impossible request for decimal to binary conversion was made.
Action: This conversion cannot be performed.
ORA-07411: slgfn: full path name too big for supplied buffer.
Cause: The supplied buffer is not big enough to hold the full path name.
Action: The construction of the full path name cannot be performed.
ORA-07412: sfaslv: Error getting entry in asynchronous write array.
Cause: One of the database writer processes could not locate its entry in the SGA.
Action: Contact customer support.
ORA-07415: slpath: allocation of memory buffer failed.
Cause: Malloc() failed to allocate buffer for storing ORACLE_PATH.
Action: System has run out of heap space. Additional information indicates errno.
ORA-07416: slpath: pathname construction failed; lack of output buffer space.
Cause: The slpath routine is given a maximum length buffer to expand the name into. An overflow of this buffer occurred.
Action: Possible internal error. Check output buffer length stored in sercose[0] and constructed pathname length in sercose[1].
ORA-07417: sfareq: One or more database writers not active.
Cause: One or more of the database writer processes is no longer running.
Action: Check the trace files for the database writers. Shut down the database and try to warm start.
ORA-07418: sfareq: Database writer got error in timing function.
Cause: An error occurred when the database writer called the system timing function.
Action: Check the database writer trace file. Shut down database and try to warm start.
ORA-07419: sfareq: Database writer got error in timing function.
Cause: An error occurred when the database writer called the system timing function.
Action: Check the database writer trace file. Shut down database and try to warm start.
ORA-07425: sdpri: error string in translating dump file location.
Cause: An oracle error occurred when translating the location of the dump file.
Action: Check the oracle error code.
ORA-07426: spstp: cannot obtain the location of dbs directory.
Cause: An oracle error occurred when translating the location of the dbs directory.
Action: Check additional information for the error returned from sltln.
ORA-07427: spstp: cannot change directory to dbs.
Cause: Chdir system call returned an error. Possible permission problems.
Action: Check additional information for the OS error code.
ORA-07431: fork failed
Cause: The server process was unable to fork a child process.
Action: Verify that there are enough system resources to support another process. The user or system process limit may have been exceeded, or the amount of free memory or swap space may be temporarily insufficient.
ORA-07432: unable to perform nested sleep
Cause: An attempt was made to make a process sleep when it was already sleeping. This platform does not support this capability.
Action: Try the SLEEP command when the process is not sleeping.
ORA-07440: WMON process terminated with error
Cause: The wakeup monitor process died.
Action: Warm start instance.
ORA-07441: function address must be aligned on string byte boundary
Cause: An improperly aligned function address was specified.
Action: Use a properly aligned function address.
ORA-07442: function address must be in the range string to string
Cause: An invalid function address was specified.
Action: Use a valid function address.
ORA-07443: function string not found
Cause: An invalid function name was specified.
Action: Use a valid function name.
ORA-07444: function address string is not readable
Cause: An invalid function name/address was specified.
Action: Use a valid function name/address.
ORA-07445: exception encountered: core dump [string] [string] [string] [string] [string] [string]
Cause: An OS exception occurred which should result in the creation of a core file. This is an internal error.
Action: Contact your customer support representative.
ORA-07446: sdnfy: bad value 'string' for parameter string.
Cause: The directory specified as the value for the stated parameter could not be used.
Action: Make sure the directory you have specified is a valid directory/file specification.
ORA-07447: ssarena: usinit failed.
Cause: Oracle failed to create a shared arena file.
Action: Use sercerrno field to determine cause of failure.
ORA-07448: ssarena: maximum number of shared arenas exceeded.
Cause: Oracle attempted to create more shared arena files than permitted.
Action: Raise the value for max_arena in INIT.ORA.
ORA-07449: sc: usnewlock failed.
Cause: Oracle failed to acquire a shared arena lock.
Action: Check result code in sercerrno to determine the cause of failure.
ORA-07451: slskstat: unable to obtain load information.
Cause: kstat library returned an error. Possible OS failure
Action: Check result code in sercose[0] for more information.
ORA-07452: specified resource manager plan does not exist in the data dictionary
Cause: User tried to load a resource manager plan that does not exist.
Action: Use a resource manager plan that exists in the data dictionary.
ORA-07453: requested resource manager plan schema does not contain OTHER_GROUPS
Cause: User tried to load a resource manager plan schema that does not contain the OTHER_GROUPS group.
Action: Use a resource manager plan schema that contains the OTHER_GROUPS group.
ORA-07454: queue timeout, string second(s), exceeded
Cause: User session queued for longer than maximum specified queue queue duration time for consumer group.
Action: Re-submit job at a later time or increase queue timeout.
ORA-07455: estimated execution time (string secs), exceeds limit (string secs)
Cause: User attempted to execute an operation whose estimated execution time exceeds the limit specified for the consumer group.
Action: Execute job on behalf of another group, or increase limit.
ORA-07456: cannot set RESOURCE_MANAGER_PLAN when database is closed
Cause: An attempt was made to turn on the Resource Manager when the database was closed.
Action: Open the database and try again.
ORA-07457: cannot set _INTERNAL_RESOURCE_MANAGER_PLAN because of FORCE
Cause: An attempt was made to set the _INTERNAL_RESOURCE_MANAGER_PLAN parameter, however this failed because the current RESOURCE_MANAGER_PLAN has the FORCE prefix.
Action: Remove the FORCE prefix from the RESOURCE_MANAGER_PLAN parameter.
ORA-07468: spwat: mset error, unable to set semaphore.
Cause: The mset routine returned an error. Semaphore may not exist.
Action: Check result code in sercerrno. Semaphore number returned in sercose[0].
ORA-07469: sppst: mclear error, unable to clear semaphore.
Cause: The mclear routine returned an error. Semaphore may not exist.
Action: Check result code in sercerrno. Semaphore number returned in sercose[0].
ORA-07470: snclget: cannot get cluster number.
Cause: The cluster_status system call failed to get status information for the current cluster.
Action: Check result code in sercose[0]. Possible operating system failure.
ORA-07471: snclrd: name translation error of sgadef.dbf file name.
Cause: Unable to expand out ?/dbs/sgadef@.dbf file name.
Action: Verify $(ORACLE_HOME) and $(ORACLE_SID) are properly set. Check error number returned from sltln in sercose[0].
ORA-07472: snclrd: open error when opening sgadef.dbf file.
Cause: open failed when opening the file ?/dbs/sgadef@.dbf
Action: Check errno. Possible permission problem. Verify that the file ?/dbs/sgadef@.dbf exists.
ORA-07473: snclrd: read error when trying to read sgadef.dbf file.
Cause: Read had an error when reading sgadef.dbf file.
Action: Check errno. Verify file exists, and is correct size.
ORA-07474: snclrd: close error, unable to close sgadef.dbf file.
Cause: An error occurred in close, while closing the file "?/dbs/sgadef@.dbf"
Action: Check errno. Possible operating system error.
ORA-07475: slsget: cannot get vm statistics.
Cause: The vm_statistics system call failed to get virtual memory statistics.
Action: Check result code in sercerrno. Possible operating system failure.
ORA-07476: slsget: cannot get mapped memory statistics.
Cause: The vm_mapmem system call failed to get mapped memory statistics.
Action: Check result code in sercerrno. Possible operating system failure.
ORA-07477: scgcmn: lock manager not initialized.
Cause: Lock manager must be initialized before converting locks.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07478: scgcmn: cannot get lock status.
Cause: lm_stat_lock failed.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07479: scgcmn: cannot open or convert lock.
Cause: lm_open or lm_open_convert failed.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07480: snchmod: cannot change permissions on ?/dbs/sgalm.dbf.
Cause: When creating an instance, snlmini could not change the permissions on ?/dbs/sgalm.dbf
Action: Contact your customer support representative.
ORA-07481: snlmatt: cannot attach to lock manager instance.
Cause: lm_attach failed to attach to lock manager instance.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07482: snlmini: cannot create lock manager instance.
Cause: lm_create failed to create lock manager instance.
Action: Check permissions on ?/dbs, and remove ?/dbs/sgalm.dbf if it exists, then retry.
ORA-07483: snlkget: cannot convert(get) lock.
Cause: lm_convert failed to convert(get) lock.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07484: snlkput: cannot convert(put) lock.
Cause: lm_convert failed to put lock value.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07485: scg_get_inst: cannot open instance number lock.
Cause: lm_open failed.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07486: scg_get_inst: cannot convert(get) instance number lock.
Cause: lm_convert failed to get lock value.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07487: scg_init_lm: cannot create lock manager instance.
Cause: lm_create failed.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07488: scgrcl: lock manager not initialized.
Cause: Lock manager must be initialized before releasing locks.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07489: scgrcl: cannot get lock status.
Cause: lm_stat_lock failed during lock release/cancel.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07490: scgrcl: cannot convert lock.
Cause: lm_convert failed during lock release/cancel.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07491: scgrcl: cannot cancel lock request.
Cause: lm_cancel failed during lock release/cancel.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07492: scgrcl: cannot close lock.
Cause: lm_close failed during lock release/cancel.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07493: scgrcl: lock manager error.
Cause: An error was encountered releasing the lock.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07494: scgcm: unexpected error.
Cause: Unknown or unexpected error code.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07495: spwat: lm_wait failed.
Cause: lm_wait failed.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07496: sppst: lm_post failed.
Cause: lm_post failed.
Action: Check result code in sercerrno. Possible lock manager failure.
ORA-07497: sdpri: cannot create trace file 'string'; errno = string.
Cause: 1. The trace file could not be created for writing.

2. The trace file is a symbolic link.

Action: 1. Check if the dump directory exists and whether it is writable.

2. Remove the symbolic link.

ORA-07498: spstp: Unable to open /dev/resched.
Cause: The rescheduling driver /dev/resched is not found or is not working properly.
Action: Check installation of the ORACLE rescheduling driver in the AIX kernel.
ORA-07499: spglk: Cannot reschedule.
Cause: The rescheduling driver /dev/resched is not open. This is an internal error and should not occur.
Action: Contact your customer support representative.


7 ORA-07500 to ORA-09859

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

7 ORA-07500 to ORA-09859

ORA-07500: scglaa: $cantim unexpected return
Cause: VMS system service $CANTIM returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07501: scgtoa: $deq unexpected return
Cause: VMS system service $DEQ returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07502: scgcmn: $enq unexpected return
Cause: VMS system service $ENQ returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07503: scgcmn: $setimr unexpected return
Cause: VMS system service $SETIMR returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07504: scgcmn: $hiber unexpected return
Cause: VMS system service $HIBER returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07505: scggt: $enq parent lock unexpected return
Cause: VMS system service $ENQ returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07506: scgrl: $deq unexpected return on lockid string
Cause: VMS system service $DEQ returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07507: scgcm: unexpected lock status condition
Cause: A global locking system service returned an unexpected value.
Action: Check for system error message (if any) and refer to VMS documentation, or contact your customer support representative.
ORA-07508: scgfal: $deq all unexpected return
Cause: VMS system service $DEQ returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07509: scgfal: $deq parent lock unexpected return
Cause: VMS system service $DEQ returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07510: scgbrm: $getlki unexpected return on lockid string
Cause: VMS system service $GETLKI returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07511: sscggtl: $enq unexpected return for master termination lock
Cause: VMS system service $ENQ returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07512: sscggtl: $enq unexpected return for client termination lock
Cause: VMS system service $ENQ returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07513: sscgctl: $deq unexpected return on cancel of term. lock
Cause: VMS system service $DEQ returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07514: scgcan: $deq unexpected return while canceling lock
Cause: VMS system service $DEQ returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07534: scginq: $getlki unexpected return on lockid string
Cause: VMS system service $GETLKI returned an unexpected value
Action: Check for system error message and refer to VMS documentation
ORA-07548: sftopn: Maximum number of files already open
Cause: Too many test files open
Action: This is an internal error, please report to Oracle
ORA-07549: sftopn: $OPEN failure
Cause: VMS system service $OPEN failed
Action: Examine system error message and refer to VMS documentation
ORA-07550: sftopn: $CONNECT failure
Cause: VMS system service $OPEN failed
Action: Examine system error message and refer to VMS documentation
ORA-07551: sftcls: $CLOSE failure
Cause: VMS system service $CLOSE failed
Action: Examine system error message and refer to VMS documentation
ORA-07552: sftget: $GET failure
Cause: VMS system service $GET failed
Action: Examine system error message and refer to VMS documentation
ORA-07561: szprv: $IDTOASC failure
Cause: VMS system service $IDTOASC failed
Action: Examine system error message and refer to VMS documentation
ORA-07562: sldext: extension must be 3 characters
Cause: An extension was found but it is of improper length
Action: This is an internal error, please report to Oracle
ORA-07563: sldext: $PARSE failure
Cause: VMS system service $PARSE failed
Action: Examine system error message and refer to VMS documentation
ORA-07564: sldext: wildcard in filename or extension
Cause: A wildcard was used in the file name
Action: Reenter the file name completely
ORA-07565: sldext: $SEARCH failure
Cause: VMS system service $SEARCH failed
Action: Examine system error message and refer to VMS documentation
ORA-07568: slspool: $OPEN failure
Cause: VMS system service $OPEN failed
Action: Examine system error message and refer to VMS documentation
ORA-07569: slspool: $CLOSE failure
Cause: VMS system service $CLOSE failed
Action: Examine system error message and refer to VMS documentation
ORA-07570: szrfc: $IDTOASC failure
Cause: VMS system service $IDTOASC failed
Action: Examine system error message and refer to VMS documentation
ORA-07571: szrfc: $FIND_HELD failure
Cause: VMS system service $FIND_HELD failed
Action: Examine system error message and refer to VMS documentation
ORA-07572: szrfc: insufficient rolename buffer space
Cause: An OS role name was too long.
Action: Re-define the role name to be of correct length.
ORA-07573: slkhst: could not perform host operation
Cause: VMS system service LIB$SPAWN failed
Action: Examine system error message and refer to VMS documentation
ORA-07574: szrfc: $GETUAI failure
Cause: VMS system service $GETUAI failed
Action: Examine system error message and refer to VMS documentation
ORA-07576: sspexst: $GETJPIW failure on process ID string
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07577: no such user in authorization file
Cause: An attempt was made to set an INTERNAL password (for either DBA or OPER privilege), but the corresponding VMS account (either ORA_<sid>_DBA or ORA_<sid>_OPER) hasn't been created yet.
Action: Add a VMS account for ORA_<sid>_DBA and/or ORA_<sid>_OPER before trying to set a password for them.
ORA-07578: szprv: $FIND_HELD failure
Cause: VMS system service $FIND_HELD failed
Action: Examine system error message and refer to VMS documentation
ORA-07579: spini: $DCLEXH failure
Cause: VMS system service $PARSE failed
Action: Examine system error message and refer to VMS documentation
ORA-07580: spstp: $GETJPIW failure
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07581: spstp: cannot derive SID from unexpected process name
Cause: A background process did not have name of correct form
Action: If the job name was changed, restore it, otherwise this is an internal error, please report to Oracle.
ORA-07582: spstp: ORA_SID has illegal value
Cause: The ORA_SID must exist and be less than 6 characters
Action: Consult the VMS Installation guide for information on setting the SID.
ORA-07584: spdcr: invalid value for ORA_sid_(proc_)PQL$_item
Cause: A logical name used to set a detached process quota value has an invalid value (probably non-numeric).
Action: Examine the values of these logical names, correct the one in error, and retry.
ORA-07585: spdcr: $PARSE failure
Cause: VMS system service $PARSE failed
Action: Examine system error message and refer to VMS documentation
ORA-07586: spdcr: $SEARCH failure
Cause: VMS system service $SEARCH failed
Action: Examine system error message and refer to VMS documentation
ORA-07587: spdcr: $CREPRC failure
Cause: VMS system service $CREPRC failed
Action: Examine system error message and refer to VMS documentation
ORA-07588: spdcr: $GETJPIW get image name failure
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07589: spdde: system ID not set
Cause: The logical name ORA_SID doesn't translate to a valid value.
Action: Check the value of ORA_SID in the process that gets the error, and correct the installation or command procedures that caused ORA_SID to be set incorrectly.
ORA-07590: spdde: $DELPRC failure
Cause: VMS system service $DELPRC failed
Action: Examine system error message and refer to VMS documentation
ORA-07591: spdde: $GETJPIW failure
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07592: sspgprv: Error obtaining required privileges
Cause: While obtaining needed privileges, an error was returned from SYS$SETPRV.
Action: This is an internal error. Please report to Oracle
ORA-07593: ssprprv: Error release privileges
Cause: While releasing privileges, an error was returned from SYS$SETPRV.
Action: This is an internal error. Please report to Oracle
ORA-07594: spiip: $GETJPIW failure
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07595: sppid: $GETJPIW failure
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07596: sptpa: $GETJPIW failure
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07597: spguns: $GETJPIW failure
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07598: spwat: $SETIMR failure
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07599: spwat: $SCHDWK failure
Cause: VMS system service $SCHDWK failed
Action: Examine system error message and refer to VMS documentation
ORA-07600: slkmnm: $GETSYIW failure
Cause: VMS system service $GETSYIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07601: spguno: $GETJPIW failure
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07602: spgto: $GETJPIW failure
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07605: szprv: $ASCTOID failure
Cause: VMS system service $ASCTOID failed
Action: Examine system error message and refer to VMS documentation
ORA-07606: szprv: $CHKPRO failure
Cause: VMS system service $CHKPRO failed
Action: Examine system error message and refer to VMS documentation
ORA-07607: szaud: $SNDOPR failure
Cause: VMS system service $SNDOPR failed
Action: Examine system error message and refer to VMS documentation
ORA-07608: szprv: $GETUAI failure
Cause: VMS system service $GETUAI failed
Action: Examine system error message and refer to VMS documentation
ORA-07609: szprv: $HASH_PASSWORD failure
Cause: VMS system service $HASH_PASSWORD failed
Action: Examine system error message and refer to VMS documentation
ORA-07610: $GETJPIW failed in retrieving the user's MAC priviledges
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07612: $GETUAI failed in retrieving the user's clearance level
Cause: VMS system service $GETUAI failed
Action: Examine system error message and refer to VMS documentation
ORA-07613: $GETJPIW failed in retrieving the user's process label
Cause: VMS system service $GETJPIW failed
Action: Examine system error message and refer to VMS documentation
ORA-07614: $CHANGE_CLASS failed in retrieving the user's process label
Cause: VMS system service $CHANGE_CLASS failed
Action: Examine system error message and refer to SEVMS documentation
ORA-07615: $CHANGE_CLASS failed in retrieving the specified file label
Cause: VMS system service $CHANGE_CLASSS failed
Action: Examine system error message and refer to SEVMS documentation
ORA-07616: $CHANGE_CLASS failed in retrieving the specified device label
Cause: VMS system service $CHANGE_CLASS failed
Action: Examine system error message and refer to SEVMS documentation
ORA-07617: $FORMAT_CLASS failed translating the binary label to a string
Cause: VMS system service $FORMAT_CLASS failed because the given binary classification was not valid.
Action: Examine system error message and refer to SEVMS documentation
ORA-07618: $IDTOASC failed translating a secrecy level
Cause: VMS system service $IDTOASC failed while looking up the string representation in the rights database of a secrecy level.
Action: Define the entry in the rights database which the binary label you specified references.
ORA-07619: $IDTOASC failed translating an integrity level
Cause: VMS system service $IDTOASC failed while looking up the string representation in the rights database of an integrity level.
Action: Define the entry in the rights database which the binary label you specified references.
ORA-07620: smscre: illegal database block size
Cause: An illegal database block size was specified in the parameter file. It must be positive, a multiple of 512, and less than the maximum physical i/o data size.
Action: Change db_block_size in the parameter file to conform to these limits.
ORA-07621: smscre: illegal redo block size
Cause: An illegal redo log buffer size was specified in the parameter file. It must be positive and a multiple of 512.
Action: Change log_buffer in the parameter file to conform to these limits.
ORA-07622: smscre: $CREATE failure
Cause: While creating the system global area (SGA) backing file, VMS system service $CREATE failed.
Action: Examine the system error message and refer to VMS documentation.
ORA-07623: smscre: $CRMPSC failure
Cause: While creating the system global area (SGA), VMS system service $CRMPSC failed.
Action: Examine the system error message and refer to VMS documentation.
ORA-07624: smsdes: $DGBLSC failure
Cause: While deleting the system global area (SGA), VMS system service $DGBLSC failed.
Action: Examine the system error message and refer to VMS documentation.
ORA-07625: smsget: $MGBLSC failure
Cause: While mapping the system global area (SGA) during logon, VMS system service $MGBLSC failed. The usual reason is that ORACLE has not been started up.
Action: Examine the system error message and refer to VMS documentation. Start up ORACLE if it is not already started.
ORA-07626: smsget: sga already mapped
Cause: An attempt to map the SGA during logon failed because it was already mapped. This is an internal error.
Action: Exit your program and try again, and report this to your customer support representative.
ORA-07627: smsfre: $CRETVA failure
Cause: While unmapping the system global area (SGA) during logoff, VMS system service $CRETVA failed.
Action: Examine the system error message and refer to VMS documentation.
ORA-07628: smsfre: sga not mapped
Cause: An attempt to unmap the SGA during logoff failed because it was not mapped. This is an internal error.
Action: Exit your program and try again, and report this to your customer support representative.
ORA-07629: smpall: $EXPREG failure
Cause: While extending the program global area (PGA), VMS system service $EXPREG failed. This often happens when the virtual memory page count quota is exceeded.
Action: Examine the system error message and refer to VMS documentation.
ORA-07630: smpdal: $DELTVA failure
Cause: While deleting the program global area (PGA) during logoff, VMS system service $DELTVA failed.
Action: Examine the system error message and refer to VMS documentation.
ORA-07631: smcacx: $EXPREG failure
Cause: While creating or extending a context area, VMS system service $EXPREG failed. This often happens when the virtual memory page count quota is exceeded.
Action: Examine the system error message and refer to VMS documentation.
ORA-07632: smsrcx: $DELTVA failure
Cause: While deleting a context area, VMS system service $DELTVA failed.
Action: Examine the system error message and refer to VMS documentation.
ORA-07633: smsdbp: illegal protection value
Cause: The buffer debug function was called with an illegal value. This is an internal error.
Action: Contact your customer support representative.
ORA-07634: smsdbp: $CRETVA failure
Cause: While attempting to set protection in the database buffer debug mechanism, VMS system service $CRETVA failed.
Action: Contact your customer support representative.
ORA-07635: smsdbp: $SETPRT failure
Cause: While attempting to set protection in the database buffer debug mechanism, VMS system service $SETPRT failed.
Action: Contact your customer support representative.
ORA-07636: smsdbp: $MGBLSC failure
Cause: While attempting to set protection in the database buffer debug mechanism, VMS system service $MGBLSC failed.
Action: Contact your customer support representative.
ORA-07637: smsdbp: buffer protect option not specified when sga created
Cause: Trying to change the buffer protect mode when the SGA was not created with buffer protect debug option. This is an internal error.
Action: Contact your customer support representative.
ORA-07638: smsget: SGA pad area not large enough for created SGA
Cause: An attempt was made to map an SGA with software in which the SGA pad area isn't large enough.
Action: Create a smaller SGA, or relink the software with a larger pad.
ORA-07639: smscre: SGA pad area not large enough (string bytes required)
Cause: An attempt was made to create an SGA with software in which the SGA pad area isn't large enough.
Action: Create a smaller SGA, or relink the software with a larger pad.
ORA-07640: smsget: SGA not yet valid. Initialization in progress
Cause: An attempt was made to map to the SGA while it was being initialized.
Action: Wait until initialization is complete, and try again.
ORA-07641: smscre: Unable to use the system pagefile for the SGA
Cause: The system global area (SGA) backing file could not be allocated using the system pagefile because the system-wide limit on global pages has been exceeded.
Action: Either increase the VMS system parameter GBLPAGFIL or use a disk file as the SGA backing file.
ORA-07642: smprtset: $CMKRNL failure
Cause: While attempting to set the protection of a region of memory, an error was returned from the $CMKRNL system service.
Action: Examine the system error message and refer to VMS documentation.
ORA-07643: smsalo: SMSVAR is invalid
Cause: an internal error
Action: Report this error to ORACLE customer support, provide your INIT.ORA file.
ORA-07645: sszfsl: $CHANGE_CLASS failure
Cause: While attempting to set the label on a file, SEVMS service $CHANGE_CLASS failed.
Action: Examine the system message and refer to SEVMS system documentation.
ORA-07646: sszfck: $CREATE failure
Cause: While attempting to create a file, VMS system service $CREATE failed.
Action: Examine the system message and refer to VMS system documentation.
ORA-07647: sszfck: $OPEN failure
Cause: While attempting to reopen a file, VMS system service $OPEN failed.
Action: Examine the system message and refer to VMS system documentation.
ORA-07650: sigunc: $GETJPIW failure
Cause: While attempting to get the user's terminal device name, user name, user program name, or process name during logon, VMS system service $GETJPIW failed.
Action: Examine the system error message and refer to VMS documentation.
ORA-07655: slsprom:$TRNLOG failure
Cause: While attempting to translate SYS$INPUT during a prompt for a password, VMS system service $TRNLOG failed.
Action: Examine the system error message and refer to VMS documentation.
ORA-07656: slsprom:$GETDVI failure
Cause: While attempting to get device characteristics during a prompt for a password, VMS system service $GETDVI failed.
Action: Examine the system error message and refer to VMS documentation.
ORA-07657: slsprom:$ASSIGN failure
Cause: While prompting for a password, VMS system service $ASSIGN failed.
Action: Examine the system error message and refer to VMS documentation.
ORA-07658: slsprom:$QIOW read failure
Cause: While prompting for a password, VMS system service $QIOW failed.
Action: Examine the system error message and refer to VMS documentation.
ORA-07665: ssrexhd: recursive exception encountered string string string string string string
Cause: A VMS exception occurred while executing in the ORACLE exception handler. The message includes the signal number, first and second signal arguments, and exception PC, PSL and R0. This is an internal error.
Action: Contact your customer support representative.
ORA-07670: $IDTOASC failed translating a secrecy category
Cause: VMS system service $IDTOASC failed while looking up the string representation in the rights database of a secrecy category.
Action: Define the entry in the rights database which the binary label you specified references.
ORA-07671: $IDTOASC failed translating an integrity category
Cause: VMS system service $IDTOASC failed while looking up the string representation in the rights database of an integrity category.
Action: Define the entry in the rights database which the binary label you specified references.
ORA-07672: $PARSE_CLASS failed translating the string into a binary label
Cause: SEVMS system service $PARSE_CLASS failed because the given string did not represent a valid classification.
Action: Examine system error message and refer to SEVMS documentation.
ORA-07680: sou2os: another call to ORACLE currently executing
Cause: A call to the ORACLE shared image entry point occurred from within the shared image. This is an internal error.
Action: Contact your customer support representative.
ORA-07681: sou2os: An error occurred while initializing Oracle
Cause: While attempting to set up the dispatch vectors for the shared image, an error occurred. This is an internal error.
Action: Contact your customer support representative.
ORA-07682: sou2os: set kernel dispatch fail err
Cause: During ORACLE shared image entry, a dispatch to kernel mode failed.
Action: Make sure that your shared image is installed with the CMKRNL privilege, then contact your customer support representative.
ORA-07683: sou2os: $SETPRV reset error
Cause: During an attempt to restore user privileges at ORACLE shared image exit, VMS system service $SETPRV failed. This is an internal error.
Action: Contact your customer support representative.
ORA-07684: sou2os: supervisor stack reset error
Cause: During an attempt to restore the supervisor-mode stack at ORACLE shared image exit, VMS system service $SETSTK failed. This is an internal error.
Action: Contact your customer support representative.
ORA-07685: sou2os: supervisor stack set error
Cause: During an attempt to set the ORACLE supervisor-mode stack at ORACLE shared image entry, VMS system service $SETSTK failed. This is an internal error.
Action: Contact your customer support representative.
ORA-07700: sksarch: interrupt received
Cause: An interrupt was received while archiving the logs
Action: Retry operation
ORA-07701: sksatln: internal exception: output buffer too small
Cause: Overflow of buffer for parsing archive control text string
Action: This is an internal error, please report to Oracle
ORA-07702: unrecognized device type in archive text
Cause: Unrecognized device type in archive text
Action: This is an internal error, please report to Oracle
ORA-07703: error in archive text: need '/' after device type
Cause: The archive control text in the ARCHIVE command is invalid; the device type (to indicate a file or tape) must be followed by a '/'.
Action: Refer to the SQLDBA Guide for the proper syntax of the text.
ORA-07704: error in archive text: need ':' after device name
Cause: The archive control text in the ARCHIVE command is invalid; the device name must be followed by a ':'.
Action: Refer to the SQLDBA Guide for the proper syntax of the text.
ORA-07705: sksaprs: device name buffer too small
Cause: The buffer supplied for the device name is too small. This is an internal error.
Action: Contact your customer support representative.
ORA-07706: error in archive text: need disk file name
Cause: The archive control text in the ARCHIVE command is invalid; the disk file name is missing.
Action: Refer to the SQLDBA Guide for the proper syntax of the text.
ORA-07707: error in archive text: need tape label name
Cause: The archive control text in the ARCHIVE command is invalid; the tape label name is missing.
Action: Refer to the SQLDBA Guide for the proper syntax of the text.
ORA-07708: sksaprs: tape label name buffer too small
Cause: The buffer supplied for the tape label is too small. This is an internal error.
Action: Contact your customer support representative.
ORA-07709: sksaprs: archiving to a remote host is not allowed
Cause: The user specified a remote disk for archiving via DECnet.
Action: Archive to a disk on the local host.
ORA-07710: sksaprs: file name buffer too small
Cause: The buffer supplied for the file name is too small. This is an internal error.
Action: Contact your customer support representative.
ORA-07713: sksamtd: could not mount archival device (SYS$MOUNT failure)
Cause: VMS system service SYS$MOUNT failed
Action: Examine system error message and refer to VMS documentation
ORA-07715: sksadtd: could not dismount archival device (SYS$DISMNT failure)
Cause: VMS system service SYS$DISMNT failed
Action: Examine system error message and refer to VMS documentation
ORA-07716: sksachk: invalid device specification for ARCHIVE
Cause: VMS system service SYS$GETDVI failed"
Action: Specify a valid device in ARCHIVE control string
ORA-07717: sksaalo: error allocating memory
Cause: VMS system service LIB$GET_VM failed"
Action: Examine system error message and refer to VMS documentation
ORA-07718: sksafre: error freeing memory
Cause: VMS system service LIB$FREE_VM failed
Action: Examine system error message and refer to VMS documentation
ORA-07721: scgcm: not enough OS resource to obtain system enqueue
Cause: d by the messages SS$_EXENQLM or SS$_INSFMEM.
Action: Free up some of the required resource to allow the creation of the required lock.
ORA-07740: slemop: incorrect handle size (programming error)
Cause: structures used for reading error message files do not match
Action: this is an internal error, please report to Oracle
ORA-07741: slemop: $OPEN failure
Cause: VMS system service $OPEN failed
Action: Examine system error message and refer to VMS documentation
ORA-07742: slemop: $CONNECT failure
Cause: VMS system service $CONNECT failed
Action: Examine system error message and refer to VMS documentation
ORA-07743: slemop: incorrect error file attributes
Cause: An error message file is of incorrect format
Action: Unless an error file has been changed, report this to Oracle
ORA-07744: slemcl: invalid error message file handle
Cause: seal in passed in handle does not match correct value
Action: this is an internal error, please report to Oracle
ORA-07745: slemcl: $CLOSE failure
Cause: VMS system service $CLOSE failed
Action: Check system error and refer to VMS documentation
ORA-07746: slemrd: invalid error message file handle
Cause: seal in passed in handle does not match correct value
Action: this is an internal error, please report to Oracle
ORA-07747: slemrd: $READ failure
Cause: VMS system service $READ failed
Action: Check system error and refer to VMS documentation
ORA-07750: slemcr: fopen failure
Cause: An attempt to create a message file failed. This is an internal error.
Action: Contact your customer support representative.
ORA-07751: slemcr: malloc failure
Cause: An attempt to allocate a cache for a newly-created message file failed. This is an internal error.
Action: Contact your customer support representative.
ORA-07753: slemcf: fseek before write failure
Cause: An attempt to seek before writing a message file cache element failed. This is an internal error.
Action: Contact your customer support representative.
ORA-07754: slemcf: fwrite failure
Cause: An attempt to write a message file cache element failed. This is an internal error.
Action: Contact your customer support representative.
ORA-07755: slemcf: fseek before read failure
Cause: An attempt to seek before reading a message file cache element failed. This is an internal error.
Action: Contact your customer support representative.
ORA-07756: slemcf: fread failure
Cause: An attempt to read a message file cache element failed. This is an internal error.
Action: Contact your customer support representative.
ORA-07757: slemcc: invalid handle
Cause: The seal in a passed-in handle does not match correct value. This is an internal error.
Action: Contact your customer support representative.
ORA-07758: slemcw: invalid handle
Cause: The seal in a passed-in handle does not match correct value. This is an internal error.
Action: Contact your customer support representative.
ORA-07759: slemtr: invalid destination
Cause: The destination string provided to the function is too short This is an internal error.
Action: Contact your customer support representative.
ORA-07760: slemtr: $open failure
Cause: the $open service failed. This is an internal error
Action: Contact your customer support representative.
ORA-07800: slbtpd: invalid number
Cause: An impossible request for binary to decimal conversion was made
Action: This conversion cannot be performed
ORA-07801: slbtpd: invalid exponent
Cause: An impossible request for binary to decimal conversion was made
Action: This conversion cannot be performed
ORA-07802: slbtpd: overflow while converting to packed decimal
Cause: An impossible request for binary to decimal conversion was made
Action: This conversion cannot be performed
ORA-07803: slpdtb: invalid packed decimal nibble
Cause: An impossible request for decimal to binary conversion was made
Action: This conversion cannot be performed
ORA-07804: slpdtb: number too large for supplied buffer
Cause: An impossible request for decimal to binary conversion was made
Action: This conversion cannot be performed
ORA-07820: sspscn: SYS$CRELNM failure
Cause: An error was returned from the SYS$CRELNM function
Action: Check system error and refer to VMS documentation
ORA-07821: sspsdn: SYS$DELLNM failure
Cause: An error was returned from the SYS$DELLNM function
Action: Check system error and refer to VMS documentation
ORA-07822: sspscm: SYS$CREMBX failure
Cause: An error was returned from the SYS$CREMBX function while trying to create the process dump mailbox.
Action: Check system error and refer to VMS documentation
ORA-07823: sspsqr: $QIO failure
Cause: An error was returned from $QIO while trying to queue a read to the process dump mailbox.
Action: Check system error and refer to VMS documentation
ORA-07824: sspain: $SETIMR failure
Cause: An error was returned from SYS$SETIMR while trying to queue a process spin-watch timer.
Action: Check system error and refer to VMS documentation
ORA-07825: sspsck: $QIO failure at AST level
Cause: An error was returned from SYS$QIO while trying to read the process dump mailbox.
Action: Check system error and refer to VMS documentation
ORA-07826: sspscm: SYS$GETDVIW failure
Cause: An error was returned from SYS$GETDVIW while trying to get information about the process dump mailbox.
Action: Check system error and refer to VMS documentation
ORA-07840: sllfop: LIB$GET_VM failure
Cause: An error was returned from LIB$GET_VM while attempting to allocate memory for an i/o vector.
Action: Check system error and refer to VMS documentation
ORA-07841: sllfop: SYS$OPEN failure
Cause: An error was returned from SYS$OPEN while attempting to open the data file for reading
Action: Check system error and refer to VMS documentation
ORA-07842: sllfcl: SYS$CLOSE failure
Cause: An error was returned from SYS$CLOSE while attempting to close the input data file
Action: Check system error and refer to VMS documentation
ORA-07843: sllfcl: LIB$FREE_VM failure
Cause: An error was returned from LIB$FREE_VM while attempting to free the memory for the i/o vector
Action: Check system error and refer to VMS documentation
ORA-07844: sllfop: LIB$GET_VM failure
Cause: An error was returned from LIB$GET_VM while attempting to allocate memory for data and index buffers
Action: Check system error and refer to VMS documentation
ORA-07845: sllfcl: LIB$FREE_VM failue
Cause: An error was returned from LIB$FREE_VM while attempting to free memory used by data and index buffers
Action: Check system error and refer to VMS documentation
ORA-07846: sllfop: string byte record too big for string byte user buffer
Cause: The longest record in the file will not fit into the largest data buffer that can be allocated
Action: Modify the RMS file to have smaller records
ORA-07847: sllfop: $CONNECT failure
Cause: An error was returned by SYS$CONNECT while attempting to open the data file
Action: Check system error and refer to VMS documentation
ORA-07848: sllfrb: $GET failure
Cause: An error was returned by SYS$GET while attempting to read the data file
Action: Check system error and refer to VMS documentation
ORA-07849: sllfsk: $GET failure
Cause: An error was returned by SYS$GET while attempting to skip records in the input file
Action: Check system error and refer to VMS documentation
ORA-07850: sllfop: bad option
Cause: You are using a bad option to loader Fixed= is one legal option. Check documentation for others.
Action: Check documentation
ORA-07860: osnsoi: error setting up interrupt handler
Cause: An error occurred while setting up the control interrupt handler
Action: This is an internal error. Contact your Oracle representative.
ORA-07880: sdopnf: internal error
Cause: A list of all files open by this process could not be obtained.
Action: This is an internal error. Contact your customer support representative.
ORA-08000: maximum number of session sequence lists exceeded
Cause: the sequence parent state objects for this session are all used
Action: an internal error; quit the session and begin a new one
ORA-08001: maximum number of sequences per session exceeded
Cause: the limit on the number of sequences usable by session has been hit
Action: increase INIT.ORA parameter user_sequences to get more
ORA-08002: sequence string.CURRVAL is not yet defined in this session
Cause: sequence CURRVAL has been selected before sequence NEXTVAL
Action: select NEXTVAL from the sequence before selecting CURRVAL
ORA-08003: sequence string.NEXTVAL exceeds internal limits
Cause: The sequence was created with unsafe values for some of the parameters. The calculation of NEXTVAL cannot be made because it exceeds the legal represention size.
Action: Alter or recreate the sequence number with legal limits.
ORA-08004: sequence string.NEXTVAL string stringVALUE and cannot be instantiated
Cause: instantiating NEXTVAL would violate one of MAX/MINVALUE
Action: alter the sequence so that a new value can be requested
ORA-08005: specified row does not exist
Cause: A row with the given rowid does not exist in any of the tables given
Action: check the query for misspellings of table names and the rowid
ORA-08006: specified row no longer exists
Cause: the row has been deleted by another user since the operation began
Action: re-try the operation
ORA-08008: another instance is mounted with USE_ROW_ENQUEUES = string
Cause: the shared instance being started does not have the same value for use_row_enqueues as already running instances
Action: ensure that all instances' INIT.ORA files specify the same value for the parameter 'use_row_enqueues'
ORA-08100: index is not valid - see trace file for diagnostics
Cause: Validate Index detected an inconsistency in its argument index
Action: Send trace file to your customer support representative
ORA-08101: index key does not exist file string: (root string, node string) blocks (string)
Cause: Internal error: possible inconsistency in index
Action: Send trace file to your customer support representative, along with information on reproducing the error
ORA-08102: index key not found, obj# string, file string, block string (string)
Cause: Internal error: possible inconsistency in index
Action: Send trace file to your customer support representative, along with information on reproducing the error
ORA-08103: object no longer exists
Cause: The object has been deleted by another user since the operation began, or a prior incomplete recovery restored the database to a point in time during the deletion of the object.
Action: Delete the object if this is the result of an incomplete recovery.
ORA-08104: this index object string is being online built or rebuilt
Cause: the index is being created or rebuild or waited for recovering from the online (re)build
Action: wait the online index build or recovery to complete
ORA-08106: cannot create journal table string.string
Cause: The online index builder could not create its journal table
Action: rename your table in conflict or rerun the SQL statement

* there may be a concurrent online index rebuild on the same object.

ORA-08108: may not build or rebuild this type of index online
Cause: only support normal index or IOT top-level index
Action: change your index type
ORA-08109: nosort is not a supported option for online index build
Cause: may not specify nosort for online index build
Action: get rid of nosort in the index creation command
ORA-08111: a partitioned index may not be coalesced as a whole
Cause: User attempted to coalesce a partitioned index using ALTER INDEX COALESCE statement, which is illegal
Action: Coalesce the index a (sub)partition at a time (using ALTER INDEX MODIFY (sub)PARTITION COALESCE)
ORA-08112: a composite partition may not be coalesced as a whole
Cause: User attempted to coalesce a composite partition
Action: Coalesce the index a subpartition at a time (using ALTER INDEX MODIFY SUBPARTITION COALESCE)
ORA-08113: composite partition index may not be compressed
Cause: User attempted to compress a composite partition index
Action: create uncompressed composite partition index
ORA-08114: can not alter a fake index
Cause: User attempted to alter a fake index
Action: drop fake index
ORA-08115: can not online create/rebuild this index type
Cause: User attempted to create index type that online doesnot support
Action: use offline index create/rebuild command
ORA-08116: can not acquire dml enough lock(S mode) for online index build
Cause: User attempted to create index online without allowing DML Share lock
Action: allow DML share lock on the base table
ORA-08117: Index Organized Table operation released its block pin
Cause: Block maintenance forced the release of a block pin
Action: Contact your customer support representative
ORA-08118: Deferred FK constraints cannot be enforced, index too big (string)
Cause: Deferred Foreign Key constraints cannot be enforced due to the index key being too big and built on a non-default DB_BLOCK_SIZE.
Action: First try to drop the Foreign Key and then the primary key.
ORA-08119: The new initrans will make the index too big
Cause: Specifying the initrans need additional space to hold the index key which might make the index too big
Action: Try giving a smaller initrans value
ORA-08120: Need to create SYS.IND_ONLINE$ table in order to (re)build index
Cause: Alter index Build/Rebuild online require existing of SYS.IND_ONLINE$ table.
Action: User/DBA needs to create sys.ind_online$ before alter the index /rdbms/admin/catcio.sql contains script to create ind_online$.
ORA-08175: discrete transaction restriction violated (string)
Cause: An attempt was made to perform an action that is not currently supported in a discrete transaction.
Action: Rollback the transaction, and retry it as a normal transaction.
ORA-08176: consistent read failure; rollback data not available
Cause: Encountered data changed by an operation that does not generate rollback data : create index, direct load or discrete transaction.
Action: In read/write transactions, retry the intended operation. Read only transactions must be restarted.
ORA-08177: can't serialize access for this transaction
Cause: Encountered data changed by an operation that occurred after the start of this serializable transaction.
Action: In read/write transactions, retry the intended operation or transaction.
ORA-08178: illegal SERIALIZABLE clause specified for user INTERNAL
Cause: Serializable mode is not supported for user INTERNAL.
Action: Reconnect as another user and retry the SET TRANSACTION command.
ORA-08179: concurrency check failed
Cause: Encountered data changed by an operation that occurred after a specific snapshot. This is usually used to indicate that a particular cached copy of a datablock is stale. This is used for internal use for now.
Action: refresh the cached copy of the datablock and retry operation.
ORA-08180: no snapshot found based on specified time
Cause: Could not match the time to an SCN from the mapping table.
Action: try using a larger time.
ORA-08181: specified number is not a valid system change number
Cause: supplied scn was beyond the bounds of a valid scn.
Action: use a valid scn.
ORA-08182: operation not supported while in Flashback mode
Cause: user tried to do dml or ddl while in Flashback mode
Action: disable Flashback and re-attempt the operation
ORA-08183: Flashback cannot be enabled in the middle of a transaction
Cause: user tried to do Flashback in the middle of a transaction
Action: do a commit
ORA-08184: attempting to re-enable Flashback while in Flashback mode
Cause: as stated above
Action: disable first before re-enabling
ORA-08185: Flashback not supported for user SYS
Cause: user logged on as SYS
Action: logon as a different (non SYS) user.
ORA-08186: invalid timestamp specified
Cause: as stated above
Action: enter a valid timestamp
ORA-08187: snapshot expression not allowed here
Cause: A snapshot expression using AS OF was specified when not allowed.
Action: Do not use the AS OF clause
ORA-08189: cannot flashback the table because row movement is not enabled
Cause: An attempt was made to perform Flashback Table operation on a table for which row movement has not been enabled. Because the Flashback Table does not preserve the rowids, it is necessary that row movement be enabled on the table.
Action: Enable row movement on the table
ORA-08191: Flashback Table operation is not supported on remote tables
Cause: An attempt was made to perform Flashback Table operation on a remote table. This is not permitted.
Action: Do not perform a Flashback Table operation on remote tables.
ORA-08192: Flashback Table operation is not allowed on fixed tables
Cause: An attempt was made to perform Flashback Table operation on a fixed table. This is not permitted.
Action: Do not perform a Flashback Table operation on fixed tables.
ORA-08193: Flashback Table operation is not allowed on temporary tables
Cause: An attempt was made to perform Flashback Table operation on a temporary table. This is not permitted.
Action: Do not perform a Flashback Table operation on temporary tables.
ORA-08194: Flashback Table operation is not allowed on materialized views
Cause: An attempt was made to perform Flashback Table operation on a materialized view. This is not permitted.
Action: Do not perform a Flashback Table operation on materialized views or snapshot logs.
ORA-08195: Flashback Table operation is not supported on partitions
Cause: An attempt was made to perform Flashback Table operation on a partition. This is not permitted.
Action: Do not perform a Flashback Table operation on partitions.
ORA-08196: Flashback Table operation is not allowed on AQ tables
Cause: An attempt was made to perform Flashback Table operation on AQ tables. This is not permitted.
Action: Do not perform a Flashback Table operation on AQ tables.
ORA-08197: Flashback Table operation is not supported on clustered tables
Cause: An attempt was made to perform Flashback Table operation on a clustered table. This is not permitted.
Action: Do not perform a Flashback Table operation on clustered tables.
ORA-08205: ora_addr: $ORACLE_SID not set in environment
Cause: The environment variable ORACLE_SID is not set.
Action: Set the ORACLE_SID environment variable.
ORA-08206: ora_addr: cannot translate address file name
Cause: Cannot translate $ORACLE_HOME/dbs/sgadef$ORACLE_SID.dbf.
Action: Ensure that ORACLE_HOME and ORACLE_SID are properly set.
ORA-08207: ora_addr: cannot open address file
Cause: The address file could not be opened.
Action: Check that ORACLE is up. Check that the file $(ORACLE_HOME)/dbs/sgadef$(ORACLE_SID).dbf exists and has correct permissions.
ORA-08208: ora_addr: cannot read from address file
Cause: The address file could not be read.
Action: Check that the file $(ORACLE_HOME)/dbs/sgadef$(ORACLE_SID).dbf exists and contains a single line of text.
ORA-08209: scngrs: SCN not yet initialized
Cause: The System Commit Number has not yet been initialized.
Action: Contact your customer support representative.
ORA-08210: Requested I/O error
Cause: Oracle requested that an I/O error be returned for this operation.
Action: This should not occur in normal Oracle operation. Contact support.
ORA-08230: smscre: failed to allocate SGA
Cause: The n_core system call failed, maybe due to insufficient memory.
Action: Specify a smaller number of buffers. Check INIT.ORA parameters.
ORA-08231: smscre: unable to attach to SGA
Cause: The process cannot attach to the SGA. This can happen if either the listener can't attach, or the process cannot communicate with the listener.
Action: Verify that the instance is up and running. Contact your customer support representative.
ORA-08232: smsdes: cannot detach from SGA
Cause: Probably, the listener process has died.
Action: Contact your customer support representative.
ORA-08233: smsdes: cannot unmap SGA
Cause: The n_core system call failed while detaching from the SGA.
Action: Note nCX error returned; contact your customer support representative.
ORA-08234: smsget: cannot get instance listener address
Cause: The instance listener address cannot be read from the sgadef file.
Action: Verify $(ORACLE_HOME) and $(ORACLE_SID) are set correctly. Additional information gives error return from ora_addr.
ORA-08235: smsget: listener not on this node
Cause: A process wishing to attach to the SGA is on a different node from its instance's listener.
Action: Verify $(ORACLE_HOME) and $(ORACLE_SID) are set correctly. Contact your customer support representative.
ORA-08236: smsget: cannot share subcube with listener
Cause: The n_share call failed, probably because the listener has died.
Action: Check if the listener is running, and contact your customer support representative.
ORA-08237: smsget: SGA region not yet created
Cause: Attempting to attach to an SGA which has not yet been created.
Action: Verify that the instance is running. Contact your customer support representative.
ORA-08238: smsfre: cannot detach from SGA
Cause: The n_core system call failed while detaching from the SGA.
Action: Check nCX error, and contact your customer support representative.
ORA-08260: ora_addr: cannot open nameserver
Cause: A process could not connect to the nameserver.
Action: Make sure the nameserver is up and running. Additional information gives nameserver's returned status.
ORA-08261: ora_addr: cannot find name in nameserver
Cause: The listener nameserver entry for an instance could not be found.
Action: Make sure the nameserver is up and running. Additional information gives nameserver's returned status.
ORA-08263: ora_addr: cannot free listener address
Cause: The listener nameserver entry could not be freed
Action: Additional information gives nameserver's returned status. Contact your customer support representative.
ORA-08264: ora_addr: cannot close nameserver
Cause: The connection to the nameserver could not be closed.
Action: Additional information gives nameserver's returned status. Contact your customer support representative.
ORA-08265: create_ora_addr: cannot open nameserver
Cause: A process could not connect to the nameserver.
Action: Make sure the nameserver is up and running. Additional information gives nameserver's returned status.
ORA-08266: create_ora_addr: cannot register name in nameserver
Cause: The listener's addressing information could not be registered.
Action: Make sure the nameserver is up and running. Additional information gives nameserver's returned status.
ORA-08267: destroy_ora_addr: cannot close nameserver
Cause: The connection to the nameserver could not be closed.
Action: Additional information gives nameserver's returned status. Contact your customer support representative.
ORA-08268: create_ora_addr: cannot close nameserver
Cause: The connection to the nameserver could not be closed.
Action: Additional information gives nameserver's returned status. Contact your customer support representative.
ORA-08269: destroy_ora_addr: cannot destroy name
Cause: The listener's addressing information could not be removed.
Action: Additional information gives nameserver's returned status. Contact your customer support representative.
ORA-08270: sksachk: Illegal archival control string
Cause: Archive files cannot be created with the given archival control string.
Action: Check that the volume exists
ORA-08271: sksabln: Buffer size not large enough for archive control string
Cause: The given archival control string expands into too many characters.
Action: Reduce archive control string length.
ORA-08274: Out of memory for environment variable
Cause: There is insufficient memory to return the requested value
Action: Reduce memory usage and retry.
ORA-08275: Environment variable unset
Cause: The requested environment variable is not set
Action: Ensure that the variable name requested is correct.
ORA-08276: No room in nameserver for pid
Cause: There is no room to record the pid for a background process
Action: Shutdown abort and restart the database.
ORA-08277: Cannot set environment variable
Cause: There is insufficient memory to expand the environment.
Action: Reduce memory usage and retry.
ORA-08278: Cannot get CPU statistics
Cause: Could not retrieve CPU times because n_stat failed.
Action: Contact customer support.
ORA-08308: sllfop: Cannot open file
Cause: Oracle could not open a file.
Action: Check the Unix errno returned as additional information.
ORA-08309: sllfop: Cannot fstat file
Cause: Oracle could not obtain information about an open file.
Action: Check the Unix errno returned as additional information.
ORA-08310: sllfop: Bad value for recsize
Cause: An illegal value for the record size was specified.
Action: Specify a value for the recsize option that is greater than 0.
ORA-08311: sllfop: bad value for maxrecsize
Cause: An illegal value for the maximum record size was specified.
Action: Specify a value for the maxrecsize option that is greater than 0.
ORA-08312: sllfop: unrecognized processing option
Cause: An unrecognized processing option was specified.
Action: Check the Oracle for nCUBE 2 User's Guide for valid options.
ORA-08313: sllfop: could not allocate buffers
Cause: Memory for the load buffers could not be allocated.
Action: Reduce the maximum record size. Eliminate any unnecessary processes on your current node before running SQL*Loader again.
ORA-08314: sllfcf: Error closing file
Cause: An error occurred trying to close a file.
Action: Check the Unix errno returned as additional information.
ORA-08315: sllfrb: Error reading file
Cause: An error occurred trying to read from a file.
Action: Check the Unix errno returned as additional information.
ORA-08316: sllfsk: Error seeking in file.
Cause: The lseek system call returned an error.
Action: Check the Unix errno returned as additional information.
ORA-08317: sllfsk: Error seeking in file.
Cause: The lseek system call returned an error.
Action: Check the Unix errno returned as additional information.
ORA-08318: sllfsk: Error reading file
Cause: An error occurred trying to read from a file.
Action: Check the Unix errno returned as additional information.
ORA-08319: sllfsk: Error reading file
Cause: An error occurred trying to read from a file.
Action: Check the Unix errno returned as additional information.
ORA-08320: scnget: Call to scnget before scnset or scnfnd.
Cause: An internal error
Action: Contact your customer support representative.
ORA-08321: scnmin: NOT IMPLEMENTED YET
Cause: An internal error
Action: Contact your customer support representative.
ORA-08322: scnmin: open/convert of bias lock failed
Cause: A call to the lkmgr failed to open and convert the bias lock
Action: Check to make sure the lkmgr is up.
ORA-08323: scnmin: close of bias lock failed
Cause: A call to the lkmgr failed to close the bias lock
Action: Check to make sure the lkmgr is up.
ORA-08330: Printing not supported
Cause: An attempt was made to automatically spool a file to the printer
Action: none
ORA-08331: Wait operation timed out
Cause: Oracle timed out waiting for an event
Action: Contact your Oracle support representative
ORA-08332: rollback segment #string specified not available
Cause: (same as 1545)
Action: (same as 1545). Also, make sure you have created enough rollback segments for the number of instances you are trying to start.
ORA-08340: This command not allowed on nCUBE, only one thread is ever used.
Cause: An illegal command was executed for the nCUBE platform.
Action: There is no need to issue this command.
ORA-08341: On nCUBE, this command can only be executed from instance 1.
Cause: A command that can only be issued on instance 1 was issued elsewhere.
Action: Log on to instance 1 and repeat the command.
ORA-08342: sropen: failed to open a redo server connection
Cause: An error occurred trying to connect to the redo server.
Action: The OS specific error message should tell you what to do.
ORA-08343: srclose: failed to close a redo server connection
Cause: An error occurred trying to close the redo server connection.
Action: The OS specific error message should tell you what to do.
ORA-08344: srapp: failed to send redo data to the redo server
Cause: An error occurred trying to send redo to the redo server.
Action: The OS specific error message should tell you what to do.
ORA-08401: invalid compiler name: string
Cause: An invalid compiler name <compname> was passed to a UTL_PG conversion routine.
Action: Correct the compiler name parameter in the PL/SQL code that called the conversion routine.
ORA-08412: error encountered in WMSGBSIZ, size for WMSGBLK is not big enough for warning message
Cause: The WMSGBSIZ is the maximun size for warning message block, it is recommanded to be 1024 bytes to 8 kbytes.
Action: Defined WMSGBLK of size between 1k to 8k bytes and update the WMSGBSIZ to the sizeof(WMSGBLK).
ORA-08413: invalid compiler type in FORMAT parameter at string
Cause: An invalid compiler type is defined in format control block. The format control block is invalid.
Action: Check to be sure that the format parameter was built by MAKE_RAW_TO_NUMBER_FORMAT or MAKE_NUMBER_TO_RAW_FORMAT, and that it was not accidentally overwritten or modified by the PL/SQL procedure.
ORA-08414: error encountered in string
Cause: The function <routine> returned an error. Where <routine> may be: RAW_TO_NUMER NUMBER_TO_RAW RAW_TO_NUMBER_FORMAT NUMBER_TO_RAW_FORMAT MAKE_NUMBER_TO_RAW_FORMAT MAKE_RAW_TO_NUMBER_FORMAT
Action: to take.
ORA-08429: raw data has invalid digit in display type data
Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine contained invalid data. The picture mask parameter specified a digit, but the corresponding input from the raw data did not contain a valid digit.
Action: Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.
ORA-08430: raw data missing leading sign
Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine had no leading sign, but the mask options parameter specified a leading sign.
Action: Correct the input raw data or the mask options so that they match.
ORA-08431: raw data missing zero as defined in picture
Cause: The picture mask parameter passed to a UTL_PG RAW_TO_NUMBER conversion routine contained a zero, but the corresponding input from the raw data was not a zero.
Action: Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.
ORA-08432: raw data has invalid floating point data
Cause: The input raw data passed to a UTL_PG RAW_TO_NUMBER conversion routine contained invalid floating point data.
Action: Correct the input raw data.
ORA-08433: invalid picture type in convert raw to number
Cause: The picture mask parameter passed to a UTL_PG RAW_TO_NUMBER conversion routine contained non-numeric characters, but the conversion was to a numeric data type.
Action: Correct the picture mask parameter.
ORA-08434: raw data has invalid trailing sign
Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine had no trailing sign, but the mask options parameter specified a trailing sign.
Action: Correct the input raw data or the mask options so that they match.
ORA-08435: PICTURE MASK missing the leading sign when SIGN IS LEADING specified
Cause: The input MASK passed to a UTL_PG RAW_TO_NUMBER conversion routine had no leading sign, but the mask options parameter specified a leading sign.
Action: Correct the input raw data or the mask options so that they match.
ORA-08436: raw data has invalid sign digit
Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine had an invalid sign digit in the position where the picture mask specified a sign.
Action: Correct the input raw data or the picture mask so that they match.
ORA-08437: invalid picture type in picture mask
Cause: The picture mask parameter passed to a UTL_PG NUMBER_TO_RAW conversion routine contained non-numeric characters, but the conversion was to a numeric data type.
Action: Correct the picture mask parameter.
ORA-08440: raw buffer is too short to hold converted data
Cause: The output raw buffer passed to a UTL_PG NUMBER_TO_RAW conversion routine was not large enough to contain the results of the conversion based on the picture mask.
Action: Increase the raw buffer size to the size necessary to hold the entire result of the conversion.
ORA-08441: closed parenthesis missing in picture mask
Cause: A closed parenthesis was missing from the picture mask passed to a UTL_PG conversion routine.
Action: Correct the picture mask.
ORA-08443: syntax error in BLANK WHEN ZERO clause in mask options
Cause: A syntax error was found in the BLANK WHEN ZERO clause in the mask options parameter passed to a UTL_PG conversion routine. Valid specifications are: BLANK ZERO BLANK ZEROS BLANK ZEROES BLANK WHEN ZERO BLANK WHEN ZEROS BLANK WHEN ZEROES
Action: Correct the mask options parameter.
ORA-08444: syntax error in JUSTIFIED clause in mask options
Cause: A syntax error was found in the JUSTIFIED clause in the mask options parameter passed to a UTL_PG conversion routine. Valid specifications are: JUST JUST RIGHT JUSTIFIED JUSTIFIED RIGHT
Action: Correct the mask options parameter.
ORA-08445: syntax error in SIGN clause in mask options
Cause: A syntax error was found in the SIGN clause in the mask options parameter passed to a UTL_PG conversion routine. Valid specifications are: SIGN LEADING SIGN LEADING SEPARATE SIGN LEADING SEPARATE CHARACTER SIGN TRAILING SIGN TRAILING SEPARATE SIGN TRAILING SEPARATE CHARACTER SIGN IS LEADING SIGN IS LEADING SEPARATE SIGN IS LEADING SEPARATE CHARACTER SIGN IS TRAILING SIGN IS TRAILING SEPARATE SIGN IS TRAILING SEPARATE CHARACTER
Action: Correct the mask options parameter.
ORA-08446: syntax error in SYNCHRONIZED clause in mask options
Cause: A syntax error was found in the SYNCHRONIZED clause in the mask options parameter passed to a UTL_PG conversion routine. Valid specifications are: SYNC SYNC LEFT SYNC RIGHT SYNCHRONIZED SYNCHRONIZED LEFT SYNCHRONIZED RIGHT
Action: Correct the mask options parameter.
ORA-08447: syntax error in USAGE clause in mask options
Cause: A syntax error was found in the USAGE clause in the mask options parameter passed to a UTL_PG conversion routine. Valid specifications are: USAGE DISPLAY USAGE COMP USAGE COMP-3 USAGE COMP-4 USAGE COMPUTATIONAL USAGE COMPUTATIONAL-3 USAGE COMPUTATIONAL-4 USAGE IS DISPLAY USAGE IS COMP USAGE IS COMP-3 USAGE IS COMP-4 USAGE IS COMPUTATIONAL USAGE IS COMPUTATIONAL-3 USAGE IS COMPUTATIONAL-4
Action: Correct the mask options parameter.
ORA-08448: syntax error in DECIMAL-POINT environment clause
Cause: A syntax error was found in the DECIMAL-POINT environment clause parameter passed to a UTL_PG conversion routine. Valid specifications are: DECIMAL-POINT IS COMMA
Action: Correct the environment clause parameter.
ORA-08449: invalid numeric symbol found in picture mask
Cause: An invalid numeric symbol was found in the picture mask parameter passed to a UTL_PG conversion routine.
Action: Correct the picture mask parameter.
ORA-08450: invalid specification of CR in picture mask
Cause: The CR suffix was incorrectly specified in the picture mask parameter passed to a UTL_PG conversion routine. The CR suffix can only appear at the end of a picture mask.
Action: Correct the picture mask parameter.
ORA-08451: invalid specification of DB in picture mask
Cause: The DB suffix was incorrectly specified in the picture mask parameter passed to a UTL_PG conversion routine. The DB suffix can only appear at the end of a picture mask.
Action: Correct the picture mask parameter.
ORA-08452: specification of E in picture mask is unsupported
Cause: The floating point exponent symbol 'E' was specified in the picture mask parameter passed to a UTL_PG conversion routine. The floating point data type is currently not supported by the UTL_PG conversion routines.
Action: Correct the picture mask parameter, and the data, if necessary.
ORA-08453: more than one V symbol specified in picture mask
Cause: The picture mask passed to a UTL_PG conversion routine contained more than one decimal point indicator ('V'). Only one decimal point indicator is allowed in the picture mask.
Action: Correct the picture mask parameter.
ORA-08454: more than one S symbol specified in picture mask
Cause: The picture mask passed to a UTL_PG conversion routine contained more than one operational sign indicator ('S'). Only one operational sign indicator is allowed in the picture mask.
Action: Correct the picture mask parameter.
ORA-08455: syntax error in CURRENCY SIGN environment clause
Cause: A syntax error was found in the CURRENCY SIGN environment clause parameter passed to a UTL_PG conversion routine. Valid specifications are: CURRENCY SIGN IS x where x is a valid currency sign
Action: Correct the environment clause parameter.
ORA-08456: no sign in picture mask but SIGN clause in mask options
Cause: The picture mask parameter passed to a UTL_PG conversion routine contained no sign symbol ('S', '+', or '-'), but the mask options parameter contained a SIGN clause. A sign symbol is required in the picture mask parameter when the mask options parameter contains a SIGN clause.
Action: Correct the picture mask parameter or the mask options parameter.
ORA-08457: syntax error in SEPARATE CHARACTER option of SIGN clause
Cause: A syntax error was found in the SEPARATE CHARACTER option of the SIGN clause in the mask options parameter passed to a UTL_PG conversion routine. Valid specifications are: SEPARATE SEPARATE CHARACTER
Action: Correct the mask options parameter.
ORA-08458: invalid format parameter
Cause: The format parameter passed to a UTL_PG conversion routine was invalid. The format parameter should have been built by a prior call to either MAKE_RAW_TO_NUMBER_FORMAT or MAKE_NUMBER_TO_RAW_FORMAT.
Action: Check to be sure that the format parameter was built by MAKE_RAW_TO_NUMBER_FORMAT or MAKE_NUMBER_TO_RAW_FORMAT, and that it was not accidentally overwritten or modified by the PL/SQL procedure.
ORA-08459: invalid format parameter length
Cause: The format parameter passed to a UTL_PG conversion routine was not the correct length. Format parameters must be 2048 bytes in length.
Action: Check to be sure that the format parameter was built by MAKE_RAW_TO_NUMBER_FORMAT or MAKE_NUMBER_TO_RAW_FORMAT, and that it was not accidentally overwritten or modified by the PL/SQL procedure.
ORA-08460: invalid environment clause in environment parameter
Cause: The environment parameter passed to a UTL_PG conversion routine contained an unsupported or invalid environment clause. Only the CURRENCY SIGN and the DECIMAL-POINT IS COMMA environment clauses are supported.
Action: Correct the environment parameter.
ORA-08462: raw buffer contains invalid decimal data
Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine contains invalid decimal data.
Action: Correct the input data.
ORA-08463: overflow converting decimal number to Oracle number
Cause: The output variable passed to a UTL_PG RAW_TO_NUMBER was not large enough to hold the Oracle number resulting from the input decimal number.
Action: Be sure that the input decimal number is valid, and besure that the output variable is large enough to hold the Oracle number value.
ORA-08464: input raw decimal data contains more than 42 digits
Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine contained more than 42 digits. This exceeds the maximum size of an Oracle number.
Action: Correct the raw input buffer.
ORA-08465: input mask contains more than 32 characters
Cause: The input mask passed to UTL_PG numeric conversion routine contained more the 32 characters.
Action: Correct the mask input buffer.
ORA-08466: raw buffer length string is too short for string
Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine was less than %s bytes long, but the picture mask parameter specified that %s bytes of input data were to be converted.
Action: Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.
ORA-08467: error converting Oracle number to string
Cause: An error occurred when converting an Oracle number to a COBOL <type> of: DISPLAY COMP-3 or character variable. The Oracle number was not in the correct format. mat.
Action: Correct the call to the conversion routine. The input must be a valid Oracle number variable.
ORA-08468: mask option string is not supported
Cause: The mask option <clause> was passed to a UTL_PG conversion routine, but is not supported by UTL_PG. The <clause> can be: USAGE IS POINTER USAGE IS INDEX USAGE IS COMP-1 USAGE IS COMP-2 POINTER
Action: Remove the <clause> from the mask options parameter in the PL/SQL call to UTL_PG.
ORA-08498: Warning: picture mask 'string' overrides picture mask option 'USAGE IS string' to 'USAGE IS DISPLAY'
Cause: Picture mask USAGE option was overridden by the picture mask.
Action: This is an informational message only. The message may be eliminated by changing the USAGE option to match the picture mask.
ORA-08499: Warning: picture mask options 'string' ignored by UTL_PG
Cause: Picture mask options such as OCCUR, SYNC and others are not processed by the UTL_PG numeric conversion routines.
Action: This is an informational message only. The message may be eliminated by removing the unnecessary picture mask options from the parameter list passed to the UTL_PG routine.
ORA-09200: sfccf: error creating file
Cause: Could be out of disk space
Action: See OSD error accompanying this message
ORA-09201: sfcopy: error copying file
Cause: Block sizes may not match
Action: See OSD error accompanying this message
ORA-09202: sfifi: error identifying file
Cause: db_block_size specified in init.ora could be incorrect
Action: See OSD error accompanying this message
ORA-09203: sfofi: error opening file
Cause: File attributes may have changed
Action: See OSD error accompanying this message
ORA-09204: sfotf: error opening temporary file
Cause: Incorrect path may have been specified for the file
Action: See OSD error accompanying this message
ORA-09205: sfqio: error reading or writing to disk
Cause: File may have been truncated or corrupted
Action: See OSD error accompanying this message
ORA-09206: sfrfb: error reading from file
Cause: File may have been truncated or corrupted
Action: See OSD error accompanying this message
ORA-09207: sfsrd: error reading from file
Cause: File may have been truncated or corrupted
Action: See OSD error accompanying this message
ORA-09208: sftcls: error closing file
Cause: File may have been corrupted
Action: See OSD error accompanying this message
ORA-09209: sftget: error reading from file
Cause: File may have been truncated or corrupted
Action: See OSD error accompanying this message
ORA-09210: sftopn: error opening file
Cause: Incorrect path may have been specified for the file
Action: See OSD error accompanying this message
ORA-09211: sfwfb: error writing to file
Cause: File may have been truncated or corrupted
Action: See OSD error accompanying this message
ORA-09212: sfwfbmt: error writing to file
Cause: File may have been truncated or corrupted
Action: See OSD error accompanying this message
ORA-09213: slgfn: error fabricating file name
Cause: Filename may be too long
Action: See OSD error accompanying this message
ORA-09214: sfdone: I/O error detected
Cause: File may have been truncated or corrupted
Action: See OSD error accompanying this message
ORA-09215: sfqio: error detected in IOCompletionRoutine
Cause: File may have been truncated or corrupted
Action: See OSD error accompanying this message
ORA-09216: sdnfy: bad value 'string' for parameter string
Cause: The directory specified as the value for the stated parameter could not be used.
Action: Make sure the directory you have specified is a valid directory/file specification.
ORA-09217: sfsfs: failed to resize file
Cause: Could be out of disk space
Action: See OSD error accompanying this message
ORA-09218: sfrfs: failed to refresh file size
Cause: File may be corrupted or truncated
Action: See OSD error accompanying this message
ORA-09240: smpalo: error allocating PGA memory
Cause: Could be out of memory
Action: See OSD error accompanying this message
ORA-09241: smsalo: error allocating SGA memory
Cause: Could be out of memory
Action: See OSD error accompanying this message
ORA-09243: smsget: error attaching to SGA
Cause: SGA may not have been created (database not started)
Action: See OSD error accompanying this message
ORA-09260: sigpidu: error obtaining process id
Cause: May be out of resources
Action: See OSD error accompanying this message
ORA-09261: spdcr: error creating detached (background) process
Cause: Could be out of resources
Action: See OSD error accompanying this message
ORA-09262: spdde: error terminating detached (background) process
Cause: Could be out of resources
Action: See OSD error accompanying this message
ORA-09263: spini: error initializing process
Cause: Could be out of memory
Action: See OSD error accompanying this message
ORA-09264: sptpa: error flagging process
Cause: Could be out of resources
Action: See OSD error accompanying this message
ORA-09265: spwat: error temporarily suspending process
Cause: Could be out of resources
Action: See OSD error accompanying this message
ORA-09266: spawn: error starting an Oracle process
Cause: Could be out memory
Action: See OSD error accompanying this message
ORA-09270: szalloc: error allocating memory for security
Cause: Could be out of memory
Action: See OSD error accompanying this message
ORA-09271: szlon: error verifying user name
Cause: Username may be too long
Action: See OSD error accompanying this message
ORA-09272: remote os logon is not allowed
Cause: Remote os login attempted when not allowed.
Action: See OSD error accompanying this message
ORA-09273: szrfc: error verifying role name
Cause: An OS error was returned when verifying the role name.
Action: See OSD error accompanying this message
ORA-09274: szrfc: insufficient role name buffer space
Cause: An OS role name was too long.
Action: See OSD error accompanying this message
ORA-09275: CONNECT INTERNAL is not a valid DBA connection
Cause: CONNECT INTERNAL is no longer supported for DBA connections.
Action: Please try to connect AS SYSDBA or AS SYSOPER.
ORA-09280: sllfcf: error closing file
Cause: File may be corrupted
Action: See OSD error accompanying this message
ORA-09281: sllfop: error opening file
Cause: Possibly incorrect path specified to the file
Action: See OSD error accompanying this message
ORA-09282: sllfrb: error reading records
Cause: File could be corrupted
Action: See OSD error accompanying this message
ORA-09283: sllfsk: error skipping records
Cause: File could be corrupted
Action: See OSD error accompanying this message
ORA-09284: sllfop: cannot allocate read buffer
Cause: malloc() system call returned an error. The system might have run out of heap space
Action: Check additional information for the OS error.
ORA-09285: sllfop: unrecognizable processing option, incorrect format
Cause: Processing option passed is of incorrect format
Action: Consult your IUG for permissible formats
ORA-09290: sksaalo: error allocating memory for archival
Cause: Could be out of memory
Action: See OSD error accompanying this message
ORA-09291: sksachk: invalid device specified for archive destination
Cause: Unable to access directory
Action: Specify a valid device in ARCHIVE control string
ORA-09292: sksabln: unable to build archive file name
Cause: Bad directory or format specified
Action: Specify a valid directory in 'log_archive_format' and a valid format string in 'log_archive_format' in init.ora
ORA-09293: sksasmo: unable to send message to console
Cause: An error was returned while attempting to send a message to the console operator
Action: See OSD error accompanying this message
ORA-09300: osncon: unable to connect, DPMI not available
Cause: Unable to detect the presence of DPMI
Action: Restart Windows and retry
ORA-09301: osncon: local kernel only supported in standard mode
Cause: An attempt was made to connect to S: while in enhanced mode
Action: Restart Windows in standard mode
ORA-09310: sclgt: error freeing latch
Cause: Internal error
Action: See OSD error accompanying this message
ORA-09311: slsleep: error temporarily suspending process
Cause: May be out of resources
Action: See OSD error accompanying this message
ORA-09312: slspool: error spooling file to printer
Cause: Could be out of resources
Action: See OSD error accompanying this message
ORA-09313: slsprom: error prompting user
Cause: May be out of resources
Action: See OSD error accompanying this message
ORA-09314: sltln: error translating logical name
Cause: Internal buffer may have overflowed
Action: See OSD error accompanying this message
ORA-09315: sql2tt: two-task error translating ORACLE_EXECUTABLE
Cause: Internal error
Action: See OSD error accompanying this message
ORA-09316: szrpc: unable to verify password for role
Cause: OS roles may not be supported for this platform
Action: See OSD error accompanying this message
ORA-09317: szprv: insufficient privileges
Cause: The password specified is invalid
Action: See OSD error accompanying this message
ORA-09318: slkhst: unable to host out to operating system
Cause: There might not be enough memory for the command or hosting out may not be supported on this platform
Action: See OSD error accompanying this message
ORA-09319: slgtd: unable to obtain the current date and time
Cause: The system time might be set incorrectly
Action: See OSD error accompanying this message
ORA-09320: szrfc: unable to obtain the list of valid OS roles
Cause: OS roles may not be supported on this platform
Action: See OSD error accompanying this message
ORA-09321: slzdtb: unable to convert zoned decimal to binary
Cause: internal error
Action: See OSD error accompanying this message
ORA-09322: slpdtb: unable to convert packed decimal to binary
Cause: internal error
Action: See OSD error accompanying this message
ORA-09330: Session terminated internally by Oracle or by an Oracle DBA
Cause: Oracle to terminate that session after about a minute. This message also appears in the trace file if a shutdown abort is performed.
Action: none
ORA-09340: Specified ORACLE_SID is either invalid or too long
Cause: ORACLE_SID must be at the most 4 alphanumeric characters.
Action: none
ORA-09341: scumnt: unable to mount database
Cause: Another instance is currently mounting the database
Action: none
ORA-09342: Detached process terminated by Oracle during shutdown abort
Cause: The user performed a shutdown abort.
Action: none
ORA-09344: spsig: error signalling thread
Cause: This function may not be implemented.
Action: none
ORA-09350: Windows 32-bit Two-Task driver unable to allocate context area
Cause: See OSD error accompanying this message
Action: none
ORA-09351: Windows 32-bit Two-Task driver unable to allocate shared memory
Cause: See OSD error accompanying this message
Action: none
ORA-09352: Windows 32-bit Two-Task driver unable to spawn new ORACLE task
Cause: See OSD error accompanying this message
Action: none
ORA-09353: Windows 32-bit Two-Task driver unable to open event semaphore
Cause: See OSD error accompanying this message
Action: none
ORA-09354: Windows 32-bit Two-Task driver: ORACLE task unexpectedly died
Cause: See OSD error accompanying this message
Action: none
ORA-09360: Windows 3.1 Two-Task driver unable to allocate context area
Cause: See OSD error accompanying this message
Action: none
ORA-09361: Windows 3.1 Two-Task driver unable to lock context area
Cause: See OSD error accompanying this message
Action: none
ORA-09362: Windows 3.1 Two-Task driver unable to deallocate context area
Cause: See OSD error accompanying this message
Action: none
ORA-09363: Windows 3.1 Two-Task driver invalid context area
Cause: See OSD error accompanying this message
Action: none
ORA-09364: Windows 3.1 Two-Task driver unable to create hidden window
Cause: See OSD error accompanying this message
Action: none
ORA-09365: Windows 3.1 Two-Task driver unable to destroy hidden window
Cause: See OSD error accompanying this message
Action: none
ORA-09366: Windows 3.1 Two-Task driver unable to allocate shared memory
Cause: See OSD error accompanying this message
Action: none
ORA-09367: Windows 3.1 Two-Task driver unable to deallocate shared memory
Cause: See OSD error accompanying this message
Action: none
ORA-09368: Windows 3.1 Two-Task driver unable to spawn ORACLE
Cause: See OSD error accompanying this message
Action: none
ORA-09369: Windows 3.1 Two-Task driver bad instance handle
Cause: See OSD error accompanying this message
Action: none
ORA-09370: Windows 3.1 Two-Task driver ORACLE task timed out
Cause: See OSD error accompanying this message
Action: none
ORA-09700: sclin: maximum number of latches exceeded
Cause: ORACLE wants to use more latches then available.
Action: increase INIT.ORA parameter latch_pages or decrease the amount of shared memory you are using.
ORA-09701: scnfy: maximum number of processes exceeded
Cause: PROCESSES INIT.ORA parameter exceeded.
Action: Decrease the PROCESSES parameter and restart.
ORA-09702: sem_acquire: cannot acquire latch semaphore
Cause: The semaphore used for accessing latches could not be seized
Action: Send trace file to your customer support representative, along with information on reproducing the error.
ORA-09703: sem_release: cannot release latch semaphore
Cause: The semaphore used for accessing latches could not be released
Action: Send trace file to your customer support representative, along with information on reproducing the error.
ORA-09704: sstascre: ftok error in creating test and set pages.
Cause: the ftok() library call failed in sstastcre().
Action: Verify that tasdef@.dbf file exists. If it does then this is a possible system failure. Perhaps System V compatibility is not enabled.
ORA-09705: spcre: cannot initialize latch semaphore
Cause: The semaphore used for accessing latches could not be initialized
Action: Send trace file to your customer support representative, along with information on reproducing the error.
ORA-09706: slsget: get_process_stats error.
Cause: get_process_stats system call returned an error. Possible OS error.
Action: Check additional information returned. Look for information in OS reference. Contact customer support.
ORA-09708: soacon: failed to bind socket to port.
Cause: The bind system call failed on the socket.
Action: Check additional information for OS error. Try connecting again.
ORA-09709: soacon: failed to accept a connection.
Cause: The accept system call failed on the socket.
Action: Check additional information for OS error. Try connecting again.
ORA-09710: soarcv: buffer overflow.
Cause: The internal buffer is not big enough to hold the message read.
Action: Internal error. Contact customer support representative.
ORA-09711: orasrv: archmon already connected.
Cause: An existing connection has already been made from archmon to orasrv.
Action: Stop trying to connect.
ORA-09712: orasrv: log archiver already connected.
Cause: An existing connection has already been made from log archiver to orasrv.
Action: Stop trying to connect.
ORA-09713: Global hardware clock failure caused instance termination.
Cause: The global hardware clock used to generate the System Change Number for Oracle has failed.
Action: Check the global hardware clock.
ORA-09714: Two Task interface: cannot obtain puname
Cause: The TXIPC driver cannot obtain the name of the PU. (Possible OS error)
Action: Check if the PUs are named (consistend).
ORA-09715: orasrv: cannot obtain puname
Cause: Orasrv cannot obtain the name of the PU. (Possible OS error)
Action: Check if the PUs are named (consistend).
ORA-09716: kslcll: Unable to fix in-flux lamport latch.
Cause: One Oracle process died while still holding a lamport latch.
Action: Exit (kill) all Oracle user processes. Shutdown (abort) and restart Oracle RDBMS kernel.
ORA-09717: osnsui: maximum number of user interrupt handlers exceeded.
Cause: The internal limit on the number of user interrupt handlers has been exceeded.
Action: Reduce the number of simulataneous logons or reduce the number of user interrupt handlers.
ORA-09718: osnsui: cannot set up user interrupt handler.
Cause: Malloc() failed to allocate space to hold user interrupt handler.
Action: Possible memory resource shortage.
ORA-09719: osncui: invalid handle.
Cause: The handle passed to osncui is out of the valid range.
Action: Use a valid handle.
ORA-09740: slsget: cannot get virtual memory region statistics.
Cause: The vm_region system call failed to get virual memory region statistics.
Action: Check return code in sercerrno. Possible operating system failure.
ORA-09741: spwat: error waiting for a post.
Cause: Msg_receive system call returned an error. Internal error.
Action: Check return code in sercerrno. Port name is returned in sercose[0].
ORA-09742: sppst: error during a post.
Cause: Msg_send system call returned an error. Internal error.
Action: Check return code in sercerrno. Port name is returned in sercose[0].
ORA-09743: smscre: could not attach shared memory.
Cause: The mmap or write system call returned an error. Internal error.
Action: Contact Oracle support.
ORA-09744: smsget: mmap returned an error.
Cause: The mmap system call returned an error. Internal error.
Action: Contact Oracle support.
ORA-09745: smscre: vm_allocate error, unable to create shared memory.
Cause: Error in system call vm_allocate. Failed to create SGA as a single shared memory segment.
Action: Check result code returned in sercerrno. Verify that the SGA attach address is valid.
ORA-09746: smscre: shared memory attach address incorrect.
Cause: The vm_allocate system call attached the SGA at an incorrect location.
Action: Verify that the SGA attach address is valid.
ORA-09747: pw_detachPorts: server call pws_detach failed.
Cause: The call pws_detach to (Oracle helper) failed.
Action: Make sure the server is still active. Check the error code returned in sercerrno, and look for error messages in the server log file.
ORA-09748: pws_look_up: fork failed
Cause: The pws_look_up call could not fork the (Oracle helper) process.
Action: Verify that there are enough system resources to support another process. The user or system process limit may have been exceeded, or the amount of free memory or swap space may be temporarily insufficient.
ORA-09749: pws_look_up: port lookup failure
Cause: The pws_look_up could not find a port to (Oracle helper).
Action: Make sure the (Oracle helper) server has been started correctly by pws_look_up, and that the network name server is still running.
ORA-09750: pw_attachPorts: port_rename failed.
Cause: The port_rename system call failed; possible internal error.
Action: Check return code in sercerrno, report to Oracle customer support.
ORA-09751: pw_attachPorts: server call pws_attach failed.
Cause: The call pws_attach to (Oracle helper) failed.
Action: Make sure the server is still active. Check the error code returned in sercerrno, and look for error messages in the server log file.
ORA-09752: pw_attachPorts: port_allocate failed.
Cause: The port_allocate system call failed; possible resource exhaustion.
Action: Check return code in sercerrno, report to Oracle customer support.
ORA-09753: spwat: invalid process number.
Cause: Function was passed an invalid oracle process id.
Action: Internal error. Additional information indicates the invalid process id.
ORA-09754: sppst: invalid process number passed to sppst.
Cause: Function was passed an invalid oracle process id.
Action: Internal error. Contact Oracle support.
ORA-09755: osngpn: port allocation failure.
Cause: The port_allocate system call failed.
Action: Possible system resource shortage; check the error code in sercerrno.
ORA-09756: osnpns: no port in the name server.
Cause: osnpns could not find the given named port in the name server.
Action: Check the error code in sercerrno. Make sure the shadow process and network name server are still running.
ORA-09757: osnipn: port allocation failure.
Cause: The port_allocate system call failed.
Action: Possible system resource shortage; check the error code in sercerrno.
ORA-09758: osnipn: could not check port in name server.
Cause: The netname_check_in call failed.
Action: Check the error code in sercerrno. Make sure the network name server is running.
ORA-09759: osnsbt: bad message received.
Cause: The msg_receive system call failed, or received a bad message.
Action: Internal error. Report the error code returned in sercerrno.
ORA-09760: osnpui: cannot send break message
Cause: The Pipe driver could not send a break message to the ORACLE shadow process break thread.
Action: Contact your customer support representative.
ORA-09761: pw_destroyPorts: server call pws_stop_instance failed.
Cause: The call pws_stop_instance to (Oracle helper) failed.
Action: Make sure the server is still active. Check the error code returned in sercerrno, and look for error messages in the server log file.
ORA-09762: sNeXT_instanceName: translation error.
Cause: A failure was detected while translating the value of ORACLE_SID.
Action: Make sure ORACLE_SID is defined, and that it is of legal length.
ORA-09763: osnmpx: send/receive error exchanging Mach ports.
Cause: The Mach driver failed to exchange port information with the other side of the connection. Either msg_send (sercose[0] == 1) or msg_receive (sercose[0] == 2) failed.
Action: Check return code in sercerrno. Make sure both sides of the connection are still running.
ORA-09764: osnmop: access error on oracle executable
Cause: The Mach driver could not access the oracle executable.
Action: Check the permissions on the ORACLE executable and each component of the ORACLE_HOME/bin path.
ORA-09765: osnmop: fork failed
Cause: The Mach driver could not fork the oracle shadow process.
Action: Verify that there are enough system resources to support another process. The user or system process limit may have been exceeded, or the amount of free memory or swap space may be temporarily insufficient.
ORA-09766: osnmop: buffer allocation failure.
Cause: The Mach driver failed to allocate enough vm space for its I/O buffers.
Action: Decrease the value of buffer_size parameter in the Two-Task driver hoststring.
ORA-09767: osnmfs: bad return code from msg_send.
Cause: The msg_send system call failed while flushing the Mach driver's send buffer.
Action: Internal error. Contact your customer support representative.
ORA-09768: osnmgetmsg: could not read a message
Cause: The msg_receive system call returned a failure code while waiting for a message in the Mach driver.
Action: Internal error. Contact your customer support representative.
ORA-09769: osnmbr: cannot send break message
Cause: The Mach driver could not send a break message to the ORACLE shadow process break thread.
Action: Internal error. Contact your customer support representative.
ORA-09770: pws_look_up: translation failure.
Cause: The pws_look_up routine failed to translate the name of the (Oracle helper) executable.
Action: Make sure ORACLE_SID and ORACLE_HOME are set and correct. Additional information gives the translation error code.
ORA-09771: osnmwrtbrkmsg: bad return code from msg_send.
Cause: The msg_send sytem call failed while sending a Mach driver break.
Action: Internal error. Contact your customer support representative.
ORA-09772: osnpmetbrkmsg: message from host had incorrect message type
Cause: The Mach driver received a message having an unrecognizable message type.
Action: Internal error. Contact your customer support representative.
ORA-09773: osnmgetdatmsg: message from host had incorrect message type
Cause: The Mach driver received a message having an unrecognizable message type.
Action: Internal error. Contact your customer support representative.
ORA-09774: osnmui: cannot send break message
Cause: The Mach driver could not send a break message to the ORACLE shadow process break thread.
Action: Internal error. Contact your customer support representative.
ORA-09775: osnmrs: reset protocol error
Cause: The Mach two-task driver could not reset the connection.
Action: Internal error. Contact your customer support representative.
ORA-09776: pws_look_up: access error on (Oracle helper) executable
Cause: The pws_look_up call could not access the (Oracle helper) executable.
Action: Check the permissions on the (Oracle helper) executable and each component of the ORACLE_HOME/bin path.
ORA-09777: osnpbr: cannot send break message
Cause: The pipe driver could not send a break message to the ORACLE shadow process break thread.
Action: Internal error. Contact your customer support representative.
ORA-09778: snynfyport: failure allocating the notify port.
Cause: The routine failed to allocate or set the task's notify port.
Action: Possible operating system error. Contact Oracle support.
ORA-09779: snyGetPort: failure to allocate a port.
Cause: The port_allocate system call failed; system resources might be exhausted.
Action: Possible operating system error. Contact Oracle support.
ORA-09786: sllfop: open error, unable to open file.
Cause: Open system call returned an error.
Action: Check errno.
ORA-09787: sllfop: unrecognizable processing option, incorrect format.
Cause: Processing option passed is of incorrect format.
Action: Consult your IUG for permissible formats.
ORA-09788: sllfrb: unable to read file.
Cause: Read system call returned an error.
Action: Check errno. Verify file exists.
ORA-09789: sllfsk: unable to read file.
Cause: Read system call returned an error.
Action: Check errno. Verify file exists.
ORA-09790: sllfcf: unable to close file.
Cause: Close system call returned an error.
Action: Check errno.
ORA-09791: slembdf: translation error, unable to translate error file name.
Cause: Additional information indicates error returned from sltln.
Action: Check additional information.
ORA-09792: sllfop: cannot allocate read buffer.
Cause: Malloc system call returned an error. The system might have run out of heap space.
Action: Check additional information for the OS error.
ORA-09793: szguns: length of user name is greater than buffer.
Cause: The length of the name of the user being looked up is longer than size of the buffer provided by the calling routine.
Action: This is an internal error. Contact ORACLE customer support.
ORA-09794: szrbuild: length of role name is greater than buffer.
Cause: The length of the name of the role being looked up is longer than size of the buffer provided by the calling routine.
Action: This is an internal error. Contact ORACLE customer support.
ORA-09795: szrbuild: malloc of role structure failed.
Cause: The allocation of memory for an internal structure used to hold a role descriptor failed.
Action: Check the UNIX error number for a possible operating system failure.
ORA-09796: szrbuild: malloc of role name failed.
Cause: The allocation of memory for an internal buffer used to hold the name of a role failed.
Action: Check the UNIX error number for a possible operating system failure.
ORA-09797: Failed to get O/S MAC privileges.
Cause: The operating system would not allow the retrieval of this process' privileges.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support.
ORA-09798: Label comparison failed.
Cause: The comparison of two binary labels failed.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support.
ORA-09799: File label retrieval failed.
Cause: ORACLE was unable to get a label attached to a file.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support.
ORA-09800: Process sensitivity label retrieval failed.
Cause: ORACLE was unable to get the sensitivity label for a process.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support.
ORA-09801: Unable to get user ID from connection
Cause: ORACLE was unable to retrieve the user's ID number from the SQL*Net connection.
Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact ORACLE support.
ORA-09802: Conversion of binary label to string failed.
Cause: ORACLE was unable to convert a binary label to a string.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support.
ORA-09803: Allocation of string buffer failed.
Cause: a buffer used to hold the name of the file for which a label was to be obtained could not be allocated.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support. The number of bytes that ORACLE attempted to allocate is in the "Additional Information" field.
ORA-09804: Class conversion from binary to ORACLE failed.
Cause: ORACLE was unable to convert a class component from binary format to ORACLE format.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support.
ORA-09805: conversion of category number to string failed.
Cause: ORACLE was unable to translate a category number to its corresponding string representation failed.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support. The category number is contained in the "Additional information" field.
ORA-09806: Allocation of label string buffer failed.
Cause: a temporary buffer used to hold a label could not be allocated.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support. The number of bytes that ORACLE attempted to allocate is in the "Additional Information" field.
ORA-09807: Conversion of label from string to binary failed.
Cause: ORACLE was unable to convert the string representation of a label to binary format.
Action: Re-enter a valid label.
ORA-09808: Could not obtain user clearance.
Cause: ORACLE was unable to get a user's clearance level.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support.
ORA-09809: Unable to get user's group ID from connection
Cause: ORACLE was unable to retrieve the user's group ID number from the SQL*Net connection.
Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact ORACLE support.
ORA-09810: Unable to get process ID from connection
Cause: ORACLE was unable to retrieve the user's process ID number from the SQL*Net connection.
Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact ORACLE customer support.
ORA-09811: Unable to initialize package.
Cause: ORACLE was unable to initialize the library used to obtain security information.
Action: This is an internal error. Contact ORACLE support.
ORA-09812: Unable to get user clearance from connection
Cause: ORACLE was unable to retrieve the user's operating system session clearance from the SQL*Net connection.
Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact ORACLE customer support.
ORA-09813: Unable to get directory status
Cause: ORACLE was unable to determine if a directory is multilevel.
Action: Check the UNIX error number for a possible operating system error. If there is no error, contact ORACLE customer support.
ORA-09814: Unable to expand file name
Cause: ORACLE was unable to expand the name of a file that resides in multilevel directory.
Action: Check the UNIX error number for a possible operating system error. If there is no error, contact ORACLE customer support.
ORA-09815: File name buffer overflow
Cause: The buffer that ORACLE uses to hold the expanded name of a too small.
Action: This is an internal error. Contact ORACLE customer support.
ORA-09817: Write to audit file failed.
Cause: ORACLE was unable to write an entry to the file used as the audit trail.
Action: Check the UNIX error number for a possible operating system error. If there is no error, contact ORACLE customer support.
ORA-09818: Number is too large
Cause: ORACLE was unable to convert a component string to a number because the number is larger than the largest possible value for an integer. The additional information field specifies the maximum.
Action: Correct the string and repeat the conversion.
ORA-09819: Number exceeds maximum legal value
Cause: the number specified for a component was greater than the maximum value allowed for that component.
Action: Change the component to a value less than the maximum and repeat the conversion. The maximum component number is contained in the "Additional information" field.
ORA-09820: Conversion of class string to numeric representation failed.
Cause: ORACLE was unable to convert a class string to a number because all of the characters in the string were not numeric.
Action: Change the string to be either all numbers or all non-numeric characters and repeat the conversion.
ORA-09821: Numeric label is not valid
Cause: A label specified in ORACLE numeric format was found not to be valid.
Action: Re-enter a valid label. Consult your system's encodings for valid numeric component values.
ORA-09822: Translation of audit file name failed.
Cause: ORACLE was unable to translate the value of the "audit_trail_dest" initialization parameter.
Action: Check the UNIX error number for a possible operating system error. If there is no error, contact ORACLE customer support.
ORA-09823: device name is too long
Cause: The name of a device was too long to fit into an internal buffer. The additional information field contains the length of the device name.
Action: This is an internal error. Contact ORACLE support.
ORA-09824: Unable to enable allowmacaccess privilege.
Cause: ORACLE was not able to turn on allowmacaccess privilege so that it could do a label comparison.
Action: Check the UNIX error number. If it indicates that ORACLE does not have the allowmacaccess privilege, add the allowmacaccess privilege to the potential privilege set of $ORACLE_HOME/bin/oracle using chpriv (1M). If the executable already has the allowmacaccess privilege, contact ORACLE support.
ORA-09825: Unable to disable allowmacaccess privilege.
Cause: ORACLE was not able to turn off the allowmacaccess privilege after doing a label comparison.
Action: This is an internal error. Contact ORACLE support.
ORA-09826: SCLIN: cannot initialize atomic latch.
Cause: System call atomic_op() return error.
Action: Check additional information in the trace file.
ORA-09827: SCLGT: atomic latch return unknown error.
Cause: System call atomic_op() return unexpected error.
Action: Check additional information in the trace file.
ORA-09828: SCLFR: atomic latch return error.
Cause: System call atomic_op() return unexpected error.
Action: Check additional information in the trace file.
ORA-09829: pw_createPorts: server call pws_start_instance failed.
Cause: The call pws_start_instance to (Oracle helper) failed; system resources might be exhausted.
Action: Make sure the server is still active. Check the error code returned in sercerrno, and look for error messages in the server log file.
ORA-09830: snyAddPort: failed to perform a remote procedure call.
Cause: The msg_rpc system call returned an error.
Action: Internal error. Contact Oracle support.
ORA-09831: snyStartThread: failed to build the server port set.
Cause: The routine failed to build a port set on which to listen for requests.
Action: Possible operating system failure. Contact Oracle support.
ORA-09832: infoCallback: bad message format.
Cause: The routine received an incorrectly formatted request.
Action: Internal error. Contact Oracle support.
ORA-09833: addCallback: bad message format.
Cause: The routine received an incorrectly formatted request.
Action: Internal error. Contact Oracle support.
ORA-09834: snyGetPortSet: failed to collect info on a port.
Cause: The port_status system called failed.
Action: Possible operating system error. Contact Oracle support.
ORA-09835: addCallback: callback port is already in a set.
Cause: The port to be added to the callback list is already in a port set.
Action: Internal error. Contact Oracle support.
ORA-09836: addCallback: could not add a port to the callback set.
Cause: The port_set_add system called failed.
Action: Possible operating system error. Contact Oracle support.
ORA-09837: addCallback: could not add allocate a callback link.
Cause: The malloc library call failed to allocate space for a callback link.
Action: Possible operating system error. Contact Oracle support.
ORA-09838: removeCallback: failure removing the callback port.
Cause: The port port_set_remove system call failed.
Action: Possible operating system error. Contact Oracle support.
ORA-09839: removeCallback: callback port is not in the callback set.
Cause: The port to be removed to the callback list is not in the callback port set.
Action: Internal error. Contact Oracle support.
ORA-09840: soacon: Name translation failure.
Cause: sltln() could not translate the named pipe ?/dbs/mon2arch_@.
Action: Make sure that the ORACLE_HOME specified for this ORACLE_SID in oratab is correct.
ORA-09841: soacon: Name translation failure.
Cause: sltln() could not translate the named pipe ?/dbs/arch2mon_@.
Action: Make sure that the ORACLE_HOME specified for this ORACLE_SID in oratab is correct.
ORA-09842: soacon: Archmon unable to create named pipe.
Cause: mknod() failed to create named pipe ?/dbs/mon2arch_@.
Action: Your current OS login may lack write permission for the ORACLE_HOME/dbs directory. Only userids in the dba group of a given instance can run archmon for that ORACLE_SID. Make sure that the ORACLE_HOME directory is correct in oratab.
ORA-09843: soacon: Archmon unable to create named pipe.
Cause: mknod() failed to create named pipe ?/dbs/arch2mon_@.
Action: Your current OS login may lack write permission for the ORACLE_HOME/dbs directory. Only userids in the dba group of a given instance can run archmon for that ORACLE_SID. Make sure that the ORACLE_HOME directory is correct in oratab.
ORA-09844: soacon: Archmon unable to open named pipe.
Cause: open() failed to open named pipe ?/dbs/mon2arch_@.
Action: Only the oracle dba can run archmon. Make sure that your current OS login has owner or group search permission for the ORACLE_HOME/dbs directory. The max number of open files may have been exceeded.
ORA-09845: soacon: Archmon unable to open named pipe.
Cause: open() failed to open named pipe ?/dbs/arch2mon_@.
Action: Only the oracle dba can run archmon. Make sure that your current OS login has owner or group search permission for the ORACLE_HOME/dbs directory. The max number of open files may have been exceeded.
ORA-09846: soacon: ARCH unable to open named pipe.
Cause: open() failed to open named pipe ?/dbs/mon2arch_@.
Action: Make sure that the OS userid of the currently running database has search permission for the ORACLE_HOME/dbs directory. The max number of open files may have been exceeded.
ORA-09847: soacon: ARCH unable to open named pipe.
Cause: open() failed to open named pipe ?/dbs/arch2mon_@.
Action: Make sure that the OS userid of the currently running database has search permission for the ORACLE_HOME/dbs directory. The max number of open files may have been exceeded.
ORA-09850: soacon: Archmon unable to lock named pipe.
Cause: fcntl() failed to set write lock on named pipe ?/dbs/arch2mon_@.
Action: Make sure that archmon is not already active on another terminal for this ORACLE_SID. Only one archmon session is allowed at a time for a given instance.
ORA-09851: soacon: Archmon unable to lock named pipe.
Cause: fcntl() failed to set read lock on named pipe ?/dbs/mon2arch_@.
Action: Make sure that archmon is not already active on another terminal for this ORACLE_SID. Only one archmon session is allowed at a time for a given instance.
ORA-09853: snyRemovePort: bad return code from request.
Cause: The request to remove a port from the callback set returned a failure code.
Action: Possible operating system error. Contact Oracle support.
ORA-09854: snyPortInfo: bad return code from request.
Cause: The request to collect info on a port in the callback set returned a failure code.
Action: Possible operating system error. Contact Oracle support.
ORA-09855: removeCallback: bad message format.
Cause: The routine received an incorrectly formatted request.
Action: Internal error. Contact Oracle support.
ORA-09856: smpalo: vm_allocate error while allocating pga.
Cause: The vm_allocate system call returned an error.
Action: Check returned error. Possibly out of system resources.
ORA-09857: smprset: vm_protect error while protecting pga.
Cause: The vm_protect system call returned an error.
Action: Internal error. Contact Oracle support.
ORA-09858: sfngat: the input file name is not in the OMF format
Cause: The function sfngat() received a filename which is not an OMF file name.
Action: Further diagnostic information should be in the error stack.
ORA-09859: sfngat: the input file name is not in the autobackup OMF format
Cause: The function sfngat() received a filename which is not an autobackup OMF file name.
Action: Further diagnostic information should be in the error stack.


8 ORA-09870 to ORA-12100

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

8 ORA-09870 to ORA-12100

ORA-09870: spini: failure initializing maximum number of open files.
Cause: ulimit system call returned an error.
Action: Check errno.
ORA-09871: TASDEF_NAME: translation error while expanding ?/dbs/tasdef@.dbf.
Cause: Failure of sltln(?/tasdef@.dbf) while creating test and set pages.
Action: Check additional return error for more information.
ORA-09872: TASDEF_CREATE: create failure in creating ?/dbs/tasdef@.dbf.
Cause: Create() failed when trying to create the tasdef file.
Action: Verify permissions on $(ORACLE_HOME)/dbs directory.
ORA-09873: TASDEF_OPEN: open error when opening tasdef@.dbf file.
Cause: Unable to open tasdef@.dbf file.
Action: Check errno. Possible permission problem. Verify that tasdef@.dbf file exists.
ORA-09874: TASDEF_READ: read error, unable to read tasdef@.dbf file.
Cause: Read system call returned an error when attempting to read ?/dbs/tasdef@.dbf.
Action: Check errno returned. Sgadef file may be corrupted or incompatible with oracle version.
ORA-09875: TASDEF_WRITE: write error when writing ?/dbs/tasdef@.dbf file.
Cause: Write call failed.
Action: Check errno returned. Possibly out of space on device.
ORA-09876: TASDEF_CLOSE: unable to close ?/dbs/tasdef@.dbf file.
Cause: Close system call returned an error.
Action: Check errno returned. Possible operating system failure.
ORA-09877: sstascre: shmget error, unable to get a shared memory segment.
Cause: Error in shmget.
Action: Check errno returned. Verify that enough shared memory is available on the system.
ORA-09878: sstascre/sstasat: shmat error, unable to attach tas write page
Cause: Error in shmat.
Action: Check errno returned.Verify that enough shared memory is available on the system.
ORA-09879: sstascre/sstasat: shmat error, unable to attach tas read page
Cause: Error in shmat.
Action: Check errno returned.Verify that enough shared memory is available on the system.
ORA-09880: sstasfre/sstasdel: shmdt error, unable to detach tas write page
Cause: Error in shmdt.
Action: Check errno returned.
ORA-09881: sstasfre/sstasdel: shmdt error, unable to detach tas read page
Cause: Error in shmdt.
Action: Check errno returned.
ORA-09882: sstasfre/sstasdel: shmctl error, unable to remove tas shm page
Cause: Error in shmctl.
Action: Check errno returned.
ORA-09883: Two Task interface: oratab file does not exist
Cause: The oratab file does not exist.
Action: Install oracle before you use it or recreate the oratab file.
ORA-09884: Two Task interface: SID doens't match current PU
Cause: You are trying to start oracle on another PU than you configured oracle on or there is no entry for this SID in oratab file.
Action: Start oracle with this SID on its designated PU (see oratab file). Or install the new database with SID.
ORA-09885: osnTXtt: cannot create TXIPC channel
Cause: The TXIPC driver failed to create pipes for two-task communications with the oracle shadow process.
Action: You have probably exceeded the maximum number of open file descriptors per user or the system file table is full. Note the operating system error code and contact your system administrator.
ORA-09886: osnTXtt: translation error while expanding txipc@.trc.
Cause: Failure of sltln(txipc@.trc) while creating debug channel.
Action: Check additional return error for more information.
ORA-09888: osnTXtt: txipc channel creation failed
Cause: The txipc driver failed to create channels for two-task communications with the oracle shadow process.
Action: You have probably exceeded the maximum number of open file descriptors per user or the system file table operating system error code and contact your system administrator.
ORA-09889: osnTXtt: access error on oracle executable
Cause: The txipc driver could not access the oracle executable.
Action: Check the permissions on the ORACLE executable and each component of the ORACLE_HOME/bin path.
ORA-09890: osnTXtt: malloc failed
Cause: The txipx driver failed to allocate enough heap space for its context area buffers.
Action: Contact your customer support representative.
ORA-09908: slkmnm: gethostname returned error code.
Cause: The system call gethostname returned an error.
Action: This is most likely an internal error. Make sure gethostname is successful in other contexts, and if so contact Oracle support.
ORA-09909: Malloc of scratch buffer failed.
Cause: Memory needed for a temporary buffer could not be allocated. The additional information field contains the number of bytes that ORACLE attempted to allocate.
Action: Check the UNIX error number. It is probable that the system has run out of memory. If there is no error, contact ORACLE support.
ORA-09910: Unable to find ORACLE password file entry for user.
Cause: No entry exists for the user in the ORACLE password file.
Action: Have the database administrator install a password entry by running orapasswd.
ORA-09911: Incorrect user password.
Cause: The password entered by the user was incorrect.
Action: Enter the correct password.
ORA-09912: Malloc of name buffer(s) failed.
Cause: ORACLE was unable to allocate memory for one or both of the buffers that are used to hold the name of DBA and the operator users.
Action: Check the UNIX error number. It is probable that the system has run out of memory. If there is no error, contact ORACLE support.
ORA-09913: Malloc of dummy name failed.
Cause: ORACLE was unable to allocate memory for the user name that is to to be used in the encryption of the user's password.
Action: Check the UNIX error number. It is probable that the system has run out of memory. If there is no error, contact ORACLE support.
ORA-09914: Unable to open the ORACLE password file.
Cause: ORACLE could not open the password file for reading.
Action: Check the UNIX error number. If the error number indicates that the file does not exist, have the database administrator create the file by running orapasswd. If the error number indicates insufficient permissions, ask the database administrator to change the permissions. Otherwise, contact ORACLE customer support.
ORA-09915: Password encryption failed.
Cause: ORACLE was unable to encrypt a password.
Action: This is an internal error - contact ORACLE customer support.
ORA-09916: Required password was not specified.
Cause: A user attempted to connect as "internal," but did not specify a password.
Action: Connect as internal again and specify a password.
ORA-09918: Unable to get user privileges from SQL*Net
Cause: ORACLE was unable to retrieve the user's privilege set from the SQL*Net connection.
Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact ORACLE support.
ORA-09919: Unable to set label of dedicated server
Cause: ORACLE was unable to set the label of the dedicated to server to the required value.
Action: Check the UNIX error number for a possible operating system error. Also, check the privileges on the oracle executable. It should have at least "allowmacaccess" privilege.
ORA-09920: Unable to get sensitivity label from connection
Cause: ORACLE was unable to retrieve the user's sensitivity label from the SQL*Net connection.
Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact ORACLE support.
ORA-09921: Unable to get information label from connection
Cause: ORACLE was unable to retrieve the user's information label from the SQL*Net connection.
Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact ORACLE support.
ORA-09922: Can't spawn process - background log directory not created properly
Cause: ORACLE was unable to spawn a background process because the directory that will hold trace files of the background processes was not created properly.
Action: Examine the directory pointed to by the initialization parameter "background_dump_dest". Make sure that all of the following is true:

1. The directory exists.

2. The name indeed points to a directory, and is not a file.

3. The directory is accessible and writable to the ORACLE user.

ORA-09923: Can't spawn process - user log directory not created properly
Cause: ORACLE was unable to spawn a background process because the directory that holds the trace files of the dedicated server processes was not created properly.
Action: Examine the directory pointed to by the initialization parameter "user_dump_dest". Make sure that all of the following is true:

1. The directory exists.

2. The name indeed points to a directory, and is not a file.

3. The directory is accessible and writable to the ORACLE user.

ORA-09924: Can't spawn process - core dump directory not created properly
Cause: ORACLE was unable to spawn a background process because the directory that holds the core dumps produced by ORACLE processes in the event of exceptions was not created properly.
Action: Examine the directory pointed to by the initialization parameter "core_dump_dest". Make sure that all of the following is true:

1. The directory exists.

2. The name indeed points to a directory, and is not a file.

3. The directory is accessible and writable to the ORACLE user.

ORA-09925: Unable to create audit trail file
Cause: ORACLE was not able to create the file being used to hold audit trail records.
Action: Check the UNIX error number for a possible operating system error. If there is no error, contact ORACLE customer support.
ORA-09926: Unable to set effective privilege set of the server
Cause: A dedicated server was unable to set it's own privilege set.
Action: Check the privileges granted to the ORACLE executable. It must have at least "allowmacacess" privilege.
ORA-09927: Unable to set label of server
Cause: ORACLE was not able to set the label of a server to a new value.
Action: Check the privileges on $ORACLE_HOME/bin/oracle. Make sure that it has "allowmacaccess" privilege.
ORA-09928: Unable to restore the label of server
Cause: ORACLE was unable to restore the label of the server to the value that it had before raising it to database high.
Action: This is an internal error - contact ORACLE support.
ORA-09929: GLB of two labels is invalid
Cause: The result of a greatest lower bound operation on two labels was not valid.
Action: Repeat the operation with two different labels. Consult the system encoding file for the values of valid labels.
ORA-09930: LUB of two labels is invalid
Cause: The result of a least upper bound operation on two labels was not valid.
Action: Repeat the operation with two different labels. Consult the system encoding file for the values of valid labels.
ORA-09931: Unable to open ORACLE password file for reading
Cause: An attempt to open a password file for reading failed.
Action: Make sure that the permissions on the file have not been changed so that the ORACLE user cannot open it.
ORA-09932: Close of ORACLE password file failed.
Cause: An attempt to close a password file failed.
Action: Check the UNIX error number for the specific reason.
ORA-09933: Deletion of old password file failed.
Cause: The removal of the old password file failed.
Action: Check the UNIX error number for the specific reason.
ORA-09934: Link of current password file to old failed.
Cause: ORACLE was unable to create a link so that the old password file could be saved.
Action: Check the UNIX error number for the specific reason.
ORA-09935: Unlink of current password file failed.
Cause: ORACLE was unable to complete the saving of the current password file.
Action: Check the UNIX error number for the specific reason.
ORA-09936: Open of ORACLE password file for write failed.
Cause: ORACLE was unable to create a password file.
Action: Check the UNIX error number for the specific reason.
ORA-09937: Chmod of ORACLE password file failed.
Cause: ORACLE was unable to change a password file to be readonly.
Action: Check the UNIX error number for the specific reason.
ORA-09938: Save of signal handlers failed.
Cause: ORACLE was unable to save the previous values of selected signal handlers.
Action: This is an internal error. Contact ORACLE support.
ORA-09939: Restoration of signal handlers failed.
Cause: ORACLE was unable to restore the previous values of selected signal handlers.
Action: This is an internal error. Contact ORACLE support.
ORA-09940: ORACLE password file header is corrupt
Cause: The header of one of the password files was not in the format that ORACLE expected.
Action: Check the headers of both files. The header should be in the format "FILE VERSION: N.N.N.N.N EXECUTABLE VERSION: N.N.N.N.N" where N is a number. Remove the corrupt file(s) and re-run "orapasswd".
ORA-09941: Version of orapasswd or installer is older than file.
Cause: The version of orapasswd or installer that is being run is older than that of the ORACLE password file. Since the file version is only changed when the format is changed, this error means that the executable is using a different format than that with which the file was created.
Action: Run a version of the installer or orapasswd whose version is the same or later than that of the file.
ORA-09942: Write of ORACLE password file header failed.
Cause: The attempt to write out the header of the ORACLE password file failed.
Action: Check the operating system error number. It is possible that the file system became full.
ORA-09943: Allocation of memory for password list component failed.
Cause: When it is building a list of password file entries, ORACLE allocates memory for various components. One of the allocations failed.
Action: Check the operating system error number. The system has probably run out of memory.
ORA-09944: Password entry is corrupt.
Cause: An entry in an ORACLE password file was not in the format that ORACLE expected.
Action: Removed the corrupt file(s) and re-run "orapasswd."
ORA-09945: Unable to initialize the audit trail file
Cause: ORACLE unable to write header information to the file being used as the audit trail.
Action: Check the UNIX error number for a possible operating system error. If there is no error, contact ORACLE customer support.
ORA-09946: File name too long for buffer
Cause: The buffer that was to be used to hold a file name was determined to be too short for the generated name. This will happen if the translated name for either a trace file or an audit file is longer than the maximum allowed, which on many ports is 256 characters.
Action: Use a shorter file name.
ORA-09947: Unable to allocate connection attributes structure
Cause: ORACLE was not able to allocate the memory needed to hold the attributes of the SQL*Net connection. The "Additional Information" field holds the number of bytes that ORACLE attempted to allocate.
Action: Check the UNIX error number. It is probable that the system has run out of memory. If there is no error, contact ORACLE customer support.
ORA-09948: Process information label retrieval failed.
Cause: ORACLE was unable to get the information label for a process.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support.
ORA-09949: Unable to get client operating system privileges
Cause: ORACLE was unable to get the operating system privileges for the client process.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support.
ORA-09950: Unable to get server operating system privileges
Cause: ORACLE was unable to get its privileges from the operating system.
Action: This is an error that should never happen. Contact ORACLE customer support.
ORA-09951: Unable to create file
Cause: ORACLE was unable to create a file.
Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact ORACLE support.
ORA-09952: scgcmn: lk_open_convert unexpected return: open failed
Cause: The distributed lock manager returned an unexpected value
Action: Check for system error message and refer to the distributed lock manager documentation or contact your customer support representative.
ORA-09953: scggc: unexpected return of a lock convert
Cause: The distributed lock manager returned an unexpected value
Action: Check for lock manager error message and refer to DLM documentation refer to the distributed lock manager documentation or contact your customer support representative.
ORA-09954: scgcc: unexpected return status to callback of lock close
Cause: The distributed lock manager returned an unexpected value
Action: Check for lock manager error message and refer to DLM documentation refer to the distributed lock manager documentation or contact your customer support representative.
ORA-09955: scgcan: unexpected return status when canceling a lock
Cause: DLM system service x returned an unexpected value
Action: Check for system error message and refer to DLM documentation refer to the distributed lock manager documentation or contact your customer support representative.
ORA-09956: scgcm: unexpected lock status condition
Cause: A global locking system service returned an unexpected value.
Action: Check for system error message (if any) and refer to refer to the distributed lock manager documentation or contact your customer support representative.
ORA-09957: Unable to send termination request to IMON
Cause: The attempt to send a termination signal to IMON failed.
Action: This is an internal error, contact ORACLE support.
ORA-09958: IMON: two processes with the same ORACLE pid are active
Cause: The IMON process was unable to add an entry for a server process because another active process occupies the slot.
Action: This is an internal error, contact ORACLE support.
ORA-09959: IMON: deletion of a process failed.
Cause: The IMON process was unable to delete a server process from its process ID array because no entry for the process could be found.
Action: This is an internal error, contact ORACLE support.
ORA-09960: Unable to establish signal handler for termination signal
Cause: ORACLE was unable to set up a handler for the signal used to notify it that the instance was shutting down.
Action: This is an internal error, contact ORACLE support.
ORA-09961: Unable to restore termination signal handler
Cause: ORACLE failed to set the handler for the termination signal to its previous value.
Action: This is an internal error, contact ORACLE support.
ORA-09966: scumnt: translation error while expanding ?/dbs/lk
Cause: Failure of sltln in scumnt
Action: Check additional return error for more information.
ORA-09967: scumnt: unable to create or open file
Cause: open system call returned an error
Action: check errno
ORA-09968: scumnt: unable to lock file
Cause: lock file operating system call returned an error
Action: check errno
ORA-09969: scurls: unable to close lock file
Cause: close system call returned an error
Action: check errno
ORA-09974: skxfidini: Error Initializing SDI Channel
Cause: The process was unable to initialize the SDI channel properly.
Action: Correct the operating system error and retry the operation.
ORA-09975: kxfspini: Error Initializing SDI Process
Cause: The process was unable to attach to the SDI channel.
Action: Verify that the SDI process specific limits correctly configured. Correct the operating system error and retry the operation.
ORA-09976: skxfqdini: Error Creating Port
Cause: The process was unable to create a communications endpoint.
Action: Verify that the SDI port specific limits correctly configured. Correct the operating system error and retry the operation.
ORA-09977: skxfqhini: Error Connecting
Cause: The process was unable to connect to another endpoint.
Action: Verify that the SDI port specific limits correctly configured. Check that the other node(s) is part of the cluster and operating properly. Correct the operating system error and retry the operation.
ORA-09978: skxfqhdel: Error Disconnecting from another endpoint.
Cause: The process was unable to disconnect cleanly from another endpoint.
Action: Check that the other node(s) are part of the cluster and operating properly. Check the instance and processes on the other node(s). Correct the operating system error and retry the operation.
ORA-09979: skxfqhsnd: Error Sending a message to another endpoint
Cause: The process was unable to send a message to an existing endpoint.
Action: Check that the other node(s) are part of the cluster and operating properly. Check the instance and processes on the other node(s). Correct the operating system error and retry the operation.
ORA-09980: skxfqdrcv: Error Receiving a message from another endpoint
Cause: The process encountered an error while trying to receive a message.
Action: Check that the other node(s) are part of the cluster and operating properly. Check the instance and processes on the other node(s). Correct the operating system error and retry the operation.
ORA-09981: skxfqdreg: Error Adding a page to the SDI buffer pool
Cause: The process was unable to add a page to the SDI buffer pool.
Action: Correct the operating system error and retry the operation.
ORA-09982: skxfqddrg: Error Removing a page from the SDI buffer pool
Cause: The process was unable to remove a page to the SDI buffer pool.
Action: Correct the operating system error and retry the operation.
ORA-09983: skxfidsht: Error shutting down SDI channel
Cause: The process was unable shut down the SDI channel
Action: Check the SDI persistent resources using SDI tools. Verify that all processes exited cleanly and the instance is safely shut down. Delete any remaining SDI channel IDs associated with the current instance.
ORA-09984: SGA file $ORACLE_HOME/dbs/sgadef$ORACLE_SID.dbf does not exist
Cause: file does not exist or is not accessible
Action: Restart the instance to create the SGA definition file.
ORA-09985: SGA definition file could not be read
Cause: UNIX read() operation failed
Action: check errno and take appropriate action.
ORA-09986: wrong number of bytes read from SGA definition file
Cause: Struct skgmsdef size differs from no. of bytes read from SGA file
Action: Compare the two struct definitions and ensure that they are identical in size and structure.
ORA-09987: unable to attach to SGA in READ-ONLY mode
Cause: The instance is not up, or SGA segments are not read-accessible
Action: Verify that the instance is up and read permissions for the SGA segments are set.
ORA-09988: error while detaching SGA
Cause: skgmsdef struct is corrupted and/or segment addresses are modified
Action: Safely shut down instance and mount SGA segments again.
ORA-09989: attempt to use invalid skgmsdef struct pointer
Cause: Pointer to skgmsdef struct used without validating it
Action: Assign a valid address to the skgmsdef struct pointer before using it.
ORA-10560: block type 'string'
Cause: Report block type for details of another error.
Action: See associated error message.
ORA-10561: block type 'string', data object# string
Cause: Report block type and data object number for details of another error.
Action: See associated error message.
ORA-10562: Error occurred while applying redo to data block (file# string, block# string)
Cause: See other errors on error stack.
Action: Investigate why the error occurred and how important is the data block. Media and standby database recovery usually can continue if user allows recovery to corrupt this data block.
ORA-10563: Test recovery had to corrupt data block (file# string, block# string) in order to proceed
Cause: Test recovery completed.
Action: No action is needed. Test recovery has ended successfully. See other messages on error stack for a summary of the result of the test recovery.
ORA-10564: tablespace string
Cause: Report tablespace name for details of another error.
Action: See associated error message.
ORA-10565: Another test recovery session is active
Cause: There can only be one test recovery session at any time. Another test recovery session is active.
Action: Wait till the other test recovery session completes.
ORA-10566: Test recovery has used all the memory it can use
Cause: Test recovery tests redo in memory. It can no longer proceed because it has consumed all the memory it can use.
Action: No action is needed. Test recovery has ended successfully. See other messages on error stack for a summary result of the test recovery.
ORA-10567: Redo is inconsistent with data block (file# string, block# string)
Cause: There are two possible causes of this error: (1) A write issued by Oracle was lost by the underlying OS or storage system. (2) an Oracle internal error.
Action: Investigate why the error occurred and how important is the data block. Media and standby database recovery usually can continue if user allows recovery to corrupt this data block.
ORA-10568: Failed to allocate recovery state object: out of SGA memory
Cause: out of SGA memory
Action: Restart the instance. If problem persists, call Oracle support.
ORA-10570: Test recovery complete
Cause: Test recovery completed.
Action: No action is needed. Test recovery has ended successfully. See other messages on error stack for a summary result of the test recovery.
ORA-10571: Test recovery canceled
Cause: User canceled test recovery.
Action: No action is needed. Test recovery has ended successfully. See other messages on error stack for a summary of the result of the test recovery.
ORA-10572: Test recovery canceled due to errors
Cause: See other errors on the error stack.
Action: is needed. See other messages on error stack for a summary of the result of the test recovery so far.
ORA-10573: Test recovery tested redo from change string to string
Cause: This message show the range of test recovery have tested.
Action: No action is needed. See other messages on error stack.
ORA-10574: Test recovery did not corrupt any data block
Cause: This message summarizes test recovery result.
Action: No action is needed. See other messages on error stack.
ORA-10575: Give up restoring recovered datafiles to consistent state: out of memory
Cause: There were not enough memory to restore recovered datafiles to consistent state
Action: This error is just a warning: You may not be able to open the database with resetlogs immediately after this error. However, you may continue media/standby recovery, and that may make the datafiles recovered consistent again.
ORA-10576: Give up restoring recovered datafiles to consistent state: some error occurred
Cause: See alert file or other errors on the stack for a cause of the problem.
Action: This error is just a warning: You may not be able to open the database with resetlogs immediately after this error. However, you may continue media/standby recovery, and that may make the datafiles recovered consistent again.
ORA-10577: Can not invoke test recovery for managed standby database recovery
Cause: Test recovery option is used for managed standby database recovery.
Action: Either remove the test recovery option or invoke manual test standby database recovery.
ORA-10578: Can not allow corruption for managed standby database recovery
Cause: You used the allow corruption option for managed standby database recovery.
Action: Either remove the allow corruption option or invoke manual standby database recovery.
ORA-10579: Can not modify control file during test recovery
Cause: To proceed with recovery, test recovery needs to modify the control file. But test recovery is not allowed to modify controlfile.
Action: No action is needed. Test recovery has ended successfully. It can only go so far in the redo stream.
ORA-10580: Can not modify datafile header during test recovery
Cause: To proceed with recovery, test recovery needs to modify a datafile header. But test recovery is not allowed to modify datafile headers.
Action: No action is needed. Test recovery has ended successfully. It can only go so far in the redo stream.
ORA-10581: Can not modify redo log header during test recovery
Cause: To proceed with recovery, test recovery needs to modify a redo log header. But test recovery is not allowed to modify redo log headers.
Action: No action is needed. Test recovery has ended successfully. It can only go so far in the redo stream.
ORA-10582: The control file is not a backup control file
Cause: User requested backup control file test recovery, but the control file is not a backup control file.
Action: Use a backup control file, or do not use USING BACKUP CONTROLFILE option.
ORA-10583: Can not recovery file string renamed as missing during test recovery
Cause: One of the files to be recovered is renamed as missing.
Action: Rename the file to the correct file or offline it.
ORA-10584: Can not invoke parallel recovery for test recovery
Cause: Both test recovery and parallel recovery are requested.
Action: Drop either one of the two recovery options.
ORA-10585: Test recovery can not apply redo that may modify control file
Cause: Test recovery has encountered a special redo that may modify control file.
Action: No action is needed. Test recovery has proceeded successfully as far as it could from its starting point.
ORA-10586: Test recovery had to corrupt 1 data block in order to proceed
Cause: This message summarizes test recovery result: Oracle may have to corrupt one block in order to apply the range of redo tested.
Action: See alert log for details of the problem.
ORA-10587: Invalid count for ALLOW n CORRUPTION option
Cause: The number specified in the ALLOW n CORRUPTION option is too big.
Action: Use a smaller number.
ORA-10588: Can only allow 1 corruption for normal media/standby recovery
Cause: The number specified in the ALLOW n CORRUPTION option is too big.
Action: change to allow zero or one corruption.
ORA-10589: Test recovery had to corrupt string data blocks in order to proceed
Cause: This message summarizes test recovery result: Oracle may have to corrupt a number of data blocks as specified in the message in order to apply the range of redo tested.
Action: See alert log for details of the problems.
ORA-10614: Operation not allowed on this segment
Cause: This procedure can be used only on segments in tablespaces with AUTO SEGMENT SPACE MANAGEMENT
Action: Recheck the segment name and type and re-issue the statement
ORA-10615: Invalid tablespace type for temporary tablespace
Cause: Tablespace with AUTO SEGMENT SPACE MANAGENEMT specified cannot be used as a temporary tablespace
Action: Recheck the tablespace name and re-issue the statement
ORA-10616: Operation not allowed on this tablespace
Cause: Cannot perform the operation on tablespace with AUTO SEGMENT SPACE MANAGEMENT
Action: Recheck the tablespace name and re-issue the statement
ORA-10617: Cannot create rollback segment in dictionary managed tablespace
Cause: Rollback segments cannot be created in dictionary managed tablespaces when SYSTEM tablespace is locally managed
Action: Recheck the tablespace name and re-issue the statement
ORA-10618: Operation not allowed on this segment
Cause: This DBMS_SPACE operation is not permitted on segments in tablespaces with AUTO SEGMENT SPACE MANAGEMENT
Action: Recheck the segment name and type and re-issue the statement
ORA-10619: Avoid assertions when possible
Cause: A bug (or upgrade) hits unicode assertions (csid, csform, bfc)
Action: Event makes RDBMS skip assertions and patch up datastructures
ORA-10620: Operation not allowed on this segment
Cause: Cannot alter freelist storage parameter for segments in tablespaces with AUTO SEGMENT SPACE MANAGEMENT
Action: Recheck the segment name and re-issue the statement
ORA-10621: data block does not belong to the segment
Cause: The specified file number and block number of the data block does not belong to the segment
Action: Recheck the segment, file number, block number and re-issue the statement
ORA-10630: Illegal syntax specified with SHRINK clause
Cause: An illegal option was specified with the SHRINK clause
Action: Verify the SQL Reference Manual and reissue the command
ORA-10631: SHRINK clause should not be specified for this object
Cause: It is incorrect to issue shrink on the object
Action: Verify the object name and type and reissue the command
ORA-10632: Invalid rowid
Cause: Segment Highwatermark was overwritten due to shrink and space reused
Action: Reissue this command.
ORA-10633: No space found in the segment
Cause: Raised while trying to find space during segment shrink
Action: This error should be trapped internally and treated. The user should not be able to see the error.
ORA-10634: Segment is already being shrunk
Cause: Only one invocation of shrink can be in progress on a segment at any time
Action: Reissue the command after the first shrink is over
ORA-10635: Invalid segment or tablespace type
Cause: Cannot shrink the segment because it is not in auto segment space managed tablespace or it is not a data, index or lob segment.
Action: Check the tablespace and segment type and reissue the statement
ORA-10636: ROW MOVEMENT is not enabled
Cause: To shrink a data segment, row movement must be enabled.
Action: Enable row movement and reissue this command.
ORA-10637: The segment does not exist
Cause: Segment to be shrunk has been dropped
Action: none
ORA-10638: Index status is invalid
Cause: Cannot shrink an index which is being rebuilt or disabled is an unusable state.
Action: none
ORA-10640: Operation not permitted during SYSTEM tablespace migration
Cause: SYSTEM tablespace is being migrated to locally managed format.
Action: Reissue this command once SYSTEM tablespace migration is over.
ORA-10641: Cannot find a rollback segment to bind to
Cause: SYSTEM tablespace migration requires rollback segment in locally managed tablespace.
Action: Drop rollback segments in dictionary managed tablespaces other than SYSTEM and create rollback segments in locally managed tablespace and retry migration.
ORA-10642: Found rollback segments in dictionary managed tablespaces
Cause: When SYSTEM tablespace is migrated found rollback segments in dictionary managed tablespaces.
Action: Drop the rollback segments in dictionary managed tablespaces and reissue the command
ORA-10643: Database should be mounted in restricted mode and Exclusive mode
Cause: When SYSTEM tablespace is being migrated database should be mounted in Exclusive mode and in Restricted mode.
Action: Reissue this command after mounting the database in right mode.
ORA-10644: SYSTEM tablespace cannot be default temporary tablespace
Cause: When SYSTEM tablespace is being migrated no user should have SYSTEM as the default temporary tablespace.
Action: Reissue this command after altering the default temporary tablespace setting for all users.
ORA-10645: Recursive Extension in SYSTEM tablespace during migration
Cause: When SYSTEM tablespace is being migrated, dictionary tables tried to extend recursively. Must be caught and processed internally. Should not be thrown to the user.
Action: Report the error as a bug.
ORA-10646: Too many recursive extensions during SYSTEM tablespace migration
Cause: When SYSTEM tablespace is being migrated, dictionary tables tried to extend recursively more than 1000 times.
Action: If SYSTEM tablespace is very large, then simply reissue the tablespace migration command.
ORA-10647: Tablespace other than SYSTEM, string, string not found in read only mode
Cause: When SYSTEM tablespace is being migrated, tablespaces other than the three should be ALTERed to read only.
Action: Alter the tablespace status to read only and retry migration.
ORA-10648: Tablespace SYSAUX is not offline
Cause: The SYSAUX tablespace was online while SYSTEM tablespace was being migrated.
Action: Alter the SYSAUX tablespace status to offline and retry migration.
ORA-10651: incorrect file number block number specified
Cause: The dba specified is not valid
Action: Check if the dba specified belongs to the segment and is under the segment HWM and reissue the statement
ORA-10652: Object has on-commit materialized views
Cause: It is illegal to issue shrink on an object with on-commit materialized views
Action: none
ORA-10653: Table is in a cluster
Cause: It is illegal to shrink a table belonging to a cluster
Action: none
ORA-10654: Table is of type temporary or external
Cause: It is illegal to shrink a temporary table or an external table
Action: none
ORA-10655: Segment can be shrunk
Cause: Error message returned when called in probe mode by OEM
Action: none
ORA-10656: Table is unusable due to incomplete operation
Cause: Cannot shrink a table that is marked unusable due to an incomplete operation
Action: none
ORA-10657: Lob column to be shrunk does not exist
Cause: Shrink was issued on a lob segment that did not exist
Action: none
ORA-10658: Lob column to be shrunk is marked unused
Cause: Shrink was issued on a lob segment that is marked as unused
Action: none
ORA-10659: Segment being shrunk is not a lob
Cause: Shrink was issued on a segment that should be a first class lob or other data type stored in lob
Action: none
ORA-10660: Segment is a shared lob segment
Cause: Shrink was issued on a segment that was being shared by multiple lob columns
Action: none
ORA-10661: Invalid option specified
Cause: Check option can be specified for one segment only
Action: none
ORA-10662: Segment has long columns
Cause: Shrink was issued on a segment with long columns. This is not supported.
Action: none
ORA-10663: Object has rowid based materialized views
Cause: Shrink was issued on an object with rowid based materialized views.
Action: Drop the rowid based materialized views and issue shrink on the object
ORA-10906: Unable to extend segment after insert direct load
Cause: This is a restriction with insert direct load transactions.
Action: When a segment has been insert direct loaded, avoid DMLs that could cause more space to be consumed.
ORA-10914: invalid TABLESPACE GROUP clause
Cause: An invalid option appears for TABLESPACE GROUP clause.
Action: Specify a valid tablespace group name.
ORA-10915: TABLESPACE GROUP cannot be specified for this type of tablespace
Cause: In CREATE/ALTER TABLESPACE, the TABLESPACE GROUP clause was used while creating/altering a tablespace that is not TEMPORARY.
Action: Remove the TABLESPACE GROUP clause.
ORA-10916: TABLESPACE GROUP already specified
Cause: In CREATE/ALTER TABLESPACE, the TABLESPACE GROUP option was specified more than once.
Action: Remove all but one of the TABLESPACE GROUP specifications.
ORA-10917: TABLESPACE GROUP cannot be specified
Cause: The tablespace name specified in the command is actually the name of a tablespace group.
Action: Please specify an appropriate tablespace name.
ORA-10918: TABLESPACE GROUP name cannot be the same as tablespace name
Cause: The tablespace group name specified in the command is the same as the tablespace being CREATEd/ALTERed.
Action: Please specify an appropriate tablespace group name.
ORA-10919: Default temporary tablespace group must have at least one tablespace
Cause: An attempt was made to move the only tablespace in the default database temporary tablespace group to another tablespace group.
Action: Either change the database default temporary tablespace or add another tablespace to the group that this tablespace belongs to.
ORA-10920: Cannot offline tablespace belonging to default temporary tablespace group
Cause: An attempt was made to offline a tablespace in the default database temporary tablespace group.
Action: Either change the database default temporary tablespace or change the tablespace group of this tablespace.
ORA-10921: Cannot drop tablespace belonging to default temporary tablespace group
Cause: An attempt was made to drop a tablespace in the default database temporary tablespace group.
Action: Either change the database default temporary tablespace or change the tablespace group of this tablespace.
ORA-10922: Temporary tablespace group is empty
Cause: An attempt was made to allocate a temporary segment in a group, which now no longer has any members.
Action: Either add some temporary tablespaces or change the temporary tablespace for this user.
ORA-12001: cannot create log: table 'string' already has a trigger
Cause: Materialized view logs are filled by a trigger on the master table. That trigger cannot be created.
Action: To create a materialized view log, drop the current trigger on the master.
ORA-12002: there is no materialized view log on table "string"."string"
Cause: There was no materialized view log on the master table.
Action: Create a materialized view log on the master table.
ORA-12003: materialized view "string"."string" does not exist
Cause: The materialized view with the given owner and name does not exist.
Action: Verify inputs and create a materialized view.
ORA-12004: REFRESH FAST cannot be used for materialized view "string"."string"
Cause: The materialized view log does not exist or cannot be used. PCT refresh is also not enabled on the materialized view
Action: Use just REFRESH, which will reinstantiate the entire table. If a materialized view log exists and the form of the materialized view allows the use of a materialized view log or PCT refresh is possible after a given set of changes, REFRESH FAST will be available starting the next time the materialized view is refreshed.
ORA-12005: may not schedule automatic refresh for times in the past
Cause: An attempt was made to schedule an automated materialized view refresh for a time in the past.
Action: Choose a time in the future instead.
ORA-12007: materialized view reuse parameters are inconsistent
Cause: The CREATE MATERIALIZED VIEW .. or CREATE MATERIALIZED VIEW LOG .. REUSE command was given inconsistent parameters immediately after the REUSE.
Action: Examine the other messages on the stack to find the problem.
ORA-12008: error in materialized view refresh path
Cause: Table SNAP$_<mview_name> reads rows from the view MVIEW$_<mview_name>, which is a view on the master table (the master may be at a remote site). Any error in this path will cause this error at refresh time. For fast refreshes, the table <master_owner>.MLOG$_<master> is also referenced.
Action: Examine the other messages on the stack to find the problem. See if the objects SNAP$_<mview_name>, MVIEW$_<mview_name>, <mowner>.<master>@<dblink>, <mowner>.MLOG$_<master>@<dblink> still exist.
ORA-12010: cannot create materialized view log on table owned by SYS
Cause: An attempt was made to create a materialized view log on the table owned by SYS. CREATE MATERIALIZED VIEW LOG attempts to create a trigger on the table, but triggers can not be created on SYS tables.
Action: Do not create a materialized view log on SYS tables.
ORA-12011: execution of string jobs failed
Cause: An error was caught in dbms_ijob.run from one or more jobs which were due to be run.
Action: Look at the alert log for details on which jobs failed and why.
ORA-12012: error on auto execute of job string
Cause: An error was caught while doing an automatic execution of a job.
Action: Look at the accompanying errors for details on why the execute failed.
ORA-12013: updatable materialized views must be simple enough to do fast refresh
Cause: The updatable materialized view query contained a join, subquery, union, connect by, order by, or group by caluse.
Action: Make the materialized view simpler. If a join is really needed, make multiple simple materialized views then put a view on top of them.
ORA-12014: table 'string' does not contain a primary key constraint
Cause: The CREATE MATERIALIZED VIEW LOG command was issued with the WITH PRIMARY KEY option and the master table did not contain a primary key constraint or the constraint was disabled.
Action: Reissue the command using only the WITH ROWID option, create a primary key constraint on the master table, or enable an existing primary key constraint.
ORA-12015: cannot create a fast refresh materialized view from a complex query
Cause: Neither ROWIDs and nor primary key constraints are supported for complex queries.
Action: Reissue the command with the REFRESH FORCE or REFRESH COMPLETE option or create a simple materialized view.
ORA-12016: materialized view does not include all primary key columns
Cause: The query that instantiates the materialized view did not include all of the columns in the master's primary key constraint.
Action: Include all of the master's primary key columns in the materialized view query or create a ROWID materialized view.
ORA-12017: cannot alter primary key mview 'string' to a rowid mview
Cause: An attempt was made to convert the primary key of a materialized view to a ROWID materialized view.
Action: Conversion of a primary key materialized view to a ROWID materialized view is not supported. Create a new materialized view with ROWIDs or drop and recreate the materialized view with ROWIDs.
ORA-12018: following error encountered during code generation for "string"."string"
Cause: The refresh operations for the indicated materialized view could not be regenerated due to errors.
Action: Correct the problem indicated in the following error messages and repeat the operation.
ORA-12019: master table is a synonym to a remote object
Cause: An attempt was made to create a materialized view or a materialized view log on a remote synonym which is unsupported.
Action: Do not create a materialized view or materialized view log on a remote synonym.
ORA-12020: materialized view string is not registered
Cause: An attempt was made to unregister a materialized view that is not registered.
Action: No action required.
ORA-12021: materialized view "string"."string" is corrupt
Cause: The materialized view indicated is no longer valid.
Action: Contact Oracle Customer Support.
ORA-12022: materialized view log on "string"."string" already has rowid
Cause: Materialized view log on the indicated table already has ROWID information.
Action: No action required.
ORA-12023: missing index on materialized view "string"."string"
Cause: The specified ROWID materialized view did not have the required index on the ROWID column of its underlying table.
Action: Drop and recreate the materialized view.
ORA-12024: materialized view log on "string"."string" does not have primary key columns
Cause: Materialized view log on the indicated table does not have primary key information.
Action: Add primary keys to the materialized view log using the ALTER MATERIALIZED VIEW command.
ORA-12025: materialized view log on "string"."string" already has primary keys
Cause: Materialized view log on the indicated table already has primary key columns.
Action: No action required.
ORA-12026: invalid filter column detected
Cause: One or more of the specified filter columns did not exist or was a primary key column or a primary key based object identifier.
Action: Ensure that all specified filter columns exist in the master table and ensure that primary key columns or primary key based object identifiers are not included in the list of filter columns.
ORA-12027: duplicate filter column
Cause: One or more of the specified filter columns were already being recorded in the materialized view log.
Action: Describe the materialized view log table and reissue the SQL command with the filter columns that are already being recorded in the materialized view log.
ORA-12028: materialized view type is not supported by master site string
Cause: Pre-Oracle8 master sites are not able to support primary key or subquery materialized views that are able to perform a fast refresh.
Action: Create a ROWID materialized view or use a master table from an Oracle8 site.
ORA-12029: LOB columns may not be used as filter columns
Cause: An attempt was made to use LOB columns as filter columns.
Action: Remove LOB columns from the filter columns list and retry command.
ORA-12030: cannot create a fast refresh materialized view
Cause: The materialized view log did not exist or did not log the information needed by the materialized view to perform a fast refresh.
Action: Ensure that the materialized view log exists and logs the necessary information.

- For ROWID materialized views, the master table's ROWID must be logged.

- For primary key materialized views, the master table's primary key columns must be logged.

- For subquery materialized views, the filter columns, primary key, and ROWID values must be logged.

- For object materialized views, object id must be logged.

ORA-12031: cannot use primary key columns from materialized view log on "string"."string"
Cause: The materialized view log either did not have primary key columns logged, or the timestamp associated with the primary key columns was more recent than the last refresh time.
Action: A complete refresh is required before the next fast refresh. Add primary key columns to the materialized view log, if required.
ORA-12032: cannot use rowid column from materialized view log on "string"."string"
Cause: The materialized view log either does not have ROWID columns logged, or the timestamp associated with the ROWID columns is more recent than the last refresh time.
Action: A complete refresh is required before the next fast refresh. Add ROWID columns to the materialized view log, if required.
ORA-12033: cannot use filter columns from materialized view log on "string"."string"
Cause: The materialized view log either did not have filter columns logged, or the timestamp associated with the filter columns was more recent than the last refresh time.
Action: A complete refresh is required before the next fast refresh. Add filter columns to the materialized view log, if required.
ORA-12034: materialized view log on "string"."string" younger than last refresh
Cause: The materialized view log was younger than the last refresh.
Action: A complete refresh is required before the next fast refresh.
ORA-12035: could not use materialized view log on "string"."string"
Cause: The materialized view log did not exist or could not be used.
Action: Use just REFRESH, which will reinstantiate the entire table. If a materialized view log exists and the form of the materialized view allows the use of a materialized view log, REFRESH FAST will be available starting the next time the materialized view is refreshed.
ORA-12036: updatable materialized view log is not empty, refresh materialized view
Cause: The updatable materialized view log was not empty. The updatable materialized view log must be empty before an updatable rowid materialized view can be altered to a primary key materialized view.
Action: Ensure that updatable materialized view log is empty by refreshing the materialized view before converting the updatable ROWID materialized view to a primary key materialized view.
ORA-12037: unknown export format
Cause: An attempt was made to import a materialized view exported by an unknown export version (e.g., from a newer release than the importing site)
Action: Re-export the file using a version of export known by the importing site.
ORA-12039: unable to use local rollback segment "string"
Cause: A local rollback segment was specified in the CREATE MATERIALIZED VIEW command, but automatic refresh parameters were not specified. Therefore a refresh group was not created to automatically refresh the materialized view and the local rollback segment can't be registered for future use.
Action: Either supply the automatic refresh parameters so that a refresh group will be created or do not specify a local rollback segment.
ORA-12040: master rollback segment option not support by master site string
Cause: An attempt was made to specify master rollback segment in the current operation. The master site of the current materialized view does not allow users to specify a rollback segment to be used for materialized view operations. This feature is only supported by Oracle8 or later master sites.
Action: Do not specify a master rollback segment in the current operation or choose a new master site.
ORA-12041: cannot record ROWIDs for index-organized table "string"."string"
Cause: Index-organized tables do not have ROWIDs. Therefore a materialized view log that records the ROWIDs of an index-organized table could not be created.
Action: Do not include the WITH ROWID option when using the CREATE MATERIALIZED VIEW command and do not include the ADD ROWID option when using the ALTER MATERIALIZED VIEW command if the master table is index-organized.
ORA-12042: cannot alter job_queue_processes in single process mode
Cause: An attempt was made to alter job_queue_processes in single process mode.
Action: Do not attempt to set job_queue_processes in single process mode.
ORA-12043: invalid CREATE MATERIALIZED VIEW option
Cause: An invalid option was used in a CREATE MATERIALIZED VIEW statement.
Action: Specify only valid options.
ORA-12044: invalid CREATE MATERIALIZED VIEW LOG option
Cause: An invalid option was used in a CREATE MATERIALIZED VIEW LOG statement.
Action: Specify only valid options.
ORA-12045: invalid ALTER MATERIALIZED VIEW LOG option
Cause: An invalid option was used in an ALTER MATERIALIZED VIEW LOG statement.
Action: Specify only valid options.
ORA-12046: cannot use trusted constraints for refreshing remote MV
Cause: REFRESH USING TRUSTED CONSTRAINTS specified in ALTER MATERIALIZED VIEW or CREATE MATERIALIZED VIEW of a remote materialized view
Action: remove this attribute from ALTER/ CREATE MATERIALIZED VIEW DDL
ORA-12047: PCT FAST REFRESH cannot be used for materialized view "string"."string"
Cause: PCT refresh is either not enabled on this materialized view or not possible after set of the base table changes since last refresh.
Action: Use just REFRESH FORCE, which will reinstantiate the entire table and try to pick the best refresh method on the materialized view Do explain_mview to look at the cause why PCT refresh is not possible on this materialized view
ORA-12051: ON COMMIT attribute is incompatible with other options
Cause: ON COMMIT refresh attribute, incompatible with other refresh options such as automatic periodic refresh, was specified.
Action: Specify only valid options.
ORA-12052: cannot fast refresh materialized view string.string
Cause: Either ROWIDs of certain tables were missing in the definition or the inner table of an outer join did not have UNIQUE constraints on join columns.
Action: Specify the FORCE or COMPLETE option. If this error is got during creation, the materialized view definition may have be changed. Refer to the documentation on materialized views.
ORA-12053: this is not a valid nested materialized view
Cause: The list of objects in the FROM clause of the definition of this materialized view had some dependencies upon each other.
Action: Refer to the documentation to see which types of nesting are valid.
ORA-12054: cannot set the ON COMMIT refresh attribute for the materialized view
Cause: The materialized view did not satisfy conditions for refresh at commit time.
Action: Specify only valid options.
ORA-12055: materialized view definition contains cyclic dependencies with existing materialized views
Cause: The materialized view query definition introduced a cyclic dependency with existing materialized view.
Action: Modify the materialized view query definition.
ORA-12056: invalid REFRESH method
Cause: The NEVER REFRESH option may not be used under the following conditions:

* The materialized view is updatable

* The materialized view refreshes ON COMMIT

* Automatic refresh options are specified

Action: For updatable materialized views, reissue the SQL command using REFRESH FORCE, REFRESH FAST, or REFRESH COMPLETE. For read-only materialized views, reissue the SQL command using ON DEMAND.
ORA-12057: materialized view "string"."string" is INVALID and must complete refresh
Cause: The status of the materialized view was INVALID and an attempt was made to fast refresh the materialized view.
Action: Perform a complete refresh of the materialized view. Check the value of the STATUS column in dba_mviews, all_mviews, or user_mviews to verify that the materialized view is VALID after the complete refresh.
ORA-12058: materialized view cannot use prebuilt table
Cause: An attempt was made to use the prebuilt tables.
Action: Reissue the SQL command using BUILD IMMEDIATE or BUILD DEFERRED.
ORA-12059: prebuilt table "string"."string" does not exist
Cause: The specified prebuilt table did not exist.
Action: Reissue the SQL command using BUILD IMMEDIATE, BUILD DEFERRED, or ensure that the prebuilt table exists.
ORA-12060: shape of prebuilt table does not match definition query
Cause: The number of columns or the type or the length semantics of a column in the prebuilt table did not match the materialized view definition query.
Action: Reissue the SQL command using BUILD IMMEDIATE, BUILD DEFERRED, or ensure that the prebuilt table matches the materialized view definition query.
ORA-12061: invalid ALTER MATERIALIZED VIEW option
Cause: An invalid option was used in an ALTER MATERIALIZED VIEW statement.
Action: Specify only valid options.
ORA-12062: transaction string received out of sequence from site string
Cause: A transaction from the client site was received out of sequence. This implies that one or more transactions were missing.
Action: Ensure that the transaction queue at the client site is valid and has not been corrupted.
ORA-12063: unable to apply transaction from site string
Cause: The current transaction from the client site could not be applied to the master site.
Action: Ensure that the client site is still valid and that it has not been dropped from the master site.
ORA-12064: invalid refresh sequence number: string
Cause: The client site was attempting to perform a refresh with an invalid refresh sequence.
Action: Perform a complete refresh to synchronize the refresh sequence number.
ORA-12065: unknown refresh group identifier string
Cause: The specified refresh group did not exist at the master site.
Action: Ensure that the client site is still valid and that it has not been dropped from the master site.
ORA-12066: invalid CREATE MATERIALIZED VIEW command
Cause: The Replication API does not support the following options and types of materialized view:

o ROWID materialized views

o REFRESH ON COMMIT

o ON PREBUILT TABLE

o BUILD DEFERRED

o NEVER REFRESH

o ENABLE QUERY REWRITE

Action: Create a PRIMARY KEY materialized view using REFRESH WITH PRIMARY KEY and/or remove the invalid options.
ORA-12067: empty refresh groups are not allowed
Cause: The refresh group being instantiated did not contain any materialized views.
Action: Modify the template to include at least one materialized view.
ORA-12068: updatable mview log for mview "string"."string" does not exist
Cause: The updatable materialized view was missing the updatable materialized view log required to track updates made to the materialized view.
Action: Create the updatable materialized view log.
ORA-12069: invalid object for offline instantiation
Cause: Only materialized views can be offline instantiated. The object being offline instantiated was not a valid materialized view.
Action: Remove the object from the template or replace the object with a valid materialized view.
ORA-12070: cannot offline instantiate materialized view "string"."string"
Cause: Offline instantiation does not support materialized views using the following options:

o ON PREBUILT TABLE

o BUILD DEFERRED

Action: Remove the invalid options.
ORA-12071: definition query of "string"."string" is invalid for offline instantiation
Cause: Offline instantiation requires materialized view definition queries to observe the following constraints:

o The database link that will be used by the materialized view site to connect to the master site must be included with each master table referenced in the query.

o All master tables referenced must be located at the local site. References to other sites are not allowed.

Action: Modify the materialized view definition query.
ORA-12072: updatable materialized view log data for "string"."string" cannot be created
Cause: The updatable materialized view was missing the updatable materialized view log required to track updates made to the materialized view.
Action: Create an updatable materialized view log.
ORA-12073: request cannot be processed
Cause: An out-of-sequence request was made and it cannot be processed.
Action: Try again with a valid request.
ORA-12074: invalid memory address
Cause: An attempt was made to access an invalid memory region.
Action: Reconnect and try the command again.
ORA-12075: invalid object or field
Cause: An attempt was made to access an invalid field or object in the Java Virtual Memory.
Action: Retry the request.
ORA-12076: invalid threshold value
Cause: The result set threshold or LOB threshold value is not supported.
Action: Specify a threshold value below 64K.
ORA-12077: temporary updatable materialized view log does not exist
Cause: Temporary updatable materialized view log was not created or was dropped.
Action: Re-create the temporary updatable materialized view log. Warning: This will cause a complete refresh of the materialized view.
ORA-12078: fast refresh of refresh group ID string failed
Cause: Refresh result set sent through client method REFRESH_REQ_RESULT returned an unknown value.
Action: Re-issue the refresh request.
ORA-12079: materialized view options require COMPATIBLE parameter to be string or greater
Cause: The following materialized view options require 8.1 or higher compatibility setting:

o ON COMMIT

o ON PREBUILT TABLE

o BUILD DEFERRED

o NEVER REFRESH

o ENABLE QUERY REWRITE The following materialized view options require 8.2 or higher compatibility setting:

o materialized views with user-defined types The following materialized view options require 9.2 or higher

o materialized views (query rewrite enabled) with set operators that are not inside an inline view or named view The following materialized view options require 10.0 or higher

o materialized views which can be refreshed USING TRUSTED CONSTRAINTS

o materialized views with SELECT column alias clause In addition, ALTER MATERIALIZED VIEW LOG can be used to add sequence number only if compatibility is set to 10.0 or higher

Action: Shut down and restart with an appropriate compatibility setting.
ORA-12081: update operation not allowed on table "string"."string"
Cause: An attempt was made to update a read-only materialized view.
Action: No action required. Only Oracle is allowed to update a read-only materialized view.
ORA-12082: "string"."string" cannot be index organized
Cause: An attempt was made to create an index-organized materialized aggregate view or an index-organized updatable ROWID materialized view. This is not supported.
Action: Try to create the materialized view without the index organization clause.
ORA-12083: must use DROP MATERIALIZED VIEW to drop "string"."string"
Cause: An attempt was made to drop a materialized view using a command other than DROP MATERIALIZED VIEW.
Action: Use the DROP MATERIALIZED VIEW command.
ORA-12084: must use ALTER MATERIALIZED VIEW to alter "string"."string"
Cause: An attempt was made to alter a materialized view using a command other than ALTER MATERIALIZED VIEW.
Action: Use the ALTER MATERIALIZED VIEW command.
ORA-12085: materialized view log on "string"."string" already has object id
Cause: Materialized view log on the indicated table already has object id information.
Action: No action required.
ORA-12086: table "string"."string" is not an object table
Cause: The CREATE MATERIALIZED VIEW LOG command was issued with the WITH OBJECT ID option and the master table is not an object table.
Action: Either specify the name of an object table, or remove the WITH OBJECT ID clause.
ORA-12087: online redefinition not allowed on tables owned by "string"
Cause: An attempt was made to online redefine a table owned by SYS or SYSTEM.
Action: Do not attempt to online redefine a table owned by SYS or SYSTEM.
ORA-12088: cannot online redefine table "string"."string" with unsupported datatype
Cause: An attempt was made to online redefine a table containing a LONG column, an ADT column, or a FILE column.
Action: Do not attempt to online redefine a table containing a LONG column, an ADT column, or a FILE column.
ORA-12089: cannot online redefine table "string"."string" with no primary key
Cause: An attempt was made to online redefine a table that does not have a primary key defined on it.
Action: Do not attempt to online redefine a table that does not have a primary key defined on it.
ORA-12090: cannot online redefine table "string"."string"
Cause: An attempt was made to online redefine a table that is either a clustered table, AQ table, temporary table, IOT overflow table or table with FGA/RLS enabled.
Action: Do not attempt to online redefine a table that is a clustered table, AQ table, temporary table, IOT overflow table or table with FGA/RLS enabled.
ORA-12091: cannot online redefine table "string"."string" with materialized views
Cause: An attempt was made to online redefine a table that had materialized views defined on it or had a materialized view log defined on it or is a master.
Action: Drop all materialized views and materialized view logs before attempting to online redefine the table.
ORA-12092: cannot online redefine replicated table "string"."string"
Cause: An attempt was made to online redefine a table that is either a materialized view or a replicated table.
Action: Do not attempt to online redefine a table that is either a materialized view or a replicated table.
ORA-12093: invalid interim table "string"."string"
Cause: The table is not the interim table of the corresponding table to be online redefined.
Action: Pass in the valid interim table.
ORA-12094: error during online redefinition
Cause: There was an error during the online redefinition process.
Action: Abort the online redefinition process.
ORA-12096: error in materialized view log on "string"."string"
Cause: There was an error originating from this materialized view log. One possible cause is that schema redefinition has occurred on the master table and one or more columns in the log is now a different type than corresponding master column(s). Another possible cause is that there is a problem accessing the underlying materialized view log table.
Action: Check further error messages in stack for more detail about the cause. If there has been schema redefinition, drop the materialized view log and recreate it.
ORA-12097: changes in the master tables during refresh, try refresh again
Cause: There are some changes (i.e., conventional DML, direct load, partition maintenance operation) in the master tables during materialized view refresh.
Action: Refresh the affected materialized views again.
ORA-12098: cannot comment on the materialized view
Cause: An attempt was made to issue a COMMENT ON TABLE statement on a materialized view.
Action: Issue a COMMENT ON MATERIALIZED VIEW statement instead.
ORA-12100: materialized view log on "string"."string" already has sequence
Cause: Materialized view log on the indicated table already has sequence information.
Action: No action required. ///////////////////////////////////////////////////////////////////////// /////////////////////////////////////////////////////////////////////////


9 ORA-12150 to ORA-12236

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

9 ORA-12150 to ORA-12236

ORA-12150: TNS:unable to send data
Cause: Unable to send data. Connection probably disconnected.
Action: Reestablish connection. If the error is persistent, turn on tracing and reexecute the operation.
ORA-12151: TNS:received bad packet type from network layer
Cause: Internal error.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
ORA-12152: TNS:unable to send break message
Cause: Unable to send break message. Connection probably disconnected.
Action: Reestablish connection. If the error is persistent, turn on tracing and reexecute the operation.
ORA-12153: TNS:not connected
Cause: Not currently connected to a remote host.
Action: Reestablish connection.
ORA-12154: TNS:could not resolve the connect identifier specified
Cause: A connection to a database or other service was requested using a connect identifier, and the connect identifier specified could not be resolved into a connect descriptor using one of the naming methods configured. For example, if the type of connect identifier used was a net service name then the net service name could not be found in a naming method repository, or the repository could not be located or reached.
Action:

- If you are using local naming (TNSNAMES.ORA file):

- Make sure that "TNSNAMES" is listed as one of the values of the NAMES.DIRECTORY_PATH parameter in the Oracle Net profile (SQLNET.ORA)

- Verify that a TNSNAMES.ORA file exists and is in the proper directory and is accessible.

- Check that the net service name used as the connect identifier exists in the TNSNAMES.ORA file.

- Make sure there are no syntax errors anywhere in the TNSNAMES.ORA file. Look for unmatched parentheses or stray characters. Errors in a TNSNAMES.ORA file may make it unusable.

- If you are using directory naming:

- Verify that "LDAP" is listed as one of the values of the NAMES.DIRETORY_PATH parameter in the Oracle Net profile (SQLNET.ORA).

- Verify that the LDAP directory server is up and that it is accessible.

- Verify that the net service name or database name used as the connect identifier is configured in the directory.

- Verify that the default context being used is correct by specifying a fully qualified net service name or a full LDAP DN as the connect identifier

- If you are using easy connect naming:

- Verify that "EZCONNECT" is listed as one of the values of the NAMES.DIRETORY_PATH parameter in the Oracle Net profile (SQLNET.ORA).

- Make sure the host, port and service name specified are correct.

- Try enclosing the connect identifier in quote marks. See the Oracle Net Services Administrators Guide or the Oracle operating system specific guide for more information on naming.

ORA-12155: TNS:received bad datatype in NSWMARKER packet
Cause: Internal error during break handling.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
ORA-12156: TNS:tried to reset line from incorrect state
Cause: Internal error during break handling.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
ORA-12157: TNS:internal network communication error
Cause: Internal error during network communication.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
ORA-12158: TNS:could not initialize parameter subsystem
Cause: Unable to locate parameter file.
Action: Verify that a valid parameter file exists, and is readable.
ORA-12159: TNS:trace file not writeable
Cause: The trace file to be generated is not writeable by this user.
Action: If the user does not have write permissions in the directory to which the trace file will be written, contact an administrator to get the proper permissions or set the TRACE_DIRECTORY_CLIENT parameter in the net profile (SQLNET.ORA file) to a directory the user can write to.
ORA-12160: TNS:internal error: Bad error number
Cause: Corrupt error reporting subsystem.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
ORA-12161: TNS:internal error: partial data received
Cause: The connection may be terminated.
Action: Reconnect and try again. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
ORA-12162: TNS:net service name is incorrectly specified
Cause: The connect descriptor corresponding to the net service name in TNSNAMES.ORA or in the directory server (Oracle Internet Directory) is incorrectly specified.
Action: If using local naming make sure there are no syntax errors in the corresponding connect descriptor in the TNSNAMES.ORA file. If using directory naming check the information provided through the administration used for directory naming.
ORA-12163: TNS:connect descriptor is too long
Cause: The connect descriptor corresponding to the net service name specified as the connect identifier is too long. The maximum length for a connect descriptor is 512 bytes and this limit has been exceeded.
Action: Check the net service name's connect descriptor in the local naming file (TNSNAMES.ORA) or in the directory server (Oracle Internet Directory). Use a smaller connect descriptor. If this is not possible, contact Worldwide Customer Support.
ORA-12164: TNS:Sqlnet.fdf file not present
Cause: The sqlnet.fdf file doesn't exist in $ORACLE_HOME/network.101/admin.
Action: The sqlnet.fdf file is required for Oracle Tracing to occur. Either install the sqlnet.fdf file in $ORACLE_HOME/network.101/admin or turn off tracing in your ORA file.
ORA-12165: TNS:Trying to write trace file into swap space.
Cause: Oracle Trace doesn't allow writing trace information into your swap space.
Action: Oracle Trace cannot write trace information into swap space so either disable tracing or redirect trace files to be written to another area of your disk.
ORA-12166: TNS:Client can not connect to HO agent.
Cause: NVstring contained DESCRIPTION/HO.
Action: Call HO agent from integrating server.
ORA-12168: TNS:Unable to contact LDAP Directory Server
Cause: Cannot contact LDAP directory server to get Oracle Net configuration.
Action: Verify that the directory server is up and accessible from the network. Verify that directory access configuration is correct. For more information see the Oracle Internet Directory Administrators Guide or the Oracle Net Administrators Guide.
ORA-12169: TNS:Net service name given as connect identifier is too long
Cause: The net service name you are attempting to resolve is too long.
Action: The maximum length of a net service name is 255 bytes; this limit has been exceeded. Use a smaller net service name. If this is not possible, contact Worldwide Customer Support.
ORA-12170: TNS:Connect timeout occurred
Cause: The server shut down because connection establishment or communication with a client failed to complete within the allotted time interval. This may be a result of network or system delays; or this may indicate that a malicious client is trying to cause a Denial of Service attack on the server.
Action: If the error occurred because of a slow network or system, reconfigure one or all of the parameters SQLNET.INBOUND_CONNECT_TIMEOUT, SQLNET.SEND_TIMEOUT, SQLNET.RECV_TIMEOUT in sqlnet.ora to larger values. If a malicious client is suspected, use the address in sqlnet.log to identify the source and restrict access. Note that logged addresses may not be reliable as they can be forged (e.g. in TCP/IP).
ORA-12171: TNS:could not resolve connect identifier: string
Cause: A connection to a database or other service was requested using a connect identifier, and the connect identifier specified could not be resolved into a connect descriptor using one of the naming methods configured. For example, if the type of connect identifier used was a net service name then the net service name could not be found in a naming method repository, or the repository could not be located or reached.
Action:

- If you are using local naming (TNSNAMES.ORA file):

- Make sure that "TNSNAMES" is listed as one of the values of the NAMES.DIRECTORY_PATH parameter in the Oracle Net profile (SQLNET.ORA)

- Verify that a TNSNAMES.ORA file exists and is in the proper directory and is accessible.

- Check that the net service name used as the connect identifier exists in the TNSNAMES.ORA file.

- Make sure there are no syntax errors anywhere in the TNSNAMES.ORA file. Look for unmatched parentheses or stray characters. Errors in a TNSNAMES.ORA file may make it unusable.

- If you are using directory naming:

- Verify that "LDAP" is listed as one of the values of the NAMES.DIRETORY_PATH parameter in the Oracle Net profile (SQLNET.ORA).

- Verify that the LDAP directory server is up and that it is accessible.

- Verify that the net service name or database name used as the connect identifier is configured in the directory.

- Verify that the default context being used is correct by specifying a fully qualified net service name or a full LDAP DN as the connect identifier

- If you are using easy connect naming:

- Verify that "EZCONNECT" is listed as one of the values of the NAMES.DIRETORY_PATH parameter in the Oracle Net profile (SQLNET.ORA).

- Make sure the host, port and service name specified are correct.

- Try enclosing the connect identifier in quote marks. See the Oracle Net Services Administrators Guide or the Oracle operating system specific guide for more information on naming.

ORA-12196: TNS:received an error from TNS
Cause: The navigation layer received an error from TNS.
Action: See the error log file for the specific TNS error.
ORA-12197: TNS:keyword-value resolution error
Cause: The navigation layer received an error while trying to look up a value for a keyword.
Action: Check the syntax of the connect descriptor.
ORA-12198: TNS:could not find path to destination
Cause: Could not navigate a path through Interchanges to the destination. This error occurs if an invalid community is in the address string, or the address includes a protocol that is not available or the TNSNAV.ORA file does not have a correct CMANAGER address specified or the Interchange is down.
Action: Assure that Interchanges necessary to get to the desired destination are up and have available capacity for an additional connection. Also check that the correct community and protocol have been specified in the CMANAGER address used.
ORA-12200: TNS:could not allocate memory
Cause: Out of memory on machine.
Action: Reconfigure machine to have more storage or run fewer applications while the Interchange is running.
ORA-12201: TNS:encountered too small a connection buffer
Cause: TNS connection buffer supplied by the application was too small to retrieve the data sent back.
Action: Supply a larger connection buffer. If problem persists, call Worldwide Customer Support.
ORA-12202: TNS:internal navigation error
Cause: Internal navigation error.
Action: Not normally visible to the user. For further details contact Worldwide Customer Support.
ORA-12203: TNS:unable to connect to destination
Cause: Invalid address specified or destination is not listening. This error can also occur because of underlying network or network transport problems.
Action: Verify that the net service name you entered was correct. Verify that the ADDRESS portion of the connect descriptor which corresponds to the net service name is correct. Ensure that the destination process (for example the listener) is running at the remote node.
ORA-12204: TNS:received data refused from an application
Cause: The application using Connection Manager refused the connection at the listener.
Action: Make sure that the application listener at the destination is functioning correctly. If it is and the problem persists, contact Worldwide Customer Support.
ORA-12205: TNS:could not get failed addresses
Cause: Internal navigation error.
Action: Not normally visible to the user. For further details contact Worldwide Customer Support.
ORA-12206: TNS:received a TNS error during navigation
Cause: Internal navigation error because of an unexpected TNS error.
Action: Look at the log file to find the TNS error. If necessary, turn on tracing and repeat the operation.
ORA-12207: TNS:unable to perform navigation
Cause: Improperly configured navigation file TNSNAV.ORA.
Action: Check the syntax of the TNSNAV.ORA file on the application`s machine, and verify that it lists the correct communities.
ORA-12208: TNS:could not find the TNSNAV.ORA file
Cause: Either the ORACLE environment is not set up correctly, or the TNSNAV.ORA file is not present.
Action: Ensure that the ORACLE environment is set up appropriately on your platform and that a TNSNAV.ORA file is present.
ORA-12209: TNS:encountered uninitialized global
Cause: Application calling navigation routine has not properly configured the global variables. There are no TNSNAV.ORA files available, or they are defective.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
ORA-12210: TNS:error in finding Navigator data
Cause: Application calling navigation routine has not properly configured the TNSNAV.ORA file.
Action: Check the syntax of the TNSNAV.ORA file.
ORA-12211: TNS:needs PREFERRED_CMANAGERS entry in TNSNAV.ORA
Cause: TNSNAV.ORA does not have a PREFERRED_CMANAGERS defined.
Action: Add a PREFERRED_CMANAGERS entry to the TNSNAV.ORA file.
ORA-12212: TNS:incomplete PREFERRED_CMANAGERS binding in TNSNAV.ORA
Cause: The PREFERRED_CMANAGERS binding in the client's TNSNAV.ORA file does not have a CMANAGER_NAME specified.
Action: Define the CMANAGER_NAME as part of the PREFERRED_CMANAGERS binding. Use of the Oracle Network Manager should eliminate this error.
ORA-12213: TNS:incomplete PREFERRED_CMANAGERS binding in TNSNAV.ORA
Cause: The PREFERRED_CMANAGERS binding in the client's TNSNAV.ORA file does not have an ADDRESS specified.
Action: Define the ADDRESS as part of the PREFERRED_CMANAGERS binding.
ORA-12214: TNS:missing local communities entry in TNSNAV.ORA
Cause: There is no LOCAL_COMMUNITIES entry in TNSNAV.ORA.
Action: Define the LOCAL_COMMUNITIES for this node in the TNSNAV.ORA file.
ORA-12215: TNS:poorly formed PREFERRED_NAVIGATORS Addresses in TNSNAV.ORA
Cause: Address binding for PREFERRED_NAVIGATORS entry is improperly entered. entry.
Action: Check your PREFERRED_NAVIGATORS entry and fix it in TNSNAV.ORA
ORA-12216: TNS:poorly formed PREFERRED_CMANAGERS addresses in TNSNAV.ORA
Cause: Address binding for the PREFERRED_CMANAGERS entry in the client's TNSNAV.ORA file is improperly entered.
Action: Define the ADDRESS as part of the PREFERRED_CMANAGERS binding.
ORA-12217: TNS:could not contact PREFERRED_CMANAGERS in TNSNAV.ORA
Cause: There is a syntax error in the PREFERRED_CMANAGERS entry, or addresses specified are wrong, or the intended Connection Managers are unavailable.
Action: Check the PREFERRED_CMANAGERS entries in the client's TNSNAV.ORA file and correct them or talk with your network administrator to determine if the specified Connection Managers are available. Verify that the Interchanges are active by using the INTCTL STATUS command.
ORA-12218: TNS:unacceptable network configuration data
Cause: Poorly formed network configuration data. For example, a PREFERRED_CMANAGERS entry may have an incorrect CMANAGER_NAME in the client's TNSNAV.ORA file. Or an Interchange downtime parameter (TIMEOUT_INTERVAL) on the Navigator may be set to zero in INTCHG.ORA.
Action: Check the entries in TNSNAV.ORA and the Interchange configuration files and correct them. If necessary, talk with your network administrator to determine if the specified Interchanges (Connection Managers) are available and properly configured. Use the Oracle Network Manager to generate the configuration files if necessary.
ORA-12219: TNS:missing community name from address in ADDRESS_LIST
Cause: This error occurs when an ADDRESS_LIST has some ADDRESSes in it that have no COMMUNITY component and others that do have a COMMUNITY component.
Action: Check that in the connect descriptors you are using either all the ADDRESSes have a COMMUNITY component or all do not.
ORA-12221: TNS:illegal ADDRESS parameters
Cause: An illegal set of protocol adapter parameters was specified. In some cases, this error is returned when a connection cannot be made to the protocol transport.
Action: Verify that the destination can be reached using the specified protocol. Check the parameters within the ADDRESS section of TNSNAMES.ORA or in the directory. Legal ADDRESS parameter formats may be found in the Oracle operating system specific documentation or the Oracle Net Administrator's Guide. Protocols that resolve names at the transport layer are vulnerable to this error if not properly configured or names are misspelled.
ORA-12222: TNS:no support is available for the protocol indicated
Cause: The protocol requested in the ADDRESS portion of the connect descriptor identified through the net service name is not available. If the supplied ADDRESS is typographically correct then support for that protocol is not installed.
Action: Install support for the protocol or correct typographical error, as appropriate. Note: if the supplied address was derived from resolving the net service name, check the address in the appropriate file (TNSNAMES.ORA, LISTENER.ORA) or in the directory server.
ORA-12223: TNS:internal limit restriction exceeded
Cause: Too many TNS connections open simultaneously.
Action: Wait for connections to close and re-try.
ORA-12224: TNS:no listener
Cause: The connection request could not be completed because the listener is not running.
Action: Ensure that the supplied destination address matches one of the addresses used by the listener - compare the TNSNAMES.ORA entry with the appropriate LISTENER.ORA file (or TNSNAV.ORA if the connection is to go by way of an Interchange). Start the listener on the remote machine.
ORA-12225: TNS:destination host unreachable
Cause: Contact can not be made with remote party.
Action: Make sure the network driver is functioning and the network is up.
ORA-12226: TNS:operating system resource quota exceeded
Cause: The current user has exceeded the allotted resource assigned in the operating system.
Action: Acquire more operating system resource, or perform a different function.
ORA-12227: TNS:syntax error
Cause: The supplied connect descriptor contains illegal syntax.
Action: Check the syntax of the connect descriptor in TNSNAMES.ORA.
ORA-12228: TNS:protocol adapter not loadable
Cause: On some platforms (such as Windows) protocol support is loaded at run-time. If the shared library (or DLL) for the protocol adapter is missing or one of its supporting libraries is missing then this error is returned.
Action: For further details, turn on tracing and reexecute the operation. The trace file will include the name of the shared library (or DLL) that could not be loaded.
ORA-12229: TNS:Interchange has no more free connections
Cause: One or more Interchanges along the path to the destination desired has no more free connections available to be used for this call.
Action: Try again later when the Interchanges are less busy, or contact your network administrator to have him determine which interchange it is, and increase the number of connections available on that interchange.
ORA-12230: TNS:Severe Network error occurred in making this connection
Cause: This error is reported by an interchange which fails to make contact with the destination due to a physical network error while calling a destination.
Action: Try again later when the network service may have been fixed or report the problem to your Network Administrator so that he may fix the problem.
ORA-12231: TNS:No connection possible to destination
Cause: This error is reported by an interchange which fails to find a possible connection along the path to the destination.
Action: Report the problem to your Network Administrator so that he may fix the problem.
ORA-12232: TNS:No path available to destination
Cause: This error is reported by an interchange which fails to find a possible path to the destination.
Action: Report the problem to your Network Administrator so that he may fix the problem.
ORA-12233: TNS:Failure to accept a connection
Cause: This error is reported by an interchange which fails to accept a connection due to a redirect failure.
Action: Report the problem to your Network Administrator so that he may isolate the interchange problem.
ORA-12234: TNS:Redirect to destination
Cause: This error is reported by an interchange which determines that this interchange is not the right gateway and needs to redirect the connection to another gateway along the path to the destination.
Action: None.
ORA-12235: TNS:Failure to redirect to destination
Cause: This error is reported by an interchange which fails to redirect a connection to another interchange along the path to the destination.
Action: Report the problem to your Network Administrator so that he may fix the problem.
ORA-12236: TNS:protocol support not loaded
Cause: On some platforms (such as Windows) protocol support is loaded at run-time. If the shared library (or DLL) for the protocol adapter has not been loaded, then this error is returned.
Action: For further details, turn on tracing and reexecute the operation. The trace file will have the name of the shared library (or DLL) that has not been loaded.


10 ORA-12315 to ORA-12354

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

10 ORA-12315 to ORA-12354

ORA-12315: database link type is invalid for the ALTER DATABASE statement
Cause: The database link name you specified on the ALTER DATABASE statement is not an ROM: link. You must specify an ROM: link when using the ALTER DATABASE statement to mount or open a secondary database.
Action: Re-issue the ALTER DATABASE statement using a valid ROM: link to the database you want to mount or open. If a valid ROM: link does not exist, create one using the CREATE DATABASE LINK command. See the Trusted ORACLE RDBMS Guide to Security Features for more information about creating database links using the ROM: link type.
ORA-12316: syntax error in database link's connect string
Cause: The connect string in the CREATE DATABASE LINK statement has a syntactical error.
Action: Drop the database link and recreate it using valid syntax. See the SQL Language Reference Manual for more information about the connect string portion of the CREATE DATABASE LINK statement.
ORA-12317: logon to database (link name string) denied
Cause: There are several possible causes for this error. First, you can get this error if your username (and password, if you are using database instead of operating system authentication) in the secondary database are not identical to your username (and password) in the primary database. Second, you can get this error if your username in the secondary database is invalid (has not been created). Third, you can get this error if the username/password combination specified in the connect string of the database link definition is invalid (either not created or has an invalid password).
Action: In the first case, ensure that the secondary database contains a username (and password, if you are using database authentication) identical to the one you are using in the primary database. In general, you should always use operating system authentication in Trusted ORACLE (see the Trusted ORACLE RDBMS Guide to Security Features for more information about the advantages of OS authentication). In the second case, ensure that your username in the secondary database has been created. In the third case, ensure that the username specified in the connect string has been created in the secondary database.
ORA-12318: database (link name string) is already mounted
Cause: You are attempting to mount a secondary database that has already been mounted by your instance.
Action: to mount it. To establish access, use the ALTER DATABASE <linkname> OPEN command to open the database.
ORA-12319: database (link name string) is already open
Cause: You are attempting to open a secondary database that is already open.
Action: The database is open and you need not take additional action to establish access.
ORA-12321: database (link name string) is not open and AUTO_MOUNTING=FALSE
Cause: The secondary database that your instance is attempting to mount is not open and automatic mounting has not been enabled.
Action: Manually mount and open the secondary database using ALTER DATABASE <linkname> with the OPEN and MOUNT options. Alternately, to allow your instance to automatically mount and open secondary databases, set the AUTO_MOUNTING parameter in the parameter file to TRUE.
ORA-12322: unable to mount database (link name string)
Cause: This message should be accompanied by additional error messages that indicate the cause of the problem.
Action: Follow the steps outlined in the accompanying error messages to resolve the problem.
ORA-12323: unable to open database (link name string)
Cause: This message should be accompanied by additional error messages that indicate the cause of the problem.
Action: Follow the steps outlined in the accompanying error messages to resolve the problem.
ORA-12324: cannot use the ROM: link type on a private database link
Cause: You can only specify the ROM: link type on a public, not a private, database link.
Action: Determine if there is an existing public database link to the secondary database. If not, and if you wish to establish public access to the secondary database, create a public database link to the secondary database using the CREATE DATABASE LINK command.
ORA-12326: database string is closing immediately; no operations are permitted
Cause: The database you attempted to access is closing, so your operation has been terminated.
Action: Wait until the database has been reopened, or contact the database adminstrator.
ORA-12329: database string is closed; no operations are permitted
Cause: The database you attempted to access is closed, so your operation has been terminated.
Action: Wait until the database is reopened, or contact the database administrator.
ORA-12333: database (link name string) is not mounted
Cause: You attempted to open a database that has not been mounted.
Action: Mount the database with the ALTER DATABASE <linkname> MOUNT command, then re-attempt to open the database.
ORA-12334: database (link name string) is still open
Cause: You attempted to dismount a database that is still open.
Action: Close the database with the ALTER DATABASE <linkname> CLOSE command, then re-attempt to dismount the database.
ORA-12335: database (link name string) is not open
Cause: You attempted to close a database that is not open.
Action: The database is closed; you can proceed with dismounting it.
ORA-12336: cannot login to database (link name string)
Cause: You are tyring to login while another user is mounting or dismounting the same database.
Action: Check to see if the database is in the middle of being mounted or opened and try your login again once the database is accessible.
ORA-12341: maximum number of open mounts exceeded
Cause: The number specified on the OPEN_MOUNTS parameter in the parameter file exceeds the maximum allowed (255).
Action: Change the value of this parameter so that it reflects the actual number of possible open mounts to secondary databases. This must be less than 255.
ORA-12342: open mounts exceeds limit set on the OPEN_MOUNTS parameter
Cause: The number of currently open mounts exceeds the value you specified on the OPEN_MOUNTS parameter.
Action: Increase the value of the OPEN_MOUNTS parameter so that it accommodates the maximum possible number of open mounts to secondary databases.
ORA-12345: user string lacks CREATE SESSION privilege in database link (linkname string)
Cause: There are several possible causes for this message: First, you will get this message if your username in the second database specified was not granted the CREATE SESSION system privilege. Second, you will get this message if the username specified in the connect string of the database link definition was not granted the CREATE SESSION system privilege.
Action: The action you take depends upon the cause of the message: In the first case, ensure that your username in the secondary database was granted the CREATE SESSION system privilege. In the second case, ensure the username specified in the connect string of the database link definition was granted the CREATE SESSION system privilege in the secondary database.
ORA-12350: database link being dropped is still mounted
Cause: An attempt was made to drop a ROM: database link that was still mounted and/or opened.
Action: Close and dismount the database and then re-issue the drop statement.
ORA-12351: cannot create view using a remote object which has a remote object reference
Cause: You tried to create a view which references a remote object which, in turn, references an object on another database. Since the view that you tried to create references a remote object, that object cannot reference an object on another database.
Action: Choose a different object to reference in your view or change the remote object so that it does not reference another database.
ORA-12352: object string.string@string is invalid
Cause: An attempt was made to reference (compile against) an object of a secondary database but the object is invalid and the system cannot validate or recompile it because it is in a secondary database.
Action: Manually recompile the invalid object in the secondary database.
ORA-12353: secondary stored object cannot reference remote object
Cause: You tried to either select from a remote view or execute a remote procedure which references an object on another database. Since the remote view or procedure is on a secondary database, an additional reference to another database cannot be done.
Action: Choose a different object to reference or change the remote view or procedure so that it does not reference another database.
ORA-12354: secondary object being dropped
Cause: You tried to access a object (for example, a table or view) on a secondary database that was in the process of being dropped.
Action: Repeat the operation. If you receive this message again, try to access the object from the secondary database. If you receive an internal error or a trace file, contact Oracle WorldWide Technical Support.


11 ORA-12400 to ORA-12497

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

11 ORA-12400 to ORA-12497

ORA-12400: invalid argument to facility error handling
Cause: An argument to a facility error handling function exceeded a maximum limit or referred to an invalid product/facility.
Action: Specify a valid facility error handling parameter value.
ORA-12401: invalid label string: string
Cause: The policy could not convert the label string to a valid internal label.
Action: Correct the syntax of the label string.
ORA-12402: invalid format string: string
Cause: The format string is not supported by the policy.
Action: Correct the syntax of the format string.
ORA-12403: invalid internal label
Cause: An internal label could not be converted to a valid label for the policy.
Action: Analyze any additional messages on the error stack and consult the policy documentation.
ORA-12404: invalid privilege string: string
Cause: The policy could not interpret the privilege string.
Action: Specify a privilege string that is supported by the policy.
ORA-12405: invalid label list
Cause: The policy determined that the label list was invalid for its intended use.
Action: Check the policy constraints on the specific list of labels.
ORA-12406: unauthorized SQL statement for policy string
Cause: The policy did not authorize the database session to perform the requested SQL statement.
Action: Grant the user or program unit the necessary policy privilege or additional authorizations.
ORA-12407: unauthorized operation for policy string
Cause: The policy did not authorize the database session to perform the requested operation.
Action: Grant the user or program unit the necessary policy privilege or additional authorizations.
ORA-12408: unsupported operation: string
Cause: The specified policy does not support the requested operation.
Action: Consult the policy documentation to determine the supported access mediation operations.
ORA-12409: policy startup failure for string policy
Cause: The policy encountered an error during startup processing; access to the data protected by the policy is prohibited.
Action: Check the alert log for additional information, correct the policy error, and restart the instance.
ORA-12410: internal policy error for policy: string Error: string
Cause: The policy enforcement encountered an internal error.
Action: Consult the policy documentation for details.
ORA-12411: invalid label value
Cause: The specified label value does not exist.
Action: Check the data dictionary views for the policy to identify valid labels.
ORA-12412: policy package string is not installed
Cause: The policy package does not exist in the database.
Action: Check that the policy package name is correct or install the required policy package.
ORA-12413: labels do not belong to the same policy
Cause: The labels being compared belong to different policies.
Action: Only compare labels that belong to the same policy.
ORA-12414: internal LBAC error: string Error: string
Cause: An internal label policy framework error occurred.
Action: Contact Oracle Customer Support.
ORA-12415: A column of another datatype exists on the specified table
Cause: The datatype of the column present in the table is different from the datatype set for the policy column.
Action: Drop the column on the table or change the datatype for policy column.
ORA-12416: policy string not found
Cause: The specified policy does not exist in the database.
Action: Enter the correct policy name or create the policy.
ORA-12417: database object "string" not found
Cause: The specified object was not in the database.
Action: Enter the correct name for the database object.
ORA-12418: user string not found
Cause: The specified user does not exist in the database.
Action: Correct the user name or create the user.
ORA-12419: null binary label value
Cause: A null value was provided for a binary label operation.
Action: Provide a valid binary label for the operation.
ORA-12420: required procedures and functions not in policy package "string"
Cause: The policy package did not contain all of the procedures and functions necessary to enforce the policy.
Action: Consult the label framework documentation for a list of required procedures and functions for a policy package.
ORA-12421: different size binary labels
Cause: The label sizes for the binary label operation were not equal.
Action: Provide binary labels with the same lengths for the operation.
ORA-12422: max policies exceeded
Cause: You tried to create a new policy, but the maximum number of policies for the instance had already been created.
Action: Increase the size of the MAX_LABEL_POLICIES initialization parameter and restart the server.
ORA-12423: invalid position specified
Cause: The position specified for a binary label operation was invalid.
Action: Provide a position that is within the label size limits.
ORA-12424: length exceeds binary label size
Cause: The length specified for a binary label operation exceeded the the size of the binary label.
Action: Provide a bit or byte length that is within the label size limits.
ORA-12425: cannot apply policies or set authorizations for system schemas
Cause: You tried to either apply a policy to the SYS, SYSTEM, or LBACSYS schema or to set user labels/privileges for the SYS, SYSTEM, or LBACSYS user.
Action: Apply policies and set authorizations only for non-system users.
ORA-12426: invalid audit option
Cause: The option specified was not a valid audit option for the specified policy.
Action: Enter a correct audit option.
ORA-12427: invalid input value for string parameter
Cause: An input parameter was specified incorrectly.
Action: Correct the parameter value.
ORA-12429: label list range exceeded
Cause: The specified index value was not between 1 and 6.
Action: Correct the index value for the label list operation.
ORA-12430: invalid privilege number
Cause: The specified privilege number was not between 1 and 32.
Action: Correct the privilege number.
ORA-12431: invalid audit action
Cause: The specified audit action was not a valid audit action.
Action: Correct the audit action number.
ORA-12432: LBAC error: string
Cause: LBAC enforcement resulted in an error.
Action: Correct the problem identified in the error message.
ORA-12433: create trigger failed, policy not applied
Cause: The policy could not be applied due to errors during the creation of a DML trigger.
Action: Correct the SQL syntax of the label function specification.
ORA-12434: invalid audit type: string
Cause: The audit type must be BY ACCESS or BY SESSION.
Action: Correct the audit type value.
ORA-12435: invalid audit success: string
Cause: The audit success parameter must be SUCCESSFUL or NOT SUCCESSFUL.
Action: Correct the audit success value.
ORA-12436: no policy options specified
Cause: A NULL option string was specified, but no default schema or policy option string was found.
Action: Enter a valid option string, or alter the schema or policy to have a valid default option string.
ORA-12437: invalid policy option: string
Cause: A value that was not a valid policy option was entered.
Action: Correct the policy option value.
ORA-12438: repeated policy option: string
Cause: A policy option was entered more than once in the option string.
Action: Remove the duplicate policy option value.
ORA-12439: invalid combination of policy options
Cause: A set of contradictory policy options was entered.
Action: Provide a set of compatible policy options.
ORA-12440: insufficient authorization for the SYSDBA package
Cause: The use of the SYSDBA package requires the LBAC_DBA role.
Action: Grant the LBAC_DBA role to the database user.
ORA-12441: policy string already exists
Cause: You tried to create a policy with the same name as an existing one.
Action: Use a different name or drop the existing policy.
ORA-12442: policy column "string" already used by an existing policy
Cause: You tried to create a policy with the same policy column name as an existing policy.
Action: Use a different name for the policy column or drop the existing policy.
ORA-12443: policy not applied to some tables in schema
Cause: You applied a policy to a schema, and some of the tables in the schema already had the policy applied.
Action: No action necessary; the policy was applied to the remaining tables.
ORA-12444: policy already applied to table
Cause: You tried to apply a policy to a table that was already protected by the policy.
Action: To change the policy options, predicate, or label function, remove the policy from the table and re-apply it.
ORA-12445: cannot change HIDDEN property of column
Cause: You tried to specify a different HIDE option for a table with an existing policy column.
Action: Drop the column from the table and reapply the policy with the new HIDE option.
ORA-12446: Insufficient authorization for administration of policy string
Cause: You tried to perform an administrative function for a policy, but you have not been granted the <policy>_DBA role.
Action: Grant the user the <policy>_DBA role for the specified policy.
ORA-12447: policy role already exists for policy string
Cause: The role named <policy>_DBA already exists.
Action: Correct the policy name or delete the existing policy.
ORA-12448: policy string not applied to schema string
Cause: You tried to alter a schema policy that was not applied.
Action: Correct the policy name or schema name.
ORA-12449: Labels specified for user must be of type USER
Cause: You tried to set labels for a user, but the labels in the list were not all designated as USER labels.
Action: Alter the labels to be USER labels.
ORA-12450: LOB datatype disabled in LBAC initialization file
Cause: You tried to specify a LOB datatype for a column or attribute, but the use of the LOB datatype has been disabled.
Action: Change the LBAC initialization file to allow the creation of LOB columns and attributes.
ORA-12451: label not designated as USER or DATA
Cause: A label is either a DATA label, a USER label, or both DATA and USER.
Action: Enter TRUE for at least DATA or USER.
ORA-12452: label tag string already exists
Cause: The label tag value you entered is already in use for another label.
Action: Enter a different value for the label tag.
ORA-12453: label string already exists
Cause: The label value you entered already exists.
Action: No action necessary; alter the label to change its tag or type.
ORA-12454: label string does not exist for policy string
Cause: The label tag or value you entered did not identify a label for the policy.
Action: Enter a label value or tag that is in use by the policy.
ORA-12461: undefined level string for policy string
Cause: The specified level is not defined for the policy.
Action: Correct the level identifier value.
ORA-12462: undefined compartment string for policy string
Cause: The specified compartment is not defined for the policy.
Action: Correct the compartment identifier value.
ORA-12463: undefined group string for policy string
Cause: The specified group is not defined for the policy.
Action: Correct the group identifier value.
ORA-12464: invalid characters in label component string
Cause: Label components can contain only alphanumeric characters, blanks, and underscores.
Action: Correct syntax of the label component.
ORA-12465: Not authorized for read or write on specified groups or compartments
Cause: You included groups or compartments that are not in the user's list of groups and compartments authorized for read or write access.
Action: Include read access when authorizing groups or compartments for write access.
ORA-12466: default level is greater than the user's maximum
Cause: The default level cannot be greater than the user's maximum.
Action: Enter an authorized level.
ORA-12467: minimum label can contain a level only
Cause: You included compartments or groups in the minimum label.
Action: Enter only an authorized minimum level as the label.
ORA-12468: max write level does not equal max read level
Cause: The level in the max write label must equal the level in the max read label.
Action: Enter max read and max write labels with the same level component.
ORA-12469: no user levels found for user string and policy string
Cause: No levels have been specified for the user.
Action: Enter the maximum and minimum labels for the user.
ORA-12470: NULL or invalid user label: string
Cause: The label entered is NULL or not within the user's authorizations.
Action: Enter the authorized labels for the user.
ORA-12471: Specified compartment or group is not authorized for user
Cause: The specified compartment or group is not in user's authorizations or the user does not have read on compartment or group specified for write.
Action: Enter an authorized compartment or group.
ORA-12472: policy string is being used
Cause: The policy which was being dropped due to event propagation from OID was applied to some table or schema.
Action: Drop a policy in OID only if it is not used in any of the databases using the policy.
ORA-12473: The procedure is disabled when Label Security is used with OID.
Cause: Using Label Security with OID disabled this procedure.
Action: Do not use OID with Label Security if this procedure is required to function.
ORA-12476: least upper bound resulted in an invalid OS label
Cause: You tried to do an operation that generated a least upper bound (LUB) label which is not a valid label on your operating system.
Action: Consult your OS label management documentation for information on invalid label generation.
ORA-12477: greatest lower bound resulted in an invalid OS label
Cause: You tried to do an operation that generated a greatest lower bound (GLB) label which is not a valid label on your operating system.
Action: Consult your OS label management documentation for information on invalid label generation.
ORA-12479: file label string must equal DBHIGH string
Cause: A database file had an OS label that did not match DBHIGH. Either DBHIGH was altered or the OS file was relabeled.
Action: Relabel the file so that its label matches DBHIGH, or alter DBHIGH so that it matches the label on the file.
ORA-12480: specified clearance labels not within the effective clearance
Cause: You specified a clearance range that was not within your authorized clearance; you can only specify clearance ranges that are within your clearance.
Action: Specify clearance labels that are within your own clearance range.
ORA-12481: effective label not within program unit clearance range
Cause: The effective label when the program unit was invoked was not within the range authorized for the program unit.
Action: Modify the program unit clearance range or invoke the program unit from a session with an authorized effective clearance.
ORA-12482: internal MLS error: string Error: string
Cause: An internal MLS policy error occurred.
Action: Contact Oracle Customer Support.
ORA-12483: label not in OS system accreditation range
Cause: The specified label is above the OS maximum label or below the OS minimum label.
Action: Use a label that is within the accreditation range for the host OS.
ORA-12484: invalid OS label
Cause: The specified label does not exist in the OS host's label definition file.
Action: Use the OS label management tools to define the label.
ORA-12485: new effective label not within effective clearance
Cause: You attempted to enter a value for an effective label that did not dominate the effective min label or was not dominated by the effective max label.
Action: Enter a value between the min and the max labels.
ORA-12486: effective max labels and min labels cannot be changed
Cause: You attempted to enter a value for an effective min label or effective max label, but these labels cannot be changed.
Action: Enter NULL values for the effective minimum and maximum labels.
ORA-12487: clearance labels not between DBHIGH and DBLOW
Cause: You attempted to enter a value for a clearance label that was not dominated by DBHIGH or did not dominate DBLOW.
Action: Enter clearance label values between DBHIGH and DBLOW.
ORA-12488: maximum label does not dominate minimum label
Cause: You attempted to enter a value for a clearance label that did not preserve the dominance relationship between the minimum and maximum labels.
Action: Enter label values that preserves the dominance relationship between the minimum and maximum.
ORA-12489: default label not within clearance range
Cause: You attempted to enter a value for a default label that did not dominate the minimum clearance or was not dominated by the maximum clearance.
Action: Enter a default label value within the clearance range.
ORA-12490: DBHIGH cannot be lowered
Cause: You attempted to enter a value for DBHIGH that did not dominate the existing value of DBHIGH.
Action: Enter a value for DBHIGH that dominates the old value.
ORA-12491: DBHIGH value does not dominate DBLOW
Cause: You attempted to enter a value for DBHIGH that did not dominate DBLOW.
Action: Enter a value for DBHIGH that dominates DBLOW.
ORA-12492: DBLOW cannot be changed
Cause: You attempted to change the value of DBLOW after it had been set to any initial value. DBLOW can only be set once after initial database creation.
Action: To change DBLOW, you have to create a new database, set DBLOW to the new value, and import your data into the new database.
ORA-12493: invalid MLS binary label
Cause: The MLS binary label contained an invalid value, was not the correct size, or contained a level, category, or release category that was not enabled.
Action: Check the DBA_MLS_LABELS view for the valid MLS labels.
ORA-12494: cannot insert or delete a level, category, or release category
Cause: You attempted to insert or delete a level, category, or release category definition.
Action: If the label definition is no longer valid, change its name to one that identifies it as invalid. When any labels are converted to character strings, the new label definition will be used.
ORA-12495: cannot disable an enabled level, category, or release category
Cause: You attempted to disable a level, category, or release category that had previously been enabled. An enabled label definition may be exist in some database label, so cannot be disabled.
Action: If the label definition is no longer valid, change its name to one that identifies it as invalid. When any labels are converted to character strings, the new label definition will be used.
ORA-12496: cannot change existing level, category, or release numbers
Cause: You attempted to change the number assigned to level, category or releasability category.
Action: Change the character string representations, not the numbers.
ORA-12497: maximum combined categories exceeds string
Cause: The maximum number of descriptive categories plus release categories supported by the MLS policy was exceeded.
Action: Enter numbers that do not add up to more than the maximum.


12 ORA-12500 to ORA-12699

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

12 ORA-12500 to ORA-12699

ORA-12500: TNS:listener failed to start a dedicated server process
Cause: The process of starting up a dedicated server process failed. The executable could not be found or the environment may be set up incorrectly.
Action: Turn on tracing at the ADMIN level and reexecute the operation. Verify that the ORACLE Server executable is present and has execute permissions enabled. Ensure that the ORACLE environment is specified correctly in LISTENER.ORA. The Oracle Protocol Adapter that is being called may not be installed on the local hard drive. Please check that the correct Protocol Adapter are successfully linked. If error persists, contact Oracle Customer Support.
ORA-12502: TNS:listener received no CONNECT_DATA from client
Cause: No CONNECT_DATA was passed to the listener.
Action: Check that the service name resolved from TNSNAMES.ORA has the CONNECT_DATA component of the connect descriptor.
ORA-12504: TNS:listener was not given the SID in CONNECT_DATA
Cause: The SID was missing from the CONNECT_DATA.
Action: Check that the connect descriptor corresponding to the service name in TNSNAMES.ORA has an SID component in the CONNECT_DATA.
ORA-12505: TNS:listener does not currently know of SID given in connect descriptor
Cause: The listener received a request to establish a connection to a database or other service. The connect descriptor received by the listener specified a SID for an instance (usually a database instance) that either has not yet dynamically registered with the listener or has not been statically configured for the listener. This may be a temporary condition such as after the listener has started, but before the database instance has registered with the listener.
Action:

- Wait a moment and try to connect a second time.

- Check which instances are currently known by the listener by executing: lsnrctl services <listener name>

- Check that the SID parameter in the connect descriptor specifies an instance known by the listener.

- Check for an event in the listener.log file.

ORA-12508: TNS:listener could not resolve the COMMAND given
Cause: d by incompatible Oracle Net or Net8 versions. Do not include in error manual.
Action: This is not seen in normal use of Oracle Net.
ORA-12509: TNS:listener failed to redirect client to service handler
Cause: The dispatcher terminated unexpectedly
Action: Attempt to connect again and if the same error occurs, contact the DBA to check the state of the dispatchers for this SID. If the problem persists, turn on tracing in the listener to determine the TNS error caused by the redirect.
ORA-12510: TNS:database temporarily lacks resources to handle the request
Cause: The dispatchers appear to be busy handling other requests.
Action: Attempt the connection again. If error persists, ask the DBA to increase the number of dispatchers and/or dispatchers' limit on number of connections/sessions that they can accept.
ORA-12511: TNS:service handler found but it is not accepting connections
Cause: The dispatchers notified the listener that they temporarily do not accept new connections.
Action: Attempt the connection again. If error persists, contact the DBA to check the state of the dispatchers and/or ask him to increase the number of dispatchers.
ORA-12513: TNS:service handler found but it has registered for a different protocol
Cause: The dispatchers registered for this service are connected to the listener by way of a different network protocol than that of the client.
Action: Contact the DBA to register a dispatcher on your protocol.
ORA-12514: TNS:listener does not currently know of service requested in connect descriptor
Cause: The listener received a request to establish a connection to a database or other service. The connect descriptor received by the listener specified a service name for a service (usually a database service) that either has not yet dynamically registered with the listener or has not been statically configured for the listener. This may be a temporary condition such as after the listener has started, but before the database instance has registered with the listener.
Action:

- Wait a moment and try to connect a second time.

- Check which services are currently known by the listener by executing: lsnrctl services <listener name>

- Check that the SERVICE_NAME parameter in the connect descriptor of the net service name used specifies a service known by the listener.

- If an easy connect naming connect identifier was used, check that the service name specified is a service known by the listener.

- Check for an event in the listener.log file.

ORA-12515: TNS:listener could not find a handler for this presentation
Cause: None of the listener's known service handlers are registered as supporting the presentation protocol required by the connecting client.
Action: Check that the destination service is configured to accept the presentation protocol.
ORA-12516: TNS:listener could not find available handler with matching protocol stack
Cause: None of the known and available service handlers for the given SERVICE_NAME support the client's protocol stack: transport, session, and presentation protocols.
Action: Check to make sure that the service handlers (e.g. dispatchers) for the given SERVICE_NAME are registered with the listener, are accepting connections, and that they are properly configured to support the desired protocols.
ORA-12518: TNS:listener could not hand off client connection
Cause: The process of handing off a client connection to another process failed.
Action: Turn on listener tracing and re-execute the operation. Verify that the listener and database instance are properly configured for direct handoff. If problem persists, call Oracle Support.
ORA-12519: TNS:no appropriate service handler found
Cause: The listener could not find any available service handlers that are appropriate for the client connection.
Action: Run "lsnrctl services" to ensure that the instance(s) have registered with the listener, and are accepting connections.
ORA-12520: TNS:listener could not find available handler for requested type of server
Cause: None of the known and available service handlers for requested type of server (dedicated or shared) are appropriate for the client connection.
Action: Run "lsnrctl services" to ensure that the instance(s) have registered with the listener and that the appropriate handlers are accepting connections.
ORA-12521: TNS:listener does not currently know of instance requested in connect descriptor
Cause: The listener received a request to establish a connection to a database or other service. The connect descriptor received by the listener specified in addition to the service name an instance name for an instance (usually a database instance) that either has not yet dynamically registered with the listener or has not been statically configured for the listener. This may be a temporary condition such as after the listener has started, but before the database instance has registered with the listener.
Action:

- Wait a moment and try to connect a second time.

- Check which instances are currently known by the listener by executing: lsnrctl services <listener name>

- Check that the INSTANCE_NAME parameter in the connect descriptor specifies an instance name known by the listener.

- Check for an event in the listener.log file.

ORA-12522: TNS:listener could not find available instance with given INSTANCE_ROLE
Cause: There are not any available and appropriate database instances registered with the listener, that are part of the service identified by SERVICE_NAME given in the connect descriptor and that have the specified INSTANCE_ROLE (and INSTANCE_NAME, if specified).
Action: Check to make sure that the INSTANCE_ROLE specified is correct. Run "lsnrctl services" to ensure that the instance(s) have registered with the listener and that they are ready to accept connections.
ORA-12523: TNS:listener could not find instance appropriate for the client connection
Cause: The listener could not find any available (database) instances, that are appropriate for the client connection.
Action: Run "lsnrctl services" to ensure that the instance(s) are registered with the listener, and have status READY.
ORA-12524: TNS:listener could not resolve HANDLER_NAME given in connect descriptor
Cause: The HANDLER_NAME in the CONNECT_DATA was not found in the listener's tables for the specified SERVICE_NAME and INSTANCE_NAME.
Action: Check to make sure that the HANDLER_NAME specified is correct.
ORA-12525: TNS:listener has not received client's request in time allowed
Cause: The listener disconnected the client because the client failed to provide the necessary connect information within the allowed time interval. This may be a result of network or system delays; or this may indicate that a malicious client is trying to cause a Denial of Service attack on the listener.
Action: If the error occurred because of a slow network or system, reconfigure INBOUND_CONNECT_TIMEOUT to a larger value. If a malicious client is suspected, use the address in listener.log to identify the source and restrict access. Turn on tracing for more information.
ORA-12526: TNS:listener: all appropriate instances are in restricted mode
Cause: Database instances supporting the service requested by the client were in restricted mode. The Listener does not allow connections to instances in restricted mode. This condition may be temporary, such as during periods when database administration is performed.
Action: Attempt the connection again. If error persists, then contact the database administrator to change the mode of the instance, if appropriate.
ORA-12527: TNS:listener: all instances are in restricted mode or blocking new connections
Cause: All appropriate database instances supporting the service requested by the client reported that they either were in restricted mode or were blocking the new connections. The Listener does not allow connections to such instances. This condition may be temporary, such as at instance startup.
Action: Attempt the connection again. If error persists, then contact the database administrator to check the status of the instances.
ORA-12528: TNS:listener: all appropriate instances are blocking new connections
Cause: All instances supporting the service requested by the client reported that they were blocking the new connections. This condition may be temporary, such as at instance startup.
Action: Attempt the connection again. If error persists, then contact the administrator to check the status of the instances.
ORA-12529: TNS:connect request rejected based on current filtering rules
Cause: Connection Manager and its listener were configured with filtering rules specifying that the connect request be rejected.
Action: If this connect request should be allowed, then contact the administrator to modify the filtering rules.
ORA-12531: TNS:cannot allocate memory
Cause: Sufficient memory could not be allocated to perform the desired activity.
Action: Either free some resource for TNS, or add more memory to the machine. For further details, turn on tracing and reexecute the operation.
ORA-12532: TNS:invalid argument
Cause: An internal function received an invalid parameter.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12533: TNS:illegal ADDRESS parameters
Cause: An illegal set of protocol adapter parameters was specified. In some cases, this error is returned when a connection cannot be made to the protocol transport.
Action: Verify that the destination can be reached using the specified protocol. Check the parameters within the ADDRESS section of TNSNAMES.ORA. Legal ADDRESS parameter formats may be found in the Oracle operating system specific documentation for your platform. Protocols that resolve names at the transport layer (such as DECnet object names) are vulnerable to this error if not properly configured or names are misspelled.
ORA-12534: TNS:operation not supported
Cause: An internal function received a request to perform an operation that is not supported (on this machine).
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12535: TNS:operation timed out
Cause: The requested operation could not be completed within the time out period.
Action: Look at the documentation on the secondary errors for possible remedy. See SQLNET.LOG to find secondary error if not provided explicitly. Turn on tracing to gather more information.
ORA-12536: TNS:operation would block
Cause: An internal operation did not commence because to do so would block the current process and the user has requested that operations be non-blocking.
Action: None needed; this is an information message.
ORA-12537: TNS:connection closed
Cause: "End of file" condition has been reached; partner has disconnected.
Action: None needed; this is an information message.
ORA-12538: TNS:no such protocol adapter
Cause: The protocol adapter requested (by way of the "(PROTOCOL=..)" keyword-value pair in a TNS address) is unknown. If the supplied address is typographically correct then the protocol adapter is not installed.
Action: Install the protocol adapter or correct typographically error, as appropriate. Note: if the supplied address was derived from resolving the service name, check the address in the appropriate file (TNSNAMES.ORA, LISTENER.ORA or SQLNET.ORA).
ORA-12539: TNS:buffer over- or under-flow
Cause: Buffer too small for incoming data or too large for outgoing data.
Action: This restriction (which is associated with CONNECT DATA) is not normally visible to the user. For further details, turn on tracing and reexecute the operation; contact Oracle Customer Support.
ORA-12540: TNS:internal limit restriction exceeded
Cause: Too many TNS connections open simultaneously.
Action: Wait for connections to close and re-try.
ORA-12541: TNS:no listener
Cause: The connection request could not be completed because the listener is not running.
Action: Ensure that the supplied destination address matches one of the addresses used by the listener - compare the TNSNAMES.ORA entry with the appropriate LISTENER.ORA file (or TNSNAV.ORA if the connection is to go by way of an Interchange). Start the listener on the remote machine.
ORA-12542: TNS:address already in use
Cause: Specified listener address is already being used.
Action: Start your listener with a unique address.
ORA-12543: TNS:destination host unreachable
Cause: Contact can not be made with remote party.
Action: Make sure the network driver is functioning and the network is up.
ORA-12544: TNS:contexts have different wait/test functions
Cause: Two protocol adapters have conflicting wait/test functions.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12545: Connect failed because target host or object does not exist
Cause: The address specified is not valid, or the program being connected to does not exist.
Action: Ensure the ADDRESS parameters have been entered correctly; the most likely incorrect parameter is the node name. Ensure that the executable for the server exists (perhaps "oracle" is missing.) If the protocol is TCP/IP, edit the TNSNAMES.ORA file to change the host name to a numeric IP address and try again.
ORA-12546: TNS:permission denied
Cause: User has insufficient privileges to perform the requested operation.
Action: Acquire necessary privileges and try again.
ORA-12547: TNS:lost contact
Cause: Partner has unexpectedly gone away, usually during process startup.
Action: Investigate partner application for abnormal termination. On an Interchange, this can happen if the machine is overloaded.
ORA-12548: TNS:incomplete read or write
Cause: A data send or receive failed.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12549: TNS:operating system resource quota exceeded
Cause: The current user has exceeded the allotted resource assigned in the operating system.
Action: Acquire more operating system resource, or perform a different function.
ORA-12550: TNS:syntax error
Cause: The supplied connect descriptor contains illegal syntax.
Action: Check the syntax of the connect descriptor in TNSNAMES.ORA.
ORA-12551: TNS:missing keyword
Cause: The supplied connect descriptor is missing one or more TNS keywords.
Action: Check the syntax, and ensure all required keywords are present.
ORA-12552: TNS:operation was interrupted
Cause: An internal operation was interrupted and could not complete.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12554: TNS:current operation is still in progress
Cause: An internal operation is still in progress.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12555: TNS:permission denied
Cause: User has insufficient privileges to perform the requested operation.
Action: Acquire necessary privileges and try again.
ORA-12556: TNS:no caller
Cause: TNS detected an incoming connect request but there was no caller.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12557: TNS:protocol adapter not loadable
Cause: On some platforms (such as OS/2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter is missing or one of its supporting libraries is missing then this error is returned.
Action: For further details, turn on tracing and reexecute the operation. The trace file will include the name of the shared library (or DLL) that could not be loaded.
ORA-12558: TNS:protocol adapter not loaded
Cause: On some platforms (such as OS/2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter has not been loaded, then this error is returned.
Action: For further details, turn on tracing and reexecute the operation. The trace file will have the name of the shared library (or DLL) that has not been loaded.
ORA-12560: TNS:protocol adapter error
Cause: A generic protocol adapter error occurred.
Action: Check addresses used for proper protocol specification. Before reporting this error, look at the error stack and check for lower level transport errors. For further details, turn on tracing and reexecute the operation. Turn off tracing when the operation is complete.
ORA-12561: TNS:unknown error
Cause: A generic protocol error occurred.
Action: For further details, turn on tracing and reexecute the operation.
ORA-12562: TNS:bad global handle
Cause: Internal error - bad 'gbh' argument passed to TNS from caller. System may have been linked with old libraries.
Action: Not normally visible to the user, contact Oracle Customer Support.
ORA-12564: TNS:connection refused
Cause: The connect request was denied by the remote user (or TNS software).
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation.
ORA-12566: TNS:protocol error
Cause: An unexpected TNS protocol error has occurred.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12569: TNS:packet checksum failure
Cause: The data received is not the same as the data sent.
Action: Attempt the transaction again. If the error is persistent, turn on tracing and reexecute the operation.
ORA-12570: TNS:packet reader failure
Cause: An error occurred during a data receive.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12571: TNS:packet writer failure
Cause: An error occurred during a data send.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12574: TNS:redirection denied
Cause: The connect request failed because it would have required redirection and the caller has requested no redirections.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12582: TNS:invalid operation
Cause: An internal function received an invalid request.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12583: TNS:no reader
Cause: A send operation has been requested but partner has already disconnected.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12585: TNS:data truncation
Cause: A receive operation has completed with insufficient data to satisfy the user's request.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12589: TNS:connection not bequeathable
Cause: An attempt to hand-off a connection from one process to another has failed because the protocol provider does not support it.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12590: TNS:no I/O buffer
Cause: An attempt to perform an I/O operation failed because no buffer was available.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12591: TNS:event signal failure
Cause: The TNS software is unable to signal an event occurrence.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12592: TNS:bad packet
Cause: An ill-formed packet has been detected by the TNS software.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12593: TNS:no registered connection
Cause: An attempt to solicit network event activity has failed because no connections are registered for event notification.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12595: TNS:no confirmation
Cause: TNS is unable to get requested confirmation acknowledgment from remote partner.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12596: TNS:internal inconsistency
Cause: TNS has detected an internal inconsistency.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
ORA-12597: TNS:connect descriptor already in use
Cause: Internal error - illegal use of connect descriptor.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12598: TNS:banner registration failed
Cause: The registration of a product banner with the Oracle server failed.
Action: This is an error which is not normally visible externally. Enable tracing and attempt to repeat the error. If it occurs again, contact Oracle Customer Support.
ORA-12599: TNS:cryptographic checksum mismatch
Cause: The data received is not the same as the data sent.
Action: Attempt the transaction again. If error persists, check (and correct) the integrity of your physical connection.
ORA-12600: TNS: string open failed
Cause: The creation of a string in ORACLE NLS format failed.
Action: This is an internal error, enable tracing and attempt to repeat the error. If it occurs again, contact Oracle Customer Support.
ORA-12601: TNS:information flags check failed
Cause: The TNS information flags set by the process prior to connection negotiation were not present after the negotiation was finished.
Action: This is an internal error. Enable tracing and attempt to repeat the error. If it occurs again, contact Oracle Customer Support.
ORA-12602: TNS: Connection Pooling limit reached
Cause: The operation failed because maximum active current connections has been reached. It may not be a real error when the Connection Pooling feature is enabled. It is possible that the application later reissues the operation and successfully grabs the connection pool slot and proceeds.
Action: This is an internal error. Enable tracing and attempt to repeat the error. If it occurs again, contact Oracle Customer Support.
ORA-12606: TNS: Application timeout occurred
Cause: A network session did not reach an application-defined stage within the allowed time interval.
Action: This is an error which does not normally appear at the high level. The action to take is application specific, and is detailed in the higher level error description.
ORA-12607: TNS: Connect timeout occurred
Cause: A network session did not reach a predefined connect stage within the allowed time interval.
Action: This is an error which does not normally appear at the high level. The action to take is application specific, and is detailed in the higher level error description.
ORA-12608: TNS: Send timeout occurred
Cause: The send or write operation did not complete within the allowed time interval.
Action: Check if the peer host is available. Increase the send timeout value if necessary.
ORA-12609: TNS: Receive timeout occurred
Cause: The receive or read operation did not complete within the allowed time interval.
Action: Check if the peer host is available. Increase the receive timeout value if necessary.
ORA-12611: TNS:operation is not portable
Cause: Attempted operation is not portable.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12612: TNS:connection is busy
Cause: Attempted operation failed because it conflicts with an ongoing
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12615: TNS:preempt error
Cause: A request to service an event failed because no event notification has yet been posted.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12616: TNS:no event signals
Cause: The operation failed because the type of data specified is unknown.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12618: TNS:versions are incompatible
Cause: The two machines are running incompatible versions of TNS.
Action: Check the version numbers, and upgrade the machine with the smaller one.
ORA-12619: TNS:unable to grant requested service
Cause: The connect request failed because requested service could not be provided by the local TNS software.
Action: If appropriate, reexecute with reduced service requirements.
ORA-12620: TNS:requested characteristic not available
Cause: The connect request failed because a requested transport characteristic could not be supported by the remote TNS software.
Action: If appropriate, reexecute with reduced requirements.
ORA-12622: TNS:event notifications are not homogeneous
Cause: An attempt to register a connection for event notification failed because the event notification type conflicts with existing registrations.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
ORA-12623: TNS:operation is illegal in this state
Cause: Connection is half-duplex and a full-duplex operation was attempted.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
ORA-12624: TNS:connection is already registered
Cause: An attempt to register a connection for event notification failed because the connection is already registered.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
ORA-12625: TNS:missing argument
Cause: An operation failed because an argument was missing"
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
ORA-12626: TNS:bad event type
Cause: An attempt to register a connection for event notification failed because the event type is unknown.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
ORA-12628: TNS:no event callbacks
Cause: An attempt to register a connection for event notification failed because asynchronous callbacks are not available.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
ORA-12629: TNS:no event test
Cause: An attempt to register a connection for event notification failed because the ability to test for events is not available.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
ORA-12630: Native service operation not supported
Cause: An operation requested by a user is not supported by the native services component.
Action: This may be an internal error if the operation should have been supported.
ORA-12631: Username retrieval failed
Cause: The authentication service failed to retrieve the name of a user.
Action: Enable tracing to determine which routine is failing.
ORA-12632: Role fetch failed
Cause: The authentication service failed to retrieve one of the user's roles.
Action: Enable tracing to determine which routine is failing.
ORA-12633: No shared authentication services
Cause: The list of authentication services specified by the user does not match those supported by the process.
Action: Either specify another list or relink the executable with the desired services.
ORA-12634: Memory allocation failed
Cause: Process was unable to allocate memory.
Action: Terminate other processes in order to reclaim needed memory.
ORA-12635: No authentication adapters available
Cause: The executable was not linked with any authentication service adapters but the sqlnet.ora parameter that determines whether or not authentication is required was set to true.
Action: Either disable the parameter or relink the executable with service adapters.
ORA-12636: Packet send failed
Cause: A process was unable to send a packet to another process. Possible causes are:

1. The other process was terminated.

2. The machine on which the other process is running went down.

3. Some other communications error occurred.

Action: If the cause is not obvious, contact Oracle Customer Support.
ORA-12637: Packet receive failed
Cause: A process was unable to receive a packet from another process. Possible causes are:

1. The other process was terminated.

2. The machine on which the other process is running went down.

3. Some other communications error occurred.

Action: If the cause is not obvious, contact Oracle Customer Support.
ORA-12638: Credential retrieval failed
Cause: The authentication service failed to retrieve the credentials of a user.
Action: Enable tracing to determine the exact error.
ORA-12639: Authentication service negotiation failed
Cause: No match was found between the types of authentication services that the client supports and those that the server is using.
Action: Possible solutions:

1. Change the entry in sqlnet.ora that determines which services are to be used.

2. Relink the client with at least one of the authentication service adapters that the server supports.

3. Relink the server with at least one of the authentication service adapters that the client supports.

4. Disable authentication on both the client and server.

ORA-12640: Authentication adapter initialization failed
Cause: The function specified in the authentication table entry for the service failed.
Action: Enable tracing to determine the exact error.
ORA-12641: Authentication service failed to initialize
Cause: The authentication service failed during initialization.
Action: Enable tracing to determine the exact error.
ORA-12642: No session key
Cause: A process has no session key associated with it because the authentication service being used does not use one.
Action: If a session key is required, use another authentication service.
ORA-12643: Client received internal error from server
Cause: The client process received an error from the server that indicated that an internal Oracle Net native services error had occurred.
Action: Enable tracing on both processes and attempt to recreate the problem. If successful in recreating the problem, contact Oracle Customer Support.
ORA-12645: Parameter does not exist.
Cause: A sqlnet.ora parameter from which a value was needed does not exist.
Action: Set the parameter in the parameter file.
ORA-12646: Invalid value specified for boolean parameter
Cause: The value specified for a parameter was set to a value other than true/false or on/off.
Action: Correct the value of the parameter.
ORA-12647: Authentication required
Cause: The parameter that controls whether authentication is required was set to true, but the executable does not have an authentication service linked in.
Action: Either re-link the executable with an authentication service adapter or disable the parameter.
ORA-12648: Encryption or data integrity algorithm list empty
Cause: An Oracle Advanced Security list-of-algorithms parameter was empty, e.g. "()".
Action: Change the list to contain the name of at least one installed algorithm, or remove the list entirely if every installed algorithm is acceptable.
ORA-12649: Unknown encryption or data integrity algorithm
Cause: An Oracle Advanced Security list-of-algorithms parameter included an algorithm name that was not recognized.
Action: Either remove that algorithm name, correct it if it was misspelled, or install the driver for the missing algorithm.
ORA-12650: No common encryption or data integrity algorithm
Cause: The client and server have no algorithm in common for either encryption or data integrity or both.
Action: Choose sets of algorithms that overlap. In other words, add one of the client's algorithm choices to the server's list or vice versa.
ORA-12651: Encryption or data integrity algorithm unacceptable
Cause: The algorithm the server chose to use for encryption or data integrity was not one of the choices acceptable to the client. This is either the result of an internal error, of a network data transmission error, or of deliberate tampering with the transmitted data.
Action: For further details, turn on tracing, re-execute the operation, and contact Oracle Customer Support.
ORA-12652: String truncated
Cause: Not enough memory was allocated for a string so it had to be truncated
Action: If it is OK that the string is truncated, then it is not an error. Otherwise, call the routine that reported the error again with a larger string buffer.
ORA-12653: Authentication control function failed
Cause: The control function utilized by the authentication service driver failed.
Action: Enable tracing to determine the exact error.
ORA-12654: Authentication conversion failed
Cause: The authentication service was unable to convert the credentials of a user from the format specific to the format into the ORACLE format.
Action: Enable tracing to determine the exact error.
ORA-12655: Password check failed
Cause: The authentication service being used was unable to verify the provided password.
Action: Enable tracing to determine the exact error.
ORA-12656: Cryptographic checksum mismatch
Cause: The cryptographic checksum received with a packet of incoming data didn't match the checksum computed by the receiving end. This indicates that the packet was tampered with or otherwise corrupted in transit.
Action: Look for sources of data corruption, perhaps including deliberate tampering.
ORA-12657: No algorithms installed
Cause: The near side of the connection required the use of a service (either encryption or checksumming) when no algorithms for that service were installed.
Action: Remove the "ON" requirement for that service.
ORA-12658: ANO service required but TNS version is incompatible
Cause: A client process that is running an earlier version of TNS attempted to connect but the connection failed because the server process required that an ANO service (authentication, encryption, etc.) be used.
Action: Relink the calling executable and retry the connection or eliminate the requirement that the service be used on the server side.
ORA-12659: Error received from other process
Cause: An error was received by one or more services from the process on the other side of the connection.
Action: Enable tracing to determine the exact error(s). The error(s) is (are) not returned directly because an error generated by a server may not make sense on the client side and vice-versa.
ORA-12660: Encryption or crypto-checksumming parameters incompatible
Cause: One side of the connection specified "REQUIRED" for encryption or crypto-checksumming, while the other side specified "REJECTED".
Action: Change the "REQUIRED" side to "REQUESTED" if the you want encryption or crypto-checksumming to be optional, or change the "REJECTED" side to "ACCEPTED" if you do not want the service to be optional.
ORA-12661: Protocol authentication to be used
Cause: The Oracle Advanced Security authentication service has determined that the Oracle Net transport protocol in use is to be utilized to authenticate a user's identity.
Action: This error is used solely to communicate information between the authentication service and the Oracle Net session layer and should not normally be visible. If the error is seen, contact Oracle Worldwide Support.
ORA-12662: proxy ticket retrieval failed
Cause: The authentication adapter used by Oracle Net failed to retrieve the credentials needed to authenticate a database link.
Action: Enable tracing to determine the exact error.
ORA-12663: Services required by client not available on the server
Cause: Service(s) that was (were) required by the client process were not available on the server process.
Action: Configure the server with the services required by the client (best solution) or delete the requirement from the configuration file of the client (least secure).
ORA-12664: Services required by server not available on the client
Cause: Service(s) that was (were) required by the server process were not available on the client process.
Action: Configure the client with the services required by the server (best solution) or delete the requirement from the configuration file of the server (least secure).
ORA-12665: NLS string open failed
Cause: A native service was unable to make a string available for use by the National Language Support component.
Action: Make sure the National Language Support component has been properly. If it has, enable tracing and report the problem to Customer Support.
ORA-12666: Dedicated server: outbound transport protocol different from inbound
Cause: The protocol specified for an externally-identified outbound connection from a dedicated server (database link) was not the same as that used for the inbound connection. It is not possible for Oracle Net to authenticate a proxy connection that uses a protocol that is different from that which was used for the connection to the dedicated server.
Action: Specify the same protocol in the Oracle Net connect descriptor for the outbound connection as that used for the inbound connection.
ORA-12667: Shared server: outbound transport protocol different from inbound
Cause: The protocol specified for an externally-identified outbound connection from a shared server (database link) was not the same as as that used for the inbound connection. It is not possible for Oracle Net to authenticate a proxy connection that uses a protocol that is different from that which was used for the connection to the shared server.
Action: Specify the same protocol in the Oracle Net connect descriptor for the outbound connection as that used for the inbound connection
ORA-12668: Dedicated server: outbound protocol does not support proxies
Cause: The protocol specified to perform an externally-identified proxy connection (database link) from a dedicated server does not support proxy connections.
Action: Specify a protocol in the Oracle Net connect descriptor used for the connection that does support externally-authenticated proxy connections. NOTE: Because of a limitation in Oracle Net, the protocol used for the proxy connection must the same as that used for the connection from the client to the server.
ORA-12669: Shared server: outbound protocol does not support proxies
Cause: The protocol specified to perform an externally-identified proxy connection (database link) from a shared server does not support proxy connections.
Action: Specify a protocol in the Oracle Net connect descriptor used for the connection that does support externally-authenticated proxy connections. NOTE: Because of a limitation in Oracle Net, the protocol used for the proxy connection must the same as that used for the connection from the client to the server.
ORA-12670: Incorrect role password
Cause: A password supplied for a role could not be validated by the authentication service.
Action: Supply the correct password.
ORA-12671: Shared server: adapter failed to save context
Cause: The adapter for the authentication service failed when it tried to save the data needed for proxy connections (database links) through the shared server.
Action: Enable tracing to determine the exact error. Contact Oracle Customer Support if the reason is not obvious.
ORA-12672: Database logon failure
Cause: The authentication service adapter in use encountered an error it attempted to validate the logon attempt of a user.
Action: Enable tracing to determine the exact error encountered by the adapter.
ORA-12673: Dedicated server: context not saved
Cause: A connection was marked as being a proxy connection (database link) from a dedicated server but no inbound context was present.
Action: This error should not normally be visible to the user. Contact Oracle Customer Support.
ORA-12674: Shared server: proxy context not saved
Cause: A connection was marked as being a proxy connection (database link) from a shared server but no inbound context was present.
Action: This error should not normally be visible to the user. Contact Oracle Customer Support.
ORA-12675: External user name not available yet
Cause: The authentication service in use was not able to return the external name of a user of the ORACLE server because it is not available to the service yet.
Action: This is just an informational message and should not normally be visible to the user. If the error does appear, contact Oracle Customer Support.
ORA-12676: Server received internal error from client
Cause: The server process received an error from the client which indicated that an internal Oracle Net native services error had occurred.
Action: Enable tracing on both processes and attempt to recreate the problem. If the problem recurs, contact Oracle Customer Support.
ORA-12677: Authentication service not supported by database link
Cause: The authentication service used by the proxy process (database link) was unable to find the adapter being used by the client in its list of authentication mechanisms.
Action: Specify an authentication adapter that is shared by the client and the server being used for the database link.
ORA-12678: Authentication disabled but required
Cause: The configuration parameters that control whether Oracle Advanced Security authentication is disabled or required were both set to TRUE.
Action: Set one or both of the parameters to FALSE.
ORA-12679: Native services disabled by other process but required
Cause: The remote process has disabled native services but the local process requires them.
Action: Enable native services on the remote process or disable them locally.
ORA-12680: Native services disabled but required
Cause: The process has disabled native services but at least one service is required.
Action: Enable native services or change the configuration file so that none of the available services are required.
ORA-12681: Login failed: the SecurID card does not have a pincode yet
Cause: The SecurID card that is used to logon to Oracle, does not have a pincode assigned to it.
Action: Use one of the programs supplied by Security Dynamics to assign a pincode to the card.
ORA-12682: Login failed: the SecurID card is in next PRN mode
Cause: The SecurID card and the SecurID server are out of sync and the server requires the next cardcode to resynchronize the card.
Action: Use one of the programs supplied by Security Dynamics to resynchronize the SecurID card.
ORA-12683: encryption/crypto-checksumming: no Diffie-Hellman seed
Cause: The "sqlnet.crypto_seed" parameter is missing from the SQLNET.ORA parameters file for Oracle Advanced Security.
Action: Add this line to SQLNET.ORA: sqlnet.crypto_seed = "randomly-chosen text"
ORA-12684: encryption/crypto-checksumming: Diffie-Hellman seed too small
Cause: The "sqlnet.crypto_seed" parameter in the SQLNET.ORA parameter file for Oracle Advanced Security is too small.
Action: Add more randomly-chosen text to it, perhaps using Network Manager.
ORA-12685: Native service required remotely but disabled locally
Cause: A native service is required by the remote process but native services have been disabled locally.
Action: Enable native services locally or change the configuration parameters on the remote host so that no native services are required.
ORA-12686: Invalid command specified for a service
Cause: An operation which does not exist was specified for a native service.
Action: This is a programming error and should not normally be visible to the user. If the error does appear, contact Oracle Customer Support.
ORA-12687: Credentials expired.
Cause: The credentials that are used to authenticate the user for the requested connection have expired.
Action: Renew your credentials. Refer to the documentation specific for your Network Authentication Adapter on how to do this.
ORA-12688: Login failed: the SecurID server rejected the new pincode
Cause: There are a number of reasons why the SecurID server would refuse a pincode:

- The user might not have permission to make up his own pincode.

- The pincode was either too short or too long. Valid pincodes consist of minimal four, but no more than eight characters.

- The pincode contains any non alphanumeric characters.

Action: Reexecute the operation and make sure to use a pincode that satisfies the above requirements. If the problem persists, turn on tracing at the Oracle Server side of the connection and examine the trace file for the exact error.
ORA-12689: Server Authentication required, but not supported
Cause: Server Authentication is required for this connection, but not supported by both sides of the connection.
Action: Make sure both sides of the connection have the correct version of Advanced Networking Option, and that the Authentication Adapter supports Server Authentication.
ORA-12690: Server Authentication failed, login cancelled
Cause: Server Authentication is required, but the server's credentials were found invalid by the client.
Action: Make sure that the server has a valid set of credentials. Refer to your authentication adapter specific documentation on how to do this.
ORA-12696: Double Encryption Turned On, login disallowed
Cause: The user is using a Secure Protocol Adapter that has Encryption turned ON as well as ANO Encryption.
Action: Turn OFF either ANO Encryption or the Protocol Adapter Encryption if possible. Refer to Oracle Advanced Security Administrator's Guide on how to do this.
ORA-12699: Native service internal error
Cause: An internal error occurred in the native services component.
Action: Enable tracing to determine the exact error. Contact Oracle Customer Support.


13 ORA-12700 to ORA-19361

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

13 ORA-12700 to ORA-19361

ORA-12700: invalid NLS parameter value (string)
Cause: An invalid or unknown NLS configuration parameter was specified.
Action: none
ORA-12701: CREATE DATABASE character set is not known
Cause: The character set specified when creating the database is unknown.
Action: none
ORA-12702: invalid NLS parameter string used in SQL function
Cause: An unknown parameter name or invalid value is specified in a NLS parameter string.
Action: none
ORA-12703: this character set conversion is not supported
Cause: The requested conversion between two character sets in the CONVERT function is not implemented
Action: none
ORA-12704: character set mismatch
Cause: One of the following:

- The string operands(other than an nlsparams argument) to an operator or built-in function do not have the same character set.

- An nlsparams operand is not in the database character set.

- String data with character set other than the database character set is passed to a built-in function not expecting it.

- The second argument to CHR() or CSCONVERT() is not CHAR_CS or NCHAR_CS.

- A string expression in the VALUES clause of an INSERT statement, or the SET clause of an UPDATE statement, does not have the same character set as the column into which the value would be inserted.

- A value provided in a DEFAULT clause when creating a table does not have the same character set as declared for the column.

- An argument to a PL/SQL function does not conform to the character set requirements of the corresponding parameter.

Action: none
ORA-12705: invalid or unknown NLS parameter value specified
Cause: The NLS parameter value specified in an alter session statement is not valid or not implemented.
Action: none
ORA-12706: this CREATE DATABASE character set is not allowed
Cause: It is not allowed to create a database on a native ASCII-based machine using an EBCDIC-based character set, and vice versa.
Action: none
ORA-12707: error while getting create database NLS parameter string
Cause: Internal error
Action: none
ORA-12708: error while loading create database NLS parameter string
Cause: Internal error
Action: none
ORA-12709: error while loading create database character set
Cause: Internal error
Action: none
ORA-12710: CREATE CONTROLFILE character set is not known
Cause: The character set specified when creating the controlfile is unknown.
Action: none
ORA-12711: this CREATE CONTROLFILE character set is not allowed
Cause: It is not allowed to create a controlfile on a native ASCII-based machine using an EBCDIC-based character set, and vice versa.
Action: none
ORA-12712: new character set must be a superset of old character set
Cause: When you ALTER DATABASE ... CHARACTER SET, the new character set must be a superset of the old character set. For example, WE8ISO8859P1 is not a superset of the WE8DEC.
Action: Specify a superset character set.
ORA-12713: Character data loss in NCHAR/CHAR conversion
Cause: When character set conversion happens between CHAR and NCHAR either implicitly or explicitly, some characters are lost due to no mapping characters in the destination character set.
Action: Make sure all the characters can be mapped to destination character set or set NLS_NCHAR_CONV_EXCP to be FALSE.
ORA-12714: invalid national character set specified
Cause: Only UTF8 and AL16UTF16 are allowed to be used as the national character set
Action: Ensure that the specified national character set is valid
ORA-12715: invalid character set specified
Cause: The character set specified is not allowed for this operation or is invalid
Action: Ensure that the specified character set is valid
ORA-12716: Cannot ALTER DATABASE CHARACTER SET when CLOB data exists
Cause: CLOB data changes representation to Unicode when converting to a multibyte character set and must be migrated
Action: Remove CLOB data as listed in the alert file. CLOB data can be migrated by methods such as import/export
ORA-12717: Cannot issue ALTER DATABASE NATIONAL CHARACTER SET when NCLOB, NCHAR or NVARCHAR2 data exists
Cause: NCLOB, NCHAR or NVARCHAR2 data changed the representation to Unicode when converting to a multibyte character set and must be migrated.
Action: Remove NCLOB, NCHAR or NVARCHAR2 data as listed in the alert file. The above type data can be migrated by methods such as import/export.
ORA-12718: operation requires connection as SYS
Cause: This command can only be run when connecting as SYS
Action: Connect as SYS to run this command
ORA-12719: operation requires database is in RESTRICTED mode
Cause: This command can only be run when the database is in RESTRICTED mode
Action: Ensure that the system is in RESTRICTED mode
ORA-12720: operation requires database is in EXCLUSIVE mode
Cause: This command can only be run when the database is in EXCLUSIVE mode
Action: Ensure that the system is in EXCLUSIVE mode
ORA-12721: operation cannot execute when other sessions are active
Cause: This command can only be run when there are no other sessions active
Action: Ensure there are no other connections to the database
ORA-12722: regular expression internal error
Cause: A regular expression internal error occurred.
Action: This is an internal error. Contact Oracle Support Services.
ORA-12723: regular expression too complex
Cause: The regular expression was too complex and could not be parsed.
Action: This is an internal error. Contact Oracle Support Services.
ORA-12724: regular expression corrupt
Cause: The regular expression contained an incorrect sequence of metacharacters.
Action: Ensure the metacharacters are correctly positioned.
ORA-12725: unmatched parentheses in regular expression
Cause: The regular expression did not have balanced parentheses.
Action: Ensure the parentheses are correctly balanced.
ORA-12726: unmatched bracket in regular expression
Cause: The regular expression did not have balanced brackets.
Action: Ensure the brackets are correctly balanced.
ORA-12727: invalid back reference in regular expression
Cause: A back references was found before a sub-expression.
Action: Ensure a valid sub-expression is being referenced.
ORA-12728: invalid range in regular expression
Cause: An invalid range was found in the regular expression.
Action: Ensure a valid range is being used.
ORA-12729: invalid character class in regular expression
Cause: An unknown character class was found in the regular expression.
Action: Ensure a valid characters class is being used.
ORA-12730: invalid equivalence class in regular expression
Cause: An unknown equivalence class was found in the regular expression.
Action: Ensure a valid equivalence class is being used.
ORA-12731: invalid collation class in regular expression
Cause: An unknown collation class was found in the regular expression.
Action: Ensure a valid collation class is being used.
ORA-12732: invalid interval value in regular expression
Cause: An invalid interval value was found in the regular expression.
Action: Ensure a valid interval value is being used.
ORA-12800: system appears too busy for parallel query execution
Cause: load on system is too high to perform parallel queries.
Action: re-execute serially or wait until system load is reduced.
ORA-12801: error signaled in parallel query server string
Cause: A parallel query server reached an exception condition.
Action: Check the following error message for the cause, and consult your error manual for the appropriate action.
ORA-12802: parallel query server lost contact with coordinator
Cause: A parallel query server lost contact with the foreground (coordinator) process/thread.
Action: Check your system for anomalies and reissue the statement. If this error persists, contact Oracle Support Services.
ORA-12803: parallel query server lost contact with another server
Cause: A parallel query server lost contact with another server.
Action: Check your system for anomalies and reissue the statement. If this error persists, contact Oracle Support Services.
ORA-12804: parallel query server appears to have died
Cause: Cannot find process information for a parallel query server thread.
Action: Check your system for anomalies and reissue the statement. If this error persists, contact Oracle Support Services.
ORA-12805: parallel query server died unexpectedly
Cause: A parallel query server died unexpectedly, PMON cleaning up the process.
Action: Check your system for anomalies and reissue the statement. If this error persists, contact Oracle Support Services. See trace file for more details.
ORA-12806: could not get background process to hold enqueue
Cause: Internal error.
Action: This error should not normally occur. If it persists, contact Oracle Support Services.
ORA-12807: process queue could not receive parallel query message
Cause: Internal error.
Action: This error should not normally occur. If it persists, contact Oracle Support Services.
ORA-12808: cannot set string_INSTANCES greater than number of instances string
Cause: An attempt was made to set SCAN_INSTANCES or CACHE_INSTANCES using the ALTER SYSTEM command to a value larger than the number of available instances.
Action: See the accompanying message for the current allowable maximum value, or set SCAN_INSTANCES / CACHE_INSTANCES to ALL.
ORA-12809: cannot set string_INSTANCES when mounted in exclusive mode
Cause: An attempt was made to set SCAN_INSTANCES or CACHE_INSTANCES using the ALTER SYSTEM command while the database was mounted in exclusive mode.
Action: SCAN_INSTANCES / CACHE_INSTANCES may not be set unless running Oracle Real Application Clusters mounted in CLUSTER_DATABASE mode.
ORA-12810: PARALLEL_MAX_SERVERS must be less than or equal to string
Cause: An attempt was made to set the PARALLEL_MAX_SERVERS parameter to a value higher than the maximum allowed by the system.
Action: Set PARALLEL_MAX_SERVERS to a value less than or equal to the maximum specified in the accompanying message and retry.
ORA-12811: PARALLEL_MIN_SERVERS must be less than or equal to PARALLEL_MAX_SERVERS, string
Cause: An attempt was made to set the PARALLEL_MIN_SERVERS parameter to a value higher than PARALLEL_MAX_SERVERS.
Action: Set PARALLEL_MIN_SERVERS to a value less than or equal to PARALLEL_MAX_SERVERS (indicated in the accompanying message) and retry.
ORA-12812: only one PARALLEL or NOPARALLEL clause may be specified
Cause: PARALLEL was specified more than once, NOPARALLEL was specified more than once, or both PARALLEL and NOPARALLEL were specified in a CREATE TABLE, CLUSTER, or INDEX or in an ALTER TABLE or CLUSTER statement, or in a RECOVER command.
Action: Remove all but one of the PARALLEL or NOPARALLEL clauses and reissue the statement.
ORA-12813: value for PARALLEL or DEGREE must be greater than 0
Cause: PARALLEL 0 or DEGREE 0 was specified in a CREATE TABLE, CLUSTER, or INDEX or in an ALTER TABLE or CLUSTER statement.
Action: Specify a degree of parallelism greater than 0 or specify default parallelism using PARALLEL with no degree or using DEGREE DEFAULT within a PARALLEL clause.
ORA-12814: only one CACHE or NOCACHE clause may be specified
Cause: CACHE was specified more than once, NOCACHE was specified more than once, or both CACHE and NOCACHE were specified in a CREATE TABLE or CLUSTER, or in an ALTER TABLE or CLUSTER statement.
Action: Remove all but one of the CACHE or NOCACHE clauses and reissue the statement.
ORA-12815: value for INSTANCES must be greater than 0
Cause: PARALLEL parameter specifying number of instances must be a positive integer or DEFAULT
Action: specify a positive integer or DEFAULT for INSTANCES if parallelism across instances is desired.
ORA-12817: parallel query option must be enabled
Cause: A parallel query option feature has been invoked but this option has not been enabled.
Action: Enable the parallel query option.
ORA-12818: invalid option in PARALLEL clause
Cause: an unrecognized option was used within a PARALLEL clause.
Action: specify any combination of DEGREE { <n> | DEFAULT } and INSTANCES { <n> | DEFAULT } within the PARALLEL clause.
ORA-12819: missing options in PARALLEL clause
Cause: PARALLEL clause cannot be empty.
Action: specify any combination of DEGREE { <n> | DEFAULT } and INSTANCES { <n> | DEFAULT } within the PARALLEL clause.
ORA-12820: invalid value for DEGREE
Cause: invalid value for DEGREE was specified within a PARALLEL clause.
Action: specify a positive integer or DEFAULT for the DEGREE option within a PARALLEL clause.
ORA-12821: invalid value for INSTANCES
Cause: invalid value for INSTANCES was specified within a PARALLEL clause.
Action: specify a positive integer or DEFAULT for the INSTANCES option within a PARALLEL clause.
ORA-12822: duplicate option in PARALLEL clause
Cause: DEGREE or INSTANCES was specified more than once within a PARALLEL clause.
Action: specify each desired PARALLEL clause option only once.
ORA-12823: default degree of parallelism may not be specified here
Cause: the PARALLEL keyword was used alone or DEGREE DEFAULT was specified in the PARALLEL clause of an ALTER DATABASE RECOVER command.
Action: respecify with an explicit degree of parallelism.
ORA-12824: INSTANCES DEFAULT may not be specified here
Cause: INSTANCES DEFAULT was specified in the PARALLEL clause of an ALTER DATABASE RECOVER command
Action: respecify with an explicit value for INSTANCES or omit the INSTANCES option if single instance recovery is desired.
ORA-12825: explicit degree of parallelism must be specified here
Cause: the DEGREE option was omitted from an ALTER DATABASE RECOVER command.
Action: respecify with an explicit degree of parallelism.
ORA-12826: hung parallel query server was killed
Cause: parallel query server was hung and subsequently killed.
Action: re-execute query and report suspicious events in trace file to Oracle Support Services if error persists.
ORA-12827: insufficient parallel query slaves available
Cause: PARALLEL_MIN_PERCENT parameter was specified and fewer than minimum slaves were acquired
Action: either re-execute query with lower PARALLEL_MIN_PERCENT or wait until some running queries are completed, thus freeing up slaves
ORA-12828: Can't start parallel transaction at a remote site
Cause: PDML transaction cannot be started because we are not in the coordinator site of the distributed transaction.
Action: Do not use PDML at remote sites.
ORA-12829: Deadlock - itls occupied by siblings at block string of file string
Cause: parallel statement failed because all itls in the current block are occupied by siblings of the same transaction.
Action: increase MAXTRANS of the block or reduce the degree of parallelism for the statement. Reexecute the statement. Report suspicious events in trace file to Oracle Support Services if error persists.
ORA-12830: Must COMMIT or ROLLBACK after executing parallel INSERT/UPDATE/DELETE
Cause: After executing a parallel INSERT/UPDATE/DELETE statement, a command other than COMMIT or ROLLBACK was issued.
Action: Execute COMMIT or ROLLBACK before issuing another SQL command.
ORA-12831: Must COMMIT or ROLLBACK after executing INSERT with APPEND hint
Cause: After executing an INSERT statement with an APPEND hint, a command other than COMMIT or ROLLBACK was issued.
Action: Execute COMMIT or ROLLBACK before issuing another SQL command.
ORA-12832: Could not allocate slaves on all specified instances
Cause: After executing a query on a global v$ fixed view, one or more instances failed to allocate a slave to process query
Action: To allow results to be returned by sucessfully allocated slaves, execute ALTER SESSION SET ALLOW_PARTIAL_SN_RESULTS=TRUE statement, or check parameters of instances
ORA-12833: Coordinator's instance not a member of parallel_instance_group
Cause: The coordinator's instance must be a member of the parallel_instance_group in which this operation will be run.
Action: Either add the coordinator's instance to the current parallel_instance_group or change parallel_instance_group.
ORA-12834: Instance group name, 'string', too long, must be less than string characters
Cause: The instance group name is too long.
Action: Either shorten the name or get rid of the instance group.
ORA-12835: No instances are active in the GLOBAL_VIEW_ADMIN_GROUP
Cause: There must be at least one instance in the GLOBAL_VIEW_ADMIN_GROUP in order to execute a query on global views
Action: Change the value of GLOBAL_VIEW_ADMIN_GROUP
ORA-12838: cannot read/modify an object after modifying it in parallel
Cause: Within the same transaction, an attempt was made to add read or modification statements on a table after it had been modified in parallel or with direct load. This is not permitted.
Action: Rewrite the transaction, or break it up into two transactions: one containing the initial modification and the second containing the parallel modification operation.
ORA-12839: cannot modify an object in parallel after modifying it
Cause: Within the same transaction, an attempt was made to perform parallel modification operations on a table after it had been modified. This is not permitted.
Action: Rewrite the transaction or break it up into two transactions: one containing the parallel modification and the second containing the initial modification operation.
ORA-12840: cannot access a remote table after parallel/insert direct load txn
Cause: Within a transaction, an attempt was made to perform distributed access after a PDML or insert direct statement had been issued.
Action: Commit/rollback the PDML transaction first, and then perform the distributed access, or perform the distributed access before the first PDML statement in the transaction.
ORA-12841: Cannot alter the session parallel DML state within a transaction
Cause: Transaction in progress
Action: Commit or rollback transaction and then re-execute
ORA-12842: Cursor invalidated during parallel execution
Cause: The cursor was invalidated during the parse phase of deferred parallel processing, e.g. when set operands are parallelized.
Action: Depends on why the cursor was invalidated. Possible causes include DDL on a schema object and shared pool being flushed.
ORA-12843: pdml lock not held properly on the table
Cause: The coodinator crashed or released the lock on the partition which the slave is trying to aquire currently.
Action: Check if the coordinator or some of the other slaves died. Also check that the lock has not been corrupted. Issue the pdml again.
ORA-12845: failed to receive interinstance parallel execution message
Cause: OS or interconnect problem receiving interinstance message
Action: Check OS specific diagnostics
ORA-12850: Could not allocate slaves on all specified instances: string needed, string allocated
Cause: When executing a query on a gv$ fixed view, one or more instances failed to allocate a slave to process query.
Action: Check trace output for instances on which slaves failed to start. GV$ query can only proceed if slaves can be allocated on all instances.
ORA-12851: PARALLEL_MAX_SERVERS must be greater than or equal to PARALLEL_MIN_SERVERS, string
Cause: An attempt was made to set the PARALLEL_MAX_SERVERS parameter to a value less than PARALLEL_MIN_SERVERS.
Action: Set PARALLEL_MAX_SERVERS to a value greater than or equal to PARALLEL_MIN_SERVERS value specified in the accompanying message and retry.
ORA-12852: PARALLEL_MIN_SERVERS must be less than PROCESSES, string
Cause: An attempt was made to set the PARALLEL_MIN_SERVERS parameter to a value higher than PROCESSES.
Action: Set PARALLEL_MIN_SERVERS to a value less than PROCESSES value specified in the accompanying message and retry.
ORA-12853: insufficient memory for PX buffers: current stringK, max needed stringK
Cause: Insufficient SGA memory for PX buffers
Action: Reconfigure sga to include at least (max - current) bytes of additional memory
ORA-12854: Parallel query is not supported on temporary LOBs
Cause: The parallel query statement produced a temporary LOB.
Action: Turn off parallelism for the query or underlying table
ORA-12855: cannot run parallel or insert direct load in a loopback
Cause: A loopback was created in the transaction before this operation.
Action: Do not use loopback when using pdml or insert direct load.
ORA-12899: value too large for column string (actual: string, maximum: string)
Cause: An attempt was made to insert or update a column with a value which is too wide for the width of the destination column. The name of the column is given, along with the actual width of the value, and the maximum allowed width of the column. Note that widths are reported in characters if character length semantics are in effect for the column, otherwise widths are reported in bytes.
Action: Examine the SQL statement for correctness. Check source and destination column data types. Either make the destination column wider, or use a subset of the source column (i.e. use substring).
ORA-12900: must specify a default temporary tablespace for a locally managed database
Cause: a locally managed database must have a temporary tablespace other than SYSTEM tablespace
Action: specify the default temporary tablespace when creating a locally managed database
ORA-12901: default temporary tablespace must be of TEMPORARY type
Cause: in a locally managed database, default temporary tablespace must be TEMPORARY type
Action: none
ORA-12902: default temporary tablespace must be SYSTEM or of TEMPORARY type
Cause: in a dictionary managed database, default temporary tablespace must be SYSTEM or TEMPORARY type
Action: none
ORA-12910: cannot specify temporary tablespace as default tablespace
Cause: attempt to assign a temporary tablespace to be a user's default tablespace
Action: assign a permanent tablespace to be the default tablespace
ORA-12911: permanent tablespace cannot be temporary tablespace
Cause: attempt to assign a permanent tablespace to be a user's temporary tablespace
Action: assign a temporary tablespace to be user's temporary tablespace
ORA-12912: Dictionary managed tablespace specified as temporary tablespace
Cause: attempt to assign a dictionary managed tablespace to be a user's temporary tablespace
Action: Assign a locally managed temporary tablespace to be user's temporary tablespace
ORA-12913: Cannot create dictionary managed tablespace
Cause: Attemp to create dictionary managed tablespace in database which has system tablespace as locally managed
Action: Create a locally managed tablespace.
ORA-12914: Cannot migrate tablespace to dictionary managed type
Cause: Attemp to migrate locally managed tablespace to dictionary managed type when the database has locally managed system tablespace.
Action: Command cannot be issued.
ORA-12915: Cannot alter dictionary managed tablespace to read write
Cause: Attemp to alter dictionary managed tablespace to read write in database which has system tablespace as locally managed. This tablespace can only be dropped.
Action: Command cannot be issued.
ORA-12916: Cannot use default permanent tablespace with this release
Cause: To use default permanent tablespace the release should be 10.0 or higher
Action: Check the compatibility setting and reissue the statement
ORA-12918: Invalid tablespace type for default permanent tablespace
Cause: The tablespace is either dropped, temporary or undo
Action: Check the tablespace type and reissue the statement
ORA-12919: Can not drop the default permanent tablespace
Cause: An attemp was made to drop the default permanent tablespace
Action: Make a different tablespace as the default permanent tablespace and reissue the drop
ORA-12920: database is already in force logging mode
Cause: ALTER DATABASE FORCE LOGGING command failed because the database is already in force logging mode.
Action: none
ORA-12921: database is not in force logging mode
Cause: ALTER DATABASE NO FORCE LOGGING command failed because the database is not in force logging mode.
Action: none
ORA-12922: concurrent ALTER DATABASE [NO] FORCE LOGGING command is running
Cause: There is a concurrent ALTER DATABASE FORCE LOGGING or ALTER DATABASE NO FORCE LOGGING command running in the system.
Action: Contact the database administrator who is responsible for the concurrent command.
ORA-12923: tablespace string is in force logging mode
Cause: An attempt to alter the specified tablespace temporary failed because the tablespace is in force logging mode.
Action: Put the tablespace out of force logging mode by ALTER TABLESPACE NO FORCE LOGGING command.
ORA-12924: tablespace string is already in force logging mode
Cause: An attempt to alter the specified tablespace into force logging mode failed because it is already in force logging mode.
Action: none
ORA-12925: tablespace string is not in force logging mode
Cause: An attempt to alter the specified tablespace out of force logging mode failed because it is not in force logging mode.
Action: none
ORA-12926: FORCE LOGGING option already specified
Cause: In CREATE TABLESPACE, the FORCE LOGGING option was specified more than once.
Action: Remove all but one of the FORCE LOGGING options.
ORA-12927: RETENTION option already specified
Cause: In CREATE TABLESPACE, the RETENTION option was specified more than once.
Action: Remove all but one of the RETENTION options.
ORA-12950: SYSTEM tablespace specified as default permanent tablespace
Cause: SYSTEM tablespace was specified as the default permanent during database creation.
Action: If default permanent tablespace is not specified,then SYSTEM will implicitly become the default permanent tablespace. Specify an alternate tablespace or omit the default tablespace clause and reissue the CREATE DATABASE statement
ORA-12951: Attempt to change default permanent tablespace to temporary
Cause: It is incorrect to alter the default permanent tablespace of a database to temporary type
Action: none
ORA-12980: checkpoint option not allowed with SET UNUSED
Cause: An attempt was made to specify checkpoint option with SET UNUSED.
Action: Remove checkpoint option.
ORA-12981: cannot drop column from an object type table
Cause: An attempt was made to drop a column from an object type table.
Action: This action is not allowed.
ORA-12982: cannot drop column from a nested table
Cause: An attempt was made to drop a column from a nested table.
Action: This action is not allowed.
ORA-12983: cannot drop all columns in a table
Cause: An attempt was made to drop all columns in a table.
Action: Make sure at least one column remains in the table after the drop column operation.
ORA-12984: cannot drop partitioning column
Cause: An attempt was made to drop a column used as the partitioning key.
Action: This action is not allowed.
ORA-12985: tablespace 'string' is read only, cannot drop column
Cause: An attempt was made to drop column from a partition/subpartition on a read only tablespace.
Action: Set the tablespace to read write and resubmit statement.
ORA-12986: columns in partially dropped state. Submit ALTER TABLE DROP COLUMNS CONTINUE
Cause: An attempt was made to access a table with columns in partially dropped state (i.e., drop column operation was interrupted).
Action: Submit ALTER TABLE DROP COLUMNS CONTINUE to complete the drop column operation before accessing the table.
ORA-12987: cannot combine drop column with other operations
Cause: An attempt was made to combine drop column with other ALTER TABLE operations.
Action: Ensure that drop column is the sole operation specified in ALTER TABLE.
ORA-12988: cannot drop column from table owned by SYS
Cause: An attempt was made to drop a column from a system table.
Action: This action is not allowed
ORA-12989: invalid value for checkpoint interval
Cause: An invalid checkpoint interval specified in statement. Checkpoint interval must be between 0 and (2^31-1).
Action: Correct checkpoint interval and resubmit statement
ORA-12990: duplicate option specified
Cause: Duplicate option specified in statement.
Action: Remove the duplicate option and resubmit statement.
ORA-12991: column is referenced in a multi-column constraint
Cause: An attempt was made to drop a column referenced by some constraints.
Action: Drop all constraints referencing the dropped column or specify CASCADE CONSTRAINTS in statement.
ORA-12992: cannot drop parent key column
Cause: An attempt was made to drop a parent key column.
Action: Drop all constraints referencing the parent key column, or specify CASCADE CONSTRAINTS in statement.
ORA-12993: tablespace 'string' is offline, cannot drop column
Cause: An attempt was made to drop a column from a partition/subpartition on an offline tablespace.
Action: Bring the tablespace online and resubmit statement.
ORA-12994: drop column option only allowed once in statement
Cause: An attempt was made to repeat the drop column option in a single statement.
Action: Separate drop column options into different statements and resubmit statements.
ORA-12995: no columns in partially dropped state
Cause: An attempt was made to submit DROP COLUMNS CONTINUE statement while there are no partially dropped columns.
Action: Cannot submit this statement.
ORA-12996: cannot drop system-generated virtual column
Cause: An attempt was made to drop a virtual column generated by the system.
Action: none
ORA-12997: cannot drop primary key column from an index-organized table
Cause: An attempt was made to drop a primary key column from an index- organized table.
Action: This action is not allowed.
ORA-13000: dimension number is out of range
Cause: The specified dimension is either smaller than 1 or greater than the number of dimensions encoded in the HHCODE.
Action: Make sure that the dimension number is between 1 and the maximum number of dimensions encoded in the HHCODE.
ORA-13001: dimensions mismatch error
Cause: The number of dimensions in two HHCODEs involved in a binary HHCODE operation do not match.
Action: Make sure that the number of dimensions in the HHCODEs match.
ORA-13002: specified level is out of range
Cause: The specified level is either smaller than 1 or greater than the maximum level encoded in an HHCODE.
Action: Verify that all levels are between 1 and the maximum number of levels encoded in the HHCODE.
ORA-13003: the specified range for a dimension is invalid
Cause: The specified range for a dimension is invalid.
Action: Make sure that the lower bound (lb) is less than the upper bound (ub).
ORA-13004: the specified buffer size is invalid
Cause: The buffer size for a function is not valid.
Action: This is an internal error. Contact Oracle Support Services.
ORA-13005: recursive HHCODE function error
Cause: An error occurred in a recursively called HHCODE function.
Action: This is an internal error. Contact Oracle Support Services.
ORA-13006: the specified cell number is invalid
Cause: The cell identifier is either less than 0 or greater than (2^ndim - 1).
Action: Make sure that the cell identifier is between 0 and (2^ndim - 1).
ORA-13007: an invalid HEX character was detected
Cause: A character that is not in the range [0-9] or [A-F a-f] was detected.
Action: Verify that all characters in a string are in [0-9] or [A-F a-f].
ORA-13008: the specified date format has an invalid component
Cause: Part of specified date format is invalid.
Action: Verify that the date format is valid.
ORA-13009: the specified date string is invalid
Cause: The specified date string has a bad component or does not match the specified format string.
Action: Make sure that the components of the date string are valid and that the date and format strings match.
ORA-13010: an invalid number of arguments has been specified
Cause: An invalid number of arguments was specified for an SDO function.
Action: Verify the syntax of the function call.
ORA-13011: value is out of range
Cause: A specified dimension value is outside the range defined for that dimension.
Action: Make sure that all values to be encoded are within the defined dimension range.
ORA-13012: an invalid window type was specified
Cause: An invalid window type was specified.
Action: Valid window types are RANGE, PROXIMITY, POLYGON.
ORA-13013: the specified topology was not INTERIOR or BOUNDARY
Cause: A topology was specified that was not INTERIOR or BOUNDARY.
Action: Make sure that INTERIOR or BOUNDARY is used to describe an HHCODE's topology.
ORA-13014: a topology identifier outside the range of 1 to 8 was specified
Cause: A topology identifier outside the range of 1 to 8 was specified.
Action: Specify a topology in the range of 1 to 8.
ORA-13015: the window definition is not valid
Cause: The number of values used to define the window does not correspond to the window type.
Action: Verify that the number of values used to defined the window is correct for the window type and number of dimensions.
ORA-13016: specified topology [string] is invalid
Cause: The specified topology did not exist in the database, or some components of the topology were missing from the database.
Action: Check the specified topology by executing the SDO_TOPO.validate_topology function.
ORA-13017: unrecognized line partition shape
Cause: The shape of a 2-D line partition could not be determined.
Action: This is an internal error. Contact Oracle Support Services.
ORA-13018: bad distance type
Cause: The specified distance type is invalid.
Action: The only supported distance functions are EUCLID and MANHATTAN.
ORA-13019: coordinates out of bounds
Cause: Vertex coordinates lie outside the valid range for specified dimension.
Action: Redefine vertex coordinates within specified boundaries.
ORA-13020: coordinate is NULL
Cause: A vertex coordinate has a NULL value.
Action: Redefine vertex coordinate to have non-NULL value.
ORA-13021: element not continuous
Cause: The coordinates defining a geometric element are not connected.
Action: Redefine coordinates for the geometric element.
ORA-13022: polygon crosses itself
Cause: The coordinates defining a polygonal geometric element represent crossing segments.
Action: Redefine coordinates for the polygon.
ORA-13023: interior element interacts with exterior element
Cause: An interior element of a geometric object interacts with the exterior element of that object.
Action: Redefine coordinates for the geometric elements.
ORA-13024: polygon has less than three segments
Cause: The coordinates defining a polygonal geometric element represent less than three segments.
Action: Redefine the coordinates for the polygon.
ORA-13025: polygon does not close
Cause: The coordinates defining a polygonal geometric element represent an open polygon.
Action: Redefine the coordinates of the polygon.
ORA-13026: unknown element type for element string.string.string
Cause: The SDO_ETYPE column in the <layer>_SDOGEOM table contains an invalid geometric element type value.
Action: Redefine the geometric element type in the <layer>_SDOGEOM table for the specified geometric element using one of the supported SDO_ETYPE values. See the Oracle Spatial documentation for an explanation of SDO_ETYPE and its possible values.
ORA-13027: unable to read dimension definition from string
Cause: There was a problem reading the dimension definition from the <layer>_SDODIM table.
Action: Verify that the <layer>_SDODIM table exists and that the appropriate privileges exist on the table. Address any other errors that might appear with the message.
ORA-13028: Invalid Gtype in the SDO_GEOMETRY object
Cause: There is an invalid SDO_GTYPE in the SDO_GEOMETRY object.
Action: Verify that the geometries have valid gtypes.
ORA-13029: Invalid SRID in the SDO_GEOMETRY object
Cause: There is an invalid SDO_SRID in the SDO_GEOMETRY object. The specified SRID may be outside the valid SRID range.
Action: Verify that the geometries have valid SRIDs.
ORA-13030: Invalid dimension for the SDO_GEOMETRY object
Cause: There is a mismatch between the dimension in the SDO_GTYPE and dimension in the SDO_GEOM_METADATA for the SDO_GEOMETRY object.
Action: Verify that the geometries have valid dimensionality.
ORA-13031: Invalid Gtype in the SDO_GEOMETRY object for point object
Cause: There is an invalid SDO_GTYPE in the SDO_GEOMETRY object where the VARRAYs are NULL but the SDO_GTYPE is not of type POINT.
Action: Verify that the geometries have valid gtypes.
ORA-13032: Invalid NULL SDO_GEOMETRY object
Cause: There are invalid SDO_POINT_TYPE or SDO_ELEM_INFO_ARRAY or SDO_ORDINATE_ARRAY fields in the SDO_GEOMETRY object.
Action: Verify that the geometries have valid fields. To specify a NULL geometry, specify the whole SDO_GEOMETRY as NULL instead of setting each field to NULL.
ORA-13033: Invalid data in the SDO_ELEM_INFO_ARRAY in SDO_GEOMETRY object
Cause: There is invalid data in the SDO_ELEM_INFO_ARRAY field of the SDO_GEOMETRY object. The triplets in this field do not make up a valid geometry.
Action: Verify that the geometries have valid data.
ORA-13034: Invalid data in the SDO_ORDINATE_ARRAY in SDO_GEOMETRY object
Cause: There is invalid data in the SDO_ORDINATE_ARRAY field of the SDO_GEOMETRY object. The coordinates in this field do not make up a valid geometry. There may be NULL values for X or Y or both.
Action: Verify that the geometries have valid data.
ORA-13035: Invalid data (arcs in geodetic data) in the SDO_GEOMETRY object
Cause: There is invalid data in the SDO_ELEM_INFO_ARRAY field of the SDO_GEOMETRY object. There are arcs in a geometry that has geodetic coordinates.
Action: Verify that the geometries have valid data.
ORA-13036: Operation [string] not supported for Point Data
Cause: The specified geometry function is not supported for point data.
Action: Make sure that the specified geometry function is not called on point data.
ORA-13037: SRIDs do not match for the two geometries
Cause: A Spatial operation is invoked with two geometries where one geometry has an SRID and the other geometry does not have an SRID.
Action: Make sure that the spatial operations are invoked between two geometries with compatible SRIDs.
ORA-13039: failed to update spatial index for element string.string.string
Cause: Another error will accompany this message that will indicate the problem.
Action: Correct any accompanying errors. If no accompanying error message appears, contact Oracle Support Services.
ORA-13040: failed to subdivide tile
Cause: This is an internal error.
Action: Note any accompanying errors and contact Oracle Support Services.
ORA-13041: failed to compare tile with element string.string.string
Cause: The spatial relationship between a generated tile and the specified element could not be determined.
Action: This is an internal error. Verify the geometry using the VALIDATE_GEOMETRY_WITH_CONTEXT procedure. If the procedure does not return any errors, note any errors that accompany ORA-13041 and contact Oracle Support Services.
ORA-13042: invalid SDO_LEVEL and SDO_NUMTILES combination
Cause: An invalid combination of SDO_LEVEL and SDO_NUMTILES values was read from the <layer>_SDOLAYER table. The most likely cause is that the columns are NULL.
Action: Verify the that SDO_LEVEL and SDO_NUMTILES columns contain valid integer values as described in the Oracle Spatial documentation. Then retry the operation.
ORA-13043: failed to read metadata from the <layer>_SDOLAYER table
Cause: An error was encountered reading the layer metadata from the <layer>_SDOLAYER table.
Action: This error is usually the result of an earlier error which should also have been reported. Address this accompanying error and retry the current operation. If no accompanying error was reported, contact Oracle Support Services.
ORA-13044: the specified tile size is smaller than the tolerance
Cause: The tile size specified for fixed size tessellation is smaller than the tolerance as specified in the layer metadata.
Action: See the Oracle Spatial documentation for an explanation of tiling levels, tile size, and tiling resolution. Ensure that the tiling parameters are set such that any generated tile is always larger than or equal to a tile at the maximum level of resolution. This can be achieved by using a fewer number of tiles per geometric object or specifying a smaller tile size value than the current one.
ORA-13045: invalid compatibility flag
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13046: invalid number of arguments
Cause: An invalid number of arguments were specified for an SDO_GEOM function.
Action: See the Oracle Spatial documentation for a description of the syntax and semantics of the relevant SDO_GEOM function.
ORA-13047: unable to determine ordinate count from table <layer>_SDOLAYER
Cause: An SDO_GEOM function was unable to determine the number of ordinates for the SDO layer <layer>.
Action: Verify that the <layer>_SDOLAYER table has a valid value for the column SDO_ORDCNT. Then retry the operation.
ORA-13048: recursive SQL fetch error
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13049: unable to determine tolerance value from table <layer>_SDODIM
Cause: An SDO_GEOM function was unable to determine the tolerance value for the SDO layer <layer>.
Action: Verify that the <layer>_SDODIM table has a valid value for the column SDO_TOLERANCE.
ORA-13050: unable to construct spatial object
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13051: failed to initialize spatial object
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13052: unsupported geometric type for geometry string.string
Cause: The geometry type for a specific instance in a <layer>_SDOGEOM table is not among the set of geometry types supported by Oracle Spatial.
Action: Check the Oracle Spatial documentation for the list of supported geometry types and workarounds that permit the storage and retrieval of non-supported geometric types with the SDO schema.
ORA-13053: maximum number of geometric elements in argument list exceeded
Cause: The maximum number of geometric elements that can be specified in the argument list for an SDO_GEOM function was exceeded.
Action: Check the Oracle Spatial documentation for the syntax of the SDO_GEOM function and use fewer arguments to describe the geometry, or check the description of the SDO_WINDOW package for a workaround that permits storing the object in a table and then using it in as an argument in a call to the SDO_GEOM function.
ORA-13054: recursive SQL parse error
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13055: Oracle object string does not exist in specified table
Cause: The requested object is not present in the specified table.
Action: Verify the syntax of the function or procedure that reported this error and verify that the object does indeed exist in the specified table. Then retry the operation.
ORA-13108: spatial table string not found
Cause: The specified spatial table does not exist.
Action: Check the Spatial data dictionary to make sure that the table is registered.
ORA-13109: spatial table string exists
Cause: The specified spatial table is registered in the Spatial data dictionary.
Action: Remove the existing table from the Spatial data dictionary or use a different name.
ORA-13110: cannot drop topology with associated topo_geometry tables
Cause: The drop_topology procedure was invoked for a topology that has assocated topo_geometry layers with it.
Action: Delete the topo_geometry layers from the topology before dropping the topology. Use SDO_TOPO.delete_topo_geometry_layer to delete topo_geometry layers from the topology.
ORA-13111: cannot add topo_geometry layer [string] to topology
Cause: It was not possible to add the specified topo_geometry layer to the topology.
Action: Make sure the topo_geometry layer table exists in the database.
ORA-13112: cannot delete topo_geometry layer [string] from topology
Cause: It was not possible to delete the specified topo_geometry layer from the topology.
Action: Check USER_SDO_TOPO_METADATA to see if the specified topo_geometry layer is part of the topology. Only those topo_geometry layers which are part of the topology can be deleted from it.
ORA-13113: invalid tg_layer_id in sdo_topo_geometry constructor
Cause: An invalid layer_id was passed to the SDO_TOPO_GEOMETRY constructor.
Action: Valid layer_ids are obtained by adding a topo_geometry layer to the topology. Check USER_SDO_TOPO_METADATA to find out the layer_id for an existing topo_geometry layer.
ORA-13114: [string]_NODE$ table does not exist
Cause: The NODE$ table for the topology did not exist in the database.
Action: There is a severe corruption of the topology. Call Oracle Support Services with the error number.
ORA-13115: [string]_EDGE$ table does not exist
Cause: The EDGE$ table for the topology did not exist in the database.
Action: There is a severe corruption of the topology. Call Oracle Support Services with the error number.
ORA-13116: [string]_FACE$ table does not exist
Cause: The FACE$ table for the topology did not exist in the database.
Action: There is a severe corruption of the topology. Call Oracle Support Services with the error number.
ORA-13117: [string]_RELATION$ table does not exist
Cause: The RELATION$ table for the topology did not exist in the database.
Action: There is a severe corruption of the topology. Call Oracle Support Services with the error number.
ORA-13118: invalid node_id [string]
Cause: A topology node operation was invoked with an invalid node_id.
Action: Check the topology node$ table to see if the specified node_id exists in the topology.
ORA-13119: invalid edge_id [string]
Cause: A topology edge operation was invoked with an invalid edge_id.
Action: Check the topology edge$ table to see if the specified edge_id exists in the topology.
ORA-13120: invalid face_id [string]
Cause: A topology face operation was invoked with an invalid face_id.
Action: Check the topology face$ table to see if the specified face_id exists in the topology.
ORA-13121: layer type type mismatch with topo_geometry layer type
Cause: The tg_type in SDO_TOPO_GEOMETRY constructor did not match the type specified for the layer.
Action: Check the USER_SDO_TOPO_METADATA view to see the layer type for the layer and use it in the constructor.
ORA-13122: invalid topo_geometry specified
Cause: The SDO_TOPO_GEOMETRY object passed into the function/operator was not valid.
Action: Check the SDO_TOPO_GEOMETRY object and verify that it is a valid topo_geometry object.
ORA-13123: invalid <TOPOLOGY> name specified
Cause: The create_topo operation requires a unique TOPOLOGY name, that already does not exist in the database.
Action: Check to see if there is already an entry in the USER_SDO_TOPO_METADATA (or the MDSYS.SDO_TOPO_METADATA_TABLE) with this topology name.
ORA-13124: unable to determine column id for column string
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13125: partition key is already set
Cause: A partition key is already set for the spatial table.
Action: Only one partition key can be specified per spatial table.
ORA-13126: unable to determine class for spatial table string
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13127: failed to generate target partition
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13128: current tiling level exceeds user specified tiling level
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13129: HHCODE column string not found
Cause: The specified spatial column does not exist.
Action: Verify that the specified column is a spatial column by checking the Spatial data dictionary.
ORA-13135: failed to alter spatial table
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13136: null common code generated
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13137: failed to generate tablespace sequence number
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13138: could not determine name of object string
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13139: could not obtain column definition for string
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13140: invalid target type
Cause: The specified target type is not valid.
Action: Substitute a valid target type. Valid target types are TABLE and VIEW.
ORA-13141: invalid RANGE window definition
Cause: The RANGE window specified is not correctly defined.
Action: A RANGE window is defined by specifying the lower and upper boundary of each dimension as a pair of values (e.g.: lower_bound1,upper_bound1,lower_bound2,upper_bound2,...). There should be an even number of values.
ORA-13142: invalid PROXIMITY window definition
Cause: The PROXIMITY window specified is not correctly defined.
Action: A PROXIMITY window is defined by specifying a center point and a radius. The center point is defined by ND values. There should be ND+1 values.
ORA-13143: invalid POLYGON window definition
Cause: The POLYGON window specified is not correctly defined.
Action: A POLYGON window is defined by specifying N pairs of values that represent the vertices of the polygon. There should be an even number of values.
ORA-13144: target table string not found
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13145: failed to generate range list
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13146: could not find table substitution variable string
Cause: The partition name substitution variable %s was not found in the SQL filter.
Action: The substitution variable %s must be in the SQL filter to indicate where that partition name should be placed.
ORA-13147: failed to generate MBR
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13148: failed to generate SQL filter
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13149: failed to generate next sequence number for spatial table string
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13150: failed to insert exception record
Cause: Operation failed to insert a record into the exception table.
Action: Fix any other errors reported.
ORA-13151: failed to remove exception record
Cause: Operation failed to remove a record from the exception table.
Action: Fix any other errors reported.
ORA-13152: invalid HHCODE type
Cause: Specified HHCODE type is not valid.
Action: Substitute a valid HHCODE type. Valid HHCODE types are POINT and LINE.
ORA-13153: invalid high water mark specified
Cause: The high water mark must be greater than or equal to zero.
Action: Make sure that the high water mark is an integer greater than or equal to zero.
ORA-13154: invalid precision specified
Cause: The precision specified is out of range.
Action: The precision must be an integer greater than or equal to zero.
ORA-13155: invalid number of dimensions specified
Cause: The number of dimensions specified is out of range.
Action: The number of dimension must be between 1 and 32.
ORA-13156: table to be registered string.string is not empty
Cause: The specified table has rows in it.
Action: Make sure that the table to be registered is empty.
ORA-13157: Oracle error ORAstring encountered while string
Cause: The specified Oracle error was encountered.
Action: Correct the Oracle error.
ORA-13158: Oracle object string does not exist
Cause: The specified object does not exist.
Action: Verify that the specified object exists.
ORA-13159: Oracle table string already exists
Cause: The specified table already exists.
Action: Drop the specified table.
ORA-13181: unable to determine length of column string_SDOINDEX.SDO_CODE
Cause: The length of the SDO_CODE column in the <layer>_SDOINDEX table could not be determined.
Action: Make sure that the <layer>_SDOINDEX table exists with the SDO_CODE column. Verify that the appropriate privileges exist on the table. Then retry the operation.
ORA-13182: failed to read element string.string.string
Cause: The specified element could not be read from the <layer>_SDOGEOM table.
Action: Verify that the specified element exists in the table. Then retry the operation.
ORA-13183: unsupported geometric type for geometry string.string
Cause: The geometry type in the <layer>_SDOGEOM table is unsupported.
Action: Modify the geometry type to be one of the supported types.
ORA-13184: failed to initialize tessellation package
Cause: Initialization of the tessellation package failed.
Action: Record the error messages that are returned and contact Oracle Support Services.
ORA-13185: failed to generate initial HHCODE
Cause: This is an internal error.
Action: Record the error messages that are returned and contact Oracle Support Services.
ORA-13186: fixed tile size tessellation failed
Cause: This is an internal error.
Action: Record the error messages that are returned and contact Oracle Support Services.
ORA-13187: subdivision failed
Cause: This is an internal error.
Action: Record the error messages that are returned and contact Oracle Support Services.
ORA-13188: cell decode failed
Cause: This is an internal error.
Action: Record the error messages that are returned and contact Oracle Support Services.
ORA-13189: recursive SQL parse failed
Cause: This is an internal error.
Action: Record the error messages that are returned and contact Oracle Support Services.
ORA-13190: recursive SQL fetch failed
Cause: This is an internal error.
Action: Record the error messages that are returned and contact Oracle Support Services.
ORA-13191: failed to read SDO_ORDCNT value
Cause: This is an internal error.
Action: Record the error messages that are returned and contact Oracle Support Services.
ORA-13192: failed to read number of element rows
Cause: This is an internal error.
Action: Record the error messages that are returned and contact Oracle Support Services.
ORA-13193: failed to allocate space for geometry
Cause: There was insufficient memory to read the geometry from the database.
Action: Validate the geometry. Record the error messages that are returned and contact Oracle Support Services.
ORA-13194: failed to decode supercell
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13195: failed to generate maximum tile value
Cause: This is an internal error.
Action: Record the error messages that are returned and contact Oracle Support Services.
ORA-13196: failed to compute supercell for element string.string.string
Cause: The system was unable to compute the minimum bounding HHCODE or supercell for the geometry.
Action: Another error might accompany this error. Correct the accompanying error. Also, validate the geometry for correctness.
ORA-13197: element string.string.string is out of range
Cause: Tessellation did not generate any tiles for this element. This error could be caused if the geometry definition puts the geometry outside the domain defined in the <layer>_SDODIM table.
Action: Verify that the geometry is valid and within the defined domain.
ORA-13198: Spatial error: string
Cause: Internal error in some Oracle Spatial stored procedure.
Action: Record the sequence of procedure calls or events that preceded this error, and contact Oracle Support Services if the error message text does not clearly specify the cause of the error.
ORA-13199: %s
Cause: This is an internal error.
Action: Contact Oracle Support Services.
ORA-13200: internal error [string] in spatial indexing.
Cause: This is an internal error.
Action: Contact Oracle Support Services with the exact error text.
ORA-13201: invalid parameters supplied in CREATE INDEX statement
Cause: An error was encountered while trying to parse the parameters clause for the spatial CREATE INDEX statement.
Action: Check the Oracle Spatial documentation for the number, syntax, and semantics of expected parameters for spatial index creation.
ORA-13202: failed to create or insert into the SDO_INDEX_METADATA table
Cause: An error was encountered while trying to create the SDO_INDEX_METADATA table or insert data into it.
Action: Verify that the current user has CREATE TABLE privilege and that the user has sufficient quota in the default or specified tablespace.
ORA-13203: failed to read USER_SDO_GEOM_METADATA view
Cause: An error encountered while trying to read the USER_SDO_GEOM_METADATA view.
Action: Check that USER_SDO_GEOM_METADATA has an entry for the current geometry table.
ORA-13204: failed to create spatial index table
Cause: An error was encountered while trying to create the index table.
Action: Check that user has CREATE TABLE privilege in the current schema and that the user has sufficient quota in the default or specified tablespace.
ORA-13205: internal error while parsing spatial parameters
Cause: An internal error was encountered while parsing the spatial parameters.
Action: Check that the parameters passed in the parameter string are all valid.
ORA-13206: internal error [string] while creating the spatial index
Cause: An internal error was encountered while creating the spatial index.
Action: Contact Oracle Support Services with the exact error text.
ORA-13207: incorrect use of the [string] operator
Cause: An error was encountered while evaluating the specified operator.
Action: Check the parameters and the return type of the specified operator.
ORA-13208: internal error while evaluating [string] operator
Cause: An internal error was encountered.
Action: Contact Oracle Support Services with the exact error text.
ORA-13209: internal error while reading SDO_INDEX_METADATA table
Cause: An internal error was encountered while trying to read the SDO_INDEX_METADATA table.
Action: Contact Oracle Support Services. Note this and accompanying error numbers.
ORA-13210: error inserting data into the index table
Cause: An error was encountered while trying to insert data into the index table. Likely causes are:

- Insufficient quota in the current tablespace

- User does not appropriate privileges

Action: Check the accompanying error messages.
ORA-13211: failed to tessellate the window object
Cause: An internal error was encountered while trying to tessellate the window object.
Action: Verify the geometric integrity of the window object using the VALIDATE_GEOMETRY_WITH_CONTEXT procedure.
ORA-13212: failed to compare tile with the window object
Cause: The spatial relationship between a generated tile and the specified window object could not be determined.
Action: This is an internal error. Verify the geometry using the VALIDATE_GEOMETRY_WITH_CONTEXT procedure. If the procedure does not return any errors, note any accompanying errors and contact Oracle Support Services.
ORA-13213: failed to generate spatial index for window object
Cause: Another error, indicating the real cause of the problem, should accompany this error.
Action: Correct any accompanying errors. If no accompanying error message appears, contact Oracle Support Services.
ORA-13214: failed to compute supercell for window object
Cause: The system was unable to compute the minimum bounding tile or supercell for the geometry.
Action: Another error might accompany this error. Correct the accompanying error. Also, validate the geometry for correctness.
ORA-13215: window object is out of range
Cause: Tessellation did not generate any tiles for this geometry. This error could be caused if the geometry definition puts the geometry outside the domain defined in the USER_SDO_GEOM_METADATA view.
Action: Verify that the geometry is valid and within the defined domain.
ORA-13216: failed to update spatial index
Cause: Another error will accompany this message that will indicate the problem.
Action: Correct any accompanying errors. If no accompanying error message appears, contact Oracle Support Services.
ORA-13217: invalid parameters supplied in ALTER INDEX statement
Cause: An error was encountered while trying to parse the parameters clause for the spatial ALTER INDEX statement.
Action: Check the Oracle Spatial documentation for the number, syntax, and semantics of expected parameters for the spatial ALTER INDEX statement.
ORA-13218: max number of supported index tables reached for [string] index
Cause: An add_index parameter was passed to ALTER INDEX when the number of existing index tables is already at maximum.
Action: Delete one of the index tables before adding another index table.
ORA-13219: failed to create spatial index table [string]
Cause: An error was encountered while trying to create the index table.
Action: There is a table in the index's schema with the specified name. The CREATE INDEX statement will try to create an index table with this name. Either rename this table or change the name of the index.
ORA-13220: failed to compare tile with the geometry
Cause: The spatial relationship between a generated tile and the specified geometry could not be determined.
Action: This is an internal error. Validate the geometry using the VALIDATE_GEOMETRY_WITH_CONTEXT procedure. If the procedure does not return any errors, note any errors that accompany ORA-13220 and contact Oracle Support Services.
ORA-13221: unknown geometry type in the geometry object
Cause: The SDO_GTYPE attribute in the geometry object contains an invalid value
Action: Redefine the geometric type in the geometry table using one of the supported SDO_GTYPE values. See the Oracle Spatial documentation for an explanation of SDO_GTYPE and its possible values.
ORA-13222: failed to compute supercell for geometry in string
Cause: The system was unable to compute the minimum bounding tile or supercell for a geometry in the specified table.
Action: Another error might accompany this error. Correct the accompanying error. Also, validate the geometry for correctness.
ORA-13223: duplicate entry for string in SDO_GEOM_METADATA
Cause: There are duplicate entries for the given table and column value pair in the USER_SDO_GEOM_METADATA view.
Action: Check that the specified table and geometry column names are correct. There should be only one entry per table, geometry column pair in the USER_SDO_GEOM_METADATA view.
ORA-13224: zero tolerance specified for layer in USER_SDO_GEOM_METADATA
Cause: A tolerance of zero or NULL is supplied for a layer in USER_SDO_GEOM_METADATA view.
Action: Check the tolerance specified to make sure it is a positive value.
ORA-13225: specified index table name is too long for a spatial index
Cause: An index table name is specified which is longer than the supported length of the spatial index table name.
Action: Check the supported size of the index table name and reduce the size of the index name.
ORA-13226: interface not supported without a spatial index
Cause: The geometry table does not have a spatial index.
Action: Verify that the geometry table referenced in the spatial operator has a spatial index on it.
ORA-13227: SDO_LEVEL values for the two index tables do not match
Cause: The SDO_LEVEL values for the two index tables used in the spatial join operator do not match.
Action: Verify that two compatible indexes are used for the spatial join operator. Quadtree indexes are compatible if they have the same SDO_LEVEL and SDO_NUMTILES values
ORA-13228: spatial index create failed due to invalid type
Cause: An Attempt was made to create a spatial index on a column of type other than SDO_GEOMETRY.
Action: Make sure that the index is created on a column of type SDO_GEOMETRY.
ORA-13230: failed to create temporary table [string] during R-tree creation
Cause: The specified temporary table either already exists or there is not enough tablespace.
Action: Delete the table if it already exists and verify if the current user has CREATE TABLE privileges and has sufficient space in the default or specified tablespace.
ORA-13231: failed to create index table [string] during R-tree creation
Cause: The specified index table either already exists or there is not enough tablespace.
Action: Delete the table if it already exists and verify if the current user has CREATE TABLE privileges and has sufficient space in the default or specified tablespace. If that fails to correct the problem, contact Oracle Support Services.
ORA-13232: failed to allocate memory during R-tree creation
Cause: This feature assumes a minimum of 64K memory for bulk creation.
Action: Create the index for a small subset of the data. Then, use transactional insert operations for the rest of the data.
ORA-13233: failed to create sequence number [string] for R-tree
Cause: The specified sequence number exists.
Action: Delete the sequence object, or contact Oracle Support Services.
ORA-13234: failed to access R-tree-index table [string]
Cause: The index table is either deleted or corrupted.
Action: Rebuild the index or contact Oracle Support Services with accompanying error messages.
ORA-13236: internal error in R-tree processing: [string]
Cause: An internal error occurred in R-tree processing.
Action: Contact Oracle Support Services with the message text.
ORA-13237: internal error during R-tree concurrent updates: [string]
Cause: An inconsistency is encountered during concurrent updates, possibly due to the use of serializable isolation level.
Action: Change the isolation level to "read committed" using the ALTER SESSION statement, or contact Oracle Support Services with the message text.
ORA-13239: sdo_dimensionality not specified during n-d R-tree creation
Cause: An error occurred in reading the dimensionality parameter
Action: Check the documentation for a valid range, and specify the dimensionality as a parameter.
ORA-13240: specified dimensionality greater than that of the query mbr
Cause: An error occurred because of too few values in the query minimum bounding rectangle (MBR).
Action: Omit the dimensionality, or use the dimensionality of the query.
ORA-13241: specified dimensionality does not match that of the data
Cause: An error occurred because the dimensionality specified in the CREATE INDEX statement does not match that of the data.
Action: Change the statement to reflect the data dimensionality.
ORA-13243: specified operator is not supported for 3- or higher-dimensional R-tree
Cause: Currently, an R-tree index with three or more index dimensions can be used only with the SDO_FILTER operator.
Action: Use the SDO_FILTER operator, and check the documentation for the querytype parameter for SDO_FILTER; or contact Oracle Support Services.
ORA-13249: %s
Cause: An internal error was encountered in the extensible spatial index component. The text of the message is obtained from some other server component.
Action: Contact Oracle Support Services with the exact error text.
ORA-13250: insufficient privileges to modify metadata table entries
Cause: The user requesting the operation does not have the appropriate privileges on the referenced tables.
Action: Check that the specified feature and geometry table names are correct, and then verify that the current user has at least SELECT privilege on those tables.
ORA-13251: duplicate entry string in metadata table
Cause: The specified entry already exists in the metadata table.
Action: Check that the specified feature and geometry table names are correct. A feature-geometry table association should be registered only once.
ORA-13260: layer table string does not exist
Cause: Data migration source table <layer>_SDOGEOM does not exist.
Action: Ensure that the specified layer name is correct and that the corresponding spatial layer tables exist in the current schema.
ORA-13261: geometry table string does not exist
Cause: The specified geometry table does not exist in the current schema.
Action: Create a table containing a column of type SDO_GEOMETRY and a column of type NUMBER for the GID values.
ORA-13262: geometry column string does not exist in table string
Cause: The specified table does not have a column of type SDO_GEOMETRY.
Action: Alter or re-create the table such that it includes a column of type SDO_GEOMETRY and a column of type NUMBER.
ORA-13263: column string in table string is not of type SDO_GEOMETRY
Cause: The column intended for storing the geometry is not of type SDO_GEOMETRY.
Action: Alter the column definition to be of type SDO_GEOMETRY.
ORA-13264: geometry identifier column string does not exist in table string
Cause: The specified table does not contain a GID column.
Action: Confirm that the GID column name was correctly specified and that it exists in the specified table.
ORA-13265: geometry identifier column string in table string is not of type NUMBER
Cause: GID column is not of type NUMBER.
Action: Alter the table definition such that the column containing the geometry identifier (GID) is of type NUMBER.
ORA-13266: error inserting data into table string
Cause: An OCI error occurred, or the user has insufficient quota in the active tablespace, or the rollback segments are too small.
Action: There should be an accompanying error message that indicates the cause of the problem. Take appropriate action to correct the indicated problem.
ORA-13267: error reading data from layer table string
Cause: There was an error reading the geometry data from the <layer>_SDOGEOM table.
Action: Verify that <layer>_SDOGEOM and <layer>_SDODIM exist. If they do exist, run VALIDATE_LAYER_WITH_CONTEXT on the specified layer.
ORA-13268: error obtaining dimension from USER_SDO_GEOM_METADATA
Cause: There is no entry in the USER_SDO_GEOM_METADATA view for the specified geometry table.
Action: Insert an entry for the destination geometry table with the correct dimension information.
ORA-13269: internal error [string] encountered when processing geometry table
Cause: An internal error occurred.
Action: Contact Oracle Support Services with the exact error message text.
ORA-13270: OCI error string
Cause: An OCI error occurred while processing the layer or geometry tables.
Action: Take the appropriate steps to correct the OCI-specific error.
ORA-13271: error allocating memory for geometry object
Cause: Insufficient memory.
Action: Make more memory available to the current session/process.
ORA-13272: geometric object string in table string is invalid
Cause: The specified object failed the geometric integrity checks performed by the validation function.
Action: Check the Oracle Spatial documentation for information about the geometric integrity checks performed by VALIDATE_GEOMETRY_WITH_CONTEXT and correct the geometry definition if required.
ORA-13273: dimension metadata table string does not exist
Cause: The <layer>_SDODIM table does not exist.
Action: Verify that the specified layer name is correct and that the <layer>_SDODIM table exists in the current schema.
ORA-13274: operator invoked with non-compatible SRIDs
Cause: A Spatial operator was invoked with a window geometry with an SRID but the layer has no SRID; or the window has no SRID but the layer has an SRID.
Action: Make sure that the layer and window both have an SRID or that they both do not have an SRID.
ORA-13275: spatial index creation failure on unsupported type
Cause: An attempt was made to create a spatial index create on a column that is not of type SDO_GEOMETRY.
Action: A spatial index can only be created on a column of type SDO_GEOMETRY. Make sure the indexed column is of type SDO_GEOMETRY.
ORA-13276: internal error [string] in coordinate transformation
Cause: OCI internal error.
Action: Contact Oracle Support Services with the exact error message text.
ORA-13278: failure to convert SRID to native format
Cause: OCI internal error.
Action: Contact Oracle Support Services with the exact error message text.
ORA-13281: failure in execution of SQL statement to retrieve WKT
Cause: OCI internal error, or SRID does not match a table entry.
Action: Check that a valid SRID is being used.
ORA-13282: failure on initialization of coordinate transformation
Cause: Parsing error on source or destination coordinate system WKT, or incompatible coordinate systems.
Action: Check the validity of the WKT for table entries, and check if the requested transformation is valid.
ORA-13283: failure to get new geometry object for conversion in place
Cause: OCI internal error.
Action: Contact Oracle Support Services with the exact error message text.
ORA-13284: failure to copy geometry object for conversion in place
Cause: OCI internal error.
Action: Contact Oracle Support Services with the exact error message text.
ORA-13285: Geometry coordinate transformation error
Cause: A coordinate pair was out of valid range for a conversion/projection.
Action: Check that data to be transformed is consistent with the desired conversion/projection.
ORA-13287: can't transform unknown gtype
Cause: A geometry with a gtype of <= 0 was specified for transformation. Only a gtype >= 1 is allowed.
Action: Check the Oracle Spatial documentation for SDO_GTYPE values, and specify a value whose last digit is 1 or higher.
ORA-13288: point coordinate transformation error
Cause: An internal error occurred while transforming points.
Action: Check the accompanying error messages.
ORA-13290: the specified unit is not supported
Cause: An Oracle Spatial function was called with an unknown UNIT value.
Action: Check Spatial documentation for the supported units, and call the function with the correct UNIT parameter.
ORA-13291: conversion error between the specified unit and standard unit
Cause: Cannot convert the specified unit from/to standard unit for linear distance, angle, or area.
Action: Check the unit specification and respecify it.
ORA-13292: incorrect ARC_TOLERANCE specification
Cause: When a SDO_BUFFER or SDO_AGGR_BUFFER function is called on a geodetic geometry, or SDO_ARC_DENSIFY is called, ARC_TOLERANCE must be specified, and it should not be less than the tolerance specified for the geometry.
Action: Check ARC_TOLERANCE specification and make sure it is correct.
ORA-13293: cannot specify unit for geometry without a georeferenced SRID
Cause: An Oracle Spatial function with a UNIT parameter was called on a geometry without a georeferenced SRID.
Action: Make sure that spatial functions with UNIT parameters are only called on geometries with georeferenced SRIDs.
ORA-13294: cannot transform geometry containing circular arcs
Cause: It is impossible to transform a 3-point representation of a circular arc without distortion.
Action: Make sure a geometry does not contain circular arcs.
ORA-13295: geometry objects are in different coordinate systems
Cause: An Oracle Spatial function was called with two geometries that have different SRIDs.
Action: Transform geometry objects to be in the same coordinate system and call the spatial function.
ORA-13296: incorrect coordinate system specification
Cause: Wrong numbers in WKT for Earth radius or flattening for the current SRID.
Action: Check WKT in the MDSYS.CS_SRS table for Earth radius and inverse flattening.
ORA-13300: single point transform error
Cause: Low-level coordinate transformation error trap.
Action: Check the accompanying error messages.
ORA-13303: failure to retrieve a geometry object from a table
Cause: OCI internal error.
Action: Contact Oracle Support Services with the exact error message text.
ORA-13304: failure to insert a transformed geometry object in a table
Cause: OCI internal error.
Action: Contact Oracle Support Services with the exact error message text.
ORA-13330: invalid MASK
Cause: The MASK passed to the RELATE function is not valid.
Action: Verify that the mask is not NULL. See the Oracle Spatial documentation for a list of supported masks.
ORA-13331: invalid LRS segment
Cause: The given LRS segment was not a valid line string.
Action: A valid LRS geometric segment is a line string geometry in Oracle Spatial. It could be a simple or compound line string (made of lines or arcs, or both). The dimension information must include the measure dimension as the last element in the Oracle Spatial metadata. Currently, the number of dimensions for an LRS segment must be greater than 2 (x/y or longitude/latitude, plus measure)
ORA-13332: invalid LRS point
Cause: The specified LRS point was not a point geometry with measure information.
Action: Check the given point geometry. A valid LRS point is a point geometry in Oracle Spatial with an additional dimension for measure.
ORA-13333: invalid LRS measure
Cause: The given measure for linear referencing was out of range.
Action: Redefine the measure.
ORA-13334: LRS segments not connected
Cause: The specified geometric segments are not connected.
Action: Check the start/end points of the given geometric segments.
ORA-13335: LRS measure information not defined
Cause: The measure information of a geometric segment was not assigned (IS NULL).
Action: Assign/define the measure information. An LRS geometric segment is defined if its start and end measure are assigned (non-null).
ORA-13336: failure in converting standard diminfo/geometry to LRS dim/geom
Cause: There is no room for the measure dimension in the given diminfo, or the specified standard geometry is not a point a line string.
Action: Check if the diminfo dimensions are less than 3 or if the geometry type is point or line string.
ORA-13337: failure in concatenating LRS polygons
Cause: LRS concatenation involving LRS polygons is not supported.
Action: Check the geometry and element types to make sure the concatenate operation is not called with a polygon type.
ORA-13338: failure in reversing LRS polygon/collection geometry
Cause: Reversing an LRS polygon/collection geometry produces an invalid geometry.
Action: Check the geometry type to make sure this operation is called on non-polygon geometries.
ORA-13339: LRS polygon clipping across multiple rings
Cause: Clipping (dynseg) a polygon across multiple rings is not allowed.
Action: Polygon clipping is allowed only for a single ring.
ORA-13340: a point geometry has more than one coordinate
Cause: A geometry, specified as being a point, has more than one coordinate in its definition.
Action: A point has only one coordinate. If this geometry is intended to represent a point cluster, line, or polygon, set the appropriate SDO_GTYPE or SDO_ETYPE value. If this is a single point object, remove the extraneous coordinates from its definition.
ORA-13341: a line geometry has fewer than two coordinates
Cause: A geometry, specified as being a line, has fewer than two coordinates in its definition.
Action: A line must consist of at least two distinct coordinates. Correct the geometric definition, or set the appropriate SDO_GTYPE or SDO_ETYPE attribute for this geometry.
ORA-13342: an arc geometry has fewer than three coordinates
Cause: A geometry, specified as being an arc, has fewer than three coordinates in its definition.
Action: An arc must consist of at least three distinct coordinates. Correct the geometric definition, or set the appropriate SDO_GTYPE or SDO_ETYPE attribute for this geometry.
ORA-13343: a polygon geometry has fewer than four coordinates
Cause: A geometry, specified as being a polygon, has fewer than four coordinates in its definition.
Action: A polygon must consist of at least four distinct coordinates. Correct the geometric definition, or set the appropriate SDO_GTYPE or SDO_ETYPE attribute for this geometry.
ORA-13344: an arcpolygon geometry has fewer than five coordinates
Cause: A geometry, specified as being an arcpolygon, has fewer than five coordinates in its definition.
Action: An arcpolygon must consist of at least five coordinates. An arcpolygon consists of an ordered sequence of arcs, each of which must be described using three coordinates. Since arcs are connected the end-point of the first is the start of the second and does not have to be repeated. Correct the geometric definition, or set the appropriate SDO_GTYPE or SDO_ETYPE attribute for this geometry.
ORA-13345: a compound polygon geometry has fewer than five coordinates
Cause: A geometry, specified as being a compound polygon, has fewer than five coordinates in its definition.
Action: A compound polygon must contain at least five coordinates. A compound polygon consists of at least one arc and one line, each of which must be described using three and at least two distinct coordinates respectively. Correct the geometric definition, or set the appropriate SDO_GTYPE or SDO_ETYPE attribute for this geometry.
ORA-13346: the coordinates defining an arc are collinear
Cause: Invalid definition of an arc. An arc is defined using three non-collinear coordinates.
Action: Alter the definition of the arc, or set the SDO_ETYPE or SDO_GTYPE to the line type.
ORA-13347: the coordinates defining an arc are not distinct
Cause: Two or more of the three points defining an arc are the same.
Action: Alter the definition of the arc to ensure that three distinct coordinate values are used.
ORA-13348: polygon boundary is not closed
Cause: The boundary of a polygon does not close.
Action: Alter the coordinate values or the definition of the SDO_GTYPE or SDO_ETYPE attribute of the geometry.
ORA-13349: polygon boundary crosses itself
Cause: The boundary of a polygon intersects itself.
Action: Correct the geometric definition of the object.
ORA-13350: two or more rings of a complex polygon touch
Cause: The inner or outer rings of a complex polygon touch.
Action: All rings of a complex polygon must be disjoint. Correct the geometric definition of the object.
ORA-13351: two or more rings of a complex polygon overlap
Cause: The inner or outer rings of a complex polygon overlap.
Action: All rings of a complex polygon must be disjoint. Correct the geometric definition of the object.
ORA-13352: the coordinates do not describe a circle
Cause: The set of coordinates used to describe a circle are incorrect.
Action: Confirm that the set of coordinates actually represent points on the circumference of a circle.
ORA-13353: ELEM_INFO_ARRAY not grouped in threes
Cause: The ELEM_INFO_ARRAY in an SDO_GEOMETRY definition has more or fewer elements than expected.
Action: Confirm that the number of elements in ELEM_INFO_ARRAY is divisible by 3.
ORA-13354: incorrect offset in ELEM_INFO_ARRAY
Cause: The offset field in ELEM_INFO_ARRAY of an SDO_GEOMETRY definition references an invalid array subscript in SDO_ORDINATE_ARRAY.
Action: Confirm that the offset is a valid array subscript in SDO_ORDINATE_ARRAY.
ORA-13355: SDO_ORDINATE_ARRAY not grouped by number of dimensions specified
Cause: The number of elements in SDO_ORDINATE_ARRAY is not a multiple of the number of dimensions supplied by the user.
Action: Confirm that the number of dimensions is consistent with data representation in SDO_ORDINATE_ARRAY.
ORA-13356: adjacent points in a geometry are redundant
Cause: There are repeated points in the sequence of coordinates.
Action: Remove the redundant point.
ORA-13357: extent type does not contain 2 points
Cause: Extent type should be represented by two points: lower left and upper right.
Action: Confirm that there are only two points for an extent type.
ORA-13358: circle type does not contain 3 points
Cause: Circle type should be represented by three distinct points on the circumference.
Action: Confirm that there are only three points for a circle type.
ORA-13359: extent does not have an area
Cause: The two points representing the extent are identical.
Action: Confirm that the two points describing the extent type are distinct.
ORA-13360: invalid subtype in a compound type
Cause: This subtype is not allowed within the ETYPE specified.
Action: Check the Oracle Spatial documentation for type definitions.
ORA-13361: not enough sub-elements within a compound ETYPE
Cause: The compound type declare more sub-elements than actually defined.
Action: Confirm that the number of sub-elements is consistent with the compound type declaration.
ORA-13362: disjoint sub-element in a compound polygon
Cause: Compound polygon must describe an enclosed area.
Action: Confirm that all sub-elements are connected.
ORA-13363: no valid ETYPE in the geometry
Cause: None of the ETYPEs within the geometry is supported.
Action: Confirm that there is at least one valid ETYPE.
ORA-13364: layer dimensionality does not match geometry dimensions
Cause: The spatial layer has a geometry with a different dimensions than the dimensions specified for the layer.
Action: Make sure that all geometries in a layer have the same dimensions and that they match the dimensions in the SDO_DIM_ARRAY object for the layer in the USER_SDO_GEOM_METADATA view.
ORA-13365: layer SRID does not match geometry SRID
Cause: The spatial layer has a geometry with a different SRID than the SRID specified for the layer.
Action: Make sure that all geometries in a layer have the same SRID and that the SRIDs match the SRID for the layer in the USER_SDO_GEOM_METADATA view.
ORA-13366: invalid combination of interior exterior rings
Cause: In an Oracle Spatial geometry, interior and exterior rings are not used consistently.
Action: Make sure that the interior rings corresponding to an exterior ring follow the exterior ring in the ordinate array.
ORA-13367: wrong orientation for interior/exterior rings
Cause: In an Oracle Spatial geometry, the exterior and/or interior rings are not oriented correctly.
Action: Be sure that the exterior rings are oriented counterclockwise and the interior rings are oriented clockwise.
ORA-13368: simple polygon type has more than one exterior ring
Cause: In a polygon geometry there is more than one exterior ring.
Action: Set the type to be multipolygon if more than one exterior ring is present in the geometry.
ORA-13369: invalid value for etype in the 4-digit format
Cause: A 4-digit etype for a non-polygon type element is used, or the orientation is not a valid orientation for interior/exterior rings of the polygon.
Action: Correct the geometry definition.
ORA-13370: failure in applying 3D LRS functions
Cause: Only non-geodetic 3D line string geometries (made of line segments) are supported for 3D LRS functions.
Action: Check the geometry and element types and the SRID values.
ORA-13371: invalid position of measure dimension
Cause: LRS measure dimension has to be after spatial dimensions. The position has to be either 3rd or 4th in the dim_info_array.
Action: Check the geometry's gtype and its position in the dim_info_array.
ORA-13372: failure in modifying metadata for a table with spatial index
Cause: Modifying the metadata after the index is created will cause an inconsistency between the geometry's gtype and diminfo.
Action: Modify (or Prepare) metadata before creating an index on the SDO_GEOMETRY column.
ORA-13373: element of type extent is not supported for geodetic data
Cause: Element type extent for a polygon geometry is not supported for geodetic data.
Action: Convert the extent type polygon to a regular 5-point polygon and set the etype accordingly.
ORA-13374: SDO_MBR not supported for geodetic data
Cause: The SDO_MBR functionality is not supported for geodetic data.
Action: Find an alternative function that can be used in this context.
ORA-13375: the layer is of type [string] while geometry inserted has type [string]
Cause: The layer has a type that is different or inconsistent with the type of the current geometry.
Action: Change the geometry type to agree with the layer type, or change the layer type to agree with the geometry type.
ORA-13376: invalid type name specified for layer_gtype parameter
Cause: An invalid type name is specified for the layer_gtype constraint.
Action: See the Spatial documentation for of valid keywords that can be used in defining a layer_gtype constraint.
ORA-13377: invalid combination of elements with orientation
Cause: An element of the geometry has orientation specified while some other element has no orientation specified (4-digit etype).
Action: Make sure all the polygon elements have orientation specified using the 4-digit etype notation.
ORA-13378: invalid index for element to be extracted
Cause: An invalid (or out of bounds) index was specified for extracting an element from a geometry.
Action: Make sure the parameters to the extract function are in the valid range for the geometry.
ORA-13379: invalid index for sub-element to be extracted
Cause: An invalid (or out of bounds) index was specified for extracting a sub-element from a geometry.
Action: Make sure the parameters to the extract function are in the valid range for the geometry.
ORA-13380: network not found
Cause: The specified network was not found in the network metadata.
Action: Insert the network information in the USER_SDO_NETWORK_METADATA view.
ORA-13381: table:string not found in network:string
Cause: The specified table was not found in the network metadata.
Action: Insert the table information in the USER_SDO_NETWORK_METADATA view.
ORA-13382: geometry metadata (table:string column:string) not found in spatial network:string
Cause: The specified geometry metadata was not found in the spatial network metadata.
Action: Insert the spatial metadata information in the USER_SDO_NETWORK_METADATA view.
ORA-13383: inconsistent network metadata: string
Cause: There was an inconsistency between the network metadata and the node/link information.
Action: Check the network metadata and the node/link information.
ORA-13384: error in network schema: string
Cause: The network table(s) did not have required column(s)
Action: Check the network schema.
ORA-13385: error in network manager: [string]
Cause: There was an internal error in network manager.
Action: Contact Oracle Customer Support for more help.
ORA-13386: commit/rollback operation error: [string]
Cause: The index-level changes were not fully incorporated as part of the commit or rollback operation.
Action: Correct the specified error and use the following statement: ALTER INDEX <index-name> PARAMETERS ('index_status=synchronize');
ORA-13387: sdo_batch_size for array inserts should be in the range [number,number]
Cause: The specified value for sdo_batch_size was too high or too low.
Action: Change the value to be in the specified range.
ORA-13388: invalid value for dst_spec parameter
Cause: The dst_spec parameter was specified in the wrong format.
Action: Check the documentation for this parameter.
ORA-13389: unable to compute buffers or intersections in analysis function
Cause: There was an internal error in computing the buffers or intersections in the specified spatial analysis function.
Action: Modify the tolerance value in the USER_SDO_GEOM_METADATA view before invoking the spatial analysis function.
ORA-13390: error in spatial analysis and mining function: [string]
Cause: There was an internal error in the specified analysis function.
Action: Contact Oracle Customer Support for more help.
ORA-13401: duplicate entry for string in USER_SDO_GEOR_SYSDATA view
Cause: The RASTER_DATA_TABLE and RASTER_ID columns contained the same information in two or more rows in the USER_SDO_GEOR_SYSDATA view.
Action: Ensure that the RASTER_DATA_TABLE and RASTER_ID columns in the USER_SDO_GEOR_SYSDATA view contain the correct information, and that the value pair is unique for each row.
ORA-13402: the rasterType is null or not supported
Cause: The specified rasterType was null or not supported.
Action: Check the documentation for the rasterType number and/or formats supported by GeoRaster.
ORA-13403: invalid rasterDataTable specification
Cause: One GeoRaster object must have one corresponding RDT table and this table must be of SDO_RASTER type if it is created. However, this was not the case.
Action: Check the rasterDataTable name specification and make sure that it is not null, that the corresponding table doesn't exist, and that it is of SDO_RASTER type if the table exists.
ORA-13404: invalid ultCoordinate parameter
Cause: The ultCoordinate array parameter had the wrong length or contained an invalid value.
Action: Check the documentation, and make sure the ultCoordinate parameter is correct.
ORA-13405: null or invalid dimensionSize parameter
Cause: The dimensionSize array parameter was null, had the wrong length, or contained an invalid value.
Action: Check the documentation, and make sure the dimensionSize parameter is correct.
ORA-13406: null or invalid GeoRaster object for output
Cause: The GeoRaster object for output was null or invalid.
Action: Make sure the GeoRaster object for output has been initialized properly.
ORA-13407: invalid storage parameter
Cause: The storage parameter contained an invalid specification.
Action: Check the documentation, and make sure the storage parameter is correct.
ORA-13408: invalid blockSize storage parameter
Cause: The blockSize storage parameter had the wrong length or contained invalid value.
Action: Check the documentation, and make sure the blockSize storage parameter is correct.
ORA-13409: null or invalid pyramidLevel parameter
Cause: The specified pyramidLevel parameter was null or invalid.
Action: Make sure the pyramidLevel parameter specifies a valid pyramid level value for the GeoRaster object.
ORA-13410: invalid layerNumbers or bandNumbers parameter
Cause: The layerNumbers or bandNumbers parameter was invalid.
Action: Check the documentation and make sure the layerNumbers or bandNumbers parameter is valid.
ORA-13411: subset results in null data set
Cause: The intersection of cropArea and source GeoRaster object was null.
Action: Check the documentation, and make sure the cropArea parameter is correct.
ORA-13412: invalid scale parameter
Cause: The scale parameter was invalid.
Action: Check the documentation, and make sure the scale parameter is correct.
ORA-13413: null or invalid resampling parameter
Cause: The resampling parameter was null or invalid.
Action: Check the documentation, and make sure the resampling parameter is correct.
ORA-13414: invalid pyramid parameter
Cause: The pyramid parameter was invalid.
Action: Check the documentation, and make sure the pyramid parameter is correct.
ORA-13415: invalid or out of scope point specification
Cause: The point position specified by the <ptGeom, layerNumber> or <rowNumber, colNumber, bandNumber> parameter combination was invalid or out of scope.
Action: Make sure the parameter(s) specify a valid point that is or can be translated into a cell position inside the cell space of the GeoRaster object.
ORA-13416: invalid geometry parameter
Cause: The geometry parameter did not specify a valid single-point geometry.
Action: Specify a valid single-point geometry.
ORA-13417: null or invalid layerNumber for get functions
Cause: The layerNumber parameter was null or out of scope.
Action: Specify a valid layerNumber parameter.
ORA-13418: null or invalid parameter(s) for set functions
Cause: A parameter for set metadata operations was null or invalid.
Action: Check the documentation for information about the parameters.
ORA-13419: cannot perform mosaick operation on the specified table column
Cause: An attempt to perform a mosaick operation failed because the GeoRaster objects in the specified table column did not meet necessary conditions.
Action: Check the documentation for SDO_GEOR.Mosaick for details.
ORA-13420: the SRID of the geometry parameter was not null
Cause: The input geometry must be in the GeoRaster cell space, which has a null SRID value.
Action: Make sure the geometry parameter has a null SRID.
ORA-13421: null or invalid cell value
Cause: The cell value was null or out of scope.
Action: Make sure the cell value is not null and is in the range as designated by the cellDepth of the specified GeoRaster object.
ORA-13422: invalid model coordinate parameter
Cause: The model coordinate array parameter had the wrong length or had null ordinate element(s).
Action: Make sure the model coordinate parameter is valid.
ORA-13423: invalid cell coordinate parameter
Cause: The cell coordinate array parameter had the wrong length or had null ordinate element(s).
Action: Make sure the cell coordinate parameter is valid.
ORA-13424: the GeoRaster object is not spatially referenced
Cause: The GeoRaster object was not spatially referenced.
Action: Make sure the GeoRaster object is spatially referenced.
ORA-13425: function not implemented
Cause: This specific function was not implemented.
Action: Do not use the function that causes this error.
ORA-13426: invalid window parameter for subset operation
Cause: The specified window parameter was invalid.
Action: Specify a valid window parameter. Check the documentation for details.
ORA-13427: invalid BLOB parameter for output
Cause: The specified output BLOB parameter was invalid.
Action: Make sure the output BLOB parameter is initialized properly.
ORA-13428: invalid modelCoordinateLocation
Cause: The program [or user] specified a modelCoordinateLocation that is not supported, or the modelCoordinateLocation of the GeoRaster object was wrong.
Action: Set or specify the modelCoordinateLocation to be CENTER (0) or UPPERLEFT (1).
ORA-13429: invalid xCoefficients or yCoefficients parameter(s)
Cause: An attempt to perform a georeference operation failed. Possible reasons include xCoefficients or yCoefficients having the wrong number of coefficients or invalid coefficients.
Action: Check the documentation for supported coefficient specifications.
ORA-13430: the GeoRaster object has null attribute(s)
Cause: The metadata or rasterType of the GeoRaster object was null.
Action: This object may only be used as an output parameter of procedures or functions. It is not valid for other purposes.
ORA-13431: GeoRaster metadata rasterType error
Cause: The rasterType in the metadata of the GeoRaster object was inconsistent with the GeoRaster rasterType attribute.
Action: Make sure the rasterType in the metadata of the GeoRaster object and the GeoRaster rasterType attribute have the same value.
ORA-13432: GeoRaster metadata blankCellValue error
Cause: The blankCellValue specification could be found in the metadata of a blank GeoRaster object.
Action: Add blankCellValue to the metadata whenever isBlank is true.
ORA-13433: GeoRaster metadata default RGB error
Cause: At least one of the defaultRed, defaultGreen, and defaultBlue values (logical layer numbers) was zero, negative, or out of range.
Action: Check the documentation for details.
ORA-13434: GeoRaster metadata cellRepresentation error
Cause: The cellRepresentation type was not supported.
Action: Check the documentation for supported cellRepresentation types.
ORA-13435: GeoRaster metadata dimension inconsistent
Cause: The specification of dimensions or totalDimensions was inconsistent with rasterType, or vice versa.
Action: Make sure dimension specifications are consistent.
ORA-13436: GeoRaster metadata dimensionSize error
Cause: Either the dimensionSize for each dimension was not specified, or an extraneous dimensionSize was specified.
Action: Add a dimsenionSize for each dimension of the GeoRaster object and delete extra dimensionSize elements.
ORA-13437: GeoRaster metadata blocking error
Cause: Either the wrong block number(s) or block size(s) along dimensions were specified, or the block numbers and sizes when taken together were not consistent.
Action: Check the documentation for details.
ORA-13438: GeoRaster metadata pyramid type error
Cause: The specified pyramid type was not supported.
Action: Check the documentation for supported pyramid types.
ORA-13439: GeoRaster metadata pyramid maxLevel error
Cause: The specified maxLevel exceeded the maximum level allowed by the specified pyramid type.
Action: Check the documentation for supported pyramid types and their total level limitations.
ORA-13440: GeoRaster metadata compression type error
Cause: The specified compression type was not supported.
Action: Check the documentation for supported compression types.
ORA-13441: GeoRaster metadata SRS error
Cause: The referenced GeoRaster object had no defined polynomial referencing model.
Action: Define or generate the polynomialModel, or set isReferenced to FALSE.
ORA-13442: GeoRaster metadata SRS error
Cause: The polynomialModel did not match the supported number of variables.
Action: Check the documentation for supported number of variables in the polynomialModel specification.
ORA-13443: GeoRaster metadata SRS error
Cause: The polynomialModel specification had an incorrect pType value.
Action: Check the documentation for supported polynomial types.
ORA-13444: GeoRaster metadata SRS error
Cause: The polynomialModel specification had the wrong number of coefficients.
Action: Check the documentation for the required number of coefficients under different conditions.
ORA-13445: GeoRaster metadata SRS error
Cause: The polynomialModel specification had a zero denominator.
Action: Make sure the denominator of the polynomialModel specification is not zero.
ORA-13446: GeoRaster metadata TRS error
Cause: The GeoRaster Temporal Reference System was not supported.
Action: Set isReferenced to FALSE.
ORA-13447: GeoRaster metadata BRS error
Cause: The GeoRaster Band Reference System was not supported.
Action: Set isReferenced to FALSE.
ORA-13448: GeoRaster metadata BRS error
Cause: The GeoRaster spectral extent specification was incorrect.
Action: The MIN value must be less than the MAX value in the spectralExtent element.
ORA-13449: GeoRaster metadata ULTCoordinate error
Cause: The GeoRaster rasterInfo ULTCoordinate was not correct.
Action: Check the documentation for restrictions.
ORA-13450: GeoRaster metadata layerInfo error
Cause: The GeoRaster had more than one layerInfo element, or the layerDimension value was not supported.
Action: The current release only supports one layerInfo element; layer can only be defined along one dimension, and this dimension must be BAND.
ORA-13451: GeoRaster metadata scaling function error
Cause: The scaling function had a zero denominator.
Action: Make sure the scaling function denominator is not zero.
ORA-13452: GeoRaster metadata BIN function error
Cause: The bin function data did not match its type.
Action: For EXPLICIT type, provide a binTableName element; otherwise, provide a binFunctionData element.
ORA-13453: GeoRaster metadata layer error
Cause: Too many subLayers were defined for the GeoRaster object, or layerNumber or layerDimensionOrdinate was not assigned correctly.
Action: The total number of logical layers cannot exceed the total number of physical layers, and each logical layer must be assigned a valid physical layer number following the same order. Check the documentation for more details.
ORA-13454: GeoRaster metadata is invalid
Cause: The GeoRaster metadata was invalid against its XML Schema.
Action: Run the schemaValidate routine to find the errors.
ORA-13455: GeoRaster metadata TRS error
Cause: The beginDateTime value was later than the endDateTime value.
Action: Make sure that the beginDateTime value is not later than the endDateTime value.
ORA-13456: GeoRaster cell data error
Cause: There was error in the GeoRaster cell data.
Action: The GeoRaster object is invalid.
ORA-13457: GeoRaster cell data error
Cause: There was error in the cell data of the pyramids.
Action: Delete the pyramids and re-generate them.
ORA-13458: GeoRaster metadata SRS error
Cause: The polynomial model did not match the requirements of a rectified GeoRaster object.
Action: Check the documentation for the requirements of the polynomial model for a rectified GeoRaster object, or set isRectified to be false.
ORA-13459: GeoRaster metadata SRS error
Cause: The polynomial model was not an six-parameter transformation, or the six-parameter transformation was not valid.
Action: Check the documentation and make sure the polynomial model is a valid six-parameter affine transformation.
ORA-13460: GeoRaster metadata SRS error
Cause: The referenced GeoRaster object had a zero model space SRID or the specified model space SRID was zero.
Action: Set or specify the model space SRID to be a nonzero number.
ORA-13461: the interleaving type is not supported
Cause: The interleaving type of the GeoRaster object was not supported.
Action: Check the documentation for the interleaving types supported by GeoRaster. Use SDO_GEOR.changeFormat to transform the image to a supported interleaving type.
ORA-13462: invalid blocking specification
Cause: The specified blocking configuration was invalid.
Action: Block size must always be a power of 2.
ORA-13463: error retrieving GeoRaster data: string
Cause: An internal error occurred while retrieving GeoRaster data from the database.
Action: Check the error message for details.
ORA-13464: error loading GeoRaster data: string
Cause: An internal error occurred while loading GeoRaster data into the database.
Action: Check the error message for details.
ORA-13465: null or invalid table or column specification
Cause: The specified table or column did not exist, or the column was not a GeoRaster column.
Action: Make sure the specified table exists and the specified column is a GeoRaster column.
ORA-13480: the Source Type is not supported
Cause: The specified source type was not supported.
Action: Check the documentation for the source types (such as FILE and HTTP) supported by GeoRaster.
ORA-13481: the destination type is not supported
Cause: The specified destination type was not supported.
Action: Check the documentation for the destination types (such as FILE) supported by GeoRaster.
ORA-13482: GeoRaster object is not initialized for the image
Cause: No GeoRaster object has been initialized for the specified image.
Action: Initialize a GeoRaster object to hold this image before loading it into the database. Check the documentation for details.
ORA-13483: insufficient memory for the specified GeoRaster data
Cause: There was insufficient memory to hold the specified GeoRaster data for this operation.
Action: Use SDO_GEOR.subset to isolate a subset of the GeoRaster data, or reblock the GeoRaster data into smaller sized blocks. Check the
ORA-13484: the file format and/or compression type is not supported
Cause: The file format and/or compression type was not supported.
Action: Check the documentation for formats that are currently supported by GeoRaster.
ORA-13497: %s
Cause: This is an internal GeoRaster error.
Action: Contact Oracle Support Services. You may want to make sure the GeoRaster object is valid before you do so.
ORA-13498: %s
Cause: This is an internal Spatial error.
Action: Contact Oracle Support Services.
ORA-13500: SYSAUX DATAFILE clause specified more than once
Cause: The CREATE DATABASE command contains more than one SYSAUX DATAFILE clause.
Action: Specify at most one SYSAUX DATAFILE clause.
ORA-13501: Cannot drop SYSAUX tablespace
Cause: Tried to drop SYSAUX tablespace
Action: None
ORA-13502: Cannot rename SYSAUX tablespace
Cause: An attempt to rename the SYSAUX tablespace failed.
Action: No action required.
ORA-13503: Creating SYSAUX tablespace with invalid attributes
Cause: An attempt to create the SYSAUX tablespace with invalid attributes.
Action: Create SYSAUX tablespace with ONLINE, PERMANENT, EXTENT MANAGEMENT LOCAL, SEGMENT SPACE MANAGEMENT AUTO attributes.
ORA-13504: No SYSAUX datafile clause specified
Cause: If Create Database has the datafile clause, then SYSAUX datafile clause has to be specified, unless using OMF.
Action: Specify the SYSAUX datafile clause.
ORA-13505: SYSAUX tablespace can not be made read only
Cause: Attempting to set the SYSAUX tablespace to read only. The SYSAUX tablespace must remain read write for database operation.
Action: Leave SYSAUX tablespace read write.
ORA-13506: operation failed due to invalid snapshot range (string, string)
Cause: An attempt was made to perform operation with an invalid Start/End Snapshot Pair.
Action: Choose a valid Start/End Snapshot Pair.
ORA-13509: error encountered during updates to a SWRF table
Cause: An update error occurred during OCI operation due to an underlying error.
Action: Check associated OCI error. Correct problem and retry the operation.
ORA-13510: invalid RETENTION string, must be in the range (string, string)
Cause: The user has specified a RETENTION setting that is in the supported range of (MIN, MAX).
Action: Choose a valid RETENTION setting and retry the operation.
ORA-13511: invalid INTERVAL string, must be in the range (string, string)
Cause: The user has specified a INTERVAL setting that is not in the supported range of (MIN, MAX).
Action: Choose a valid INTERVAL setting and retry the operation.
ORA-13514: Metric Capture too close to last capture, group string
Cause: The metric capture cannot be executed because it is too close to the last capture (within 1 centi-second).
Action: add some delay and reissue command to retry.
ORA-13515: Error encountered during Database Usage Statistics capture
Cause: Error occurred during OCI operation due to underlying error.
Action: Check associated OCI error. Correct problem and retry the operation.
ORA-13516: SWRF Operation failed: string
Cause: The operation failed because SWRF is not available. The possible causes are: SWRF schema not yet created; SWRF not enabled; SWRF schema not initialized; or database not open or is running in READONLY or STANDBY mode.
Action: check the above conditions and retry the operation.
ORA-13517: Baseline (id = string) does not exist
Cause: The operation failed because the specified baseline ID does not exist in the Workload Repository.
Action: check the baseline id and retry the operation.
ORA-13518: Invalid database id (string)
Cause: The operation failed because the specified database ID does not exist in the Workload Repository.
Action: check the database id and retry the operation.
ORA-13519: Database id (string) exists in the workload repository
Cause: The operation failed because the specified database ID already exists in the Workload Repository.
Action: check the database id and retry the operation.
ORA-13520: Database id (string) not registered, Status = string
Cause: The operation failed because the specified database ID was not registered in the Workload Repository properly.
Action: check the status of database id and retry the operation.
ORA-13521: Unregister operation on local Database id (string) not allowed
Cause: The operation failed because the local database ID cannot be unregistered from the Workload Repository.
Action: check the database id and retry the operation.
ORA-13523: unable to allocate required space for return type
Cause: Out of memory to allocate the space for the return variable for an external procedure.
Action: Try operation again.
ORA-13524: error encountered while retrieving baseline information
Cause: A read error occurred during the OCI operation to retrieve the baseline information
Action: Check associated error. Correct problem and retry the operation.
ORA-13525: error with computing space usage for sysaux occupant
Cause: Error occurred during OCI operation due to underlying error.
Action: Check associated OCI error. Correct problem and retry the operation.
ORA-13526: baseline (string) does not exist
Cause: The operation failed because the specified baseline name does not exist in the Workload Repository.
Action: check the baseline name and retry the operation.
ORA-13527: invalid baseline name
Cause: The operation failed because the specified baseline name does not exist in the Workload Repository.
Action: check the baseline name and retry the operation.
ORA-13528: name (string) is already used by an existing baseline
Cause: The operation failed because the specified baseline name already exists in the Workload Repository.
Action: check the baseline name and retry the operation.
ORA-13600: error encountered in Advisor string
Cause: An error occurred in the Advisor. This message will be followed by a second message giving more details about the nature of the error.
Action: See the Advisor documentation for an explanation of the second error message.
ORA-13601: The specified Advisor string does not exist.
Cause: The user specified an advisor name that has not be defined in the advisor repository.
Action: Correct the advisor name and retry the operation.
ORA-13602: The specified parameter string is not valid for task or object string.
Cause: The user attempted to access a task parameter that does not exist for the specified advisor object. The parameter may be misspelled or the user has selected a parameter that is not supported by the particular advisor.
Action: Validate the parameter name and retry the operation.
ORA-13603: The specified parameter string cannot be fetched as a numeric value for task or object string.
Cause: The user attempted to retrieve a string parameter as a numeric value.
Action: Check the datatype for the task parameter and retry the operation.
ORA-13604: The specified parameter string cannot be fetched as a SQL table.
Cause: The user attempted to retrieve a non-table parameter as a table name.
Action: Check the datatype for the task parameter and retry the operation.
ORA-13605: The specified task or object string does not exist for the current user.
Cause: The user attempted to reference an advisor task or object using a name that does not exist in the Advisor repository.
Action: Adjust the name and retry the operation.
ORA-13606: the specified task parameter element string is out of range for parameter string.
Cause: The user attempted to reference an invalid parameter element.
Action: Adjust the element offset and retry the operation.
ORA-13607: The specified task or object string already exists
Cause: The user attempted to create the specified task or object using a name that already exists in the Advisor repository. Task names must be unique to the database user.
Action: Adjust the name and retry the operation.
ORA-13608: The task or object name string is invalid.
Cause: The user attempted to specify a task name that contains invalid characters or an invalid wildcard specifier.
Action: Adjust the name and retry the operation.
ORA-13609: The specified task string must be executing to be cancelled or interrupted.
Cause: The user attempted to cancel or interrupt a task that is not currently executing.
Action: Check the status of the task and retry the operation.
ORA-13610: The directive string does not exist for task string.
Cause: The user attempted to access a task directive that does not exist.
Action: Validate the directive and retry the operation.
ORA-13611: The command string is not a valid advisor command.
Cause: The user attempted to specify a command that does not exist.
Action: Validate the command and retry the operation.
ORA-13612: The recommendation action string,string is not valid for task string.
Cause: The user attempted to access a recommendation action that does not exist in the task.
Action: Validate the recommendation-action and retry the operation.
ORA-13613: The requested operation is not supported for this advisor object.
Cause: The user attempted to perform an operation that is not supported for the particular advisor or task type.
Action: Validate the task or object and retry the operation.
ORA-13614: The template string is not compatible with the current advisor.
Cause: The user attempted to create a new task or object using an existing task or object that was not created by the same advisor.
Action: Validate the template and retry the operation.
ORA-13615: The task or object string is greater than the maximum allowable length of 30 characters.
Cause: The user attempted to create a new task or object using a name that is too long.
Action: Shorten the name and retry the operation.
ORA-13616: The current user string has not been granted the ADVISOR privilege.
Cause: The user attempted an advisor operation that requires privilege.
Action: Adjust the user's privileges and retry the operation.
ORA-13617: The specified task string already executing
Cause: The user attempted to execute a task that is currently executing.
Action: Wait for the task to finish before attempting any further task activities.
ORA-13618: The value string is not a valid value for procedure argument string.
Cause: The user executed an advisor procedure but failed to provide correct values for the argument.
Action: Correct the procedure arguments and retry the operation.
ORA-13619: The procedure argument string is greater than the maximum allowable length of string characters.
Cause: The user attempted to pass a character argument that is too long.
Action: Shorten the specified character argument and retry the operation.
ORA-13620: The task or object string is read-only and cannot be deleted or modified.
Cause: The user attempted to perform an operation that will update or delete a read-only task or object.
Action: Adjust the READ_ONLY property for the object and retry the operation.
ORA-13621: The task_or object string is marked as a template and cannot perform the requested operation.
Cause: The user attempted perform an unsupported operation on a task or object that is identified as a template.
Action: Choose a different object and retry the operation.
ORA-13622: The recommendation annotation string is invalid.
Cause: The user attempted to mark a recommendation using an invalid annotation. Valid annotation actions are ACCEPT, REJECT and IGNORE.
Action: Correct the action and retry the operation.
ORA-13623: The recommendation string is not valid for task string.
Cause: The user attempted to access a recommendation that does not exist in the task.
Action: Validate the recommendation and retry the operation.
ORA-13624: The task string is executing and cannot be deleted or modified.
Cause: The user attempted to access a task that currently executing.
Action: Wait for the task to complete and retry the operation.
ORA-13625: %s is an invalid advisor object type.
Cause: The user has specified an invlaid object type.
Action: Refre to dba_advisor_object_types for all valid object types
ORA-13626: The specified object string is not valid for task string.
Cause: The user specified an non-existent object for the task
Action: Choose a different object and retry the operation.
ORA-13627: Setting of parameter string is disallowed until the task is reset.
Cause: The user attempted to set the value of a parameter before the task was reset. This parameter cannot be changed until the task is reset.
Action: Reset the task and retry the operation.
ORA-13628: Insufficient privileges to access the task belonging to user string
Cause: The current user needs to be able to access dba_* views.
Action: Retry operation as owner of the task or afer granting new privileges.
ORA-13629: The task or object string is being used by another operation.
Cause: The user attempted to access a task or object that is locked by another session.
Action: Wait for the task or object activity to complete and retry the operation.
ORA-13630: The task string contains execution results and cannot be executed.
Cause: The user attempted to execute a task that already contains execution results.
Action: Reset the task to its initial state and retry the operation.
ORA-13631: The task string contains no execution results.
Cause: The user attempted to create a report or script from a task that has not successfully completed an execution.
Action: Execute the task and then retry the operation
ORA-13632: The user cancelled the current operation.
Cause: The user signaled a cancel during a task or object operation.
Action: None
ORA-13633: The task string was interrupted and needs to be resumed.
Cause: The user attempted to execute a task that was interrupted.
Action: Resume the execution of the task via the RESUME_TASK API.
ORA-13634: The task string needs to be reset before being re-executed.
Cause: The task encountered an execution error or its execution was cancelled.
Action: Reset the task to its initial state and retry the operation.
ORA-13635: The value string provided for parameter string cannot be converted to a number.
Cause: A numeric parameter was incorrectly supplied in string form.
Action: Retry by supplying valid numeric value.
ORA-13636: The specified value string provided for parameter string is not valid for this advisor.
Cause: The user supplies an invalid parameter value.
Action: Retry by supplying valid value.
ORA-13637: Executing or modifying task string is disallowed until the task is reset to its initial state.
Cause: The user attempted to execute or modify the task that is in not in its INITIAL state.
Action: Reset the task and retry the operation.
ORA-13638: The user interrupted the current operation.
Cause: The user signaled an interrupt during a task or object operation.
Action: None
ORA-13639: The current operation was interrupted because it timed out.
Cause: The task or object operation timed out.
Action: None
ORA-13640: The current operation was cancelled because it timed out, and was not in interruptible mode.
Cause: The task or object operation timed out.
Action: None
ORA-13641: Task cannot be interrupted yet. You may cancel it instead.
Cause: The user attempted to interrupt a task that has not reached interruptible mode.
Action: Wait until the task reaches interruptible mode, or cancel the task execution.
ORA-13642: The specified string string provided for string cannot be converted to a date. The acceptable date format is string.
Cause: The user supplied a date value in an incorrect format.
Action: Retry by supplying valid value.
ORA-13643: The task can not be interrupted or cancelled.
Cause: Request to interrupt or cancel task execution can not be granted because the task has not reached the appropriate mode.
Action: User should wait for a few seconds and try again.
ORA-13699: Advisor feature is not currently implemented.
Cause: The user attempted to execute an unsupported advisor operation.
Action: Verify the availability of the operation.
ORA-13701: Snapshot pair [string, string] seems to be specified in reverse order.
Cause: The start snapshot id was greater than the end snapshot id.
Action: Swap the start and end snapshot ids.
ORA-13702: Snapshot IDs specified by the range [string, string] are equal.
Cause: The start snapshot id and end snapshot id were identical.
Action: Provide different start and end snapshot ids.
ORA-13703: The snapshot pair [string, string] for database_id string and instance_id string are not found in the current repository.
Cause: The snapshot ids or the database id or the instance id was invalid or the specified snapshots have already been purged.
Action: Set valid snapshot ids and retry.
ORA-13704: Invalid value "string" specified for parameter "string".
Cause: The parameter was not set before executing the ADDM.
Action: Set the parameter to a valid value and retry.
ORA-13705: There was a instance shutdown/startup between the snapshots in the range [string, string].
Cause: Instance was shut down and restarted between the two specified snapshots.
Action: Specify start and end snapshot ids that doesn't have a shutdown/startup in between them.
ORA-13706: Invalid value "string" specified for parameter "string" in "string" analysis mode.
Cause: The parameter was not set to an acceptable value for this particular mode of analysis.
Action: Set the parameter to a valid value and retry.
ORA-13707: Either the start snapshot string or the end snapshot string is incomplete or missing key statistics.
Cause: Either the start or the end snaphots was missing or purged or had encountered errors while creating them.
Action: Verify that AWR is done taking these two snapshots, or Look in DBA_HIST_SNAP_ERROR to find what tables are missing in the start/end snapshots. Use the ERROR_NUMBER column in that view together with the alert log to identify the reason for failure and take necessary action to prevent such failures in the future. Try running ADDM on a different snapshot range that has valid start and end snapshots.
ORA-13708: Some snapshots in the range [string, string] were purged before the analysis was complete.
Cause: One or both of the snapshots have been purged from SWRF.
Action: Verify that the SWRF auto purging is not trying to purge these snapshots and re-run ADDM.
ORA-13709: Required parameter "string" must be set before execution.
Cause: The parameter needs to be set before running the ADDM
Action: Set the parameter to a valid value and retry.
ORA-13710: Parameter "string" must have a higher value than parameter "string". The values supplied were "string" and "string" respectively.
Cause: Invalid interaction between two parameter values.
Action: Set at least one of the values so the value of the first parameter is higher than the value of the second parameter.
ORA-13711: Some snapshots in the range [string, string] are missing key statistics.
Cause: Some AWR tables encountered errors while taking one ore more snapshots in the given range. The missing table, being one of the key tables that ADDM looks at, renders ADDM unable to run.
Action: Look in DBA_HIST_SNAP_ERROR to find what tables are missing in the given snapshot range. Use the ERROR_NUMBER column in that view together with the alert log to identify the reason for failure and take necessary action to prevent such failures in the future. Try running ADDM on a different snapshot range that doesn't include any incomplete snapshots.
ORA-13750: User "string" has not been granted the "ADMINISTER SQL TUNING SET" privilege.
Cause: The user attempted an SQL Tuning Set operation that requires a specific privilege.
Action: Adjust the user's privileges and retry the operation.
ORA-13751: "SQL Tuning Set" "string" does not exist or user "string" is not the owner of the "SQL Tuning Set".
Cause: The user attempted to access a SQL Tuning Set that does not exist or the user does not own the SQL Tuning Set.
Action: Check the existence of the "SQL Tuning Set" or adjust the user's privileges and retry the operation.
ORA-13752: User "string" must be SYS or must have the "ADMINISTER ANY SQL TUNING SET" privilege.
Cause: The attempted to create a SQL Tuning Set in another schema without having the right privilege.
Action: Connect as SYS or adjust the user's privilege and retry the operation.
ORA-13753: "SQL Tuning Set" "string" already exists.
Cause: The user attempted to create a "\SQL Tuning"\ Set using a name that already exsits.
Action: Change the name of the SQL Tuning Set and retry the operation.
ORA-13754: "SQL Tuning Set" "string" does not exist.
Cause: The user attempted to access a SQL Tuning Set that does not exist.
Action: Check the speelling of the SQL Tuning Set name and retry the operation.
ORA-13755: invalid "SQL Tuning Set" name
Cause: The user attempted to specify a SQL Tuning Set name that is invalid. A name must not contain wildcards and its length must be less than 30 characters.
Action: Adjust the name and retry the operation.
ORA-13756: Cannot update attribute "string".
Cause: The user attempted to update an attribute element that cannot be modified. The only string attributes that can be updated are MODULE, ACTION, PRIORITY and PARSING_SCHEMA_ID.
Action: Adjust the attribute name and retry the operation.
ORA-13757: "SQL Tuning Set" "string" is active.
Cause: The user attempted to update an active SQL Tuning Set.
Action: Remove all reference to the SQL Tuning Set and retry the operation.
ORA-13758: "SQL Tuning Set" "string" is in use.
Cause: The user attempted to modify a SQL Tuning Set or to add a reference to a SQL Tuning Set which is in use.
Action: Wait until the end of the previous operation and retry.
ORA-13759: User "string" cannot remove reference "string".
Cause: The user attempted to remove a SQL Tuning Set reference that does not exist. The user might not own the reference.
Action: Check the reference ID and the reference owner and retry the operation.
ORA-13760: duplicate entry for "SQL_ID" "string" in "SQL Tuning Set" "string"
Cause: The user attempted to insert a SQL statement which already exists.
Action: Remove the duplicated statement from the input workload and retry the operation.
ORA-13761: invalid filter
Cause: The user attempted to select data from a data source using an invalid filter. A filter is a WHERE clause on data source content.
Action: Correct the filter and retry the operation.
ORA-13762: The string ranking measure is invalid.
Cause: The user attempted to select data from a data source using an invlaid ranking measure. A ranking measure must represent a valid numerical expression.
Action: Correct the ranking measure and retry the operation.
ORA-13763: illegal ranking attribute "string"
Cause: The user attempted to use an attribute element that is not allowed in a ranking meseare.
Action: Check the attribute in the ranking meseare and retry the operation.
ORA-13764: Value "string" is illegal as a result percentage.
Cause: The user attempted to select data from a SQL Tuning Set using an invalid result percentage. The result percentage must be between 0 and 1.
Action: Correct the result percentage value and retry the operation.
ORA-13765: Value "string" is illegal for a result limit.
Cause: The user attempted to select data from a SQL Tuning Set using an invalid result limit. A result limit must be a positive interger.
Action: Correct the result limit value and retry the operation.
ORA-13766: A ranking measure is required.
Cause: The user attempted to select data from a SQL Tuning Set using a percentage argument without specifying a ranking measure.
Action: Add a ranking measure or remove the percentage argument and retry the operation.
ORA-13767: End snapshot ID must be greater than or equal to begin snapsho ID.
Cause: The user attempted to select data from the workload repository using an invalid snaphot ID range.
Action: Adjust the snapshot ID range and retry the operation.
ORA-13768: Snaphshot ID must be between string and string.
Cause: The user attempted to select data from the workload repository using a snaphot ID which does not exist.
Action: Adjust the snapshot ID and retry the operation.
ORA-13769: Snapshots string and string do not exist.
Cause: The user attempted to select data from the workload repository using snapshots that do not exist.
Action: Check the snapshot identifiers and retry the operation.
ORA-13770: Baseline "string" does not exist.
Cause: The user attempted to access a baseline that does not exsit.
Action: Check the speelling of the baseline name and retry the operation.
ORA-13771: cannot obtain exclusive lock string on "SQL Tuning Set" "string"
Cause: Unexpected error from DBMS_LOCK.REQUEST.
Action: This error should not normally occur. Check your system for anomalies and retry the operation. If this error persists, contact Oracle Support Services.
ORA-13772: unexpected deadlock on "SQL Tuning Set" "string"
Cause: Unexpected error from DBMS_LOCK.REQUEST
Action: This error should not normally occur. Check your system for anomalies and retry the operation. If this error persists, contact Oracle Support Services.
ORA-13773: insufficient privileges to select data from the cursor cache
Cause: The user attempted to perform an operation without having the appropriate privileges on V$SQL and V$SQL_BIND_CAPTURE.
Action: Adjust the user's privileges and retry the operation.
ORA-13774: insufficient privileges to select data from the workload repository
Cause: The user attempted to perform an operation without having the appropriate privileges on views DBA_HIST_BASELINE, DBA_HIST_SQLTEXT, DBA_HIST_SQLSTAT, DBA_HIST_SQLBIND, and DBA_HIST_OPTIMIZER_ENV.
Action: Adjust the user's privileges and retry the operation.
ORA-13775: inconsistent datatype in input cursor
Cause: The user attempted to load a SQL Tuning Set using an invalid input cursor. All rows in the cursor must match type SQLSET_ROW.
Action: Check the rows type in the cursor and retry the operation.
ORA-13780: SQL statement does not exist.
Cause: The user attempted to tune a SQL statement that does not exist.
Action: Verify the sql_id and the plan hash value of the statement and retry the operation.
ORA-13781: The tuning task does not exist.
Cause: The user attempted to access a tuning task that does not exist.
Action: Verify the name of the tuning task and the name of the user and retry the operation.
ORA-13782: The specified user "string" does not exist.
Cause: The user attempted to tune a SQL statement in a user schema that does not exist.
Action: Check the username and retry the operation.
ORA-13783: invalid tuning scope
Cause: The user attempted to specify a tuning task scope that is invalid. The possible values are LIMITED or COMPREHENSIVE.
Action: Check the scope value and retry the operation.
ORA-13784: cannot accept SQL profiles for all statements in the "SQL Tuning Set"
Cause: The user attempted to accept SQL profiles for all statements in a SQL Tuning Set.
Action: Provide the object identifier corresponding to a statement in the SQL Tuning Set and retry the operation.
ORA-13785: missing target object for tuning task "string"
Cause: The user attempted to perform an operation on a task without specifying a target object or by using an invalid object identifier.
Action: Check the identifier of the object and retry the operation.
ORA-13786: missing SQL text of statement object "string" for tuning task "string"
Cause: The user attempted to accept SQL profile for an object that has not a SQL text associated to it.
Action: Check the identifier of the object and retry the operation.
ORA-13787: missing SQL profile for statement object "string" for tuning task "string"
Cause: The user attempted to accept a SQL profile for an object that has not a SQL profile associated to it.
Action: Check the identifier of the object and retry the operation.
ORA-13797: invalid SQL Id specified, string
Cause: Invalid SQL Id specified for conversion.
Action: Specify valid SQL Id.
ORA-13798: Parameter string cannot be NULL.
Cause: A call to GET_THRESHOLD procedure was made without a required parameter.
Action: Specify a valid value for this parameter.
ORA-13799: threshold not found
Cause: No threshold was found with the specified threshold key.
Action: No action required.
ORA-13800: concurrent DDL failure on SQL repository objects
Cause: A SQL repository object was the target of two concurrent DDL operations.
Action: Check the current state of the object and retry the operation that failed.
ORA-13801: invalid value for SQLTUNE_CATEGORY parameter
Cause: An invalid Oracle identifier was used as the value of the parameter.
Action: Specify the parameter conforming to the rules for Oracle identifiers.
ORA-13802: failed to purge SQL Tuning Base entry from sql$
Cause: An error occured while try to delete a SQL Tuning Base object.
Action: Look at the underlying error(s) on the error stack.
ORA-13825: missing SQL statement text for create SQL profile
Cause: No SQL text was provided to the create SQL profile operation.
Action: Retry with properly specified SQL text.
ORA-13826: empty SQL profile not allowed for create or update SQL profile
Cause: No attributes were specified to the create SQL profile operation.
Action: Retry with at least one hint specified.
ORA-13827: null or zero length attribute specified in SQL profile collection
Cause: One of the attributes within the SQL profile was not properly specified.
Action: Retry with a fully specified SQL profile.
ORA-13828: generated SQL profile name string already exists
Cause: A SQL profile already exists with the name generated by the system.
Action: Retry the operation as the generated name is time sensitive.
ORA-13829: SQL profile named string already exists
Cause: A SQL profile already exists with the name specified.
Action: Specify a different name or drop the existing SQL profile.
ORA-13830: SQL profile with category string already exists for this SQL statement
Cause: A SQL profile already exists for the given SQL statement and category.
Action: Drop or update the existing SQL profile.
ORA-13831: SQL profile name specified is invalid
Cause: An invalid SQL profile name was specified.
Action: Look for the underlying error on the error message stack.
ORA-13832: category name specified is invalid
Cause: An invalid category name swas pecified.
Action: Look for the underlying error on the error message stack.
ORA-13833: SQL profile named string doesn't exist
Cause: A SQL profile name was specified that doesn't exist.
Action: Verify the name of the SQL profile.
ORA-13834: name of SQL profile to be cloned must be provided
Cause: A SQL profile name was not provided as the from target of a clone SQL profile operation.
Action: Provide the name of the SQL profile being cloned.
ORA-13835: invalid attribute name specified
Cause: An invalid attribute name was specified for an alter SQL profile operation.
Action: Verify the name of the attribute.
ORA-13836: invalid attribute value specified
Cause: An invalid attribute value was specified for an alter SQL profile operation.
Action: Verify the attribute value.
ORA-13837: invalid HASH_VALUE
Cause: An invalid HASH_VALUE was passed to a create SQL profile operation
Action: Verify the HASH_VALUE.
ORA-13838: invalid ADDRESS value
Cause: An invalid ADDRESS value was passed to a create SQL profile operation.
Action: Verify the ADDRESS value.
ORA-13839: V$SQL row doesn't exist with given HASH_VALUE and ADDRESS.
Cause: A HASH_VALUE and ADDRESS combination passed to the create SQL profile operation doesn't coorespond to an existing V$SQL entry.
Action: Verify the HASH_VALUE and ADDRESS in V$SQL.
ORA-13850: Tracing for client identifier string is not enabled
Cause: Attempt to disable a client identifier tracing which was never enabled
Action: Supply correct client identifier
ORA-13851: Tracing for client identifier string is already enabled
Cause: Attempt to enable a client identifier tracing which has been already enabled
Action: Supply correct client identifier, or disable and re-enable tracing with different bind/wait options
ORA-13852: Tracing for service(module/action) string is not enabled
Cause: Attempt to disable a service-level tracing which was never enabled
Action: Supply correct service(module/action) name
ORA-13853: Tracing for service (module/action) string is already enabled
Cause: Attempt to enable a service-level tracing which has been already enabled
Action: Supply correct service(module/action), or disable and re-enable tracing with different bind/wait options
ORA-13854: Tracing for service(module/action) string on instance string is not enabled
Cause: Attempt to disable a service-level tracing which was never explicitly enabled on a specific instance
Action: Supply correct service(module/action) name
ORA-13855: Tracing for service (module/action) string on instance string is already enabled
Cause: Attempt to enable a service-level tracing which has been already enabled on a specific instance
Action: Supply correct service(module/action), or disable and re-enable tracing with different bind/wait options
ORA-13856: Service name must be specified
Cause: Omitting service name while enabling/disabling tracing or aggregation
Action: Supply the service name
ORA-13857: Invalid module name
Cause: Module name is too long (exceeding 48 characters)
Action: Supply correct name
ORA-13858: Invalid action name
Cause: Action name is too long (exceeding 32 characters)
Action: Supply correct name
ORA-13859: Action cannot be specified without the module specification
Cause: Action name is specified, but the module name is not
Action: Supply the module name
ORA-13860: Invalid service name
Cause: Service name is too long (exceeding 64 characters)
Action: Supply correct name
ORA-13861: Statistics aggregation for client identifier string is already enabled
Cause: Attempt to enable a client identifier aggregation which has been already enabled
Action: Supply correct client identifier
ORA-13862: Statistics aggregation for client identifier string is not enabled
Cause: Attempt to disable a client identifier statistics aggregation which was never enabled
Action: Supply correct client identifier
ORA-13863: Statistics aggregation for service(module/action) string is not enabled
Cause: Attempt to disable a service-level statistics aggregation which was never enabled
Action: Supply correct service(module/action) name
ORA-13864: Statistics aggregation for service (module/action) string is already enabled
Cause: Attempt to enable a service-level statistics aggregation which has been already enabled
Action: Supply correct service(module/action)
ORA-13865: Module name must be specified
Cause: Attempt to enable/disable a service-level statistics aggregation without a module specification
Action: Supply module name
ORA-13866: Client identifier must be specified
Cause: Omitting client identifier while enabling/disabling tracing or aggregation
Action: Supply the client identifier
ORA-13900: missing or invalid parameter string
Cause: A call to SET_THRESHOLD procedure was either missing a parameter, or the parameter was invalid.
Action: Specify a valid value for this parameter.
ORA-13901: Object string was not found.
Cause: An object name was passed to SET_THRESHOLD procedure that did not map to a valid object.
Action: Specify a valid object name.
ORA-13902: The specified file string is not a data file.
Cause: The object name was passed to a SET_THRESHOLD procedure that did not map to a valid data file.
Action: Specify a valid data file name.
ORA-13903: Invalid combination of string threshold value and operator.
Cause: A non-positive number was used for "Blocked User Session Count" metrics while operator contains equal.
Action: Use a positive number for the threshold value or use "greater than" operator.
ORA-13904: The file has been dropped and recreated during the procedure call.
Cause: The file on which threshold is specified was dropped and recreated during the procedure call.
Action: Retry this operation.
ORA-13905: Critical or warning threshold have incorrect values
Cause: The tablespace threshold values can be in the range 0 to 100 only.
Action: Check the threshold values
ORA-13906: The tablepace is not of the right type.
Cause: An attempt was made to set a threshold on dictionary-managed tablespaces.
Action: Check the tablespace type and reissue the command.
ORA-13907: Threshold value is invalid.
Cause: An attempt was made to specify an invalid value for critical or warning thresholds.
Action: Use non-negative integers only for threshold values.
ORA-13908: Invalid combination of metrics id and object type parameters.
Cause: An attempt was made to specify an invalid combination of metrics id // and object type parameters.
Action: Specify a valid combination of metrics id and object type parameters.
ORA-13909: Invalid combination of threshold value and operator.
Cause: An attempt was made to specify an invalid combination of threshold value and operator.
Action: Check the operator and threshold values and reissue statement.
ORA-13910: Parameter string cannot be NULL.
Cause: An attempt was made to call GET_THRESHOLD procedure without a required parameter.
Action: Specify a valid value for this parameter.
ORA-13911: Threshold not found
Cause: The threshold did not exist with the specified threshold key.
Action: No action required.
ORA-13912: Critical threshold value is less than warning threshold value.
Cause: An attempt was made to call SET_THRESHOLD procedure with the critical threshold value less than the warning threshold value.
Action: Check the threshold values and reissue the statement.
ORA-13913: The threshold cannot be set when SYSAUX is offline.
Cause: SET_THRESHOLD procedure was called when SYSAUX tablespace was offline.
Action: Call SET_THRESHOLD procedure when SYSAUX is online.
ORA-13914: Threshold notification failed.
Cause: This is an internal Server Manageability Error
Action: Contact Oracle Support Services
ORA-14000: only one LOCAL clause may be specified
Cause: CREATE INDEX statement contained more than one LOCAL clause
Action: Specify LOCAL option at most once
ORA-14001: LOCAL clause contradicts previosly specified GLOBAL clause
Cause: CREATE INDEX statement contained a GLOBAL clause and a LOCAL clause
Action: Specify LOCAL or GLOBAL clause, but not both
ORA-14002: only one GLOBAL clause may be specified
Cause: CREATE INDEX statement contained more than one GLOBAL clause
Action: Specify GLOBAL option at most once
ORA-14003: GLOBAL clause contradicts previosly specified LOCAL clause
Cause: CREATE INDEX statement contained a LOCAL clause and a GLOBAL clause
Action: Specify GLOBAL or LOCAL clause, but not both
ORA-14004: missing PARTITION keyword
Cause: keyword PARTITION missing
Action: supply missing keyword
ORA-14005: missing RANGE keyword
Cause: keyword RANGE missing
Action: supply missing keyword
ORA-14006: invalid partition name
Cause: a partition name of the form <identifier> is expected but not present.
Action: enter an appropriate partition name.
ORA-14007: missing LESS keyword
Cause: keyword LESS missing
Action: supply missing keyword
ORA-14008: missing THAN keyword
Cause: keyword THAN missing
Action: supply missing keyword
ORA-14009: partition bound may not be specified for a LOCAL index partition
Cause: while parsing a CREATE INDEX statement to create a LOCAL partitioned index, <partition-description> of one of partitions was found to contain VALUES LESS THAN clause which is illegal since a LOCAL index inherits partition bounds from its base table
Action: remove all VALUES LESS THAN clauses from descriptions of LOCAL index partitions
ORA-14010: this physical attribute may not be specified for an index partition
Cause: unexpected option was encountered while parsing physical attributes of an index partition; valid options for Range or Composite Range partitions are INITRANS, MAXTRANS, TABLESPACE, STORAGE, PCTFREE; only TABLESPACE may be specified for Hash partitions
Action: remove invalid option(s) from the list of physical attributes of an index partition
ORA-14011: names assigned to resulting partitions must be distinct
Cause: Names of partitions resulting from splitting of an existing table or index partition are not distinct
Action: rename resulting partition(s) to ensure that their names are distinct and different from those of any other partition of the table or index
ORA-14012: resulting partition name conflicts with that of an existing partition
Cause: Name of a partition resulting from splitting of an existing table or index partition is identical to that of some other existing partition of that table or index
Action: rename resulting partition(s) to ensure that their names are distinct and different from those of any other partition of the table or index
ORA-14013: duplicate partition name
Cause: Name of a partition of a table or index being created is not unique
Action: rename partition(s) to ensure that their names are unique among partitions of the table or index being created
ORA-14014: maximum number of partitioning columns is 16
Cause: number of columns in a partitioning column list exceeded the legal limit of 16
Action: modify partitioning column list so that it consists of at most 16 columns
ORA-14015: too many partition descriptions
Cause: CREATE TABLE or CREATE INDEX contained too many partition descriptions; maximum number of partitions is 65535.
Action: Reduce number of partitions to not exceed 65535.
ORA-14016: underlying table of a LOCAL partitioned index must be partitioned
Cause: User attempted to create a LOCAL partitioned index on a non-partitioned table which is illegal. Only GLOBAL indices (partitioned or otherwise) may be created on a non-partitioned table.
Action: Correct the statement and reenter
ORA-14017: partition bound list contains too many elements
Cause: Partition bound list contained more elements than there are partitioning columns
Action: Ensure that the number of elements in partition bound list is equal to the number of partitioning columns of the table or index
ORA-14018: partition bound list contains too few elements
Cause: Partition bound list contained fewer elements than there are partitioning columns
Action: Ensure that the number of elements in partition bound list is equal to the number of partitioning columns of the table or index
ORA-14019: partition bound element must be one of: string, datetime or interval literal, number, or MAXVALUE
Cause: Partition bound list contained an element of invalid type (i.e. not a number, non-empty string, datetime or interval literal, or MAXVALUE)
Action: Ensure that all elements of partition bound list are of valid type
ORA-14020: this physical attribute may not be specified for a table partition
Cause: unexpected option was encountered while parsing physical attributes of a table partition; valid options for Range or Composite Range partitions are INITRANS, MAXTRANS, TABLESPACE, STORAGE, PCTFREE, and PCTUSED; only TABLESPACE may be specified for Hash partitions
Action: remove invalid option(s) from the list of physical attributes of a table partition
ORA-14021: MAXVALUE must be specified for all columns
Cause: In the VALUES LESS THAN clause for the highest (last) partition of a GLOBAL index, MAXVALUE must be specified for all columns
Action: Ensure that VALUES LESS THAN clause for the last partition of a GLOBAL index has MAXVALUE specified for all columns
ORA-14022: creation of LOCAL partitioned cluster indices is not supported
Cause: An attempt was made to create a LOCAL partitioned cluster index, which is currently illegal
Action: Remove LOCAL along with <partition description>s, if any, from the CREATE INDEX statement.
ORA-14023: creation of GLOBAL partitioned cluster indices is not supported
Cause: An attempt was made to create a GLOBAL partitioned cluster index, which is currently illegal
Action: Remove PARTITION BY RANGE clause along with <partition description>s from the CREATE INDEX statement.
ORA-14024: number of partitions of LOCAL index must equal that of the underlying table
Cause: User attempted to create a LOCAL partitioned index with a number of partitions which is different from that of the underlying table.
Action: Correct the CREATE INDEX statement to specify a correct number of partitions
ORA-14025: PARTITION may not be specified for a materialized view or a materialized view log
Cause: PARTITION option was encountered while parsing a definition of a materialized view or a materialized view log
Action: Ensure that a definition of a MATERIALIZED VIEW does not include invalid options
ORA-14026: PARTITION and CLUSTER clauses are mutually exclusive
Cause: definition of a table contained both PARTITION and CLUSTER clauses which is illegal
Action: Remove one of the conflicting clauses
ORA-14027: only one PARTITION clause may be specified
Cause: CREATE TABLE statement contained more than one PARTITION clause
Action: Specify PARTITION option at most once
ORA-14028: missing AT or VALUES keyword
Cause: keyword AT or VALUES missing
Action: supply missing keyword
ORA-14029: GLOBAL partitioned index must be prefixed
Cause: partitioning columns of a global partitioned index must form a prefix of the index' key columns
Action: Ensure that the GLOBAL partitioned index being created is prefixed
ORA-14030: non-existent partitioning column in CREATE TABLE statement
Cause: Partitioning column specified in CREATE TABLE statement is not one of columns of the table being created.
Action: Ensure that all columns in the partitioning column list are columns of the table being created.
ORA-14031: partitioning column may not be of type LONG or LONG RAW
Cause: Partitioning column specified by the user was of type LONG or LONG RAW, which is illegal.
Action: Ensure that no partitioning column is of type LONG or LONG RAW.
ORA-14032: partition bound of partition number string is too high
Cause: High bound of the partition whose number (partitions are numbered starting with 1) is displayed in this message did not collate lower than that of the following partition, which is illegal.
Action: Ensure that high bound of every partition (except for the last one) collates lower than that of a following partition.
ORA-14036: partition bound value too large for column
Cause: Length of partition bound value is longer than that of the corresponding partitioning column.
Action: Ensure that lengths of high bound values do not exceed those of corresponding partitioning columns
ORA-14037: partition bound of partition "string" is too high
Cause: High bound of the partition whose name (explicitly specified by the user) is displayed in this message did not collate lower than that of the following partition, which is illegal.
Action: Ensure that high bound of every partition (except for the last one) collates lower than that of a following partition.
ORA-14038: GLOBAL partitioned index must be prefixed
Cause: User attempted to create a GLOBAL non-prefixed partitioned index which is illegal
Action: If the user, indeed, desired to create a non-prefixed index, it must be created as LOCAL; otherwise, correct the list of key and/or partitioning columns to ensure that the index is prefixed
ORA-14039: partitioning columns must form a subset of key columns of a UNIQUE index
Cause: User attempted to create a UNIQUE partitioned index whose partitioning columns do not form a subset of its key columns which is illegal
Action: If the user, indeed, desired to create an index whose partitioning columns do not form a subset of its key columns, it must be created as non-UNIQUE; otherwise, correct the list of key and/or partitioning columns to ensure that the index' partitioning columns form a subset of its key columns
ORA-14041: partition bound may not be specified for resulting partitions
Cause: while parsing an ALTER {TABLE|INDEX} SPLIT PARTITION statement, <partition-description> of a resulting partition was found to contain VALUES LESS THAN clause which is illegal
Action: remove VALUES LESS THAN clause from the description(s) of partitions resulting from splitting an existing table or index partition
ORA-14042: partition bound may not be specified for a partition being moved, modified or rebuilt
Cause: while parsing an ALTER {TABLE|INDEX} MODIFY PARTITION, ALTER TABLE MOVE PARTITION, or ALTER INDEX REBUILD PARTITION statement, description of new physical attributes of the partition being moved, modified, or rebuilt was found to contain VALUES LESS THAN clause which is illegal
Action: remove VALUES LESS THAN clause from the description of new attributes of the partition being moved, modified, or rebuilt
ORA-14043: only one partition may be added
Cause: ALTER TABLE ADD PARTITION contained descriptions of more than one partition to be added
Action: Ensure that the statement contains exactly one partition definition and that it does not contain any commas
ORA-14044: only one partition may be moved
Cause: ALTER TABLE MOVE PARTITION contained descriptions of more than one partition to be moved
Action: Ensure that the statement describes exactly one partition to be moved and that it does not contain any commas
ORA-14045: only one partition may be modified
Cause: ALTER TABLE|INDEX MODIFY PARTITION contained descriptions of more than one partition to be modified
Action: Ensure that the statement describes exactly one partition to be modified and that it does not contain any commas
ORA-14046: a partition may be split into exactly two new partitions
Cause: ALTER TABLE|INDEX SPLIT PARTITION did not contain descriptions of exactly two new partitions into which an existing table or index partition was to be split
Action: Ensure that the statement describes exactly two partition into which an existing partition is to be split
ORA-14047: ALTER TABLE|INDEX RENAME may not be combined with other operations
Cause: ALTER TABLE or ALTER INDEX statement attempted to combine a RENAME operation with some other operation which is illegal
Action: Ensure that RENAME operation is the sole operation specified in ALTER TABLE or ALTER INDEX statement;
ORA-14048: a partition maintenance operation may not be combined with other operations
Cause: ALTER TABLE or ALTER INDEX statement attempted to combine a partition maintenance operation (e.g. MOVE PARTITION) with some other operation (e.g. ADD PARTITION or PCTFREE which is illegal
Action: Ensure that a partition maintenance operation is the sole operation specified in ALTER TABLE or ALTER INDEX statement; operations other than those dealing with partitions, default attributes of partitioned tables/indices or specifying that a table be renamed (ALTER TABLE RENAME) may be combined at will
ORA-14049: invalid ALTER TABLE MODIFY PARTITION option
Cause: An option other than PCTFREE, PCTUSED, INITRANS, MAXTRANS, STORAGE, BACKUP, ALLOCATE EXTENT, or DEALLOCATE UNUSED was specified in an ALTER TABLE MODIFY PARTITION statement for a Range or Composite Range partition.
Action: Specify only legal options.
ORA-14050: invalid ALTER INDEX MODIFY PARTITION option
Cause: An option other than INITRANS, MAXTRANS, STORAGE, or DEALLOCATE UNUSED was specified in an ALTER INDEX MODIFY PARTITION statement.
Action: Specify only legal options.
ORA-14051: invalid ALTER MATERIALIZED VIEW option
Cause: An option other than PCTFREE, PCTUSED, INITRANS, MAXTRANS, STORAGE, or BACKUP was specified in an ALTER MATERIALIZED VIEW statement.
Action: Specify only legal options.
ORA-14052: partition-extended table name syntax is disallowed in this context
Cause: User attempted to use partition-extended table name syntax in illegal context (i.e. not in FROM-clause or INSERT, DELETE, or UPDATE statement)
Action: Avoid use of partition-extended table name in contexts other those mentioned above.
ORA-14053: illegal attempt to modify string in string statement
Cause: Certain attributes of objects (e.g. tables) may be specified at creation time, but may not be modified using ALTER statement. Unfortunately, user specified one of such attributes.
Action: Ensure that ALTER statement specifies new values only for attributes which may be changed once an object has been created
ORA-14054: invalid ALTER TABLE TRUNCATE PARTITION option
Cause: Name of the partition to be truncated may be followed by DROP STORAGE or REUSE STORAGE
Action: Ensure that no options besides DROP STORAGE or REUSE STORAGE are specified with ALTER TABLE TRUNCATE PARTITION
ORA-14055: keyword REBUILD in ALTER INDEX REBUILD must immediately follow <index name>
Cause: ALTER INDEX statement contained REBUILD keyword following some index attributes (e.g. INITRANS.)
Action: Ensure that keyword REBUILD immediately follows the name of the index being altered
ORA-14056: partition number string: sum of PCTUSED and PCTFREE may not exceed 100
Cause: the sum of PCTUSED and PCTFREE for a partition whose number (partitions are numbered starting with 1) is displayed in this message exceeds 100. Note that if PCTUSED and/or PCTFREE values for this partition were not specified explicitly, default values for the partitioned table or index would be used. If, in turn, default PCTUSED and/or PCTFREE values for the partitioned table or index were not specified, system defaults would be used.
Action: ensure that a sum of PCTUSED and PCTFREE for the partition does not exceed 100
ORA-14057: partition "string": sum of PCTUSED and PCTFREE may not exceed 100
Cause: the sum of PCTUSED and PCTFREE for a partition whose name (explicitly specified by the user) is displayed in this message exceeds 100. Note that if PCTUSED and/or PCTFREE values for this partition were not specified explicitly, default values for the partitioned table or index would be used. If, in turn, default PCTUSED and/or PCTFREE values for the partitioned table or index were not specified, system defaults would be used.
Action: ensure that a sum of PCTUSED and PCTFREE for the partition does not exceed 100
ORA-14058: partition number string: INITRANS value must be less than MAXTRANS value
Cause: Value of INITRANS was found to be greater than that of MAXTRANS for a partition whose number (partitions are numbered starting with 1) is displayed in this message. Note that if INITRANS and/or MAXTRANS values for this partition were not specified explicitly, default values for the partitioned table or index would be used. If, in turn, default INITRANS and/or MAXTRANS values for the partitioned table or index were not specified, system defaults would be used.
Action: ensure that value of INITRANS (whether specified explcitly or derived from the default value for the partitioned table or index) is no greater than that of MAXTRANS
ORA-14059: partition "string": INITRANS value must be less than MAXTRANS value
Cause: Value of INITRANS was found to be greater than that of MAXTRANS for a partition whose name (explicitly specified by the user) is displayed in this message. Note that if INITRANS and/or MAXTRANS values for this partition were not specified explicitly, default values for the partitioned table or index would be used. If, in turn, default INITRANS and/or MAXTRANS values for the partitioned table or index were not specified, system defaults would be used.
Action: ensure that value of INITRANS (whether specified explcitly or derived from the default value for the partitioned table or index) is no greater than that of MAXTRANS
ORA-14060: data type or length of a table partitioning column may not be changed
Cause: User issued ALTER TABLE statement attempting to modify data type and/or length of a column used to partition the table named in ALTER TABLE statement, which is illegal
Action: Avoid modifying data type and/or length of table partitioning column(s)
ORA-14061: data type or length of an index partitioning column may not be changed
Cause: User issued ALTER TABLE statement attempting to modify data type and/or length of a column used to partition some index defined on the table named in ALTER TABLE statement, which is illegal
Action: Avoid modifying data type and/or length of index partitioning column(s)
ORA-14062: one or more of table's partitions reside in a read-only tablespace
Cause: User issued ALTER TABLE statement attempting to modify an existing VARCHAR2 (or VARCHAR) column to be of type CHAR (or CHARACTER), increase length of an existing CHAR (or CHARACTER) column, or add a column with user-specified default for a table one or more partitions of which reside in read-only tablespaces, which is illegal
Action: Avoid performing aformentioned operations on a partitioned table one or more partitions of which reside in read-only tablespaces
ORA-14063: Unusable index exists on unique/primary constraint key
Cause: User attempted to add or enable a primary key/unique constraint on column(s) of a table on which there exists an index marked Index Unusable.
Action: Drop the existing index or rebuild it using ALTER INDEX REBUILD
ORA-14064: Index with Unusable partition exists on unique/primary constraint key
Cause: User attempted to add or enable a primary key/unique constraint on column(s) of a table on which there exists an index one or more partitions of which are marked Index Unusable.
Action: Drop the existing index or rebuild unusable partitions it using ALTER INDEX REBUILD PARTITION
ORA-14065: ALLOCATE STORAGE may not be specified for a partitioned table
Cause: User specified ALLOCATE STORAGE clause in ALTER TABLE statement issued against a partitioned table which is illegal.
Action: Remove the illegal option. If it is desired to add storage to individual partitions, ALLOCATE STORAGE clause may be specified with ALTER TABLE MODIFY PARTITION statement.
ORA-14066: illegal option for a non-partitioned index-organized table
Cause: An attempt was made to issue a CREATE or ALTER TABLE command on a non-partitioned IOT, but the command contains an option that is legal only for partitioned index-organized tables. Such options are: ENABLE ROW MOVEMENT and DISABLE ROW MOVEMENT.
Action: Remove the illegal option(s) from the command.
ORA-14067: duplicate TABLESPACE_NUMBER specification
Cause: TABLESPACE_NUMBER clause was specified more than once for an table, index or an index partition
Action: Correct the code generating text of CREATE INDEX statement sent to the slaves
ORA-14068: TABLESPACE and TABLESPACE_NUMBER may not be both specified
Cause: Both TABLESPACE and TABLESPACE_NUMBER clauses were specified for a table, index or an index partition
Action: Correct the code generating text of CREATE INDEX statement sent to the slaves
ORA-14069: invalid TABLESPACE_NUMBER value
Cause: The TABLESPACE_NUMBER value is not an integer between 0 and 0x7FFFFFFF
Action: Correct the code generating text of CREATE INDEX statement sent to the slaves
ORA-14070: option may be specified only for partitioned indices or with REBUILD
Cause: User issued ALTER INDEX statament containing an option which is legal only for partitioned indices or in conjunction with REBUILD against a non-partitioned index. Such options are: PCTFREE, TABLESPACE, [NO]PARALLEL and INITIAL, FREELISTS, and FREELIST GROUPS inside STORAGE clause
Action: Remove illegal option(s).
ORA-14071: invalid option for an index used to enforce a constraint
Cause: An option other than COMPRESS, NOCOMPRESS, PCTFREE, INITRANS, MAXTRANS, STORAGE, TABLESPACE, PARALLEL, NOPARALLEL, RECOVERABLE, UNRECOVERABLE, LOGGING, NOLOGGING, LOCAL, or GLOBAL was specified for an index used to enforce a constraint.
Action: Choose one of the valid index options.
ORA-14072: fixed table may not be truncated
Cause: User attempted to truncate a fixed table which is illegal.
Action: Ensure that the table being truncated is not a fixed table.
ORA-14073: bootstrap table or cluster may not be truncated
Cause: User attempted to truncate a bootstrap table or cluster which is illegal
Action: Ensure that the table (or cluster) being truncated is not a bootstrap table (or cluster)
ORA-14074: partition bound must collate higher than that of the last partition
Cause: Partition bound specified in ALTER TABLE ADD PARTITION statement did not collate higher than that of the table's last partition, which is illegal.
Action: Ensure that the partition bound of the partition to be added collates higher than that of the table's last partition.
ORA-14075: partition maintenance operations may only be performed on partitioned indices
Cause: Index named in ALTER INDEX partition maintenance operation is not partitioned, making a partition maintenance operation, at best, meaningless
Action: Ensure that the index named in ALTER INDEX statement specifying a partition maintenance operation is, indeed, partitioned
ORA-14076: submitted alter index partition/subpartition operation is not valid for local partitioned index
Cause: User attempted to either drop, split, add or coalesce a partition or a subpartition of a local index which is illegal.
Action: Ensure that the index named in such statement is a global partitioned index.
ORA-14078: you may not drop the highest partition of a GLOBAL index
Cause: User attempted to drop highest partition of a GLOBAL index, which is illegal.
Action: Ensure that the partition specified in ALTER INDEX DROP PARTITION statement is not the highest partition of the index.
ORA-14079: illegal option for a partition marked Index Unusable
Cause: ALTER INDEX MODIFY PARTITION statement against an index partition marked Index Unusable contained STORAGE and/or DEALLOCATE SPACE clauses which is illegal
Action: Ensure that only valid optins are specified
ORA-14080: partition cannot be split along the specified high bound
Cause: User attempted to split a partition along a bound which either collates higher than that of the partition to be split or lower than that of a partition immediately preceding the one to be split
Action: Ensure that the bound along which a partition is to be split collates lower than that of the partition to be split and higher that that of a partition immediately preceding the one to be split
ORA-14081: new partition name must differ from the old partition name
Cause: User entered ALTER TABLE/INDEX RENAME PARTITION specifying <new-partition-name> which is identical to the name of the partition being renamed
Action: Ensure that the new partition name is different from the name of any (including the one being renamed) existing partition of a given table or index
ORA-14082: new partition name must differ from that of any other partition of the object
Cause: User entered ALTER TABLE/INDEX RENAME PARTITION specifying <new-partition-name> which is identical to the name of some existing partition of the object
Action: Ensure that the new partition name is different from the name of any (including the one being renamed) existing partition of a given table or index
ORA-14083: cannot drop the only partition of a partitioned table
Cause: A drop partition command is being executed when there is only one partition in the table
Action: Ensure that there is at least one partition. Drop table to remove all partitions
ORA-14084: you may specify TABLESPACE DEFAULT only for a LOCAL index
Cause: User attempted to specify TABLESPACE DEFAULT for an object other than a LOCAL index, which is illegal.
Action: Reenter the statement without TABLESPACE DEFAULT clause.
ORA-14085: partitioned table cannot have column with LONG datatype
Cause: User tried to create a partitioned table with a LONG datatype or tried to add a LONG datatype column to a partitioned table.
Action: LONG data types are not supported with partitioned tables. Create table without LONG column or change table to not partitioned. If adding column, do not use LONG datatype. If modifying attributes of a column to change data type to LONG, it has to be a non partitioned table.
ORA-14086: a partitioned index may not be rebuilt as a whole
Cause: User attempted to rebuild a partitioned index using ALTER INDEX REBUILD statement, which is illegal
Action: Rebuild the index a partition at a time (using ALTER INDEX REBUILD PARTITION) or drop and recreate the entire index
ORA-14094: invalid ALTER TABLE EXCHANGE PARTITION option
Cause: Name of the table to be EXCHANGED has to be followed by [{INCLUDING|EXCLUDING} INDEX][{WITH|WITHOUT} VALIDATION]
Action: Ensure that no options besides INCLDING INDEX or EXCLUDING INDEX are specified with ALTER TABLE EXCHANGE PARTITION
ORA-14095: ALTER TABLE EXCHANGE requires a non-partitioned, non-clustered table
Cause: The table in the EXCHANGE operation is either clustered or partitioned
Action: Ensure that the table with which the partition is being exchanged for is not partitioned or clustered.
ORA-14096: tables in ALTER TABLE EXCHANGE PARTITION must have the same number of columns
Cause: The two tables specified in the EXCHANGE have different number of columns
Action: Ensure that the two tables have the same number of columns with the same type and size.
ORA-14097: column type or size mismatch in ALTER TABLE EXCHANGE PARTITION
Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE PARTITION are of different type or size
Action: Ensure that the two tables have the same number of columns with the same type and size.
ORA-14098: index mismatch for tables in ALTER TABLE EXCHANGE PARTITION
Cause: The two tables specified in the EXCHANGE have indexes which are not equivalent
Action: Ensure that the indexes for the two tables have indexes which follow this rule For every non partitioned index for the non partitioned table, there has to be an identical LOCAL index on the partitioned table and vice versa. By identical, the column position, type and size have to be the same.
ORA-14099: all rows in table do not qualify for specified partition
Cause: There is at least one row in the non partitioned table which does not qualify for the partition specified in the ALTER TABLE EXCHANGE PARTITION
Action: Ensure that all the rows in the segment qualify for the partition. Perform the alter table operation with the NO CHECKING option. Run ANALYZE table VALIDATE on that partition to find out the invalid rows and delete them.
ORA-14100: partition extended table name cannot refer to a remote object
Cause: User attempted to use partition-extended table name syntax in conjunction with remote object name which is illegal
Action: Correct the statement and reenter
ORA-14101: partition extended table name cannot refer to a synonym
Cause: User attempted to use partition-extended table name syntax in conjunction with synonym name which is illegal
Action: Correct the statement and reenter
ORA-14102: only one LOGGING or NOLOGGING clause may be specified
Cause: LOGGING was specified more than once, NOLOGGING was specified more than once, or both LOGGING and NOLOGGING were specified.
Action: Remove all but one of the LOGGING or NOLOGGING clauses and reissue the statement.
ORA-14103: LOGGING/NOLOGGING may not be combined with RECOVERABLE/UNRECOVERABLE
Cause: A statement contained both [NO]LOGGING and [UN]RECOVERABLE clauses which is disallowed.
Action: Remove one of the offending clauses. [UN]RECOVERABLE is being deprecated in V8 and will be obsoleted in V9. To duplicate semantics of UNRECOVERABLE clause, create an object with NOLOGGING option and then ALTER it specifying LOGGING. To duplicate semantics of RECOVERABLE clause, create an object with LOGGING option.
ORA-14104: RECOVERABLE/UNRECOVERABLE may not be specified for partitioned tables/indices
Cause: CREATE TABLE/INDEX statement used to create a partitioned table/index contained RECOVERABLE or UNRECOVERABLE clause which is illegal
Action: Remove offending clause. [UN]RECOVERABLE is being deprecated in V8 and will be obsoleted in V9. To duplicate semantics of UNRECOVERABLE clause, create an object with NOLOGGING option and then ALTER it specifying LOGGING. To duplicate semantics of RECOVERABLE clause, create an object with LOGGING option.
ORA-14105: RECOVERABLE/UNRECOVERABLE may not be specified in this context
Cause: RECOVERABLE/UNRECOVERABLE clause is not allowed in this context.
Action: Remove offending clause. RECOVERABLE/UNRECOVERABLE may only be specified in CREATE TABLE/INDEX statement describing a non-partitioned table or index and ALTER INDEX REBUILD statement. [UN]RECOVERABLE is being deprecated in V8 and will be obsoleted in V9. To duplicate semantics of UNRECOVERABLE clause, create an object with NOLOGGING option and then ALTER it specifying LOGGING. To duplicate semantics of RECOVERABLE clause, create an object with LOGGING option.
ORA-14106: LOGGING/NOLOGGING may not be specified for a clustered table
Cause: User attempted to specify LOGGING or NOLOGGING clausein CREATE TABLE or ALTER TABLE statement involving a clustered table
Action: Remove offending clause.
ORA-14107: partition specification is required for a partitioned object
Cause: parameter which supplies partition name is missing. This parameter is optional for non-partitioned objects, but is required for partitioned objects.
Action: supply missing parameter
ORA-14108: illegal partition-extended table name syntax
Cause: Partition to be accessed may only be specified using its name. User attempted to use a partition number or a bind variable.
Action: Modify statement to refer to a partition using its name
ORA-14109: partition-extended object names may only be used with tables
Cause: User attempted to use a partition-extended object name with an object which is not a table.
Action: Avoid using partition-extended name syntax with objects which are not tables
ORA-14110: partitioning column may not be of type ROWID
Cause: Partitioning column specified by the user was of type ROWID, which is illegal.
Action: Ensure that no partitioning column is of type ROWID.
ORA-14111: creation of a GLOBAL partitioned index on clustered tables is not supported
Cause: An attempt was made to create a GLOBAL partitioned index on a clustered table which is currently illegal.
Action: Remove PARTITION BY RANGE/HASH clause along with any partition descriptions to create a GLOBAL non-partitioned index on a clustered table
ORA-14112: RECOVERABLE/UNRECOVERABLE may not be specified for a partition or subpartition
Cause: Description of a partition or subpartition found in CREATE TABLE/INDEX statement contained RECOVERABLE or UNRECOVERABLE clause which is illegal
Action: Remove offending clause. Use LOGGING or NOLOGGING instead.
ORA-14113: partitioned table cannot have column with LOB datatype
Cause: User tried to create a partitioned table with a LOB datatype or tried to add a LOB datatype column to a partitioned table.
Action: LOB data types are not supported with partitioned tables. Create table without LOB column or change table to not partitioned. If adding column, do not use LOB datatype. If modifying attributes of a column to change data type to LOB, it has to be a non partitioned table.
ORA-14114: partitioned table cannot have column with object, REF, nested table, array datatype
Cause: User tried to create a partitioned table with a object datatype (object, REF, nested table, array) or tried to add a object datatype column to a partitioned table.
Action: object data types are not supported with partitioned tables. Create table without object column or change table to not partitioned. If adding column, do not use object datatypes. If modifying attributes of a column to change data type to object, it has to be a non partitioned table.
ORA-14115: partition bound of partition number string is too long
Cause: Length of linear key representation of a high bound of the partition whose number (partitions are numbered starting with 1) is displayed in this message exceeded the legal limit (4K).
Action: Change representation of a partition high bound to bring its length within legal limit.
ORA-14116: partition bound of partition "string" is too long
Cause: Length of linear key representation of a high bound of the partition whose name (explicitly specified by the user) is displayed in this message exceeded the legal limit (4K).
Action: Change representation of a partition high bound to bring its length within legal limit.
ORA-14117: partition resides in offlined tablespace
Cause: User attempted an operation requiring that we access data in a partition which resides in a tablespace which was taken offline. Such operations include trying to drop a tablespace of a table which has indices defined on it or is referenced by a constraint.
Action: Bring tablespace online before attempting the operation.
ORA-14118: CHECK constraint mismatch in ALTER TABLE EXCHANGE PARTITION
Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE PARTITION statement have CHECK constraint defined on them.
Action: Ensure that the two tables do not have CHECK constraint defined on any column
ORA-14119: specified partition bound is too long
Cause: Length of a linear key representation of a high bound of a table partition being added or along which an existing table or index partition is being split exceeded the legal limit (4K).
Action: Change representation of a partition high bound to bring its length within legal limit.
ORA-14120: incompletely specified partition bound for a DATE column
Cause: An attempt was made to use a date expression whose format does not fully (i.e. day, month, and year (including century)) specify a date as a partition bound for a DATE column. The format may have been specified explicitly (using TO_DATE() function) or implicitly (NLS_DATE_FORMAT).
Action: Ensure that date format used in a partition bound for a DATE column supports complete specification of a date (i.e. day, month, and year (including century)). If NLS_DATE_FORMAT does not support complete (i.e. including the century) specification of the year, use TO_DATE() (e.g. TO_DATE('01-01-1999', 'MM-DD-YYYY') to fully express the desired date.
ORA-14121: MODIFY DEFAULT ATTRIBUTES may not be combined with other operations
Cause: ALTER TABLE or ALTER INDEX statement attempted to combine MODIFY DEFAULT ATTRIBUTES with some other operation (e.g. ADD PARTITION or PCTFREE) which is illegal
Action: Ensure that MODIFY DEFAULT ATTRIBUTES is the sole operation specified in ALTER TABLE or ALTER INDEX statement; operations other than those dealing with partitions, default attributes of partitioned tables/indices or specifying that a table be renamed (ALTER TABLE RENAME) may be combined at will
ORA-14122: only one REVERSE or NOREVERSE clause may be specified
Cause: Both REVERSE and NOREVERSE were specified in CREATE INDEX statement.
Action: Remove all but one of the REVERSE or NOREVERSE clauses and reissue the statement.
ORA-14123: duplicate NOREVERSE clause
Cause: NOREVERSE was specified more than once in ALTER INDEX statement.
Action: Remove all but one of the NOREVERSE clauses and reissue the statement.
ORA-14124: duplicate REVERSE clause
Cause: REVERSE was specified more than once in ALTER INDEX or CREATE INDEX statements.
Action: Remove all but one of the REVERSE clauses and reissue the statement.
ORA-14125: REVERSE/NOREVERSE may not be specified in this context
Cause: REVERSE/NOREVERSE clause is not allowed in this context.
Action: Remove offending clause. REVERSE may be specified as an attribute of an index (not of an individual partition, if creating a partitioned index) in CREATE INDEX statement and ALTER INDEX REBUILD statement. NOREVERSE may be specified only in ALTER INDEX REBUILD statement.
ORA-14126: only a <parallel clause> may follow description(s) of resulting partitions
Cause: Descriptions of partition(s) resulting from splitting of a table or index partition may be followed by an optional <parallel clause> which applies to the entire statement and which, in turn, may not be followed by any other clause.
Action: Ensure that all partition attributes appear within the parenthesized list of descriptions of resulting partitions in ALTER TABLE/INDEX SPLIT PARTITION statement.
ORA-14128: FOREIGN KEY constraint mismatch in ALTER TABLE EXCHANGE PARTITION
Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE PARTITION statement have different FOREIGN KEY constraints.
Action: Ensure that the two tables do not have FOREIGN KEY constraints defined on any column or disable all FOREIGN KEY constraints on both tables. Then retry the operation.
ORA-14129: INCLUDING INDEXES must be specified as tables have enabled UNIQUE constraints
Cause: Matching UNIQUE constraints in both table are enabled and validated but INCLUDING INDEXES is not specified in ALTER TABLE EXCHANGE PARTITION|SUBPARTITION command.
Action: Disable currently enabled matching UNIQUE constraints on both tables or ensure that INCLUDING INDEXES option is used.
ORA-14130: UNIQUE constraints mismatch in ALTER TABLE EXCHANGE PARTITION
Cause: One of the tables named in the ALTER TABLE EXCHANGE PARTITION command has a UNIQUE constraint for which no matching (vis-a-vis key columns) constraint is defined on the other table or a matching constraint is defined on the other table, but it differs from that defined on the first table vis-a-vis being enabled and/or validated.
Action: Ensure that for every UNIQUE constraint defined on one of the tables named in the ALTER TABLE EXCHANGE PARTITION statement there is a matching (vis-a-vis key columns and being enabled and/or validated) UNIQUE constraint defined on the other table. If UNIQUE constrains are enabled, UNIQUE constraints on the partitioned table should be enforced using local indexes.
ORA-14131: enabled UNIQUE constraint exists on one of the tables
Cause: One of the tables referenced in the ALTER TABLE EXCHANGE PARTITION|SUBPARTITION statement has enabled UNIQUE constraint(s) defined on it, which prevents EXCHANGE from proceeding.
Action: Disable constraints defined on tables referenced in the ALTER TABLE EXCHANGE PARTITION|SUBPARTITION statement and retry the statement.
ORA-14132: table cannot be used in EXCHANGE
Cause: An attempt was made to issue an ALTER TABLE EXCHANGE PARTITION | SUBPARTITION command, but the non-partitioned table cannot be used in the EXCHANGE because one or more of the following apply:

- it is a typed table

- it contains ADT columns

- it contains nested-table columns

- it contains REF columns

- it contains array columns

- it is an index-organized table

- it contains LOB columns

- it is a nested table

Action: Make sure the non-partitioned table does not violate any of the above restrictions for the ALTER TABLE EXCHANGE PARTITION | SUBPARTITION command.
ORA-14133: ALTER TABLE MOVE cannot be combined with other operations
Cause: An attempt was made to combine an ALTER TABLE MOVE statement with another operation, such as MODIFY.
Action: Make sure that MOVE is the only operation specified in ALTER TABLE statement;
ORA-14134: indexes cannot use both DESC and REVERSE
Cause: An attempt was made to make a reverse index with some index columns marked DESC.
Action: Do not use DESC in reverse indexes. The rule-based optimizer can scan indexes backwards, which allows a normal reverse index to simulate a reverse index with columns marked DESC.
ORA-14135: a LOB column cannot serve as a partitioning column
Cause: An attempt was made to specify a column of type BLOB or CLOB as a partitioning or subpartitioning column.
Action: Ensure that no partitioning or subpartitioning column is of type BLOB or CLOB.
ORA-14136: ALTER TABLE EXCHANGE restricted by fine-grained security
Cause: User doing exchange does not have full table access due to VPD policies.
Action: Grant exempt priviliges to this user.
ORA-14150: missing SUBPARTITION keyword
Cause: keyword SUBPARTITION missing
Action: supply missing keyword
ORA-14151: invalid table partitioning method
Cause: Invalid partitioning method was specified in CREATE TABLE statement. A table may be partitioned by RANGE, HASH, or Composite Range/Hash (R+H).
Action: Specify one of valid partitioning methods
ORA-14152: invalid number of partitions specified in PARTITIONS clause
Cause: number-of-partitions clause contained in CREATE TABLE or CREATE INDEX statement specified a number of partitions outside of legal range (1-65535)
Action: Specify a number between 1 and 65535 in the number-of-partitions clause
ORA-14153: only one of STORE IN or <partition-description> clause may be specified
Cause: both STORE IN and <partition-description> clauses were specified in a CREATE TABLE|INDEX command
Action: Remove one of offending clauses
ORA-14154: only one of STORE IN or <subpartition-description> clause may be specified
Cause: both STORE IN and <subpartition-description> clauses were specified in a CREATE TABLE|INDEX, or ALTER TABLE ADD|SPLIT PARTITION or ALTER TABLE MERGE PARTITIONS command for a Composite Range partitioned object
Action: Remove one of offending clauses
ORA-14155: missing PARTITION or SUBPARTITION keyword
Cause: expect either PARTITION or SUBPARTITION keyword but none was supplied
Action: supply missing keyword
ORA-14156: invalid number of subpartitions specified in [SUBPARTITIONS | SUBPARTITION TEMPLATE] clause
Cause: number-of-subpartitions clause contained in CREATE TABLE or CREATE INDEX statement specified a number of subpartitions outside of legal range (1-65535)
Action: Specify a number between 1 and 65535 in the number-of-subpartitions clause
ORA-14157: invalid subpartition name
Cause: a subpartition name of the form <identifier> is expected but not present.
Action: enter an appropriate subpartition name.
ORA-14158: too many subpartition descriptions
Cause: CREATE TABLE or CREATE INDEX contained too many subpartition descriptions; maximum number of subpartitions is 65535.
Action: Reduce number of subpartitions to not exceed 65535.
ORA-14159: duplicate subpartition name
Cause: Name of a subpartition of a table or index being created is not unique
Action: rename subpartition(s) to ensure that their names are unique among subpartitions of the table or index being created
ORA-14160: this physical attribute may not be specified for a table subpartition
Cause: unexpected option was encountered while parsing physical attributes of a table subpartition; TABLESPACE is the only valid option
Action: remove invalid option(s)
ORA-14161: subpartition number string: sum of PCTUSED and PCTFREE may not exceed 100
Cause: the sum of PCTUSED and PCTFREE for a subpartition whose number (subpartitions are numbered starting with 1) is displayed in this message exceeds 100. Note that if PCTUSED and/or PCTFREE values for this subpartition were not specified explicitly, default values at partition-level would be used. If, in turn, default PCTUSED and/or PCTFREE values at partition-level were not specified, default values for the partitioned table or index would be used. If those values were also not specified explicitly, system defaults would be used.
Action: ensure that a sum of PCTUSED and PCTFREE for the subpartition does not exceed 100
ORA-14162: subpartition "string": sum of PCTUSED and PCTFREE may not exceed 100
Cause: the sum of PCTUSED and PCTFREE for a subpartition whose name (explicitly specified by the user) is displayed in this message exceeds 100. Note that if PCTUSED and/or PCTFREE values for this subpartition were not specified explicitly, default values at partition-level would be used. If, in turn, default PCTUSED and/or PCTFREE values at partition-level were not specified, default values for the partitioned table or index would be used. If those values were also not specified explicitly, system defaults would be used.
Action: ensure that a sum of PCTUSED and PCTFREE for the subpartition does not exceed 100
ORA-14163: subpartition number string: INITRANS value must be less than MAXTRANS value
Cause: Value of INITRANS was found to be greater than that of MAXTRANS for a subpartition whose number (subpartitions are numbered starting with 1) is displayed in this message. Note that if INITRANS and/or MAXTRANS values for this subpartition were not specified explicitly, default values at partition-level would be used. If, in turn, default INITRANS and/or MAXTRANS values at partition-level were not specified, default values for the partitioned table or index would be used. If those values were also not specified explicitly, system defaults would be used.
Action: ensure that value of INITRANS (whether specified explicitly or derived from the default value at partition-level, table-level or index-level) is no greater than that of MAXTRANS
ORA-14164: subpartition "string": INITRANS value must be less than MAXTRANS value
Cause: Value of INITRANS was found to be greater than that of MAXTRANS for a subpartition whose name (explicitly specified by the user) is displayed in this message. Note that if INITRANS and/or MAXTRANS values for this subpartition were not specified explicitly, default values at partition-level would be used. If, in turn, default INITRANS and/or MAXTRANS values at partition-level were not specified, default values for the partitioned table or index would be used. If those values were also not specified explicitly, system defaults would be used.
Action: ensure that value of INITRANS (whether specified explicitly or derived from the default value at partition-level, table-level or index-level) is no greater than that of MAXTRANS
ORA-14165: MODIFY DEFAULT ATTRIBUTES FOR PARTITION may not be combined with other operations
Cause: ALTER TABLE or ALTER INDEX statement attempted to combine MODIFY DEFAULT ATTRIBUTES OF PARTITION with some other operation (e.g. ADD PARTITION or PCTFREE) which is illegal
Action: Ensure that MODIFY DEFAULT ATTRIBUTES is the sole operation specified in ALTER TABLE or ALTER INDEX statement; operations other than those dealing with partitions, default attributes of partitioned tables/indices or specifying that a table be renamed (ALTER TABLE RENAME) may be combined at will
ORA-14166: missing INTO keyword
Cause: keyword INTO missing
Action: supply missing keyword
ORA-14167: only one subpartition may be moved
Cause: ALTER TABLE MOVE SUBPARTITION contained descriptions of more than one subpartition to be moved
Action: Ensure that the statement describes exactly one subpartition to be moved and that it does not contain any commas
ORA-14168: only one subpartition may be modified
Cause: ALTER TABLE|INDEX MODIFY SUBPARTITION contained descriptions of more than one subpartition to be modified
Action: Ensure that the statement describes exactly one subpartition to be modified and that it does not contain any commas
ORA-14169: invalid ALTER TABLE MODIFY SUBPARTITION option
Cause: An option other than PCTFREE, PCTUSED, INITRANS, MAXTRANS, STORAGE, was specified in an ALTER TABLE MODIFY SUBPARTITION statement.
Action: Specify only legal options.
ORA-14170: cannot specify <partition-description> clause in CREATE TABLE|INDEX
Cause: User requested to generate default partition description(s) (possibly via PARTITIONS <number-of-partitions>) while at the same time specified <partition-description> clause which is illegal
Action: Remove one of offending clauses.
ORA-14171: cannot specify <subpartition-description> clause in CREATE|ALTER TABLE
Cause: User requested to generate default subpartition description(s) (possibly via SUBPARTITIONS) while at the same time specified <subpartition-description> clause which is illegal
Action: Remove one of offending clauses.
ORA-14172: invalid ALTER TABLE EXCHANGE SUBPARTITION option
Cause: Name of the table to be EXCHANGED has to be followed by [{INCLUDING|EXCLUDING} INDEX][{WITH|WITHOUT} VALIDATION]
Action: Ensure that no options besides INCLDING INDEX or EXCLUDING INDEX are specified with ALTER TABLE EXCHANGE SUBPARTITION
ORA-14173: illegal subpartition-extended table name syntax
Cause: Subpartition to be accessed may only be specified using its name. User attempted to use a subpartition number or a bind variable.
Action: Modify statement to refer to a subpartition using its name
ORA-14174: only a <parallel clause> may follow COALESCE PARTITION|SUBPARTITION
Cause: ALTER TABLE COALESCE PARTITION|SUBPARTITION may be followed by an optional <parallel clause>. No partition/subpartition attributes may be specified
Action: Ensure that no partition/subpartition attribute was specified.
ORA-14175: a subpartition maintenance operation may not be combined with other operations
Cause: ALTER TABLE or ALTER INDEX statement attempted to combine a subpartition maintenance operation (e.g. MOVE SUBPARTITION) with some other operation (e.g. MODIFY PARTITION ADD SUBPARTITION or PCTFREE) which is illegal
Action: Ensure that a subpartition maintenance operation is the sole operation specified in ALTER TABLE or ALTER INDEX statement; operations other than those dealing with subpartitions, default attributes of partitioned tables/indices or specifying that a table be renamed (ALTER TABLE RENAME) may be combined at will
ORA-14176: this attribute may not be specified for a hash partition
Cause: An invalid option was encountered while parsing physical attributes of a partition of an object partitioned using the HASH method. The TABLESPACE option is the only valid option for such partitions.
Action: Remove the invalid option(s).
ORA-14177: STORE-IN (Tablespace list) can only be specified for a LOCAL index on a Hash or Composite Range Hash table
Cause: STORE-IN (Tablespace list) clause was used while creating a local index on a range/list/composite range list partitioned table
Action: Do not use the STORE_IN (Tablespace list) clause while creating a local index on range/list/composite range list partitioned table
ORA-14178: STORE IN (DEFAULT) clause is not supported for hash partitioned global indexes
Cause: STORE IN (DEFAULT) is valid only for local indexes.
Action: a) Specify a tablespace list in place of DEFAULT, or b) Remove STORE IN clause and specify tablespaces individually for each index partition.
ORA-14183: TABLESPACE DEFAULT can be specified only for Composite LOCAL index
Cause: User attempted to specify TABLESPACE DEFAULT for a partition of a Range/System/Hash partitioned LOCAL index object, which is illegal.
Action: Replace TABLESPACE DEFAULT with TABLESPACE <ts_name> or remove it.
ORA-14185: incorrect physical attribute specified for this index partition
Cause: unexpected option was encountered while parsing physical attributes of a local index partition; valid options for Range or Composite Range partitions are INITRANS, MAXTRANS, TABLESPACE, STORAGE, PCTFREE, PCTUSED, LOGGING and TABLESPACE; but only TABLESPACE may be specified for Hash partitions STORE IN () is also disallowed for all but Composite Range partitions
Action: remove invalid option(s) from the list of physical attributes of an index partition
ORA-14186: number of sub-partitions of LOCAL index must equal that of the underlying table
Cause: User attempted to create a LOCAL partitioned index with a number of sub-partitions which is different from that of the underlying table.
Action: Correct the CREATE INDEX statement to specify a correct number of sub-partitions
ORA-14187: partitioning method for LOCAL index is inconsistent with that of the underlying table
Cause: User attempted to create a LOCAL partitioned index that is not equi-partitioned with the underlying table. The partitioning types are mismatched.
Action: Correct the CREATE INDEX statement to ensure that the index partitionining method is consistent with that of the base table
ORA-14188: sub-partitioning columns must form a subset of key columns of a UNIQUE index
Cause: User attempted to create a UNIQUE partitioned index whose sub-partitioning columns do not form a subset of its key columns which is illegal
Action: If the user, indeed, desired to create an index whose subpartitioning columns do not form a subset of its key columns, it must be created as non-UNIQUE; otherwise, correct the list of key and/or subpartitioning columns to ensure that the index' subpartitioning columns form a subset of its key columns
ORA-14189: this physical attribute may not be specified for an index subpartition
Cause: unexpected option was encountered while parsing physical attributes of an index subpartition; TABLESPACE is the only valid option
Action: remove invalid option(s)
ORA-14190: only one ENABLE/DISABLE ROW MOVEMENT clause can be specified
Cause: One of three possible actions caused the error: 1) ENABLE ROW MOVEMENT was specified more than once. 2) DISABLE ROW MOVEMENT was specified more than once. 3) Both ENABLE ROW MOVEMENT and DISABLE ROW MOVEMENT were specified.
Action: Remove all but one of the ENABLE ROW MOVEMENT or DISABLE ROW MOVEMENT clauses; then, reissue the command.
ORA-14191: ALLOCATE STORAGE may not be specified for Composite Range partitioned object
Cause: User specified ALLOCATE STORAGE clause in ALTER TABLE/ALTER INDEX statement issued against a range-partitioned index which is illegal.
Action: Remove the illegal option. If it is desired to add storage to individual partitions, ALLOCATE STORAGE clause may be specified with ALTER TABLE/INDEX MODIFY PARTITION statement.
ORA-14192: cannot modify physical index attributes of a Hash index partition
Cause: User attempted to modify one of INITRANS/MAXTRANS/LOGGING/STORAGE clause for an index partition of a Hash partitioned index
Action: Remove the physical attributes one is trying to modify
ORA-14193: invalid ALTER INDEX MODIFY SUBPARTITION option
Cause: An option other than UNUSABLE, ALLOCATE EXTENT, DEALLOCATE UNUSED was specified in an ALTER INDEX MODIFY SUBPARTITION statement.
Action: Specify only legal options.
ORA-14194: only one subpartition may be rebuilt
Cause: ALTER INDEX REBUILD SUBPARTITION contained descriptions of more than one subpartition to be rebuilt
Action: Ensure that the statement describes exactly one subpartition to be rebuilt and that it does not contain any commas
ORA-14195: ALLOCATE STORAGE may not be specified for RANGE or LIST partitioned object
Cause: User specified ALLOCATE STORAGE clause in ALTER TABLE/ALTER INDEX statement issued against a range-partitioned index which is illegal.
Action: Remove the illegal option. If it is desired to add storage to individual partitions, ALLOCATE STORAGE clause may be specified with ALTER TABLE/INDEX MODIFY PARTITION statement.
ORA-14251: Specified subpartition does not exist
Cause: Subpartition not found for the object.
Action: Retry with correct subpartition name.
ORA-14252: invalid ALTER TABLE MODIFY PARTITION option for a Hash partition
Cause: Only ALLOCATE EXTENT and DEALLOCATE UNUSED may be specified in ALTER TABLE MODIFY PARTITION for a Hash partition.
Action: Specify only legal options.
ORA-14253: table is not partitioned by Composite Range method
Cause: The table in a subpartition maintenance operation (ALTER TABLE EXCHANGE/MODIFY/MOVE/TRUNCATE SUBPARTITION, or ALTER TABLE MODIFY PARTITION ADD/COALESCE SUBPARTITION command must be partitioned by Composite Range method
Action: Ensure that the table is partitioned by Composite Range method
ORA-14254: cannot specify ALLOCATE STORAGE for a (Composite) Range or List partitioned table
Cause: User specified ALLOCATE STORAGE clause in ALTER TABLE statement issued against a Range or Composite Range partitioned table which is illegal.
Action: Remove the illegal option. If it is desired to add storage to individual partitions/subpartitions, ALLOCATE STORAGE clause may be specified with ALTER TABLE MODIFY PARTITION/SUBPARTITION statement. If it is desired to add storage to all subpartitions of a Composite partition, ALLOCATE STORAGE clause may be specified with ALTER TABLE MODIFY PARTITION.
ORA-14255: table is not partitioned by Range, Composite Range or List method
Cause: ALTER TABLE SPLIT/DROP PARTITION or ALTER TABLE MERGE PARTITIONS command is only valid for table partitioned by Range, List or Composite Range method
Action: Ensure that the table is partitioned by Range, List or Composite Range method
ORA-14256: invalid resulting partition description(s)
Cause: User specified STORE-IN clause, SUBPARTITIONS clause, and/or <subpartition-description> clause in partition description(s) in ALTER TABLE SPLIT PARTITION or ALTER TABLE MERGE PARTITIONS statement but the table in the maintenance operation is not a Composite Range partitioned table which is illegal
Action: Remove invalid clause(s), or ensure that the table is partitioned by Composite Range method
ORA-14257: cannot move partition other than a Range or Hash partition
Cause: User attempt to move a partition that is not a Range or Hash partition which is illegal
Action: Specify MOVE PARTITION for a Range or Hash partition only
ORA-14258: invalid partition description
Cause: User specified STORE-IN clause, SUBPARTITIONS clause, and/or <subpartition-description> clause in ALTER TABLE ADD PARTITION statement but the table in the maintenance operation is not a Composite Range/Hash partitioned table which is illegal
Action: Remove invalid clause(s), or ensure that the table is partitioned by Composite Range/Hash method
ORA-14259: table is not partitioned by Hash method
Cause: ALTER TABLE COALESCE PARTITION is only valid for table partitioned by Hash method
Action: Specify valid ALTER TABLE option for the table, or ensure that the table is partitioned by Hash method
ORA-14260: incorrect physical attribute specified for this partition
Cause: User specified INITRANS, MAXTRANS, STORAGE, PCTFREE, PCTUSED, and/or [NO]LOGGING option to a Hash partition via ALTER TABLE ADD/MOVE PARTITION command which is illegal. Only TABLESPACE may be specified.
Action: Remove invalid option(s)
ORA-14261: partition bound may not be specified when adding this Hash partition
Cause: User specified VALUES LESS THAN clause when adding a partition (via ALTER TABLE ADD PARTITION) to a Hash partitioned table which is illegal
Action: Remove VALUES LESS THAN clause from the description of partition being added
ORA-14262: new subpartition name must differ from the old subpartition name
Cause: User entered ALTER TABLE/INDEX RENAME SUBPARTITION specifying <new-subpartition-name> which is identical to the name of the subpartition being renamed
Action: Ensure that the new subpartition name is different from the name of any (including the one being renamed) existing subpartition of a given table or index
ORA-14263: new subpartition name must differ from that of any other subpartition of the object
Cause: User entered ALTER TABLE/INDEX RENAME SUBPARTITION specifying <new-subpartition-name> which is identical to the name of some existing subpartition of the object
Action: Ensure that the new subpartition name is different from the name of any (including the one being renamed) existing subpartition of a given table or index
ORA-14264: table is not partitioned by Composite Range method
Cause: The table in the MODIFY DEFAULT ATTRIBUTES FOR PARTITION operation is partitioned by method other than Composite method
Action: Ensure that the table is partitioned by Composite method
ORA-14265: data type or length of a table subpartitioning column may not be changed
Cause: User issued ALTER TABLE statement attempting to modify data type and/or length of a column used to subpartition the table named in ALTER TABLE statement, which is illegal
Action: Avoid modifying data type and/or length of table subpartitioning column(s)
ORA-14266: data type or length of an index subpartitioning column may not be changed
Cause: User issued ALTER TABLE statement attempting to modify data type and/or length of a column used to subpartition some index defined on the table named in ALTER TABLE statement, which is illegal
Action: Avoid modifying data type and/or length of index subpartitioning column(s)
ORA-14267: cannot specify PARALLEL clause when adding a (Composite) Range partition
Cause: User issued ALTER TABLE ADD PARTITION statement with PARALLEL clause for a Range or Composite Range partition which is illegal
Action: Remove the PARALLEL clause.
ORA-14268: subpartition 'string' of the partition resides in offlined tablespace
Cause: User attempted an operation requiring that we access data in a subpartition which resides in a tablespace which was taken offline. Such operations include trying to drop a tablespace of a table which has indices defined on it or is referenced by a constraint.
Action: Bring tablespace online before attempting the operation.
ORA-14269: cannot exchange partition other than a Range or Hash partition
Cause: User attempt to exchange a partition with a non-partitioned table but the specified partition is not a Range or Hash partition which is illegal
Action: Specify EXCHANGE PARTITION for a Range or Hash partition only
ORA-14270: table is not partitioned by Range or Hash or List method
Cause: The table in ALTER TABLE MODIFY PARTITION { UNUSABLE LOCAL INDEXES | REBUILD UNUSABLE LOCAL INDEXES } statement is not partitioned by Range or Hash method which is illegal.
Action: Ensure that the table is partitioned by Range or Hash method
ORA-14271: table is not partitioned by Composite Range method
Cause: The table in ALTER TABLE MODIFY SUBPARTITION { UNUSABLE LOCAL INDEXES | REBUILD UNUSABLE LOCAL INDEXES } statement is not partitioned by Composite Range method which is illegal.
Action: Ensure that the table is partitioned by Composite Range method
ORA-14272: only a partition with higher bound can be reused
Cause: User attempt to reuse a lower-bound partition in ALTER TABLE MERGE PARTITIONS statement as the resulting partition which is illegal.
Action: Use the higher-bound partition to be the resulting partition or specify a new partition name
ORA-14273: lower-bound partition must be specified first
Cause: User specified higher-bound partition before lower-bound partition in ALTER TABLE MERGE PARTITIONS statement which is illegal
Action: Specify lower-bound partition then higher-bound partition
ORA-14274: partitions being merged are not adjacent
Cause: User attempt to merge two partitions that are not adjacent to each other which is illegal
Action: Specify two partitions that are adjacent
ORA-14275: cannot reuse lower-bound partition as resulting partition
Cause: User attempt to reuse lower-bound partition of the partitions being merged which is illegal
Action: Specify new resulting partition name or reuse the higher-bound partition only
ORA-14276: EXCHANGE SUBPARTITION requires a non-partitioned, non-clustered table
Cause: The table in the ALTER TABLE EXCHANGE SUBPARTITION operation is either clustered or partitioned
Action: Ensure that the table with which the subpartition is being exchanged for is not partitioned or clustered.
ORA-14277: tables in EXCHANGE SUBPARTITION must have the same number of columns
Cause: The two tables specified in the ALTER TABLE EXCHANGE SUBPARTITION have different number of columns
Action: Ensure that the two tables have the same number of columns with the same type and size.
ORA-14278: column type or size mismatch in EXCHANGE SUBPARTITION
Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE SUBPARTITION are of different type or size
Action: Ensure that the two tables have the same number of columns with the same type and size.
ORA-14279: index mismatch for tables in ALTER TABLE EXCHANGE SUBPARTITION
Cause: The two tables specified in the ALTER TABLE EXCHANGE SUBPARTITION have indexes which are not equivalent
Action: Ensure that the indexes for the two tables have indexes which follow this rule For every non partitioned index for the non partitioned table, there has to be an identical LOCAL index on the partitioned table and vice versa. By identical, the column position, type and size have to be the same.
ORA-14280: all rows in table do not qualify for specified subpartition
Cause: There is at least one row in the non partitioned table which does not qualify for the subpartition specified in the ALTER TABLE EXCHANGE SUBPARTITION
Action: Ensure that all the rows in the segment qualify for the subpartition. Perform the alter table operation with the NO CHECKING option. Run ANALYZE table VALIDATE on that subpartition to find out the invalid rows and delete them.
ORA-14281: CHECK constraint mismatch in ALTER TABLE EXCHANGE SUBPARTITION
Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE SUBPARTITION statement have CHECK constraint defined on them.
Action: Ensure that the two tables do not have CHECK constraint defined on any column
ORA-14282: FOREIGN KEY constraint mismatch in ALTER TABLE EXCHANGE SUBPARTITION
Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE SUBPARTITION statement have different FOREIGN KEY constraints.
Action: Ensure that the two tables do not have FOREIGN KEY constraints defined on any column or disable all FOREIGN KEY constraints on both tables. Then retry the operation.
ORA-14283: UNIQUE constraints mismatch in ALTER TABLE EXCHANGE SUBPARTITION
Cause: One of the tables named in the ALTER TABLE EXCHANGE SUBPARTITION command has a UNIQUE constraint for which no matching (vis-a-vis key columns) constraint is defined on the other table or a matching constraint is defined on the other table, but it differs from that defined on the first table vis-a-vis being enabled and/or validated.
Action: Ensure that for every UNIQUE constraint defined on one of the tables named in the ALTER TABLE EXCHANGE SUBPARTITION statement there is a matching (vis-a-vis key columns and being enabled and/or validated) UNIQUE constraint defined on the other table. If UNIQUE constrains are enabled, UNIQUE constraints on the partitioned table should be enforced using local indexes.
ORA-14284: one or more of table's subpartitions reside in a read-only tablespace
Cause: User issued ALTER TABLE statement attempting to modify an existing VARCHAR2 (or VARCHAR) column to be of type CHAR (or CHARACTER), increase length of an existing CHAR (or CHARACTER) column, or add a column with user-specified default for a table one or more subpartitions of which reside in read-only tablespaces, which is illegal
Action: Avoid performing aformentioned operations on a partitioned table one or more subpartitions of which reside in read-only tablespaces
ORA-14285: cannot COALESCE the only partition of this hash partitioned table or index
Cause: A COALESCE PARTITION command was issued when there is only one partition in the table or index, which is illegal
Action: Ensure that there is at least one partition. Drop the table or index to remove all partitions.
ORA-14286: cannot COALESCE the only subpartition of this table partition
Cause: A COALESCE SUBPARTITION command was issued when there is only one subpartition in the partition which is illegal
Action: Ensure that there is at least one subpartition. Drop partition to remove all subpartitions.
ORA-14287: cannot REBUILD a partition of a Composite Range partitioned index
Cause: User attempted to rebuild a partition of a Composite Range partitioned index which is illegal
Action: REBUILD the index partition, a subpartition at a time
ORA-14288: index is not partitioned by Composite Range method
Cause: The index in a partition or subpartition maintenance operation (ALTER INDEX MODIFY [SUBPARTITION|DEFAULT ATTRIBUTES FOR PARTITION] or ALTER INDEX REBUILD SUBPARTITION command must be partitioned by Composite Range method
Action: none
ORA-14289: cannot make local index partition of Composite Range partitioned table unusable
Cause: User attempted to rebuild a partition of a Composite Range partitioned index which is illegal
Action: none
ORA-14290: PRIMARY KEY constraint mismatch in ALTER TABLE EXCHANGE [SUB]PARTITION
Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE [SUB]PARTITION statement have different PRIMARY KEY constraints.
Action: Ensure that the two tables do not have PRIMARY KEY constraints defined on any column or disable all PRIMARY KEY constraints on both tables. Then retry the operation.
ORA-14291: cannot EXCHANGE a composite partition with a non-partitioned table
Cause: A composite partition can only be exchanged with a partitioned table.
Action: Ensure that the table being exchanged is partitioned or that that the partition being exchanged is non-composite.
ORA-14292: Partitioning type of table must match subpartitioning type of composite partition
Cause: When exchanging a partitioned table with a composite partition the partitioning type of the table must match the subpartitioning type of the composite partition.
Action: Ensure that the partitioning type of partitioned table is the same as the subpartitioning type of the composite partition.
ORA-14293: Number of partitioning columns does not match number of subpartitioning columns
Cause: When exchanging a partitioned table with a composite partition the number of partitioning columns of the table must match the number of subpartitioning columns of the composite partition.
Action: Ensure that the number of partitioning columns in the partitioned table is the same as the number of subpartitioning columns in the the composite partition.
ORA-14294: Number of partitions does not match number of subpartitions
Cause: When exchanging a partitioned table with a composite partition the number of partitions of the table must match the number of subpartitions of the composite partition.
Action: Ensure that the number of partitions in the partitioned table is the same as the number of subpartitions in the the composite partition.
ORA-14295: column type or size mismatch between partitioning columns and subpartitioning columns
Cause: When exchanging a partitioned table with a composite partition the type and size of the partitioning columns of the table must match the type and size of the subpartitioning columns of the composite partition.
Action: Ensure that the type and size of the partitioning columns of the partitioned is the same as the type and size of the subpartitioning columns of the composite partition.
ORA-14296: Table block size mismatch in ALTER TABLE EXCHANGE [SUB]PARTITION
Cause: The block sizes of the two tables specified in the ALTER TABLE EXCHANGE [SUB]PARTITION statement are different. For index organized tables, either the block sizes of the index or the overflow (or both) do not match.
Action: Ensure that the block sizes of the tables involved in the ALTER TABLE EXCHANGE [SUB]PARTITION statement are the same. For index organized tables, ensure that the block sizes of both the index and the overflow of the two tables match.
ORA-14297: Index block size mismatch in ALTER TABLE EXCHANGE [SUB]PARTITION
Cause: The block sizes of a pair of indexes being exchanged in the ALTER TABLE EXCHANGE [SUB]PARTITION statement are different.
Action: Ensure that the block sizes of the corresponding pairs of indexes that need to be exchanged in the ALTER TABLE EXCHANGE [SUB]PARTITION statement are the same.
ORA-14298: LOB column block size mismatch in ALTER TABLE EXCHANGE [SUB]PARTITION
Cause: The block sizes of a pair of corresponding LOB columns of the two tables specified in the ALTER TABLE EXCHANGE [SUB]PARTITION statement are different.
Action: Ensure that the block sizes of corresponding pairs of LOB columns of the tables involved in the ALTER TABLE EXCHANGE [SUB]PARTITION statement are the same.
ORA-14299: total number of partitions/subpartitions exceeds the limit of 65535
Cause: The total number of combined fragments specified in partitions /subpartitions exceeds 64K - 1.
Action: Reissue the statement with fewer number of fragments
ORA-14301: table-level attributes must be specified before partition-level attributes
Cause: While processing an ALTER TABLE ADD COLUMN statement, table-level attributes of LOB columns were encountered after processing partition-level attributes of LOB columns or while processing CREATE TABLE statement, table-level attributes of LOB columns were encountered after processing partition descriptions.
Action: Modify the SQL statement to specify table-level attributes prior to partition-level attributes or partition descriptions; then retry the statement.
ORA-14302: only one list of added-LOB-storage-clauses can be specified in a statement
Cause: While parsing an ALTER TABLE ADD COLUMN statement, one list of added-LOB-storage-clauses was parsed when another list of added-LOB-storage-clauses was encountered. There cannot be more than one list of added-LOB-storage-clauses in a statement; all added-LOB-storage-clauses must be combined into one list.
Action: Combine all of the lists of added-LOB-storage-clauses into one list and retry the statement.
ORA-14303: partitions or subpartitions are not in the right order
Cause: User attempted to rebuild a partition of a Composite Range partitioned index which is illegal
Action: Re-order the partitions or subpartitions in the added LOB storage clause by partition or subpartition DDL order, and retry the statement.
ORA-14304: List partitioning method expects a single partitioning column
Cause: number of columns in a partitioning column list exceeded the legal limit of 1 for List partitioned objects
Action: modify partitioning column list so that it consists of at most 1 column
ORA-14305: List value 'string' specified twice in partition 'string'
Cause: A list value cannot be specified more that once
Action: Remove one of the specifications of the value
ORA-14306: List value 'string' specified twice in partitions 'string', 'string'
Cause: A list value cannot be specified more that once
Action: Remove one of the specifications of the value
ORA-14307: partition contains too many list values
Cause: Partition list contains more than 65535 list values
Action: Reduce the number of values to not exceed 65535 values
ORA-14308: partition bound element must be one of: string, datetime or interval literal, number, or NULL
Cause: Partition bound list contained an element of invalid type (i.e. not a number, non-empty string, datetime or interval literal, or NULL)
Action: Ensure that all elements of partition bound list are of valid type
ORA-14309: Total count of list values exceeds maximum allowed
Cause: Partitioned object contains more than 65535 list values
Action: Reduce number of values to less than 65535.
ORA-14310: VALUES LESS THAN or AT clause cannot be used with List partitioned tables
Cause: VALUES LESS THAN or AT clause can be used only with Range partitioned tables
Action: Use VALUES (<value list>) clause with List partitioned tables
ORA-14311: Expecting VALUES LESS THAN or AT clause
Cause: VALUES (<value list>) clause can be used only with List partitioned tables
Action: Use VALUES LESS THAN clause with Range partitioned tables
ORA-14312: Value string already exists in partition string
Cause: One of the list values in the ADD PARTITION or ADD VALUES statement already exists in another partition
Action: Remove the duplicate value from the statement and try again
ORA-14313: Value string does not exist in partition string
Cause: One of the list values in the SPLIT PARTITION or DROP VALUES statement does not exist in the partition
Action: Remove the value from the statement and try again
ORA-14314: resulting List partition(s) must contain atleast 1 value
Cause: After a SPLIT/DROP VALUE of a list partition, each resulting partition(as applicable) must contain at least 1 value
Action: Ensure that each of the resulting partitions contains atleast 1 value
ORA-14315: cannot merge a partition with itself
Cause: The same partition name was specified twice for the merge operation
Action: Re-submit operation with 2 distinct partition names
ORA-14316: table is not partitioned by List method
Cause: ALTER TABLE ADD|DROP VALUES can only be performed on List partitioned objects
Action: Re-issue the command against a List partitoned object.
ORA-14317: cannot drop the last value of partition
Cause: ALTER TABLE DROP VALUES tried to drop the last value of the partition
Action: Cannot execute the command, unless two or more values exist for partition
ORA-14318: DEFAULT partition must be last partition specified
Cause: A partition description follows the one describing the default partition
Action: Ensure that the DEFAULT partition is the last partition description
ORA-14319: DEFAULT cannot be specified with other values
Cause: DEFAULT keyword has been specified along with other values when specifying the values for a list partition
Action: Ensure that if DEFAULT is specified, it is the only value specified
ORA-14320: DEFAULT cannot be specified for ADD/DROP VALUES or SPLIT
Cause: DEFAULT keyword has been specified when doing a ADD VALUES or DROP VALUES or SPLIT partition or subpartition.
Action: Ensure that DEFAULT is not specified for ADD/DROP VALUES or SPLIT partition/subpartition operation.
ORA-14321: cannot add/drop values to DEFAULT partition
Cause: A ADD/DROP VALUES operation is being done on the default partition
Action: Ensure that ADD/DROP VALUES is not done on the DEFAULT partition
ORA-14322: DEFAULT partition already exists
Cause: A partition already exists with DEFAULT value
Action: none
ORA-14323: cannot add partition when DEFAULT partition exists
Cause: An ADD PARTITION operation cannot be executed when a partition with DEFAULT values exists
Action: Issue a SPLIT of the DEFAULT partition instead
ORA-14324: values being added already exist in DEFAULT partition
Cause: An ADD VALUE operation cannot be executed because the values being added exist in the DEFAULT partition
Action: Issue a SPLIT of the DEFAULT partition and then MERGE the split partition into the partition to which values need to be added
ORA-14325: only LOCAL indexes may be specified in this clause
Cause: A global index has been specified in the UPDATE INDEXES (..) clause
Action: Only specify local indexes when using this clause
ORA-14326: Primary index on an IOT, DOMAIN and LOB indexes may not be specified in the UPDATE INDEXES clause
Cause: A Primary index on an IOT, DOMAIN or LOB index has been specified in the UPDATE INDEXES (..) clause
Action: Do not specify any of these indexes when using this clause
ORA-14327: Some index [sub]partitions could not be rebuilt
Cause: The first phase (partition DDL and index [sub]partition placement) completed successfully. During the second phase, some of the index [sub]partitions could not be rebuilt.
Action: .
ORA-14329: domain index [sub]partitions cannot be renamed in this clause
Cause: The user tried to rename a domain index [sub]partition in the UPDATE INDEXES clause of a ALTER TABLE MOVE [SUB]PARTITION operation. This is not allowed.
Action: Leave the name blank or use the same name.
ORA-14400: inserted partition key does not map to any partition
Cause: An attempt was made to insert a record into, a Range or Composite Range object, with a concatenated partition key that is beyond the concatenated partition bound list of the last partition -OR- An attempt was made to insert a record into a List object with a partition key that did not match the literal values specified for any of the partitions.
Action: Do not insert the key. Or, add a partition capable of accepting the key, Or add values matching the key to a partition specification
ORA-14401: inserted partition key is outside specified partition
Cause: the concatenated partition key of an inserted record is outside the ranges of the two concatenated partition bound lists that delimit the partition named in the INSERT statement
Action: do not insert the key or insert it in another partition
ORA-14402: updating partition key column would cause a partition change
Cause: An UPDATE statement attempted to change the value of a partition key column causing migration of the row to another partition
Action: Do not attempt to update a partition key column or make sure that the new partition key is within the range containing the old partition key.
ORA-14403: cursor invalidation detected after getting DML partition lock
Cause: cursor invalidation was detected after acquiring a partition lock during an INSERT, UPDATE, DELETE statement. This error is never returned to user, because is caught in opiexe() and the DML statement is retried.
Action: nothing to be done, error should never be returned to user
ORA-14404: partitioned table contains partitions in a different tablespace
Cause: An attempt was made to drop a tablespace which contains tables whose partitions are not completely contained in this tablespace
Action: find tables with partitions which span the tablespace being dropped and some other tablespace(s). Drop these tables or move partitions to a different tablespace
ORA-14405: partitioned index contains partitions in a different tablespace
Cause: An attempt was made to drop a tablespace which contains indexes whose partitions are not completely contained in this tablespace, and which are defined on the tables which are completely contained in this tablespace.
Action: find indexes with partitions which span the tablespace being dropped and some other tablespace(s). Drop these indexes, or move the index partitions to a different tablespace, or find the tables on which the indexes are defined, and drop (or move) them.
ORA-14406: updated partition key is beyond highest legal partition key
Cause: At attempt was made to update a record with a concatenated partition key that is beyond the concatenated partition bound list of the last partition.
Action: Do not update the key. Or, add a partition capable of accepting the key.
ORA-14407: partitioned table contains subpartitions in a different tablespace
Cause: An attempt was made to drop a tablespace which contains tables whose subpartitions are not completely contained in this tablespace
Action: find tables with subpartitions which span the tablespace being dropped and some other tablespace(s). Drop these tables or move subpartitions to a different tablespace
ORA-14408: partitioned index contains subpartitions in a different tablespace
Cause: An attempt was made to drop a tablespace which contains indexes whose subpartitions are not completely contained in this tablespace, and which are defined on the tables which are completely contained in this tablespace.
Action: find indexes with subpartitions which span the tablespace being dropped and some other tablespace(s). Drop these indexes, or move the index partitions to a different tablespace, or find the tables on which the indexes are defined, and drop (or move) them.
ORA-14409: inserted partition key is outside specified subpartition
Cause: the concatenated partition key of an inserted record is outside the ranges of the two concatenated subpartition bound lists that delimit the subpartition named in the INSERT statement
Action: do not insert the key or insert it in another subpartition
ORA-14450: attempt to access a transactional temp table already in use
Cause: An attempt was made to access a transactional temporary table that has been already populated by a concurrent transaction of the same session.
Action: do not attempt to access the temporary table until the concurrent transaction has committed or aborted.
ORA-14451: unsupported feature with temporary table
Cause: An attempt was made to create an IOT, specify physical attributes, specify partition or parallel clause.
Action: do not do that.
ORA-14452: attempt to create, alter or drop an index on temporary table already in use
Cause: An attempt was made to create, alter or drop an index on temporary table which is already in use.
Action: All the sessions using the session-specific temporary table have to truncate table and all the transactions using transaction specific temporary table have to end their transactions.
ORA-14453: attempt to use a LOB of a temporary table, whose data has alreadybeen purged
Cause: An attempt was made to use LOB from a temporary table whose data has been dropped either because table was transaction-specific and transaction has commited or aborted, table was truncated or session which created this LOB has ended.
Action: This LOB locator is invalid and cannot be used.
ORA-14454: attempt to reference temporary table in a referential integrity constraint
Cause: An attempt was made to reference temporary table in a referencial integrity constraint. This is not supported.
Action: Use triggers.
ORA-14455: attempt to create referential integrity constraint on temporary table
Cause: An attempt was made to create a referential integrity constraint on a temporary table. This is not supported.
Action: Use triggers.
ORA-14456: cannot rebuild index on a temporary table
Cause: An attempt was made to rebuild an index on a temp table.
Action: The index data is anyway lost at end of session/transaction.
ORA-14457: disallowed Nested Table column in a Temporary table
Cause: An attempt made to create a Nested Table column in a temporary table. This is not supported.
Action: Do not specify these datatypes for temporary tables.
ORA-14458: attempt was made to create a temporary table with INDEX organization
Cause: An attempt was made to create an Index Organized Temporary table. This is not supported.
Action: Create the table with HEAP organization and the primary key.
ORA-14459: missing GLOBAL keyword
Cause: keyword GLOBAL is missing while creating temporary table.
Action: supply keyword.
ORA-14460: only one COMPRESS or NOCOMPRESS clause may be specified
Cause: COMPRESS was specified more than once, NOCOMPRESS was specified more than once, or both COMPRESS and NOCOMPRESS were specified.
Action: specify each desired COMPRESS or NOCOMPRESS clause option only once.
ORA-14500: LOCAL option not valid without partition name
Cause: Incorrect syntax specified
Action: Retry the command
ORA-14501: object is not partitioned
Cause: Table or index is not partitioned. Invalid syntax.
Action: Retry the command with correct syntax.
ORA-14503: only one partition name can be specified
Cause: More than one partition name has been specified for analyze
Action: Specify one partition name.
ORA-14504: syntax not supported for analyze
Cause: A partition/subpartition number or bind variable has been used
Action: Specify a valid partition/subpartition name.
ORA-14505: LOCAL option valid only for partitioned indexes
Cause: Incorrect syntax specified
Action: Retry the command
ORA-14506: LOCAL option required for partitioned indexes
Cause: Incorrect syntax specified
Action: Retry the command
ORA-14507: partition corrupt. all rows do not fall within partition bounds
Cause: The partition contains rows which should really be in some other partition. Possibly due to an exchange partition without validation
Action: Delete rows in partition which do not qualify
ORA-14508: specified VALIDATE INTO table not found
Cause: The specified table either does not exist or user does not have the proper privleges.
Action: Specify the correct table to use.
ORA-14509: specified VALIDATE INTO table form incorrect
Cause: The specified table does not have the proper field definitions.
Action: Specify the correct table to use. See utlvalid.sql for more information.
ORA-14510: can specify VALIDATE INTO clause only for partitioned tables
Cause: The VALIDATE INTO has been specified for a non partitioned table or cluster or index.
Action: Use syntax correctly
ORA-14511: cannot perform operation on a partitioned object
Cause: An attempt was made to perform an operation that is not allowed on partitioned tables or indexes.
Action: Retry the command with correct syntax.
ORA-14512: cannot perform operation on a clustered object
Cause: An attempt was made to perform an operation that is not allowed on clustered tables or indexes.
Action: Retry the command with correct syntax.
ORA-14513: partitioning column may not be of object datatype
Cause: Partitioning column specified by the user was an object datatype (object, REF, nested table, array) which is illegal.
Action: Ensure that no partitioning column is an object datatype.
ORA-14514: LOCAL option not valid without subpartition name
Cause: Incorrect syntax specified
Action: Retry the command
ORA-14515: only one aubpartition name can be specified
Cause: More than one subpartition name has been specified for analyze
Action: Specify one subpartition name.
ORA-14516: subpartition corrupt. all rows do not fall within subpartition bounds
Cause: The subpartition contains rows which should really be in some other subpartition. Possibly due to an exchange subpartition without validation
Action: Delete rows in subpartition which do not qualify
ORA-14517: subpartition of index 'string.string' is in unusable state
Cause: An attempt has been made to access an index subpartition that has been marked unusable by a direct load or by a DDL operation
Action: REBUILD the unusable index subpartition
ORA-14518: partition contains rows corresponding to values being dropped
Cause: table partition contains rows for the values being dropped.
Action: DELETE all rows for the values being dropped and reissue statement
ORA-14519: Conflicting tablespace blocksizes for string string: Tablespace string block size string [string] conflicts with previously specified/implied tablespace string block size string [string]
Cause: An attempt has been made to create a partitioned object in a manner that would require the partitioned object to span tablespaces of more than one block size.
Action: Ensure that all tablespaces specified in the DDL command for the given object as well as any tablespaces implicitly assigned to partitions or subpartitions of the object being created are all of the same block size.
ORA-14520: Tablespace string block size [string] does not match existing object block size [string]
Cause: A DDL statement was issued that would require a tablespace of a block size different from the block size of the specified partitioned object to be assigned either: (1) As the object's default tablespace (or one of the object's partition-level default tablespaces, if composite partitioning is being used) OR (2) To one of the object's partitions/subpartitions.
Action: Specify a tablespace of the same block size as the partitioned object.
ORA-14521: Default tablespace string block size [string] for string string does not match existing string block size [string]
Cause: A DDL statement was issued that would require creation of a new partition/subpartition in the object-level default tablespace of an existing partitioned object. However, the object-level default tablespace block size does not match the block size of the partitioned object.
Action: Either (1) Modify the default tablespace of the partitioned object to a tablespace of the same block size as the object and then retry the DDL command, OR (2) Ensure that tablespaces of the correct block size are specified for all new partitions/subpartitions being created.
ORA-14522: Partition-level default tablespace string block size [string] for string string does not match existing string block size [string]
Cause: A DDL statement was issued that would require creation of a new subpartition in one of the partition-level default tablespaces of an existing composite partitioned object. However, the partition-level default tablespace block size does not match the block size of the partitioned object.
Action: Either (1) Modify the partition-level default tablespace of the appropriate partition of the partitioned object to a tablespace of the same block size as the object and then retry the DDL command, OR (2) Ensure that tablespaces of the correct block size are specified for all new subpartitions being created.
ORA-14523: Cannot co-locate [sub]partition of string string with table [sub]partition because string block size [string] does not match table block size [string]
Cause: A DDL statement was issued that would require a partition/subpartition of a local index/LOB column to be co-located with the corresponding partition/subpartition of the base table. However, this is not possible because the block sizes of the table and the LOB column/local index are different.
Action: Either (1) Specify an object-level default tablespace (or partition-level default tablespace for the appropriate partition, if composite partitioning is used) for the partitioned local index/LOB column and then retry the DDL command, OR (2) Ensure that tablespaces of the correct block size are specified for all new partitions/subpartitions being created. Also ensure that neither of TABLESPACE DEFAULT and STORE IN (DEFAULT) is specified for a local index whose block size does not match that of the base table.
ORA-14551: cannot perform a DML operation inside a query
Cause: DML operation like insert, update, delete or select-for-update cannot be performed inside a query or under a PDML slave.
Action: Ensure that the offending DML operation is not performed or use an autonomous transaction to perform the DML operation within the query or PDML slave.
ORA-14552: cannot perform a DDL, commit or rollback inside a query or DML
Cause: DDL operations like creation tables, views etc. and transaction control statements such as commit/rollback cannot be performed inside a query or a DML statement.
Action: Ensure that the offending operation is not performed or use autonomous transactions to perform the operation within the query/DML operation.
ORA-14553: cannot perform a lob write operation inside a query
Cause: A lob write operation cannot be performed inside a query or a PDML slave.
Action: Ensure that the offending lob write operation is not performed or use an autonomous transaction to perform the operation within the query or PDML slave.
ORA-14601: Illegal to specify SUBPARTITIONS or STORE-IN while specifying a subpartition template
Cause: Cannot specify these clauses while specifying a template
Action: Correct the subpartition template clause.
ORA-14602: SUBPARTITION TEMPLATE is legal only for a composite partitioned table
Cause: SUBPARTITION TEMPLATE can be specified only for composite partitioned tables
Action: Do not use SUBPARTITION TEMPLATE on non-partitioned or non-composite partitioned tables.
ORA-14603: [SUBPARTITIONS | SUBPARTITION TEMPLATE] subpartition_count syntax is valid only for range-hash tables
Cause: This syntax is valid only if subpartitioning dimension is hash
Action: none
ORA-14604: During CREATE TABLE time it is illegal to specify SUBPARTITIONS or STORE IN once a SUBPARTITION TEMPLATE has been specified
Cause: Once a subpartition template has been specified during a CREATE TABLE it is illegal to specify SUBPARTITIONS or STORE IN anywhere else
Action: Remove either the SUBPARTITIONS | STORE IN or remove the SUBPARTITION TEMPLATE clause
ORA-14605: Name missing for subpartition / lob segment in template
Cause: A subpartition / lob segment was not specified a name in the template descriptions
Action: All subpartitions / lob segments must have names specified in the template
ORA-14606: Tablespace was specified for previous subpartitions in template but is not specified for string
Cause: Tablespaces may either be specified for all subpartitions or must not be specified for any subpartitions
Action: Either specify tablespaces for all or for none of the subpartitions
ORA-14607: Tablespace was not specified for previous subpartitions in template but is specified for string
Cause: Tablespaces may either be specified for all subpartitions or must not be specified for any subpartitions
Action: Either specify tablespaces for all or for none of the subpartitions
ORA-14608: Tablespace was specified for the previous lob segments of column string in template but is not specified for string
Cause: Tablespaces may either be specified for all lob segments of a column or must not be specified for any lob segments of this column
Action: Either specify tablespaces for all or for none of the lob segments
ORA-14609: Tablespace was not specified for the previous lob segments of column string in template but is specified for string
Cause: Tablespaces may either be specified for all lob segments of a column or must not be specified for any lob segments of this column
Action: Either specify tablespaces for all or for none of the lob segments
ORA-14610: Lob attributes not specified for lob column string for subpartition string
Cause: Lob attributes of a column must be specified for all subpartitions or must not be specified at all
Action: Ensure lob attributes of a column are specified for all subpartitions or not specified at all
ORA-14611: Duplicate subpartition name string in template
Cause: A subpartition name cannot be duplicated within the template
Action: Rename one of the subpartitions.
ORA-14612: Duplicate lob segment name string for lob column string in template
Cause: Two lob segments of the same column were given the same name in the template
Action: Rename one of the lob segments
ORA-14613: Attempt to generate name from parent name string and template name string failed as the combine named would have been longer than allowed
Cause: Any name generated from a partition name and template name must be less than the maximum permissible name for an identifier
Action: Shorten either partition or template name.
ORA-14614: List value 'string' specified twice in subpartition 'string'
Cause: A list value cannot be specified more that once
Action: Remove one of the specifications of the value
ORA-14615: List value 'string' specified twice in subpartitions 'string', 'string'
Cause: A list value cannot be specified more that once
Action: Remove one of the specifications of the value
ORA-14616: table is not subpartitioned by List method
Cause: A subpartition maintenance operation such as ALTER TABLE MODIFY SUBPARTITION ADD|DROP VALUES or ALTER TABLE DROP|SPLIT|MERGE SUBPARTITION can only be performed on List subpartitioned objects
Action: Re-issue the command against a List subpartitoned object.
ORA-14617: cannot add/drop values to DEFAULT subpartition
Cause: A ADD/DROP VALUES operation is being done on the default subpartition
Action: Ensure that ADD/DROP VALUES is not done on the DEFAULT subpartition
ORA-14618: cannot drop the last value of subpartition
Cause: ALTER TABLE DROP VALUES tried to drop the last value of the subpartition
Action: Cannot execute the command, unless two or more values exist for subpartition
ORA-14619: resulting List subpartition(s) must contain at least 1 value
Cause: After a SPLIT/DROP VALUE of a list subpartition, each resulting subpartition(as applicable) must contain at least 1 value
Action: Ensure that each of the resulting subpartitions contains atleast 1 value
ORA-14620: DEFAULT subpartition already exists
Cause: A subpartition already exists with DEFAULT value
Action: Remove the DEFAULT value from the list specified
ORA-14621: cannot add subpartition when DEFAULT subpartition exists
Cause: An ADD SUBPARTITION operation cannot be executed when a subpartition with DEFAULT values exists
Action: Issue a SPLIT of the DEFAULT subpartition instead
ORA-14622: Value string already exists in subpartition string
Cause: One of the list values in the ADD SUBPARTITION or ADD VALUES statement already exists in another subpartition
Action: Remove the duplicate value from the statement and try again
ORA-14623: Value string does not exist in subpartition string
Cause: One of the list values in the SPLIT PARTITION or DROP VALUES statement does not exist in the subpartition
Action: Remove the value from the statement and try again
ORA-14624: DEFAULT subpartition must be last subpartition specified
Cause: A subpartition description follows the one describing the default subpartition
Action: Ensure that the DEFAULT subpartition is the last subpartition description
ORA-14625: subpartition contains rows corresponding to values being dropped
Cause: table subpartition contains rows for the values being dropped.
Action: DELETE all rows for the values being dropped and reissue statement
ORA-14626: values being added already exist in DEFAULT subpartition
Cause: An ADD VALUE operation cannot be executed because the values being added exist in the DEFAULT subpartition
Action: Issue a SPLIT of the DEFAULT subpartition and then MERGE the split subpartition into the subpartition to which values need to be added
ORA-14627: Invalid operation was specified on a GLOBAL partitioned index
Cause: An invalid operation such as ALTER INDEX DROP|SPLIT SUBPARTITION was specified on the global index
Action: Ensure that subpartition level operations are not specified on a GLOBAL index, since these are only RANGE partitioned
ORA-14628: specification of bounds is inconsistent with LIST method
Cause: An operation such as ALTER TABLE SPLIT|ADD SUBPARTITION specified bounds that were inconsistent with List subpartitioning method
Action: Specify VALUES/subpartition descriptions correctly for SPLIT/ADD of List subpartitions
ORA-14629: cannot drop the only subpartition of a partition
Cause: A drop subpartition command is being executed when there is only one subpartition in the partition
Action: none
ORA-14630: subpartition resides in offlined tablespace
Cause: User attempted an operation requiring that we access data in a subpartition which resides in a tablespace which was taken offline. Such operations include trying to drop a tablespace of a table which has indices defined on it or is referenced by a constraint.
Action: Bring tablespace online before attempting the operation.
ORA-14631: the partition bounds do not match the subpartition bounds of the partition
Cause: When exchanging a partitioned table with a composite partition the bounds that describe the partitions of the table must match the bounds that describe the subpartitions of the composite partition.
Action: Ensure that the bounds describing partitions in the partitioned table is the same as the bounds of the subpartitions in the the composite partition.
ORA-14632: cannot specify PARALLEL clause when adding a List subpartition
Cause: User issued ALTER TABLE ADD SUBPARTITION statement with PARALLEL clause for a List subpartition of a Range/List partitioned object which is illegal
Action: Remove the PARALLEL clause.
ORA-14633: Index maintainence clause not allowed for ADD list subpartition to a Composite partitioned table
Cause: The clause INVALIDATE or UPDATE GLOBAL INDEXES is allowed only for ADD hash subpartition to a composite partitioned table.
Action: Remove clause and reissue operation
ORA-14634: Subpartition descriptions cannot be specified during the SPLIT/MERGE of a partition of a Range-List partitioned table
Cause: During a split or a merge of a partition of a range list partitioned table you cannot specify any subpartitioning information for the resulting partition (s)
Action: Remove all subpartitioning information from the DDL.
ORA-14635: only one resulting subpartition can be specified for MERGE SUBPARTITIONS
Cause: ALTER TABLE MERGE SUBPARTITIONS contained more than one resulting subpartition for the MERGE
Action: Ensure that the statement describes exactly one subpartition as the target that need to be MERGEd
ORA-14636: only 2 resulting subpartition can be specified for SPLIT SUBPARTITION
Cause: ALTER TABLE SPLIT SUBPARTITION contained more than 2 resulting subpartition for the SPLIT
Action: Ensure that the statement describes exactly 2 subpartitions as the target of the SPLIT operation
ORA-14637: cannot merge a subpartition with itself
Cause: The same subpartition name was specified twice for the merge operation
Action: Re-submit operation with 2 distinct subpartition names within the same composite partition
ORA-14638: cannot MERGE subpartitions in different Range Composite partitions
Cause: Attempted to MERGE subpartitions in different Range Composite partitions
Action: Reissue the command after ensuring that the 2 subpartitions being merged lie in the same composite partition
ORA-14639: SUBPARTITIONS clause can be specfied only for Hash, Composite Range Hash table/partition
Cause: Attempted to specify SUBPARTITIONS clause on table that is not partitioned by the Composite Range-Hash method
Action: Reissue the command after ensuring that the SUBPARTITIONS clause is not specified, to specify a template for a Composite Range List object use the SUBPARTITION TEMPLATE clause
ORA-14640: add/coalesce index partition operation is valid only for hash partitioned global indexes
Cause: User attempted to add or coalesce an index partition of a global index not partitioned by hash method.
Action: Issue the statement on a global index partitioned by hash method. or if the index is partitioned by range method consider using split/drop instead of add/coalesce.
ORA-14641: STORE-IN clause can be specified only for a Hash, Composite Range Hash table/partition
Cause: Specifying a STORE-IN clause during CREATE/ALTER of a Range, Composite Range List partitioned table which is not allowed"
Action: Re-issue the stament after removing the STORE-IN clause
ORA-14642: Bitmap index mismatch for tables in ALTER TABLE EXCHANGE PARTITION
Cause: The two tables in the EXCHANGE have usable bitmap indexes, and the INCLUDING INDEXES option has been specified and the tables have different hakan factors.
Action: Perform the exchange with the EXCLUDING INDEXES option or alter the bitmap indexes to be unusable.
ORA-14643: Hakan factor mismatch for tables in ALTER TABLE EXCHANGE PARTITION
Cause: Either records_per_block has been minimized for one of the tables to be exchanged, but not the other, or the hakan factors for the tables to be exchanged are not equal.
Action: If records_per_block has been minimized for one of the tables, but not the other, either perform alter table with the NOMINIMIZE RECORDS_PER_BLOCK option for both tables, or perform alter table with the MINIMIZE RECORDS_PER_BLOCK for both tables. If the hakan factors do not match perform alter table with the NOMINIMIZE RECORDS_PER_BLOCK option for both tables.
ORA-14644: table is not subpartitioned by Hash method
Cause: A subpartition maintenance operation such as ALTER TABLE MODIFY PARTITION COALESCE SUBPARTITION can only be performed on Hash subpartitioned objects
Action: Re-issue the command against a Hash subpartitoned object.
ORA-14645: STORE IN clause cannot be specified for Range List objects
Cause: A STORE IN clause was specified for Range List partitioned object
Action: Re-issue the command after removng the STORE IN clause
ORA-14646: Specified alter table operation involving compression cannot be performed in the presence of usable bitmap indexes
Cause: The first time a table is altered to include compression, it cannot have a usable bitmap index (partition). Subsequent alter table statements involving compression do not have this same restriction.
Action: A) Drop any bitmap indexes defined on the table, and re-create them once the operation is complete or, B) Mark all index fragments of all bitmap indexes defined on the table UNUSABLE and rebuild them once the operation is complete.
ORA-15000: command disallowed by current instance type
Cause: The user has issued a command to a conventional RDBMS instance that is only appropriate for an ASM instance. Alternatively, the user has issued a command to an ASM instance that is only appropriate for an RDBMS instance.
Action: Connect to the correct instance type and re-issue the command.
ORA-15001: diskgroup "string" does not exist or is not mounted
Cause: An operation failed because the diskgroup specified does not exist or is not mounted by the current ASM instance.
Action: Verify that the diskgroup name used is valid, that the diskgroup exists, and that the diskgroup is mounted by the current ASM instance.
ORA-15002: parameter LOCK_NAME_SPACE exceeds limit of string characters
Cause: The LOCK_NAME_SPACE initialization parameter contained a value that is too long.
Action: Correct the LOCK_NAME_SPACE initialization parameter.
ORA-15003: diskgroup "string" already mounted in another lock name space
Cause: The diskgroup could not be mounted by the ASM instance because it was operating in a lockspace different than another existing
Action: Check the LOCK_NAME_SPACE initialization parameter value, or dismount the diskgroup from the other ASM instances.
ORA-15004: alias "string" does not exist
Cause: The specified alias did not exist within the diskgroup.
Action: Check the alias name and diskgroup name.
ORA-15005: name "string" is already used by an existing alias
Cause: An existing alias in the diskgroup used the same name.
Action: Select another alias name, or drop the existing alias.
ORA-15006: template "string" does not exist
Cause: The specified template did not exist within the diskgroup.
Action: Check the template name and diskgroup name.
ORA-15007: name is already used by an existing template
Cause: A template with the same name already exists.
Action: Select another template name, or drop the existing template.
ORA-15008: cannot drop system template
Cause: The specified template was created by the system and must always exist for proper operation.
Action: Select another template name.
ORA-15009: ASM disk "string" does not exist
Cause: The specified ASM disk was not found.
Action: Check the ASM disk name.
ORA-15010: name is already used by an existing ASM disk
Cause: The specified name was already used in this diskgroup.
Action: Specify a different ASM disk name.
ORA-15011: failure group "string" contains no members
Cause: The specified name did not match the failure group of any disks in the diskgroup. This usually indicates that the failure group name was specified incorrectly.
Action: Check the failure group name.
ORA-15012: ASM file 'string' does not exist
Cause: The ASM file was not found.
Action: Check the ASM file name.
ORA-15013: diskgroup "string" is already mounted
Cause: An ALTER DISKGROUP MOUNT command specified the name of a diskgroup which is already mounted by the current ASM instance.
Action: Check the name of the diskgroup.
ORA-15014: location 'string' is not in the discovery set
Cause: The operating system path specified was outside the set of disks that are discovered by the instance.
Action: Specify a operating system path within the set of disks that are discovered based upon the ASM_DISKSTRING parameter. Alternatively, check the setting of the ASM_DISKSTRING parameter.
ORA-15015: invalid _ASM_LIBRARIES initialization parameter 'string'
Cause: The _ASM_LIBRARIES initialization parameter contained a bad value.
Action: Correct the _ASM_LIBRARIES initialization parameter.
ORA-15016: invalid ASM_DISKGROUPS initialization parameter "string"
Cause: The ASM_DISKGROUPS initialization parameter contained a bad value.
Action: Correct the ASM_DISKGROUPS initialization parameter.
ORA-15017: diskgroup "string" cannot be mounted
Cause: The specified diskgroup could not be mounted.
Action: Check for additional errors reported.
ORA-15018: diskgroup cannot be created
Cause: The specified diskgroup could not be created.
Action: Check for additional errors reported.
ORA-15019: discovered duplicate path 'string' for 'string'
Cause: The discovery encountered multiple paths to the same disk.
Action: Check that the ASM_DISKSTRING parameter specifies only a single path for each disk.
ORA-15020: discovered duplicate ASM disk "string"
Cause: The discovery encountered two disks claiming to be the same named ASM disk.
Action: Check that the ASM_DISKSTRING parameter specifies only a single path for each disk.
ORA-15021: parameter "string" is not valid in string instance
Cause: The specified parameter was not supported when starting an instance of this type.
Action: Delete the specified parameter from the INIT.ORA file.
ORA-15022: parameter length 'string' is longer than string
Cause: The specified parameter was too long.
Action: Contact Oracle Support Services.
ORA-15023: reached maximum allowable number of disks string
Cause: An attempt was made to add another disk to a diskgroup which already contains the maximum number of disks allowed.
Action: Consider dropping existing disks from the diskgroup before adding additional ones, or create a new diskgroup.
ORA-15024: discovered duplicately numbered ASM disk string
Cause: The discovery encountered two disks claiming to have the same ASM disk number.
Action: Check that the ASM_DISKSTRING parameter specifies only a single path for each disk.
ORA-15025: could not open disk 'string'
Cause: The specified disk could not be opened.
Action: Check the additional error messages, if any.
ORA-15026: disk 'string' is not an ASM disk
Cause: The disk did not contain a valid ASM disk header.
Action: Check to see if the data on the disk has been changed by some system administrator action.
ORA-15027: open files in diskgroup "string" preclude its dismount
Cause: An ALTER DISKGROUP ... DISMOUNT command specified a diskgroup which had database instance clients with open files in the diskgroup. Diskgroups cannot be dismounted until all open files in the diskgroup are closed by the database instance clients.
Action: Stop all clients that are using this diskgroup and retry the ALTER DISKGROUP ... DISMOUNT command.
ORA-15028: ASM file 'string' not dropped; currently being accessed
Cause: An attempt was made to drop an ASM file, but the file was being accessed by one or more database instances and therefore could not be dropped.
Action: Shut down all database instances that might be accessing this file and then retry the drop command.
ORA-15029: disk 'string' is already mounted by this instance
Cause: An attempt was made to add to a diskgroup a disk that was already mounted by the current instance as part of some (possibly other) diskgroup.
Action: Specify a different disk in the command. Note that not even the FORCE option can be used to correct the situation until the diskgroup containing the disk becomes dismounted by this instance.
ORA-15030: diskgroup name "string" is in use by another diskgroup
Cause: A CREATE DISKGROUP command specfied a diskgroup name that was already assigned to another diskgroup.
Action: Select a different name for the diskgroup.
ORA-15031: disk specification 'string' matches no disks
Cause: The device specification string to a CREATE DISKGROUP command did not match any devices which could be discovered.
Action: Check the device specification string matches a disk on the system.
ORA-15032: not all alterations performed
Cause: At least one ALTER DISKGROUP action failed.
Action: Check the other messages issued along with this summary error.
ORA-15033: disk 'string' belongs to diskgroup "string"
Cause: An attempt was made to ADD to a diskgroup a disk that was already part of another diskgroup, or an attempt was made to DROP / OFFLINE / ONLINE / CHECK a disk that was not part of the specified diskgroup.
Action: For ADD, check the path specifier for the disk. If it is certain that the disk is not in use by another diskgroup, the FORCE option may be used to override this check. For the other commands, check the name of the specified disk.
ORA-15034: disk 'string' does not require the FORCE option
Cause: An attempt was made to add the disk to the diskgroup using the FORCE option. The disk was not found to be in use at the present time, so the FORCE option was not permitted.
Action: Avoid gratuitous use of the FORCE option.
ORA-15035: no disks belong to diskgroup "string"
Cause: An attempt was made to mount a diskgroup for which no member disks were discovered.
Action: Specify a valid diskgroup name that contains disks.
ORA-15036: disk 'string' is truncated
Cause: The size of the disk, as reported by the operating system, was smaller than the size of the disk as recorded in the disk header block on the disk.
Action: Check if the system configuration has changed.
ORA-15037: disk 'string' is smaller than mimimum of string MBs
Cause: The size of the disk, as reported by the operating system, was too small to allow the disk to become part of the diskgroup.
Action: Check if the system configuration is correct.
ORA-15038: disk 'string' size mismatch with diskgroup [string] [string] [string]
Cause: An attempt was made to mount into a diskgroup a disk whose recorded allocation unit size, metadata block size, or physical sector size was inconsistent with the other diskgroup members.
Action: Check if the system configuration has changed.
ORA-15039: diskgroup not dropped
Cause: An attempt to drop a diskgroup failed.
Action: See the associated messages for details about why the drop was not successful.
ORA-15040: diskgroup is incomplete
Cause: Some of the disks comprising a diskgroup were not present.
Action: Check the hardware to ensure that all disks are functional. Also check that the setting of the ASM_DISKSTRING initialization parameter has not changed.
ORA-15041: diskgroup space exhausted
Cause: The diskgroup ran out of space.
Action: Add more disks to the diskgroup, or delete some existing files.
ORA-15042: ASM disk "string" is missing
Cause: The specified disk, which is a necessary part of a diskgroup, could not be found on the system.
Action: Check the hardware configuration.
ORA-15043: ASM disk "string" is not a diskgroup member
Cause: The specified disk has been removed from the diskgroup, but a disk matching its name was found.
Action: Check the hardware configuration.
ORA-15044: ASM disk 'string' is incorrectly named
Cause: Either the specified disk had its contents changed such that it no longer contained an ASM disk name in its header that matches the diskgroup information or its FAILGROUP information may have become inconsistent.
Action: Drop the disk from the diskgroup.
ORA-15045: ASM file name 'string' is not in reference form
Cause: The ASM file name was not in a form that can be used to reference an existing file because a file/incarnation number or an alias name was not present or a template name was included.
Action: Correct the specified ASM file name.
ORA-15046: ASM file name 'string' is not in single-file creation form
Cause: The ASM file name was not in a form that can be used to create an single file because a file/incarnation number was present.
Action: Correct the specified ASM file name.
ORA-15047: ASM file name 'string' is not in multiple-file creation form
Cause: The ASM file name was not in a form that can be used to create multiple files because either a fully-qualified file name or an alias name was present.
Action: Correct the specified ASM file name.
ORA-15048: ASM internal files cannot be deleted
Cause: An attempt was made to delete a metadata file used by ASM to manage the diskgroup.
Action: Check the specified ASM file name.
ORA-15049: diskgroup "string" contains string error(s)
Cause: Errors were discovered by the ALTER DISKGROUP CHECK command.
Action: See the alert log for details of the errors.
ORA-15050: disk "string" contains string error(s)
Cause: Errors were discovered by the ALTER DISKGROUP CHECK DISK command.
Action: See the alert log for details of the errors.
ORA-15051: file 'string' contains string error(s)
Cause: Errors were discovered by the ALTER DISKGROUP CHECK FILE command.
Action: See the alert log for details of the errors.
ORA-15052: ASM file name 'string' is not in diskgroup "string"
Cause: The ASM file name did not contain a diskgroup name that specified the correct diskgroup as implied by the other arguments to the command.
Action: Correct the specified ASM file name or diskgroup name.
ORA-15053: diskgroup "string" contains existing files
Cause: An attempt was made to drop a diskgroup that still contains existing files.
Action: Specify the INCLUDING CONTENTS option to drop the diskgroup and all of its existing files.
ORA-15054: disk "string" does not belong to diskgroup "string"
Cause: An attempt was made to DROP (or CHECK) from diskgroup a disk which existed, but was part of a different diskgroup than the one specified in the command.
Action: Check the name of the specified disk and the specified diskgroup.
ORA-15055: unable to connect to ASM instance
Cause: When accessing a diskgroup for the first time, the database was unable to connect to the required ASM instance.
Action: Check the additional error messages. May need to configure correct ASM sid or make sure the database instance has OS privileges for ASM SYSDBA.
ORA-15056: additional error message
Cause: An operating system error occured.
Action: Correct the operating system error and retry the operation.
ORA-15057: specified size of string MB is larger than actual size of string MB
Cause: A disk size expression exceeded the amount of storage actually availalable, as reported by the operating system.
Action: Specify a valid size.
ORA-15058: disk 'string' belongs to an incompatible diskgroup
Cause: An attempt was made to ADD to a diskgroup a disk which was already part of another diskgroup. The other diskgroup was written by a more recent software release.
Action: Check the path specifier for the disk. If it is certain that the disk is not in use by another diskgroup, the FORCE option may be used to override this check.
ORA-15059: invalid device type for ASM disk
Cause: The device type of the discovered disk was not valid for use as an ASM disk.
Action: Check the file path and retry or exclude it from the discovery set. See the accompanying operating system error for additional information.
ORA-15060: template "string" does not exist
Cause: A command specified a template name, either directly or as part of an ASM file name, which did not exist.
Action: Check the template specifier in the command.
ORA-15062: ASM disk is globally closed
Cause: The disk to which the I/O request was issued has gone offline or has been globally closed by the background process. Check other messages in the trace files for more information.
Action: Bring the disk online for I/Os to get through.
ORA-15063: diskgroup "string" lacks quorum of string PST disks; string found
Cause: ASM did not find a sufficient number of disks belonging to the diskgroup to continue the operation.
Action: Check that the disks are present and functioning, and that the ASM_DISKSTRING initialization parameter has been set correctly.
ORA-15064: communication failure with ASM instance
Cause: There was a failure to communicate with the ASM instance, most likely because the connection went down.
Action: Check the accompanying error messages for more information on the reason for the failure. Note that database instances will always return this error when the ASM instance is terminated abnormally.
ORA-15065: hash collision for diskgroup names 'string' and 'string'
Cause: There was a collision in the group name used for the diskgroup. The diskgroup(s) cannot be mounted using colliding names.
Action: Use a different diskgroup name and also report to oracle support the two diskgroup names which collided.
ORA-15066: offlining disk "string" may result in a data loss
Cause: Following I/O failures, the disks holding all copies of a data block were attempted to be taken offline.
Action: Check the accompanying error messages for more information on the reason for the disk I/O failures.
ORA-15067: command or option incompatible with diskgroup redundancy
Cause: An attempt was made to use a feature which is not permitted by the diskgroup's redundancy policy. Common examples are forcibly dropping a disk from an EXTERNAL REDUNDANCY diskgroup, using the FAILGROUP clauses with an EXTERNAL REDUNDANCY diskgroup, or using invalid template attributes.
Action: Omit the option from the command.
ORA-15068: maximum number of diskgroups string already mounted
Cause: An attempt was made to mount more diskgroups than the instance is capable of mounting at one time.
Action: Dismount a mounted diskgroup and retry the command.
ORA-15069: ASM file 'string' not accessible; timed out waiting for lock
Cause: An attempt was made to access an ASM file, but the file is currently being created, resized, or deleted and therefore cannot be accessed.
Action: No action required, or try again later, after the create or resize has completed.
ORA-15070: maximum number of files string exceeded in diskgroup "string"
Cause: The diskgroup ran out of space.
Action: Delete some existing ASM files or create files in a new diskgroup.
ORA-15071: ASM disk "string" is already being dropped
Cause: An attempt was made to drop a disk from a diskgroup which was already in the process of being dropped from the diskgroup. Alternatively, an attempt was made to forcibly drop a disk from a diskgroup using the FORCE option which was already being forcibly dropped from the diskgroup.
Action: Check the ASM disk name and FORCE option as specified in the command.
ORA-15072: command requires at least string failure groups, specified only string
Cause: An attempt was made to create either normal or high redundancy diskgroup with fewer than two or three failure groups.
Action: Specify more failure groups in the command.
ORA-15073: diskgroup string is mounted by another ASM instance
Cause: An attempt was made to drop a diskgroup that is still mounted somewhere in the cluster by another instance.
Action: dismount the diskgroup from all nodes except the one performing the drop diskgroup command.
ORA-15074: diskgroup string requires rebalance completion
Cause: An attempt was made to repeatedly add or drop disks from a diskgroup. ASM could not perform the operation given the current state of the diskgroup.
Action: Manually invoke the ALTER DISKGROUP REBALANCE command and allow the rebalance to run to completion. Alternatively, invoke the ALTER DISKGROUP UNDROP DISKS command and allow the rebalance to run to completion. After the rebalance has completed, retry the operation.
ORA-15075: disk(s) are not visible cluster-wide
Cause: An ALTER DISKGROUP ADD DISK command specified a disk that could not be discovered by one or more nodes in a RAC cluster configuration.
Action: Determine which disks are causing the problem from the GV$OSM_DISK fixed view. Check operating system permissions for the device and the storage sub-system configuration on each node in a RAC cluster that cannot identify the disk.
ORA-15076: Emulating I/O errors on the OSM disk
Cause: The disk to which the I/O request was issued is in an error emulation mode.
Action: Bring the disk online for I/Os to get through.
ORA-15090: handle string is not a valid descriptor
Cause: The file handle was not valid in this session.
Action: Submit a handle obtained from a successful call to DBMS_DISKGROUP.OPEN().
ORA-15091: operation incompatible with open handle in this session
Cause: The current session contained an open handle from the DBMS_DISKGROUP PL/SQL package which precluded performing the command.
Action: Close the hanlde with DBMS_DISKGROUP.CLOSE() before executing the command, or execute the command in a different session.
ORA-15092: I/O request size string is not a multiple of logical block size string
Cause: The length of the request was not a multiple of logical block size.
Action: Correct the error and retry the operation.
ORA-15093: buffer only contains string bytes, I/O requested is string bytes
Cause: The buffer supplied for write was too small to satisfy the request.
Action: Correct the error and retry the operation.
ORA-15094: attempted to write to file opened in read only mode
Cause: The file handle passed to DBMS_DISKGROUP.WRITE() did not have write privileges.
Action: Obtain a file handle in read-write mode and retry the write operation.
ORA-15095: reached maximum ASM file size (string GB)
Cause: An ASM file creation or file resize operation exceeded the maximum file size permitted by ASM.
Action: Use smaller files.
ORA-15100: invalid or missing diskgroup name
Cause: The command did not specify a valid diskgroup name.
Action: Specify a valid diskgroup name.
ORA-15101: no action specified
Cause: The ALTER DISKGROUP command did not specify any alterations.
Action: Specify at least one operation clause.
ORA-15102: invalid POWER expression
Cause: The syntax of the POWER expression was invalid.
Action: Specify a valid POWER expression.
ORA-15103: conflicting or duplicate REPAIR options
Cause: The command specified conflicting or duplicate REPAIR keywords.
Action: Specify only one REPAIR action.
ORA-15104: conflicting CONTENTS options
Cause: The command specified conflicting or duplicate INCLUDING CONTENTS or EXCLUDING CONTENTS options.
Action: Specify only one option.
ORA-15105: missing or invalid FAILGROUP name
Cause: The command did not specify a valid failure group name.
Action: Specify a valid failure group name.
ORA-15106: missing or invalid operating system disk locator string
Cause: The command did not specify a valid operating system path for the device as a string.
Action: Specify a valid operating system path for the device.
ORA-15107: missing or invalid ASM disk name
Cause: The command did not specify a valid ASM disk name identifier.
Action: Specify a valid ASM disk name identifier.
ORA-15108: missing or invalid template name
Cause: The command did not specify a valid template name identifier.
Action: Specify a valid template name identifier.
ORA-15109: conflicting protection attributes specified
Cause: The command contained an invalid combination of the UNPROTECTED, MIRROR, or PARITY keywords.
Action: Specify only one keyword.
ORA-15110: no diskgroups mounted
Cause: No diskgroups were specified in the ASM_DISKGROUPS parameter, so instance startup or the ALTER DISKGROUP ALL MOUNT command did not mount any diskgroups.
Action: Specify valid diskgroups in the ASM_DISKGROUPS parameter or ignore the error.
ORA-15111: conflicting or duplicate STRIPE options
Cause: The command contained both a FINE and COARSE keyword, or contained the FINE keyword more than once, or contained the COARSE keyword more than once.
Action: Specify only one keyword.
ORA-15112: No diskgroups are currently mounted.
Cause: An ALTER DISKGROUP ALL command did not find any mounted diskgroups upon which to operate. Either instance shutdown or an ALTER DISKGROUP ALL DISMOUNT command did not dismount any diskgroups, or an ALTER DISKGROUP ALL UNDROP DISKS command did not undrop any disks.
Action: Mount the diskgroups on which you wish to operate or ignore the error.
ORA-15113: alias name 'string' refers to a directory
Cause: The name specified referred to a directory in the alias directory and not a valid alias entry.
Action: Check the alias name and retry.
ORA-15114: missing or invalid ASM file name
Cause: The command did not specify a valid ASM file name identifier.
Action: Specify a valid ASM file name identifier.
ORA-15115: missing or invalid ASM disk size specifier
Cause: The command did not specify a valid ASM disk size.
Action: Specify a valid ASM disk size.
ORA-15116: invalid combination of ALTER DISKGROUP options
Cause: The ALTER DISKGROUP options may not be combined in this manner.
Action: Issue separate ALTER DISKGROUP commands to accomplish the desired action.
ORA-15117: command only operates on one diskgroup
Cause: An ALTER DISKGROUP, CREATE DISKGROUP, or DROP DISKGROUP command specified a list of diskgroups or the keyword ALL in a context where only a single diskgroup was permitted.
Action: Issue separate ALTER DISKGROUP, CREATE DISKGROUP, or DROP DISKGROUP commands to accomplish the desired action.
ORA-15120: ASM file name 'string' does not begin with the ASM prefix character
Cause: A file name was specified to ASM which did not begin with the ASM prefix character (currently '+'). ASM uses the prefix to determine that a file specification is in fact an ASM file.
Action: Correct the file name specification.
ORA-15121: ASM file name 'string' contains an invalid diskgroup name
Cause: A file name was specified that did not contain a valid diskgroup name. The diskgroup name follows immediately after the ASM prefix character. It must start with an alphabetic character, and consist of up to 30 characters which are alphabetic, numeric, or the characters '$' and '_'.
Action: Correct the file name specification.
ORA-15122: ASM file name 'string' contains an invalid file number
Cause: A numeric file name was specified which did not contain a valid ASM file number. The ASM file number follows immediately after the diskgroup name. It must be preceeded by a '.' character, and contain only numeric characters.
Action: Correct the file name specification.
ORA-15123: ASM file name 'string' contains an invalid incarnation number
Cause: A numeric file name was specified which did not contain a valid ASM incarnation number. The ASM incarnation number follows immediately after the ASM file number. It must be preceeded by a '.' character, and contain only numeric characters.
Action: Correct the file name specification.
ORA-15124: ASM file name 'string' contains an invalid alias name
Cause: A file name was specified which did not contain a valid ASM alias name. The ASM alias name, if present, follows immediately after the diskgroup name, in place of the ASM file number. It must be preceeded by a slash, start with an alphabetic character, and consist of up to 48 characters which are alphabetic, numeric, or the characters '$' and '_', space can separate two parts of an alias name.
Action: Correct the file name specification.
ORA-15125: ASM file name 'string' contains an invalid template name
Cause: A file name was specified to ASM which did not contain a valid template name. The template name, if present, follows immediately after the ASM incarnation number or the ASM alias name, if such is used in place of the ASM file number. It must be enclosed in parenthesis, start with an alphabetic character, and consist of up to 30 characters which are alphabetic, numeric, or the characters '$' and '_'.
Action: Correct the file name specification.
ORA-15126: component within ASM file name 'string' exceeds maximum length
Cause: The maximum identifier length of 30 characters was exceeded for the diskgroup name, template name, or alias name field within the ASM file name.
Action: Correct the file name specification.
ORA-15127: ASM file name 'string' cannot use templates
Cause: A fully qualified ASM file name was specified. Such a specification does not permit the inclusion of a template name in the ASM file name.
Action: Correct the file name specification.
ORA-15128: ASM file name 'string' exceeds maximum length string
Cause: The maximum ASM file name length of 256 characters was exceeded for the combination of diskgroup name, file number, template name, alias name plus punctuation within the ASM file name.
Action: Correct the file name specification.
ORA-15129: entry 'string' does not refer to a valid directory
Cause: The entry indicated did not refer to a directory. Attempt was made to access the contents of this directory.
Action: Correct the error and try again.
ORA-15130: diskgroup "string" is being dismounted
Cause: The diskgroup is being dismounted by request or because an I/O error was encountered that could not be handled by taking the disks offline. A disk cannot be offlined whenever doing so could result in all copies of a redundant extent being unavailable.
Action: Repair the hardware problem and re-mount the diskgroup. Refer to the alert log to determine which disks have failed.
ORA-15131: block string of file string in diskgroup string could not be read
Cause: A block could not be read because the disk containing the block is either offline or an I/O error occured while reading the block. If this is mirrored file, then all disks that contain a copy of the block are either offline or received errors.
Action: Repair the affected disk and bring it back online. Refer to accompanying error messages to determine which disk has failed.
ORA-15132: block string of file string in diskgroup string could not be written
Cause: A block could not be written because the disk containing the block is either offline or an I/O error occured while writing the block. If this is mirrored file, then insufficient disks which contain a copy of the block are either offline or received errors.
Action: Repair the affected disk and bring it back online. Refer to accompanying error messages to determine which disk has failed.
ORA-15133: instance recovery required for diskgroup string
Cause: An instance in the cluster crashed making instance recovery necessary.
Action: None. This error should not normally be seen by an ASM client. ASM will trap this error and retry the operation after doing instance recovery automatically.
ORA-15150: instance lock mode 'string' conflicts with other ASM instance(s)
Cause: Some other ASM instance used the lock name space in a conflicting mode.
Action: Shutdown the other instance or start up in compatible mode.
ORA-15169: destination 'string' is a subdirectory of 'string'
Cause: Attempt to rename directory failed because the new directory name was a subdirectory of the original directory.
Action: Correct the path of the destination and try again.
ORA-15170: cannot add entry 'string' in directory 'string'
Cause: Other errors prevented directory/alias creation.
Action: Correct the errors and try again.
ORA-15171: invalid syntax in the alias path after 'string'
Cause: An invalid alias/directory name syntax was specified.
Action: Correct the alias path and try again.
ORA-15173: entry 'string' does not exist in directory 'string'
Cause: The specified alias did not exist in the given directory.
Action: Correct the alias path and try again.
ORA-15175: cannot create alias for diskgroup metadata file 'string'
Cause: An attempt was made to create an alias for a diskgroup metadata file.
Action: Correct the alias path and try again.
ORA-15176: file 'string' already has an alias associated with it
Cause: An attempt was made to create an alias for a file that already had an existing alias.
Action: Correct the file name and try again or drop existing alias.
ORA-15177: cannot operate on system aliases
Cause: An attempt was made to modify a system alias.
Action: Correct the alias name and try again.
ORA-15178: directory 'string' is not empty; cannot drop this directory
Cause: An attempt was made to drop a directory that contained valid entries.
Action: Correct the directory path or specify the FORCE option to drop a directory that is not empty.
ORA-15179: missing or invalid alias name
Cause: The command did not specify a valid alias identifier.
Action: Specify a valid alias identifier.
ORA-15180: Could not open dynamic library string, error [string]
Cause: The library was not accessible
Action: Correct the permissions of the library and try again.
ORA-15181: Symbol [string] not found in library string, error [string]
Cause: An error was encountered while loading the specified ASMLIB symbol.
Action: Correct the error reported and try again.
ORA-15182: ASMLIB [string] version mismatch, oracle version [string]
Cause: The ASMLIB version reported is not supported by the oracle binary.
Action: Install the correct library and try again.
ORA-15183: ASMLIB initialization error [string]
Cause: Unable to initialize the ASMLIB in oracle.
Action: Contact ASMLIB library vendor support with the error details.
ORA-15184: ASMLIB error could not be determined [string] [string]
Cause: An error was encountered which cannot be diagnosed further.
Action: Contact ASMLIB libary vendor for support.
ORA-15185: Could not close dynamic library string, error [string]
Cause: Could not close the dynamic library.
Action: Contact ASMLIB libary vendor for support.
ORA-15186: ASMLIB error function = [string], error = [string], mesg = [string]
Cause: An error occured during a call to function listed in the error.
Action: The detailed message associated with the error is listed along with the error. Correct the error and try again or contact ASMLIB library vendor for support.
ORA-15192: invalid ASM disk header [string] [string] [string] [string] [string]
Cause: ASM encountered an invalid disk header.
Action: Contact Oracle Support Services.
ORA-15196: invalid ASM block header [string:string] [string] [string] [string] [string != string]
Cause: ASM encountered an invalid metadata block.
Action: Contact Oracle Support Services.
ORA-15197: suppressing string additional ASM messages
Cause: The ASM command generated so many erorrs that this summary message was reported in place of many individual messages.
Action: If the command contained multiple actions, try separating each action into its own command and executing each command by itself. Otherwise, try not to generate so many errors.
ORA-15198: operation string is not yet available
Cause: An unimplemented operation was attempted.
Action: Consider upgrading to later releases as they become available.
ORA-16000: database open for read-only access
Cause: The database has been opened for read-only access. Attempts to modify the database using inappropriate DML or DDL statements generate this error.
Action: In order to modify the database, it must first be shut down and re-opened for read-write access.
ORA-16001: database already open for read-only access by another instance
Cause: The database has been opened for read-only access by another instance, and cannot be opened for read-write access by this instance.
Action: This instance must be opened for read-write access, or all other instances must first be shut down and re-opened for read-only access.
ORA-16002: database already open for read-write access by another instance
Cause: The database has been opened for read-write access by another instance, and cannot be opened for read-only access by this instance.
Action: This instance must be opened for read-only access, or all other instances must first be shut down and re-opened for read-write access.
ORA-16003: standby database is restricted to read-only access
Cause: To ensure its integrity, a standby database can only be opened for read-only access.
Action: Re-issue the ALTER DATABASE OPEN specifying READ ONLY.
ORA-16004: backup database requires recovery
Cause: The control file is for a backup database which requires recovery, and cannot be opened for read-only access by this instance.
Action: Perform the necessary recovery and re-open for read-only access.
ORA-16005: database requires recovery
Cause: The database requires recovery, and therefore cannot be opened for read-only access by this instance.
Action: Perform the necessary recovery and re-open for read-only access.
ORA-16006: audit_trail destination incompatible with database open mode
Cause: The audit_trail initialization parameter was set to "DB" (or TRUE), which is incompatible with a database opened for read-only access.
Action: When the database is opened for read-only access, the audit_trail initialization parameter can only be set to "OS" or "NONE" (FALSE).
ORA-16007: invalid backup control file checkpoint
Cause: The backup control file being opened for read-only access does not contain a valid control file checkpoint. Therefore the database cannot be opened for read-only access.
Action: First open the database for read-write access which will result in valid control file checkpoint. Then re-open the database for read-only access.
ORA-16008: indeterminate control file checkpoint
Cause: The control file for the database being opened for read-only access was created via CREATE CONTROLFILE. Therefore a control file checkpoint could not be calculated and the database cannot be opened for read-only access.
Action: First open the database for read-write access which will result in valid control file checkpoint. Then re-open the database for read-only access.
ORA-16009: remote archive log destination must be a STANDBY database
Cause: The database associated with the archive log destination service name is other than the required STANDBY type database. Remote archival of redo log files is not allowed to non-STANDBY database instances.
Action: Take the necessary steps to create the required compatible STANDBY database before retrying the ARCHIVE LOG processing.
ORA-16011: Archivelog Remote File Server process in Error state
Cause: The archivelog remote file server (RFS) process at the specified standby database site has experienced an unrecoverable error and is unable to receive further archive log data.
Action: Correct the problem at the standby database site.
ORA-16012: Archive log standby database identifier mismatch
Cause: The database identifiers of the Primary and Standby database do not match. Remote archival of redo log files is not allowed to incompatible STANDBY database instances.
Action: Take the necessary steps to create the required compatible STANDBY database before retrying the ARCHIVE LOG processing.
ORA-16013: log string sequence# string does not need archiving
Cause: An attempt was made to archive the named file manually, but the file did not require archiving. The file had previously been successfully archived.
Action: No action is required.
ORA-16014: log string sequence# string not archived, no available destinations
Cause: An attempt was made to archive the named log, but the archive was unsuccessful. The archive failed because there were no archive log destinations specified or all destinations experienced debilitating errors.
Action: Verify that archive log destinations are being specified and/or take the necessary step to correct any errors that may have occurred.
ORA-16015: log string sequence# string not archived, media recovery disabled
Cause: An attempt was made to archive the named log, but the archive was unsuccessful. A standby archive log destination was specified and the database was not media recovery enabled. This is not allowed.
Action: Disable the standby destination or enable media recovery and retry.
ORA-16016: archived log for thread string sequence# string unavailable
Cause: The managed standby database recovery operation has timed out waiting for the requested archived log file.
Action: Verify that the primary database is still archiving redo logs to the standby recovery database site and reissue the RECOVER STANDBY DATABASE WAIT command.
ORA-16017: cannot use LOG_ARCHIVE_DUPLEX_DEST without a primary archive destination
Cause: The parameter LOG_ARCHIVE_DUPLEX_DEST was set to a non-NULL value when the primary archive destination was set to NULL explicitly.
Action: Set the primary archive destination to a valid non-NULL value.
ORA-16018: cannot use string with LOG_ARCHIVE_DEST_n or DB_RECOVERY_FILE_DEST
Cause: One of the following events caused an incompatibility: 1) Parameter LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST was in use when a LOG_ARCHIVE_DEST_n (n = 1...10) parameter was encountered while fetching initialization parameters. 2) An ALTER SYSTEM ARCHIVE LOG START TO command was in effect when a LOG_ARCHIVE_DEST_n parameter was encountered while fetching initialization parameters. 3) A LOG_ARCHIVE_DEST_n parameter was in use when an ALTER SYSTEM command was used to define a value for either the LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST parameter. 4) Parameter DB_RECOVERY_FILE_DEST was in use when an attempt was made to use an ALTER SYSTEM or ALTER SESSION command to define a value for LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST.
Action: Eliminate any incompatible parameter definitions.
ORA-16019: cannot use string with LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST
Cause: One of the following events caused an incompatibility: 1) Parameter LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST was in use when the specified LOG_ARCHIVE_DEST_n (n = 1...10) or DB_RECOVERY_FILE_DEST parameter was encountered while fetching initialization parameters. 2) Parameter LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST was in use when an attempt was made to use an ALTER SYSTEM or ALTER SESSION command to define a value for the specified LOG_ARCHIVE_DEST_n or DB_RECOVERY_FILE_DEST parameter. 3) An ALTER SYSTEM ARCHIVE LOG START TO command was in effect when the specified LOG_ARCHIVE_DEST_n parameter was encountered while fetching initialization parameters. 4) An ALTER SYSTEM ARCHIVE LOG START TO command was in effect when an attempt was made to use an ALTER SYSTEM or ALTER SESSION command to define a value for the specified LOG_ARCHIVE_DEST_n parameter.
Action: Eliminate any incompatible parameter definitions.
ORA-16020: less destinations available than specified by LOG_ARCHIVE_MIN_SUCCEED_DEST
Cause: With automatic archiving enabled, the number of archive log destinations that could be used for the database was less than the LOG_ARCHIVE_MIN_SUCCEED_DEST parameter value.
Action: Either adjust the settings of the log archive destination parameters, or lower the value of LOG_ARCHIVE_MIN_SUCCEED_DEST.
ORA-16021: session string destination cannot be the same as session string destination
Cause: An attempt was made to change the first specified archive log parameter using ALTER SESSION to have a destination value that duplicates the session-level destination value of the second specified archive log parameter.
Action: Specify a different session destination value for one of the LOG_ARCHIVE_DEST_n parameters.
ORA-16022: LOG_ARCHIVE_DEST cannot be NULL because LOG_ARCHIVE_DUPLEX_DEST is non-NULL
Cause: An attempt was made to change parameter LOG_ARCHIVE_DEST to NULL when parameter LOG_ARCHIVE_DUPLEX_DEST is non-NULL.
Action: Either set parameter LOG_ARCHIVE_DEST to a non-NULL value, or set parameter LOG_ARCHIVE_DUPLEX_DEST to a NULL value.
ORA-16023: system string destination cannot be the same as session string destination
Cause: An attempt to change the first specified LOG_ARCHIVE_DEST_n (n = 1...10) parameter produced a destination that duplicates the session destination value of the second specified LOG_ARCHIVE_DEST_n parameter. This error can occur when setting a non-NULL value with the ALTER SYSTEM command. Or, this error can occur when setting a NULL value with ALTER SESSION command, because then the associated system destination value may appear as a duplicate.
Action: Specify a different destination value for the first specified LOG_ARCHIVE_DEST_n parameter.
ORA-16024: parameter string cannot be parsed
Cause: The value for the indicated LOG_ARCHIVE_DEST_n (n = 1...10) parameter could not be parsed. Common causes for this error are a misplaced equal sign, an unrecognized attribute, or an attribute that is missing a required value.
Action: Correct the value for the indicated LOG_ARCHIVE_DEST_n parameter.
ORA-16025: parameter string contains repeated or conflicting attributes
Cause: The value for the specified LOG_ARCHIVE_DEST_n (n = 1...10) parameter contained either repeated attributes or attributes that conflicted with each other.
Action: Correct the value for the indicated LOG_ARCHIVE_DEST_n parameter.
ORA-16026: parameter string contains an invalid attribute value
Cause: The value for the specified LOG_ARCHIVE_DEST_n (n = 1...10) parameter contained an attribute with an invalid value.
Action: Correct the value for the indicated LOG_ARCHIVE_DEST_n parameter.
ORA-16027: parameter string is missing a destination option
Cause: The value for the indicated LOG_ARCHIVE_DEST_n (n = 1...10) parameter failed to include a destination option. A destination option is specified using either the LOCATION or SERVICE attrbute.
Action: Correct the value for the indicated LOG_ARCHIVE_DEST_n parameter.
ORA-16028: new string causes less destinations than LOG_ARCHIVE_MIN_SUCCEED_DEST requires
Cause: With automatic archiving enabled, an attempt was made to change the indicated LOG_ARCHIVE_DEST_n or a LOG_ARCHIVE_DEST_STATE_n parameter (n = 1...10) to a value that reduces the number of archive log destinations to less than the specified LOG_ARCHIVE_MIN_SUCCEED_DEST value.
Action: Either select different options for the LOG_ARCHIVE_DEST_n or LOG_ARCHIVE_DEST_STATE_n parameters, or reduce the value for parameter LOG_ARCHIVE_MIN_SUCCEED_DEST.
ORA-16029: cannot change LOG_ARCHIVE_MIN_SUCCEED_DEST, no archive log destinations
Cause: An attempt was made to change the LOG_ARCHIVE_MIN_SUCCEED_DEST parameter when there are no archive log destinations.
Action: Define one or more log archive destinations using parameters LOG_ARCHIVE_DEST, LOG_ARCHIVE_DUPLEX_DEST, or LOG_ARCHIVE_DEST_n (n = 1...10). Then, change the value of parameter LOG_ARCHIVE_MIN_SUCCEED_DEST.
ORA-16030: session specific change requires a LOG_ARCHIVE_DEST_n destination
Cause: The following event caused an incompatibility: Parameter LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST was in use when an attempt was made to change the LOG_ARCHIVE_MIN_SUCCEED_DEST parameter with an ALTER SESSION command.
Action: Replace any LOG_ARCHIVE_DEST and LOG_ARCHIVE_DUPLEX_DEST parameters with LOG_ARCHIVE_DEST_n (n = 1...10) parameters.
ORA-16031: parameter string destination string exceeds string character limit
Cause: The value for the specified parameter contained a destination string that is too long.
Action: Replace the destination value for the specified parameter with a character string that has a length below the limit specified in the error message.
ORA-16032: parameter string destination string cannot be translated
Cause: The value for the specified parameter contained a destination string that could not be translated.
Action: Use a valid destination string in the specified parameter.
ORA-16033: parameter string destination cannot be the same as parameter string destination
Cause: An attempt was made to change the first specified archive log parameter to have a destination value that duplicates the system-level destination value of the second specified archive log parameter.
Action: Specify a different value for one of the archive log parameters.
ORA-16034: FROM parameter is incompatible with MANAGED recovery
Cause: Use of the FROM 'location' parameter is not allowed when MANAGED recovery has been specified.
Action: Correct the syntax and retry the command.
ORA-16035: missing required keyword string
Cause: The indicated keyword is required but was not specified.
Action: Correct the syntax and retry the command.
ORA-16036: invalid MANAGED recovery CANCEL option
Cause: A mode other than IMMEDIATE follows the CANCEL keyword in RECOVER MANAGED STANDBY DATABASE statement.
Action: Specify either nothing or IMMEDIATE following CANCEL.
ORA-16037: user requested cancel of managed recovery operation
Cause: The managed standby database recovery operation has been canceled per user request.
Action: No action is required.
ORA-16038: log string sequence# string cannot be archived
Cause: An attempt was made to archive the named file, but the file could not be archived. Examine the secondary error messages to determine the cause of the error.
Action: No action is required.
ORA-16039: RFS request version mismatch
Cause: A request to archive a redo log to a standby site failed because the request was incompatible with the Remote File Server (RFS) at the standby site.
Action: Verify that compatible versions of Oracle are running on the primary and all standby sites.
ORA-16040: standby destination archive log file is locked
Cause: The target standby destination archive log file is currently locked. This indicates that the file is being archived to by another Remote File Server (RFS) process.
Action: Check for and eliminate duplicate standby destination archive log service names defined for the primary database.
ORA-16041: Remote File Server fatal error
Cause: The Remote File Server (RFS) process at the standby destination archive log site has encountered a disabling error and is no longer available. Further archiving to the standby site may not be possible.
Action: Refer to the appropriate RFS trace file located at the standby site for details regarding the error encountered and if possible take corrective action.
ORA-16042: user requested cancel immediate of managed recovery operation
Cause: The managed standby database recovery operation has been canceled immediately per user request. Processing of the current archive log file has been interrupted and therefore the database is in an inconsistent state.
Action: No action is required.
ORA-16043: managed recovery session canceled
Cause: The standby database managed recovery operation has been canceled per user request or operation timeout.
Action: More specific messages will accompany this message.
ORA-16044: destination string attribute cannot be specified at session level
Cause: An archive log destination attribute was attempted to be modified at the session level.
Action: Use the ALTER SYSTEM command to modify the destination attribute.
ORA-16045: circular archive log destination dependency chain
Cause: An archive log destination contains a dependency to another archive log destination that also contains a dependency.
Action: The parent archive log destination cannot be dependent on another archive log destination. Use the ALTER SYSTEM command to remove one of the dependency attributes.
ORA-16046: Archive log destination failed due to failed dependent destination
Cause: The archive log destination is dependent upon another destination, which has failed. Therefore, this destination also fails.
Action: No action required.
ORA-16047: DGID mismatch between destination setting and standby
Cause: The DB_UNIQUE_NAME specified for the destination does not match the DB_UNIQUE_NAME at the destination.
Action: Make sure the DB_UNIQUE_NAME specified in the LOG_ARCHIVE_DEST_n parameter defined for the destination matches the DB_UNIQUE_NAME parameter defined at the destination.
ORA-16050: destination exceeded specified quota size
Cause: An archive log was attempted to be created in a destination with a specified maximum quota size. The creation of the archive log exceeded the specified quota size. Therefore, the destination has been made inaccessible to future archival operations.
Action: No action is required.
ORA-16051: parameter string contains an invalid delay time
Cause: The value for the specified LOG_ARCHIVE_DEST_n (n = 1...10) parameter contained a DELAY attribute with an invalid numeric value. The valid range is 0-5760 (in minutes).
Action: Correct the value for the indicated LOG_ARCHIVE_DEST_n parameter.
ORA-16052: DB_UNIQUE_NAME attribute is required
Cause: The DB_UNIQUE_NAME attribute is required when DG_CONFIG is enabled.
Action: Use the DB_UNIQUE_NAME attribute to specify a valid Data Guard Name for the destination. The list of valid DB_UNIQUE_NAMEs can be seen with the V$DATAGUARD_CONFIG view.
ORA-16053: DB_UNIQUE_NAME string is not in the Data Guard Configuration
Cause: The specified DB_UNIQUE_NAME is not in the Data Guard Configuration.
Action: If the DG_CONFIG attribute of the LOG_ARCHIVE_CONFIG parameter is enabled, you must specify a valid DB_UNIQUE_NAME. The list of valid DB_UNIQUE_NAMEs can be seen with the V$DATAGUARD_CONFIG view. This problem can also occur when specifying a non-standby destination with an DB_UNIQUE_NAME attribute that does not match the DB_UNIQUE_NAME initialization parameter for the current instance.
ORA-16055: FAL request rejected
Cause: FAL server rejects the FAL request from the FAL client. This may be caused by different reasons.
Action: to solve the problem.
ORA-16056: backup control file archival requires proper syntax
Cause: An attempt was made to perform an online log file archival using a backup control file. However, the USING BACKUP CONTROLFILE syntax was not specified.
Action: If the archival operation is correct when using a backup control file, then the USING BACKUP CONTROLFILE syntax is required.
ORA-16057: DGID from server not in Data Guard configuration
Cause: The Data Guard name of the primary database or the FAL server is not in the Data Guard configuration of the standby.
Action: In order for the primary database or the FAL server to archive logs to the standby database, the Data Guard name of the primary or FAL server must be in the Data Guard configuration of the standby.
ORA-16058: standby database instance is not mounted
Cause: The RFS process on the standby database received an internal error.
Action: Check the standby alert log and RFS trace files for more information.
ORA-16059: Log file is empty or invalid next available block
Cause: Archiving not allowed of an empty or invalid log file.
Action: No action is required.
ORA-16060: Log file is current
Cause: The current log file cannot be archived using its file name.
Action: No action is required.
ORA-16061: Log file status has changed
Cause: It is possible the online log file was reclaimed as a new log file either before archival started, or during the archival operation.
Action: No action is required.
ORA-16062: DGID from standby not in Data Guard configuration
Cause: The Data Guard name from the standby is not in the Data Guard configuration of the server.
Action: In order for the server to be allowed to archive logs to the standby, the Data Guard name of the standby must be in the Data Guard configuration of the server.
ORA-16063: remote archival is enabled by another instance
Cause: Remote archival of database REDO log files has been enabled by another instance, and cannot be disabled for this instance.
Action: Set the REMOTE_ARCHIVE_ENABLE parameter to TRUE and restart this instance.
ORA-16064: remote archival is disabled by another instance
Cause: Remote archival of database REDO log files has been disabled by another instance, and cannot be enabled for this instance.
Action: Set the REMOTE_ARCHIVE_ENABLE parameter to FALSE and restart this instance.
ORA-16065: remote archival disabled at standby destination
Cause: Receipt of remote archived REDO log files has been disabled at the associated standby destination host database.
Action: If appropriate change the associated archive log parameter to specify a local destination with the LOCATION keyword or defer the associated archive log destination. Or, if possible, set the standby REMOTE_ARCHIVE_ENABLE parameter to TRUE, or enable the RECEIVE attribute of the LOG_ARCHIVE_CONFIG parameterand restart the standby database instance before further REDO log file archivals occur.
ORA-16066: remote archival disabled
Cause: An archive log destination parameter has specified a remote destination with the SERVICE keyword. Remote archival of REDO log files has been disabled for this database. The associated archive log destination has been disabled.
Action: If appropriate change the archive log parameter to specify a local destination with the LOCATION keyword or (if appropriate) set the REMOTE_ARCHIVE_ENABLE parameter to TRUE, or enable the SEND attribute of the LOG_ARCHIVE_CONFIG parameter and restart the database instance before further REDO log file archivals occur.
ORA-16067: activation identifier mismatch in archive log string
Cause: The activation identifier contained in the archive log file header does not match the activation identifier of the database being recovered. The indicated archive log cannot be applied to the database.
Action: Locate the appropriate archive log for the database.
ORA-16068: redo log file activation identifier mismatch
Cause: The activation identifier of the indicated redo log file does not match the activation identifier of the database.
Action: none
ORA-16069: Archive Log standby database activation identifier mismatch
Cause: The activation identifiers of the Primary and Standby database do not match. Remote archival of redo log files is not allowed to incompatible STANDBY database instances. This can occur when trying to apply an incorrect archive log to a standby database, or when trying to archive to a standby database that does not match the primary database.
Action: Take the necessary steps to create the required compatible STANDBY database before retrying the ARCHIVE LOG processing.
ORA-16070: parameter string contains an invalid REGISTER attribute value
Cause: The value for the specified LOG_ARCHIVE_DEST_n (n = 1...10) parameter contained a REGISTER attribute that specified an invalid file name template string. If specified, the REGISTER file name template string must indicate an O/S-specific file path name including thread and log sequence number substitution directives (%t, %T, %s, %S).
Action: Correct the value for the LOG_ARCHIVE_DEST_n parameter.
ORA-16071: dependency archived log file not found string
Cause: The specified archived log file was not found at the indicated standby destination.
Action: Verify the correctness of the dependency archived log file name template specified for the indicated standby destination against the actual dependency archived log file.
ORA-16072: a minimum of one standby database destination is required
Cause: No standby database archive log destinations were specified.
Action: Specify a standby archive log destination in the initialization parameter file.
ORA-16073: archiving must be enabled
Cause: Online log file archiving is disabled.
Action: Enable log file archiving.
ORA-16074: ARCH processes must be active
Cause: There are no active ARCH processes.
Action: It is required that at least one ARCH process be active.
ORA-16075: standby database destination mismatch
Cause: A standby database destination was specified that is not accessed by another instance.
Action: All database instances must access the same standby databases.
ORA-16076: unknown standby database destination
Cause: A standby database destination was specified that is not accessed by another instance.
Action: All database instances must access the same standby databases.
ORA-16078: media recovery disabled
Cause: The database is not in ARCHIVELOG mode.
Action: Place the database in ARCHIVELOG mode.
ORA-16079: standby archival not enabled
Cause: The standby database does not have archival enabled.
Action: In order to allow the standby database to access the standby log files, the ARCH process must be enabled and active.
ORA-16080: invalid LogMiner session string for APPLY
Cause: Logical standby apply engine was started with an invalid LogMiner session identifier.
Action: Fix the problem with the LogMiner session or create a new session.
ORA-16081: insufficient number of processes for APPLY
Cause: Logical standby apply engine was started with fewer processes available than needed.
Action: Increase the values of the initialization parameters PROCESSES and and PARALLEL_MAX_SERVERS, or the MAX_SLAVES parameter seen in the DBA_LOGSTDBY_PARAMETERS view.
ORA-16082: logical standby is not initialized correctly
Cause: Logical standby apply engine was started but it found inconsistencies in its metadata.
Action: Look in the trace file for more information.
ORA-16083: LogMiner session has not been created
Cause: Logical standby apply engine was started without creating a LogMiner session.
Action: Create a LogMiner session and restart the apply engine.
ORA-16084: an apply engine is already running
Cause: A logical standby apply engine was running when another was created.
Action: Shut down the previous apply engine before starting a new one.
ORA-16086: standby database does not contain available standby log files
Cause: The primary database is in "no data loss" mode, but the standby database does not contain any "standby log files".
Action: Add one or more standby log files to the standby database. This can be done while the standby database is mounted.
ORA-16087: graceful switchover requires standby or current control file
Cause: An attempt was made to perform a graceful switchover operation using a backup or clone control file.
Action: Convert the backup control file into a current control file prior to attempting a graceful switchover operation. A clone control file cannot be used for a graceful switchover operation.
ORA-16088: archive log has not been completely archived
Cause: An attempt was made to register an archive log that has not been completely archived. The specified archive log may be a "current" log file.
Action: Specify a completed archive log.
ORA-16089: archive log has already been registered
Cause: An attempt was made to register an archive log that already has a corresponding thread# and sequence# entry in the standby database control file. Duplicate information is not permitted.
Action: Use the V$ARCHIVED_LOG fixed view to verify the archive log information.
ORA-16090: archive log to be replaced not created by managed standby process
Cause: An attempt was made to replace an archive log entry that was not originally created by the managed standby operation.
Action: No user action required.
ORA-16091: dependent archive log destination already archived
Cause: An archive log destination contains a dependency to another archive log destination that has previously been archived.
Action: The parent archive log destination cannot be dependent on another archive log destination. Use the ALTER SYSTEM command to remove one of the dependency attributes.
ORA-16092: dependent archive log destination is not active
Cause: An archive log destination contains a dependency to another archive log destination that is not active"
Action: The child archive log destination cannot be dependent on another invalid archive log destination. Use the ALTER SYSTEM command to remove one of the dependency attributes.
ORA-16093: dependent archive log destination is not LGWR-enabled
Cause: An archive log destination contains a dependency to another archive log destination that is not enabled for the LGWR process"
Action: The child archive log destination cannot be dependent on another archive log destination not archived by the LGWR. Use the ALTER SYSTEM command to change the parent archive log to specify the LGWR process.
ORA-16094: database shutdown during archival operation
Cause: The database was shut down while an online log file archival was active.
Action: None required. The ARCH process is terminated.
ORA-16095: Dependent destination removal for inactivation
Cause: A dependent archive log destination was inactivated due to the parent archive log destination becoming inelligible for archival. This may be due to the parent destination being manually deferred by an application user.
Action: None required.
ORA-16096: ALTER DATABASE COMMIT TO SWITCHOVER TO PHYSICAL STANDBY
Cause: None
Action: Specify this command to prepare the primary database for switchover
ORA-16097: ALTER DATABASE COMMIT TO SWITCHOVER TO PRIMARY
Cause: None
Action: Specify this command to prepare the standby database for switchover
ORA-16098: inaccessible standby database forced shutdown to protect primary
Cause: No standby database archive log destinations remain accessible and the primary database is in "protected" no-data-loss mode.
Action: Specify an alternate standby archive log destination in the initialization parameter file.
ORA-16099: internal error ORA-00600 occurred at standby database
Cause: The RFS process on the standby database received an internal error.
Action: Check the standby alert log and RFS trace files for more information.
ORA-16100: not a valid Logical Standby database
Cause: This database has not been completely configured as a Logical Standby database.
Action: Verify that the database is the intended Logical Standby database. Ensure that you already started logical standby apply with the ALTER DATABASE START LOGICAL APPLY INITIAL statement. See the Oracle8i SQL Reference manual for the statement syntax.
ORA-16101: a valid start SCN could not be found
Cause: An SCN from which to start could not be found.
Action: Register the first log file following the backup from which this database was generated. Using the ALTER DATABASE REGISTER LOGILE statement to register the database is recommended. Alternatively, you can provide a starting SCN value with this startement.
ORA-16102: remote information is not available on the specified primary
Cause: The new primary has not completed generating the necessary information for the standby to begin consuming its log stream.
Action: Verify that the database link provided references a system that is about to become a new primary. Wait a short time before retrying the command to allow the primary some time to generate the necessary information.
ORA-16103: Logical Standby apply must be stopped to allow this operation
Cause: Logical Standby is currently applying changes. The apply must complete or be stopped to allow the requested operation.
Action: Execute the ALTER DATABASE STOP LOGICAL STANDBY APPLY statement, then re-enter or respecify the operation.
ORA-16104: invalid Logical Standby option requested
Cause: The option requested is not valid.
Action: Check spelling or refer to the Oracle8i SQL Reference manual for the correct statement syntax, then re-enter the request.
ORA-16105: Logical Standby is already running in background
Cause: A Logical Standby apply operation is already running.
Action: none
ORA-16107: all log data from primary has been processed
Cause: On the primary system, the log stream has been ended by the ALTER DATABASE COMMIT TO SWITCHOVER TO LOGICAL STANDBY command.
Action: Issue one of the following commands to make this standby a primary or resume applying changes from a new primary. ALTER DATABASE COMMIT TO SWITCHOVER TO LOGICAL PRIMARY; ALTER DATABASE START LOGICAL STANDBY APPLY NEW PRIMARY dblink;
ORA-16108: database is no longer a standby database
Cause: The current database has already been made a primary database.
Action: Issue the following commands to make this primary a standby. ALTER DATABASE COMMIT TO SWITCHOVER TO LOGICAL STANDBY; ALTER DATABASE START LOGICAL STANDBY APPLY NEW PRIMARY dblink;
ORA-16109: failed to apply log data from previous primary
Cause: Log data from previous primary could not be completely applied.
Action: . Then, re-issue command.
ORA-16110: user procedure processing of logical standby apply DDL
Cause: A user provided stored procedure has been called to inspect a DDL statement prior to it being processed.
Action: No action necessary, this informational statement is provided to record user involvement in the processing of a statement. Additional information can be found in the DBA_LOGSTDBY_EVENTS and the DBA_LOGSTDBY_SKIP views.
ORA-16111: log mining and apply setting up
Cause: This logical standby process is setting up to begin processing changes.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16112: log mining and apply stopping
Cause: This logical standby process is cleaning up and stopping Logical Standby apply.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16113: applying change to table or sequence string
Cause: The process is applying changes to a specific schema object.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16114: applying DDL transaction with commit SCN string
Cause: The process is applying a DDL change that's committed at the given SCN.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16115: loading Log Miner dictionary data
Cause: The process is loading dictionary information from the redo stream. This activity may take a few minutes.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16116: no work available
Cause: The process is idle waiting for additional changes to be made available.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16117: processing
Cause: The process is performing its primary function and is not waiting on any significant event.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16119: building transaction at SCN string
Cause: The transaction being committed at the given SCN is being prepared for apply.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16120: dependencies being computed for transaction at SCN string
Cause: The transaction committed at the given SCN is being analyzed for dependencies.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16121: applying transaction with commit SCN string
Cause: The transaction committed at the given SCN is being applied.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16122: applying large dml transaction at SCN string
Cause: A large transaction is being applied before the commit has been seen. The current redo being applied ends as the given SCN.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16123: transaction string string string is waiting for commit approval
Cause: The apply process is waiting for approval to commit a transaction. This transaction may depend on another or other synchronization activity may delay the committing of a transaction.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16124: transaction string string string is waiting on another transaction
Cause: The apply process is waiting to apply additional changes. This transaction likely depends on another.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16125: large transaction string string string is waiting for more data
Cause: The apply process is waiting until additional changes for a large transaction are retrieved from the log stream.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16126: loading table or sequence string
Cause: Information on the given table or sequence is being loaded into an in memory cache for future use.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16127: stalled waiting for additional transactions to be applied
Cause: This process is waiting for additional memory before continuing. Additional log information cannot be read into memory until more transactions have been applied to the database, thus freeing up additional memory.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes. If this message occurs often and changes are not being applied quickly, increase available SGA or the number of apply processes.
ORA-16128: User initiated shut down successfully completed
Cause: Logical standby was shutdown in an orderly fashion.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16129: unsupported dml encountered
Cause: DML to tables in the SYS schema have been updated and are not part of a DDL operation. This may be due to some DBA activity or DML associated with a kernel PL/SQL request that Logical Standby does not yet support.
Action: Check the DBA_LOGSTDBY_EVENTS table for the name of the table being processed. Possibly use Log Miner to understand the transaction, and provide a compensating transaction on the standby system. Once complete, call DBMS_LOGSTDBY.SKIP_TRANSACTION with the associated transaction id, and resume apply.
ORA-16130: supplemental log information is missing from log stream
Cause: Supplemental logging is not enabled at the primary database.
Action: Issue the following command to enable supplemental logging. ALTER DATABASE ADD SUPPLEMENTAL LOG DATA (PRIMARY KEY, UNIQUE INDEX) COLUMNS;
ORA-16131: An error occurred during a Terminal Recovery of the standby.
Cause: An error occurred during a Terminal Recovery of the standby.
Action: Check the standby alert log additional information.
ORA-16132: An error occurred during activation of the standby.
Cause: An error occurred during activation of the standby database following a Terminal Recovery.
Action: Check the standby alert log additional information.
ORA-16133: Datafile string has incorrect terminal recovery stamp.
Cause: After activation of a standby database following a terminal recovery (recovery of standby using current logs), recovery of a datafile from before the activation must have completed the same terminal recovery to avoid corruption.
Action: A backup of the datafile taken after the terminal recovery and before activating the standby must be used for recovery.
ORA-16134: invalid MANAGED recovery FINISH option
Cause: A mode other than NOWAIT follows the FINISH keyword in RECOVER MANAGED STANDBY DATABASE statement.
Action: Specify either nothing or NOWAIT following FINISH.
ORA-16135: Invalid LOG_ARCHIVE_CONFIG modification while in protected mode
Cause: The LOG_ARCHIVE_CONFIG parameter can not be modified while any RAC instance is open in either maximum protection or maximum availability mode. Also, the parameter can not be modified in such way that would cause all destinations to fail while in maximum protection mode.
Action: Make the modification before the database is opened by any instance.
ORA-16136: Managed Standby Recovery not active
Cause: An attempt was made to cancel a managed recovery session but no managed recovery session was active.
Action: No action is necessary.
ORA-16137: No terminal recovery is required
Cause: All archived logs have been applied, and there are no current logs to be applied. Terminal recovery is not required.
Action: No action is necessary. The standby database may be activated as a new primary or may continue as a standby.
ORA-16138: end of log stream not received from primary
Cause: The standby system has not received notification that the primary system log stream has been terminated. A graceful switchover is not possible.
Action: Verify that the primary log stream has been terminated. Ensure that the standby has applied all necessary redo from the primary system and, if appropriate, reissue the graceful switchover command.
ORA-16139: media recovery required
Cause: The database has not been recovered through the end of log stream. Graceful switchover is not possible.
Action: Ensure that the entire log stream has been applied. If appropriate, reissue the graceful switchover command.
ORA-16140: standby online logs have not been recovered
Cause: The standby database has online logs containing redo that has not been recovered. Activating the standby would lose redo contained in the online logs.
Action: To recover the standby online logs issue the following command: ALTER DATABASE RECOVER MANAGED STANDBY DATABASE FINISH. Then re-issue the ALTER DATABASE ACTIVATE STANDBY DATABASE command. To activate the standby without recovering the online logs, issue the following command: ALTER DATABASE ACTIVATE STANDBY DATABASE SKIP STANDBY LOGFILE.
ORA-16143: RFS connections not allowed during or after terminal recovery
Cause: An attempt was made, by an RFS process, to access a standby online log file during or after a terminal recovery.
Action: The primary must not attempt to archive to the standby after a terminal recovery.
ORA-16145: archival for thread# string sequence# string in progress
Cause: The indicated archived log file is not available for recovery due to the fact that it is still being archived.
Action: Verify that archival of the indicated log file has completed and reissue the RECOVER STANDBY DATABASE command.
ORA-16146: standby destination control file enqueue unavailable
Cause: The target standby destination control file is currently unavailable to the Remote File Server (RFS) process. This indicates that the target destination is the primary database itself.
Action: Check for and eliminate the standby destination archive log parameter in question.
ORA-16147: standby database referenced by multiple archive log destinations
Cause: Multiple archive log destinations reference the same standby database, using different service names. This is not allowed.
Action: Remove one of the duplicate archive log destinations.
ORA-16148: user requested expiration of managed recovery operation
Cause: The managed standby database recovery operation has been canceled per user specified EXPIRE option of the RECOVER MANAGED STANDBY DATABASE statement.
Action: No action is required.
ORA-16150: FINISH recovery performed on another, older standby database
Cause: An archive log containing a FINISH recovery indicator was received by a standby database that has received archive logs in the future of the received archive log. Because of the possibility that these future archive logs have been applied to this standby database, the received archive log must be rejected.
Action: No action is required.
ORA-16151: Managed Standby Recovery not available
Cause: The attempted operation failed because of a pending CANCEL of the managed standby recovery operation.
Action: Wait for the managed standby recovery session to end. Then retry the operation.
ORA-16152: standby database is in 'no-data-loss' protected mode
Cause: The attempted database operation is not allowed while the standby database is in 'no-data-loss' protected mode.
Action: Verify that the attempted database operation is warranted, ALTER DATABASE SET STANDBY DATABASE UNPROTECTED and reissue the statement.
ORA-16154: suspect attribute: string
Cause: Use of the indicated attribute is illegal in the given context.
Action: Make the appropriate changes and reissue the statement.
ORA-16156: LGWR archive log dependency not allowed if database is standby protected
Cause: The use of a LGWR archive log dependency is not allowed when the primary is protected by a standby database, as this requires use of the standby redo log files.
Action: Remove the LGWR archive log dependency and use normal LGWR archival instead.
ORA-16157: media recovery not allowed following successful FINISH recovery
Cause: A RECOVER MANAGED STANDBY DATABASE FINISH command has previously completed successfully. Another media recovery is not allowed.
Action: Issue one of these operations following a FINISH recocvery: ALTER DATABASE OPEN READ ONLY or ALTER DATABASE COMMIT TO SWITCHOVER TO PRIMARY.
ORA-16159: Cannot change protected standby destination attributes
Cause: An attempt was made to change the LGWR/ARCH or SYNC/ASYNC attributes for a destination that is participating in the standby protection mode of the database.
Action: No action is required.
ORA-16160: Cannot change protected standby database configuration
Cause: An attempt was made to change the standby database configuration when the primary database is in standby protected mode.
Action: The standby database must be added to the configuration before the primary database is opened.
ORA-16161: Cannot mix standby and online redo log file members for group string
Cause: An attempt was made to add a log file member that does not match the other member types. This problem typically occurs when adding a standby log file member to an online redo logfile group, or adding an online redo log file member to a standby redo log file group.
Action: Verify the log file group type using the TYPE column of the V$LOG fixed view.
ORA-16162: Cannot add new standby databases to protected configuration
Cause: An attempt was made to enable a new standby database destination when the primary database is in standby protected mode.
Action: The standby database must be added to the configuration before the primary database is opened.
ORA-16163: LGWR network server host attach error
Cause: The LGWR network server could not attach to remote host
Action: The alert log contains more problem-specific information
ORA-16164: LGWR network server host detach error
Cause: The LGWR network server could not detach from remote host
Action: The alert log contains more problem-specific information
ORA-16165: LGWR failed to hear from network server
Cause: The LGWR lost its connection to the network server
Action: The alert log contains more problem-specific information
ORA-16166: LGWR network server failed to send remote message
Cause: The LGWR network server could not communicate with the remote host
Action: The alert log contains more problem-specific information
ORA-16167: LGWR network server could not switch to non-blocking mode
Cause: The LGWR network server could not switch to non-blocking mode
Action: The alert log contains more problem-specific information
ORA-16168: LGWR network server could not switch to blocking mode
Cause: The LGWR network server could not switch to blocking mode
Action: The alert log contains more problem-specific information
ORA-16169: LGWR network server invalid parameters
Cause: The LGWR network server could not switch to blocking mode
Action: The alert log contains more problem-specific information
ORA-16170: Terminal recovery may have left the database in an inconsistent state
Cause: When terminal recovery is invoked in a standby database without synchronous log shipping, in the rare case of the recovery session being in an unrecoverable state, terminal recovery cannot bring the standby database to a consistent SCN boundary if the primary database continues to have redo thread(s) open.
Action: Continue standby recovery with additional log shipping from primary.
ORA-16171: RECOVER...FINISH not allowed due to gap for thr string, seq string-string
Cause: See alert log for more details
Action: Copy missing archived logs from primary or another standby. Register the logs and re-issue the RECOVER...FINISH command. If the logs are not available, issue the ALTER DATABASE RECOVER MANAGED STANDBY SKIP command to ignore the standby redo log files.
ORA-16172: archive logs detected beyond Terminal End-Of-Redo
Cause: An attempt to archive a Terminal End-Of-Redo archive log to a remote destination failed due the existence, at the remote site, of archive logs containing REDO in the future of the Terminal EOR.
Action: none
ORA-16173: incompatible archival network connections active
Cause: One of two situations can cause this error: 1) An attempt to start a Terminal Incomplete Recovery operation failed due to an active Remote File Server process detected. 2) An attempt to archive a Terminal End-Of-Redo archive log to a remote destination failed due to an active Remote File Server process at the remote site. An active Remote File Server (RFS) process implies connectivity with the primary database which may indicate that a Terminal Incomplete Recovery operation is not warrented.
Action: Verify the Managed Standby environment and re-evaluate the necessity of a Terminal Incomplete Recovery operation.
ORA-16174: user requested thread/sequence termination of managed recovery
Cause: The managed standby database recovery operation has been terminated per user specified THROUGH THREAD/SEQUENCE option of the RECOVER MANAGED STANDBY DATABASE statement.
Action: No action is required.
ORA-16175: cannot shut down database when media recovery is active
Cause: An attempt was made to shut down a standby database while media recovery was active.
Action: Cancel media recovery to proceed with the shutdown.
ORA-16176: background dictionary build cannot be running
Cause: The background process dedicated to dictionary build is active.
Action: wait and try it later.
ORA-16177: media recovery is not required
Cause: The THROUGH LAST SWITCHOVER clause of the ALTER DATABASE RECOVER MANAGED STANDBY DATABASE was specified and the database has been recovered to the most recent End-Of-Redo marker. All known archived logs have been applied. Managed recovery is not required.
Action: No action is necessary. The standby database may be activated as a new primary or may continue as a standby.
ORA-16178: Cannot specify remote destinations in archivelog manual mode
Cause: The database is operating in ARCHIVELOG MANUAL mode. Remote archivelog destinations are not allowed in this mode.
Action: Use the ALTER DATABASE ARCHIVELOG command to place the database in automatic archivelog mode, or defer the archivelog destinations that specify the SERVICE= attribute.
ORA-16179: incremental changes to "string" not allowed with SPFILE
Cause: Incremental changes to a log_archive_dest_n parameter cannot be made when using an SPFILE.
Action: Specify either LOCATION or SERVICE plus all other attributes to be set in one ALTER SYSTEM/SESSION SET command.
ORA-16180: number processes specified for MAX_PARALLEL_SERVERS is too small
Cause: The max number of parallel servers available for Logical Standby is less than 5 becase of the limit imposed by the too small value of MAX_PARALLEL_SERVERS.
Action: Adjust the values of the initialization parameters PARALLEL_MAX_SERVERS to be at least 5.
ORA-16181: SGA specified for Logical Standby is too large
Cause: MAX_SGA is larger than the larger of initialization parameters SHARED_POOL_SIZE and SGA_TARGET.
Action: Specify the value of MAX_SGA to be less than the maximum of SHARED_POOL_SIZE and SGA_TARGET. Likely only 75% or lower.
ORA-16182: Internal error on internal channel during remote archival
Cause: An internal error was encountered on the internal channel between LGWR and Network Server.
Action: No action is required, as an attempt will be made to re-archive the file that had this failure during archival.
ORA-16184: DB_UNIQUE_NAME string hashes to the same value as DB_UNIQUE_NAME string
Cause: The internal hash value generated for one DB_UNIQUE_NAME collided with the hash value of another DB_UNIQUE_NAME.
Action: Slightly modify one of the DB_UNIQUE_NAMEs so it hashes to a different value.
ORA-16185: REMOTE_ARCHIVE_ENABLE and LOG_ARCHIVE_CONFIG mutually exclusive
Cause: Both the REMOTE_ARCHIVE_ENABLE and LOG_ARCHIVE_CONFIG parameters are defined in the initialization file and they are mutually exclusive.
Action: The REMOTE_ARCHIVE_ENABLE parameter has been made obsolete. Use only the LOG_ARCHIVE_CONFIG parameter.
ORA-16186: Modifying LOG_ARCHIVE_CONFIG requires SID='*' qualifier
Cause: The setting for the LOG_ARCHIVE_CONFIG parameter must be exactly the same on all RAC instances so the SID='*' qualifier is required.
Action: Re-enter the command using the SID='*' qualifier.
ORA-16187: LOG_ARCHIVE_CONFIG contains duplicate, conflicting or invalid attributes
Cause: The LOG_ARCHIVE_CONFIG parameter was specified with duplicate, conflicting or invalid attributes.
Action: Check the documentation regarding the correct specification of the LOG_ARCHIVE_CONFIG parameter.
ORA-16188: LOG_ARCHIVE_CONFIG settings inconsistent with previously started instance
Cause: The settings for the LOG_ARCHIVE_CONFIG parameter are inconsistent with the settings of a previously started instance. The settings for this parameter must be exactly the same for all instances.
Action: Make sure all instances use the exact same LOG_ARCHIVE_CONFIG settings.
ORA-16191: Primary log shipping client not logged on standby
Cause: An attempt to ship redo to standby without logging on to standby or with invalid user credentials.
Action: Check that primary and standby are using password files and that both primary and standby have the same SYS password. Restart primary and/or standby after ensuring that password file is accessible and REMOTE_LOGIN_PASSWORDFILE initialization parameter is set to SHARED or EXCLUSIVE.
ORA-16192: Primary and standby network integrity mismatch
Cause: Standby wants sqlnet network integrity for redo shipment which is not configured properly at the primary.
Action: Check sqlnet.ora documentation regarding how to setup network integrity and set it up identically on both primary and standby. Restart primary and/or standby.
ORA-16193: Primary and standby network encryption mismatch
Cause: Standby wants sqlnet network encryption for redo shipment which is not configured properly at the primary.
Action: Check sqlnet.ora documentation regarding how to setup network encryption and set it up identically on both primary and standby. Restart primary and/or standby.
ORA-16194: Modifying DB_UNIQUE_NAME requires SID='*' qualifier
Cause: The setting for the DB_UNIQUE_NAME parameter must be exactly the same on all RAC instances so the SID='*' qualifier is required.
Action: Re-enter the command using the SID='*' qualifier.
ORA-16195: DG_CONFIG requires DB_UNIQUE_NAME be explicitly defined
Cause: The DG_CONFIG attribute of the LOG_ARCHIVE_CONFIG parameter can only be used if the DB_UNIQUE_NAME parameter has been explicitly defined.
Action: Explicitly define a valid DB_UNIQUE_NAME.
ORA-16196: database has been previously opened and closed
Cause: The instance has already opened and closed the database, which is allowed only once in its lifetime.
Action: Shut down the instance.
ORA-16197: Invalid DB_UNIQUE_NAME parameter specification
Cause: The DB_UNIQUE_NAME parameter has an invalid specification. The DB_UNIQUE_NAME parameter has a maximum length of 30 characters and the only characters allowed are alpha-numeric characters and "_", "$" and "#".
Action: Check the documentation and re-enter the parameter.
ORA-16198: Timeout incurred on internal channel during remote archival
Cause: A timeout was incurred during remote archival.
Action: No action is required, as an attempt will be made to re-archive the file that had this failure during archival.
ORA-16199: Terminal recovery failed to recover to a consistent point
Cause: See alert log for more details
Action: Try to resolve the problem. Retry terminal recovery. If the problem occurs repeatedly and cannot be resolved, call Oracle support.
ORA-16200: Skip procedure requested to skip statement
Cause: Logical standby called a skip procedure that requested for a particular statement not to be applied.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16201: Skip procedure requested to apply statement
Cause: Logical standby called a skip procedure that requested for a particular statement to be applied.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16202: Skip procedure requested to replace statement
Cause: Logical standby called a skip procedure that requested for a particular statement to be replaced with a new statement.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16203: Unable to interpret skip procedure return values
Cause: The skip procedure returned conflicting or invalid values.
Action: Ensure that the new_statement output parameter is non-NULL when returning DBMS_LOGSTDBY.SKIP_ACTION_REPLACE and NULL otherwise. Also ensure SKIP_ACTION is specified correctly.
ORA-16204: DDL successfully applied
Cause: A DDL statement has successfully commited on the logical standby database.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16205: DDL skipped due to skip setting
Cause: A setting in the logical standby skip table indicates that this type of DDL should always be skipped.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16206: database already configured as Logical Standby database
Cause: This database has been previously configured as a Logical Standby database. A Logical Standby database is not capable of processing the requested operation.
Action: Ensure that you entered the command on the correct database as this database is a Logical Standby and is not capable of servicing the request.
ORA-16207: Logical standby dictionary build not permitted.
Cause: A dictionary build is currently in progress. Only one build can be active at a time.
Action: Wait for the active build to complete before invoking a new build.
ORA-16208: Logical standby dictionary build failed to start.
Cause: Failure to start the logical standby dictionary build process (LSP1)"
Action: Check the accompanying messages, and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.
ORA-16209: Logical standby dictionary build failed to complete.
Cause: The logical standby dictionary build process terminated abnormally."
Action: Check the accompanying messages, and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.
ORA-16210: Logical standby coordinator process terminated with error
Cause: The logical standby coordinator process terminated abnormally."
Action: Check the accompanying messages, and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.
ORA-16211: unsupported record found in the archived redo log
Cause: Log apply services encountered a record in the archived redo log that could not be interpreted.
Action: 1. Use DBMS_LOGSTDBY.INSTANTIATE_TABLE to re-create the table on the standby database or simply drop the table if it's unimportant.

2. ALTER DATABASE START LOGICAL STANDBY APPLY;

3. Examine the current_scn column in the DBA_LOGSTDBY_EVENTS view to determine which log file contains the unsupported record.

4. Provide the log file to Oracle Support Services.

ORA-16212: number processes specified for APPLY is too great
Cause: Logical standby apply engine was started with more processes requested than are available.
Action: Adjust the values of the initialization parameters PROCESSES and and PARALLEL_MAX_SERVERS, or the MAX_SLAVES parameter seen in the DBA_LOGSTDBY_PARAMETERS view.
ORA-16213: ddl encountered, stopping apply engine
Cause: stop_on_ddl callout specified and DDL was encountered.
Action: Either disable stop_on_ddl callout or remove DDL.
ORA-16214: apply stalled for apply delay
Cause: A delay has been specified on the primary database for this destination.
Action: Either turn off the delay on the primary or use DBMS_LOGSTDBY.APPLY_UNSET('APPLY_DELAY'); to override.
ORA-16215: history metadata inconsistency
Cause: internal error.
Action: This is an internal error. Contact Oracle support.
ORA-16216: Log stream sequence error
Cause: The log stream being processed did not follow the last processed stream.
Action: If the database is in an active configuration, issue an ALTER DATABASE START LOGICAL STANDBY APPLY NEW PRIMARY command to synchronize log stream data with the current primary database. If the database is not in an active configuration, manually add the next dictionary-begin logfile that followed the previous log stream.
ORA-16217: prepare to switchover has not completed
Cause: An ALTER DATABASE PREPARE TO SWITCHOVER command was issued, but the prepare activity did not complete.
Action: Verify that the standby was prepared properly. You may cancel the prepare and perform an unprepared switchover which requires a database link to complete. Or reissue the prepare operation on the standby.
ORA-16218: This database is already preparing to switch over.
Cause: The database was already preparing to switch over and was not able to accomodate another prepare attempt.
Action: Cancel the current prepare attempt with the ALTER DATABASE PREPARE TO SWITCHOVER CANCEL command, then reissue the prepare request.
ORA-16219: This database is not preparing to switch over.
Cause: The database was not preparing to switch over. Therefore, it was not possible to cancel the SWITCHOVER command.
Action: Preparing for the SWITCHOVER command can be accomplished with the ALTER DATABASE PREPARE TO SWITCHOVER command.
ORA-16220: no failed transaction found
Cause: No failed transaction was found.
Action: Retry the ALTER DATABASE START LOGICAL STANDBY APPLY command without the SKIP FAILED TRANSACTION option.
ORA-16221: history table synchronization error
Cause: internal error.
Action: This is an internal error. Contact Oracle support.
ORA-16222: automatic Logical Standby retry of last action
Cause: A failure occurred while running Logical Standby apply. A new attempt is automatically being made by Logical Standby apply.
Action: No action is necessary. This informational statement is provided to record the event for diagnostic purposes.
ORA-16223: DDL skipped, unsupported in current version
Cause: The given DDL statement was not supported in the current version of Logical Standby and was skipped.
Action: No action is necessary. This informational statement is provided to record the event for diagnostic purposes.
ORA-16224: Database Guard is enabled
Cause: Operation could not be performed because database guard is enabled
Action: Verify operation is correct and disable database guard
ORA-16225: Missing LogMiner session name for Streams
Cause: An attempt was made to register the log file for Streams without a specified LogMiner session name.
Action: Specify a valid LogMiner session name to which the log file will be registered.
ORA-16226: DDL skipped due to lack of support
Cause: Logical Standby does not support this type of DDL in this version, so the DDL is skipped.
Action: The DBA may apply the DDL explicitly at a later time or a procedure to handle this type of DDL can be created. see DBMS_LOGSTDBY.SKIP procedure for details.
ORA-16227: DDL skipped due to missing object
Cause: A table or other database object upon which this DDL depends is not defined on the Logical Standby database.
Action: No action is necessary, this infomational statement is provided to record the event for diagnostic purposes.
ORA-16228: Insufficient recovery for logical standby
Cause: Insufficient amount of recovery was run for logical standby instantiation.
Action: Continue to recover the database using ALTER DATABASE RECOVER MANAGED STANDBY DATABASE.
ORA-16229: PDML child string string string for parent string string string cannot be skipped.
Cause: A request was made to skip a parallel DML child transaction id. This is not supported.
Action: Using the DBMS_LOGSTDBY.UNSKIP_TRANSACTION procedure, remove the child transaction id, then specify the parent transaction id using DBMS_LOGSTDBY.SKIP_TRANSACTION if appropriate.
ORA-16230: committing transaction string string string
Cause: Logical Standby apply was committing changes for the given transaction.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16231: DDL barrier
Cause: Logical Standby was holding back changes until dependent changes were applied.
Action: No action necessary, this informational statement is provided to record the event for diagnostic purposes.
ORA-16232: adding Logical Standby skip entry for table string.string
Cause: Table was previously unsupported due to datatype or storage attribute definitions. Table is now capable of being supported.
Action: To have Logical Standby maintain the table, import that table directly from the primary.
ORA-16233: The table string.string is unsupported now
Cause: Table was previously supported but now is unsupported due to altered datatype or storage attribute definitions.
Action: None.
ORA-16234: restarting to reset Logical Standby apply
Cause: Logical Standby encountered a work load that required a restart to properly reschedule.
Action: No action necessary. This informational statement is provided to record the event for diagnostic purposes.
ORA-16235: DDL skipped because import has occurred
Cause: An object was exported from the primary database and imported into the Logical Standby database. This DDL occurred before the export.
Action: No action necessary. This informational statement is provided to record the event for diagnostic purposes.
ORA-16400: quota attributes are not allowed with DB_RECOVERY_FILE_DEST
Cause: Quota attributes for the destination parameters are not allowed when the parameter DB_RECOVERY_FILE_DEST is defined.
Action: No action is required.
ORA-16401: archivelog rejected by RFS
Cause: An attempt was made to re-archive an existing archivelog. This usually happens because either a multiple primary database or standby database(s) or both are trying to archive to this standby database.
Action: See alert log and trace file for more details. No action is necessary; this is an informational statement provided to record the event for diagnostic purposes.
ORA-16402: ONDEMAND archival requires FAL_CLIENT and FAL_SERVER support
Cause: The archivelog destination TRANSPORT=ONDEMAND attribute was specified on the primary database. Use of the TRANSPORT=ONDEMAND attributes requires that the corresponding standby database explicitly specify the FAL_CLIENT and FAL_SERVER initialization parameters.
Action: Make sure the FAL_CLIENT and FAL_SERVER initialization parameters are explicitly specified on the standby database that received this error.
ORA-16403: shutdown in progress - remote connection is not permitted
Cause: The SHUTDOWN command was used to shut down a running remote primary or standby ORACLE instance, so the LGWR or ARCH processes cannot connect to ORACLE.
Action: Wait for the remote instance to be restarted, or contact your DBA.
ORA-16406: Primary and standby database software version mismatch
Cause: The primary database and standby database Oracle software is not compatible.
Action: Install the correct Oracle software and try again.
ORA-16407: Standby database is in the future of the archive log
Cause: An archive log, from a different Redo Branch, was received by a standby database that has applied Redo in the future of Redo contained within the archive log. The standby database has rejected the REDO Branch archive logs.
Action: No action is required.
ORA-16408: Incompatible archival Redo Branch lineage
Cause: An archive log, from an incompatible different Redo Branch, was received by a standby database. The standby database has rejected the Redo Branch archive logs.
Action: No action is required.
ORA-16409: Archive log switchover reference number mismatch
Cause: The archive log switchover reference numbers of the Primary and Standby database do not match. Remote archival of redo log files is not allowed to incompatible STANDBY database instances.
Action: No action is required.
ORA-16411: ONDEMAND archival requires active managed recovery operation
Cause: The use of the ONDEMAND attribute for a physical standby database destination requires that the managed recovery operation be active prior to establishing the network connection.
Action: Start the managed recovery operation on the standby database.
ORA-16412: ONDEMAND archival requires active SQL apply operation
Cause: The use of the ONDEMAND attribute for a logical standby database destination requires that the SQL apply operation be active prior to establishing the network connection.
Action: Start the SQL apply operation on the standby database.
ORA-16413: Unsupported database type for ONDEMAND archivelog destinations
Cause: The use of the ONDEMAND attribute for a standby database destination is supported for only physical and logical standby database types. Cross-Instance-Archival and repository database types are not valid for the ONDEMAND attribute.
Action: Verify the database corresponding to the archivelog destination is either a physical standby database or a logical standby database.
ORA-16501: the Data Guard broker operation failed
Cause: The Data Guard broker operation failed.
Action: See other messages for details.
ORA-16502: the Data Guard broker operation succeeded with warnings
Cause: The Data Guard broker operation succeeded with warnings.
Action: See other messages for details.
ORA-16503: site ID allocation failure
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16504: The Data Guard configuration already exists.
Cause: A request to create a Data Guard configuration was made while connected to a database that is part of an existing configuration.
Action: Delete the existing configuration if you want to create a new configuration.
ORA-16505: site ID is invalid
Cause: The request contained an invalid site ID.
Action: Make the request again with a valid site iD.
ORA-16506: out of memory
Cause: Process exceeded private or shared memory limits.
Action: Check for memory leaks, increase system parameters and restart.
ORA-16507: unrecognized request identifier
Cause: The specified request identifier was not recognized by the Data Guard broker.
Action: Re-issue the request using a valid request identifier.
ORA-16508: channel handle not initialized
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16509: the request timed out
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16510: messaging error using ksrwait
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16511: messaging error using ksrget
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16512: parameter exceeded maximum size limit
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16513: maximum requests exceeded
Cause: Non-blocking commands were issued but responses are not read or the commands did not complete execution.
Action: Read pending responses or delete outstanding requests and try again.
ORA-16514: the request was not found
Cause: An attempt was made to read a response but a matching request was not found.
Action: Verify request identifier is valid and references a previously issued request.
ORA-16515: no rcv channel
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16516: The current state is invalid for the attempted operation.
Cause: The broker may return this error for switchover operations and for database state change operations. If this error is returned for a switchover operation, the broker has determined that either:

- The databases changing roles are offline.

- The primary database is not shipping log files.

- The standby database that will become the primary is not applying log files. The broker returns this error for database state change operations if the database state specified is invalid.

Action: If this error is returned when attempting a switchover operation, make sure that:

- The databases changing roles are online.

- The primary database is shipping log files.

- The standby database is applying log files. If this error is returned when attempting a database state change operation, make sure you specify a valid state.

ORA-16517: the object handle is invalid
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16518: unable to allocate virtual instance id
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16519: the resource handle is invalid
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16520: unable to allocate resource id
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16521: unable to create generic template id
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16522: generic template not found
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16523: Operation requires the client to connect to instance "string".
Cause: The switchover or failover operation requires the client to connect to the apply instance of the target database.
Action: Connect to the indicated instance and reissue the switchover or failover command.
ORA-16524: unsupported operation
Cause: A command or option is not supported in this release.
Action: Contact Oracle Support Services.
ORA-16525: the Data Guard broker is not yet available
Cause: The Data Guard broker process has not yet been started, is initializing, or has failed to start.
Action: If the broker has not been started, set DG_BROKER_START to true and allow the broker to finish initializing before making the request. If the broker failed to start, check the Data Guard log for possible errors. Otherwise, retry the operation.
ORA-16526: unable to allocate task element
Cause: The Data Guard broker was unable to allocate memory for a request.
Action: Increase the size of your SGA.
ORA-16527: unable to allocate SGA heap
Cause: The Data Guard broker was unable to allocate a heap within the SGA.
Action: Increase SGA memory.
ORA-16528: unable to allocate PGA heap
Cause: No space in PGA to allocate heap
Action: Increase process virtual memory.
ORA-16529: bad sender id
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16530: invalid buffer or length
Cause: A NULL buffer or a length of zero is specified.
Action: Correct command parameters and retry.
ORA-16531: unable to post message
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16532: Data Guard broker configuration does not exist.
Cause: A broker operation was requested that requires an already existing broker configuration.
Action: Create a Data Guard broker configuration prior to issuing other requests.
ORA-16533: inconsistent Data Guard broker state
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16534: no more requests accepted
Cause: The Data Guard broker returns this status when:

- A failover operation has been submitted or is currently is in progress.

- A switchover operation has been submitted or is currently is in progress.

- An instance restart is pending for one or more databases.

Action: Wait until the operation is complete and then re-issue the request.
ORA-16535: CRS is preventing execution of a broker operation.
Cause: A broker operation was underway that required CRS to stop managing the instances of this database, but CRS management could not be stopped on behalf of the broker's request on at least some of the instances, so the broker operation was canceled.
Action: Suspend CRS management of this database using SRVCTL STOP DATABASE -D <name> -O NONE. Then re-issue the broker request.
ORA-16536: unknown object type
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16537: child count exceeded
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16538: no match on requested item
Cause: The Data Guard broker did not recognize the specified property or state name.
Action: Verify command parameters and re-issue the request.
ORA-16539: task element not found
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16540: invalid argument
Cause: One of the arguments for the specified request was invalid for the request type.
Action: Verify arguments and then re-issue the request.
ORA-16541: site is not enabled
Cause: The site specified in the request is not enabled.
Action: Select an enabled site and re-issue the request.
ORA-16542: unrecognized operation
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16543: invalid request made to broker
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16544: Modifying DG_BROKER_START requires SID='*' qualifier
Cause: The setting for the DG_BROKER_START parameter must be exactly the same on all RAC database instances. The SID='*' qualifier was required in the command.
Action: Re-enter the command using the SID='*' qualifier.
ORA-16545: unable to get response
Cause: The Data Guard broker was unable to return the result of a previous request.
Action: Contact Oracle Support Services.
ORA-16546: missing or invalid piece
Cause: The piece of the request to return was not specified or is invalid.
Action: Specify the piece of the response starting from 1.
ORA-16547: cannot disable the primary database
Cause: An attempt was made to explicitly disable broker management of the primary database.
Action: Broker management of the primary database cannot be explicitly disabled. Instead you must disable the entire broker configuration if you wish to disable the primary database.
ORA-16548: object not enabled
Cause: An attempt was made to modify or query a disabled Data Guard object, most likely a database. This error is also returned on an attempt to enable, modify, or query a database that the broker has permanently disabled. A permanently disabled database cannot be re-enabled. The broker permanently disables its management of a database when it detects that the database needs to be reinstantiated. The broker also permanently disables management of a database that lags behind in terms of DRC Unique ID sequence value.
Action: If broker management of the database is not permanently disabled, enable it and re-issue the request.
ORA-16549: invalid string
Cause: A request contains an invalid or NULL string value.
Action: Correct command parameters and retry.
ORA-16550: truncated result
Cause: A string property value was truncated due to insufficient buffer size.
Action: Specify a larger receive buffer.
ORA-16551: short string copied
Cause: A string property value that does not fill the receive buffer has been placed in the receive buffer.
Action: This is an informational message only. It is not an error.
ORA-16552: An error occurred when generating the CLIENT OPERATION table.
Cause: An error occurred while Data Guard broker was generating the CLIENT OPERATION table.
Action: See the next error message in the error stack for more detailed information. If the situation described in the next error in the stack can be corrected, do so; otherwise, contact Oracle Customer Support.
ORA-16553: the Data Guard broker process (DMON) failed to shutdown
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16554: translation not valid
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16555: The Data Guard database is not active.
Cause: An operation was attempted on a database that is currently not active (off path).
Action: Verify that the database is active.
ORA-16556: Error message is in XML already.
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16557: The database is already in use.
Cause: An attempt was made to create a duplicate database in the broker configuration.
Action: Check the database to be added and be sure there are no duplicates.
ORA-16558: The database specified for switchover is not a standby.
Cause: An attempt was made to switchover to a database that is not a standby database.
Action: Locate an enabled standby database and select that database as the target of the switchover.
ORA-16559: out of memory at string
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16560: unable to convert document, syntax error at "string"
Cause: There was an error at the given token.
Action: Correct the errors and submit the request again.
ORA-16561: Cannot remove an active instance.
Cause: The instance to be removed is currently running.
Action: Shut down the instance and reissue the REMOVE command.
ORA-16562: intended_state not used here, syntax error at "string"
Cause: There was an error at the given token.
Action: Correct the errors and submit the request again.
ORA-16563: unable to add value, syntax error at "string"
Cause: There was an error at the given token.
Action: Correct the errors and submit the request again.
ORA-16564: lookup failed, syntax error at string
Cause: There was an error at the given token.
Action: Correct the errors and submit the request again.
ORA-16565: duplicate property, syntax error at "string"
Cause: There was an error at the given token.
Action: Correct the errors and submit the request again.
ORA-16566: unsupported document type
Cause: The XML document submitted is not supported.
Action: Correct the errors and submit the request again.
ORA-16567: Data Guard broker internal parser error at "string"
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16568: cannot set property string
Cause: The named property could not be modified. The property may not be editable or may not exist.
Action: Retry the operation with a valid property.
ORA-16569: Data Guard configuration is not enabled.
Cause: The requested operation required that broker management of the Data Guard configuration must be enabled.
Action: Enable the Data Guard configuration and re-issue the request.
ORA-16570: operation requires restart of database "string"
Cause: The Data Guard broker operation required a given database to be shutdown and restarted.
Action: If the client has not already done so, shutdown the Oracle instance and then restart it.
ORA-16571: Data Guard configuration file creation failure
Cause: The Data Guard broker was unable to create the configuration file on permanent storage.
Action: Verify space, permissions and filename as indicated by the dg_broker_config_file[1|2] parameters and retry.
ORA-16572: Data Guard configuration file not found
Cause: The Data Guard broker configuration file is either unavailable or does not exist.
Action: Verify that the configuration file was successfully created. If the dg_broker_config_file[1|2] parameter was changed, ensure the filename on disk and the parameter value match, there is space on the device, and you have the right permissions.
ORA-16573: attempt to change configuration file for an enabled broker configuration
Cause: The Data Guard broker configuration file parameter was currently in use because broker management of the configuration was enabled. The attempt to alter that parameter was rejected.
Action: Disable the configuration and shut down the Data Guard broker before changing this value. Be sure to rename the configuration file at the OS level to match the new value before reenabling broker management of the configuration.
ORA-16574: switchover disallowed when required databases are offline
Cause: Switchover failed because the primary database and/or the designated standby database are offline.
Action: Check the states of the broker configuration, primary database and standby database. Set their states to ONLINE if necessary.
ORA-16575: request terminated at broker discretion
Cause: This status is returned when the broker terminates a user- initiated request. The broker will terminate all other current and pending requests when it begins processing a failover request. These other requests are terminated with this status.
Action: There is no action to be taken.
ORA-16576: failed to update Data Guard configuration file
Cause: A failure was encountered while the broker was updating the Data Guard broker configuration file on permanent storage.
Action: Verify space, permissions and filename as indicated by the dg_broker_config_file[1|2] parameters.
ORA-16577: corruption detected in Data Guard configuration file
Cause: The Data Guard broker detected errors while loading the configuration file.
Action: Verify space, permissions and filename as indicated by the dg_broker_config_file[1|2] parameters. Contact Oracle Support Services.
ORA-16578: failed to read Data Guard configuration file
Cause: A failure was encountered while the broker was reading the configuration file on permanent storage.
Action: Verify space, permissions and filename as indicated by the dg_broker_config_file[1|2] parameters.
ORA-16579: bad Data Guard NetSlave state detected
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16580: bad Data Guard NetSlave network link
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16581: Data Guard NetSlave failed to send message to DRCX
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16582: Could not edit instance specific property.
Cause: The request intended to change an instance specific property, but specified a database with more than one instance.
Action: Specify a particular instance instead to change the property value.
ORA-16583: bad Data Guard Connection Process DRCX state
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16584: illegal operation on a standby site
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16585: illegal operation on a primary site
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16586: Could not edit database property through instance.
Cause: The request intended to change a database property but specified an instance.
Action: Specify the database instead to change the database property.
ORA-16587: Ambiguous object specified to Data Guard broker
Cause: The request specified an object that the broker could not uniquely distinguish between other objects in the configuration.
Action: Try to further distinguish the object specified for the operation and re-issue the request.
ORA-16588: no more internal buffers
Cause: See trace file.
Action: Contact Oracle Support Services.
ORA-16589: Data Guard Connection process detected a network transfer error
Cause: The Data Guard Connection process (DRCX) detected an error while transferring data from one database to another. This error is returned in the following situations:

- While transmitting the configuration file between databases, DRCX detected an inconsistency in the block count of the file.

- The DRCX process got an error while writing the configuration file.

Action: Contact Oracle Support Services.
ORA-16590: no primary established in Data Guard configuration
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16591: unknown field "string" in document
Cause: There was an error at the given token.
Action: Correct the errors and submit the request again.
ORA-16592: missing field "string" in document
Cause: There was an error at the given token.
Action: Correct the errors and submit the request again.
ORA-16593: XML conversion failed
Cause: There was an error in the XML request document
Action: Correct the errors and submit the request again.
ORA-16594: %s process discovered that DMON process does not exist
Cause: The Data Guard broker process (DMON) that was expected to be running in this instance was found to be missing by the Data Guard NetSlave (NSV*) process(es).
Action: Check the Data Guard broker log and DMON process trace file to determine why the DMON process is missing.
ORA-16595: NetSlave process string failed to terminate
Cause: The specified NetSlave process did not terminate at the request of the Data Guard broker.
Action: Contact Oracle Support Services.
ORA-16596: object not part of the Data Guard broker configuration
Cause: A request was made on a database object that is not in the Data Guard broker configuration. The request cannot be completed.
Action: Re-issue the request on a database object that is in the broker configuration.
ORA-16597: Data Guard broker detects two or more primaries.
Cause: The Data Guard broker detected two or more primary databases in the broker configuration and cannot continue.
Action: Contact Oracle Support Services.
ORA-16598: Data Guard broker detected a mismatch in configuration.
Cause: The Data Guard broker detected a significant mismatch in configuration validation between two or more databases in the broker configuration. This can occur when the primary database has a stale broker configuration file.
Action: Contact Oracle Support Services.
ORA-16599: Data Guard broker detected a stale configuration.
Cause: The Data Guard broker detected a stale configuration during initialization for this database.
Action: The broker will automatically resolve this situation once the primary database completes its initialization.
ORA-16600: Failover operation can only be submitted at target database.
Cause: This error is returned when a failover request specified a different database than the database to which the client is currently connected.
Action: Explicitly connect to the database to which you wish to failover and re-issue the failover request.
ORA-16601: site contains required resources that are disabled
Cause: The Data Guard broker detected disabled, required resources prior to performing an operation that needs those resources to be enabled.
Action: Enable all required resources and re-issue the request.
ORA-16602: Object must be disabled to perform this operation.
Cause: An attempt was made to edit a database object that can only be done while broker management of that database is disabled.
Action: Disable broker management of the database and re-issue the request.
ORA-16603: Data Guard broker detected a mismatch in configuration ID.
Cause: The Data Guard broker for this database detected a mismatch in configuration Unique ID. This can occur if the original configuration was recreated while this database was disconnected from the network or the same database was added to two different broker configurations.
Action: Make sure the database belongs to only one broker configuration. Remove the Data Guard broker configuration files and restart the broker.
ORA-16604: unable to describe template using package "string"
Cause: The Data Guard broker was unable to execute the OnDescribe function in the named package.
Action: Verify that the named package is loaded on the primary database. Also verify that the OnDescribe function is in the package.
ORA-16605: unable to delete template, template is in use
Cause: The Data Guard broker was unable to delete the template because the template is still being used by one or more resources.
Action: Delete all resources using the template before deleting the template. You cannot delete the database template.
ORA-16606: unable to find property "string"
Cause: The named property does not exist.
Action: Specify a valid property name and re-issue the request.
ORA-16607: one or more databases have failed
Cause: The Data Guard broker detected a failure on one or more database in the Data Guard configuration.
Action: Locate the database(s) with a failure status and correct it.
ORA-16608: one or more sites have warnings
Cause: The Data Guard broker detected a warning status on one or more sites.
Action: Locate the site(s) with a warning status and correct it.
ORA-16609: one or more resources have failed
Cause: The Data Guard broker detected a failure on one or more resources on a site.
Action: Locate the resource(s) with a failure status and correct it.
ORA-16610: one or more resources have warnings
Cause: The Data Guard broker detected a warning status on one or more resources on a site.
Action: Locate the resource(s) with a warning status and correct it.
ORA-16611: operation aborted at user request
Cause: The Data Guard broker aborted an operation at the user's request.
Action: No action required.
ORA-16612: string value too long for attribute "string"
Cause: The string value for the named attribute is too long.
Action: Use a shorter string.
ORA-16613: initialization in progress for site
Cause: The site received a directive to change its initialization state or a change in its configuration before it has completed initialization.
Action: Wait until the site has completed initialization before issuing requests to modify run-time state or configuration.
ORA-16614: object has an ancestor that is disabled
Cause: A request to enable an object that has an ancestor that is disabled was received by the broker. The broker has enabled management of the object to the extent that it can, but cannot fully enable the object until its ancestor is enabled.
Action: Determine the ancestor object that is disabled and enable that ancestor prior to enabling the child object.
ORA-16617: unknown object identifier specified in request
Cause: The Data Guard broker returned this error because the object identifier specified in the request was invalid or unknown. For example, this error is returned if an invalid or unknown database object identifier is specified in a request that requires a database object identifier.
Action: Verify that a valid object identifier was specified in the request and then re-issue the request.
ORA-16618: response document of size "string" bytes is too large
Cause: The document response cannot be returned because the size of the document is too large. This can occur when displaying the Data Guard broker log.
Action: View the broker log for the given database directly.
ORA-16619: Health Check timed out
Cause: This status is returned when the Data Guard broker could not reach a standby database during a routine health check.
Action: This typically indicates a network problem where the standby database is unable to respond to the primary within a pre-defined time frame.
ORA-16620: one or more databases could not be contacted for a delete operation
Cause: The Data Guard broker could not reach one or more standby databases for either a delete database operation or a delete broker configuration operation.
Action: This typically indicates a network problem where the standby database is unable to respond to the primary. In the event of this situation, examine the Data Guard broker log for the primary database to determine which standby databases could not be reached. Then for each standby database not reached, connect to that database and shut down the broker by setting the initialization parameter, dg_broker_start, to false. After the broker has been shut down for the standby database, locate the Data Guard broker configuration files from the standby's dg_broker_config_file[1|2] parameter values and delete them.
ORA-16621: Database name for ADD DATABASE must be unique.
Cause: An attempt was made to add a database to the broker configuration that already includes a database with the specified name. The database names must be unique.
Action: Verify that you have specified a unique name for the new database you wish to add. This can be done by checking that there is no database with the same name. Also note that the database name must match the DB_UNIQUE_NAME initialization parameter of the database.
ORA-16622: Two or more broker database objects resolve to one physical database.
Cause: The Data Guard broker determined that there were multiple database objects referring to the same physical database.
Action: Examine the details of all databases in the broker configuration and verify that there are not two or more databases that indicate the same physical database. If you detect this situation, remove and re-add the erroneously defined database(s) to resolve the ambiguity.
ORA-16623: stale DRC UID sequence number detected
Cause: The Data Guard broker detected a stale sequence value during its bootstrap or health check operations. The sequence value is changed each time a role change occurs. A database that is unavailable to participate in the role change operation will end up with a stale sequence number. Should the broker for that database attempt to re-join the broker configuration, the broker will determine that it missed a role change and will disable its management of that database. The broker permanently disables the database since it may no longer be a viable standby for the new primary.
Action: Examine the broker configuration for databases that were permanently disabled and which may require reinstantiation.
ORA-16624: broker protocol version mismatch detected
Cause: The broker detected a network protocol version number mismatch. This can happen if the databases in question are not at the same version of Oracle. The broker will permanently disable management of the databases that do not have the same network protocol version number as the primary.
Action: Examine the version of Oracle installed for all databases to make sure they are identical. Once the Oracle versions are the same for all databases, remove and re-add to the broker configuration those databases that had been permanently disabled.
ORA-16625: cannot reach the primary
Cause: The broker rejected a write operation requested by the client when the primary database is not reachable from the database where the request was made. All modifications made to the Data Guard broker configuration must be processed by the copy of the broker running in the instance for the primary database.
Action: Check your network connection between the database to which your client is connected and the primary database. Alternatively, you can connect your client to a different database in the Data Guard broker configuration and try your request again.
ORA-16626: failed to enable specified object
Cause: The broker failed to enable management of an object (most likely a standby database). You can expect to see this status when attempting to enable broker management of a standby database that:

- cannot locate itself in the broker configuration file.

- fails to distinguish itself from two or more databases in the configuration file.

- determines it was not part of a change of primary due to failover.

Action: To correct the problem, try one of these actions:

- confirm that the host and SID names for the database exactly match the values in the HOST_NAME and INSTANCE_NAME columns of V$INSTANCE.

- confirm that you have not created two or more databases with the same connect identifier. That is, multiple databases in the broker configuration should not indicate the same physical database.

- if you had performed a failover and have re-instantiated your old primary database (or a standby database that had to be reinstantiated), make sure the Data Guard broker configuration files have been removed for that database. Do NOT remove the configuration files that are in use by the new primary.

ORA-16627: No standby databases support the overall protection mode.
Cause: This status is returned in the following situations:

- The broker rejects an attempt to change the configuration's overall protection mode since it could not find any online, enabled standby databases that support the proposed protection mode.

- The broker rejects an attempt to enable the configuration if it determines there are no online, enabled standby databases that support the overall protection mode.

- The broker rejects an attempt to disable or remove a database that, if disabled or deleted, would result in no remaining standby databases that can support the configuration's overall protection mode.

- The broker rejects an attempt to set the configuration offline if doing so would violate the configuration's overall protection mode.

- The broker rejects an attempt to set a standby database offline if doing so would violate the configuration's overall protection mode.

- The broker rejects a switchover attempt if doing so would violate the configuration's overall protection mode.

- The broker returns this error during a health check.

Action: - If changing the overall protection mode, confirm that at least one standby database satisfies the new protection mode.

- For enable failures, confirm that at least one standby database has a LogXptMode configuration property setting that supports the current overall protection mode.

- For delete and disable failures, confirm that at least one other standby database has a LogXptMode configuration property setting that supports the overall protection mode.

- For state change failures, confirm that at least one other standby database has a LogXptMode configuration property setting that supports the overall protection mode. If setting the configuration OFFLINE you may have to downgrade the protection mode setting to maximum performance beforehand.

- For switchover failures, confirm that at least one other standby database has a LogXptMode configuration property setting that supports the overall protection mode. If your configuration contains a primary and a single standby, ensure that the LogXptMode configuration property established for the primary database supports the overall protection mode. After the switchover, the old primary will become the standby and its LogXptMode configuration property setting must support the overall protection mode.

- For health check error, confirm that at least one standby database has a LogXptMode configuration property setting that supports the current overall protection mode.

ORA-16628: The broker protection mode is inconsistent with the database setting.
Cause: The Data Guard broker protection mode saved in the broker's configuration file was inconsistent with the actual database setting.
Action: Reset the protection mode through the Data Guard broker.
ORA-16629: Database reports a different protection level from the protection mode.
Cause: The actual protection level supported by the standby database was different from the protection mode set on the primary. This was likely caused by log transport problems.
Action: Check the database alert logs and Data Guard broker logs for more details. Check the log transport status. Make sure at least one standby log transport is supporting the protection mode and that the network to the standby is working.
ORA-16630: That database property was deprecated.
Cause: The property that was specified in the user operation was a deprecated property.
Action: Check the broker documentation to identify a replacement property or issue a SQL command to achieve the same result if no such replacement property exists.
ORA-16631: Operation requires shutdown of database/instance "string"
Cause: The Data Guard broker operation requires a shutdown of the database or instance.
Action: If the client has not yet done so, please shutdown all Oracle instances for the database.
ORA-16632: instance being added to database profile
Cause: The Data Guard broker determined that an instance has successfully found its database profile within the broker configuration file, but yet lacks an instance-specific profile. The broker automatically creates an instance-specific profile and associates the instance with its database profile.
Action: No user action is required. The broker will automatically associate the instance with its database profile and incorporate the instance in broker activity.
ORA-16633: The only instance of the database cannot be removed.
Cause: The instance to be removed was the only instance of the corresponding database that is known to the broker.
Action: Remove the corresponding database object from the broker configuration instead of that individual instance object of the database.
ORA-16635: NetSlave connection was broken in the middle of a transmission session.
Cause: The Data Guard NetSlave process detected a connection failure to a remote database in the broker configuration. This failure happened in the middle of a transmission session. A transmission session usually requires more than one send operation for sending a large amount of data (e.g. the broker configuration file) to the remote database. This error implies the transmission has to be re-started from the beginning.
Action: In most cases, no user action is required. The Data Guard broker always tries to re-send the data from the beginning. If the problem persists, the user will eventually see this error reported. This will indicate there are some problems with the network connection between broker managed databases. Further network troubleshooting should be done to identify and address the actual problem.
ORA-16636: the object is permanently disabled
Cause: A broker operation was attempted on a database that is permanently disabled. This occurs when the broker detects that this database cannot function as a viable standby to the current primary database, generally following a role change, i.e., failover or switchover.
Action: Remove the database from the broker configuration, reinstantiate the database and then add it back into the configuration.
ORA-16637: An instance failed to access the Data Guard broker configuration.
Cause: When an instance was started, the DMON process on the instance failed to access the Data Guard broker configuration. This can happen if the DG_BROKER_CONFIG_FILE1 and DG_BROKER_CONFIG_FILE2 initialization parameters are not set up correctly to point to the broker configuration files shared among all instances.
Action: Set DG_BROKER_CONFIG_FILE1 and DG_BROKER_CONFIG_FILE2 to the correct file specifications that point to the broker configuration files shared among all instances. Bounce the DMON process by setting DG_BROKER_START initialization parameter to FALSE and then to TRUE.
ORA-16638: could not get the instance status
Cause: The broker failed to check whether the given instance was alive or not.
Action: See the next error message in the error stack for more detailed information. If the situation described in the next error in the stack can be corrected, do so; otherwise, contact Oracle Support Services.
ORA-16639: specified instance inactive or currently unavailable
Cause: An attempt was made to perform an operation on an instance that was not running or was unavailable.
Action: Ensure that the instance specified in the operation is running and then retry the operation.
ORA-16640: CRS warns that multiple instances may still be running.
Cause: A broker operation was underway that required CRS to stop monitoring the instances of this database and to shut down all but one instance. Although instance monitoring has ceased, CRS cannot guarantee that only one instance remains running. The broker operation was canceled.
Action: Suspend CRS management of this database using SRVCTL STOP DATABASE -D <name> -O NONE. Then re-issue the broker request.
ORA-16641: failure to acquire broker configuration metadata lock
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16642: db_unique_name mismatch
Cause: The expected db_unique_name value did not match the actual db_unique_name value for the database that the broker contacted using the connect identifier that was associated with that database.
Action: Verify that the connect identifier correctly connects to the intended database. Verify that the name of the database that the broker expects to find via that connect identifier matches the actual db_unique_name for that database.
ORA-16643: unable to determine location of broker configuration files
Cause: The Data Guard broker was unable to determine the location of its configuration files from the DG_BROKER_CONFIG_FILE[1|2] initialization parameters.
Action: Retry the operation and if the error persists, contact Oracle Support Services.
ORA-16644: apply instance not available
Cause: The broker operation could not finish, because it requires a running apply instance for the standby database, and either there was no such instance designated for the standby database or the designated apply instance was not currently available.
Action: Start the designated apply instance or wait until the broker specifies an instance to be the apply instance and issue the command again.
ORA-16645: unexpected new instance interrupted current operation
Cause: A new instance unexpectedly joined the Data Guard configuration at a point when the current operation may proceed only if the set of known instances is not changing dynamically.
Action: Reissue the operation after the new instance has joined the Data Guard configuration.
ORA-16700: The standby database has diverged from the primary database.
Cause: The primary database may have been flashed back or restored from a backup set and then re-opened with the RESETLOGS option.
Action: Reinstantiate the standby database from the primary database.
ORA-16701: generic resource guard request failed
Cause: Request to modify or query the resource failed.
Action: Check the Data Guard broker log for the reason for the failure, and re-issue the request.
ORA-16702: generic resource manager warning
Cause: Request to modify or query the resource resulted in a warning.
Action: Check the Data Guard broker log for the reason for the warning, and if necessary re-issue the request.
ORA-16703: cannot set the property while the database is enabled
Cause: The property was protected from being updated while the database it belongs to is enabled in the Data Guard broker configuration.
Action: Disable broker management of the database first, then update the property and re-enable the database.
ORA-16704: Cannot set the property because it is read-only
Cause: The property is protected from being updated by the user directly.
Action: The property is controlled internally by the Data Guard broker so do not try to update the property value.
ORA-16705: severe internal error in resource guard
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16706: no resource guard is available
Cause: No resource guard is available to service the request.
Action: Contact Oracle Support Services.
ORA-16707: The value of the property string is invalid. The valid values are string.
Cause: An invalid property value was entered while broker management of the database was disabled.
Action: Reset the value to a correct one.
ORA-16708: The state supplied to resource guard is invalid.
Cause: The state name specified is invalid for the database.
Action: Check the state name and re-issue the request.
ORA-16709: standby archived log location settings in conflict with flash recovery area
Cause: The flash recovery area was already set up on the standby database for storing incoming archived logs from the primary database. In this case, StandbyArchiveLocation and AlternateLocation properties should not be used for setting up standby archived log location. The Data Guard broker raised this error because it detected one of the following: (1) the user attempted to use StandbyArchiveLocation or AlternateLocation properties to set up a standby archived log location; (2) On the standby database, some local destination corresponding to the StandbyArchiveLocation or AlternateLocation properties was still set up to store archived logs from the primary database.
Action: If you get this error when trying to set property StandbyArchiveLocation or AlteranteLocation (case (1) above), avoid setting these properties again. If you get this error after a broker health check (case (2) above), re-enable the standby database to clear the error.
ORA-16710: The resource guard is out of memory.
Cause: The resource guard was unable to allocate memory while trying to service a request.
Action: Disable broker management of the configuration, shut down Oracle, increase SGA size, and restart.
ORA-16711: the resource guard index is out of bounds
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16712: the resource handle is invalid
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16713: The resource guard timed out while servicing the request.
Cause: The resource guard timed out while servicing the request.
Action: Verify that the operation is valid for the database and then re-issue the request.
ORA-16714: The value of property string is inconsistent with the database setting.
Cause: d by a user operation on the database outside of the Data Guard broker's control.
Action: Query property InconsistentProperties on the database to find out the inconsistent values. Reset the property to make it consistent with the database setting.
ORA-16715: Log transport related property string of standby "string" is inconsistent.
Cause: d by a user operation on the database outside of the Data Guard broker's control.
Action: Query property InconsistentLogXptProps on the primary find out the inconsistent values. Reset the property on the standby to make it consistent with the primary's log transport setting.
ORA-16716: clearing parameter LOG_ARCHIVE_DEST failed
Cause: An attempt to clear the LOG_ARCHIVE_DEST parameter failed.
Action: Contact Oracle Support Services.
ORA-16717: clearing parameter LOG_ARCHIVE_DUPLEX_DEST failed
Cause: An attempt to clear the LOG_ARCHIVE_DUPLEX_DEST parameter failed.
Action: Contact Oracle Support Services.
ORA-16718: failed to locate the database resource
Cause: The resource guard was unable to locate the database in the broker configuration.
Action: Add the database to the broker configuration and then re-issue the request.
ORA-16719: unable to query V$ARCHIVE_DEST fixed view
Cause: SQL command to query V$ARCHIVE_DEST failed.
Action: Test and clear the problem using SQL*Plus.
ORA-16720: no available LOG_ARCHIVE_DEST_n parameters to use
Cause: All LOG_ARCHIVE_DEST_n parameters have been defined.
Action: Set some of the LOG_ARCHIVE_DEST_n parameters to empty string.
ORA-16721: unable to set LOG_ARCHIVE_DEST_n parameters
Cause: An attempt of setting some of the LOG_ARCHIVE_DEST_n parameters failed.
Action: Check the Data Guard broker log and database alert logs for further details.
ORA-16722: unable to set LOG_ARCHIVE_DEST_STATE_n parameters
Cause: An attempt to set some of the LOG_ARCHIVE_DEST_STATE_n parameters failed.
Action: Check the Data Guard broker log and database alert logs for further details.
ORA-16723: Setting AlternateLocation property conflicts with the log transport setting.
Cause: The standby database is not using standby redo logs, and the log transport service to the standby database is set with a nonzero value of ReopenSecs and a zero value of MaxFailure. Under such setting, the log transport service will retry the standby destination indefinitely and never switch to the alternate destination.
Action: Any one of the following actions will solve the problem: (1) add standby redo logs to the standby database; (2) set ReopenSecs property to zero; (3) set MaxFailure property to a nonzero value. After executing one of the above actions, reset the AlternateLocation property.
ORA-16724: the intended state for the database has been set to OFFLINE
Cause: The intended state of the database has been set to offline.
Action: If broker management of the database is currently enabled, set its state to online.
ORA-16725: the phase supplied to resource manager is invalid
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16726: the external condition supplied to resource manager is invalid
Cause: Internal error
Action: Contact Oracle Support Services.
ORA-16727: resource guard cannot close database
Cause: The resource guard could not close the database.
Action: Check if there any active sessions connect to the database, terminate them, then re-issue the request.
ORA-16728: Checking the consistency of property string hits error string.
Cause: The property consistency check failed on the property due to the error specified.
Action: Check the error message that follows and clear the error.
ORA-16729: Validating the value of property string hits error string.
Cause: The property value validity check failed on the property due to the error specified.
Action: Check the error message that follows and clear the error.
ORA-16730: Error executing dbms_logstdby.skip_txn procedure
Cause: Logical standby package may not be installed.
Action: Install logical standby packages and re-issue the request.
ORA-16731: Error executing dbms_logstdby.unskip_txn procedure
Cause: Logical standby package may not be installed.
Action: Install logical standby packages and re-issue the request.
ORA-16732: Error executing dbms_logstdby.skip procedure
Cause: Logical standby package may not be installed.
Action: Install logical standby packages and re-issue the request.
ORA-16733: Error executing dbms_logstdby.unskip procedure
Cause: Logical standby package may not be installed.
Action: Install logical standby packages and re-issue the request.
ORA-16734: Error executing dbms_logstdby.skip_error procedure
Cause: Logical standby package may not be installed.
Action: Install logical standby packages and re-issue the request.
ORA-16735: Error executing dbms_logstdby.unskip_error procedure
Cause: Logical standby package may not be installed.
Action: Install logical standby packages and re-issue the request.
ORA-16736: unable to find the destination entry of standby "string" in V$ARCHIVE_DEST
Cause: Either the standby destination was manually changed or deleted outside the Data Guard broker's control, or no entry was available for Data Guard broker.
Action: Clean up destination setting, remove the unused ones, and reset the log transport service.
ORA-16737: The log transport service for standby "string" has an error.
Cause: A problem in communicating with the standby caused the log transport to fail.
Action: Query the LogXptStatus property to see the error message. Check the Data Guard broker log and Oracle Alert log for further details.
ORA-16738: log tranport service for standby "string" unexpectedly offline
Cause: The log transport service for the standby was offline instead of online.
Action: Check the Data Guard broker log for further details. If necessary, start the log transport service.
ORA-16739: log transport service for standby "string" unexpectedly online
Cause: The log transport service for the standby was online instead of offline.
Action: Check the Data Guard broker log for further details. If necessary, stop the log transport service for the standby database.
ORA-16740: log transport service for standby "string" incorrectly set to ALTERNATE.
Cause: Log transport service for the standby is currently set to ALTERNATE while no other destination is set to alternate to this destination.
Action: Reset the database state to turn on log transport again if necessary.
ORA-16741: The destination parameter of standby "string" has the wrong syntax.
Cause: The destination defined in the INIT.ORA file has the wrong syntax, and the Data Guard broker failed to update the destination when the log transport is turned on.
Action: Fix the syntax error in the INIT.ORA file or remove the entry from the INIT.ORA file. Check for correct syntax for the log transport related properties.
ORA-16742: The standby "string" has used up its quota.
Cause: The standby has used up its quota for storing archived redo logs.
Action: Remove some archived logs at the standby database or increase its quota.
ORA-16743: The status of log transport service for standby "string" is unknown.
Cause: The log transport to the standby had an unknown status.
Action: Check the Data Guard broker log and Oracle Alert log for further details.
ORA-16744: The DG_CONFIG list of LOG_ARCHIVE_CONFIG parameter is full.
Cause: The DG_CONFIG list of the LOG_ARCHIVE_CONFIG attribute was full and the Data Guard broker was not able to add a new DB_UNIQUE_NAME to the list.
Action: Remove some unused entries in the DG_CONFIG list, then re-enable the database.
ORA-16745: unable to add DB_UNIQUE_NAME string into The DG_CONFIG list because it is full
Cause: The DG_CONFIG list of the LOG_ARCHIVE_CONFIG attribute was full and the Data Guard broker was not able to add the specified DB_UNIQUE_NAME to the list.
Action: Remove some unused entries in the DG_CONFIG list, then re-enable the database.
ORA-16746: Resource guard encountered error during database mount
Cause: The resource guard could not mount the database.
Action: Check the Data Guard broker log for further details.
ORA-16747: Logical standby guard could not be turned on
Cause: The resource guard could not turn on the logical standby guard.
Action: Check the Data Guard broker log for further details.
ORA-16748: Resource guard encountered errors during database open
Cause: The resource guard could not open the database.
Action: Check the Data Guard broker log for further details.
ORA-16749: Resource guard encountered errors in switchover to logical primary
Cause: The resource guard could not prepare to switch to logical primary.
Action: Check the Data Guard broker log for further details.
ORA-16750: Resource guard encountered errors while activating logical primary
Cause: The resource guard could not activate logical primary.
Action: Check the Data Guard broker log for further details.
ORA-16751: Resource guard encountered errors in switchover to primary
Cause: The resource guard could not prepare to switch to primary.
Action: Check the Data Guard broker log for further details.
ORA-16752: Resource guard could not mount standby
Cause: The resource guard could not mount the standby database.
Action: Check the Data Guard broker log for further details.
ORA-16753: Resource guard could not open standby database
Cause: The resource guard could not open the standby database.
Action: Check the Data Guard broker log for further details.
ORA-16754: Resource guard could not activate standby
Cause: The resource guard could not activate the standby.
Action: Check the Data Guard broker log for further details.
ORA-16755: failed to set initialization parameter
Cause: The ALTER SYSTEM SET or ALTER SYSTEM RESET command issued by the Data Guard broker failed.
Action: Check the Data Guard broker log for further details.
ORA-16756: Resource guard could not open standby readonly
Cause: The resource guard could not open the standby readonly.
Action: Check the Data Guard broker log for further details.
ORA-16757: Resource guard could not get property
Cause: The resource guard failed to get the specified property.
Action: Check the Data Guard broker log for further details.
ORA-16758: The specified apply instance is not running.
Cause: The apply instance specified by the user is not running, so the Data Guard broker cannot move apply service to that instance.
Action: Start that instance first.
ORA-16759: Resource guard unable to start logical apply engine with initial SCN
Cause: The resource guard failed to start the logical apply engine with an initial SCN.
Action: Check the Data Guard broker log for further details.
ORA-16760: Resource guard could not start logical apply engine
Cause: The resource guard failed to start the logical apply engine.
Action: Check the Data Guard broker log for further details.
ORA-16761: Resource guard could not stop logical apply engine
Cause: The resource guard failed to stop the logical apply engine.
Action: Check the Data Guard broker log for further details.
ORA-16762: Invalid database state
Cause: Database is not in the intended state.
Action: Determine the reason for invalid state, and re-issue get status request.
ORA-16763: log transport service for some standby database unexpectedly online
Cause: The log transport service for some standby database was online instead of offline.
Action: Query StatusReport property for further details. If necessary, stop the log transport service for the database.
ORA-16764: log tranport service for some standby database unexpectedly offline
Cause: The log transport service for some standby database is offline instead of online.
Action: Query StatusReport property for further details. If necessary, start the log transport service.
ORA-16765: Physical apply service unexpectedly online
Cause: Physical apply service is online when it should be offline.
Action: If necessary, stop the physical apply service.
ORA-16766: Physical apply service unexpectedly offline
Cause: Physical apply service is offline when it should be online.
Action: If necessary, start the physical apply service.
ORA-16767: Logical apply service unexpectedly online
Cause: Logical apply service is online when it should be offline.
Action: If necessary, stop the logical apply service.
ORA-16768: Logical apply service unexpectedly offline
Cause: Logical apply service is offline when it should be online.
Action: If necessary, start the logical apply service.
ORA-16769: The physical standby database is incorrectly put into read-only state.
Cause: All instances in the physical standby database were put into a read-only state instead of log-apply-off.
Action: Issue the set state command to move the database to log-apply-off state.
ORA-16770: physical standby database not in read-only state.
Cause: All instances in the physical standby database were put into a log-apply-off state instead of read-only.
Action: Issue the set state command to move the database to read-only state.
ORA-16771: Converting physical standby to primary failed in the failover operation.
Cause: In the failover operation, the step of converting the physical standby database to the primary database failed.
Action: Check the alert log and the Data Guard broker log for more details about the error.
ORA-16772: Error in switching over between primary and standby databases
Cause: There was an error during switchover of primary and standby databases.
Action: Check the Data Guard broker log for further details.
ORA-16773: Error in starting the physical apply service (MRP process)
Cause: There was an error in starting the physical apply service (MRP process).
Action: Check the Data Guard broker log for further details.
ORA-16774: Error in stopping the physical apply service (MRP process)
Cause: There was an error in stopping the physical apply service (MRP process).
Action: Check the Data Guard broker log for further details.
ORA-16775: Target standby in switchover operation has missing redo logs.
Cause: The target standby database in a switchover operation did not have all the redo logs from the primary database. The switchover cannot continue in this case.
Action: Query SendQEntries to see what are the missing logs. Make sure log transport service is functioning correctly. Do some log switches on the primary and wait for the gap fetching mechanism to re-ship all the missing redo logs. Issue the switchover command again when there is no missing redo logs on the target standby database.
ORA-16776: Health check of the log transport service failed.
Cause: Due to some internal failure, the database resource guard could not complete the health check of the log transport service.
Action: Check the Data Guard broker log and Oracle Alert log for further details.
ORA-16777: unable to find the destination entry of a standby in V$ARCHIVE_DEST
Cause: Either a destination was manually deleted or no entry was available for Data Guard.
Action: Check the Data Guard broker log and the Oracle Alert log for further details. The log transport service may need to be reset.
ORA-16778: log transport error for one or more databases
Cause: Some problem in communicating with a standby database causes the log transport to fail.
Action: Check the Data Guard broker log and Oracle Alert log for further details. Query the LogXptStatus property to see the error message.
ORA-16779: The destination parameter of some database has wrong syntax.
Cause: The destination was defined in the INIT.ORA file with wrong syntax. The Data Guard broker failed to update the destination when the log transport was turned on.
Action: Check the Data Guard broker log to see which database has the problem. Fix the syntax error in the INIT.ORA file or remove the entry from the INIT.ORA file. Check if the syntax of the log transport related properties are correct.
ORA-16780: Destination to some database has used up its quota.
Cause: Some database has used up its quota for storing archived redo logs.
Action: Check the Data Guard broker log to see which database has the problem. Remove some archived logs at the standby database or increase its quota.
ORA-16781: The status of log transport service for some database is unknown
Cause: Log transport to some database had an unknown status.
Action: Check the Data Guard broker log and Oracle Alert log for further details.
ORA-16782: some instance not open for read and write access
Cause: An instance was left in a mounted mode and was not open for read and write access.
Action: Query the StatusReport property for more details. Open the instance manually or by reenabling the database through the Data Guard broker.
ORA-16783: instance string not open for read and write access
Cause: The instance was left in a mounted mode and was not open for read and write access.
Action: Open the instance manually or by reenabling the database through the Data Guard broker.
ORA-16784: The database object name given in property Dependency is incorrect.
Cause: The database object name, which should be the value of the DB_UNIQUE_NAME initialization parameter, provided in property Dependency is incorrect.
Action: Reset property to the correct name of the database.
ORA-16785: The database is not in ARCHIVELOG mode
Cause: The database is in NOARCHIVELOG mode, when it is either a primary database or a standby database that is being switched over to be a primary database.
Action: Reset the primary database to ARCHIVELOG mode by issuing ALTER DATABASE ARCHIVELOG command.
ORA-16786: Resource guard cannot access Data Guard metadata
Cause: The Data Guard broker configuration files did not exist or for some other reason the resource guard could not access the Data Guard configuration metadata.
Action: Check the Data Guard broker log for further details.
ORA-16788: Unable to set one or more database configuration property values
Cause: This situation occurs when the database resource guard attempts to set database configuration property values into the database by issuing "ALTER SYSTEM" or "ALTER DATABASE" command. Typical causes of this error are: a) The values of log transport related properties have syntax errors; b) The Value of LogArchiveTrace is out of range; c) Database initialization parameter STANDBY_FILE_MANAGEMENT cannot be set to AUTO because the database compatability is not set to 9.0.0.0.0 or higher.
Action: Check the Data Guard broker log to see which property has the problem and reset the property correctly.
ORA-16789: Missing standby redo logs
Cause: Standby redo logs are missing when needed for certain log transport modes.
Action: Check the Data Guard documentation to create standby redo logs on the standby.
ORA-16790: The value of the configurable property is invalid
Cause: User entered an invalid property value.
Action: Reset the value to a correct one.
ORA-16791: Unable to check the existence of the standby redo logs
Cause: The database may not be mounted, or the query of V$STANDBY_LOG failed.
Action: Bring the database to an online state, or fix the problem during the query of V$STANDBY_LOG.
ORA-16792: Some configurable property value is inconsistent with the database setting.
Cause: d by a user operation on the database outside of the Data Guard broker's control.
Action: Query property InconsistentProperties on the database or check the Data Guard broker log to find which properties are inconsistent. Reset these properties to make them consistent with the database settings.
ORA-16793: Logical Standby Database Guard is unexpectedly OFF
Cause: The logical standby database guard is OFF.
Action: Issue the 'alter database guard all' to turn the guard ON and verify that Data Guard health check error/warning is cleared.
ORA-16794: Database Guard is ON for primary database
Cause: Primary database has database guard ON, which is not normal.
Action: Issue the 'alter database guard none' to turn the guard OFF and verify that Data Guard health check error/warning is cleared.
ORA-16795: Database resource guard detects that database reinstantiation is required
Cause: In the act of failover or switchover, the database resource guard may detect that reinstantiation of the database is necessary due to the impending role change. This occurs when the database resource guard recognizes a situation in which the the database in question cannot be a viable standby database for the new primary database.
Action: Reinstantiate (or flashback) the database indicated by the broker and then re-enable broker management of that database in the broker configuration.
ORA-16796: One or more properties could not be imported from the database.
Cause: The broker was unable to import property values for the database being added to the broker configuration. This error indicates:

- the net-service-name specified in DGMGRL's CREATE CONFIGURATION or ADD DATABASE command is not one that provides access to the database being added, or

- there are no instances running for the database being added.

Action: Remove the database from the configuration using the REMOVE CONFIGURATION or REMOVE DATABASE command. Make sure that the database to be added has at least one instance running and that the net-service-name provides access to the running instance. Then reissue the CREATE CONFIGURATION or ADD DATABASE command.
ORA-16797: SPFILE is missing in the Data Guard broker environment
Cause: SPFILE (server parameter file) is not being used in the database, or the resource guard failed to retrieve the status of the SPFILE.
Action: Issue "CREATE SPFILE='..' FROM PFILE='...'" command to create an SPFILE, and restart the database to use the SPFILE.
ORA-16798: Unable to complete terminal recovery on the standby
Cause: Terminal recovery on the standby failed during the failover operation.
Action: Check Data Guard broker log and alert logs to see more details on the reason of the failure.
ORA-16799: Physical apply service is offline
Cause: Either the Data Guard metadata indicates the physical apply service is turned off, or the recovery process MRP0 is not running. In either of the cases, physical apply related properties cannot be set.
Action: Turn on the physical apply service through Data Guard broker, then reset the physical apply related property again.
ORA-16800: Log transport service for some database is incorrectly set to ALTERNATE.
Cause: Log transport service for some database was set to ALTERNATE while no other destinations were set to alternate to this destination.
Action: Check the Data Guard broker log for further details. Reset database state to turn on log transport again if necessary.
ORA-16801: Some log transport related property is inconsistent.
Cause: The values of one or more log transport related configurable properties of a standby database were inconsistent with the primary's log transport service settings. This may be caused by a user operation on the database outside of the Data Guard broker's control.
Action: Query property InconsistentLogXptProps on the primary or Check the Data Guard broker log to find which properties are inconsistent. Reset these properties on the appropriate standby to make them consistent with the primary's log transport settings.
ORA-16802: downgrading log transport mode from SYNC disallowed
Cause: An attempt was made to downgrade the log transport mode of a standby database from SYNC to ASYNC or ARCH when the configuration was in Maximum Protection or Maximum Availability mode and the primary database was a RAC database. This is not allowed, even if there are other standby databases with log transport modes set to SYNC to support the data protection mode.
Action: You can do one of the following if you need to downgrade the log transport mode of the standby: (1) Shut down all instances of the primary database and restart one instance with initialization parameter CLUSTER_DATABASE set to FALSE. Downgrade the log transport mode, shutdown the instance, and restart all instances with CLUSTER_DATABASE set to TRUE. (2) Downgrade the protection mode to Maximum Performance mode first. Then downgrade the log transport mode, then upgrade the protection mode again (which involves a shutdown and restart of the primary database). Note that the above only works when there exists at least one more standby database in the configuration that has the log transport mode set to SYNC.
ORA-16803: Unable to query a database table or fixed view.
Cause: Failed to query a database table or fixed view. The database may not be open or mounted.
Action: Check Data Guard broker log for more details.
ORA-16804: One or more configuration properties in metadata have invalid values.
Cause: Data Guard broker health check detected that one or more configuration properties in the broker's configuration metadata have invalid values. They may have been entered at a time when broker management of the database is disabled.
Action: Check Data Guard broker log for more details on which properties have invalid values and reset them through the Data Guard broker.
ORA-16805: Change of LogXptMode property violates overall protection mode.
Cause: The standby database resource guard rejected the attempt to change the LogXptMode configuration property for the standby database. The rejection was necessary to avoid violating the overall protection mode for the configuration.
Action: If the LogXptMode configuration property must be changed for the specified standby database, first downgrade the overall protection mode for the broker configuration. After that operation has completed, you will be able to change the LogXptMode configuration property for the standby database.
ORA-16806: Supplemental logging is not turned on.
Cause: Supplemental logging was not turned on while there is a logical standby database in the configuration. This could happen either on the primary or on the logical standby that is being switched over to be the primary.
Action: Check Data Guard broker log for more details. Issue "ALTER DATABASE ADD SUPPLEMENTAL LOG DATA (PRIMARY KEY, UNIQUE INDEX) COLUMNS" to add supplemental logging.
ORA-16807: unable to set protection mode to the database
Cause: An attempt to issue an ALTER DATABASE SET STANDBY TO ... statement failed.
Action: Check the Oracle alert log and Data Guard broker log for more information.
ORA-16808: unable to resolve the full path name
Cause: An attempt to resolve the full path name from a string failed.
Action: Check the Data Guard broker log for the full error stack. It is likely to be an OS error.
ORA-16809: multiple warnings detected for the database
Cause: The broker has detected multiple warnings for the database.
Action: Check the StatusReport monitorable property of the database specified.
ORA-16810: multiple errors or warnings detected for the database
Cause: The broker detected multiple errors or warnings for the database.
Action: Check the StatusReport monitorable property of the database specified.
ORA-16811: apply instance not recorded by the Data Guard broker
Cause: An apply instance is needed but the Data Guard broker has no record about the apply instance.
Action: Re-enable the standby database to clear the error.
ORA-16812: apply service not running on the apply instance recorded by the broker
Cause: The Data Guard broker has the record of the apply instance but the apply service is not running on the instance.
Action: Re-enable the standby database to clear the error.
ORA-16813: apply service not running on the apply instance string recorded by the broker
Cause: The Data Guard broker has the record of the apply instance but the apply service is not running on the instance.
Action: Re-enable the standby database to clear the error.
ORA-16814: incorrect log transport setting for standby's AlternateLocation
Cause: The Data Guard broker detected that the log transport setting for some database regarding its AlternateLocation property value is incorrect. The incorrect setting could be one of the following: (1) the AlternateLocation property is empty but the log transport to the standby has an ALTERNATE setting; (2) the AlternateLocation property is not empty but the log transport to the standby has no ALTERNATE setting; (3) the AlternateLocation property does not match the ALTERNATE setting in the log transport. The mismatch may includes service string, directory specification of the alternate location, or SP_NAME attribute; (4) the log_archive_dest_state_n parameter corresponding to the alternate location is not set to ALTERNATE; (5) the flash recovery area is being used by the standby for archived logs, but the log transport to the standby still has an ALTERNATE setting for the AlternateLocation. Data Guard broker logs provide further details on which of the above cases causes the error.
Action: Re-enable the primary database to clear the error.
ORA-16815: incorrect log transport setting for AlternateLocation of standby "string"
Cause: The Data Guard broker detected that the log transport setting for the standby database regarding its AlternateLocation property value is incorrect. The incorrect setting could be one of the following: (1) the AlternateLocation property is empty but the log transport to the standby has an ALTERNATE setting; (2) the AlternateLocation property is not empty but the log transport to the standby has no ALTERNATE setting; (3) the AlternateLocation property does not match the ALTERNATE setting in the log transport. The mismatch may includes service string, directory specification of the alternate location, or SP_NAME attribute. (4) the log_archive_dest_state_n parameter corresponding to the alternate location is not set to ALTERNATE. (5) the flash recovery area is being used by the standby for archived logs, but the log transport to the standby still has an ALTERNATE setting for the AlternateLocation. Data Guard broker logs provide further details on which of the above cases causes the error.
Action: Re-enable the primary database to clear the error.
ORA-16950: Remote mapped cursors are not supported by this feature.
Cause: This cursor is a remote mapped cursor which could not be processed locally.
Action: Try to process this statement directly on the remote site.
ORA-16951: Too many bind variables supplied for this SQL statement.
Cause: Binding this SQL statement failed because too many bind variables were supplied.
Action: Pass the correct number of bind variables.
ORA-16952: Failed to bind this SQL statement.
Cause: Binding this SQL statement failed.
Action: Check if bind variables for that statement are properly specified.
ORA-16953: Type of SQL statement not supported.
Cause: This type of SQL statement could not be processed.
Action: none
ORA-16954: SQL parse error.
Cause: The specified SQL statement failed to be parsed.
Action: Check if syntax is correct and ensure that this statement can be parsed by the specified user name.
ORA-16955: Unknown error during SQL analyze.
Cause: The specified SQL statement failed to be analyzed.
Action: This is an internal error, please contact Oracle support.
ORA-17500: ODM err:string
Cause: An error returned by ODM library
Action: Look at error message and take appropriate action or contact Oracle Support Services for further assistance
ORA-17501: logical block size string is invalid
Cause: logical block size for oracle files must be a multiple of the physical block size, and less than the maximum
Action: check INIT.ORA file parameters
ORA-17502: ksfdcre:string Failed to create file string
Cause: file creation failed due to either insufficient OS permission or the file already exists
Action: check additional error messages
ORA-17503: ksfdopn:string Failed to open file string
Cause: file open failed due to either insufficient OS permission or the name of file exceeds maximum file name length.
Action: check additional error messages
ORA-17504: ksfddel:Failed to delete file string
Cause: The file that was being deleted is still in use or the process has insufficient permission to delete file.
Action: check additional error messages
ORA-17505: ksfdrsz:string Failed to resize file to size string blocks
Cause: There is insufficient space left on the device or the process has insufficient permission to resize file.
Action: check additional error messages
ORA-17506: I/O Error Simulation
Cause: The i/o request is marked with error because the i/o error simulation event is turned on.
Action: none
ORA-17507: I/O request size string is not a multiple of logical block size
Cause: i/o's are done in multiple of logical block size
Action: Check additional error messages
ORA-17508: I/O request buffer ptr is not alligned
Cause: i/o request buffer should be alligned, check additional information for buffer ptr value
Action: Call Oracle Support Services
ORA-17509: Attempt to do i/o beyond block1 offset
Cause: When a file is identified with logical block size of 0, only i/o's to block1 is allowed.
Action: check additional error messages and call Oracle Support Services
ORA-17510: Attempt to do i/o beyond file size
Cause: The i/o request points to a block beyond End Of File
Action: check additional error messages and call Oracle Support Services
ORA-17610: file 'string' does not exist and no size specified
Cause: An attempt to create a file a file found neither an existing file nor a size for creating the file.
Action: Specify a size for the file.
ORA-17611: ksfd: file 'string' cannot be accessed, global open closed
Cause: An attempt to write to a file which has gone offline/unidentified
Action: Check for other errno in the stack
ORA-17612: Failed to discover Oracle Disk Manager library, return value string
Cause: Discovery of the odm library by calling odm_discover() failed
Action: Contact your storage vendor who has provided the ODM library or call Oracle Support
ORA-17613: Failed to initialize Oracle Disk Manager library: string
Cause: ODM initialization for the thread failed due to insufficient previlige or memory.
Action: Make sure there is enough system resources available for the oracle process and it has access to the ODM library
ORA-17618: Unable to update block 0 to version 10 format
Cause: An attempt was made to update block 0 to version 10 format.
Action: Check additional error messages and call Oracle Support Services
ORA-17619: max number of processes using I/O slaves in a instance reached
Cause: An attempt was made to start large number of processes requiring I/O slaves.
Action: There can be a maximum of 35 processes that can have I/O slaves at any given time in a instance.
ORA-17620: failed to register the network adapter with Oracle Disk Manager library: string
Cause: The ODM library returned an error while trying to register the network adapter.
Action: Make sure the network adapter name given in the fileio_network_adapters is a valid name, and that the Oracle user has the correct access privileges.
ORA-17621: failed to register the memory with Oracle Disk Manager library
Cause: The ODM library returned an error while trying to register the memory.
Action: Contact the Oracle Disk Manager Library provider.
ORA-17622: failed to deregister the memory with Oracle Disk Manager library
Cause: The ODM library returned an error while trying to deregister the memory.
Action: Contact the Oracle Disk Manager Library provider
ORA-17624: Failed to delete directory string
Cause: The directory that was being deleted is still in use or the process had insufficient permission to delete the directory.
Action: check additional error messages.
ORA-17626: ksfdcre: string file exists
Cause: trying to create a database file, but file by that name already exists
Action: verify that name is correct, specify REUSE if necessary
ORA-18000: invalid outline name
Cause: The parser detected a missing or invalid outline name
Action: none
ORA-18001: no options specified for ALTER OUTLINE
Cause: The parser detected that no clause was specified on the command Our performance tests, which are not typical as they exercise all branches of the code, have shown approximately a 30% performance increase line for ALTER OUTLINE.
Action: Re-issue the command, specifying a valid ALTER OUTLINE clause.
ORA-18002: the specified outline does not exist
Cause: Either the outline did not exist to begin with, or a timing window allowed for another thread to drop or alter the outline midstream.
Action: none
ORA-18003: an outline already exists with this signature
Cause: The signature generation algorithm generates signatures that are are 16 bytes in length so it is highly unlikely that any 2 signatures will be identical. This message is raised in such a rare case.
Action: Either re-issue the statement that led to the outline being created with some whitespace added or force the outline to be created in a different category.
ORA-18004: outline already exists
Cause: An outline already exists, either with the specified name, or for the specified SQL text.
Action: none
ORA-18008: cannot find OUTLN schema
Cause: The database creation script that creates this schema must not have been executed.
Action: Review the log files to see what happened when the database was created.
ORA-18009: one or more outline system tables do not exist
Cause: Either the database creation script that creates these tables was not executed or a user accidently deleted the table
Action: Review the log files to see what happened when the database was created.
ORA-18010: command missing mandatory CATEGORY keyword
Cause: User failed to specify the CATEGORY keyword
Action: Re-issue the command with the CATEGORY keyword included
ORA-18015: invalid source outline signature
Cause: User imported an 8i outline into a 9i database without updating signatures
Action: execute dbms_outln.update_signatures
ORA-19000: missing RELATIONAL keyword
Cause: The keyword RELATIONAL in the work OBJECT RELATIONAL is missing in the XMLTYPE storage clause specification.
Action: Supply the RELATIONAL keyword in the storage clause
ORA-19001: Invalid storage option specified
Cause: An invalid storage option was specified for the XMLType.
Action: Supply a valid storage option.
ORA-19002: Missing XMLSchema URL
Cause: A XML schema URL must be specified in the storage option.
Action: Specify a URL for the XMLSchema.
ORA-19003: Missing XML root element name
Cause: A root element in the XMLSchema must be specified if the XML schema is given.
Action: Specify a root element in the XML schema.
ORA-19004: Duplicate XMLType OBJECT RELATIONAL storage option
Cause: A duplicate storage option for the XMLType column was specified
Action: Specify a single storage option for an XMLType column
ORA-19005: Duplicate XMLType LOB storage option
Cause: A duplicate storage option for the XMLType column was specified
Action: Specify a single storage option for an XMLType column
ORA-19006: XMLType TYPE storage option not appropriate for storage type
Cause: The TYPE option can only be used in case of OBJECT RELATIONAL storage option
Action: Remove the TYPE option or specify an OBJECT RELATIONAL storage for the XMLType column
ORA-19007: Schema string does not match expected string.
Cause: The given XML document conformed to a different schema than expected.
Action: Insert/Update only the XML documents that conform to that particular schema.
ORA-19008: Invalid version of the XMLType
Cause: An invalid version of the XMLType was found.
Action: This is possible due to data corruption or an internal error or running an older client against a newer version of the database. Make sure that the version of the client can understand the XMLType in the database.
ORA-19009: Missing XMLSchema keyword
Cause: The XMLSchema keyword is missing
Action: Specify the XMLSchema URL and element name.
ORA-19010: Cannot insert XML fragments
Cause: XML fragments got from extractNode cannot be inserted into the database.
Action: Convert the fragment into a proper XML document before insertion.
ORA-19011: Character string buffer too small
Cause: The string result asked for is too big to return back
Action: Get the result as a lob instead
ORA-19012: Cannot convert XML fragment to the required datatype
Cause: A conversion to a datatype was requested which cannot be performed
Action: The XMLType may contain fragments and other elements which cannot be converted to the appropriate datatype.
ORA-19013: Cannot create VARRAY columns containing XMLType
Cause: An attempt was made to create a VARRAY column which contains a XMLType
Action: You cannot store VARRAYs containing XMLTypes in tables. Use nested tables instead
ORA-19015: Invalid XML tag identifier (string)
Cause: An invalid XML identifer was detected during XML generation
Action: Fix the offending tag to not contain characters or symbols that are not allowed by the XML specification
ORA-19016: attributes cannot occur after element specifications
Cause: Attributes specified using the "@" identifier can only occur before any other element definition when creating XML
Action: Change the order of the types so that the attributes occur in the begining
ORA-19017: Attributes can only be simple scalars
Cause: Attribute values can only be simple scalar values
Action: Use only simple datatypes for attribute values
ORA-19018: Invalid character in XML tag 'string'
Cause: A tag name was found to have an invalid XML character during XML generation.
Action: Rewrite the query so that the generated XML tag, corresponding to a column name or alias, contains only valid characters.
ORA-19019: Invalid context passed to DBMS_XMLGEN.GETXML
Cause: The value of context passed to GETXML was invalid.
Action: Rewrite the query so that the value of context passed to GETXML is valid.
ORA-19020: invalid dereference of XMLType columns
Cause: An attempt was made to dereference the attributes of an XMLType column which is not part of a base table
Action: You can only dereference the attributes of a base table XMLType column
ORA-19023: The first argument to UPDATEXML operator has to be an XMLTYPE
Cause: The first argument passed to the update value operator was not an XMLTYPE.
Action: Rewrite the query so that the first argument to the UPDATEXML operator is XMLTYPE.
ORA-19024: Cursor expression must be named
Cause: The value of context passed to GETXML was invalid.
Action: Rewrite the query so that the value of context passed to GETXML is valid.
ORA-19025: EXTRACTVALUE returns value of only one node
Cause: Given XPath points to more than one node.
Action: Rewrite the query so that exactly one node is returned.
ORA-19026: EXTRACTVALUE can only retrieve value of leaf node
Cause: Given XPath does not point to a leaf node.
Action: Rewrite the query so that a leaf node is returned.
ORA-19028: Invalid ADT parameter passed to toObject() function
Cause: The object passed as ADT parameter to sys.XMLType.toObject() is not the same type, or a super-type, of the mapped type.
Action: Pass an object of the correct type to toObject().
ORA-19029: Cannot convert the given XMLType to the required type
Cause: The passed in XMLType could not be convert to the required type
Action: Binary XMLtype instances or other objects cannot be converted to the required object or collection types.
ORA-19030: Method invalid for non-schema based XML Documents.
Cause: The method can be invoked on only schema based xmltype objects.
Action: Don't invoke the method for non schema based xmltype objects.
ORA-19031: XML element or attribute string does not match any in type string.string
Cause: The passed in XML tag does not match any in the object type
Action: Pass a valid canonical XML that can map to the given object type
ORA-19032: Expected XML tag string got string
Cause: When converting XML to object, a wrong tag name was present
Action: Pass a valid canonical XML that can map to the given object type
ORA-19033: schema specified in the XML document does not match the schema parameter
Cause: When creating schema-based XML, the schema specified in the XML document is different from the schema passed in as the 'schema' parameter.
Action: Change the schema parameter to match the schema specified in the XML document.
ORA-19034: Type not supported during schema generation
Cause: The object type contained a type that is not supported for schema generation.
Action: Use a different type or do not generate a schema.
ORA-19035: Invalid select item of the query in newContextFromHierarchy()
Cause: The query does not have a number select item followed by an XMLType select item only.
Action: Make sure the result set of the query used in the newContextFromHierarchy() must have only two selected items: the first item must be number type and the second item must be XMLType.
ORA-19036: Invalid query result set in newContextFromHierarchy()
Cause: The result set of the query used in the newContextFromHierarchy() does not have the same property as the result set generated by a CONNECT BY query.
Action: Make sure the query used in newContextFromHierarchy() is a CONNECT BY query or the query returns the result set have the same property as the result set generated by a CONNECT BY query.
ORA-19037: XMLType result can not be a fragment
Cause: The select item of the query in newContextFromHierarchy() is an XML fragment.
Action: Make sure the select item of the query in newContextFromHierarchy() is NOT an XML fragment
ORA-19038: Invalid opertions on query context
Cause: SetMaxRows, SetSkipRows, SetRowTagName opertions are applied to a query context created from newContextFromHierarchy().
Action: SetMaxRows, SetSkipRows, SetRowTagName opertions can not be applied to a query context created from newContextFromHierarchy().
ORA-19039: Keyword string reserved for future use
Cause: The keyword is reserved for future use as a builtin function.
Action: Change the name mentioned above to a different one.
ORA-19040: Element string does not match expected string.
Cause: The given XML document had a different root element than expected.
Action: Insert/Update only the XML documents that conform to that particular schema and element.
ORA-19200: Invalid column specification
Cause: All input arguments must be valid columns
Action: Specify a valid list of columns
ORA-19201: Datatype not supported
Cause: The particular datatype is not supported in the XMLGEN operator
Action: Specify only supported datatypes as arguments to the XMLGEN operator
ORA-19202: Error occurred in XML processingstring
Cause: An error occurred when processing the XML function
Action: Check the given error message and fix the appropriate problem
ORA-19203: Error occurred in DBMS_XMLGEN processingstring
Cause: An error occurred when processing the DBMS_XMLGEN functions
Action: Check the given error message and fix the appropriate problem
ORA-19204: Non-scalar value 'string' is marked as XML attribute
Cause: Only scalar values (i.e. values which are not of object or collection type) can be marked as XML attribute,i.e. is prefixed by '@'. In this case, a non-scalar value was prefixed with '@'
Action: Remove the '@' sign, or make the value a scalar.
ORA-19205: Attribute 'string' qualifies a non-scalar value in the select list
Cause: The attribute immediately follows a value of object or collection type in the select list or type definition.
Action: Remove the '@' sign, or make the previous value a scalar.
ORA-19206: Invalid value for query or REF CURSOR parameter
Cause: The queryString argument passed to DBMS_XMLGEN.newContext was not a valid query, or REF CURSOR.
Action: Rewrite the query so that the queryString argument is a valid query or REF CURSOR.
ORA-19207: scalar parameter string of XMLELEMENT cannot have an alias.
Cause: The scalar parameter to XMLELEMENT has been qualified with an alias.
Action: Remove the AS clause of the scalar element.
ORA-19208: parameter string of function string must be aliased
Cause: The indicated parameter of the XML generation function has not been aliased, although it is an expression.
Action: Specify an alias for the expression using the AS clause.
ORA-19209: invalid or unsupported formatting argument
Cause: An invalid or unsupported formatting argument was supplied
Action: Change the formatting argument to legal supported values
ORA-19210: column 'string', specified to be a key or update column for DBMS_XMLSTORE, does not not exist in table 'string'
Cause: The column specified using setKeyColumn()/setUpdateColumn() did not exist in the table.
Action: Change the column specified to be a column in the table
ORA-19211: column 'string', specified as key using DBMS_XMLSTORE.setKeyColumn() , must be of scalar type
Cause: The column specified using setKeyColumn() was a non-scalar type column.
Action: Change the column specified to be a scalar column in the table
ORA-19212: no key columns specified before call to DBMS_XMLSTORE.updateXML()
Cause: No columns were specified as key columns before the call to DBMS_XMLSTORE.updateXML.
Action: Use DBMS_XMLSTORE.setKeyColumn() to specify key columns
ORA-19300: Error occurred in uri processingstring
Cause: An error occurred when processing the URL
Action: Check the given error message and fix the appropriate problem
ORA-19320: Host name not specified in HTTP URL
Cause: A host name was not specified in the HTTP url
Action: Specify a host name in the HTTP url when creating the URL string
ORA-19321: Could not open HTTP connection to host (string): port (string)
Cause: A HTTP connection could not be opened to the host
Action: Specify a valid host name and port to connect to
ORA-19322: An error occurred while reading from host (string): port (string)
Cause: An error occurred while reading from the HTTP host
Action: Specify a valid host name and port to read from
ORA-19323: Invalid url string
Cause: The URL must be a valid URL string
Action: Specify a valid url string
ORA-19330: Type 'string'.'string' not installed. Please install the type before using the CREATE_DBURI operator
Cause: The type required for the CREATE_DBURI operator has not been installed correctly.
Action: Read the installation notes to install the type correctly.
ORA-19331: Last argument to CREATE_DBURI operator must be a column
Cause: The final argument to the CREATE_DBURI operator must be a column to which the reference is being created.
Action: Specify a valid column name in the query.
ORA-19332: Invalid column in the CREATE_DBURI operator
Cause: The argument to the CREATE_DBURI operator can only be a column.
Action: Specify a valid column name for the operator
ORA-19333: Invalid flags for the CREATE_DBURI operator
Cause: The flags argument given to the DBURI operator is invalid
Action: Specify a valid flag value (TEXT) for the DBURI operator
ORA-19334: Invalid column specification for CREATE_DBURI operator
Cause: All columns must be valid and pointing to the same table or view
Action: Specify valid list of columns that are from the same table or view.
ORA-19335: Invalid format type object
Cause: An invalid format type object was specified for the XML function
Action: Specify a valid format type object
ORA-19336: Missing XML root element
Cause: The XML being generated does not have an enclosing root element.
Action: The XML generated must have a root element
ORA-19361: ONLINE option not allowed with this type of index
Cause: The ONLINE option was specified to validate the structure of a system-generated metadata index
Action: The ONLINE option can not be used with system-generated metadata indexes such as an LOB index, an IOT Top index, an Index on Clusters etc., Run query without using the ONLINE option.


14 ORA-19400 to ORA-24276

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

14 ORA-19400 to ORA-24276

ORA-19400: System type conflict with object SYS.string
Cause: The user had an object with the same name as one of the system types. The system types were not initialized properly.
Action: Remove the conflicting object and rerun migration.
ORA-19500: device block size string is invalid
Cause: the device block size returned by sequential I/O OSD is invalid
Action: If the block size was set by using the PARMS option of the Recovery Manager ALLOCATE CHANNEL command, then the specified block size must be changed. If no PARMS option was specified on the ALLOCATE CHANNEL command, then this is an internal error that should be reported to Oracle.
ORA-19501: read error on file "string", blockno string (blocksize=string)
Cause: read error on input file
Action: check the file
ORA-19502: write error on file "string", blockno string (blocksize=string)
Cause: write error on output file
Action: check the file
ORA-19503: cannot obtain information on device, name="string", type="string", parms="string"
Cause: call to get device information returned an error
Action: check device name, type and parameters
ORA-19504: failed to create file "string"
Cause: call to create file returned an error
Action: check additional messages, check access permissions
ORA-19505: failed to identify file "string"
Cause: call to identify the file returned an error
Action: check additional messages, and check if the file exists
ORA-19506: failed to create sequential file, name="string", parms="string"
Cause: call to create the sequential file returned an error
Action: check additional messages, check access permissions
ORA-19507: failed to retrieve sequential file, handle="string", parms="string"
Cause: call to retrieve the sequential file returned an error
Action: check additional messages, and check if the file exists
ORA-19508: failed to delete file "string"
Cause: call to delete the file returned an error
Action: check additional messages
ORA-19509: failed to delete sequential file, handle="string", parms="string"
Cause: call to delete the sequential file returned an error
Action: check additional messages
ORA-19510: failed to set size of string blocks for file "string" (blocksize=string)
Cause: call to resize the file returned an error
Action: check additional messages
ORA-19511: Error received from media manager layer, error text: string
Cause: An error occurred in the media management software which is linked with the Oracle server to perform backup and restore in cooperation with Recovery Manager.
Action: If the text of message 19511 does not provide enough information to resolve the problem, then you should contact the vendor of the media management software.
ORA-19512: file search failed
Cause: Recovery manager or Oracle Server attempted to discover files that matched the specified pattern but failed.
Action: Check errors on the error stack for an explanation why the search for files could not be successfully executed.
ORA-19550: cannot use backup/restore functions while using dispatcher
Cause: Attempted to use backup/restore functions while connected to the dispatcher in a shared server. This is not allowed because the device that is used for backup and restore must remain allocated to a single process.
Action: Connect directly to the instance then re-execute the backup or restore function.
ORA-19551: device is busy, device type: string, device name: string
Cause: The indicated device could not be allocated because it is allocated to another session, or no device was named, or all devices of the requested type are busy.
Action: Either attempt to allocate another device or wait until the required device is no longer busy.
ORA-19552: device type string is invalid
Cause: The device type indicated is invalid.
Action: Supply a correct device type and retry the allocation.
ORA-19553: device name string is invalid
Cause: The device name indicated is invalid.
Action: Supply a correct device name and retry the allocation.
ORA-19554: error allocating device, device type: string, device name: string
Cause: The specified device could not be allocated.
Action: One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error and retry the allocation.
ORA-19555: invalid LOG_ARCHIVE_MIN_SUCCEED_DEST parameter value
Cause: The value of parameter LOG_ARCHIVE_MIN_SUCCEED_DEST was not set within the valid range.
Action: Specify a correct value for parameter LOG_ARCHIVE_MIN_SUCCEED_DEST. If the archive log parameters LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST are in use, set parameter LOG_ARCHIVE_MIN_SUCCEED_DEST to either 1 or 2.
ORA-19556: required destination LOG_ARCHIVE_DUPLEX_DEST currently is deferred
Cause: The destination for parameter LOG_ARCHIVE_DUPLEX_DEST was deferred when it was required to be enabled. The destination was deferred automatically when an ALTER SYSTEM command for parameter LOG_ARCHIVE_DEST defined a destination which duplicated an existing LOG_ARCHIVE_DUPLEX_DEST parameter destination.
Action: Change the destination value for the LOG_ARCHIVE_DUPLEX_DEST parameter.
ORA-19557: device error, device type: string, device name: string
Cause: An error occurred in the platform-specific device code
Action: One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error and retry the allocation.
ORA-19558: error de-allocating device
Cause: The specified device could not be de-allocated.
Action: One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error and retry the allocation.
ORA-19559: error sending device command: string
Cause: An error occurred while sending the indicated command to the session device.
Action: One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error and retry the allocation.
ORA-19560: %s is not a valid device limit
Cause: An invalid type of device limit was specified in a call to x$dbms_backup_restore.setlimit.
Action: Use one of the documented limits: KBYTES, READRATE, or PARALLEL.
ORA-19561: %s requires a DISK channel
Cause: The attempted command requires that a DISK device channel be allocated to the session, but a non-DISK device was found.
Action: Deallocate the current device and allocate a DISK channel, then then retry the command.
ORA-19562: file string is empty
Cause: The indicated file, which is an archivelog, controlfile, or datafile was found to be empty during a copy, backup, or scan] operation.
Action: Ensure that the correct files are being specified for the copy or backup operation.
ORA-19563: %s header validation failed for file string
Cause: When opening the file to be placed in a copy or backup set, to be inspected, or used as the target for an incremental restore, the header was not recognized as a valid file header for a file of the indicated type (data file, archived log, or control file), belonging to the current database.
Action: Ensure that the correct files are being specified for the copy or backup operation.
ORA-19564: error occurred writing string bytes at block number string
Cause: An error occurred while writing to a file.
Action: One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error if possible, then retry the copy, backup, or restore operation.
ORA-19565: BACKUP_TAPE_IO_SLAVES not enabled when duplexing to sequential devices
Cause: An attempt was made to specify duplexing to sequential devices, but the BACKUP_TAPE_IO_SLAVES initialization parameter was not enabled.
Action: Specify BACKUP_TAPE_IO_SLAVES=TRUE in the INIT.ORA file, or do not specify duplexing to sequential devices.
ORA-19566: exceeded limit of string corrupt blocks for file string
Cause: The user specified limit of allowable corrupt blocks was exceeded while reading the specified datafile for a datafile copy or backup.
Action: None. The copy or backup operation fails. The session trace file contains detailed information about which blocks were corrupt.
ORA-19567: cannot shrink file string because it is being backed up or copied
Cause: An ALTER statement attempted to reduce the size of the indicated file while the same file is being backed up or copied.
Action: Retry the resize after the backup or copy is complete.
ORA-19568: a device is already allocated to this session
Cause: A device cannot be allocated to a session if another device is already allocated.
Action: Deallocate the current device
ORA-19569: no device is allocated to this session
Cause: An operation was attempted which requires a device to be allocated to the current session, and there is no device allocated.
Action: Allocate a device then retry the operation.
ORA-19570: file number string is outside valid range of 1 through string
Cause: A file number used in a copy, backup, or restore operation is not valid for the current database.
Action: Specify a valid file number.
ORA-19571: %s recid string stamp string not found in controlfile
Cause: The input file specified for a copy or backup operation could not be opened because the record describing the file is not found in the controlfile.
Action: Specify a correct recid/stamp and retry the copy or backup.
ORA-19572: cannot process file string, file is being being resized
Cause: The input file specified for a copy or backup operation could not be opened because the file is being resized.
Action: Wait for the resize to complete then retry the copy or backup.
ORA-19573: cannot obtain string enqueue for datafile string
Cause: The file access enqueue could not be obtained for a file specified in a backup, copy or restore operation. If the enqueue type shown is 'shared', then the file is the input file for a backup or copy. If the type is 'exclusive', then the file is the output file for a datafile copy or restore which is attempting to overwrite the currently active version of that file - in this case, the file must be offline or the database must be closed. If the type is 'read-only', then you are attempting to back up or copy this file while the database is in NOARCHIVELOG mode.
Action: Wait until the conflicting operation is complete, then retry the copy or backup. If the database is in NOARCHIVELOG mode, then all files being backed up must be closed cleanly.
ORA-19574: output filename must be specified
Cause: This type of copy or restore requires an output file name.
Action: Specify an output filename and retry the copy.
ORA-19575: expected string blocks in file string, found string
Cause: During a backup, restore, copy, or scan operation, the indicated file did not contain as many blocks as were indicated in the file header.
Action: The input copy or backup piece is probably corrupt. If another backup or copy exists of the file that is being restored, then the corrupt file can be deleted from the recovery catalog and the operation can be restarted.
ORA-19576: datafile string not defined in control file
Cause: The specified file number was not found in the control file.
Action: Specify a correct file number and retry the operation.
ORA-19577: file string is MISSING
Cause: A copyDataFileCopy, restoreDataFileTo or proxyRestoreDataFile function specified a file number but no output file name, indicating that the output filename should be taken from the controlfile. However, the controlfile entry for this file indicates that it was created for a file that was present in the data dictionary but not named during the last CREATE CONTROLFILE statement, so the name in the controlfile cannot be used for restoration.
Action: Either specify an output filename or issue a SQL RENAME command to enter a valid name for this file in the controlfile.
ORA-19578: end of volume while duplexing to sequential files, backup piece incomplete
Cause: An end of volume (EOV) condition was detected while duplexing to sequential files, and this condition cannot be handled currently.
Action: Before retrying the backup, make sure the backup pieces will fit in the volume, or disable duplexing.
ORA-19579: archivelog record for string not found
Cause: No archived log record corresponding to input file could be found in the controlfile.
Action: Specify a valid archivelog file name and retry the operation.
ORA-19580: %s conversation not active
Cause: A backup or restore operation was attempted before a conversation was started.
Action: Start a conversation then retry the operation.
ORA-19581: no files have been named
Cause: An attempt was made to proceed from the file naming phase to the piece processing phase of a backup or restore conversation before any files have been specified for backup or restore.
Action: Specify some files then retry the operation.
ORA-19582: archivelog file header validation for string failed
Cause: Archived log file header is corrupt and could not be validated.
Action: Provide a valid archivelog file and retry the operation.
ORA-19583: conversation terminated due to error
Cause: An error occurred which forced the termination of the current backup or restore conversation.
Action: There should be other error messages to help identify the cause of the problem. Correct the error and begin another conversation.
ORA-19584: file string already in use
Cause: The indicated file, which was specified as the target for a copy, restore, or delete operation is already in use by the database.
Action: Specify a different name and retry the operation.
ORA-19585: premature end of volume on piece string
Cause: While creating the indicated backup piece, an end-of-volume condition was encountered before all of the backup set control data was written to the backup piece. This is most likely a media error, because the amount of backup set control data is very small in relation to the total amount of data in a backup set.
Action: Retry the piece with a larger piece of output media.
ORA-19586: %s k-byte limit is too small to hold piece directory
Cause: The user-specified limit of k-bytes per backup piece is not enough to hold the backup set control data.
Action: Use the setLimit procedure to increase the k-byte limit and retry the operation.
ORA-19587: error occurred reading string bytes at block number string
Cause: An error occurred while reading from a file.
Action: One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error then retry the copy, backup, or restore operation.
ORA-19588: %s recid string stamp string is no longer valid
Cause: The indicated record has been marked as deleted. This indicates that the corresponding file has either been overwritten by another copy or restore, or that the copy was 'consumed' by a switchToCopy operation.
Action: If you know the name of the file you wish to copy, then inspect it and then retry the copy specifying the new recid.
ORA-19589: %s is not a snapshot or backup controlfile
Cause: The controlfile that is the source for a backup or copy operation is not a snapshot or backup controlfile.
Action: Specify the name of a snapshot or backup controlfile.
ORA-19590: conversation already active
Cause: You tried to begin a backup or restore conversation, but another conversation is already active in this session.
Action: Either continue the current conversation, or call backupCancel or restoreCancel to end the current conversation before starting a new one.
ORA-19591: backup aborted because job time exceeded duration time
Cause: You tried to backup with duration option and the time provided was not sufficient to complete the backup.
Action: Adjust the duration time and re-run the command. Or run the backup command without duration option.
ORA-19592: wrong string conversation type
Cause: You attempted to specify a type of file to be backed-up or restored, but the current conversation cannot process this type of file. For example, you specified an archived log to be included in a datafile backup set. The specified file will not be included in the backup or restore operation.
Action: No action required - the conversation is still active, and more files can be specified.
ORA-19593: datafile number string already included as string
Cause: This datafile is already specified for inclusion in this backup or restore conversation. A backup or restore conversation may process only a single instance of a datafile.
Action: No action required - the conversation is still active, and more files can be specified.
ORA-19594: controlfile already included as string
Cause: The controlfile is already specified for inclusion in this backup or restore conversation. A backup or restore conversation may process only a single instance of the controlfile.
Action: No action required - the conversation is still active, and more files can be specified.
ORA-19595: archivelog string already included in backup conversation
Cause: The indicated archivelog has already been specified for inclusion in this backup conversation.
Action: No action required - the conversation is still active, and more files can be specified.
ORA-19596: SPFILE already included
Cause: The SPFILE is already specified for inclusion in this backup or restore conversation. A backup or restore conversation may process only a single instance of the SPFILE.
Action: No action required - the conversation is still active, and more files can be specified.
ORA-19597: file string blocksize string does not match set blocksize of string
Cause: A file was specified for inclusion in a backup set but it has a logical block size different from the rest of the files in the backup set. All files in a backup set must have the same logical block size.
Action: Specify a file that has the same block size as the rest of the files in the backup set. The conversation is still active and more files can be specified.
ORA-19598: can not backup SPFILE because the instance was not started with SPFILE
Cause: A backup command requested a backup of the SPFILE, but no SPFILE was used to startup the instance.
Action: Create an SPFILE and re-start the instance using the SPFILE.
ORA-19599: block number string is corrupt in string string
Cause: A corrupt block was found in a controlfile, archivelog, or backup piece that is being read for a backup or copy. Corruption shall not be tolerated in controlfiles, archivelogs, or backup pieces.
Action: None. The copy or backup operation fails. Note that in the case of a backup set, the conversation is still active and the piece may be retried.
ORA-19600: input file is string string (string)
Cause: This message identifies the input file for a failed copy operation. Both the file number and name (if the name has been determined) are shown. For a datafile, the file number refers to the datafile's absolute file number as shown in the DBA_DATA_FILES view. For a datafile-copy, the file number refers to the copy's controlfile record number as shown in the RECID column of the V$DATAFILE_COPY view. For an archived log, the file number refers to the log's controlfile record number as shown in the RECID column of the V$ARCHIVED_LOG view.
Action: See other error message.
ORA-19601: output file is string string (string)
Cause: This message identifies the output file for a failed copy operation. The fields are as described in message 19600. When creating a new datafile copy, its controlfile record number may not have been determined when the message is printed. In that case, the record number shown is zero.
Action: See other error message.
ORA-19602: cannot backup or copy active file in NOARCHIVELOG mode
Cause: You tried to copy or backup a file that was not closed cleanly, and the database was in NOARCHIVELOG mode. This is not allowed because when restored, the file will require redo application before it is usable, and redo is not currently being saved beyond the contents of the online redo logs.
Action: Take the tablespace offline clean or close the database and retry the copy or backup.
ORA-19603: cannot backup or copy active file with KEEP .. UNRECOVERABLE option
Cause: The user tried to copy or backup a file that was not closed cleanly, with KEEP .. UNRECOVERABLE option. This is not allowed because when restored, the file will require redo application before it is usable, and redo will not be saved because of KEEP .. UNRECOVEARABLE option.
Action: Take the tablespace offline cleanly, or close the database and retry the copy or backup.
ORA-19604: conversation file naming phase is over
Cause: A call was made to specify a file to be backed up or restored after the first backup piece has been processed.
Action: You cannot specify more files to be processed during a backup or restore conversation after the first backup piece has been processed. If more files must be specified, you must begin a new conversation.
ORA-19605: input filename must be specified
Cause: The input file name was not specified for a controlfile copy operation.
Action: Specify an input file name and retry the operation.
ORA-19606: Cannot copy or restore to snapshot controlfile
Cause: A controlfile copy or restore operation specified the name of the snapshot controlfile as the output file. It is not permitted to overwrite the snapshot controlfile in this manner. Other methods are available to create the snapshot controlfile.
Action: Specify a different file name and retry the operation. If this is a restore, then the restore conversation remains active and more files may be specified.
ORA-19607: %s is an active controlfile
Cause: A controlfile copy, restore, or backup specified the name of a controlfile named in the INIT.ORA file as the input or output file.
Action: Specify a different file name and retry the operation. If this is a backup or restore conversation, then the conversation remains active and more files may be specified.
ORA-19608: %s is not a backup piece
Cause: The specified file is not a backup piece produced by the dbms_backup_restore package. Either the first block of the backup piece is corrupt or this file is not a backup piece.
Action: Specify a different file name and retry the operation.
ORA-19609: %s is from different backup set: stamp string count string
Cause: The specified file is not from the backup set which is currently being processed. It is part of a different backup set. The identification of the set containing this piece is shown.
Action: Specify the correct backup piece and retry the operation.
ORA-19610: directory block string is corrupt
Cause: The indicated directory block failed checksum validation. This backup piece is unusable.
Action: Supply another copy of the same backup piece, or terminate the restore conversation.
ORA-19611: backup piece out of order. Expected string but found string
Cause: This backup piece is out of sequence.
Action: Supply the correct backup piece.
ORA-19612: datafile string not restored due to string
Cause: The indicated file could not be restored, because all of its data blocks were not found in the backup piece.
Action: The restore conversation remains active, and the current piece must be re-processed. If the failure cannot be resolved by re-processing the current piece, then the restore conversation must be cancelled.
ORA-19613: datafile string not found in backup set
Cause: The indicated file could not be restored, because it is not in this backup set. If the file number is zero, then this refers to the controlfile.
Action: This message is issued when the directory from the first backup piece is read and one or more files named for restoration were not found. The restore conversation is still active, but no data has been read and you must supply the first backup piece of a backup set that contains all of the requested files.
ORA-19614: archivelog thread string sequence string not found in backup set
Cause: The indicated archived log file was named explicitely for restoration but is not contained in this backup set.
Action: This message is issued when the directory from the first backup piece is read and one or more files named for restoration were not found. The restore conversation is still active, but no data has been read and you must supply the first backup piece of a backup set that contains all of the requested files.
ORA-19615: some files not found in backup set
Cause: Some files that were specified for restoration were not found in the backup set directory. Message 19613 or 19614 is issued for each unfound file.
Action: See the instructions for message 19613.
ORA-19616: output filename must be specified if database not mounted
Cause: A datafile restore specified no target filename, but the database is not mounted. The database must be mounted when no target filename is specified, so that the target filename can be obtained from the controlfile.
Action: The restore conversation remains active. If you wish to restore datafiles without their target filenames, then mount the datbase before continuing. Otherwise, a target filename must be specified on all datafile restoration calls.
ORA-19617: file string contains different resetlogs data
Cause: The indicated file contains resetlogs data which is different from the archived log files which are already included in the backup set. All archived log files in a backup set must have the same resetlogs data.
Action: The restore conversation remains active, and you may continue to specify archived log files for inclusion in the backup set.
ORA-19618: cannot name files after restoreValidate has been called
Cause: A call was made to specify a file to restore from a backup set, but a previous call to restoreValidate has already been made.
Action: You must cancel and restart the conversation if you wish to specify files to restore.
ORA-19619: cannot call restoreValidate after files have been named
Cause: restoreValidate was called after some files had already been specified for restoration.
Action: You must cancel and restart the conversation if you wish to call restoreValidate.
ORA-19621: archivelog range has already been specified
Cause: A range of logs has already been specified. Only one SCN range may be specified per conversation.
Action: The restore conversation remains active and more logs may be specified by thread and sequence number, if desired.
ORA-19622: archivelog thread string sequence string not restored due to string
Cause: The indicated file could not be restored, because all of its data blocks were not found in the backup piece.
Action: The restore conversation remains active, and the current piece must be re-processed. If the failure cannot be resolved by re-processing the current piece, then the restore conversation must be cancelled.
ORA-19623: file string is open
Cause: A SwitchToCopy operation specified a datafile copy whose parent datafile is open.
Action: Take the owning tablespace offline or close the database, then retry the operation.
ORA-19624: operation failed, retry possible
Cause: A backup, restore or image copy operation failed with an I/O error. If the source of the I/O error can be corrected, then the operation may be retried.
Action: This message is used by recovery manager to decide whether or not to retry the operation.
ORA-19625: error identifying file string
Cause: A file specified as input to a copy or backup operation, or as the target for an incremental restore, could not be identified as an Oracle file. An OS-specific error accompanies this error to help pinpoint the problem.
Action: Specify an different file and retry the operation.
ORA-19626: backup set type is string - can not be processed by this conversation
Cause: The data in the backup set is not compatible with the current conversation.
Action: Either supply the first piece from a backup set that matches the current conversation or start a new restore conversation which can process this backup set.
ORA-19627: cannot read backup pieces during controlfile application
Cause: This is a controlfile restore conversation, which is using the offline range information from one or more controlfiles to update datafile checkpoint data. Backup sets are not used during this type of conversation.
Action: The conversation is still active and more controlfiles may be applied.
ORA-19628: invalid SCN range
Cause: The starting SCN for restoreRedoLogRange is greater than the ending SCN.
Action: Specify a starting SCN which is less than or equal to the ending SCN.
ORA-19629: no files in specified archivelog SCN range
Cause: This backup set contains no files in the specified range.
Action: Either supply a backup set that contains files in the correct range or start a new conversation and specify a range which will select some files from this backup set.
ORA-19630: end of volume encountered while copying backup piece
Cause: While copying a backup piece from the OS native filesystem to an output device, the output device encountered end-of-volume.
Action: The copy fails. This could happen if a tape was used which is not large enough to hold the entire backup piece.
ORA-19631: archivelog record contains no file name
Cause: This archivelog record represents a switch into an active log that took place without archiving its prior contents. The prior contents of the log file are lost.
Action: Specify the recid of an archivelog record that contains a file name. Fixed view v$archived_log can be used to examine the archived logs.
ORA-19632: file name not found in controlfile
Cause: The name passed to getFno was not found in the controlfile.
Action: Supply a valid filename.
ORA-19633: controlfile record string is out of sync with recovery catalog
Cause: The controlfile record describing the file to be deleted in a call to deleteBackupPiece, deleteDataFilecopy, proxyDelete or deleteArchivedLog does not match the validation data supplied by recovery manager.
Action: contact Oracle support
ORA-19634: filename required for this function
Cause: The fname or handle parameter was not specified for deletePiece, deleteDataFileCopy, deleteRedoLog or proxyDelete.
Action: Specify the fname or handle parameter when calling these functions.
ORA-19635: input and output filenames are identical: string
Cause: Identical input and output file names were specified for a datafile copy operation.
Action: Specify an output file name which is different from the input file name.
ORA-19636: archivelog thread string sequence string already included
Cause: The indicated archivelog has already been specified for inclusion in this restore conversation. A restore conversation may process only one copy of any archivelog.
Action: No action required - the conversation is still active, and more files can be specified.
ORA-19637: backupPieceCreate requires file name when using DISK device
Cause: The session device is currently allocated to disk, and so a file name is required.
Action: Supply a filename and retry the operation.
ORA-19638: file string is not current enough to apply this incremental backup
Cause: The checkpoint of the target for this incremental backup is less than the start of the incremental backup. If this backup were applied, then any changes made between the datafile checkpoint and the start of the incremental backup could be lost.
Action: Supply a backup set that can be applied and retry the operation.
ORA-19639: file string is more current than this incremental backup
Cause: The checkpoint of the target for this incremental backup is greater than or equal to the checkpoint of the file in the incremental backup set. This backup cannot advance the checkpoint of the target file, so there is no point in applying it.
Action: Supply a backup set that can be applied and retry the operation.
ORA-19640: datafile checkpoint is SCN string time string
Cause: This message identifies the datafile checkpoint for a datafile that was too old to take an incremental backup from, or the target of an incremental restore that could not be applied.
Action: See other error message.
ORA-19641: backup datafile checkpoint is SCN string time string
Cause: This message identifies the checkpoint of a datafile in an incremental backup set that could not be applied.
Action: See other error message.
ORA-19642: incremental-start SCN is string
Cause: This message identifies the starting SCN of an incremental backup that could not be applied.
Action: See other error message.
ORA-19643: datafile string: incremental-start SCN is too recent
Cause: The incremental-start SCN which was specified when starting an incremental datafile backup is greater than the datafile checkpoint SCN, which could cause some blocks to be missed.
Action: Specify a smaller incremental-start SCN.
ORA-19644: datafile string: incremental-start SCN is prior to resetlogs SCN string
Cause: The incremental-start SCN which was specified when starting an incremental datafile backup is less than the resetlogs SCN.
Action: Specify a larger incremental-start SCN.
ORA-19645: datafile string: incremental-start SCN is prior to creation SCN string
Cause: The incremental-start SCN which was specified when starting an incremental datafile backup is less than the datafile's creation SCN.
Action: Specify a larger incremental-start SCN.
ORA-19646: cannot change size of datafile string from string to string
Cause: The indicated file was resized before this incremental backup was taken, but the incremental backup failed to set the file to the new size.
Action: Examine the other messages which should be present to indicate the cause of the failure.
ORA-19647: non-zero LEVEL cannot be specified when INCREMENTAL is FALSE
Cause: BackupSetDataFile was called with a non-zero backup_level and a FALSE incremental indication.
Action: Either set incremental to TRUE or change backup_level to zero.
ORA-19648: datafile string: incremental-start SCN equals checkpoint SCN
Cause: The incremental-start SCN which was specified when starting an incremental datafile backup is equal to the datafile's checkpoint SCN. Since an incremental backup can only be applied to a datafile whose checkpoint SCN is between the backup set incremental-start SCN (inclusive) and the backup set checkpoint SCN (exclusive), there is no datafile that this backup set could ever be applied to.
Action: Specify a smaller incremental-start SCN. NOTE that this message will usually only be encountered by the user while taking an incremental backup with Recovery Manager. Recovery Manager should intercept all usual cases of this error and simply ignore the incremental backup for this file. So, if you do encounter this error, please report it to Oracle Support.
ORA-19649: offline-range record recid string stamp string not found in file string
Cause: applyOfflineRange was called with a recid/stamp which was not found in the indicated controlfile. This probably means that the specified controlfile is no longer the same controlfile that Recovery Manager thinks it is.
Action: Specify the recid/stamp of a record that exists in the controlfile copy.
ORA-19650: Offline-range record recid string stamp string in file string has SCN string
Cause: This messages identifies the offline-clean SCN from the indicated offline-range record in the indicated file.
Action: See other error message.
ORA-19651: cannot apply offline-range record to datafile string: SCN mismatch
Cause: applyOfflineRange cannot apply an offline-range record to a target datafile unless the datafile's checkpoint SCN exactly matches the offline-clean SCN in the specified offline-range record.
Action: Specify an offline-range record whose offline-clean SCN matches the target datafile's checkpoint.
ORA-19652: cannot apply offline-range record to datafile string: file is fuzzy
Cause: The target datafile for an applyOfflineRange call is fuzzy.
Action: Specify a target datafile that is closed cleanly.
ORA-19653: cannot switch to older file incarnation
Cause: SwitchToCopy was called with a datafile copy for a datafile that was dropped prior to the time this controlfile was backed up.
Action: Restore and mount an earlier controlfile. It is acceptable to use a controlfile that was backed up prior to the creation of the specified datafile.
ORA-19654: must use backup controlfile to switch file incarnations
Cause: This switchToCopy operation is attempting to switch incarnations of a datafile, but the currently mounted controlfile is not a backup controlfile.
Action: Restore and mount a backup controlfile.
ORA-19655: cannot switch to incarnation with different resetlogs data
Cause: This switchToCopy operation is attempting to switch to a datafile which comes from a different resetlogs version of the database.
Action: Either restore a backup controlfile that was taken from the same database version as the target datafile-copy, or switch to a different datafile-copy.
ORA-19656: cannot backup, copy, or delete online log string
Cause: The indicated log file is an active log. You can only backup, copy, or delete archived logs.
Action: The indicated log file cannot be processed - select another file.
ORA-19657: cannot inspect current datafile string
Cause: The file being inspected is already part of the currently mounted database.
Action: None - the file is already part of the database.
ORA-19658: cannot inspect string - file is from different resetlogs
Cause: The resetlogs data in the log file being inspected does not match that in the currently mounted controlfile.
Action: The indicated file cannot be processed - inspect another file.
ORA-19659: incremental restore would advance file string past resetlogs
Cause: This incremental backup cannot be applied to the specified datafile, because the datafile is from an earlier incarnation of the database, and its checkpoint would be advanced too far to be recoverable in the current incarnation of the database.
Action: This incremental cannot be applied to this datafile. If you wish to recover the file to the resetlogs SCN so that the database can be opened with the RESETLOGS option, then you must use redo-log recovery, not incremental restore, to continue recovering this file.
ORA-19660: some files in the backup set could not be verified
Cause: A restore conversation was made to verify all the files in a backup set, and the files which were printed in messages 19661 or 19662 could not be verified because corrupt blocks for those files were found in the backup set.
Action: Unless the damage to the backup set can be repaired, the indicated files cannot be restored from this backup set.
ORA-19661: datafile string could not be verified
Cause: Some data blocks for the indicated datafile were corrupt in the backup set.
Action: Unless the damage to the backup set can be repaired, the indicated datafile cannot be restored from this backup set.
ORA-19662: archived log thread string sequence string could not be verified
Cause: Some data blocks for the indicated archived log were corrupt in the backup set.
Action: Unless the damage to the backup set can be repaired, the indicated archived log cannot be restored from this backup set.
ORA-19663: cannot apply current offline range to datafile string
Cause: An attempt was made to apply the current offline range to the specified datafile, but the datafile is either not current enough or is not at the correct SCN to apply the offline range.
Action: The datafile remains unchanged.
ORA-19664: file type: string, file name: string
Cause: This message is issued to identify the file which is the subject of an error.
Action: None - this is an informational message. There should be other Oracle messages explaining the cause of the error.
ORA-19665: size string in file header does not match actual file size of string
Cause: The size of the file as indicated in the file header does not match the true size of the file. The two differing sizes are shown in units of logical blocks.
Action: This file is not usable - it has most likely been truncated.
ORA-19666: cannot do incremental restore of the controlfile
Cause: The controlfile was included in an incremental restore conversation
Action: If you wish to restore the controlfile, you must do a full restore of the controlfile
ORA-19667: cannot do incremental restore of datafile string
Cause: The backup of the datafile is a full backup
Action: If you wish to restore the datafile, you must do a full restore of the datafile
ORA-19668: cannot do full restore of datafile string
Cause: The backup of the datafile is an incremental backup
Action: If you wish to restore the datafile, you must do an incremental restore of the datafile
ORA-19669: proxy copy functions cannot be run on DISK channel
Cause: A proxy copy procedure was called, but the device which is allocated to the current session has type DISK.
Action: Allocate a non-DISK channel and retry the operation. Note that proxy copy requires a 3rd-party media management software product that supports the this backup/restore feature.
ORA-19670: file string already being restored
Cause: A proxy restore function has already named this file as a restore destination.
Action: Use a different file name. If this message occurs during a recovery manager job, then this is an internal error in recovery manager, and you should contact Oracle support.
ORA-19671: media management software returned invalid proxy handle
Cause: During a proxy backup or restore, the media management software returned an invalid file handle.
Action: This is an internal error in the media management software which is linked with Oracle to provide backup/restore services. Contact the media management software vendor.
ORA-19672: media management software returned invalid file status
Cause: During a proxy backup or restore, the media management software returned an invalid file status.
Action: This is an internal error in the media management software which is linked with Oracle to provide backup/restore services. Contact the media management software vendor.
ORA-19673: error during proxy copy of file string
Cause: During a proxy backup or restore, an error occurred while copying this file, but other files may have been copied successfully.
Action: There should be other errors on the error stack which explain why the file could not be successfully copied.
ORA-19674: file string is already being backed up with proxy copy
Cause: Recovery manager attempted to back up the specified file with proxy copy, but the file is already being backed up by another recovery manager job.
Action: Wait until the other recovery manager backup of this file is complete, then retry the backup.
ORA-19675: file string was modified during proxy copy
Cause: A proxy backup of the specified file failed because the file was brought on-line or otherwise modified while the proxy backup was in progress. This file was off-line or read-only when the backup began, so the file was not put into hot-backup mode, therefore no modifications are permitted while the backup is in progress.
Action: Take another backup of this file.
ORA-19676: one or more files failed during proxy backup or restore
Cause: During a proxy backup or restore, errors were encountered while processing some files. The files for which no error messages are shown were processed successfully.
Action: Examine the messages regarding the specific files to determine the cause of the problems.
ORA-19677: RMAN configuration name exceeds maximum length of string
Cause: The configuration name string exceeds maximum length.
Action: Supply a correct configuration name and retry the function.
ORA-19678: RMAN configuration value exceeds maximum length of string
Cause: The configuration value string exceeds maximum length.
Action: Supply a correct configuration value and retry the operation.
ORA-19679: RMAN configuration number string is outside valid range of 1 through string
Cause: An invalid RMAN Configuration number was specified.
Action: Specify a correct datafile number and retry the operation.
ORA-19680: some blocks not recovered. See trace file for details
Cause: Some blocks are not recovered during block media recovery.
Action: See trace files for details of the problem.
ORA-19681: block media recovery on control file not possible
Cause: filenumber 0 specified in block media recovery
Action: check filenumber
ORA-19682: file string not in block media recovery context
Cause: Internal error
Action: none
ORA-19683: real and backup blocksize of file string are unequal
Cause: block size changed between backup & real file
Action: use right backup
ORA-19684: block media recovery failed because database is suspended
Cause: Database is suspended, probably by an ALTER SYSTEM SUSPEND statement
Action: Execute ALTER SYSTEM RESUME then retry block media recovery
ORA-19685: SPFILE could not be verified
Cause: Some data blocks for the SPFILE were corrupt in the backup set.
Action: Unless the damage to the backup set can be repaired, the SPFILE cannot be restored from this backup set.
ORA-19686: SPFILE not restored due to string
Cause: The indicated file could not be restored, because some of its data blocks were not found in the backup piece.
Action: Unless the damage to the backup set can be repaired, the SPFILE cannot be restored from this backup set.
ORA-19687: SPFILE not found in backup set
Cause: The SPFILE could not be restored, because it is not in this backup set.
Action: This message is issued when the directory from the first backup piece is read and one or more files named for restoration were not found in the piece. You must supply the first backup piece of a backup set that contains the requested file.
ORA-19688: control file autobackup format(string) for string does not have %F
Cause: control file autobackup format must contain %F for the device.
Action: Change controlfile format using RMAN command CONGIGURE CONTROLFILE BACKUP FORMAT FOR DEVICE TYPE <type> TO <format>.
ORA-19689: cannot have more than one %F in control file autobackup format(string) for string
Cause: control file autobackup format contains more than one %F for the device.
Action: Change controlfile format using RMAN command CONGIGURE CONTROLFILE BACKUP FORMAT FOR DEVICE TYPE <type> TO <format>.
ORA-19690: backup piece release string incompatible with Oracle release string
Cause: The backup piece was created by incompatible software.
Action: Either restart with a compatible software release or create another backup using the current release.
ORA-19691: %s is from different database: id=string, name=string
Cause: The database name or database id in backuppiece header does not match the one in controlfile.
Action: Supply the correct backuppiece belonging to this database.
ORA-19692: missing creation stamp on piece string
Cause: The backuppiece doesn't have information about creation stamp.
Action: Supply another backuppiece which is created by oracle 9i or later version.
ORA-19693: backup piece string already included
Cause: This backup piece was already specified for inclusion in the restore conversation. A restore conversation may process only a single instance of a backup piece.
Action: Remove the specified duplicate backup piece in restore steps and restart the conversation.
ORA-19694: some changed blocks were not found in the change tracking file
Cause: A backup or copy found that some changed blocks had not been recorded in the change tracking file. The details of which files and blocks are affected will be in an Oracle trace file.
Action: This indicates that there is a problem with the change tracking feature. Disable change tracking and re-start the backup.
ORA-19695: fixed table x$krbmsft has not been populated
Cause: This is an internal error. The fixed table x$krbmaft was not populated using the function dbms_backup_restore.searchFiles.
Action: Internal error - contact Oracle Customer Support.
ORA-19696: controlfile not found in backup set
Cause: The controlfile could not be restored because it is not in this backup set.
Action: This message is issued when the directory from the first backup piece is read and one or more files named for restoration were not found in the piece. You must supply the first backup piece of a backup set that contains the requested file.
ORA-19697: standby controlfile not found in backup set
Cause: The standby controlfile could not be restored because it is not in this backup set.
Action: This message is issued when the directory from the first backup piece is read and one or more files named for restoration were not found in the piece. You must supply the first backup piece of a backup set that contains the requested file.
ORA-19698: %s is from different database: id=string, db_name=string
Cause: Catalog failed becasuse the database id in file header does not match the one in controlfile.
Action: Supply the correct file belonging to this database.
ORA-19699: cannot make copies with compression enabled
Cause: Datafile copies with compression are not supported.
Action: If the function dbms_backup_restore.backuppieceCreate is called outside RMAN, then the incompatible values are being passed for the parameters docompress and imagcp. If this message occurs during an RMAN job, then this is an internal error in RMAN, and you should contact Oracle support.
ORA-19700: device type exceeds maximum length of string
Cause: The device type indicated is invalid.
Action: Supply a correct device type and retry the allocation.
ORA-19701: device name exceeds maximum length of string
Cause: The device name indicated is invalid.
Action: Supply a correct device name and retry the allocation.
ORA-19703: device command string exceeds maximum length of string
Cause: The device command string exceeds maximum length.
Action: Correct the command and retry the operation.
ORA-19704: file name exceeds maximum length of string
Cause: The specified file name, which was a parameter to a copy, backup, or restore operation, exceeds the maximum file name length for this operating system.
Action: Retry the operation with a shorter file name.
ORA-19705: tag value exceeds maximum length of string characters
Cause: During a backup or copy operation, the user supplied a tag value too long to fit in the file header.
Action: Supply a shorter tag and retry the operation.
ORA-19706: invalid SCN
Cause: The input SCN is either not a positive integer or too large.
Action: Check the input SCN and make sure it is a valid SCN.
ORA-19707: invalid record block number - string
Cause: The input number is either negative or too large.
Action: Check the input record block number and make sure it is a valid number clauses in the create database statement.
ORA-19708: log destination exceeds maximum length of string characters
Cause: When starting a restore conversation, the user specified a log restore destination longer than the port-specific maximum.
Action: Supply a shorter destination and retry the operation.
ORA-19709: numeric parameter must be non-negative integer
Cause: A numeric parameter to an x$dbms_backup_restore procedure is negative or contains a fractional portion.
Action: Supply a valid numeric parameter.
ORA-19710: unsupported character set string
Cause: When the target database is not mounted, RMAN sets the target database character set to the value specified in the users environment.
Action: Specify a valid character set in the environment. This is usually done via the NLS_LANG environment variable.
ORA-19711: cannot use reNormalizeAllFileNames while database is open
Cause: An attempt was made to re-normalize all the filenames in the controlfile while the database is open.
Action: Close the database before using the reNormalizeAllFileNames procedure.
ORA-19712: table name exceeds maximum length of string
Cause: The table name string exceeds maximum length.
Action: Retry the operation with a shorter table name.
ORA-19713: invalid copy number: string
Cause: The copy number is not in a valid range or you have reached maximum limit.
Action: Report the error and other information to support.
ORA-19714: length for generated name longer than string
Cause: The specified format exceeds the maximum length for the piece name.
Action: Change the format to create shorter piece names.
ORA-19715: invalid format string for generated name
Cause: A restricted format or undefined format was used incorrectly.
Action: Change the format specified in the additional information by removing the restricted format.
ORA-19716: error processing format string to generate name for backup
Cause: There were errors while processing the format to generate name for backup.
Action: Change the format.
ORA-19717: for non-OMF search the pattern must be specified
Cause: The procedure dbms_backup_restore.searchFiles was called with an empty pattern while the parameter omf was set to FALSE.
Action: Either specify the pattern or set the parameter omf to TRUE.
ORA-19718: length for command id longer than string
Cause: The specified command id exceeds the maximum length for command id.
Action: Supply a shorter command id and retry the operation.
ORA-19719: length for operation name longer than string
Cause: The specified operation name exceeds the maximum length for operation name.
Action: Supply a shorter operation name and retry the operation.
ORA-19720: Error occurred when converting an OCI number into an SCN
Cause: This is most likely caused by an invalid SCN number that came from an external file, such as an export file.
Action: See other errors on the error stack to look for the source of the problem.
ORA-19721: Cannot find datafile with absolute file number string in tablespace string
Cause: Can not find one of the datafile that should be in the Pluggable Set.
Action: Make sure all datafiles are specified via import command line option or parameter files.
ORA-19722: datafile string is an incorrect version
Cause: The datafile is an incorrect version. It contains either less or more changes then the desired version.
Action: Make sure the right datafiles are transported. Make sure the datafile is copied while its tablespace is read only.
ORA-19723: Cannot recreate plugged in read-only datafile string
Cause: The datafile is plugged in read only. It can not recreated.
Action: Use ALTER DATABASE RENAME FILE command instead.
ORA-19724: snapshot too old: snapshot time is before file string plug-in time
Cause: The snapshot SCN is before the SCN at which the referred datafile is plugged into the database.
Action: retry the query.
ORA-19725: can not acquire plug-in enqueue
Cause: There maybe another "ALTER DATABASE RESET COMPATIBILITY" command issued concurrently, preventing this process from acquiring the plug-in enqueue.
Action: retry the operation.
ORA-19726: cannot plug data [string] at level string into database running at compatibility level string
Cause: Some of the data in the pluggable set requires a compatibility level higher than what is currently allowed by the database. The string in square bracket is the name of the compatibility type associated with the data.
Action: Raise the "compatible" init.ora parameter and retry the operation.
ORA-19727: cannot plug data [string] at level string into database running Oracle string
Cause: Some of the data in the pluggable set requires a compatibility level higher than the release level of the Oracle executable. The string in square bracket is the name of the compatibility type associated with the data.
Action: Upgrade Oracle and retry the operation.
ORA-19728: data object number conflict between table string and partition string in table string
Cause: The non-partitioned table has the same data object number as one of the partitions in the partitioned table. One can not exchange the table with the partition in this case.
Action: Use "alter table move partition" command to move the offending partition, so that the partition will get a new data object number. Retry the operation then.
ORA-19729: File string is not the initial version of the plugged in datafile
Cause: The file is not the initial version of the plugged in datafile.
Action: Use the correct initial version of the plugged in datafile.
ORA-19730: can not convert offline plugged-in datafile string
Cause: As part of making a tablespace read-write, we need to convert datafiles that are plugged in read-only. The file must be online.
Action: Online the datafile and retry the operation.
ORA-19731: cannot apply change to unverified plugged-in datafile string
Cause: Recovery was not able to verify the referred datafile according to information in the control file. Before encountering this change vector for this file, somehow recovery did not encounter the file conversion redo that is supposed to verify the file. This may happen due to corrupted or incorrect control file used for media recovery.
Action: Use the correct control file and continue recovery.
ORA-19732: incorrect number of datafiles for tablespace string
Cause: d by a user editing the export file.
Action: Use the correct export file and retry the operation.
ORA-19733: COMPATIBLE parameter needs to be string or greater
Cause: The COMPATIBLE initialization parameter is not high enough to allow the operation. Allowing the command would make the database incompatible with the release specified by the current COMPATIBLE parameter.
Action: Shutdown and startup with a higher compatibility setting.
ORA-19734: wrong creation SCN - control file expects converted plugged-in datafile
Cause: When a tablespace is plugged into a database, the tablespace is initially read-only. Oracle converts the header of the plugged-in datafiles (assign them a new creation SCN) when the tablespace is first made read-write. This error occurs when the creation SCN in the file header is different from the creation SCN in the controlfile, possibly because this is the initial version of plugged-in datafile.
Action: Either restore the converted datafile or continue recovering the datafile.
ORA-19735: wrong creation SCN - control file expects initial plugged-in datafile
Cause: When a tablespace is plugged into a database, the tablespace is initially read-only. Oracle converts the header of the plugged-in datafiles (assign them a new creation SCN) when the tablespace is first made read-write. This error occurs when the creation SCN in the file header is different from the creation SCN in the controlfile, possibly because this is the converted datafile.
Action: Either restore the initial version of the plugged-in datafile, or continue database recovery, which will recover the control file.
ORA-19736: can not plug a tablespace into a database using a different national character set
Cause: Oracle does not support plugging a tablespace into a database using a different national character set.
Action: Use import/export or unload/load to move data instead.
ORA-19740: text is longer than string
Cause: The specified text exceeds the maximum length for text.
Action: Supply a shorter text and retry the operation.
ORA-19750: change tracking file: 'string'
Cause: This message reports the name of a file involved in other messages.
Action: See associated error messages for a description of the problem.
ORA-19751: could not create the change tracking file
Cause: It was not possible to create the change tracking file.
Action: Check that there is sufficient disk space and no conflicts in filenames and try to enable block change tracking again.
ORA-19752: block change tracking is already enabled
Cause: The ALTER DATABASE ENABLE BLOCK CHANGE TRACKING command was issued, but block change tracking is already turned on for this database.
Action: None, this is an informative message only.
ORA-19753: error writing to change tracking file
Cause: An I/O error occurred while writing to the change tracking file.
Action: There will be other messages on the error stack that show details of the problem.
ORA-19754: error reading from change tracking file
Cause: An I/O error occurred while reading from the change tracking file.
Action: There will be other messages on the error stack that show details of the problem.
ORA-19755: could not open change tracking file
Cause: The change tracking file could not be opened.
Action: There will be other messages on the error stack that show details of the problem.
ORA-19756: corrupt block number string found in change tracking file
Cause: The specified block number is corrupt in the change tracking file.
Action: There will be other messages on the error stack that show details of the problem. There will also be a trace file that contains a complete dump of the corrupt block.
ORA-19757: could not resize change tracking file to string blocks
Cause: An error occurred while trying to change the size of the change tracking file.
Action: There will be other messages on the error stack that show details of the problem.
ORA-19758: failed to enable/disable block change tracking: out of SGA memory
Cause: out of SGA memory
Action: Increase SGA and restart the instance.
ORA-19759: block change tracking is not enabled
Cause: A command was entered that requires block change tracking to be enabled, but block change tracking is not enabled.
Action: None, this is an informative message only.
ORA-19760: error starting change tracking
Cause: Change tracking is enabled, but a problem was encountered while enabling the change tracking subsystem in this instance. The alert log and the trace file from the CTWR process will contain more information about the error.
Action: Examine the trace and alert files. Correct the error if possible, otherwise disable change tracking.
ORA-19761: block size string is not valid for change tracking file
Cause: While opening the specified change tracking file, it was found that the file header did not contain a valid logical block size. This probably means that the file is corrupt.
Action: If the file can be repaired, do so, otherwise disable and re-enable change tracking to re-initialize the file.
ORA-19762: invalid file type string
Cause: An invalid file type was found in the change tracking file. Some other file was put in place of the change tracking file, or the file is corrupt.
Action: Disable then re-enable change tracking.
ORA-19763: compatibility version string is higher than maximum allowed: string
Cause: The compatibility version in the change tracking file is greater than what can be used by the current release of Oracle. This can happen when you upgrade, use change tracking with a new release, then downgrade.
Action: Disable then re-enable change tracking.
ORA-19764: database id string does not match database id string in control file
Cause: The change tracking file is not the correct one for this database. This can happen when the database ID for this database has been changed.
Action: Disable then re-enable change tracking.
ORA-19765: mount id string does not match mount id string in control file
Cause: d by having a change tracking file that cannot be consistently updated by all instances.
Action: In RAC, ensure that the name specified for the change tracking file truly represents the same disk location for all nodes in the cluster. Disable then re-enable change tracking.
ORA-19766: missing CHANGE keyword
Cause: Syntax error.
Action: Use the correct syntax: ENABLE/DISABLE BLOCK CHANGE TRACKING
ORA-19767: missing TRACKING keyword
Cause: Syntax error.
Action: Use the correct syntax: ENABLE/DISABLE BLOCK CHANGE TRACKING
ORA-19768: USING clause only valid with ENABLE CHANGE TRACKING
Cause: The USING clause was specified with DISABLE CHANGE TRACKING
Action: Correct the statement.
ORA-19769: missing FILE keyword
Cause: Syntax error.
Action: Use the correct syntax: ENABLE/DISABLE BLOCK CHANGE TRACKING
ORA-19770: invalid change tracking file name
Cause: The USING clause was specified with ALTER DATABASE ENABLE BLOCK CHANGE TRACKING, but no file name was given.
Action: Specify the change tracking file name, or omit the USING clause to allow Oracle to create a default name for the change tracking file.
ORA-19771: cannot rename change tracking file while database is open
Cause: The ALTER DATABASE RENAME FILE command was used to rename the change tracking file, and the database is open by one or more instances. The database must be mounted, and not open, to rename the change tracking file.
Action: Close the database and reissue the command.
ORA-19772: change tracking file name exceeds limit of string characters
Cause: The name specified for the change tracking file is too long.
Action: Specify a shorter change tracking file name.
ORA-19773: must specify change tracking file name
Cause: No file name was specified with the ALTER DATABASE ENABLE CHANGE TRACKING command, and the DB_CREATE_FILE_DEST parameter was not set.
Action: Either specify a file name, or set the DB_CREATE_FILE_DEST parameter.
ORA-19776: PROXY restore to ASM diskgroup "string" is not supported.
Cause: An attempt was made to proxy restore a file to ASM diskgroup using RMAN command. This is not supported.
Action: Use a different file name and reissue RMAN command.
ORA-19777: ASM file string cannot be proxy backed up.
Cause: An attempt was made to proxy backup a ASM file. This is not supported.
Action: Use a different file name and reissue RMAN command.
ORA-19800: Unable to initialize Oracle Managed Destination
Cause: The name given for an Oracle managed files destination cannot be initialized.
Action: , if possible, and retry the command or use a different name for destination.
ORA-19801: initialization parameter DB_RECOVERY_FILE_DEST is not set
Cause: An attempt was made to create a file in DB_RECOVERY_FILE_DEST when DB_RECOVERY_FILE_DEST was not set. There are number of possible causes of this error, including: 1) A LOG_ARCHIVE_DEST_n parameter was specified using a LOCATION attribute whose value was DB_RECOVERY_FILE_DEST and an archivelog file creation was attempted. 2) STANDBY_ARCHIVE_DEST parameter was specified using a LOCATION attribute whose value was DB_RECOVERY_FILE_DEST and an archivelog file creation was attempted.
Action: Specify a valid destination for DB_RECOVERY_FILE_DEST in initialization parameter file or with the ALTER SYSTEM SET command.
ORA-19802: cannot use DB_RECOVERY_FILE_DEST without DB_RECOVERY_FILE_DEST_SIZE
Cause: There are two possible cause for this error: 1) The DB_RECOVERY_FILE_DEST parameter was in use when no DB_RECOVERY_FILE_DEST_SIZE parameter was encountered while fetching initialization parameter. 2) An attempt was made to set DB_RECOVERY_FILE_DEST with the ALTER SYSTEM command when no DB_RECOVERY_FILE_DEST_SIZE was in use.
Action: Correct the dependency parameter definitions and retry the command.
ORA-19803: Parameter DB_RECOVERY_FILE_DEST_SIZE is out of range (1 - string)
Cause: Parameter DB_RECOVERY_FILE_DEST_SIZE specfied was not valid.
Action: Specify a valid number within the range.
ORA-19804: cannot reclaim string bytes disk space from string limit
Cause: Oracle cannot reclaim disk space of specified bytes from the DB_RECOVERY_FILE_DEST_SIZE limit.
Action: There are five possible solutions: 1) Take frequent backup of recovery area using RMAN. 2) Consider changing RMAN retention policy. 3) Consider changing RMAN archivelog deletion policy. 4) Add disk space and increase DB_RECOVERY_FILE_DEST_SIZE. 5) Delete files from recovery area using RMAN.
ORA-19805: recid string of string is about to be deleted or resized
Cause: The file described by the record in controlfile was about to be deleted or resized. This probably means another process was resizing this file or deleting this file in order to reclaim disk space.
Action: Wait and try again.
ORA-19806: cannot make duplex backups in recovery area
Cause: Duplex backup to recovery area is not supported.
Action: Remove duplex option and try again.
ORA-19808: recovery destination parameter mismatch
Cause: The value of parameters DB_RECOVERY_FILE_DEST and DB_RECOVERY_FILE_DEST_SIZE must be same in all instances. instance. All databases must have same recovery destination parameters.
Action: Check DB_RECOVERY_FILE_DEST and DB_RECOVERY_FILE_DEST_SIZE values in all instances.
ORA-19809: limit exceeded for recovery files
Cause: The limit for recovery files specified by the DB_RECOVERY_FILE_DEST_SIZE was exceeded.
Action: The error is accompanied by 19804. See message 19804 for further details.
ORA-19810: Cannot create temporary controlfile file string in DB_RECOVERY_FILE_DEST
Cause: An attempt was made to create a controlfile for a temporary purpose in DB_RECOVERY_FILE_DEST.
Action: Retry the operation with a new file name.
ORA-19811: cannot have files in DB_RECOVERY_FILE_DEST with keep attributes
Cause: An attempt was made to 1) Create backuppiece or image copy in the recovery area with KEEP option. 2) Update the KEEP attributes of an existing backup piece or image copy in the recovery area.
Action: Reissue RMAN command without KEEP options.
ORA-19812: cannot use string without DB_RECOVERY_FILE_DEST
Cause: There are three possible cause for this error: 1) The indicated parameter was in use when no DB_RECOVERY_FILE_DEST parameter was encountered while fetching the initialization parameter. 2) An attempt was made to set indicated the parameter with the ALTER SYSTEM command when no DB_RECOVERY_FILE_DEST was in use. 3) An attempt was made to clear DB_RECOVERY_FILE_DEST with the ALTER SYSTEM command when the indicated parameter was in use.
Action: Eliminate any incompatible parameter definitions.
ORA-19813: cannot have unavailable file string in DB_RECOVERY_FILE_DEST
Cause: An attempt was made to change backuppiece or image copy in recovery area to UNAVAILABLE.
Action: Correct and resubmit the RMAN command. Do not use messages 19814; it is used for simulating crash.
ORA-19815: WARNING: string of string bytes is string used, and has string remaining bytes available.
Cause: DB_RECOVERY_FILE_DEST is running out of disk space.
Action: One of the following:

1. Add disk space and increase DB_RECOVERY_FILE_DEST_SIZE.

2. Backup files to tertiary device using RMAN.

3. Consider changing RMAN retention policy.

4. Consider changing RMAN archivelog deletion policy.

5. Delete files from recovery area using RMAN.

ORA-19816: WARNING: Files may exist in string that are not known to database.
Cause: One of the following events caused this:

1. A database crash happened during file creation.

2. A backup controlfile was restored.

3. The controlfile was re-created.

4. DB_RECOVERY_FILE_DEST has previously been enabled and then disabled.

Action: Use RMAN command CATALOG RECOVERY AREA to re-catalog any such files. If the file header is corrupted, then delete those files using an OS utility.
ORA-19830: error from target database: string
Cause: This error should be followed by other errors indicating the cause of the problem.
Action: No action required.
ORA-19831: incompatible string.string.string DBMS_BACKUP_RESTORE package: string.string.string required
Cause: This version of database was incompatible with the the indicated dbms_backup_restore package installed in the database.
Action: If the database has been upgraded from an earlier version, ensure that the catxxxx.sql script has been run successfully. Re-install dbmsbkrs.sql and prvtbkrs.plb if necessary.
ORA-19851: OS error while managing auxiliary database string
Cause: An OS error was received while managing the automatic auxiliary instance.
Action: Check the accompanying errors.
ORA-19852: error creating services for auxiliary instance string (error string)
Cause: An error was received while managing the services of the auxiliary instance.
Action: Check the accompanying errors.
ORA-19853: error preparing auxiliary instance string (error string)
Cause: An error was received while managing the automatic auxiliary instance.
Action: Check the accompanying errors.
ORA-19854: error obtaining connect string from target
Cause: Could not obtain the connect string from the target database
Action: Check the accompanying errors.
ORA-19860: piece validation cannot be performed more than once
Cause: The user attempted to validate a list of backup pieces more than once. Validation may only be performed once for a given validation conversation.
Action: Do not attempt to validate the pieces more than once.
ORA-19861: additional backup pieces cannot be validated in this conversation
Cause: The user tried to add new pieces to the list of files being validated after the validation had already been performed. In a validation conversation, the list can only be validated once.
Action: Add all the backup pieces to the list before validating, or start a new validation conversation for the remaining pieces.
ORA-19862: backup pieces must be validated before accessing results
Cause: The user tried to get validation results for backup pieces before the pieces were actually validated.
Action: Validate the pieces before trying to access the results.
ORA-19900: RESETLOGS must be specified after recovery to new incarnation
Cause: Recovery was done to an incarnation after changing the destination incarnation using RMAN's RESET DATABASE command.
Action: Open the database with the RESETLOGS option.
ORA-19901: database needs more recovery to create new incarnation
Cause: Recovery was done to an incarnation after changing the destination incarnation using RMAN's RESET DATABASE command, but one or more of the recovered datafiles still belongs to the parent incarnation. This usually happens when recovery is ended before any logs from the desired incarnation have been applied.
Action: Continue recovery.
ORA-19902: incarnation key string not found
Cause: The specified incarnation was not found in the controlfile.
Action: Resubmit request with known incarnation key. To see which incarnations are available for this target database, query V$DATABASE_INCARNATION or use RMAN's LIST INCARNATION command.
ORA-19903: test recovery not allowed when recovering to new incarnation
Cause: A new incarnation was set using RMAN's RESET DATABASE command for a controlfile that was CURRENT. As recovery to new incarnation require changing controlfile to BACKUP, test recovery is not allowed.
Action: Perform actual recovery or RESET DATABASE to incarnation that was last opened using the controlfile to do test recovery.
ORA-19904: test recovery not allowed for datafile string
Cause: The specified datafile has been restored from a backup that was taken before the last resetlogs. Recovering this datafile will require a file header update that is incompatible with test recovery.
Action: Perform actual recovery.
ORA-19905: log_archive_format must contain %%s, %%t and %%r
Cause: log_archive_format is missing a mandatory format element. Starting with Oracle 10i, archived log file names must contain each of the elements %s(sequence), %t(thread), and %r(resetlogs id) to ensure that all archived log file names are unique.
Action: Add the missing format elements to log_archive_format.
ORA-19906: recovery target incarnation changed during recovery
Cause: While a media recovery was active, a new incarnation was detected by the server due to inspection or cataloging of archived logs or backup files.
Action: If you want recovery to use the new incarnation, restart recovery. This is the most common action on a standby database when resetlogs is done in primary. If you do not want recovery to use the new incarnation, change the recovery destination using RMAN's RESET DATABASE TO INCARNATION <incarnation#> command. To see which incarnations are available for this target database, query V$DATABASE_INCARNATION or use RMAN's LIST INCARNATION command.
ORA-19907: recovery time or SCN does not belong to recovered incarnation
Cause: A point-in-time recovery to an SCN or timestamp prior to the last resetlogs was requested.
Action: Either change the specified recovery time/scn, or change the recovery destination using RMAN's RESET DATABASE command.
ORA-19908: datafile string has invalid checkpoint
Cause: The specified datafile has an invalid checkpoint.
Action: Restore the datafile from a backup.
ORA-19909: datafile string belongs to an orphan incarnation
Cause: Either the specified datafile was restored from a backup that was taken during a period of time that has already been discarded by a resetlogs operation, or Oracle cannot identify which database incarnation the file belongs to. The alert log contains more information.
Action: Restore a backup of this file that belongs to either the current or a prior incarnation of the database. If you are using RMAN to restore, RMAN will automatically select a correct backup.
ORA-19910: can not change recovery target incarnation in controlfile
Cause: The RESET DATABASE TO INCARNATION command was used while the database is open. This is not allowed.
Action: Close the database then re-issue the command.
ORA-19911: datafile string contains future changes at the incarnation boundary
Cause: The file did not hit end backup marker redo during recovery at the incarnation boundary, hence may contain changes discarded by new incarnation.
Action: Use older backup of the file and then re-issue the command.
ORA-19921: maximum number of string rows exceeded
Cause: The maximum number of rows in the V$RMAN_STATUS or V$RMAN_OUTPUT table has been exceeded.
Action: Close some of existing and unused RMAN connections and sessions.
ORA-19922: there is no parent row with id string and level string
Cause: RMAN tried to add a new V$RMAN_STATUS row, but the parent row did not exist.
Action: This is an internal error. Contact Oracle Support.
ORA-19923: the session for row with id string is not active
Cause: RMAN tried to update an V$RMAN_STATUS row but the process which owns this row died.
Action: This is an internal error. Contact Oracle Support.
ORA-19924: there are no row with id string
Cause: RMAN tried to update an V$RMAN_STATUS row, but the row don't exist.
Action: This is an internal error. Contact Oracle Support.
ORA-19951: cannot modify control file until DBNEWID is completed
Cause: An operation requiring to modify the control file was attempted, but a NID change is in progress.
Action: Wait until NID completes before attempting the operation.
ORA-19960: Internal use only
Cause: NID usage
Action: None
ORA-19999: skip_row procedure was called
Cause: The skip_row procedure was called which raises this error
Action: Skip_row should only be called within a trigger or a procedure called by a trigger.
ORA-20000: %s
Cause: The stored procedure 'raise_application_error' was called which causes this error to be generated.
Action: Correct the problem as described in the error message or contact the application administrator or DBA for more information.
ORA-21300: objects option not installed
Cause: The objects option is not installed at this site. object types and other object features are, therefore, unavailable.
Action: Install the objects option. The objects option is not part of the Oracle Server product and must be purchased separately. Contact an Oracle sales representative if the objects option needs to be purchased.
ORA-21301: not initialized in object mode
Cause: This function requires the OCI process to be initialized in object mode.
Action: Specify OCI_OBJECT mode when calling OCIInitialize().
ORA-21500: internal error code, arguments: [string], [string], [string], [string], [string], [string], [string], [string]
Cause: This is the generic error number for the OCI environment (client-side) internal errors. This indicates that the OCI environment has encountered an exceptional condition.
Action: Report as a bug - the first argument is the internal error number.
ORA-21501: program could not allocate memory
Cause: The operating system has run out of memory.
Action: Take action to make more memory available to the program.
ORA-21503: program terminated by fatal error
Cause: A program is in an unrecoverable error state.
Action: Report as a bug.
ORA-21520: database server driver not installed
Cause: User attempted to access a database server through an object-mode OCI environment but the necessary driver for supporting such access to the database server is not installed or linked in.
Action: Check if the driver corresponding to the database server has been installed/linked in and entered in the server driver table.
ORA-21521: exceeded maximum number of connections in OCI (object mode only)
Cause: User exceeded the maximum number of connections (255) that can be supported by an OCI environment in object mode.
Action: Close some of existing and unused connections before opening more connections.
ORA-21522: attempted to use an invalid connection in OCI (object mode only)
Cause: User attempted to use an invalid connection or a connection that has been terminated in an OCI environment (object mode), or user attempted to dereference a REF obtained from a connection which has been terminated.
Action: Ensure that the connection exists and is still valid.
ORA-21523: functionality not supported by the server (object mode only)
Cause: User attempted to use a functionality that the server does not support.
Action: Upgrade the server
ORA-21524: object type mismatch
Cause: The object type of the object is different from what is specified.
Action: Check the type of the object and correct it.
ORA-21525: attribute number or (collection element at index) string violated its constraints
Cause: Attribute value or collection element value violated its constraint.
Action: Change the value of the attribute or collection element such that it meets its constraints. The constraints are specified as part of the attribute or collection element's schema information.
ORA-21526: initialization failed
Cause: The initialization sequence failed. This can happen, for example, if an environment variable such as NLS_DATE_FORMAT is set to an invalid value.
Action: Check that all NLS environment variables are well-formed.
ORA-21527: internal OMS driver error
Cause: A process has encountered an exceptional condition. This is the generic internal error number for Oracle object management services exceptions.
Action: Report this as a bug to Oracle Support Services.
ORA-21560: argument string is null, invalid, or out of range
Cause: The argument is expecting a non-null, valid value but the argument value passed in is null, invalid, or out of range. Examples include when the LOB/FILE positional or size argument has a value outside the range 1 through (4GB - 1), or when an invalid open mode is used to open a file, etc.
Action: Check your program and correct the caller of the routine to not pass a null, invalid or out-of-range argument value.
ORA-21561: OID generation failed
Cause: The handles passed in may not be valid
Action: Check the validity of the env, svc handles
ORA-21600: path expression too long
Cause: The path expression that is supplied by the user is too long. The path expression is used to specify the position of an attribute in an object. This error occurs when one of the intermediate elements in the path expression refers to an attribute of a built-in type. Thus, the OCI function cannot proceed on to process the rest of the elements in the path expression.
Action: User should pass in the correct path expression to locate the attribute.
ORA-21601: attribute is not an object
Cause: The user attempts to perform an operation (that is valid only for an object) to an attribute of a built-in type. An example of such an illegal operation is to dynamically set a null structure to an attribute of a built-in type.
Action: User should avoid performing such operation to an attribute of built-in type.
ORA-21602: operation does not support the specified typecode
Cause: The user attempts to perform an operation that does not support the specified typecode.
Action: User should use the range of valid typecodes that are supported by this operation.
ORA-21603: property id [string] is invalid
Cause: The specified property id is invalid.
Action: User should specify a valid property id. Valid property ids are enumerated by OCIObjectPropId.
ORA-21604: property [string] is not a property of transient or value instances
Cause: Trying to get a property which applies only to persistent objects.
Action: User should check the lifetime and only get this property for persistent objects.
ORA-21605: property [string] is not a property of value instances
Cause: Trying to get a property which applies only to persistent and transient objects.
Action: User should check the lifetime and only get this property for persistent and transient objects.
ORA-21606: can not free this object
Cause: Trying to free an object that is persistent and dirty and the OCI_OBJECTFREE_FORCE flag is not specified.
Action: Either flush the persistent object or set the flag to OCI_OBJECTFREE_FORCE
ORA-21607: memory cartridge service handle not initialized
Cause: Attempt to use the handle without initializing it.
Action: Initialize the memory cartridge service handle.
ORA-21608: duration is invalid for this function
Cause: Attempt to use a duration not valid for this function.
Action: Use a valid duration - a previously created user duration or OCI_DURATION_STATEMENT or OCI_DURATION_SESSION. For callout duration or external procedure duration, use OCIExtProcAllocCallMemory.
ORA-21609: memory being resized without being allocated first
Cause: Attempt to resize memory without allocating it first.
Action: Allocate the memory first before resizing it.
ORA-21610: size [string] is invalid
Cause: Attempt to resize memory with invalid size.
Action: Pass in a valid size (must be a positive integer).
ORA-21611: key length [string] is invalid
Cause: Attempt to use an invalid key length.
Action: Key length is invalid and valid range is 0 to 64
ORA-21612: key is already being used
Cause: Attempt to use a key that is already used.
Action: Use a new key that is not yet being used.
ORA-21613: key does not exist
Cause: Attempt to use a non-existent key
Action: Use a key that already exists.
ORA-21614: constraint violation for attribute number [string]
Cause: Constraints on the attribute were violated
Action: Correct the value (of the attribute) so that it satisfies constraints
ORA-21615: copy of an OTS (named or simple) instance failed
Cause: see following message
Action: Check that no attribute value violates constraints.
ORA-21700: object does not exist or is marked for delete
Cause: User attempted to perform an inappropriate operation to an object that is non-existent or marked for delete. Operations such as pinning, deleting and updating cannot be applied to an object that is non-existent or marked for delete.
Action: User needs to re-initialize the reference to reference an existent object or the user needs to unmark the object.
ORA-21701: attempt to flush objects to different servers
Cause: User attempted to flush objects to different servers in one function call. These objects are obtained by calling a callback functions provided by the program.
Action: User should avoid performing such operation.
ORA-21702: object is not instantiated or has been de-instantiated in cache
Cause: User attempted to perform an inappropriate operation to a transient object that is not instantiated in the object cache. Operations that cannot be applied to a not-instantiated transient object include deleting or pinning such an object.
Action: User should check their code to see if they are performing such an operation without instantiating the object first, or performing such an operation after the allocation duration of the object has expired.
ORA-21703: cannot flush an object that is not modified
Cause: See the error message.
Action: The object should not be flushed.
ORA-21704: cannot terminate cache or connection without flushing first
Cause: See the error message.
Action: The transaction should be aborted or committed before terminating the cache or connection.
ORA-21705: service context is invalid
Cause: The service context that is supplied by the user is not valid.
Action: User needs to establish the service context.
ORA-21706: duration does not exist or is invalid
Cause: The duration number that is supplied by the user is not valid.
Action: User needs to establish the duration or use a correct predefined duration.
ORA-21707: pin duration is longer than allocation duration
Cause: The pin duration supplied by the user is longer than the allocation duration. This affects operations such as pinning and setting default parameters.
Action: User should use a shorter pin duration or use the null duration.
ORA-21708: inappropriate operation on a transient object
Cause: User attempted to perform an inappropriate operation on a transient object. Operations that cannot be applied to a transient object include flushing and locking.
Action: User should avoid performing such operation on a transient object.
ORA-21709: cannot refresh an object that has been modified
Cause: User attempted to refresh an object that has been marked for delete, update or insert (new).
Action: User should unmark the object before refreshing it.
ORA-21710: argument is expecting a valid memory address of an object
Cause: The object memory address that is supplied by the user is invalid. The user may have passed in a bad memory address to a function that is expecting a valid memory address of an object.
Action: User should pass in a valid memory address of an object to the function.
ORA-21779: duration not active
Cause: User is trying to use a duration that has been terminated.
Action: User should avoid performing such operation.
ORA-22053: overflow error
Cause: This operation's result is above the range of Oracle number.
Action: Decrease the input value(s) so that the result is in the range of Oracle number.
ORA-22054: underflow error
Cause: This operation's result is below the range of Oracle number.
Action: Increase the input value(s) so that the result is in the range of Oracle number.
ORA-22055: unknown sign flag value [string]
Cause: Signed flag used is not OCI_NUMBER_SIGNED or OCI_NUMBER_UNSIGNED.
Action: Use either OCI_NUMBER_SIGNED or OCI_NUMBER_UNSIGNED as sign flag.
ORA-22056: value [string] is divided by zero
Cause: Given value is divied by zero.
Action: Modify divisor value to be non-zero.
ORA-22057: bad integer length [string]
Cause: The length of the integer (ie number of bytes) to be converted to or from an Oracle number is invalid.
Action: Use integer length 1, 2, 4 or 8 bytes only.
ORA-22059: buffer size [string] is too small - [string] is needed
Cause: The buffer to hold the resulting text string is too small.
Action: Provide a buffer of the required size.
ORA-22060: argument [string] is an invalid or uninitialized number
Cause: An invalid or uninitialized number is passed in.
Action: Use a valid number. To initialize number call OCINumberSetZero().
ORA-22061: invalid format text [string]
Cause: The numeric format string for converting characters to or from an Oracle number is invalid.
Action: Use valid format string as documented in OCI Programmer's Guide.
ORA-22062: invalid input string [string]
Cause: The text string for converting to numbers is invalid.
Action: Use a valid input string as documented in OCI Programmer's Guide.
ORA-22063: reading negative value [string] as unsigned
Cause: Attempt to convert a negative number to an unsigned integer.
Action: Use the sign flag ORLTSB to convert a signed number.
ORA-22064: invalid NLS parameter string [string]
Cause: The NLS parameter string for converting characters to or from an Oracle number is invalid.
Action: Use valid format string as documented in OCI Programmer's Guide.
ORA-22065: number to text translation for the given format causes overflow
Cause: Rounding done due to the given string format causes overflow.
Action: Change the string format such that overflow does not occur.
ORA-22130: buffer size [string] is less than the required size [string]
Cause: The size of the buffer into which the hexadecimal REF string is to be written is too small.
Action: Provide a buffer of the required size.
ORA-22131: hexadecimal string length is zero
Cause: The given hexadecimal string length must be greater than zero.
Action: Specify a length greater than zero.
ORA-22132: hexadecimal string does not correspond to a valid REF
Cause: The given hexadecimal string is invalid.
Action: Provide a valid hexadecimal string which was previously returned by a call to OCIRefToHex().
ORA-22140: given size [string] must be in the range of 0 to [string]
Cause: The given resize size is invalid.
Action: Ensure that the given size is in the required range.
ORA-22150: variable-length array has not been initialized
Cause: An un-initialized variable-length array is being operated upon.
Action: Initialize the variable-length array prior to calling this function.
ORA-22151: cannot resize non-zero variable-length array to zero elements
Cause: Trying to resize a non-zero variable-length array to 0 elements.
Action: Specify a non-zero size.
ORA-22152: destination variable-length array is not initialized
Cause: The variable-length array on the right-hand-side of an assignment or the destination array of an append is not initialized.
Action: Initialize the destination variable-length array prior to calling this function.
ORA-22153: source variable-length array is not initialized
Cause: The variable-length array on the left-hand-side of an assignment or the source array of an append is not initialized.
Action: Initialize the destination variable-length array prior to calling this function.
ORA-22160: element at index [string] does not exist
Cause: Collection element at the given index does not exist.
Action: Specify the index of an element which exists.
ORA-22161: type code [string] is not valid
Cause: Given type code is not valid.
Action: Use one of the typecodes enumerated in OCITypeCode.
ORA-22162: element at index [string] has been previously deleted
Cause: Trying to delete a non-existent collection element.
Action: Check for the existence of the element prior to calling this function.
ORA-22163: left hand and right hand side collections are not of same type
Cause: Left hand and right side collections are not of same type.
Action: Ensure that the same collection type is passed for both left hand and right hand side of this function.
ORA-22164: delete element operation is not allowed for variable-length array
Cause: Trying to delete an element of a variable-length array.
Action: Ensure that the collection is not a variable-length array prior to calling this function.
ORA-22165: given index [string] must be in the range of 0 to [string]
Cause: Given index is not in the required range.
Action: Ensure that the given index is in the required range.
ORA-22166: collection is empty
Cause: Given collection is empty.
Action: Test if collection is empty prior to invoking this function.
ORA-22167: given trim size [string] must be less than or equal to [string]
Cause: Given trim size is greater than the current collection size.
Action: Ensure that the given size is less than or equal to the collection size prior to calling this function.
ORA-22275: invalid LOB locator specified
Cause: There are several causes: (1) the LOB locator was never initialized; (2) the locator is for a BFILE and the routine expects a BLOB/CLOB/NCLOB locator; (3) the locator is for a BLOB/CLOB/NCLOB and the routine expects a BFILE locator; (4) trying to update the LOB in a trigger body -- LOBs in trigger bodies are read only; (5) the locator is for a BFILE/BLOB and the routine expects a CLOB/NCLOB locator; (6) the locator is for a CLOB/NCLOB and the routine expects a BFILE/BLOB locator;
Action: For (1), initialize the LOB locator by selecting into the locator variable or by setting the LOB locator to empty. For (2),(3), (5) and (6)pass the correct type of locator into the routine. For (4), remove the trigger body code that updates the LOB value.
ORA-22276: invalid locator for LOB buffering
Cause: There are several causes: (1) the locator was never enabled for buffering (2) it is not an updated locator but is being used for a write/flush operation
Action: For (1) enable the locator for buffering; (2) ensure that only an updated locator is used for a LOB update operation
ORA-22277: cannot use two different locators to modify the same LOB
Cause: LOB buffering is enabled and an attempt was made to modify the LOB using two different LOB locators.
Action: When using LOB buffering, modify the LOB through one LOB locator only.
ORA-22278: must update the LOB only through the LOB buffers
Cause: LOB buffering is enabled for this LOB and there are buffers for this LOB in the buffer pool. Thus, updating the LOB through means other than the LOB buffers is not allowed.
Action: Update the LOB through the LOB buffers using the locator that has LOB buffering enabled. If this operation is required, buffers associated with this LOB should either be flushed as necessary or buffering should be disabled. Once this is done, reissue the command.
ORA-22279: cannot perform operation with LOB buffering enabled
Cause: The operation attempted is not allowed when LOB buffering is enabled.
Action: If the operation is required, LOB buffering should not be used. In this case, flush buffers associated with the input LOB locator as necessary, disable buffering on the input LOB locator and reissue the command.
ORA-22280: no more buffers available for operation
Cause: There are two causes: (1) All buffers in the buffer pool have been used up by previous operations (2) Attempt to flush a LOB without any previous buffered update operations.
Action: For (1), flush the LOB(s) through the locator that is being used to update the LOB. For (2), write to the LOB through a locator enabled for buffering before attempting to flush buffers.
ORA-22281: cannot perform operation with an updated locator
Cause: The input locator has buffering enabled and was used to update the LOB value through the LOB buffering subsystem. The modified buffer has not been flushed since the write that was performed by the the input locator; thus, the input locator is considered an updated locator. Updated locators cannot be the source of a copy operation. Only one locator per LOB may be used to modify the LOB value through the LOB buffering subsystem.
Action: Depending on whether the modifications made through the input locator to the LOB buffering subsystem should be written to the server, either flush the buffer to write the modifications, or, disable buffering on the locator to discard the modifications. Then, reissue the command.
ORA-22282: non-contiguous append to a buffering enabled LOB not allowed
Cause: The buffered write operation has an input offset value more than one byte or character past the end of the LOB.
Action: Specify an input offset value which is exactly one character or byte greater than the length of the LOB that you are attempting to update through a buffered write operation.
ORA-22283: filename contains characters that refer to parent directory
Cause: Filename contains a path "../" which references a parent directory
Action: Ensure that the filename does not contain characters which reference a parent directory.
ORA-22285: non-existent directory or file for string operation
Cause: Attempted to access a directory that does not exist, or attempted to access a file in a directory that does not exist.
Action: Ensure that a system object corresponding to the specified directory exists in the database dictionary, or make sure the name is correct.
ORA-22286: insufficient privileges on file or directory to perform string operation
Cause: The user does not have the necessary access privileges on the directory alias and/or the file for the operation.
Action: Ask the database/system administrator to grant the required privileges on the directory alias and/or the file.
ORA-22287: invalid or modified directory occurred during string operation
Cause: The directory alias used for the current operation is not valid if being accessed for the first time, or has been modified by the DBA since the last access.
Action: If you are accessing this directory for the first time, provide a valid directory name. If you have been already successful in opening a file under this directory before this error occured, then close the file and retry the operation with a valid directory alias as modified by your DBA. Oracle recommends that directories should be modified only during quiescent periods.
ORA-22288: file or LOB operation string failed string
Cause: The operation attempted on the file or LOB failed.
Action: See the next error message in the error stack for more detailed information. Also, verify that the file or LOB exists and that the necessary privileges are set for the specified operation. If the error still persists, report the error to the DBA.
ORA-22289: cannot perform string operation on an unopened file or LOB
Cause: The file or LOB is not open for the required operation to be performed.
Action: Precede the current operation with a successful open operation on the file or LOB.
ORA-22290: operation would exceed the maximum number of opened files or LOBs
Cause: The number of open files or LOBs has reached the maximum limit.
Action: Close some of the opened files or LOBs and retry the operation.
ORA-22291: Open LOBs exist at transaction commit time
Cause: An attempt was made to commit a transaction with open LOBs at transaction commit time.
Action: Close the LOBs before committing the transaction.
ORA-22292: Cannot open a LOB in read-write mode without a transaction
Cause: An attempt was made to open a LOB in read-write mode before a transaction was started.
Action: Start a transaction before opening the LOB in read-write mode. Ways to start a transaction include issuing a SQL DML or SELECT FOR UPDATE command. Opening hte LOB in read-only mode does not require a transaction.
ORA-22293: LOB already opened in the same transaction
Cause: An attempt was made to open a LOB that already is open in this transaction.
Action: Close the LOB before attempting to re-open it.
ORA-22294: cannot update a LOB opened in read-only mode
Cause: An attempt was made to write to or update a LOB opened in read-only mode.
Action: Close the LOB and re-open it in read-write mode before attempting to write to or update the LOB.
ORA-22295: cannot bind more than 4000 bytes data to LOB and LONG columns in 1 statement
Cause: An attempt was made to bind data more than 4000 bytes of data to both LOB and LONG columns in the same insert or update statement. You can bind more than 4000 bytes of data to either a LONG column or one or more LOB columns but not both.
Action: Bind more than 4000 bytes of data to either the LONG column or one or more LOB columns but not both.
ORA-22296: invalid ALTER TABLE option for conversion of LONG datatype to LOB
Cause: An attempt was made to specify ALTER TABLE options which are disallowed during conversion of LONG datatype to LOB. The only ALTER TABLE options allowed during conversion of LONG datatype to LOB are the default clause and LOB storage clause for the column being converted to LOB.
Action: Remove the disallowed options.
ORA-22297: warning: Open LOBs exist at transaction commit time
Cause: An attempt was made to commit a transaction with open LOBs at transaction commit time.
Action: This is just a warning. The transaction was commited successfully, but any domain or functional indexes on the open LOBs were not updated. You may want to rebuild those indexes.
ORA-22298: length of directory alias name or file name too long
Cause: The length of directory alias name or file name given for a BFILE is too long.
Action: Use a shorter alias or file name.
ORA-22303: type "string"."string" not found
Cause: The user is trying to obtain information for a type that cannot be found.
Action: Check that the schema is correct and that the type has been created correctly.
ORA-22304: input type is not an object type
Cause: The user is trying to obtain the supertype information for a non-object type.
Action: Pass in only an object type.
ORA-22305: attribute/method/parameter "string" not found
Cause: Type element with the given name is not found in the type.
Action: Check to make sure that the type element exists.
ORA-22306: type "string"."string" already exists
Cause: The user is trying to create a type that already exists.
Action: Check to make sure that the type has not been created prior to this.
ORA-22307: operation must be on a user-defined type
Cause: attempt to perform an operation that is allowed only on a user-defined type, and the type is not a user-defined type.
Action: Check to make sure that only user-defined types are being operated on.
ORA-22308: operation not allowed on evolved type
Cause: An attempt was made to replace a type whose attribute definition been been altered.
Action: Submit ALTER TYPE ADD/DROP statement instead of ALTER TYPE REPLACE.
ORA-22309: attribute with name "string" already exists
Cause: The user is attempting to create an object type where more than one attributes have the same name.
Action: Check to make sure that all attribute names are unique.
ORA-22310: ALTER TYPE error. Refer to table "string"."string" for errors
Cause: An invalid alter type statement was submitted.
Action: Correct the errors listed in specified table and resubmit statement.
ORA-22311: type for attribute "string" does not exist
Cause: The type of the attribute does not exist.
Action: No types were created/modified for this DDL transaction. Redo the DDL transaction and add the creation of the attribute's type in the DDL transaction.
ORA-22312: must specify either CASCADE or INVALIDATE option
Cause: An attempt was made to alter a type which has a dependent type or table without specifying the CASCADE or INVALIDATE option.
Action: Resubmit the statement with either the CASCADE or INVALIDATE option. Specify CASCADE if you want to cascade the type change to dependent types and tables; otherwise, specify INVALIDATE to invalidate all dependents.
ORA-22313: cannot use two versions of the same type "string"
Cause: The version of this type conflicts with the version of this type used by another library that was linked in with the application. An application may only use one version of a type.
Action: Check that the libraries being linked with this application and use the same versions of the type.
ORA-22314: method information mismatch in ALTER TYPE
Cause: The number of methods or the method signature do not match that of the original type declaration. This is not supported.
Action: Make sure the method signature stay identical for the previously declared method. Do not drop existing methods.
ORA-22315: type "string" does not contain a map or order function
Cause: The input type does not contain a map or order function so one cannot be returned.
Action: Add a map or order function to the type or catch this error.
ORA-22316: input type is not a collection type
Cause: The user is trying to obtain information for collection types on a non-named collection type.
Action: Use a named collection type for the function.
ORA-22317: typecode number is not legal as a number type
Cause: The user is trying to use a number typecode that is not valid.
Action: Use only OCI_TYPECODE_SMALLINT, OCI_TYPECODE_INTEGER, OCI_TYPECODE_REAL, OCI_TYPECODE_DOUBLE, OCI_TYPECODE_FLOAT, OCI_TYPECODE_NUMBER, or OCI_TYPECODE_DECIMAL.
ORA-22318: input type is not an array type
Cause: The user is trying to obtain the number of elements for a non-array type.
Action: Pass in only a named collection type which is an array.
ORA-22319: type attribute information altered in ALTER TYPE
Cause: The type attribute information does not match that of the original type declaration when altering type. Attributes cannot be altered during ALTER TYPE. Only new methods can be added.
Action: Check that all type alterations are legal.
ORA-22320: missing user version string
Cause: The VERSION option is specified without a user version string.
Action: Resubmit the statement with the version string following the VERSION keyword.
ORA-22321: method does not return any result
Cause: OCITypeResult() was called on a method that does not return any results.
Action: Check that you are passing in the correct method descriptor, or that your method creation was done correctly.
ORA-22322: error table "string"."string" has incorrect structure
Cause: The specified error table does not have the expected table structure.
Action: Execute the DBMS_UTILITY.CREATE_ALTER_TYPE_ERROR_TABLE procedure to create an error table, then resubmit the statement using the new error table.
ORA-22323: error table "string"."string" does not exist
Cause: The error table does not exist.
Action: Resubmit the statement with a correct error table name.
ORA-22324: altered type has compilation errors
Cause: The use of the ALTER TYPE statement caused a compilation error.
Action: Correct the error reported and resubmit the statement.
ORA-22326: cannot change a type to FINAL if it has subtypes
Cause: An attempt was made to change a type with subtypes to FINAL.
Action: Drop all subtypes of the target type before changing it to FINAL.
ORA-22327: cannot change a type to NOT INSTANTIABLE if it has dependent tables
Cause: An attempt was made to change a type with dependent tables to NOT INSTANTIABLE.
Action: Drop all dependent tables of the target type and resubmit the statement.
ORA-22328: object "string"."string" has errors. string
Cause: Altering the target type causes errors in its dependent object.
Action: Correct the problem in the dependent object and resubmit the statement.
ORA-22329: cannot alter a non-object type
Cause: An attempt was made to execute ALTER TYPE on a non-object type.
Action: Drop the non-object type first, then re-create it as an object type.
ORA-22330: cannot alter a type that is not valid
Cause: An attempt was made to perform ALTER TYPE on an invalid type.
Action: Use the CREATE OR REPLACE TYPE command to modify the type.
ORA-22331: cannot alter an incomplete type
Cause: An attempt was made to perform ALTER TYPE on an incomplete type.
Action: Use CREATE TYPE to completely define the original type before executing the ALTER TYPE.
ORA-22332: a dependent object in schema "string" has errors. string
Cause: Altering the target type causes errors in its dependent object.
Action: Correct the problem in the dependent object and resubmit the statement.
ORA-22333: cannot reset type "string"."string" due to invalid dependent types and tables
Cause: An attempt was made to reset the type version with invalid dependent types and tables.
Action: Use the ALTER TYPE COMPILE statement to compile all invalid dependent types and use the ALTER TABLE UPGRADE INCLUDING DATA to upgrade all the dependent tables then resubmit the statement.
ORA-22334: cannot reset type "string"."string". Dependent tables must be upgraded to latest version
Cause: An attempt was made to reset the type version when the data in the dependent table has not been upgraded to the latest type version.
Action: Use the ALTER TABLE UPGRADE INCLUDING DATA statement to upgrade the data in the dependent tables then resubmit the statement.
ORA-22335: The client cannot work with an altered type
Cause: A pre 8.2 client has requested a type that has been altered on the server.
Action: Only 8.2 or higher clients could access altered types
ORA-22336: table contained 8.0 image format, must specify INCLUDING DATA
Cause: One of the following: 1) An attempt was made to alter a type with a dependent table in 8.0 image format and the NOT INCLUDING TABLE DATA option was specified. 2) An attempt was made to upgrade a table in 8.0 image format with the NOT INCLUDING DATA option specified.
Action: Resubmit the statement with INCLUDING DATA option.
ORA-22337: the type of accessed object has been evolved
Cause: The type of the accessed object has been altered and the client's object is based on an earlier type definition.
Action: The user needs to exit application and modify application to accommodate the type change. From SQL/PLUS, reconnect and resubmit statement.
ORA-22338: must specify CASCADE INCLUDING DATA when altering the final property
Cause: An attempt was made to alter the final property of a type with dependent table(s) without specifying the CASCADE INCLUDING DATA . option.
Action: Resubmit the statement with the CASCADE INCLUDING DATA option.
ORA-22339: cannot alter to not final since its attribute column is substitutable
Cause: An attempt was made to alter a type to not final when its embedded attribute is defined as substitutable in some tables. Note, this is a restriction in 9.0 version because when a type is altered to not final, column of that type is set to not substitutable at all levels; thus, it is an error if one of its embedded attribute column is already marked substitutable.
Action: Recreate the table and specify NOT SUBSTITUTABLE AT ALL LEVELS for all columns of non final type. Then resubmit the ALTER TYPE statement.
ORA-22340: cannot string type "string"."string". Dependent tables must be upgraded to latest version
Cause: An attempt was made to reset the version, drop or alter a type when the data in dependent table has not been upgraded to the latest version.
Action: Use the ALTER TABLE UPGRADE INCLUDING DATA statement to upgrade the data in the dependent tables then resubmit the statement.
ORA-22341: cannot assign supertype instance to subtype
Cause: An attempt was made to assign or copy a supertype instance to a container (destination) that can only hold a subtype instance.
Action: Make sure the runtime type of the source of the assignment or copy is the same type as the destination or is a subtype of the destination type
ORA-22342: dependent VARRAY column exceeds the maximum inline column size
Cause: An attempt was made to alter a type (add or modify attribute) which causes the size of its dependent VARRAY column to exceed the maximum inline column size. However, the VARRAY column was not specified to be stored as LOB at the table level when the table was created.
Action: Specify the VARRAY column to be stored as LOB at the table level when the table is created.
ORA-22343: Compilation error for type invalidated by ALTER TYPE
Cause: Compilation failed for a type which was invalidated by ALTER TYPE. We throw this error and rollback the compilation effort so that the user may be able to fix whatever is causing the compilation error and try again. It is important that we do not chnage status here and modify the dependency information as this will affect the creation of versions.
Action: Check what is causing teh compilation error and correct it and try again.
ORA-22344: can not specify CONVERT TO SUBSTITUTABLE option for ALTER TYPE other than NOT FINAL change
Cause: An attempt was made to specify CONVERT TO SUBSTITUTABLE option for ALTER TYPE other than NOT FINAL change.
Action: Specify CONVERT TO SUBSTITUTABLE option only for ALTER TYPE NOT FINAL change.
ORA-22345: recompile type string.string before attempting this operation
Cause: An attempt was made to perform an operation which requires the specified datatype to be valid, but the datatype is invalid
Action: Recompile the specified type and retry the operation
ORA-22346: Type has cyclical dependency. Should use CASCADE option
Cause: An attempt was made to alter a type which has a cyclical dependency, with invalidate option.
Action: Give CASCADE option instead of INVALIDATE
ORA-22347: No changes to type specified for ALTER TYPE
Cause: The ALTER TYPE does not contain any changes to the type.
Action: If any change is required for the type, modify the ALTER TYPE to specify the change. Else no need for the ALTER.
ORA-22369: invalid parameter encountered in method string
Cause: An invalid parameter is being passed to this method of SYS.AnyType ,SYS.AnyData or SYS.AnyDataSet
Action: Check the parameters being passed to this method and make sure that the parameters are allowed.
ORA-22370: incorrect usage of method string
Cause: This method of SYS.AnyType or SYS.AnyData or SYS.AnyDataSet is being used inappropriately.
Action: Check the documentation for correct usage.
ORA-22371: Table contains data of type string.string, version string, which does not exist
Cause: Some of the older versions of the type may have got deleted because one or more of the types it were referencing was dropped.
Action: These data could not be read as the whole ADT. Read the data at individual scalar attribute level.
ORA-22600: encountered 8.0.2 (Beta) VARRAY data that cannot be processed
Cause: Production Oracle8 (8.0.3 and beyond) encounters some VARRAY data which was created and stored by Oracle8 8.0.2 (Beta 2). Production Oracle8 cannot understand or process such VARRAY data.
Action: Delete the VARRAY data from the table by dropping the table, deleting the rows, or nulling out the VARRAY columns, and then re-insert the VARRAY data. There is no provided script or tool to help automate this conversion.
ORA-22601: pickler TDS context [string] is not initialized
Cause: Attempt to use the pickler TDS context without initializing it.
Action: Use OCIPicklerTdsCtxInit to initialize the context.
ORA-22602: pickler TDS handle [string] is not well-formed
Cause: Attempt to use the pickler TDS handle without initializing/ constructing it.
Action: Use OCIPicklerTdsInit to initialize the handle before it is constructed. Use OCIPicklerTdsGenerate to generate the TDS before its attributes can be accessed.
ORA-22603: cannot add an attribute to the already generated TDS handle
Cause: Attempt to add an attribute to the already constructed TDS.
Action: Use a TDS handle that is initialized but not yet constructed.
ORA-22604: TDS handle already generated
Cause: Attempt to geneate TDS that is already genearated.
Action: Use a TDS handle that is initialized but not yet generated.
ORA-22605: FDO handle [string] is not initialized
Cause: Attempt to use an uninitialized FDO handle.
Action: Use OCIPicklerFdoInit to initialize FDO handle".
ORA-22606: pickler image handle [string] is not well-formed
Cause: Attempt to use the image handle without initializing/ constructing it.
Action: Use OCIPicklerImageInit to initialize the handle before it is constructed. Use OCIPicklerImageGenerate to generate the image before its attributes can be accessed.
ORA-22607: image handle already generated
Cause: Attempt to geneate image that is already genearated.
Action: Use a image handle that is initialized but not yet generated.
ORA-22608: cannot add an attribute to the already generated image handle
Cause: Attempt to add an attribute to the already constructed image.
Action: Use a image handle that is initialized but not yet constructed.
ORA-22609: error string during initialization of FDO
Cause: Error during FDO initialization.
Action: Take an action based on the specified error.
ORA-22610: error while adding a scalar to the image handle
Cause: Error while adding a scalar attribute to the image handle
Action: Make sure image handle is initialized before adding scalar
ORA-22611: TDS version is not recognized
Cause: Incorrect TDS handle is passed
Action: Make sure image handle is initialized with the correct TDS
ORA-22612: TDS does not describe a collection TDS
Cause: collection construct/access routines are being on an image but the TDS does not describe that a collection TDS
Action: Make sure a collection TDS is used before invoking collection routines on the image handle
ORA-22613: buflen does not match the size of the scalar
Cause: buflen is incorrect
Action: Make sure buflen is correct and matches the size of the scalar
ORA-22614: error while construction the collection in the image
Cause: Error during the construction of collection
Action: Make sure image handle is initialized and OCIPicklerImageCollBegin is called to begin collection
ORA-22615: attribute is not a collection
Cause: collection routine is invoked upon a non-collection attribute
Action: Make sure attribute is a collection
ORA-22616: image is not of Oracle 8.1 format
Cause: The function being invoked is applicable only for 8.1 images
Action: Make sure image is of 8.1 format
ORA-22617: error while accessing the image handle collection
Cause: Error while accessing collection in the image handle
Action: Make sure image is initialized correctly and the collection is constructed properly.
ORA-22618: attribute is a BAD NULL in the image handle
Cause: attribute in question is probably the attribute of a null embedded image
Action: Make sure attribute number is valid or it is NULL or NOT NULL.
ORA-22619: all collection elements have already been accessed
Cause: Accessing a collection element after all the collection elements are already accessed
Action: This function should not be invoked any more.
ORA-22620: buffer size too small to hold the value
Cause: Buffer size is not enough to hold the value. Most likely while doing the character set conversion, a bigger buffer is needed.
Action: Pass in a bigger buffer. If the client character set format differs from that of server, doing the conversion may result in 4X expansion.
ORA-22621: error transfering an object from the agent
Cause: Any error returned from pickler routines on the agent side.
Action: Contact Oracle Support.
ORA-22625: OCIAnyData is not well-formed
Cause: Attempt to use the OCIAnyData without initializing constructing it.
Action: Use OCIAnyDataBeginConstruct to initialize the handle before it is adding attributes. Use OCIAnyDataEndConstruct to complete the construction. Or use OCIAnyDataConvert to do the construction. MAke sure it is properly constructed before accessing attributes.
ORA-22626: Type Mismatch while constructing or accessing OCIAnyData
Cause: Type supplied is not matching the type of the AnyData. If piece wise construction or access is being attempted, the type supplied is not matching the type of the current attribute.
Action: Make sure the type supplied matches the type of object to to be constucted or accessed.
ORA-22627: tc [string] must be that of object/varray/nested table
Cause: Type code is not that of object/varray/nested table
Action: Make sure the type code is OCI_TYPECODE_OBJECT or OCI_TYPECODE_VARRAY or OCI_TYPECODE_TABLE
ORA-22628: OCIAnyData already constructed
Cause: Attempt to add attributes to OCIAnyData that is already constructed.
Action: Use the OCIAnyData that is initialized but not yet constructed.
ORA-22629: OCIAnyData is null
Cause: Attempting an operation that is not valid on null OCIAnyData
Action: Make sure OCIAnyData is not null.
ORA-22630: attribute [string] is null or it is not well-formed
Cause: Passing an attribute that is null or not well-formed
Action: Make sure the attribute is not null or is well-formed.
ORA-22631: attribute [string] is is not well-formed or does not match the type
Cause: Passing an attribute that is not well-formed or does not match the input type.
Action: Make sure the attribute is well-formed and matches the type specified.
ORA-22632: AnyDataSet parameter is not valid for the current operation
Cause: The AnyDataSet parameter is null or it is somehow invalid for the current operation.
Action: Check the documentation for the current operation.
ORA-22633: Error freeing AnyDataSet
Cause: AnyDataSet that is passed in may not be valid.
Action: Check all the AnyDataSet parameters.
ORA-22634: Error adding new instance to AnyDataSet
Cause: Current instance in the AnyDataSet has not been fully constructed.
Action: Make sure that the current instance is fully constructed before adding new instance.
ORA-22800: invalid user-defined type
Cause: An attempt was made to use an incomplete type as a constructor.
Action: Complete the type definition before using it in a query.
ORA-22801: invalid object row variable
Cause: The specified object row variable is not available in the scope of name resolution.
Action: Verify the specified object row variable is correct, or use an object row variable visible in scope.
ORA-22803: object type contains zero attributes
Cause: An attempt was made to create or specify a column or constructor of an object type that has no attributes. Only object types that have at least one attribute are allowed in this context.
Action: specify a valid object type
ORA-22804: remote operations not permitted on object tables or user-defined type columns
Cause: An attempt was made to perform queries or DML operations on remote object tables or on remote table columns whose type is one of object, REF, nested table or VARRAY.
Action: none
ORA-22805: cannot insert NULL object into object tables or nested tables
Cause: An attempt was made to insert a NULL object into an object table or a Nested Table.
Action: Ensure that a non-NULL object is inserted into the table or insert an object with attributes whose values are NULL.
ORA-22806: not an object or REF
Cause: An attempt was made to extract an attribute from an item that is neither an object nor a REF.
Action: Use an object type or REF type item and retry the operation.
ORA-22807: cannot resolve to a scalar type or a collection type
Cause: Invalid use of a non-scalar (for example, object type) item.
Action: Change the item's data type and retry the operation.
ORA-22808: REF dereferencing not allowed
Cause: An attempt was made to access an object type's attributes by dereferencing a REF item.
Action: Make the item an object type instead of a REF to an object type.
ORA-22809: nonexistent attribute
Cause: An attempt was made to access a non-existent attribute of an object type.
Action: Check the attribute reference to see if it is valid. Then retry the operation.
ORA-22810: cannot modify object attributes with REF dereferencing
Cause: An attempt was made to modify the attributes an object by dereferencing a REF column in an UPDATE statement.
Action: Update the table containing the object that the REF points to, or change the REF column to an object type column.
ORA-22812: cannot reference nested table column's storage table
Cause: An attempt to access the nested table column's storage table is not allowed in the given context.
Action: Issue the statement against the parent table containing the nested table column.
ORA-22813: operand value exceeds system limits
Cause: Object or Collection value was too large. The size of the value might have exceeded 30k in a SORT context, or the size might be too big for available memory.
Action: Choose another value and retry the operation.
ORA-22814: attribute or element value is larger than specified in type
Cause: Value provided for the object type attribute or collection element exceeded the size specified in the type declaration.
Action: Choose another value and retry the operation.
ORA-22816: unsupported feature with RETURNING clause
Cause: RETURNING clause is currently not supported for object type columns, LONG columns, remote tables and INSERT with subquery.
Action: Use separate select statement to get the values.
ORA-22817: subquery not allowed in the default clause
Cause: An attempt was made to use a subquery in the column default clause expression.
Action: Remove the subquery from the default clause.
ORA-22818: subquery expressions not allowed here
Cause: An attempt was made to use a subquery expression where these are not supported.
Action: Rewrite the statement without the subquery expression.
ORA-22819: scope of input value does not correspond to the scope of the target
Cause: An attempt to operate on a REF value scoped to a different table than the expected one
Action: Use a ref which is scoped to the expected table and retry the operation
ORA-22826: cannot construct an instance of a non instantiable type
Cause: An attempt was made to use a non instantiable type as a constructor.
Action: None.
ORA-22828: input pattern or replacement parameters exceed 32K size limit
Cause: Value provided for the pattern or replacement string in the form of VARCHAR2 or CLOB for LOB SQL functions exceeded the 32K size limit.
Action: Use a shorter pattern or process a long pattern string in multiple passes.
ORA-22833: Must cast a transient type to a persistent type
Cause: An attempt was made to use the transient type in the query result.
Action: Cast the transient type to a structurally equivalent persistent type.
ORA-22850: duplicate LOB storage option specificed
Cause: A LOB storage option (CHUNK, PCTVERSION, CACHE, NOCACHE, TABLESPACE, STORAGE, INDEX) was specified more than once.
Action: Specify all LOB storage options only once.
ORA-22851: invalid CHUNK LOB storage option value
Cause: The specified CHUNK LOB storage option value must be an integer.
Action: Choose an appropriate integer value and retry the operation.
ORA-22852: invalid PCTVERSION LOB storage option value
Cause: The specified PCTVERSION LOB storage option value must be an integer.
Action: Choose an appropriate integer value and retry the operation.
ORA-22853: invalid LOB storage option specification
Cause: A LOB storage option was not specified
Action: Specify one of CHUNK, PCTVERSION, CACHE, NOCACHE, TABLESPACE, STORAGE, INDEX as part of the LOB storage clause.
ORA-22854: invalid option for LOB storage index
Cause: A valid LOB store index option was not specified.
Action: Specify one of (INITTRANS, MAXTRANS, TABLESPACE, STORAGE) as part of the LOB storage index.
ORA-22855: optional name for LOB storage segment incorrectly specified
Cause: The optional name for LOB storage segment was specified with multiple columns in the column list.
Action: Specify each column LOB storage only with optional name(s).
ORA-22856: cannot add columns to object tables
Cause: An attempt was made to add columns to an object table. Object tables cannot be altered to add columns since its definition is based on an object type.
Action: Create a new type with additional attributes, and use the new type to create an object table. The new object table will have the desired columns.
ORA-22857: cannot modify columns of object tables
Cause: An attempt was made to alter the object table by modifing existing columns. An object table cannot be altered to modify existing columns since it is based on an object type. The table definition must be in sync with the corresponding type.
Action: Create a new type with the desired attribute types and use it to create an object table. The new object table will have the desired columns.
ORA-22858: invalid alteration of datatype
Cause: An attempt was made to modify the column type to object, REF, nested table, VARRAY or LOB type.
Action: Create a new column of the desired type and copy the current column data to the new type using the appropriate type constructor.
ORA-22859: invalid modification of columns
Cause: An attempt was made to modify an object, REF, VARRAY, nested table, or LOB column type.
Action: Create a new column of the desired type and copy the current column data to the new type using the appropriate type constructor.
ORA-22860: object type expected
Cause: An attempt was made to create an object table using a non- object type, or to create a column that is a REF to a non-object type.
Action: Use a valid object type in the table or column definition.
ORA-22861: invalid user-defined type
Cause: An attempt was made to create a column or object table of a non- existent type.
Action: Specify a valid type in the table or column definition.
ORA-22862: specified object identifier doesn't match existing object identifier
Cause: An attempt was made to specify an object identifier for the type that does not match the existing identifier of the incomplete type of the same name.
Action: Specify the correct object identifier or leave it out of the statement.
ORA-22863: synonym for datatype string.string not allowed
Cause: A synonym specification for a datatype is not supported
Action: do not use the synonym for the datatype
ORA-22864: cannot ALTER or DROP LOB indexes
Cause: An attempt was made to ALTER or DROP a LOB index.
Action: Do not operate directly on the system-defined LOB index. Perform operations on the corresponding LOB column.
ORA-22865: more than one column specified
Cause: An attempt was made to specify multiple columns where only one is allowed.
Action: Specify a single column and retry the operation.
ORA-22866: default character set is of varying width
Cause: A character LOB was defined but the default character set is not fixed width.
Action: Ensure that the character set is of fixed width before defining character LOBs.
ORA-22868: table with LOBs contains segments in different tablespaces
Cause: An attempt was made to drop a tablespace which contains the segment(s) for the LOB columns of a table but does not contain the table segment.
Action: Find table(s) with LOB columns which have non-table segments in this tablespace. Drop these tables and reissue drop tablespace.
ORA-22869: depth of type dependency hierarchy exceeds maximum limit
Cause: The type dependency hierarchy was structured to have depth greater than 1024.
Action: Re-structure the type dependency hierarchy to a shorter depth.
ORA-22870: ALTER TYPE with REPLACE option a non-object type
Cause: attempt to perform ALTER TYPE with REPLACE option a non-object type
Action: drop the non-object type first, then re-create it as an object type
ORA-22871: ALTER TYPE with REPLACE is not allowed for pure incomplete types
Cause: An attempt to perform ALTER TYPE with REPLACE option for a pure incomplete type
Action: Completely define the original type, before using the ALTER TYPE with REPLACE option.
ORA-22872: OID INDEX clause not allowed on tables with primary key based object identifiers
Cause: An attempt to create an OID INDEX on a table with primary key based object identifiers.
Action: Remove the OID INDEX clause
ORA-22873: primary key not specified for primary key based object table
Cause: An attempt to create a primary key based object table without specifying a primary key
Action: Specify a primary key and retry the operation
ORA-22874: attribute "string" is not part of the type "string"
Cause: Attribute specified in the user_defined clause is not an attribute of the REF type
Action: Ensure that the name specified in the user_defined clause is the name of a valid attribute of the REF type
ORA-22875: cannot drop primary key of an object table whose object identifier is primary key based
Cause: An attempt to drop the primary key of an object table which has a primary key based object identifier
Action: Remove the drop primary key clause
ORA-22876: this user-defined type is not allowed or it cannot be used in this context
Cause: An attempt to create a kind of user-defined type which is not allowed, or an attempt to create table columns or use default constructor with a type on which these are not supported.
Action: Ensure that the type is permitted in this context.
ORA-22877: invalid option specified for a HASH partition or subpartition of a LOB column
Cause: One or more invalid options were encountered while parsing the physical attributes of a LOB partition or subpartition. Either the LOB partition is in a table partitioned using the HASH method, or the LOB subpartition is in a table subpartitioned using the HASH method. TABLESPACE is the only valid option for a HASH partition or subpartition.
Action: Remove the invalid option(s).
ORA-22878: duplicate LOB partition or subpartition specified
Cause: An attempt was made to specify a partition or subpartition that has already been specified for the LOB column.
Action: Remove the duplicate specification.
ORA-22879: cannot use the LOB INDEX clause for partitioned tables
Cause: An attempt was made to specify a LOB INDEX clause in a CREATE TABLE or ALTER TABLE statement for a partitioned table.
Action: Remove the LOB INDEX clause.
ORA-22880: invalid REF
Cause: An invalid REF was accessed.
Action: Modify the REF and retry the operation.
ORA-22881: dangling REF
Cause: The object corresponding to the REF that was accessed does not exist.
Action: Ensure that the REF value is pointing to an existing object.
ORA-22882: object creation failed
Cause: The object cannot be created in the database.
Action: Check to see if the object table exists and the object size is not too big. Then retry the operation.
ORA-22883: object deletion failed
Cause: The object could not be deleted from the database.
Action: Check to see if the object table exists.Then retry the operation.
ORA-22884: object modification failed
Cause: The object could not be modified in the database.
Action: Check to see if the object table exists and the object size is not too big. Then retry the operation.
ORA-22885: cannot get REF to a non-persistent object
Cause: An attempt was made to get a REF for something other than an object in an object table. REFs can only be taken for objects in object tables.
Action: Rewrite the query to obtain REF values from object tables.
ORA-22886: scoped table "string" in schema "string" is not an object table
Cause: The scoped table specified for a REF column is not an object table.
Action: Ensure that the scoped table is an object table.Then retry the operation.
ORA-22887: type of REF column is not the same as that of its scoped table
Cause: The type specified for the REF column and the type specified for the scope table are different.
Action: Ensure that the types of a REF column and its scoped table are the same.
ORA-22888: duplicate SCOPE clauses for a REF column
Cause: Multiple SCOPE clauses were specified for a single REF column.
Action: Remove the duplicate SCOPE clauses and retry the operation.
ORA-22889: REF value does not point to scoped table
Cause: An attempt was made to insert a REF value that does not point to the scoped table.
Action: Ensure that the REF values point to the scoped table.
ORA-22890: cannot specify name for REF column constraint
Cause: An attempt was made to specify a constraint name for a constraint on a REF column.
Action: Remove the constraint name and retry the operation.
ORA-22891: cannot have multiple columns in REF constraint
Cause: An attempt was made to specify multiple columns in a single REF constraint.
Action: Specify separate constraints for each column and retry the operation.
ORA-22892: scoped table "string" does not exist in schema "string"
Cause: The scoped table specified for a REF column does not exist.
Action: Ensure that the scoped table exists and retry the operation.
ORA-22893: constraint can be specified only for REF columns
Cause: The constraint specified does not apply to non-REF columns.
Action: Remove the constraint and retry the operation.
ORA-22894: cannot add constraint on existing unscoped REF columns of non-empty tables
Cause: An attempt was made to add a constraint to existing unscoped REF columns of a table which contains one or more rows.
Action: Remove the constraint specification or add the constraint after emptying the table.
ORA-22895: referenced table "string" in schema "string" is not an object table
Cause: The referenced table specified for a REF column is not an object table.
Action: Ensure that the referenced table is an object table.Then retry the operation.
ORA-22896: cannot have both scope and referential constraint on REF column "string"
Cause: REF column has both a referential and a scope constraint. A referential constraint implies a scope constraint.
Action: Remove either the referential or scope constraint and then retry the operation.
ORA-22897: no scope clause specified for user-defined REF column "string"
Cause: User-defined REF column does not have a scope constraint.
Action: Specify a scope constraint for the user-defined REF column and retry the operation.
ORA-22898: existing scope clause on "string" points to a table other than the one mentioned in the referential constraint
Cause: Table mentioned in the referential integrity constraint is different from the scope table of the REF column.
Action: Specify the scope table of the REF column in the referential integrity constraint and then retry the operation.
ORA-22899: cannot specify both scope and rowid constraint on ref column
Cause: An attempt was made to specify both a scope and a rowid constraint on a REF column.
Action: Remove either the rowid or scope constraint and then retry the operation.
ORA-22900: the SELECT list item of THE subquery is not a collection type
Cause: The THE subquery must SELECT a nested table or VARRAY item.
Action: change the subquery to SELECT a nested table or VARRAY item.
ORA-22901: cannot compare nested table or VARRAY or LOB attributes of an object type
Cause: Comparison of nested table or VARRAY or LOB attributes of an object type was attempted in the absence of a MAP or ORDER method.
Action: define a MAP or ORDER method for the object type.
ORA-22902: CURSOR expression not allowed
Cause: CURSOR on a subquery is allowed only in the top-level SELECT list of a query.
Action: none
ORA-22903: MULTISET expression not allowed
Cause: MULTISET expressions are allowed only inside a CAST to a nested table or VARRAY type.
Action: put the MULTISET(subquery) expression inside a CAST to a nested table or VARRAY type.
ORA-22904: invalid reference to a nested table column
Cause: invalid use of a nested table column
Action: remove invalid reference to the nested table column
ORA-22905: cannot access rows from a non-nested table item
Cause: attempt to access rows of an item whose type is not known at parse time or that is not of a nested table type
Action: use CAST to cast the item to a nested table type
ORA-22906: cannot perform DML on expression or on nested table view column
Cause: Attempted to perform a DML on an expression or on a nested table view column where a nested table column of a base table is expected.
Action: Only nested table column of a base table is allowed in the DML.
ORA-22907: invalid CAST to a type that is not a nested table or VARRAY
Cause: Attempted to CAST to a type that is not a nested table or VARRAY
Action: Re-specify CAST to a nested table or VARRAY type.
ORA-22908: reference to NULL table value
Cause: The evaluation of the THE subquery or nested table column resulted in a NULL value implying a NULL table instance. The THE subquery or nested table column must identify a single non-NULL table instance.
Action: Ensure that the evaluation of the THE subquery or nested table column results in a single non-null table instance. If happening in the context of an insert statement where the THE subquery is the target of an insert, then ensure that an empty nested table instance is created by updating the nested table column of the parent table's row specifying an empty nested table constructor.
ORA-22909: exceeded maximum VARRAY limit
Cause: The total number of elements used in VARRAY construction exceeds the specified VARRAY limit.
Action: Don't use the more than the specified limit of elements for VARRAY construction.
ORA-22910: cannot specify schema name for nested tables
Cause: Table name was qualified with schema name in the nested table column's (or attribute's) storage clause.
Action: Re-specify the nested table item's storage clause without the schema name qualification. By default, the storage table for the nested table item is created in the same schema as the containing table.
ORA-22911: duplicate storage specification for the nested table item
Cause: The storage clause is specified more than once for the NESTED TABLE column.
Action: Remove the duplicate storage specification.
ORA-22912: specified column or attribute is not a nested table type
Cause: The storage clause is specified for a column or attribute that is not a nested table column or attribute.
Action: Specify a valid nested table column or attribute.
ORA-22913: must specify table name for nested table column or attribute
Cause: The storage clause is not specified for a nested table column or attribute.
Action: Specify the nested table storage clause for the nested table column or attribute.
ORA-22914: DROP of nested tables not supported
Cause: Attempted to DROP a nested table.
Action: nested tables cannot be explicitly dropped. nested tables can only be dropped by dropping their containing parent table.
ORA-22915: cannot ALTER a nested table's storage table to ADD/MODIFY columns
Cause: any such change.
Action: Columns cannot be added or modified for a nested table's storage table. You must alter the parent table's nested table column to
ORA-22916: cannot do an exact FETCH on a query with Nested cursors
Cause: Exact FETCH on a query was specified which is not allowed if the query returns any cursors.
Action: Do not use an exact FETCH.
ORA-22917: use VARRAY to define the storage clause for this column or attribute
Cause: Not using VARRAY to define storage clause for VARRAY column or attribute.
Action: Specify VARRAY before the column storage clause and resubmit statement.
ORA-22918: specified column or attribute is not a VARRAY type
Cause: Attemp to define a VARRAY storage clause for a column or attribute which is not VARRAY type.
Action: Specify VARRAY storage clause for a VARRAY column or attribute.
ORA-22919: dangling REF error or lock object failed for no wait request
Cause: The error could be one of the following. The object corresponding to the REF does not exist or the object was locked by another user and the lock with nowait request failed.
Action: Ensure that the REF value is pointing to an existing object or issue a lock request without the nowait option.
ORA-22920: row containing the LOB value is not locked
Cause: The row containing the LOB value must be locked before updating the LOB value.
Action: Lock the row containing the LOB value before updating the LOB value.
ORA-22921: length of input buffer is smaller than amount requested
Cause: The buffer length is not big enough to hold the amount of data requested.
Action: Verify that the number of bytes/characters specified in the input amount parameter is not bigger than the number of bytes specified in the input buffer length parameter. Allocate more space for the input buffer if necessary.
ORA-22922: nonexistent LOB value
Cause: The LOB value associated with the input locator does not exist. The information in the locator does not refer to an existing LOB.
Action: Repopulate the locator by issuing a select statement and retry the operation.
ORA-22923: amount of data specified in streaming LOB write is 0
Cause: Trying to write LOB value via the streaming mechanism (i.e. unlimited write) but the input amount of data to stream was specified as 0. Thus, the user is trying to write 0 bytes to the LOB value.
Action: Write more than 0 bytes to the LOB value.
ORA-22924: snapshot too old
Cause: The version of the LOB value needed for the consistent read was already overwritten by another writer.
Action: Use a larger version pool.
ORA-22925: operation would exceed maximum size allowed for a LOB value
Cause: Trying to write too much data to the LOB value. LOB size is limited to 4 gigabytes.
Action: Either start writing at a smaller LOB offset or write less data to the LOB value.
ORA-22926: specified trim length is greater than current LOB value's length
Cause: The input length for which to trim the LOB value to is greater than the current length of the LOB value.
Action: May not need to trim the LOB value because it's already smaller than the trim length specified. Or, if trimming the LOB value really is required, use a smaller trim length.
ORA-22927: invalid LOB locator specified
Cause: There are several causes: (1) the LOB locator was never initialized; (2) the locator is for a BFILE and the routine expects a BLOB/CLOB/NCLOB locator; (3) the locator is for a BLOB/CLOB/NCLOB and the routine expects a BFILE locator; (4) trying to update the LOB in a trigger body -- LOBs in trigger bodies are read only.
Action: For (1), initialize the LOB locator by selecting into the locator variable or by setting the LOB locator to empty. For (2) and (3), pass the correct type of locator into the routine. For (4), remove the trigger body code that updates the LOB value.
ORA-22928: invalid privilege on directories
Cause: An attempt was made to grant or revoke an invalid privilege on a directory.
Action: Only CREATE, DELETE, READ and WRITE privileges can be granted or revoked on directories. Do not grant or revoke other privileges.
ORA-22929: invalid or missing directory name
Cause: The required directory name is invalid or missing.
Action: Specify a valid name.
ORA-22930: directory does not exist
Cause: Attempt to access a directory that does not exist.
Action: Make sure the name is correct.
ORA-22931: MOVE of nested table to a different tablespace not supported
Cause: Attempt to move a nested table to a different tablespace.
Action: Nested tables always colocate in the same tablespace as the parent. A nested table can be moved to a different tablespace only by moving its containing table to the target tablespace.
ORA-22933: cannot change object with type or table dependents
Cause: Attempt to replace, drop or rename an object with type or table dependents.
Action: Drop depending objects or use FORCE option if available.
ORA-22950: cannot ORDER objects without MAP or ORDER method
Cause: an object type must have a MAP or ORDER method defined for all comparisons other than equality and inequality comparisons.
Action: Define a MAP or ORDER method for the object type
ORA-22951: NULL returned by ORDER method
Cause: ORDER method used to compare two object values returned NULL which is not allowed.
Action: Redefine the ORDER method to not return a NULL.
ORA-22952: Nested Table equality requires a map method on the element ADT
Cause: Nested Table equality was tried where the element ADT did not have a map method defined on it.
Action: Define a map method on the element ADT..
ORA-22953: Cardinality of the input to powermultiset exceeds maximum allowed
Cause: The cardinality of the input nested table to the powermultiset should not exceed 32 elements
Action: Reduce the number of elements to the input.
ORA-22954: This multiset operation is not supported for this element type.
Cause: The multiset operation attempted was not supported for the nested table element type.
Action: Use a supported element type.
ORA-22955: The cardinality parameter is not within the allowed limits
Cause: The cardinality parameter has to be greater than 1 and less than or equal to the cardinality of the input.
Action: Give a valid cardinality value.
ORA-22956: The set contains no elements
Cause: An empty set was given as input to the powermultiset function.
Action: Give a non-empty set as input
ORA-22957: NULL is an invalid input to powermultiset and COLLECT functions
Cause: NULL was given as input to the powermultiset or COLLECT function.
Action: Give a non-null value as input
ORA-22958: This operation is not allowed in check constraints or triggers
Cause: An invalid operation is used in a check constraint or trigger
Action: Do not use the operation
ORA-22970: name does not correspond to an object view
Cause: Either the expression is not a view name or the name specified does not correspond to an object view.
Action: Replace the expression with the name of an object view.
ORA-22971: invalid datatype for PRIMARY KEY-based object identifier
Cause: When creating an object view, the datatype of an expression in the WITH OBJECT OID clause is not allowed for PRIMARY KEY-based OID.
Action: Replace the expression with one of appropriate scalar datatype.
ORA-22972: NULL value not allowed in PRIMARY KEY-based object identifier
Cause: A value constituting the PRIMARY KEY-based object identifier is NULL.
Action: Ensure the expressions in MAKE_REF system function or attributes in the WITH OBJECT OID clause of an object view do not evaluate to NULL.
ORA-22973: size of object identifier exceeds maximum size allowed
Cause: Size of the PRIMARY KEY-based object identifier of an object view exceeds the maximum size of 4000 bytes.
Action: Specify fewer or smaller PRIMARY KEY attributes in the WITH object OID clause when creating the object view.
ORA-22974: missing WITH OBJECT OID clause
Cause: WITH OBJECT OID clause is not specified when creating an object view.
Action: Specify the WITH OBJECT OID clause.
ORA-22975: cannot create a PRIMARY KEY-based REF to this object view
Cause: The object view specified in the MAKE_REF function does not have a PRIMARY KEY-based object identifier. A PRIMARY KEY-based REF cannot be created for such a view.
Action: Specify an object view that has a PRIMARY KEY-based object identifier in the MAKE_REF function.
ORA-22976: incorrect number of arguments to MAKE_REF
Cause: Number of arguments for MAKE_REF is different from the number of PRIMARY KEY attributes of the object view.
Action: Specify all the necessary arguments for MAKE_REF.
ORA-22977: missing or invalid attribute
Cause: Either the attribute name is missing in the WITH OBJECT OID clause or it is invalid.
Action: Specify a valid attribute of the object type of the object view.
ORA-22978: only simple attribute name is allowed in the WITH OBJECT OID clause
Cause: Attempted to specify a Nested attribute in the WITH OBJECT OID clause.
Action: Specify a top-level attribute of the object type of the object view.
ORA-22979: cannot INSERT object view REF or user-defined REF
Cause: Attempt to insert an object view REF or user-defined REF in a REF column created to store system generated REF values"
Action: Make sure the REF to be inserted is not from an object view or from a user-defined REF column
ORA-22980: must specify a set of attributes for the WITH OBJECT OID clause
Cause: The WITH OBJECT OID DEFAULT clause was used, but the underlying view or table does not have a OID.
Action: Specify attributes for the WITH OBJECT OID clause to create a primary key based object identifier for the object view.
ORA-22981: must specify a table/view having system generated OID
Cause: The super-view is based on a table/view having the system generated OID and the sub-view must also be based on a similar table/view.
Action: Specify table/view having system generated OID and retry the the operation.
ORA-22982: cannot create sub-view under this view
Cause: The view derives its OID from a table/view having primary key based OID and sub-views cannot be created under such views.
Action: Specify view having system generated OID or a view created with the specification of attributes in the WITH OBJECT ID clause and retry the operation.
ORA-22983: not a user-defined REF
Cause: Attempt to use a system generated REF value where a user-defined REF value should be used.
Action: Make sure the REF value is user-defined.
ORA-22984: view query cannot contain references to a super view
Cause: The query defining the view contains references to a super-view of the view being created.
Action: Make sure that the view query does not reference a super-view.
ORA-22990: LOB locators cannot span transactions
Cause: A LOB locator selected in one transaction cannot be used in a different transaction.
Action: Re-select the LOB locator and retry the operation.
ORA-22991: insufficient space allocated for argument string
Cause: The data to be returned in the argument is greater than the amount of space allocated for the argument.
Action: Allocate more space for the argument.
ORA-22992: cannot use LOB locators selected from remote tables
Cause: A remote LOB column cannot be referenced.
Action: Remove references to LOBs in remote tables.
ORA-22993: specified input amount is greater than actual source amount
Cause: (1) For LOB write, the amount of data received is different from the amount that was indicated would be sent. (2) For LOB copy and loadfromfile, the end of the source LOB/FILE value was reached before the specified input amount was copied/loaded.
Action: (1) will happen when using OCI's piecewise mechanism with polling or with a callback function. Modify the code either to send the amount specified or to pass 0 as the input amount so that any amount of data can be sent. (2) will happen if the specified input amount is too large for the source LOB/FILE given the starting source offset. Either decrease the starting source offset, or decrease the amount to copy/load.
ORA-22994: source offset is beyond the end of the source LOB
Cause: The source offset for a LOB COPY or LOB LOADFROMFILE is beyond the end of the source LOB.
Action: Check the length of the LOB and then adjust the source offset.
ORA-22995: TABLESPACE DEFAULT option is invalid in this context
Cause: TABLESPACE DEFAULT option can be specified for LOB columns only in the following contexts:

- at the table level for a partitioned table

- at the partition level for a composite partition. An attempt was made to use the TABLESPACE DEFAULT option in a different context.

Action: Remove the TABLESPACE DEFAULT option.
ORA-22996: NEXT extent size is smaller than LOB chunksize
Cause: An attempt was made to create or alter a LOB segment so that its NEXT extent size was less than the LOB chunksize
Action: Specify a NEXT extent size that is greater than or equal to the LOB chunksize
ORA-22997: VARRAY | OPAQUE stored as LOB is not specified at the table level
Cause: An attempt was made to specify a VARRAY|OPAQUE column to be stored as LOB at the partition/subpartition/template level. However the VARRAY|OPAQUE column was not specified to be stored as LOB at the table level when the table was created.
Action: Specify the VARRAY | OPAQUE column to be stored as LOB at the table level when the table is created. Alternatively, do not specify the VARRAY | OPAQUE column to be stored as LOB at the partition/subpartition/template level if it is not specified at the table level when the table is created.
ORA-22998: CLOB or NCLOB in multibyte character set not supported
Cause: A CLOB or NCLOB in a fixed-width or varying-width multibyte character set was passed to a SQL character function which does not support multibyte LOB data.
Action: Use DBMS_LOB functions such as DBMS_LOB.INSTR() and DBMS_LOB.SUBSTR()
ORA-22999: CLOB or NCLOB data may have been corrupted
Cause: CLOB or NCLOB contains invalid character data. One possible cause is that the wrong csid was specified for the external file when calling DBMS_LOB.LOADCLOBFROMFILE or DBMS_XSLPROCESSOR.READ2CLOB to load CLOB or NCLOB data from external files.
Action: Reload the CLOB/NCLOB data with the correct csid specified for the external file.
ORA-23290: This operation may not be combined with any other operation
Cause: ALTER TABLE RENAME COLUMN/CONSTRAINT operation was given in conjunction with another ALTER TBALE Operation. This is not allowed.
Action: Ensure that RENAME COLUMN/CONSTRAINT is the only operation specified in the ALTER TABLE.
ORA-23291: Only base table columns may be renamed
Cause: Tried to rename a column of a non-base table, like object table/ nested table/ materialized view table.
Action: None. This is not allowed.
ORA-23292: The constraint does not exist
Cause: The given constraint name does not exist.
Action: Give an existing constraint's name.
ORA-23293: Cannot rename a column which is part of a join index
Cause: The column participates in a join index.
Action: If you need to rename the column, you need to drop the join index.
ORA-23300: %s
Cause: The stored procedure 'raise_system_error' was called which causes this error to be generated.
Action: Correct the problem as described in the error message or contact the application administrator or DBA for more information.
ORA-23301: mixed use of deferred rpc destination modes
Cause: Replication catalog determined deferred RPC destinations were mixed with destination determined by other mechanisms in the same transaction.
Action: Do not mix destination types in the same transaction.
ORA-23302: application raised communication failure during deferred RPC
Cause: An application declared a communication failure during a defered RPC.
Action: Retry the application when communication is restored.
ORA-23303: application raised generic exception during deferred RPC
Cause: An application declared a generic failure during a defered RPC.
Action: Determined by the application
ORA-23304: malformed deferred rpc at arg string of string in call string, in tid string
Cause: A deferred RPC call was issued without the correct number of arguments as determined by the count parameter to dbms_defer.call
Action: Be sure the number of actuals matches the count.
ORA-23305: internal deferred RPC error: string
Cause: An internal error occurred in deferred rpc.
Action: Report the error and other information to support.
ORA-23306: schema string does not exist
Cause: The schema name was null or misspelled, or the schema does not exist locally.
Action: Specify the schema correctly, or create it with CREATE USER.
ORA-23307: replicated schema string already exists
Cause: The given database already replicates the given schema.
Action: Choose a different schema or a different database.
ORA-23308: object string.string does not exist or is invalid
Cause: The given name was null or misspelled, the given type was wrong, the object does not exist as a valid database object, or the object does not exist as a replicated object with the appropriate status.
Action: Ensure the object is valid in the database, is visible to the user, and, if appropriate, is a valid object in all_repobject.
ORA-23309: object string.string of type string exists
Cause: An object in the same namespace exists, perhaps with a different type or shape, or the same object has already been registered as an repobject in another object group.
Action: Remove the offending object with the SQL DROP command, unregister the offending object with dbms_repcat.drop_master_repobject(), or reinvoke the request using TRUE for a boolean parameter such as retry or use_existing_object.
ORA-23310: object group "string"."string" is not quiesced
Cause: The requested operation requires the object group to be suspended.
Action: Invoke suspend_master_activity at the repgroup's masterdef, wait until the status has changed to quiesced, and then retry the original request.
ORA-23312: not the masterdef according to string
Cause: The group name is null, the group name is misspelled, the invocation or given database is not the masterdef, or one of the masters does not believe the invocation database is the masterdef.
Action: If the given group name and masterdef were both correct, connect to the masterdef and retry the request, or relocate the masterdef at the (errant) databases using relocate_masterdef.
ORA-23313: object group "string"."string" is not mastered at string
Cause: The group name is null, the group name is misspelled, the invocation database is not a master, or the invocation database does not believe the given database is a master.
Action: If the given group name was correct, connect to a current master and retry the request, make the invocation database a master with add_master_database, or use switch_mview_master if the invocation database is a materialized view site.
ORA-23314: database is not a materialized view site for "string"."string"
Cause: The invocation database is not a materialized view database for the given object group.
Action: Connect to the desired materialized view database and retry the request, or make the invocation database a materialized view site with create_mview_repschema or create_mview_repgroup.
ORA-23315: repcatlog version or request string is not supported by version string
Cause: Either incompatible repcat versions are used, or a repcatlog record has been corrupted.
Action: Convert the master to a compatible version of repcat or retry the request.
ORA-23316: the masterdef is string
Cause: The requested operation is not permitted on a masterdef site.
Action: Relocate the masterdef to another master and retry the operation.
ORA-23317: a communication failure has occurred
Cause: The remote database is inaccessible.
Action: Ensure the remote database is running, the communications network is functioning, and the appropriate database links are present.
ORA-23318: a ddl failure has occurred
Cause: User-supplied or system-generated ddl did not execute successfully.
Action: Examine ddl, database state, repcatlog, and all_errors to determine why the failure occurred.
ORA-23319: parameter value string is not appropriate
Cause: The given value of a parameter is either null, misspelled, or not supported.
Action: Refer to the documentation and use parameter values that are appropriate for the given situation.
ORA-23320: the request failed because of values string and string
Cause: A missing ddl record for a repcatlog record, or inconsistency in repcat views.
Action: Retry the request, or make the views consistent.
ORA-23321: Pipename may not be null
Cause: You called dbms_pipe with a null pipe name.
Action: Find out the name of the pipe and call function with non-null pipename.
ORA-23322: Privilege error accessing pipe
Cause: You either tried to create a pipe that already existed and belonged to someone else, or remove a pipe that you were not authorized to use, or put a message into a pipe that you were not authorized for, or get a message from a pipe that you were not authorized for.
Action: You may have to use a different pipename.
ORA-23323: parameter length exceeds deferred RPC limits
Cause: A deferred rpc parameter was longer than the deferred rpc limits of 4000 bytes for char/varchar2 parameters and 2000 bytes for raw parameters.
Action: Use smaller parameters.
ORA-23324: error string, while creating deferror entry at "string" with error string
Cause: The given error was encountered while attempting to create a deferor entry for the give error code and the give database.
Action: Correct the cause of the given error.
ORA-23325: parameter type is not string
Cause: A conflict resolution priority function was given a type different than the type assigned to the priority group; or the priority group has no type assigned or a function; or dbms_defer_sys_query was called to retrieve a deferred rpc parameter from the deferred rpc queue, but the type of the parameter does not match the return type of the function.
Action: Use the function corresponding to the parameter type.
ORA-23326: object group "string"."string" is quiesced
Cause: Either suspend_master_activity has been called before the object group has resumed normal operation or a (deferred) rpc operation was attempted while the object group was quiesced.
Action: If suspend_master_activity has been called and a resume_master_activity request is pending, wait until it completes, and then reinvoke suspend_master_activity. Otherwise, resume database activity with the resume_master_activity call.
ORA-23327: imported deferred rpc data does not match string of importing db
Cause: Deferred rpc queues were imported from a database with a different global name or operating system than importing database.
Action: Deferred rpc data should only be imported into a database with the same global name and hardware and operating system.
ORA-23328: mview base table "string"."string" differs from master table "string"."string"
Cause: When creating a materialized view through repcat, the materialized view base table name did not match a replicated table name at the master.
Action: Change the materialized view ddl to use the same base table as the replicated table name at the master.
ORA-23329: successful user-provided ddl but no materialized view "string"."string"
Cause: The DDL provided by the user to create a materialized view was executed without error, but materialized view does not exist.
Action: Manually back-out the DDL, and reregister with matching ddl and materialized view.
ORA-23330: column group string already exists
Cause: The column group was already registered in the object group.
Action: Use a column group name not yet registered in the replicated object group.
ORA-23331: column group string does not exist
Cause: The given column group is either null, misspelled or not registered.
Action: Use a registered column group.
ORA-23332: group string is in use; cannot drop
Cause: The given column group or priority group is being used to resolve conflicts.
Action: Call dbms_repcat procedures drop_update_resolution, drop_delete_resolution, drop_unique_resolution so that the column group or priority group is no longer in use before dropping.
ORA-23333: column string is already part of a column group
Cause: Attempted to add a column to a column group when the column was already a member of a column group.
Action: Drop the column from its existing column group before trying to add it to another.
ORA-23334: column string does not exist in table or column group
Cause: The given column is either null, misspelled or is not part of the given table or column group.
Action: Use a column that is a member of the table or column group.
ORA-23335: priority group string already exists
Cause: The priority group was already registered in the object group.
Action: Use a column group name not yet registered in the object group.
ORA-23336: priority group string does not exist
Cause: The priority group was already registered in the object group.
Action: Use a priority group name not yet registered in the object group.
ORA-23337: priority or value not in priority group string
Cause: The specified value or priority has not been registered as part of the priority group.
Action: Either specify a different value or priority that is already part of the priority group, or add the value to the priority group.
ORA-23338: priority or value already in priority group string
Cause: The specified value or priority has already been registered as part of the priority group.
Action: Either specify a different value or priority that not already part of the priority group, or drop the value to the priority group.
ORA-23339: duplicate conflict resolution information
Cause: The specified combination of column group, sequence, conflict type and/or parameter table name, parameter column name, and parameter sequence number has already been registered.
Action: Verify that additional conflict resolution information needs to be added and provide a new sequence number. If modifying existing information, the existing information must be dropped first.
ORA-23340: incorrect resolution method string
Cause: User function is specified when conflict resolution method was not "USER FUNCTION" or specified resolution method is not one of the predefined methods.
Action: If user function is specified when conflict resolution method was not "USER FUNCTION", either reregister function with method as "USER FUNCTION" or specify a NULL user function. Otherwise Specify one of the documented supported conflict resolution methods.
ORA-23341: user function required
Cause: A NULL user function was specified for the "USER FUNCTION" method.
Action: Provide user function name (e.g., "schema"."package"."function") that conforms to the documented user function specifications or specify one of the documented supported conflict resolution methods.
ORA-23342: invalid parameter column string
Cause: The parameter column name is null or misspelled, the invocation database is not a master, or is of the wrong type for the specified conflict resolution method.
Action: Specify a parameter column from the specified column group that has a correct type for the conflict resolution method.
ORA-23343: no match for specified conflict resolution information
Cause: The specified combination of column group, sequence, conflict type has not been registered (e.g., for adding a comment).
Action: Specify a combination of column group, sequence, conflict type has been registered.
ORA-23344: constraint (string.string) does not exist
Cause: A null, misspelled or nonexistent constraint was specified when registering a uniqueness conflict.
Action: Register a named constraint for the specified table.
ORA-23345: table "string"."string" not registered to collect statistics
Cause: A procedure that deals with conflict resolution statistics-gathering was called for a table that was not registered to collect statistics.
Action: Call dbms_repcat.register_statistics to register the table.
ORA-23346: primary key or object ID is undefined for table or materialized view string
Cause: Trying to generate replication support for a table or materialized view without a primary key (as defined by a constraint or dbms_repcat.set_columns) or an object ID.
Action: For a table, add a primary key constraint or define a primary key using dbms_repcat.set_columns or use object tables. For a ROWID materialized view, set min_communication to false or use primary key or object ID materialized views.
ORA-23347: datatype string for column string table string not supported
Cause: The table has a column whose datatype is not supported by repcat.
Action: Remove the column from the table, or alter the column to have one of the supported datatypes.
ORA-23348: cannot replicate procedure string; only IN parameters supported
Cause: Trying to generate replication support for a package that has a procedure with OUT or IN OUT parameters.
Action: Remove the procedure from the package, or remove the OUT or IN OUT parameters from the procedure.
ORA-23349: cannot generate replication support for functions
Cause: Trying to generate replication support for a package that has a public function, or for a stand-alone function.
Action: Remove the public function from the package, or alter the function to be a procedure.
ORA-23350: maximum number of recursive calls exceeded
Cause: This usually occurs when trying to resolve conflicts in a table while concurrent updates to the same row create more conflicts.
Action: Re-execute the deferred transaction from DefError using dbms_defer_sys.execute_error
ORA-23351: parameter datatype string for procedure string not supported
Cause: The procedure has a parameter whose datatype is not supported by repcat.
Action: Remove the parameter from the procedure, or alter the parameter to have one of the supported datatypes.
ORA-23352: duplicate destination for deferred transaction
Cause: A duplicate destination was specified for a deferred transaction either in a dbms_defer.call call or an earlier dbms_defer.transaction call or a dbms_defer_sys.add_default_dest call.
Action: Remove the duplicate entry
ORA-23353: deferred RPC queue has entries for object group "string"."string"
Cause: The requested action cannot be performed until the queue is empty for the given object group
Action: Use dbms_defer_sys.execute or dbms_defer_sys.delete_tran to empty the queue.
ORA-23354: deferred RPC execution disabled for "string" with "string"
Cause: Deferred RPC can not be executed at the destination with the specified catchup value because their propogation has been disabled.
Action: Enable deferred RPC execution with the dbms_defer_sys.set_disabled call.
ORA-23355: object string.string does not exist or is invalid at master site
Cause: The given name was null or misspelled, the given type was wrong, the object does not exist as a valid database object at the master site, or the object does not exist as a replicated object with the appropriate status.
Action: Ensure the object is valid in the master database, and is visible to the user, and, if appropriate, is a valid object in all_repobject.
ORA-23356: masterdef recognizes a master which does not recognize the masterdef
Cause: Possibly drop_master_repgroup was run at a master site but remove_master_databases was not run at master definition site for that master.
Action: Run remove_master_databases from master definition site to remove the appropriate master (see associated error messages).
ORA-23357: the propagator does not exist
Cause: The propagator does not exist.
Action: Register a new propagator.
ORA-23358: invalid remote user
Cause: The local user does not match the remote user connected via a database link.
Action: Drop and recreate the identified database link with the connect-to user identical to the owner of the database link.
ORA-23359: error on creating a ddl record for a repcatlog record
Cause: The userid in the repcatlog record does not match the userid of the connected user.
Action: Retry the operation with a different user.
ORA-23360: only one materialized view for master table "string" can be created
Cause: Trying to create more than one materialized view on a given master table in the same rep group.
Action: Create these other materialized views in a different rep group at another site.
ORA-23361: materialized view "string" does not exist at master site
Cause: The materialized view does not exist at the master site for offline instantiation of the materialized view.
Action: The correct procedure is to create the materialized view in a different schema at the master site, and then follow the instructions for offline instantiation of materialized views.
ORA-23362: invalid user
Cause: The given user does not exist.
Action: none
ORA-23363: mismatch of mview base table "string" at master and mview site
Cause: The name of the base table of the materialized view at the master site is different from the base table at the materialized view site. This error may arise during offline instantiation of materialized views.
Action: Retry offline instantiation with a materialized view name less than 24 bytes
ORA-23364: Feature not enabled: Advanced replication
Cause: The Advanced Replication feature is not enabled at this site. Updatable materialized views, deferred RPCs, and other replication features are, therefore, unavailable.
Action: Do not attempt to use this feature. Contact an Oracle Customer Support representative if the Advanced Replication feature has been purchased but not enabled.
ORA-23365: site string does not exist
Cause: site specified in argument "reference_site" or argument "comparison_site" in call to "differences()" routine or "rectify()" routine does not name an existing site.
Action: Make sure that database sites specified really do exist, and re-run the routine.
ORA-23366: integer value string is less than 1
Cause: Value of argument "max_missing" to routine "differences()" cannot be less than 1. Value of argument "commit_rows" to routines "differences()" and "rectify()" cannot be less than 1.
Action: Choose an integer value for those arguments to be 1 or greater.
ORA-23367: table string is missing the primary key
Cause: Table specified in argument "oname1" or "oname2" in call to "differences()" routine does not contain either a primary key or a virtual primary key (defined through dbms_repcat package under symmetric replication).
Action: Make sure the tables specified have a primary key defined.
ORA-23368: name string cannot be null or the empty string
Cause: Argument "sname1," "sname2," "oname1," "oname2," "missing_rows_sname," "missing_rows_oname1," "missing_rows_oname2" to "differences()" or "rectify()" cannot be NULL or '' (empty string).
Action: Change argument to non-null or non-empty string.
ORA-23369: value of "string" argument cannot be null
Cause: Argument "max_missing" to "differences()" routine cannot be NULL.
Action: Legal values for "max_missing" are integers 1 or greater.
ORA-23370: table string and table string are not shape equivalent (string)
Cause: The tables specified are not shape equivalent, which means intuitively that the number of columns, the names, their datatypes and lengths are not the same. Specifically, problem is in the parentheses and is one of the following: the number of columns are not equal, datatypes of columns with same name in different tables are different, lengths of varchar2 and char columns are not equal, precision and scale of number datatypes are not equal.
Action: Make sure the two tables being compared have the same number of columns, same column names, and same datatypes.
ORA-23371: column string unknown in table string
Cause: Some column in "array_columns" argument (or "column_list" argument) to "differences()" routine does not correspond to a column in the specified table.
Action: Make sure that all the columns in either "array_columns" or "column_list" are present in the specified table.
ORA-23372: type string in table string is unsupported
Cause: Certain types in the table comparison utility are not supported.
Action: Make sure that the types of columns in the tables to be compared are the ones supported by symmetric replication.
ORA-23373: object group "string"."string" does not exist
Cause: The group name was null or misspelled, or the group does not exist locally.
Action: Specify the group correctly, or create it with dbms_repcat.create_master_repgroup().
ORA-23374: object group "string"."string" already exists
Cause: The given database already replicates the given object group. A materialized view repgroup cannot be created at a given site where a master repgroup with the same name already exists.
Action: Choose a different group or a different database.
ORA-23375: feature is incompatible with database version at string
Cause: A feature not compatible with the specified database was used
Action: Set or raise the value of the "compatible" INIT.ORA parameter to match the necessary compatibility level.
ORA-23376: node string is not compatible with replication version "string"
Cause: A feature not compatible with the remote database was used
Action: Upgrade the remote database and retry the operation
ORA-23377: bad name string for missing_rows_oname1 argument
Cause: An attempt was made to use the name of the reference site table as the name of the missing_rows_oname1 argument.
Action: Provide a separately created table with a different name for missing_rows_oname1 argument. The separately created table will contain the differences between the tables being compared.
ORA-23378: connection qualifier "string" is not valid for object group "string"."string"
Cause: The connection qualifier used in the database link for the specified object group does not match the qualifier specified for the group in create_master_repgroup.
Action: Use or create a database link which contains the correct connection qualifier.
ORA-23379: connection qualifier "string" is too long
Cause: The maximum length of a database link, including the connection qualifier, is 128 bytes.
Action: Use a shorter connection qualifier, or shorten the name of the database link
ORA-23380: propagation mode "string" is not valid
Cause: The specified propagation may be misspelled, or is not supported. For materialized view sites, all materialized view object groups at the same materialized view site with the same master object group must all have the same propagation method.
Action: Refer to the manual on replicated data for valid propagation modes. For materialized view sites, also ensure that the propagation modes of all materialized view object groups with the same master object group are the same.
ORA-23381: generated object for base object string.string@string does not exist
Cause: The system generated object(s) for the specified base object do not exist at the specified site. The current operation requires the base object to have generated replication support.
Action: Ensure that the generated replication object(s) for the base object exist and are valid at the specified site. If the generated object(s) do not exist, then the procedure dbms_repcat.generate_replication_support() needs to be called from the master definition site for the base object. missing_rows_oname1 argument. The separately created table will contain the differences between the tables being compared.
ORA-23382: materialized view repgroup "string"."string" is not registered at site string
Cause: The materialized view repgroup is not currently registered at the master and so cannot be unregistered.
Action: None
ORA-23383: registration for materialized view repgroup "string"."string" failed at site string
Cause: Insertion into local repschema table failed.
Action: None
ORA-23384: replication parallel push string argument out of range
Cause: Specified numeric argument to dbms_defer_sys.push is invalid.
Action: Fix the argument value and try again.
ORA-23385: replication parallel push string argument not valid
Cause: Specified string argument to dbms_defer_sys.push is invalid.
Action: Fix the argument value and try again.
ORA-23386: replication parallel push cannot create slave processes
Cause: An error was occurred while creating slave processes for parallel push.
Action: none
ORA-23387: replication parallel push dequeue error
Cause: An attempt to dequeue a deferred transaction failed while trying to assign a new queue batch number.
Action: none
ORA-23388: replication parallel push watermark error
Cause: An error occurred during parallel push while trying to update the high-water-mark information in system.def$_destination.
Action: none
ORA-23389: obsolete procedure; drop objects and recreate using new master
Cause: dbms_repcat.switch_mview_master is no longer supported.
Action: Drop the objects in the object group and recreate them using the new master.
ORA-23392: could not find materialized view to be associated with "string"."string"
Cause: Could not find materialized view associated with a trigger or index that is being pulled from the master site.
Action: Ensure that materialized view, master, and master index or trigger is registered as replicated objects.
ORA-23393: the user is already the propagator
Cause: The given user is already the current propagator.
Action: none
ORA-23394: duplicate propagator
Cause: More than one valid propagator exist.
Action: Unregister any duplicate propagator.
ORA-23395: object "string"."string" of type "string" does not exist or is invalid
Cause: The given name was null or misspelled, the given type was wrong, the object does not exist as a valid database object, or the object does not exist as a replicated object with the appropriate status.
Action: Ensure the object is valid in the database, is visible to the user, and, if appropriate, is a valid object in all_repobject.
ORA-23396: database link "string" does not exist or has not been scheduled
Cause: the database link does not exist in the schema of the replication propagator or has not been scheduled.
Action: Ensure that the database link exists in the database, is accessible and is scheduled for execution.
ORA-23397: global name "string" does not match database link name "string"
Cause: the database link name at the local node does not match the global name of the database that the link accesses.
Action: Ensure that global names is set to true and the link name matches the global name.
ORA-23398: user name "string" at database link "string" does not match local user name "string"
Cause: the user name of the replication administration user at the local node and the user name at the node corresponding to the database link are not the same. Symmetric replication expects the two users to be the same.
Action: Ensure that the user ID of the replication administration user at the local node and the user ID at the node corresponding to the database link are the same.
ORA-23399: generation of replication support for "string"."string" is not complete
Cause: Replication support for the specified object has not been generated or the generation process is not yet complete.
Action: Ensure that replication support has been generated for the object. Use DBMS_REPCAT.GENERATE_REPLICATION_SUPPORT() to generate replication support for the object.
ORA-23400: invalid materialized view name "string"
Cause: A null, misspelled, or badly formed materialized view name was given to dbms_mview.refresh.
Action: Provide a valid materialized view name to dbms_mview.refresh.
ORA-23401: materialized view "string"."string" does not exist
Cause: A materialized view name was given to dbms_mview.refresh that is not in sys.snap$ or its associated views.
Action: Provide a materialized view name that is in sys.snap$, all_mviews or user_mviews.
ORA-23402: refresh was aborted because of conflicts caused by deferred txns
Cause: There are outstanding conflicts logged in the DefError table at the materialized view's master.
Action: Resolve the conflicts in the master DefError table and refresh again after the table is empty. Alternatively, refresh with refresh_after_errors set to TRUE, which will proceed with the refresh even if there are conflicts in the master's DefError table. Proceeding despite conflicts can result with an updatable materialized view's changes appearing to be temporarily lost (until a refresh succeeds after the conflicts are resolved).
ORA-23403: refresh group "string"."string" already exists
Cause: Making a new refresh group when there is already a group of the same name in sys.rgroup$.
Action: Choose a diifferent refresh group name.
ORA-23404: refresh group "string"."string" does not exist
Cause: A refresh group name was given that is not in sys.rgroup$.
Action: Provide a refresh group name that is in sys.rgroup$ or dbs_rgroup.
ORA-23405: refresh group number string does not exist
Cause: A refresh group number was given that is not in sys.rgroup$.
Action: Provide a refresh group number that is in sys.rgroup$ or dbs_rgroup.
ORA-23406: insufficient privileges on user "string"
Cause: The caller is not the owner of the materialized view and does not have ALTER ANY MATERIALIZED VIEW privileges.
Action: Perform the operation as the owner of the materialized view or as a user with ALTER ANY MATERIALIZED VIEW privileges.
ORA-23407: object name string must be shaped like "schema"."object" or "object"
Cause: The object name (e.g., the rollback segment, the materialized view name, the refresh group) was incorrectly specified.
Action: Retry the operation with the object name properly specified (like "schema"."object" or "object")
ORA-23408: this replication operation is not supported in a mixed configuration
Cause: operation is not supported if the object group is replicated at a pre-V8 node.
Action: Ensure that all nodes of the replicated object group are V8.
ORA-23409: could not find an unused refresh group number
Cause: 1000 consecutive refresh group numbers, as defined by the rgroupseq number, were already used by rows in sys.rgroup$.
Action: Alter the sequence number to be within a legal unused range and destroy unneeded refresh groups.
ORA-23410: materialized view "string"."string" is already in a refresh group
Cause: A materialized view of the same name is already in a refresh group.
Action: Subtract the materialized view from the current refresh group and add it to its new refresh group, or combine the two refresh groups into a single refresh group.
ORA-23411: materialized view "string"."string" is not in refresh group "string"."string"
Cause: The specified materialized view is not in the specified refresh group.
Action: Try again with the proper materialized view and refresh group names.
ORA-23412: master table's primary key columns have changed
Cause: The master table's primary key constraint was modified after the primary key materialized view was created.
Action: Drop and recreate the primary key materialized view
ORA-23413: table "string"."string" does not have a materialized view log
Cause: The fast refresh can not be performed because the master table does not contain a materialized view log.
Action: Use the CREATE MATERIALIZED VIEW LOG command to create a materialized view log on the master table.
ORA-23414: materialized view log for "string"."string" does not record rowid values
Cause: A rowid materialized view is being fast refreshed, but the materialized view log does not record rowid information.
Action: Use the CREATE MATERIALIZED VIEW LOG...ADD ROWID command to begin recording rowid information in the materialized view log.
ORA-23415: materialized view log for "string"."string" does not record the primary key
Cause: A primary key materialized view is being fast refreshed, but the materialized view log does not record primary key information.
Action: Use the CREATE MATERIALIZED VIEW LOG...ADD PRIMARY KEY command to begin recording primary key information in the materialized view log.
ORA-23416: table "string"."string" does not contain a primary key constraint
Cause: The master table does not constaint a primary key constraint or the primary key constraint has been disabled.
Action: Create a primary key constraint on the master table or enable the existing constraint.
ORA-23417: unknown materialized view type: string
Cause: A fast refresh is being performed on a materialized view of an unknown or unsupported type.
Action: Check all_mviews and ensure that the materialized view being refreshed a valid materialized view.
ORA-23418: cannot unregister the propagator who is currently in use
Cause: The propagator is currently used in propagating replication RPCs.
Action: Try again later when there is no transaction active in propagating replication RPCs.
ORA-23419: regenerate replication support before resuming master activity
Cause: There are tables in the object group that require regeneration of replication support.
Action: Check the generation_status column in the all_repobjects view. Regenerate replication support for any table in the object group with a 'NEEDSGEN' status. Resume master activity.
ORA-23420: interval must evaluate to a time in the future
Cause: The parameter "interval" evaluates to a time earlier than SYSDATE.
Action: Choose an expression that evaluates to a time later than SYSDATE.
ORA-23421: job number string is not a job in the job queue
Cause: There is no job visible to the caller with the given job number.
Action: Choose the number of a job visible to the caller.
ORA-23422: Oracle Server could not generate an unused job number
Cause: Oracle Server could not generate a job number that was not used to identify another job.
Action: Retry the operation.
ORA-23423: job number string is not positive
Cause: The given job number is less than 1.
Action: Choose a positive integer.
ORA-23424: materialized view "string"."string" at string not registered
Cause: The specified materialized view has not be successfully registered at this site.
Action: Register the materialized view manually at either the master site or the materialized view site.
ORA-23425: invalid materialized view identifier string
Cause: The argument provided to dbms_mview.purge_mview_from_log is an invalid materialized view identifer or it does not identify an Oracle 8 fast refreshable materialized view or the materialized view has been already purged.
Action: If the materialized view is an Oracle 8 fast refreshable materialized view then provide purge_mview_from_log with its valid materialized view identifier.
ORA-23426: deferred RPC queue has entries for string
Cause: The requested action cannot be performed until the queue is empty for the given site/dblink
Action: Use dbms_defer_sys.push, dbms_defer_sys.purge_queue or dbms_defer_sys.delete_tran to empty the queue.
ORA-23427: deferred purge queue argument string out of range
Cause: Specified numeric argument to dbms_defer_sys.purge_queue is invalid.
Action: Fix the argument value and try again.
ORA-23428: job associated instance number string is not valid
Cause: A job is associated with an instance that is not running.
Action: Choose a running instance for job affinity, or set force parameter to TRUE.
ORA-23430: argument "string" cannot be NULL or empty string
Cause: The caller has provided an argument whose value cannot be NULL or the empty string.
Action: Check that the varchar2 value provided is not NULL or the empty string, and retry the call.
ORA-23431: wrong state: string
Cause: The routine was executed against a replicated object group that was in the wrong state.
Action: Make sure that the replicated object group is in the state given in the error message.
ORA-23432: master site string already exists
Cause: An attempt was made to instantiate a replicated object group at a master site that was already a part of the object group.
Action: If you were trying to add this site, do nothing because it already exists; otherwise, pick the name of another site, and re-run the routine.
ORA-23433: executing against wrong master site string
Cause: An attempt was made to execute the routine at a site that is different from the site specified in the argument of the routine.
Action: Provide an argument to the routine that correctly indicates the site against which the routine should be executing.
ORA-23434: master site string not known for object group
Cause: The site name given as an argument to a routine was not already known to the replicated object group.
Action: Execute the dbms_offline_og.begin_instantiation() routine to add a new site to the replicated object group.
ORA-23435: cannot create an updatable ROWID materialized view with LOB columns
Cause: The propagation of LOB data from materialized view sites to the master site requires a primary key on the replicated table. Thus updatable ROWID materialized views that contain LOB columns are not supported.
Action: Create a primary key materialized view instead of a ROWID materialized view. If the materialized view already exists, it can be converted to a primary key materialized view using the ALTER MATERIALIZED VIEW DDL command.
ORA-23436: missing template authorization for user
Cause: The specified template authorization does not exist.
Action: Check the values for user name and refresh template name to ensure a valid row exists in the DBA_REPCAT_USER_AUTHORIZATIONS view.
ORA-23437: template authorization already exists for user
Cause: The specified user already has been authorized to use the specified refresh group template.
Action: Check the values for user name and refresh template name or query the DBA_REPCAT_USER_AUTHORIZATIONS view to ensure that the correct values were passed as parameters.
ORA-23438: missing refresh group template
Cause: The specified refresh group template does not exist.
Action: Verify that the refresh group template does not exist by querying the DBA_REPCAT_REFRESH_TEMPLATES view.
ORA-23439: refresh group template already exists
Cause: The specified refresh group template already exists.
Action: Verify that the refresh group template exists by querying the DBA_REPCAT_REFRESH_TEMPLATES view.
ORA-23440: incorrect public template value
Cause: The public template parameter is not 'Y', 'N' or NULL.
Action: Correct the value of the public template parameter. It must be 'Y','N' or NULL.
ORA-23441: object does not exist for refresh group template
Cause: The specified object does not exist in the refresh group template.
Action: Correct the object name and object type parameters. Check the DBA_REPCAT_TEMPLATE_OBJECTS view to verify the correct name and type of the object.
ORA-23442: object already exists for the refresh group template
Cause: The specified object already exists in the refresh group template.
Action: Change the object name and object type parameters. Query the DBA_REPCAT_REMPLATE_OBJECTS view to verify the correct name and type of the object.
ORA-23443: missing template parameter
Cause: The specified template parameter does not exist.
Action: Correct the template parameter value and execute the procedure again. Use the DBA_REPCAT_TEMPLATE_PARMS view to verify the name of the refresh group template and parameter name.
ORA-23444: duplicate template parameter
Cause: The template parameter already exists for the specified refresh group template.
Action: Correct the template parameter value and execute the procedure again. Use the DBA_REPCAT_TEMPLATE_PARMS view to verify the name of the refresh group template and parameter name.
ORA-23445: missing template site
Cause: The template site specified by the site name, user name and refresh group template name does not exist.
Action: Correct the invalid parameter and execute the procedure again. Use the DBA_REPCAT_TEMPLATE_SITES view to query the existing template sites.
ORA-23446: duplicate template site
Cause: The template site specified by the site name, user name and refresh group template name already exists.
Action: Correct the invalid parameter and execute the procedure again. Use the DBA_REPCAT_TEMPLATE_SITES view to query the existing template sites.
ORA-23447: missing user parameter value
Cause: The user parameter value specified by the user name, parameter name and refresh group template name does not exist.
Action: Correct the invalid parameter and execute the procedure again. Use the DBA_REPCAT_USER_PARMS view to query the existing user parameters.
ORA-23448: duplicate user parameter value
Cause: The user parameter value specified by the user name, parameter name and refresh group template name already exists.
Action: Correct the invalid parameter and execute the procedure again. Use the DBA_REPCAT_USER_PARMS view to query the existing user parameters.
ORA-23449: missing user name
Cause: The user specified by the user name parameter does not exist in the database.
Action: Correct an invalid user name or create the user in the master database. Use the DBA_USERS view to select the valid database users.
ORA-23450: flavor already contains object "string"."string"
Cause: The flavor already contains the specified object.
Action: Check that the specified object is correct. To add all columns of a table object, delete the object from the flavor and then add it again.
ORA-23451: flavor string already defined for object group "string"."string"
Cause: The given object group already contains a (possibly unpublished) definition of the specified flavor.
Action: Check the spelling of the flavor name. Check for an unpublished flavor of the desired name.
ORA-23452: flavor string of object group "string"."string" is already published
Cause: The given object group already contains a (published) definition of the specified flavor.
Action: Check the spelling of the flavor name.
ORA-23453: requested operation is not supported on top flavor
Cause: The TOP flavor has a NULL name and may not be directly defined or deleted.
Action: Supply the name of a flavor other than the TOP flavor or use dbms_repcat routines to implicitly change the TOP flavor.
ORA-23454: flavor string not defined for object group "string"."string"
Cause: The given object group does not contain a (published) definition of the specified flavor.
Action: Check the spelling of the flavor name. Ensure the flavor has been defined (and published) for the object group.
ORA-23455: flavor string contains object "string"
Cause: The given flavor contains the object to be dropped.
Action: Purge the flavor or choose another object to drop.
ORA-23456: flavor string does not contain "string"
Cause: The flavor does not contain the given object, column, or attribute.
Action: Either drop the flavor or choose a different object, column, or attribute.
ORA-23457: invalid flavor ID string
Cause: The given flavor ID is invalid.
Action: Make sure this flavor has been instantiated. If the flavor ID is outside the range (-2147483647, 2147483647), contact customer support.
ORA-23458: inappropriate flavor string at string
Cause: The given flavor at the given database prevents the operation from succeeding.
Action: Either change the database flavor or choose a different operation.
ORA-23459: flavor string must contain "string"
Cause: The flavor must contain the given object, column, or attribute.
Action: Either choose a different database flavor or ensure the object, column, or attribute is available.
ORA-23460: missing value for column string in resolution method "string" for "string"."string"."string"
Cause: before resolving conflicts, some values necessary resolving conflicts are not available, or after resolving conflicts, some values necessary for re-trying of the SQL are not available
Action: define appropriate flavors, provide necessary values through availability vector in USER FLAVOR FUNCTION for conflict resolution
ORA-23462: flavor string in use at site string
Cause: The given flavor cannot be deleted because it is being used at the given site.
Action: Change the flavor of the site, or unregister it if it is a materialized view site.
ORA-23463: flavor incompatible with object "string"."string"
Cause: An existing flavor includes the specified object with an incompatible type.
Action: Change the type of the object, or delete the flavor if it is not in use.
ORA-23464: flavor lacks column string of "string"."string"
Cause: The flavor includes some columns of an object group but not all the required columns.
Action: Change the flavor definition to include all required columns.
ORA-23465: flavor already includes column string of "string"."string"
Cause: The flavor includes the specified column which is being added.
Action: Check that the specified column is correct.
ORA-23466: flavor requires missing object "string"."string"
Cause: The flavor includes the specified object which does not exist
Action: Check that the specified object name is correct, and create the object if appropriate.
ORA-23467: flavor lacks object "string"."string"
Cause: The flavor does not include the specified object which is being dropped.
Action: Check that the specified object is correct.
ORA-23468: missing string string
Cause: The template is missing the object with the specified key.
Action: Add the object to the template.
ORA-23469: %s is different between templates
Cause: The values for the specified columns are different in each template for the same key values.
Action: Correct the column values to make the templates the same.
ORA-23470: invalid status
Cause: The status should be DELETED, INSTALLING or INSTALLED. Any other status is invalid.
Action: Check that the specified status value is correct.
ORA-23471: template not authorized for user
Cause: The refresh template is private and the user has not been authorized to instantiate the template.
Action: Authorize the user to use the template.
ORA-23472: materialized view "string"."string" must be atomically refreshed
Cause: Non-atomic refresh is not supported for the specified materialized view.
Action: Set the value of the ATOMIC parameter to FALSE in the refresh procedure being used or remove the specified materialized view from the set of materialized views being refreshed.
ORA-23473: replication RPC processing for "string"."string" is disabled
Cause: The processing of replication RPCs for the object group that contains this object is disabled. This includes RPCs in the error queue.
Action: Processing of replication RPCs is disabled when the object group is being offline instantiated. Wait until offline instantiation is finished.
ORA-23474: definition of "string"."string" has changed since generation of replication support
Cause: The current columns in the specified table and their column types do not match the columns and column types when replication support was last generated.
Action: Regenerate replication support for the affected table. All flavors that include the specified table should be checked for validity. Types for any UDT columns should also be checked for validity.
ORA-23475: key column string must be sent and compared
Cause: The specified column is a key column and must be sent and compared during replication propagation.
Action: Make sure every key column is sent and compared.
ORA-23476: cannot import from string to string
Cause: This object was imported from a database with a different global name than the importing database.
Action: Only import this object into a database with the same global name.
ORA-23477: unable to alter propagation mode for object group "string"."string"
Cause: The propagation method of a materialized view object group can only be altered when no other object groups with the same master object group are sharing the materialized view site.
Action: Ensure that there are no other materialized view object groups at the local site with the same master object group.
ORA-23478: object group "string" is already mastered at string
Cause: There is at least one other materialized view repgroup at the local site with the same group name but a different master site.
Action: Ensure that all materialized view repgroups at the local site with the same group name have the same master.
ORA-23480: Column string is not a top-level column of "string"."string".
Cause: The column is either not a top-level column or is not present in the table or materialized view.
Action: Ensure only valid top-level columns are used.
ORA-23482: column string of "string"."string": object types not allowed.
Cause: The column is of Object Type.
Action: Ensure that all the columns are not of Object Type.
ORA-23483: object "string"."string" not allowed in this operation.
Cause: The specified operation does not support the given object.
Action: Do not invoke the operation for this object.
ORA-23484: internal internet Application Server error: string
Cause: An internal error occurred in internet Application Server.
Action: Report the error and other information to support.
ORA-23485: Column group "string" must consist of a single numeric column only
Cause: The column group doesn't contain only one numeric column.
Action: Use a column group containing a single numeric column.
ORA-23487: object groups "string"."string" and "string"."string" do not have the same connection qualifier
Cause: The specified two object groups do not have the same connection qualifier.
Action: Do not invoke the operation on the above object groups, or ensure they have the same connection qualifier.
ORA-23488: propagation mode "string" for "string" is not allowed for this operation
Cause: This operation does not support the specified dblink in the above propagation mode.
Action: Do not invoke the operation for this dblink, or change the propagation mode for this dblink.
ORA-23489: duplicate entry "string"
Cause: The specified value is duplicated in the parameter list.
Action: Remove duplicated entries in the parameter list.
ORA-23490: extension request "string" with status "string" not allowed in this operation
Cause: The specified operation is not allowed for the extension request with the specified status.
Action: Ensure the extension request has the appropriate status before retrying this operation.
ORA-23491: no valid extension request at "string"
Cause: The specified database does not have a valid extension request.
Action: Ensure there is a valid extension request in DBA_REPEXTENSIONS view before retrying this operation.
ORA-23492: no new sites for extension request "string"
Cause: There is no new site with the specified extension request.
Action: Ensure there is at least one new site in DBA_REPSITES_NEW view for this request before retrying this operation.
ORA-23493: "string" is not a new site for extension request "string"
Cause: The specified extension request does not include the specified site as a new site.
Action: Ensure the specified site is a new site for this extension request before retrying this operation.
ORA-23494: too many rows for destination "string"
Cause: The specified destination has too many rows in system.def$_destination table.
Action: Ensure the specified destination has at most two valid rows before retrying this operation.
ORA-23495: serial propagation can not be used for "string"
Cause: The sites involved may be in the process of adding a new site without quiescing.
Action: Check the def$_destination table for this destination and try parallel propagation.
ORA-23496: can not change disabled status for "string" and "string"
Cause: The disabled status for this site is set internally for synchronization during adding a new master without quiescing.
Action: Ensure adding a new master without quiescing finished before invoking this procedure.
ORA-23497: repgroup name cannot be null
Cause: The array of Repgroup names contains a null value.
Action: Ensure that the array of Repgroup names is dense and is not null terminated.
ORA-23498: repgroups specified must have the same masters
Cause: The Repgroup names specified do not have the same masters.
Action: Ensure that the Repgroup names specified have the same masters.
ORA-23500: cannot switch master for a multi-tier materialized view repgroup "string"."string"
Cause: An attempt was made to switch master for a materialized view repgroup when its parent repgroup is also a materialized view repgroup. This is not allowed.
Action: Drop and recreate the materialized view repgroup based on a proper parent repgroup.
ORA-23501: refresh template cannot be instantiated for database with compatibilty equal to or less than 8.0
Cause: Instantiation of a refresh template is not supported for database compatibility 8.0 or less.
Action: Be sure the database compatibility is 8.1 or above.
ORA-23502: valid directory for offline instatiation is not specified
Cause: An attempt was made to offline instantiate to a directory which is not specified or null.
Action: There are two ways to specify the directory: o As a parm offline_dirpath to the API o As an init.ora parm named utl_file_dir Make sure you have specified an appropriate directory in which the offline file can be created.
ORA-23503: error occurred during IAS instantiation
Cause: An attempt was made to instantiate a IAS site. Error occurred during IAS instantiation.
Action: See other errors on the error stack to look for the source of the problem. If the error still persists, contact Oracle Support.
ORA-23504: columns added to table do not match list of columns to be added
Cause: The list of columns passed as a parameter does not match the columns to be added to the table.
Action: Correct the DDL string or list of columns and rexecute.
ORA-23505: Object "string"."string" is missing.
Cause: The specified object does not exist.
Action: Check that the specified object is correct.
ORA-23514: invalid or incorrect number of arguments
Cause: The arguments passed to the online redefinition API were invalid or missing.
Action: Call the online redefinition API with the right number of valid arguments.
ORA-23515: materialized views and/or their indices exist in the tablespace
Cause: An attempt was made to drop a tablespace which contains materialized views and/or their indices.
Action: Drop the materialized views in this tablespace. Also, find indices belonging to materialized views in this tablespace and drop then. Then try dropping the tablespace.
ORA-23531: site owner already exists in the template.
Cause: Site owner for the template already exists.
Action: Do not create multiple siteowners for this template.
ORA-23532: tables with different synchronization mechanisms are in the same group
Cause: Tables belonging to the same replication group were specified to be cached with different synchronization mechanisms.
Action: Do not specify different synchronization mechanisms while caching tables belonging to the same replication group.
ORA-23533: object "string"."string" can not be cached
Cause: An attempt was made to cache an object which is not supported.
Action: Do not cache an object which is not supported.
ORA-23534: missing column in materialized view container table "string"."string"
Cause: After import, the materialized view container table has missing columns.
Action: Check if materialized view container table was imported correctly.
ORA-23535: instantiating templates from multiple back ends is not allowed.
Cause: An attempt was made to set a new non-null back end database for an iAS site.
Action: Call dbms_ias_configure.set_back_end_db procedure with null dblink. Then, call the same procedure with the new non-null dblink.
ORA-23536: the object "string"."string" is not cached at the middle tier as expected.
Cause: The object may have been dropped or renamed at the back end after dbms_ias_inst.start_ias_inst was executed.
Action: Check the validity of the object at the back end and retry the instantiation.
ORA-23537: function or procedure string is not allowed to be invoked from this site.
Cause: This function or procedure is restricted to the backend or middle tier site
Action: Connect to the proper site before calling this function or procedure.
ORA-23538: cannot explicitly refresh a NEVER REFRESH materialized view ("string")
Cause: An attempt was made to explicitly refresh a NEVER REFRESH MV.
Action: Do not perform this refresh operation or remove the MV(s) from the list.
ORA-23539: table "string"."string" currently being redefined
Cause: An attempt was made to redefine a table which is currently involved in an ongoing redefinition.
Action: Do not perform this redefinition operation on this table or wait till the ongoing redefinition of the table is completed.
ORA-23540: Redefinition not defined or initiated
Cause: An attempt was made to continue or complete a redefinition which was not defined or initiated.
Action: Define or initiate the redefinition before performing this operation.
ORA-23541: tables do not match tables used while defining the redefinition
Cause: An attempt was made to continue or complete a redefinition by providing different tables than those used while defining or initiating the redefinition.
Action: Repeat this operation and specify the same tables as those that were specified while defining or initiating the redefinition.
ORA-23542: dependent object "string"."string" already registered
Cause: An attempt was made to register an already registered dependent object to an ongoing redefinition.
Action: Do not attempt to register an already registered dependent object to an ongoing redefinition. ///////////////////////////////////////////////////////////////////////////// 23600-23999 Reserved for Log Based Replication PL/SQL packages /////////////////////////////////////////////////////////////////////////////
ORA-23600: cannot create PROPAGATION, string already exists
Cause: The propagate_name already exists.
Action: Drop the propagate_name usign DROP_PROPAGATEcommand or specify propagate_name.
ORA-23601: PROPAGATION_NAME string does not exist
Cause: Propagation does not exist.
Action: Query DBA_PROPAGATION view to find existing propagation_name
ORA-23602: Invalid streams process type string
Cause: Specified streams process type is not valid.
Action: Specify either capture or apply.
ORA-23603: STREAMS enqueue aborted due to low SGA
Cause: An attempt to enqueue a STREAMS message was aborted because ORACLE is running low on memory allotted for STREAMS.
Action: Either start consuming messages by enabling any STREAMS propagation or apply which might be disabled. An alternative is to allot more memory to STREAMS, which can be done by increasing the streams_pool_size initialization parameter if one was defined or by increasing the shared_pool_size.
ORA-23605: invalid value "string" for STREAMS parameter string
Cause: An attempt was made to specify an invalid parameter value.
Action: Specify a valid value for the parameter. Check the documentation for valid parameter values.
ORA-23606: invalid object string
Cause: An attempt was made to specify an invalid object.
Action: Specify a valid object.
ORA-23607: invalid column "string"
Cause: An invalid column was specified in the column list.
Action: Check the columns in the object and specify the right column name.
ORA-23608: invalid resolution column "string"
Cause: An invalid column was specified as the resolution column. The resolution column must belong to the list of columns specified in the 'column_list' parameter.
Action: Check the columns in the column_list and specify the right resolution column name.
ORA-23609: unable to find directory object for directory string
Cause: There was no entry in ALL_DIRECTORIES corresponding to the specified directory.
Action: Grant to the current user appropriate privileges on either a new directory object or an existing directory object.
ORA-23610: internal dbms_streams_tablespaces error: [string] [string] [string] [string]
Cause: Streams detected an erroneous result.
Action: Look for information in the session trace file and contact customer support.
ORA-23611: tablespace "string" has more than one data file
Cause: The specified tablespace had more than one data file and hence did not qualify as a simple tablespace.
Action: Choose a self-contained tablespace with a single data file, or use a procedure that supports any tablespace.
ORA-23612: unable to find tablespace "string"
Cause: Either the tablespace did not exist, or the current user did not have sufficient privileges on the tablespace.
Action: Grant appropriate privileges on the tablespace to the current user or choose a different tablespace.
ORA-23619: non-Oracle system error: string
Cause: A non-Oracle database has returned an error message to STREAMS when attempting to apply a DML statement. The non-Oracle system error message is a parameter to this Oracle error.
Action: Corrective action may or may not be possible (depending on the non-Oracle system error). If corrective action is possible, correct the problem and try applying the transaction again.
ORA-23620: bind value size too large for PL/SQL CALL operation
Cause: In a PL/SQL CALL to a stored procedure, the bind string size exceeded 4K.
Action: Either make the bind string size shorter (less than 4K) or use BEGIN-END to call the procedure instead of CALL.
ORA-24000: invalid value string, string should be of the form [SCHEMA.]NAME
Cause: An invalid value was specified for the paramerter.
Action: Specify a string of the form [SCHEMA.]NAME .
ORA-24001: cannot create QUEUE_TABLE, string already exists
Cause: The queue table already exists in the queueing system.
Action: Drop the table first using the DROP_QUEUE_TABLE() command or specify another table.
ORA-24002: QUEUE_TABLE string does not exist
Cause: Queue_table not exist.
Action: Query on the user view USER_QUEUE_TABLES to find out existing queue tables.
ORA-24003: Queue table index string inconsistent with queue table string
Cause: The queue table index has not yet been successfully imported.
Action: Import the queue table index before attempting to use the queue table. If the import failed, correct the problem and try to import the queue table index again.
ORA-24004: invalid column name string in SORT_LIST, should be ENQ_TIME or PRIORITY
Cause: Invalid column name was specified in the SORT_LIST.
Action: The valid column names are ENQ_TIME and PRIORITY.
ORA-24005: must use DBMS_AQADM.DROP_QUEUE_TABLE to drop queue tables
Cause: An attempt was made to use the SQL command DROP TABLE for queue tables, but DROP TABLE is not supported for queue tables.
Action: Use the DBMS_AQADM.DROP_QUEUE_TABLE procedure instead of the DROP TABLE command.
ORA-24006: cannot create QUEUE, string already exists
Cause: The queue requested to be created already exists.
Action: Specify another queue name. Query USER_QUEUES for all the exisiting queues in the users's schema.
ORA-24007: invalid value string, MAX_RETRIES should be non-negative integer
Cause: An invalid value was specified for MAX_RETRIES.
Action: Specify a non-negative integer.
ORA-24008: queue table string.string must be dropped first
Cause: An error was detected when dropping a queue table in a cluster, tablespace, or schema.
Action: Use the DBMS_AQADM.DROP_QUEUE_TABLE procedure to drop the specified queue table first; then, retry the operation.
ORA-24009: invalid value string, QUEUE_TYPE should be NORMAL_QUEUE or EXCEPTION_QUEUE
Cause: Invalid queue type parameter
Action: Valid values are NORMAL_QUEUE for normal queue and EXCEPTION_QUEUE for exception queue.
ORA-24010: QUEUE string does not exist
Cause: The specified queue does not exist.
Action: Specify a valid queue. Query USER_QUEUES for all the valid queues.
ORA-24011: cannot drop QUEUE, string should be stopped first
Cause: The queue has not been stopped i.e. either enqueue or dequeue is still enabled.
Action: Stop the queue first using the STOP_QUEUE command and disable it from both enqueueing and dequeueing.
ORA-24012: cannot drop QUEUE_TABLE, some queues in string have not been dropped
Cause: A queue exists in the queue table which has not been dropped. All queues need to be dropped first.
Action: Drop all queues belonging to this queue table using the drop_queue() command. Be sure to stop the queues appropriately before dropping them. Alternately, use the force option in drop_queuetable.
ORA-24013: invalid value string, RETRY_DELAY should be non-negative
Cause: A negative value was specified for RETRY_DELAY.
Action: Specify a non-negative value for RETRY_DELAY.
ORA-24014: invalid value string, RETENTION_TIME should be FOREVER or non-negative
Cause: Queue retention was specified, but the retention time was specified to be less than zero.
Action: Specify the retention time to be non-negative or FOREVER. Alternately don't specify retention.
ORA-24015: cannot create QUEUE_TABLE, QUEUE_PAYLOAD_TYPE string.string does not exist
Cause: An invalid QUEUE_PAYLOAD_TYPE specified during create_queue_table.
Action: The QUEUE_PAYLOAD_TYPE should be RAW or an object type that already exists in the database.
ORA-24016: cannot create QUEUE_TABLE, user string does not have execute privileges on QUEUE_PAYLOAD_TYPE string.string
Cause: An invalid object type specified for QUEUE_PAYLOAD_TYPE during create_queue_table.
Action: The user should have execute priviliges on the object type specified for the queue.
ORA-24017: cannot enable enqueue on QUEUE, string is an exception queue
Cause: User tried to enable enqueueing to an exception queue.
Action: None.
ORA-24018: STOP_QUEUE on string failed, outstanding transactions found
Cause: There were outstanding transactions on the queue, and WAIT was set to false, so STOP_QUEUE was unsucessful in stopping the queue.
Action: Set WAIT to TRUE and try STOP_QUEUE again. It will hang till all outstanding transactions are completed.
ORA-24019: identifier for string too long, should not be greater than string characters
Cause: The identifier specified is too long.
Action: Try again with a shorter identifier.
ORA-24020: Internal error in DBMS_AQ_IMPORT_INTERNAL, string
Cause: Internal Error occured in the package DBMS_AQ_IMPORT_INTERNAL.
Action: Internal error, call Oracle Support.
ORA-24021: queue table definition not imported for string.string
Cause: The queue definition is not updated because the queue table was not imported properly
Action: Import the queue table again.
ORA-24022: the specified parameters has no effect on the queue
Cause: The parameter combination will not cause the queue to be started or stoped.
Action: None. This is just a warning.
ORA-24023: Internal error in DBMS_AQ_EXP_INTERNAL.string [string] [string]
Cause: Internal Error occured in the package DBMS_AQ_EXP_INTERNAL.
Action: Internal error, call Oracle Support.
ORA-24024: Internal error in DBMS_AQ_IMP_INTERNAL.string [string] [string]
Cause: Internal Error occured in the package DBMS_AQ_IMP_INTERNAL.
Action: Internal error, call Oracle Support.
ORA-24025: invalid value string, QUEUE_PAYLOAD_TYPE should be RAW or an object type
Cause: Parameter queue_payload_type has invalid value.
Action: Specify a valid object type or RAW.
ORA-24026: operation failed, queue string.string has errors
Cause: An attempt was made to enqueue, dequeue or administer a queue which has errors.
Action: Drop the queue table setting the force option to true.
ORA-24027: AQ HTTP propagation encountered error, status-code string, string
Cause: AQ propagation's HTTP request to the propagation servlet at the specified address encountered an error
Action: Specify a valid address in the connect string of the propagation destination dblink, the dblink user has the correct permissions, check if the AQ propagation servlet was properly installed.
ORA-24028: cannot create a reciever non-repudiable single consumer queue
Cause: Tried to create a reciever non-repudiable single consumer queue
Action: This feature is not supported
ORA-24029: operation not allowed on a single-consumer queue
Cause: Tried an operation not allowed on a single-consumer queue.
Action: Specify the operation on a multi-consumer queue.
ORA-24030: Only one of rule or rule-set must be specified
Cause: Specified both a rule and rule-set for the operation.
Action: Specify only one of rule or rule-set.
ORA-24031: invalid value, string should be non-NULL
Cause: Parameter is NULL.
Action: Specify a non NULL value for the parameter.
ORA-24032: object string exists, index could not be created for queue table string
Cause: Oracle AQ tried to create an index with the name specified in the error message. The index could not be created for the specified queue table because a object exists with the same name.
Action: Drop the object specified in the error message and retry the command. You can also choose a different name for the queue table.
ORA-24033: no recipients for message
Cause: An enqueue was performed on a queue that has been set up for multiple dequeuers but there were neither explicit recipients specified in the call nor were any queue subscribers determined to be recipients for this message.
Action: Either pass a list of recipients in the enqueue call or add subscribers to the queue for receiving this message.
ORA-24034: application string is already a subscriber for queue string
Cause: An application name that was already a subscriber for the queue was specified in the dbms_aq.subscribe call.
Action: none
ORA-24035: AQ agent string is not a subscriber for queue string
Cause: An AQ agent that was not a subscriber for the queue was specified.
Action: Check the name and/or address of the agent and retry the call.
ORA-24036: invalid SORT_ORDER column string specified for queue table
Cause: The create queue table command was issued with message_grouping set to TRANSACTIONAL and a sort order column other than priority. Only the priority column can be specified in the sort order for queue tables with transactional grouping.
Action: Change the sort order list in the create queue table command and retry the call.
ORA-24037: schema string in QUEUE_NAME is not same as schema string in QUEUE_TABLE
Cause: The schema specified in the QUEUE_NAME parameter of CREATE_QUEUE is not the same as the schema specified in the QUEUE_TABLE parameter.
Action: Use the same schema name for both the QUEUE_NAME and QUEUE_TABLE parameters and retry the command.
ORA-24038: RETRY_DELAY and MAX_RETRIES cannot be used for a 8.0 compatible multiple consumer queue
Cause: The CREATE_QUEUE or ALTER_QUEUE command was issued with a non-zero RETRY_DELAY and a QUEUE_TABLE that was created for multiple consumers and with COMPATIBLE parameter set to '8.0'.
Action: Either set the RETRY_DELAY to zero or upgrade the queue table to 8.1 compatible using the DBMS_AQADM.MIGRATE_QUEUE_TABLE procedure.
ORA-24039: Queue string not created in queue table for multiple consumers
Cause: Either an ADD_SUBSCRIBER, ALTER_SUBSCRIBER, or REMOVE_SUBSCRIBER procedure, or an ENQUEUE with a non-empty recipient list, was issued on a queue that was not created for multiple consumers.
Action: Create the queue in a queue table that was created for multiple consumers and retry the call.
ORA-24041: propagation schedule exists for QUEUE string and DESTINATION string
Cause: A SCHEDULE_PROPAGATION was issued for a queue and destination pair which has an existing propagation schedule.
Action: Issue UNSCHEDULE_PROPAGATION to remove the existing schedule and then reissue the SCHEDULE_PROPAGATION call.
ORA-24042: no propagation schedule exists for QUEUE string and DESTINATION string
Cause: AN UNSCHEDULE_PROPAGATION was issued for a queue and destination pair which has no existing propagation schedule.
Action: Verify the spelling of the specified QUEUE and DESTINATION and then reissue the call with the correct spelling.
ORA-24043: destination string uses a reserved name, names with AQ$_ prefix are not valid
Cause: An attempt was made to specify a reserved name for a destination.
Action: Enter a different value or NULL for the local destination. Then retry the operation.
ORA-24044: source string and destination string object types do not match
Cause: A message recipient's queue has a different object structure than the sender's queue. The message cannot be propagated.
Action: Either remove the recipient from the subscriber's list for the sender's queue or create the destination queue with an object type that matches the source queue's object type.
ORA-24045: invalid agent address string, agent address should be of the form [SCHEMA.]NAME[@DATABASE LINK]
Cause: An invalid value was specified for the agent address parameter.
Action: Specify a string of the form [SCHEMA.]NAME[@DATABASE LINK].
ORA-24046: protocol attribute reserved for future use
Cause: The protocol attribute of the AQ agent object type is reserved for future use.
Action: Do not specify the protocol attribute in the agent object type.
ORA-24047: invalid agent name string, agent name should be of the form NAME
Cause: An invalid value was specified for the agent name parameter.
Action: Specify a string of the form NAME. Then retry the operation.
ORA-24048: cannot create QUEUE_TABLE, user does not have access to AQ object types
Cause: An attempt was made to issue the CREATE_QUEUE_TABLE command, but the user who issued the command does not have access to internal AQ object types.
Action: Use the DBMS_AQADM.GRANT_TYPE_ACCESS procedure to grant the user access to the AQ object types.
ORA-24049: invalid agent name string, names with AQ$_ prefix are not valid
Cause: An attempt was made to use a reserved prefix in the agent name.
Action: Enter a different value for the agent name. Then, retry the operation.
ORA-24050: subscribers are not supported for exception queue string
Cause: An ADD_SUBSCRIBER, ALTER_SUBSCRIBER, or REMOVE_SUBSCRIBER procedure was issued on a queue that was created as an EXCEPTION_QUEUE.
Action: Specify a NORMAL_QUEUE in the procedure.
ORA-24051: cannot propagate object type payloads that have a REF attribute
Cause: An ADD_SUBSCRIBER or ENQUEUE procedure with a non-NULL address field in the agent type was issued on a queue whose payload has a REF attribute. Propagation of object type payloads that have a REF attribute currently is not supported.
Action: Specify an agent with a NULL address field so that the agent can dequeue from the same queue. Or, change the object type definition to one that does not use REF attributes.
ORA-24052: cannot propagate object type payloads with LOB attributes to an 8.0 release
Cause: The recipient of a message with LOB attributes was using an Oracle 8.0 release. Propagation of LOB attributes is supported only in Oracle 8.1 and higher releases.
Action: Upgrade the target release to Oracle 8.1 and retry. Or, change the object type definition to one that does not use LOBs.
ORA-24053: PRIMARY_INSTANCE and SECONDARY_INSTANCE must be non-negative
Cause: One of PRIMARY_INSTANCE or SECONDARY_INSTANCE was negative.
Action: Specify non-negative integers for PRIMARY_INSTANCE and SECONDARY_INSTANCE.
ORA-24054: cannot propagate to an Oracle 8.0.3 release or lower release
Cause: The recipient of a message was using an Oracle 8.0.3 release or lower release. Propagation is supported only in Oracle 8.0.4 and higher releases.
Action: Upgrade the target release to Oracle 8.0.4 or higher and retry.
ORA-24055: cannot delete propagation status rows that are in prepared state
Cause: An attempt was made to use the internal administration procedure to delete status rows from the SYS.AQ$_PROPAGATION_STATUS table that were in the prepared state.
Action: Wait for the propagation to complete successfully before retrying the operation.
ORA-24056: internal inconsistency for QUEUE string and destination string
Cause: The sequence numbers used in the SYS.AQ$_PROPAGATION_STATUS table were inconsistent for the given queue and destination.
Action: Contact Oracle Worldwide Support.
ORA-24057: cannot define subscriber with rule for queue string
Cause: An ADD_SUBSCRIBER or ALTER_SUBSCRIBER procedure with a rule was issued on a queue for which rule based subscribers are not supported. Rule based subscribers currently are supported only for NORMAL (persistent) multi-consumer queues created using an Oracle release 8.1.0 or higher compatible queue table.
Action: Create a NORMAL multi-consumer queue in an Oracle release 8.1.0 or higher compatible queue table, and retry the call. Or, if the queue is a normal (persistent) multi-consumer queue, convert the queue table to Oracle 8.1.0 or higher compatibility and retry.
ORA-24058: cannot downgrade QUEUE_TABLE that has propagation in a prepared state
Cause: An attempt was made to downgrade the queue table when there were messages being propagated that were in the prepared state.
Action: Wait for the propagation to complete before retrying the operation.
ORA-24059: invalid COMPATIBLE parameter setting string specified in DBMS_AQADM.string
Cause: An invalid compatible parameter was specified in the DBMS_AQADM procedure. The parameter setting must be of the form '8.x.y' where x is the release number and y is the update number.
Action: Specify a valid COMPATIBLE parameter setting, and retry the operation.
ORA-24060: cannot convert QUEUE_TABLE, string already is compatible with release string
Cause: The source queue table in the DBMS_AQADM procedure is compatible with the specified COMPATIBLE parameter setting.
Action: Choose a different COMPATIBLE parameter setting to convert the queue table to the desired compatibility.
ORA-24061: cannot specify non-zero SECONDARY_INSTANCE if PRIMARY_INSTANCE was zero
Cause: A non-zero value was specified for SECONDARY_INSTANCE when PRIMARY_INSTANCE was zero.
Action: Specify a non-zero primary instance before you specify a non-zero secondary instance.
ORA-24062: Subscriber table string inconsistent with queue table string
Cause: The subscriber table has not yet been successfully imported.
Action: Import the subscriber table before attempting to use the queue table. If the import failed, correct the problem and try to import the subscriber table again.
ORA-24063: cannot downgrade QUEUE_TABLE that has queues with rule-based subscribers
Cause: An attempt was made to downgrade the queue table when there were queues on which rule based subscribers are defined.
Action: Remove the rule based subscribers for all queues in this queue table and retry.
ORA-24064: propagation for QUEUE string and DESTINATION string already enabled
Cause: An ENABLE_SCHEDULE_PROPAGATION command was issued for a queue and destination pair whose propagation schedule already was enabled.
Action: Make sure the QUEUE and DESTINATION are correct when you issue the ENABLE_SCHEDULE_PROPAGATION command.
ORA-24065: propagation for QUEUE string and DESTINATION string already disabled
Cause: A DISABLE_SCHEDULE_PROPAGATION command was issued for a queue and destination pair whose propagation schedule already was disabled.
Action: Make sure the QUEUE and DESTINATION are correct when you issue the DISABLE_SCHEDULE_PROPAGATION command.
ORA-24066: invalid privilege specified
Cause: An invalid privilege is specified for granting or revoking privilege
Action: Specify a valid privilege.
ORA-24067: exceeded maximum number of subscribers for queue string
Cause: An attempt was made to add new subscribers to the specified, but the number of subscribers for this queue has exceeded the maximum number (1024) of subscribers allowed per queue.
Action: Remove existing subscribers before trying to add new subscribers.
ORA-24068: cannot start queue string, queue table string is being migrated
Cause: An attempt was made to start a queue in a queue table that is being migrated.
Action: Complete the queue table migration, and retry the operation.
ORA-24069: cannot downgrade queue table string while it is being upgraded
Cause: An attempt was made to downgrade a queue table, but a previous command to upgrade the queue table has not yet completed successfully.
Action: Complete the upragde of the queue table by re-executing the DBMS_AQADM.MIGRATE_QUEUE_TABLE procedure. Then, downgrade the queue table.
ORA-24070: cannot upgrade queue table string while it is being downgraded
Cause: An attempt was made to upgrade a queue table, but a previous command to downgrade the queue table has not yet completed succesfully.
Action: Complete the downgrade of the queue table by re-executing the DBMS_AQADM.MIGRATE_QUEUE_TABLE procedure. Then, upgrade the queue table.
ORA-24071: cannot perform operation string, queue table string is being migrated
Cause: An attempt was made to perform an operation on a queue in a queue table that is being migrated.
Action: Complete the queue table migration, and retry the operation.
ORA-24072: cannot execute MIGRATE_QUEUE_TABLE procedure; must own queue table
Cause: An attempt was made to upgrade or downgrade a queue table using the DBMS_AQADM.MIGRATE_QUEUE_TABLE procedure, but the user who executed the procedure does not own the queue.
Action: Reconnect as the owner of the queue table, and then execute the DBMS_AQADM.MIGRATE_QUEUE_TABLE procedure.
ORA-24073: cannot specify RETENTION_TIME on exception queue string.string
Cause: An attempt was made to create or alter an exception queue by specifying a non-zero RETENTION_TIME.
Action: Use the default RETENTION_TIME parameter value for exception queues.
ORA-24074: RETRY_DELAY and MAX_RETRIES cannot be used for exception queue %.string
Cause: The CREATE_QUEUE or ALTER_QUEUE command was issued with a non-zero RETRY_DELAY and an exception queue.
Action: Do not specify RETRY_DELAY or MAX_RETRIES for exception queues.
ORA-24075: cannot specify agent with NULL address and non-NULL protocol
Cause: An ADD_SUBSCRIBER or enqueue was attemoted with an agent that had a NULL address and a non-NULL protocol.
Action: Either specify a non-NULL address or set the protocol to NULL.
ORA-24076: cannot perform operation string for NON_PERSISTENT queue string.string
Cause: One of the operations, SCHEDULE_PROPAGATION, ALTER_QUEUE, LISTEN, DEQUEUE was issued for a NON_PERSISTENT queue.
Action: Do not specify a NON_PERSISTENT queue for these operations.
ORA-24077: cannot create propagation schedule for EXCEPTION queue string.string
Cause: A SCHEDULE_PROPAGATION was issued for an EXCEPTION queue. Propagation schedules can be created only for NORMAL queues.
Action: To propagate messages from a queue specify the queue type as NORMAL.
ORA-24078: cannot specify a non-NULL SECONDARY_INSTANCE if PRIMARY_INSTANCE was NULL
Cause: A non-NULL value was specified for SECONDARY_INSTANCE when PRIMARY_INSTANCE was NULL.
Action: Specify a non-NULL primary instance before you specify a non-NULL secondary instance.
ORA-24079: invalid name string, names with AQ$_ prefix are not valid for string
Cause: An attempt was made to use a reserved prefix for the object name.
Action: Enter a different name for this object. Then, retry the operation.
ORA-24080: unschedule_propagation pending for QUEUE string and DESTINATION string
Cause: A propagation administration command was issued for a queue and destination pair whose propagation is being unscheduled.
Action: Do not issue propagation administration commands for a propagation schedule on which there is a pending unschedule request.
ORA-24081: compatible parameter needs to be string or greater
Cause: The compatible parameter was not high enough to allow the operation.
Action: shutdown and startup with a higher compatibility setting.
ORA-24082: propagation may still be happening for the schedule for QUEUE string and DESTINATION string
Cause: The snapshot process executing the propagation schedule did not respond to the disable propagation command.
Action: Make sure that the job for the propagation schedule has been ended.
ORA-24083: cannot specify remote subscribers for string QUEUE string
Cause: An add_subscriber call with a non-null address field was issued on a queue which does not support remote subscribers. Remote subscribers are not supported for NON_PERSISTENT QUEUES.
Action: Specify a null address field and retry the call.
ORA-24084: DBLINK name in address field of agent string is not unique within the first 24 bytes
Cause: Advanced Queuing requires that the agent's dblink name should be unique within the first 24 bytes (for 8.0 compatible queuetables)
Action: Specify a dblink name that is unique within the first 24 bytes or migrate to 8.1 compatible queuetables where this restriction is not there.
ORA-24085: operation failed, queue string is invalid
Cause: An attempt was made to enqueue, dequeue or administer a queue which is invalid. This could have occured because the payload type of the queue's queue table was dropped.
Action: Drop the queue table setting the force option to true.
ORA-24086: cannot create a 8.0 compatible string queue
Cause: An attempt was made to create a 8.0 compatible queue table and enable a feature that is supported only on 8.1 style queue tables
Action: This feature is not supported
ORA-24087: Invalid database user string
Cause: An invalid database username was specified
Action: Specify a valid database user
ORA-24088: AQ Agent string does not exist
Cause: This AQ Agent does not exist
Action: Specify a valid AQ agent. Check the DBA_AQ_AGENTS view for a list of valid aq agents
ORA-24089: AQ Agent string already exists
Cause: This AQ agent has already been created
Action: Specify another agent name or use the ALTER api to modify the agent information.
ORA-24090: at least one protocol must be enabled
Cause: No protocol was enabled for aq agent
Action: Enable one of the protocols by setting one of the enable parameters to true.
ORA-24092: invalid value string specified
Cause: A queue, queue table, rule, or ruleset name that requires double quotes was specifed when the database compatibility was less than 10.0.
Action: Specify a value that does not require double quotes and retry the operation.
ORA-24093: AQ agent string not granted privileges of database user string
Cause: The specified AQ agent does not have privileges of the specified database user
Action: Specify a valid combination of AQ agent and database user. Check the DBA_AQ_AGENT_PRIVS or USER_AQ_AGENT_PRIVS view for user/agent mappings
ORA-24094: invalid transformation, target type does not match that of the queue
Cause: The target type of the transformation specified was different from the type of the queue.
Action: Provide a valid transformation whose target type is the same as the queue type.
ORA-24095: invalid transformation, source type does not match that of the queue
Cause: The source type of the transformation specified was different from the type of the queue.
Action: Provide valid transformation whose source type is the same as the queue type.
ORA-24096: invalid message state specified
Cause: Invalid value is specified for message state
Action: Provide a valid message state as specified in the documentation
ORA-24097: Invalid value string, string should be non-negative
Cause: A negative value or NULL was specified for the parameter.
Action: Specify a non negative integer.
ORA-24098: invalid value string for string
Cause: An Invalid value or NULL was specified for the parameter.
Action: Check the documentation for valid values.
ORA-24099: operation not allowed for 8.0 compatible queues
Cause: The specified operation is only supported for queues with compatibility 8.1 or greater
Action: Upgrade the 8.0 compatible queue to release 8.1 using DBMS_AQADM.MIGRATE_QUEUE_TABLE or specify a queue with compatibility 8.1
ORA-24100: error in ktz testing layer
Cause: There is an error in the Transaction layer test ICDs
Action: none
ORA-24101: stopped processing the argument list at: string
Cause: One of the arguments of the requested operation contained a list of scheduler objects. While processing this list an error was encountered with the specified item.
Action: Resolve the error for this element of the list and then re-issue the command with the remainder of the argument list. See the rest of the error stack to find out what the exact error is.
ORA-24102: invalid prefix for generate_job_name
Cause: generate_job_name was called with a prefix longer than 18 characters or a prefix ending in a digit.
Action: Re-issue the command using a prefix no longer than 18 characters and not ending in a digit.
ORA-24120: invalid string parameter passed to DBMS_REPAIR.string procedure
Cause: An invalid parameter was passed to the specified DBMS_REPAIR procedure.
Action: Specify a valid parameter value or use the parameter's default.
ORA-24121: both cascade and a block range passed to DBMS_REPAIR.CHECK_OBJECT procedure
Cause: Both cascade and a block range were specified in a call to DBMS_REPAIR.CHECK_OBJECT.
Action: Use either cascade or a block range, or do not use either one.
ORA-24122: invalid block range specification
Cause: An incorrect block range was specified.
Action: Specify correct values for the BLOCK_START and BLOCK_END parameters.
ORA-24123: feature string is not yet implemented
Cause: An attempt was made to use the specified feature, but the feature is not yet implemented.
Action: Do not attempt to use the feature.
ORA-24124: invalid ACTION parameter passed to DBMS_REPAIR.string procedure
Cause: An invalid ACTION parameter was specified.
Action: Specify CREATE_ACTION, PURGE_ACTION or DROP_ACTION for the ACTION parameter.
ORA-24125: Object string.string has changed
Cause: An attempt was made to fix corrupt blocks on an object that has been dropped or truncated since DBMS_REPAIR.CHECK_OBJECT was run.
Action: Use DBMS_REPAIR.ADMIN_TABLES to purge the repair table and run DBMS_REPAIR.CHECK_OBJECT to determine whether there are any corrupt blocks to be fixed.
ORA-24126: invalid CASCADE_FLAG passed to DBMS_REPAIR.string procedure
Cause: CASCADE_FLAG was specified for an object that is not a table.
Action: Use CASCADE_FLAG only for tables.
ORA-24127: TABLESPACE parameter specified with an ACTION other than CREATE_ACTION
Cause: The TABLESPACE parameter can only be used with CREATE_ACTION.
Action: Do not specify TABLESPACE when performing actions other than CREATE_ACTION.
ORA-24128: partition name specified for a non-partitioned object
Cause: A partition name was specified for an object that is not partitioned.
Action: Specify a partition name only if the object is partitioned.
ORA-24129: table name string does not start with string prefix
Cause: An attempt was made to pass a table name parameter without the specified prefix.
Action: Pass a valid table name parameter.
ORA-24130: table string does not exist
Cause: An attempt was made to specify a map, repair, or sync table that does not exist.
Action: Specify a valid table name parameter.
ORA-24131: table string has incorrect columns
Cause: An attempt was made to specify a map, repair, or sync table that does not have a correct definition.
Action: Specify a table name that refers to a properly created table.
ORA-24132: table name string is too long
Cause: An attempt was made to specify a table name is greater than 30 characters long"
Action: Specify a valid table name parameter.
ORA-24141: rule set string.string does not exist
Cause: An attempt to access or modify a ruleset was made, which failed because the ruleset does not exist.
Action: Only access or modify existing rulesets.
ORA-24142: invalid ruleset name
Cause: An attempt to create a ruleset with an invalid name was made. The ruleset name can not be NULL, and can not be more than 26 characters, unless a rules_table_name is also specified, in which case the ruleset name may be up to 30 characters.
Action: Retry the create with a valid ruleset name.
ORA-24143: invalid evaluation context name
Cause: An attempt to create a rule/ruleset on an invalid evaluation name was made. The evaluation_context can not be more than 30 characters. The evaluation context with the name specified must exist.
Action: Retry the create with a valid evaluation context name.
ORA-24144: rules engine internal error, arguments: [string], [string]
Cause: An internal error occurred in the rules engine. This indicates that the rules engine has encountered an exception condition.
Action: Please report this error as a bug. The first argument is the error and the second argument is the package.
ORA-24145: evaluation context string.string already exists
Cause: An evaluation context of the given name already exists
Action: Specify another name for the evaluation context being created
ORA-24146: rule string.string already exists
Cause: A rule of the given name already exists
Action: Specify another name for the rule being created.
ORA-24147: rule string.string does not exist
Cause: The rule of the given name does not exist
Action: create the rule or specify one that exists
ORA-24148: cannot drop rule string.string with dependents
Cause: The rule still belongs to some rulesets, cannot be dropped
Action: do not drop a rule that belongs to rulesets without force option
ORA-24149: invalid rule name
Cause: An attempt to create a rule with an invalid name was made. The rule name can not be NULL, and can not be more than 30 characters
Action: none
ORA-24150: evaluation context string.string does not exist
Cause: The evaluation context of the given name does not exist
Action: create the evaluation context or specify one that exists
ORA-24151: no evaluation context is associated with rule string.string or rule set string.string
Cause: Whening adding a rule to a rule set, either the rule or the rule set must have an evaluation context associated with it
Action: do not add a rule without an evaluation context to a ruleset that does not have a default evaluation context
ORA-24152: cannot drop evaluation context string.string with dependents
Cause: The evaluation context still belongs to some rules or rule sets, cannot be dropped
Action: do not drop an evaluation context with dependents without force option
ORA-24153: rule set string.string already exists
Cause: A rule set of the given name already exists
Action: Specify another name for the rule set being created.
ORA-24154: rule string.string already in rule set string.string
Cause: a rule can be added to a rule set only once
Action: do not add a rule to a rule set that already contains this rule
ORA-24155: rule string.string not in rule set string.string
Cause: the rule to be removed from the rule set is not in the rule set
Action: do not remove a rule from a rule set that does not contain the rule
ORA-24156: duplicate table alias string
Cause: there is a table alias of the same name in the evaluation context
Action: do not add two table aliases of the same name to an evaluation context
ORA-24157: duplicate variable name string
Cause: there is a variable of the same name in the evaluation context
Action: do not add two variables of the same name to an evaluation context
ORA-24158: invalid table alias
Cause: table alias name or base table name is not specified in the table alias definiton
Action: specify both alias name and alias base table in the table alias structure
ORA-24159: invalid variable definiton
Cause: variable name or variable type is not specified in the variable definiton
Action: specify both variable name and variable type in the variable definition structure
ORA-24160: name string already exists in the name value pair list
Cause: there is already a name-value pair with the same name in the NVlist
Action: try another name.
ORA-24161: name string does not exist in the name value pair list
Cause: there is not such a name-value pair in the NVlist
Action: check the name-value pair exists in the NVList.
ORA-24162: name value pair list is full, cannot add another entry
Cause: The NVList is full (1024 elements) and cannot hold more elements
Action: do not add elements to a full list.
ORA-24163: dblink is not supported in rules engine DDLs
Cause: the object name has a database link in it, which is not supported
Action: Do not specify remote objects in rules engine DDLs.
ORA-24164: invalid rule engine system privilege: string
Cause: no such system privilege number for rule engine objects
Action: check specfication of dbms_rule_adm for valid system privilege numbers
ORA-24165: invalid rule engine object privilege: string
Cause: no such object privilege number for rule engine objects
Action: check specfication of dbms_rule_adm for valid object privilege numbers
ORA-24166: evaluation context string.string has errors
Cause: cannot resolve the table aliases and the variable types specified in the evaluation context
Action: make sure all base tables exist and all variable types correct
ORA-24167: incompatible rule engine objects, cannot downgrade
Cause: there are rule engine objects in the database that cannot be downgraded.
Action: check utlincmp.sql and remove all incompatible rules engine objects before downgrade.
ORA-24168: rule string.string cannot have default evaluation context
Cause: If a rule is added to a rule set with more than one evaluation contexts, it must not have an evaluation context itself.
Action: Do not set the evaluation context of such rules to a not-null value
ORA-24169: rule condition has unrecognized variables
Cause: The rule references variables not in the evaluation context.
Action: Modify the rule condition to remove illegal reference.
ORA-24170: %s.string is created by AQ, cannot be dropped directly
Cause: This object is created by AQ, thus cannot be dropped directly
Action: use dbms_aqadm.drop_subscriber to drop the object
ORA-24171: creation properties are only for internal use
Cause: user specified not null creation properties when creating rules engine objects, which are not for external use
Action: do not set creation properties when creating rules engine objects
ORA-24172: rule set string.string has errors
Cause: The rule references variables not in the evaluation context.
Action: Modify the rule condition to remove illegal reference.
ORA-24180: invalid transformation expression, the transformation expression does not evaluate to the target type/attribute
Cause: The transformation expression does not evaluate to the target type or the target type's specified attribute.
Action: Provide valid transformation expression which evaluates to the target type or the target type's specified attribute.
ORA-24181: The type string does not exist
Cause: The source or destination type for the transformation does not exist
Action: Create the type or specify one that exists
ORA-24182: attribute number specified does not exist
Cause: The target type of the transformation does not have the attribute number specified in the ADD_ATTRIBUTE_TRANSFORMATION command
Action: check the target type definition and specify a valid attribute number
ORA-24183: invalid transformation
Cause: The transformation specified is invalid because the source or the target type have been dropped/modified.
Action: Drop and recreate the transformation
ORA-24184: transformation string.string, already exists
Cause: A transformation of the given name already exists
Action: Specify another name for the transformation being created.
ORA-24185: Transformation string.string, does not exist
Cause: The transformation being specified does not exist.
Action: Create the transformation before using it or specify an existing transformation.
ORA-24186: wrong object type, could not transform message
Cause: The object type of the message to be transformed does not match the source type of the specified transfomation.
Action: Specify another transformation, or specify a message of the correct type.
ORA-24190: length of payload exceeds string
Cause: the length of payload being taken exceeds the limit of varchar2 or raw.
Action: use clob type or blob type to call get_text or get_bytes.
ORA-24191: the property name string has existed
Cause: the property name being set has existed.
Action: use another property name.
ORA-24192: the property name cannot be null
Cause: the property name cannot be null.
Action: make sure the property name not null.
ORA-24193: the property value exceeds the valid range string
Cause: the property valus being set exceeds the valid range.
Action: make sure the property value is within the valid range.
ORA-24194: attempt to read data in a message as the wrong type
Cause: According to JMS specification, some type conversions were not allowed.
Action: Make sure to use the correct READ function to retrieve message data.
ORA-24195: attemp to retrieve the name list of a map message with size exceeding 1024
Cause: The GET_NAMES function returns the names in a varray with a size limit of 1024.
Action: Retrieve in several smaller steps using the GET_NAMES function with OFFSET and LENGTH parameters.
ORA-24196: access the message in a wrong access mode
Cause: StreamMessage and BytesMessage could not be read when they were in write only mode and vice versa.
Action: Change the access mode using PREPARE, CLEAR_BODY and RESET procedures.
ORA-24197: JAVA stored procedure throws JAVA exceptions
Cause: The JAVA stored procedure threw some exceptions that could not be catergorized.
Action: Use GET_EXCEPTION procedure to see what the exception is about.
ORA-24198: attempt to use an invalid operation ID
Cause: An attempt was made to use an invalid operation ID to access messages.
Action: Use the correct operation ID returned by PREPARE or CLEAR_BODY procedure.
ORA-24199: message store is overflow
Cause: An attemp was made to access too many messages at the same time.
Action: Use the CLEAN procedure to clean up some of the messages.
ORA-24201: duplicate publisher, publisher already added to the queue
Cause: Attempted to add a publisher to the queue again.
Action: Specify another publisher or user DBMS_AQADM.ALTER_PUBLISHER to alter the publisher's properties.
ORA-24202: publisher does not exist for the queue
Cause: Attempted to alter or drop a non existent publisher from a queue.
Action: Specify another publisher.
ORA-24203: operation failed, queue table string.string has errors
Cause: An operation attempt was made to a queue table which has errors.
Action: Drop the queue table setting the force option to true.
ORA-24265: Insufficient privileges for SQL profile operation
Cause: A DDL operation was attempted on a SQL profile by a session without the proper privileges.
Action: Grant the user the appropriate privilege.
ORA-24270: a row already exists in the string table for these parameters
Cause: A call was made to create a new row in the specified table. A row already exists in the table with the specified values.
Action: Delete the existing row using the appropriate API or check the parameters used to create the row.
ORA-24271: translation type must be either T, S or M
Cause: The translation type parameter is not a T, S or an M. A value other than T, S or M was specified.
Action: Correct the translation type and reexecute the API call.
ORA-24272: initialization value must be either F or T
Cause: The initialization value must be either F or T. A value other than F or T was specified.
Action: Correct the initialization value and reexecute the API call.
ORA-24273: translation text is required if translation type is T or S
Cause: If a translation type of T or S is specified, translation text must be supplied.
Action: Provide translation text and reexecute the API call.
ORA-24274: no row exists in the string table for these parameters
Cause: A call was made to update a row that does not exist or a foreign key value supplied to create a table does not exist.
Action: Create the row using the appropriate API or check the parameters used to create the new row to ensure that all specified values exist.
ORA-24275: function 'string' parameter 'string' missing or invalid
Cause: The function <pkgname.funcname> was called with a parameter <parmname> that was null, 0 length, or had an invalid value.
Action: Correct the parameter to supply values that comply with its datatype and limits as specified in the documentation.
ORA-24276: function 'string' output 'string' maximum value exceeded
Cause: The function <pkgname.funcname> computed a value for the output <parmname> that exceeded the maximum allowed. This can occur when multiple input parameters, each valid separately, combine to specify an invalid result. For example, when a length parameter multiplied by a copies parameter yields a total length exceeding the maximum for the output datatype.
Action: Correct the input values to produce a result that will comply with the limits as specified in the documentation.


15 ORA-24280 to ORA-28674

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

15 ORA-24280 to ORA-28674

ORA-24280: invalid input value for parameter string
Cause: The parameter has been provided a negative, out of range, or NULL input value.
Action: Correct the input value such that it is valid, and is within the range as specified in the documentation.
ORA-24281: invalid access past the maximum size of LOB parameter string
Cause: The value of positional or size parameters exceeds the maximum allowed LOB size of 4 Gigabytes.
Action: Correct the input values for amount and offset such that their sum is less than or equal to 4 Gigabytes. If error occurs in a read or write loop, check the looping conditions and/or offset increments.
ORA-24292: no more tables permitted in this sorted hash cluster
Cause: A sorted hash cluster only supports a maximum of 2 tables
Action: none
ORA-24295: max key length (string) for sorted hash cluster exceeded
Cause: Sorted hash clusters have a maximum key size
Action: none
ORA-24300: bad value for mode
Cause: An undefined mode value was specified.
Action: Check that the correct mode is selected and that an allowed value for that mode is specified.
ORA-24301: null host specified in thread-safe logon
Cause: An HDA was not specified in the logon call while running in a thread safe environment.
Action: Make sure that HDA is not NULL when calling the logon routine.
ORA-24302: host connection in use by another thread
Cause: An attempt was made to use the host connection while it was in use by another thread.
Action: Wait for another thread to finish before using this connection.
ORA-24303: call not supported in non-deferred linkage
Cause: One of the calls that is supported in deferred mode linkage exclusively was invoked when the client was linked non-deferred.
Action: Use this call in deferred mode of linkage.
ORA-24304: datatype not allowed for this call
Cause: Data of this datatype cannot be sent or fetched in pieces.
Action: Use other bind or define calls for this datatype.
ORA-24305: bad bind or define context
Cause: The call was executed on a cursor for which this is invalid.
Action: Verify that this call is valid for this cursor. For example, Get piece information and set piece information are valid on a cursor if appropriate binds and defines have been done on this cursor.
ORA-24306: bad buffer for piece
Cause: A zero length buffer or a null buffer pointer was provided.
Action: Verify that the buffer pointing to this piece or its length is non-zero. The buffer pointer for the next piece or its length can be zero if it is the last piece to be inserted and there are no more data for the column.
ORA-24307: invalid length for piece
Cause: The length of the piece exceeded the maximum possible size.
Action: Verify that the length of this piece and the cumulative length of all the previous pieces is not more than the desired value supplied by the application.
ORA-24308: illegal define position
Cause: Call to modify attributes was done for a non-existent position
Action: Verify that a define has been done for this position
ORA-24309: already connected to a server
Cause: This server handle is already attached to a server.
Action: Disconnect from the server and then retry the call to establish a connection.
ORA-24310: length specified for null connect string
Cause: The connect string is null, but a length was specified for it.
Action: Set length to zero if connect string is null.
ORA-24311: memory initialization failed
Cause: Cannot initialize user memory.
Action: Contact customer support.
ORA-24312: illegal parameters specified for allocating user memory
Cause: An illegal size or null pointer was specified for user memory.
Action: Specify a legal size and a valid pointer for user memory.
ORA-24313: user already authenticated
Cause: A user has already been authenticated on this service handle.
Action: Terminate the service context before using it for another user.
ORA-24314: service handle not initialized
Cause: The server context does not done exist.
Action: Establish the server context in the service context.
ORA-24315: illegal attribute type
Cause: An illegal attribute type was specified for the handle.
Action: Consult user manual to specify an attribute valid for this handle.
ORA-24316: illegal handle type
Cause: An illegal handle type was specified.
Action: Consult user manual to specify a valid handle type.
ORA-24317: define handle used in a different position
Cause: A define was done with an existing handle on a different position.
Action: Specify the same position as before on a re-define.
ORA-24318: call not allowed for scalar data types
Cause: This call is valid only for object types.
Action: Verify that the data-type for this variable is an object type
ORA-24319: unable to allocate memory
Cause: Process was unable to allocate memory to store diagnostics.
Action: Terminate other processes in order to reclaim needed memory.
ORA-24320: unable to initialize a mutex
Cause: An attempt to initialize a mutex failed.
Action: Contact customer support.
ORA-24321: inconsistent parameters passed
Cause: One of the three memory function pointers is null or non-null.
Action: Verify that either all the memory functions are null or non-null.
ORA-24322: unable to delete an initialized mutex
Cause: An attempt to delete an initialized mutex failed.
Action: Contact customer support.
ORA-24323: value not allowed
Cause: A null value or a bogus value was passed in for a mandatory parameter.
Action: Verify that all mandatory parameters are properly initialized.
ORA-24324: service handle not initialized
Cause: An attempt was made to use an improper service context handle.
Action: Verify that the service context handle has all the parameters initialized prior to this call.
ORA-24325: this OCI operation is not currently allowed
Cause: An attempt was made to use a context handle outside its scope.
Action: Verify that the context handle is set to a service context handle that has been converted to a logon data area for other OCI calls. The logon data area must be converted back to a service context before it can be used.
ORA-24326: handle passed in is already initialized
Cause: An attempt was made to pass an initialized handle.
Action: Verify that the parameter passed in to retrieve a handle does not already point to a handle.
ORA-24327: need explicit attach before authenticating a user
Cause: A server context must be initialized before creating a session.
Action: Create and initialize a server handle.
ORA-24328: illegal attribute value
Cause: The attribute value passed in is illegal.
Action: Consult the users manual and specify a legal attribute value for the handle.
ORA-24329: invalid character set identifier
Cause: The character set identifier specifed is invalid
Action: Specify a valid character set identifier in the OCI call.
ORA-24330: internal OCI error
Cause: An internal OCI error has occurred.
Action: Please contact Oracle customer support.
ORA-24331: user buffer too small
Cause: The user buffer to contain the output data is too small.
Action: Specify a bigger buffer.
ORA-24332: invalid object type
Cause: An invalid object type is requested for the describe call.
Action: Specify a valid object type to the describe call.
ORA-24333: zero iteration count
Cause: An iteration count of zero was specified for the statement
Action: Specify the number of times this statement must be executed
ORA-24334: no descriptor for this position
Cause: The application is trying to get a descriptor from a handle for an illegal position.
Action: Check the position number.
ORA-24335: cannot support more than 1000 columns
Cause: The number of columns exceeds the maximum number supported.
Action: none
ORA-24336: invalid result set descriptor
Cause: The result set descriptor should have valid data fetched into it before it can be converted to a statement handle
Action: Fetch valid data into the descriptor before attempting to convert it into a statement handle
ORA-24337: statement handle not prepared
Cause: A statement cannot be executed before making preparing a request.
Action: Prepare a statement before attempting to execute it.
ORA-24338: statement handle not executed
Cause: A fetch or describe was attempted before executing a statement handle.
Action: Execute a statement and then fetch or describe the data.
ORA-24339: cannot set server group name after connecting to server
Cause: An attempt was made to set the server group in a server handle after connecting to the server. However, once the connection is established to a server, the server group name cannot be set anymore.
Action: Attach to the server after setting the server group name in the server handle.
ORA-24340: cannot support more than 255 columns
Cause: The number of columns exceeds maximum supported by the server.
Action: Limit your operation to 255 columns.
ORA-24341: bad mode specified
Cause: OCI_ENV_NO_MUTEX mode was specified for a non-threaded client.
Action: OCI_ENV_NO_MUTEX may be specified when OCI_THREADED had been specified at process initialization.
ORA-24342: unable to destroy a mutex
Cause: An attempt to destroy a mutex failed.
Action: none
ORA-24343: user defined callback error
Cause: The only valid return value for a user defined callback function is OCI_CONTINUE or OCI_ROWCBK_DONE. Any other value will cause this error.
Action: Please insure that OCI_CONTINUE or OCI_ROWCBK_DONE is returned from the user defined callback function.
ORA-24344: success with compilation error
Cause: A sql/plsql compilation error occurred.
Action: Return OCI_SUCCESS_WITH_INFO along with the error code
ORA-24345: A Truncation or null fetch error occurred
Cause: A truncation or a null fetch error"
Action: Please ensure that the buffer size is long enough to store the returned data.
ORA-24346: cannot execute without binding variables
Cause: None of the bind variables in the SQL statement are bound.
Action: Please bind all the variables before the execute is done.
ORA-24347: Warning of a NULL column in an aggregate function
Cause: A null column was processed by an aggregate function
Action: An OCI_SUCCESS_WITH_INFO is returned.
ORA-24348: Update or Delete without Where
Cause: An update or delete was executed without where clause
Action: An OCI_SUCCESS_WITH_INFO is returned.
ORA-24350: OCI call not allowed
Cause: OCI used is not permitted from external procedures.
Action: Refer to user manual for usage restrictions.
ORA-24351: invalid date passed into OCI call
Cause: A bad date was passed into one of the OCI calls.
Action: Check your date bind values and correct them.
ORA-24352: invalid COBOL display type passed into OCI call
Cause: A bad COBOL display type was passed into one of the OCI calls.
Action: Check your COBOL display type bind values and correct them.
ORA-24353: user buffer too small to accommodate COBOL display type
Cause: User supplied buffer for a COBOL display type was too small to accommodate fetched number.
Action: Increase the allocation for COBOL display type buffer.
ORA-24354: number fetched too large to fit in COBOL display type buffer.
Cause: The number fetched was beyond the range that can be displayed.
Action: Please check the number in the database.
ORA-24355: attempt to store a negative number in an Unsigned Display type.
Cause: An attempt was made to convert a negative number into an unsigned display type.
Action: Please check the number in the database or change the defined datatype.
ORA-24356: internal error while converting from to COBOL display type.
Cause: An internal error was encountered during conversion to COBOL display type.
Action: Contact customer support.
ORA-24357: internal error while converting from to OCIDate.
Cause: An internal error was encountered during conversion to OCIDate type.
Action: Contact customer support.
ORA-24358: OCIBindObject not invoked for a Object type or Reference
Cause: OCIBindObject was not invoked resulting in an incomplete bind specification for a Object Type or Reference.
Action: Please invoke the OCIBindObject call for all Object Types and References.
ORA-24359: OCIDefineObject not invoked for a Object type or Reference
Cause: OCIDefineObject was not invoked resulting in an incomplete bind specification for a Object Type or Reference.
Action: Please invoke the OCIDefineObject call for all Object Types and References.
ORA-24360: Type Descriptor Object not specified for Object Bind/Define
Cause: Type Descriptor Object is a mandatory parameter for Object Types Binds and Defines.
Action: Please invoke the OCIBindObject() or OCIDefineObject() call with a valid Type Descriptor Object.
ORA-24361: basic bind call not invoked before invoking advanced bind call
Cause: One of the basic bind calls was not invoked on this bind handle before performing an advanced bind call.
Action: Please invoke the advanced bind call on this bind handle only after performing a basic bind call.
ORA-24362: improper use of the character count flag
Cause: When the character count flag is set, then the maximum size of the buffer in the server should be specified as a non-zero value.
Action: Please use a non-zero value for the mamimum size of the buffer in the server.
ORA-24363: measurements in characters illegal here
Cause: Measurements in characters instead of bytes are illegal if either the server's or client's character set is varying width.
Action: If either the client's or server's character set is varying width then do not use the OCI_ATTR_CHAR_COUNT attribute for the bind handle. Use OCI_ATTR_MAXDATA_SIZE instead.
ORA-24364: internal error while padding blanks
Cause: An internal error has occurred while attempting to blank pad string data. This error should not occur normally.
Action: Contact customer support.
ORA-24365: error in character conversion
Cause: This usually occurs during conversion of a multibyte character data when the source data is abnormally terminated in the middle of a multibyte character.
Action: Make sure that all multibyte character data is properly terminated.
ORA-24366: migratable user handle is set in service handle
Cause: This occurs during user authentication, a migratable user handle has been set in the service handle.
Action: Service handle must not be set with migratable user handle when it is used to authenticate another user.
ORA-24367: user handle has not been set in service handle
Cause: This occurs during authentication of a migratable user. the service handle has not been set with non-migratable user handle.
Action: Service handle must be set with non-migratable user handle when it is used to authenticate a migratable user.
ORA-24368: OCI mutex counter non-zero when freeing a handle
Cause: This is an internal OCI error.
Action: Contact customer support.
ORA-24369: required callbacks not registered for one or more bind handles
Cause: No callbacks have been registered for one or more of the bind handles which are part of the RETURNING clause.
Action: The bind handles which are to receive data in a DML statememt with a RETURNING clause must have their mode set as DATA_AT_EXEC and callback functions must be registered for these bind handles using OCIBindDynamic.
ORA-24370: illegal piecewise operation attempted
Cause: Data of a certain datatype that does not support piecewise operation is being sent or fetched in pieces.
Action: Always set the piece value to OCI_ONE_PIECE for datatypes that does not support piecewise operation.
ORA-24371: data would not fit in current prefetch buffer
Cause: An internal OCI error has occurred.
Action: Please contact Oracle customer support.
ORA-24372: invalid object for describe
Cause: The object to be described is not valid. It either has compilation or authorization errors.
Action: The object to be described must be valid.
ORA-24373: invalid length specified for statement
Cause: The length specified for the statement is either 0 or too large.
Action: Specify a valid length for the statement.
ORA-24374: define not done before fetch or execute and fetch
Cause: The application did not define output variables for data being fetched before issuing a fetch call or invoking a fetch by specifying a non-zero row count in an execute call.
Action: Issue OCI define calls for the columns to be fetched.
ORA-24375: Cannot use V6 syntax when talking to a V8 server
Cause: V6 syntax is no longer supported in V8 server.
Action: Change syntax to V7 syntax or higher.
ORA-24376: cannot register/get user callback for non-environment handle
Cause: A user callback registration or get was attempted on a handle which is not an environment handle.
Action: Pass the environment handle to register/get user callback.
ORA-24377: invalid OCI function code
Cause: An invalid function code was used to register or get user callback"
Action: Use a valid OCI function code.
ORA-24378: user callbacks not allowed for this call
Cause: An attempt was made to register a user callback for an OCI call for which it not allowed to register user callbacks.
Action: Do not register user callback for this OCI call.
ORA-24379: invalid user callback type
Cause: An invalid type of user callback was specified.
Action: Specify a valid user callback type.
ORA-24380: invalid mode specification
Cause: The mode parameter in an OCIU* call is invalid
Action: Use only valid mode parameter
ORA-24381: error(s) in array DML
Cause: One or more rows failed in the DML.
Action: Refer to the error stack in the error handle.
ORA-24382: statement handled already executed or described
Cause: The Statement handle was executed or described successfuly before.
Action: Perform a OCIStmtPrepare again before OCI_PARSE_ONLY.
ORA-24383: Overflow segment of an IOT cannot be described
Cause: The name specified in the OCIDescribeAny call referred to an IOT overflow segment.
Action: Use OCIDescribeAny to describe only documented objects.
ORA-24384: Application context size is not initialized
Cause: The size of the application context must be initialized before populating each context element.
Action: Issue OCIAttrSet with OCI_ATTR_CTX_SIZE to initialize context size
ORA-24385: Application context size or index is not valid
Cause: The size or index of the application context must be non-zero and non-negative.
Action: Use an appropriate value for the size.
ORA-24386: statement/server handle is in use when being freed
Cause: This is an internal OCI error.
Action: The user should reset in-use flag in statement handle before freeing the handle.
ORA-24387: Invalid attach driver
Cause: Trying to attach using the wrong driver
Action: Relink the application in the right mode
ORA-24388: Unsupported functionality in fast path mode
Cause: Feature not supported in fast path mode
Action: Avoid using the functionality in this mode
ORA-24389: Invalid scrollable fetch parameters
Cause: All the requested rows in this fetch could not be received.
Action: Check the fetch orientation, scroll offset, OCI_ATTR_CURRENT_POSITION and number of rows in OCIStmtFetch2 call. If required, change some of above parameters and fetch again.
ORA-24390: Unsupported scrollable cursor operation
Cause: The scrollable cursor execute or fetch has failed.
Action: Check the documentation for supported types, and other restrictions while using scrollable cursors.
ORA-24391: invalid fetch operation
Cause: Scrollable cursor operation requested with non-scrollable cursor.
Action: Check if the statement was executed in the scrollable mode. Else the only acceptable orientation is OCI_FETCH_NEXT that ignores the scroll offset parameter.
ORA-24392: no connection pool to associate server handle
Cause: OCIServerAttach called in OCI_POOL mode but no connection pool found to associate the server handle.
Action: 1) Verify that OCIConnectionPoolCreate is called before calling OCIServerAttach. 2) Verify that the database link specified in OCIServerAttach matches with that of the connection pool database link.
ORA-24393: invalid mode for creating connection pool
Cause: Mode specified in OCIConnectionPoolCreate is invalid.
Action: Use a valid mode.
ORA-24394: invalid mode for destroying connection pool
Cause: Mode specified in OCIConnectionPoolDestroy is invalid.
Action: Use a valid mode.
ORA-24395: cannot reinitialize non-existent pool
Cause: OCIConnectionPoolCreate was not called in OCI_DEFAULT mode for this pool handle.
Action: Create a connection pool prior to reinitializing it.
ORA-24396: invalid attribute set in server handle
Cause: Attribute OCI_ATTR_NONBLOCKING_MODE has been set on the server handle and attached in OCI_POOL mode. Connection pooling does not support non blocking mode.
Action: Do not set the OCI_ATTR_NONBLOCKING_MODE attribute on the server handle while attaching in OCI_POOL mode.
ORA-24397: error occured while trying to free connections
Cause: An internal error occured while trying to free connections.
Action: Contact customer support.
ORA-24398: connection pool already exists
Cause: A connection pool has already been created for the specified pool handle.
Action: 1) Specify a different pool handle to create a new connection pool. 2) If you wish to modify the pool parameters, call OCIConnectionPoolCreate in OCI_CPOOL_REINITIALIZE mode.
ORA-24399: invalid number of connections specified
Cause: An invalid combination of minimum, maximum and increment number of connections was specified in the OCIConnectionPoolCreate call.
Action: Specify a valid combination of parameters.
ORA-24400: error occured while creating connections in the pool
Cause: The database link specified in OCIConnectionPoolCreate might be an invalid one.
Action: Specify a valid database link.
ORA-24401: cannot open further connections
Cause: Sufficient number of connections are not present in the pool to execute the call. No new connections can be opened as the connMax parameter supplied in OCIConnectionPoolCreate has been reached.
Action: Call OCIConnectionPoolCreate in OCI_CPOOL_REINITIALIZE mode and increase the value of the connMax parameter.
ORA-24402: error occured while creating connections in the pool
Cause: The username and password specified in OCIConnectionPoolCreate might be invalid.
Action: Specify a valid username and password.
ORA-24403: error occured while trying to destroy the connection pool
Cause: Some connections in the pool were busy when an attempt to destroy the connection pool was made.
Action: Ensure no connections from the pool are being used.
ORA-24404: connection pool does not exist
Cause: An attempt was made to use the connection pool before creating it.
Action: Create the connection pool.
ORA-24405: error occured while trying to create connections in the pool
Cause: An internal error occured while creating connections in the pool.
Action: Contact customer support.
ORA-24406: API mode switch is disallowed when a call is in progress.
Cause: A mode switch from OCI8 to OCI7 was attempted in a callback.
Action: The user should perform the API mode switch either prior to initiating the top call or after the main call is done.
ORA-24407: connection pool already exists
Cause: A connection pool has already been created for the specified pool name.
Action: Specify a different pool name to create a new connection pool.
ORA-24408: could not generate unique server group name
Cause: An internal error occured while generating unique server group name.
Action: Contact customer support.
ORA-24409: client cannot understand the object
Cause: The client cannot process all the new features in the object.
Action: Upgrade the client so that features like inheritance and SQLJ objects can be used.
ORA-24410: scrollable cursor max size exceeded
Cause: Result set size exceeded the max limits.
Action: Check the documentation for allowable maximum result set size for scrollable cursors. Re-execute with a smaller expected result set size or make the cursor non-scrollable.
ORA-24411: Session pool already exists.
Cause: A session pool has already been created for the specified pool handle.
Action: 1) Specify a different pool handle to create a new session pool. 2) If you wish to modify the pool parameters, call OCISessionPoolCreate in OCI_SPOOL_REINITIALIZE mode.
ORA-24412: Cannot reinitialize non-existent pool
Cause: OCISessionPoolCreate was not called in OCI_DEFAULT mode for this pool handle.
Action: Create a session pool prior to reinitializing it.
ORA-24413: Invalid number of sessions specified
Cause: An invalid combination of minimum, maximum and increment number of sessions was specified in the OCISessionPoolCreate call.
Action: Specify a valid combination of parameters.
ORA-24414: Only number sessions could be started.
Cause: The number of sessions specified by the minSess parameter of OCISessionPoolCreate could not be started, possibly because the value supplied was larger than that supported by the server."
Action: This is a warning. Check the maximum number of sessions allowed on the server.
ORA-24415: Missing or null username.
Cause: Username and password must be specified when pool is created in this mode.
Action: Specify a valid username and password.
ORA-24416: Invalid session Poolname was specified.
Cause: An attempt was made to use a Session Pool that does not exist.
Action: Create a Session Pool before using it.
ORA-24417: Session pool size has exceeded the maximum limit
Cause: The number of sessions has exceeded the maximum size of the Session Pool.
Action: This is a warning. You can tune the session pool with appropriate minimum and maximum parameters.
ORA-24418: Cannot open further sessions.
Cause: Sufficient number of sessions are not present in the pool to execute the call. No new sessions can be opened as the sessMax parameter supplied in OCISessionPoolCreate has been reached.
Action: Call OCISessionPoolCreate in OCI_SPOOL_REINITIALIZE mode and increase the value of the sessMax parameter.
ORA-24419: Proxy sessions are not supported in this mode.
Cause: A proxy session was requested for from a Session Pool which does not support proxy sessions.
Action: Do not specify mode OCI_CRED_PROXY.
ORA-24420: OCISessionRelease must be used to release this session.
Cause: The session was retrieved using OCISessionGet, and an attempt has been made to release it using a call other than OCISessionRelease.
Action: Call OCISessionRelease.
ORA-24421: OCISessionRelease cannot be used to release this session.
Cause: The session was not retrieved using OCISessionGet, and an attempt has been made to release it using OCISessionRelease.
Action: Release the session using an appropriate call.
ORA-24422: error occurred while trying to destroy the Session Pool
Cause: An attempt was made to destroy the session pool while some sessions in the pool were busy.
Action: Ensure that no sessions from the pool are being used OR call OCISessionPoolDestroy with mode set to OCI_SPD_FORCE.
ORA-24430: Null values for sqltext and key were specified.
Cause: An attempt was made to call OCIStmtPrepare2 and neither sqltext nor key were specified.
Action: Specify valid values for sqltext or key or both.
ORA-24431: Statement does not exist in the cache
Cause: The statement that was requested for does not exist in the statement cache.
Action: Please request for a valid statement.
ORA-24432: The statement that was returned is not tagged.
Cause: A tagged statement was requested for, but an untagged statement has been returned.
Action: This is a warning. Please modify and tag the statement as desired.
ORA-24433: This statement has already been prepared using OCIStmtPrepare2.
Cause: A statement that was earlier prepared using OCIStmtPrepare2 is now being reprepared using OCIStmtPrepare."
Action: Please use a different statement handle.
ORA-24434: OCIStmtRelease called before OCIStmtPrepare2.
Cause: An attempt was made to release a statement without first preparing it using OCIStmtPrepare2.
Action: Call OCIStmtPrepare2 before OCIStmtRelease.
ORA-24435: Invalid Service Context specified.
Cause: The statement was prepared using a service context that is different from the one specified in OCIStmtExecute.
Action: Please specify the same service context that the statement was prepared with.
ORA-24436: Invalid statement Handle.
Cause: OCIHandleFree called on a statement that was prepared using OCIstmtPrepare2.
Action: Release the statement using OCIStmtRelease.
ORA-24437: OCIStmtExecute called before OCIStmtPrepare2.
Cause: An attempt was made to execute a statement without first preparing it using OCIStmtPrepare2.
Action: Call OCIStmtPrepare2 before OCIStmtExecute.
ORA-24438: Invalid Authentication Handle specified.
Cause: The statement was prepared using an authentication handle that is different from the one specified in OCIStmtExecute.
Action: none
ORA-24439: success with PLSQL compilation warning
Cause: A plsql compilation warning occurred.
Action: Return OCI_SUCCESS_WITH_INFO along with the error code.
ORA-24440: OCI Easy Install mode cannot be initialized
Cause: An internal OCI error has occurred.
Action: Please contact Oracle customer support.
ORA-24460: Native Net Internal Error
Cause: Internal error .
Action: This error should not normally occur. If it persists, please contact your customer service representative.
ORA-24500: invalid UTF16 mode
Cause: UTF16 mode is allowed only at environment handle creation time.
Action: Remove UTF16 mode for functions other than OCIEnvCreate()
ORA-24501: invalid UTF16 string passed in
Cause: Non-UTF16 string is passed in while UTF16 string is expected
Action: Check the parameter which is actually a string
ORA-24502: codepoint length overflows
Cause: Returned buffer has more codepoints than allowed
Action: Set OCI_MAXCHAR_SIZE large enough to accommodate
ORA-24503: codepoint length overflows for piecewise operation
Cause: Accumulated codepoint length exceeds allowed codepoint length
Action: Set OCI_MAXCHAR_SIZE large enough to accommodate
ORA-24504: data length larger than expected
Cause: Incoming data larger than receiving buffer
Action: Set OCI_MAXDATA/MAXCHAR_SIZE appropriately or remove the setting
ORA-24505: cannot change character set id on the handle
Cause: Attempts to change character set id on non-environment handles
Action: Only try to change character set id on environment handles
ORA-24506: invalid attempt to change character set id on env handle
Cause: Attempts to change character set id after other handles have been allocated from the env handle
Action: Change character set id after creating environment handle but before allocating any handles from it.
ORA-24507: invalid combination of character set ids
Cause: Attempts to set one character set id as zero
Action: Set both charset and ncharset as zero or non-zero in OCIEnvNlsCreate()
ORA-24508: Buffer is not aligned correctly.
Cause: Alignment error ocurred in buffer when converting between character sets.
Action: Align buffer appropriately. For UTF16 buffer, pass a ub2 pointer.
ORA-24750: incorrect size of attribute
Cause: Transaction ID attribute size is incorrect.
Action: Verify that the size parameter is correct.
ORA-24752: OCI_TRANS_NEW flag must be specified for local transactions
Cause: Application attempted to start a local transaction without using OCI_TRANS_NEW.
Action: Use OCI_TRANS_NEW when starting local transactions.
ORA-24753: local transactions cannot be detached
Cause: An attempt to detach a local transaction was made.
Action: Local transactions may only be committed or rolled back.
ORA-24754: cannot start new transaction with an active transaction
Cause: An attempt to start a new transaction was made when there was an active transaction.
Action: Commit, rollback or detach the existing transaction before starting a new transaction.
ORA-24755: OCI_TRANS_NOMIGRATE, OCI_TRANS_JOIN options are not supported
Cause: These flags are currently not supported.
Action: none
ORA-24756: transaction does not exist
Cause: An invalid transaction identifier or context was used or the transaction has completed.
Action: Supply a valid identifier if the transaction has not completed and retry the call.
ORA-24757: duplicate transaction identifier
Cause: An attempt was made to start a new transaction with an identifier already in use by an existing transaction.
Action: Verify that the identifier is not in use.
ORA-24758: not attached to the requested transaction
Cause: An attempt was made to detach or complete a transaction that is not the current transaction.
Action: Verify that the transaction context refers to the current transaction.
ORA-24759: invalid transaction start flags
Cause: An invalid transaction start flag was passed.
Action: Verify that one of the following values - OCI_TRANS_NEW, OCI_TRANS_JOIN, OCI_TRANS_RESUME was specified.
ORA-24760: invalid isolation level flags
Cause: An invalid isolation level flag was passed.
Action: Verify that only one of following values - OCI_TRANS_READONLY, OCI_TRANS_READWRITE, OCI_TRANS_SERIALIZABLE is used.
ORA-24762: server failed due to unspecified error
Cause: An internal error has occured in the server commit protocol.
Action: Contact customer support.
ORA-24763: transaction operation cannot be completed now
Cause: The commit or rollback cannot be performed now because the session cannot switch to the specified transaction.
Action: Retry the operation later.
ORA-24769: cannot forget an active transaction
Cause: Transaction identifier refers to an active transaction.
Action: Verify that the identifier of an active transaction was not passed as an argument.
ORA-24770: cannot forget a prepared transaction
Cause: Transaction identifier refers to a prepared transaction.
Action: Verify that the identifier of a prepared transaction was not passed as an argument.
ORA-24771: cannot detach, prepare or forget a local transaction
Cause: Service handle contains a local transaction context.
Action: Verify that the transaction context does not refer to a local transaction.
ORA-24772: Cannot mix tightly-coupled and loosely-coupled branches
Cause: Application attempted to start a transaction with a global transaction identifier and a wrong option.
Action: Verify that all branches of a global transaction are started with either OCI_TRANS_TIGHT or OCI_TRANS_LOOSE option. If the application is correct and uses distributed updates, contact customer support.
ORA-24773: invalid transaction type flags
Cause: OCI_TRANS_TIGHT or OCI_TRANS_LOOSE mode was not specified.
Action: Verify that the right parameters are being used.
ORA-24774: cannot switch to specified transaction
Cause: The transaction specified in the call refers to a transaction created by a different user.
Action: Create transactions with the same authentication so that they can be switched.
ORA-24775: cannot prepare or commit transaction with non-zero lock value
Cause: An attempt was made to detach the transaction with a non-zero lock value.
Action: Detach the transaction with lock value set to zero and then try to prepare or commit the transaction.
ORA-24776: cannot start a new transaction
Cause: An attempt was made to start a new transaction when session was already attached to an existing transaction.
Action: End the current transaction before creating a new transaction.
ORA-24777: use of non-migratable database link not allowed
Cause: The transaction, which needs to be migratable between sessions, tried to access a remote database from a non-multi threaded server process.
Action: Perform the work in the local database or open a connection to the remote database from the client. If multi threaded server option is installed, connect to the Oracle instance through the dispatcher.
ORA-24778: cannot open connections
Cause: The migratable transaction tried to access a remote database when the session itself had opened connections to remote database(s).
Action: Close the connection(s) in the session and then try to access the remote database from the migratable transaction. If the error still occurs, contact Oracle customer support.
ORA-24779: detach not allowed with open remote cursor
Cause: The migratable transaction tried to detach from the current session while having an open remote cursor.
Action: Close any open remote cursor prior to detach.
ORA-24780: cannot recover a transaction while in an existing transaction
Cause: An attempt was made to commit or roll back a transaction while in a different transaction, and the transaction for which the action is requested is in a recovery state (this happens if it is idle too long).
Action: Detach from the current transaction and retry the operation.
ORA-24781: branches don't belong to the same global transaction
Cause: The list of xids passed into kpotxmp() don't have the same gtrid
Action: none
ORA-24782: Cannot detach from a non-migratable transaction
Cause: An attempt was made to detach from a non-migrateable transaction.
Action: Either commit or rollback the transaction.
ORA-24783: Cannot switch non-migratable transactions
Cause: An attempt was made to prepare/commit a txn different from current.
Action: none
ORA-24784: Transaction exists
Cause: An attempt was made to start a transaction, while attached to a non-migrateable transaction
Action: none
ORA-24785: Cannot resume a non-migratable transaction
Cause: An attempt was made to resume a non-migrateable transaction.
Action: none
ORA-24786: separated transaction has been completed
Cause: The current transaction has been completed by another process.
Action: Start a new transaction
ORA-24787: remote cursors must be closed before a call completes
Cause: The previous operation did not close all the remote cursors it opened. Since separated transactions are enabled, this is not allowed.
Action: Close all remote cursors in each call, or start a regular (non-separated) transaction.
ORA-24788: cannot switch to specified transaction (server type)
Cause: The transaction specified was created by a shared server and the requestor is a dedicated server, or the transaction was created by a dedicated server and the requestor is a shared server.
Action: All parts of this application should connect as dedicated or as shared.
ORA-24790: cannot mix OCI_TRANS_RESUME and transaction isolation flags
Cause: An attempt was made to change the isolation level of an existing transaction.
Action: No action required
ORA-24791: invalid transaction start flags
Cause: An invalid transaction start flag was passed.
Action: Verify that OCI_TRANS_LOOSE was not passed along with OCI_TRANS_JOIN, OCI_TRANS_RESUME.
ORA-24801: illegal parameter value in OCI lob function
Cause: One of the parameter values in the OCI lob function is illegal.
Action: Check every parameter in the OCI Lob function call to make sure they are correct. Offsets should be greater than or equal to one.
ORA-24802: user defined lob read callback error
Cause: The only valid return value for a user defined lob read callback function is OCI_CONTINUE. Any other value will cause this error.
Action: Verify that OCI_CONTINUE is returned from the user defined lob read callback function.
ORA-24803: illegal parameter value in lob read function
Cause: Internal error .
Action: This error should not normally occur. If it persists, please contact your customer service representative.
ORA-24804: Lob read/write functions called while another OCI LOB read/write streaming is in progress
Cause: Internal error.
Action: Wait for the ongoing LOB streaming call to finish before issuing the next server call, or use OCIBreak() abort the current LOB streaming call.
ORA-24805: LOB type mismatch
Cause: When copying or appending LOB locators, both source and desctination LOB locators should be of the same type.
Action: Pass the same type of LOB locators for copying or appending.
ORA-24806: LOB form mismatch
Cause: When reading from or writing into LOBs, the character set form of the user buffer should be same as that of the LOB.
Action: Make sure that the buffer you are using to read or write has the same form as that of the LOB.
ORA-24807: LOB form mismatch
Cause: When copying or appending LOBs, both source and desctination LOB locators should have the same character set form.
Action: Pass locators of the same character set form for copying or appending LOBs.
ORA-24808: streaming of lob data is not allowed when using lob buffering
Cause: Attempted to stream lob data via the polling mode or a callback when lob buffering was enabled for the input lob locator.
Action: Lob buffering is useful when reading/writing small amounts of lob data so streaming should not be necessary. Rewrite the OCILobRead/OCILobWrite call so that it does not use streaming. If streaming of data is required, lob buffering should not be used. In this case, flush buffers associated with the input lob locator as necessary, disable buffering on the input lob locator and reissue the OCILobRead/OCILobWrite call.
ORA-24809: amount specified will not fit in the lob buffers
Cause: LOB buffering is enabled for the input lob locator so buffering will be used. However, the amount of lob data to read or write is larger than what the lob buffers can hold.
Action: Either disable buffering on the input lob locator and reissue the command or pass a smaller amount.
ORA-24810: attempting to write more data than indicated
Cause: While writing into a LOB, more data was supplied than indicated.
Action: If data is written in pieces, then make sure that you do not provide more data in the pieces (cumulatively), than you indicated.
ORA-24811: less data provided for writing than indicated
Cause: While writing into a LOB, less data was provided than indicated.
Action: If writing data in single pieces, then make sure that the buffer length specified is big enough to accommodate tha data being provided. If data is written in pieces, then make sure that all the data has been provided before specifying OCI_LAST_PIECE.
ORA-24812: character set conversion to or from UCS2 failed
Cause: If the database character set is varying-width, the CLOB/NCLOB value is implicitly converted to or from UCS2. This implicit conversion failed.
Action: Contact Oracle Worldwide Support.
ORA-24813: cannot send or receive an unsupported LOB
Cause: An attempt was made to send a LOB across the network, but either the server does not support the LOB sent by the client, or the client does not support the LOB sent by the server. This error usually occurs when the client and server are running different versions of Oracle.
Action: Use a version of the Oracle that supports the LOB on both the client and the server.
ORA-24814: operation not allowed for temporary LOBs
Cause: Temporary LOB locators are not allowed in the operation. For example: OCILobAssign only takes persistent LOB locators as parameters, not temporary LOBs.
Action: Use OCILobLocatorAssign for temporary LOBs instead. Note that OCILobLocatorAssign can also be used for persistent LOBs, in which case it will behave the same as OCILobAssign.
ORA-24815: Invalid character set form
Cause: An invalid character set form was passed into an OCI LOB function. For example, the only valid cs form for OCILobCreateTemporary() is OCI_DEFAULT(0), SQLCS_IMPLICIT(1) or SQLCS_NCHAR(2).
Action: Specify a valid character set form.
ORA-24816: Expanded non LONG bind data supplied after actual LONG or LOB column
Cause: A Bind value of length potentially > 4000 bytes follows binding for LOB or LONG.
Action: Re-order the binds so that the LONG bind or LOB binds are all at the end of the bind list.
ORA-24850: failed to startup shared subsystem
Cause: While attempting to initialize OCI in shared mode, a problem was encountered in starting up the shared subsystem.
Action: Contact Oracle Customer support.
ORA-24851: failed to connect to shared subsystem
Cause: While attempting to initialize OCI in shared mode, a problem was encountered in connecting the process to the shared subsystem.
Action: Contact Oracle Customer Support.
ORA-24852: protocol error during statement execution
Cause: An internal protocol error occurred while receiving describe data from the server during execution of a statement.
Action: Contact Oracle Customer Support.
ORA-24853: failed to connect thread to shared subsystem
Cause: While attempting to initialize OCI in shared mode, a problem was encountered in connecting the thread to the shared subsystem.
Action: Contact Oracle Customer Support.
ORA-24900: invalid or unsupported mode paramater passed in call
Cause: The mode parameter passed into the OCI Client Notification call is incorrect.
Action: Please correct the mode parameter passed into OCI.
ORA-24901: handles belonging to different environments passed into an OCI call
Cause: All handles passed into an OCI call should belong to the same environment. In the call that returned this error, handles belonging to different environments were passed in.
Action: Please ensure that the handle parameters in the call to come from the same OCI Environment.
ORA-24902: invalid subscription name or name-length in subscription handle
Cause: The subscription handle passed into the OCI call does not have a proper name or name-length attribute.
Action: Please set the name and name-length attributes using the OCIAttrSet() call.
ORA-24903: invalid namespace attribute passed into OCI call
Cause: The subscription handle passed into the OCI call does not have a proper namespace attribute.
Action: Please set the namespace attribute using the OCIAttrSet() call.
ORA-24904: invalid callback attribute passed into OCI call
Cause: The subscription handle passed into the OCI call does not have a proper callback attribute.
Action: Please set the callback attribute using the OCIAttrSet() call.
ORA-24905: invalid recepient protocol attribute passed into OCI call
Cause: The subscription handle passed into the OCI call does not have a proper recepient protocol attribute.
Action: Please set the recepient protocol attribute using the OCIAttrSet() call.
ORA-24906: invalid recepient attribute passed into OCI call
Cause: The subscription handle passed into the OCI call does not have a proper recepient attribute.
Action: Please set the recepient attribute using the OCIAttrSet() call.
ORA-24907: invalid pair of callback and recepient protocol attributes
Cause: The subscription handle passed into the OCI call can't have both the callback defined and a recepient protocol other than OCI_SUBSCR_PROTO_OCI at the same time.
Action: Please set the appropriate callback and recepient protocol attributes using the OCIAttrSet() call.
ORA-24908: invalid recipient presentation attribute
Cause: The subscription handle passed into the OCI call does not have a valid recipient presentation attribute.
Action: Set the recipient presentation attribute using the OCIAttrSet() call
ORA-24909: call in progress. Current operation cancelled
Cause: The OCI call was invoked when another call on the connection was in progress.
Action: Check if the OCI call is supported when the call is in progress under special conditions; for example, if it is being used by a signal handler.
ORA-24950: unregister failed, registeration not found
Cause: The registeration that was asked to be unregistered could not be found.
Action: Please check the callback function name and the subscription name in the unregister call.
ORA-24960: the attribute string is greater than the maximum allowable length of number
Cause: The user attempted to pass an attribute that is too long
Action: Shorten the specified attribute and retry the operation.
ORA-25000: invalid use of bind variable in trigger WHEN clause
Cause: A bind variable was used in the when clause of a trigger.
Action: Remove the bind variable. To access the table columns use (new/old).column_name.
ORA-25001: cannot create this trigger type on views
Cause: Only INSTEAD OF triggers can be created on a view.
Action: Change the trigger type to INSTEAD OF.
ORA-25002: cannot create INSTEAD OF triggers on tables
Cause: Only BEFORE or AFTER triggers can be created on a table.
Action: Change the trigger type to BEFORE or AFTER.
ORA-25003: cannot change NEW values for this column type in trigger
Cause: Attempt to change NEW trigger variables of datatype object, REF, nested table, VARRAY or LOB datatype which is not supported.
Action: Do not change the NEW trigger variables in the trigger body.
ORA-25004: WHEN clause is not allowed in INSTEAD OF triggers
Cause: WHEN clause is specified in an INSTEAD OF trigger.
Action: Remove the WHEN clause when creating an INSTEAD OF trigger.
ORA-25005: cannot CREATE INSTEAD OF trigger on a read-only view
Cause: attempt to create an INSTEAD OF trigger on a view created with read-only option. The view cannot be updated using INSTEAD OF triggers.
Action: Do not create the trigger.
ORA-25006: cannot specify this column in UPDATE OF clause
Cause: Attempt to create a trigger on update of a column whose datatype is disallowed in the clause, such as LOB and nested table.
Action: Remove the UPDATE OF clause.
ORA-25007: functions or methods not allowed in WHEN clause
Cause: PLSQL function call or method invocation is not allowed in the WHEN clause when creating a trigger.
Action: Remove the function call or method invocation from the WHEN clause.
ORA-25008: no implicit conversion to LOB datatype in instead-of trigger
Cause: When inserting or updating a view using instead-of trigger, the new value for a LOB view column is of a different datatype.
Action: Specified a LOB value as the new value for the LOB view column.
ORA-25009: Nested table clause allowed only for INSTEAD OF triggers
Cause: Triggers on nested tables can only be created on view columns using INSTEAD OF triggers.
Action: Use view nested table columns for defining nested table triggers.
ORA-25010: Invalid nested table column name in nested table clause
Cause: The column name specified in the nested table clause of an INSTEAD OF trigger does not correspond to a nested table column.
Action: Specify a nested table column on which the trigger is to be defined.
ORA-25012: PARENT and NEW values cannot be identical
Cause: The referencing clause specifies identical values for PARENT and OLD.
Action: Re-specify either the PARENT or NEW referencing value.
ORA-25013: OLD and PARENT values cannot be identical
Cause: The referencing clause specifies identical values for OLD and PARENT.
Action: Re-specify either the OLD or PARENT referencing value.
ORA-25014: cannot change the value of a PARENT reference variable
Cause: Parent values can only be read and not changed.
Action: Do not attempt to change a Parent variable.
ORA-25015: cannot perform DML on this nested table view column
Cause: DML cannot be performed on a nested table view column except through an INSTEAD OF trigger
Action: Create an INSTEAD OF trigger over the nested table view column and then perform the DML.
ORA-25016: cannot specify column list for insert into nested table view column
Cause: A column list cannot be specified for inserts into the nested table view column.
Action: Specify all the columns for insert into the nested table.
ORA-25017: cannot reference NEW ROWID for movable rows in before triggers
Cause: NEW ROWID was referenced in a before row trigger which is defined on an index-organized table, or a partitioned table with enabled movement of rows. The ROWID cannot be computed in a before row update trigger because it depends on the actual values of the row
Action: Remove references to NEW ROWID from the trigger definition.
ORA-25018: conflicting trigger string already exists
Cause: Conflicting instead of DDL trigger on schema/database already exists.
Action: Remove the old trigger
ORA-25019: too much concurreny
Cause: cannot pin the database/schema because of too much concurrency
Action: try the operation later
ORA-25020: renaming system triggers is not allowed
Cause: renaming system triggers is not allowed
Action: Drop the trigger, and create a new one for the same
ORA-25100: TABLESPACE option can only be used with ALTER INDEX REBUILD
Cause: The TABLESPACE option to ALTER INDEX was used without the REBUILD option.
Action: Use ALTER INDEX REBUILD TABLESPACE tablespace name.
ORA-25101: duplicate REBUILD option specification
Cause: The REBUILD option to ALTER INDEX is specified more than once.
Action: Specify the option at most once.
ORA-25102: PARALLEL option can only be used with ALTER INDEX REBUILD
Cause: The PARALLEL option to ALTER INDEX was used without the REBUILD option.
Action: Use ALTER INDEX REBUILD.
ORA-25103: NOPARALLEL option can only be used with ALTER INDEX REBUILD
Cause: The NOPARALLEL option to ALTER INDEX was used without the REBUILD option.
Action: Use ALTER INDEX REBUILD.
ORA-25104: UNRECOVERABLE option can only be used with ALTER INDEX REBUILD
Cause: The UNRECOVERABLE option to ALTER INDEX was used without the REBUILD option.
Action: Use ALTER INDEX REBUILD.
ORA-25105: RECOVERABLE option can only be used with ALTER INDEX REBUILD
Cause: The RECOVERABLE option to ALTER INDEX was used without the REBUILD option.
Action: Use ALTER INDEX REBUILD.
ORA-25106: only one of PARALLEL or NOPARALLEL clause may be specified
Cause: PARALLEL was specified more than once, NOPARALLEL was specified more than once, or both PARALLEL and NOPARALLEL were specified in an ALTER INDEX REBUILD statement.
Action: Remove all but one of the PARALLEL or NOPARALLEL clauses.
ORA-25107: duplicate TABLESPACE option specification
Cause: the TABLESPACE was specified more than once in an ALTER INDEX REBUILD statement.
Action: Remove all but one of the TABLESPACE clauses.
ORA-25108: standby lock name space exceeds size limit of string characters
Cause: The lock name space for the standby database exceeded the maximum string length.
Action: Change initialization parameter _STANDBY_LOCK_NAME_SPACE to a character string of less than the specified characters.
ORA-25109: standby lock name space has illegal character 'string'
Cause: An invalid lock name space was specified for the standby database. The lock name space for the standby database can only contain A-Z, 0-9, '_', '#', '$', '.' and '@' characters.
Action: Change initialization parameter _STANDBY_LOCK_NAME_SPACE to a valid character string.
ORA-25110: NOSORT may not be used with a bitmap index
Cause: An attempt was made to create a bitmap index using the NOSORT option.
Action: Remove NOSORT from the CREATE BITMAP INDEX statement.
ORA-25111: creation of BITMAP cluster indices is not supported
Cause: An attempt was made to create a cluster index with the BITMAP attribute.
Action: Remove BITMAP from the CREATE INDEX statement.
ORA-25112: maximum number of BITMAP index columns is 30
Cause: Too many columns were specified for the index.
Action: Create an index on fewer columns.
ORA-25113: GLOBAL may not be used with a bitmap index
Cause: An attempt was made to create a bitmap index using the GLOBAL option.
Action: Remove GLOBAL from the CREATE BITMAP INDEX statement, and/or add a LOCAL partition descriptor if the table is partitioned.
ORA-25114: invalid file number specified in the DUMP DATAFILE/TEMPFILE command
Cause: An invalid file number was used in dumping a datafile or tempfile.
Action: Specify a valid file number.
ORA-25115: duplicate BLOCK option specification
Cause: BLOCK (MIN/MAX) was specified more than once in the DUMP DATAFILE/TEMPFILE command.
Action: Specify only one BLOCK option.
ORA-25116: invalid block number specified in the DUMP DATAFILE/TEMPFILE command
Cause: An invalid block number was used in dumping a datafile or tempfile.
Action: Specify a valid block number.
ORA-25117: MIN/MAX/Block Number expected
Cause: A value other than MIN/MAX, or a block number was entered in the DUMP DATAFILE/TEMPFILE command.
Action: Correct the syntax.
ORA-25118: invalid DUMP DATAFILE/TEMPFILE option
Cause: An invalid option was specified for the DUMP DATAFILE/TEMPFILE command.
Action: Correct the syntax.
ORA-25119: LOGGING/NOLOGGING option already specified
Cause: In CREATE TABLESPACE, the LOGGING and/or NOLOGGING options were specified more than once.
Action: Remove all but one of the logging specifications.
ORA-25120: MINIMUM EXTENT option already specified
Cause: In CREATE TABLESPACE, the MINIMUM EXTENT option was specified more than once.
Action: Remove all but one of the MINIMUM EXTENT specifications.
ORA-25121: MINIMUM EXTENT value greater than maximum extent size
Cause: In CREATE/ALTER TABLESPACE, the value specified for the MINIMUM EXTENT option was greater than the maximum extent size.
Action: Choose a lower value for the MINIMUM EXTENT option.
ORA-25122: Only LOCAL bitmap indexes are permitted on partitioned tables
Cause: An attempt was made to create a global bitmap index on a partioned table.
Action: create a local bitmap index instead.
ORA-25123: Too many components specified in the name.
Cause: Specifying more components to a name than allowed.
Action: Check the name specified for the operation.
ORA-25124: Database link name not allowed.
Cause: Specifying a database link name when it is not permitted.
Action: Check the name specified for the operation.
ORA-25125: BUFFER_POOL storage option not allowed
Cause: The user attempted to specify the BUFFER_POOL storage option. This option may only be specified during CREATE/ALTER TABLE/CLUSTER/INDEX.
Action: Remove this option and retry the statement.
ORA-25126: Invalid name specified for BUFFER_POOL
Cause: The name of the buffer pool specified by the user is invalid. The only valid names are KEEP, RECYCLE and DEFAULT.
Action: Use a valid name or remove the BUFFER_POOL clause.
ORA-25127: RELY not allowed in NOT NULL constraint
Cause: An attempt to set RELY on for NOT NULL constraint.
Action: only NORELY may be specified for a NOT NULL constraint.
ORA-25128: No insert/update/delete on table with constraint (string.string) disabled and validated
Cause: Try to insert/update/delete on table with DISABLE VALIDATE constraint.
Action: Change the constraint's states.
ORA-25129: cannot modify constraint (string) - no such constraint
Cause: the named constraint does not exist for this table.
Action: Obvious
ORA-25130: cannot modify primary key - primary key not defined for table
Cause: Attempted to modify a primary key that is not defined for the table.
Action: None
ORA-25131: cannot modify unique(string) - unique key not defined for table
Cause: attempted to modify a unique key that is not deined for the table.
Action: None
ORA-25132: UNIQUE constraint (string.string) disabled and validated in ALTER TABLE EXCHANGE PARTITION
Cause: cannot ALTER TABLE EXCHANGE PARTITION when the partition and the table have a disabled and validated unique constraints AND the unique keys in the partion is not mutually exclusive from the rest of the table.
Action: Change the constraint's status.
ORA-25133: duplicate SINGLE TABLE option specified
Cause: The SINGLE TABLE option was specified more than once.
Action: Specify the SINGLE TABLE option only once.
ORA-25134: keyword TABLE expected
Cause: The keyword TABLE is missing from the SINGLE TABLE option.
Action: Place the keyword TABLE after the keyword SINGLE in the command.
ORA-25135: cannot use the SINGLE TABLE option
Cause: The SINGLE TABLE option is only valid for hash clusters.
Action: Do not specify the SINGLE TABLE option.
ORA-25136: this cluster can contain only one table
Cause: An attempt was made to store more than one table in a cluster that was created with the SINGLE TABLE option.
Action: Do not attempt to store more than one table in the cluster.
ORA-25137: Data value out of range
Cause: Value from cast operand is larger than cast target size.
Action: Increase size of cast target.
ORA-25138: %s initialization parameter has been made obsolete
Cause: An obsolete initialization parameter has been specified
Action: The system will come up, but parameters must be examined
ORA-25139: invalid option for CREATE TEMPORARY TABLESPACE
Cause: An invalid option appears.
Action: Specify one of the valid options: TEMPFILE, EXTENT MANAGEMENT LOCAL, UNIFORM
ORA-25140: %s space policy cannot be specified for the string extent management
Cause: An invalid option appears.
Action: Make sure that for LOCAL extent management UNIFORM or AUTOALLOCATE is specified, and for DICTIONARY extent management UNIFORM or AUTOALLOCATE are not specified
ORA-25141: invalid EXTENT MANAGEMENT clause
Cause: An invalid option appears for EXTENT MANAGEMENT clause
Action: Specify one of the valid options: UNIFORM SIZE, AUTOALLOCATE
ORA-25142: default storage clause specified twice
Cause: default storage clause was specified twice for create tablespace
Action: Specify it once.
ORA-25143: default storage clause is not compatible with allocation policy
Cause: default storage clause was specified for a tablespace with AUTOALLOCATE or UNIFORM policy
Action: Omit the storage clause
ORA-25144: invalid option for CREATE TABLESPACE with TEMPORARY contents
Cause: An invalid option appears.
Action: Specify one of the valid options: EXTENT MANAGEMENT DICTIONARY, USER
ORA-25145: allocation policy already specified
Cause: In CREATE TABLESPACE, the allocation policy was specified more than once, for example, AUTOALLOCATE and UNIFORM.
Action: Remove all but one of the allocation policy specifications.
ORA-25146: EXTENT MANAGEMENT option already specified
Cause: In CREATE TABLESPACE, the EXTENT MANAGEMENT option was specified more than once.
Action: Remove all but one of the EXTENT MANAGEMENT specifications.
ORA-25147: UNIFORM SIZE value greater than maximum extent size
Cause: In CREATE/ALTER TABLESPACE, the value specified for the UNIFORM SIZE option was greater than the maximum extent size.
Action: Choose a lower value for the UNIFORM SIZE option.
ORA-25148: ONLINE option not permitted
Cause: An attempt was made to specify ONLINE for ALTER TABLE MOVE on a table that is not index-organized. The ONLINE option is currently supported only for index-organized tables.
Action: Remove the ONLINE option from the command.
ORA-25149: Columns of UROWID type may not be indexed
Cause: An attempt was made to create an index on a column of UROWID type
Action: Remove the column from the list of indexed columns
ORA-25150: ALTERING of extent parameters not permitted
Cause: An attempt was made to alter the extent parameters for a segment in a tablespace with autoallocate or uniform extent allocation policy.
Action: Remove the appropriate extent parameters from the command.
ORA-25151: Rollback Segment cannot be created in this tablespace
Cause: An attempt was made to create a rollback segment in a tablespace with autoallocate extent allocation policy.
Action: Specify a different tablespace for the rollback segment
ORA-25152: TEMPFILE cannot be dropped at this time
Cause: An attempt was made to drop a TEMPFILE being used by online users
Action: The TEMPFILE has been taken offline. Try again, later.
ORA-25153: Temporary Tablespace is Empty
Cause: An attempt was made to use space in a temporary tablespace with no files.
Action: Add files to the tablespace using ADD TEMPFILE command.
ORA-25154: column part of USING clause cannot have qualifier
Cause: Columns that are used for a named-join (either a NATURAL join or a join with a USING clause) cannot have an explicit qualifier.
Action: Remove the qualifier.
ORA-25155: column used in NATURAL join cannot have qualifier
Cause: Columns that are used for a named-join (either a NATURAL join or a join with a USING clause) cannot have an explicit qualifier.
Action: Remove the qualifier.
ORA-25156: old style outer join (+) cannot be used with ANSI joins
Cause: When a query block uses ANSI style joins, the old notation for specifying outer joins (+) cannot be used.
Action: Use ANSI style for specifying outer joins also.
ORA-25157: Specified block size string is not valid
Cause: An attempt was made to create a tablespace with a block size which is not supported.
Action: Specify one of the valid blocksizes i.e the standard blocksize or one of (2k, 4k, 8k, 16k, 32k) subject to the maximum and minimum blocksizes supported by the platform.
ORA-25158: Cannot specify RELY for foreign key if the associated primary key is NORELY
Cause: RELY is specified for the foreign key contraint, when the associated primary key constraint is NORELY.
Action: Change the option of the primary key also to RELY.
ORA-25175: no PRIMARY KEY constraint found
Cause: A PRIMARY KEY constraint must be defined for a table with this organization
Action: Define a PRIMARY KEY
ORA-25176: storage specification not permitted for primary key
Cause: Storage parameters cannot be defined for a PRIMARY KEY constraint for a table with this organization
Action: Remove storage specification for primary key
ORA-25177: UNRECOVERABLE option not permitted
Cause: The UNRECOVERABLE option may not be specified for a primary key for a table with this organization
Action: Remove UNRECOVERABLE option for primary key
ORA-25178: duplicate PCTTHRESHOLD storage option specification
Cause: The storage option PCTTHRESHOLD is specified more than once.
Action: Specify storage options at most once.
ORA-25179: invalid PCTTHRESHOLD storage option value
Cause: The specified value must be a positive integer.
Action: Specify an appropriate value.
ORA-25180: PCTTHRESHOLD only valid for certain table organizations
Cause: PCTTHRESHOLD can only be specified for tables with certain organizations.
Action: Remove the PCTTHRESHOLD option.
ORA-25181: missing ON keyword for NESTED INDEX
Cause: ON keyword required to specify nested index column nest
Action: Add ON keyword
ORA-25182: feature not currently available for index-organized tables
Cause: An attempt was made to use one or more of the following feature(s) not currently supported for index-organized tables: CREATE TABLE with LOB/BFILE/VARRAY columns, partitioning/PARALLEL/CREATE TABLE AS SELECT options, ALTER TABLE with ADD/MODIFY column options, CREATE INDEX
Action: Do not use the disallowed feature(s) in this release.
ORA-25183: index-organized table top index segment is in a different tablespace
Cause: An attempt was made to drop a tablespace which contains an index only table's overflow segment but not the top index segment"
Action: find index-organized tables which span the tablespace being dropped and some other tablespace(s). Drop these tables.
ORA-25184: column name expected
Cause: A column name is not present where required by the CREATE TABLE for specifying last column to be included in the index segment of the index-organized table
Action: Specify a column name where required by the syntax.
ORA-25185: index column other than last can not be specified for INCLUDE clause
Cause: An index column name other than the last is specified as including column
Action: Specify either a column name which is not part of index-organized table primary key index , or the last key column of the primary key for the INCLUDING clause.
ORA-25186: INCLUDING clause specified for index-organized table without OVERFLOW
Cause: INCLUDING clause of a CREATE TABLE is an valid option only for index-organized tables with OVERFLOW clause (at creation time) or if an OVERFLOW segment already exists (at ALTER time).
Action: Specify OVERFLOW clause for the index-organized table : For ALTER, perform ADD OVERFLOW first.
ORA-25187: specified exceptions table form incorrect
Cause: The specified table does not have the proper field definitions.
Action: Specify the correct table to use.
ORA-25189: illegal ALTER TABLE option for an index-organized table
Cause: During ALTER of a index-organized table, the user attempted to enter one or more of the following options: TABLESPACE, ALLOCATE/DEALLOCATE EXTENT, PCTFREE/PCTUSED for IOT top index segment
Action: Remove the illegal option(s).
ORA-25190: an index-organized table maintenance operation may not be combined with other operations
Cause: ALTER TABLE statement attempted to combine an index-organized table maintenance operation (e.g. changing physical attributes) with some other operation (e.g. ADD constraint) which is illegal
Action: Ensure that a index-organized table maintenance operation is the sole operation specified in ALTER TABLE statement;
ORA-25191: cannot reference overflow table of an index-organized table
Cause: An attempt to directly access the overflow table of an index-organized table
Action: Issue the statement against the parent index-organized table containing the specified overflow table.
ORA-25192: invalid option for an index-organized table
Cause: An attempt to specify one or more of the following options for an index-organized table: [NO]CACHE, NO LOGGING, CLUSTER
Action: Remove the illegal option(s)
ORA-25193: cannot use COMPRESS option for a single column key
Cause: An attempt to use COMPRESS option on single column key
Action: Remove the COMPRESS option.
ORA-25194: invalid COMPRESS prefix length value
Cause: The specified value must be a positive integer less than the number of key columns
Action: Specify an appropriate value.
ORA-25195: invalid option for index on an index-organized table
Cause: An attempt to specify one or more of the following options for index on an IOT: BITMAP, REVERSE, PCTUSED
Action: none
ORA-25196: keyword MOVE in ALTER TABLE MOVE must immediately follow <table name>
Cause: MOVE specified after one/more other ALTER options
Action: Remove the illegal option(s)
ORA-25197: an overflow segment already exists for the indexed-organized table
Cause: An attempt was made to ADD OVERFLOW segment on an index-organized table that already has an overflow segment
Action: none
ORA-25198: only range, list, and hash partitioning are supported for index-organized table
Cause: System, or Composite partitioning schemes are not supported yet
Action: Select a different partitioning scheme
ORA-25199: partitioning key of a index-organized table must be a subset of the primary key
Cause: An attempt to specify a partitioning key which is not a prefix of the primary key of the index-organized table
Action: Select a different partitioning key
ORA-25200: invalid value string, QUEUE_NAME should be [SCHEMA.]NAME
Cause: A NULL parameter was specified for QUEUE_NAME.
Action: Specify a non-NULL queue name.
ORA-25201: invalid value, VISIBILITY should be ON_COMMIT or IMMEDIATE
Cause: An invalid value specified for parameter VISIBILITY.
Action: Specify either ON_COMMIT or IMMEDIATE.
ORA-25202: invalid value NULL, string should be non-NULL
Cause: A NULL value was specified for the parameter.
Action: Specify a non-NULL value.
ORA-25203: invalid value string, DELAY should be non-negative
Cause: A negative value or NULL was specified for DELAY.
Action: Specify a non negative integer for DELAY.
ORA-25204: invalid value, SEQUENCE_DEVIATION should be BEFORE or TOP
Cause: An invalid SEQUENCE_DEVIATION was specified.
Action: Specify either the option 'BEFORE' or 'TOP'.
ORA-25205: the QUEUE string.string does not exist
Cause: The specified queue does not exist.
Action: Create the queue first before specifying it for enqueue or dequeue.
ORA-25206: enqueue failed, enqueue to exception queue string.string not permitted
Cause: An attempt was made to enqueue to an exception queue.
Action: Try enqueueing to another queue.
ORA-25207: enqueue failed, queue string.string is disabled from enqueueing
Cause: The queue has been stopped to prevent any further enqueueing.
Action: Enable the queue first by using an administrative operation.
ORA-25208: RELATIVE_MSGID must be specified if SEQUENCE_DEVIATION is BEFORE
Cause: A relative message identifier should be specified if sequence deviation is specified as BEFORE.
Action: Either specify an existing relative message identifier or don't specify sequence deviation as BEFORE.
ORA-25209: invalid value string, EXPIRATION should be non-negative or NEVER
Cause: The expiration is less than zero or NULL.
Action: Specify a valid value for expire_after which should be greater than or equal to zero or NEVER.
ORA-25210: invalid value for RELATIVE_MSGID, no message in queue with that msgid
Cause: No message inm the queue with the msgid equal to the specified RELATIVE_MSGID.
Action: Try again with a valid RELATIVE_MSGID.
ORA-25211: invalid DELAY specified when using sequence deviation
Cause: The DELAY specified in the enqueue is greater than the delay of the message with the given relative message id.
Action: Set the DELAY to be less than or equal to the delay of the message with the given relative message id. If the TOP option is used the delay must be less than or equal to the delay of all the messages in the queue.
ORA-25212: invalid PRIORITY specified when using sequence deviation
Cause: The PRIORITY specified in the enqueue is less than the priority of the message with the given relative message id.
Action: Set the PRIORITY to be less than the delay of the message with the given relative message id. If the TOP option is used the prioirty must be greater than or equal to the priority of all the messages in the queue.
ORA-25213: message with specified RELATIVE_MSGID has been dequeued
Cause: The message specified by the RELATIVE_MSGID field in the sequence deviation BEFORE option has been dequeued.
Action: none
ORA-25214: cannot specify delay or expiration for enqueue to exception queue
Cause: A message was enqueued to the exception queue with either delay or expiration specified.
Action: Enqueue a message without delay or expiration.
ORA-25215: user_data type and queue type do not match
Cause: A user tries to enqueue an object to a queue that was created for objects of different type.
Action: Try enqueue again with an object of the right type.
ORA-25216: invalid recipient, either NAME or ADDRESS must be specified
Cause: Both attributes, NAME and ADDRESS, were specified null for one of the recipients in the recipient list.
Action: Specify a non-null NAME or ADDRESS for the recipient.
ORA-25217: enqueue failed, visibility must be IMMEDIATE for queue string.string
Cause: An attempt was made to enqueue to a non-persistent queue without setting visibility to IMMEDIATE.
Action: Set visibility to IMMEDIATE.
ORA-25218: enqueue failed, delay must be zero for queue string.string
Cause: An attempt was made to enqueue to a non-persistent queue with delay greater than zero seconds.
Action: Set delay to zero.
ORA-25219: enqueue failed, sequence deviation not allowed for queue string.string
Cause: An attempt was made to enqueue to a non-persistent queue with sequence deviation specified.
Action: Do not specify sequence deviation.
ORA-25220: enqueue failed, signature not specified for a non-repudiable queue
Cause: An attempt was made to enqueue to a non-repudiable queue without specifying the signature
Action: Give the signature
ORA-25221: enqueue failed, signature specified queue not supporting non-repudiation
Cause: An attempt was made to enqueue to a queue specifying the signature for a queue not supporting non-repudiation
Action: Remove the signature
ORA-25222: enqueue failed, complete sender info. not provided for a queue supporting non-repudiation
Cause: An attempt was made to enqueue to a queue without giving the complete sender information (name) for a queue supporting non-repudiation
Action: Provide the sender information
ORA-25223: user_data type used is not supported
Cause: An attempt was made to enqueue data into a non persistent queue that is of a type other than the supported raw or object type.
Action: Enqueue the message again with data of raw or object type.
ORA-25224: sender name must be specified for enqueue into secure queues
Cause: An attempt was made to enqueue into a secure queue without specifying a sender name.
Action: Enqueue the message with sender name specified.
ORA-25225: invalid value string, DEQUEUE_MODE should be REMOVE or BROWSE or LOCKED
Cause: An invalid parameter has been specified for DEQUEUE_MODE.
Action: Specify either REMOVE, BROWSE or LOCKED.
ORA-25226: dequeue failed, queue string.string is not enabled for dequeue
Cause: The queue has not been enabled for dequeue.
Action: Enable the queue using START_QUEUE.
ORA-25228: timeout or end-of-fetch during message dequeue from string.string
Cause: User-specified dequeue wait time has passed or the end of the queue has been reached but no message has been retrieved.
Action: Try dequeue again with the appropriate WAIT_TIME or the FIRST_MESSAGE option.
ORA-25229: error on transformation of message string string
Cause: There was an error when transforming a message at enqueue, dequeue or propagation time.
Action: Correct the transformation function.
ORA-25230: invalid value string, WAIT should be non-negative
Cause: A negative value has been specified for WAIT.
Action: specify a non negative value or FOREVER.
ORA-25231: cannot dequeue because CONSUMER_NAME not specified
Cause: A user tried to dequeue from a queue that has been created for multiple consumers but a CONSUMER_NAME was not been specified in the dequeue options.
Action: Specify the CONSUMER_NAME in the dequeue options.
ORA-25232: duplicate recipients specified for message
Cause: An enqueue was performed with duplicate queue agents in the recipients parameter.
Action: Remove the duplicate queue agent and retry the call.
ORA-25233: invalid parameter specified for NAVIGATION
Cause: An invalid parameter has been specified for NAVIGATION.
Action: Choose one of FIRST_MESSAGE, NEXT_MESSAGE or NEXT_TRANSACTION. Use FIRST_MESSAGE for dequeuing the first message that satisifies the criterion, NEXT_MESSAGE for dequeuing the next message that satisifies the criterion and NEXT_TRANSACTION for moving to a set of messages enqueued by another transaction.
ORA-25234: NEXT_TRANSACTION navigation option invalid for queue table string.string
Cause: The NEXT_TRANSACTION navigation option was used in a dequeue from a queue in a queue table that was not created for transactional grouping.
Action: Specify either FIRST_MESSAGE or NEXT_MESSAGE as the navigation option. If you want to dequeue messages using transactional grouping create the queue in a queue table that has transactional grouping enabled.
ORA-25235: fetched all messages in current transaction
Cause: The NEXT_TRANSACTION navigation option was used in a dequeue when there were no more messages that belong to the same transaction.
Action: Use the NEXT_TRANSACTION navigation option to move to the next also use the FIRST_MESSAGE option to start from the head of the queue again.
ORA-25236: buffer too small for user data
Cause: The variable or buffer used for the out parameter payload is too small for the user data dequeued.
Action: Increase the size of the buffer or the size of the variable. Maximum size allowed is 32K.
ORA-25237: navigation option used out of sequence
Cause: The NEXT_MESSAGE or NEXT_TRANSACTION option was specified after dequeuing all the messages.
Action: Reset the dequeuing position using the FIRST_MESSAGE naviagtion option and then specify the NEXT_MESSAGE or NEXT_TRANSACTION option.
ORA-25238: too many recipients specified for message destination string
Cause: An ENQUEUE was performed with more than 32 recipients for the given destination (address).
Action: Reduce the number of recipients to 32 or less, and retry the call.
ORA-25239: message ID not supplied when dequeuing from exception queue string.string
Cause: An attempt was made to dequeue from a release 8.0-compatible exception queue without including a message ID in the dequeue options.
Action: Check the application to ensure that the queue name has been specified correctly. If the queue name is correct supply a message ID when dequeuing from a release 8.0-compatible exception queue. Otherwise, upgrade the queue_table containing the queue to release 8.1-compatible using the DBMS_AQADM.MIGRATE_QUEUE_TABLE procedure.
ORA-25240: message ID and dequeue condition/correlation ID specified in dequeue options
Cause: An attempt was made to dequeue by including both a message ID and a dequeue condition/correlation ID in the dequeue options. In the dequeue options, you are permitted to specify either message ID or dequeue condition/correlation ID, or neither.
Action: To dequeue a message, specify a message ID or a dequeue condition/correlation ID in the dequeue options, but do not specify both. If you want to dequeue in the queue's sort order, then do not specify either the message ID or dequeue condition/correlation ID in the dequeue options.
ORA-25241: cannot change correlation ID from string to string without FIRST_MESSAGE option
Cause: An attempt was made to change the correlation ID while using the NEXT_MESSAGE or NEXT_TRANSACTION option for dequeuing.
Action: To use a correlation ID that is different from the previous dequeue call, reset the dequeuing position by using the FIRST_MESSAGE navigation option.
ORA-25242: cannot change subscriber name from string to string without FIRST_MESSAGE option
Cause: An attempt was made to change the subscriber name while using the NEXT_MESSAGE or NEXT_TRANSACTION option for dequeuing.
Action: To use a subscriber name that is different from the previous dequeue call, reset the dequeuing position by using the FIRST_MESSAGE navigation option.
ORA-25243: CONSUMER_NAME cannot be specified when dequeuing from exception queue string.string
Cause: An attempt was made to dequeue from an exception queue by specifying the CONSUMER_NAME in the dequeue options. CONSUMER_NAME can only be specified when dequeuing from a normal queue created for multiple consumers.
Action: Specify only the message id in the dequeue options to dequeue a message from an exception queue.
ORA-25244: dequeue index key not found, QUEUE string, rowid string
Cause: An internal error was encountered. There may be an inconsistency in the queue table index.
Action: Contact your Oracle customer support representative. You may need to provide the trace file and information about reproducing the error.
ORA-25245: agent name cannot be specified if address is a single-consumer queue or an exception queue
Cause: The agent name for the agent in the LISTEN call was specified when the agent address was a single-consumer queue or an exception queue.
Action: Do not specify the agent name.
ORA-25246: listen failed, the address string is an 8.0 style exception queue
Cause: An 8.0 style exception queue was specified in the agent-list for the LISTEN call.
Action: Specify a normal 8.0 style queue or an 8.1 style queue in the agent-list.
ORA-25247: %s is not a recipient of specified message
Cause: The consumer name specified in the dequeue options is not a recipient of the message specified by the message id.
Action: Ensure that the agent specified by the consumer name is a recipient of the message specified by the message id.
ORA-25248: duplicate agent specified in the agent list
Cause: An agent was specified more than once in the agent list of the LISTEN call.
Action: Remove the duplicate agent specification(s), and retry the call.
ORA-25249: dequeue failed, dequeue not allowed for queue string.string
Cause: An attempt was made to dequeue from a non-persistent queue.
Action: Dequeue from a different queue.
ORA-25250: Cannot specify a remote recipient for the message
Cause: A recipient for the message enqueued to a non-persistent queue had a non-local address.
Action: Do not specify the address field or specify the queue which is the target of the enqueue
ORA-25251: exceeded maximum number of recipients for message
Cause: An attempt was made to issue an ENQUEUE call that exceeded the the maximum number (1024) of recipients per message.
Action: Reduce the number of recipients to 1024 or less, and retry the call.
ORA-25252: listen failed, the address string is a non-persistent queue
Cause: A non-persistent queue was specified as an address for an agent in the LISTEN call.
Action: Specify a normal queue as address for the agent, and retry the the LISTEN call.
ORA-25253: listen failed, queue string.string is not enabled for dequeue
Cause: An attempt was made to specify a queue that is not enabled for dequeue in a LISTEN call.
Action: Enable the queue for dequeue using START_QUEUE, and retry the LISTEN call.
ORA-25254: time-out in LISTEN while waiting for a message
Cause: The specified wait time has elapsed and there were no messages for any of the agents in the agent-list.
Action: Try the LISTEN call with an appropriate time-out.
ORA-25255: incorrect subscription string string
Cause: An incorrect subscription string was specified with OCIRegister.
Action: Specify a subscription string using the [CONSUMER:]SCHEMA.QUEUE form.
ORA-25256: consumer cannot be specified with a single-consumer queue or an exception queue
Cause: An attempt was made to specify a consumer in the subscription string when registering for notification on a single-consumer queue or an exception queue.
Action: Do not specify the consumer in the subscription string.
ORA-25257: consumer must be specified with a multi-consumer queue
Cause: An attempt was made to register on a multi-consumer queue without specifying a consumer in the subscription string.
Action: Specify a consumer in the subscription string.
ORA-25258: cannot register for notifications on an 8.0 style exception queue
Cause: An attempt was made to specify an 8.0 style exception queue in the subscription string of OCIRegister.
Action: Specify a normal queue or a non-persistent queue.
ORA-25259: cannot specify protocol for agent
Cause: The user specified the protocol attribute for an agent in the agent list.
Action: Do not specify the protocol attribute of the agent object type.
ORA-25261: JOB_QUEUE_PROCESSES must be at least 2 for AQ propagation
Cause: AQ Propagator encountered a setting for JOB_QUEUE_PROCESSES that is insufficient for AQ propagation.
Action: Set the number of JOB_QUEUE_PROCESSES to at least 2 for AQ propagation.
ORA-25262: agent name cannot be NULL if address is a multi-consumer queue
Cause: The name for the agent in the LISTEN call was not specified when the agent address was a multi-consumer queue.
Action: Specify a non-NULL name for the agent.
ORA-25263: no message in queue string.string with message ID string
Cause: An attempt was made to dequeue a message with a specific message ID, but no such message exists in the queue.
Action: Try dequeue again with a valid message ID.
ORA-25264: cant get signature for this queue
Cause: An attempt was made to dequeue the signature from this queue, which is not reciever non-repidiable.
Action: Try dequeue again without the get signature option
ORA-25265: specified signature for a queue which does not support reciever non-repudiation
Cause: An attempt was made to dequeue the message from a queue which does not support reciever non-repudiation, but the signature was specified for verification
Action: Try dequeue again without the signature
ORA-25266: didnt try to dequeue by message id. with the signature
Cause: The signature was specified for a queue, but the dequeue was not done by message id.
Action: Try dequeue again by message id.
ORA-25267: didnt specify the signature for a reciever non-repudiable queue
Cause: The signature was not specified for a reciever non-repudiable queue
Action: Try dequeue again along with the signature
ORA-25268: didnt dequeue in browse mode with get signature option
Cause: The dequeue was not performed in browse mode with get signature option
Action: Try dequeue again in browse mode
ORA-25269: cant specify sognature with get signature option
Cause: The signature is not required for the dequeue with get signature option
Action: Try dequeue again without the signature in dequeue options
ORA-25270: sender info does not match with the actual sender of the message
Cause: The sender info. and the message id. do not match
Action: Try dequeue again without the signature in dequeue options
ORA-25271: queue table not found for the given queue
Cause: The queue table does not exist for the given queue
Action: Provide the right queue name
ORA-25272: Signature does not exist for the given reciever and message id.
Cause: Signature does not exist for the given reciever and message id.
Action: Check the message id. and the reciever's information
ORA-25275: Test support for buffered queues
Cause: internal use only
Action: none.
ORA-25276: table specified is not a queue table
Cause: An invalid queue table name is specified.
Action: Check the dictionary views to see if the table is a queue table.
ORA-25277: cannot grant or revoke object privilege on release 8.0 compatible queues
Cause: An attempt was made to grant or revoke object privilege on release 8.0 style queues.
Action: Convert the release 8.0 compatible queue table to release 8.1 compatible using DBMS_AQADM.MIGRATE_QUEUE_TABLE before granting or revoking object privilege.
ORA-25278: grantee name cannot be NULL
Cause: An attempt was made to specify NULL for the grantee parameter.
Action: Specify a valid grantee parameter.
ORA-25279: dequeue as select not supported before 8.2
Cause: Dequeue as select not supported before 8.2.
Action: Dont use select condition while dequeuing
ORA-25280: complete sender information not provided to non-repudiate sender
Cause: complete sender information not provided to non-repudiate sender
Action: Provide the complete sender information
ORA-25281: complete reciever information not provided to non-repudiate reciever
Cause: complete reciever information not provided to non-repudiate reciever
Action: Provide the complete reciever information
ORA-25282: message id. not provided for non-repudiation
Cause: message id. was not provided
Action: Provide the message id.
ORA-25283: either agent's name or address needed for non-repudiation
Cause: neither agent's name nor address provided for non-repudiation"
Action: Provide the agent info.
ORA-25284: Invalid value string for string
Cause: An Invalid value or NULL was specified for the parameter.
Action: Check the documentation for valid values.
ORA-25285: Invalid value string for array_mode
Cause: An Invalid value or NULL was specified for the array_mode.
Action: Check the documentation for valid values.
ORA-25286: Invalid number of elements in the message properties array
Cause: Number of elements in the message properties array do not match the number of elements in the payload array.
Action: Create a message property array with one element (that applies for all the elements in the payload array) or create a message property array with the same number of elements as there are in the payload array.
ORA-25287: Invalid value string, string should be non-negative
Cause: An Invalid value or NULL was specified for the parameter.
Action: Specify a non negative integer.
ORA-25288: AQ HTTP propagation encountered error, status-code number, string
Cause: AQ propagation's HTTP request to the propagation servlet at the specified address encountered an error
Action: Specify a valid address in the connect string of the propagation destination dblink, the dblink user has the correct permissions, check if the AQ propagation servlet was properly installed.
ORA-25289: Buffer Already Exists
Cause: Buffer already exists for the specified queue.
Action: None
ORA-25290: Cannot complete operation on queue string with existing messages
Cause: Queue already has messages. Cannot complete operation
Action: Truncate the queue before adding/dropping a buffer
ORA-25291: Buffer does not exist for the specified queue
Cause: Buffer does not exist for the specified queue
Action: Operation on the buffer cannot be performed. create the buffer
ORA-25292: Cannot add buffer on the specified queue
Cause: Buffer cannot be added on Specified Queue
Action: Can only add buffers to 8.1 style non-exception multi-consumer queues, which do not have priority, non_repudiation, message_grouping, max_retries and retention.
ORA-25293: Remote Recipient Subsribers and buffered operations not possible for Queue string
Cause: Specified Queue has remote recipient subscribers
Action: Cannot add buffers/add buffered subscribers to queues with remote recipient subscribers
ORA-25294: Queue string has a buffer
Cause: Specified Queue has a buffer
Action: Drop the buffer first
ORA-25295: Subscriber is not allowed to dequeue buffered messages
Cause: Subscriber is only allowed to dequeue persistent messages
Action: Drop the subscriber and re-create it
ORA-25296: Queue Table string has a buffered queue string
Cause: Cannot downgrade the queue table because it has a buffered queue
Action: Drop the buffer or the buffered queue
ORA-25297: The message options only make sense for buffered messages
Cause: The message options only make sense for buffered messages
Action: Check the enqueue/dequeue options
ORA-25298: The memory threshold for a queue cannot be negative
Cause: The memory threshold for a queue cannot be negative
Action: Correct the memory threshold
ORA-25299: Cannot add buffered subscriber for a non-buffered queue
Cause: Cannot add buffered subscriber for a non-buffered queue
Action: Either add buffer to the queue, or make the subscriber non-buffered
ORA-25300: Cannot drop buffer for queue with buffered subscribers
Cause: Cannot drop buffer for queue with buffered subscribers
Action: Either drop buffered subscribers or forcibly drop the buffer
ORA-25301: cannot specify recipient list during enqueue
Cause: Recipient list for buffered queue not supported
Action: Dont specify recipient list for buffered enqueues
ORA-25302: Operation not possible for non-buffered queue string
Cause: Last enqd/ackd message is only supported for buffered queues
Action: The operation is not supported.
ORA-25303: Buffered operation allowed only on the owner instance
Cause: Operation was not performed on the owner instance.
Action: Perform operation on the owner instance.
ORA-25304: Queue Table has primary/secondary instance affinity. Cannot add buffer
Cause: Cannot add buffer if primary/secondary instance is specified.
Action: Add buffer after removing instance affinities.
ORA-25305: enqueue failed, expiration must be zero for queue string.string
Cause: An attempt was made to enqueue to a non-persistent or buffered queue with expiration greater than zero seconds.
Action: Set expiration to zero.
ORA-25306: Queue table string has buffered queues. Cannot alter
Cause: Cannot change instance affinities if there are buffered queues on this queue table.
Action: Perform Alter after dropping all buffered queues.
ORA-25307: Enqueue rate too high. Enable flow control
Cause: Subscribers cannot keep pace with the enqueue rate.
Action: Try enqueue after sleeping for some time.
ORA-25321: enqueue failed, user property specified but queue string.string is not an 8.1 style queue
Cause: user properties can only be specified when enqueueing into 8.1 style queues.
Action: Specify an 8.1 style queue or pass user property as NULL.
ORA-25326: Array string operation failed for message at index string
Cause: Array operation fails for the message at specified index. Look at the remainder of the error stack to see what the problem was.
Action: Fix cause of error and retry array operation.
ORA-25327: Array size is invalid
Cause: Array size must be a positive, non-zero integer.
Action: Use corrected array size and retry array operation.
ORA-25328: %s argument size string is smaller than array size
Cause: The size of the argument is smaller than the given array size.
Action: Lower array size or use a larger sized input argument.
ORA-25329: AQ array operations not allowed on 8.0 queues
Cause: An array enqueue/dequeue was attempted on an 8.0 queue.
Action: Use single enqueue/dequeue with this queue.
ORA-25330: PL/SQL associative arrays may not be used with AQ array operations
Cause: A PL/SQL associative array was provided for the payload parameter in an enqueue/dequeue array operation.
Action: Use VARRAY or NESTED TABLE types with AQ array operations.
ORA-25350: maximum number of concurrent transaction branches exceeded
Cause: the limit on the number of concurrent transaction branches has been reached
Action: Increase the INIT.ORA parameter 'transactions' and restart the system.
ORA-25351: transaction is currently in use
Cause: The transaction is currently used by a different session.
Action: Do not switch to a transaction attached to some other session.
ORA-25352: no current transaction
Cause: The user session is not attached to any transaction.
Action: Do not attempt to detach when there is no current transaction.
ORA-25353: branch marked for deletion
Cause: The branch specified cannot be killed immediately because another session is using the branch, but it has been marked for kill. This means it will be deleted as soon as possible after the current uninterruptable operation is completed.
Action: No action is required for the branch to be deleted.
ORA-25400: must replay fetch
Cause: A failure occured since the last fetch on this statement. Failover was able to bring the statement to its original state to allow continued fetches.
Action: This is an internally used error message and should not be seen by the user.
ORA-25401: can not continue fetches
Cause: A failure occured since the last fetch on this statement. Failover was unable to bring the statement to its original state to allow continued fetches.
Action: Reexecute the statement and start fetching from the beginning
ORA-25402: transaction must roll back
Cause: A failure occured while a transaction was active on this connection.
Action: The client must roll back.
ORA-25403: could not reconnect
Cause: The connection to the database has been lost, and attempts to reconnect have failed.
Action: Manually reconnect.
ORA-25404: lost instance
Cause: The primary instance has died.
Action: This is an internally used error message and should not be seen by the user.
ORA-25405: transaction status unknown
Cause: A failure occured while a transaction was attempting to commit. Failover could not automatically determine instance status.
Action: The user must determine the transaction's status manually.
ORA-25406: could not generate a connect address
Cause: Failover was unable to generate an address for a backup instance.
Action: Contact Oracle customer support.
ORA-25407: connection terminated
Cause: The connection was lost while doing a fetch.
Action: This is an internally used error message and should not be seen by the user.
ORA-25408: can not safely replay call
Cause: The connection was lost while doing this call. It may not be safe to replay it after failover.
Action: Check to see if the results of the call have taken place, and then replay it if desired.
ORA-25409: failover happened during the network operation,cannot continue
Cause: The connection was lost when fetching a LOB column.
Action: Failover happened when fetching LOB data directly or indirectly. Please replay the top level statement.
ORA-25425: connection lost during rollback
Cause: The connection was lost while issuing a rollback and the application failed over.
Action: The connection was lost and failover happened during rollback. If the transaction is not externally coordinated, then Oracle implicitly rolled back, so no action is required. Otherwise examine pending_trans$ to determine if "rollback force" is required.
ORA-25426: remote instance does not support shared dblinks
Cause: A shared dblink is being used to connect to a remote instance that does not support this feature because it is an older version.
Action: Use a normal dblink if you need to connect to this instance.
ORA-25436: invalid table alias: string
Cause: An attempt to evaluate was made, which failed because one of the table values specified had an invalid alias.
Action: Check the valid table aliases in the evaluation context, and try again with a valid alias.
ORA-25437: duplicate table value for table alias: string
Cause: An attempt to evaluate was made, which failed because some of the table values specified had the same table alias.
Action: Check the table values specified, and try again with only one value per table.
ORA-25438: invalid variable name: string
Cause: An attempt to evaluate was made, which failed because one of the variable values specified had an invalid name.
Action: Check the valid variable names in the evaluation context, and try again with a valid name.
ORA-25439: duplicate variable value for variable: string
Cause: An attempt to evaluate was made, which failed because some of the variable values specified had the same variable name.
Action: Check the variable names specified, and try again with only one value per variable.
ORA-25440: invalid table alias: string
Cause: An attempt to evaluate was made, which failed because one of the column values specified had an invalid table alias.
Action: Check the valid table aliases in the evaluation context, and try again with a valid name.
ORA-25441: duplicate column value for table alias: string
Cause: An attempt to evaluate was made, which failed because one of the column values supplied a value for a table alias, which already had a table value supplied.
Action: Check the table and column values specified, and try again with either a table value or column values for each table alias.
ORA-25442: too many column values for table alias: string
Cause: An attempt to evaluate was made, which failed because too many column values were supplied for the specified table alias.
Action: Check the column values specified, and try again with the right number of column values.
ORA-25443: duplicate column value for table alias: string, column number: string
Cause: An attempt to evaluate was made, which failed because duplicate column values were supplied for the specified table alias and column number.
Action: Check the column values specified, and try again with only one column value for each table alias, and column number.
ORA-25444: invalid ROWID: string for table alias: string
Cause: An attempt to evaluate was made, which failed because an invalid ROWID was supplied for the specified table alias.
Action: Check the column values specified, and try again with only one column value for each table alias, and column number.
ORA-25445: invalid column number: string for table alias: string
Cause: An attempt to evaluate was made, which failed because an invalid column number was supplied for the specified table alias as a part of a column value.
Action: Check the column values specified, and try again with a valid column number.
ORA-25446: duplicate column value for table alias: string, column: string
Cause: An attempt to evaluate was made, which failed because duplicate column values were supplied for the specified table alias and column name.
Action: Check the column values specified, and try again with only one column value for each table alias, and column name.
ORA-25447: encountered errors during evaluation of rule string.string
Cause: An attempt to evaluate was made, which failed during the evaluation of the specified rule.
Action: Check the rule and the values passed to evaluate, and try again with valid values.
ORA-25448: rule string.string has errors
Cause: An attempt to load the specified rule failed due to errors in the rule.
Action: Check the rule and retry the operation.
ORA-25449: invalid variable name: string
Cause: An attempt to evaluate was made, which failed because one of the attribute values specified had an invalid variable name.
Action: Check the valid variable names in the evaluation context, and try again with a valid name.
ORA-25450: error string during evaluation of rule set string.string
Cause: The specified error occurred during evaluation of the rule set.
Action: Check the error and take appropriate action.
ORA-25451: too many attribute values for variable: string
Cause: An attempt to evaluate was made, which failed because too many attribute values were supplied for the specified variable.
Action: Check the attribute values specified, and try again with the right number of attribute values.
ORA-25452: duplicate attribute value for variable: string, attribute: string
Cause: An attempt to evaluate was made, which failed because duplicate attribute values were supplied for the specified variable and attribute name.
Action: Check the attribute values specified, and try again with only one attribute value for each variable, and attribute name.
ORA-25453: invalid iterator: string
Cause: An attempt to get rule hits or to close an iterator was made, which failed because an invalid iterator was passed in.
Action: Check the iterator, and try again with a valid iterator.
ORA-25454: error during evaluation of rule set: string.string for iterator: string
Cause: An attempt to get rule hits for an iterator was made, which failed because of an error in evaluation of the specified rule set.
Action: Check the validity of the rule set and try again.
ORA-25455: evaluation error for rule set: string.string, evaluation context: string.string
Cause: An attempt to evaluate the specified rule set using the evaluation context specified failed due to some errors.
Action: Check additional errors signalled to determine the problem.
ORA-25456: rule set was modified or evaluation terminated for iterator: string
Cause: An attempt to get rule hits was made, which failed because the underlying rule set was modified after the iterator was returned.
Action: Try again after re-evaluating the rule set.
ORA-25457: evaluation function string returns failure
Cause: The specified evaluation function returned a failure during evaluation, causing evaluation to terminate.
Action: Check arguments to evaluate and retry.
ORA-25461: rule set not specified
Cause: An attempt to evaluate was made, which failed because the ruleset name specified was null.
Action: Check the rule set name, and try again with a valid name.
ORA-25462: evaluation context not specified
Cause: An attempt to evaluate was made, which failed because the evaluation context specified was null.
Action: Check the evaluation context name, and try again with a valid name.
ORA-25463: table alias not specified
Cause: An attempt to evaluate was made, which failed because one of the table values specified had a NULL alias name.
Action: Check the list of table values, and try again with a valid alias name.
ORA-25464: ROWID not specified for table alias: string
Cause: An attempt to evaluate was made, which failed because the table value for the specified table alias had a NULL ROWID.
Action: Check the list of table values, and try again with a valid ROWID.
ORA-25465: variable name not specified
Cause: An attempt to evaluate was made, which failed because one of the variable values specified had a NULL variable name.
Action: Check the list of variable values, and try again with a valid variable name.
ORA-25466: data not specified for variable name: string
Cause: An attempt to evaluate was made, which failed because the variable value for the specified variable name had NULL data.
Action: Check the list of variable values, and try again with valid data.
ORA-25467: table alias not specified
Cause: An attempt to evaluate was made, which failed because one of the column values specified had a NULL alias name.
Action: Check the list of column values, and try again with a valid alias name.
ORA-25468: column name not specified for alias: string
Cause: An attempt to evaluate was made, which failed because one of the column values for the specified alias name had a NULL column name.
Action: Check the list of column values, and try again with a valid column name.
ORA-25469: data not specified for alias: string column name: string
Cause: An attempt to evaluate was made, which failed because the column value for the specified alias and column name had NULL data.
Action: Check the list of column values, and try again with valid data.
ORA-25470: duplicate attribute value for variable: string
Cause: An attempt to evaluate was made, which failed because one of the attribute values supplied a value for a variable, which already had a variable value supplied.
Action: Check the variable and attribute values specified, and try again with either a variable value or attribute values for each variable.
ORA-25471: attribute name not specified for variable: string
Cause: An attempt to evaluate was made, which failed because one of the attribute values for the specified variable had a NULL attribute name.
Action: Check the list of attribute values, and try again with a valid attribute name.
ORA-25472: maximum open iterators exceeded
Cause: The open rule hit iterators in the session exceeded 2 * OPEN_CURSORS.
Action: Close some rule hit iterators.
ORA-25473: cannot store string in rule action context
Cause: The user attempted to put unsupported data types, such as LOBs and evolved ADTs, into the rule action context.
Action: Use only supported data types in rule action context.
ORA-25500: database is not open
Cause: Database must be open to perform ALTER SYSTEM QUIESCE RESTRICTED command.
Action: Open the database and retry this command.
ORA-25501: ALTER SYSTEM QUIESCE RESTRICTED command failed
Cause: Database resource manager failed to change plan.
Action: Look at the alert logs to see detailed description of the error.
ORA-25502: concurrent ALTER SYSTEM QUIESCE/UNQUIESCE command is running
Cause: There is a concurrent ALTER SYSTEM QUIESCE RESTRICTED or ALTER SYSTEM UNQUIESCE command running in the system.
Action: Contact the database administrator who is responsible for the concurrent command.
ORA-25503: cannot open database because the database is being quiesced
Cause: Database cannot be opened because the system is being or has been quiesced.
Action: Open the database after the system has been quiesced.
ORA-25504: the system is already in quiesced state
Cause: Cannot quiesce the system because the system is already quiesced.
Action: none
ORA-25505: the system is not in quiesced state
Cause: Cannot unquiesce the system because the system is not in quiesced state.
Action: none
ORA-25506: resource manager has not been continuously on in some instances
Cause: Cannot quiesce the system because resource manager has not been continuously on since startup in this or some other instances.
Action: none
ORA-25507: resource manager has not been continuously on
Cause: Cannot quiesce the system because resource manager has not been continuously on since startup.
Action: none
ORA-25508: database is not mounted
Cause: Database must be mounted to perform ALTER SYSTEM UNQUIESCE command.
Action: Mount the database and retry this command.
ORA-25509: operation on "string"."string".string not allowed
Cause: A column has been added to a replicated table, but replication support processing has not completed.
Action: Wait until replication support processing has completed before updating the column
ORA-25526: bad format of _DB_MTTR_SIM_TARGET: string
Cause: One value in _DB_MTTR_SIM_TARGET is not a valid MTTR.
Action: Alter the value of _DB_MTTR_SIM_TARGET.
ORA-25527: bad format of _DB_MTTR_SIM_TARGET
Cause: One value in _DB_MTTR_SIM_TARGET is empty.
Action: Set the value of _DB_MTTR_SIM_TARGET properly.
ORA-25528: too many candidate MTTRs are specified in _DB_MTTR_SIM_TARGET
Cause: Too many candidate MTTRs are specified in _DB_MTTR_SIM_TARGET.
Action: Alter the value of _DB_MTTR_SIM_TARGET.
ORA-25530: FAST_START_MTTR_TARGET is not specified
Cause: An attempt to start MTTR advisory was made, which failed because FAST_START_MTTR_TARGET was not specified.
Action: Set FAST_START_MTTR_TARGET.
ORA-25531: MTTR specified is too small: string
Cause: The current FAST_START_MTTR_TARGET setting or a candidate MTTR setting is too small for MTTR advisory.
Action: Set a larger FAST_START_MTTR_TARGET or candidate MTTR.
ORA-25532: MTTR specified is too large: string
Cause: The current FAST_START_MTTR_TARGET setting or a candidate MTTR setting is too large for MTTR advisory.
Action: Set a smaller FAST_START_MTTR_TARGET or candidate MTTR.
ORA-25533: FAST_START_IO_TARGET or LOG_CHECKPOINT_INTERVAL is specified
Cause: An attempt to start MTTR advisory was made, which failed because either FAST_START_IO_TARGET or LOG_CHECKPOINT_INTERVAL was specified.
Action: Set FAST_START_IO_TARGET and LOG_CHECKPOINT_INTERVAL to 0.
ORA-25534: _MEAN_TIME_TO_CLUSTER_AVAILABILITY is specified
Cause: An attempt to start MTTR advisory was made, which failed because _MEAN_TIME_TO_CLUSTER_AVAILABILITY was specified.
Action: No action required.
ORA-25950: missing where clause in join index specification
Cause: An attempt to create a join index was made, which failed because no valid where clause was found.
Action: Ensure that a where clause with valid join conditions is specified in the create index statement.
ORA-25951: join index where clause cannot contain OR condition
Cause: An attempt to create a join index was made, which failed because there was an OR branch in the where clause.
Action: Reformulate the where clause without using ORs.
ORA-25952: join index must only contain inner equi-joins
Cause: An attempt to create a join index was made, which failed because it included a predicate which wasn't an equi-inner join.
Action: Remove the inappropriate predicate.
ORA-25953: join index cannot be a functional index
Cause: An attempt to create a join index was made, which failed because a functional index was requested or necessary (such as is the case for indexing columns using timezone).
Action: Remove any functional indexing columns.
ORA-25954: missing primary key or unique constraint on dimension
Cause: An attempt to create a join index was made, which failed because one or more dimensions did not have an appropriate constraint matching the join conditions.
Action: Ensure that the where clause is correct (contains all of the constraint columns) and that an enforced constraint is on each dimension table.
ORA-25955: all tables must be joined in the where clause
Cause: An attempt to create a join index was made, which failed because one of the tables in the from clause did not appear in the where clause.
Action: Ensure that the where clause contains all from clause tables.
ORA-25956: join index cannot be created on tables owned by SYS
Cause: An attempt to create a join index was made, which failed because one of the tables was owned by SYS.
Action: Ensure that no join index related table is owned by SYS.
ORA-25957: join index where clause cannot contain cycles
Cause: An attempt to create a join index was made, which failed because the where clause contains a cycle.
Action: Ensure that the where clause is in the form of a star or snowflake schema.
ORA-25958: join index where clause predicate may only contain column references
Cause: An attempt to create a join index was made, which failed because a predicate in the where clause contained something other than a simple column.
Action: Ensure that the where clause only contains columns.
ORA-25959: join index must be of the bitmap type
Cause: An attempt to create a join index was made, which failed because no bitmap keyword was used.
Action: Make the index a bitmap index.
ORA-25960: join index cannot be based on a temporary table
Cause: An attempt to create a join index was made, which failed because one of the tables was temporary.
Action: Ensure no underlying tables are temporary.
ORA-25961: join index prevents dml cascade constraint operation
Cause: An attempt to execute dml resulted in the need to perform dml on another table because of a cascade constraint. The join index only allows one of its underlying tables to me modified at a time.
Action: Drop the join index or remove the constraint.
ORA-25962: join index prevents multitable insert or merge
Cause: An attempt to execute an merge or multitable insert on a table that was used to create a bitmap join index was made. Merge and multitable inserts are not supported on tables that were used to create a bitmap join index.
Action: Drop the join index.
ORA-25963: join index must be created on tables
Cause: An attempt to create a join index was made, which failed because the from clause contains non table object.
Action: Ensure that the from clause only contains tables.
ORA-25964: column type incompatible with join column type
Cause: The datatype of the join column is incompatible with the datatype of the joined column.
Action: Select a compatible datatype for the join column.
ORA-25965: fact table must be included in the from clause
Cause: An attempt to create a join index was made, which failed because the from clause does not contain the fact table.
Action: Ensure that the from clause contains the fact table.
ORA-25966: join index cannot be based on an index organized table
Cause: An attempt to create a join index was made, which failed because one of the tables was an index organized table.
Action: Ensure no underlying tables are index organized.
ORA-26000: partition load specified but table string is not partitioned
Cause: The Loader control file contains a PARTITION clause but the table being loaded is not partitioned.
Action: Remove the partition specification from the SQL*Loader control file and retry the load.
ORA-26001: Index string specified in SORTED INDEXES does not exist on table string
Cause: A nonexistent index was specified in the SORTED INDEXES clause.
Action: Do not specify as a SORTED INDEX.
ORA-26002: Table string has index defined upon it.
Cause: Parallel load was specified into a table which has index defined upon it.
Action: Drop index(es) defined upon table, or don't use parallel load, or use SKIP_INDEX_MAINTENANCE option.
ORA-26003: parallel load not supported for index-organized table string.
Cause: Parallel load is not supported for index-organized tables.
Action: load the index-organized table without the PARALLEL option.
ORA-26004: Tables loaded through the direct path may not be clustered
Cause: User attempted to load a clustered table via the direct path.
Action: Use the conventional path.
ORA-26005: Invalid handle for direct path load
Cause: In direct path load, the handle passed in does not match the type listed.
Action: Verify the handle and type are correct.
ORA-26006: Incorrect bind variable in column string's sql expression - string
Cause: In direct path load, the bind variables listed in the sql expression do not match the input argument column names.
Action: Verify all the input arguments are listed in the expression as bind variables, and all the bind variables are listed as input arguments to the expression. Or verify that there were no errors in executing the OCI statements when getting the bind variable list.
ORA-26007: invalid value for SETID or OID column
Cause: The value passed in a Direct Path API stream for a column containing a SETID or OID has an invalid value. SETIDs and Object IDs must be either 16 bytes of RAW data or 32 bytes of hexidecimal characters.
Action: Regenerate the Direct Path API stream with a valid value for the SETID column.
ORA-26010: Column string in table string is NOT NULL and is not being loaded
Cause: A column which is NOT NULL in the database is not being loaded and will cause every row to be rejected.
Action: Load the column by specifying the NOT NULL column in the INTO TABLE clause in the SQL*Loader control file.
ORA-26011: Cannot load type string into column string in table string
Cause: A column can only store data of type declared for that column. And a substitutable column can only store data of valid subtypes of the supertype declared for that column.
Action: Check that the type or subtype specified is valid for that column.
ORA-26012: No data found while executing sql statement string for column string - check input for: string
Cause: Executing sql statement against the data dictionary tables returned "ORA-01403: no data found".
Action: No data retrieved when selecting against the data dictionary tables most likely means that there's an error in user input. Check that the input listed is correct.
ORA-26013: List allocated may not be big enough
Cause: There seems to be a discrepancy between the size for a list or buffer allocated by direct path api and the size needed.
Action: Contact Oracle Customer Support.
ORA-26015: Array column string in table string is not supported by direct path
Cause: User attempted to load an array column via the direct path.
Action: Use the conventional path.
ORA-26017: global indexes not allowed for direct path load of table partition string
Cause: Global indexes are defined on a table when direct path loading a single partition of the table.
Action: none
ORA-26018: Column string in table string does not exist
Cause: Column specified in the loader control file does not exist.
Action: Make sure the column exists and that you have privileges on it. Correct the loader control file if it is wrong.
ORA-26019: Column string in table string of type string not supported by direct path
Cause: The Specified column of SQL column type %s is not supported by the direct path loader.
Action: If the column is NULLable, remove it from the control file description. Then it will be loaded as a NULL.
ORA-26020: index string.string loaded successfully with string keys
Cause: Non-partitioned index information put to loader log file.
Action: None. Information only.
ORA-26021: index string.string partition string loaded successfully with string keys
Cause: Partitioned index information put to loader log file.
Action: None. Information only.
ORA-26022: index string.string was made unusable due to:
Cause: A Non-partitioned index was made index unusable due to the error displayed below this error.
Action: Depending on the error, either rebuild the index, or drop and re-create it.
ORA-26023: index string.string partition string was made unusable due to:
Cause: A partition of a partitioned index was made index unusable due to error displayed below this error.
Action: Depending on the error, either rebuild the index partition, or drop and re-create the entire index.
ORA-26024: SKIP_UNUSABLE_INDEXES requested and index segment was initially unusable
Cause: User requested SKIP_UNUSABLE_INDEXES option, and the index segment

* was in unusable state prior to the beginning of the load.

Action: Informational only. User will need to either rebuild the index

* or index partition, or re-create the index.

ORA-26025: SKIP_INDEX_MAINTENANCE option requested
Cause: User requested that index maintenance be skipped on a direct path load.
Action: The listed index was put into Index Unusable state due to the user requesting that index maintenance be skipped. Either rebuild the index or index partitions, or drop and re-create the index.
ORA-26026: unique index string.string initially in unusable state
Cause: A unique index is in IU state (a unique index cannot have

* index maintenance skipped via SKIP_UNUSABLE_INDEXES).

Action: Either rebuild the index or index partition, or use

* SKIP_INDEX_MAINTENANCE if the client is SQL*Loader.

ORA-26027: unique index string.string partition string initially in unusable state
Cause: A partition of a unique index is in IU state (a unique index

* cannot have index maintenance skipped via SKIP_UNUSABLE_INDEXES).

Action: Either rebuild the index or index partition, or use

* SKIP_INDEX_MAINTENANCE if the client is SQL*Loader.

ORA-26028: index string.string initially in unusable state
Cause: An index is in IU state prior to the beginning of a direct

* path load, it cannot be maintained by the loader.

Action: Either rebuild the index, re-create the index, or use either

* SKIP_UNUSABLE_INDEXES or SKIP_INDEX_MAINTENANCE (Sql*Loader only).

ORA-26029: index string.string partition string initially in unusable state
Cause: A partition of an index is in IU state prior to the beginning

* of a direct path load, it cannot be maintained by the loader.

Action: Either rebuild index partition, re-create the index, or use either

* SKIP_UNUSABLE_INDEXES or SKIP_INDEX_MAINTENANCE (Sql*Loader only).

ORA-26030: index string.string had string partitions made unusable due to:
Cause: A logical index error occurred on a partitioned index which

* affected one or more index partitions, which are listed below

* this message.

Action: The affected index partitions will have to be re-built, or, the

* entire index dropped and re-created.

ORA-26031: index maintenance error, the load cannot continue
Cause: A index errror occurred during the index maintenance phase of

* a direct path load. The load cannot continue. See error message

* below this message.

Action: See action for the error message which follows this one.
ORA-26032: index string.string loading aborted after string keys
Cause: An index error occurred during direct-load of an index-organized table.

* Loading had to be aborted. No rows were loaded.

Action: Check the key just following the number of keys mentioned above.

* This key caused the index problem mentioned in an earlier message. *

ORA-26033: Direct path operation not supported on table with encrypted colum
Cause: A direct path operation was attempted on a table with an encrypted

* column.

Action: Use conventional path load on tables with encrypted columns. *
ORA-26034: Column string does not exist in stream
Cause: Column specified in the column list does not exist in the stream.
Action: Make sure the column exists or remove it from the list.
ORA-26036: subpartition load specified but table string is not subpartitioned
Cause: The Loader control file contains a PARTITION clause but the table being loaded is not subpartitioned.
Action: Remove the subpartition specification from the SQL*Loader control file and retry the load.
ORA-26040: Data block was loaded using the NOLOGGING option
Cause: Trying to access data in block that was loaded without

* redo generation using the NOLOGGING/UNRECOVERABLE option

Action: Drop the object containing the block.
ORA-26041: DATETIME/INTERVAL datatype conversion error
Cause: The column could not be converted from DATETIME

* datatype to internal DATETIME/CHARACTER datatype.

Action: Contact Oracle Customer Support.
ORA-26045: REF column string expects string arguments; found string.
Cause: The number of arguments for the REF column is incorrect.
Action: Specify the correct number of input arguments for REFs.

1. Unscoped system-generated REFs can have exactly 1 or 2 input arguments. a) It has exactly 1 input argument (one for the OID value) if a fixed table name was specified through OCI_DIRPATH_EXPR_REF_TBLNAME. b) It has exactly 2 input arguments (one for the table name and one for the OID value) if a fixed table name was not specified through OCI_DIRPATH_EXPR_REF_TBLNAME.

2. Scoped system-generated REFs can have 1 or 2 input arguments. Because a table name argument is not needed for a scoped ref, only 1 argument (OID value) is expected. But if the table name argument is given, it's still accepted.

3. Scoped primary-key REFs with N columns in its primary-key OID can have N or N+1 input arguments. Because a table name argument is not needed for a scoped ref, only N arguments (making up the OID value) is expected. But if the table name argument is given, it's still accepted.

ORA-26046: REF column string expects scoped table name string; user passed in string.
Cause: The scoped table name passed in by the user does not match the name in the schema.
Action: Specify the correct table name for the scoped REF column.
ORA-26048: Scoped REF column has wrong table name.
Cause: The scoped table name passed in by the user does not match the name in the schema.
Action: Specify the correct table name for the scoped REF column.
ORA-26049: Unscoped REF column has non-existent table name.
Cause: The table name passed in by the user does not exist in the schema.
Action: Specify a valid table name for the unscoped REF column.
ORA-26050: Direct path load of domain index is not supported for this column type.
Cause: Direct path can not load a domain index of that column type.
Action: Drop the index and try again or load using conventional path.
ORA-26051: internal error parsing packed decimal format string
Cause: A packed decimal field with a non-zero scale factor is mapped to a character column. In order to perform the datatype conversion, a numeric format string must be created based on the input field's precision and scale specifications. Direct path loader encountered an error in creating this format string.
Action: Examine the packed decimal field's precision and scale specifications and make sure that they contain valid values.
ORA-26052: Unsupported type number for SQL expression on column string.
Cause: The direct path api does not support a SQL expression on a column of that type.
Action: Make sure the types are correct.
ORA-26053: Row was not loaded due to conversion error.
Cause: The current row was not loaded due to a conversion error.
Action: Continue with the load anyways. 260xx - 260xx Direct Path API
ORA-26054: Direct Path Context prepared for a different mode than operation requested.
Cause: The user prepared the direct path context for one operation (Load, Unload, Convert), but then tried to perform a different operation.
Action: Make sure the direct path context mode and operation matches.
ORA-26055: Invalid buffer specified for direct path unload
Cause: The user specified a zero length or null buffer to be used for the Direct Path Unload operation.
Action: Specify a valid buffer and length.
ORA-26056: Can not unload from a view through the direct path.
Cause: User attempted to unload from a view via the direct path.
Action: Unload from a normal table.
ORA-26057: Conversion is not necessary for this direct path stream.
Cause: User attempted to convert a direct path stream that does not require conversion.
Action: Load the stream without conversion it.
ORA-26058: unexpected error fetching metadata for column string in table string
Cause: The direct path API encountered an unexpected error while retrieving metadata for a column.
Action: Contact Oracle support.
ORA-26059: Data is too large for column string
Cause: The direct path API encountered a column that can not be loaded because the input data is too large for a column.
Action: Make the target column larger.
ORA-26060: Can not convert type identifier for column string
Cause: The direct path API encountered a type identifier for a column that can not be loaded because a mapping can not be found for the input value.
Action: Verify the input data.
ORA-26061: Concurrent direct unloads is not allowed.
Cause: User attempted a direct unload when another is still in progress.
Action: Complete the current direct unload before starting another.
ORA-26062: Can not continue from previous errors.
Cause: User attempted to continue a direct path load after receiving an error which indicates the load can not continue.
Action: Address the original error that was returned.
ORA-26063: Can not flashback to specified SCN value - Wrap: string Base: string.
Cause: User specified an SCN which occurs before the last time the table definition was modified.
Action: Specify a more recent SCN.
ORA-26064: Invalid SCN specified - Wrap: string Base: string.
Cause: User specified an invalid SCN.
Action: Specify a valid SCN.
ORA-26076: cannot set or reset value after direct path structure is allocated
Cause: Client attempted to set or reset the number of rows in a direct path

* structure after it has already been allocated and initialized.

* Attributes used is one of the following:

* - OCI_ATTR_NUM_ROWS: to set # of rows in a direct path column array

* - OCI_ATTR_DIRPATH_DCACHE_SIZE: to set size of a date cache

* (default is 0)

* - OCI_ATTR_DIRPATH_DCACHE_DISABLE: to set whether date cache will be

* disabled on overflow (default is FALSE)

Action: Set the following attributes before:

* - OCI_ATTR_NUM_ROWS: before calling OCIHandleAlloc for column array

* - OCI_ATTR_DIRPATH_DCACHE_SIZE: before calling OCIDirPathPrepare

* - OCI_ATTR_DIRPATH_DCACHE_DISABLE: before calling OCIDirPathPrepare

ORA-26077: direct path column array is not initialized
Cause: Client attempted to allocate a column array for a direct path

* function context before allocating a column array for the

* table-level direct path context.

Action: Allocate the table-level direct path context's column array

* via OCIHandleAlloc before allocating column arrays for

* direct path function contexts.

ORA-26078: file "string" is not part of database being loaded
Cause: A parallel load file was specified which is not part

* of the database.

Action: Check filename and pathname for correctness.
ORA-26079: file "string" is not part of table string.string
Cause: A parallel load file was specified which is not in the

* tablespace of the table being loaded.

Action: Check to make sure that the specified parallel load file

* is in the tablespace of the table being loaded.

ORA-26080: file "string" is not part of table string.string partition string
Cause: A parallel load file was specified which is not in the

* tablespace of the table (partition, subpartition) being loaded.

* When a partitioned table is being loaded, the file must be

* in the tablespace of every partition or subpartition

* (i.e. each (sub)partition must be in the same tablespace).

Action: Specify a different parallel load file, or no file at all.
ORA-26082: load of overlapping segments on table string.string is not allowed
Cause: Client application is attempting to do multiple direct path load

* operations on the same table, but the segments overlap.

Action: Check the partition names (subname attribute of the direct path

* context) being loaded. Make sure you are not loading a table,

* and a partition of the same table. Make sure you are not

* loading a partition, and a sub-partition within the same

* partition.

ORA-26083: unsupported direct path stream version string
Cause: The stream version requested is not supported by the server.
Action: Check to make sure that the VERSION attribute of the direct

* stream is not being set to an invalid value.

ORA-26084: direct path context already finished
Cause: An OCIDirPathLoadStream operation was attempted after

* OCIDirPathFinish was called. Once a direct path operaton

* has been finished, no more data can be loaded.

Action: Check program logic to make sure OCIDirPathLoadStream is

* not called after OCIDirPathFinish.

ORA-26085: direct path operation must start its own transaction
Cause: A direct path operation is being attempted within a transaction

* that has already been started.

Action: Commit the transaction and Prepare the direct path operation again.
ORA-26086: direct path does not support triggers
Cause: A direct path operation is being attempted on a table which

* has enabled triggers.

Action: Disable the triggers on the table and try again.
ORA-26088: scalar column "string" must be specified prior to LOB columns
Cause: All scalar columns (i.e. non-LOB and non-LONG columns) must be

* specified by the client of the direct path API prior to

* specifying any LOB columns.

Action: Specify all scalar columns prior to specifying any LOB columns.
ORA-26089: LONG column "string" must be specified last
Cause: A client of the direct path API specified a LONG column to be

* loaded, but the LONG column was not the last column to be

* specified.

Action: Specify the LONG column last.
ORA-26090: row is in partial state
Cause: A direct path operation is being finished or a data save request

* has been made, but the table for which the request is being made

* on has a row in partial state. The row must be completed before

* the segment high water marks can be moved.

Action: Either complete the row, or abort the direct path operation.
ORA-26091: requested direct path operation not supported
Cause: A direct path operation was requested that is not supported
Action: Do not use that operation. Currently, UNLOAD is not supported.
ORA-26092: only LONG or LOB types can be partial
Cause: A column which is not a LONG or LOB had the

* OCI_DIRPATH_COL_PARTIAL flag associated with it.

* Only LONG or LOB type columns can be loaded in pieces.

Action: Do not use the OCI_DIRPATH_COL_PARTIAL flag for the column.
ORA-26093: input data column size (number) exceeds the maximum input size (number)
Cause: The user attempted to specify a column size (%d) that exceeded

* the maximum allowable input size (%d)."

Action: Make sure the input column metadata matches the column definition.
ORA-26094: stream format error: input column overflow
Cause: An input stream contained data for more input columns

* than specified by the client of the direct path API.

Action: Make sure that the stream being loaded is for the

* correct table. Check initialization sequence.

ORA-26095: unprocessed stream data exists
Cause: Either a OCIDirPathLoadStream call was made which provided

* more stream data prior to the server being able to fully

* process the stream data that it already has, or a

* OCIDirPathFinish call was made when the server had

* unprocessed stream data.

Action: Most likely an application mis-use of the direct path API.

* Make sure that the stream is not being reset inadvertently

* prior to any previous stream data being processed, or, that

* OCIDirPathFinish is not being called prematurely (i.e. stream

* pushed, error encountered and LoadStream not called to process

* the remainder of the stream before Finish is called.)

ORA-26096: transfer size too small for row data (number bytes required)
Cause: Either the transfer buffer size specified, or the default

* transfer buffer size (if you did not specify a size), is

* too small to contain a single row of the converted row data.

Action: Set the transfer buffer size attribute of the direct path

* context to be larger.

ORA-26097: unsupported conversion for column string (from type number to type number)
Cause: The direct path api does not support the required conversion.
Action: Make sure the types are correct. *
ORA-26098: direct path context is not prepared
Cause: A direct path api function was called with a direct path

* context which has not been prepared.

Action: Make sure all necessary attributes in the direct path

* context have been set, and the context is prepared via

* OCIDirPathPrepare.

ORA-26099: direct path context is already prepared
Cause: OCIDirPathPrepare was called with a context that has already

* been prepared.

Action: Free the direct path context, set necessary attributes, and

* call OCIDirPathPrepare.

ORA-26101: tablespace # in file header is string rather than string for file string
Cause: The tablespace number in the file header is inconsistent with that in the control file.
Action: Check if the control file has been migrated correctly. Retry with the correct control file and data file.
ORA-26102: relative file # in file header is string rather than string for file string
Cause: The relative file number in the file header is inconsistent with that in the control file.
Action: Check if the control file has been migrated correctly. Retry with the correct control file and data file.
ORA-26103: V6 or V7 data file used to create control file
Cause: The file header of the referenced file is in V6 or V7 format.
Action: Either remove the file from the create control file command, or somehow migrate the file header to V8 format.
ORA-26500: error on caching "string"."string"
Cause: Attempt to cache the replication information which is unavailable in the catalog for the object.
Action: Use dbms_reputil.sync_up_rep to validate the replication catalog, or use dbms_reputil.make_internal_pkg to validate internal package.
ORA-26501: RepAPI operation failure
Cause: An external RepAPI operation failed.
Action: consult detail error message.
ORA-26502: error resignal
Cause: An internal service failed and signalled an error"
Action: consult detail error message.
ORA-26503: internal RepAPI operation failure on object string.string
Cause: An unexpected internal RepAPI failure was detected
Action: Contact Oracle support.
ORA-26504: operation not implemented
Cause: The caller requested a RepAPI operation that was not implemented
Action: Do not issue this call.
ORA-26505: unexpected internal null
Cause: An internal buffer control structure was NULL
Action: Verify that sufficient memory resources are available to RepAPI.
ORA-26506: null global context
Cause: An internal buffer control structure was NULL
Action: Verify that sufficient memory resources are available to RepAPI.
ORA-26507: null master connection
Cause: The master connection handle was or became invalid.
Action: Verify that the master connection is valid.
ORA-26508: null materialized view connection
Cause: The client connection handle was or became invalid.
Action: Verify that the client connection is valid.
ORA-26509: null materialized view control structure
Cause: An internal materialized view control structure could not be obtained.
Action: Check that the owner and users provided are correct.
ORA-26510: materialized view name: 'string' is greater than max. allowed length of string bytes
Cause: The specified materialized view name was too long.
Action: Shorten the materialized view name.
ORA-26511: master table 'string.string' not found
Cause: A RepAPI operation was attempted against a non-existent or invalid master table
Action: Verify that the master table object exists.
ORA-26512: error pushing transaction to def$error
Cause: An unexpected error occurred while sending an def$error rpc to the master site
Action: Verify that the DBMS_DEFER package is valid and executable by the RepAPI client. Contact the local or master site administrator, if necessary.
ORA-26513: push error: master proc. string$RP.string failed for trans:string seq:string
Cause: A conflict/error occurred at the master site while executing a $RP.rep_insert(), rep_update(), or rep_delete() function which was not handled by conflict resolution logic at the master.
Action: Notify master site system adminstrator or DBA.
ORA-26514: object 'string.string' not found
Cause: The specified object was expected but not found.
Action: Verify that the specified object exists and is valid.
ORA-26515: no master log available for 'string.string'
Cause: The specified master log was not found or available for the named table.
Action: Create the master log at the master site or correct any problems that may exist with the log.
ORA-26516: no push transaction acknowledgement
Cause: RepAPI was unable to confirm that the last pushed transaction was successfully commited by the master site.
Action: Verify that the communications link between the local site and the master site is still valid. If the transaction has not been committed at the master, repush the transaction.
ORA-26517: materialized view control entry for 'string.string' was not found
Cause: The specified materialized view catalog control reocrd was not found.
Action: Verify that the local materialized view catalog is valid and that the local materialized view is properly defined.
ORA-26518: push queue synchronization error detected
Cause: Client tried to repush a transaction has already been committed at the master site. A common cause of this problem is an error at the local site in initializing or updating the local site transaction sequence mechanism.
Action: Verify that transaction data that RepAPI was attempting to repushed to the master site exists at the master table and is valid and consistent with the local site. If this error occurs, redundantly identified transactions are ignored and then purged from the local updatable materialized view logs. Check that the local site is correctly assigning new transactionIDs and is not accidently generating non-unique values.
ORA-26519: no memory available to allocate
Cause: There was no memory left for the RepAPI process. This error may occur when RepAPI is trying to allocate a new table buffer area.
Action: Shutdown one or more local applications to attempt to free heap memory and retry the RepAPI operation.
ORA-26520: internal memory failure
Cause: An internal memory error was detected.
Action: Check if other errors have occurred or determine if any local application may have corrupted the memory subsystem.
ORA-26521: rpc initialization error
Cause: An error occurred during the initialization of a PL/SQL rpc.
Action: Verify that the procudure to be invoked exists and is valid at the master site and is executable by the RepAPI user.
ORA-26522: rpc execution error
Cause: An error occurred during the execution of a PL/SQL rpc.
Action: Check the error messages from the remote procedure and fix any remote site problems that may be preventing the execution of the invoked rpc.
ORA-26523: rpc termination error
Cause: An error occurred during the termination of a PL/SQL rpc. This is usually caused by master site being unable to close an opened cursor or if RepAPI cannot deallocate internal memory.
Action: Fix any server side problems first, determine if the RepAPI memory subsystem has been corrupted.
ORA-26524: nls subsystem initialization failure for product=string, facility=string
Cause: The NLS product/facility error message file could not be located or properly initialized.
Action: Check that the error message directory and file(s) have been properly installed.
ORA-26525: session connection attempt failed for string (@string)
Cause: A connection could not be established to the specified database using the provided connection string.
Action: Check that the user, password, connect string, names services, network, and any remote site listener process are properly installed and working.
ORA-26526: materialized view sql ddl parse/expansion failed for string.string
Cause: The client sql materialized view definition query could not be properly parsed by the master Oracle site.
Action: Check that materialized view ddl sql is compatible with the currently connected version of Oracle and does not violate any of the RepAPI sql limitations or restrictions.
ORA-26527: local store callback init phase failed for 'string.string'
Cause: The client callback failed during its INIT phase for the named object.
Action: Verify that the objects referenced by the client callback exist and are valid. Refer to the vendor-specific callback error code reference to diagnose the local problem. Record all error state and notify Oracle support.
ORA-26528: local store callback proc phase failed for 'string.string'
Cause: The client callback failed during its PROC phase for the named object.
Action: Refer to the vendor-specific callback error code reference to diagnose the local problem. Record all error state and notify Oracle support.
ORA-26529: local store callback term phase failed for 'string.string'
Cause: The client callback failed during its TERM phase for the named object.
Action: Refer to the vendor-specific callback error code reference to diagnose the local problem. Record all error state and notify Oracle support.
ORA-26530: unable to build materialized view refresh control list
Cause: The materialized view control list could not be constructed. This is generally the result of an error while accessing the local materialized view catalog.
Action: Verify that the named materialized view(s) are properly defined and valid.
ORA-26532: replication parallel push simulated site failure
Cause: A parallel push executed with event 26531 enabled raises this error to simulation failure of network or destination site.
Action: Do not enable the event for normal operation.
ORA-26534: collision: tranID number ignored and purged
Cause: A transaction that was pushed had a transaction ID that collided with a transaction that was previously pushed and committed at the master site.
Action: See the action section for E_QUEUESYNC (26518).
ORA-26535: %ud byte row cache insufficient for table with rowsize=number
Cause: A transaction that was pushed had a transaction ID that collided with a transaction that was previously pushed and committed at the master site.
Action: Increase the RepAPI row buffer size or reduce the width of the replicated tables.
ORA-26536: refresh was aborted because of conflicts caused by deferred transactions
Cause: There are outstanding conflicts logged in the DEFERROR table at the materialized view's master site.
Action: Resolve the conflicts in the master DEFERROR table and refresh again after the table is empty. Alternatively, refresh with REFRESH_AFTER_ERRORS, even if there are conflicts in the master's DEFERROR table. Proceeding despite conflicts can result in an updatable materialized view's changes appearing to be temporarily lost, until a refresh succeeds after the conflicts are resolved.
ORA-26563: renaming this table is not allowed
Cause: Attempt to rename a replicated table, an updatable materialized view table or the master table of a materialized view for which a materialized view log has beencreated.
Action: If desired, unregister the replicated table with dbms_repcat.drop_master_repobject, or use the recommended procedure to rename the master table of a materialized view.
ORA-26564: %s argument is not of specified type
Cause: User passed type of the given argument number doesn't match with the type of the argument in the stored arguments.
Action: Invoke correct type procedure (i.e. get_XXX_arg)
ORA-26565: Call to <type>_arg made before calling dbms_defer.call
Cause: User invoked <type>_arg procedure before starting a deferred call
Action: Invoke various procedures in the correct order.
ORA-26566: Couldn't open connect to string
Cause: Failed to open connection using given dblink
Action: Make sure that the dblink is valid and remote m/c is up.
ORA-26571: %s.string.string: number of arguments (string) does not match replication catalog
Cause: number of arguments does not match replication catalog
Action: examine total number of arguments for the rpc call
ORA-26572: %s.string.string: argument string does not match replication catalog
Cause: the (rpc) call is corrupted
Action: examine total number of arguments and each argument for the rpc call
ORA-26575: remote database does not support replication parallel propagation
Cause: The remote database has a version lower than Oracle 8.0 and hence does not understand replication parallel propagation.
Action: Use serial propagation or upgrade the remote database to Oracle 8.0 or above.
ORA-26576: cannot acquire SR enqueue
Cause: An attempt to acquire the SR enqueue in exclusive mode failed.
Action: none
ORA-26577: PRESERVE TABLE can not be used when dropping old style materialized view string.string
Cause: The materialized view consists of a view and a container table.
Action: Drop the materialized view without PRESERVE TABLE option.
ORA-26650: %s background process string might not be started successfully
Cause: An error occurred during creation of a capture or apply background process.
Action: Please review V$Capture and V$Apply_coordinator views for the status of these processes. Please also check the trace file for more information.
ORA-26660: Invalid action context value for string
Cause: The value specified in the action context is invalid for use in STREAMS.
Action: Check that the type and value are correct.
ORA-26662: unable to process STREAMS Data Dictonary information for object
Cause: The database is unable to process STREAMS Data Dictionary for this object.
Action: Check that the compatibility for the database supports the object, and check the trace file for information about the object.
ORA-26663: error queue for apply process string must be empty
Cause: The error queue for this apply process contains error entries.
Action: Execute or delete errors in the error queue.
ORA-26664: cannot create STREAMS process string
Cause: An attempt was made to create a STREAMS process when another was being created concurrently.
Action: Wait for the creation of the other STREAMS process to finish before attempting to create the STREAMS process.
ORA-26665: STREAMS process string already exists
Cause: An attempt was made to create a STREAMS process that already exists.
Action: Either specify another STREAMS process or remove the existing STREAMS process.
ORA-26666: cannot alter STREAMS process string
Cause: An attempt was made to alter a STREAMS process that is currently running.
Action: Stop the STREAMS process and reissue the command.
ORA-26667: invalid STREAMS parameter string
Cause: An attempt was made to specify an invalid parameter.
Action: Check the documentation for valid parameters.
ORA-26668: STREAMS process string exists
Cause: An attempt to remove the component failed because it is associated with the STREAMS process.
Action: Either remove the process manually or specify the "cascade" option in dbms_streams_adm.remove_queue.
ORA-26669: parameter string inconsistent with parameter string
Cause: An attempt was made to specify a subprogram parameter value that is inconsistent with another parameter value.
Action: Check the documentation for valid parameter values.
ORA-26670: STREAMS option requires COMPATIBLE parameter to be string or higher
Cause: Streams requires compatibility to be 9.2.0 or higher.
Action: Shut down and restart with an appropriate compatibility setting.
ORA-26671: maximum number of STREAMS processes exceeded
Cause: Cannot create additional STREAMS processes since the maximum number of STREAMS processes has been reached.
Action: Remove existing STREAMS processes and retry the operation.
ORA-26672: timeout occurred while stopping STREAMS process string
Cause: Timeout occurred while waiting for a STREAMS process to shut down.
Action: Retry the operation. If the error persists, try stopping the process with the FORCE option, or contact Oracle Support Services.
ORA-26675: cannot create Streams capture process string
Cause: Streams capture process could not be created because one or more parameters contain invalid value.
Action: Refer to trace file for more details.
ORA-26677: Streams downstream capture process string cannot proceed
Cause: Database global name has been set to a value which is same as the source database name of the downstream capture process.
Action: Change database global name to a value other than the source database name for the downstream capture.
ORA-26678: Streams capture process must be created first
Cause: Must create Streams capture process before attempting this operation.
Action: Create a Streams capture process, then retry the operation.
ORA-26679: operation not allowed on LOB or LONG columns in LCR
Cause: Certain operations on LOB/LONG columns of the LCR through rule-based transformations, DML handlers, or error handlers were not allowed.
Action: Do not perform restricted operations on LOB or LONG columns in LCRs. See the documentation for operations that are restricted on LOB/LONG columns in LCRs.
ORA-26680: object type not supported
Cause: The specified object type is not supported.
Action: Retry with a supported object type.
ORA-26681: command type not supported
Cause: The specified command type is not supported.
Action: Retry with a supported command type.
ORA-26682: invalid value for publication_on
Cause: The publication_on parameter should be either 'Y' or 'N'
Action: Retry with a proper value for publication_on.
ORA-26683: invalid value for value_type
Cause: The value_type parameter should be either 'OLD' or 'NEW'
Action: Retry with proper value_type.
ORA-26684: invalid value for value_type
Cause: The value_type parameter should be one of 'OLD', 'NEW' or '*'
Action: Retry with proper value_type.
ORA-26685: cannot apply transactions from multiple sources
Cause: Transactions from multiple sources were sent to the same apply process.
Action: Create multiple apply processes and create appropriate rules so that transactions from only one source reach an apply process.
ORA-26686: cannot capture from specified SCN
Cause: An attempt was made to specify an invalid SCN.
Action: Retry with a valid SCN.
ORA-26687: no instantiation SCN provided for "string"."string" in source database "string"
Cause: Object SCN was not set. If the object is a table, then both fields will be filled, for example "SCOTT"."EMP". If the object is a schema, only one field will be set, for example "SCOTT"."". And if the object is the entire database, no fields will be set, for example ""."".
Action: Set the SCN by calling DBMS_APPLY_ADM.SET_%_INSTANTIATION_SCN
ORA-26688: missing key in LCR
Cause: Metadata mismatch, or not enough information in the user generated LCR.
Action: Alter the database object, or provide all defined keys in the LCR.
ORA-26689: column datatype mismatch in LCR
Cause: The datatypes of columns in the LCR are not the same as the datatypes in the database object.
Action: Alter the database object.
ORA-26690: datatype not supported at non-Oracle system
Cause: One of the columns of the LCR being applied was of a datatype not supported by either the target non-Oracle system or by the Oracle transparent gateway through which the apply is being done.
Action: Do not apply data of this type. If possible, filter out columns containing such datatypes before applying.
ORA-26691: operation not supported at non-Oracle system
Cause: The apply process attempted an operation that is either not supported by the non-Oracle system or by the Oracle transparent gateway through which the apply is being done. Some kinds of DML (like procedure and function calls) and all DDL will cause this error to be raised.
Action: Do not attempt to apply such LCRs to non-Oracle systems. If possible, filter out such LCRs before applying.
ORA-26692: invalid value string, string should be in string format
Cause: The parameter specified was not in the correct format.
Action: Specify the parameter value in the correct format.
ORA-26693: STREAMS string process dropped successfully, but error occurred while dropping rule set string
Cause: An attempt to drop an unused rule set failed after dropping the STREAMS proccess successfully.
Action: Check existence of rule set and manually drop if necessary.
ORA-26694: error while enqueueing into queue string.string
Cause: An error occurred while enqueueing a message.
Action: If the situation described in the next error on the stack can be corrected, do so.
ORA-26695: error on call to string: return code string
Cause: A locking related call failed.
Action: Try the call again after fixing the condition indicated by the return code.
ORA-26696: no streams data dictionary for object with number string and version number string from source database string
Cause: An attempt to access the database object failed because the data dictionary for the object was either never populated or it was purged.
Action: Make sure the streams data dictionary is created by calling DBMS_CAPTURE_ADM.PREPARE_%_INSTANTIATION.
ORA-26698: %s did not have a string rule set
Cause: The STREAMS client does not have a rule set of the indicated type.
Action: Verify that the Streams client has a rule set of the specified type, and retry the operation.
ORA-26699: STREAMS message consumer string already exists
Cause: An attempt was made to create a STREAMS message consumer that already exists.
Action: Either specify another STREAMS message consumer or remove the existing STREAMS message consumer.
ORA-26701: STREAMS process string does not exist
Cause: An attempt was made to access a STREAMS process which does not exist.
Action: Check with the relevant security views for the correct name of the object.
ORA-26705: cannot downgrade capture process after Streams data dictionary has been upgraded
Cause: An attempt was made to downgrade a capture process after it has upgraded the Streams data dictionary.
Action: Drop the capture process before attempting the downgrade.
ORA-26706: cannot downgrade capture process
Cause: An attempt was made to downgrade a capture process that has a higher version than the downgrade release version.
Action: Drop the capture process after capture has finished consuming all the redo logs before attempting the downgrade.
ORA-26708: remote DDL not supported by STREAMS : dblink string
Cause: The apply process attempted to apply a DDL LCR via a dblink. This is not supported.
Action: Do not attempt to apply DDL LCRs via a dblink. If possible, filter out DDL LCRs before applying.
ORA-26710: incompatible version marker encountered during Capture
Cause: Capture process cannot mine redo from a version higher than the current software release version.
Action: Drop and recreate the capture process.
ORA-26711: remote table does not contain a primary key constraint
Cause: The master table for remote apply does not constain a primary key constraint or the primary key constraint has been disabled.
Action: Create a primary key constraint on the master table or enable the existing constraint.
ORA-26712: remote object is "string"."string"\@"string"
Cause: See the preceding error message to identify the cause. This message names the remote object, usually a table or view, for which an error occurred when Streams tried to access it for remote apply.
Action: See the preceding error message.
ORA-26713: remote object does not exist or is inaccessible
Cause: Streams replication could not access the named table or view at a remote database to apply changes.
Action: Confirm that the given remote table or view exists and is accessible through the given database link. When using a Heterogeneous Services database link to access a non-Oracle system, it may be necessary to check administration details for network connections at the non-Oracle system.
ORA-26714: User error encountered while applying
Cause: An error was encountered while applying.
Action: Query the dba_apply_error view to determine the error and take the appropriate action.
ORA-26715: time limit reached
Cause: The specified time limit was reached for the STREAMS process.
Action: Restart the STREAMS process, increasing the TIME_LIMIT parameter if necessary.
ORA-26716: message limit reached
Cause: The specified message limit was reached for the Capture process.
Action: Restart the Capture process, increasing the MESSAGE_LIMIT parameter if necessary.
ORA-26717: SCN limit reached
Cause: The specified SCN limit was reached for the STREAMS process.
Action: Change the MAXIMUM_SCN parameter, then restart the STREAMS process.
ORA-26718: transaction limit reached
Cause: The specified transaction limit was reached for the Apply process.
Action: Restart the Apply process, increasing the TRANSACTION_LIMIT parameter if necessary.
ORA-26721: enqueue of the LCR not allowed
Cause: An apply process attempted to enqueue an LCR with a LONG column. This is not supported.
Action: Modify rules or unset the enqueue destination to prevent LCRs with LONG columns from being enqueued by the apply process.
ORA-26723: user "string" requires the role "string"
Cause: The user was not granted the specified role required to proceed.
Action: Grant the specified role to the user.
ORA-26724: only SYS is allowed to set the Capture or Apply user to SYS.
Cause: The Capture or Apply user was specified as SYS by a user other than SYS.
Action: Set SYS as the Capture or Apply user while logged in as SYS.
ORA-26725: cannot downgrade apply handlers
Cause: An attempt was made to downgrade apply handlers that are not associated with a local database object, or the apply handlers are associated with a specific apply process.
Action: Drop the associated apply handlers before attempting the downgrade.
ORA-27000: skgfqsbi: failed to initialize storage subsystem (SBT) layer
Cause: sbtinit returned an error, additional information indicates error
Action: verify that vendor's storage subsystem product is operating correctly
ORA-27001: unsupported device type
Cause: the specified device type is supported on this platform
Action: check V$BACKUP_DEVICE for supported device types
ORA-27002: function called with invalid device structure
Cause: internal error, aditional information indicates which function encountered error
Action: check for trace file and contact Oracle Support
ORA-27003: cannot open file on device allocated with NOIO option
Cause: internal error, a file is being created/retrieved on a device allocated with NOIO option, additional information indicates which function encountered error
Action: check for trace file and contact Oracle Support
ORA-27004: invalid blocksize specified
Cause: internal error, blocksize specified is incorrect for the device on which file is being created, aditional information indicates blocksize specified, and the function that encountered the error
Action: check for trace file and contact Oracle Support
ORA-27005: cannot open file for async I/O on device not supporting async
Cause: internal error, a file is being opened for async I/O on a device that does not support async I/O, additional information indicates which function encountered error
Action: check for trace file and contact Oracle Support
ORA-27006: sbtremove returned error
Cause: additional information indicates error returned by sbtremove, and the function that encountered the error
Action: verify that vendor's storage subsystem product is operating correctly
ORA-27007: failed to open file
Cause: sbtopen returned error, additional information indicates error returned from sbtopen, and the function that encountered the error
Action: verify that vendor's storage subsystem product is operating correctly
ORA-27008: function called with invalid file structure
Cause: internal error, aditional information indicates which function encountered error
Action: check for trace file and contact Oracle Support
ORA-27009: skgfwrt: cannot write to file opened for read
Cause: internal error
Action: check for trace file and contact Oracle Support
ORA-27010: skgfwrt: write to file failed
Cause: sbtwrite returned error, additional information indicates error returned from sbtwrite
Action: verify that vendor's storage subsystem product is operating correctly
ORA-27011: skgfrd: cannot read from file opened for write
Cause: internal error
Action: check for trace file and contact Oracle Support
ORA-27012: skgfrd: read from file failed
Cause: sbtread returned error, additional information indicates error returned from sbtread
Action: verify that vendor's storage subsystem product is operating correctly
ORA-27013: skgfqdel: cannot delete an open file
Cause: internal error
Action: check for trace file and contact Oracle Support
ORA-27014: skgfqpini: translation error while expanding SS_UDMPDIR
Cause: Failure of sltln in skgfqpini
Action: Check additional return error for more information.
ORA-27015: skgfcls: failed to close the file
Cause: sbtclose returned error, additional information indicates error returned from sbtclose
Action: verify that vendor's storage subsystem product is operating correctly
ORA-27016: skgfcls: sbtinfo returned error
Cause: additional information indicates error returned from sbtinfo
Action: verify that vendor's storage subsystem product is operating correctly
ORA-27017: skgfcls: media handle returned by sbtinfo exceeds max length(SSTMXQMH)
Cause: media handle string length exceeds SSTMXQMH
Action: verify that vendor's storage subsystem product is operating correctly, and that the platform limit (SSTMXQMH) is atleast 64 (the limit specified for sbtinfo). additional information indicates the media handle string length returned by sbtinfo, and the limit (SSTMXQMH)
ORA-27018: BLKSIZE is not a multiple of the minimum physical block size
Cause: User-specified BLKSIZE (blocking factor) is not a multiple of the minimum block size that is permitted on this platform.
Action: Two ADDITIONAL INFORMATION messages are displayed which show the blocking factor provided by the user and the minimum physical block size. Specify a BLKSIZE that is an integral multiple of the minimum block size.
ORA-27019: tape filename length exceeds limit (SBTOPMXF)
Cause: length of tape filename provided to sequential I/O OSD functions is too long
Action: additional information indicates in which function this error is encountered, the length of filename provided, and the limit on filename
ORA-27020: named devices not supported
Cause: the platform or the specified device type does not support named devices
Action: do not specify device name or use a device type that supports named devices. Use V$BACKUP_DEVICE view to see what device types and names (if any) are available.
ORA-27021: sequential file handle must be specified
Cause: The filename which will be passed to sbtopen was not specified.
Action: Specify a filename and continue. If this is a backup set being created via Recovery Manager, use the 'format' option to specify the backup piece handle name.
ORA-27022: skgfqsbi: could not allocate memory for media manager
Cause: Oracle could not allocate memory required by the media management software which is linked with Oracle to provide backup/restore services.
Action: Increase the amount of memory available to the Oracle process and retry the backup/restore.
ORA-27023: skgfqsbi: media manager protocol error
Cause: The media management software which is linked with Oracle to provide backup/restore services did not provide its function pointer structure to Oracle.
Action: This is an internal error in the media management product. Contact the media management vendor.
ORA-27024: skgfqsbi: sbtinit2 returned error
Cause: sbtinit2 returned an error. This happens during a backup or restore operation.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27025: skgfqsbi: invalid media manager context area size
Cause: The media management software requested a context area size which is greater than the maximum allowable size.
Action: This is an internal error in the media management product. Contact the media management vendor.
ORA-27026: skgfrls: sbtend returned error
Cause: sbtend returned an error. This happens during a backup or restore operation.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27027: sbtremove2 returned error
Cause: sbtremove2 returned an error. This happens when deleting a backup file.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27028: skgfqcre: sbtbackup returned error
Cause: sbtbackup returned an error. This happens when creating a backup file during a backup operation.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27029: skgfrtrv: sbtrestore returned error
Cause: sbtrestore returned an error. This happens when retrieving a backup file during a restore operation.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27030: skgfwrt: sbtwrite2 returned error
Cause: sbtwrite2 returned an error. This happens while writing a backup file during a backup operation.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27031: mirror resilvering functions not supported
Cause: internal error
Action: check for trace file and contact Oracle Support
ORA-27032: failed to obtain file size limit
Cause: getrlimit system call returned an error
Action: check errno
ORA-27033: failed to obtain file size limit
Cause: ulimit system call returned an error
Action: check errno
ORA-27034: maximum length of ORACLE_SID exceeded
Cause: too many characters in the ORACLE_SID string
Action: rename the ORACLE_SID to a string of up to the maximum number of characters specified for your system
ORA-27035: logical block size is invalid
Cause: logical block size for oracle files must be a multiple of the physical block size, and less than the maximum
Action: block size specified is returned as additional information, check init.ora parameters, additional information also indicates which function encountered the error
ORA-27036: translation error, unable to expand file name
Cause: additional information indicates sltln/slnrm error, and also indicates which function encountered the error
Action: check additional information
ORA-27037: unable to obtain file status
Cause: stat system call returned an error, additional information indicates which function encountered the error
Action: check errno
ORA-27038: created file already exists
Cause: trying to create a database file, but file by that name already exists
Action: verify that name is correct, specify reuse if necessary
ORA-27039: create file failed, file size limit reached
Cause: an attempt was made to create a file that exceeds the process's file size limit, additional information indicates which function encountered the error
Action: raise the file size limit
ORA-27040: file create error, unable to create file
Cause: create system call returned an error, unable to create file
Action: verify filename, and permissions
ORA-27041: unable to open file
Cause: open system call returned an error, additional information indicates which function encountered the error
Action: check errno
ORA-27042: not enough space on raw partition to fullfill request
Cause: internal error, file too large for raw partition, additional information indicates which function encountered the error
Action: check for trace file and contact Oracle Support
ORA-27043: unable to seek to beginning of file
Cause: seek system call failed, additional information indicates which function encountered the error
Action: check errno
ORA-27044: unable to write the header block of file
Cause: write system call failed, additional information indicates which function encountered the error
Action: check errno
ORA-27045: unable to close the file
Cause: close system call failed, additional information indicates which function encountered the error
Action: check errno
ORA-27046: file size is not a multiple of logical block size
Cause: file size as indicated by stat is not correct, additional information indicates which function encountered the error
Action: verify that the file has not been overwritten or truncated
ORA-27047: unable to read the header block of file
Cause: read system call failed, additional information indicates which function encountered the error
Action: check errno
ORA-27048: skgfifi: file header information is invalid
Cause: possibly trying to use a non-database file as a database file
Action: verify that file is a database file
ORA-27049: unable to seek to and read the last block
Cause: an attempt was made to seek to and read the last block in file, additional information indicates which function encountered error
Action: check errno
ORA-27050: function called with invalid FIB/IOV structure
Cause: internal error, aditional information indicates which function encountered error
Action: check for trace file and contact Oracle Support
ORA-27052: unable to flush file data
Cause: fsync system call returned error, additional information indicates which function encountered the error
Action: check errno
ORA-27053: blocksize in file header not a multiple of logical block size
Cause: the logical block size is invalid, additional information indicates the logical block size and the blocksize in the file header
Action: use a different logical block size, or do not reuse file
ORA-27056: could not delete file
Cause: unlink system call returned error
Action: check errno
ORA-27057: cannot perform async I/O to file
Cause: internal error, query is being asked about async vector I/O when the file does not support async I/O
Action: check for trace file and contact Oracle Support
ORA-27058: file I/O question parameter is invalid
Cause: internal error, invalid query is being asked
Action: check for trace file and contact Oracle Support
ORA-27059: could not reduce file size
Cause: ftruncate system call returned error
Action: check errno
ORA-27060: could not set close-on-exec bit on file
Cause: fcntl system call returned error
Action: check errno
ORA-27061: waiting for async I/Os failed
Cause: aiowait function returned error
Action: check errno
ORA-27062: could not find pending async I/Os
Cause: There should have been some async I/Os in the system but a blocking aiowait indicates that there are no more I/Os. It could be either because of an Oracle bug or the vendor OS bug or due to a NFS server not responding
Action: check Oracle trace file, OS message files and contact Oracle Support
ORA-27063: number of bytes read/written is incorrect
Cause: the number of bytes read/written as returned by aiowait does not match the original number, additional information indicates both these numbers
Action: check errno
ORA-27064: cannot perform async I/O to file
Cause: internal error, asked to perform async I/O when IOV indicates that it cannot be performed on the file
Action: check for trace file and contact Oracle Support
ORA-27065: cannot perform async vector I/O to file
Cause: internal error, asked to perform async vector I/O when it cannot be performed on the file
Action: check for trace file and contact Oracle Support
ORA-27066: number of buffers in vector I/O exceeds maximum
Cause: internal error, number of buffers in vector I/O exceeds maximum allowed by the OSD, additional information indicates both these numbers
Action: check for trace file and contact Oracle Support
ORA-27067: size of I/O buffer is invalid
Cause: internal error, buffer size is either 0, or greater than SSTIOMAX or not a multiple of logical block size, additional information indicates where in function the error was encountered and the buffer size
Action: check for trace file and contact Oracle Support
ORA-27068: I/O buffer is not aligned properly
Cause: internal error, buffer is not aligned to SSIOALIGN boundary, additional information indicates where in function the error was encountered and the buffer pointer
Action: check for trace file and contact Oracle Support
ORA-27069: attempt to do I/O beyond the range of the file
Cause: internal error, the range of blocks being read or written is outside the range of the file, additional information indicates the starting block number, number of blocks in I/O, and the last valid block in the file
Action: check for trace file and contact Oracle Support
ORA-27070: async read/write failed
Cause: aioread/aiowrite system call returned error, additional information indicates starting block number of I/O
Action: check errno
ORA-27071: unable to seek to desired position in file
Cause: lseek system call returned error, additional information indicates block number in file to which seek was attempted
Action: check errno
ORA-27072: File I/O error
Cause: read/write/readv/writev system call returned error, additional information indicates starting block number of I/O
Action: check errno
ORA-27073: Trying to close a file which has async I/Os pending to be dequeued
Cause: internal error, the file is being closed but not all async I/Os to the file have been dequeued, additional information indicates number of I/Os pending on the file
Action: check for trace file and contact Oracle Support
ORA-27074: unable to determine limit for open files
Cause: The getrlimit() system call returned an error.
Action: Check errno.
ORA-27075: SSTMOFRC constant too large
Cause: internal error
Action: check for trace file and contact Oracle Support
ORA-27076: unable to set limit for open files
Cause: The setrlimit() system call returned an error.
Action: Check errno.
ORA-27077: too many files open
Cause: internal error, the number of files opened through skgfofi has reached the limit
Action: Check for trace file and contact Oracle Support.
ORA-27078: unable to determine limit for open files
Cause: The getrlimit() system call returned an error.
Action: Check errno.
ORA-27080: too many files open
Cause: The number of files opened has reached the system limit.
Action: Check the error, and set system configuration values.
ORA-27081: unable to close the file
Cause: The close() system call failed.
Action: Check errno.
ORA-27083: waiting for async I/Os failed
Cause: The aio_waitn() library call returned an error.
Action: Check errno.
ORA-27084: unable to get/set file status flags
Cause: The fcntl() system call with F_GETFL/F_SETFL flag returned an error.
Action: Check errno.
ORA-27086: unable to lock file - already in use
Cause: the file is locked by another process, indicating that it is currently in use by a database instance.
Action: determine which database instance legitimately owns this file.
ORA-27087: unable to get share lock - file not readable
Cause: share lock request was made on a file not open for read access.
Action: file must be open read-only or read-write to get a share lock.
ORA-27088: unable to get file status
Cause: file not open or file descriptor is invalid.
Action: none
ORA-27089: unable to release advisory lock
Cause: release of file lock failed
Action: see errno
ORA-27091: unable to queue I/O
Cause: read/write/readv/writev system call returned error, additional information indicates starting block number of I/O
Action: check errno
ORA-27092: size of file exceeds file size limit of the process
Cause: an attempt was made to open a file that exceeds the process's file size limit (ulimit), additional information shows the current limit (logical blocks) and the size of the file (logical blocks)
Action: increase the processes file size limit (ulimit) and retry
ORA-27093: could not delete directory
Cause: rmdir system call returned error
Action: check errno
ORA-27100: shared memory realm already exists
Cause: Tried to start duplicate instances, or tried to restart an instance that had not been properly shutdown
Action: Use a different instance name, or cleanup the failed instance's SGA
ORA-27101: shared memory realm does not exist
Cause: Unable to locate shared memory realm
Action: Verify that the realm is accessible
ORA-27102: out of memory
Cause: Out of memory
Action: Consult the trace file for details
ORA-27103: internal error
Cause: internal error
Action: contact Oracle support
ORA-27120: unable to removed shared memory segment
Cause: shmctl() call failed
Action: check permissions on segment, contact Oracle support
ORA-27121: unable to determine size of shared memory segment
Cause: shmctl() call failed
Action: check permissions on segment, contact Oracle support
ORA-27122: unable to protect memory
Cause: mprotect() call failed
Action: contact Oracle support
ORA-27123: unable to attach to shared memory segment
Cause: shmat() call failed
Action: check permissions on segment, contact Oracle support
ORA-27124: unable to detach from shared memory segment
Cause: shmdt() call failed
Action: contact Oracle support
ORA-27125: unable to create shared memory segment
Cause: shmget() call failed
Action: contact Oracle support
ORA-27126: unable to lock shared memory segment in core
Cause: insufficient privileges to lock shared memory segment in core
Action: make sure process is running with necessary privileges.
ORA-27127: unable to unlock shared memory segment
Cause: insufficient privileges to unlock shared memory segment
Action: make sure process is running with necessary privileges.
ORA-27128: unable to determine pagesize
Cause: sysconf() call failed
Action: contact Oracle support
ORA-27141: invalid process ID
Cause: process operation attempted using invalid process ID
Action: contact Oracle Support
ORA-27142: could not create new process
Cause: OS system call
Action: check errno and if possible increase the number of processes
ORA-27143: OS system call failure
Cause: OS system call failed
Action: check errno and contact Oracle support
ORA-27144: attempt to kill process failed
Cause: OS system call error
Action: check errno and contact Oracle Support
ORA-27145: insufficient resources for requested number of processes
Cause: OS system call error
Action: check errno and contact Oracle Support
ORA-27146: post/wait initialization failed
Cause: OS system call failed
Action: check errno and contact Oracle Support
ORA-27147: post/wait reset failed
Cause: OS system call failed
Action: check errno and contact Oracle Support
ORA-27148: spawn wait error
Cause: OS system call failed
Action: check errno and contact Oracle Support
ORA-27149: assignment out of range
Cause: internal error, requested conversion too large for type
Action: contact Oracle Support
ORA-27150: attempt to notify process of pending oradebug call failed
Cause: OS system call
Action: check errno contact Oracle Support
ORA-27151: buffer not large enough to hold process ID string
Cause: internal error
Action: contact Oracle Support
ORA-27152: attempt to post process failed
Cause: OS system call failed
Action: check errno and contact Oracle Support
ORA-27153: wait operation failed
Cause: OS system called failed
Action: check errno contact Oracle Support
ORA-27154: post/wait create failed
Cause: internal error, multiple post/wait creates attempted simultaneously
Action: check errno and contact Oracle Support
ORA-27155: could not execute file
Cause: OS system call failed
Action: check errno and contact Oracle Support
ORA-27156: request for process information failed
Cause: internal error
Action: contact Oracle Support
ORA-27157: OS post/wait facility removed
Cause: the post/wait facility for which the calling process is awaiting
Action: check errno and contact Oracle Support
ORA-27158: process control failure
Cause: Oracle was unable to set the specified process control.
Action: Consult the Oracle Administrator's Guide.
ORA-27159: failure setting process scheduling priority
Cause: Oracle was unable to set the scheduling priority desired.
Action: Consult the Oracle Administrator's Guide.
ORA-27160: process requested to perform operation
Cause: The current process was requested to perform an operation by another process.
Action: This is used internally; no action is required.
ORA-27190: skgfrd: sbtread2 returned error
Cause: sbtread returned an error. This happens while reading a backup file during a restore operation.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27191: sbtinfo2 returned error
Cause: sbtinfo2 returned an error. This happens while retrieving backup file information from the media manager's catalog.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27192: skgfcls: sbtclose2 returned error - failed to close file
Cause: sbtclose2 returned an error. This happens while closing a backup file during a backup or restore operation.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27193: sbtinfo2 did not return volume label
Cause: sbtinfo2 did not return the volume label information for the backup file that was just created.
Action: This is an internal error in the media management product. Contact the media management vendor.
ORA-27194: skgfdvcmd: sbtcommand returned error
Cause: sbtcommand returned an error. This happens when an rman SEND command is issued.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27195: proxy copy not supported
Cause: An attempt was made to do a proxy backup or restore, but the media management software installed with Oracle does not support proxy copy.
Action: Re-run the backup in non-proxy mode, or contact the media management vendor if the software is supposed to support proxy copy.
ORA-27196: skgfpbk: sbtpcbackup returned error
Cause: sbtpcbackup returned an error. This happens when a proxy backup is begun.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27197: skgfprs: sbtpcrestore returned error
Cause: sbtpcrestore returned an error. This happens when a proxy restore is begun.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27198: skgfpvl: sbtpcvalidate returned error
Cause: sbtpcvalidate returned an error. This happens during a proxy backup or restore.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27199: skgfpst: sbtpcstatus returned error
Cause: sbtpcstatus returned an error. This happens during a proxy backup or restore.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27200: skgfpgo: sbtpcstart returned error
Cause: sbtpcstart returned an error. This happens during a proxy backup or restore.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27201: skgfpcm: sbtpccommit returned error
Cause: sbtpccommit returned an error. This happens during a proxy backup or restore.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27202: skgfpen: sbtpcend returned error
Cause: sbtpcend returned an error. This happens during a proxy backup or restore.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27203: skgfpqb: sbtpcquerybackup returned error
Cause: sbtpcquerybackup returned an error. This happens during a proxy backup.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27204: skgfpqr: sbtpcqueryrestore returned error
Cause: sbtpcqueryrestore returned an error. This happens during a proxy restore.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27205: skgfpcn: sbtpccancel returned error
Cause: sbtpccancel returned an error. This happens during a proxy restore.
Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.
ORA-27206: requested file not found in media management catalog
Cause: A backup file used in a recovery manager catalog maintenance command was not found in the media management catalog.
Action: Retry the command with a different file.
ORA-27207: syntax error in device PARMS - parentheses mismatch or missing
Cause: User-supplied PARMS value has incorrect syntax.
Action: Retry the command with correct syntax: ENV=(..) BLKSIZE=nnnn
ORA-27208: syntax error in device PARMS - environment variable value missing
Cause: User-supplied PARMS value has incorrect syntax.
Action: Retry the command with correct syntax: ENV=(var1=val1,var2=val2,..)
ORA-27209: syntax error in device PARMS - unknown keyword or missing =
Cause: User-supplied PARMS value has incorrect syntax. The server expected to find ENV or BLKSIZE, but found an unknown keyword.
Action: Retry the command with correct syntax: ENV=(..) BLKSIZE=nnnn
ORA-27210: syntax error in device PARMS
Cause: User-supplied PARMS value has incorrect syntax.
Action: Retry the command with correct syntax: ENV=(..) BLKSIZE=nnnn
ORA-27211: Failed to load Media Management Library
Cause: User-supplied SBT_LIBRARY or libobk.so could not be loaded. Call to dlopen for media library returned error. See Additional information for error code.
Action: Retry the command with proper media library. Or re-install Media management module for Oracle.
ORA-27212: some entrypoints in Media Management Library are missing
Cause: media library does not have one of the following entrypoints : sbtinfo, sbtread, sbtwrite, sbtremove, sbtopen, sbtclose, sbtinit
Action: Retry the command with proper media library.
ORA-27213: failed to unload Media Management Library
Cause: dlclose for media library returned error. See Additional Additional information for error code.
Action: contact Oracle Support.
ORA-27214: skgfrsfe: file search failed
Cause: The FindNextFile function returned unxpected error.
Action: Check errors on the error stack for an explanation why the search for files could not be successfully executed.
ORA-27215: skgfgsmcs: sbtinfo2 returned unknown file
Cause: During an sbtinfo2() call, the media management software returned information about an unknown backup file.
Action: Contact the media management vendor.
ORA-27216: skgfgsmcs: sbtinfo2 returned a malformed response
Cause: The media management software returned a malformed response during an sbtinfo2() call.
Action: Contact the media management vendor.
ORA-27230: OS system call failure
Cause: OS system call failed
Action: check errno and contact Oracle support
ORA-27250: OS system call failure
Cause: OS system call failed
Action: check errno and contact Oracle support
ORA-27300: OS system dependent operation:string failed with status: string
Cause: OS system call error
Action: contact Oracle Support
ORA-27301: OS failure message: string
Cause: OS system call error
Action: contact Oracle Support
ORA-27302: failure occurred at: string
Cause: OS system call error
Action: contact Oracle Support
ORA-27303: additional information: string
Cause: OS system call error
Action: contact Oracle Support
ORA-27365: job has been notified to stop, but failed to do so immediately
Cause: The job specified in the stop_job command cannot be stopped immediately(because it is rolling back or blocked on a network operation), but it has been notified to stop. This means it will be stopped as soon as possible after its current uninterruptable operation is done.
Action: No action is required for the job to be stopped, but calling stop_job with force (if you have the privilege) may cause the job to be stopped sooner.
ORA-27366: job "string.string" is not running
Cause: An attempt was made to stop a job that was not running.
Action: Verify the status of the job. If the job is running but this message is still being returned, contact Oracle support.
ORA-27367: program "string.string" associated with this job is disabled
Cause: An attempt was made to run a job whose program has been disabled.
Action: Reenable the program before running the job.
ORA-27369: job of type EXECUTABLE failed with exit code: string
Cause: A problem was encountered while running a job of type EXECUTABLE. The cause of the actual problem is identified by the exit code.
Action: Correct the cause of the exit code and reschedule the job.
ORA-27370: job slave failed to launch a job of type EXECUTABLE
Cause: The scheduler ran into an error when the job slave tried to start a job of type EXECUTABLE. The rest of the error stack will provide more detailed information on what the exact problem was.
Action: Correct the problem specified in the error stack and reschedule the job.
ORA-27371: jobs of type EXECUTABLE are not supported on this platform
Cause: The user tried to create a job or program of type EXECUTABLE on a platform where such jobs are not supported.
Action: Switch to a different platform or create a different type of job or program.
ORA-27372: length of action and arguments exceeds platform limit string
Cause: The total length of the job or program action and the arguments exceeds the platform limit specified.
Action: Reduce the total length by specifying fewer and/or shorter arguments
ORA-27411: An empty string is not a valid repeat interval.
Cause: An empty string '' was provided as a repeat interval for a window or a schedule.
Action: Specify a valid repeat interval, e.g., 'FREQ=DAILY;BYHOUR=8;BYMINUTE=0;BYSECOND=0' for a job that executes daily at 8am.
ORA-27412: repeat interval contains invalid keyword: string
Cause: The calendar string for the repeat interval of a job, schedule, or window contained an unsupported keyword.
Action: Correct the repeat interval such that it no longer contains the invalid keyword.
ORA-27413: repeat interval is too long
Cause: The repeat interval consisted of a calendar string larger than the maximum size allowed.
Action: Use a shorter calendar string for the repeat interval.
ORA-27414: Invalid BY value type
Cause: The type of BY value was not allowed for the frequency specified
Action: Ommit BY values of this type or alter the frequency
ORA-27415: repeat interval must start with the FREQ= clause
Cause: The specified calendar string for the repeat interval did not start with the frequency clause.
Action: Create a repeat interval that starts with a frequency clause, e.g. 'FREQ=YEARLY;BYMONTH=FEB'
ORA-27416: BYDAY= clause in repeat interval contains an invalid weekday
Cause: The BYDAY clause of the repeat interval contained a value that doesn't properly represent a weekday.
Action: Use the correct three letter abbreviations for weekdays, e.g. MON for Monday and FRI for Friday.
ORA-27417: BYWEEKNO clause is only supported when FREQ=YEARLY
Cause: A repeat interval calendar string contained a BYWEEKNO clause with a frequency other than yearly.
Action: Remove the BYWEEKNO clause or change the frequency to yearly.
ORA-27418: syntax error in repeat interval
Cause: The repeat interval could not be recognized as a valid syntax.
Action: Specify a valid repeat interval.
ORA-27419: unable to determine valid execution date from repeat interval
Cause: The specified repeat interval contained conflicting clauses that made it impossible to ever find a matching date, e.g., 'FREQ=YEARLY;BYMONTH=FEB;BYMONTHDAY=31'. Alternatively, the scheduler reached its maximum number of attempts to try to find a valid execution date. This occurs when theoretically there is a valid execution date far in the future, but the scheduler took too many attempts to determine this date.
Action: Remove the conflicting clauses, or simplify the repeat interval so that it is easier to determine the next execution date.
ORA-27451: %s cannot be NULL
Cause: An attempt was made to set a NOT NULL scheduler attribute to NULL.
Action: Reissue the command using a non-NULL value for the specified attribute.
ORA-27452: %s is an invalid name for a database object.
Cause: An invalid name was used to identify a database object.
Action: Reissue the command using a valid name.
ORA-27453: %s is an invalid job or program argument name.
Cause: An invalid job or program argument name was specified.
Action: Reissue the command using a valid name for this argument.
ORA-27454: argument name and position cannot be NULL
Cause: The name or position of a program or job argument was defined as NULL.
Action: Reissue the command providing either a valid argument name or valid argument position.
ORA-27455: Only "SYS" is a valid schema for a string.
Cause: A non-SYS schema was specified for an object that must be in the SYS schema.
Action: Reissue the command, leaving out the schema name or using the schema name of SYS.
ORA-27456: not all arguments of program "string.string" have been defined
Cause: The number_of_arguments attribute of the named program did not match the actual number of arguments that have been defined.
Action: Define as many arguments as the number of arguments, or change the number of arguments.
ORA-27457: argument string of job "string.string" has no value
Cause: No value was provided for the job argument with the specified position.
Action: Provide a value for the job argument using any of the set_job_xxxx_value() routines. Or, when using a named program, specify a default value for the corresponding argument of the program.
ORA-27458: A program of type PLSQL_BLOCK cannot have any arguments.
Cause: An attempt was made to create or enable a program of type PLSQL_BLOCK with arguments. This is not allowed.
Action: Change the number of arguments to zero, or change the type of the program.
ORA-27459: A program of type EXECUTABLE must have character-only arguments.
Cause: A program of type EXECUTABLE was created or enabled with one or more arguments of non-character datatypes.
Action: Change the arguments to be of character-only datatypes.
ORA-27460: cannot execute disabled job "string.string"
Cause: An attempt was made to run a job that is disabled.
Action: Enable the job and then reschedule the job.
ORA-27461: The value for attribute string is too large.
Cause: The value that was provided for the specified attribute was too large.
Action: Reissue the command using a smaller or shorter value.
ORA-27463: invalid program type string
Cause: An invalid program type was specified.
Action: Reissue the command using a valid program type.
ORA-27464: invalid schedule type string
Cause: An invalid schedule type was specified.
Action: Reissue the command using a valid schedule type.
ORA-27465: invalid value string for attribute string
Cause: An invalid value was provided for the specified attribute.
Action: Reissue the command using a valid value for this attribute.
ORA-27467: invalid datatype for string value
Cause: The value provided for the named scheduler attribute was of an invalid datatype.
Action: Reissue the command using a value of the correct datatype.
ORA-27468: "string.string" is locked by another process
Cause: An attempt was made to read or modify the state of the named scheduler object when another process was also updating the same object and held the lock.
Action: Retry the operation. Scheduler locks are held for a very short duration. If the error persists, contact Oracle Support.
ORA-27469: %s is not a valid string attribute
Cause: A non-existant attribute was specified.
Action: Reissue the command using a valid attribute for that specific scheduler object.
ORA-27470: failed to re-enable "string.string" after making requested change
Cause: A change was made to an enabled scheduler object that caused it to become disabled.
Action: Alter the object so that it becomes valid and then enable it.
ORA-27471: window "string.string" is already closed
Cause: An attempt was made to close a window that was not open.
Action: No action required.
ORA-27472: invalid metadata attribute string
Cause: An invalid metadata attribute was specified.
Action: Reissue the command using a valid metadata attribute.
ORA-27473: argument string does not exist
Cause: An argument which was specified does not exist.
Action: Reissue the command using an argument name defined by the program or using a valid argument position.
ORA-27474: cannot give both an argument name and an argument position
Cause: An argument was specified using both a name and a position.
Action: Reissue the command using either the argument name or the argument position but not both.
ORA-27475: "string.string" must be a string
Cause: An object of the wrong type was specified. For example, a table could have been passed to the drop_job() procedure.
Action: Reissue a different command applicable to this object type or reissue the same command using an object of the valid type.
ORA-27476: "string.string" does not exist
Cause: A database object was specified that does not exist.
Action: Reissue the command using an object that exists or create a new object and then reissue this command.
ORA-27477: "string.string" already exists
Cause: An attempt was made to create an object with a name that has already been used by another object in the same schema.
Action: Reissue the command using a different name or schema.
ORA-27478: job "string.string" is running
Cause: An attempt was made to drop a job that is currently running.
Action: Stop the job and then reissue the command, or reissue the command specifying the force option to stop the job first.
ORA-27479: Cannot string "string.string" because other objects depend on it
Cause: An attempt was made to drop or disable a scheduler object that has jobs associated with it without specifying the force option.
Action: Alter the associated jobs so they do not point to the scheduler object being dropped or disabled and then reissue the command. Alternatively reissue the command specifying the force option. If the force option is specified and a scheduler object is being dropped, all associated jobs will be disabled.
ORA-27480: window "string" is currently open
Cause: An attempt was made to drop a window that is currently open, or to manually open a window while another window is already open.
Action: Close the window that is open and then reissue the command, or reissue the command while setting the force option to TRUE.
ORA-27481: "string.string" has an invalid schedule
Cause: An attempt was made to enable a job or window that has an invalid schedule.
Action: Alter the schedule of the job or window so that it is valid and then reissue the enable command.
ORA-27483: "string.string" has an invalid END_DATE
Cause: An attempt was made to enable a job or window that has an invalid end_date. Either the end_date is before the start_date or the end_date is in the past.
Action: Alter the job or window so that the end date becomes valid (possibly null) and then reissue the command.
ORA-27484: Argument names are not supported for jobs without a program.
Cause: An attempt was made to set or reset a job argument by using the name of the argument. Identifying job arguments by their name is only supported in combination with jobs that are based on programs. Jobs that are not using a program cannot have named arguments.
Action: Use argument position instead of name and then issue the command again.
ORA-27485: argument string already exists at a different position
Cause: An attempt was made to create or replace an argument with a name that is already used by an argument at a different position.
Action: Use a different name for the argument or drop or alter the argument which already exists with this name and then reissue the command.
ORA-27486: insufficient privileges
Cause: An attempt was made to perform a scheduler operation without the required privileges.
Action: Ask a sufficiently privileged user to perform the requested operation, or grant the required privileges to the proper user(s).
ORA-27487: invalid object privilege for a string
Cause: The granted object privilege is not valid for the specified scheduler object.
Action: Check the scheduler documentation to verify which object privileges can be granted on which scheduler objects.
ORA-27488: unable to set string because string was/were already set
Cause: An attempt was made to set an object's attribute even though one or more conflicting attributes of the same object had already been set.
Action: Set the other conflicting attributes to NULL and then reissue the command.
ORA-27489: unable to process job "string.string" from job class "string"
Cause: An error was encountered while processing the named job from the specified job class.
Action: Resolve the error for this job and then reissue the command. See the next error message on the stack to find out what the error for the job is.
ORA-27490: cannot open disabled window "string.string"
Cause: The user tried to open a disabled window.
Action: Enable the window and then try to open it again.
ORA-27491: repeat_interval and start_date cannot both be NULL
Cause: An attempt was made to set both repeat_interval and start_date to equal NULL for a Scheduler window or schedule.
Action: If either repeat_interval or start_date is set to equal NULL, the other should be set to a non-NULL value.
ORA-27500: inter-instance IPC error
Cause: This is an operating system/cluster interconnect error.
Action: Check the extra information and contact Oracle Support Services.
ORA-27501: IPC error creating a port
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27502: IPC error deleting OSD context
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27503: IPC error attempting to cancel request
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27504: IPC error creating OSD context
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27505: IPC error destroying a port
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27506: IPC error connecting to a port
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27507: IPC error disconnecting from a port
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27508: IPC error sending a message
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27509: IPC error receiving a message
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27510: IPC error waiting for a request to complete
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27542: Failed to unprepare a buffer prepared for remote update
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27543: Failed to cancel outstanding IPC request
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27544: Failed to map memory region for export
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27545: Fail to prepare buffer for remote update
Cause: This is an operating system/cluster interconnect error.
Action: Check the value of errno and contact Oracle Support Services.
ORA-27546: Oracle compiled against IPC interface version string.string found version string.string
Cause: A misconfiguration or installation error occurred.
Action: Install the IPC library for this release of Oracle.
ORA-27547: Unable to query IPC OSD attribute string
Cause: This is an operating system-dependent IPC error.
Action: Contact Oracle support Services.
ORA-27548: Unable to unprepare IPC buffer
Cause: This is an operating system-dependent IPC error.
Action: Contact Oracle support Services.
ORA-28000: the account is locked
Cause: The user has entered wrong password consequently for maximum number of times specified by the user's profile parameter FAILED_LOGIN_ATTEMPTS, or the DBA has locked the account
Action: Wait for PASSWORD_LOCK_TIME or contact DBA
ORA-28001: the password has expired
Cause: The user's account has expired and the password needs to be changed
Action: change the password or contact the DBA
ORA-28002: the password will expire within string days
Cause: The user's account is about to about to expire and the password needs to be changed
Action: change the password or contact the DBA
ORA-28003: password verification for the specified password failed
Cause: The new password did not meet the necessary complexity specifications and the password_verify_function failed
Action: Enter a different password. Contact the DBA to know the rules for choosing the new password
ORA-28004: invalid argument for function specified in PASSWORD_VERIFY_FUNCTION string
Cause: The password verification function does not have the required number and type of input/output arguments and/or the return argument
Action: Check the manual to find out the format of the password verification function
ORA-28005: invalid logon flags
Cause: The flags are not properly set or conflicting flags are set in making calls
Action: Call the function with appropriate flags set.
ORA-28006: conflicting values for parameters string and string
Cause: The parameters PASSWORD_REUSE_TIME and PASSWORD_REUSE_MAX cannot both be set. One parameter should be unlimited while other is set
Action: Set one value to UNLIMITED explicitly
ORA-28007: the password cannot be reused
Cause: The password cannot be reused for the specified number of days or for the specified nunmber of password changes
Action: Try the password that you have not used for the specified number of days or the specified number of password changes Refer to the password parameters in the CREATE PROFILE statement
ORA-28008: invalid old password
Cause: old password supplied is wrong; Hence user cannot be authenticated using old password
Action: Supply the correct old password for authentication
ORA-28009: connection to sys should be as sysdba or sysoper
Cause: connect sys/<password> is no longer a valid syntax
Action: Try connect sys/<password> as sysdba or connect sys/<password> as sysoper
ORA-28010: cannot expire external or global accounts
Cause: If a user account is created as IDENTIFIED EXTERNALLY, or IDENTIFIED GLOBALLY, this account cannot be expired
Action: Try to expire the password of the user that has database password
ORA-28011: the account will expire soon; change your password now
Cause: The user's account is marked for expir; the expiry period is unlimited.
Action: Change the password or contact the DBA.
ORA-28012: Manual commit not allowed here
Cause: An attempt was made to commit a non-autonomous transaction from within a change password trigger or password verification routine
Action: Remove the COMMIT from the password trigger or password verification routine
ORA-28020: IDENTIFIED GLOBALLY already specified
Cause: The IDENTIFIED GLOBALLY clause was specified twice.
Action: Use only one IDENTIFIED GLOBALLY clause.
ORA-28021: cannot grant global roles
Cause: A role granted was IDENTIFIED GLOBALLY. Global roles can only be granted via a central authority for the domain.
Action: Use ALTER ROLE to change the type of role (from IDENTIFIED GLOBALLY to other, such as IDENTIFIED BY password), or allocate it to a global user via the central authority.
ORA-28022: cannot grant external roles to global user or role
Cause: A role granted was IDENTIFIED EXTERNALLY. External roles cannot be granted to global users or global roles.
Action: Use ALTER ROLE to change the type of the role being granted (from IDENTIFIED EXTERNALLY to other, such as IDENTIFIED BY password), or use ALTER ROLE or ALTER USER to change the type of the user or role that is the grantee.
ORA-28023: must revoke grants of this role to other user(s) first
Cause: The role altered to IDENTIFIED GLOBALLY was granted to one or more other users and/or roles. Global roles cannot be granted to any user or role.
Action: Use REVOKE to revoke the role from other users or roles first.
ORA-28024: must revoke grants of external roles to this role/user
Cause: The user or role altered to IDENTIFIED GLOBALLY has external roles directly granted - these must be revoked, since external roles cannot be granted to global users or roles.
Action: Use REVOKE to revoke the external roles from the user or role to be ALTERed.
ORA-28025: missing or null external name
Cause: The IDENTIFIED EXTERNALLY AS or IDENTIFIED GLOBALLY AS clause was specified with a valid external name.
Action: Provide a valid external name.
ORA-28026: user with same external name already exists
Cause: The external name specified for the user being created or altered already exists for another user.
Action: External names must be unique among users. Specify another.
ORA-28027: privileged database links may be used by global users
Cause: Only users IDENTIFIED GLOBALLY may use a privileged database link.
Action: Either change the user to a global user or try to use a different database link.
ORA-28028: could not authenticate remote server
Cause: During the course of opening a privileged database link, the remote server was not securely identified using the network security service. Additional errors should follow.
Action: Consult the network security service documentation on how to properly configure the remote server.
ORA-28029: could not authorize remote server for user string
Cause: During the course of opening a privileged database link, the remote server was found to lack the necessary authorizations to connect as the current global user. This may be because the server was not authorized by the network security service. Or it may be because the local server is restricting access by the remote server using the DBMS_SECURITY_DOMAINS_ADMIN package.
Action: Grant the remote server the proper authorization to connect as the given global user, and check that the local server is not restricting access.
ORA-28030: Server encountered problems accessing LDAP directory service
Cause: Unable to access LDAP directory service
Action: Please contact your system administrator
ORA-28031: maximum of string enabled roles exceeded
Cause: The user attempted to enable too many roles.
Action: Enable fewer roles.
ORA-28035: Cannot Get Session Key for Authentication
Cause: Client and server cannot negotiate shared secret during logon
Action: User should not see this error. Please contact your system administrator
ORA-28037: Cannot Get Session Key for RACF Authentication
Cause: Client and server cannot negotiate shared secret during logon
Action: User should not see this error. Please contact your system administrator
ORA-28038: disallow O2LOGON
Cause: turn off O2LOGON
Action: none
ORA-28039: cannot validate Kerberos service ticket
Cause: The Kerberos service ticket provided was invalid or expired
Action: Provide a valid, unexpired service ticket.
ORA-28040: No matching authentication protocol
Cause: No acceptible authentication protocol for both client and server
Action: Administrator should set SQLNET_ALLOWED_LOGON_VERSION parameter on both client and servers to values that matches the minimum version supported in the system.
ORA-28041: Authentication protocol internal error
Cause: Authentication protocol failed with an internal error
Action: none
ORA-28042: Server authentication failed
Cause: Server failed to authenticate itself to the client
Action: Confirm that the server is a valid database server.
ORA-28043: invalid bind credentials for DB-OID connection
Cause: The Database password stored in the wallet did not match the one in OID .
Action: Use DBCA to reset the database password so that it is the same in database wallet and in OID.
ORA-28044: unsupported directory type
Cause: The database tried to work with a directory which is not OID.
Action: Enterprise User Security works only with Oracle Internet Directory. Update the ldap.ora file to reflect an appropriate OID.
ORA-28045: SSL authentication between database and OID failed
Cause: Server failed to authenticate itself to the Directory.
Action: Make sure the sqlnet.ora used is pointing to the wallet with the right certificate.
ORA-28046: Password change for SYS disallowed
Cause: REMOTE_LOGIN_PASSWORDFILE is set to SHARED, prohibiting SYS password changes.
Action: Change setting of REMOTE_LOGIN_PASSWORDFILE to EXCLUSIVE or NONE.
ORA-28047: database is not a member of any enterprise domain in OID
Cause: An enterprise user login was attempted on a database that is not a member of any enterprise domain in OID.
Action: An administrator should put the database into an enterprise domain in OID, and then the user should reconnect.
ORA-28100: policy function schema string is invalid
Cause: The schema was dropped after the policy associated with the function had been added to the object.
Action: Drop the policy and re-create it with a policy function owned by a valid user. Or re-create the user and the policy function under the new user.
ORA-28101: policy already exists
Cause: A policy with the same name for the same object already exists.
Action: Check if the policy has already been added or use a different policy name.
ORA-28102: policy does not exist
Cause: Try to drop/enable/refresh a non-existent policy.
Action: Correct the policy name argument.
ORA-28103: adding a policy to an object owned by SYS is not allowed
Cause: Try to add a policy to a table or a view owned by SYS.
Action: You can not perform this operation.
ORA-28104: input value for string is not valid
Cause: Input value for the argument is not valid
Action: specify a valid argument value.
ORA-28105: cannot create security relevant column policy in an object view
Cause: Security relevant column argument is not null in policy creation for an object view
Action: none
ORA-28106: input value for argument #string is not valid
Cause: Input values for the argument is missing or invalid.
Action: Correct the input values.
ORA-28107: policy was disabled
Cause: Try to flush a disabled policy.
Action: If the policy is supposed to be enforced, it must be enabled.
ORA-28108: circular security policies detected
Cause: Policies for the same object reference each other.
Action: Drop the policies
ORA-28109: the number of related policies has exceeded the limit of 16
Cause: Too many policies are involved in the same objects.
Action: Drop one or more policies. Or combine a few of them into one.
ORA-28110: policy function or package string.string has error
Cause: The policy function may have been dropped, or is no longer valid.
Action: Check the status of the function and correct the problem. Or re-create the policy with a valid function.
ORA-28111: insufficient privilege to evaluate policy predicate
Cause: Predicate has a subquery which contains objects that the owner of policy function does not have privilege to access.
Action: Grant appropriate privileges to the policy function owner.
ORA-28112: failed to execute policy function
Cause: The policy function has one or more error during execution.
Action: Check the trace file and correct the errors.
ORA-28113: policy predicate has error
Cause: Policy function generates invalid predicate.
Action: Review the trace file for detailed error information.
ORA-28115: policy with check option violation
Cause: Policy predicate was evaluated to FALSE with the updated values.
Action: none
ORA-28116: insufficient privileges to do direct path access
Cause: Users with insufficient privileges attempting to do direct path access of tables with fine grain access control policies.
Action: Ask the database administrator to do the operation. Note that users can work with security administrator to temporarily drop/disable the policies at time of export, import, or load, but this has security implication, and thus access of the database must be controlled carefully.
ORA-28117: integrity constraint violated - parent record not found
Cause: try to update/insert a child record with new foreign key values, but the corresponding parent row is not visible because of fine-grained security in the parent.
Action: make sure that the updated foreign key values must also visible in the parent
ORA-28118: policy group already exists
Cause: try to create a policy group that already exists
Action: none
ORA-28119: policy group does not exist
Cause: try to drop a policy group that does not exist
Action: none
ORA-28120: driving context already exists
Cause: try to create a driving context that already exists
Action: none
ORA-28121: driving context does not exist
Cause: try to drop a driving context that does not exist
Action: none
ORA-28132: Merge into syntax does not support security policies.
Cause: Merge into syntax currently does not support a security policy on the destination table.
Action: use the insert / update DML stmts on the table that has a security policy defined on it.
ORA-28134: object cannot have fine-grained access control policy
Cause: Only tables, views, or synonyms of tables or views may have VPD policies
Action: none
ORA-28137: Invalid FGA audit Handler
Cause: An invalid audit handler was specified.
Action: Specify a valid audit handler.
ORA-28138: Error in Policy Predicate
Cause: An invalid policy predicate was specified.
Action: Please specify a valide policy Predicate for the FGA policy
ORA-28139: Maximum allowed Fine Grain Audit Policies Exceeded
Cause: A maximum of 256 policies can be enabled on an object
Action: Drop or disable an existing policy before creating more
ORA-28140: Invalid column specified
Cause: Column name specified during policy creation is invalid
Action: Please specify a valid column name. Object columns are not supported
ORA-28150: proxy not authorized to connect as client
Cause: A proxy user attempted to connect as a client, but the proxy was not authorized to act on behalf of the client.
Action: Grant the proxy user permission to perform actions on behalf of the client by using the ALTER USER ... GRANT CONNECT command.
ORA-28151: more than one user name specified for command
Cause: More than one user name was specified for an ALTER USER command.
Action: Try the command again with only one user name.
ORA-28152: proxy user 'string' may not specify initial role 'string' on behalf of client 'string'
Cause: A proxy user attempted to specify an initial role for a client, but the client does not possess the role.
Action: Change the proxy user so that it does not specify the role or grant the role to the client.
ORA-28153: Invalid client initial role specified: 'string'
Cause: A role specified by a proxy user as an initial role to be activated upon connecting on behalf of a client is invalid.
Action: Connect again as the client specifying a valid role.
ORA-28154: Proxy user may not act as client 'string'
Cause: A proxy user may not assume the identity of a privileged user in order to limit the privileges that a proxy may possess.
Action: Execute the statement again specify a client other than a privileged user.
ORA-28155: user 'string' specified as a proxy is actually a role
Cause: A user specified in an AUDIT <operation> BY <proxy> ON BEHALF OF <client> is actually a role.
Action: Execute the statement again with a valid proxy user.
ORA-28156: Proxy user 'string' not authorized to set role 'string' for client 'string'
Cause: A proxy user has not been granted the right to use a role on behalf of a client.
Action: Execute the command ALTER USER <client> GRANT CONNECT THROUGH PROXY <proxy> to grant the needed role.
ORA-28157: Proxy user 'string' forbidden to set role 'string' for client 'string'
Cause: A proxy user was forbidden to use a role on behalf of a client through the command ALTER USER <client> GRANT CONNECT THROUGH <proxy> WITH ALL ROLES EXCEPT <role>
Action: Execute the command ALTER USER <client> GRANT CONNECT THROUGH PROXY <proxy> to grant the needed role.
ORA-28163: GRANT already specified
Cause: The GRANT clause was specified twice.
Action: Use only one GRANT clause.
ORA-28164: REVOKE already specified
Cause: The REVOKE clause was specified twice.
Action: Use only one REVOKE clause.
ORA-28165: proxy 'string' may not specify password-protected role 'string' for client 'string'
Cause: A proxy user attempted to activate a role on behalf of a client which has a password associated with it. Since the proxy does not have a password, this activation cannot be allowed.
Action: Attempt to activate a different role or change the role administratively so that there is no password.
ORA-28166: duplicate rolename in list
Cause: The name of a role was specified more than once in a list.
Action: Repeat the command specifying the role once.
ORA-28168: attempted to grant password-protected role
Cause: An ALTER USER ... GRANT CONNECT command was attempted specifying a role that is protected by a password as a role which the proxy may execute on behalf of a client.
Action: Either specify a role that does not have a password or alter the role so that a password is not required.
ORA-28169: unsupported certificate type
Cause: The type of certificate from which the server is to extract the credentials of the client is not supported.
Action: Specify a supported type.
ORA-28170: unsupported certificate version
Cause: The version of the certificate from which the server is to extract the credentials of the client is not supported.
Action: Specify a supported version.
ORA-28171: unsupported Kerberos version
Cause: the version the Kerberos ticket which the server is to use to validate the identity of the client is not supported.
Action: Specify a supported version.
ORA-28172: distinguished name not provided by proxy
Cause: A client user is to be identified using a distinguished name, but none was provided by the proxy user.
Action: Provide a distinguished name.
ORA-28173: certificate not provided by proxy
Cause: A client user is to be identified using a certificate but none was provided by the proxy user.
Action: Provide a certificate.
ORA-28174: Kerberos ticket not provided by proxy
Cause: A client user is to be authenticated using a Kerberos ticket but none was provided by the proxy user.
Action: Provide a Kerberos ticket.
ORA-28175: incorrect certificate type
Cause: the type of certificate provided by the proxy user to identify a client user does not match the type that is required.
Action: Provide a certificate of the correct type.
ORA-28176: incorrect certificate version
Cause: the version of certificate provided by the proxy user to identify a client user does not match the version that is required.
Action: Provide a certificate of the correct version.
ORA-28177: incorrect Kerberos ticket version
Cause: the version of Kerberos ticket provided by the proxy user to authenticate a client user does not match the version that is required.
Action: Provide a Kerberos ticket of the correct version.
ORA-28178: password not provided by proxy
Cause: A client user is to be authenticated using a database password but none was provided by the proxy user.
Action: Provide a password.
ORA-28179: client user name not provided by proxy
Cause: No user name was provided by the proxy user for the client user.
Action: Either specify a client database user name, a distinguished name or an X.509 certificate.
ORA-28180: multiple authentication methods provided by proxy
Cause: More than one authentication method was specified by the proxy user for the client user.
Action: Specify only one of the following: a client database user name, a distinguished name or an X.509 certificate.
ORA-28181: proxy 'string' failed to enable one or more of the specified initial roles for client 'string'
Cause: Attempt to enable specified initial roles after logon resulted in failure.
Action: Check that the initial roles are valid, granted to client, and not password protected.
ORA-28182: cannot acquire Kerberos service ticket for client
Cause: An attempt to use a Kerberos forwardable ticket granting ticket to obtain a Kerberos service ticket failed.
Action: Check that the Kerberos forwardable ticket granting ticket belongs to the client, is valid, and that the key distribution center is available.
ORA-28183: proper authentication not provided by proxy
Cause: A client user must be authenticated but no authentication credentials were provided by the proxy user.
Action: Provide some form of authentication credentials.
ORA-28200: IDENTIFIED USING already specified
Cause: The IDENTIFIED USING clause was specified twice.
Action: Use only one IDENTIFIED USING clause.
ORA-28201: Not enough privileges to enable application role 'string'
Cause: An attempt to enable application role outside the scope of the designated package
Action: Enable the role directly or indirectly using the designated package
ORA-28221: REPLACE not specified
Cause: User is changing password but password verification function is turned on and the original password is not specified and the user does not have the alter user system privilege.
Action: Supply the original password.
ORA-28231: no data passed to obfuscation toolkit
Cause: A NULL value was passed to a function or procedure.
Action: Make sure that the data passed is not empty.
ORA-28232: invalid input length for obfuscation toolkit
Cause: Length of data submitted for encryption or decryption is not a multiple of 8 bytes.
Action: Make sure that the length of the data to be encrypted or decrypted is a multiple of 8 bytes.
ORA-28233: double encryption not supported
Cause: The obfuscation toolkit does not support the encryption of already-encrypted data.
Action: Do not attempt to encrypt already-encrypted data.
ORA-28234: key length too short
Cause: The key specified is too short for the algorithm. DES requires a key of at least 8 bytes. Triple DES requires a key of least 16 bytes in two-key mode and 24 bytes in three-key mode.
Action: Specify a longer key.
ORA-28235: algorithm not available
Cause: The encryption algorithm desired is not available.
Action: Run the installer to install the needed algorithm in Oracle Advanced Security.
ORA-28236: invalid Triple DES mode
Cause: An unknown value was specified for the mode in which triple DES encryption is to run.
Action: Specify a valid value. See the package declaration for a list of valid values.
ORA-28237: seed length too short
Cause: The seed specified for the key generation routine must be at least 80 characters.
Action: Specify a longer seed.
ORA-28238: no seed provided
Cause: A NULL value was passed in as the seed to be used in generating a key.
Action: Provide a non-NULL value for the seed.
ORA-28239: no key provided
Cause: A NULL value was passed in as a encryption or decryption key.
Action: Provide a non-NULL value for the key.
ORA-28261: CURRENT_USER can not be used in PLSQL Definer's Right procedure.
Cause: An attempt to retrieve CURRENT_USER using SYS_CONTEXT PLSQL interface.
Action: Use a SQL statement to query CURRENT_USER inside a DR procedure.
ORA-28262: global_context_pool_size has invalid value.
Cause: Parameter global_context_pool_size has a value less than the minimum required value (10K).
Action: Please specify a value for the init.ora parameter global_context_pool_size which is atleast 10k.
ORA-28263: Insufficient memory in global context pool
Cause: Allocations for the global context heap exceeded the value set in init.ora.
Action: Increase the value of global_context_pool_size parameter in init.ora or clear usused global context.
ORA-28264: Client identifier is too long
Cause: The length of the client identifier is longer than 64
Action: Set a client identifier whose length is less than 64.
ORA-28265: NameSpace beginning with 'sys_' is not allowed
Cause: Namespace beginning with 'sys_' is not allowed.
Action: Use a namespace that does not begin with 'sys_'.
ORA-28267: Invalid name for NameSpace
Cause: Context NameSpace conflicts with reserved key words.
Action: Use a NameSpace that does not use reserved key words.
ORA-28270: Malformed user nickname for password authenticated global user.
Cause: An attempt to login as password-auuthenticated global user with a malformed user nickname.
Action: Make sure the nickname is valid and re-login.
ORA-28271: No permission to read user entry in LDAP directory service.
Cause: ORACLE server does not have read permission on user nickname's X.500 user entry.
Action: Make sure ORACLE server is using right SSL credentials to connect to LDAP directory services. Make sure permissions for LDAP user entries are right.
ORA-28272: Domain policy restricts password based GLOBAL user authentication.
Cause: Domain policy does not allow password-authenticated GLOBAL users.
Action: Make sure ORACLE server is using right SSL credentials to connect to LDAP directory services. Make sure orclDBAuthTypes attributes within Oracle enterprise domain object is either set to PWD or ALL.
ORA-28273: No mapping for user nickname to LDAP distinguished name exists.
Cause: ORACLE server cannot map the given user nickname to LDAP distinguished name.
Action: Make sure user entries in LDAP are correctly provisioned with correct user nickname attribute values.
ORA-28274: No ORACLE password attribute corresponding to user nickname exists.
Cause: LDAP user entry corresponding to user nickname does not have a ORACLE password attribute or the attribute is not initialized.
Action: Make sure user entries in LDAP are correctly provisioned with correct ORACLE password attribute values.
ORA-28275: Multiple mappings for user nickname to LDAP distinguished name exist.
Cause: The given user nickname maps to more than one LDAP distinguished name.
Action: Make sure user nickname is unique within the enterprise.
ORA-28276: Invalid ORACLE password attribute.
Cause: The ORACLE password attribute of a user entry has an invalid format.
Action: Make sure ORACLE password attribute value is RFC-2307 compliant.
ORA-28277: LDAP search, while authenticating global user with passwords, failed.
Cause: The LDAP search for finding the appropriate user entry and ORACLE password failed.
Action: Make sure LDAP directory service is up and running.
ORA-28278: No domain policy registered for password based GLOBAL users.
Cause: No policy about password authenticated GLOBAL users has been registered.
Action: Add attribute orclDBAuthTypes to the database server's Enterprise domain.
ORA-28279: Error reading ldap_directory_access init parameter.
Cause: ldap_directory_access parameter is not specified corrrectly.
Action: Make sure spfile.ora has ldap_directory_access set correctly. Possible correct values are PASSWORD, SSL and NONE.
ORA-28280: Multiple entries for ORACLE database password exist.
Cause: The ORACLE password attribute of a user entry has multiple entries of ORACLE database password.
Action: Make sure ORACLE password attribute has one entry for ORACLE Database password.
ORA-28290: Multiple entries found for the same Kerberos Principal Name
Cause: Multiple user entries has been configured with the same krbPrincipalName
Action: Modify enterprise user's entry to assign its Kerberos principal name Make sure the user entries in LDAP are provisioned correctly.
ORA-28291: No Kerberos Principal Value found.
Cause: Oracle server fails to get value of krbPrincipalName attribute
Action: Make sure user entries are correctly provisioned with correct Kerberos principal value
ORA-28292: No Domain Policy registered for Kerberos based authentication
Cause: The enterprise domain entry is not configured for Kerberos based global authentication.
Action: Modify orclDBAuthType of the database server's enterprise domain entry and assign it "ALL" or "KRB5"
ORA-28293: No matched Kerberos Principal found in any user entry
Cause: Oracle server fails to find the principal in the user search base
Action: Make sure the user search base is correct. Use ESM to configure the enterprise user its Kerberos principal name
ORA-28300: No permission to read user entry in LDAP directory service.
Cause: ORACLE server does not have read permission on user entries.
Action: Make sure ORACLE server is using right credentials to connect to LDAP directory services. Make sure permissions for LDAP user entries are configured correctly.
ORA-28301: Domain Policy hasn't been registered for SSL authentication.
Cause: An attempt was made to authenticate with SSL, but the database enterprise domain was not configured for SSL authentication.
Action: Modify orclDBAuthType of the server's enterprise domain entry and assign it "ALL" or "SSL".
ORA-28302: User does not exist in the LDAP directory service.
Cause: An attempt was made to authenticate with SSL using the user's certificate, but there was no user entry in the LDAP server that matched the user's Distinguished Name.
Action: Add an user entry whose DN matches the user's PKI DN in the LDAP directory.
ORA-28500: connection from ORACLE to a non-Oracle system returned this message:
Cause: The cause is explained in the forwarded message.
Action: See the non-Oracle system's documentation of the forwarded message.
ORA-28501: communication error on heterogeneous database link
Cause: An unexpected communication failure occurred on a heterogeneous database link to a non-Oracle system. The message above will be followed by a second message generated by the connected non-Oracle system.
Action: See the documentation for the non-Oracle system for an explanation of the second error message.
ORA-28502: internal communication error on heterogeneous database link
Cause: A communication error internal to ORACLE's heterogeneous services has occurred.
Action: Contact Oracle customer support.
ORA-28503: bind value cannot be translated into SQL text for non-Oracle system
Cause: A SQL statement used bind variables on a Heterogenous Services database link to a non-Oracle system, but the non-Oracle system does not support bind variables.
Action: Change your SQL statement so that it does not use bind variables.
ORA-28504: ROWID not found in ROWID cache for heterogeneous database link
Cause: The ROWID cache for Heterogeneous Services held no entry that corresponds to the specified ROWID. The ROWID entry may have been overwritten in the ROWID cache.
Action: Enlarge the Heterogeneous Services ROWID cache size by increasing the value of the Heterogenous Services initialization parameter HS_ROWID_CACHE_SIZE.
ORA-28505: cannot get non-Oracle system capabilities from string
Cause: ORACLE was unable to retrieve capability information for the non-Oracle system connected through a heterogeneous database link. This capability information should be stored in data dictionary tables viewable with the HS_CLASS_CAPS or HS_INST_CAPS data dictionary views.
Action: Contact the DBA to check the server data dictionary table named in the error message. If table contents are incorrect, the DBA should restore all data dictionary content for this FDS_CLASS_NAME and/or FDS_INST_NAME. It usually is sufficient to delete all current data dictionary content for this class and/or instance and initiate a new connection to let the connected agent upload new data dictionary content to the server.
ORA-28506: parse error in data dictionary translation for string stored in string
Cause: A reference to an ORACLE data dictionary table or view name on a heterogeneous database link to a non-Oracle system could not be translated. The ORACLE data dictionary tables shown with view HS_CLASS_DD contain invalid SQL for the data dictionary translation.
Action: Contact customer support of the agent vendor.
ORA-28507: error in data dictionary view string
Cause: The initialization parameter table for the Heterogeneous Services was not available, or its structure (number of columns or column types) was incorrect.
Action: Verify correct installation of the following Heterogeneous Services' initialization parameter views: HS_CLASS_INIT and HS_INST_INIT. If these views are not available, make sure you ran the script CATHS.SQL in the $ORACLE_HOME/rdbms/admin directory.
ORA-28508: invalid value string for Heterogeneous Services initialization parameter string
Cause: The specified Heterogeneous Services initialization parameter had an invalid value when attempting to connect to a non-Oracle system.
Action: Check the Heterogeneous Services and agent documentation to determine acceptable values
ORA-28509: unable to establish a connection to non-Oracle system
Cause: Initialization of a database link to a non-Oracle system failed to connect to the Heterogeneous Services agent process for this non-Oracle system.
Action: Check the Net8 service name definition in the following places: -- the USING clause of the CREATE DATABASE LINK statement -- the TNSNAMES.ORA file -- the Oracle Names Server The following are possible reasons for name mismatches: -- The USING clause in the CREATE DATABASE LINK statement has to match the service name defined in the TNSNAMES.ORA file or in the Oracle Names Server. -- The protocol-specific information in the service name definition must match the protocol-specific definition of the responding listener. -- The SID=<name> in the service name definition (in the TNSNAMES.ORA file or in Oracle Names Server) must match the value in the LISTENER.ORA file for the responding listener.
ORA-28510: heterogeneous database link initialization failed
Cause: Initialization of a heterogeneous database link to a non-Oracle system failed due to an error identified by the agent for this non-Oracle system.
Action: Make sure the non-Oracle system is up and running and that all of the environment and initialization values for the agent are set correctly.
ORA-28511: lost RPC connection to heterogeneous remote agent using SID=string
Cause: A fatal error occurred in one of the following places: -- the connection between the ORACLE server and the agent -- the heterogeneous services remote agent itself -- the connection to the non-Oracle system This error occurred after communication had been established successfully.
Action: Check for network problems and remote host crashes. The problem is probably in the agent software. If so, contact a customer support representative of the agent vendor.
ORA-28512: cannot get data dictionary translations from string
Cause: ORACLE was unable to retrieve data dictionary translation information for the non-Oracle system connected through a heterogeneous database link. This data dictionary translation information should be stored in data dictionary tables viewable with the HS_CLASS_DD or HS_INST_DD data dictionary views.
Action: Ask your DBA to check the server data dictionary table named in the error message. If table contents are incorrect, the DBA should restore all data dictionary content for this FDS_CLASS_NAME and/or FDS_INST_NAME. It usually is sufficient to delete all current data dictionary content for this class and/or instance and initiate a new connection to let the connected agent upload new data dictionary content to the server.
ORA-28513: internal error in heterogeneous remote agent
Cause: An internal error has occurred in the Oracle remote agent supporting a heterogeneous database link.
Action: Make a note of how the error was produced and contact the customer support representative of the agent vendor.
ORA-28514: heterogeneous database link initialization could not convert system date
Cause: The system date was not retrievable.
Action: Verify that the ORACLE server's host machine and operating system are operational. This error should not occur unless low level system functions are failing.
ORA-28515: cannot get external object definitions from string
Cause: ORACLE was unable to retrieve definitions of distributed external procedures or remote libraries registered for the non-Oracle system instance, probably because the underlying data dictionary table does not exist or is malformed.
Action: Verify that the ORACLE server's Heterogeneous Services data dictionary was installed correctly. If the Heterogeneous Services data dictionary is not installed, execute the CATHS.SQL script in the $ORACLE_HOME/rdbms/admin directory.
ORA-28518: data dictionary translation has illegal translation type
Cause: A data dictionary translation definition, either in the ORACLE server data dictionary or in data dictionary content uploaded from a Heterogeneous Services agent, specified an illegal translation type code. Legal values are 'T' or 't' for 'translate', 'M' or 'm' for 'mimic'. Information on the exact data dictionary translation causing the error is written to a trace (*.TRC) file for the ORACLE instance and to the ORACLE instance's alert log. This error occurs when a Heterogeneous Services agent uploads data dictionary content to an ORACLE server on the first connection from the server to the agent.
Action: Contact the customer support of the agent vendor.
ORA-28519: no heterogeneous data dictionary translations available
Cause: The ORACLE server's data dictionary did not define data dictionary translations for the connected non-Oracle system, and automatic self-registration (data dictionary upload) was disabled.
Action: Ask a DBA to resolve this problem. The easiest solution is to enable automatic self-registration by setting the ORACLE server's HS_AUTO_REGISTER initialization parameter to TRUE. An alternative is to load the Heterogeneous Services data dictionary with information specific for the non-Oracle system by executing a SQL script supplied by the agent vendor. If the script is run and the error persists, contact the customer support representative of the agent vendor.
ORA-28520: error initializing heterogeneous data dictionary translations
Cause: ORACLE was unable to retrieve data dictionary translations for the non-Oracle system instance, probably because the underlying data dictionary table does not exist or is formed incorrectly.
Action: Verify that the ORACLE server's Heterogeneous Services data dictionary was installed correctly. If the Heterogeneous Services data dictionary is not installed, execute the CATHS.SQL script in the $ORACLE_HOME/rdbms/admin directory. If the connected agent, identified by FDS_CLASS_NAME, requires a custom installation script for the ORACLE server, verify that the script has been run. If both scripts were executed and the error persists, contact the customer support representative of the agent vendor.
ORA-28521: no heterogeneous capability information available
Cause: The ORACLE server's data dictionary did not contain capability definitions for the connected non-Oracle system, and automatic self-registration (data dictionary upload) was disabled.
Action: Ask a DBA to resolve this problem. The easiest resolution is to enable automatic self-registration by setting the ORACLE server's HS_AUTO_REGISTER initialization parameter to TRUE. An alternative is to load the Heterogeneous Services data dictionary with information specific for the non-Oracle system by executing a SQL script supplied by the agent vendor. If the script is run and the error persists, contact the customer support representative of the agent vendor.
ORA-28522: error initializing heterogeneous capabilities
Cause: ORACLE was unable to retrieve capability definitions for the non-Oracle system instance, probably because the underlying data dictionary table does not exist or is formed incorrectly.
Action: Verify that the ORACLE server's Heterogeneous Services data dictionary was installed correctly. If the Heterogeneous Services data dictionary is not installed, execute the CATHS.SQL script in the $ORACLE_HOME/rdbms/admin directory. If the connected agent, identified by FDS_CLASS_NAME, requires a custom installation script for the ORACLE server, verify that the script has been run. If both scripts were executed and the error persists, contact the customer support representative of the agent vendor.
ORA-28523: ORACLE and heterogeneous agent are incompatible versions
Cause: An operation on a database link attempted to connect to a non-Oracle system, but the ORACLE instance and the agent process for the non-Oracle system are incompatible.
Action: Ask your DBA to confirm configuration of both the ORACLE instance and the agent. Additional information on the version incompatibility is logged in trace (*.TRC) files, the ORACLE instance and the agent, and in the ORACLE instance's alert log. Check the documentation for your agent to find out which releases of the Oracle Server are supported.
ORA-28525: unable to create Heterogeneous Services error message text
Cause: Incorrect arguments were passed into the error message creation routine.
Action: Contact Oracle customer support.
ORA-28526: invalid describe information returned to Heterogeneous Services
Cause: The Heterogeneous Services received invalid describe information for a select list, bind list, or stored procedure from the Heterogeneous Services agent. This indicates a problem with the Heterogeneous Services' non-Oracle system agent.
Action: Contact customer support of the agent vendor.
ORA-28527: Heterogeneous Services datatype mapping error
Cause: Either an Oracle datatype could not be mapped to a non-Oracle datatype, or a non-Oracle datatype could not be mapped to an Oracle datatype. These mappings are defined as capability definitions in the ORACLE server's data dictionary.
Action: Verify that the ORACLE server's data dictionary has been initialized with correct capability definitions for the connected FDS_CLASS_NAME and FDS_INST_NAME. If table contents are incorrect, a DBA should restore all data dictionary content for this FDS_CLASS_NAME and/or FDS_INST_NAME. It usually is sufficient to delete all current data dictionary content for this class and/or instance and initiate a new connection to let the connected agent upload new data dictionary content to the server. If the error persists contact the customer support representative of the agent vendor.
ORA-28528: Heterogeneous Services datatype conversion error
Cause: Either an Oracle datatype could not be converted to a non-Oracle datatype, or a non-Oracle datatype could not be converted to an Oracle datatype. The following are possible reasons for for the conversion failure: -- overflow problems (in the case of numbers) -- length limitations (in the case of character strings) -- invalid values passed into the conversion routines
Action: Contact customer support of the agent vendor. If the problem is due to size discrepancies between Oracle and the non-Oracle system, it may not be possible to convert the value.
ORA-28529: invalid or missing parameter in Net8 service name definition
Cause: There was an invalid or missing Heterogeneous Services parameter in the Net8 service name definition stored in either the TNSNAMES.ORA file or in the Oracle Names Server.
Action: Ask your DBA to make sure the information in the Net8 service definition is correct and complete. The correct information that should be included in the Net8 service definition can be found in the agent's documentation.
ORA-28530: Heterogeneous Services initialization error in NLS language ID
Cause: Heterogeneous Services was unable to initialize an NLS language ID. Both the ORACLE server and the Heterogeneous Services agent for the connected non-Oracle system must have language IDs.
Action: Contact Oracle customer support.
ORA-28533: Heterogeneous Services coercion handling error
Cause: The Heterogeneous Services encountered an error in coercion handling. The HS can, if the agent vendor so chooses, perform extra processing on SQL statements that contain implicit coercions or that contain coercion functions such as TO_CHAR, TO_NUMBER or TO_DATE. This functionality is controlled by coercion-related capabilities. HS logic reports this error when it encounters an error in one of these capability definitions.
Action: The capability table settings are controlled by the agent vendor and can be modified by the DBA. Contact your DBA and agent vendor and get the correct set of capabilities installed.
ORA-28534: Heterogeneous Services preprocessing error
Cause: One of the things that the Heterogeneous Services can do is to preprocess parts of SQL statements that contain implicit coercions or calls to explicit coercion functions like TO_CHAR TO_NUMBER or TO_DATE. For example, it could convert a call to TO_DATE to a bind variable, pre-evaluate the TO_DATE function call and pass the resulting value to the non-Oracle system as the bind value. This behavior is controlled by some coercion related capabilities. If the capabilities are set incorrectly, the HS could encounter errors when it attempts to do the preprocessing. If it does then this error will be signaled.
Action: The capability table settings are controlled by the agent vendor and can be modified by the DBA. Contact your DBA and agent vendor and get the correct set of capabilities installed.
ORA-28535: invalid Heterogeneous Services context
Cause: A Heterogeneous Services agent's driver module called an HS service routine with an invalid HS context value. This probably is a logic error in the driver.
Action: Contact Oracle customer support or your agent vendor.
ORA-28536: error in processing Heterogeneous Services initialization parameters
Cause: An error described by a subsequent error message prevented successful processing of Heterogeneous Services initialization parameters from the ORACLE server data dictionary.
Action: Check server data dictionary views HS_CLASS_INIT, HS_INST_INIT, and HS_ALL_INITS. Look for conditions which could produce the error identified in the error message immediately following this one.
ORA-28537: no more result sets
Cause: This error code is used internally within Oracle Transparent Gateway and Heterogeneous Services code and should not be reported to a client program.
Action: Contact Oracle customer support.
ORA-28538: result set not found
Cause: The client program tried fetching from a result set that is not open anymore. Many gateways will, on execution of a stored procedure, automatically close all result sets that were returned by any previously executed stored procedure.
Action: Check the documentation for the gateway that you are using and see if it will automatically close currently open result sets each time a stored procedure is executed. Then check if your client program is doing anything that violates this rule. If it is, fix your program. If it is not then contact Oracle customer support.
ORA-28539: gateway does not support result sets
Cause: The client program tried executing a stored procedure that returns one or more result sets through a gateway that does not have result set support.
Action: Check the documentation for the gateway that you are using and see if it supports result sets returned from stored procedures. If it does not, then the only way of accessing such stored procedures is to upgrade to a version of the gateway that does support result sets (if such a version exists). If the gateway does have result set support and you are still seeing this error then contact Oracle customer support.
ORA-28540: internal result set error
Cause: A protocol error internal to Heterogeneous Services or Transparent Gateway code has occurred.
Action: Contact Oracle customer support.
ORA-28541: Error in HS init file on line number.
Cause: A syntax error occurred in the gateway initialization file.
Action: Check gateway init file to correct the syntax error. For further information, check the error message in the gateway trace file.
ORA-28542: Error in reading HS init file
Cause: Reading the gateway init file generated an error.
Action: Check the gateway initialization file name to see that the gateway initialization file acctually exists. Check the ifile parameter to see that it points to the correct location.
ORA-28543: Error initializing apply connection to non-Oracle system
Cause: Attempt to initialize connection to non-Oracle for heterogeneous replication failed.
Action: Check if the listener used to connect to the gateway is up and is correctly configured. Make sure that the database link used has been configured correctly and, if a tnsnames alias has been used in the database link definition, make sure that the configuration of the entry in tnsnames.ora has been done correctly.
ORA-28544: connect to agent failed, probable Net8 administration error
Cause: Net8 reported a failure to make a RSLV connection or a protocol mode error when the Oracle server attempted to establish communication with a Heterogeneous Services agent or an external procedure agent. This usually is due to an administration error in setting up Net8 service definitions in TNSNAMES.ORA or LISTENER.ORA: A basic network connection is opened, but it connects to a program which does not use the appropriate protocol. This often is a sign that the connection goes to the wrong program.
Action: Check Net8 administration in the following ways: -- When using TNSNAMES.ORA or an Oracle Names server, make sure that the connection from the ORACLE server uses the correct service name or SID. -- Check LISTENER.ORA on the agent's host machine to assure that the service name or SID refers to the correct agent executable in its (PROGRAM=...) clause. -- Confirm in TNSNAMES.ORA or the equivalent service definition that sevice 'extproc_connection_data' does NOT contain (HS=), or that the service definition used by a Heterogeneous Services database link DOES contain (HS=).
ORA-28545: error diagnosed by Net8 when connecting to an agent
Cause: An attempt to call an external procedure or to issue SQL to a non-Oracle system on a Heterogeneous Services database link failed at connection initialization. The error diagnosed by Net8 NCR software is reported separately.
Action: Refer to the Net8 NCRO error message. If this isn't clear, check connection administrative setup in tnsnames.ora and listener.ora for the service associated with the Heterogeneous Services database link being used, or with 'extproc_connection_data' for an external procedure call.
ORA-28546: connection initialization failed, probable Net8 admin error
Cause: A failure occurred during initialization of a network connection from the Oracle server to a second process: The connection was completed but a disconnect occurred while trying to perform protocol-specific initialization, usually due to use of different network protocols by opposite sides of the connection. This usually is caused by incorrect Net8 administrative setup for database links or external procedure calls. The most frequent specific causes are: -- Database link setup for an Oracle-to-Oracle connection instead connects to a Heterogeneous Services agent or an external procedure agent. -- Database link setup for a Heterogeneous Services connection instead connects directly to an Oracle server. -- The extproc_connection_data definition in tnsnames.ora connects to an Oracle instance instead of an external procedure agent. -- Connect data for a Heterogeneous Services database link, usually defined in tnsnames.ora, does not specify (HS=). -- Connect data for an Oracle-to-Oracle database link, usually defined in tnsnames.ora, specifies (HS=).
Action: Check Net8 administration in the following ways: -- When using TNSNAMES.ORA or an Oracle Names server, make sure that the connection from the ORACLE server uses the correct service name or SID. -- Check LISTENER.ORA on the connection end point's host machine to assure that this service name or SID connects to the correct program. -- Confirm in TNSNAMES.ORA or the equivalent service definition that service 'extproc_connection_data' does NOT contain (HS=), or that the service definition used by a Heterogeneous Services database link DOES contain (HS=).
ORA-28547: connection to server failed, probable Net8 admin error
Cause: A failure occurred during initialization of a network connection from a client process to the Oracle server: The connection was completed but a disconnect occurred while trying to perform protocol-specific initialization, usually due to use of different network protocols by opposite sides of the connection. This usually is caused by incorrect Net8 administrative setup for database links or external procedure calls. The most frequent specific causes are: -- The connection uses a connect string which refers to a Heterogeneous Services agent instead of an Oracle server. -- The connection uses a connect string which includes an (HS=) specification.
Action: Check Net8 administration in the following ways: -- When using TNSNAMES.ORA or an Oracle Names server, make sure that the client connection to the ORACLE server uses the correct service name or SID. -- Check LISTENER.ORA on the connection end point's host machine to assure that this service name or SID refers to the correct server. -- Confirm in TNSNAMES.ORA or the equivalent service definition that the connect string does NOT contain (HS=).
ORA-28550: pass-through SQL: cursor not found
Cause: A value passed to a pass-through SQL function or procedure call as a cursor does not identify a currently open cursor.
Action: Use a cursor number returned by the pass-through SQL OPEN_CURSOR call.
ORA-28551: pass-through SQL: SQL parse error
Cause: A non-Oracle system rejected text supplied as a pass-through SQL statement.
Action: Ensure that the SQL supplied to the pass-through SQL PARSE call is legal for the non-Oracle system.
ORA-28552: pass-through SQL: call flow error
Cause: A pass-through SQL function was called in an invalid order.
Action: Correct program flow by changing the order of API calls to match the flow described in the manual.
ORA-28553: pass-through SQL: invalid bind-variable position
Cause: A pass-through SQL function referring to the position of a bind variable in the currently-parsed SQL statement supplied an invalid bind-variable position. Valid values are 1 through n, where n is the number of bind-variable place-holders in the SQL text.
Action: Verify that the bind-variable position parameter is in the correct range to represent a place-holder in the SQL text. Confirm that the SQL text uses the correct syntax for a bind-variable place-holder, as required by the non-Oracle system.
ORA-28554: pass-through SQL: out of cursors
Cause: The maximum number of open cursors has been exceeded.
Action: Close open cursors by using the pass-through SQL CLOSE_CURSOR function.
ORA-28555: pass-through SQL: required parameter missing or NULL
Cause: An attempt was made to pass a NULL value to a non-NULL parameter.
Action: Use a non-NULL value for the parameter.
ORA-28556: authorization insufficient to access table
Cause: A query attempted to access a table in the non-Oracle system that is either privileged or has privileged columns.
Action: Contact the DBA for the non-Oracle system. The DBA can grant permission to access the privileged table or columns.
ORA-28557: unknown string for database link to non-Oracle system
Cause: When attempting to connect to a non-Oracle system through a Heterogeneous Services database link, the agent supporting this non-Oracle system failed to return FDS_CLASS_NAME and/or FDS_INST_NAME. ORACLE requires these names to configure the heterogeneous database link.
Action: Contact the DBA to check setup of the connection and the Heterogeneous Services agent.
ORA-28558: HS_FDS_CONNECT_STRING undefined for non-Oracle system
Cause: A database link to a non-Oracle system had no HS_FDS_CONNECT_STRING initialization parameter in the ORACLE server's data dictionary for Heterogeneous Services. Without this parameter, the connection could not be completed.
Action: Contact your DBA to verify correct setup of an HS_FDS_CONNECT_STRING entry in the ORACLE Heterogeneous Services data dictionary.
ORA-28559: FDS_CLASS_NAME is string, FDS_INST_NAME is string
Cause: An associated error was reported in another message, and this message supplies supplementary information to assist diagnosis of that error. FDS_CLASS_NAME and FDS_INST_NAME are used to access information in tables and views of the ORACLE data dictionary that direct operation of Heterogeneous Services on a database link to a non-Oracle data store.
Action: Use the FDS_CLASS_NAME and FDS_INST_NAME values to check ORACLE data dictionary contents when necessary to diagnose the cause of the associated error.
ORA-28560: error in configuration of agent process
Cause: An ORACLE server invoked a function not supported by the connected agent (Heterogeneous Services or external procedures). The most probable cause is incorrect Net8 setup, resulting in use of the wrong agent executable.
Action: Check Net8 administration in the following ways: -- When using TNSNAMES.ORA or an Oracle Names server, make sure that the connection from the ORACLE server uses the correct SID. -- Check LISTENER.ORA on the agent's host machine to assure that this SID refers to the correct agent executable in its (PROGRAM=...) clause.
ORA-28561: unable to set date format on non-Oracle system
Cause: Initialization of a Heterogeneous Services connection to set the date format to be used on the connected non-Oracle system.
Action: If the Oracle data dictionary supplies a value for the HS_NLS_DATE_FORMAT parameter, confirm that this value is formatted correctly by the rules of the non-Oracle system. Also check for additional information in log and trace files generated by the Heterogeneous Services agent.
ORA-28575: unable to open RPC connection to external procedure agent
Cause: Initialization of a network connection to the extproc agent did not succeed. This problem can be caused by network problems, incorrect listener configuration, or incorrect transfer code.
Action: Check listener configuration in LISTENER.ORA and TNSNAMES.ORA, or check Oracle Names Server.
ORA-28576: lost RPC connection to external procedure agent
Cause: of this error is abnormal termination of the invoked "C" routine. If this is not the case, check for network problems. Correct the problem if you find it. If all components appear to be normal but the problem persists, the problem could be an internal logic error in the RPC transfer code. Contact your customer support representative.
Action: First check the 3GL code you are invoking; the most likely
ORA-28577: argument string of external procedure string has unsupported datatype string
Cause: While transferring external procedure arguments to the agent, an unsupported datatype was detected.
Action: Check your documentation for the supported datatypes of external procedure arguments.
ORA-28578: protocol error during callback from an external procedure
Cause: An internal protocol error occurred while trying to execute a callback to the Oracle server from the user's 3GL routine.
Action: Contact Oracle customer support.
ORA-28579: network error during callback from external procedure agent
Cause: An internal network error occurred while trying to execute a callback to the Oracle server from the user's 3GL routine.
Action: Contact Oracle customer support.
ORA-28580: recursive external procedures are not supported
Cause: A callback from within a user's 3GL routine resulted in the invocation of another external procedure.
Action: Make sure that the SQL code executed in a callback does not directly call another external procedure, or indirectly results in another external procedure, such as triggers calling external procedures, PL/SQL procedures calling external procedures, etc.
ORA-28581: protocol error while executing recursive external procedure
Cause: An internal protocol error occurred while trying to execute an external procedure resulting from a callback in another external procedure.
Action: Contact Oracle customer support.
ORA-28582: a direct connection to this agent is not allowed
Cause: A user or a tool tried to establish a direct connection to either an external procedure agent or a Heterogeneous Services agent, for example: "SVRMGR> CONNECT SCOTT/TIGER@NETWORK_ALIAS". This type of connection is not allowed.
Action: When executing the CONNECT statement, make sure your database link or network alias is not pointing to a Heterogeneous Option agent or an external procedure agent.
ORA-28583: remote references are not permitted during agent callbacks
Cause: A Heterogeous Services agent issued a callback to the Oracle server which attemted to to access a remote system. This is not supported.
Action: Make sure that SQL code issued by Heterogeneous Services agents does not reference a database link.
ORA-28584: heterogeneous apply internal error
Cause: The apply slave process encountered an error while trying to apply changes through a gateway to a non-Oracle system.
Action: Make sure that the apply database link is correctly configured and that the gateway listener and the non-Oracle system are correctly set up and are up and running. If everything is configured correctly and the problem still occurs, contact Oracle customer support. errors 28590 - 28599 are reserved for the HS agent control utility
ORA-28590: agent control utility: illegal or badly formed command
Cause: The user has issued an unrecognized or syntactically incorrect command.
Action: Refer to documentation and correct the syntax of the command.
ORA-28591: agent control utility: unable to access parameter file
Cause: The agent control utility was unable to access its parameter file. This could be because it could not find its admin directory or because permissions on directory were not correctly set.
Action: The agent control utility puts its parameter file in either the directory pointed to by the environment variable AGTCTL_ADMIN or in the directory pointed to by the environment variable TNS_ADMIN. Make sure that at least one of these environment variables is set and that it points to a directory that the agent has access to.
ORA-28592: agent control utility: agent SID not set
Cause: The agent needs to know the value of the AGENT_SID parameter before it can process any commands. If it does not have a value for AGENT_SID then all commands will fail.
Action: Issue the command SET AGENT_SID <value> and then retry the command that failed.
ORA-28593: agent control utility: command terminated with error
Cause: An error occurred during the processing of the command. There could be several causes. A SET or an UNSET command could have been issued after the agent was started. This is illegal. The user may have attempted to start two agents with the same SID value or the user could have attempted to shutdown an agent that is no longer running.
Action: If the user wishes to issue a SET or an UNSET command, he should make sure the agent is shutdown first by issuing the SHUTDOWN command.
ORA-28594: agent control utility: invalid parameter name
Cause: The user tried to set or unset an invalid agent parameter.
Action: Refer to documentation and correct the parameter name.
ORA-28595: Extproc agent : Invalid DLL Path
Cause: The path of DLL supplied for the extproc execution is invalid.
Action: Check if the DLL path is set properly using the EXTPROC_DLLS environment variable. errors 28600 - 28620 are reserved for bitmap indexes
ORA-28601: invalid [no]MINIMIZE option
Cause: user didn't type this alter table <table_name> MINIMIZE RECORDS_PER_BLOCK or alter table <table_name> NOMINIMIZE RECORDS_PER_BLOCK
Action: reenter correct sql command
ORA-28602: statement not permitted on tables containing bitmap indexes
Cause: table has bitmap indexes and user is minimizing or nominimizing records_per_block
Action: drop all bitmap indexes before changing records_per_block
ORA-28603: statement not permitted on empty tables
Cause: table is empty and statement does not work on empty tables
Action: try statement after loading your data
ORA-28604: table too fragmented to build bitmap index (string,string,string)
Cause: The table has one or more blocks that exceed the maximum number of rows expected when creating a bitmap index. This is probably due to deleted rows. The values in the message are: (data block address, slot number found, maximum slot allowed)
Action: Defragment the table or block(s). Use the values in the message to determine the FIRST block affected. (There may be others).
ORA-28605: bitmap indexes cannot be reversed
Cause: user tried to create reverse bitmap index
Action: don't do this; it is not supported
ORA-28606: block too fragmented to build bitmap index (string,string)
Cause: The block(s) exceed the maximum number of rows expected when creating a bitmap index. This is probably due to maximum slot allowed set too low. The values in the message are: (slot number found, maximum slot allowed)
Action: alter system flush shared_pool; update tab$ set spare1 = 8192 where obj# = (select obj# from obj$ where NAME=<table_name> AND owner# = <table_owner>; commit;
ORA-28611: bitmap index is corrupted - see trace file for diagnostics
Cause: Validate Index detected bitmap corruption in its argument index
Action: Drop this bitmap index and create a new one.
ORA-28650: Primary index on an IOT cannot be rebuilt
Cause: An attempt is made to issue alter index rebuild on IOT-TOP
Action: Use Alter table MOVE to reorganize the table(IOT)
ORA-28651: Primary index on IOTs can not be marked unusable
Cause: An attempt is made to mark IOT-TOP unusable thru ALTER INDEX
Action: Remove the option UNUSABLE
ORA-28652: overflow segment attributes cannot be specified
Cause: During ALTER MOVE ONLINE of a index-organized table, the user attempted to enter one or more of the following options: OVERFLOW, PCTTHRESHOLD,INCLUDING.
Action: Remove the illegal option(s).
ORA-28653: tables must both be index-organized
Cause: Attempt to exchange a non IOT table/partition with a partition/table respectively
Action: Ensure that non-partitioned and partitioned tables are both index-organized.
ORA-28654: table and partition not overflow compatible
Cause: If one of the tables (partitioned/non-partitioned) has overflow data segment and the other one doesn't.
Action: Ensure that non-partitioned and partitioned tables both have overflow data segment or neither one does.
ORA-28655: Alter table add overflow syntax error
Cause: Syntax error
Action: Check the syntax.
ORA-28656: incomplete attribute specification
Cause: The attribute specification is not done for all partitions"
Action: Specify the storage attributes either for ALL partitions or NONE
ORA-28658: This operation is supported only for Index-Organized tables
Cause: Attempt to perform some IOT specific operation on a non-IOT
Action: don't do this. This is not supported
ORA-28659: COMPRESS must be specified at object level first
Cause: Attempt to specify COMPRESS at partition level without first specifying at the table level
Action: Specify COMPRESS at table level. Use ALTER TABLE xxx MODIFY DEFAULT ATTRIBUTES COMPRESS ...
ORA-28660: Partitioned Index-Organized table may not be MOVEd as a whole
Cause: Attempt to MOVE partitioned IOT as a whole
Action: don't do this. This is not supported
ORA-28661: Object already has COMPRESS clause specified
Cause: Attempt to specify compress for iot/index which already has a compression clause.
Action: This is a 'create time only' attribute
ORA-28662: IOT index and overflow segments must share the same LOGGING attribute
Cause: Attempt to specify LOGGING for one segment and NOLOGGING for the other segment.
Action: don't do that
ORA-28663: Logging/Nologging attribute can not be specified in the statement ALTER TABLE ADD OVERFLOW
Cause: Attempt to specify LOGGING for a Alter Table Add Overflow.
Action: don't do that
ORA-28664: a partitioned table may not be coalesced as a whole
Cause: User attempted to coalesce a partitioned IOT using ALTER TABLE COALESCE statement, which is illegal
Action: Coalesce the table a partition at a time (using ALTER TABLE MODIFY PARTITION COALESCE)
ORA-28665: table and partition must have same compression attribute
Cause: User attempted to EXCHANGE a compression enabled partition with a compression disabled table or vice versa OR the # of columns compressed is different for table and partition
Action: Make sure the compression attributes match If they don't, fix it using ALTER TABLE MOVE [PARTITION] COMPRESS
ORA-28666: option not allowed for an index on UROWID column(s)
Cause: User attempted to build a REVERSE or COMPRESSED or GLOBAL partitioned index on UROWID column(s)
Action: Build the index without these options
ORA-28667: USING INDEX option not allowed for the primary key of an IOT
Cause: User attempted to define storage attributes for the primary key index of an Index-Organized table with USING INDEX clause. All the storage attribute defined for the (IOT)table applies to the primary key index and a separate USING INDEX clause is not required.
Action: Remove the USING INDEX clause and specify all attributes directly for the table
ORA-28668: cannot reference mapping table of an index-organized table
Cause: An attempt to directly access the mapping table of an index-organized table
Action: Issue the statement against the parent index-organized table containing the specified mapping table.
ORA-28669: bitmap index can not be created on an IOT with no mapping table
Cause: User attempted to create a bitmap index on an index-organized table without a mapping table.
Action: Enable bitmap indexes on the Index-organized table by creating a mapping table using 'ALTER TABLE .. MOVE MAPPING TABLE'.
ORA-28670: mapping table cannot be dropped due to an existing bitmap index
Cause: User attempted to drop the mapping table with NOMAPPING option when the IOT has one or more bitmap indexed.
Action: Drop the bitmap index(es) before dropping the mapping table.
ORA-28671: UPDATE BLOCK REFERENCES may not be used on a partitioned index as a whole
Cause: User attempted to UPDATE BLOCK REFERENCES on a partitioned index using ALTER INDEX UPDATE BLOCK REFERENCES statement, which is illegal.
Action: Issue a partition level operation with ALTER INDEX .. PARTITION .. UPDATE BLOCK REFERENCES
ORA-28672: UPDATE BLOCK REFERENCES may not be used on a global index
Cause: User attempted to UPDATE BLOCK REFERENCES on a global partitioned or non-partitioned index. This feature is not supported for non-partitioned or global partitioned index on a partitioned IOT and a global partitioned index on a non-partitioned IOT.
Action: Use online index [partition] rebuild to fix the block references
ORA-28673: Merge operation not allowed on an index-organized table
Cause: User attempted merge operation on an index-organized table. Merge is not supported on a IOT .
Action: Use updates and inserts on index-organized table .
ORA-28674: cannot reference transient index-organized table
Cause: An attempt was made to directly access a transient table created created on behalf of a index-organized table partition maintenance operation.
Action: Issue the statement against the associated permanent index-organized table.


16 ORA-29250 to ORA-32775

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

16 ORA-29250 to ORA-32775

ORA-29250: Invalid index specifed in call to dbms_sql.bind_array
Cause: An invalid index was specified in a call to bind_array of dbms_sql. The index may have been null or of an improper value.
Action: Correct the index value by modifying your PL/SQL program and try the bind_array call again.
ORA-29251: Index1 is greater than Index2 in call to dbms_sql.bind_array
Cause: The value of index1 was greater than the value for index2 in the call to bind_array. This is illegal since the elements of the table that will be bound are those with indexes greater than or equal to index1 and less than or equal to index2.
Action: Correct the value of the two indexes and try the call to again bind_array.
ORA-29252: collection does not contain elements at index locations in call to dbms_sql.bind_array
Cause: The bound table does not contain elements at both index locations in call to bind_array of dbms_sql. This is illegal. Both index locations must contain elements. In other words tab.exists(index1) and tab.exists(index2) must both return true.
Action: Either modify the two indexes or the contents of the table and try the call again.
ORA-29253: Invalid count argument passed to procedure dbms_sql.define_array
Cause: The count argument specified in the call to procedure define_array of package dbms_sql had an invalid value. Invalid values are negative numbers and nulls. The argument must be a positive integer.
Action: Correct your PL/SQL program so that only valid arguments are passed to define_array and try again.
ORA-29254: Invalid lower_bound argument passed to procedure dbms_sql.define_array
Cause: The lower_bound argument specified in the call to procedure define_array had an invalid value. Legal values are all integers (both positive and negative) including zero. The null value is illegal.
Action: Correct your PL/SQL program so that only valid arguments are passed to define_array and try again.
ORA-29255: Cursor contains both bind and define arrays which is not permissible
Cause: Both define_array and bind_array have been called on this cursor. This is illegal. It is not possible for a cursor to both contain array binds and array defines. The semantics of this setting are nonsensical. Array defines are used to move data from select queries into PL/SQL tables and array binds to bind PL/SQL tables to non-select queries.
Action: Modify your PL/SQL program to only perform calls to one of the two functions depending on the kind of cursor at hand.
ORA-29256: Cursor contains both regular and array defines which is illegal
Cause: Both define_array and define_column have been called on this cursor. This is illegal. It is not possible for a cursor to both contain regular and array defines. The semantics of this setting are nonsensical. Array defines are used to move data from select queries into PL/SQL tables and regular defines to move data from select queries into PL/SQL variables.
Action: Modify your PL/SQL program to only perform calls to one of the two functions depending on the situation at hand.
ORA-29257: host string unknown
Cause: The specified host was unknown.
Action: Check the spelling of the host name or the IP address. Make sure that the host name or the IP address is valid.
ORA-29258: buffer too small
Cause: The input or output buffer was too small for the operation.
Action: Increase the size of the buffer and retry the operation.
ORA-29259: end-of-input reached
Cause: The end of the input was reached.
Action: If the end of the input is reached prematurely, check if the input source terminates prematurely. Otherwise, close the connection to the input.
ORA-29260: network error: string
Cause: A network error occurred.
Action: Fix the network error and retry the operation.
ORA-29261: bad argument
Cause: A bad argument was passed to the PL/SQL API.
Action: Check the arguments passed to the PL/SQL API and retry the call.
ORA-29262: bad URL
Cause: An improperly formed URL was passed to the PL/SQL API.
Action: Check the URL and retry the call.
ORA-29263: HTTP protocol error
Cause: A HTTP protocol error occured during the HTTP operation.
Action: Check the HTTP server that the HTTP operation was performed to make sure that it follows the HTTP protocol standard.
ORA-29264: unknown or unsupported URL scheme
Cause: The URL scheme was unknown or unsupported.
Action: Check the URL to make sure that the scheme is valid and supported.
ORA-29265: HTTP header not found
Cause: The requested HTTP header was not found.
Action: Check to make sure that the requested HTTP header is present.
ORA-29266: end-of-body reached
Cause: The end of the HTTP response body was reached.
Action: If the end of the HTTP response is reached prematurely, check if the HTTP response terminates prematurely. Otherwise, end the HTTP response.
ORA-29267: illegal call
Cause: The call to the PL/SQL API was illegal at the current stage of the operation.
Action: Retry the call at a different stage of the operation.
ORA-29268: HTTP client error string
Cause: The HTTP response indicated that the HTTP client error occurred.
Action: Fix the HTTP client error and retry the HTTP request.
ORA-29269: HTTP server error string
Cause: The HTTP response indicated that the HTTP server error occurred.
Action: Fix the HTTP server error and retry the HTTP request. Contact the admistrator of the HTTP server when necessary.
ORA-29270: too many open HTTP requests
Cause: Too many HTTP requests were opened.
Action: End some HTTP requests and retry the HTTP request.
ORA-29271: not connected
Cause: The network connection was not made while the network operation was attempted.
Action: Retry the network operation after the network connection is made successfully.
ORA-29272: initialization failed
Cause: The UTL_HTTP package failed to initialize.
Action: Free up some memory or other system resources and retry the operation.
ORA-29273: HTTP request failed
Cause: The UTL_HTTP package failed to execute the HTTP request.
Action: Use get_detailed_sqlerrm to check the detailed error message. Fix the error and retry the HTTP request.
ORA-29274: fixed-width multibyte character set not allowed for a URL
Cause: The character set used as an encoding of the URL is a fixed-width multibyte character set and is not allowed for a URL.
Action: Use the corresponding variable-width multibyte character set for the URL instead.
ORA-29275: partial multibyte character
Cause: The requested read operation could not complete because a partial multibyte character was found at the end of the input.
Action: Ensure that the complete multibyte character is sent from the remote server and retry the operation. Or read the partial multibyte character as RAW.
ORA-29276: transfer timeout
Cause: Timeout occurred while reading from or writing to a network connection.
Action: Check the remote server or the network to ensure that it responds within the timeout limit. Or increase the timeout value.
ORA-29277: invalid SMTP operation
Cause: The SMTP operation was invalid at the current stage of the SMTP transaction.
Action: Retry the SMTP operation at the appropriate stage of the SMTP transaction.
ORA-29278: SMTP transient error: string
Cause: A SMTP transient error occurred.
Action: Correct the error and retry the SMTP operation.
ORA-29279: SMTP permanent error: string
Cause: A SMTP permanent error occurred.
Action: Correct the error and retry the SMTP operation.
ORA-29280: invalid directory path
Cause: A corresponding directory object does not exist.
Action: Correct the directory object parameter, or create a corresponding directory object with the CREATE DIRECTORY command.
ORA-29281: invalid mode
Cause: An invalid value was specified for file open mode.
Action: Correct the mode to be one of the values: 'r','a', or 'w'.
ORA-29282: invalid file ID
Cause: A file ID handle was specified for which no corresponding open file exists.
Action: Verify that the file ID handle is a value returned from a call to UTL_FILE.FOPEN.
ORA-29283: invalid file operation
Cause: An attempt was made to read from a file or directory that does not exist, or file or directory access was denied by the operating system.
Action: Verify file and directory access privileges on the file system, and if reading, verify that the file exists.
ORA-29284: file read error
Cause: An attempt to read from a file failed.
Action: Verify that the file exists, and that it is accessible, and that it is open in read mode.
ORA-29285: file write error
Cause: Failed to write to, flush, or close a file.
Action: Verify that the file exists, that it is accessible, and that it is open in write or append mode.
ORA-29286: internal error
Cause: A fatal error occurred while allocating PL/SQL session memory.
Action: Verify that the PL/SQL session is connected and that adequate memory resources are available.
ORA-29287: invalid maximum line size
Cause: An invalid maximum line size value was specified.
Action: Correct the maximum line size to be in the range [1, 32767].
ORA-29288: invalid file name
Cause: A NULL or zero length file name was specified.
Action: Correct the file name to be a nonzero length string.
ORA-29289: directory access denied
Cause: A directory object was specified for which no access is granted.
Action: Grant access to the directory object using the command GRANT READ ON DIRECTORY [object] TO [username];.
ORA-29290: invalid offset specified for seek
Cause: An attempt was made to seek past the end of the file, or both the absolute and relative offsets were NULL, or absolute offset was less than zero.
Action: If specifying an absolute offset, ensure it is in the range [0, <total number of bytes in the file>], or if specifying a relative offset, ensure it is no greater than the current byte position plus the number of bytes remaining in the file.
ORA-29291: file remove operation failed
Cause: A file deletion attempt was refused by the operating system.
Action: Verify that the file exists and delete privileges granted on the directory and the file.
ORA-29292: file rename operation failed
Cause: A file rename attempt was refused by the operating system either because the source or destination directory does not exist or is inaccessible, or the source file isn't accessible, or the destination file exists.
Action: Verify that the source file, source directory, and destination directory exist and are accessible, and that the destination file does not already exist.
ORA-29293: A stream error occurred during compression or uncompression.
Cause: The stream state was discovered to be invalid during compression or uncompression, or an invalid compression quality was requested or a NULL or invalid compression parameter was detected.
Action: Verify that quality is within the range [0,9] and that valid input source data exists.
ORA-29294: A data error occurred during compression or uncompression.
Cause: An error occurred while compressing or uncompressing input source.
Action: Verify that source data is a valid compressed or uncompressed data set.
ORA-29295: invalid mime header tag
Cause: An error occurred while scanning string for mime header tag
Action: Verify that source data is a valid mime header string, in the format: =?<charset>?<encoding>?<encoded string>?=
ORA-29296: invalid encoded string
Cause: An error occurred while decoding the input string
Action: Verify that source data is a valid encoded string.
ORA-29297: The compressed representation is too big
Cause: The compressed output is too big to return.
Action: Do not attempt to compress source data.
ORA-29298: Character set mismatch
Cause: The character set mode in which the file was opened did not match the character set of the read or write operation.
Action: Use the correct UTL_FILE read and write procedures which coorespond to the character set mode in which the file was opened.
ORA-29299: Invalid handle for piecewise compress or uncompress
Cause: The process program opened too many handles, and the specified handle was either uninitialized or outside a valid range.
Action: Close some handles and verify that the specified handle is opened or within a valid range.
ORA-29300: ORACLE error, tablespace point-in-time recovery
Cause: Another ORACLE error occured in the DBMS_PITR package.
Action: See the text of the error message for a description of the error.
ORA-29301: wrong DBMS_PITR package function/procedure order
Cause: The DBMS_PITR package function/procedure was called in an incorrect order.
Action: Restart tablespace point-in-time recovery with a correct procedure.
ORA-29302: database is not open clone
Cause: The database was not opened as a clone database.
Action: Mount the database clone and open the database.
ORA-29303: user does not login as SYS
Cause: The user did not log in as SYS to perform tablespace point-in-time recovery in a clone database.
Action: Log in as SYS and restart tablespace point-in-time recovery.
ORA-29304: tablespace 'string' does not exist
Cause: The selected tablespace does not exist in the database.
Action: Check the list of tablespaces in V$TABLESPACE and select a valid tablespace.
ORA-29305: cannot point-in-time recover tablespace 'string'
Cause: An attempt was made to ALTER the tablespace to be read only.
Action: Check if the tablespace is SYSTEM or with online rollback segment.
ORA-29306: datafile string is not online
Cause: The selected datafile was not online.
Action: Bring the the datafile online and rename it if necessary.
ORA-29307: datafile string error, string
Cause: The datafile is not ready for tablespace point-in-time recovery.
Action: Check the correct tablespace point-in-time recovery procedure.
ORA-29308: view TS_PITR_CHECK failure
Cause: Some objects which crossed the boundary of the recovery set were not allowed in the tabelspace point-in-time recovery.
Action: Query TS_PITR_CHECK and resolve the boundary crossing objects.
ORA-29309: export dump file was generated by different version of DBMS_PITR package
Cause: The version of DBMS_PITR is different from the version of the cloned database.
Action: Load the version of DBMS_PITR which matches the version of the cloned database.
ORA-29310: database is not open, or opened as a clone
Cause: Either the database was not open, or an attempt was made to open it as a cloned database.
Action: Open the production database instead.
ORA-29311: export dump file was not generated by this database, string does not match
Cause: The export dump files were imported to an incorrect database.
Action: Open the correct production database and try the import again.
ORA-29312: changes by release string cannot be used by release string, type: string
Cause: A point-in-time tablespace was chosen to perform the recovery, but the current database is not compatible with the database that was used to create the point-in-time tablespace.
Action: Choose a point-in-time and retry the operation.
ORA-29313: tablespace 'string' cannot be imported twice
Cause: This is an internal error.
Action: Contact your database administrator.
ORA-29314: tablespace 'string' is not OFFLINE FOR RECOVER nor READ ONLY
Cause: Tablespace clean SCN is either 0 or invalid.
Action: ALTER the tablespace OFFLINE FOR RECOVER.
ORA-29315: tablespace 'string' has been recreated
Cause: An attempt was made to recover a tablespace to a point-in-time before it was recreated.
Action: Choose a different point in time for recovery.
ORA-29316: datafile string been imported twice
Cause: This is an internal error.
Action: Contact your database administrator.
ORA-29317: datafile string does not exist
Cause: The specified datafile could not be found in the production database.
Action: Copy the datafile from the clone database.
ORA-29318: datafile string is online
Cause: The datafile is online.
Action: Take the datafile offline.
ORA-29319: datafile string is not correct
Cause: An incorrect datafile was copied to the production database. The datafile information in the export dump file differs with the information in the datafile in the production database.
Action: Copy the datafile from the clone database to the production database.
ORA-29320: datafile header error
Cause: An error occured during reading datafile header.
Action: Copy the correct datafile from the clone database to the production database, then retry the operation.
ORA-29321: too many datafiles added since the point-in-time
Cause: Too many datafiles were added to the recovery set since the point-in-time recovery.
Action: Divide the recovery set into smaller subsets and retry.
ORA-29322: SCN string size too long -- maximum size 58 bytes/characters
Cause: Too many characters in specifying the SCN string
Action: Remove all unnecessary characters. Only 15 characters are required for both the hex and decimal representation of the 48 bit SCN.
ORA-29323: ALTER DATABASE SET COMPATIBILITY command not supported by string
Cause: The ALTER DATABASE SET COMPATIBILITY command failed because one or more instances do not support dynamic compatible setting change.
Action: No action required.
ORA-29324: SET COMPATIBILITY release string format is wrong
Cause: It should be of the form x.x.x
Action: Use the correct format.
ORA-29325: SET COMPATIBILITY release number lower than string
Cause: The SET COMPATIBILITY release compatibility release number was lower than the current compatible setting.
Action: Specify a higher release number.
ORA-29326: SET COMPATIBILITY release number higher than string
Cause: The ALTER DATABASE SET COMPATIBILITY command failed because one or more instances had a lower release number.
Action: Specify a lower release number.
ORA-29327: unsupported client compatibility mode used when talking to the server
Cause: The client compatibility mode is higher than the version of the server.
Action: Using SET COMPATIBILITY command, specify the same release number as the server.
ORA-29328: too many datafiles in this tablespace 'string'
Cause: Too many datafiles in this bitmap tablespace. ORACLE does not support at this moment.
Action: Call Oracle Support.
ORA-29335: tablespace 'string' is not read only
Cause: The tablespace is not read only.
Action: Make the tablespace read only and retry the operation.
ORA-29336: Internal error [string] [string] from DBMS_PLUGTS
Cause: Internal error from package DBMS_PLUGTS.
Action: Call Oracle Support.
ORA-29337: tablespace 'string' has a non-standard block size (string)
Cause: The tablespace has a non-standard block size and making such a tablespace read-write is not permitted.
Action: Use some other mechanism to import the data
ORA-29338: datafile string is in an undesired state (string, string)
Cause: The referred datafile is not in a state ready for tablespace copy operation. For example, the datafile may be offline. The datafile needs to be ONLINE, and either READ ONLY or READ WRITE.
Action: Put the datafile into the desired state.
ORA-29339: tablespace block size string does not match configured block sizes
Cause: The block size of the tablespace to be plugged in or created does not match the block sizes configured in the database.
Action: Configure the appropriate cache for the block size of this tablespace using one of the various (db_2k_cache_size, db_4k_cache_size, db_8k_cache_size, db_16k_cache_size, db_32K_cache_size) parameters.
ORA-29340: export file appears to be corrupted: [string] [string] [string]
Cause: This is caused either by a corrupted export file or by an Oracle internal error.
Action: Make sure the export file used for transportable tablespace is not corrupted. If the error still occurs, call Oracle support.
ORA-29341: The transportable set is not self-contained
Cause: The set of objects in the set of tablespaces selected are not self-contained.
Action: Consider using different export options, or removing some of the pointers that caused the violation, or selecting a different set of tablespaces.
ORA-29342: user string does not exist in the database
Cause: The referred user is one of the owners of data in the pluggable set. This user does not exist in the database.
Action: Consider either creating the user in the database or map the user to a different user via FROM_USER and TO_USER import options.
ORA-29343: user string (mapped from user string) does not exist in the database
Cause: The referred user is one of the owners of data in the pluggable set. This user does not exist in the database.
Action: Consider either creating the user or map the original user to a different user.
ORA-29344: Owner validation failed - failed to match owner 'string'
Cause: The system failed to match the referred owner. There are two cases that this may occur. (1) This user owns data in the transportable set, but this user is not specified in the TTS_OWNERS list of the import command line option, assuming that TTS_OWNERS is specified. (2) This user is specified in the TTS_OWNER list, but this user does not own any data in the transportable set.
Action: Retry import with a different OWNER list.
ORA-29345: can not plug a tablespace into a database using a different character set
Cause: Oracle does not support plugging a tablespace into a database using a different character set.
Action: Use import/export or unload/load to move data instead.
ORA-29346: invalid tablespace list
Cause: the tablespace list supplied to dbms_tts.transport_set_check PL/SQL routine is in an incorrect format.
Action: Check the manual and use the correct format.
ORA-29347: Tablespace name validation failed - failed to match tablespace 'string'
Cause: The system failed to match the referred tablespace. There are 2 cases that this may happen. (1) This tablespace is in the transportable set, but it is not specified in the TABLESPACES list of the import command line option, assuming that TABLESPACES is specified. (2) This tablespace is in the TABLESPACES list, but it is not in the transportable set.
Action: Retry the operation with the correct TABLESPACES list.
ORA-29348: You must specify the datafiles to be plugged in
Cause: The datafiles to be plugged in are not specified.
Action: Specify the datafiles via the import DATAFILES command line option.
ORA-29349: tablespace 'string' already exists
Cause: Tried to plug-in a tablespace which already exists.
Action: Drop the offending tablespace if possible. Otherwise use a different method (e.g., import/export) to move data.
ORA-29351: can not transport system, sysaux, or temporary tablespace 'string'
Cause: The referred tablespace is either the system tablespace, the sysaux tablespace, or a temporary tablespace.
Action: Do not include this tablespace in the transportable set.
ORA-29352: event 'string' is not an internal event
Cause: The DBMS_SYSTEM.WAIT_FOR_EVENT procedure was called with an event name that is not an internal event.
Action: Check the list of events from X$KSLED and verify the event name parameter passed to the WAIT_FOR_EVENT procedure.
ORA-29353: The transportable list is too long.
Cause: The transportable list exceeds the buffer size of 32767.
Action: Reduce the list of tablespaces to transport.
ORA-29355: NULL or invalid string argument specified
Cause: The named argument was either invalid or specified as a NULL
Action: Specify non-null, valid arguments.
ORA-29356: These parameters can be specified only for directives that refer to consumer groups
Cause: The below parameters were specified as an argument to procedure CREATE_PLAN_DIRECTIVE or UPDATE_PLAN_DIRECTIVE of package DBMS_RESOURCE_MANAGER.where the GROUP_OR_SUBPLAN argument is a resource plan. "ACTIVE_SESS_POOL_P1", "QUEUEING_P1", "PARALLEL_DEGREE_LIMIT_P1", "SWITCH_P1", "SWITCH_P2", "SWITCH_P3", "MAX_EST_EXEC_TIME", "UNDO_POOL"
Action: Specify these parameters only for consumer group directives.
ORA-29357: object string already exists
Cause: The name specified as argument to procedure CREATE_PLAN, CREATE_CONSUMER_GROUP of package DBMS_RESOURCE_MANAGER was already in use.
Action: Specify an unused name.
ORA-29358: resource plan string does not exist
Cause: An invalid plan name was specified as an argument to procedure UPDATE_PLAN of package DBMS_RESOURCE_MANAGER.
Action: Specify an existing plan name.
ORA-29359: invalid method name string specified for resource plan string
Cause: An invalid method was specified as an argument to procedure CREATE_PLAN or UPDATE_PLAN of package DBMS_RESOURCE_MANAGER.
Action: Specify a valid method name.
ORA-29360: retry operation. Too much concurrent activity
Cause: An attempt was made to revoke the switch consumer group privilege from a user for his/her initial consumer group but someone is modifying the user in another session.
Action: Retry the operation later.
ORA-29361: value string is outside valid range of 0 to 100
Cause: An invalid value was specified for a plan directive parameter.
Action: Specify a value between 0 and 100 inclusive.
ORA-29362: plan directive string, string does not exist
Cause: A non-existent plan directive was specified for procedure UPDATE_PLAN_DIRECTIVE of package DBMS_RESOURCE_MANAGER.
Action: Specify an existing plan directive for update.
ORA-29363: plan directive string, string is mandatory and cannot be modified or deleted
Cause: An attempt was made to modify a mandatory plan directive.
Action: Do not attempt to modify mandatory plan directives because they are required by the Resource Manager and cannot be modified.
ORA-29364: plan directive string, string already exists
Cause: An attempt was made to create a plan directive that already exists.
Action: Retry the create operation using different values.
ORA-29365: parameters string and string cannot both be set
Cause: An attempt was made to set both parameters.
Action: Only set one of parameters or neither of them.
ORA-29366: invalid CONSUMER_GROUP argument specified
Cause: An invalid consumer group name was specified.
Action: Specify a non-NULL, valid consumer group name.
ORA-29367: object string does not exist
Cause: A non-existent object name was specified as an argument to procedure CREATE_PLAN_DIRECTIVE of package DBMS_RESOURCE_MANAGER.
Action: Specify a valid plan or consumer group name.
ORA-29368: consumer group string does not exist
Cause: An non-existent consumer group was specified.
Action: Specify an existing consumer group.
ORA-29369: invalid method name string specified for consumer group string
Cause: An invalid method name was specified as an argument to procedure CREATE_CONSUMER_GROUP or UPDATE_CONSUMER_GROUP of package DBMS_RESOURCE_MANAGER.
Action: Specify a valid method name.
ORA-29370: pending area is already active
Cause: An attempt was made to activate a pending area that is already active.
Action: Wait until the pending area is no longer active; then, retry the operation.
ORA-29371: pending area is not active
Cause: An attempt was made to make changes without creating a pending area.
Action: Invoke procedure CREATE_PENDING_AREA before making any changes.
ORA-29372: identifier string is too long; it must be less than string characters
Cause: An attempt was made to specify an identifier that is more than 30 characters long.
Action: Use an identifier that is 30 characters or less in length.
ORA-29373: resource manager is not on
Cause: An attempt was made to execute an operation that cannot be executed with the resource manager being off
Action: Turn on the resource manager and try again.
ORA-29374: resource plan string in top-plan string has no plan directives
Cause: A plan was created in the pending area that is an orphan or stand-alone.
Action: Create plan directives if needed. Otherwise, delete the plan.
ORA-29375: sum of values string for level string, plan string exceeds string
Cause: The sum of plan directive parameter values for the specified plan level exceeded 100.
Action: Alter the values for the level so that they sum to 100.
ORA-29376: number of consumer groups string in top-plan string exceeds string
Cause: The number of consumer groups in the specified top-plan is more than 32.
Action: Change the top-plan to have no more than 32 consumer groups.
ORA-29377: consumer group string is not part of top-plan string
Cause: OTHER_GROUPS was not included as part of the specified top-plan. Each top plan must include the built-in consumer group OTHER_GROUPS.
Action: Create a plan directive with the argument GROUP_OR_SUBPLAN being OTHER_GROUPS somewhere in the top-plan.
ORA-29378: invalid consumer group mapping priorities
Cause: The mapping priorities were not unique integers within the valid range.
Action: Set the mapping priorities to unique integers within the
ORA-29379: resource plan string is involved in a loop in top-plan string
Cause: A loop was discovered while validating a top-plan.
Action: Check the plans that have the specified plan as a GROUP_OR_SUBPLAN, and remove the plan directive that causes the loop.
ORA-29380: resource plan string is currently active and cannot be deleted
Cause: An attempt was made to delete an active plan in the pending area. No changes can be made to active plans.
Action: Delete the plan when it is not in use.
ORA-29381: plan/consumer_group string referred to by another plan and cannot be deleted
Cause: An attempt was made to delete a plan or consumer group that is referred to by another plan.
Action: Remove all plan directives that have the plan or consumer group as GROUP_OR_SUBPLAN; then delete the plan or consumer group.
ORA-29382: validation of pending area failed
Cause: Invalid changes were attempted in the pending area.
Action: See documentation and the error messages that follow this one.
ORA-29383: all leaves of top-plan string must be consumer groups
Cause: An attempt was made to create or modify the specified top-plan but it has some plans as leaves.
Action: To identify which plans and/or plan directives need to be modified, look at all plans that have no plan directives. Then, alter the top-plan so that all its leaves are consumer groups.
ORA-29384: number of children for plan string exceeds string
Cause: An attempt was made to create or modify the specified plan, but the plan has more than 32 children.
Action: Make sure the specified plan points to no more than 32 distinct nodes.
ORA-29385: cannot create plan directive from string to string
Cause: An attempt was made to create a plan directive from a plan to itself.
Action: Make sure the arguments PLAN and GROUP_OR_SUBPLAN to procedure CREATE_PLAN_DIRECTIVE of package DBMS_RESOURCE_MANAGER are different.
ORA-29386: plan or consumer group string is mandatory and cannot be deleted or modified
Cause: An attempt was made to delete or modify the specified mandatory plan or consumer group.
Action: Do not attempt to delete or modify mandatory plans and consumer groups.
ORA-29387: no top-plans found in the pending area
Cause: The VALIDATE_PENDING_AREA procedure found that either the intended top-plan(s) are involved in a loop or there are no top-plans.
Action: Check all edges going from a subplan to the intended top-plan. Make sure the top plan does not have any plan referring to it.
ORA-29388: plan/consumer_group string is part of more than one top-plan
Cause: An attempt was made to delete a subtree that includes a plan or consumer group that is part of more than one top-plan as part of procedure DELETE_PLAN_CASCADE or package DBMS_RESOURCE_MANAGER. Such a plan or consumer group cannot be deleted.
Action: Check the ancestors of the plan or consumer group and make sure it is only part of the top-plan that includes the subtree being deleted.
ORA-29389: too many errors during validation
Cause: The number of errors detected during validation is too high.
Action: Perform the necessary actions to remove some errors, and retry validation.
ORA-29390: some resource plans are not part of any top-plan
Cause: An attempt was made to create or modify some plans in the pending area that are not part of any top-plan
Action: Remove these plans are try validation again.
ORA-29391: %s and string must be mandatory to create a mandatory plan directive
Cause: An attempt was made to create a mandatory plan directive where either PLAN or GROUP_OR_SUBPLAN or both were not mandatory
Action: Recreate these objects as mandatory and then create the plan directive.
ORA-29392: cpu parameters for level string for plan string must be zero
Cause: The cpu parameters for the specified level had a non-zero value, which is not a valid value for the plan's current cpu policy.
Action: Change the cpu level parameters for the specified level to zero or change the plan cpu policy.
ORA-29393: user string does not exist or is not logged on
Cause: An invalid user name was specified as argument to procedure SET_INITIAL_CONSUMER_GROUP of package DBMS_RESOURCE_MANAGER or SWITCH_CONSUMER_GROUP_FOR_USER of package DBMS_SYSTEM or the specified user was not logged on.
Action: Specify a valid user name.
ORA-29394: session id string and serial# string do not exist
Cause: Invalid session id and serial# were specified as arguments to procedure SWITCH_CONSUMER_GROUP_FOR_SESS of package DBMS_SYSTEM.
Action: Specify valid values from the view V$SESSION.
ORA-29395: cannot set the initial consumer group to string
Cause: An attempt was made to set the initial consumer group of a user to OTHER_GROUPS.
Action: OTHER_GROUPS is for the resource manager's internal use. Specify another consumer group.
ORA-29396: cannot switch group to string
Cause: An attempt was made to switch the consumer group of a user or a session to OTHER_GROUPS.
Action: OTHER_GROUPS is for the resource manager's internal use. Specify another consumer group.
ORA-29397: cannot grant/revoke switch privilege for string
Cause: An attempt was made to grant or revoke the privilege to switch to OTHER_GROUPS.
Action: OTHER_GROUPS is for the resource manager's internal use. Specify another consumer group.
ORA-29398: invalid privilege name specified
Cause: An invalid privilege name was specified as an argument to procedure GRANT_SYSTEM_PRIVILEGE or REVOKE_SYSTEM_PRIVILEGE of package DBMS_RESOURCE_MANAGER_PRIVS.
Action: Specify a valid privilege name.
ORA-29399: user string does not have privilege to switch to consumer group string
Cause: An attempt was made to set the initial consumer group of the specified user but the user does not have the privilege to switch to that group.
Action: Grant the privilege to switch to the consumer group to the user and then set the initial group.
ORA-29400: data cartridge error string
Cause: An error has occurred in a data cartridge external procedure. This message will be followed by a second message giving more details about the data cartridge error.
Action: See the data cartridge documentation for an explanation of the second error message.
ORA-29500: NAMED keyword is invalid in CREATE JAVA CLASS
Cause: A NAMED keyword was specified in the CREATE JAVA CLASS statement. NAMED keywords are valid only in CREATE JAVA SOURCE or RESOURCE statements.
Action: Remove the NAMED keyword from the CREATE JAVA CLASS statement.
ORA-29501: invalid or missing Java source, class, or resource name
Cause: The required name for a Java source, class, or resource was invalid or missing.
Action: Specify a valid name.
ORA-29502: NAMED keyword required in CREATE JAVA RESOURCE
Cause: The name for a Java resource was not specified. The name must be specified with the NAMED keyword.
Action: Specify a valid name with the NAMED keyword.
ORA-29503: SCHEMA keyword not valid with NAMED keyword
Cause: SCHEMA and NAMED keywords were used together in the same CREATE JAVA command, but only one may be used in a CREATE JAVA command.
Action: Remove either the NAMED or the SCHEMA keyword.
ORA-29504: invalid or missing schema name
Cause: The required schema name was invalid or missing.
Action: Specify a valid schema name.
ORA-29505: AS keyword is invalid in CREATE JAVA CLASS or RESOURCE
Cause: The AS keyword was used in CREATE JAVA CLASS or RESOURCE. The AS keyword is valid only in CREATE JAVA SOURCE.
Action: Use the USING keyword in CREATE JAVA CLASS or RESOURCE.
ORA-29506: invalid query derived from USING clause
Cause: The USING clause did not form a valid query.
Action: Correct the USING clause.
ORA-29507: query derived from USING clause found zero or many rows
Cause: The USING clause defined a query that either did not return any values, or returned more than one value.
Action: Correct the USING clause.
ORA-29508: query derived from USING clause did not select a value of type string
Cause: The USING clause did not form a query that selects a value of the type specified by the term following the USING keyword.
Action: Correct the USING clause.
ORA-29509: incorrectly formed Java binary class definition
Cause: An attempt was made to create a Java class using data expected to be in binary (Java .class) format. The data was found not to be in this format, or to be incorrectly formed.
Action: Correct the definition data.
ORA-29510: name, string.string, already used by an existing object
Cause: A CREATE JAVA command attempted to create a source, class, or resource object with a name that is already in use.
Action: Drop the existing object that is using the desired name, or use a different name for the new object.
ORA-29511: could not resolve Java class
Cause: A CREATE AND RESOLVE NOFORCE JAVA CLASS command specified definition data that could not be resolved, or resolution failed for some referenced class.
Action: Remove the NOFORCE option or remove impediments to resolution.
ORA-29512: incorrectly formed name resolver specification
Cause: A name resolver was not specified in the required form: (( <name pattern> , <schema name>) ...)
Action: Correct the specification.
ORA-29513: referenced class name too long
Cause: An attempt was made to import a .class file containing a class name of length greater than %d. The .class file could not be imported because the referenced class name was too long.
Action: Shorten the referenced class name in the .class file.
ORA-29514: class name contains illegal character
Cause: An attempt was made to import a .class file containing a character that cannot be converted to the server character set. The .class file could not be imported because of the illegal character.
Action: Correct the illegal character in the .class file.
ORA-29515: exit called from Java code with status string
Cause: Java code included a call to java.lang.Runtime.exitInternal.
Action: Do not include this call unless non-local exit is desired.
ORA-29516: Aurora assertion failure: string
Cause: An internal error occurred in the Aurora module.
Action: Contact Oracle Worldwide Support.
ORA-29517: recursive resolution failed for a referenced class
Cause: An attempt to resolve a referenced class failed.
Action: Review the errors for referenced classes and complete the necessary actions to correct them.
ORA-29518: name string resolved to an object in schema string that is not a Java class
Cause: A referenced name was resolved to an object that is not a Java class.
Action: Adjust name resolver or add missing Java class.
ORA-29519: name string resolved via a synonym in schema string to a class with a different name
Cause: A referenced name was resolved to a synonym, which translated to a class whose name does not match the referenced name.
Action: Adjust name resolver or add missing Java class.
ORA-29520: name string resolved to a class in schema string that could not be accessed
Cause: An attempt to access a referenced class failed.
Action: Adjust authorizations or name resolution.
ORA-29521: referenced name string could not be found
Cause: Name resolution failed to find an object with the indicated name.
Action: Adjust name resolver or add missing Java class.
ORA-29522: authorization error for referenced name string.string
Cause: An attempt was made to resolve a class that is not authorized to use the indicated referenced class.
Action: Adjust authorizations or name resolution.
ORA-29523: authorization error for unknown referenced name
Cause: An attempt was made to resolve a class that is not authorized to use a referenced class. The name of the referenced class could not be determined.
Action: Adjust authorizations or name resolution.
ORA-29524: wrong types of arguments in call to 'string'
Cause: A method was called with argument(s) of incompatible type(s).
Action: Adjust caller.
ORA-29525: referenced name is too long: 'string'
Cause: An attempt was made to create a class that references a name longer than 4000 characters. The class could not be created because the name is too long.
Action: Adjust the definition.
ORA-29526: created Java class string"string"
Cause: An informational message, not an error.
Action: None.
ORA-29527: created Java source string"string"
Cause: An informational message, not an error.
Action: None.
ORA-29528: invalid Java call in trigger string
Cause: The Java method specified in trigger does not exist or cannot be called as used.
Action: Adjust trigger definition.
ORA-29529: invalid function or method call string in trigger string
Cause: The function or method specified in Java trigger call expression could not be resolved.
Action: Adjust trigger definition.
ORA-29530: could not create shortened name for string
Cause: Insert into shortened name translation table failed.
Action: Retry the insert.
ORA-29531: no method string in class string
Cause: An attempt was made to execute a non-existent method in a Java class.
Action: Adjust the call or create the specified method.
ORA-29532: Java call terminated by uncaught Java exception: string
Cause: A Java exception or error was signaled and could not be resolved by the Java code.
Action: Modify Java code, if this behavior is not intended.
ORA-29533: attempt to overwrite class or resource string while defining or compiling string.string
Cause: A class or resource defined by a SQLJ source conflicted with an existing object.
Action: Remove existing object, or modify SQLJ source.
ORA-29534: referenced object string.string could not be resolved
Cause: Name resolution determined that the indicated object is referenced but could not be resolved.
Action: Correct name resolver or address resolution problems in the referenced class, or correct compilation problems in its source.
ORA-29535: source requires recompilation
Cause: The reason the current class object was invalid is recorded with the source object from which it was compiled.
Action: Inspect errors in the source object and take the necessary corrective actions.
ORA-29536: badly formed source: string
Cause: An attempt was made to create a Java source object with text that could not be parsed adequately to determine the class(es) defined by it.
Action: Correct errors in source.
ORA-29537: class or resource cannot be created or dropped directly
Cause: An attempt was made to create or drop a Java class or resource that is known to result from compilation of an existing Java source object.
Action: Act on the class or resource by acting on the source, or change the source so that it no longer defines the class or resource.
ORA-29538: Java not installed
Cause: An attempt was made to use a Java command when Java is not installed.
Action: Install Java, or do not use the command.
ORA-29539: Java system classes already installed
Cause: An attempt was made to use the CREATE JAVA SYSTEM command in a database where the Java system classes already are installed.
Action: Use CREATE OR REPLACE JAVA SYSTEM.
ORA-29540: class string does not exist
Cause: Java method execution failed to find a class with the indicated name.
Action: Correct the name or add the missing Java class.
ORA-29541: class string.string could not be resolved
Cause: An attempt was made to execute a method in a Java class that had not been previously and cannot now be compiled or resolved successfully.
Action: Adjust the call or make the class resolvable.
ORA-29542: class string already defined by source string
Cause: An attempt was made to create a Java source object that would define a class that is already defined by a different Java source object.
Action: Either drop the old source or modify the new source.
ORA-29543: Java command string not yet implemented
Cause: An attempt was made to use a Java command that is not yet implemented.
Action: Do not use the command.
ORA-29544: invalid type
Cause: The type argument in a call to a Java export or import command did not have a recognized value.
Action: Correct the value.
ORA-29545: badly formed class: string
Cause: An attempt was made to create a Java class object with bytecodes that were rejected by the Java verifier.
Action: It is possible that an attempt was made to create the Java class from a damaged class file, in which case the CREATE should be reattempted with a correct class file. It is also possible that the message is the result of using "-" in the resolver so that the verifier could not check the correctness of some code. In that case, the class needs to be created with a resolver.
ORA-29546: badly formed resource: string
Cause: An attempt was made to create a Java resource object with data that was rejected by the Java verifier.
Action: Correct the data.
ORA-29547: Java system class not available: string
Cause: An attempt was made to use a command that requires a Java system class that was not yet present or was invalid.
Action: Load the system classes, or do not use the command.
ORA-29548: Java system class reported: string
Cause: A command that uses a Java system class was aborted due to an error reported by the Java system class.
Action: Correct the error that was reported.
ORA-29549: class string.string has changed, Java session state cleared
Cause: A class in use by the current session was redefined or dropped, invalidating the current Java session state and requiring that it be cleared.
Action: No action required.
ORA-29550: Java session state cleared
Cause: The Java state in the current session became inconsistent and was cleared.
Action: No action required.
ORA-29551: could not convert string to Unicode
Cause: A string in the database character set could not be converted to Unicode, as required for use by Java.
Action: Correct the string.
ORA-29552: verification warning: string
Cause: An attempt was made to create a Java class object with bytecodes that caused the Java verifier to issue a warning.
Action: It is possible that the Java class was created from a damaged class file, in which case the CREATE should be reattempted with a correct class file. It is also possible that the message is the result of using "-" in the resolver so that the verifier could not check the correctness of some code. In that case, the class needs to be created with a resolver.
ORA-29553: class in use: string.string
Cause: An attempt was made to modify a Java class that is in use in the current call.
Action: Correct the code in use in this call.
ORA-29554: unhandled Java out of memory condition
Cause: The session encountered an out of memory condition in Java from which it could not recover. Java session state was cleared.
Action: No action required.
ORA-29555: Java source, class or resource is not allowed here
Cause: A Java source, class, or resource was specified in an inappropriate place in a statement.
Action: Make sure the name is correct or remove it.
ORA-29556: object type has changed
Cause: A database object name that named a Java source, class, or resource now names an object of a different type.
Action: No action required.
ORA-29557: Java system class string cannot be modified
Cause: A command was attempted that would have modified a Java system class.
Action: No action required.
ORA-29655: USING clause is incompatible with its supertype
Cause: The USING clause of a type has to be the same as its supertype or compatible with it.
Action: Make sure the USING clause is compatible with its supertype.
ORA-29656: Invalid option for USING
Cause: The class has to implement the required interface for the value of the option for USING.
Action: Make sure the USING clause is supported.
ORA-29657: class defined in EXTERNAL NAME clause is used in another subtype
Cause: The supertype has an existing type that has the same value for the EXTERNAL NAME.
Action: Make sure the EXTERNAL NAME clause is unique among subtypes.
ORA-29658: EXTERNAL NAME clause is not compatible with its supertype
Cause: The EXTERNAL NAME clause of the type is not a subclass of the supertype EXTERNAL NAME.
Action: Make sure the EXTERNAL NAME clause of the type is a subclass of the EXTERNAL NAME of its supertype.
ORA-29659: SQLJ Object Type validation failed to get default connection
Cause: Unable to connect using the JDBC default connection.
Action: No action required.
ORA-29660: Unable to find the class defined in the EXTERNAL NAME clause
Cause: The class is not loaded in the database.
Action: Make sure the EXTERNAL NAME corresponds to a loaded class in the the database.
ORA-29661: Unable to find the superclass of the defined in the EXTERNAL NAME
Cause: The class is not loaded in the database.
Action: Make sure the superclass of the EXTERNAL NAME is loaded in the the database.
ORA-29662: Unable to find a field that matches one or more of the attributes
Cause: The EXTERNAL NAME option of one or more attributes do not match any fields in the defined class.
Action: Make sure the EXTERNAL NAME option of each attribute matches a field in the defined in the defined class.
ORA-29663: Unable to find a method that matches one or more of the functions
Cause: The EXTERNAL NAME option of one or more functions do not match any method in the defined class.
Action: Make sure the EXTERNAL NAME option of each function matches a method in the defined in the defined class.
ORA-29664: Unable to generate the helper class for the defined type
Cause: The helper class used for supporting SQLJ Object Type is not generated.
Action: No Action is required.
ORA-29665: Java thread deadlock detected
Cause: The Java VM has detected a thread deadlock.
Action: Modify the Java program to avoid the deadlock condition.
ORA-29701: unable to connect to Cluster Manager
Cause: Connect to CM failed or timed out.
Action: Verify that the CM was started. If the CM was not started, start it and then retry the database startup. If the CM died or is not responding, check the Oracle and CM trace files for errors.
ORA-29702: error occurred in Cluster Group Service operation
Cause: An unexpected error occurred while performing a CGS operation.
Action: Verify that the LMON process is still active. Also, check the Oracle LMON trace files for errors.
ORA-29703: error occurred in global enqueue service operation
Cause: An unexpected error occurred while performing a global enqueue service operation.
Action: Check oracle trace files for errors.
ORA-29704: cannot specify ACTIVE_INSTANCE_COUNT in 8.1.5 or earlier release
Cause: The ACTIVE_INSTANCE_COUNT parameter was specified when one of the instances in the cluster was running Oracle 8.1.5 or an earlier release.
Action: Restart the instance without specifying the ACTIVE_INSTANCE_COUNT parameter. Or, upgrade all instances to Oracle 8.1.6 or later release and then specify the parameter.
ORA-29705: ACTIVE_INSTANCE_COUNT is string which is incompatible with the value in other instances
Cause: The value of the ACTIVE_INSTANCE_COUNT parameter must be the same in all Oracle cluster database instances.
Action: Check your initialization parameter files in all instances and ensure that the ACTIVE_INSTANCE_COUNT parameter has the same value. Then restart the instance.
ORA-29706: incorrect value string for parameter ACTIVE_INSTANCE_COUNT
Cause: The ACTIVE_INSTANCE_COUNT parameter must be set to 1 in a two node cluster database configuration or unspecified if a secondary instance is not needed.
Action: Check your initialization parameter files and correct the value of the ACTIVE_INSTANCE_COUNT parameter. If you are configuring a two node primary/secondary cluster database, set this value to 1. Otherwise, do not specify any value for the parameter.
ORA-29707: inconsistent value string for initialization parameter string with other instances
Cause: The value of the initialization parameter in error must be identical on all Oracle cluster database instances and was not.
Action: Check your INIT.ORA files on all instances and ensure that the initialization parameters in error have the same value.
ORA-29740: evicted by member string, group incarnation string
Cause: This member was evicted from the group by another member of the cluster database for one of several reasons, which may include a communications error in the cluster, failure to issue a heartbeat to the control file, etc.
Action: Check the trace files of other active instances in the cluster group for indications of errors that caused a reconfiguration.
ORA-29741: IMR active for some, but not all members of cluster
Cause: The IMR feature is not active for this instance, but is active for another instance in the cluster database.
Action: Ensure that all instances have the same value for the _imr_active init.ora parameter
ORA-29746: Cluster Synchronization Service is being shut down.
Cause: The administrator has shut down the Cluster Synchronization Service daemon. This error message is intended to be informative to users on the status of the service.
Action: Check the log file of the Cluster Synchronization Service daemon to verify the state of the service.
ORA-29760: instance_number parameter not specified
Cause: The init.ora file did not contain a value for the instance_number which is required to identify this instance to other instances of the database running on the same cluster
Action: Assign a value to the instance_number parameter in the init.ora parameter file
ORA-29800: invalid name for operator
Cause: The name specified for the operator is incorrect.
Action: Specify a correct name for the operator.
ORA-29801: missing RETURN keyword
Cause: The RETURN keyword has not been specified.
Action: Specify the RETURN keyword or check the SQL statement.
ORA-29802: missing CONTEXT keyword
Cause: The CONTEXT keyword has not been specified.
Action: Specify the CONTEXT keyword or check the SQL statement.
ORA-29803: missing ANCILLARY keyword
Cause: The ANCILLARY keyword has not been specified.
Action: Specify the ANCILLARY keyword or check the SQL statement.
ORA-29804: missing DATA keyword
Cause: The DATA keyword has not been specified.
Action: Specify the DATA keyword or check the SQL statement.
ORA-29805: missing COLUMN keyword
Cause: Keyword COLUMN is expected .
Action: Either specify the COLUMN keyword or specify another option.
ORA-29806: specified binding does not exist
Cause: The operator binding which has been specified does not exist.
Action: Ensure that the operator binding that has been specified does exist.
ORA-29807: specified operator does not exist
Cause: The operator which has been specified does not exist.
Action: Ensure that the operator that has been specified does exist.
ORA-29808: specified primary operator binding does not exist
Cause: The specified binding for the primary operator does not exist.
Action: Ensure that the specified binding for the primary operator exists.
ORA-29809: cannot drop an operator with dependent objects
Cause: The operator which is being dropped has some dependent objects.
Action: Either drop the dependent objects first and then issue the DROP OPERATOR command or specify the FORCE option with DROP OPERATOR.
ORA-29810: inadequate operator privileges
Cause: The user does not have the appropriate privileges to perform the specified operation on the operator.
Action: Grant the appropriate privileges to the user and then reissue the statement.
ORA-29811: missing STATISTICS keyword
Cause: This is not a valid option with the ASSOCIATE command.
Action: Specify STATISTICS keyword after the ASSOCIATE command.
ORA-29812: incorrect object name specified
Cause: The specified name is not a valid name.
Action: Specify the correct name of the object with for which an association needs to be defined.
ORA-29813: non-supported object type with associate statement
Cause: The type of object specified is not supported with the associate statistics statement.
Action: Use a valid object type with the associate command.
ORA-29814: expecting USING or DEFAULT keyword
Cause: Expecting the USING or DEFAULT keyword after the names of object(s).
Action: Provide the USING or DEFAULT keyword.
ORA-29815: object being associated is not present
Cause: The object for which the association is being defined is not present.
Action: Ensure that all the objects for which the association is being defined are present.
ORA-29816: object being disassociated is not present
Cause: Object which is being disassociated is not present.
Action: Ensure that the object which needs to be disassociated is present.
ORA-29817: non-supported option with disassociate statement
Cause: The type of object specified is not supported with the disassociate statistics statement.
Action: Use a object type which is supported with the disassociate command.
ORA-29818: column name not properly specified
Cause: Name of the column should contain the table and the column name.
Action: Specify a valid column name.
ORA-29819: cannot associate default values with columns
Cause: User tried to associate DEFAULT values with columns which is not a valid option .
Action: Specify a valid option.
ORA-29820: the statistics type is not present
Cause: The statistics type which is being associated with object(s) is not present.
Action: Ensure that the type which contains the statistics functions is present.
ORA-29821: specified primary operator does not exist
Cause: The specified primary operator does not exist.
Action: Check the primary operator and the signature specified.
ORA-29822: selectivity cannot be specified for the type of object
Cause: User tried to associate selectivity with index or indextypes which is not allowed .
Action: Specify a valid option.
ORA-29823: object being analyzed is not a table
Cause: The object being analyzed is not a table and is not supported
Action: Specify only a supported option.
ORA-29824: operator is invalid
Cause: The operator is invalid.
Action: Drop and recreate the operator.
ORA-29825: invalid name for indextype
Cause: Indextype name or Indextype schema name has invalid characters.
Action: Verify that the name has valid characters and it is not a reserved word.
ORA-29826: keyword FOR is missing
Cause: FOR keyword must be provided with Create Indextype statement.
Action: Use FOR keyword and provide relevant operator information.
ORA-29827: keyword USING is missing
Cause: USING keyword and corresponding implementation details must be provided.
Action: Provide USING keyword and relevant implementation details with Create Indextype statement.
ORA-29828: invalid name for implementation type
Cause: Implementation type or Implementation schema name is invalid.
Action: Verify that the name has valid characters and it is not a reserved word.
ORA-29829: implementation type does not exist
Cause: The implementation type specified with USING clause could not be found.
Action: Check to see if the type exists and the user has EXECUTE privilege on this type.
ORA-29830: operator does not exist
Cause: The operator could not be found.
Action: Verify that the operator exists and the user has EXECUTE privilege for this operator.
ORA-29831: operator binding not found
Cause: The specified binding for the operator is not available from the operator schema object.
Action: Verify that the operator with the specified binding exists.
ORA-29832: cannot drop or replace an indextype with dependent indexes
Cause: One or more indexes are dependent upon the indextype.
Action: Drop all the indexes which are dependent upon the indextype before dropping the indextype itself.
ORA-29833: indextype does not exist
Cause: There is no indextype by the specified name.
Action: Use public views for the indextypes to see if an indextype by the specified name has been created.
ORA-29834: REF datatype not supported with operators
Cause: The user specified a REF datatype which is not supported in CREATE OPERATOR.
Action: Reissue the CREATE OPERATOR statement without the REF datatype.
ORA-29835: ODCIGETINTERFACES routine does not return required interface(s)
Cause: The ODCIObjectList returned by the ODCIGetInterfaces routine does not contain the interface(s) required by the current usage.
Action: Ensure that the ODCIGetInterfaces routine returns the name(s) of the required interface(s).
ORA-29836: failed to validate referenced operators
Cause: One of the operators referenced cannot be compiled.
Action: Try to recompile the operators which are referenced by this indextype. Use USER_INDEXTYPE_OPERATORS view to find out the referenced operators.
ORA-29837: insufficient privileges to execute implementation type
Cause: User does not have privileges to execute the implementation type.
Action: The owner of the implementation type must grant appropriate privileges to the user.
ORA-29838: insufficient privileges to execute the operator(s)
Cause: User does not have privileges to execute one of the operators.
Action: The owner of the operators must grant appropriate privileges to the user .
ORA-29839: failed to validate implementation type
Cause: Implementation type cannot be compiled.
Action: Try to compile the implementation type.
ORA-29840: indextype and implementation type are not in same schema
Cause: Indextype and implementation type are in different schema.
Action: Put the indextype and implementation type in the same schema.
ORA-29841: invalid option for ALTER INDEXTYPE
Cause: The user specified an invalid option with the ALTER INDEXTYPE command
Action: Choose a valid option with the ALTER INDEXTYPE command
ORA-29842: option not supported with the version string of the indextype interface
Cause: User specified an option which is not supported with the version of the indextype interface provided
Action: User should either not request for this option or should provide an implementation type that implements the correct version of the indextype interface.
ORA-29843: indextype should support atleast one operator
Cause: User attempted to drop all the operators from the indextype
Action: Do not drop all the operators from the indextype
ORA-29844: duplicate operator name specified
Cause: User attempted to add an operator name to an indextype which is already supported by the indextype
Action: Remove the duplicate operator and retry the command
ORA-29845: indextype does not support local domain index on string partitioned table
Cause: User specified a create local domain index statement using an indextype that does not support local domain indexes on tables partitioned with the given method
Action: Use a different indextype or build a global domain index
ORA-29846: cannot create a local domain index on a string partitioned table
Cause: User specified a create local domain index statement on a table partitioned using a method not supported by domain indexes
Action: Build a global domain index on the partitioned table
ORA-29847: cannot create a local domain index on a partitioned index-organized table
Cause: User specified a create local domain index statement on a partitioned index-organized table
Action: Build a global domain index on the partitioned index-organized table
ORA-29848: error occurred in the execution of ODCIINDEXMERGEPARTITION routine
Cause: Failed to successfully execute the ODCIIndexMergePartition routine.
Action: Check to see if the routine has been coded correctly.
ORA-29849: error occurred in the execution of ODCIINDEXSPLITPARTITION routine
Cause: Failed to successfully execute the ODCIIndexSplitPartition routine.
Action: Check to see if the routine has been coded correctly.
ORA-29850: invalid option for creation of domain indexes
Cause: The user specified an invalid option like ASC, DESC, SORT or a parallel clause, partitioning clause or physical attributes clause.
Action: Choose one of the valid clauses for creation of domain indexes.
ORA-29851: cannot build a domain index on more than one column
Cause: User attempted to build a domain index on more than one column.
Action: Build the domain index only on a single column.
ORA-29852: keyword IS is missing
Cause: IS keyword must be specified with Create Index statement for domain indexes.
Action: Use IS keyword and then specify the indextype name.
ORA-29853: keyword UNIQUE may not be used in creating domain indexes
Cause: An attempt was made to create a domain index with the UNIQUE attribute.
Action: Remove UNIQUE from the CREATE INDEX statement.
ORA-29854: keyword BITMAP may not be used in creating domain indexes
Cause: An attempt was made to create a domain index with the BITMAP attribute.
Action: Remove BITMAP from the CREATE INDEX statement.
ORA-29855: error occurred in the execution of ODCIINDEXCREATE routine
Cause: Failed to successfully execute the ODCIIndexCreate routine.
Action: Check to see if the routine has been coded correctly.
ORA-29856: error occurred in the execution of ODCIINDEXDROP routine
Cause: Failed to successfully execute the ODCIIndexDrop routine.
Action: Check to see if the routine has been coded correctly.
ORA-29857: domain indexes and/or secondary objects exist in the tablespace
Cause: An attempt was made to drop a tablespace which contains secondary objects and/or domain indexes.
Action: Drop the domain indexes in his tablespace. Also, find the domain indexes which created secondary objects in this tablespace and drop them. Then try dropping the tablespace.
ORA-29858: error occurred in the execution of ODCIINDEXALTER routine
Cause: Failed to successfully execute the ODCIIndexAlter routine.
Action: Check to see if the routine has been coded correctly.
ORA-29859: error occurred in the execution of ODCIINDEXTRUNCATE routine
Cause: Failed to successfully execute the ODCIIndexTruncate routine.
Action: Check to see if the routine has been coded correctly.
ORA-29860: cannot truncate a table with domain indexes marked LOADING
Cause: The table has domain indexes defined on it that are marked LOADING.
Action: Wait to see if the ongoing index DDL ends and the index state changes from LOADING state. Else ,drop the domain indexes marked as LOADING with the FORCE option.
ORA-29861: domain index is marked LOADING/FAILED/UNUSABLE
Cause: An attempt has been made to access a domain index that is being built or is marked failed by an unsuccessful DDL or is marked unusable by a DDL operation.
Action: Wait if the specified index is marked LOADING Drop the specified index if it is marked FAILED Drop or rebuild the specified index if it is marked UNUSABLE.
ORA-29862: cannot specify FORCE option for dropping non-domain index
Cause: A DROP INDEX FORCE was issued for a non-domain index.
Action: Reissue the command without the FORCE option.
ORA-29863: warning in the execution of ODCIINDEXCREATE routine
Cause: A warning was returned from the ODCIIndexCreate routine.
Action: Check to see if the routine has been coded correctly Check user specified log tables for greater detail.
ORA-29864: analyzing domain indexes marked LOADING/FAILED not supported
Cause: Tried to analyze a domain index which was marked as LOADING or FAILED.
Action: If the index was marked LOADING, wait till it is marked valid before retrying the analyze. If index was marked FAILED, drop it OR rebuild it and retry the analyze.
ORA-29865: indextype is invalid
Cause: The indextype is invalid.
Action: Drop and recreate the indextype.
ORA-29866: cannot create domain index on a column of index-organized table
Cause: Tried to create a domain index on a column of an index-organized table.
Action: Do not attempt to create a domain index on columns of an index-organized table.
ORA-29867: cannot create a domain index on a LONG column
Cause: The user attempted to create a domain index on a column of LONG datatype.
Action: Do not create a domain index on a LONG column.
ORA-29868: cannot issue DDL on a domain index marked as LOADING
Cause: Tried to issue a DROP/ALTER/TRUNCATE on a domain index in a LOADING state.
Action: Wait till the index operation completes OR issue a DROP INDEX FORCE to drop the index.
ORA-29869: cannot issue ALTER without REBUILD on a domain index marked FAILED
Cause: Tried to issue a DROP/ALTER on a domain index in a FAILED state.
Action: Truncate the table to mark the index as valid OR do ALTER INDEX REBUILD to rebuild the index.
ORA-29870: specified options are only valid for altering a domain index
Cause: Specified the ONLINE or PARAMETERS clause with a non-domain index.
Action: Reissue the statement with the correct syntax for alter.
ORA-29871: invalid alter option for a domain index
Cause: The user specified an invalid option for altering a domain index.
Action: Reissue the alter statement with a valid option.
ORA-29872: parameters clause cannot be combined with the specified options
Cause: The user combined PARAMETERS clause with other alter index options.
Action: Reissue the statement with the correct syntax for alter.
ORA-29873: warning in the execution of ODCIINDEXDROP routine
Cause: A waring was returned from the ODCIIndexDrop routine.
Action: Check to see if the routine has been coded correctly Check the user defined warning log tables for greater details.
ORA-29874: warning in the execution of ODCIINDEXALTER routine
Cause: A waring was returned from the ODCIIndexAlter routine.
Action: Check to see if the routine has been coded correctly Check the user defined warning log tables for greater details.
ORA-29875: failed in the execution of the ODCIINDEXINSERT routine
Cause: Failed to successfully execute the ODCIIndexInsert routine.
Action: Check to see if the routine has been coded correctly.
ORA-29876: failed in the execution of the ODCIINDEXDELETE routine
Cause: Failed to successfully execute the ODCIIndexDelete routine.
Action: Check to see if the routine has been coded correctly.
ORA-29877: failed in the execution of the ODCIINDEXUPDATE routine
Cause: Failed to successfully execute the ODCIIndexUpdate routine.
Action: Check to see if the routine has been coded correctly.
ORA-29878: warning in the execution of ODCIINDEXTRUNCATE routine
Cause: A warning was returned from the ODCIIndexTruncate routine.
Action: Check to see if the routine has been coded correctly Check the user defined warning log tables for greater details.
ORA-29879: cannot create multiple domain indexes on a column list using same indextype
Cause: An attempt was made to define multiple domain indexes on the same column list using identical indextypes.
Action: Check to see if a different indextype can be used or if the index can be defined on another column list.
ORA-29880: such column list already indexed using another domain index and indextype
Cause: An attempt was made to create multiple domain indexes on a column list using indextypes which do not have disjoint operators.
Action: Check to see if the operator sets for the indextypes can be made disjoint.
ORA-29881: failed to validate indextype
Cause: Indextype cannot be compiled.
Action: Try to compile the indextype which is referenced by the domain index.
ORA-29882: insufficient privileges to execute indextype
Cause: User does not have privileges to execute the indextype.
Action: The owner of the indextype must grant appropriate privileges to the user.
ORA-29883: cannot create a domain index on column expressions
Cause: User specified an expression in the column list.
Action: Specify only simple columns in the column list for domain index.
ORA-29884: domain index is defined on the column to be dropped
Cause: An ALTER TABLE DROP COLUMN was issued on a column on which a domain index exists.
Action: Drop the domain index before attempting to drop the column.
ORA-29885: domain index is defined on the column to be modified
Cause: An ALTER TABLE MODIFY COLUMN was issued on a column on which a domain index exists.
Action: Drop the domain index before attempting to modify the column.
ORA-29886: feature not supported for domain indexes
Cause: Feature is not supported for domain indexes.
Action: No action required.
ORA-29887: cannot support row movement if domain index defined on table
Cause: An ALTER TABLE ENABLE ROW MOVEMENT was issued on a table which has a domain index defined on it.
Action: Drop the domain index if you want to enable row movement and then reissue the command.
ORA-29888: cannot create domain index on a table with row movement enabled
Cause: A create domain index statement was issued on a table that has row movement enabled.
Action: Disable the row movement in the table and then reissue the create domain index statement.
ORA-29890: specified primary operator does not have an index context
Cause: The primary operator does not have an index and scan contexts.
Action: Create the primary operator with a context clause.
ORA-29892: indextypes with array DML do not support the given data type
Cause: The user specified a REF or a LONG datatype which is not supported in CREATE/ALTER INDEXTYPE WITH ARRAY DML (DATA_TYPE, VARRAY_TYPE).
Action: Reissue the CREATE/ALTER INDEXTYPE statement without the REF or LONG datatype.
ORA-29893: indextypes without column data do not need the given data type
Cause: WITH ARRAY DML (DATA_TYPE, VARRAY_TYPE) option and WITHOUT COLUMN DATA option conflicted in an alter indextype statement
Action: Reissue the ALTER INDEXTYPE statement without the conflict.
ORA-29894: base or varray datatype does not exist
Cause: One of the base and varray datatypes specified in WITH ARRAY DML (DATA_TYPE, VARRAY_TYPE) clause could not be found.
Action: Check to see if the datatype exists and the user has EXECUTE privilege on this datatype.
ORA-29895: duplicate base datatype specified
Cause: User attempted to add a base datatype to an indextype with ARRAY DML which is already supported by the indextype
Action: Remove the duplicate base datatype and retry the command
ORA-29900: operator binding does not exist
Cause: There is no binding for the current usage of the operator.
Action: Change the operator arguments to match any of the existing bindings or add a new binding to the operator.
ORA-29901: function underlying operator binding does not exist
Cause: The function underlying the operator binding does not exist.
Action: Ensure that the function corresponding to the operator invocation exists.
ORA-29902: error in executing ODCIIndexStart() routine
Cause: The execution of ODCIIndexStart routine caused an error.
Action: Examine the error messages produced by the indextype code and take appropriate action.
ORA-29903: error in executing ODCIIndexFetch() routine
Cause: The execution of ODCIIndexFetch routine caused an error.
Action: Examine the error messages produced by the indextype code and take appropriate action.
ORA-29904: error in executing ODCIIndexClose() routine
Cause: The execution of ODCIIndexClose routine caused an error.
Action: Examine the error messages produced by the indextype code and take appropriate action.
ORA-29905: method string does not exist in type string.string
Cause: A required method with the required signature does not exist in the specified type.
Action: Add the required method to the type.
ORA-29906: indextype string.string does not exist
Cause: The indextype does not exist.
Action: Create the indextype.
ORA-29907: found duplicate labels in primary invocations
Cause: There are multiple primary invocations of operators with the same number as the label.
Action: Use distinct labels in primary invocations.
ORA-29908: missing primary invocation for ancillary operator
Cause: The primary invocation corresponding to an ancillary operator is missing.
Action: Add the primary invocation with the same label as the ancillary operator.
ORA-29909: label for the ancillary operator is not a literal number
Cause: The label used for invoking the ancillary operator is not a literal number.
Action: Use a literal number as the label.
ORA-29910: invalid callback operation
Cause: Encountered an invalid callback operation.
Action: Ensure that all the callbacks executed from callouts are valid in the statement context.
ORA-29911: null scan context returned by ODCIIndexStart() routine
Cause: The ODCIIndexStart() routine returned a null scan context
Action: Ensure that the ODCIIndexStart() routine returns a non-null scan context.
ORA-29913: error in executing string callout
Cause: The execution of the specified callout caused an error.
Action: Examine the error messages take appropriate action.
ORA-29914: ODCIGETINTERFACES routine does not return required stream version
Cause: The ODCIObjectList returned by the ODCIGetInterfaces routine does not contain the required stream version for external tables.
Action: Ensure that the ODCIGetInterfaces routine returns the required stream version.
ORA-29915: cannot select FOR UPDATE from collection operand
Cause: Collection operands cannot be updated
Action: Remove FOR UPDATE clause
ORA-29917: cannot lock a table which gets its rows from a collection operand
Cause: Tables which gets its rows from a collection operand cannot be locked
Action: Don't lock the table
ORA-29925: cannot execute string
Cause: The specified function does not exist or does not have an appropriate signature.
Action: Implement the function with the appropriate signature.
ORA-29926: association already defined for the object
Cause: The object for which the association is being defined, already has a statistics type associated with it.
Action: Disassociate the object and then associate the object.
ORA-29927: error in executing the ODCIStatsCollect / ODCIStatsDelete routine
Cause: The ODCIStatsCollect / ODCIStatsDelete function is causing an error.
Action: Check the ODCIStatsCollect / ODCIStatsDelete function.
ORA-29928: duplicate default selectivity specified
Cause: The keyword DEFAULT SELECTIVITY can only be specified once.
Action: Remove the duplicate keyword.
ORA-29929: missing SCAN Keyword
Cause: The scan context is not specified.
Action: Supply the SCAN keyword.
ORA-29930: COMPUTE ANCILLARY DATA specified without the INDEX CONTEXT clause
Cause: The COMPUTE ANCILLARY DATA option was specified without the WITH INDEX CONTEXT clause.
Action: Specify the WITH INDEX CONTEXT option.
ORA-29931: specified association does not exist
Cause: One or more of the object(s) that have been specified to be disassociated, do not have an association defined for them.
Action: Verify the objects which have an association defined and issue the disassociate command again.
ORA-29932: the type being dropped is a statistics type
Cause: Some objects have defined their statistics methods in the type being dropped.
Action: First drop the relevant associations using the DISASSOCIATE command and then retry the DROP command, or use the FORCE option with DROP TYPE command.
ORA-29933: object being disassociated has some user defined statistics stored
Cause: There are some user defined statistics collected for the object being disassociated.
Action: First delete the user defined statistics and then reissue the DISASSOCIATE command or specify the FORCE option with DISASSOCIATE.
ORA-29934: index specified for association is not a domain index
Cause: The user issued an ASSOCIATE STATISTICS command with an index which is not a domain index.
Action: Issue an ASSOCIATE STATISTICS WITH INDEXES command on a domain index only
ORA-29935: missing FROM keyword
Cause: The keyword FROM is missing.
Action: Specify the FROM keyword or check the SQL statement.
ORA-29936: NULL association is allowed only with a column or an index
Cause: User tried to use the ASSOCIATE command with a schema object other than a column or an index
Action: Specify the NULL clause only with a column or an index
ORA-29950: warning in the execution of ODCIINDEXMERGEPARTITION routine
Cause: A warning was returned from the ODCIIndexMergePartition routine.
Action: Check to see if the routine has been coded correctly Check user specified log tables for greater detail.
ORA-29951: warning in the execution of ODCIINDEXSPLITPARTITION routine
Cause: A warning was returned from the ODCIIndexSplitPartition routine.
Action: Check to see if the routine has been coded correctly Check user specified log tables for greater detail.
ORA-29952: cannot issue DDL on a domain index partition marked as LOADING
Cause: Tried to issue a DROP/ALTER/TRUNCATE on a domain index partition in a LOADING state.
Action: Wait till the index partition operation completes OR issue a DROP INDEX FORCE to drop the index OR issue a ALTER TABLE DROP PARTITION to drop the partition.
ORA-29953: cannot issue DDL on a domain index partition marked as FAILED
Cause: Tried to issue a DROP/ALTER on a domain index partition in a FAILED state.
Action: do ALTER INDEX REBUILD PARTITION to rebuild the index partition OR ALTER TABLE TRUNCATE PARTITION to mark the index partition as valid.
ORA-29954: domain index partition is marked LOADING/FAILED/UNUSABLE
Cause: An attempt has been made to access a domain index that is being built or is marked failed by an unsuccessful DDL or is marked unusable by a DDL operation.
Action: Wait if the specified index partition is marked LOADING Rebuild the specified index partition if it is marked FAILED or UNUSABLE.
ORA-29955: error occurred in the execution of ODCIINDEXEXCHANGEPARTITION routine
Cause: Failed to successfully execute the ODCIIndexExchangePartition routine.
Action: Check to see if the routine has been coded correctly.
ORA-29956: warning in the execution of ODCIINDEXEXCHANGEPARTITION routine
Cause: A warning was returned from the ODCIIndexExchangePartition routine.
Action: Check to see if the routine has been coded correctly Check user specified log tables for greater detail.
ORA-29957: cannot create a function-based domain index on a string table
Cause: User specified an unsupported create function-based domain index statement.
Action: Issue the create function-based domain index statement only on supported types of tables.
ORA-29958: fatal error occurred in the execution of ODCIINDEXCREATE routine
Cause: Failed to successfully execute the ODCIIndexCreate routine.
Action: Check to see if the routine has been coded correctly.
ORA-29959: error in the execution of the string routine for one or more of the index partitions
Cause: An error occurred during execution of the routine for one or more of the index partitions
Action: Check the *_IND_PARTITIONS view to see which partitions are marked FAILED. Rebuild or Truncate the FAILED index partitions
ORA-29960: line string, string
Cause: The ODCIIndex DDL routine has put a warning message into table SYS.ODCI_WARNINGS$
Action: Check the warning message
ORA-29961: too many warnings occurred in the execution of ODCIIndex DDL routine
Cause: The number of warnings during the ODCIIndex DDL routine is too high.
Action: Query table SYS.ODCI_WARNINGS$ to get more warning messages
ORA-29962: fatal error occurred in the execution of ODCIINDEXALTER routine
Cause: Failed to successfully execute the ODCIIndexAlter routine.
Action: Check to see if the routine has been coded correctly.
ORA-29963: missing BINDING keyword
Cause: Keyword BINDING is expected .
Action: Specify the BINDING keyword or check the SQL statement.
ORA-29964: missing ADD or DROP keyword
Cause: One of the keywords ADD or DROP is expected.
Action: Specify the ADD or DROP keyword or check the SQL statement.
ORA-29965: The specified binding does not exist
Cause: The binding specified in the DROP BINDING clause is not a valid binding for this operator.
Action: Specify an existing binding for this op in DROP BINDING clause.
ORA-29966: The only binding of an operator cannot be dropped
Cause: This operator only has one binding. It cannot be dropped using Alter Operator Drop Binding.
Action: If you wish to drop the entire operator, call Drop Operator.
ORA-29967: Cannot drop an operator binding with dependent objects
Cause: The operator binding that is being dropped has dependent objects.
Action: Either drop the dependent objects first and then issue the ALTER OPERATOR DROP BINDING command or specify the FORCE option with ALTER OPERATOR DROP BINDING.
ORA-29968: No primary operator bindings found for ancillary binding #string
Cause: At least one ancillary binding of the specified operator could not be validated because all of its associated primary operator bindings have been dropped.
Action: Either drop the ancillary binding whose primary operators are missing, or drop the entire operator, if this is the only binding. This binding cannot be re-validated.
ORA-30000: missing either trim specification or char expression in TRIM
Cause: Since FROM is specified in TRIM function, either trim specification (TRAILING, HEADING, BOTH) or trim character or both must be specified.
Action: Add either trim specification (TRAILING, HEADING, BOTH) or trim character or both.
ORA-30001: trim set should have only one character
Cause: Trim set contains more or less than 1 character. This is not allowed in TRIM function.
Action: Change trim set to have only 1 character.
ORA-30002: SYS_CONNECT_BY_PATH function is not allowed here
Cause: SYS_CONNECT_BY_PATH function is called at places other than select list.
Action: Remove calls to SYS_CONNECT_BY_PATH function at places other than select list.
ORA-30005: missing or invalid WAIT interval
Cause: A non-zero integer must be specified for wait interval (in seconds) after the WAIT keyword.
Action: Correct the syntax and retry.
ORA-30006: resource busy; acquire with WAIT timeout expired
Cause: The requested resource is busy.
Action: Retry the operation later.
ORA-30011: Error simulated: psite=string, ptype=string
Cause: error generated for testing purposes.
Action: None.
ORA-30012: undo tablespace 'string' does not exist or of wrong type
Cause: the specified undo tablespace does not exist or of the wrong type.
Action: Correct the tablespace name and reissue the statement.
ORA-30013: undo tablespace 'string' is currently in use
Cause: the specified undo tablespace is currently used by another instance.
Action: Wait for the undo tablespace to become available or change to another name and reissue the statement.
ORA-30014: operation only supported in Automatic Undo Management mode
Cause: the operation is only supported in automatic undo mode.
Action: restart instance in Automatic Undo Management mode before retrying operation.
ORA-30015: previously offlined undo tablespace 'string' is still pending
Cause: the current operation is not allowed because an undo tablespace containing active transactions is pending from a previous SWITCH UNDO operation. The operation will be allowed again after all transactions in the previous undo tablespace are committed.
Action: Wait for all previous transactions to commit before reissuing the current statement.
ORA-30016: undo tablespace 'string' is already in use by this instance
Cause: the specified undo tablespace is currently used by this instance. The operation failed.
Action: If the specified undo tablespace name is wrong, reissue the statement with the correct name.
ORA-30017: segment 'string' is not supported in string Undo Management mode
Cause: the type of the specified undo segment is incompatible with the current undo management mode of the instance.
Action: Check the undo segment name and the undo management mode and reissue statement if necessary.
ORA-30018: Create Rollback Segment failed, USN string is out of range
Cause: the system runs out of undo segment number. Too many undo segments exist.
Action: drop some of the unused undo segments and retry operation.
ORA-30019: Illegal rollback Segment operation in Automatic Undo mode
Cause: This operation only allowed in Manual Undo mode.
Action: restart instance in Manual Undo_Management mode and retry operation.
ORA-30020: UNDO_MANAGEMENT=AUTO needs Compatibility string or greater
Cause: Auto undo management mode not allowed in specified compatibility release
Action: restart instance in correct compatibility release
ORA-30021: Operation not allowed on undo tablespace
Cause: This operation is not allowed on undo tablespaces
Action: Check the tablespace name and reissue command if necessary
ORA-30022: Cannot create segments in undo tablespace
Cause: Cannot create segments in undo tablespace
Action: Check the tablespace name and reissue command
ORA-30023: Duplicate undo tablespace specification
Cause: Cannot create more than one undo tablespace during database creation
Action: Modify the command to contain only one undo tablespace
ORA-30024: Invalid specification for CREATE UNDO TABLESPACE
Cause: You have specified an clause that should not used with CREATE UNDO TABLESPACE
Action: Drop the clause from the command and reissue it.
ORA-30025: DROP segment 'string' (in undo tablespace) not allowed
Cause: Explicit DROP operation is not allowed on undo tablespace segments
Action: Check the undo segment name and reissue statement if necessary.
ORA-30026: Undo tablespace 'string' has unexpired undo with string(sec) left, Undo_Retention=string(sec)
Cause: Tried to drop a tablespace that contains unexpired undo information
Action: lower setting of UNDO_RETENTION or wait a while before reissue command to drop undo tablespace
ORA-30027: Undo quota violation - failed to get string (bytes)
Cause: the amount of undo assigned to the consumer group of this session has been exceeded.
Action: ask DBA to increase undo quota, or wait until other transactions to commit before proceeding.
ORA-30029: no active undo tablespace assigned to instance
Cause: the current instance does not have an active undo tablespace assigned to execute transactions.
Action: ask DBA to create an undo tablespace, online the undo tablespace and then retry operation.
ORA-30030: suppress resumable related error message
Cause: none
Action: This event is to be used if the errors 30031 and 30032 wish to be suppressed.
ORA-30031: the suspended (resumable) statement has been aborted
Cause: DBA or the user aborted the execution of the suspended statement in the resumable session
Action: none
ORA-30032: the suspended (resumable) statement has timed out
Cause: A correctible error was signaled in the resumable session and the error was not cleared within the timeout interval.
Action: Fix the correctible error within the timeout. Default is 2 hours. Or increase the (resumable) timeout.
ORA-30033: Undo tablespace cannot be specified as default user tablespace
Cause: It is incorrect to specify undo tablespace as default user tablespace
Action: Check the tablespace name and reissue the command
ORA-30034: Undo tablespace cannot be specified as temporary tablespace
Cause: Undo tablespace cannot be specified as default temporary tablespace for the user
Action: Check the tablespace name and reissue the command
ORA-30035: Undo tablespace cannot be specified as default temporary tablespace
Cause: Undo tablespace cannot be specified as default temporary tablespace for the database
Action: Check the tablespace name and reissue the command
ORA-30036: unable to extend segment by string in undo tablespace 'string'
Cause: the specified undo tablespace has no more space available.
Action: Add more space to the undo tablespace before retrying the operation. An alternative is to wait until active transactions to commit.
ORA-30037: Cannot perform parallel DML after a prior DML on the object
Cause: Attempt to perform parallel DML after another DML on the same object in the same transaction.
Action: Use bitmap segments to perform multiple (parallel) DML operations on the same object. Or commit before issueing the DML
ORA-30038: Cannot perform parallel insert on non-partitioned object
Cause: Attempt to perform parallel insert on a non-partitioned object after a previous DML on the object in the same transaction.
Action: Commit before issueing the insert.
ORA-30039: Cannot drop the undo tablespace
Cause: Cannot drop an undo tablespace that is in use
Action: Switch to a different undo tablespace and then try to drop
ORA-30040: Undo tablespace is offline
Cause: Cannot operate on an offlined undo tablespace
Action: Online the undo tablespace and redo the operation
ORA-30041: Cannot grant quota on the tablespace
Cause: User tried to grant quota on an undo tablespace
Action: Check the tablespace name and reissue the command
ORA-30042: Cannot offline the undo tablespace
Cause: Cannot offline an undo tablespace that is in use
Action: Switch to a different undo tablespace and then try to offline
ORA-30043: Invalid value 'string' specified for parameter 'Undo_Management'
Cause: the specified undo management mode is invalid
Action: Correct the parameter value in the initialization file and retry the operation.
ORA-30044: 'Retention' can only specified for undo tablespace
Cause: An attempt was made to specify retention for a non-undo tablespace.
Action: Modify the CREATE TABLESPACE statement.
ORA-30045: No undo tablespace name specified
Cause: If Create Database has the datafile clause, then undo tablespace name has to be specified, unless using OMF.
Action: Specify the undo tablespace name.
ORA-30046: Undo tablespace string not found in controlfile.
Cause: The specified undo tablespace is not present in the control file.
Action: Modify the CREATE CONTROLFILE statement that created the current control file to include undo tablespace(s) and reissue the statement.
ORA-30051: VERSIONS clause not allowed here
Cause: A VERSIONS clause was specified when it was not allowed.
Action: Do not use the VERSIONS clause
ORA-30052: invalid lower limit snapshot expression
Cause: The lower limit snapshot expression was below the UNDO_RETENTION limit.
Action: Specify a valid lower limit snapshot expression.
ORA-30053: invalid upper limit snapshot expression
Cause: The upper limit snapshot expression is greater than the SQL statement read snapshot.
Action: Specify a valid upper limit snapshot expression.
ORA-30054: invalid upper limit snapshot expression
Cause: The upper limit snapshot expression is less than the lower limit snapshot expression.
Action: Specify a valid upper limit snapshot expression.
ORA-30055: NULL snapshot expression not allowed here
Cause: The snapshot expression is NULL.
Action: Specify a non-NULL snapshot expression.
ORA-30071: conversion between datetime/interval and string fail
Cause: An error occurs during a conversion between datetime/interval and string data type due to one of the following reasons:

- The buffer is too short to hold the result.

- The format string is bad.

Action: none
ORA-30072: invalid time zone value
Cause: The value specified for the time zone string, which appears in ALTER SESSION statement, environment variable ORA_SDTZ, or a datetime factor, is not valid.
Action: none
ORA-30073: invalid adjustment value
Cause: The value is none of the followings: 'ADJUST', 'NO_ADJUST', 'ANSI_DATE', 'ADJUST_WITH_ANSI_DATE'. 'NO_ADJUST' is the default value.
Action: set it to one of the three values
ORA-30074: GLOBAL partitioned index on TIME/TIMESTAMP WITH TIME ZONE not allowed
Cause: try to GLOBAL partitioned index on TIME/TIMESTAMP WITH TIME ZONE.
Action: Do not GLOBAL partitioned index on TIME/TIMESTAMP WITH TIME ZONE.
ORA-30075: TIME/TIMESTAMP WITH TIME ZONE literal must be specified in CHECK constraint
Cause: User is trying to create a constraint on a time or timestamp with or without time zone column without explicitly specifying the time zone.
Action: Use time or timestamp with time zone literals only.
ORA-30076: invalid extract field for extract source
Cause: The extract source does not contain the specified extract field.
Action: none
ORA-30077: illegal casting between specified datetime types
Cause: Cannot cast between the specified datetime types.
Action: none
ORA-30078: partition bound must be TIME/TIMESTAMP WITH TIME ZONE literals
Cause: An attempt was made to use a time/timestamp expression whose format does not explicitly have time zone on a TIME/TIMESTAMP or TIME/TIMESTAMP WITH TIME ZONE column.
Action: Explicitly use TIME/TIMESTAMP WITH TIME ZONE literal.
ORA-30079: cannot alter database timezone when database has TIMESTAMP WITH LOCAL TIME ZONE columns
Cause: An attempt was made to alter database timezone with TIMESTAMP WITH LOCAL TIME ZONE column in the database.
Action: Either do not alter database timezone or first drop all the TIMESTAMP WITH LOCAL TIME ZONE columns.
ORA-30081: invalid data type for datetime/interval arithmetic
Cause: The data types of the operands are not valid for datetime/interval arithmetic.
Action: none
ORA-30082: datetime/interval column to be modified must be empty to decrease fractional second or leading field precision
Cause: datetime/interval column with existing data is being modified to decrease fractional second or leading field precisions.
Action: Such columns are only allowed to increase the precisions.
ORA-30083: syntax error was found in interval value expression
Cause: A syntax error was found during parsing an interval value value expression.
Action: Correct the syntax.
ORA-30084: invalid data type for datetime primary with time zone modifier
Cause: When a time zone modifier is specified, the data type of datetime primary must be one of the following: TIME, TIME WITH TIME ZONE, TIMESTAMP, TIMESTAMP WITH TIME ZONE.
Action: none
ORA-30085: syntax error was found in overlaps predicate
Cause: A syntax error was found during parsing an overlaps predicate.
Action: Correct the syntax.
ORA-30086: interval year-month result not allowed for datetime subtraction
Cause: An attempt was made to specify interval year to month as the result of datetime subtraction.
Action: This is not allowed currently due to unclear specification in SQL Standards for this interval type. Change the interval type to interval day to second and resubmit statement.
ORA-30087: Adding two datetime values is not allowed
Cause: An attempt was made to add two datetime values.
Action: This addition is not allowed.
ORA-30088: datetime/interval precision is out of range
Cause: The specified datetime/interval precision was not between 0 and 9.
Action: Use a value between 0 and 9 for datetime/interval precision.
ORA-30089: missing or invalid <datetime field>
Cause: A <datetime field> (YEAR, MONTH, DAY, HOUR, MINUTE, SECOND) is expected but not found, or a <datetime field> specified the <end field> in an <interval qualifier> is more significant than its <start field>.
Action: none
ORA-30100: internal error [number]
Cause: An internal error has occurred.
Action: Contact Oracle Worldwide Support and report the error.
ORA-30101: unknown parameter name 'string'
Cause: You have misspelled the parameter name.
Action: Spell the parameter name correctly.
ORA-30102: 'string' is not in the legal range for 'string'
Cause: The value of the parameter is not within the legal range.
Action: Refer to the manual for the allowable values for this parameter.
ORA-30103: 'string' contains an illegal integer radix for 'string'
Cause: An illegal integer radix specification was found.
Action: Only 'd', 'h', 'D', and 'H' may be used as radix specifications.
ORA-30104: 'string' is not a legal integer for 'string'
Cause: The value is not a valid integer.
Action: Specify only valid integers for this parameter.
ORA-30105: 'string' is not a legal boolean for 'string'
Cause: The value is not a valid boolean.
Action: Refer to the manual for allowable boolean values.
ORA-30106: reserved for future use
Cause: None.
Action: None.
ORA-30107: parameter name abbreviation 'string' is not unique
Cause: The abbreviation given was not unique.
Action: Use a longer abbreviation to make the parameter name unique.
ORA-30108: invalid positional parameter value 'string'
Cause: An invalid positional parameter value has been entered.
Action: Remove the invalid positional parameter.
ORA-30109: could not open parameter file 'string'
Cause: The parameter file does not exist.
Action: Create an appropriate parameter file.
ORA-30110: syntax error at 'string'
Cause: A syntax error was detected.
Action: Change the input so that the correct syntax is used.
ORA-30111: no closing quote for value 'string'
Cause: A quoted string was begun but not finished.
Action: Put a closing quote in the proper location.
ORA-30112: multiple values not allowed for parameter 'string'
Cause: You attempted to specify multiple values for a parameter which can take only one value.
Action: Do not specify more than one value for this parameter.
ORA-30113: error when processing file 'string'
Cause: A problem occurred when processing this file.
Action: Examine the additional error messages and correct the problem.
ORA-30114: error when processing from command line
Cause: A problem occurred when processing the command line.
Action: Examine the additional error messages and correct the problem.
ORA-30115: error when processing an environment variable
Cause: A problem occurred when processing an environment variable.
Action: Examine the additional error messages and correct the problem.
ORA-30116: syntax error at 'string' following 'string'
Cause: A syntax error was detected.
Action: Change the input so that the correct syntax is used.
ORA-30117: syntax error at 'string' at the start of input
Cause: A syntax error was detected.
Action: Change the input so that the correct syntax is used.
ORA-30118: syntax error at 'string' at the end of input
Cause: A syntax error was detected.
Action: Change the input so that the correct syntax is used.
ORA-30119: unable to obtain a valid value for 'string'
Cause: No valid value was obtained for this parameter.
Action: Rerun the application and enter a valid value.
ORA-30120: 'string' is not a legal oracle number for 'string'
Cause: The value is not a valid oracle number.
Action: Refer to the manual for allowable oracle number values.
ORA-30121: 'string' is not an allowable value for 'string'
Cause: The value is not a legal value for this parameter.
Action: Refer to the manual for allowable values.
ORA-30122: value 'string' for 'string' must be between 'number' and 'number'
Cause: The value of the parameter is not within the legal range.
Action: Specify a value that is within the legal range.
ORA-30129: invalid function argument received
Cause: A function received an invalid argument
Action: Check function calls, make sure correct arguments are being passed.
ORA-30130: invalid parameter key type received
Cause: A function received an invalid parameter key type
Action: Check parameter key types in function calls
ORA-30131: number of keys being set exceeds allocation
Cause: Number of parameter keys being set exceeds allocation
Action: Reduce the number of keys being set or increase allocation
ORA-30132: invalid key index supplied
Cause: The key index specified was not within bounds
Action: Change key index to ensure it lies within bounds
ORA-30133: reserved for future use
Cause: None.
Action: None.
ORA-30134: reserved for future use
Cause: None.
Action: None.
ORA-30135: OCI Thread operation fails
Cause: An OCI Thread function call has failed.
Action: Check the function call to make sure that the correct parameters are being passed and take the apropriate action.
ORA-30150: Invalid argument passed to OCIFile function
Cause: An invalid argument is passed to the OCIFile function. The most common cause is that a NULL pointer is passed where a non-NULL pointer is expected.
Action: Make sure that the values passed as arguments are valid. Esp check for NULL pointers.
ORA-30151: File already exists
Cause: Tried to open a file with OCI_FILE_EXCL flag and the file already exists.
Action: OCIFile is supposed throw this exception in this case.
ORA-30152: File does not exist
Cause: The OCIFile function requires the file to exist, but it does not.
Action: Make sure that the file exists.
ORA-30153: An invalid File Object is passed to the OCIFile function
Cause: An invalid File Object is passed to the OCIFile function.
Action: Make sure that the file object is a valid one. Create a new file object by calling OCIFileOpen if needed.
ORA-30154: The memory address given as buffer for OCIFileRead/Write is invalid
Cause: An invalid memory address is given as the buffer pointer for OCIFileRead/Write.
Action: Make sure that the required memory is allocated and pass a valid memory address as buffer pointer.
ORA-30155: An I/O Error occured during an OCIFile function call
Cause: An I/O error occurred at the system level.
Action: This is a system error and the action will depnd on the error.
ORA-30156: Out of disk space
Cause: The disks associated with the underlying file system are full.
Action: Create more disk space.
ORA-30157: An invalid argument was given to operating system call
Cause: The OS call was called with an invalid argument.
Action: Check the values passed. If unsuccessful to solve the problem contact ORACLE support.
ORA-30158: The OCIFileWrite causes the file to exceed the maximum allowed size
Cause: There is no space to write to the file. Its size is at the maximum limit.
Action: Up to the user.
ORA-30159: OCIFileOpen: Cannot create the file or cannot open in the requested mode
Cause: The create flag was specified in OCIFileOpen such that the file was to be created. But unable to do so. Or the file already exists and the permissions on it doesn't allow the file to be opened in in the requested open mode
Action: Check whether the user has permissions to create the specified file or if the file exists whether the permissions on it allow the requested open mode.
ORA-30160: Unable to access the file
Cause: The function was unable to access the existing the file.
Action: Check if the user has the required permissions on the file.
ORA-30161: A system error occurred during the OCIFile function call
Cause: A system error occured while executing the OCIFile function.
Action: Depend on the error.
ORA-30162: The OCIFile context is not initialzed
Cause: The function OCIFileInit need to be called before calling any other OCIFile function to initialize the OCIFile context.
Action: Call the function OCIFileInit need to be called before calling any other OCIFile function.
ORA-30163: The thread safety initialization failed
Cause: The call to SlgInit failed in OCIFileInit.
Action: Contact support
ORA-30175: invalid type given for an argument
Cause: There is an argument with an invalid type in the argument list.
Action: Use the correct type wrapper for the argument.
ORA-30176: invalid format code used in the format string
Cause: There is an invalid format code in the format string.
Action: Replace the invalid format code with a valid one.
ORA-30177: invalid flag used in a format specification
Cause: There is an invalid flag in a format specification.
Action: Replace the invalid flag with a valid one.
ORA-30178: duplicate flag used in a format specification
Cause: There is a duplicate flag in a format specification.
Action: Remove the duplicate flag.
ORA-30179: invalid argument index used in a format code
Cause: Zero or negative argument index or index not following (."
Action: Replace the invalid argument index with a valid one.
ORA-30180: argument index is too large
Cause: An argument index exceeds actual number of arguments supplied.
Action: Fix format string or pass additional arguments.
ORA-30181: integer in argument index is not immediately followed by )
Cause: Missing closing parenthesis in argument index.
Action: Fix the format specification.
ORA-30182: invalid precision specifier
Cause: Period in format specification not followed by valid format.
Action: Replace the invalid precision specifier with a valid one.
ORA-30183: invalid field width specifier
Cause: Invalid field width supplied.
Action: Replace the invalid field width with a valid one.
ORA-30184: argument type not compatible with a format code
Cause: Bad argument type given for a format code.
Action: Make format and arguments be compatible.
ORA-30185: output too large to fit in the buffer
Cause: The buffer is not large enough to hold the entire output string.
Action: Fix the buffer size and length passed in.
ORA-30186: '' must be followed by four hexdecimal characters or another ''
Cause: In the argument of SQL function UNISTR, a '' must be followed by four hexdecimal characters or another ''
Action: Fix the string format
ORA-30187: reserved for future use
Cause: None.
Action: None.
ORA-30188: reserved for future use
Cause: None.
Action: None.
ORA-30189: reserved for future use
Cause: None.
Action: None.
ORA-30190: reserved for future use
Cause: None.
Action: None.
ORA-30191: missing argument list
Cause: No argument list supplied.
Action: Modify the argument list to have at least OCIFormatEnd in it.
ORA-30192: reserved for future use
Cause: None.
Action: None.
ORA-30193: reserved for future use
Cause: None.
Action: None.
ORA-30194: reserved for future use
Cause: None.
Action: None.
ORA-30195: reserved for future use
Cause: None.
Action: None.
ORA-30196: reserved for future use
Cause: None.
Action: None.
ORA-30197: reserved for future use
Cause: None.
Action: None.
ORA-30198: reserved for future use
Cause: None.
Action: None.
ORA-30199: reserved for future use
Cause: None.
Action: None.
ORA-30200: Wrong NLS item was passed into OCINlsGetInfo()
Cause: The item is not supported NLS item
Action: Correct the item number passed to OCINlsGetInfo().
ORA-30201: Unable to load NLS data object
Cause: It may be caused by invalid NLS environment setting
Action: Check your NLS environment setting such as ORA_NLS33
ORA-30202: NULL pointer to OCIMsgh was passed to OCIMsg function
Cause: The NULL pointer was passed.
Action: Check your value of OCIMsgh pointer.
ORA-30203: Cannot open mesage file
Cause: The message may not exist in your system.
Action: Check your message for the given product and facility.
ORA-30204: buffer is not large enougth
Cause: The destination buffer is not large enough for storing converted data.
Action: Check the size of the destination buffer.
ORA-30205: invalid Character set
Cause: The specified character set is invalid.
Action: Check if the character set ID is valid.
ORA-30331: summary does not exist
Cause: A non-existant summary name was specified.
Action: Check the spelling of the summary name.
ORA-30332: container table already in use by other summary
Cause: Another summary is already using this table as a container table.
Action: Select another table or materialized view as the container table for this summary.
ORA-30333: dimension does not exist
Cause: The dimension named in a dimension DDL statment does not exist.
Action: Check the spelling of the dimension name.
ORA-30334: illegal dimension level name
Cause: A level name in a dimension ddl statement did not conform to SQL identifier rules.
Action: Use a level name that begins with a letter, consists of only letters, digits, and underscores and contains no more than 30 characters.
ORA-30335: JOIN KEY clause references a level not in this hierarchy
Cause: The level name specified with the REFERENCES portion of a JOIN KEY clause in a dimension DDL statement does not reference a level in the hierarchy that contains the JOIN KEY clause. *Acction: Check the spelling of the level name.
Action: none
ORA-30336: no child for specified JOIN KEY
Cause: The level specified in the REFERENCES portion of a JOIN KEY clause in a dimension DDL statement does not have a child level.
Action: Check the spelling of the level name referenced in the JOIN KEY clause. If the referenced level is the first level in the hierarchy, you need not and must not specify a JOIN KEY clause.
ORA-30337: multiple JOIN KEY clauses specified for the same parent level
Cause: More than one JOIN KEY clause was specified for a given parent level in a dimension hierarchy.
Action: Match up each JOIN KEY clause with the level it references in the hierarchy. Eliminate the redundant JOIN KEY clause.
ORA-30338: illegal dimension hierachy name
Cause: An illegal dimension hierarchy name was specified in a dimension DDL statement.
Action: Make sure the name begins with a letter, contains only letters, digits and underscore and contains no more than 30 characters. If you qualify the name with the owner name, make sure the owner name conforms with the requirements for an owner name on your system.
ORA-30339: illegal dimension attribute name
Cause: An illegal dimension attribute name was specified in a dimension DDL statement.
Action: Make sure the name begins with a letter, contains only letters, digits and underscore and contains no more than 30 characters. If you qualify the name with the owner name, make sure the owner name conforms with the requirements for an owner name on your system.
ORA-30340: illegal dimension name
Cause: An illegal dimension name was specified in a dimension DDL statement.
Action: Make sure the name begins with a letter, contains only letters, digits and underscore and contains no more than 30 characters. If you qualify the name with the owner name, make sure the owner name conforms with the requirements for an owner name on your system.
ORA-30341: dropped level has references
Cause: An attempt was made to drop a level using the default or RESTRICT option in a dimension while references to that level remain in the dimension. References can occur in hierarchies and attributes within the dimension.
Action: First remove any referenes to the level prior to dropping it, or specify the CASCADE option with the DROP LEVEL clause.
ORA-30342: referenced level is not defined in this dimension
Cause: A reference to a level not defined within the dimension was found.
Action: Check the spelling of the level name.
ORA-30343: level name is not unique within this dimension
Cause: Two or more levels were defined with the same name.
Action: Check the spelling of the level names.
ORA-30344: number of child cols different from number of parent level cols
Cause: The number of child columns specified in a JOIN KEY clause is not the same as the number of columns in the specified parent level.
Action: Check the child columns and the columns in the definition of the referenced parent level and correct the discrepency.
ORA-30345: circular dimension hierarchy
Cause: A circularity was found the dimension hierarchy.
Action: Check the hierarchy for a level name that occurs more than once.
ORA-30346: hierarchy name must be unique within a dimension
Cause: The same name was used for more than one hierarchy in a dimension.
Action: Check the spelling of the hierarchy name.
ORA-30347: a table name is required to qualify the column specification
Cause: A table name was omitted in a column specification where where the column must be qualified by the table name.
Action: Qualify the column with the table name.
ORA-30348: ADD and DROP cannot both be specified
Cause: One or more ADD clauses were found in the same ALTER DIMENSION statement with one or more DROP clauses.
Action: Separate your ADD operations into one ALTER DIMENSION statement and your DROP operations into another.
ORA-30349: specified dimension hierarchy does not exist
Cause: A hierarchy name was encountered that is not defined within the dimension.
Action: Check the spelling of the hierarchy name.
ORA-30350: specified dimension attribute does not exist
Cause: An attribute name was encountered that is not defined within the dimension.
Action: Check the attribute name spelling.
ORA-30351: query rewrite does not currently support this expression
Cause: A complex expression was specified that is is not currently supported by query rewrite.
Action: Reduce the complexity of the expression.
ORA-30352: inconsistent numeric precision or string length
Cause: The SELECT expression was of a different numeric precision or string length than the corresponding container column. Therefore, query rewrite cannot guarantee results that are identical to the results obtained with the un-rewritten query.
Action: Correct the precision or string length difference, specify the WITH REDUCED PRECISION option, or disable the REWRITE option on the materialized view.
ORA-30353: expression not supported for query rewrite
Cause: The select clause referenced UID, USER, ROWNUM, SYSDATE, CURRENT_TIMESTAMP, MAXVALUE, a sequence number, a bind variable, correlation variable, a set result,a trigger return variable, a parallel table queue column, collection iterator, etc.
Action: Remove the offending expression or disable the REWRITE option on the materialized view.
ORA-30354: Query rewrite not allowed on SYS relations
Cause: A SYS relation was referenced in the select clause for a materialized view with query rewrite enabled.
Action: Remove the reference to the SYS relation from the select clause or disable the REWRITE option on the materialized view.
ORA-30355: materialized view container does not exist
Cause: A DROP TABLE command was issued directly against the materialized view container table.
Action: Use the DROP MATERIALIZED VIEW command to clean up the residual meta data for the materialized view. Then use the CREATE MATERIALIZED VIEW statement to recreate the materialized view. Thereafter, use the DROP MATERIALIZED VIEW command rather than the DROP TABLE command to drop a materialized view.
ORA-30356: the specified refresh method is not supported in this context
Cause: The refresh method that was specified is not currently supported.
Action: Specify a different refresh method or change the context to enable support of the chosen refresh method.
ORA-30357: this PL/SQL function cannot be supported for query rewrite
Cause: The statement referenced a PL/SQL function that is not marked DETERMINISTIC.
Action: Perform one of the following actions:

- Remove the use of the PL/SQL function.

- Mark the PL/SQL function as DETERMINISTIC.

- Disable the REWRITE option on the materialized view. The function should be marked DETERMINISTIC only if it always returns the same result value for any given set of input argument values, regardless of any database state or session state. Do not mark the function as DETERMINISTIC if it has any meaningful side-effects.

ORA-30358: summary and materialized view are not in same schema
Cause: An internal Oracle error occured.
Action: Report the problem through your normal support channels.
ORA-30359: Query rewrite is not supported on SYS materialized views
Cause: An attempt was made to enable the REWRITE option on a materialized view in the SYS schema.
Action: Create the materialized view in a different schema or disable the REWRITE option.
ORA-30360: REF not supported with query rewrite
Cause: The statement contained a REF operator. Repeatable behavior cannot be guaranteed with the REF operator. Therefore, query rewrite cannot support the REF operator.
Action: Remove the reference to the REF operator or disable the REWRITE option on the materialized view.
ORA-30361: unrecognized string type
Cause: An internal Oracle error occured.
Action: Report the problem through your normal support channels.
ORA-30362: dimension column cannot be a sequence
Cause: The dimension statement referenced a column that is a sequence.
Action: Remove the reference to the sequence.
ORA-30363: columns in a dimension column list must be in the same relation
Cause: The dimension statement contained a column list where the columns are not all from the same relation.
Action: Specify the list of columns using only columns from a single relation.
ORA-30364: this level has the same set of columns as another
Cause: The level definition contained the same set of columns as another level.
Action: Eliminate the redundant level definition.
ORA-30365: left relation in the JOIN KEY clause cannot be same as right
Cause: The relation of the child columns on the left side of the JOIN KEY clause was the same as that of the parent level on the right side.
Action: Remove the JOIN KEY clause. It is not required or allowed when the child and the parent are in the same relation.
ORA-30366: child JOIN KEY columns not in same relation as child level
Cause: The relation of the child columns on the left side of the JOIN KEY clause differed from that of that child level.
Action: Specify the correct child columns in the JOIN KEY clause.
ORA-30367: a JOIN KEY clause is required
Cause: A JOIN KEY clause was omitted in a dimension statement. A JOIN KEY clause is required when the child level and the parent level are not in the same relation.
Action: Specify a JOIN KEY clause to indicate how the relation of the child level joins to the relation of the parent level.
ORA-30368: ATTRIBUTE cannot determine column in a different relation
Cause: An ATTRIBUTE clause in a dimension statement specified a determined column on the right that is in a different relation than that of the level on the left.
Action: Specify attibutes only for those dimension levels that functionally determine other columns within the same relation.
ORA-30369: maximum number of columns is 32
Cause: A list of columns was specified using more than 32 columns.
Action: Specify the list using no more than 32 columns.
ORA-30370: set operators are not supported in this context
Cause: A set operator such as UNION, UNION ALL, INTERSECT, or MINUS was encountered in an unsupported context, such as in a materialized view definition.
Action: Re-specify the expression to avoid the use of set operators.
ORA-30371: column cannot define a level in more than one dimension
Cause: A column was used in the definition of a level after it had already been used to define a level in a different dimension.
Action: Reorganize dimension levels and hierarchies into a single dimension such that no column is used to define levels in different dimensions. There is no limit on the number of levels or hierarchies you can place in a dimension. A column can be used to define any number of levels provided all such levels are in the same dimension and provided no two levels contain identical sets of columns.
ORA-30372: fine grain access policy conflicts with materialized view
Cause: A fine grain access control procedure has applied a non-null policy to the query for the materialized view.
Action: In order for the materialized view to work correctly, any fine grain access control procedure in effect for the query must return a null policy when the materialized view is being created or refreshed. This may be done by ensuring that the usernames for the creator, owner, and invoker of refresh procedures for the materialized view all receive a null policy by the user-written fine grain access control procedures.
ORA-30373: object data types are not supported in this context
Cause: An object data type was encountered in an unsupported context.
Action: Re-specify the expression to avoid the use of objects.
ORA-30374: materialized view is already fresh
Cause: If the materialized view is fresh, ORACLE ignores the ALTER MATERIALIZED VIEW <mv> RELY FRESH command, and issues this error message.
Action: None
ORA-30375: materialized view cannot be considered fresh
Cause: If the materialized view is invalid or unusable, it cannot be considered fresh with the ALTER MATERIALIZED VIEW <mv> CONSIDER FRESH command.
Action: None
ORA-30376: prevent sharing of a parsed query of an explain rewrite session
Cause: Explain rewrite generates a shared cursor after parsing the user query. Raising this error will prevent the cursor from being shared.
Action: None
ORA-30377: MV_CAPABILITIES_TABLE not found
Cause: You have used the DBMS_MVIEW.EXPLAIN_MVIEW() API before you have defined the MV_CAPABILITIES_TABLE.
Action: Invoke the admin/utlxmv.sql script after connecting to the desired schema.
ORA-30378: MV_CAPABILITIES_TABLE is not compatible with Oracle version
Cause: One or more column definitions in the MV_CAPABILITIES_TABLE is either missing or incompatible with the current Oracle version.
Action: Connect to the appropriate schema, DROP TABLE MV_CAPABILITIES_TABLE and recreate it by invoking the admin/utlxmv.sql script prior to invoking the DBMS_MVIEW.EXPLAIN_MVIEW() API.
ORA-30379: query txt not specified
Cause: You have attempted use DBMS_MVIEW.EXPLAIN_REWRITE() API using an empty query text argument
Action: Input a valid SQL query
ORA-30380: REWRITE_TABLE does not exist
Cause: You have used the DBMS_MVIEW.EXPLAIN_REWRITE() API before you have created the REWRITE_TABLE.
Action: Create it using the admin/utlxrw.sql script after connecting to the desired schema
ORA-30381: REWRITE_TABLE is not compatible with Oracle version
Cause: One or more column definitions in the REWRITE_TABLE is either missing or incompatible with the current Oracle version.
Action: Connect to the appropriate schema, DROP TABLE REWRITE_TABLE and recreate it by invoking the admin/utlxrw.sql script prior to invoking the DBMS_MVIEW.EXPLAIN_REWRITE() API.
ORA-30382: DROP MATERIALIZED VIEW string.string operation is not complete
Cause: The drop materialized view operation got an unexpected error while dropping summary object.
Action: Issue the drop materialized view command again
ORA-30383: specified dimension level does not exist in the attribute
Cause: An attribute level was encountered that is not defined within the attribute.
Action: Check the attribute level name spelling.
ORA-30384: specified column name does not exist in the attribute
Cause: A column was encountered that is not defined within the attribute.
Action: Check the attribute column name spelling.
ORA-30385: specified attribute relationship ('string' determines 'string') exists
Cause: The specified attribute relationship has already been declared in one of the attribute clauses
Action: Remove the duplicate attribute relationship
ORA-30386: invalid SQL statement for DECLARE_REWRITE_EQUIVALENCE
Cause: Either the source or destination statement is NULL
Action: Verify both source and destination statement are valid
ORA-30387: invalid rewrite mode for REWRITE_EQUIVALENCE API
Cause: The specified rewrite mode is not supported by REWRITE_EQUIVALENCE API
Action: Verify the rewrite mode is supported by REWRITE_EQUIVALENCE API
ORA-30388: name of the rewrite equivalence is not specified
Cause: The name of the rewrite equivalence is NULL
Action: Input a valid rewrite equivalence name
ORA-30389: the source statement is not compatible with the destination statement
Cause: The SELECT clause of the source statement is not compatible with the SELECT clause of the destination statement
Action: Verify both SELECT clauses are compatible with each other such as numbers of SELECT list items are the same and the datatype for each SELECT list item is compatible
ORA-30390: the source statement is not equivalent to the destination statement
Cause: the set of rows returned by the source SQL text is not the same as the set of rows returned by the destination SQL text
Action: Make sure both source and destination statement return the same number of rows
ORA-30391: the specified rewrite equivalence does not exist
Cause: the specified rewrite equivalence does not exist
Action: Verify the rewrite equivalence has been created
ORA-30392: the checksum analysis for the rewrite equivalence failed
Cause: the given checksum does not match with that generated from the source and destination statements.
Action: Verify the create safe rewrite equivalence statement to see if it has been modified.
ORA-30393: a query block in the statement did not rewrite
Cause: A query block with a REWRITE_OR_ERROR hint did not rewrite
Action: Verify the rewrite equivalence has been created
ORA-30394: source statement identical to the destination statement
Cause: The source statement was identical to the destination statement
Action: Make sure both source and destination statements are not identical
ORA-30395: dimension options require the COMPATIBLE parameter to be string or greater
Cause: The following materialized view options require 10.1 or higher compatibility setting:

o dimension attribute extended level syntax ATTRIBUTE <attribute name> LEVEL <level name> DETERMINES <column name>

Action: Shut down and restart with an appropriate compatibility setting.
ORA-30396: rewrite equivalence procedures require the COMPATIBLE parameter to be string or greater
Cause: Query rewrite equivalence APIs require 10.1 or higher compatibility setting:

o DBMS_ADVANCED_REWRITE.DECLARE_REWRITE_EQUIVALENCE

o DBMS_ADVANCED_REWRITE.ALTER_REWRITE_EQUIVALENCE

o DBMS_ADVANCED_REWRITE.DROP_REWRITE_EQUIVALENCE

o DBMS_ADVANCED_REWRITE.VALIDATE_REWRITE_EQUIVALENCE

Action: Shut down and restart with an appropriate compatibility setting.
ORA-30430: list does not contain any valid summaries
Cause: List is empty or does not contain the names of existing summaries
Action: Verify that the list of names passed to refresh contains the name of at least one existing summary object
ORA-30431: refresh method must be ANY or INCREMENTAL or FORCE_FULL, not string
Cause: An invalid refresh method was specified
Action: Verify that the refresh method is one of 'ANY' or 'INCREMENTAL' or 'FORCE_FULL'
ORA-30432: summary 'string.string' is in INVALID state
Cause: The summary is in INVALID state and cannot be refreshed
Action: none
ORA-30433: 'string.string' is not a summary
Cause: There is no such summary, therefore it cannot be refreshed
Action: Verify the correct name of the summary
ORA-30434: refresh method must be one of FC?AN, not 'string'
Cause: An invalid refresh method was specified
Action: Verify that the refresh method is one of 'FC?AN'
ORA-30435: job_queue_processes must be non-zero in order to refresh summaries
Cause: The server must be started with parameter 'job_queue_processes' greater than zero
Action: Correct the value of job_queue_processes and restart the server instance
ORA-30436: unable to open named pipe 'string'
Cause: The refresh process was unable to open a named pipe to the job queue process usually because of insufficient system resources
Action: This is an internal error. Notify ORACLE technical support
ORA-30437: all job queue processes have stopped running
Cause: All of the job queue processes used by refresh have stopped for some reason. At least one job queue process must be running in order to refresh summaries.
Action: This is an internal error. Notify ORACLE technical support
ORA-30438: unable to access named pipe 'string'
Cause: The refresh process was unable to access a named pipe to the job queue process after it successfully opened the pipe. This usually indicates an internal or operating system error condition.
Action: This is an internal error. Notify ORACLE technical support
ORA-30439: refresh of 'string.string' failed because of string
Cause: The refresh job queue process encountered an error and is reporting it. The accompanying text of the message indicates cause of the error
Action: Varies, depending upon the reported cause.
ORA-30440: can't fast refresh;refresh complete or set event 30441 for partial refresh
Cause: Both DML and direct-load are performed against detail tables. Fast refresh can only process direct-load inserts.
Action: Refresh complete or set event 30441 to enable partial refresh with only direct-load inserts
ORA-30442: can not find the definition for filter string
Cause: For the specified filterid parameter, there is no corresponding filter definition found in the advisor repository
Action: Use a valid filterid geneated by the create_filter function
ORA-30443: definition for filter string's item string is invalid
Cause: The specified filter is invalid. It contains at least one invalid filter item. If a filter item has a string list, it becomes illegal when the string list cannot be successfully parsed. If the filter item contains a range definition, and the lower bound of the range is greater than the higher bound, the item also becomes invalid.
Action: Remove the illegal filter with the purge_filter sub-program and redefine a correct filter
ORA-30444: rewrite terminated by the sql analyzer
Cause: The sql analyzer terminates the rewrite process
Action: This is an internal error. Notify ORACLE technical support
ORA-30445: workload queries not found
Cause: No workload queries in the advisor repository can satifiy the specified filter
Action: Redefine a new filter or load additional workload queries that can satisfy the specified filter
ORA-30446: valid workload queries not found
Cause: None of the specified queries can be successfully parsed. The error may come from many sources: SQL syntax error, the owner specified by the load_workload subprograms do not match the real user who generates the SQL statement
Action: Only load valid SQL statements into the advisor repository. Make sure the statements can be parsed with privilege of the owner as specified in the owner parameter of the load_workload() subprogram.
ORA-30447: internal data for run number string is inconsistent
Cause: Users should not explicitly modify summary advisor's internal tables. Such modifications may cause inconsistency in the internal tables and result in this error.
Action: Users can call the DBMS_OLAP.PURGE_RESULTS subprogram to remove the inconsistent data from summary advisor's internal tables
ORA-30448: internal data of the advisor repository is inconsistent
Cause: Users should not explicitly modify summary advisor's internal tables. Such modifications may cause inconsistency in the internal tables and result in this error.
Action: This is an internal error. Notify ORACLE technical support
ORA-30449: syntax error in parameter string
Cause: The syntax for the specified parameter is incorrect
Action: Check ORACLE documentation for the correct syntax
ORA-30450: refresh_after_errors was TRUE; The following MVs could not be refreshed: string
Cause: One or more errors occurred during a refresh of multiple summaries.
Action: The number_of_failures parameter returns the count of how many failures occurred. The trace logs for each refresh operation describe the each individual failure in more detail
ORA-30451: internal error
Cause: An internal error was detected by the summary refresh subsystem, and aborted the refresh operation
Action: Notify ORACLE support.
ORA-30452: cannot compute AVG(X), VARIANCE(X) or STDDEV(X), without COUNT(X) or SUM(X)
Cause: Incremental refresh of summaries requires a COUNT(X) column in order to incrementally refresh AVG(X). It requires both SUM(X) and COUNT(X) columns in order to in refresh STDDEV(X) or VARIANCE(X)
Action: Make sure that the required columns are part of the summary definition if incremental refresh capability is desired.
ORA-30453: summary contains AVG without corresponding COUNT
Cause: Incremental refresh of summaries with AVG(X) requires a COUNT(X) column to be included in the summary definition
Action: Make sure that the required columns are part of the summary definition if incremental refresh capability is desired.
ORA-30454: summary contains STDDEV without corresponding SUM & COUNT
Cause: Incremental refresh of summaries with STDDEV(X) requires COUNT(X) and SUM(X) columns to be included in the summary definition
Action: Make sure that the required columns are part of the summary definition if incremental refresh capability is desired.
ORA-30455: summary contains VARIANCE without corresponding SUM & COUNT
Cause: Incremental refresh of summaries with VARIANCE(X) requires COUNT(X) and SUM(X) columns to be included in the summary definition
Action: Make sure that the required columns are part of the summary definition if incremental refresh capability is desired.
ORA-30456: 'string.string' cannot be refreshed because of insufficient privilege
Cause: The user lacks one or more permissions that are required in order to refresh summaries.
Action: Make sure that the user is granted all required privileges.
ORA-30457: 'string.string' cannot be refreshed because of unmnanaged NOT NULL columns in container
Cause: The container object for the summary contains one or more unmanaged columns do not allow nulls, and which do not specify a default valur for those columns.
Action: Make sure that default values are specified for all NOT NULL columns that are not part of the summary definition.
ORA-30458: 'string.string' cannot be refreshed because the refresh mask is string
Cause: An attempt was made to incrementally refresh a summary that is not incrementally refreshable.
Action: Do not attempt to incrementally refresh the summary; use full refresh instead.
ORA-30459: 'string.string' cannot be refreshed because the refresh method is NONE
Cause: An attempt was made to refresh a summary whose refresh method is NONE
Action: Summaries whose refresh method is NONE (NEVER REFRESH) cannot be refreshed. Alter the summary to change the default refresh method from NONE to some other value.
ORA-30460: 'string.string' cannot be refreshed because it is marked UNUSABLE
Cause: An attempt was made to refresh a summary which is UNUSABLE
Action: Determine why the summary is UNUSABLE, re-enable it, and retry the refresh.
ORA-30461: 'string.string' cannot be refreshed because it is marked DISABLED
Cause: An attempt was made to refresh a summary which is DISABLED
Action: Determine why the summary is DISABLED, re-enable it, and retry the refresh.
ORA-30462: unsupported operator: string
Cause: An attempt was made to refresh a summary containing an unsupported operator
Action: Verify that all columns of the summary contain expressions that are refreshable.
ORA-30463: 'string' is not a detail table of any summary
Cause: The list of tables passed to refresh_dependent contains at least one invalid table name. That table is not a detail table of any summary and is therefore an invalid input to refresh_dependent
Action: Verify the correct name of all tables in the list
ORA-30464: no summaries exist
Cause: A call was made to refresh_all_mviews, but no summaries exist. At least one summary must exist before calling refresh_all_mviews
Action: Create one or more summaries
ORA-30465: supplied run_id is not valid: string
Cause: There are three possible causes: The specified run_id does not exist; the run_id was created by another user other than the current user; the run_id has already been used.
Action: Call DBMS_OLAP.CREATE_ID to create a new id
ORA-30466: can not find the specified workload string
Cause: The specified workload_id is not valid
Action: Use a valid workload_id or DBMS_OLAP.WORKLOAD_ALL
ORA-30467: internal data for filter number string is inconsistent
Cause: Users should not explicitly modify summary advisor's internal tables. Such modifications may cause inconsistency in the internal tables and result in this error.
Action: Users can call the DBMS_OLAP.PURGE_FILTER subprogram to remove the inconsistent data from summary advisor's internal tables
ORA-30475: feature not enabled: string
Cause: The specified feature is not enabled.
Action: Do not attempt to use this feature.
ORA-30476: PLAN_TABLE does not exist in the user's schema
Cause: Estimate_Summary_Size uses Oracle SQL "EXPLAIN PLAN" command to estimate cardinality of the specified select-clause. This requires a table called the PLAN_TABLE in the user's schema. For more information refer to the SQL Reference Manual.
Action: Create the PLAN_TABLE as described for EXPLAIN PLAN. On most systems a script utlxplan.sql will create this table.
ORA-30477: The input select_clause is incorrectly specified
Cause: The input select-clause parameter to Estimate_Summary_Size is incorrectly specified and cannot be compiled.
Action: Check the syntax of the select-clause.
ORA-30478: Specified dimension does not exist
Cause: the specified dimension to be verified does not exist
Action: Check the spelling of the dimension name
ORA-30479: Summary Advisor error string
Cause: An error has occurred in the Summary Advisor package This message will be followed by a second message giving more details about the nature of the error.
Action: See the Summary Advisor documentation for an explanation of the second error message.
ORA-30483: window functions are not allowed here
Cause: Window functions are allowed only in the SELECT list of a query. And, window function cannot be an argument to another window or group function.
Action: none
ORA-30484: missing window specification for this function
Cause: All window functions should be followed by window specification, like <function>(<argument list>) OVER (<window specification>)
Action: none
ORA-30485: missing ORDER BY expression in the window specification
Cause: Either the ORDER BY expression is mandatory for this function, or there is an aggregation group without any ORDER by expression.
Action: none
ORA-30486: invalid window aggregation group in the window specification
Cause: If the window specification is specified using RANGE option and there are multiple ORDER BY expressions, then the aggregation group cannot contain any expression (It can only have CURRENT ROW, UNBOUNDED PRECEDING, or UNBOUNDED FOLLOWING). First end point (bound) cannot be UNBOUNDED FOLLOWING and second end point cannot be UNBOUNDED PRECEDING. If the first end point is CURRENT ROW, then second end point can only be CURRENT ROW or <expr> /UNBOUNDED FOLLOWING. If the first end point is <expr> FOLLOWING, then second end point can only be <expr>/UNBOUNDED FOLLOWING.
Action: none
ORA-30487: ORDER BY not allowed here
Cause: DISTINCT functions and RATIO_TO_REPORT cannot have an ORDER BY
Action: none
ORA-30488: argument should be a function of expressions in PARTITION BY
Cause: The argument of the window function should be a constant for a partition.
Action: none
ORA-30489: Cannot have more than one rollup/cube expression list
Cause: GROUP BY clause has more than one rollup/cube expression list.
Action: Modify the query such that only one rollup/cube expressions appear per sub-query.
ORA-30490: Ambiguous expression in GROUP BY ROLLUP or CUBE list
Cause: An expression in the GROUP BY ROLLUP or CUBE list matches an expression in the ordinary GROUP BY expression list
Action: Remove the expression from either ordinary GROUP BY expression list or ROLLUP or CUBE expression list
ORA-30493: The percentile value should be a number between 0 and 1.
Cause: A percentile value for PERCENTILE_CONT or PERCENTILE_DISC function is specified out of range.
Action: Specify a value from [0,1].
ORA-30500: database open triggers and server error triggers cannot have BEFORE type
Cause: An attempt was made to create a trigger that fires before the database is open or before server errors, but these types of triggers are not supported.
Action: Do not attempt to create a trigger that fires before the database is open or before server errors.
ORA-30501: instance shutdown triggers cannot have AFTER type
Cause: An attempt was made to create a trigger that fires after an instance shutdown, but this type of trigger is not supported.
Action: Do not attempt to create a trigger that fires after an instance shutdown.
ORA-30502: system triggers cannot have INSERT, UPDATE, or DELETE as triggering events
Cause: An attempt was made to create a system trigger with INSERT, UPDATE, or DELETE triggering events, but this type of trigger is not supported because a system trigger does not have a base table.
Action: Do not attempt to create a system trigger with INSERT, UPDATE, or DELETE triggering events.
ORA-30503: system triggers cannot have a REFERENCING clause
Cause: An attempt was made to use a REFERENCING clause with a system trigger, but this type of trigger is not supported because a system triggers does not have a base table.
Action: Do not use a REFERENCING clause with a system trigger.
ORA-30504: system triggers cannot have a FOR EACH ROW clause
Cause: An attempt was made to use a FOR EACH ROW clause with a system trigger, but this type of trigger is not supported because a system triggers does not have a base table.
Action: Do not use a FOR EACH ROW clause with a system trigger.
ORA-30505: system triggers should not reference a column in a WHEN clause
Cause: An attempt was made to use a WHEN clause to reference a column with a system trigger, but this type of trigger is not supported because a system trigger does not have a base table.
Action: Change the WHEN clause to an appropriate clause.
ORA-30506: system triggers cannot be based on tables or views
Cause: An attempt was made to base a system trigger on a table or a view.
Action: Make sure the type of the trigger is compatible with the base object.
ORA-30507: normal triggers cannot be based on a schema or a database
Cause: An attempt was made to base a normal trigger on a schema or a database, but normal triggers can be based only on tables or views.
Action: Make sure the type of the trigger is compatible with the base object.
ORA-30508: client logon triggers cannot have BEFORE type
Cause: An attempt was made to create a trigger that fires before logon. This type of trigger is not supported.
Action: Do not attempt to create a trigger that fires before logon.
ORA-30509: client logoff triggers cannot have AFTER type
Cause: An attempt was made to create a trigger that fires after logoff. This type of trigger is not supported.
Action: Do not attempt to create a trigger that fires after logoff.
ORA-30510: system triggers cannot be defined on the schema of SYS user
Cause: An attempt was made to define a system trigger on the schema of SYS user. This type of trigger is not supported currently.
Action: Do not attempt to create a system trigger defined on the schema of SYS user.
ORA-30511: invalid DDL operation in system triggers
Cause: An attempt was made to perform an invalid DDL operation in a system trigger. Most DDL operations currently are not supported in system triggers. The only currently supported DDL operations are table operations and ALTER?COMPILE operations.
Action: Remove invalid DDL operations in system triggers.
ORA-30512: cannot modify string.string more than once in a transaction
Cause: An attempt was made to modify an object more than once in a transaction. This error is usually caused by a DDL statement that fires a system trigger that tries to modify the same object. It can also happen when an attempt is made to perform more than one DDL operation on a queue table in the same transaction without issuing a commit between operations.
Action: Do not create system triggers that might modify an already modified object. Also, do not specify more than one DDL operation on a queue table in the same transaction.
ORA-30513: cannot create system triggers of INSTEAD OF type
Cause: Only BEFORE or AFTER triggers can be created on system events.
Action: Change the trigger type to BEFORE or AFTER.
ORA-30514: system trigger cannot modify tablespace being made read only
Cause: A beofre trigger tries to modify a tablespace which is being made READ ONLY as the part of DDL oepration
Action: Modify the trigger to avoid modifications to the objects in the same tablespace as the one which is being made read only, or use autonomous transactions to commit modifications
ORA-30515: suspend triggers cannot have BEFORE type
Cause: An attempt was made to create a trigger that fires before execution suspended. This type of trigger is not supported.
Action: Do not attempt to create a trigger that fires before execution suspended.
ORA-30550: index depends on a package/function spec/body which is not valid
Cause: the functional indexes depends on some invalid/non-existent package/function spec/body
Action: verify that all the package/functions which the index depends on exist and are valid
ORA-30551: The index depends on a package/type body which does not exist
Cause: the functional indexes depends on a package/type body which does not exist
Action: create the package/type body
ORA-30552: The package/procedure/function cannot be changed
Cause: The package/procedure/function is deterministic and some object depends on it
Action: Drop the other object which depends on the package/function/procedure you are trying to change
ORA-30553: The function is not deterministic
Cause: The function on which the index is defined is not deterministic
Action: Mark the function as deterministic
ORA-30554: function-based index string.string is disabled
Cause: An attempt was made to access a function-based index that has been marked disabled because the function on which the index depends has been changed.
Action: Perform one of the following actions: -- drop the specified index using the DROP INDEX command -- rebuild the specified index using the ALTER INDEX REBUILD command -- enable the specified index using the ALTER INDEX ENABLE command -- make the specified index usable using the ALTER INDEX UNUSABLE command
ORA-30555: global index partitioning key is an expression
Cause: An attempt was made to use an expression as a partitioning key in an index.
Action: Do not attempt to use an expression as index partitioning key.
ORA-30556: functional index is defined on the column to be modified
Cause: An ALTER TABLE MODIFY COLUMN was issued on a column on which a functional index exists.
Action: Drop the functional index before attempting to modify the column.
ORA-30557: function based index could not be properly maintained
Cause: The user updated a column on which a function based index is present which was not successfully updated
Action: Determine the error in updating the index and fix the problem
ORA-30558: internal error [string] in function based index
Cause: This is an internal error.
Action: Contact Worldwide support with the exact error text.
ORA-30563: outer join operator (+) not allowed in select-list
Cause: An attempt was made to reference (+) in select-list.
Action: Do not use the operator in select-list.
ORA-30564: Index maintainence clause not allowed for ADD partition to RANGE partitioned tables
Cause: The clause INVALIDATE or UPDATE GLOBAL INDEXES is allowed only for ADD partition to a HASH partitioned table or ADD subpartition to a composite partitioned table.
Action: Remove clause and reissue operation
ORA-30565: Only one INVALIDATE or UPDATE GLOBAL INDEXES clause may be specified
Cause: The clause INVALIDATE or UPDATE GLOBAL INDEXES was specified more than once.
Action: Remove all but one of the INVALIDATE or UPDATE GLOBAL INDEXES clause and reissue the statement
ORA-30566: Index maintainence clause not allowed for this command
Cause: The clause INVALIDATE or UPDATE GLOBAL INDEXES is not allowed for this command
Action: Remove clause and reissue operation
ORA-30567: name already used by an existing log group
Cause: The specified log group name has to be unique.
Action: Specify a unique name for the log group. The name cannot be the same as any other log group, constraint, or cluster hash expression.
ORA-30568: cannot drop log group - nonexistent log group
Cause: The <log_group_name> specified in alter table drop log group is incorrect or nonexistent.
Action: Reenter the statement using the correct log group name.
ORA-30569: data type of given column is not supported in a log group
Cause: An attempt was made to include a column with one of these unsupported data types: LONG, VARRAY, nested table, object, LOB, FILE, or REF in a log group.
Action: Change the column data type or remove the log group. Then retry the operation.
ORA-30570: SEGMENT SPACE MANAGEMENT option already specified
Cause: In CREATE TABLESPACE, the SEGMENT SPACE MANAGEMENT option was specified more than once.
Action: Remove all but one of the SEGMENT SPACE MANAGEMENT specifications.
ORA-30571: invalid SEGMENT SPACE MANAGEMENT clause
Cause: An invalid option appears for SEGMENT SPACE MANAGEMENT clause.
Action: Specify one of the valid options: AUTO, MANUAL.
ORA-30572: AUTO segment space management not valid with DICTIONARY extent management
Cause: in CREATE TABLESPACE, the AUTO SEGMENT SPACE MANAGEMENT was used with a DICTIONARY extent management clause.
Action: Either specify LOCAL extent management or remove the AUTO SEGMENT SPACE MANAGEMENT specification.
ORA-30573: AUTO segment space management not valid for this type of tablespace
Cause: in CREATE TABLESPACE, the AUTO SEGMENT SPACE MANAGEMENT was used while creating an UNDO or TEMPORARY tablespace.
Action: Remove the AUTO SEGMENT SPACE MANAGEMENT clause.
ORA-30574: Cannot create rollback segment in tablespace with AUTO segment space management
Cause: A rollback segment is being created in a tablespace that was created with AUTO segment space management.
Action: Create the rollback segment in a different tablespace.
ORA-30575: ConText Option not installed
Cause: Oracle executable doesn't have ConText Option linked in
Action: get the correct version of Oracle
ORA-30576: ConText Option dictionary loading error
Cause: ConText dictionary tables may be corrupted
Action: not a user error
ORA-30625: method dispatch on NULL SELF argument is disallowed
Cause: A member method of a type is being invoked with a NULL SELF argument.
Action: Change the method invocation to pass in a valid self argument.
ORA-30645: reject limit out of range
Cause: Reject limit specifies the number of records rejected before terminating a table scan. The range is a either a number between 1..100000 or UNLIMITED if no limit is intended.
Action: Change the token representing the reject limit to either a number in the range of 0 and 100000 or the keyword UNLIMITED.
ORA-30646: schema for external table type must be SYS
Cause: A schema other then SYS was specified for the TYPE
Action: For this version of oracle server always use schema name SYS.
ORA-30647: error retrieving access parameters for external table string.string
Cause: an error occurred when fetching the access parameters for the specified external table.
Action: If the access parameter is a query which returns a CLOB, check EXTERNAL_TAB$ to make sure the query is correct.
ORA-30649: missing DIRECTORY keyword
Cause: DEFAULT DIRECTORY clause missing or incorrect.
Action: Provide the DEFAULT DIRECTORY.
ORA-30653: reject limit reached
Cause: the reject limit has been reached.
Action: Either cleanse the data, or increase the reject limit.
ORA-30654: missing DEFAULT keyword
Cause: DEFAULT DIRECTORY clause not specified or incorrect.
Action: Provide the DEFAULT DIRECTORY.
ORA-30655: cannot select FOR UPDATE from external organized table
Cause: A select for update on an external table was attempted.
Action: Don't do it!
ORA-30656: column type not supported on external organized table
Cause: Attempt to create an external organized table with a column of type LONG, LOB, BFILE, ADT, or VARRAY.
Action: These column types are not supported, change the DDL.
ORA-30657: operation not supported on external organized table
Cause: User attempted on operation on an external table which is not supported.
Action: Don't do that!
ORA-30658: attempt was made to create a temporary table with EXTERNAL organization
Cause: An attempt was made to create an External Organized Temporary table. This is not supported.
Action: Don't do that!
ORA-30659: too many locations specified for external table
Cause: An attempt was made to create an External Organized table with more than the maximum allowable (32767) locations specified.
Action: Don't do that, use fewer location clauses. Either consider concatenating the input files, or, creating two external tables with the input files split between them.
ORA-30676: socket read or write failed
Cause: A problem kept a socket from reading or writing the expected amount of data. More specific information is not available.
Action: Try re-establishing a connection. You may need to restart whatever program is at the other end of the socket that failed, or you may need to have some problem on your network fixed.
ORA-30677: session is already connected to a debugger
Cause: An attempt to connect a session to a debugger could not proceed because the session is already connected to some debugger.
Action: Either use the option to force a connection or first disconnect the session from its existing debugger.
ORA-30678: too many open connections
Cause: An attempt to open a connection failed because too many are already open by this session. The number of allowed connections varies as some may be in use through other components which share the same pool of allowed connections.
Action: Retry after closing some other connection. The number of connections supported is currently not adjustable.
ORA-30679: JDWP-based debugging not supported in this configuration
Cause: An attempt to open a debugging connection failed because this server configuration cannot support the required asynchronous socket traffic detection.
Action: This feature will not work under this server configuration. Either the feature is not supported on this platform at all, or is available only through use of a protocol=tcp dispatcher in shared-server configurations. Please consult the platform-specific documentation and "readme" material.
ORA-30680: debugger connection handshake failed
Cause: A problem occurred when trying to establish a debugger connection. This might indicate that the port specified as the location of the debugger is actually being used by some other type of application.
Action: Correct the host or port specifications if they are incorrect, and verify that the debugger is properly waiting for a connection.
ORA-30681: improper value for argument EXTENSIONS_CMD_SET
Cause: An improper parameter value was provided in a call to DBMS_DEBUG_JDWP.CONNECT_TCP.
Action: Correct the indicated parameter value and try again.
ORA-30682: improper value for argument OPTION_FLAGS
Cause: An improper parameter value was provided in a call to DBMS_DEBUG_JDWP.CONNECT_TCP.
Action: Correct the indicated parameter value and try again.
ORA-30683: failure establishing connection to debugger
Cause: An error was indicated when trying to establish a connection to a debugger. Usually a TNS error will display along with this message to further explain the problem, although this TNS error will likely be hidden if you choose to trap the error.
Action: Correct the indicated parameter value and try again.
ORA-30685: package version is not compatible with Oracle version
Cause: The installed version of the package from which this error is raised is not compatible with this release of Oracle.
Action: Install a compatible version of the package's spec and body.
ORA-30686: no dispatcher accepted TCP/IP connection request
Cause: A connection had to be routed through a local socket rather than a dispatcher. When this occurs, shared servers are less beneficial because the session that owns the socket cannot relinquish the process until the socket is closed. The most likely cause is that no dispatcher is configured for protocol=tcp.
Action: To improve the scalability of your configuration, configure a dispatcher for protocol=tcp. To route these particular connections through a particular set of dispatchers, you can specify presentation=kgas. However, if you haven't done so, any protocol=tcp dispatcher will be used.
ORA-30687: session terminated by debugger
Cause: Your program's execution has been stopped by the debugger. This can occur because of an explicit request to do so sent by the debugger, or because the debugger disconnected without first telling Oracle to let your program continue to run after the disconnection. To stop your program completely, Oracle needs to fully terminate the process.
Action: This is in response to a debugger request; it is not an error. No action required.
ORA-30688: maximum program calling depth exceeded
Cause: Your program contains a set of calls that are too deep to be handled. Only transitions between the different execution engines (SQL, PL/SQL, and Java) count in reaching this limit; calls within the same engine don't count.
Action: Restructure your program so as to not call so deeply. Perhaps some recursion can be replaced with iteration.
ORA-30689: improper value for ORA_DEBUG_JDWP
Cause: An improper value was used for ORA_DEBUG_JDWP when trying to establish a connection to a debugger. The value either did not conform to the format of ORA_DEBUG_JDWP or was too long.
Action: Correct the value for ORA_DEBUG_JDWP and try again.
ORA-30690: timeout occurred while registering a TCP/IP connection for data traffic detection
Cause: A timeout occurred while registering a TCP/IP connection for data traffic detection.
Action: Retry the operation later.
ORA-30691: failed to allocate system resources while registering a TCP/IP connection for data traffic detection
Cause: System resources ran out while registering a TCP/IP connection for data traffic detection.
Action: Retry the operation later.
ORA-30695: JDWP message format problem
Cause: A message passed from one software subcomponent to another using the JDWP protocol appears invalidly formatted.
Action: This is an internal error. Contact ORACLE Support Services.
ORA-30725: JDWP-based debugging is not yet available
Cause: This feature is not yet available for use.
Action: Please wait for a future release.
ORA-30726: cannot specify referenced column list here
Cause: An attempt was made to specify a referenced column list for a referential constraint involving a REF column.
Action: Remove the referenced column list specification.
ORA-30727: duplicate referential constraint for a REF column
Cause: Multiple referential constraints were specified for a single REF column.
Action: Remove the duplicate referential constraint and retry the operation.
ORA-30728: maximum number of columns exceeded
Cause: Adding referential constraint on a REF column requires the the creation of an additional column.
Action: Drop some columns and retry the operation.
ORA-30729: maximum number of columns exceeded
Cause: Adding scope or referential constraint on a REF column requires the creation of additional columns if the target table's object identifier is primary key based.
Action: Drop some columns and retry the operation.
ORA-30730: referential constraint not allowed on nested table column
Cause: An attempt was made to define a referential constraint on a nested table column.
Action: Do not specify referential constraints on nested table columns.
ORA-30731: scope constraint not allowed on nested table column when the nested table is being created
Cause: An attempt was made to define a scope constraint on a nested table column when the nested table is being created.
Action: Do not specify a scope constraint on a nested table column when creating it. Instead, specify it using the ALTER TABLE statement.
ORA-30732: table contains no user-visible columns
Cause: An attempt was made to query on a system table which has no user-visible columns.
Action: Do not query on a system table that has no user-visible columns.
ORA-30733: cannot specify rowid constraint on scoped ref column
Cause: An attempt was made to specify rowid constraint on a scoped REF column.
Action: Remove the rowid constraint and then retry the operation.
ORA-30734: cannot specify scope constraint on ref column with rowid
Cause: An attempt was made to specify scope constraint on a REF column with the rowid constraint.
Action: Remove the scope constraint and then retry the operation.
ORA-30735: cannot create multiple subtables of the same type under a supertable
Cause: An attempt was made to create under a supertable (superview), a subtable(subview) of the same type as another existing subtable (subview).
Action: Drop the existing subtable(subview) and retry the operation.
ORA-30736: objects in a table or view hierarchy have to be in the same schema
Cause: An attempt was made to create a subtable(subview) under a supertable(superview) located in another schema.
Action: Connect as schema owner of the superobject and retry the operation.
ORA-30737: cannot create subtable of a type which is not a subtype of the type of the supertable
Cause: An attempt was made to create a subtable(subview) of a type which is not a subtype of the type of the super object.
Action: Change the type of the subtable to be a subtype of the superobject's type and then retry the operation.
ORA-30738: object "string" does not exist in schema "string"
Cause: The specified object does not exist.
Action: Ensure that the specified object exists and retry the operation.
ORA-30739: cannot drop a table that has subtables
Cause: The user tried to drop a table that has subtables defined under it.
Action: Drop all subtables before trying this operation.
ORA-30740: cannot grant UNDER privilege on this object
Cause: The user tried to grant UNDER privilege on an object that is not one of the following : non final object type, object table of non final type, object view of non final type.
Action: Ensure that the UNDER privilege is granted on a valid object.
ORA-30741: WITH HIERARCHY OPTION can be specified only for SELECT privilege
Cause: The user tried to specify WITH HIERARCHY OPTION for a privilege other than SELECT privilege.
Action: Ensure that the HIERARCHY OPTION is specified only with the SELECT privilege
ORA-30742: cannot grant SELECT privilege WITH HIERARCHY OPTION on this object
Cause: The user tried to grant SELECT privilege WITH HIERARCHY OPTION on an object that is not one of the following : object table of non final type, object view of non final type.
Action: Ensure that the SELECT privilege WITH HIERARCHY OPTION is granted on a valid object.
ORA-30743: "string" is not an object view
Cause: The specified object is not an object view.
Action: Specify an object view and retry the operation.
ORA-30744: "string" is not an object table
Cause: The specified object is not an object table.
Action: Specify an object table and retry the operation.
ORA-30745: error occured while trying to add column "string" in table "string"
Cause: The user tried to add a subtype which tried to alter the tables dependent on the supertype.
Action: Ensure that the table will not exceed the columnlimit on adding this subtype.
ORA-30746: error occured while trying to drop column "string" in table "string"
Cause: The user tried to drop a subtype with VALIDATE option which tried to check for stored instances of the type in the stated table
Action: Delete all instances of this subtype and then drop the type.
ORA-30747: cannot create substitutable tables or columns of non final type string.string
Cause: The user tried to create substitutable table or column of a non final type. This operation is not currently supported.
Action: Change the statement to create a non substitutable table/column.
ORA-30748: column string already enabled to store objects of type string.string
Cause: The user is trying to enable a column to store instances of a type for which it is already enabled.
Action: None
ORA-30749: column string not enabled to store objects of type string.string
Cause: The user is trying to disable a column from storing instances of a type for which it is already enabled.
Action: None
ORA-30750: cannot enable column string to store objects of type string.string
Cause: The user is trying to enable a column to store instances of a subtype. The error is raised due to one of the following :
Action: Fix the cause of the error and retry the operation.
ORA-30751: cannot disable column string from storing objects of type string.string
Cause: The user is trying to drop a type from being stored in a substitutable column or table. This error is raised due to one of the following reasons :

- the column is enabled to store instances of some subtype of the type being dropped.

- the column is enabled to store instances of only one type

Action: Fix the cause of the error and retry the operation.
ORA-30752: column or table string is not substitutable
Cause: The user is performing an operation that is not allowed on non substitutable column or table.
Action: None.
ORA-30753: column or table string is substitutable
Cause: The user is performing an operation that is not allowed on substitutable column or table.
Action: None.
ORA-30754: column or table string stores objects of only one type
Cause: The user is trying to perform an operation that is not allowed on object column or table that is enabled to store instances of a single type.
Action: None
ORA-30755: error during expansion of view hierarchy
Cause: There was an error while trying to expand a view hierarchy. This could be due to invalid subviews (or subviews with errors)
Action: Ensure that all subviews are valid e.g. alter view ... compile and retry the operation.
ORA-30756: cannot create column or table of type that contains a supertype attribute
Cause: The user tried to create a column or table of an object type that contains a supertype attribute. This is not supported because it leads to infinite recursion in our current storage model. Note that creating a column of a type implies that we create columns corresponding to all subtype attributes as well.
Action: Change the type definition to contain a supertype REF attribute instead of the supertype object attribute.
ORA-30757: cannot access type information
Cause: Either a subtype was created and operations performed with this new type while the session was in progress, or the type information was unpinned from the object cache.
Action: Commit necessary changes, end the user session, reconnect again and re-try the object operations. If problem persists, contact your Oracle Support representative.
ORA-30765: cannot modify scope for an unscoped REF column
Cause: An attempt was made to modify the scope for an unscoped REF column.
Action: Use an ALTER TABLE ADD SCOPE FOR command instead.
ORA-30766: cannot modify scope for a REF column with a REFERENCES constraint
Cause: An attempt was made to modify the scope for a REF column with a REFERENCES constraint.
Action: Drop the REFERENCES constraint, and retry the operation.
ORA-30767: OID type mismatch
Cause: An attempt was made to modify the scope for a REF column to a table whose object identifier's type is different from that of the original scoped table.
Action: none
ORA-30768: Cannot evaluate pipelined function
Cause: Pipelined functions can only be used in a TABLE expression in the from clause.
Action: Use a non-pipelined function instead.
ORA-30770: Cannot specify storage options for fixed size opaque type
Cause: Storage clause was specified during table creation for a fixed size opaque type.
Action: Do not provide storage option clause.
ORA-30771: Cannot add more than one referential constraint on REF column "string"
Cause: Multiple referential constraints were specified for a single REF column.
Action: Remove the additional referential constraints and retry the operation.
ORA-30772: opaque types do not have default constructors
Cause: Constructor invocation did not succeed, since no user-defined constructors were defined for the opaque type, and since opaque types do not have default constructors.
Action: Add user-defined constructors to opaque type, or specify a member or static method for the opaque type.
ORA-30926: unable to get a stable set of rows in the source tables
Cause: A stable set of rows could not be got because of large dml activity or a non-deterministic where clause.
Action: Remove any non-deterministic where clauses and reissue the dml.
ORA-30927: Unable to complete execution due to failure in temporary table transformation
Cause: In memory temporary tables we create are aged out of shared pool before we are able to grab them again.
Action: Reduce activities that use a lot of shared pool space or wait for a while, then retry.
ORA-30928: Connect by filtering phase runs out of temp tablespace
Cause: It is probably caused by the fact that there is a loop in the data.
Action: Please retry the query with the NO_FILTERING hint. If the same error still occurs, then increase temp tablespace.
ORA-30929: ORDER SIBLINGS BY clause not allowed here
Cause: ORDER SIBLINGS BY clause is specifed in a query which doesn't have CONNECT BY clause.
Action: Remove ORDER SIBLINGS BY clause or add CONNECT BY clause.
ORA-30930: NOCYCLE keyword is required with CONNECT_BY_ISCYCLE pseudocolumn
Cause: CONNECT_BY_ISCYCLE was specifed in a query which does not have the NOCYCLE keyword.
Action: Remove CONNECT_BY_ISCYCLE or add NOCYCLE.
ORA-30931: Element 'string' cannot contain mixed text
Cause: XML elements must be declared mixed to contain multiple text nodes
Action: Declare this element type as mixed in its schema
ORA-30932: Reference node 'string' not contained in specified parent node 'string'
Cause: When using a reference node, it must have the specified parent node
Action: Use a node in the specified parent as the reference
ORA-30933: Element 'string' may not appear at this point within parent 'string'
Cause: The ordering specified by the content model of the parent does not allow for this element to occur at this position.
Action: Reorder the child elements to conform with the content model of the parent element
ORA-30934: 'string' (string node) cannot be inserted in parent 'string' (string node)
Cause: The schema does not allow a child node of this type to be inserted into a parent node of this type. For example, only element nodes may only be inserted into a document
Action: Insert only child nodes that make sense for this node type
ORA-30935: XML maxoccurs value (string) exceeded
Cause: An attempt was made to insert more than maxoccurs values into a schema-based XML document.
Action: Do not insert more than maxoccurs values into the document.
ORA-30936: Maximum number (string) of 'string' XML node elements exceeded
Cause: An attempt was made to insert more than the allowed number of elements (specified by the maxoccurs facet) into an XML
Action: Do not attempt to add more than the maximum number of elements to XML documents.
ORA-30937: No schema definition for 'string' (namespace 'string') in parent 'string'
Cause: The schema definition for the parent node being processed does not allow for the specified child node in its content model. Note that any typecasting via xsi:type must occur before the schema definitions for the new type can be used.
Action: Only insert elements and attributes declared in the schema. Check to make sure that xsi:type (if used) is specified first.
ORA-30938: No prefix defined for namespace 'string' (particle string)
Cause: An XML namespace mapping (xmlns:<prefix>=<namespace URL>) must be defined for each particle (element or attribute) stored in an schema-constrained XMLType document.
Action: Add an xmlns attribute definition (attribute name="xmlns:prefix" and value="namespace URL") to the current XMLType document. The safest place to add this attribute is in the root node of the document to ensure that the mapping will be in scope.
ORA-30939: Order violation: Element 'string' may not follow element 'string'
Cause: The XML schema specifies a content model that is sequential, where the order of nodes in the instance must follow the order specified by the schema, and this instance relies on the schema validity to avoid maintaining instance order information
Action: Insert elements only in the order specified in the schema
ORA-30940: Cannot resolve prefix 'string' for QName node 'string'
Cause: An attempt was made to store a QName value without having a valid namespace in scope for that prefix.
Action: Declare the namespace for the prefix used
ORA-30941: Cannot specify empty URI for non-default namespace 'string'
Cause: An attempt was made to insert a namespace declaration for a non-default namespace using an empty URI string.
Action: Specify a non-empty URI for namespace declarations other than the default namespace.
ORA-30942: XML Schema Evolution error for schema 'string' table string column 'string'
Cause: The given XMLType table/column which conforms to the given schema had errors during evolution. For more information, see the more specific error below this one
Action: Based on the schema, table and column information in this error and the more specific error below, take corrective action
ORA-30943: XML Schema 'string' is dependent on XML schema 'string'
Cause: Not all dependent schemas were specified and/or the schemas were not specified in dependency order, i.e., if schema S1 is dependent on schema S, S must appear before S1.
Action: Include the previously unspecified schema in the list of schemas and/or correct the order in which the schemas are specified. Then retry the operation.
ORA-30944: Error during rollback for XML schema 'string' table string column 'string'
Cause: The given XMLType table/column which conforms to the given schema had errors during a rollback of XML schema evolution. For more information, see the more specific error below this one
Action: Based on the schema, table and column information in this error and the more specific error below, take corrective action
ORA-30945: Could not create mapping table 'string'
Cause: A mapping table could not be created during XML schema evolution. For more information, see the more specific error below this one
Action: Ensure that a table with the given name does not exist and retry the operation
ORA-30946: XML Schema Evolution warning: temporary tables not cleaned up
Cause: An error occurred after the schema was evolved while cleaning up temporary tables. The schema evolution was successful
Action: If the user needs to remove the temporary tables, use the mapping table to get the temporary table names and drop them.
ORA-30951: Element or attribute at Xpath string exceeds maximum length
Cause: An attempt was made to insert a node of length exceeding the maximum length (specified by the maxLength facet) into an XML document.
Action: Do not attempt to add a node exceeding the maximum length to XML documents.
ORA-30990: insufficient privileges to change owner of resource string
Cause: An attempt was made to change the <Owner> field of an XML DB resource without sufficient privileges to do so.
Action: Switch to SYS before performing the ownership change, or have the intended recipient of the resource perform the transfer.
ORA-30991: cannot use DOM to add special attribute to schema-based parent
Cause: An attempt was made to add or remove an xsi:schemaLocation, xsi:noNamespaceSchemaLocation, xsi:type, or xsi:nil attribute to or from a schema-based XML node using DOM.
Action: Use the updateXML operator instead of DOM.
ORA-31000: Resource 'string' is not an XDB schema document
Cause: The given schema URL does not refer to a registered XDB schema
Action: Make sure the specified schema has been registered in XDB
ORA-31001: Invalid resource handle or path name "string"
Cause: An invalid resource handle or path name was passed to the XDB hierarchical resolver.
Action: Pass a valid resouce handle or path name to the hierarchical resolver.
ORA-31002: Path name string is not a container
Cause: XDB expected the given path name to represent a container.
Action: Pass a path name or resource handle that represents a container.
ORA-31003: Parent string already contains child entry string
Cause: An attempt was made to insert a duplicate child into the XDB hierarchical resolver.
Action: Insert a unique name into the container.
ORA-31004: Length string of the BLOB in XDB$H_INDEX is below the minimum string
Cause: In the XDB$H_INDEX table, the CHILDREN column, a BLOB, must have a certain minimum length without being chained. The calculated length of the LOB was less than the stated minimum.
Action: Set the value of the init.ora parameter db_block_size to at least 2K. For XDB to run at its fastest, set db_block_size to 8K.
ORA-31005: Path name length string exceeds maximum length string
Cause: The length of a path name passed to the XDB hierarchical resolver exceeded the maximum length.
Action: Choose a shorter path name.
ORA-31006: Path name segment length string exceeds maximum length string
Cause: The length of a path name segment passed to the XDB hierarchical resolver exceeded the maximum length of a path name segment.
Action: Choose a shorter path name segment.
ORA-31007: Attempted to delete non-empty container string/string
Cause: An attempt was made to delete a non-empty container in the XDB hierarchical resolver.
Action: Either perform a recursive deletion, or first delete the contents of the container.
ORA-31009: Access denied for property string
Cause: An attempt was made to access a property you don't have access to
Action: Check the ACL to see what privileges you have for this property
ORA-31010: XML element index string exceeds maximum insertion index string
Cause: An attempt was made to insert an XML element at an invalid index location in the node.
Action: Choose a new index that falls within the allowed range.
ORA-31011: XML parsing failed
Cause: XML parser returned an error while trying to parse the document.
Action: Check if the document to be parsed is valid.
ORA-31012: Given XPATH expression not supported
Cause: XPATH expression passed to the function is currently unsupported.
Action: Check the xpath expression and change it to use a supported expression.
ORA-31013: Invalid XPATH expression
Cause: XPATH expression passed to the function is invalid.
Action: Check the xpath expression for possible syntax errors.
ORA-31014: Attempted to delete the root container
Cause: An attempt was made to delete the root container in the hierarchical index.
Action: Do not delete the root container.
ORA-31015: Attempted to insert entry without name
Cause: An attempt was made to insert an entry into the hierarchical resolver without a child name.
Action: Supply a child name and try inserting again.
ORA-31016: Attempted to delete entry without name
Cause: An attempt was made to delete an entry from the hierarchical resolver without a child name.
Action: Supply a child name and try deleting again.
ORA-31017: Error generating unique OID for XML document
Cause: An error occurred while generating a globally unique OID for storing an XML document.
Action: none
ORA-31018: Error deleting XML document
Cause: The XMLType object pointed to by the given REF could not be deleted because either the REF was invalid or it pointed to a non-existent table.
Action: Either use FORCE deletion or supply a valid REF.
ORA-31019: Recursive deletion snapshot too old for string/string
Cause: Changes were made to the structure of a directory while it was being recursively deleted.
Action: Try deleting the directory again.
ORA-31020: The operation is not allowed, Reason: string
Cause: The operation attempted is not allowed
Action: See reason and change to a valid operation.
ORA-31021: Element definition not found
Cause: The element definition was not found.
Action: Supply the definition for the element or use a defined element.
ORA-31022: Element not found
Cause: The element was not found.
Action: Make sure the specified element exists.
ORA-31023: Index size error
Cause: The index is greater than the allowed value.
Action: Make sure the index is less than allowed value.
ORA-31025: Invalid document element
Cause: An attempt was made to replace the data at an invalid index number in the XML document
Action: Supply a correct occurrence number and try again.
ORA-31027: Path name or handle string does not point to a resource
Cause: An attempt was made to retrieve a resource based on a path name or resource handle that points to an entity other than a resource.
Action: Do not attempt to retrieve a resource based on that path name or resource handle.
ORA-31028: Resource metadata length string exceeded maximum length string
Cause: An attempt was made to insert resource metadata that exceeded the maximum length of that type of metadata.
Action: Keep resource metadata within its allowed length.
ORA-31029: Cannot bind to unsaved resource
Cause: An attempt was made to bind to a resource that had not been saved to disk.
Action: Bind only to saved resources.
ORA-31030: Unable to retrieve XML document
Cause: The resource had an invalid (dangling) REF to an XML document.
Action: Rebind the resource using a valid XMLType REF.
ORA-31033: Requested number of XML children string exceeds maximum string
Cause: An attempt was made to add more than the maximum number of allowable children in an XML element.
Action: Redefine the schema to allow breaking up of the children among siblings.
ORA-31035: Could not bind locked resource to path string/string
Cause: An attempt was made to bind an existing resource to a new location in the hierarchy, but a lock could not be obtained on the resource.
Action: Commit or roll back the transaction that has the lock on the resource.
ORA-31037: Invalid XML attribute name string
Cause: The attribute name in the XML document did not match anything in the associated schema.
Action: Supply only schema-defined or XML standard attributes.
ORA-31038: Invalid string value: "string"
Cause: The text in the XML document did not represent a valid value given the datatype and other constraints in the schema.
Action: Ensure that the specified value in XML documents is valid with respect to the datatype and other constraints in the schema.
ORA-31039: XML namespace length string exceeds maximum string
Cause: The length of the disk-formatted XML namespace exceeded the maximum.
Action: Keep XML namespace declarations below the maximum length.
ORA-31040: Property string: XML type (string) not compatible with internal memory type (string)
Cause: The XML datatype given is inconsistent with the database datatype, and a conversion cannot be made.
Action: This is an internal error, generally resulting from corruption of the compiled XML schema. Re-register schemas, or contact Oracle support.
ORA-31041: Property string: Memory type (string) not compatible with database type (string)
Cause: The memory type associated with this property is mapped to an incompatible database type, and a conversion cannot be made.
Action: This is an internal error, generally resulting from corruption of the compiled XML schema. Re-register schemas, or contact Oracle support.
ORA-31042: Too many properties in type 'string'
Cause: The type can only have the same number of properties (elements and attributes) as a table can have columns.
Action: Modify the XML schema to move properties into subelements that are not inlined.
ORA-31043: Element 'string' not globally defined in schema 'string'
Cause: The specified element name has not been defined at the top level of the XML schema (i.e. globally). Elements must be defined globally to be the root of an XMLType object.
Action: Check the XML schema definition to make sure the specified element name has been defined at the top level.
ORA-31044: Top-level prefix length string exceeds maximum string
Cause: An attempt was made to save to disk a top-level XML namespace prefix whose length exceeded the maximum.
Action: Do not define XML namespace prefixes that exceed the maximum length.
ORA-31045: Cannot store more than string extras outside the root XML node
Cause: An attempt was made to store more than the maximum number of XML extras (e.g. comments and processing instructions) either before or after the document's root node.
Action: Keep the number of extras outside the root node below the maximum.
ORA-31046: Incorrect argument(s) specified in the operator
Cause: One or more of the arguments specified in the operator in the query are incorrect
Action: Correct the arguments specified in the operator
ORA-31047: Could not retrieve resource data at path string
Cause: An error occurred while retrieving the contents and/or metadata of a resource.
Action: Contact Oracle customer support.
ORA-31048: Unsaved resources cannot be updated
Cause: An attempt was made to update a resource that was never saved to disk.
Action: Perform a resource insertion instead.
ORA-31050: Access denied
Cause: The requested access privileges have not been granted to the current user. User must be granted privileges prior to resource access.
Action: Check the set of requested access privileges to make sure that they are included in the set of access privilges granted to the user.
ORA-31051: Requested access privileges not supported
Cause: The requested access privileges are not supported for the specified resource.
Action: Ensure that the set of requested access privileges are valid access privileges for the specified resource.
ORA-31052: Cannot delete ACL with other references
Cause: The requested deletion of an ACL resource cannot proceed. The ACL is in use by other resources.
Action: Remove the resources that are making reference to the ACL in question and try again.
ORA-31053: The value of the depth argument in the operator cannot be negative
Cause: The value of the depth argument passed to the primary operator is not a positive integer
Action: Pass a positive value of the depth argument
ORA-31054: The string operator cannot have an ancillary operator
Cause: An ancillary operator was used with an operator which does not does not support ancillary operators
Action: Remove the ancillary operator in the query
ORA-31055: A null XMLType element cannot be inserted into RESOURCE_VIEW
Cause: The element which is being inserted into the RESOURCE_VIEW is NULL
Action: Specify a non-null XMLType element to insert into RESOURCE_VIEW
ORA-31056: The document being inserted does not conform to string
Cause: The XMLType element being inserted into the RESOURCE_VIEW does not conform to the specified Schema
Action: Insert an element which conforms to the specified Schema
ORA-31057: Display Name of the element being inserted is null
Cause: The Display Name of the element which is being inserted into the RESOURCE_VIEW is null
Action: Specify the Display Name and insert the element into RESOURCE_VIEW
ORA-31058: cannot modify read-only XOBs
Cause: Read-Only XOBs cannot be modified.
Action: Use only read operations on such a XOB.
ORA-31059: Cannot insert root XML document node if it already exists
Cause: An attempt was made to insert a root node into an XML
Action: Call the appropriate replace function to replace the node instead of inserting it anew.
ORA-31060: Resource at path string could not be deleted
Cause: An error occurred while deleting the named resource. The specific error can be found one lower on the error stack.
Action: Look at the next error on the stack and take approprate action.
ORA-31062: Cannot delete an unsaved resource
Cause: An attempt was made to delete a resource that had not been saved to disk.
Action: Delete only saved resources.
ORA-31065: Cannot modify read-only property [string]
Cause: An attempt was made to modify an immutable XML node.
Action: Use only read operations on such properties.
ORA-31066: Insertion of string into string creates a cycle
Cause: An attempt was made to insert a link into the XDB hierarchy that would create a cycle in the tree.
Action: Ensure that links to existing resources do not cause cycles.
ORA-31067: XML nodes must be updated with nodes of the same type
Cause: An attempt was made to use updateXML to update an XML node with a node of another type.
Action: Ensure that the node specified by the XPath matches the type of new data provided.
ORA-31068: updateXML expected data format [string] instead of [string]
Cause: An attempt was made to use updateXML to update data with a node of the incorrect type. Text and attribute nodes must be updated with string data, whereas element nodes must be updated with XMLType data.
Action: Use CREATEXML or getStringVal to coerce the new data to the proper format.
ORA-31069: Cannot apply typed changes to non-schema-based XMLType nodes
Cause: An attempt was made to insert, delete, or update a non-schema-based XMLType node using an XML schema definition.
Action: Make changes to non-typed nodes only by referencing their tag names.
ORA-31070: Invalid database user ID string
Cause: An attempt was made set an invalid user ID into an XDB resource metadata property.
Action: Verify the validity of the user ID and try again.
ORA-31071: Invalid database username or GUID string
Cause: An attempt was made to set an invalid username or GUID into an XDB resource metadata property.
Action: Verify the validity of the username or GUID and try again.
ORA-31072: Too many child nodes in XMLType fragment for updateXML
Cause: An attempt was made to pass an XMLType fragment with multiple children as new data for the updateXML operator.
Action: Extract the desired child from the XMLType before passing it to updateXML as the desired new XML node.
ORA-31073: Resource not retrieved using path name
Cause: An attempt was made to access the path name of a resource that was either never saved to disk or was loaded using a method other than with its path name.
Action: Perform path name operations only on resources obtained using a path name. ////// 31075 - 31099 reserved for XML Schema Compiler
ORA-31075: invalid string declaration in XML Schema
Cause: The XML schema contains an invalid declaration identified by the message.
Action: Fix the identified error and try again.
ORA-31076: required attribute "string" not specified
Cause: The XML schema does not specify a required attribute.
Action: Specify a value for the required attribute.
ORA-31077: invalid attribute "string" specified
Cause: The XML schema specifies an invalid attribute.
Action: Remove specification of the invalid attribute.
ORA-31078: error in SQL mapping information
Cause: There is an error in the SQL type and table specification within the XML Schema.
Action: Ensure that all specified SQL types and tables are valid and compatible with the corresponding XML types.
ORA-31079: unable to resolve reference to string "string"
Cause: The identified type or attribute or element could not be resolved.
Action: Make sure that the name corresponds to a valid XML (simple/complex) type or attribute or element and try again.
ORA-31080: type not specified for attribute or element "string"
Cause: The identified attribute or element does not have a type.
Action: Make sure that every attribute and element has a valid type specification.
ORA-31081: name not specified for global declaration
Cause: The XML schema does not specify the name for the global declaration of attribute or element or simpleType or complexType.
Action: Specify names for all global declarations.
ORA-31082: invalid attribute "string" specified in declaration of "string"
Cause: The XML schema specifies an invalid attribute.
Action: Remove specification of the invalid attribute.
ORA-31083: error while creating SQL type "string"."string"
Cause: An error occurred while trying to create the SQL type based on the specification of a complex type.
Action: Fix the identified error and try again.
ORA-31084: error while creating table "string"."string" for element "string"
Cause: An error occurred while trying to create the table based on the declaration for the identified element.
Action: Fix the identified error and try again.
ORA-31085: schema "string" already registered
Cause: An attempt was made to register a schema with the same URL as a previously registered schema.
Action: Register the schema with a different URL.
ORA-31086: insufficient privileges to register global schema "string"
Cause: An attempt was made to register a global schema without sufficient privileges.
Action: Make sure that the user has sufficient privileges to register a global schema.
ORA-31087: insufficient privileges to delete schema "string"
Cause: An attempt was made to delete a schema resource without sufficient privileges.
Action: Make sure that the user has sufficient privileges to delete the schema.
ORA-31088: object "string"."string" depends on the schema
Cause: An attempt was made to delete a schema which has dependent objects.
Action: Either drop the dependent objects prior to deleting the schema or use the CASCADE or FORCE options.
ORA-31089: schema "string" does not target namespace "string"
Cause: The schema document contains references (via include and import definitions) to other schemas that do not belong to valid namespaces.
Action: Make sure that all schemas referenced via include definitions target the same namespace as the parent schema. Further make sure that the namespace specified in the import definition matches the actual target namespace of the specified schema.
ORA-31090: invalid database schema name "string"
Cause: The XML schema document contains an invalid database schema name For example, the value of attribute SQLSchema
Action: Make sure that all database user/schema names specified in the XML schema document refer to existing database users/schemas.
ORA-31091: empty string specified as a SQL name
Cause: The XML schema document contains a null SQL name. For example, the values of attributes SQLName, SQLType, defaultTable.
Action: Make sure that all names of SQL schema objects specified in the XML schema document are valid SQL names. Otherwise, remove such attributes from the schema and try again.
ORA-31092: invalid SQL name "string"
Cause: The XML schema document contains an invalid SQL name. For example, the values of attributes SQLName, SQLType, defaultTable.
Action: Make sure that all names of SQL schema objects specified in the XML schema document are valid SQL names. This implies that the database length and other restrictions on names be satisfied.
ORA-31093: null or invalid value specified for parameter : string
Cause: The argument value passed for the given parameter is null or invalid.
Action: Make sure that all the input argument values are valid.
ORA-31094: incompatible SQL type "string" for attribute or element "string"
Cause: The SQL type information provided in the XML schema is not compatible with the XML datatype for the specified attribute or element.
Action: Make sure that the specified SQL types are compatible with the declared XML datatypes.
ORA-31095: cannot generate string : "string.string" already exists
Cause: The type/table name specified in the XML schema document cannot be generated because it is already being used.
Action: Use different names for types/tables or use the NOGEN mode so that schema compiler does not generate new types/tables.
ORA-31096: validation failed for schema
Cause: The XML Schema could not be validated.
Action: Make sure that the SQLType and other datatype mapping is valid.
ORA-31097: Hierarchical Index not empty
Cause: An attempt was made to rebuild the hierarchical index which is not empty.
Action: Delete all rows in the hierarchical index and then rebuild it.
ORA-31099: XDB Security Internal Error
Cause: An XDB Security internal error has occurred.
Action: Contact Oracle Support. ////// 31100 - 31110 reserved for WebDAV compliant resource locks
ORA-31100: XDB Locking Internal Error
Cause: An XDB Locking Internal error has occurred.
Action: Contact Oracle Support.
ORA-31101: Token "string" not given while locking resource "string"
Cause: Locking attempted on resource when the pricipal already owns a lock given by the token above.
Action: Reattempt the lock with the token.
ORA-31102: Already locked in exclusive mode. Cannot add lock.
Cause: The resource is already locked in exclusive mode. Cannot add another lock.
Action: Unlock the existing lock.
ORA-31103: Resource locked in shared mode. Cannot add exclusive lock
Cause: The resource is locked in shared mode. Cannot add a shared lock.
Action: Try locking in shared mode or unlocking the existing lock.
ORA-31104: Cannot find lock with token "string" on "string" for unlock
Cause: The lock may have been unlock or it may have expired.
Action: No action needed. Unlock already successful.
ORA-31105: User does not own lock "string"
Cause: The lock to be unlocked is not owned by the user.
Action: none
ORA-31107: Action failed as resource "string" is locked by name lock
Cause: Lock requests cause the whole request URI to be locked
Action: Supply lock token or unlock the lock
ORA-31108: Action failed as resource string is locked
Cause: Delete/Rename failed because of an existing lock
Action: Do lockdiscovery to find the lock and delete it.
ORA-31109: Action failed as parent resource string is locked
Cause: Delete/Rename failed because of an lock on parent resource
Action: Do lockdiscovery to find the lock and delete it.
ORA-31110: Action failed as resource string is locked by name
Cause: Delete/Rename failed because one of the children is locked.
Action: Do lockdiscovery to find the lock and delete it.
ORA-31111: table string cannot be hierarchically enabled
Cause: Trigger <tabname>_xdb_pitrigger already exists
Action: Delete all rows in the hierarchical index and then rebuild it.
ORA-31112: fail to string for string port using xdb configuration
Cause: port number for the defined presentation is not valid
Action: Either the port number is already in use or it is protected. Specify another port number.
ORA-31113: XDB configuration may not be updated with non-schema compliant data
Cause: An attempt was made to update the XDB configuration resource with non-schema or non-schema compliant data.
Action: Check the document to make sure it is schema based and schema compliant.
ORA-31114: XDB configuration has been deleted or is corrupted
Cause: The XDB configuration resource has been deleted or corrupted.
Action: Reinstall XDB, or reinsert a valid configuration document.
ORA-31115: XDB configuration error: string
Cause: An error related to XDB configuration has occurred.
Action: Make sure the configuration resource contains valid data.
ORA-31116: Tablespace not specified correctly
Cause: XDB cannot be moved to the specified tablespace.
Action: Specify a valid tablespace.
ORA-31121: The string operator can not be FALSE
Cause: The value of the operator that is specified is FALSE
Action: Specify an operator that evaluates to TRUE
ORA-31122: The string operator has incorrect RHS value
Cause: The right hand side value that has been specified for the operator does not evaluate to TRUE
Action: Specify value on the right hand side that evaluate to TRUE ////// 31151 - 31189 reserved for XML Schema Compiler
ORA-31151: Cyclic definition encountered for string: "string"
Cause: The schema definition for this type has cycles.
Action: Remove cyclic definition and re-compile schema.
ORA-31153: Cannot create schema URL with reserved prefix "http://xmlns.oracle.com/xdb/schemas/"
Cause: This prefix is reserved for XDB extended schema URLs and cannot be used in a user specified URL.
Action: Modify the prefix to a different one.
ORA-31154: invalid XML document
Cause: The XML document is invalid with respect to its XML Schema.
Action: Fix the errors identified and try again.
ORA-31155: attribute string not in XDB namespace
Cause: The specified attribute should be prefixed with XDB's namespace.
Action: Ensure that all XDB specified attributes are prefixed with XDB's namespace and try again.
ORA-31157: Invalid Content-Type charset
Cause: HTTP Content-Type header had a charset that Oracle does not understand.
Action: Fix the Content-Type header in the HTTP request.
ORA-31158: schema "string" currently being referenced
Cause: The specified schema URL is currently being referenced by the same session. This could happen because of PLSQL XMLType variables still in scope.
Action: Ensure all references to this schema in this session are released and try the operation again.
ORA-31159: XML DB is in an invalid state
Cause: XML DB's internal tables are in an invalid state, probably because the database was not upgraded or the upgrade was not successful
Action: Ensure that the database is upgraded successfully. If the problem persists, contact Oracle Support
ORA-31160: max substitution group size string exceeded by "string" (string) for head element "string" (string)
Cause: The maximum limit on nested substitution groups has been exceeded by an element.
Action: Delete specified schema and re-register it after removing the offending substitution element.
ORA-31161: element or attribute "string" cannot be stored out of line
Cause: An element or attribute of a simple type has SQLInline=false
Action: Remove the SQLInline=false qualification for the offending element or attribute
ORA-31162: element or attribute "string" has no SQLType specified
Cause: Schema registration was invoked with GENTYPES=false without specifying a SQLType for some element or attribute
Action: Specify a SQLType for the offending element or attribute and register the schema again
ORA-31163: element or attribute "string" has invalid attribute value "string" (should be "string")
Cause: An element or attribute for a complextype derived by restriction has an attribute whose value is different from that in the base type
Action: Remove the mismatched attribute values from the offending element or attribute
ORA-31164: cannot load object-relational XML attribute using direct path
Cause: The table being loaded contains a xml column with object-relational storage. The xmltype column contains a type with subtypes. This type of attribute cannot be loaded with direct path.
Action: Perform the load with conventional path mode.
ORA-31165: cannot load object-relational XML attribute using direct path
Cause: The table being loaded contains a xml column with object-relational storage. The xmltype column either contains an out-of-line partitioned table or the table itself is partitioned by one of the attributes of xmltype. This type of table cannot be loaded with direct path.
Action: Perform the load with conventional path mode.
ORA-31180: DOM Type mismatch in invalid PL/SQL DOM handle
Cause: The specified PL/SQL DOM handle is referencing a DOM Node whose DOM Type that does not match the one available in the session. This could happen because the pl/sql handle was reused, or the original document is no longer available.
Action: Ensure that the pl/sql handle for the target node is valid and try the operation again.
ORA-31181: PL/SQL DOM handle accesses node that is no longer available
Cause: The specified pl/sql handle is referencing a node in a DOM Document that is no longer available.
Action: Ensure that the pl/sql handle for the target node is valid and try the operation again.
ORA-31182: Too many PL/SQL DOM handles specified
Cause: An attempt was made to create a PL/SQL DOM handle that exceeded the maximum allowable number of PL/SQL DOM handles.
Action: Free PL/SQL DOM handles and try the operation again.
ORA-31185: DOM Nodes do not belong to the same DOM Document
Cause: The specified PL/SQL DOM Node does not belong to the parent DOM Document of the referring DOM Node.
Action: Ensure that both the DOM Nodes are part of the same DOM Document.
ORA-31190: Resource string is not a version-controlled resource
Cause: Either one of the following is the cause:

- Checkout is requested for a resource that isn't under version control". Only version-controlled resource can be checked out.

- Checkout is requested for a row of a non-versioned table.

Action: put the resource under version-control before checking out.
ORA-31191: Resource string is already checked out
Cause: Either one of the following is the cause:

- Checkout is requested for a resource that is already checked out to the workspace by the same of different user.

Action: checked in the resource from the workspace before checking out
ORA-31192: Resource string has not been checked out
Cause: Either one of the following is the cause:

- Checkin or uncheckout is requested for a resource that has not been checked out to the workspace by any user in a workspace

Action: checked in the resource from the workspace before checking out
ORA-31193: This versioning feature isn't supported for resource string
Cause: Either one of the following is the cause:

- Container cannot be put under version-controlled.

Action: Avoid using these features.
ORA-31194: Resource string is already deleted
Cause: Access a version-controlled resource that is already deleted.
Action: Remove the cyclic definitions in the type and retry compilation.
ORA-31195: XML node 'string' (type=string) does not support this operation
Cause: The given node's type is not supported for this operation. For example, trying to add children to an attribute node, or passing in a document node as a child, are unsupported operations.
Action: Use a valid node type for the operation.
ORA-31196: XML nodes over string in size cannot be printed
Cause: An attempt was made to use an XML Text Node with a size greater than 64K, or an XML Comment Node with a size greater than 4K. These cannot be printed. For example, trying to add children to an attribute node, or passing in a document node as a child, are unsupported operations.
Action: Use getClobVal() or getStringVal() to print the Document.
ORA-31197: Error in processing file string
Cause: An error occurred while operating on the specifed file. The possible causes are the file header is corrupt or check the next error on stack
Action: Ensure that the specified file is correct. Look at the next error on the stack and take appropriate action.
ORA-31198: Mismatch in number of bytes transferred due to non-binary mode
Cause: An error occurred while reading the specifed file. The most probable cause is that the transfer was initiated in ASCII mode.
Action: Ensure that the transfer mode is set to BINARY
ORA-31199: Warning in processing file string
Cause: A warning was raised while operating on the specifed file. However, the current operation was completed successfully.
Action: This is primarily an informational message. Look at the next error on the stack to obtain further information. ////////////////////////// DBMS_LDAP & OiD messages
ORA-31201: DBMS_LDAP: generic error: string
Cause: There has been an error in the DBMS_LDAP package.
Action: Please report the error number and description to Oracle Support.
ORA-31202: DBMS_LDAP: LDAP client/server error: string
Cause: There is a problem either on the LDAP server or on the client.
Action: Please report this error to the LDAP server administrator or your Database administrator.
ORA-31203: DBMS_LDAP: PL/SQL - Init Failed.
Cause: There has been an error in the DBMS_LDAP Init operation.
Action: Please check the host name and port number, or report the error number and description to Oracle Support.
ORA-31204: DBMS_LDAP: PL/SQL - Invalid LDAP Session.
Cause: There has been an error in the DBMS_LDAP bind operation.
Action: Please check the session handler that you use for binding, or report the error number and description to Oracle Support.
ORA-31205: DBMS_LDAP: PL/SQL - Invalid LDAP Auth method.
Cause: There has been an error in the DBMS_LDAP bind operation.
Action: Please check the authentication credentials that you use for binding, or report the error number and description to Oracle Support.
ORA-31206: DBMS_LDAP: PL/SQL - Invalid LDAP search scope.
Cause: There has been an error in the DBMS_LDAP search operation.
Action: Please check the search scope that you use for search, or report the error number and description to Oracle Support.
ORA-31207: DBMS_LDAP: PL/SQL - Invalid LDAP search time value.
Cause: There has been an error in the DBMS_LDAP search operation.
Action: Please check the search time value that you use for search, or report the error number and description to Oracle Support.
ORA-31208: DBMS_LDAP: PL/SQL - Invalid LDAP Message.
Cause: There has been an error in the DBMS_LDAP operation.
Action: Please check the LDAP message that you use for LDAP operation, or report the error number and description to Oracle Support.
ORA-31209: DBMS_LDAP: PL/SQL - LDAP count_entry error.
Cause: There has been an error in the DBMS_LDAP count_entry operation.
Action: Please check the LDAP count_operation, or report the error number and description to Oracle Support.
ORA-31210: DBMS_LDAP: PL/SQL - LDAP get_dn error.
Cause: There has been an error in the DBMS_LDAP get_dn operation.
Action: Please check the LDAP get_dn, or report the error number and description to Oracle Support.
ORA-31211: DBMS_LDAP: PL/SQL - Invalid LDAP entry dn.
Cause: There has been an error in the DBMS_LDAP operation.
Action: Please check the entry dn that you use for LDAP operation, or report the error number and description to Oracle Support.
ORA-31212: DBMS_LDAP: PL/SQL - Invalid LDAP mod_array.
Cause: There has been an error in the DBMS_LDAP operation.
Action: Please check the LDAP mod_array that you use for LDAP operation, or report the error number and description to Oracle Support.
ORA-31213: DBMS_LDAP: PL/SQL - Invalid LDAP mod option.
Cause: There has been an error in the DBMS_LDAP populate_mod_array operation.
Action: Please check the LDAP mod option that you use for LDAP populate_mod_array operation, or report the error number and description to Oracle Support.
ORA-31214: DBMS_LDAP: PL/SQL - Invalid LDAP mod type.
Cause: There has been an error in the DBMS_LDAP populate_mod_array operation.
Action: Please check the LDAP mod type that you use for LDAP populate_mod_array operation, or report the error number and description to Oracle Support.
ORA-31215: DBMS_LDAP: PL/SQL - Invalid LDAP mod value.
Cause: There has been an error in the DBMS_LDAP populate_mod_array operation.
Action: Please check the LDAP mod value that you use for LDAP populate_mod_array operation, or report the error number and description to Oracle Support.
ORA-31216: DBMS_LDAP: PL/SQL - Invalid LDAP rdn.
Cause: There has been an error in the DBMS_LDAP operation.
Action: Please check the LDAP rdn value that you use for LDAP operation, or report the error number and description to Oracle Support.
ORA-31217: DBMS_LDAP: PL/SQL - Invalid LDAP newparent.
Cause: There has been an error in the DBMS_LDAP rename_s operation.
Action: Please check the LDAP newparent value that you use for LDAP rename_s operation, or report the error number and description to Oracle Support.
ORA-31218: DBMS_LDAP: PL/SQL - Invalid LDAP deleteoldrdn.
Cause: There has been an error in the DBMS_LDAP rename_s operation.
Action: Please check the LDAP deleteoldrdn value that you use for LDAP rename_s operation, or report the error number and description to Oracle Support.
ORA-31219: DBMS_LDAP: PL/SQL - Invalid LDAP notypes.
Cause: There has been an error in the DBMS_LDAP explode_dn or explode_rdn operation.
Action: Please check the LDAP notypes value that you use for LDAP explode_dn or explode_rdn operation, or report the error number and description to Oracle Support.
ORA-31220: DBMS_LDAP: PL/SQL - Invalid LDAP SSL wallet location.
Cause: There has been an error in the DBMS_LDAP operation.
Action: Please check the LDAP sslwrl value that you use for LDAP operation, or report the error number and description to Oracle Support.
ORA-31221: DBMS_LDAP: PL/SQL - Invalid LDAP SSL wallet passwd.
Cause: There has been an error in the DBMS_LDAP operation.
Action: Please check the LDAP sslpasswd value that you use for LDAP operation, or report the error number and description to Oracle Support.
ORA-31222: DBMS_LDAP: PL/SQL - Invalid LDAP SSL authentication mode.
Cause: There has been an error in the DBMS_LDAP operation.
Action: Please check the LDAP sslauth value that you use for LDAP operation, or report the error number and description to Oracle Support.
ORA-31223: DBMS_LDAP: cannot open more than string LDAP server connections
Cause: An attempt was made to open more than the maximum allowed LDAP server connections.
Action: Free unused connections.
ORA-31398: DBMS_LDAP: Shared servers are not supported.
Cause: The session executing functions from the DBMS_LDAP package is being handled by a shared server in the Database.
Action: Use dedicated database sessions to execute functions in the DBMS_LDAP package.
ORA-31399: Cannot contact LDAP server string at port number
Cause: The LDAP server specified could not be contacted. This can happen if the server is down or inaccessible.
Action: Contact the administrator of the LDAP server ////////////////////////// End of DBMS_LDAP & OiD messages
ORA-31401: change source string is not an existing change source
Cause: The caller did not use the name of an existing change source. The name given does not match the name of any existing change source.
Action: Check the spelling of the change source name. Choose an existing change source.
ORA-31402: unrecognized parameter string
Cause: Unrecognized parameter was detected.
Action: Check for too many parameters in the call.
ORA-31403: change table string already contains a column string
Cause: Issued ALTER_CHANGE_TABLE with an add operation but a column by this name already exists in the specified table.
Action: Check the names and call the procedure again.
ORA-31404: all input parameters are null
Cause: All input parameters are null. At least one property must be altered.
Action: Call the procedure again, making sure that all the required parameters have been specified. Ensure that at least one parameter is not null. Refer to user documentation for the correct way of calling this procedure.
ORA-31405: cannot make changes while change set string is advancing
Cause: The change set is currently advancing. Change sources related to an advancing change set cannot be altered. Change tables related to the advancing change set cannot be created, altered or dropped. Some or all the parameters of the change set cannot be altered while the set is advancing.
Action: Wait until the change set has finished advancing, then reissue the command. If altering the change set, only the advance_enable parameter can be altered during an advance.
ORA-31406: change source string is referenced by a change set
Cause: The operation cannot complete because this change source is referenced by one or more change sets.
Action: Drop the change sets first, then re-issue the command. May have to drop some change tables before the change sets are dropped.
ORA-31407: end_date must be greater than the begin_date
Cause: The end data of the change set is earlier than the begin date. The end date must always be later in time than the begin date, so that the duration between the begin and end dates is a positive amount of time.
Action: Change the begin date and/or the end date, so that the end date is later than the begin date.
ORA-31408: invalid value specified for begin_scn or end_scn
Cause: The begin_scn was not greater than zero. The end_scn was less than zero. The end_scn was less than the begin_scn.
Action: Check the values of both begin_scn and end_scn. Correct them to make sure that they form a legal SCN range. An end_scn value of zero indicates an infinite scn range.
ORA-31409: one or more values for input parameters are incorrect
Cause: One or more of the inputs to the procedure had invalid values.
Action: Identify the bad parameter(s) and supply correct values to the procedure.
ORA-31410: change set string is not an existing change set
Cause: Could not find an existing change set by this name.
Action: Check the spelling of the change set name. Call the procedure again, passing the correct change set name.
ORA-31411: change set string is referenced by a change table
Cause: The operation cannot be performed because the change set contains one or more change tables.
Action: You will need to drop the change table(s) first, then repeat the operation
ORA-31412: change set string is disabled and cannot be advanced
Cause: The specified change set is disabled. The change set needs to be enabled for the operation to succeed.
Action: Determine why the change set is disabled and correct this condition. Alter the change set specifying 'y' for advance_enable then retry the operation.
ORA-31413: change set string is currently being advanced
Cause: An advance operation is in progress for this change set and we only allow one at a time.
Action: Since the change set is currently being advanced, the best action is to wait for it to finish advancing. Only one caller at a time can advance the change set. Check for the cause of long running advance operations.
ORA-31414: error(s) occurred during change table advance
Cause: One or more errors occurred during the advance operation.
Action: Check the log file(s) for a more detailed report of the underlying errors.
ORA-31415: change set string does not exist
Cause: Specified change set does not exist or the user does not have access to the publications in that change set. The name specified did not match the name of any existing change set. Certain privileges are required to access the publications within that change set.
Action: Check the name and call the procedure again, with the name of an existing change set. Contact the publisher or database administrator if user privileges are required to access the publications in the change set.
ORA-31416: invalid SOURCE_COLMAP value
Cause: A source_colmap value of 'y' was specified for an asynchronous change table.
Action: Specify a source_colmap parameter value of 'n' and call the procedure again.
ORA-31417: column list contains control column string
Cause: Reserved column name was specified in a column list or column type parameter.
Action: Control columns are selected with separate parameters. If you did not want a control column, then change the name of the specified column so that it does not conflict with a reserved column name.
ORA-31418: source schema string does not exist
Cause: Trying to create a synchronous change table and the source schema did not match any existing schema names in the database.
Action: Specify the name of an existing schema.
ORA-31419: source table string does not exist
Cause: When creating a synchronous change table, the underlying source table must exist when the procedure is called. In this case, the source table did not exist.
Action: Specify the name of an existing table.
ORA-31420: unable to submit the purge job
Cause: When creating the first change table, a purge job is submitted to the job queue. Submission of this purge job failed.
Action: Make sure that job queue processes are enabled and are currently running. If this does not solve the problem, contact Oracle.
ORA-31421: change table does not exist
Cause: Specified change table does not exist.
Action: Recheck the name, and call the procedure again using an existing change table.
ORA-31422: owner schema string does not exist
Cause: Value specifed for the owner parameter does not contain the name of an existing schema in the database.
Action: Recheck the name, and call the procedure again using an existing schema name.
ORA-31423: change table string does not contain column string
Cause: Issued ALTER_CHANGE_TABLE with a drop operation and the specified column does not exist in the change table.
Action: Recheck the names, and call the procedure again.
ORA-31424: change table has active subscriptions
Cause: The change table is subscribed to, so it cannot be dropped.
Action: Do not drop a change table while there are active subscribers. If this is an emergency, use the FORCE parameter. This will forcibly drop the change table out from under all subscribers.
ORA-31425: subscription does not exist
Cause: The subscription either did not exist or did not belong to this user.
Action: Call the function again with a valid subscription name.
ORA-31426: cannot modify active subscriptions
Cause: The subscription was already activated so that additional calls to SUBSCRIBE were prohibited.
Action: Subscribe to all the desired tables and columns before activating the subscription. Ensure that the correct subscription name is specifed.
ORA-31427: publication string already subscribed
Cause: The subscription already contained this publication.
Action: Check the values of subscription_name and publication_id. Check any other subscribe calls to see if they subscribe to columns that are shared among more than one publication on the same source table. Do not attempt to subscribe to the same publication more than once in the same subscription. Use the publication_id variant of the SUBSCRIBE call if needed to specify precise publications.
ORA-31428: no publication contains all the specified columns
Cause: One or more of the specifed columns cannot be found in a single publication.
Action: Change the subscription request to select only columns that are in the same publication. Consult the USER_PUBLISHED_COLUMNS view to see current publications.
ORA-31429: subscription has not been activated
Cause: The called procedure required an activated subscription.
Action: Check the subscription name and correct if necessary. Call the ACTIVATE_SUBSCRIPTION procedure for this subscription and then reissue the original command.
ORA-31430: subscriber view exists
Cause: A view that is already in use was specified for the subscriber view.
Action: Call the SUBSCRIBE procedure using a different subscriber view name.
ORA-31431: all source tables must belong to the synchronous change set
Cause: Not all of the source tables belong to the synchronous change set.
Action: Check the spelling of the source tables. Make sure that all of the source tables belong to the synchronous change set.
ORA-31432: invalid source table
Cause: Either the schema_name.source_table did not exist or it did not belong to this subscription.
Action: Check the spelling of the schema_name and source_table. Verify that the specifed table exists in the specifed schema and is subscribed to by the subscription.
ORA-31433: subscriber view does not exist
Cause: The subscription did not contain this subscriber view.
Action: Recheck the name, and specify the name of an existing subscriber view.
ORA-31434: purge is currently running
Cause: Called the PURGE procedure while a purge job was currently running.
Action: Wait for purge to complete before reissueing this command.
ORA-31435: an error occurred during the purge operation
Cause: An error occurred during the purge operation
Action: Check the logfile for a more detailed report of the underlying errors.
ORA-31436: duplicate change source string
Cause: A change source by the specifed name already exists.
Action: Recreate the change source with a unique name.
ORA-31437: duplicate change set string
Cause: A change set by the specified name already exists.
Action: Recreate the change set with a unique name.
ORA-31438: duplicate change table string
Cause: A change table by the specified name already exists.
Action: Recreate the change table with a unique name.
ORA-31439: subscription is already active
Cause: The subscription is already active.
Action: Check name and retry.
ORA-31440: change set string is empty and cannot be advanced
Cause: User attempted to advance a change set which does not contain any change tables. Without change tables, a change set cannot be advanced.
Action: Create change tables in the change set, then retry the advance.
ORA-31441: table is not a change table
Cause: User attempted to execute the DROP_CHANGE_TABLE procedure on a table that is not a CHANGE table. This can also occur when a CHANGE table object has been orphaned. CHANGE tables can become orphaned after a CREATE_CHANGE_TABLE failure or an incomplete DROP_CHANGE_TABLE.
Action: Check spelling. If error was due to an incorrect name, then retry the procedure using the correct name. To drop a table that is not a CHANGE table, or an orphaned CHANGE table, use the DROP TABLE DDL command instead.
ORA-31442: operation timed out while acquiring lock on string
Cause: CDC attempted to acquire a lock on the resource, but the operation timed out.
Action: Retry the operation later.
ORA-31443: deadlock detected while acquiring lock on string
Cause: CDC attempted to acquire a lock on the resource, but encountered a deadlock.
Action: Contact Oracle corporation
ORA-31444: parameter error while acquiring lock on string
Cause: CDC attempted to acquire a lock on the resource, but encountered a problem passing parameters to the lock manager.
Action: Contact Oracle corporation
ORA-31445: invalid lock handle while acquiring lock on string
Cause: CDC attempted to acquire a lock on the resource, but encountered a invalid lock handle, which did not correspond to any existing handle.
Action: Contact Oracle corporation
ORA-31446: this session does not own the lock handle for string
Cause: CDC attempted to acquire a lock on the resource, does not own the the lock associated with the lock. This is an internal error.
Action: Contact Oracle corporation
ORA-31447: cannot create change tables in the SYS schema
Cause: Attempted to create a change table in the SYS schema. This is not allowed.
Action: Use a different existing schema and retry the command.
ORA-31448: invalid value for change_source
Cause: The specified value was not a valid name for a Change Source.
Action: Specify a valid name and retry the command.
ORA-31449: invalid value for change_set_name
Cause: The specified value was not a valid name for a Change Set.
Action: Specify a valid name and retry the command.
ORA-31450: invalid value for change_table_name
Cause: The specified value was not a valid name for a Change Table.
Action: Specify a valid name and retry the command.
ORA-31451: invalid value string for capture_values, expecting: OLD, NEW, or BOTH
Cause: The specified value was not a valid option for a capture_values.
Action: Specify a valid option and retry the command.
ORA-31452: invalid value string for parameter, expecting: Y or N
Cause: The specified value was not Y or N.
Action: Specify Y or N for the parameter and retry the command.
ORA-31453: invalid value string for parameter, expecting: Y, N, or NULL
Cause: The specified value was not Y, N or NULL.
Action: Specify Y, N or NULL for the parameter and retry the command.
ORA-31454: invalid value string for operation parameter, expecting: ADD or DROP
Cause: The specified value was not ADD or DROP.
Action: Specify ADD or DROP and retry the command.
ORA-31455: nothing to ALTER
Cause: The specified column list is NULL and all optional control columns are 'N'.
Action: Specify one or more columns to ALTER.
ORA-31456: error executing a procedure in the DBMS_CDC_UTILITY package
Cause: An internal attempt to invoke a procedure within the DBMS_CDC_UTILITY package failed.
Action: Check the trace logs for more information. Ensure that the package has been installed successfully. Try issuing a DESCRIBE command from SQL on the package. If it fails, then try reinstalling the package. If it succeeds then try invoking one of the procedures from SQL.
ORA-31457: maximum length of description field exceeded
Cause: The maximum number of characters permitted in the description field was exceeded.
Action: The maximum length of the description field is 30 characters. Ensure the length does not exceed this value and retry the command.
ORA-31458: an internal error occurred
Cause: This is an internal error.
Action: Contact Oracle Worldwide Customer Support and report the error.
ORA-31459: system triggers for DBMS_CDC_PUBLISH package are not installed
Cause: One or more required system triggers are not installed. These triggers are required for the proper operation of Change Data Capture. Operations on Change tables cannot continue.
Action: Install or reenable the triggers, or reinstall the package.
ORA-31460: logfile location string is not an existing directory
Cause: The directory specification for logfile location for the change source, does not correspond with an existing directory, or the directory was not accessible.
Action: 1. Create the directory if it does not exist. If the directory does exist, change the file system permissions so the directory can be accessed. OR 2. perform ALTER CHANGE SOURCE and change the logfile_location to be an existing directory that contains the logfiles
ORA-31461: logfile location string contains no files that match pattern string
Cause: The directory specification for logfile location for the change source, does not contain any files whose names pattern-match the logfile_suffix.
Action: 1. Make sure that the logfile location contains logfiles whose names match the logfile_suffix pattern for the change set. OR 2. perform ALTER CHANGE SOURCE and change the logfile_suffix such that it matches the names of existing logfiles in the directory
ORA-31462: internal error while accessing metadata
Cause: An unexpected internal error occurred while CDC was accessing its internal Metadata.
Action: Contact Oracle Corporation
ORA-31463: logfile location string is an empty directory
Cause: The directory specification for logfile location for the change source, is an empty directory
Action: 1. Make sure it is the correct location of the logfiles. If it is, make sure the directory contains logfiles. OR 2. perform ALTER CHANGE SOURCE and change the logfile_location to be an existing directory that contains the logfiles
ORA-31464: target table for the change table no longer exists
Cause: User tried to drop a change table but its underlying storage table (that contains the change data) has been dropped.
Action: Contact Oracle Corporation
ORA-31465: cannot obtain a lock on the subscription
Cause: A timeout occurred while trying to place a lock on the subscription. Another session had already acquired the lock on the subscription.
Action: Ensure the subscription name is correct and correct it if necessary. If it is already correct, try the operation again after the session holding the lock has released it.
ORA-31466: no publications found
Cause: Did not find any publications that matched the input parameters or the user does not have the privileges to access the specified publication.
Action: Check the input parameters on the call to SUBSCRIBE. Validate that the proposed source table has been published by checking the USER_PUBLICATIONS view for that source table. Contact the publisher if user privileges are required to access the publication. Retry the command with correct security or publication information.
ORA-31467: no column found in the source table
Cause: The OBJECT_ID flag was set to 'Y' on the call to CREATE_CHANGE_TABLE and change table belongs to the synchronous change set. The corresponding object column was not detected in the source table.
Action: Create the change table with the OBJECT_ID flag set to 'N' or investigate why the object column is not in the source table and add it to the source table.
ORA-31468: cannot process DDL change record
Cause: The change set has stop_on_ddl enabled and was trying to process a DDL change record.
Action: Check the alert log to find out what the DDL record contained. Make any necessary changes to the change tables. Call ALTER_CHANGE_SET with recover_after_error and remove_ddl set to 'Y'.
ORA-31469: cannot enable Change Data Capture for change set string
Cause: The change set has reached the specified limit that was set up by the CREATE_CHANGE_SET command.
Action: Check the alert log to find out whether capture, apply or both reached the limit. Once apply reaches its limit, the change set is permanently disabled. Create a new change set with new limits to continue capturing data.
ORA-31470: asynchronous change tables must contain the RSID$ column
Cause: If creating an asynchronous change table, the RSID was set to 'N'. If altering an asynchronous change table with an operation parameter of 'DROP' RSID was set to 'Y'.
Action: When creating asynchronous change tables, always specify 'Y' for the RSID parameter. When altering asynchronous change tables always specify 'N' for RSID.
ORA-31471: invalid OBJECT_ID value
Cause: An object_id value of 'y' was specified for an asynchronous change table.
Action: Specify an object_id parameter value of 'n' and call the procedure again.
ORA-31472: Importing Change Data Capture version string.string is too new
Cause: An attempt was made to Import a file that was exported by a newer version of Oracle than the target instance.
Action: If possible, re-export the file using a version of export that matches the import target. Objects can not be imported into previous versions of Oracle that did not support them.
ORA-31475: redo log catalog contains no metadata for the source table
Cause: While advancing a change set, an CDC attempted to query the LogMiner dictionary system tables to obtain the columns from the source table. The query returned no rows. This may be because none of the redo logs contains a catalog, or it may be an internal error.
Action: First, verify that the source system contains the source table. execute dbms_logmnr_d.build procedure to populate the redos log with logminer dictionary information. If this has been done and the problem persists, then contact Oracle Corporation
ORA-31476: a change table data column is missing from the source table
Cause: While advancing a change set, an CDC determined that at least one of the data columns in a change table does not match the name of any of the columns in the source table. The source table column listis stored in dictionary table SYSTEM.LOGMNR_OBJ$
Action: Make sure that all of the data columns of the change table have the same names as the corresponding columns in the source table, and that all the columns exist in the source table.
ORA-31477: could not detach LogMiner session during cleanup
Cause: Failure during detach from a LogMiner session during advance of an asynchronous change set. This is an internal error. This exception is raised when a previous exception occurred during the internal protocol with LogMiner, after which Change Data Capture attempted to detach the LogMiner session as part of recovery. The detach session also failed
Action: Contact Oracle Corporation
ORA-31478: could not detach LogMiner session after change set advance
Cause: Failure during detach from a LogMiner session after successful advance of an asynchronous change set. This is an internal error. This exception is raised when an asynchronous change set has been successfully advanced but CDC was unable to detach from the LogMiner session
Action: Contact Oracle Corporation
ORA-31479: could not create LogMiner session
Cause: Failure during create of a new LogMiner session while advancing an asynchronous change set. This is an internal error.
Action: Contact Oracle Corporation
ORA-31490: could not attach to LogMiner session
Cause: Failure during attach to a LogMiner session while advancing an asynchronous change set. This is an internal error.
Action: Contact Oracle Corporation
ORA-31491: could not add logfile to LogMiner session
Cause: Failure during add logfile to a LogMiner session while advancing an asynchronous change set. This is an internal error.
Action: Contact Oracle Corporation
ORA-31492: could not set session parameters for LogMiner session
Cause: Failure during set parameters for a LogMiner session while advancing an asynchronous change set. This is an internal error.
Action: Contact Oracle Corporation
ORA-31493: could not prepare session for LogMiner session
Cause: Failure during prepare session for a LogMiner session while advancing an asynchronous change set. This is an internal error.
Action: Contact Oracle Corporation
ORA-31494: could not activate a LogMiner session
Cause: Failure during activation of a LogMiner session while advancing an asynchronous change set. This is an internal error.
Action: Contact Oracle Corporation
ORA-31495: error in synchronous change table on "string"."string"
Cause: There was an error originating from this synchronous change table. One possible cause is that schema redefinition has occurred on the source table and one or more columns in the change table are now a different type than corresponding source columns. Another possible cause is that there is a problem accessing the synchronous change table.
Action: Check further error messages in stack for more detail about the cause. If there has been schema redefinition, drop and recreate the synchronous change table.
ORA-31496: must use DBMS_CDC_PUBLISH.DROP_CHANGE_TABLE to drop change tables
Cause: An attempt was made to use the SQL command DROP TABLE for change tables, but DROP TABLE is not supported for change tables.
Action: Use the DBMS_CDC_PUBLISH.DROP_CHANGE_TABLE procedure instead of the DROP TABLE command.
ORA-31497: invalid value specified for first_scn
Cause: The first_scn was not greater than zero or was less than the previous value of first_scn.
Action: Check the value of first_scn. Correct it to make sure it is an integer greater than zero and greater than any previous value for this change source.
ORA-31498: description and remove_description cannot both be specified
Cause: The description and remove_description parameters were both specified.
Action: Check the values of description and remove_description. Correct call to only supply one of these values.
ORA-31499: null value specified for required parameter string
Cause: A null value was specified for a parameter that requires an explicit value.
Action: Correct call to supply a value for this parameter.
ORA-31500: change source string is not a ManualLog change source
Cause: A change source was specified that is not a ManualLog change source, but a ManualLog change source is required.
Action: Correct call to supply a ManualLog change source.
ORA-31501: change source string is not an AutoLog change source
Cause: A change source was specified that was not an AutoLog change source, but an AutoLog change source was required.
Action: Correct call to supply an AutoLog change source.
ORA-31502: invalid number supplied for supplemental_processes
Cause: The caller supplied an invalid value for supplemental_processes. The value must be a positive integer.
Action: Correct call to supply a positive integer value for supplemental_processes.
ORA-31503: invalid date supplied for begin_date or end_date
Cause: The caller supplied an invalid value for begin_date or end_date. The value must be a valid date value.
Action: Correct call to supply a valid date value for begin_date and/or end_date.
ORA-31504: cannot alter or drop predefined change source
Cause: The caller attempted to alter or drop one of the predefined change sources HOTLOG_SOURCE or SYNC_SOURCE.
Action: Do not attempt to alter or drop a predefined change source or correct call to supply the name of a user-created change source.
ORA-31505: cannot alter or drop predefined change set
Cause: The caller attempted to alter or drop the predefined change set SYNC_SET.
Action: Do not attempt to alter or drop the predefined change set or correct call to supply the name of a user-created change set.
ORA-31506: duplicate subscription name string
Cause: A subscription by the specifed name already exists.
Action: Recreate the subscription with a unique name.
ORA-31507: %s parameter value longer than maximum length string
Cause: A value was specified for a parameter that was longer than the maximum permitted length.
Action: Correct the call to supply a shorter value for this parameter that fits within the maximum length.
ORA-31508: invalid parameter value for synchronous change set
Cause: A parameter value was specified that is not supported for synchronous change sets.
Action: Correct the call to supply only valid parameter values for a synchronous change set. Synchronous change sets only support the default values for the following parameters: begin_scn, end_scn, begin_date, end_date, stop_on_ddl, supplemental_processes.
ORA-31509: publication does not exist
Cause: The specified publication did not exist or it subscribed to a publication that no longer exists.
Action: Recheck the publication or subscription specified. Either call the procedure again with an existing publication or create a new subscription that only subscribes to existing publications.
ORA-31510: name uses reserved prefix CDC$
Cause: A name was specified that starts CDC$. The name prefix CDC$ is reserved for use by Oracle Corporation.
Action: Change the name so it does not start with characters CDC$
ORA-31511: name exceeds maximum length of 30 characters
Cause: A name was supplied that exceeds the maximum length of 30 characters.
Action: Change the name so it does not exceed 30 characters
ORA-31512: name cannot contain double quotation marks
Cause: A name containing a double quotation mark was supplied. Subscription names cannot contain the double quotation mark.
Action: Change the name so it has no double quotation marks
ORA-31513: unsupported column type specified in change table
Cause: A source column of an unsupported type was specified for inclusion in a change table. Columns types of LOB or LONG are not currently supported for change capture.
Action: Change the column list so that it does not include columns of LOB or LONG types.
ORA-31514: change set string disabled due to capture error
Cause: This change set has encountered a capture error and was disabled.
Action: Contact the change set's publisher to request that the capture error be resolved. Subscriptions using this change set cannot be activated or have their subscription windows extended or purged until the capture error is resolved.
ORA-31515: CDC change source string already exists
Cause: A Change Data Capture change source intended for import already existed.
Action: Either verify that the existing change source has the desired characteristics or drop the existing change source and perform the import again.
ORA-31516: CDC change set string already exists
Cause: A Change Data Capture change set intended for import already existed.
Action: Either verify that the existing change set has the desired characteristics or drop the existing change set and perform the import again.
ORA-31517: CDC change table string.string already exists
Cause: A Change Data Capture change table intended for import already existed.
Action: Either verify that the existing change table has the desired characteristics or drop the existing change table and perform the import again.
ORA-31518: change column string already exists in CDC change table string.string
Cause: A column in a Change Data Capture change table intended for import was already present in the change table.
Action: Either verify that the change table contains the desired columns or drop the change table and perform the import again.
ORA-31519: CDC subscription string already exists
Cause: A Change Data Capture subscription intended for import already existed.
Action: Either verify that the existing subscription has the desired characteristics or drop the existing subscription and perform the import again.
ORA-31520: CDC subscription string already subscribes to publication ID string
Cause: A Change Data Capture subscription intended for import already subscribed to a publication.
Action: Either verify that the existing subscription has the desired characteristics or drop the existing subscription and perform the import again.
ORA-31521: CDC subscription string already subscribes to publication ID string column string
Cause: A Change Data Capture subscription intended for import already subscribed to a published column.
Action: Either verify that the existing subscription has the desired characteristics or drop the existing subscription and perform the import again.
ORA-31522: could not find Streams object string for CDC change set string
Cause: An underlying Streams capture, apply, or queue was missing for an imported Change Data Capture change set.
Action: Drop the imported change set because it is invalid. Retry the import, ensuring that STREAMS_CONFIGURATION=y is specified.
ORA-31523: could not find change source string for CDC change set string
Cause: The change source was missing for an imported Change Data Capture change set.
Action: Drop the imported change set because it is invalid. Verify that the schema containing the missing change source was included in the original export. If needed, perform the export again, including the schema of the missing change source.
ORA-31524: could not find change set string for CDC change table string.string
Cause: The change set was missing for an imported Change Data Capture change table.
Action: Drop the imported change table because it is invalid. Verify that the schema containing the missing change set was included in the original export. If needed, perform the export again, including the schema of the missing change set.
ORA-31525: could not find column string in CDC change table string.string
Cause: A column was missing for an imported Change Data Capture change table.
Action: It is likely that this table existed before the import operation and import did not overwrite it. Determine whether the imported change table should supercede the original table. If so, drop the original table and retry the import. If not, the change table must have a different name in order to be imported.
ORA-31526: could not find source table string.string for CDC change table string.string
Cause: The source table was missing or was not set up correctly for an imported Change Data Capture change table. A synchronous change table requires the source table to exist and have the Change Data Capture trigger defined on it. An asynchronous change table requires table rules to be defined for the source table.
Action: Drop the imported change table because it is invalid. Verify that the schema containing the source table was included in the original export. If needed, perform the export again, including the schema of the source table. If change table is asynchronous, ensure that STREAMS_CONFIGURATION=y is specified for the import.
ORA-31527: could not find source column string for CDC change table string.string
Cause: A source column was missing for an imported Change Data Capture change table.
Action: Drop the imported change table because it is invalid. Verify that the schema containing the source table was included in the original export. If needed, perform the export again, including the schema of the missing source table.
ORA-31528: could not find change set string for CDC subscription string
Cause: The change set was missing for an imported Change Data Capture subscription.
Action: Drop the imported subscription because it is invalid. Verify that the schema containing the missing change set was included in the original export. If needed, perform the export again, including the schema of the missing change set.
ORA-31529: could not find publication for CDC subscriber view string.string
Cause: A publication was missing for an imported Change Data Capture subscription.
Action: Drop the imported subscription because it is invalid. Verify that the schema containing the missing publication was included in the original export. If needed, perform the export again, including the schema of the missing publication.
ORA-31530: could not find published column string for CDC subscriber view string.string
Cause: A published column was missing for an imported Change Data Capture subscription.
Action: Drop the imported subscription because it is invalid. Verify that the schema containing the missing published column was included in the original export. If needed, perform the export again, including the schema of the missing published column.
ORA-31531: could not find column string in CDC subscriber view string.string
Cause: A column was missing in a subscriber view for an imported Change Data Capture subscription.
Action: It is likely that this view existed before the import operation and import did not overwrite it. Determine whether the imported subscriber view should supercede the original view. If so, drop the original view and retry the import. If not, the subscriber view must have a different name in order to be imported.
ORA-31600: invalid input value string for parameter string in function string
Cause: A NULL or invalid value was supplied for the parameter.
Action: Correct the input value and try the call again.
ORA-31601: Function string cannot be called now that fetch has begun.
Cause: The function was called after the first call to FETCH_xxx.
Action: Correct the program.
ORA-31602: parameter string value "string" in function string inconsistent with string
Cause: The parameter value is inconsistent with another value specified by the program. It may be inconsistent with the object type associated with the OPEN context, or it may be of the wrong datatype (a boolean rather than a text string or vice versa).
Action: Correct the program
ORA-31603: object "string" of type string not found in schema "string"
Cause: The specified object was not found in the database.
Action: Correct the object specification and try the call again.
ORA-31604: invalid string parameter "string" for object type string in function string
Cause: The specified parameter value is not valid for this object type.
Action: Correct the parameter and try the call again.
ORA-31605: the following was returned from string in routine string: LPX-number: string
Cause: An LPX routine (XML/XSL processing) returned an internal error number to its PL/SQL wrapper routine in facility KUX which provides the implementation for package UTL_XML.
Action: Look up the LPX error number and follow its corrective action.
ORA-31606: XML context number does not match any previously allocated context
Cause: A method in package UTL_XML was called with an invalid XML context handle. All handles must have previously been allocated by UTL_XML.XMLINIT.
Action: Always call XMLINIT before any other methods in pkg. UTL_XML.
ORA-31607: function string is inconsistent with transform.
Cause: Either (1) FETCH_XML was called when the "DDL" transform was specified, or (2) FETCH_DDL was called when the "DDL" transform was omitted.
Action: Correct the program.
ORA-31608: specified object of type string not found
Cause: The specified object was not found in the database.
Action: Correct the object specification and try the call again.
ORA-31609: error loading file "string" from file system directory "string"
Cause: The installation script initmeta.sql failed to load the named file from the file system directory into the database.
Action: Examine the directory and see if the file is present and can be read.
ORA-31610: cannot call this function from a non-master process
Cause: Called a Data Pump process model function from a process which is not a master process.
Action: Create a master process first. Then call the function from the master process. If this error occurs from a Data Pump client (e.g. expdp or impdp), try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31612: Allocation of process descriptor failed.
Cause: During creation of a master process or a worker process, a failure occurred allocating a process descriptor for the process.
Action: Try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31613: Master process string failed during startup.
Cause: The master process whose name is listed failed during startup.
Action: Refer to any following error messages for possible actions. Check the trace log for the failed process to see if there is any information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31614: routine string received this error from string: string
Cause: The call to the specified routine failed and the specific error text is included in this error message (the last %s string).
Action: Correct inputs to the specified routine.
ORA-31615: routine string received this error: string
Cause: The specified routine failed and the specific error text is included in this error message (the last %s string).
Action: Correct inputs to the specified routine.
ORA-31616: unable to write to dump file "string"
Cause: Export was unable to write to the export file, probably because of a device error. This message is usually followed by a device message from the operating system.
Action: Take appropriate action to restore the device.
ORA-31617: unable to open dump file "string" for write
Cause: Export was unable to open the export file for writing. This message is usually followed by device messages from the operating system.
Action: Take appropriate action to restore the device.
ORA-31618: dump file size too small
Cause: The value specified for the FILESIZE parameter or the VOLUMESIZE parameter was too small to hold the header information for the export file, plus any data.
Action: Increase the value of the FILESIZE or VOLUMESIZE parameter.
ORA-31619: invalid dump file "string"
Cause: Either the file was not generated by Export or it was corrupted.
Action: If the file was indeed generated by Export, report this as an Import bug and submit the export file to Oracle Customer Support.
ORA-31620: file or device "string" cannot be specified for string operation
Cause: There was an inappropriate use of file or device in the current operation.
Action: Correct operation or job setup.
ORA-31621: error creating master process
Cause: Setup to create a master process failed.
Action: Refer to any following error messages for possible actions. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31622: ORACLE server does not have string access to the specified file
Cause: An attempt was made to read or write files within protected directories.
Action: Correct the file/directory permissions and try the call again.
ORA-31623: a job is not attached to this session via the specified handle
Cause: An attempt to reference a job using a handle which is invalid or no longer valid for the current session.
Action: Select a handle corresponding to a valid active job or start a new job.
ORA-31624: operation string not allowed when job in string state
Cause: The user requested an invalid operation given the current job state.
Action: Verify the state before executing this operation.
ORA-31625: error changing username from string to string
Cause: An error occurred when attempting to change the username.
Action: Refer to any following error messages for possible actions. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31626: job does not exist
Cause: An invalid reference to a job which is no longer executing, is not executing on the instance where the operation was attempted, or that does not have a valid Master Table. Refer to any following error messages for clarification.
Action: Start a new job, or attach to an existing job that has a valid Master Table.
ORA-31627: API call succeeded but more information is available
Cause: The user specified job parameters that yielded informational messages.
Action: Call DBMS_DATAPUMP.GET_STATUS to retrieve additional information.
ORA-31628: error getting worker process exception
Cause: Attempt to get a worker process exception failed.
Action: Refer to any following error messages for possible actions. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31629: unable to allocate additional memory
Cause: A dynamic memory allocation failure occurred.
Action: Report this problem to a database administrator.
ORA-31630: a job name is required to attach a job for user string
Cause: No job name was supplied for an attach and the user has either no jobs executing or mutiple jobs executing.
Action: Provide a job name for attach to use in selecting an executing job, or to use for restarting a stopped job.
ORA-31631: privileges are required
Cause: The necessary privileges are not available for operations such as: restarting a job on behalf of another owner, using a device as a member of the dump file set, or ommiting a directory object associated with any of the various output files. Refer to any following error messages for additional information.
Action: Select a different job to restart, try a different operation, or contact a database administrator to acquire the needed privileges.
ORA-31632: master table "string.string" not found, invalid, or inaccessible
Cause: A Master Table is required but no such table exists, or the content is not consistent with that of a valid Master Table, or the table is not accessible. Refer to any following error messages for clarification.
Action: Make sure a valid Master Table exists, and eliminate any problems indicated by the following error messages.
ORA-31633: unable to create master table "string.string"
Cause: Job creation failed because a Master Table and its indexes could not be created, most commonly due to the pre-existance of a table with the same name (job name) in the user schema. Refer to any following error messages for clarification.
Action: Select a different job name, DROP the existing table, or eliminate any problems indicated by the following error messages.
ORA-31634: job already exists
Cause: Job creation or restart failed because a job having the selected name is currently executing. This also generally indicates that a Master Table with that job name exists in the user schema. Refer to any following error messages for clarification.
Action: Select a different job name, or stop the currently executing job and re-try the operation (may require a DROP on the Master Table).
ORA-31635: unable to establish job resource synchronization
Cause: A lock used in synchronizing Data Pump resources during job creation and deletion could not be obtained during job creation. This indicates that a process for some other Data Pump job has not released the lock due to an internal error.
Action: Eliminate the processes for any failed Data Pump job and try to create the new job again. If the error continues to occur, contact Oracle Customer Support and report the error.
ORA-31636: session is already attached to job string for user string
Cause: The session executing the attach is already attached to the specified job.
Action: Select a different job or create a new session.
ORA-31637: cannot create job string for user string
Cause: Unable to create or restart a job. Refer to any following or prior error messages for clarification.
Action: Eliminate the problems indicated.
ORA-31638: cannot attach to job string for user string
Cause: Unable to attach a job to a session. Refer to any following or prior error messages for clarification.
Action: Eliminate the problems indicated.
ORA-31639: unexpected data found
Cause: The Master Table or Data Pump file contents appear invalid. The table or file may not have been produced by a Data Pump job, or they may have been corrupted.
Action: Select a different job name (Master Table) or replace the table or file with one produced by Data Pump.
ORA-31640: unable to open dump file "string" for read
Cause: Import was unable to open the export file for reading. This message is usually followed by device messages from the operating system.
Action: Take appropriate action to restore the device.
ORA-31641: unable to create dump file "string"
Cause: Export was unable to create the specified file with write enabled.
Action: Check the file name and file system for the source of the error.
ORA-31642: the following SQL statement fails: string
Cause: An internal error was generated from package DBMS_METADATA.
Action: Contact Oracle Customer Support and report the error.
ORA-31643: unable to close dump file "string"
Cause: Export or Import was unable to close the dump file. This message is usually followed by device messages from the operating system.
Action: Take appropriate action to restore the device.
ORA-31644: unable to position to block number string in dump file "string"
Cause: Export or Import was unable to position its file pointer to a specific block within the dump file. This message is usually followed by device messages from the operating system.
Action: Take appropriate action based on the device messages.
ORA-31645: unable to read from dump file "string"
Cause: Import could not read from the dumpfile, probably because of a device error. This message is usually followed by a device message from the operating system.
Action: Take appropriate action to restore the device.
ORA-31648: Timeout before master process string finished initialization.
Cause: The master process whose name is listed started up but did not finish its initialization within the allowed time limit.
Action: Refer to any following error messages for possible actions. Check the trace log for the failed process to see if there is any information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31649: Master process string violated startup protocol.
Cause: The master process whose name is listed started up but then exited before notifying the creating process that it was finished with initialization.
Action: Refer to any following error messages for possible actions. Check the trace log for the failed process to see if there is any information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31650: timeout waiting for master process response
Cause: After creating the job infrastructure and sending the initial message to the master process, it failed to respond in the allotted time and most likely aborted during startup.
Action: Retry the open or attach request. Contact Oracle Customer Support if the problem persists.
ORA-31651: communication error with master process - detaching job
Cause: Unexpected failure trying to communicate with the master process.
Action: Attach again and retry operation. Contact Oracle Customer Support if the problem persists.
ORA-31652: command response message was invalid type - detaching job
Cause: Something horribly wrong with the command/response protocol.
Action: Reattach and retry operation. Contact Oracle Customer Support if the problem persists.
ORA-31653: unable to determine job operation for privilege check
Cause: Failure trying to determine the operation of the current job in order to test for appropriate privileges.
Action: Retry in case it's an intermittent failure. If it still fails, detach, reattach, and retry the call. Contact Oracle Customer Support if the problem persists.
ORA-31654: unable to convert file or volume size as specified to a number
Cause: File or volume size specification has an error the prevents it from being converted into a numeric value.
Action: Fix the call.
ORA-31655: no data or metadata objects selected for job
Cause: After the job parameters and filters were applied, the job specified by the user did not reference any objects.
Action: Verify that the mode of the job specified objects to be moved. For command line clients, verify that the INCLUDE, EXCLUDE and CONTENT parameters were correctly set. For DBMS_DATAPUMP API users, verify that the metadata filters, data filters, and parameters that were supplied on the job were correctly set.
ORA-31656: cannot use TABLESPACE_EXPR filter with transportable mode
Cause: A TABLESPACE_EXPR metadata filter was supplied for for a transportable mode import job. Transportable mode import does not support the subsetting of tablespaces from a dump file set.
Action: Remove the filter expression.
ORA-31657: data filter name can not be defaulted
Cause: A null data filter name was supplied.
Action: Fix the call to specify a data filter name.
ORA-31658: specifying a schema name requires a table name
Cause: The caller specified a schema name but neglected to specify a corresponding table name.
Action: Fix the call to include a table name.
ORA-31659: status message was invalid type - detaching job
Cause: Message from the master process on the status queue had an invalid message type, indicating a failure in the protocol.
Action: Reattach and retry the operation. Contact Oracle Customer Support if the problem persists.
ORA-31660: metadata filter name can not be defaulted
Cause: A null metadata filter name was supplied.
Action: Fix the call to specify a metadata filter name.
ORA-31661: there are no metadata transform values of type VARCHAR2
Cause: The specified metadata transform value was an invalid type.
Action: Fix the call to specify a valid metadata transform value.
ORA-31662: metadata transform name can not be defaulted
Cause: A null metadata transform name was supplied.
Action: Fix the call to specify a metadata transform name.
ORA-31663: metadata remap name can not be defaulted
Cause: A null metadata remap name was supplied.
Action: Fix the call to specify a metadata remap name.
ORA-31664: unable to construct unique job name when defaulted
Cause: The job name was defaulted, and the name creation algorithm was unable to find a unique job name for this schema where the table name (for the master table) didn't already exist.
Action: Specify a job name to use or delete some of the existing tables causing the name conflicts.
ORA-31665: mode can only be defaulted for IMPORT and SQL_FILE operations
Cause: The job mode can not be null except for IMPORT and SQL_FILE operations.
Action: Fix the call to specify the job mode.
ORA-31666: Master process string had an unhandled exception.
Cause: A Data Pump process model master process had an unhandled exception condition.
Action: Refer to any following error messages for possible actions. Check the trace log for the failed process to see if there is any information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31667: parameter name can not be defaulted
Cause: A null was supplied for the parameter name.
Action: Fix the call by providing a valid parameter name.
ORA-31668: Timeout before worker process string finished initialization.
Cause: The worker process whose name is listed started up but did not finish its initialization within the allowed time limit.
Action: Refer to any following error messages for possible actions. Check the trace log for the failed process to see if there is any information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31669: Worker process string violated startup protocol.
Cause: The worker process whose name is listed started up but then exited before notifying the creating process that it was finished with initialization.
Action: Refer to any following error messages for possible actions. Check the trace log for the failed process to see if there is any information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31670: Username argument must be specified and non-null.
Cause: Called change user with a NULL username or a null string.
Action: Specify a valid username argument. If this error occurs from a Data Pump client (e.g. expdp or impdp), try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31671: Worker process string had an unhandled exception.
Cause: A Data Pump process model worker process had an unhandled exception condition.
Action: Refer to any following error messages for possible actions. Check the trace log for the failed process to see if there is any information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31672: Worker process string died unexpectedly.
Cause: A Data Pump process model worker process died unexpectedly, so PMON is cleaning up the process.
Action: Check your system for problems. Check the trace file for the process, if one was created, for any additional information. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31673: worker process interrupt for normal exit by master process
Cause: A worker process was requested to clean up and exit because the master process is doing a normal exit.
Action: If this error occurs from a Data Pump client (e.g. expdp or impdp). it means that the master process for the operation exited prematurely. Try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31674: worker process interrupt for unhandled exception in master process
Cause: A worker process was requested to clean up and exit because an unhandled exception occurred in the master process.
Action: If this error occurs from a Data Pump client (e.g. expdp or impdp), it means that the master process for the operation had an unhandled exception. Check the log file for the operaton and the trace file for the master process for any additional information. Try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31675: worker process interrupt for unexpected death of master process
Cause: A worker process was requested to clean up and exit (signaled by PMON, doing cleanup because the master process died unexpectedly).
Action: If this error occurs from a Data Pump client (e.g. expdp or impdp), it means that the master process for the operation died unexpectedly. Check the log file for the operaton and the trace file for the master process for any additional information. Try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31676: illegal value for number of workers, string
Cause: Called create worker processes with an illegal number of workers specified.
Action: Make sure that the number of workers value is greater than 0 and less than the maximum value for the platform (normally 32767). If this error occurs from a Data Pump client (e.g. expdp or impdp) and you specified the parallel parameter, try the operation again with a smaller value for the parallel parameter. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31686: error creating worker processes
Cause: Setup to create worker processes failed.
Action: Refer to any following error messages for possible actions. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31687: error creating worker process string with worker id string
Cause: Attempt to create the listed worker process failed.
Action: Refer to any following error messages for possible actions. Check the trace log for the failed process to see if there is any information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31688: Worker process string failed during startup.
Cause: The worker process whose name is listed failed during startup.
Action: Refer to any following error messages for possible actions. Check the trace log for the failed process to see if there is any information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31689: illegal value for base worker id, string
Cause: Called create worker processes with an illegal base worker id value specified.
Action: Make sure that the base worker id value is greater than 0 and less than the maximum value for the platform (normally 32767). If this error occurs from a Data Pump client (e.g. expdp or impdp), try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31690: Process name buffer size must be specified and must be greater than 0.
Cause: Called get worker exception and either specified NULL or 0 for the buffer size argument.
Action: Be sure to specify a buffer size that is big enough to hold the worker process name (e.g. 30 bytes). If this error occurs from a Data Pump client (e.g. expdp or impdp), try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31691: The worker received message number string from the MCP, which is invalid.
Cause: Bad code.
Action: Fix mcp code and reissue export/import command.
ORA-31692: The following SQL statement failed trying to insert a row into the Master table: string
Cause: Bad code.
Action: Fix code and reissue export/import command.
ORA-31693: Table data object string failed to load/unload and is being skipped due to error: string
Cause: Table failed to load or unload due to some error.
Action: Check load/unload error, correct problem and retry command.
ORA-31694: master table string failed to load/unload
Cause: Master table failed to load or unload.
Action: Check load/unload error, correct problem and retry command.
ORA-31695: Inconsistent master table on restart. The following SQL statement returned string identical objects. string
Cause: Master table on restart has the same object inserted multiple times.
Action: Restart not possible, reissue original export/import.
ORA-31696: unable to export/import string using client specified string method
Cause: Table attributes prevent client specified method for exporting or importing data.
Action: Use default 'DATA_ACCESS' parameter value.
ORA-31697: aborting operation at process order number string
Cause: User asked for it.
Action: Don't ask for it.
ORA-31698: Error stack buffer size must be specified and must be greater than 0.
Cause: Called get worker exception and either specified NULL or 0 for the error stack size argument.
Action: Be sure to specify am error stack buffer size that is big enough to hold the error stack string (e.g. 4096 bytes). If this error occurs from a Data Pump client (e.g. expdp or impdp), try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-31901: the current operation was cancelled by the user
Cause: The user requested to cancel current operation
Action: No action is necessary
ORA-32001: write to SPFILE requested but no SPFILE specified at startup
Cause: An alter system command or an internal self tuning mechanism requested a write to the SPFILE but no SPFILE was used to startup the instance
Action: Create an SPFILE and re-start the instance using the SPFILE.
ORA-32002: cannot create SPFILE already being used by the instance
Cause: A create spfile command is trying to write to an SPFILE that was used to startup the instance.
Action: Specify a different SPFILE name
ORA-32003: error occured processing parameter 'string'
Cause: An error occured while parsing the parameter file.
Action: See additional errors to determine the root cause.
ORA-32004: obsolete and/or deprecated parameter(s) specified
Cause: One or more obsolete and/or parameters were specified in the SPFILE or the PFILE on the server side.
Action: See alert log for a list of parameters that are obsolete. or deprecated. Remove them from the SPFILE or the server side PFILE.
ORA-32005: error while parsing size specification [string]
Cause: The value specified for an alter operation on a size parameter is not valid
Action: Correct the value and retry the operation
ORA-32006: %s initialization parameter has been deprecated
Cause: A deprecated parmeter was specified at startup
Action: Consult Oracle documentation to find new parameters to use instead.
ORA-32007: internal
Cause: A parameter error occured.
Action: Call Oracle support.
ORA-32008: error while processing parameter update at instance string
Cause: An error occured while processing a parameter on a remote instance.
Action: See accompanying error messages.
ORA-32009: cannot reset the memory value for instance string from instance string
Cause: Memory resets of local parameters are only allowed.
Action: Retry the query for the local instance if needed.
ORA-32010: cannot find entry to delete in SPFILE
Cause: The SPFILE did not contain the sid.parameter entry.
Action: Change the sid and/or the parameter.
ORA-32011: cannot restore SPFILE to location already being used by the instance
Cause: A restore operation trying to write to an SPFILE that was used to startup the instance.
Action: Specify a different SPFILE name
ORA-32012: failure in processing system parameters from restored SPFILE
Cause: Failure during processing of parameters from restored SPFILE
Action: Further diagnostic information should be in the error stack.
ORA-32013: failure in verifying parameters from the restored SPFILE
Cause: Failure during processing of parameters from restored SPFILE. It could be that restore image of the SPFILE is corrupted.
Action: Further diagnostic information should be in the error stack.
ORA-32014: error processing parameter "string" from the SPFILE restore image
Cause: Failure during processing of parameters from restored SPFILE. It could be that restore image of the SPFILE is corrupted.
Action: Further diagnostic information should be in the error stack.
ORA-32015: unable to restore SPFILE
Cause: Failure during SPFILE restore. It could be that the restore destination is not valid.
Action: Further diagnostic information should be in the error stack.
ORA-32016: parameter "string" cannot be updated in SPFILE
Cause: Database is mounted.
Action: Unmount the database to update the parameter in the SPFILE
ORA-32017: failure in updating SPFILE
Cause: A failure occured while updating the SPFILE.
Action: See associated errors.
ORA-32018: parameter cannot be modified in memory on another instance
Cause: Parameter adjustment can take a very long time
Action: Modify the parameter individually on each instance using the SID clause of the alter system command
ORA-32019: The parameter SPFILE cannot be updated in the server parameter file.
Cause: An attempt was made to update the parameter SPFILE in the server parameter file.
Action: Convert the server parameter file into a parameter file and then add the parameters needed and recreate the server parameter file.
ORA-32020: SID=* clause needed to modify this parameter
Cause: The parameter did not have the same value on all RAC instances.
Action: Retry the command by specifying SID=*
ORA-32021: parameter value longer than string characters
Cause: An attempt was made to alter a parameter value but the number of characters in the parameter value was longer than the allowed maximum. For a list parameter, one of the values in the list was longer than the allowed maximum.
Action: Reduce the parameter value length and retry the command. For the DISPATCHERS parameter, use listener aliases to reduce value length.
ORA-32022: parameter value longer than string characters
Cause: An attempt was made to alter a parameter value but the combined length of all the parameter values was more than the allowed maximum.
Action: Reduce the parameter value length and retry the command. For the DISPATCHERS parameter, use listener aliases to reduce value length.
ORA-32024: invalid directory specified for audit_file_dest parameter
Cause: Either the directory does not exist or it is not writable.
Action: Retry the command by specifying a valid directory or granting appropriate directory permissions.
ORA-32025: %s.string is not a table or view object.
Cause: An attempt was made to set the audit table to a non-table object or a non-view object.
Action: Specify a valid table or view object for the audit table option.
ORA-32026: %s.string has fewer columns compared to string table.
Cause: An attempt was made to set the audit table to a table or view object that has fewer columns compared to the base audit table.
Action: Specify a valid table or view object for the audit table option.
ORA-32027: There is no string column with the matching type in string.string.
Cause: An attempt was made to set the audit table to a table or view object that does not have a column with the same name and type as the one in the audit table.
Action: Specify a valid table or view object for the audit table option.
ORA-32031: illegal reference of a query name in WITH clause
Cause: forward or recursive reference of a query name in WITH clause is not allowed.
Action: Correct query statement, then retry.
ORA-32032: free temporary object number not available
Cause: Too many queries using temp table transformation are currently being run to use up all temporay object numbers.
Action: Turn off temporary table transformation or wait, then retry
ORA-32033: unsupported column aliasing
Cause: column aliasing in WITH clause is not supported yet
Action: specify aliasing in defintion subquery and retry
ORA-32034: unsupported use of WITH clause
Cause: Inproper use of WITH clause because one of the following two reasons:

1. nesting of WITH clause within WITH clause not supported yet

2. For a set query, WITH clause can't be specified for a branch.

3. WITH clause can't sepecified within parentheses.

Action: correct query and retry
ORA-32035: unreferenced query name defined in WITH clause
Cause: There is at least one WITH clause query name that is not referenced in any place.
Action: remove the unreferenced query name and retry
ORA-32036: unsupported case for inlining of query name in WITH clause
Cause: There is at least one query name which is inlined more than once because it's definition query is too simple and references another query name. This is currently unsupported yet.
Action: remove such query name and retry
ORA-32037: unsupported use of LEVEL in membership condition
Cause: An attempt was made to use LEVEL in membership condition with subquery that is not supported.
Action: Rewrite query to avoid using LEVEL in membership condition
ORA-32050: %s operation failed
Cause: A mapping operation failed.
Action: Check FMON trace files for errors.
ORA-32051: mapping service not available
Cause: The mapping service was never started or previously failed to start properly.
Action: Set FILE_MAPPING to TRUE if it is not currently set. Otherwise, check FMON trace files for an ORA-32052 error.
ORA-32052: failed to start mapping service
Cause: The mapping service failed to start properly.
Action: Check FMON trace files for errors.
ORA-32053: operation not supported
Cause: Mapping libraries do not support operation.
Action: Check whether mapping libraries are available and whether operation is supported by the libraries.
ORA-32054: lost communication with FMPUTL process
Cause: Lost communication with mapping utility.
Action: Check FMON and FMPUTL trace files for errors.
ORA-32055: invalid file type
Cause: Invalid file type used when mapping files.
Action: Specify one of expected file types.
ORA-32056: invalid number of extents
Cause: Invalid number of extents used for map operation.
Action: Specify a non-negative number of extents.
ORA-32057: invalid lock mode
Cause: An invalid mode was used for a lock operation.
Action: Specify one of expected lock modes.
ORA-32058: operation restricted to SYSDBA users
Cause: Operation requires SYSDBA priviliges.
Action: Connect to the database as SYSDBA.
ORA-32059: deadlock detected on mapping structures
Cause: Mapping structures already locked by the same session.
Action: Unlock mapping structures before proceeding with current operation.
ORA-32060: channel failure
Cause: Channel failure between foreground and background process.
Action: Check foreground trace files for errors.
ORA-32100: operation invalid on transient object
Cause: Trying to perform an operation on transient object which is is valid only on persistent objects
Action: Make sure object is persistent
ORA-32101: cannot create OCI Environment
Cause: An OCI Environment could not be created for OCCI
Action: Insure that the parameters to the creatEnvironment method are valid
ORA-32102: invalid OCI handle
Cause: An invalid OCI handle is passed to an OCI call.
Action: This is an internal OCCI Error. Please contact customer support.
ORA-32103: error from OCI call
Cause: An error code other than OCI_ERROR is returned from an OCI call.
Action: This is an internal OCCI Error. Please contact customer support.
ORA-32104: cannot retrieve OCI error message
Cause: Error message after an OCI call could not be retrieved.
Action: This is an internal OCCI Error. Please contact customer support.
ORA-32106: array fetch not allowed without setBuffer on all columns
Cause: The setBuffer method was not called for all column postions and the next method was called to fetch more than one row.
Action: Call the setBuffer method for all column positions if next is to to be called to fetch more than one row.
ORA-32107: internal OCI memory allocation failure
Cause: Memory could not be allocated from an OCI heap.
Action: Increase the process memory size.
ORA-32108: max column or parameter size not specified
Cause: The max column or parameter size is not specified.
Action: Specify the max size by setMaxColumnSize or setMaxParamSize.
ORA-32109: invalid column or parameter position
Cause: An invalid column or parameter position is specified.
Action: Specify a valid column or position number.
ORA-32110: Connection not specified
Cause: A null connection was passed.
Action: Pass a valid, non-null connection.
ORA-32113: Null object passed
Cause: Null object was passed.
Action: Pass a non-null object.
ORA-32114: Cannot perform operation on a null LOB
Cause: The LOB instance on which the operation was attempted was null.
Action: Use a valid, non-null LOB instance to perform this operation.
ORA-32116: Buffer size is less than amount specified
Cause: The buffer size specified for the LOB read or write operation was less than the amount to be read or written.
Action: The buffer size must be equal to or greater than than the amount to be read from or written to the LOB.
ORA-32117: Source LOB is null
Cause: The source LOB instance on which the operation was attempted was null.
Action: Use a valid, non-null source LOB instance for this operation.
ORA-32118: Cannot perform operation on a null FILE
Cause: The FILE instance on which the operation was attempted was null.
Action: Use a valid, non-null FILE instance to perform this operation.
ORA-32120: Buffer size is less than amount specified
Cause: The buffer size specified for the FILE read or write operation was less than the amount to be read or written.
Action: The buffer size must be equal to or greater than than the amount to be read from or written to the FILE.
ORA-32121: Source FILE is null
Cause: The source FILE instance on which the operation was attempted was null.
Action: Use a valid, non-null source FILE instance for this operation.
ORA-32123: Attribute number is out of range
Cause: The attribute number passed is greater than the total number of attributes of the described object.
Action: Pass the attribute number within the allowable range.
ORA-32124: Illegal attribute passed
Cause: The attribute passed is not applicable for the described object.
Action: Pass a valid attribute.
ORA-32125: Attribute type is not appropriate
Cause: The return type of the get method does not match the type of the attribute being passed.
Action: Call the appropriate get method.
ORA-32126: Cannot perform operations on a null REF
Cause: The REF instance on which the operation was attempted was null.
Action: Use a valid, non-null REF instance to perform this operation.
ORA-32127: REFs do not belong to any connection
Cause: Neither of the REFs being compared had associated connection information.
Action: Atleast one of the REFs being compared must be associated with a valid connection.
ORA-32128: setDataBuffer called after fetch has started
Cause: Fetch from result set has already started and the setDataBuffer call was made.
Action: Call the setDataBuffer method before calling the next() method.
ORA-32129: cannot get information about this column
Cause: The setDataBuffer method was called to get information about this column. Therfore, the current method cannot be called.
Action: Use the information from the buffers specifed in the setDataBuffer call.
ORA-32130: invalid offset/index refrenced in Bytes
Cause: The offset/index is out of range of valid data locations in Bytes offsets.
Action: Insure that offsets or index is within the range of Bytes object.
ORA-32131: bind data type cannot be changed
Cause: The setXXX method is called again with a different data type than originally specified, or the setXXX method is called for a subsequent iteration without being called before the first iteration.
Action: Call the setXXX method with the same data type as done before the first iteration. If no setXXX method was called for this parameter postion the first iteration, then make sure that a setXXX method is called before the first addIteration method is called.
ORA-32132: maximum iterations cannot be changed
Cause: The setMaxIterations is called after a setXXX method has been called.
Action: Call the setMaxIterations method before calling any setXXX methods.
ORA-32133: Cannot get stream from LOB/FILE
Cause: An open stream exists on the the LOB/FILE on which the operation was attempted.
Action: Close the stream before getting another.
ORA-32134: Cannot assign LOBs
Cause: An open stream exists on the target LOB.
Action: Close the stream on the target LOB before assigning the LOBs.
ORA-32135: Cannot assign FILEs
Cause: An open stream exists on the target FILE.
Action: Close the stream on the target FILE before assigning the FILEs.
ORA-32136: Cannot perform operation on an invalid stream
Cause: The LOB/FILE from which the stream was obtained had been nullified or destroyed.
Action: Use a valid stream.
ORA-32139: Cannot write to the stream
Cause: A write was performed after the last buffer was written.
Action: Close this stream and get a new stream to perform the write.
ORA-32140: cannot peform this operation on stream
Cause: Either a read is attempted from a stream oi write mode, or a write is attempted on a stream in read mode.
Action: Check the status of the stream to find out the valid operations that can be performed.
ORA-32141: get method does not match the type of the parameter
Cause: The getXXX method called on the Statement object does not match the type of the bind parameter.
Action: Call the getXXX method that is the same as the type of the parameter.
ORA-32142: maximum number of iterations exceeded
Cause: The addIteration exceeds the maximum number of iterations set by the the setMaxIterations method.
Action: Increase the maximum number of allowed iterations.
ORA-32143: Environment not specified
Cause: A null environment was passed.
Action: Pass a valid, non-null environment.
ORA-32144: Cannot perform operation on a null interval
Cause: The interval involved in this operation is null.
Action: Use valid, non-null interval instance to perform this operation.
ORA-32145: Environment not specified
Cause: The interval on which the operation was attempted was null and no environment was specified.
Action: Specify non-null environment or perform the operation on a non null instance.
ORA-32146: Cannot perform operation on a null date
Cause: The date involved in this operation is null.
Action: Use valid, non-null date instance to perform this operation.
ORA-32147: Environment not specified
Cause: The date on which the operation was attempted was null and no environment was specified.
Action: Specify non-null environment or perform the operation on a non null instance.
ORA-32150: Cannot perform operation on a null timestamp
Cause: The timestamp involved in this operation is null.
Action: Use valid, non-null timestamp instance to perform this operation.
ORA-32151: Environment not specified
Cause: The timestamp on which the operation was attempted was null and no environment was specified.
Action: Specify non-null environment or perform the operation on a non null instance.
ORA-32152: Cannot perform operation on a null number
Cause: The number involved in this operation is null.
Action: Use valid, non-null number instance to perform this operation.
ORA-32153: Environment not specified
Cause: The number on which the operation was attempted was null and no environment was specified.
Action: Specify non-null environment or perform the operation on a non null instance.
ORA-32154: Anydata context not specified
Cause: A null anydata context was passed.
Action: Pass a valid, non-null anydata context.
ORA-32155: Anydata not specified
Cause: A null anydata was passed.
Action: Pass a valid, non-null anydata.
ORA-32156: Cannot perform operation on stream
Cause: This operation is not applicable to streams obtained from LOBs.
Action: none
ORA-32158: Invalid type passed
Cause: An inapplicable type was passed to this call.
Action: Pass an applicable type.
ORA-32159: Cannot set prefetch options for a null Type
Cause: A null Type name was passed.
Action: Pass an non-null Type name.
ORA-32161: Cannot perform piecewise fetch
Cause: Zero amount was passed and buffer size was less than LOB size
Action: Specify a larger buffer or use Stream
ORA-32162: Read/Write SQL method not registered
Cause: readSQL/writeSQL method was NULL or was not registered
Action: Register readSQL/writeSQL by calling put method in Map
ORA-32163: Method called on Invalid Environment type
Cause: A non-XA call made on an XA Environment or XA call made on non-XA Environment
Action: Make sure Environment type is OK
ORA-32164: Method called on Invalid Connection type
Cause: A non-XA call made on an XA Connection or XA call made on non-XA Connection
Action: Make sure Connection type is OK
ORA-32165: Cannot get XA environment
Cause: Incorrect dbname string was passed or the XA connection has not been opened
Action: Pass the correct dbname string or check if the XA connection is open
ORA-32166: Cannot get XA connection
Cause: Incorrect dbname string was passed or the XA connection has not been opened
Action: Pass the correct dbname string or check if the XA connection is open
ORA-32167: No payload set on the Message
Cause: An attempt was made to enqueue a message without setting a payload on it.
Action: Set a payload on the message before calling the send method.
ORA-32300: cannot drop a secondary materialized view "string"."string"
Cause: An attempt was made to drop a materialized view of a nested table column's storage table.
Action: Drop the materialized view that contains the nested table column. This will implicitly drop all secondary materialized views.
ORA-32301: object-relational materialized views must be primary key based
Cause: An attempt was made to create an object-relational materialized view that is not primary key based.
Action: Create the materialized view with the PRIMARY KEY keyword.
ORA-32302: object materialized views must be object ID based
Cause: An attempt was made to create an object materialized view that is not object ID based.
Action: Create the materialized view using the OF clause but omit any ROWID or PRIMARY KEY clauses.
ORA-32303: mviews with user-defined types cannot reference multiple master sites
Cause: For materialized views with user-defined types, the definition query cannot reference tables from different master sites.
Action: Do not create materialized views with user-defined types referencing multiple master sites.
ORA-32304: materialized views with user-defined types cannot use prebuilt table
Cause: An attempt was made to create a materialized view with the ON PREBUILT TABLE option.
Action: Do not create the materialized view with the ON PREBUILT TABLE option.
ORA-32305: RepAPI materialized views with user-defined types are not supported
Cause: An attempt was made to create a RepAPI materialized view with user-defined types.
Action: Do not create a RepAPI materialized view with user-defined types.
ORA-32306: updatable materialized views with user-defined types must use SELECT *
Cause: An attempt was made to create an updatable materialized view with user-defined types where the definition query did not use SELECT * at the topmost level.
Action: Rewrite the definition query so that SELECT * is used at the topmost level.
ORA-32307: must use FROM ONLY clause when referencing an object table
Cause: An attempt was made to create a materialized view whose definition query references object tables without the FROM ONLY clause.
Action: Rewrite the definition query to use the FROM ONLY clause for all the object tables in the query.
ORA-32308: object materialized views must use SELECT *
Cause: An attempt was made to create an object materialized view where the definition query did not use SELECT * at the topmost level.
Action: Rewrite the definition query so that SELECT * is used at the topmost level.
ORA-32309: object mview type "string"."string" does not match the master table type
Cause: An attempt was made to create an object materialized view whose type does not match the type of the master object table.
Action: Redefine the type so that it matches the type of the master object table.
ORA-32310: object materialized views must select from an object table
Cause: An attempt was made to create an object materialized view whose definition query did not select from an object table.
Action: Rewrite the definition query to select from an object table.
ORA-32311: materialized view definition query selects an unsupported user-defined type
Cause: An attempt was made in the definition query to select an embedded user-defined type, function returning a user-defined type, or a function whose arguments are user-defined types.
Action: Rewrite the definition query to exclude these unsupported user-defined types.
ORA-32312: cannot refresh a secondary materialized view "string"."string"
Cause: An attempt was made to refresh a materialized view of a nested table column's storage table.
Action: Refresh the materialized view that contains the nested table column. This will implicitly refresh all secondary materialized views.
ORA-32313: REFRESH FAST of "string"."string" unsupported after PMOPs
Cause: A Partition Maintenance Operation (PMOP) has been performed on a detail table, and the specified materialized view does not support fast refersh after PMOPs.
Action: Use REFRESH COMPLETE. Note: you can determine why your materialized view does not support fast refresh after PMOPs using the DBMS_MVIEW.EXPLAIN_MVIEW() API.
ORA-32314: REFRESH FAST of "string"."string" unsupported after deletes/updates
Cause: One or more deletes or updates has been performed on one or more of the detail tables referenced by the specified materialized view. This materialized view does not support fast refresh after deletes or updates.
Action: Use REFRESH COMPLETE. Note: you can determine why your materialized view does not support fast refresh after deletes or updates using the DBMS_MVIEW.EXPLAIN_MVIEW() API.
ORA-32315: REFRESH FAST of "string"."string" unsupported after mixed DML and Direct Load
Cause: One or more of the materialized view logs on the detail tables referenced by the specified materialized view omits the sequence number option. Such a log cannot be used to refresh a materialized view after deletes or updates and direct path insert.
Action: Use REFRESH COMPLETE. Note: you can use the DBMS_MVIEW.EXPLAIN_MVIEW() API to determine which materialized view logs omit the sequence number option.
ORA-32316: REFRESH FAST of "string"."string" unsupported after mixed DML
Cause: One or more of the materialized view logs on the detail tables referenced by the specified materialized view omits the sequence number option. Such a log cannot be used to refresh a materialized view after deletes or updates have been performed on multiple detail tables.
Action: Use REFRESH COMPLETE. Note: you can use the DBMS_MVIEW.EXPLAIN_MVIEW() API to determine which materialized view logs omit the sequence number option.
ORA-32317: cannot run a job from a job
Cause: An attempt was made to execute a job from within another job.
Action: Do not submit jobs that run other jobs.
ORA-32318: cannot rename a materialized view
Cause: Renaming a materialized view or its base table is not supported.
Action: Do not rename the base table of a materialized view.
ORA-32319: Cannot use direct loader log to FAST REFRESH materialized view "string"."string"
Cause: The direct loader log might have been dropped
Action: Need to do complete refresh
ORA-32320: REFRESH FAST of "string"."string" unsupported after container table PMOPs
Cause: A Partition Maintenance Operation (PMOP) has been performed on the materialized view, and no materialized view supports fast refersh after container table PMOPs.
Action: Use REFRESH COMPLETE. Note: you can determine why your materialized view does not support fast refresh after PMOPs using the DBMS_MVIEW.EXPLAIN_MVIEW() API.
ORA-32321: REFRESH FAST of "string"."string" unsupported after detail table TRUNCATE
Cause: A detail table has been truncated and no materialized view supports fast refersh after a detail table has been truncated
Action: Use REFRESH COMPLETE. Note: you can determine why your materialized view does not support fast refresh after TRUNCATE using the DBMS_MVIEW.EXPLAIN_MVIEW() API.
ORA-32322: PCT refresh of "string"."string" not allowed the sequence of DMLs/PMOPs
Cause: A table join dependent on another table on which PCT refresh is enabled has changed
Action: Use REFRESH FORCE which will pick the best possible refresh method on the materialized view
ORA-32330: invalid operation on online redefinition interim table "string"."string"
Cause: An invalid operation was performed on an interim table which was being used for online redefinition of a table.
Action: Do not perform any unsupported operation on the interim table.
ORA-32331: type "string"."string" is incompatible with the master site
Cause: A type used by the materialized view was found to be incompatible with its coressponding type on the master site. This could be because the type does not exist on the master site or has been evolved to a different version from that on the materialzied view site.
Action: Make sure that the types used by the materialized view are the same on both the materialized view and master sites.
ORA-32332: cannot refresh materialized view "string"."string" as type evolution has occured
Cause: The types used by the materialized view or its master tables have been evolved.e29250.msg@@/main/308e29250.msg@@/main/308
Action: Ensure that the types used by the materialized view have been evolved to the same version at both the master and materialized sites. Then, before refreshing the materialized view, evolve the materialized view using ALTER MATERIALIZED VIEW.
ORA-32333: disable table scn update for Materialized view
Cause: an event is set for disabling table scn update to prevent deadlock situation. (bug 1376209)
Action: disable null refresh and/or base table scn update for Materialized view
ORA-32334: cannot create prebuilt materialized view on a table already referenced by a MV
Cause: the table on which the materialized view is created as prebuilt is already referenced by a materialized view
Action: create the materialized view on a different table
ORA-32335: dimension must have at least one level
Cause: An level-less dimension is not allowed.
Action: Do not drop the only level of a dimension.
ORA-32336: cannot use USING NO INDEX to create materialized view "string"."string"
Cause: The USING NO INDEX option was specified to create an updatable primary key based materialized view, an index-organized materialized view or an object-id materialized view.
Action: Do not use the USING NO INDEX option to create an updatable primary key based materialized view, an index-organized materialized view or an object-id materialized view.
ORA-32337: cannot alter materialized view with pending changes refresh on commit
Cause: There are some pending changes in the detail tables
Action: Execute an on-demand refresh on the materialized view to synchronize the data between the materialized view and the detail tables and then issue an ALTER MATERIALIZED VIEW statement.
ORA-32338: on commit refresh grab all the detailed tables
Cause: an event is set to let on-commit MV refresh to grab all the detailed tables, no matter whether they have modified or not.
Action: none
ORA-32339: cannot alter materialized view with the PMOP
Cause: the materialized view is not allowed to have destructive PMOPS such as DROP, TRUNCATE and EXCHANGE (sub)partition. The UGA flag of i_am_a_refresh should be set first.
Action: execute set_i_am_a_refresh first before alter materialized view with the PMOP.
ORA-32340: cannot tune the materialized view definition
Cause: Due to constructs in the materialized view definition, it could not be tuned to be fast-refreshable or rewriteable.
Action: Execute DBMS_MVIEW.EXPLAIN_MVIEW to determine the cause.
ORA-32341: The EXPLAIN_MVIEW facility failed to explain the materialized view "string"."string"
Cause: The dependent object(s) of the materialized view may have changed. The materialized view may no longer be valid.
Action: Execute ALTER MATERIALIZED VIEW COMPILE and to determine the status of the materialized view in catalog views.
ORA-32342: The EXPLAIN_MVIEW facility failed to explain the materialized view statement
Cause: An error exists in the materialized view definition. As a result, the materialized view statement could not be explained.
Action: Check the syntax of the statement. If it is a CREATE MATERIALIZED VIEW statement, then also check the PARAMETERs specified for the materialized view.
ORA-32400: cannot use object id columns from materialized view log on "string"."string"
Cause: The materialized view log either does not have object id columns logged, or the timestamp associated with the object id columns is more recent than the last refresh time.
Action: A complete refresh is required before the next fast refresh. Add object id columns to the materialized view log, if required.
ORA-32401: materialized view log on "string"."string" does not have new values
Cause: Materialized view log on the indicated table does not have new values information.
Action: Add new values to materialized view log using the ALTER MATERIALIZED VIEW LOG command.
ORA-32403: cannot use new values from mv log on "string"."string"
Cause: The materialized view log either does not have new values logged, or the timestamp associated with the new values columns is more recent than the last refresh time.
Action: Perform a complete refresh is required before the next fast refresh.
ORA-32404: snapshot log uses Change Data Capture which is not enabled for this database
Cause: A snapshot log that utilizes Change Data Capture is being imported to a database where Change Data Capture has not been enabled.
Action: First enable Change Data Capture on the database then retry the import.
ORA-32405: cannot alter tablespace for existing materialized view log
Cause: The tablespace specification for the existing materialized view log cannot be altered or changed.
Action: remove the tablespace clause from the statement.
ORA-32406: cannot alter partitioning for existing materialized view log
Cause: The partitioning specification for the existing materialized view log cannot be altered or changed.
Action: remove the partitioning clause from the statement.
ORA-32407: cannot exclude new values when materialized view log includes new values
Cause: The excluding new values specification for the existing materialized view log cannot be accepted when including new values is the current option.
Action: change excluding new values clause.
ORA-32408: materialized view log on "string"."string" already has new values
Cause: The materialized view log on the indicated table already has new values.
Action: No action required.
ORA-32409: materialized view log on "string"."string" already excludes new values
Cause: The materialized view log on the indicated table already excludes new values.
Action: No action required.
ORA-32500: Dirname 'string' cannot exceed 'number' characters
Cause: Path name too long
Action: Use shorter pathname than maximum specified for dirname.
ORA-32501: Writing SGA to file failed
Cause: Underlying OSDs encountered an error
Action: Check additional information. slercerrno contains errno.
ORA-32502: Cannot execute command. Flash Freeze is not in effect
Cause: This command can only be issued after a flash freeze
Action: Refer to instructions for flash freeze and Oracle diagnostics.
ORA-32503: Mapping SGA from file failed
Cause: Underlying OSDs encountered an error
Action: Check additional information. slercerrno contains errno.
ORA-32504: expecting one of string, string, string, or string but found string
Cause: illegal value specified for create watchpoint mode
Action: specify one of the expected modes
ORA-32505: too many watchpoints
Cause: too many watchpoints created
Action: increase appropriate initialization parameters
ORA-32506: expecting one of string, string, or string but found string
Cause: invalid arguments provided
Action: provide one of the expected arguments
ORA-32507: expecting string but found string
Cause: invalid arguments to command
Action: provide one of the expected arguments
ORA-32508: no such watchpoint id
Cause: invalid watchpoint id
Action: use oradebug show to list valid watchpoint ids
ORA-32509: watchpoint was already deleted
Cause: trying to delete an already deleted watchpoint
Action: use oradebug show to list valid watchpoint ids
ORA-32510: cannot create watchpoint on unreadable memory
Cause: trying to create watchpoint on invalid address
Action: provide a different valid address
ORA-32511: cannot create watchpoint in memory needed by watchpointing code
Cause: overlap exists between requested memory range to watch and internal memory structures that watchpointing operations need
Action: provide a different address range
ORA-32550: Replacement occured despite hint to the contrary
Cause: This should never be signalled; it's internal.
Action: Report to Oracle support.
ORA-32575: Explicit column default is not supported for modifying views
Cause: Default keyword was used to modify views.
Action: Use implicit default - omitting column-value pair.
ORA-32576: missing TYPE keyword
Cause: keyword TYPE is missing.
Action: Use TYPE keyword.
ORA-32577: username must be SYS or SYSTEM
Cause: A user name of SYS or SYSTEM was not specified when providing a password in the CREATE DATABASE statement.
Action: Only passwords for the SYS and SYSTEM users can be provided in the CREATE DATABASE statement. Re-issue the statement with passwords for users SYS or SYSTEM.
ORA-32578: password for SYS already specified
Cause: A password for the SYS user was specified twice in the CREATE DATABASE statement.
Action: Re-issue the CREATE DATABASE statement with only one password for the SYS user.
ORA-32579: password for SYSTEM already specified
Cause: A password for the SYSTEM user was specified twice in the CREATE DATABASE statement.
Action: Re-issue the CREATE DATABASE statement with only one password for the SYSTEM user.
ORA-32580: both SYS and SYSTEM passwords must be provided
Cause: Passwords for both the SYS and SYSTEM users were not provided in the CREATE DATABASE statement. If one of the passwords was provided, then both should be provided.
Action: Re-issue the CREATE DATABASE statement with a password for both the SYS and SYSTEM users.
ORA-32581: missing or invalid password
Cause: An incorrect password was provided for the SYS or SYSTEM user in the CREATE DATABASE statement.
Action: Re-issue the CREATE DATABASE statement with a valid password.
ORA-32582: table function with left correlation to a table cannot also be left outer-joined to the table
Cause: A table function T2 contains a reference to a table T1. T2 is also left outer-joined to T1. This is not allowed.
Action: Remove the reference to T1 from T2 or remove the left outer-join specification (+).
ORA-32583: query passed to table function has wrong number of elements in select list
Cause: The query used as an input to a table function which takes a a ref cursor as argument has wrong number of elements in the select list which does not correspond to the elements in ref cursor. The ref cursor mentioned here refers to the one referenced in order by parition clauses. This is not allowed.
Action: Make sure that the select list of the query matches the ref cursor columns as defined in the function.
ORA-32584: missing LOG keyword
Cause: keyword LOG is missing.
Action: Use LOG keyword.
ORA-32585: duplicate specification of a supplemental log attribute
Cause: In a create/alter DDL a supplemental log attribute is specified more than once.
Action: Rewrite the Create/Alter DDL such that it has a single occurence of any supplemental log attribute.
ORA-32586: multiple specification of a supplemental logging attribute
Cause: The primary key, unique index, foreign key or all column supplemental logging attribute can be specified at most once in a create/alter ddl.
Action: Rewrite the Create/Alter DDL with single occurence of the offending supplemental logging attribute.
ORA-32587: Cannot drop nonexistent string supplemental logging
Cause: specified supplemental log attribute does not exist.
Action: None
ORA-32588: supplemental logging attribute string exists
Cause: specified supplemental logging attribute exits.
Action: retry the alter/create ddl after removing this supplemental logging attribute.
ORA-32589: unable to drop minimal supplemental logging
Cause: Minimal supplemental logging could not be dropped as one of primary key, foreign key, unique or all column supplemental logging is enabled at the database level.
Action: Use V$DATABASE to determine the databasewide supplemental logging directives. Minimal supplemental logging could be dropped if and only if no other databasewide supplemental logging directives are enabled.
ORA-32590: log group specification not allowed here
Cause: Supplemental log specification is not allowed in the statement.
Action: Remove the supplemental log specification from the statement.
ORA-32591: connect string too long
Cause: The connect string specified for the database link was more than 2000 characters.
Action: Specify a connect string less than 2000 chracters.
ORA-32592: all columns in log group can not be no log columns
Cause: A supplemental log group must have at least one column of scalar type that is not marked as no log.
Action: Redefine the supplemental log group with at least one column of scalar type that is not marked as no log.
ORA-32593: database supplemental logging attributes in flux
Cause: there is another process actively modifying the database wide supplemental logging attributes.
Action: Retry the DDL or the LogMiner dictionary build that raised this error.
ORA-32600: RETENTION and PCTVERSION cannot be used together
Cause: cannot use both RETENTION and PCTVERSION together.
Action: Use either RETENTION or PCTVERSION.
ORA-32601: value for retention cannot be provided
Cause: cannot give a value for Retention Period.
Action: do not provide the value for parameter.
ORA-32602: FREEPOOLS and FREELIST GROUPS cannot be used together
Cause: cannot use both FREEPOOLS and FREELIST GROUPS together.
Action: Use either FREEPOOLS or FREELIST GROUPS.
ORA-32603: invalid FREEPOOLS LOB storage option value
Cause: The specified FREEPOOLS LOB storage option value must be an integer.
Action: Choose an appropriate integer value and retry the operation.
ORA-32604: invalid REBUILD option
Cause: Keyword FREEPOOLS expected after the REBUILD keyword.
Action: User must specify FREEPOOLS keyword.
ORA-32605: invalid REBUILD option
Cause: cannot rebuild freepools while creating table with lob column.
Action: User must not specify REBUILD... in this context.
ORA-32606: missing NAV keyword in MODEL clause
Cause: The NAV keyword was specified where it is expected.
Action: Specify the NAV keyword or check the SQL statement.
ORA-32607: invalid ITERATE value in MODEL clause
Cause: The specified ITERATE value must be a 4 byte positive integer.
Action: Choose an appropriate value and retry the operation.
ORA-32608: missing INCREMENT or DECREMENT keyword in FOR loop
Cause: INCREMENT or DECREMENT keyword was not specifiedi where it is expected.
Action: Specify the INCREMENT or DECREMENT keyword or check the SQL statement.
ORA-32609: missing REFERENCE keyword in MODEL clause
Cause: The REFERENCE keyword was not specified where it is expected.
Action: Specify the REFERENCE keyword or check the SQL statement.
ORA-32610: missing SINGLE REFERENCE or DIMENSION keyword in MODEL clause
Cause: SINGLE REFERENCE or DIMENSION keyword was not specified where it is expected.
Action: Specify the applicable keywords or check the SQL statement.
ORA-32611: incorrect use of MODEL CV operator
Cause: CV function was used outside a dimension expression, in UNTIL condition, or with non-dimensional arguments.
Action: Check the SQL statement and rewrite if necessary.
ORA-32612: invalid use of FOR loop
Cause: The MODEL FOR loop was used where it is not allowed. FOR loops are not allowed in complex dimensional predicates, on the right hand side of rules, or in the until condition.
Action: Check the SQL statement and rewrite if necessary.
ORA-32613: not a MODEL cell
Cause: The operator requires a MODEL cell as operand.
Action: Specify MODEL cell as operand, check SQL statement.
ORA-32614: illegal MODEL SELECT expression
Cause: An expression other than MODEL aliases, constants, or expressions of the two is specified in the MODEL SELECT clause.
Action: Reformulate the query, perhaps nesting inside another SELECT.
ORA-32615: incorrect use of MODEL IS ANY predicate
Cause: IS ANY predicate is used outside dimension expression or with non-dimensional or different dimensional arguments.
Action: Check the SQL statement and rewrite if necessary.
ORA-32616: missing DIMENSION BY keyword in MODEL clause
Cause: The DIMENSION keyword was not pecified where it is expected.
Action: Specify the DIMENSION keyword or check the SQL statement.
ORA-32617: missing MEASURES keyword in MODEL clause
Cause: The MEASURES keyword was not specified where it is expected.
Action: Specify the MEASURES keyword or check the SQL statement.
ORA-32618: incorrect use of MODEL PREVIOUS function
Cause: The MODEL PREVIOUS function was used outside of MODEL "ITERATE UNTIL" clause, or was nested.
Action: Check the SQL statement and rewrite if necessary.
ORA-32619: incorrect use of MODEL ITERATION_NUMBER
Cause: ITERATION_NUMBER was used outside of an iterated MODEL.
Action: Check the SQL statement and rewrite if necessary.
ORA-32620: illegal subquery within MODEL rules
Cause: A subquery was used illegally within the MODEL rule.
Action: Check the SQL statement and rewrite if necessary.
ORA-32621: illegal aggregation in UNTIL iteration condition
Cause: An aggregate function was used in UNTIL condition.
Action: Check the SQL statement and rewrite if necessary.
ORA-32622: illegal multi-cell reference
Cause: Multi-cell reference was specified on a measure expression without an aggregate function.
Action: Use an aggregate function on the measure expression or qualify the cell reference.
ORA-32623: incorrect use of MODEL PRESENT* functions
Cause: A PRESENT* function (IS PRESENT, PRESENTV, PRESENTNNV) was used in a measure expression.
Action: Check the SQL statement and rewrite if necessary.
ORA-32624: illegal reordering of MODEL dimensions
Cause: The expressions to qualify dimensions were specified in an incorrect order within a cell reference.
Action: Reorder dimension expressions in the cell reference.
ORA-32625: illegal dimension in cell reference predicate
Cause: A non-positional dimension was referenced in the predicate.
Action: Check the SQL statement and rewrite if necessary.
ORA-32626: illegal bounds or increment in MODEL FOR loop
Cause: FOR loop allows only numeric and datetime without timezone type for bounds. Only constants of interval and numeric types are allowed as increment/decrement expressions.
Action: Check the SQL statement and rewrite if necessary.
ORA-32627: illegal pattern in MODEL FOR LIKE loop
Cause: The FOR LIKE pattern had zero or more than one wild characters.
Action: Simplify the pattern to have a single wildcard character.
ORA-32628: invalid nesting of MODEL cell reference
Cause: MODEL cell reference was nested too deeply.
Action: Avoid deep nesting of cell references and rewrite if necessary.
ORA-32629: measure used for referencing cannot be updated
Cause: A measure used in nested referencing is updated by a MODEL rule in the automatic order MODEL.
Action: Modify the SQL statement or use sequential order MODEL.
ORA-32630: multiple assignment in automatic order MODEL
Cause: A MODEL cell was updated on the same measure in multiple MODEL rules. Multiple assignment is not allowed in automatic order MODELs as it causes in ambiguity and nondeterminism.
Action: Use sequential order MODEL or rewrite the rule to avoid this.
ORA-32631: illegal use of objects in MODEL
Cause: An object column was used as a MODEL column. Object types are not allowed as partition by, dimension by or measure expressions.
Action: Check the SQL statement and rewrite if necessary.
ORA-32632: incorrect subquery in MODEL FOR cell index
Cause: An illegal subquery was specified in MODEL FOR cell index. A subquery used in a MODEL FOR cell index can not have subqueries, correlation, binds and references to WITH tables.
Action: Check the SQL statement and rewrite if necessary.
ORA-32633: MODEL subquery FOR cell index returns too many rows
Cause: Subquery in MODEL FOR cell index returned more than the allowed maximum.
Action: Split the rule into multiple ones.
ORA-32634: automatic order MODEL evaluation does not converge
Cause: Evaluation using automatic rule ordering did not reach a convergence point.
Action: Modify the rules or use sequential order instead.
ORA-32635: not a single cell reference predicate
Cause: A predicate that is not a single cell reference predicate was specified where a single cell reference predicate was expected. A single cell reference predicate is either a constant expression or a predicate of the form <dimension_key = constant_expr>
Action: Make sure that the predicate is a proper single cell reference. In some cases, you might have to put explicit type conversion operators (or casts) on the constant expression.
ORA-32636: Too many rules in MODEL
Cause: The number of rules (possibly after rule unfolding) exceeded the maximum number of rules allowed.
Action: Reduce the number of rules.
ORA-32637: Self cyclic rule in sequential order MODEL
Cause: A self-cyclic rule was detected in the sequential order MODEL. Sequential order MODELs cannot have self cyclic rules to guarantee that the results do not depend on the order of evaluation of the cells that are updated or upserted.
Action: Use ordered rule evaluation for this rule.
ORA-32638: Non unique addressing in MODEL dimensions
Cause: The address space defined for the MODEL (partition by and dimension by expressions) do not uniquely identify each cell.
Action: Rewrite the MODEL clause. Using UNIQUE SINGLE REFERENCE option might help.
ORA-32639: Aggregate functions on reference MODELs are not allowed
Cause: An aggregate function was specified on the cells of a reference MODEL.
Action: Check the SQL statement and rewrite if necessary.
ORA-32640: FOR LIKE loops are not allowed for multi-byte character types
Cause: FOR LIKE loops was specified for a multi-byte character type.
Action: Check the SQL statement and rewrite if necessary.
ORA-32641: invalid expression in MODEL rule ORDER BY clause
Cause: An invalid expression was specified in the MODEL rule ORDER BY clause where only expressions of dimension and measure columns and reference MODEL cell references are allowed
Action: Modify the order by clause in the MODEL rule.
ORA-32642: non-unique cell values from the ORDER BY clause
Cause: The MODEL rule ORDER BY clause did not generate unique values for all cells that satisfy the predicates in the left side of the rule.
Action: Modify the rule ORDER BY clause in the MODEL rule.
ORA-32690: Hash Table Infrastructure ran out of memory
Cause: Not enough memory.
Action: Increase memory.
ORA-32695: HTI: Not enough memory
Cause: Memory is not enough.
Action: Increase memory.
ORA-32696: HTI: No free slot
Cause: There is not enough memory.
Action: Increase memory.
ORA-32700: error occurred in DIAG Group Service
Cause: An unexpected error occurred while performing a DIAG Group Service operation.
Action: Verify that the DIAG process is still active. Also, check the Oracle DIAG trace files for errors.
ORA-32730: Command cannot be executed on remote instance
Cause: DIAG is not registered with DIAG Group Service
Action: Issue the command without the cluster database syntax
ORA-32731: Another Parallel Oradebug session is in progress
Cause: Another session for Parallel Oradebug is in progress with the database
Action: Issue the command later when the current session finishes
ORA-32732: Parallel Oradebug session is aborted
Cause: Group reconfiguration is occurring among DIAGs
Action: Issue the command later when group reconfiguration completes
ORA-32733: Error occurred when executing Parallel Oradebug
Cause: Error is encountered during executing command at local node
Action: Check alert log and DIAG trace file for error detail
ORA-32734: Error occurred when sending Oradebug command to remote DIAGs
Cause: IPC communication problem encountered
Action: Check IPC communication between DIAGs and issue the command again
ORA-32735: DIAG process is not running in the instance
Cause: DIAG process is not alive
Action: Check error in DIAG trace file and issue the command again when DIAG is restarted
ORA-32736: Hang analysis aborted due to wrong message type
Cause: DIAG received wrong message.
Action: Check DIAG trace files for errors.
ORA-32737: Hang analysis aborted due to failed memory allocation
Cause: DIAG couldn't allocate buffer for remote copy.
Action: Check DIAG trace files for errors.
ORA-32738: Hang analysis aborted due to failed memory copy
Cause: DIAG couldn't copy buffer to remote node.
Action: Check DIAG trace files for errors.
ORA-32739: Hang analysis aborted due to failed heap re-grow
Cause: DIAG couldn't re-grow the heap for wait-for-graphs.
Action: Check DIAG trace files for errors.
ORA-32740: The requested operation cannot be proceeded
Cause: Operation was aborted because instance termination was in progress.
Action: Retry later after restarting the instance.
ORA-32741: Hang analysis already going on
Cause: Hang analysis was already in process globally or for the instance.
Action: Wait for the current operation to complete and re-run the command.
ORA-32742: Hang analysis initialize failed
Cause: Hang analyzer was not able to allocate memory to initialize.
Action: Check the trace files.
ORA-32743: command cannot be executed on remote instance
Cause: The database was not mounted in SHARED mode.
Action: Mount the database in SHARED mode.
ORA-32761: Turn off Temp LOB Ref Count Feature
Cause: None
Action: Turn off the whole temp lob ref count feature
ORA-32762: Turn on Temp LOB Ref Count Tracing
Cause: None
Action: Check Trace file for debug info
ORA-32763: Turn off N-Pass Temp LOB cleanup
Cause: None
Action: Facilitate debugging and testing //////////////////////////// SQL function on LOBs Error numbers 32766 to 32770 are reserved for SQL function on LOBs ////////////////////////////
ORA-32766: instr with negative offset: use varchar semantics on LOBs
Cause: The current varchar behavior is different. e.g. instr('abcd', 'cd', -2, 1) returns 3, whereas instr(to_clob('abcd'), 'cd', -2, 1) returns 0, (i.e. no match), because the reverse search starts from offset -2, which points to 'c' and moving backward, i.e. 'd' is ignored. This is symmetric to instr('dcba','dc',2,1), which returns 0.
Action: ORACLE uses the same varchar semantics on LOBs (instr). Using the same example, instr(to_clob('abcd'), 'cd', -2, 1) will return 3 as in the varchar case.
ORA-32771: cannot add file to bigfile tablespace
Cause: An attempt was made to add the second file to a bigfile tablespace.
Action: Do not use this command with bigfile tablespace.
ORA-32772: BIGFILE is invalid option for this type of tablespace
Cause: An attempt was made to create a bigfile tablespace that is dictionary managed or locally managed with manual segment-space management.
Action: Either change the tablespace type to locally managed with automatic segment-space management, or create a SMALLFILE tablespace instead.
ORA-32773: operation not supported for smallfile tablespace string
Cause: An attempt was made to perform an operation which is supported only for bigfile tablespaces, e.g. resize tablespace.
Action: Use the appropriate clause of the ALTER DATABASE DATAFILE command instead.
ORA-32774: more than one file was specified for bigfile tablespace string
Cause: More than one datafile or tempfile was specified in CREATE TABLESPACE command for a bigfile tablespace.
Action: Change command to contain only one file or create a smallfile tablespace instead.
ORA-32775: cannot change size attributes of read only tablespace string
Cause: An attempt was made to change size attributes of a tablespace that is read only.
Action: Change the tablespace to read/write and retry the operation.


17 ORA-32800 to ORA-32846

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

17 ORA-32800 to ORA-32846

ORA-32800: internal error string
Cause: An unexpected error occurred.
Action: Contact Oracle Support Services.
ORA-32801: invalid value string for string
Cause: An invalid value was specified for a parameter.
Action: Specify a valid value for the parameter.
ORA-32802: value for string must be string
Cause: An invalid value was specified for a parameter.
Action: Specify the value as indicated by the message.
ORA-32803: value for string cannot be altered
Cause: An attempt was made to alter a value that cannot be altered.
Action: Retry the operation without altering the indicated value.
ORA-32804: invalid value string, string should have form string
Cause: A value specified for a parameter has the incorrect form.
Action: Specify a string of the correct form.
ORA-32805: identifier for string too long, maximum length is string characters
Cause: An identifier string exceeded the maximum allowed length.
Action: Specify a string whose length is less than the maximum allowed length.
ORA-32806: value for string is too long, maximum length is string
Cause: A value exceeded it's maximum allowed length.
Action: Specify a value whose length is less than the maximum allowed length.
ORA-32807: message system link string already exists
Cause: A message system link of the specified name already exists.
Action: Specify a different name.
ORA-32808: message system link string does not exist
Cause: A message system link of the specified name does not exist.
Action: Specify a message system link name that already exists.
ORA-32809: foreign queue string is already registered
Cause: The foreign queue has already been registered for this message system link (NAME@MSGLINK).
Action: Specify a different name that is not being used for this message system link.
ORA-32810: foreign queue string is not registered
Cause: The foreign queue (NAME@MSGLINK) has not been registered for this message system link.
Action: Specify the name of a registered foreign queue.
ORA-32811: subscriber string already exists
Cause: The specified subscriber identifier already exists.
Action: Specify a different identifier.
ORA-32812: subscriber string does not exist
Cause: The specified subscriber identifier does not exist.
Action: Specify an existing subscriber identifier.
ORA-32813: propagation schedule string already exists
Cause: The specified propagation schedule identifer already exists.
Action: Specify a different identifier.
ORA-32814: propagation schedule string does not exist
Cause: The specified propagation schedule identifier does not exist.
Action: Specify a schedule identifier that already exists.
ORA-32815: message system link string is referenced by a foreign queue
Cause: An attempt was made to remove a message system link currently referenced by one or more registered foreign queues.
Action: Unregister all foreign queues using this message system link and retry the operation.
ORA-32816: foreign queue string is referenced by a subscriber or schedule
Cause: An attempt was made to unregister a foreign queue currently referenced by one or more subscribers or propagation schedules.
Action: Remove all subscribers and propagation schedules using this foreign queue and retry the operation.
ORA-32817: message system link string is not configured with a log queue for string
Cause: An attempt was made to add a propagation subscriber but the message system link was not configured with a log queue for the indicated propagation type.
Action: Alter the message system link to configure the link with a log queue for this propagation type.
ORA-32818: AQ queue string does not exist
Cause: An operation was attempted where the specified AQ queue does not exist.
Action: Specify the name of an existing AQ queue.
ORA-32819: AQ queue string must be a normal queue
Cause: An operation was attempted where the specified AQ queue exists but is not a normal queue.
Action: Specify the name of an AQ queue which was created as a normal queue (NORMAL_QUEUE).
ORA-32820: subscriber queue and exception queue must use same message system link
Cause: An operation was attempted for INBOUND propagation where the specified subscriber queue and exception queue reference different message system links.
Action: Specify an exception queue that is a registered foreign queue of the same message system link as the subscriber queue.
ORA-32821: subscriber queue and exception queue must have same payload type
Cause: An operation was attempted for OUTBOUND propagation where the AQ queues used for the subscriber queue and exception queue have different payload types.
Action: Specify an exception queue that has the same payload type as the subscriber queue.
ORA-32822: subscriber string is marked for removal
Cause: An administration operation was attempted for a subscriber which is marked for removal. If attempting to remove a subscriber, the Messaging Gateway agent is not running or is running but unable to remove the subscriber at this time.
Action: Do not issue propagation administration commands for a subscriber for which removal is pending. Wait for the subscriber to be removed by the agent or issue REMOVE_SUBSCRIBER with the FORCE option to force the subscriber to be removed.
ORA-32823: subscriber exists for queue string and destination string
Cause: An attempt was made to create a propagation subscriber when one already exists for the specified queue and destination pair.
Action: Specify a different queue and destination pair, or remove the subscriber using that pair and retry the operation.
ORA-32824: schedule exists for source string and destination string
Cause: An attempt was made to create a propagation schedule when one already exists for the specified source and destination pair.
Action: Specify a different source and destination pair, or remove the schedule using that pair and retry the operation.
ORA-32825: Messaging Gateway agent has not been started
Cause: An attempt was made to shut down the Messaging Gateway agent when it is not started.
Action: No action required.
ORA-32826: Messaging Gateway agent has already been started
Cause: An attempt was made to start the Messaging Gateway agent when it is already started.
Action: No action required.
ORA-32827: Messaging Gateway agent must be shut down
Cause: An operation was attempted that requires the Messaging Gateway agent to be shut down.
Action: Issue SHUTDOWN, wait for MGW_GATEWAY view to show a NOT_STARTED status, and retry the operation. CLEANUP_GATEWAY may need to be issued to reset the gateway state if the agent fails to shut down after a reasonable time period.
ORA-32828: Messaging Gateway agent must be running
Cause: An operation was attempted that requires the Messaging Gateway agent to be started and responsive.
Action: Issue STARTUP, wait for MGW_GATEWAY view to show a RUNNING status, and retry the operation.
ORA-32829: Messaging Gateway agent cannot be shut down while it is starting
Cause: An attempt was made to shut down the Messaging Gateway agent when it is in the process of starting and initializing.
Action: Wait for MGW_GATEWAY view to show a RUNNING status and retry the operation. CLEANUP_GATEWAY may need to be issued to reset the gateway state if the agent fails to start after a reasonable time period.
ORA-32830: result code string returned by Messaging Gateway agent
Cause: The Messaging Gateway agent terminated abnormally due to an unexpected error.
Action: Review the Messaging Gateway log file for further information regarding the problem. Resolve the problem and start the Messaging Gateway agent. Contact Oracle Support Services if the problem cannot be resolved.
ORA-32831: timed out trying to acquire administration lock
Cause: A timeout occurred when attempting an administration operation. Either an administration operation was attempted while the Messaging Gateway agent was starting and initializing, or two administration operations were attempted at the same time.
Action: Retry the operation. If the Messaging Gateway agent is starting, wait for MGW_GATEWAY view to show a RUNNING status and retry the operation.
ORA-32832: failure string trying to acquire administration lock
Cause: An unexpected error occurred trying to acquire administration lock.
Action: Retry the operation. Contact Oracle Support Services if the error persists.
ORA-32833: failure string trying to release administration lock
Cause: An unexpected error occurred trying to release administration lock.
Action: Contact Oracle Support Services if the error persists.
ORA-32834: Messaging Gateway agent user has not been set
Cause: A Messaging Gateway agent user has not been configured.
Action: Create a database user having role MGW_AGENT_ROLE and issue DB_CONNECT_INFO to configure an agent user.
ORA-32835: database user string does not exist
Cause: The specified database user does not currently exist.
Action: Create the user and grant all necessary privileges and roles.
ORA-32836: database user string must be granted role string
Cause: The specified database user does not have a required role.
Action: Grant the user the indicated role.
ORA-32837: invalid configuration state string
Cause: The specified configuration state is invalid.
Action: Remove and re-create the configured entities. Contact Oracle Support Services if the problem cannot be identified or resolved.
ORA-32838: exceeded maximum number of properties
Cause: An attempt was made to alter a property list where the number of properties in the resulting list exceeds the maximum allowed.
Action: Order the elements of the alter list differently so the number of elements in the resulting list is less than the maximum.
ORA-32839: property string is reserved, names with MGWPROP$_ prefix are not valid
Cause: An attempt was made to specify a reserved name for a property name.
Action: Use a non-reserved name.
ORA-32840: property name cannot be NULL
Cause: An attempt was made to use NULL for a property name.
Action: Specify a non-NULL name.
ORA-32841: invalid value for property string
Cause: An attempt was made to specify an invalid value for a property.
Action: Specify a valid property value.
ORA-32842: value for property string cannot be altered
Cause: An attempt was made to alter a property that cannot be altered.
Action: Retry the operation without altering the indicated property.
ORA-32843: value for string is outside the valid range of string to string
Cause: A value was specified that is not in the valid range.
Action: Specify a value within the indicated range.
ORA-32844: exceeded maximum number of string values
Cause: An attempt was made to add a value of the specified type but the maximum number of such values has been reached.
Action: No action required.
ORA-32845: Messaging Gateway agent is already running
Cause: An attempt was made to start the Messaging Gateway agent when an agent instance is already running.
Action: Shut down the Messaging Gateway agent currently running, verify the agent process has been terminated, and start the Messaging Gateway agent.
ORA-32846: Messaging Gateway agent cannot be started; status is string
Cause: An attempt to start the Messaging Gateway agent failed due to the indicated agent status. A BROKEN status indicates a problem that requires user intervention before the agent can be started.
Action: Review the MGW_GATEWAY view and the Messaging Gateway log file for further information. Resolve the problem and start the Messaging Gateway agent. Contact Oracle Support Services if the problem cannot be resolved.


18 ORA-33000 to ORA-37134

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

18 ORA-33000 to ORA-37134

ORA-33000: (AGOPEN00) AGGMAP workspace object cannot be accessed because it was compiled by a more recent version of string.
Cause: The AGGMAP was already compiled by a more recent version of the product than was being used to execute this command.
Action: Recompile the AGGMAP in the current version.
ORA-33002: (XSAGDNGL00) In AGGMAP workspace object, the FLOOR argument of number must be less than the CEILING argument of number.
Cause: The user specified a floor argument greater than the ceiling argument.
Action: Adjust the floor and ceiling arguments so that the floor is less than the ceiling. OBSOLETE, please remove this
ORA-33003: (XSAGDIMDROP) workspace object, to be transformed during data load, must be a base dimension and not otherwise referenced in the AGGMAP.
Cause: The user tried to specify a dimension in a dataflow-related clause in an aggmap which is already in another RELATION statement, DIMENSION statement, or possibly dimensioning the AGGMAP, or they specified a composite or conjoint dimension, or an object which is not a dimension
Action: Remove the conflicting reference or specify a valid object
ORA-33004: (XSAGDNGL01) workspace object is not a relationship array.
Cause: A RELATION clause in the AGGMAP named a workspace object that is not a relation.
Action: Name a valid self-relation in the RELATION statement.
ORA-33005: (XSAGDIMBREAK) Invalid breakout for dimension workspace object.
Cause: The user specified something that was not a valid dimension or relation on a BREAKOUTDIM line in an aggmap. This might be because the object was not a valid relation, was not over the specified dimension or was multidimensional
Action: Use a valid relation instead
ORA-33006: (XSAGDNGL02) The relation workspace object is not related to itself.
Cause: A relation was named in a RELATION clause of the AGGMAP that is not a self-relation.
Action: Name a valid self-relation in the RELATION statement.
ORA-33008: (XSAGDNGL03) The relation workspace object is not a relation over a base dimension of AGGMAP workspace object.
Cause: A relation was named in a RELATION clause of the AGGMAP that is not a relation for a base dimension of the AGGMAP.
Action: Name a valid self-relation in the RELATION statement, that is, one that has a dimension that dimensions the AGGMAP.
ORA-33010: (XSAGDNGL04) Relation workspace object is duplicated in the AGGMAP workspace object.
Cause: Two RELATION statements in the AGGMAP reference the same relation object.
Action: Remove the duplicate RELATION statement.
ORA-33012: (XSAGDNGL05) AGGMAP workspace object contains invalid syntax.
Cause: A line in the AGGMAP contains invalid syntax.
Action: Change the line to have valid syntax.
ORA-33014: (XSAGDNGL06) In AGGMAP workspace object, variable operator workspace object cannot be dimensioned by rollup dimension workspace object.
Cause: Operator variables cannot have the rollup dimension as one of their base dimensions.
Action: Modify the definition of the operator variable so that the current rollup dimension is not one of its bases.
ORA-33016: (XSAGDNGL07) In AGGMAP workspace object, workspace object is not a valid operator or variable name.
Cause: An invalid argument was supplied to the OPERATOR clause in the relation statement.
Action: Fix the OPERATOR clause so that it specifies either a valid variable name or a valid operator.
ORA-33018: (XSAGDNGL08) In AGGMAP workspace object, the data type of workspace object must be TEXT, not string.
Cause: An operator variable was supplied whose data type is not TEXT.
Action: Change the operator clause to reference a TEXT variable.
ORA-33020: (XSAGDNGL09) In AGGMAP workspace object, the MIN argument of number must be less than the MAX argument of number.
Cause: The min argument was greater than the max argument.
Action: Adjust the max and max arguments so that min is less than max. OBSOLETE, please remove this
ORA-33022: (XSAGDNGL10) The measure dimension workspace object must be a TEXT or ID base dimension that does not dimension AGGMAP workspace object, but is in the same analytic workspace.
Cause: A MEASUREDIM was supplied in the AGGMAP that was not acceptable.
Action: Modify the MEASUREDIM clause to specify a valid dimension.
ORA-33024: (XSAGDNGL11) AGGMAP workspace object contains duplicate information.
Cause: The aggmap contains multiple instances of a clause that can only be specified once.
Action: Remove the extra clause.
ORA-33030: (XSAGDNGL14) In AGGMAP workspace object, you can have either a single independent PROTECT statement or PROTECT statements in your RELATION statements.
Cause: The AGGMAP either specified multiple PROTECT statements not on a RELATION line, or specified PROTECT statements both independently and on RELATION lines.
Action: Correct the AGGMAP to have valid syntax.
ORA-33036: (XSAGDNGL17) ARGS option workspace object must be a TEXT variable.
Cause: An ARGS value had a non-text data type.
Action: Use a text variable for ARGS.
ORA-33046: (XSAGDNGL22) In AGGMAP workspace object, you can specify only one SCREENBY clause.
Cause: The AGGMAP contained multiple SCREENBY clauses.
Action: Remove one of the SCREENBY clauses from the AGGMAP.
ORA-33048: (XSAGDNGL23) In AGGMAP workspace object, the relation workspace object and the relation workspace object are both over the same base dimension.
Cause: The AGGMAP contains incompatible RELATION statements.
Action: Remove one of the RELATION statements from the AGGMAP.
ORA-33050: (XSAGDNGL24) AGGMAP workspace object cannot be used to aggregate workspace object, because it is defined in a different analytic workspace.
Cause: The user attempted to aggregate a variable in another analytic workspace.
Action: Create an AGGMAP in the other analytic workspace to aggregate that variable.
ORA-33052: (XSAGDNGL25) AGGMAP workspace object is a dimensioned AGGMAP; it can only be used to aggregate like-dimensioned variables.
Cause: The user attempted to aggregate a variable with different dimensions than the AGGMAP. This is only possible with undimensioned AGGMAPs.
Action: Create a new undimensioned AGGMAP.
ORA-33054: (XSAGDNGL26) In AGGMAP workspace object, a MIN argument of number must be less than a FLOOR argument of number.
Cause: The user specified a MIN argument that was greater than or equal to the FLOOR argument.
Action: Reduce the MIN argument. OBSOLETE, please remove this
ORA-33056: (XSAGDNGL27) In AGGMAP workspace object, the MAX argument of number must be greater than the CEILING argument of number.
Cause: The user specified a MAX argument that was less than or equal to the CEILING argument.
Action: Increase the MAX argument. OBSOLETE, please remove this
ORA-33058: (XSAGDNGL28) In AGGMAP workspace object, error code string is greater than the maximum error code of number.
Cause: The user specified an invalid ERRORMASK value.
Action: Remove the invalid value from the ERRORMASK list.
ORA-33060: (XSAGDNGL29) In AGGMAP workspace object, the value for the ERRORLOG MAX option must be greater than 0.
Cause: The user specified an ERRORLOG MAX of 0 or a negative number.
Action: Adjust the AGGMAP so that it uses a positive number.
ORA-33064: (XSAGDNGL31) In AGGMAP workspace object, the hierarchy dimension QDR workspace object cannot refer to the related dimension of the relation.
Cause: The user specified an invalid hierarchy dimension qualified data reference.
Action: Adjust the AGGMAP so that it uses a valid dimension value qualified data reference.
ORA-33066: (XSAGDNGL32) In AGGMAP workspace object, the hierarchy dimension QDR workspace object must be a hierarchy dimension of the relation.
Cause: The user specified an invalid qualified data reference for the hierarchy dimension.
Action: Adjust the AGGMAP so that it uses a valid dimension value qualified data reference.
ORA-33068: (XSAGDNGL33) In AGGMAP workspace object, the hierarchy dimension QDR over dimension workspace object must specify a positive dimension offset.
Cause: The user specified an invalid qualified data reference for the hierarchy dimension.
Action: Adjust the AGGMAP so that it uses a valid dimension value qualified data reference.
ORA-33070: (XSAGDNGL34) In AGGMAP workspace object, all QDRs of dimension workspace object must map to the same dimension position.
Cause: The user specified two conflicting hierarchy dimension qualified data references.
Action: Adjust the AGGMAP so that it uses a consistent qualified data reference.
ORA-33072: (XSAGDNGL35) In AGGMAP workspace object, the hierarchy dimension QDR over dimension workspace object must be specified for every relation dimensioned by that hierarchy dimension.
Cause: Multiple dimensions share the same hierarchy dimension, but it is only qualified within a subset of the AGGMAP relations.
Action: Adjust the AGGMAP so that it uses consistent qualified data references.
ORA-33074: (XSAGDNGL36) In AGGMAP workspace object, the offset number is not a valid offset into dimension workspace object.
Cause: The hierarchy dimension offset is an invalid dimension position.
Action: Adjust the AGGMAP so that it uses valid qualified data references.
ORA-33076: (XSAGDNGL37) In AGGMAP workspace object, the value 'number' is not a valid value of dimension workspace object.
Cause: The hierarchy dimension offset is an invalid dimension position.
Action: Adjust the AGGMAP so that it uses valid qualified data references.
ORA-33078: (XSAGDNGL39) In AGGMAP workspace object, the hierarchy dimension QDR workspace object must refer to a dimension.
Cause: The user specified an invalid qualified data reference for the hierarchy dimension.
Action: Adjust the AGGMAP so that it uses a valid dimension value qualified data reference.
ORA-33080: (XSAGDNGL40) In AGGMAP workspace object, you cannot reference dimension workspace object with both a RELATION statement and a DIMENSION statement.
Cause: The user included both RELATION and DIMENSION statements in the AGGMAP referring to the same AGGMAP.
Action: Remove one of the conflicting clauses.
ORA-33082: (XSAGDNGL41) In AGGMAP workspace object, the non-dimensioned valueset workspace object must have a parent QDR in its VALUESET statement over the VALUESET's base dimension.
Cause: The VALUESET statement specified a scalar valueset but did not include a qualified data reference to specify the parent.
Action: Add a qualified data reference specifying the parent to the VALUESET statement.
ORA-33084: (XSAGDNGL42) In AGGMAP workspace object, you cannot qualify the dimensioned valueset workspace object.
Cause: The VALUESET line referred to a dimensioned valueset.
Action: Use a non-dimensioned valueset to limit the status of the dimensioned one.
ORA-33086: (XSAGINIT01) AGGMAP workspace object cannot be dimensioned by a conjoint dimension.
Cause: The specified AGGMAP was dimensioned by a conjoint dimension.
Action: Use the CHGDFN command to change the conjoint to a composite dimension.
ORA-33092: (XSAGCOMP04) number is not the name of a MODEL in any attached analytic workspace.
Cause: An invalid model name was attached to an AGGMAP.
Action: Remove the model from the AGGMAP or create a model with that name.
ORA-33094: (XSAGGMAPLIST01) Your expression uses too much execution space. Eliminate recursion or reduce the levels of nesting.
Cause: formulas likely refer to each other recursively or with a great deal of depth.
Action: eliminate recursion and flatten formula trees.
ORA-33098: (APABBR01) A value of 'string' is not valid for the workspace object option.
Cause: An inappropriate value was specified for the named option.
Action: Set a legal value for the option.
ORA-33100: (APABBR02) Value 'number' is not valid for the workspace object option.
Cause: An inappropriate value was specified for the named option.
Action: Set a legal value for the option.
ORA-33213: (CINSERT06) The target position for MAINTAIN ADD or MAINTAIN MOVE cannot fall in the range of session-only values.
Cause: The user specified a BEFORE or AFTER clause specifying a position in the range of SESSION dimension values.
Action: Do not use a position clause, or specify a position before the first SESSION value.
ORA-33214: (CINSERT02) The workspace object dimension is too large.
Cause: The dimension has too many values.
Action: Deleted values can still take up space in the dimension and cause this error. Try removing the deleted values by exporting the dimension to EIF and reimporting it with the REPLACE DELETE option.
ORA-33215: (CINSERT07) You cannot add session-only values to the workspace object dimension.
Cause: The user tried to add a SESSION dimension value while a spreadsheet spreadsheet cursor was open.
Action: Try adding the SESSION value while the cursor is not active.
ORA-33217: (CINSERT20) Custom member values cannot be added to concat dimension workspace object, or to any of its bases, because it is not defined as UNIQUE.
Cause: Only UNIQUE concat dimensions can have custom member values.
Action: Use the CHGDFN command to change the concat dimension to UNIQUE and retry.
ORA-33218: (CINSERT04) %K is not a valid value for the workspace object dimension. Values for this dimension can have at most number significant digits after rounding to number decimal places.
Cause: The user attempted to insert a value that had too many digits into a NUMBER dimension. For instance, the user might have tried to insert the value 99999 (5 digits) into a dimension with data type NUMBER(4).
Action: Use a smaller number for the dimension value, or define a new dimension with a larger precision and replace the old dimension with the new one.
ORA-33219: (CINSERT05) %K cannot be added to workspace object because it is already a value of the dependent UNIQUE concat dimension workspace object, from leaf dimension workspace object.
Cause: A value cannot be added to a dimension if it conflicts with an existing value in a unique concat dimension containing this dimension.
Action: The concat(s) causing the conflict could be CHGDFNed to NOT UNIQUE, or either of the duplicate values could be renamed to make them UNIQUE.
ORA-33223: (CMOVE03) You cannot move a session-only dimension value.
Cause: The user named a SESSION dimension value in the MAINTAIN MOVE command.
Action: Do not try to MAINTAIN MOVE session-only dimension values.
ORA-33247: (CRENAME03) %K is already a value of the dependent UNIQUE concat dimension workspace object, from leaf dimension workspace object.
Cause: A value cannot be renamed in a dimension if the new value conflicts with an existing value in a unique concat dimension containing this dimension.
Action: The concat(s) causing the conflict could be CHGDFNed to NOT UNIQUE, or either of the duplicate values could be changed to make them UNIQUE.
ORA-33261: (DBERRLEN) Analytic workspace string extension number truncated at number bytes while trying to read at number.
Cause: Either an internal error or a mistaken user has truncated the AW
Action: Export any data if possible and restore from backup
ORA-33262: (DBERR01) Analytic workspace string does not exist.
Cause: The analytic workspace requested does not seem to be in the current database
Action: Check that you are in the correct schema and have access to the requested AW.
ORA-33263: Could not create analytic workspace string
Cause: A serious error was encountered while trying to set up the tables for the named analytic workspace. Possibilities include a tablespace that can't be written to, corrupted metadata about which AWs exist, bogus tables with names the code expects to be able to use, or the remains of a partially removed AW.
Action: There should be another error on the error stack. Consult it to determine what is causing the problem and remove that table.
ORA-33265: (DBERRBSZ) Analytic workspace string cannot be opened. Tablespace blocksize number does not match database cache size number.
Cause: The blocksize of the containing tablspace didn't match database cache size.
Action: Change either size to make them consistent.
ORA-33267: (DBERRRLS) Analytic workspace string cannot be accessed because it has fine-grained access control applied to it
Cause: An attempt was made to access the specified analytic workspace's LOB table. The OLAP option detected the table had fine-grained security applied to it. The OLAP option requires full access to this table to operate correctly.
Action: Remove the fine-grained access control.
ORA-33270: (DBERR05) Analytic workspace string already exists.
Cause: The AW CREATE command was passed the name of an analytic workspace that already exists
Action: Specify a different name.
ORA-33278: (DBERR09) Analytic workspace string cannot be attached in RW or EXCLUSIVE mode until the changes made and updated in MULTI mode are committed or rolled back.
Cause: There are still changes to this analytic workspace that were updated and not committed when the workspace was attached in MULTI mode.
Action: Either try attaching the workspace is RO or MULTI mode or commit or roll back the transaction before trying to attach the workspace in RW or EXCLUSIVE mode.
ORA-33280: (DBERR10) Analytic workspace string cannot be attached in MULTI mode until the changes made and updated in RW or EXCLUSIVE mode are committed or rolled back.
Cause: There are still changes to this analytic workspace that were updated and not committed when the workspace was attached in RW or EXCLUSIVE mode.
Action: Either try attaching the workspace is RO, RW, or EXCLUSIVE mode or commit or roll back the transaction before trying to attach the workspace in MULTI mode.
ORA-33282: (DBERR11) Cannot wait for analytic workspace string to become available since doing so would cause a deadlock.
Cause: Trying to wait for the workspace to become available caused a deadlock.
Action: Release an analytic workspace that some other user might be waiting for before proceeding to attach this analytic workspace in this mode.
ORA-33284: (DBERR12) Analytic workspace string cannot be opened in MULTI mode before converting it by the latest version of string.
Cause: The AW is stored in 9i format.
Action: Convert the AW to a later format
ORA-33288: (DBERR15) Another user has incompatible access to analytic workspace string, and the wait timeout has expired.
Cause: An attempt to access an analytic workspace conflicted with another user's access, and the timeout specified has elapsed.
Action: Wait until the conflicting user is done.
ORA-33290: (DBERR17) Analytic workspace string cannot be attached in the mode you requested because another user has it attached in an incompatible mode.
Cause: An attempt to access an analytic workspace conflicted with another user's access, and no timeout was specified
Action: Wait unitl the conflicting user is done.
ORA-33300: (DBERR22) Analytic workspace string cannot be opened because it was last modified by an incompatible version of string.
Cause: The user attempted to attach an old OLAP Services analytic workspace that cannot be convered by this version of OLAP Services.
Action: Either create a new analytic workspace or try using a version of OLAP Services compatible with the one that created this analytic workspace.
ORA-33302: (DBVALID01) SEVERE ERROR: Record number multiply used.
Cause: The AW VALIDATE command has detected an error in the structure of the analytic workspace. This error will result in the corruption of one or more objects
Action: Export what you can of the analytic workspace.
ORA-33304: (DBVALID02) Note: Record number was allocated but not used. This can result in wasted space.
Cause: This is a benign message. The AW VALIDATE command found an analytic workspace has some inaccessible space.
Action: Either nothing, or export and recreate the analytic workspace
ORA-33306: (DBVALID03) The AW VALIDATE command cannot be used with read-only analytic workspace string.
Cause: The AW VALIDATE command does not support read-only access.
Action: Attach the analytic workspace read/write and try again.
ORA-33308: (DBVALID04) SEVERE ERROR: Record number used but not allocated
Cause: The AW VALIDATE command has detected a problem that will result in corruption of the analytic workspace. There is no corruption yet.
Action: Export and recreate the analyitic workspace.
ORA-33313: (DELDENT05) workspace object cannot be deleted because it is the target of an external partition of a partitioned variable.
Cause: User attempted to delete a variable, but some partitioned variable was defined to use that variable as the target of one of its external partitions.
Action: DELETE the partitioned variable or CHGDFN DROP PARTITION the the external partition from the partitioned variable, then delete the target variable.
ORA-33332: (DSSEXIST01) Use the AW command to establish a current analytic workspace. Then start your current activity again.
Cause: There is no currently active analytic workspace. The command that generated the error requires an active analytic workspace to operate on.
Action: Execute an AW ATTACH or AW CREATE command to establish an active workspace.
ORA-33334: (DSSEXIST04) Analytic workspace string is not attached.
Cause: The specified analytic workspace is currently not attached to the session, or the name is misspelled.
Action: Attach the analytic workspace with the AW ATTACH command, or correct the spelling of the name .
ORA-33336: (DSSEXIST04A) Analytic workspace string is not attached.
Cause: The specified analytic workspace is currently not attached to the session, or the name is misspelled.
Action: Attach the analytic workspace with the AW ATTACH command, or correct the spelling of the name .
ORA-33338: (DSSEXIST05) You cannot specify the EXPTEMP analytic workspace.
Cause: The command requires a non-temporary analytic workspace to operate on.
Action: Specify an analytic workspace other than EXPTEMP.
ORA-33425: (EIFMAKEF15) CAUTION: Exporting NTEXT objects using string for the EIF file character set can cause loss of data. To preserve all NTEXT data, export using the UTF8 character set for the EIF file.
Cause: The user exported an object with data type NTEXT, but the EIF file that will result from the EXPORT command is not written in Unicode. Because no non-Unicode file can represent all possible Unicode data, it is possible that some data will be lost when converting from the Unicode NTEXT object to the EIF file. The EIF file will be written in the character set indicated by the "nls_charset" argument of the EXPORT command, or, if no such argument is present, in the database character set.
Action: If the user is certain that the contents of the NTEXT object can be represented in the specified character set, then no action is necessary. Otherwise, the user can add "nls_charset 'UTF8'" to the EXPORT command string. This will result in the EIF file being written in UTF8 Unicode, which can represent all the data contained in NTEXT objects.
ORA-33427: (EIFMAKEF16) CAUTION: NTEXT object workspace object will be exported with type TEXT.
Cause: User attempted to export an object whose data type is NTEXT, but but the EIFVERSION option indicates a version of Express / Oracle OLAP that does not support the NTEXT data type. The object will be exported as a TEXT object instead.
Action: No action needed.
ORA-33429: (EIFMAKEF17) CAUTION: NTEXT expression will be exported with type TEXT.
Cause: User attempted to export an expression whose data type is NTEXT, but but the EIFVERSION option indicates a version of Express / Oracle OLAP that does not support the NTEXT data type. The expression will be exported as a TEXT object instead.
Action: No action needed.
ORA-33443: (ESDREAD14) Discarding compiled code for workspace object because analytic workspace string is not attached.
Cause: A program used an analytic workspace name in a qualified object name. The named analytic workspace is not attached at program run time.
Action: No action necessary. The program will be automatically recompiled. It is likely that the recompile will fail with an appropriate exception code, in which case the signaled condition should be corrected and the program re-run.
ORA-33445: (ESDREAD15) Discarding compiled code for workspace object because workspace object and workspace object, which were not partition-dependent when the code was compiled, are now partition-dependent.
Cause: Two variables are "partition-dependent" if they share any external partition target variables, or if one is the target of an external partition of the other. If object names referred to non-partition-dependent variables at compile time but refer to partition-dependent variables in the run-time context, the OLAP DML program, formula, or model will be automatically recompiled.
Action: None needed.
ORA-33447: (ESDREAD16) Discarding compiled code for workspace object because workspace object and workspace object, which were partition-dependent when the code was compiled, are now not partition-dependent.
Cause: Two variables are "partition-dependent" if they share any external partition target variables, or if one is the target of an external partition of the other. If object names referred to partition-dependent variables at compile time but refer to non-partition-dependent variables in the run-time context, the OLAP DML program, formula, or model will be automatically recompiled.
Action: None needed.
ORA-33448: (ESDREAD04) Discarding compiled code for workspace object because number now has string data, whereas it had string data when the code was compiled.
Cause: The datatype of the specified variable has changed.
Action: None needed.
ORA-33449: (ESDREAD17) Discarding compiled code for workspace object because the partition method or partition dimension of number has changed since it was compiled.
Cause: The partitioning method (LIST, RANGE, or CONCAT) or the partition dimension of the partition template is sufficiently different from what it was when the code was compiled that the code must be recompiled.
Action: None needed.
ORA-33450: (ESDREAD05) Discarding compiled code for workspace object because number now has more or fewer dimensions than it had when the code was compiled.
Cause: The dimensionality of the specified object has changed.
Action: None needed.
ORA-33452: (ESDREAD06) Discarding compiled code for workspace object because number is now dimensioned by workspace object. It was dimensioned by workspace object when the code was compiled.
Cause: The dimensionality of the specified object has changed.
Action: None needed.
ORA-33454: (ESDREAD07) Discarding compiled code for workspace object because number is now string workspace object, whereas it was string workspace object when the code was compiled.
Cause: The specified object has changed.
Action: None needed.
ORA-33456: (ESDREAD08) Discarding compiled code for workspace object because number is a(n) string, which string did not expect to find in a compiled program.
Cause: The type of the specified object has changed.
Action: None needed.
ORA-33458: (ESDREAD09) Discarding compiled code for workspace object because number is now type string, whereas it was type string when the code was compiled.
Cause: The type of the specified object has changed.
Action: None needed.
ORA-33460: (ESDREAD10) Discarding compiled code for workspace object because object workspace object is not in analytic workspace string.
Cause: The specified object is not in the same analytic workspace it was in when the compiled object was compiled.
Action: None needed.
ORA-33462: (ESDREAD10A) Discarding compiled code for workspace object because object number is not in analytic workspace string.
Cause: The specified object was not in the same analytic workspace it was when the compiled object was compiled
Action: None needed.
ORA-33468: (ESDREAD13) Discarding compiled code for workspace object because number is no longer a surrogate of dimension workspace object.
Cause: When the compiled code was saved, the specified object was a surrogate of a certain dimension. Now the specified object is a surrogate of a different dimension.
Action: No action needed; program automatically recompiles.
ORA-33625: (FRASSIGN02) You cannot use the APPEND keyword with concat dimension workspace object.
Cause: User used the APPEND keyword on a CONCAT target in a FILEREAD, SQL FETCH or SQL SELECT command.
Action: APPENDing a value to one of the CONCATs leaves automatically appends to the CONCAT.
ORA-33883: (MAKEDCL36) You cannot use the string attribute when you define an EXTERNAL partition with an existing target.
Cause: User gave the TEMPORARY keyword in the definition of an external partition whose target variable was previously defined.
Action: Any storage characteristics of the external partition are determined by the target variable. These attributes should be set when the target is defined, not when the external partition is defined.
ORA-33911: (MAKEDCL29) You cannot define a string in analytic workspace string because it has not been upgraded to version string.
Cause: User attempted to define an object that requires a certain compatibility setting in an AW that has not been upgraded to that compatibility level.
Action: Make sure that the database is running in the appropriate compatibility mode, and upgrade the AW.
ORA-33918: (MAKEDCL33) You cannot define a surrogate of dimension workspace object because it is a string.
Cause: Not all kinds of dimensions can have surrogates. The user attempted to define a surrogate of a prohibited kind of dimension.
Action: Do not attempt to define a surrogate on this dimension.
ORA-33920: (MAKEDCL34) The string SURROGATE must have one of the following data types: ID, NTEXT, TEXT, NUMBER, or INTEGER.
Cause: The user attempted to define a surrogate without specifying a valid data type.
Action: Specify the data type (ID, NTEXT, TEXT, NUMBER, or INTEGER) in the definition of the surrogate.
ORA-33922: (MAKEDCL35) You cannot define a surrogate of dimension workspace object because it is a time dimension.
Cause: The user attemped to define a surrogate on a dimension that has type DAY, WEEK, MONTH, or YEAR.
Action: Do not attempt to define a surrogate on this dimension.
ORA-33998: (MODCOMP12) You cannot use both workspace object and workspace object as model dimensions, because workspace object is a surrogate of workspace object.
Cause: The user attempted to include both a dimension and its surrogate in the DIMENSION statement of a model.
Action: Use either the dimension or the surrogate in the DIMENSION statement of the model, but not both.
ORA-34000: (MODCOMP13) You cannot use both workspace object and workspace object as model dimensions, because they are both surrogates of dimension workspace object.
Cause: The user attempted to include two dimension surrogates of the same dimension in the DIMENSION statement of a model.
Action: Use either of the two surrogates in the DIMENSION statement of the model, but not both.
ORA-34001: (MODCOMP14) Concat leaf dimension workspace object already is used in a DIMENSION statement, either explicitly or as a leaf of another concat dimension.
Cause: Either two concat dimensions which share a common leaf dimension, or a concat and one of its leaves where both specified in the DIMENSION statement(s).
Action: Do not specify overlapping concat dimensions, or any leaves of specified concat dimensions.
ORA-34019: (MSCGADD03) workspace object is not a LIST PARTITION TEMPLATE.
Cause: User attempted to MAINTAINT ADD or DELETE a list value from a RANGE or CONCAT partition template.
Action: Partitioning in a RANGE or CONCAT partition template cannot be changed using the MAINTAIN command.
ORA-34021: (MSCGADD04) You must specify a partition when maintaining PARTITION TEMPLATE workspace object.
Cause: User attempted to MAINTAINT ADD or DELETE a list value from a LIST parititon template, but didn't specify which partition to add to or delete from.
Action: Specify the partition: maintain (template) add to partition (partitionname) (values) or maintain (template) delete from partition (partitionname) (values)
ORA-34059: (MSEXECUT12) You cannot delete non session-only dimension values from unique concat dimension workspace object.
Cause: The user tried to apply MAINTAIN DELETE to a non-SESSION value.
Action: Only use MAINTAIN DELETE to remove SESSION values from a concat dimension.
ORA-34061: (MSEXECUT11) Session-only values cannot be added to non-unique concat dimension workspace object, or any of its base dimensions.
Cause: Only UNIQUE concat dimensions can have custom member values.
Action: Use the CHGDFN command to change the concat dimension to UNIQUE and retry.
ORA-34141: (MXCGPUT00) You cannot use the ASSIGN keyword with DIMENSION workspace object.
Cause: User used the ASSIGN keyword on a DIMENSION target in a FILEREAD, SQL FETCH or SQL SELECT command.
Action: To create a new dimension value in a FILEREAD, SQL FETCH or SQL SELECT command, use the APPEND keyword.
ORA-34143: (MXCGPUT02) You cannot assign values to SURROGATE workspace object because it is type INTEGER.
Cause: The user attempted to assign a value to a dimension surrogate whose data type is INTEGER. INTEGER surrogates, like INTEGER dimensions, cannot have values assigned to them. They can only be referenced by position.
Action: Do not attempt to assign values to an INTEGER surrogate. Values will automatically appear and disappear from the INTEGER surrogate as positions are added to or removed from the underlying dimension.
ORA-34145: (MXCGPUT03) You cannot use the APPEND keyword with SURROGATE workspace object.
Cause: User used the APPEND keyword on a SURROGATE target in a FILEREAD, SQL FETCH or SQL SELECT command.
Action: To assign a value to a SURROGATE in a FILEREAD, SQL FETCH or SQL SELECT command, use the ASSIGN keyword.
ORA-34164: (MXCGVAR01) A dimension used to define a local string variable cannot be located. Execution cannot continue.
Cause: A local relation or valueset has become invalid, most probably because an object used by the currently executing program has been deleted.
Action: This is an internal error that should be referred to Oracle technical support.
ORA-34177: (MXCHGDCL19) number cannot be deleted because one or more partitioned variables instantiate it.
Cause: User attempted to CHGDFN DELETE a partition template, but some partitioned variable had data in the partition specified for deletion.
Action: Drop the partitions that are causing the problem, then retry.
ORA-34179: (MXCHGDCL20) workspace object is not a PARTITION TEMPLATE.
Cause: User specified an object that is not a partition template where a partition template is required.
Action: Supply the name of a partition template.
ORA-34181: (MXCHGDCL21) workspace object is not a partitioned VARIABLE.
Cause: User specified an object that is not a partitioned variable in a place where a partitioned variable is required.
Action: Supply the name of a partitioned variable.
ORA-34183: (MXCHGDCL22) Partition number already exists.
Cause: User attempted to ADD a partition that already existed to a partitioned variable.
Action: None required - the partition already exists.
ORA-34210: (MXCHGDCL18) You cannot change workspace object to a dimension composite because one or more surrogates has been defined for it.
Cause: The user attempted to redefine a conjoint dimension as a composite, but the conjoint has one or more surrogates defined. A dimension that has surrogates cannot be redefined as a composite.
Action: Either delete all surrogates for the dimension, or do not attempt to redefine the dimension as a composite.
ORA-34243: (MXDCL11) You can only use the string keyword when defining a COMPOSITE.
Cause: User supplied the COMPRESSED keyword when defining an object that was not a COMPOSITE.
Action: If the intent is to create a compressed composite, make sure that the object type is COMPOSITE. Otherwise, remove the COMPRESSED keyword from the command string and rerun.
ORA-34260: (MXDCL25) You cannot use number to dimension a string because it is, or involves, a dimension composite. Use the composite's bases instead.
Cause: The user attempted to use a COMPOSITE in the dimension list of an object that does not allow for such dimensions.
Action: Use the base dimensions of the COMPOSITE in the dimension list.
ORA-34276: (MXDCL33) (Precision, Scale) arguments can only be used with a NUMBER variable or dimension.
Cause: The user attempted to use NUMBER(Precision) or NUMBER(Precision, Scale) as the dataype in a definition for some object other than a DIMENSION or VARIABLE, such as a FORMULA or PROGRAM. This error can also be produced in cases where a NUMBER data type is not allowed at all.
Action: Use the NUMBER type without specifying a precision or scale. If a NUMBER data type is not allowed at all, this fix will only change the exception message to something more specific.
ORA-34279: (MXDCL37) CONCAT can only be used when defining a DIMENSION.
Cause: The CONCAT keyword was used incorrectly.
Action: Retry the command without the CONCAT keyword.
ORA-34286: (MXDCL53) workspace object cannot be used in this context because it is a string.
Cause: User specified a dimension composite, conjoint, or partition template in a place where that kind of dimension is not allowed. For instance, a relation cannot be dimensioned by a composite, and only a variable can dimensioned by a partition template.
Action: Usually, the offending dimension can be replaced with its bases. For instance, a relation cannot be dimensioned by a a composite of PRODUCT and GEOG, but it can be dimensioned by both PRODUCT and GEOG instead.
ORA-34296: (MXDCL36) A NUMBER dimension must be defined with a fixed precision and scale, using the form NUMBER(precision) or NUMBER(precision, scale).
Cause: The user attempted to define a NUMBER dimension without specifying a precision. The proper format for declaring a number dimension is NUMBER(Precision) or NUMBER(Precision, Scale). NUMBER with no precision or scale is not allowed.
Action: Use NUMBER(Precision) or NUMBER(Precision, Scale) to specify the datatype of a NUMBER dimension.
ORA-34342: (MXDSS01) IMPORTANT: Analytic workspace string is read-only. Therefore, you will not be able to use the UPDATE command to save changes to it.
Cause: This is an informational message that reminds you that you may not save changes to the specified analytic workspace.
Action: None, unless it was desired to save changes to the analytic workspace. In that case, detach and reattach the analytic workspace read-write.
ORA-34344: (MXDSS03) Analytic workspace string is not attached.
Cause: The command attempted to operate on an analytic workspace that is not currently attached, or the name of the analytic workspace is misspelled.
Action: Attach the analytic workspace or correct the spelling.
ORA-34346: (MXDSS04) The string analytic workspace cannot be detached.
Cause: The specified analytic workspace is an internal workspace and may not be detached by the user.
Action: Specify a different analytic workspace to detach.
ORA-34348: (MXDSS05) string is used only for internal purposes and cannot be accessed as an analytic workspace.
Cause: The command attempted to operate on an internal analytic workspace used by the system.
Action: Specify a different analytic workspace.
ORA-34350: (MXDSS06) string is an open analytic workspace.
Cause: The specified analytic workspace is currently in use.
Action: The desired action requires an analytic workspace that is not currently in use.
ORA-34357: (MXDSS10) string is not an alias of analytic workspace string.
Cause: User attempted to use AW UNALIAS on a non-existent alias.
Action: Make sure that the command specified the correct analytic workspace and alias. The alias must have been assigned (using AW ALIAS) during the current session and must not have been removed by a previous AW UNALIAS or AW DETACH command.
ORA-34358: (MXDSS14) number other users reading
Cause: Used for AW LIST output formatting when %d > 1
Action: None
ORA-34359: (MXDSS11) string appears twice in the alias list.
Cause: User included the same name twice in the alias list of an AW ALIAS or AW UNALIAS command.
Action: Remove the duplicate name and try again.
ORA-34360: (MXDSS15) number other users writing
Cause: Used for AW LIST output formatting when %d > 1
Action: None
ORA-34361: (MXDSS12) number other user reading
Cause: Used for AW LIST output formatting when %d == 1
Action: None
ORA-34363: (MXDSS13) number other user writing
Cause: Used for AW LIST output formatting when %d == 1
Action: None
ORA-34481: (MXMAINT07) You cannot string values of PARTITION TEMPLATE workspace object.
Cause: User attempted to use the MAINTAIN command with some keyword other than ADD or DELETE on a partition template.
Action: It is not possible to MAINTAIN a partition template, except to add or delete values of a partition list.
ORA-34487: (MXMAINT08) You cannot string values of non-unique concat dimension workspace object.
Cause: The specified MAINTAIN operation can only be applied to UNQUE concats.
Action: Use the CHGDFN command to change the concat dimension to UNIQUE and retry.
ORA-34489: (MXMAINT06) You cannot maintain workspace object because it is a SURROGATE.
Cause: The user attempted to use the MAINTAIN command on a dimension surrogate. The MAINTAIN command can only be used with real dimensions, not surrogates.
Action: Use the MAINTAIN command to modify the underlying dimension of the surrogate instead.
ORA-34514: (MXOPERR) You cannot string string data in the expression that begins with 'string'.
Cause: The user attempted an invalid operation.
Action: none
ORA-34656: (MXSQL24) Additional WHERE clause conditions with CURRENT OF <cursor name> syntax
Cause: A SQL UPDATE or DELETE statement tried to use the CURRENT of <cursor name> syntax with a WHERE clause containing multiple conditions.
Action: When using the CURRENT OF <cursor name> syntax make sure it is the only condition in the WHERE clause.
ORA-34719: (NLSCHARSET03) Character data loss in NTEXT/TEXT conversion
Cause: When character set conversion happens between TEXT and NTEXT either implicitly or explicitly, some characters are lost due to no mapping characters in the destination character set.
Action: Make sure all the characters can be mapped to destination character set or set NLS_NCHAR_CONV_EXCP to be FALSE. Note: This message is the OLAP equivalent of ORA-12713.
ORA-34722: (NLSCHARSET05) CAUTION: Character data loss in character set conversion from string to string
Cause: Some operation required a string to be converted into a different character set, but the string contained characters that didn't exist in the new character set.
Action: Choose different character sets.
ORA-34726: (NLSCHARSET06) CAUTION: String truncated during character set conversion from string to string
Cause: Some operation required a string to be converted into a different character set. The string required more bytes in the new encoding, and exceeded some byte limit on its allowable length, causing some characters to be removed from the end of the string.
Action: If the byte limit is due to using the ID datatype, consider using the CHAR datatype instead. If the byte limit is due to the limit of 4000 bytes per line of CHAR data, break the long line up into multiple lines.
ORA-34802: (OCI11) OLAP OCI operation caused ROLLBACK past an UPDATE of an attached analytic workspace. Current operation canceled.
Cause: ROLLBACK past the UPDATE of one of the attached Analytic Workspaces was called. The current operation is aborted, and the Analytic Workspace detached.
Action: Change the called SQL procedure to avoid the ROLLBACK
ORA-34871: (PERMIT06) Session-only value 'value' of workspace object has been deleted because a PERMIT change has revealed a duplicate value.
Cause: Execution of a PERMIT command revealed a permanent dimension or surrogate value having the same name as the SESSION value.
Action: If the SESSION value is still needed, add it with a different name.
ORA-34896: (PPMONTHS00) At least 12 month names must be given. Only number were provided.
Cause: There must be at least one name for each month. Not enough names were provided.
Action: Provide at least 12 names.
ORA-34897: (PPMONTHS01) Blank lines are not allowed in the MONTHNAMES option.
Cause: There is at least one blank line in the string populating the MONTHNAMES option. We do not allow blank month names.
Action: Remove the blank line(s) from the string.
ORA-34900: (PPWKDAYS00) At least 7 day names must be given. Only number were provided.
Cause: There must be at least one name for each day. Not enough names were provided.
Action: Make sure there are at least 7 names in the string.
ORA-34901: (PPWKDAYS01) Blank lines are not allowed in the DAYNAMES option.
Cause: There is at least one blank line in the string populating the DAYNAMES option. We do not allow blank day names.
Action: Remove the blank line(s) from the string.
ORA-35062: (QFGET01) Duplicate files found for extension number number of EIF file string.
Cause: IMPORT searched the directories specified in EIFEXTENSIONPATH and found two EIF extension files with the same name (differing at most by the case used in the final name component.
Action: Delete, rename or move any files that are not to be read by IMPORT.
ORA-35066: (QFGET03) Extension number number is missing for EIF file string.
Cause: IMPORT searched the directories specified in EIFEXTENSIONPATH and could not find the appropriately numbered extension file.
Action: Move the missing file into one of the searched directories.
ORA-35071: (QFHEAD06) EIF file string cannot be imported because analytic workspace string has not been upgraded to version string.
Cause: User attempted to import from an EIF file that was created by a newer version of the product into an AW that was created by a older version of the product.
Action: Make sure that the compatibility mode parameter in the init.ora of the importing instance specifies a version that is at least as high as the parameter was in the exporting instance. Then, convert the AW to the latest storage format and reexecute the import command. Alternatively, change the EIFVERSION option of the exporting instance to a lower number, recreate the EIF file, and import the new file.
ORA-35074: (QFHEAD02) EIF file string cannot be read by this version of string.
Cause: The EIF file was created with an internal version number indicating it may contain objects that are not compatible with the current Oracle OLAP version, or the EIF file is in an obsolete format.
Action: If possible, set EIFVERSION in the exporting instance to a lower number, recreate the EIF file, and import the new file.
ORA-35076: (QFHEAD04) CAUTION: The textual data in EIF file string is encoded in a character set that is not recognized by this version of string.
Cause: IMPORT could not recognize the character set specification in the EIF file.
Action: Check the imported text data. If it was not imported correctly, recreate the EIF file with a character set supported by the current Oracle version.
ORA-35078: (QFHEAD05) An EIF extension file header for string is not in the correct format.
Cause: An EIF extension file in multi-file IMPORT did not contain correct header information.
Action: Check to be sure that EIFEXTENSIONPATH is set correctly and that all the extension files for the current IMPORT were created by the same EXPORT command as the main EIF file.
ORA-35095: (QFSVNS01) One or more imported values of fixed-width dimension workspace object have been truncated.
Cause: The data in the EIF file was exported from a dimension with wider values than the target dimension will accommodate.
Action: Change the definition of the target dimension, or check to be sure that multiple values from the target dimension havve not become identical during the import process. This could cause data loss as data from later dimension values overstores data imported earlier.
ORA-35180: (SNSYN103) The format of the OUTFILE command is: OUTFILE [APPEND] {EOF | TRACEFILE | filename [NOCACHE] [NLS_CHARSET name]}
Cause: The user specified incorrect syntax for the OUTFILE command.
Action: none
ORA-35276: (SNSYN163) The format of the ALLOCATE command is: ALLOCATE varname [SOURCE svarname] [BASIS bvarname [ACROSS dimname]] [TARGET tvarname [TARGETLOG logvarname]] [ USING aggmap ]
Cause: The user used incorrect syntax for the ALLOCATE command.
Action: Correct the calling syntax.
ORA-35280: (SNSYN165) The format of the AGGREGATE command is: AGGREGATE varname1 [varname2 varname3 ...] USING aggmap-name [COUNTVAR intvar-name1 [intvar-name2 intvar-name3 ...]] [FUNCDATA] [THREADS #]
Cause: The user used incorrect syntax for the AGGREGATE command.
Action: Correct the calling syntax.
ORA-35282: (SNSYN166) The format of the AGGREGATE function is: AGGREGATE(varname USING aggmap-name [COUNTVAR intvar-name] [FORCECALC])
Cause: The user used incorrect syntax for the AGGREGATE function.
Action: Correct the calling syntax.
ORA-35578: (SQLOUT11) SQL cursor 'number' cannot be used with CURRENT OF <cursor name> syntax
Cause: The CURRENT OF <cursor> syntax in the WHERE clause tried to use a cursor that was not declared with the FOR UPDATE [ of <column name> ] SQL syntax.
Action: Add the FOR UPDATE [ OF <column name> ] SQL syntax to the cursor specified.
ORA-35587: (SQLOUT20) The nesting of table functions and SQL commands has exceeded the maximum of number levels.
Cause: The nesting of table functions with the PREDMLCMD token populated with an OLAP DML expression that use the embedded SQL support to access another table function which contains a table functions with the PREDMLCMD token filled in with an OLAP DML expression that uses the embedded SQL support.
Action: Reduce the level of nesting between table functions and OLAP DML embedded SQL support.
ORA-35756: (VCTODT02) 'number' is not a valid date because number is out of range for a year.
Cause: n'%1p'
Action: none
ORA-35917: (XSHIDE05) You cannot HIDE model workspace object because the analytic workspace in which it is defined has not been upgraded to version string.
Cause: User attempted to apply the HIDE command to a model in an AW that has not been upgraded to the necessary compatibility level.
Action: Make sure that the database is running in the appropriate compatibility mode, and upgrade the AW.
ORA-36154: (XSMXAGGR01) workspace object is not a data variable.
Cause: An object was specified on the Aggregate command line that was not a variable
Action: Specify a variable instead
ORA-36155: (XSMXAGGRFROM) workspace object must be a variable or formula of a similar data type to workspace object to be used with FROM, or a TEXT variable or formula to be used with FROMVAR.
Cause: The user specified an illegal variable for use with FROM or FROMVAR on the AGGREGATE command line
Action: Specify a legal variable instead
ORA-36157: (XSMXAGGRCOMMIT) To use the AUTOCOMMIT keyword, you must also specify the AUTOUPDATE keyword.
Cause: The user specified AUTOCOMMIT but not AUTOUPDATE on the AGGREGATE command line, which is illegal
Action: Either also specify AUTOUPDATE or don't specify AUTOCOMMIT
ORA-36160: (XSMXAGGR04) You may not use AGGREGATE on scalar VARIABLE workspace object.
Cause: The user specified a scalar variable to use for AGGREGATE
Action: Specify a dimensioned variable instead
ORA-36178: (XSAGGR01) To be used with AGGREGATE, AGGMAP workspace object must be declared with the AGGMAP command.
Cause: The user used the ALLOCMAP command to define the AGGMAP, so the AGGMAP can only be used with the ALLOCATE command, or the AGGMAP has no contents attached to it.
Action: Use the AGGMAP command to define the AGGMAP.
ORA-36179: (XSNOAGM) No AGGMAP was specified for VARIABLE workspace object.
Cause: The user used the AGGREGATE command without specifying an AGGMAP on the command line, with a variable which had no $AGGMAP property.
Action: Specify an AGGMAP on the AGGREGATE command line, or add the $AGGMAP property to the variable in question.
ORA-36180: (XSAGGR08) AGGREGATE cannot function because there is a permission clause associated with variable workspace object.
Cause: When using AGGREGATE, only simple permissions and permissions on base dimensions are valid.
Action: Remove the permissions clause from the variable causing problems.
ORA-36182: (XSAGGR09) Could not locate a value for variable number in measure dimension workspace object.
Cause: A measure dimension was supplied in the AGGMAP, but a position for the variable was not found in it.
Action: Add a position for the variable in the measure dimension.
ORA-36184: (XSAGGR10) You do not have sufficient permissions for the variable workspace object.
Cause: The user lacked the permissions necessary for the aggregation variable.
Action: Remove the restricting permissions from the variable or base dimension.
ORA-36188: (XSAGGR16) AGGREGATE read a value less than 1 out of COUNTVAR variable workspace object. Either the values of the COUNTVAR variable are stored improperly, or there is problem in AGGREGATE. If no one has modified the values in this COUNTVAR, contact Oracle customer support.
Cause: Either someone improperly changed the COUNTVAR variable, or AGGREGATE has an error.
Action: Set the COUNTVAR variable to NA before starting AGGREGATE. If you previously set the COUNTVAR variable to NA, then contact Oracle OLAP technical support.
ORA-36198: (XSAGGR33) The AGGREGATE operator string does not require a weight, but ARGS variable workspace object specified %4p as a weight.
Cause: The ARGS variable specified a weight even though one is not needed.
Action: Modify the ARGS variable so that it does not specify a weight for that operation.
ORA-36200: (XSAGGR34) AGGREGATE operator string requires a WEIGHTBY clause, but ARGS variable workspace object did not specify one.
Cause: The given operator requires a WEIGHT specification, but the ARGS variable did not supply one.
Action: Modify the ARGS variable to specify a weight for the operation.
ORA-36202: (XSAGOP01) 'number' is not a valid aggregation operator.
Cause: An invalid string was provided for an aggregation operator.
Action: Check the spelling of the operator to make sure you are specifying a valid one.
ORA-36204: (XSAGOP04N) In AGGMAP workspace object, the NAOPERATOR string must be HFIRST, HLAST or HEVEN.
Cause: An invalid NAOPERATOR was specified.
Action: Specify HFIRST, HLAST or HEVEN.
ORA-36206: (XSAGOP04R) In AGGMAP workspace object, REMOPERATOR string must be MIN, MAX, FIRST, LAST, HFIRST or HLAST.
Cause: An invalid REMOPERATOR was specified.
Action: Specify one of the legal operators.
ORA-36208: (XSAGOP05N) In AGGMAP workspace object, you can only specify NAOPERATOR string with the PROPORTIONAL or EVEN operators, not string.
Cause: The user specified an NAOPERATOR when you were not using PROPORTIONAL or EVEN.
Action: Remove the NAOPERATOR clause from the RELATION line.
ORA-36210: (XSAGOP05R) In AGGMAP workspace object, you can only specify the REMOPERATOR string with the PROPORTIONAL, EVEN, or HEVEN operators, not string.
Cause: The user specified a REMOPERATOR without using PROPORTIONAL, EVEN, or HEVEN.
Action: Remove the REMOPERATOR clause from the RELATION line.
ORA-36212: (XSAGOP06) In AGGMAP workspace object, you can only specify the MIN, MAX, FLOOR, and CEILING arguments while using the PROPORTIONAL operator, not string.
Cause: The user specified MIN, MAX, FLOOR, or CEILING when using an operator other than PROPORTIONAL.
Action: Remove the incorrect argument from the RELATION line.
ORA-36258: (XSAGINFO00) When the AGGMAPINFO function is called, workspace object must be an AGGMAP.
Cause: The AGGMAPINFO function was called with an object that is not an AGGMAP.
Action: Modify the call to AGGMAPINFO to specify an AGGMAP object.
ORA-36260: (XSAGHIERPART00) Aggregating from partition %J to partition %J over hierarchy workspace object creates an increase in sparsity.
Cause: In the partition creation / aggmap creation a situation developed such that when aggregating over a particular dimension of the aggmap a partition boundery was crossed such that the sparsity of the target partition included dimensions that were not in the sparisty of the source partition. Since the process of aggregation always densifies rather than sparsifying this is an extremely suboptimal design and it is not supported by the aggregate system.
Action: Set up your partitioning such that for any partition boundary the source and target partitions of the aggregation will always move towards denser partitions. For any child (c) and any parent (p) where (c) and (p) are in different partitions it must be the case that the parent partition contains no dimension in the composite that the child partition does not contain in it's composite.
ORA-36261: (XSAGPARTDEP00) Can not Aggregate PARTITION TEMPLATE %J because the path of aggregation would recursively enter partition %J.
Cause: The partitioning scheme was such that while aggregating there exists a cell (m) such that both one of it's descendents and one of it's ancestors are both in the referenced partition, whil (m) is in a different partition.
Action: Change the partitioning scheme.
ORA-36266: (XSCGMDLAGG00) Invalid context for the AGGREGATION function
Cause: Aggregation function is not used in model
Action: Use aggregation function only in model
ORA-36268: (XSCGMDLAGG01) 'string' is not a valid dimension value.
Cause: Not a valid dimension value
Action: Use the valid dimension value
ORA-36270: (XSCGMDLAGG03) The right-hand side of the AGGREGATION function includes duplicate values.
Cause: Use the duplicate values
Action: Use the distinct values
ORA-36272: (XSCGMDLAGG04) 'workspace object' is not a valid operator for the AGGREGATION function.
Cause: Use an invalid operator
Action: Use the valid operator
ORA-36274: (XSCGMDLAGG05) The operator used in this equation needs a weight variable.
Cause: No a valid weight variable
Action: Use the valid weight variable
ORA-36276: (XSCGMDLAGG06) Current operator does not need the weight variable.
Cause: Use the weight variable in wrong context
Action: Remove the weight variable
ORA-36278: (XSCGMDLAGG07) workspace object is not a valid valueset.
Cause: Use an invalid object name or a non-valueset object
Action: Use the valueset object
ORA-36280: (XSCGMDLAGG08) The dimension of valueset workspace object is not in the dimension list of the current compiling model.
Cause: Use the wrong valueset
Action: Use the valueset which limits over the dimension of model.
ORA-36290: (EIFMAKEF14) You cannot export object workspace object, because EIFVERSION is set to number. That version does not support dimensions of type NUMBER.
Cause: The user tried to export a NUMBER dimension to an EIF file with the EIFVERSION option set to a number less than 80000. Versions previous to that eversion do not support NUMBER dimensions.
Action: A NUMBER dimension cannot be used in a version of older than 9.2.0. If the EXPORT file is going to be read by version 9.2.0 or higher, set EIFVERSION to a number greater than or equal to 80000 and execute the EXPORT command again.
ORA-36312: (PHYS00) workspace object must be a dimension or dimensioned variable.
Cause: The user specified an invalid OLAP object while attempting to use the PHYSICAL function
Action: Specify a valid object
ORA-36314: (PHYS01) workspace object must be a dimension, relation or variable.
Cause: The user specified an invalid OLAP object while attempting to use the PHYSICAL command
Action: Specify a valid object
ORA-36316: (PHYS02) Relation workspace object must be a single-dimensional relation that relates one INTEGER dimension to another.
Cause: The user specified an invalid relation while attempting to use the PHYSICAL command
Action: Specify a valid relation
ORA-36341: (SNSYN130) The format of the PARTITIONCHECK function is: PARTITIONCHECK(aggmap, partition_template)
Cause: Bad syntax
Action: Correct syntax
ORA-36342: (SNSYN200) The format of the CLEAR command is: CLEAR [ ALL | STATUS ] [ CHANGES | PRECOMPUTES | NONPRECOMPUTES | CACHE ] FROM var1 [var2, var3...] [USING aggmap]
Cause: The syntax for the CLEAR command was invalid.
Action: Modify your syntax using the correct format.
ORA-36376: (XSAGZERO) AGGREGATE attempted to divide by zero. Set DIVIDEBYZERO to YES if you want NA to be returned as the result of a division by zero.
Cause: A calculation in the current AGGREGATE command attempted to divide by zero as a result of an AVERAGE, WAVERAGE, HAVERAGE or HWAVERAGE operation.
Action: Either fix the data, or set DIVIDEBYZERO to YES to return NA instead of signalling an error.
ORA-36378: (XSAGTHRWEIGHT) While running AGGREGATE with multiple threads, the weight variable workspace object specified by your ARGS variable workspace object must exist in the same analytic workspace as your AGGMAP workspace object.
Cause: While running AGGREGATE in threaded mode, you attempted to specify a WEIGHT variable in another analytic workspace.
Action: Use a weight variable from the same analytic workspace as the aggmap and rollup variable.
ORA-36380: (AGGRECURSE) AGGREGATE was called recursively, which is not allowed.
Cause: A model, NATRIGGER, or other object called the AGGREGATE function or command while another AGGREGATE function or command was already in progress.
Action: Modify your objects so that they do not need to have two AGGREGATE commands or functions executing at once.
ORA-36389: (XSAGPARTDEP01) Can not aggregate from PARTITION number into PARTITION number due to increasing sparsity along DIMENSION %J.
Cause: The user is attempting to use partitions as a means of sparsity control, however they have set up their partitions in a manner that simply makes no sense. It is a simple fact that during aggregation data becomes more dense, not less dense, and yet thier partitions indicate the opposite.
Action: Modify the partition template add the specified dimension into the source composite, or removing it from the target composite.
ORA-36391: (XSMXCLEA01) When CLEAR is used with the STATUS keyword or an AGGMAP, workspace object must be dimensioned identically to workspace object.
Cause: The user specified objects whose dimensionality didn't match
Action: Break up the CLEAR command into multiple commands where the dimensionality of the objects matches
ORA-36392: (XSMXCLEA02) When using CLEAR with the PRECOMPUTES or NONPRECOMPUTES options, you must supply an AGGMAP.
Cause: The user didn't specify an AGGMAP with the CLEAR command
Action: Specify the AGGMAP used to aggregate the variable being cleared
ORA-36393: (XSMXCLEA03) When using the CHANGES or CACHE options, you must specify the ALL keyword.
Cause: The user didn't use the ALL keyword when using CHANGES or CACHE
Action: Specify the ALL keyword
ORA-36394: (XSMXCLEA04) When using CLEAR on the AGGMAP workspace object, CACHE is the only valid directive.
Cause: The user attempted to CLEAR an AGGMAP using a directive other than CACHE
Action: Amend the CLEAR line to only use the CACHE keyword with AGGMAPs.
ORA-36398: (XSSPROP01) Property name 'number' is invalid because only system-reserved property names can begin with "$".
Cause: The user attempted to add a property which starts with $ but is not a reserved property name
Action: Remove the $ from the property name
ORA-36400: (XSSPROP02) workspace object is not a valid variable name.
Cause: Not a valid variable name
Action: Change to a valid variable name
ORA-36402: (XSSPROP03) The property '$string' requires a leading "$" because it is a system-reserved property name.
Cause: The user tried to specify a property name which is reserved, but did not use a leading $
Action: Either add a leading $ or choose another property name
ORA-36403: (XSBADSPROP) number is an illegal value for system-reserved property string on workspace object.
Cause: The user tried to specify an illegal value for a special property
Action: Specify a legal value.
ORA-36608: (XSAGHOVERFLOW) The depth of the hierarchies encountered while processing a composite dimension in AGGREGATE caused a counter overflow.
Cause: The depth of the hierarchies that are part of a composite exceeded 4 billion levels during the merge.
Action: Reduce the number of levels in the hierarchies, reduce the number of dimensions in the composite, or do not aggregate over all dimensions at once.
ORA-36610: (XSLMS00) Unable to locate a message file for product 'value' and facility 'value'.
Cause: An application called the INTL.MESG function with an incorrect or uninstalled product / facility combination.
Action: Make sure that the appropriate binary message file is stored on the host in the correct location: $ORACLE_HOME/product/facilitylanguage.msb.
ORA-36612: (XSLMS01) An application attempted to retrieve a non-existent user message. (Product: value, Facility: value, Message Number: value)
Cause: The caller of INTL.MESG tried to retrieve a non-existent message.
Action: Add the message to the application's message file, and recompile or reinstall the binary message file.
ORA-36614: (XSLMS02) string attempted to retrieve a nonexistent user message. (Message number number)
Cause: An internal Oracle OLAP error. Oracle OLAP attempted to retrieve a message that does not exist in the installed message file $OLAP_HOME/aps*.msb.
Action: Ignore this error message.
ORA-36628: (XSAGMODLIST03) MODEL workspace object could not be added to AGGMAP workspace object.
Cause: The dimension of the model must match a hierarchy of the aggmap.
Action: Add a RELATION statement to the AGGMAP for that dimension.
ORA-36630: (XSDUNION00) An empty base dimension list was specified in the concat dimension definition.
Cause: An empty concat dimension list was specified.
Action: Specify a valid list of dimensions when defining a concat dimension.
ORA-36632: (XSDUNION01) The concat dimension workspace object is not currently defined as UNIQUE.
Cause: Attempt was made to CHGDFN a concat, which is already non-unique, to NOT UNIQUE.
Action: Since the concat is already non-unique, this command is unnecessary.
ORA-36634: (XSDUNION02) INTEGER dimension workspace object cannot be used as a concat dimension base.
Cause: The user cannot specify INTEGER base dimensions when defining a concat dimension.
Action: Change the datatype of the INTEGER base dimension, or omit it from the concat.
ORA-36635: (XSDUNION03) The base dimension workspace object has an invalid datatype for use in a UNIQUE concat definition.
Cause: Base dimensions of a unique concat must have TEXT or ID datatypes.
Action: Specify a valid list of dimensions when defining a unique concat dimension.
ORA-36636: (XSDUNION04) The unique concat dimension workspace object cannot be changed to NOT UNIQUE, because it is a base of at least one other unique concat dimension.
Cause: A non-unique concat dimension cannot be used as a base of a dependent unique concat.
Action: CHGDFN any dependent unique concat dimensions to NOT UNIQUE and retry.
ORA-36637: (XSDUNION05) The concat dimension cannot be defined as UNIQUE because it has a non-unique concat base dimension workspace object.
Cause: A non-unique concat dimension cannot be used as a base of a dependent unique concat.
Action: CHGDFN any non-unique concat base dimensions to UNIQUE and retry.
ORA-36638: (XSDUNION17) Concat dimension workspace object cannot be changed to UNIQUE because it has a non-unique concat base dimension workspace object.
Cause: A non-unique concat dimension cannot be used as a base of a dependent unique concat.
Action: CHGDFN any non-unique concat base dimensions to UNIQUE and retry.
ORA-36639: (XSDUNION18) UNIQUE cannot be applied to this concat dimension because leaves workspace object and workspace object share the value number.
Cause: Unique concat base dimensions cannot contain duplicate values.
Action: Use MAINTAIN RENAME to change one of the duplicate values and retry.
ORA-36640: (XSDUNION19) Concat dimension workspace object cannot be changed to UNIQUE because base dimension workspace object does not have a TEXT or ID datatype.
Cause: Base dimensions of a unique concat must have TEXT or ID datatypes.
Action: none
ORA-36641: (XSDUNION20) The concat dimension must be defined as UNIQUE because base dimension workspace object contains custom member values.
Cause: The UNIQUE keyword was not specified in the concat dimension definition, and is required if any of its base dimensions contain custom member values.
Action: Define the concat as UNIQUE, or remove all base custom member values.
ORA-36642: (XSDUNION06) Concat dimension list contains duplicate leaf dimension workspace object.
Cause: Duplicate concat leaf dimension was found.
Action: Remove duplicate concat base dimensions and retry.
ORA-36643: (XSDUNION21) Concat dimension workspace object cannot be changed to NOT UNIQUE because it contains custom member values.
Cause: Only UNIQUE concat dimensions can have custom member values or base dimensions which contain custom member values.
Action: Remove all custom member values from the concat and all of its bases, and retry.
ORA-36644: (XSDUNION07) Concat dimension workspace object contains a previously detected leaf dimension.
Cause: Concat dimension contains a previously detected leaf dimension.
Action: none
ORA-36646: (XSDUNION08) Only concat dimensions can be redefined as UNIQUE. workspace object is not a concat dimension.
Cause: UNIQUE keyword was used with an invalid object.
Action: Retry without the UNIQUE keyword.
ORA-36648: (XSDUNION09) Concat dimension workspace object is already defined as UNIQUE.
Cause: Attempt to change a concat dimension to UNIQUE, but it is already UNIQUE.
Action: none
ORA-36650: (XSDUNION10) Concat dimension workspace object cannot be changed to UNIQUE. Leaves workspace object and workspace object share the value number.
Cause: Unique concat base dimensions cannot contain duplicate values.
Action: Use MAINTAIN RENAME to change one of the duplicate values and retry.
ORA-36652: (XSDUNION11) workspace object is not a string type dimension.
Cause: The CHGDFN BASE ADD command is only valid for concat dimensions.
Action: none
ORA-36664: (XSDPART02) You must specify a partitioning method and one or more partition dimensions when defining a PARTITION TEMPLATE.
Cause: User tried to define a PARTITION TEMPLATE without a PARTITION BY clause.
Action: Add a PARTITION BY clause.
ORA-36665: (XSDPART03) workspace object is not in the dimension list of the PARTITION TEMPLATE.
Cause: While defining a partition template, user attempted to specify a partition dimension that is not a dimension of the partition template itself.
Action: Choose a partition dimension from among the dimensions of the partition template.
ORA-36666: (XSDPART04) workspace object is not a concat dimension.
Cause: User tried to define a partition template with PARTITION BY CONCAT(... dim ...) where dim is not a concat dimension.
Action: Only concat dimensions can serve as partition dimensions with CONCAT partitioning. Choose a different partition dimension.
ORA-36667: (XSDPART05) string is not a legal CONCAT partition.
Cause: User attempted to use RANGE or LIST syntax in defining a CONCAT partition template.
Action: Use CONCAT partition syntax.
ORA-36668: (XSDPART06) string is not a legal RANGE partition.
Cause: User attempted to use CONCAT or LIST syntax in defining a RANGE partition template.
Action: Use RANGE partition syntax.
ORA-36669: (XSDPART07) string is not a legal LIST partition.
Cause: User attempted to use RANGE or CONCAT syntax in defining a LIST partition template.
Action: Use LIST partition syntax.
ORA-36670: (XSDPART08) workspace object is an INTEGER or NTEXT dimension, or contains an INTEGER or NTEXT dimension. INTEGER and NTEXT dimensions cannot be used as partition dimensions.
Cause: User attempted to define a partition template partitioned by an INTEGER or NTEXT dimension or a concat containing an NTEXT leaf.
Action: Either pick a different partition dimension, or redefine the dimension to use a different datatype.
ORA-36671: (XSDPART09) Leaves of workspace object have different datatypes. A partition dimension cannot have more than one datatype when RANGE partitioning is used.
Cause: User attempted to define a range partition template with a concat partition dimension, and the concat had two leaf dimensions with different datatypes.
Action: Pick a different partition dimension.
ORA-36672: (XSDPART10) A RANGE or LIST PARTITION TEMPLATE can only have a single partition dimension.
Cause: User attempted to define a RANGE or LIST partition template with more than one partition dimension.
Action: Remove all but one of the dimensions from the PARTITION BY RANGE(...) or PARTITION BY LIST(...) clause of the partition template definition.
ORA-36673: (XSDPART11) Use simple leaf values to identify concat dimension values in a VALUES LESS THAN clause, rather than the <LEAF: VALUE> format.
Cause: When defining a RANGE partition template with a concat dimension for the partition dimension, the user attempted to define a range using the <LEAF: VALUE> format of a concat dimension value.
Action: Use just the leaf value. Instead of "VALUES LESS THAN <leaf: value>", just say, "VALUES LESS THAN value".
ORA-36674: (XSDPART12) Invalid dimension value starting at string.
Cause: When defining a RANGE or LIST partition template, the user specified an invalid value in a VALUES LESS THAN or VALUES clause. An "invalid value" can be one of two things: a value whose datatype does not match the partition dimension's datatype, or a non-constant value.
Action: Modify the offending VALUES LESS THAN or VALUES phrase.
ORA-36676: (XSDPART14) Missing dimension list for string.
Cause: User attempted to define a CONCAT partition template, and didn't supply a list of dimensions for one of the partition definitions.
Action: Give a dimension list for each partition.
ORA-36677: (XSDPART15) Duplicate value in value lists of number and number
Cause: In a LIST PARTITION TEMPLATE definition, a value appeared in more than one value list, or more than once within a single value list.
Action: List each value only once.
ORA-36678: (XSDPART16) workspace object is missing from one or more partition dimension lists.
Cause: In the definition of a partition template, one of the partitions had a dimension list that did not contain all the dimensions of the partition template.
Action: Add the offending dimension to the partition's dimension list, or delete it from the partition template's dimension list. If using CONCAT partitioning and the missing dimension is a partition dimension, add to the partition dimension list any leaf of the partition dimension or any concat of leaves of the partition dimension.
ORA-36679: (XSDPART17) workspace object contains a leaf (workspace object) that is not part of the partition dimension workspace object.
Cause: In the definition of a CONCAT partition template, one of the partitions was dimensioned by a dimension that is "concat-related" to a partition dimension, meaning it shares some leaves with the partition dimension, but it contained some leaves that are not in the partition dimension.
Action: Either modify the dimensionality of the partition template to include a concat dimension that contains all the desired leaves, or pick a different dimension for the partition.
ORA-36680: (XSDPART18) workspace object is not a dimension of the PARTITION TEMPLATE.
Cause: In the definition of a partition template, one of the partitions was dimensioned by a dimension that was not given in the dimension list of the partition template.
Action: Remove the offending dimension from the partition's dimension list, or add it to the partition template's dimension list.
ORA-36681: (XSDPART19) Partitions string and string are out of order.
Cause: In the definition of a range partition template, a partition with a lower range boundary was listed after a partition with a higher range boundary.
Action: Alter the order of the partition definition list.
ORA-36682: (XSDPART20) Partition name string appears twice.
Cause: User gave a list of AW partitions in which some partition name appeared twice.
Action: Remove all but the first instance of the partition name from the list.
ORA-36683: (XSDPART21) Partition string dimensioned by more than one composite.
Cause: It is illegal to define a partition template in which one of the partitions is dimensioned by more than one composite.
Action: Make sure that the partition template being defined has at most one composite per partition.
ORA-36684: (XSDPART22) You cannot rename values of DIMENSION workspace object because it is the partition dimension of RANGE PARTITION TEMPLATE workspace object
Cause: User attempted to rename a value of a dimension that serves as the partition dimension of some RANGE or LIST partition template.
Action: It is not possible to rename values in such a dimension without deleting all RANGE and LIST partition templates that are partitioned by it.
ORA-36685: (XSDPART23) Only CONCAT partition templates can be subpartitioned.
Cause: User attempted to define a RANGE or LIST partition template with one or more partitions dimensioned by another partition template.
Action: Use only regular dimensions and composites to dimension each partition of the RANGE or LIST template.
ORA-36686: (XSDPART24) Value number is not in partition number.
Cause: User attempted to reorganize a list partition template by removing a value from some partition's list, but the value was not in the list.
Action: Ensure that the given values match the given partition.
ORA-36688: (NTEXTCNV00) Error during conversion from TEXT to NTEXT.
Cause: An unknown character set conversion error occurred when converting a TEXT value to an NTEXT value.
Action: Unknown.
ORA-36690: (NTEXTCNV01) Error during conversion from NTEXT to TEXT.
Cause: An unknown character set conversion error occurred when converting an NTEXT value to a TEXT value.
Action: Unknown.
ORA-36691: (NTEXTCNV02) Invalid escape sequence in argument to UNISTR function: string.
Cause: The user called the UNISTR function on a string that had an invalid escape sequence. The only valid escape sequences in UNISTR are 1.) an escape-escape sequence, and 2.) an escape, followed by exactly four hexadecimal digits.
Action: Make sure that all escape sequences in UNISTR arguments are exactly four hexadecimal digits. To represent codepoints whose value is less than 0x1000, use preceding zeros. WRONG: 0x10; RIGHT: 0x0010.
ORA-36692: (XSRELTBL00) The format of the HIERHEIGHT command is: HIERHEIGHT relation1[(dimension dimvalue, ...)] into relation2 [using relation3 | a | d] [inhierarchy {variable | valueset}].
Cause: The user input the wrong format/object types
Action: Make sure number of arguments and all object types are correct.
ORA-36694: (XSRELTBL01) The value cannot be added to dimension workspace object.
Cause: Unkown.
Action: Check the context and permission for dimension maintenance.
ORA-36696: (XSRELTBL02) QDR dimension workspace object should not be the related dimension of the relation.
Cause: Try to limit relation dimension using qdr list.
Action: Delete the part of qdr list for relation dimension.
ORA-36698: (XSRELTBL03) QDR dimension workspace object should be in the dimension list that dimensions the relation.
Cause: Use other dimensions than dimensions in relation dimensions.
Action: Make sure all dimensions of qdrs dimension the relation.
ORA-36700: (XSRELTBL04) QDR dimension workspace object repeats.
Cause: Repeat the qdr dimesion.
Action: Delete the repeated qdr.
ORA-36702: (XSRELTBL05) The format of the HIERHEIGHT function is: HIERHEIGHT(relation [,] level) level >= 1.
Cause: The HIERHEIGHT function was specified incorrectly.
Action: Make sure the format is correct.
ORA-36704: (XSRELTBL06) workspace object should be dimensioned by workspace object.
Cause: The level relation is not dimensioned by the source relation dimension.
Action: Make sure the level relation has the correct definition.
ORA-36706: (XSRELTBL07) workspace object should be dimensioned by workspace object and one level dimension.
Cause: The destination relation has the wrong definition.
Action: Make sure the destination relation has the correct dimensions.
ORA-36708: (XSMXALLOC00) Variable workspace object must be dimensioned to be used by the ALLOCATE command.
Cause: The user supplied an undimensioned (scalar) variable to the ALLOCATE command.
Action: Use a dimensioned variable.
ORA-36710: (XSMXALLOC01) TARGETLOG variable workspace object must be dimensioned identically to TARGET variable workspace object.
Cause: The user attempted to execute ALLOCATE with mismatching TARGET and TARGETLOG variables
Action: Use TARGET and TARGETLOG variables with matching dimensionality.
ORA-36712: (XSMXALLOC02) Relation workspace object must be a one-dimensional self-relation to be used as a SOURCE or BASIS with ALLOCATE.
Cause: The user specified an invalid source or basis relation on the ALLOCATE command line.
Action: Modify the relation to be a one-dimensional self-relation.
ORA-36714: (XSMXALLOC03) TARGETLOG variable workspace object must have the same data type as TARGET variable workspace object.
Cause: The user specified a TARGETLOG variable that had a different data type from the TARGET variable.
Action: Use TARGETLOG and TARGET variables with an identical data type.
ORA-36716: (XSMXALLOC04) You can only use the ACROSS phrase when allocation BASIS workspace object is a FORMULA.
Cause: The user specified an ACROSS composite when the BASIS is not a FORMULA.
Action: Remove the ACROSS phrase or use a FORMULA for the BASIS.
ORA-36718: (XSALLOC00) You do not have the necessary permissions to use AGGMAP workspace object.
Cause: The user did not have sufficient permissions to run the ALLOCATE command
Action: Change to a user ID with the appropriate permissions, or use objects that you have permission to use.
ORA-36720: (XSALLOC01) To be used with ALLOCATE, your AGGMAP workspace object must be defined with the ALLOCMAP command.
Cause: The user used the AGGMAP command to define the AGGMAP, so either the AGGMAP can only be used with the AGGREGATE command, or the AGGMAP has no contents attached to it.
Action: Use the ALLOCMAP command to define the AGGMAP.
ORA-36722: (XSALLOC02) In AGGMAP workspace object, you specified an NA or ZERO sourceval but supplied formula workspace object as your source for ALLOCATE.
Cause: The user requested that source values be modified during the allocation, but that is not possible when using a formula source.
Action: Either use a VARIABLE source or remove the SOURCEVAL specification for your ALLOCMAP.
ORA-36726: (XSALERR00) The character 'character' is not a valid format specifier for the ALLOCATE error log.
Cause: The user specified an invalid formatter in the ALLOCERRLOGHEADER or ALLOCERRLOGFORMAT options.
Action: Correct the option to have a valid format.
ORA-36728: (XSALERR01) While performing the ALLOCATE command with AGGMAP workspace object, the error logging limit of number was exceeded.
Cause: The user specified an ERRORLOG MAX value in the ALLOCMAP, but more errors were encountered while performing the allocation.
Action: Either set ERRORLOG NOSTOP, reduce the allocation errors, or increase the ERRORLOG MAX setting
ORA-36735: A value exceeded the MAX specification
Cause: .
Action: none
ORA-36740: A CHILDLOCK was detected in your valueset
Cause: .
Action: none
ORA-36770: (XSPGERRPERMDETACH) Parallel updating analytic workspace string failed
Cause: Unexpected error occurred to parallel update servers.
Action: Check the error underneath and act accordingly. AW may need to be detached.
ORA-36772: (XSPGERRTEMP) Ran out of temporary storage while writing to analytic workspace with ID=number. Free some temporary storage immediately. You can do so, for example, by DETACHING an analytic workspace.
Cause: Ran out of temporary tablespace storage.
Action: Increase the amount of temporary tablespace storage.
ORA-36774: (XSPGERRTEMPUSER) Ran out of temporary storage while writing to analytic workspace string. Free some temporary storage immediately. You can do so, for example, by DETACHING an analytic workspace.
Cause: Ran out of temporary tablespace storage.
Action: Increase the amount of temporary tablespace storage.
ORA-36776: (XSPGERRTEMPSYSTEM) Ran out of temporary storage while writing to a system temporary analytic workspace. Free some temporary storage immediately. You can do so, for example, by DETACHING an analytic workspace.
Cause: Ran out of temporary tablespace storage.
Action: Increase the amount of temporary tablespace storage.
ORA-36778: (XSPGTRLOW) The amount of available temporary storage is still low. Free some temporary storage immediately. You can do so, for example, by UPDATING or DETACHING an analytic workspace.
Cause: Ran out of temporary tablespace storage.
Action: Increase the amount of temporary tablespace storage.
ORA-36779: (XSPGPOOLOUT) Invalid parameter value. Olap_page_pool_size must be between must be between 2097152 and 2147483647. Olap_page_pool_size remain unmodified.
Cause: Specified value for olap_page_pool_size out of range.
Action: NONE.
ORA-36800: (XSTBLFUNC00) The OLAP_TABLE function can only have a single LOOP statement within the LIMITMAP
Cause: The olap table function given used more than one LOOP statement.
Action: It is currently impossible to specify more than one LOOP composite, either remove one of the statements (and loop densly over relevant dimensions), or create a new composite that encompasses both loops and have a single loop statement refer to that.
ORA-36802: (XSTBLFUNC01) The OLAP_TABLE function must contain a DATAMAP that executes a FETCH command or a LIMITMAP.
Cause: There is no limitmap on the table function and either the datamap does not contain a fetch, or it errored before the fetch was called.
Action: Check the datamap for errors, make sure that it executes a fetch statement, if it is not intended to execute the fetch then make sure that the table function has a valid limitmap.
ORA-36804: (XSTBLFUNC02) The OLAP_TABLE function encountered an error while parsing the LIMITMAP.
Cause: Invalid LIMITMAP syntax, or the name resolution failure of an ANALYTIC WORSKPACE OBJECT.
Action: Check the syntax of the limit map, check that the OLAP_TABLE function refers to a valid analytic workspace, check that all analytic workspace objects within the limitmap actually exist within the analytic workspace
ORA-36806: (XSTBLFUNC03) The OLAP_TABLE function refers to an invalid ADT attribute: string.
Cause: The limitmap refers to a matching of ADT attribute to AW object, but the ADT attribute is not an element of the specified ADT table. Most commonly this is a typo.
Action: Add the attribute to the ADT, correct the LIMITMAP, or remove the reference from the LIMITMAP.
ORA-36808: (XSTBLFUNC04) The OLAP_TABLE function LEVELREL clause cannot declare number ADT fields from number AW fields.
Cause: The limitmap has a levelrel clause which has a different number of values in the list to the right of the FROM than it has to the left.
Action: Change the limitmap so that there is a 1:1 mapping of adt and aw elements.
ORA-36810: (XSTBLFUNC05) Analytic workspace object number does not exist.
Cause: The limitmap refers to a non-existent aw object.
Action: Change the limitmap or define the object
ORA-36812: (XSTBLFUNC06) Invalid Syntax at '?'.
Cause: The limitmap has a question mark character outside the context of a string.
Action: Fix the limitmap
ORA-36814: (XSTBLFUNC07) The datatype of the column used in the ROW2CELL clause of a LIMITMAP must be RAW(16).
Cause: Datatype of column used in ROW2CELL clause of a LIMITMAP is not RAW(16).
Action: Change datatype to RAW(16).
ORA-36815: (XSTBLFUNC08) The OLAP_TABLE has attempted to use an AW single row function with the aw_attach parameter set to DURATION QUERY.
Cause: The OLAP_TABLE aw_attach parameter was set to DURATION QUERY.
Action: Change the OLAP_TABLE aw_attach parameter to DURATION SESSION.
ORA-36820: (XSLMINFO00) The LIMITMAPINFO function encountered an error while parsing the LIMITMAP.
Cause: Invalid LIMITMAP syntax.
Action: Correct the syntax of the limit map.
ORA-36871: (XSFTDSC01) Object string cannot be used to define a column in a LIMITMAP.
Cause: The object cannot define a column in LIMITMAP most likely because it is of a wrong type such as, for example, a Worksheet.
Action: Remove the reference from the LIMITMAP.
ORA-36872: (XSTFDSC02) Column type specifier cannot be used when the table function data type is specified.
Cause: Column type can only be used with implicitly-specified table functions
Action: Remove column type from reference from the LIMITMAP or remove the explicit table function data type specification.
ORA-36873: (XSTFDSC03) Column type must be specified explicitly.
Cause: Missing column type specification.
Action: Error not used presently
ORA-36874: (XSFTDSC04) Expression string cannot be used to define a column in a LIMITMAP.
Cause: The expression cannot define a column in LIMITMAP most likely because it is of a wrong type such as, for example, a Worksheet.
Action: Remove the reference from the LIMITMAP.
ORA-36875: (XSFTDSC05) LIMITMAP is missing or is not a string literal.
Cause: Table functions that have an automatic ADT require LIMITMAP to be a string literal.
Action: Either specify ADT for the table function or specify LIMITMAP as a string literal.
ORA-36881: (XSSRF00) The OLAP DML ROW2CELL function can only be used in a LIMITMAP.
Cause: Using the ROW2CELL function outside of the LIMITMAP.
Action: Remove use of the ROW2CELL function.
ORA-36882: (XSSRF01) The second parameter of an AW single row function cannot be NULL.
Cause: The second parameter of the AW single row function was NULL
Action: Pass a valid OLAP DML expression as the second parameter of the AW single row function
ORA-36883: (XSSRF02) The first parameter of an AW single row function cannot be NULL.
Cause: The first parameter of the AW single row function was NULL
Action: Make sure the column specified in the LIMITMAP ROW2CELL clause is the first parameter of the AW single row function.
ORA-36884: (XSSRF03) The value of the first parameter of the AW single row function is incorrect.
Cause: The column specified in the LIMITMAP ROW2CELL clause was not the first parameter of the AW single row function.
Action: Make sure the column specified in the LIMITMAP ROW2CELL clause is the first parameter of the AW single row function.
ORA-36902: (XSAGDNGL43) In AGGMAP workspace object, the MODEL workspace object is not a model over a base dimension of the AGGMAP.
Cause: Model may include equations others than dimension values, or blocks other than simple blocks.
Action: Make sure model only includes the simple blocks with dimension values.
ORA-36904: (XSAGDNGL44) In AGGMAP workspace object, RELATION workspace object occurs after a dynamic model. The dynamic model must be the last calculation within the AGGMAP.
Cause: Before the current relation, dynamic model exists.
Action: Make sure the dynamic model is the last statement.
ORA-36906: (XSAGDNGL45) 4. Model only includes one non-step dimension in the equations.
Cause: Not the qualified model.
Action: double check the model.
ORA-36908: (XSAGDNGL46) In AGGMAP workspace object, MODEL workspace object has the repeating dimension with the previous model.
Cause: two models use the same dimension.
Action: merge the equations in the two models.
ORA-36910: (XSAGDNGL47) In AGGMAP workspace object, DYNAMIC MODEL workspace object can only edit the top level of its matching relation hierarchy.
Cause: model edits the node in relation hierarchy which has parent.
Action: change the defination of model.
ORA-36912: (XSAGDNGL48) In AGGMAP workspace object, MODEL workspace object cannot be simultaneous.
Cause: use simultaneous model inside aggmap
Action: change the defination of model.
ORA-36930: Cannot start a recursive call to Oracle OLAP because a ROLLBACK past an UPDATE to an attached analytic workspace has been performed.
Cause: ROLLBACK past the UPDATE of one of the attached Analytic Workspaces was called. A recursive Oracle OLAP call cannot be made until the control returns to the initial OLAP call and the affected Analytic Workspaces detached.
Action: Change the called SQL procedure to avoid the ROLLBACK
ORA-36950: (XSFCAST22) The list of string values cannot have more than number members. You supplied number.
Cause: There are more than the maximum number of OFFSET or PERIODICITY values.
Action: Remove some of the values.
ORA-36952: (XSFCAST23) You cannot specify a cycle number when querying the string forecasting option.
Cause: A cycle number was specified in a call to FCQUERY to retrieve forecast data not related to a cycle.
Action: Remove the cycle specification from the call to FCQUERY.
ORA-36954: (XSFCAST24) The cycle number must be between 1 and number. You specified number.
Cause: A cycle number less than 1 or greater than the maximum value was specified in a call to FCQUERY.
Action: Specify a number in the indicated range.
ORA-36956: (XSFCAST25) There are only number PERIODICITY values. You cannot specify more OFFSET values.
Cause: More OFFSET values were specified than PERIODICITY values.
Action: Supply only as many OFFSETs as there are PERIODICITY values.
ORA-36958: (XSFCAST26) The OFFSET value for cycle number cannot be greater than the cycle's PERIODICITY, which is number. You specified number.
Cause: The OFFSET for a cycle exceeded the PERIODICITY for that cycle.
Action: Supply an OFFSET less than or equal to the PERODICITY for the corresponding cycle.
ORA-36960: (XSFCAST27) The value of the string expression must be an odd number. You specified number.
Cause: An even number was given for an option that requires an odd number.
Action: Supply an odd number or let the option default.
ORA-36961: Oracle OLAP is not available.
Cause: The user attempted to utilize functionality found only in Oracle OLAP, but OLAP has not been enabled in the executable.
Action: Install the Oracle OLAP option
ORA-36962: (XSRELTBL08) string is not a valid qualified data reference for dimension workspace object.
Cause: The qdr is not in its dimension.
Action: Make sure the qdr in its dimension.
ORA-36964: (XSRELTBL09) workspace object is not a valid level relation.
Cause: The level relation includes the invalid content.
Action: In level relation, all parents should be always either greater or less than their children.
ORA-36966: (XSRELTBL10) workspace object must be a dimension.
Cause: Use other objects than dimension in qdr list.
Action: Must use dimensions only in qdr list.
ORA-36968: (XSRELTBL11) workspace object must be a relation.
Cause: Wrong object type for either source or destination
Action: Give the correct object.
ORA-36970: (XSRELTBL12) workspace object must be a self-relation.
Cause: Source relation is not self-relation.
Action: Give a self-relation as source.
ORA-36972: (XSRELTBL13) Relation workspace object must be dimensioned by workspace object.
Cause: Destination relation is not dimensioned by source relation dimension.
Action: Give a correct destination relation.
ORA-36976: (XSRELGID00) The format of the GROUPINGID command is: GROUPINGID [relation1] INTO {variable | relation2 | surrogate} [USING levelrelation] [INHIERARCHY {inhvariable | valueset}] [LEVELORDER levelordervs] The source relation can be omitted only when using both surrogate gid and level order valueset.
Cause: Command format is not correct.
Action: Check the object type and number, and give the correct format.
ORA-36978: (XSRELGID01) workspace object must be a self-relation.
Cause: Source relation is not a self-relation.
Action: Give a source relation as self-relation.
ORA-36980: (XSRELGID02) Variable workspace object must have a numeric data type.
Cause: Destination variable is not numeric type variable.
Action: Make sure the variable is numeric.
ORA-36982: (XSRELGID03) The grouping variable/relation workspace object must be dimensioned by all dimensions of the source relation workspace object which have more than one element in status.
Cause: Destination variable/relation does not have enough dimensionality to hold the result from the multi-dimensional source relation.
Action: Either limit the status of hierarchy dimensions or redefine the destination variable/relation with the extended dimensionality
ORA-36984: (XSRELGID04) A value cannot be inserted into dimension workspace object.
Cause: Unkown.
Action: Make sure the dimension can be inserted.
ORA-36986: (XSRELGID05) Relation workspace object must be dimensioned by workspace object.
Cause: The destination relation is not dimensioned by the dimension of the source relation.
Action: Change the definition of the destination relation to be dimensioned by the dimension of the source relation.
ORA-36988: (XSRELGID06) The related dimension of relation workspace object must be of type NUMBER.
Cause: The destination relation has the wrong dimension type.
Action: Change the definition of the destination relation so that its dimension is Oracle number.
ORA-36990: (XSRELGID07) %a workspace object The level relation %1p should be dimensioned by a level dimension.
Cause: wrong dimension in the level relation
Action: change the definition of the level relation
ORA-36991: (XSRELGID08) The level relation and level order valueset provide inconsistent level mappings.
Cause: the level conflicts between the hierarchy/level relation and level order valueset.
Action: make them match
ORA-36992: (XSRELGID09) A level relation is needed to produce a surrogate dimension gid.
Cause: there is no level relation.
Action: add the level relation.
ORA-36993: (XSRELGID10) OBJECT workspace object must be a VARIABLE, RELATION, or a numeric SURROGATE DIMENSION based on the level dimension workspace object.
Cause: not a surrogate dimension, or the surrogate dimension is not based on the level dimension.
Action: modify/change the surrogate dimension.
ORA-36994: (XSRELGID11) The SURROGATE DIMENSION workspace object must be numeric.
Cause: The surrogate dimension is not numeric
Action: Change the surrogate dimension as numeric
ORA-36995: (XSRELGID12) There are duplicate values in the surrogate dimension gid. Use the levelorder option to resolve the ambiguity.
Cause: more than 1 hiearchies in the current computing scope.
Action: use inhierarchy to limit
ORA-36996: (XSRELGID13) Valueset workspace object should be defined over dimension workspace object.
Cause: Valueset doesn't match the dimension
Action: Change the valueset's dimension
ORA-36997: (XSRELGID14) For variable or relation grouping ids, a level relation is needed when a level order valueset is specified.
Cause: no level relation exists with level order valueset.
Action: provide the level relation.
ORA-36998: (XSRELGID15) LEVEL ORDER VALUESET workspace object and LEVEL RELATION workspace object have the different level dimensions.
Cause: either level order valueset or level relation has wrong level dimension.
Action: choose the correct level dimension
ORA-36999: (XSRELGID16) OBJECT workspace object is not a surrogate dimension, a source relation must be specifed when creating any non-surrogate grouping id.
Cause: use variable/relation gid without providing the source relation
Action: use the surrogate or provide the source relation
ORA-37000: (NOTALIAS00) workspace object is not an ALIAS DIMENSION of workspace object.
Cause: The user specified an object which is not alias dimesnion of the first dimension
Action: Specify an alias dimension of the first dimension
ORA-37001: You have one or more attached but unupdated analytic workspaces.
Cause: The user has attempted to shut down OLAP, but they have active analytic workspaces whose changes have not been saved.
Action: Either issue the update command to update the AWs, or pass TRUE as the force parameter to dbms_aw.shutdown()
ORA-37002: Oracle OLAP failed to initialize. Please contact Oracle OLAP technical support.
Cause: A severe error occured while initializing OLAP.
Action: Contact support (and possibly OLAP development) for help in debugging the issue.
ORA-37003: (AWLISTALL01) number readers
Cause: used in AW(LISTALL) output formatting when %d is 0
Action: none
ORA-37004: (AWLISTALL02) number reader
Cause: used in AW(LISTALL) output formatting when %d is 1
Action: none
ORA-37005: (AWLISTALL03) number readers
Cause: used in AW(LISTALL) output formatting when %d is > 1
Action: none
ORA-37006: (AWLISTALL04) number writers
Cause: used in AW(LISTALL) output formatting when %d is 0
Action: none
ORA-37007: (AWLISTALL05) number writer
Cause: used in AW(LISTALL) output formatting when %d is 1
Action: none
ORA-37008: (AWLISTALL06) number writers
Cause: used in AW(LISTALL) output formatting when %d is > 1
Action: none
ORA-37010: (XSACQUIRE_DIFFAW) When using CONSITENT WITH clause, all objects must come from the same analytic workspace.
Cause: ACQUIRE command cannot keep objects from several workspaces consistent with each other
Action: Omit CONSISTENT WITH clause or make sure all objects being acquired belong to the same analytic workspace.
ORA-37011: (XSACQUIRE_LOCKED) Object workspace object is locked by another user.
Cause: Could not acquire (or acquire consistent) the object since it is locked by another user
Action: Try to acquire this object later
ORA-37012: (XSACQUIRE_TIMEOUT) Object workspace object is locked by another user and the WAIT timed out.
Cause: Could not acquire (or acquire consistent) the object for a while since it is locked by another user
Action: Try to acquire this object later
ORA-37013: (XSACQUIRE_DEADLOCK) Cannot wait to acquire object workspace object since doing so would cause a deadlock.
Cause: Waiting to acquire the object would cause a deadlock
Action: Release some other object that another user is waiting for and try to acquire this object again.
ORA-37014: (XSACQUIRE_ACQUIRED) Object workspace object is already acquired.
Cause: The object is already acquired
Action: Do not try to acquire this object again
ORA-37015: (XSACQUIRE_YNRESYNC) Object workspace object is ambiguously listed to be acquired both with and without RESYNC.
Cause: The object is listed in with resync list and no resync list. Such usage is ambigous as to the user's intent on preserving or not preserving private changes.
Action: Do not list the object both with and without RESYNC
ORA-37016: (XSACQUIRE01) You must specify objects to acquire for the ACQUIRE command.
Cause: A list of obejcts to acquire with or without resync is missing
Action: Specify the list of objects to acquire
ORA-37018: (XSACQUIRE03) Multiwriter operations are not supported for object workspace object.
Cause: Multiwriter presently does not work for this object type
Action: Attach the AW in RW or EXCLUSIVE modes to modify this object.
ORA-37020: (XSMULTI01) Analytic workspace string is not in MULTI mode.
Cause: The workspace for an object is not in multiwriter mode. Hence, no multiwriter operations are allowed on the objects in the workspace
Action: Attach the workspace in the multiwriter mode or do not use multiwriter commands with it.
ORA-37021: (XSMULTI02) Object workspace object is not acquired.
Cause: The object must be acquired for this multiwriter operation
Action: Do not use this multiwriter operation on an object that is not acquired
ORA-37023: (XSMLTUPD01) Object workspace object cannot be updated without dimension workspace object.
Cause: One cannot update an object if it is dimensioned by a maintained dimension without updating that dimension or if the object is a relation and the dimension is its target.
Action: Include the maintained dimension in the update list
ORA-37026: (XSMLTRESYNC01) Object workspace object cannot be resynced without dimension workspace object.
Cause: One cannot resync an object if it is dimensioned by a maintained dimension without updating that dimension or if the object is a relation and the dimension is its target.
Action: Include the maintained dimension in the update list
ORA-37027: (XSMLTRESYNC02) Object workspace object cannot be resynced without modified object workspace object because they share a modified composite dimension.
Cause: When one resyncs an object that is dimensioned by a composite dimension, the composite dimension is resynced automatically, dropping all new tuples. This cannot be done, however, if the automatic resync of the composite dimension might cause data in an object that shares the composite dimension to become NA.
Action: Resync both objects together. ALternatively, you can try to acquire the other object (that will ensure that the composite dimension is locked in the latest generation and will not be resynced when resyncning the first object), resync the first object, and release the other object.
ORA-37028: (XSMLTRESYNC03) Object workspace object cannot be resynced without modified object workspace object because they share a modified dimension map.
Cause: When one resyncs an object that is dimensioned by a dimension map, the dimension map is resynced automatically, dropping all changes. This cannot be done, however, if the automatic resync of the dimension map might cause data in an object that shares the dimension map to become NA.
Action: Resync both objects together. ALternatively, you can try to acquire the other object (that will ensure that the dimensions map is locked in the latest generation and will not be resynced when resyncning the first object), resync the first object, and release the other object.
ORA-37030: (XSMLTMAINT01) You cannot maintain workspace object because it is not ACQUIRED.
Cause: One cannot maintain a dimension in a multiwriter AW if it is not acquired.
Action: Acquire the dimension first.
ORA-37031: (XSMLTMAINT02) You cannot MOVE, DELETE, or add SESSION values of dimension workspace object in MULTI mode.
Cause: MOVE, DELETE, and SESSION are not allowed in multiwriter mode
Action: Perform the operations above in a non-multiwriter AW
ORA-37032: (XSMLTMAINT03) You cannot MAINTAIN partition template workspace object in MULTI mode.
Cause: User attempted to add or remove values from a LIST partition template's lists while the AW containing the partition template was attached in multiwriter mode.
Action: Do the maintenance in read only or read-write mode.
ORA-37035: (XSMLTDCL01) You can only DEFINE SESSION objects in analytic workspace string because it is attached in MULTI mode.
Cause: One cannot maintain a dimension in a multiwriter AW if it is not acquired.
Action: Acquire the dimension first.
ORA-37040: (XSACQUIRE_DEP_LOCKED) Composite, concat, dimension map, or internal partition workspace object is locked by another user.
Cause: Some object required locking a composite, concat, dimension map, or internal partition, which is locked by another user
Action: Try to acquire this object later
ORA-37041: (XSACQUIRE_DEP_TIMEOUT) Composite, concat, dimension map, or internal partition workspace object is locked by another user and the WAIT timed out.
Cause: Some object required locking a composite, concat, dimension map, or internal partition, which could not be locked for a while since it is locked by another user
Action: Try to acquire this object later
ORA-37042: (XSACQUIRE_DEP_DEADLOCK) Cannot wait to acquire composite, concat, dimension map, or internal partition workspace object since doing so would cause a deadlock.
Cause: Some object required locking a composite, concat, dimension map, or internal partition, which would cause a deadlock
Action: Release some other object that another user is waiting for and try to acquire this object again.
ORA-37043: (XSACQUIRE_DEP_OLDGEN) Composite, concat, dimension map, or internal partition workspace object cannot be locked since another user has committed a new one already.
Cause: Some object required locking a composite, concat, dimension map, or internal partition in the present generation, which is not possible since a newer generation already exists.
Action: Try to acquire the main object with resync
ORA-37044: (XSACQUIRE_OLDGEN) Cannot acquire object workspace object without resync.
Cause: Could not acquire the object without resync because another user has committed a newer version of it already.
Action: Try to acquire this object with resync parameter
ORA-37060: (XSMCSESS08) number is not a valid custom member in dimension workspace object.
Cause: No custom member or invalid custom member
Action: Create the custom member or use the correct custom member
ORA-37070: You may not execute OLAP DML programs in a parallel query session.
Cause: The user attempted to execute a DML program inside of a parallel query session, perhaps in parallel aggregate
Action: Adjust the job so that a program does no need to be executed, or disable parallelism
ORA-37071: You may not execute a parallel OLAP operation against updated but uncommitted AW string.
Cause: The user attempted to use a parallel feature against an AW which they updated but which has not been committed
Action: Commit the current changes
ORA-37072: (XSMCSESS00) Object workspace object has the wrong type.
Cause: The object is not of the object type specified in the APPLY clause
Action: Specify the correct object type
ORA-37073: (XSMCSESS01) Applied relation workspace object must be dimensioned by dimension workspace object.
Cause: Applied relation has the different dimension from the dimension currently being maintained
Action: Maintain relation dimension
ORA-37074: (XSMCSESS02) Variable workspace object has no default aggmap.
Cause: The applied variable has no default aggmap
Action: Use variable with the default aggmap or aggmap directly
ORA-37075: (XSMCSESS03) You cannot rename a session-only dimension value.
Cause: The user tried to apply MAINTAIN RENAME to a SESSION value.
Action: Delete the old value and add a new one with the desired name.
ORA-37076: (XSMCSESS04) workspace object is not the type of dimension that can have session-only values. Valid types are TEXT and NTEXT.
Cause: The user tried to add a SESSION value to a dimension type that does not support SESSION values.
Action: Use a dimension of type TEXT or NTEXT.
ORA-37077: (XSMCSESS05) Object workspace object is specified more than once.
Cause: The same object name was given more than once in the apply clause or in the step dimension list.
Action: Remove the repetitions.
ORA-37078: (XSMCSESS06) The dimension being maintained (workspace object) cannot also be used as a step dimension.
Cause: The dimension being maintained was named as a step dimension.
Action: Remove this dimension from the list of step dimensions.
ORA-37079: (XSMCSESS07) Aggmap workspace object cannot be used for AGGREGATE.
Cause: The current aggmap may be for ALLOCATE
Action: Choose the correct aggmap for AGGREGATE only.
ORA-37080: Advice requested for hierarchy with too many levels
Cause: A request was made for advice on a hierarchy with more levels than are supported.
Action: Only request advice for hierarchies with less than 32 levels.
ORA-37081: Requested advice produced no precomputes
Cause: A request was made for advice with insufficient amount of space to do any precomputation.
Action: Increase the percent precomputed target.
ORA-37082: Invalid percent
Cause: A request was made for advice with an illegal percent value.
Action: Request between 0 and 100 percent precomputation.
ORA-37083: Invalid object string
Cause: A request was made for advice with an illegal object name.
Action: Request using valid object names.
ORA-37084: Output valueset string must match string's dimesnionality
Cause: A request was made for advice for a relation with different dimensionality from the output valueset.
Action: Request using objects that have the same dimesnsionality.
ORA-37086: %s is not a valueset
Cause: An operation was attempted that supports only valuesets as precompute expressions in an aggmap, yet a different kind of precompute expression was used.
Action: Replace this limit expression with an equivalent valueset and retry the operation. General precompute expressions are deprecated.
ORA-37100: (XSUNCOMMITTED) You have one or more updated but uncommitted analytic workspaces.
Cause: The user has attempted to shut down OLAP, but they have active analytic workspaces whose changes have not been saved.
Action: Issue the commit command. ---- 37101 - 37110 are reserved for partitioned variables ----
ORA-37101: (XSVPART01) Partitioning information can only be given for variables dimensioned by a PARTITION TEMPLATE.
Cause: User attempted to define or reference an AW object with the "all internal" phrase or internal / external partition list, but the object was not a variable, was not dimensioned by a partition template, or was an already existing target of an external partition.
Action: Eliminate phrases specific to partitioned variables from the definition string, or dimension the variable by a partition template.
ORA-37102: (XSVPART02) Invalid partition name string.
Cause: The user gave an invalid partition name. When defining a partitioned variable, this message indicates that the partition name does not exist in the partition template. In any other context, it indicates that the partitioned variable or partition template does not have a partition with the given name.
Action: Supply a valid partition name.
ORA-37103: (XSVPART03) The dimensionality or datatype of workspace object does not match the dimensionality or datatype of the partition.
Cause: User attempted to define a partitioned variable with an external partition, but the target of the external partition had incorrect dimensionality or datatype.
Action: Pick a different target variable. The target variable must be dimensioned by exactly the same dimensions, composites, and partition templates, in the same order, as are specified in the partition template, and must have the exact same datatype (including width, precision, and scale) as the partitioned variable itself.
ORA-37104: (XSVPART04) A partitioned variable must be dimensioned by a single partition template only.
Cause: User attempted to define a partitioned variable with more than one partition templates, or a partition template and one or more other dimensions, in the dimension list.
Action: Use only a partition template in the dimension list of the variable. All dimensions of the variable must be included in the definition of the partition template.
ORA-37105: (XSVPART05) Only variables dimensioned by a CONCAT PARTITION TEMPLATE can have string partitions.
Cause: User attempted to create an external partition on a partitioned variable, but the variable was dimensioned by a RANGE or LIST partition template.
Action: Declare the partition INTERNAL instead of EXTERNAL, or use a CONCAT partition template in place of the RANGE or LIST partition template.
ORA-37106: (XSVPART06) Invalid partition name number.
Cause: The user gave an invalid partition name.
Action: Supply a valid partition name.
ORA-37107: (XSVPART07) Attempt to write to non-existent partition of workspace object.
Cause: Some action attempted to write data to a partitioned variable, but the variable didn't have a partition for that data. This can result from a partition template that does not assign all possible dimension values to some subcube, or from a partitioned variable that does not have a partition for one of the partitions defined by the partition template.
Action: Make sure that the cell being written is assigned to some partition by the partition template, and that the variable has an actual partition associated with the partition of the template. Use the CHGDFN template DEFINE... command to define new partitions within the template, and the CHGDFN variable ADD... command to add new partitions to the variable. Alternatively, the PARTWRITEERR can be set to false, in which case data being written to a non-existent partition will be silently discarded.
ORA-37111: Unable to load the OLAP API sharable library: (string)
Cause: This happens if: (1) the OLAP API sharable library is missing. (2) a sharable library upon which the OLAP API sharable library depends is missing. (3) the OLAP API sharable library is the wrong version.
Action: Ensure that Oracle is properly installed with the OLAP option. If the RDBMS has been patched, review the patch log for errors. If the problem persists, report it to Oracle Customer Support.
ORA-37112: OLAP API requires Oracle 9.2 or later
Cause: The version of the OLAP API jar files that you used requires Oracle version 9.2 or later.
Action: Ensure that the URL with which the JDBC connection was opened is correct. If the RDBMS instance is running in compatibility mode for a version older than 9.2, it must be upgraded to at least 9.2.0.0.0 to used with this version of the OLAP API.
ORA-37113: OLAP API initialization error: (string)
Cause: OLAP API initialization failed.
Action: Ensure that Oracle is properly installed with the OLAP option. If the RDBMS has been patched, review the patch log for errors. If the problem persists, report it to Oracle Customer Support.
ORA-37114: OLAP API bootstrap error: (string)
Cause: OLAP API bootstraping failed.
Action: Ensure that Oracle is properly installed with the OLAP option. If the RDBMS has been patched, review the patch log for errors. If the problem persists, report it to Oracle Customer Support.
ORA-37115: New OLAP API history is not allowed
Cause: If there are active OLAP API sessions, it is not allowed to start a new OLAP API history by setting _olapi_history_retention parameter to true.
Action: Wait until all active OLAP API sessions terminate before resetting _olapi_history_retention parameter to true.
ORA-37116: OLAP API table function error: (string)
Cause: OLAP API table function failed.
Action: Ensure that Oracle is properly installed with the OLAP option. If the RDBMS has been patched, review the patch log for errors. If the problem persists, report it to Oracle Customer Support.
ORA-37117: olapi history retention has been disabled
Cause: Under certain circumstances, for example, when the database is read only, olapi history retention is not possible because it requires updating persistent tables from time to time. If olapi history retention has been disabled, setting _olapi_history_retention parameter to true has no effect.
Action: Ensure that Oracle is properly installed with the OLAP option. If the RDBMS has been patched, review the patch log for errors. If the problem persists, report it to Oracle Customer Support.
ORA-37121: AW Spreadsheet invalidated
Cause: While this cursor was open, a command was issued that changed the underlying data to become inconsistent.
Action: Perform the query again, avoid performing dimension maintenance and cache clears during spreadsheet processing.
ORA-37122: AW Session cache disabled
Cause: A SQL Spreadsheet was attempted while the AW Session cache was disabled.
Action: Enable the session cache and perform the query again.
ORA-37126: (XSCCOMP01) The COMPRESSED COMPOSITE workspace object can only be used as a base of a single variable.
Cause: The user attempted to DEFINE a variable dimensioned by a COMPRESSED COMPOSITE, but that COMPRESSED COMPOSITE is already being used by another VARIABLE.
Action: Create a second COMPRESSED COMPOSITE for the second VARIABLE or add a measure dimension to the first variable.
ORA-37127: (XSCCOMP02) The COMPRESSED COMPOSITE workspace object must be last in the dimension list.
Cause: The user attempted to DEFINE a variable dimensioned by a COMPRESSED COMPOSITE, but gave a slower varying dimension in the dimension list.
Action: Put the COMPRESSED COMPOSITE last in the dimension list when defining the VARIABLE.
ORA-37128: (XSCCOMP03) It is not possible to PARTITION over a base of a COMPRESSED COMPOSITE.
Cause: The user attempted to use a base of a COMPRESSED COMPOSITE as a partitioning dimension.
Action: Choose a dense dimension as the partition base.
ORA-37129: (XSCCOMP04) The AGGMAP workspace object cannot be used to aggregate the VARIABLE workspace object. All static MODEL statements must precede all RELATION statments over the bases of the COMPRESSED COMPOSITE.
Cause: The AGGMAP was defined with a MODEL statement after a RELATION statement over a base of the COMPRESSED COMPOSITE.
Action: Change the AGGMAP so that the MODEL statements appear before the RELATION statements.
ORA-37130: (XSCCOMP05) Cannot aggregate VARIABLE workspace object using AGGMAP workspace object because there is a PRECOMPUTE clause on a RELATION over the base of a COMPRESSED COMPOSITE.
Cause: A PRECOMPUTE clause was specified in the AGGMAP for a RELATION over a base of a COMPRESSED COMPOSITE.
Action: Remove the PRECOMPUTE clause from the AGGMAP.
ORA-37131: (XSCCOMP06) Cannot aggregate VARIABLE workspace object using AGGMAP workspace object because the OPERATOR string is not supported for bases of a COMPRESSED COMPOSITE.
Cause: The user specifed an aggregation OPERATOR that is not supported by COMPRESSED COMPOSITES.
Action: Use a MODEL for the calculation, or use an uncompressed COMPOSITE.
ORA-37132: (XSCCOMP07) Incremental aggregation over the dense DIMENSION workspace object is not supported when aggregating a VARIABLE dimensioned by a COMPRESSED COMPOSITE.
Cause: The status of the specified dimension did not include all detail cells.
Action: Add all detail cells to the status of the dimension and reissue the AGGREGATE command.
ORA-37133: (XSCCOMP08) Cannot write into an aggregated VARIABLE dimensioned by a COMPRESSED COMPOSITE. Use the CLEAR AGGREGATES command to reenable write access.
Cause: The user attempted to store a value into to a variabled dimensioned by a compressed composite, and the variable had previously been precomputed using the AGGREGATE command. Once the AGGREGATE command is run on a variable dimensioned by a compressed composite, it becomes read-only until the computed values are removed with the CLEAR command.
Action: Run the CLEAR AGGREGATES command to remove the computed values from the variable and then rerun the failed operation. Note that CLEAR AGGREGATES will remove all the data computed during the last AGGREGATE command on this variable.
ORA-37134: (XSCCOMP09) You cannot add new values to workspace object because it includes positions for precomputed aggregate values.
Cause: The user attempted to create a new position in a compressed composite, either directly (using MAINTAIN MERGE or MAINTAIN ADD) or by storing a value into the variable dimensioned by the compressed composite. This is not allowed when the variable has been precomputed using the AGGREGATE command. Once the AGGREGATE command is run on a variable dimensioned by a compressed composite, the compressed composite becomes read-only until the computed values are removed with the CLEAR command.
Action: Run the CLEAR AGGREGATES command to remove the computed values from the variable and then rerun the failed operation. Note that CLEAR AGGREGATES will remove all the data computed during the last AGGREGATE command on this variable.


19 ORA-38029 to ORA-39961

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

19 ORA-38029 to ORA-39961

ORA-38029: object statistics are locked
Cause: An attept was made to modify optimizer statistics of the object.
Action: Unlock statistics with the DBMS_STATS.UNLOCK_TABLE_STATS procedure on base table(s). Retry the operation if it is okay to update statistics.
ORA-38101: Invalid column in the INSERT VALUES Clause: string
Cause: INSERT VALUES clause refers to the destination table columns
Action: none
ORA-38102: Invalid column in the INSERT WHERE Clause: string
Cause: INSERT WHERE clause refers to the destination table columns
Action: none
ORA-38103: Invalid column in the UPDATE SET Clause: string
Cause: UPDATE SET clause refers to the source table columns in the LHS
Action: none
ORA-38104: Columns referenced in the ON Clause cannot be updated: string
Cause: LHS of UPDATE SET contains the columns referenced in the ON Clause
Action: none
ORA-38105: Delete not yet supported when Update row-migration is possible
Cause: When Update Row-Migration is possible, Delete in MERGE is not yet supported
Action: none
ORA-38201: assert if pin during flush
Cause: internal use only
Action: enables checking for bugs in upper layers when there is a pin on a buffer or there are users for buffer and we are trying to flush the object associated with the buffer
ORA-38303: invalid option for PURGE TABLESPACE
Cause: Either a token other than USER was found following the tablespace name or some text was found following USER <user name>.
Action: Place nothing or only USER <user name> after the tablespace name
ORA-38304: missing or invalid user name
Cause: A valid user name was expected.
Action: Specify a valid user name.
ORA-38305: object not in RECYCLE BIN
Cause: Trying to Flashback Drop an object which is not in RecycleBin.
Action: Only the objects in RecycleBin can be Flashback Dropped.
ORA-38306: this object is not recoverable standalone
Cause: Trying to flashback drop an object other than of type TABLE.
Action: Only tables are recoverable.
ORA-38307: object not in RECYCLE BIN
Cause: Trying to Purge the object which is not in RecycleBin.
Action: Only the objects in RecycleBin can be PURGEDED.
ORA-38309: object not purgable
Cause: An attempt was made to purge an object that is either not purgable or else dependent upon some other object.
Action: Cannot purge this object.
ORA-38310: cannot purge tablespace for other users
Cause: An attempt was made to purge the tablespace for a different user by a user who does not have system DBA priviledges.
Action: Cannot purge the tablespace for some other user.
ORA-38311: cannot purge objects owned by other users
Cause: An attempt was made to purge an object which is owned by some other user.
Action: Cannot purge this object.
ORA-38312: original name is used by an existing object
Cause: An attempt was made to recover an object preserving the original name, but that name is taken up by some other object.
Action: use the RENAME clause to recover the object with a different name.
ORA-38401: synonym string not allowed
Cause: An attempt was made to use a synonym for a data type of an attribute or a table alias.
Action: Use the object name instead of the synonym.
ORA-38402: invalid name: empty string or spaces in the name
Cause: There were spaces in the name.
Action: Remove spaces in the name or use quotes around the name.
ORA-38403: attribute set name may not be longer than 22 characters
Cause: The attribute set name was longer than 22 characters.
Action: Choose a name that has 22 or fewer characters.
ORA-38404: schema extension not allowed for the attribute set name
Cause: There was a schema extension for the attribute set name. Attribute sets are always created in the current schema and thus schema extended names are not allowed.
Action: Create the attribute set from the appropriate schema.
ORA-38405: quotes not allowed in the attribute set name
Cause: The attribute set name contained quotes.
Action: Remove quotes in the attribute set name.
ORA-38406: attribute set string already exists
Cause: An attribute set with a matching name already exists in the current schema.
Action: Drop the existing attribute set or choose a different name.
ORA-38407: The ADT associated with the attribute set already exists.
Cause: The Abstract type (ADT) with the same name as the attribute set already exists in the current schema.
Action: Create the attribute set for the existing ADT or drop the ADT.
ORA-38408: The ADT "string" does not exist in the current schema.
Cause: An attempt was made to create the attribute set from a nonexistent ADT.
Action: Make sure that the ADT with the same name as the attribute set exists in the current schema.
ORA-38409: invalid name or option for the attribute set: string
Cause: An invalid name or option was used for the attribute set.
Action: Set serveroutput ON and repeat the operation for additional information.
ORA-38410: schema extension not allowed for the table name
Cause: An attempt was made to use a schema extended name for the table storing expressions.
Action: The table storing expressions and the corresponding attribute set should be created in the same schema.
ORA-38411: invalid datatype for the column storing expressions
Cause: An attempt was made to create an expression column from a column of invalid datatype.
Action: Create a VARCHAR2 or CHAR column to store expressions in a table.
ORA-38412: Expression set column string does not exist.
Cause: The column storing expressions does not exist.
Action: Pass a valid name for the column storing expressions.
ORA-38413: elementary attribute name may not be longer than 32 characters
Cause: An attempt was made to create an elementary attribute with a name longer than 32 characters.
Action: Use a shorter name for the elementary attribute.
ORA-38414: invalid datatype for the attribute string
Cause: The datatype specified for the attribute was invalid.
Action: If the datatype is an ADT, make sure that the ADT exists and the current user has execute permissions to it.
ORA-38415: invalid name or datatype for the attribute: string
Cause: An invalid name or datatype was used for the attribute.
Action: Set serveroutput ON and repeat the operation for additional information.
ORA-38416: A stored attribute may not be longer then 300 characters.
Cause: An attempt was made to create a stored or indexed attribute longer than 300 characters.
Action: A predicate with such attribute may not be indexed. It will be evaluated as sparse predicate.
ORA-38417: attribute set string does not exist
Cause: An attempt was made to use an attribute set that does not exist.
Action: Create the attribute set or choose an existing attribute set.
ORA-38418: ADT associated with the attribute set string does not exist
Cause: The ADT with the same name as the attribute set was not found in the current schema.
Action: Drop the attribute set and recreate it.
ORA-38419: invalid identifier in attribute : string
Cause: An identifier used in the stored/indexed attribute sub-expression was not defined or was invalid.
Action: Create all the required elementary attributes and user-defined functions and try again.
ORA-38420: invalid stored attribute sub-expression: string
Cause: The sub-expression used for the stored expression was invalid.
Action: Set serveroutput ON and repeat the operation for additional information.
ORA-38421: attribute string already exists
Cause: An attribute with a matching name (or form) already exists in the attribute set.
Action: Drop the existing attribute or choose a different name for the new attribute.
ORA-38422: invalid datatype for the attribute: string
Cause: An attempt was made to create an attribute with invalid datatype.
Action: If the data type of the attribute is an ADT, make sure that the type exists.
ORA-38423: Attribute set created from an ADT may not be extended.
Cause: An attempt was made to add an elementary attribute to an attribute set created from an ADT.
Action: Create a new attribute set and add all the required elementary attributes one at a time.
ORA-38424: no attribute set currently assigned to the expression set
Cause: An attempt was made to un-assign an attribute set from an expression set when there is no attribute set assigned to it.
Action: No action is required.
ORA-38425: attribute set used for an index object may not be unassigned
Cause: An attempt was made to un-assign an attribute set from an expression set when there is an Expression Filter index defined on the column.
Action: Drop the index before un-assigning the attribute set.
ORA-38426: attribute set assigned to an expression set may not be dropped
Cause: An attempt was made to drop an attribute set when it is still associated with an expression set.
Action: Un-assign the attribute set from the expression set before dropping it.
ORA-38427: attribute string does not exist
Cause: An attempt was made to use an attribute set that does not exist.
Action: Create the attribute set.
ORA-38428: too many attributes selected for indexing
Cause: An attempt was made to create an expression filter index with more than 490 indexed attributes.
Action: Remove some of the indexed attributes. Make sure that the default indexed attributes associated with the attribute set combined with the indexed attributes specified in the Create Index Parameters clause are less than or equal to 490.
ORA-38429: invalid datatype for a stored attribute: string
Cause: The (resulting) datatype for the attribute was not appropriate for storing.
Action: Choose a stored attribute that has a resulting datatype of NUMBER, VARCHAR2, CHAR or DATE.
ORA-38430: Operation "string" not supported in the current release.
Cause: An attempt was made to perform an unsupported operation.
Action: Do not use the operation.
ORA-38431: could not evaluate subexpression "string" for rowid "string"
Cause: Either the expression was not a valid SQL-WHERE clause format or it had references to nonexistent schema objects.
Action: Correct the expression.
ORA-38432: EVALUATE operator only allowed on an expression column
Cause: An attempt was made to use the EVALUATE operator on a column not configured as a column storing expressions.
Action: Assign an attribute set to the column.
ORA-38433: index "string" could not be maintained due to "string"
Cause: The error was caused by the recursive operation.
Action: Fix the error and retry.
ORA-38434: could not evaluate expression "string"
Cause: Either the expression was not in a valid SQL-WHERE clause format or it had references to nonexistent schema objects or there is a missing attribute value.
Action: Set serveroutput ON for more details.
ORA-38435: missing elementary attribute value or invalid name-value pairs
Cause: The second argument to the EVALUATE operator had either a missing attribute or an invalid value for an attribute.
Action: Try again after fixing the error.
ORA-38436: attribute set used for an Expression set may not be modified.
Cause: An attempt was made to add an elementary attribute to an attribute set assigned to an expression set.
Action: Un-assign the attribute set and try again.
ORA-38437: The ADT "string" may not contain any user methods.
Cause: An attempt was made to create an attribute set from an ADT that has one or more user methods.
Action: Drop the ADT and recreate it with no user methods.
ORA-38438: getVarchar not possible due to "string" datatype in the attribute set
Cause: An attempt was made to use the getVarchar API when the attribute set has one or more non-scalar types.
Action: Use AnyData conversion to encode the data item.
ORA-38439: invalid operation "string"
Cause: An attempt was made to use an invalid operation.
Action: Use one of the following operations : ADD, DROP
ORA-38440: attribute set string does not exist
Cause: An attempt was made to copy an attribute set that is not accessible from the current schema.
Action: Grant execute permissions on the corresponding ADT to the current user and try again.
ORA-38441: System could not derive the list of STORED and INDEXED attributes.
Cause: The attribute set was created without default index parameters.
Action: Specify the default index parameters for the attribute set or include a valid PARAMETERS clause for the CREATE INDEX command.
ORA-38442: The ADT "string" is not in a valid state.
Cause: An attempt was made to use an ADT that is not in a valid state.
Action: Check the INCOMPLETE field in the user_types catalog view to make sure that the ADT is in a valid state. Drop the invalid ADT and recreate the corresponding attribute set.
ORA-38443: An attribute set should be assigned to the expression set for statistics collection.
Cause: An attempt was made to collect statistics for an expression set with no attribute set assigned to it.
Action: Assign an attribute set to the expression set before collecting the statistics.
ORA-38444: statistics do not exist for the expression set
Cause: An attempt was made to clear the statistics that do not exist.
Action: No action was required.
ORA-38445: TOP clause not allowed with no statistics
Cause: An attempt was made to use the TOP parameters clause with no statistics available for the expression set.
Action: Collect statistics for the expression set and try again.
ORA-38446: Error with embedded ADT "string" in the attribute set.
Cause: The embedded ADT has errors.
Action: Set serveroutput ON for additional information.
ORA-38447: Type required for the embedded ADT attribute "string" is missing
Cause: Object type required for the embedded ADT was missing.
Action: Set serveroutput ON for additional information.
ORA-38448: Indexing predicates with "string" operator is not supported.
Cause: An unsupported operator was used in the exf$indexoper array.
Action: Choose the operators from this list : =, <, >, <=, >=, !=, is null, is not null, nvl, and between.
ORA-38449: table "string" does not exist or is not accessible
Cause: An attempt was made to create a table alias for a table that does not exist or is not accessible.
Action: Grant select privileges on the table to the current user.
ORA-38450: error computing a stored attribute for the expression set.
Cause: Either values for one of the attributes was incorrect or a stored attribute was invalid due to broken dependencies.
Action: Correct the input.
ORA-38451: index is in an inconsistent state
Cause: One or more secondary objects used to maintain the index did not exist
Action: Drop the index and recreate it.
ORA-38452: Expression Filter index name may not be longer than 25 characters
Cause: An attempt was made to use a name longer than 25 characters for the Expression Filter index.
Action: Choose a name that has 25 or fewer characters
ORA-38453: ExpFilter index should be created in the same schema as the base table.
Cause: An attempt was made to create the Expression Filter index in a schema other than that of the base table.
Action: Create the index in the same schema as the base table.
ORA-38454: attribute set not defined for the column being indexed
Cause: An attempt was made to create an Expression Filter index on a column with no attribute set association.
Action: Assign an attribute set to the expression set column begin indexed.
ORA-38455: Expression Filter index should be created by the owner.
Cause: An attempt was made to create the Expression Filter index by a user who is not the owner of the index.
Action: Create the index using owner's privileges.
ORA-38456: The attribute set "string" is in an inconsistent state.
Cause: The attribute set was in an inconsistent state due to broken dependencies.
Action: Set serveroutput ON for more details. The attribute set may not be reused after this error.
ORA-38457: The attribute "string" is not a valid XMLType attribute.
Cause: An attempt was made to use a non-XMLType attribute to configure XPath filtering.
Action: Use an attribute of sys.XMLType datatype to configure XPath filtering.
ORA-38458: invalid operation "string" for XPATH_FILTER_PARAMETERS
Cause: An attempt was made to use an invalid operation.
Action: Use one of the following operations : ADD, DROP.
ORA-38459: XML Tag "string" not found for the XMLType attribute "string"
Cause: An Attempt was made to use a non-existent XML Tag.
Action: Correct the name of the XML Tag or the XMLType attribute.
ORA-38460: filtering based on datatype "string" not supported for XML Tags
Cause: An attempt was made to configure XPath filtering with an XML Tag of unsupported datatype.
Action: Leave the XML Tag out of filter parameters. It will be processed as sparse predicate
ORA-38461: XML Tag "string" already exists for the XMLType attribute "string"
Cause: An attempt was made to create a duplicate XML Tag.
Action: Choose a different XML Tag.
ORA-38462: invalid attribute list
Cause: The input was missing an attribute list or had null values for the attribute names.
Action: Correct the input.
ORA-38463: invalid XML Tag list
Cause: The input was missing a tag list or had null values for the tag names.
Action: Correct the input.
ORA-38464: expression set is not empty.
Cause: An attempt was made to assign an attribute set to a non-empty expression set.
Action: Use FORCE = 'TRUE' to validate all the existing expressions.
ORA-38465: failed to create the privilege checking trigger due to: string
Cause: Creation of the trigger failed due to the error listed in the message.
Action: Set serveroutput ON for more information.
ORA-38466: user does not have privileges to CREATE/MODIFY expressions
Cause: An attempt was made to INSERT or UPDATE a column storing expression without appropriate permissions.
Action: Appropriate privileges on the expression set should be granted by the owner of the expression set.
ORA-38467: user cannot GRANT/REVOKE privileges to/from himself
Cause: An attempt was made to GRANT or REVOKE privileges to or from the current user.
Action: The the to_user or from_user field should be different from the user performing the operation.
ORA-38468: column "string" is not identified as a column storing expressions.
Cause: An attempt was made to grant permission on a nonexistent expression set.
Action: Make sure that the table and the column exist and an attribute set is associated with the column.
ORA-38469: invalid privilege for an expression set: string
Cause: An attempt was made to use an invalid privilege.
Action: See documentation for a valid privilege.
ORA-38470: cannot revoke a privilege that was not granted.
Cause: An attempt was made to revoke a privilege that had not been granted.
Action: Check catalog views to see if the user has the privilege.
ORA-38471: ROWIDs for table aliases cannot be null
Cause: An attempt was made to pass a null value for the table alias attribute in the data item, which is not permitted.
Action: Pass a valid rowid value for the table alias.
ORA-38472: VARCHAR representation of the data item is too long.
Cause: The VARCHAR representation of data item was too long.
Action: Use the EVALUATE operator with AnyData argument instead.
ORA-38473: cannot drop a type used for Expression Filter attribute set
Cause: An attempt was made to drop an ADT that was used to maintain an attribute set for the Expression Filter.
Action: Query USER_EXPFIL_ATTRIBUTE_SETS view to see the dependency.
ORA-38474: attribute set may not have attributes of TABLE COLLECTION type.
Cause: An attempt was made to create an attribute with a TABLE COLLECTION type.
Action: Use VARRAYs instead of table collection, if possible.
ORA-38475: The attribute set and the associated ADT are out of sync.
Cause: The ADT was directly modified by CREATE or ALTER operations.
Action: Drop the attribute set and recreate it from scratch.
ORA-38476: abstract type used for an Attribute set may not be modified.
Cause: An attempt was made to alter a type (ADT) that is used to maintain an attribute set of an Expression set.
Action: Do not modify the ADT directly. Use DBMS_EXPFIL APIs instead.
ORA-38477: attribute set cannot be derived from an evolved type or a subtype.
Cause: An attempt was made to create an attribute set from an evolved ADT or a subtype.
Action: The ADT used for the attribute set cannot be an evolved type or a subtype.
ORA-38478: creation of system trigger EXPFIL_DROPOBJ_MAINT failed
Cause: The creation of the system trigger EXPFIL_DROPOBJ_MAINT failed due to missing Expression Filter dictionary tables.
Action: Try a clean installation again. If this error is ignored, the Expression Filter dictionary could have some stale entries.
ORA-38479: creation of system trigger EXPFIL_RESTRICT_TYPEEVOLVE failed
Cause: The creation of system trigger EXPFIL_RESTRICT_TYPEEVOLVE failed due to missing Expression Filter dictionary tables.
Action: Try a clean installation again. If this error is ignored, the user will be able to evolve ADTs associated with the attribute set, thus causing spurious errors.
ORA-38480: creation of system trigger EXPFIL_ALTEREXPTAB_MAINT failed.
Cause: The creation of system trigger EXPFIL_ALTEREXPTAB_MAINT failed due to errors in SYS.EXF$DBMS_EXPFIL_SYSPACK package.
Action: Try a clean installation again. If this error is ignored, a RENAME of the expression table may cause the EVALUATE queries to fail.
ORA-38481: ADT "string" is used for a dependent object.
Cause: An attempt was made to create an attribute set from an ADT which is used by one or more dependent objects.
Action: Use a new ADT instead.
ORA-38482: no elementary attributes defined in the attribute set
Cause: An attempt was made to use an empty attribute set.
Action: Create one or more elementary attributes for the attribute set.
ORA-38483: invalid FUNCTION/PACKAGE/TYPE name: "string"
Cause: An attempt was made to use an invalid name format.
Action: The function/package/type name should be specified in the following format [owner.]object_name
ORA-38484: FUNCTION/PACKAGE/TYPE string does not exist
Cause: Attempt was made to use a object that does not exist.
Action: Query ALL_OBJECT view to ensure that the object exists.
ORA-38485: invalid object type for the user-defined function
Cause: An attempt was made to use an invalid object as a function.
Action: Valid object types are FUNCTION / PACKAGE / TYPE
ORA-38486: FUNCTION/PACKAGE/TYPE already exists for the attribute set
Cause: An attempt was made to add a duplicate function to the list.
Action: Use a different object name.
ORA-38487: FUNCTION/PACKAGE/TYPE "string" not allowed in the expression
Cause: An attempt was made to use an un-approved function in the expression.
Action: Add the function to the corresponding attribute set
ORA-38488: attribute set already assigned to the column storing expressions
Cause: An attempt was made to reassign an attribute set to an expression column.
Action: Query USER_EXPFIL_EXPRESSION_SETS view to find the attribute set assigned the expression set
ORA-38489: predicate table creation failed due to: ORAstring
Cause: Predicate table creation failed due to the reported error.
Action: Set serveroutput ON for additional information
ORA-38490: invalid name: quotes do not match
Cause: The quotes in the name did not match.
Action: Correct the name to match the quotes.
ORA-38491: could not evaluate subexpression for rowid "string"
Cause: Either the expression was not in a valid SQL-WHERE clause format or it had references to nonexistent schema objects.
Action: Correct the expression.
ORA-38492: invalid ALTER INDEX parameters clause "string"
Cause: An invalid parameters clause was specified with the ALTER INDEX command.
Action: See documentation for a valid list of parameters.
ORA-38493: feature not enabled : Expression Filter index
Cause: An attempt was made to create an Expression Filter index in Standard Edition.
Action: Do not attempt to use this feature.
ORA-38494: column in the table alias and an attribute have matching names
Cause: One of the attributes in the set has the same name as the name of one of the columns in the table configured for table alias.
Action: If possible, use a different name for the attribute.
ORA-38495: data type for the stored attribute string is inconsistent.
Cause: The actual data type for the stored attribute configured for the Expression Filter index object did not match the data type recorded in the Expression Filter dictionary.
Action: Delete the attribute from the default index attributes and recreate it.
ORA-38496: Expression Filter index is not in a valid state
Cause: An attempt was made to REBUILD an Expression Filter index that was not valid.
Action: Use DEFAULT keyword in the parameters clause to rebuild the index from defaults or drop and recreate the index.
ORA-38497: Expression Filter index does not exist
Cause: Index with a matching name does not exist or the index was not created using ExpFilter indextype.
Action: Identify the correct index using the Expression Filter catalog views
ORA-38498: invalid stored attribute for the index object : string
Cause: The expression filter index object has a stored or indexed attribute that had broken dependencies.
Action: Make sure that all the identifiers used in the attribute are valid.
ORA-38499: expression set already configured for stored/indexed attributes
Cause: The expression set already had a list of stored and indexed attributes. Additional attributes cannot be specified in the CREATE INDEX parameters clause.
Action: Remove TOP, STOREATTRS and INDEXATTRS clauses from the parameters clause or clear the expression set statistics using DBMS_EXPFIL.INDEX_PARAMETERS API.
ORA-38500: %s
Cause: There was a generic error
Action: See documentation for further information.
ORA-38501: sub-query not allowed in the expression
Cause: An attempt was made to use a sub-query in the expression.
Action: Do not use sub-queries in the expressions.
ORA-38502: invalid XML tag: string
Cause: An attempt was made to use an invalid XML tag for the index.
Action: Correct the XML tag and retry.
ORA-38503: index already defined using the parameters
Cause: An attempt was made to modify the index parameters after the index creation.
Action: Drop the index and retry.
ORA-38504: this operator not allowed with the configured attribute set
Cause: An attempt was made to use the operator binding with an attribute set containing more than one (table alias) attribute. This is not permitted.
Action: Use a different operator binding.
ORA-38601: FI Not enough memory for frequent itemset counting: string
Cause: The memory size did not satisfy the minimum memory requirement.
Action: In workarea_size_policy='manual' mode, set _fic_area_size to a reasonably larger value. Or, In workarea_size_policy='auto' mode, this error should never happen.
ORA-38602: FI invalid input cursor
Cause: The input cursor did not return exactly two columns for transactional input format or the input cursor didn't have consistent data types for horizontal input format
Action: For transactional input format, specify that the input cursor returns exactly two columns: one for transaction-id, one for item-id. For horizontal input format, make sure the input cursor's columns have the same data types.
ORA-38603: FI including & excluding cursor can only return one column
Cause: The including & excluding cursor did not return exactly one column.
Action: Specify that the cursor return only one column: item-id.
ORA-38604: FI including & excluding cursor item-id type must match input cursor item-id type
Cause: The including & excluding cursor item-id type did not match input cursor item-id type
Action: Specify that the item-id type of the cursors match each other.
ORA-38605: FI not enough memory(stringK) for candidate generation(stringK)
Cause: There was insufficient available memory for candidate generation.
Action: In workarea_size_policy='manual' mode, set _fic_area_size to a reasonably larger value. Or, in workarea_size_policy='auto' mode, set pga_aggregate_target to a reasonably larger value.
ORA-38606: FI support threshold not between [0, 1]
Cause: The user inputed a support threshold not in the range of [0, 1].
Action: The user should adjust the input value in the range of [0, 1].
ORA-38607: FI minimum and maximum itemset length not between [1, string]
Cause: The inputed minimum or maximum itemset length exceed the internal maximum itemset length or less than 1.
Action: The user should adjust the input value not larger than the internal maximum itemset length and not less than 1.
ORA-38608: FI itemset minimum-length(string) should not be greater than maximum length(string)
Cause: The user inputed minimum length is more than maximum length.
Action: The user should adjust the input values to make the minimum length less than or equal to the maximum length.
ORA-38609: FI Not enough memory for tree counting, requires at least stringKB
Cause: The memory size did not satisfy the minimum memory requirement for tree counting.
Action: In workarea_size_policy='manual' mode, set _fic_area_size to a reasonably larger value. Or, In workarea_size_policy='auto' mode, this error should never happen.
ORA-38610: FI "string" name prefix is reserved for frequent itemset counting
Cause: An error occurred because DBMS_FREQUENT_ITEMSET and prefix ORA_FI are reserved for the DBMS_FREQUENT_ITEMSET package's internal use.
Action: Do not re-define functions with names starting with DBMS_FREQUENT_ITEMSET package or ORA_FI.
ORA-38611: FI input cursor's item type is not supported
Cause: The input cursor's item type is not number or character type
Action: Redefine the input cursor so that item type is number or character type.
ORA-38612: FI item length cannot exceed half of one database block.
Cause: The item's length was more than half of one database block.
Action: Redefine the data type of the item column so that its maximum length is less than half of one database block.
ORA-38700: Limit of string flashback database logs has been exceeded.
Cause: The maximum number of flashback database log files was exceeded.
Action: DB_FLASHBACK_RETENTION_TARGET may be set to high. Modify it to a smaller value.
ORA-38701: Flashback database log string seq string thread string: "string"
Cause: This message reports the filename for details of another message.
Action: Other messages will accompany this message. See the associated messages for the appropriate action to take.
ORA-38702: Cannot update flashback database log file header.
Cause: Could not write to the flashback database log file.
Action: Restore access to the file.
ORA-38703: Type string in header is not a flashback database log file.
Cause: A corrupt flashback database log file header was read.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38704: Checksum error in flashback database log file header.
Cause: The flashback database log file header contained a checksum that does not match the value calculated from the file header as read from disk. This means the file header was corrupt.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38705: Expected block size string does not match string in log header.
Cause: When the flashback log file header was read, the block size in the control file did not match the block size contained in the header.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38706: Cannot turn on FLASHBACK DATABASE logging.
Cause: An ALTER DATABASE FLASHBACK ON command failed. Other messages in the alert log describe the problem.
Action: Fix the problem and retry.
ORA-38707: Media recovery is not enabled.
Cause: An ALTER DATABASE FLASHBACK ON command failed because media recovery was not enabled.
Action: Turn on media recovery with an ALTER DATABASE ARCHIVELOG command and then retry the command.
ORA-38708: not enough space for first flashback database log file
Cause: An ALTER DATABASE FLASHBACK ON command failed because there was not enough space in the Recovery Area for the first flashback database log file.
Action: Make more space in the Recovery Area. For example, this can be done by increasing the value of DB_RECOVERY_FILE_DEST_SIZE.
ORA-38709: Recovery Area is not enabled.
Cause: An ALTER DATABASE FLASHBACK ON command failed because the Recovery Area was not enabled.
Action: Set DB_RECOVERY_FILE_DEST to a location and retry.
ORA-38710: Flashback log version string is incompatible with ORACLE version string.
Cause: The flashback database log file was rejected because it appeared to be written by an incompatible version of Oracle.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38711: Corrupt flashback log block header: block string
Cause: A corrupt Flashback Database log file block header was read. More information was dumped to the trace file.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38712: Corrupt flashback log record header: block string, offset string.
Cause: A corrupt flashback database log record header was read. Either the record type or length were incorrect. More information was dumped to the trace file.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38713: Flashback Database logging is already turned on.
Cause: An ALTER DATABASE FLASHBACK ON command had no effect because flashback database logging was already on.
Action: No action required.
ORA-38714: Instance recovery required.
Cause: An ALTER DATABASE FLASHBACK ON command failed because the database either crashed or was shutdown with the ABORT option.
Action: Open the database and then enter the SHUTDOWN command with the NORMAL or IMMEDIATE option.
ORA-38715: Invalid log number specified in the DUMP FLASHBACK command.
Cause: An invalid log number was used when dumping a flashback database log file.
Action: Specify a valid flashback database log number.
ORA-38716: Must supply an integer for the TYPE option.
Cause: An invalid value was specified for TYPE in the DUMP FLASHBACK command.
Action: Specify an integer value.
ORA-38717: Invalid DUMP FLASHBACK option.
Cause: An invalid option was specified in the DUMP FLASHBACK command. Currently the only options allowed are: DBA, TYPE, and LOGICAL.
Action: Retry the command with the correct options.
ORA-38718: Invalid thread number specified in the DUMP FLASHBACK command.
Cause: An invalid thread number was used in dumping the flashback database log files for a thread.
Action: Specify a valid thread number.
ORA-38719: Invalid DUMP FLASHBACK object.
Cause: An invalid object was specified in a DUMP FLASHBACK command. Currently the only objects allowed are: LOGFILE or THREAD.
Action: Retry the command with the correct options.
ORA-38720: Missing log file number.
Cause: A log file number was missing in a DUMP FLASHBACK LOGFILE command.
Action: Supply a valid log file number.
ORA-38721: Invalid file number.
Cause: An invalid file number was specified in the DBA clause of a DUMP FLASHBACK command.
Action: Supply a valid file number.
ORA-38722: ON or OFF expected.
Cause: The ALTER DATABASE FLASHBACK command was specified without the ON or OFF keyword.
Action: Retry the command with the ON or OFF keyword.
ORA-38723: Invalid SCN expression.
Cause: The SCN keyword was specified in a FLASHBACK DATABASE command but the SCN expression was invalid.
Action: Retry the command using a valid SCN number.
ORA-38724: Invalid option to the FLASHBACK DATABASE command.
Cause: An invalid option was specified to the FLASHBACK DATABASE command. Valid options are: SCN or TIMESTAMP.
Action: Correct the syntax and retry the command.
ORA-38725: specified name "string" does not match actual "string"
Cause: The database name specified in a FLASHBACK DATABASE command did not match the name of the currently mounted database.
Action: Correct the database name spelling or DISMOUNT the mounted database and mount the correct database.
ORA-38726: Flashback database logging is not on.
Cause: A FLASHBACK DATABASE command was tried but flashback database logging has not been enabled.
Action: Flashback database logging must be enabled via the ALTER DATABASE FLASHBACK ON command before a FLASHBACK DATABASE command can be tried. If the database must be taken back in time then a restore and incomplete recovery must be performed.
ORA-38727: FLASHBACK DATABASE requires a current control file.
Cause: The control file being used is a backup control file.
Action: FLASHBACK DATABASE cannot be used with a backup control file. If the database must be taken back in time then a restore and an incomplete recovery must be performed.
ORA-38728: Cannot FLASHBACK DATABASE to the future.
Cause: An SCN or time stamp provided in a FLASHBACK DATABASE command was in the future.
Action: Supply a proper SCN or time stamp and retry the command.
ORA-38729: Not enough flashback database log data to do FLASHBACK.
Cause: There was not enough flashback database log data to do the FLASHBACK DATABASE.
Action: If the database must be taken back in time then a restore and incomplete recovery must be performed.
ORA-38730: Invalid SCN/TIMESTAMP expression.
Cause: The expression supplied in a FLASHBACK DATABASE command was invalid.
Action: Retry the command using a valid number or time stamp expression.
ORA-38731: Expected version string does not match string in log header.
Cause: The version of the flashback database log file header was corrupt.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38732: Expected file size string does not match string.
Cause: The file size indicated in the control file did not match the file size contained in the flashback log file header. The flashback database log file was corrupt.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38733: Physical size string less than needed string.
Cause: A flashback database log file shrank in size. This was likely to have been caused by operator or operating system error.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38734: Flashback log is inconsistent; belongs to another database.
Cause: The database ID in the flashback database log file did not match the database ID in the control file.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38735: Wrong log number string in flashback log file header.
Cause: The log file number in the flashback database log file did not match the control file.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38736: Wrong thread number string in flashback log file header.
Cause: The thread number in the flashback database log file did not match the control file.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38737: Expected sequence number string doesn't match string
Cause: The flashback database log is corrupted or is an old version.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38738: Flashback log file is not current copy.
Cause: A check of flashback database log file header at database open found that the flashback database log appeared to be an incorrectly restored backup. Flashback database log files cannot be backed up and restored.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38739: Flashback log file is more recent than control file.
Cause: The control file change sequence number in the flashback database log file was greater than the number in the control file. This implies that the wrong control file was being used. Note that repeatedly causing this error can make it stop happening without correcting the real problem. Every attempt to open the database will advance the control file change sequence number until it is great enough.
Action: FLASHBACK DATABASE can only be used with the current control file. If it is not available, then a restore and an incomplete recovery must be performed instead.
ORA-38740: Usable blocks value string is not valid.
Cause: A flashback database log file header contained a usable blocks value greater than the file size. The flashback database log file file is corrupt.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38741: Formatted blocks value string is not valid.
Cause: The formatted blocks value in the flashback database log file was greater than the file size. The flashback database log file was corrupt.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38742: Flashback log file has incorrect log reset status.
Cause: The flashback database log file header had log reset data that was different than the control file. The log was probably an incorrectly restored backup. Flashback database logs cannot be backed up.
Action: If you are doing a FLASHBACK DATABASE, then the flashback cannot be performed because of the corrupted log. A restore and an incomplete recovery must be performed instead.
ORA-38743: Time/SCN is in the future of the database.
Cause: The Time/SCN provided in a FLASHBACK DATABASE command was in the future of the database.
Action: Retry the command with a correct Time/SCN or RECOVER the database.
ORA-38744: file string is not the same file seen at start of flashback
Cause: A different copy of the file was accessed the last time FLASHBACK DATABASE looked at the file header. A backup of the file was restored or the meaning of the file name changed during FLASHBACK DATABASE.
Action: Ensure the correct file is available, then retry FLASHBACK DATABASE.
ORA-38746: error occurred while restoring data block (file# string, block# string)
Cause: An error occurred during a FLASHBACK DATABASE command. See other errors on error stack.
Action: Investigate why the error occurred. It may be that the flashback database log data is corrupt. If so, a restore and an incomplete recovery must be performed instead.
ORA-38747: corrupt before image (file# string, block# string)
Cause: A corrupt data block before image was encountered during a FLASHBACK DATABASE command.
Action: The flashback log data is probably corrupt. If so, a restore and an incomplete recovery must be performed instead.
ORA-38748: cannot flashback data file string - file is in use or recovery
Cause: An attempt to do FLASHBACK DATABASE found that the file was not available for recovery. Either it was online and the database was open in some instance, or another process was currently doing media recovery or flashback on the file.
Action: Do not do FLASHBACK DATABASE.
ORA-38749: A media recovery has been started.
Cause: An attempt was made to start a FLASHBACK DATABASE in the same session as a media recovery.
Action: Complete or cancel the first media recovery session.
ORA-38750: FLASHBACK DATABASE may not be performed using a dispatcher.
Cause: An attempt was made to use a dispatcher process for FLASHBACK DATABASE. Memory requirements disallow this recovery method.
Action: Connect to the instance via a dedicated server process to perform FLASHBACK DATABASE.
ORA-38752: file string does not exist
Cause: During an RMAN FLASHBACK DATABASE conversation, a file was listed which was not part of the database. The RMAN conversation was aborted.
Action: Retry the conversation with the appropriate file numbers.
ORA-38753: Cannot flashback data file string; no flashback log data.
Cause: An attempt to perform a FLASHBACK DATABASE failed because the file does not have enough flashback log data to cover the time to flash back. Either the file did not have flashback generation enabled for it, or had flashback generation turned off for it some time during the time span of the flashback.
Action: The file cannot be flashed back. The file must be taken offline or the tablespace dropped before continuing with the FLASHBACK DATABASE command.
ORA-38754: FLASHBACK DATABASE not started; required redo log is not available
Cause: A FLASHBACK DATABASE command did not start. A redo log needed for the recovery part of FLASHBACK DATABASE could not be found or accessed.
Action: See trace files for details of the problem.
ORA-38755: Flashback is already turned on for this tablespace.
Cause: An attempt was made to turn on flashback database logging for a tablespace that already has flashback turned on.
Action: No action required.
ORA-38756: Flashback is already turned off for this tablespace.
Cause: An attempt was made to turn off flashback database logging for a tablespace that already has flashback off.
Action: No action required.
ORA-38757: Database must be mounted EXCLUSIVE and not open to FLASHBACK.
Cause: An attempt to Flashback a database was made when the database was not mounted EXCLUSIVE or was already open.
Action: Mount the database EXCLUSIVE and retry the FLASHBACK command.
ORA-38758: cannot flashback data file string; restored since last recovery
Cause: An attempt to do FLASHBACK DATABASE found that the file was restored since the last standby recovery. The file cannot be flashed back.
Action: The file must be taken offline before continuing with the FLASHBACK DATABASE command.
ORA-38759: Database must be mounted EXCLUSIVE and not open.
Cause: An attempt to turn on or off Flashback Database logging was made when the database was not mounted EXCLUSIVE or was already open.
Action: Mount the database EXCLUSIVE and retry the command.
ORA-38760: This database instance failed to turn on flashback database
Cause: Database flashback is on but this instance failed to start generating flashback data. Look in alert log for more specific errors.
Action: Correct the error or turn off database flashback.
ORA-38761: thread string redo log sequence number string could not be accessed
Cause: A redo log needed for the recovery portion of FLASHBACK could not be read or opened. The FLASHBACK operation failed.
Action: Restore the log and retry the FLASHBACK command.
ORA-38762: thread string redo log with scn string could not be found
Cause: A redo log needed for the recovery portion of FLASHBACK could not be found. The FLASHBACK operation failed.
Action: Restore the log and retry the FLASHBACK command.
ORA-38763: flashback not started; enabled threads have changed
Cause: A FLASHBACK DATABASE command did not start. The set of enabled threads changed during the time to flash back.
Action: The flashback cannot be performed. Perform a restore and an incomplete recovery instead.
ORA-38764: flashback not started; datafile string enabled threads are different
Cause: A FLASHBACK DATABASE command did not start. The datafile was restored from a backup taken when the enabled threads were different than at the time of the flashback.
Action: The flashback cannot be performed. Perform a restore and an incomplete recovery instead.
ORA-38765: Flashed back database cannot be opened read-only.
Cause: A complete recovery was performed after a database flashback but the database was not opened for read-write access, or a FLASHBACK DATABASE command failed.
Action: If a complete recovery was performed after a database flashback, open the database for read-write access. If a FLASHBACK DATABASE command failed, fix what caused the command to fail and retry the command, or recover and open the database for read-write access.
ORA-38766: cannot flashback data file string; file resized smaller
Cause: An attempt to do FLASHBACK DATABASE found that the file was shrunk during the time to flash back.
Action: The file cannot be flashed back. The file must be taken offline or the tablespace dropped before continuing with the FLASHBACK DATABASE command.
ORA-38767: flashback retention target parameter mismatch
Cause: The value of parameters DB_FLASHBACK_RETENTION_TARGET must be same in all instances. All databases must have same flashback retention target parameters.
Action: Check DB_FLASHBACK_RETENTION_TARGET values in all instances.
ORA-38768: resizing datafile string failed
Cause: An operating system error occurred when Flashback Database tried to shrink (resize) a datafile. Flashback shrinks a file in order to undo the effects of a file expand, for example, an autoextension of the file.
Action: Recover the database to return it to its previous state, or fix the cause of the operating system error and retry the Flashback. If that is not possible, then the file can be taken offline and the Flashback command retried. The file will have to be restored from a backup and rolled forward.
ORA-38769: FLASHBACK DATABASE failed after modifying data.
Cause: A FLASHBACK DATABASE command failed after modifying the the database. Look in the alert log for more information about the failure.
Action: Recover the database to return it to its previous state, or fix the cause of the error and retry the Flashback.
ORA-38770: FLASHBACK DATABASE failed during recovery.
Cause: A FLASHBACK DATABASE command successfully restored the database but failed during the recovery step. Look in the alert log for more information about the failure.
Action: Fix the error and then recover the database to the same SCN or timestamp used in the FLASHBACK DATABASE command.
ORA-38771: unnamed datafile(s) added to controlfile by flashback recovery
Cause: The recovery step of FLASHBACK DATABASE encountered the creation of a datafile that could not be added to the controlfile. An entry has been added to the controlfile for the new datafile, but with the file name UNNAMEDnnnn, where nnnn is the file number. Related error messages provide the file names that were originally used to create the files.
Action: Rename the file in the controlfile, or use the ALTER ALTER DATABASE CREATE DATAFILE command to create a file suitable for recovery. If the file is not going to be recovered, then take it offline with the FOR DROP option. The recovery step of Flashback can be resumed by entering a RECOVERY command with the same SCN or timestamp as used in the FLASHBACK DATABASE command. For example, RECOVER AUTOMTAIC DATABASE UNTIL CHANGE <flashback-scn>.
ORA-38772: cannot add datafile 'string' - file could not be created
Cause: The recovery step of FLASHBACK DATABASE encountered the creation of a datafile and could not recreate the file. The error from the creation attempt is displayed in another message. The controlfile file entry for the file is 'UNNAMEDnnnnn'.
Action: Use the ALTER DATABASE CREATE DATAFILE statement to create the file.
ORA-38773: cannot add data file 'string' - file already part of database
Cause: The recovery step of FLASHBACK database encountered the creation of a datafile and could not create the file because the file name is already in use in the database. The controlfile file entry for the file is 'UNNAMEDnnnnn'.
Action: Use the ALTER DATABASE CREATE DATAFILE statement to create the file with a different name.
ORA-38774: cannot disable media recovery - flashback database is enabled
Cause: An attempt was made to disable media recovery while flashback database was enabled.
Action: Use the ALTER DATABASE FLASHBACK OFF statement to disable flashback database, then disable media recovery.
ORA-38775: cannot disable flash recovery area - flashback database is enabled
Cause: An attempt was made to set DB_RECOVERY_FILE_DEST to null while flashback database was enabled. Flashback database requires DB_RECOVERY_FILE_DEST to be set.
Action: Use the ALTER DATABASE FLASHBACK OFF statement to disable flashback database, then disable the flash recovery area.
ORA-38776: cannot begin flashback generation - flash recovery area is disabled
Cause: During a database mount, the RVWR process discovered that the flash recovery area was disabled. DB_RECOVERY_FILE_DEST must have been set null or removed from the INIT.ORA file while the database was unmounted.
Action: Flashback database requires the flash recovery area to be enabled. Either enable the flash recovery area by setting the DB_RECOVERY_FILE_DEST and DB_RECOVERY_FILE_DEST_SIZE initialization parameters, or turn off flashback database with the ALTER DATABASE FLASHBACK OFF command.
ORA-38900: missing mandatory column "string" of error log table "string"
Cause: Mandatory column of error logging table is not present
Action: Add the named column to the error logging table. Consult ORACLE documentation for the correct data type.
ORA-38901: column "string" of table "string" must be one of the first "number" columns
Cause: Mandatory information column of error logging table is present, but must be at the beginning of the row.
Action: Create the error logging table correctly. Consult ORACLE documentation for the correct format of an error logging table.
ORA-38950: Source platform string not cross platform compliant
Cause: Cross platform transport was not allowed for this platform.
Action: For a list of supported platforms, query fixed view SYS.V$TRANSPORTABLE_PLATFORM.
ORA-38951: Target platform string not cross platform compliant
Cause: Cross platform transport was not allowed for this platform.
Action: none
ORA-38952: Source database not 10.0.0.0 compatible
Cause: Cross platform transport is not supported unless database compatibility is advanced to 10.0.0.0 or higher
Action: Use the compatible parameter to advance source database compatibility and redo the transport
ORA-38954: Cross platform transport is not supported between source platform identifier string and target platform identifier string
Cause: The platform identifier in the transported file indicated that the datafile format was different than the target database datafile format.
Action: For a list of supported platforms, query fixed view SYS.V$TRANSPORTABLE_PLATFORM. If both platforms are present, Contact Oracle support
ORA-38955: Source platform string not cross platform compliant
Cause: The platform identifier in the transported file indicated that this platform is not supported for a cross platform transport.
Action: For a list of supported platforms, query fixed view SYS.V$TRANSPORTABLE_PLATFORM.
ORA-38956: Target platform string not cross platform compliant
Cause: Cross platform transport was not allowed for this platform.
Action: For a list of supported platforms, query fixed view SYS.V$TRANSPORTABLE_PLATFORM.
ORA-38957: Target database not 10.0.0.0 compatible
Cause: Cross platform transport is not supported unless database compatibility is advanced to 10.0.0.0 or higher
Action: Use the compatible parameter to advance source database compatibility
ORA-38958: Source platform string is in different byte order than target platform string
Cause: Probably a conversion was not done before the import phase of the transport.
Action: Use RMAN CONVERT functionality to convert endian ordering.
ORA-38959: Failed to update block 0 to new version 10 format
Cause: An attempt was made to update block 0 to version 10 format.
Action: check additional error messages and contact Oracle Support Services.
ORA-39000: bad dump file specification
Cause: The user specified a dump file that could not be used in the current job. Subsequent error messages describe the inadequacies of the dump file.
Action: Specify a dump file that is usable for the job.
ORA-39001: invalid argument value
Cause: The user specified API parameters were of the wrong type or value range. Subsequent messages supplied by DBMS_DATAPUMP.GET_STATUS will further describe the error.
Action: Correct the bad argument and retry the API.
ORA-39002: invalid operation
Cause: The current API cannot be executed because of inconsistencies between the API and the current definition of the job. Subsequent messages supplied by DBMS_DATAPUMP.GET_STATUS will further describe the error.
Action: Modify the API call to be consistent with the current job or redefine the job in a manner that will support the specified API.
ORA-39003: unable to get count of total workers alive
Cause: Attempt to get count of total worker processes alive failed.
Action: Check the additional error messages to see what caused the failure. Correct the error, if possible, and try the operation again. If this error occurs from a Data Pump client (e.g. expdp or impdp), try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-39004: invalid state
Cause: The state of the job precludes the execution of the API.
Action: Rerun the job to specify the API when the job is an appropriate state.
ORA-39005: inconsistent arguments
Cause: The current API cannot be executed because of inconsistencies between arguments of the API call. Subsequent messages supplied by DBMS_DATAPUMP.GET_STATUS will further describe the error.
Action: Modify the API call to be consistent with itself.
ORA-39006: internal error
Cause: An unexpected error occurred while processing a Data Pump job. Subsequent messages supplied by DBMS_DATAPUMP.GET_STATUS will further describe the error.
Action: Contact Oracle Customer Support.
ORA-39012: Client detached before the job started.
Cause: The client detached or ended their session before the Data Pump job was started.
Action: Create new job and remain attached to the job until it is started.
ORA-39013: All of the workers exited before the job completed.
Cause: All of the worker processes exited before the job was completed. With no workers, the master process will terminate the job.
Action: Rerun the job. If problem persists, contact Oracle Customer Support.
ORA-39014: One or more workers have prematurely exited.
Cause: One or more of the worker processes exited before the job was completed. With no workers, the master process will terminate the job.
Action: Rerun the job. If problem persists, contact Oracle Customer Support.
ORA-39015: job is not running
Cause: An API was executed that required the job to be running, but the job was not active.
Action: Retry the API. If problem persists, contact Oracle Customer Support.
ORA-39016: Operation not supported when job is in string state.
Cause: The state of the job precludes the execution of the API.
Action: Rerun the job to specify the API when the job is an appropriate state.
ORA-39017: Worker request not supported when job is in string state.
Cause: The state of the job precludes the execution of a worker request. This is an internal error.
Action: Contact Oracle Customer Support.
ORA-39018: master process received invalid message number string
Cause: Internal Error
Action: Contact Oracle Customer Support.
ORA-39019: invalid operation type string
Cause: User specified an invalid operation name on an DBMS_DATAPUMP.OPEN API or an invalid operation name was specified in the master table for a restart API.
Action: Correct the operation name and recreate the job.
ORA-39020: invalid mode type string
Cause: User specified an invalid mode on an DBMS_DATAPUMP.OPEN API or an invalid mode was specified in the master table for a restart API.
Action: Correct the mode and recreate the job.
ORA-39021: Database compatibility version string is not supported.
Cause: User selected COMPATIBLE as the version on an DBMS_DATAPUMP.OPEN API, but the current database compatibility version is not supported by the Data Pump API. Database versions before 9.2 are not supported by the Data Pump.
Action: Specify a supported version and recreate the job.
ORA-39022: Database version string is not supported.
Cause: User selected LATEST as the version on an DBMS_DATAPUMP.OPEN API, but the current database version is not supported by the Data Pump API. Database versions before 9.2 are not supported by the Data Pump.
Action: Specify a supported version and recreate the job.
ORA-39023: Version string is not supported.
Cause: User specified an explicit version on an DBMS_DATAPUMP.OPEN API, but the current database version is not supported by the Data Pump API. Database versions before 9.2 are not supported by the Data Pump.
Action: Specify a supported version and recreate the job.
ORA-39024: wrong schema specified for job
Cause: Internal error caused by the master process finding inconsistencies between the schemas specified for the job.
Action: Contact Oracle Customer Support.
ORA-39025: jobs of type string are not restartable
Cause: Attempt to restart a job which was not restartable.
Action: Recreate the job via the open API.
ORA-39026: master table is inconsistent on validation string
Cause: Job cannot be restarted because it failed a validation check. Validation checks are of the form -xx.y where -xx is the value of the PROCESS_ORDER column in the master table where the error was detected and y is the actual validity check for the row.
Action: Recreate the job. If master table has not been modified, but problem persists, contact Oracle Customer Support.
ORA-39027: wrong version of master table
Cause: Job cannot be restarted because the version of the database upon which the job started is different than the current version of the database and the format of the master table has changed between the versions.
Action: Recreate the job.
ORA-39028: cannot restart job from string state
Cause: The job was not in a suitable state for restart. Jobs must begin executing before they can be restarted.
Action: Recreate the job.
ORA-39029: worker string with process name "string" prematurely terminated
Cause: The specified worker process terminated unexpectedly. Subsequent messages describe the reason for the termination.
Action: If problem persists, contact Oracle Customer Support.
ORA-39030: invalid file type string
Cause: An invalid filetype was specified for an DBMS_DATAPUMP.ADD_FILE API call.
Action: Correct the filetype parameter and reissue the API request.
ORA-39031: invalid filter name string
Cause: An invalid filter name was specified on a DBMS_DATAPUMP.DATA_FILTER
Action: Correct the filter name parameter and reissue the API request.
ORA-39032: function string is not supported in string jobs
Cause: The specified API is not supported for the specified class of jobs.
Action: Recreate the job with the appropriate mode or operation type.
ORA-39033: SUBQUERY data filter is inconsistent with direct path
Cause: The user specified that the data access method for the job was direct which precludes the use of the SUBQUERY filter.
Action: Use SUBQUERY data filter with automatic data access method.
ORA-39034: Table string does not exist.
Cause: The user referenced a table in an API that did not exist.
Action: Correct table name and retry API.
ORA-39035: Data filter string has already been specified.
Cause: The user has already specified a data filter that matches on the filter name, schema name, and table.
Action: Specify a different data filter.
ORA-39036: invalid metadata filter name string
Cause: An invalid metadata filter name was specified on a DBMS_DATAPUMP.METADATA_FILTER API call.
Action: Correct the metadata filter name parameter and reissue the API request.
ORA-39037: Object type path not supported for string metadata filter.
Cause: An object type path was specified for the filter, but the filter does not support the object type path parameter.
Action: Remove the object type path parameter.
ORA-39038: Object path "string" is not supported for string jobs.
Cause: The specified object type path is invalid for the job mode.
Action: Correct the object type path.
ORA-39039: Schema expression "string" contains no valid schemas.
Cause: The specified SCHEMA_EXPR filter resulted in no schemas being selected.
Action: Correct the the SCHEMA_EXPR filter specification.
ORA-39040: Schema expression "string" must identify exactly one schema.
Cause: For TABLE mode jobs, the SCHEMA_EXPR filter must identify exactly one schema.
Action: Correct the the SCHEMA_EXPR filter specification.
ORA-39041: Metadata filter has no selectivity.
Cause: INCLUDE_PATH_EXPR or EXCLUDE_PATH_EXPR Metadata filter either returns all objects or no objects in the job.
Action: Correct the the metadata filter specification.
ORA-39042: invalid transform name string
Cause: An invalid transform name was specified on a DBMS_DATAPUMP.METADATA_TRANSFORM API call.
Action: Correct the transform name parameter and reissue the API request.
ORA-39043: Object type string is not supported for string jobs.
Cause: The specified object type is invalid for the job mode.
Action: Correct the object type.
ORA-39044: Metadata transform string has already been specified.
Cause: The user has already specified the metadata transform for the same class of object types.
Action: Specify a different object_type for the transform.
ORA-39045: invalid metadata remap name string
Cause: An invalid metadata remap name was specified on a DBMS_DATAPUMP.METADATA_REMAP API call.
Action: Correct the metadata remap name parameter and reissue the API request.
ORA-39046: Metadata remap string has already been specified.
Cause: The user has already specified a metadata remap that matches on the remap name and original value.
Action: Specify a different original value.
ORA-39047: Jobs of type string cannot use multiple execution streams.
Cause: The user specified a value of parallelism that is precluded by the operation type or mode of the job.
Action: Specify only a parallelism of 1 for this type of job.
ORA-39048: Unable to start all workers; only string worker(s) available.
Cause: The full degree of parallelism could not be honored due process limits, resource limits, or other internal errors.
Action: Increase process/resource limits for the job.
ORA-39049: invalid parameter name string
Cause: An invalid parameter name was specified on a DBMS_DATAPUMP.SET_PARAMETER API call.
Action: Correct the parameter name and reissue the API request.
ORA-39050: parameter string is incompatible with parameter string
Cause: Two parameters were set that were incompatible with each other. Only the first parameter setting will be used.
Action: Decide which parameter is to be used and stick to it.
ORA-39051: parameter string specified multiple times
Cause: The user has already specified a parameter that matches on the name and the specific parameter doesn't support duplicate definitions.
Action: Specify non-repeatable parameters only once.
ORA-39052: cannot specify SKIP_CURRENT on initial start of a job.
Cause: The user has already specified SKIP_CURRENT for a job that has never executed.
Action: Only specify SKIP_CURRENT when restarting a job.
ORA-39053: parameter or attribute string must be defined for a string job
Cause: The job being defined cannot be started because it is missing the specified definition.
Action: Specify the omitted parameter or attribute before starting the job.
ORA-39054: missing or invalid definition of the SQL output file.
Cause: The job being defined cannot be started because it is missing the file to receive the SQL output of the job or the definition is unusable.
Action: Specify a valid directory name and file name for the SQL file.
ORA-39055: invalid bad file specification.
Cause: The bad file for the job was incorrectly specified.
Action: Specify a valid directory name and file name for the bad file.
ORA-39056: invalid log file specification.
Cause: The log file for the job was incorrectly specified.
Action: Specify a valid directory name and file name for the log file.
ORA-39057: invalid worker request string for string jobs.
Cause: The worker process sent a message that wasn't supported for the current job.
Action: Internal error -- contact Oracle Customer Support and report the error.
ORA-39058: current object skipped: string of type string
Cause: The user specified SKIP_CURRENT when restarting a job. This message is a confirmation that the object will not be imported.
Action: User must manually define the object in the target database.
ORA-39059: dump file set is incomplete
Cause: An IMPORT or SQL_FILE operation was being performed but not all of the files from the EXPORT dump file set were included.
Action: Check the export log file and make sure all of the files that were exported are included in the current job.
ORA-39060: table(s) dropped because of conflict with master table
Cause: A table specified by a job was not included because its definition would collide with the master table definition for the current job.
Action: After the job completes. Import the conflicting tables using a unique job name to avoid conflicts with normal user tables.
ORA-39061: import mode string conflicts with export mode string
Cause: The mode used for import cannot be used with a dump file set of specified mode. Transportable jobs are not compatible with other modes.
Action: Perform the import using a mode compatible with the export.
ORA-39062: error creating master process string
Cause: An attempt to create the listed master process failed.
Action: Refer to any following error messages for possible actions. Check the trace log for the failed process to see if there is any information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-39064: unable to write to the log file
Cause: Errors were detecting while writing to the log file. Subsequent messages will detail the problems.
Action: Fix the problems outlined in the secondary messages.
ORA-39065: unexpected master process exception in string
Cause: An unhandled exception was detected internally within the master control process for the Data Pump job. This is an internal error. messages will detail the problems.
Action: If problem persists, contact Oracle Customer Support.
ORA-39067: Unable to close the log file.
Cause: Errors were detecting while closing the log file. Subsequent messages will detail the problems.
Action: Fix the problems outlined in the secondary messages.
ORA-39068: invalid master table data in row with PROCESS_ORDER=string
Cause: A corruption was detected in the master table in the specified row(s). Either the row wasn't found, it was missing columns or had illegal values in its columns.
Action: Rerun the job with an uncorrupted master table.
ORA-39070: Unable to open the log file.
Cause: Errors were detecting while opening the log file. Subsequent messages will detail the problems.
Action: Fix the problems outlined in the secondary messages.
ORA-39071: Value for string filter is badly formed.
Cause: The value of the user specified filter did not contain legitimate SQL clause. Subsequent messages will detail the problems.
Action: Fix the problems outlined in the secondary messages.
ORA-39076: cannot delete job string for user string
Cause: Unable to delete a job. Refer to the any following or prior error messages for clarification.
Action: Eliminate the problems indicated.
ORA-39077: unable to subscribe agent string to queue "string"
Cause: The Data Pump's communication layer was unable to attach one of its processes to the control or status queue. Subsequent messages will detail the problem.
Action: Fix the problem if possible, or contact Oracle Customer Support.
ORA-39078: unable to dequeue message for agent string from queue "string"
Cause: The Data Pump's communication layer was unable to retrieve a message from the control or status queue. Subsequent messages will detail the problem.
Action: Fix the problem if possible, or contact Oracle Customer Support.
ORA-39079: unable to enqueue message string
Cause: The Data Pump's communication layer was unable to send the specified message on the control or status queue. Subsequent messages will detail the problem.
Action: Fix the problem if possible, or contact Oracle Customer Support.
ORA-39080: failed to create queues "string" and "string" for Data Pump job
Cause: The Data Pump's communication layer was unable to create the status and control queues required for interprocess communication. Subsequent messages will detail the problem.
Action: Fix the problem if possible, or contact Oracle Support.
ORA-39081: failed to unsubscribe agent string from queue "string"
Cause: The Data Pump's communication layer was unable to unsubscribe a process from the control or status queue. Subsequent messages will detail the problem.
Action: Fix the problem if possible, or contact Oracle Customer Support.
ORA-39082: Object type string created with compilation warnings
Cause: The object in the SQL statement following this error was created with compilation errors. If this error occurred for a view, it is possible that the base table of the view was missing.
Action: This is a warning. The object may have to be recompiled before being used.
ORA-39083: Object type string failed to create with error: string Failing sql is: string
Cause: Examine original error code to determine actual cause
Action: Original error code will contain more information
ORA-39084: cannot detach job string for user string
Cause: Unable to detach a job from the session. Refer to any following error messages for clarification.
Action: Eliminate the problems indicated.
ORA-39085: cannot update job string for user string
Cause: Unable to update the fixed table information for a job. Refer to any following or prior error messages for clarification.
Action: Eliminate the problems indicated.
ORA-39086: cannot retrieve job information
Cause: Unable to retrieve fixed table information for a job. Refer to the secondary error messages that follow this one for clarification.
Action: Eliminate the problems indicated by the secondary errors.
ORA-39087: directory name string is invalid
Cause: A corresponding directory object does not exist.
Action: Correct the directory object parameter, or create a corresponding directory object with the CREATE DIRECTORY command.
ORA-39088: file name cannot contain a path specification
Cause: The name of a dump file, log file, or sql file contains a path specification.
Action: Use the name of a directory object to indicate where the file should be stored.
ORA-39090: Cannot add devices to file oriented job.
Cause: Attempt to add a device to a job that already contains more than one disk file.
Action: Only specify one file for jobs that contain sequential devices.
ORA-39091: unable to determine logical standby and streams status
Cause: An error occurred when determining if the Data Pump job needed to support logical standby or streams.
Action: The subsequent message describes the error that was detected. Correct the specified problem and restart the job.
ORA-39092: unable to set SCN metadata for object "string.string" of type string
Cause: An error occurred when applying a SCN to the specified object to support logical standby or streams.
Action: The subsequent message describes the error that was detected. Correct the specified problem and restart the job.
ORA-39093: FLASHBACK automatically enabled to preserve database integrity.
Cause: A Data Pump job was required to enable flashback support to specific SCNs in order to preserve the consistency of a logical standby or streams instantiation.
Action: None
ORA-39094: Parallel execution not supported in this database edition.
Cause: Parallel execution of Data Pump jobs is not supported for this database edition.
Action: Specify a parallelism of 1 for jobs not running on Enterprise Edition databases.
ORA-39095: Dump file space has been exhausted: Unable to allocate string bytes
Cause: The Export job ran out of dump file space before the job was completed.
Action: Reattach to the job and add additional dump files to the job restarting the job.
ORA-39096: invalid input value string for parameter string
Cause: A NULL or invalid value was supplied for the parameter.
Action: Correct the input value and try the call again.
ORA-39097: Data Pump job encountered unexpected error string
Cause: An unexpected, potentially non-fatal error occurred while processing a Data Pump job.
Action: Contact Oracle Customer Support.
ORA-39098: Worker process received data objects while loading metadata. Invalid process order range is string..string
Cause: This is an internal error. Messages will detail the problem.
Action: If problem persists, contact Oracle Customer Support.
ORA-39099: cannot create index for "string" on master table string
Cause: One or more indexes couldn't be created on the master table. subsequent error messages describe the failure.
Action: Correct the condition that is preventing the indexes from being created.
ORA-39102: Timeout before master process string finished initialization. Master error:
Cause: The master process whose name is listed started up but did not finish its initialization within the allowed time limit.
Action: Refer to any following error messages for possible actions. Also, check the trace log for the failed process, if one was created, to see if there is any additional information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-39103: Timeout before worker process string finished initialization. Worker error:
Cause: The worker process whose name is listed started up but did not finish its initialization within the allowed time limit.
Action: Refer to any following error messages for possible actions. Also, check the trace log for the failed process, if one was created, to see if there is any additional information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-39104: cannot call this function from a SQL parallel query slave process
Cause: Called a Data Pump process model function from a process which is a SQL parallel query slave process
Action: A SQL parallel query slave process cannot create a Data Pump master process. This is not supported. If this error occurs from a Data Pump client (for example, expdp or impdp), contact Oracle Customer Support and report the error.
ORA-39105: Master process string failed during startup. Master error:
Cause: The master process whose name is listed failed during startup.
Action: Refer to any following error messages for possible actions. Also, check the trace log for the failed process, if one was created, to see if there is any additional information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-39106: Worker process string failed during startup. Worker error:
Cause: The worker process whose name is listed failed during startup.
Action: Refer to any following error messages for possible actions. Also, check the trace log for the failed process, if one was created, to see if there is any additional information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-39107: Master process string violated startup protocol. Master error:
Cause: The master process whose name is listed started up but then exited before notifying the creating process that it was finished with initialization.
Action: Refer to any following error messages for possible actions. Also, check the trace log for the failed process, if one was created, to see if there is any additional information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-39108: Worker process string violated startup protocol. Worker error:
Cause: The worker process whose name is listed started up but then exited before notifying the creating process that it was finished with initialization.
Action: Refer to any following error messages for possible actions. Also, check the trace log for the failed process, if one was created, to see if there is any additional information about the failure. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-39109: Unprivileged users may not operate upon other users' schemas
Cause: An unprivileged user attempted to reference another user's schema during a Data Pump operation. Because of this, no schemas were were selected for the job.
Action: Retry the operation under a username owning the schema.
ORA-39110: error deleting worker processes
Cause: An attempt to delete the worker processes failed.
Action: Refer to any following error messages for possible actions. Correct the error, if possible, and try the operation again. If the error occurs again, contact Oracle Customer Support and report the error.
ORA-39111: Dependent object type string skipped, base object type string already exists
Cause: During a Data Pump import job, a dependent object is being skipped because its base object already existed.
Action: If the object from the dump file is wanted, drop the base and dependent objects and try to import again using desired filters.
ORA-39112: Dependent object type string skipped, base object type string creation failed
Cause: During a Data Pump import job, a dependent object is being skipped because its base object creation failed.
Action: If the object from the dump file is wanted, drop the base and dependent objects and try to import again using desired filters
ORA-39113: Unable to determine database version
Cause: The Data Pump was unable to determine the compatibility level and version of the current database using SYS.DBMS_UTILITY.DB_VERSION.
Action: Make sure access to the DBMS_UTILITY package is granted to you. If this is a network job, be sure that access to the DBMS_UTILITY package is granted to you on the remote instance.
ORA-39114: Dump files are not supported for string jobs
Cause: An attempt was made to add a dumpfile to a job not configured for dumpfiles. Dumpfiles are not allowed in Export ESTIMATE_ONLY jobs or in Import/Sql_file jobs over a network link.
Action: Do not specify a dumpfile for jobs that do not require dumpfiles.
ORA-39115: %s is not supported over a network link
Cause: An attempt was made to use an option that is not supported over network links such as the PARTITION_LIST filter.
Action: Do not attempt to use Data Pump features on network jobs if they are not compatible with jobs over the network.
ORA-39116: invalid trigger operation on mutating table string.string
Cause: A Data Pump load operation failed because a trigger attempted to fire on the table while it was mutating.
Action: Disable trigger(s) on the specified table. Also see ORA-004091.
ORA-39117: Type needed to create table is not included in this operation. Failing sql is: string
Cause: A create table was attempted and a dependent type does not exist in the dumpfile or on the target database. Either the export or the import Data Pump job was a table mode job and types are not included in table mode jobs.
Action: Determine which type(s) are missing and create them on the target system and run the Data Pump import job again.
ORA-39119: worker process interrupt for delete worker processes call by master process
Cause: The master process that created this worker process called delete worker processes to abort the current operation.
Action: No action is necessary. This is an informational error message.
ORA-39120: Table string can't be truncated, data will be skipped. Failing error is: string
Cause: Table data was about to be loaded into a table that already existed and the table_exists_action parameter is truncate, but the table could not be truncated.
Action: Determine actual cause by looking at base error.
ORA-39121: Table string can't be replaced, data will be skipped. Failing error is: string
Cause: Table data was about to be loaded into a table that already existed and the table_exists_action parameter is replace, but the table could not be dropped.
Action: Determine actual cause by looking at base error.
ORA-39122: Unprivileged users may not perform string remappings.
Cause: A user attempted to remap objects during an import but lacked the IMPORT_FULL_DATABASE privilege.
Action: Retry the job from a schema that owns the IMPORT_FULL_DATABASE privilege.
ORA-39123: Data Pump transportable tablespace job aborted string
Cause: A DBMS_PLUGTS procedure failed and the Data Pump operation could not continue so it was aborted. The DBMS_PLUGTS failure listed describes the original error.
Action: Look at the DBMS_PLUGTS error to determine actual cause.
ORA-39124: dump file name "string" contains an invalid substitution variable
Cause: The substitution variable '%' must be followed by '%','u', or 'U'.
Action: Correct the substitution variable in the dump file name and re-enter the command.
ORA-39125: Worker unexpected fatal error in string while calling string [string]
Cause: An unhandled exception was detected internally within the worker process for the Data Pump job while calling the specified external routine. This is an internal error. Additional information may be supplied.
Action: If problem persists, contact Oracle Customer Support.
ORA-39126: Worker unexpected fatal error in string [string] string
Cause: An unhandled exception was detected internally within the worker process for the Data Pump job. This is an internal error. Additional information may be supplied.
Action: If problem persists, contact Oracle Customer Support.
ORA-39127: unexpected error from call to string string
Cause: The exception was raised by the function invocation, a procedural action extension of export.
Action: Record the accompanying messages and report this as a Data Pump internal error to customer support.
ORA-39128: unexpected DbmsJava error number from statement string
Cause: The error was returned from a call to a DbmsJava procedure.
Action: Record the accompanying messages and report this as a Data Pump internal error to customer support.
ORA-39129: Object type string not imported. Name conflicts with the master table
Cause: The table being imported from the remote instance has the same name as the master table running this Data Pump job.
Action: Rerun the Data Pump job with a nonconflicting name.
ORA-39130: Object type string not imported. Base object name conflicts with the master table
Cause: The object being imported from the remote instance is dependent on an object that has the same name as the master table running this Data Pump job.
Action: Rerun the Data Pump job with a nonconflicting name.
ORA-39132: object type "string"."string" already exists with different hashcode
Cause: An object type could not be created because there was already a type with the same name but a different hashcode on the target system. Tables in the transportable tablespace set that use this object type cannot be read.
Action: Drop the object type from the target system and retry the operation.
ORA-39133: object type "string"."string" already exists with different typeid
Cause: An object type in a transportable tablespace set already exists on the target system, but with a different typeid. The typeid could not be changed because the type is used by an existing table. Tables in the transportable tablespace set that use this object type cannot be read.
Action: Drop the object type from the target system and retry the operation.
ORA-39134: Cannot include "string" tablespace as a Transportable Tablespace
Cause: The user attempt to specify the SYSAUX or SYSTEM tablespace as a member of the transportable tablespace list in the current job. These tablespaces may not be transported between databases.
Action: Specify different tablespaces to be transported.
ORA-39135: SYS schema cannot read data using specific SCNs
Cause: The user was operating under the SYS schema and either explicitly specified an SCN via the FLASHBACK_SCN or FLASHBACK_TIME or TABLE_CONSISTENCY parameters or the job required that a specific SCN be used because of streams or logical replication activity.
Action: Do not perform Data Pump jobs using the SYS schema or 'AS SYSDBA'.
ORA-39136: cannot specify an SCN on a transportable job
Cause: A target SCN was specified for a table in a transportable job by the streams or logical standy components which was not the defaulted SCN for the table.
Action: This is an internal error. Please report it to Oracle support.
ORA-39137: cannot specify a TABLE_EXISTS_ACTION of string for a job with no metadata
Cause: A job was defined with the TABLE_EXISTS_ACTION parameter set to REPLACE or SKIP, but without metadata. Without metadata, data could not be loaded for the requested table actions.
Action: Change the setting of the TABLE_EXISTS_ACTION parameter to APPEND or TRUNCATE or supply Metadata with the data.
ORA-39138: Insufficient privileges to load data not in your schema
Cause: An unprivileged user attempted to load data into a different schema.
Action: Use a privileged account if you must load data not in your schema
ORA-39139: Data Pump does not support XMLSchema objects. string will be skipped.
Cause: Object has XMLSchema-based columns, which are unsupported by Data Pump.
Action: Use the original exp and imp utilities to move this object.
ORA-39140: dump file "string" belongs to job string
Cause: When a dump file set consists of multiple files, all files in the set must be specified for an import operation, and all files must have been produced by the same export job. One of the files provided does not belong to the original dump file set. For instance, it was created by a different export job than the other files.
Action: Remove the dump file indicated in the message and retry the import operation providing only the complete set of dump files created by a specific export job.
ORA-39141: dump file "string" is a duplicate of dump file "string"
Cause: When a dump file set consists of multiple files, all files in the set must be specified for an import operation. One of the files provided to import was found to be a duplicate of another dump file in the set. This can occur if the files in the dump set were copied or renamed using operating system utilities and the same dump file was inadvertently copied more than once with different destination names.
Action: Remove the dump file indicated in the message and retry the import operation providing only the complete set of dump files created by a specific export job.
ORA-39142: incompatible version number string in dump file "string"
Cause: A dump file was specified for an import operation whose version number is incompatible with the dump file version of the Data Pump product currently running on the system. Usually this message indicates that the dump file was produced by a newer version of the Data Pump export utility.
Action: Import this dump file using the Data Pump import utility with the same version as the export which created the file.
ORA-39143: dump file "string" may be an original export dump file
Cause: A dump file was specified for an import operation which appears to have been created using the original export utility. These dump files cannot be processed by the Data Pump import utility.
Action: Try using the original import utility to process this dump file.
ORA-39144: file name parameter must be specified and non-null
Cause: No file name was provided in an DBMS_DATAPUMP.ADD_FILE API call.
Action: Correct the file name parameter and reissue the API request.
ORA-39145: directory object parameter must be specified and non-null
Cause: No directory object was provided in either an DBMS_DATAPUMP.ADD_FILE API call or to the directory parameter used by the Data Pump command line clients.
Action: Correct the directory object parameter and retry the operation.
ORA-39146: schema "string" does not exist
Cause: The specified schema was referenced as the source of a REMAP_SCHEMA parameter, but did not exist in the dump file (for
Action: Specify the correct name of the schema to be remapped.
ORA-39147: cannot migrate Data Pump queue table ownership to this instance
Cause: There are active Data Pump jobs running on another instance in a RAC. All concurrent, active Data Pump jobs must be run on the same instance.
Action: Start this job on the same instance where other active Data Pump jobs are running, or wait until they finish.
ORA-39148: unable to import data into pre-existing queue table string. Table_exists_action of string being ignored for this table
Cause: A Data Pump import detected that a queue table that was to be imported already exists. Importing data into pre-existing queue tables is not supported.
Action: If the data from the dump file is desired, then drop the queue table and perform the import again, or use the import parameter table_exists_action=replace.
ORA-39149: cannot link privileged user to non-privileged user
Cause: A Data Pump job initiated be a user with EXPORT_FULL_DATABASE/IMPORT_FULL_DATABASE roles specified a network link that did not correspond to a user with equivalent roles on the remote database.
Action: Specify a network link that maps users to identically privileged users in the remote database.
ORA-39150: bad flashback time
Cause: A flashback time was specified for the Data Pump job which either could not be parsed or else could not be translated into a system change number (SCN). This typically occurs when
Action: Specify an explicit SCN for the desired flashback rather than a time.
ORA-39301: schema does not exist or is in use
Cause: The specified schema does not exist, or app upgrade still in progress.
Action: Provide an alternative schema or stop the upgrade in progress in the schema.
ORA-39302: schema clone operation failed
Cause: Clone can not reach a consistent state after a few iterations. This can happen if the source schema is changing rapidly.
Action: Re-start clone from scratch.
ORA-39303: schema sync/swap operation fail because of confilcts
Cause: There are conflicting changes to objects in source and target schema. This might happen if an object has been changed in both schemas.
Action: Re-start clone from scratch.
ORA-39304: during sync/swap, object "string" conflicts: "string"
Cause: Conflicting changes to objects in source and target schemas. This might happen if an object has been changed in both schemas.
Action: Do sync/swap/validation_check with ignore_conflict/force_sync parameters(TRUE), or Re-start clone from scratch.
ORA-39305: specified schema "string" does not exist
Cause: The schema you specified does not exist.
Action: Specify the correct schema, or correct a target schema if it is target schema.
ORA-39306: the schema "string" mismatch: require the schema "string"
Cause: The schema you specified does not match the schema in the initial clone operation.
Action: Specify the correct schema, or re-start clone from scratch if it is a new set of clone/sync/swap operation.
ORA-39307: the operation is illegal without an initial clone
Cause: The operation: sync/swap/validation/clean_up requires an initial clone operation.
Action: Start an clone operation.
ORA-39308: application/database upgrade internal error: "string"
Cause: An unexpected error occurred while processing the application/database upgrade.
Action: Check outside factor, e.g. enough tablespaces. and re-try it. If thr error persists, contact Oracle Customer Support.
ORA-39309: schema sync operation failed
Cause: Clone can not reach a consistent state after a few iterations. This can happen if the source schema is changing rapidly.
Action: Re-start sync operation.
ORA-39310: illegal clean_failed_clone() call: it only applys to failed clones
Cause: Operation clean_failed_clone is illegal here. This can happen if last operation is not a clone, or is done sucessfully.
Action: IF you want to clean up target schema, call clean_target().
ORA-39311: illegal clone_recovery() call: it only applys to failed clones
Cause: Operation clone_recovery is illegal here. This can happen if last operation is not a clone, or is done sucessfully.
Action: Apply other appropriate operations.
ORA-39312: illegal clean_target() call: last clone operation is failed
Cause: Operation clean_target is illegal here. This can happen if last clone operation is failed.
Action: Only available operations are clean_failed_clone or clone_recovery.
ORA-39313: illegal clone() call: clone has been done before
Cause: Operation clone() is illegal here. This can happen if a clone operation has been done before.
Action: apply other operations, or call clean_up() before clone().
ORA-39314: illegal sync_code() call: only applys after clone/sync_code
Cause: Operation sync_code() is illegal here. This can happen if last operation is not clone or sync_code.
Action: apply other operations.
ORA-39315: illegal swap() call: only applys after clone/sync_code
Cause: Operation swap() is illegal here. This can happen if last operation is not clone or sync_code. However, swap() can be applies to other cases if the parameter 'force_swap' is TRUE.
Action: apply other operations, or set force_swap to TRUE.
ORA-39316: illegal clean_up() call: last clone operation is failed
Cause: Operation clean_up() is illegal here. This can happen if last clone operation is failed. To clean up failed clone, call clean_failed_clone.
Action: Only available operations are clean_failed_clone or clone_recovery.
ORA-39317: illegal validation_check() call: only applys after clone/sync_code/valdation_check
Cause: Operation validation_check() is illegal here. This can happen if last operation is not clone/sync_code/valdation_check.
Action: Run clone/sync_code/valdation_check, or clean_up() for new clone.
ORA-39500: failed to notify CRS of a Startup/Shutdown event for database "string", instance "string" (ignored)
Cause: The instance was unable to obtain the context or information required to notify the CRS framework.
Action: None Required. The error is ignored.
ORA-39501: failed to notify CRS of a Startup/Shutdown event [number] (ignored)
Cause: The instance was unable to communicate with the CRS framework.
Action: None Required. The error is ignored.
ORA-39502: failed to notify CRS of a Startup/Shutdown event [number] (ignored)
Cause: The instance was unable to create an environment context.
Action: None Required. The error is ignored.
ORA-39503: failed to notify CRS of a Startup/Shutdown event [number] (ignored)
Cause: The instance was unable to populate the environment context.
Action: None Required. The error is ignored.
ORA-39504: failed to notify CRS of a Startup/Shutdown event [number] (ignored)
Cause: The instance was unable to find the location of the alert file.
Action: None Required. The error is ignored.
ORA-39600: Queue keys needs to be a suffix of cluster key.
Cause: Attempt to specify queue key columns that don't form a suffix of the cluster key.
Action: Only specify queue key columns as a suffix of cluster key.
ORA-39601: Hash key is required.
Cause: Missing hash key in the cluster key specification.
Action: Specify one or more hash key columns.
ORA-39700: database must be opened with UPGRADE option
Cause: The database has not been upgraded, but a standard database open was attempted.
Action: Use the UPGRADE option when opening the database to indicate that the database is being opened for upgrade.
ORA-39701: database must be mounted EXCLUSIVE for UPGRADE or DOWNGRADE
Cause: The database was mounted for SHARED cluster access.
Action: Set the CLUSTER_DATABASE initialization parameter to FALSE and restart the server with the UPGRADE or DOWNGRADE option.
ORA-39702: database not open for UPGRADE or DOWNGRADE
Cause: An upgrade, downgrade, reload, or patch script was invoked when the database was not open for UPGRADE or DOWNGRADE.
Action: Use STARTUP UPGRADE to open the database for upgrade or to apply a patch set. Use STARTUP DOWNGRADE for running a downgrade script or the reload script.
ORA-39703: server version and script version do not match
Cause: An upgrade, downgrade, reload, or patch script was invoked, but the database instance version was not the version for which the script was intended.
Action: Check that the correct ORACLE_HOME and ORACLE_SID environment variables are set. Also check that the SQL script is being invoked from the correct ORACLE_HOME.
ORA-39704: permission to modify component registry entry denied
Cause: An attempt was made to modify an entry in the component registry, but the session user was not authorized; only the CONTROL or SCHEMA user for the component are authorized to modify the component registry entry.
Action: Connect as either the CONTROL or SCHEMA user for the component.
ORA-39705: component 'string' not found in registry
Cause: No entry in the component registry was found for the specfied component.
Action: Check the spelling of the component ID and use the DBA_REGISTRY view to list the existing components.
ORA-39706: schema 'string' not found
Cause: The schema name specified was not found in the database.
Action: Create the schema before loading the component.
ORA-39707: compatibile parameter string too high for downgrade to string
Cause: A downgrade was attempted, but the compatible initialization parameter value was greater than the downgrade release version.
Action: Once the compatible value has been raised, downgrade to earlier releases is not supported.
ORA-39708: component 'string' not a string component
Cause: The component was not a component for the specified namespace.
Action: Either enter a valid component identifier for the namespace or set the session namespace to the correct component namespace.
ORA-39709: incomplete component downgrade; string downgrade aborted
Cause: One or more components did not have a status of DOWNGRADED.
Action: Correct the component problem and re-run the downgrade script.
ORA-39726: unsupported add/drop column operation on compressed tables
Cause: An unsupported add/drop column operation for compressed table was attemped.
Action: When adding a column, do not specify a default value. DROP column is only supported in the form of SET UNUSED column (meta-data drop column).
ORA-39727: COMPATIBLE must be set to 10.0.0.0.0 or higher
Cause: An add/drop column operation for compressed table has been performed on the database. This requires COMPATIBLE to be set to 10.0.0.0.0 or higher during upgrade from 9.2 to a 10i or higher release.
Action: Set COMPATIBLE to 10.0.0.0.0 and retry the upgrade.
ORA-39751: partitioned table on both sides of PARTITIONED OUTER JOIN is not supported
Cause: An attempt was made to partition both sides of PARTITIONED OUTER JOIN.
Action: Specify partitioned table on one side of PARTITIONED OUTER JOIN only.
ORA-39752: redundent column in partitioning and join columns is not allowed
Cause: An attempt was made to sepcify redundent columns in partitioning and join columns for NATURAL or named column PARTITIONED OUTER JOIN.
Action: Do not specify redundent column in partitioning and join columns.
ORA-39753: unsupported use of subquery in PARTITIONED OUTER JOIN condition
Cause: An attempt was made to use subquery in PARTITIONED OUTER JOIN condition.
Action: Remove subquery from the join condition.
ORA-39754: FULL PARTITIONED OUTER JOIN is not supported
Cause: An attempt was made to use FULL PARTITIONED OUTER JOIN.
Action: Specify FULL PARTITIONED OUTER JOIN through UNION of LEFT and RIGHT PARITTION OUTER JOIN.
ORA-39950: invalid parameter for PLSQL warnings flag
Cause: The user either entered invalid value for the PLSQL_WARNINGS flag or the value of the flag conflicts with other values.
Action: Enter correct values for the switch.
ORA-39951: incomplete values specified for PL/SQL warning settings
Cause: The user either did not enter the value for the settings or entered incomplete values.
Action: Enter correct syntax for the switch.
ORA-39952: only numbers can be specified as range values
Cause: The range values did not have numerical values only.
Action: Enter only numerical values.
ORA-39953: the range value specified is beyond allowed range
Cause: The range values were either too low or too high.
Action: Specify only the allowed range values.
ORA-39954: DEFERRED is required for this system parameter
Cause: The ALTER SYSTEM command for PLSQL_WARNINGS did not include the keyword, DEFERRED.
Action: Change the command to use the keyword, DEFERRED.
ORA-39955: invalid PL/SQL warning message number
Cause: The PL/SQL message number specified was not in a valid range.
Action: Specify PL/SQL warning message numbers within the valid range.
ORA-39956: duplicate setting for PL/SQL compiler parameter string
Cause: A PL/SQL compiler parameter was set more than once.
Action: Remove the duplicate PL/SQL compiler setting.
ORA-39957: invalid warning category
Cause: The category of the message was incorrect.
Action: Specify a vaild category
ORA-39958: invalid warning category qualifier
Cause: The category qualifier was incorrect.
Action: Specify a vaild category qualifier.
ORA-39959: invalid warning number (string)
Cause: The warning number was incorrect.
Action: Specify a vaild warning number.
ORA-39960: scope can only be SYSTEM or SESSION
Cause: The scope specified was not set.
Action: Specify a vaild scope, either SESSION or SYSTEM.
ORA-39961: message specified was not found
Cause: The message number specified was not set.
Action: specify the message number whise settings have been set in the given scope. /// MAX ERROR NUMBER 65535 /// EOF - Add errors till 40000 ABOVE this line. REGISTER at errorinf.txt


20 ORA-40001 to ORA-40273

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

20 ORA-40001 to ORA-40273

ORA-40001: value for string must be greater than zero
Cause: The input parameter in question has a value of zero or less.
Action: Provide a value greater than zero for the relevant parameter.
ORA-40002: wordsize must be string or greater
Cause: The input wordsize is less than the prescribed limit for the BLAST Match or Align algorithm.
Action: Provide a wordsize greater than or equal to the prescribed value.
ORA-40003: wordsize must be in the range string - string for BLAST-P
Cause: The input wordsize has a value out of the prescribed range.
Action: Provide a wordsize value within the prescribed range for BLAST-P.
ORA-40004: penalty must be negative for BLAST-N
Cause: The input value provided for penalty is zero or greater.
Action: Provide a negative penalty value.
ORA-40101: Data Mining System Error string-string-string
Cause: An internal system error occured during a data mining operation.
Action: Contact Oracle Support Services.
ORA-40102: invalid input string for data mining operation string
Cause: The input parameter is either null or invalid for the given operation.
Action: Provide a valid value. Check range for NUMBER parameters.
ORA-40103: invalid case-id column: string
Cause: The column designated as case-id is not of one of CHAR, VARCHAR2, NUMBER data type. Case-id columns of type CHAR and VARCHAR2 must be of length less than or equal to 128 bytes.
Action: Change the schema of your input data to supply a case-id column of appropriate data type and/or length.
ORA-40104: invalid training data for model build
Cause: The training data provided in the reported table is unsuitable for build, either because it is empty, has unsuitable data, or the schema of the table does not match the input specifications.
Action: Inspect the training data and correct the contents/schema as appropriate.
ORA-40105: input data incompatible with model signature
Cause: The data provided for this post-build operation is in format different from that used for model build.
Action: Provide data whose attribute data types match the build data. Input data attributes must have the same data types as those described in the model signature for the model.
ORA-40106: positive target value not specified for computing Lift
Cause: Positive target value has not been specified for Lift.
Action: Provide a positive target value for the Lift operation.
ORA-40107: operation requires string option to be installed
Cause: The specified option has not been installed with the RDBMS.
Action: Install the reported option and retry the operation.
ORA-40108: input data contains too few distinct target (string) values
Cause: At least two distinct target values are required for Build.
Action: Provide counter-example target values in the input data.
ORA-40201: invalid input parameter string
Cause: The input parameter was either null or invalid.
Action: Provide a valid value for the input parameter.
ORA-40202: column string does not exist in the input table string
Cause: The column was missing from the table.
Action: Correct the table schema and/or provide the correct column name.
ORA-40203: model string does not exist
Cause: The model did not exist.
Action: Supply a valid model name.
ORA-40204: model string already exists
Cause: A model by the same name exists.
Action: Provide a different, unique name for the model.
ORA-40205: invalid setting name string
Cause: The input setting name was invalid.
Action: Consult the documentation for the settings table and provide a valid setting name.
ORA-40206: invalid setting value for setting name string
Cause: The input value for the given setting name was invalid.
Action: Consult the documentation for the settings table and provide a valid setting value.
ORA-40207: duplicate or multiple function settings
Cause: The input settings table contained settings for multiple mining functions.
Action: Provide setting(s) for a single function in the settings table.
ORA-40208: duplicate or multiple algorithm settings for function string
Cause: The input settings table had duplicate or multiple algorithm settings for a mining function.
Action: Provide only one appropriate algorithm setting for the mining function.
ORA-40209: setting % is invalid for % function
Cause: The specified setting was not supported for the mining function supplied.
Action: Provide appropriate combination of function and algorithm settings.
ORA-40211: algorithm name string is invalid
Cause: Algorithm name for the model was invalid or the operation was not valid for the algorithm.
Action: Check the algorithm name for the model and verify that the operation is valid.
ORA-40212: invalid target data type in input data for string function
Cause: Target data type was invalid.
Action: Classification function accepts CHAR,VARCHAR2, and NUMBER targets. Regression function accepts NUMBER targets only.
ORA-40213: contradictory values for settings: string, string
Cause: The settings values were not compatible.
Action: Check the documentation and change the setting value(s).
ORA-40214: duplicate setting: string
Cause: Duplicate setting in the settings table.
Action: Remove the duplicate setting from the settings table.
ORA-40215: model string is incompatible with current operation
Cause: The current operation was not supported for the mining function the model corresponds to.
Action: Provide the model name suitable for current operation.
ORA-40216: feature not supported
Cause: The feature was not supported in the API.
Action: Modify the code to avoid usage of the feature.
ORA-40219: apply result table string is incompatible with current operation
Cause: The current operation was not allowed for the apply result table supplied.
Action: Make sure the operation being performed is valid for the mining function used to build the model (using which the apply result table was created).
ORA-40220: maximum number of attributes exceeded
Cause: The data had too many attributes.
Action: Reduce the dimensionality of the data.
ORA-40221: maximum target cardinality exceeded
Cause: The target cardinality of the training data was too high.
Action: Reduce the target cardinality.
ORA-40222: data mining model export failed, job name=string, error=string
Cause: The model export job failed.
Action: Check export job settings as required by DataPump.
ORA-40223: data mining model import failed, job name=string, error=string
Cause: The model import job failed.
Action: Check import job settings as required by DataPump.
ORA-40225: model is currently in use by another process
Cause: The model is currently in use by another process.
Action: Retry if necessary.
ORA-40251: no support vectors were found
Cause: The input data is non-predictive in nature, or one of the input settings is incorrect/incompatible with respect to the input data.
Action: Provide additional data or change model setting value.
ORA-40252: no target values were found
Cause: No target values were identified during load.
Action: Validate that the target is correctly specified.
ORA-40253: no target counter examples were found
Cause: One or more of the target classes have only positive examples.
Action: Provide counter examples or remove that target class.
ORA-40261: input data for model build contains negative values
Cause: The input data contains negative values, which is not acceptable for a Non-negative Matrix Factorization model.
Action: Provide clean data for build without any negative values.
ORA-40262: NMF: number of features not between [1, string]
Cause: The number of requested features must be greater than 1, and less than the smaller of the number of attributes and the number of cases in the dataset.
Action: Specify the desired number of features within the acceptable range.
ORA-40271: no statistically significant features were found
Cause: Input data inadequate in volume and/or quality to derive statistically significant predictions for building a Adaptive Bayes Network model.
Action: Provide a well-prepared training data set.
ORA-40272: apply rules prohibited for this model mode
Cause: Adaptive Bayes Network rules are only generated for SingleFeature ABN models
Action: Rebuild model in SingleFeature mode and then apply with rules.
ORA-40273: invalid model type string for Adaptive Bayes Network algorithm
Cause: The valid values for the abns_model_type settings are: abns_multi_feature, abns_single_feature, abns_naive_bayes.
Action: Use a valid value for the abns_model_type setting.


21 EXP-00000 to EXP-00105

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

21 EXP-00000 to EXP-00105

EXP-00000: Export terminated unsuccessfully
Cause: Export encountered an Oracle error.
Action: Look up the accompanying Oracle message in the ORA message chapters of this manual, and take appropriate action.
EXP-00001: data field truncation - column length=number, buffer size=number actual size=number
Cause: Export could not fit a column in the data buffer.
Action: Record the given size parameters and the accompanying messages and report this as an Export internal error to customer support. (Part of the table has been exported. Export will continue with the next table.)
EXP-00002: error in writing to export file
Cause: Export could not write to the export file, probably because of a device error. This message is usually followed by a device message from the operating system.
Action: Take appropriate action to restore the device.
EXP-00003: no storage definition found for segment(number, number)
Cause: Export could not find the storage definitions for a cluster, index, or table.
Action: Record the accompanying messages and report this as an Export internal error to customer support.
EXP-00004: invalid username or password
Cause: An invalid username or password was specified.
Action: Retry with a valid username and password.
EXP-00005: all allowable logon attempts failed
Cause: Attempts were repeatedly made to log on with an invalid username or password.
Action: Shut down the utility, then restart and retry with a valid username and password.
EXP-00006: internal inconsistency error
Cause: Export's data structure was corrupted.
Action: Record the accompanying messages and report this as an Export internal error to customer support.
EXP-00007: dictionary shows no columns for string.string
Cause: Export failed to gather column information from the data dictionary. The table may have been dropped.
Action: Retry the export and, if this error recurs, report it as an Export internal error to customer support.
EXP-00008: ORACLE error number encountered
Cause: Export encountered the referenced Oracle error.
Action: Look up the Oracle message in the ORA message chapters of this manual and take appropriate action.
EXP-00009: no privilege to export string's table string
Cause: An attempt was made to export another user's table. Only a database administrator can export another user's tables.
Action: Ask your database administrator to do the export.
EXP-00010: %s is not a valid username
Cause: An invalid username was specified.
Action: Shut down the utility, then restart and retry with a valid username.
EXP-00011: %s.string does not exist
Cause: Export could not find the specified table.
Action: Retry with the correct table name.
EXP-00012: %s is not a valid export mode
Cause: An invalid export mode was specified.
Action: Retry with a valid export mode.
EXP-00013: respond with either 'Y', 'N', RETURN or '.' to quit
Cause: An invalid response was entered.
Action: Enter any of the responses shown in the message.
EXP-00014: error on row number of table string
Cause: Export encountered an Oracle error while fetching rows.
Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action.
EXP-00015: error on row number of table string, column string, datatype number
Cause: Export encountered an error while fetching or writing the column. An accompanying message gives more information.
Action: Correct the error and try again.
EXP-00016: ORACLE error encountered while reading default auditing options
Cause: Export encountered an Oracle error while reading the default auditing options (those for updates, deletes, and so on).
Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action.
EXP-00017: feature "string" is needed, but not present in database
Cause: The command entered requires the specified feature. Either that feature is not installed, or the row describing the feature is missing from table V$OPTION
Action: Reinstall Oracle with the feature specified in the message.
EXP-00018: datatype (number) for column string, table string.string is not supported
Cause: Export does not support the referenced datatype.
Action: Retry with an acceptable datatype (CHAR, NUMBER, DATE, LONG, or RAW).
EXP-00019: failed to process parameters, type 'EXP HELP=Y' for help
Cause: Invalid command-line parameters were specified.
Action: Check the online help screen for the set of valid parameters, then retry.
EXP-00020: failed to allocate memory of size number
Cause: Export failed to allocate the necessary memory.
Action: Decrease the export buffer size so that less memory is required, or increase the runtime memory size for Export.
EXP-00021: can only perform incremental export in Full Database mode
Cause: USER or TABLE mode was specified when doing an incremental export.
Action: Specify FULL database mode (FULL=Y) and retry.
EXP-00022: must be SYS or SYSTEM to do incremental export
Cause: The privileges needed to do an incremental export do not exist. Only a data base administrator can do incremental exports.
Action: Ask the database administrator to do the incremental export.
EXP-00023: must be a DBA to do Full Database or Tablespace export
Cause: The privileges needed to do a FULL database export do not exist. Only a database administrator can do a FULL database export.
Action: Ask the database administrator to do the FULL database export.
EXP-00024: Export views not installed, please notify your DBA
Cause: The necessary Export views were not installed.
Action: Ask the database administrator to install the required Export views.
EXP-00025: dictionary shows no column for constraint string.number
Cause: Export failed to gather column information about the referenced constraint from the data dictionary. The constraint may have been altered.
Action: Retry the export and, if this error recurs, report it as an Export internal error to customer support.
EXP-00026: conflicting modes specified
Cause: Conflicting export modes were specified.
Action: Specify only one parameter and retry.
EXP-00027: failed to calculate ORACLE block size
Cause: Export failed to calculate the Oracle block size.
Action: Report this as an Export internal error to customer support.
EXP-00028: failed to open string for write
Cause: Export failed to open the export file for writing. This message is usually followed by device messages from the operating system.
Action: Take appropriate action to restore the device.
EXP-00029: Incremental export mode and consistent mode are not compatible
Cause: Both consistent and incremental exports were specified.
Action: None. Consistent mode is turned off.
EXP-00030: Unexpected End-Of-File encountered while reading input
Cause: Encountered an End-Of-File while reading the user input.
Action: If input to export is being redirected, check the file for errors.
EXP-00031: Arraysize not in valid range. Using arraysize=number
Cause: The arraysize value specified is not in the valid range.
Action: None
EXP-00032: Non-DBAs may not export other users
Cause: Only database administrators can export to other users. A non- database administrator attempted to specify owner=user where exporter is not the user.
Action: Request that this operation be performed by the database administrator.
EXP-00033: Could not find environment character set
Cause: The environment character set is missing or incorrectly specified.
Action: Ensure that the environment character set is correctly specified and is present.
EXP-00034: error on rowid: file# number block# number slot# number
Cause: Identifies the rowid on which an error occurred.
Action: This is an information message. No action is required.
EXP-00035: QUERY parameter valid only for table mode exports
Cause: You specified the QUERY parameter in an export command, but you are not performing a table mode export. The QUERY parameter cannot be used for a user mode export, a full export, nor a point in time recovery export.
Action: If you want to select a subset of rows for a table, you must export the table independently with a table mode export. Issue a table mode export command that specifies the table name and the query you want to execute during export.
EXP-00036: Object number non-existent in dictionary
Cause: The specified object could not be found in the dictionary. The object might have been dropped during the export
Action: The object no longer exists; no action is needed.
EXP-00037: Export views not compatible with database version
Cause: The Export utility is at a higher version than the database version and is thereby incompatible.
Action: Use the same version of Export utility as the database.
EXP-00038: Bad Hash cluster id in clu$
Cause: The function id in clu$ is not a legal number. Clu$ has become corrupted.
Action: Contact Worldwide Support
EXP-00039: export file string must be on a disk
Cause: On some platforms, export can read files from tape. This message is displayed if the first file in an export file set was on disk and you specified a tape device for a second or subsequent file.
Action: Verify that you have specified the correct file name for the export file. Remember that all export files can be either on disk or all files can be on tape, but not mixed both tape and disk.
EXP-00040: Dump file and log file must be different
Cause: The dump file and log file cannot be the same file.
Action: Specify different file names for the dump file and the log file, then retry the operation.
EXP-00041: INCTYPE parameter is obsolete
Cause: Export encountered the INCTYPE parameter when parsing Export options. Incremental Exports are no longer supported.
Action: Consult the Oracle Backup and Recovery guide. Export will attempt to continue.
EXP-00042: Missing NLS_CHARACTERSET/NLS_NCHAR_CHARACTERSET in props$
Cause: A value for NLS_CHARACTERSET/NLS_NCHAR_CHARACTERSET was not entered in the props$ table"
Action: internal error.
EXP-00043: Invalid data dictionary information in the row where column "string" is "string" in table string
Cause: The export utility retrieved invalid data from the data dictionary.
Action: Contact Oracle Worldwide Suport.
EXP-00044: must be connected 'AS SYSDBA' to do Point-in-time Recovery or Transportable Tablespace import
Cause: The user must log in 'as SYSDBA' to perform transportable tablespace imports or Point-In-Time Recovery imports.
Action: Ask your database adminstrator to perform the Transportable Tablespace import or the Tablespace Point-in-time Recovery import.
EXP-00045: Cannot export SYSTEM Tablespace for Point-in-time Recovery or Transportable Tablespace
Cause: SYSTEM tablespace cannot be part of recovery set or transportable tablespace set.
Action: Contact Oracle Wordwide Support.
EXP-00046: Tablespace named string does not exist
Cause: The specified tablespace does not exist in dictionary.
Action: Contact Oracle Wordwide Support.
EXP-00047: Missing tablespace name(s)
Cause: Tablespace name(s) were not supplied
Action: Provide tablespace name(s)
EXP-00048: Cannot export SYSAUX Tablespace for Point-in-time Recovery or Transportable Tablespace
Cause: SYSAUX tablespace cannot be part of recovery set or transportable tablespace set.
Action: Contact Oracle Wordwide Support.
EXP-00049: %s option is not compatible with Point-in-time Recovery or Transportable Tablespace Export
Cause: An option was specified incompatible with Point-in-time Recovery or Transportable Tablespace Export.
Action: Retry the Export without the displayed option.
EXP-00050: Cannot perform Partition Export "string" on non-partitioned table "string"
Cause: The table specified in this Partition Export is not a partitioned table.
Action: Use Table mode, or specify a non-partitioned table.
EXP-00051: "string" - given partition or subpartition name is not part of "string" table
Cause: The specified partition or subpartition name is not in the specified table.
Action: Check if the correct table, partition or subpartition name was specified.
EXP-00052: error on row number of partition string
Cause: Export encountered the referenced Oracle error while fetching rows.
Action: Look up the Oracle message in the ORA message chapters of this manual and take appropriate action.
EXP-00053: unable to execute QUERY on table string because the table has inner nested tables
Cause: You specified the QUERY parameter on a table that has one or more inner nested tables. The QUERY parameter cannot be specified on tables that have inner nested tables.
Action: Export the entire table by omitting the QUERY parameter.
EXP-00054: error on row number of subpartition string
Cause: Export encountered the referenced Oracle error while fetching rows.
Action: Look up the Oracle message in the ORA message chapters of this manual and take appropriate action.
EXP-00055: %s.string is marked not exportable
Cause: An object was marked as non-exportable in the NOEXP$ table.
Action: Consult your database administrator.
EXP-00057: Failure to initialize parameter manager
Cause: The parameter manager failed in intialization.
Action: Record the messages that follow and report this to Oracle Wordwide Support as an Export internal bug.
EXP-00058: Password Verify Function for string profile does not exist
Cause: Cannot find the function for the profile.
Action: Check if the profile was created properly.
EXP-00059: error converting an object type's identifier to characters
Cause: An invalid length of an object type identifier prevented its conversion.
Action: Contact Oracle Worldwide Support
EXP-00060: an object type had multiple TYPE BODYs
Cause: More than one TYPE BODY was found for an object type.
Action: Try dropping the TYPE BODY, if that is not successful, contact Oracle Worldwide Support
EXP-00061: unable to find the outer table name of a nested table
Cause: While exporting a bitmap index or posttable action on an inner nested table, the name of the outer table could not be located, using the NTAB$ table.
Action: Verify the table is properly defined.
EXP-00062: invalid source statements for an object type
Cause: TYPE was not found in the statements in SOURCE$ for an Object Type
Action: Contact Oracle Worldwide Support.
EXP-00063: error in changing language handle
Cause: Unable to change language handle.
Action: Contact Oracle Worldwide Support.
EXP-00064: %s is an inner nested table and cannot be exported.
Cause: An attempt was made to export an inner nested table without its parent table.
Action: Export the parent of the inner nested table.
EXP-00065: Error writing lob to the dump file.
Cause: The current LOB could not be written to the dump file.
Action: Identify the cause of the write failure and fix it.
EXP-00066: Object table string is missing its object identifier index
Cause: All object tables must have an object identifier index, but the specified table was missing an index on its object identifier column.
Action: Recreate the type table and retry the operation.
EXP-00068: tablespace string is offline
Cause: Export failed to export tablespace (tablespace being offline).
Action: Make tablespace online and re export.
EXP-00070: attempt to free unallocated memory
Cause: An attempt was made to free memory that was not allocated.
Action: Contact Oracle Worldwide Support
EXP-00071: QUERY parameter not compatible with Direct Path export
Cause: You specified a value for the QUERY parameter for a direct path export. The QUERY parameter cannot be used with a direct path export.
Action: Re-issue the export command with DIRECT=N or omit the DIRECT parameter from the command line.
EXP-00072: error closing export file string
Cause: An error occurred while trying to close the export file.
Action: Contact Oracle Worldwide Support.
EXP-00073: dump file size too small
Cause: You specified either the FILESIZE parameter or the VOLSIZE parameter (if your platform supports it), and the value of the parameter is too small to hold the header information for the export file, plus any data.
Action: Increase the value of the FILESIZE or VOLSIZE parameter.
EXP-00074: rounding VOLSIZE down, new value is string
Cause: The VOLSIZE parameter must be a multiple of the RECORDLENGTH, but the value you specified for VOLSIZE does not meet this requirement. The value of VOLSIZE has been rounded down to be a multiple of the RECORDLENGTH used for the dump file.
Action: No action is required. You can adjust the VOLSIZE or RECORDLENGTH parameter to avoid this message. When importing this file, you must specify the VOLSIZE value reported by this message.
EXP-00075: rounding FILESIZE down, new value is string
Cause: The FILESIZE parameter must be a multiple of the RECORDLENGTH, but the value you specified for FILESIZE does not meet this requirement. The value of FILESIZE has been rounded down to be a multiple of the RECORDLENGTH used for the dump file.
Action: No action is required. You can adjust the FILESIZE or RECORDLENGTH parameter to avoid this message. When importing this file, you must specify the FILESIZE value reported by this message.
EXP-00076: multiple devices specified for tape output
Cause: You specified multiple file names when doing an export to a tape device. EXPORT uses the same device for writing all files, of the number of tape volumes required. For this reason, export will accept only one value for the FILE parameter when writing to tape.
Action: Reenter the EXPORT command, but specify only one tape device in the FILE parameter.
EXP-00077: multiple output files specified for unbounded export file
Cause: You specified multiple file names when doing an export and you also specified a value of 0 for the FILESIZE parameter. Note that 0 is the value used if FILESIZE is not specified on the command line. Since a value of 0 for FILESIZE means that only one file will be written and there is no size limit for that file, the other files you specified in the FILE parameter can never be used.
Action: If you intended to write multiple files, respecify the command but use the FILESIZE to specify the maximum number of bytes that EXPORT should write to each file. If you intended to write only one file with no limits on it's size, reissue the EXPORT command but specify only one file name for the FILE parameter.
EXP-00078: Error exporting metadata for index string. Index creation will be skipped
Cause: Domain indexes export private metadata via anonymous PL/SQL blocks prior to the CREATE INDEX statement. Export does this by calling the ODCIIndexGetMetadata method on the implementation type associated with the index. A problem occurred inside this routine. Because the metadata is considered an integral part of the index, the CREATE INDEX statement was not written to the dump file.
Action: Contact the developer of the index's implementation type. If this is an Oracle-supplied index (perhaps via a data cartridge), contact Oracle Worldwide Support.
EXP-00079: Data in table "string" is protected. Conventional path may only be exporting partial table.
Cause: User without the execute privilege on DBMS_RLS, the access control package, tries to export a table that has access control. Since table owner is also subjected to access control, the owner may not be able to export all rows in the table, but only the ones he can see. Also, to preserve integrity of the table, user exporting the table should have enough privilege to recreate the table with the security policies at import time. Therefore, it is strongly recommended the database administrator should be handling exporting of this table. Granting the table owner execute privilege would also satisfy this security check, though it might have other security implications. If the table does not have objects, can use direct mode.
Action: Ask the database administrator to export/import this table/view.
EXP-00080: Data in table "string" is protected. Using conventional mode.
Cause: User without the execute privilege on DBMS_RLS, the access control package, tries to direct export a table that has access control enabled. Using conventional export mode instead. Note that because of access control, only a partial table may be exported.
Action: Ask the database administrator to export/import this table/view.
EXP-00081: Exporting access control for table/view "string" as non-DBA.
Cause: A non-DBA user tries to export table/view and the associated fine grain access control policies. The user may not have enough privilege to recreate the access control policies when importing the table/view. And such an event may cause inconsistency in the security model of the table/view.
Action: Ask the database administrator to export/import this table/view.
EXP-00082: Invalid function name passed to procedural object support: string
Cause: Internal inconsistency error: The listed function is not a method on export's procedural object interface specification.
Action: Contact Oracle Worldwide Support
EXP-00083: The previous problem occurred when calling string.string.string
Cause: The listed package provides export/import support for procedural
Action: Contact Oracle Worldwide Support. Most packages are supplied by Oracle internal cartridge or server development groups. The package name will help Support determine the correct owner of the problem.
EXP-00084: Unexpected DbmsJava error number at step number
Cause: The error was returned from a call to a DbmsJava procedure.
Action: Record the accompanying messages and report this as an Export internal error to customer support.
EXP-00085: The previous problem occurred when calling string.string.string for object number
Cause: The listed package provides export/import support for procedural objects, i.e, those whose DDL is supplied by stored procedures. The previously listed error occurred while calling the specified function.
Action: Contact Oracle Worldwide Support. Most packages are supplied by Oracle internal cartridge or server development groups. The package name will help Support determine the correct owner of the problem.
EXP-00086: Primary key REFs in table "string"may not be valid on import
Cause: The specified table contains primary key REFs which may not be valid in the import database.
Action: Do not use Export/Import to move Primary key REFs between databases having differing character sets.
EXP-00087: Problem with internal hash table of schema/table names
Cause: Most likely a problem with allocating memory for the hash table entries.
Action: Contact Oracle Worldwide Support
EXP-00089: invalid FILE_FORMAT specification
Cause: The FILE_FORMAT specification did not contain an instance of "%s". This wildcard string must be present.
Action: Correct the error and reenter the EXPORT command.
EXP-00090: cannot pin type "string"."string"
Cause: Export was unable to pin the specified type in the object cache. This is typically caused because a type could not be made valid (for example because of authorization violations in accessing subtypes).
Action: Fix the problem with the offending type until the type can be successfully compiled.
EXP-00091: Exporting questionable statistics.
Cause: Export was able export statistics, but the statistics may not be usuable. The statistics are questionable because one or more of the following happened during export: a row error occurred, client character set or NCHARSET does not match with the server, a query clause was specified on export, only certain partitions or subpartitions were exported, or a fatal error occurred while processing a table.
Action: To export non-questionable statistics, change the client character set or NCHARSET to match the server, export with no query clause, export complete tables. If desired, import parameters can be supplied so that only non-questionable statistics will be imported, and all questionable statistics will be recalculated.
EXP-00092: Unable to set NLS_NUMERIC_CHARACTERS to required defaults.
Cause: Export was unable to set NLS_NUMERIC_CHARACTERS to '.,'
Action: Record the accompanying messages and report this as an Export internal error to customer support.
EXP-00093: Could not convert to server character set's handle
Cause: Internal error.
Action: Contact Worldwide support.
EXP-00094: Could not convert to server national character set's handle
Cause: Internal error.
Action: Contact Worldwide support.
EXP-00095: Flashback_time and Flashback_scn are not compatible
Cause: Both flashback_time and flashback_scn paramerers were specified.
Action: Reissue command with only one flashback parameter.
EXP-00097: Object type "string"."string" is not in a valid state, type will not be exported
Cause: The object type's status is invalid which may be caused by a dependant type's modification (or removal) without cascading the change.
Action: The type must be recompiled using ALTER TYPE COMPILE.
EXP-00098: Data in table has not been upgraded, table will not be exported
Cause: Export is attempting to process a table containing references to a type which has evolved. In order for Export to process the table successfully, all data within each table must be upgraded to the latest revision of each referenced type.
Action: The table must be updated using ALTER TABLE UPGRADE DATA.
EXP-00099: Table "string"."string" is not in a valid state, table will not be exported
Cause: A table or one of its dependant types has modified without cascading the change. This left the table in an INVALID state.
Action: The table must be updated using ALTER TABLE UPDATE.
EXP-00100: error converting an object type's hashcode to characters
Cause: An invalid length of an object type identifier prevented its conversion.
Action: Contact Oracle Worldwide Support
EXP-00101: Version 1 extensible index "string"."string" can not be included in Transportable Tablespace Export
Cause: Transporable Tablespace extensible indexes must be at least version 2.
Action: Upgrade extensibile index implementation to version 2 specifications.
EXP-00102: Resumable parameters ignored -- current session not resumable
Cause: Current session is not resumable.
Action: Must specify RESUMABLE=Y to enable resumable session in order for the RESUMABLE_NAME and RESUMABLE_TIMEOUT parameters to take effect.
EXP-00103: The FLASHBACK_TIME parameter was invalid
Cause: FLASHBACK_TIME did not contain a valid timestamp or an expression that yields a valid timestamp.
Action: Specify a timestamp value in the format of YYYY-MM-DD HH24:MI:SS or an expression that evaluates to a valid timestamp.
EXP-00104: datatype (string) of column string in table string.string is not supported, table will not be exported
Cause: The column is of a datatype which does not contain the required support. The table will not be exported.
Action: Use the Data Pump version of Export to export this table.
EXP-00105: parameter string is not supported for this user
Cause: The user attempted to specify either CONSISTENT or OBJECT_CONSISTENT when connected as sysdba.
Action: If a consistent export is needed, then connect as another user.


22 IMP-00000 to IMP-00401

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

22 IMP-00000 to IMP-00401

IMP-00000: Import terminated unsuccessfully
Cause: Import encountered an Oracle error.
Action: Look up the accompanying Oracle message in the ORA message chapters of this manual, and take appropriate action.
IMP-00001: respond with either string, string, RETURN or '.' to quit
Cause: An invalid response was entered.
Action: Enter any of the responses shown in the message.
IMP-00002: failed to open string for read
Cause: Import failed to open the export file for reading. This message is usually followed by a device message from the operating system.
Action: Take appropriate action to restore the device.
IMP-00003: ORACLE error number encountered
Cause: Import encountered the referenced Oracle error.
Action: Look up the Oracle message in the ORA message chapters of this manual, and take appropriate action.
IMP-00004: invalid username or password
Cause: An invalid username or password was specified.
Action: Retry with a valid username and password.
IMP-00005: all allowable logon attempts failed
Cause: An attempt was repeatedly made to log on with an invalid username or password.
Action: Retry with valid username and password.
IMP-00006: failed to allocate memory of size number
Cause: Import failed to allocate the necessary memory.
Action: Decrease the import buffer size so that less memory is required, or increase the runtime memory size for Import.
IMP-00007: must be a DBA to import objects to another user's account
Cause: The privileges needed to import into another user's account do not exist. Only a database administrator can import into another user's account.
Action: Ask the database administrator to do the import.
IMP-00008: unrecognized statement in the export file: string
Cause: Import did not recognize a statement in the export file. Either the export file was corrupted, or an Import internal error has occurred.
Action: If the export file was corrupted, retry with a new export file. Otherwise, report this as an Import internal error and submit the export file to customer support.
IMP-00009: abnormal end of export file
Cause: The export file is probably from an aborted Export session.
Action: If so, retry the export and import. Otherwise, report this as an Import bug and submit the export file that caused this error to customer support.
IMP-00010: not a valid export file, header failed verification
Cause: Either the file was not generated by Export or it was corrupted.
Action: If the file was indeed generated by Export, report this an Import bug and submit the export file to customer support.
IMP-00011: formatted table data not currently supported
Cause: You tried to import an export file that contains formatted table data. Import only supports export files containing binary table data. wher
Action: Retry using an export file that contains only binary table data.
IMP-00012: invalid export mode (character) in header
Cause: The Export mode specified in the export file header is invalid.
Action: Check the export file to see if it was corrupted. If it was not, report this as an Import bug and submit the export file to customer support.
IMP-00013: only a DBA can import a file exported by another DBA
Cause: The privileges needed to Import an export file generated by a database administrator do not exist. Only a database administrator can import such files.
Action: Ask the database administrator to do the import.
IMP-00014: option "string" is needed, but not present in database
Cause: The command entered requires the specified option. Either that option is not installed, or the row describing the option is missing from table V$OPTION
Action: Reinstall Oracle with the option specified by the message.
IMP-00015: following statement failed because the object already exists:
Cause: Import failed to create an object because it already exists.
Action: Specify IGNORE=Y to ignore such errors and import rows even when tables are not created because they already exist.
IMP-00016: required character set conversion (type number to number) not supported
Cause: Import could not convert the character format of the export file into the native character format.
Action: Change the user character set by setting the NLS_LANG environment variable to match the character set of the export file.
IMP-00017: following statement failed with ORACLE error number:
Cause: Import failed to execute the statement from the export file because of an Oracle error.
Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action.
IMP-00018: partial import of previous table completed: number rows imported
Cause: A table was only partially imported because of an Oracle error.
Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action.
IMP-00019: row rejected due to ORACLE error number
Cause: Import encountered the referenced Oracle error while trying to import a row.
Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action.
IMP-00020: long column too large for column buffer size (number)
Cause: The column buffer is too small. This usually occurs when importing LONG data.
Action: Increase the insert buffer size 10,000 bytes at a time (for example). Use this step-by-step approach because a buffer size that is too large may cause a similar problem.
IMP-00021: INCTYPE parameter is obsolete
Cause: Import encountered the INCTYPE parameter when parsing Import options. Incremental Imports are no longer supported.
Action: Consult the Oracle Backup and Recovery guide. Import will attempt to continue.
IMP-00022: failed to process parameters, type 'IMP HELP=Y' for help
Cause: Invalid command-line parameters were specified.
Action: Check the online help screen for the set of valid parameters, then retry.
IMP-00023: Import views not installed, please notify your DBA
Cause: The necessary Import views were not installed.
Action: Ask your database administrator to install the required Import views.
IMP-00024: Only one mode (TABLES, FROMUSER, or FULL) can be specified
Cause: Parameters were specified that conflict with the import specification FULL=Y.
Action: Retry, making sure not to specify FULL=Y.
IMP-00025: for DBA export files, FROMUSER must be specified with TOUSER option
Cause: When importing a database administrator export file, you specified the TOUSER parameter but not the FROMUSER parameter.
Action: Specify the FROMUSER parameter so that Import knows which user's objects to import.
IMP-00027: failed to rollback partial import of previous table
Cause: Import encountered an Oracle error while trying to roll back a partial import.
Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action. Then, log on to Oracle and check that the partial import was not committed.
IMP-00028: partial import of previous table rolled back: number rows rolled back
Cause: Import encountered an Oracle error while trying to import a table.
Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action. Then, if necessary, re-import the table.
IMP-00029: cannot qualify table name by owner (string), use FROMUSER parameter
Cause: A table name was qualified with the name of its owner, as shown in the following example. This is not allowed. IMP SYSTEM/MANAGER TABLES=(SCOTT.EMP)
Action: Use the FROMUSER parameter to specify the table's owner, as shown in the following example: IMP SYSTEM/MANAGER FROMUSER=SCOTT TABLES=(EMP, DEPT)
IMP-00030: failed to create file string for write
Cause: Import was unable to create the specified file with write enabled.
Action: Check the file name and file system for the source of the error.
IMP-00031: Must specify FULL=Y or provide FROMUSER/TOUSER or TABLES arguments
Cause: The database administrator did not specify full or partial import.
Action: The database administrator must specify FROMUSER/TOUSER or table arguments if not a full import.
IMP-00032: SQL statement exceeded buffer length
Cause: The buffer was too small for the SQL statement being read.
Action: Rerun with a larger buffer. This can also be an indication of a corruption in the import datafile.
IMP-00033: Warning: Table "string" not found in export file
Cause: A table name was specified that does not exist in export file.
Action: Correct the table specification.
IMP-00034: Warning: FromUser "string" not found in export file
Cause: The user specified a FROMUSER name that does not exist in export file.
Action: Correct the FROMUSER specification.
IMP-00035: input file string must be on a disk
Cause: On some platforms, import can read files from tape. This message is displayed if the first file in an export file set was on disk and you specified a tape device for a second or subsequent file.
Action: Verify that you have specified the correct file name for the import file. Remember that all input files can be either on disk or all files can be on tape, but not mixed both tape and disk.
IMP-00036: Could not find environment character set
Cause: An environment character set was specified that was not recognized by the Import utility.
Action: Ensure that the spelling of the character set specified in the command line parameter CHARSET (for Release 6 only) or the environment variable NLS_LANG is correct.
IMP-00037: Character set marker unknown
Cause: The export file is corrupted.
Action: Try to obtain an uncorrupted version of the export file. If the export file is not corrupted, report this as an Import internal error and submit the export file to customer support.
IMP-00038: Could not convert to environment character set's handle
Cause: Internal error.
Action: Contact Worldwide Support.
IMP-00039: VOLSIZE does not match the value used for export: string
Cause: The value specified for VOLSIZE does not match the value specified during the creation of the export file.
Action: If you believe that the specified VOLSIZE value is correct, verify that you specified the correct file for import. If you specified the correct file but are unsure about the correct value, re-execute the import command but specify VOLSIZE=0.
IMP-00040: FILESIZE does not match the value used for export: string
Cause: The value specified for FILESIZE does not match the value specified during the creation of the export file.
Action: If you believe the specified FILESIZE value is correct, verify that you specified the correct file for import. If you specified the correct file but are unsure about the correct value, re-execute the import command but specify FILESIZE=0.
IMP-00041: Warning: object created with compilation warnings
Cause: The object in the SQL statement following this error was created with compilation errors. If this error occurred for a view, it is possible that the base table of the view was missing.
Action: This is a warning. The object may have to be recompiled before being used.
IMP-00042: CHARSET used, but the export file has specific character set
Cause: The user requested that a specific character set be used to process an export file that has a specific embedded character set ID. The ID in the export file is accurate and should be used.
Action: Remove the CHARSET keyword from the command line.
IMP-00043: export file character set inconsistent
Cause: The character set of the export file and the environment character set (or the character set specified with the CHARSET keyword) are inconsistent. One character set is ASCII-based while the other is EBCDIC based.
Action: Specify the correct character set with the CHARSET keyword.
IMP-00044: unable to allocate enough memory for statement
Cause: Import was unable to allocate sufficient memory to read in the specified statement and execute it.
Action: Increase the allocation for database buffers, restart the instance, and reexecute the Import command.
IMP-00045: using VOLSIZE value from export file of string
Cause: Either you did not specify the VOLSIZE parameter in your IMPORT command, or you specified VOLSIZE=0 and the export was created with a non-zero value for VOLSIZE. Import will use the value specified in the export file.
Action: None required.
IMP-00046: using FILESIZE value from export file of string
Cause: Either you did not specify the FILESIZE parameter in your IMPORT command, or you specified FILESIZE=0 and the export file was created with a non-zero value for FILESIZE. Import will use the value specified in the export file.
Action: None required.
IMP-00047: unexpected file sequence number; expected number but found number
Cause: The header in the export file contains a sequence number that is used to track the order in which multiple export files are written. The first export file is assigned sequence number one, the second file is assigned sequence number two and so on. This message is displayed when a number other than the expected sequence number is found in the file header
Action: Execute the import command again, but specify the files in the order in which Export wrote them.
IMP-00048: mismatched file header
Cause: During verification of the 2nd or subsequent file in a multi-file export, Import found header fields in the file that did not match values in the first file.
Action: Check the names of the files created by Export and verify that you specified them correctly for the import operation.
IMP-00049: Unknown language specified in CHARSET
Cause: An unknown language was listed in the CHARSET option.
Action: Use a known character set.
IMP-00050: Dump file and log file cannot be identical
Cause: Identical names were given to the dump file and log file.
Action: Specify different names for the dump file and log file and retry the operation.
IMP-00051: Direct path exported dump file contains illegal column length
Cause: An invalid column length was encountered while processing column pieces."
Action: Check to make sure the export file is not corrupted, or else report this to Oracle Worldwide Support as an Import/Export internal bug and submit the export file.
IMP-00052: Warning: Unable to set event for freelist communication with server
Cause: An event could not be set for current the session.
Action: If Import fails, give the Import user ALTER SESSION PRIV and retry the operation.
IMP-00053: Import mode incompatible with Export dump file
Cause: The specified import option is incompatible with point-in-time- recovery dump file.
Action: Generate a proper dump file or use point-in-time-recovery import mode.
IMP-00054: must be connected 'AS SYSDBA' to do Point-in-time Recovery or Transportable Tablespace import
Cause: The user must log in 'as SYSDBA' to perform transportable tablespace imports or Point-In-Time Recovery imports.
Action: Ask your database adminstrator to perform the Transportable Tablespace import or the Tablespace Point-in-time Recovery import.
IMP-00055: Warning: partition or subpartition "string":"string" not found in export file
Cause: A partition or subpartition name was specified that does not exist in export file.
Action: Check to make sure the partition or subpartition name belongs to the table.
IMP-00056: multiple devices specified for tape input
Cause: You specified multiple file names when doing an import from a tape device. Import uses the same device for reading all tapes, regardless of the number of tape volumes required. For this reason, export will accept only one value for the FILE parameter when writing to tape.
Action: Reenter the IMPORT command, but specify only one tape device in the FILE parameter.
IMP-00057: Warning: Dump file may not contain data of all partitions of this table
Cause: The dump file used for this Table Import might not contain all of the data belonging to the exported table.
Action: Check to see if the export was done as intended, or try performing a Partition Import.
IMP-00059: Failure to initialize parameter manager
Cause: Parameter manager failed in initialization.
Action: Report this to Oracle Worldwide Support as an Import internal bug.
IMP-00060: Warning: Skipping table "string"."string" because object type "string"."string" does not exist or has different identifier
Cause: An object type needed by the table, either does not exist on the

* target system or, if it does exist, it has a different object identifier.

Action: Create the object type on the target system with a valid

* identifier.

IMP-00061: Warning: Object type "string"."string" already exists with a different identifier
Cause: An object type cannot be created because it already exists on the

* target system, but with a different identifier

Action: Drop the object type from the target system and retry the operation.
IMP-00062: Warning: The identifier on the dump file for object type "string"."string" is invalid
Cause: The character string representing the object type's identifier

* could not be converted to an object identifier.

Action: Internal error.
IMP-00063: Warning: Skipping table "string"."string" because object type "string"."string" cannot be created or has different identifier
Cause: An error occurred creating an object type that is used by the

* table.

Action: Examine the import log to determine why the object type could not

* be created. If the object type already existed, with a

* different object identifier, then drop the object type and

* retry the import.

IMP-00064: Definition of LOB was truncated by export
Cause: While producing the dump file, Export was unable to write the

* entire contents of a LOB. Import is therefore unable to

* reconstruct the contents of the LOB. The remainder of the

* import of the current table will be skipped.

Action: Delete the offending row in the exported database and retry the

* export.

IMP-00065: Import is unable to recreate lobs within objects.
Cause: An error occurred recreating a LOB within an imported object.
Action: Report this to Oracle Worldwide Support as an Import internal error.
IMP-00066: Missing NLS_CHARACTERSET in props$
Cause: No value for NLS_CHARACTERSET in props$.
Action: Contact Worldwide support.
IMP-00067: Could not convert to server character set's handle
Cause: Internal error.
Action: Contact Worldwide support.
IMP-00068: Could not find environment national character set
Cause: An environment national character set was specified that was not recognized by the Import utility.
Action: Ensure that the spelling of the national character set specified in the environment variable NLS_NCHAR is correct.
IMP-00069: Could not convert to environment national character set's handle
Cause: Internal error..
Action: Contact Worldwide support.
IMP-00070: Lob definitions in dump file are inconsistent with database.
Cause: The number of LOBS per row in the dump file is different than the

* number of LOBS per row in the table being populated.

Action: Modify the table being imported so that it matches the column

* attribute layout of the table that was exported.

IMP-00071: Object identifier of imported table mismatches object identifier of existing table
Cause: An attempt was made to import data into a table that was recreated under a different object identifier than the object identifier used for the exported object table. Under this situation, REF's to this table that are contained within the dump file will also be invalid.
Action: Drop the offending object table prior to import.
IMP-00072: Warning: The object table's object identifier is invalid.
Cause: The character string representing the table's object identifier could not be converted to an internal object identifier.
Action: Internal error.
IMP-00073: FILE locator "string" "string" is truncated to "string" "string" in server character set
Cause: The conversion of the specified directory and name strings for a file attribute or column from the export server's character set into the import server's character set exceeded the maximum string lengths allowed within FILE descriptors. The strings will be truncated to the maximum supported lengths.
Action: Rename the directory aliases and external filenames to match the truncated names in the specified FILE column or attribute.
IMP-00074: The constraints flagged by ALL_CONSTRAINTS.BAD will break in 2000 A.D.
Cause: Constraints exist in the data base that specify date values without fully specifying the year. These constraints could break in the year 2000 A.D.
Action: Query ALL_CONSTRAINTS and correct those constraints marked as bad.
IMP-00075: Warning: The nested table may contain partial rows or duplicate rows
Cause: An error occurred inserting data into an outer or inner nested table. If the error occurred in the outer table, rows are still inserted into the inner tables. If the error occurred in an inner table, data is still inserted into the outer table and other inner tables. This can result in duplicate inner table rows or partial logical rows.
Action: Examine the data in the tables. Delete the incorrect rows or drop the entire table and perform the import again.
IMP-00076: Missing NLS_NCHAR_CHARACTERSET in props$
Cause: No value for NLS_NCHAR_CHARACTERSET in props$.
Action: Contact Worldwide support.
IMP-00077: Could not convert to server national character set's handle
Cause: Internal error.
Action: Contact Worldwide support.
IMP-00078: Cannot translate FILE locator to "string" "string" in server character set
Cause: (1) The current export dump file was generated using Beta-2 of Oracle8.0 AND (2) there was a File that appeared as an an attribute of an ADT within a table's column AND (3) the character set of the export server's database was different than the character set of the import server's database AND (4) when the filename or the aliasname of the File increased in size when it was translated to the character set of the import server. When all of these conditions are true, translation of the strings could yield corruption of the data in the column. Rather than proceeding with the translation, import will leave the character strings in the File in the old character set.
Action: After import completes, rename the directory aliases and external filenames to match the real names used for the target database.
IMP-00079: Warning: National character set data in this table may be incorrect
Cause: Due to a problem in 8.0.2 Export, national character data in NCHAR and NVARCHAR2 columns was incorrectly assumed to be in the export server's data base character set and was converted to the export client's data base character set. This conversion would only be correct if the export server's data base character set was the same as the export server's national character set and the export client's data base character set was the same as the export client's national character set. All other combinations would likely be incorrect. This export dump file was generated by 8.0.2 Export and the export client and server characater sets did not fit that criteria.
Action: Examine the national character data. If incorrect, update the data with correct data.
IMP-00080: Error during character conversion of long column or long command
Cause: During piecewise character conversion of the data in a long column or of a long command, a fatal conversion error occurred. Either character truncation occurred or an invalid character set handle was used.
Action: Retry the import with a different character set.
IMP-00081: attempt to free unallocated memory
Cause: An attempt was made to free memory that was not allocated.
Action: Contact Oracle Worldwide Support
IMP-00082: Error during conversion ROWID from string format to internal
Cause: An error occured while attempting to to convert a ROWID from an export dump file into an internal format.
Action: Report this to Oracle Worldwide Support as an Import internal error.
IMP-00083: dump file does not contain an incremental export
Cause: An incremental import was requested and the dump file specified for the import command is either a user or table export.
Action: Reissue the command import command but specify the name of a dump file containing an incremental export.
IMP-00084: attempt to mix incremental import with user or table import
Cause: An incremental import was requested along with the FROMUSER, TOUSER, or TABLE qualifier. An incremental import cannot be done if any of these other qualifiers are also specified.
Action: Determine whether you want to do an incremental import, full import, user import or table import and reissue the import command with the appropriate qualifiers.
IMP-00085: multiple input files specified for unbounded export file
Cause: You specified multiple file names for the FILE parameter when doing an import, but the header in the export file indicates that that the export operation could create only one file. Specifying multiple file names is valid for an import operation only if the export files were created by an export operation in which the user specified a non-zero value for the FILESIZE parameter.
Action: If you believe the export contains multiple files, verify that you have specified the correct files. If you believe the export should be in only one file then try the import operation again, but specify only one value for the FILE parameter.
IMP-00086: TOID "string" not found in export file
Cause: Import did not find the type identification specified in the TOID_NOVALIDATE parameter. The specified type identification does not exist in export file.
Action: Correct or omit the TOID_NOVALIDATE parameter.
IMP-00087: Problem with internal hash table of schema/table names
Cause: Most likely a problem with allocating memory for the hash table entries.
Action: Contact Oracle Worldwide Support
IMP-00088: Problem importing metadata for index string. Index creation will be skipped
Cause: Domain indexes import private metadata via anonymous PL/SQL blocks prior to the CREATE INDEX statement. The execution of one of these PL/SQL blocks failed. Because the metadata is considered an integral part of the index, the subsequent CREATE INDEX statement was skipped.
Action: Contact the developer of the index's implementation type. If this is an Oracle-supplied index (perhaps via a data cartridge), contact Oracle Worldwide Support.
IMP-00089: Fine grain policy "string" not recreated on table/view "string"
Cause: Import user fails to recreate fine grained policies of the table/view being imported. To recreate the policy, the user doing the import needs execute privilege on the package DBMS_RLS for access policies or DBMS_FGA for audit policies.
Action: Ask the database administrator to perform the export/import of this table/view.
IMP-00090: Unexpected DbmsJava error number at step number while creating string
Cause: The error was returned from a call to a DbmsJava procedure.
Action: Record the accompanying messages and report this as an Import internal error to customer support.
IMP-00091: Above error occurred on the following function and object: string. Remaining PL/SQL blocks for this object will be skipped.
Cause: An error occurred while executing a PL/SQL block that implements the DDL for the named function and procedural object. A procedural object is one whose DDL is implemented as stored procedures rather than as standard SQL statements.
Action: Contact Oracle Worldwide Support so they may determine the development group responsible for the package that failed.
IMP-00092: Java object "string"."string" already exists, cannot be created
Cause: Import failed to create the Java source, class or resource object because it already exists.
Action: Drop the object type from the target system and retry the operation.
IMP-00093: Inconsistency between dumpfile constraint definition for table string with columns (string)
Cause: Import failed to locate a base table for a constraint that was defined in the dump file and statistics were not imported.
Action: Check to see if the table and constraint exist. If the table and constraint exist, then report this to Oracle Support Services as an Import internal error.
IMP-00094: Warning: The identifier on the dump file for object type "string"."string" is invalid
Cause: The character string representing the object type's identifier

* could not be converted.

Action: Contact Oracle Worldwide Support.
IMP-00095: Resumable parameters ignored -- current session not resumable
Cause: Current session is not resumable.
Action: Must specify RESUMABLE=Y to enable resumable session in order for the RESUMABLE_NAME and RESUMABLE_TIMEOUT parameters to take effect.
IMP-00096: Warning: Skipping table "string"."string" because type synonym "string"."string" cannot be created
Cause: An error occurred creating a synonym for a type that is used by the

* table.

Action: Examine the import log to determine why the type synonym could

* not be created. If the synonym already existed, but is not

* needed, then drop the synonym and retry the import. If the

* synonym is PUBLIC but the importer does not have the

* CREATE PUBLIC SYNONYM system privilege, then the import must

* be done by someone possessing that privilege, or the importer

* must be granted the privilege.

IMP-00097: STREAMS_CONFIGURATION=Y ignored, only valid with FULL=Y
Cause: STREAMS_CONFIGURATION=Y can only be used

* when FULL=Y is present on the command line

Action: Remove conflicting command arguments
IMP-00098: INTERNAL ERROR: string
Cause: An INTERNAL error occurred.
Action: Contact Oracle Worldwide Support.
IMP-00099: Warning: The typeid in the dump file for object type "string"."string" is invalid
Cause: The character string representing the object type's identifier

* could not be converted.

Action: Contact Oracle Worldwide Support.
IMP-00400: Warning: Object type "string"."string" already exists with a different typeid
Cause: An object type could not be created because it already existed on the

* target system, but with a different typeid

Action: Drop the object type from the target system and retry the operation.
IMP-00401: dump file "string" may be an Data Pump export dump file
Cause: A dump file was specified for an import operation which appears to have been created using the Data Pump export utility. These dump files cannot be processed by the original import utility.
Action: Try using the Data Pump import utility to process this dump file.


23 SQL*Loader-00100 to SQL*Loader-03121

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

23 SQL*Loader-00100 to SQL*Loader-03121

SQL*Loader-00100: Syntax error on command-line
Cause: Possible causes for this error include: placing a positional argument after keyword arguments, misspelling a keyword, not balancing parentheses or quotes, or leaving space between the operator, '=', and an argument.
Action: Check the command syntax and the spelling, then retry.
SQL*Loader-00101: Invalid argument for username/password
Cause: The username/password argument specified on the command line was not recognized. Another argument (not identified by a keyword) could be in the position where username/password is expected.
Action: Check the format of the username/password argument, which is the first argument on the command line, if arguments are given without keywords.
SQL*Loader-00102: Invalid control file name on command line
Cause: is the existence of a space between username and password. See error 101, above.
Action: Check the spelling and position of the arguments on the command line.
SQL*Loader-00103: Invalid log file name on command line
Cause: The log file name specified on the command line was not recognized. It could be misspelled, or another argument (not identified by a keyword) could be in its place.
Action: Check the spelling and position of the arguments on the command line.
SQL*Loader-00104: Invalid bad file name on command line
Cause: The bad file name specified on the command line was not recognized. It could be misspelled, or another argument (not identified by a keyword) could be in its place.
Action: Correct it.
SQL*Loader-00105: Invalid data file name on command line
Cause: The datafile name specified on the command line was not recognized. It could be misspelled, or another argument (not identified by a keyword) could be in its place.
Action: Check the spelling and position of the arguments on the command line.
SQL*Loader-00106: Invalid discard file name on command line
Cause: The discard file name specified on the command line was not recognized. It could be misspelled, or another argument (not identified by a keyword) could be in its place.
Action: Check the spelling and position of the arguments on the command line.
SQL*Loader-00107: Invalid maximum number of discards
Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.
Action: Check the command line and retry.
SQL*Loader-00108: Invalid number of logical records to load
Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.
Action: Check the command line and retry.
SQL*Loader-00109: Invalid number of logical records to skip
Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.
Action: Check the command line and retry.
SQL*Loader-00110: Invalid maximum number of errors
Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.
Action: Check the command line and retry.
SQL*Loader-00111: Invalid number of rows for bind array or data saves
Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.
Action: Check the command line and retry.
SQL*Loader-00112: Invalid maximum bind array size
Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.
Action: Check the command line and retry.
SQL*Loader-00113: Invalid silent mode option
Cause: The only valid options for the SILENT command-line argument are ALL, ERROR, FEEDBACK, or HEADER. The argument could be misspelled, or another argument (not identified by a keyword) could be in its place.
Action: Check the command line and retry.
SQL*Loader-00114: Error in OPTIONS statement
Cause: Command line options specified in the SQL*Loader control file with the OPTIONS clause were found to be incorrect.
Action: Check the format of the OPTIONS clause in the SQL*Loader control file.
SQL*Loader-00115: Invalid direct path option
Cause: The only valid options for the DIRECT command-line argument are TRUE or FALSE. The argument could be misspelled, or another argument (not identified by a keyword) could be in its place.
Action: Check the command line and retry.
SQL*Loader-00116: Error prompting for password
Cause: An internal error has occurred.
Action: Contact customer support.
SQL*Loader-00118: Invalid parallel load option
Cause: The command-line argument used for the parallel load is incorrect.
Action: Use only TRUE or FALSE as the value for the parallel load option.
SQL*Loader-00119: Invalid parallel file (data file) name on command line
Cause: The command-line argument for the parallel file was entered incorrectly.
Action: Check the command line argument and retry the operation.
SQL*Loader-00120: Invalid _synchro option string
Cause: The command-line argument _synchro is incorrect.
Action: Use only one of the allowed modes: see ulminv[].
SQL*Loader-00121: Invalid skip_unusable_indexes option
Cause: The command line argument for skip_unusable_indexes is incorrect.
Action: Use only TRUE or FALSE as the value for the skip_unusable_indexes option.
SQL*Loader-00122: Invalid skip_index_maintenance option
Cause: The command line argument for skip_index_maintenance is incorrect.
Action: Use only true or falseas the value for the skip_index_maintenance option. (Note: only on direct loads!)
SQL*Loader-00123: specified value for bindsize(number) less than readsize(number)
Cause: The command line argument specified for bindsize was less than the value of readsize.
Action: No action is required. SQL*Loader automatically adjusts the value of bindsize to equal the value of readsize.
SQL*Loader-00124: specified value for readsize(number) less than bindsize(number)
Cause: The command line argument specified for readsize was less than the value of bindsize.
Action: No action is required. SQL*Loader automatically adjusts the value of readsize to equal the value of bindsize.
SQL*Loader-00125: specified value for readsize(number) less than max_record_size(number)
Cause: The command line argument specified for readsize was less than the value of max_record_size.
Action: No action is required. SQL*Loader automatically adjusts the value of readsize to equal the value of max_record_size.
SQL*Loader-00126: Invalid read size
Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.
Action: Check the command line and retry.
SQL*Loader-00127: Invalid maximum record size
Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.
Action: Check the command line and retry.
SQL*Loader-00128: unable to begin a session
Cause: An error occurred when attempting to start a session on the database.
Action: See the message that follows this message for information on the cause of the error.
SQL*Loader-00129: Invalid number of rows for direct path column array
Cause: The argument's value is inappropriate
Action: Check the command line and retry.
SQL*Loader-00130: Invalid direct path stream size
Cause: The argument's value is inappropriate
Action: Check the command line and retry.
SQL*Loader-00131: Invalid multithreading option
Cause: The only valid options for the MULTITHREADING command-line argument are TRUE or FALSE. The argument could be misspelled, or another argument (not identified by a keyword) could be in its place.
Action: Check the command line and retry.
SQL*Loader-00132: invalid argument for external table option
Cause: The command line argument specified for external_tables was not TRUE or FALSE
Action: Check the command line and retry.
SQL*Loader-00133: Can't specify both direct path and external tables
Cause: Both options for direct path and exrernal tables were indicated. Only one of these can be applied at a time.
Action: Change at least one of the parameters to enable only one.
SQL*Loader-00134: invalid option specified for EXTERNAL_TABLE parameter
Cause: An invalid value was specified for the EXTERNAL_TABLE parameter.
Action: Specify one of the following values. NOT_USED disables use of external tables. GENERATE_ONLY generates the SQL statements that will use external tables to load the data. EXECUTE both generates the SQL statements and then executes them.
SQL*Loader-00135: Invalid argument for RESUMABLE
Cause: The command line argument specified for RESUMABLE was not TRUE or FALSE.
Action: Check the command line and retry.
SQL*Loader-00136: Invalid argument for RESUMABLE_NAME
Cause: The command line argument specified for RESUMABLE_NAME was not a valid string.
Action: Check the command line and retry.
SQL*Loader-00137: Invalid value for RESUMABLE_TIMEOUT
Cause: The command line argument specified for RESUMABLE_TIMEOUT was not a valid positive integer.
Action: Check the command line and retry.
SQL*Loader-00138: Invalid value for DATE_CACHE
Cause: The command line argument specified for DATE_CACHE was not a valid positive integer.
Action: Check the command line and retry.
SQL*Loader-00200: FORMAT clause should not be present - flat data files only
Cause: SQL/DS FORMAT clause is not supported.
Action: Remove the FORMAT command from the SQL*Loader control file or
SQL*Loader-00250: Work data sets are not used by SQL*Loader
Cause: The SQL*Loader control file contains a WRKDDN statement. SQL*Loader ignores this clause.
Action: No action required. This is an informational message.
SQL*Loader-00251: Sort devices are not used by SQL*Loader
Cause: The SQL*Loader control file contains a SORTDEVT statement. SQL*Loader ignores this clause.
Action: No action required. This is an informational message.
SQL*Loader-00252: Sort data sets are not used by SQL*Loader
Cause: The SQL*Loader control file contains a SORTNUM statement. SQL*Loader ignores this clause.
Action: No action required. This is an informational message.
SQL*Loader-00253: DB2 partition number has no significance -- ignored
Cause: The SQL*Loader control file contains a PART statement. SQL*Loader ignores this clause.
Action: No action required. This is an informational message.
SQL*Loader-00254: Cannot have DISCARDFILE specs here when multiple data files
Cause: The SQL*Loader control file contained multiple INFILE statements and a DISCARDFILE statement was found below the RESUME clause.
Action: Move the DISCARDFILE statement above the RESUME clause, so it is adjacent to one of the INFILE statements.
SQL*Loader-00255: Log file for error recovery not used by SQL*Loader
Cause: The SQL*Loader control file contains a LOG statement. SQL*Loader ignores this clause.
Action: No action required. This is an informational message.
SQL*Loader-00256: SORTED INDEXES option allowed only for direct path
Cause: The SQL*Loader control file contains a SORTED INDEXES statement, but it was not used in a direct path load.
Action: Specify a direct path load with DIRECT=TRUE on the command line, remove the statement from the SQL*Loader control file, or
SQL*Loader-00257: TERMINATED BY EOF option not valid with ENCLOSED BY option
Cause: A field description in the SQL*Loader control file contains both the TERMINATED BY EOF and the ENCLOSED BY options. These options are mutually exclusive.
Action: Remove either or both of the clauses.
SQL*Loader-00258: Maximum number of SORTED INDEXES (number) exceeded on table string
Cause: There are too many indexes in the SORTED INDEX clause. The message displays the maximum number that are permitted.
Action: Reduce the number of indexes specified in the SORTED INDEX clause or use the conventional path load instead of the direct path load.
SQL*Loader-00259: Could not escalate DDL share lock to exclusive on table string
Cause: This error occurs when another user has a parse lock on the table, for example, when another user is doing a select on the table. The parse lock should clear momentarily.
Action: Give the parse lock a chance to clear and then retry or else use the conventional path load.
SQL*Loader-00260: TERMINATED BY EOF option available only with LOBFILE option
Cause: The TERMINATED BY EOF option can be used only when describing data to be loaded from a LOBFILE. It cannot be specified at the table level and it cannot be for data in "regular" data files.
Action: Verify that you have specified the correct option for TERMINATED BY and verify that the TERMINATED BY option is specified for the correct fields.
SQL*Loader-00261: illegal use of TERMINATED BY for RAW field
Cause: The TERMINATED BY option cannot be used for loading data of type RAW from the data file. The only exception is when loading RAW data from LOBFILES. In that case, you may specify the TERMINATED BY EOF option.
Action: Remove the TERMINATED BY option from the RAW field in the SQL*Loader control file.
SQL*Loader-00262: PIECED keyword (on column string) allowed only when path is direct
Cause: The PIECED keyword cannot be used in a conventional path load.
Action: Remove the PIECED keyword or use the direct path load.
SQL*Loader-00263: PIECED column string must be last specified column in table string
Cause: A column that is not the last column was specified as PIECED.
Action: Remove the PIECED keyword or place the column last.
SQL*Loader-00264: File mode token string parsed but ignored
Cause: An obsolete file mode token was used in the SQL*Loader control file. As of Release 1.1 of SQL*Loader, the file-processing options string is used to control file processing, rather than keywords like STREAM, RECORD, FIXED, and VARIABLE.
Action: No action required. This message is informational. Removing the obsolete keywords will eliminate the message without changing the way in which the datafile is processed.
SQL*Loader-00265: Unable to get default character set name.
Cause: SQL*Loader was unable to locate the default character set name for the environment.
Action: Supply a character set name with the CHARACTERSET keyword.
SQL*Loader-00266: Unable to locate character set handle for string.
Cause: SQL*Loader could not find the character set handle for the named character set.
Action: Correct the character set name.
SQL*Loader-00267: Control file must be first data file.
Cause: The SQL*Loader control file is specified as containing data using the INFILE "*" clause, but other datafiles were named first.
Action: Move the INFILE "*" clause so that it is the first datafile declared in the SQL*Loader control file.
SQL*Loader-00268: UNRECOVERABLE keyword may be used only in direct path.
Cause: The UNRECOVERABLE keyword can only be specified in the direct path load.
Action: Use the direct path load or remove the keyword. (Conventional path loads are always recoverable).
SQL*Loader-00269: Null string not allowed as clause comparison text.
Cause: A clause is being compared to a null string.
Action: Modify the clause to compare to at least one character.
SQL*Loader-00270: TERMINATED BY EOF valid only for CHAR or RAW datatypes
Cause: A field description in the SQL*Loader control file used the TERMINATED BY EOF option when the field was not a RAW or CHAR datatype.
Action: Modify the SQL*Loader control file to either remove the TERMINATED BY EOF clause or change the datatype for the field to be CHAR or RAW.
SQL*Loader-00271: Not a Parallel load. Table level OPTIONS statement ignored.
Cause: A table-level OPTIONS statement was specified for a non-parallel load.
Action: Remove the OPTIONS statement from the SQL*Loader control file.
SQL*Loader-00272: Table level OPTIONS statement ignored.
Cause: In the parallel load option, the file specified on the command line overrides the file specified in the SQL*Loader control file.
Action: Remove the OPTIONS statement from the SQL*Loader control file.
SQL*Loader-00273: READBUFFERS may be used only in direct path.
Cause: The READBUFFERS specification was not entered as part of a direct path.
Action: Use the direct path or remove the READBUFFERS specification from the SQL*Loader control file.
SQL*Loader-00274: At least 2 read buffers have to be specified.
Cause: Fewer than 2 read buffers have been specified.
Action: Specify at least 2 read buffers in the READBUFFERS statement, in the SQL*Loader control file.
SQL*Loader-00275: Data is in control file but "INFILE *" has not been specified.
Cause: The INFILE specification was not entered in the SQL*Loader control file.
Action: If data in the SQL*Loader control file is to be read, specify INFILE * in the SQL*Loader control file.
SQL*Loader-00276: Local storage option overrides global storage.
Cause: A storage clause has been specified in the table level options statement and also in the global options statement.
Action: This is only a warning message. Table level options take precedence over global options. Drop the table level options statement if this is not the intent.
SQL*Loader-00277: Local file specification overrides global file specification.
Cause: A filename has been specified in the table level options statement and also in the global options statement.
Action: This is only a warning message. Table level options take precedence over global options. Drop the table level options statement if this is not the intent.
SQL*Loader-00278: Incorrect file specification for parallel load.
Cause: The filename used to perform the parallel load was entered incorrectly.
Action: Correct the filename and re-invoke parallel loader.
SQL*Loader-00279: Only APPEND mode allowed when parallel load specified.
Cause: INSERT, REPLACE, or TRUNCATE mode was used in a parallel load specification.
Action: Change the SQL*Loader control file to use the APPEND keyword and re-invoke the parallel loader.
SQL*Loader-00280: table string is a temporary table
Cause: The sqlldr utility does not load temporary tables. Note that if sqlldr did allow loading of temporary tables, the data would disappear after the load completed.
Action: Load the data into a non-temporary table.
SQL*Loader-00281: Warning: ROWS parameter ignored in parallel mode.
Cause: Specifying save points using the ROWS parameter is not supported for parallel loads.
Action: Remove the ROWS parameter from the command-line arguments or specify a non-parallel direct load to have save points performed.
SQL*Loader-00282: Unable to locate character set handle for character set ID (number).
Cause: SQL*Loader could not find the character set handle for the given character set ID.
Action: The character set ID was obtained from the database server, the SQL*Loader client does not have knowledge of the given character set ID. Possible mis-match of NLS data on the client and server side.
SQL*Loader-00283: file processing string "string" ignored for INFILE *
Cause: The SQL*Loader control file specified INFILE * for a load data file along with an optional file processing string. This message is a warning that the file processing string will be ignored since SQLLDR will expect the data to have the same record format as the SQL*Loader control file.
Action: If the data in the SQL*Loader control file is in the same format as the rest of the SQL*Loader control file, then you don't need to do anything. Removing the file processing string will get rid of this error message. If the data in the SQL*Loader control file has a different record format, then you need to copy the data into a separate file and use that file's name in the INFILE clause.
SQL*Loader-00284: Warning: Input data file string specified multiple times.
Cause: The same input datafile is loaded multiple times. This can occur if the INFILE keyword is placed out of order in the load syntax statement, which causes the filename of the first datafile loaded to default to the name of the control file with an extension or file type of DAT.
Action: Check that INFILE keyword is not placed after one of these - BADFILE/BADDN/DISCARDFILE/DISCARDDN/DISCARDS.
SQL*Loader-00285: %s may be used only in conventional path.
Cause: HIDDEN can only be specified in the conventional path load.
Action: Use the conventional path load.
SQL*Loader-00286: ROWS parameter is not supported when loading an IOT.
Cause: Specifying save points using the ROWS parameter is not supported when loading an IOT.
Action: Remove the ROWS parameter from the command-line arguments.
SQL*Loader-00287: No control file name specified.
Cause: No control file name was provided at the control prompt.
Action: Provide the name of a valid control file at the prompt or on the command line.
SQL*Loader-00288: Delimiters may not be specified for collections stored in SDF.
Cause: A TERMINATED BY or ENCLOSED BY clause was found along with an SDF (secondary data files) clause for a nested table or varray field.
Action: The TERMINATED BY or ENCLOSED BY clauses may be specified only if the nested table or VARRAY data is stored in the record in the main data file. If you are loading nested table or VARRAY data from a secondary data file, then you must use COUNT to indicate the number of elements in the secondary data file that are stored in the file.
SQL*Loader-00289: SQL string for column string occludes SQL string for column string.
Cause: A SQL string has been associated with both a column object and one of its attributes in the control file. Because the SQL string of the column object will replace the entire column object in the VALUE clause of the INSERT statement, the SQL string of the attribute is ignored. This could cause unexpected or incorrect values to be loaded.
Action: Correct the control file so that only the column object or its attribute has a SQL string, but not both.
SQL*Loader-00290: PIECED keyword (on column string) allowed only for lob or long columns
Cause: The PIECED keyword cannot be used for non lob or long columns.
Action: Remove the PIECED keyword or use lob or long column type.
SQL*Loader-00291: Invalid bind variable string in SQL string for column string.
Cause: A bind variable may not refer to a filler field or to a non-existent field. Also, when running in direct-path mode, a bind variable may not refer to field that represents a LOB stored in a secondary file or a collection.
Action: Remove the offending bind variable from the SQL string.
SQL*Loader-00292: ROWS parameter ignored when a LOB column is loaded
Cause: Command-line arguments contained a ROWS parameter. Specifying save points using the ROWS parameter is not supported when any table being loaded contains a LOB.
Action: Remove the ROWS parameter from the command-line arguments.
SQL*Loader-00293: Missing XMLTYPE directive in control file for table string
Cause: A table of sys.xmltype must specify the XMLTYPE directive.
Action: Add XMLTYPE directive to control file.
SQL*Loader-00294: invalid name % specified in TREAT AS clause
Cause: The type name specified in a TREAT AS clause is invalid. It might contain characters that are not valid in the client character set or a quoted string might not be terminated or the name might be too long to contain a valid schema name and type name.
Action: Verify that the type name has valid characters and is not too long. Also, ensure that all quoted strings are terminated.
SQL*Loader-00303: Non-hex character encountered where hex char expected
Cause: A non-hex character was found in a hexadecimal string.
Action: Change it to the intended hexadecimal character.
SQL*Loader-00304: Illegal combination of non-alphanumeric characters
Cause: The SQL*Loader control file contains a combination of non-alphanumeric characters that SQL*Loader does not recognize. For example, the combination != is recognized as "not equal", but the combination =! is not valid.
Action: Remove the unrecognized characters from the control file.
SQL*Loader-00305: More than one end of file character encountered
Cause: The file contains multiple end-of-file marks.
Action: Remove the excess end-of-file characters.
SQL*Loader-00306: Token longer than max allowable length of number chars
Cause: The SQL*Loader control file contains a single word or combination of characters (a token) that is longer than the maximum permissible value. The maximum possible value is shown. This error could result from missing spaces, so that multiple tokens are joined.
Action: Check that the proper SQL*Loader control file is being executed Separate tokens, if joined, or shorten the token.
SQL*Loader-00307: Warning: conflicting lengths number and number specified for column string table string
Cause: The SQL*Loader control file specifies two different lengths for the named column. There are three ways to specify the length of a field: --with the POSITION keyword: POSITION(1:3) -- with the length specifier: CHAR(6) -- with the implied length of a datatype; for example, INTEGER -- A conflict could occur between any two of these specifications (or among all three, but only two are shown). A common cause of this error is the specification of some numeric datatype, such as INTEGER, when the numeric external form is intended (INTEGER EXTERNAL). The external form consists of character data, so it is considerably longer than the numeric form, which consists of binary data.
Action: No action is necessarily required, because SQL*Loader uses only one of the lengths. Check the log file under the heading "Len" in the table-description section to see which length was used. Adjusting the SQL*Loader control file to produce uniform length specifications will remove the warning.
SQL*Loader-00308: %s SQL string of column string must be in double quotes.
Cause: A SQL string was found that was not quoted or in single quotes.
Action: Use double quotes for the SQL string, rather than single quotes.
SQL*Loader-00309: No SQL string allowed as part of string field specification
Cause: Particular field types do not allow SQL strings as part of their field specification (e.g. field corresponding to a LOB column). This was violated and needs to be corrected.
Action: Remove the SQL string from the particular field specification.
SQL*Loader-00350: Syntax error at line number.
Cause: num identifies the line in the SQL*Loader control file at which the error occurred. This message is followed by another of the form -- Expecting str1, found str2 where str1 is a description of what SQL*Loader expected in the SQL*Loader control file, and str2 is what was found. Then SQL*Loader displays the offending line from the SQL*Loader control file, indicating the location of the error in the line by a carat (^) or an asterisk (*). An example follows: -- SQL*Loa er-350: Syntax error at line 28 -- Expecting column name, found keyword CHAR -- col3 ENCLOSED BY '"', CHAR ENCLOSED "'",
Action: Compare the DDL syntax against the syntax diagrams in Oracle7 Server Utilities and make any necessary corrections.
SQL*Loader-00401: End field position number must be greater than or equal to start number
Cause: The named field contains a (start:end) clause in which end is less than start.
Action: Modify the clause so that end is greater than or equal to start.
SQL*Loader-00402: Unable to determine length of column string from specification
Cause: The specified datatype does not have an implied length (for example, a numeric external or RAW datatype), it is not specified with delimiters, no length was specified, and a length cannot be determined from a POSITION clause.
Action: If a POSITION clause is specified, adding an end location to it produces a length specification. This clause then has the form POSITION(start:end) A length can also specified after the datatype, as in INTEGER EXTERNAL (6) Finally, the field could be specified with delimiters, or the datatype changed to one that has an implied length.
SQL*Loader-00403: Referenced column string not present in table string.
Cause: The named column is not present in the given table.
Action: Correct the column name or table name.
SQL*Loader-00404: Column string present more than once in string's INTO TABLE block.
Cause: The named column is specified more than once in a single INTO TABLE statement.
Action: Remove the extraneous column specification.
SQL*Loader-00405: Need termination delim with optional enclosure delim: column string table string
Cause: The named column was specified with an optional enclosure delimiter, but no termination delimiter. Enclosure delimiters can only be optional when termination delimiters are present.
Action: Specify a termination delimiter or make the enclosure delimiters non-optional.
SQL*Loader-00406: If data is all generated, number to load cannot be ALL
Cause: When only generated data is loaded, a number to load must be given so SQL*Loader knows when to stop.
Action: Specify a number to load.
SQL*Loader-00407: If data is all generated, number to skip is meaningless
Cause: When all data is generated, no file is read, and there are no records to skip.
Action: Remove the number to skip.
SQL*Loader-00408: Physical record stack overflow
Cause: An internal error has occurred.
Action: Contact customer support.
SQL*Loader-00409: Number to skip must be table-level, not load-level on continued loads
Cause: The SKIP parameter was specified on the command line or in the OPTIONS statement, but the load was specified as continued with CONTINUE_LOAD. When a multiple-table direct load is interrupted, it is possible that a different number of records were loaded into each table. As a result, the number of records to skip must be specified for each table when continuing the load. In this case, the load is specified as continued with the CONTINUE_LOAD statement, and the number of records to skip is given in each INTO TABLE statement. See also messages 410 and 411 for more information.
Action: Check the log file to determine the appropriate number of records to skip for each table and specify this number in the INTO TABLE statement for each table in a continued load or with the command-line SKIP parameter in a standard load.
SQL*Loader-00410: Number to skip must be load-level, not table-level
Cause: A SKIP clause was found in the INTO TABLE statement of a standard (non-continued) load. In a standard load, specified with LOAD DATA, it is not possible to skip a different number of records for each table. The number of records to skip must be specified for the entire load by using the SKIP parameter on the command line or in the OPTIONS clause. If table-level skip is required, because a different number of records were loaded into each table (only possible for a multiple- table direct load), then specify a continued load with the CONTINUE_LOAD statement. See also messages 409 and 411 for more information.
Action: If the load was not a multiple-table, direct path load, then move the SKIP clause from the INTO TABLE statements to the command line or to the OPTIONS clause. Otherwise, specify the load as continued with CONTINUE_LOAD.
SQL*Loader-00411: Only a direct path load may be continued
Cause: The load is specified with CONTINUE_LOAD, but DIRECT=FALSE. CONTINUE_LOAD is only possible for a direct path load and is only necessary for a multiple-table, direct path load when a different number of records have been loaded into each table. See also messages 409 and 410 for more information.
Action: If CONTINUE_LOAD is necessary, specify a direct load and put the number of records to skip in each INTO TABLE statement. Otherwise, use the command line or OPTIONS clause to specify the number of records to skip and use LOAD DATA instead of CONTINUE_LOAD.
SQL*Loader-00412: More columns specified for table string than the maximum (number)
Cause: More columns were specified for the table than the maximum number allowed by the database.
Action: Remove the extraneous columns.
SQL*Loader-00413: NULLIF or DEFAULTIF clause specified for filler field string in table string.
Cause: A NULLIF or DEFAULTIF clause was specified in the SQL*Loader control file for the named filler field. These options cannot be specified for filler fields.
Action: Remove the NULLIF or DEFAULTIF clause from the field definition.
SQL*Loader-00414: no columns to load for table string
Cause: There were no fields in the data file to be loaded for the table. Probably all fields were identified as FILLER fields.
Action: Verify that the FILLER attribute was set correctly for the fields.
SQL*Loader-00415: column string in table string cannot use and be the object of an SDF or LOBFILE
Cause: The named column is identified as the target of a secondary data file (SDF) or LOBFILE clause. However, the column also gets it's value from an SDF or LOBFILE. If a field name is named in an SDF or LOBFILE clause, then that field cannot have an SDF or LOBFILE clause.
Action: Verify that the SDF and LOBFILE clauses in the SQL*Loader control file name the correct fields. Also verify that the SDF and LOBFILE clauses are specified for the correct field.
SQL*Loader-00416: SDF clause for field string in table string references a non existent field.
Cause: The secondary data file clause for the field identified another field that doesn't exist in the table definition for the SQL*Loader control file.
Action: Verify the definition of the secondary data file to make sure it identifies the intended field.
SQL*Loader-00417: SQL string (on column string) not allowed in direct path.
Cause: Because the direct path bypasses SQL processing, the SQL string cannot be used.
Action: Remove the SQL string or use the conventional path.
SQL*Loader-00418: Bad datafile datatype for column string
Cause: The datatype in the data file specified for the column cannot be used to load the column. This message is often displayed for columns that need to be loaded with special features. For example, BFILE columns can only be loaded via the BFILE directive in the control file; same goes for REF fields. in the SQL*Loader control file. Similarly, REF columns can only be loaded with theREF datatype in the SQL*Loader control file.
Action: Determine the datatype of the column in the database check the
SQL*Loader-00419: input datatype for column string is not supported when loading varrays
Cause: The datatype in the SQL*Loader control file for the column is cannot be used to load data in a varray.
Action: Use a different datatype.
SQL*Loader-00420: unsupported datatype conversion requested for column string in table string
Cause: The colummn needs to have it's data converted to another datatype before loading the data. The required conversion cannot be done by sqlldr.
Action: Verify that the correct datatype was specified for the column.
SQL*Loader-00421: error converting data
Cause: This message can be displayed as one of the reasons for rejecting a row. The sqlldr utility was attempting to convert data for the column from its datatype in the data file to the datatype for the column in the database. This message should be followed with another message describing the conversion error.
Action: Correct the data in the data file so that it can be converted.
SQL*Loader-00422: constant element count of number for column string is greater than maximum, number
Cause: The number of elements specified for a varray column in a table is greater than the maximum number of elements allowed for the type of the varray column.
Action: Increase the number of elements allowed for the type or remove unwanted elements from the data file.
SQL*Loader-00423: element count is greater than maximum allowed for the column
Cause: When building a varray from the data file, SQL*Loader encountered more varray elements than are allowed for the column.
Action: The previous error messges contain the name of the column and the row number containing the bad data.
SQL*Loader-00424: table string makes illegal reference to collection field string
Cause: A WHEN, OID or SID clause for the table refers to a field declared inside of a collection.
Action: Move the data containing the value for a SID or OID clause outside of the collection definition.
SQL*Loader-00425: column string makes illegal reference to collection field string
Cause: A clause, such as NULLIF or BFILE clause, for the column refers to a field declared inside of a collection.
Action: Move the data containing the value for a SID or OID clause outside of the collection definition.
SQL*Loader-00426: count of elements in VARRAY string comes after the data for the varray
Cause: The COUNT clause for a VARRAY field indicates that the count of elements in the varray is stored in another data field. However, that data field comes after the varray data in the data file. Since finding the count field would require SQL*Loader to know the number of elements in the VARRAY first, SQL*Loader requires that the count field come before the VARRAY data.
Action: Move the count field to be before the collection data in the data file.
SQL*Loader-00427: a field condition references a non-scalar field or a LOB field string
Cause: The field condition is referencing a field which is either a nested table, varray, column object, LOB or BILE field. These fields with these typescannot be references by other field.
Action: Correct the NULLIF, DEFAULTIF, or WHEN clauses to reference only non-LOB scalar data fields.
SQL*Loader-00428: count for field string not stored in character or integer field
Cause: The count clause for a field references another field, but the referenced field is not a character or integer datatype.
Action: Modify the count field so that it reference a a data field that has the count in an integere or character format.
SQL*Loader-00429: insufficient number of elements found for varray
Cause: The COUNT directive was specified for a varray, but the number of elements found is less than the number specified by the COUNT directive.
Action: Correct the data so that the count and the number of elements agree.
SQL*Loader-00430: NULL nested table element is not allowed
Cause: A row in a nested table was set to NULL. Nested tables cannot contain NULL fields.
Action: Correct the data so that there are no NULL rows in the nested table.
SQL*Loader-00431: illegal NULLIF or DEFAULTIF clause specified for nested table column string
Cause: Rows in a nested table annot be set to NULL. SQLLDR displays this error when a NULLIF clause was specified for the element that defines the row that make up a nested table. SQLLDR also displays this error if a DEFAULTIF clause is specified for an element that is a named type, since SQLLDR will set a named type to NULL if the DEFAULTIF evaluates to TRUE.
Action: none
SQL*Loader-00432: converted data too large
Cause: This message is preceded by a message identifying a row and column. It is displayed when there is insufficient room to convert the data from the datatype in the input file to the datatype for the column in the database.
Action: Modify the data so that it fits in the database field.
SQL*Loader-00433: no attributes found for column object string in table string
Cause: No attributes are to be loaded for a column object named in the control file. This can happen if all fields in the definition for the column object in the control are designated as FILLER fields.
Action: Either specify attributes to load for the column object or remove the column object from the control file.
SQL*Loader-00434: Can not load LOB/XML in a nested table along with the parent table.
Cause: Loading LOBs and XML data within a nested table at the same time as the parent table is not supported.
Action: Load the nested table with the LOB or XML column separately from the parent table.
SQL*Loader-00435: invalid constant value string for nested table column string
Cause: A constant value was specified for the SETID of a nested table column. An error occured while translating the character constant into a SETID.
Action: Make sure the constant string contains valid hexadecimal characters and that there are 32 hexadecimal characters.
SQL*Loader-00436: error converting GUID
Cause: The value of the field named in the message is used to populate the column named in the messsage. Because column is a Set ID or an Object ID, the field needs to be converted. This message indicates that there was a conversion error. If the field is a character field, then the conversion error could be caused by too many or too few haxeadecimal charactersI. Also, one or more of the characters in the field might not be a valid hexadecimal character. If the field contains RAW data, then either too many or to few bytes were specified for the field.
Action: Fix the data and reload the row.
SQL*Loader-00440: Invalid table specified as scope of a REF
Cause: As part of the REF directive one specifies the table name or another fields name which contains the table name of the table which the REF references.
Action: Make sure that the right referenced table name is specified.
SQL*Loader-00456: end of collection found after number elements when looking for number elements
Cause: A count value was specified for a varray or nested table column and the number of rows found is less than the number of rows specified
Action: Verify that the count field has the correct value and that there is no missing data for the collection.
SQL*Loader-00457: Comparison text of CONTINUEIF LAST must have length 1 not number
Cause: The comparison text is too long. It can only be one character.
Action: Reduce the comparison text to one character.
SQL*Loader-00458: Comparison text ('string') of CONTINUEIF LAST must be non-whitespace
Cause: The comparison text is a whitespace character (blank or tab).
Action: Change the comparison text to a non-whitespace character.
SQL*Loader-00459: error fetching numeric value for sequence on column (string)
Cause: An attempt was made to retrieve a non-numeric value for a sequenced column.
Action: Verify that the data for the sequenced column is numeric. Then retry the operation.
SQL*Loader-00460: Column (string), form of use (number) does not match char set id of (number)
Cause: The given column with the given form of use does not have the same character set ID as a previous column with the same form of use.
Action: This should not happen. Contact ORACLE support and supply the following information: DDL for the table being loaded, and the SQL*Loader control file. ADDED in 8.1
SQL*Loader-00461: direct path loading of datatype for column string not supported
Cause: The datatype for the specified column is one that cannot be loaded with direct path.
Action: If the datatype is supported with conventional path, load the table using conventional path.
SQL*Loader-00462: error inserting LOB into column string, row number, table string
Cause: An error occurred while attempting to write a lob into a row.
Action: See accompanying messages describing why the LOB could not be loaded, what actions sqlldr took (if any), and where the errors may be in order to reload.
SQL*Loader-00463: secondary data file for LOB is string
Cause: The secondary data file that was in use for populating the LOB when an error occured.
Action: none
SQL*Loader-00464: file offset for beginning of lob is string
Cause: The offset into the secondary data file that contains the start of the LOB that was being written when an error occured.
Action: none
SQL*Loader-00465: %s directive expects number arguments, number found.
Cause: You specified a directive such as COUNT() or BFILE() in the SQL*Loader control file. This directive specifies a fixed number of arguments, but the SQL*Loader control file contains a different number of arguments.
Action: Correct the SQL*Loader control file so that the directive contains the correct number of arguments.
SQL*Loader-00466: Column string does not exist in table string.
Cause: The SQL*Loader control file specified a table column that does not exist.
Action: none
SQL*Loader-00467: attribute string does not exist in type string for table string.
Cause: The SQL*Loader control file specified an attribute that does not exist for the specified type. The table that contains the type is also identified in the error message.
Action: Verify that the correct table in the correct schema is named in the SQL*Loader control file. Also verify that the column name is spelled correctly.
SQL*Loader-00468: OID directive expects 1 argument, number found.
Cause: More than one argument was specified for an OID clause.
Action: Specify the name of the field containing the value to use for the OID. If the OID for the table is user-defined, then do not use the OID clause in the control file.
SQL*Loader-00469: SID directive expects 1 argument, number found.
Cause: More than one argument was specified for a SID clause.
Action: Only specify the name of the field containing the value to use for the SID in the SID clause.
SQL*Loader-00470: table string does not have system generated OID
Cause: You specified an OID clause for a table but the table is either not an object table or the table is an object table but the OIDs for the rows are not system generated.
Action: Verify that the you are loading the correct table. If you are, then you must not specify the OID clause for this table. You should use the OID clause only when the table is an object table, has system generated OIDs and when you want to specify OIDs to be assigned to each row of the table.
SQL*Loader-00471: OID or SID clause has an argument that is CONSTANT
Cause: You specified a CONSTANT as an argument in an OID clause for an object table or in the SID clause for a nested table column. Since these columns must have unique values, SQL Loader does not allow the a constant to be specified for their values.
Action: Store the OID for each row in a filler field and specify the name of the filler field as an argument.
SQL*Loader-00472: collections can contain only one non FILLER field specification
Cause: More than one non filler field specification is found in a collection field's member field list.
Action: See correct syntax in the Utilities Manual. If indeed there is more than one attribute that makes up the particular collection, then it must be a collection of a object type which needs to be specified using the COLUMN OBJECT field specification syntax.
SQL*Loader-00473: nesting of collections is not allowed.
Cause: Nesting of one collection type field description within another is not allowed.
Action: Verify that collection nesting is attempted in the SQL*Loader control file. Correct the mistake.
SQL*Loader-00474: no value set for dynamic file for column string in table string row number
Cause: The data for the named column is in a dynamic LOBFILE or secondary data file. This message is returned when the field containing the name of the file with the data for this field has not been set or is NULL. This could be because the record in the data file does not match the format described by the SQL*Loader control file.
Action: Correct any errors in the data file or the SQL*Loader control file.
SQL*Loader-00475: field for dynamic file name is string in table string
Cause: This message is always displayed after message 474.
Action: none
SQL*Loader-00476: count of elements for collection is not set or null, 0 will be used
Cause: This message is displayed following a message that identifies the column and row that contained the problem. The message indicates that the collection field named in the previous message has the count of elements in the collection stored in another field. This message is displayed if the field containing the count does not have a value or is set to NULL. When this happens, SQL*Loader uses 0 as the number of elements.
Action: If 0 is not the count of elementsfor the collection, correct the data in the data file.
SQL*Loader-00477: REF directive for field string requires at least two arguments
Cause: The SQL Loader control file contains a REF directive for the field, but only one argument was supplied for the directive. The REF directive always requires at least two arguments.
Action: Supply the missing argument to the REF directive. Remember that you must always supply a table name to the REF directive even if the REF is scoped.
SQL*Loader-00478: unable to continue due to missing filename for LOBFILE or SDF
Cause: The name for a LOBFILE or secondary data file is either missing or NULL for the current row. SQL*Loader is unable to continue loading since it can't determine how to get the LOB for the next row.
Action: Correct the data file so that there are valid values for all fields containing the names of LOBFILEs and secondary data files.
SQL*Loader-00479: REF directive for column string expects number arguments; found number.
Cause: The number of arguments in the REF directive for the column is incorrect.
Action: Specify the correct number of arguments for REF. Remember that the REF directive always requires a table name. Also, primary key REFs require one arguments for each field in the primary key.
SQL*Loader-00480: EXPRESSION may not be used with elements of a collection.
Cause: The EXPRESSION keyword is followed by a required SQL string expression and is used to load a column with the result of the SQL string expression instead of with a value from the input data file. However, this capability is not allowed with elements of a collection.
Action: Remove the EXPRESSION keyword and associated SQL string from the collection element in the control file.
SQL*Loader-00481: HIDDEN may not be used with non-scalar fields.
Cause: The HIDDEN keyword is only allowed for scalar fields.
Action: Remove the HIDDEN keyword from the non-scalar field in the control file.
SQL*Loader-00486: sql-strings may not be specified for collection field string
Cause: A sql-string was specified as part of the description of the field that is inside a nested table or varray. Sql-strings cannot be used to load a field in a varrary or nested tables.
Action: Remove the sql-string from the field description. Modify the data file so that it contains the values to be loaded into the column in the collection.
SQL*Loader-00487: COUNT clause required for collection string
Cause: A VARRAY or NESTED TABLE was defined in the SQL Loader control file and all of the fields in the VARRAY or NESTED TABLE are generated by SQL Loader and do not come from a data file. SQL Loader requires a COUNT clause be specified so that it knows how many elements to add to the VARRAY or NESTED TABLE for each row.
Action: Add a COUNT clause to the VARRAY or NESTED TABLE definition.
SQL*Loader-00488: %s not a named collection type for filler field string
Cause: The FILLER option was specified for a VARRAY or NESTED TABLE field in the SQL Loader control file. However, the type name specified for the field is not the name of a VARRAY or NESTED TABLE type.
Action: Verify that the correct type name was specified. If the type is defined in a different schema, also verify that the correct schema name is specified.
SQL*Loader-00500: Unable to open file (string)
Cause: SQL*Loader could not open the named file.
Action: Check the operating system messages below this one in the log file.
SQL*Loader-00501: Unable to read file (string)
Cause: SQL*Loader could not read the named file.
Action: Check the operating system messages following this message in the log file.
SQL*Loader-00502: unable to open data file 'string' for field string table string
Cause: An attempt to open a LOBFILE or secondary data file failed.
Action: Check the operating system messages following this message for information on why the open failed. Verify that the correct name is specified for the LOBFILE or secondary data file.
SQL*Loader-00503: Error appending extension to file (string)
Cause: SQL*Loader could not append the default extension to create the filename. The given name could be too long or contain illegal characters.
Action: Check the specified filename.
SQL*Loader-00504: Error skipping records in file (string)
Cause: SQL*Loader could not open the file or could not read from it.
Action: Check that the file is where it is expected and that read access has been granted.
SQL*Loader-00505: error reading LOBFILE
Cause: An attempt to read a secondary data file failed.
Action: Check the operating system message that follows this message for more information.
SQL*Loader-00506: formatting error reading SDF or LOBFILE string for column string in table string
Cause: The the record format of the named LOBFILE or SDF file is incorrect.
Action: Fix the record formatting problems in the file.
SQL*Loader-00507: unexpected EOF reading SDF or LOBFILE string for column string in table string
Cause: The end of file was reached for a secondary data file or LOBFILE before the data for the current row was found.
Action: If the file is a LOBFILE, verify the correct datatype was specified for the field. If the file is a secondary data file, make sure the record format is specified correctly in the SQL*Loader control file.
SQL*Loader-00508: record formating error in data file string
Cause: The data found in the data file does not correspond to the record format in the SQL*Loader control file.
Action: Verify that all records in the data file match the format as described in the SQL*Loader control file.
SQL*Loader-00509: System error: string
Cause: A platform-specific error was returned during an operation. This message is used to display the text of the error.
Action: none
SQL*Loader-00510: Physical record in data file (string) is longer than the maximum(number)
Cause: The datafile has a physical record that is too long.
Action: Use CONCATENATE or CONTINUEIF. Break up the physical records.
SQL*Loader-00511: Unable to initialize read functions
Cause: SQL*Loader could not initialize the read functions.
Action: Check the errors below this message in the log file for more information.
SQL*Loader-00512: Unable to free read buffer
Cause: An internal error has occurred.
Action: Contact customer support.
SQL*Loader-00513: Unable to close file (string)
Cause: SQL*Loader could not close the named file.
Action: Check the errors below this message in the log file for more information.
SQL*Loader-00514: Error getting elapsed time
Cause: SQL*Loader could not get the elapsed time from the system.
Action: No action required.
SQL*Loader-00515: Error getting CPU time
Cause: SQL*Loader could not get the CPU time from the system.
Action: No action required.
SQL*Loader-00516: Control file (string) has no contents
Cause: The named file was found to be empty.
Action: Check that the intended file was referenced and that it is not empty.
SQL*Loader-00517: Error decomposing file name (string)
Cause: SQL*Loader could not break down the filename into its component parts.
Action: Check the filename for illegal characters.
SQL*Loader-00518: Error reassembling file name (string)
Cause: SQL*Loader could not put the filename back together again from its components.
Action: Check the filename for illegal characters.
SQL*Loader-00520: lfimknam failed for file (string)
Cause: LFI failed to make a name object for the file.
Action: Contact Oracle Worldwide Support.
SQL*Loader-00521: lfilini failed for file (string)
Cause: LFI failed to create or initialize a file object for the file.
Action: Contact Oracle Worldwide Support.
SQL*Loader-00522: lfiopn failed for file (string)
Cause: LFI failed to open the file.
Action: Check for any possible operating system errors and/or potential memory problems.
SQL*Loader-00523: error number writing to file (string)
Cause: Could not write to specified file.
Action: Check the following: the file actually resides in the specified location you have write privileges on the file you have sufficient disk space you have not exceeded your disk quota If all of these conditions are satisfied, then retry the operation.
SQL*Loader-00524: partial record found at end of datafile (string)
Cause: An incomplete record was found at the end of the indicated datafile.
Action: Make sure the last record in the datafile is complete and has the correct terminating character(s). Also, if fixed-length records are in use, verify that no record exceeds the platform-specific length for a single record.
SQL*Loader-00525: OCI return status: success
Cause: The message describes the status code returned by an OCI call.
Action: See surrounding messages for more information.
SQL*Loader-00526: OCI return status: success with info
Cause: The message describes the status code returned by an OCI call.
Action: See surrounding messages for more information.
SQL*Loader-00527: OCI return status: no data
Cause: The message describes the status code returned by an OCI call.
Action: See surrounding messages for more information.
SQL*Loader-00528: OCI return status: error
Cause: The message describes the status code returned by an OCI call.
Action: See surrounding messages for more information.
SQL*Loader-00529: OCI return status: invalid handle
Cause: The message describes the status code returned by an OCI call.
Action: See surrounding messages for more information.
SQL*Loader-00530: OCI return status: need data
Cause: The message describes the status code returned by an OCI call.
Action: See surrounding messages for more information.
SQL*Loader-00531: OCI return status: still executing
Cause: The message describes the status code returned by an OCI call.
Action: See surrounding messages for more information.
SQL*Loader-00532: OCI return status: continue
Cause: The message describes the status code returned by an OCI call.
Action: See surrounding messages for more information.
SQL*Loader-00533: OCI return status: unknown, value is number
Cause: An unknown status was returned by an OCI call.
Action: See surrounding messages for more information.
SQL*Loader-00551: internal error: error initializing slf
Cause: An internal error occured while trying to initialize the file I/O component.
Action: Call customer support.
SQL*Loader-00552: insufficient privilege to open file
Cause: SQL*Loader does not have the previleges required to open the file.
Action: Verify that the correct file was specified and that the file has the appropriate permissions.
SQL*Loader-00553: file not found
Cause: The specified file cannot be found.
Action: verify that the correct name exists and whether the file is in the intended location.
SQL*Loader-00554: error opening file
Cause: An error occurred while trying to open the file. No further information is available.
Action: Verify that the file is accessible.
SQL*Loader-00555: unrecognized processing option
Cause: The processing option specified for the file cannot be processed.
Action: Verify that the processing options specified for the file contain legal syntax for the platform where SQL*Loader is running.
SQL*Loader-00556: unable to allocate read buffer
Cause: Attempt to allocate the read buffer failed.
Action: If possible, try specifying a smaller size for the read buffer.
SQL*Loader-00557: unable to allocate memory
Cause: An attempt to allocate some memory to track I/O for the file failed.
Action: Contact customer support.
SQL*Loader-00558: attempt to use SKIP parameter with linked-in loader
Cause: SKIP parameter was specified with a linked-in file processor.
Action: Do not use the SKIP parameter in this case.
SQL*Loader-00559: error closing file
Cause: An error occured while closing the file.
Action: Contact customer support.
SQL*Loader-00560: error reading file
Cause: An error occurred while reading the file.
Action: Make sure the file is still accessible.
SQL*Loader-00561: end of file
Cause: End of file reached.
Action: none
SQL*Loader-00562: record too big
Cause: A record in the file is larder than the read buffer.
Action: Verify that the file is not corrupt. If not, try specifying a larger size for the read buffer.
SQL*Loader-00563: bad length for VAR record
Cause: The length protion of a VAR record contains non-numeric data.
Action: Fix the data in the file.
SQL*Loader-00564: illegal hexadecimal literal specified for record delimiter
Cause: A hexadecimal literal that contains the record delimiter for the file does not contain a valid hexadecimal string.
Action: Verify that the correct hexadecimal value was specified in the processing options for the file.
SQL*Loader-00565: unexpected error during skip .
Cause: an unexpected error occured while attempting to skip records.
Action: This message should be followed by another message giving more specific information about the error
SQL*Loader-00566: partial record found at end of datafile
Cause: An incomplete record was found at the end of file.
Action: Make sure the last record in the datafile is complete and has the correct terminating character(s).
SQL*Loader-00600: Bind size of number bytes increased to number bytes to hold 1 row.
Cause: The space needed to contain a single row is longer than the specified bind size. The value used for the bind size will be increased to handle the larger size
Action: No action is required. This message will go away if the new value in the error message is specified for the bind size.
SQL*Loader-00601: For INSERT option, table must be empty. Error on table string
Cause: A non-empty table is being loaded with the INSERT option.
Action: Use the REPLACE keyword to empty the old table and store the new data in its place. Use the APPEND keyword to leave the table's contents intact and add the new data to it.
SQL*Loader-00602: Maximum converted length number of column string is too big for bind array
Cause: The named column cannot undergo the specified character set conversion and still be placed in a contiguous piece of memory on the system.
Action: Specify a shorter data column or eliminate the conversion.
SQL*Loader-00603: Maximum length number of column string is too big for bind array
Cause: The named column cannot be put in a contiguous piece of memory on the system.
Action: Specify a shorter data column.
SQL*Loader-00604: Error occurred on an attempt to commit
Cause: An error occurred while trying to commit changes to the database.
Action: Look at the message listed below this one in the log file for more information.
SQL*Loader-00605: Non-data dependent ORACLE error occurred -- load discontinued.
Cause: An error occurred that is independent of the data. For example, an out-of-space condition. Because all further rows will be rejected, the load is discontinued. (If the error were data dependent, then other rows might succeed.)
Action: See the errors below this one in the log file for more information.
SQL*Loader-00606: Object string in INTO TABLE clause is not a local table
Cause: The synonym specified in the INTO TABLE clause in the SQL*Loader control file specifies a remote object via a database link. Only a synonym for an existing local table can be specified in the INTO TABLE clause.
Action: Ensure that a local table name or a synonym for a local table is fully specified in the INTO TABLE clause. The table must already exist.
SQL*Loader-00607: partition not empty for INSERT option; table string, partition string
Cause: An attempt was made to use the INSERT option on a non-empty partition.
Action: Empty the partition, or use the REPLACE or TRUNCATE option.
SQL*Loader-00608: subpartition not empty for INSERT option; table string, subpartition string
Cause: An attempt was made to use the INSERT option on a non-empty subpartition.
Action: Empty the subpartition, or use the REPLACE or TRUNCATE option.
SQL*Loader-00609: value used for ROWS parameter changed from number to number
Cause: SQL Loader adjusted the value it was using for the ROWS parameter to the new value reported. This is an informational message and not an error. SQL Loader will adjust the value of the ROWS parameter if the amount of memory specified by BINDSIZE is not large enough to hold data for the number of rows specified. SQL Loader will also change the value of the ROWS parameter for conventional path loads if the value is larger than 65534. Conventional path load can load at most 65534 rows at a time.
Action: If the limit of 65534 rows for conventional path load is not being reached, then try increasing the value of BINDSIZE.
SQL*Loader-00620: Initial enclosure character not found
Cause: A mandatory initial enclosure delimiter was not present. Either it is missing on the current field or the previous field is missing an identical closing delimiter.
Action: Supply the missing delimiters.
SQL*Loader-00621: Field in data file exceeds maximum length
Cause: A field exceeded its maximum allowable length. The maximum length is either the length specified in the SQL*Loader control file, or, for delimitable fields without a length specified, the default maximum length (255 bytes).
Action: Check for missing delimiters and/or shorten the field.
SQL*Loader-00622: Column not found before end of logical record (use TRAILING NULLCOLS)
Cause: The logical record ended before all specified fields were found.
Action: If the missing fields should be loaded as null, use the TRAILING NULLCOLS clause. Otherwise, correct the data.
SQL*Loader-00623: second enclosure string not present
Cause: The logical end of record or the end of a LOBFILE was reached before a second enclosure delimiter was found.
Action: Correct the data file to include the missing delimiter.
SQL*Loader-00624: no terminator found after TERMINATED and ENCLOSED field
Cause: No termination delimiter was found after the enclosed field ended.
Action: Supply the missing termination delimiter.
SQL*Loader-00625: Multibyte character error in control file.
Cause: Incomplete multi-byte character strings were found in the SQL*Loader control file.
Action: Edit the SQL*Loader control file to check that all multi-byte character data is valid.
SQL*Loader-00626: Character set conversion buffer overflow.
Cause: A conversion from the datafile character set to the client character set required more space than that allocated for the conversion buffer. The size of the conversion buffer is limited by the maximum size of a varchar2 column.
Action: The input record is rejected. The data will not fit into the column.
SQL*Loader-00627: Character set conversion graph not available.
Cause: A conversion from the datafile character set to the client character failed due to the conversion graph not being available.
Action: Contact Oracle support. Check NLSRTL installation.
SQL*Loader-00628: Character set conversion error.
Cause: A character set conversion error occurred.
Action: Contact Oracle support. Check NLSRTL installation. Provide a reproduceable test case.
SQL*Loader-00640: Variable length field was truncated.
Cause: The end of the logical record was encountered before the end of a variable length field. The length of each variable-length field is embedded in the field, so SQL*Loader knows that more data should have been present.
Action: Check the data for inadvertent truncation and verify the SQL*Loader control file specifications against the log file; the field may be starting in the wrong place.
SQL*Loader-00641: Invalid packed decimal nibble.
Cause: Each byte in a packed decimal field contains two 4-bit nibbles. Each nibble must have a valid value.
Action: Check the SQL*Loader control file's specifications against the log file to ensure that the field location was specified correctly. Check the contents of the field.
SQL*Loader-00642: Relative start position > absolute field end position.
Cause: A field specified as POSITION(*+n:y) had its relative start occur after the absolute position y.
Action: Check that a delimiter is not missing and that the values of n and y are correct.
SQL*Loader-00643: error executing INSERT statement for table string
Cause: A fatal error occured while attempting to insert data into the table.
Action: Refer to the messages that follow for more information. If you specified SQL stings for any of your columns, verify that strings are correct. Specifcally, check for balanced parenthesis and correct use of quotation marks. Another format error
SQL*Loader-00644: end of logical record found when reading length of varying length field
Cause: While attempting to read the length portion of a varying length field, then end of the logical record was reached.
Action: Verify that the SQL*Loader control file describes the data correctly and that the data in the data file matches the description in the SQL*Loader control file
SQL*Loader-00645: error converting character length field to a number
Cause: An error occurred while attempting to convert the characters containing the count portion of a VARCHARC or VARRAWC field.
Action: Verify that the count portion for the column has the correct value.
SQL*Loader-00646: lob set to EMPTY in column string, row number, table string
Cause: Encountered errors (e.g. parsing errors in LOBFILE) while loading LOBs. The row will remain in the table and its LOB column will be initialized to empty. Loading of other records will continue.
Action: Correct the data file (see accompanying messages) and reload.
SQL*Loader-00647: Integer to number conversion error
Cause: An error occurred while attempting to convert an integer to an Oracle number format.
Action: Verify that the integer field in the data file is a valid integer. If the INTEGER(N) syntax was used, then verify that the length specified is valid.
SQL*Loader-00649: Quoted string missing closing quote
Cause: A quoted string in the control file is missing a closing quote.
Action: Insert the closing quote as appropriate.
SQL*Loader-00650: incomplete lob data written for column string, row number, table string
Cause: Encountered errors (e.g. parsing errors in LOBFILE) while loading LOBs using direct path. The row will remain in the table and its LOB column may not be complete. Loading of other records will continue.
Action: Correct the data file (see accompanying messages) and reload.
SQL*Loader-00651: error skipping lob for column string, row number, table string
Cause: Encountered errors (e.g. parsing errors in LOBFILE) while skipping LOBs.
Action: Correct the data file (see accompanying messages) and reload.
SQL*Loader-00652: Invalid zoned decimal byte.
Cause: Each byte of a zoned decimal field must have a valid value based on the character set encoding used. ASCII-based zoned decimals must follow the formats specified in the VAX Architecture Reference Manual. EBCDIC-based zoned decimals must follow the formats specified in the ESA/390 Principles of Operations, version 8.1.
Action: Check the SQL*Loader control file's specifications against the log file to ensure that the field location was specified correctly. Check the contents of the field.
SQL*Loader-00653: XML data set to NULL in column string, row number, table string
Cause: Encountered errors (e.g. parsing errors in LOBFILE) while loading LOBs into an XML column. The row will remain in the table and its XML column will be initialized to null. Loading of other records will continue.
Action: Correct the data file (see accompanying messages) and reload.
SQL*Loader-00654: Variable length field exceeds maximum length.
Cause: A variable length field (with a leading length subfield) exceeded its maximum allowable length. The maximum length is either the length specified in the SQL*Loader control file, or, the default if not specified (4kb).
Action: Shorten the field and its length.
SQL*Loader-00655: cannot load object-relational XML attribute using direct path
Cause: The table being loaded contains a column object which contains an XML attribute with a storage type of object-relational. This type of attribute cannot be loaded with direct path.
Action: Perform the load with conventional path mode.
SQL*Loader-00700: Out of memory while performing essential allocations [number]
Cause: SQL*Loader could not allocate the memory it needs.
Action: Check the operating system and process memory. Increase memory available to SQL*Loader, if possible. If using direct path, try lowering the columnarrayrows option (see log file for current default value).
SQL*Loader-00702: Internal error - string
Cause: An internal error has occurred.
Action: Make a note of the message and contact customer support.
SQL*Loader-00703: Internal error: argument number
Cause: An internal error has occurred.
Action: Make a note of the message and the number, then contact customer support.
SQL*Loader-00704: Internal error: string [number]
Cause: An internal error has occurred.
Action: Make a note of the message and the number, then contact customer support.
SQL*Loader-00705: Internal error
Cause: An internal error has occurred.
Action: Contact customer support.
SQL*Loader-00706: Bad argument to ulerr [number].
Cause: An internal error has occurred.
Action: Contact customer support.
SQL*Loader-00708: Internal error: unknown status number returned from sllf layer
Cause: An unknown status was returned by a call to the sllf layer.
Action: Contact customer support.
SQL*Loader-00709: Internal error calling SLTS layer: string failed
Cause: A nonsuccess status was returned by a call to the SLTS layer.
Action: Contact customer support.
SQL*Loader-00710: Internal error: direct path stream buffer not loaded
Cause: A direct path stream buffer was built but not loaded.
Action: Contact customer support.
SQL*Loader-00711: Internal error: bad address for little endian UTF16 conversion
Cause: Address for little endian UTF16 data not in a valid buffer.
Action: Contact customer support.
SQL*Loader-00712: Internal error: bad address for big endian UTF16 conversion
Cause: Address for big endian UTF16 data not in a valid buffer.
Action: Contact customer support.
SQL*Loader-00800: %s specified and ignored
Cause: An option was specified that is not supported by External Table load.
Action: Do not specify the unsupported option or do not use External Table load.
SQL*Loader-00801: all INTO TABLE clauses must have the same options (string)
Cause: At least two INTO TABLE clauses have different options set.
Action: Set the options to be the same or do the loads separately.
SQL*Loader-00802: numeric EXTERNAL with DEFAULTIF clause not supported by External Table
Cause: A numeric EXTERNAL type was specified with a DEFAULTIF clause and that is not supported by External Table Load.
Action: Remove the clause if possible or do not use External Table Load.
SQL*Loader-00803: %s field type not supported by External Table
Cause: The specified field type is not supported by External Table Load.
Action: Remove the specified field type or do not use External Table Load.
SQL*Loader-00804: SEQUENCES with intervals are not supported by External Table Load.
Cause: A sequence with an interval is specified and is not supported by External Table Load.
Action: Remove the interval from the sequence, or the the sequence itself, or do not use External Table Load.
SQL*Loader-00805: %s not supported by External Table
Cause: The specified option is not supported by External Table Load.
Action: Remove the specified option or do not use External Table Load.
SQL*Loader-00806: unknown record format specified for data file
Cause: The osd string containing file processing options in the control file specified an unknown file processing option.
Action: Verify the correct options are specified for the platform being used.
SQL*Loader-00807: error loading table
Cause: An INSERT statement used to load a table from an external table or a temporary internal table failed. The statement that failed is shown immediately preceding this mesage.
Action: See subsequent messages for more information about the error.
SQL*Loader-00808: error creating sequence: string
Cause: An attempt to create a sequence needed for the load failed.
Action: See messages that follow this one for information about the failure.
SQL*Loader-00809: error dropping sequence: string
Cause: A sequence needed to be dropped either because SQL Loader found a sequence with the same name it is trying to create or because SQL Loader is cleaning up from sequences it created at the beginning of the load.
Action: See messages that follow this one for information about why the attampt to drop the sequence failed.
SQL*Loader-00810: error creating external table: string
Cause: An attempt to create the external table sued for the load failed.
Action: See messages that follow for more information about the failure.
SQL*Loader-00811: error dropping external table: string
Cause: An error occurred when trying to drop an external table. Note that the table may have been left from a previous load.
Action: none
SQL*Loader-00812: error creating internal table: string
Cause: An error was encountered trying to create a temporary internal table. The internal table is used only when loading multiple tables from the same data file. The internal table is loaded once and the target tables are loaded from the internal table.
Action: none
SQL*Loader-00813: error dropping internal table: string
Cause: An error was encountered trying to drop a temporary internal table. The internal table is used only when loading multiple tables from the same data file. The internal table is loaded once and the target tables are loaded from the internal table. The internal table may have been left from a previous build.
Action: none
SQL*Loader-00816: error creating temporary directory object string for file string
Cause: No existing directory object was found in the database for the directory containing the file. Since all files loaded by external tables must be in a directory named by a directory object, SQL Loader tried to create a directory object for the file.
Action: See error messages that follow this message for more information.
SQL*Loader-00817: error dropping directory object string
Cause: SQL Loader created a directory object as part of an external table load. An attempt to cleanup the directory object failed.
Action: See messages following this one for more information about the error.
SQL*Loader-00820: cannot create where clause with range for table string
Cause: The EXTERNAL_TABLE parameter was specified for a multi-table load, and a WHEN clause for one of the tables contains a reference to a range of bytes in the record. SQL Loader uses the WHEN clause from the control file to generate the WHERE clause in the INSERT statement. If the WHERE clause contains a reference to a range of bytes in the table, then a valid WHERE clause can not be generated. Note that SQL Loader will proceed as if GENERATE_ONLY was specified for the EXTERNAL_TABLE parameter.
Action: Modify the control file to only use field references in the WHEN clause. Note that this may require creating a filler field. Another alternative is to create one control file for each table to be loaded and load the table separately.
SQL*Loader-00821: switching to GENERATE_ONLY
Cause: SQL Loader is not able to execute the SQL statements it generated for loading the data using external tables. See previous messages for more information.
Action: none
SQL*Loader-00822: operation not supported on external organized table
Cause: User attempted on operation on an external table which is not supported.
Action: Don't do that!
SQL*Loader-00823: TREAT AS clause for object tables not supported for external tables
Cause: A TREAT AS clause was specified in the INTO TABLE clause for an object table in the SQL*Loader control file and the EXTERNAL_TABLES command line parameter was set to either EXECUTE or GENERATE_ONLY. External tables can be used to load the data, but SQL*Loader does not generate the correct SQL statements to do this.
Action: Use SQL*Loader direct path or SQL*Loader conventional path to load the table.
SQL*Loader-00901: Error logging on to ORACLE:
Cause: An attempt was made to log on to Oracle in direct path load mode.
Action: Ensure that the instance is up and running. Check the Oracle messages below this one in the log file for more information.
SQL*Loader-00902: Error opening cursor: [number]
Cause: An internal error has occurred.
Action: Check the Oracle messages below this one in the log file and contact customer support.
SQL*Loader-00903: Database must be at least version number.number.number.number.number for direct path
Cause: The direct path load mode is being used with an incompatible database.
Action: Upgrade the database to the specified version or else use the conventional path load.
SQL*Loader-00904: You cannot used the direct path when linked with v5 of the database
Cause: The direct path mode is being used after SQL*Loader has been linked with a Version 5 database.
Action: Use the conventional path.
SQL*Loader-00905: Error parsing SQL statement for upi: [number]
Cause: Header message.
Action: Check the message below this one in the log file for more information.
SQL*Loader-00906: Error executing SQL statement for upi: [number]
Cause: An internal error has occurred.
Action: Check the message below this one in the log file for more information.
SQL*Loader-00909: Loader views must be loaded (as SYS) for direct path to be used
Cause: Database views required for the direct path mode are not present.
Action: The Oracle7 Server Administrator's Guide details how to run the required scripts as user SYS for loading the required views.
SQL*Loader-00910: Error binding input variables for upi: [number]
Cause: Header message.
Action: Check the message below this one in the log file for more information.
SQL*Loader-00911: Error defining output variable(s) for upi: [number]
Cause: Header message.
Action: Check the message below this one in the log file for more information.
SQL*Loader-00913: Error fetching results of select statement (upi): [number]
Cause: Header message.
Action: Check the message below this one in the log file for more information.
SQL*Loader-00914: Error locking table string in exclusive mode.
Cause: The direct path mode could not lock the named table.
Action: Check the message below this one in the log file for more information. Check that the necessary privileges have been granted.
SQL*Loader-00915: Error closing cursor: [number]
Cause: Header message.
Action: CCheck the message below this one in the log file for more information.
SQL*Loader-00916: Error checking path homogeneity
Cause: To do a direct path load load when the front end and back end of the database are on separate hardware systems, the systems must be identical, using the same machine, operating system, and character set. This error occurs when SQL*Loader detects a difference between the systems that will prevent a direct load from operating properly.
Action: Use a conventional path load for this configuration.
SQL*Loader-00918: The catalog must be loaded (as SYS) for SQL*Loader to be used
Cause: The catalog is not loaded.
Action: Logon as user SYS and load the Oracle7 catalog and the views in the script ULVIEW.SQL.
SQL*Loader-00919: Error during upi fetch: [number]
Cause: An internal error has occurred.
Action: Check the message below this one in the log file for more information.
SQL*Loader-00925: Error while string
Cause: An internal error has occurred.
Action: Check the message below this one in the log file for more information. The table or column referenced may not be accessible.
SQL*Loader-00926: OCI error while string for table string
Cause: An OCI error has occurred.
Action: Check the message below this one in the log file for more information. The table or column referenced may not be accessible.
SQL*Loader-00929: Error parsing insert statement for table string.
Cause: The table's insert statement caused a parse error.
Action: Check all SQL strings that were used.
SQL*Loader-00930: Error parsing insert statement for table string column string.
Cause: The named column's INSERT statement caused a parse error.
Action: Check the message below this one in the log file for more information. Check the SQL string used for this column.
SQL*Loader-00931: OCI error while binding variable for column string in table string
Cause: An OCI error has occurred.
Action: Check the errors below it for more information. The SQL string for this column may be in error.
SQL*Loader-00932: Could not truncate table string.
Cause: Truncation of the table was attempted and failed.
Action: Check the following errors for more information. Truncation due to referential constraints should not occur.
SQL*Loader-00933: Specified file string not part of database
Cause: The specified filename to load the table is not a database file.
Action: Specify a valid datafile.
SQL*Loader-00934: Incorrect data file string specified for table string
Cause: A datafile name was given to load the table that is not a part of the tablespace in which the table resides.
Action: Specify a valid datafile.
SQL*Loader-00935: Error verifying required option for parallel load.
Cause: An error was encountered because a required option was not found or was invalid.
Action: Correct the problem as described in the accompanying Oracle message.
SQL*Loader-00937: parallel load requested and string has enabled triggers or constraints
Cause: A request was made for a parallel direct load, but the object to be loaded has an enabled constraint (check, referential) and/or enabled triggers.
Action: Disable the offending enabled constraints and/or triggers and retry the parallel direct load.
SQL*Loader-00938: partition load requested and string has enabled triggers or constraints
Cause: A request was made for a direct load of a single partition, but the object to be loaded has an enabled constraint (check, referential) and/or enabled triggers.
Action: Disable the offending enabled constraints and/or triggers and retry the parallel direct load.
SQL*Loader-00939: OCI error while string for table string partition string
Cause: Header message.
Action: Check the following errors for more information. The table or partition referenced may not be accessible.
SQL*Loader-00940: UPI error while setting NCHAR bind attributes for column string table string
Cause: An error occured while setting the charsetform attribute of an NCHAR column.
Action: This is an internal error. Report to ORACLE support.
SQL*Loader-00941: Error during describe of table string
Cause: Error while executing a describe of a select list on the given table. Check the error immediately preceding this error.
Action: none
SQL*Loader-00942: partition string not part of table string
Cause: the specified partition is not part of the specified table
Action: none
SQL*Loader-00943: incorrect datafile string specified for table string partition string
Cause: The specified datafile is not in the tablespace of the specified partition. Due to use of FILE= keyword on a partitioned table. When loading all partitions of a partitioned table, the partitions must be in the same tablespace. When loading a single partition, the tablespace of the partition being loaded must be the same as the tablespace in which the specified datafile file resides.
Action: none
SQL*Loader-00944: error preparing insert statement for table string.
Cause: A call to OCIStmtPrepare for the table's insert statement returned an error.
Action: Refer to the message that follows for information about the error returned by OCIStmtPrepare. Make sure the syntax is correct for all SQL strings specified in the SQL*Loader control file.
SQL*Loader-00945: record size number too large for direct path
Cause: The maximum size of records in the data file is larger than the maximum size supported by direct path, which is 65535
Action: Load the data file using conventional path.
SQL*Loader-00946: OCI error while string for table string subpartition string
Cause: Header message.
Action: Check the following errors for more information. The table or subpartition referenced may not be accessible.
SQL*Loader-00947: subpartition load requested and string has enabled triggers or constraints
Cause: A request was made for a direct load of a single subpartition, but the object to be loaded has an enabled constraint (check, referential) and/or enabled triggers.
Action: Disable the offending enabled constraints and/or triggers and retry the parallel direct load.
SQL*Loader-00948: subpartition string not part of table string
Cause: the specified subpartition is not part of the specified table
Action: none
SQL*Loader-00949: incorrect datafile string specified for table string subpartition string
Cause: The specified datafile is not in the tablespace of the specified subpartition. Due to use of FILE= keyword on a subpartitioned table. When loading all subpartitions of a subpartitioned table, the subpartitions must be in the same tablespace. When loading a single subpartition, the tablespace of the subpartition being loaded must be the same as the tablespace in which the specified datafile file resides.
Action: none
SQL*Loader-00950: Error shipping data structures across 2-task
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00951: Error calling once/load initialization
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00952: Error calling once/data file initialization
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00953: Error shipping read buffer across 2-task
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00954: Error shipping index to read buffer across 2-task
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00955: Error calling col array build, block formatter
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00956: Error calling once/data file finishing
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00957: Error shipping text string across 2-task
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00958: Error popping data relocation address stack
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00959: Error shipping buffer across 2-task
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00961: Error calling once/load finishing for table string
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00962: Error setting user-side Ctrl-C handler
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00963: Error clearing user-side Ctrl-C handler
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00965: Error number disabling constraint string on table string
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00966: Error number disabling all triggers on table string
Cause: Header message.
Action: Check the error(s) below it for more information.
SQL*Loader-00969: Error performing file name translation on kernel side
Cause: File specified for parallel load is probably not a valid database file.
Action: Specify a valid database file.
SQL*Loader-02026: the load was aborted because SQL Loader cannot continue.
Cause: The load cannot continue. See the error message before this

* message for the cause of the error.

Action: See the action for the error message that precedes this one.
SQL*Loader-02050: Multibyte character error.
Cause: Text specified by POSITION or terminated by newlines is invalid.
Action: Edit the SQL*Loader control file or the data file to fix alignment of column.
SQL*Loader-03120: Resumable parameters ignored -- current session not resumable
Cause: Current session is not resumable.
Action: Must specify RESUMABLE=TRUE to enable resumable session in order for the RESUMABLE_NAME and RESUMABLE_TIMEOUT parameters to take effect.
SQL*Loader-03121: Maximum record length of [number] exceeded for bad or discard file
Cause: There is a limit on the maximum size of the record which can be written to the bad or discard file. SQL*Loader encountered a record that exceeded this limit.
Action: See the next message which follows this message to know which record exceeded the limit. Modify that record, if necessary, and try to load again.


24 KUP-00550 to KUP-11012

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

24 KUP-00550 to KUP-11012

KUP-00550: parser package failed to load
Cause: Attempt to load parser package returned an error indication.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
KUP-00552: internal XAD package failed to load
Cause: An error was encountered while attempting to initialize the XAD package.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
KUP-00554: error encountered while parsing access parameters
Cause: The parser detected a syntax error.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
KUP-00561: invalid length for binary integer field string
Cause: An integer field was specified with an invalid length. The only supported lengths for binary integer fields are 1, 2, 4, and 8.
Action: none
KUP-00562: unknown escape sequence
Cause: An unknown escape sequence was specified to the parser. An escape sequence is a backslash followed by a character.
Action: Consult documentation for list of allowable control characters.
KUP-00600: internal error, arguments [string] [string] [string] [string] [string]
Cause: An internal XAD error occurred.
Action: Contact Oracle Support.
KUP-00601: fatal XAD error
Cause: A fatal error has occurred.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
KUP-01006: error signalled during parse of access parameters
Cause: An error was signalled during parsing of the access parameters.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
KUP-01007: at line number column number
Cause: This is an informational message indicating the line and column where a syntax error was detected.
Action: none
KUP-01008: the bad identifier was: string
Cause: This is an informational message indicating the identifier token that caused a syntax error.
Action: none
KUP-02000: wrong message file version (msg number not found)
Cause: The kupxx.msb file is not the correct version.
Action: Check that the installation was done correctly.
KUP-02001: unrecognized punctuation symbol "string"
Cause: An illegal punctuation character was encountered.
Action: Remove the illegal character.
KUP-02002: unexpected end of input file reached
Cause: This is probably caused by failure to supply the closing quote for a quoted string.
Action: Correct the input.
KUP-02003: unrecognized character: string
Cause: An input character that is neither an alpha, digit, or punctuation was encountered.
Action: Remove the character.
KUP-02004: quoted string too big
Cause: A quoted string longer than 2000 bytes was encountered.
Action: This may be caused by a missing close quote. If so, add the missing quote, otherwise shorten the string.
KUP-02005: token too big
Cause: A token longer than 1000 bytes was encountered
Action: Tokens must be separated by whitespace or punctuation. Either add the missing whitespace or punctuation, or shorten the token.
KUP-02006: script line too long
Cause: a line longer than 500 bytes was encountered
Action: break the line up into shorter lines
KUP-03001: fatal error during library cache pre-loading
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
KUP-03002: end position (number) <= start position (number) for field: string
Cause: Error in specifying position for the specified field in the access parameters."
Action: Check that the specified end position is greater than the specified start position.
KUP-03003: absolute end(number) - start(number) != fieldlength (number) for field string
Cause: The number of bytes occupied by the field as specified by the starting offset and ending offset of the field is not the same as the number of bytes specified for the datatype of the field.
Action: Verify the absolute begin/end position(s) specified match the length of the field.
KUP-03004: absolute end (number) specified with relative start (number) for field string
Cause: The position of field was specified with a relative start and an absolute end.
Action: Use relative end with relative start
KUP-03005: relative end (number) specified does not match fieldlen(number) for field string
Cause: The number of bytes specified by the relative end position for the field does not match the number of bytes in the datatype.
Action: Correct either the datatype length or the relative end position.
KUP-03006: error initializing handle for character set string
Cause: Error attempting to retrieve information for the character set.
Action: Verify that the character set name is valid.
KUP-03007: end position (number) is less than start position (number) for range
Cause: A byte range specified a start position that comes after the end position.
Action: Verify the start and end positions are correctly specified.
KUP-03008: OCI error getting column parameters.
Cause: An error occurred while trying to obtain column parameters.
Action: Contact Oracle Support.
KUP-03009: OCI error getting column name.
Cause: An error occurred while trying to obtain column name.
Action: Contact Oracle Support.
KUP-03010: OCI error getting database column type.
Cause: An error occurred while trying to obtain database column type.
Action: Contact Oracle Support.
KUP-03011: OCI error getting database column size.
Cause: An error occurred while trying to obtain database column size.
Action: Contact Oracle Support.
KUP-03012: OCI error getting database column precision.
Cause: An error occurred while trying to obtain database column precision.
Action: Contact Oracle Support.
KUP-03013: OCI error getting database column scale.
Cause: An error occurred while trying to obtain database column scale.
Action: Contact Oracle Support.
KUP-03014: OCI error getting datetime fsprecision.
Cause: An error occurred while trying to obtain a datetime column precision value."
Action: Contact Oracle Support.
KUP-03015: OCI error getting datetime lfprecision.
Cause: An error occurred while trying to obtain database column precision.
Action: Contact Oracle Support.
KUP-03016: length specified for FIXED records must be greater than 0
Cause: A record format of FIXED was specified with a length of 0.
Action: none
KUP-03017: length specified for VARIABLE records must be greater than 0
Cause: A record format of VARIABLE was specified with a length of 0.
Action: none
KUP-03018: invalid date mask "string" specified for column string
Cause: The date mask for the specified column is invalid.
Action: none
KUP-03019: directory object not specified in LOBFILE clause for field string
Cause: A LOBFILE clause was specified for the field, but no directory object was specified. When no directory object is specified, then the default directory specified for the external table is used, but no default directory was specified.
Action: Specify a directory object in the LOBFILE clause or specify a default directory for the external table.
KUP-03020: empty delimiter specified for record
Cause: An empty delimiter string was specified for a record delimiter.
Action: Specify the string used to delimiter records.
KUP-03021: clause references unknown field string
Cause: A WHEN, NULLIF or DEFAULTIF clause referenced a field that doesn't exist in the data file.
Action: none
KUP-03022: lob data could not be found for field string
Cause: The field specified in the data source that contains the name of the lob file for the record could not be identified.
Action: none
KUP-03999: error occurred while processing a date format: ORA-number: string
Cause: Error converting a date format string into an internal representation.
Action: Verify that the date format strings specified in the access parameters are valid.
KUP-04000: error initializing IO state for file string in string
Cause: An unexpected error occurred while preparing the file.
Action: Contact Oracle support.
KUP-04001: error opening file string
Cause: An error occurred while attempting to open the specified file. This message should be followed by another message with more information about the error.
Action: See the error that follows to determine the action to be taken.
KUP-04002: error getting file size for file string
Cause: An error occurred while retrieving the number of bytes in the specified file.
Action: See the error that follows to determine the action to be taken.
KUP-04003: error while closing file string
Cause: An error occurred while closing the specified file.
Action: See the error that follows to determine the action to be taken.
KUP-04004: error while reading file string
Cause: An error occurred while reading the specified file.
Action: See the error that follows to determine the action to be taken.
KUP-04005: file operation successful
Cause: A file oepration succeeded.
Action: None
KUP-04006: file operation failed
Cause: An operation on a file failed. The file is named in the message preceeding this one.
Action: See subsequent message for more information about the error.
KUP-04007: end of file reached
Cause: The end of file was reached for a file. The file is named in the message preceding this one.
Action: See the message that follows this one for more information.
KUP-04008: access to file denied
Cause: Acess to a file was denied. The file is named in the message preceding this one.
Action: See the message that follows for more information. Verify that the correct files are being used and that the appropriate access is allowed to those files.
KUP-04009: invalid SLF handle
Cause: An internal error caused a data structure associated with the file to become corrupt.
Action: Contact Oracle support.
KUP-04010: file does not exist
Cause: A file operation failed because a file does not exist. The message preceding this message contains the name of the file.
Action: Verify that the correct file name was specified.
KUP-04011: file system is full
Cause: An operation on a file failed because the file system is full. The message preceding this one contains the name of the file.
Action: Free space on the file system or move the file to a different file system.
KUP-04012: file length is too large for output field
Cause: Size of a file is too large.
Action: Break the file up into smaller files.
KUP-04013: other system error
Cause: Internal component SLF was unable to complete an operation because of a system error.
Action: The message displayed before this message describes the operation that was being performed when the error occurred.
KUP-04014: invalid SLF parameter
Cause: An invalid parameter was passed in a call to internal component SLF.
Action: Contact Oracle support.
KUP-04015: internal SLF error
Cause: Internal component SLF encountered an internal error.
Action: Contact Oracle support.
KUP-04016: unknown SLF status code number
Cause: Internal component SLF returned an unknown error code.
Action: Contact Oracle support.
KUP-04017: OS message: string
Cause: An error occurred. This message contains the message associated with this error that was returned by the operating system. The message displayed before this one should indicate the operation that failed.
Action: none
KUP-04018: partial record at end of file string
Cause: An incomplete record was found at the end of the file.
Action: Verify the file is not corrupt or missing data.
KUP-04019: illegal length found for VAR record in file string
Cause: A record in a VAR file has an length field with either no numeric characters in it or with non numeric characters in it.
Action: Verify the records in the file have the correct length specified for them.
KUP-04020: found record longer than buffer size supported, number, in string
Cause: a record in the data source was longer than the maximum data size supported. The number reported is the maximum supported size of a record.
Action: none
KUP-04021: field formatting error for field string
Cause: There was an error trying to find the contents of the specified field in a record.
Action: This message should be followed by another message containing more specific information about the cause of the error.
KUP-04022: field start is before start of record
Cause: The position of the start of a field is before the start of a record. This can occur if a negative number is used to indicate the relative start of a field.
Action: Verify that the definition of the layout of fields in the data file is correct.
KUP-04023: field start is after end of record
Cause: This can happen when specifying either absolute or relative positioning for a field.
Action: Verify that the definition of the layout of fields in the data file is correct. If it is valid for fields at the end of the record to be missing, use the MISSING FIELD VALUES ARE NULL clause in the access parameters.
KUP-04024: field end is before field start
Cause: The end of the field comes after the start of the field. This can happen if the field is defined with a relative start position and an absolute end position.
Action: Verify that the definition of the layout of fields in the data file is correct.
KUP-04025: field extends beyond end of record
Cause: This can happen when specifying either absolute or relative positioning for a field.
Action: Verify that the definition of the layout of fields in the data file is correct.
KUP-04026: field too long for datatype
Cause: The character field in the record is larger than the maximum length specified.
Action: Make sure the definition of the layout of the fields in the data file is correct. Also make sure the correct maximum size was specified for a character datatype.
KUP-04028: conversion of character length to a number failed
Cause: The character length portion of the field could not be converted to a number. This message is followed by another message with information on why the conversion failed.
Action: Make sure the data is correct. Also verify the datatypes specified for the fields are correct.
KUP-04029: numeric field overflowed
Cause: An attempt to convert a character string to number failed because the value of the number in the string was too large.
Action: none
KUP-04030: invalid numeric data
Cause: An attempt to convert a character string to a number failed because non-numeric characters were found.
Action: none
KUP-04032: internal error string while parsing field string:
Cause: An internal error occurred while parsing a field.
Action: Contact Oracle support.
KUP-04035: beginning enclosing delimiter not found
Cause: The beginning enclosure was not found for a field that is enclosed by delimiters.
Action: Verify that the data is correct. Also verify that the correct enclosing delimiters were specified and whether the enclosing delimiter should be optional.
KUP-04037: terminator not found
Cause: The terminator for the field is missing.
Action: Verify that the records are formatted correctly.
KUP-04038: internal error: string
Cause: an unexpected error condition was detected.
Action: contact Oracle customer support
KUP-04039: unexpected error while trying to find file string in string
Cause: An error occurred while trying to find path containing the file.
Action: This message should be followed by another message with more information about the error.
KUP-04040: file string in string not found
Cause: The file was not found in the directory specified
Action: Verify the correct file and directory names were specified.
KUP-04041: error generating full file name for string in string
Cause: Unexpected error occurred while trying to form a file name.
Action: none
KUP-04043: table column not found in external source: string
Cause: A column in the external table was not found in the access parameters that define the contents of the data source
Action: Verify that the external table is defined correctly and that the abstract parameters are also correct.
KUP-04044: error positioning file string
Cause: An attempt to position a file to an absolute file offset failed.
Action: See messages that follow for more information.
KUP-04045: unexpected OCI status string
Cause: An OCI call returned a status that cannot be handled.
Action: Contact Oracle support.
KUP-04047: error parsing record from external data source
Cause: An error occurred while trying to extract a record from the data source.
Action: Look in the log file for more messages about the error.
KUP-04048: internal error parsing record from external data source
Cause: An unexpected or unhandled error occurred while getting a record from the data source
Action: Contact Oracle support.
KUP-04049: record number discarded from file string
Cause: Informational message displayed whenever the WHEN clause has been satisfied. If a DISCARD file has been specified for the operation, the record will be written to that file.
Action: None.
KUP-04050: error while attempting to allocate number bytes of memory
Cause: d by insufficient memory.
Action: Reconnect to the instance and retry the operation.
KUP-04051: error processing column string in row number for datafile string
Cause: an error occurred while trying to convert the data from the data file into the type of a column in the external table.
Action: See messages that follow for more details.
KUP-04052: error processing column string in a row for datafile string
Cause: an error occurred while trying to convert the data from the data file into the type of a column in the external table.
Action: See messages that follow for more details.
KUP-04053: record number number
Cause: This message identifies a record number in a file for a record that had an error. The message preceding this one contains information about the error and the name of the file.
Action: none
KUP-04054: internal error: invalid bad row number identified for bad column number
Cause: This is an internal error.
Action: Contact Oracle support.
KUP-04055: column string is both a field in the data file and a column transform
Cause: The specified column was in the list of fields in the data file and in the list of column transforms. The column should be in one list or the other, but not both.
Action: Determine whether the value for the field in the data file or the value for the field in the column transform should be loaded in to the table. If the value for the data file is to be loaded, then remove the column transform. If the value for the column transform is to be loaded, then rename the field in the data file so that it does not match the name of a field in the table.
KUP-04056: internal error: OCI error while fetching record: number
Cause: An OCI error occurred while processing the granule.
Action: Contact Oracle support.
KUP-04057: internal error: OCI error while fetching record.
Cause: An OCI error occurred while processing the granule.
Action: Contact Oracle support.
KUP-04058: unrecoverable error occurred, operation aborted.
Cause: An unrecoverable error occurred during processing.
Action: See preceding error messages for more information.
KUP-04059: found EOF in length portion of VARIABLE record in file string
Cause: The record parser was looking for the size portion of a file a record format of VARIABLE. It found EOF before finding all the bytes for the length.
Action: Correct the corruption in the file.
KUP-04060: field string referenced by lobfile column string not found
Cause: The LOBFILE transform for the named column referenced a field for either the directory object portion or the name portion of the LOBFILE. However, that field did not exist anywhere in the definition of the data file.
Action: Verify that the LOBFILE clause is specified correctly. Also verify that the field definitions for the data file are correct.
KUP-04061: directory object string specified for LOBFILE column string is not valid
Cause: The column being loaded from a LOBFILE specified the directory object containing the LOBFILE through another field in the data file. In this case, the LOBFILE clause in the access parameters must specify a list of all directory objects that will be used for this field. This error occurs because a field contains the name of a directory object that is not in this list.
Action: Verify that the data file contains the correct directory object and verify that the list of valid directory objects in the LOBFILE clause for this column is complete.
KUP-04062: no data source specified
Cause: No location for the data source of the external table was specified when the external table was created. An empty string is not valid.
Action: Specify the name of the data source in the LOCATION clause when creating an external table.
KUP-04063: unable to open log file string OS error string
Cause: An attempt to open the log file failed.
Action: Specify a different log file or use NO LOGFILE to disable logging.
KUP-04064: fatal error during initialization
Cause: An unexpected error occurred while initializing access to an external table.
Action: Contact Oracle support.
KUP-04065: error processing LOBFILE for field string
Cause: An error occured while opening or reading a LOBFILE for a column in a row.
Action: See message in log file for more information about the error.
KUP-04066: error initializing access to external table source
Cause: An error occurred while attempting to retrieve information about a data source.
Action: See messages preceding this one for more information about the error.
KUP-04067: internal error allocating handle type string
Cause: An attempt to create an internal object failed.
Action: Contact Oracle support.
KUP-04068: internal error fetching attribute string
Cause: An attempt to fetch information about an internal object failed.
Action: Contact Oracle support.
KUP-04069: error fetching data for external table
Cause: An error occurred while atempting to fetch data from an external table.
Action: See messages the precede this one for more information.
KUP-04070: field string referenced by column transform string not found
Cause: The column transform for the named column references a field that did not exist anywhere in the definition of the data file.
Action: Verify that the column transform clause is specified correctly. Also verify that the field definitions for the data file are correct.
KUP-04071: record discarded from file string
Cause: Informational message displayed whenever the WHEN clause has been satisfied. If a DISCARD file has been specified for the operation, the record will be written to that file. The record number in the source data file is not known because multiple servers are loading from the file.
Action: none
KUP-04072: error writing to file string
Cause: An error occurred while attempting to write to the named file.
Action: See messages that follow this message for more information about the error.
KUP-04073: record ignored because all referenced fields are null for a record
Cause: A record was rejected because all fields in the data file referenced by the query were NULL.
Action: none
KUP-04074: no write access to directory object string
Cause: The user does not have write access to the directory object used for a log, bad or reject file.
Action: none
KUP-04075: no read access to directory object string
Cause: The user does not have read access to the directory object used for a data file.
Action: none
KUP-04076: file name cannot contain a path specification: string
Cause: The name of a data file, log file, bad file or reject file contains a path specification.
Action: Use the name of a directory object to indicate where the file should be stored.
KUP-04077: unknown format specifier in file name string
Cause: A format specifier is a percent sign followed by a character. The percent sign and character are replaced by a value depending on the character. This error occurs when the character following the percent sign is not defined to have a value.
Action: See the documentation for information on valid format specifiers. If the file to be opened needs to have a percent sign in its name then use two pecent signs. They will get replaces by a single percent sign in the resulting file name.
KUP-04078: invalid file name specified: string
Cause: Attempt to parse the file name failed.
Action: Specify a valid file name.
KUP-04079: error fetching list of valid directories
Cause: An attempt to retrieve a list of valid directories that can be used by the user to open files failed. See messages that follow for more information.
Action: Contact Oracle support. As a workaround try specifing no log file, no discard files and no bad files.
KUP-04080: directory object string not found
Cause: The directory object specified for an input file or a log, bad or discard file does not exist in the database or the user has no privileges to access this directory.
Action: none
KUP-04081: field string used in concatenation for column string is not a character type
Cause: The specified field was part of a concatenation of strings used to create the value for the names column. However, the field was not of a character datatype. Only character fields may be used as part of concatenating fields.
Action: Verify the correct field was used in the CONCAT clause. Also verify that the correct datatype is specified for the field in the field list.
KUP-04082: error converting field string for LOBFILE column string
Cause: The LOBFILE column had either its directory object name or filename specified by a field in the data file and that field needed to be converted to the server's character set before it could be used. This message indicates that an attempt to convert the field failed.
Action: Verify that the data file has the correct value for the fields. Also verify that the correct character set was specified for the data file.
KUP-04083: no directory object specified in LOBFILE clause for column string
Cause: There was no directory object specified for the LOB files used to populate the named column and no default directory was specified for the external table.
Action: Either specify a directory name, or the name of a data field containing the name of the directory object that contains the files.
KUP-04084: The ORACLE_DATAPUMP access driver does not support the ROWID column.
Cause: A query of an external table of type ORACLE_DATAPUMP tried to reference the ROWID column. The ORACLE_DATAPUMP access driver does not support ROWIDs.
Action: Remove the ROWID from the query. If that is not possible, create a table in the database with the same columns as the external table, copy the data from the external table into the newly created table, and use that new table for the query.
KUP-04085: duplicate directory object string and file string specified for unload
Cause: A CREATE TABLE AS SELECT statement was executed for an external table of type ORACLE_DATAPUMP and the same directory object and filename combination was specified multiple times.
Action: Issue the CREATE TABLE AS SELECT command again but make sure the combination of directory objects and filenames is unique.
KUP-04088: data sampling is not supported by this access driver
Cause: A query of an external table requested a sample of the data returned. The access driver for the external table does not support sampling.
Action: Do not try to use sampling for this external table.
KUP-04089: column transform string is not the name of a table column
Cause: The specified column was in the list of column transforms but a column by that name does not exist in the table
Action: Verify that the correct name was specified in the column transform.
KUP-04090: big endian byte order mark found when little endian expected in string
Cause: A big endian byte order mark was found at the beginning of the specified file and either the access parameters specified the data was in little endian order or the byte order mark for a previous file was little endian.
Action: The file needs to be loaded separately. If a byte order was specified in the access parameters, make sure it is changed to be big endian.
KUP-04091: little endian byte order mark found when big endian expected in string
Cause: A little endian byte order mark was found at the beginning of the specified file and either the access parameters specified the data was in big endian order or the byte order mark for a previous file was big endian.
Action: The file needs to be loaded separately. If a byte order was specified in the access parameters, make sure it is changed to be little endian.
KUP-04100: record rejected in file string
Cause: A record in the data file was not loaded into the table because of an error while finding fields in the record. See the previous error for more information. The record will be written to the BAD file, if one is being used. The record number in the source data file is not known because multiple servers are loading from the file.
Action: none
KUP-04101: record number rejected in file string
Cause: A record in the data file was not loaded into the table because of an error while finding fields in the record. See the previous error for more information. The record will be written to the BAD file, if one is being used.
Action: none
KUP-04102: record number discarded from file string
Cause: Informational message displayed whenever the WHEN clause has been satisfied. If a DISCARD file has been specified for the operation, the record will be written to that file.
Action: none
KUP-04103: error converting zoned decimal field to number for string
Cause: An error occurred converting a zoned decimal number to an Oracle number.
Action: Verify that the zoned decimal number is formatted correctly.
KUP-04104: zoned decimal field has bad values for string
Cause: A zoned decimal number has an invalid format.
Action: Verify that the zoned decimal number is formatted correctly.
KUP-04105: zoned decimal to number conversion caused overflow for string
Cause: A zoned decimal number could not be converted to an Oracle number because the number is too big for an oracle number.
Action: Verify that the zoned decimal number is formatted correctly.
KUP-04106: precision for zoned decimal number is too large for string
Cause: The precision of a zoned decimal number is larger than the precision that can be stored in an Oracle number.
Action: Verify that the zoned decimal number is formatted correctly.
KUP-04108: unable to reread file string
Cause: The query that is executing requires that a data source for an external table be read multiple times. However, the data source is a sequential device that cannot be reread. Examples of this type of data source is a tape or pipe.
Action: There are a few ways around this problem. One is to rewrite the query so that the external table is referenced only once. Another option is to move the data source to a rereadable device such as a disk file. A third option is to load the data for the external table into a temporary table and change the query to reference the temporary table.
KUP-11000: file truncated error
Cause: A truncated file was used for the load operation.
Action: Verify unload operation completed successfully.
KUP-11001: files not from the same unload operation
Cause: Files used for the load operation were not from the same unload operation.
Action: Verify the files used are from the same unload operation.
KUP-11002: unable to read data chunk string
Cause: A read or seek to this data chunk was not possible. This chunk may not have existed.
Action: Verify the files used for the load operation are correct.
KUP-11003: bad data encountered while reading from file string
Cause: There was a datatype conversion error while attempting to convert the data in the data file to match the datatype of a column in the external table. The message that follows this one displays the name of the column and the start of the data for the column that could not be converted. The row containing the bad data is rejected and not included as a row in the external table.
Action: If the row containing the bad data should not be filtered out, then modify the definition of the external table so that the datatypes of the columns match the datatypes of the fields in the data file.
KUP-11005: error seeking in file: string
Cause: An attempt to seek to the specified position in file failed.
Action: Review the error message. Resolve the problem and retry the the operation. Contact Oracle Support Services if the problem cannot be resolved.
KUP-11006: file truncated error in string
Cause: A truncated or incomplete file was used for the load operation.
Action: Verify unload operation completed successfully.
KUP-11007: conversion error loading table string.string
Cause: A row could not be loaded into the table because there was a conversion error for one or more columns in a row.
Action: See the message that follows for more information about the row that could not be loaded. To avoid this error, make sure the definition of the table being loaded matches the definition of the table being unloaded.
KUP-11008: conversion error loading table string.string partition string
Cause: A row could not be loaded into the table because there was a conversion error for one or more columns in a row.
Action: See the message that follows for more information about the row that could not be loaded. To avoid this error, make sure the definition of the table being loaded matches the definition of the table being unloaded.
KUP-11009: data for row: string
Cause: A conversion error occurred while loading data into a table. The message shows values for the field in the row that had the conversion error.
Action: None. This is only an informational message.
KUP-11010: unable to open at least one dump file for load
Cause: None of the files listed in the LOCATION clause could be opened for load.
Action: A load operation requires that at least one file could be opened. Check that the unload operation succeeded. Check that the path and filenames to the dump files are correct.
KUP-11011: file string is not valid for this load operation
Cause: The specified file could not be used for this load because the internal header and/or table metadata of this file were not consistent with those of the first file listed in the LOCATION clause.
Action: Verify all the files listed in the LOCATION clause are from the same unload operation.
KUP-11012: file string in string already exists
Cause: The specified file could not be used for this unload because that would mean overwriting an existing file.
Action: Specify a file that does not currently exist.


25 UDE-00001 to UDE-00053

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

25 UDE-00001 to UDE-00053

UDE-00001: user requested cancel of current operation
Cause: User has requested a cancellation of current job.
Action: No action is needed.
UDE-00002: invalid username or password
Cause: An invalid username or password was specified.
Action: Retry with a valid username and password.
UDE-00003: all allowable logon attempts failed
Cause: Attempts were repeatedly made to log on with an invalid username or password.
Action: Shut down the utility, then restart and retry with a valid username and password.
UDE-00004: operation generated ORACLE error number
Cause: The operation unexpectedly produced the specified error. Refer to the description of that error for more information.
Action: s.
UDE-00005: unexpected End-Of-File encountered while reading input
Cause: Encountered an End-Of-File while reading the user input.
Action: If input to export is being redirected, check the file for errors.
UDE-00006: failed to allocate memory of size number
Cause: Unable to allocate the necessary memory.
Action: Record the messages that follow and report this to Oracle Customer Support as an Export internal bug.
UDE-00007: attempt to free unallocated memory
Cause: An attempt was made to free memory that was not allocated.
Action: Contact Oracle Worldwide Support
UDE-00010: multiple job modes requested, string and string.
Cause: Multiple job modes were specified.
Action: Specify only one valid mode, then retry.
UDE-00011: parameter string is incompatible with parameter string
Cause: An invalid combination of parameters was specified.
Action: Refer to documentation for the set of valid modes, then retry.
UDE-00012: table mode exports only allow objects from one schema
Cause: Multiple schemas were selected for export.
Action: Retry export specifying only one schema.
UDE-00013: internal expdp error.
Cause: Fatal internal Data Pump client error.
Action: Contact Oracle Customer Support
UDE-00014: invalid value for parameter, 'string'.
Cause: Could not parse the specified parameter or parameter value.
Action: Refer to documentation for valid parameter values.
UDE-00015: invalid context or job state for parameter, 'string'.
Cause: Invalid job state or context for specified parameter.
Action: Refer to documentation for correct parameter usage.
UDE-00016: 'string' parameter requires a value.
Cause: Parameter was specified without a value.
Action: Refer to documentation for correct parameter usage.
UDE-00017: Data Pump job is already executing.
Cause: Incorrect Data Pump job state for requested operation.
Action: Refer to documentation for correct usage.
UDE-00050: Unable to setup parameter processing.
Cause: An unexpected error occurred during parameter manager initialization.
Action: Record the messages that follow and report this to Oracle Customer Support as an Export internal bug.
UDE-00051: unable to set NLS_NUMERIC_CHARACTERS to required defaults.
Cause: Export was unable to set NLS_NUMERIC_CHARACTERS to '.,'
Action: Record the accompanying messages and report this as an Export internal error to Oracle customer support.
UDE-00052: incorrect Data Pump client for operation: string
Cause: Export client attempted to attach to import job.
Action: Use appropriate client when attaching to an existing job
UDE-00053: unrecognized client command 'string'
Cause: Invalid interactive client command.
Action: Refer to documentation for valid client commands.


26 UDI-00001 to UDI-00053

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

26 UDI-00001 to UDI-00053

UDI-00001: user requested cancel of current operation
Cause: User has requested a cancellation of current job.
Action: No action is needed.
UDI-00002: invalid username or password
Cause: An invalid username or password was specified.
Action: Retry with a valid username and password.
UDI-00003: all allowable logon attempts failed
Cause: Attempts were repeatedly made to log on with an invalid username or password.
Action: Shut down the utility, then restart and retry with a valid username and password.
UDI-00004: operation generated ORACLE error number
Cause: The operation unexpectedly produced the specified error. Refer to the description of that error for more information.
Action: s.
UDI-00005: unexpected End-Of-File encountered while reading input.
Cause: Encountered an End-Of-File while reading the user input.
Action: If input to import is being redirected, check the file for errors.
UDI-00006: failed to allocate memory of size number
Cause: Unable to allocate the necessary memory.
Action: Record the messages that follow and report this to Oracle Customer Support as an Import internal bug.
UDI-00007: attempt to free unallocated memory
Cause: An attempt was made to free memory that was not allocated.
Action: Contact Oracle Customer Support
UDI-00010: multiple job modes requested, string and string.
Cause: Invalid job mode was specified.
Action: Specify only one valid mode, then retry.
UDI-00011: parameter string is incompatible with parameter string
Cause: An invalid combination of parameters was specified.
Action: Refer to documentation for the set of valid modes, then retry.
UDI-00012: table mode imports only allow objects from one schema
Cause: Multiple schemas were selected for import.
Action: Retry import specifying only one schema.
UDI-00013: internal impdp error.
Cause: Fatal internal Data Pump client error.
Action: Contact Oracle Customer Support.
UDI-00014: invalid value for parameter, 'string'
Cause: Could not parse the specified parameter or parameter value.
Action: Refer to documentation for valid parameter values.
UDI-00015: invalid context or job state for parameter, 'string'.
Cause: Invalid job state or context for specified parameter.
Action: Refer to documentation for correct parameter usage.
UDI-00016: 'string' parameter requires a value.
Cause: Parameter was specified without a value.
Action: Refer to documentation for correct parameter usage.
UDI-00017: Data Pump job is already executing.
Cause: Incorrect Data Pump job state for requested operation.
Action: Refer to documentation for correct usage.
UDI-00050: unable to setup parameter processing.
Cause: An unexpected error occurred during parameter manager initialization.
Action: Record the messages that follow and report this to Oracle Customer Support as an Import internal bug.
UDI-00051: unable to set NLS_NUMERIC_CHARACTERS to required defaults.
Cause: Import was unable to set NLS_NUMERIC_CHARACTERS to '.,'
Action: Record the accompanying messages and report this as an Import internal error to Oracle Customer Support.
UDI-00052: incorrect Data Pump client for operation: string
Cause: Import client attempted to attach to export job.
Action: Use appropriate client when attaching to an existing job
UDI-00053: unrecognized client command 'string'
Cause: Invalid interactive client command.
Action: Refer to documentation for valid client commands.


27 DBV-00200 to DBV-00200

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

27 DBV-00200 to DBV-00200

DBV-00200: Block, dba number, already marked corrupted
Cause: The block was previously corrupted. It has been marked as corrupt by the Oracle database server.
Action: If the block is not currently allocated to a database object, then no action is required. If the block is allocated, then the options and required action depend on the type and nature of the object which owns the block. To repair an allocated block perform block or file media recovery.


28 NID-00001 to NID-00604

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

28 NID-00001 to NID-00604

NID-00001: Illegal command line syntax - parse error = (number)
Cause: Illegal operand on command line.
Action: Remove illegal operand.
NID-00002: Parse error: string
Cause: An error was encountered while parsing the command line.
Action: Remove offending operand.
NID-00010: Password:
Cause: Password was not specified in command line.
Action: Type password at this prompt.
NID-00100: Cannot open datafile "string"
Cause: The specified datafile could not be opened.
Action: Ensure that the specified datafile exists and is writable.
NID-00101: LOGFILE (string) not accessible
Cause: The specified log file could not be opened.
Action: Specify a log file that is writable.
NID-00102: Garbled target string
Cause: The supplied connect string could not be parsed. The connect string does not have the correct format.
Action: Refer to Oracle9i Database Concepts.
NID-00103: Missing password in connect string "string"
Cause: Could not find the password in the supplied connect string. The connect string does not have the correct format.
Action: Refer to Oracle9i Database Concepts.
NID-00104: Need to specify TARGET connection parameter in command line
Cause: The mandatory parameter TARGET was not specified.
Action: Specify TARGET=<username>/<password> when invoking this utility.
NID-00105: Need to specify "LOGFILE=<logfile>" when using APPEND=YES option
Cause: The APPEND parameter was specified without a LOGFILE.
Action: Specify APPEND=YES only when LOGFILE is also specified.
NID-00106: LOGIN to target database failed with Oracle error: string
Cause: An Oracle error was reported while attempting to log in to the target database.
Action: Follow the actions for the specified Oracle error.
NID-00107: File I/O error on datafile "string" during string operation (number/string)
Cause: An operating system error was reported while performing the specified operation in the specified file.
Action: Verify the datafile and check for operating system errors.
NID-00109: DBNAME string length number exceeds maximum length of number
Cause: The specified new database name exceeded the maximum size.
Action: Specify a shorter, valid name.
NID-00110: Cannot use REVERT and specify a database name at the same time
Cause: Conflicting options were specified in the command line.
Action: Choose only one of the options.
NID-00111: Oracle error reported from target database while executing string string
Cause: An Oracle error was reported when executing an OCI operation.
Action: Follow the actions for the specified Oracle error.
NID-00113: Error reading answer - aborting
Cause: Response caused an error.
Action: Retry the operation.
NID-00114: Must specify new database name when SETNAME is used
Cause: SETNAME=YES was specified but no DBNAME was provided.
Action: Specify DBNAME or remove the SETNAME=YES option.
NID-00115: Database should be mounted
Cause: The database was not mounted.
Action: Mount the database.
NID-00120: Database should be mounted exclusively
Cause: The database was started in parallel mode. To change the DBID, the database must be mounted exclusively.
Action: Shut down the database and start it in exclusive mode.
NID-00121: Database should not be open
Cause: The database was open. To change the DBID, the database must be mounted exclusively.
Action: Shutdown the database and mount it in exclusive mode.
NID-00122: Database should have no offline immediate datafiles
Cause: The database has one or more datafiles that are in OFFLINE IMMEDIATE mode.
Action: Drop the datafiles or recover them and bring them online.
NID-00123: Magic number for datafile "string" is incorrect
Cause: Block 0 header has an incorrect magic number for the specified datafile.
Action: Verify that the datafile is correct and retry the operation.
NID-00124: Mismatched dbid for datafile string, expected number, found number
Cause: The dbid of the datafile does not match the 'old' DBID or the 'new' DBID.
Action: Verify that this datafile belongs to the database. You may need to restore a backup of the datafile.
NID-00125: Database should have no disabled datafiles
Cause: The database has one or more datafiles that are disabled.
Action: Drop the datafiles or recover them and bring them online.
NID-00126: Database should have no datafiles in unknown state
Cause: The database has one or more datafiles that are in an unknown state.
Action: Drop the datafiles or recover them and bring them online.
NID-00127: All online files in the database must have the same checkpoint SCN
Cause: The database has one or more datafiles that have a checkpoint SCN that does not match the database checkpoint SCN.
Action: Restart the database and shut it down cleanly, then retry the operation.
NID-00128: Cannot revert change of database, change not in progress
Cause: The REVERT option was used, but the control file does not show that a change of DBID was in progress.
Action: Do not use the REVERT option, or possibly restore the control file that was in place when the utility was started.
NID-00129: Invalid DBID for datafile "string", expecting number, found number
Cause: A datafile header shows a different DBID from the rest of the database files.
Action: Ensure that the file belongs to this database.
NID-00130: Mismatched CHECKPOINT_CHANGE# in datafile "string", expecting string, found string
Cause: The datafile header does not match information in the control file.
Action: Revert the change, open the database, and verify that all datafiles are consistent. Then, shut down the database and retry the operation.
NID-00131: Control file is not current
Cause: A non-current control file is currently mounted.
Action: Perform necessary actions to make the control file current and retry.
NID-00132: CHECKPOINT_CHANGE# in datafile "string": string in the future of controlfile: string
Cause: The checkpoint in the datafile header is ahead of the checkpoint in the control file.
Action: Make the database consistent and retry.
NID-00133: Database should have only consistent datafiles
Cause: The database has one or more datafiles that are marked FUZZY in the control file.
Action: Restart the database and shut down consistently, then retry the operation.
NID-00134: Datafile "string" is not consistent
Cause: The datafile is marked as fuzzy in its header.
Action: Restart the database and shut down cleanly, then retry the operation.
NID-00135: There are number active threads
Cause: is that the database crashed the last time it was shut down.
Action: Ensure that all threads are closed before retrying the operation. Start and open the database to perform crash recovery, then shut down with the NORMAL or IMMEDIATE options to close it cleanly. Finally, try running the utility again.
NID-00137: All datafiles that are not dropped should be readable
Cause: The database had one or more files that could not be read.
Action: Restore the missing files and retry the operation.
NID-00138: Block verification failed for datafile string (number)
Cause: Block header checksum yields a nonzero value for the specified datafile.
Action: Verify that the datafile is correct and retry the operation.
NID-00139: Mismatched dbname for datafile string, expected string, found string
Cause: The dbname of the datafile does not match the 'old' dbname or the 'new' dbname.
Action: Verify that this datafile belongs to the database. You may need to restore a backup of the datafile.
NID-00140: Specified database name string does not match previous name used string
Cause: This is a continuation of a failed attempt. However in the failed attempt, the database name is different than the one used in the last attempt.
Action: Retry the command using the original database name.
NID-00141: No database name specified, previous attempt used string
Cause: This is a continuation of a failed attempt. However, in the failed attempt, a database name was provided.
Action: Retry the command using the original database name.
NID-00142: Only changing database name, previous attempt changed dbid to number
Cause: This is a continuation of a failed attempt. However, in the failed attempt, the database id was also being changed.
Action: Retry the command removing SETNAME=YES.
NID-00143: Mismatched controlfile string
Cause: A controlfile did not have the correct status.
Action: Shutdown the database, remove the mismatched controlfile, mount the database, and retry the operation.
NID-00144: New name for database string is the same as current name string
Cause: The specified name is the same as the current name of the database.
Action: Specify a different name or do not use the DBNAME option.
NID-00145: nls subsystem initialization failure for product=string, facility=string
Cause: The NLS product/facility error message file could not be located or properly initialized.
Action: Check that the error message directory and file(s) have been properly installed.
NID-00300: Connected to database string (DBID=number)
Cause: Informational message.
Action: No action required.
NID-00301: Datafile string - dbid changed, wrote new name
Cause: Informational message.
Action: No action required.
NID-00302: Datafile string - dbid changed
Cause: Informational message.
Action: No action required.
NID-00303: Datafile string - wrote new name
Cause: Informational message.
Action: No action required.
NID-00304: Datafile string - reverted
Cause: Informational message.
Action: No action required.
NID-00305: Datafile string - already changed
Cause: Informational message.
Action: No action required.
NID-00306: Datafile string - no revert needed
Cause: Informational message.
Action: No action required.
NID-00307: Control File string - dbid changed, wrote new name
Cause: Informational message.
Action: No action required.
NID-00308: Control File string - dbid changed
Cause: Informational message.
Action: No action required.
NID-00309: Control File string - wrote new name
Cause: Informational message.
Action: No action required.
NID-00310: Control File string - reverted
Cause: Informational message.
Action: No action required.
NID-00311: Control File string - modified
Cause: Informational message.
Action: No action required.
NID-00312: Connected to server version string
Cause: Informational message.
Action: No action required.
NID-00315: Operation already in progress, continuing
Cause: Informational message.
Action: No action required.
NID-00320: Operation cancelled at user request
Cause: Informational message.
Action: No action required.
NID-00321: Proceeding with operation
Cause: Informational message.
Action: No action required.
NID-00330: The following datafiles are offline immediate:
Cause: Informational message.
Action: No action required.
NID-00331: The following datafiles are disabled:
Cause: Informational message.
Action: No action required.
NID-00332: The following datafiles are in unknown state:
Cause: Informational message.
Action: No action required.
NID-00333: Cannot read the header of the following datafiles:
Cause: Informational message.
Action: No action required.
NID-00334: The following datafiles are not checkpointed to string:
Cause: Informational message.
Action: No action required.
NID-00335: The following datafiles are not consistent:
Cause: Informational message.
Action: No action required.
NID-00336: The following datafiles are offline clean:
Cause: Informational message.
Action: No action required.
NID-00337: The following datafiles are read-only:
Cause: Informational message.
Action: No action required.
NID-00338: Control Files in database:
Cause: Informational message.
Action: No action required.
NID-00350: string (number) string
Cause: Informational message.
Action: No action required.
NID-00351: string (number)
Cause: Informational message.
Action: No action required.
NID-00352: string (number), error: number
Cause: Informational message.
Action: No action required.
NID-00353: string
Cause: Informational message.
Action: No action required.
NID-00354: Instance shut down
Cause: Informational message.
Action: No action required.
NID-00370: Change database ID of database string? (Y/[N]) =>
Cause: Informational message.
Action: No action required.
NID-00371: Change database name of database string to string? (Y/[N]) =>
Cause: Informational message.
Action: No action required.
NID-00372: Change database ID and database name string to string? (Y/[N]) =>
Cause: Informational message.
Action: No action required.
NID-00373: Revert changes for database string (Y/[N]) =>
Cause: Informational message.
Action: No action required.
NID-00390: These files must be writable by this utility.
Cause: Informational message.
Action: No action required.
NID-00395: Reverting database name from string to string
Cause: Informational message.
Action: No action required.
NID-00396: Reverting database ID from number to number
Cause: Informational message.
Action: No action required.
NID-00397: Changing database name from string to string
Cause: Informational message.
Action: No action required.
NID-00398: Changing database ID from number to number
Cause: Informational message.
Action: No action required.
NID-00400: DBNEWID - Completed with errors.
Cause: Informational message.
Action: No action required.
NID-00401: Must finish REVERT changes before attempting any database operation.
Cause: Informational message.
Action: No action required.
NID-00402: Must finish change or REVERT changes before attempting any database operation.
Cause: Informational message.
Action: No action required.
NID-00403: DBNEWID - Completed with validation errors.
Cause: Informational message.
Action: No action required.
NID-00404: DBNEWID - Completed succesfully.
Cause: Informational message.
Action: No action required.
NID-00405: Reversion of database name and database ID failed.
Cause: Informational message.
Action: No action required.
NID-00406: Reversion of database name failed.
Cause: Informational message.
Action: No action required.
NID-00407: Reversion of database ID failed.
Cause: Informational message.
Action: No action required.
NID-00410: Reversion of database changes failed during validation - database is intact.
Cause: Informational message.
Action: No action required.
NID-00415: Change of database name and database ID failed.
Cause: Informational message.
Action: No action required.
NID-00416: Change of database name failed.
Cause: Informational message.
Action: No action required.
NID-00417: Change of database ID failed.
Cause: Informational message.
Action: No action required.
NID-00420: Change of database name and ID failed during validation - database is intact.
Cause: Informational message.
Action: No action required.
NID-00421: Change of database name failed during validation - database is intact.
Cause: Informational message.
Action: No action required.
NID-00422: Change of database ID failed during validation - database is intact.
Cause: Informational message.
Action: No action required.
NID-00425: Database name restored to string.
Cause: Informational message.
Action: No action required.
NID-00426: Database ID for database string restored to number.
Cause: Informational message.
Action: No action required.
NID-00430: Database is ready to be open or shut down.
Cause: Informational message.
Action: No action required.
NID-00431: DBNEWID - Reversion completed.
Cause: Informational message.
Action: No action required.
NID-00435: Database name changed to string.
Cause: Informational message.
Action: No action required.
NID-00436: Modify parameter file and generate a new password file before restarting.
Cause: Informational message.
Action: No action required.
NID-00440: Database ID for database string changed to number.
Cause: Informational message.
Action: No action required.
NID-00441: All previous backups and archived redo logs for this database are unusable.
Cause: Informational message.
Action: No action required.
NID-00442: Database has been shutdown, open database with RESETLOGS option.
Cause: Informational message.
Action: No action required.
NID-00450: Succesfully changed database name and ID.
Cause: Informational message.
Action: No action required.
NID-00451: Succesfully changed database name.
Cause: Informational message.
Action: No action required.
NID-00452: Succesfully changed database ID.
Cause: Informational message.
Action: No action required.
NID-00480: Database is intact - database is ready to be open or shut down.
Cause: Informational message.
Action: No action required.
NID-00481: DBNEWID - Cancelled.
Cause: Informational message.
Action: No action required.
NID-00490: LOG being redirected to STDERR due to errors.
Cause: Could no write message to log file.
Action: N/A.
NID-00500: Keyword Description (Default)
Cause: Informational message.
Action: No action required.
NID-00501: ----------------------------------------------------
Cause: Informational message.
Action: No action required.
NID-00502: TARGET Username/Password (NONE)
Cause: Informational message.
Action: No action required.
NID-00503: DBNAME New database name (NONE)
Cause: Informational message.
Action: No action required.
NID-00504: LOGFILE Output Log (NONE)
Cause: Informational message.
Action: No action required.
NID-00505: REVERT Revert failed change NO
Cause: Informational message.
Action: No action required.
NID-00506: SETNAME Set a new database name only NO
Cause: Informational message.
Action: No action required.
NID-00507: APPEND Append to output log NO
Cause: Informational message.
Action: No action required.
NID-00508: HELP Displays these messages NO
Cause: Informational message.
Action: No action required.
NID-00600: Internal Error - [number] [number] [number] [number]
Cause: This is the generic internal error number for program exceptions. This indicates that the program has encountered an exceptional condition.
Action: Report as a bug - the first argument is the internal error number
NID-00601: Internal Error - [number] [string] [number] [number]
Cause: This is the generic internal error number for program exceptions. This indicates that the program has encountered an exceptional condition.
Action: Report as a bug - the first argument is the internal error number
NID-00602: Could not allocate number bytes for "string"
Cause: Memory allocation failed.
Action: Free memory at the operating system level and retry operation.
NID-00603: No datafiles found in database
Cause: Controlfile has not datafiles recorded
Action: Report as a bug - the first argument is the internal error number
NID-00604: No control files found in database
Cause: Instance has no control files recorded
Action: Report as a bug - the first argument is the internal error number


29 DGM-16900 to DGM-17002

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

29 DGM-16900 to DGM-17002

DGM-16900: Unable to initialize client
Cause: The client could not be initialized.
Action: This is an internal error. Contact Oracle Support Services.
DGM-16901: Unable to initialize environment
Cause: The database environment could not be allocated and initialized.
Action: This is an internal error. Contact Oracle Support Services.
DGM-16902: Unable to allocate handle
Cause: The database handles could not be allocated.
Action: This is an internal error. Contact Oracle Support Services.
DGM-16903: Unable to connect to database
Cause: The specified database was unreachable because it does not exist or was not started.
Action: Correct the request or start the database and try again.
DGM-16904: Unable to set attribute
Cause: The server attributes could not be set.
Action: Check additional error messages.
DGM-16905: Failed.
Cause: The given action failed.
Action: Check additional error messages.
DGM-16906: Unable to accept commands: no memory
Cause: No memory was available for the program.
Action: Increase memory and try again.
DGM-16909: Fatal error - quitting...
Cause: A fatal error was encountered.
Action: See additional error messages and/or contact Oracle Support Services.
DGM-16910: unable to issue command to server
Cause: Commands cannot be issued to the server.
Action: See additional error messages and/or contact Oracle Support Services.
DGM-16911: Warning:
Cause: An action succeeded with warnings.
Action: See error message and take appropriate action.
DGM-16912: Unknown command "string". Try "help"
Cause: An unknown command was issued.
Action: Try again using a valid command.
DGM-16916: Missing site name. Try "help"
Cause: The site name is missing.
Action: Try the command again using correct syntax
DGM-16917: Unable to shut down instance "string".
Cause: DGMGRL could not shut down the given instance because of the errors that displayed prior to this message.
Action: Shut down the instance manually.
DGM-16933: Unable to start instance "string".
Cause: DGMGRL could not start the given instance because of the errors that displayed prior to this message.
Action: Start the instance manually.
DGM-16934: You must start instance "string" manually.
Cause: The operation was successfully completed, and it requires startup of the given instance. However, DGMGRL was unable to perform an automatic startup.
Action: Start the given instance manually.
DGM-16943: You must connect to instance "string" and issue the command again.
Cause: The operation requires DGMGRL to connect to a specific instance to complete, but DGMGRL could not automatically connect to the given instance.
Action: Connect to the given instance and issue the command again.
DGM-16944: Failover succeeded. New primary is "string"
Cause: The failover operation succeeded.
Action: No action is required.
DGM-16945: Syntax error before or at "string"
Cause: The given command could not be processed because a syntax error occurred at the named token.
Action: Try the command again using valid syntax.
DGM-16946: Site "string" was not found
Cause: The named site could not be found.
Action: Try the command again using a valid site.
DGM-16948: Can not proceed to switchover. Primary is still "string".
Cause: The switchover operation could not be executed due to the errors reported before this error message. The primary role has not been changed.
Action: Correct the errors reported before this error message and try the switchover command again.
DGM-16949: "string" was not found
Cause: The named object was not found.
Action: Try the command again using a valid database name.
DGM-16951: Can not proceed to failover.
Cause: The failover operation could not be executed due to the errors reported before this error message.
Action: Correct the errors reported before this error message and try the failover command again.
DGM-16952: unable to describe configuration
Cause: The broker configuration could not be described.
Action: The Data Guard broker process (DMON) could not be contacted. Verify that the DMON process is running.
DGM-16959: NULL answer from DMON
Cause: No answer came from the DMON process.
Action: The Data Guard broker process (DMON) is not available. Verify that the DMON process is running.
DGM-16960: status not available
Cause: The status could not be retrieved.
Action: The Data Guard broker process (DMON) is not available. Verify that the DMON process is running.
DGM-16991: More than one resources have name "string".
Cause: The named resource exists on more than one site.
Action: The request must be more specific. Issue the command again using the ON SITE clause.
DGM-16992: You must shut down instance "string" manually.
Cause: The operation was successfully completed, and it requires shutdown of the given instance. However, DGMGRL was unable to perform an automatic shutdown.
Action: Shut down the given instance manually.
DGM-16999: Instance "string" was not found.
Cause: The named instance could not be found.
Action: Try the command again using a valid instance name.
DGM-17000: More than one instances have name "string".
Cause: The named instance exists on more than one databases.
Action: The request must be more specific. Issue the command again using the ON DATABASE clause.
DGM-17002: Primary database can not be removed.
Cause: The named database to be removed is the primary database.
Action: Remove the broker configuration instead.


30 LCD-00100 to LCD-00219

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

30 LCD-00100 to LCD-00219

LCD-00100: internal error, argument [number]
Cause: An internal error has occurred
Action: Report it to your System Administrator immediately
LCD-00111: value not in legal range [string]
Cause: The value of the parameter is outside bounds
Action: Refer to the manual for the bounds on the parameter
LCD-00112: illegal integer radix specification [string]
Cause: Self Explanatory
Action: valid characters are 'd', 'h', 'D' and 'H'
LCD-00113: integer conversion error or negative integer [string]
Cause: A bad or negative integer was assigned to an integer parameter
Action: Self explanatory
LCD-00114: illegal boolean response [string]
Cause: You a value than TRUE or FALSE to a boolean parameter
Action: Boolean parameters only take TRUE or FALSE
LCD-00122: unrecognized keyword [string]
Cause: You have misspelled the parameter name
Action: Spell the parameter name correctly
LCD-00128: invalid positional parameter value [string]
Cause: An invalid positional parameter value has been entered
Action: Remove the invalid positional parameter
LCD-00161: ORACLE error (possible syntax error) parameter [string]
Cause: Possible syntax error. Additional messages follow.
Action: Correct the parameter in error.
LCD-00201: could not open specified filename [string]
Cause: The file specified does not exist
Action: Create an appropriate parameter file
LCD-00203: missing keyword [string]
Cause: A keyword is expected but none was found
Action: Add a keyword followed by an '=' sign and a parameter value
LCD-00204: left parenth and no parameter specified [string]
Cause: A parameter list was started but no parameter was specified
Action: Add an appropriate list of values and close the parameter list
LCD-00205: unbalanced parentheses [string]
Cause: Self explanatory
Action: Balance the parentheses
LCD-00206: positional parameter entered after keyword [string]
Cause: An '=' sign is missing
Action: All keywords must be followed by '=' signs
LCD-00207: nested parentheses encountered [string]
Cause: Only one set of parentheses is permitted
Action: Remove the nested parentheses
LCD-00208: unexpected keyword in value list [string]
Cause: A keyword was found instead of a value
Action: Insert an appropriate value for the given parameter
LCD-00209: missing value for keyword at end of string [string]
Cause: A keyword is specified with no value
Action: Specify a valid value for the keyword
LCD-00210: illegal assignment operator [string]
Cause: You used a sign other than '=' to assign a keyword a value
Action: Use only the '=' sign
LCD-00211: unexpected delimiter [string]
Cause: An invalid delimiter was found between values
Action: A comma or a space is a valid delimiter
LCD-00212: runaway quoted string [string]
Cause: The parameter value was quoted on the left side but not on the right
Action: Quote the parameter value on both sides
LCD-00215: parameter files nested too deep [string]
Cause: Too many levels of indirection of file parameters. Maximum is 3.
Action: Reduce the level of indirection to less than 3
LCD-00217: failure while processing file parameter [string]
Cause: An error occurred while processing the specified file parameter
Action: Specific details will appear in other messges
LCD-00218: error in file [string]
Cause: An error occurred in the particular file.
Action: Refer to the other messages for the specific error.
LCD-00219: nested include file [string] is too large
Cause: There is a limit on the size of a parameter file, and it was exceeded. This limit is now 8192 bytes.
Action: Remove characters from the file to make it smaller, or use another level of nesting.


31 QSM-00501 to QSM-02188

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

31 QSM-00501 to QSM-02188

QSM-00501: unable to initialize Summary Advisor environment
Cause: The Summary Advisor external procedure initialization process failed.
Action: Contact Oracle Worldwide Support.
QSM-00502: OCI error
Cause: A OCI callback routine reported an error
Action: Contact Oracle Worldwide Support.
QSM-00503: out of memory
Cause: Summary Advisor failed to allocate the necessary memory.
Action: Contact Oracle Worldwide Support.
QSM-00504: internal error
Cause: An internal error occurred.
Action: Contact Oracle Worldwide Support.
QSM-00505: syntax error
Cause: A syntax error occurred.
Action: Correct syntax error if possible or contact Oracle Worldwide Support.
QSM-00506: no fact-tables could be found
Cause: The fact-filter is not specified, and there are no fact-tables in the warehouse. A fact-table is a table having foreign-key constraints to one or more of the dimension-tables in the data warehouse.
Action: Check the fact-filter is correctly specified; check that appropriate constraints exist; and the user has privileges to access the tables
QSM-00507: no dimensions could be found
Cause: The database does not have any dimensions
Action: Create the dimensions in your warehouse
QSM-00508: statistics missing on tables/columns
Cause: The system metadata does not contain statistics on one or more tables or columns. The Advisor needs cardinalities of all fact-tables, and of the level-keys of all dimensions in the data warehouse.
Action: Run ANALYZE on the tables and summaries in the warehouse to collect statistics
QSM-00509: invalid parameter
Cause: The indicated parameter has an invalid value
Action: Supply a value in the proper range
QSM-00510: statistics missing on materialized views
Cause: The system metadata does not contain statistics on one or more materialized views. The Advisor needs cardinalities of all materialized views in the data warehouse.
Action: Run ANALYZE on the tables and materialized views in the warehouse to collect statistics.
QSM-00511: invalid fact-tables specified in fact-filter
Cause: The tables specified in the fact-filter are not valid fact-tables. A fact-table must have foreign-key constraints to one or more of the dimension-tables in the data warehouse.
Action: Check the fact-filter is correctly specified; check that appropriate constraints exist; and the user has privileges to access the tables
QSM-00512: invalid summaries specified in the retention-list
Cause: The summaries specified in the retention-list are not valid.
Action: Check the spelling of the summary-names; check that they are valid; and the user has privileges to access them.
QSM-00513: one or more of the workload tables is missing
Cause: One or both of the workload tables are missing. The two workload tables which should be present in the user's schema are V_192216243_F_5_E_14_8_1 and V_192216243_F_5_E_15_8_1; the former is mapped to WORK$_IDEAL_MVIEW and the latter to WORK$_MVIEW_USAGE. The workload tables are created by the Oracle Trace Formatter when the data-collection-file (oraclesm.dat) is formatted by the user.
Action: Check whether the Formatter succeeded in formatting the data collection. Sometimes the V_192216243_F_5_E_14_8_1 (i.e WORK$_IDEAL_MVIEW) may not be created whereas the other table is created. The most likely cause of this is the init.ora parameters needed to invoke mview-rewrite are not enabled. Check your
QSM-00514: the size of must-retain summaries exceeds specified space limit
Cause: The specified space limit is greater than the size of must-retain summaries.
Action: Reduce the number of must-retain summaries or increase the space limit
QSM-00515: operation cancelled by user
Cause: The operation has been cancelled by the user
Action: None
QSM-00516: illegal status detected for run
Cause: The run has encountered an illegal value in the status field of the mview$_adv_log table. This could be internal error or an application error.
Action: Contact Oracle Worldwide Support.
QSM-00517: Summary Advisor requires a COMPATIBLE setting of 8.1.0.0 or greater
Cause: The current database has a compatibility setting that is earlier than the supported server version.
Action: Adjust the instance parameter COMPATIBLE to 8.1.0.0 or greater.
QSM-00518: Java is not enabled. Please execute INITJVM.SQL and INITQSMA.SQL
Cause: The current database has has not be created or upgraded to support Java stored procedures. Summary Advisor requires Java stored procedures.
Action: Log into the database with SYSDBA privileges. Execute the INITJVM.SQL script which is found in the ORACLE home directory under JAVAVM. Next, execute the INITQSMA.SQL script found in the ADMIN directory under the ORACLE home.
QSM-00519: Summary Advisor is not installed. Please execute INITQSMA.SQL.
Cause: The current database has has not be created or upgraded to support Summary Advisor. Summary Advisor requires several Java stored procedures.
Action: Log into the database with SYSDBA privileges. Execute the INITQSMA.SQL script found in the ADMIN directory under the ORACLE home. **** **** Messages 520-709 are in the 9i Summary Advisor Java modules
QSM-00710: data access error in module string
Cause: SQL Access Advisor detected a severe error while accessing the advisor repository.
Action: See the accompanying error message for approprate actions.
QSM-00750: the specified value string for parameter string is invalid or contains an invalid item
Cause: The user attempted to set a task parameter using invalid data.
Action: Adjust the data value and retry the operation.
QSM-00751: the file string could not be opened for write access
Cause: Access Advisor could not create the script or report due to a file system error.
Action: Verify the location for file write access and retry the operation.
QSM-00752: the parameter string contains an invalid combination of options string
Cause: The user specified correct option keywords, but entered a combination that is not supported within Access Advisor.
Action: Validate the correct option usage and retry the operation.
QSM-00753: the specified value string is out of the acceptable range of string to string for parameter string
Cause: The user attempted to set a task parameter using invalid data.
Action: Adjust the data value and retry the operation.
QSM-00754: task string does not reference a valid workload and therefore cannot be executed
Cause: The user attempted to execute a advisor task that requires a workload.
Action: Specify a workload for the task and retry the operation.
QSM-00755: a set of workload statements already exists for workload string
Cause: The user attempted to save workload data into an existing workload that already contains data without specifying APPEND or REPLACE.
Action: Validate the import mode retry the operation.
QSM-00756: the specified workload string is being used by one or more advisor tasks
Cause: The user attempted to modify or delete a workload that is currently being used by another task.
Action: Remove the workload reference from the advisor task and retry the operation.
QSM-00757: the specified workload string is not referenced by task string
Cause: The user attempted to delete invalid workload reference from the task.
Action: Validate the workload reference and retry the operation.
QSM-00758: the specified parameter string is not valid for workload string
Cause: The user attempted to access a workload parameter that is does not exist for the specified workload. The parameter may be misspelled or the user selected a parameter that is not supported by the particular advisor.
Action: Validate the parameter name and retry the operation.
QSM-00759: the user string does not exist for the specified workload statement
Cause: The user attempted to add a new SQL statement with an invalid username.
Action: Adjust the name and retry the operation.
QSM-00760: the import mode string is invalid for the current operation
Cause: The user attempted to store data in the repository with an invalid import mode.
Action: Use one of the following valid values: NEW, APPEND, or REPLACE.
QSM-00761: the priority string is invalid for the current operation
Cause: The user attempted to store data in the repository with an invalid priority.
Action: Use one of the following valid values: 1, 2, 3.
QSM-00762: the specified Summary Advisor workload string does not exist
Cause: The user attempted to import an advisor workload from an invalid or non-existent Summary Advisor workload.
Action: Validate the Summary Advisor workload identifier and retry the operation.
QSM-00763: the owner string is invalid while validating user-defined workload string.string
Cause: The user attempted to import an advisor workload from a user who may not access to the table.
Action: Validate the location of the user-defined workload.
QSM-00764: the column string was not found in the user-defined workload table string.string
Cause: The user attempted to import an advisor workload from a user table that does not contain the required column.
Action: Validate the user-defined workload table and retry the operation.
QSM-00765: cannot validate user-defined workload because table string.string is invalid.
Cause: The user attempted to import an advisor workload from a table that is not accessible.
Action: Validate the location of the user-defined workload.
QSM-00766: a SQL statement is required for the current workload operation
Cause: The user attempted to create an entry in a workload collection without specifying a SQL statement.
Action: Validate the SQL statement and retry the operation.
QSM-00767: a SQL cache is not available to user string
Cause: The user attempted to collect a workload from the SQL without having authorization.
Action: Validate the user account and retry the operation.
QSM-00768: the search condition is invalid for the requested operation
Cause: The user provided a invalid SEARCH argument to an Access Advisor workload operation. A search condition must be a valid SQL search condition using only the column names specified in the procedure documentation.
Action: Correct the search condition and retry the operation.
QSM-00769: the SQL statement string was not found for workload string
Cause: The user attempted to access a SQL statement that does not exist in the workload.
Action: Validate the SQL statement identifier and retry the operation.
QSM-00770: the specified workload string is already referenced by task string
Cause: The user attempted to add a workload reference to a task when the task already contains the reference.
Action: Validate the workload reference and retry the operation.
QSM-00771: the specified SQL statement cannot be stored in the workload because it has no valid table references
Cause: The user attempted to add a workload statement that contains table references that are either system-specified or user-specified invalid tables.
Action: Validate the workload statement and retry the operation.
QSM-00772: the specified SQL statement cannot be stored in the workload due to a statement error
Cause: The user attempted to add a workload statement that contains invalid SQL syntax or an invalid column reference.
Action: Validate the workload statement and retry the operation.
QSM-00773: the parameter string contains the invalid string name string
Cause: The task or workload parameter contains a name that is either too long or does not exist in the database.
Action: Validate the parameter value and retry the operation.
QSM-00774: there are no SQL statements to process for task string
Cause: While executing, the specified task found no valid SQL statements to analyze. Possible causes are: an empty workload, table filtering, or username filtering.
Action: Validate the workload and the appropriate task parameters and retry the operation.
QSM-00775: the specified SQL statement cannot be stored in the workload due to invalid table references
Cause: The user attempted to add a workload statement that contains one or more invalid identifier for the parsing user.
Action: Validate the workload statement and retry the operation.
QSM-00776: the user-defined workload string is missing the following column: string
Cause: The user attempted to import a workload from an external table; however, the table does not contain all of the required columns.
Action: Adjust the target workload table and retry the operation.
QSM-00777: the specified directive string is unsupported at this time
Cause: The user attempted to create a directive that is not currently supported.
Action: Check the advisor documentation for valid directives.
QSM-00778: the specified output filename string is invalid or cannot be accessed
Cause: The user attempted to create a report or script in a file that cannot be written or created.
Action: Adjust the file name or directory and retry the operation.
QSM-00779: the specified directive conflicts with the existing directive string
Cause: The user attempted to add a directive that cannot operate with an existing directive.
Action: Check the advisor documentation for valid directives.
QSM-00780: the task string could not be executed because the workload string is being modified
Cause: While attempting to execute a task, Access Advisor checks for exclusive access to all of the referenced workloads. If any cannot be reserved, then the execution fails.
Action: Wait until the referenced workloads are free for exclusive access retry the operation.
QSM-00781: the specified value string is invalid for parameter string. Valid keywords are string
Cause: The user attempted to set a task parameter using invalid data.
Action: Adjust the data value and retry the operation
QSM-00782: the specified value string is an invalid date format for parameter string
Cause: The user attempted to set a task parameter using invalid date formatting directives.
Action: See the Oracle documentation for valid date-formatting and retry the operation.
QSM-00783: the specified value string contains an invalid date for parameter string
Cause: The user attempted to set a task parameter using invalid date formatting.
Action: A date literal must be in the form DD/MM/YYYY HH24:MI:SS.
QSM-00784: the string string referenced in the list string is invalid for parameter string
Cause: The user attempted to set a task parameter using an invalid username or table specification.
Action: Validate the object name and retry the operation.
QSM-00785: the directive string is not supported for task string at this time
Cause: The user attempted to add an invalid directive to the current task.
Action: Validate the directive and retry the operation.
QSM-00786: the name string is invalid for directive string
Cause: The user attempted to add a directive that contains an empty or invalid object name.
Action: Correct the name and retry the operation.
QSM-00787: the tablespace string is invalid for directive string
Cause: The user attempted to add a directive that contains an empty or invalid tablespace name.
Action: Correct the name and retry the operation.
QSM-00788: the table string is invalid for directive string
Cause: The user attempted to add a directive that contains an empty or invalid table specification.
Action: Correct the name and retry the operation.
QSM-00789: the string string is invalid for directive string
Cause: The user attempted to add a directive that contains an empty or invalid attribute.
Action: Correct the value and retry the operation.
QSM-00790: the workload string cannot be modified or changed because it is being used by task string
Cause: The user attempted to change or delete a workload that is referenced by an active task.
Action: Remove references to a workload from any tasks that reference that workload, unless the task is in its initial task state.
QSM-00791: the specified SQL statement cannot be stored in the workload because is contains unsupported statement type
Cause: The user attempted to add a workload statement that contains an invalid statement type. Supported statement types are INSERT, DELETE, UPDATE, SELECT and MERGE.
Action: Validate the workload statement and retry the operation.
QSM-00792: the specified SQL statement cannot be stored in the workload because one or more tables have missing statistics
Cause: The user attempted to add a workload statement that contains a table without statistics. Access Advisor requires all referenced tables to have valid statistics.
Action: Validate the workload statement and retry the operation.
QSM-00793: the specified SQL Tuning Set string does not exist
Cause: The user specified a SQL Tuning Set that has not been defined in the SQL Tuning Set repository.
Action: Correct the SQL Tuning Set name and retry the operation.
QSM-00794: the statement can not be stored due a violation of the string filter
Cause: The user attempted to manually add a workload statement that failed a filter test. Manual statements must meet the same filtering guidelines as imported statements.
Action: Adjust the attributes or the filter and retry the operation.
QSM-00795: the SQL Tuning Set repository has not been implemented
Cause: The user attempted to collect a workload from a SQL Tuning Set repository that has not yet been implemented or enabled.
Action: Validate the existence of the repository and retry the operation.
QSM-00796: the specified SQL statement cannot be stored in the workload because table string does not have valid statistics
Cause: The user attempted to add a workload statement that references a table with missing statistics.
Action: Gather statistics for the referenced table and retry the operation.
QSM-00797: the specified workload string does not exist for the current user
Cause: The user attempted to reference an Access Advisor workload using a name that does not exist in the Advisor repository.
Action: Adjust the name and retry the operation.
QSM-00798: the specified workload string already exists
Cause: The user attempted to create the specified workload using a name that already exists in the Advisor repository. Task names must be unique to the database user.
Action: Adjust the name and retry the operation.
QSM-00799: the user-defined workload table string cannot be found
Cause: The user has attempted to import a workload from an external table that does not exist or cannot be accessed.
Action: Adjust the target workload table and retry the operation.
QSM-00800: the specified workload name string is invalid
Cause: The user has specified an invalid workload name.
Action: Adjust the target workload name and retry the operation.
QSM-00801: the specified username string is invalid
Cause: The user has specified an invalid username.
Action: Adjust the target username and retry the operation.
QSM-00802: An error occurred while implementing action string (string) string.
Cause: While performing IMPLEMENT_TASK, a specific action operation failed.
Action: Make the necessary adjustments as specified in the secondary message and retry the operation.
QSM-00803: The STORAGE_CHANGE parameter value string cannot be zero or negative for partial workloads.
Cause: While performing EXECUTE_TASK, the user specified a STORAGE_CHANGE value that is incompatible with the type of workload data.
Action: Set a positive STORAGE_CHANGE value.
QSM-00804: not enough space for mandatory access structures
Cause: While performing EXECUTE_TASK, the user specified a STORAGE_CHANGE value that leaves no space for mandatory access structures, such as primary key indexes.
Action: Set a greater STROAGE_CHANGE value.
QSM-00999: Advisor feature is not currently implemented
Cause: The user attempted to execute an unsupported advisor operation.
Action: Verify the availability of the operation.
QSM-01001: query rewrite not enabled
Cause: When query rewrite is disabled, no query rewrite will take place.
Action: Enable query rewrite with ALTER SESSION SET QUERY_REWRITE ENABLE command.
QSM-01002: no query rewrite when OPTIMIZER_MODE is rule based
Cause: Query rewrite did not occur because the OPTIMIZER_MODE was set to RULE.
Action: Change the optimizer mode using the OPTIMIZER_MODE parameter.
QSM-01003: no query rewrite on DDL queries
Cause: If query contains any data definition operations, no query rewrite will take place.
Action: none.
QSM-01004: no query rewrite before view merging
Cause: Internal session parameter _QUERY_REWRITE_2 is set to FALSE
Action: Change session parameter with ALTER SESSION command.
QSM-01005: no query rewrite when query has slave SQL
Cause: Current prcess is a kxfx slave
Action: none
QSM-01006: query rewrite disabled for this query block
Cause: During query rewrite, certain view query blocks cannot be rewritten.
Action: none
QSM-01007: query has NOREWRITE hint
Cause: When query contains a NOREWRITE hint, no query rewrite will take place for that query block.
Action: Remove the NOREWRITE hint from the query
QSM-01008: no query rewrite for update queries
Cause: If a query or part of it has any DML update operations, no query rewrite will take place.
Action: none
QSM-01009: materialized view, string, matched query text
Cause: The query was rewritten using a materialized view, because query text matched the definition of the materialized view
Action: none
QSM-01010: table(s) in the query not found in materialized view, string
Cause: If the materialized view does not reference the base tables found in the query, it cannot be used for rewrite
Action: none
QSM-01011: when heuristic rewrite not set, rewrite hint required
Cause: When using a stored outline, a rewrite hint is required for query rewrite
Action: none
QSM-01012: SAMPLE clause present in FROM
Cause: If a query contains a SAMPLE clause, query rewrite will not take place
Action: none
QSM-01013: nested aggregates or CONNECT BY/START WITH clause present
Cause: If the query contains nested aggregates, CONNECT BY clause, or START WITH clause, query rewrite will not take place
Action: none
QSM-01014: top level operator in WHERE clause of the query is an OR
Cause: If the top-level operator in the WHERE clause is an OR and there is more than one table in the FROM list, then query rewrite will not take place.
Action: none
QSM-01015: GROUP BY clause has non-columns
Cause: No query rewrite, if there is no valid column in the GROUP BY clause.
Action: none
QSM-01016: Query rewrite does not support, aggregate, string
Cause: No query rewrite, if the query contains any DISTINCT aggregates other than COUNT, MIN or MAX.
Action: none
QSM-01017: aggregate argument cannot be converted to canonical form
Cause: Argument of each aggregrate in the query needs to be convertible into a canonical form for query rewrite.
Action: none
QSM-01018: single table materialized join view rewrite not required
Cause: Materialized join view is more expensive for rewrite than using the base table
Action: none.
QSM-01019: no suitable materialized view found to rewrite this query
Cause: There doesn't exist any materialized view in the dataware house that can be used to rewrite this query.
Action: Consider creating a new materialized view.
QSM-01020: materialized view, string, is ineligible
Cause: Materialized view is probably disabled or stale.
Action: Consider enabling the materialized view for rewrite or refreshing it.
QSM-01021: materialized view, string, not found in the hint list
Cause: There is a rewrite hint list specified in the query, but this materialized view is not among the hinted ones.
Action: Include this materialized view in the rewrite hint list.
QSM-01022: a more optimal materialized view than string was used to rewrite
Cause: Query Rewrite always chooses the most optimal materialized view based on certain parameters, such as cardinality of the materialized view, number of joins etc. The materialized view specified was found to be less optimal.
Action: To force using a materialized view, consider using a rewrite hint.
QSM-01023: materialized view, string, has GRANT errors
Cause: Materialized view probably has some metadata errors.
Action: Consider recreating it.
QSM-01024: materialized view, string, has unknown compile errors
Cause: Materialized view probably has some metadata errors.
Action: Consider recreating it.
QSM-01025: materialized view, string, not found
Cause: The specified materialized view is not found in the database.
Action: Check the spelling or create a new materialized view
QSM-01026: query rewrite is disabled for, string
Cause: Query rewrite could not use this materialized view, because query rewrite was not enabled for it.
Action: Enable query rewrite for the materialized view with ALTER MATERIALIZED VIEW "mv" ENABLE QUERY REWRITE command, where "mv" is the name of the materializev view.
QSM-01027: materialized view, string, is unusable
Cause: Materialized view probably has some metadata errors.
Action: Consider recreating it.
QSM-01028: materialized view, string, is currently being refreshed
Cause: Materialized view cannot be used for query rewrite while it is being refreshed
Action: Rerun the query, after the refresh operation is completed.
QSM-01029: materialized view, string, is stale in ENFORCED integrity mode
Cause: A stale materialized view cannot be used for query rewrite when the query rewrite integrity mode is set to ENFORCED.
Action: Refresh the materialized view or alter the rewrite integrity mode with ALTER SESSION QUERY_REWRITE_INTEGRITY = STALE TOLERATED command.
QSM-01030: materialized view, string, has PL/SQL functions in ENFORCED integrity mode
Cause: A materialized view with PL/SQL functions in its definition cannot be used for query rewrite when query rewrite integrity is set to ENFORCED.
Action: Consider running the query in STALE TOLERATED mode.
QSM-01031: materialized view, string, is stale in TRUSTED integrity mode
Cause: A stale materialized view cannot be used for query rewrite when the query rewrite integrity mode is set to TRUSTED.
Action: Refresh the materialized view or alter the rewrite integrity mode with ALTER SESSION QUERY_REWRITE_INTEGRITY = STALE TOLERATED command.
QSM-01032: materialized view, string, not found
Cause: There was no associated metadata for the materialized view.
Action: Check the spelling and re-run the query.
QSM-01033: query rewritten with materialized view, string
Cause: The specified materialized view was used to rewrite the given query.
Action: none
QSM-01034: materialized view, string, needs a dimension level to join table, string
Cause: One or more hierarchical relationship(s) in the table(s) could not be established.
Action: Consider adding a level in the dimension to provide the missing intra- table relationships.
QSM-01035: a row level security policy exists on this table
Cause: Any row level security policy that may exist on a base-table prevents exact text match query rewrite.
Action: none.
QSM-01036: unmatched column, string, present in query after view merging
Cause: Clearing the columns after view merging failed due to some reasons - bug??
Action: none
QSM-01037: Query Rewrite failed to allocate the necessary query join graph
Cause: Join graph allocation and initialization failed, possibly due to one or more undetermined operand(s) in the query expression.
Action: none
QSM-01038: logical operator(s) could not be processed
Cause: One or more logical operator(s) in the query predicates could not be processed, possibly due to invalid operator(s).
Action: none
QSM-01039: selection present on right hand side of an outer join
Cause: Query cannot be rewritten if any predicate contains a selection on the right hand side of an outer join.
Action: none
QSM-01040: match between the materialized view (string) and query join graphs failed
Cause: Query rewrite will not take place if the joins in the query and the materialized view do not have any match.
Action: none
QSM-01041: materialized view, string, does not match with a measure in the query
Cause: If a measure (such as SUM, AVERAGE) in the query cannot be matched or computed from the materialized view, it will not be used for rewrite.
Action: none
QSM-01042: anchor and matching join arc check failed for string
Cause: If there is a lossy join in the materialized view that doesn't exist in the query, query rewrite will not take place.
Action: none
QSM-01043: join back attempted on a table to the RHS of a semi or anti join for string
Cause: Query Rewrite will not occur if a join back is required to a table that appears to the right hand side of a semi or anti-join.
Action: none
QSM-01044: join back attempted on a view for string
Cause: Query Rewrite will not occur if a join back to a table is required to find any missing columns.
Action: none
QSM-01046: complex join back on correlated columns not allowed (string)
Cause: Query Rewrite will not occur if a join back is required on a column that is referenced by a sub-query.
Action: none
QSM-01047: complex join back on non-MAV rewrite not allowed (string)
Cause: Query Rewrite can occur by means of a complex join back only during a MAV rewrite.
Action: none
QSM-01048: join back level(s) not present (string)
Cause: Query Rewrite requires joining back to a level of a dimension to find a missing information.
Action: Consider creating a dimension.
QSM-01049: semi-join check failed for materialized view, string
Cause: If there is a semi join in the query, then Query Rewrite will create (select distinct <pk-list>, <ref-col> from mjv) where <pk-list> is the list of rowids/pk of all mjv tables that don't correspond to a right side of a semi-join and <ref-col> are their columns. Query Rewrite will not occur if a join from the materialized view cannot match the semi-join from the query.
Action: none
QSM-01050: roll-up check failed for materialized view, string
Cause: A column in the query cannot be computed from the materialized view.
Action: Consider creating a dimension to supply the missing information
QSM-01051: no support for rollup when a window function is present on the column
Cause: No query rewrite if a window function is present on a column that requires a roll-up to compute a measure.
Action: none
QSM-01052: referential integrity constraint on table, string, not VALID in ENFORCED integrity mode
Cause: A join present in the materialized view requires validated primary/foreign key constraints in ENFORCED query rewrite integrity mode.
Action: Validate the constraint or change the integrity mode with ALTER SESSION SET QUERY_REWRITE_INTEGRITY = STALE_TOLERATED command.
QSM-01053: NORELY referential integrity constraint on table, string, in TRUSTED/STALE TOLERATED integrity mode
Cause: A join present in the materialized view requires RELY mode to be set on the primary/foreign key constraints.
Action: Set the RELY mode with ALTER TABLE <table> MODIFY CONSTRAINT <constraint> RELY command. Alternatively validate the constraint with ALTER TABLE <table> VALIDATE CONSTRAINT <constraint>.
QSM-01054: no join match between query and summary, string
Cause: There are no common joins between the query and the the materialized view
Action: none
QSM-01055: Query Rewrite failed to allocate the necessary materialized view join graph
Cause: Join graph allocation and initialization failed, possibly due to one or more undetermined operand(s).
Action: none
QSM-01056: no query rewrite for this DDL expression
Cause: Some SELECT statements which are part of a DDL expression may be eligible for rewrite. These include CREATE AS SELECT and CREATE OUTLINE statements. The given query expression is a DDL expression, which doesn't fall in this category.
Action: none
QSM-01057: no query rewrite for this DML expression
Cause: Current DML is being done using an updatable view, so it is not eligible for rewrite.
Action: none
QSM-01058: MV, string, does not have column, string, for a joinback
Cause: A GROUP BY column in the query is not present in the GROUP BY clause of of the materialized view. This usually requires a join back to a third table.
Action: none
QSM-01059: HAVING clause in the query block is malformed
Cause: An illegal HAVING clause has been specified in the query.
Action: Correct the query syntax and run the query again.
QSM-01060: illegal subquery in the HAVING clause
Cause: When a HAVING clause has a subquery, then any references to the tables in the outer query should only reference the tables in the GROUP BY clause.
Action: Correct error in the syntax and rerun the query.
QSM-01061: illegal query expression
Cause: An illegal query was specified. Specifically one of the following criteria was not satisfied: (a) All (non-constant, non-aggregate) SELECT expressions in the query should be made up of group expressions. (b) All column references in the HAVING clause should come from the GROUP BY expressions. (c) If there is an ORDER BY clause, then all column references should come from the GROUP BY or SELECT clause, depending on whether the query selects DISTINCT.
Action: Correct error in the syntax and rerun the query.
QSM-01062: query has one or more manual partition(s)
Cause: Query rewrite is not possible if query has any manual partitions.
Action: none
QSM-01063: query has a dictionary table or view
Cause: Query rewrite is not allowed if query references any dictionary tables/views.
Action: none
QSM-01064: query has a fixed table or view
Cause: Query rewrite is not allowed if query references any fixed tables/views
Action: none
QSM-01065: materialized view, string, cannot compute measure, string, in the query
Cause: If the materialized view cannot compute a measure in the query using the measures in its definition, then query rewrite will not occur.
Action: none
QSM-01066: materialized view, string, does not have the column, string, from query
Cause: Query rewrite will not occur, if the materialized view cannot provide all the columns that the query has
Action: none
QSM-01067: materialized view, string, cannot support the query measure, string
Cause: An attempt was made to push a grouping function through an expression specified in the query to transform a measure. Query rewrite will not occur if this measure transformation failed.
Action: none
QSM-01068: no dimensions present
Cause: An attempt was made to load a dimension from the dataware house, but there were no dimensions present.
Action: none
QSM-01069: summary join graph for, string, does not have table, string
Cause: An attempt to locate an object that is part of a join failed.
Action: none
QSM-01070: equivalence class manager was not found
Cause: An equivalence class manager is required to compute the transitive closure for the columns in an equivalence class.
Action: none
QSM-01071: a lossy join in materialized view, string, from table, string, not found in query
Cause: All lossy joins in the materialized view must be present in the query for query rewrite to occur.
Action: none
QSM-01072: materialized view, string, and query have different joins between tables, string
Cause: Anchors, if any, in the MV and query match. But the joins between these anchors in the MV and query are different.
Action: none
QSM-01073: materialized view, string, has a join not found in query
Cause: Query rewrite may not be possible if the materialized view has some joins that query does not have
Action: none
QSM-01074: materialized view, string, and query have different no of joins between tables, string
Cause: Query rewrite may not be possible if the query has some joins that the materialized view does not have between the same pair of tables.
Action: none
QSM-01075: materialized view, string, does not support aggregate function, string
Cause: The specified aggregate function is not found in the materialized view.
Action: none
QSM-01076: no materialized join view was found
Cause: To support an MJV rewrite, we require a materialized join view.
Action: none
QSM-01077: materialized view, string, is grouping at a higher level than query
Cause: If a query column, which is not present in the materialized view, can be obtained by a rollup within the materialized view, then it should group at a higher level than the materialized view.
Action: none
QSM-01078: materialized view, string, is marked invalid
Cause: The materialized view's kglobsta field has KGLSINV bit set.
Action: none ??
QSM-01079: DML operation occurred on a table referenced by MV, string
Cause: If any dependent tables of a materialized view undergoes a DML operation, query rewrite may be restricted depending on the query rewrite integrity mode for the session. In this situation, query rewrite will take place only if the rewrite integrity mode is STALE_TOLERATED.
Action: Consider refreshing the materialized view chaning the rewrite integrity mode to STALE_TOLERATED.
QSM-01080: invalid dimension, string
Cause: This dimension table has authorization or compilation problems.
Action: none
QSM-01081: no primary key or row id found for table, string, in MV, string
Cause: In order to obtain a missing column, the materialized view needs to join back to the above table. But it lacks the primary key or rowid for the table.
Action: none
QSM-01082: Joining materialized view, string, with table, string, not possible
Cause: A column in the query is not found in the summary. To obtain the column, a join back of materialized view to the table by means of either the primary key, foreign key or rowid of the table is required. The specified materialized view does not have the primary key, foreign key or rowid of the table to perform the join operation.
Action: Consider building a dimension-table to provide the missing information.
QSM-01083: query text not available - possible inline view
Cause: During the query rewrite transformation, orignal query was possibly transformed into an inline view.
Action: none
QSM-01084: materialized view, string, has anchor, string, not found in query
Cause: A table in a materialized view is an anchor, (a) if it is not joined to any other table or (b) joined to other tables but each of its joins is either lossy or lossless with the above table being child-side table. If an anchor which is present in the materialized view is not found in the query, then query rewrite will not take place.
Action: none
QSM-01085: materialized view, string, has a lossy join between tables, string
Cause: There are no primary key, foreign key constraints between these tables. But query rewrite is still possible if the lossy join between the above tables also appear in the query
Action: none
QSM-01086: dimension(s) not present or not used in ENFORCED integrity mode
Cause: Query rewrite does not use dimensions in ENFORCED query rewrite integrity mode. If a suitable dimension is present, consider chaning the current integrity mode to either TRUSTED or STALE_ TOLERATED by using ALTER SESSION SET QUERY_REWRITE_INTEGRITY = command.
Action: none
QSM-01087: query grouping on a column that cannot be derived from materialized view, string
Cause: Query is grouping on undetermined columns.
Action: none
QSM-01089: an inline view in the query does not have a materialized view
Cause: General query rewrite is not possible if an inline view in the query does not have a matching materialized view in the meta data.
Action: none
QSM-01090: no query rewrite after view merging
Cause: Internal session parameter _QUERY_REWRITE_1 is set to FALSE
Action: Change session parameter with ALTER SESSION command.
QSM-01091: cost based optimizer found query rewrite is more expensive
Cause: When cost based optimizer is ON, cost of the rewritten cursor is compared to the cursor generated without query rewrite, and the cheaper one is chosen for execution.
Action: none
QSM-01092: mjv tries to rewrite a semi-join and primary key or rowid missing
Cause: Materialized join view tries to rewrite a semi-join (IN sub-query) and the primary keys or rowids of left tables of semi-joins are missing from MJV.
Action: none
QSM-01093: anti-join marker not found in materialized join view
Cause: Materialized join view has outer join while the query inner join. For rewrite to succeed MV must have an anti-join marker like the rowid or primary key of the right tables of outer join
Action: none
QSM-01094: outer-join filter not found in materialized join view
Cause: Materialized join view has outer join while the query inner join. For rewrite to succeed MV must have an anti-join marker like the rowid or primary key of the right tables of outer join
Action: none
QSM-01095: no suitable grouping_id found in MV with grouping sets
Cause: If materialized aggregate view contains grouping sets, then it also must contain the grouping_id() function. This function must contain all columns in the MV GROUP BY.
Action: none
QSM-01096: Materialized view with grouping sets contains duplicates
Cause: Materialized view with grouping sets contains duplicates and no rewrite is supported for it. For example, GROUP BY GROUPING SET ((a), (a)) is not supported for rewrite.
Action: none
QSM-01097: Materialized view with grouping sets has too long key
Cause: Materialized view with grouping sets has more that 64 different keys in its GROUP BY. No rewrite is supported then.
Action: none
QSM-01098: mv string clause more restrictive than query string clause
Cause: The materialized view contains a selection condition in the WHERE or HAVING clause that is more restrictive than the corresponding selection condition in the request query.
Action: Change the selection criteria in the request query to be at least as restrictive as the selection criteria in the materialized view, or drop and recreate the materialized view using less restrictive selection criteria.
QSM-01099: non-tolerated reference to stale portion of mv for table string
Cause: The materialized view is partially stale. It is stale with respect to one or more partitions in one or more of its detail tables. The request query references one or more such detail partitions.
Action: (1) Change the selection criteria of the request to restrict the query to only the fresh portion of the materialized view, or (2) ALTER {SYSTEM|SESSION} QUERY_REWRITE_INTEGRITY = STALE_TOLERATED or (3) refresh the materialized view.
QSM-01100: containment check failed for mv, string
Cause: The materialized view contains a selection condition in the WHERE or HAVING clause that is more restrictive than the corresponding selection condition in the request query.
Action: Change the selection criteria in the request query to be at least as restrictive as the selection criteria in the materialized view, or drop and recreate the materialized view using less restrictive selection criteria.
QSM-01101: rollup(s) took place on mv, string
Cause: If query's GROUP BY has one of the higher levels of columns found in the materialized view, then the lower level columns in the materialized view will be rolled up to compute the desired results.
Action: none
QSM-01102: materialized view, string, requires join back to table, string, on column, string
Cause: A column in the query does not appear in the materialized view. Query rewrite will try to obtain this column from the base table, by doing a join back to that column with the MV.
Action: none
QSM-01103: there is a remote table, string, referenced in the query
Cause: Query rewrite does not support query with remote tables.
Action: none
QSM-01104: query is using flashback
Cause: Query rewrite does not support flashback.
Action: none
QSM-01105: no primary key or row id in MV, string, is found for table, string
Cause: In order to obtain a missing column, the materialized view needs to join back to the above table. But it lacks the primary key or rowid for the table.
Action: none
QSM-01106: MV, string, is stale with respect to some partition(s) in the base table(s)
Cause: Query is requesting some data from the MV that are stale with respect to some partitions in the base tables due to some updates.
Action: refresh the stale partitions and rerun the query
QSM-01107: Partition Containment Tracking (PCT) rewrite is not allowed
Cause: Query rewrite is disabled for PCT through a session parameter
Action: none
QSM-01108: maximum number of disjuncts exceeded in the query string
Cause: Query rewrite engine cannot process the query if the number of disjuncts (OR's)in the WHERE clause exceeds the maximum allowed number. The number of disjuncts in the query and the maximum allowed disjuncts are given at the end of the message in the form of (no of disjuncts in query, maximum disjuncts allowed).
Action: none
QSM-01109: while rewriting with MV, string, table, string, migrated to query delta
Cause: There was an unmatched join on the MV, so a table involved in the join was pushed to the query delta to see if the query can be rewritten
Action: none
QSM-01110: a lossy join in MV, string, between tables, string, not found in query
Cause: All lossy joins in the materialized view must be present in the query for query rewrite to occur.
Action: none
QSM-01111: no partition key or partition marker found in MV, string
Cause: In order to do query rewrite with fresh partitions of an MV, the MV should have a partiton key or partition marker.
Action: none
QSM-01112: WHERE clause of mv, string, is more restrictive than query
Cause: The materialized view contains a selection condition in the WHERE clause that is more restrictive than the corresponding selection condition in the request query.
Action: Change the selection criteria in the request query to be at least as restrictive as the selection criteria in the materialized view, or drop and recreate the materialized view using less restrictive selection criteria.
QSM-01113: HAVING clause of mv, string, is more restrictive than query
Cause: The materialized view contains a selection condition in the HAVING clause that is more restrictive than the corresponding selection condition in the request query.
Action: Change the selection criteria in the request query to be at least as restrictive as the selection criteria in the materialized view, or drop and recreate the materialized view using less restrictive selection criteria.
QSM-01115: rollup took place on a column with a window function
Cause: There was a rollup to aggregate the data on a column with a window function.
Action: none
QSM-01116: window function computability checks failed
Cause: The window function in the query could not be computed from the materialized view.
Action: none
QSM-01120: recursive rewrite not allowed here
Cause: This query was possibly rewritten with an equivalence which doesn't allow further rewrites.
Action: none
QSM-01121: materialized view, string, is TRUSTED in ENFORCED integrity mode
Cause: A stale materialized view created with USING TRUSTED CONSTRAINTS clause cannot be used when the query rewrite integrity mode is set ENFORCED.
Action: Alter materialized view such that it has the ENFORCED CONSTRAINTS ALTER MATERIALIZED VIEW <mv> REFRESH USING ENFORCED CONSTRAINTS
QSM-01123: self-join algorithm could not resolve multiple instances
Cause: The generalized self-join algorithm could not resolve the mutliple instances, likely due to mismatch in joins or measures
Action: Consider using aliases in the query to match with the aliases in the materialized view
QSM-01124: set operator materialized view, string, doesn't have a marker column
Cause: The specified set operator materialized view does not have a marker column.
Action: Add a marker column to the specified materialized view.
QSM-01125: a more optimal set operator materialized view than string was used to rewrite
Cause: Query Rewrite always chooses the most optimal set operator materialized view based on parameters, such as cardinality of the set operator materialized view, number of branches that the set operator materialized view can rewrite etc. The set operator materialized view specified was found to be less optimal.
Action: To force using a set operator materialized view, consider using a rewrite hint.
QSM-01126: query rewritten with set operator materialized view, string
Cause: The specified set operator materialized view was used to rewrite the given query.
Action: none
QSM-01127: query rewritten with multiple MVs
Cause: The query was succesfully rewritten with multiple MVs
Action: none
QSM-01128: Multi MV rewrite is disabled
Cause: When multimv query rewrite is disabled, no multimv query rewrite will take place.
Action: Enable multimv query rewrite with ALTER SESSION SET "_MULTIMV_QUERY_REWRITE_ENABLED" = true .
QSM-01129: query has NO_MULTIMV_REWRITE hint
Cause: WHen the query has this hint no multimv rewrite will be tried for this query
Action: Remove hint from query
QSM-01130: Multi MV rewrite not allowed if at least one query block has no MVs
Cause: When only multimv query rewrite is enabled, every query block should have at least one MV in it's from clause
Action: Disable only multimv query rewrite with ALTER SESSION SET "_ONLY_MULTIMV_QUERY_REWRITE_ENABLED" = false .
QSM-01131: query has ONLY_MULTIMV_REWRITE hint
Cause: WHen the query has this hint no multimv rewrite will be done if the query has a query block with no MVs in the from clause
Action: Remove hint from query
QSM-01509: equivalence, string, matched query text
Cause: The query was rewritten using an equivalence, because query text matched the source statement for this equivalence.
Action: none
QSM-01522: a more optimal equivlanece than string was used to rewrite
Cause: Query Rewrite always chooses the most optimal equivalence based on certain parameters, such as cardinality of the equivalence, number of joins etc. The equivalence view specified was found to be less optimal.
Action: none
QSM-01526: query rewrite is disabled for equivalence, string
Cause: Query rewrite could not use this equivalence, because this equivalence was created as disabled.
Action: Enable this equivalence using alter_rewrite_equivalence procedure from package, dbms_advanced_rewrite.
QSM-01533: query rewritten with equivalence, string
Cause: The specified equivalence was used to rewrite the given query.
Action: none
QSM-01565: equivalence, string, cannot compute measure, string, in the query
Cause: If a measure in the query cannot be computed using the measures in the equivalence, then query rewrite will not occur.
Action: none
QSM-01567: equivalence, string, cannot support the query measure, string
Cause: An attempt was made to push a grouping function through an expression specified in the query to transform a measure. Query rewrite will not occur if this measure transformation failed.
Action: none
QSM-01572: equivalence, string, and query have different joins between tables, string
Cause: Anchors, if any, in the equivalenceand query match. But the joins between these anchors in the equivalence and query are different.
Action: none
QSM-01582: Joining equivalence, string, with table, string, not possible
Cause: A column in the query is not found in the equivalence. To obtain the column, a join back of equivalence to the table by means of either the primary key, foreign key or rowid of the table is required. But join backs are not allowed for equivalence rewrite
Action: none
QSM-01584: equivalence, string, has anchor, string, not found in query
Cause: If an anchor which is present in the equivalence is not found in the query, then query rewrite will not take place.
Action: none
QSM-01601: rollup(s) took place on equivalence, string
Cause: If query's GROUP BY has one of the higher levels of columns found in the equivalence, then the lower level columns in the equivalence will be rolled up to compute the desired results.
Action: none
QSM-01602: equivalence, string, requires join back to table, string, on column, string
Cause: A column in the query does not appear in the equivalence. Query rewrite will try to obtain this column from the base table, by doing a join back to that column with a materialized view. But join backs are not allowed for equivalence rewrite as the required constraints are not guaranteed to be found on the tables in the destination statement of the equivalence.
Action: none
QSM-01610: a lossy join in equivalence, string, between tables, string, not found in query
Cause: All lossy joins in the equivalence must be present in the query for query rewrite to occur.
Action: none
QSM-01617: equivalence definition is disabled
Cause: There is an equivalence defition that could have been probably used by query rewrite to rewrite the query. But this equivalence is disabled.
Action: none
QSM-01618: equivalence, string, is enabled for text match rewrite only
Cause: This equivalence was created for text match rewrite only
Action: none
QSM-01619: equivalence cannot be used in ENFORCED integrity mode
Cause: An equivalence cannot be used for query rewrite when the query rewrite integrity mode is set to ENFORCED.
Action: none
QSM-01621: join backs to base tables not allowed with an equivalence
Cause: Query rewrite needs to do a join back to a base table column to answer this query. But join back is not allowed for an equivalence rewrite
Action: none
QSM-02001: clustered mv container table
Cause: The capability in question is not supported on a materialized view that has a clustered container table.
Action: Recreate the materialized view using a conventional container table.
QSM-02002: DISTINCT aggregate measure in SELECT list
Cause: The capability in question is not supported when the materialized view uses the DISTINCT qualifier on an aggregate function.
Action: Remove the DISTINCT qualifier.
QSM-02003: aggregate function nested within an expression
Cause: The capability in question is not supported when the materialized view contains an aggregate function invocation nested within an outer expression.
Action: Re-phrase the expression such that the aggregate function invocation is not nested.
QSM-02004: grouping column omitted from SELECT list
Cause: The capability in question is not supported when the materialized view contains a column or expression in the GROUP BY clause that is not also present in the list of output select expressions.
Action: Include all GROUP BY expressions in the output select list.
QSM-02005: named view in FROM list
Cause: The capability in question is not supported when a named view appears in the FROM list.
Action: Remove the named view from the FROM list.
QSM-02006: subquery in FROM list
Cause: The capability in question is not supported when a subquery appears in the FROM list.
Action: Remove the subquery from the FROM list.
QSM-02007: multiple instances of the same table or view
Cause: The capability in question is not supported when the same table or view occurs more than once in the FROM list.
Action: Re-phrase the query to avoid multiple instances of the same table. For instance,
QSM-02008: non-join filter condition in WHERE or HAVING clause
Cause: The capability in question is not supported when the materialized view has a selection condition (an expression not representing a join) in the WHERE or HAVING clauses.
Action: Remove the selection filter expression.
QSM-02009: non-inner join
Cause: The capability in question is only supported with inner joins.
Action: Re-phrase the query using an inner join. Remove any outer joins.
QSM-02010: join predicate with operator other than equals (=)
Cause: The capability in question is not supported when the materialized uses a relationship operator other than equals ("=") in a join in the WHERE clause. This is known as a non-equijoin.
Action: Re-phrase the query to avoid the non-equijoin.
QSM-02011: a HAVING clause is present
Cause: The capability in question is not supported when the materialized view uses a HAVING clause.
Action: Remove the HAVING clause.
QSM-02012: a CONNECT BY clause is present
Cause: The capability in question is not supported when the materialized view uses a CONNECT BY clause.
Action: Re-phrase the query to avoid use of the CONNECT BY clause.
QSM-02013: SELECT list includes a RAW data type expression
Cause: The capability in question is not supported when the materialized view uses RAW data type in an expression.
Action: Remove the reference to the RAW expression.
QSM-02014: GROUP BY expression other than a column
Cause: The capability in question is not supported when the materialized view uses an expression other than a simple column reference in the GROUP BY clause.
Action: Re-phrase the query to use only simple column expressions in the GROUP BY clause.
QSM-02015: Index Organized Table (IOT) present in FROM list
Cause: The capability in question is not supported when the materialized view references an Index Organized Table in the FROM list.
Action: Remove the reference to the Index Organized Table.
QSM-02016: clustered table in FROM list
Cause: The capability in question is not supported when the materialized view references a clustered table in the FROM list.
Action: Remove the reference to the clustered table in the FROM list.
QSM-02017: subquery present in the HAVING clause
Cause: The capability in question is not supported when the materialized view uses a subquery in the HAVING clause.
Action: Re-phrase the query to avoid the subquery in the HAVING clause.
QSM-02018: subquery present in the WHERE clause
Cause: The capability in question is not supported when the materialized view uses a subquery in the WHERE clause.
Action: Re-phrase the query to avoid the subquery in the WHERE clause.
QSM-02019: mv references another mv in FROM clause
Cause: The capability in question is not supported when the materialized view is nested (i.e., when it references another materialized view in its FROM list).
Action: Re-phrase the query to avoid reference to the other materialized view.
QSM-02020: container column not in SELECT list with NOT NULL constraint
Cause: The capability in question is not supported when the materialized view's container table has a column that does not correspond to an output expression in the select list, and that column has a NOT NULL constraint. This situation can result in problems during refresh since any new rows inserted into the materialized view will set that column to NULL.
Action: Disable or remove the NOT NULL constraint.
QSM-02021: set operator encountered in mv
Cause: The capability in question is not supported when the materialized view uses set operators such as UNION, UNION ALL, MINUS, etc.
Action: Re-phrase the query to avoid the use of set operators.
QSM-02022: aggregate selections
Cause: The capability in question is not supported when the materialized view uses an aggregate expression in the HAVING clause.
Action: Re-phrase the query to avoid the use of an aggregate in the HAVING clause.
QSM-02023: nested cursor
Cause: The capability in question is not supported when the materialized view uses a nested cursor expression.
Action: Re-phrase the query to avoid use of a nested cursor expression.
QSM-02024: no GROUP BY clause
Cause: The capability in question is not supported when the materialized view does not use a GROUP BY clause.
Action: Re-phrase the query to use a GROUP BY clause.
QSM-02025: no aggregate functions
Cause: The capability in question is not supported when the materialized view uses no aggregate functions.
Action: Re-phrase the query to use aggregate functions.
QSM-02026: non-AND conjunction in WHERE clause
Cause: The capability in question is not supported when the materialized view uses a conjunction other than AND (such as OR) in the WHERE clause.
Action: Re-phrase the query to avoid use of the non-AND conjunction.
QSM-02027: group by ROLLUP
Cause: The capability in question is not supported when the materialized view uses the ROLLUP operator in the GROUP BY clause.
Action: Re-phrase the query to avoid use of the ROLLUP operator.
QSM-02028: group by CUBE
Cause: The capability in question is not supported when the materialized view uses the CUBE operator in the GROUP BY clause.
Action: Re-phrase the query to avoid use of the CUBE operator.
QSM-02029: PL/SQL function invocation
Cause: The capability in question is not supported when the materialized view invokes a PL/SQL function.
Action: Re-phrase the query to avoid use of PL/SQL functions.
QSM-02030: reduced precision specified for prebuilt mv
Cause: The capability in question is not supported when the materialized view is created with the WITH REDUCED PRECISION clause.
Action: DROP the materialized view and re-create it without using the WITH REDUCED PRECISION clause.
QSM-02031: materialized view cannot support any type of query rewrite
Cause: of the problem.
Action: Examine the other messages and documentation to determine the
QSM-02032: no joins are present in the WHERE clause
Cause: The capability in question is not supported when the materialized view includes no join conditions in the WHERE clause.
Action: Re-phrase the query to include a join.
QSM-02033: no filter conditions are present in the WHERE clause
Cause: The capability in question is not supported when the materialized view includes no filter selection conditions in the WHERE clause.
Action: Add a filter condition.
QSM-02034: no joins are present in the HAVING clause
Cause: The capability in question is not supported when the materialized view includes no joins in the HAVING clause.
Action: Re-phrase the query to include a join.
QSM-02035: no filter conditions are present in the HAVING clause
Cause: The capability in question is not supported when the materialized view includes no filter condition in the HAVING clause.
Action: Re-phrase the query to include a join.
QSM-02036: in-list present in mv
Cause: The capability in question is not supported when the materialized view uses an IN list.
Action: Re-phrase the query to avoid the use of IN lists.
QSM-02037: cannot evaluate constant expression at compile time
Cause: The capability in question is not supported when the materialized view uses a compile-time non-constant expression in a filter condition in the WHERE or HAVING clauses. For example, WHERE X=1 uses a compile-time constant expression in a filter condition. WHERE X=MY_PLSQL_FUNCTION() uses a compile-time non-constant expression in a filter condition.
Action: Re-phrase the query to avoid the use of a compile-time non-constant expressions in filter conditions.
QSM-02038: Partition Change Tracking (PCT) is enabled
Cause: The Partition Change Tracking (PCT) capability is supported for this materialized view.
Action: No action is needed.
QSM-02039: top level mv query uses grouping sets
Cause: The capability in question is not supported when the materialized view use grouping sets.
Action: Re-phrase the query to avoid use of grouping sets.
QSM-02040: top level query contains GSets and the key is too long for rewrite
Cause: The capability in question is not supported when the materialized view uses a grouping set with too many keys.
Action: Reduce the number of grouping set keys.
QSM-02041: nested aggregate function
Cause: The capability in question is not supported when the materialized view nests an aggregate function invocation as an argument to another aggregate function.
Action: Re-phrase the query to avoid the nested aggregate function invocation.
QSM-02042: view or subquery in from list
Cause: The capability in question is not supported when the materialized view references a view or subquery in the FROM list.
Action: Re-phrase the query to avoid the use of views or subqueries in in the FROM list.
QSM-02044: ORDER BY clause in mv
Cause: The capability in question is not supported when the materialized view includes an ORDER BY clause.
Action: Remove the ORDER BY clause.
QSM-02045: START WITH clause in mv
Cause: The capability in question is not supported when the materialized view includes a START WITH clause.
Action: Re-phrase the query to avoid the use of the START WITH clause.
QSM-02047: window function in mv
Cause: The capability in question is not supported when the materialized view uses a window function.
Action: Re-phrase the query to avoid the use of window functions.
QSM-02048: outer join in mv
Cause: The capability in question is not supported when the materialized view uses an outer join.
Action: Re-phrase the query to avoid the use of outer joins.
QSM-02049: subquery using the ANY clause in mv
Cause: The capability in question is not supported when the materialized view uses the ANY clause with a subquery.
Action: Re-phrase the query to avoid the use of the ANY clause.
QSM-02050: subquery using the ALL clause in mv
Cause: The capability in question is not supported when the materialized view uses the ALL clause with a subquery.
Action: Re-phrase the query to avoid the use of the ALL clause.
QSM-02051: subquery using the NOT EXISTS clause in mv
Cause: The capability in question is not supported when the materialized view uses the NOT EXISTS with a subquery.
Action: Re-phrase the query to avoid the use of the NOT EXITS clause.
QSM-02052: subquery using a select list in mv
Cause: The capability in question is not supported when the materialized view uses a select list.
Action: Re-phrase the query to avoid the use of a select list.
QSM-02053: collection subquery in mv
Cause: The capability in question is not supported when the materialized view uses a collection subquery.
Action: Re-phrase the query to avoid the use of collection subqueries.
QSM-02054: DISTINCT clause in select list in mv
Cause: The capability in question is not supported when the materialized view uses the DISTINCT clause in the select list.
Action: Re-phrase the query to avoid the use of the DISTINCT clause.
QSM-02055: mv references a packed object table or view
Cause: The capability in question is not supported when the materialized view references a packed object table or view.
Action: Re-phrase the query to avoid the use of the packed object tables or views.
QSM-02056: correlated variable and outer join in mv
Cause: The capability in question is not supported when the materialized view uses a correlated variable and an outer join.
Action: Re-phrase the query to avoid the use of the correlated variables or outer joins.
QSM-02057: ROWNUM referenced in mv
Cause: The capability in question is not supported when the materialized view references the ROWNUM function.
Action: Re-phrase the query to avoid the use of the ROWNUM function.
QSM-02058: set operator in mv and compatibility mode is less than 9.0
Cause: The capability in question is not supported when the materialized view uses a set operator and the compatibility mode is less than 9.0.
Action: Re-phrase the query to avoid the use of set operators or set the compatibility mode to 9.0 or greater.
QSM-02059: join may produce duplicate rows in mv
Cause: The capability in question is not supported when the materialized view contains a join condition that can result in duplicate rows in the materialized view.
Action: Re-phrase the query to avoid the occurrence of duplicate rows in the materialized view.
QSM-02061: one or more joins present in mv
Cause: The capability in question is not supported when the materialized view contains joins.
Action: Re-phrase the query to avoid the use of the joins.
QSM-02062: GROUP BY clause in mv
Cause: The capability in question is not supported when the materialized view uses the GROUP BY clause.
Action: Re-phrase the query to avoid the use of the GROUP BY clause.
QSM-02063: aggregate function in mv
Cause: The capability in question is not supported when the materialized view uses an aggregate function.
Action: Re-phrase the query to avoid the use of the aggregate functions.
QSM-02064: subquery in mv
Cause: The capability in question is not supported when the materialized view uses a subquery.
Action: Re-phrase the query to avoid the use of the subqueries.
QSM-02066: Oracle error: see RELATED_NUM and RELATED_TEXT for details
Cause: The capability in question is not supported because an attempt to create the materialized view would result in an error.
Action: Examine the associated Oracle error code in the RELATED_NUM column and the Oracle error text in the RELATED_TEXT column and address the problem.
QSM-02067: no partition key or PMARKER or join dependent expression in select list
Cause: The capability in question is not supported when the materialized view unless the select list (and group by list if a GROUP BY clause is present) includes the partition key or PMARKER function reference to the table in question or an expression join dependent on the partitioning column of the table in question.
Action: Add the partition key or a PMARKER function reference or a join dependent expression to the select list (and the GROUP BY clause, if present).
QSM-02068: relation is not a partitioned table
Cause: The capability in question is not supported when the relation in question is not a partitioned table.
Action: Change the query to reference a partitioned table.
QSM-02069: PCT not supported with multi-column partition key
Cause: The capability in question is not supported when the table in is partitioned on a multi-column key.
Action: Re-phrase the query to reference a table partitioned on a single column key.
QSM-02070: PCT not supported with this type of partitioning
Cause: The capability in question is not supported when the table in question uses certain types of partitioning.
Action: Re-phrase the query to reference a table that is uses a type of partitioning that is supported for this capability.
QSM-02071: internal error: undefined PCT failure code
Cause: An internal Oracle error has occurred.
Action: Report the problem through your normal support channels.
QSM-02072: requirements not satisfied for fast refresh of nested mv
Cause: The capability in question is not supported because one or more of the requirements for this capability have not been satisfied.
Action: Examine the relevant nested materialized view documentation in the Warehouse Guide and address the problem.
QSM-02073: non-primary key RepAPI mv is not fast refreshable
Cause: Fast refresh is supported for RepAPI materialized views only if it is also a primary key materialized view.
Action: Re-design the materialized view to be a primary key materialized view.
QSM-02074: materialized view over Heterogeneous Services link
Cause: The capability in question is not supported when the materialized view uses a heterogeneous link.
Action: Re-design the materialized view to avoid the use of the heterogeneous links.
QSM-02075: materialized view on synonym
Cause: The capability in question is not supported when the materialized view references a synonym.
Action: Re-phrase the query to avoid the use of the synonyms.
QSM-02076: sequence number in the mv log is newer than last refresh
Cause: The timestamp of the sequence number in the mv log was after the last refresh time.
Action: A complete refresh is required before the next fast refresh.
QSM-02077: mv log is newer than last full refresh
Cause: The capability in question is not supported when the relevant materialized view log was created after the creation or most recent complete refresh of the materialized view.
Action: Perform a complete refresh of the materialized view.
QSM-02078: mv log must have new values
Cause: The capability in question is not supported when the relevant materialized view log omits new values.
Action: Re-create the materialized view log using the NEW VALUES clause.
QSM-02079: mv log must have ROWID
Cause: The capability in question is not supported when the relevant materialized view log omits ROWIDs.
Action: Re-create the materialized view log using the ROWID clause.
QSM-02080: mv log must have primary key
Cause: The capability in question is not supported when the relevant materialized view log omits primary keys.
Action: Re-create the materialized view log using the PRIMARY KEY clause.
QSM-02081: mv log does not have all necessary columns
Cause: The capability in question is not supported when the relevant materialized view log omits columns referenced in the select list of the materialized view.
Action: Re-create the materialized view log and include all columns referenced in the select list.
QSM-02082: problem with mv log
Cause: The capability in question is not supported because of a problem the materialized view log in question.
Action: Examine the relevant materialized view log and fast refresh
QSM-02083: mv references PL/SQL function that maintains state
Cause: The capability in question is not supported when the materialized view references a PL/SQL function that maintains state and which may not return the same value every time it is invoked against the same set of rows.
Action: Re-phrase the query to avoid such a PL/SQL function. Or modify the PL/SQL function to avoid state maintenance and change its declaration accordingly.
QSM-02084: DISTINCT clause on a duplicate sensitive aggregate function
Cause: The capability in question is not supported when the materialized view uses the DISTINCT clause in this context.
Action: Re-phrase the query to avoid the use of the DISTINCT clause.
QSM-02086: mv uses the MIN or MAX aggregate functions
Cause: The capability in question is not supported when the materialized view uses the MIN or MAX function.
Action: Re-phrase the query to avoid the use of the MIN or MAX functions.
QSM-02088: mv omits at least one grouping key from the select list
Cause: The capability in question is not supported when the materialized view omits any grouping expressions from the select list.
Action: Include all GROUP BY expressions in the select list.
QSM-02090: SELECT includes an expression that is not just a column
Cause: The capability in question is not supported when the materialized view uses an expression in the select list that is not a simple column reference.
Action: Re-phrase the query to avoid the use of the expressions that are not simple column references.
QSM-02091: mv references a non-repeatable or session-sensitive expression
Cause: The capability in question is not supported when the materialized view uses an expression that may not return the same value each time it is invoked against the same set of rows or that may return different values depending on session parameters.
Action: Re-phrase the query to avoid the use of such expressions.
QSM-02092: mv references a sequence number
Cause: The capability in question is not supported when the materialized view references a sequence number.
Action: Re-phrase the query to avoid the reference to sequence numbers.
QSM-02093: mv uses an object REF clause
Cause: The capability in question is not supported when the materialized view uses an object REF clause.
Action: Re-phrase the query to avoid the use of an object REF clause.
QSM-02096: mv references a named view
Cause: The capability in question is not supported when the materialized view references a view.
Action: Re-phrase the query to avoid references to views.
QSM-02099: mv references a remote table or view in the FROM list
Cause: The capability in question is not supported when the materialized view references a remote table or view in the FROM list.
Action: Re-phrase the query to avoid references to remote tables or views.
QSM-02101: mv references a synonym in the FROM list
Cause: The capability in question is not supported when the materialized view references a synonym in the FROM list.
Action: Re-phrase the query to avoid the reference to the synonym.
QSM-02102: mv FROM list references an object in the SYS schema
Cause: The capability in question is not supported when the materialized view references an object in the SYS schema.
Action: Re-phrase the query to avoid the reference to the SYS schema.
QSM-02104: aggregate function in a filter condition in the HAVING clause
Cause: The capability in question is not supported when the materialized view references an aggregate function in a filter condition in the HAVING clause.
Action: Re-phrase the query to avoid the use of aggregates in filter conditions in the HAVING clause.
QSM-02106: mv uses a filter condition in the WHERE or HAVING clause
Cause: The capability in question is not supported when the materialized view includes a filter condition in the WHERE or HAVING clause.
Action: Re-phrase the query to avoid the use of filter conditions in the WHERE or HAVING clauses.
QSM-02112: top level query has LEFT OUTER, RIGHT OUTER or FULL OUTER join
Cause: The capability in question is not supported when the materialized view uses these types of joins.
Action: Re-phrase the query to avoid the use of these types of joins.
QSM-02113: expression in select list references multiple tables or views
Cause: The capability in question is not supported when the materialized view includes an expression in the select list that references multiple tables or views.
Action: Re-phrase the query to avoid the use of the such expressions.
QSM-02114: no GROUP BY clause, no aggregates and not >= 9.0 compatibility
Cause: The capability in question is not supported when the materialized view has no GROUP BY clause, no aggregates and compatibility mode is less than 9.0.
Action: Re-phrase the query to avoid the include a GROUP BY clause or an aggregate function. Or set compatibility mode to 9.0 or greater.
QSM-02115: mv references a remote object and is refreshed ON COMMIT
Cause: The capability in question is not supported when the materialized view references a remote object and is refreshed ON COMMIT.
Action: Re-phrase the query to avoid the reference to the remote object or alter the materialized view to be refreshed ON DEMAND.
QSM-02116: mupltiple master sites
Cause: The capability in question is not supported when the materialized view references multiple remote objects that reside at different remote instances.
Action: Re-phrase the query to avoid the use of multiple master sites.
QSM-02117: missing GROUPING_ID or GROUPING functions on GROUP BY column(s)
Cause: The capability in question is not supported when the materialized view uses grouping sets but omits the relevant GROUPING_ID or GROUPING functions.
Action: Re-phrase the query to include the relevant GROUPING_ID or GROUPING functions.
QSM-02118: duplicate grouping sets
Cause: The capability in question is not supported when the materialized view redundantly references grouping sets.
Action: Re-phrase the query to avoid the use of the redundant grouping sets.
QSM-02119: internal error while analyzing required supporting aggregates
Cause: An internal Oracle error has occurred.
Action: Report the problem through your normal support channels.
QSM-02120: compatibility mode must be 9.0 or higher
Cause: The capability in question is not supported when the compatibility mode is less than 9.0.
Action: Set the compatibility mode to 9.0 or higher.
QSM-02121: set operator in a context not supported for fast refresh
Cause: The capability in question is not supported when the materialized view uses a set operator in this context.
Action: Re-phrase the query to avoid the use of the set operator.
QSM-02122: compatibility mode must be 8.1 or higher
Cause: The capability in question is not supported when the compatibility mode is less than 8.1.
Action: Set the compatibility mode to 8.1 or higher.
QSM-02123: subquery and UNION mv's must be primary key mv's
Cause: The capability in question is not supported when the materialized view is not a primary key materialized view and uses subqueries or the union operator in this context.
Action: Re-create the materialized view as a primary key materialized view.
QSM-02124: object type in WHERE clause
Cause: The capability in question is not supported when the materialized view references an object type in the WHERE clause.
Action: Re-phrase the query to avoid the reference to the object type.
QSM-02125: subquery join conditions don't meet requirements for capability
Cause: The capability in question is not supported when the materialized view uses a subquery in a join in this way.
Action: Examine the relevant replication documentation concerning subquery materialized views and address the problem.
QSM-02126: no rowid at master site
Cause: The capability in question is not supported when the materialized view references a remote site that does not support rowids.
Action: Re-phrase the query to avoid the reference to the remote site.
QSM-02127: not supported for this type mv by Oracle version at master site
Cause: The capability in question is not supported when the materialized view uses certain constructs and references an older version, remote Oracle instance.
Action: Re-phrase the query to avoid the use of the construct or upgrade the remote Oracle instance.
QSM-02128: does not meet the requirements of a primary key mv
Cause: The capability in question is not supported when the materialized view fails to meet the requirements of a primary key materialized view.
Action: Examine the relevant primary key materialized view replication
QSM-02129: join or filter condition(s) are complex
Cause: The capability in question is not supported when the materialized view uses a complex join or filter condition.
Action: Re-phrase the query to simplify the join or filter condition.
QSM-02130: expression not supported for fast refresh
Cause: The capability in question is not supported when the materialized view references certain, complex expressions.
Action: Re-phrase the query to simplify the expression.
QSM-02131: agg(expr) requires correspondng SUM(expr) function
Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the SUM function on the same argument.
Action: Add the SUM function to the select list.
QSM-02132: agg(expr) requires correspondng COUNT(expr) function
Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the COUNT function on the same argument.
Action: Add the COUNT function to the select list.
QSM-02133: agg(expr) requires correspondng MIN(expr) function
Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the MIN function on the same argument.
Action: Add the MIN function to the select list.
QSM-02134: agg(expr) requires correspondng MAX(expr) function
Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the MAX function on the same argument.
Action: Add the MAX function to the select list.
QSM-02135: agg(expr) requires correspondng AVG(expr) function
Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the AVG function on the same argument.
Action: Add the AVG function to the select list.
QSM-02136: agg(expr) requires correspondng VARIANCE(expr) function
Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the VARIANCE function on the same argument.
Action: Add the VARIANCE function to the select list.
QSM-02137: agg(expr) requires correspondng STDDEV(expr) function
Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the STDDEV function on the same argument.
Action: Add the STDDEV function to the select list.
QSM-02138: agg(expr) requires correspondng agg(expr*expr) function
Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of that same aggregate function on the square of the same argument.
Action: Add an invocation of the same aggregate function on the square of the same argument (that is, the argument multiplied by itself).
QSM-02139: agg(expr) requires correspondng agg(expr+expr) function
Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of that same aggregate function on the same argument added to the same argument.
Action: Add the indicated aggregate function to the select list.
QSM-02140: agg(expr) requires correspondng SUM(expr*expr) function
Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the SUM function on the square of the same argument (the argument multiplied by itself).
Action: Add the SUM function on the square of the argument.
QSM-02141: the reason why the capability is disabled has escaped analysis
Cause: The EXPLAIN_MV analysis engine has failed to capture the reason why the given capability is not possible.
Action: Report the problem through your normal problem reporting channels.
QSM-02142: COUNT(*) is not present in the select list
Cause: The materialized view query omits COUNT(*) from the select list.
Action: Add COUNT(*) to the select list.
QSM-02143: SUM(expr) without COUNT(expr)
Cause: SUM(expr) occurs in the select list without a corresponding COUNT(expr).
Action: Add COUNT(expr) to the select list.
QSM-02144: aggregate functions are present without a GROUP BY clause
Cause: One or more aggregate functions are present in the select list but a GROUP BY clause is not used.
Action: Add a GROUP BY clause.
QSM-02145: GROUP BY clause is present but no aggregate functions are used
Cause: A GROUP BY clause is used but no aggregate functions are present in the select list.
Action: Add an aggregate function to the select list.
QSM-02146: see the reason why REFRESH_FAST_AFTER_INSERT is disabled
Cause: REFRESH_FAST_AFTER_ONETAB_DML is disabled for the same reason that REFRESH_FAST_AFTER_INSERT is disabled.
Action: Correct the problem with REFRESH_FAST_AFTER_INSERT.
QSM-02147: default date format is sensitive to session settings
Cause: You have specified a date conversion operation using either the default format or an incomplete format. The default date format or an incomplete format is sensitive to session settings, and therefore may not be reproducible across different environments.
Action: Specify a complete date format string.
QSM-02148: many to many subquery joins require 9.0 compatibility or higher
Cause: You have specified a many to many join in your materialized view while running in less than 9.0 compatibility mode.
Action: Set your compatibility mode to 9.0 or higher or restructure the materialized view query.
QSM-02149: ON COMMIT with this MV requires 9.0 compatibility or higher
Cause: You have specified a materialized view that uses some combination of the following: joins aggregation filter conditions in the WHERE clause a remote relation in the FROM list a SUM(x) function without a corresponding COUNT(x) function an omitted COUNT(*) aggregate function a MIN() or MAX() aggregate function in combination with the REFRESH ON COMMIT option while running in less than 9.0 compatibility mode.
Action: Set your compatibility mode to 9.0 or higher or restructure the materialized view query.
QSM-02150: select lists must be identical across the UNION operator
Cause: You have specified a materialized view using the UNION operator and the respective queries on each side of the UNION operator do not have the same select list. The RELATED_NAME column shows the alias of the first different select list item. The RELATED_NUM column shows the offset from the SELECT keyword to the start of this select list item.
Action: Restructure the materialized view query such that the respective sides of the UNION operator have identical select lists.
QSM-02151: subquery or named view in FROM list and < 9.0 compatibility
Cause: You have specified a materialized view that references a subquery or named view in its top level FROM list while running in less than 9.0 compatibility mode.
Action: Set compatibility mode to 9.0 or higher or restructure the materialized view query.
QSM-02152: subquery or named view in FROM list even after view merging
Cause: You have specified a materialized view that references a subquery ore named view in its top level FROM list that could not be merged during the view merging process.
Action: Restructure the materialized view query.
QSM-02153: inline view or subquery in FROM list not supported for this type MV
Cause: You have specified a materialized view that references an inline view or a subquery. The indicated capability is not supported for this type of materialized view.
Action: Restructure the materialized view query.
QSM-02154: MV is not fast refreshable even with view merging
Cause: You have a materialized view with view in the FROM clause, however it does not meet the criteria for fast refresh after view merging.
Action: Restructure the materialized view query to remove the offending view or the complex construct in the view.
QSM-02161: see the reason why REFRESH_FAST_AFTER_ONETAB_DML is disabled
Cause: REFRESH_FAST_AFTER_ANY_DML is disabled for the same reason that REFRESH_FAST_AFTER_ONETAB_DML is disabled.
Action: Correct the problem with REFRESH_FAST_AFTER_ONETAB_DML.
QSM-02162: the detail table does not have a materialized view log
Cause: The fast refresh cannot be performed because the master table does not contain a materialized view log.
Action: Use the CREATE MATERIALIZED VIEW LOG command to create a materialized view log on the master table.
QSM-02163: cannot use object id columns from materialized view log
Cause: The materialized view log either does not have object id columns logged, or the timestamp associated with the object id columns is more recent than the last refresh time.
Action: A complete refresh is required before the next fast refresh. Add object id columns to the materialized view log, if required.
QSM-02170: tables must be identical across the UNION operator
Cause: You have specified a materialized view using the UNION operator and the tables on each side of the UNION operator do not match. Fast refresh is not supported in this context.
Action: Restructure the materialized view query such that the respective sides of the UNION operator have the same table.
QSM-02171: the materialized view has a join operation in the outer UNION block
Cause: Fast refresh is not supported if a materialized view having the UNION operator contains a join operation.
Action: Rewrite the materialized view query without the join.
QSM-02173: the unique constraints does not exist on the join columns of the inner table
Cause: If there are outer joins, unique constraints must exist on the join columns of the inner table. Othwerwise, the materialized view can not be fast refreshable.
Action: none
QSM-02174: the materialized view does not have a UNION ALL marker column
Cause: For a materialized view with UNION ALL to be fast refreshable, it must have a UNION ALL marker column. This is a constant column, at the same ordinal position in each query block and must have distinct values in each query block.
Action: Add a UNION ALL marker column to each query block in the UNION ALL query defining the materialized view.
QSM-02175: some query block in UNION ALL MV is not fast refreshable
Cause: For a materialized view with UNION ALL to be fast refreshable, each query block must conform to a fast refreshable materialized join view or materialized aggregate view.
Action: Check each query block in the UNION ALL to ensure it is either a materialized view with joins or aggregates.
QSM-02176: MV with UNION ALL in a view is too complex
Cause: If a materialized view has a view whose definition involves a UNION ALL query, then the materialized view's defining query cannot have any clauses other than SELECT or FROM. Other clauses such as WHERE, HAVING, CONNECT BY, or GROUP BY are not allowed. Further more, the FROM clause should have only one item.
Action: Remove any clauses besides SELECT and FROM from the materialized view's defining query.
QSM-02177: MV with UNION ALL in a view must match the view's SELECT list
Cause: If a materialized view has a view whose definition involves a UNION ALL query, then the materialized view's select list must match the underlying view's select list exactly. It must not have any expressions and must not have add/drop/reorder columns from the underlying view.
Action: Use select * when defining a materialized view with a UNION ALL in a view.
QSM-02178: MV has a view with UNION ALL that is not fast refreshable
Cause: The materialized view has a view whose definition involves a UNION ALL query that does not satisfy the requirements for fast refresh.
Action: Check that the defining query of the view being referenced in the materialized view satisfies conditions for fast refresh of a UNION ALL materialized view.
QSM-02179: MV with UNION ALL requires compatibility >= 9.2
Cause: The setting of the COMPATIBLE initialization parameter is less than 9.2.0.
Action: Set COMPATIBLE to 9.2.0 or higher.
QSM-02180: no primary key constraint in the master table
Cause: The explain_mview assumes that the materialized view is going to be created as the Primary Key materialized view. A Primary Key materialized view can not be created if the base table does not have a primary key constraint.
Action: Add a primary key constraint to the base table, or create the materialized view as Rowid MV by specifying the WITH ROWID option. If the materialized view is a Rowid MV, then it should be able to do complete refresh and even fast refresh, given that the materialized view log on the master table has a rowid.
QSM-02181: a SPREADSHEET clause is present
Cause: The capability in question is not supported when the materialized view uses a SPREADSHEET clause.
Action: Remove the SPREADSHEET clause.
QSM-02182: PCT is enabled through a join dependency
Cause: The capability in question is not supported when the materialized view does not contain some expression join dependent on the partitioning key of relation in question in the select list. For definition of join dependency, please look at Oracle
Action: Change the query to contain the partitioning key
QSM-02183: Expression to enable PCT not in PARTITION BY of analytic function or SPREADSHEET
Cause: The capability in question is not supported when the expression is not in the PARTITION BY clause
Action: Change the query so that the expression is in the PARTITION BY
QSM-02184: Expression to enable PCT cannot be rolled up
Cause: The capability in question is not supported when the expression is rolled up
Action: Change the query so that the expression is not rolled up
QSM-02185: no partition key or PMARKER in select list
Cause: The capability in question is not supported when the materialized view unless the select list (and group by list if a GROUP BY clause is present) includes either the partition key of or a PMARKER function reference to the table in question.
Action: Add the partition key or a PMARKER function reference to the select list (and the GROUP BY clause, if present).
QSM-02186: PARTITIONED OUTER JOIN is present
Cause: The capability in question is not supported when the materialized view has PARTITIONED OUTER JOIN.
Action: Remove PARTITIONED OUTER JOIN.
QSM-02187: materialized view on external table
Cause: The capability in question is not supported when the materialized view references an external table.
Action: Re-phrase the query to avoid the use of the external tables.
QSM-02188: named view in FROM list not supported for this type MV
Cause: You have specified a materialized view that references a named view The indicated capability is not supported for this type of materialized view.
Action: Restructure the materialized view query.


32 RMAN-00550 to RMAN-20506

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

32 RMAN-00550 to RMAN-20506

RMAN-00550: parser package failed to load
Cause: lpmloadpkg() return an error indication.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-00551: initialization of parser package failed
Cause: The parser package initialization routine returned an error.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-00552: syntax error in command line arguments
Cause: The arguments supplied to RMAN could not be parsed, or no arguments were supplied at all.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-00553: internal recovery manager package failed to load
Cause: lpmloadpkg() return an error indication.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-00554: initialization of internal recovery manager package failed
Cause: The internal package initialization routine returned an error.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-00555: target database connect string must be specified
Cause: The TARGET parameter was not specified.
Action: Supply the necessary parameter.
RMAN-00556: could not open CMDFILE "string"
Cause: An error occurred when trying to open the file.
Action: Check that the filename was specified correctly and that the file exists and that the user running RMAN has read permission for the file.
RMAN-00557: could not open MSGLOG "string"
Cause: An error occurred when trying to open the file.
Action: Check that the filename was specified correctly and that the file exists and that the user running RMAN has write permission for the file.
RMAN-00558: error encountered while parsing input commands
Cause: The parser detected a syntax error.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-00562: username too long
Cause: The specified user name exceeds the maximum allowable username length.
Action: Correct the username.
RMAN-00563: password too long
Cause: The specified password exceeds the maximum allowable password length.
Action: Correct the password.
RMAN-00564: host data too long
Cause: The SQL*NET host connect string exceeds the maximum allowable length.
Action: Correct the host string.
RMAN-00565: unable to read input file
Cause: An error occurred while trying to read from STDIN or from the CMDFILE.
Action: Ensure that the cmdfile is readable. The cmdfile must be a text file with 1 line per record.
RMAN-00566: could not open TRACE "string"
Cause: An error occurred when trying to open the file.
Action: Check that the filename was specified correctly and that the user running RMAN has write permission for the file.
RMAN-00567: Recovery Manager could not print some error messages
Cause: An error occurred while trying to print the error message stack.
Action: If the associated error message indicates a condition that can be corrected, do so, otherwise contact Oracle.
RMAN-00568: user interrupt received
Cause: The user typed ^C or ATTN.
Action: no action required
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
Cause: This message preceeds an error message stack.
Action: The errors are printed in last-in first-out order. So to interpret them correctly, read from the bottom to the top.
RMAN-00570: **end-of-file**
Cause: The end of an inline cmdfile was reached. This is just an informational message.
Action: no action required
RMAN-00571: ===========================================================
Cause: Displayed to highlight the error message stack.
Action: The errors are printed in last-in first-out order. So to interpret them correctly, read from the bottom to the top.
RMAN-00572: waiting for dbms_pipe input
Cause: This message is used only when the PIPE option was specified.
Action: enqueue some RMAN input into the pipe
RMAN-00573: dbms_pipe.next_item_time returned unknown type code: number
Cause: This is an internal error
Action: contact Oracle Customer Support.
RMAN-00574: rman aborting due to errors read/writing dbms_pipe
Cause: RMAN was run with input/output being sent to dbms_pipe. An error was encountered while reading from or writing to the pipe. This error should be preceeded by information describing the error.
Action: RMAN terminates. Refer to the cause/action for the preceding errors.
RMAN-00575: timeout while trying to write to dbms_pipe
Cause: d by death of the process that was talking to rman.
Action: RMAN will abort.
RMAN-00576: PIPE cannot be used with CMDFILE
Cause: The PIPE and CMDFILE options cannot be used together. When using the PIPE option, RMAN must obtain its input from the input pipe.
Action: Remove either the PIPE or CMDFILE option.
RMAN-00577: PIPE requires that TARGET be specified on the command line
Cause: The PIPE option obtains its input from, and writes its output to, an Oracle database pipe in the target database. Therefore, the target database connection must be specified on the command line, so that RMAN can connect to the target database to receive its input from the pipe.
Action: Specify the TARGET option on the RMAN command line.
RMAN-00578: pipe string is not private and owned by SYS
Cause: The pipe that RMAN needs to use for its input or output is either a public pipe or a private pipe that is not owned by SYS. This is a potential security problem, because it allows a non-SYS user to issue commands to RMAN or to retrieve the RMAN output.
Action: If you are attempting to put data on the RMAN input pipe prior to starting RMAN, so RMAN will process the data on the pipe as soon as it starts, you must be connected as SYS and you must first use the dbms_pipe.create_pipe function to explicitely create the pipe as a private pipe.
RMAN-00579: SCRIPT cannot be used with CMDFILE
Cause: The SCRIPT and CMDFILE options cannot be used together. When using the SCRIPT option, RMAN executes only the specified script.
Action: Remove either the SCRIPT or CMDFILE option.
RMAN-00600: internal error, arguments [string] [string] [string] [string] [string]
Cause: An internal error in recovery manager occurred.
Action: Contact Oracle Customer Support.
RMAN-00601: fatal error in recovery manager
Cause: A fatal error has occurred.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-00700: SCRIPT requires that TARGET be specified on the command line
Cause: A SCRIPT option was included on the RMAN command line without a specified TARGET database.
Action: Specify the TARGET option on the RMAN command line.
RMAN-00701: SCRIPT requires that CATALOG be specified on the command line
Cause: A SCRIPT option was included on the RMAN command line without a specified CATALOG recovery catalog.
Action: Specify the CATALOG option on the RMAN command line.
RMAN-01006: error signalled during parse
Cause: An error was signalled during parsing.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-01007: at line number column number file: string
Cause: This is an informational message indicating the line and column where a syntax error was detected.
Action: no action required
RMAN-01008: the bad identifier was: string
Cause: This is an informational message indicating the identifier token that caused a syntax error.
Action: no action required
RMAN-02000: wrong message file version (msg number not found)
Cause: The rmanxx.msb file is not the correct version.
Action: Check that the installation was done correctly. The RMAN binary (executable, load module, whatever it is called on your O/S) and the rmanxx.msb file must be from the same version, release, and patch level.
RMAN-02001: unrecognized punctuation symbol "string"
Cause: An illegal punctuation character was encountered.
Action: Remove the illegal character.
RMAN-02002: unexpected end of input file reached
Cause: This is probably caused by failure to supply the closing quote for a quoted string.
Action: Correct the input.
RMAN-02003: unrecognized character: string
Cause: An input character that is neither an alpha, digit, or punctuation was encountered.
Action: Remove the character.
RMAN-02004: quoted string too big
Cause: A quoted string longer than 2000 bytes was encountered.
Action: This may be caused by a missing close quote. If so, add the missing quote, otherwise shorten the string.
RMAN-02005: token too big
Cause: A token longer than 1000 bytes was encountered
Action: Tokens must be separated by whitespace or punctuation. Either add the missing whitespace or punctuation, or shorten the token.
RMAN-02006: script line too long
Cause: a line longer than 500 bytes was encountered
Action: break the line up into shorter lines
RMAN-02007: Integer value overflow
Cause: Parser failed to convert input string to integer
Action: Acceptable values for integer are from 0 to 2147483648. Retry command using valid integer value.
RMAN-03000: recovery manager compiler component initialization failed
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-03001: recovery manager command sequencer component initialization failed
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-03002: failure of string command at string
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-03003: command not implemented yet: string
Cause: The command is not implemented in the current release.
Action: Avoid using the command.
RMAN-03004: fatal error during execution of command
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-03008: error while performing automatic resync of recovery catalog
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-03009: failure of string command on string channel at string
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-03010: fatal error during library cache pre-loading
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-03011: Recovery Manager: Release string string
Cause: This is the RMAN banner
Action: no action required
RMAN-03012: fatal error during compilation of command
Cause: A fatal error occurred during compilation of a command.
Action: This message should be accompanied by other errors explaining the cause of the failure.
RMAN-03013: Copyright (c) 1995, 2003, Oracle Corporation. All rights reserved.
Cause: This is the copyright banner
Action: no action required
RMAN-03014: implicit resync of recovery catalog failed
Cause: of the failure.
Action: no action required
RMAN-03015: error occurred in stored script string
Cause: informational message only
Action: no action required
RMAN-03017: recursion detected in stored script string
Cause: A stored script is calling itself or another script which calls itself.
Action: Remove the recusion.
RMAN-03018: asynchronous RPCs are working correctly
Cause: informational message
Action: no action required
RMAN-03019: asynchronous RPCs are NOT working
Cause: The RPCTEST command has determined that RPCs are not executing asynchronously. Instead, they are blocking. This is caused by using a SQL*NET driver that does not support non-blocking UPI.
Action: Try using a different SQL*NET driver.
RMAN-03020: asynhronous RPC test will take 1 minute
Cause: informational message
Action: no action required
RMAN-03023: executing command: string
Cause: informational message
Action: no action required
RMAN-03028: fatal error code for command string : number
Cause: Informational message. This preceeds error 3012.
Action: no action required
RMAN-03029: echo set on
Cause: a SET ECHO ON command was issued
Action: no action required
RMAN-03030: echo set off
Cause: a SET ECHO OFF command was issued
Action: no action required
RMAN-03031: this option of set command needs to be used inside a run block
Cause: The option used with the SET command is not valid outside a run block.
Action: Change the SET command or place it inside a run block.
RMAN-03032: this option of set command needs to be used outside of a run block
Cause: The option used with the SET command is not valid inside of a run block.
Action: Change the SET command or place it outside a run block.
RMAN-03033: current log archived
Cause: A "ALTER SYSTEM ARCHIVE LOG CURRENT" command completed successfully.
Action: None, this is an informational message.
RMAN-03034: LEVEL number is invalid. LEVEL must be between string and string
Cause: An invalid DEBUG LEVEL was used.
Action: Change the DEBUG LEVEL argument.
RMAN-03035: Debugging turned off
Cause: a DEBUG OFF comand was issued
Action: no action required
RMAN-03036: Debugging set to level=number, types=string
Cause: a DEBUG comand was issued
Action: no action required
RMAN-03037: Spooling started in log file: string
Cause: a SPOOL LOG TO ... comand was issued
Action: no action required
RMAN-03038: Spooling started in trace file: string
Cause: a SPOOL TRACE TO ... comand was issued
Action: no action required
RMAN-03039: Spooling for log turned off
Cause: a SPOOL LOG OFF comand was issued
Action: no action required
RMAN-03040: Spooling for trace turned off
Cause: a SPOOL TRACE TO ... comand was issued
Action: no action required
RMAN-03090: Starting string at string
Cause: informational message
Action: no action required
RMAN-03091: Finished string at string
Cause: informational message
Action: no action required
RMAN-03098: RMAN-number: stringstring
Cause: This is the message prefix with a possible indentation.
Action: no action required
RMAN-03099: job cancelled at user request
Cause: The user interrupted the current job.
Action: None.
RMAN-03999: Oracle error occurred while while converting a date: ORA-number: string
Cause: Internal error converting a date.
Action: Contact Oracle Customer Support.
RMAN-04000: memory allocation failure
Cause: A memory allocation request could not be satisified.
Action: Increase the amount of memory available to RMAN.
RMAN-04001: heap initialization failure
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-04002: ocipi failed, ORA-string
Cause: OCI process level initialization failed.
Action: This error should not normally occur.
RMAN-04003: ociinit failed
Cause: The call to OCIEnvInit failed.
Action: This error should not normally happen. Contact Oracle Customer Support.
RMAN-04004: error from recovery catalog database: string
Cause: Oracle error signaled by catalog database. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-04005: error from target database: string
Cause: Oracle error signaled by target database. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-04006: error from auxiliary database: string
Cause: Oracle error signaled by auxiliary database. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-04007: WARNING from recovery catalog database: string
Cause: Non fatal Oracle error signaled by catalog database. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-04008: WARNING from target database: string
Cause: Non fatal Oracle error signaled by target database. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-04009: WARNING from auxiliary database: string
Cause: Non fatal Oracle error signaled by auxiliary database. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-04010: target database Password:
Cause: No password was provided for the target database.
Action: Provide target database password.
RMAN-04011: recovery catalog database Password:
Cause: No password was provided for the recovery catalog database.
Action: Provide recovery catalog database password.
RMAN-04012: auxiliary database Password:
Cause: No password was provided for the auxiliary database.
Action: Provide auxiliary database password.
RMAN-04013: must connect before startup
Cause: A STARTUP command was attempted before connecting to the database.
Action: Connect to database before attempting STARTUP command.
RMAN-04014: startup failed: string
Cause: The database failed to startup.
Action: The cause of the failure is included in the error message. Correct the cause of the failure and retry the startup command.
RMAN-04015: error setting target database character set to string
Cause: An error was received while setting the session character set in the target database.
Action: This error should not normally happen. Contact Oracle Customer Support.
RMAN-04016: could not get OCI error handle
Cause: An error was received while initializing the OCI layer.
Action: This error should not normally happen. Contact Oracle Customer Support.
RMAN-04020: target database name "string" does not match channel's name: "string"
Cause: The CONNECT clause in the ALLOCATE command has resulted in a connection to a database which is not the same as the one used to connect to the target database.
Action: Verify that the CONNECT string connects to the same database as the one specified in the TARGET connection for the CONNECT command.
RMAN-04021: target database DBID string does not match channel's DBID string
Cause: The CONNECT clause in the ALLOCATE command has resulted in a connection to a database which is not the same as the one used to connect to the target database.
Action: Verify that the CONNECT string connects to the same database as the one specified in the TARGET connection for the CONNECT command.
RMAN-04022: target database mount id string does not match channel's mount id string
Cause: The CONNECT clause in the ALLOCATE command has resulted in a connection to a database which is not the same as the one used to connect to the target database.
Action: Verify that the CONNECT string connects to the same database as the one specified in the TARGET connection for the CONNECT command.
RMAN-04024: trying to start the Oracle instance without parameter files ...
Cause: The instance could not be started because no default parameter file (either PFILE or SPFILE) could be found. The instance will be started in restricted mode with default parameters.
Action: None - this is an informational message.
RMAN-04025: unable to generate a temporary file
Cause: Creation of a temporary file failed. If could be that the system does not have enough resources (disk space, memory or similar).
Action: Verify and free some system resources memory and try again.
RMAN-04026: unable to open a temporary file: "string"
Cause: Opening of a temporary file failed. If could be that the system does not have enough resources (disk space, memory or similar).
Action: Verify and free some system resources memory and try again.
RMAN-04027: unable to write to a temporary file: "string"
Cause: Writing to a temporary file failed. If could be that the system does not have enough resources (disk space, memory or similar).
Action: Verify and free some system resources memory and try again.
RMAN-04031: initialization parameters used for automatic instance: string
Cause: informational message
Action: no action required
RMAN-04032: using contents of file string
Cause: The specified file was included as part of the auxiliary database parameter file. This is an informational message.
Action: no action required
RMAN-04033: cannot open auxiliary parameter file string
Cause: An auxiliary parameter file was specified with SET AUXILIARY INSTANCE PARAMETER FILE command but the specified file cannot be found.
Action: Set the parameter file to an existen file or retry the command without setting AUXILIARY INSTANCE PARAMETER FILE.
RMAN-05000: CONFIGURE AUXNAME required for datafile string
Cause: Either: -) The controlfile mounted by the auxiliary database does not have an entry for this datafile, therefore filename conversion is not possible. -) A COPY DATAFILE TO AUXNAME command was issued, but no auxname was set for this datafile.
Action: Use the CONFIGURE AUXNAME command to specify a filename that the auxiliary database can use as a restore destination.
RMAN-05001: auxiliary filename string conflicts with a file used by the target database
Cause: RMAN is attempting to use the specified filename as a restore destination in the auxiliary database, but this name is already in use by the target database.
Action: Use the CONFIGURE AUXNAME command to specify a name for the datafile that does not conflict with a filename in use by the target db.
RMAN-05002: aborting point-in-time tablespace recovery
Cause: Previously encountered error(s) were issued which require corrective action.
Action: Resolve the error conditions, and then re-issue the RECOVER command.
RMAN-05003: point-in-time recovery is not allowed for tablespace string
Cause: The SYSTEM tablespace or a tablespace containing rollback segments is not allowed in point-in-time recovery.
Action: Remove the indicated tablespace from the recovery set and retry the operation.
RMAN-05004: target database log mode is NOARCHIVELOG
Cause: An attempt was made to apply TSPITR to a database that is in NOARCHIVELOG mode.
Action: If all required archive log files are available to TSPITR, alter the target database log mode to ARCHIVELOG and retry the TSPITR operation. Otherwise, TSPITR cannot be applied to this database.
RMAN-05005: point-in-time recovery is not allowed for re-created tablespace string
Cause: The requested tablespace has been re-created and is not allowed in point-in-time recovery.
Action: Remove the indicated tablespace from the recovery set and retry the operation.
RMAN-05006: cannot recover clone standby single tablespaces
Cause: Standby recover can only be performed for the whole database.
Action: Change the tablespace list to a database specification.
RMAN-05007: no channel allocated
Cause: A command was entered that requires a channel, and no channel is allocated.
Action: Use ALLOCATE CHANNEL before using the command
RMAN-05008: SET NEWNAME TO NEW not allowed (datafile string)
Cause: SET NEWNAME ... TO NEW is not allowed with TSPITR.
Action: Set the new name to a specific file name and retry.
RMAN-05009: Block Media Recovery requires Enterprise Edition
Cause: The BLOCKRECOVER command was specified.
Action: Remove the BLOCKRECOVER command.
RMAN-05010: target database must be opened in READ WRITE mode for TSPITR
Cause: The target database was not opened in read write mode.
Action: Open the database in read write mode.
RMAN-05011: auxiliary instance must be in nomount state for TSPITR
Cause: The Auxiliary instance was not in nomount state.
Action: Open the auxiliary instance in nomount state.
RMAN-05012: trying to start the Oracle instance without parameter files ...
Cause: The instance could not be started because no default parameter file (either PFILE or SPFILE) could be found. The instance will be started in restricted mode with default parameters.
Action: None - this is an informational message.
RMAN-05013: auxiliary control filename string conflicts with a file used by the target database
Cause: RMAN is attempting to use the specified control filename for TSPITR as a restore destination in the auxiliary database, but this name is already in use by the target database.
Action: Set control_files parameter in the auxiliary instance to a name that does not conflict with a filename in use by the target database.
RMAN-05016: failover to previous backup
Cause: This is an informational message to indicate the RMAN could not successfully restore the files using the specified backups. An attempt was made to restore the datafiles/archivelogs/ controlfile/SPFILE using a previous existing backup.
Action: See accompnaying additional error messages indicating the cause of the failover.
RMAN-05017: no copy of datafile number found to recover
Cause: A RECOVER COPY command was not able to proceed because no copy of indicated file was found to recover. Possible causes include the following:

1. no copy of indicated file exists on disk that satisfy the criteria specified in the user's recover operands.

2. copy of indicated datafile exists on disk but no incremental backup was found to apply to the datafile copy.

Action: One of the following:

1. Use or correct TAG specification to recover a different datafile copy.

2. Use BACKUP FOR RECOVER OF COPY command to create necessary incremental backup or copy.

RMAN-05018: some datafile copies cannot be recovered, aborting the RECOVER command
Cause: This error message can follow one or more RMAN-5017 or RMAN-5019 error messages.
Action: See RMAN-5017 or RMAN-5019 error messages documentation for more information.
RMAN-05019: WARNING: no channel of required type allocated to recover copy of datafile number
Cause: A RECOVER COPY command could not proceed because incremental backup sets exist on a device type that has not been allocated.
Action: Use the LIST command to determine which device type is needed, then allocate a channel of that type.
RMAN-05020: cannot specify AUXILIARY DESTIONATION option for normal recovery
Cause: The AUXILIARY DESTIONATION option was specified for a normal recovery. It is only allowed for tablespace point in time recovery.
Action: Remove the AUXILIARY DESTIONATION option and re-run the RECOVER command.
RMAN-05021: this configuration cannot be changed for a BACKUP or STANDBY control file
Cause: The user attempted to modify the configuration which cannot be changed for a BACKUP or STANDBY control file while the mounted control file was either BACKUP or STANDBY. The following configurations can be changed only when connected to primary database instance that has CURRENT/CREATED control file type mounted: CONFIGURE RETENTION POLICY CONFIGURE EXCLUDE CONFIGURE ARCHIVELOG DELETION POLICY
Action: Connect to primary database instance and execute the command.
RMAN-05500: the auxiliary database must be not mounted when issuing a DUPLICATE command
Cause: A DUPLICATE command was issued, but the auxiliary database is mounted.
Action: Dismount the auxiliary database.
RMAN-05501: aborting duplication of target database
Cause: Previously encountered errors require corrective action.
Action: Resolve the error conditions, and reissue the DUPLICATE TARGET DATABASE command.
RMAN-05502: the target database must be mounted when issuing a DUPLICATE command
Cause: A DUPLICATE command was issued, but the target database control file is not mounted.
Action: Mount the target database control file by issuing ALTER DATABASE MOUNT via Enterprise Manager or Server Manager.
RMAN-05503: at least one auxiliary channel must be allocated to execute this command
Cause: No auxiliary channels were allocated.
Action: Allocate an auxiliary channel.
RMAN-05504: at least two redo log files or groups must be specified for this command
Cause: Only one redo log file or group was specified
Action: Specify at least one more redo log file or group
RMAN-05505: auxiliary filename conversion of 'string' exceeds maximum length of string
Cause: When the given filename is converted to the name used for the auxiliary database, the converted name is larger than the maximum allowed filename.
Action: Change initialization parameter DB_FILE_NAME_CONVERT to convert to a valid filename.
RMAN-05506: error during recursive execution
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-05507: standby controlfile checkpoint (string) is more recent than duplication point in time (string)
Cause: A DUPLICATE FOR STANDBY command was issued, but the checkpoint of the controlfile is more recent than the last archivelog or the specified point in time.
Action: If an explicit point in time was specified, change it to be at least the controlfile checkpoint; otherwise archive (and backup/copy) the current log.
RMAN-05508: SET NEWNAME TO NEW not allowed (datafile string)
Cause: SET NEWNAME ... TO NEW is not allowed with the DUPLICATE command.
Action: Set the new name to a specific file name and retry.
RMAN-05510: Duplicate finished
Cause: informational message
Action: no action required
RMAN-05511: Datafile string skipped by request
Cause: informational message
Action: no action required
RMAN-05512: tablespace string cannot be skipped from duplication
Cause: The SYSTEM and SYSAUX tablespaces were not included in the duplicate database. They must be present.
Action: Remove the SYSTEM and/or SYSAUX tablespace from the SKIP list and retry the operation.
RMAN-05513: cannot duplicate, controlfile is not current or backup
Cause: DUPLICATE requires that the target database has a current controlfile
Action: Open the target database and retry operation
RMAN-05514: tablespace string has undo information, cannnot skip
Cause: All tablespaces that have undo information must be included in the duplication.
Action: Remove the specified tablespace from the SKIP list and retry the operation.
RMAN-05515: Duplicate for standby does not allow the use of SET UNTIL
Cause: A SET UNTIL clause was specified for the command.
Action: Remove the SET UNTIL clause and try again.
RMAN-06000: could not open recovery manager library file: string
Cause: The "recover.bsq" file could not be opened.
Action: Check that the file was installed correctly and that the user running RMAN has authority to read the file.
RMAN-06001: error parsing job step library
Cause: A syntax error was encountered while parsing "recover.bsq".
Action: Ensure that the correct version of the file is installed and that it has not been modified in any way.
RMAN-06002: command not allowed when not connected to a recovery catalog
Cause: A command that is allowed only when a recovery catalog connect string was supplied was attempted.
Action: Avoid using the command, or restart RMAN and supply a recovery catalog connect string via the CATALOG parameter.
RMAN-06003: ORACLE error from target database: string
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-06004: ORACLE error from recovery catalog database: string
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-06005: connected to target database: string (DBID=string)
Cause: informational message
Action: no action required
RMAN-06006: connected to target database: string (not mounted)
Cause: informational message
Action: no action required
RMAN-06007: target database not mounted and db_name not set in init.ora
Cause: The target database has not mounted the controlfile, and its "init.ora" file does not specify the DB_NAME parameter.
Action: MOUNT the target database, or add the DB_NAME parameter to its "init.ora" and restart the instance.
RMAN-06008: connected to recovery catalog database
Cause: informational message
Action: no action required
RMAN-06009: using target database controlfile instead of recovery catalog
Cause: informational message
Action: no action required
RMAN-06010: error while looking up datafile: string
Cause: An error occurred while looking up the specified datafile in the recovery catalog or target database controlfile.
Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the filename is entered correctly. If the datafile was added recently, then a RESYNC CATALOG must be done to update the recovery catalog.
RMAN-06011: invalid level specified: number
Cause: An invalid incremental backup level was specified.
Action: Incremental backup level must be between 0 and 4.
RMAN-06012: channel: string not allocated
Cause: A RELEASE or SETLIMIT command was found for a channel identifier that was not yet allocated.
Action: Correct the channel identifier, or add an ALLOCATE CHANNEL command.
RMAN-06013: duplicate channel identifier found: string
Cause: A channel identifier was reused without first releasing the channel.
Action: Add a RELEASE CHANNEL command.
RMAN-06014: command not implemented yet: string
Cause: Not all commands are implemented for the beta release.
Action: Avoid using the command.
RMAN-06015: error while looking up datafilecopy name: string
Cause: An error occurred while looking up the specified datafilecopy name in the recovery catalog or target database controlfile.
Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the filename is entered correctly. If the datafilevopy was created when the recovery catalog was not available, then a RESYNC CATALOG must be done to update the recovery catalog.
RMAN-06016: duplicate backup operand specified: string
Cause: The specified operand appears more than once in the same backup specifier or backup command.
Action: Delete the duplicate operand.
RMAN-06017: initialization of parser failed
Cause: The parser package initialization routine returned an error.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-06018: duplicate operand specified in backup specification: string
Cause: A backup specification operand appears more than once in a backup specification.
Action: Delete the duplicate operand.
RMAN-06019: could not translate tablespace name "string"
Cause: An error occurred while looking up the specified tablespace name in the recovery catalog or target database controlfile.
Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the tablespace is entered correctly. If the tablespace was added recently, then a RESYNC CATALOG must be done to update the recovery catalog.
RMAN-06020: connected to auxiliary database (not started)
Cause: informational message
Action: no action required
RMAN-06021: FROM DATAFILECCOPY/BACKUPSET may not be specified with archive logs
Cause: The FROM DATAFILECCOPY/BACKUPSET option applies only to datafile and controlfile restores.
Action: Use this option only for datafile and controlfile restores.
RMAN-06022: invalid level specified for image copy: number
Cause: An invalid incremental backup level was specified for an image copy.
Action: Incremental backup level must be 0 for image copies.
RMAN-06023: no backup or copy of datafile number found to restore
Cause: A datafile, tablespace, or database restore could not proceed because no backup or copy of the indicated file was found. It may be the case that a backup or copy of this file exists but does not satisfy the criteria specified in the user's restore operands.
Action: None - this is an informational message. See message 6026 for further details.
RMAN-06024: no backup or copy of the controlfile found to restore
Cause: A controlfile restore could not proceed because no backup or copy of the controlfile was found. It may be the case that a backup or copy of this file exists but does not satisfy the criteria specified in the user's restore operands.
Action: None - this is an informational message. See message 6026 for further details.
RMAN-06025: no backup of log thread number seq number lowscn string found to restore
Cause: An archive log restore restore could not proceed because no backup of the indicated archived log was found. It may be the case that a backup of this file exists but does not satisfy the criteria specified in the user's restore operands.
Action: None - this is an informational message. See message 6026 for further details.
RMAN-06026: some targets not found - aborting restore
Cause: Some of the files specified for restore could not be found. Message 6023, 6024, or 6025 is also issued to indicate which files could not be found. Some common reasons why a file can not be restored are that there is no backup or copy of the file that is known to recovery manager, or there are no backups or copies that fall within the criteria specified on the RESTORE command, or some datafile copies have been made but not cataloged.
Action: The Recovery Manager LIST command can be used to display the backups and copies that Recovery Manager knows about. Select the files to be restored from that list.
RMAN-06027: no archive logs found that match specification
Cause: An archive log record specifier did not match any archive logs in the recovery catalog.
Action: Resubmit the command with a different archive log record specifier. The rman LIST command can be used to display all archive logs that Recovery Manager knows about.
RMAN-06028: duplicate operand specified in restore specification: string
Cause: The CHANNEL, TAG, FROM, PARMS, VALIDATE, DEVICE TYPE or CHECK READONLY option was specified more than once in the restore command or in one of the restore specifications.
Action: Correct and resubmit the comand.
RMAN-06029: the controlfile may be included only in a datafile backup set
Cause: The "include current/standby controlfile" option was specified for an archive log backup set.
Action: Use this option only for datafile backup sets.
RMAN-06030: the DELETE [ALL] INPUT option may not be used with a datafile backup set
Cause: The DELETE [ALL] INPUT option was specified for a backup that contains the current controlfile or datafiles.
Action: Remove the option and resubmit the command.
RMAN-06031: could not translate database keyword
Cause: An error was received when calling dbms_rcvman
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-06032: at least 1 channel of TYPE DISK must be allocated to execute a COPY command
Cause: No channel of TYPE DISK was allocated.
Action: Allocate a channel of TYPE DISK and re-issue the command.
RMAN-06033: channel string not allocated
Cause: An rman command requests a specific channel, but the requested channel has not been allocated.
Action: ALLOCATE the channel, or correct the channel identifier.
RMAN-06034: at least 1 channel must be allocated to execute this command
Cause: No channels were allocated.
Action: ALLOCATE a channel.
RMAN-06035: wrong version of recover.bsq, expecting string, found string
Cause: The "recover.bsq" file is incompatible with the RMAN executable.
Action: Install the correct version of recover.bsq.
RMAN-06036: datafile number is already restored to file string
Cause: A SET NEWNAME command was issued to restore a datafile to a location other than the original datafile, and Recovery Manager determined that the best candidate for restoring the file is the datafile copy with the same name, therefore the file is already restored and no action need be taken.
Action: None - this is an informational message.
RMAN-06038: recovery catalog package detected an error
Cause: A call to dbms_rcvman returned an error.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-06039: no set newname command has been issued for datafile number
Cause: A SWITCH command was specified for a datafile, but no destination was specified and no SET NEWNAME command has been previously issued for that file. An explicit file to switch to must be specified if no SET NEWNAME command has been issued.
Action: Correct and resubmit the SWITCH command.
RMAN-06040: controlfile is already restored to file string
Cause: The best candidate controlfile for restoration is the one that is named in the RESTORE (controlfile) command, hence no action need be taken.
Action: None - this is an informational message.
RMAN-06041: cannot switch file number to copy of file number
Cause: An attempt was made to switch a datafile to a copy of a different datafile.
Action: Correct and resubmit the SWITCH command.
RMAN-06042: PLUS ARCHIVELOG option is not supported with non-datafile backups
Cause: The PLUS ARCHIVELOG option was supplied but does not apply to this type of backup.
Action: Remove the PLUS ARCHIVELOG operand and re-enter the command.
RMAN-06043: TAG option not supported for archive log copies
Cause: The tag option was supplied but does not apply to this type of copy.
Action: Remove the TAG operand and re-enter the command
RMAN-06045: LEVEL option not supported for archive log or current/standby controlfile copies
Cause: The LEVEL option was supplied but does not apply to this type of copy.
Action: Remove the LEVEL operand and re-enter the command.
RMAN-06046: archive log name: string
Cause: An error occurred while translating an archive log name to its recovery catalog recid/timestamp. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-06047: duplicate datafile number specified for restoration from copy
Cause: The indicated datafile was specified more than once in the same restore command.
Action: Correct and resubmit the RESTORE command.
RMAN-06048: duplicate controlfile specified for restoration from copy
Cause: The controlfile was specified more than once in the same RESTORE command.
Action: Correct and resubmit the RESTORE command.
RMAN-06049: CHECK LOGICAL option not supported for archive log or current/standby controlfile copies
Cause: The check logical option was supplied but does not apply to this type of copy.
Action: Remove the CHECK LOGICAL operand and re-enter the command
RMAN-06050: archive log thread number sequence number is already on disk as file string
Cause: An archive log which was requested to be restored (either explicitely or via a range specification) does not need to be restored because it already exists on disk.
Action: None - this is an informational message
RMAN-06051: DELETE INPUT option not implemented yet
Cause: This option was specified in a backup specification.
Action: Remove the DELETE INPUT option.
RMAN-06052: no parent backup or copy of datafile number found
Cause: An incremental backup at level 1 or higher could not find any parent backup or copy of the indicated datafile. A level 0 backup of the datafile will be taken automatically.
Action: informational message
RMAN-06053: unable to perform media recovery because of missing log
Cause: This message is accompanied with another message identifying the missing log. The log would be needed to perform the media recovery, but the log is not on disk and no backup set containing the log is available.
Action: Determine if a backup set containing the log can be made available. If so, then use the CHANGE command to make the backup set available and retry the command. If not, then a point in time recovery up to the missing log is the only alternative.
RMAN-06054: media recovery requesting unknown log: thread string seq string lowscn string
Cause: Media recovery is requesting a log whose existance is not recorded in the recovery catalog or controlfile.
Action: If a copy of the log is available, then add it to the recovery catalog and/or controlfile via a CATALOG command and then retry the RECOVER command. If not, then a point in time recovery up to the missing log is the only alternative and database can be opened using ALTER DATABASE OPEN RESETLOGS command.
RMAN-06055: could not find log sequence string thread string
Cause: A log which was on disk at the start of media recovery or which should have been restored from a backup set could not be found.
Action: Check the Recovery Manager message log to see if the log was restored by a previous job step. If so, then check the V$ARCHIVED_LOG view to see if the log is listed in the controlfile. If so, then validate that the log exists on disk and is readable. If the log was not restored, or was restored but no record of the log exists in V$ARCHIVED_LOG, then contact Oracle Customer Support.
RMAN-06056: could not access datafile number
Cause: A backup or copy could not proceed because the datafile header could not be read or the header was not valid.
Action: Make the datafile accessible or skip it.
RMAN-06057: a standby controlfile cannot be included along with a current controlfile
Cause: "current controlfile" was specified along with "standby controlfile".
Action: Remove "current controlfile" or "standby controlfile" from backup specification.
RMAN-06058: a current controlfile cannot be included along with a standby controlfile
Cause: "standby controlfile" was specified along with "current controlfile".
Action: Remove "standby controlfile" or "current controlfile" from backup specification.
RMAN-06059: expected archived log not found, lost of archived log compromises recoverability
Cause: The archived log was not found. The repository thinks it does exist. If the archived log has in fact been lost and there is no backup, then the database is no longer recoverable across the point in time covered by the archived log. This may occur because the archived log was removed by an outside utility without updating the repository.
Action: If the archived log has been removed with an outside utility and the archivelog has already been backed up, then you can synchronize the repository by running CROSSCHECK ARCHIVELOG ALL. If the archivelog has not been previously backed up, then you should take a full backup of the database and archivelogs to preserve recoverability. Previous backups are not fully recoverable.
RMAN-06060: WARNING: skipping datafile compromises tablespace string recoverability
Cause: SKIP INACCESSIBLE or SKIP OFFLINE option resulted in skipping datafiles during BACKUP. If the datafile has in fact been lost and there is no backup, then the tablespace is no longer recoverable without ALL archive logs since datafile creation. This may occur because the datafile was deleted by an outside utility or the datafile is made OFFLINE [DROP].
Action: If there is no backup of skipped datafiles and the tablespace has to be recoverable without ALL archive logs since datafile creation, then you should make these datafiles available for backup.
RMAN-06061: WARNING: skipping archivelog compromises recoverability
Cause: SKIP INACCESSIBLE option resulted in skipping archivelogs during BACKUP. If the archived log has in fact been lost and there is no backup, then the database is no longer recoverable across the point in time covered by the archived log. This may occur because archived log was removed by an outside utility without updating the repository.
Action: If the archived log has been removed with an outside utility and the archivelog has already been backed up, then you can synchronize the repository by running CROSSCHECK ARCHIVELOG ALL. If the archivelog has not been previously backed up, then you should take a full backup of the database and archivelogs to preserve recoverability. Previous backups are not fully recoverable.
RMAN-06062: can not backup SPFILE because the instance was not started with SPFILE
Cause: A backup command requested a backup of the SPFILE, but no SPFILE was used to startup the instance.
Action: Create an SPFILE and re-start the instance using the SPFILE or modify the command.
RMAN-06063: DBID is not found in the recovery catalog
Cause: DBID is not found in the recovery catalog.
Action: Verify that the DBID is correct and restart the command.
RMAN-06064: creating datafile fno=string name=string
Cause: RESTORE/RECOVER command was issued and there were no backup available for the datafile.
Action: informational message
RMAN-06065: The backup operand [string] conflicts with another specified operand.
Cause: The user attempted to use two (or more) conflicting operands within the same statement.
Action: Remove one or both of the conflicting operands.
RMAN-06066: the target database must be mounted when issuing a RECOVER command
Cause: A RECOVER command was issued, but the target database controlfile is not mounted.
Action: Mount the target database controlfile by issuing ALTER DATABASE MOUNT via Enterprise Manager or Server Manager.
RMAN-06067: RECOVER DATABASE required with a backup or created controlfile
Cause: The controlfile has been restored from a backup or was created via ALTER DATABASE CREATE CONTROLFILE.
Action: Use the RECOVER DATABASE command to perform the recovery.
RMAN-06068: recovery aborted because of missing datafiles
Cause: This error should be accompanied by one or more instances of message ORA-06094.
Action: Refer to message ORA-06094.
RMAN-06069: the filename for datafile string is missing in the controlfile
Cause: Media recovery of a backup controlfile added this datafile to the controlfile, but it does not set the filename because that is unsafe.
Action: If the datafile is on disk, then issue ALTER DATABASE RENAME to correct the controlfile. Otherwise, RESTORE the datafile, and then use SWITCH to make it known to the controlfile. If the tablespace containing this datafile will be dropped, then reissue the RECOVER command with a SKIP clause to skip recovery of this tablespace.
RMAN-06070: DBWR could not identify datafile string
Cause: DBWR could not find the specified datafile.
Action: Ensure that the datafile exists and is accessible.
RMAN-06071: could not open datafile string
Cause: An error was encountered when trying to open the specified datafile.
Action: Ensure that the datafile exists and is accessible.
RMAN-06073: file header is corrupt for datafile string
Cause: ORACLE detected a corruption in the file header. A media failure has probably occurred.
Action: RESTORE the datafile to a new location, then do a SWITCH, and then retry the RECOVER command.
RMAN-06074: file string is not an ORACLE datafile
Cause: The file header indicates that this file is not a datafile. The file may have been overlaid or corrupted.
Action: RESTORE the datafile to a new location, then do a SWITCH, and then retry the RECOVER command.
RMAN-06075: datafile string does not belong to this database
Cause: The file header indicates that this file belongs to some other ORACLE database.
Action: RESTORE the datafile to a new location, then do a SWITCH, and then retry the RECOVER command.
RMAN-06076: datafile string contains wrong datafile
Cause: The datafile header indicates the file contains a different datafile number.
Action: RESTORE the datafile, and then retry the RECOVER command.
RMAN-06077: datafile string is a different version than contained in the controlfile
Cause: The controlfile entry for this datafile specifies a different version of this datafile. Different versions of a datafile can exist when a tablespace is dropped, and a new tablespace is created which reuses the same datafile numbers.
Action: If the datafile is correct, the fix the controlfile by using the SWITCH command. Otherwise, RESTORE the correct version of this datafile and retry the RECOVER command.
RMAN-06078: the controlfile is older than datafile string
Cause: The controlfile appears to be older than the specified datafile, but it is not marked as a backup controlfile. This indicates that the controlfile has been replaced with an older version. This error does not occur when a backup controlfile which was created via Recovyer Manager or the ALTER DATABASE BACKUP CONTROLFILE command is restored because such controlfiles are marked as backups.
Action: RESTORE a controlfile and perform RECOVER DATABASE.
RMAN-06079: database must be mounted to perform recovery
Cause: A RECOVER command was issued, but the target database is not mounted.
Action: Issue ALTER DATABASE MOUNT.
RMAN-06080: SWITCH required for datafile string
Cause: The controlfile record for this datafile is for an older incarnation of the datafile. A SWITCH command must be issued to update the controlfile before doing RECOVER.
Action: Issue SWITCH command then retry RECOVER.
RMAN-06081: error reading datafile header for datafile string, code string
Cause: X$KCVFH returned the specified code in the hxerr column when it was queried for the specified datafile.
Action: Ensure the datafile exists and is readable. Using a newer release of Recovery Manager may return a more meaningful error message. If you have no newer version of Recovery Manager, contact Oracle Customer Support.
RMAN-06082: datafilecopy tag string is ambiguous
Cause: The specified tag refers to multiple datafile copies belonging to different datafiles.
Action: Specify the datafilecopy by filename rather than by tag.
RMAN-06083: error when loading stored script string
Cause: The recovery catalog database returned an error. This error explains the cause of the problem.
Action: Correct the problem and retry.
RMAN-06084: the target database may not be mounted when issuing REPLICATE
Cause: A REPLICATE command was issued, but the target database is already mounted.
Action: dismount the target database controlfile by issuing ALTER DATABASE CLOSE and ALTER DATABASE DISMOUNT via Enterprise Manager or Server Manager.
RMAN-06085: must use SET NEWNAME command to restore datafile string
Cause: A RESTORE command for the specified datafile could not find a destination name for the specified datafile.
Action: Add a SET NEWNAME command prior to the RESTORE command to specify the restore destination for this file.
RMAN-06086: offline files may only be skipped in a datafile backup set
Cause: The SKIP OFFLINE option was specified for an archive log backup set.
Action: Use this option only for datafile backup sets.
RMAN-06087: read-only files may only be skipped in a datafile backup set
Cause: The SKIP READONLY option was specified for an archive log backup set.
Action: Use this option only for datafile backup sets.
RMAN-06088: datafile copy string not found or out of sync with catalog
Cause: The indicated file is not found, or is found but is not the same file that the recovery catalog thinks it is. It is likely that some operation outside of Recovery Manager has altered the file, or that Recovery Manager has not resynced with the target database.
Action: Re-catalog the file and retry the operation.
RMAN-06089: archived log string not found or out of sync with catalog
Cause: The indicated file is not found, or is found but is not the same file that the recovery catalog thinks it is. It is likely that some operation outside of Recovery Manager has altered the file, or that Recovery Manager has not resynced with the target database.
Action: Re-catalog the file and retry the operation.
RMAN-06090: error while looking up controlfile copy: string
Cause: An error occurred while looking up the specified controlfile copy in the recovery catalog or target database controlfile.
Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the filename is entered correctly. If the controlfile copy was created when the recovery catalog was not available, then a RESYNC CATALOG must be done to update the recovery catalog.
RMAN-06091: no channel allocated for maintenance (of an appropriate type)
Cause: A command was entered that requires a maintenance channel, and no maintenance channel is allocated, or none of the appropriate type.
Action: Use ALLOCATE CHANNEL FOR MAINTENANCE before deleting backup pieces, or using the CROSSCHECK or DELETE EXPIRED commands. Proxy copies require a non-DISK channel.
RMAN-06092: error while looking up backup piece
Cause: An error occurred while looking up the specified backup piece in the recovery catalog or target database controlfile.
Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the name or key is entered correctly. If the backup piece was created when the recovery catalog was not available, then a RESYNC CATALOG must be done to update the recovery catalog.
RMAN-06093: recovery catalog contains obsolete version of datafile string
Cause: The specified datafile number was dropped and then reused. The controlfile mounted by the target database contains the newer version of the datafile, but the recovery catalog contains information about only the older version.
Action: Issue a RESYNC command to update the recovery catalog, then reissue the failing command. If the error persists, contact Oracle Customer Support.
RMAN-06094: datafile string must be restored
Cause: A RECOVER command was issued, and the recovery catalog indicates the specified datafile should be part of the recovery, but this datafile is not listed in the controlfile, and cannot be found on disk.
Action: Issue a RESTORE command for this datafile, using the same UNTIL clause specified to the RECOVER command (if any), then reissue the RECOVER.
RMAN-06095: a backup controlfile must be restored to recover datafile string
Cause: The controfile currently mounted by the target database contains a newer incarnation of the datafile than the recovery catalog indicates is appropriate for the point-in-time being recovered to.
Action: Restore the controlfile, using the same UNTIL clause specified on the failing RECOVER command, then reissue the command. If no controlfile can be restored, then you should issue a CREATE CONTROLFILE command.
RMAN-06096: SWITCH required for newname of datafile string to take effect
Cause: A SET NEWNAME was issued for this datafile, but no SWITCH command was issued before the RECOVER command.
Action: Issue a SWITCH command to make the newname take effect before doing RECOVER.
RMAN-06098: the target database must be mounted when issuing a BACKUP command
Cause: A BACKUP command was issued, but the target database controlfile is not mounted.
Action: Mount the target database controlfile by issuing ALTER DATABASE MOUNT via Enterprise Manager or Server Manager.
RMAN-06099: error occurred in source file: string, line: number
Cause: See accompanying error
Action: See accompanying error
RMAN-06100: no channel to restore a backup or copy of datafile number
Cause: A datafile, tablespace, or database restore could not proceed because the backup of the indicated file exists on a device type that was not allocated for restore.
Action: None - this is an informational message. See message 6026 for further details.
RMAN-06101: no channel to restore a backup or copy of the controlfile
Cause: A controlfile restore could not proceed because the backup of the indicated file exists on a device type that was not allocated for restore.
Action: None - this is an informational message. See message 6026 for further details.
RMAN-06102: no channel to restore a backup or copy of log thread number seq number lowscn string
Cause: An archive log restore restore could not proceed because the backup of the indicated file exists on a device type that was not allocated for restore.
Action: None - this is an informational message. See message 6026 for further details.
RMAN-06103: duplicate qualifier found in REPORT command: string
Cause: The indicated qualifier appears more than once in a REPORT qualifier list.
Action: delete the duplicate qualifier
RMAN-06105: duplicate qualifier found in LIST command: string
Cause: The indicated qualifier appears more than once in a LIST qualifier list.
Action: delete the duplicate qualifier
RMAN-06106: this command requires that target database be mounted
Cause: A command was issued that requires the target database to be mounted, but the target database is not mounted.
Action: Mount the target database controlfile by issuing ALTER DATABASE MOUNT via Enterprise Manager or Server Manager.
RMAN-06107: WARNING: controlfile is not current for REPORT NEED BACKUP DAYS
Cause: The REPORT NEED BACKUP DAYS command may report some files as requiring backups when they really do not, because the most current online status of the file is not known unless a current controlfile is mounted.
Action: no action required, however, a current controlfile should be mounted, if possible, to get the most accurate REPORT output.
RMAN-06108: changed datafile copy unvailable
Cause: informational message
Action: no action required
RMAN-06109: changed archive log unavailable
Cause: informational message
Action: no action required
RMAN-06110: changed controlfile copy unavailable
Cause: informational message
Action: no action required
RMAN-06111: changed backup piece unavailable
Cause: informational message
Action: no action required
RMAN-06112: changed datafile copy available
Cause: informational message
Action: no action required
RMAN-06113: changed archive log available
Cause: informational message
Action: no action required
RMAN-06114: changed controlfile copy available
Cause: informational message
Action: no action required
RMAN-06115: changed backup piece available
Cause: informational message
Action: no action required
RMAN-06116: cannot crosscheck unavailable object
Cause: An attempt was made to crosscheck an object which is unavailable.
Action: Make object available and try again or don't crosscheck object.
RMAN-06117: cannot do DELETE EXPIRED on an object which is not expired
Cause: An attempte was made to DELETE EXPIRED an object which is not expired.
Action: Remove EXPIRED keyword, crosscheck object, or don't delete object.
RMAN-06118: a backup controlfile older than SCN string must be used for this recovery
Cause: An attempt was made to recover the database, but some files had no backup, and were not present in the control file at the beginning of the restore. This happens when the control file used during the recovery is a backup control file taken before the creation of some of the files that had no backup. In this situation, the control file that is used must be taken before the creation of all files that have no backup. This will enable RMAN to automatically re-create all of the files that had no backup.
Action: Restore a controlfile that was backed up before the specified SCN. The following RMAN commands can be used to do this: SET UNTIL SCN <x>;(where <x> is the SCN displayed in the message) RESTORE CONTROLFILE;
RMAN-06119: uncataloged datafile copy
Cause: informational message
Action: no action required
RMAN-06120: uncataloged archive log
Cause: informational message
Action: no action required
RMAN-06121: uncataloged controlfile copy
Cause: informational message
Action: no action required
RMAN-06122: CHANGE .. UNCATALOG not supported for BACKUPSET
Cause: The CHANGE BACKUPSET .. UNCATALOG command was entered. The UNCATALOG operation is not supported with backup set.
Action: Use CHANGE BACKUPSET .. DELETE instead.
RMAN-06123: operation not supported without the recovery catalog or mounted controlfile
Cause: A command was used which requires a connection to a recovery catalog database or the target database to be mounted. The command cannot be used when no backup repository is available.
Action: If a recovery catalog database is available, then connect to the recovery catalog and retry the command, otherwise enter a different command.
RMAN-06124: error while looking up datafilecopy key: number
Cause: An error occurred while looking up the specified datafilecopy key in the recovery catalog.
Action: This error is accompanied by other errors describing the reason for the failure.
RMAN-06125: error while looking up archive log key: number
Cause: An error occurred while looking up the specified archive log key in the recovery catalog.
Action: This error is accompanied by other errors describing the reason for the failure.
RMAN-06126: skipping offline file string
Cause: The indicated file will not be included in the backup set because it is offline and the SKIP OFFLINE option was specified.
Action: no action required
RMAN-06127: skipping read-only file string
Cause: The indicated file will not be included in the backup set because it is read only and the SKIP READONLY option was specified.
Action: no action required
RMAN-06128: skipping inaccessible file string
Cause: The indicated file will not be included in the backup set because it could not be read, and the SKIP INACCESSIBLE option was specified.
Action: no action required
RMAN-06129: invalid reserved channel ID: string
Cause: The specified channel id is invalid. DELETE and DEFAULT are reserved channel names and may not be specified by users.
Action: Specify a different channel ID.
RMAN-06131: skip offline/readonly only allowed with current controlfile
Cause: The SKIP OFFLINE and SKIP READONLY options are only permitted when the target database controlfile is current. When the target controlfile is not current, it is not possible to obtain a datafile's offline/readonly status.
Action: Remove the skip option or mount a current controlfile on the target database.
RMAN-06132: cannot backup datafile string because it is not in the controlfile
Cause: A backup command was issued that includes the specified datafile, but the datafile is not listed in the controlfile. The controlfile is not current (it is a backup or a created controlfile).
Action: Recover the controlfile to make it current, then retry the backup command.
RMAN-06133: recovery catalog may have obsolete data for datafile string
Cause: A RESTORE UNTIL was issued, and the recovery catalog choose an older incarnation of the datafile than is listed in the controlfile.
Action: If the recovery catalog has correct data for the datafile, then restore a backup controlfile using the same UNTIL clause, then retry the datafile restore. Otherwise, restore a backup of the incarnation of the datafile listed in the controlfile.
RMAN-06134: host command complete
Cause: An operating system command has completed.
Action: None - this is an informational message.
RMAN-06135: error executing host command: string
Cause: A host command returned a non-zero return code.
Action: Correct the offending command.
RMAN-06136: ORACLE error from auxiliary database: string
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-06137: must have recovery catalog for REPORT SCHEMA AT TIME
Cause: A 'REPORT SCHEMA at_clause' command was issued, but there is no recovery catalog database.
Action: If you are not using a recovery catalog, then you may only issue the 'REPORT SCHEMA' command with no at_clause.
RMAN-06138: controlfile not mounted - must specify AT clause with REPORT command
Cause: A 'REPORT SCHEMA' with no at_clause was issued, and there is no recovery catalog, and there is also no controlfile mounted at the target database, so there is no place to get the information about the current list of files comprising the database.
Action: Use a recovery catalog or mount a controlfile at the target database.
RMAN-06139: WARNING: controlfile is not current for REPORT SCHEMA
Cause: A 'REPORT SCHEMA' with no at_clause was issued, and there is no recovery catalog, and the controlfile mounted by the target instance is not current, so the information about the current list of datafiles may not be current.
Action: Use a recovery catalog or mount a current controlfile.
RMAN-06140: cannot specify TAG option with LIST INCARNATION
Cause: The TAG option was specified with LIST INCARNATION. This is not permitted because there is no TAG associated with a database incarnation.
Action: Remove the TAG option and re-run the LIST command.
RMAN-06141: cannot specify ARCHIVELOG LIKE option with RESTORE
Cause: The ARCHIVELOG LIKE option was specified with RESTORE. This is not permitted because recovery catalog contains only those records that are not deleted from disk.
Action: Remove the ARCHIVELOG LIKE option and re-run the command.
RMAN-06142: DEVICE TYPE cannot be specified with this command
Cause: The DEVICE TYPE option was specified with a command that does not support it.
Action: Remove the DEVICE TYPE option and re-run the command.
RMAN-06143: LIKE may only be specified with COPY
Cause: The LIKE option was specified with a RMAN command. This is not permitted because only copies of datafiles, controlfiles or archive logs have file names that may be tested with a LIKE operand.
Action: Remove the LIKE option and re-run the RMAN command.
RMAN-06144: FROM or UNTIL may not be specified with LIST INCARNATION
Cause: The FROM or UNTIL option was specified with LIST INCARNATION. This is not permitted because there is no time associated with a database incarnation.
Action: Remove the FROM or UNTIL option and re-run the LIST command.
RMAN-06145: controlfile is not current - obsolete file list may be incomplete
Cause: A CHANGE or REPORT command needs to compute the list of backups that are redundant and may be deleted. If the mounted controlfile is not current, it may not be possible to determine if a satisfactory backup exists for files which have been offline since the last OPEN RESETLOGS.
Action: No action need be taken - this is an informational message only. To ensure a complete report of obsolete backups, mount a current controlfile.
RMAN-06146: changes found for file number beyond offline SCN
Cause: A CHANGE or REPORT command needs to compute the list of backups that are redundant and may be deleted. A backup was found for a file which is shown as offline in the target database controlfile, but the backup contains changes beyond the SCN when the file went offline. This is most likely because the target database controlfile is not really current, but is a restored copy of an older controlfile.
Action: Mount a current controlfile or a backup controlfile.
RMAN-06147: no obsolete backups found
Cause: A CHANGE or REPORT command could find no files that meet the specified criteria for obsoleteness.
Action: None - this is an informational message.
RMAN-06148: redundancy count must be greater than zero
Cause: The REDUNDANCY operand specified for a CHANGE or REPORT OBSOLETE command was zero.
Action: Specify a REDUNDANCY operand of 1 or greater.
RMAN-06150: auxiliary name for datafile number set to: string
Cause: This message is issued in response to a CONFIGURE AUXNAME command.
Action: None - this is an informational message.
RMAN-06151: datafile string creation scn string
Cause: This is an informational message. It should be accompanied by other messages.
Action: none
RMAN-06153: validation failed for datafile copy
Cause: The CHANGE DATAFILE COPY VALIDATE command found that the datafile copy could not be found or no longer contains the same data, so its record was deleted from the recovery catalog.
Action: None - this is an informational message.
RMAN-06154: validation succeeded for datafile copy
Cause: The CHANGE DATAFILE COPY VALIDATE command found that the datafile copy still matches its data in the recovery catalog.
Action: None - this is an informational message.
RMAN-06155: validation failed for controlfile copy
Cause: The CHANGE CONTROLFILECOPY VALIDATE command found that the controlfile copy could not be found or no longer contains the same data, so its record was deleted from the recovery catalog.
Action: None - this is an informational message.
RMAN-06156: validation succeeded for controlfile copy
Cause: The CHANGE CONTROLFILECOPY VALIDATE command found that the controlfile copy still matches its data in the recovery catalog.
Action: None - this is an informational message.
RMAN-06157: validation failed for archived log
Cause: The CHANGE ARCHIVELOG VALIDATE command found that the archived log could not be found or no longer contains the same data, so its record was deleted from the recovery catalog.
Action: None - this is an informational message.
RMAN-06158: validation succeeded for archived log
Cause: The CHANGE ARCHIVED LOG VALIDATE command found that the archived log still matches its data in the recovery catalog.
Action: None - this is an informational message.
RMAN-06159: error while looking up backup set
Cause: An error occurred while looking up the specified backup set in the recovery catalog or target database controlfile.
Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the key is entered correctly. If the backup set was created when the recovery catalog was not available, then a RESYNC CATALOG must be done to update the recovery catalog.
RMAN-06160: no backup pieces found for backup set key: number
Cause: No backup pieces for the requested backup set were found in the recovery catalog, or the target database controlfile.
Action: Specify an existing backup set.
RMAN-06161: error when inspecting auxiliary filename: string
Cause: This error is accompanied by other errors explaining the cause.
Action: Correct the auxiliary filename if it is wrong via the CONFIGURE AUXNAME command.
RMAN-06162: sql statement: string
Cause: This is the sql statement about to be executed for a SQL command.
Action: None, informational message only.
RMAN-06163: some datafiles cannot be recovered, aborting the RECOVER command
Cause: This message should be followed by one or more 6162 or 6164 messages.
Action: Check the accompanying errors.
RMAN-06164: WARNING: no channel of required type allocated to recover datafile number
Cause: A RECOVER command could not proceed because incremental backup sets or archive log backup sets exist on a device type that has not been allocated.
Action: Use the LIST command to determine which device type is needed, then allocate a channel of that type.
RMAN-06165: datafile string is too old to recover, restore a more recent copy
Cause: The archived logs and/or incremental backup sets required to recover the datafile do not exist, but a more recent backup of the datafile exists which can be recovered.
Action: Issue a RESTORE for the datafile, then reissue the RECOVER command.
RMAN-06166: datafile string cannot be recovered
Cause: Incremental backups or archived redo logs needed to recover the datafile cannot be found, and no recoverable full backup or datafile copy exists.
Action: Use the LIST command to see if there is a backup set or datafile copy that can be made AVAILABLE. If not, then the datafile is unrecoverable. If a full or datafile copy exists, then a point-in-time recovery may be possible.
RMAN-06167: already connected
Cause: a CONNECT command was issued, but RMAN is already connected to the specified database.
Action: RMAN has no DISCONNECT command, so to connect to a different instance, exit RMAN and start it again.
RMAN-06168: no backup pieces with this tag found: string
Cause: A tag was used to specify a list of backup pieces, but no backup pieces with this tag could be found.
Action: Make sure the tag is specified correctly.
RMAN-06169: could not read file header for datafile string error reason string
Cause: The specified datafile could not be accessed. The reason codes are: 1 - filename is MISSINGxx in the controlfile 2 - file is offline 3 - file is not verified 4 - DBWR could not find the file 5 - unable to open file 6 - I/O error during read 7 - file header is corrupt 8 - file is not a datafile 9 - file does not belong to this database 10 - file number is incorrect 12 - wrong file version 15 - controlfile is not current
Action: If the error can be corrected, do so and retry the operation. The SKIP option can be used to ignore this error during a backup.
RMAN-06170: no controlfile copy found with offline range recid string stamp string datafile string
Cause: This offline range is needed for recovering the specified datafile, but the offline range record has aged out of the current controlfile and no controlfile copy with the record could be accessed. At least 1 controlfile copy containing the offline range was found in the recovery catalog and was in AVAILABLE status.
Action: Query the rc_controlfile_copy view for the names of all controlfile copies, then issue a CHANGE CONTROLFILECOPY ... VALIDATE; command for them. Then reissue the RECOVER command.
RMAN-06171: not connected to target database
Cause: A command was issued but no connection to the target database has been established.
Action: Issue a CONNECT TARGET command to connect to the target database.
RMAN-06172: no autobackup found or specified handle is not a valid copy or piece
Cause: A restore could not proceed because no autobackup was found or specified handle is not a valid copy or backup piece. In case of restore from autobackup, it may be the case that a backup exists, but it does not satisfy the criteria specified in the user's restore operands. In case of restore from handle, it may be the handle is not a backup piece or controflile copy. In may be that it does not exist.
Action: Modify autobackup search criteria or verify the handle.
RMAN-06173: no set newname command has been issued for datafile string when restore auxiliary
Cause: Auxiliary type was specified for the controlfile, but no SET NEWNAME command has been previously issued for a datafile.
Action: Issue SET NEWNAME command for every datafile in the recovery set.
RMAN-06174: not connected to auxiliary database
Cause: An auxiliary command was issued but no connection to a auxiliary database has been established.
Action: Issue a CONNECT AUXILIARY command to connect to the auxiliary database.
RMAN-06175: deleted script: string
Cause: A DELETE SCRIPT command was executed.
Action: None, informational message only.
RMAN-06176: no recovery required; all files are readonly or offline
Cause: A RECOVER DATABASE command does not need to recover any files because all of the files to be recovered are offline or read only. This can only occur when the SKIP clause includes the system tablespace.
Action: None, informational message only
RMAN-06177: restore not done; all files readonly, offline, or already restored
Cause: A RESTORE command does not need to restore any files, because all of the files to be restored are offline, read-only, or are already restored to their correct destinations.
Action: None, informational message only
RMAN-06178: datafile number not processed because file is offline
Cause: A RESTORE DATABASE or RECOVER DATABASE command omitted processing the indicated datafile because it is offline clean at the desired point in time.
Action: None, informational message only
RMAN-06179: datafile number not processed because file is read-only
Cause: A RESTORE DATABASE or RECOVER DATABASE command omitted processing the indicated datafile because it is part of a read-only tablespace at the desired point in time.
Action: None, informational message only
RMAN-06180: incremental backups require Enterprise Edition
Cause: A BACKUP command with INCREMENTAL LEVEL > 0 was specified.
Action: Use FULL, or INCREMENTAL LEVEL 0.
RMAN-06181: multiple channels require Enterprise Edition
Cause: Attempt to allocate more than 1 channel in a job.
Action: Remove all except one ALLOCATE CHANNEL command.
RMAN-06182: archive log larger than MAXSETSIZE: thread string seq string string
Cause: A BACKUP ARCHIVELOG command specified the MAXSETSIZE operand too low. The specified archive log is larger than MAXSETSIZE will allow.
Action: Increase MAXSETSIZE limit.
RMAN-06183: datafile or datafilecopy larger than MAXSETSIZE: file# string string
Cause: A BACKUP DATAFILE(copy) command specified the MAXSETSIZE operand too low. The specified datafile is larger than MAXSETSIZE will allow.
Action: Increase MAXSETSIZE limit.
RMAN-06184: duplicate object in backup specifier: string string
Cause: A backup command specifies the same datafile or copy of a datafile multiple times.
Action: Eliminate the duplicates.
RMAN-06185: Recovery Manager incompatible with string database: RMAN number.number.number to number.number.number required
Cause: This version of recovery manager is incompatible with the indicated database or the dbms_backup_restore package installed in the indicated database.
Action: If the database has been upgraded from an earlier version, ensure that the catxxxx.sql script has been run successfully. Re-install dbmsbkrs.sql and prvtbkrs.plb if necessary. Otherwise, use a version of RMAN within the range specified in the error message.
RMAN-06186: PL/SQL package string.string version string in string database is too old
Cause: The specified PL/SQL package is a version that is too old to work with this version of the Recovery Manager (RMAN).
Action: If the database indicated is CATALOG, then you can use the UPGRADE CATALOG command to upgrade the recovery catalog to the most current version. If the database is TARGET or AUXILIARY, then you must either upgrade the specified database or use an older version of RMAN.
RMAN-06187: controlfile copy string not found or out of sync with catalog
Cause: The indicated file is not found, or is found but is not the same file that the recovery catalog thinks it is. It is likely that some operation outside of Recovery Manager has altered the file, or that Recovery Manager has not resynced with the target database.
Action: Re-catalog the file and retry the operation.
RMAN-06188: cannot use command when connected to a mounted target database
Cause: An attempt was made to issue a command that can be used only when there is no connection to the target database or when the target database is not mounted.
Action: Dismount the database or restart RMAN and use the command before connecting to the target database.
RMAN-06189: current DBID number does not match target mounted database (number)
Cause: SET DBID was used to set a DBID that does not match the DBID of the database to which RMAN is connected.
Action: If the current operation is a restore to copy the database, do not mount the database. Otherwise, avoid using the SET DBID command, or restart RMAN.
RMAN-06190: PL/SQL package string.string version string in string database is not current
Cause: RMAN detected an old version of the specified package. RMAN will execute in backwards-compatible mode.
Action: No action is required, but certain features and bug-fixes may not be available when RMAN runs in backwards-compatible mode. If the database is CATALOG, then you can use the UPGRADE CATALOG command to upgrade the recovery catalog to the most current version. If the database is TARGET or AUXILIARY, then you must either upgrade the specified database or use an older version of RMAN. The files that must be run to upgrade the target or auxiliary database are dbmsrman.sql and prvtrman.plb.
RMAN-06191: PL/SQL package string.string version string in string database is too new
Cause: RMAN detected an incompatible version of the specified package.
Action: Use a newer version of recovery manager. Message 6439 indicates the minimum required version of recovery manager.
RMAN-06192: maximum value for MAXPIECESIZE or MAXSETSIZE must be between 1 Kb and 2048 Gb
Cause: Input size for MAXPIECESIZE or MAXSETSIZE was out of range.
Action: Specify a valid size and retry the command.
RMAN-06193: connected to target database (not started)
Cause: informational message
Action: The database must be started before any other RMAN commands are issued.
RMAN-06194: target database instance not started
Cause: A command was issued that requires the target database instance be started.
Action: Issue a STARTUP command to start the instance.
RMAN-06195: auxiliary database not started
Cause: A command was issued that requires the auxiliary database instance be started.
Action: Issue a STARTUP AUXILIARY command.
RMAN-06196: Oracle instance started
Cause: A STARTUP command completed successfully.
Action: None, this is an informational message.
RMAN-06197: Total System Global Area string bytes
Cause: informational message
Action: no action required
RMAN-06198: %-24s string bytes
Cause: informational message
Action: no action required
RMAN-06199: database mounted
Cause: informational message
Action: no action required
RMAN-06200: Changed string objects to AVAILABLE status
Cause: informational message
Action: no action required
RMAN-06201: Deleted string objects
Cause: informational message
Action: no action required
RMAN-06202: Deleted string EXPIRED objects
Cause: informational message
Action: no action required
RMAN-06203: Changed KEEP options for string objects
Cause: informational message
Action: no action required
RMAN-06204: Changed string objects to UNAVAILABLE status
Cause: informational message
Action: no action required
RMAN-06205: Uncataloged string objects
Cause: informational message
Action: no action required
RMAN-06206: Crosschecked string objects
Cause: informational message
Action: no action required
RMAN-06207: WARNING: string objects could not be deleted for string channel(s) due
Cause: informational message
Action: no action required
RMAN-06208: to mismatched status. Use CROSSCHECK command to fix status
Cause: informational message
Action: no action required
RMAN-06209: List of failed objects
Cause: informational message
Action: no action required
RMAN-06210: List of Mismatched objects
Cause: informational message
Action: no action required
RMAN-06211: ==========================
Cause: informational message
Action: no action required
RMAN-06212: Object Type Filename/Handle
Cause: informational message
Action: no action required
RMAN-06213: --------------- ---------------------------------------------------
Cause: informational message
Action: no action required
RMAN-06214: %-15s string
Cause: informational message
Action: no action required
RMAN-06220: Creating automatic instance
Cause: No connection to the auxiliary instance was provided, but the command requires an auxiliary instance.
Action: no action required unless you want to create a permanent database, in which case you should stop the command and re-run it, providing an auxiliary instance connection.
RMAN-06221: Removing automatic instance
Cause: RMAN is removing the automatic auxiliary instance that was created for this command.
Action: no action required
RMAN-06223: starting up automatic instance string
Cause: informational message
Action: no action required
RMAN-06224: Automatic instance created
Cause: informational message
Action: no action required
RMAN-06225: shuting down automatic instance string
Cause: informational message
Action: no action required
RMAN-06226: Automatic instance removed
Cause: informational message
Action: no action required
RMAN-06230: List of Stored Scripts in Recovery Catalog
Cause: This message is issued in response to a LIST SCRIPT NAMES command. The following fields are shown for each script that is stored in the recovery catalog: Header indicating to what database the script belongs. Script Name: name of the script. Description: comment associated with this script.
Action: no action required
RMAN-06246: List of Database Incarnations
Cause: This message is issued in response to a LIST INCARNATION OF DATABASE command. The following fields are shown for each database that is registered with the recovery catalog: DB Key: This is the unique key which identifies this database in the recovery catalog. Inc Key: This is the unique key which identifies this incarnation of the database in the recovery catalog. DB Name: The name of the database. DB ID: The database ID. This is a number which remains the same for the life of the database, even if the database name is changed. Status: 'YES' if this is the current incarnation of this database, otherwise 'NO'. Reset SCN: SCN of the most recent resetlogs operation. Reset Time: Time of the most recent resetlogs operation.
Action: no action required
RMAN-06250: Report of files that need backup due to unrecoverable operations
Cause: An unlogged change (such as 'create table unrecoverable') has been made to this file, and the most recent backup of the file does not contain those changes.
Action: Take a backup of this file. If this file is lost before a backup is taken, then the unlogged modifications will be lost. The message indicates whether a full backup is required or whether a incremental backup will suffice.
RMAN-06263: %-4s string string
Cause: This message is issued in response to the REPORT NEED BACKUP INCREMENTAL command, for those files which would use more than the specified number of incrementals during recovery.
Action: To reduce the number of incremental backups which would be used during recovery of this datafile, take a new full backup of this file now.
RMAN-06270: Report of files whose recovery needs more than number days of archived logs
Cause: This message is issued in response to the REPORT NEED BACKUP DAYS command for those files which need more than the specified number of days' archived logs for recovery.
Action: To reduce the number of log files needed for recovery of this datafile, take a new full or incremental backup now.
RMAN-06280: Report of obsolete backups and copies
Cause: This message is issued in response to the REPORT OBSOLETE command. Each of the files listed is obsolete because it is more redundant than the level of redundancy specified in the REPORT command.
Action: Depending on your needs, you might need to take new backups.
RMAN-06290: Report of database schema
Cause: This message is issued in response to the REPORT SCHEMA command. The report shows the physical schema of the database at the indicated time. The following fields are shown for each datafile: File: The file number. K-bytes: The size of the file. Tablespace: The name of the tablespace which contains this file. RB segs: YES if this file is part of a tablespace containing rollback segments, otherwise NO. Name: The file name.
Action: no action required
RMAN-06300: Report of files with less than number redundant backups
Cause: This message is issued when the REPORT NEED BACKUP REDUNDANCY command is used for those files which have less than the specified number of backups which can be used for recovery.
Action: Take another backup of the datafiles listed.
RMAN-06306: ====================
Cause: This message is issued in response to a LIST BACKUP DATABASE/TABLESPACE/DATAFILE command when some backups were taken with the PROXY option. If a recovery catalog is in use, then the information comes from the recovery catalog, otherwise it comes from the target database control file. The following fields are shown for each proxy datafile backup. Key: This is the unique key which identifies this proxy backup in the recovery catalog. This value can be used in a CHANGE command to change its status. If the target database control file is being used as the recovery catalog, then this field uniquely identifies this copy in the controlfile. File: The file number that this file was copied from. Status: This is the status of the file. Possible values are: A - Available U - Unavailable D - Deleted X - Expired Status 'U' will not be used if the target database controlfile is being used as the recovery catalog. Completion time: This is the date and time when the backup was created. This column will be printed in the default Oracle date format, unless overridden with a NLS_DATE_FORMAT environment variable. Ckp SCN: This is the checkpoint SCN of the backup. The file contains all changes made at or before this SCN. Ckp time: This is the time that the file was last checkpointed. Handle: This is the media manager handle of the proxy backup.
Action: no action required
RMAN-06378: List of Backup Sets
Cause: This message is issued in response to a LIST BACKUP command.
Action: no action required
RMAN-06400: database opened
Cause: informational message
Action: no action required
RMAN-06401: database is already started
Cause: A STARTUP command without the FORCE option was issued, but the target database is already started.
Action: Use the FORCE option if you want to restart the database.
RMAN-06402: Oracle instance shut down
Cause: informational message
Action: no action required
RMAN-06403: could not obtain a fully authorized session
Cause: The most likely cause of this error is that one of the databases to which RMAN had previously connected is not started or has has been shutdown. Other error messages should identify exactly which database is the problem.
Action: Startup the database causing the problem.
RMAN-06404: database dismounted
Cause: informational message
Action: no action required
RMAN-06405: database closed
Cause: informational message
Action: no action required
RMAN-06406: deleted archive log
Cause: informational message
Action: no action required
RMAN-06407: auxiliary instance datafile string deleted
Cause: informational message
Action: no action required
RMAN-06408: recovery catalog upgraded to version string
Cause: This is an informational message issued by the UPGRADE CATALOG command. It indicates the version of the recovery catalog schema to which the recovery catalog was just upgraded. Note that this version number may not reflect the version number of your rman executable or target database, because the recovery catalog schema is not changed with each Oracle release.
Action: no action required
RMAN-06409: LIKE clause in LIST BACKUP OF ARCHIVELOG is not supported
Cause: LIST BACKUP OF ARCHIVELOG LIKE was used, which is not supported.
Action: Remove LIKE clause from command.
RMAN-06410: cannot use command when channels are allocated
Cause: An attempt was made to issue a command that can be used only when there are no allocated channels.
Action: Do not use the command, or de-allocate channels and use the command when no channels are allocated.
RMAN-06411: backup copies setting out of range (1-4): number
Cause: An attempt was made to set backup copies to an invalid value.
Action: Use a value in the specified range.
RMAN-06412: no proxy copy channel found
Cause: A proxy copy was started, but no allocated channel supports proxy copy. This could be because the media management software used by the target database does not support proxy copy, or because all of the allocated channels are of type DISK, which never support proxy copy.
Action: If this is a backup, then either allocate a non-disk channel, or do not use the PROXY option. If this is a restore, then a channel of the same type which created the proxy backup was allocated, but now does not support proxy copy. If proxy copy is no longer supported by the media management software at the target database, the CROSSCHECK or CHANGE commands should be used so that those backups will not be considered for further restores.
RMAN-06413: channel string does not support proxy copy
Cause: The channel which was specified for this backup or restore does not support proxy copy. This could be because the media management software used by the target database does not support proxy copy, or because the channel is of type DISK, which never supports proxy copy.
Action: If this is a backup, then either allocate a non-disk channel, or do not use the PROXY option. If this is a restore, then a channel of the same type which created the proxy backup was allocated, but now does not support proxy copy. If proxy copy is no longer supported by the media management software at the target database, the CROSSCHECK command should be used so that those backups will not be considered for further restores.
RMAN-06414: target database COMPATIBLE option does not support proxy copy
Cause: PROXY was specified, and the target database uses a media manager that supports proxy copy, but the COMPATIBLE initialization parameter of the target database must be 8.1.0 or greater to create proxy backups. If the database is downgraded to the earlier release that is specified in the COMPATIBLE parameter, then it will no longer be able to restore proxy backups.
Action: Either take a non-proxy backup or change the target database COMPATIBLE parameter.
RMAN-06415: file string cannot be proxy backed up
Cause: The PROXY option was specified, but the media management software used by the target database cannot back up the specified file using proxy copy. If PROXY ONLY was specified, then the backup is terminated. If PROXY was specified, then this file will be placed into a non-proxy backup set.
Action: Remove the ONLY option to place the files into a regular backup set, or contact the media management vendor if you believe that the media management software should support proxy copy of this file.
RMAN-06416: PROXY ONLY was specified and some files could not be proxy copied
Cause: PROXY ONLY was specified, and some of the files to be backed up could not be backed up by the media management software used by the target database. Message 6415 is issued for each file that cannot be proxy copied.
Action: Remove the ONLY option to place the files into a regular backup set, or contact the media management vendor if you believe that the media management software should support proxy copy of these files.
RMAN-06418: proxy incremental backups with level > 0 not supported
Cause: PROXY was specified for a non-level-zero incremental backup. Proxy backups may only be full or level 0 backups.
Action: Remove one of the conflicting options.
RMAN-06419: file string cannot be proxy restored from handle string
Cause: The media management software used by the target database indicated that it cannot restore the specified file from the specified backup handle.
Action: Consult the media management software documentation to find out why this restriction exists or contact the media management vendor.
RMAN-06420: some files could not be proxy restored - aborting restore
Cause: Some of the files to be restored could not be restored by the media management software used by the target database. Message 6419 is issued for each file that cannot be restored.
Action: Contact the media management vendor if you believe that the media management software should support proxy copy of these files. The CROSSCHECK or CHANGE commands can be used to remove these proxy copies from the catalog to prevent the RESTORE command from trying to restore from these proxy backups.
RMAN-06421: sent command to channel: string
Cause: informational message
Action: no action required
RMAN-06422: no channels found for SEND command
Cause: No channels with the specified names or device types were found. If no channel qualifiers were specified, then no channels were allocated.
Action: Specify a different channel type or allocate a channel of the desired type.
RMAN-06423: requested limit of number exceeds vendor limit of number
Cause: A SETLIMIT CHANNEL command was used to set the backup piece size limit, but the media management software used by the target database cannot create backup pieces that large.
Action: Specify a smaller backup piece limit.
RMAN-06424: error while looking up proxy copy
Cause: An error occurred while looking up the specified proxy copy in the recovery catalog or target database controlfile.
Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the name or key is entered correctly. If the proxy copy was created when the recovery catalog was not available, then a RESYNC CATALOG must be done to update the recovery catalog.
RMAN-06425: <datafile pathname not available>
Cause: informational message
Action: no action required
RMAN-06426: RECOVERY_CATALOG_OWNER role must be granted to user string
Cause: The CREATE CATALOG or UPGRADE CATALOG command was used, but the userid that was supplied in the CATALOG connect string does not have the RECOVERY_CATALOG_OWNER role granted as a DEFAULT role.
Action: Grant the RECOVERY_CATALOG_OWNER role to the recovery catalog owner.
RMAN-06427: recovery catalog already exists
Cause: The CREATE CATALOG command cannot be used when the recovery catalog already exists.
Action: Use the UPGRADE CATALOG command to upgrade your recovery catalog to the most current release without losing any existing backup data. Use the DROP CATALOG command to remove an existing recovery catalog.
RMAN-06428: recovery catalog is not installed
Cause: A recovery catalog database connection has been made, but the recovery catalog tables and views have not been installed.
Action: If you mis-typed the recovery catalog owner userid, then correct the userid and reconnect to the recovery catalog. If this is the first time that you have signed on to Recovery Manager with this recovery catalog owner userid, then use the CREATE CATALOG command to create the recovery catalog schema.
RMAN-06429: %s database is not compatible with this version of RMAN
Cause: The indicated database is not compatible with this version of the Recovery Manager (RMAN). Other messages have also been issued which detail the cause of the error.
Action: See the other messages. If the database is CATALOG, then you may be able to use the CREATE CATALOG or UPGRADE CATALOG commands to correct the problem. If the database is TARGET or AUXILIARY, then you must either upgrade the target database or use a newer version of the RMAN executable.
RMAN-06430: recovery catalog userid cannot be SYS
Cause: A recovery catalog connection was made to userid SYS. The recovery catalog must be created in a userid other than SYS.
Action: Specify a different userid in the CATALOG connect string.
RMAN-06431: recovery catalog created
Cause: This is an informational message issued by the CREATE CATALOG command.
Action: no action required
RMAN-06432: recovery catalog dropped
Cause: This is an informational message issued by the DROP CATALOG command.
Action: no action required
RMAN-06433: error installing recovery catalog
Cause: An error was received from the recovery catalog database while it was being installed. Another error message shows the error message from the server.
Action: The most common reasons for failure to install the recovery catalog are:

- Lack of space in the recovery catalog database: allocate more space, use the DROP CATALOG command to remove any partially installed recovery catalog, and retry the command.

- Object already exists: This is caused by a partial recovery catalog installation. Use the DROP CATALOG command to remove the partially installed recovery catalog and retry the command.

RMAN-06434: some errors occurred while removing recovery catalog
Cause: Some errors were received from the recovery catalog database while removing the recovery catalog.
Action: Correct the error(s) and retry the command. Note that the Recovery Manager intercepts and ignores common errors, such as 'object not found', which can happen while removing a partially installed recovery catalog. Only serious errors will be displayed while removing the recovery catalog.
RMAN-06435: recovery catalog owner is string
Cause: This is an informational message issued by the UPGRADE CATALOG and DROP CATALOG commands.
Action: no action required
RMAN-06436: enter DROP CATALOG command again to confirm catalog removal
Cause: The DROP CATALOG command deletes the recovery catalog, rendering all database backups unusable, and should be used with care. The command must be entered twice to ensure that this is really what you want to do.
Action: If you really want to remove the recovery catalog, then enter the DROP CATALOG command again.
RMAN-06437: cannot drop catalog - catalog is newer than this RMAN
Cause: The DROP CATALOG command was entered, but the recovery catalog was created by a newer version of the Recovery Manager (RMAN). This version of RMAN may not be able to drop the entire recovery catalog.
Action: Use the version of RMAN which most recently created or upgraded the recovery catalog.
RMAN-06438: error executing package DBMS_RCVMAN in string database
Cause: Recovery Manager requires the DBMS_RCVMAN package in the SYS schema of the indicated database. Normally this package is installed during database creation. To re-create the package, run the files dbmsrman.sql and prvtrmns.plb.
Action: re-create the DBMS_RCVMAN package in the SYS schema.
RMAN-06439: RMAN must be upgraded to version string to work with this package
Cause: This message indicates the minimum version of recovery manager required to use the package which was specified in message 6191.
Action: A newer version of RMAN must be used with this package.
RMAN-06441: cannot upgrade catalog - catalog is already newer than this RMAN
Cause: The recovery catalog is already at a version level that is greater than this version of the Recovery Manager. The UPGRADE CATALOG command is not needed.
Action: Either upgrade to a more recent Recovery Manager, or continue to use the current version. Message 6191 will be issued if the recovery catalog is too new to work with this version of Recovery Manager.
RMAN-06442: enter UPGRADE CATALOG command again to confirm catalog upgrade
Cause: The UPGRADE CATALOG command alters the recovery catalog schema. Although the recovery catalog is designed to be compatible with older versions of the Recovery Manager (RMAN), it is possible that an upgrade will remove support for older versions of RMAN.
Action: If you really want to upgrade the recovery catalog, then enter the UPGRADE CATALOG command again. If you are not going to use an older version of RMAN with this recovery catalog, then compatibility is not an issue. If you plan to also continue using an older version of RMAN with this recovery catalog then, before upgrading, consult the Migration Guide for the current Oracle release to determine if upgrading to the current version of the recovery catalog will remove support for older versions of RMAN.
RMAN-06443: error upgrading recovery catalog
Cause: An error was received from the recovery catalog database while upgrading the recovery catalog.
Action: Correct the error and retry the command. Note that the Recovery Manager intercepts and ignores common errors, such as 'column already exists,' which can happen if the recovery catalog has already been partially upgraded. Only serious errors will be displayed while upgrading the recovery catalog.
RMAN-06444: %s created with compilation errors
Cause: During the CREATE CATALOG or UPGRADE CATALOG command, the indicated PL/SQL package specification or body could not be created because of PL/SQL compilation errors.
Action: The PL/SQL packages used by the recovery catalog are located in the RECOVER.BSQ library file, and should never be modified. Make sure that the RECOVER.BSQ file has not been modified or damaged, and then if this error persists, contact Oracle support. Connect to the recovery catalog owner and query the USER_ERRORS view to find out the details of the compilation errors.
RMAN-06445: cannot connect to recovery catalog after NOCATALOG has been used
Cause: The CONNECT CATALOG command was used after the user had already specified the NOCATALOG option.
Action: Re-start rman if you wish to use a recovery catalog.
RMAN-06446: changed proxy copy unavailable
Cause: informational message
Action: no action required
RMAN-06447: changed proxy copy available
Cause: informational message
Action: no action required
RMAN-06448: uncataloged proxy copy
Cause: informational message
Action: no action required
RMAN-06449: deleted proxy copy
Cause: informational message
Action: no action required
RMAN-06450: crosschecked proxy copy: found to be 'string'
Cause: informational message
Action: no action required
RMAN-06451: proxy copy handle=string recid=string stamp=string
Cause: informational message
Action: no action required
RMAN-06452: %s package upgraded to version string
Cause: This is an informational message issued by the UPGRADE CATALOG command. It indicates the version to which the indicated package was just upgraded. Note that this version number may not reflect the version number of your rman executable or target database, because the recovery catalog packages are not changed with each Oracle release.
Action: no action required
RMAN-06453: RECOVERABLE may only be used with datafile objects
Cause: An attempt was made to use LIST ... RECOVERABLE .. with OF CONTROLFILE or OF ARCHIVELOG.
Action: Remove the RECOVERABLE keyword and try again.
RMAN-06454: duplexed backups require Enterprise Edition
Cause: The SET COPIES or CONFIGURE BACKUP COPIES command was used to create more than one copy of each backup piece, but Enterprise Edition is not installed.
Action: Do not attempt to create more than one copy of each backup piece.
RMAN-06455: point-in-time tablespace recovery requires Enterprise Edition
Cause: A point-in-time tablespace recovery was attempted, but Enterprise Edition is not installed.
Action: Do not do point-in-time tablespace recovery.
RMAN-06456: command is obsolete
Cause: informational message
Action: no action required
RMAN-06457: UNTIL scn (string) is ahead of last scn in archived logs (string)
Cause: UNTIL scn cannot be more than the last scn of the last archived log
Action: Check the UNTIL scn.
RMAN-06458: AS COPY option cannot be used with RECOVERY FILES, RECOVERY AREA or DB_RECOVERY_FILE_DEST
Cause: The RECOVERY FILES, RECOVERY AREA or DB_RECOVERY_FILE_DEST was specified with AS COPY.
Action: Remove the AS COPY option and resubmit the command.
RMAN-06459: BACKUP <VALIDATE|DURATION> is not supported with PROXY
Cause: BACKUP <VALIDATE|DURATION> and PROXY were specified in the same backup command.
Action: Remove the incompatible option.
RMAN-06460: Controlfile copy string cannot be backed up by proxy.
Cause: The PROXY option was specified, but proxy copy of controlfile is not supported. This file will be placed into a non-proxy backup set.
Action: No action required. This is an informational message.
RMAN-06461: Current controlfile cannot be backed up by proxy.
Cause: The PROXY option was specified, but proxy copy of controlfile is not supported. This file will be placed into a non-proxy backup set.
Action: No action required. This is an informational message.
RMAN-06462: no backupsets found on device DISK that match specification
Cause: A backupset record specifier did not match an backupset on device DISK in the recovery catalog.
Action: Resubmit the command with a different backupset record specifier. The rman LIST command can be used to display all backupsets that Recovery Manager knows about.
RMAN-06463: Backup set key string cannot be backed up by proxy.
Cause: The PROXY option was specified, but proxy copy of backup set is not supported. This file will be placed into a non-proxy backup set.
Action: No action required. This is an informational message.
RMAN-06464: BACKUP BACKUPSET is not supported with VALIDATE option
Cause: BACKUP BACKUPSET and VALIDATE were specified in the same backup command.
Action: To VALIDATE BACKUPSET use 'validate' or 'restore validate' command.
RMAN-06465: configuration not implemented: string
Cause: The configuration is not implemented in the current release.
Action: Avoid using the command.
RMAN-06466: error parsing configuration string (string)
Cause: Unsupported configuration string is stored in recovery catalog or target database controlfile.
Action: Check compatibility matrix rman executable and target database and recover catalog. Use dbsm_backup_restore.deleteConfig to remove problematic configuration.
RMAN-06467: could not translate DBA: number
Cause: An error was received when calling dbms_rcvman
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-06468: Invalid Data Block Address: number
Cause: The DBA specified doesn't belong to the mentioned tablespace
Action: Check the DBA
RMAN-06469: could not translate corruption list
Cause: An error was received when calling dbms_rcvman
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-06470: DEVICE TYPE is supported only when automatic channels are used
Cause: The DEVICE TYPE option was specified with a BACKUP, RESTORE, RECOVER, DUPLICATE, CHANGE, VALIDATE, CROSSCHECK, or DELETE EXPIRED command. This option is allowed only when automatically allocated channels are used.
Action: Remove the DEVICE TYPE option and re-run the command. Or Remove all ALLOCATE commands and re-run the script so that channels are automatically allocated.
RMAN-06471: no configuration found to allocate channels for string
Cause: Device type configuration was not found in recovery catalog
Action: Setup device type configuration using configure command for required device type
RMAN-06472: channel id string is automatically allocated
Cause: Channel id was used on ALLOCATE/RELEASE command.
Action: Use other channel id that does not belong to reserved channel id's namespace
RMAN-06474: maintenance channels are not allocated
Cause: RELEASE CHANNEL was used without allocating any maintenance channels.
Action: Allocate maintenance channel before executing this command.
RMAN-06475: parallelism setting out of range (1-254): number
Cause: Parallelism for the device type in CONFIGURE PARALLELISM command is out of range
Action: Enter value of parallelism that are within the allowed range.
RMAN-06476: channel number out of range (1-254): number
Cause: Channel number entered in CONFIGURE CHANNEL command is out of range.
Action: Enter channel number within allowed range and retry the command. for this device and retry the command
RMAN-06477: configuration value length exceeds 1024
Cause: CONFIGURE CHANNEL command entered has configuration value greater than 1024 bytes.
Action: Reduce the length of CONFIGURE CHANNEL command options
RMAN-06478: WARNING: datafile copy 'string' cannot be found on disk
Cause: The CHANGE DATAFILECOPY AVAILABLE command was used, but the datafilecopy cannot be found on disk.
Action: If the storage containing the datafilecopy has been removed from the host, restore it and retry the command. If the datafilecopy is permanently gone, then issue the CHANGE DATAFILECOPY DELETE command for this datafile.
RMAN-06479: WARNING: control file copy 'string' cannot be found on disk
Cause: The CHANGE CONTROLFILECOPY AVAILABLE command was used, but the control file copy cannot be found on disk.
Action: If the storage containing the control file copy has been removed from the host, restore it and retry the command. If the control file copy is permanently gone, then issue the CHANGE CONTROLFILECOPY DELETE command for this control file.
RMAN-06480: WARNING: archivelog 'string' cannot be found on disk
Cause: The CHANGE ARCHIVELOG AVAILABLE command was used, but the archivelog cannot be found on disk.
Action: If the storage containing the archivelog has been removed from the host, restore it and retry the command. If the archivelog is permanently gone, then issue the CHANGE ARCHIVELOG DELETE command for this archivelog.
RMAN-06481: WARNING: backup piece 'string' cannot be found on the storage medium
Cause: The CHANGE BACUKPPIECE AVAILABLE command was used, but the backup piece cannot be found on the storage medium.
Action: If the storage containing the backup piece has been removed from the host, restore it and retry the command. If the backup piece is permanently gone, then issue the CHANGE BACKUPPIECE DELETE command for this backup piece.
RMAN-06482: WARNING: proxy copy 'string' cannot be found on the storage medium
Cause: The CHANGE PROXY AVAILABLE command was used, but the proxy copy cannot be found on disk.
Action: If the storage containing the proxy copy has been removed from the host, restore it and retry the command. If the proxy copy is permanently gone, then issue the CHANGE PROXY DELETE command for this proxy copy.
RMAN-06483: changed datafile copy expired
Cause: informational message
Action: no action required
RMAN-06484: changed controlfile copy expired
Cause: informational message
Action: no action required
RMAN-06485: changed archivelog expired
Cause: informational message
Action: no action required
RMAN-06486: changed backup piece expired
Cause: informational message
Action: no action required
RMAN-06487: changed proxy copy expired
Cause: informational message
Action: no action required
RMAN-06488: restore from autobackup does not allow any other modifiers
Cause: A controlfile or SPFILE restore from autobackup was attempted and other restore options were used.
Action: Do not specify any other options for the controlfile autobackup restore.
RMAN-06489: no configuration found to allocate clone channel number for device type string
Cause: Target channel configuration could not be used for clone channel as it contains CONNECT option.
Action: Setup clone channel configuration using CONFIGURE CLONE command for required channel number and device type
RMAN-06490: WARNING: limit of autobackups for the day has been reached
Cause: No more controlfile autobackups are possible in this day.
Action: This is a warning message, no action is required.
RMAN-06491: controlfile autobackup format "string" contains more than one "string" format specifier
Cause: A controlfile autobackup format cannot have more than one reserved format specifier.
Action: Specify only one reserved format specifier or use an alternative format.
RMAN-06492: controlfile autobackup format "string" must specify a "string" format specifier
Cause: A reserved format specifier was not specified for the controlfile autobackup format.
Action: Add a specifier to the controlfile autobackup format.
RMAN-06493: only UNTIL TIME clause is allowed when performing a restore from autobackup, found: string
Cause: For restoring a controlfile autobackup only SET UNTIL TIME can be used. It is not possible to translate the others to a precise day.
Action: Specify SET UNTIL TIME to indicate the day to start the restore of a controlfile autobackup.
RMAN-06494: %s = string is out of range (string-string)
Cause: The specified parameter for restoring a controlfile autobackup is out of the valid range.
Action: Change the parameter value to a valid number or do not specify it.
RMAN-06495: must explicitly specify DBID with SET DBID command
Cause: Restore of a controlfile autobackup was attempted when the database is not mounted.
Action: Specify the DBID of the database using SET DBID or mount the database.
RMAN-06496: must use the TO clause when the database is mounted or open
Cause: A controlfile restore was attempted when the database is mounted or open and no alternate destination was specified.
Action: Specify an alternate destination with the TO clause or dismount the database.
RMAN-06497: WARNING: controlfile is not current, controlfile autobackup skipped
Cause: Controlfile autobackup is not possible without a current controlfile.
Action: This is a warning message, no action is required.
RMAN-06498: skipping datafile string; already backed up string time(s)
Cause: The indicated datafile will not be included in the backup set. It is already backed up on the device requested and file is offline/read-only datafile. Use the FORCE option to override backup optimization.
Action: no action required
RMAN-06499: skipping archive log file string; already backed up string time(s)
Cause: The indicated log file will not be included in the backup set because it is already backed up on the device requested. Use FORCE option to override backup optimization.
Action: no action required
RMAN-06500: skipping backupset key string; already backed up string time(s)
Cause: The indicated backupset will not be copied because it is already backed up on the device requested. Use FORCE option to override backup optimization.
Action: no action required
RMAN-06501: skipping datafile string; already backed up on string
Cause: The indicated datafile will not be included in the backup set. It is already been backed up once, or before the since time specified.
Action: no action required
RMAN-06502: skipping archive log file string; already backed on string
Cause: The indicated log file will not be included in the backup set. It is already been backed up once, or before the since time specified.
Action: no action required
RMAN-06503: skipping backupset key string; already backed up on string
Cause: The indicated backupset will not be backed up. It has already been backed up on the device once, or before the since time specified.
Action: no action required
RMAN-06504: PROXY option with multiple backup copies is not supported
Cause: Multiple backup copies and PROXY option were specified in BACKUP command.
Action: Resolve the conflict.
RMAN-06506: the MAXSETSIZE option cannot be used with a backup backupset
Cause: The MAXSETSIZE option was specified for a backup backupset command.
Action: Remove the option and resubmit the command.
RMAN-06507: trying alternate file for archivelog thread number, sequence number
Cause: This is an informational message, appearing when an archivelog was found out of sync with catalog database.
Action: no action required
RMAN-06508: MAXSETSIZE string kbytes should be greater than blocksize string bytes
Cause: MAXSETSIZE configured or specified in backup command should be greater than database blocksize.
Action: Specify a larger MAXSETSIZE limit.
RMAN-06509: only SPFILE or controlfile can be restored from autobackup
Cause: A datafile or archived log restore from autobackup was attempted.
Action: Do not specify DATAFILE or ARCHIVELOG for restore from autobackup.
RMAN-06510: RMAN retention policy is set to recovery window of number days
Cause: informational message
Action: no action required
RMAN-06511: RMAN retention policy is set to redundancy number
Cause: informational message
Action: no action required
RMAN-06512: copy will be obsolete on date string
Cause: informational message
Action: no action required
RMAN-06513: copy will never be obsolete
Cause: informational message
Action: no action required
RMAN-06514: archived logs required to recover from this copy will not be kept
Cause: informational message
Action: no action required
RMAN-06515: archived logs required to recover from this copy will expire when this copy expires
Cause: informational message
Action: no action required
RMAN-06516: time specified in KEEP UNTIL clause must be be after today
Cause: KEEP UNTIL support only a future time.
Action: Correct the time and retry the command.
RMAN-06517: KEEP option is not supported for archive log backups
Cause: The KEEP option is not supported for archive logs.
Action: Either remove KEEP option and retry the command or don't specify archive logs for this backup.
RMAN-06518: backup will be obsolete on date string
Cause: informational message
Action: no action required
RMAN-06519: backup will never be obsolete
Cause: informational message
Action: no action required
RMAN-06520: archived logs required to recover from this backup will not be kept
Cause: informational message
Action: no action required
RMAN-06521: archived logs required to recover from this backup will expire when this backup expires
Cause: informational message
Action: no action required
RMAN-06522: KEEP FOREVER option is not supported without the recovery catalog
Cause: The KEEP FOREVER option was used, but it requires a connection to a recovery catalog database. The KEEP FOREVER option cannot be used when the backup repository is the target database controlfile. This is because information about this backup cannot be permanently stored. (If information is stored just in the controlfile it will be aged out depending on CONTROL_FILE_RECORD_KEEP_TIME initialization parameter.)
Action: If a recovery catalog database is available, then connect to the recovery catalog and retry the command, otherwise use a different KEEP option. 6523, 1, "unused"
RMAN-06524: RMAN retention policy will be applied to the command
Cause: informational message
Action: no action required
RMAN-06525: RMAN retention policy is set to none
Cause: Command DELETE OBSOLETE and REPORT OBSOLETE requires that either:

* RMAN retention policy is not NONE or,

* RMAN retention policy is specified with REPORT/DELETE command.

Action: Either configure RMAN retention policy with CONFIGURE command or specify it at the end of DELETE/REPORT command.
RMAN-06526: KEEP option cannot be used with incremental backup
Cause: The KEEP option was specified for a incremental backup.
Action: Remove the option and resubmit the command.
RMAN-06527: KEEP option is not supported for backup of backup sets
Cause: The KEEP option is not supported for backup of backup sets.
Action: Either remove KEEP option and retry the command or don't specify backup sets for this backup.
RMAN-06528: CHANGE ... KEEP not supported for BACKUPPIECE
Cause: The CHANGE BACKUPPIECE ... KEEP command was entered. KEEP attributes cannot be specified for backup pieces.
Action: Use CHANGE BACKUPSET ... KEEP instead.
RMAN-06529: CHANGE ... KEEP not supported for ARCHIVELOG
Cause: The CHANGE ARCHIVELOG ... KEEP command was entered. KEEP attributes cannot be specified for archive logs.
Action: Use CHANGE BACKUPSET ... KEEP instead.
RMAN-06530: CHANGE ... KEEP not supported for backup set which contains archive logs
Cause: The CHANGE BACKUPSET ... KEEP command was entered, but the BACKUPSET contains archive logs. Backup sets with archive logs cannot have KEEP attributes.
Action: Do not specify backup set with archive logs for the CHANGE BACKUPSET ... KEEP command.
RMAN-06531: CHANGE ... KEEP not supported for incremental BACKUPSET
Cause: The CHANGE BACKUPSET ... KEEP command was entered, but the BACKUPSET is an incremental backup set. Incremental backup sets cannot have KEEP attributes.
Action: Do not specificy backup set with archive logs for the CHANGE BACKUPSET ... KEEP command.
RMAN-06532: redundancy count must be greater than zero
Cause: The REDUNDANCY operand specified for the retention policy was zero.
Action: Specify a REDUNDANCY operand of 1 or greater.
RMAN-06533: KEEP ... NOLOGS option is not supported when database is open
Cause: The KEEP ... NOLOGS option was specified for a backup or copy of on open database. This kind of backup requires archive logs for recovery, so archive logs must be kept.
Action: Remove the KEEP ... NOLOGS option and resubmit the command.
RMAN-06534: KEEP ... CONSISTENT option is not supported
Cause: The KEEP ... CONSISTENT option was specified but the option is not supported.
Action: Remove the option and resubmit the command.
RMAN-06535: LIST COPY OF SPFILE is not supported
Cause: LIST COPY OF SPFILE was used, which is not supported because SPFILE cannot have a copy.
Action: Remove SPFILE from the command.
RMAN-06536: BACKED UP ... TIMES option is supported only for archived logs
Cause: The BACKUP UP ... TIMES option was used as a qualifier. This option is supported only for archived logs.
Action: Remove the option and resubmit the command.
RMAN-06537: CHANGE ... KEEP not supported for BACKUP
Cause: The CHANGE BACKUP... KEEP command was entered. KEEP attributes cannot be specified for copies and backup pieces in a single command.
Action: Use CHANGE BACKUPSET ... KEEP instead.
RMAN-06540: tablespace string will be excluded from future whole database backups
Cause: informational message
Action: no action required
RMAN-06541: tablespace string will be included in future whole database backups
Cause: informational message
Action: no action required
RMAN-06542: file string is excluded from whole database backup
Cause: The indicated file will not be included in the backup set because it's tablesapce is configured as excluded from backup.
Action: no action required
RMAN-06543: duplicate or conflicting LIST options: string and string
Cause: The indicated options conflict with each other or appear more than once in a LIST command.
Action: remove the duplicate/conflicting option from the command.
RMAN-06544: Do you really want to delete the above objects (enter YES or NO)?
Cause: This is a user prompt.
Action: Answer the question to proceed.
RMAN-06545: "string" is an invalid response - please re-enter.
Cause: An incorrect response was entered.
Action: Enter a correct response.
RMAN-06546: Error occurred getting response - assuming NO response
Cause: An error occurred reading user response.
Action: None - informational message.
RMAN-06547: tablespace SYSTEM cannot be excluded from whole database backup
Cause: The SYSTEM tablespace must be included in whole database backup.
Action: Remove the SYSTEM tablespace from the CONFIGURE ... EXCLUDE and retry the operation.
RMAN-06548: connected to auxiliary database: string (DBID=string)
Cause: informational message
Action: no action required
RMAN-06549: connected to auxiliary database: string (not mounted)
Cause: informational message
Action: no action required
RMAN-06550: clone database not mounted and db_name not set in init.ora
Cause: The clone database "init.ora" file does not specify the DB_NAME parameter.
Action: Add the DB_NAME parameter to the clone database "init.ora" and restart the instance.
RMAN-06551: error while looking up datafilecopy for file number: string
Cause: An error occurred while looking up the specified datafilecopy in the recovery catalog or target database controlfile.
Action: This error is accompanied by other errors describing the reason for the failure. If the datafilecopy was created during a RESTORE with a new name, ensure that the RESTORE completed successfully.
RMAN-06552: newname for datafile number was set to NEW, but file was not restored
Cause: A SWITCH command was specified for a datafile, but the newname was set to NEW and the file was not restored. If newname is set to NEW, the file must be restored before issuing a SWITCH command.
Action: Correct and resubmit the SWITCH command.
RMAN-06553: DB_CREATE_FILE_DEST must be set for SET NEWNAME ... TO NEW
Cause: The SET NEWNAME ... TO NEW option was specified but the OMF destinatation init parameter DB_CREATE_FILE_DEST is not set.
Action: Supply a full name to the SET NEWNAME command or set DB_CREATE_FILE_DEST at the target database.
RMAN-06554: WARNING: file string is in backup mode
Cause: A file which is being backed up or copied is in backup mode. RMAN will back up the file anyway, but files do not need to be put into backup mode before backing them up with RMAN.
Action: Use the ALTER TABLESPACE ... END BACKUP statement, at the target database server, to take the files out of backup mode.
RMAN-06555: datafile string must be restored from backup created before string
Cause: An incomplete recovery session was started, but the file is in newer than the UNTIL TIME clause.
Action: Check the UNTIL TIME clause or restore the file from a sufficient old backup.
RMAN-06556: datafile string must be restored from backup older than scn string
Cause: An incomplete recovery session was started, but the file is newer than the UNTIL clause.
Action: Check the UNTIL clause or restore the file from a sufficient old backup.
RMAN-06557: unable to restore archived log thread number, sequence number
Cause: Restore of the specified archived log failed because the size of the archived log is larger than available disk space.
Action: One of the following: 1) Increase the MAXSIZE parameter and retry the command. 2) Free up disk space in the recovery area.
RMAN-06558: archived log size of number kb is bigger than available space of number kb
Cause: This message should be followed by one or more 6557 messages.
Action: Check the accompanying errors.
RMAN-06559: MAXSIZE must be larger than 1 kb
Cause: The MAXSIZE parameter is out of range.
Action: Specify a valid size and retry the command.
RMAN-06560: WARNING: backup set with key number will be read number times
Cause: This message should be followed by one or more 6562 messages.
Action: Check the accompanying messages.
RMAN-06561: available space must be larger than number kb
Cause: The recovery failed because it requires more disk space. One of the following could have caused this error: 1) The MAXSIZE option is used but is not large enough to restore files. 2) Files should be restored to recovery area, but available disk space is not large enough to restore files.
Action: One of the following: 1) Increase the MAXSIZE parameter and retry the command. 2) Free up disk space in the recovery area.
RMAN-06562: available space of number kb needed to avoid reading the backup set multiple times
Cause: A backup set is read more than once. Multiple reads of a backup set can slow restore performance. One of the following could have caused this: 1) The MAXSIZE option is used but is not large enough to restore files. 2) Files should be restored to a recovery area, but the available disk space is not large enough to restore files.
Action: One of the following: 1) Increase the MAXSIZE parameter and retry the command. 2) Free up disk space in the recovery area.
RMAN-06563: controlfile or SPFILE must be restored using FROM AUTOBACKUP
Cause: RESTORE CONTROLFILE or RESTORE SPFILE was specified without the FROM AUTOBACKUP option when RMAN is not connected to the recovery catalog.
Action: If the recovery catalog is available, connect to the recovery catalog and retry the restore. If the recovery catalog in not available, following is the procedure to restore controlfile or SPFILE:

1. Specify the DBID of the database with the SET DBID command.

2. If the autobackup was created with non-default autobackup format, then specify the autobackup format using the SET CONTROLFILE AUTOBACKUP FORMAT command.

3. If the backup was created with SBT device, then allocate an SBT channel using the ALLOCATE CHANNEL command.

4. Restore controlfile or SPFILE by starting the RESTORE ... FROM AUTOBACKUP command.

RMAN-06564: must use the TO clause when the instance is started with SPFILE
Cause: A restore of the SPFILE from autobackup was attempted when the instance is started with SPFILE and no alternate destination was specified.
Action: Specify an alternate destination with the TO clause.
RMAN-06565: WARNING: string: sqlcode number was caught, automatic retry #number
Cause: The RMAN client caught a transient error and will automatically retry several times.
Action: No action required, this is an informational message.
RMAN-06566: target database incarnation not found in control file
Cause: resetlogs change# and/or time of the target database doesn't match any database incarnation in the control file.
Action: One of the following actions can be taken to resolve this error -- Restore the controlfile from the incarnation. -- To populate the new incarnation, inspect or restore an archived log/datafile/datafilecopy/backup set from the target incarnation
RMAN-06570: datafile number switched to datafile copy "string"
Cause: This message was issued in response to a SWITCH command.
Action: No action is required; this is an informational message.
RMAN-06571: datafile number does not have recoverable copy
Cause: The SWITCH command with the option TO COPY was specified but the datafile has no valid copy to switch to.
Action: Verify whether the datafile has a valid datafile copy.
RMAN-06572: database is open and datafile number is not offline
Cause: The SWITCH command with the option TO COPY was specified, but datafile is not offline and database is open.
Action: Either make sure the datafile is offline or the database must be mounted but not opened.
RMAN-06575: platform id number found in datafile string header is not a valid platform id
Cause: The platform id found in the datafile header was not recognized.
Action: Verify that this is a valid datafile.
RMAN-06576: platform 'string' (number) found in header of datafile string does not mmatch specified platform name 'string' (number)
Cause: The platform specified in the command did not match the platform found in the datafile header.
Action: Specify the correct platform name and retry the command.
RMAN-06577: FROM TAG option may only be used with datafilecopies
Cause: The FROM TAG option was specified for datafiles.
Action: Remove the option and resubmit the command.
RMAN-06578: INCREMENTAL LEVEL > 0 must be specified with FOR RECOVER OF
Cause: The FOR RECOVER OF option was specified without specifying INCREMENTAL LEVEL > 0.
Action: Specify INCREMENTAL LEVEL > 0 and resubmit the command.
RMAN-06580: the string option cannot be used with AS COPY
Cause: The specified option was specified for a backup as copy command.
Action: Remove the option and resubmit the command.
RMAN-06581: option string not supported
Cause: This option was specified and it is not supported.
Action: Remove the specified option.
RMAN-06582: AS COPY option cannot be used when backing up backupsets
Cause: The backupset was specified with AS COPY.
Action: Remove the AS COPY option or remove the backupsets.
RMAN-06583: at least 1 channel of TYPE DISK must be allocated to use AS COPY option
Cause: No channel of TYPE DISK was allocated.
Action: Allocate a channel of TYPE DISK and re-issue the command or remove AS COPY.
RMAN-06584: WARNING: AS BACKUPSET option added due to allocation of multiple channel types
Cause: DISK and non DISK channels were allocated for a backup command. Configuration indicates to produce image copies to DISK, however due to the mixed channel types BACKUPSETs will be created on DISK.
Action: Do not allocate non DISK channels to produce image copies to DISK or allocate only non DISK channels to produce BACKUPSETs only.
RMAN-06585: no copy of datafile number found
Cause: An available datafilecopy for the specified datafile could not be found.
Action: make sure that all specified datafiles have a copy available.
RMAN-06586: no copy of datafile number with tag string found
Cause: An available datafilecopy for the specified datafile could not be found.
Action: make sure that all specified datafiles have a copy available.
RMAN-06587: one or more datafilecopies were not found
Cause: This error message was accompanied by an additional error message or messages indicating the cause of the error.
Action: Follow the recommended actions of the additional error message or messages.
RMAN-06588: number of patterns (number) to DB_FILE_NAME_CONVERT should be even
Cause: An uneven number of patterns was specified.
Action: Specify one more or one less pattern.
RMAN-06589: cannot specify DB_FILE_NAME_CONVERT option without AS COPY
Cause: The DB_FILE_NAME_CONVERT option was specified without AS COPY. This is not permitted for backupset backups where multiple files are combined into a set.
Action: Remove the DB_FILE_NAME_CONVERT option and re-run the BACKUP command.
RMAN-06590: tablespace string cannot be converted
Cause: The system tablespaces could not be transported to other platforms.
Action: Remove the specified tablespace from the CONVERT command and retry the operation.
RMAN-06591: must specify TO PLATFORM
Cause: There was a missing parameter to the command.
Action: Specify the TO PLATFORM parameter with the command.
RMAN-06592: must specify FROM PLATFORM
Cause: There was a missing parameter to the command.
Action: Specify the FROM PLATFORM parameter with the command.
RMAN-06593: platform name 'string' specified in FROM PLATFORM is not valid
Cause: The platform name was not recognized.
Action: Specify a valid platform name.
RMAN-06594: platform name 'string' specified in TO PLATFORM is not valid
Cause: The platform name was not recognized.
Action: Specify a valid platform name.
RMAN-06595: platform name 'string' does not match database platform name 'string'
Cause: The platform name specified did not match the name of the database performing the conversion.
Action: Specify the correct platform name.
RMAN-06596: to use CONVERT compatibility must be set to 10.0.0 or greater, currently set to string
Cause: A command was attempted that requires a higher database compatibility.
Action: Raise the compatibility of the database before attempting the command again.
RMAN-06597: conversion between platforms 'string' and 'string' is not implemented
Cause: Conversion of Oracle data files between the specified platforms was not supported.
Action: Do not do the conversion.
RMAN-06598: conversion between platforms 'string' and 'string' is not needed
Cause: Conversion of Oracle data files between the specified platforms was not necessary because the Oracle data file format is already the same on both platforms.
Action: Do not do the conversion.
RMAN-06599: tablespace string is not read-only
Cause: A conversion was attempted on a tablespace which is not read-only.
Action: Change the tablespace to read-only and retry the operation.
RMAN-06600: old RMAN configuration parameters:
Cause: This message is issued in response to a CONFIGURE command.
Action: None - informational message.
RMAN-06601: new RMAN configuration parameters:
Cause: This message is issued in response to a CONFIGURE command.
Action: None - informational message.
RMAN-06604: new RMAN configuration parameters are successfully stored
Cause: This message is issued in response to a CONFIGURE command.
Action: None - informational message.
RMAN-06605: old RMAN configuration parameters are successfully deleted
Cause: This message is issued in response to a CONFIGURE command.
Action: None - informational message.
RMAN-06606: RMAN configuration parameters are successfully reset to default value
Cause: This message is issued in response to a CONFIGURE command.
Action: None - informational message.
RMAN-06607: RMAN configuration parameters are:
Cause: This message is issued in response to a SHOW command.
Action: None - informational message.
RMAN-06608: RMAN configuration has no stored or default parameters
Cause: This message is issued in response to a SHOW command.
Action: None - informational message.
RMAN-06609: AS COPY can be configured only for disk device
Cause: The AS COPY option was specified for non disk device.
Action: Remove the AS COPY option and resubmit the command.
RMAN-06700: error parsing text script in file string
Cause: Incorrect syntax or invalid commands were found.
Action: Fix text script and retry the command.
RMAN-06701: could not construct path for file: "string"
Cause: An error was encountered when trying to construct the full pathname for the specified file.
Action: Ensure that the path is correct.
RMAN-06702: could not initialize for input file: "string"
Cause: An error was encountered when trying to initialize the specified file for input.
Action: Ensure that the file exists.
RMAN-06703: could not open file: "string" (reason=string)
Cause: An error was encountered when trying to open the specified file.
Action: Ensure that the file has correct permissions.
RMAN-06705: text script line is too long (>1024)
Cause: A text script contained a line longer than the permitted maximum length.
Action: Split the line in smaller lines an retry the operation.
RMAN-06706: could not close file: "string" (reason=string)
Cause: An error was encountered when trying to close the specified file.
Action: Ensure that the file has correct permissions and still exists.
RMAN-06707: could not initialize for output file: "string"
Cause: An error was encountered when trying to initialize the specified file for output.
Action: Ensure that the file exists.
RMAN-06708: short write while writing file "string". Wrote string bytes instead of string bytes
Cause: An attempt was made to write to a file system that was full.
Action: Ensure that the file system has room for the file. Check system logs.
RMAN-06709: No scripts in recovery catalog
Cause: An attempt was made to list the scripts in the catalog, but no scripts could be found in the specified recovery catalog.
Action: None. This is an informational message.
RMAN-06710: script string not found in catalog
Cause: An attempt was made to call a script that could not be found in the target database or as a global script in the specified catalog.
Action: Verify the script name and retry the command.
RMAN-06711: global scripts require a target connection
Cause: Connection to a target database was not specified.
Action: Provide a target connection and retry the command.
RMAN-06716: skipping datafile number; already restored to file string
Cause: Recovery Manager determined that this file is already restored. Use FORCE option to override this optimization.
Action: informational message
RMAN-06717: number of source files (string) and destination files (string) does not match
Cause: The number of files to retrieve from the catalog does not match the number of destinations specified.
Action: Ensure that the number of files to be retrieved matches the number of destinations specified.
RMAN-06718: could not find file "string" in catalog
Cause: The filename provided was not found in the catalog.
Action: The specified file is not stored in the catalog, or it is stored with a different path than the one provided. Specify the filename as stored in the catalog.
RMAN-06719: file "string" (string bytes) restrieved from catalog
Cause: informational message
Action: no action required
RMAN-06720: file "string" removed from catalog
Cause: informational message
Action: no action required
RMAN-06721: could not normalize path for file: "string"
Cause: An error was encountered when trying to normalize the pathname for the specified file.
Action: Ensure that the path is correct.
RMAN-06722: unable to remove file "string" from catalog
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Follow actions for other messages.
RMAN-06723: file "string" (string bytes) updated in catalog
Cause: informational message
Action: no action required
RMAN-06724: backup not done; all files already backed up
Cause: A BACKUP command does not need to backup any files, because all of the files to backup are already backed up.
Action: None, informational message only
RMAN-06725: database not open: sort area size too small
Cause: sort area size too small to execute RMAN commands.
Action: open the database or increase sort_area_size.
RMAN-06726: could not locate archivelog string
Cause: The specified archivelog could not be found on any allocated channel.
Action: Allocate additional channels on other nodes of the cluster, or, if the archived logs have been deleted, use the CROSSCHECK ARCHIVELOG command to correct the recovery catalog entries.
RMAN-06727: could not locate datafilecopy string
Cause: The specified datafilecopy could not be found on any allocated channel.
Action: Allocate additional channels on other nodes of the cluster, or if the datafilecopy have been deleted, use the CROSSCHECK DATAFILECOPY command to correct the recovery catalog entries.
RMAN-06728: could not locate controlfilecopy string
Cause: The specified controlfilecopy could not be found on any allocated channel.
Action: Allocate additional channels on other nodes of the cluster, or if the controlfilecopy have been deleted, use the CROSSCHECK CONTROLFILECOPY command to correct the recovery catalog entries.
RMAN-06729: no backup of the SPFILE found to restore
Cause: A SPFILE restore could not proceed because no backup of the SPFILE was found. It may be the case that a backup of this file exists but does not satisfy the criteria specified in the user's restore operands.
Action: Modify options for the SPFILE restore.
RMAN-06730: no channel to restore a backup of the SPFILE
Cause: A SPFILE restore could not proceed because the backup on a device type that was not allocated for restore.
Action: None - this is an informational message. See message 6026 for further details.
RMAN-06731: command string:string%% complete, time left number:number:number
Cause: informational message
Action: no action required
RMAN-06732: database dropped
Cause: informational message
Action: no action required
RMAN-06733: database unregistered from the recovery catalog
Cause: informational message
Action: no action required
RMAN-06734: Do you really want to drop all backups and the database (enter YES or NO)?
Cause: This is a user prompt.
Action: Answer the question to proceed.
RMAN-06735: Do you really want to drop the database (enter YES or NO)?
Cause: This is a user prompt.
Action: Answer the question to proceed.
RMAN-06736: Do you really want to unregister the database (enter YES or NO)?
Cause: This is a user prompt.
Action: Answer the question to proceed.
RMAN-06737: database name "string" does not match target database name "string"
Cause: The UNREGISTER DATABASE command was used with a database name that does not match the name of the database to which RMAN is connected.
Action: Specify the correct database name or avoid specifying the database name when connected to the target database.
RMAN-06738: database name "string" is not unique in the recovery catalog
Cause: The UNREGISTER DATABASE command was used with a database name that is ambiguous.
Action: Use the SET DBID command to specify the database id and resolve the ambiguity.
RMAN-06739: database "string" is not found in the recovery catalog
Cause: The UNREGISTER DATABASE command was used with a database name that was not found in the recovery catalog.
Action: Make sure the database name specified in the DROP DATABASE command syntax is correct.
RMAN-06740: database name is not specified
Cause: The UNREGISTER DATABASE command failed because of the following:

o RMAN is not connected to the target database

o The database name is not specified in the command

o DBID is not set with the SET DBID command

Action: Any one of the following actions will fix the problem: o Connect to the target database o Specify database name o Set DBID with SET DBID command
RMAN-06741: database name is "string" and DBID is string
Cause: informational message
Action: no action required
RMAN-06742: platform name 'string' longer than number
Cause: The specified platform name exceeds the maximum allowable platform name.
Action: Correct the platform name.
RMAN-06743: specification does not match any backupset in the repository
Cause: The specified backupsets are not found in the repository.
Action: Verify backupset existence and retry the command.
RMAN-06744: specification does not match any datafilecopy in the repository
Cause: The specified datafilecopies are not found in the repository.
Action: Verify datafilecopy existence and retry the command.
RMAN-06745: skipping datafilecopy string; already backed up string time(s)
Cause: The indicated datafilecopy was not included in the backup set because it was already backed up on the device requested.
Action: Use FORCE option to override backup optimization.
RMAN-06746: backup cancelled because all files were skipped
Cause: All files for this backup set were skipped, therefore no backup no backup set was created.
Action: This message is informational only.
RMAN-06747: at least 1 channel of tertiary storage must be allocated to execute this command
Cause: The executed command requires a SBT channel, but no channels of type SBT were configured or allocated.
Action: ALLOCATE or CONFIGURE a SBT channel.
RMAN-06748: no or more than one tertiary storage channel found
Cause: RECOVERY FILES, RECOVERY AREA or DB_RECOVERY_FILE_DEST option was specified in BACKUP command, but no or more than one tertiary channel was found. One of the following could have caused this error: 1) All of the allocated channels are of type DISK. 2) No tertiary storage (SBT) channel configured. 3) CHANNEL or DEVICE TYPE option specified is of DISK type. 4) More than one tertiary storage channel allocated or configured and no DEVICE TYPE or CHANNEL option specified.
Action: One of the following: 1) Allocate a channel of TYPE SBT. 2) Configure a SBT channel. 3) Specify CHANNEL, DEVICE TYPE option of TYPE SBT.
RMAN-06750: SPFILE cannot be backed up by proxy.
Cause: The PROXY option was specified, but proxy copy of SPFILE is not supported. This file will be placed into a non-proxy backup set.
Action: No action required. This is an informational message.
RMAN-06751: ASM file string cannot be proxy backed up.
Cause: The PROXY option was specified, but proxy copy of ASM file is not supported. This file will be placed into a non-proxy backup set.
Action: No action required. This is an informational message.
RMAN-06899: updating recovery catalog with new database incarnation
Cause: The target database has a new incarnation that has not already been seen by the recovery catalog. This usually happens because a point-in-time recovery was done. RMAN has made the necessary updates to the recovery catalog.
Action: informational message
RMAN-06900: WARNING: unable to generate V$RMAN_STATUS or V$RMAN_OUTPUT row
Cause: The routine createRmanStatusRow() or createRmanOutputRow() could add new row into V$RMAN_STATUS or V$RMAN_OUTPUT.
Action: Check the associated error messages. If the associated error message indicates a condition that can be corrected, do so, otherwise contact Oracle.
RMAN-06901: WARNING: disabling update of the V$RMAN_STATUS and V$RMAN_OUTPUT rows
Cause: Informational message only.
Action: No action required.
RMAN-06902: AS COMPRESSED BACKUPSET option cannot be used when backing up backupsets
Cause: The backupset was specified with AS COMPRESSED BACKUPSET.
Action: Remove the AS COMPRESSED BACKUPSET option.
RMAN-06903: backup of datafile string was cancelled
Cause: This is informational message displayed when PARTIAL option of DURATION option was specified on the backup command and backup could not be completed with in the given duration time.
Action: Run backup command to backup cancelled files, or let the next backup window backup the cancelled files. It should be noted that the files that were skipped in current job will be given preference to other files for next the backup command with DURATION option.
RMAN-06904: backup of log thread number seq number lowscn string was cancelled
Cause: This is informational message displayed when PARTIAL option of DURATION option was specified on the backup command and backup could not be completed with in the given duration time.
Action: Run backup command to backup cancelled files, or let the next backup window backup the cancelled files. It should be noted that the files that were skipped in current job will be given preference to other files for next the backup command with DURATION option.
RMAN-06905: backup of backupset key number was cancelled
Cause: This is informational message displayed when PARTIAL option of DURATION option was specified on the backup command and backup could not be completed with in the given duration time.
Action: Run backup command to backup cancelled files, or let the next backup window backup the cancelled files. It should be noted that the files that were skipped in current job will be given preference to other files for next the backup command with DURATION option.
RMAN-06906: backup of controlfile was cancelled
Cause: This is informational message displayed when PARTIAL option of DURATION option was specified on the backup command and backup could not be completed with in the given duration time.
Action: Run backup command to backup cancelled files, or let the next backup window backup the cancelled files. It should be noted that the files that were skipped in current job will be given preference to other files for next the backup command with DURATION option.
RMAN-06907: MINIMIZE LOAD option not allowed for the specified input files
Cause: This option was specified in a backup command specification for BACKUP BACKUPSET or BACKUP CURRENT CONTROLFILE command.
Action: Remove the MINIMIZE LOAD option and retry the command.
RMAN-06908: WARNING: operation will not run in parallel on the allocated channels
Cause: RMAN allocated more than one channel for a job, but the job will not run in parallel on these channels because parallelism require Enterprise Edition.
Action: None
RMAN-06909: WARNING: parallelism require Enterprise Edition
Cause: RMAN allocated more than one channel for a job, but the job will not run in parallel on these channels because parallelism require Enterprise Edition.
Action: None
RMAN-06910: can not invoke parallel recovery for test recovery
Cause: Recover database was called with TEST and PARALLEL option
Action: Call recover database with either just the TEST or PARALLEL option
RMAN-06911: only one PARALLEL or NOPARALLEL clause may be specified
Cause: Recover database was called with PARALLEL and NOPARALLEL option
Action: Call recover database with either just the PARALLEL or NOPARALLEL option.
RMAN-07000: List of SPFILE Backups
Cause: This message is issued in response to a LIST BACKUP OF SPFILE command.
Action: no action required
RMAN-07500: searching for all files that match the pattern string
Cause: informational message
Action: no action required
RMAN-07501: searching for all files in the recovery area
Cause: informational message
Action: no action required
RMAN-07502: List of Files Unknown to the Database
Cause: This message is issued in response to a CATALOG command.
Action: no action required
RMAN-07506: Do you really want to catalog the above files (enter YES or NO)?
Cause: This is a user prompt.
Action: Answer the question to proceed.
RMAN-07507: cataloging files...
Cause: informational message
Action: no action required
RMAN-07508: cataloging done
Cause: informational message
Action: no action required
RMAN-07509: List of Cataloged Files
Cause: This message is issued in response to a CATALOG command.
Action: no action required
RMAN-07513: List of Files Which Where Not Cataloged
Cause: This message is issued in response to a CATALOG command.
Action: no action required
RMAN-07517: Reason: The file header is corrupted
Cause: Either the file is not an Oracle file or the file header is corrupted.
Action: Delete the file using OS utility.
RMAN-07521: cannot create recovery catalog in database version string; version string required
Cause: An attempt was made to use a version of the recovery catalog schema that was incompatible with the version of the database.
Action: Upgrade the catalog database to at least the required version or install the catalog schema in a different database which is of at least the required version.
RMAN-07522: CREATE TYPE privilege must be granted to user string
Cause: The CREATE CATALOG or UPGRADE CATALOG command was used, but the userid that was supplied in the CATALOG connect string does not have the CREATE TYPE privilege granted.
Action: Grant CREATE TYPE privilege to the recovery catalog owner.
RMAN-08000: channel string: copied datafile string
Cause: informational message
Action: no action required
RMAN-08001: restore not complete
Cause: All of the backup pieces have been successfully applied, but x$dbms_backup_restore indicates that the restore conversation is not complete. This usually means that the backup set contained corrupt data.
Action: Restore the files from a different backup set, if possible. The Recovery Manager CHANGE BACKUPPIECE UNAVAILABLE can be used to prevent Recovery Manager from attempting to restore from the corrupt backup piece(s).
RMAN-08002: starting full resync of recovery catalog
Cause: informational message
Action: no action required
RMAN-08004: full resync complete
Cause: informational message
Action: no action required
RMAN-08005: new incarnation of database registered in recovery catalog
Cause: informational message
Action: no action required
RMAN-08006: database registered in recovery catalog
Cause: informational message
Action: no action required
RMAN-08007: channel string: copied datafilecopy of datafile string
Cause: informational message
Action: no action required
RMAN-08008: channel string: starting full datafile backupset
Cause: informational message
Action: no action required
RMAN-08009: channel string: starting archive log backupset
Cause: informational message
Action: no action required
RMAN-08010: channel string: specifying datafile(s) in backupset
Cause: informational message
Action: no action required
RMAN-08011: including current controlfile in backupset
Cause: informational message
Action: no action required
RMAN-08012: including controlfile copy in backup set
Cause: informational message
Action: no action required
RMAN-08014: channel string: specifying archive log(s) in backup set
Cause: informational message
Action: no action required
RMAN-08015: datafile string switched to datafile copy
Cause: informational message
Action: no action required
RMAN-08016: channel string: starting datafile backupset restore
Cause: informational message
Action: no action required
RMAN-08017: channel string: starting archive log restore to default destination
Cause: informational message
Action: no action required
RMAN-08018: channel string: starting archive log restore to user-specified destination
Cause: informational message
Action: no action required
RMAN-08019: channel string: restoring datafile string
Cause: informational message
Action: no action required
RMAN-08020: including standby controlfile in backupset
Cause: informational message
Action: no action required
RMAN-08021: channel string: restoring controlfile
Cause: informational message
Action: no action required
RMAN-08022: channel string: restoring archive log
Cause: informational message
Action: no action required
RMAN-08023: channel string: restored backup piece string
Cause: informational message
Action: no action required
RMAN-08024: channel string: restore complete
Cause: informational message
Action: no action required
RMAN-08025: channel string: copied controlfile copy
Cause: informational message
Action: no action required
RMAN-08026: channel string: copied archive log
Cause: informational message
Action: no action required
RMAN-08027: channel string: copied current controlfile
Cause: informational message
Action: no action required
RMAN-08028: channel string: copy current controlfile failed
Cause: informational message
Action: no action required
RMAN-08029: snapshot controlfile name set to default value: string
Cause: informational message
Action: no action required
RMAN-08030: allocated channel: string
Cause: informational message
Action: no action required
RMAN-08031: released channel: string
Cause: informational message
Action: no action required
RMAN-08032: channel string: recid string stamp string does not match recovery catalog
Cause: The record that identifies the source file for a copy or backup database does not contain the same data as is stored in the recovery catalog.
Action: Perform a full resync and retry the operation. If the problem persists, then contact Oracle.
RMAN-08033: channel string: including datafilecopy of datafile string in backupset
Cause: informational message
Action: no action required
RMAN-08034: full resync skipped, target database not mounted
Cause: informational message
Action: no action required
RMAN-08035: partial resync skipped, target database not mounted
Cause: informational message
Action: no action required
RMAN-08036: channel string: could not create controlfile record for string string
Cause: The record identifying the named file was no longer present in the target database controlfile, and repeated attempts to inspect the file were unsuccessful in creating the record. This could be because the circular-reuse section of the controlfile which holds information about the specified type of file is too small and there is other database activity which is causing the record to be overwritten before it can be used.
Action: Try increasing either the size of the controlfile circular-reuse section for this file type (datafile copy or archived log, as indicated in the error message, or the control_file_record_keep_time initialization parameter. If neither of those remedies works then contact Oracle.
RMAN-08037: channel string: unexpected validation return code string
Cause: This is an internal error that should never be issued.
Action: Contact Oracle Support.
RMAN-08038: channel string: starting piece string at string
Cause: informational message
Action: no action required
RMAN-08039: channel string: starting incremental datafile backupset restore
Cause: informational message
Action: no action required
RMAN-08040: full resync skipped, controlfile is not current or backup
Cause: informational message
Action: no action required
RMAN-08041: partial resync skipped, controlfile is not current or backup
Cause: informational message
Action: no action required
RMAN-08042: channel string: copied standby controlfile
Cause: informational message
Action: no action required
RMAN-08043: channel string: copy standby controlfile failed
Cause: informational message
Action: no action required
RMAN-08044: channel string: finished piece string at string
Cause: informational message
Action: no action required
RMAN-08045: channel string: finished piece string at string with string copies
Cause: informational message
Action: no action required
RMAN-08046: channel string: starting compressed full datafile backupset
Cause: informational message
Action: no action required
RMAN-08047: channel string: starting compressed incremental level string datafile backupset
Cause: informational message
Action: no action required
RMAN-08048: channel string: starting incremental level string datafile backupset
Cause: informational message
Action: no action required
RMAN-08049: channel string: starting compressed archive log backupset
Cause: informational message
Action: no action required
RMAN-08050: cataloged datafile copy
Cause: informational message
Action: no action required
RMAN-08051: cataloged archive log
Cause: informational message
Action: no action required
RMAN-08052: cataloged controlfile copy
Cause: informational message
Action: no action required
RMAN-08054: starting media recovery
Cause: informational message
Action: no action required
RMAN-08055: media recovery complete
Cause: informational message
Action: no action required
RMAN-08056: skipping datafile string because it has not changed
Cause: The specified datafile has not had its checkpoint advanced since the previous backup, therefore it does not need a new incremental backup.
Action: informational message
RMAN-08057: channel string: backup cancelled because all files were skipped
Cause: All datafiles for this incremental backup set were skipped, therefore no backup set is created.
Action: informational message
RMAN-08058: replicating controlfile
Cause: informational message
Action: no action required
RMAN-08059: media recovery failed
Cause: informational message
Action: no action required
RMAN-08060: unable to find archive log
Cause: informational message
Action: no action required
RMAN-08066: database reset to incarnation string
Cause: informational message
Action: no action required
RMAN-08070: deleted datafile copy
Cause: informational message
Action: no action required
RMAN-08071: channel string: deleting archive log(s)
Cause: informational message
Action: no action required
RMAN-08072: deleted controlfile copy
Cause: informational message
Action: no action required
RMAN-08073: deleted backup piece
Cause: informational message
Action: no action required
RMAN-08074: crosschecked backup piece: found to be 'string'
Cause: informational message
Action: no action required
RMAN-08085: created script string
Cause: informational message
Action: no action required
RMAN-08086: replaced script string
Cause: informational message
Action: no action required
RMAN-08087: channel string: started backup set validation
Cause: informational message
Action: no action required
RMAN-08088: applied offline range to datafile string
Cause: informational message
Action: no action required
RMAN-08089: channel string: specifying datafile(s) to restore from backup set
Cause: informational message
Action: no action required
RMAN-08090: channel string: starting proxy restore
Cause: informational message
Action: no action required
RMAN-08091: channel string: specifying datafile(s) for proxy backup
Cause: informational message
Action: no action required
RMAN-08092: channel string: specifying datafilecopy of datafile string for proxy backup
Cause: informational message
Action: no action required
RMAN-08093: specifying current controlfile for proxy backup
Cause: informational message
Action: no action required
RMAN-08094: channel string: specifying datafile(s) for proxy restore
Cause: informational message
Action: no action required
RMAN-08096: channel string: starting validation of datafile backupset
Cause: informational message
Action: no action required
RMAN-08097: channel string: starting validation of archive log backupset
Cause: informational message
Action: no action required
RMAN-08098: channel string: validation complete
Cause: informational message
Action: no action required
RMAN-08099: specifying standby controlfile for proxy backup
Cause: informational message
Action: no action required
RMAN-08100: channel string: starting proxy validation
Cause: informational message
Action: no action required
RMAN-08101: channel string: proxy validation complete
Cause: informational message
Action: no action required
RMAN-08102: channel string: located backup piece: string
Cause: informational message
Action: no action required
RMAN-08103: channel string: could not locate backup piece: string
Cause: informational message
Action: no action required
RMAN-08104: input backupset count=string stamp=string creation_time=string
Cause: informational message
Action: no action required
RMAN-08105: channel string: backup cancelled because no pieces were found
Cause: All backupsets specified has no pieces. Therefore, no backup set is created.
Action: informational message
RMAN-08106: channel string: restoring block(s)
Cause: informational message
Action: no action required
RMAN-08107: channel string: block restore complete
Cause: informational message
Action: no action required
RMAN-08108: channel string: specifying block(s) to restore from backup set
Cause: informational message
Action: no action required
RMAN-08109: channel string: restored block(s) from backup piece string
Cause: informational message
Action: no action required
RMAN-08110: failover to next copy of backuppiece
Cause: informational message
Action: no action required
RMAN-08111: some blocks not recovered: See trace file for details
Cause: Some blocks not recovered due to errors.
Action: See trace file for details of the problem.
RMAN-08112: archivelog failover was done on string, check alert log for more info
Cause: This is an informational message to indicate the server found a corrupted block in an archivelog and had to switch to another archivelog with same logseq in alternate archivelog destination to get corresponding un-corrupted block.
Action: If backup is done with delete input option, nothing needs to be done. Otherwise delete the archivelog that has corrupted block(s) as recovery on applying this log would fail. alert log contains name of the log that has corrupted block(s).
RMAN-08113: including current SPFILE in backupset
Cause: informational message
Action: no action required
RMAN-08114: channel string: restoring SPFILE to PFILE
Cause: informational message
Action: no action required
RMAN-08115: channel string: restoring SPFILE
Cause: informational message
Action: no action required
RMAN-08116: output filename is original SPFILE location
Cause: informational message
Action: no action required
RMAN-08117: channel string: the autobackup does not contain an SPFILE
Cause: The requested autobackup does not contain a SPFILE. This is because the instance was not started with a SPFILE when the autobackup was created.
Action: no action required RMAN will try three older autobackups before signaling ORA-19687.
RMAN-08118: WARNING: could not delete the following archived redo log
Cause: The routine deleteArchivedLog() could not delete an archived redo log on the target instance.
Action: Check the accompanying file specification and the associated error messages. The file specification indicates what archived redo log on the target instance RMAN was trying to delete and the error messages indicate why RMAN was unable to delete it. Resolve the problem by first confirming that the archived redo log in question has been backed up, do the deletion manually, and then do a crosscheck so that RMAN is aware of the deletion.
RMAN-08119: skipping backup piece handle string; already exists
Cause: A BACKUP command does not need to backup controlfile autobackup pieces, because they already exists.
Action: This is an informational message, no action required.
RMAN-08120: WARNING: archive log not deleted, not yet applied by standby
Cause: This is an informational message to alert the user that an archivelog that should have been deleted was not as it has not been applied to the standby database. The next message identifies the archivelog
Action: Archivelog can be deleted after it has been applied to standby database.
RMAN-08121: keep attributes for the backup are deleted
Cause: informational message
Action: no action required
RMAN-08122: keep attributes for the backup are changed
Cause: informational message
Action: no action required
RMAN-08123: keep attributes for the datafile/controlfile copy are deleted
Cause: informational message
Action: no action required
RMAN-08124: keep attributes for the datafile/controlfile copy are changed
Cause: informational message
Action: no action required
RMAN-08125: keep attributes for the proxy copy are deleted
Cause: informational message
Action: no action required
RMAN-08126: keep attributes for the proxy copy are changed
Cause: informational message
Action: no action required
RMAN-08127: cataloged backuppiece
Cause: informational message
Action: no action required
RMAN-08128: uncataloged backuppiece
Cause: informational message
Action: no action required
RMAN-08129: failover to piece handle=string tag=string
Cause: This is an informational message to indicate the server found a corrupted block in a piece and had to switch to another copy of piece to get corresponding un-corrupted block.
Action: See alert log for information on corruption block(s) and the name of the piece that has the corrupted block(s).
RMAN-08130: failover to copy on device type string
Cause: This is an informational message to indicate the RMAN could not successfully restore the database using the specified backups. An attempt was made to restore the datafiles/archivelogs/ controlfile/SPFILE using the same backupset on a different device type.
Action: See accompanying additional error messages indicating the cause of the failover.
RMAN-08131: channel string: specifying datafile copies to recover
Cause: informational message
Action: no action required
RMAN-08132: WARNING: cannot refresh aged file list
Cause: Cannot update deletable recovery area file list.
Action: Check the accompanying error.
RMAN-08133: channel string: the autobackup does not contain a standby controlfile.
Cause: The requested autobackup did not contain a standby controlfile.
Action: No action is required, RMAN will try three older autobackups before signaling ORA-19687.
RMAN-08135: some corrupt blocks found during conversion of file string
Cause: While converting the specified file from one platform to another, some corrupt blocks were discovered in the specified file. Details about the corruption have been written to a server trace file.
Action: If these corrupt blocks are unexpected, you may be able to use Block Media Recovery at the source database to fix the problem, then re-convert the files.
RMAN-08136: channel string: deleting incremental backup(s)
Cause: This is an informational message.
Action: No Action Required.
RMAN-08150: created global script string
Cause: informational message
Action: no action required
RMAN-08151: replaced global script string
Cause: informational message
Action: no action required
RMAN-08152: global script string written to file string
Cause: informational message
Action: no action required
RMAN-08153: deleted global script: string
Cause: informational message
Action: no action required
RMAN-08154: deleted script: string
Cause: informational message
Action: no action required
RMAN-08155: printing stored global script: string
Cause: informational message.
Action: no action required
RMAN-08156: printing stored script: string
Cause: informational message.
Action: no action required
RMAN-08157: script string written to file string
Cause: informational message
Action: no action required
RMAN-08158: executing script: string
Cause: informational message
Action: no action required
RMAN-08159: executing global script: string
Cause: informational message
Action: no action required
RMAN-08160: script commands will be loaded from file string
Cause: informational message
Action: no action required
RMAN-08161: contents of Memory Script:
Cause: informational message
Action: no action required
RMAN-08162: executing Memory Script
Cause: informational message
Action: no action required
RMAN-08180: channel string: restore complete, elapsed time: string
Cause: informational message
Action: no action required
RMAN-08181: media recovery complete, elapsed time: string
Cause: informational message
Action: no action required
RMAN-08182: channel string: validation complete, elapsed time: string
Cause: informational message
Action: no action required
RMAN-08183: channel string: block restore complete, elapsed time: string
Cause: informational message
Action: no action required
RMAN-08500: channel string: sid=string devtype=string
Cause: informational message
Action: no action required
RMAN-08501: output filename=string recid=string stamp=string
Cause: informational message
Action: no action required
RMAN-08503: piece handle=string comment=string
Cause: informational message
Action: no action required
RMAN-08504: input archive log thread=string sequence=string recid=string stamp=string
Cause: informational message
Action: no action required
RMAN-08505: output filename=string
Cause: informational message
Action: no action required
RMAN-08506: input filename=string
Cause: informational message
Action: no action required
RMAN-08507: input datafilecopy recid=string stamp=string filename=string
Cause: informational message
Action: no action required
RMAN-08508: archive log destination=string
Cause: informational message
Action: no action required
RMAN-08509: destination for restore of datafile string: string
Cause: informational message
Action: no action required
RMAN-08510: archive log thread=string sequence=string
Cause: informational message
Action: no action required
RMAN-08511: piece handle=string tag=string
Cause: informational message
Action: no action required
RMAN-08512: waiting for snapshot controlfile enqueue
Cause: informational message
Action: no action required
RMAN-08513: datafile copy filename=string recid=string stamp=string
Cause: informational message
Action: no action required
RMAN-08514: archive log filename=string recid=string stamp=string
Cause: informational message
Action: no action required
RMAN-08515: archive log filename=string thread=string sequence=string
Cause: informational message
Action: no action required
RMAN-08516: controlfile copy filename=string recid=string stamp=string
Cause: informational message
Action: no action required
RMAN-08517: backup piece handle=string recid=string stamp=string
Cause: informational message
Action: no action required
RMAN-08518: channel string: scanning controlfile copy string
Cause: informational message
Action: no action required
RMAN-08519: channel string: scanning datafilecopy string
Cause: informational message
Action: no action required
RMAN-08520: channel string: scanning archive log string
Cause: informational message
Action: no action required
RMAN-08521: offline range recid=string stamp=string
Cause: informational message
Action: no action required
RMAN-08522: input datafile fno=string name=string
Cause: informational message
Action: no action required
RMAN-08523: restoring datafile string to string
Cause: informational message
Action: no action required
RMAN-08524: input controlfilecopy name=string
Cause: informational message
Action: no action required
RMAN-08526: channel string: string
Cause: informational message
Action: no action required
RMAN-08527: channel string: starting string proxy datafile backup at string
Cause: informational message
Action: no action required
RMAN-08528: channel string: proxy copy complete, elapsed time: string
Cause: informational message
Action: no action required
RMAN-08529: proxy file handle=string
Cause: informational message
Action: no action required
RMAN-08531: channel string: proxy copy string is string in media management catalog
Cause: informational message
Action: no action required
RMAN-08532: channel string: restoring block(s) from datafilecopy string
Cause: informational message
Action: no action required
RMAN-08533: restoring blocks of datafile string
Cause: informational message
Action: no action required
RMAN-08534: channel string: controlfile restore from autobackup complete
Cause: informational message
Action: no action required
RMAN-08535: channel string: looking for autobackup on day: string
Cause: informational message
Action: no action required
RMAN-08536: channel string: autobackup found: string
Cause: informational message
Action: no action required
RMAN-08537: channel string: skipped, autobackup already found
Cause: informational message
Action: no action required
RMAN-08538: channel string: no autobackup in string days found
Cause: informational message
Action: no action required
RMAN-08539: backup set key=string recid=string stamp=string
Cause: informational message
Action: no action required
RMAN-08540: channel string: backup set complete, elapsed time: string
Cause: informational message
Action: no action required
RMAN-08541: channel string: SPFILE restore from autobackup complete
Cause: informational message
Action: no action required
RMAN-08542: channel string: starting proxy archivelog backup at string
Cause: informational message
Action: no action required
RMAN-08543: channel string: specifying archivelog(s) for proxy backup
Cause: informational message
Action: no action required
RMAN-08544: channel string: specifying archivelog(s) for proxy restore
Cause: informational message
Action: no action required
RMAN-08545: flashback command failed: See trace file for details
Cause: An attempt was made to issue a flashback command which failed due to errors. See trace file for details.
Action: See trace file for details of the problem.
RMAN-08546: channel string: autobackup found in the recovery area
Cause: informational message
Action: no action required
RMAN-08547: channel string: no autobackups found in the recovery area
Cause: The recovery area does not have desired autobackup.
Action: Check the option UNTIL TIME in case an existing autobackup does satisfy the criteria specified in the restore command. Otherwise, verify the init.ora parameters DB_RECOVERY_FILE_DEST and LOCK_NAME_SPACE to verify whether the recovery area location is set correctly. Note that the parameters can be specified as options to the restore command.
RMAN-08548: recovery area destination: string
Cause: informational message
Action: no action required
RMAN-08549: database name (or lock name space) used for search: string
Cause: informational message
Action: no action required
RMAN-08550: autobackup search outside recovery area not attempted because DBID was not set
Cause: Restore of a controlfile autobackup was attempted without DBID being set.
Action: If you want to search for autobackup outside recovery area, then specify the DBID of the database using SET DBID.
RMAN-08551: recovering datafilecopy fno=string name=string
Cause: informational message
Action: no action required
RMAN-08580: channel string: starting datafile copy
Cause: informational message
Action: no action required
RMAN-08581: channel string: datafile copy complete, elapsed time: string
Cause: informational message
Action: no action required
RMAN-08582: channel string: starting archive copy
Cause: informational message
Action: no action required
RMAN-08583: channel string: archivelog copy complete, elapsed time: string
Cause: informational message
Action: no action required
RMAN-08584: copying current controlfile
Cause: informational message
Action: no action required
RMAN-08585: copying standby controlfile
Cause: informational message
Action: no action required
RMAN-08586: output filename=string tag=string recid=string stamp=string
Cause: informational message
Action: no action required
RMAN-08587: input is copy of datafile string: string
Cause: informational message
Action: no action required
RMAN-08588: converted datafile=string
Cause: informational message
Action: no action required
RMAN-08589: channel string: starting datafile conversion
Cause: informational message
Action: no action required
RMAN-08590: channel string: datafile conversion complete, elapsed time: string
Cause: informational message
Action: no action required
RMAN-08591: WARNING: invalid archivelog deletion policy
Cause: An invalid ARCHIVELOG DELETION POLICY was supplied. The archivelog deletion policy was APPLIED but there was no mandatory archivelog destinations.
Action: One of the following: 1) Change archivelog deletion policy using CONFIGURE command 2) Make one or more of standby destination as MANDATORY.
RMAN-08599: channel string: throttle time: string
Cause: informational message
Action: no action required
RMAN-10000: error parsing target database connect string "string"
Cause: An invalid target connect string was supplied.
Action: Specify a valid connect string and re-run the job.
RMAN-10001: error parsing recovery catalog connect string "string"
Cause: An invalid recovery catalog connect string was supplied.
Action: Specify a valid connect string and re-run the job.
RMAN-10002: ORACLE error: string
Cause: The specified Oracle error was received. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-10003: unable to connect to target database
Cause: Recovery manager was unable to connect to the target database. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Ensure that that the target database is started, and that the connect string is valid.
RMAN-10004: unable to connect to recovery catalog
Cause: Recovery manager was unable to connect to the recovery catalog
Action: Ensure that that the recovery catalog is started, and that the connect string is valid. This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-10005: error opening cursor
Cause: An error was received while trying to open a cursor. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: If the associated Oracle error message indicates a condition that can be corrected, do so, otherwise contact Oracle.
RMAN-10006: error running SQL statement: string
Cause: An error message was received while running the SQL statement shown.
Action: If the associated Oracle error message indicates a condition that can be corrected, do so, otherwise contact Oracle.
RMAN-10007: error closing cursor
Cause: An error was received while trying to close a cursor. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: If the associated Oracle error message indicates a condition that can be corrected, do so, otherwise contact Oracle.
RMAN-10008: could not create channel context
Cause: An error was received while trying create a channel context. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: If the associated Oracle error message indicates a condition that can be corrected, do so, otherwise contact Oracle.
RMAN-10009: error logging off of Oracle
Cause: An error was received while disconnecting from Oracle. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: informational message
RMAN-10010: error while checking for RPC completion
Cause: Recovery Manager's channel context had an error while checking to see if a remote procedure call had completed. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: If other error messages indicate a condition that can be corrected, do so, otherwise contact Oracle.
RMAN-10011: synchronization error while polling for rpc number, action=string
Cause: Recovery Manager could not synchronize properly with a remote procedure call.
Action: This is an internal error that should not be issued. Contact Oracle Support.
RMAN-10012: KGU error: string
Cause: An error occurred while initializing the KGU subsystem
Action: This is an internal error that should not be issued. Contact Oracle Support.
RMAN-10013: error initializing PL/SQL
Cause: An error occurred while initializing the PL/SQL subsystem.
Action: This is an internal error that should not be issued. Contact Oracle Support.
RMAN-10014: PL/SQL error number on line number column number: string
Cause: PL/SQL error
Action: The text of this message will be issued by the PL/SQL subsystem. See the PL/SQL error message manual.
RMAN-10015: error compiling PL/SQL program
Cause: An error occurred while compiling a PL/SQL program.
Action: This is an internal error that should not be issued. Contact Oracle Support.
RMAN-10018: error cleaning up channel context
Cause: An error was received during inter-step cleanup of a channel context.
Action: This is an internal error that should not be issued. Contact Oracle Support.
RMAN-10020: error initializing Recovery Manager execution layer
Cause: An error was received while initializing the Recovery Manager execution layer in preparation for running a job. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: If other error messages indicate a condition that can be corrected, do so, otherwise contact Oracle.
RMAN-10022: error in system-dependant sleep routine
Cause: An error was received while waiting for a remote RPC to complete. The error occurred in the system-dependant sleep routine.
Action: This is an internal error that should not be issued. Contact Oracle Support.
RMAN-10023: RPC attempted to unrecognized package
Cause: The Recovery Manager internal RPC router received a package name that it could not understand.
Action: This is an internal error that should not be issued. Contact Oracle Support.
RMAN-10024: error setting up for rpc polling
Cause: The Recovery Manager could not create the RPC polling context which is required to test for RPC completion. This message should be accompanied by other error message(s) indicating the cause of the error.
Action: If other error messages indicate a condition that can be corrected, do so, otherwise contact Oracle.
RMAN-10025: connection is already registered for events
Cause: The Recovery Manager could not enable the target database connection to test for RPC completion.
Action: This is an internal error that should not be issued. Contact Oracle Support.
RMAN-10026: network error number-number occurred registering connection
Cause: An network error occurred while attempting to register the target database connection to test for RPC completion.
Action: This is an internal error that should not be issued. The message numbers are issued by the Sql*Net layer. Contact Oracle Support.
RMAN-10027: could not locate network layer context
Cause: Recovery Manager could not locate a necessary context area while attempting to register the target database connection to test for RPC completion.
Action: This is an internal error that should not be issued. Contact Oracle Support.
RMAN-10028: network error number-number occurred during remote RPC
Cause: An network error occurred while waiting for a remote RPC to complete.
Action: This is an internal error that should not be issued. The message numbers are issued by the Sql*Net layer. Contact Oracle Support.
RMAN-10029: unexpected return code number from PL/SQL execution
Cause: PL/SQL returned an unexpected return code while executing one channel program.
Action: This is an internal error that should not be issued. Contact Oracle Support.
RMAN-10030: RPC call appears to have failed to start on channel string
Cause: An RPC to a target database instance was issued, but was not observed to start within 5 timeouts.
Action: This error is probably accompanied by other error messages giving the precise cause of the failure.
RMAN-10031: RPC Error: ORA-number occurred during call to string.string
Cause: An RPC to the target database or recovery catalog database encountered an error.
Action: This error is accompanied with the error message from the server where the error occurred.
RMAN-10032: unhandled exception during execution of job step number: string
Cause: An unhandled PL/SQL execption occurred during a job step.
Action: This error is accompanied by the error messages describing the exception.
RMAN-10033: error during compilation of job step number: string
Cause: PL/SQL detected a problem during the compilation of a job step
Action: This error message is accompanied by the error messages describing
RMAN-10034: unhandled exception during execution of job step number, error unknown
Cause: PL/SQL detected an unhandled exception during execution of a job step, but no further information available
Action: none
RMAN-10035: exception raised in RPC: string
Cause: A call to a remote package resulted in an exception.
Action: The exception should indicate what went wrong.
RMAN-10036: RPC call ok on channel string
Cause: This is just an informational message. It should be preceeded by message 10030.
Action: no action required
RMAN-10037: RPC anomaly detected on channel string, upinblt=number
Cause: This is an debugging message and can be ignored.
Action: no action required.
RMAN-10038: database session for channel string terminated unexpectedly
Cause: The database connection for the specified channel no longer exists. Either the session was terminated by some external means or the channel terminated because of an internal error.
Action: Check for an oracle trace file for detailed information on why the session terminated.
RMAN-10039: error encountered while polling for RPC completion on channel string
Cause: This error should be accompanied by other errors giving the cause of the polling error.
Action: Check the accompanying errors.
RMAN-10040: asynchronous support not detected, RMAN will run synchronously
Cause: The database connection does not support asynchronous operation, so RMAN will not multi-task work among multiple channels. Multiple channels can still be allocated, but they will not run work concurrently.
Action: Use a connection type that supports asynchronous operations.
RMAN-11000: message number number not found in recovery manager message file
Cause: Recovery manager message file is out of date.
Action: Make sure that the recovery manager error message file is current and installed in the correct location.
RMAN-11001: Oracle Error: string
Cause: informational message
Action: no action required
RMAN-11002: could not open a cursor to the target database
Cause: informational message
Action: no action required
RMAN-11003: failure during parse/execution of SQL statement: string
Cause: informational message
Action: no action required
RMAN-11004: format requires %%c when duplexing
Cause: SET_DUPLEX=ON was specified, but %c was not part of the format.
Action: Include %c in format, or use %U.
RMAN-11005: conflicting media information for piece "string"
Cause: While restoring the specified backup piece, RMAN received conflicting information about the physical location of the piece from the Media Management software. This can cause poor restore performance.
Action: If RMAN does not parallelize the restore from all of the available channels, then you should contact the Media Management vendor.
RMAN-11006: WARNING: test recovery results: string
Cause: User called recover database with the test option
Action: None required
RMAN-12000: execution layer initialization failed
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-12001: could not open channel string
Cause: An ALLOCATE CHANNEL command could not be processed.
Action: This message should be accompanied by other error message(s) indicating the cause of the error.
RMAN-12005: error during channel cleanup
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-12007: cannot allocate more than number channels
Cause: The maximum number of RMAN channels has been exceeded. Note that one channel is reserved for RMAN.
Action: Allocate fewer channels. Contact Oracle if you have a need for more channels in a single job.
RMAN-12008: could not locate backup piece string
Cause: There was at least 1 backup set that could not be accessed by any of the allocated channels.
Action: Allocate additional channels on other nodes of the cluster
RMAN-12009: command aborted because some backup pieces could not be located
Cause: Same as 7008.
Action: Refer to 7008.
RMAN-12010: automatic channel allocation initialization failed
Cause: This message should be accompanied by other error message(s) indicating the cause of the error.
Action: Check the accompanying errors.
RMAN-12011: multiple records for default device type found in catalog
Cause: configuration for default device type not consistent.
Action: re-run CONFIGURE DEFAULT DEVICE TYPE command to set device type.
RMAN-12012: multiple records for string parallelism found in catalog
Cause: configuration for device parallelism is not consistent.
Action: re-run CONFIGURE PARALLELISM command for device to set parallelism.
RMAN-12013: multiple records for string channel number found in catalog
Cause: configuration for the channel is not consistent.
Action: re-run CONFIGURE CHANNEL command to configure this channel.
RMAN-12014: multiple records for default channel configuration for string found in catalog
Cause: configuration for the channel is not consistent.
Action: re-run CONFIGURE CHANNEL command to configure the channel.
RMAN-12015: configuration for string channel number is ignored
Cause: this is an informational message. parallelism for the device is less than associated channel number.
Action: to use this configuration increase parallelism for this device. to clear this configuration use CONFIGURE CHANNEL... CLEAR command.
RMAN-12016: using channel string
Cause: informational message
Action: no action required
RMAN-12017: could not locate pieces of backupset key string
Cause: No copies of the specified backupset key can be accessed on any of the allocated channels.
Action: Allocate additional channels on other nodes of the cluster, or, if the backup pieces have been deleted, use the CROSSCHECK BACKUP command to correct the recovery catalog entries.
RMAN-12018: channel string disabled, job failed on it will be run on another channel
Cause: This is an informational message displayed whenever a retriable error occurs for the job and there are channels available to run this step.
Action: no action required.
RMAN-12019: continuing other job steps, job failed will not be re-run
Cause: This is an informational message displayed whenever there is a non-retriable error occured for the job.
Action: no action required.
RMAN-12020: error on step filtered for normal output string
Cause: This message is added when stacking errors for failed jobs after channel failover was performed. It will be filtered from normal output.
Action: no action required.
RMAN-20000: abnormal termination of job step
Cause: A job step encountered an error and could not recover. This error should be followed by other errors indicating the cause of the problem.
Action: Check the accompanying error.
RMAN-20001: target database not found in recovery catalog
Cause: target database is not found in the recovery catalog
Action: make sure that the target database is registered in the recovery recovery catalog
RMAN-20002: target database already registered in recovery catalog
Cause: target database is already registered in the recovery catalog
Action: if the target database is really registered, there is no need to register it again. Note that the recovery catalog enforces that all databases have a unique DBID. If the new database was created by copying files from an existing database, it will have the same DBID as the original database and cannot be registered in the same recovery catalog.
RMAN-20003: target database incarnation not found in recovery catalog
Cause: resetlogs change# and/or time of the target database doesn't match any database incarnation in the recovery catalog.
Action: if target database was opened with resetlogs option then use 'reset database' to register the new incarnation.
RMAN-20004: target database name does not match name in recovery catalog
Cause: name of the target database doesn't match the one stored in the recovery catalog
Action: This is an internal error, call support.
RMAN-20005: target database name is ambiguous
Cause: two or more databases in the recovery catalog match this name
Action: none
RMAN-20006: target database name is missing
Cause: target database instance is not started or db_name initialization parameter is not set
Action: startup the instance and make sure that db_name parameter is set
RMAN-20009: database incarnation already registered
Cause: this incarnation is already registered in the recovery catalog
Action: no action required
RMAN-20010: database incarnation not found
Cause: database incarnation does not match any database incarnation in the recovery catalog
Action: specify a valid database incarnation key
RMAN-20011: target database incarnation is not current in recovery catalog
Cause: the database incarnation that matches the resetlogs change# and time of the mounted target database controlfile is not the current incarnation of the database
Action: If 'reset database to incarnation <key>' was used to make an old incarnation current then restore the target database from a backup that matches the incarnation and mount it. You will need to do 'startup nomount' before you can restore the controlfile using RMAN. Otherwise use 'reset database to incarnation <key>' make the intended incarnation current in the recovery catalog.
RMAN-20029: cannot make a snapshot controlfile
Cause: another operation that needs the snapshot controlfile is in progress
Action: try again later if necessary
RMAN-20030: resync in progress
Cause: this procedure can not be called while a resync is in progress
Action: This is an internal error
RMAN-20031: resync not started
Cause: this procedure can only be called in a resync
Action: This is an internal error
RMAN-20032: checkpoint change# too low
Cause: the checkpoint change# is less than the one of the previous resync or the checkpoint change# is null
Action: make sure that the right controlfile is used
RMAN-20033: controlfile sequence# too low
Cause: the controlfile sequence is less than the one of the previous resync
Action: make sure that the right controlfile is used
RMAN-20034: resync not needed
Cause: the control file has not changed since the previous resync
Action: nothing since the recovery catalog is in sync
RMAN-20039: format requires character when duplexing
Cause: SET_DUPLEX=ON was specified, but %c was not part of the format.
Action: Include %c in format, or use %U.
RMAN-20201: datafile not found in the recovery catalog
Cause: The specified datafile is not found in the recovery catalog
Action: make sure that the datafile name is correct and that the recovery catalog is up-to-date
RMAN-20202: tablespace not found in the recovery catalog
Cause: the specified tablespace is not found in the recovery catalog
Action: make sure that the tablespace name is correct and that the recovery catalog is up-to-date
RMAN-20203: translation in progress
Cause: this procedure can not be called when name translation is in progress
Action: this is an internal error
RMAN-20204: translation not started
Cause: getDatafile procedure was called before translateTablespace
Action: this is an internal error
RMAN-20205: incomplete UNTIL clause
Cause: The sequence# was NULL
Action: this is an internal error
RMAN-20206: log sequence not found in the repository
Cause: The specified log sequence does not exists in log history of the current database incarnation
Action: check the thread# and sequence#
RMAN-20207: UNTIL TIME or RECOVERY WINDOW is before RESETLOGS time
Cause: UNTIL TIME and RECOVERY WINDOW cannot be less than the database creation time or RESETLOGS time.
Action: Check the UNTIL TIME or RECOVERY WINDOW. If the database needs to be restored to an old incarnation, use the RESET DATABASE TO INCARNATION command.
RMAN-20208: UNTIL CHANGE is before RESETLOGS change
Cause: UNTIL CHANGE cannot be less than the database RESETLOGS change.
Action: Check the UNTIL CHANGE. If the database needs to be restored to an old incarnation, use the RESET DATABASE TO INCARNATION command.
RMAN-20209: duplicate datafile name
Cause: Two datafiles have the same name
Action: this is an internal error
RMAN-20211: FROM TIME is before RESETLOGS time
Cause: FROM TIME cannot be less than the database creation time or RESETLOGS time.
Action: Check the FROM TIME. If the database needs to be restored to an old incarnation, use the RESET DATABASE TO INCARNATION command.
RMAN-20215: backup set not found
Cause: The specified backup set key was not found in the recovery catalog
Action: Specify a different backup set key.
RMAN-20217: datafile not part of the database
Cause: the datafile does not exists or did not exist at until time/scn
Action: check the datafile name or number. This is an internal error for restore database or tablespace.
RMAN-20218: datafile not found in recovery catalog
Cause: This is an internal error
Action: Contact Oracle Customer Support.
RMAN-20220: controlfile copy not found in the recovery catalog
Cause: the specified controlfile is not in the recovery catalog or it has been marked deleted
Action: check the filename
RMAN-20221: ambiguous controlfile copy name
Cause: more than one controlfile copy in the recovery catalog match the specified name.
Action: none
RMAN-20222: datafilename not found in recovery catalog or is ambiguous
Cause: The specified datafilename is not the name of a datafile that is currently part of the target database, or an UNTIL clause has been specified and the filename was for a different datafile at the time specified by the UNTIL clause than it is now.
Action: Use a datafile number to specify the datafile you want to RESTORE or RECOVER.
RMAN-20230: datafile copy not found in the recovery catalog
Cause: the specified datafile is not in the recovery catalog or it has been marked deleted
Action: check the datafile copy name or key
RMAN-20231: ambiguous datafilecopy name
Cause: more than one controlfile copy in the recovery catalog match the specified name.
Action: use the datafile copy key to uniquely specify the datafile copy
RMAN-20240: archived log not found in the recovery catalog
Cause: the specified archived log was not found in the recovery catalog or it has been marked deleted
Action: check the archived log name or key
RMAN-20241: ambiguous archived log name
Cause: more than one archived log in the recovery catalog match the specified name
Action: use the archived log key to uniquely specify the archived log
RMAN-20250: offline range not found in the recovery catalog
Cause: the specified offline was not found in the recovery catalog
Action: check that recovery catalog is current
RMAN-20260: backup piece not found in the recovery catalog
Cause: the specified backup piece is not in the recovery catalog or it has been marked deleted
Action: check the backup piece handle or key
RMAN-20261: ambiguous backup piece handle
Cause: more than one backup piece in the recovery catalog match the specified handle
Action: use the backup piece key to uniquely specify the backup piece
RMAN-20272: no parent backup found for the incremental backup
Cause: no available backup or copy that could be used as the parent of the incremental backup was found in the recovery catalog.
Action: take a level 0 backup or copy of the datafile first
RMAN-20280: too many device types
Cause: more than 8 device types were allocated
Action: make sure that the job allocates at most 8 different device types
RMAN-20298: DBMS_RCVCAT package not compatible with the recovery catalog
Cause: The version of the recovery catalog tables does not work with this version of the DBMS_RCVCAT package.
Action: Check that the recovery catalog packages and schema are installed correctly. The UPGRADE CATALOG command can be used to upgrade the recovery catalog tables and packages to the most current version.
RMAN-20299: DBMS_RCVMAN package not compatible with the recovery catalog
Cause: The version of the recovery catalog tables does not work with this version of the DBMS_RCVMAN package.
Action: Check that the recovery catalog packages and schema are installed correctly. The UPGRADE CATALOG command can be used to upgrade the recovery catalog tables and packages to the most current version.
RMAN-20310: proxy copy not found in the recovery catalog
Cause: the specified proxy copy is not in the recovery catalog or it has been marked deleted
Action: check the proxy copy handle or key
RMAN-20311: ambiguous proxy copy handle
Cause: more than one proxy copy in the recovery catalog matches the specified handle
Action: use the proxy copy key to uniquely specify the proxy copy
RMAN-20401: script already exists
Cause: a CREATE SCRIPT was issued, but a script with the specified name already exists.
Action: use a different name or use REPLACE SCRIPT.
RMAN-20501: redo logs from parent database incarnation cannot be applied
Cause: A RESTORE or RECOVER of a datafile was requested, but recovery of the datafile would require applying redo logs that were generated before the most recent OPEN RESETLOGS.
Action: If a full backup or datafilecopy from the current database incarnation exists, ensure that it is marked AVAILABLE, and that a channel of the correct device type is allocated. It may also be necessary to remove the FROM BACKUPSET or FROM DATAFILECOPY or FROM TAG operands if these have been specified.
RMAN-20502: DELETE EXPIRED cannot delete objects that exist - run CROSSCHECK
Cause: A DELETE EXPIRED command was run, but the object was actually found to exist. This means the recovery catalog or controlfile is out of sync with reality.
Action: Run CROSSCHECK.
RMAN-20503: DELETE cannot delete expired objects - run CROSSCHECK or DELETE EXPIRED
Cause: A DELETE command was run without EXPIRED option, but the object doesn't exist. This means the recovery catalog or controlfile is out of sync with reality.
Action: Run CROSSCHECK.
RMAN-20504: corruption list not found in recovery catalog
Cause: corruption list is empty
Action: make sure that one or more blocks are marked corrupted in v$copy_corruption and v$backup_corruption and recovery catalog is up-to-date.
RMAN-20505: create datafile during recovery
Cause: applying of archived log caused a create datafile redo-entry to to terminate recovery.
Action: none. This message is never displayed. RMAN automatically detects this case and creates the datafile.
RMAN-20506: no backup of archivelog found
Cause: during the recover process, no backup was found from which the archivelogs could be restored.
Action: this message should be followed by a list of missing archivelogs. Please make the necessary archivelog backups available and try again.


33 LRM-00100 to LRM-00123

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

33 LRM-00100 to LRM-00123

LRM-00100: internal error [number]
Cause: An internal error has occurred.
Action: Contact Oracle Support Services and report the error.
LRM-00101: unknown parameter name 'string'
Cause: The parameter name was misspelled.
Action: Spell the parameter name correctly.
LRM-00102: 'string' is not in the legal range for 'string'
Cause: The value of the parameter is not within the legal range.
Action: Refer to the manual for the allowable values for this parameter.
LRM-00103: 'string' contains an illegal integer radix for 'string'
Cause: An illegal integer radix specification was found.
Action: Only 'd', 'h', 'D', and 'H' may be used as radix specifications.
LRM-00104: 'string' is not a legal integer for 'string'
Cause: The value is not a valid integer.
Action: Specify only valid integers for this parameter.
LRM-00105: 'string' is not a legal Boolean for 'string'
Cause: The value is not a valid Boolean.
Action: Refer to the manual for allowable Boolean values.
LRM-00106: out of memory
Cause: The operating system has run out of memory.
Action: Take action to make more memory available to the program.
LRM-00107: parameter name abbreviation 'string' is not unique
Cause: The given abbreviation was not unique.
Action: Use a longer abbreviation to make the parameter name unique.
LRM-00108: invalid positional parameter value 'string'
Cause: An invalid positional parameter value has been entered.
Action: Remove the invalid positional parameter.
LRM-00109: could not open parameter file 'string'
Cause: The parameter file does not exist.
Action: Create an appropriate parameter file.
LRM-00110: syntax error at 'string'
Cause: A syntax error was detected.
Action: Change the input so that the correct syntax is used.
LRM-00111: no closing quote for value 'string'
Cause: A quoted string was started but not finished.
Action: Put a closing quote in the proper location.
LRM-00112: multiple values not allowed for parameter 'string'
Cause: An attempt was made to specify multiple values for a parameter which can take only one value.
Action: Do not specify more than one value for this parameter.
LRM-00113: error when processing file 'string'
Cause: A problem occurred when processing this file.
Action: Examine the additional error messages and correct the problem.
LRM-00114: error when processing from command line
Cause: A problem occurred when processing the command line.
Action: Examine the additional error messages and correct the problem.
LRM-00115: error when processing an environment variable
Cause: A problem occurred when processing an environment variable.
Action: Examine the additional error messages and correct the problem.
LRM-00116: syntax error at 'string' following 'string'
Cause: A syntax error was detected.
Action: Change the input so that the correct syntax is used.
LRM-00117: syntax error at 'string' at the start of input
Cause: A syntax error was detected.
Action: Change the input so that the correct syntax is used.
LRM-00118: syntax error at 'string' at the end of input
Cause: A syntax error was detected.
Action: Change the input so that the correct syntax is used.
LRM-00119: unable to obtain a valid value for 'string'
Cause: No valid value was obtained for this parameter.
Action: Rerun the application and enter a valid value.
LRM-00120: 'string' is not a legal Oracle number for 'string'
Cause: The value is not a valid Oracle number.
Action: Refer to the manual for allowable Oracle number values.
LRM-00121: 'string' is not an allowable value for 'string'
Cause: The value is not a legal value for this parameter.
Action: Refer to the manual for allowable values.
LRM-00122: value 'string' for 'string' must be between 'number' and 'number'
Cause: The value of the parameter is not within the legal range.
Action: Specify a value that is within the legal range.
LRM-00123: invalid character number found in the input file
Cause: A character that is invalid was found in the input file.
Action: Specify an input file that contains only valid characters.


34 LFI-00002 to LFI-01523

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

34 LFI-00002 to LFI-01523

LFI-00002: Out of memory. string
Cause: The File IO package failed in trying to dynamically allocate memory. function name is used for additional comments to indicate where, when and why the error occured.
Action: Perform whatever actions necessary to make more memory available to the executing program.
LFI-00003: Internal exception code. icode = [string], [string].
Cause: Unknown - indicated by parameters. The first '%s' gives the internal exception code; the second is for any other additional comments.
Action: Report to the appropriate development group
LFI-00004: Call to string failed.
Cause: A function call has failed. This error is a generic message to show that the exception has occurred in a particular function function name. This allows the client to know the trace runtime calling sequence by examining the exception stack.
Action: See the accompanying error messages for more information.
LFI-00005: Free some memory failed in string.
Cause: A call to free some memory in function function name has failed.
Action: See the accompanying error messages for more information and contact Oracle Worldwide Support immediately.
LFI-00006: Invalid parameter to function string.
Cause: The function was called with an invalid parameter.
Action: Check the function call to make sure that the correct parameters are being passed.
LFI-00007: NLSRTL's call failed. string.
Cause: LX calls return failure
Action: Check if our parameters are correct. Contact the appropriate group immediately if we parameters are valid.
LFI-00008: SLTS's initializing/terminating mutex failed for string.
Cause: SLTS's call return failure in function '%s'.
Action: Contact the appropriate development group.
LFI-00100: Unable to perform operation, file not opened in string.
Cause: The file has not been successfully opened at the time the operation is attempted.
Action: Check to make sure that the file exists (for read) or that the program has access to the write a file (for write). It is also possible that the file was just never opened
LFI-00101: Write failed, file cannot be written to.
Cause: The buffer write operation failed. Possibly due to incorrect parameters being passed in.
Action: Check the underlying error for more information.
LFI-00102: Unable to seek in sequentially accessed file.
Cause: The file was opened with the flag LFILFA_SEQ for sequential file operations. Use seek only on files that are opened with the LFILFA_RANDOM flag for random access.
Action: Check to see how the file is being opened and accessed and make the two operations consistent (that is, make them both operations either sequential or random).
LFI-00103: Seek operation failed.
Cause: The buffer seek operation failed. Probably due to incorrect parameters or flags.
Action: Check syntax of the seek command and retry the operation.
LFI-00104: Read operation failed.
Cause: The buffer read operation failed. Probably due to incorrect parameters or flags.
Action: Check syntax of the read command and retry the operation.
LFI-00105: Unable to add path.
Cause: One of the following might have caused the error: the current path might not be in the proper format the directory might not be in the proper format the name object might not have been initialized properly
Action: Check the format of the current path and the new directory; check that the name object was initialized properly.
LFI-00106: Path object holds more than one path.
Cause: The path object passed to lfippth() holds more than one path.
Action: Make sure that the path object used in lfippth() holds only one path.
LFI-00107: Open does not expect the file [string][string] to exist.
Cause: The flags specified for the open indicate that the file does not exist. However, the file does exist.
Action: Check to make sure that the options that were specified for the file are correct and that you do not expect that the file should exist. If so then find out why the file does exist.
LFI-00108: Open expect the file [string][string] to exist.
Cause: The flags specified for the open indicate that the file the file to exist and it does not.
Action: Check to make sure that the options that were specified for the file are correct and that you expect that the file should exist. If so then find out why the file doesn't.
LFI-00109: Unable to open file [string][string]. string.
Cause: Either: the process does not have the proper access rights to open the file the file is already open
Action: Check to make sure the proper access permissions are assigned. If they are and the file still cannot be opened, then contact Oracle Worldwide Support.
LFI-00110: Unable to initialize the Buffer Manager.
Cause: The Buffer Manager initialization routine failed; probably because memory was exhausted.
Action: See the accompanying error messages for more information.
LFI-00111: No other flags allowed in fixed length format.
Cause: The function lfigfo() was called with an invalid File ID Descriptor. The valid File ID Descriptors are LFISTDIN, LFISTDOUT, and LFISTDERR.
Action: Check the call to lfigfo() to make sure it is correct.
LFI-00113: Unable to initialize the Standard File object string.
Cause: The call to open the standard file object failed.
Action: Check the underlying errors for more information.
LFI-00114: Append is not allowed with string.
Cause: Attempting to append using certain options.
Action: Check the flag options to verify its usage.
LFI-00115: Buffer free failed.
Cause: Probably do to the buffer flush failing.
Action: See the accompanying error messages for more information.
LFI-00116: Unable to close file in operation string.
Cause: The file close operation failed.
Action: See the accompanying error messages for more information.
LFI-00117: Unable to rename file.
Cause: The rename operation failed. Rename is called when we are protecting a file by operating on a temp file.
Action: Check to make sure that the process has the correct access rights to perform a rename.
LFI-00118: Unable to change type to Unknown.
Cause: The function lfichty() was called to change the file extension to LFIEXUNK (Unknown). This is not a valid operation.
Action: Check why you are doing this. If the extension is already unknown then you do not need to do this. If you just want no extension then use the extension type LFIEXNONE.
LFI-00119: Unable to Abort an Unprotected file.
Cause: The Abort function lfiabt() was called on a file that was not opened as a protected file. As such the abort operation is not valid.
Action: Check to see if you intended to open the file as a protected file.
LFI-00120: Unable to parse root filename string.
Cause: The root filename that was given to lfimknam() is not in a format that this platform understands.
Action: Check the format of the filename and retry the operation.
LFI-00121: Only one of REPLACE, or PROT allowed for opty.
Cause: Two or more of the following open type options were specified for the lfilini() function: LFILOPTY_REPLACE, or LFILOPTY_PROT.
Action: Remove one or more the of options such that you are only passing in one of the three.
LFI-00122: Can only delete a file if we create it.
Cause: The delete file flag was specified for a file that was not created by this file operation. The ability to delete a file is not portable. As such the only deletion that is allowed by this package is if we know we want to delete the file when we create it.
Action: You can only delete a file that you create. If you need to delete a file that you do not create then you will have to find another means of doing so.
LFI-00123: Cannot access file Sequentially and Randomly.
Cause: Both the LFILFA_SEQ (sequential) and LFILFA_RANDOM (random) flags were specified during the file object creation. This is not allowed. Only one of the two may be specified.
Action: Choose how you wish to access the file. If you choose random you can still access sequentially by just not using the repositioning functions.
LFI-00124: No access mode was specified, default is sequential.
Cause: Neither LFILFA_SEQ (sequential) or LFILFA_RANDOM (random) were specified during file object creation.
Action: The default is sequential but this should be explicitly set.
LFI-00125: Random access only allowed on fixed length record files.
Cause: The LFILFA_RANDOM flag was specified on a file that was not organized into fixed-length records. Random access is only allowed on fixed-length record files.
Action: Determine if the organization of your data needs to be in variable-length records and if you need to have random access to the file. If both conditions are true then you might need to buffer the entire file or enough of it to remove your need for random access. Another option is to close and rescan the file although this is not the optimal solution.
LFI-00126: Record format can only be one of Fixed or Variable.
Cause: Both LFILRF_FIXED (fixed) and LFILRF_VAR (variable) were specified during file object creation. Only one of the two is allowed for a given file.
Action: Determine how the file is organized and choose the option that matches.
LFI-00127: No Record Format was specified, default is variable.
Cause: Neither LFILRF_FIXED (fixed) or LFILRF_VAR (variable) were specified for record format. One of the two must be specified for each file.
Action: The default is LFILRF_VAR, but this should be explicitly set during file object creation.
LFI-00128: Carriage Control is only valid for Standard file objects.
Cause: The Carriage Control option is only valid for the standard file objects (LFISTDIN, LFISTDOUT, LFISTDERR). You may not specify this option for any other type of file.
Action: Choose between LFILRF_FIXED and LFILRF_VAR for the record format.
LFI-00129: Invalid option string were specified on an input only file.
Cause: The file was opened as input only but the output mode option LFILRF_WR_ASIS or delete option LFLOPTY_DELETE was specified.
Action: Check to see how you intend to open this file and make the necessary changes.
LFI-00130: Input option specified on output only file.
Cause: The file was opened as output only but one of the input mode options (LFILRF_READ_NL or LFILRF_FORCE_NL) or was specified.
Action: Check to see how you intend to open this file and make the necessary changes.
LFI-00131: No open type specified.
Cause: The file object was created without an open type (that is, LFILOPTY_INPUT, LFILOPTY_OUTPUT, etc.).
Action: Decide how the file should be accessed and specify one of the open types.
LFI-00132: Record length string is greater than max length of string.
Cause: The record length specified for the file is greater than the max supported by this platform.
Action: Decrease the record length.
LFI-00133: Trying to create file string that already exists.
Cause: The file object was initialized with LFILOPTY_OUTPUT and without LFILOPTY_REPLACE and yet a file by this name already exists.
Action: Check to make sure that you are creating the right file. If you intend to overwrite the file if it exists that specify the replace option LFILOPTY_REPLACE when initializing the file object.
LFI-00134: Unable to protect a file for an append operation.
Cause: The LFILOPTY_APPEND and LFILOPTY_PROT options were both specified for the file. This is currently not allowed because it would require copying the entire file at open time.
Action: Decide if you really need to protect the file for append. If so then think about making a copy of it before appending.
LFI-00135: Unable to remove temporary file.
Cause: A temporary file was created to protect a file and when the the tempfile was nolonger needed it LFI attempted to remove it and was unable to do so.
Action: Check the permissions and where the temp files are being created.
LFI-00136: Unable to change type of open file.
Cause: The function lfichty() was called on an opened file.
Action: This is a bug in the client code. lfichty() cannot be used in this case.
LFI-00137: Unable to perform string on a file object that is string.
Cause: Unable to perform an LFI operation on a file object for the given reason.
Action: Take the appropriate corrective measure. For example if a file is supposed to be opened before the operation can be performed, client code will need to open the file first.
LFI-00138: Unable to perform string on a name object that is string.
Cause: Unable to perform an LFI operation on a name object for the given reason.
Action: Take the appropriate corrective measure.
LFI-00139: Option string cannot be used with option string in calling string.
Cause: First option cannot be used with second option in such a function call.
Action: Re-examine code to determine which option is needed.
LFI-00140: Invalid option string were specified on input-output file.
Cause: The file was opened as input-output and one of the mode options (LFIOPTY_DELETE or non-LFIOPTY_RANDOM) was specified.
Action: Check to see how you intend to open this file and make the necessary changes.
LFI-00141: Unable to abort file in operation string.
Cause: The abort operation failed.
Action: Check the underlying errors for more information.
LFI-00142: Unable to delete an existing file [string][string] not owned by Oracle.
Cause: The file was not created by Oracle.
Action: Change owner of file to Oracle or give Oracle access privileges to delete it.
LFI-00143: Unable to delete non-existent file string.
Cause: The file to be deleted does not exist.
Action: Check the underlying errors for more information.
LFI-00144: File [string][string] does not exist
Cause: The file does not exist.
Action: Check to make sure the file exists and retry the operation.
LFI-00145: User buffer too short.
Cause: The buffer that was passed is not large enough.
Action: Allocate a larger buffer and retry the operation.
LFI-00146: copy does not expect the file string.string to exist
Cause: We are expecting the destination file not to exist and it does.
Action: Find out why the file does exist.
LFI-00147: File string.string does not exist
Cause: The file does not exist.
Action: Check to make sure the file exists and retry the operation.
LFI-00148: %s can be called only on files opened in byte mode
Cause: A routine that should be used only for files in byte mode was called for a file that was opened in record mode
Action: In order to use this function, the file should be opened in byte mode.
LFI-00149: Error on destroying hash table in function string
Cause: We were expecting the cache path object and it does not.
Action: In order to use this function, the path object should be cache path object.
LFI-00150: Error on creating hash table in function string
Cause: routine failed to create path object hash table
Action: make sure that startsize <= LHTQMAXSLOTS
LFI-00151: Error on inserting into hash table in function string
Cause: routine failed to insert into hash table
Action: make sure there is enough memory for allocation and that the hash table exists.
LFI-00152: Read operation (byte mode) failed.
Cause: Byte mode read operation failed. Probably due to incorrect parameters or flags, or trying to read beyond end of file.
Action: Check syntax of the read command and size of file.
LFI-01000: Unable to write line to file.
Cause: The file being written to may no longer be open or we may have reached the end of the file.
Action: Examine underlying errors for more information.
LFI-01001: Unable to write string bytes to file.
Cause: The file being written to may no longer be open or we may have reached the end of the file.
Action: Examine underlying errors for more information.
LFI-01002: Unable to read line from file.
Cause: The file being read from may no longer be open.
Action: Examine underlying errors for more information.
LFI-01003: Unable to read string bytes from file.
Cause: The file being read from may no longer be open.
Action: See the accompanying error messages for more information.
LFI-01004: Unable to empty buffer.
Cause: The buffer manager is probably unable to write to the underlying file.
Action: Examine underlying errors for more information.
LFI-01005: Unable to fill buffer.
Cause: The buffer manager is probably unable to read from the underlying file.
Action: See the accompanying error messages for more information.
LFI-01006: File ends in partial character in string.
Cause: A line ends in a partial character.
Action: Examine underlying errors for more information.
LFI-01007: Line is too long; encountered in function string.
Cause: The length of the line exceeds the maximum length.
Action: Examine underlying errors for more information.
LFI-01500: Error condition on call to OSD function string.
Cause: An error condition arises in calling an OSD function. This message occurs if calls to malloc or free functions failed.
Action: Contact Oracle Worldwide Support.
LFI-01501: tmpnam() fails to generate temporary file name.
Cause: Operating system was unable to create temporary file name.
Action: Contact the development organization.
LFI-01502: Base filename does not exist.
Cause: The filename that was parsed had no base file. It was either all path or extension.
Action: Check the filename being passed in to make sure it is correct.
LFI-01503: Max filename size exceeded generating filename.
Cause: While building a filename we exceeded the buffer allocated to hold the new filename.
Action: Contact the development organization.
LFI-01504: fseek() failed(OSD return value = string) in string.
Cause: The function fseek() returned an error condition.
Action: Contact Oracle Worldwide Support.
LFI-01505: fclose() failed(OSD return value = string) in string.
Cause: The function fclose() returned an error condition.
Action: Contact Oracle Worldwide Support.
LFI-01506: fflush() failed(OSD return value = string).
Cause: The function fflush() returned an error condition.
Action: Contact the development organization.
LFI-01507: fwrite() failed(OSD return value = string) in string.
Cause: File pointer may be null or may not be opened for write.
Action: Contact the development organization.
LFI-01508: access() failed.
Cause: Call to access() failed.
Action: Contact the development organization.
LFI-01509: fopen() failed(OSD return value = string).
Cause: Call to fopen() failed.
Action: Contact Oracle Worldwide Support.
LFI-01510: fread() failed(OSD return value = string) in string.
Cause: Call to fread() failed.
Action: Contact Oracle Worldwide Support.
LFI-01511: unlink() failed(OSD errno = string) in string.
Cause: Call to unlink() failed.
Action: Contact the development organization.
LFI-01512: stat() failed
Cause: Call to stat() failed.
Action: Contact Oracle Worldwide Support.
LFI-01514: ftell() failed in string
Cause: The ftell() function returned an error.
Action: Contact Oracle Worldwide Support.
LFI-01515: truncate() failed.
Cause: The function truncate() returned an error condition.
Action: Contact the development organization.
LFI-01516: read() failed (OSD return value = string) in string.
Cause: Call to read() failed.
Action: Contact the development organization.
LFI-01517: open() failed(OSD return value = string).
Cause: Call to open() failed.
Action: Contact the development organization.
LFI-01518: write() failed(OSD return value = string) in string.
Cause: Call to write() failed.
Action: Contact the development organization.
LFI-01519: llseek() failed(OSD return value = string) in string.
Cause: The llseek() function returned an error.
Action: Contact Oracle Worldwide Support.
LFI-01520: close() failed(OSD return value = string) in string.
Cause: The function close() returned an error condition.
Action: Contact the development organization.
LFI-01521: fsync() failed(OSD return value = string) in string.
Cause: The function fsync() returned an error condition.
Action: Contact the development organization.
LFI-01522: opendir() failed.
Cause: The function opendir() returned an error condition.
Action: Contact the development organization.
LFI-01523: rename() failed.
Cause: A call to lficstd() had failed.
Action: Contact development service


35 PLS-00049 to PLS-01913

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

35 PLS-00049 to PLS-01913

PLS-00049: bad bind variable 'string'
Cause: The client (caller) of PL/SQL has parsed a bind variable that it has informed to be 'bad'.
Action: none
PLS-00101: reserved for future use
Cause: This error message is not used yet. (Heh, heh, that's a joke, son.)
Action: none
PLS-00102: parser stack overflow because nesting is too deep
Cause: The parser, which checks the syntax of PL/SQL statements, uses a data structure called a stack; the number of levels of nesting in the PL/SQL block exceeded the stack capacity.
Action: Reorganize the block structure to avoid nesting at too deep a level. For example, move the lowest-level sub-block to a higher level.
PLS-00103: %s
Cause: This error message is from the parser. It found a token (language element) that is inappropriate in this context.
Action: Check previous tokens as well as the one given in the error message. The line and column numbers given in the error message refer to the end of the faulty language construct.
PLS-00104: empty argument list in call of procedure 'string' must be omitted
Cause: In a subprogram call, the name of the subprogram was followed by an empty parameter list. For example, procedure P was called as P(). This is not allowed.
Action: Remove the empty parameter list. In the example, change the procedure call to P.
PLS-00105: at most one forward declaration of type 'string' is permitted
Cause: More than one forward declaration of a type is redundant.
Action: Remove all but one forward declaration.
PLS-00108: declarative units must be a single variable declaration
Cause: While checking a declarative unit (a top-level declare block without the BEGIN...END), PL/SQL found that there was more than one item declared or that the item was not a variable declaration. A table is a common variable declaration at the unit level. To define a TABLE, compile a DECLARE compilation unit, but only one at a time is allowed.
Action: Declare variables in separate declarative units.
PLS-00109: unknown exception name 'string' in PRAGMA EXCEPTION_INIT
Cause: No declaration for the exception name referenced in an EXCEPTION_INIT pragma was found within the scope of the pragma.
Action: Make sure the pragma follows the exception declaration and is within the same scope.
PLS-00110: bind variable 'string' not allowed in this context
Cause: A bind variable, that is, an identifier prefixed with a colon, was found in an inappropriate context.
Action: Remove the colon or replace the bind variable with the appropriate object.
PLS-00111: end-of-file in comment
Cause: A Comment had a comment initiator (/*), but before the
Action: Remove the Comment initiator or add a comment terminator. The line and column numbers accompanying the error message refer to the beginning of the last legal token before the Comment initiator.
PLS-00112: end-of-line in quoted identifier
Cause: A quoted identifier had a beginning quote ("), but before the ending quote (") was found, an end-of-line marker was encountered.
Action: Remove the beginning quote or add the ending quote. The line and column numbers accompanying the error message refer to the beginning of the quoted identifier.
PLS-00113: END identifier 'string' must match 'string' at line string, column string
Cause: Following the keyword END, which terminates some language constructs (such as loops, blocks, functions, and procedures), you can optionally place the name of that construct. For example, at the end of the definition of loop L you might write END L. This error occurs when the optional name does not match the name given to the language construct. It is usually caused by a misspelled identifier or by faulty block structure.
Action: Make sure the spelling of the END identifier matches the name given to the language construct and that the block structure is correct.
PLS-00114: identifier 'string' too long
Cause: The name of a PL/SQL variable is longer than 30 characters. Legal identifiers (including quoted identifiers) have a maximum length of 30 characters. A string literal might have been mistakenly enclosed in double quotes instead of single quotes, in which case PL/SQL considers it a quoted identifier.
Action: Shorten the identifier.
PLS-00115: this PRAGMA must follow the declaration of 'string'
Cause: The pragma refers to a PL/SQL object that was not declared or is not within the scope of the reference. Identifiers must be declared before they are used in a pragma; forward references are not allowed.
Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.
PLS-00116: Duplicate where-clause in table expression
Cause: Two or more WHERE clauses were found in a DELETE, SELECT, or UPDATE statement. The WHERE clause specifies a condition under which rows in a table are processed. The condition can contain several logical expressions connected by AND or OR, but a statement can contain only one WHERE clause.
Action: Remove one of the WHERE clauses and, if necessary, connect logical expressions by AND or OR
PLS-00117: Duplicate connect-by clause in table expression
Cause: Two or more CONNECT BY clauses were found in a SELECT statement. The CONNECT BY clause defines a relationship used to return rows in a hierarchical order. The relationship can contain two expressions separated by a relational operator (such as = or !=), but a statement can contain only one CONNECT BY clause.
Action: Remove one of the CONNECT BY clauses and, if necessary, separate expressions by a relational operator.
PLS-00118: Duplicate group-by clause in table expression
Cause: Two or more GROUP BY clauses were found in a SELECT statement. The GROUP BY clause lists column expressions used to form a summary row for each group of selected rows. The list can contain several column expressions separated by commas, but a statement can contain only one GROUP BY clause.
Action: Remove one of the GROUP BY clauses and, if necessary, separate column expressions by commas.
PLS-00119: Duplicate having-clause in table expression
Cause: Two or more HAVING clauses were found in a SELECT statement. The HAVING clause specifies a condition under which groups of rows (formed by the GROUP BY clause) are included in the result. The condition can include several logical expressions connected by AND or OR, but a statement can contain only one HAVING clause.
Action: Remove one of the HAVING clauses and, if necessary, connect logical expressions by AND or OR.
PLS-00120: inappropriate argument in OPEN statement
Cause: The asterisk (*) option was used in the argument list of a SQL group function other than COUNT. For example, the code might look like SELECT SUM(*) INTO emp_count FROM emp; -- should be COUNT(*) Only COUNT permits the use of the asterisk option, which returns the number of rows in a table.
Action: Remove the asterisk option from the argument list and replace it with an expression that refers to one or more database columns.
PLS-00122: %s as separator is allowed only with specific built-in functions
Cause: A few built-in functions use keywords (instead of commas) as argument separators: Built-in function Argument separators --------------------------------------------- CHR, TRANSLATE USING CAST AS TRIM TRAILING, LEADING, BOTH, FROM A function different from one of these built-in functions is using a keyword as an argument separator.
Action: Correct the argument list or change the function name.
PLS-00123: program too large
Cause: PL/SQL was designed primarily for robust transaction processing. One consequence of the special-purpose design is that the PL/SQL compiler imposes a limit on block size. The limit depends on the mix of statements in the PL/SQL block. Blocks that exceed the limit cause this error.
Action: The best solution is to modularize the program by defining subprograms, which can be stored in an Oracle database. Another solution is to break the program into two sub-blocks. Have the first block INSERT any data the second block needs into a temporary database table. Then, have the second block SELECT the data from the table.
PLS-00124: name of exception expected for first arg in exception_init pragma
Cause: The first argument passed to the EXCEPTION_INIT pragma was something other than an exception name. The first argument must be the name of a legally declared exception.
Action: Replace the first argument with the name of a legally declared exception.
PLS-00125: type name expected
Cause: When a constant or variable was declared, its datatype was not specified. For example, the code might look like pi CONSTANT := 3.14159; -- should be CONSTANT REAL := 3.14159 Every constant and variable must have a datatype, which specifies a storage format, constraints, and valid range of values.
Action: Supply the type name
PLS-00126: selector ALL is not allowed
Cause: The ALL shortcut for specifying system privileges or statement options was used in a SQL statement. PL/SQL does not support the ALL shortcut.
Action: Remove the ALL shortcut from the SQL statement.
PLS-00127: Pragma string is not a supported pragma
Cause: The named pragma (compiler directive) is not among those supported by PL/SQL. The pragma name might be misspelled, or the pragma syntax might be faulty.
Action: Check the spelling of the pragma name, and make sure the proper syntax was used.
PLS-00128: Illegal number of arguments for pragma string
Cause: The number of arguments (actual parameters) passed to the named pragma (compiler directive) is incorrect. A required argument was omitted from the argument list, or the pragma syntax is faulty (for example, a comma might be missing between two parameters).
Action: Supply the missing argument, or correct the faulty syntax.
PLS-00129: Pragma INTERFACE only supports C as its first argument
Cause: The first parameter passed to pragma INTERFACE specified a host language other than C. Currently, C is the only host language supported. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).
Action: Check the spelling of the first parameter, which should be C, and make sure the proper syntax was used.
PLS-00130: Pragma string expects 1st argument to be a procedure/function/package/cursor
Cause: The first argument (actual parameter) passed to the named pragma (compiler directive) was not the name of a subprogram, package, or cursor, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).
Action: Check the spelling of the first parameter, and make sure the proper syntax was used.
PLS-00131: Pragma string expects 2nd argument to be a procedure
Cause: The second argument (actual parameter) passed to the named pragma (compiler directive) was not the name of a procedure, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).
Action: Check the spelling of the second parameter, and make sure the proper syntax was used.
PLS-00132: Pragma RESTRICT_REFERENCES does not support string
Cause: One of the parameters passed to pragma RESTRICT_REFERENCES was not among the following, as required: WNDS, WNPS, RNDS, RNPS. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters)
Action: Check the spelling of all the parameters, and make sure the proper syntax was used.
PLS-00133: Pragma string expects 1st argument to be an identifier or string-literal
Cause: The first argument (actual parameter) passed to the named pragma (compiler directive) was not an identifier or string literal, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).
Action: Check the spelling of the first parameter, and make sure the proper syntax was used.
PLS-00134: Pragma string expects 2nd argument to be an identifier or string-literal
Cause: The second argument (actual parameter) passed to the named pragma (compiler directive) was not an identifier or string literal, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).
Action: Check the spelling of the second parameter, and make sure the proper syntax was used.
PLS-00135: Pragma string expects 3rd argument to be an identifier, string or numeric literal
Cause: The fourth argument (actual parameter) passed to the named pragma (compiler directive) was not a numeric literal, as required. The parameter might be miscoded, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).
Action: Check the coding of the fourth parameter, and make sure the proper syntax was used.
PLS-00138: Precision for a binary type must be one of 8, 16, or 32
Cause: Invalid precision was specified for a signed or unsigned binary type.
Action: Specify precision as one of 8, 16, or 32.
PLS-00139: duplicate external NAME specification in subprogram expression
Cause: The subprogram was found to have two external NAME specifications.
Action: Remove one of the external NAME specifications.
PLS-00140: duplicate external LIBRARY specification in subprogram expression
Cause: The subprogram was found to have two external LIBRARY specifications.
Action: Remove one of the external LIBRARY specifications.
PLS-00141: duplicate external PARAMETER STYLE specification in subprogram expression
Cause: The subprogram was found to have two external PARAMETER STYLE specifications.
Action: Remove one of the external PARAMETER STYLE specifications.
PLS-00142: duplicate external PARAMETER list specification in subprogram expression
Cause: The subprogram was found to have two external PARAMETER STYLE specifications.
Action: Remove one of the external PARAMETER STYLE specifications.
PLS-00143: duplicate external LANGUAGE specification in subprogram expression
Cause: The subprogram was found to have two external LANGUAGE specifications.
Action: Remove one of the external LANGUAGE specifications.
PLS-00144: duplicate external CALLING STANDARD specification in subprogram expression
Cause: The subprogram was found to have two external CALLING STANDARD specifications.
Action: Remove one of the external CALLING STANDARD specifications.
PLS-00145: duplicate external WITH CONTEXT specification in subprogram expression
Cause: The subprogram was found to have two external WITH CONTEXT specifications.
Action: Remove one of the external WITH CONTEXT specifications.
PLS-00146: duplicate external TRUSTED/UNTRUSTED specification in subprogram expression
Cause: The subprogram was found to have two external TRUSTED/UNTRUSTED specifications.
Action: Remove one of the external external TRUSTED/UNTRUSTED specifications.
PLS-00147: LIBRARY file specification string is empty
Cause: A zero-length string was found for the LIBRARY file specification.
Action: Specify a non-zero length string for the LIBRARY file specification.
PLS-00148: Only 1 pragma of this type is allowed per subprogram
Cause: The subprogram was found to have two PRAGMA RESTRICT_REFERENCES.
Action: Remove one of the PRAGMA RESTRICT_REFERENCES.
PLS-00150: found: string but expected : INTEGER
Cause: This error happens in the creation of a pl/sql external type: [SIGNED | UNSIGNED] BINARY INTEGER (<precision>). It may be referenced only in a create type statement. Such types are non-queryable. Something other than 'INTEGER' was supplied.
Action: none
PLS-00151: Expression or Variable is an illegal type to PLS/QL: string
Cause: A type was used which does not belong PL/SQL. This type can only be referenced in CREATE TYPE statements, and is a non-queryable data type.
Action: none
PLS-00152: POINTER type may only reference an object type.
Cause: A POINTER type which does not belong to PL/SQL can only refer to an object type. This type can only be referenced in CREATE TYPE statements, and is a non-queryable data type.
Action: none
PLS-00153: A string type may only be used as an object type attribute.
Cause: A POINTER or [SIGNED/UNSIGNED] BINARY INTEGER can only be used as attributes of object types. These types can only be referenced in CREATE TYPE statements, and are non-queryable data types. One of these external PL/SQL types outside of an object type.
Action: none
PLS-00154: An object type may have only 1 MAP or 1 ORDER method.
Cause: More than one map or order function was declared. An object type can have only one map function or one order function, but not both.
Action: none
PLS-00155: Only a function may be a MAP, ORDER or CONSTRUCTOR method.
Cause: A procedure was declared as a MAP, ORDER or CONSTRUCTOR method. Only functions can be MAP, ORDER or CONSTRUCTOR methods.
Action: none
PLS-00156: Null constraints not supported for object attributes.
Cause: A null constraint was specified for an attribute in an object. This is not supported.
Action: Remove the constraint.
PLS-00157: AUTHID only allowed on schema-level programs
Cause: An AUTHID clause was specified for a subprogram inside a package or type. These clauses are only supported for top-level stored procedures, packages, and types.
Action: Remove the clause
PLS-00160: AUTHID must specify CURRENT_USER or DEFINER
Cause: The only two allowed options for AUTHID are CURRENT_USER and DEFINER.
Action: Fix the AUTHID clause to specify CURRENT_USER or DEFINER
PLS-00161: Pragma string expects 3rd argument to be an identifier or a string literal
Cause: The third argument (actual parameter) passed to the named pragma (compiler directive) was not an identifier or a string literal when there is a fourth argument to the pragma. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).
Action: Check the spelling of the third parameter, and make sure the proper syntax was used.
PLS-00162: Pragma string expects 4th argument to be a positive integer literal
Cause: The fourth argument (actual parameter) passed to the named pragma (compiler directive) was not a numeric literal, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).
Action: Check the spelling of the fourth parameter, and make sure the proper syntax was used.
PLS-00164: cursor subqueries are not supported in this release
Cause: This feature is not yet implemented.
Action: none
PLS-00165: call statement is not supported in PL/SQL
Cause: A CALL statement was found in PL/SQL source.
Action: Use an ordinary PL/SQL function or procedure call.
PLS-00166: bad format for date, time or timestamp literal
Cause: The contents of the date, time or timestamp literal did not match the expected format 'yyyy-mm-dd hh24:mi:ssxfftzh:tzm'.
Action: Use a correctly-formatted datetime literal.
PLS-00167: keyword BULK is used in a wrong context
Cause: keyword BULK is used illegally. For example, BULK is used without INTO clause
Action: remove the keyword BULK.
PLS-00168: duplicate modifier specification 'string'
Cause: A method or object type modifier was specified more than once.
Action: Remove all but one occurence of the duplicate modifier.
PLS-00169: modifier 'string' conflicts with prior 'string' specification
Cause: The method or object type modifier specified conflicts with an earlier modifier. For example, a FINAL modifier cannot be combined with a NOT FINAL modifier.
Action: Remove one of the conflicting modifiers.
PLS-00170: the SQL statement in an OPEN statement or FOR loop must be a SELECT
Cause: An OPEN cursor statement or cursor FOR loop can only invoke a SELECT statement, not an UPDATE, INSERT or DELETE.
Action: Use only SELECT statements in OPEN or cursor FOR loops
PLS-00171: duplicate dedicated AGENT specification in subprogram expression
Cause: The subprogram was found to have two dedicated AGENT specifications.
Action: Remove one of the dedicated AGENT specifications.
PLS-00172: string literal too long
Cause: The string literal was longer than 32767 bytes.
Action: Use a string literal of at most 32767 bytes.
PLS-00173: SPACE, TAB or RETURN are disallowed as alternative quote delimiters
Cause: SPACE, TAB or RETURN was used as alternative quote delimiter.
Action: Use a character other than SPACE, TAB or RETURN as the alternative quote delimiter.
PLS-00201: identifier 'string' must be declared
Cause: You tried to reference either an undeclared variable, exception, procedure, or other item, or an item to which no privilege was granted or an item to which privilege was granted only through a role.
Action: 1) Check your spelling and declaration of the referenced name. 2) Verify that the declaration for the referenced item is placed correctly in the block structure. 3) If the referenced item is indeed declared but you don't have privileges to refer to that item, for security reasons, you will be notified only that the item is not declared. 4) If the referenced item is indeed declared and you believe that you have privileges to refer to that item, check the privileges; if the privileges were granted only via a role, then this is expected and documented behavior. Stored objects (packages, procedures, functions, triggers, views) run in the security domain of the object owner with no roles enabled except PUBLIC. Again, you will be notified only that the item was not declared.
PLS-00202: type 'string' must be declared
Cause: An attempt was made to reference an undefined type. Either the type specifier was not declared or it is not within the scope of the reference.
Action: Check the spelling and declaration of the type specifier. Also confirm that the declaration is placed correctly in the block structure.
PLS-00203: function DECODE must be called with at least 3 non-boolean arguments
Cause: Less than three arguments were passed to the built-in function DECODE. Though DECODE takes a variable number of (non-Boolean) arguments, at least three arguments must be passed.
Action: Call DECODE with three or more arguments
PLS-00204: function or pseudo-column 'string' may be used inside a SQL statement only
Cause: A pseudocolumn or proscribed function was used in a procedural statement. The SQL pseudocolumns (CURRVAL, LEVEL, NEXTVAL, ROWID, ROWNUM) can be used only in SQL statements. Likewise, certain functions such as DECODE, DUMP, and VSIZE and the SQL group functions (AVG, MIN, MAX, COUNT, SUM, STDDEV, VARIANCE) can be used only in SQL statements.
Action: Remove the pseudocolumn reference or function call from the procedural statement. Or, replace the procedural statement with a SELECT INTO statement; for example, replace bonus := DECODE(rating, 1, 5000, 2, 2500, ...); with the following statement: SELECT DECODE(rating, 1, 5000, 2, 2500, ...) INTO bonus FROM dual;
PLS-00205: Aggregate not allowed here
Cause: An aggregate, that is, a parenthesized list of values such as (7788, 'SCOTT', 20), was found in an inappropriate context.
Action: Remove or relocate the aggregate.
PLS-00206: %%TYPE must be applied to a variable, column, field or attribute, not to "string"
Cause: The program object declared using the %TYPE datatype attribute is not of the appropriate class. It must be a variable, column, record component, subprogram formal parameter, or other object to which values can be assigned.
Action: Declare an object of the appropriate class or define the datatype in another way (for example, use %ROWTYPE).
PLS-00207: identifier 'string', applied to implicit cursor SQL, is not a legal cursor attribute
Cause: An identifier that is not a cursor attribute was applied to the identifier SQL. For example, this error occurs if the cursor attribute is misspelled.
Action: Check the spelling of the cursor attribute name. Make sure the attribute is one of these: %NOTFOUND, %FOUND, %ROWCOUNT, %ISOPEN.
PLS-00208: identifier 'string' is not a legal cursor attribute
Cause: An identifier not declared as a cursor attribute was applied to an identifier declared as a cursor. For example, this error occurs if the cursor attribute is misspelled.
Action: Check the spelling of the cursor attribute name. Make sure the attribute is one of these: %NOTFOUND, %FOUND, %ROWCOUNT, %ISOPEN.
PLS-00209: table 'string' is not in FROM clause
Cause: In a query, a table referenced by the select list is not named in the FROM clause.
Action: Check the spelling of the table names, make sure each column in the select list refers to a table in the FROM clause, then re-execute the query.
PLS-00210: an OTHERS clause is required in this CASE statement
Cause: Unless the clauses of a CASE statement mention all values of the type of the selecting expression, an OTHERS clause must be provided as the last clause of the CASE statement. It is impossible to cover all values of type INTEGER (or NUMBER), so an OTHERS clause is always required when the expression following the keyword CASE is of type INTEGER (or NUMBER).
Action: none
PLS-00211: CASE labels or ranges must not be duplicated in different WHEN clauses
Cause: In this CASE statement, a value appears in more than one WHEN clause. A value may appear in at most one WHEN clause of a CASE statement.
Action: none
PLS-00212: could not obtain enough memory to compile CASE statement
Cause: The CASE statement is too big. The compiler did not have enough storage to process it.
Action: none
PLS-00213: package STANDARD not accessible
Cause: The PL/SQL compiler could not find package STANDARD in the current Oracle database. To compile a program, PL/SQL needs package STANDARD.
Action: Make sure that package STANDARD is available in the current Oracle database, then retry the operation.
PLS-00214: BEGIN...END block nesting is too deep
Cause: The number of levels of nesting in the PL/SQL block is too large. Blocks can be nested up to 255 levels deep, depending on the availability of system resources such as memory.
Action: Reorganize the block structure to avoid nesting at too deep a level. For example, move the lowest-level sub-block to a higher level.
PLS-00215: String length constraints must be in range (1 .. 32767)
Cause: When a character variable was declared, a length outside the legal range was specified. For example, the following declarations are illegal: flag CHAR(0); -- illegal; zero length name VARCHAR2(-10); -- illegal; negative length
Action: Change the length constraint, making sure that it lies in the range 1 .. 32767.
PLS-00216: NUMBER precision constraint must be in range (1 .. 38)
Cause: A NUMBER variable was declared with a precision that is outside the legal range. Declarations such as N NUMBER(800) or N NUMBER(123,10) are not supported.
Action: Change the illegal NUMBER precision constraint, making sure that it lies in the range 1 .. 38.
PLS-00217: NUMBER scale constraint must be in range (-84 .. 127)
Cause: A NUMBER variable was declared with a scale that is outside the legal range. Declarations such as N NUMBER(10,345) or N NUMBER(10,-100) are not supported.
Action: Change the illegal NUMBER scale constraint, making sure that it lies in the range -84 .. 127.
PLS-00218: a variable declared NOT NULL must have an initialization assignment
Cause: In general, variables that have no initialization clause in their declaration are automatically initialized to NULL. This is illogical for NOT NULL variables; therefore, an initialization clause is required.
Action: Add an initialization clause to the variable declaration. If the initilization is too complicated for the syntax, one can add a function call (in a later release).
PLS-00219: label 'string' reference is out of scope
Cause: A block or loop label was used to qualify a variable (as in outer_block.date) that was not declared or is not within the scope of the label. The variable name might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.
Action: Check the spelling and declaration of the variable name. Also confirm that the declaration is placed correctly in the block structure.
PLS-00220: simple name required in this context
Cause: A qualified name such as A.B or A.B.C is not permitted here.
Action: Use a simple name such as A instead.
PLS-00221: 'string' is not a procedure or is undefined
Cause: An identifier being referenced as a procedure was not declared or actually represents another object (for example, it might have been declared as a function).
Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.
PLS-00222: no function with name 'string' exists in this scope
Cause: An identifier being referenced as a function was not declared or actually represents another object (for example, it might have been declared as a procedure).
Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.
PLS-00223: paramaterless procedure 'string' used as function
Cause: An identifier being referenced as a parameterless function actually represents a procedure.
Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure. If necessary, change the declaration of the identifier or change the reference so that it does not require a return value.
PLS-00224: object 'string' must be of type function or array to be used this way
Cause: An identifier being referenced as a function or an array actually represents an object (a number or date, for example) that cannot be referenced in this way.
Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.
PLS-00225: subprogram or cursor 'string' reference is out of scope
Cause: The prefix in a qualified name was a subprogram or cursor which was not in an enclosing scope; i.e., a subprogram or cursor name is being used as a scope qualifier for a reference to an entity (within that subprogram or cursor) that is not in scope. Example: declare x number; type t1 is record (a number); function f return t1 is a number; begin x := f.a; -- legal use of function "f" as a scope qualifier; -- resolves to local variable "a" in function "f". x := f().a; -- legal reference to component "a" of returned record end; begin x := f.a; -- illegal use of function "f" as a scope qualifier x := f().a; -- legal reference to component "a" of returned record end;
Action: a) if the intention was to refer to a local variable of a non-enclosing function, this is not allowed; remove the reference b) if this is a parameterless function, and the the intention was to access a field of the result of a call to this function, then use empty parentheses in the call.
PLS-00226: package 'string' used as variable reference
Cause: A package was referenced in an expression as if it were a variable or function. Either the name of the variable or function is misspelled or the reference is not fully qualified. For example, to call the function my_function, which is stored in package my_package, dot notation must be used, as follows: ... my_package.my_function ...
Action: Correct the spelling of the variable or function name or use dot notation to reference the packaged variable or function.
PLS-00227: subprogram 'in' formal string is not yet denotable
Cause: When the formal parameters of a subprogram were declared, one parameter was used to initialize another, as in PROCEDURE my_proc (j NUMBER, k NUMBER := j) IS ... The first parameter has no value until run time, so it cannot be used to initialize another parameter.
Action: Remove the illegal formal parameter reference.
PLS-00228: Illegal declaration of variable of type LONG
Cause: The identifier is a formal parameter which is being used in the context of a default expression value for a formal parameter in the same formal parameter list. E.g.: procedure p(j number, k number := j).
Action: Remove the offending variable definition
PLS-00229: Attribute expression within SQL expression
Cause: An attribute expression, such as SQL%NOTFOUND, was used in a SQL statement, but attribute expressions are allowed only in procedural statements.
Action: To workaround this limitation, assign the value of the attribute expression to a variable, then use the variable in the SQL statement. For example, replace the statement INSERT INTO audits VALUES (c1%ROWCOUNT, ...); with the following statements: row_count := c1%ROWCOUNT; INSERT INTO audits VALUES (row_count, ...);
PLS-00230: OUT and IN OUT formal parameters may not have default expressions
Cause: When the formal parameters of a procedure were declared, an OUT or IN OUT parameter was initialized to a default value, as in PROCEDURE calc_bonus (bonus OUT REAL := 0, ...) IS ... However, only IN parameters can be initialized to default values.
Action: Remove the illegal default expression.
PLS-00231: function 'string' may not be used in SQL
Cause: A proscribed function was used in a SQL statement. Certain functions such as SQLCODE and SQLERRM can be used only in procedural statements.
Action: Remove the function call from the SQL statement. Or, replace the function call with a local variable. For example, the following statement is illegal: INSERT INTO errors VALUES (SQLCODE, SQLERRM); However, you can assign the values of SQLCODE and SQLERRM to local variables, then use the variables in the SQL statement, as follows: err_num := SQLCODE; err_msg := SQLERRM; INSERT INTO errors VALUES (err_num, err_msg);
PLS-00232: nested packages not permitted
Cause: A package was declared inside another package, but package declarations are allowed only at the top level. In other words, packages cannot be nested.
Action: Move the package declaration outside the enclosing package.
PLS-00233: function name used as an exception name in when clause
Cause: The WHEN clause in an exception handler contains a function call instead of an exception name. A valid exception handler consists of a WHEN clause, which must specify an exception, followed by a sequence of statements to be executed when that exception is raised.
Action: Check the spelling of the identifier in the WHEN clause, then replace the function call with an exception name.
PLS-00234: PARAMETER STYLE SQL may not be specified with a PARAMATERS list
Cause: A subprogram cannot specify both PARAMETER STYLE SQL and an explicit PARAMETERS list. Use PARAMETER STYLE GENERAL to supply default PARAMETERS list types.
Action: Change the subprogram specification.
PLS-00235: the external type is not appropriate for the parameter
Cause: An unsuccessful attempt was made to convert a parameter to the specified external parameter type.
Action: Specify a different external type or parameter type.
PLS-00236: Invalid external type specification for string.
Cause: The external type specified is not valid for one of the following: INDICATOR, LENGTH, MAXLEN, TDO, DURATION, CHARSETID, or CHARSETFORM.
Action: Check the manual and specify an appropriate external type.
PLS-00237: invalid BY VALUE indicator or length specification
Cause: BY VALUE was specified with an indicator or length parameter that is being passed in OUT or IN OUT mode. Only IN mode parameters may be passed by value.
Action: Remove the BY VALUE specification or change it to IN mode.
PLS-00238: external parameter name string not found in formal parameter list
Cause: An external parameter name was specified that does not match one in the formal parameter list.
Action: Correct the external parameter name.
PLS-00239: invalid external type specification for SQLCODE
Cause: An inappropriate external parameter type was specified for the SQLCODE parameter.
Action: Correct the SQLCODE parameter specification.
PLS-00240: Invalid type specification for RETURN indicator, length, tdo, duration
Cause: An inappropriate external parameter type was specified for the RETURN indicator, LENGTH, TDO, or DURATION.
Action: Correct the RETURN parameter specification.
PLS-00241: invalid external type specification for SQLSTATE
Cause: An inappropriate external parameter type was specified for the SQLSTATE parameter.
Action: Correct the SQLSTATE parameter specification.
PLS-00242: invalid external type specification for CONTEXT
Cause: An inappropriate external parameter type was specified for the CONTEXT parameter.
Action: Correct the CONTEXT parameter specification.
PLS-00243: invalid external type specification for SQLNAME
Cause: An inappropriate external parameter type was specified for the SQLNAME parameter.
Action: Correct the SQLNAME parameter specification.
PLS-00244: Multiple declarations in foreign function formal parameter list
Cause: There are multiple declarations of at least one the following FORMAL, INDICATOR, LENGTH, MAXLENGTH, or CONTEXT. PL/SQL allows only one declaration of the above for each formal parameter in the PARAMETERS clause.
Action: Correct the PARAMETERS clause.
PLS-00245: Formals used in the 'parameters' clause must appear exactly once
Cause: There are multiple declarations of the formal parameter in the PARAMETERS clause. PL/SQL allows only one declaration of the formal parameter in the PARAMETERS clause.
Action: Correct the PARAMETERS clause.
PLS-00246: PARAMETER STYLE is unsupported
Cause: A PARAMETER STYLE clause was placed in the external subprogram body.
Action: Remove the PARAMETER STYLE clause.
PLS-00247: LIBRARY name must be specified
Cause: The LIBRARY name is missing from the external subprogram body.
Action: The LIBRARY name was not specified in the external subprogram body.
PLS-00248: Invalid Library Syntax
Cause: The LIBRARY syntax was entered incorrectly.
Action: Correct the LIBRARY syntax and recompile.
PLS-00249: Invalid WITH CONTEXT Syntax
Cause: CONTEXT was used in a WITH CONTEXT or a PARAMETERS clause. This is invalid.
Action: Check if WITH CONTEXT is used without specifying CONTEXT in the PARAMETERS clause or vice versa. The PARAMETERS clause must be complete. Thus if WITH CONTEXT is specified, then CONTEXT must be referenced in the PARAMETERS clause (if there is one).
PLS-00250: Incorrect Usage of string in parameters clause.
Cause: The usage of Keywords such as MAXLEN, LENGTH, CHARSETID, CHARSETFORM RETURN in the parameters clause was incorrect
Action: This error occurs if keywords like MAXLEN, LENGTH, TDO, DURATION, CHARSETID, or CHARSETFORM cannot be used with PL/SQL formal parameters or the mode of the formal parameter. For example, MAXLEN can only be declared for a CHAR or VARCHAR2 PL/SQL variable and its use is allowed only for OUT or INOUT PL/SQL variables. Also, RETURN was specified in the parameters clause for a PL/SQL PROCEDURE. E.g. CREATE PROCEDURE proc IS EXTERNAL NAME ... LIBRARY ... PARAMETERS(RETURN INDICATOR SHORT, RETURN);
PLS-00251: RETURN, for actual function return, must be last in the parameters clause
Cause: RETURN specification for the actual function return, used within the parameters clause must hold the very last position. Example : The following will give this error since the RETURN specification for the actual function return in the parameters clause is not the last. FUNCTION myexternalfunc (var1 BINARY_INTEGER, var2 BINARY_INTEGER) RETURN BINARY_INTEGER IS EXTERNAL NAME "myexternalfunc" LIBRARY somelib PARAMETERS (var1 LONG, var2 SHORT, RETURN INT, RETURN INDICATOR SHORT); The correct syntax is the following. Note that RETURN for actual function return is the last specification in the parameters clause. FUNCTION myexternalfunc (var1 BINARY_INTEGER, var2 BINARY_INTEGER) RETURN BINARY_INTEGER IS EXTERNAL NAME "myexternalfunc" LIBRARY somelib PARAMETERS (var1 LONG, var2 SHORT, RETURN INDICATOR SHORT, RETURN INT);
Action: Correct the syntax of the RETURN specification in the parameters clause
PLS-00252: reference to the wrong copy of package STANDARD
Cause: A reference is made to the fixed package version of STANDARD when the database is open, or to the on-disk version when the database is closed. Explicit use of a SYS.X$ package name can lead to this. One might also see this from a compilation that begins while the db is closed but has the bad luck to have another session open the db before compilation is complete. Another possible cause is having 'set serveroutput on' through svrmgrl when doing an 'alter database close'.
Action: Make use of on-disk versions of packages when the database is open and fixed (preloaded) versions when the database is closed. Do not attempt to use the wrong set. It should be quite hard to reference the wrong set, except by using SYS.X$ package names explicitly. Also, be sure to 'set serveroutput off' before doing an 'alter database close'.
PLS-00253: Formal parameter string missing in the parameters clause
Cause: The parameter clause does not have a matching parameter for a parameter specified in the formal parameter list.
Action: Provide a matching parameter in parameters clause for every formal parameter.
PLS-00254: OUT and IN/OUT modes cannot be used in this context
Cause: actual parameter mode (OUT, or IN/OUT) is not used properly in USING clause. For USING clause in an OPEN statement, only IN mode is allowed.
Action: change the parameter mode in the USING clause to an appropriate mode.
PLS-00255: CALL Specification parameters cannot have default values
Cause: CALL Specification formal parameters default values are disallowed.
Action: Remove the default values in the formal parameter list (spec or body) and compile again.
PLS-00256: %s is not a valid external library
Cause: The supplied external library name in the external clause is not a valid alias library.
Action: Provide the name of a valid alias library which is previously declared.
PLS-00257: illegal use of EXTERNAL clause in a TYPE or PACKAGE specification
Cause: An EXTERNAL Clause was detected in a TYPE Specification or a PACKAGE specification.
Action: Remove the EXTERNAL Clause and use the new CALL Specification syntax.
PLS-00258: constrained datatypes disallowed in CALL Specifications
Cause: A call specification for C or Java cannot have constraints on the PL/SQL formal parameter types. PL/SQL types which have have constraints are NATURAL, NATURALN, POSITIVE, POSITIVEN, SIGNTYPE, INTEGER, INT, SMALLINT, DECIMAL, NUMERIC, DEC This includes NOT NULL constraints from POSITIVEN, NATURALN
Action: Use the unconstrained type for that PL/SQL formal declaration i.e NUMBER, BINARY_INTEGER or PLS_INTEGER
PLS-00259: rights model (AUTHID) must be specified
Cause: It is mandatory to specify the rights model if a PL/SQL PROCEDURE, FUNCTION, PACKAGE OR TYPE HAS CALL-Specifications
Action: Add the AUTHID clause indicating the rights model.
PLS-00260: Datetime/Interval constraints must be in range (0 .. 9)
Cause: A Datetime/Interval variable or attribute was declared with a constraint outside the legal range.
Action: Change the illegal constraint.
PLS-00261: Java CALL Specification not yet allowed as a method in an object type
Cause: A call specification declaring that an implementation is in Java has been found for a method of an object or opaque type. This usage is not yet supported.
Action: Implement the method using a language other than Java. A PL/SQL method implementation is permitted to call to Java through a call specification provided as a schema-level procedure or in a package; such a call specification can only target a static Java method, however. ****** errors until 300 are reserved for External Procedures ********** ****** PH2 errors **********
PLS-00302: component 'string' must be declared
Cause: In a reference to a component (for example, in the name "A.B", "B" is a component of "A"), the component has not been declared. The component might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.
Action: Check the spelling and declaration of the component. Also confirm that the declaration is placed correctly in the block structure.
PLS-00303: qualifier 'string' must be declared
Cause: In a name such as "A.B", "A" is the qualifier, and "B" is a component of the qualifier. This error occurs when no declaration for the qualifier is found.The qualifier might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.
Action: Check the spelling and declaration of the qualifier. Also confirm that the declaration is placed correctly in the block structure.
PLS-00304: cannot compile body of 'string' without its specification
Cause: The compiled package specification required to compile a package body could not be found. Some possible causes follow: --the package name is misspelled --the package specification was never compiled --the compiled package specification is not accessible The package specification must be compiled before compiling the package body, and the compiler must have access to the compiled specification.
Action: Check the spelling of the package name. Compile the package specification before compiling the package body. Also, make sure the compiler has access to the compiled specification.
PLS-00305: previous use of 'string' (at line string) conflicts with this use
Cause: While looking for prior declarations of a cursor, procedure, function, or package, the compiler found another object with the same name in the same scope. Or, the headers of subprogram in a package specification and body do not match word for word.
Action: Check the spelling of the cursor, procedure, function, or package name. Also check the names of all constants, variables, parameters, and exceptions declared in the same scope. Then, remove or rename the object with the duplicate name. Or, change the headers of the packaged subprogram so that they match word for word.
PLS-00306: wrong number or types of arguments in call to 'string'
Cause: This error occurs when the named subprogram call cannot be matched to any declaration for that subprogram name. The subprogram name might be misspelled, a parameter might have the wrong datatype, the declaration might be faulty, or the declaration might be placed incorrectly in the block structure. For example, this error occurs if the built-in square root function SQRT is called with a misspelled name or with a parameter of the wrong datatype.
Action: Check the spelling and declaration of the subprogram name. Also confirm that its call is correct, its parameters are of the right datatype, and, if it is not a built-in function, that its declaration is placed correctly in the block structure.
PLS-00307: too many declarations of 'string' match this call
Cause: The declaration of a subprogram or cursor name is ambiguous because there was no exact match between the declaration and the call and more than one declaration matched the call when implicit conversions of the parameter datatypes were used. The subprogram or cursor name might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.
Action: Check the spelling and declaration of the subprogram or cursor name. Also confirm that its call is correct, its parameters are of the right datatype, and, if it is not a built-in function, that its declaration is placed correctly in the block structure.
PLS-00308: this construct is not allowed as the origin of an assignment
Cause: The construct or expression does not designate a value that can be assigned to a variable. For example, the datatype name NUMBER cannot appear on the right hand side of an assignment statement as in X := NUMBER.
Action: Correct the illegal assignment statement.
PLS-00309: with %%LAST attribute, 'string' must be a variable of an enumerated type
Cause: The "%LAST" attribute must be applied to an identifier that has been declared as a variable of an enumerated type (or subtype of an enumerated type). This error occurs when "%LAST" follows some identifier that has not been so declared.
Action: none
PLS-00310: with %%ROWTYPE attribute, 'string' must name a table, cursor or cursor-variable
Cause: The %ROWTYPE attribute must be applied to an identifier declared as a cursor, cursor variable, or database table. This error occurs when %ROWTYPE follows some identifier that has not been so declared.
Action: Change the declaration or do not apply the %ROWTYPE attribute to the identifier.
PLS-00311: the declaration of "string" is incomplete or malformed
Cause: This occurrence of the identifier cannot be compiled because its type has not been properly defined.
Action: Correct the faulty datatype declaration.
PLS-00312: a positional parameter association may not follow a named association
Cause: When a list of parameters is passed to a subprogram or cursor, if both positional and named associations are used, all positional associations must be placed in their declared order and before all named associations, which can be in any order.
Action: Reorder the parameter list to meet the requirements or use named association only.
PLS-00313: 'string' not declared in this scope
Cause: There is no declaration for the given identifier within the scope of reference. The identifier might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.
Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.
PLS-00314: TABLE declarations are not allowed as PL/SQL local variables
Cause: In a precompiled program, the DECLARE TABLE statement was mistakenly used inside an embedded PL/SQL block. If an embedded PL/SQL block refers to a database table that does not yet exist, use the DECLARE TABLE statement to tell the precompiler what the table will look like. However, DECLARE TABLE statements are allowed only in the host program.
Action: Move the DECLARE TABLE statement outside the embedded PL/SQL block. If you want a variable that can store an entire row of data selected from a database table or fetched from a cursor or cursor variable, use the %ROWTYPE attribute.
PLS-00315: Implementation restriction: unsupported table index type
Cause: In the INDEX BY clause of a PL/SQL table declaration, a datatype other than BINARY_INTEGER, PLS_INTEGER, or VARCHAR2 was specified. PL/SQL tables can have one column and a primary key. The column can have any scalar type, but the primary key must be either a binary integer type or VARCHAR2.
Action: Use one of the supported key types in the INDEX BY clause.
PLS-00316: PL/SQL TABLEs must use a single index
Cause: In the INDEX BY clause of a PL/SQL table declaration, a composite primary key was specified. PL/SQL tables must have a simple, unnamed primary key of a binary integer or VARCHAR2 type.
Action: Use one of the supported key types in the INDEX BY clause.
PLS-00317: incomplete type "string" was not completed in its declarative region
Cause: An incomplete type declaration was not completed in the declarative region where it was declared.
Action: Complete the type appropriately, then retry the operation.
PLS-00318: type "string" is malformed because it is a non-REF mutually recursive type
Cause: A type-declaration such as: -- a non-REF recursive type, for example: type t is record (a t); or -- non-REF mutually dependent types, for example: type t1; type t2 is record (a t1); type t1 is record (a t2); was performed. In these examples, the type is malformed because it participates in a mutually recursive non-REF relationship with itself and possibly other types.
Action: Use another type to remove the recursion.
PLS-00319: subquery in an IN or NOT IN clause must contain exactly one column
Cause: An invalid expression such as X IN (SELECT A,B ...) was used. When a [NOT]IN clause is used with a subquery, it does not test for set membership. The number of expressions in the [NOT]IN clause and the subquery select list must match. So, in the example above, the subquery must specify at most one column.
Action: Change the subquery to select only one column.
PLS-00320: the declaration of the type of this expression is incomplete or malformed
Cause: In a declaration, the name of a variable or cursor is misspelled or the declaration makes a forward reference. Forward references are not allowed in PL/SQL. A variable or cursor must be declared before it is referenced it in other statements, including other declarative statements. For example, the following declaration of dept_rec raises this exception because it refers to a cursor not yet declared: DECLARE dept_rec dept_cur%ROWTYPE; CURSOR dept_cur IS SELECT ... ...
Action: Check the spelling of all identifiers in the declaration. If necessary, move the declaration so that it makes no forward references.
PLS-00321: expression 'string' is inappropriate as the left hand side of an assignment statement
Cause: The expression does not designate a variable that can have a value assigned to it. For example, the function SYSDATE cannot appear on the left hand side of an assignment statement such as SYSDATE := '01-JAN-1990';
Action: Correct the illegal assignment statement.
PLS-00322: declaration of a constant 'string' must contain an initialization assignment
Cause: A constant declaration lacks the assignment of an initial value. For example, in the following declaration" := 3.14159" is the initialization clause: "pi constant number := 3.14159;"
Action: Correct the constant declaration by supplying the missing initialization assignment.
PLS-00323: subprogram or cursor 'string' is declared in a package specification and must be defined in the package body
Cause: A subprogram specification was placed in a package specification, but the corresponding subprogram body was not placed in the package body. The package body implements the package specification. So, the package body must contain the definition of every subprogram declared in the package specification.
Action: Check the spelling of the subprogram name. If necessary, add the missing subprogram body to the package body.
PLS-00324: cursor attribute may not be applied to non-cursor 'string'
Cause: This error occurs when a cursor-attribute ("%FOUND", "%NOTFOUND", "%ROWS", "%IS_OPEN", etc.) appears following an identifier that is not declared as a cursor or cursor variable. It occurs, for example, if the variable name my_cur in my_cur%FOUND was not properly declared as a cursor or if the variable declaration was placed incorrectly in the block structure.
Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.
PLS-00325: non-integral numeric literal string is inappropriate in this context
Cause: A non-integral numeric literal was used in a context that requires an integer (a number with no digits to the right of its decimal point).
Action: Replace the inappropriate literal with an integer literal.
PLS-00326: IN clause must contain same number of expressions as subquery
Cause: The number of expressions in an IN clause did not equal the number of expressions in a corresponding subquery select list. For example, the following statement is invalid because the IN clause contains two expressions, but the subquery select list contains just one: ... WHERE (ename, sal) IN (SELECT sal FROM emp);
Action: Check the number of expressions in each set, then revise the statement to make the numbers equal.
PLS-00327: "string" is not in SQL scope here
Cause: In a SQL statement, a reference was made to an out-of-scope database object. The referenced object might be misspelled, or the reference might be mixed, as in the following example: CURSOR c1 IS SELECT dept.dname FROM emp;
Action: Check the spelling of all database objects in the SQL statement, and make sure all references are to objects within the current scope.
PLS-00328: A subprogram body must be defined for the forward declaration of string.
Cause: A subprogram specification was declared, but the corresponding subprogram body was not defined. Write the subprogram specification and body as a unit. An alternative solution is to separate the specification from its body, which is necessary when you want to define mutually recursive subprograms or you want to group subprograms in a package.
Action: Check the spelling of the subprogram name. If necessary, supply the missing subprogram body.
PLS-00329: schema-level type has illegal reference to string
Cause: An attempt was made to make a reference from a schema-level type to something other than a schema-level type.
Action: Replace the illegal reference and retry the operation.
PLS-00330: invalid use of type name or subtype name
Cause: A datatype or subtype specifier was mistakenly used in place of a constant, variable, or expression. For example, the code might look like IF emp_count > number THEN ... -- illegal; NUMBER is a datatype specifier
Action: Replace the datatype or subtype specifier with a valid constant, variable, or expression.
PLS-00331: illegal reference to string
Cause: You had an EITHER

1. an illegal reference to some object in user SYS. to use one of them in an illegal way OR

2. an illegal reference to a remote object type.

Action: Remove the reference.
PLS-00332: "string" is not a valid prefix for a qualified name
Cause: You have a malformed qualified name because the prefix is not valid.
Action: Remove or change the reference.
PLS-00333: "string" must match an object-table alias in this context
Cause: The name, appearing in the context of a REF or VALUE, did not resolve to an object-table alias.
Action: 1) If there is no object table in the scope, then remove the REF or VALUE; or provide the missing object table reference. 2) If there is an object table in the scope, but you're not referring to it, add the reference.
PLS-00334: "string" matches table or view without an alias
Cause: You have a reference to a table or view name without an alias.
Action: Replace the reference with a reference to an object-table alias.
PLS-00335: a package name conflicts with an existing object
Cause: In a CREATE PACKAGE statement, a package (which is a database object that groups logically related PL/SQL types, objects, and subprograms) was given the same name as an existing database object.
Action: Give the package a unique name.
PLS-00336: non-object-table "string" illegal in this context
Cause: You have a REF or VALUE modifier for a non-object-table
Action: Replace the reference with a reference to an object-table alias.
PLS-00337: "string" matches too many object table aliases
Cause: You have an ambiguous reference to an object-table alias; there are at least two object-table aliases in the same scope.
Action: Remove all but one of the references or change the alias names of the remaining.
PLS-00338: unable to resolve "string" as a column or row expression
Cause: You have a reference to a name that could not be resolved as a column or row expression. This occurred in an update or insert statement involving an object-table.
Action: If this is an update statement and you intended to code this as a column reference, fix it as such. If you intended to code this as a row expression, change this to refer to an alias of an object-table.
PLS-00339: "string" matches object-table without a REF or VALUE modifier
Cause: You have an object-table name appearing without a REF or VALUE modifier.
Action: If you intended to code this with a REF or VALUE modifier, add the modifier; if you intended to code this as a column reference, change the reference appropriately; otherwise, remove the reference.
PLS-00341: declaration of cursor 'string' is incomplete or malformed
Cause: A cursor declaration is improper or an identifier referenced in the cursor declaration was not properly declared. A return type that does not refer to an existing database table or a previously declared cursor or cursor variable might have been specified. For example, the following cursor declaration is illegal because c1 is not yet fully defined: CURSOR c1 RETURN c1%ROWTYPE IS SELECT ... -- illegal In this case, a return type does not have to be specified because it is implicit.
Action: Check the spelling and declaration of the cursor name and any identifiers referenced in the cursor declaration. Also confirm that the declaration is placed correctly in the block structure. If a return type was specified, make sure that it refers to an existing database table or a previously declared cursor or cursor variable.
PLS-00351: Not logged onto database 'string'
Cause: An attempt was made to access an Oracle database without being logged on. Probably, an invalid username or password was entered.
Action: Log on to Oracle with a correctly spelled username and password before trying to access the database.
PLS-00352: Unable to access another database 'string'
Cause: An attempt was made to reference an object in a database other than the current local or remote Oracle database.
Action: Correct the reference and make sure the object is in the current Oracle database.
PLS-00353: 'string' must name a user in the database
Cause: This error occurs when the username was misspelled or when the user does not exist in the database.
Action: Check the spelling of the username and make sure the user exists.
PLS-00354: username must be a simple identifier
Cause: A qualified username such as scott.accts is not permitted in this context.
Action: Specify a simple username such as scott instead.
PLS-00355: use of pl/sql table not allowed in this context
Cause: A PL/SQL table was referenced in the wrong context (for example, with a remote link).
Action: Remove the PL/SQL table reference or change the context.
PLS-00356: 'string' must name a table to which the user has access
Cause: The named table is not accessible to the user. This error occurs when the table name or username was misspelled, the table and/or user does not exist in the database, the user was not granted the necessary privileges, or the table name duplicates the name of a local variable or loop counter.
Action: Check the spelling of the table name and username. Also confirm that the table and user exist, the user has the necessary privileges, and the table name does not duplicate the name of a local variable or loop counter.
PLS-00357: Table,View Or Sequence reference 'string' not allowed in this context
Cause: A reference to database table, view, or sequence was found in an inappropriate context. Such references can appear only in SQL statements or (excluding sequences) in %TYPE and %ROWTYPE declarations. Some valid examples follow: SELECT ename, emp.deptno, dname INTO my_ename, my_deptno, my_dept .FROM emp, dept WHERE emp.deptno = dept.deptno; DECLARE last_name emp.ename%TYPE; dept_rec dept%ROWTYPE;
Action: Remove or relocate the illegal reference.
PLS-00358: column 'string' exists in more than one table; use qualifier
Cause: The statement is ambiguous because it specifies two or more tables having the same column name. For example, the following statement is ambiguous because deptno is a column in both tables: SELECT deptno, loc INTO my_deptno, my_loc FROM emp, dept;
Action: Precede the column name with the table name (as in emp.deptno) so that the column reference is unambiguous.
PLS-00359: assignment target in 'string' must have components
Cause: An assignment target was declared that lacks the components needed to store the assigned values. For example, this error occurs if you try to assign a row of column values to a variable instead of a record, as follows: DECLARE dept_rec dept%ROWTYPE; my_deptno dept.deptno%TYPE; ... BEGIN SELECT deptno, dname, loc INTO my_deptno -- invalid FROM dept WHERE ...
Action: Check the spelling of the names of the assignment target and all its components. Make sure the assignment target is declared with the required components and that the declaration is placed correctly in the block structure.
PLS-00360: cursor declaration without body needs return type
Cause: A cursor declaration lacks either a body (SELECT statement) or a return type. If you want to separate a cursor specification from its body, a return type must be supplied, as in CURSOR c1 RETURN emp%ROWTYPE;
Action: Add a SELECT statement or return type to the cursor declaration.
PLS-00361: IN cursor 'string' cannot be OPEN'ed
Cause: A cursor parameter with mode IN cannot be modified, and therefore cannot be opened.
Action: Change the cursor parameter to be IN OUT or OUT
PLS-00362: invalid cursor return type; 'string' must be a record type
Cause: In a cursor specification or REF CURSOR type definition, a non- record type such as NUMBER or TABLE was specified as the return type. This is not allowed. Only the following return types are allowed: <record_type_name> <record_name>%TYPE <table_name>%ROWTYPE <cursor_name>%ROWTYPE <cursor_variable_name>%ROWTYTPE
Action: Revise the cursor specification or REF CURSOR type definition so that it specifies one of the above return types.
PLS-00363: expression 'string' cannot be used as an assignment target
Cause: A literal, constant, IN parameter, loop counter, or function call was mistakenly used as the target of an assignment. For example, the following statement is illegal because the assignment target, 30, is a literal: SELECT deptno INTO 30 FROM dept WHERE ... -- illegal
Action: Correct the statement by using a valid assignment target.
PLS-00364: loop index variable 'string' use is invalid
Cause: An attempt was made to assign the value of an OUT parameter to
Action: Use an IN OUT parameter instead of the OUT parameter. Inside a
PLS-00366: subtype of a NOT NULL type must also be NOT NULL
Cause: After a subtype was defined as NOT NULL, it was used as the base type for another subtype defined as NULL. That is not allowed. For example, the code might look like DECLARE SUBTYPE Weekday IS INTEGER NOT NULL; SUBTYPE Weekend IS Weekday NULL; -- illegal instead of DECLARE SUBTYPE Weekday IS INTEGER NOT NULL; SUBTYPE Weekend IS Weekday;
Action: Revise the subtype definitions to eliminate the conflict.
PLS-00367: a RAISE statement with no exception name must be inside an exception handler
Cause: A RAISE statement not followed by an exception name was found outside an exception handler
Action: Delete the RAISE statement, relocate it to an exception handler, or supply the missing exception name.
PLS-00368: in RAISE statement, 'string' must be an exception name
Cause: The identifier in a RAISE statement is not a valid exception name.
Action: Make sure the identifier in the RAISE statement was declared as an exception and is correctly placed in the block structure. If you are using the name of a PL/SQL predefined exception, check its spelling.
PLS-00369: no choices may appear with choice OTHERS in an exception handler
Cause: A construct of the form WHEN excep1 OR OTHERS => was encountered in the definition of an exception handler. The OTHERS handler must appear by itself as the last exception handler in a block.
Action: Remove the identifier that appears with OTHERS or write a separate exception handler for that identifier.
PLS-00370: OTHERS handler must be last among the exception handlers of a block
Cause: One or more exception handlers appear after an OTHERS handler. However, the OTHERS handler must be the last handler in a block or subprogram because it acts as the handler for all exceptions not named specifically.
Action: Move the OTHERS handler so that it follows all specific exception handlers.
PLS-00371: at most one declaration for 'string' is permitted in the declaration section
Cause: A reference to an identifier is ambiguous because there are conflicting declarations for it in the declarative part of a block, procedure, or function. At most one declaration of the identifier is permitted in a declarative part.
Action: Check the spelling of the identifier. If necessary, remove all but one declaration of the identifier.
PLS-00372: In a procedure, RETURN statement cannot contain an expression
Cause: In a procedure, a RETURN statement contains an expression, which is not allowed. In functions, a RETURN statement must contain an expression because its value is assigned to the function identifier. However, in procedures, a RETURN statement simply lets you exit before the normal end of the procedure is reached.
Action: Remove the expression from the RETURN statement, or redefine the procedure as a function.
PLS-00373: EXIT label 'string' must label a LOOP statement
Cause: The label in an EXIT statement does not refer to a loop. An EXIT statement need not specify a label. However, if a label is specified (as in EXIT my_label), it must refer to a loop statement.
Action: Make sure the label name is spelled correctly and that it refers to a loop statement.
PLS-00374: illegal EXIT statement; it must appear inside the loop labeled 'string'
Cause: An EXIT statement need not specify a label. However, if a label is specified (as in EXIT my_label), the EXIT statement must be inside the loop designated by that label.
Action: Make sure the label name is spelled correctly; if necessary, move the EXIT statement inside the loop to which the label refers.
PLS-00375: illegal GOTO statement; this GOTO cannot branch to label 'string'
Cause: The line and column numbers accompanying the error message refer to a GOTO that branches from outside a construct (a loop or exception handler, for example) that contains a sequence of statements to a label inside that sequence of statements. Such a branch is not allowed.
Action: Either move the GOTO statement inside the sequence of statements or move the labeled statement outside the sequence of statements.
PLS-00376: illegal EXIT statement; it must appear inside a loop
Cause: An EXIT statement was found outside of a loop construct. The EXIT statement is used to exit prematurely from a loop and so must always appear within a loop.
Action: Either remove the EXIT statement or place it inside a loop.
PLS-00377: internal type PLS_INTEGER is not included in this release of PL/SQL
Cause: The type-name INTEGER was used in a declaration.
Action: none
PLS-00378: invalid compilation unit for this release of PL/SQL
Cause: A compilation unit is a file containing PL/SQL source code that is passed to the compiler. Only compilation units containing blocks, declarations, statements, and subprograms are allowed. This error occurs when some other language construct is passed to the compiler.
Action: Make sure the compilation unit contains only blocks, declarations, statements, and subprograms.
PLS-00379: CASE statements are not included in this release of PL/SQL
Cause: The unit being compiled contains a CASE statement. However, the current release of PL/SQL does not support CASE statements.
Action: Remove the CASE statement from the compilation unit.
PLS-00380: functions and procedures are not included in this release of PL/SQL
Cause: The program being compiled contains a declaration of a FUNCTION or PROCEDURE.
Action: none
PLS-00381: type mismatch found at 'string' between column and variable in subquery or INSERT
Cause: The datatypes of a column and a variable do not match. The variable was encountered in a subquery or INSERT statement.
Action: Change the variable datatype to match that of the column.
PLS-00382: expression is of wrong type
Cause: An expression has the wrong datatype for the context in which it was found.
Action: Change the datatype of the expression. You might want to use datatype conversion functions.
PLS-00383: type mismatch found at 'string' inside an IN or NOT IN clause
Cause: In a test for set membership such as X NOT IN (SELECT Y ... ), the expressions X and Y do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.
Action: Change the expressions so that their datatypes match. You might want to use datatype conversion functions in the select list.
PLS-00384: type mismatch found at 'string' in UPDATE's SET clause
Cause: The column to the left of the equal sign in the SET clause of an UPDATE statement does not match in datatype with the column, expression, or subquery to the right of the equal sign, and it is unclear which implicit conversion is required to correct the mismatch.
Action: Change the expressions so that their datatypes match. You might want to use datatype conversion functions in the SET clause.
PLS-00385: type mismatch found at 'string' in SELECT...INTO statement
Cause: The expressions to the left and right of the INTO clause in a SELECT...INTO statement do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.
Action: Change the expressions so that their datatypes match. You might want to use datatype conversion functions in the select list.
PLS-00386: type mismatch found at 'string' between FETCH cursor and INTO variables
Cause: An assignment target in the INTO list of a FETCH statement does not match in datatype with the corresponding column in the select list of the cursor declaration, and it is unclear which implicit conversion is required to correct the mismatch.
Action: Change the cursor declaration or change the datatype of the assignment target. You might want to use datatype conversion functions in the select list of the query associated with the cursor.
PLS-00387: INTO variable cannot be a database object
Cause: An item in the INTO list of a FETCH or SELECT statement was found to be a database object. INTO introduces a list of user-defined variables to which output values are assigned. Therefore, database objects cannot appear in the INTO list.
Action: Check the spelling of the INTO list item. If necessary, remove the item from the INTO list or replace it with a user-defined output variable.
PLS-00388: undefined column 'string' in subquery
Cause: A subquery contains a column name that was not defined in the specified table.
Action: Change the expression to specify a column that was defined.
PLS-00389: table, view or alias name "string" not allowed in this context
Cause: A table, view or alias name <name> corresponding to a regular (non-object) table appeared in an inappropriate context.
Action: Remove the reference, or, if you intended to code this as a column reference, fix it as such.
PLS-00390: undefined column 'string' in INSERT statement
Cause: Check the spelling of the column name, then change the expression so that it refers only to defined columns.
Action: Check the spelling of the column name, then change the expression so that it refers only to defined columns.
PLS-00391: undefined column 'string' in UPDATE statement
Cause: An UPDATE statement refers to a column not defined for the table or view being updated.
Action: Check the spelling of the column name, then revise the statement so that it refers only to defined columns.
PLS-00392: Type mismatch in arguments to BETWEEN
Cause: In a comparison such as X BETWEEN Y AND Z, the expressions X, Y, and Z do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.
Action: Change the expressions so that their datatypes match. You might want to use datatype conversion functions.
PLS-00393: wrong number of columns in SELECT...INTO statement
Cause: The number of columns selected by a SELECT...INTO statement does not match the number of variables in the INTO clause.
Action: Change the number of columns in the select list or the number of variables in the INTO clause so that the numbers match.
PLS-00394: wrong number of values in the INTO list of a FETCH statement
Cause: The number of variables in the INTO clause of a FETCH statement does not match the number of columns in the cursor declaration.
Action: Change the number of variables in the INTO clause or the number of columns in the cursor declaration so that the numbers match.
PLS-00395: wrong number of values in VALUES clause of INSERT statement
Cause: The number of columns in an INSERT statement does not match the number of values in the VALUES clause. For example, the following statement is faulty because no column is specified for the value 20: INSERT INTO emp (empno, ename) VALUES (7788, 'SCOTT', 20);
Action: Change the number of items in the column list or the number of items in the VALUES list so that the numbers match.
PLS-00396: INSERT statement's subquery yields wrong number of columns
Cause: The number of columns in an INSERT statement does not match the number of columns in a subquery select list. For example, the following statement is faulty because no corresponding column is specified for col3: INSERT INTO emp (ename, empno) SELECT col1, col2, col3 FROM ...
Action: Change the number of items in the column list of the INSERT statement or the number of items in the select list so that the numbers match.
PLS-00397: Type mismatch in arguments to IN
Cause: In a test for set membership such as X IN (Y, Z), the expressions X, Y, and Z do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.
Action: Change the expressions so that their datatypes match. You might want to use datatype conversion functions.
PLS-00398: wrong number of columns in UNION, INTERSECT, or MINUS expression
Cause: The SELECT clauses to the left and right of a UNION, INTERSECT, or MINUS expression do not select the same number of columns. For example, the following statement is faulty because the select lists do not contain the same number of items: CURSOR my_cur IS SELECT ename FROM emp INTERSECT SELECT ename, empno FROM emp;
Action: Change the select lists so that they contain the same number of items.
PLS-00399: different types of columns in UNION, INTERSECT, or MINUS expression
Cause: The select lists to the left and right of a UNION, INTERSECT, or MINUS expression select at least one column that is mismatched in datatype. For example, the following statement is faulty because the constant 3 has datatype NUMBER, whereas SYSDATE has datatype DATE: CURSOR my_cur IS SELECT 3 FROM emp INTERSECT SELECT SYSDATE FROM emp;
Action: Change the select lists so that they match in datatype. You might want to use datatype conversion functions in the select list of one or more queries.
PLS-00400: different number of columns between cursor SELECT statement and return value
Cause: In a cursor declaration, a return type (such as RETURN emp%ROWTYPE) was specified, but the number of returned column values does not match the number of select-list items.
Action: Change the cursor return type or the select list so that the number of returned column values matches the number of select-list items.
PLS-00401: different column types between cursor SELECT statement and return value found at 'string'
Cause: In a cursor declaration, a return type (such as RETURN emp%ROWTYPE) was specified, but a returned column value and its corresponding select-list item have different datatypes.
Action: Change the cursor return type or the select list so that each returned column value and its corresponding select-list item have the same datatype.
PLS-00402: alias required in SELECT list of cursor to avoid duplicate column names
Cause: A cursor was declared with a SELECT statement that contains duplicate column names. Such references are ambiguous.
Action: Replace the duplicate column name in the select list with an alias.
PLS-00403: expression 'string' cannot be used as an INTO-target of a SELECT/FETCH statement
Cause: A FETCH statement was unable to assign a value to an assignment target in its INTO list because the target is not a legally formed and declared variable. For example, the following assignment is illegal because 'Jones' is a character string, not a variable: FETCH my_cur INTO 'Jones';
Action: Check the spelling and declaration of the assignment target. Make sure that the rules for forming variable names are followed.
PLS-00404: cursor 'string' must be declared with FOR UPDATE to use with CURRENT OF
Cause: The use of the CURRENT OF cursor_name clause is legal only if cursor_name was declared with a FOR UPDATE clause.
Action: Add a FOR UPDATE clause to the definition of the cursor or do not use the CURRENT OF cursor_name clause.
PLS-00405: subquery not allowed in this context
Cause: A subquery was used in an inappropriate context, such as: if (SELECT deptno FROM emp WHERE ... ) = 20 then ... Subqueries are allowed only in SQL statements.
Action: The same result can be obtained by using a temporary variable, as in: SELECT deptno INTO temp_var FROM emp WHERE ...; IF temp_var = 20 THEN ...
PLS-00406: length of SELECT list in subquery must match number of assignment targets
Cause: A query select list is not the same length as the list of targets that will receive the returned values. For example, the following statement is faulty because the subquery returns two values for one target: UPDATE emp SET ename = (SELECT ename, empno FROM emp WHERE ename = 'SMITH') ...
Action: Change one of the lists so that they contain the same number of items.
PLS-00407: '*' not allowed here; a list of columns is required
Cause: An asterisk (*) was used as an abbreviation for a list of column names. However, in this context the column names must be written out explicitly.
Action: Replace the asterisk with a list of column names.
PLS-00408: duplicate column 'string' not permitted in INSERT or UPDATE
Cause: An UPDATE or INSERT statement has a column list that contains duplicate column names.
Action: Check the spelling of the column names, then eliminate the duplication.
PLS-00409: duplicate variable 'string' in INTO list is not permitted
Cause: The same variable appears twice in the INTO list of a SELECT or FETCH statement.
Action: Remove one of the variables from the INTO list.
PLS-00410: duplicate fields in RECORD,TABLE or argument list are not permitted
Cause: When a user-defined record was declared, the same name was given to two fields. Like column names in a database table, field names in a user-defined record must be unique.
Action: Check the spelling of the field names, then remove the duplicate.
PLS-00411: Number of values in aggregate and in subquery don't match
Cause: In a statement of the form aggregate = subquery, the numbers of values in the aggregate and subquery are unequal. For example, the code might look like ... WHERE (10,20,30) = (SELECT empno,deptno FROM emp WHERE...);
Action: Revise the aggregate or subquery so that the numbers of values match.
PLS-00412: list of values not allowed as argument to this function or procedure
Cause: A parenthesized list of values separated by commas (that is, an aggregate) was used in the wrong context. For example, the following usage is invalid: WHERE (col1, col2) > (SELECT col3, col4 FROM my_table ...) However, an equal sign can take a list of values and a subquery as left- and right-hand-side arguments, respectively. So, the following usage is valid: WHERE (col1, col2) = (SELECT col3, col4 FROM my_table ...)
Action: Rewrite the expression. For example, the clause WHERE (col1, col2) > (SELECT col3, col4 FROM my_table ...) can be rewritten as WHERE col1 > (SELECT col3 FROM my_table ...) AND col2 > (SELECT col4 FROM my_table ...)
PLS-00413: identifier in CURRENT OF clause is not a cursor name
Cause: The identifier in a CURRENT OF clause names an object other than a cursor.
Action: Check the spelling of the identifier. Make sure that it names the cursor in the DELETE or UPDATE statement and that it names the cursor itself, not a FOR-loop variable.
PLS-00414: no column 'string' in table
Cause: A table name or alias was used to qualify a column reference, but the column was not found in that table. Either the column was never defined or the column name is misspelled.
Action: Confirm that the column was defined and check the spelling of the column name.
PLS-00415: 'string' is an OUT parameter and cannot appear in a function
Cause: An OUT or IN OUT formal parameter was used in a function specification.
Action: none
PLS-00416: The third argument of DECODE cannot be NULL
Cause: The third argument of DECODE is NULL.
Action: Enter an argument with a proper type and value.
PLS-00417: unable to resolve "string" as a column
Cause: A database table, view, or column was specified in a SQL statement that does not exist, or the privileges required to access the table or view were not granted.
Action: Check the spelling of the table (or view) and column names; make sure the table and columns exist. If necessary, ask the DBA to grant the privileges required to access the table.
PLS-00418: array bind type must match PL/SQL table row type
Cause: A host array was passed (by an Oracle Precompiler program, for example) to a PL/SQL subprogram for binding to a PL/SQL table parameter. However, the datatypes of the array elements and PL/SQL table rows are incompatible. So, the binding failed.
Action: Change the datatype of the array elements or PL/SQL table rows to make the datatypes compatible.
PLS-00419: reference to remote attribute not permitted
Cause: An attempt was made to reference a remote cursor attribute, which is not allowed. For example, the code might look like IF SQL%NOTFOUND@newyork THEN ...
Action: Do not try to reference a remote cursor attribute.
PLS-00420: can't call builtin routines remotely
Cause: An attempt was made to call a built-in PL/SQL function remotely, which is not allowed. For example, the code might look like my_sqlerrm := SQLERRM@newyork; or INSERT INTO emp VALUES (my_empno, STANDARD.RTRIM@newyork(my_ename), ...);
Action: Always call built-in functions locally; never specify a database link.
PLS-00421: synonym definitions nested too deeply; possible loop in synonyms
Cause: Directly or indirectly, a synonym was defined in terms of itself, creating a circular definition. Or, a chain of synonyms, too long for the PL/SQL compiler to handle, was defined.
Action: Redefine the synonyms to eliminate the circular definition. If necessary, shorten the chain of synonyms.
PLS-00422: no PL/SQL translation for the bindtype given for this bind variable
Cause: A host variable was passed (by an Oracle Precompiler program, for example) to PL/SQL for binding. However, its datatype is not compatible with any PL/SQL datatype. So, the binding failed.
Action: Change the datatype of the host variable to make it compatible with a PL/SQL datatype.
PLS-00423: ORDER BY item must be the number of a SELECT-list expression
Cause: A column alias was used in the ORDER BY clause of a SELECT statement that uses a UNION, INTERSECT, or MINUS set operator. This is not allowed. In such cases, expressions in the ORDER BY clause must be unsigned integers that designate the ordinal positions of select-list items.
Action: Change the alias in the ORDER BY clause to an unsigned integer that designates the ordinal position of the select item in question.
PLS-00424: RPC defaults cannot include Package State
Cause: An attempt was made to call a remote subprogram whose defaulted parameters depend on package state, which is not allowed. When calling remote subprograms, the actual parameters must be passed explicitly if the corresponding formal parameters depend on package state.
Action: Call the remote subprogram by passing each actual parameter explicitly.
PLS-00425: in SQL, function argument and return types must be SQL type
Cause: When a cursor variable was declared as the formal parameter of a
Action: Change the parameter mode from OUT to IN or IN OUT.
PLS-00427: RPC defaults cannot use builtins when versions of STANDARD differ
Cause: An attempt was made to call a remote subprogram whose defaulted parameter value is calculated using a builtin operation. If the calling system uses a different version of package STANDARD than does the called system, a defaulted expression must be either a simple numeric or string literal, NULL, or a direct call to a user-written function.
Action: Call the remote subprogram by passing each actual parameter value explicitly.
PLS-00428: an INTO clause is expected in this SELECT statement
Cause: The INTO clause of a SELECT INTO statement was omitted. For example, the code might look like SELECT deptno, dname, loc FROM dept WHERE ... instead of SELECT deptno, dname, loc INTO dept_rec FROM dept WHERE ... In PL/SQL, only a subquery is written without an INTO clause.
Action: Add the required INTO clause.
PLS-00429: unsupported feature with RETURNING clause
Cause:

- INTO clause and RETURNING clause cannot be use in the same statement

- RETURNING clause is currently not supported for object type columns, LONG columns, records, %rowtypes, remote tables and INSERT with subquery. This is as ORA-28815.

Action: Use separate select statement to get the values.
PLS-00430: FORALL iteration variable string is not allowed in this context
Cause: FORALL iteration variable can only be used as a subscript. It cannot be used directly or as a part of an expression.
Action: Use FORALL variable only as a collection subscript.
PLS-00431: bulk SQL attributes must use a single index
Cause: More than one index specified to access SQL bulk attribute.
Action: Use a single index of integer datatype.
PLS-00432: implementation restriction: cannot use FORALL and BULK COLLECT INTO together in SELECT statements
Cause: SELECT statement contains both the FORALL and BULK COLLECT INTO phrases.
Action: Dn not use FORALL and BULK COLLECT INTO together in SELECT statements.
PLS-00433: inconsistent package STANDARD
Cause: PL/SQL compiler could not find the entries (such as type declarations) that should exist in the package STANDARD.
Action: Make sure that the correct version of package STANDARD is available in the current Oracle database, then retry compilation.
PLS-00434: record field has unsupported type: "string"
Cause: An attempt was made to use an unsupported type for a record field. In this release, the use of the SQL92 datetime types (time, timestamp, time with time zone, timestamp with time zone, interval year to month, interval day to second) are not supported in record fields.
Action: Use only supported types for record fields.
PLS-00435: DML statement without BULK In-BIND cannot be used inside FORALL
Cause: The DML (SELECT/INSERT/DELETE/UPDATE) statement inside the FORALL statement does not contain BULK IN-BIND variables.
Action: The DML (SELECT/INSERT/DELETE/UPDATE) statement inside the FORALL statement must contain BULK IN-BIND variables.
PLS-00436: implementation restriction: cannot reference fields of BULK In-BIND table of records
Cause: table(bulk_index).field is not supported at run-time yet.
Action: Use FOR loop with plain FORALL DML statement (SELECT/INSERT/DELETE/UPDATE) instead
PLS-00437: FORALL bulk index cannot be used in string clause
Cause: RETURNING table(bulk_index) is not supported.
Action: Use RETURNING BULK COLLECT instead
PLS-00438: value in LIMIT clause: 'string' use is invalid
Cause: The evaluation value in the LIMIT clause of a bulk fetch was found in an inappropriate context. For example, the following statement is illegal because the LIMIT clause in a bulk fetch expects a numeric value. FETCH c1 BULK COLLECT INTO var_tab LIMIT '22333'; -- illegal
Action: Change the expression of the LIMIT clause so that the evaluation result is compatible to a numeric value.
PLS-00439: A LIMIT clause must be used within a BULK FETCH
Cause: A LIMIT clause is used within a non-bulk fetch
Action: Do not use a LIMIT clause when a non-bulk fetch is used.
PLS-00450: a variable of this private type cannot be declared here
Cause: A variable declaration uses a type that is declared PRIVATE in some other compilation unit.
Action: Do not use this type in a PRIVATE variable declaration.
PLS-00452: Subprogram 'string' violates its associated pragma
Cause: A packaged function cannot be called from SQL statements unless its purity level is asserted by coding a RESTRICT_REFERENCES pragma in the package specification. The pragma, which is used to control side effects, tells the PL/SQL compiler to deny the packaged function read/write access to database tables, public packaged variables, or both. A SQL statement that violates the pragma will cause a compilation error.
Action: Raise the purity level of the function, or relax the pragma restrictions.
PLS-00453: remote operations not permitted on object tables or user-defined type columns
Cause: A reference to a remote object tables or user-defined type column was found.
Action: Do not refer to it.
PLS-00454: with a returning into clause, the table expression cannot be remote or a subquery
Cause: A reference to a remote table or subquery was found in a sql statement with a returning into clause.
Action: Do not refer to it, or do use a subsequent select statement.
PLS-00455: cursor 'string' cannot be used in dynamic SQL OPEN statement
Cause: dynamicly OPEN a REF CURSOR that has RETURN type. However, only REF CURSOR without RETURN type can be OPEN'ed by an embebded dynamic OPEN statement.
Action: define a REF CURSOR without return type, and use it in the statement.
PLS-00456: item 'string' is not a cursor
Cause: the given variable is not a cursor and therefore cannot be OPEN'ed or FETCH'ed from.
Action: check the spelling and declaration for the given variable.
PLS-00457: expressions have to be of SQL types
Cause: an expression of wrong type is in USING or dynamic RETURNING clause. In USING or dynamic RETURNING clause, an expression cannot be of non-SQL types such as BOOLEAN, INDEX TABLE, and record.
Action: change the expression type to a SQL type.
PLS-00458: subprogram 'string' cannot be called from a REPEATABLE subprogram
Cause: The subprogram is not REPEATABLE and cannot be called from a REPEATABLE subprogram.
Action: delete the call or delete REPEATABLE.
PLS-00459: this feature is not allowed in REPEATABLE subprogram
Cause: Having one of the followings feature in the REPEATABLE subprogram: dynamic SQL statements or autonomous transaction.
Action: delete the statements or delete REPEATABLE.
PLS-00460: REPEATABLE subprogram 'string' has to be RNDS, WNDS, RNPS, and WNPS
Cause: Repeatable subprogram can neither read database state (RNDS), write database state (WNDS), read package state (RNPS), nor write package state (WNPS).
Action: make the subprogram to be RNDS, WNDS, RNPS, and WNPS or delete REPEATABLE
PLS-00461: mismatch REPEATABLE information between specification and body of 'string'
Cause: REPEATABLE is declared at the subprogram's specification, but not at its body, or vice versa.
Action: make sure both specification and body are declared as REPEATABLE
PLS-00462: nested subprogram 'string' has to be REPEATABLE
Cause: the nested subprogram of a REPEATABLE subprogram is not declared as REPEATABLE. If a subprogram is REPEATABLE, all of its nested subprograms has to be declared as REPEATABLE.
Action: declared the nested subprogram as REPEATABLE
PLS-00483: exception 'string' may appear in at most one exception handler in this block
Cause: An exception appears in two different WHEN clauses (that is, two different exception handlers) in the exception-handling part of a PL/SQL block or subprogram.
Action: Remove one of the references to the exception.
PLS-00484: redundant exceptions 'string' and 'string' must appear in same exception handler
Cause: Using the EXCEPTION_INIT pragma, different exceptions were initialized to the same Oracle error number; then, they were referenced in different exception handlers within the same exception-handling part. Such references conflict.
Action: Remove one of the exceptions or initialize it to a different Oracle error number.
PLS-00485: in exception handler, 'string' must be an exception name
Cause: An identifier not declared as an exception appears in an exception handler WHEN clause. Only the name of an exception is valid in a WHEN clause.
Action: Check the spelling of the exception name and make sure the exception was declared properly.
PLS-00486: select list cannot be enclosed in parentheses
Cause: In a SELECT statement, the select list was enclosed in parentheses, as in: SELECT (deptno, dname, loc) FROM dept INTO ... This breaks the rules of SQL syntax. Parentheses are not required because the keywords SELECT and FROM delimit the select list.
Action: Remove the parentheses enclosing the select list.
PLS-00487: Invalid reference to variable 'string'
Cause: A variable was referenced in a way that is inconsistent with its datatype. For example, a scalar variable might have been mistakenly referenced as a record, as follows: DECLARE CURSOR emp_cur IS SELECT empno, ename, sal FROM emp; emp_rec emp_cur%ROWTYPE; my_sal NUMBER(7,2); BEGIN ... total_sal := total_sal + my_sal.sal; -- invalid ...
Action: Check the spelling of the variable name. Make sure the variable was declared properly and that the declaration and reference are consistent regarding datatype.
PLS-00488: invalid variable declaration: object 'string' must be a type or subtype
Cause: The datatype specifier in a variable declaration does not designate a legal type. For example, the %TYPE attribute might not have been added to a declaration, as in DECLARE my_sal emp.sal%TYPE; my_ename emp.ename; -- missing %TYPE ... When declaring a constant or variable, to provide the datatype of a column automatically, use the %TYPE attribute. Likewise, when declaring a record, to provide the datatypes of a row automatically, use the %ROWTYPE attribute.
Action: Make sure the datatype specifier designates a legal type. Remember to use the %TYPE and %ROWTYPE attributes when necessary.
PLS-00489: invalid table reference: 'string' must be a column in this expression
Cause: In a query, a select-list item refers to a table in the FROM clause but not to a database column.
Action: Check the spelling of the column names, make sure each column in the select list refers to a table in the FROM clause, then re-execute the query.
PLS-00490: illegal statement
Cause: A constant, variable, function call, or incomplete statement was used where a statement was expected. For example, instead of calling a function from an expression, it might have been called as a statement (as if it were a procedure).
Action: Check the statement, making sure that its commands, identifiers, operators, delimiters, and terminator form a complete and valid PL/SQL statement.
PLS-00491: numeric literal required
Cause: A constant or variable was used where a numeric literal is required. For example, the code might look like my_ename VARCHAR2(max_len); instead of my_ename VARCHAR2(15); When specifying the maximum length of a VARCHAR2 variable, an integer literal must be used.
Action: Replace the identifier with a numeric literal.
PLS-00492: variable or constant initialization may not refer to functions declared in the same package
Cause: If a package spec p declares a function f, that function may not be used in any variable declarations in that same package spec. This is because of a circular instantiation problem: in order to fully instantiate the package spec, the variable must be initialized. To initialize the variable, the function body code in the package body must be executed. That requires that the package body be instantiated. However, the package body cannot be instantiated until the package spec is fully instantiated.
Action: Remove the reference to the function from the variable initialization. A technique which often works is to move the variable initialization from the variable declaration (in the package spec) to the package body initialization block.
PLS-00493: invalid reference to a server-side object or function in a local context
Cause: A reference to a server-side object (e.g. a table column) or function (a group function such as SUM, AVG, MIN, MAX, ... ) was found in a context where only PL/SQL objects may be present (such as within the parameter list of a local function or as the index of a (local) PL/SQL table.)
Action: Rewrite the offending statement; or (if a local function call is the problem context), make the function non-local (either packaged or top- level.)
PLS-00494: coercion into multiple record targets not supported
Cause: The INTO list of a SELECT or FETCH specified more than a single record- type target and the column types required coercion into a record to match the INTO list. This is type checked as correct, but not yet supported.
Action: Create a new record type to hold all of the column types or code the SELECT with an INTO target for every source column.
PLS-00495: too many columns in SELECT...INTO statement after bursting record targets
Cause: Type checking indicated the columns in a SELECT or FETCH were being collected into a record in the INTO list. The record was burst into its fields. There were not enough fields in the record for each of the columns.
Action: Change the number of columns or the record variable(s) in the INTO clause so that they match.
PLS-00496: too few columns in SELECT...INTO statement after bursting record targets
Cause: Type checking indicated the columns in a SELECT or FETCH were being collected into a record in the INTO list. The record was burst into its fields. There were not enough columns to fill all of the fields in the record.
Action: Change the number of columns or the record variable(s) in the INTO clause so that they match.
PLS-00497: cannot mix between single row and multi-row (BULK) in INTO list
Cause: - When BULK syntax (e.g. BULK COLLECT INTO) is used to retrieve data, every variable in the INTO list has to be of type that is a collection of the type of the corresponding column.

- When BULK is NOT used, every variable in the INTO list has to be of compatible type with the corresponding column.

Action: Change the INTO list so that all variables have correct data types
PLS-00498: illegal use of a type before its declaration
Cause: A variable or constant was declared to be of a type whose declaration appears later in the compilation unit; or, a type or subtype was declared in terms of another type whose declaration appears later in the compilation unit.
Action: Ensure that the type declaration preceeds its use in the variable/ constant/type declaration.
PLS-00499: coercion into collection of records not supported
Cause: A SELECT or FETCH may specify a column list to be coerced into a variable which is a collection of records. This is type checked as correct, but not yet supported because of the implicit layout change required.
Action: Express the SELECT with an object constructor around the columns and use a collection of objects as an INTO variable. Or, build the collection one row at a time coercing each row into a record which happens to be an element. Or, use a record of collections.
PLS-00500: invalid operator binding
Cause: An operator binding fucntion cannot be found in the specified scope.
Action: Provide the correct number and types of parameters for the operator binding fucntion. Or, specify the correct names for schema, package, or type containing the operator binding fucntion.
PLS-00503: RETURN <value> statement required for this return from function
Cause: In a function body, a RETURN statement was used that contains no expression. In procedures, a RETURN statement contains no expression because the statement simply returns control to the caller. However, in functions, a RETURN statement must contain an expression because its value is assigned to the function identifier.
Action: Add an expression to the RETURN statement.
PLS-00504: type string_BASE may not be used outside of package STANDARD
Cause: In a declaration, the datatype NUMBER_BASE (for example) was mistakenly specified. The datatypes CHAR_BASE, DATE_BASE, MLSLABEL_BASE, and NUMBER_BASE are for internal use only.
Action: Specify (for example) the datatype NUMBER instead of NUMBER_BASE.
PLS-00505: User Defined Types may only be defined as PLSQL Tables or Records
Cause: An attempt was made to define a type other than TABLE or RECORD, but these are the only user- defined types allowed in this release of PL/SQL. For example, the following type definition is illegal: TYPE Byte IS INTEGER(2); -- illegal
Action: Remove the type definition, or revise it to specify a TABLE or RECORD type.
PLS-00506: User Defined Constrained Subtypes are disallowed
Cause: An attempt was made to define a constrained subtype, but only unconstrained subtypes are allowed in this release of PL/SQL. For example, the following type definition is illegal: SUBTYPE Acronym IS VARCHAR2(5); -- illegal
Action: Remove the illegal type constraint.
PLS-00507: a PLSQL Table may not contain a table or a record with composite fields
Cause: In a TABLE type definition, a nested record type was specified as the element type. This is not allowed. All fields in the record must be scalars.
Action: Remove the TABLE type definition, or replace the nested record type with a simple record type.
PLS-00508: The expression in a RETURN statement cannot be a type
Cause: A datatype specifier was used instead of an expression in the RETURN statement of a user-defined function, as shown in the example below. Do not confuse the RETURN statement, which sets the function identifier to the result value, with the RETURN clause, which specifies the datatype of the result value. FUNCTION credit-rating (acct_no NUMBER) RETURN BOOLEAN IS BEGIN ... RETURN NUMBER; -- should be an expression END;
Action: Replace the datatype specifier in the RETURN statement with an appropriate expression.
PLS-00509: Implementation Restriction : Pass a returned record to a temporary identifier before selecting a field
Cause: Illegal syntax was used to call a parameter-less function that returns a record or a PL/SQL table of records. When calling a function that takes parameters and returns a record, you use the following syntax to reference fields in the record: function_name(parameters).field_name However, you cannot use the syntax above to call a parameter-less function because PL/SQL does not allow empty parameter lists. That is, the following syntax is illegal: function_name().field_name -- illegal; empty parameter list You cannot just drop the empty parameter list because the following syntax is also illegal: function_name.field_name -- illegal; no parameter list.
Action: Declare a local record or PL/SQL table of records to which you can assign the function result, then reference its fields directly.
PLS-00510: Float cannot have scale
Cause: When a FLOAT variable was declared, its precision and scale were specified, as shown in the following example: DECLARE Salary FLOAT(7,2); However, a scale for FLOAT variables cannot be specified; only a precision can be specified, as in salary FLOAT(7);
Action: Remove the scale specifier from the declaration, or declare a NUMBER variable instead.
PLS-00511: a record may not contain a PL/SQL table of records
Cause: n a RECORD definition, one of the fields was declared as a PL/SQL table of records. This is not allowed. A record can be the component of another record (that is, records can be nested), but a PL/SQL table of records cannot be the component of a record.
Action: Remove the field declaration, or revise it to specify a simple record type.
PLS-00512: Implementation Restriction: 'string': Cannot directly access remote package variable or cursor
Cause: An attempt was made to reference a remote packaged variable or cursor. This is not allowed. Instead, add to the remote package a function that returns the value of the variable or cursor.
Action: Remove the illegal reference.
PLS-00513: PL/SQL function called from SQL must return value of legal SQL type
Cause: In a SQL statement, do not call a PL/SQL function having a return type that can not be handled by SQL. For example, type BOOLIAN, records and indexed-tables are not supported by SQL and functions returneing such values can not be called from SQL.
Action: none
PLS-00514: INSERT statement with REF INTO clause requires a typed table
Cause: This INSERT statement provides REF INTO clause, which is only legal when the table specified in the INTO clause is an object table.
Action: none
PLS-00515: The type of the REF INTO variable 'string' must be REF to the table's type
Cause: In INSERT statement with REF INTO clause, the type of the data item must be REF to the type of the table used in INTO clause.
Action: none
PLS-00516: Type mismatch between object table and value 'string' in INSERT statement.
Cause: In the INSERT statement operating on typed tables (tables of objects), the type of a non-aggregate value did not match the object type of the table.
Action: none
PLS-00517: Type mismatch between a select list element 'string' and corresponding table column in INSERT statement with a subquery
Cause: In an INSERT statement with subquery, at lease one of the elements of the select list was not type-compatible with the corresponding column of the table in the INTO clause. This error indicates that the subquery should be rewritten to match the structure of the target table.
Action: none
PLS-00518: This INSERT statement requires VALUES clause containing a parenthesised list of values
Cause: A VALUES clause was entered without a list of SQL data items in parentheses. In all INSERT statements with an explicit column list, the VALUES clause must contain a list of SQL data items in parentheses. For example: INSERT INTO my_tab (a,b,c) VALUES (1,2,my_variable);
Action: Rewrite the statement to include a list of SQL data items in parentheses.
PLS-00519: This INSERT statement requires a VALUES clause containing an object type expression, not a list of values
Cause: In an INSERT statement with typed tables, an aggregate was used when an object type item was expected.
Action: Replace the aggregate with an object constructor or other object type expression.
PLS-00520: MAP methods must be declared without any parameters other than (optional) SELF.
Cause: A MAP member function was declared with a parameter. Map member functions can have only one parameter: the default SELF parameter. Map methods must be declared without any parameters. The compiler adds the SELF parameter.
Action: Remove the parameter from the map member function.
PLS-00521: ORDER methods must be declared with 1 (one) parameter in addition to (optional) SELF.
Cause: An order member function was declared without the user-specified parameter. Order member functions have two parameters, one is the default SELF parameter which is added by the compiler. the second parameter is added by the user and must declare an order method which must be the same type as the containing object type.
Action: Check and correct the way the parameter is specified.
PLS-00522: MAP methods must return a scalar type.
Cause: The MAP member function was written such that it returns something other than a scalar type.
Action: Rewrite the MAP function such that it returns a scalar type.
PLS-00523: ORDER methods must return an INTEGER.
Cause: An order member function was written such that it returns something other than an integer type.
Action: Rewrite the ORDER method such that it returns an integer type.
PLS-00524: The parameter type in an ORDER method must be the containing object type.
Cause: An order member function was declared without the user- specified parameter. Order member functions have two parameters, one is the default SELF parameter which is added by the compiler. the second parameter is added by the user and must declare an order method which must be the same type as the containing object type.
Action: Check and correct the way the parameter is specified.
PLS-00525: Within SQL statements, only equality comparisons of objects are allowed without a map or order function.
Cause: A map or order function was not provided for a relational comparison. Only equality comparisons may be used when a map or order function is not supplied.
Action: Supply either a map or order function for the object. Otherwise change the program to use only equality comparisons.
PLS-00526: A MAP or ORDER function is required for comparing objects in PL/SQL.
Cause: Within stand alone PL/SQL, an attempt was made to compare objects without a map or order function.
Action: Provide a map or order function and retry the operation.
PLS-00527: MAP or ORDER functions require a PRAGMA RESTRICT_REFERENCES specifying :WNDS,WNPS,RNPS,RNDS.
Cause: Either a PRAGMA RESTRICT_REFERENCES was not specified or it was specified without one of the following: WNDS, WNPS, RNPS, or RNDS.
Action: Add or correct the PRAGMA and retry the operation.
PLS-00528: The parameters to an ORDER function must have IN mode
Cause: You declared parameter to an ORDER function to have OUT or IN OUT mode.
Action: Correct the parameter to use IN mode only.
PLS-00529: Bad column name string in INSERT statement (must be an identifier)
Cause: In an INSERT statement, an attempt was made to use a column name that is not an identifier. In any INSERT statement with explicit column list a column name must be a simple identifier.
Action: Rewrite the INSERT statement, using a simple identifier for the column name.
PLS-00530: Illegal type used for object type attribute: 'string'.
Cause: An attempt was made to use an invalid type for an object type attribute.
Action: Use only supported types for the object type attribute.
PLS-00531: Unsupported type in a VARRAY or TABLE type: 'string'.
Cause: An attempt was made to use an unsupported type in a VARRAY or TABLE type.
Action: Use only supported types in a VARRAY or TABLE type.
PLS-00532: Target of REF must be a complete or incomplete object type.
Cause: The target of a REF can only be a complete or an incomplete object type.
Action: If a REF is to be used, change the type; otherwise, remove the REF.
PLS-00533: Tables of non_queryable types are not supported.
Cause: An attempt was made to create a table of a type which cannot be queried. Tables of such types are not supported.
Action: Create an object type containing the non-queryable type. Then create a table of the object type.
PLS-00534: A Table type may not contain a nested table type or VARRAY.
Cause: An attempt was made to do one of the following: define a table type which contained nested collection types. or define an object table that has (perhaps nested) another table type or VARRAY type.
Action: Check the table definitions to be sure that they do not contain nested tables or VARRAYs.
PLS-00535: A VARRAY type may not contain a NESTED TABLE, VARRAY or LOB
Cause: An attempt was made to do one of the following: define a VARRAY type containing a nested collection type or LOB or define a VARRAY type of an object type that has a nested attribute which is one of NESTED TABLE, VARRAY or LOB type.
Action: Check the VARRAY definitions to be sure that they do not contain nested colection types, LOBs or nested attributes.
PLS-00536: Navigation through REF variables is not supported in PL/SQL.
Cause: The expression of the form refvar.field was entered. This is not supported in PL/SQL, ver 8.0.
Action: none
PLS-00537: A VARRAY must have a positive limit
Cause: A VARRAY type was declared with a non-positive limit, for example VARRAY(0).
Action: Declare the VARRAY with a positive limit and retry the operation.
PLS-00538: subprogram or cursor 'string' is declared in an object type specification and must be defined in the object type body
Cause: The specified subprogram is declared in an object type's specification, but is not defined in the object type body.
Action: Define the subprogram in the object type body, or remove the declaration from the specification.
PLS-00539: subprogram 'string' is declared in an object type body and must be defined in the object type specification
Cause: The specified subprogram is declared in an object type's body, but is not defined in the object type's specification. Notice cursor bodies can exist without a specification.
Action: Define the subprogram in the object type's specification, or remove the declaration from the body.
PLS-00540: object not supported in this context.
Cause: An object was declared inside a local scope (Function, Procedure, or anonymous block), or in a package scope which is not supported.
Action: Declare the type in a global or data base scope.
PLS-00541: size or length specified is too large.
Cause: A length or size that is too large was specified for a data item.
Action: Specify a smaller value and retry the operation.
PLS-00542: CLOB and NCLOB cannot use varying-width character sets in the server
Cause: A server type is being created with an embedded CLOB or NCLOB atttribute which uses a varying-width character set.
Action: Use VARCHAR2 instead of CLOB, or use a fixed-width character set.
PLS-00543: a PLSQL Table may not contain a nested table type or VARRAY.
Cause: An attempt was made to define a PLSQL table that contained a (possibly deeply) nested table type or VARRAY. Nested collection types are not supported.
Action: Remove the nested table type or VARRAY from the table. Then retry the operation.
PLS-00546: SELF may not be declared as a REF parameter.
Cause: SELF was declared as a ref parameter to a member function or procedure. SELF is not supported as a REF.
Action: Redeclare SELF as a value parameter.
PLS-00548: invalid use of operator.
Cause: A name of an operator is used as a qualifier or appears outside from sql context.
Action: Eliminate the use of operator name as a qualifier or place it in a sql clause.
PLS-00550: character set specification is not allowed for this type
Cause: A character set specification was made on a type that does not require one.
Action: Remove the character set specification, or change the type.
PLS-00551: character set ANY_CS is only allowed on a subprogram parameter
Cause: The character set ANY_CS was specified when it is not allowed.
Action: Change or remove the character set specification.
PLS-00552: flexible character set is not allowed on component element
Cause: ANY_CS or %CHARSET was used to reference an ANY_CS parameter which is not a CHAR, VARCHAR2, or CLOB type. ANY_CS or %CHARSET is not allowed for fields of a record , object, elements of a collection, etc.
Action: Change or remove the character set specification.
PLS-00553: character set name is not recognized
Cause: An unrecognized name appears in a character set specification.
Action: Change or remove the character set specification.
PLS-00554: character set has already been determined
Cause: A redundant or conflicting character set was specified.
Action: Remove the CHARACTER SET specification, or change the character set specified.
PLS-00555: default expressions are not allowed for SQL operators
Cause: A default expression has been specified for a SQL operator.
Action: Eliminate the default expression from the operator.
PLS-00560: character set mismatch
Cause: An expression was used that has the wrong character set for this context.
Action: Adjust the expression, using TRANSLATE(... USING ...) or by rethinking the logic.
PLS-00561: character set mismatch on value for parameter 'string'
Cause: An expression was used that contains an incorrect character set. The actual argument has a character set conflict. If a default argument value is being used, it might be in conflict with some actual argument that must have the same character set.
Action: Adjust the expression, using TRANSLATE(... USING ...) or change the character set.
PLS-00562: a function must return a type.
Cause: The current function was definied to return something other than a data type.
Action: Make sure the function is returning a data type.
PLS-00563: illegal use of CAST expression
Cause: CAST (in PLSQL) was used outside of a DML scope.
Action: Do not use CAST outside DML statements.
PLS-00564: lob arguments are not permitted in calls to remote server
Cause: use of lob argument in call to remote server
Action: Do not use LOBs in call to remote server
PLS-00565: %s must be completed as a potential REF target (object type)
Cause: Incomplete library units that are potential targets of REF dependencies must be completed so that they continue to remain potential targets of REF dependencies (since there might be library units with REF dependencies on this library unit). Potential REF targets include complete and incomplete object types. This error happened because an attempt was made to complete a potential REF target as something other than a potential REF target.
Action: Use another name for this library unit, or drop the original incomplete library unit.
PLS-00566: type name "string" cannot be constrained
Cause: A lob, date, boolean, rowid, or mlslabel type was constrained with a length specification. For example: X BLOB(5);
Action: Remove the constraint.
PLS-00567: cannot pass NULL to a NOT NULL constrained formal parameter
Cause: You attempted to pass NULL to a NOT NULL constrained parameter.
Action: Pass a NOT NULL expression instead.
PLS-00568: cannot access rows from a non-nested table item
Cause: You attempted to use TABLE expression, from a non-nested table
Action: pass the correct parameter
PLS-00569: numeric overflow or underflow
Cause: A constant literal is either too large or too small to fit in an Oracle number
Action: Change the value of the literal
PLS-00570: different number of columns in the multiset and cast expressions
Cause: Number of columns in the collection returned by MULTISET and the number of columns for the CAST type don't match. For example: create type tab_obj as object (n number); create type tab1 as table of tab_obj; create table tab2 (col1 number, col2 number); select CAST(MULTISET(select col1, col2 from tab2) as tab1) from tab2;
Action: none
PLS-00571: method access through data base link not yet supported on client side
Cause: Remote link is used with on client side
Action: Create a dummy function to call symbolic link on server side or wiat till it is implemented
PLS-00572: improper constraint form used
Cause: "number" types cannot have a range. user-defined aggregate types and integer types cannot have scale or precision specified. Example: "x number(5,3)" is acceptable but "x number range 1..10" is not.
Action: Remove the constraint
PLS-00573: cannot constrain scale, precision, or range of an anchored type declaration
Cause: A variable declared with %TYPE or %ROWTYPE cannot have a scale, precision, or range constraint. Example: x y%TYPE(10) is not acceptable. It is legal to add "NOT NULL" or non-conflicting CHARACTER SET constraints to anchored type declarations.
Action: Remove the constraint or use a type name instead of an anchored type.
PLS-00580: supertype must be an object type
Cause: An attempt was made to declare an object type to have a supertype, but the specified supertype was not itself an object type. Object types can inherit only from other object types.
Action: Remove the supertype specification, or change it to refer to an object type. If the declaration appears correct, make sure the supertype has compiled correctly.
PLS-00581: inheritance is not supported for opaque types
Cause: An attempt was made to declare an opaque type with a supertype.
Action: Remove the supertype specification.
PLS-00582: attribute declarations are not allowed in opaque types
Cause: An attempt was made to declare an attribute in an opaque type.
Action: Remove the attribute declaration.
PLS-00583: size must be specified if opaque type is fixed-length
Cause: An attempt was made to declare a fixed-length opaque type without specifying an explicit size.
Action: Specify an explicit size, or change the declaration to be varying-length.
PLS-00584: size of an opaque type must be between 1 and 4000 bytes
Cause: An attempt was made to specify an explicit size for an opaque type, but the specified size was out of the valid range.
Action: Change the explicit size to be between 1 and 4000 bytes, or change the declaration to be varying-length without an explicit size.
PLS-00585: declared support library for opaque type is not a library
Cause: An attempt was made to name a support library for an opaque type, but the name refers to an object that is not a library.
Action: Change the declaration to name a valid library.
PLS-00586: a static method cannot declare a parameter named SELF
Cause: An attempt was made to name a parameter SELF when declaring a static method. SELF is reserved as a parameter name in methods, to hold the object instance on which the method is applied. A parameter named SELF is not allowed in static methods because static methods do not apply to a particular object instance.
Action: Change the name of the parameter in the declaration.
PLS-00587: a static method cannot be invoked on an instance value
Cause: An attempt was made to use an object instance value, not a typename, as the qualifier of the name of a method invocation, but only a typename can be used as the qualifier when calling a static method.
Action: Use the typename, not an object instance value, to qualify the name of a method if the method is static.
PLS-00588: unqualified instance attribute references allowed only in member methods
Cause: An attempt was made to use the name of an object instance attribute in the body of a static method, or in an initialization default value on another attribute. If the instance attribute is not qualified with a particular object instance that supplies a value, the instance attribute can be named only when it is inside a member method.
Action: Qualify the attribute reference with the name of an object value, or change the containing method to a member method rather than a static method.
PLS-00589: no attributes found in object type "string"
Cause: Table of non adt type is defined.
Action: Table of type should be of ADT type only
PLS-00590: attempting to create a subtype UNDER a FINAL type
Cause: An attempt was made to create a subtype UNDER a FINAL type.
Action: Avoid deriving a subtype from this FINAL type.
PLS-00591: this feature is not supported in client-side programs
Cause: One of the following features was used in a wrong context: pragma AUTONOMOUS_TRANSACTION, dynamic SQL statements, (e.g. EXECUTE IMMEDIATE), and bulk binds. These listed features can only be used in server-side programs but not client-side programs.
Action: Remove it or define a server-side subprogram to do the work and call the subprogram from the client.
PLS-00592: the type of a object table must be an object type
Cause: You have defined a typed-table of a non-object type.
Action: Replace the non-object type with an object-type.
PLS-00593: default value of parameter "string" in body must match that of spec
Cause: The default value initialization of a parameter in a subprogram body contained in a package body did not match that of the corresponding subprogram specification in the corresponding package specification.
Action: Change the default initialization of the parameter in body to match that of spec.
PLS-00594: the SELF parameter can be declared only as IN or as IN OUT
Cause: The SELF parameter was declared as an OUT parameter.
Action: Declare the SELF parameter as either an IN or an IN OUT parameter.
PLS-00595: the TABLE operator is not allowed in this context
Cause: This feature is not yet implemented.
Action: Don't use weak ref cursors with bulk binds.
PLS-00597: expression 'string' in the INTO list is of wrong type
Cause: This exception is raised for the following errors:

- the expression in INTO clause of OPEN or RETURNING statement is neither of legal SQL datatypes nor of PL/SQL RECORD datatype

- a collection of records is used in INTO clause of OPEN or RETURNING statement.

- a record or a collection of records is used in BULK COLLECT INTO

Action: Use expression with correct datatype in the INTO clause
PLS-00598: comparison of object with NULL using "string" is not allowed
Cause: An object is compared with NULL using a relational operator.
Action: Use IS NULL comparison operator.
PLS-00599: SAMPLE percentage must be in the range [0.000001,100)
Cause: The percentage number is not in the range [0.000001,100)
Action: Use a percentage number in the range [0.000001,100)
PLS-00600: SAMPLE cannot be applied to a remote object
Cause: SAMPLE applying to a remote object is not supported
Action: Do not use SAMPLE with a remote object
PLS-00601: partition extended object names may only be used with tables
Cause: User attempted to use a partition-extended object name with an object which is not a table.
Action: Avoid using partition-extended name syntax with objects which are not tables
PLS-00602: CUBE and ROLLUP may appear only in a GROUP BY clause
Cause: User attempted to use the keywords CUBE or ROLLUP outside a GROUP BY clause
Action: Avoid using the keywords CUBE and ROLLUP outside the GROUP BY clause
PLS-00603: GROUPING function supported only with GROUP BY CUBE or ROLLUP
Cause: User attempted to use the GROUPING function without GROUP BY CUBE or GROUP BY ROLLUP
Action: Avoid using the GROUPING function without GROUP BY CUBE or ROLLUP
PLS-00604: aggregate function is not allowed here
Cause: One of the functions, such as AVG, COUNT, MAX, MIN, SUM, STDDEV or VARIANCE, was used in a WHERE or GROUP BY clause
Action: Remove the group function from the WHERE or GROUP BY clause. The desired result may be achieved by including the function in a subquery or HAVING clause.
PLS-00605: set operators are not yet supported as an argument to a MULTISET operator
Cause: A set operator was used in a subquery that was the argument to a MULTISET operator.
Action: Rewrite your SQL statement so that it does not use a set operator in the subquery that is the argument to the MULTISET operator.
PLS-00606: cursor subquery is not supported on client side in this release
Cause: A query that contains a cursor subquery is being used from client side.
Action: Use this feature from serevr side only.
PLS-00607: SQLJ Object Types can have only SQLJ Types as its supertype or subtype
Cause: You were trying to create a SQLJ Object Type under a non-SQLJ Object Type.
Action: Recreate the type as a SQLJ Object Type.
PLS-00608: the value of the USING clause must match that of the supertype
Cause: You were trying to create a SQLJ Object Type with a different value of the USING clause from the USING clause specified in its supertype.
Action: Change the value of the USING clause to match the USING clause in its supertype.
PLS-00609: the OVERRIDING clause is not valid for SQLJ Object Types
Cause: You were trying to a SQLJ Object Type method that override an inherited method.
Action: Change the SQLJ Object Type defintion by removing the OVERRIDING method.
PLS-00610: ROW can be used only once in SET clause of UPDATE statement
Cause: You were trying to use ROW more than once in UPDATE statement.
Action: Remove all the additional ROW in set clause of UPDATE statement.
PLS-00611: right hand side can be only the variables of record type
Cause: with ROW on LHS, only PL/SQL records or %ROWTYPE variables are allowed on right hand side..
Action: Make appropriate changes, so that right hande side should only have variables of record or %ROWTYPE.
PLS-00612: Number of attributes do not match in SET clause
Cause: Number of columns do not match with number of attributes on record type on rhs.
Action: Make sure that number of columns match with the number of attributes in record on rhs.
PLS-00613: only one item is allowed, when using variables of record type
Cause: You are trying to use more than one values in VALUES clause or RETURNING INTO clause, when one of the value is of record type..
Action: Specify only one variable of record type, or don't use variables of record type.
PLS-00614: creating a FINAL NOT INSTANTIABLE type
Cause: An attempt was made to create a FINAL NOT INSTANTIABLE type. No useful operation can be performed with this type.
Action: Avoid using the keywords FINAL and NOT INSTANTIABLE together when creating types.
PLS-00615: type mismatch found at 'string' between CASE operand and WHEN operands
Cause: In a simple CASE statement or expression, the CASE operand and WHEN operands do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.
Action: Change the CASE operand and WHEN operands so that their datatypes match. Consider using datatype conversion functions in the CASE operand and/or WHEN operands.
PLS-00616: type mismatch found at 'string' among result expressions in a CASE expression
Cause: In a CASE expression, the result expressions do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.
Action: Change the result expressions so that their datatypes match. Consider using datatype conversion functions in the result expressions.
PLS-00617: at least one result in the CASE expression must not be NULL
Cause: All the results in the CASE expression are the literal NULL.
Action: Change at least one result in the CASE expression to be non-NULL.
PLS-00618: type mismatch found at 'string' between operands in a NULLIF expression
Cause: In a NULLIF expression, the two operands do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.
Action: Change the operands so that their datatypes match. Consider using datatype conversion functions in the operands.
PLS-00619: the first operand in the NULLIF expression must not be NULL
Cause: The first operand in the NULLIF expression is the literal NULL.
Action: Change the first operand in the NULLIF expression to be non-NULL.
PLS-00620: type mismatch found at 'string' among operands in a COALESCE expression
Cause: In a COALESCE expression, the operands do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.
Action: Change the operands so that their datatypes match. Consider using datatype conversion functions in the operands.
PLS-00621: at least one operand in the COALESCE expression must not be NULL
Cause: All the operands in the COALESCE expression are the literal NULL.
Action: Change at least one operand in the COALESCE expression to be non-NULL.
PLS-00622: range constraints must be between -2147483647 and 2147483647
Cause: The range constraints specified for a pls_integer or binary_integer declaration did not fall between -2147483647 and 2147483647.
Action: Use range constraints between -2147483647 and 2147483647.
PLS-00623: FLOAT precision constraint must be between 1 and 126
Cause: The precision specified for a FLOAT, REAL or DOUBLE PRECISION did not fall between 1 and 126.
Action: Use precision constraints between 1 and 126.
PLS-00624: USING clause must be used with either aggregate or pipelined functions
Cause: USING clause cannot be used with functions that are not declared with AGGREGATE or PIPELINED properties.
Action: Define function body in PL/SQL or some other language (using external callout call specification).
PLS-00625: PARTITION/CLUSTER/ORDER-BY clause can only be used with IN parameters
Cause: A PARTITION/CLUSTER/ORDER-BY clause was used with an OUT or IN OUT ref-cursor parameter.
Action: Change the parameter mode to IN or use some other parameter with the PARTITION/CLUSTER/ORDER-BY clause.
PLS-00626: partitioned/clustered/ordered parameter must be a function argument
Cause: A partitioning or clustering/ordering specification specified on an argument that is not one of the function arguments.
Action: Specify partitioning/clustering/ordering based on the function ref-cursor formal argument.
PLS-00627: 'string' must be a strongly typed ref cursor
Cause: A partitioning or clustering/ordering specification specified on an argument that is not a strongly typed ref cursor.
Action: Specify partitioning/clustering/ordering based on the function ref-cursor formal argument.
PLS-00628: 'string' must be a valid record attribute
Cause: A partitioning or clustering/ordering specification must use only valid record attributes.
Action: Specify partitioning/clustering/ordering based on valid record attributes.
PLS-00629: PIPE statement cannot be used in non-pipelined functions
Cause: A PIPE statement was used in a non-pipelined function.
Action: Use PIPE statement only in pipelined functions.
PLS-00630: pipelined functions must have a supported collection return type
Cause: A pipelined function was specified with an unsupported return type. The following are not supported as return types of pipelined functions:

- non-collections,

- PL/SQL tables,

- associative arrays,

- collections of PL/SQL types: rowid, mlslabel, long, long raw, boolean, binary_integer, pls_integer, string and urowid The following restrictions apply:

- If the return type is a collection of records, then each of the attributes of the record must be a supported type.

- A collection of records must not contain a record type as one of its attributes.

Action: Specify a supported collection type as the pipelined function return type.
PLS-00631: PARTITION-BY and CLUSTER/ORDER-BY clauses must be used with the same function argument
Cause: PARTITION-BY and CLUSTER/ORDER-BY clauses are specified on different function arguments.
Action: Use the same argument in both PARITITON-BY and CLUSTER/ORDER-BY clauses.
PLS-00632: NOT INSTANTIABLE method cannot have a body
Cause: An attempt was made to provide an implementation for a NOT INSTANTIABLE method.
Action: Remove the implementation for the NOT INSTATIABLE method.
PLS-00633: RETURN statement in a pipelined function cannot contain an expression
Cause: A RETURN statement in a pipelined function contains an expression, which is not allowed. Pipelined functions must send back values to the caller by using the PIPE statement.
Action: Remove the expression from the RETURN statement and use a PIPE statement to return values. Else, convert the function into a non-pipelined function.
PLS-00634: type with NOT INSTANTIABLE methods must be declared NOT INSTANTIABLE
Cause: The type being created contains NOT INSTANTIABLE methods, either declared or inherited. The type must be explicitly declared NOT INSTANTIABLE
Action: Explicitly specify the NOT INSTANTIABLE keyword or provide implementations for all the NOT INSTANTIABLE methods.
PLS-00635: method does not override
Cause: The method specification contains the OVERRIDING keyword but the method does not override a method in the ancestor types.
Action: Check the method specification.
PLS-00636: overriding method requires OVERRIDING keyword
Cause: An attempt was made to provide an overriding method specification, but the OVERRIDING keyword was not specified.
Action: Modify the method specification and specify the OVERRIDING keyword.
PLS-00637: FINAL method cannot be overriden or hidden
Cause: An attempt was made to override a FINAL MEMBER method or hide a FINAL STATIC method.
Action: Avoid overriding FINAL MEMBER methods or hiding FINAL STATIC methods
PLS-00638: cannot overload MAP method
Cause: The MAP method does override the inherited one.
Action: Make the specifications match.
PLS-00639: NCHAR/NVARCHAR2 cannot be byte length semantics
Cause: NCHAR/NVARCHAR can only be codepoint length sematics. BYTE qualifiers used with NCHAR is illegal: nc NCHAR(7 BYTE); name NVARCHAR2(10 byte);
Action: Remove BYTE qualifier to make it as codepoint length semantics
PLS-00640: a pipelined function cannot be called from PL/SQL context
Cause: A pipelined function was invoked from a PL/SQL expression.
Action: Use the pipelined function in the FROM clause of a SQL query.
PLS-00641: INTO clause not allowed for this SELECT statement
Cause: A SELECT statement in a cursor definition, an OPEN statement or a cursor FOR loop has an erroneous INTO clause.
Action: Remove the INTO clause.
PLS-00642: local collection types not allowed in SQL statements
Cause: A locally-defined (i.e. not schema level) collection type was used in a SQL statement. The type must be defined in a schema to be accepted in a SQL statement.
Action: Define the collection type in your schema, not inside a PL/SQL subprogram.
PLS-00643: booleans, index tables, records and cursors not allowed in SQL statements
Cause: Items of type boolean, table of foo index by binary_integer, record and static cursors cannot be used in SQL statements.
Action: Remove expressions of these types from the SQL statement.
PLS-00644: character set mismatch found at 'string' among result expressions in a CASE expression
Cause: In a CASE expression, the result expressions do not match in character set, and it is unclear which implicit conversion is required to correct the mismatch.
Action: Change the result expressions so that their character sets match.
PLS-00645: character set mismatch found at 'string' among operands in a COALESCE expression
Cause: In a COALESCE expression, the operands do not match in character set and it is unclear which implicit conversion is required to correct the mismatch.
Action: Change the operands so that their character sets match.
PLS-00646: MAP or ORDER method must be defined in the root of the subtype hierarchy
Cause: An attempt was made to define a MAP or ORDER method in a subtype.
Action: Define the MAP or ORDER method in the root of the subtype hierarchy. You can override MAP methods in subtypes.
PLS-00647: attribute by name "string" conflicts with method by same name
Cause: While creating a subtype some attribute name conflicted with a method name.
Action: Use a different name for attribute or method in the type being created.
PLS-00648: type of supertype attribute "string" can not be a subtype or reference to a subtype in this release
Cause: User tried to complete a type, Tsub as a subtype of another type, Tsuper where Tsuper contained an attribute of type Tsub or of type REF to Tsub. This is an implementation restriction.
Action: Change the design of code to not use any type with attribute whose type is of subtype or REF to subtype.
PLS-00649: method "string" can be overridden only once per object type
Cause: User tried to override the method more than once in the same subtype.
Action: Either make this an extra overload by removing the OVERRIDING keyword where the method signature is different. The argument types should be reconsidered otherwise.
PLS-00650: invalid type for PARTITION/CLUSTER/ORDER BY clause
Cause: Uer tried to use invalid type for PARTITION/CLUSTER?ORDER BY clause.
Action: Use legal allowed types.
PLS-00651: implementation type in Aggregate/Table function should be a valid type
Cause: User tried to use some other database object like a package to define implementation type of an aggregate/table function.
Action: Use a valid user defined type as implementation type.
PLS-00652: aggregate functions should have exactly one argument
Cause: User tried to create aggregate function with either 0 or more than one arguments.
Action: Do not create aggregate function with 0 or more than one argument.
PLS-00653: aggregate/table functions are not allowed in PL/SQL scope
Cause: User tried to use a table/aggregate function in PL/SQL scope.
Action: Do not use table/aggregate function in PL/SQL scope.
PLS-00654: PARTITION/ORDER/CLUSTER BY are allowed for only with PARALLEL_ENABLE
Cause: User tried partion by order by cluster by without parallel enable clause in table function.
Action: specify parallel enable also when using partion by, cluster by order by clause.
PLS-00655: only functions can be declared as PIPELINED
Cause: user is trying to declare a procedure to be pipeliend function
Action: declare a function instead of a procedure to be a pipelined function
PLS-00656: field 'string' not available in input argument
Cause: An EXTRACT operation specified a field that was not present. For example, you tried to extract the YEAR field from a TIME variable.
Action: Specify a legal field in the call to EXTRACT.
PLS-00657: Implementation restriction: bulk SQL with associative arrays with VARCHAR2 key is not supported.
Cause: Variable or expression of associative array type was used as bulk SQL bind or define.
Action: Use colleciton types supported by bulk SQL.
PLS-00658: constructor method name must match type name
Cause: The name of the object type constructor does not match the type name.
Action: Change the name of the constructor method to match the type name.
PLS-00659: constructor method must return SELF AS RESULT
Cause: The return clause of the constructor method did not specify SELF AS RESULT.
Action: Change the return clause to include RETURN SELF AS RESULT.
PLS-00660: SELF parameter of constructor method must be IN OUT
Cause: The mode of the SELF parameter of the constructor was not IN OUT.
Action: Change the mode of the SELF parameter to be IN OUT.
PLS-00661: RETURN statement in a CONSTRUCTOR cannot include an expression
Cause: An attempt was made to include an expression in the RETURN statement of a CONSTRUCTOR body.
Action: Remove the expression from the RETURN statement.
PLS-00662: Non-external object types containing external mapped attributes are not allowed
Cause: An attempt was made to create a non-external object, whoose attributes are mapped externally.
Action: Create the object as an external object.
PLS-00663: the NEW keyword is not allowed in this context
Cause: The NEW keyword is not followed by an call to a constructor method.
Action: Remove the NEW keyword, or make sure the expression following it is a constructor call.
PLS-00664: Both ORDER BY and CLUSTER BY can not be specified for the same table function
Cause: An attempt was made to specify both ORDER BY and CLUSTER BY for the same table function.
Action: specify either ORDER BY or CLUSTER BY for a table function, but not both.
PLS-00665: ORDER BY and CLUSTER BY clauses require a PARTITION BY clause
Cause: An attempt was made to specify an ORDER BY or CLUSTER BY clause without also specifying a PARTITION BY clause.
Action: Add a PARTITION BY clause, or remove the ORDER BY or CLUSTER BY clause.
PLS-00666: Only index by binary_integer/pls_integer associative arrays allowed here
Cause: An attempt was made to specify index collection that was not indexed by binary_integer or pls_integer.
Action: Change the index collection variable type to associative array that is indexed by binary_integer or pls_integer.
PLS-00667: Element type of associative array should be pls_integer or binary_integer
Cause: An attempt was made to specify index collection whos element type was not one of pls_integer or binary_integer.
Action: Change the index collection variable type to associative array whose element type is pls_integer or binary_integer.
PLS-00668: Type of expression should be a collection type
Cause: An attempt was made to specify expression after INDICES OF or VALUES OF clause whose type is not a collection type.
Action: Change the index collection expression type to a valid collection type.
PLS-00669: Type of expression should be a valid collection variable
Cause: An attempt was made to specify expression after INDICES OF or VALUES OF clause that is not a collection variable.
Action: Change the index collection expression type to a valid collection variable.
PLS-00670: sort columns must be simple column names
Cause: An attempt was made to specify an expression as a sort column in a PARTITION BY, CLUSTER BY or ORDER BY clause. Only simple column names are permitted.
Action: Specify a simple column name.
PLS-00700: PRAGMA EXCEPTION_INIT of string must follow declaration of its exception in the same declarative part
Cause: An EXCEPTION_INIT pragma was not declared in the same block as its exception. They must be declared in the proper order in the same block, with the pragma declaration following the exception declaration.
Action: Place the EXCEPTION_INIT pragma directly after the exception declaration referenced by the pragma.
PLS-00701: illegal ORACLE error number string for PRAGMA EXCEPTION_INIT
Cause: The error number passed to an EXCEPTION_INIT pragma was out of range. The error number must be in the range -9999 .. -1 (excluding -100) for Oracle errors or in the range -20000 .. -20999 for user-defined errors.
Action: Use a valid error number.
PLS-00702: second argument to PRAGMA EXCEPTION_INIT must be a numeric literal
Cause: The second argument passed to an EXCEPTION_INIT pragma was something other than a numeric literal (a variable, for example). The second argument must be a numeric literal in the range -9999 .. -1 (excluding -100) for Oracle errors or in the range -20000 .. -20999 for user-defined errors.
Action: Replace the second argument with a valid error number.
PLS-00703: multiple instances of named argument in list
Cause: Two or more actual parameters in a subprogram call refer to the same formal parameter.
Action: Remove the duplicate actual parameter.
PLS-00704: 'string' must be declared as an exception
Cause: The exception_name parameter passed to an EXCEPTION_INIT pragma is misspelled or does not refer to a legally declared exception. Or, the pragma is misplaced; it must appear in the same declarative section, somewhere after the exception declaration.
Action: Check the spelling of the exception_name parameter. Then, check the exception declaration, making sure the exception name and the keyword EXCEPTION are spelled correctly. Also make sure the pragma appears in the same declarative section somewhere after the exception declaration.
PLS-00705: exception 'string' used in expression requiring return type
Cause: An exception was referred to in an expression. Exceptions have names but not values and therefore cannot contribute values to an expression. For example, the following RETURN statement is illegal: FUNCTION credit_limit (cust_no INTEGER) RETURN NUMBER IS limit NUMBER; over_limit EXCEPTION; ... BEGIN ... RETURN over_limit; -- illegal END;
Action: Check the spelling of the identifiers in the expression, then rewrite the expression so that it does not refer to an exception.
PLS-00706: Exception string cannot be used as prefix of a selected component
Cause: An exception name was mistakenly used to qualify a reference to a component. For example, when dot notation was used to specify fields within a record, an exception name might have been coded instead of the record name.
Action: Rewrite the component reference using a valid prefix (for example, the name of a package, record, or schema).
PLS-00707: unsupported construct or internal error [string]
Cause: At run time, this is an internal error. At compile time, it indicates one of the following problems: -- A call was made to a remote subprogram that has a parameter type or default expression not supported at the calling site. -- An incomplete upgrade or downgrade was done to a database that has stored procedures. Perhaps incorrect versions of system packages such as STANDARD.SQL were installed. -- A compiler bug was encountered. In such cases, legal PL/SQL syntax will fail to compile.
Action: Either report the internal error to your Customer Support representative or, depending on the problem, take one of the following actions: -- Revise the logic of the application to use parameter types and default expressions that are supported at both the local and remote sites. -- Complete the upgrade or downgrade properly, making sure to install correct versions of all system packages. -- Report the legal-syntax error to your Customer Support representative. If there are line and column numbers displayed with the error message, they might help you find a workaround. For example, try recoding the offending line to avoid the bug.
PLS-00708: Pragma string must be declared in a package specification
Cause: The named pragma was not declared in a package specification, as required. For example, the pragma RESTRICT_REFERENCES must be declared in a package specification.
Action: Remove or relocate the misplaced pragma.
PLS-00709: pragma string must be declared in package specification and body
Cause: The named pragma was declared in a package specification but not in the corresponding package body or vice-versa, as well as the package body.
Action: Add the pragma to that part of the package declaration that does not have the pragma.
PLS-00710: PRAGMA AUTONOMOUS_TRANSACTION cannot be declared here
Cause: The PRAGMA was declared in an inappropriate context. This PRAGMA has to be declared in the declarative section of a procedure, a function, a top level anonymous block.
Action: Remove or relocate the misplaced pragma.
PLS-00711: PRAGMA AUTONOMOUS_TRANSACTION cannot be declared twice
Cause: The PRAGMA was declared twice in the same block.
Action: remove the duplicate declaration of the PRAGMA
PLS-00712: illegal option for subprogram string
Cause: Only top level subprograms or subprogram declarations in PACKAGE or TYPE specifications are allowed to have the options DETERMINISTIC or PARALLEL_ENABLE. For example, this error would be raised if the options are used in PACKAGE or TYPE body.
Action: remove the option.
PLS-00713: attempting to instantiate a type that is NOT INSTANTIABLE
Cause: An attempt was made to instantiate a type that is defined as NOT INSTANTIABLE.
Action: Avoid instantiating variables of this NOT INSTANTIABLE type, instead derive an INSTANTIABLE subtype from it and instantiate variables of the subtype.
PLS-00714: supertypes's AUTHID is DEFINER but supertype and subtype are not in same schema
Cause: The supertype's AUTHID is DEFINER, but the supertype and subtype are defined in different schemas. SQL statements executed in dynamically dispatched methods can potentially pick up different values from database tables in the two schemas.
Action: Create the subtype in the same schema as the supertype.
PLS-00715: attribute or method by name 'string' does not exist
Cause: An attempt was made to drop a nonexistant method or attribute from the type being altered.
Action: Check the spelling of the attribute or method name. Make sure it is locally defined in the type and not inherited.
PLS-00716: Attribute/method 'string' can occur only once in an ALTER TYPE statement
Cause: User attempted more than one of ADD, DROP or MODIFY on an attribute in single ALTER TYPE statement. User attempted more than one of ADD or DROP on a method in single ALTER TYPE statement.
Action: Do only one ADD, DROP or MODIFY for an attribute in single ALTER TYPE statement. Do only one ADD or DROP for a method in single ALTER TYPE statement.
PLS-00717: method 'string' does not have matching signature among existing methods
Cause: The method to be dropped matches the name of some existing method but does not match it in signature.
Action: Make sure that a matching method signature is provided for dropping a method.
PLS-00718: type of attribute 'string' does not allow modifications to the attribute
Cause: The type of the attribute to modify is not one of VARCHAR2, NUMBER, or RAW.
Action: Only VARCHAR2, NUMBER and RAW type attributes are allowed to be modified.
PLS-00719: only widening of attribute 'string' constraints is allowed
Cause: Modification to the attribute did not widen its constraints or attempted to change the type of the attribute. For NUMBER type attributes, scale and precision can be changed to allow increase in number of digits after and before the decimal point. For VARCHAR2 and RAW type attributes the size can be increased. Other type attributes are not allowed to be modified. Change of type of attribute is also not allowed.
Action: Change the constraint specification so as to widen the existing constraints.To narrow the constraints or to change the type of the attribute, you must drop the attribute and add it with new constraints or new type. In that case you must also take appropriate steps to preserve your existing data based on the type (if you want to preserve it).Typically this will involve backing up the data and restoring it after the ALTER TYPE.
PLS-00720: type 'string' has evolved
Cause: The type has evolved. The version of the type used by the compiled code is not the same as the latest version of the type.
Action: Recompile the code to use the latest version of the type.
PLS-00721: 'string' formed a non-REF mutually-dependent cycle with 'string'
Cause: This compilation was aborted because the library unit that was compiled would have formed a non-REF mutually-dependent cycle with some other library units. This happens when an attempt is made to compile types that have attributes of other types that may participate in a cycle with this type. Example: create type t1; create type t2 (a t1); create type t1 (a t2);
Action: Break the cycle (possibly by adding a REF or by using another type).
PLS-00722: supertypes's AUTHID is different than subtype's AUTHID
Cause: The subtype's's AUTHID must be same as the supertype's AUTHID.
Action: Create the subtype with AUTHID of its supertype or do not specify AUTHID for subtype.
PLS-00725: type 'string' must be a supertype or subtype of the TREAT expression
Cause: In TREAT(<expr> AS <type>), type must be a supertype or subtype of <expr>.
Action: none
PLS-00726: MODIFY ELEMENT is supported only on schema-level varray and nested tables
Cause: An attempt was made to modify the limit of a type that was not a schema-level varray and nested table type.
Action: This is not a legal ALTER TYPE command for this type.
PLS-00727: MODIFY LIMIT is supported only on schema-level varray types
Cause: An attempt was made to modify the limit of a type that was not a schema-level varray type.
Action: This is not a legal ALTER TYPE command for this type.
PLS-00728: the limit of a VARRAY can only be increased and to a maximum 2147483647
Cause: An attempt was made to decrease the limit or raise it past 2147483647.
Action: This is not a legal limit for this type, change it.
PLS-00729: only widening of the collection element type is allowed
Cause: Modification to the collection element type did not widen its constraints or attempted to change the type of the element. For NUMBER types, scale and precision can be changed to allow increase in number of digits after and before the decimal point. For VARCHAR2 and RAW type attributes the size can be increased.
Action: Change the constraint specification so as to widen the existing constraints.
PLS-00730: collection element type does not allow modifications
Cause: The element type to modify is not one of VARCHAR2, NUMBER, or RAW.
Action: Only VARCHAR2, NUMBER and RAW collection elements can be modified.
PLS-00731: ALTER TYPE is supported only on schema-level types
Cause: An attempt was made to alter a type that was not schema-level.
Action: ALTER TYPE is not legal for this type.
PLS-00732: Illegal overload of ellipsis in formal parameter list
Cause: An ellipsis and a non-ellipsis type appeared at the same position in separate overload candidates. Currently, if ellipsis types are used they must appear in ALL overload candidates with the same name (regardless of the number or types of their formal parameters) at the same position in the formal parameter list.
Action: Make sure that ellipsis types appear at the same position in all overload candidates.
PLS-00733: RPCs to variable argument functions are not allowed
Cause: Attempted to call a vararg function (a function which contains ellipsis in the formal parameter list) as an RPC.
Action: Do not call vararg functions as an RPC.
PLS-00734: Illegal use of an associational parameter with a formal ellipsis
Cause: Attempted to use an associational actual argument for a formal ellipsis type argument.
Action: Remove associational parameters which correspond to formal ellipsis types.
PLS-00735: Attempted to declare more than one formal ellipsis parameter
Cause: More than one ellipsis ('...') was found in a formal parameter specification for a function or procedure
Action: Make sure only one ellipsis appears in a formal parameter specification for any given function or procedure
PLS-00736: user-declared operators are not allowed
Cause: An attempt was made by the user to declare an operator (a function whose name is enclosed in single quotes ("'")). Operators may only be declared in package STANDARD.
Action: Remove the single quotes from around the function name, replacing them with double quotes (""") only if needed.
PLS-00737: LIBRARY file specification exceeds the maximum allowed length
Cause: A string of more than expected number of chararacters was found for the LIBRARY file specification.
Action: Limit the LIBRARY file specification to the appropriate size for the platform.
PLS-00738: REF target string changed during compilation
Cause: The current unit contains a REF to a target object. During compilation, the REF's target object was simultaneously changed by a different session. The current unit is therefore invalid and needs to be recompiled to pick up the latest definition of the REF target.
Action: Recompile the unit that has this error.
PLS-00751: cannot find PACKAGE SYS_STUB_FOR_PURITY_ANALYSIS
Cause: A top level subprogram (function or procedure) cannot be created if the system package SYS_STUB_FOR_PURITY_ANALYSIS is missing in the Oracle database.
Action: Make sure the package is in the database, and retry the creation
PLS-00752: Table function string is in an inconsistent state.
Cause: Some of the internally generated types prefixed with SYS_ have been dropped. These should never be dropped by the user.
Action: Recompile the table function or the package or type that contains the table function.
PLS-00801: internal error [string]
Cause: This is a generic internal error that might occur during compilation or execution. The first parameter is the internal error number.
Action: Report this error as a bug to your Customer Support representative.
PLS-00900: can't find body of unit 'string'
Cause: At run time, the body of a program unit could not be found. This can happen for one of two reasons. -- First, there may be a unit 'a' which calls a module 'b', where the spec for 'b' exists but not the body. In this case, since the spec is present, there will be no compile-time errors. -- Secondly, this can occur if there is a reference to a sequence outside of the proper context such as a SQL statement. In this case, the "spec" of the sequence reference can be found, but it is invalid to actually run code which references the sequence outside a SQL statement, as in: i := seq.nextval;
Action: If caused by the first reason, create a body for the object that is being referenced. If caused by the second reason, move the sequence into a SQL statement. For example, i := seq.nextval; can be replaced by: select seq.nextval into temp from dual; i := temp;
PLS-00901: the data type of column 'string' of table 'string' is not supported
Cause: A column in a database table belongs to a datatype that is not supported by the current release of PL/SQL.
Action: Remove the offending column from the table or copy the desired columns to another table.
PLS-00902: A READ-ONLY bind variable used in OUT or IN-OUT context
Cause: A host variable that is protected from update was used in a context that allows an update.
Action: Check the context and change the use of the host variable, or assign the value of the host variable to a PL/SQL local variable, then use the local variable instead.
PLS-00904: insufficient privilege to access object string
Cause: An attempt was made to operate on a database object without the required privilege. This error occurs, for example, if an attempt was made to UPDATE a table for which only SELECT privileges were granted.
Action: Ask the DBA to perform the operation or to grant you the required privilege.
PLS-00905: object string is invalid
Cause: An invalid package specification or stored subprogram was referenced. A package specification or stored subprogram is invalid if its source code or any database object it references has been DROPped, REPLACEd, or ALTERed since it was last compiled.
Action: Find out what invalidated the package specification or stored subprogram, then make sure that Oracle can recompile it without errors.
PLS-00906: Compilation is not possible
Cause: The PL/SQL compiler cannot run properly because its operating environment is corrupted. For example, its error message file might be inaccessible.
Action: Check the PL/SQL operating environment, making sure that all files required by the compiler are accessible.
PLS-00907: cannot load library unit string (referenced by string)
Cause: PL/SQL is unable to find and load a library unit that was previously available. This typically happens when you try to load a unit which references another library unit that is non-existent or invalid.
Action: Provide the needed library unit.
PLS-00908: The stored format of string is not supported by this release
Cause: PL/SQL cannot understand the stored format of a library unit. It has been compiled or shrink-wrapped with a version of PL/SQL either too new or too old for this version to understand it.
Action: Recompile the library unit for this version of PL/SQL.
PLS-00909: object string is not declared or insufficient privileges to access object string
Cause: An object from the operator declaration is not declared, or it is declared but there is no sufficient privileges to access that object.
Action: Declare the object, or ask the DBA to grant the privileges required to access the object.
PLS-00910: insufficient privilege to inherit from type string
Cause: An attempt was made to inherit from a type without the required UNDER privilege.
Action: none
PLS-00920: parameter plsql_native_library_dir is not set
Cause: A PL/SQL program is being compiled natively, but the compiler parameter plsql_native_library_dir, which denotes the directory to store the native shared objects (DLL), is not set.
Action: The DBA should set this parameter.
PLS-00923: native compilation failed: string:string
Cause: The native compilation of PL/SQL program has failed because the native shared object (DLL) could not be created successfully.
Action: The DBA should ensure that the commands specified in spnc_commands file are correct.
PLS-00924: native compilation is not supported on this platform
Cause: Native compilation of PL/SQL programs is not supported on this platform.
Action: Compile the PL/SQL program to bytecode by setting the parameter plsql_compiler_flags to INTERPRETED.
PLS-00925: native compilation failed: Unable to create C file (string string)
Cause: Native compilation of a PL/SQL program failed because the C file could not be created. It is likely that the system paramter plsql_native_library_dir does not reference a writable, existing directory
Action: Ensure that the system parameter plsql_native_library_dir references a dirextory which exists, and is writable.
PLS-00950: In this version, PL/SQL tables can not be used in this SQL statement.
Cause: In a SQL statement, a PL/SQL table was referenced incorrectly. For example, the following reference might have been made, but PL/SQL table attributes can only be used in procedural statements: SELECT ename_tab.COUNT INTO name_count WHERE ...
Action: Remove the incorrect reference from the SQL statement.
PLS-00951: %s Feature is not supported by this release
Cause: PL/SQL cannot understand something in an imported library unit. It uses some feature either too new or too old for this version to understand it.
Action: Recompile the imported library unit with this version of PL/SQL, to discover more precisely what feature is not supported.
PLS-00960: RPCs cannot use variables with schema level user-defined types in this release
Cause: Schema level user-defined types, or types which recursively use such types, cannot be used in RPCs. For example: create type foo as object (...) create package my_pack is type my_tab is table of foo; -- on a remote server: x my_pack.my_tab@rpc; -- illegal attempt to use type my_tab
Action: Use only PLSQL defined types for RPC calls. It may be necessary to add extra code to element-wise copy top-level types into local types in order to move such data through an RPC.
PLS-00970: The class name of a method must match that of EXTERNAL NAME clause in the type header
Cause: The class name defined as part of the method signature does not match the one defined in the type header in the EXTERNAL NAME clause. create type foo as object EXTERNAL NAME 'foo' LANGUAGE JAVA (... MEMBER FUNCTION my (number) return number EXTERNAL NAME 'bar.func(oracle.sql.NUMBER) return oracle.sql.NUMBER', .. );
Action: Either omit the class name from the method signature or use the one defined in the type header.
PLS-00989: Cursor Variable in record, object, or collection is not supported by this release
Cause: 3.0 Implementation Restriction for Ref Cursors
Action: none
PLS-00990: Index Tables of Cursor Variables are disallowed
Cause: 2.2 Implementation Restriction for Ref Cursors
Action: none
PLS-00992: Cursor Variables cannot be FETCH'ed from
Cause: 2.2 Implementation Restriction for Ref Cursors
Action: none
PLS-00993: Cursor Variables cannot be passed as RPC arguments or results
Cause: An attempt was made to pass a cursor variable to or from a remote subprogram, which is not allowed. For example, a remote procedure cannot be used to open a cursor variable because remote subprograms cannot return the values of cursor variables.
Action: Change the subprogram call to reference a local database.
PLS-00994: Cursor Variables cannot be declared as part of a package
Cause: An attempt was made to declare a cursor variable in a package specification, which is not allowed. Although REF CURSOR types can be defined in a PL/SQL block, subprogram, or package, cursor variables can be declared only in a block or subprogram.
Action: Move the cursor variable declaration into a PL/SQL block or subprogram.
PLS-00995: unhandled exception # string
Cause: An exception was raised for which no handler was found. If it cannot find a handler for a raised exception, PL/SQL returns an unhandled exception to the host environment. The number embedded in the message is an Oracle error code listed in this manual.
Action: Fix the condition that raised the exception, write an appropriate exception handler, or use the OTHERS handler. If there is an appropriate handler in the current block, the exception was raised in a declaration or exception handler, and therefore propagated immediately to the enclosing block.
PLS-00996: out of memory
Cause: A request from PL/SQL for more memory failed.
Action: Make sure that you are not referencing the wrong row in a PL/SQL table and that the program is not recursing too deeply.
PLS-00997: no cursor return types allowed in this beta version
Cause: Cursor return types have bugs, and it is best to disable them for now.
Action: none
PLS-01400: Use of '||' token
Cause: Use of '||' token in expressions is not in ANSI's grammar. This corresponds to the "binary_add_op"'s reduction to a "CAT_" in plsql.y
Action: none
PLS-01401: Identifier over 18 characters long
Cause: Identifiers over 18 characters long are not allowed under the ANSI grammar.
Action: none
PLS-01402: Use of quoted identifier
Cause: The use of quoted identifiers is a PL/SQL extension and is not allowed under the ANSI grammar.
Action: none
PLS-01403: Comment delimiters /* */
Cause: C-style comments (introduced with the '/' and '*' characters) are not part of the ANSI grammar. To conform with ANSI, comments must be preceded by the ANSI comment introducer, '--' , and must not contain a newline. If someone can figure out a way to make this message look less cheesy without ending up with nested comments, be my guest.
Action: none
PLS-01404: ANSI Identifiers can only consist of letters, digits, and the underscore character
Cause: ANSI identifiers can only consist of letters, digits, and the underscore character. PL/SQL allows "#" and "$" in identifiers, but these are not ANSI.
Action: none
PLS-01405: Under ANSI's grammar, numeric data represented in exponent notationmust use an uppercase E
Cause: Under ANSI's grammar, numeric data represented in exponent notation must use an uppercase "E". Example: 3.45E-6 is ANSI, but 3.45e-6 is not.
Action: none
PLS-01406: An identifier has been found that is considered a keyword in ANSI's grammar but not in PL/SQL's
Cause: An identifier has been found that is considered a keyword in ANSI's grammar but not in PL/SQL's.
Action: none
PLS-01407: One of the identifiers CHAR, CHARACTER, or INTEGER has been redefined by the programmer
Cause: One of the identifiers "CHAR", "CHARACTER", or "INTEGER" (all ansi keywords) has been redefined by the programmer.(special case of 1406, above).
Action: none
PLS-01408: Use of '&' token
Cause: Use of '&' token in expressions is not in ANSI's grammar.
Action: none
PLS-01409: Use of 'PRIOR_' token
Cause: Use of 'PRIOR_' token in expressions is not in ANSI's grammar.
Action: none
PLS-01410: Use of 'MOD' token
Cause: Use of 'MOD' token in expressions is not in ANSI's grammar.
Action: none
PLS-01411: Use of 'REM' token
Cause: Use of 'REM' token in expressions is not in ANSI's grammar.
Action: none
PLS-01412: Use of 'EXP' token
Cause: Use of 'EXP' token in expressions is not in ANSI's grammar.
Action: none
PLS-01413: Use of NULL an expression
Cause: Use of NULL an expression not in ANSI's grammar.
Action: none
PLS-01414: Use of qualified expression here
Cause: Use of qualified expression here is not in ANSI's grammar.
Action: none
PLS-01415: Use of aggregate value here
Cause: Use of aggregate value here is not in ANSI's grammar.
Action: none
PLS-01416: Use of <id> (<value>...) here
Cause: Use of <id> (<value>...) here is not in ANSI's grammar.
Action: none
PLS-01417: Use of %%attribute
Cause: Use of %%attribute value here is not in ANSI's grammar.
Action: none
PLS-01418: Subquery cannot include set operators in ANSI's grammar
Cause: Subquery cannot include set operators in ANSI's grammar.
Action: none
PLS-01419: Subquery must have either '*' or exactly one column in its select list
Cause: Subquery must have either '*' or exactly one column in its select list according to ANSI's grammar.
Action: none
PLS-01420: INTERSECT and MINUS set operators are not ANSI
Cause: INTERSECT and MINUS set operators are not ANSI
Action: none
PLS-01421: FOR UPDATE clause
Cause: FOR UPDATE clause is not in ANSI's grammar.
Action: none
PLS-01422: Aliases
Cause: Aliases are not in ANSI's grammar.
Action: none
PLS-01423: Subquery on right-hand-side in set clause
Cause: Subquery on right-hand-side in set clause is not in ANSI's grammar.
Action: none
PLS-01424: Non-ANSI order of clauses
Cause: ANSI specifies an ordering to clauses in a table-expression which PL/SQL doesn't. The ordering according to ANSI must be: (1) from clause (2) where clause (3) group-by clause (4) having clause In PL/SQL, the from clause must come first, and the clauses after it can appear in any order (with the addition of the non-ansi connect-by clause).
Action: none
PLS-01425: Connect-by clause
Cause: ANSI doesn't allow connect-by clauses.
Action: none
PLS-01450: This <value expression> contains a nonconforming data type
Cause: This <value expression> contains a nonconforming data type. Section 4.2 of X3H2, "Data types" states that: "A nonnull value is either a character string or a number." Many builtin functions in STANDARD will be flagged with this warning by means of a pragma.
Action: none
PLS-01451: The data types of these <value expressions> must be comparable
Cause: The data types of these <value expressions> must be comparable. Section 4.2 of X3H2, "Data types", states that: "A character string and a number are not comparable values." Many builtin functions in STANDARD will be flagged with this warning by means of a pragma. This warning will be place on data-type coercion functions, for example, TO_CHAR(<number>), that are inserted in OracleSQL to allow non-conforming data type combinations.
Action: none
PLS-01452: This function is not part of the ANSI standard
Cause: This function is not part of the ANSI standard. This warning is used to flag such functions as "POWER" that are not mentioned in the ANSI specifications.
Action: none
PLS-01453: This procedure is not part of the ANSI standard
Cause: This procedure is not part of the ANSI standard. This warning is used to flag such procedures as "STOP" that are not mentioned in the ANSI specifications.
Action: none
PLS-01454: No operator may be used with values of data type CHAR
Cause: No operator may be used with values of data type "character string". Section 5.9, "<value expression>", syntax rule 3, of X3H2 states: "If the data type of a <primary> is character string, then the <value expression> shall not include any operators." This warning is placed on many functions in STDBASE that take CHAR args.
Action: none
PLS-01455: The predicates IS NULL and IS NOT NULL are defined only for column specifications
Cause: The predicates "IS NULL" and "IS NOT NULL" are defined only for column specifications, not for any other expressions. Section 5.15, "<null predicate>", indicates that in the predicate "x IS NULL", x must be a column, and may not be any other kind of expression.
Action: none
PLS-01458: The set clause in an UPDATE statement requires a column name of length 1
Cause: The set clause in an UPDATE statement requires a column name of length 1. Sect. 8.11, 8.12
Action: none
PLS-01460: Cannot access object on a remote host
Cause: Cannot access object on a remote host.
Action: none
PLS-01463: STDDEV is not a standard set function
Cause: STDDEV is not a standard set function.
Action: none
PLS-01464: VARIANCE is not a standard set function
Cause: VARIANCE is not a standard set function.
Action: none
PLS-01466: Null strings are not allowed
Cause: Null strings are not allowed.
Action: none
PLS-01467: The value list of the IN predicate, if not a subquery, must contain only value_specifications
Cause: The value list of the IN predicate, if not a subquery, must contain only value_specifications (i.e. literals and PL/SQL or embedded variables).
Action: none
PLS-01468: The first argument of the like-predicate must be a column of type character string
Cause: The first argument of the like-predicate must be a column of type character string.
Action: none
PLS-01469: ANSI standard does not permit records
Cause: ANSI standard does not permit records.
Action: none
PLS-01470: The escape character in the like-predicate must be a literal or a variable of type CHAR
Cause: The escape character in the like-predicate must be a literal or a variable of type character.
Action: none
PLS-01471: The keyword DISTINCT must be present in a COUNT(DISTINCT sim_expr)
Cause: The keyword DISTINCT must be present in a COUNT(DISTINCT sim_expr). Sect 5.8
Action: none
PLS-01472: In a set_function_specification, if DISTINCT is present, the expression must be a column_specification
Cause: In a set_function_specification, if DISTINCT is present, the expression must be a column_specification.
Action: none
PLS-01473: Use <> instead of != or ~=
Cause: Use <> instead of != or ~=. Sect 5.11.
Action: none
PLS-01474: Use of ANY is non_ANSI
Cause: Due to the combining of comparison_predicate and quantified_predicate, we may have something like sim_expr = ANY_ sim_expr, which is nonetheless accepted by kernel.
Action: none
PLS-01500: Unions are not allowed in the definition of a view
Cause: Unions are not allowed in the definition of a view. Sect. 6.9
Action: none
PLS-01501: Options in CREATE TABLE statement is non-ANSI.
Cause: CREATE TABLE allows only the definition of the structure of a table. None of the .SPACE__name. .PCTFREE__numeric_literal. .cluster. is ANSI. Sect. 6.2
Action: none
PLS-01502: Constraint name and constraint status are non-ANSI.
Cause: Constraint name and constraint status are non-ANSI. Sect. 6.3
Action: none
PLS-01503: The expression in a SET clause must not include a set function
Cause: The expression in a SET clause must not include a set function. Sect. 8.12.
Action: none
PLS-01504: Use of AS phase in CREATE TABLE statement is non_ANSI
Cause: CREATE TABLE allows only the definition of the structure of a table. Use of AS phase in CREATE TABLE statement is non-ANSI.
Action: none
PLS-01505: ALTER is non-ANSI
Cause: ALTER is non-ANSI
Action: none
PLS-01506: CREATE INDEX is non-ANSI
Cause: CREATE INDEX is non-ANSI
Action: none
PLS-01507: DROP is non-ANSI
Cause: DROP is non-ANSI
Action: Sect. 6.2
PLS-01701: Illegal syntax in ROLLBACK WORK statement
Cause: Illegal syntax in ROLLBACK WORK statement.
Action: none
PLS-01702: Illegal syntax in COMMIT WORK statement
Cause: Illegal syntax in COMMIT WORK statement.
Action: none
PLS-01703: Cursor name in CLOSE statment must be of length 1
Cause: Cursor name in CLOSE statment must be of length 1.
Action: none
PLS-01704: The expressions in a sort clause must be column specs or unsigned integers, with optional ASC or DESC
Cause: The expressions in a sort clause may only be column specifications or unsigned integers, followed by optional ASC or DESC.
Action: none
PLS-01705: table specified by a cursor not updatable if cursor specification has a UNION or ORDER_BY
Cause: Missing keyword FROM.
Action: none
PLS-01707: In positioned DELETE or UPDATE statement, table must be identified in specification of cursor
Cause: In a positioned DELETE or UPDATE statement, the table deleted fromor updated must be identified in the specifictation of the cursor.
Action: none
PLS-01708: In searched DELETE, UPDATE or INSERT, table must not appear in FROM clause of subqueries in search condition
Cause: In a searched DELETE, UPDATE or INSERT statement, the table affected must not appear in a FROM clause in any of the subqueries in the search condition.
Action: none
PLS-01709: value list of INSERT statement, if specified with value list rather than subquery, must be value specification
Cause: In an INSERT statement, the insert value list, if specified with a value list rather than a subquery, must be value specifications, i.e. no compound expressions or column references. Sect 8.7.
Action: none
PLS-01710: In a positioned DELETE or UPDATE statement, the cursor name must be of length 1
Cause: In a positioned DELETE or UPDATE statement, the cursor name must be of length 1.
Action: none
PLS-01711: A SELECT statement may not contain ORDER_BY, HAVING, or GROUP_BY clause
Cause: A SELECT statement may not contain ORDER_BY, HAVING, or GROUP_BY clause. Sect. 8.10.
Action: none
PLS-01712: ANSI does not allow bind variables as INDICATORS
Cause: ANSI does not allow bind variables as INDICATORS
Action: none
PLS-01713: The constraints on these types do not match
Cause: The constraints on these types do not match
Action: none
PLS-01714: ANSI expects a column name not a literal value here
Cause: ANSI expects a column name not a literal value here
Action: none
PLS-01900: : character to number conversion error
Cause: There was a failure while converting a character string into a numeric value.
Action: Verify that all character strings assigned to number variables have valid numeric value interpretations.
PLS-01901: : host bind array too small
Cause: PL/SQL was unable to transfer data into a host array because the array is too small.
Action: Increase the size of the host array.
PLS-01902: : hex to raw conversion error
Cause: There was a failure while converting a hexadecimal string to a raw.
Action: Verify that the hexadecimal variable to be converted contains a valid hexadecimal value.
PLS-01903: : non-integer error number
Cause: SQLERRM() was called with a non-integer value.
Action: Make sure SQLERRM() is called with an integer value.
PLS-01904: : NULL index table key value
Cause: An attempt was made to index into an index table with a NULL key value.
Action: Make sure key values used to index into index tables are non-NULL.
PLS-01905: : character string buffer too small
Cause: An error was encountered while moving a character string from a source to a destination. This error occurs if, for example, an attempt is made to move a a character string of 10 characters into a 1 character buffer. The cause of this error may not always be obvious. For example, the following will result in this error: a varchar2(1); b number; b := 10; a := b; An error results because an implicit conversion causes the number 10 to become the character string '10', which does not fit in the character buffer of 1 allocated for the variable a.
Action: First, look for character string assignment statements where the buffer size is mismatched. If there are none found, then consider the implicit conversion case illustrated in the example above.
PLS-01906: : raw variable length too long
Cause: The length of a raw variable being copied or assigned was too long to fit into its destination.
Action: Make sure the raw variable length is correct.
PLS-01907: : number precision too large
Cause: The number begin copied or assigned had too many digits to the left of the decimal and did not fit into its destination. In other words, there is a number precision mismatch. This error may also occur if, for example, an attempt is made to assign a character string to a number, as demonstrated below. a varchar2(4); b number(1,1); a := '10.1'; b := a;
Action: First, check explicit number precision value mismatches. If none are found, then consider implicit conversions of other types to numbers, including conversions performed during binds.
PLS-01908: : RETURNING INTO buffer too small
Cause: PL/SQL determined that a server side DML with a RETURNING INTO clause does not use a buffer that is large enough to hold the data being returned.
Action: Increase the size of the RETURNING INTO clause buffer.
PLS-01909: : cannot assign supertype instance to subtype
Cause: An attempt was made to assign or copy a supertype instance to a container (destination) that can only hold a subtype instance.
Action: Make sure the runtime type of the source of the assignment or copy is the same type as the destination or is a subtype of the destination type
PLS-01910: : associative array shape is not consistent with session parameters
Cause: NLS parameters affecting comparison of keys have been altered dynamically. The associative array's index is invalid.
Action: Avoid using associative arrays with string keys in applications which require frequent changes of NLS_COMP and/or NLS_SORT.
PLS-01911: : associative array key violates its type constraints
Cause: The key value of an element being inserted into an associative array violates the the key type constraints.
Action: Relax the constraints if the key value is meant to be acceptable. Otherwise, apply a valid key value when inserting an element.
PLS-01912: : instance must of be of type 'string'
Cause: The run-time type of the instance is not the declared type. e.g. If the return value of a user defined constructor is wrong.
Action: Return the correct type.
PLS-01913: : instance must of be of type 'string' or one of its subtypes
Cause: The run-time type of the instance is the not declared type or one of its subtypes. e.g. TREAT(supertype AS subtype) fails.
Action: Catch the exception.


36 PLW-05000 to PLW-07204

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

36 PLW-05000 to PLW-07204

PLW-05000: mismatch in NOCOPY qualification between specification and body
Cause: The indicated parameter was declared with the NOCOPY hint in the subprogram specification but not in the body, or it was declared with the NOCOPY hint in the body but not in the specification.
Action: Ensure that the specification and the body agree in their use of NOCOPY. If this mismatch is not corrected, the program will obey the declaration given in the specification, ignoring that in the body.
PLW-05001: previous use of 'string' (at line string) conflicts with this use
Cause: While looking for prior declarations of a variable or constant, the compiler found another object with the same name in the same scope. Or, the headers of subprogram in a package specification and body are not identical.
Action: Check the spelling of the variable or constant name. Also check the names of all parameters and exceptions declared in the same scope. Then, remove or rename the object with the duplicate name. Or, change the headers of the packaged subprogram in the package specification or body so that they are identical.
PLW-05003: same actual parameter(string and string) at IN and NOCOPY may have side effects
Cause: The indicated parameter was declared with the NOCOPY hint in the subprogram specification but not in the body, or it was declared with the NOCOPY hint in the body but not in the specification.
Action: Ensure that the specification and the body agree in their use of NOCOPY. If this mismatch is not corrected, the program will obey the declaration given in the specification, ignoring that in the body.
PLW-05004: identifier string is also declared in STANDARD or is a SQL builtin
Cause: The indicated identifier was also either: o) declared in package STANDARD, or o) a SQL builtin function, or o) a pseudo-column. This situation can result in name resolution issues since the STANDARD/builtin declaration will be chosen over the local declaration in SQL statements; however the local declaration will be chosen over the STANDARD/builtin declaration outside SQL scope. (See the documentation on PL/SQL name resolution.)
Action: Either: o) rename the given identifier, o) qualify any references to the identifier with the containing scope's name, or o) make sure the intended resolution occurs if using the identifier in SQL scope.
PLW-05005: function string returns without value at line string
Cause: The function exited without a return value. Return statements are required for all PL/SQL functions.
Action: Inspect the function source code for exit points, and place a return at each point so that no runtime error will be generated when the function exits.
PLW-06002: Unreachable code
Cause: Static program analysis determined that some code on the specified line would never be reached during execution. This may come as a result of expression evaluation at compile time.
Action: Inspect program logic for possible defects. Disable the warning if much code is made unreachable intentionally and the warning message is more annoying than helpful.
PLW-07202: bind type would result in conversion away from column type
Cause: The column type and the bind type do not exactly match. This will result in the column being converted to the type of the bind variable. This type conversion may prevent the SQL optimizer from using any index the column participates in. This may adversely affect the execution performance of this statement.
Action: To make use of any index for this column, make sure the bind type is the same type as the column type.
PLW-07203: parameter 'string' may benefit from use of the NOCOPY compiler hint
Cause: The mode of the specified parameter was IN OUT or OUT. Use of the NOCOPY compiler hint may speed up calls to this subprogram.
Action: Change the mode of the parameter to explicitly use the NOCOPY compiler hint. For example, if your subprogram declaration is: PROCEDURE proc(p1 IN OUT CLOB); you can change it to: PROCEDURE proc(p1 IN OUT NOCOPY clob); to get the benefit of the NOCOPY hint. For member procedures or functions in object types, you may have to explicitly declare the SELF parameter as illustrated in the following: MEMBER PROCEDURE proc(SELF IN OUT NOCOPY MY_TYPE);
PLW-07204: conversion away from column type may result in sub-optimal query plan
Cause: The column type and the bind type do not exactly match. This may result in the column being converted to the type of the bind variable. This type conversion may prevent the SQL optimizer from using any index the column participates in. This may adversely affect the execution performance of this statement.
Action: To make use of any index for this column, make sure the bind type is the same type as the column type.


37 AMD-00100 to AMD-00160

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

37 AMD-00100 to AMD-00160

AMD-00100: not found: string "string"
Cause: A metadata entity could not be found in the OLAP Catalog.
Action: Check that the metadata entity name and owner are properly specified. Refer to the OLAP Catalog union views named with the OLAP2U prefix) for existing OLAP metadata entity names.
AMD-00101: cannot create string "string"; metadata entity already exists
Cause: A metadata entity could not be created, because it already exists in the OLAP Catalog.
Action: When creating a new metadata entity, specify an entity name that is unique for the entity owner. Refer to the OLAP Catalog union views (named with the OLAP2U prefix) for existing OLAP metadata entity names.
AMD-00102: invalid metadata entity: string "string"
Cause: An OLAP metadata entity was found to be invalid.
Action: Check the mapping to columns in your data warehouse tables or views.
AMD-00103: %s "string" does not have a string
Cause: A required child entity was not found for a metadata entity.
Action: Refer to the Oracle9i OLAP User's Guide to determine which metadata entities require dependent entities.
AMD-00104: Level "string" cannot be added to the hierarchy; parent and child parameters represent the same level
Cause: The same level name was specified for both the parent and the child parameters of the ADD_LEVEL_TO_HIERARCHY procedure.
Action: Determine which level should be the parent of the new level being added to the hierarchy. Specify the parent in the parent parameter and the new level in the child parameter of the ADD_LEVEL_TO_HIERARCHY procedure. Re-run the procedure.
AMD-00105: Level "string" cannot be added to the hierarchy; the specified parent level "string" is already the parent of "string"
Cause: The level specified as the parent in the ADD_LEVEL_TO_HIERARCHY procedure could not be used, because it was the parent of another level within the hierarchy.
Action: In the ADD_LEVEL_TO_HIERARCHY procedure, specify a parent that is not already a parent of another level within a hierarchy.
AMD-00106: parent string "string" must be removed before child string "string" can be removed
Cause: A metadata entity could not be removed, because it was the child of another metadata entity.
Action: Remove the parent metadata entity. All the dependent entities will be removed with the parent.
AMD-00107: no root level in hierarchy: "string"
Cause: A hierarchy was found to have no root level.
Action: Use the ADD_LEVEL_TO_HIERARCHY procedure to add a level to the hierarchy. Specify the root level in the child parameter and leave the parent parameter blank.
AMD-00108: Dimension "string" is improperly mapped; the dimension has string hierarchies mapped, but hierarchy level "string" has string columns mapped
Cause: Dimension table columns could not be accessed, because dimension hierarchies were incorrectly mapped.
Action: Add or remove dimension hierarchies or hierarchy level mappings. The number of dimension hierarchies must equal the number of hierarchy level columns.
AMD-00109: Parent metadata entity has too many child entities. string "string" has more than string string
Cause: A metadata entity was found to have too many dependent entities of another type.
Action: Add the required mapping.
AMD-00110: parameter string of "string" not valid
Cause: A parameter was found to be invalid.
Action: Ensure that the parameter is correctly formed and valid.
AMD-00111: PROCEDURE string, invalid directory: "string"
Cause: Directory name provided to a procedure was found to be invalid.
Action: Ensure that the directory name represents a valid directory.
AMD-00112: PROCEDURE string, invalid mode
Cause: UTL_FILE.INVALID_MODE: An error occurred when accessing a file.
Action: Check that files being accessed have correct permissions, then retry.
AMD-00113: PROCEDURE string, invalid operation
Cause: UTL_FILE.INVALID_OPERATION: An error occurred when accessing a file.
Action: Check that the file being accessed is not already opened by another program, then retry.
AMD-00114: PROCEDURE string, internal error
Cause: UTL_FILE.INTERNAL_ERROR: Possible hardware or software problem when accessing a file.
Action: Verify that hardware is functioning normally, then retry. Contact Oracle Support Services if needed.
AMD-00115: PROCEDURE string, invalid file handle
Cause: UTL_FILE.INVALID_FILEHANDLE: Possible software or hardware problem when accessing a file.
Action: Verify that hardware is functioning normally, then retry. Contact Oracle Support Services if needed.
AMD-00116: PROCEDURE string, read error
Cause: UTL_FILE.READ_ERROR: Possible software or hardware problem when accessing a file.
Action: Verify that hardware is functioning normally, then retry. Contact Oracle Support Services if needed.
AMD-00117: input file "string" not found
Cause: The input text file was not found in the specified location.
Action: Copy the input text file to the specified location, then retry.
AMD-00118: output file "string" already exists
Cause: The output file already exists in the specified location.
Action: Delete or rename the file, then retry.
AMD-00119: analytic workspace dimensions not specified in input
Cause: Either the input text file or the input string did not specify an analytic workspace dimension.
Action: Add one or more dimensions to the input text file or the input string. At least one dimension is required.
AMD-00120: dimension #string: analytic workspace dimension name not specified
Cause: Dimension name was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing dimension name.
AMD-00121: dimension #string: analytic workspace hierarchy not specified
Cause: Hierarchy for this dimension was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing hierarchy.
AMD-00122: dimension #string: analytic workspace hierarchy dimension not specified
Cause: Hierarchy dimension for this dimension was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing hierarchy dimension.
AMD-00123: dimension #string: analytic workspace hierarchy dimension value not specified
Cause: Hierarchy dimension value for this dimension was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing hierarchy dimension value.
AMD-00124: dimension #string: analytic workspace GID variable not specified
Cause: Analytic workspace GID variable for this dimension was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing Analytic Workspace GID variable.
AMD-00125: dimension #string: analytic workspace column level dimension not specified
Cause: Analytic workspace column level dimension for this dimension was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing analytic workspace column level dimension.
AMD-00126: dimension #string: analytic workspace column level relation not specified
Cause: Analytic workspace column level relation for this dimension was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing analytic workspace column level dimension.
AMD-00127: dimension #string: RDBMS dimension column not specified
Cause: RDBMS dimension column for this dimension was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing RDBMS dimension column.
AMD-00128: dimension #string: RDBMS parent column not specified
Cause: RDBMS parent column for this dimension was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing RDBMS parent column.
AMD-00129: dimension #string: RDBMS GID column not specified
Cause: RDBMS GID column for this dimension was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing RDBMS GID column.
AMD-00130: dimension #string: RDBMS dimension column data type not specified
Cause: RDBMS dimension column data type for this dimension was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing RDBMS dimension column data type.
AMD-00131: dimension #string: RDBMS parent column data type not specified
Cause: RDBMS dimension column data type for this dimension was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing RDBMS dimension column data type.
AMD-00132: dimension #string: RDBMS GID column data type not specified
Cause: RDBMS dimension column data type for this dimension was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing RDBMS dimension column data type.
AMD-00133: measure #string: analytic workspace measure name not specified
Cause: Analytic workspace measure name for this measure was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing analytic workspace measure name.
AMD-00134: measure #string: RDBMS measure column name not specified
Cause: RDBMS measure column name for this measure was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing RDBMS measure column name.
AMD-00135: measure #string: RDBMS measure column data type not specified
Cause: RDBMS measure column data type for this measure was not specified in either the input text file or the input string.
Action: Modify the input text file or the input string to include the missing RDBMS measure column data type.
AMD-00136: Generation of SQL script "string" failed
Cause: There was a program error or a system resource limit was exceeded.
Action: Verify that sufficient system resources are available, then retry.
AMD-00137: prefix "string" exceeds maximum permitted length of string characters
Cause: A prefix supplied to an API call was too long.
Action: Change the prefix so that it is within the permitted length, then re-issue the API call.
AMD-00138: level names parameter not null or defaulted
Cause: Level names were provided to the LEVELS_LIST parameter, but the LEVELS parameter did not specify the number of levels.
Action: Either set the LEVELS_LIST parameter to null (the default) or set the LEVELS parameter to the number of levels.
AMD-00139: level names parameter not valid
Cause: The number of names in the LEVELS_LIST parameter did not equal the number specified by the LEVELS parameter.
Action: Ensure that the LEVELS_LIST parameter is correctly formed and that it holds the number of names specified by the LEVELS parameter.
AMD-00140: internal error: [string] [string] [string] [string] [string]
Cause: This is an internal error.
Action: Contact Oracle Support Services.
AMD-00141: parameter string of "string" not valid starting around "string"
Cause: A parameter was found to be invalid.
Action: Ensure that the parameter is correctly formed and valid.
AMD-00142: Analytic Workspace name "string" must be fully qualified with the Owner.
Cause: A parameter was found to be invalid.
Action: Ensure that the parameter is correctly formed and valid. For example, SCOTT.EMP is a fully qualified name.
AMD-00143: View name "string" must be fully qualified with the Owner.
Cause: A parameter was found to be invalid.
Action: Ensure that the parameter is correctly formed and valid. For example, SCOTT.EMP is a fully qualified name.
AMD-00144: Custom Measure "string" does not exist in Workspace "string"
Cause: A required object does not exist in specified Workspace.
Action: Ensure that the parameter is correctly formed and valid.
AMD-00145: error attaching Workspace "string" in mode "string"
Cause: Either the Workspace does not exist, is already attached in a different mode, or there are insufficient system resources to attach Workspace.
Action: Ensure that workspace name is correct and can be currently attached in the specified mode.
AMD-00146: Custom Measure "string" already exists in Workspace "string"
Cause: You have attempted to create a Custom Measure when it already exists.
Action: Ensure that the Custom Measure name is correct and does not already exist in the specified Workspace.
AMD-00147: invalid Custom Measure creation mode "string" specified
Cause: Custom Measure creation mode must be "PERMANENT" or "TEMPORARY."
Action: Ensure that the Custom Measure creation mode is correct.
AMD-00148: Workspace "string" is not currently open. No update done.
Cause: The Workspace must be attached before a Custom Measure can be updated.
Action: Attach Workspace first before attempting to modify Custom Measure.
AMD-00149: Custom Measure to delete "string" does not exist in Workspace "string"
Cause: The Custom Measure does not exist in specified Workspace.
Action: Ensure that the Custom Measure name is correct and exists in specified Workspace.
AMD-00150: Custom Measure to delete "string" not mapped to View "string"
Cause: The Custom Measure to delete is not mapped to the View specified.
Action: Ensure that the Custom Measure and View Name name are correct, and mapped to each other.
AMD-00151: Creation of Custom Measure "string" in Workspace "string" failed
Cause: Invalid parameters were supplied, or a program error occured.
Action: Ensure that API parameters are correct and sufficient system resources are available.
AMD-00152: Workspace "string" is not currently open.
Cause: The Workspace must be attached before an operation can be performed on it.
Action: Attach the Workspace first before attempting operation.
AMD-00153: error detaching workspace "string"
Cause: The Workspace was not attached or a program error occured.
Action: Ensure the Workspace name is correct and it is attached in the current session.
AMD-00154: Cannot delete session object "string" in Workspace "string"
Cause: You cannot delete a session object. These are deleted automatically when the session is ended.
Action: Ensure that API parameters are correct.
AMD-00155: Object to delete "string" does not exist in Workspace "string"
Cause: The Object slated for deletion does not exist in the Workspace specified.
Action: Ensure that API parameters are correct.
AMD-00156: formula "string" to modify does not exist in Workspace "string"
Cause: Formula does not exist in Workspace specified.
Action: Ensure that API parameters are correct.
AMD-00157: invalid attach mode "string" specified when attempting to attach Workspace "string"
Cause: An invalid parameter supplied.
Action: Attach mode must be "RO" (read only) or "RW" (read/write).
AMD-00158: The Workspace "string" is currently open in read-only mode.
Cause: An invalid parameter was supplied. You may not specify an operation which requires an update when the Workspace is open in read-only mode.
Action: The Creation Mode parameter must be "TEMPORARY" for a Workspace open in read-only mode.
AMD-00159: The Workspace "string" is currently attached in read/write mode.
Cause: An invalid parameter was supplied.
Action: The Creation Mode parameter must be "PERMANENT" for a Workspace open in read/write mode.
AMD-00160: Warning! Exceeded maximum Custom Measure number of "string"
Cause: The system limit has been reached.
Action: Old Custom Measures created against the specified View have to be deleted before new Custom Measures can be created.


38 CLSR-00001 to CLSR-06507

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

38 CLSR-00001 to CLSR-06507

CLSR-00001: Oracle error number encountered
Cause: Oracle-related error is encountered.
Action: Check alert log and trace file for more detail.
CLSR-00002: Oracle error encountered while executing string
Cause: Oracle-related error is encountered while executing a request.
Action: Check alert log for more detail.
CLSR-00003: ORACLE_HOME environment variable not set
Cause: ORACLE_HOME environment variable is not set.
Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported.
CLSR-00004: Error encountered at string, category=number, operation=string, OS error=number
Cause: Operating system error occurred.
Action: Check for the error message for more detail.
CLSR-00005: Error encountered during memory allocation
Cause: System memory is insufficient.
Action: Check the availability of memory in the system before retrying.
CLSR-00006: Error encountered when writing file string
Cause: Error when writing file.
Action: Check the permission of the file and the existence of its path.
CLSR-00007: Error encountered when reading file string
Cause: Error when reading file.
Action: Check the permission and existence of the file.
CLSR-00501: Error number encountered when connecting to EVM daemon
Cause: Error encountered when connecting to EVM daemon.
Action: Check status of EVM daemon and log file for detail.
CLSR-00502: Error number encountered when subscribing an EVM event
Cause: Error encountered when subscribing an EVM event.
Action: Contact customer support.
CLSR-00503: Error number encountered when creating an EVM event
Cause: Error encountered when creating an EVM event.
Action: Contact customer support.
CLSR-00504: Error number encountered when posting an EVM event
Cause: Error encountered when posting an EVM event.
Action: Contact customer support.
CLSR-00505: Empty event type is specified
Cause: Empty event type is specified.
Action: Try again with a valid event type.
CLSR-00506: Unmatched resource name prefix string is specified
Cause: Specified resource name prefix does not match as required.
Action: Try again with a valid resource name prefix.
CLSR-00507: The length of the facility name string exceeds the limit (number)
Cause: The given facility name is too long.
Action: Try again with a short facility name.
CLSR-00508: Invalid message number number
Cause: An incorrect message number is specified.
Action: Try again with a correct message number.
CLSR-00509: Unable to initialize NLS
Cause: Failed to initialize callback structure for NLS.
Action: Contact customer support.
CLSR-00510: Unable to load NLS data
Cause: Failed to initialize NLS data loading.
Action: Not action required as default data loading will be used.
CLSR-00511: Error number encountered when handling incoming EVM message
Cause: Error encountered when handling incoming EVM message.
Action: Check log file for detail.
CLSR-00512: Invalid CAA trigger event type [string]
Cause: Invalid CAA trigger event type is specified.
Action: Try again with a valid type.
CLSR-00513: Message file is not found
Cause: The requested OCI message file is not found.
Action: Check if the message file is properly installed.
CLSR-00514: Unable to locate PMON [pid=string]
Cause: Cannot find PMON with this pid.
Action: Check the existence of PMON.
CLSR-00515: A service member is already running on this node
Cause: There is a service member of the same service running on this node.
Action: No action required as the service member will try to start on another node.
CLSR-00516: No service provider found at this node
Cause: No suitable service provider is found on this node.
Action: No action required as the service member will try to start on another node.
CLSR-00517: Failed to register a service name
Cause: The requested service name cannot be registered.
Action: Check log file for detail.
CLSR-00518: Failed to register a preconnect service name
Cause: The requested preconnect service name cannot be registered.
Action: Check log file for detail.
CLSR-00519: No instance found
Cause: No instance is found running for the database resource.
Action: No action required as the database resource will fail itself.
CLSR-00520: No service member found
Cause: No service member is found running for the composite service resource.
Action: No action required as the composite service resource will fail itself.
CLSR-00521: Event string is rejected by EVM daemon
Cause: No template has been registered for the event or caller is not authorized to post the event.
Action: Check if there is a template registered for this event and the authority of posting this event.
CLSR-00522: Resource string is not registered
Cause: CRS resource is not registered.
Action: Register the CRS resource.
CLSR-00523: Resource string is not enabled
Cause: CRS resource is not enabled.
Action: Enable the CRS resource.
CLSR-00524: Resource string is stopping, resource string cannot start
Cause: Resource cannot start because its composite resource is stopping.
Action: Retry to start the resource when its composite resource is not stopping.
CLSR-00525: prsr initialization failed
Cause: See the related error message.
Action: Run crs_stat to make sure CSS and OCR working properly.
CLSR-00526: Failed to retrieve database configuration in OCR
Cause: See the related error message.
Action: Run crs_stat to make sure CSS and OCR working properly and database configuration in ocr is initialized.
CLSR-00527: OCR operation failed
Cause: See related error messages about the OCR operation.
Action: Fix the related error. Then try again.
CLSR-00528: RACGONS: host and port number already configured in OCR
Cause: host and port number already configured in OCR.
Action: None.
CLSR-00529: RACGONS: host and port number to be removed does not exist
Cause: host and port number to be removed is not configured in OCR.
Action: None.
CLSR-00530: Can not get user name
Cause: Error caused by OSD layer.
Action: Contact Oracle support.
CLSR-00531: Can not get primary group name
Cause: There is no primary group for this OS.
Action: Not faital. None.
CLSR-01001: Unsupported open mode number is specified
Cause: Unsupported open mode is specified for mounting database.
Action: Retry again with a valid open mode.
CLSR-01002: Unable to process instance startup
Cause: ORACLE_HOME environment variable not set.
Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported.
CLSR-01003: Error number encountered during mounting database
Cause: Unexpected error occurs when mounting database.
Action: Check current status of database before retrying.
CLSR-01004: Failed to mount database
Cause: Database cannot be mounted by an instance.
Action: Check alert log for error detail.
CLSR-01005: Error number encountered during altering database open mode
Cause: Unexpected error occurs when altering database open mode.
Action: Check current database status.
CLSR-01006: Unable to process instance shutdown
Cause: ORACLE_HOME environment variable not set.
Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported.
CLSR-01007: Connection to database was not established
Cause: Connection to database is failed to establish.
Action: Make sure connection and environment are properly set up.
CLSR-01008: Error number encountered during querying for PMON status
Cause: Unexpected error encountered when querying v$process for PMON.
Action: Check alert log and connection to database.
CLSR-01009: database management module failed to start
Cause: Error encountered during initializing database management module.
Action: Check previous error message for detail.
CLSR-01010: Unable to record PMON pid to string
Cause: Failed to write os pid for PMON to file.
Action: Check file system for disk space and access privilege.
CLSR-01011: Invalid instance startup mode [string] is specified
Cause: Invalid startup mode is specified.
Action: Retry again with a valid startup mode.
CLSR-01012: Invalid instance stop mode [string] is specified
Cause: Invalid stop mode is specified.
Action: Retry again with a vaild stop mode.
CLSR-06500: Invalid input arguments
Cause: Invalid input arguments are specified.
Action: Retry again with a valid argument.
CLSR-06501: Exceeds maximum number of arguments
Cause: Too many input arguments are specified.
Action: Retry again with correct number of arguments.
CLSR-06502: Failed to connect to database
Cause: Failed to connect to database.
Action: Check database and log file for details.
CLSR-06503: Service name already registered
Cause: Requested service name has been registered by another service.
Action: Choose another service name and retry registration again.
CLSR-06504: Service name not in SERVICE_NAMES
Cause: Requested service name is not registered.
Action: Make sure the correct service name is specified in the request.
CLSR-06505: SERVICE_NAMES found null and fixed
Cause: SERVICE_NAMES parameter becomes null after the delete operation.
Action: Not action required as SERVICE_NAMES is set to default value.
CLSR-06506: Error number encountered when executing string
Cause: Error occurred when executing the SQL statement.
Action: Check alert log for more detail.
CLSR-06507: Cannot add to SERVICE_NAMES, SERVICE_NAMES will be too long
Cause: Adding the service name will exceed the limit of SERVICE_NAMES.
Action: Change the configuration to avoid SERVICE_NAMES becomes too long.


39 CLSS-00001 to CLSS-03202

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

39 CLSS-00001 to CLSS-03202

CLSS-00001: skgxn not active
Cause: The skgxn service is required, but is not active
Action: Verify that the clusterware skgxn is active and restart it if necessary
CLSS-00002: unable to determine local node number. type string
Cause: Either the skgxn service is unavailable, or the OCR configuration is incomplete/inaccurate.
Action: Verify that the clusterware skgxn is active and restart it if necessary. Additionally validate that the clusterware installation was successful, and that the local node was entered in the node listings.
CLSS-00003: unable to determine cluster name. type string
Cause: Name of the cluster cannot be determined from configuration.
Action: Verify that the clusterware installation was successful and that the OCR registry is available.
CLSS-00004: unable to allocate memory resources
Cause: Memory allocation routines failed.
Action: Validate that the system has sufficient memory resources to use the product.
CLSS-00099: logfile open failed for string, err string
Cause: The log file could not be opened, with error type err
Action: Verify that the log directory specified during installation exists and that the ocssd executable has permission to create a file in that directory
CLSS-00100: configuration data access failed for key string
Cause: Access of the configuration data indicated by key failed with error code error
Action: Verify that the clusterware installation was successful and that the OCR registry is accessible
CLSS-00101: Oracle Cluster Repository mismatch with node string. (string != string)
Cause: A remote node is accessing a different set of configuration. This situation can be caused by attempting to reinstall while there are active cluster nodes.
Action: Verify that the local and remote nodes are accessing the same Oracle Cluster Repository.
CLSS-00102: initialization failure: [string] [string] [string] [string] [string] [string]
Cause: A general initialization failure occurred.
Action: Contact Oracle Customer Service for more information.
CLSS-00103: unable to read configuration information for node string
Cause: Incomplete configuration information for the specified node was found.
Action: Validate the integrity of the Oracle Cluster Repository, restoring it from backup if necessary.
CLSS-00200: local node string not listed in configuration
Cause: The OCR configuration information does not list this node as a member of the cluster
Action: Verify that the clusterware installation was successful and that the node has not been added since installation
CLSS-01200: skgxn errror: category string, operation string, loc string
Cause: The skgxn service encountered an error, the information in the error message is vendor supplied diagnostic information
Action: Report this error to the vendor who supplied the skgxn
CLSS-02000: reconfiguration successful, incarnation string with string nodes
Cause: A rconfiguration has completed successfully
Action: None
CLSS-02001: local node number string, master node number string
Cause: Informational message regarding this incarnation
Action: None
CLSS-02200: Received node deletion request for active node string.
Cause: User attempted to delete a node from the configuration before shutting it down.
Action: Shut down the specified node and retry the node deletion.
CLSS-02201: endpoint already in use: string
Cause: The specified endpoint is already in use. Another process is using the endpoint.
Action: Shut down the other process, and retry the startup attempt.
CLSS-02202: voting device access took an excessive amount of time. (string sec)
Cause: A read or write to the voting device took an unacceptable amount of time.
Action: Contact the disk hardware vendor for information on improving the availability of the disk.
CLSS-02203: unable to access voting device: string
Cause: The CSS daemon received a failure using the voting device.
Action: Examine the permissions on the voting device. If this failure occurred later than boot time, then access to the voting device was lost.
CLSS-02204: voting device not configured. [string] [string]
Cause: A voting device was not supplied during configuration.
Action: The voting device assists in ensuring data integrity and is required by the CSS daemon. Configure a voting device and restart the cluster.
CLSS-02205: remote node string signaled our eviction via voting device: cause string
Cause: A remote node of the cluster evicted the local node due to network failure or due to software failure in the local CSS daemon.
Action: Verify the stability of the private network between the local node and the specified remote node.
CLSS-02206: local node evicted by vendor node monitor
Cause: The Operating System vendor's node monitor evicted the local node.
Action: Examine the vendor node monitor's logs for relevant information.
CLSS-02207: error string getting status from vendor node monitor
Cause: The CSS daemon received a failure interacting with the vendor node monitor. The local node may have been evicted or the vendor node monitor may have been shut down.
Action: Examine the vendor node monitor's logs for relevant information.
CLSS-03000: reconfiguration successful, incarnation string with string nodes
Cause: A rconfiguration has completed successfully
Action: None
CLSS-03001: local node number string, master node number string
Cause: Informational message regarding this incarnation
Action: None
CLSS-03200: timed out waiting on nested reconfiguration
Cause: The current reconfiguration hung. A network failure may have \ occurred.
Action: The local node will terminate itself to cause remote nodes to enter a nested reconfiguration. This may allow the cluster to continue operation.
CLSS-03201: An attempt to begin a nested reconfiguration failed.
Cause: unable to cancel previous reconfiguration to begin a new one
Action: None.
CLSS-03202: out of sync with master: [string] [string] [string] [string]
Cause: Consistency checks between the local node and the master failed.
Action: The local daemon will terminate itself to ensure that the surviving cluster is all properly coordinated.


40 PROC-00001 to PROC-00106

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

40 PROC-00001 to PROC-00106

PROC-00001: Oracle Cluster Registry cannot be initialized.
Cause: An invalid init level was passed to initialize Oracle Cluster Registry.
Action: Initialize Oracle Cluster Registry with a valid init level.
PROC-00002: Cannot perform cluster registry operation at the current init level.
Cause: Program tried a cluster registry operation which is not permitted at the init level.
Action: Initialize Oracle Cluster Registry with an appropriate init level.
PROC-00003: Cannot perform cluster registry operation because context is invalid.
Cause: The Oracle Cluster Registry context passed was invalid.
Action: Intialize Oracle Cluster Registry and retry the operation.
PROC-00004: The cluster registry key to be operated on does not exist.
Cause: Program tried a cluster registry operation on a key which does not exist.
Action: Check to see if the key exists and try the operation again.
PROC-00005: User does not have permission to perform a cluster registry operation on this key.
Cause: Program tried an operation on a cluster registry key for which it does not have permission.
Action: Check to see if program is run as the correct user.
PROC-00006: User does not have permission to perform a cluster registry operation on this key.
Cause: Program tried a cluster registry operation on a key for which it does not have permission.
Action: Check to see if program is run as the correct user.
PROC-00007: Cannot perform cluster registry operation because key handle is invalid.
Cause: The cluster registry key handle passed was invalid.
Action: Open the cluster registry key again, and retry the operation.
PROC-00008: Cannot perform cluster registry operation because one of the parameters is invalid.
Cause: Program tried a cluster registry operation using an invalid parameter.
Action: Check the parameters, and retry the operation.
PROC-00009: Cannot perform cluster registry operation because the buffer passed is too small.
Cause: The amount of memory allocated for the buffer was insufficent.
Action: Allocate sufficient memory, and retry the operation.
PROC-00010: Cannot delete the cluster registry key as subkeys exist.
Cause: The program tried to delete a key for which subkeys exist.
Action: retry the operation with the recurse flag set to TRUE.
PROC-00011: Cannot perform cluster registry operation because key is NULL.
Cause: The cluster registry key passed was NULL.
Action: Retry the operation with a valid keyname.
PROC-00012: Out of heap memory.
Cause: The program ran out of heap memory.
Action: Contact Oracle Custmoer Support.
PROC-00013: Cannot perform cluster registry operation because one of the parameters is NULL.
Cause: Program tried a cluster registry operation using an NULL parameter.
Action: Check the parameters, and retry the operation.
PROC-00014: Unknown error occurred
Cause: This is generic internal error for Oracle Cluster Registry.
Action: Contact Oracle Customer Support.
PROC-00015: Failed to initialize the cluster registry successfully
Cause: There are the following possible causes: The backend is not reachable. This could happen if the permissions are not set correctly for a shared device backend. CSS could not be contacted because of communication failure. This could happen if the cluster registry was never initialized at PROCR_INSTALL_LEVEL and one tried to initialize it at other OCR levels.
Action: Make sure that cluster registry was initialized properly. Make sure that the clusterware is working.
PROC-00016: Cannot retrieve any more subkeys for the given keyhandle
Cause: The key has no more subkeys to enumerate.
Action: Call procr_close_key on the key and then procr_open_key again followed by procr_enumerate_key call.
PROC-00017: Unimplemented feature
Cause: Requested feature has not been implemented in the current release.
Action: Try the feature again in the upcoming Oracle release.
PROC-00018: The value size passed is too large
Cause: Cannot set a value of the given size.
Action: Pass a smaller value size to procr_set_value API.
PROC-00019: Cannot create more subkeys for the key
Cause: An attempt was made to create more subkeys under a key that is not permitted by the cluster registry.
Action: Delete some subkeys before creating new subkeys under the key.
PROC-00020: ORACLE_HOME environment not set
Cause: ORACLE_HOME environment not set.
Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported.
PROC-00021: Maximum permitted depth of the OCR tree is reached
Cause: An attempt was made to create subkeys under a key which is already at depth PROCR_MAX_KEY_DEPTH
Action: Create the key under some other key.
PROC-00022: The OCR backend has an invalid format
Cause: An attempt was made to use OCR before initializing it.
Action: Use 'srvconfig -init -f' to initialize OCR.
PROC-00023: Error in cluster services layer
Cause: An error occurred in the cluster services layer while performing a cluster registry operation.
Action: Contact Oracle Customer Support.
PROC-00024: Error in the messaging layer
Cause: An error occurred in the messaging layer while performing a cluster registry operation.
Action: Contact Oracle Customer Support.
PROC-00025: Error in the NLS services
Cause: An error occurred in the NLS services while performing a cluster registry operation.
Action: Contact Oracle Customer Support.
PROC-00026: Error while accessing the physical storage
Cause: An error occurred while accessing the physical storage of the cluster registry
Action: Check that the storage has the correct permissions.
PROC-00027: Error in authentication layer
Cause: An error occurred in the authentication layer while performing a cluster registry operation.
Action: Contact Oracle Customer Support.
PROC-00028: Oracle Cluster Registry already in current version
Cause: An attempt to upgrade the cluster registry which has already been upgraded.
Action: No action required.
PROC-00029: Error in logging layer
Cause: An error occurred in the logging layer while performing a cluster registry operation.
Action: Contact Oracle Customer Support.
PROC-00030: Oracle Cluster Registry IDs do not match
Cause: The cluster registry storage seen by the client was not the same as the one seen by the server. This may be caused by a misconfiguration.
Action: Contact Oracle Customer Support.
PROC-00031: Storage device for the cluster registry is too small
Cause: The configured storage device for cluster registry was too small.
Action: Please follow the documentation and configure a storage device that is large enough for use by cluster registry.
PROC-00032: Cluster Ready Services on the local node is not running
Cause: Cluster Ready Services daemon on the local node was not running
Action: Please bring up the Cluster Ready Services on the local node.
PROC-00101: Operating System error [string]
Cause: An error occurred in the operating system layer while performing a cluster registry operation
Action: Contact Oracle customer support.
PROC-00102: Cluster services error
Cause: An error occurred in the cluster services layer while performing a cluster registry operation.
Action: Contact Oracle customer support.
PROC-00103: Messaging error
Cause: An error occurred in the messaging layer while performing a cluster registry operation.
Action: Contact Oracle customer support.
PROC-00104: Authentication error
Cause: An error occurred in the authentication layer while performing a cluster registry operation.
Action: Contact Oracle customer support.
PROC-00105: Logging error
Cause: An error occurred in the logging layer while while performing a cluster registry operation.
Action: Contact Oracle customer support.
PROC-00106: Unidentified component error
Cause: An error occurred in an unidentified layer while performing a cluster registry operation.
Action: Contact Oracle customer support.


41 PROT-00001 to PROT-00807

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

41 PROT-00001 to PROT-00807

PROT-00001: Failed to initialize ocrconfig
Cause: Unable to initialize and start ocrconfig
Action: Check log file for details about the failure
PROT-00002: Export file already exists
Cause: Requested export file exists in the given path
Action: Change the location for export file or remove the old export file
PROT-00003: Failed to create export file
Cause: Unable to create or open file for exporting cluster registry data
Action: Check access privilege or disk space of the requested path
PROT-00004: Failed to retrieve data from the cluster registry
Cause: Unable to retrieve necessary information from the cluster registry
Action: Check the availability of the cluster registry and the details of the failure from the log file
PROT-00005: Clusterware is not running properly
Cause: Unable to register with clusterware for access to the cluster registry
Action: Check the status of clusterware running on the machine
PROT-00006: The specified import file cannot be found
Cause: The import file does not exist
Action: Check the file and its correct path and try again
PROT-00007: Failed to open the specified import file
Cause: Unable to access the specified import file
Action: Check access privilege of the import file
PROT-00008: Failed to import data from specified file to the cluster registry
Cause: Unable to read data from the import file and import to the cluster registry
Action: Check availability of the cluster registry and the details of the failure from the log file
PROT-00009: Failed to open the specified import file
Cause: Unable to access the specified import file
Action: Check access privilege of the import file
PROT-00010: Failed to open the specified source cluster registry
Cause: Unable to access the specified source cluster registry
Action: Check access privilege and location of the source cluster registry, and the log file for more detail
PROT-00011: Failed to open the specified destination cluster registry
Cause: Unable to access the specified destination cluster registry
Action: Check access privilege and location of the destination cluster registry. Also check the log file for more details
PROT-00012: Oracle Cluster Registry to be upgraded has an unsupported version
Cause: Oracle Cluster Registry to be upgraded has an unsupported version
Action: Upgrade Oracle Cluster Registry to a version supported
PROT-00013: Oracle Cluster Registry is in current version
Cause: Oracle Cluster Registry is in current version
Action: No action required
PROT-00014: Oracle Cluster Registry to be downgraded has an earlier version
Cause: Oracle Cluster Registry to be downgraded has an earlier version
Action: No action required
PROT-00015: Unimplemented feature
Cause: Requested feature has not been implemented in current release
Action: Try the feature again in the next release.
PROT-00016: Internal Error
Cause: This is a generic internal error for ocrconfig
Action: Contact Oracle Customer Support
PROT-00017: Fatal Error
Cause: This is a generic fatal error for ocrconfig
Action: Contact Oracle Customer Support
PROT-00018: Failed to open file
Cause: File does not exist or user does not have permission to open the file
Action: Try with a different file name
PROT-00114: Please ensure you have file creation privileges in the executing directory before running this tool.
Cause: ocrconfig called with incorrect or missing options
Action: Use ocrconfig with correct options
PROT-00301: Dump is not feasible when clusterware is running
Cause: Unable to dump cluster registry data when clusterware is running
Action: Stop the clusterware before retrying ocrdump
PROT-00302: Failed to initialize ocrdump
Cause: Unable to initialize and start ocrdump
Action: Check log file for details about the failure
PROT-00303: Dump file already exists
Cause: Requested dump file exists in the given path
Action: Change the location for the dump file or remove the old dump file
PROT-00304: Failed to create dump file
Cause: Unable to create or open file for dumping cluster registry data
Action: Check access privilege or disk space of the requested path
PROT-00410: Please ensure you have file creation privileges in the executing directory before running this tool.
Cause: ocrdump called with incorrect or missing options
Action: Use ocrdump with correct options
PROT-00601: Failed to initialize ocrcheck
Cause: Unable to initialize and start ocrcheck
Action: Check log file for details about the failure
PROT-00707: Cluster registry integrity check failed
Cause: ocrcheck called
Action: None
PROT-00807: Please ensure you have file creation privileges in the executing directory before running this tool.
Cause: ocrcheck called with incorrect or missing options
Action: Use ocrcheck with correct options


42 TNS-00000 to TNS-12699

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

42 TNS-00000 to TNS-12699

TNS-00000: Not An Error
Cause: Everything is working as it should.
Action: Don't worry: Be happy.
TNS-00001: INTCTL: error while getting command line from the terminal
Cause: Improper standard input connection from the terminal.
Action: Normally not visible to the user. Start the INTCTL program again. If error persists, contact Oracle Customer Support.
TNS-00002: INTCTL: error while starting the Interchange
Cause: of the problem. Be sure to turn tracing off when the problem has been rectified.
Action: Check the Interchange configuration files (INTCHG.ORA, TNSNET.ORA and TNSNAV.ORA) for errors and confirm that no other programs are using the ADDRESS(es) specified. If error continues, turn on tracing in the Interchange components and examine the trace files to determine the
TNS-00003: INTCTL: error while sending request to the Interchange
Cause: Improper command sent to the Interchange or the Interchange is not responding. Not normally visible to the user.
Action: Verify that the command sent to the Interchange is valid. Also check that the Interchange is running by using the INTCTL STATUS command. If necessary, start the Interchange using the INTCTL START command.
TNS-00004: INTCTL: error while starting the Navigator
Cause: The Navigator could not be started.
Action: Check to make sure that executables for the Navigator (navgatr) are present in the ORACLE executable directory on your platform. Check the configuration files TNSNET.ORA and TNSNAV.ORA for errors. If error continues, turn on tracing in the Interchange components and examine the trace files to determine the cause of the problem. Be sure to turn tracing off when the problem has been rectified.
TNS-00005: INTCTL: error while sending request to the Navigator
Cause: The Navigator is not responding. Either the Navigator is not running or another process is responding.
Action: Check that the Navigator is running by using the STATUS command of the Interchange Control Utility. Verify that the correct addresses are listed in the TNSNAMES.ORA, TNSNET.ORA, and TNSNAV.ORA configuration files.
TNS-00006: INTCTL: HOST variable is not defined
Cause: The HOST variable was not set.
Action: Set the variable HOST properly and restart the INTCTL program.
TNS-00007: INTCTL: unknown host
Cause: The pointer HOST is set to an unknown hostname.
Action: Set the pointer HOST properly and restart INTCTL program.
TNS-00008: INTCTL: could not contact destination Navigator
Cause: Connection could not be properly established to a Navigator. This may be because the Navigator specified is not running or the Navigator addresses are incorrect.
Action: Check that the Navigator is running by using the STATUS command of the Interchange Control Utility; if necessary, start the Navigator using the START command of the Interchange Control Utility. If it is running and the error persists, contact Oracle Customer Support.
TNS-00009: INTCTL: could not contact destination Connection Manager
Cause: Connection could not be properly established to a Connection Manager. This may be because the Connection Manager (Interchange) specified is not running or the Connection Manager addresses are incorrect.
Action: Make sure the Connection Manager is running by using the STATUS command of the Interchange Control Utility; if necessary, start the Connection Manager using the START command of the Interchange Control Utility. If it is running and the error persists, contact Oracle Customer Support.
TNS-00010: Error while flushing NS context
Cause: Internal NS error; connection may be lost.
Action: Make sure the connection is properly established. If the error persists, then contact Oracle Customer Support.
TNS-00011: INTCTL: error while starting the Connection Manager
Cause: The Connection Manager could not be started.
Action: Assure that the executable can be found in the standard Oracle executable area. Check the configuration file INTCHG.ORA for errors and confirm that no other process is using the ADDRESS(es) for this Connection Manager as specified in TNSNET.ORA. Tracing can also be turned on in the Connection Manager and detailed information about the reason for the error determined. Consult the MultiProtocol Interchange Administrator's Guide and Chapter 2 of this manual for how to turn on tracing.
TNS-00012: INTCTL: error while processing Connection Manager request
Cause: An improper command was sent to the Connection Manager or it is not responding. Not normally visible to the user.
Action: Verify that the correct addresses are listed in the TNSNAMES.ORA, TNSNET.ORA, and TNSNAV.ORA configuration files. Also check that the Connection Manager is running by using the STATUS command of the Interchange Control Utility. If the error persists, contact Oracle Customer Support.
TNS-00013: INTCTL: error while performing NS disconnect command
Cause: Internal NS error. Error in closing down connections.
Action: Make sure the networking protocol being used is properly installed on the machine. If the error persists contact Oracle Customer Support.
TNS-00014: INTCTL: error while opening terminal input channel
Cause: Could not open standard terminal input. Internal error.
Action: Normally not visible to the user. Restart the INTCTL program. If error persists, contact Oracle Customer Support.
TNS-00015: INTCTL: error while closing terminal input channel
Cause: Could not close terminal input channel. Internal error.
Action: Normally not visible to the user. Restart the INTCTL program. If error persists, contact Oracle Customer Support.
TNS-00016: INTCTL: error while performing NS send command
Cause: Internal NS error. Connection may be lost.
Action: If the error persists contact Oracle Customer Support.
TNS-00017: INTCTL: error while performing NS receive command
Cause: Internal NS error. Connection may be lost.
Action: If the error persists contact Oracle Customer Support.
TNS-00018: INTCTL: TNS_ADMIN not defined
Cause: The TNS_ADMIN pointer is improperly set.
Action: No action necessary; TNS_ADMIN need only be set if you want to use a different network environment.
TNS-00019: INTCTL: error initializing the national language interface
Cause: The message file could not be found.
Action: Make sure that the ORACLE environment is set and that the message file is in the correct place.
TNS-00020: INTCTL: missing NAVIGATOR_DATA in TNSNAV.ORA
Cause: TNSNAV.ORA does not contain the NAVIGATOR_DATA component.
Action: Define the ADDRESS(es) for the Navigator, then restart the INTCTL program.
TNS-00021: INTCTL: missing INTERCHANGE_DATA in INTCHG.ORA
Cause: INTCHG.ORA does not contain an INTERCHANGE_DATA component.
Action: Define the correct data for the Connection Manager, then restart the INTCTL program.
TNS-00022: INTCTL: missing CMANAGER_NAME in INTCHG.ORA
Cause: INTCHG.ORA does not contain a CMANAGER_NAME component.
Action: Define the correct name for the CMANAGER_NAME, then restart the INTCTL program.
TNS-00023: INTCTL: missing ADDRESS(es) in config files
Cause: Configuration files do not contain an ADDRESS/ADDRESS_LIST component.
Action: Define the Connection Manager ADDRESS(es) in the TNSNET.ORA file and check the Navigator ADDRESS(es) in the TNSNAV.ORA file, then restart the INTCTL program.
TNS-00024: INTCTL: Unable to contact Navigator to obtain Connection Manager address
Cause: The Navigator is not running.
Action: Verify that the Navigator is running by doing a status request on the Navigator (use the Interchange Control Utility command STATUS). If necessaary, start the Navigator using the Interchange Control Utility. Verify that the network is properly configured; if the error persists, contact Worldwide Customer Support.
TNS-00025: INTCTL: The ORACLE environment is not set up correctly
Cause: The ORACLE environment is incorrectly set up.
Action: Refer to the Oracle operating system specific documentation for your platform for information on how the ORACLE environment should be set. Correct it and rerun INTCTL. Make sure the ORACLE environment includes the correct directories.
TNS-00026: INTCTL: TNS_ADMIN directory set, and is being used
Cause: The TNS_ADMIN environment variable is set properly. INTCTL will use the TNS_ADMIN directory. This is only an informative message. If you do not want it to be used, and want the default directory to be used instead, then unset TNS_ADMIN and reexecute.
Action: None.
TNS-00027: INTCTL: Could not resolve Navigator's name/address
Cause: The Navigator's name to address definition is missing.
Action: Check TNSNAMES.ORA file and make sure to include a definition for the name specified.
TNS-00028: INTCTL: Could not resolve Connection Manager's name/address
Cause: The Connection Manager's name does not have a definition that the Navigator knows about, nor is the name/address available in the TNSNAMES.ORA file. The name may also be incorrect in the INTCHG.ORA file.
Action: Verify that the Connection Manager's name is in the TNSNET.ORA file read by the Navigator or in the TNSNAMES.ORA file. Be sure that INTCHG.ORA is correct.
TNS-00031: INTCTL: internal NT error
Cause: Problem interfacing to the protocol adapters installed.
Action: Normally not visible to the user. Try starting INTCTL again. If the error persists, check the product installation. If it is correct, contact Oracle Customer Support.
TNS-00032: INTCTL: internal NS error
Cause: Problem interfacing with TNS.
Action: Normally not visible to the user. Try starting INTCTL again. If the error persists, check the product installation. If it is correct, contact Oracle Customer Support.
TNS-00033: INTCTL: internal NL error
Cause: Problem with internal TNS module NL.
Action: Normally not visible to the user. Try starting INTCTL again. If the error persists, check the product installation. If it is correct, contact Oracle Customer Support.
TNS-00034: INTCTL: internal NR error
Cause: Problem with internal Interchange routines.
Action: Normally not visible to the user. Try starting INTCTL again. If the error persists, check the product installation. If it is correct, contact Oracle Customer Support.
TNS-00035: INTCTL: error while constructing full file name
Cause: Problem while constructing the full path for a file name because the path name to the file or the environment variables are incorrect. Files looked up include TNSNAMES.ORA, TNSNAV.ORA, INTCHG.ORA and the error files for the Navigator and Connection Manager.
Action: Check that all environment variables are defined correctly and that all configuration files exist in their correct places.
TNS-00036: INTCTL: error reading from Navigator or Connection Manager error files
Cause: Problem while reading from Navigator or Connection Manager error files generated by the Navigator or Connection Manager when they fail to start.
Action: Check that a standard Network Error directory exists and that all privileges on the directory are appropriate.
TNS-00037: INTCTL: error opening Navigator or Connection Manager error files
Cause: Failed to open Navigator or Connection Manager error files when they have failed to start.
Action: Check that a Network Error directory exists and that all privileges on the directory are appropriate.
TNS-00038: INTCTL: Poorly formed address or command string
Cause: An unacceptable string was encountered while attempting to send a message to either the Navigator or Connection Manager. The addresses provided for either the Navigator or Connection Manager may be incorrectly constructed.
Action: Check all address strings in configuration files (TNSNAMES.ORA, TNSNAV.ORA or TNSNET.ORA) and assure that they are properly formed. Regenerate the files, if possible. If all is correct, please contact Worldwide Customer Support.
TNS-00039: INTCTL: error while spawning a process
Cause: An error was encountered while spawning a process due to an internal operating system dependent problem. Machine resources may be limited.
Action: Retry command. Check permissions on Interchange executables and the current setting of the search path. If necessary, terminate other applications to free up machine resources. If the error persists, contact Oracle Customer Support.
TNS-00040: INTCTL: failed to initialize trace context- Continuing anyway
Cause: Problem while opening specified trace file because of errors in INTCHG.ORA or because the user has incorrect privileges, or the file does not exist.
Action: Check the privileges on the configuration files and ensure that all of them exist in their proper locations.
TNS-00041: INTCTL: Navigator already running. Start operation cancelled
Cause: There is a Navigator already running and listening on the same addresses.
Action: None; the Navigator is already running.
TNS-00042: INTCTL: CMANAGER already running. Start operation cancelled
Cause: There is a Connection Manager already running and listening on the same addresses.
Action: None; the Connection Manager is already running.
TNS-00043: The CMANAGER has active connections, do you still want to stop it (y/n)?
Cause: The CMANAGER that is being stopped has active connections going through. This is the confirmation message.
Action: Respond by pressing y or n. Answering y will cause the active database connection to be dropped; this is not generally recommended.
TNS-00044: INTCTL: You must have an INTCHG.ORA file to contact the Connection Manager
Cause: There was an attempt to contact a default Connection Manager (Interchange) where there was no INTCHG.ORA present in the correct directory.
Action: Create an INTCHG.ORA file. Make sure it is placed in the correct directory and includes the correct name for the Connection Manager you wish to contact.
TNS-00045: INTCTL: Could not contact the Navigator on address
Cause: There was an attempt to contact a Navigator on a specific address which is not responding.
Action: Check the TNSNAV.ORA file for that address. Or check that the Navigator is actually listening on that address.
TNS-00046: INTCTL: Could not contact the CMANAGER on address
Cause: There was an attempt to contact a CMANAGER on a specific address which is not responding.
Action: Verify that the TNSNET.ORA file contains that address. Also check that the CMANAGER is actually listening on that address by using the INTCTL STATUS command. If necessary, start the Connection Manager using the INTCTL START command.
TNS-00060: INTCTL: Bad command: only the STATUS command can be used on remote Interchanges
Cause: The user entered a command that does not exist, or the user tried to make a request other than STATUS to a remote Interchange.
Action: Check the MultiProtocol Interchange Administrator's Guide for a list of INTCTL commands or type HELP for a list of valid commands.
TNS-00061: INTCTL: Bad command or syntax error: You must specify a trace level
Cause: The user did not specify a trace level.
Action: Specify a trace level and retry command.
TNS-00062: INTCTL: Bad command or syntax error: For help type help/h/?
Cause: The user entered an invalid command.
Action: Check the MultiProtocol Interchange Administrator's Guide or type HELP for a list of valid commands.
TNS-00063: INTCTL: Failed to allocate memory for buffers
Cause: INTCTL was unable to allocate memory for internal buffers.
Action: Check the amount of available memory on your machine to ensure that there is enough memory to run this executable. If necessary, free up memory by running fewer programs, then try again.
TNS-00064: INTCTL: Failed to find CMANAGER_NAME in INTCHG.ORA
Cause: INTCTL was unable to find the CMANAGER_NAME parameter in INTCHG.ORA.
Action: Check that the INTCHG.ORA file is properly constructed.
TNS-00065: INTCTL: Command cannot be executed remotely
Cause: A command other than status and version has been attempted remotely.
Action: If you desire execute any command other than status and version, you must run intctl on the interchange machine.
TNS-00070: INTCTL usage: [intctl] <command> <process_name> [argument]
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00071: where <command> is one of following:
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00072: * start - start up process_name
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00073: * stop/abort - stop the process_name
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00074: * status - get statistics from the process_name
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00075: NOTE: the user may get the status info of a remote
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00076: component by specifying the component name in
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00077: the argument field
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00078: * log_on - ask process_name to turn logging on
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00079: * log_off - ask process_name to turn logging off
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00080: * force_log - ask process_name to dump its state
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00081: * trace_on - ask process name to turn tracing on
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00082: NOTE: the user MUST specify a trace level
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00083: (USER or ADMIN) in the argument field
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00084: * trace_off - ask process name to turn tracing off
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00085: * reread - ask the process name to reread parameter files
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00086: * reload - ask the Navigator to reload TNSNET.ORA
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00087: * version - ask the process name to display its version number
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00088: * exit - quit the Interchange controller
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00089: process_name is one of Interchange, CMANAGER, or Navigator
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00090: * Interchange - will ask the Interchange
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00091: * Navigator (or navgatr) - will ask the Navigator only
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00092: * CMANAGER (or intlsnr) - will ask the Cmanager only
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00093: argument is only supplied to either status or trace_on
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00094: * to status - argument is considered the remote process_name
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00095: * to trace_on - argument is considered the trace level
Cause: Help message displayed by INTCTL.
Action: None.
TNS-00100: Unable to allocate memory
Cause: Out of memory on the machine.
Action: Add more memory or run fewer processes.
TNS-00101: File operation error
Cause: Error in accessing reading or writing a particular file.
Action: Check existence of or operating system access to the log and trace file locations.
TNS-00102: Keyword-Value binding operation error
Cause: Not normally visible to the user. May indicate a shortage of memory.
Action: If error persists contact Oracle Customer Support.
TNS-00103: Parameter file load error
Cause: Parameter file process failed.
Action: Check to make sure that all parameter files necessary for the Interchange are present (TNSNAV.ORA, TNSNET.ORA and INTCHG.ORA). If these files are present and properly configured, turn on tracing and repeat the operation. Turn off tracing when the trace is complete. Look in the trace file for errors in the parameter loading process. If error persists contact Oracle Customer Support.
TNS-00104: Data stream open/access error
Cause: Unable to open or access data stream for either log or trace files for the Interchange.
Action: Check read/write permissions on Oracle files and directories.
TNS-00105: Could not initialize tracing
Cause: The INTCHG.ORA file is improperly configured. Verify the trace parameters specified.
Action: If error persists contact Oracle Customer Support.
TNS-00106: Failed to open log file
Cause: Unable to access or obtain write permission to create log file.
Action: Check existence of or access to log file directory.
TNS-00107: Unable to initialize TNS global data
Cause: Not normally visible to the user.
Action: If error persists contact Oracle Customer Support.
TNS-00108: TNS_ADMIN not defined
Cause: TNS_ADMIN pointer is not set.
Action: Set the TNS_ADMIN pointer before running application
TNS-00109: Message could not be printed; not enough memory
Cause: Printing of message failed due to lack of memory. Not normally visible to user.
Action: Increase the resources on your machine. If error persists contact Oracle Customer Support.
TNS-00110: Could not initialize network from file TNSNET.ORA
Cause: Poorly formed network information in network file.
Action: Fix network configuration data to assure that at least one Interchange is defined in TNSNET.ORA.
TNS-00111: Failed to get configuration data from file
Cause: Poorly formed configuration information in network files TNSNET.ORA or TNSNAV.ORA.
Action: Check TNSNET.ORA and TNSNAV.ORA and confirm that they are correct.
TNS-00112: Failed to find configuration file name
Cause: Name specified for configuration file was incorrect.
Action: Check for presence of the configuration file.
TNS-00113: Failed to open error log file
Cause: Could not open log file during startup of Navigator or Connection Manager due to read or write permission problems or non-existent error directory.
Action: Create the standard error directory or assure that if one is present the Interchange executables can write to it.
TNS-00114: Internal error- Allocation of addresses not performed
Cause: Internal error. Should not normally occur.
Action: Contact Oracle Customer Support.
TNS-00115: Could not allocate pump global buffers
Cause: Not enough memory to allocate pump buffers.
Action: Decrease the number of PUMP_BUFFERS in INTCHG.ORA.
TNS-00116: Pump failed during initial bequeath
Cause: d by insufficient machine resources.
Action: Attempt the connection again. The pump should recover from such a failure. If machine resources appear to be the problem, add more resources // or shut down some active applications. If problem persists, contact Oracle Customer Support.
TNS-00117: Internal error- No data passed through pump
Cause: Internal error. Data expected has not arrived yet.
Action: If error persists, contact Oracle Customer Support.
TNS-00119: Missing PUMP_CONNECTIONS in INTCHG.ORA
Cause: No PUMP_CONNECTIONS parameter specified in INTCHG.ORA.
Action: Add PUMP_CONNECTIONS parameter to INTCHG.ORA.
TNS-00120: Missing PUMPS in INTCHG.ORA
Cause: No PUMPS parameter specified.
Action: Add an appropriate number of PUMPS to INTCHG.ORA.
TNS-00121: Missing CMANAGER_NAME in INTCHG.ORA
Cause: No CMANAGER_NAME parameter specified.
Action: Define the CMANAGER_NAME parameter in INTCHG.ORA; it must match the CMANAGER_NAME parameter used in TNSNET.ORA for that Interchange.
TNS-00122: Missing ADDRESS(es) in TNSNET.ORA file
Cause: No ADDRESS or ADDRESS_LIST parameter specified in TNSNET.ORA.
Action: Define a valid set of ADDRESSes for the Connection Manager in the TNSNET.ORA file.
TNS-00123: Unable to perform a listen on configured ADDRESS(es)
Cause: Another process is already listening on this address or the ADDRESS is incorrectly defined.
Action: Check the ADDRESS(es) defined in TNSNET.ORA (for the Connection Manager) for errors. Verify that another program is not using them.
TNS-00124: Internal error - Unable to create empty address
Cause: - Internal error. Should not normally occur.
Action: If problem persists contact Oracle Customer Support.
TNS-00125: Failed to get number of Interchanges in TNSNET.ORA
Cause: Error in the TNSNET.ORA file.
Action: Check the contents of TNSNET.ORA and eliminate errors. Regenerate the configuration files.
TNS-00126: Missing Connection Manager name and address in TNSNET.ORA
Cause: The Interchange name specified in INTCHG.ORA is not defined in the TNSNET.ORA file.
Action: Define one Connection Manager name and set of addresses for each Interchange in the network. Regenerate the configuration files.
TNS-00127: Missing Connection Manager name in TNSNET.ORA
Cause: One or more Connection Manager names are missing.
Action: Ensure that each Connection Manager name is defined in TNSNET.ORA. Regenerate TNSNET.ORA.
TNS-00128: Missing COMMUNITY in TNSNET.ORA
Cause: One or more ADDRESSes does not have a COMMUNITY assigned.
Action: Ensure that all addresses have a COMMUNITY defined in TNSNET.ORA.
TNS-00129: Internal error - Failed to create new community
Cause: Internal Error. Should not normally occur. There may be a resource limitation problem on the machine.
Action: Stop and restart Interchange. If possible, make more memory available on the machine. If problem persists, contact Oracle Customer Support.
TNS-00130: Failed to create Interchange's internal address
Cause: There is an error in one of the addresses listed in TNSNET.ORA.
Action: Check the file for errors in defining Interchanges.
TNS-00131: Missing COMMUNITY in COMMUNITY_COST_LIST in TNSNET.ORA
Cause: A COMMUNITY keyword-value pair is missing within the COMMUNITY_COST_LIST in TNSNET.ORA.
Action: Define the communities with a COMMUNITY name and associated COST in COMMUNITY_COST_LIST.
TNS-00132: COST value must be an integer greater than 0
Cause: A community has been defined in TNSNET.ORA with a COST of 0.
Action: Assign an alternate value that is greater than 0.
TNS-00133: Missing LOCAL_COMMUNITIES field in TNSNAV.ORA
Cause: Improperly configured TNSNAV.ORA file.
Action: Define the LOCAL_COMMUNITIES fields correctly in TNSNAV.ORA.
TNS-00134: Missing COMMUNITY component in addresses for the Navigator in TNSNAV.ORA
Cause: The addresses specified for the Navigator have no COMMUNITY name.
Action: Ensure that all addresses in the NAVIGATOR_ADDRESSES field have a COMMUNITY entry in the TNSNAV.ORA file.
TNS-00135: Missing TNS error message file
Cause: No error message file present.
Action: Ensure that the ORACLE environment is correctly set for your platform and that there is a message directory that contains the correct error message file.
TNS-00136: Did not register product/facility for TNS error message
Cause: Error message file error.
Action: Ensure that the ORACLE environment is correctly set for your platform and that there is a message directory that contains the correct error message file.
TNS-00137: Failed to get TNS error message file entry
Cause: No TNS error message file present.
Action: Ensure that the ORACLE environment is correctly set for your platform and that there is a message directory that contains the correct error message file.
TNS-00138: Failed to find ORACLE executable directory
Cause: The ORACLE environment is not correctly set.
Action: Ensure that the ORACLE environment is correctly set and the error messages file is in the correct place.
TNS-00139: Internal - Data passed from the Interchange listener is poorly formed
Cause: Internal error in Interchange.
Action: Check that you are using compatible components of the Interchange product, using the INTCTL VERSION command. If problem persists call Oracle Customer Support.
TNS-00140: Interchange specified was not found in network tables
Cause: Could not find the Interchange specified in a control request.
Action: Check that the Interchange specified is indeed in TNSNET.ORA.
TNS-00141: Failed to get file stream information
Cause: Error in the file stream package.
Action: None.
TNS-00142: Community mismatch in TNSNAV.ORA
Cause: The communities in the LOCAL_COMMUNITIES entry in TNSNAV.ORA do not correspond with all the communities in the NAVIGATOR_ADDRESSES entry.
Action: Assure that all communities in the NAVIGATOR_ADDRESSES correspond to those in the LOCAL_COMMUNITIES component.
TNS-00143: Illegal PREFERRED_CMANAGERS entry in TNSNAV.ORA
Cause: PREFERRED_CMANAGERS entry in the TNSNAV.ORA used by the Connection Manager. There should only be a PREFERRED_NAVIGATORS entry in the TNSNAV.ORA on an Interchange.
Action: Remove the PREFERRED_CMANAGERS entry from TNSNAV.ORA and assure that either no PREFERRED_NAVIGATORS entry is present or that it is correct.
TNS-00144: PUMP_CONNECTIONS value in INTCHG.ORA is too large.
Cause: The number of PUMP_CONNECTIONS specified in INTCHG.ORA is too large to be supported on this platform.
Action: Consult the Oracle operating system specific manual for the maximum value for the number of PUMP_CONNECTIONS.
TNS-00145: PUMPS value in INTCHG.ORA is too large.
Cause: The number of PUMPS specified in INTCHG.ORA is too large to be supported on this platform.
Action: Consult the Oracle operating system specific manual for the maximum value for the number of PUMPS.
TNS-00146: Internal-- Retry data request withing pump.
Cause: The data space provided in order to receive data from the pump is to small.
Action: Operation must be retried with a larger buffer.
TNS-00147: Failed to start a pre-spawned pump.
Cause: The Connection Manager was unable to start a pump during startup.
Action: Check all configuration parameters and assure that they are correct. Turn on tracing to determine the area that the failure ocurred in.
TNS-00200: Unable to do nsanswer on context result=string
Cause: Requester of service may have aborted or options negotiation failed.
Action: Try making the connection again. If the problem persists call Oracle Customer Support.
TNS-00201: Unable to read answer connection data :string:
Cause: Improperly formed connect data sent to the Interchange listener.
Action: If problem persists, check the application using the Interchange (it may be closing down or crashing). Call Oracle Customer Support if the problem cannot be located.
TNS-00202: Failure in redirecting call : Original to string Redirect to string
Cause: Internal - error could not redirect call to a pump or other Interchange listener. The cause may be insufficient network or machine resources.
Action: Add resources or close some running applications in order to free up resources. If error persists, call Oracle Customer Support.
TNS-00203: Unable to start tracing in intlsnr
Cause: Failure in setting up tracing for Interchange listener.
Action: Check file permissions in Network trace directory also check to make sure that if trace file names and directories are specified in INTCHG.ORA, they are correct.
TNS-00204: Started tracing in intlsnr
Cause: Internal message- Successfully started tracing information.
Action: None.
TNS-00205: Turning off tracing in intlsnr
Cause: Internal message - Turned off tracing in the Interchange listener.
Action: None
TNS-00206: Status Information for Interchange string:
Cause: Message sent back by Interchange as header for status request.
Action: None
TNS-00207: Uptime : number days number hr. number min. number sec
Cause: Part of status request.
Action: None
TNS-00208: Logging : string
Cause: Part of status request.
Action: None
TNS-00209: Tracing : string
Cause: Part of status request Interchange.
Action: None
TNS-00210: Total Pumps Available : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00211: Total Active Pumps : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00212: Total Pumps Started : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00213: Available Connections : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00214: Total Connections in Use : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00215: Total Successful Connections : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00216: Total Failed Connections : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00217: Total Bytes of Data : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00218: Current Bytes/Sec. : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00219: Pump Strategy : string
Cause: Part of status request.
Action: None
TNS-00220: Pump Breakdown --------------
Cause: Part of status request.
Action: None
TNS-00221: Pump Connections Total Data Bytes/Second
Cause: Part of status request.
Action: None
TNS-00222: -------------------------------------------------------------------
Cause: Part of status request.
Action: None
TNS-00223: numbernumbernumbernumber
Cause: Part of status request.
Action: None
TNS-00224: No more connections available
Cause: More connections were made to the Interchange than are configured in INTCHG.ORA.
Action: Wait until the Interchange is not as busy or change the number of connections allowed in INTCHG.ORA and restart the Interchange.
TNS-00225: Unable to bequeath connection to pump
Cause: Unable to start a pump because either the executable cannot be found or too many processes aare currently running on a particular machine.
Action: Reduce the number of processes on the machine or increase the resources on the machine.
TNS-00226: Unable to contact pump number to send broadcast message string
Cause: Could not call a particular pump.
Action: None, but if the problem persists call Oracle Customer Support.
TNS-00227: Unable to contact pump; Connection Manager declared pump dead
Cause: A pump became an orphaned process. A protocol adapter is not working properly or machine network resources are being over used.
Action: This error is not immediately fatal; the orphaned pump may continue to function. Restart the Interchange when convenient. If the problem persists, call Oracle Customer Support.
TNS-00228: Failure in finding pump data
Cause: Internal problem with data passed back from pump.
Action: None.
TNS-00229: Error in call: unable to deliver message :string: string string string
Cause: Destination for call is unavailable.
Action: None.
TNS-00230: Cannot start new pump process: string string Protocol Adapter errors:number
Cause: Unable to create a new process; possibly there are too many processes on the machine.
Action: Free machine resources by exiting other applications on the Interchange machine. If the problem continues you may need more memory on the machine. If you believe there are sufficient resources on the machine but the problem persists, contact Oracle Customer Support.
TNS-00231: Pump is alive
Cause: Pump log message sent to Interchange listener.
Action: None.
TNS-00232: Unable to setup connection
Cause: Error log message sent from pump to indicate failure in initiating connection because of errors in the call string: network problem or resource limitations.
Action: None.
TNS-00233: Interchange failed to make contact with destination with errors: string string string
Cause: Pump call to destination failed.
Action: Check destination.
TNS-00234: Connect data for failed call: CALL DATA = string RECEIVE DATA = :string:
Cause: Connect data supplied for error 00233.
Action: None
TNS-00235: Aborting connection: Protocol Apapter errors: string;number,number string;number,number
Cause: Pump aborting connection because connection has been up too long, or some other network error on the connection.
Action: None.
TNS-00236: Failed to initialize tracing
Cause: Pump failed to initialize tracing.
Action: Check that INTCHG.ORA is properly configured.
TNS-00237: Failed to refuse connection
Cause: Connection may have aborted before error took place in Pump.
Action: None.
TNS-00238: Pump number @: string:
Cause: Prepended message to all pump log messages.
Action: None.
TNS-00239: Connection Manager has been stopped
Cause: Message sent back to control program from Interchange.
Action: None.
TNS-00240: Connection Manager: Logging is now ON
Cause: Message sent back to control program from Interchange.
Action: None.
TNS-00241: Connection Manager: Logging is now OFF
Cause: Message sent back to control program from Interchange.
Action: None.
TNS-00242: Connection Manager: Tracing is now ON
Cause: Message sent back to control program from Interchange.
Action: None.
TNS-00243: Connection Manager: Tracing is now OFF
Cause: Message sent back to control program from Interchange.
Action: None.
TNS-00244: Connection Manager: Request Failed
Cause: Message sent back to control program from Interchange.
Action: None.
TNS-00245: Connection Manager: Failed to open log file
Cause: Message sent back to control program from Interchange.
Action: None.
TNS-00246: Connection Manager: Failed to start tracing
Cause: Message sent back to control program from Interchange.
Action: None.
TNS-00247: Unable to allocate memory for configuration data from TNSNET.ORA file
Cause: Navigator failed to allocate enough memory for TNSNET.ORA configuration file.
Action: Increase machine resources available for running the Interchange or remove some other running applications from the machine.
TNS-00248: Unable to get information from file :string: Exiting with NR error:number
Cause: TNSNAV.ORA poorly configured or addresses provided are already being used by another application.
Action: Check the syntax of the TNSNAV.ORA file; if necessary, assign new addresses.
TNS-00249: Unable to read network configuration data from file string with error: string
Cause: Network configuration file TNSNET.ORA is missing or poorly configured.
Action: Check to make sure that TNSNET.ORA is properly configured.
TNS-00250: Navigator has been started
Cause: Message to log file on Navigator startup.
Action: None.
TNS-00251: Failure in nstest:
Cause: NS test operation failed due to internal error.
Action: If the problem persists there may be a network problem or resource limitations on the machine. If these do not seem to be causing the problem, call Oracle Customer Support.
TNS-00252: Unable to handle route request: string
Cause: Command requested did not exist.
Action: None.
TNS-00253: Error in reading network configuration data from file string with error string
Cause: TNSNET.ORA is poorly configured or nonexistent.
Action: Check to make sure that TNSNET.ORA is properly configured.
TNS-00254: Navigator has been stopped
Cause: Message sent to Interchange control program by Navigator confirming it has been stopped.
Action: None.
TNS-00255: Closing down log, stopping Navigator
Cause: Log message when Navigator is stopped.
Action: None.
TNS-00256: Status of Navigator:
Cause: Navigator status message component
Action: None.
TNS-00257: Number of Successful Requests : number
Cause: Navigator status message component
Action: None.
TNS-00258: Number of Failed Requests : number
Cause: Navigator status message component
Action: None.
TNS-00259: Disabled Interchange list:
Cause: Navigator status message component
Action: None.
TNS-00260: -------------------------------------------------------------------
Cause: Navigator status message component
Action: None.
TNS-00261: Interchange Name Community Link Down Time Remaining (secs)
Cause: Navigator status message component
Action: None.
TNS-00262: %20sstringnumber
Cause: Navigator status message component
Action: None.
TNS-00263: Navigator: Request Failed
Cause: Response from Navigator when a particular request failed.
Action: None.
TNS-00264: Navigator: Failed to reload configuration data
Cause: Message sent to the Interchange control program when reload of network configuration failed. TNSNET.ORA Poorly configured or missing.
Action: None.
TNS-00265: Navigator: Reloaded network configuration data
Cause: Message sent to Interchange control program when reload of network is successful.
Action: None.
TNS-00266: Navigator: Unknown Request
Cause: Request was made to Navigator that it knows nothing about.
Action: None.
TNS-00267: Navigator: Internal Error
Cause: Generated when a request was made to the Navigator it knows nothing about.
Action: None.
TNS-00268: ON
Cause: On component of message.
Action: None.
TNS-00269: OFF
Cause: Off component of message.
Action: None.
TNS-00270: %s: Terminal Error string
Cause: Message put out in error file of executable when it fails to start.
Action: None.
TNS-00271: Connection Manager
Cause: Name of the Connection Manager.
Action: None.
TNS-00272: Navigator
Cause: Name for the Navigator.
Action: None.
TNS-00273: Navigator: Logging is now ON
Cause: Message sent back to control program from Navigator.
Action: None.
TNS-00274: Navigator: Logging is now OFF
Cause: Message sent back to control program from Navigator.
Action: None.
TNS-00275: Navigator: Tracing is now ON
Cause: Message sent back to control program from Navigator.
Action: None.
TNS-00276: Navigator: Tracing is now OFF
Cause: Message sent back to control program from Navigator.
Action: None.
TNS-00277: Navigator: Request Failed
Cause: Message sent back to control program from Navigator.
Action: None.
TNS-00278: Navigator: Failed to Open Log file
Cause: Message sent back to control program from Navigator.
Action: None.
TNS-00279: Navigator: Failed to Start Tracing
Cause: Message sent back to control program from Navigator.
Action: None.
TNS-00280: Max Avg Bytes/Sec : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00281: Connection Manager: Forced Log output
Cause: Message sent back to control program from Connection Manager.
Action: None.
TNS-00282: Connection Manager: Failed to force log, logging is off
Cause: Message sent back to control program from Connection Manager.
Action: None.
TNS-00283: Listening on the following TNS addresses:
Cause: Message sent back to control program from Connection Manager.
Action: None.
TNS-00284: Imm Max Avg Bytes/Sec : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00285: Avg Connect Time (secs) : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00286: Max Connect Time (secs) : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00287: Min Connect Time (secs) : number
Cause: Part of status request for Connection Manager.
Action: None
TNS-00288: Navigator: Failed to Disable Interchange
Cause: Message sent back to control program from Navigator.
Action: None.
TNS-00289: Navigator: Disabled Interchange
Cause: Message sent back to control program from Navigator.
Action: None.
TNS-00290: Navigator: Failed to Enable Interchange
Cause: Message sent back to control program from Navigator.
Action: None.
TNS-00291: Navigator: Enabled Interchange
Cause: Message sent back to control program from Navigator.
Action: None.
TNS-00292: Log File Name : string
Cause: Message sent back to control program showing log file name
Action: None.
TNS-00293: Trace File Name : string
Cause: Message sent back to control program showing trace file name
Action: None.
TNS-00294: Connection Manager: Security is enabled, you cannot STOP the Interchange
Cause: Message sent back to control program indicating that the connection manager is secure.
Action: None.
TNS-00295: Navigator: Security is enabled, you cannot STOP the Navigator
Cause: Message sent back to control program indicating that the Navigator is secure.
Action: None.
TNS-00296: Stoppable : string
Cause: Message sent back to control program indicating whether program can be stopped.
Action: None.
TNS-00297: Logging Level : string
Cause: Message sent back to control program indicating whether program can be stopped.
Action: None.
TNS-00298: Request to Navigator: string
Cause: Log entry for request to Navigator.
Action: None.
TNS-00299: Response from Navigator: string
Cause: Log entry for request to Navigator.
Action: None.
TNS-00300: ***Disabling Interchange : string
Cause: Log entry for disabling a particular Interchange.
Action: None.
TNS-00301: ***Enabling Interchange : string
Cause: Log entry for disabling a particular Interchange.
Action: None.
TNS-00302: Connection Manager: Unknown Request
Cause: Request sent by Interchange control program is unknown.
Action: None.
TNS-00303: Connection Manager: Reread parameter data
Cause: Request sent by control manager to control programming indicating that parameter data was read.
Action: None.
TNS-00304: Status Information for Connection Manager:
Cause: Message sent back by Interchange as header for status request.
Action: None
TNS-00305: The Navigator encountered an invalid/unknown trace level
Cause: Message sent back by the Navigator indicating an invalid trace level.
Action: Reattempt the request with a correct trace level.
TNS-00306: Connection Manager encountered an invalid/unknown trace level
Cause: Message sent back by the Connection Manager indicating an invalid trace level.
Action: Reattempt the request with a correct trace level.
TNS-00307: Navigator: Reread parameter data
Cause: Request sent by the Navigator to control program indicating that parameter data was read.
Action: None.
TNS-00308: Navigator: Failed to open log while rereading parameter data
Cause: Request sent by the Navigator to control program indicating that it could not reopen log file after rereading parameter data.
Action: None.
TNS-00309: Connection Manager: Failed to open log while re-reading parameter data
Cause: Request sent by the Connection Manager to control program indicating that it could not reopen log file after rereading parameter data.
Action: None.
TNS-00310: Navigator: Failed to start tracing after rereading parameter data
Cause: Message sent back to control program from Navigator.
Action: None.
TNS-00311: Connection Manager: Failed to start tracing after rereading parameter data
Cause: Message sent back to control program from Connection Manager.
Action: None.
TNS-00312: Connection Manager: Failed to get version information
Cause: Message sent back to control program from Connection Manager.
Action: None.
TNS-00313: Navigator: Failed to get version information
Cause: Message sent back to control program from Connection Manager.
Action: None.
TNS-00314: Protocol Adapter Errors: number,number
Cause: Protocol Adapter errors which go with message 233
Action: None.
TNS-00315: Failed to allocate larger connect data area for getting pump data: number
Cause: Could not allocate a large enough area to get pump statistics; continue without them.
Action: None.
TNS-00316: Ran out of data buffers in the pump
Cause: The Interchange is resource limited by having too few data buffers in the pump.
Action: If the problem persists (that is, there are a lot of log messages), increase the number of pump buffers by increasing the value of the parameter PUMP_BUFFERS in INTCHG.ORA. Then shutdown and restart the Interchange to make the changes take effect.
TNS-00317: Failed to contact Connection Manager
Cause: Connection Manager is not running.
Action: Start the Connection Manager and retry
TNS-00501: Cannot allocate memory
Cause: Sufficient memory could not be allocated to perform the desired activity.
Action: Either free some resource for TNS or add more memory to the machine. For further details, turn on tracing and reexecute the operation.
TNS-00502: Invalid argument
Cause: An internal function received an invalid parameter.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-00503: Illegal ADDRESS parameters
Cause: An illegal set of protocol adapter parameters was specified.
Action: Check the parameters within the ADDRESS section of the TNSNAMES.ORA file. It may be helpful to turn on tracing and look at the addresses specified in the trace file, checking for spelling or other errors. Be sure to turn tracing off when the trace is complete.
TNS-00504: Operation not supported
Cause: An internal function received a request to perform an operation that is not supported (on this machine).
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-00505: Operation timed out
Cause: The requested operation could not be completed within the timeout period.
Action: For further details, turn on tracing and reexecute the operation.
TNS-00506: Operation would block
Cause: An internal operation did not commence because to do so would block the current process and the user has requested that operations be non-blocking.
Action: None needed; this is an information message.
TNS-00507: Connection closed
Cause: Normal "end of file" condition has been reached; partner has disconnected.
Action: None needed; this is an information message.
TNS-00508: No such protocol adapter
Cause: The protocol adapter requested for this connection does not exist.
Action: Install the protocol adapter or use one that is available. Be sure that the correct protocols are listed in the configuration files.
TNS-00509: Buffer overflow
Cause: Too much data for buffer.
Action: Reexecute with larger receive buffer or smaller send buffer.
TNS-00510: Internal limit restriction exceeded
Cause: Too many files or sockets open simultaneously (or some other resource has been depleted).
Action: For further details, trace the operation for protocol details.
TNS-00511: No listener
Cause: The connect request could not be completed because no application is listening on the address specified, or the application is unable to service the connect request in a sufficiently timely manner.
Action: Ensure that the supplied destination address matches one of the addresses used by the listener - compare the TNSNAMES.ORA entry with appropriate LISTENER.ORA file (or TNSNAV.ORA if the connection is to go by way of an Interchange. Start the listener on the remote machine.
TNS-00512: Address already in use
Cause: Specified listener address is already being used.
Action: Start your listener with an unused address.
TNS-00513: Destination host unreachable
Cause: Contact cannot be made with remote party.
Action: Make sure the network driver is functioning and the network is up.
TNS-00514: Contexts have different wait/test functions
Cause: Two protocol adapters have conflicting wait/test functions.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-00515: Connect failed because target host or object does not exist
Cause: The address specified is not valid, or the program being connected to does not exist.
Action: Ensure the ADDRESS parameters have been entered correctly; the most likely incorrect parameter is the node name. Ensure that the executable for the server exists (perhaps "oracle" is missing.)
TNS-00516: Permission denied
Cause: User has insufficient privileges to perform the requested operation.
Action: Acquire necessary privileges and try again.
TNS-00517: Lost contact
Cause: Partner has unexpectedly gone away.
Action: Investigate partner application for abnormal termination.
TNS-00518: Incomplete read or write
Cause: A data send or receive failed.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-00519: Operating system resource quota exceeded
Cause: The current user has exceeded the allotted resource assigned in the operating system.
Action: Acquire more operating system resource, or perform a different function.
TNS-00520: Syntax error
Cause: The supplied connect descriptor contains illegal syntax.
Action: Check the syntax of the connect descriptor for correct syntax.
TNS-00521: Missing keyword
Cause: The supplied connect descriptor is missing one or more TNS keywords.
Action: Check the syntax, and ensure all required keywords are present.
TNS-00522: Operation was interrupted
Cause: An internal operation was interrupted and could not complete.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-00523: Previous operation was busy
Cause: Operation tried could not be successfully completed because the requested resource was busy.
Action: Attempt the operation again. If error persists, contact Oracle Customer Support.
TNS-00524: Current operation is still in progress
Cause: Internal operation is still in progress but will complete.
Action: None; wait for operation to complete.
TNS-00525: Insufficient privilege for operation
Cause: Operating system failed to complete operation because user lacked sufficient privileges.
Action: Check your platform-specific privileges.
TNS-00526: No caller (false async event)
Cause: Internal error.
Action: For further details, turn on tracing and reexecute the operation.
TNS-00527: Protocol Adapter not loadable
Cause: On some platforms (for example OS/2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter is missing or one of its supporting libraries is missing, then this error is returned.
Action: For further details, turn on tracing and reexecute the operation. The trace file will have the name of the shared library (or DLL) that could not be loaded.
TNS-00528: Protocol Adapter not loaded
Cause: On some platforms (for example OS/2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter has not been loaded, then this error is returned.
Action: For further details, turn on tracing and reexecute the operation. The trace file will have the name of the shared library (or DLL) that has not been loaded.
TNS-00530: Protocol adapter error
Cause: A generic protocol adapter error occurred.
Action: For further details, turn on tracing and reexecute the operation.
TNS-00532: No previous async operation to wait on
Cause: Internal protocol adapter error.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-00533: Connection dissolved or not yet made
Cause: Internal protocol adapter error.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-00534: Failed to grant connection ownership to child
Cause: Internal protocol adapter error.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-00535: Failed to send or receive disconnect message
Cause: Internal protocol adapter error.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-00536: Connection entered inappropriate state
Cause: Internal protocol adapter error.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-00537: Index into protocol adapter table is out of legal range
Cause: Internal protocol adapter error.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-00539: Network or Protocol services are down
Cause: The Network services on or from your node are not running or have stopped running.
Action: Restart your network or protocol services on this platform. If error persists, contact Oracle Customer Support.
TNS-00540: SSL protocol adapter failure
Cause: The SSL protocol adapter encountered an error.
Action: In most cases, this error should only be pair with a more meaningful ORA- error.
TNS-00541: underlying transport does not exist.
Cause: The SSL protocol adapter was unable to locate an adapter for the protocol that it is going to use as the data transport.
Action: In most cases, the underlying transport is TCP. Make sure that the Oracle Net TCP/IP adapter was installed.
TNS-00542: SSL Handshake failed
Cause: The SSL protocol adapter was unable to connect to another process.
Action: This error can be caused by a variety of problems including the termination of the peer process. Enable Oracle Net tracing and attempt the connection again. The trace file should give some clues as to what the exact problem is.
TNS-00543: internal error
Cause: The SSL protocol adapter encountered an unexpected error.
Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle customer support.
TNS-00544: unsupported operation
Cause: The SSL adapter could not perform a given command.
Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle customer support.
TNS-00545: parameter retrieval failure
Cause: The SSL protocol adapter was not able to retrieve a configuration parameter for some reason.
Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle customer support.
TNS-00546: control failure
Cause: The SSL protocol adapter was unable to perform a command.
Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle customer support.
TNS-00547: user information retrieval failed
Cause: The SSL protocol adapter was unable to retrieve information about the remote user.
Action: Examine the first error in the error stack. It should describe the error in more detail.
TNS-00548: value specified for client authentication parameter is not boolean
Cause: The value specified for the parameter that specifies that SSL client authentication is to be used was not boolean.
Action: Specify a correct value for the parameter.
TNS-00549: value specified for the SSL version is not valid
Cause: The value specified for the SSL version is not valid.
Action: Specify a valid value for the SSL version.
TNS-00550: disconnection error
Cause: The SSL protocol adapter encountered an error when the underlying transport disconnected.
Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle customer support.
TNS-00551: underlying transport connection failed
Cause: The underlying transport adapter used by the SSL adapter failed to connect.
Action: Enable Oracle Net tracing and try the connection again. If the connection fails, examine the trace file to determine the cause.
TNS-00552: no valid cipher suites were specified
Cause: SSL cipher specs were specified, but none were valid.
Action: Specify correct cipher suites.
TNS-00553: read failed
Cause: The SSL adapter failed to read data from its connection.
Action: Examine the contents of sqlnet.log for more information. Enable Oracle Net tracing and try the connection again. If the connection fails, examine the trace file to determine the cause.
TNS-00554: write failed
Cause: The SSL adapter failed to send data over its connection.
Action: Examine the contents of sqlnet.log for more information. Enable Oracle Net tracing and try the connection again. If the connection fails, examine the trace file to determine the cause.
TNS-00555: no directory specified for wallet resource locator
Cause: It was specified that a file was to be used from which to retrieve a wallet, but no directory was specified for the wallet.
Action: Specify the directory where the wallet is located.
TNS-00556: no method specified for wallet retrieval
Cause: A wallet resource locator was specified, but no method was given for the retrieval of the wallet.
Action: Specify the method by which the method is to be retrieved.
TNS-00557: unsupported wallet retrieval method
Cause: The method specified for wallet retrieval is not supported. Currently, only files are supported for wallet retrieval.
Action: Specify "FILE" as the wallet retrieval method.
TNS-00558: Entrust login failed
Cause: Entrust failed to authenticate the username, password, and/or profile name that was presented.
Action: Specify correct values for the username, password or profile name. If no data was prompted for, contact Oracle support.
TNS-00559: load of Entrust certificate failed
Cause: An error occurred while attempting to validate the provided Entrust certificate.
Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle customer support.
TNS-00560: extraction of name from Entrust certificate failed
Cause: An error occurred while attempting to extract a name from an Entrust certificate.
Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle customer support.
TNS-01000: spawn [<listener_name>] <spawn_alias> [<(ARGUMENTS='arg0, arg1,...')>]
Cause: Control program usage message.
Action: None.
TNS-01001: start [<listener_name>] : start listener
Cause: Control program usage message.
Action: None.
TNS-01002: stop [<listener_name>] : stop listener
Cause: Control program usage message.
Action: None.
TNS-01003: status [<listener_name>] : get the status of listener
Cause: Control program usage message.
Action: None.
TNS-01004: reload [<listener_name>] : reload the parameter files and SIDs
Cause: Control program usage message.
Action: None.
TNS-01005: trace OFF | USER | ADMIN | SUPPORT [<listener_name>] : set tracing to the specified level
Cause: Control program usage message.
Action: None.
TNS-01006: set password : set the password for subsequent calls
Cause: Control program usage message.
Action: None.
TNS-01007: quit | exit : exit LSNRCTL
Cause: Control program usage message.
Action: None.
TNS-01008: version [<listener_name>] : get the version information of the listener
Cause: Control program usage message.
Action: None.
TNS-01009: service [<listener_name>] : get the service information of the listener
Cause: Control program usage message.
Action: None.
TNS-01013: set|show trc_{ } [<value>]: set|show trace parameters of current listener
Cause: Control program usage message.
Action: None.
TNS-01014: set|show log_{ } [<value>]: set|show log parameters of current listener
Cause: Control program usage message.
Action: None.
TNS-01015: set|show parm_name [<value>]: sets|shows current listener parm values
Cause: Control program usage message.
Action: None.
TNS-01016: change_password [<listener_name>]: changes the password of the listener
Cause: Control program usage message.
Action: None.
TNS-01017: set|show current_listener [<listener_name>]: sets|shows current listener
Cause: Control program usage message.
Action: None.
TNS-01018: save_config [<listener_name>]: saves configuration changes to parameter file
Cause: Control program usage message.
Action: None.
TNS-01019: set rawmode ON | OFF: set output mode for services and status commands
Cause: Control program usage message.
Action: None.
TNS-01020: STATUS of the LISTENER
Cause: Control program status message.
Action: None.
TNS-01021: ------------------------
Cause: Control program status message.
Action: None.
TNS-01022: Alias string
Cause: Control program status message.
Action: None.
TNS-01023: Version string
Cause: Control program status message.
Action: None.
TNS-01024: Trace Level string
Cause: Control program status message.
Action: None.
TNS-01025: Security string
Cause: Control program status message.
Action: None.
TNS-01026: Start Date string
Cause: Control program status message.
Action: None.
TNS-01027: Listener Trace File string
Cause: Control program status message.
Action: None.
TNS-01028: Listener Log File string
Cause: Control program status message.
Action: None.
TNS-01029: Services Summary...
Cause: Control program status message.
Action: None.
TNS-01030: The listener supports no services
Cause: Control program status message.
Action: None.
TNS-01033: Listener Parameter File string
Cause: Control program status message.
Action: None.
TNS-01034: Uptime number days number hr. number min. number sec
Cause: Control program status message.
Action: None.
TNS-01036: %s established:string refused:string
Cause: Control program status message.
Action: None.
TNS-01037: "string" established:string refused:string
Cause: Control program status message.
Action: None.
TNS-01038: %s established:string refused:string current:string max:string state:string
Cause: Control program status message.
Action: None.
TNS-01039: %s has string service handler(s)
Cause: Control program status message.
Action: None.
TNS-01040: SNMP string
Cause: Control program status message.
Action: None.
TNS-01041: %s parameter "string" set to string
Cause: Control program status message.
Action: None.
TNS-01042: Current Listener is string
Cause: Control program status message.
Action: None.
TNS-01043: Password changed for string
Cause: Control program status message.
Action: None.
TNS-01044: %s(Registered) has string service handler(s)
Cause: Control program status message.
Action: None.
TNS-01045: %s(Not Registered) has string service handler(s)
Cause: Control program status message.
Action: None.
TNS-01046: Saved string configuration parameters.
Cause: Control program status message.
Action: None.
TNS-01047: Old Parameter File string
Cause: Control program status message.
Action: None.
TNS-01048: No changes to save for string.
Cause: Control program status message.
Action: None.
TNS-01049: %s (string) has string service handler(s)
Cause: Control program status message.
Action: None.
TNS-01050: %s
Cause: Control program general message.
Action: None.
TNS-01052: The command completed successfully
Cause: Control program general message.
Action: None.
TNS-01053: Connecting to string
Cause: Control program general message.
Action: None.
TNS-01054: Contacted the listener successfully
Cause: Control program general message.
Action: None.
TNS-01055: Successfully stopped the listener
Cause: Control program general message.
Action: None.
TNS-01057: Program name: string
Cause: Control program general message.
Action: None.
TNS-01058: Arguments : string
Cause: Control program general message.
Action: None.
TNS-01059: Environment : string
Cause: Control program general message.
Action: None.
TNS-01060: The password has has been set to: string
Cause: Control program general message.
Action: None.
TNS-01061: The password has not been set
Cause: Control program general message.
Action: None.
TNS-01062: The db subagent is already running.
Cause: Control program general message.
Action: None.
TNS-01063: The db subagent is not started.
Cause: Control program general message.
Action: None.
TNS-01064: Listener configuration changes will not be persistent
Cause: Configuration changes to the listener will not be visible when the listener starts up again as the check-pointing has been turned off in listener.ora
Action: Edit LISTENER.ORA setting USE_CKPFILE_LISTENER=true
TNS-01065: Raw mode is string
Cause: Control program general message.
Action: None.
TNS-01066: Presentation: string
Cause: Listener starting message.
Action: None.
TNS-01067: Service display mode is string
Cause: Control program general message.
Action: None.
TNS-01070: Starting string: please wait...
Cause: Listener starting message.
Action: None.
TNS-01071: %s is set to string
Cause: Listener starting message.
Action: None.
TNS-01072: Started at string
Cause: Listener starting message.
Action: None.
TNS-01073: Listening on: string
Cause: Listener starting message.
Action: None.
TNS-01074: Error listening on: string
Cause: Listener starting message.
Action: None.
TNS-01075: Opened log file: string
Cause: Listener starting message.
Action: None.
TNS-01076: Opened trace file: string
Cause: Listener starting message.
Action: None.
TNS-01077: Opened parameter file: string
Cause: Listener starting message.
Action: None.
TNS-01078: Opened name lookup file: string
Cause: Listener starting message.
Action: None.
TNS-01079: Attempted to bequeath: string
Cause: Listener starting message.
Action: None.
TNS-01080: Listener failed to start. See the error message(s) above...
Cause: Listener starting message.
Action: None.
TNS-01081: Started with pid=string
Cause: Listener starting message.
Action: None.
TNS-01082: Running in PROXY mode
Cause: Listener starting message.
Action: None.
TNS-01090: No longer listening on: string
Cause: Listener logging message.
Action: None.
TNS-01093: %s * string * number
Cause: Listener logging message.
Action: None.
TNS-01094: %s * number
Cause: Listener logging message.
Action: None.
TNS-01095: %s * string * string * number
Cause: Listener logging message.
Action: None.
TNS-01096: %s * string * string * string * string * number
Cause: Listener logging message.
Action: None.
TNS-01097: TIMESTAMP * CONNECT DATA [* PROTOCOL INFO] * EVENT [* SID] * RETURN CODE
Cause: Listener logging message.
Action: None.
TNS-01098: TIMESTAMP * CONNECT DATA * ADDRESS * [PRESENTATION *] COMMAND * ERROR TIMESTAMP * [INSTANCE NAME *] [ADDRESS *] [PRESENTATION *] COMMAND * ERROR -------------------------------------------------------------------------------
Cause: Listener logging message.
Action: None.
TNS-01099: %s * string * string * string * number
Cause: Listener logging message.
Action: None.
TNS-01100: TNS returned error number when attempting to start the listener
Cause: d by the fact that the TNSLSNR executable cannot be found in the place expected in your platform's ORACLE environment. Verify that the full pathname of the TNSLSNR executable as displayed by LSNRCTL is correct.
Action: If NS error code 12538 is also returned then the BEQ driver is not installed; call Oracle Worldwide Support as the BEQ driver should always be installed. If this is not the problem then the error is probably
TNS-01101: Could not find service name string
Cause: The ervice name could not be resolved by name-lookup.
Action: Verify that the listener name or service name specified to LSNRCTL has the correct name and address defined in LISTENER.ORA or in TNSNAMES.ORA.
TNS-01102: TNS application contacted was not the listener
Cause: Another TNS application such as the Interchange was listening at the address contacted. There may be another TNS application listening at the address contacted and the data returned is not in the appropriate format.
Action: Verify that the listener name or service name specified to LSNRCTL has the correct name and address defined in LISTENER.ORA or in TNSNAMES.ORA.
TNS-01103: Protocol specific component of the address is incorrectly specified
Cause: The ADDRESS used to contact the listener is not correctly specified. This error occurs because the address fails to specify the destination of the listener. The address is well formed (for example, there are no missing parentheses) but it is missing a protocol specific component. For example, this is the error returned when the HOST component is missing from a TCP/IP address string.
Action: Edit the ADDRESS in LISTENER.ORA to include the required protocol-specific keywords. For more information about the keywords required by different protocol adapters, see the Oracle operating system specific documentation for your platform.
TNS-01106: Listener using listener name string has already been started
Cause: Another listener is already listening on one of the ADDRESSes specified.
Action: Shutdown the previous listener specified by the listener name before starting this one.
TNS-01107: A valid trace level was not specified
Cause: Failed to specify a valid trace level for the LSNRCTL trace command.
Action: Specify one of OFF, USER, ADMIN, or SUPPORT. Type "LSNRCTL help trace" for more information or consult Chapter 2 of this manual for an introduction to the concepts of tracing.
TNS-01108: Listener password prompt failed
Cause: Password not entered via tty
Action: Enter the listener password on a tty device
TNS-01109: Listener password encryption failed
Cause: Possibly garbled password entered
Action: Re-enter the listener password, using valid ASCII characters. If problem persists, contact Oracle Customer Support.
TNS-01110: Mismatch - password unchanged
Cause: New password and reentered new password are different"
Action: Re-enter the listener password, make sure that New password and reentered new password are the same
TNS-01111: Log status can either be ON or OFF
Cause: Failed to specify a log status value for the LSNRCTL log_status command.
Action: Specify one of ON or OFF. Type "LSNRCTL help set log_status" for more information or consult Chapter 2 of this manual for an introduction to the concepts of logging.
TNS-01112: Plug and play can either be ON or OFF
Cause: Failed to specify a valid value for the LSNRCTL use_plugandplay command.
Action: Specify one of ON or OFF. Type "LSNRCTL help set use_plugandplay" for more information.
TNS-01113: save_config_on_stop can either be ON or OFF
Cause: Failed to specify a valid value for the LSNRCTL save_config_on_stop command.
Action: Specify one of ON or OFF. Type "LSNRCTL help set save_config_on_stop" for more information.
TNS-01114: LSNRCTL could not perform local OS authentication with the listener
Cause: LSNRCTL failed to obtain system resources (heap memory, or shared memory) needed to perform local OS authentication with the listener.
Action: Make sure that system resources like shared memory and heap memory are available for LSNRCTL tool to execute properly.
TNS-01150: The address of the specified listener name is incorrect
Cause: The address on which the listener attempted to listen contains a syntax error.
Action: For the listener name or service name specified to LSNRCTL, check that the address or connect descriptor is well-formed. You can find the listener name in LISTENER.ORA, or you can access the listener through the service name is TNSNAMES.ORA.
TNS-01151: Missing listener name, string, in LISTENER.ORA
Cause: The listener could not find the listener name specified.
Action: Make sure valid addresses on which to listen are specified for the listener name in LISTENER.ORA.
TNS-01152: All addresses specified for the listener name, string, failed
Cause: The listener failed to listen on any of the specified addresses.
Action: Make sure that another application is not listening on the addresses specified or check that the appropriate protocol adapters are installed. Turn on tracing and execute again for more information.
TNS-01153: Failed to process string: string
Cause: The string specified is not well-formed.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-01154: SID detected in old format that is no longer supported
Cause: One of the SIDs was specified in an obsolete format.
Action: Check LISTENER.ORA for a line of the form: <sid> = (SID=(ORACLE_HOME=<oracle_home>)) OR <sid> = (SID_DESC=(ORACLE_HOME=<oracle_home>)) The above format is no longer supported and SID_LIST_<listener_name> format described in the Oracle9i Net Services Reference Guide should be used. For example, SID_LIST_LISTENER = (SID_LIST=(SID_DESC=(SID_NAME=<sid>)(ORACLE_HOME=<oracle_home>)))
TNS-01155: Incorrectly specified SID_LIST_string parameter in LISTENER.ORA
Cause: SID_LIST_<listener_name> in LISTENER.ORA has an error in it.
Action: Be sure this parameter is specified as described in the Oracle9i Net Services Reference Guide. For example, SID_LIST_LISTENER = (SID_LIST=(SID_DESC=(SID_NAME=<sid>)(ORACLE_HOME=<oracle_home>)))
TNS-01156: Missing or inappropriate PROTOCOL, TIMEOUT or POOL_SIZE parameter from PRESPAWN_DESC
Cause: PRESPAWN_DESC in each SID_DESC does not have required fields.
Action: Be sure the parameters required for PRESPAWN_DESC are specified in each SID_DESC. For example, SID_LIST_LISTENER = (SID_LIST=(SID_DESC=(SID_NAME=<sid>)(PRESPAWN_MAX=5)(ORACLE_HOME=<oracle_home>)(PRESPAWN_DESC=(PROTOCOL=tcp)(POOL_SIZE=10)(TIMEOUT=30)))) Add or correct these parameters in the LISTENER.ORA file
TNS-01157: Can only listen on number addresses - ignoring string
Cause: Too many addresses were given to listen on.
Action: Reduce the number of addresses to listen on and use another listener to listen on the remaining addresses.
TNS-01158: Internal connection limit reached, preventing dispatcher from connecting
Cause: The internal Oracle Net connection list is full. Too many dispatchers are connected to the listener; therefore, no more dispatchers are allowed to connect.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-01159: Internal connection limit has been reached; listener has shut down
Cause: The internal Oracle Net connection list is full. The listener is configured to use too many Oracle Net connections.
Action: Reduce the number of listen addresses or services connected to the listener. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-01160: Trace level was not specified
Cause: Failed to specify a trace level for the trace command.
Action: Specify one of OFF, USER, ADMIN, or SUPPORT. Users should not see this error if LSNRCTL is being used.
TNS-01161: Spawn alias string was not found. Check listener parameter file
Cause: The alias specified to spawn a program was not found in LISTENER.ORA.
Action: This is not seen in normal use of Oracle Net.
TNS-01162: Syntax error in the address resolved from the spawn alias: string
Cause: The alias specified to spawn a program was not a valid NVstring.
Action: This is not seen in normal use of Oracle Net.
TNS-01163: Failed to spawn process: string
Cause: The process failed to start correctly.
Action: This is not seen in normal use of Oracle Net.
TNS-01164: No spawn alias sent to listener
Cause: The spawn command was issued without an alias.
Action: This is not seen in normal use of Oracle Net.
TNS-01165: Spawn alias has no program name set in it
Cause: The spawn alias in LISTENER.ORA is incorrectly specified.
Action: This is not seen in normal use of Oracle Net.
TNS-01167: The command string is not supported by the listener contacted
Cause: The listener does not recognize the command.
Action: This is caused when a newer version of LSNRCTL contacts an old listener. Upgrade listener if executing this command is important.
TNS-01168: Cannot allocate memory
Cause: Sufficient memory could not be allocated to perform the desired activity.
Action: Either free some resource for TNS, or add more memory to the machine. For further details, turn on tracing and reexecute the operation.
TNS-01169: The listener has not recognized the password
Cause: The listener has the password security mechanism enabled and requires the correct password to execute any command other than VERSION. The user attempted to issue one of the privileged administrative commands, but could not be successfully authenticated with the password provided.
Action: If an authorized user is attempting the command, then use the SET PASSWORD command at the LSNRCTL prompt with the listener password. If you do not know the password, then you are trying to execute an inappropriate command.
TNS-01170: Event detection broke for address: string
Cause: The event detection mechanism for the address specified returned an error.
Action: Future attempts to detect events on this address will fail. The listener will deallocate the listen address and connections will no long be accepted for this address. This error is not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-01171: Event detection broke for dispatcher: string
Cause: The event detection mechanism for the dispatcher specified returned an error.
Action: Future attempts to detect events on this dispatcher will fail. The listener will deallocate the dispatcher and connections will no long be redirected to this dispatcher. This error is not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-01172: Listener has shut down since all listen addresses have been deallocated
Cause: The event detection mechanism broke and caused all listen addresses to be removed.
Action: Error 1170 has occured and caused all the listen addresses to be deallocated. Since all the listen addresses have been removed, no more connections can be established to this listener so it shuts itself down. This error is not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-01173: Missing or inappropriate PRESPAWN_MAX parameter from SID_DESC
Cause: PRESPAWN_MAX in each SID_DESC does not have required fields.
Action: Be sure the parameters required for PRESPAWN_DESC are specified in each SID_DESC. For example, SID_LIST_LISTENER = (SID_LIST=(SID_DESC=(SID_NAME=<sid>)(PRESPAWN_MAX=15)(ORACLE_HOME=<oracle_home>)(PRESPAWN_DESC=(PROTOCOL=tcp)(POOL_SIZE=10)(TIMEOUT=30)))) Add or correct these parameters in the LISTENER.ORA file
TNS-01174: The sum of the POOL_SIZEs from each PRESPAWN_DESC is greater than the PRESPAWN_MAX
Cause: The minimum value for PRESPAWN_MAX should be the sum of the POOL_SIZEs.
Action: Be sure the parameters required for PRESPAWN_DESC are specified in each SID_DESC. For example, SID_LIST_LISTENER = (SID_LIST=(SID_DESC=(SID_NAME=<sid>)(PRESPAWN_MAX=15)(ORACLE_HOME=<oracle_home>)(PRESPAWN_DESC=(PROTOCOL=tcp)(POOL_SIZE=10)(TIMEOUT=30))(PRESPAWN_DESC=(PROTOCOL=ipc)(POOL_SIZE=5)(TIMEOUT=15)))) Add or correct these parameters in the LISTENER.ORA file
TNS-01175: Password unchanged
Cause: Unable to set the new password
Action: Be sure to see that the new password has legal ASCII characters. Try to set the password again.
TNS-01176: Error in loading the new parameter value
Cause: Illegal values given for the parameters
Action: Make sure that the parameter values are valid refer to the manual for the legal values for paramters
TNS-01177: Log Status is OFF. Log file/directory unchanged
Cause: Log status needs to be set ON for changing the log file
Action: use command set log_status ON to set the log status of the listener ON.
TNS-01178: Trace Level is 0. Trace file/directory unchanged
Cause: Trace Level needs to be set for changing the trace file/directory
Action: use command set trc_level ON to set the trace level
TNS-01179: Listener cannot load instance class "string"
Cause: Instance tried to register as a class unknown to listener.
Action: check LISTENER.ORA and/or instance configuration, and reference platform documentation to find the instance classes available for the listener on this platform.
TNS-01180: Missing listener object string in Directory Server
Cause: The listener could not find the listener object specified.
Action: Make sure the listener object is present in the Directory Server.
TNS-01181: Internal registration connection limit reached
Cause: The number of registration connections has reached the maximum. No more registrations are allowed until some of the existing registration connections are completed.
Action: Disconnect existing registration connections if they are no longer needed.
TNS-01182: Listener rejected registration of service "string"
Cause: Received registration information could not be processed because it was invalid, or an internal error occurred.
Action: Not normally visible to the user. For further details, turn on tracing and restart the instance. If error persists, contact Oracle Customer Support.
TNS-01183: Listener rejected registration or update of instance "string"
Cause: Received registration or update information could not be processed because it was invalid, or an internal error occurred.
Action: Not normally visible to the user. For further details, turn on tracing and restart the instance. If error persists, contact Oracle Customer Support.
TNS-01184: Listener rejected registration or update of service handler "string"
Cause: Received registration or update information could not be processed because it was invalid, or an internal error occurred.
Action: Not normally visible to the user. For further details, turn on tracing and restart the instance. If error persists, contact Oracle Customer Support.
TNS-01185: Registration attempted from a remote node
Cause: It was determined that the registering instance is not located on the same node as the listener. It is required that the instance be colocated with the listener for this type of service registration.
Action: Check the configuration of the registering instance. Ensure that local_listener parameter specifies only local listeners. Use remote_listener parameter to specify remote listeners.
TNS-01186: Client connection was dropped based on a filtering rule
Cause: Listener was configured with a filtering rule which explicitly specified that the client connection should be terminated without returning an error to the client.
Action: Modify the filtering rules if the client should be allowed access to the requested service.
TNS-01187: No proxy service handler available
Cause: One of the following conditions has occurred:

- the proxy service was not registered

- the proxy service was registered, but was blocking new connections

- all of the registered proxy service handlers were blocking new connections

Action: If the proxy service is not registered it may need to be restarted. If the proxy service handlers are busy and not accepting new connections more of them may need to be started to handle the load.
TNS-01188: Listener cannot operate with incompatible transport protocols
Cause: Listener was configured with multiple listening addresses with different and incompatible transport protocols. Listener cannot operate efficiently in such configuration.
Action: Modify the existing listener configuration by removing the listening address that caused the error. Configure a separate listener to listen on this address.
TNS-01189: The listener could not authenticate the user
Cause: The user attempted to issue a privileged administrative command, but could not be successfully authenticated by the listener using the local OS authentication mechanism. This may occur due to one of the following reasons:

1. The user is running a version of LSNRCTL that is lower than the version of the listener.

2. The user is attempting to administer the listener from a remote node.

3. The listener could not obtain the system resources needed to perform the authentication.

4. The local network connection between the listener and LSNRCTL was terminated unexpectedly during authentication message exchange, such as if LSNRCTL program was suddenly aborted.

5. The communication between the listener and LSNRCTL is being intercepted by a malicious user.

6. The software that the user is running is not following the authentication protocol, indicating a malicious user.

Action: Make sure that administrative commands are issued using the LSNRCTL tool that is of a version equal or greater than the version of the listener, and that the tool and the listener are running on the same node. You can issue the VERSION command to find out the version of the listener. If a malicious user is suspected, use the information provided in the listener log file to determine the source and nature of the requests. Enable listener tracing for more information. If the error persists, contact Oracle Support Services.
TNS-01190: The user is not authorized to execute the requested listener command
Cause: Most of the listener administrative commands are only intended to be issued by privileged users, for example DBAs or system administrators. If the listener password is not set, then the listener only accepts administrative requests from LSNRCTL running with the same OS credentials, or running as a local administrator (also referred to as super user).
Action: If an authorized user is attempting the command, then make sure that LSNRCTL is executed with the same OS user credentials as the running listener, or as a local administrator.
TNS-01191: Failed to initialize the local OS authentication subsystem
Cause: Initialization of the security subsystem failed during listener startup or reload. The listener could not obtain system resources (memory, or file descriptors) needed for local OS authentication security mechanism.
Action: Make sure that system resources like shared memory and heap memory are available for listener to execute properly. For further details, turn on tracing and execute the operation again. If the error persists, contact Oracle Support Services.
TNS-01200: The listener must be suid root
Cause: The ownership privileges of the TNSLSNR executable are incorrect.
Action: Contact your DBA or system administrator to change the ownership of the file to be suid root and restart the listener. This action is necessary because the user that started the process should claim ownership.
TNS-01201: Listener cannot find executable string for SID string
Cause: The executable for the Oracle dedicated server process cannot be found.
Action: Check the appropriate SID_DESC in LISTENER.ORA to make sure that the ORACLE_HOME component is pointing to a valid location. If this component is not set, then check the value of the ORACLE_HOME environment variable.
TNS-01202: Missing the dba group (string) specified by DBA_GROUP in SID_DESC
Cause: The dba group specified is missing from /ETC/GROUP.
Action: Check the DBA_GROUP parameter in the SID_DESC in LISTENER.ORA and verify it has a valid entry in /ETC/GROUP.
TNS-01203: Missing the account (string) specified by DEFAULT_USER_ACCOUNT in SID_DESC
Cause: The unprivileged OS account is missing from /etc/passwd.
Action: Check the DEFAULT_USER_ACCOUNT parameter in the SID_DESC in LISTENER.ORA and verify it has a valid entry in /etc/passwd. This is the account that the Oracle shadow process will be started with if the the connecting client has database privileges or does not exist on this machine.
TNS-01204: Unprivileged account (string) is in dba group (string)
Cause: The unprivileged account has DBA privileges. The unprivileged account specified by DEFAULT_USER_ACCOUNT in the SID_DESC in LISTENER.ORA is a member of the dba group specified by DBA_GROUP in SID_DESC. The unprivileged account cannot belong to the dba group because this would be a security violation with OPS$ logins.
Action: Remove the unprivileged account from the dba group.
TNS-01300: ERROR at string
Cause: Listener logging message.
Action: None.
TNS-01301: TNS error structure:
Cause: Listener logging message.
Action: None.
TNS-01302: nr err code: number
Cause: Listener logging message.
Action: None.
TNS-01303: ns main err code: number
Cause: Listener logging message.
Action: None.
TNS-01304: ns secondary err code: number
Cause: Listener logging message.
Action: None.
TNS-01305: nt main err code: number
Cause: Listener logging message.
Action: None.
TNS-01306: nt secondary err code: number
Cause: Listener logging message.
Action: None.
TNS-01307: nt OS err code: number
Cause: Listener logging message.
Action: None.
TNS-01400: Instance "string" has number handlers.
Cause: Control program status message.
Action: None.
TNS-01401: Class: string
Cause: Control program status message.
Action: None.
TNS-01402: TYPE: string
Cause: Control program status message.
Action: None.
TNS-01403: Load: string
Cause: Control program status message.
Action: None.
TNS-01404: Max Load: string
Cause: Control program status message.
Action: None.
TNS-01405: Host: string
Cause: Control program status message.
Action: None.
TNS-01406: ID: string
Cause: Control program status message.
Action: None.
TNS-01407: Status: string Total handlers: string Relevant handlers: string
Cause: Control program status message.
Action: None.
TNS-01408: Instance "string", status string, has string handler(s) for this service...
Cause: Control program status message.
Action: None.
TNS-01409: Instance "string"
Cause: Control program status message.
Action: None.
TNS-01410: Service "string" has number instances.
Cause: Control program status message.
Action: None.
TNS-01411: Service "string" has number instance(s).
Cause: Control program status message.
Action: None.
TNS-01412: Handler(s):
Cause: Control program status message.
Action: None.
TNS-01413: "string" established:string refused:string current:string max:string state:string
Cause: Control program status message.
Action: None.
TNS-01414: "string", state string, established string, refused string, current string, max string
Cause: Control program status message.
Action: None.
TNS-01415: Listening Endpoints Summary...
Cause: Control program status message.
Action: None.
TNS-01416: Process ID string
Cause: Control program status message.
Action: None.
TNS-01417: "string" established:string refused:string state:string
Cause: Control program status message.
Action: None.
TNS-01418: Proxy service "string" has number instance(s).
Cause: Control program status message.
Action: None.
TNS-01420: Presentation: string
Cause: Control program status message.
Action: None.
TNS-01421: Session: string
Cause: Control program status message.
Action: None.
TNS-01441: Number of filtering rules currently in effect: number
Cause: Control program status message
Action: None
TNS-01442: No filtering rules currently in effect.
Cause: Control program status message
Action: None
TNS-02020: set displaymode RAW | COMPAT | NORMAL | VERBOSE: output mode for lsnrctl display
Cause: Control program usage message.
Action: None.
TNS-02021: DIRECT_HANDOFF can be either ON or OFF.
Cause: Invalid value for the LSNRCTL direct_handoff parameter.
Action: Specify one of ON or OFF.
TNS-02022: show rules: Show rules that are currently in effect
Cause: Control program usage message.
Action: None.
TNS-02401: gbname string too long, allowed number characters
Cause: gbname or domain name too long.
Action: Check the gbname parameter in listener.ora, shorten it.
TNS-02402: Bad CLBGNAMES parameter in tnsnames.ora
Cause: CLBGNAMES parameter in tnsnames.ora is bad.
Action: Check the CLBGNAMES parameter format and correct it. Make sure that the tnsnames.ora file is there.
TNS-02403: Bad alias string or alias not present in tnsnames.ora
Cause: An alias was expected in tnsnames.ora but was not found or was not correctly formed.
Action: Check the tnsnames.ora for the alias and make sure it is correctly formed.
TNS-02404: Service string contains no local handlers
Cause: The listener found no suitable handler to redirect to.
Action: Make sure that there is at least one handler for this node.
TNS-02405: GMS call failed, check GMS logs.
Cause: A GMS call made by the listener failed.
Action: Check if the GMS is up and running. See GMS-client trace files for more information.
TNS-02501: Authentication: no more roles
Cause: When a process attempted to retrieve a role from the authentication service, no more were available.
Action: None. This error is used internally and occurs in the normal course of events.
TNS-02502: Authentication: unable to find initialization function
Cause: The native authentication service was unable to call the initialization function for the specified service because it does not exist.
Action: If this service adaptor came directly from Oracle, contact Oracle Customer Support, as this error should never happen. Otherwise, add an initialization function for the service being used.
TNS-02503: Parameter retrieval failed
Cause: The native service layer was unable to retrieve a parameter from a configuration file.
Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Customer Support.
TNS-02504: Parameter count retrieval failed
Cause: The native service layer was unable to determine the number of arguments given for a configuration parameter.
Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Customer Support.
TNS-02505: Authentication: null context pointer provided
Cause: The function nau_ini() was passed a null pointer as the pointer to the context that it is supposed to use.
Action: Call nau_ini() with a pointer to a context structure.
TNS-02506: Authentication: no type string
Cause: An authentication context structure does not contain a string that describes the authentication service being used.
Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Customer Support.
TNS-02507: Encryption: algorithm not installed
Cause: After picking an algorithm, the server was unable to find an index for it in its table of algorithms. This should be impossible because the algorithm was chosen (indirectly) from that list.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-02508: Encryption: server negotiation response in error
Cause: The server's response in negotiation was in error.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-02509: Authentication: invalid process state
Cause: The state in which a process is running does not correspond to any of the values which are valid.
Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Customer Support.
TNS-02510: Invalid numeric data type
Cause: The type of a piece of numeric data that was received does not correspond to one of the valid values.
Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Customer Support.
TNS-02511: Invalid data type
Cause: The type of a piece of data that was received or to be transmitted did not correspond to any of the correct values.
Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Customer Support.
TNS-02512: Invalid status received
Cause: A process received a value as a status flag which was unknown.
Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Customer Support.
TNS-02513: Requested data type does not match retrieved type
Cause: A service requested data whose type does not match that of the segment which was sent from the other process.
Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Customer Support.
TNS-02514: Invalid packet received
Cause: A process received a data packet which was not meant for the native services layer.
Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Customer Support.
TNS-02515: Encryption/crypto-checksumming: unknown control type
Cause: An encryption or crypto-checksumming algorithm "control" function was called, but did not recognize the "type" argument it was given.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-02516: No data available
Cause: A native service attempted to retrieve data but no data was available to be received.
Action: The error is not normally visible as it usually is only used to signal the end of a data stream. If the error becomes visible, enable tracing to reproduce the problem and contact Oracle Customer Support.
TNS-02517: key smaller than requested size
Cause: The key returned by negotiation was smaller than the size requested by some service (either encryption or crypto-checksumming).
Action: The error is not normally visible. If the error persists, enable tracing to reproduce the problem and contact Oracle Customer Support.
TNS-02518: key negotiation error
Cause: An error occurred while the two sides of the connection were negotiating an encryption or crypto-checksumming key.
Action: The error is not normally visible. If the error persists, enable tracing to reproduce the problem and contact Oracle Customer Support.
TNS-02519: no appropriate key-negotiation parameters
Cause: No appopriate key-negotiation parameters are available for the key size requested either by encryption or by crypto- checksumming.
Action: The error is not normally visible. Enable tracing to reproduce the problem and contact Oracle Customer Support.
TNS-02520: encryption/crypto-checksumming: no Diffie-Hellman seed
Cause: The "sqlnet.crypto_seed" parameter is missing from the SQLNET.ORA parameters file for Oracle Advanced Security.
Action: Add this line to SQLNET.ORA: sqlnet.crypto_seed = "randomly-chosen text"
TNS-02521: encryption/crypto-checksumming: Diffie-Hellman seed too small
Cause: The "sqlnet.crypto_seed" parameter in the SQLNET.ORA parameter file for Oracle Net is too small.
Action: Add more randomly-chosen text to it.
TNS-02524: Authentication: privilege check failed
Cause: An error occurred when the Oracle Advanced Security authentication service attempted to verify that a user had a specific database privilege.
Action: This error should not happen normally. Enable tracing and attempt to repeat the error. Contact Customer Support.
TNS-02525: encryption/crypto-checksumming: self test failed
Cause: The Oracle Advanced Security encryption/crypto-checksumming service detected an error while running tests on the active encryption or checksumming algorithm.
Action: Contact Customer Support.
TNS-02526: server proxy type does not match client type
Cause: The authentication type selected by the server does not match that picked by the client.
Action: Contact Oracle Customer Support
TNS-03501: OK
Cause: The operation succeeded.
Action: No action necessary.
TNS-03502: Insufficient arguments. Usage: tnsping <address> [<count>]
Cause: Some required command-line arguments are missing.
Action: Re-enter the command using the correct arguments.
TNS-03503: Could not initialize NL
Cause: The network library could not be initialized.
Action: This is an internal error which should not normally be visible. Ensure that memory is available to run the application and that there are no other operating system problems, and then attempt the command again.
TNS-03504: Service name too long
Cause: The service name you are attempting to ping is too long.
Action: Re-enter the command using the correct service name.
TNS-03505: Failed to resolve name
Cause: The service name you provided could not be found in TNSNAMES.ORA, an Oracle Names server, or a native naming service.
Action: Verify that you entered the service name correctly. You may need to ensure that the name was entered correctly into the network configuration.
TNS-03506: Failed to create address binding
Cause: The TNSPING utility found the requested address or service name, but received an internal error when trying to use it.
Action: This is an internal error which should not normally be visible. Ensure that memory is available to run the application and that there are no other operating system problems, and then attempt the command again.
TNS-03507: Failure looking for ADDRESS keyword
Cause: The TNS address did not contain an ADDRESS keyword.
Action: If you entered the TNS address on the command line, be sure that the syntax is correct. If you entered a service name on the command line, the address contains the wrong information. You should verify that the information was entered correctly.
TNS-03508: Failed to create address string
Cause: The TNSPING utility received an internal error when generating an address.
Action: This is an internal error which should not normally be visible. Ensure that memory is available to run the application and that there are no other operating system problems, and then attempt the command again.
TNS-03509: OK (number msec)
Cause: The operation succeeded, in this amount of time.
Action: No action necessary.
TNS-03510: Failed due to I/O error
Cause: An I/O operation failed, perhaps due to a resource failure or premature window termination.
Action: This is an internal error which should not normally be visible. Do not close the TNSPING window before all I/O operations have completed.
TNS-03511: Used parameter files: string
Cause: Prints out the path of the parameter files(sqlnet.ora,tnsnames.ora) used in the process of resolving the NAME.
Action: NONE
TNS-03512: Used string adapter to resolve the alias
Cause: Prints out the name of the adapter which resolved the TNS alias.
Action: NONE
TNS-03601: Failed in route information collection
Cause: The route could either not connect, or encountered an unsupported version of Oracle Net.
Action: Check if Oracle Net along all nodes is version 2.3 or greater.
TNS-03602: Insufficient arguments. Usage: trcroute <address>
Cause: Some required command-line arguments are missing.
Action: Re-enter the command using the correct arguments.
TNS-03603: Encountered a node with a version eariler than SQL*Net 2.3
Cause: Versions of SQL*Net before 2.3 do not support trcroute.
Action: Find the node that isn't responding to trcroute.
TNS-04001: %s
Cause: CMCTL general message.
Action: None.
TNS-04002: The command completed successfully.
Cause: Not applicable.
Action: None
TNS-04003: Syntax Error.
Cause: The command issued has a wrong syntax.
Action: Check for the command issue syntax, and correct the problem.
TNS-04004: Unable to encrypt the supplied password.
Cause: The password that was supplied to the ADMINISTER command could not be encrypted.
Action: Change the password to something acceptable. See Oracle Net Services documentation for valid password values.
TNS-04005: Unable to resolve address for string.
Cause: The alias name supplied with the ADMINISTER command could not be resolved to an Oracle Connection Manager address.
Action: Check if your an entry for the alias is present in either CMAN.ORA file or in TNSNAMES.ORA file.
TNS-04006: Invalid password
Cause: The password given with the ADMINISTER command could not be verified by the Oracle Connection Manager instance.
Action: Retry with the correct password.
TNS-04007: Internal error number.
Cause: Not normally visible to the user.
Action: If error persists, contact Oracle Support Services.
TNS-04008: %-25s | string
Cause: String parameter value.
Action: None.
TNS-04009: %-25s | number
Cause: Integer parameter value.
Action: None.
TNS-04010: Command cannot be issued before the ADMINISTER command.
Cause: A command was issued before administering the Oracle Connection Manager instance.
Action: Enter the ADMINISTER command before retrying this command.
TNS-04011: Oracle Connection Manager instance not yet started.
Cause: A command was issued when Oracle Connection Manager was not yet started or already shutdown.
Action: Start Oracle Connection Manager.
TNS-04012: Unable to start Oracle Connection Manager instance.
Cause: CMCTL was unable to start the Oracle Connection Manager instance. Some of the possible reasons include: cmadmin not present in ORACLE_HOME/bin, Invalid parameter in configuration repository, wrong parameter values, or log directory not present.
Action: 1. Check whether log directory is present, and is writable. Log directory can be found at ORACLE_HOME/network.101/log, or as specified by the LOG_DIRECTORY parameter in CMAN.ORA.

2. Turn on logging or tracing to get more information about this error.

3. Correct any parameter errors (or mismatched paranthesis), and retry starting Oracle Connection Manager.

4. If the problem persists, contact Oracle Support Services.

TNS-04013: CMCTL timed out waiting for Oracle Connection Manager to start
Cause: Oracle Connection Manager internal registrations have not been completed.
Action: Turn on logging or tracing to get more information about this error. If the problem persists, contact Oracle Support Services.
TNS-04014: Current instance string is already started
Cause: An ADMINISTER command was issued to administer an Oracle Connection Manager instance that is already started.
Action: None
TNS-04015: Current instance string is not yet started
Cause: An ADMINISTER command was issued to an instance that has not yet been started.
Action: None
TNS-04016: Connecting to string
Cause: CMCTL is connecting to the the specified Oracle Connection Manager address.
Action: None
TNS-04017: Please wait. Shutdown in progress.
Cause: A command which cannot be used while Oracle Connection Manager is shutting down was issued.
Action: Wait for some time before retrying the command.
TNS-04018: Instance already started
Cause: The STARTUP command was issued to an instance which was already started.
Action: None
TNS-04019: Starting Oracle Connection Manager instance string. Please wait...
Cause: The STARTUP command was issued for an Oracle Connection Manager instance. CMCTL is waiting for the instance to start.
Action: None
TNS-04020: CMCTL Version: number.number.number.number.number
Cause: None.
Action: None.
TNS-04021: The SET command is unsuccessful for parameter string.
Cause: The value set for the parameter was out of range.
Action: See Oracle Net Services documentation for value ranges for the parameters.
TNS-04022: %s parameter string set to string.
Cause: Parameter value was successfully set.
Action: None
TNS-04023: Command failed.
Cause: The command issued failed to complete successfully.
Action: Retry command. If problem persists, contact Oracle Support Services.
TNS-04037: Connections refer to string.
Cause: The ADMINISTER command resolved to the address in the specified message string.
Action: None
TNS-04044: Specified gateways do not exist.
Cause: One or more specified gateway IDs do not exist.
Action: Specify correct gateway IDs.
TNS-04045: Invalid specification of time
Cause: The time specified with the GT (greater than) option was invalid.
Action: Check Oracle Net Services documentation for valid time specification.
TNS-04046: Invalid specification for source
Cause: The source specified with the FROM option was invalid.
Action: Check Oracle Net Services documentation for valid source specification.
TNS-04047: Invalid specification for destination
Cause: The destination specified with the TO option was invalid.
Action: Check Oracle Net Services documentation for valid destination specification.
TNS-04048: Specified service does not exist.
Cause: The service specified with the FOR option did not exist.
Action: None
TNS-04049: Specified connections do not exist
Cause: One or more connection IDs do not exist.
Action: None
TNS-04050: Invalid specification for gateway ID.
Cause: The gateway ID specified is invalid.
Action: Check Oracle Net Services documentation for a valid gateway ID specification.
TNS-04063: Remote administration disabled in the Oracle Connection Manager instance.
Cause: CMCTL attempted to connect to a remote Oracle Connection Manager instance in which remote administration was disabled.
Action: Set parameter remote_admin=on in the remote instance before starting it.
TNS-04064: The number of CMCTL sessions exceeds MAX_CMCTL_SESSIONS.
Cause: The Oracle Connection Manager instance already has MAX_CMCTL_SESSIONS number of CMCTLs connected to it.
Action: Use an already connected CMCTL, or, use a higher value for the parameter MAX_CMCTL_SESSIONS in the CMAN.ORA file.
TNS-04065: The number of remote CMCTL sessions exceeds (MAX_CMCTL_SESSIONS-1)
Cause: The Oracle Connection Manager instance already has (MAX_CMCTL_SESSIONS-1) number of remote CMCTL sessions connected to it.
Action: Use an already connected CMCTL, or, use a higher value for the parameter MAX_CMCTL_SESSIONS in the CMAN.ORA file.
TNS-04066: The following log events can be enabled or disabled:
Cause: None
Action: None
TNS-04067: Number of connections: number.
Cause: Either no information qualifier (COUNT/DETAIL) was present in SHOW CONNECTIONS command, or, COUNT was used as the information qualifier.
Action: None
TNS-04068: Cannot start an Oracle Connection Manager instance remotely.
Cause: CMCTL was used to start Oracle Connection Manager instance in a remote host.
Action: Use a local CMCTL to start the Oracle Connection Manager.
TNS-04069: Sleeping for number seconds...
Cause: CMCTL is idle for specified seconds. This feature is only provided for testing purposes.
Action: None
TNS-04070: Cannot administer a remote Oracle Connection Manager instance which is not yet started.
Cause: An attempt was made to administer a remote Oracle Connection Manager instance which is not yet started.
Action: Use a local CMCTL session to start the Oracle Connection Manager instance before trying to administer it remotely.
TNS-04071: Connections closed successfully. Number closed: number.
Cause: The specified connections were closed successfully.
Action: None
TNS-04072: Unable to suspend atleast one of the gateways.
Cause: CMCTL was unable to suspend one or more gateways. Possible reason could be suspending a gateway that was already suspended or suspending a gateway that was not present.
Action: Turn on tracing and logging, retry operation. Information in the log files would help.
TNS-04073: Passwords do not match.
Cause: The new password and its confirmation do not match
Action: Use SET PASSWORD again.
TNS-04074: Invalid value for the parameter string.
Cause: The parameter value set using the SET command is invalid.
Action: See Oracle Net Services documentation for the valid values of the parameter.
TNS-04075: Cannot use ADMINISTER directly from the command line.
Cause: ADMINISTER can only be issued from the CMCTL> prompt.
Action: Use the -c option with any command instead of ADMINISTER.
TNS-04076: Invalid specification for state.
Cause: The state specified with "in" option is invalid.
Action: Check Oracle Net Services documentation for valid state specification.
TNS-04077: WARNING: No password set for the Oracle Connection Manager instance.
Cause: A connection to the Oracle Connection Manager instance was made with no password from the user.
Action: Ignore the warning if the Oracle Connection Manager is secure enough. Otherwise, use SET PASSWORD command to set a new password for the instance.
TNS-04078: Unable to resume atleast one of the gateways.
Cause: CMCTL was unable to resume one or more gateways. Possible reason could be resuming a gateway that was ready for connections, or resuming a gateway that was not present.
Action: Turn on tracing and logging, retry operation. Information in the log files would help.
TNS-04079: Cannot administer Oracle Connection Manager with no CMAN.ORA, and port = number.
Cause: CMAN.ORA is not present or address not configured in CMAN.ORA, and the net service name in the TNSNAMES.ORA contains a nondefault Oracle Connection Manager port.
Action: Either change the TNSNAMES.ORA entry to use the default port, or configure the CMAN.ORA file with the Oracle Connection Manager's address.
TNS-04080: Failed to reload
Cause: Oracle Connection Manager failed to reload the new configuration due to errors in the configuration file.
Action: Set log_level to support and retry operation. Error encountered will be logged in the log file of CMADMIN.
TNS-04081: Event groups:
Cause: None
Action: None
TNS-04082: %s event string set to string.
Cause: Event value was successfully set.
Action: None
TNS-04083: Failed to save password
Cause: Oracle Connection Manager failed to save the password in the configuration file.
Action: Check for the permissions on the configuration file. The file should have WRITE permissions.
TNS-04084: WARNING: Non-reloadable parameters have retained their values.
Cause: Values of non-reloadable parameters were changed, or, one or more non-reloadable parameters having non-default values were added to the parameter file.
Action: See Oracle Net Services documentation for a list of non-reloadable parameters.
TNS-04085: Password not changed since last save.
Cause: Password has not been changed since it was last saved.
Action: None
TNS-04086: Invalid value for the event string.
Cause: The event value set using the SET EVENT command is invalid.
Action: See Oracle Net Services documentation for the valid values of the event.
TNS-04087: Unable to shutdown atleast one of the gateways.
Cause: CMCTL was unable to shutdown one or more gateways. Possible reason could be shutting down a gateway that was not present.
Action: Turn on tracing and logging, retry operation. Information in the log files would help.
TNS-04088: Unable to close atleast one of the connections.
Cause: CMCTL was unable to close one or more connections. Possible reason could be closing a connection that was not present.
Action: Turn on tracing and logging, retry operation. Information in the log files would help.
TNS-04140: Migration completed successfully.
Cause: CMMIGR has successfully completed the migration of the old CMAN.ORA file to the new format.
Action: None
TNS-04141: Unable to find CMAN.ORA file.
Cause: CMMIGR was not able to find CMAN.ORA file.
Action: Check whether CMAN.ORA file is present in $TNS_NAME/admin, or in $ORACLE_HOME/network.101/admin, or in the path specified in the command line.
TNS-04142: CMAN.ORA file has an invalid format.
Cause: CMMIGR was unable to recognize the format of CMAN.ORA file.
Action: Check for the syntax errors in CMAN.ORA file, and correct them.
TNS-04143: Unable to write the new CMAN.ORA file.
Cause: CMMIGR was unable to create the new CMAN.ORA file due to insufficient perimissions.
Action: Set WRITE permissions to the directory in which CMAN.ORA file is to be written.
TNS-04144: Nothing to migrate
Cause: CMMIGR did not find anything in the old CMAN.ORA file that has an equivalent in the new format.
Action: None
TNS-04201: Trace Assistant Usage ERROR: Missing File name
Cause: Trace file name argument is missing
Action: Put the trace file name as the last command line argument for for this tool.
TNS-04202: Trace Assistant Usage ERROR: Not enough arguments
Cause: The <file name> and/or the <options> arguments are missing
Action: Put the right number of command line arguments.
TNS-04203: Trace Assistant Usage ERROR: Invalid options
Cause: The options provided are not valid
Action: Check the valid options for this tool.
TNS-04204: Trace Assistant Internal ERROR: Couldn't Open trace file
Cause: The trace file name given doesn't exist or it is not accessible for this user.
Action: Check the spelling, and permissions of the trace file.
TNS-04205: Trace Assistant Internal ERROR: Memory
Cause: Possible memory problem
Action: Verify the amount of available memory on the system.
TNS-04206: Trace Assistant Internal ERROR: Packet Type
Cause: The packet type read by trcAsst is not valid.
Action: Verify that your trace file is not corrupted. If trace file looks OK, with not strange characters in it, contact World Wide Support and provide trace file to them.
TNS-04207: Trace Assistant Internal ERROR: Packet Length
Cause: The packet being decode is corrupted.
Action: Verify that your trace file is not corrupted. If trace file looks OK, with not strange characters in it, contact World Wide Support and provide trace file to them.
TNS-04208: Trace Assistant Internal ERROR: Fatal
Cause: Fatal internal error
Action: Contact World Wide Support.
TNS-04209: Trace Assistant Internal ERROR: Type Error
Cause: Internal type error,
Action: Contact World Wide Support.
TNS-04210: Trace Assistant Internal ERROR: End of File
Cause: Reaching End of File to soon. Not able to decode trace file. Your trace file appears to be truncated.
Action: Generate another trace file. This trace file can not be decoded.
TNS-04211: Trace Assistant Internal ERROR: CORE
Cause: Internal System Error
Action: Contact World Wide Support.
TNS-04212: Trace Assistant Internal ERROR: NACOM Type Error
Cause: Not able to decode Network Authentication information
Action: Contact World Wide Support.
TNS-04231: Trace Assistant WARNING: Assuming Oracle trace format
Cause: This trace file may not be a Network trace file. The default format (Oracle Trace) will be assumed.
Action: None.
TNS-04232: Trace Assistant WARNING: Not retrieving all rows
Cause: Trace Assitante won't retrieve all the rows data.
Action: None.
TNS-04233: Trace Assistant WARNING: Going beyond Packet length
Cause: Trying to read beyond packet length. The trace file may be corrupted
Action: None.
TNS-04234: Trace Assistant WARNING: won't decode TTC
Cause: Trace assistant does not have enough information to decode TTC data. This maybe an old trace file or from a platform that trace assistant does not understand.
Action: None.
TNS-04235: Trace Assistant WARNING: Unknown TTC protocol
Cause: Trace Assistant has reached a point in which the TTC protocol can not be understood.
Action: None.
TNS-12150: TNS:unable to send data
Cause: Unable to send data. Connection probably disconnected.
Action: Reestablish connection. If the error is persistent, turn on tracing and reexecute the operation.
TNS-12151: TNS:received bad packet type from network layer
Cause: Internal error.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
TNS-12152: TNS:unable to send break message
Cause: Unable to send break message. Connection probably disconnected.
Action: Reestablish connection. If the error is persistent, turn on tracing and reexecute the operation.
TNS-12153: TNS:not connected
Cause: Not currently connected to a remote host.
Action: Reestablish connection.
TNS-12154: TNS:could not resolve the connect identifier specified
Cause: A connection to a database or other service was requested using a connect identifier, and the connect identifier specified could not be resolved into a connect descriptor using one of the naming methods configured. For example, if the type of connect identifier used was a net service name then the net service name could not be found in a naming method repository, or the repository could not be located or reached.
Action:

- If you are using local naming (TNSNAMES.ORA file):

- Make sure that "TNSNAMES" is listed as one of the values of the NAMES.DIRECTORY_PATH parameter in the Oracle Net profile (SQLNET.ORA)

- Verify that a TNSNAMES.ORA file exists and is in the proper directory and is accessible.

- Check that the net service name used as the connect identifier exists in the TNSNAMES.ORA file.

- Make sure there are no syntax errors anywhere in the TNSNAMES.ORA file. Look for unmatched parentheses or stray characters. Errors in a TNSNAMES.ORA file may make it unusable.

- If you are using directory naming:

- Verify that "LDAP" is listed as one of the values of the NAMES.DIRETORY_PATH parameter in the Oracle Net profile (SQLNET.ORA).

- Verify that the LDAP directory server is up and that it is accessible.

- Verify that the net service name or database name used as the connect identifier is configured in the directory.

- Verify that the default context being used is correct by specifying a fully qualified net service name or a full LDAP DN as the connect identifier

- If you are using easy connect naming:

- Verify that "EZCONNECT" is listed as one of the values of the NAMES.DIRETORY_PATH parameter in the Oracle Net profile (SQLNET.ORA).

- Make sure the host, port and service name specified are correct.

- Try enclosing the connect identifier in quote marks. See the Oracle Net Services Administrators Guide or the Oracle operating system specific guide for more information on naming.

TNS-12155: TNS:received bad datatype in NSWMARKER packet
Cause: Internal error during break handling.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
TNS-12156: TNS:tried to reset line from incorrect state
Cause: Internal error during break handling.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
TNS-12157: TNS:internal network communication error
Cause: Internal error during network communication.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
TNS-12158: TNS:could not initialize parameter subsystem
Cause: Unable to locate parameter file.
Action: Verify that a valid parameter file exists, and is readable.
TNS-12159: TNS:trace file not writeable
Cause: The trace file to be generated is not writeable by this user.
Action: If the user does not have write permissions in the directory to which the trace file will be written, contact an administrator to get the proper permissions or set the TRACE_DIRECTORY_CLIENT parameter in the net profile (SQLNET.ORA file) to a directory the user can write to.
TNS-12160: TNS:internal error: Bad error number
Cause: Corrupt error reporting subsystem.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
TNS-12161: TNS:internal error: partial data received
Cause: The connection may be terminated.
Action: Reconnect and try again. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
TNS-12162: TNS:net service name is incorrectly specified
Cause: The connect descriptor corresponding to the net service name in TNSNAMES.ORA or in the directory server (Oracle Internet Directory) is incorrectly specified.
Action: If using local naming make sure there are no syntax errors in the corresponding connect descriptor in the TNSNAMES.ORA file. If using directory naming check the information provided through the administration used for directory naming.
TNS-12163: TNS:connect descriptor is too long
Cause: The connect descriptor corresponding to the net service name specified as the connect identifier is too long. The maximum length for a connect descriptor is 512 bytes and this limit has been exceeded.
Action: Check the net service name's connect descriptor in the local naming file (TNSNAMES.ORA) or in the directory server (Oracle Internet Directory). Use a smaller connect descriptor. If this is not possible, contact Worldwide Customer Support.
TNS-12164: TNS:Sqlnet.fdf file not present
Cause: The sqlnet.fdf file doesn't exist in $ORACLE_HOME/network.101/admin.
Action: The sqlnet.fdf file is required for Oracle Tracing to occur. Either install the sqlnet.fdf file in $ORACLE_HOME/network.101/admin or turn off tracing in your ORA file.
TNS-12165: TNS:Trying to write trace file into swap space.
Cause: Oracle Trace doesn't allow writing trace information into your swap space.
Action: Oracle Trace cannot write trace information into swap space so either disable tracing or redirect trace files to be written to another area of your disk.
TNS-12166: TNS:Client can not connect to HO agent.
Cause: NVstring contained DESCRIPTION/HO.
Action: Call HO agent from integrating server.
TNS-12168: TNS:Unable to contact LDAP Directory Server
Cause: Cannot contact LDAP directory server to get Oracle Net configuration.
Action: Verify that the directory server is up and accessible from the network. Verify that directory access configuration is correct. For more information see the Oracle Internet Directory Administrators Guide or the Oracle Net Administrators Guide.
TNS-12169: TNS:Net service name given as connect identifier is too long
Cause: The net service name you are attempting to resolve is too long.
Action: The maximum length of a net service name is 255 bytes; this limit has been exceeded. Use a smaller net service name. If this is not possible, contact Worldwide Customer Support.
TNS-12170: TNS:Connect timeout occurred
Cause: The server shut down because connection establishment or communication with a client failed to complete within the allotted time interval. This may be a result of network or system delays; or this may indicate that a malicious client is trying to cause a Denial of Service attack on the server.
Action: If the error occurred because of a slow network or system, reconfigure one or all of the parameters SQLNET.INBOUND_CONNECT_TIMEOUT, SQLNET.SEND_TIMEOUT, SQLNET.RECV_TIMEOUT in sqlnet.ora to larger values. If a malicious client is suspected, use the address in sqlnet.log to identify the source and restrict access. Note that logged addresses may not be reliable as they can be forged (e.g. in TCP/IP).
TNS-12171: TNS:could not resolve connect identifier: string
Cause: A connection to a database or other service was requested using a connect identifier, and the connect identifier specified could not be resolved into a connect descriptor using one of the naming methods configured. For example, if the type of connect identifier used was a net service name then the net service name could not be found in a naming method repository, or the repository could not be located or reached.
Action:

- If you are using local naming (TNSNAMES.ORA file):

- Make sure that "TNSNAMES" is listed as one of the values of the NAMES.DIRECTORY_PATH parameter in the Oracle Net profile (SQLNET.ORA)

- Verify that a TNSNAMES.ORA file exists and is in the proper directory and is accessible.

- Check that the net service name used as the connect identifier exists in the TNSNAMES.ORA file.

- Make sure there are no syntax errors anywhere in the TNSNAMES.ORA file. Look for unmatched parentheses or stray characters. Errors in a TNSNAMES.ORA file may make it unusable.

- If you are using directory naming:

- Verify that "LDAP" is listed as one of the values of the NAMES.DIRETORY_PATH parameter in the Oracle Net profile (SQLNET.ORA).

- Verify that the LDAP directory server is up and that it is accessible.

- Verify that the net service name or database name used as the connect identifier is configured in the directory.

- Verify that the default context being used is correct by specifying a fully qualified net service name or a full LDAP DN as the connect identifier

- If you are using easy connect naming:

- Verify that "EZCONNECT" is listed as one of the values of the NAMES.DIRETORY_PATH parameter in the Oracle Net profile (SQLNET.ORA).

- Make sure the host, port and service name specified are correct.

- Try enclosing the connect identifier in quote marks. See the Oracle Net Services Administrators Guide or the Oracle operating system specific guide for more information on naming.

TNS-12196: TNS:received an error from TNS
Cause: The navigation layer received an error from TNS.
Action: See the error log file for the specific TNS error.
TNS-12197: TNS:keyword-value resolution error
Cause: The navigation layer received an error while trying to look up a value for a keyword.
Action: Check the syntax of the connect descriptor.
TNS-12198: TNS:could not find path to destination
Cause: Could not navigate a path through Interchanges to the destination. This error occurs if an invalid community is in the address string, or the address includes a protocol that is not available or the TNSNAV.ORA file does not have a correct CMANAGER address specified or the Interchange is down.
Action: Assure that Interchanges necessary to get to the desired destination are up and have available capacity for an additional connection. Also check that the correct community and protocol have been specified in the CMANAGER address used.
TNS-12200: TNS:could not allocate memory
Cause: Out of memory on machine.
Action: Reconfigure machine to have more storage or run fewer applications while the Interchange is running.
TNS-12201: TNS:encountered too small a connection buffer
Cause: TNS connection buffer supplied by the application was too small to retrieve the data sent back.
Action: Supply a larger connection buffer. If problem persists, call Worldwide Customer Support.
TNS-12202: TNS:internal navigation error
Cause: Internal navigation error.
Action: Not normally visible to the user. For further details contact Worldwide Customer Support.
TNS-12203: TNS:unable to connect to destination
Cause: Invalid address specified or destination is not listening. This error can also occur because of underlying network or network transport problems.
Action: Verify that the net service name you entered was correct. Verify that the ADDRESS portion of the connect descriptor which corresponds to the net service name is correct. Ensure that the destination process (for example the listener) is running at the remote node.
TNS-12204: TNS:received data refused from an application
Cause: The application using Connection Manager refused the connection at the listener.
Action: Make sure that the application listener at the destination is functioning correctly. If it is and the problem persists, contact Worldwide Customer Support.
TNS-12205: TNS:could not get failed addresses
Cause: Internal navigation error.
Action: Not normally visible to the user. For further details contact Worldwide Customer Support.
TNS-12206: TNS:received a TNS error during navigation
Cause: Internal navigation error because of an unexpected TNS error.
Action: Look at the log file to find the TNS error. If necessary, turn on tracing and repeat the operation.
TNS-12207: TNS:unable to perform navigation
Cause: Improperly configured navigation file TNSNAV.ORA.
Action: Check the syntax of the TNSNAV.ORA file on the application`s machine, and verify that it lists the correct communities.
TNS-12208: TNS:could not find the TNSNAV.ORA file
Cause: Either the ORACLE environment is not set up correctly, or the TNSNAV.ORA file is not present.
Action: Ensure that the ORACLE environment is set up appropriately on your platform and that a TNSNAV.ORA file is present.
TNS-12209: TNS:encountered uninitialized global
Cause: Application calling navigation routine has not properly configured the global variables. There are no TNSNAV.ORA files available, or they are defective.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Worldwide Customer Support.
TNS-12210: TNS:error in finding Navigator data
Cause: Application calling navigation routine has not properly configured the TNSNAV.ORA file.
Action: Check the syntax of the TNSNAV.ORA file.
TNS-12211: TNS:needs PREFERRED_CMANAGERS entry in TNSNAV.ORA
Cause: TNSNAV.ORA does not have a PREFERRED_CMANAGERS defined.
Action: Add a PREFERRED_CMANAGERS entry to the TNSNAV.ORA file.
TNS-12212: TNS:incomplete PREFERRED_CMANAGERS binding in TNSNAV.ORA
Cause: The PREFERRED_CMANAGERS binding in the client's TNSNAV.ORA file does not have a CMANAGER_NAME specified.
Action: Define the CMANAGER_NAME as part of the PREFERRED_CMANAGERS binding. Use of the Oracle Network Manager should eliminate this error.
TNS-12213: TNS:incomplete PREFERRED_CMANAGERS binding in TNSNAV.ORA
Cause: The PREFERRED_CMANAGERS binding in the client's TNSNAV.ORA file does not have an ADDRESS specified.
Action: Define the ADDRESS as part of the PREFERRED_CMANAGERS binding.
TNS-12214: TNS:missing local communities entry in TNSNAV.ORA
Cause: There is no LOCAL_COMMUNITIES entry in TNSNAV.ORA.
Action: Define the LOCAL_COMMUNITIES for this node in the TNSNAV.ORA file.
TNS-12215: TNS:poorly formed PREFERRED_NAVIGATORS Addresses in TNSNAV.ORA
Cause: Address binding for PREFERRED_NAVIGATORS entry is improperly entered. entry.
Action: Check your PREFERRED_NAVIGATORS entry and fix it in TNSNAV.ORA
TNS-12216: TNS:poorly formed PREFERRED_CMANAGERS addresses in TNSNAV.ORA
Cause: Address binding for the PREFERRED_CMANAGERS entry in the client's TNSNAV.ORA file is improperly entered.
Action: Define the ADDRESS as part of the PREFERRED_CMANAGERS binding.
TNS-12217: TNS:could not contact PREFERRED_CMANAGERS in TNSNAV.ORA
Cause: There is a syntax error in the PREFERRED_CMANAGERS entry, or addresses specified are wrong, or the intended Connection Managers are unavailable.
Action: Check the PREFERRED_CMANAGERS entries in the client's TNSNAV.ORA file and correct them or talk with your network administrator to determine if the specified Connection Managers are available. Verify that the Interchanges are active by using the INTCTL STATUS command.
TNS-12218: TNS:unacceptable network configuration data
Cause: Poorly formed network configuration data. For example, a PREFERRED_CMANAGERS entry may have an incorrect CMANAGER_NAME in the client's TNSNAV.ORA file. Or an Interchange downtime parameter (TIMEOUT_INTERVAL) on the Navigator may be set to zero in INTCHG.ORA.
Action: Check the entries in TNSNAV.ORA and the Interchange configuration files and correct them. If necessary, talk with your network administrator to determine if the specified Interchanges (Connection Managers) are available and properly configured. Use the Oracle Network Manager to generate the configuration files if necessary.
TNS-12219: TNS:missing community name from address in ADDRESS_LIST
Cause: This error occurs when an ADDRESS_LIST has some ADDRESSes in it that have no COMMUNITY component and others that do have a COMMUNITY component.
Action: Check that in the connect descriptors you are using either all the ADDRESSes have a COMMUNITY component or all do not.
TNS-12221: TNS:illegal ADDRESS parameters
Cause: An illegal set of protocol adapter parameters was specified. In some cases, this error is returned when a connection cannot be made to the protocol transport.
Action: Verify that the destination can be reached using the specified protocol. Check the parameters within the ADDRESS section of TNSNAMES.ORA or in the directory. Legal ADDRESS parameter formats may be found in the Oracle operating system specific documentation or the Oracle Net Administrator's Guide. Protocols that resolve names at the transport layer are vulnerable to this error if not properly configured or names are misspelled.
TNS-12222: TNS:no support is available for the protocol indicated
Cause: The protocol requested in the ADDRESS portion of the connect descriptor identified through the net service name is not available. If the supplied ADDRESS is typographically correct then support for that protocol is not installed.
Action: Install support for the protocol or correct typographical error, as appropriate. Note: if the supplied address was derived from resolving the net service name, check the address in the appropriate file (TNSNAMES.ORA, LISTENER.ORA) or in the directory server.
TNS-12223: TNS:internal limit restriction exceeded
Cause: Too many TNS connections open simultaneously.
Action: Wait for connections to close and re-try.
TNS-12224: TNS:no listener
Cause: The connection request could not be completed because the listener is not running.
Action: Ensure that the supplied destination address matches one of the addresses used by the listener - compare the TNSNAMES.ORA entry with the appropriate LISTENER.ORA file (or TNSNAV.ORA if the connection is to go by way of an Interchange). Start the listener on the remote machine.
TNS-12225: TNS:destination host unreachable
Cause: Contact can not be made with remote party.
Action: Make sure the network driver is functioning and the network is up.
TNS-12226: TNS:operating system resource quota exceeded
Cause: The current user has exceeded the allotted resource assigned in the operating system.
Action: Acquire more operating system resource, or perform a different function.
TNS-12227: TNS:syntax error
Cause: The supplied connect descriptor contains illegal syntax.
Action: Check the syntax of the connect descriptor in TNSNAMES.ORA.
TNS-12228: TNS:protocol adapter not loadable
Cause: On some platforms (such as Windows) protocol support is loaded at run-time. If the shared library (or DLL) for the protocol adapter is missing or one of its supporting libraries is missing then this error is returned.
Action: For further details, turn on tracing and reexecute the operation. The trace file will include the name of the shared library (or DLL) that could not be loaded.
TNS-12229: TNS:Interchange has no more free connections
Cause: One or more Interchanges along the path to the destination desired has no more free connections available to be used for this call.
Action: Try again later when the Interchanges are less busy, or contact your network administrator to have him determine which interchange it is, and increase the number of connections available on that interchange.
TNS-12230: TNS:Severe Network error occurred in making this connection
Cause: This error is reported by an interchange which fails to make contact with the destination due to a physical network error while calling a destination.
Action: Try again later when the network service may have been fixed or report the problem to your Network Administrator so that he may fix the problem.
TNS-12231: TNS:No connection possible to destination
Cause: This error is reported by an interchange which fails to find a possible connection along the path to the destination.
Action: Report the problem to your Network Administrator so that he may fix the problem.
TNS-12232: TNS:No path available to destination
Cause: This error is reported by an interchange which fails to find a possible path to the destination.
Action: Report the problem to your Network Administrator so that he may fix the problem.
TNS-12233: TNS:Failure to accept a connection
Cause: This error is reported by an interchange which fails to accept a connection due to a redirect failure.
Action: Report the problem to your Network Administrator so that he may isolate the interchange problem.
TNS-12234: TNS:Redirect to destination
Cause: This error is reported by an interchange which determines that this interchange is not the right gateway and needs to redirect the connection to another gateway along the path to the destination.
Action: None.
TNS-12235: TNS:Failure to redirect to destination
Cause: This error is reported by an interchange which fails to redirect a connection to another interchange along the path to the destination.
Action: Report the problem to your Network Administrator so that he may fix the problem.
TNS-12236: TNS:protocol support not loaded
Cause: On some platforms (such as Windows) protocol support is loaded at run-time. If the shared library (or DLL) for the protocol adapter has not been loaded, then this error is returned.
Action: For further details, turn on tracing and reexecute the operation. The trace file will have the name of the shared library (or DLL) that has not been loaded.
TNS-12500: TNS:listener failed to start a dedicated server process
Cause: The process of starting up a dedicated server process failed. The executable could not be found or the environment may be set up incorrectly.
Action: Turn on tracing at the ADMIN level and reexecute the operation. Verify that the ORACLE Server executable is present and has execute permissions enabled. Ensure that the ORACLE environment is specified correctly in LISTENER.ORA. The Oracle Protocol Adapter that is being called may not be installed on the local hard drive. Please check that the correct Protocol Adapter are successfully linked. If error persists, contact Oracle Customer Support.
TNS-12502: TNS:listener received no CONNECT_DATA from client
Cause: No CONNECT_DATA was passed to the listener.
Action: Check that the service name resolved from TNSNAMES.ORA has the CONNECT_DATA component of the connect descriptor.
TNS-12504: TNS:listener was not given the SID in CONNECT_DATA
Cause: The SID was missing from the CONNECT_DATA.
Action: Check that the connect descriptor corresponding to the service name in TNSNAMES.ORA has an SID component in the CONNECT_DATA.
TNS-12505: TNS:listener does not currently know of SID given in connect descriptor
Cause: The listener received a request to establish a connection to a database or other service. The connect descriptor received by the listener specified a SID for an instance (usually a database instance) that either has not yet dynamically registered with the listener or has not been statically configured for the listener. This may be a temporary condition such as after the listener has started, but before the database instance has registered with the listener.
Action:

- Wait a moment and try to connect a second time.

- Check which instances are currently known by the listener by executing: lsnrctl services <listener name>

- Check that the SID parameter in the connect descriptor specifies an instance known by the listener.

- Check for an event in the listener.log file.

TNS-12508: TNS:listener could not resolve the COMMAND given
Cause: d by incompatible Oracle Net or Net8 versions. Do not include in error manual.
Action: This is not seen in normal use of Oracle Net.
TNS-12509: TNS:listener failed to redirect client to service handler
Cause: The dispatcher terminated unexpectedly
Action: Attempt to connect again and if the same error occurs, contact the DBA to check the state of the dispatchers for this SID. If the problem persists, turn on tracing in the listener to determine the TNS error caused by the redirect.
TNS-12510: TNS:database temporarily lacks resources to handle the request
Cause: The dispatchers appear to be busy handling other requests.
Action: Attempt the connection again. If error persists, ask the DBA to increase the number of dispatchers and/or dispatchers' limit on number of connections/sessions that they can accept.
TNS-12511: TNS:service handler found but it is not accepting connections
Cause: The dispatchers notified the listener that they temporarily do not accept new connections.
Action: Attempt the connection again. If error persists, contact the DBA to check the state of the dispatchers and/or ask him to increase the number of dispatchers.
TNS-12513: TNS:service handler found but it has registered for a different protocol
Cause: The dispatchers registered for this service are connected to the listener by way of a different network protocol than that of the client.
Action: Contact the DBA to register a dispatcher on your protocol.
TNS-12514: TNS:listener does not currently know of service requested in connect descriptor
Cause: The listener received a request to establish a connection to a database or other service. The connect descriptor received by the listener specified a service name for a service (usually a database service) that either has not yet dynamically registered with the listener or has not been statically configured for the listener. This may be a temporary condition such as after the listener has started, but before the database instance has registered with the listener.
Action:

- Wait a moment and try to connect a second time.

- Check which services are currently known by the listener by executing: lsnrctl services <listener name>

- Check that the SERVICE_NAME parameter in the connect descriptor of the net service name used specifies a service known by the listener.

- If an easy connect naming connect identifier was used, check that the service name specified is a service known by the listener.

- Check for an event in the listener.log file.

TNS-12515: TNS:listener could not find a handler for this presentation
Cause: None of the listener's known service handlers are registered as supporting the presentation protocol required by the connecting client.
Action: Check that the destination service is configured to accept the presentation protocol.
TNS-12516: TNS:listener could not find available handler with matching protocol stack
Cause: None of the known and available service handlers for the given SERVICE_NAME support the client's protocol stack: transport, session, and presentation protocols.
Action: Check to make sure that the service handlers (e.g. dispatchers) for the given SERVICE_NAME are registered with the listener, are accepting connections, and that they are properly configured to support the desired protocols.
TNS-12518: TNS:listener could not hand off client connection
Cause: The process of handing off a client connection to another process failed.
Action: Turn on listener tracing and re-execute the operation. Verify that the listener and database instance are properly configured for direct handoff. If problem persists, call Oracle Support.
TNS-12519: TNS:no appropriate service handler found
Cause: The listener could not find any available service handlers that are appropriate for the client connection.
Action: Run "lsnrctl services" to ensure that the instance(s) have registered with the listener, and are accepting connections.
TNS-12520: TNS:listener could not find available handler for requested type of server
Cause: None of the known and available service handlers for requested type of server (dedicated or shared) are appropriate for the client connection.
Action: Run "lsnrctl services" to ensure that the instance(s) have registered with the listener and that the appropriate handlers are accepting connections.
TNS-12521: TNS:listener does not currently know of instance requested in connect descriptor
Cause: The listener received a request to establish a connection to a database or other service. The connect descriptor received by the listener specified in addition to the service name an instance name for an instance (usually a database instance) that either has not yet dynamically registered with the listener or has not been statically configured for the listener. This may be a temporary condition such as after the listener has started, but before the database instance has registered with the listener.
Action:

- Wait a moment and try to connect a second time.

- Check which instances are currently known by the listener by executing: lsnrctl services <listener name>

- Check that the INSTANCE_NAME parameter in the connect descriptor specifies an instance name known by the listener.

- Check for an event in the listener.log file.

TNS-12522: TNS:listener could not find available instance with given INSTANCE_ROLE
Cause: There are not any available and appropriate database instances registered with the listener, that are part of the service identified by SERVICE_NAME given in the connect descriptor and that have the specified INSTANCE_ROLE (and INSTANCE_NAME, if specified).
Action: Check to make sure that the INSTANCE_ROLE specified is correct. Run "lsnrctl services" to ensure that the instance(s) have registered with the listener and that they are ready to accept connections.
TNS-12523: TNS:listener could not find instance appropriate for the client connection
Cause: The listener could not find any available (database) instances, that are appropriate for the client connection.
Action: Run "lsnrctl services" to ensure that the instance(s) are registered with the listener, and have status READY.
TNS-12524: TNS:listener could not resolve HANDLER_NAME given in connect descriptor
Cause: The HANDLER_NAME in the CONNECT_DATA was not found in the listener's tables for the specified SERVICE_NAME and INSTANCE_NAME.
Action: Check to make sure that the HANDLER_NAME specified is correct.
TNS-12525: TNS:listener has not received client's request in time allowed
Cause: The listener disconnected the client because the client failed to provide the necessary connect information within the allowed time interval. This may be a result of network or system delays; or this may indicate that a malicious client is trying to cause a Denial of Service attack on the listener.
Action: If the error occurred because of a slow network or system, reconfigure INBOUND_CONNECT_TIMEOUT to a larger value. If a malicious client is suspected, use the address in listener.log to identify the source and restrict access. Turn on tracing for more information.
TNS-12526: TNS:listener: all appropriate instances are in restricted mode
Cause: Database instances supporting the service requested by the client were in restricted mode. The Listener does not allow connections to instances in restricted mode. This condition may be temporary, such as during periods when database administration is performed.
Action: Attempt the connection again. If error persists, then contact the database administrator to change the mode of the instance, if appropriate.
TNS-12527: TNS:listener: all instances are in restricted mode or blocking new connections
Cause: All appropriate database instances supporting the service requested by the client reported that they either were in restricted mode or were blocking the new connections. The Listener does not allow connections to such instances. This condition may be temporary, such as at instance startup.
Action: Attempt the connection again. If error persists, then contact the database administrator to check the status of the instances.
TNS-12528: TNS:listener: all appropriate instances are blocking new connections
Cause: All instances supporting the service requested by the client reported that they were blocking the new connections. This condition may be temporary, such as at instance startup.
Action: Attempt the connection again. If error persists, then contact the administrator to check the status of the instances.
TNS-12529: TNS:connect request rejected based on current filtering rules
Cause: Connection Manager and its listener were configured with filtering rules specifying that the connect request be rejected.
Action: If this connect request should be allowed, then contact the administrator to modify the filtering rules.
TNS-12531: TNS:cannot allocate memory
Cause: Sufficient memory could not be allocated to perform the desired activity.
Action: Either free some resource for TNS, or add more memory to the machine. For further details, turn on tracing and reexecute the operation.
TNS-12532: TNS:invalid argument
Cause: An internal function received an invalid parameter.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12533: TNS:illegal ADDRESS parameters
Cause: An illegal set of protocol adapter parameters was specified. In some cases, this error is returned when a connection cannot be made to the protocol transport.
Action: Verify that the destination can be reached using the specified protocol. Check the parameters within the ADDRESS section of TNSNAMES.ORA. Legal ADDRESS parameter formats may be found in the Oracle operating system specific documentation for your platform. Protocols that resolve names at the transport layer (such as DECnet object names) are vulnerable to this error if not properly configured or names are misspelled.
TNS-12534: TNS:operation not supported
Cause: An internal function received a request to perform an operation that is not supported (on this machine).
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12535: TNS:operation timed out
Cause: The requested operation could not be completed within the time out period.
Action: Look at the documentation on the secondary errors for possible remedy. See SQLNET.LOG to find secondary error if not provided explicitly. Turn on tracing to gather more information.
TNS-12536: TNS:operation would block
Cause: An internal operation did not commence because to do so would block the current process and the user has requested that operations be non-blocking.
Action: None needed; this is an information message.
TNS-12537: TNS:connection closed
Cause: "End of file" condition has been reached; partner has disconnected.
Action: None needed; this is an information message.
TNS-12538: TNS:no such protocol adapter
Cause: The protocol adapter requested (by way of the "(PROTOCOL=..)" keyword-value pair in a TNS address) is unknown. If the supplied address is typographically correct then the protocol adapter is not installed.
Action: Install the protocol adapter or correct typographically error, as appropriate. Note: if the supplied address was derived from resolving the service name, check the address in the appropriate file (TNSNAMES.ORA, LISTENER.ORA or SQLNET.ORA).
TNS-12539: TNS:buffer over- or under-flow
Cause: Buffer too small for incoming data or too large for outgoing data.
Action: This restriction (which is associated with CONNECT DATA) is not normally visible to the user. For further details, turn on tracing and reexecute the operation; contact Oracle Customer Support.
TNS-12540: TNS:internal limit restriction exceeded
Cause: Too many TNS connections open simultaneously.
Action: Wait for connections to close and re-try.
TNS-12541: TNS:no listener
Cause: The connection request could not be completed because the listener is not running.
Action: Ensure that the supplied destination address matches one of the addresses used by the listener - compare the TNSNAMES.ORA entry with the appropriate LISTENER.ORA file (or TNSNAV.ORA if the connection is to go by way of an Interchange). Start the listener on the remote machine.
TNS-12542: TNS:address already in use
Cause: Specified listener address is already being used.
Action: Start your listener with a unique address.
TNS-12543: TNS:destination host unreachable
Cause: Contact can not be made with remote party.
Action: Make sure the network driver is functioning and the network is up.
TNS-12544: TNS:contexts have different wait/test functions
Cause: Two protocol adapters have conflicting wait/test functions.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12545: Connect failed because target host or object does not exist
Cause: The address specified is not valid, or the program being connected to does not exist.
Action: Ensure the ADDRESS parameters have been entered correctly; the most likely incorrect parameter is the node name. Ensure that the executable for the server exists (perhaps "oracle" is missing.) If the protocol is TCP/IP, edit the TNSNAMES.ORA file to change the host name to a numeric IP address and try again.
TNS-12546: TNS:permission denied
Cause: User has insufficient privileges to perform the requested operation.
Action: Acquire necessary privileges and try again.
TNS-12547: TNS:lost contact
Cause: Partner has unexpectedly gone away, usually during process startup.
Action: Investigate partner application for abnormal termination. On an Interchange, this can happen if the machine is overloaded.
TNS-12548: TNS:incomplete read or write
Cause: A data send or receive failed.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12549: TNS:operating system resource quota exceeded
Cause: The current user has exceeded the allotted resource assigned in the operating system.
Action: Acquire more operating system resource, or perform a different function.
TNS-12550: TNS:syntax error
Cause: The supplied connect descriptor contains illegal syntax.
Action: Check the syntax of the connect descriptor in TNSNAMES.ORA.
TNS-12551: TNS:missing keyword
Cause: The supplied connect descriptor is missing one or more TNS keywords.
Action: Check the syntax, and ensure all required keywords are present.
TNS-12552: TNS:operation was interrupted
Cause: An internal operation was interrupted and could not complete.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12554: TNS:current operation is still in progress
Cause: An internal operation is still in progress.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12555: TNS:permission denied
Cause: User has insufficient privileges to perform the requested operation.
Action: Acquire necessary privileges and try again.
TNS-12556: TNS:no caller
Cause: TNS detected an incoming connect request but there was no caller.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12557: TNS:protocol adapter not loadable
Cause: On some platforms (such as OS/2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter is missing or one of its supporting libraries is missing then this error is returned.
Action: For further details, turn on tracing and reexecute the operation. The trace file will include the name of the shared library (or DLL) that could not be loaded.
TNS-12558: TNS:protocol adapter not loaded
Cause: On some platforms (such as OS/2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter has not been loaded, then this error is returned.
Action: For further details, turn on tracing and reexecute the operation. The trace file will have the name of the shared library (or DLL) that has not been loaded.
TNS-12560: TNS:protocol adapter error
Cause: A generic protocol adapter error occurred.
Action: Check addresses used for proper protocol specification. Before reporting this error, look at the error stack and check for lower level transport errors. For further details, turn on tracing and reexecute the operation. Turn off tracing when the operation is complete.
TNS-12561: TNS:unknown error
Cause: A generic protocol error occurred.
Action: For further details, turn on tracing and reexecute the operation.
TNS-12562: TNS:bad global handle
Cause: Internal error - bad 'gbh' argument passed to TNS from caller. System may have been linked with old libraries.
Action: Not normally visible to the user, contact Oracle Customer Support.
TNS-12564: TNS:connection refused
Cause: The connect request was denied by the remote user (or TNS software).
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation.
TNS-12566: TNS:protocol error
Cause: An unexpected TNS protocol error has occurred.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12569: TNS:packet checksum failure
Cause: The data received is not the same as the data sent.
Action: Attempt the transaction again. If the error is persistent, turn on tracing and reexecute the operation.
TNS-12570: TNS:packet reader failure
Cause: An error occurred during a data receive.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12571: TNS:packet writer failure
Cause: An error occurred during a data send.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12574: TNS:redirection denied
Cause: The connect request failed because it would have required redirection and the caller has requested no redirections.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12582: TNS:invalid operation
Cause: An internal function received an invalid request.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12583: TNS:no reader
Cause: A send operation has been requested but partner has already disconnected.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12585: TNS:data truncation
Cause: A receive operation has completed with insufficient data to satisfy the user's request.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12589: TNS:connection not bequeathable
Cause: An attempt to hand-off a connection from one process to another has failed because the protocol provider does not support it.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12590: TNS:no I/O buffer
Cause: An attempt to perform an I/O operation failed because no buffer was available.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12591: TNS:event signal failure
Cause: The TNS software is unable to signal an event occurrence.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12592: TNS:bad packet
Cause: An ill-formed packet has been detected by the TNS software.
Action: For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12593: TNS:no registered connection
Cause: An attempt to solicit network event activity has failed because no connections are registered for event notification.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12595: TNS:no confirmation
Cause: TNS is unable to get requested confirmation acknowledgment from remote partner.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12596: TNS:internal inconsistency
Cause: TNS has detected an internal inconsistency.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
TNS-12597: TNS:connect descriptor already in use
Cause: Internal error - illegal use of connect descriptor.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12598: TNS:banner registration failed
Cause: The registration of a product banner with the Oracle server failed.
Action: This is an error which is not normally visible externally. Enable tracing and attempt to repeat the error. If it occurs again, contact Oracle Customer Support.
TNS-12599: TNS:cryptographic checksum mismatch
Cause: The data received is not the same as the data sent.
Action: Attempt the transaction again. If error persists, check (and correct) the integrity of your physical connection.
TNS-12600: TNS: string open failed
Cause: The creation of a string in ORACLE NLS format failed.
Action: This is an internal error, enable tracing and attempt to repeat the error. If it occurs again, contact Oracle Customer Support.
TNS-12601: TNS:information flags check failed
Cause: The TNS information flags set by the process prior to connection negotiation were not present after the negotiation was finished.
Action: This is an internal error. Enable tracing and attempt to repeat the error. If it occurs again, contact Oracle Customer Support.
TNS-12602: TNS: Connection Pooling limit reached
Cause: The operation failed because maximum active current connections has been reached. It may not be a real error when the Connection Pooling feature is enabled. It is possible that the application later reissues the operation and successfully grabs the connection pool slot and proceeds.
Action: This is an internal error. Enable tracing and attempt to repeat the error. If it occurs again, contact Oracle Customer Support.
TNS-12606: TNS: Application timeout occurred
Cause: A network session did not reach an application-defined stage within the allowed time interval.
Action: This is an error which does not normally appear at the high level. The action to take is application specific, and is detailed in the higher level error description.
TNS-12607: TNS: Connect timeout occurred
Cause: A network session did not reach a predefined connect stage within the allowed time interval.
Action: This is an error which does not normally appear at the high level. The action to take is application specific, and is detailed in the higher level error description.
TNS-12608: TNS: Send timeout occurred
Cause: The send or write operation did not complete within the allowed time interval.
Action: Check if the peer host is available. Increase the send timeout value if necessary.
TNS-12609: TNS: Receive timeout occurred
Cause: The receive or read operation did not complete within the allowed time interval.
Action: Check if the peer host is available. Increase the receive timeout value if necessary.
TNS-12611: TNS:operation is not portable
Cause: Attempted operation is not portable.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12612: TNS:connection is busy
Cause: Attempted operation failed because it conflicts with an ongoing
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12615: TNS:preempt error
Cause: A request to service an event failed because no event notification has yet been posted.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12616: TNS:no event signals
Cause: The operation failed because the type of data specified is unknown.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12618: TNS:versions are incompatible
Cause: The two machines are running incompatible versions of TNS.
Action: Check the version numbers, and upgrade the machine with the smaller one.
TNS-12619: TNS:unable to grant requested service
Cause: The connect request failed because requested service could not be provided by the local TNS software.
Action: If appropriate, reexecute with reduced service requirements.
TNS-12620: TNS:requested characteristic not available
Cause: The connect request failed because a requested transport characteristic could not be supported by the remote TNS software.
Action: If appropriate, reexecute with reduced requirements.
TNS-12622: TNS:event notifications are not homogeneous
Cause: An attempt to register a connection for event notification failed because the event notification type conflicts with existing registrations.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
TNS-12623: TNS:operation is illegal in this state
Cause: Connection is half-duplex and a full-duplex operation was attempted.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation. If error persists, contact Oracle Customer Support.
TNS-12624: TNS:connection is already registered
Cause: An attempt to register a connection for event notification failed because the connection is already registered.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
TNS-12625: TNS:missing argument
Cause: An operation failed because an argument was missing"
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
TNS-12626: TNS:bad event type
Cause: An attempt to register a connection for event notification failed because the event type is unknown.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
TNS-12628: TNS:no event callbacks
Cause: An attempt to register a connection for event notification failed because asynchronous callbacks are not available.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
TNS-12629: TNS:no event test
Cause: An attempt to register a connection for event notification failed because the ability to test for events is not available.
Action: Not normally visible to the user. For further details, turn on tracing and reexecute the operation and contact Oracle Customer Support.
TNS-12630: Native service operation not supported
Cause: An operation requested by a user is not supported by the native services component.
Action: This may be an internal error if the operation should have been supported.
TNS-12631: Username retrieval failed
Cause: The authentication service failed to retrieve the name of a user.
Action: Enable tracing to determine which routine is failing.
TNS-12632: Role fetch failed
Cause: The authentication service failed to retrieve one of the user's roles.
Action: Enable tracing to determine which routine is failing.
TNS-12633: No shared authentication services
Cause: The list of authentication services specified by the user does not match those supported by the process.
Action: Either specify another list or relink the executable with the desired services.
TNS-12634: Memory allocation failed
Cause: Process was unable to allocate memory.
Action: Terminate other processes in order to reclaim needed memory.
TNS-12635: No authentication adapters available
Cause: The executable was not linked with any authentication service adapters but the sqlnet.ora parameter that determines whether or not authentication is required was set to true.
Action: Either disable the parameter or relink the executable with service adapters.
TNS-12636: Packet send failed
Cause: A process was unable to send a packet to another process. Possible causes are:

1. The other process was terminated.

2. The machine on which the other process is running went down.

3. Some other communications error occurred.

Action: If the cause is not obvious, contact Oracle Customer Support.
TNS-12637: Packet receive failed
Cause: A process was unable to receive a packet from another process. Possible causes are:

1. The other process was terminated.

2. The machine on which the other process is running went down.

3. Some other communications error occurred.

Action: If the cause is not obvious, contact Oracle Customer Support.
TNS-12638: Credential retrieval failed
Cause: The authentication service failed to retrieve the credentials of a user.
Action: Enable tracing to determine the exact error.
TNS-12639: Authentication service negotiation failed
Cause: No match was found between the types of authentication services that the client supports and those that the server is using.
Action: Possible solutions:

1. Change the entry in sqlnet.ora that determines which services are to be used.

2. Relink the client with at least one of the authentication service adapters that the server supports.

3. Relink the server with at least one of the authentication service adapters that the client supports.

4. Disable authentication on both the client and server.

TNS-12640: Authentication adapter initialization failed
Cause: The function specified in the authentication table entry for the service failed.
Action: Enable tracing to determine the exact error.
TNS-12641: Authentication service failed to initialize
Cause: The authentication service failed during initialization.
Action: Enable tracing to determine the exact error.
TNS-12642: No session key
Cause: A process has no session key associated with it because the authentication service being used does not use one.
Action: If a session key is required, use another authentication service.
TNS-12643: Client received internal error from server
Cause: The client process received an error from the server that indicated that an internal Oracle Net native services error had occurred.
Action: Enable tracing on both processes and attempt to recreate the problem. If successful in recreating the problem, contact Oracle Customer Support.
TNS-12645: Parameter does not exist.
Cause: A sqlnet.ora parameter from which a value was needed does not exist.
Action: Set the parameter in the parameter file.
TNS-12646: Invalid value specified for boolean parameter
Cause: The value specified for a parameter was set to a value other than true/false or on/off.
Action: Correct the value of the parameter.
TNS-12647: Authentication required
Cause: The parameter that controls whether authentication is required was set to true, but the executable does not have an authentication service linked in.
Action: Either re-link the executable with an authentication service adapter or disable the parameter.
TNS-12648: Encryption or data integrity algorithm list empty
Cause: An Oracle Advanced Security list-of-algorithms parameter was empty, e.g. "()".
Action: Change the list to contain the name of at least one installed algorithm, or remove the list entirely if every installed algorithm is acceptable.
TNS-12649: Unknown encryption or data integrity algorithm
Cause: An Oracle Advanced Security list-of-algorithms parameter included an algorithm name that was not recognized.
Action: Either remove that algorithm name, correct it if it was misspelled, or install the driver for the missing algorithm.
TNS-12650: No common encryption or data integrity algorithm
Cause: The client and server have no algorithm in common for either encryption or data integrity or both.
Action: Choose sets of algorithms that overlap. In other words, add one of the client's algorithm choices to the server's list or vice versa.
TNS-12651: Encryption or data integrity algorithm unacceptable
Cause: The algorithm the server chose to use for encryption or data integrity was not one of the choices acceptable to the client. This is either the result of an internal error, of a network data transmission error, or of deliberate tampering with the transmitted data.
Action: For further details, turn on tracing, re-execute the operation, and contact Oracle Customer Support.
TNS-12652: String truncated
Cause: Not enough memory was allocated for a string so it had to be truncated
Action: If it is OK that the string is truncated, then it is not an error. Otherwise, call the routine that reported the error again with a larger string buffer.
TNS-12653: Authentication control function failed
Cause: The control function utilized by the authentication service driver failed.
Action: Enable tracing to determine the exact error.
TNS-12654: Authentication conversion failed
Cause: The authentication service was unable to convert the credentials of a user from the format specific to the format into the ORACLE format.
Action: Enable tracing to determine the exact error.
TNS-12655: Password check failed
Cause: The authentication service being used was unable to verify the provided password.
Action: Enable tracing to determine the exact error.
TNS-12656: Cryptographic checksum mismatch
Cause: The cryptographic checksum received with a packet of incoming data didn't match the checksum computed by the receiving end. This indicates that the packet was tampered with or otherwise corrupted in transit.
Action: Look for sources of data corruption, perhaps including deliberate tampering.
TNS-12657: No algorithms installed
Cause: The near side of the connection required the use of a service (either encryption or checksumming) when no algorithms for that service were installed.
Action: Remove the "ON" requirement for that service.
TNS-12658: ANO service required but TNS version is incompatible
Cause: A client process that is running an earlier version of TNS attempted to connect but the connection failed because the server process required that an ANO service (authentication, encryption, etc.) be used.
Action: Relink the calling executable and retry the connection or eliminate the requirement that the service be used on the server side.
TNS-12659: Error received from other process
Cause: An error was received by one or more services from the process on the other side of the connection.
Action: Enable tracing to determine the exact error(s). The error(s) is (are) not returned directly because an error generated by a server may not make sense on the client side and vice-versa.
TNS-12660: Encryption or crypto-checksumming parameters incompatible
Cause: One side of the connection specified "REQUIRED" for encryption or crypto-checksumming, while the other side specified "REJECTED".
Action: Change the "REQUIRED" side to "REQUESTED" if the you want encryption or crypto-checksumming to be optional, or change the "REJECTED" side to "ACCEPTED" if you do not want the service to be optional.
TNS-12661: Protocol authentication to be used
Cause: The Oracle Advanced Security authentication service has determined that the Oracle Net transport protocol in use is to be utilized to authenticate a user's identity.
Action: This error is used solely to communicate information between the authentication service and the Oracle Net session layer and should not normally be visible. If the error is seen, contact Oracle Worldwide Support.
TNS-12662: proxy ticket retrieval failed
Cause: The authentication adapter used by Oracle Net failed to retrieve the credentials needed to authenticate a database link.
Action: Enable tracing to determine the exact error.
TNS-12663: Services required by client not available on the server
Cause: Service(s) that was (were) required by the client process were not available on the server process.
Action: Configure the server with the services required by the client (best solution) or delete the requirement from the configuration file of the client (least secure).
TNS-12664: Services required by server not available on the client
Cause: Service(s) that was (were) required by the server process were not available on the client process.
Action: Configure the client with the services required by the server (best solution) or delete the requirement from the configuration file of the server (least secure).
TNS-12665: NLS string open failed
Cause: A native service was unable to make a string available for use by the National Language Support component.
Action: Make sure the National Language Support component has been properly. If it has, enable tracing and report the problem to Customer Support.
TNS-12666: Dedicated server: outbound transport protocol different from inbound
Cause: The protocol specified for an externally-identified outbound connection from a dedicated server (database link) was not the same as that used for the inbound connection. It is not possible for Oracle Net to authenticate a proxy connection that uses a protocol that is different from that which was used for the connection to the dedicated server.
Action: Specify the same protocol in the Oracle Net connect descriptor for the outbound connection as that used for the inbound connection.
TNS-12667: Shared server: outbound transport protocol different from inbound
Cause: The protocol specified for an externally-identified outbound connection from a shared server (database link) was not the same as as that used for the inbound connection. It is not possible for Oracle Net to authenticate a proxy connection that uses a protocol that is different from that which was used for the connection to the shared server.
Action: Specify the same protocol in the Oracle Net connect descriptor for the outbound connection as that used for the inbound connection
TNS-12668: Dedicated server: outbound protocol does not support proxies
Cause: The protocol specified to perform an externally-identified proxy connection (database link) from a dedicated server does not support proxy connections.
Action: Specify a protocol in the Oracle Net connect descriptor used for the connection that does support externally-authenticated proxy connections. NOTE: Because of a limitation in Oracle Net, the protocol used for the proxy connection must the same as that used for the connection from the client to the server.
TNS-12669: Shared server: outbound protocol does not support proxies
Cause: The protocol specified to perform an externally-identified proxy connection (database link) from a shared server does not support proxy connections.
Action: Specify a protocol in the Oracle Net connect descriptor used for the connection that does support externally-authenticated proxy connections. NOTE: Because of a limitation in Oracle Net, the protocol used for the proxy connection must the same as that used for the connection from the client to the server.
TNS-12670: Incorrect role password
Cause: A password supplied for a role could not be validated by the authentication service.
Action: Supply the correct password.
TNS-12671: Shared server: adapter failed to save context
Cause: The adapter for the authentication service failed when it tried to save the data needed for proxy connections (database links) through the shared server.
Action: Enable tracing to determine the exact error. Contact Oracle Customer Support if the reason is not obvious.
TNS-12672: Database logon failure
Cause: The authentication service adapter in use encountered an error it attempted to validate the logon attempt of a user.
Action: Enable tracing to determine the exact error encountered by the adapter.
TNS-12673: Dedicated server: context not saved
Cause: A connection was marked as being a proxy connection (database link) from a dedicated server but no inbound context was present.
Action: This error should not normally be visible to the user. Contact Oracle Customer Support.
TNS-12674: Shared server: proxy context not saved
Cause: A connection was marked as being a proxy connection (database link) from a shared server but no inbound context was present.
Action: This error should not normally be visible to the user. Contact Oracle Customer Support.
TNS-12675: External user name not available yet
Cause: The authentication service in use was not able to return the external name of a user of the ORACLE server because it is not available to the service yet.
Action: This is just an informational message and should not normally be visible to the user. If the error does appear, contact Oracle Customer Support.
TNS-12676: Server received internal error from client
Cause: The server process received an error from the client which indicated that an internal Oracle Net native services error had occurred.
Action: Enable tracing on both processes and attempt to recreate the problem. If the problem recurs, contact Oracle Customer Support.
TNS-12677: Authentication service not supported by database link
Cause: The authentication service used by the proxy process (database link) was unable to find the adapter being used by the client in its list of authentication mechanisms.
Action: Specify an authentication adapter that is shared by the client and the server being used for the database link.
TNS-12678: Authentication disabled but required
Cause: The configuration parameters that control whether Oracle Advanced Security authentication is disabled or required were both set to TRUE.
Action: Set one or both of the parameters to FALSE.
TNS-12679: Native services disabled by other process but required
Cause: The remote process has disabled native services but the local process requires them.
Action: Enable native services on the remote process or disable them locally.
TNS-12680: Native services disabled but required
Cause: The process has disabled native services but at least one service is required.
Action: Enable native services or change the configuration file so that none of the available services are required.
TNS-12681: Login failed: the SecurID card does not have a pincode yet
Cause: The SecurID card that is used to logon to Oracle, does not have a pincode assigned to it.
Action: Use one of the programs supplied by Security Dynamics to assign a pincode to the card.
TNS-12682: Login failed: the SecurID card is in next PRN mode
Cause: The SecurID card and the SecurID server are out of sync and the server requires the next cardcode to resynchronize the card.
Action: Use one of the programs supplied by Security Dynamics to resynchronize the SecurID card.
TNS-12683: encryption/crypto-checksumming: no Diffie-Hellman seed
Cause: The "sqlnet.crypto_seed" parameter is missing from the SQLNET.ORA parameters file for Oracle Advanced Security.
Action: Add this line to SQLNET.ORA: sqlnet.crypto_seed = "randomly-chosen text"
TNS-12684: encryption/crypto-checksumming: Diffie-Hellman seed too small
Cause: The "sqlnet.crypto_seed" parameter in the SQLNET.ORA parameter file for Oracle Advanced Security is too small.
Action: Add more randomly-chosen text to it, perhaps using Network Manager.
TNS-12685: Native service required remotely but disabled locally
Cause: A native service is required by the remote process but native services have been disabled locally.
Action: Enable native services locally or change the configuration parameters on the remote host so that no native services are required.
TNS-12686: Invalid command specified for a service
Cause: An operation which does not exist was specified for a native service.
Action: This is a programming error and should not normally be visible to the user. If the error does appear, contact Oracle Customer Support.
TNS-12687: Credentials expired.
Cause: The credentials that are used to authenticate the user for the requested connection have expired.
Action: Renew your credentials. Refer to the documentation specific for your Network Authentication Adapter on how to do this.
TNS-12688: Login failed: the SecurID server rejected the new pincode
Cause: There are a number of reasons why the SecurID server would refuse a pincode:

- The user might not have permission to make up his own pincode.

- The pincode was either too short or too long. Valid pincodes consist of minimal four, but no more than eight characters.

- The pincode contains any non alphanumeric characters.

Action: Reexecute the operation and make sure to use a pincode that satisfies the above requirements. If the problem persists, turn on tracing at the Oracle Server side of the connection and examine the trace file for the exact error.
TNS-12689: Server Authentication required, but not supported
Cause: Server Authentication is required for this connection, but not supported by both sides of the connection.
Action: Make sure both sides of the connection have the correct version of Advanced Networking Option, and that the Authentication Adapter supports Server Authentication.
TNS-12690: Server Authentication failed, login cancelled
Cause: Server Authentication is required, but the server's credentials were found invalid by the client.
Action: Make sure that the server has a valid set of credentials. Refer to your authentication adapter specific documentation on how to do this.
TNS-12696: Double Encryption Turned On, login disallowed
Cause: The user is using a Secure Protocol Adapter that has Encryption turned ON as well as ANO Encryption.
Action: Turn OFF either ANO Encryption or the Protocol Adapter Encryption if possible. Refer to Oracle Advanced Security Administrator's Guide on how to do this.
TNS-12699: Native service internal error
Cause: An internal error occurred in the native services component.
Action: Enable tracing to determine the exact error. Contact Oracle Customer Support.


43 NNC-00001 to NNC-00501

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

43 NNC-00001 to NNC-00501

NNC-00001: maximum number of connections already open
Cause: All available name service connections are handling requests.
Action: If the problem occurs when running a name server, increase the values of names.max_open_connections. If the problem occurs in a client program, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00002: error listening on stream string
Cause: The name server was asked to listen on the specified address, and failed, probably because the address is malformed, or because it uses a SQL*Net protocol adaptor which has not been installed.
Action: Make sure the address is properly formed, and that it uses a protocol adaptor which has been installed on your system.
NNC-00003: error opening stream string
Cause: A name server or client program attempted to open a connection to another server and failed, either because the server is down, or because the network path to that server is not working. This error is usually displayed underneath an error which describes the problem in more detail.
Action: Make sure that the server being connected to is listening on the address used, and that there is network connectivity between the two end-points.
NNC-00004: connection is broken
Cause: The connection from a name server or client program to another server has been broken, either because that server has shut down, or because the network path to the server has stopped working. This error is usually displayed underneath an error which describes the problem in more detail.
Action: Make sure that the server being connected to is running and listening on the address used, and that there is network connectivity between the two end-points.
NNC-00005: cannot initialization stream subsystem
Cause: The name service stream subsystem could not be started, probably because of a missing TNS error message file.
Action: Check that SQL*Net has been installed properly and that all message files are in their proper locations.
NNC-00050: message format error
Cause: A corrupted name server message was received by a name server or the name server program interface.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00051: message content error
Cause: A corrupted name server message was received by a name server or the name server program interface.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00052: client and server protocol versions are incompatible
Cause: A name server message with an incompatible protocol version was received by a name server or the name server program interface. This problem will occur when there are clients and servers with widely varying protocol versions that are trying to communicate.
Action: upgrade older client and server software so it is compatible with newer software.
NNC-00053: ASN.1 error encountered while sending or receiving message
Cause: The name server or the name server program interface attempted to send or receive a message and failed because of an ASN.1 error.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00400: memory exhausted
Cause: The program interface has run out of memory.
Action: Add more memory or run fewer processes.
NNC-00401: program interface initialization failed
Cause: The name server program interface could not be initialised, probably because of a missing TNS or name server error message file.
Action: Check that SQL*Net has been installed properly and that all message files are in their proper locations.
NNC-00402: program interface de-initialization failed
Cause: An internal error occurred while the name server program interface was being de-initialised by an internal function.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00403: program interface has not been initialised
Cause: An internal function has attempted to de-initialise the name service program interface when it has not yet been initialised.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00404: supplied buffer of size string is smaller than minimum size string
Cause: A caller supplied the name server program interface with a memory buffer too small for the interface's requirements. This error is usually displayed underneath an error which describes the problem in more detail.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00405: network failure
Cause: The network connection between the client program and the name server has failed, either because the server has shut down, or because the network path to the server has stopped working. This error is usually displayed underneath an error which describes the problem in more detail.
Action: Contact your name server administrator to make sure that the server being connected to is running and listening on the address used, and that there is network connectivity between the two end-points.
NNC-00406: name "string" does not exist
Cause: The user asked for information associated with a global name that does not exist.
Action: Re-try the failing operation with a global name that exists.
NNC-00407: alias loop in name request
Cause: The name service detected an "alias loop" when trying to retrieve information associated with a global name. An alias loop occurs when an alias name X points to another alias name Y, which in turn points back to X, rather than eventually to a global name which contains data.
Action: Contact your name server administrator to have the alias loop investigated and fixed.
NNC-00408: name "string" exists but desired data does not
Cause: The user asked for information associated with a global name. The name in question exists, but does not contain the desired type of information.
Action: Re-try the failing operation with a type which the desired name does contain.
NNC-00409: temporary name service failure
Cause: There are no name servers available to handle a client request, or a name server was temporarily unable to handle a client request. This situation is almost always temporary, and occurs when the program interface has issued a name server request and not received a timely response from any of its preferred servers. Such delays can occur due to transient network or name server outages or heavy load.
Action: Re-try the failing operation. If the error persists, make sure there is network connectivity between the client and its preferred name servers, and contact your name server administrator to make sure that those name servers are running.
NNC-00410: invalid preferred server address list
Cause: The names.preferred_servers parameter in sqlnet.ora is malformed.
Action: Make sure the address list is properly formatted.
NNC-00411: invalid default domain name "string"
Cause: The names.default_domain parameter in sqlnet.ora is invalid.
Action: Make sure the parameter value is a valid global name. See your
NNC-00412: invalid name "string"
Cause: The name server program interface was given an invalid global name to process.
Action: Supply a valid domain name. If the error is caused by an internal function, contact Worldwide Customer Support.
NNC-00413: general failure
Cause: A name server program interface error occured which did not fall under the heading of any other more specific error condition. The error will usually be followed by more specific lower-level information.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00414: invalid name-value binding string "string"
Cause: A caller provided the name server program interface with an invalid name-value binding string value.
Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a valid name-value binding string argument. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00415: section identifier string is invalid, must be between string and string
Cause: An internal function has called the name server program interface with illegal arguments.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00416: user callback function returned error number string
Cause: An internal function has called the name server program interface with illegal arguments.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00417: name "string" already exists
Cause: A caller has attempted to create a new global name, and that name already exists.
Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a name that does not already exist. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00418: name "string" cannot be modified because it has children
Cause: A caller has attempted to delete or rename a global name, and that name cannot be modified because it has child names underneath it in the name space.
Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a name that is a leaf node. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00419: authoritative server is unreachable
Cause: A name server request cannot be processed because the server which received the operation does not own the name specified in the request and cannot locate the server which does own the name. The error is almost always transient, and occurs either because the path between the server receiving the request and the request's final destination has been interrupted, or because the final destination is down.
Action: Not normally visible to the user, except when using the name server control program. Because the error is typically a transient one, retrying the failing operation will usually work. If the failure persists, the name server which is allowed to process the failing operation is probably shut down or unreachable. Contact your name server administrator to make sure that your site's name servers are running, and are properly configured.
NNC-00420: operation not allowed
Cause: A name server request cannot be processed because the server which received the operation is not allowed to process it. The problem typically occurs when an administrator has disabled request processing at a particular server for some reason.
Action: Contact your name server administrator to determine why server request processing has been disabled.
NNC-00421: invalid modification directive string, must be between string and string
Cause: An internal function has called the name server program interface with illegal arguments.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00422: invalid data type name "string"
Cause: A caller has provided an invalid data type name to the name server program interface.
Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a valid type name. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00423: invalid data item syntax code string
Cause: A caller has provided an invalid data type code to the name server program interface.
Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a valid type name. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00424: invalid address "string"
Cause: A caller provided the name server program interface with an invalid address value.
Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a valid address argument. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00425: meta-data violation
Cause: A caller issued a name server modification request and that request cannot be processed because it would violate data type meta-data constraints.
Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, examine the meta-data constraints for the data type being operated upon and don't violate them. Examples of typical constraint violations are attempts to add a new data item to a name which already contains alias information, or attempts to add alias information to a name which already contains other data, or attempts to replace a data item with another item that has the wrong syntax. If the error occurs outside the control program, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00426: no such data type
Cause: A caller attempted to create a data item, and could not because the data item's type does not exist.
Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the operation with an existent data type. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00427: server does not support this version of the protocol
Cause: A name server message with an incompatible protocol version was received by a name server or the name server program interface. This problem will occur when there are clients and servers with widely varying protocol versions that are trying to communicate.
Action: upgrade older client and server software so it is compatible with newer software.
NNC-00428: invalid meta-data data item
Cause: A caller provided the name server program interface with an invalid meta-data data item.
Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a valid meta-data argument. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00429: invalid octet string literal "string"
Cause: A caller provided the name server program interface with an invalid octet string string value.
Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a valid octet string argument. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNC-00430: Database not accessible
Cause: When a database is used for consistency between different nameservers, any modify operation should not only modify the cache but also the database. And if the database is not accessible, this error occurs.
Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, make sure database is available and then re-execute the operation. If error persists, contact Worldwide Customer Support.
NNC-00431: NS address does not match any of the current addresses
Cause: When delegating a domain, the address of the Nameserver is provided by the client. If the nameserver already exists, then it already has address(es) associated with it. So, the address supplied by the client must match one of them. Otherwise, this error occurs.
Action: Not normally visible to the user, except when using name server control program. If the error occurs when using the control program, either provide an one of the existing addresses of the name server or delegate the domain to a new nameserver.
NNC-00500: warning: "string" parameter value is illegal, setting to string
Cause: The named parameter value is invalid.
Action: Make sure the parameter value is formatted correctly. Valid choices for boolean parameter values are TRUE, FALSE, YES, NO, ON, and OFF.
NNC-00501: warning: "string" parameter value must be between number and number, setting to number
Cause: The named parameter value is invalid or outside legal boundary values.
Action: Make sure the parameter value is a number, and falls between valid minimum and maximum values, as specified in the error text.


44 NNO-00050 to NNO-00854

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

44 NNO-00050 to NNO-00854

NNO-00050: serious errors in configuration data, server cannot run
Cause: The server's configuration data has a problem of some sort which prevents the server from starting.
Action: Previous error messages in the log file will specify the exact problems leading to the shutdown. The problem most frequently occurs when the network is broken up into multiple administrative regions and the delegation points are incorrect. Read the Oracle Names documentation sections on region delegation and ensure that their directions are being followed correctly.
NNO-00051: domain count number exceeds maximum of number, first number will be loaded
Cause: The server's configuration contains more domains than the server can support.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00052: invalid domain description list
Cause: The server's configuration contains an invalid domain description list.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00053: duplicate domain description for domain "string"
Cause: The server's configuration contains duplicate domain descriptions in the domain description list.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00054: invalid domain name "string"
Cause: The server's configuration contains a domain description with an invalid name.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00055: invalid domain minimum TTL "string"
Cause: The server's configuration contains a domain description with an invalid minimum TTL.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00056: warning: domain minimum TTL must be between number and number, set to number seconds
Cause: The server's configuration contains a domain description with an invalid minimum TTL. This error is not fatal; the server will automatically set the TTL to a default value which is suitable for most uses.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00057: loading and verifying topology data
Cause: An informational message written to the log file during normal server startup.
Action: none
NNO-00058: cannot load topology data from configuration database
Cause: An error was encountered while trying to load the server's topology data from the configuration database. If more information is available, it will appear under this error. This error will cause the server to shut down.
Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the names.no_region_database parameter set to TRUE. If no checkpoint data is available, the server will shut down.
NNO-00059: cannot construct topology checkpoint file name
Cause: the server could not construct a system-dependent file name.
Action: An internal error not normally visible to the user. For further details, turn on tracing and restart the server. If the error persists, contact Worldwide Customer Support.
NNO-00060: loading server topology from checkpoint file "string"
Cause: An informational message written to the log file when the server has been forced to load from its most recent topology checkpoint file, by setting the names.no_region_database parameter to TRUE.
Action: none
NNO-00061: loading data for domain "string"
Cause: An informational message written to the log file during normal server startup.
Action: none
NNO-00062: cannot load domain data from configuration database
Cause: An error was encountered while trying to load the server's domain data from the configuration database. If more information is available, it will appear under this error. This error will cause the server to shut down.
Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the names.no_region_database parameter set to TRUE. If no checkpoint data is available, the server will shut down.
NNO-00063: cannot construct domain checkpoint file name
Cause: the server could not construct a system-dependent file name.
Action: An internal error not normally visible to the user. For further details, turn on tracing and restart the server. If the error persists, contact Worldwide Customer Support.
NNO-00064: loading domain data from checkpoint file "string"
Cause: An informational message written to the log file when the server has been forced to load from its most recent domain checkpoint file, by setting the names.no_region_database parameter to TRUE.
Action: none
NNO-00065: loading cached data from checkpoint file "string"
Cause: An informational message written to the log file during normal server startup.
Action: none
NNO-00066: server will perform reload check of administrative region in number seconds
Cause: An informational message written to the log file whenever the Oracle Network Manager or the Oracle Names control program send a reload request to the server.
Action: none
NNO-00067: server reload check countdown aborted
Cause: An informational message written to the log file whenever the Oracle Names control program halts a reload request previously sent to the server
Action: none
NNO-00068: warning: administrative region check failed, next check in number seconds
Cause: this warning is issued whenever the server fails to connect to the configuration database to see if any configuration data has changed. The server will automatically begin reissuing reload checks more frequently, and will eventually give up if connections fail continuously for three days.
Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database.
NNO-00069: warning: too many administrative region check failures, checking disabled
Cause: a warning issued whenever the server has continuously failed for three days in its attempts to connect to the configuration database. The server disables reload checking. Reload checking can later be re-enabled from the Oracle Network Manager or the Oracle Names control program.
Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the names.no_region_database parameter set to TRUE. If no checkpoint data is available, the server will shut down.
NNO-00070: administrative region has changed, reloading domain data
Cause: An informational message written to the log file whenever the server's configuration has changed, and the server is reloading the new configuration from the configuration database.
Action: none
NNO-00071: cannot construct cache checkpoint file name
Cause: the server could not construct a system-dependent file name.
Action: An internal error not normally visible to the user. For further details, turn on tracing and restart the server. If the error persists, contact Worldwide Customer Support.
NNO-00072: loading from region database
Cause: normal
Action: An internal error not normally visible to the user. For further details, turn on tracing and restart the server. If the error persists, contact Worldwide Customer Support.
NNO-00073: loading server config from region database
Cause: An informational message written to the log file during normal server startup.
Action: none
NNO-00074: downloading region from server string
Cause: An informational message written to the log file during normal server startup.
Action: none
NNO-00080: domain "string" cannot be delegated because its parent is already delegated
Cause: an internal delegation error has occurred. Delegation is controlled by the Oracle Network Manager, which enforces correct delegation rules.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00081: domain "string" has no name servers
Cause: an internal configuration error has occurred. The Oracle Network Manager is responsible for configuring Oracle Names servers correctly.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00082: domain "string" is missing my name "string" as a name server
Cause: an internal configuration error has occurred. The Oracle Network Manager is responsible for configuring Oracle Names servers correctly.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00083: domain "string" server "string" has no addresses
Cause: an internal configuration error has occurred. The Oracle Network Manager is responsible for configuring Oracle Names servers correctly.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00084: domain "string" is not in the authoritative domain list
Cause: an internal configuration error has occurred. The Oracle Network Manager is responsible for configuring Oracle Names servers correctly.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00104: line string: syntax error, data ignored
Cause: the server found a syntax error its domain data. This message will also appear if the server's internal checkpoint files become corrupted. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00105: line string: invalid name "string", data ignored
Cause: the server found an invalid global name in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00106: line string: invalid TTL "string", data ignored
Cause: the server found an invalid TTL in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00107: line string: ignoring stale checkpoint data
Cause: an informational message which appears during server startup when the server detects out-of-date cached data in its cache checkpoint file. The message is part of normal server startup.
Action: none
NNO-00108: line number: TTL of number seconds below domain minimum number, using minimum
Cause: the server found an invalid TTL value in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00109: line string: invalid data type name "string", data ignored
Cause: the server found an invalid data type name in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00110: line string: unknown data type "string", data ignored
Cause: the server found an unknown data type in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00111: line string: data type "string" has syntax "string", should be "string", data ignored
Cause: the server found an invalid data type syntax in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00112: line string: ignored duplicate data of type "string"
Cause: the server found a duplicate record in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00113: line string: alias data already exists, all other data ignored
Cause: the server found a alias and non-alias data with the same global name in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00114: line string: other data exists, alias data ignored
Cause: the server found a alias and non-alias data with the same global name in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00115: line string: single-value data type "string", other instances ignored
Cause: the server found more than one record with the same name and type, when the type allows only a single record with a particular name. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00116: warning: data type "string" in string load
Cause: the server found a record with an invalid data type in its domain data.
Action: No action required; adjustments to data will eliminate warning.
NNO-00117: line string: missing data type, data ignored
Cause: the server found a record with a missing data type in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00118: line string: data length string exceeds maximum of string, data ignored
Cause: the server found a record whose length exceeds an internal limit. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00119: line string: server not authoritative for name "string", data ignored
Cause: the server found a global name in its domain data for which it is not authoritative. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00120: line string: topology name "string" not allowed here
Cause: the server found an invalid record in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00121: LDIF file string open failed: error = number
Cause: the server found an invalid record in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00122: invalid name, data ignored: entry: string
Cause: the server found an invalid global name in its domain data. The record in question is not loaded, but the server continues to load data.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00123: node "string" has no authoritative parent, data ignored
Cause: an object in the domain data is apparently not in the domain(s) which the server is authoritative for. The record in question is not loaded, but the server continues to load data.
Action: Check for inconsistencies in the data and correct any errors in topology definition or domain data outside of authoritative domains.
NNO-00150: warning: invalid hint list, no hints loaded
Cause: The server's configuration contains an invalid hint description list. The server will continue to run, but will not load any hints.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00151: warning: ignoring hint for domain "string", server is authoritative
Cause: the server's configuration contained a hint for a domain in the server's administrative region. The hint is ignored and the server continues to run.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00152: warning: hint count number exceeds maximum of number, first number will be loaded
Cause: There are too many hints in the server's hint list. The server will load a specified maximum number of hints, ignore the rest, and continue running.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00153: warning: hint domain number has invalid name "string", hint domain ignored
Cause: The server's configuration contains a hont domain with an invalid name. The domain is ignored and the server continues to run.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00154: warning: hint number has invalid server name "string", hint ignored
Cause: The server's configuration contains a hint with an invalid server name. The hint is ignored and the server continues to run.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00155: warning: hint number has missing address, hint ignored
Cause: The server's configuration contains a hint with no server address. The hint is ignored and the server continues to run.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00156: warning: hint number address length number exceeds maximum of number, hint ignored
Cause: The server's configuration contains a hint whose address length exceeds an internal limit. The hint is ignored and the server continues to run.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00157: warning: hint number has invalid address, hint ignored
Cause: The server's configuration contains a hint with an invalid address. The hint is ignored and the server continues to run.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00158: warning: hint domain count number exceeds maximum of number, first number will be loaded
Cause: The server's hint domain list is too long. The server will load a specified maximum number of hint domains, ignore the rest, and continue running.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00159: warning: ignoring duplicate hint domain number name "string"
Cause: The server's hint domain list contains a duplicate domain. The duplicate is ignored and the server continues running.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00160: warning: ignoring duplicate hint server "string"
Cause: The server's hint server list contains a duplicate server. The duplicate is ignored and the server continues running.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00250: invalid administrative region description
Cause: The server encountered an invalid administrative region description during startup. This error will prevent the server from starting. The administrative region description is stored in the server's names.ora configuration file.
Action: Make sure that the names.admin_region parameter in names.ora is correct. The names.ora file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Worldwide Customer Support.
NNO-00251: missing administrative region parameter string
Cause: The server's administrative region description is missing a required parameter. This error will prevent the server from starting. The administrative region description is stored in the server's names.ora configuration file.
Action: Make sure that the names.admin_region parameter in names.ora is correct. The names.ora file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Worldwide Customer Support.
NNO-00252: invalid administrative region parameter string value "string"
Cause: The server encountered an invalid administrative region parameter. This error will prevent the server from starting. The administrative region description is stored in the server's names.ora configuration file.
Action: Make sure that the names.admin_region parameter in names.ora is correct. The names.ora file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Worldwide Customer Support.
NNO-00253: administrative region parameter string length string exceeds maximum of string
Cause: The server encountered an administrative region parameter whose length exceeds an internal limit. This error will prevent the server from starting. The administrative region description is stored in the server's names.ora configuration file.
Action: Make sure that the names.admin_region parameter in names.ora is correct. The names.ora file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Worldwide Customer Support.
NNO-00254: warning: parameter string value must be between number and number, set to number seconds
Cause: The server encountered an administrative region parameter with an invalid value. The value is set to a default suitable for most applications, and the server continues running. The administrative region description is stored in the server's names.ora configuration file.
Action: Make sure that the names.admin_region parameter in names.ora is correct. The names.ora file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Worldwide Customer Support.
NNO-00255: cannot initialize ROS
Cause: The server was unable to initialize ROS during startup. The error prevents the server from running.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00256: using administrative region "string"
Cause: an informational message which appears during server startup, and notes the name of the administrative region for future diagnostic use by administrators. The message is part of normal server startup.
Action: none
NNO-00257: warning: cannot get serial number from region store
Cause: The server encountered an error while trying to get the configuration database's serial number. The error occurs almost always because time the server is unable to access the configuration database. If the error occurs during server startup, the server will shut down. If the error occurs during server operation (the server checks the serial number periodically to see if it should reload itself), then the server assumes a transient failure has occurred and repeats the operation a short while later. If the repetitions continue to fail for three days, the server will log another error and stop issuing the serial number load operation.
Action: First make sure that the Netadmin program has exported a server configuration for this name server. Next, make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. If the error occurs during server startup, you can force startup anyway, with checkpoint data, by starting the server with the names.no_region_database parameter set to TRUE. If no checkpoint data is available, the server will shut down.
NNO-00258: cannot load configuration from configuration database
Cause: An error was encountered while trying to load the server's configuration from the configuration database. If more information is available, it will appear under this error. This error will cause the server to shut down.
Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the names.no_region_database parameter set to TRUE. If no checkpoint data is available, the server will shut down.
NNO-00259: configuration tables have not been installed or are inaccessible
Cause: The configuration database has not been properly installed.
Action: Make sure the Oracle Network Manager and its database have been properly installed
NNO-00260: loading configuration data from checkpoint file "string"
Cause: An informational message written to the log file when the server has been forced to load from its most recent configuration checkpoint file, by setting the names.no_region_database parameter to TRUE.
Action: none
NNO-00261: cannot construct configuration checkpoint file name
Cause: the server could not construct a system-dependent file name.
Action: An internal error not normally visible to the user. For further details, turn on tracing and restart the server. If the error persists, contact Worldwide Customer Support.
NNO-00262: warning: cannot write checkpoint file "string"
Cause: the server was unable to write the named checkpoint file. This problem is typically due to the file system's protection settings. The error is not fatal; it simply means the server will not create any checkpoint data. Note, however, that if the configuration database is ever unavailable during a future server startup, the lack of checkpoint data means you will be unable to force a startup from checkpoint data with the names.no_region_database parameter.
Action: Check to see that the server has permission to write the file named in the error message.
NNO-00263: error from configuration database
Cause: the server encountered an error while accessing the configuration database. The error can occur when the database is unavailable, or SQL*Net connectivity to the database is interrupted.
Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the names.no_region_database parameter set to TRUE. If no checkpoint data is available, the server will shut down.
NNO-00264: configuration database query returned no data
Cause: the server attempted to fetch data from the configuration database and no data was found.
Action: The error generally appears underneath a more specific error which will tell you the exact nature of the problem.
NNO-00265: warning: cannot load data from checkpoint file
Cause: the server was started using checkpoint data, and was unable to read that data. The remaining errors below this one on the error stack provide more specific information about the problem.
Action: Check to see that the named file exists and that the server has permission to read it.
NNO-00266: cannot find document "string" in configuration database
Cause: The server encountered an error while trying to get its configuration ID from the configuration database. The error can occur any time the server is unable to access the configuration database. This error will cause the server to shut down.
Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the names.no_region_database parameter set to TRUE. If no checkpoint data is available, the server will shut down.
NNO-00267: warning: configuration database contains no data for server "string"
Cause: the server successfully contacted the configuration database, but was unable to find any configuration information associated with the server's name. The name is specified in the server's names.ora configuration file. The error occurs almost always because the server configuration has not been exported from the Netadmin program.
Action: Make sure that the Netadmin program has exported a server configuration for this name server.
NNO-00268: warning: configuration database is not used, using checkpoint data instead
Cause: An informational message indicating that the server has been started with the names.no_region_database parameter set to TRUE, and that it will use checkpoint data rather than attempting to contact the configuration database.
Action: none
NNO-00269: configuration database is version string, server requires at least version string
Cause: The server cannot use the specified configuration database because it is of an incorrect version.
Action: Run the document conversion utility supplied with the Network Manager and re-export your network. The conversion utility will upgrade old documents to a version which can be understood by the name server.
NNO-00270: ORACLE error string
Cause: An ORACLE error was encountered while accessing the configuration database. The error can occur when the database is unavailable, or SQL*Net connectivity to the database is interrupted.
Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the names.no_region_database parameter set to TRUE. If no checkpoint data is available, the server will shut down.
NNO-00271: warning: names.ora region is version string, network definition is version string
Cause: The region description in names.ora is out of synch with the network definition.
Action: No action is required unless the name server cannot run with the network definition. To be safe names.ora should be updated with one which is consistent with the network definition.
NNO-00272: line string; invalid DIT/DN
Cause: There is a syntax error in the DIT/DN provided in the region description.
Action: Correct the error and restart the server.
NNO-00300: no listen addresses specified, at least one is required
Cause: the server's configuration is missing addresses on which to listen.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00301: server will shut down in number seconds
Cause: An informational message written to the log file when the server receives a shutdown request from the Oracle Names control program.
Action: none
NNO-00302: server stopped
Cause: An informational message written to the log file when the server shuts down.
Action: none
NNO-00303: server "string" started with process ID number
Cause: An informational message written to the log file when the server successfully starts up.
Action: none
NNO-00304: listen address string length string exceeds maximum of string
Cause: the length of one of the server's listen addresses exceeds an internal limit.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00305: trace level changed from number to number
Cause: An informational message written to the log file when the server changes its trace level in response to a request from the Oracle Names control program.
Action: none
NNO-00306: server shutdown countdown aborted
Cause: An informational message written to the log file whenever the Oracle Names control program halts a shutdown request previously sent to the server
Action: none
NNO-00307: invalid server name "string"
Cause: the server's name is invalid. The name is specified in the server's names.ora configuration file.
Action: Make sure that the names.server_name parameter in names.ora is correct. The names.ora file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Worldwide Customer Support.
NNO-00308: server will restart in number seconds
Cause: An informational message written to the log file when the server receives a restart request from the Oracle Names control program.
Action: none
NNO-00309: server restarting
Cause: An informational message written to the log file when the server restarts.
Action: none
NNO-00310: server restart countdown aborted
Cause: An informational message written to the log file whenever the Oracle Names control program halts a restart request previously sent to the server
Action: none
NNO-00311: invalid listen address list
Cause: the server's configuration contains an invalid listen address list.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00312: listen address string is invalid
Cause: the server's configuration contains an invalid listen address.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00313: server password length string exceeds maximum of string
Cause: the server's password length exceeds an internal limit.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00314: error changing trace level from number to number, level change ignored
Cause: the server encountered an error while changing its trace level in response to a request from the Oracle Names control program.
Action: An internal error not normally visible to the user. For further details, turn on tracing and restart the server. If the error persists, contact Worldwide Customer Support.
NNO-00315: server is listening on address string
Cause: An informational message written to the log file during server startup.
Action: none
NNO-00316: statistic counter reset disabled
Cause: An informational message written to the log file when the server disables statistic counter resetting in response to a request from the Oracle Names control program.
Action: none
NNO-00317: statistic counter reset interval changed to number seconds
Cause: An informational message written to the log file when the server changes its statistic counter reset interval in response to a request from the Oracle Names control program.
Action: none
NNO-00318: overriding next statistic counter reset, resetting in number seconds
Cause: An informational message written to the log file when the server resets its statistic counters in response to a request from the Oracle Names control program.
Action: none
NNO-00320: missing server name parameter
Cause: the server could not find a names.server_name parameter. The name is specified in the server's names.ora configuration file.
Action: Make sure that the names.server_name parameter in names.ora is correct. The names.ora file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Worldwide Customer Support.
NNO-00321: statistic counter dump disabled
Cause: An informational message written to the log file when the server disables statistics dumping in response to a request from the Oracle Names control program.
Action: none
NNO-00322: statistic counter dump interval changed to number seconds
Cause: An informational message written to the log file when the server changes its statistic dump interval in response to a request from the Oracle Names control program.
Action: none
NNO-00323: overriding next statistic counter dump, dumping in number seconds
Cause: An informational message written to the log file when the server dumps its statistic counters in response to a request from the Oracle Names control program.
Action: none
NNO-00326: server statistic counter dump follows
Cause: An informational message written to the log file at the beginning of a statistic dump. The message is followed by a set of server statistics, and ends with another informational message indicating the dump has finished.
Action: none
NNO-00327: server statistic counter dump ends
Cause: An informational message written to the log file at the end of a statistic dump. The message is preceded by a set of server statistics.
Action: none
NNO-00328: server has reset statistic counters to zero
Cause: An informational message written to the log file when the server resets its statistic counters to zero in response to a request from the Oracle Names control program.
Action: none
NNO-00329: server will save the config file in number seconds
Cause: An informational message written to the log file when the server saves the config to config file in response to a request from the Oracle Names control program.
Action: none
NNO-00330: server saved the config file "string".
Cause: An informational message written to the log file when the server saves the config to config file in response to a request from the Oracle Names control program.
Action: none
NNO-00331: error saving new value string of string to the save config table.
Cause: An informational message written to the log file when the a set operation is performed and the change cannot be saved in the save config ptable, but should be.
Action: none
NNO-00332: warning: region store serial number reduced from number to number
Cause: An informational message written to the log file when the server finds the region database has its serial number set lower than it was when the server previously loaded the region data. This is an unnatural condition- every update to the region should increment the serial number so a reduction of the serial number might reflect tampering or accidental manual alteration this and possibly other region tables.
Action: Administrators should find out how/why the serial number decreased.
NNO-00333: warning: ROS admin_region types obsolete; using SQL
Cause: the value set in names.admin_region is an obsolete ROS type
Action: No action is necessary; administrators should set the value to the correct type- probably SQL, possibly LDAP or LDIF
NNO-00334: region load failure: ROS admin_region type number unsupported
Cause: the value set in names.admin_region is an obsolete ROS type
Action: No action is necessary; administrators should set the value to the correct type- probably SQL, possibly LDAP or LDIF
NNO-00600: warning: forwarder count number exceeds maximum of number, first number will be loaded
Cause: the server's configuration contains too many default forwarders. The server loads a specified maximum number of forwarders, ignores the rest, and continues running.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00601: warning: no forwarders, DEFAULT-FORWARDERS-ONLY mode ignored
Cause: the server's configuration enables DEFAULT-FORWARDERS-ONLY mode but the configuration contains no default forwarders. The server ignores the request and continues running.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00602: warning: forwarder number has invalid address, forwarder ignored
Cause: One of the forwarders in the default forwarder list has an invalid address. The forwarder definition is ignored and the server continues running.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00603: enabling all request processing
Cause: An informational message written to the log file when the server enables request processing in response to a request from the Oracle Names control program.
Action: none
NNO-00604: disabling all request processing
Cause: An informational message written to the log file when the server disables request processing in response to a request from the Oracle Names control program.
Action: none
NNO-00605: enabling modification requests
Cause: An informational message written to the log file when the server enables modification-request processing in response to a request from the Oracle Names control program.
Action: none
NNO-00606: disabling modification requests
Cause: An informational message written to the log file when the server disables modification-request processing in response to a request from the Oracle Names control program.
Action: none
NNO-00607: server will forward to default forwarders only
Cause: An informational message written to the log file when the server's configuration enables DEFAULT-FORWARDERS-ONLY mode.
Action: none
NNO-00608: received corrupted message
Cause: The server received a corrupted request. The request is ignored.
Action: corrupted requests are usually caused by transient network problems. If many corrupted messages are received, turn on tracing for further information. If the errors persist, contact Worldwide Customer Support.
NNO-00609: warning: forwarder number address length number exceeds maximum of number, ignored
Cause: the server's configuration contains a forwarder address whose length exceeds an internal limit.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00610: detected possible alias loop involving name "string"
Cause: the server detected an alias loop involving the specified name. An alias loop occurs when an alias "X" points to another alias "Y", which points back to "X" rather than to an address or other name server data. The loop can contain more hops but the basic idea remains the same. Loops occur when administrators mis-enter network data, particularly when an alias in one administrative region points to data in another administrative region.
Action: Use the Oracle Names control program to query for the specified name. The control program will describe the alias path, and you can use that information to find which names are incorrect and what administrative regions the incorrect data belongs to.
NNO-00611: disabling request forwarding
Cause: An informational message written to the log file when the server disables request forwarding in response to a request from the Oracle Names control program.
Action: none
NNO-00612: enabling request forwarding
Cause: An informational message written to the log file when the server enables request forwarding in response to a request from the Oracle Names control program.
Action: none
NNO-00613: disabling FORWARDING-DESIRED on system queries
Cause: An informational message written to the log file when the server disables the FORWARDING-DESIRED attribute on queries that it generates. The message comes in response to a request from the Oracle Names control program.
Action: none
NNO-00614: enabling FORWARDING-DESIRED on system queries
Cause: An informational message written to the log file when the server enables the FORWARDING-DESIRED attribute on queries that it generates. The message comes in response to a request from the Oracle Names control program.
Action: none
NNO-00615: disabling DEFAULT-FORWARDERS-ONLY mode
Cause: An informational message written to the log file when the server disables DEFAULT-FORWARDERS-ONLY mode in response to a request from the Oracle Names control program.
Action: none
NNO-00616: enabling DEFAULT-FORWARDERS-ONLY mode
Cause: An informational message written to the log file when the server enables DEFAULT-FORWARDERS-ONLY mode in response to a request from the Oracle Names control program.
Action: none
NNO-00617: enabling AUTHORITY-REQUIRED on system queries
Cause: An informational message written to the log file when the server enables the AUTHORITY-REQUIRED attribute on queries that it generates. The message comes in response to a request from the Oracle Names control program.
Action: none
NNO-00618: disabling AUTHORITY-REQUIRED on system queries
Cause: An informational message written to the log file when the server disables the AUTHORITY-REQUIRED attribute on queries that it generates. The message comes in response to a request from the Oracle Names control program.
Action: none
NNO-00622: warning: too many auto-refresh failures for name "string", query expired
Cause: If an auto-refresh query is issued and continuously returns an error for three days, the query is removed from the auto-refresh queue and a warning logged. The query can be restarted from the Oracle Names control program.
Action: this message will be preceded by numerous warnings that the query in question is failing. Use the Oracle Names control program to describe the failing query. Make sure the server being queried is running and that there is network connectivity between the querying server and the server being queried.
NNO-00623: setting auto-refresh retry interval to number seconds
Cause: An informational message written to the log file when the server changes its auto-refresh retry interval in response to a request from the Oracle Names control program.
Action: none
NNO-00624: setting auto-refresh expiration period to number seconds
Cause: An informational message written to the log file when the server changes its auto-refresh expiration period in response to a request from the Oracle Names control program.
Action: none
NNO-00625: overriding auto-refresh of name "string", type "string", refresh in number seconds
Cause: An informational message written to the log file when the server changes the time when an auto-refresh query is next issued. The message comes in response to a request from the Oracle Names control program.
Action: none
NNO-00626: cannot enable DEFAULT-FORWARDERS-ONLY mode, no default forwarders exist
Cause: the Oracle Names control program issued a request to enable DEFAULT-FORWARDERS-ONLY mode, and the request was ignored because the server has no default forwarders.
Action: none
NNO-00627: cancelling auto-refresh of name "string", type "string"
Cause: An informational message written to the log file when the server removes a query from the auto-refresh queue in response to a request from the Oracle Names control program.
Action: none
NNO-00628: setting maximum reforwards per query to number
Cause: An informational message written to the log file when the server changes its maximum-reforward count in response to a request from the Oracle Names control program.
Action: none
NNO-00629: warning: invalid forwarder list, no default forwarders loaded
Cause: The server's configuration contains an invalid forwarder description list.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00630: setting request-processing delay to number seconds
Cause: An informational message written to the log file when the server sets an artificial request-processing delay in response to a request from the Oracle Names control program.
Action: none
NNO-00631: warning: forwarder number has invalid name "string", forwarder ignored
Cause: The server's configuration contains a forwarder description with an invalid server name.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00632: warning: forwarder number has missing address, forwarder ignored
Cause: The server's configuration contains a forwarder description with a missing address.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00633: detected fatal delegation loop involving server "string"
Cause: the server detected a fatal delegation loop while forwarding a request. A loop occurs when the server's topology data indicates that it should forward a request to itself. The server immediately shuts down in response to this error.
Action: An internal error not normally visible to the user. For further details, turn on tracing and restart the server. If the error persists, contact Worldwide Customer Support.
NNO-00634: received authoritative name "string" when we are its authority
Cause: a server "X" received authoritative data from another server "Y" when server "X" is also authoritative for the data. Such situations should never arise because if server "X" is authoritative for the requested data, it should never forward the request to another server.
Action: An internal error not normally visible to the user. For further details, turn on tracing and restart the server. If the error persists, contact Worldwide Customer Support.
NNO-00635: warning: ignoring duplicate forwarder "string"
Cause: The server's default forwarder list contains a duplicate server. The duplicate is ignored and the server continues running.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00700: warning: cannot checkpoint the cache, trying again in number seconds
Cause: The server was unable to perform its normal periodic cache checkpointing, typically because the cache checkpoint file could not be written. The cache checkpoint file name appears as an informational message during server startup.
Action: Check to see that the server has permission to write the cache checkpoint file, and that there is sufficient disk space for the file to be written.
NNO-00701: warning: cannot construct checkpoint file name, checkpointing disabled
Cause: the server could not construct a system-dependent file name.
Action: An internal error not normally visible to the user. For further details, turn on tracing and restart the server. If the error persists, contact Worldwide Customer Support.
NNO-00702: cache checkpointing disabled
Cause: An informational message written to the log file when the server disables cache checkpointing in response to a request from the Oracle Names control program.
Action: none
NNO-00703: checkpoint interval changed to number seconds
Cause: An informational message written to the log file when the server changes its cache checkpoint interval in response to a request from the Oracle Names control program.
Action: none
NNO-00705: warning: cannot open checkpoint file "string", checkpointing disabled
Cause: the server was unable to open the named checkpoint file for writing. This problem is typically due to the file system's protection settings. The error is not fatal; it simply means the server will not checkpoint its cache.
Action: Check to see that the server has permission to write the file named in the error message.
NNO-00706: overriding next cache checkpoint, checking in number seconds
Cause: An informational message written to the log file when the server checkpoints its cache in response to a request from the Oracle Names control program.
Action: none
NNO-00707: server's cache will be flushed in number seconds
Cause: An informational message written to the log file when the server flushes its cache in response to a request from the Oracle Names control program.
Action: none
NNO-00708: cache flush countdown aborted
Cause: An informational message written to the log file whenever the Oracle Names control program halts a cache flush request previously sent to the server
Action: none
NNO-00709: failed delete of cache checkpoint file "string", cache flush may not work
Cause: the server attempted to flush its cache, which also deletes the cache checkpoint file. The file deletion failed, although the rest of the cache flush succeeded. Succeeding errors describe the reason for the deletion failure.
Action: This error typically occurs when two cache-flush operations are issued in succession without an intervening cache checkpoint operation (which would recreate the file). The first deletes the cache file, the second attempts to do so, but fails since the file has already been deleted. In such cases, the message is harmless and can be ignored. If, however, the error occurs because the server lacks permission to delete the file, then you must change the file system permissions so the server is allowed to delete the file.
NNO-00710: server's cache will be dumped to the trace file in number seconds
Cause: An informational message written to the log file when the server dumps its cache to the trace file in response to a request from the Oracle Names control program.
Action: none
NNO-00711: cache dump countdown aborted
Cause: An informational message written to the log file whenever the Oracle Names control program halts a cache dump request previously sent to the server
Action: none
NNO-00712: warning: group string cache checkpoint failed
Cause: The server was unable to perform its normal periodic cache checkpointing, typically because the cache checkpoint file could not be written. The cache checkpoint file name appears as an informational message during server startup.
Action: Check to see that the server has permission to write the cache checkpoint file, and that there is sufficient disk space for the file to be written.
NNO-00800: Error: cannot read version from config database
Cause: The query for the region database version failed. The database may be shut down, or the tables may not exist in the schema specified in names.ora.
Action: Correct any access problems accordingly.
NNO-00801: Error: OCI_SUCCESS_WITH_INFO: string
Cause: Diagnostic information was returned from OCI during region database access.
Action: none
NNO-00802: Error: OCI_NEED_DATA
Cause: The server did not provide sufficient data to the OCI interface while accesing the region database.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00803: Error: OCI_INVALID_HANDLE
Cause: The server called OCI with an invalid handle whilc accessing the region database.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNO-00804: Error: OCI_STILL_EXECUTE
Cause: An OCI operation between the server and the database is still in progress.
Action: none
NNO-00805: Error: OCI_CONTINUE
Cause: Not possible.
Action: none
NNO-00806: Error: OCI_ERROR: string
Cause: An OCI occurred accessing the region database. More specific details will be written to the log file.
Action: Find the appropriate entry in the log file and correct the cause of the failure if possible. Otherwise contact Worldwide Customer Support.
NNO-00807: End of Fetch: OCI_NO_DATA
Cause: All rows have been returned from the region table.
Action: none
NNO-00808: Error connecting to region database
Cause: Not possible.
Action: none
NNO-00809: Unknown OCI error: number
Cause: Not possible.
Action: none
NNO-00850: Error: LDAP query returns string
Cause: The LDAP API returned an error. More specific details will be written to the log file.
Action: Find the appropriate entry in the log file and correct the cause of the failure if possible. Otherwise contact Worldwide Customer Support.
NNO-00851: LDAP open/bind failed: error = number
Cause: the server failed to connect to the LDAP directory.
Action: Find the cause of the error and correct it and restart the server.
NNO-00852: failed to get LDAP entry: error = number
Cause: the server could not retrieve query entries from the LDAP API.
Action: Find the cause of the error and correct it and restart the server.
NNO-00853: failed to get LDAP attribute/value: error = number
Cause: the server failed to connect to the LDAP directory.
Action: Find the cause of the error and correct it and restart the server.
NNO-00854: error unbinding LDAP: error = number
Cause: the server failed to connect to the LDAP directory.
Action: Find the cause of the error and correct it and restart the server.


45 NNL-00001 to NNL-01078

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

45 NNL-00001 to NNL-01078

NNL-00001: request argument "string" is invalid
Cause: The user entered an invalid request command argument.
Action: Supply a valid argument.
NNL-00002: request argument "string" is not allowed with this operation
Cause: The user entered a request command argument which is not valid with the particular request command.
Action: Supply a valid argument.
NNL-00003: memory exhausted
Cause: The program has run out of memory
Action: Check the amount of available memory on your machine to ensure that there is enough memory to run this executable. If necessary, free up memory by running fewer programs, then try again.
NNL-00004: invalid command argument "string"
Cause: The user entered an invalid command argument.
Action: Supply a valid argument.
NNL-00005: no server has been set. Use the "SET SERVER" command first
Cause: The user attempted to issue a command which requires that a default managed Oracle Names server be set first.
Action: Use the SET SERVER command to set your default server, then reissue the command. Alternatively, if the command allows, re-issue it with a specific server name so the control program does not need to use the default.
NNL-00006: timeout, server is not responding
Cause: The control program issued a request to an Oracle Names server and no response arrived in a timely fashion. The network connection between the control program and the server may be faulty, the server may be very heavily loaded, or there may be substantial network delays between the control program and the server. The latter is especially true for WAN links.
Action: Reissue the command; if it continues to fail, check to see that the server being managed is running correctly and that the network connection between the server and the control program is working correctly.
NNL-00007: server responded with an error
Cause: The control program issued a request to an Oracle Names server and the server responded with an error.
Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNL-00008: request not understood by server
Cause: The control program issued a request to an Oracle Names server and the server did not understand the request.
Action: If the server and the control program have different versions, they may be unable to communicate. Check your documentation for version compatibility constraints. If the server and control program are compatible, turn on tracing for further details, and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNL-00009: encryption of server password failed
Cause: The control program attempted and failed to encrypt a server password, supplied either through the SET PASSWORD command or the namesctl.server_password configuration parameter.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNL-00010: error getting address for server "string"
Cause: s for the failure. The control program's SQLNET.ORA file must exist in the correct system-specific location, and must be readable by the control program. The file must contain a names.preferred_servers entry with valid name server addresses. If the user has changed managed servers with the SET SERVER command, the new server must be running, and must be able to resolve the address or forward the request to another server which can resolve the address. Alternatively, a TNSNAMES.ORA file with valid name server names and addresses must exist in the correct system-specific location.
Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNL-00011: no server with name "string" exists
Cause: The user issued a SET SERVER request and the current managed Oracle Names server was unable to translate that name into an address. Alternatively, the user issued a control program request to a specific server, and that server's name could not be translated into an address. Both problems are almost always caused by mis-typing the server name.
Action: Re-issue the request with a valid server name.
NNL-00012: invalid "string" value "string"
Cause: The first argument is a data type, the second is a value. The user supplied an invalid data value of the specified type.
Action: Re-issue the failing operation with correct data.
NNL-00013: not performed, permission denied for supplied password
Cause: The user issued a request to an Oracle Names server, and the password supplied with the request was incorrect.
Action: Check to see that the password sent by the control program to the server is correct for that server. You can set a new password with the SET PASSWORD control program command.
NNL-00014: unknown data type "string"
Cause: The user issued a name server request which contained an unknown data type.
Action: It is possible that the server had no information on the type, but automatically fetched it in response to the failing request. Re-issue the failing request; if the server has in the meantime fetched the appropriate data type information, the error will go away. If the error persists, the data type is probably invalid.
NNL-00015: type "string" has "string" syntax, which has no textual representation
Cause: Not all data type syntaxes can be represented as text. This message indicates that the user issued a name server request for a type with an non-textual representation.
Action: Re-issue the operation with a data type that has a syntax with a textual representation.
NNL-00016: cannot start server, error getting program directory's name
Cause: The user issued a STARTUP request, but the control program was unable to start the server because it was unable to find the name of the directory where the server executable resides.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNL-00017: cannot start server, program "string" does not exist
Cause: The user issued a STARTUP request, but the control program was unable to start the server because it was unable to find the server executable.
Action: Make sure that a copy of the server executable exists in your system's oracle executable directory.
NNL-00018: warning: could not contact default name server
Cause: The control program was unable to contact its default name server during startup. There are a number of possible causes for this error. The control program's SQLNET.ORA file must exist in the correct system-specific location, and must be readable by the control program. The file must contain a names.preferred_servers entry with valid name server addresses. The first server in the preferred-server list must be running, and there must be network connectivity between the control program and that server.
Action: Check to see that all of the above are true. If the control program is still unable to contact its default server, turn on tracing and restart the control program. If the error persists, contact Worldwide Customer Support.
NNL-00019: warning: server either changed or ignored your request
Cause: The user issued a request to an Oracle Names server and that request was altered in some way. Typically the user specified an invalid argument of some sort, and the server either ignored the request, or replaced the invalid argument with a reasonable default.
Action: Use the control program to check the current state of the value that you attempted to change. The server's log file may also contain information about the exact cause of the problem. Re-issue the operation with correct arguments.
NNL-00020: warning: no TNSNAMES.ORA file and no preferred name servers in SQLNET.ORA
Cause: The control program was unable to find a TNSNAMES.ORA file and was unable to find a default name server in SQLNET.ORA. The control program will operate in this state, but will be unable to resolve any names until a default server has been set, and that server must be set using its raw TNS address.
Action: The control program's SQLNET.ORA file must exist in the correct system-specific location, and must be readable by the control program. The file must contain a names.preferred_servers entry with valid name server addresses. The first server in the preferred-server list must be running, and there must be network connectivity between the control program and that server. Alternatively, a TNSNAMES.ORA file with valid name server information must exist in the correct system-specific location.
NNL-00022: error changing trace level from string to string, level change ignored
Cause: The user attempted to change the control program's local trace level, and the program encountered an error while changing the level. Usually the problem is that tracing was enabled for the first time (by changing the trace level from OFF to something else) and the trace file is not writeable by the control program.
Action: Check to see that the trace file is writeable. Your documentation will tell you the name of the trace file.
NNL-00023: SET command is missing an argument
Cause: The user attempted to issue a SET command with no argument.
Action: Supply a valid argument to the SET command.
NNL-00024: warning: no preferred name servers in SQLNET.ORA
Cause: The control program was unable to find any preferred name servers in SQLNET.ORA, and will therefore not connect to a default server.
Action: Make sure that the SQLNET.ORA file contains a valid names.preferred_servers entry.
NNL-00035: File string or nested IFILEs not found.
Cause: Error in loading from the tnsfile.
Action: None.
NNL-00036: No records loaded
Cause: No loadable data.
Action: None.
NNL-00037: Error number while sequencing through parameter table.
Cause: The NL Parameter system reported an error while retrieving the next name from the table.
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNL-00038: Distinguished Name syntax error
Cause: Distinguished Name incorrectly specified.
Action: Supply a valid DN.
NNL-00039: no RRs
Cause: Object has no relevant RRs to be mapped to LDAP objects.
Action: None.
NNL-00040: Distinguished Name exceeds buffer length: string
Cause: Distinguished Name derived from Domain Name is too long.
Action: Either move the object to a domain whose name is shorter or manually update the LDAP object.
NNL-00041: Object string not in domain string
Cause: Object has no relevant RRs to be mapped to LDAP objects.
Action: None.
NNL-00042: LDAP bind failure: number, string
Cause: Call to ldap_bind failed with return set to given number.
Action: Correct user/pwd parameters or definitions.
NNL-00043: LDAP open failure
Cause: LDAP server could not be contacted.
Action: Correct connect info or server unavailability.
NNL-00044: Unsupported data type string not mapped
Cause: ONames data type could not be mapped to LDAP attributes
Action: An internal error not normally visible to the user. Contact Worldwide Customer Support.
NNL-00045: No host given for LDAP server
Cause: LDAP open will dump core without a host.
Action: Provide appropriate host with '-h' option.
NNL-00046: Name string exceeds DN template depth
Cause: There are more domains in the name than are specified in the DN template.
Action: Add fields to the template or migrate subdomains with separate dump operations.
NNL-00047: LDAP modify returned error: 0xnumber, string
Cause: LDAP failed with the return code shown.
Action: Refer to LDAP documentation for the meaning of the error.
NNL-00048: Error opening file: string
Cause: Named file cannot be opened.
Action: Provide for access to file.
NNL-00049: Output in string cannot be renamed to string
Cause: The given file cannot be created.
Action: Insure that the file specified can be created before running the command. Or use the temporary file itself.
NNL-00201: Shutdown occurs in string
Cause: Control program general message.
Action: None.
NNL-00202: No shutdown currently scheduled
Cause: Control program general message.
Action: None.
NNL-00203: Scheduled shutdown to occur in string
Cause: Control program general message.
Action: None.
NNL-00204: Cancelled shutdown
Cause: Control program general message.
Action: None.
NNL-00205: Reload check occurs in string
Cause: Control program general message.
Action: None.
NNL-00206: No reload check currently scheduled
Cause: Control program general message.
Action: None.
NNL-00207: Scheduled reload check to occur in string
Cause: Control program general message.
Action: None.
NNL-00208: Cancelled reload check
Cause: Control program general message.
Action: None.
NNL-00209: Cache checkpoint interval is currently string
Cause: Control program general message.
Action: None.
NNL-00210: Cache checkpointing is currently disabled
Cause: Control program general message.
Action: None.
NNL-00211: Cache checkpoint interval is now string
Cause: Control program general message.
Action: None.
NNL-00212: Cache checkpointing is now disabled
Cause: Control program general message.
Action: None.
NNL-00213: No entry with specified index number, try "SHOW SYSTEM_QUERIES"
Cause: Control program general message.
Action: None.
NNL-00214: Next auto-refresh for specified index number occurs in string
Cause: Control program general message.
Action: None.
NNL-00215: Scheduled specified index number's next auto-refresh to occur in string
Cause: Control program general message.
Action: None.
NNL-00216: Disabled auto-refresh for specified index number
Cause: Control program general message.
Action: None.
NNL-00217: Controller is sleeping for number seconds
Cause: Control program general message.
Action: None.
NNL-00218: Ignoring spurious trailing text "string"
Cause: Control program general message.
Action: None.
NNL-00219: Statistic counter logging interval is currently string
Cause: Control program general message.
Action: None.
NNL-00220: Statistic counter logging is currently disabled
Cause: Control program general message.
Action: None.
NNL-00221: Statistic counter logging interval is now string
Cause: Control program general message.
Action: None.
NNL-00222: Statistic counter logging is now disabled
Cause: Control program general message.
Action: None.
NNL-00223: Statistic counters are next logged in string
Cause: Control program general message.
Action: None.
NNL-00224: Scheduled statistic counters to be logged in string
Cause: Control program general message.
Action: None.
NNL-00225: Currently managing name server "string"
Cause: Control program general message.
Action: None.
NNL-00226: Current request-processing delay is string
Cause: Control program general message.
Action: None.
NNL-00227: Request-processing delay is currently disabled
Cause: Control program general message.
Action: None.
NNL-00228: Request-processing delay is now string
Cause: Control program general message.
Action: None.
NNL-00229: Request-processing delay is now disabled
Cause: Control program general message.
Action: None.
NNL-00230: Controller NOCONFIRM mode is currently string
Cause: Control program general message.
Action: None.
NNL-00231: Controller NOCONFIRM mode is now string
Cause: Control program general message.
Action: None.
NNL-00232: Auto-refresh failure-retry interval is currently string
Cause: Control program general message.
Action: None.
NNL-00233: Auto-refresh failure-retry interval is now string
Cause: Control program general message.
Action: None.
NNL-00234: Auto-refresh failure-retry expiration period is currently string
Cause: Control program general message.
Action: None.
NNL-00235: Auto-refresh failure-retry expiration period is now string
Cause: Control program general message.
Action: None.
NNL-00236: Statistic counter reset interval is currently string
Cause: Control program general message.
Action: None.
NNL-00237: Resetting of statistic counters is currently disabled
Cause: Control program general message.
Action: None.
NNL-00238: Statistic counter reset interval is now string
Cause: Control program general message.
Action: None.
NNL-00239: Resetting of statistic counters is now disabled
Cause: Control program general message.
Action: None.
NNL-00240: Starting "string"...
Cause: Control program general message.
Action: None.
NNL-00241: Processing of modification requests is currently enabled
Cause: Control program general message.
Action: None.
NNL-00242: Processing of modification requests is currently disabled
Cause: Control program general message.
Action: None.
NNL-00243: Processing of modification requests is now enabled
Cause: Control program general message.
Action: None.
NNL-00244: Processing of modification requests is now disabled
Cause: Control program general message.
Action: None.
NNL-00245: General request processing is currently enabled
Cause: Control program general message.
Action: None.
NNL-00246: General request processing is currently disabled
Cause: Control program general message.
Action: None.
NNL-00247: General request processing is now enabled
Cause: Control program general message.
Action: None.
NNL-00248: General request processing is now disabled
Cause: Control program general message.
Action: None.
NNL-00249: DEFAULT-FORWARDERS-ONLY mode is currently enabled
Cause: Control program general message.
Action: None.
NNL-00250: DEFAULT-FORWARDERS-ONLY mode is currently disabled
Cause: Control program general message.
Action: None.
NNL-00251: DEFAULT-FORWARDER-ONLY mode is now enabled
Cause: Control program general message.
Action: None.
NNL-00252: DEFAULT-FORWARDER-ONLY mode is now disabled
Cause: Control program general message.
Action: None.
NNL-00253: Server-generated requests currently request forwarding
Cause: Control program general message.
Action: None.
NNL-00254: Server-generated requests currently do not request forwarding
Cause: Control program general message.
Action: None.
NNL-00255: Server-generated requests now request forwarding
Cause: Control program general message.
Action: None.
NNL-00256: Server-generated requests now do not request forwarding
Cause: Control program general message.
Action: None.
NNL-00257: Server-generated requests currently require authoritative answers
Cause: Control program general message.
Action: None.
NNL-00258: Server-generated requests currently do not require authoritative answers
Cause: Control program general message.
Action: None.
NNL-00259: Server-generated requests now require authoritative answers
Cause: Control program general message.
Action: None.
NNL-00260: Server-generated requests now do not require authoritative answers
Cause: Control program general message.
Action: None.
NNL-00261: Request forwarding is currently enabled
Cause: Control program general message.
Action: None.
NNL-00262: Request forwarding is currently disabled
Cause: Control program general message.
Action: None.
NNL-00263: Request forwarding is now enabled
Cause: Control program general message.
Action: None.
NNL-00264: Request forwarding is now disabled
Cause: Control program general message.
Action: None.
NNL-00266: Round trip time is string
Cause: Control program general message.
Action: None.
NNL-00267: Address is string
Cause: Control program general message.
Action: None.
NNL-00268: Enter name server password:
Cause: Prompt for password after user has issued 'set password'
Action: Type password, invisibly.
NNL-00270: Current default domain is "string"
Cause: Control program general message.
Action: None.
NNL-00271: Default domain is now "string"
Cause: Control program general message.
Action: None.
NNL-00272: Removed name "string" from caches along the following path:
Cause: Control program general message.
Action: None.
NNL-00273: server successfully started
Cause: Control program general message.
Action: None.
NNL-00274: server not started, errors follow
Cause: Control program general message.
Action: None.
NNL-00275: Trace level is currently number
Cause: Control program general message.
Action: None.
NNL-00276: Trace level is now number
Cause: Control program general message.
Action: None.
NNL-00277: Maximum number of times a request can be reforwarded is currently number
Cause: Control program general message.
Action: None.
NNL-00278: Maximum number of times a request can be reforwarded is now number
Cause: Control program general message.
Action: None.
NNL-00279: Restart occurs in string
Cause: Control program general message.
Action: None.
NNL-00280: No restart currently scheduled
Cause: Control program general message.
Action: None.
NNL-00281: Scheduled restart to occur in string
Cause: Control program general message.
Action: None.
NNL-00282: Cancelled restart
Cause: Control program general message.
Action: None.
NNL-00283: Next cache checkpoint occurs in string
Cause: Control program general message.
Action: None.
NNL-00284: Scheduled cache checkpoint to occur in string
Cause: Control program general message.
Action: None.
NNL-00285: Server has no queued system queries
Cause: Control program general message.
Action: None.
NNL-00286: Server does not own any domains
Cause: Control program general message.
Action: None.
NNL-00287: Cache flush occurs in string
Cause: Control program general message.
Action: None.
NNL-00288: No cache flush currently scheduled
Cause: Control program general message.
Action: None.
NNL-00289: Scheduled cache flush to occur in string
Cause: Control program general message.
Action: None.
NNL-00290: Cancelled cache flush
Cause: Control program general message.
Action: None.
NNL-00291: Statistic counters are next reset in string
Cause: Control program general message.
Action: None.
NNL-00292: Scheduled statistic counters to be reset in string
Cause: Control program general message.
Action: None.
NNL-00293: Controller's trace level remains unchanged
Cause: Control program general message.
Action: None.
NNL-00294: No entries found
Cause: Control program general message.
Action: None.
NNL-00295: Controller's local trace level is currently number
Cause: Control program general message.
Action: None.
NNL-00296: Controller's local trace level changed from number to number
Cause: Control program general message.
Action: None.
NNL-00297: Cache will be dumped to trace file in string
Cause: Control program general message.
Action: None.
NNL-00298: No cache dump currently scheduled
Cause: Control program general message.
Action: None.
NNL-00299: Scheduled server cache dump to occur in string
Cause: Control program general message.
Action: None.
NNL-00300: Cancelled server cache dump
Cause: Control program general message.
Action: None.
NNL-00301: Server shutting down
Cause: Control program general message.
Action: None.
NNL-00302: Server restarting
Cause: Control program general message.
Action: None.
NNL-00303: Server checking for reload
Cause: Control program general message.
Action: None.
NNL-00304: Server flushing its cache
Cause: Control program general message.
Action: None.
NNL-00305: Server dumping statistics to the log file
Cause: Control program general message.
Action: None.
NNL-00306: Server setting all statistic counters to zero
Cause: Control program general message.
Action: None.
NNL-00307: Server checkpointing its cache
Cause: Control program general message.
Action: None.
NNL-00308: Server dumping its cache to the trace file
Cause: Control program general message.
Action: None.
NNL-00340: Trace file name is currently string
Cause: Control program general message.
Action: None.
NNL-00341: Trace file name is now string
Cause: Control program general message.
Action: None.
NNL-00342: Log file name is currently string
Cause: Control program general message.
Action: None.
NNL-00343: Log file name is now string
Cause: Control program general message.
Action: None.
NNL-00344: Save_config_on_stop is currently ON
Cause: Control program general message.
Action: None.
NNL-00345: Save_config_on_stop is currently OFF
Cause: Control program general message.
Action: None.
NNL-00346: Save_config_on_stop is now ON
Cause: Control program general message.
Action: None.
NNL-00347: Save_config_on_stop is now OFF
Cause: Control program general message.
Action: None.
NNL-00348: Server saving the config file now
Cause: Control program general message.
Action: None.
NNL-00349: Configuration will be saved in string
Cause: Control program general message.
Action: None.
NNL-00350: No save config currently scheduled
Cause: Control program general message.
Action: None.
NNL-00351: Scheduled configuration save to occur in string
Cause: Control program general message.
Action: None.
NNL-00352: Cancelled save config
Cause: Control program general message.
Action: None.
NNL-00353: Not allowed
Cause: Control program general message.
Action: None.
NNL-00400: Response status:
Cause: Control program general message.
Action: None.
NNL-00401: Authoritative answer: string
Cause: Control program general message.
Action: None.
NNL-00402: Authoritative server: string
Cause: Control program general message.
Action: None.
NNL-00403: Number of answers: number
Cause: Control program general message.
Action: None.
NNL-00404: TTL: string
Cause: Control program general message.
Action: None.
NNL-00405: Forwarding information:
Cause: Control program general message.
Action: None.
NNL-00406: Canonical name: string
Cause: Control program general message.
Action: None.
NNL-00407: Alias translations:
Cause: Control program general message.
Action: None.
NNL-00408: Answers:
Cause: Control program general message.
Action: None.
NNL-00409: data type is "string"
Cause: Control program general message.
Action: None.
NNL-00410: Average response time: string
Cause: Control program general message.
Action: None.
NNL-00411: Minimum response time: string
Cause: Control program general message.
Action: None.
NNL-00412: Number of requests: number
Cause: Control program general message.
Action: None.
NNL-00413: Total response time: string
Cause: Control program general message.
Action: None.
NNL-00414: Maximum response time: string
Cause: Control program general message.
Action: None.
NNL-00415: Name: string
Cause: Control program general message.
Action: None.
NNL-00416: Last timestamp: number
Cause: Control program general message.
Action: None.
NNL-00417: Distinguished Name: string
Cause: Control program general message.
Action: None.
NNL-00418: Attributes Mapped: number
Cause: Control program general message.
Action: None.
NNL-00500: Shows information on domains served by this server
Cause: Control program help text.
Action: None.
NNL-00501: set|show log_stats_interval [<seconds>] [<server_list>] : set|show the server's statistic counter logging interval
Cause: Control program help text.
Action: None.
NNL-00502: Shows, sets, or cancels when the server next dumps its statistic counters
Cause: Control program help text.
Action: None.
NNL-00503: repeat <number> <command> [<args>] : repeat a command <number> times
Cause: Control program help text.
Action: None.
NNL-00505: log_stats [<server_list>] : write Names server statistics to the log file
Cause: Control program help text.
Action: None.
NNL-00506: reset_stats [<server_list>] : reset Names server statistics
Cause: Control program help text.
Action: None.
NNL-00507: Shows, sets, or cancels the time when an auto-refresh query is next issued
Cause: Control program help text.
Action: None.
NNL-00508: show system_queries [<server_list>] : show system query information
Cause: Control program help text.
Action: None.
NNL-00509: set|show cache_checkpoint_interval [<seconds>] [<server_list>] : set|show the server's cache checkpoint interval
Cause: Control program help text.
Action: None.
NNL-00510: Adds a data record to an existing name
Cause: Control program help text.
Action: None.
NNL-00511: Shows or sets the server's system query authority requirements
Cause: Control program help text.
Action: None.
NNL-00512: Shows or sets the server's auto-refresh expiration period
Cause: Control program help text.
Action: None.
NNL-00513: Shows or sets the server's auto-refresh failure retry interval
Cause: Control program help text.
Action: None.
NNL-00514: Creates a new name with a default TTL
Cause: Control program help text.
Action: None.
NNL-00515: Deletes a name and its data
Cause: Control program help text.
Action: None.
NNL-00516: Displays complete server status
Cause: Control program help text.
Action: None.
NNL-00517: Insert-replaces a data item under an existing name
Cause: Control program help text.
Action: None.
NNL-00518: Shows or sets the maximum number of times a server can reforward a request
Cause: Control program help text.
Action: None.
NNL-00519: Shows, enables, or disables modification request processing
Cause: Control program help text.
Action: None.
NNL-00520: Changes an existing name's TTL
Cause: Control program help text.
Action: None.
NNL-00521: Shows or sets the server's system query forwarding requirements
Cause: Control program help text.
Action: None.
NNL-00522: Removes a data item from a name by value or by type
Cause: Control program help text.
Action: None.
NNL-00523: Renames an existing name
Cause: Control program help text.
Action: None.
NNL-00524: Replaces a data item with another data item
Cause: Control program help text.
Action: None.
NNL-00525: Shows or sets the server's default-forwarding status
Cause: Control program help text.
Action: None.
NNL-00526: Starts a server using a non-standard executable and optional arguments
Cause: Control program help text.
Action: None.
NNL-00527: Shows, sets, or cancels the time when the server next checkpoints its cache
Cause: Control program help text.
Action: None.
NNL-00528: [set] password <password> : set the password for subsequent calls
Cause: Control program help text.
Action: None.
NNL-00529: set|show default_domain [<domain_name>] : set|show the current default domain
Cause: Control program help text.
Action: None.
NNL-00530: quit|exit : exit the names control program
Cause: Control program help text.
Action: None.
NNL-00531: flush_name <name> : removes a name from caches along a route to an authoritative server
Cause: Control program help text.
Action: None.
NNL-00532: set|show forwarding_available [<on|off>] [<server_list>] : enable, disable or show server request forwarding
Cause: Control program help text.
Action: None.
NNL-00533: ping [<server_list>] : ping one or more Names servers
Cause: Control program help text.
Action: None.
NNL-00534: query <name> [<type>] : query for a desired name and RR type
Cause: Control program help text.
Action: None.
NNL-00535: reload [<server_list>] : reload server cache data if there are changes
Cause: Control program help text.
Action: None.
NNL-00536: set|show requests_enabled [<on|off>] [<server_list>] : enable, disable or show server request processing
Cause: Control program help text.
Action: None.
NNL-00537: set|show server [<server_name>] : set|show the currently managed server
Cause: Control program help text.
Action: None.
NNL-00538: stop|shutdown [<server_list>] : stop one or more Names servers
Cause: Control program help text.
Action: None.
NNL-00539: start|startup [<args>] : start the Names server with optional arguments
Cause: Control program help text.
Action: None.
NNL-00540: [show] status [<server_list>] : display server status summary
Cause: Control program help text.
Action: None.
NNL-00541: set|show trace_level [<level>] [<server_list>] : set|show the server's tracing level
Cause: Control program help text.
Action: None.
NNL-00542: restart [<server_list>] : restart one or more Names servers
Cause: Control program help text.
Action: None.
NNL-00543: [show] version [<server_list>] : show the name and version of one or more Names servers
Cause: Control program help text.
Action: None.
NNL-00544: Displays operations statistics
Cause: Control program help text.
Action: None.
NNL-00545: Displays query request statistics
Cause: Control program help text.
Action: None.
NNL-00546: Displays delete request statistics
Cause: Control program help text.
Action: None.
NNL-00547: Displays rename request statistics
Cause: Control program help text.
Action: None.
NNL-00548: Displays update request statistics
Cause: Control program help text.
Action: None.
NNL-00549: Displays stream usage statistics
Cause: Control program help text.
Action: None.
NNL-00550: flush [<server_list>] : flush one or more servers' cache(s)
Cause: Control program help text.
Action: None.
NNL-00551: Displays cache statistics
Cause: Control program help text.
Action: None.
NNL-00553: Displays forwarding statistics
Cause: Control program help text.
Action: None.
NNL-00555: Displays meta data statistics
Cause: Control program help text.
Action: None.
NNL-00556: set|show reset_stats_interval [<seconds>] [<server_list>] : set|show server statistic counter reset interval
Cause: Control program help text.
Action: None.
NNL-00557: Causes the controller to sleep for N seconds
Cause: Control program help text.
Action: None.
NNL-00558: set|show namesctl_trace_level : set|show the controller's tracing level
Cause: Control program help text.
Action: None.
NNL-00559: Shows, sets, or cancels the time for the next cache dump to the trace file
Cause: Control program help text.
Action: None.
NNL-00560: Shows or sets the server's request-processing delay
Cause: Control program help text.
Action: None.
NNL-00561: register <name> [-t<type>] [-d<address>] [-h<hostname>] [-l<listener_name>] : register an object with Oracle Names
Cause: Control program help text.
Action: None.
NNL-00562: unregister <name> [-d<address>] [-l<listener_name>] : unregister an object with Oracle Names
Cause: Control program help text.
Action: None.
NNL-00563: timed_query [<timestamp>] : query all objects in the Names server's cache
Cause: Control program help text.
Action: None.
NNL-00565: set trace_file_name [<filename>] [<server_list>] : set|show the server's trace file name
Cause: Control program help text.
Action: None.
NNL-00566: set|show log_file_name [<filename>] [<server_list>] : set|show the log file name on one or more servers
Cause: Control program help text.
Action: None.
NNL-00567: reorder_ns [<server_address>] : Generate the enhanced discovery file
Cause: Control program help text.
Action: None.
NNL-00568: delegate_domain <domain_name> <NS_name> <NS_Addr> : Delegate the given domain to the given nameserver
Cause: Control program help text.
Action: None.
NNL-00569: domain_hint <domain_name> <NS_name> <NS_Addr> : Provide hint of a nameserver for a given domain
Cause: Control program help text.
Action: None.
NNL-00570: save_config [<server_list>] : saves server configuration to parameter file
Cause: Control program help text.
Action: None.
NNL-00571: set|show save_config_on_stop [<on|off>]
Cause: Control program help text.
Action: None.
NNL-00572: set|show save_config_interval [<seconds>] [<server_list>] : set time of next config save
Cause: Control program help text.
Action: None.
NNL-00573: load_tnsnames [<file>, ... ] : load tnsnames into ONames
Cause: Control program help text.
Action: None.
NNL-00574: dump_tnsnames [<file>] : dump ONames addresses into tnsnames file
Cause: Control program help text.
Action: None.
NNL-00575: list_objects: list all objects in a domain or subtree
Cause: Control program help text.
Action: None.
NNL-00576: list_delegated: list all delegated domains in the region or subtree
Cause: Control program help text.
Action: None.
NNL-00577: list_domains: list authoritative domains in the region or subtree
Cause: Control program help text.
Action: None.
NNL-00578: dump_ldap: dump addresses in the domain or region to LDAP
Cause: Control program help text.
Action: None.
NNL-00579: _scan: find objects/records matching the given types
Cause: Control program help text.
Action: None.
NNL-00580: register_ns: <name server> <address> <domain>
Cause: Control program help text.
Action: None.
NNL-00581: unregister_ns: <name server> <domain>
Cause: Control program help text.
Action: None.
NNL-00582: dump_alias: dump aliases in the domain or region to LDAP
Cause: Control program help text.
Action: None.
NNL-00800: Query requests received: number
Cause: Control program statistic description
Action: None.
NNL-00801: Queries received, type ANY: number
Cause: Control program statistic description
Action: None.
NNL-00802: Queries received, type ADDRESS: number
Cause: Control program statistic description
Action: None.
NNL-00803: Queries received, type ALIAS: number
Cause: Control program statistic description
Action: None.
NNL-00804: Queries received, type META-DATA: number
Cause: Control program statistic description
Action: None.
NNL-00805: Queries received, type NAME-SERVER: number
Cause: Control program statistic description
Action: None.
NNL-00806: Queries received, type RELATED-INFO: number
Cause: Control program statistic description
Action: None.
NNL-00807: Queries received, type SOA: number
Cause: Control program statistic description
Action: None.
NNL-00808: Queries received, all user-defined types: number
Cause: Control program statistic description
Action: None.
NNL-00809: Queries received, multiple types: number
Cause: Control program statistic description
Action: None.
NNL-00810: Queries received with no type: number
Cause: Control program statistic description
Action: None.
NNL-00811: Fastest query processing time: string
Cause: Control program statistic description
Action: None.
NNL-00812: Slowest query processing time: string
Cause: Control program statistic description
Action: None.
NNL-00813: Average query processing time: string
Cause: Control program statistic description
Action: None.
NNL-00814: Total query processing time: string
Cause: Control program statistic description
Action: None.
NNL-00830: Delete requests received: number
Cause: Control program statistic description
Action: None.
NNL-00831: Deletes refused, name is not a leaf name: number
Cause: Control program statistic description
Action: None.
NNL-00832: Deletes refused, name is a topology name: number
Cause: Control program statistic description
Action: None.
NNL-00833: Fastest delete processing time: string
Cause: Control program statistic description
Action: None.
NNL-00834: Slowest delete processing time: string
Cause: Control program statistic description
Action: None.
NNL-00835: Average delete processing time: string
Cause: Control program statistic description
Action: None.
NNL-00836: Total delete processing time: string
Cause: Control program statistic description
Action: None.
NNL-00850: Rename requests received: number
Cause: Control program statistic description
Action: None.
NNL-00851: Renames refused, name is not a leaf name: number
Cause: Control program statistic description
Action: None.
NNL-00852: Renames refused, name is a topology name: number
Cause: Control program statistic description
Action: None.
NNL-00853: Renames refused, new name already exists: number
Cause: Control program statistic description
Action: None.
NNL-00854: Fastest rename processing time: string
Cause: Control program statistic description
Action: None.
NNL-00855: Slowest rename processing time: string
Cause: Control program statistic description
Action: None.
NNL-00856: Average rename processing time: string
Cause: Control program statistic description
Action: None.
NNL-00857: Total rename processing time: string
Cause: Control program statistic description
Action: None.
NNL-00870: Update requests received: number
Cause: Control program statistic description
Action: None.
NNL-00871: Updates refused, name is a topology name: number
Cause: Control program statistic description
Action: None.
NNL-00872: Updates refused, data is topology data: number
Cause: Control program statistic description
Action: None.
NNL-00873: Fastest update processing time: string
Cause: Control program statistic description
Action: None.
NNL-00874: Slowest update processing time: string
Cause: Control program statistic description
Action: None.
NNL-00875: Average update processing time: string
Cause: Control program statistic description
Action: None.
NNL-00876: Total update processing time: string
Cause: Control program statistic description
Action: None.
NNL-00890: Messages received: number
Cause: Control program statistic description
Action: None.
NNL-00891: Corrupted messages received: number
Cause: Control program statistic description
Action: None.
NNL-00892: Duplicate requests received: number
Cause: Control program statistic description
Action: None.
NNL-00893: Similar requests received: number
Cause: Control program statistic description
Action: None.
NNL-00894: Requests refused, permission denied: number
Cause: Control program statistic description
Action: None.
NNL-00895: Requests refused, processing disabled: number
Cause: Control program statistic description
Action: None.
NNL-00896: Requests refused, modifications disabled: number
Cause: Control program statistic description
Action: None.
NNL-00897: Messages sent: number
Cause: Control program statistic description
Action: None.
NNL-00898: Responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00899: OK responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00900: NO SUCH NAME responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00901: CONTENT ERROR responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00902: ALIAS LOOP responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00903: SERVER FAILURE responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00904: NAME EXISTS responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00905: NOT AUTHORITY responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00906: NOT A LEAF NAME responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00907: NOT ALLOWED responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00908: UNKNOWN TYPE responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00909: META VIOLATION responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00910: VERSION SKEW responses sent: number
Cause: Control program statistic description
Action: None.
NNL-00911: Responses sent with invalid error code: number
Cause: Control program statistic description
Action: None.
NNL-00912: Alias loops detected: number
Cause: Control program statistic description
Action: None.
NNL-00913: Server-generated requests sent: number
Cause: Control program statistic description
Action: None.
NNL-00914: Forwarding desired on server queries: string
Cause: Control program statistic description
Action: None.
NNL-00915: Authority required on server queries: string
Cause: Control program statistic description
Action: None.
NNL-00916: Modification requests enabled: string
Cause: Control program statistic description
Action: None.
NNL-00917: Artificial request processing delay: string
Cause: Control program statistic description
Action: None.
NNL-00918: Time until server restart: string
Cause: Control program statistic description
Action: None.
NNL-00919: Time until server shutdown: string
Cause: Control program statistic description
Action: None.
NNL-00920: Time until next config save: string
Cause: Control program statistic description
Action: None.
NNL-00930: Requests refused, unknown data type: number
Cause: Control program statistic description
Action: None.
NNL-00931: Requests refused, no cached meta-data: number
Cause: Control program statistic description
Action: None.
NNL-00932: Requests refused, type syntax mismatch: number
Cause: Control program statistic description
Action: None.
NNL-00933: Requests refused, OTHER-DATA violation: number
Cause: Control program statistic description
Action: None.
NNL-00934: Requests refused, ALIAS-EXISTS violation: number
Cause: Control program statistic description
Action: None.
NNL-00935: Requests refused, SINGLE-VALUE violation: number
Cause: Control program statistic description
Action: None.
NNL-00936: Requests refused, DATA-EXISTS violation: number
Cause: Control program statistic description
Action: None.
NNL-00950: Cache lookup requests: number
Cause: Control program statistic description
Action: None.
NNL-00951: Names created on lookup: number
Cause: Control program statistic description
Action: None.
NNL-00952: Cache lookup failures: number
Cause: Control program statistic description
Action: None.
NNL-00953: Cache lookup exact matches: number
Cause: Control program statistic description
Action: None.
NNL-00954: Hash tables created: number
Cause: Control program statistic description
Action: None.
NNL-00955: Hash tables enlarged: number
Cause: Control program statistic description
Action: None.
NNL-00956: Hash tables freed: number
Cause: Control program statistic description
Action: None.
NNL-00957: Name nodes created: number
Cause: Control program statistic description
Action: None.
NNL-00958: Name nodes freed: number
Cause: Control program statistic description
Action: None.
NNL-00959: Time until cache dump to trace file: string
Cause: Control program statistic description
Action: None.
NNL-00960: Time until cache flush: string
Cause: Control program statistic description
Action: None.
NNL-00961: Cache checkpoints: number
Cause: Control program statistic description
Action: None.
NNL-00962: Cache checkpoint failures: number
Cause: Control program statistic description
Action: None.
NNL-00963: Timeouts, name TTL expired: number
Cause: Control program statistic description
Action: None.
NNL-00970: System query index number: number
Cause: Control program statistic description
Action: None.
NNL-00971: Query ID: number
Cause: Control program statistic description
Action: None.
NNL-00972: Query next issued in: string
Cause: Control program statistic description
Action: None.
NNL-00973: Query state: number
Cause: Control program statistic description
Action: None.
NNL-00974: Name: string
Cause: Control program statistic description
Action: None.
NNL-00975: Desired data type: string
Cause: Control program statistic description
Action: None.
NNL-00980: Forwarding failures: number
Cause: Control program statistic description
Action: None.
NNL-00981: Timeouts, server not responding: number
Cause: Control program statistic description
Action: None.
NNL-00982: Not forwarded, no servers found: number
Cause: Control program statistic description
Action: None.
NNL-00983: Name-to-hint translations: number
Cause: Control program statistic description
Action: None.
NNL-00984: Name-to-hint translations failed: number
Cause: Control program statistic description
Action: None.
NNL-00985: Requests reforwarded using referrals: number
Cause: Control program statistic description
Action: None.
NNL-00986: Reforwarded requests expired: number
Cause: Control program statistic description
Action: None.
NNL-00987: Authoritative answers when authority: number
Cause: Control program statistic description
Action: None.
NNL-00988: Non-authoritative NACKs received: number
Cause: Control program statistic description
Action: None.
NNL-00989: Objects received with no TTL: number
Cause: Control program statistic description
Action: None.
NNL-00990: DEFAULT-FORWARDERS-ONLY mode: string
Cause: Control program statistic description
Action: None.
NNL-00991: Maximum number of reforwards per request: number
Cause: Control program statistic description
Action: None.
NNL-00992: Auto-refresh failure retry interval: string
Cause: Control program statistic description
Action: None.
NNL-00993: Auto-refresh failure retry expiration: string
Cause: Control program statistic description
Action: None.
NNL-00994: Responses received: number
Cause: Control program statistic description
Action: None.
NNL-00995: Unmatched responses received: number
Cause: Control program statistic description
Action: None.
NNL-00996: OK responses received: number
Cause: Control program statistic description
Action: None.
NNL-00997: NO SUCH NAME responses received: number
Cause: Control program statistic description
Action: None.
NNL-00998: CONTENT ERROR responses received: number
Cause: Control program statistic description
Action: None.
NNL-00999: ALIAS LOOP responses received: number
Cause: Control program statistic description
Action: None.
NNL-01000: SERVER FAILURE responses received: number
Cause: Control program statistic description
Action: None.
NNL-01001: NAME EXISTS responses received: number
Cause: Control program statistic description
Action: None.
NNL-01002: NOT AUTHORITY responses received: number
Cause: Control program statistic description
Action: None.
NNL-01003: NON LEAF responses received: number
Cause: Control program statistic description
Action: None.
NNL-01004: NOT ALLOWED responses received: number
Cause: Control program statistic description
Action: None.
NNL-01005: UNKNOWN TYPE responses received: number
Cause: Control program statistic description
Action: None.
NNL-01006: META VIOLATION responses received: number
Cause: Control program statistic description
Action: None.
NNL-01007: VERSION SKEW responses received: number
Cause: Control program statistic description
Action: None.
NNL-01008: Outbound message contexts allocated: number
Cause: Control program statistic description
Action: None.
NNL-01009: Outbound message contexts freed: number
Cause: Control program statistic description
Action: None.
NNL-01010: Forwarding contexts allocated: number
Cause: Control program statistic description
Action: None.
NNL-01011: Forwarding contexts freed: number
Cause: Control program statistic description
Action: None.
NNL-01030: Domain index number: number
Cause: Control program statistic description
Action: None.
NNL-01031: Name: string
Cause: Control program statistic description
Action: None.
NNL-01032: Minimum TTL: string
Cause: Control program statistic description
Action: None.
NNL-01040: Data streams opened by server: number
Cause: Control program statistic description
Action: None.
NNL-01041: Data stream open failures: number
Cause: Control program statistic description
Action: None.
NNL-01042: Data streams answered by server: number
Cause: Control program statistic description
Action: None.
NNL-01043: Data stream answer failures: number
Cause: Control program statistic description
Action: None.
NNL-01044: Errors reading data stream: number
Cause: Control program statistic description
Action: None.
NNL-01045: Errors writing data stream: number
Cause: Control program statistic description
Action: None.
NNL-01050: Version banner is "string"
Cause: Control program statistic description
Action: None.
NNL-01051: Server name: string
Cause: Control program statistic description
Action: None.
NNL-01052: Server has been running for: string
Cause: Control program statistic description
Action: None.
NNL-01053: Request processing enabled: string
Cause: Control program statistic description
Action: None.
NNL-01054: Request forwarding enabled: string
Cause: Control program statistic description
Action: None.
NNL-01055: Requests received: number
Cause: Control program statistic description
Action: None.
NNL-01056: Requests forwarded: number
Cause: Control program statistic description
Action: None.
NNL-01057: Foreign data items cached: number
Cause: Control program statistic description
Action: None.
NNL-01058: Region data next checked for reload in: string
Cause: Control program statistic description
Action: None.
NNL-01059: Region data reload check failures: number
Cause: Control program statistic description
Action: None.
NNL-01060: Cache next checkpointed in: string
Cause: Control program statistic description
Action: None.
NNL-01061: Cache checkpoint interval: string
Cause: Control program statistic description
Action: None.
NNL-01062: Cache checkpoint file name: string
Cause: Control program statistic description
Action: None.
NNL-01063: Statistic counters next reset in: string
Cause: Control program statistic description
Action: None.
NNL-01064: Statistic counter reset interval: string
Cause: Control program statistic description
Action: None.
NNL-01065: Statistic counters next logged in: string
Cause: Control program statistic description
Action: None.
NNL-01066: Statistic counter logging interval: string
Cause: Control program statistic description
Action: None.
NNL-01067: Trace level: number
Cause: Control program statistic description
Action: None.
NNL-01068: Trace file name: string
Cause: Control program statistic description
Action: None.
NNL-01069: Log file name: string
Cause: Control program statistic description
Action: None.
NNL-01070: System parameter file name: string
Cause: Control program statistic description
Action: None.
NNL-01071: Command-line parameter file name: string
Cause: Control program statistic description
Action: None.
NNL-01072: Administrative region name: string
Cause: Control program statistic description
Action: None.
NNL-01073: Administrative region description: string
Cause: Control program statistic description
Action: None.
NNL-01074: ApplTable Index: number
Cause: Control program statistic description
Action: None.
NNL-01075: Contact string
Cause: Control program statistic description
Action: None.
NNL-01076: Operational Status number
Cause: Control program statistic description
Action: None.
NNL-01077: Save Config on Stop string
Cause: Control program statistic description
Action: None.
NNL-01078: Access/Create File Error : string
Cause: Failed to access/create named file or its backup File due to incorrect permissions
Action: Provide correct access to file.


46 NPL-00100 to NPL-00420

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

46 NPL-00100 to NPL-00420

NPL-00100: cannot initialize ASN.1 context
Cause: The ASN.1 program interface could not be initialized, probably because its error message file could not be found.
Action: Check that SQL*Net has been installed properly and that all message files are in their proper locations.
NPL-00101: uninitialized ASN.1 context
Cause: The ASN.1 program interface received an uninitialized ASN.1 handle.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00102: missing stream functions in ASN.1 context initialization
Cause: An internal function imporoperly attempted to initialize an ASN.1 handle.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00103: unusable ASN.1 context
Cause: The ASN.1 program interface received an unusable ASN.1 handle.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00300: maximum ASN.1 element nesting depth string exceeded on read
Cause: An ASN.1 construct is too complex for the program interface to read.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00301: maximum ASN.1 element nesting depth string exceeded on write
Cause: An ASN.1 construct is too complex for the program interface to write.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00302: ASN.1 type tag is greater than maximum of 16383
Cause: An internal function attempted to create an illegal ASN.1 construct
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00303: uninitialized ASN.1 class attribute
Cause: An internal function attempted to create an illegal ASN.1 construct
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00304: uninitialized ASN.1 tag attribute
Cause: An internal function attempted to create an illegal ASN.1 construct
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00305: unsupported ASN.1 "UNIV" type string
Cause: An internal function attempted to create an illegal ASN.1 construct
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00307: ASN.1 sequence has already been ended on write
Cause: An internal function attempted to end an ASN.1 construct prematurely.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00308: requested ASN.1 class string does not match received class string
Cause: An internal function requested an ASN.1 construct different from that received by the ASN.1 protocol engine.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00309: requested ASN.1 type tag string does not match received type tag string
Cause: An internal function requested an ASN.1 construct different from that received by the ASN.1 protocol engine.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00310: ASN.1 sequence has already been ended on read
Cause: An internal function attempted to finish reading an ASN.1 construct which has already been completely read.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00311: cannot end constructed ASN.1 encoding, string encoding octets unread
Cause: An internal function attempted to finish reading an ASN.1 construct prematurely.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00312: attempt to put ASN.1 "UNIV" type with illegal tag string
Cause: An internal function attempted to create an illegal ASN.1 construct.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00313: requested form string does not match actual form string
Cause: An internal function received an ASN.1 construct different from that expected.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00410: incoming ASN.1 value too large (string octets) to store locally
Cause: The ASN.1 protocol engine was unable to translate an ASN.1 construct to its host representation because the construct was too big.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00411: incoming ASN.1 NULL encoding has nonzero length of string
Cause: The ASN.1 protocol engine received a corrupted ASN.1 construct.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00412: incoming ASN.1 BOOLEAN encoding has incorrect length of string
Cause: The ASN.1 protocol engine received a corrupted ASN.1 construct.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00413: incoming ASN.1 encoding has length string, maximum allowed is string
Cause: The ASN.1 protocol engine received an ASN.1 construct too large for it to process.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00414: incoming ASN.1 type tag is greater than maximum of 16383
Cause: The ASN.1 protocol engine received an illegal ASN.1 construct.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00415: received unsupported ASN.1 INDEFINITE-LENGTH encoding
Cause: The ASN.1 protocol engine received an ASN.1 encoding which it could not process because its implementation does not support it.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00416: received illegal ASN.1 encoding length of string
Cause: The ASN.1 protocol engine received a corrupted ASN.1 construct.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00417: received ASN.1 length octet count greater than maximum of string
Cause: The ASN.1 protocol engine received an ASN.1 encoding which it could not process because its implementation does not support it..
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00418: received malformed ASN.1 object identifier
Cause: The ASN.1 protocol engine received a corrupted ASN.1 construct.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00419: received ASN.1 object identifier with sub-identifier that is too large
Cause: The ASN.1 protocol engine received an ASN.1 encoding which it could not process because its implementation does not support it.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NPL-00420: received ASN.1 object identifier with more than 256 sub-identifiers
Cause: The ASN.1 protocol engine received an ASN.1 encoding which it could not process because its implementation does not support it.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.


47 NNF-00001 to NNF-04009

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

47 NNF-00001 to NNF-04009

NNF-00001: Not a TNS address
Cause: While asking to read an address the name service returned a record which was not an address.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNF-00002: Invalid value passed to function call
Cause: An invalid value was passed to an interface function.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNF-00003: Naming adapter string does not exist
Cause: The requested name service adapter was not found in the current adapter table.
Action: Check the spelling of the adapter reqested. Verify that the adapter runs on this platform, and the adapter is compiled into the adapter table linked into the executable.
NNF-00004: Operation not supported in string
Cause: The operation requested is not supported under this adapter.
Action: Verify that the operation being performed is not under restriction, such as writing to read-only name service. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNF-00005: Functionality not implemented
Cause: The operation requested is not supported in this implementation.
Action: If this is retrieved from a production release, contact Worldwide Customer Support. Otherwise, check the release notes as to the restrictions in this release.
NNF-00110: no values exist
Cause: Test program help text.
Action: None.
NNF-00540: Failed to insert name: string
Cause: Failed to insert name into the native service.
Action: Verify that the name is not already in the native namespace and the appropriate access permissions are set for the namespace.
NNF-01001: ds_initialize: workspace initialization failed
Cause: The DCE workspace as setup by ds_initialize() failed to initialize.
Action: Verify that conditions necessary for a successful ds_initialize() call are present on this platform (e.g is there enough memory?). Check that there is not another workspace user in this program. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNF-01002: DCE could not open configuration file
Cause: A DCE call returned an error that it could not access its configuration file.
Action: Check that the DCE configuration file for this platform is present, and accessable. On Unix this file is dce_cf.db. Check if a simple call to dce_cf_get_cell_name() succeeds.
NNF-01003: DCE could not find cell name
Cause: A DCE call returned an error that it could not find the cell name in its configuration file.
Action: Check that this machine has been configured for a DCE cell. Chcek that the DCE configuration file is not corrupted. On Unix, this file is dce_cf.db. Check if a simple call to dce_cf_get_cell_name() succeeds.
NNF-01004: DCE returned unspecified error string
Cause: A DCE call returned an status that was not in this implementation's list of possible status values for this DCE call.
Action: Verify that this platform's DCE release is not beyond those supported by this Oracle application. If the error persists, contact Worldwide Customer Support.
NNF-01005: Internal XOM class violation
Cause: A DCE XOM call returned statuses inconsistent with the class definitions in the DCE documentation.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNF-01006: Attribute string not available
Cause: A insertion call attempted to use an attribute which did not have a translation to a DCE attribute.
Action: Use another attribute, or insert the translation into DCE.
NNF-01007: DCE long strings are not supported
Cause: A query returned a object which has a XOM OM_S_LONG_STRING. The current implementation does not support such objects.
Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNF-01008: XDS attribute syntax string incorrect for Oracle Names syntax string
Cause: The syntax as specified in the XDS object is different than that which is expected for the given Oracle names syntax.
Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NNF-02001: NIS client error string: string
Cause: A call to an NIS (YP) function failed. This message contains the text of the NIS error code returned.
Action: Should only be visible when returned as part of another error. If the error persists, contact Worldwide Customer Support.
NNF-02002: NIS value does not conform to adapter schema: string
Cause: The values in the maps used by the NIS adapter must conform to a specific set of internal formatting rules. This value returned did not conform to those rules.
Action: Should not be visible, unless you are attempting to create your own maps. If the error persists, contact Worldwide Customer Support.
NNF-02003: Unknown NIS error code: string
Cause: An error code returned by a NIS (YP) function was not in the list expected by this program.
Action: Verify that the error is generated by the YP functions on this platform. Notify Worldwide Customer Support of the error.
NNF-02004: NIS map string does not exist
Cause: The requested attribute does not exist.
Action: For an unused attribute, no action is required, as this is the expected error. Otherwise, add the attribute and reload the NIS (YP) maps.
NNF-02005: NIS key string does not exist in map string
Cause: The requested name was not found.
Action: For an unused name, no action is required, as this is the expected error. Otherwise, add the name to the map and reload the NIS (YP) maps.
NNF-03002: Unknown BIND error code: string
Cause: The return code in the BIND (DNS) query response did not conform to those values listed in RFC 1035.
Action: Verify that the error is generated by the BIND functions on this platform. Notify Worldwide Customer Support of the error.
NNF-03003: Format error parsing server response
Cause: The query response packet returned from the BIND (DNS) API did not conform to the format listed in RFC 1035.
Action: Verify that the error is generated by the BIND functions on this platform. Notify Worldwide Customer Support of the error.
NNF-03004: DNS Class mismatch (string)
Cause: The query response packet returned a class different from the ones expected by the interface.
Action: Verify that the error is generated by the BIND functions on this platform. Notify Worldwide Customer Support of the error.
NNF-04000: File succesfully converted
Cause: The requested conversion is performed.
Action: Normal condition, no action necessary.
NNF-04001: Error converting input file
Cause: The input file contains lines that cannot be converted by the conversion program.
Action: Check that the syntax of the input file is correct.
NNF-04002: Outputfile already exists
Cause: An old output file already exists in the current directory
Action: Remove the existing file, and restart the conversion tool
NNF-04003: Entry in inputfile is too long
Cause: The makedbm program, limits entries in mapfiles to 1017 characters. Therefor, the conversion tool will not process TNS addresses which are longer than 1017 characters.
Action: Shorten the offending entry.
NNF-04004: Invalid string in inputfile
Cause: the input file contains invalid lines.
Action: Check that the syntax of the input file is correct.
NNF-04005: Cannot open inputfile
Cause: The specified input file could not be found.
Action: restart the conversion tool with the correct input file.
NNF-04006: Could not create outputfile
Cause: An output file could not be created in the current working directory
Action: Change the permissions of the current directory and restart the conversion tool.
NNF-04007: Error reading input file
Cause: A problem while reading the input file. This could be caused by an unexpected end of file in the input file.
Action: Check that the file is intact and that the syntax of the input file is correct.
NNF-04008: Error writing outputfile
Cause: An error occured while writing to the output file.
Action: Check available disk space. If the error persists, contact Worldwide Customer Support.
NNF-04009: Usage: tns2nis <filename>
Cause: The conversion tool was not invoked properly. The filename should either be tnsnames.ora or native.ora
Action: Restart the conversion tool with the proper parameter.


48 NMP-00001 to NMP-00011

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

48 NMP-00001 to NMP-00011

NMP-00001: value too big
Cause: The SNMP program interface received a value too large for it to process. This error is usually displayed underneath an error which describes in more detail the value which caused the problem.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NMP-00002: no such SNMP variable name
Cause: An SNMP request was not processed because the one or more of the variable names in the request does not exist. This error is not normally visible to the user except in a trace file, where it is usually part of a "soft" error condition which is normal.
Action: The error may indicate that a managed server does not support an operation requested by its control program, perhaps because of version incompatibility. For further details, turn on tracing and re-execute the failing operation. If the error persists, and does not occur as part of a "soft" error condition as noted in the trace file, contact Worldwide Customer Support.
NMP-00003: bad SNMP variable value
Cause: The SNMP program interface received a variable value which has an unsupported data type. This error may occur if a standard SNMP network monitor is sending requests to an Oracle service through an SNMP-to-TNS gateway, and that service cannot understand the requests.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, and occurs when an Oracle control program sends requests to an Oracle service, contact Worldwide Customer Support.
NMP-00004: SNMP variable is read only
Cause: The user attempted to change a variable value at a remote server, and that variable is read-only. This error is usually displayed underneath an error which describes the problem in more detail.
Action: Read-only variables may never be modified.
NMP-00005: general SNMP error
Cause: an SNMP error occured which did not fall under the heading of any other more specific error condition. This error may occur if a standard SNMP network monitor is sending requests to an Oracle service through an SNMP-to-TNS gateway, and that service cannot understand the requests.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, and occurs when an Oracle control program sends requests to an Oracle service, contact Worldwide Customer Support.
NMP-00006: uninitialized SNMP context
Cause: An internal function attempted to use an uninitialize SNMP handle.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.
NMP-00007: I/O failure
Cause: The SNMP program interface attempted to send or receive an SNMP request and was unable to do so because of a network failure of some sort. This error is usually displayed underneath an error which describes the problem in more detail. The problem typically occurs when a control program is attempting to communicate with a service and either that service has unexpectedly terminated or the network path between the control program and the service has been interrupted.
Action: none
NMP-00008: SNMP message has incorrect version, version 0 is required
Cause: The SNMP program interface received a protocol request with an illegal version number. This error may occur if a standard SNMP network monitor is sending malformed requests to an Oracle service through an SNMP-to-TNS gateway.
Action: Ensure that the management platform in question is sending SNMP requests with the correct version number. If the error persists, and occurs when an Oracle control program sends requests to an Oracle service, contact Worldwide Customer Support.
NMP-00009: SNMP initialization failure
Cause: The SNMP program interface could not be initialized, either because its error message file could not be found, or because there is a malformed snmp.communities parameter value in the parameter table.
Action: Check that SQL*Net has been installed properly and that all message files are in their proper locations. Turn on tracing and look for parameter table load errors.
NMP-00010: memory exhausted
Cause: The program interface has run out of memory.
Action: Add more memory or run fewer processes.
NMP-00011: internal SNMP program interface error
Cause: An internal error occurred inside the SNMP program interface. This error is usually displayed underneath an error which describes the problem in more detail.
Action: Not normally visible to the user. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Worldwide Customer Support.


49 NCR-00001 to NCR-04023

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

49 NCR-00001 to NCR-04023

NCR-00001: NCR: Could not allocate memory
Cause: Insufficient swap space or system memory.
Action: Increase swap space or system memory.
NCR-00002: NCR: Invalid usage
Cause: Bad function parameter.
Action: Check function call.
NCR-00003: NCR: Initialization failure
Cause: Usually insufficient swap space or system memory.
Action: Increase swap space or system memory.
NCR-01003: NCRS: Read error.
Cause: Failed to read data from an input device.
Action: Check the input device driver return code for further information.
NCR-01004: NCRS: Write error.
Cause: Failed to write data to an output device.
Action: Check the output device driver return code for further information.
NCR-01005: NCRS: Failed to flush the output buffer.
Cause: Failed to write data in the output buffer to an output device.
Action: Check the output device driver return code for further information.
NCR-01006: NCRS: Data buffer overflow.
Cause: An attempt to read or write data outside of a given data buffer.
Action: Check data buffer size.
NCR-01007: NCRS: Operation is not supported in a given mode.
Cause: Attempt to perform an operation which is not supported for the current mode.
Action: See documentation for a list of work modes and supported operations.
NCR-01008: NCRS: Failed to obtain transport parameters.
Cause: Could not identify transport layer parameters.
Action: Check the transport layer return code for further information.
NCR-01009: NCRS: Record handling error.
Cause: Encountered an invalid record or an attempt to read beyond last record.
Action: See documentation for description of record handling methods.
NCR-01010: NCRS: Invalid network address length.
Cause: Network address size is set to 0.
Action: See documentation for valid network address sizes.
NCR-01011: NCRS: Send message failure.
Cause: Failed to send a message over network.
Action: Check the network interface return code for further information.
NCR-01012: NCRS: Receive message failure.
Cause: Failed to receive a network message.
Action: Check the network interface return code for further information.
NCR-01013: NCRS: Unvalid connection type.
Cause: Connection type is other than stream or message.
Action: See documentation for description of connection types.
NCR-01018: NCRS: Encryption failure.
Cause: Can not do the encryption for the data.
Action: See the SNS documentation for more information.
NCR-01019: NCRS: Checksumming failure.
Cause: Can not add the checksumming for the data.
Action: See the SNS documentation for more information.
NCR-01020: NCRS: Operation would block.
Cause: An I/O operation returned with no data read/written because the transport connection is "non-blocking" and, to succeed, the operation would have needed to block.
Action: This is a soft error; retry the operation.
NCR-02003: NCRF: Invalid type passed to format interpreter.
Cause: The format interpreter was given a data type it did not recognize.
Action: Check the types returned to the interpreter from either the type callback routine or from the type context structure.
NCR-02004: NCRF: Invalid format interpreter type context
Cause: The format interpreter was given an invalid type context.
Action: This error usually happens due to an improperly described aggregrate. For example, declaring NCRF_END_STRUCT_DATA_TYPE within a context, without a complementary NCRF_STRUCT_DATA_TYPE, is invalid.
NCR-02005: NCRF: Invalid session mode
Cause: The data format layer received a session mode other than GET,PUT or FREE.
Action: None.
NCR-02006: NCRF: Invalid floating point representation received
Cause: The data format layer received a floating point representation it did not recognize.
Action: Check incoming format descriptor for errors.
NCR-02007: NCRF: Invalid format descriptor received
Cause: The data format layer received an improperly formed format descriptor. Subsequent data could not be formatted.
Action: Check for data integrity on receipt from remote host.
NCR-02008: NCRF: Error within stream processing in format interpreter
Cause: An error occured while the interpreter was processing an NCRF_STREAM_DATA_TYPE.
Action: Check for data integrity, or for stream existence.
NCR-02009: NCRF: Unable to open trace file
Cause: Failure to open tracing file.
Action: Make sure that this is a legal file name and that the user has write access.
NCR-03002: NCRO: Maximum number of contexts has been reached
Cause: An attempt to create either a call context or a service context has failed because all context slots are in use.
Action: Free-up context slots by destroying those contexts no longer required, or, reconfigure NCRO with more context slots.
NCR-03003: NCRO: Unexpected message
Cause: Message read from service connection is not of the expected type.
Action: Application error - debug and fix.
NCR-03004: NCRO: Unknown message
Cause: Message read from service connection is of unknown type.
Action: Internal error - contact customer support.
NCR-03005: NCRO: Orphan message
Cause: Message read from service connection is for a call context that no longer exists.
Action: Application error - debug and fix.
NCR-03006: NCRO: Invalid operation
Cause: Attempted operation over call context is invalid. For example, attempting to send IN args for a procedure which is defined to have none.
Action: Application error - debug and fix.
NCR-03007: NCRO: Context is busy
Cause: Attempted operation failed because service/call context is busy performing a previous operaion.
Action: Application error - debug and fix.
NCR-03008: NCRO: Call rejected
Cause: An attempt to execute a remote procedure has failed because the server has rejected the procedure id.
Action: If wrong procedure id, send the correct one. If wrong server was contacted, then contact the right one.
NCR-03009: NCRO: Protocol version mismatch
Cause: Client and server NCRO layers are at incompatible versions levels.
Action: Upgrade to latest NCRO version.
NCR-03010: NCRO: Transfer callback error
Cause: Application transfer callback function has returned a "FAILED" status.
Action: Debug the transfer callback function.
NCR-03012: NCRO: Invalid session mode
Cause: Attempted operation has failed because the session context is in an invalid state.
Action: Internal error - contact customer support.
NCR-03013: NCRO: Operation not supportd
Cause: Attempted operation is not supported on this service connection because it is incompatible with the NCRO version level of the remote application.
Action: Link remote application with latest NCR library.
NCR-03014: NCRO: Bad transport address
Cause: A service context cannot be created because the transport address descriptor (contained in the binding context) is invalid.
Action: Application error - initialize the transport address descriptor correctly.
NCR-03015: NCRO: No transport address
Cause: A service context cannot be created because no transport address was provided (in the binding context) and the transport protocol uses datagrams.
Action: Application error - provide a transport address.
NCR-03016: NCRO: Message has bad address
Cause: Message read from service connection has bad address information.
Action: Internal error - contact customer support.
NCR-03017: NCRO: Transport type RSLV not supported
Cause: Support for transport type RSLV has not been built.
Action: Re-compile NCR library with NCR_USE_RSLV defined.
NCR-03018: NCRO: Failed to make RSLV connection
Cause: Failure to make RSLV connection usually means that the name resolution failed or the resolved TNS address is bad.
Action: Make sure that the name is in TNSNAMES.ORA and that it is set to the correct TNS address.
NCR-03019: NCRO: Unable to initialize thread support
Cause: Attempt to initialize the Core thread package has failed.
Action: Internal error - contact customer support.
NCR-03020: NCRO: Invalid call context
Cause: The call context is not an valid call context.
Action: Call context was destroyed, probably because the Break was received
NCR-03021: NCRO: Reset the in-band line
Cause: Our parnter is asking to reset the in-band line, after receiving a break
Action: The in-band line is required to be reset
NCR-03022: NCRO: Cannot send the break
Cause: There is an error occur when sending the break using the side-band channel
Action: Read the documention regarding to side-band break support issues
NCR-03023: NCRO: Cannot receive the break
Cause: There is an error occur when receiving the break using the side-band channel
Action: Read the documention regarding to side-band break support issues
NCR-03024: NCRO: Transport type LIST not supported
Cause: Support for transport type LIST has not been built.
Action: Re-compile NCR library with NCR_USE_LIST defined.
NCR-03025: NCRO: Failed to make LIST connection(s)
Cause: Failure to make LIST connection(s) usually means one of two things: (1) Address list syntax error, (2) Could not connect with supplied addresses
Action: Check address list syntax and make sure that there is a 'listener' process for each (or some) of the supplied addresses.
NCR-03026: NCRO: The result buffer has overflowed
Cause: The result buffer for holding the pickling result is too small.
Action: Please enlarge the result buffer and try again.
NCR-03027: NCRO: No remote service session set up yet.
Cause: Sender-makes-right needs the remote FID.
Action: Please set up the remote session before using the Send Make's Right option.
NCR-03028: NCRO: Partner refused request for sender-makes-right.
Cause: Sender-makes-right was requested by the current side, yet refused by the server.
Action: Check the server side to see why it refused SMR.
NCR-04002: NCRR: Invalid interface descriptor
Cause: An attempt to register an interface has failed because of an invalid interface descriptor.
Action: Check interface descriptor passed into the ncrrri_register_interface call.
NCR-04003: NCRR: Interface exists
Cause: An attempt to register an interface has failed because an interface already exists.
Action: Application error - register a new interface, destroy the old one, or indicate that the old one must be replaced.
NCR-04004: NCRR: Invalid interface instance handle
Cause: A service registration API call has failed because of an invalid instance handle.
Action: Application error - debug and fix.
NCR-04005: NCRR: Invalid procedure handle
Cause: A procedure/object registration has failed because of an invalid procedural handle.
Action: Application error - debug and fix.
NCR-04006: NCRR: Invalid argument descriptor
Cause: A procedure registration has failed because of an invalid argument descriptor.
Action: Application error - debug and fix.
NCR-04007: NCRR: Invalid object handle
Cause: A service registration API call failed because of an invalid object handle, for example, one that does not exist.
Action: Application error - debug and fix.
NCR-04008: NCRR: Procedure exists
Cause: An attempt to register a remote procedure has failed because the procedure already exists in this interface.
Action: Application error - register a new procedure, destroy the old one, or indicate that the old one must be replaced.
NCR-04009: NCRR: Object exists
Cause: An attempt to register an object has failed because the object already exists in this interface.
Action: Application error - register a new object, destroy the old one, or indicate that the old one must be replaced.
NCR-04010: NCRR: Unable to contact Oracle Names Server
Cause: Service export or import failed to contact Names Server.
Action: Ensure Oracle Names configuration is correct. If still no success, turn on Names tracing and/or contact customer support
NCR-04011: NCRR: Oracle Names error
Cause: Service export or import failed during interaction with Names Server.
Action: Turn on Names tracing and/or contact customer support
NCR-04012: NCRR: Invalid address descriptor
Cause: An ncrrei_export_interface call failed because of an invalid address descriptor.
Action: Application error - debug and fix.
NCR-04013: NCRR: Insufficient authorization
Cause: Attempted Names Server operation has failed because of insufficient authorization.
Action: Contact customer support.
NCR-04014: NCRR: Invalid instance name
Cause: Service export or import failed because of an invalid instance name
Action: Application error - debug and fix.
NCR-04015: NCRR: Invalid interface name
Cause: Service export or import failed because of an invalid interface name
Action: Application error - debug and fix.
NCR-04016: NCRR: Last interface instance handle
Cause: The instance handle passed in is the last instance handle in the list.
Action: Not an error - means reaching the end of the list.
NCR-04017: NCRR: Unable to find the interface instance handle
Cause: The instance handle corresponding to the instance name was not found.
Action: Application error - debug and fix.
NCR-04018: NCRR: Unable to create the TNS address list
Cause: Unable to create the TNS address list from the interface instance list.
Action: Application error - debug and fix.
NCR-04019: NCRR: Interface or instance name already exists
Cause: Service export failed because the name already exists with the name server
Action: Application error - debug and fix.
NCR-04020: NCRR: Interface or instance name does not exist
Cause: Service expunge/query failed because the name does not exist with the name server
Action: Turn on Names tracing and/or contact customer support
NCR-04021: NCRR: Pickler errors
Cause: Service export/query failed because of pickler errors
Action: Contact customer support
NCR-04022: NCRR: Invalid procedure descriptor
Cause: A procedure registration has failed because of an invalid procedural descriptor.
Action: Application error - debug and fix.
NCR-04023: NCRR: Invalid object descriptor
Cause: An object registration has failed because of an invalid object descriptor.
Action: Application error - debug and fix.


50 NZE-28750 to NZE-29249

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

50 NZE-28750 to NZE-29249

NZE-28750: unknown error
Cause: An Oracle Security Server error occurred of an unspecified type.
Action: Contact your customer support representative. This error should not be visible to applications.
NZE-28751: memory allocation failure
Cause: The allocation of memory failed due to exhaustion of system memory.
Action: Terminate other processes to free up memory or add memory to the system.
NZE-28752: data source initialization failure
Cause: A data source failed to initialize. Frequently, this error is caused by the exhaustion of system resources.
Action: Enable Oracle Net tracing to determine the exact cause of the error.
NZE-28753: failure to terminate use of data source
Cause: The system failed to terminate its use of a data source. This error may have been caused by memory or disk corruption, among other things.
Action: Enable Oracle Net tracing to determine the exact cause of the error.
NZE-28754: object storage failure
Cause: Error not user-visible.
Action: none
NZE-28755: object retrieval failure
Cause: The system failed to retrieve information from a file or a database.
Action: Check if the data source exists, or check to ensure that the correct information exists.
NZE-28756: callback failure to allocate memory
Cause: A function supplied by the caller failed to allocate memory. This error could have been caused by system memory exhaustion.
Action: Terminate other processes to free up memory or add memory to the system.
NZE-28757: system attempt to allocate 0 bytes of memory
Cause: The system attempted to allocate 0 bypes of memory because there was no available memory left to allocate. This error could have been caused by system memory exhaustion.
Action: Terminate other processes to free up memory or add memory to the system.
NZE-28758: memory release failure
Cause: The release of a memory fragment failed. This may have been caused by memory corruption either within the application or in the Oracle Security Server library.
Action: Enable Oracle Net tracing to determine the reason why the operation failed.
NZE-28759: failure to open file
Cause: The system could not open the specified file.
Action: Enable Oracle Net tracing to determine the name of the file that could not be opened and the reason.
NZE-28760: list creation failure
Cause: Error not user-visible.
Action: none
NZE-28761: element creation failure
Cause: Error not user-visible.
Action: none
NZE-28762: failure to add element
Cause: Error not user-visible.
Action: none
NZE-28763: Invalid parameter type found in configuration file.
Cause: A parameter in the sqlnet.ora file may have been specified incorrectly.
Action: Check the sqlnet.ora file for this parameter value.
NZE-28764: failure to retrieve a configuration parameter
Cause: The system failed to retrieve a configuration parameter from the sqlnet.ora file. This error may have occurred because a necessary configuration parameter was not specified in the sqlnet.ora file.
Action: Supply the needed configuration parameter in the sqlnet.ora file.
NZE-28765: Data method list does not exist.
Cause: Error not user-visible.
Action: none
NZE-28766: failure to terminate use of data source
Cause: The system failed to terminate its use of a data source. This error may have been caused by memory or disk corruption, or a system error.
Action: Enable Oracle Net tracing to determine the exact cause of the error.
NZE-28767: invalid version number
Cause: Version number of a file was incorrect.
Action: Replace the file with the correct version.
NZE-28768: bad magic number
Cause: d by a corrupted disk or by some other process overwriting the file.
Action: Enable Oracle Net tracing to determine the exact cause of the error.
NZE-28769: Specified method does not exist.
Cause: The data access method that was specified in the configuration file is not supported.
Action: Specify a supported method. Consult the Oracle Security Server
NZE-28770: Data source is already initialized.
Cause: The caller attempted to initialize a data source which was already initialized.
Action: This is a programming error. An application should not attempt to initialize a data source more than once.
NZE-28771: Data source is not yet initialized.
Cause: The caller attempted to use a data source which had not been initialized yet.
Action: This is a programming error. The application must always initialize the data source before it can be used.
NZE-28772: invalid file ID
Cause: Error not user-visible.
Action: none
NZE-28773: failure to write magic and version numbers
Cause: Both the magic and version numbers failed to write. This usually occurs because disk space has been exhausted.
Action: Delete unnecessary files to free up disk space or add disk space to the system.
NZE-28774: file cannot write to disk
Cause: The output of a file failed. This error usually occurs because disk space has been exhausted.
Action: Delete unnecessary files to free up disk space or add disk space to the system.
NZE-28775: file cannot close
Cause: The closing of a file, which is used by a data access method, has failed. This error usually indicates memory corruption or a system error.
Action: Enable Oracle Net tracing and examine the trace file to see exactly what error occurred.
NZE-28776: Output buffer supplied is too small.
Cause: The data returned by a function was too large for the supplied buffer.
Action: Call the routine again with a larger buffer.
NZE-28777: binding creation failure
Cause: The creation of a binding for use in the parsing of a parameter value failed. This error can be caused by the parameter value being in an incorrect format, e.g. a right parenthesis was not supplied where expected, or the exhaustion of system memory.
Action: Make sure that the parameter is specified in the correct format. If the format is correct, free up system memory by terminating processes or adding more memory.
NZE-28778: Configuration parameter is not specified in the proper format.
Cause: The configuration parameter was not specified in the proper format.
Action: Consult the Oracle Security Server documentation for a description of the proper format for this parameter.
NZE-28779: no data access method specified in parameter
Cause: No method for data access was specified in the parameter value.
Action: Specify a method for data access in the parameter. Consult the Oracle Security Server documentation for the supported data access methods for this data type.
NZE-28780: invalid data access method specified by the parameter
Cause: The data access method specified by the parameter value is not supported.
Action: Specify a supported data access method. Consult the Oracle Security Server
NZE-28781: No data for the access method is specified in the parameter.
Cause: No data was specified in the parameter for use with the specified access method.
Action: Consult the Oracle Security Server documentation for the data that must be specified for the access method.
NZE-28782: data source is not allocated
Cause: No memory was allocated for a data source.
Action: Ensure that the application calls in the data source initialization function.
NZE-28783: invalid parameter
Cause: There was no match for the parameter name that was used in the configuration file.
Action: Check your sqlnet.ora file for the correct parameter name.
NZE-28784: file name translation failure
Cause: The translation of a file name from Oracle format to native format has failed.
Action: Specify a correct file name. Consult your ORACLE documentation for the correct file name format.
NZE-28785: parameter does not exist
Cause: A necessary configuration parameter was not found in the parameter file.
Action: Supply the required parameter.
NZE-28786: decryption of encrypted private key failure
Cause: An incorrect password was used to decrypt an encrypted private key.
Action: Enter the correct password.
NZE-28787: private key encryption failure
Cause: This may have been caused by an error in the mkwallet parameter of the sqlnet.ora file.
Action: Check your sqlnet.ora file. Also turn on Oracle Net tracing and check the mktoken.trc file for other errors.
NZE-28788: user provided invalid information, or an unknown error
Cause: User may have responded to a prompt with unexpected input, or an unknown error occurred.
Action: Re-enter the correct input, or enable Oracle Net tracing to check the trace file for errors.
NZE-28789: name type not found
Cause: Error not user-visible.
Action: none
NZE-28790: NLS string open failure
Cause: The opening of a string for use by the NLS subsystem failed.
Action: Enable Oracle Net tracing to determine the exact error.
NZE-28791: certificate verification failure
Cause: Verification of the certificate, which the user supplied, failed.
Action: Enable Oracle Net tracing to determine the exact error.
NZE-28792: PL/SQL operation failure
Cause: A PL/SQL operation attempted by the Oracle Security Server failed.
Action: This is an internal error. Enable Oracle Net tracing and try the operation again. Contact Oracle customer support for assistance.
NZE-28793: variable bind failure
Cause: Error not user-visible.
Action: none
NZE-28794: data type attribute did not initialize
Cause: d by the exhaustion of system resources.
Action: Enable Oracle Net tracing to determine the exact cause of this error.
NZE-28795: data type attribute did not terminate
Cause: The termination of the use of the attribute data type subsystem failed.
Action: Enable Oracle Net tracing to determine the exact cause of this error.
NZE-28796: access method is not supported
Cause: The method specified to access data is not supported.
Action: Use a supported access method. Consult your Oracle documentation to determine which access methods are supported.
NZE-28797: invalid key data type
Cause: The type specified for a key is not supported.
Action: Correct the key type. Consult your Oracle documentation to determine which key types are supported.
NZE-28798: Number of sub-keys application passes to bind does not match that in the key.
Cause: The number of keys passed by the application to bind does not match the number used to create the key.
Action: This is an internal programming exception. Contact your customer support representative.
NZE-28799: failure to allocate shared memory
Cause: The allocation of shared memory for use in operations involving the shared server failed. This error was probably caused by the exhaustion of the memory heap supplied by the Oracle server.
Action: Enable Oracle Net tracing to determine the exact error.
NZE-28800: data source failed to open
Cause: A data source (a file or a database) failed to open.
Action: Enable Oracle Net tracing to determine the exact error.
NZE-28801: invalid object type
Cause: Error not user-visible.
Action: none
NZE-28802: invalid mode or data source in configuration file
Cause: An invalide mode or data source has been specified in the configuration file (sqlnet.ora).
Action: Check the method parameter in the sqlnet.ora file. If the parameter value is correct, then enable Oracle Net tracing to determine the exact error.
NZE-28803: I/O operation failure
Cause: The system or application failed to access a data source (file or database).
Action: Enable Oracle Net tracing to determine the exact error.
NZE-28804: Data source cannot close.
Cause: The data source, which could be either a file or a database), failed to close.
Action: Enable Oracle Net tracing to determine the exact error.
NZE-28805: Cannot retrieve information from the data source.
Cause: The system or application failed to retrieve information from the data source (file or database).
Action: Enable Oracle Net tracing to determine the exact error.
NZE-28806: Cannot write to the data source.
Cause: The system or application failed to write to the data source (file or database).
Action: Enable Oracle Net tracing to determine the exact error.
NZE-28807: Cannot update the data source.
Cause: The system or application failed to update the data source (file or database).
Action: Enable Oracle Net tracing to determine the exact error.
NZE-28808: Cannot retrieve method information from the configuration file.
Cause: The system or application failed to retrieve method information from the sqlnet.ora configuration file.
Action: Check the method configuration parameters in the sqlnet.ora file. If the method configuration parameters are correct, then enable Oracle Net tracing to determine the exact error.
NZE-28809: Cannot delete information from the data source.
Cause: The system or application failed to delete information from the data source (file or database).
Action: Enable Oracle Net tracing to determine the exact error.
NZE-28810: Cannot create key descriptor.
Cause: The system failed to create a key descriptor.
Action: Enable Oracle Net tracing to determine the exact error.
NZE-28811: invalid access descriptor
Cause: Error not user-visible.
Action: none
NZE-28812: record operation failure
Cause: Error not user-visible.
Action: none
NZE-28813: invalid record type
Cause: Error not user-visible.
Action: none
NZE-28814: Cannot convert a number in Oracle format to native format.
Cause: The conversion of a number from Oracle format to native format failed.
Action: This is an internal programming exception. Enable Oracle Net tracing and attempt to reproduce the problem. Contact your customer support representative and supply the trace file.
NZE-28815: Cannot convert a number in native format to Oracle format.
Cause: The conversion of a number from native format to Oracle portable format failed.
Action: This is an internal programming exception. Enable Oracle Net tracing and attempt to reproduce the problem. Contact your customer support representative and supply the trace file.
NZE-28816: No password provided for a PL/SQL function.
Cause: A required password was not passed to a PL/SQL function.
Action: This is an internal error. Contact Oracle customer support.
NZE-28817: PL/SQL function returned an error.
Cause: A PL/SQL function returned an error unexpectedly.
Action: This is an internal error. Contact Oracle customer support.
NZE-28818: No package context provided.
Cause: The context that holds the state of the security package was not passed to a function or procedure that was expecting it.
Action: This is an internal error. Contact Oracle customer support.
NZE-28819: No distinguished name provided.
Cause: The user's distinguished name was not provided to a PL/SQL function or procedure.
Action: This is an internal error. Contact Oracle customer support.
NZE-28820: Signature or decryption/encryption state is not provided.
Cause: The state of either a signature or decryption/encryption was not passed to a PL/SQL function or procedure.
Action: This is an internal error. Contact Oracle customer support.
NZE-28821: No input buffer provided.
Cause: A PL/SQL function or procedure was not passed an expected buffer.
Action: This is an internal error. Contact Oracle customer support.
NZE-28822: Required seed is not specified.
Cause: No seed was specified to the PL/SQL seed initialization function.
Action: This is an internal error. Contact Oracle customer support.
NZE-28823: Number of random bytes to generate is not specified.
Cause: The number of random bytes to generate was not specified to the PL/SQL random number generator.
Action: This is an internal error. Contact Oracle customer support.
NZE-28824: invalid encryption/decryption/signature state passed
Cause: An invalid state was passed to a PL/SQL encryption, decryption, or signature procedure or function.
Action: Specify a correct state value.
NZE-28825: No cryptographic engine function specified.
Cause: No function was specified for the cryptographic engine.
Action: This is an internal error. Contact Oracle customer support.
NZE-28826: invalid cryptographic engine function passed
Cause: An incorrect cryptographic engine function was passed to a PL/SQL function or procedure.
Action: Specify a correct engine function.
NZE-28827: invalid cipher type passed
Cause: An incorrect cipher type was passed to a PL/SQL function or procedure.
Action: Specify a correct cipher type.
NZE-28828: invalid identity type passed
Cause: An incorrect identity type was passed to a PL/SQL function or procedure.
Action: Specify a correct identity type.
NZE-28829: no cipher type specified
Cause: No cipher type was passed to a PL/SQL function or procedure.
Action: This is an internal error. Contact Oracle customer support.
NZE-28830: no identity type specified
Cause: No identity type was passed to a PL/SQL function or procedure.
Action: This is an internal error. Contact Oracle customer support.
NZE-28831: no data unit format
Cause: No data unit format was passed to a PL/SQL function or procedure.
Action: This is an internal error. Contact Oracle customer support.
NZE-28832: invalid data unit format
Cause: An incorrect data unit format was passed to a PL/SQL function or procedure.
Action: Specify a data unit format.
NZE-28833: inadequate information provided
Cause: Inadequate information, which usually is in the form of parameters, has been provided to a PL/SQL function.
Action: This is an internal error. Contact Oracle customer support.
NZE-28834: Buffer is too small.
Cause: The buffer provided by PL/SQL to an Oracle Security Server toolkit function is too small for the data to be returned.
Action: This is an internal error. Contact Oracle customer support.
NZE-28835: Identity descriptor is not present or is too small.
Cause: An identity descriptor, which is passed to a PL/SQL function or descriptor, was not provided or was not the correct size.
Action: This is an internal error. Contact Oracle customer support.
NZE-28836: Wallet is not open.
Cause: The wallet to be used has not been opened yet.
Action: Call the function that opens the wallet.
NZE-28837: no wallet descriptor
Cause: No wallet descriptor was specified to a PL/SQL function or procedure.
Action: This is an internal error. Contact Oracle customer support.
NZE-28838: no identity descriptor
Cause: No identity descriptor was specified to a PL/SQL function or procedure.
Action: This is an internal error. Contact Oracle customer support.
NZE-28839: no persona descriptor
Cause: No persona descriptor was specified to a PL/SQL function or procedure.
Action: This is an internal error. Contact Oracle customer support.
NZE-28840: Wallet is already open.
Cause: An attempt was made to open a wallet that had already been opened.
Action: This is a programming error. A wallet should only be opened once.
NZE-28841: Operation is not supported.
Cause: An attempt was made to perform an operation that is not supported.
Action: This is a programming error. Please refer to Oracle documentation to determine which operations are supported.
NZE-28842: Incorrect file permissions
Cause: The subject file did not have the correct permissions for the operation.
Action: Check the file permissions to ensure that they are adequate for the current operation.
NZE-28843: Operating system error while creating/opening file
Cause: An operating system dependent error occurred while trying to create/ open the file or while trying to set the appropriate permissions on the file.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-28844: No wallet present
Cause: There was no wallet in the location specified.
Action: Check to ensure that the wallet is in the correct directory location.
NZE-28845: No certificate
Cause: Either there is no certificate or the system cannot find it.
Action: Check to ensure that the certificate is in the specified wallet.
NZE-28846: No private key
Cause: Either there is no private key or the system cannot find it.
Action: Check to ensure that the private key is in the specified wallet.
NZE-28852: Bad password
Cause: The password created for obfuscated wallet exceeds the maximum password length limit.
Action: none
NZE-28853: Initialization failure
Cause: Either initialization or module loading has failed.
Action: Enable Oracle Net tracing to determine the exact cause of this error.
NZE-28854: Memory allocation failure
Cause: The allocation of memory failed due to exhaustion of system memory.
Action: Terminate other processes to free up memory or add memory to the system.
NZE-28855: Unsupported SSL operation
Cause: An unsupported operation was attempted, for example, an attempt was made to select a mode of operation that is not allowed.
Action: Refer to the SSL chapter in the product's documentation.
NZE-28856: Buffer overflow error
Cause: A buffer overflowed during the SSL handshake.
Action: This error is not normally visible to the user. Enable Oracle Net tracing and attempt the connection again. Then contact Oracle customer support with the trace output.
NZE-28857: Unknown SSL error
Cause: An unknown SSL error occurred.
Action: This error is not normally visible to the user. Enable Oracle Net tracing and attempt the connection again. Then contact Oracle customer support with the trace output.
NZE-28858: SSL protocol error
Cause: An error occurred while negotiating the SSL handshake between two processes.
Action: This error is not normally visible to the user. Enable Oracle Net tracing and attempt the connection again. Then contact Oracle customer support with the trace output.
NZE-28859: SSL negotiation failure
Cause: An error occurred during the negotiation between two processes as part of the SSL protocol. This error will occur if the two sides to the connection do not support a common cipher suite.
Action: Configure each process so they support a common cipher suite. Then attempt the connection again. If error occurs again enable Oracle Net tracing and attempt the connection again. Then contact Oracle customer support with the trace output.
NZE-28860: Fatal SSL error
Cause: An error occurred during the SSL connection to the peer. It is likely that this side sent data which the peer rejected.
Action: Enable Oracle Net tracing on the peer and examine the trace output.
NZE-28861: SSL connection would block
Cause: This error is informational only. It should never be communicated to the user.
Action: Enable Oracle Net tracing and attempt the connection again. Then contact Oracle customer support with the trace output.
NZE-28862: SSL connection failed
Cause: This error occurred because the peer closed the connection.
Action: Enable Oracle Net tracing on both sides and examine the trace output. Contact Oracle Customer support with the trace output.
NZE-28863: SSL session not found
Cause: This error is informational only. It indicates that a specified session does not exist.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-28864: SSL connection closed gracefully
Cause: This error is informational only. It indicates that the connection closed without error.
Action: This error is not normally visible to the user. Enable Oracle Net tracing and attempt the connection again. If the error persists, contact Oracle customer support.
NZE-28865: SSL connection closed
Cause: The SSL connection closed because of an error in the underlying transport or because the peer process quit unexpectedly.
Action: Enable Oracle Net tracing and attempt the connection again. The trace output should indicate how the failure occurred.
NZE-28866: Invalid peer certificate encoding
Cause: A certificate in the peer's certificate chain had a field that could not be recognized.
Action: Refer to Oracle Wallet Manager documentation to find out how to obtain the peer's certificate. Then contact Oracle customer support with the peer's certificate chain.
NZE-28867: Integer value is too big.
Cause: The certificate presented had an integer field whose value was too large.
Action: Refer to Oracle Wallet Manager documentation to find out how to obtain the peer's certificate. Then contact Oracle customer support with the peer's certificate chain.
NZE-28868: Peer certificate chain check failed.
Cause: The check of the certificate list presented by the peer failed. This could be caused by a number of problems including:

1. the expiration of one of the certificates;

2. a certificate authority in a certificate was not recognized as a trust point;

3. the signature in a certificate could not be verified.

Action: Refer to Oracle Wallet Manager documentation to find out how to open your wallet and ensure that:

1. all of the certificates installed in your wallet are current

2. a certificate authority's certificate from your peer's certificate chain is added as a trusted certificate in your wallet

NZE-28869: Peer's certificate is expired.
Cause: The certificate being used to authenticate a client or server has expired.
Action: Obtain a new certificate, which has not expired, and attempt the connection again.
NZE-28870: Name comparison failure
Cause: A comparison between the names contained within two certificates failed.
Action: This error is not normally visible to the user. Enable Oracle Net tracing and attempt the connection again. If the error persists, contact Oracle customer support.
NZE-28871: Peer certificate chain is incomplete.
Cause: The peer certificate chain presented was not complete because it did not end with a self-signed root certificate.
Action: Refer to Oracle Wallet Manager documentation to find out how to open your wallet and ensure that:

1. the certificate authority's certificate specified as the root is self-signed.

2. a certificate authority's certificate from your peer's certificate chain is added as a trusted certificate in your wallet

NZE-28872: Invalid peer certificate format
Cause: The peer certficate does not conform to the X.509v3 standard.
Action: Refer to Oracle Wallet Manager documentation to find out how to get the peer certificate. Then contact Oracle customer support with the peer's certificate.
NZE-28873: Invalid parameter
Cause: A function was presented with a null parameter.
Action: This error is not normally visible to the user. Enable Oracle Net tracing and attempt the connection again. If the error persists, contact Oracle customer support.
NZE-28874: SSL: I/O closed - override goodbye kiss
Cause: This error is informational only. It indicates that the connection closed without error.
Action: This error is not normally visible to the user. Enable Oracle Net tracing and attempt the connection again. If the error persists, contact Oracle customer support.
NZE-28875: SSL: use server-gated cryptographic suites
Cause: This error is used as a internal status indicator and not really an error.
Action: This error is not normally visible to the user. Enable Oracle Net tracing and attempt the connection again. If the error persists, contact Oracle customer support.
NZE-28884: invalid cipher suite
Cause: An invalid cipher suite to a string has been specified in the product's configuration file.
Action: Refer to the product documentation for information about the supported cipher suites.
NZE-28885: No certificate with the required key usage found.
Cause: Certificate not created with the appropriate X509v3 key usage extension.
Action: Refer to Oracle Wallet Manager documentation to find out the supported key usages.
NZE-28890: Entrust Login Failed
Cause: An application's attempt to log in to an Entrust Profile failed. This could be caused by a number of problems including:

1. Entrust Admin/Authority was not online.

2. Invalid password for Entrust profile was specified.

3. Invalid path to Entrust profile was specified

4. Invalid Entrust initialization file was specified.

5. Entrust Server Login program was not executed (server-side only).

Action: Make sure that:

1. Entrust Authority is online;

2. Password for Entrust profile is specified correctly;

3. Path to Entrust profile is specified correctly;

4. A valid Entrust initialization file is provided;

5. Entrust Server Login program is run before the database startup. For more information, enable Oracle Net tracing and the trace output should indicate the exact Entrust failure codes.

NZE-29000: Certificate not installed
Cause: Trying to delete a certificate which has not been installed.
Action: Refer to the Oracle Wallet Manager documentation for information about delete option.
NZE-29002: SSL transport detected invalid or obsolete server certificate.
Cause: The client detected a mismatch between the server's distinguished name specified on the server's certificate and the server's SID or service name.
Action: Refer to the SSL chapter in Oracle Advanced Security Administrator's Guide for information about enabling server distinguished name matching. Contact your administrator to perform the appropriate action.
NZE-29003: SSL transport detected mismatched server certificate.
Cause: The client detected a mismatch between the server's distinguished name specified on the server's certificate and the server's SID or service name.
Action: Refer to the SSL chapter in Oracle Advanced Security Administrator's Guide for information about enabling server distinguished name matching. Contact your administrator to perform the appropriate action.
NZE-29004: Callback Failure
Cause: The alert callback returns this error is the alert is not fatal.
Action: none
NZE-29005: The certificate is invalid.
Cause: The peer certificate encoding is invalid when using SSL 2.0.
Action: Refer to Oracle Wallet Manager documentation to find out how to obtain the peer's certificate. Then contact Oracle customer support with the peer's certificate chain.
NZE-29006: The certificate request message is invalid when using SSL 2.0.
Cause: There is an error processing the SSL 2.0 REQUEST-CERTIFICATE message.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29007: Bad Clear Key Length when using SSL 2.0
Cause: The clear key length of an SSL 2.0 Client Master key handshake message is invalid.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29008: Bad DH Param key length
Cause: The length of the Diffie-Hellman params exceeds export restrictions.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29009: Bad encrypted key length when using SSL 2.0
Cause: The encrypted key length of an SSL 2.0 Client Master key handshake message is invalid.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29010: Export key length does not meet export restrictions.
Cause: The server sent a ServerKeyExchange message with an export key which does not meet export restrictions. For RSA, the export key must be exactly 512 bits.
Action: Obtain a certificate with the appropriate key length.
NZE-29011: Finished message is incorrect.
Cause: The FINISHED message data verifcation failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29012: Bad key argument length when using SSL 2.0
Cause: The key argument length of an SSL 2.0 Client Master Key handshake message is invalid.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29013: SSL MAC verification failure
Cause: Verification of SSL Record MAC failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29014: Maximum fragment length extension is incorrect.
Cause: The maximum fragment length extension specified is incorrect.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29015: incorrect message length
Cause: The message length is not correct.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29016: inadequate PKCS1 message padding
Cause: The message was not properly padded before encryption.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29017: The premaster secret length is incorrect.
Cause: The premaster secret sent by the peer has an incorrect length.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29018: The premaster secret contains an incorrect version number.
Cause: The premaster secret must contain the same version number as the ClientHello. The version sent by the client was incorrect.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29019: The protocol version is incorrect.
Cause: There is a protocol version mismatch between the two peers.
Action: Specify the correct protocol version in the product's configuration file.
NZE-29020: The handshake record length is too long.
Cause: The handshake record length exceeds the maximum that is specified by the SSL specification.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29021: Secret key length is incorrect when using SSL 2.0.
Cause: The length of the decrypted ENCRYPTED-KEY is incorrect.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29022: Operation is being attempted on the wrong side of the client/server connection.
Cause: The SSL network layer has detected that the operation has been attempted on the wrong side of the client/server connection.
Action: Select the protocol side (of this protocol) to be the same as the one selected with a previous protocol.
NZE-29023: The buffers are not empty.
Cause: Trying to free buffers that are not empty.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29024: Certificate validation failure
Cause: The certificate sent by the other side could not be validated. This may occur if the certificate has expired, has been revoked, or is invalid for another reason.
Action: Check the certificate to determine whether it is valid. Obtain a new certificate, alert the sender that there certificate has failed, or resend.
NZE-29025: Error found in certificate check callback.
Cause: The application callback failed while trying to do additional certificate validation. Additional checks include CRL validation, extension checking.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29026: Decryption failure
Cause: SSL record decryption failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29027: Error in entropy collection
Cause: The internal entropy collection failed to generate enough seed data.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29028: Server verification failure when using SSL 2.0
Cause: Processing of an SSL 2.0 SERVER-VERIFY message failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29029: SSL handshake already completed
Cause: The system is trying to initiate a handshake when it has already been completed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29030: SSL handshake is requested.
Cause: The peer sends this message if it wishes to renegotiate. The application can either proceed with the rengotiation or reject the request.
Action: This is not an error. To find out more details enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29031: SSL handshake is required.
Cause: Renegotiation cannot proceed before the SSL handshake is completed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29032: The given identity is not complete.
Cause: The certificate list does not contain both private key and certificate.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29033: Invalid PFX
Cause: The PFX is invalid for this operation containing either no certificates and private key or multiple private keys. However, the API which returns this error is not used in our code.
Action: none
NZE-29034: Correct cipher suite or client authentication is needed.
Cause: Before installing a private key, a cipher suite or client authentication suite using the same key exchange algorithm must be installed first. This has not been done.
Action: Install a cipher suite or client authentication suite that uses the same key exchange algorithm as the private key before re-installing the private key.
NZE-29035: Pseudo Random Number Generator is needed
Cause: PRNG not set yet. A PRNG must be installed first.
Action: none
NZE-29036: This feature is not supported
Cause: Operation is not supported by the current connection parameters.
Action: Check the Oracle documentation to determine the appropriate connection parameters required for this operation.
NZE-29037: No certificate is present
Cause: The other client or server sent a certificate message that contained no certificates.
Action: No action recommended other than checking the other client or server to ensure they have appropriate credentials.
NZE-29038: There are no matching certificates.
Cause: The other client or server sent a certificate message that contained a certificate which was not signed by a trusted certificate authority (CA).
Action: Check to ensure that the other client or server sends a certificate which is signed by a CA that is in your trusted list. Or you can include the CA certificate for the other client or server's certificate as a trustpoint in your wallet.
NZE-29039: There are no matching cipher suites.
Cause: Neither end of the handshake can agree on a cipher suite.
Action: Check to ensure that both sides of the handshake select cipher suites that are supported.
NZE-29040: There are no supported cipher suites.
Cause: This end of the handshake cannot support any cipher suites. This connection and the peer have some matching cipher suites, howvever, these cipher suites cannot be negotiated because they cannot be supported by the connection.
Action: Check to ensure that both sides of the handshake select cipher suites that are supported by the connection. Refer to Oracle documentation for supported cipher suites.
NZE-29041: The callback is NULL.
Cause: A NULL callback was passed.
Action: none
NZE-29042: Read buffer is not empty.
Cause: There is an attempt to free a read buffer that is not empty.
Action: none
NZE-29043: Read is required.
Cause: Renegotiation with the peer has not started yet. There is application data which must be processed before the handshake can proceed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29044: Renegotiation has already been requested.
Cause: Renegotiation has already been requested.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29045: Renegotiation request has been refused.
Cause: A renegotiated handshake has been refused by the peer.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29046: Session is resumable.
Cause: Server is trying to resume a session with different session parameters.
Action: Server should resume the session with the correct session parameters.
NZE-29047: Mismatch in Transport Layer Security extension
Cause: Neither side can agree on a TLS extension.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29048: Unexpected message received.
Cause: An unexpected message has been received.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29049: Unknown record
Cause: The record type is unknown.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29050: Installed client authentication mode is not supported.
Cause: The enabled client authentication mode(s) cannot be used within the selected cipher suite.
Action: Enable a client authentication mode that can be used within the selected cipher suite.
NZE-29051: The given public key type is not supported.
Cause: The public key in the first certificate is not supported.
Action: Check to ensure that the certificate complies with the X.509v3 standard.
NZE-29052: Write buffer is not empty.
Cause: There is an attempt to free a write buffer that is not empty.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29084: The parameter specified is illegal.
Cause: The parameter is not correct. For example, it could be bad input, or an invalid message.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29095: Index is not correct.
Cause: The instance identified by the index parameter doesn't exist.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29096: The given length is incorrect.
Cause: The length specified is too small or invalid.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29100: Cannot create local key ID.
Cause: Creation of local key identifier for the certificate or the private key failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29101: Cannot add private key bag.
Cause: The private key could not be added to the PKCS#12 object. Possible reasons are: (i) A required parameter is NULL (ii) The PKCS#12 construct is not supported (iii) An ASN.1 encoding error occured in the certificate.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29102: Cannot add certificate bag.
Cause: Creation of certificate bag failed. The application could have run out of memory.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29103: Cannot create PKCS #12 wallet.
Cause: Creation of PKCS#12 wallet failed possibly due to memory allocation failure.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29104: Cannot add certificate request.
Cause: Adding certificate request to the PKCS#12 wallet failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29105: Cannot export PKCS #12 wallet.
Cause: A required parameter is NULL or the PKCS#12 construct is not supported.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29106: Cannot import PKCS #12 wallet.
Cause: A required parameter is NULL or the BER-encoding is malformed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29107: Cannot create PKCS #12 wallet.
Cause: PKCS#12 wallet creation failed. One of the possible reasons is that the application could have run of of memory.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29108: Cannot initialize random object.
Cause: The random object could not be initialized or seeded. Either memory allocation has failed or the pseudo random numner generator module has not be en installed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29109: Cannot create private key object.
Cause: The private key object could not be created. Memory allocation must have failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29110: Invalid PKCS #12 bag type
Cause: The PKCS #12 bag type is invalid. Either one of the required parameters is NULL or the requested OID is not in the list.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29111: Invalid index
Cause: The index passed for getting the bag type is less than 1.
Action: Check to ensure that the index is greater than 1.
NZE-29112: Cannot access attributes from a PKCS #12 certificate bag.
Cause: The cerificate cannot be accessed. One of the required parameters is probably NULL, or the index specified by the application does not contain a certbag. Another possible reason is that the certificate could be malformed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29113: Cannot access attributes from a PKCS #12 key bag.
Cause: Retrieval of the private key failed. One of the required parameters is probably NULL or the index specified by the application does not contain a key bag.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29114: Cannot import private key.
Cause: The private key could not be imported. One of the required parameters could be NULL or the encoded private key could be malformed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29115: Cannot export private key.
Cause: The private key could not be exported. Either the application ran out of memory or the key type is not valid.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29116: Cannot get PKCS #12 attributes.
Cause: Retrieval of an attribute failed. One of the required parameters could be NULL.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29117: Cannot add PKCS #12 attributes.
Cause: Could not add an attribute. The attribute parameter could be NULL.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29118: Cannot create PKCS #12 attributes.
Cause: Creation of the attributes failed. The possible reason is a memory allocation error.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29119: Cannot import certificate.
Cause: The certificate cannot be imported. One of the required parameters could be NULL or the certificate has an invalid X.509 BER or DER encoding.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29120: Cannot export certificate.
Cause: The certificate cannot be exported. One of the required parameters could be NULL.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29135: Seed generation for Random Number Generator failed.
Cause: Generation of seed for random number generator failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29136: The allocated buffer is too small.
Cause: The output buffer is too small.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29137: The global context is incorrect.
Cause: The global context is incorrectly configured or invalid.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29140: Cannot create certificate object.
Cause: Creation of the certificate object failed. The application could have run out of memory.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29141: Cannot import in the der format.
Cause: Cannot import the certificate into the certificate object. The reason could be a malformed certificate.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29150: DES self-test failure
Cause: DES power up self test has failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29151: 3DES self-test failure
Cause: 3DES power up self test has failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29152: SHA-1 self-test failure
Cause: The SHA-1 power up self test has failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29153: RSA self-test failure
Cause: The RSA power up self-test has failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29154: deterministic RNG self-test failure
Cause: The deterministic Random Number Generator power up self-test has failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29155: continuous key pair consistency check self-test failure
Cause: The public-private key pair check test failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29156: conditional RNG self-test failure
Cause: Continuous Random Number Generator test, which is needed in FIPS mode, has failed.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29157: Unable to build an absolute path to the library.
Cause: Not able to construct an absolute path to the location of the library.
Action: Enable Oracle Net tracing and attempt the connection again. Contact Oracle customer support with the trace output.
NZE-29158: Unable to open library.
Cause: Opening of the library failed.
Action: Check to ensure that the library is present in the location specified, and that it has the appropriate file permissions.
NZE-29159: Unable to read library.
Cause: Not able to read the library on which the DAC check has to be performed. Read call failed.
Action: Check if the library has the appropriate file permissions.
NZE-29160: NZ library being used is different.
Cause: The NZ library being used at runtime is not the same one on which the digest was computed for doing the software integrity check.
Action: Check to ensure that the library being used is the same as the one on which the digest was pre-computed.
NZE-29161: software integrity self-test failure
Cause: The software integrity check test on the NZ shared library has failed.
Action: Check to ensure that the library being used is the same as the one on which the digest was pre-computed.
NZE-29162: Non-FIPS cipher suites being used in FIPS mode.
Cause: The cipher suite being used does not contain FIPS approved algorithms.
Action: Use cipher suites that contain FIPS approved algorithms.
NZE-29163: Third party PKI vendor is not supported in FIPS mode.
Cause: Third party PKI vendors like Entrust and MCS are not supported in FIPS mode.
Action: Use only Oracle PKI when running in FIPS mode.
NZE-29164: External PKCS #12 wallet is not supported in FIPS mode.
Cause: PKCS #12 wallets created using third party software cannot be used in FIPS mode.
Action: Use only PKCS #12 wallets created by Oracle Wallet Manager when running in FIPS mode.
NZE-29176: CRL signature verification failed
Cause: A CRL is verified before being used. CRL signature cannot be verified.
Action: Get a new CRL from CA
NZE-29177: certificate serial number is not in CRL
Cause: Cert is not revoked
Action: none
NZE-29178: certificate serial number is in CRL
Cause: Cert has been revoked
Action: Reject the certificate
NZE-29180: Unsupported validation protocol
Cause: The certificate validation protocol is not supported
Action: Make sure a supported certificate validation protocol is specified
NZE-29187: unsupported validation mechanism
Cause: The validation mechanism specified in OID is not supported
Action: Make sure a supported validation mechanism is set in OID
NZE-29189: No entry found in OID
Cause: CRL not found in OID
Action: Upload the CRL to OID
NZE-29190: Multiple entries in OID
Cause: For a given issuer name there should be only one CRL in OID
Action: Make sure there is only one CRL for a given issuer name in OID
NZE-29191: OID connection information not set
Cause: To connect to OID the connection information must be available
Action: Set the OID connection info
NZE-29192: Validation mechanism not set in OID
Cause: The validation mechanism to be used is not set in OID
Action: Set validation mechanism to be used in OID at cn=ValidationMechanism, cn=Validation, cn=PKI, cn=Products, cn=OracleContext
NZE-29193: no CRL found using CRLDP mechanism
Cause: A CRL could not fetched using CRL Distributuon point (CRLDP)
Action: Discuss with CA
NZE-29194: no CRL found in cache
Cause: CRL not in cache
Action: none
NZE-29195: CRL is expired
Cause: CRL nextUpdate time is in the past
Action: Get a new CRL from the CA
NZE-29222: Distinguished name does not match.
Cause: Distinguished name (DN) on certificate doesn't match user.
Action: Create the global user in the database with the DN that matches with the one in the user certificate on the client side.
NZE-29223: Cannot create certificate chain.
Cause: Unable to create a certificate chain with the existing trust points for the certificate that is to be installed.
Action: Install the trust point that signed the certificate.
NZE-29224: Cannot locate matching certificate request.
Cause: No matching certificate request for the certificate was found.
Action: Install the correct certificate if there is one.
NZE-29225: Certificate already installed.
Cause: Attempting to install a certificate into a persona which already has it.
Action: Do not install the certificate.
NZE-29226: No matching private key found.
Cause: Could not locate a matching private key in the persona for the given certificate (public key).
Action: none
NZE-29227: Certificate is expired.
Cause: Certificate is no longer valid..
Action: Obtain another certificate or renew this certificate.
NZE-29228: Cannot calculate the number of bytes for output.
Cause: The cryptographic engine is confused about the algorithm.
Action: Check the parameters being used with the cryptographic functions.
NZE-29229: the magic number found in the header does not match expected
Cause: The input TDU has either been corrupted or it is not being used correctly.
Action: Check that the TDU is being used from the beginning. If possible, compare the size of the TDU upon generation to the size trying to be used.
NZE-29230: the header length is not sufficient for message header
Cause: The input TDU has either been corrupted or it is not being used correctly.
Action: Check that the TDU is being used from the beginning. If possible, compare the size of the TDU upon generation to the size trying to be used.
NZE-29231: the cryptographic engine failed to initialize
Cause: During initialization of the cryptographic engine, some failure occured. This includes running out of memory and trying to seed the random number generator.
Action: Make sure the executable has been linked with compatible library versions, and that you are not running out of swap space.
NZE-29232: the cryptographic engine key initialization failed
Cause: During initialization of a key for cryptography, some failure occured. This includes running out of memory and passing illegal arguments.
Action: Make sure the executable has been linked with compatible library versions, and that the correct parameters are being used for the cryptographic functions.
NZE-29233: the key object could not be encoded
Cause: The key object may be corrupted or may be an unsupported type.
Action: Check the key object being passed to the encoding routine.
NZE-29234: a key object was not extracted from encoding
Cause: The encoding may be corrupted or may not be a key object at all.
Action: Check the encoding and parameters passed to decoding routine.
NZE-29235: the key information could not be retrieved
Cause: The key may be corrupted or may be an unsupported type.
Action: Check the parameters being used with the cryptographic functions.
NZE-29236: the random number generator will not accept seed
Cause: The cryptographic engine may have run out of memory.
Action: Make sure the executable has been linked with compatible library versions.
NZE-29237: the cryptographic engine could not finish the algorithm
Cause: The cryptographic engine does not have enough information to correctly finish applying the algorithm.
Action: Check the parameters being used with the cryptographic functions.
NZE-29238: the cryptographic engine could not apply the algorithm
Cause: The cryptographic engine does not have enough information to correctly apply the algorithm.
Action: Check the parameters being used with the cryptographic functions.
NZE-29239: the cryptographic engine could not initialize the algorithm
Cause: The cryptographic engine does not have enough information to correctly initialize the algorithm.
Action: Check the parameters being used with the cryptographic functions.
NZE-29240: the cryptographic engine does not recognize the algorithm
Cause: The application is probably passing the wrong parameters.
Action: Check the parameters being used with the cryptographic functions.
NZE-29241: a buffer block needs to more space but its length is fixed
Cause: The application has preallocated an output buffer that is too short for the operation and has specified that the buffer should not grow as needed.
Action: Either preallocate a larger buffer or allow the toolkit to grow the output buffer as needed.
NZE-29242: the asymmetric key is too short to be used with the data.
Cause: An asymmetric key must be at least 11 bytes longer than the data it is being used to encrypt.
Action: Use an asymmetric key with more bits or break the data into smaller pieces.
NZE-29243: the toolkit does not recognize the type of key being used
Cause: The application is probably passing the wrong parameters.
Action: Check the parameters being used with the toolkit functions.
NZE-29245: the toolkit does not recognize the function being used
Cause: The application is probably passing the wrong parameters.
Action: Check the parameters being used with the toolkit functions.
NZE-29246: the toolkit could not parse the tdu
Cause: The TDU could be corrupted.
Action: Check the parameters being used with the toolkit functions.
NZE-29247: an unopen toolkit object was used before it was opened
Cause: Some toolkit objects must be opened before they can be used.
Action: Check the parameters being used with the toolkit functions.
NZE-29248: an unrecgonized WRL was used to open a wallet
Cause: WRL's have a specific set of types and must be formatted correctly.
Action: Check the parameters being used with the toolkit functions.
NZE-29249: an unrecognized state was passed to a cryptographic function
Cause: The application is probably passing the wrong parameters.
Action: Check the parameters being used with the toolkit functions.


51 O2F-00301 to O2F-00341

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

51 O2F-00301 to O2F-00341

O2F-00301: Error attempting to read from the INTYPE file
Cause: An operating system error occurred while attempting to read from the INTYPE file.
Action: Try opening the INTYPE file with an editor to make sure you are able to access the file.
O2F-00302: Unable to allocate memory
Cause: OTT was unable to allocate memory.
Action: Contact ORACLE customer support.
O2F-00303: No INTYPE file was specified
Cause: The required option INTYPE was not specified.
Action: Set the INTYPE option to the name of the file containing names of types for OTT to translate. The INTYPE option may be specified on the command line or in a CONFIG file.
O2F-00304: Invalid filename for the INTYPE file
Cause: The filename specified for the INTYPE file is not syntactically correct.
Action: Make sure you spelled the filename of the INTYPE file correctly.
O2F-00305: Error opening the INTYPE file for reading
Cause: An operating system error occurred while attempting to open the INTYPE file.
Action: Make sure you spelled the filename of the INTYPE file correctly. Try opening the INTYPE file with an editor to make sure you have access to the file.
O2F-00306: Unable to close the INTYPE file
Cause: An operating system error occurred while attempting to close the INTYPE file.
Action: Try opening the INTYPE file with an editor to make sure you are able to access the file.
O2F-00307: Unable to read the INTYPE file
Cause: The first token of the INTYPE file was not read. Either an operating system error occurred while attempting to read from the INTYPE file, or all lines of the INTYPE file are blank lines or comment lines.
Action: Try opening the INTYPE file with an editor to make sure you are able to access the file. Make sure the INTYPE file contains one or more type specifications.
O2F-00308: No type specifications were seen in the INTYPE file
Cause: Either there are no type specifications in the INTYPE file, or the first type specification could not be read due to a previously reported error.
Action: Fix any previously reported errors. Make sure there are one or more type specifications in the INTYPE file.
O2F-00309: Name of user-defined type is illegal or missing
Cause: The name of a user-defined type is expected following the keyword TYPE at the beginning of a type specification. No legal type name was seen.
Action: Make sure that the type specification is syntactically correct, and that the type name is spelled correctly.
O2F-00310: Illegal or missing identifier name
Cause: A legal C or C++ identifier was expected following AS, but was not seen.
Action: Use a legal C or C++ identifier, consisting of letters, digits, and underscores not beginning with a digit.
O2F-00311: Illegal or missing file name
Cause: A legal file name was expected, but was not seen.
Action: Make sure your TYPE file syntax is correct. Use a correct file name.
O2F-00312: Illegal or missing type version string
Cause: A type version name was expected, but was not seen.
Action: Make sure your TYPE file syntax is correct. Use a correct version name.
O2F-00313: Illegal or missing attribute name
Cause: An attribute name was expected in the INTYPE file, but was not seen.
Action: Make sure your TYPE file syntax is correct. Use a correct attribute name.
O2F-00314: AS expected but not seen in the INTYPE file
Cause: Incorrect syntax in the INTYPE file.
Action: Make sure your TYPE file syntax is correct.
O2F-00315: An attribute of a type is listed twice in a type specification
Cause: An attribute of a user-defined type is listed twice in a type specification in the INTYPE file. The second occurrence is ignored.
Action: Remove one of the two occurrences of the attribute.
O2F-00316: An unexpected token was seen at the end of a type specification
Cause: There is a syntax error in the INTYPE file.
Action: Check your documentation to make sure the type specifications
O2F-00317: Error opening the ERRTYPE file for writing
Cause: An operating system error occurred while attempting to open the ERRTYPE file for writing.
Action: Make sure you spelled the ERRTYPE filename correctly. Try creating or modifying the ERRTYPE file to make sure you have write access to the file.
O2F-00318: Error writing to the OUTTYPE file
Cause: An operating system error occurred when attempting to write to the OUTTYPE file.
Action: Make sure you have operating system permission to write to the file. Also, make sure disk space is available.
O2F-00319: No OUTTYPE file specified
Cause: The required option OUTTYPE was not specified.
Action: Set the OUTTYPE option to the name of the file to which the TYPE file produced by OTT should be written. The OUTTYPE option may be specified on the command line or in a CONFIG file.
O2F-00320: Invalid filename for the OUTTYPE file
Cause: The filename specified for the OUTTYPE file is not syntactically correct.
Action: Make sure you spelled the filename of the OUTTYPE file correctly.
O2F-00321: Error opening the OUTTYPE file for writing
Cause: An operating system error occurred while attempting to open the OUTTYPE file.
Action: Make sure you spelled the filename of the OUTTYPE file correctly. Make sure you have operating system permission to open the the file.
O2F-00322: Unable to close the OUTTYPE file
Cause: An operating system error occurred while attempting to close the OUTTYPE file.
Action: Try opening the OUTTYPE file with an editor to make sure you are able to access the file.
O2F-00323: Internal error in OTT facility O2F
Cause: An internal OTT error occurred in the O2F component of OTT.
Action: Contact ORACLE customer support.
O2F-00324: Unable to convert from the database character set to the compiler character set
Cause: The name of a type, attribute, or method cannot be converted from the client character set in effect when OTT was invoked to the compiler character set (typically ASCII or EBCDIC).
Action: A name is translated first from the database character set to the client character set, and then from the client character set to the compiler character set. The client character set is specified in a platform-dependent manner (On UNIX platforms, the client character set is specified by setting the NLS_LANG environment variable). Use a client character set that can be translated to the compiler character set. The compiler character set itself is one such character set. Specify synonyms in the INTYPE file for any names of database objects that cannot be successfully translated to the client character set.
O2F-00325: None of the characters in a name were legal identifier characters
Cause: None of the characters in the name of a database entity could be translated to a character that may begin a C or C++ identifier, such as a letter or an underscore.
Action: Specify an explicit translation for the name in the INTYPE file.
O2F-00326: Some characters in this name were not legal identifier characters
Cause: One or more characters in the name of a database entity could not be translated to a character that may appear in a C or C++ identifier, such as a letter, an underscore, or a digit. The characters that could not be translated were replaced with underscores.
Action: Make sure that the name is spelled correctly, and that it is terminated by a blank, the end of a line, or an equals sign ("="). You may use the translated name with added underscores, or you may specify an explicit translation for the name in the INTYPE file.
O2F-00327: CASE option has an illegal value
Cause: The value given for the CASE option in the INTYPE file is not legal.
Action: Change the value given for the CASE option to one of the following legal values: SAME, LOWER, UPPER, or OPPOSITE.
O2F-00328: Illegal INITFUNC name
Cause: The function name given for the INITFUNC option in the INTYPE file is not a legal C or C++ identifier.
Action: Specify the name of the INITFUNC function as a legal C or C++ identifier. This name can be given in the INTYPE file, given on the command line, or derived from the INITFILE name.
O2F-00329: Type or option specification expected
Cause: A type or option specification was expected in the INTYPE file, but was not seen.
Action: Check the INTYPE file for syntax errors. Supply a type or option specification. A type specification begins with the word TYPE. An option specification begins with the word CASE, INITFILE, or INITFUNC.
O2F-00330: Name exceeds 265 bytes in length
Cause: A name seen in the INTYPE file exceeds 265 bytes in length.
Action: Choose a shorter name.
O2F-00331: A syntactically illegal name was seen in the INTYPE file
Cause: A syntax error occurred in a name used in the INTYPE file.
Action: If the name is quoted, make sure that the quotes are at the beginning and at the end of the name. If a period (which separates a schema name from a type name) appears, make sure that the schema name and the type name are both present.
O2F-00332: A database link may not appear in the name of a user-defined type
Cause: A database link was seen in the name of a user-defined type. This feature is not yet supported.
Action: Declare the user-defined type in the database to which OTT connects.
O2F-00333: An unexpected token appeared where a keyword was expected in the INTYPE file
Cause: A keyword such as TYPE was expected in the INTYPE file, but an incorrect or misspelled keyword was seen.
Action: Verify that your TYPE specification obeys the syntax described in your documentation. Verify that your keyword is spelled correctly.
O2F-00334: A user-defined type is listed more than once in the INTYPE file
Cause: The same name of a user-defined type appears in more than one type specification. The duplicate specifications of the type name will be ignored.
Action: Put all of the information about the type, including all type name and attribute name translations, in a single TYPE specification, and eliminate the duplicate TYPE specifications.
O2F-00335: Internal error in O2F component of OTT
Cause: A request was made that all types in the database schema are to database.
Action: List the types to be processed in an INTYPE file. Contact ORACLE customer support.
O2F-00336: Error reported by subsystem:
Cause: A request was made to generate declarations for all the types in a database schema. An error occurred in a subsystem when accessing the database.
Action: Examine the error message reported by the sybsystem to determine its cause. List the types to be processed in an INTYPE file.
O2F-00337: Schema not found, or no types found in schema
Cause: A request was made to generate declarations for all the types in a database schema. Either the schema was not found, no user-declared types were found in the schema, or unable to connect to Oracle.
Action: Ensure that a login/password string was specified for OTT and that the Oracle database can be accessed with it. Ensure that the USER_TYPES table contains at least one row.
O2F-00338: Illegal or missing package name
Cause: A legal Java package name was expected following IN or PACKAGE or IN PACKAGE, but was not seen.
Action: Use a legal Java package name.
O2F-00339: CODE option has an illegal value
Cause: The value given for the CODE option in the INTYPE file is not legal.
Action: Change the value given for the CODE option to one of the following legal values: C, ANSI_C, KR_C, JAVA, NATIVE_JAVA, ORACLE_JAVA.
O2F-00340: Name was null
Cause: A name had a length of 0 characters.
Action: This error should never be reported to the user. Contact ORACLE customer support.
O2F-00341: An error occurred for which no message is available
Cause: The cause of this error was not reported.
Action: Contact ORACLE customer support.


52 O2I-00101 to O2I-00133

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

52 O2I-00101 to O2I-00133

O2I-00101: Invalid value for the USERID parameter
Cause: The value supplied for the USERID parameter is not a legal <username>/<password>[@<databasename>] string.
Action: Set the USERID option to the correct <username>/<password> or <username>/<password>@<database name> combination to use when connecting to the database. If you have an OPS$ account, you may instead omit the USERID option, in which case OTT will attempt to connect to the database using the userid OPS$<username>. The USERID option may be specified on the command line or in a CONFIG file.
O2I-00102: Unable to connect to Oracle
Cause: OTT could not connect to Oracle with the username, password, and, if applicable, database link that was supplied. Either the USERID option value was incorrect, or, if the USERID was not supplied, the userid OPS$<username> was not accepted.
Action: Check that the username and password are current and correct. Run another program that connects to Oracle to verify that you can connect using that username and password.
O2I-00103: Two file names refer to the same HFILE file in the INTYPE file
Cause: Two different file names have been used in the INTYPE file to refer to the same HFILE file, or different file names have been used to refer to the same HFILE file on the command line and in the INTYPE file.
Action: Consistently refer to each HFILE file using the same file name.
O2I-00110: Internal error in OTT component O2I
Cause: An internal OTT error occurred in the O2I component of OTT.
Action: Contact ORACLE customer support.
O2I-00111: Unable to allocate memory
Cause: OTT was unable to allocate memory.
Action: Contact ORACLE customer support.
O2I-00112: Unable to write to the HFILE file
Cause: An operating system error occurred when attempting to write to the HFILE file.
Action: Make sure you have operating system permission to write to the file. Also, make sure disk space is available.
O2I-00113: No HFILE specified
Cause: The HFILE file to which C declarations generated by OTT are written was not specified.
Action: Specify the global HFILE option on the command line or in a CONFIG file. You may choose a different HFILE for a particular type by specifying a different HFILE in the INTYPE file entry describing the type. If every INTYPE file entry specifies an HFILE, and if none of the types in the HFILE require declarations of types not mentioned there, the global HFILE option may be omitted. An INTYPE file generated by a previous invocation of OTT satisfies these conditions.
O2I-00114: Invalid HFILE file name
Cause: An HFILE file name was specified that is not syntactically correct.
Action: Make sure the HFILE filename is spelled correctly.
O2I-00115: Error opening the HFILE file
Cause: An operating system error occurred while attempting to open the HFILE file for writing.
Action: Make sure the HFILE filename is spelled correctly. Try creating or modifying the HFILE to make sure you have write access to the file.
O2I-00116: Unable to close the HFILE file
Cause: An operating system error occurred while attempting to close the HFILE file.
Action: Try creating or modifying the HFILE file to make sure you are able to access the file.
O2I-00117: Internal error: No message file for component O2U
Cause: The message file for the internal OTT component O2U was not found. OTT may not be correctly installed.
Action: Contact ORACLE customer support.
O2I-00118: This user-defined type was not found in the database
Cause: A user-defined type specified in the INTYPE file was not found in the database.
Action: Make sure the name of the type is spelled correctly. Make sure the type is actually declared in the database.
O2I-00119: Warning reported by subsystem:
Cause: A subsystem invoked by OTT reported a warning. This warning immediately follows the "Warning reported by subsystem" message.
Action: Examine the warning reported by the subsystem to determine its cause.
O2I-00120: Error reported by subsystem:
Cause: A subsystem invoked by OTT reported an error. This error immediately follows the "Error reported by subsystem" message.
Action: Examine the error message reported by the sybsystem to determine its cause.
O2I-00121: No value was specified for the CODE option
Cause: The required CODE option was not specified on the command line or in a configuration file.
Action: Specify the CODE option on the command line or in a configuration file. Currently, the following values of the CODE option are supported: CODE=ANSI_C, CODE=KR_C, CODE=C
O2I-00122: Invalid filename for the INITFILE file
Cause: The filename specified for the INITFILE file is not syntactically correct.
Action: Make sure the filename of the INITFILE file is spelled correctly.
O2I-00123: Unable to close the INITFILE file
Cause: An operating system error occurred while attempting to close the INITFILE file.
Action: Try opening the INITFILE file with an editor to make sure the file can be accessed.
O2I-00124: Error opening the INITFILE file for writing
Cause: An operating system error occurred while attempting to open the INITFILE file for writing.
Action: Make sure the INITFILE filename is spelled correctly. Try creating or modifying the INITFILE file to make sure you have write access to the file.
O2I-00125: Error writing to the INITFILE file
Cause: An operating system error occurred when attempting to write to the INITFILE file.
Action: Make sure you have operating system permission to write to the file. Also, make sure disk space is available.
O2I-00126: You must specify an INTYPE file with SCHEMA_NAMES=FROM_INTYPE
Cause: The option SCHEMA_NAMES=FROM_INTYPE requests that schema names be written to the OUTTYPE file as given in the INTYPE file. However, an INTYPE file was not specified.
Action: Either supply the name of an INTYPE file, or specify the SCHEMA_NAMES option ALWAYS or IF_NEEDED.
O2I-00127: Illegal INITFUNC name
Cause: The name of the INITFUNC function is not a legal C or C++ identifier.
Action: Specify the name of the INITFUNC function as a legal C or C++ identifier. This name may be given in the INTYPE file, given on the command line, or derived from the INITFILE name.
O2I-00128: Unable to write to the Java file
Cause: An operating system error occurred when attempting to write to a Java source file.
Action: Make sure you have operating system permission to write to the file. Also, make sure disk space is available.
O2I-00129: No Java file specified
Cause: The file to which Java declarations generated by OTT are written was not specified.
Action: This message should never be seen, because Java files are named after the classes declared within them. Contact ORACLE customer support.
O2I-00130: Invalid Java file name
Cause: A Java file name was specified that is not syntactically correct.
Action: Make sure the Java filename is spelled correctly.
O2I-00131: Error opening a Java file
Cause: An operating system error occurred while attempting to open a Java file for writing.
Action: Make sure the filename is spelled correctly. Try creating or modifying the file to make sure you have write access to the file.
O2I-00132: Unable to close a Java file
Cause: An operating system error occurred while attempting to close a Java file.
Action: Try creating or modifying the Java file to make sure you are able to access the file.
O2I-00133: An error occurred for which no message is available
Cause: The cause of this error was not reported.
Action: Contact ORACLE customer support.


53 O2U-00200 to O2U-00212

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

53 O2U-00200 to O2U-00212

O2U-00200: Internal error in OTT facility O2U
Cause: An internal OTT error occurred in the O2U facility of OTT.
Action: Contact ORACLE customer support.
O2U-00201: Illegal arguments to function o2upt()
Cause: Illegal arguments were passed to the function o2upt(). This is an internal error that should not be encountered by an end user.
Action: Contact ORACLE customer support.
O2U-00202: Invalid data passed to function
Cause: Arguments with incorrect values were passed to the function o2upt(). This is an internal error that should not be encountered by the end user.
Action: Contact ORACLE customer support.
O2U-00203: Type to be declared must be an object type or a named collection type
Cause: You have asked OTT to generate code for a type it does not support. When generating Java code, OTT will only generate code for object types. When generating C declarations, OTT will only generate declarations for object types and named collection types.
Action: You are probably asking OTT to declare a built-in type, or, if you are generating Java code, a named collection type. Do not ask OTT to generate a declaration for this type.
O2U-00204: Unable to convert from the database character set to the compiler character set
Cause: The name of a type, attribute, or method cannot be converted from the client character set in effect when OTT was invoked to the compiler character set (typically ASCII or EBCDIC).
Action: A name is translated first from the database character set to the client character set, and then from the client character set to the compiler character set. The client character set is specified in a platform-dependent manner (On UNIX platforms, the client character set is specified by setting the NLS_LANG environment variable.) Use a client character set that includes the character set of the INTYPE file and can be translated to the compiler character set. The database character set is one such character set. Specify synonyms in the INTYPE file for any names of database objects that cannot be successfully translated to the client character set.
O2U-00205: None of the characters in a type name were legal identifier characters
Cause: None of the characters in the name of a user-defined type could be translated to a character that can begin a C or C++ identifier, such as a letter or an underscore.
Action: Specify an explicit translation for the type name in the INTYPE file.
O2U-00206: Some characters in a type name were not legal identifier characters
Cause: One or more characters in the name of a user-define type could not be translated to a character that can appear in a C or C++ identifier, such as a letter, an underscore, or a digit. The characters that could not be translated were replaced with underscores.
Action: Specify an explicit translation for the type name in the INTYPE file, or just use the translated type name with added underscores.
O2U-00207: None of the characters in an attribute name were legal identifier characters
Cause: None of the characters in the name of an attribute of a type could be translated to a character that can begin a C or C++ identifier, such as a letter or an underscore. To find the affected attribute, look in the declaration generated for this type for data member names that are obviously incorrect.
Action: Specify an explicit translation for the attribute name in the INTYPE file.
O2U-00208: One or more characters in an attribute name were not legal identifier characters
Cause: If an attribute name contains one or more characters that can not be translated to a legal C or C++ identifier character, the characters that can not be translated are replaced with underscores. To find the affected attribute or attributes, look in the declaration generated for this type for data member names that have extra underscores not present in the original attribute names.
Action: Specify explicit translations for the affected attribute names in the INTYPE file, or just use the translated attribute names with added underscores.
O2U-00209: Attribute or function name to be translated was not found
Cause: This name, for which a translation was requested, is not the name of an attribute or a function of the current type.
Action: Make sure that the name is spelled correctly, and is the name of an attribute or function defined in the current type.
O2U-00210: Unable to allocate memory
Cause: OTT was unable to allocate memory.
Action: Contact ORACLE customer support.
O2U-00211: A type without attributes was translated
Cause: OTT translated a type without attributes. The corresponding C-type will be a struct without any components, which is not legal C. The empty type in the database may be the result of an error during type creation. Additionally, incomplete types may be used temporarily in the creation of types that reference one another.
Action: Re-create a full version of the type in the database and then re-run OTT.
O2U-00212: An error occurred for which no message is available
Cause: The cause of this error was not reported.
Action: Contact ORACLE customer support.


54 PCB-00001 to PCB-00903

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

54 PCB-00001 to PCB-00903

PCB-00001: %s
Cause: This is a generic error message from the command-line processor.
Action: Correct the indicated error.
PCB-00002: Command line processor severe error
Cause: The command line processor encountered a severe error.
Action: After making sure that all the command-line options are specified correctly, call customer support with a full account of all the options and configuration files used.
PCB-00003: Value of DBMS option invalid with given value of MODE option
Cause: When MODE={ANSI14 | ANSI13}, DBMS=V7 or V8 was specified, or when MODE=ANSI, DBMS=v6 was specified. These option settings are incompatible. Note that the DBMS option was not available before release 1.5 of the Oracle Precompilers.
Action: With DBMS=V7 or V8, instead of MODE={ANSI14 | ANSI13}, specify MODE={ANSI | ORACLE}. With DBMS=V6, instead of MODE=ANSI, specify MODE={ANSI14 | ANSI13 | ORACLE}, but MODE=ORACLE is recommended.
PCB-00004: UNSAFE_NULL=YES must be used with DBMS=V7 or V8 and MODE=ORACLE
Cause: The option UNSAFE_NULL=YES has been used with DBMS=V6 or DBMS=NATIVE (the default) or has been used with MODE=ANSI/ANSI14/ANSI13.
Action: Use DBMS=V7 or V8 and MODE=ORACLE (the default) when using UNSAFE_NULL=YES or do not use UNSAFE_NULL=YES.
PCB-00005: Command line option MODE=ANSI required with option NLS_LOCAL=YES
Cause: The precompiler option NLS_LOCAL=YES was used without also specifying MODE=ANSI. The precompiler option MODE=ANSI must be specifiied if NLS_LOCAL=YES.
Action: Set the precompiler option MODE=ANSI in addition to NLS_LOCAL=YES or do not set NLS_LOCAL=YES.
PCB-00006: Userid only used when SQLCHECK=FULL, userid ignored.
Cause: The USERID option was specified when SQLCHECK={SYNTAX | NONE}. This is unnecessary.
Action: Specify the USERID option only when SQLCHECK=SEMANTICS.
PCB-00007: %s
Cause: This is a generic error message from the command-line processor.
Action: Correct the indicated error.
PCB-00008: Must use option SQLCHECK=SEMANTICS(FULL) when there is embedded PL/SQL
Cause: The precompiler tried to parse an embedded PL/SQL block when SQLCHECK={SYNTAX | NONE}. PL/SQL blocks can be parsed only when SQLCHECK=SEMANTICS is specified.
Action: Remove the PL/SQL block or specify SQLCHECK=SEMANTICS.
PCB-00009: Cannot change MAXLITERAL after an EXEC SQL statement
Cause: The MAXLITERAL option has been used in an inline EXEC ORACLE OPTION statement after and EXEC SQL, EXEC TOOLS, or EXEC IAF statement. This is not allowed.
Action: Use the MAXLITERAL option only on the command line or in an EXEC ORACLE OPTION statement placed at the beginning of the input source file.
PCB-00010: SQLCHECK value in EXEC ORACLE statement exceeds command line value
Cause: The SQLCHECK option was entered inline and specified a level of checking higher than the level specified (or accepted by default) on the command line. This is not allowed. For example, if SQLCHECK={SYNTAX | LIMITED} is specified on the command line, SQLCHECK={SEMANTICS | FULL} cannot be specified inline. This informational message is; the precompiler ignores the inline value and continues processing.
Action: Revise the EXEC ORACLE statement or specify a lower level of checking on the command line.
PCB-00011: DBMS=V6 no longer supported; using DBMS=NATIVE
Cause: V6 compatibility is no longer supported. The precompiler will precompile as though DBMS=NATIVE was specified.
Action: Revise the specified DBMS option value from v6 to another value as desired.
PCB-00012: Command line option DYNAMIC=ANSI required with option TYPE_CODE=ANSI
Cause: The precompiler option TYPE_CODE=ANSI was used without also specifying DYNAMIC=ANSI. The precompiler option DYNAMIC=ANSI must be specifiied if TYPE_CODE=ANSI.
Action: Set the precompiler option DYNAMIC=ANSI in addition to TYPE_CODE=ANSI or do not set TYPE_CODE=ANSI.
PCB-00100: Unable to reopen temporary file string
Cause: The precompiler was unable to reopen a temporary file. Some possible causes follow:

o File access privileges are insufficient.

o Another user has locked the file.

o There is not enough disk space.

o There are too many open files.

Action: Check that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).
PCB-00101: Could not find or open system configuration file
Cause: The precompiler was unable to open the system configuration file. The system configuration file does not exist or is not in the proper directory.
Action: Check that the system configuration file is in the proper directory. See Oracle installation documentation for where this should be. Put a new copy of pcccob.cfg with desired default options in the proper directory.
PCB-00102: Input file name length exceeds the maximum length
Cause: The file name length specified exceeded the maximum length. Some operating systems have a maximum file name length.
Action: Use a file name of length less than or equal to the maximum platform specific file name length.
PCB-00104: Unable to open input file "string"
Cause: The precompiler was unable to open the input file specified by the INAME precompiler option. Some possible causes follow:

o The filename is misspelled.

o The file does not exist.

o The search path to the file is incorrect.

o File access privileges are insufficient.

o Another user has locked the file.

o There is not enough disk space.

o There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).
PCB-00105: Included file name "string" exceeds name limit of number characters
Cause: The file name length specified exceeded the maximum length. Some operating systems have a maximum file name length.
Action: Use a file name of length less than or equal to the maximum platform specific file name length.
PCB-00106: Unable to open INCLUDE file "string"
Cause: The precompiler was unable to open the input file specified in the INCLUDE statement. Some possible causes follow:

o The filename is misspelled.

o The file does not exist.

o The search path to the file is incorrect.

o File access privileges are insufficient.

o There is not enough disk space.

o There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges to access the file have been granted, and that it is not locked by another user. Also, check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).
PCB-00108: Unable to open list file "string"
Cause: The precompiler was unable to open the list file specified by the LNAME precompiler option. Some possible causes follow:

o The filename is misspelled.

o The file does not exist.

o The search path to the file is incorrect.

o File acces privileges are insufficient.

o Another user has locked the file.

o There is not enough disk space.

o There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager). If a listing file is not needed, specify LTYPE=NONE on the command line.
PCB-00109: Unable to open generated source file "string"
Cause: The precompiler was unable to open the output file specified by the ONAME precompiler option. Some possible causes follow:

o The filename is misspelled.

o The file does not exist.

o The search path to the file is incorrect.

o File acces privileges are insufficient.

o Another user has locked the file.

o There is not enough disk space.

o There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).
PCB-00110: Unable to open temporary file "string"
Cause: The precompiler was unable to open a file for temporary use. Some possible causes follow:

o File acces privileges are insufficient.

o A file of the same name already exists and is locked.

o There is not enough disk space.

o There are too many open files.

Action: Check that the file exists, that sufficient privileges have been granted to access the file, and that it is not locked. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager). "200 - 299, Host variable errors."
PCB-00200: Cannot equivalence PIC N or PIC G variable "string"
Cause: A PIC N/G variable, an implicit VARCHAR group item with a PIC N/G elementary item, or a group item with a PIC N/G elementary item was used in an EXEC SQL VAR statement. This is not allowed.
Action: Do not use the PIC N variable in an EXEC SQL VAR statement. If you want an equivalence to an Oracle type using an EXEC SQL VAR statement, use a PIC X variable, instead of a PIC N variable.
PCB-00201: Indicator variable string not a group item
Cause: The host variable is a group item containing tables. Indicator variables used with this type of host variable must be group items of tables of indicators corresponding the the tables in the group item host variable.
Action: Change the indicator variable to be a group item of indicator tables.
PCB-00202: Indicator variable string not a group item or table
Cause: The host variable is a group item. Indicator variables used with this type of host variable must be a group item or table of indicator variables.
Action: Use a group item or table of indicator variables.
PCB-00203: Nested group item "string" not supported
Cause: The variable used as a host variable was a group item which itself contained other group items.
Action: Remove any group items from the group item to be used as a host variable.
PCB-00204: Group items cannot be used except in INTO or VALUES clause
Cause: A group item host variable was used outside of an INTO or VALUES clause. A group item host variable may be used only in an INTO or VALUES clause.
Action: Do not use a group item outside of an INTO or VALUES clause.
PCB-00205: Cannot use PIC N or PIC G variable in PL/SQL when NLS_LOCAL=YES
Cause: A PIC N or PIC G variable was used in an embedded PL/SQL block when the precompiler option NLS_LOCAL=YES was used. A PIC N or PIC G variable is not supported in this situation.
Action: Do not use the PIC N or PIC G variable within the PL/SQL block or use precompiler option NLS_LOCAL=NO.
PCB-00206: Cannot use N quoted literal in PL/SQL when NLS_LOCAL=YES
Cause: A "N" literal (a literal of the form N'...') was used within a PL/SQL block when the precompiler option NLS_LOCAL=YES was used. N literals are not supported in this situation.
Action: Use an ordinary literal (one without the "N") within the PL/SQL block or use precompiler option NLS_LOCAL=NO.
PCB-00207: Invalid use of PIC N or PIC G table variable when NLS_LOCAL=YES
Cause: A PIC N variable was declared using an OCCURS clause. Tables of PIC N variables are not supported when NLS_LOCAL=YES.
Action: Declare the PIC N variable without an OCCURS clause or, do not use the PIC N variable in any SQL statements.
PCB-00208: Incorrect type for host variable "string"
Cause: A variable of unsupported datatype was used in a SQL statement or embedded PL/SQL block.
Action: Use a host variable of a supported datatype.
PCB-00209: Scale is not supported for host variable "string"
Cause: A variable whose format does not support scaling was used in a SQL statement or embedded PL/SQL block. The following formats do not support scaling: PIC S9(n) COMP PIC S9(n) COMP-4 PIC S9(n) COMP-5 PIC S9(n) BINARY PIC 9(n) COMP
Action: Remove the scale or use a datatype that support scaling.
PCB-00210: DISPLAY-1 only allowed with PIC G and PIC N variables "string"
Cause: A variable declared with DISPLAY-1 in the usage clause without PIC G or PIC N in the picture clause was used in a SQL statement.
Action: Replace DISPLAY-1 with DISPLAY or change the picture clause to use PIC N or PIC G.
PCB-00211: VARYING not supported with PIC N or PIC G variable "string"
Cause: The keyword VARYING was used in a PIC N variable declaration.
Action: Remove the keyword VARYING from the variable declaration. If you want to declare a PIC N VARCHAR variable, specify the precompiler option VARCHAR=YES and declare the variable as an implicit VARCHAR group item as illustrated by the following example: EXEC SQL BEGIN DECLARE SECTION END-EXEC. ... 01 ENAME. 05 ENAME-LEN PIC S9(4) COMP. 05 ENAME-ARR PIC N(20). ... EXEC SQL END DECLARE SECTION END-EXEC.
PCB-00212: PICTURE clause not allowed for host variable "string"
Cause: A variable declared with a PIC clause and COMP-1 or COMP-2 was used in a SQL statement or embedded PL/SQL block.
Action: Remove the PIC clause or use a datatype other than COMP-1 or COMP-2 in the declaration of the variable.
PCB-00214: JUSTIFIED clause not allowed for host variable "string"
Cause: A variable declared with a JUSTIFIED clause was used in a SQL statement or embedded PL/SQL block.
Action: Remove the JUSTIFIED clause from the variable declaration.
PCB-00215: OCCURS TO TIMES clause not allowed for host variable "string"
Cause: A variable declared with an OCCURS clause with the TO TIMES subclause was used in a SQL statement or embedded PL/SQL block.
Action: Remove the TO TIMES subclause from the variable declaration.
PCB-00216: OCCURS ASCENDING/DESCENDING clause not allowed for "string"
Cause: A variable declared with an OCCURS clause with the ASCENDING or DESCENDING KEY IS subclause was used in a SQL statement or embedded PL/SQL block.
Action: Remove the ASCENDING or DESCENDING KEY IS subclause from the variable declaration.
PCB-00217: OCCURS INDEXED clause not allowed for host variable "string"
Cause: A variable declared with an OCCURS INDEXED clause was used in a SQL statement or embedded PL/SQL block.
Action: Remove the OCCURS INDEXED clause from the variable declaration.
PCB-00218: RENAMES clause not allowed for host variable "string"
Cause: A variable declared with a RENAMES clause was used in a SQL statement or embedded PL/SQL block.
Action: Remove the RENAMES clause from the declaration.
PCB-00219: Invalid size specified in EXEC SQL VAR statement
Cause: A size which is specified which is not valid for the specified data type.
Action: Specify a size which is valid for the specified type.
PCB-00220: Invalid scale specified in EXEC SQL VAR statement
Cause: A scale which is specified which is not valid for the specified data type.
Action: Specify a scale which is valid for the specified type.
PCB-00221: OCCURS DEPENDING ON clause not allowed for host variable "string"
Cause: A variable declared with an OCCURS clause with the DEPENDING ON subclause was used in a SQL statement or embedded PL/SQL block.
Action: Remove the DEPENDING ON subclause from the variable declaration.
PCB-00222: Size for host variable string exceeds maximum size
Cause: A variable declared with PIC S9(n), with n greater than what is allowed on the given platform, was used in an embedded sql statement. On 32 bit machines n must not exceed 9, and on 64 bit machines, n must not exceed 18.
Action: Use a smaller number in the picture clause that does not exceed the maximum allowed size on your platform or use COMP-3.
PCB-00223: Undeclared variable "string"
Cause: A variable used in a SQL statement was not declared or its name is misspelled or if option DECLARE_SECTION=YES the declaration was not in a DECLARE SECTION.
Action: Add or correct the variable declaration.
PCB-00224: Ambiguously referenced variable "string"
Cause: There is more than one variable of the same name and the qualification given was insufficient to determine which variable the reference was to.
Action: Use more complete qualification in the variable reference.
PCB-00225: Undeclared SQL identifier "string"
Cause: The name of a descriptor, statement, or cursor was not declared or is misspelled, or was declared as a different kind of SQL identifier.
Action: Add or correct the descriptor, statement, or cursor declaration.
PCB-00226: SQL identifier "string" already defined
Cause: The SQL identifier (cursor name, statement name, etc.) has already been defined in another way.
Action: Use a different name for this use of the name.
PCB-00227: Undeclared indicator variable "string"
Cause: An indicator variable used in a SQL statement was not declared in the Declare Section or its name is misspelled.
Action: Add or correct the indicator variable declaration.
PCB-00228: Invalid group item variable "string"
Cause: An unacceptable group item variable was used in a SQL statement. or its name is misspelled.
Action: Correct the group item variable declaration or its use in the SQL statement.
PCB-00229: Indicator variable "string" has wrong type or length
Cause: An indicator variable was not declared in the Declare Section as a 2-byte integer. Indicator variables must be defined as 2-byte integers.
Action: Redefine the indicator variable as a 2-byte integer.
PCB-00230: Indicator table size must not be less than its host variable
Cause: An host variable table was used with an indicator table declared with a smaller dimension. For example: EXEC SQL BEGIN DECLARE SECTION END-EXEC. 01 EMP-NUM OCCURS 4 TIMES PIC S9(4) COMP. 01 EMP-NUM-IND OCCURS 2 TIMES PIC S9(4) COMP. EXEC SQL END DECLARE SECTION END-EXEC. ... SELECT ... INTO EMP-NUM:EMP-NUM-IND ...
Action: Increase the size of the indicator table.
PCB-00231: Host and indicator variables may not have the same name.
Cause: In an EXEC SQL statement, an indicator variable had the same name as a host variable. The names of a host variable and its associated indicator variable must be different. Also, an indicator variable cannot be used as a host variable.
Action: Rename the host or indicator variable.
PCB-00232: Tables not allowed as input bind variables in SELECT statement
Cause: A host table was used in the WHERE clause of a SELECT-INTO statement or in the SELECT list of a SELECT-INTO statement.
Action: Rewrite the SELECT statement without using tables or use a cursor.
PCB-00233: Table size mismatch in INTO/USING. Minimum is: number
Cause: The size of an table variable in an INTO/USING clause is too small for the number of rows processed.
Action: Declare all table variables in the INTO/USING clause to have at least the minimum dimension given.
PCB-00234: FOR variable "string" is invalid type
Cause: The count variable in a FOR clause has the wrong datatype. The datatype must be NUMBER or LONG (or be compatible with NUMBER or LONG).
Action: Check the declaration and check that the count variable has a datatype of NUMBER or LONG (or a compatible Oracle or host-language datatype).
PCB-00235: Table size mismatch in INTO/USING. Minimum is: number
Cause: The size of a table variable in an INTO/USING clause of a dynamic EXECUTE statement has been ARRAYLEN...EXECUTE'd while the other host variable has not and is not a table of dimension 1 or a plain non-table host variable. Example: 01 X PIC X(10) OCCURS 10. 01 Y PIC S9(4) COMP OCCURS 10. 01 Z PIC S9(4) COMP. ... EXEC SQL ARRAYLEN X (DIM) EXECUTE END-EXEC. ... EXEC SQL EXECUTE S1 USING :X, :Y END-EXEC. <-- error EXEC SQL EXECUTE S1 USING :X, :Z END-EXEC. <-- ok Please note that this error differs from 233 in that it is an ERROR not a WARNING.
Action: ARRAYLEN...EXECUTE all of the table variables in the INTO/USING clause or those host variables not ARRAYLEN...EXECUTEd need to be of dimension 1.
PCB-00236: Cannot use PIC N/G variable. NLS_NCHAR not set or set incorrectly.
Cause: To use PIC N or PIC G variables as host variables, both of the environment variables NLS_LANG and NLS_NCHAR must be set with correct values. One of the following problems has occurred which prevents Pro*COBOL from accepting PIC N and PIC G variables as host variables: 1) One or both of NLS_LANG and NLS_NCHAR are not set at all. 2) NLS_LANG is not set with a valid language, territory, or character set. 3) NLS_NCHAR is not set to a valid NCHAR character set. 4) The character set specified by NLS_NCHAR is not a fixed width character set. Pro*COBOL can only use fixed width character sets for PIC N or PIC G host variables.
Action: Set the NLS_NCHAR environment variable to a valid fixed width character set name. Set NLS_LANG with a valid language, territory, and character set.
PCB-00237: Declaration of "string" cannot have a level number greater than 48
Cause: A VARYING or SQL-CURSOR declaration has been encountered which has the level number greater than 48.
Action: Change the level to 48 or less.
PCB-00238: Element of this table group item host variable cannot be a table
Cause: A group item that is a table and having an element that is a table was used in a SQL statement.
Action: Remove the OCCURS clause from the element of the group item.
PCB-00239: Element of a table group item indicator cannot be table or group item
Cause: A group item that is a table and used as an indicator has an element that is a table or group item.
Action: Change the nested table or group item in the indicator so that it is an elementary item.
PCB-00240: Group item containing this host variable cannot be table
Cause: An elementary item belonging to a group item with an OCCURS clause has been referenced. This is not allowed.
Action: Change the elementary item used to an item that is not an element of a table of group items.
PCB-00241: A host variable is required here
Cause: The COUNT item in the dynamic SQL statement must be a host variable but is not.
Action: Use a host variable in the COUNT item of the dynamic SQL statement.
PCB-00242: A host variable or exact numeric constant is required here
Cause: The particular item in the dynamic SQL statement is required to be a host variable or exact numeric (integer) constant, but is not.
Action: Change the item in the dynamic SQL statement to use a host variable or exact numeric constant. "300 - 399: FIPS flagging error messages."
PCB-00300: Datatype for host variable not supported by ANSI "string"
Cause: An Oracle extension to the ANSI/ISO standard was used. Specifically, aa pointer or nonconforming datatype such as VARCHAR was used. For example, the offending code might look like: EXEC SQL BEGIN DECLARE SECTION END-EXEC. 01 USERNAME PIC X(10) VARYING. EXEC SQL END DECLARE SECTION END-EXEC. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: none
PCB-00301: Use of non-ANSI function is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a non-ANSI function was used. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action is required. However, for ANSI/ISO compliance, do not use this function.
PCB-00302: This statement is not supported by ANSI
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a nonconforming SQL statement such as PREPARE was used. For example, the offending code might look like: EXEC SQL PREPARE SQL-STMT FROM :HV END-EXEC. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the nonconforming statement.
PCB-00303: Dynamic SQL and PL/SQL are Oracle extensions to ANSI SQL
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, dynamic SQL or embedded PL/SQL was used. For example, the offending code might look like: EXEC SQL EXECUTE BEGIN SELECT ... END; END-EXEC. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use dynamic SQL or embedded PL/SQL.
PCB-00304: Oracle extension to the WHENEVER statement
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a nonconforming keyword such as NOTFOUND, STOP, RAISE, or DO was used in the WHENEVER statement. (Note that NOT FOUND is ANSI-compliant.) For example, the offending code might look like: EXEC SQL WHENEVER SQLERROR STOP END-EXEC. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the nonconforming keyword.
PCB-00305: Oracle extension to the COMMIT and ROLLBACK statements
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the parameter RELEASE, COMMENT, or FORCE were used in a COMMIT or ROLLBACK statement. For example, the offending code might look like: EXEC SQL ROLLBACK RELEASE END-EXEC. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the nonconforming parameter.
PCB-00306: CREATE FUNCTION/PROCEDURE/PACKAGE/TRIGGER are Oracle extensions
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, one of the following statements was used:

o CREATE FUNCTION

o CREATE PROCEDURE

o CREATE PACKAGE

o CREATE TRIGGER This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use any of these statements.
PCB-00307: DROP TABLE statement is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the DROP TABLE statement was used. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action is required. However, for ANSI/ISO compliance, do not use the DROP statement.
PCB-00308: FOR clause is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the FOR clause was used in an table-processing SQL statement. For example, the offending code might look like: EXEC SQL FOR :LIMIT INSERT INTO EMP (EMPNO, JOB, DEPTNO) VALUES (:EMPNUM, :JOB, :DEPTNO) END-EXEC. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the FOR clause.
PCB-00309: The CONNECT statement is Oracle implementation dependent
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the CONNECT statement was used to log on to ORACLE. For example, the offending code might look like: EXEC SQL CONNECT :USERNAME IDENTIFIED BY :PSSWORD END-EXEC. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, specify the AUTO_CONNECT command-line option instead of using a CONNECT statement.
PCB-00310: AT clause is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the AT <db_name> clause was used in a SQL statement. For example, the offending code might look like: EXEC SQL AT oracle3 COMMIT RELEASE END-EXEC. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the AT <db_name> clause.
PCB-00311: Datatype equivalencing is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the EXEC SQL VAR statement was used.
Action: No action required. However, for ANSI/ISO compliance, do not use the EXEC SQL VAR statement.
PCB-00312: Keyword WORK required here by ANSI
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the keyword WORK was used in a COMMIT or ROLLBACK statement. For example, the offending code might look like: EXEC SQL COMMIT WORK RELEASE END-EXEC. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the keyword WORK.
PCB-00313: TO SAVEPOINT clause is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the TO SAVEPOINT <save_id> clause was used in a ROLLBACK statement.
Action: No action required. However, for ANSI/ISO compliance, do not use the TO SAVEPOINT clause.
PCB-00314: DECLARE DATABASE is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the DECLARE DATABASE statement was used.
Action: No action required. However, for ANSI/ISO compliance, do not use this statement.
PCB-00315: DECLARE TABLE is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the DECLARE TABLE statement was used.
Action: No action required. However, for ANSI/ISO compliance, do not use this statement.
PCB-00316: SQL FORMS statements are Oracle extensions
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the one of the following statements was used:

o EXEC IAF GET

o EXEC IAF PUT

o EXEC TOOLS GET

o EXEC TOOLS SET This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use any of these statements.
PCB-00317: Group item host variables are Oracle extensions
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a group item variable was used as a host variable. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action is required. However, for ANSI/ISO compliance, do not use group items as host variables.
PCB-00318: ARRAYLEN is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the ARRAYLEN statement was used. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action is required. However, for ANSI/ISO compliance, do not use this statement.
PCB-00319: EXEC ORACLE statements are an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, an EXEC ORACLE statement was used. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action is required. However, for ANSI/ISO compliance, do not use this statement.
PCB-00320: VARYING host variable "string" is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a variable declared of VARYING type was used in a SQL statement. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action is required. However, for ANSI/ISO compliance, do not use this statement.
PCB-00321: Implicit varchar host variables are an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, an iimplicit varchar variable was used in a SQL statement. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action is required. However, for ANSI/ISO compliance, do not use this statement.
PCB-00322: EXEC SQL LOB statements an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, an EXEC SQL LOB statement was used. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action is required. However, for ANSI/ISO compliance, do not use this statement. "400 - 499, Tokenizer or parsing errors."
PCB-00400: %s
Cause: A syntax error was found.
Action: Do the appropriate action to fix the indicated error.
PCB-00401: Character string not properly terminated
Cause: The character string was not terminated with a quote or apostrophe as appropriate or line continuation was not correct.
Action: Check that the character string is terminated properly and that line continuation syntax is correct.
PCB-00402: Pseudo-text not properly terminated
Cause: A block of pseudo-text has not been properly terminated with "==".
Action: Terminate the pseudo-text at the appropriate place with "==". "500 - 649, Other semantic errors grouped by these features: threads, result set cursors, miscellaneous, pl/sql (includes arraylen), exec tools and lobs."
PCB-00403: EXEC statement cannot begin in Area A
Cause: An EXEC statement began in Area A (before column 12).
Action: Shift the EXEC statement to the right to start it in Area B (in or after column 12).
PCB-00404: %s
Cause: A syntax error was found.
Action: Do the appropriate action to fix the indicated error. "500 - 524, Threads"
PCB-00500: No EXEC SQL CONTEXT USE statement encountered
Cause: No EXEC SQL CONTEXT USE statement was encountered and the option threads=yes was requested.
Action: Ensure that the necessary context variable (of type sql-context) has been declared, ALLOCATEd, and USEd prior to any executable SQL statements.
PCB-00501: Runtime context variable "string" not of correct type
Cause: The runtime context variable referenced in an EXEC SQL CONTEXT USE statement is not of type sql_context.
Action: Declare your runtime context variable of type sql_context.
PCB-00502: This statement can only be used with THREADS=YES
Cause: EXEC SQL ENABLE THREADS has been used, even though option THREADS is set to NO.
Action: Specify option THREADS=YES or remove the EXEC ENABLE THREADS statement from the source code. "525 - 549, Result Set Cursors"
PCB-00525: Use of the AT clause is not permitted here
Cause: An explicit AT clause was used with an ALLOCATE statement or a FETCH/CLOSE statement also using a sql-cursor declaration.
Action: Remove the AT clause. "550 - 574, Miscellaneous"
PCB-00550: Unable to log on to ORACLE with "string". ORACLE error number: number
Cause: The precompiler was unable to log on to ORACLE with the specified username and password. An ORACLE error with given number occurred when the logon was attempted.
Action: .
PCB-00551: The SQLCA has already been included
Cause: The precompiler has encountered an include SQLCA statement after SQLCA has already been included. The SQLCA can only be included once.
Action: Remove the duplicate include SQLCA statement.
PCB-00552: The SQLCA and a SQLCODE variable cannot both be used
Cause: The SQLCA has been included and a SQLCODE variable has been declared. This is not allowed as references to the SQLCODE variable are ambiguous and will result in COBOL compiler errors.
Action: Use either the SQLCA or the SQLCODE variable. Remove either the include of the SQLCA or the SQLCODE variable declaration.
PCB-00553: FOR clause not allowed on this statement
Cause: A FOR clause was used with a SELECT, LOB, or DEALLOCATE DESCRIPTOR statement. A FOR clause cannot be used with these statements. In the case of a SELECT statement, data returned from the last loop in the execution of the SELECT would overwrite data returned in a previous loop.
Action: Remove the FOR clause from the statement. Use a host language construct to iteratively execute the statement.
PCB-00554: Must include SQLCA when mode=ANSI and WHENEVER SQLWARNING used
Cause: When MODE={ANSI | ANSI14}, an attempt was made to use the WHENEVER SQLWARNING statement without declaring the SQLCA. When MODE={ANSI | ANSI14}, declaring the SQLCA is optional, but to use the WHENEVER SQLWARNING statement, the SQLCA must be declared.
Action: Remove all WHENEVER SQLWARNING statements from the program or declare the SQLCA by hardcoding it or copying it into the program with the INCLUDE statement.
PCB-00555: Using WHERE CURRENT OF on cursor defined without FOR UPDATE clause
Cause: if mode=ORACLE, then a cursor defined with a WHERE CURRENT OF clause must also have a FOR UPDATE clause.
Action: Rewrite the cursor definition.
PCB-00556: Unrecoverable error. Fix previous errors and re-precompile
Cause: A fatal parsing error or token stack overflow error has been encountered.
Action: Fix the syntax error that is causing the parsing error.
PCB-00557: USING clause can only be used on a PREPAREd dynamic statement
Cause: A severe semantics error occurred because the USING clause was used with the OPEN cursor statement and the cursor declaration is not for a PREPAREd statement. The correct sequence of statements should be like: EXEC SQL prepare sv from :sel_stmt END-EXEC. EXEC SQL declare csv cursor for sv END-EXEC. EXEC SQL open csv USING :hv1, :hv2 END-EXEC.
Action: Use the prepare statement for the sql statement and use that in the declare cursor statement.
PCB-00558: Invalid external datatype specified in EXEC SQL VAR statement
Cause: An invalid external datatype was specified in the EXEC SQL VAR statement.
Action: Specify a valid external datatype. "575 - 599, PL/SQL (including ARRAYLEN)"
PCB-00575: PLS-number: string
Cause: Refer to the indicated PL/SQL error message for the indicated condition.
Action: Refer to the indicated PL/SQL error message to correct the SQL statement or embedded PL/SQL block.
PCB-00576: PLS-number: string
Cause: The precompiler found an error in an embedded SQL statement or PL/SQL block.
Action: Refer to the indicated PL/SQL error message to correct the SQL statement or embedded PL/SQL block.
PCB-00577: Use of ARRAYLEN with host tables in SQL statements is ignored
Cause: ARRAYLEN is only valid with PL/SQL.
Action: Use an appropriate table type.
PCB-00578: Variable "string" must be a table
Cause: In an ARRAYLEN statement, the name of a previously declared host table was not specified. The first host variable in an ARRAYLEN statement must be a table. The second host variable, which specifies an array dimension, must be a 4-byte integer. The correct syntax follows: EXEC SQL ARRAYLEN HTABLE (DIM) END-EXEC. The ARRAYLEN statement must appear along with, but somewhere after, the declarations of host_table and dimension.
Action: Check the spelling of both identifiers in the ARRAYLEN statement. If necessary, supply the missing host table name.
PCB-00579: Invalid ARRAYLEN length variable type for "string"
Cause: A valid table dimension was not specified in an ARRAYLEN statement. The table dimension must be specified using a previously declared 4-byte integer host variable, not a literal or expression. For example, the offending code might look like: EXEC SQL ARRAYLEN ETABLE (25) END-EXEC. -- illegal dimension
Action: Supply a valid table dimension. If necessary, declare a 4-byte integer host variable for use in the ARRAYLEN statement.
PCB-00580: Previous use of host variable "string" uses different indicator
Cause: Within a PL/SQL statement, a host variable was used with two different indicator variables or was used with an indicator variable in one instance and without an indicator in another instance.
Action: Change all references to the host variable so that they all use the same indicator variable or all use no indicator variable.
PCB-00581: "string" used as both host variable and indicator
Cause: Within a PL/SQL statement, the variable was used as both a host variable and an indicator variable.
Action: Use different variables for host variables and indicator variables. "600 - 624, EXEC TOOLS"
PCB-00600: indicators are not allowed in EXEC IAF statements
Cause: Indicator variables associated with host variables cannot be used in EXEC IAF statements such as GET and PUT in a user exit.
Action: Eliminate the indicator variables. If feasible (for example with Forms V4), use EXEC TOOLS statements, which do allow indicator variables. See the Programmer's Guide to the Oracle Precompilers for more information of EXEC IAF and EXEC TOOLS statements.
PCB-00603: An EXEC TOOLS MESSAGE host variable is not a character type
Cause: If a host variable is used to specify the message in an EXEC TOOLS MESSAGE statement, that host variable must be of a character type.
Action: Declare the message to a host variable of a char type. "625 - 649, EXEC SQL LOB statements"
PCB-00625: An indicator variable is not required with this attribute
Cause: In a LOB DESCRIBE, an indicator variable was used with a host variable when retrieving a LOB attribute that does not require one.
Action: Remove the indicator variable.
PCB-00626: Incompatible LOB types
Cause: A LOB operation was attempted between LOBs whose types were not compatible. For example, When ASSIGNing one LOB to another, both LOBs must be of the same type. If they are not, this error results.
Action: Correct the LOB operation by having it function between LOBs of the same type. This may require a redeclaration of one of the LOBs used in the LOB statement performing the specified operation.
PCB-00627: Host variable is not of character type
Cause: The given host variable was not declared to be of the required character type. In this case, one of several possible character types would have been accepted. However, the host variable type did not match any of them.
Action: Redeclare the problematic host variable, using one of the permitted character types.
PCB-00628: Buffer type is incompatible with LOB type
Cause: This error can occur in either of the following situations

1. An attempt to READ from a LOB into a buffer whose type was not compatible with the LOB type.

2. An attempt to WRITE a buffer into a LOB whose type was not compatible with the buffer type.

Action: Either the LOB type or the buffer type needs to be changed so that the LOB and buffer types become compatible for the specified operation.
PCB-00629: Host variable is not of Internal LOB type
Cause: The given host variable was not declared to be an internal LOB. BLOB, CLOB or NCLOB are internal lob types.
Action: Redeclare the host variable using one of the internal LOB types.
PCB-00630: Host variable is not of LOB type
Cause: The given host variable was not declared to be any type of LOB, Internal or External. BLOB, CLOB or NCLOB are internal lob types. BFILE is an external type.
Action: Redeclare the host variable using any of the LOB types, Internal or External.
PCB-00631: Host variable is not an External LOB
Cause: The given host variable was not declared to be an External LOB. BFILE is an external type.
Action: Redeclare the host variable using an External LOB type (BFILE).
PCB-00632: Cannot open an External LOB in READ WRITE mode
Cause: An attempt was made to OPEN a BFILE in READ WRITE mode. Writable BFILEs are currently not supported so this operation is considered erroneous.
Action: Do not open BFILEs using READ WRITE mode. BFILEs can only be OPENed in READ ONLY mode.
PCB-00633: Invalid host variable and attribute pairing
Cause: The host variable and attribute pairing in a LOB DESCRIBE was invalid. Most likely, this was due to some problem with the host variable. For example, this error could occur if the host variable was not declared.
Action: Usually, other, more specific, errors will accompany this one. Correcting some or all of those problems should resolve this error.
PCB-00635: This attribute is only valid for Internal LOB types
Cause: A request for a LOB attribute was made in a LOB DESCRIBE statement in which the given LOB was not of some Internal LOB type.
Action: Replace the LOB host variable in the LOB DESCRIBE with one that was declared to be an Internal LOB.
PCB-00636: This attribute is only valid for External LOB types
Cause: A request for a LOB attribute was made in a LOB DESCRIBE statement in which the given LOB was not an External LOB type (BFILE).
Action: Use an External LOB (BFILE) host variable in the LOB DESCRIBE statement.
PCB-00637: Host variable is not an exact binary integer
Cause: A host variable was given that was not declared to be of some acceptable exact binary integer type. Generally, when this error occurs, a signed or unsigned integer type was expected. Floating point or otherwise imprecise numeric types are considered erroneous.
Action: Replace the problematic host variable with one that was declared using a proper binary integer type.
PCB-00638: This attribute is only valid for internal or external LOB types
Cause: A request for a LOB attribute was made in a LOB DESCRIBE statement in which the given source was not an internal or external LOB type.
Action: Use a LOB host variable in the LOB DESCRIBE statement.
PCB-00639: Cannot specify destination offset in a LOB WRITE APPEND
Cause: A destination offset was specified in a LOB WRITE APPEND statement. The destination offset is assumed to be the end of the LOB so specifying an explicit destination offset is erroneous.
Action: Remove the destination offset from the LOB WRITE APPEND statement. "700 - 725, Dynamic SQL error conditions"
PCB-00700: This statement can only be used with DYNAMIC=ANSI
Cause: One of the following statements was used without specifying DYNAMIC=ANSI:

o EXEC SQL ALLOCATE/DEALLOCATE/GET/SET DESCRIPTOR

o EXEC SQL DESCRIBE OUTPUT/INPUT ... USING ... <descriptor name>

o EXEC SQL EXECUTE ... INTO ...

o EXEC SQL EXECUTE ... USING... <descriptor name>

o EXEC SQL OPEN ... INTO ...

o EXEC SQL OPEN ... USING... <descriptor name>

o SCROLL in DECLARE CURSOR

o EXEC SQL FETCH <orientation> ... where <orientation> is NEXT, PRIOR, FIRST, LAST, ABSOLUTE, or RELATIVE

Action: Specify DYNAMIC=ANSI or remove statement(s) like those above.
PCB-00701: MAX OCCURRANCES must be between 1 and 65535
Cause: The value specified in the WITH MAX clause of an EXEC SQL ALLOCATE DESCRIPTOR statement was less than 1 or greater than 65535
Action: Specifiy a value between 1 and 65535 inclusive
PCB-00702: Out-of-range item number
Cause: The value specified in the VALUES clause of an EXEC SQL GET/SET DESCRIPTOR statement was less than one or greater than 65535.
Action: Specify a value between 1 and 65535. "900 - 1000, Fatal error conditions"
PCB-00901: Pro*COBOL internal error condition detected (Code = number)
Cause: Pro*COBOL had detected an abnormal condition in its internal data structures. This error message should not normally ever be produced. Customer service should be contacted to report the error.
Action: Correct any other errors which have been reported. If the internal error still exist, examine the source code where the condition was detected and try modifying in some way. Possibly this will alleviate the internal error condition.
PCB-00902: Unable to read message file, facility PCB
Cause: Pro*COBOL was unable to access the message file containing message text. The file is possibly corrupt.
Action: Contact customer support for information on reinstalling the Pro*COBOL message files.
PCB-00903: Pro*COBOL is unable to initialize its parser function
Cause: Pro*COBOL was unable to access the message file containing message text. The file is possibly corrupt.
Action: Contact customer support for information on reinstalling the Pro*COBOL message files.


55 PCC-00001 to PCC-01515

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

55 PCC-00001 to PCC-01515

PCC-00001: Unable to open file string
Cause: The precompiler was unable to open a temporary file for internal use. There might be insufficient disk space, too many open files, or read-only protection on the output directory.
Action: Check that there is enough disk space, that the limit for open files is set high enough (check with the system manager) and that protection on the directory allows opening a file for writing.
PCC-00002: Invalid syntax at column number in line number of file string
Cause: There is a syntax error in an EXEC statement or the statement is not properly terminated.
Action: Correct the syntax of the EXEC statement. If the error occurred at the end of the input file, check that the last EXEC statement is properly terminated.
PCC-00003: Invalid SQL Identifier at column number in line number of file string
Cause: The symbol in a conditional precompilation statement (such as EXEC ORACLE IFDEF) is invalid, or the name of a SQL descriptor, statement, or cursor is invalid or was not properly declared.
Action: Check the statement syntax and spelling of the identifier and check that a reserved word was not accidentally used. If necessary, define the identifier in a variable declaration or DECLARE statement ahead of the line in error.
PCC-00004: Mismatched IF/ELSE/ENDIF block at line number in file string
Cause: There is an EXEC ORACLE ELSE or EXEC ORACLE ENDIF statement without a matching EXEC ORACLE IFDEF statement.
Action: Add the missing EXEC ORACLE IFDEF statement or deletee or move the EXEC ORACLE ELSE or EXEC ORACLE ENDIF statement.
PCC-00005: Unsupported datatype in line number of file string
Cause: A host variable defined in the Declare Section has an unsupported datatype or has a scale or precision outside the supported range.
Action: Redefine the host variable using a supported datatype. Check that the scale and precision of a numeric variable are in the accepted range.
PCC-00007: Invalid WHENEVER condition at column number in line number of file string
Cause: A condition other than SQLERROR, SQLWARNING, or NOT FOUND was specified in an EXEC SQL WHENEVER statement, or one of these was used, but spelled incorrectly.
Action: Correct the spelling of the WHENEVER condition or use a host- language IF statement to test the special condition.
PCC-00008: Invalid WHENEVER action at column number in line number of file string
Cause: At lease one of the following:

o An action other than CONTINUE, DO, GOTO, or STOP was specified in an EXEC SQL WHENEVER statement.

o One of the specified actions was spelled incorrectly.

o The host language does not allow the action (STOP is illegal in Pro*Pascal programs).

o A GOTO label is invalid.

Action: Check that the host language allows the specified WHENEVER action. If necessary, correct the spelling of the WHENEVER action or correct the GOTO label.
PCC-00009: Invalid host variable at column number in line number of file string
Cause: A host variable used in an EXEC SQL statement was not declared in the Declare Section or has an unsupported datatype.
Action: Declare the host variable in the Declare Section, making sure it has one of the supported datatypes.
PCC-00010: Statement out of place at line number in file string
Cause: An EXEC statement was not placed properly in the host program. For example, there might be a data manipulation statement in the Declare Section. In a Pro*COBOL program, the Declare Section might be outside the WORKING-STORAGE or LINKAGE SECTION.
Action: Remove or relocate the statement.
PCC-00011: Already in a declare section at line number in file string
Cause: A BEGIN DECLARE SECTION statement was found inside a Declare Section.
Action: Remove the extra BEGIN DECLARE SECTION statement.
PCC-00012: Not in a declare section at line number in file string
Cause: An END DECLARE SECTION statement without a matching BEGIN DECLARE SECTION statement was found. Either the BEGIN DECLARE SECTION statement is missing or misspelled or the END DECLARE SECTION statement is an extra.
Action: Add or correct the BEGIN DECLARE SECTION statement or remove the extra END DECLARE SECTION statement.
PCC-00013: Unable to open include file "string" at line number in file string
Cause: The precompiler was unable to open the input file specified in the INCLUDE statement. Some possible causes follow:

o The filename is misspelled.

o The file does not exist.

o The search path to the file is incorrect.

o File access privileges are insufficient.

o There is not enough disk space.

o There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges to access the file have been granted, and that it is not locked by another user. Also, check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).
PCC-00014: Undeclared SQL Identifier "string" at line number in file string
Cause: The name of a descriptor, statement, or cursor was not declared or is misspelled.
Action: Add or correct the descriptor, statement, or cursor declaration.
PCC-00015: Unrecognized Host Language syntax ignored at line number in file string
Cause: The host language syntax used to define a host variable in the Declare Section is incorrect.
Action: Check the syntax and the spelling, then correct the declaration.
PCC-00016: Unable to open a cursor at line number in file string
Cause: The syntax in a SQL statement is faulty. The precompiler was expecting a host variable, but found something else.
Action: Check the syntax and the spelling, then correct the SQL statement.
PCC-00017: Unable to parse statement at line number in file string
Cause: There is a syntax error in an array declaration. The precompiler was expecting a right bracket (]) but found something else.
Action: Check the syntax, then correct the array declaration.
PCC-00018: Expected "string", but found "string" at line number in file string
Cause: The syntax in a SQL statement is faulty. The precompiler found an unexpected or illegal token.
Action: Check the syntax and the spelling, then correct the SQL statement.
PCC-00019: Unable to obtain bind variables at line number in file string
Cause: The precompiler was unable to find information about an input host variable (bind variable) used in a SQL statement.
Action: Check that the input host variable is declared in the Declare Section and used properly in the SQL statement.
PCC-00020: Unable to obtain define variables at line number in file string
Cause: The precompiler was unable to find information about an output host variable (define variable) used in a SQL statement.
Action: Check that the output host variable is declared in the Declare Section and used properly in the SQL statement.
PCC-00021: Oracle Error: string
Cause: An Oracle error occurred.
Action: Refer to the indicated message in the ORA message chapters of this manual.
PCC-00022: Out of space - unable to allocate number bytes
Cause: The precompiler process ran out of memory.
Action: Allocate more memory to the process, then retry.
PCC-00023: Unable to log off from ORACLE
Cause: An Oracle connection error occurred while the precompiler was trying to log off, probably because ORACLE has been shut down.
Action: Check that ORACLE is available, then retry.
PCC-00024: Indicator variable "string" has wrong type or length at line number in file string
Cause: An indicator variable was not declared in the Declare Section as a 2-byte integer. Indicator variables must be defined as 2-byte integers.
Action: Redefine the indicator variable as a 2-byte integer.
PCC-00025: Undeclared indicator variable "string" at line number in file string
Cause: An indicator variable used in a SQL statement was not declared in the Declare Section or its name is misspelled.
Action: Add or correct the indicator variable declaration.
PCC-00026: Invalid host variable "string" at line number in file string
Cause: A host variable used in a SQL statement was not declared properly. Some possible causes follow:

o It was not declared in the Declare Section.

o Its datatype is not supported.

o Its name is misspelled.

o It is a COBOL group item; in Pro*COBOL, only elementary items are allowed in a SQL statement.

Action: Add or correct the host variable declaration.
PCC-00027: Redeclared SQL Identifier "string" at line number in file string
Cause: The name of a SQL descriptor, statement, or cursor was re-declared (that is, declared twice)
Action: Check the spelling of the identifier, then, if necessary, remove the extra declaration.
PCC-00028: Option "string" not legal as EXEC ORACLE OPTION
Cause: A precompiler option was specified inline in an EXEC ORACLE statement. Some options can be specified only on the command line. For example, INAME cannot be specified inline.
Action: Respecify the precompiler option on the command line, instead of in an EXEC ORACLE statement. To see an online display of the precompiler options, enter the precompiler command (with no options) at the operating-system prompt.
PCC-00029: Ambiguous option "string"
Cause: The name of a precompiler option was abbreviated ambiguously. For example, MAX= might refer to MAXLITERAL or MAXOPENCURSORS.
Action: Respecify the full option name or an unambiguous abbreviation. To see an online display of the precompiler options, enter the precompiler command (with no options) at the operating-system prompt.
PCC-00031: Invalid value given for option "string"
Cause: The value specified for a precompiler option is invalid, probably because the value is misspelled (as in LTYPE=HORT) or out of range (as in PAGELEN=-55).
Action: Check the value, making sure it is spelled correctly and within the legal range.
PCC-00032: Invalid option "string"
Cause: The precompiler found an invalid precompiler option name. Some possible causes follow:

o The option name is misspelled.

o The specified option does not exist.

o The equal sign (=) between the option name and value is missing or has space around it.

Action: Check that the option exists and that its name is spelled correctly. To see an online display of the precompiler options, enter the precompiler command (with no options) at the operating- system prompt. Also check that there is an equal sign between the option name and value.
PCC-00033: Missing operand for option "string"
Cause: No value was specified for a precompiler option. Either the value is missing or there is space around the equal sign (as in LTYPE =SHORT).
Action: Check that a value for each option has been specified and there is no space around the equal sign.
PCC-00036: No input file name specified
Cause: The input file was not specified on the command line.
Action: Use the INAME command-line option to specify the input file.
PCC-00037: Unable to log on to ORACLE with "string". ORACLE error number: number
Cause: The precompiler was unable to log on to ORACLE with the specified username and password. An ORACLE error with given number occurred when the logon was attempted.
Action: Refer to the indicated message in the ORA message chapters of this manual.
PCC-00038: Unable to open a cursor
Cause: This is an internal error message not usually issued.
Action: Call customer support for assistance. If the application does not require syntactic or semantic checking of SQL statements and does not use PL/SQL, specify SQLCHECK=NONE on the command line.
PCC-00039: Unable to open input file "string"
Cause: The precompiler was unable to open the input file specified by the INAME precompiler option. Some possible causes follow:

o The filename is misspelled.

o The file does not exist.

o The search path to the file is incorrect.

o File access privileges are insufficient.

o Another user has locked the file.

o There is not enough disk space.

o There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).
PCC-00040: Unable to open listing file "string"
Cause: The precompiler was unable to open the listing file specified by the LNAME precompiler option. Some possible causes follow:

o The filename is misspelled.

o The file does not exist.

o The search path to the file is incorrect.

o File acces privileges are insufficient.

o Another user has locked the file.

o There is not enough disk space.

o There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager). If a listing file is not needed, specify LTYPE=NONE on the command line.
PCC-00041: Unable to open output file "string"
Cause: The precompiler was unable to open the listing file specified by the ONAME precompiler option. Some possible causes follow:

o The filename is misspelled.

o The file does not exist.

o The search path to the file is incorrect.

o File acces privileges are insufficient.

o Another user has locked the file.

o There is not enough disk space.

o There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).
PCC-00042: Must EXEC SQL INCLUDE SQLCA when mode=ANSI and WHENEVER SQLWARNING used
Cause: When MODE={ANSI | ANSI14}, an attempt was made to use the WHENEVER SQLWARNING statement without declaring the SQLCA. When MODE={ANSI | ANSI14}, declaring the SQLCA is optional, but to use the WHENEVER SQLWARNING statement, the SQLCA must be declared.
Action: Remove all WHENEVER SQLWARNING statements from the program or declare the SQLCA by hardcoding it or copying it into the program with the INCLUDE statement.
PCC-00044: Array size mismatch in INTO/USING. Minimum is: string(number:number)
Cause: The size of an array variable in an INTO/USING clause is too small for the number of rows processed.
Action: Declare all array variables in the INTO/USING clause to have at least the minimum dimension given.
PCC-00045: %s clause inappropriate at line number in file string. Ignored.
Cause: There is a misplaced clause at the end of an EXEC SQL statement (an AT clause at the end of a SELECT statement, for example), or the
Action: Check the statement syntax, then relocate or correct the misplaced or invalid clause.
PCC-00047: Unterminated comment/string constant beginning near line number in file string
Cause: A string constant is missing an ending quotation mark, or a comment is missing an ending delimiter.
Action: Check that all comments are delimited and all string constants are enclosed by quotation marks.
PCC-00050: Unable to generate descriptor in program unit ending line number in file string
Cause: The precompiler was unable to generate a descriptor for the compilation unit. This can occur from either of the following:

o A non-existent or improperly implemented Declare Section

o Undetected syntax errors near the beginning of the source file or just before the END DECLARE SECTION statement

Action: Verify that the Declare Section is properly implemented. Then check for syntax errors at the beginning of the compilation unit and before any END DECLARE SECTION statement, and correct as appropriate.
PCC-00051: Size of VARCHAR string is larger than 65533 in line number in file string
Cause: The declared size of a VARCHAR host variable exceeds the precompiler limit of 65533 bytes.
Action: Check the Declare Section, making sure the size of each VARCHAR variable does not exceed the limit of 65533 bytes.
PCC-00053: FOR variable string is invalid type at line number in file string
Cause: The count variable in a FOR clause has the wrong datatype. The datatype must be NUMBER or LONG (or be compatible with NUMBER or LONG).
Action: Check the declaration and check that the count variable has a datatype of NUMBER or LONG (or a compatible Oracle or host-language datatype).
PCC-00054: Expected End-of-Statement at column number in line number of file string
Cause: The precompiler expected to find a statement terminator at the end of an EXEC statement but found something else. This can happen if tabs were embedded in the source code (because the precompiler has no way of knowing how many spaces a tab represents).
Action: If tabs are embedded in the source ocde, replace them with spaces. Check the statement syntax and check that each EXEC statement has a terminator. For embedded CREATE {FUNCTION | PROCEDURE | PACKAGE} statements and for embedded PL/SQL blocks, check that the statement terminator is END-EXEC.
PCC-00055: Array "string" not allowed as bind variable at line number in file string
Cause: A host array was used as a bind (input) variable in the WHERE clause of a SELECT statement. This is not allowed.
Action: Remove the host array or replace it with a simple host variable.
PCC-00056: FOR clause not allowed on SELECT statement at line number in file string.
Cause: A FOR clause was used with a SELECT statement. This is not allowed as data returned from the last loop in the execution of the SELECT overwrites data returned in a previous loop.
Action: Remove the FOR clause from the SELECT statement and use a host- language construct to iteratively execute the SELECT statement.
PCC-00060: Both CURSOR and STATEMENT have AT clauses at line number of file string.
Cause: Two AT clauses, one in a DECLARE STATEMENT statement, the other in a DECLARE CURSOR statement, pertain to the same SQL statement. The AT clause may be specified with either DECLARE STATEMENT or DECLARE CURSOR, but not with both.
Action: Remove the AT clause from one of the statements.
PCC-00061: Error at line number, column number. PLS-number: string
Cause: The precompiler found an error in an embedded SQL statement or PL/SQL block.
Action: Refer to the indicated PL/SQL error message to correct the SQL statement or embedded PL/SQL block.
PCC-00062: Must use option SQLCHECK=SEMANTICS(FULL) when there is embedded PL/SQL
Cause: The precompiler tried to parse an embedded PL/SQL block when SQLCHECK={SYNTAX | NONE}. PL/SQL blocks can be parsed only when SQLCHECK=SEMANTICS is specified.
Action: Remove the PL/SQL block or specify SQLCHECK=SEMANTICS.
PCC-00063: Reached end of file string before End-of-Statement at line number!
Cause: The precompiler encountered an end-of-file while parsing a PL/SQL block.
Action: Add the appropriate statement terminator (;) or end-of-block statement (END;) to the PL/SQL block.
PCC-00064: All uses of a given host variable must use identical indicator variables.
Cause: Two or more occurrences of a host variable in an EXEC SQL statement were associated with different indicator variables. This is not allowed.
Action: Rename the indicator variables so that each occurrence of the host variable is associated with the same indicator variable.
PCC-00065: Userid required, but not specified.
Cause: The SQLCHECK=SEMANTICS option was specified, but the USERID option on the command line was not specified.
Action: Specify USERID=username/password or enter a username and password when prompted or specify SQLCHECK={SYNTAX | NONE}.
PCC-00066: Userid only used when SQLCHECK = FULL, userid ignored.
Cause: The USERID option was specified when SQLCHECK={SYNTAX | NONE}. This is unnecessary.
Action: Specify the USERID option only when SQLCHECK=SEMANTICS.
PCC-00067: Ireclen exceeded. Line number in file string truncated.
Cause: While reading the input file, the precompiler found a line longer than IRECLEN.
Action: Either shorten the input line or specify a larger IRECLEN value on the command line.
PCC-00068: Host and indicator variables may not have the same name.
Cause: In an EXEC SQL statement, an indicator variable had the same name as a host variable. The names of a host variable and its associated indicator variable must be different. Also, an indicator variable cannot be used as a host variable.
Action: Rename the host or indicator variable.
PCC-00069: Host variable "string" has unsupported datatype at line number in file string
Cause: A host variable had an unsupported datatype. For a list of supported datatypes, see the language-specific supplement to the Programmer's Guide to the Oracle Precompilers.
Action: Redefine the host variable in the Declare Section, giving it a supported datatype.
PCC-00070: Illegal syntax, Exponential value in SQL statement: string
Cause: The precompiler found a syntax error while parsing a number coded in scientific notation. The precompiler expected to find a signed integer following the exponentiation indicator (E), but found something else.
Action: Reformat the number correctly.
PCC-00071: Unable to open message file.
Cause: The precompiler was unable to open the message file containing the messages that can be issued by the precompiler. This can happen if there are too many open files or if there were problems with installation of the precompiler.
Action: Check that the limit for open files is high enough (check with the system manager). Otherwise, contact customer support.
PCC-00072: Input file name length exceeds the maximum length
Cause: The file name length specified exceeded the maximum length. Some operating systems have a maximum file name length.
Action: Use a file name of length less than or equal to the maximum platform specific file name length.
PCC-00073: Cursor is declared but never OPENed at line number in file string.
Cause: A cursor was DECLAREd but was not referenced in an OPEN statement. This is only an informational message.
Action: Remove the cursor declaration or code an OPEN statement for the cursor.
PCC-00075: ":" expected before indicator variable
Cause: An indicator variable was not prefixed with a colon, as required.
Action: Prefix a colon to the indicator variable in question.
PCC-00076: DISPLAY type must be SIGN LEADING SEPARATE
Cause: This message is issued only by Pro*COBOL. DISPLAY SIGN LEADING SEPARATE is the only DISPLAY type supported by Pro*COBOL.
Action: Check the spelling of the variable declaration. If necessary, remove the reference to the unsupported DISPLAY type.
PCC-00077: Colon usage with numeric label in WHENEVER statement is not ANSI
Cause: An Oracle extenstion to the ANSI/ISO SQL standard was used. Specifically, a numeric WHENEVER ... GOTO label was prefixed with a colon. For exammple the code might have looked like EXEC SQL WHENEVER SQLERROR GOTO :99; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, prefix alphanumeric (but not numeric) WHENEVER ... GOTO labels with a colon.
PCC-00078: FIPS warning: Invalid ANSI SQL Identifier
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the name given to a host variable:

o is longer than 18 characters,

o does not begin with a letter, or

o contains consecutive or trailing underscores. In the following Pro*C example, the host variable name is 19 characters long and therefore non-compliant: EXEC SQL BEGIN DECLARE SECTION; int department_location: -- not ANSI/ISO compliant EXEC SQL END DECLARE SECTION; This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, change the host variable name so that it is <= 18 characters long, begins with a letter, and does not contain consecutive or trailing underscores.
PCC-00079: ANSI requires colon on label in WHENEVER statement
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, an alphanumeric WHENEVER ... GOTO label was not prefixed with a colon. For example the offending code might look like: EXEC SSQL WHENEVER NOT FOUND GOTO no_more; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, prefix alphanumeric (but not numeric) WHENEVER ... GOTO labels with a colon.
PCC-00080: TYPE identifier already TYPEd
Cause: The identifier being TYPEd in an EXEC SQLY TYPE statement appeared in a previous EXEC SQL TYPE statement. A given identifier can appear in only one EXEC SQL TYPE statement.
Action: Check the spelling of the identifiers. Use different identifiers in the EXEC SQL TYPE statements, or remove one of the EXEC SQL TYPE statements.
PCC-00081: Scale specification not allowed for given datatype
Cause: The Oracle external datatype referenced in an EXEC SQL VAR or EXEC SQL TYPE statement does no allow a scale specification.
Action: Check the precision specification and remove the scale specification.
PCC-00082: Length and scale specifications must be an integer
Cause: A floating point number or a non-number to specify a length or scale was used. Only integers can be used.
Action: Correct or remove the length and/or scale specification.
PCC-00083: Bind and define variables not allowed in CREATE statement
Cause: Host variables cannot appear in a CREATE statement. If the makeup of a CREATE statement cannot be known until run time, a dynamic SQL statement must be used to execute it. That is, the program must accept or build the CREATE statement at run time, store it in a host string, then EXECUTE it.
Action: Correct or remove the erroneous CREATE statement.
PCC-00085: Error writing to file string
Cause: The precompiler was unable to write to the named output file. Some possible causes follow:

o Sufficient file access privileges were not defined.

o Another user has locked the file.

o There is not enough disk space.

o There are too many open files.

Action: Check that sufficient privileges exist to access the file and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with system manager).
PCC-00086: Source file string has zero length
Cause: The source file specified on the command line contains no code. Consequently, there is nothing for the precompiler to process.
Action: Specify a valid source file containing embedded SQL statements.
PCC-00087: EXEC SQL TYPE statement not allowed for this host language
Cause: An EXEC SQL TYPE statement was used with a host language that does not support user-defined datatype equivalencing. This feature is available only in Pro*C and Pro*Pascal.
Action: Remove the offending EXEC SQL TYPE statement.
PCC-00088: User defined type identifier expected
Cause: The user-defined datatype name in an EXEC SQL TYPE statement is missing or misspelled, is a reserved word, is not a legal identifier in the host-language or conflicts with a base datatype in that language.
Action: Check the spelling of the user-defined datatype name. If necessary, declare a valid user-defined datatype. User-defined datatype equivalencing is available only in Pro*C and Pro*Pascal.
PCC-00089: Invalid Oracle TYPE specification
Cause: The Oracle external datatype name in an EXE SQL TYPE or EXEC SQL VAR statement is missing or misspelled.
Action: Check the spelling of the external datatype name. If necessary, supply the missing datatype name.
PCC-00090: Precision/scale specification must be given for DECIMAL datatype
Cause: A precision and/or scale specification for the Oracle external datatype DECIMAL in an EXEC SQL TYPE or EXEC SQL VAR statement was omitted.
Action: Add the precision and/or scale specification to the EXEC SQL TYPE or EXEC SQL VAR statement.
PCC-00091: TYPE statement requires format specification for this Oracle datatype
Cause: A length, precision, and/or scale specification for an Oracle external datatype in an EXEC SQL TYPE or EXEC SQL VAR statement was omitted.
Action: Add the length, precision, and/or scale specification for the external datatype to the EXEC SQL TYPE or EXEC SQL VAR statement.
PCC-00092: Length and/or scale incompatible with specified Oracle datatype
Cause: An invalid length or scale for an Oracle external datatype in an EXEC SQL TYPE or EXEC SQL VAR statement was specified.
Action: Check that a length large enough to accommodate the external datatype is specified. If a scale is specified, check that it lies in the range -84..99.
PCC-00093: Invalid or obsolete option, ignored
Cause: The precompiler found an option available in a prior version or different host language but not in the current version or host language.
Action: Remove the option specification.
PCC-00094: Array length for char[n] datatype must be >= 2
Cause: When MODE={ANSI | ANSI14}, a length of less than 2 characters for a char[n] host variable was specified or a simple char variable was specified. When MODE={ANSI | ANSI14}, the length must be at least 2 characters. This message is issued only by the Pro*C precompiler.
Action: Correct the declaration so that it specifies a length of at least 2 characters.
PCC-00095: Missing PROGRAM, SUBROUTINE, FUNCTION, or BLOCK DATA statement
Cause: FORTRAN source files are expected to have at least one PROGRAM, SUBROUTINE, FUNCTION, or BLOCK DATA statement, which the precompiler uses to detect the beginning of a routine or compilation unit.
Action: Add one of these statements to the source file.
PCC-00096: Array FETCH not allowed for mode=ANSI14
Cause: When MODE=ANSI14, an array SELECT or FETCH was attempted. However, array operations are not allowed with MODE=ANSI14.
Action: If MODE=ANSI14 must be specified, place the SELECT or FETCH statement in a host-language loop, instead of using the array interface.
PCC-00097: Use of DECIMAL and DISPLAY types allowed only for COBOL and PL/I
Cause: The DECIMAL and DISPLAY external datatype was used in an EXEC SQL VAR or EXEC SQL TYPE statement with an Oracle precompiler other than Pro*COBOL or PRO*PL/I. These external datatypes are available only in Pro*COBOL and PRO*PL/I.
Action: Remove the reference to the DECIMAL or DISPLAY external datatype from the EXEC SQL TYPE or EXEC SQL VAR statement.
PCC-00098: Scale specification cannot be used in this context
Cause: In a Pro*C, Pro*FORTRAN, Pro*Pascal program, scale in an EXEC SQL TYPE or EXEC SQL VAR statement in the current context cannot be specified.
Action: Remove the scale specification from the EXEC SQL TYPE or EXEC SQL VAR statement.
PCC-00099: Length cannot be given for types ROWID, DATE, or MLSLABEL
Cause: A length for the ROWID, DATE, or MLSLABEL external datatype was specified in an EXEC SQL TYPE or EXEC SQL VAR statement. This is unnecessary because those are fixed length types.
Action: Remove the length specification from the EXEC SQL TYPE or EXEC SQL VAR statement.
PCC-00100: Non integer label is not ANSI
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a non-integer WHENEVER ... GOTO label was in a Pro*Pascal program. For example, the offending code might look like: EXEC SQL WHENEVER NOT FOUND GOTO quit; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, use only integer WHENEVER... GOTO labels in a Pro*Pascal program.
PCC-00101: Lower case 'e' in floating point number is not ANSI
Cause: A Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a lowercase 'e' was used in scientific notation. For example, the offending code might look like: maxnum = 10e38; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, use an uppercase 'E' in scientific notation.
PCC-00102: FOR UPDATE is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the FOR UPDATE OF clause was used in a cursor declaration. For example, the offending code might look like: EXEC SQL DECLARE emp_cursor CURSOR FOR SELECT ENAME, SAL FROM EMP WHERE DEPTNO = :dept_number FOR UPDATE OF SAL; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the FOR UPDATE OF clause.
PCC-00103: AT clause is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the AT <db_name> clause was used in a SQL statement. For example, the offending code might look like: EXEC SQL AT oracle3 COMMIT RELEASE; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the AT <db_name> clause.
PCC-00104: FOR clause is an Oracle extension
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the FOR clause was used in an array-processing SQL statement. For example, the offending code might look like: EXEC SQL FOR :limit INSERT INTO EMP (EMPNO, JOB, DEPTNO) VALUES (:emp_number, :job_title, :dept_number); This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the FOR clause.
PCC-00105: Keyword WORK required here by ANSI
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the keyword WORK was used in a COMMIT or ROLLBACK statement. For example, the offending code might look like: EXEC SQL COMMIT WORK RELEASE; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the keyword WORK.
PCC-00106: RELEASE is an Oracle extension to the COMMIT and ROLLBACK statements
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the parameter RELEASE was used in a COMMIT or ROLLBACK statement. For example, the offending code might look like: EXEC SQL ROLLBACK RELEASE; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the parameter RELEASE;
PCC-00107: The CONNECT statement is Oracle implementation dependent
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the CONNECT statement was used to log on to ORACLE. For example, the offending code might look like: EXEC SQL CONNECT :username IDENTIFIED BY :password; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, specify the AUTO_CONNECT command-line option instead of using a CONNECT statement.
PCC-00108: This statement is not supported by ANSI
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a nonconforming SQL statement such as PREPARE was used. For example, the offending code might look like: EXEC SQL PREPARE sql_statement FROM :sql_string; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the nonconforming statement.
PCC-00109: Dynamic SQL and PL/SQL are Oracle extensions to ANSI SQL
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, dynamic SQL or embedded PL/SQL was used. For example, the offending code might look like: EXEC SQL EXECUTE BEGIN SELECT ... END; END-EXEC; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use dynamic SQL or embedded PL/SQL.
PCC-00110: Oracle extension to the WHENEVER statement
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a nonconforming keyword such as NOTFOUND, STOP, RAISE, or DO was used in the WHENEVER statement. (Note that NOT FOUND is ANSI-compliant.) For example, the offending code might look like: EXEC SQL WHENEVER SQLERROR STOP; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use the nonconforming keyword.
PCC-00111: SQLCHECK value in EXEC ORACLE statement exceeds command line value
Cause: The SQLCHECK option was entered inline and specified a level of checking higher than the level specified (or accepted by default) on the command line. This is not allowed. For example, if SQLCHECK={SYNTAX | LIMITED} is specified on the command line, SQLCHECK={SEMANTICS | FULL} cannot be specified inline.
Action: Revise the EXEC ORACLE statement or specify a lower level of checking on the command line.
PCC-00112: Datatype not supported by ANSI
Cause: An Oracle extension to the ANSI/ISO standard was used. Specifically, aa pointer or nonconforming datatype such as VARCHAR was used. For example, the offending code might look like: EXEC SQL BEGIN DECLARE SECTION VARCHAR username[20]; EXEC SQL END DECLARE SECTION This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use pointers or nonconforming datatypes.
PCC-00113: Value of DBMS option invalid with given value of MODE option
Cause: When MODE={ANSI14 | ANSI13}, DBMS=V7 was specified, or when MODE=ANSI, DBMS=v6 was specified. These option settings are incompatible. Note that the DBMS option was not available before release 1.5 of the Oracle Precompilers.
Action: With DBMS=V7, instead of MODE={ANSI14 | ANSI13}, specify MODE={ANSI | ORACLE}. With DBMS=V6, instead of MODE=ANSI, specify MODE={ANSI14 | ANSI13 | ORACLE}, but MODE=ORACLE is recommended.
PCC-00114: Length spec required in EXEC SQL VAR statements for VARxxx types
Cause: In an EXEC SQL VAR statement, a VARCHAR or VARRAW external datatype was specified without a length. Unlike other types, the maximum length of the data field must be specified for VARCHAR and VARRAW.
Action: Add a length specification to the EXEC SQL VAR statement.
PCC-00115: Array required here
Cause: In an ARRAYLEN statement, the name of a previously declared host array was not specified. The first host variable in an ARRAYLEN statement must be an array. The second host variable, which specifies an array dimension, must be a 4-byte integer. The correct syntax follows: EXEC SQL ARRAYLEN host_array (dimension); The ARRAYLEN statement must appear in the Declare Section along with, but somewhere after, the declarations of host_array and dimension.
Action: Check the spelling of both identifiers in the ARRAYLEN statement. If necessary, supply the missing host array name.
PCC-00116: This array already given in an ARRAYLEN statement
Cause: The same host array was specified in two different ARRAYLEN statements. A given host array cannot be specified in more than one ARRAYLEN statement.
Action: Check the spelling of the host array names in both ARRAYLEN statements. Change one of the names so that they refer to different host arrays or remove one of the ARRAYLEN statements.
PCC-00117: Invalid ARRAYLEN length variable type
Cause: A valid array dimension was not specified in an ARRAYLEN statement. The array dimension must be specified using a previously declared 4-byte integer host variable, not a literal or expression. For example, the offending code might look like: EXEC SQL ARRAYLEN ename_array (25); -- illegal dimension
Action: Supply a valid array dimension. If necessary, declare a 4-byte integer host variable for use in the ARRAYLEN statement.
PCC-00118: Use of host variable initialization not supported by ANSI SQL
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a host variable was initialized in its declaration, as shown in the following Pro*C example: EXEC SQL BEGIN DECLARE SECTION; int dept_number = 20; -- not ANSI/ISO-compliant EXEC SQL END DECLARE SECTION; This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not initialize host variables in their declarations.
PCC-00119: Value of const variable in INTO clause will be modified
Cause: A variable declared with the type specifier "const" was used in an INTO clause. Such variables should not be modified and should not be used in an INTO clause.
Action: Check the spelling of all identifiers in the INTO clause. If necessary, remove "const" from the host variable declaration or use a different host variable.
PCC-00120: File I/O error during code generation
Cause: d by insufficient disk space.
Action: Check that there is enough disk space.
PCC-00121: Arrays of VARCHAR pointers are not supported
Cause: An array of pointers was declared, which is not allowed. However, pointers to scalar types are allowed. With Pro*C, declare pointers to char[n] and varchar[n] variables as pointers to CHAR or VARCHAR (with no length specification).
Action: Correct or remove the declaration.
PCC-00122: Input file name and output file name are identical
Cause: On the command line, the same pathname for INAME and ONAME was specified, which designates the precompiler input and output files, respectively.
Action: Change one of the path/filenames.
PCC-00123: Entire VARCHAR declaration must be on same line
Cause: In a Pro*C program, a VARCHAR declaration spans more than one line, which is not allowed.
Action: Revise the declaration so that it uses only one line.
PCC-00124: COMMON_NAME option is specified too late
Cause: In a FORTRAN program, subroutine, or function, the precompiler option COMMON_NAME was mistakenly specified after the PROGRAM, SUBROUTINE, or FUNCTION statement. If COMMON_NAME is specified inline, its EXEC ORACLE OPTION statement must precede the PROGRAM SUBROUTINE, or FUNCTION statement.
Action: Relocate the EXEC ORACLE OPTION statement or specify COMMON_NAME on the command line.
PCC-00126: Could not find or open system configuration file
Cause: The precompiler was unable to find or open the system configuration file (a text file containing preset command-line options, which the precompiler uses by default). Some possible causes follow:

o The file does not exist.

o The search path to the file is incorrect.

o File access privileges are insufficient.

o There are too many open files. However, this message is just a warning. Processing continues even if the system configuration file does not exist.

Action: Check that the file exists, that the search path to the file is correct, and that sufficient privileges exist to access the file. Also check that the limit for open files is set high enough (check with the system manager).
PCC-00127: %s
Cause: This is a generic error message from the command-line processor.
Action: Correct the indicated error.
PCC-00128: Command line processor severe error
Cause: The command line processor encountered a severe error.
Action: After making sure that all the command-line options are specified correctly, call customer support with a full account of all the options and configuration files used.
PCC-00129: Option "string" must be given
Cause: A required command-line option is missing. For example, the INAME option, which specifies the name of the input file, might be missing.
Action: Supply the missing command-line option.
PCC-00132: Indicator array size must not be less than its host variable
Cause: An host variable array was used with an indicator array declared with a smaller dimension. For example: EXEC SQL BEGIN DECLARE SECTION; int dept_no[20]; short dept_no_ind[10]; EXEC SQL END DECLARE SECTION; ... SELECT ... INTO dept_no:dept_no_ind ...
Action: Increase the size of the indicator array.
PCC-00133: Command line option MODE=ANSI required with option NLS_LOCAL=YES
Cause: The precompiler option NLS_LOCAL=YES was used without also specifying MODE=ANSI. The precompiler option MODE=ANSI must be specifiied if NLS_LOCAL=YES.
Action: Set the precompiler option MODE=ANSI in addition to NLS_LOCAL=YES or do not set NLS_LOCAL=YES.
PCC-00135: Result Set Cursor usage is not standard SQL
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, an Oracle Result Set Cursor has been used. This informational message is issued by the FIPS Flagger when FIPS=YES.
Action: No action required. However, for ANSI/ISO compliance, do not use Result Set Cursors.
PCC-00136: Invalid SQL_CURSOR declaration
Cause: An array of SQL_CURSOR host variables was declared or, if Pro*COBOL, a PICTURE clause was specified in the SQL-CURSOR declaration. In Pro*FORTRAN, a length specification (i.e. "*n") on the SQL_CURSOR declaration could have been specified. These usages are not supported.
Action: Check that the SQL_CURSOR variable is not declared as an array or, if Pro*COBOL, that no PICTURE clause is specified for the SQL_CURSOR. In Pro*FORTRAN, check that there is no length specification (i.e. "*n") for the SQL_CURSOR.
PCC-00137: Invalid use of SQL cursor host variable
Cause: A SQL_CURSOR variable was used in an INTO or WHERE clause. SQL_CURSOR variables can be used only where ordinary cursor identifiers would be used or, in a PL/SQL block, where a cursor would normally be used.
Action: Remove the SQL cursor variable reference from the INTO clause or WHERE clause, or use a host variable of another type in the INTO or WHERE clause.
PCC-00138: Result Set Cursors are not implemented in this precompiler
Cause: There was an attempt to reference a host variable as a cursor reference. Cursor variables are not implemented in PRO*Pascal or Pro*PL/I.
Action: Rewrite your host-language code to use standard SQL cursors.
PCC-00139: Cannot change MAXLITERAL after an EXEC SQL statement
Cause: The MAXLITERAL option has been used in an inline EXEC ORACLE OPTION statement after and EXEC SQL, EXEC TOOLS, or EXEC IAF statement. This is not allowed.
Action: Use the MAXLITERAL option only on the command line or in an EXEC ORACLE OPTION statement placed at the beginning of the input source file.
PCC-00140: CREATE FUNCTION/PROCEDURE/PACKAGE/TRIGGER are Oracle extensions
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, one of the following statements was used:

o CREATE FUNCTION

o CREATE PROCEDURE

o CREATE PACKAGE

o CREATE TRIGGER These statements are Oracle extensions to the ANSI/ISO SQL standards. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use any of these statements.
PCC-00141: Thread Safety is not implemented in this precompiler
Cause: There has been an attempt to use CONTEXT sql statements. The thread safety feature is not implemented in PRO*Pascal, Pro*PL/I, or Pro*C 1.x.
Action: Rewrite your host-language code to not use contexts.
PCC-00142: No EXEC SQL CONTEXT USE statement encountered
Cause: No EXEC SQL CONTEXT USE statement was encountered and the option threads=yes was requested.
Action: Ensure that the necessary context variable (of type sql_context) has been declared, ALLOCATEd, and USEd prior to any executable SQL statements.
PCC-00143: Runtime context variable not of correct type
Cause: The runtime context variable referecned in an EXEC SQL CONTEXT USE statement is not of type sql_context.
Action: Declare your runtime context variable of type sql_context.
PCC-00144: UNSAFE_NULL=YES must be used with DBMS=V7 and MODE=ORACLE
Cause: The option UNSAFE_NULL=YES has been used with DBMS=V6 or DBMS=NATIVE (the default) or has been used with MODE=ANSI/ANSI14/ANSI13.
Action: Either specify DBMS=V7 and MODE=ORACLE (the default) when using UNSAFE_NULL=YES or do not use UNSAFE_NULL=YES.
PCC-00145: This statement can only be used with THREADS=YES
Cause: EXEC SQL ENABLE THREADS or one of the EXEC SQL CONTEXT statements has been used, even though option THREADS is set to NO.
Action: Specify option THREADS=YES or remove the EXEC ENABLE THREADS or EXEC SQL CONTEXT statement from the source code.
PCC-00146: Illegal value for host option, ignored
Cause: An invalid host language was specified using the command-line host option. The host option valid values are pro* language specific. For example, for profor, the only valid value is FORTRAN. For procob, the only valid values are COBOL and COB74.
Action: Specify a valid host language with the host option.
PCC-00147: DBMS=V6 no longer supported; using DBMS=NATIVE
Cause: V6 compatibility is no longer supported. The precompiler will precompile as though DBMS=NATIVE was specified.
Action: Revise the specified DBMS option value from v6 to another value as desired.
PCC-01000: You are not authorized to run Pro*COBOL
Cause: The authorization or license to run the Pro*COBOL Precompiler has expired.
Action: Call customer support for assistance.
PCC-01001: Your Pro*COBOL authorization is about to expire
Cause: The authorization or license to run the Pro*COBOL Precompiler is about to expire.
Action: Call customer support for assistance.
PCC-01002: Invalid character "character" in indicator area at line number in file string
Cause: In a Pro*COBOL Precompiler program, only a blank, hyphen (-), asterisk (*), slash (/), or letter "D" is allowed in the indicator area, but the precompiler found another character.
Action: Remove or replace the invalid character. If the FORMAT=ANSI option is specified, check for an end-of-line in column 7.
PCC-01003: Invalid continuation at line number in file string
Cause: In a PRO*COBOL program, a continuation line was completely blank, except for the continuation character.
Action: Remove or replace the empty continuation line.
PCC-01004: In an EXEC statement at end-of-file
Cause: In a Pro*COBOL input file, the last EXEC statement was not terminated properly.
Action: Terminate the last EXEC statement with an END-EXEC.
PCC-01005: PROCEDURE DIVISION not found
Cause: The precompiler could not find the PROCEDURE DIVISION header in a Pro*COBOL program. Some possible causes follow:

o A keyword in the header is missing or misspelled.

o There is an apostrophe in the REMARKS section (the precompiler mistook the apostrophe for the beginning of a string literal).

o There is an unterminated literal in the WORKING-STORAGE SECTION.

o The wrong value for the FORMAT option was specified.

Action: Check that the PROCEDURE DIVISION header is in place and spelled correctly, that there is no apostrophe in the REMARKS section, that all literals in the WORKING-STORAGE SECTION are terminated, and that the right value for the FORMAT option is specified.
PCC-01006: EXEC statement cannot begin in Area A at line number in file string
Cause: In a Pro*COBOL program, EXEC statements must begin in Area B, but the precompiler found a statement beginning in Area A.
Action: Move the statement rightward so that it begins in Area B.
PCC-01007: WORKING-STORAGE SECTION not found
Cause: The precompiler could not find the WORKING-STORAGE SECTION header in a Pro*COBOL program, probably because a keyword is missing or misspelled, or the wrong value for the FORMAT option might have been specified.
Action: Check that the WORKING-STORAGE SECTION header is in place and spelled correctly and that the right value for the FORMAT option is specified.
PCC-01008: Multiple element records not allowed in DECLARE section
Cause: A few COBOL compilers do not allow group items to be passed as parameters in a CALL statement. (Check the COBOL compiler user's guide.) If the compiler is one of these, group items within the Declare Section can contain only one elementary item.
Action: Assign each host variable its own group item.
PCC-01009: For hostlan = COB74, a SQL statement must be followed by ELSE or "."
Cause: In a Pro*COBOL program, an EXEC SQL statement is followed by another statement in the same sentence. An EXEC SQL statement must be the last statement in a COBOL-74 sentence and so must be terminated by the keyword ELSE or a period.
Action: Change the program logic, making the EXEC SQL statement the last statement in the sentence.
PCC-01010: Invalid use of NULL character in character literal
Cause: A null character (binary zero) was found in a string literal. This is not allowed by Pro*COBOL.
Action: Remove the null character from the string literal.
PCC-01011: USAGE IS BINARY clause must be terminated by "." on same line
Cause: The period terminating the USAGE IS BINARY clause must be on the same line as the USAGE clause. This message only occurs on systems that support the COMP5=YES command line option of Pro*COBOL, where where COMP-5 is substituted for BINARY.
Action: Check that the period terminating the USAGE IS BINARY clause is on the same line as the USAGE clause.
PCC-01012: DATA DIVISION not found
Cause: The Pro*COBOL precompiler did not find a DATA DIVISION in the input source file. Pro*COBOL applications are required to have a DATA DIVISION.
Action: Add a DATA DIVISION to the input source file.
PCC-01013: Invalid use of PIC N array variable "string" at line number in file string
Cause: A PIC N variable was declared using an OCCURS clause. Tables of PIC N variables are not supported by the Pro*COBOL precompiler.
Action: Declare the PIC N variable without an OCCURS clause or, if the PIC N variable is not used in any SQL statements, declare it outside the Declare Section.
PCC-01014: "VARYING" not supported with PIC N PICTURE clause
Cause: The keyword VARYING was used in a PIC N variable declaration.
Action: Remove the keyword VARYING from the variable declaration. If you want to declare a PIC N VARCHAR variable, specify the precompiler option VARCHAR=YES and declare the variable as an implicit VARCHAR group item as illustrated by the following example: EXEC SQL BEGIN DECLARE SECTION END-EXEC. ... 01 ENAME. 05 ENAME-LEN PIC S9(4) COMP. 05 ENAME-ARR PIC N(20). ... EXEC SQL END DECLARE SECTION END-EXEC.
PCC-01015: Cannot equivalence PIC N variable string
Cause: A PIC N variable or an implicit VARCHAR group item (with a PIC N variable as an elementary item) was used in an EXEC SQL VAR statement. This is not allowed.
Action: Do not use the PIC N variable in an EXEC SQL VAR statement. If you want an equivalence to an Oracle type using an EXEC SQL VAR statement, use a PIC X variable, instead of a PIC N variable.
PCC-01016: "N" character literals not supported in embedded PL/SQL
Cause: An "N" character literal was used within a PL/SQL block
Action: Remove the "N" character literal from the PL/SQL block.
PCC-01017: The SQLCA and a SQLCODE variable cannot both be used
Cause: The SQLCA has been included and a SQLCODE variable has been declared. This is not allowed as references to the SQLCODE variable are ambiguous and will result in COBOL compiler errors.
Action: Use either the SQLCA or the SQLCODE variable. Remove either the include of the SQLCA or the SQLCODE variable declaration.
PCC-01018: Conversion buffer size can only be specified for character types
Cause: A CONVBUFSZ clause has been used in an EXEC SQL VAR statement where the variable is not of a character datatype.
Action: Remove the CONVBUFSZ clause from the EXEC SQL VAR statement.
PCC-01019: Invalid conversion buffer size
Cause: The size specified in a CONVBUFSZ clause must be an integer in the range 1-32765. Either the size given is not an integer or is outside the required range.
Action: Specify an integer in the range 1-32765.
PCC-01100: You are not authorized to run Pro*FORTRAN
Cause: The authorization or license to run the Pro*FORTRAN Precompiler has expired.
Action: Call customer support for assistance.
PCC-01101: Your Pro*FORTRAN authorization is about to expire
Cause: The authorization or license to run the Pro*FORTRAN Precompiler is about to expire.
Action: Call customer support for assistance.
PCC-01102: Invalid label at line number in file string
Cause: The Pro*FORTRAN Precompiler found an invalid FORTRAN statement label in columns 1 through 6.
Action: Correct or remove the statement label.
PCC-01200: You are not authorized to run Pro*C
Cause: The authorization or license to run the Pro*C Precompiler has expired.
Action: Call customer support for assistance.
PCC-01201: Your Pro*C authorization is about to expire
Cause: The authorization or license to run the Pro*C Precompiler is about to expire.
Action: Call customer support for assistance.
PCC-01202: Identifier "string" truncated to 31 characters
Cause: A host identifier (the name of a host variable, for example) was truncated to the maximum length (31 characters) allowed by the precompiler.
Action: No action required. This message is just informational.
PCC-01300: You are not authorized to run Pro*PL/I
Cause: The authorization or license to run the Pro*PL/I Precompiler has expired.
Action: Call customer support for assistance.
PCC-01301: Your Pro*PL/I authorization is about to expire
Cause: The authorization or license to run the Pro*PL/I Precompiler is about to expire.
Action: Call customer support for assistance.
PCC-01400: You are not authorized to run Pro*Pascal
Cause: The authorization or license to run the Pro*Pascal Precompiler has expired.
Action: Call customer support for assistance.
PCC-01401: Your Pro*Pascal authorization is about to expire
Cause: The authorization or license to run the Pro*Pascal Precompiler is about to expire.
Action: Call customer support for assistance.
PCC-01500: You are not authorized to run Pro*Ada
Cause: The authorization or license to run the Pro*Ada Precompiler has expired.
Action: Call customer support for assistance.
PCC-01501: Your Pro*Ada authorization is about to expire
Cause: The authorization or license to run the Pro*Ada Precompiler is about to expire.
Action: Call customer support for assistance.
PCC-01510: No Package, Procedure or Function statement seen in string
Cause: Every Ada source file must have a package, procedure, or function statement. The precompiler did not find one.
Action: Add the appropriate statement(s) to the source file and rerun Pro*Ada.
PCC-01511: Identifier on line number in file string too long for code generated in file string
Cause: An identifier used in the host program is of a length that causes precompiler-generated code to exceed the length limitation on source lines.
Action: Use a shorter identifier or use the ORECLEN option to increase the allowed line length.
PCC-01512: Invalid EXEC SQL INCLUDE of file string found at line number in file string
Cause: The EXEC SQL INCLUDE statement is not allowed in Pro*Ada.
Action: Embed required source text directly in the Pro*Ada file. Use the "with" context clause to include required packages.
PCC-01513: FIPS warning: Unsupported datatype in line number of file string
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a host variable was declared with a non-ANSI/ISO standard type.
Action: No action required. However, for ANSI/ISO compliance, use only ANSI/ISO standard types.
PCC-01515: FIPS warning: Undeclared host variable "string" at line number in file string
Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a host variable was declared outside of a Declare Section.
Action: No action required. However, for ANSI/ISO compliance, declare the host variable within a Declare Section.


56 PCC-02010 to PCC-02451

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

56 PCC-02010 to PCC-02451

PCC-02010: found end-of-file while scanning string literal
Cause: A string in a SQL statement, which should be delimited by single quotation marks, was not terminated properly.
Action: Check that all strings are delimited.
PCC-02011: found identifier greater than 128 characters (truncated)
Cause: The precompiler found an identifier that was too long.
Action: Shorten the identifier. SQL identifiers should be limited to 18 characters.
PCC-02012: did not find matching quote for char constant
Cause: A character constant with a single quotation mark was not terminated.
Action: Terminate the character constant.
PCC-02013: unknown escape sequence
Cause: The precompiler found an escape sequence that it could not process inside a string literal. This error can arise when multibyte character strings that can contain shift-in or shift-out escape sequences are used.
Action: Correct the string representation.
PCC-02014: Syntax error at line number, column number, file string:
Cause: The precompiler detected an errorin C or embedded SQL syntax. This message is followd by a more specific error message.
Action: Correct the syntax error.
PCC-02015: unable to open include file
Cause: The precompiler could not open a header file that was specified using the #include preprocessor directive or the EXEC SQL INCLUDE statement. This can happen if the file specification is inaccurate or if read permission or read access rights on the file or on one or more of the directories in the path were not granted.
Action: Recheck that the file specification is correct, that the file exists, and that read permission has been granted so that the file can be read.
PCC-02016: include file pathname is too long
Cause: The pathname for include files exceeded the maximum length of 80 characters.
Action: Move the include file, or create an environment variable or logical to shorten the pathname.
PCC-02017: unable to open output file
Cause: The precompiler could not open an output file. This could be a generated code output file(.c file) or a listing file. This message can result from many causes. For example: o) A pathname for a specified output file contains a non-exixtent directory. o) An operating-system error occured because the file system or disk is full. o) Write permission on the specified directory or directories in the path do not exist.
Action: Track down the cause of the error, as suggested above, and correct it.
PCC-02018: found end-of-file while scanning comment
Cause: A C comment either in C code or in an embedded SQL statement, was not terminated.
Action: Find the unterminated comment and terminate it with */ .
PCC-02019: Preprocessor warning at line number, column number, file string:
Cause: This message indicates that a warning condition occured as the precompiler was doing the preprocessor pass. A more specific warning message will follow this message.
Action: Correct the condition according to the action specified for the message that follows.
PCC-02020: Preprocessor error at line number, column number, file string:
Cause: This message indicates that an error condition occured as the precompiler was in the preprocessing phase. A more specific error message will follow this message.
Action: Correct the error according to the action specified for the message that follows.
PCC-02021: Found newline while scanning string literal
Cause: A string constant contains a newline character, For example char x[] = "Hello world";
Action: Remove the newline character.
PCC-02022: Found end of file while scanning a SQL statement
Cause: The precompiler encountered an end of file while parsing an EXEC SQL statement.
Action: Add statement terminator(;) or complete the EXEC SQL statement.
PCC-02023: Found end of file while scanning a PL/SQL statement
Cause: The precompiler encountered an end of file while parsing a PL/SQL statement (EXEC SQL EXECUTE ...).
Action: Complete the PL/SQL statement.
PCC-02035: CMD-LINE: CONFIG= option is invalid in a config file
Cause: A user configuration file inside a user configuration file cannot be specified. That is, nested configuration files cannot be nested.
Action: If there are nested configuration files, move the options from the nested files to the top levels.
PCC-02040: CMD-LINE: Option selected, but no value provided
Cause: An option on the command line was specified, but a value for it was not included. For example, the offending code might look like: proc iname=sample1.pc oname=
Action: Provide a value for the option.
PCC-02041: CMD-LINE: Option does not exist:
Cause: A non existent option on the command line was specified.
Action: See the Programmer's Guide to the Oracle Precompilers, Release 2.2 for a list of the valid command line options and their possible values.
PCC-02043: CMD-LINE: Option syntax is incorrect
Cause: A value for a command line option was incorrectly specified.
Action: See the Programmer's Guide to the Oracle Precompilers, Release 2.2 for the correct syntax for specifying command line option values.
PCC-02044: CMD-LINE: Illegal or out of range value for option:
Cause: A value specified for a command line option was not within the accepted range. For example,, the range for the MAXOPENCURSORS option is 5 to 256. If a value outside the range is specified, the message is triggered.
Action: See the Programmer's Guide to the Oracle Precompilers for the ranges that option values can take.
PCC-02045: CMD-LINE: Option is not unique:
Cause: An option name was partially specified on the command line that made it non unique. For example, % proc in=t.pc the "in" option can imply either the INAME or INCLUDE option.
Action: Provide sufficient characters on the command line to make the option name unique.
PCC-02046: CMD-LINE: Unable to open config file:
Cause: A non-existent user configuration file was specified on the command line with the config option.
Action: Provide a valid filename for the configuration file.
PCC-02047: CMD-LINE: Option is not allowed inline:
Cause: An option was entered inline that can only be entered on the command line or in a configuration file. For example, the offending code might look like EXEC ORACLE OPTION (NLS_CHAR=<name>); The NLS_CHAR option can only be entered on the command line or in a configuration file.
Action: Remove the option from the source file, and specify it on the command line.
PCC-02066: CMD-LINE: Could not find or could not open system config file
Cause: The system configuration file has a standard name (pmscfg.h) and a location that is operating system dependent. On UNIX systems, it is located in the ORACLE_HOME/proc directory. If a file named pmscfg.h is not found in the standard location, this warning message is issued.
Action: Create a system configuration file in the standard location. The file can be empty. See also the operating system specific Oracle documentation.
PCC-02081: CMD-LINE: Unterminated option value list or value list was truncated.
Cause: An option that takes a list of values was entered. The value list did not have a closing parenthesis. This error may also occur if the list of values entered on a single line was too long and Pro*C truncated it.
Action: Ensure that all value lists are terminated with a closing parenthesis. Split long value lists into individual entries.
PCC-02100: Unable to initialize PL/SQL
Cause: The precompiler connected to Oracle but could not invoke the PL/SQL engine. This error can result if an earlier release of Oracle7 is used without the Procedural Option.
Action: To use PL/SQL, upgrade to a more recent release of Oracle7.
PCC-02101: Unable to open input file
Cause: The precompiler could not open the input file. This is the .pc file specified in the INAME=option. This means that the file does not exist, that a directory was incorrectly specified in the pathname, or that the person running the precompiler does not have read permission for the file. This message could also result from operating-system errors. For example, an unmounted file system or disk I/O errors, could trigger this error.
Action: Check that permission to read the file exists and that the full pathname has been specified correctly. Check for operating- system problems. See also the operating system-specific Oracle documentation.
PCC-02102: Fatal error while doing C preprocessing
Cause: The precompiler issues this message after a more specific message.
Action: Correct the problem specified in the previous message or messages.
PCC-02103: Password:
Cause: The username was specified on the command line without a password. For example, proc sqlcheck=full iname=sample1.pc userid=scott
Action: Re-enter the command line, and include the password or specify the password when prompted.
PCC-02104: Unable to connect to Oracle
Cause: The precompiler could not connect to Oracle with the username, password, and, if applicable, database link that was supplied. Note that this is a precompiler message, not a runtime message. This means that the USERID option value, either on the command line or in a configuration file, was incorrect.
Action: Check that the username and password are current and correct. Run SQL*DBA or SQL*PLUS and verify that connection can be made using that username and password.
PCC-02105: Unable to open list file
Cause: The precompiler could not open the listing file. This message can result from many causes. For example, o) A pathname for a specified listing file contains a non-existent directory. o) An operating-system error occured because the file system or disk is full. o) Write permission on the specified directory has not been granted.
Action: Track down the cause of the error, as suggested above, and correct it.
PCC-02106: Userid only used when SQLCHECK = FULL, userid ignored.
Cause: The USERID option was specified on the command line, but SQLCHECK was not equal to FULL or SEMANTICS. The USERID has no effect, unless SQLCHECK=FULL or SQLCHECK=SEMANTICS.
Action: This is a warning message only.
PCC-02107: You may not specify PARSE = FULL when CODE = CPP
Cause: The PARSE=FULL and CODE=CPP options were both specified on the command line. The PARSE=FULL option invokes the C parser which does not understand any C++ constructs generated by the precompiler with CODE=CPP option.
Action: Set the PARSE option to either NONE or PARTIAL if the CODE=CPP option is specified.
PCC-02108: UNSAFE_NULL=YES allowed if MODE=ORACLE and DBMS=V7 or V8
Cause: UNSAFE_NULL=YES was specified on the command line, but but either the MODE was not ORACLE or the DBMS was not V7 or V8.
Action: Specify MODE=ORACLE and DBMS=V7 or V8 when using UNSAFE_NULL=YES.
PCC-02109: SQLCHECK=NONE is no longer supported.. using SYNTAX
Cause: SQLCHECK=NONE was specified on the command line but is no longer a supported option. SQLCHECK=SYNTAX was used instead.
Action: This is a warning message only. To avoid this warning, specify SQLCHECK=SYNTAX or SQLCHECK=SEMANTICS.
PCC-02110: DBMS=V6_CHAR is deprecated. Use CHAR_MAP=VARCHAR2, DBMS=V7 instead
Cause: DBMS=V6_CHAR was specified on the command line but is no longer a supported option. The options CHAR_MAP=VARCHAR2 and DBMS=V7 were used instead.
Action: This is a warning message only. To avoid this warning, specify CHAR_MAP=VARCHAR2 and, if required, DBMS=V7.
PCC-02111: CHAR_MAP option ignored. Only CHAR_MAP=VARCHAR2 allowed for DBMS=V6
Cause: DBMS=V6 was specified, and CHAR_MAP was specified with a value other than VARCHAR2. The CHAR_MAP value is ignored.
Action: This is a warning message only. To avoid this warning, specify a DBMS value other than DBMS=V6 or use CHAR_MAP=VARCHAR2.
PCC-02112: OBJECTS option ignored. OBJECTS=YES is not allowed for DBMS=V6 or V7.
Cause: OBJECTS=YES was specified on the Pro*C command line, but the DBMS option value was not valid.
Action: This is a warning message only. To avoid this warning for OBJECTS=YES, use DBMS=V8 or DBMS=NATIVE with a V8 database.
PCC-02113: DBMS=V6 no longer supported; using DBMS=NATIVE, CHAR_MAP=VARCHAR2.
Cause: DBMS=V6 was specified on the command line, but is no longer a supported option value. The options DBMS=NATIVE and CHAR_MAP=VARCHAR2 were used instead.
Action: Check your program to verify that you are not depending on any V6 behavior. Please refer to the Programmer's Guide to the Pro*C/C++ Precompiler for effects of specifying DBMS=V6.
PCC-02114: Command line argument MODE=ANSI may not be used with DBMS=V6
Cause: The semantics of certain operations (such as character comparison) in Oracle version ^ are not 100% compliant with the ANSI/ISO SQL standards. When V6 semantics are requested, using the DBMS=V6 or DBMS=V6_CHAR option, precompilation with MODE=ANSI is not permitted.
Action: Do not use ANSI mode with V6 options.
PCC-02115: Unable to open output file for writing
Cause: An attempt was made to precompile a header file where the output data file could not be opened (or created) for writing.
Action: Check for appropriate permissions on the directory and possibly file objects (if a data file already exists) to make sure that write permissions have been granted.
PCC-02116: You must specify a file extension using the HEADER option
Cause: An attempt was made to precompile a header file without specifying the name of the extension to use when creating the generated data file.
Action: Use the HEADER option to specify the name of a file extension to use when creating a data file for a precompiled header.
PCC-02129: CMD-LINE: Client supplied static options table is invalid
Cause: This is an internal error message not usually issued.
Action: Call Oracle customer support.
PCC-02132: CMD-LINE: Could not allocate memory
Cause: This is an internal error message not usually issued.
Action: Call Oracle customer support.
PCC-02133: CMD-LINE: Error in string processing function
Cause: This is an internal error message not usually issued. It indicates that a C string function, such as strcpy or strlen, returned an error.
Action: Call Oracle customer support.
PCC-02134: CMD-LINE: Null option supplied
Cause: A zero length option was specified on the command line.
Action: Re-enter the command line with a valid option.
PCC-02135: CMD-LINE: User asked for help
Cause: This is a final message that the precompiler issues when information about the command line options has been requested. For example, if the command proc ? is issued to get a list of current default values for the command line options, this message appears at the end of the list.
Action: No action required.
PCC-02138: CMD-LINE: Internal consistency error
Cause: This is an internal message for program exceptions. An unexpected condition was encountered by the command-line processor and a consistency check failed. Some possible causes of this message include: --invalid command-line options --memory corruption
Action: Report this error to Worldwide Support after gathering the following information: --the events that led to the error --the attempted operations that led to the error --any unusual circumstances prior to this error
PCC-02144: CMD-LINE: Blank characters are not allowed on either side of an equal sign (=)
Cause: An equal sign (=) was either immediately preceded or followed by a blank character.
Action: Precompile your program again without blank characters on either side of any equal sign (=) on the command line.
PCC-02150: Error at line number, column number in file string
Cause: An error was encounter at the given location.
Action: Check the named source file and correct the error using the additional information which follows this error message.
PCC-02151: Line number column number file string:
Cause: An error was encounter at the given location.
Action: Check the listed source file and correct the error using the additional information which follows this error message.
PCC-02152: Unable to open file string to display or list the source line number
Cause: The file contains an error, but could not be reopened to list or display the incorrect line.
Action: Check that the file is intact and it has read permission. Then rerun the operation.
PCC-02153: Open file: string
Cause: A new source file was opened while producing the list file.
Action: No action required; this is an informational message.
PCC-02154: Close file: string
Cause: A source file was closed while producing the list file.
Action: No action required; this is an informational message.
PCC-02200: found unrecognized punctuation sequence
Cause: The error indicates that the precompiler parser encountered a badly-formed identifier or keyword.
Action: Correct the syntax.
PCC-02201: Found syntax error
Cause: This general message precedes one or more specific messages that detail the nature of the error.
Action: No action required. Correct the errors diagnosed in the following message(s).
PCC-02202: No typedef name was given
Cause: The precompiler parser encountered a typedef statement that had no name after the type specification. For example, typedef int;
Action: Correct the syntax
PCC-02203: found end of file when not expected
Cause: The parser can emit this message when a general syntax error occurs, for example, an unmatched '{' or '('.
Action: Correct the syntax.
PCC-02204: EXEC SQL INCLUDE not permitted from within an included file
Cause: EXEC SQL INCLUDE statements cannot be nested. Also, EXEC SQL INCLUDE statement cannot be put inside a file that is included using the #include preprocessor command.
Action: Recode the program so that the nested include statement is not required.
PCC-02205: Parser error at line number, column number, file string:
Cause: The precompiler parser encountered a syntax error, either in C code or in SQL code. A more specific message should follow.
Action: for any following messages.
PCC-02206: Host variables are not permitted within a DDL statement
Cause: A Data Definition Language statement cannot use host variables. For example, the statement CREATE TABLE :table_name (c1 char(10)); is illegal, because the name of the table in a CREATE TABLE statement cannot be represented using host variable.
Action: Use dynamic SQL to create the names of database objects (tables, views, columns, etc.) at runtime. See the Programmer's Guide to the Oracle Precompilers, Release2.2 for information about dynamic SQL.
PCC-02207: Invalid macro name
Cause: The precompiler parser encountered a #define directive that had no macro name associated with it. For example, #define
Action: Correct the syntax.
PCC-02208: No filename specified in #include statement
Cause: The precompiler parser encountered a #include directive that had no filename associated with it. For example, #include
Action: Specify appropriate filename with the #include directive, or correct the syntax.
PCC-02209: Macro invocation has incorrect number of arguments
Cause: A macro invocation in the source does not have the same number of arguments as the macro definition in the #define line.
Action: Correct the macro reference or the macro definition.
PCC-02210: C++ punctuation sequences are not permitted
Cause: C++ punctuation sequences are not supported by the ProC/C++ precompiler.
Action: Rewrite your C++ code without using punctuation sequences and precompile it again.
PCC-02301: cannot reopen input file for reading
Cause: The semantic analysis phase of the precompiler could not reopen the input file to generate the output code.
Action: Check that the input file and it's directory protection and priveleges do not change during precompilation.
PCC-02302: cannot open code generation output file "string"
Cause: Pro*C was unable to open one or both temporary files required for code generation. The user executing the precompiler must have write permission (and/or the appropriate privileges) on the current directory.
Action: Check that permission exists to create files in the the directory where you precompile.
PCC-02303: cannot open include file
Cause: The precompiler was not able to open a header file specified using the #INCLUDE preprocessor directive or the EXEC SQL INCLUDE statement. This can happen if the file specification is inaccurate or if read permission or read-access rights on the file or on one or more of the directories in the path have not been granted.
Action: Recheck that the file specification is correct, that the file exists, and that read permission has been granted so that the file can be read.
PCC-02304: invalid declaration of C function
Cause: A C function using invalid syntax was declared.
Action: Consult a C programming manual and correct the declaration.
PCC-02305: illegal mixing of new and old style C function declarations
Cause: All C functions using either the traditional style (K&R style) function declarations or the new (ANSI) style must be declared; the two styles cannot be mixed.
Action: Adopt a consist declaration style for functions.
PCC-02306: illegal name of C function
Cause: A C function was declared with a name that is not a legal C identifier.
Action: Use legal C identifiers for all function names.
PCC-02307: void can only be used when single parameter
Cause: A function can be declared or defined using the following syntax: int func1(void) to indicate that the function has no parameters. void can be used only once in this case.
Action: Remove the extra voids in the function definition or declaration.
PCC-02308: identifier required in this function declaration
Cause: A function definition written in ANSI C must have both the name and the type for all parameters.
Action: Rewrite the function definition so that it contains the name of each parameter.
PCC-02309: illegal formal parameter declaration
Cause: A formal parameter to a function was specified without giving its type.
Action: Rewrite the function declaration and include types of all parameters in function declarations.
PCC-02310: formal parameter VARCHARs should be declared as pointers
Cause: Many C compilers allow structures to be passed to and returned from functions. Although a VARCHAR is implemented as a C struct, VARCHARs must be passed to a function as pointers.
Action: Take the address of a VARCHAR when it is passed to a function. See the example in the section "Referencing VARCHAR Variables" in the Programmer's Guide to the Oracle Precompilers.
PCC-02311: cannot have VARCHAR bit fields
Cause: Host variables cannot contain bit fields.
Action: Recode the application to remove the bit fields.
PCC-02312: arrays of VARCHAR greater than 2 dimensions not allowed
Cause: A VARCHAR variable having more that 2 dimensions was declared. Multidimensional arrays are not supported as host variables.
Action: Recode the application to remove multidimensional array usage.
PCC-02313: malformed VARCHAR declaration - missing length
Cause: When a VARCHAR is declared, a length specification is mandatory. For example, the following VARCHAR declaration is meaningless, hence illegal: VARCHAR v1[];
Action: Specify the length for each declared VARCHAR.
PCC-02314: cannot evaluate constant sizeof expression
Cause: A SIZEOF operator was used where a precompiler expression was expected. For example, as the length of a varchar.
Action: Eliminate the SIZEOF operator in this instance.
PCC-02315: cannot evaluate expression as constant
Cause: The specified expression does not evaluate to a constant. Such expressions are required, for example, as the length of a VARCHAR.
Action: Replace the expression with one that does evaluate to a constant integer.
PCC-02316: illegal operator in constant expression
Cause: A non-arithmetic operator was present in a constant expression.
Action: Rewrite the expression to eliminate the non-arithmetic operator.
PCC-02317: illegal cast type expression
Cause: An illegal cast is present in the expression.
Action: Remove the illegal cast.
PCC-02318: missing type expression
Cause: The specified expression is missing the declaration of a type.
Action: Specify a type for the expression.
PCC-02319: expression type does not match usage
Cause: The type of a variable does not match is usage. For example, in dynamic SQL, a host variable containing the text of a SQL statement must be declared as a C character type or be equivalenced to the SQL type STRING.
Action: Remove the declaration.
PCC-02320: arithmetic expression does not have correct operand types
Cause: The arithmetic expression must be specified with integral types.
Action: Rewrite the expression using integral types.
PCC-02321: only subtraction between two pointers is permitted
Cause: Pointer values cannot be added, multiplied, or divided. The only arithmetic operation permitted with pointers is subtraction.
Action: Recode to avoid this error message.
PCC-02322: found undefined identifier
Cause: An identifier used in a SQL statement was not defined. For example, a cursor name was referenced that had not been declared, or in a DECLARE CURSOR statement, a statement name was used that had not been PREPAREd.
Action: Provide a declaration for the variable and/or its type identifier.
PCC-02323: found typedef name used in an expression (expecting a value)
Cause: The name of a typedef was found where a variable was expected.
Action: Rewrite the expression and remove the reference to the typedef.
PCC-02324: found variable name used as a typedef name
Cause: The name of a variable was found where a typedef was expected.
Action: Rewrite the expression and specify the correct typedef reference.
PCC-02325: illegal indirection operation
Cause: An attempt was made to use a non-pointer type as a pointer.
Action: Rewrite the expression.
PCC-02326: illegal structure reference operation
Cause: A structure component using invalid syntax was referenced. For example, a -> operator was used instead of a required `.' operator.
Action: Correct the invalid reference.
PCC-02327: struct or struct pointer required
Cause: A scalar host variable was used in a context where a structure (or its pointer) is required.
Action: Make the host variable a structure or add more scalar host variables to satisfy the SQL syntax requirements.
PCC-02328: undefined struct member
Cause: A structure component was referenced that was not declared as part of the structure.
Action: Redefine the structure member.
PCC-02329: found reference to undeclared function
Cause: A function was referenced that was not declared. All function references must be declared.
Action: Declare the function.
PCC-02330: expecting an expression of integer type
Cause: The expression does not evaluate to an integer. For example, a SQL FOR expression must evaluate to an integral type.
Action: Rewrite the expression.
PCC-02331: undefined SQL identifier
Cause: All SQL identifiers must be declared before they are used. This message can result when a CURSOR or STATEMENT is not declared (defined) before being referenced.
Action: Define the SQL identifier before it is used.
PCC-02332: attempted to redefine SQL identifier
Cause: A SQL identifier (such as a cursor name) can be defined only once.
Action: Do not redefine the SQL identifier.Use a different name.
PCC-02333: SQL identifier was not declared as a statement
Cause: A SQL statement identifier was referenced in a DECLARE... CURSOR statement that was not PREPAREd.
Action: Check that all SQL statement names have been declared. Remember that SQL statement names are identifiers, not variables, and that they are local to the precompilation unit.
PCC-02334: SQL identifier was not declared as a cursor
Cause: A cursor name was used in an OPEN, FETCH, or CLOSE statement that had not been DECLAREd.
Action: Check that all SQL cursor names have been declared. Remember that cursors are identifiers, not variables, and that they are local to the precompilation unit.
PCC-02335: body of cursor must name statement identifier
Cause: In a Dynamic SQL Method 4 application, the DECLARE... CURSOR statement must name a statement identifier that has been PREPAREd in a preceding statement. The PREPARE statement must physically (not logically) precede the DECLARE command.
Action: This error message is followed by another message that gives the line and column of the reference to the statement. Recode the application.
PCC-02336: host variable expression has invalid type
Cause: The host variable was declared using a C type that is not permitted as a host variable. See the Programmer's Guide to the Oracle Precompilers for a list of the permissible C types for host variables.
Action: Use a permissible host variable type.
PCC-02337: cannot declare multi-dimensioned array for this type
Cause: Host variable arrays of scalars with more than 1 dimension cannot be declared.The only host variables allowed to be multi-dimensioned are CHAR and VARCHAR.
Action: Rewrite the variable declaration.
PCC-02338: structure contains a nested struct or union
Cause: A structure used as a host variable may not have structures or unions nested within it.
Action: Rewrite the variable declaration.
PCC-02339: host variables cannot be of union types
Cause: A C union as a host variable cannot be used.
Action: This error message is followed by another message that gives the line and column of the reference to the illegal union. Recode, using a struct or individual scalar host variables.
PCC-02340: structure contains a bit field
Cause: Bit fields are not allowed in host variables because they are meaningless for database DML operations.
Action: This error message is followed by another message that gives the line and column of the reference to the offending host variable. Recode the application.
PCC-02341: host variable has illegal type
Cause: A host variable has an unpermitted type (i.e.; enum, void, etc).
Action: Rewrite the host variable declaration, using a permissible host variable type.
PCC-02342: using WHERE CURRENT OF on cursor defined without FOR UPDATE clause
Cause: When MODE=Oracle, a cursor defined with a WHERE CURRENT OF clause must also have a FOR UPDATE clause.
Action: Rewrite the cursor definition.
PCC-02343: body of cursor must be a query expression
Cause: A cursor definition must be a SELECT statement.
Action: Rewrite the cursor definition.
PCC-02344: Host variable array size mismatch. Using minimum: number
Cause: Host variable arrays in a single statement should all be of equal size.
Action: Redefine the bind variable array lengths to all be the same size.
PCC-02345: SQLCHECK=SEMANTICS must be given when embedded PL/SQL blocks are used
Cause: Embedded PL/SQL blocks require that the command-line flag SQLCHECK=SEMANTICS is used.
Action: Use the SQLCHECK=SEMANTICS option. This also requires that the USERID connect option be given.
PCC-02346: PL/SQL found semantic errors
Cause: A database entity, such as a table or column name, was referenced, that does not exist. This is a compile time error, not a runtime error.
Action: Check that all referenced objects in PL/SQL statements actually exist and that the necessary access permission on them have been granted.
PCC-02347: PL/SQL found syntax errors
Cause: A PL/SQL statement was used illegally.
Action: Check the PL/SQL User's Guide and Reference for the correct syntax.
PCC-02348: indicators are not allowed in EXEC IAF statements
Cause: Indicator variables associated with host variables cannot be used in EXECIAF statements such as GET and PUT in a user exit.
Action: Eliminate the indicator variabls. If feasible (for example with Forms V4), use EXEC TOOLS statements, which do allow indicator variables. See the Programmer's Guide to the Oracle Precompilers for more information of EXECIAF and EXEC TOOLS statements.
PCC-02349: precision must be specified for this type
Cause: In a VAR or TYPE statement, certain Oracle types require that the precision be specified. For example, VARCHAR2 or CHAR.
Action: Indicate the precision.
PCC-02350: cannot equivalence this SQL type
Cause: Datatype or variable equivalencing to the datatypes NUMBER or DECIMAL cannot be used. See the "Datatype Equivalencing" section in the Programmer's Guide to the Oracle Precompilers for more information.
Action: Use the appropriate datatype for the application.
PCC-02351: illegal datatype equivalencing operation
Cause: The datatype specified could not be equivalenced, or the syntax was incorrect in the VAR or TYPE statement.
Action: See the Programmer's Guide to the Oracle Precompilers for a list of the datatypes that can be equivalenced and the correct syntax of the VAR or TYPE statement.
PCC-02352: out of bounds bind position from PL/SQL
Cause: PL/SQL requested a bind position that does not exist.
Action: Contact ORACLE customer support.
PCC-02353: Semantic error at line number, column number, file string:
Cause: This error message precedes a more specific error message.
Action: No action required. Correct the error(s) reported in the following message(s).
PCC-02354: A file included with #include may not contain SQL statements
Cause: The Pro*C Precompiler reads header files referenced in #INCLUDE directives and uses the values defined in them. But the precompiler never generates code using statements in header files, so use of SQL statements in these files is illegal.
Action: Move the SQL statement(s) into the main body of the application or use EXEC SQL INCLUDE to check that the included file is precompiled.
PCC-02355: Invalid or obsolete option, ignored
Cause: A command-line option that is not used in Pro*C Release 2.0 was specified. For example, the option AREASIZE is no longer valid with precompilers used with the Oracle7 Server.
Action: No action required. This is an informational message.
PCC-02356: Warning at line number, column number, file string:
Cause: This is a generic warning message. It precedes a more specific warning.
Action: No action required. Correct the error(s) indicated in the following message(s).
PCC-02357: Function calls may not be used as host variable expressions
Cause: Only objects that are lvalues (that resolve to an address) can be host variables. Because a function call is not an lvalue, one cannot be used in place of a host variable.
Action: Recode the application.
PCC-02358: Identifier following ARRAYLEN must be the name of an array
Cause: A declared array must be specified as the argument for an ARRAYLEN statement. Declare the array textually before the ARRAYLEN statement. See the Programmer's Guide to the Oracle Precompilers for the syntax of the ARRAYLEN statement.
Action: Correct the statement, specifying a host array as the argument.
PCC-02359: Identifier specifying ARRAYLEN must be a 4-byte integer
Cause: The expression that specifies the ARRAYLEN dimension must evaluate to an integer. For example, the statement EXEC SQL ARRAYLEN my_array(1,3) cannot be parsed.
Action: Correct the statement, using an integral dimesnsion.
PCC-02360: This array type is invalid for use with ARRAYLEN statement
Cause: Arrays of some host variables types are not allowed and hence also cannot be used in ARRAYLEN statements. VARCHAR and DATE are examples.
Action: Specify an array with a datatype that can be used in host arrays.
PCC-02361: Use of ARRAYLEN with SQL bind arrays is ignored
Cause: ARRAYLEN is only valid with arrays that can be bound in PL/SQL blocks.
Action: Use an appropriate array type.
PCC-02362: Host variable not declared within SQL DECLARE section
Cause: When MODE=ANSI is specified at precompile time, all host variables must be declared inside Declare Sections. Remember that MODE=ANSI refers to ANSI SQL, not ANSI C.
Action: Add the EXEC SQL BEGIN DECLARE SECTION... EXEC SQL END DECLARE SECTION statements around all host variable declarations.
PCC-02363: Indicator variable must be a structure
Cause: If a host variable is a structure, the associated indicator variable must also be a structure.
Action: Recode the application to create an indicator variable as a structure.
PCC-02364: Host struct and its indicator must have the same number of fields
Cause: When a structure containing indicator variables is declared and associated with a host structure, the indicator structure must contain the same number of fields as the host structure. This is so even when some of the indicators will not be used or even when it would not make sense to do so (for fields constrained as NON NULL, for example).
Action: Redeclare the indicator variable with the correct number of fields.
PCC-02365: Indicator array size cannot be smaller than host array size
Cause: An indicator array must have dimension greater than or equal to the corresponding host variable array dimension.
Action: Change the dimension of the indicator array.
PCC-02366: Command line argument MODE=ANSI may not be used with DBMS=V6
Cause: The semantics of certain operations (such as character comparison) in Oracle version ^ are not 100% compliant with the ANSI/ISO SQL standards. When V6 semantics are requested, using the DBMS=V6 or DBMS=V6_CHAR option, precompilation with MODE=ANSI is not permitted.
Action: Do not use ANSI mode with V6 options.
PCC-02367: This indicator variable must be declared as type short
Cause: An indicator for a host variable of this type must have the C type short. An array of such indicators must be an array of shorts.
Action: Declare the indicator variable or indicator array as type short.
PCC-02368: An EXEC TOOLS host variable context name is not type char
Cause: If a host variable is used to define a context name in an EXEC TOOLS GET CONTEXT or EXEC TOOLS SET CONTEXT statement, that host variable must be of a character type.
Action: Redeclare the context name to a host variable of a char type.
PCC-02369: An EXEC TOOLS host pointer variable is not a pointer
Cause: The host variable specifying an EXEC TOOLS context must be a pointer type.
Action: Redeclare the variable, making sure that it is a pointer.
PCC-02370: An EXEC TOOLS MESSAGE host variable is not type char
Cause: f a host variable is used to define a context name in an EXEC TOOLS GET CONTEXT or EXEC TOOLS SET CONTEXT statement, that host variable must be of a character type.
Action: Declare the message to a host variable of a char type.
PCC-02371: Illegal FOR clause
Cause: The argument of a FOR clause must be specified as an integer or as an identifier containing an integer.
Action: Rewrite the FOR clause.
PCC-02372: FOR clause not allowed in SELECT statement
Cause: A SQL statement containing a SELECT command cannot contain a FOR clause. The meaning of such a statement would be unclear.
Action: Rephrase the SELECT statement, removing the FOR clause.
PCC-02373: Invalid declaration in EXEC SQL DECLARE section
Cause: An improper declaration was placed in a Declare Section. This message is usually caused by including an EXEC SQL TYPE or EXEC SQL VAR declaration in a Declare Section.
Action: Move the declaration outside of the SQL DECLARE section.
PCC-02374: SQLCHECK value exceeds command line value
Cause: The value given to the SQLCHECK option in an EXEC ORACLE statement in a program was greater than the value given either on the command line or greater than the default value if no SQLCHECK option was given on the command line. The order of the option values is SEMANTICS>SYNTAX>NONE. When this warning message is issued, the original value of SQLCHECK (the default or the command-line value) stays in effect.
Action: Remove or recode the EXEC Oracle option(s) in the .pc source file to avoid this warning message.
PCC-02375: SQL statement found outside the body of a function
Cause: A SQL statement other than a declarative, datatype equivalence or WHENEVER statement was found outside the body of a function when PARSE=FULL.
Action: Move the SQL statement inside the body of a function.
PCC-02376: You may not declare SQLCODE when DEF_SQLCODE = TRUE
Cause: The DEF_SQLCODE option may not be specified if a SQLCODE declaration already explicitely appears in the program.
Action: Remove the SQLCODE declaration from the program or specify DEF_SQLCODE=NO (the default).
PCC-02377: Arrays of implicit varchars are not permitted
Cause: An array of implicit VARCHARS was declared when HOST_VARCHAR=TRUE.
Action: Rewrite the implicit VARCHAR declaration without using arrays.
PCC-02378: Invalid type for National Language character variable
Cause: A variable declared as a National Language character using the NLS_CHAR option was not declared as a char or implicit VARCHAR.
Action: Declare the variable as a char or implicit VARCHAR or do not specify using the NLS_CHAR option.
PCC-02379: Cannot equivalence National Language character variables
Cause: A National Language character variable (specified using the NLS_CHAR option) has undergone datatype equivalencing using either the EXEC SQL VAR or TYPE statements.
Action: Do not equivalence National Language character variables.
PCC-02380: Cannot specify a connect mode when altering a user password
Cause: An attempt was made to connect in either SYSOPER or SYSDBA mode while at the same time trying to change passwords using the ALTER AUTHORIZATION clause in the same CONNECT statement.
Action: Changing passwords while connecting in SYSOPER or SYSDBA mode is prohibited. Rewrite the connect statement by either removing the ALTER AUTHORIZATION cluase or the CONNECT MODE clause.
PCC-02382: You must specify MODE=ANSI when using NLS_LOCAL=YES
Cause: NLS_CHAR was used to specify NLS multi-byte character variables without specifying MODE=ANSI.
Action: Specify MODE=ANSI on the command line when using NLS_LOCAL=TRUE.
PCC-02383: Expecting an expression of type OCIExtProcContext
Cause: The type of the bind variable given in a REGISTER CONNECT USING statement was not (pointer to) OCIExtProcContext.
Action: Declare a variable having type (pointer to) OCIExtProcContext and use it in the REGISTER CONNECT USING statement.
PCC-02384: Missing array length specifier
Cause: An array declaration was given without an array length specifier.
Action: Provide the length for the array declaration.
PCC-02385: CHAR_MAP disallowed when using NLS_CHAR and NLS_LOCAL=TRUE
Cause: The CHAR_MAP option was specified while indicating which host variables are to be treated by the precompiler as NLS multi-byte character variables. This mapping cannot be performed with the option NLS_LOCAL=TRUE. This error also occurs when DBMS=V6 is used in conjunction with NLS_CHAR and NLS_LOCAL=TRUE.
Action: Remove either the CHAR_MAP option or set NLS_LOCAL=FALSE. Ensure that DBMS is not set to V6.
PCC-02386: Use of the AT clause is not permitted here
Cause: An explicit AT clause was used with an ALLOCATE statement or a FETCH/CLOSE statement also using a SQL_CURSOR declaration.
Action: Remove the AT clause.
PCC-02387: Expecting an expression of type sql_cursor
Cause: A host bind variable was used in an ALLOCATE, FETCH or CLOSE statement that was not declared as a result set SQL_CURSOR.
Action: Declare the variable to be of type sql_cursor.
PCC-02388: Arrays not allowed in FROM/WHERE clause of SELECT statement
Cause: A host array was used in the WHERE clause of a SELECT-INTO statement.
Action: Rewrite the SELECT statement without using arrays or use a cursor.
PCC-02389: Arrays not allowed as input bind variables in SELECT list
Cause: A host array was used in the SELECT list of a SELECT-INTO statement.
Action: Rewrite the SELECT statement without using arrays in SELECT list.
PCC-02390: No EXEC SQL CONTEXT USE statement encountered
Cause: No EXEC SQL CONTEXT USE statement was encountered and the option threads=yes was requested.
Action: Ensure that the necessary context variable (of type sql_context) has been declared and that has been ALLOCATEd and USEd prior to any executable SQL statements.
PCC-02391: Runtime context variable not of correct type
Cause: The host variable in a EXEC SQL CONTEXT USE statement or in the RETURNING clause of a REGISTER CONNECT statement was not declared to be of type SQL_CONTEXT.
Action: Declare the runtime context variable to be of type SQL_CONTEXT.
PCC-02392: You are already in an EXEC SQL DECLARE SECTION
Cause: A SQL DECLARE SECTION appears nested inside another one.
Action: Do not nest DECLARE SECTIONS. Remove any nested inner ones.
PCC-02393: SQL statement found inside an EXEC SQL DECLARE SECTION
Cause: An executable SQL statement appears inside a DECLARE SECTION.
Action: Move the SQL statement into the body of a function.
PCC-02394: Input file name and output filename are identical
Cause: The values of INAME and ONAME are the same or the default output filename is the same as that specified by ONAME.
Action: Use ONAME to specify a different filename for the output file.
PCC-02395: Using arrays of structs requires that the struct be named
Cause: An array of some unnamed struct was used as a host variable. When using arrays of structs, the struct requires a name or tag.
Action: Provide a name for the struct.
PCC-02396: Illegal use of arrays inside an array of structs
Cause: An array of a struct that contained arrays of scalars or two-dimensional char or VARCHAR fields was used as a host variable.
Action: Rewrite the struct so that there are no scalar arrays or two-dimensional char or VARCHAR fields.
PCC-02397: VARCHAR declarations not permitted in #include file
Cause: A VARCHAR declaration was found in a file included using a #include form.
Action: Use the EXEC SQL INCLUDE form to include files with VARCHAR declarations instead.
PCC-02398: Indicator ignored in this statement for this type
Cause: An indicator variable was used in a host/indicator variable pair for some type in a statement that did not require or need one. Typically, indicator variables are not used in ALLOCATE and FREE statements for types other than object or collection types. They are also not used in OBJECT CREATE/DEREF statements for REF types.
Action: Remove the use of the indicator for the type in the specified statement. It will be ignored otherwise.
PCC-02399: Illegal CHAR_MAP option value for DBMS=V6. Option ignored.
Cause: A CHAR_MAP option other than CHAR_MAP=VARCHAR2 was specified inline. Since DBMS=V6, this option is ignored for a character or string variable in the offending statement.
Action: Either set DBMS to something other than V6, or specify CHAR_MAP=VARCHAR2.
PCC-02400: This host variable must be declared as a pointer type
Cause: The specified host variable was not declared as a pointer type.
Action: Declare the host variable to be a pointer type.
PCC-02401: Host variable arrays of this type are currently not supported
Cause: Host variable arrays of the specified type are not supported.
Action: Rewrite your program so that there are no arrays of this type.
PCC-02402: Pro*C option OBJECTS=YES is required when using the object cache
Cause: The object cache will be used for this host variable, but OBJECTS=NO was specified on the Pro*C command line.
Action: Specify OBJECTS=YES on the Pro*C command line when using the object cache.
PCC-02403: Invalid indicator variable type for this host variable
Cause: The type of the indicator variable is not appropriate for the specified host variable.
Action: Change the type of the indicator variable to a valid type. Refer to the "Programmer's Guide to the ORACLE Pro*C/C++ Precompiler" for a discussion of appropriate indicator variable declarations.
PCC-02404: This indicator variable must be declared as a pointer type
Cause: The specified indicator variable was not declared as pointer type.
Action: Declare the indicator variable to be a pointer type.
PCC-02405: Variable is of undefined type
Cause: No declaration was found for the type identifier of the variable.
Action: Provide a valid declaration for the type of the host variable. If using objects in your program, check that the OTT-generated header for the object type was #included and that the typefile was specified in the INTYPE option on the Pro*C command line.
PCC-02406: Expecting the form 'RETURN[ING] REF INTO :<ref>' only
Cause: When using the RETURNING clause in an OBJECT CREATE statement, only a single 'REF INTO :<host variable>' is expected. This error occurs if the expression list to which REF belongs is greater than one or if there are more than one host variables supplied in the into list.
Action: Rewrite the RETURNING clause as per the given specification.
PCC-02407: Object and REF types do not match
Cause: In an OBJECT CREATE or DEREF statement, the types of the given Object and its associated REF do not match.
Action: Make sure that the Object and its REF have the same type. The type information is generated by OTT and should appear in the header file which OTT creates.
PCC-02408: Expecting an expression of some Object type
Cause: The expression is not an Object type. For example, many host variable expressions in the Navigational statements require that the variable be declared of some Object type.
Action: Rewrite the expression or declare the variable to be an Object.
PCC-02409: Expecting an expression of some REF type
Cause: The expression is not a REF type. For example, some host variables in the Navigational CREATE and DEREF statements are required to be declared of some REF type.
Action: Rewrite the expression or declare the variable to be a REF.
PCC-02410: Expecting an expression of some Collection type.
Cause: The expression is not a Collection type. A VARRAY or Nested Table object was expected, but the given host variable did not resolve to a valid Collection type.
Action: Check that the OTT-generated header for the Collection type was properly #included in the Pro*C/C++ program and that the typefile was specified in the INTYPE option on the Pro*C/C++ command line.
PCC-02411: Invalid type for INDICATOR descriptor item host variable
Cause: The type of the host variable paired with the INDICATOR descriptor item was invalid. The only permissable types for the INDICATOR item are a signed 2 byte numeric type or an indicator struct generated by the Object Type Translator for a user defined object type.
Action: Either replace the INDICATOR host variable with a valid one having an acceptable type or redeclare the existing host variable to be of a valid type.
PCC-02412: FOR clause not permitted in OBJECT GET or SET statement
Cause: An explicit FOR clause was used in an OBJECT GET or OBJECT SET statement. Use of the FOR clause is illegal for these statements.
Action: Remove the FOR clause.
PCC-02413: Number of attributes does not match number of host variables
Cause: The number of attributes supplied in the attribute list of an OBJECT SET of GET statement does not match the total number of host variables also supplied in that statement.
Action: Either remove some attributes or remove some host variables from the statement in order to make the total count for each the same.
PCC-02414: This attribute does not exist in the specified Object
Cause: An attribute given in the attribute list of an OBJECT SET or GET statement is not a member of the specified object in that statement.
Action: Remove the attribute from the list.
PCC-02415: Cannot manipulate Object attributes in an OBJECT GET or SET
Cause: An attempt was made to either GET or SET an attribute of an Object that itself was an Object or REF type.
Action: Remove the attribute from the attribute list in the statement.
PCC-02416: The Object in an OBJECT GET or SET must not be an array
Cause: The Object specified in an OBJECT GET or SET statement is an array which is illegal.
Action: Redeclare the Object so that it is not an array or subscript the Object so that only a single element of the Object array is specified.
PCC-02417: Illegal type conversion between attribute and host variable
Cause: An illegal type conversion was attempted in a Navigational GET or SET statement between the type of the Attribute and the type of the Host Variable.
Action: Change the type of either the Attribute or the Host Variable.
PCC-02418: Array size mismatch between Object and REF host variables
Cause: The array sizes of the Object and REF variables in an OBJECT CREATE or DEREF do not match.
Action: Adjust the array dimensions of the two host variables so that they are equal to one another.
PCC-02419: Host variable arrays not allowed in an OBJECT SET or GET
Cause: An array was found in the host variable list of an OBJECT SET or GET statement.
Action: Only scalars are allowed (except for single dimensioned char or varchar variables) in the host variable list of an OBJECT SET or GET. Make sure to use only scalars in these statements.
PCC-02420: Incomplete (or missing) type specification
Cause: An incomplete or perhaps missing type specification was given when declaring a host variable used in some SQL statement.
Action: Provide a complete type definition when declaring host variables intended for use inside any SQL statements.
PCC-02421: This host variable requires the use of an indicator variable
Cause: No indicator variable was provided (or matched) with a specific host variable where one was explicitely required.
Action: Provide an indicator variable for use with the specified host variable in the given SQL statement.
PCC-02422: Invalid value specified for the given context option
Cause: An illegal value was given for the specified runtime context option in the CONTEXT <option> OPTION SET (or GET) statement.
Action: Use a valid option value in the statement for the specified option being manipulated by the statement.
PCC-02423: Host variable has an invalid type for this option value
Cause: The type of the host variable corresponding to a specific option value in a CONTEXT <option> OPTION SET (or GET) statement is invalid for that particular value.
Action: Use a type suitable for the specific value being manipulated.
PCC-02424: The number of values and host variables does not match
Cause: There is a mismatch between the number of values specified and the number of valid host variables given in a CONTEXT <option> OPTION SET (or GET) statement.
Action: Use the same number of host variables as there are values given in that particular statement.
PCC-02425: An indicator variable is not required with this attribute
Cause: In a LOB or Collection DESCRIBE, an Indicator Variable was used with a Host Variable when retrieving a LOB attribute that doesn't require one.
Action: Remove the Indicator Variable.
PCC-02426: Incompatible LOB types
Cause: A LOB operation was attempted between LOBs whose types were not compatible. For example, When ASSIGNing one LOB to another, both LOBs must be of the same type. If they are not, this error results.
Action: Correct the LOB operation by having it function between LOBs of the same type. This may require a redeclaration of one of the LOBs used in the LOB statement performing the specified operation.
PCC-02427: Expression is not of the correct character string type
Cause: The given host variable expression was not declared to be of the required character type. In this case, one of several possible character types would have been accepted. However, the host variable type did not match any of them.
Action: Redeclare the problematic host variable, using one of the permitted character types.
PCC-02428: Buffer type is incompatible with LOB type
Cause: This error can occur in either of the following situations

1. An attempt to READ from a LOB into a buffer whose type was not compatible with the LOB type.

2. An attempt to WRITE a buffer into a LOB whose type was not compatible with the buffer type.

Action: Either the LOB type or the buffer type needs to be changed so that the LOB and buffer types become compatible for the specified operation.
PCC-02429: Expecting an expression of some internal LOB type
Cause: The given host variable was not declared to be an Internal LOB. BLOB, CLOB or NCLOB would have been accepted, however, the type of the host variable did not match any of these.
Action: Redeclare the host variable using one of the Internal LOB types.
PCC-02430: Expecting an expression of some arbitrary LOB type
Cause: The given host variable was not declared to be any type of LOB, Internal or External. In addition to any Internal LOB type, BFILE would also have been accepted, however, the type of the host variable did not match any of these.
Action: Redeclare the host variable using any of the LOB types, Internal or External.
PCC-02431: Expecting an expression of type external LOB (BFILE)
Cause: The given host variable was not declared to be an External LOB. Only BFILE would have been accepted in this case.
Action: Redeclare the host variable using an External LOB type (BFILE).
PCC-02432: Cannot open an external LOB (BFILE) in READ WRITE mode
Cause: An attempt was made to OPEN a BFILE in READ WRITE mode. Writable BFILEs are currently not supported so this operation is considered erroneous.
Action: Do not open BFILEs using READ WRITE mode. BFILEs can only be OPENed in READ ONLY mode.
PCC-02433: Invalid host variable and attribute pairing
Cause: The host variable and attribute pairing in a LOB or Collection DESCRIBE is invalid. Most likely, this was due to some problem with the host variable. For example, this error could occur if the host variable was not declared or is otherwise not provided.
Action: Usually, other, more specific, errors will accompany this one. Correcting some or all of those problems should resolve this error.
PCC-02434: FOR clause not permitted in any LOB statement
Cause: An explicit FOR clause was used in some LOB statement. The use of the FOR clause in LOB statements is erroneous.
Action: Remove the FOR clause.
PCC-02435: This attribute is only valid for internal LOB types
Cause: A request for a LOB attribute was made in a LOB DESCRIBE statement in which the given LOB was not of some Internal LOB type.
Action: Replace the LOB host variable in the LOB DESCRIBE with one that was declared to be an Internal LOB.
PCC-02436: This attribute is only valid for external LOB types (BFILEs)
Cause: A request for a LOB attribute was made in a LOB DESCRIBE statement in which the given LOB was not an External LOB type (BFILE).
Action: Use an External LOB (BFILE) host variable in the LOB DESCRIBE statement.
PCC-02437: Expecting an expression having binary integral type
Cause: A host variable was given that was not declared to be of some acceptable binary numberic integral type. Generally, when this error occurs, a signed or unsigned integral type was expected. Floating point or otherwise imprecise numeric types are considered erroneous.
Action: Replace the problematic host variable with one that was declared using a proper exact numeric integral type.
PCC-02438: Arrays of collection objects are not allowed
Cause: An array of collections was given in a COLLECTION statement. Only scalar (non-array) collection objects are allowed in any of the COLLECTION statements.
Action: Change the declaration of the Collection host variable so that it is not an array.
PCC-02439: FOR clause not allowed in this COLLECTION statement
Cause: An illegal FOR clause was used in a COLLECTION statement that did not allow one, particularly, one of either the TRIM or DESCRIBE COLLECTION statements.
Action: Remove the FOR clause from the statement.
PCC-02440: This attribute is valid for either internal or external LOBs
Cause: A request for a LOB attribute was made in a LOB DESCRIBE statement in which the given LOB host variable was neither an Internal an External LOB (BFILE) type.
Action: Use either an Internal or External LOB host variable in the LOB DESCRIBE statement.
PCC-02441: Number of attributes does not match number of host variables
Cause: There is a mismatch between the number of attributes and the number of valid host variables in the LOB or Collection DESCRIBE.
Action: Make sure that for each attribute being requested there is at most a single valid host variable given to hold its value.
PCC-02442: Expecting a value between 1 and 65535 inclusive
Cause: The value specified in the WITH MAX clause of an ALLOCATE DESCRIPTOR statement or the VALUE clause of a GET/SET DESCRIPTOR statement was either less than 1 or greater than 65535.
Action: Specify a value between 1 and 65535 inclusive.
PCC-02443: This usage is only valid when DYNAMIC=ANSI is specified
Cause: One of the following statements was used without specifying a DYNAMIC=ANSI command line option setting

o EXEC SQL ALLOCATE/DEALLOCATE/GET/SET DESCRIPTOR

o EXEC SQL DESCRIBE OUTPUT/INPUT ... USING ... <descriptor>

o EXEC SQL EXECUTE ... INTO ...

o EXEC SQL EXECUTE ... USING ... <descriptor>

o EXEC SQL OPEN ... INTO ...

o EXEC SQL OPEN ... USING ... <descriptor>

Action: Specify DYNAMIC=ANSI or remove statements like those above from the program.
PCC-02444: Invalid combination of descriptor and non-descriptor clauses
Cause: There was a mixing of descriptor and non-descriptor clauses in an ANSI Dynamic SQL statement.
Action: Do not mix descriptors and non-descriptors in the ANSI statement in question.
PCC-02445: USING clause valid only on a PREPAREd dynamic statement
Cause: The USING clause was used with an OPEN cursor statement where the cursor declaration was not for a PREPAREd statement. The correct sequence of statements should be as follows EXEC SQL PREPARE s FROM :stmt; EXEC SQL DECLARE c CURSOR FOR s; EXEC SQL OPEN c USING ...;
Action: Use the PREPARE statement for the SQL statement and use that in the DECLARE CURSOR statement.
PCC-02446: FOR clause not allowed in a DEALLOCATE statement
Cause: An explicit FOR clause was used in a DEALLOCATE DESCRIPTOR statement.
Action: Remove the FOR clause from the statement.
PCC-02447: Cannot specify destination offset in a LOB WRITE APPEND
Cause: A destination offset was specified in a LOB WRITE APPEND statement. The destination offset is assumed to be the end of the LOB so specifying an explicit destination offset is erroneous.
Action: Remove the destination offset from the LOB WRITE APPEND statement.
PCC-02448: Cannot specify a UCS2 variable in the NLS_NCHAR option
Cause: A variable declared as utext, uvarchar, or longuvarchar was specified in the NLS_NCHAR command line option.
Action: Re-precompile without specifying the variable in an NLS_NCHAR command line option.
PCC-02449: Cannot type equivalence a UCS2 type
Cause: A UCS2 type has been type equivalenced in an EXEC SQL TYPE statement or a variable of UCS2 type has been type equivalenced in an EXEC SQL VAR statement.
Action: Remove the EXEC SQL TYPE or EXEC SQL VAR statement.
PCC-02450: Cursor was not declared in scrollable mode
Cause: A cursor which was not DECLAREd in SCROLL mode was used in scrollable mode in the FETCH statement.
Action: Declare the cursor in scroll mode using the SCROLL keyword.
PCC-02451: Value of offset cannot be negative in ABSOLUTE orientation mode
Cause: The offset for the FETCH ABSOLUTE statement is negative.
Action: Value of offset should be positive.


57 SQL-01075 to SQL-02157

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

57 SQL-01075 to SQL-02157

SQL-01075: you are currently logged on
Cause: There is already a connection on this host.
Action: Do not attempt the second connection.
SQL-02100: Out of memory (i.e., could not allocate)
Cause: SQLLIB was unable to allocate enough memory to execute the program.
Action: Allocate more memory to the user session, then rerun the program. If the error persists, call customer support for assistance.
SQL-02101: Inconsistent cursor cache. Unit cursor/global cursor mismatch
Cause: This internal error typically indicates a memory-related error.
Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.
SQL-02102: Inconsistent cursor cache. No global cursor entry.
Cause: This internal error typically indicates a memory-related error.
Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.
SQL-02103: Inconsistent cursor cache. Out of range cursor cache reference
Cause: This internal error typically indicates a memory-related error.
Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.
SQL-02104: Inconsistent host cache. No cursor cache available
Cause: This internal error typically indicates a memory-related error.
Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.
SQL-02105: Inconsistent cursor cache. Global cursor not found
Cause: This internal error typically indicates a memory-related error.
Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.
SQL-02106: Inconsistent cursor cache. Invalid Oracle cursor number
Cause: This internal error typically indicates a memory-related error.
Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.
SQL-02107: Program too old for runtime library; please re-precompile it
Cause: The program was precompiled by an older version of the Oracle Precompilers, which is incompatible with this release of SQLLIB.
Action: Precompile the program with a newer version of the Oracle Precompilers.
SQL-02108: Invalid descriptor passed to run-time library
Cause: This internal error typically indicates a memory-related error.
Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.
SQL-02109: Inconsistent host cache. Host reference is out of range
Cause: This internal error typically indicates a memory-related error.
Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.
SQL-02110: Inconsistent host cache. Invalid host cache entry type
Cause: This internal error typically indicates a memory-related error.
Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.
SQL-02111: Heap consistency error
Cause: This internal error typically indicates a memory-related error.
Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.
SQL-02112: SELECT..INTO returns too many rows
Cause: A SELECT...INTO statement returned more rows than can be stored in the host variable provided.
Action: There are 3 possible solutions:

1. Use the precompiler option select_error=no.

2. Declare a host variable with a larger array dimension.

3. Declare a cursor or cursor variable for the select statement.

SQL-02113: Unable to open message file
Cause: SQLLIB was unable to find or open the sqllib message file sql*.msb
Action: Check that the file exists in the mesg directory and that it is readable
SQL-02114: Invalid SQL Cursor usage: trying to CLOSE a CLOSEd cursor
Cause: An attempt was made to CLOSE a cursor that was already CLOSEd with MODE={ANSI|ANSI14}. A CLOSEd cursor can be re-CLOSEd only when MODE={ORACLE|ANSI13}.
Action: When MODE={ANSI|ANSI14}, verify that a cursor is not already CLOSEd before trying to CLOSE it. Specify MODE={ORACLE|ANSI13} if a CLOSEd cursor is to be re-CLOSEd.
SQL-02115: Code interpretation problem -- check COMMON_NAME usage
Cause: With PRO*FORTRAN, this error occurs if the precompiler option COMMON_NAME is specified incorrectly. With other Oracle Precompilers, this error occurs when the precompiler cannot generate a section of code.
Action: With Pro*FORTRAN, when using COMMON_NAME to precompile two or more source modules, make sure to specify a different common name for each module. With other Oracle Precompilers, if the error persists, call customer support for assistance.
SQL-02116: FATAL ERROR: Reentrant code generator gave invalid context
Cause: This internal error typically indicates a memory-related error.
Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.
SQL-02117: Invalid SQL Cursor usage: trying to OPEN an OPENed cursor
Cause: An attempt was made to OPEN a cursor that was already OPENed with MODE={ANSI|ANSI14|ANSI13}. An open cursor can be re-OPENed only when MODE=ORACLE.
Action: When MODE={ANSI|ANSI14|ANSI13}, verify that a cursor is not already OPENed before trying to OPEN it. Specify MODE=ORACLE if an OPENed cursor is to be re-OPENed.
SQL-02118: Invalid row for a WHERE CURRENT OF operation
Cause: An attempt was made to reference a nonexistent row using the CURRENT OF clause in an UPDATE or DELETE statement. This happens when no FETCH has been executed or when FETCH returns a "no data found" error that the program fails to trap.
Action: Check that the last cursor operation succeeded and that the current row of the cursor is valid. The outcome of a cursor operation can be checked in two ways: implicit checking with the WHENEVER statement or explicit checking of SQLCODE in the SQLCA.
SQL-02119: Invalid HSTDEF argument
Cause: A non-null ptr was given for a hstdef as the second argument to a call to sqlrcn when the first argument was also used. Either the first or the second argument to SQLRCN must be null.
Action: Pass a null pointer in either the first or second argument to SQLRCN. *Note: This error *msg* is never actually used. The error *number* is used, given as the return value of sqlrcn if this error occurs.
SQL-02120: First and second arguments to SQLRCN both null
Cause: Both the first and second arguments to sqlrcn were null. An HSTDEF must be passed into SQLRCN in either the form of an OCI lda (first argument) or as an HSTDEF pointer itself (second argument).
Action: Pass in either an OCI LDA or an HSTDEF, but not both. *Note: This error *msg* is never actually used. The error *number* is used, given as the return value of sqlrcn if this error occurs.
SQL-02121: Invalid host name
Cause: The host name passed into a SQLFCN call was not used in a previous call to SQLRCN.
Action: Use the same identifier used in the corresponding SQLRCN call. *Note: This error *msg* is never actually used. The error *number* is used, given as the return value of sqlfcn if this error occurs.
SQL-02122: Invalid OPEN or PREPARE for this database connection
Cause: An attempt was made to execute an OPEN or a PREPARE statement using a cursor that is currently open for another database connection and, therefore, cannot be used for this connection.
Action: Close the cursor to make it available for this connection or use a different cursor for this connection.
SQL-02123: Context referenced in EXEC TOOLS GET CONTEXT statement not found
Cause: The context name given in the EXEC TOOLS GET CONTEXT statement was never stored with an EXEC TOOLS SET CONTEXT statement.
Action: Use the EXEC TOOLS SET CONTEXT statement to save any contexts to be retrieved later.
SQL-02124: NULL value returned by EXEC TOOLS statement
Cause: A NULL value was returned by EXEC TOOLS for a host variable that lacks an indicator variable. This error is returned only when MODE=ANSI. When MODE=ORACLE, although the value of the host variable is indeterminate, no error is generated.
Action: Associate an indicator variable with each host variable to which nulls might be returned.
SQL-02125: Connect error, can't get error text
Cause: No connection (not even to the default host) was available, so SQLLIB could not get the message text for the Oracle error that occurred. However, SQLLIB returns the Oracle error number, which can be used to look up the message.
Action: Look up the appropriate message in the Oracle7 Server Messages manual, and follow the Cause and Action information provided.
SQL-02126: Count of array elements cannot be negative (i.e. < 0)
Cause: The precompiler found a negative number of array elements in the the N or F element of the SQLDA (SQL Descriptor Area, which is used with dynamic SQL Method 4). Before executing the DESCRIBE statement, N must be set to the dimension of the descriptor arrays. After executing the DESCRIBE statement, N must be reset to the actual number of variables DESCRIBEd, which is stored in the F variable.
Action: Check that the N or F variables are set to non-negative values.
SQL-02127: Precompiler/SQLLIB version mismatch
Cause: The program was linked to an older version of SQLLIB, which is incompatible with this release of the Oracle Precompilers.
Action: Relink the program with a newer version of SQLLIB
SQL-02128: Sessions still exist, not logged off
Cause: A host was not removed ("logged off") from SQLLIB because XA still has sessions associated with that host.
Action: Before calling SQLXDH to drop a host, XA must either drop all sessions for that host or set the "doit_anyway" flag. *Note: This error *msg* is never actually used. The error *number* is used, given as a possible return value to the sqllib xa function sqlxdh.
SQL-02129: Fetched number of bytes is odd.
Cause: The program tried to FETCH an invalid column value into a multi-byte NLS host variable. Specifically, the column did not contain valid double-byte data.
Action: Make sure the column contains only double-byte data. To verify this, use SQL*Plus or Server Manager.
SQL-02130: EXEC TOOLS interface is not available.
Cause: An attempt was made to link with a version of an Oracle tool that does not support the EXEC TOOLS interface. EXEC TOOLS interface.
Action: Either upgrade the Oracle tool, or use the EXEC IAF interface.
SQL-02131: Runtime context in use
Cause: Your application attempted to execute a SQL statement using a runtime context that is already in use.
Action: Rewrite the application to either wait for one thread to complete before executing another SQL statement with the same runtime context, or to allocate and use a separate runtime context for each thread.
SQL-02132: Unable to allocate runtime context sdfla asdjklfajs jfja ajsdf
Cause: An attempt to allocate a runtime context failed.
Action: This error typically occurs when the process memory is low. Allocate more memory and run the application again.
SQL-02133: Unable to initialize process for use with threads
Cause: This is an internal error.
Action: Call customer support.
SQL-02134: Invalid runtime context
Cause: The runtime context associated with this statement has not been properly allocated.
Action: Rewrite the application to execute the EXEC SQL CONTEXT ALLOCATE statement before executing any SQL statements.
SQL-02135: Unable to initialize date format using supplied mask
Cause: The runtime library was unable to issue a set date format statement with the date format mask supplied.
Action: Check the validity of the date format and correct if necessary. Check the ORA error number for further information.
SQL-02136: Invalid NCHAR character set id
Cause: An attempt was made to bind or define an NCHAR host variable, and the NLS_NCHAR variable was not set correctly.
Action: Set the NLS_NCHAR environment variable to a valid fixed width character set id and run the application again.
SQL-02137: Multi-threaded agent with no RETURNING clause present
Cause: The EXEC SQL REGISTER CONNECT statement does not contain a RETURNING clause and the agent is running in threaded mode.
Action: Re-code the statement to use a RETURNING clause that references a declared sql_context host variable.
SQL-02138: No external procedure context exists
Cause: The external procedure context passed in the EXEC SQL REGISTER CONNECT statement is not valid.
Action: Ensure that you have done the following:

1. Created the PL/SQL procedure/function with a CONTEXT parameter.

2. Included OCIExtProcContext in the formal parameter list of the external procedure

3. Correctly passed the OCIExtProcContext to the EXEC SQL REGISTER CONNECT statement.

SQL-02139: Unable to get the OCI handles
Cause: The call to OCIExtProcGetEnv failed.
Action: Ensure that the OCIExtProcContext that the external procedure has been created with a CONTEXT parameter and that this context is correctly referenced in the EXEC SQL REGISTER CONNECT statement.
SQL-02140: An unnamed connection already exists
Cause: An attempt to register an external procedure context was made when an unnamed connection already exists for the runtime context.
Action: Do not attempt to establish any connections with the EXEC SQL CONNECT statement from external procedures.
SQL-02141: Collection descriptor has not been allocated
Cause: An unallocated collection descriptor was referenced in a COLLECTION SET or COLLECTION GET statement.
Action: Allocate the collection descriptor with the EXEC SQL ALLOCATE statement. e.g. EXEC SQL ALLOCATE :coldesc_p;
SQL-02142: Collection is NULL
Cause: The collection referenced in an EXEC SQL COLLECTION statement is null.
Action: Check the status of the associated indicator variable prior to executing an EXEC SQL COLLECTION statement.
SQL-02143: Target object has not been properly allocated
Cause: An attempt was made to retrieve elements from a collection into an unallocated object pointer.
Action: Allocate the object pointer with the EXEC SQL ALLOCATE statement.
SQL-02144: Invalid ANSI dynamic usage
Cause: An ANSI allocate, deallocate, get or set descriptor statement was encountered when dynamic option was not set.
Action: Precompile your source with option dynamic=ansi.
SQL-02145: Invalid dynamic descriptor
Cause: An attempt to access an unallocated or invalid descriptor was encountered.
Action: For ANSI descriptors, check that descriptor name is valid and descriptor has been allocated and not previously deallocated. Or if using Oracle descriptors (sqlda) with mode=ansi also use dynamic=oracle.
SQL-02146: Attempt to allocate an existing descriptor
Cause: An attempt allocated a descriptor which has previously been allocated was encountered.
Action: Use and unique descriptor name or deallocate the descriptor before attempting to reallocate it.
SQL-02147: ANSI Dynamic occurrence value out of range
Cause: The value clause in a dynamic GET or SET statement is less than one or greater than MAX given for descriptor allocation.
Action: Supply a number for the VALUE clause between 1 and the MAX occurrences supplied when the descriptor was allocated.
SQL-02148: ANSI Dynamic count value out of range
Cause: The count in a dynamic GET or SET statement is less than one or greater than MAX given for descriptor allocation.
Action: Supply a number for the COUNT clause between 1 and the MAX occurrences supplied when the descriptor was allocated.
SQL-02149: ANSI Dynamic insufficient item descriptor areas
Cause: The SQL statement being described contains more output items (or columns) than were allocated in the descriptor.
Action: Increase the MAX number of occurrences when allocating the descriptor.
SQL-02150: Encountered zero length in ANSI dynamic SET statement
Cause: An invalid length of zero was encountered in an ANSI dynamic statement.
Action: Set the length to a non-zero value
SQL-02151: Invalid host variable for exact numeric SET statement item
Cause: An host variable with an invalid type or length was used to get or set an exact numeric item in an ANSI dynamic statement.
Action: Make sure your host variable is and int or short for C or for COBOL, S9(4) or S9(9) binary/comp/display sign leading separate.
SQL-02152: Invalid numeric variable for use in an array GET/SET statement
Cause: An host variable with type other than int or short for C or S9(4) or S9(9) binary or comp was used for an exact numeric with and array size > 1.
Action: Use only int or short for C or S9(4) or S(9) binary or comp for COBOL when supplying an exact numeric in conjunction with the for clause to indicate arrays. Specifically, display sign leading separate is not allowed in this context.
SQL-02153: Invalid character variable for use in a GET/SET statement
Cause: An host variable with type other than character, string or varchar was found as an item name (other than DATA item) in an ANSI Dynamic GET or SET descriptor statement.
Action: Host variable types for character items (other than the DATA item) in ANSI dynamic GET or SET descriptor statements must not be of type LONG or LONG VARCHAR. Redeclare the variable to be character, string or varchar type
SQL-02154: Invalid or unset data type for host variable in ANSI Dynamic
Cause: An ANSI Dynamic SET statement with item name DATA was encountered with out a valid TYPE having been previously set and option mode=ansi was used
Action: With mode=ansi, you must set the TYPE before setting the DATA. Issue a SET statement with correct item TYPE or, for output issue a DESCRBE to set the item type. Or use mode=oracle which allows the type to default to the type of the bind/define host variable
SQL-02155: Date Time Interval only valid with Dynamic=ANSI
Cause: An attempt to access the datetime interval code or precision was encountered when type_code option not set to ANSI
Action: Use precompiler option type_code=ansi to access the date time interval code or date time interval precision
SQL-02156: Invalid type for Indicator or Returned Length
Cause: A host variable associated with the item Indicator or Returned Length must be of type short or s9(4) comp. If value semantics and scalar they may also be gotten into display sign leading separate host variables
Action: Use signed short for indicator, ref indicator and returned length, ref returned length host variables in C. For COBOL use s9(4) comp. for GETs only with non-arrays and you may use display sign leading separate host variables
SQL-02157: Source or destination lob is invalid
Cause: One of the lobs used in the lob append call is invalid or possibly null.
Action: Make sure the lobs used in the append call are non-null.


58 AUD-00702 to AUD-00809

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

58 AUD-00702 to AUD-00809

AUD-00702: unable to initialize audio processing environment
Cause: The initalization of the audio processing procedure failed.
Action: See the database administrator to make sure that enough memory has been allocated to JServer. If JServer does have enough memory, contact Oracle Customer Support Services.
AUD-00703: unable to read audio data
Cause: An error occurred while accessing the audio source.
Action: Make sure the audio source is valid. For external sources, make sure all access priviliges are granted.
AUD-00704: invalid input format
Cause: The audio data in the source was not in the format specified by the format field of the audio object. In some unusual cases, the audio data is actually corrupted.
Action: Provide a correct value in the format field. If the correct value is unknown, put NULL in the format field to invoke the DEFAULT format plug-in.
AUD-00705: unsupported input format
Cause: The file format of the audio data was not supported. This error can only occur in the DEFAULT format plug-in package.
Action: Refer to the interMedia documentation for supported formats.
AUD-00706: unsupported or corrupted input format
Cause: The audio data was either corrupted or the file format was not supported.
Action: Refer to the interMedia documentation for supported formats. If the audio data is not corrupted and is in a supported file format, contact Oracle Customer Support Services.
AUD-00713: internal error while parsing audio data
Cause: An internal error occurred during parsing.
Action: Contact Oracle Customer Support Services.
AUD-00714: internal error
Cause: An internal error occurred.
Action: Contact Oracle Customer Support Services.
AUD-00802: name of index is limited to 22 characters
Cause: The user specified an index name that is more than 22 characters long.
Action: Drop this index, and issue the CREATE INDEX statement again with a name that is at most 22 characters long.
AUD-00803: internal error while processing WHERE clause
Cause: The WHERE clause could not be properly processed.
Action: Contact Oracle Customer Support Services.
AUD-00806: first argument to SpeechContains must be a column
Cause: The first argument to SpeechContains is not a column. This is not allowed.
Action: Make sure that the first argument to SpeechContains is a column in a database table.
AUD-00807: SpeechContains: index of indextype ORDSpeechIndex is required
Cause: SpeechContains was used without an associated index of indextype ORDSpeechIndex.
Action: Make sure that SpeechContains is used in the context of an index of indextype ORDSpeechIndex. See the Oracle interMedia documentation for sample usage scenarios.
AUD-00808: ORDSpeechIndex: unable to CREATE internal Text index
Cause: CREATE INDEX for ORDSpeechIndex failed when trying to create internal Text index.
Action: Make sure that you are supplying a valid parameter string. See SpeechIndexing and Oracle Text documentation for descriptions of a valid parameter string for CREATE INDEX. To return to a consistent state, issue a DROP INDEX command.
AUD-00809: ORDSpeechIndex: unable to ALTER REBUILD internal Text index
Cause: ALTER INDEX REBUILD for ORDSpeechIndex failed when trying to alter rebuild internal Text index.
Action: Make sure that you are supplying a valid parameter string. See SpeechIndexing and Oracle Text documentation for descriptions of a valid parameter string for ALTER INDEX REBUILD. To return to a consistent state, issue a ALTER INDEX REBUILD PARAMETERS('optimize full') command.


59 IMG-00001 to IMG-02014

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

59 IMG-00001 to IMG-02014

IMG-00001: unable to initialize Oracle interMedia environment
Cause: The image processing external procedure initialization process failed.
Action: Contact Oracle Customer Support Services.
IMG-00002: unrecoverable error
Cause: This is an internal error.
Action: Contact Oracle Customer Support Services.
IMG-00003: exhausted memory while processing image
Cause: Oracle interMedia exhausted available Java memory during processing.
Action: Increase the JAVA_POOL_SIZE initialization parameter setting.
IMG-00502: invalid scale value
Cause: An invalid scale value was found while parsing the parameters for the image process function.
Action: Refer to the Oracle interMedia documentation for a description of the correct usage and syntax for the image processing command string.
IMG-00505: missing value in CUT rectangle
Cause: An incorrect number of values was used to specify a rectangle.
Action: Use exactly four integer values for the lower-left and upper- right vertices.
IMG-00506: extra value in CUT rectangle
Cause: An incorrect number of values was used to specify a rectangle.
Action: Use exactly four integer values for the lower left and upper right vertices.
IMG-00510: %s
Cause: A syntax error was found while parsing the parameters for the image process function.
Action: Refer to the Oracle interMedia documentation for a description of the correct usage and syntax for the image processing command string.
IMG-00511: %s
Cause: An error was found while accessing image data.
Action: Contact Oracle Customer Support Services.
IMG-00512: multiple incompatible scaling parameters found
Cause: Multiple incompatible scaling parameters were found in the image process command string. With the exception of XSCALE and YSCALE, which can be used together in a process command string, scaling functions are mutually exclusive and cannot be combined.
Action: Remove scaling functions until only one remains (or two, if they are XSCALE and YSCALE).
IMG-00513: missing value in scaling operation
Cause: An incorrect number of values was used to specify image dimensions. fixedScale and maxScale require exactly two integer values for the X and Y dimensions of the desired image.
Action: Use two values for fixedScale and maxScale.
IMG-00514: extra value in scaling operation
Cause: An incorrect number of values was used to specify image dimensions. fixedScale and maxScale require exactly two integer values for the X and Y dimensions of the desired image.
Action: Use two values for fixedScale and maxScale.
IMG-00515: incorrect number of input channels
Cause: An incorrect number of values was used to specify input channels. InputChannels requires either one or three channels numbers for the gray or red, green, and blue channel assignments.
Action: Use either one or three values to specify the input channels.
IMG-00516: default channel out of range
Cause: An incorrect value was used to specify the default channel selection.
Action: Use a channel number which is less than or equal to the number of bands and greater than zero.
IMG-00517: height or width not present in parameter string
Cause: Height and/or width were not specified in the setProperties parameter string.
Action: Specify both the height and width.
IMG-00518: invalid value for height or width
Cause: Height and/or width were not positive integers"
Action: Specify both the height and width as positive integers"
IMG-00519: illegal combination of parameters
Cause: Other than height, width, dataOffset, and userString no other parameters may be specified in the setProperties parameter string when CCITTG3 or CCITTG4 is used as the compressionFormat.
Action: Supply only the height and width when compessionFormat is either CCITTG3 or CCITTG4. The dataOffset and userString may optionally be supplied as well.
IMG-00520: invalid value for numberOfBands
Cause: NumberOfBands was not a positive integer"
Action: Specify numberOfBands as a positive integer"
IMG-00521: invalid value for dataOffset
Cause: DataOffset was not a positive integer"
Action: Specify dataOffset as a positive integer"
IMG-00522: invalid format for parameter value
Cause: A floating point value was specified where an integer is required, or a character value was specified where a numeric value is required.
Action: Specify the correct type of values for process parameters.
IMG-00523: invalid process verb
Cause: A process verb was specified that is not understood by Oracle interMedia.
Action: Refer to the Oracle interMedia documentation for a description of valid process verbs.
IMG-00524: mismatched quotes
Cause: Quotation marks used within a process command string were not matched.
Action: Ensure that quotation marks occur in pairs.
IMG-00525: locale error
Cause: This is an internal error.
Action: Contact Oracle Customer Support Services.
IMG-00526: error parsing foreign image description
Cause: An internal error occurred while processing a foreign image.
Action: Contact Oracle Customer Support Services.
IMG-00530: internal error while parsing command
Cause: An internal error occurred while parsing the command passed to the image processing function or the foreign image setProperties function.
Action: If you are certain that your command is correct, then contact Oracle Customer Support Services.
IMG-00531: empty or null image processing command
Cause: An empty or null image processing command was passed to the image process function.
Action: Refer to the Oracle interMedia documentation for a description of the correct usage and syntax for the image processing command string.
IMG-00540: contentFormat and interleave conflict
Cause: Interleave values were specified using both the contentformat and interleave verbs.
Action: Specify interleave using either contentformat or interleave, but not both.
IMG-00541: invalid contentFormat specified
Cause: The specified contentFormat was not valid.
Action: Refer to the Oracle interMedia documentation for a description of valid contentFormat specifications.
IMG-00542: contentFormat includes invalid extra information
Cause: The specified contentFormat included invalid characters at the end of the parameter string.
Action: Refer to the Oracle interMedia documentation for a description of valid contentFormat specifications.
IMG-00543: invalid compressionFormat specified
Cause: The specified compressionFormat was not valid.
Action: Refer to the Oracle interMedia documentation for a description of valid compressionFormat specifications.
IMG-00544: invalid compressionQuality specified
Cause: The specified compressionQuality was not valid.
Action: Refer to the Oracle interMedia documentation for a description of valid compressionQuality specifications.
IMG-00545: invalid cut values specified
Cause: An invalid value was found while parsing the parameters for the cut operation.
Action: Refer to the Oracle interMedia documentation for a description of the correct usage and syntax for the image processing command string.
IMG-00546: invalid page number specified
Cause: An invalid page number was specified.
Action: Specify page numbers that are not negative.
IMG-00547: invalid channelOrder specified
Cause: The specified channelOrder was not valid.
Action: Refer to the Oracle interMedia documentation for a description of valid channelOrder specifications.
IMG-00548: invalid interleave specified
Cause: The specified interleave was not valid.
Action: Refer to the Oracle interMedia documentation for a description of valid interleave specifications.
IMG-00549: invalid pixelOrder specfied
Cause: The specified pixelOrder was not valid.
Action: Refer to the Oracle interMedia documentation for a description of valid pixelOrder specifications.
IMG-00550: invalid scanlineOrder specified
Cause: The specified scanline order was not valid.
Action: Refer to the Oracle interMedia documentation for a description of valid scanlineOrder specifications.
IMG-00551: invalid quantize method specified
Cause: The specified quantization method was not valid.
Action: Refer to the Oracle interMedia documentation for a description of valid quantization method specifications.
IMG-00552: invalid inputChannels specified
Cause: An invalid value was specified for the inputChannels verb.
Action: Refer to the Oracle interMedia documentation for a description of the correct usage and syntax for the image processing command string.
IMG-00553: invalid rotate value
Cause: An invalid value was specified for image rotation. Rotation values must be a floating point number.
Action: Correct the statement by providing a valid rotation value.
IMG-00554: extra value in rotate operation
Cause: Multiple arguments were used to specify image rotation. The rotate operation accepts only a single value.
Action: Provide a single value for the rotate operation.
IMG-00555: invalid value for gamma correction
Cause: An invalid value was specified for gamma correction. Gamma values must be positive.
Action: Correct the statement by providing a positive gamma value.
IMG-00556: incorrect number of gamma values
Cause: An incorrect number of values were used to specify gamma correction. Gamma correction requires either one or three gamma values.
Action: Provide either one or three values to specify the gamma correction.
IMG-00557: invalid value for contrast enhancement
Cause: An invalid value was used to specify contrast enhancement.
Action: To specify contrast enhancement using percentages, provide values between 0 and 100. To specify contrast enhancement using bounds, provide values greater than 0.
IMG-00558: incorrect number of contrast values
Cause: An incorrect number of values were used to specify contrast enhancement. Contrast enhancement requires one, two, three, or six contrast values.
Action: Provide one or three values to specify contrast enhancement using percentages; provide two or six values to specify contrast enhancement using contrast bounds.
IMG-00560: input format does not support page selection
Cause: The page verb was specified for an input format that does not support selecting pages.
Action: Refer to the Oracle interMedia documentation for a description of which image formats support page selection.
IMG-00561: input format does not support channel selection
Cause: The inputChannels verb was specified for an input format that does not support selecting channels.
Action: Refer to the Oracle interMedia documentation for a description of which image formats support input channel selection.
IMG-00577: invalid quantize argument
Cause: A quantize value was specified that accepts an argument, but the argument provided was not valid.
Action: Provide a valid, non-negative argument for the quantize value.
IMG-00578: missing quantize argument
Cause: A quantize value was specified that requires an argument, but no argument was provided.
Action: Provide an argument for the quantize value.
IMG-00579: extra quantize argument
Cause: An extra argument was provided for a quantize value. Some quantize values accept no arguments, while others accept a single argument.
Action: Provide an argument only for quantize values that accept an argument.
IMG-00580: specified format does not support output
Cause: The output format specified by fileFormat does support output.
Action: Refer to the Oracle interMedia documentation for a description of which formats support output.
IMG-00581: output format does not support the specified contentFormat
Cause: The specified contentFormat is not supported by the explicitly or implicitly specified output format.
Action: Refer to the Oracle interMedia documentation for a description of which contentFormat values are supported for each output format.
IMG-00582: output format does not support the specified interleave
Cause: The specified interleave is not supported by the explicitly or implicitly specified output format.
Action: Refer to the Oracle interMedia documentation for a description of which interleave values are supported for each output format.
IMG-00583: output format does not support the specified compressionFormat
Cause: The specified compressionFormat is not supported by the explicitly or implicitly specified output format.
Action: Refer to the Oracle interMedia documentation for a description of which compressionFormat values are supported for each output format.
IMG-00584: output format does not support the specified compressionQuality
Cause: The specified compressionQuality is not supported by the explicitly or implicitly specified output format.
Action: Refer to the Oracle interMedia documentation for a description of which compressionQuality values are supported for each output format.
IMG-00585: output format does not support the specified channelOrder
Cause: The specified channelOrder is not supported by the explicitly or implicitly specified output format.
Action: Refer to the Oracle interMedia documentation for a description of which channelOrder values are supported for each output format.
IMG-00586: output format does not support the specified pixelOrder
Cause: The specified pixelOrder is not supported by the explicitly or implicitly specified output format.
Action: Refer to the Oracle interMedia documentation for a description of which pixelOrder values are supported for each output format.
IMG-00587: output format does not support the specified scanlineOrder
Cause: The specified scanlineOrder is not supported by the explicitly or implicitly specified output format.
Action: Refer to the Oracle interMedia documentation for a description of which scanlineOrder values are supported for each output format.
IMG-00599: internal error
Cause: An internal error has occurred.
Action: Contact Oracle Customer Support Services.
IMG-00601: out of memory while copying image
Cause: Operating system process memory has been exhausted while copying the image.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00602: unable to access image data
Cause: An error occurred while reading or writing image data.
Action: Contact your system administrator.
IMG-00603: unable to access source image data
Cause: The source image SOURCE attribute is invalid.
Action: Ensure that the SOURCE attribute of the source image is populated with image data.
IMG-00604: unable to access destination image data
Cause: The destination image SOURCE attribute is invalid.
Action: Ensure that the SOURCE attribute of the destination image is populated with image data.
IMG-00606: unable to access image data
Cause: An attempt was made to access an invalid image.
Action: Ensure that the SOURCE attribute of the image is populated with image data.
IMG-00607: unable to write to destination image
Cause: The destination image SOURCE attribute is invalid.
Action: Ensure that the SOURCE attribute of the destination image is initialized correctly and that you have sufficient tablespace.
IMG-00609: unable to read image stored in a BFILE
Cause: The image stored in a BFILE cannot be opened for reading.
Action: Ensure that the access privileges of the image file and the image file's directory allow read access.
IMG-00701: unable to set the properties of an empty image
Cause: There is no data in the image object.
Action: Refer to the Oracle interMedia documentation for information on how to populate image data into the image object.
IMG-00702: unable to initialize image processing environment
Cause: The image processing external procedure initialization process failed.
Action: Contact Oracle Customer Support Services.
IMG-00703: unable to read image data
Cause: There is no image data in the image object.
Action: Refer to the Oracle interMedia documentation for information on how to populate image data into the image object.
IMG-00704: unable to read image data
Cause: There is no image data in the image object.
Action: Refer to the Oracle interMedia documentation for information on how to populate image data into the image object.
IMG-00705: unsupported or corrupted input format
Cause: This is an internal error.
Action: Contact Oracle Customer Support Services.
IMG-00706: unsupported or corrupted output format
Cause: This is an internal error.
Action: Contact Oracle Customer Support Services.
IMG-00707: unable to access image data
Cause: An error occurred while reading or writing image data.
Action: Contact your system administrator.
IMG-00710: unable to write to destination image
Cause: The destination image is invalid.
Action: Ensure that the SOURCE attribute of the destination image is initialized and that you have sufficient tablespace.
IMG-00711: unable to set properties of destination image
Cause: This is an internal error.
Action: Contact Oracle Customer Support Services.
IMG-00712: unable to write to destination image
Cause: The destination image is invalid.
Action: Ensure the row containing the destination image has been locked (this does not apply to temporary BLOBs).
IMG-00713: unsupported destination image format
Cause: A request was made to convert an image to a format that is not supported.
Action: Refer to the Oracle interMedia Documentation for supported formats.
IMG-00714: internal error
Cause: This is an internal error.
Action: Contact Oracle Customer Support Services.
IMG-00715: unable to open image stored in a BFILE
Cause: The image stored in a BFILE could not be opened for reading.
Action: Ensure that the access privileges of the image file and the image file's directory allow read access.
IMG-00716: source image format does not support process options
Cause: A request was made to apply a processing option not supported by the source image format.
Action: Refer to the Oracle interMedia Documentation for a discussion of supported processing options.
IMG-00717: destination image format does not support process options
Cause: A request was made to apply a processing option not supported by the destination image format.
Action: Refer to the Oracle interMedia Documentation for a discussion of supported processing options.
IMG-00718: the same Temporary LOB cannot be used as both source and destination
Cause: A call was made to processCopy with the same Temporary LOB being specified as both the source and destination.
Action: Specify a different LOB for parameter "dest".
IMG-00719: image processing internal error
Cause: This is an internal error.
Action: Contact Oracle Customer Support Services.
IMG-00720: image processing internal error
Cause: This is an internal error.
Action: Contact Oracle Customer Support Services.
IMG-00730: unable to process empty image
Cause: There is no data in the input image object.
Action: Refer to the Oracle interMedia documentation for information on how to put image data into the image object.
IMG-00731: specified page could be found in input image
Cause: The specified page does not exist in the input image.
Action: Restrict the value of the page parameter to values specifying pages that exist within the input image object.
IMG-00732: specified inputChannels could not be found in input image
Cause: The specified inputChannel parameter does not exist in the input image.
Action: Restrict the value of the inputChannels parameter to values specifying channels that exist within the input image object.
IMG-00800: internal error while parsing attribute string
Cause: An internal error occurred while parsing the attribute string containing the weights of the attributes.
Action: If you are certain that your command is correct, then contact Oracle Customer Support Services.
IMG-00801: cannot extract height and width
Cause: Height and width are not set in the image object.
Action: Set the properties of the image object by calling setProperties and then generate signature.
IMG-00802: empty or null attribute string
Cause: An empty or null attributes string was passed to the image matching operators.
Action: Refer to the Oracle interMedia documentation for a description of the correct usage and syntax of the attributes string.
IMG-00803: invalid attribute value
Cause: An invalid value was found while parsing the attribute string for the image matching operators.
Action: Refer to the Oracle interMedia documentation for a description of the correct usage and syntax for the attributes string. The weight values should be between 0.0 and 1.0.
IMG-00804: Syntax error in attribute string
Cause: A syntax error was found while parsing the attribute string for the image matching operators.
Action: Refer to the Oracle interMedia documentation for a description of the correct usage and syntax of the attributes string.
IMG-00805: SIGNATURE data has been corrupted or is invalid
Cause: The data in the signature is not a valid signature.
Action: Re-create the signature using the generateSignature method.
IMG-00806: invalid input image
Cause: The image data is either corrupt or is in an unsupported format.
Action: Repopulate the image object, set properties of the image, and generate the signature.
IMG-00807: no weights specified in weight string
Cause: All weights passed were zero. At least one attribute must be weighted.
Action: Specify a non-zero weight for at least one attribute
IMG-00808: unable to read an empty image
Cause: There is no data in the image object.
Action: Refer to the Oracle interMedia documentation for information on how to populate the image object with image data.
IMG-00809: usage of IMGSimilar is incorrect
Cause: Syntax error while using IMGSimilar
Action: Refer to the Oracle interMedia documentation for information on how to use the IMGSimilar operator. Check whether the value returned by IMGSimilar is compared to the value 1.
IMG-00810: boundary queue initialization failed
Cause: Operating system process memory has been exhausted while initializing the boundary queue.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00811: fail queue initialization failed
Cause: Operating system process memory has been exhausted while initializin the fail queue.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00812: merged area queue initialization failed
Cause: Operating system process memory has been exhausted while initializing the merged area queue.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00813: boundary queue free failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00814: fail queue free failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00815: merged area queue free failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00820: area 0 queue clear failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00821: area N queue clear failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00822: area queue reset failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00823: boundary queue pop failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00824: fail queue pop failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00825: merged area queue pop failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00830: boundary queue is full
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00831: boundary queue size exceeds expected size
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00832: fail queue is full
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00833: boundary queue size exceeds expected size
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00834: merged area queue is full
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00835: merged area queue size exceeds expected size
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00836: area queue merge failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00840: image structure allocation failed
Cause: Operating system process memory has been exhausted while initializing the image structure.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00841: image data allocation failed
Cause: Operating system process memory has been exhausted while initializing the image data.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00842: image index allocation failed
Cause: Operating system process memory has been exhausted while initializing the image index.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00843: internal image structure allocation failed
Cause: Operating system process memory has been exhausted while initializing the internal image structure.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00844: internal image data allocation failed
Cause: Operating system process memory has been exhausted while initializing the internal image data.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00845: internal image index allocation failed
Cause: Operating system process memory has been exhausted while initializing the internal image index.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00846: adjacency matrix allocation failed
Cause: Operating system process memory has been exhausted while initializing the adjacency matrix.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00847: area list allocation failed
Cause: Operating system process memory has been exhausted while initializing the area list.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00850: image structure free failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00851: image data free failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00852: image index free failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00853: internal image structure free failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00854: internal image data free failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00855: internal image index free failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00856: adjacency matrix free failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00857: area list free failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number.
IMG-00860: assert failure, number of region exceeds allocated
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00861: assert failure, inconsistency in area merge operation
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00862: assert failure, inconsistency in merged area labels
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00870: unsupported aspect ratio or image size
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00871: unexpected number of seeds
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00872: unsupported image model
Cause: Signature generation was attempted on an image with an image model that interMedia is unable to support.
Action: Try scaling the image down. If signature generation still fails, contact Oracle Customer Support Services with the error number and the image causing this problem.
IMG-00899: signature cannot be generated
Cause: generateSignature could not generate the signature.
Action: Verify that the input image is a format supported by interMedia.
IMG-00901: VIR signature version mismatch
Cause: Two signatures to be compared have different versions.
Action: Recompute signatures on the same platform and repeat signature comparison.
IMG-00902: VIR signature free failed
Cause: An internal error has occured.
Action: Contact Oracle Customer Support Services.
IMG-00910: allocation of basic data structure failed
Cause: Operating system process memory has been exhausted while copying the image.
Action: See the database administrator or operating system administrator to increase process memory quota.
IMG-00911: free basic data structure failed
Cause: Operating system process memory has been exhausted while copying the image.
Action: Contact Oracle Customer Support Services.
IMG-00921: threshold out of range
Cause: Threshold is not between 0 and 100
Action: Use a threshold between 0 and 100 and retry query.
IMG-00922: location specified without feature
Cause: only location was specified.
Action: Specify at least one other parameter (color, texture or shape) along with location. Refer to the Oracle interMedia documentation for more details.
IMG-00923: signature is empty
Cause: Signature has not been generated.
Action: Generate the signature for the image by calling the generateSignature method.
IMG-00924: Incorrect parameter specification during CREATE INDEX
Cause: There is a spelling error, or duplicate parameter specification, or incorrect specification of parameters while creating an index of type ORDIMAGEINDEX.
Action: Refer to the Oracle interMedia documentation for correct specification of CREATE INDEX parameters.
IMG-00925: unable to write to the ORDImageSignature object
Cause: The signature object was not valid and therefore the write operation failed. This problem is commonly caused by an attempt to invoke the generateSignature method on an uninitialized ORDImageSignature object.
Action: Ensure that the ORDImageSignature object has been initialized and inserted into a table. Also ensure that the row containing the signature object is locked. (The two previous actions do not apply to signature objects created using temporary BLOBs). Ensure that there is sufficient tablespace to contain the signature.
IMG-02001: 2FF01 - incorrect image format
Cause: There was a SQL/MM Still Image exception. Either the supplied image BLOB format did not match the image format or the image format is unsupported.
Action: For supported image formats, specify an input BLOB that has the same format as the image. For unsupported image formats, this method is not supported. Refer to the Oracle interMedia documentation for more information.
IMG-02002: 2FF02 - incorrect average color feature specification
Cause: There was a SQL/MM Still Image exception. The specified average color value was not a valid SI_Color value.
Action: Specify an average color value that is not null and contains valid SI_Color values. SI_Color attribute values must be integers from 0 to 255. Refer to the Oracle interMedia
IMG-02003: 2FF03 - incorrect color histogram feature specification
Cause: There was a SQL/MM Still Image exception. This exception was caused by one of the following.

- The specified color value was null or invalid.

- The specified frequency value was null or invalid.

- The input color and frequency arrays were not equal in size.

- The SI_ColorList array attribute had reached the maximum size.

Action: Ensure that the following are true(as applicable to your case):

- The color and frequency values are not null.

- The SI_Color attribute values are integers from 0 to 255.

- The frequency value is a double precision number from 0 to 100.

- The color and frequency arrays are equal in size and the size of the arrays is less than the SI_MaxHistogramLength value listed in the SI_VALUES view in the SI_INFORMTN_SCHEMA. Refer to the Oracle interMedia documentation for more information on constructing SI_ColorHistogram objects.

IMG-02004: 2FF04 - incorrect feature list specification
Cause: There was a SQL/MM Still Image exception. Either the specified feature values were invalid or the specified feature weights were invalid.
Action: Check the values of feature and featureweight pairs. For a non null feature value, the corresponding feature weight value must be a double precision number greater than 0.0. Refer to the Oracle interMedia documentation for more information on the SI_FeatureList object type and its methods.
IMG-02005: 2FF05 - incorrect color specification
Cause: There was a SQL/MM Still Image exception. The specified red/green/blue value was null or invalid.
Action: Specify red, green and blue values as integers from 0 to 255.
IMG-02006: 2FF06 - average color feature cannot be determined
Cause: There was a SQL/MM Still Image exception. Either the specified image was null, the image data in the specified image was null, or the average color feature was not supported by the specified image format
Action: Specify an image with non null image data and a supported format. Refer to the SI_INFORMTN_SCHEMA views and the Oracle interMedia
IMG-02007: 2FF07 - positional color feature cannot be determined
Cause: There was a SQL/MM Still Image exception. Either the specified image was null, the image data in the specified image was null, or the positional color feature was not supported by the specified image format.
Action: Specify an image with non null image data and a supported format. Refer to the SI_INFORMTN_SCHEMA views and the Oracle interMedia
IMG-02008: 2FF08 - color histogram feature cannot be determined
Cause: There was a SQL/MM Still Image exception. Either the specified image was null, the image data in the specified image was null, or the color histogram feature was not supported by the specified image format.
Action: Specify an image with non null image data and a supported format Refer to the SI_INFORMTN_SCHEMA views and the Oracle interMedia
IMG-02009: 2FF09 - texture feature cannot be determined
Cause: There was a SQL/MM Still Image exception. Either the specified image was null, the image data in the specified image was null, or the texture feature was not supported by the specified image format.
Action: Specify an image with non null image data and a supported format. Refer to the SI_INFORMTN_SCHEMA views and the Oracle interMedia
IMG-02010: 2FF10 - illegal image format specification
Cause: There was a SQL/MM Still Image exception. The specified format name was null or invalid.
Action: Specify a format name that is not null. For supported image formats, specify a format name that matches the image BLOB format. For unsupported image formats, specify a format name that is not listed as supported image format. Refer to the SI_INFORMTN_SCHEMA views and the Oracle interMedia
IMG-02011: 2FF11 - unsupported image format conversion specified
Cause: There was a SQL/MM Still Image exception. Either the specified target format value was null, the specified image had a null format value, or the conversion from the specified image format to the specified target format was not supported.
Action: Specify an image with a supported image format and specify a target format value that is supported for conversion. Refer to the SI_INFORMTN_SCHEMA views and the Oracle interMedia
IMG-02012: 2FF12 - illegal specification for thumbnail generation
Cause: There was a SQL/MM Still Image exception. Either the specified image format did not support thumbnail generation, the specified thumbnail height or width was greater than the image height or width respectively, or the default thumbnail size 80 X 80 was greater than the image height or width respectively.
Action: Specify an image for which thumbnail generation is supported and specify thumbnail height and width values that are less than the image height and width values. Refer to the SI_INFORMTN_SCHEMA views and the Oracle interMedia
IMG-02014: 2202D Data exception - Null image value
Cause: There was a SQL/MM Still Image exception. The function was invoked using a null image value.
Action: Specify an image whose image data is not null. Refer to the Oracle interMedia documentation for more information on constructing SI_StillImage objects.


60 VID-00702 to VID-00714

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

60 VID-00702 to VID-00714

VID-00702: unable to initialize video processing environment
Cause: The initalization of the video processing procedure failed.
Action: See the database administrator to make sure that enough memory has been allocated to JServer. If JServer does have enough memory, contact Oracle Customer Support.
VID-00703: unable to read video data
Cause: An error occurred while accessing the video source.
Action: Make sure the video source is valid. For external sources, make sure all access priviliges are granted.
VID-00704: invalid input format
Cause: The video data in the source was not in the format specified by the format field of the video object. In some unusal cases, the video data is actually corrupted.
Action: Provide a correct value in the format field. If the correct value is unknown, put NULL in the format field to invoke the DEFAULT format plug-in.
VID-00705: unsupported input format
Cause: The file format of the video data was not supported. This error can only occur in the DEFAULT format plug-in package.
Action: Refer to the interMedia documentation for supported formats.
VID-00706: unsupported or corrupted input format
Cause: The video data was either corrupted or the file format was not supported.
Action: Refer to the interMedia documentation for supported formats. If the video data is not corrupted and is in a supported file format, contact Oracle Customer Support Services.
VID-00713: internal error while parsing video data
Cause: An internal error occurred during parsing.
Action: Contact Oracle Customer Support Services.
VID-00714: internal error
Cause: An internal error occurred.
Action: Contact Oracle Customer Support Services.


61 DRG-10000 to DRG-52210

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

61 DRG-10000 to DRG-52210

DRG-10000: failed to read column string.string
Cause: Error during read of specified text column
Action: check existence and privs of column
DRG-10001: can not access result table string
Cause: specified table does not exist or server does not have write privileges
Action: check result table
DRG-10002: can not insert into result table
Cause: text server is not privileged to insert, tablespace exhausted
Action: check privileges and tablespace
DRG-10011: invalid object name string
Cause: a table, column or procedure name specified had an invalid format. It is either too long or contains illegal characters. Probably you are passing in incorrect parameters.
Action: check parameter values
DRG-10015: id exceeds limit(2147483642) of a number
Cause: the limit of an id is 2147483642
Action: use an id with value 214748364 or under
DRG-10016: you must be the owner to modify this object
Cause: you tried to modify an object which you do not own
Action: have the owner modify the object
DRG-10017: you must be string to do this: string
Cause: you tried to modify an object which you have no privilege
Action: have the owner modify the object
DRG-10100: invalid argument found: string
Cause: invalid command argument was specified
Action: check the documentation for the legal arguments and re-execute the command
DRG-10101: no value for argument: string
Cause: this argument requires value(s)
Action: re-execute the command with the correct argument value(s)
DRG-10102: mandatory argument missing: string
Cause: this argument is mandatory
Action: re-execute the command and specify the argument
DRG-10103: illegal value for argument: string
Cause: an illegal value was passed to this argument
Action: check the documentation for the legal values for this argument
DRG-10200: invalid server personality mask: string
Cause: the specification for the server personality mask is invalid
Action: check the documentation and specify the correct mask
DRG-10202: server failed to register
Cause: the server failed to register itself with the data dictionary
Action: look at the next error on the stack
DRG-10203: server named string does not exist
Cause: update was called with the name of a server that does not exist
Action: correct the name of the server
DRG-10204: server update failed
Cause: the attempt to update the server failed
Action: look at the next error on the stack
DRG-10205: server deregister failed
Cause: the attempt to deregister the server from the data dictionary failed
Action: look at the next error on the stack
DRG-10206: failed to perform recovery for a server or client
Cause: Contact oracle support
Action: Contact oracle support
DRG-10301: timed out waiting for responses from servers
Cause: Not enough servers are running to handle the current system load, and a large backlog of commands has accumulated; perhaps no servers are running. This message could also indicate an internal error where one of the servers has crashed trying to process a given request
Action: Check that enough servers are running, and that they are processing commands of the correct type. For instance, a DDL command might timeout if all the servers are setup to exclusively process query commands. Also, check the server log files.
DRG-10302: interrupted waiting for responses from servers
Cause: User interrupted the request before it was completed
Action: Restart the request
DRG-10303: could not queue given commands to be processed
Cause: The given command or commands could not (all) be queued. This could indicate an extremely high system load, but it is more likely an internal error.
Action: Check if any servers are running to process the command.
DRG-10304: unexpected error sending command(s) to Oracle Text server
Cause: There was an unexpected error sending command(s) to server
Action: Call customer support.
DRG-10305: pipe string is full
Cause: Could not send command to pipe, because the pipe was full
Action: Check if any servers are running to process the commands on that pipe
DRG-10306: server terminated unexpectedly while processing command
Cause: The server shutdown during execution of your command. This could be caused by a shutdown abort, or by an internal error in the server.
Action: If the server terminated had an internal error, contact customer support.
DRG-10307: no servers running
Cause: Could not process command because no servers are running with the correct personality mask.
Action: Start some servers with correct personality mask.
DRG-10308: no server with the required string personality mask is running
Cause: Could not process command because no servers are running with the correct personality mask.
Action: Start some servers with correct personality mask.
DRG-10309: not enough job queue processes
Cause: Could not process command because no servers with the correct personality mask are running.
Action: increase the JOB_QUEUE_PROCESSES initialization parameter or reduce the parallel degree for this statement.
DRG-10310: servers were shutdown before processing request
Cause: The command could not be completed because the servers were shut down or terminated before processing the request.
Action: Start another server with the correct personality mask.
DRG-10311: remote send not supported
Cause: You tried to specify a database link in an index specification
Action: Specify only local index names
DRG-10312: logfile name must be specified
Cause: You tried to start logging without specifying a logfile name
Action: Specify a logfile name
DRG-10313: logging has already been started
Cause: You tried to start logging even though logging has already been started
Action: Stop logging first, or ignore
DRG-10314: logging has not been started
Cause: You tried to stop logging even though logging has not been started
Action: Start logging first, or ignore
DRG-10315: logging is not supported on MTS
Cause: You tried to start logging on MTS
Action: none
DRG-10500: CREATE_INDEX failed: column spec string
Cause: failed to create text index on the specified column
Action: See the next errors on stack and take appropriate action
DRG-10501: invalid stopword: string
Cause: The stopword specified cound be lexed into multiple tokens with current lexer preference
Action: Check lexer preference and Respecifies the stopword
DRG-10502: index string does not exist
Cause: the specified index does not exist or you do not have access to it.
Action: Specify an existing index
DRG-10503: table string cannot be indexed because it has no primary key
Cause: a textkey needs to be a single column unique key whose length does not exceed 64 bytes. no such key was defined as an unique index or declared as a primary or unique key constraint
Action: create a suitable textkey for the table or specify it explicitly in this procedure call
DRG-10504: primary key is required when using the DETAIL_DATASTORE
Cause: you tried to use the detail datastore to index a table with no primary key constraint
Action: add a primary key constraint on the table
DRG-10506: table does not exist: string
Cause: The table, view, or synonym specified does not exist. There may also be a permissions problem reading the table.
Action: Reinvoke the operation with the correct table name
DRG-10507: duplicate index name: string
Cause: the specified index already exists in the dictionary
Action: this index can be updated or deleted, however this is only allowed if there is no text index available on the text column
DRG-10509: invalid text column: string
Cause: the column specified is not valid
Action: check that the followings are valid: a) text column is of supported datatype b) valid table name, column name in the specification.
DRG-10510: stopword is missing
Cause: The stopword to be added was not specified.
Action: Specify the stopword
DRG-10511: index string does not exist or is incomplete
Cause: index creation is not complete
Action: create index before performing this operation
DRG-10513: index string metadata is corrupt
Cause: dictionary contains bad preferences for this index
Action: contact you DBA
DRG-10516: failed to perform DDL operation due to an Oracle error
Cause: the ddl operation requested has failed because of an Oracle error
Action: see the Oracle error on the stack and take the appropriate action
DRG-10517: index string is already valid
Cause: The index was in a valid state and did not need the requested operation.
Action: Check the requested operation
DRG-10518: an operation is in progress which conflicts with string request
Cause: another session is operating on this index. it could be: a) DML is requested and DDL is in progress or b) DDL is requested and DML is in progress operation on the index
Action: try again later
DRG-10520: failed to drop index: string
Cause: Failed to drop index on the specified index
Action: see the Oracle error on the stack and take the appropriate action
DRG-10525: missing REBUILD keyword
Cause: all Oracle Text alter index options require the REBUILD keyword
Action: specify alter index with the REBUILD keyword
DRG-10528: primary keys of type string are not allowed
Cause: you tried to create an index on a table with an illegal primary key datatype
Action: change the textkey to one of the followings: VARCHAR2, NUMBER, VARCHAR, DATE, CHAR, MLSLABEL
DRG-10531: parallel parameter must be > 0
Cause: you called create index with parallel = 0
Action: specify with value > 0
DRG-10532: table is not partitioned
Cause: you called parallel create index on non-partitioned table
Action: recreate the table with partitions or remove the PARALLEL clause
DRG-10533: invalid user name: string
Cause: you specified a user name that is invalid
Action: specify the correct user name
DRG-10535: failed to optimize text index string
Cause: the optimize operation requested has failed because of an Oracle error
Action: see the Oracle error on the stack and take the appropriate action
DRG-10549: length of the object name string exceeded the limit
Cause: object name has exceeded the maximun length of 30 bytes
Action: Reduce the length of the object name if you want to re-create it
DRG-10550: illegal syntax for index, preference, source or section name
Cause: name may have additional periods(.)
Action: check the syntax of the name
DRG-10553: illegal syntax for column specification string
Cause: column specification may have additional periods(.)
Action: check the syntax of column specification if you want to re-create it
DRG-10561: index string is not valid for requested operation
Cause: The index was not in a valid state due to some prior error.
Action: Drop index and create index again.
DRG-10562: missing alter index parameter
Cause: The parameter string was missing
Action: Provide correct parameter string with regard to the requested alter index operation.
DRG-10569: table or column does not exist: string
Cause: The table, view, synonym or column specified does not exist. There may also be a permissions problem reading the table.
Action: Reinvoke the operation with the correct table name or column name
DRG-10573: index string is obsolete
Cause: you specified an obsolete index
Action: perform upgrade_index on the index
DRG-10574: failed to upgrade text index string
Cause: the upgrade operation has failed because of an Oracle error
Action: see the Oracle error on the stack and take the appropriate action
DRG-10579: must provide text query criteria
Cause: text query criteria is mandatory
Action: provide text query criteria
DRG-10580: parallel indexing is not supported: string
Cause: attempted to create index with parallel servers
Action: Drop index and set parallel to 1 in create index
DRG-10581: indirect datastores cannot be used with long or lob text columns
Cause: You tried to create an index on a long or lob column using an indirect datastore such as the file or url datastores
Action: Use direct datastore or a varchar column
DRG-10582: column string does not exist in table string
Cause: you specified an invalid column
Action: specify valid column
DRG-10583: TRUNCATE INDEX failed: string
Cause: Failed to truncate index
Action: See the next errors on stack and take appropriate action
DRG-10584: failed to string string string due to an Oracle error
Cause: a DDL operation on an index object failed due to SQL error
Action: see following error
DRG-10595: ALTER INDEX string failed
Cause: failed to alter index
Action: See the next errors on stack and take appropriate action
DRG-10597: invalid rebuild online operation
Cause: REBUILD ONLINE is not supported for requested operation.
Action: Alter index without the online option.
DRG-10598: invalid parallel operation
Cause: PARALLEL is not supported for requested operation.
Action: Alter index without the parallel option
DRG-10599: column is not indexed
Cause: The column specified is not indexed.
Action: Create index on the column before performing this operation
DRG-10601: failed to remove pending DML for this index
Cause: The system could not remove triggers setup to monitor updates to the requested table
Action: See next error on stack to determine course of action. Call Oracle support if necessary. Until this error is fixed, updates to all text columns in the given table may not be indexed.
DRG-10602: failed to queue DML change to column string for primary key string
Cause: The system could not record that a change had been made to the given column
Action: See next error on stack to determine course of action. Call Oracle support if necessary. Until this error is fixed, updates to all text columns in the given table may not be indexed.
DRG-10606: server failed to access the DML Queue
Cause: The server was had an error accessing the DML Queue
Action: See next error on stack.
DRG-10700: preference does not exist: string
Cause: the preference name specified does not exists
Action: retry with the correct preference name
DRG-10701: preference string.string already exists
Cause: the specified preference already exists
Action: must drop the preference if you want to re-create it.
DRG-10702: cannot create or modify preference in another user's schema
Cause: you tried to create a preference for another user
Action: owner or CTXSYS or a user who has CTXADMIN role should create preference
DRG-10703: invalid framework object string
Cause: you specified an invalid object type
Action: use a valid framework object
DRG-10704: preference string does not have an attribute named string
Cause: you tried to set value for a invalid attribute (not supported by the object.
Action: specify the correct attribute name
DRG-10705: invalid value string for attribute string
Cause: you tried to set an illegal value for an attribute
Action: specify the correct attribute value for the datatype of the attribute
DRG-10706: length of string exceeds maximum size of string
Cause: Parameter is too many bytes
Action: Correct preference setting and resubmit
DRG-10707: a value is required for attribute string of preference string
Cause: A required attribute was not provided
Action: Correct preference setting and resubmit
DRG-10708: invalid class id string for preference string
Cause: the specified class id is not correct for the specified preference
Action: specify the correct class id
DRG-10709: this preference is referenced by string and cannot be dropped
Cause: the specified preference is used as part of another preference and cannot be dropped until the referring preference is modified
Action: modify the referring preference
DRG-10750: unknown parameter string
Cause: Unrecognized parameter
Action: Specify correct parameter
DRG-10751: invalid value for parameter
Cause: Wrong data type or out of range
Action: Specify correct parameter value
DRG-10752: DEFAULT_INDEX_MEMORY cannot be greater than MAX_INDEX_MEMORY
Cause: You tried to set DEFAULT_INDEX_MEMORY to a value higher than the maximum set in MAX_INDEX_MEMORY
Action: Specify a lower value
DRG-10753: invalid memory size string string
Cause: You specified an incorrectly formatted memory string
Action: Specify a correctly formatted memory string
DRG-10754: memory size must be between string and string
Cause: You specified a memory size which is outside the allowed range
Action: Specify a memory size within the allowed range
DRG-10755: %(1)s and string have characters in common
Cause: the join character sets cannot have characters in common
Action: Correct the attribute values and resubmit
DRG-10756: neither text indexing nor theme indexing has been selected
Cause: INDEX_TEXT and INDEX_THEMES preferences both cannot be FALSE.
Action: Set either of INDEX_TEXT or INDEX_THEMES or both to TRUE.
DRG-10757: stoplist cannot have more than 4096 stopwords
Cause: a stoplist cannot have more than 4096 stopwords. This includes stopthemes.
Action: none required
DRG-10758: index owner does not have the privilege to use this preference
Cause: index owner does not have the role defined in FILE_DATATSTORE_ROLE
Action: grant index owner the appropriate role
DRG-10759: invalid role
Cause: the role does not exist in the database
Action: check the role name or create the role
DRG-10760: illegal format for procedure name
Cause: the procedure name specified is invalid. For instance, it may have a semicolon
Action: check the procedure name
DRG-10761: procedure string does not exist
Cause: the specified procedure could not be found
Action: check input. Try a fully-specified format such as OWNER.OBJECT
DRG-10762: index owner does not have access to procedure string
Cause: the index owner does not have execute privilege on the specified procedure
Action: grant index owner execute permission on the procedure
DRG-10800: query failed: string string string
Cause: Failed to process the query
Action: Check the errors on stack and take appropriate action
DRG-10801: cannot create an SQE for another user
Cause: You tried to create an SQE for another user
Action: Remove owner from SQE name specification
DRG-10816: display/highlight call failed
Cause: See the next error on the stack.
Action: See the next error on the stack.
DRG-10817: CONTAINS term consists of stopword or phrase of stopwords: string
Cause: One or more terms within a CONTAINS query consist of just a stopword or a phrase of just stopwords
Action: Replace the stopword or use stopwords within phrases containing non-stopwords.
DRG-10819: could not open contains cursor
Cause: An error occurred while trying to open a contains cursor
Action: See accompanying error messages in the stack
DRG-10820: invalid contains cursor id
Cause: You tried to fetch or close a contains cursor with an id which does not exist.
Action: Review fetch or close invocation
DRG-10821: contains cursor is not open
Cause: You tried to fetch from a contains cursor which was not open.
Action: Open cursor first
DRG-10822: duplicate query name
Cause: You tried to create a stored query with a name already used.
Action: Use different name
DRG-10823: invalid query name
Cause: The query name specified is not valid
Action: Check the query name
DRG-10825: stored query does not exist: string
Cause: The specified stored query does not exist.
Action: Check the query name
DRG-10826: no document with the specified textkey is found
Cause: There is no document with the specified textkey.
Action: Check the textkey
DRG-10827: open_con must be performed before count_last
Cause: last_count returns hit from in-memory query,so an in-memory query must be run before you can use count_last
Action: execute open_con before run count_last
DRG-10828: token string is longer than maximum length for column string
Cause: A token to be inserted in the feedback table is longer than the maximum allowed column size.
Action: Modify the query, or the column size for feedback table, or feedback procedure arguments accordingly.
DRG-10829: feedback id string is longer than the maximum length of string bytes
Cause: Feedback id is longer than the maximum allowed length for the feedback_id column.
Action: Use a smaller feedback_id.
DRG-10830: SHARELEVEL is not 0 or 1
Cause: You specified a sharelevel which is not 0 or 1
Action: Use sharelevel equal to 0 or 1 only.
DRG-10831: can not insert into feedback table string
Cause: Not privileged to insert.
Action: Check privileges.
DRG-10832: can not delete from feedback table string
Cause: Not privileged to delete.
Action: Check privileges.
DRG-10833: feedback failed
Cause: Failed to process feedback request
Action: Check the errors on stack and take appropriate action
DRG-10834: upper-case form of section name string too long
Cause: upper-case form of the section name is longer then supported length
Action: reduce length of section name when adding section
DRG-10835: WITHIN operator not supported for theme index
Cause: WITHIN operator used in theme index query
Action: Rewrite query without WITHIN operator
DRG-10836: field section and attribute section can not be nested
Cause: A field section or a attribute section is specified in a nested section search
Action: Rewrite query without nested field sections
DRG-10837: section string does not exist
Cause: The given section name does not exist in USER_SECTIONS
Action: Rewrite query with valid section name
DRG-10838: invalid SPAN argument supplied to NEAR
Cause: An invalid value was supplied for SPAN argument to NEAR
Action: Provide a valid SPAN. Valid values are integers from 0 to 100.
DRG-10839: invalid ORDER argument supplied to NEAR
Cause: An invalid value was supplied for ORDER argument to NEAR
Action: Provide a valid ORDER. Valid values are T, TRUE, F, FALSE (case insensitive).
DRG-10840: CONTAINS predicate including 0 is not supported by FIRST_ROWS hint
Cause: User attempts to issue a query with CONTAINS predicate including 0 while giving FIRST_ROWS hint.
Action: remove FIRST_ROWS hint.
DRG-10841: invalid SCORE argument supplied to FUZZY
Cause: An invalid value was supplied for SCORE argument to FUZZY
Action: Provide a valid SCORE. Valid values are integers from 0 to 80.
DRG-10842: invalid NUMRESULTS argument supplied to FUZZY
Cause: An invalid value was supplied for NUMRESULTS argument to FUZZY
Action: Provide a valid NUMRESULTS. Valid values are integers from 0 to 5000.
DRG-10843: invalid WEIGHT argument supplied to FUZZY
Cause: An invalid value was supplied for WEIGHT argument to FUZZY
Action: Set WEIGHT to WEIGHT or NOWEIGHT.
DRG-10844: index cannot execute this structured predicate efficiently
Cause: You specified a combination of condition and order by columns in a catsearch query which cannot be executed by the index's index set efficiently
Action: none
DRG-10845: column string is not indexed
Cause: You specified a column in a condition or order by which is not part of the ctxcat index
Action: none
DRG-10846: order by columns must be all ascending or all descending
Cause: You specified an order by clause which has some columns ascending and some descending. This is not currently supported by catsearch
Action: none
DRG-10847: catsearch requires prefix index for this type of queries
Cause: For efficient execution of this Vgram query we require presence of a prefix index.
Action: create a prefix index
DRG-10848: invalid structured clause
Cause: you have specified an invalid structured clause
Action: none
DRG-10849: catsearch does not support functional invocation
Cause: the query plan for your query is invoking a catsearch operator functionally rather than as an index rowsource. The catsearch operator does not support functional invocation
Action: add optimizer hints so that all catsearch operators are performed through index scans
DRG-10850: CTXRULE indextype does not support the operator
Cause: Used an operator not supported by CTXRULE. Currently it only supports AND, NEAR, phrase, NOT, WITHIN, OR, ABOUT, EQUIVALENCE, STEM and THESAURUS operators
Action: Rewrite query without this operator
DRG-10851: Invalid grammar string specified for query template
Cause: incorrect grammar specification
Action: Rewrite query specifying valid grammar name
DRG-10852: Invalid scoring type string specified for query template
Cause: incorrect scoring type specification
Action: Rewrite query specifying valid scoring type (integer/float)
DRG-10853: Catsearch does not support this operator
Cause: unsupported operator specified
Action: Rewrite query using valid operators
DRG-10854: Invalid scoring algorithm string specified for query template
Cause: incorrect scoring algorithm specification
Action: Rewrite query specifying valid scoring algorithm (default/count)
DRG-10900: out of memory
Cause: can not allocate more memory
Action: Contact your system adminstrator
DRG-11000: invalid keyword string
Cause: A keyword was invalid.
Action: Respecify the parameter string with correct keyword
DRG-11001: missing keyword when expecting one of string
Cause: A keyword was missing.
Action: Respecify the parameter string with keyword
DRG-11002: missing value for string
Cause: A value for the argument was missing.
Action: Respecify the parameter string with value
DRG-11003: invalid value string for string
Cause: An invalid value was given for the argument
Action: Specify a valid value
DRG-11004: duplicate or conflicting value for string
Cause: More than one value has been specified for the argument
Action: Check parameter string and correct the problem parameter
DRG-11005: invalid create index parameter string
Cause: the supplied parameter string is not correct
Action: drop index and recreate index with correct parameters
DRG-11006: invalid alter index parameter string
Cause: The parameter string was invalid.
Action: Reissue the statement with the correct parameter string.
DRG-11007: multiple stopwords specified
Cause: Tried to add more than one stopword
Action: Specify one stopword at a time
DRG-11008: invalid create index partition parameter string
Cause: The parameter string was invalid
Action: drop index and recreate index with correct parameters
DRG-11100: unable to connect to the database
Cause: failed to connect to Oracle database
Action: check the Oracle error and connect string
DRG-11101: failed to open file string
Cause: failed to open a file
Action: check whether the file exist or access permission available
DRG-11102: assigned lexer can not operate on string language setting
Cause: Single byte lexer selected in multibyte language setting
Action: check RDBMS language setting or text columns lexer setting
DRG-11104: Oracle Text error:
Cause: See the next error on stack
Action: See the next error on stack
DRG-11106: user database session has terminated during this operation
Cause: this database session does not exist or has terminated
Action: determine why the user database session terminated while the operation was still being carried out.
DRG-11107: invalid path specification: string
Cause: the path specified is not valid
Action: check the path specification
DRG-11108: invalid filename specified: string
Cause: the filename specified is not valid
Action: check the filename for beginning or trailing spaces, invalid characters, or other such problems.
DRG-11109: assigned lexer does not support string query operator
Cause: This lexer does not support this query operator
Action: do not use the operator in your query
DRG-11111: value of string must be between string and string
Cause: You specified a value for the parameter which is out of range
Action: Specify a value which is in the allowed range
DRG-11112: length of string exceeds maximum of string
Cause: You specified a value for the parameter which is too long
Action: Specify a value which is less than or equal to the maximum length
DRG-11113: value of string must be one of string
Cause: You specified a value for the parameter which is invalid
Action: Specify a valid value for the parameter
DRG-11114: result table format is not correct for this operation
Cause: You specified a result table which has the wrong number, type, or names of columns for this operation.
Action: Check result table. Refer to the documentation for the correct format for each operation
DRG-11115: a value for string must be specified
Cause: You did not specify a value for the parameter
Action: Specify a value for the parameter
DRG-11116: value of string must be less than or equal to value of string
Cause: You specified values for the two parameters which are invalid
Action: Specify valid values for the parameters
DRG-11117: name is already used by an existing object
Cause: You tried to create an object whose name conflicts with an object of that type which already exists
Action: Specify a new name
DRG-11118: object string does not exist
Cause: You tried to modify or drop an object which does not exist
Action: Specify correct object name
DRG-11119: operation is not supported by this index type
Cause: You tried to invoke an operation on an index which is not supported by the index type
Action: none
DRG-11120: failed to write to file string
Cause: failed to write to a file
Action: check whether the file exist or access permission available
DRG-11121: failed to read from file string
Cause: failed to read from a file
Action: check whether the file exist or access permission available
DRG-11122: unsupported section group
Cause: unsupported section group is specified for functional contains
Action: change the section group to NULL_SECTION_GROUP
DRG-11123: theme indexing is not supported
Cause: theme indexing is on in the lexer preference for functional contains
Action: turn off theme indexing
DRG-11124: invalid value string
Cause: you specified an invalid value
Action: specify a valid value
DRG-11125: invalid format of existing log file string
Cause: the file specified by START_LOG already exists, and is not a previously written log file
Action: specify a new file, or remove the existing file
DRG-11126: context index is empty
Cause: the training table is empty or the context index of training table is not populated
Action: populate the training table or context index
DRG-11127: inconsistent index policy with trained rule
Cause: the ctxrule index policy is inconsistent with the policy in which the rule was trained
Action: change the ctxrule index policy
DRG-11128: invalid format of rule
Cause: the rule format is not valid for this operation
Action: check the rule type and operation type
DRG-11129: the rule table is empty
Cause: the rule table is empty
Action: populate the rule table by training
DRG-11130: no data found in the collection
Cause: feature preparation program can not find any feature in the specified collection
Action: check the setting for extracting features.
DRG-11203: INSO filter not supported on this platform
Cause: You tried to use the INSO filter on a platform which does not support it
Action: Do not use the INSO filter
DRG-11204: user filter command is too long
Cause: The user filter command must be 32 characters or less
Action: Specify a shorted user filter command
DRG-11205: user filter command contains illegal characters
Cause: The user filter command cannot contain special characters such as slashes, parentheses, semicolons, etc.
Action: Correct command specification
DRG-11206: user filter command string could not be executed
Cause: The user filter command could not be executed.
Action: Check that the command exists in $ORACLE_HOME/ctx/bin, and that it is executable.
DRG-11207: user filter command exited with status string
Cause: The user filter command exited with the given error status.
Action: See any DRG-11220, DRG-11221, DRG-11222, DRG-11223, DRG-11224, or DRG-11225 error message on the error stack otherwise see error status.
DRG-11208: ORACLE_HOME is not set
Cause: ORACLE_HOME is not set
Action: make sure ORACLE_HOME is set when running ctxsrv
DRG-11209: filename for string exceeds maximum length of string
Cause: Value of the file name is too long
Action: Specify a shorter filename
DRG-11210: format column must be a char, varchar, or varchar2 type
Cause: you specified a format column which is not a char, varchar, or varchar2 type.
Action: specify a format column of correct type
DRG-11211: charset column must be a char, varchar, or varchar2 type
Cause: you specified a charset column which is not a char, varchar, or varchar2 type.
Action: specify a charset column of correct type
DRG-11212: procedure filter procedure name contains a semicolon
Cause: the procedure name specified had a semicolon
Action: remove semicolon or rename procedure name. The correct format is PACKAGENAME.PROCEDURE_NAME
DRG-11213: CTXSYS does not own procedure filter stored procedure: string
Cause: CTXSYS does not have execute privilege to the procedure filter stored procedure
Action: make sure the package is owned by CTXSYS and the procedure exist
DRG-11214: execution of procedure filter stored procedure has failed
Cause: an error occur while executing the proedure filter stored procedure
Action: check or debug the stored procedure
DRG-11215: index owner does not have access to filter stored procedure: string
Cause: the index owner does not have execute privilege of the procedure
Action: CTXSYS to grant execute privilege of the procedure to index owner
DRG-11216: length of datastore data exceeds limit
Cause: the length of the datastore data passed to the filter stored procedure is longer than the maximum length (32767 bytes)
Action: check primary key parameter
DRG-11217: INSO safe callout failed
Cause: The INSO safe callout cannot be executed
Action: check the Oracle errpr
DRG-11218: malformed mail line, line string
Cause: The mail message has an error at the indicated line
Action: manually edit mail message, if possible
DRG-11219: malformed mail configuration file, line string
Cause: mail filter configuration file has an error at the indicated line
Action: manually edit mail filter configuration file, if possible
DRG-11220: Third-party filter is out of memory.
Cause: Third-party filter could not filter this document because it was unable to allocate sufficient virtual memory.
Action: Increase virtual memory provided by the Operating System and reindex this document.
DRG-11221: Third-party filter indicates this document is corrupted.
Cause: Third-party filter could not filter this document because this
Action: Fix the corruption and reindex this document.
DRG-11222: Third-party filter does not support this known document format.
Cause: Third-party filter was able to recognize the format of this
Action: Remove this document or specify it to be ignored.
DRG-11223: Third-party filter indicates this document is password protected or encrypted.
Cause: Third-party filter encountered a password protected or encrypted
Action: Remove this document or specify it to be ignored.
DRG-11224: Third-party filter is unable to create or write to temporary file.
Cause: Third-party filter could not filter this document because it was unable to create a temporary file or unable to write to a temporary file.
Action: Make sure that the Operating System specified temporary directory has enough space and that the Operating System Oracle user has the privileges to create files in this temporary directory.
DRG-11225: Third-party filter timed out.
Cause: Third-party filter could not filter this document because the filter timed out.
Action: Increase the value of the TIMEOUT attribute of INSO_FILTER filter type and reindex this document. When TIMEOUT attribute is set to 0 and the session hangs then contact Oracle Support.
DRG-11301: error while indexing document
Cause: An error was encountered while indexing the document. The error may have occurred during lexing, parsing for sections, or other
Action: review document and update with valid data. Note that the
DRG-11303: secondary indexes are not supported by this indextype
Cause: You attempted to create an index on an index-organized table, but the indextype does not support this action.
Action: none
DRG-11304: function-based indexes are not supported by this indextype
Cause: You attempted to create a function-based index but the indextype does not support this action.
Action: none
DRG-11305: create/alter index string is in progress in another session
Cause: you attempted to mark the index from INPROGRESS to FAILURE but create/alter on the same index is in progress in another session
Action: none
DRG-11306: operation cannot be performed on a policy
Cause: you attempted to perform an operation on a policy, but the operation is only valid for an index.
Action: none
DRG-11307: operation cannot be performed on an index
Cause: you attempted to perform an operation on an index, but the operation is only valid for a policy.
Action: none
DRG-11400: failed to parse document with key string
Cause: The document specified for linguistic extraction could not be parsed. This could indicate that the document is not well-formed English
Action: check the document contents
DRG-11403: primary key value too long
Cause: the primary key value parameter passed to the service request is longer than the maximum primary key length (64 bytes)
Action: check primary key parameter
DRG-11404: no primary key value specified
Cause: the primary key value parameter passed to the service request is null
Action: check primary key parameter
DRG-11410: could not insert into string result table
Cause: an ORACLE error occurred while linguistic output was being inserted into the result table
Action: take action appropriate to the ORACLE error code.
DRG-11418: insufficient document content for linguistic parser
Cause: the document specified for linguistic extraction was parsed but the document content was insufficient for linguistic extraction by the specified parser.
Action: check the document contents or try modifying linguistic settings
DRG-11422: linguistic initialization failed
Cause: linguistic services initialization failed
Action: Check to see if knowledge base files present for the language
DRG-11425: gist level string is invalid
Cause: invalid gist level
Action: Specify a valid gist level
DRG-11427: valid gist level values are string
Cause: Invalid gist level
Action: Specify a valid gist level
DRG-11432: file error while accessing knowledge base
Cause: An oracle error was encountered during knowledge base access
Action: Check to see if knowledge base files present for the language
DRG-11435: primary key value is invalid
Cause: the primary key value parameter passed to the service request is not valid
Action: check primary key parameter
DRG-11439: index name length exceeds maximum of string bytes
Cause: the length of the index name is longer than the maximum index name size
Action: drop the index and recreate the index with a shorter index name
DRG-11440: operation not supported for the string language
Cause: the requested operation is not supported for the current language
Action: Do not request this operation
DRG-11441: gist numParagraphs string is invalid
Cause: invalid gist numparagraphs
Action: Specify valid gist numparagraphs
DRG-11442: valid gist numParagraphs values are string
Cause: invalid gist numparagraphs
Action: Specify valid gist numparagraphs
DRG-11443: gist maxPercent string is invalid
Cause: invalid gist max percent
Action: Specify valid gist max percent
DRG-11444: valid gist maxPercent values are string
Cause: invalid gist max percent
Action: Specify valid gist max percent
DRG-11445: rowid value is invalid: string
Cause: the rowid value parameter passed to the service request is not valid
Action: check rowid parameter
DRG-11480: ctxkbtc memory allocation error: %(1)
Cause: Unable to allocate memory
Action: Contact your system administrator
DRG-11500: column name expected, found string on line string
Cause: possibly miss-spelt column name or keyword
Action: check spellings and punctuation around specified line
DRG-11501: identifier string found in place of column name on line string
Cause: possibly miss-spelt column name
Action: check spellings around specified line
DRG-11502: read of file failed at line string for file string
Cause: bad file name, wrong file_type or file system error
Action: check file name, type and/or file integrity
DRG-11503: insert statement overflows maximum statement size
Cause: total length of statement exceeds database maximum
Action: reduce length of column names or number of columns
DRG-11504: invalid longsize parameter of string specified
Cause: invalid option argument
Action: specify long buffer size in kbytes above 0
DRG-11505: long data on line string not found or invalid
Cause: either bad data or bad data file
Action: check file exists and is accessible, if separate
DRG-11506: record ignored on line string because of error(s)
Cause: an error occured parsing this row's data
Action: move and amend line in error to alternate load file
DRG-11507: file error trying to read file string
Cause: file not found or could not be read
Action: check name and location of file
DRG-11508: bad or missing string token on line string
Cause: token expected was not found
Action: move and amend record affected to error load file
DRG-11509: value expected on line string
Cause: could not make sense of text where value expected
Action: move and amend record affected to error load file
DRG-11510: encountered unrecoverable error on line string
Cause: see previous messages
Action: see previous errors
DRG-11511: specified table does not contain a LONG RAW column
Cause: text must be inserted into a LONG RAW type column
Action: check table and type of data
DRG-11512: bad syntax for thesaurus load file at line string
Cause: load file must have specific format for loading thesaurus
Action: check documentation for description of correct format
DRG-11513: unable to open or write to file string
Cause: an attempt to open or to write to the given file failed
Action: check with system administrator
DRG-11514: user string does not have UPDATE or SELECT privilege on string
Cause: user has not been granted UPDATE or SELECT privilege
Action: check privilege on the user
DRG-11515: not enough text key values
Cause: number of values provided does not match the number of text keys
Action: provide same number of values as the number of text keys
DRG-11516: user must be at least in role CTXUSER to perform this operation
Cause: user does not have CTXUSER, CXAPP or CTXADMIN role
Action: grant user the proper role
DRG-11517: error when validating text objects
Cause: see accompanying Oracle error
Action: see accompanying Oracle error
DRG-11518: text table string does not have a LONG or LONG RAW column
Cause: table specified does not have a LONG or LONG RAW column
Action: check the table
DRG-11519: encounter error when exporting a LONG or LONG RAW column
Cause: see accompanying error message
Action: see accompanying error message
DRG-11520: error writing to file
Cause: file does not exist
Action: make sure file exists
DRG-11521: encounter error when updating a LONG or LONG RAW column
Cause: see accompanying error message
Action: see accompanying error message
DRG-11522: no row exists for the text key(s) specified
Cause: no row in the table has the text key(s) specified
Action: use a valid text key(s)
DRG-11523: unable to lock the specified row for update
Cause: some other process has a lock on the row
Action: release the lock or wait until the lock is released
DRG-11524: primary key value is missing
Cause: primary key value is not provided
Action: provide the primary key value(s)
DRG-11525: invalid commitafter parameter of string specified
Cause: invalid option argument
Action: specify commitafter above 0
DRG-11526: filename exceeds maximum length
Cause: value of the file name is too long
Action: Specify a shorter file name
DRG-11527: end token not found on line string
Cause: <TEXTEND> not found at end of record
Action: processing discontinued - amend record
DRG-11528: LONG or LONG RAW column defintion found in structure data
Cause: could be misplaced
Action: remove reference to LONG or LONG RAW column from structure data
DRG-11529: token exceeds maximum length
Cause: value of the column name or value is too long
Action: processing discontinued - amend record
DRG-11530: token exceeds maximum length
Cause: value of the phrase or relation word is too long
Action: processing discontinued - amend record
DRG-11531: start token not found on line string
Cause: <TEXTSTART: not found at start of record
Action: processing discontinued - amend record
DRG-11532: error reading through end of line string for file string
Cause: characters encountered while reading through end of line
Action: remove extraneous characters
DRG-11533: improper value of column string
Cause: value of the column is too long or mismatched quote
Action: processing discontinued - amend record
DRG-11534: invalid column string
Cause: column does not exist or it's misspelled
Action: processing discontinued - amend record
DRG-11535: error writing phrase or qualifier: string on line string to memory
Cause: not enough memory
Action: allocate more memory, contact WorldWide Support if problem persists
DRG-11600: URL store: string has permanently moved
Cause: the document referred to by the URL has permanently moved
Action: find the new address, if any, of the document
DRG-11601: URL store: bad syntax on request for string
Cause: client did not make correct request
Action: contact support
DRG-11602: URL store: access to string requires authentication
Cause: user has to provide password or other authentication
Action: get required access, or check URL
DRG-11603: URL store: payment required to access string
Cause: payment is required before the URL can be accessed
Action: check URL, or pay if required if access necessary
DRG-11604: URL store: access to string is denied
Cause: access to the URL is denied
Action: check URL; if correct, do not try to access URL again
DRG-11605: URL store: document specified by string not found
Cause: the document can not be found on the host specified
Action: check URL
DRG-11606: URL store: access to string timed out waiting for client request
Cause: client did not make response within timeout period
Action: check URL
DRG-11607: URL store: access to string was denied due to garbled response
Cause: Web server identified in URL doesn't obey HTTP protocol
Action: contact the Web administrator of the remote host
DRG-11608: URL store: host portion of string specified incorrectly
Cause: host portion of the URL could not be parsed
Action: check URL
DRG-11609: URL store: unable to open local file specified by string
Cause: attempt to open local file failed
Action: check URL
DRG-11610: URL store: unable to read local file specified by string
Cause: attempt to read local file failed
Action: contact system administrator
DRG-11611: URL store: unknown protocol specified in string
Cause: the protocol parsed is neither http or file
Action: check URL
DRG-11612: URL store: unknown host specified in string
Cause: the address of the host specified could not be resolved
Action: check URL
DRG-11613: URL store: connection refused to host specified by string
Cause: attempt to connect to host was forcibly refused
Action: check URL
DRG-11614: URL store: communication with host specified in string timed out
Cause: a network operation timed out
Action: try again later; network connection may be down to Web server
DRG-11615: URL store: write failed sending to string over network
Cause: unknown error writing request to Web server
Action: check network connection
DRG-11616: URL store: too many redirections trying to access string
Cause: too long a chain of HTTP redirections given the URL
Action: contact the Web administrator of the remote host
DRG-11617: URL store: URL string is too long
Cause: The length of the URL string is longer than URLSIZE
Action: set URLSIZE attribute to a larger value
DRG-11618: URL store: document identified by string is too large
Cause: document larger than user-set maximum size
Action: do not access URL, or increase document size limit
DRG-11619: URL store: row in table is empty
Cause: row deleted or otherwise missing
Action: check table if necessary
DRG-11620: URL store: thread operation error
Cause: thread operation failed
Action: contact system administrator
DRG-11621: URL store: socket open error for string
Cause: socket open failed; probably too many open file descriptors
Action: reduce the maximum number of threads started
DRG-11622: URL store: unknown HTTP error getting string
Cause: an unexpected HTTP error has occurred
Action: consult HTTP error codes; if valid, contact support
DRG-11623: URL store: unknown error getting string
Cause: unexpected error
Action: contact support
DRG-11624: invalid attribute string for string: proper range string to string
Cause: unexpected error
Action: change attribute value
DRG-11625: MAXURLS * URLSIZE must be less than string
Cause: MAXURLS * URLSIZE cannot be larger than the limit
Action: Lower either MAXURLS or URLSIZE
DRG-11700: thesaurus string already exists
Cause: thesaurus with same name exists
Action: use another name
DRG-11701: thesaurus string does not exist
Cause: thesaurus does not exist
Action: use another thesaurus or create it
DRG-11702: %(1)s
Cause: error while parsing thesaurus operator in query term. see error message for details.
Action: see error message
DRG-11703: user string must have at least CTXAPP role to execute this function
Cause: privilege is not sufficient
Action: grant user CTXAPP role
DRG-11704: phrase string does not exist
Cause: phrase does not exist
Action: use another phrase or create it
DRG-11705: multilevel jump from string to string
Cause: the thesaurus load file has a multilevel jump which could not be parsed.
Action: correct thesaurus file
DRG-11706: invalid relation string
Cause: You specified an invalid relation. The set of valid relations will be displayed. Additionally, you may be able to specify a translation, which has the syntax languagename: where languagename can be any string up to 10 bytes
Action: Specify a valid relation
DRG-11707: valid relations: string
Cause: You specified an invalid relation. The set of valid relations will be displayed. Additionally, you may be able to specify a translation, which has the syntax languagename: where languagename can be any string up to 10 bytes
Action: Specify a valid relation
DRG-11708: too many thesauri
Cause: ctxkbtc cannot compile more than 16 thesauri
Action: Specify fewer thesauri
DRG-11709: too many terms in thesaurus
Cause: number of thesaurus terms exceeds maximum
Action: Use a thesaurus with fewer terms
DRG-11710: thesaurus term string too long
Cause: knowledge base does not permit terms longer than 80 characters
Action: Correct thesaurus
DRG-11711: too much data for term string
Cause: internal limit on size of data per term
Action: redesign thesaurus
DRG-11712: multiple Broader Terms for term string
Cause: There is a term in the thesaurus with multiple broader terms
Action: make sure each term has only one broader term
DRG-11713: multiple Preferred Terms per synonym ring
Cause: There is a synonym ring in the thesaurus with multiple preferred terms
Action: make sure each synonym ring has only one preferred term
DRG-11714: synonyms have different Broader Terms
Cause: Some synonyms in a synonym ring have different broader terms
Action: make sure all synonyms have the same broader term
DRG-11715: attempt to add a BT relation between 2 KB categories string and string
Cause: BT relation cannot be between two existing knowledge base categories
Action: redesign the BT hierarchy
DRG-11716: attempt to add Narrower Term string for non-Preferred Term string
Cause: only a PT can have NTs
Action: attach the NT to the preferred term
DRG-11717: attempt to add Related Term string to non-Preferred Term string
Cause: only a PT can have RTs
Action: attach the RT
DRG-11718: multiple Preferred Terms for term string
Cause: There are multiple preferred terms for this term
Action: Correct thesaurus
DRG-11719: Broader Term hierarchy too deep
Cause: The broader term hierarchy in this thesaurus is too deep
Action: flatten the hierarchy for best results
DRG-11720: too many synonyms per synonym ring
Cause: too many synonyms for a single preferred term
Action: introduce further distinctions to deepen the hierarchy
DRG-11721: thesaurus string is empty
Cause: no entries in thesaurus
Action: add some entries or drop the thesaurus
DRG-11722: invalid language specification
Cause: language specification cannot be more than 10 characters
Action: reduce language specification to less or equal to 10 char
DRG-11723: phrase cannot be NULL
Cause: you tried to add a NULL phrase to the thesaurus
Action: specify a valid phrase
DRG-11724: phrase string already exists
Cause: phrase with same name exists
Action: use another name
DRG-11725: phrase does not have any synonyms
Cause: you tried to nominate a phrase with no synonyms to be the preferred term, or you tried to drop SYN from a phrase with no synonyms
Action: none
DRG-11726: phrase is not a preferred term
Cause: you tried to remove the preferred term relation from a phrase which is not a preferred term.
Action: none
DRG-11727: phrase does not have any related terms
Cause: you tried to drop a relation which does not exist
Action: none
DRG-11728: phrase does not have any broader terms of this type
Cause: you tried to drop a relation which does not exist
Action: none
DRG-11729: phrase does not have any narrower terms of this type
Cause: you tried to drop a relation which does not exist
Action: none
DRG-11730: relation does not exist
Cause: you tried to drop a relation which does not exist
Action: none
DRG-11731: translation does not exist
Cause: you tried to drop a translation which does not exist
Action: none
DRG-11732: phrase does not have any translations
Cause: you tried to drop translations which does not exists
Action: none
DRG-11733: more than one translation for the term in the specified language
Cause: the term has more than one translation in the specified language
Action: specified a translation
DRG-11801: Continue
Cause: Enquire user to decide if continue is necessary HTTP_ERROR = 100
Action: Upon positive response, continue the original operation
DRG-11802: Switching Protocols
Cause: Telling client a protocol switching just happened HTTP_ERROR = 101
Action: The user agent takes proper actions
DRG-11803: OK
Cause: Telling client things are ok HTTP_ERROR = 200
Action: The user agent takes proper actions
DRG-11804: Created
Cause: Telling client things are created HTTP_ERROR = 201
Action: The user agent takes proper actions
DRG-11805: Accepted
Cause: Telling client things are accepted but not commited HTTP_ERROR = 202
Action: The user agent takes proper actions
DRG-11806: Non-authoritative Information
Cause: The returned metainformation is not the definitive set HTTP_ERROR = 203
Action: The user agent knows the information is Non-authoritative
DRG-11807: No Content
Cause: request has been fulfilled but no new information found HTTP_ERROR = 204
Action: The user agent takes proper actions
DRG-11808: Reset Content
Cause: Telling client to reset the document view HTTP_ERROR = 205
Action: The user agent takes proper actions
DRG-11809: Partial Content
Cause: Telling client document content is a patial content HTTP_ERROR = 206
Action: The user agent takes proper actions
DRG-11810: Partial Update OK
Cause: Telling client document is partially updated HTTP_ERROR = 207
Action: The user agent takes proper actions
DRG-11811: Multiple Choices
Cause: Telling client multiple choices of resources is possible HTTP_ERROR = 300
Action: The user agent takes proper actions
DRG-11812: Moved Permanently
Cause: The URI has been assigned a new permanent URI HTTP_ERROR = 301
Action: The user agent takes proper actions
DRG-11813: Moved Temporarily
Cause: The URI resides temporarily under a different URI. HTTP_ERROR = 302
Action: The user agent takes proper actions
DRG-11814: See Other
Cause: The URI can be found using GET METHOD under a different URI HTTP_ERROR = 303
Action: The user agent takes proper actions
DRG-11815: Not Modified
Cause: Response to conditional GET, indicating document not modified. HTTP_ERROR = 304
Action: The user agent takes proper actions
DRG-11816: Use Proxy
Cause: The client should use specified proxy to repeat the request HTTP_ERROR = 305
Action: The user agent takes proper actions
DRG-11817: Proxy Redirect
Cause: Proxy redirection. Not used HTTP_ERROR = 306
Action: Outdated due to HTTP evolution
DRG-11818: Temporary Redirect
Cause: The resource is temporarily under a different URI. HTTP_ERROR = 307
Action: The takes proper actions
DRG-11819: Bad Request
Cause: The URL syntax is incorrect. Request rejected by server. HTTP_ERROR = 400
Action: The user agent takes proper actions
DRG-11820: Unauthorized
Cause: The request requires further authentication. HTTP_ERROR = 401
Action: The user agent takes proper actions
DRG-11821: Payment Required
Cause: Reserved for future use. HTTP_ERROR = 402
Action: The user agent takes proper actions
DRG-11822: Forbidden
Cause: The server refuses to fulfil the request from client HTTP_ERROR = 403
Action: The user agent takes proper actions
DRG-11823: Not Found
Cause: The server can not find the requested URI HTTP_ERROR = 404
Action: The user agent takes proper actions
DRG-11824: Method Not Allowed
Cause: The user agent specified method not allowed HTTP_ERROR = 405
Action: The user agent reads allow header to decide alternatives.
DRG-11825: Not Acceptable
Cause: Requested resource is not acceptable according to request header HTTP_ERROR = 406
Action: The user agent should query the user for the next action.
DRG-11826: Proxy Authentication Required
Cause: The client must authenticate itself with the proxy. HTTP_ERROR = 407
Action: The user agent takes proper actions
DRG-11827: Request Timeout
Cause: The server is tired of waiting for the requst HTTP_ERROR = 408
Action: The user agent repeat the request
DRG-11828: Conflict
Cause: The request conflicts with the current state of the URI HTTP_ERROR = 409
Action: The user agent takes proper actions
DRG-11829: Gone
Cause: The resource is no longer available and no forwarding address. HTTP_ERROR = 410
Action: The user agent takes proper actions
DRG-11830: Length Required
Cause: The server must receive a content-length header. HTTP_ERROR = 411
Action: The user agent takes proper actions
DRG-11831: Precondition Failed
Cause: Telling the user agent that the resource failed preconditions HTTP_ERROR = 412
Action: The user agent takes proper actions
DRG-11832: Request Entity Too Large
Cause: Request rejected because request entity is too large. HTTP_ERROR = 413
Action: If Retry-After header found, the user agent should retry.
DRG-11833: Request-URI Too Big
Cause: The server is refusing to accept the URI which is too big. HTTP_ERROR = 414
Action: The user agent takes proper actions
DRG-11834: Unsupported Media Type
Cause: The server is refusing the request because of media type HTTP_ERROR = 415
Action: The user agent takes proper actions
DRG-11835: Requested Range Not Satisfiable
Cause: The byte range request can not be satisfied by the resource extent. HTTP_ERROR = 416
Action: The user agent reads content-range header in the response.
DRG-11836: Expectation Failed
Cause: Server can not meet the user agent's expectation. HTTP_ERROR = 417
Action: The user agent takes pro
DRG-11837: Reauthorization Required
Cause: Reserved HTTP_ERROR = 418
Action: Reserverd
DRG-11838: Proxy Reauthentication Required
Cause: Reserved HTTP_ERROR = 419
Action: Reserved
DRG-11839: Internal Server Error
Cause: The server encountered internal error in fulfilling the request. HTTP_ERROR = 500
Action: The user agent takes proper actions
DRG-11840: Not Implemented
Cause: The server can't support a request feature which has yet to be implemented. HTTP_ERROR = 501
Action: The user agent takes proper actions
DRG-11841: Bad Gateway
Cause: In serving the request, the server received invalid response from gateway. HTTP_ERROR = 502
Action: The user agent takes proper actions
DRG-11842: Service Unavailable
Cause: Server overloaded or in maintenance mode. HTTP_ERROR = 503
Action: If retry-after header is in the response, retry the request.
DRG-11843: Gateway Timeout
Cause: Upstream server did not timely respond to the gateway server. HTTP_ERROR = 504
Action: The user agent takes proper actions
DRG-11844: HTTP Version Not Supported
Cause: The HTTP version in the request header is rejected by the server. HTTP_ERROR = 505
Action: The user agent takes proper actions
DRG-11845: No Partial Update
Cause: Reserved HTTP_ERROR = 506
Action: Reserved
DRG-11846: Response Is Stale
Cause: The the user agent knows the returned reponse is stale. HTTP_CACHE_ERROR = 10
Action: The user agent client takes proper actions.
DRG-11847: Revalidation Failed
Cause: User agent's attempt to revalidate a stale response failed. HTTP_CACHE_ERROR = 11
Action: The user agent client takes proper actions
DRG-11848: Disconnected Operation
Cause: The cache is intentionally disconnected for a time period. HTTP_CACHE_ERROR = 12
Action: The user agent client takes proper actions
DRG-11849: Heuristic Expiration
Cause: Cache freshness lifetime and response age both greater than 24 hours. HTTP_CACHE_ERROR = 13
Action: The user agent client takes proper actions
DRG-11850: Transformation Applied
Cause: Telling cache manager, content encoding/media type has been changed in cache. HTTP_CACHE_ERROR = 14
Action: The user agent takes proper actions
DRG-11851: Cache Related Warning
Cause: Arbitrary information about cache to be presented to logger. HTTP_CACHE_ERROR = 99
Action: The user agent client must not take any automated action.
DRG-11852: Can't Locate Remote Host
Cause: connection to remote host failed USER_AGENT_ERROR
Action: The user agent client takes proper actions
DRG-11853: No Host Name Found
Cause: The host name is not specicied in URI. USER_AGENT_ERROR
Action: The user agent client takes proper action.
DRG-11854: No File Name Found Or File Not Accessible
Cause: Unable to open the file specified USER_AGENT_ERROR
Action: The user agent client takes proper actions
DRG-11855: FTP Server Replies
Cause: FTP server responds to the agent request USER_AGENT_ERROR
Action: The user agent client takes proper actions
DRG-11856: FTP Server Doesn't Reply
Cause: No response from FTP server during operation. USER_AGENT_ERROR
Action: The user agent client takes proper actions
DRG-11857: Server Timed Out
Cause: Server operation timed out USER_AGENT_ERROR
Action: The user agent client takes proper actions
DRG-11858: Gopher Server Replies
Cause: Gopher server responds to the agent request. USER_AGENT_ERROR
Action: The user agent client takes proper actions
DRG-11859: Data Transfer Interrupted
Cause: Processing of URL request was interrupted USER_AGENT_ERROR
Action: The user agent client takes proper actions
DRG-11860: Connection Establishment Interrupted
Cause: Connection operation was interupped USER_AGENT_ERROR
Action: The user agent client takes proper actions
DRG-11861: CSO-server Replies
Cause: Telling client things are ok USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11862: This Is Probaly A HTTP Server 0.9 Or Less
Cause: A very old web server USER_AGENT_ERROR
Action: The user agent client takes proper actions
DRG-11863: Bad, Incomplete, Or Unknown Response
Cause: The server is mumbering something not understandable USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11864: Unknown Access Authentication Scheme
Cause: The server is using an unkown access authentication scheme USER_AGENT_ERROR
Action: The user agent client takes proper actions
DRG-11865: News Server Replies
Cause: News Server is responding USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11866: Please Try `ftp://' Instead Of `file://'
Cause: wrong access scheme is used. USER_AGENT_ERROR
Action: The user agent client takes proper actions
DRG-11867: Method Not Suited For Automatic Redirection
Cause: Telling client things are ok USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11868: Too Many Redirections
Cause: The web server setup configured too many redirections USER_AGENT_ERROR
Action: The user agent client should take proper actions
DRG-11869: Premature End Of File Detected
Cause: Detected end of file is unexpected USER_AGENT_ERROR
Action: The user agent client takes proper actions
DRG-11870: Response From WAIS Server Too Large -- Extra Lines Ignored
Cause: Response from WAIS caused buffer overflow USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11871: WAIS Server Doesn't Return Any Data
Cause: Bad WAIS Server USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11872: Can't Connect To WAIS Server
Cause: Connect to WAIS server failed USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11873: System Call Replies
Cause: register what system call replies USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11874: Wrong Or Unknown Access Scheme
Cause: Protocol class is wrongfully connected to ther server USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11875: Access Scheme Is Not Allowed
Cause: Telling client things are ok USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11876: When Your Are Connected, You Can Log In
Cause: Pass information to telnet agent USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11877: This Cache Version Has Expired And Will Be Automatically Reloaded
Cause: Need to tell user that cache entry has been reloaded USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11878: Loading New Rules Must Be Explicitly Acknowledged
Cause: Let user agent client be aware of new rule loading USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-11879: Automatic Proxy Redirection Msut Be Explicitly Acknowledged
Cause: Let user agent client be aware of proxy redirection USER_AGENT_ERROR
Action: The user agent takes proper actions
DRG-12001: Please enter username:
Cause: Prompt user for name W3CLIB_MSG = 0
Action: The user agent client takes proper actions
DRG-12002: Please enter username for proxy authentication:
Cause: Prompt user for name W3CLIB_MSG = 1
Action: The user agent client takes proper actions
DRG-12003: Please enter username for this FTP server:
Cause: Prompt user for name W3CLIB_MSG = 2
Action: The user agent client takes proper actions
DRG-12004: Password:
Cause: Prompt user for password W3CLIB_MSG = 3
Action: The user agent client takes proper actions
DRG-12005: Please give name of file to save in:
Cause: Prompt user for file name W3CLIB_MSG = 4
Action: The user agent client takes proper actions
DRG-12006: Plase enter account:
Cause: Prompt user for account W3CLIB_MSG = 5
Action: The user agent client takes proper actions
DRG-12007: You might not be allowed to use this method here, continue?
Cause: Warn user of deny of service. W3CLIB_MSG = 6
Action: The user agent client takes proper actions
DRG-12008: Location has moved, continue?
Cause: Warn user of location changes. W3CLIB_MSG = 7
Action: The user agent client takes proper actions
DRG-12009: A new set of rules is requested to be added to your setup - continue?
Cause: Warn user of rule changes. W3CLIB_MSG = 8
Action: The user agent client takes proper actions
DRG-12010: This file already exists - replace existing file?
Cause: Warn user of pending replacement W3CLIB_MSG = 9
Action: The user agent client takes proper actions
DRG-12011: Authentication failed - retry?
Cause: Warn user of authentication failure W3CLIB_MSG = 10
Action: The user agent client takes proper actions
DRG-12012: Proxy authentication failed - retry?
Cause: Warn user of proxy authentication failure W3CLIB_MSG = 11
Action: The user agent client takes proper actions
DRG-12013: This method has already been performed - repeat operation?
Cause: Warn user the repetition of previous method used W3CLIB_MSG = 12
Action: The user agent client takes proper actions
DRG-12014: This document is very big - continue operation?
Cause: Warn user of big document processing W3CLIB_MSG = 13
Action: The user agent client takes proper actions
DRG-12015: The source document for this operation has moved - continue?
Cause: Warn user of location changes W3CLIB_MSG = 14
Action: The user agent client takes proper actions
DRG-12016: The target document for this operation has moved - continue?
Cause: Warn user of destination document changes W3CLIB_MSG = 15
Action: The user agent client takes proper actions
DRG-12017: A redirection may change the behavior of this method - proceed anyway?
Cause: Warn user of redirection effects on method W3CLIB_MSG = 16
Action: The user agent client takes proper actions
DRG-12018: Encountered an automatic request for changing proxy - continue?
Cause: Warn user of automatic proxy change W3CLIB_MSG = 17
Action: The user agent client takes proper actions
DRG-12201: section group string already exists
Cause: Section group with the same name already exists
Action: Use another name or delete the existing one first
DRG-12202: error while creating section group
Cause: detect an Oracle error while creating section group
Action: see the accompanying Oracle error and take appropriate action
DRG-12203: section group string does not exist
Cause: section group provided does not exist
Action: provide an existing section group
DRG-12204: error while dropping section group string
Cause: detect an Oracle error while dropping a section group
Action: see the accompanying Oracle error and take appropriate action
DRG-12206: tag string already exists in section group string
Cause: the start tag provided already exists in the same Section
Action: provide another start tag
DRG-12210: error while adding section string
Cause: detect an Oracle error while adding a section
Action: see the accompanying Oracle error and take appropriate action
DRG-12211: section or section id string does not exist
Cause: Section name or Section id to be dropped does not exist
Action: provide an existing Section name or Section id
DRG-12212: error while dropping section string
Cause: detect an Oracle error while dropping a Section
Action: see the accompanying Oracle error and take appropriate action
DRG-12213: cannot create/drop section group or sections for other user
Cause: You can only create/drop section group objects of your own
Action: have the other user create/drop his/her own objects
DRG-12217: tags cannot be more than 64 bytes
Cause: max limit of start and end tag is 64 bytes
Action: provide a shorter start and end tag
DRG-12218: section group name missing
Cause: must provide section group name
Action: provide a section group name when creating Section or section group
DRG-12219: section name missing
Cause: must provide Section name when creating a Section
Action: provide a Section name
DRG-12220: a valid tag must be provided
Cause: must provide tag when adding a section to a section group
Action: provide a tag
DRG-12223: section name string is a reserved name
Cause: you tried to name a section a reserved name
Action: Specify a different name for the section
DRG-12224: use ctx_ddl.create_section_group to create section groups
Cause: you tried to use ctx_ddl.create_preference to create a section group
Action: use ctx_ddl.create_section_group
DRG-12225: this type of section cannot be added to this section group
Cause: You tried to add sections to the null section group, add a stop section to a non-auto section group, or add a zone or field section to the auto section group
Action: Do not add this type of section to this section group
DRG-12226: a field section named string already exists in this section group
Cause: you tried to name an attribute or zone section the same name as an existing field section
Action: use another name
DRG-12227: a zone section named string already exists in this section group
Cause: you tried to name an attribute or field section the same name as an existing zone section
Action: use another name
DRG-12228: maximum number of field sections (string) exceeded
Cause: a section group has more than the maximum number of unique field sections
Action: no action required
DRG-12229: special section string already exists in this section group
Cause: you tried to add a special section which already exists
Action: no action required
DRG-12230: special section name must be one of string
Cause: you tried to add an invalid special section
Action: specify a valid special section
DRG-12231: an attr section named string already exists in this section group
Cause: you tried to name a field or zone section the same name as an existing attribute section
Action: use another name
DRG-12232: invalid attribute tag format
Cause: you specified a tag for use as an attribute tag which did not have the correct format. An attribute tag must have the form TAG@ATTR
Action: use correct format
DRG-12233: xml sections cannot co-exist with other section types
Cause: you tried to add an xml section to a section group or index which already has zone, field, attr, or special sections, or you tried to add a zone, field, attr, or special section to a section group or index which already has xml sections
Action: none
DRG-12300: an index with this column list already exists in the index set
Cause: You tried to add an index to an index set, but an index with the specified column list already exists
Action: none
DRG-12301: index does not exist in index set
Cause: You tried to remove an index from an index set, but the specified index was not found
Action: none
DRG-12302: invalid column list
Cause: You specified an invalid column list -- it may have a syntax error, duplicate columns, or invalid column names
Action: none
DRG-12303: cannot add more than 99 indexes to an index set
Cause: You tried to add too many indexes to the index set
Action: none
DRG-12304: index set string does not exist
Cause: You specified an invalid index set name
Action: none
DRG-12305: column string data type is not supported for index set columns
Cause: You specified a column in the column list of an index of an index set which does not have a valid datatype
Action: use only DATE, NUMBER, CHAR, or VARCHAR2 columns in index column lists
DRG-12306: column string is too long for index set columns
Cause: You specified a column in the column list of an index of an index set which is too long
Action: CHAR and VARCHAR2 columns must be 30 bytes or less max length
DRG-12307: column string is NULL and cannot be indexed
Cause: You tried to index a row where at least one of the meta columns was NULL.
Action: provide a value for the meta column and reindex the row
DRG-12308: use ctx_ddl.create_index_set to create index sets
Cause: you tried to use ctx_ddl.create_preference to create an index set
Action: use ctx_ddl.create_index_set
DRG-12400: template string is empty
Cause: The template is empty.
Action: Check the template was installed successfully.
DRG-12401: invalid template: query within a loop
Cause: A CTX EXEC tag cannot occur within a CTX REPEAT tag.
Action: Remove the CTX EXEC tag.
DRG-12402: error processing template string, line string
Cause: An error occurred when processing a template.
Action: See other errors on the stack and take the appropriate action.
DRG-12403: template string was not found
Cause: The template does not exist.
Action: Check the name of the template and check that it is installed.
DRG-12404: more than one template string found
Cause: More than one template with the same name was found.
Action: Remove templates as appropriate.
DRG-12405: error occurred processing CTX REDIRECT or CTX LABEL tag
Cause: Error in syntax of a tag.
Action: Correct the syntax of the tag.
DRG-12406: invalid CTX EXEC tag attribute (string)
Cause: The specified attribute is incorrectly specified.
Action: Check the sytax of the specified attribute.
DRG-12407: invalid CTX REPEAT tag attribute (string)
Cause: The specified attribute is incorrectly specified.
Action: Check the sytax of the specified attribute.
DRG-12408: invalid variable reference: string.string
Cause: The variable referenced does not exist.
Action: Check the label and column name.
DRG-12409: syntax error for label in string
Cause: The SQL in a CTX EXEC tag has incorrect syntax for a label or label type.
Action: Check the SQL attribute of the CTX EXEC tag.
DRG-12410: could not process CTX EXEC tag
Cause: An error occurred when processing the SQL attribute of a CTX EXEC tag.
Action: See other errors on the stack and take the appropriate action.
DRG-12411: SQL processing error: string
Cause: Error executing SQL from SQL attribute of CTX EXEC tag.
Action: Check the SQL in the SQL attribute.
DRG-12412: missing or invalid Template Processor attribute (string)
Cause: The specified attribute was missing or invalid in a HTML input field.
Action: Check the Template Processor-specific attributes in the INPUT, SELECT, RADIO and CHECKBOX tags of the template.
DRG-12422: write to client failed
Cause: See the following messages.
Action: Contact the administrator.
DRG-12430: mandatory argument missing: string
Cause: This argument is mandatory.
Action: Re-submit the URL with this argument supplied.
DRG-12431: configuration section string not found
Cause: Specified conf argument is invalid.
Action: Re-submit the URL with this argument corrected.
DRG-12432: configuration file string not found or unreadable
Cause: An error occurred when processing the configuration file.
Action: Contact the administrator.
DRG-12433: load of string JDBC driver class failed
Cause: Driver class is invalid.
Action: Contact the administrator to modify configuration.
DRG-12434: connection failed using configuration string information
Cause: Configuration information is not correct.
Action: Contact the administrator to modify configuration.
DRG-12435: highlight table allocation failed
Cause: See the following messages.
Action: Contact the administrator.
DRG-12436: document table allocation failed
Cause: See the following messages.
Action: Contact the administrator.
DRG-12437: highlight table release failed
Cause: See the following messages.
Action: Contact the administrator.
DRG-12438: document table release failed
Cause: See the following messages.
Action: Contact the administrator.
DRG-12439: highlight table read failed
Cause: See the following messages.
Action: Contact the administrator.
DRG-12440: document table read failed
Cause: See the following messages.
Action: Contact the administrator.
DRG-12441: counting the number of highlights failed
Cause: See the following messages.
Action: Contact the administrator.
DRG-12500: stoplist string already exists
Cause: the specified stop list already exists
Action: must remove the duplicate stop list if you want to re-create it.
DRG-12501: null stoplist is not allowed
Cause: the specified stop list is null
Action: mustspecify a valid stop list
DRG-12502: cannot modify stoplists owned by other users
Cause: You can only create/drop Stop List or Stop Word objects of your own
Action: have the other user create/drop his/her own objects
DRG-12503: error while creating or dropping stoplist
Cause: detect an Oracle error while creating Stop List
Action: see the accompanying Oracle error and take appropriate action
DRG-12504: stoplist string does not exist
Cause: the specified stop list does not exist
Action: check that the Stop List is valid
DRG-12505: error while adding or removing a stop word
Cause: detect an Oracle error while adding or removing Stop Word
Action: see the accompanying Oracle error and take appropriate action
DRG-12506: stop word string does not exist in stoplist string
Cause: the specified Stop Sord does not exist
Action: check that the Stop Word is valid
DRG-12507: stop word string already exists in this stoplist
Cause: the specified stop word already exists
Action: must remove the duplicate word if you want to re-create it.
DRG-12508: null stop words are not allowed
Cause: the specified stop word is null
Action: must remove the null stop word if you want to re-create it.
DRG-12509: length of the stop word string exceeded the limit of string bytes
Cause: A stop list entry has exceeded the maximun length
Action: Reduce the length of the stop list entry
DRG-12511: use ctx_ddl.create_stoplist to create stoplists
Cause: you tried to use ctx_ddl.create_preference to create a stoplist
Action: use ctx_ddl.create_stoplist
DRG-12512: invalid stop class string
Cause: you specified an invalid stop class
Action: specify a valid stop class
DRG-12513: valid stop classes are: string
Cause: You specified an invalid stop class
Action: Specify a valid stop class
DRG-12514: languages must be specified for stopwords in a MULTI_STOPLIST
Cause: You tried to add a stopword to a multi_stoplist without specifying the language of the stopword
Action: Specify the language of the stopword
DRG-12515: cannot specify language for stopwords in a BASIC_STOPLIST
Cause: You tried to add a language-specific stopword to a basic stoplist.
Action: Do not specify language for the stopword
DRG-12516: language column must be specified when using the multi stoplist
Cause: you tried to create an index using a multi stoplist but you did not specify a language column
Action: specify a language column
DRG-12517: cannot add stopthemes to a MULTI_STOPLIST
Cause: you tried to add a stoptheme to a MULTI_STOPLIST. This is not supported in this version.
Action: none
DRG-12600: user datastore procedure name contains a semicolon
Cause: the procedure name specified had a semicolon
Action: remove semicolon or rename procedure name. The correct format is PACKAGENAME.PROCEDURE_NAME
DRG-12601: invalid user datastore procedure name: string
Cause: the format of the procedure name is invalid. It should be in the form PACKAGENAME.PROCEDURENAME or PROCEDURENAME
Action: make sure PROCEDURE attr has the format PACKAGENAME.PROCEDURENAME or PROCEDURENAME
DRG-12602: index owner does not have access to user datastore procedure: string
Cause: the index owner does not have execute privilege of the procedure
Action: CTXSYS to grant execute privilege of the procedure to index owner
DRG-12603: CTXSYS does not own user datastore procedure: string
Cause: CTXSYS does not have execute privilege to the user datastore procedure
Action: make sure the package is owned by CTXSYS and the procedure exist
DRG-12604: execution of user datastore procedure has failed
Cause: an error occur while executing the user datastore procedure
Action: check or debug the datastore procedure
DRG-12605: datatype of column number in COLUMNS list is not supported
Cause: one or more of the columns in the column list of the multi datastore are of a type which the multi datastore is unable to process
Action: change the column list of the multi datastore to contain only supported types. PL/SQL functions can be used in the comlumn list to convert unsupported types to supported types.
DRG-12606: error encountered while parsing COLUMNS list
Cause: An oracle error was encountered while parsing the columns list of the multi datastore.
Action: See next error on stack and take appropriate action
DRG-12607: only ctxsys can create MULTI_COLUMN preferences
Cause: In order to create a multi column datastore preference, the effective user must be ctxsys.
Action: contact your DBA to create the preference as ctxsys
DRG-12700: seed word must be a single word
Cause: seed word is not a single word
Action: use a single-word seed word
DRG-12800: Attribute NESTED_TYPE must have owner name as prefix
Cause: the attribute NESTED_TYPE does not have an owner name prefix
Action: reset the attribute NESTED_TYPE to include owner name prefix
DRG-12801: invalid type: string
Cause: invalid nested_type or
Action: check the owner and the type attribute names
DRG-12802: invalid type column: string
Cause: column specified does not exist in the type table
Action: check the type table
DRG-12803: invalid text datatype
Cause: LONG and LONG RAW are not supported in nested table
Action: change text column to a supported data type
DRG-12900: Operation:string for index: string has already been started
Cause: the specified operation has been started
Action: none
DRG-13000: error while adding or removing a sub lexer
Cause: see next error
Action: none
DRG-13001: sub lexer and multi lexer must have the same owner
Cause: you specified a sub lexer which is not owned by the owner of the enclosing multi-lingual lexer preference
Action: specify a sub lexer owned by the owner of the multi-lexer preference
DRG-13002: preference string is not a MULTI_LEXER
Cause: you tried to add a sub lexer to a lexer preference which cannot accept sub lexers. Only multi-lingual lexers can accept sub lexers.
Action: specify a multi lingual lexer
DRG-13003: preference string cannot be used as a sub lexer
Cause: you specified a preference for sub lexer which is not a lexer, or is a multi-lingual lexer
Action: specify a sub lexer which is not a multi-lingual lexer
DRG-13004: language is invalid
Cause: you specified an invalid language for the sub lexer or stopword
Action: specify a valid language -- see NLS Support Guide for a list of valid languages
DRG-13005: alt_value cannot be an NLS language name
Cause: you specified an NLS language name as the alt value
Action: specify a non-NLS value
DRG-13006: sub lexer for this language is not defined
Cause: you tried to remove a sub lexer for a language, but no sub lexer was defined for that language
Action: none
DRG-13007: cannot define an alternate value for the DEFAULT sub lexer
Cause: you tried to define an alternate value for the DEFAULT sub lexer
Action: none
DRG-13008: cannot remove the DEFAULT sub lexer
Cause: you tried to remove the DEFAULT sub lexer
Action: none
DRG-13009: multi lexer preference does not have a DEFAULT sub lexer
Cause: you tried to use a multi lexer preference which does not have a DEFAULT sub lexer defined
Action: add a DEFAULT sub lexer to the multi lexer preference and retry
DRG-13010: alt_value is already used by another sub lexer
Cause: you tried to specify an alt value which is already in use by another sub lexer in the lexer preference
Action: specify a different alt value
DRG-13011: language column must be specified when using the multi lexer
Cause: you tried to create an index using a multi lexer preference, but you did not specify a language column
Action: specify a language column
DRG-13012: language column must be a char, varchar, or varchar2 type
Cause: you specified a language column which is not a char, varchar, or varchar2 type.
Action: specify a language column of correct type
DRG-13100: index is not partitioned
Cause: you attempted to invoke a partition-level operation on an index which is not partitioned
Action: invoke appropriate index-level operation
DRG-13101: partition string does not exist in this index
Cause: you specified a partition name which does not exist
Action: specify correct partition name
DRG-13102: index partition name must be specified
Cause: you attempted to invoke a partition-level operation on a partitioned index but did not specify the partition name
Action: none
DRG-13103: index table string is partitioned
Cause: you attempted to perform an exchange partition including indexes, but one or more of the internal index tables are partitioned.
Action: specify EXCLUDING INDEXES on the exchange partition, then manually rebuild the indexes.
DRG-13104: indexes do not have equivalent settings for string
Cause: you attempted to perform an exchange partition including indexes, but the specified metadata setting is not equivalent across the two indexes, so the data cannot be exchanged
Action: specify EXCLUDING INDEXES on the exchange partition, then manually rebuild the indexes.
DRG-13200: failed to load dictionary file string
Cause: failed to load a dictionary file
Action: check whether the dictionary file exists in $ORACE_HOME/ctx/data/kolx or access permission is available
DRG-13300: document size bigger than string bytes
Cause: size of the document being indexed is larger than the maximum supported size for the VARCHAR2 interface of stored procedure
Action: use the CLOB interface for the stored procedure
DRG-13301: syntax error in token data when expecting string, at line string
Cause: token data returned by the user-defined lexer procedure is incorrect
Action: modify user-defined lexer procedure to return expected data
DRG-13302: number of wildcard offsets must be in the range string..string, at line string
Cause: number of wildcard offsets specified as value for the wildcard attribute does not meet the supported range
Action: modify user-defined lexer query procedure to return valid number of wildcard offsets
DRG-13303: value of wildcard offset must be in the range string..string, at line string
Cause: value of pre-normalized wildcard offset or post-normalized wildcard offset specified as value for the wildcard attribute does not meet the supported range
Action: modify user-defined lexer query procedure to return valid value for wildcard offset
DRG-13304: character referenced by wildcard attribute is not a wildcard character, at line string
Cause: The wildcard attribute value specified the offset of a wildcard character. The character at the specified offset is neither the '%' character nor the '_' character.
Action: Modify user-defined lexer query procedure.
DRG-13305: 'off' attribute value must be in the range string..string, at line string
Cause: value of 'off' attribute does not meet the supported range
Action: modify user-defined lexer index procedure to return valid value for 'off' attribute
DRG-13306: 'len' attribute value must be in the range string..string, at line string
Cause: value of 'len' attribute does not meet the supported range
Action: modify user-defined lexer index procedure to return valid value for 'len' attribute
DRG-13307: 'off'=string and 'len'=string references character past end-of-file of string character document, at line string
Cause: value of 'off' attribute plus value of 'len' attribute is greater than the number of characters in the document
Action: modify user-defined lexer index procedure to return valid values for 'off' and 'len' attributes
DRG-13308: query operator ABOUT not supported by USER_LEXER
Cause: the query contains an ABOUT operator while using USER_LEXER lexer type
Action: remove ABOUT operator from query or use lexer type other than USER_LEXER
DRG-13309: operation not supported by USER_LEXER
Cause: USER_LEXER does not support this operation
Action: stop the operation or use alternate lexer type
DRG-13310: index owner does not have EXECUTE privilege on USER_LEXER stored procedure string
Cause: user CTXSYS did not grant EXECUTE privilege on USER_LEXER stored procedure to the index owner
Action: user CTXSYS grant EXECUTE privilege on USER_LEXER stored procedure to index owner
DRG-13311: USER_LEXER stored procedure name contains a semicolon
Cause: the procedure name contains a semicolon character
Action: remove semicolon from procedure name or rename stored procedure
DRG-13312: user CTXSYS does not own USER_LEXER stored procedure string
Cause: CTXSYS does not have EXECUTE privilege on the USER_LEXER stored procedure
Action: make sure the stored procedure exists and is owned by CTXSYS
DRG-50000: requested size larger than pagesize
Cause: The requested memoery size is larger than page size,
Action: Contact support
DRG-50100: CORE LSF error: string
Cause: detect a CORE LSF error
Action: look up the core error and take appropriate action
DRG-50101: CORE LEM error: string
Cause: detect a CORE LEM error while reading the error stack
Action: Contact support
DRG-50200: Third-party filter internal error
Cause: Third-party filter could not filter this document because of an internal error.
Action: Contact Oracle Support.
DRG-50300: error sending message from server to client
Cause: internal database error or internal Text error
Action: Call customer support
DRG-50301: server error reading request queue
Cause: database error or internal Text error
Action: Call customer support
DRG-50302: server error reading OOB break queue; cannot detect interrupts
Cause: database error or internal Text error
Action: Call customer support
DRG-50303: error in bufout
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50304: error in execute()
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50305: getcmd() called when one of the queue names is NULL
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50400: maximum number of fuzzy match candidates exceeded: string
Cause: Internal error, probably result of large number of indexed words
Action: Contact Oracle support
DRG-50401: failed to retrieve fuzzy match candidates from db: string
Cause: Internal error
Action: Contact Oracle support
DRG-50600: assertion failed
Cause: An internal check-condition has been violated
Action: Contact Oracle support for assistance
DRG-50601: fatal error
Cause: A fatal error has occurred
Action: Contact Oracle support for assistance
DRG-50603: unrecognized operation code string
Cause: Bad operation code was encountered (reached switch default:)
Action: check .h files versions
DRG-50607: failed to obtain column info for cid string
Cause: internal error, probably a bug
Action: call customer support
DRG-50608: unexpected end of data
Cause: internal error, probably a bug
Action: call customer support
DRG-50609: pipe internal error
Cause: internal error, probably a bug
Action: call customer support
DRG-50610: internal error: string
Cause: internal error, probably a bug
Action: call customer support
DRG-50700: unknown command (args=queue, command)
Cause: this is an internal error
Action: Contact Oracle support to report a bug
DRG-50701: error in listener.get_cmd()
Cause: this is an internal error
Action: Contact Oracle support to report a bug
DRG-50702: error in drtlsleep()
Cause: this is an internal error in a testing function
Action: Contact Oracle Support
DRG-50703: listener startup error
Cause: this is an internal error
Action: Contact Oracle support to report a bug
DRG-50704: Net8 listener is not running or cannot start external procedures
Cause: Oracle Text needs to call external code to complete your request, and could not start the extproc agent process.
Action: Start listener if it is configured for external procedures and is not running. If your listener is running, configure it for starting external procedures and restart it. Consult Oracle documentation for details.
DRG-50800: failed to open cursor
Cause: Too many cursors open for internal queries
Action: implement cursor cleanup routine
DRG-50801: failed to parse cursor
Cause: parse error on an internal query
Action: check versions of code
DRG-50802: failed to bind input
Cause: bind error on an internal query
Action: check versions of code
DRG-50803: failed to define output
Cause: define error on an internal query
Action: check versions of code
DRG-50804: failed to exec cursor
Cause: exec error on an internal query
Action: debug code
DRG-50805: failed to close cursor
Cause: cursor close error on an internal query
Action: check versions of code
DRG-50806: failed to rollback
Cause: transaction rollback error
Action: contact support
DRG-50807: failed to commit
Cause: internal error
Action: contact support
DRG-50850: %(1)s
Cause: This is an oracle error
Action: See RDBMS documentation
DRG-50851: SQL execute failed
Cause: failed to execute a sql statement
Action: please report this as a bug
DRG-50852: failed to turn SQL trace on
Cause: internal error,
Action: Please contact Oracle support
DRG-50853: fetch error
Cause: fetch error on an internal query
Action: check versions of code
DRG-50855: logoff fail
Cause: Fail to logoff from the database
Action: check versions of code
DRG-50857: oracle error in string
Cause: this is an informational message
Action: See error
DRG-50858: OCI error: string
Cause: a generic OCI error occurred
Action: Please contact Oracle support
DRG-50859: failed to allocate statement handle
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50860: failed to prepare statement
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50861: failed to obtain type descriptor
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50862: failed to create new Oracle object
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50863: string assignment failed
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50864: number assignment failed
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50865: failed to append to collection
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50866: failed to resize string
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50867: failed to free Oracle object
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50868: failed to free statement handle
Cause: This is an internal error
Action: Contact Oracle Support
DRG-50900: text query parser error on line string, column string
Cause: bad query
Action: fix query
DRG-50901: text query parser syntax error on line string, column string
Cause: bad query
Action: fix query
DRG-50902: unexpected character string
Cause: bad query
Action: fix query
DRG-50903: invalid weight string
Cause: invalid weight
Action: fix query
DRG-50904: weight string outside valid range 0.1 to 10.0
Cause: invalid weight
Action: fix query
DRG-50905: invalid score threshold string
Cause: invalid score threshold
Action: fix query
DRG-50906: score threshold string is not an integer
Cause: invalid score threshold
Action: fix query
DRG-50907: score threshold string outside valid range 1 to 100
Cause: invalid score threshold
Action: fix query
DRG-50908: invalid maximum number of documents string
Cause: invalid maximum number of documents
Action: fix query
DRG-50909: maximum number of documents string is not an integer
Cause: invalid maximum number of documents
Action: fix query
DRG-50910: max documents requested string outside valid range 1 to 65535
Cause: invalid maximum number of documents
Action: fix query
DRG-50911: invalid first document number string
Cause: invalid first document number
Action: fix query
DRG-50912: first document number string is not an integer
Cause: invalid first document number
Action: fix query
DRG-50913: first document requested string is not a positive number
Cause: invalid first document number
Action: fix query
DRG-50914: invalid last document number string
Cause: invalid last document number
Action: fix query
DRG-50915: last document number string is not an integer
Cause: invalid last document number
Action: fix query
DRG-50916: last document string is less than first document
Cause: invalid last document number
Action: fix query
DRG-50917: escape on at end of text query string
Cause: unbalanced escape characters
Action: turn escape off
DRG-50918: mismatched close escape character
Cause: no matching open escape character for close escape
Action: match open and close escapes
DRG-50919: NEAR operand not a phrase, equivalence or another NEAR expression
Cause: invalid operand type for NEAR operator
Action: correct operand type
DRG-50920: part of phrase not itself a phrase or equivalence
Cause: invalid type of expression which is part of phrase
Action: fix query
DRG-50921: EQUIV operand not a word or another EQUIV expression
Cause: invalid operand type for EQUIV operator
Action: correct operand type
DRG-50922: PL/SQL execution failed for string
Cause: PL/SQL function may not exist or is returning bad value
Action: PL/SQL may not exist or is returning bad value
DRG-50923: could not rewrite PL/SQL for execution
Cause: parser internal
Action: call support
DRG-50924: PL/SQL inside PL/SQL not supported
Cause: PL/SQL function call returned another PL/SQL call
Action: remove recursive PL/SQL
DRG-50925: could not parse return value of PL/SQL
Cause: string returned by PL/SQL function could not be parsed
Action: fix PL/SQL function being called
DRG-50926: invalid text query string
Cause: query string empty or made up of invalid characters
Action: fix query
DRG-50927: parser failed on line string on column string
Cause: bug
Action: call support
DRG-50928: reserved failure on line string on column string
Cause: bug
Action: call support
DRG-50929: parser internal on line string on column string
Cause: bug
Action: call support
DRG-50930: parser memory failure on line string on column string
Cause: memory allocation or freeing error
Action: call support
DRG-50931: parser not opened
Cause: bug
Action: call support
DRG-50932: parser preference initialization failed
Cause: bug
Action: call support
DRG-50933: parser hash insert failure
Cause: bug
Action: call support
DRG-50934: parser hash create failure
Cause: bug
Action: call support
DRG-50935: parser component failure
Cause: bug
Action: look for other errors
DRG-50936: query word string is too complex for index
Cause: bug
Action: look for other errors
DRG-50937: query too complex
Cause: query is too complex for our query evaluator
Action: make query smaller
DRG-50938: parser already bound
Cause: internal coding mistake
Action: call support
DRG-50939: parser not set
Cause: bug
Action: call support
DRG-50940: parser not parsed
Cause: bug
Action: call support
DRG-50941: PL/SQL function string cannot be executed
Cause: PL/SQL function may not exist or cannot be executed by user
Action: rewrite PL/SQL function specified in query
DRG-50942: errors: stringstring
Cause: PL/SQL function encountered error -- this is the error message
Action: See error message
DRG-50943: query token too long on line string on column string
Cause: A query token is longer than 256 bytes
Action: Rewrite query
DRG-50944: NEAR operator not supported for theme index
Cause: NEAR operator used in theme index query
Action: Rewrite query without NEAR operator
DRG-50945: Illegal phrase in query for theme index
Cause: Phrase incorrectly defined in theme index query
Action: Rewrite query
DRG-50946: Invalid unary operator for theme index
Cause: Stemming, fuzzy match and soundex not allowed for theme index
Action: Rewrite query
DRG-50947: ABOUT clause not allowed without a theme index
Cause: The query contains an ABOUT clause, but there is no theme index to support it
Action: Rewrite query
DRG-50948: ABOUT clause required in the absence of a text index
Cause: There is no text index, but the query does not contain any about clause. With only a theme index present, each query term must belong to an ABOUT clause
Action: Rewrite query
DRG-50949: too many SQEs
Cause: Too many SQEs to expand
Action: Rewrite query or SQE
DRG-50950: circular SQE found
Cause: Circular SQE reference is found.
Action: Rewrite query or SQE
DRG-50951: Unable to resolve element name for attribute string
Cause: XPATH expression such as A/*/@B or A//@B is not supported.
Action: Rewrite query
DRG-50952: Section is not PATH section group
Cause: XPATH expression has section which is not created using PATH section group.
Action: Rewrite query not to use XPATH expression or create the index with PATH section group
DRG-50953: Unable to determin section name
Cause: XPATH expression should not end with . or *
Action: Rewrite the path expression not to use . or * at the end
DRG-50954: Theme index is required for CTXCAT about queries
Cause: There is no theme index, but the catsearch query contains about clause. You must create a theme index before using ABOUT query against CTXCAT index
Action: create theme index
DRG-51002: unexpected component failure
Cause: Internal error
Action: Contact Oracle support
DRG-51017: unable to open storage buffer for fuzzy match candidates
Cause: Internal error, probably insufficient memory
Action: Contact Oracle support
DRG-51019: unable to open or illegal format for fuzzy match data file: string
Cause: Unable to open OS file containing fuzzy matching information or the file was not of the correct format
Action: Consult the documentation for correct location of the fuzzy match information files and check for file damage
DRG-51020: out of memory in fuzzy matcher
Cause: Cannot allocate more memory
Action: Contact your system adminstrator
DRG-51021: undefined error in fuzzy matcher
Cause: Internal error
Action: Contact Oracle support
DRG-51022: undefined error in stemmer
Cause: Internal error
Action: Contact Oracle support
DRG-51023: stemmer file cannot be opened
Cause: Unable to open OS file containing stemmer lexicon, or the file contents were not correct
Action: Consult documentation for for correct location of the stemmer lexicons and check for file damage
DRG-51024: out of memory in stemmer
Cause: Cannot allocate more memory
Action: Contact your system administrator
DRG-51025: an invalid character was passed to the stemmer
Cause: Invalid character in word input to the stemmer
Action: Remove invalid character from word to be stemmed
DRG-51028: unexpected error in fuzzy match expansion: %(1)
Cause: Internal error
Action: Contact Oracle support
DRG-51029: unexpected error in stemmer expansion: %(1)
Cause: Internal error
Action: Contact Oracle support
DRG-51030: wildcard query expansion resulted in too many terms
Cause: User error
Action: Make wildcard query narrower
DRG-51100: invalid program argument index
Cause: This is an internal error
Action: Contact Oracle Support to report a bug
DRG-51101: argument processing callback failed
Cause: this is an internal error
Action: Contact Oracle support to report a bug
DRG-51200: open keymap failed for index id = string
Cause: Failed to initialize the keymap for the column id specified.
Action: Check index ID. Contact support if caused by internal errors
DRG-51201: failed to perform DDL operation: database object string
Cause: Textkey mapping service failed on DDL operation
Action: Check Oracle error and take corrective action
DRG-51202: invalid key mapping operation mode : string
Cause: invalid keymap mode value found. This is an internal error
Action: Contact Oracle support
DRG-51203: found doc ids without mappings during get maps
Cause: found doc ids without mappings during get mapping by doc ids, the index data and keymap service are out of synch.
Action: Contact Oracle support
DRG-51300: error getting dml Queue lock
Cause: a server must have hung while processing the dml Queue, leaving it locked
Action: Contact Oracle support
DRG-51301: error releasing dml Queue lock
Cause: internal database error, or perhaps someone dropped the lock while we were using it
Action: Contact Oracle support
DRG-51311: DML lock handle previously allocated
Cause: internal error
Action: Contact Oracle support
DRG-51312: DML lock internal error string
Cause: internal error
Action: Contact Oracle support
DRG-51313: timeout while waiting for DML or optimize lock
Cause: most likely an internal error
Action: Contact Oracle support
DRG-51403: New index name not provided by kernel
Cause: this is an internal error
Action: Contact Oracle support
DRG-51801: failed to seek in file: %(1)
Cause: this is an internal error
Action: Contact Oracle support
DRG-51802: failed to read from file: %(1)
Cause: this is an internal error
Action: Contact Oracle support
DRG-51803: failed to open file: %(1)
Cause: this is an internal error
Action: Contact Oracle support
DRG-51804: failed to write to file: %(1)
Cause: this is an internal error
Action: Contact Oracle support
DRG-52100: %(1)s returned internal error code string
Cause: this is an internal error
Action: Contact Oracle support
DRG-52101: an invalid session handle was passed to Oracle Text
Cause: this is an internal error
Action: Contact Oracle support
DRG-52102: an invalid transaction handle was passed to Oracle Text
Cause: this is an internal error
Action: Contact Oracle support
DRG-52103: the Oracle Text environment could not reset
Cause: this is an internal error
Action: Contact Oracle support
DRG-52104: the Oracle Text environment could not initialize
Cause: this is an internal error
Action: Contact Oracle support
DRG-52105: no delete function found
Cause: this is an internal error
Action: Contact Oracle support
DRG-52106: Oracle Text service results could not be committed
Cause: this is an internal error
Action: Contact Oracle support
DRG-52107: ctxkbtc internal error
Cause: this is an internal error
Action: Contact Oracle support
DRG-52108: failed to delete knowledge base user extension
Cause: this is an internal error
Action: check file permissions or contact Oracle support
DRG-52109: error in reading thesaurus
Cause: this is an internal error
Action: Contact Oracle support
DRG-52110: error in writing extended knowledge base
Cause: this is an internal error
Action: Contact Oracle support
DRG-52111: error in knowledge base cache
Cause: this is an internal error
Action: Contact Oracle support
DRG-52112: improper Chinese string string of length number
Cause: this is an internal error
Action: none
DRG-52113: improper Japanese string string of length number
Cause: this is an internal error
Action: none
DRG-52200: invalid state during export
Cause: this is an internal error
Action: Contact Oracle support
DRG-52201: imcompatible Oracle Text versions
Cause: attempting to import an incompatible version of Oracle Text data
Action: make sure source and target Oracle Text versions are compatible
DRG-52202: invalid class name: string
Cause: the specified class name is not valid
Action: Contact Oracle Support
DRG-52203: invalid object name: string
Cause: the specified object name is not valid
Action: Contact Oracle Support
DRG-52204: error while registering index
Cause: this is an internal error
Action: Contact Oracle support
DRG-52205: class string and object string already exists for this index
Cause: duplicate entry of class and object
Action: Contact Oracle support
DRG-52206: error while registering index object
Cause: this is an internal error
Action: Contact Oracle support
DRG-52207: the specified attribute does not exist: string
Cause: This is an internal error
Action: Contact Oracle Support
DRG-52208: the specified attribute already exist: string
Cause: This is an internal error
Action: Contact Oracle Support
DRG-52210: error while registering value for attribute: string
Cause: This is an internal error
Action: Contact Oracle Support


62 LPX-00000 to LPX-00690

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

62 LPX-00000 to LPX-00690

LPX-00000: normal, successful completion
Cause: Normal exit
Action: No action required.
LPX-00001: NULL pointer
Cause: A NULL pointer was detected as an internal error condition.
Action: This is a programming error by the caller of the XML parser. Please contact someone who can fix the problem.
LPX-00002: out of memory
Cause: The operating system has run out of memory.
Action: Make more memory available to the program.
LPX-00003: duplicate entry in hash table
Cause: An internal error has occurred (a key was requested to be placed in a hash table but was already there).
Action: Contact Oracle Support Services and report the error.
LPX-00004: internal error "~s"
Cause: An internal error has occurred.
Action: Contact Oracle Support Services and report the error.
LPX-00005: ~1s buffer overflow, maximum size is ~2u bytes
Cause: A name, quoted string, URL, or other document component was too long.
Action: Restrict the component to the maximum size shown.
LPX-00006: invalid child type for parent node
Cause: An attempt was made to add an invalid node-type to a parent node.
Action: Correct the code.
LPX-00007: unexpected end-of-file encountered
Cause: The documented ended unexpectedly, perhaps due to truncation.
Action: Verify that the document is complete.
LPX-00008: invalid memory callback
Cause: The memory callback structure passed to xmlinit was missing the allocate or free functions (or both).
Action: Provide both functions in the callback structure.
LPX-00011: In line ~1u of ~2s [general entity ~3S]:
Cause: Error message prefixes, not errors themselves. These are the possible banner messages which appear before an XML error to describe the position (line#) and source (buffer or URI) in which the error occurred, as well as the entity's name (if the source is an entity). Parameter entity banner must be at +1 to non-entity banner, general entity at +2 (see lpxerr.c).
Action: No action required. This is not an error message.
LPX-00012: Unicode data alignment error
Cause: An input Unicode (UCS2) datum was not aligned properly.
Action: UCS2 data consists of an array of shorts (ub2) which must be aligned on an even-byte boundary.
LPX-00013: wrong node type
Cause: The wrong node type was given as argument to a DOM call.
Action: Review the failing function call, consult the documentation, and make sure the node types passed as correct.
LPX-00014: context is not clean
Cause: An operation was performed on a context that has already been used (so is not "clean").
Action: Some functions must be performed on a newly initialized context before being used for parsing. For example, setting a shared DTD. Change the code and do the call before parsing.
LPX-00017: ~1sNodeName: <~2S>
Cause: More error message boilerplate.
Action: No action required. This is not an error message.
LPX-00018: internal error "nested open strings"
Cause: An internal error has occurred.
Action: Contact Oracle Support Services and report the error.
LPX-00019: property "~s" unknown
Cause: The named initialization property was unknown
Action: Refer to the documentation for the complete set of init properties.
LPX-00100: root element "~1S" does not match DTD root "~2s"
Cause: Validity Constraint 2.8 failed: "The Name in the document type declaration must match the element type of the root element." *Example: <?xml version="1.0"?> <!DOCTYPE greeting [ <!ELEMENT greeting (#PCDATA)> ]> <salutation>Hello!</salutation> *Explanation: The document's root element, salutation, does not match the root element declared in the DTD (greeting).
Action: Correct the document.
LPX-00101: parameter-entity markup cannot be split up
Cause: Validity Constraint 2.8 failed: "Parameter-entity replacement text must be properly nested with markup declarations." *Example: <?xml version="1.0"?> <!DOCTYPE greeting [ <!ENTITY % e "<!ELEMENT "> %e; greeting (#PCDATA)> ]> <greeting>Hello!</greeting> *Explanation: The parameter entity 'e' contains markup which may not be split up; the entire ELEMENT (or ATTLIST or ENTITY) definition must be present in one piece.
Action: Correct the document.
LPX-00102: standalone document declaration should be "no"
Cause: Validity Constraint 2.9 failed: "Standalone document declaration must have the value 'no' if any external markup declarations contain declarations of:

* attributes with default values - or -

* entities - or -

* attributes with values subject to normalization - or -

* element types with element content"

Action: Correct the document.
LPX-00103: document structure does not match DTD
Cause: Validity Constraint 3 failed: "An element is valid if there is a declaration matching elementdecl where the Name matches the element type, and one of the following holds:

* The declaration matches EMPTY and the element has no content

* The declaration matches children and the sequence of child elements belongs to the language generated by the regular expression in the content model, with optional white space (characters matching the nonterminal S) between each pair of child elements.

* The declaration matches Mixed and the content consists of character data and child elements whose types match names in the content model.

* The declaration matches ANY, and the types of any child elements have been declared."

Action: Correct the document.
LPX-00104: element "~S" is not declared in the DTD
Cause: Validity Constraint 3 failed: The named element has no matching elementdecl in the DTD
Action: Correct the document.
LPX-00105: element "~S" is not empty as required by the DTD
Cause: Validity Constraint 3 failed: The named element is declared as EMPTY in the DTD but contains sub-elements in the document.
Action: Correct the document.
LPX-00106: attribute "~1S" of element "~2S" is undefined
Cause: Validity Constraint 3.1 failed:
Action: Correct the document.
LPX-00107: element "~S" has multiple declarations
Cause: Validity Constraint 3.2 failed: "No element type may be declared more than once."
Action: Correct the DTD.
LPX-00108: parameter-entity parenthetical cannot be split up
Cause: Validity Constraint 3.2.1 failed: "Parameter-entity replacement text must be properly nested with parenthesized groups. For interoperability, if a parameter-entity reference appears in a choice, seq, or Mixed construct, its replacement text should not be empty, and neither the first nor last non-blank character of the replacement text should be a connector (| or ,). *Example: <?xml version="1.0"?> <!DOCTYPE foo [ <!ELEMENT greeting (#PCDATA)> <!ENTITY % e "(#PCDATA|"> <!ELEMENT foo %e; greeting)> ]> <greeting>Hello!</greeting> *Explanation: The parenthetical content of the 'e' entity may not be split up into sections: both open and close parentheses must be in the same declaration.
Action: Correct the DTD.
LPX-00109: duplicate name "~S" in mixed-content declaration
Cause: Validity Constraint 3.2.2 failed: "The same name must not appear more than once in a single mixed-content declaration." *Example: <!ELEMENT p (#PCDATA|a|b|c|d|a)> *Explanation: 'a' occurs more than once in the mixed-content declaration.
Action: Correct the DTD.
LPX-00110: invalid ~1s "~2S" (not a Name)
Cause: Validity Constraint 3.3.1 failed: Given thing is not a Name
Action: Correct the document.
LPX-00111: invalid ~1s "~2S" (not a Nmtoken)
Cause: Validity Constraint 3.3.1 failed: Given thing is not a Nmtoken
Action: Correct the document.
LPX-00112: element "~S" has multiple ID attributes
Cause: Validity Constraint 3.3.1 failed: "No element type may have more than one ID attribute specified."
Action: Correct the document.
LPX-00113: element "~1S" ID attribute "~2S" must be #IMPLIED or #REQUIRED
Cause: Validity Constraint 3.3.1 failed: "An ID attribute must have a declared default of #IMPLIED or #REQUIRED."
Action: Correct the document.
LPX-00114: element "~1S" attribute "~2S" has invalid enumeration value "~3S"
Cause: Validity Constraint 3.3.1 failed: "Values of this type must match one of the Nmtoken tokens in the declaration."
Action: Correct the document.
LPX-00115: element "~1S" is missing required attribute "~2S"
Cause: Validity Constraint 3.3.2 failed: "If the default declaration is the keyword #REQUIRED, then the attribute must be specified for all elements of the type in the attribute-list declaration."
Action: Correct the document.
LPX-00116: element "~1S" attribute "~2S" has invalid value "~3S", must be "~4S"
Cause: Validity Constraint 3.3.2 failed: "If an attribute has a default value declared with the #FIXED keyword, instances of that attribute must match the default value."
Action: Correct the document.
LPX-00118: undefined entity "~S"
Cause: Validity Constraint 4.1 failed: "In a document with an external subset or external parameter entities with "standalone='no'", the Name given in the entity reference must match that in an entity declaration."
Action: Correct the document.
LPX-00119: element "~1S" attribute "~2S" must be an unparsed entity
Cause: The attribute value must be an unparsed entity.
Action: Correct the document.
LPX-00120: entity "~1S" NDATA (notation) "~2S" is undefined
Cause: Entity's NDATA (notation) is undefined
Action: Correct the document.
LPX-00121: undefined notation "~S"
Cause: Notation is not known.
Action: Correct the document.
LPX-00122: undefined ID "~S" in IDREF
Cause: Validity Constraint 3.3.1 failed: "A name must not appear more than once in an XML document as a value of this type; i.e., ID values must uniquely identify the elements which bear them."
Action: Correct the document.
LPX-00123: duplicate ID "~S"
Cause: An ID was used twice, they must be unique.
Action: Correct the document.
LPX-00124: attribute value should be one or more tokens
Cause: An attribute with tokenized type (IDREFS, ENTITIES, NMTOKENS) did not contain any tokens.
Action: Value must contain one or more tokens, separated by spaces.
LPX-00125: duplicate entity "~S" (ignored)
Cause: Warning returned by XmlDomGetDecl when original document did not contain an XMLDecl
Action: This is a warning, not an error. The value XMLERR_NO_DECL is used by the programmer to detect whether a document had an XMLDecl or not. It does not indicate a problem.
LPX-00200: could not convert from encoding ~1s to ~2s
Cause: The conversion cannot be made between the specified encodings.
Action: Choose a data encoding which can represent all expected input encoding (such as a Unicode-based encoding, UTF-8 or UTF-16).
LPX-00201: unknown encoding "~s"
Cause: The specified encoding was not known. It should be an IANA or Oracle encoding name.
Action: Use an appropriate encoding.
LPX-00202: could not open "~s" (error ~u)
Cause: The named input (file, URL, etc) does not exist.
Action: Make sure the named input is available and can be opened.
LPX-00203: could not read from "~s" (error ~u)
Cause: Data could not be read from the named input.
Action: Take appropriate action to allow data to be read.
LPX-00204: syntax error
Cause: A syntax error was found.
Action: Check the XML document line and correct it.
LPX-00205: expected "<!--" at the start of comment
Cause: Bad syntax detected when processing a comment.
Action: Fix the comment syntax.
LPX-00206: invalid CDATA section
Cause: Bad syntax detected when processing CDATA. Proper format is '<![CDATA[' data ']]>'.
Action: Correct the CDATA syntax.
LPX-00207: expected "[" at the start of conditional section
Cause: Bad syntax detected when processing a conditional section.
Action: Fix the conditional section syntax.
LPX-00208: unknown DTD keyword "~s"
Cause: An unknown keyword was found in the DTD.
Action: Use a proper keyword.
LPX-00209: PI names starting with XML are reserved
Cause: Processing instruction starting with XML was found.
Action: Use another name for the processing instruction.
LPX-00210: expected '~1c' instead of '~2c'
Cause: A syntax error was detected.
Action: Use proper syntax.
LPX-00211: attribute default must be REQUIRED, IMPLIED, or FIXED
Cause: Attribute default was invalid.
Action: Default must be REQUIRED, IMPLIED, or FIXED.
LPX-00212: comment must not contain "--"
Cause: A syntax error was detected in the comment.
Action: Use '--' only when specifying the end of the comment.
LPX-00213: comment did not end in "-->"
Cause: A syntax error was detected in the comment.
Action: Be sure to end the comment with '-->'.
LPX-00214: CDATA section did not end in "]]>"
Cause: A syntax error was detected in the CDATA section.
Action: Be sure to end the CDATA section with ']]>'.
LPX-00215: processing instruction did not end in "?>"
Cause: A syntax error was detected in the PI section.
Action: Be sure to end the PI with '?>'.
LPX-00216: invalid character ~1u (~2X)
Cause: An invalid multibyte character was found.
Action: Use only characters allowed by the XML specification.
LPX-00217: invalid character ~1u (~2x)
Cause: An invalid Unicode character was found.
Action: Use only characters allowed by the XML specification.
LPX-00218: invalid character ~1u ('~2c')
Cause: An invalid native (ASCII/EBCDIC) character was found.
Action: Use only characters allowed by the XML specification.
LPX-00219: invalid digit '~c' in character reference
Cause: An invalid digit was found in a character reference.
Action: Character references are either &#DDD; where D's are decimal digits, or &#xHHH; where H's are hexadecimal digits.
LPX-00220: the string "]]>" cannot occur in character data
Cause: Found ']]>' in character data.
Action: Do not use ']]>' in character data.
LPX-00221: the character "<" cannot occur in attribute values
Cause: Found '<' in an attribute value.
Action: Do not use '<' in attribute values.
LPX-00222: error received from SAX callback function
Cause: An error was received from the SAX callback function.
Action: Examine the additional error messages and take corrective action.
LPX-00223: external entity "~s" found in an attribute value
Cause: An external entity reference was found in an attribute value.
Action: Use only references to internal or character entities in attribute values.
LPX-00224: multiple occurrences of attribute "~S" found
Cause: An attribute occurred multiple times in the same start-tag or empty-element tag.
Action: Make sure that the attributes are unique.
LPX-00225: end-element tag "~1S" does not match start-element tag "~2S"
Cause: An element tag was not ended properly.
Action: Make sure that the correct end element tag is used.
LPX-00226: entity "~S" is not declared
Cause: An entity is not declared.
Action: Declare the entity before referencing it.
LPX-00227: entity "~S" is not a parsed entity
Cause: An entity reference contained the name of an unparsed entity.
Action: Only reference parsed entities.
LPX-00228: entity reference "~S" refers to itself
Cause: An entity reference contains a recursive reference to itself.
Action: Modify the contents of the entity reference to remove this recursion.
LPX-00229: input source is empty
Cause: An XML input file has no contents.
Action: The XML file representing a document must contain at least one element.
LPX-00230: invalid character ~1u (~2x) found in a Name or Nmtoken
Cause: An invalid character was found in a NAME or NMTOKEN.
Action: Use only the characters allowed for NAMES and NMTOKENS by the XML specification.
LPX-00231: invalid character ~1u ('~2c') found in a Name or Nmtoken
Cause: An invalid character was found in a NAME or NMTOKEN.
Action: Use only the characters allowed for NAMES and NMTOKENS by the XML specification.
LPX-00232: invalid use of a parameter entity reference
Cause: A parameter entity reference was found in an improper location in the internal DTD subset.
Action: Use a parameter entity reference only where markup declarations can occur in the internal DTD subset, in the external DTD subset, or in an external entity.
LPX-00233: namespace prefixes starting with "xml" are reserved
Cause: Namespace prefix starting with XML was found.
Action: Use another name for the namespace prefix.
LPX-00234: namespace prefix "~S" is not declared
Cause: Namespace prefix is not declared.
Action: Declare the prefix in an attribute list.
LPX-00235: invalid XML version, must be 1.0 or 2.0
Cause: Only versions 1.0 and 2.0 of the XML specification are supported.
Action: Use the 1.0 or 2.0 specification & set version# accordingly.
LPX-00236: invalid character ~1u ('~2c') found in public identifier
Cause: An invalid character was found in a public identifier.
Action: Use only the characters allowed for public identifiers by the XML specification.
LPX-00237: invalid condition section keyword, must be INCLUDE or IGNORE
Cause: A conditional section <![ keyword [ markup ]]> had invalid keyword, must be either "IGNORE" or "INCLUDE"
Action: Correct condition section usage in document.
LPX-00238: unterminated conditional section
Cause: A conditional section was not properly terminated with ]]>.
Action: Verify conditional nesting in document and correct.
LPX-00239: invalid attribute type "~s"
Cause: The attribute type is not valid. Options are CDATA, ID, IDREF, IDREFS, ENTITY, ENTITIES, NMTOKEN, or NMTOKENS.
Action: Check and correct attribute declaration.
LPX-00240: element-start tag is not well formed
Cause: A start-element tag was improperly formed.
Action: Check and correct the start-element syntax.
LPX-00241: entity reference is not well formed
Cause: An entity reference (general or parameter) was not formed properly.
Action: Form entity reference correctly as "&name;" or "%name;".
LPX-00242: invalid use of ampersand ('&') character (use &amp;)
Cause: The ampersand character is used only to start entity or character references.
Action: To include an ampersand character as data, use the built-in &amp; general entity.
LPX-00243: element attribute value must be enclosed in quotes
Cause: An attribute defined in an element's start-tag must be enclosed in single ('') or double ("") quotes.
Action: Enclose the attribute value in quotes.
LPX-00244: invalid use of less-than ('<') character (use &lt;)
Cause: The less-than character ('<') is not permitted as data.
Action: Use the built-in entity &lt; instead. Check for mismatched quotes ("') in case the '<' is part of subsequent markup.
LPX-00245: extra data after end of document
Cause: After the close of the top-level element, more data was found.
Action: The end-element tag for the top-level element must be the last thing in the document.
LPX-00246: missing system ID after public ID
Cause: In an external ID declaration, the public ID literal was not followed by the system ID literal as required.
Action: Provide with public *and* system IDs for 'PUBLIC' type.
LPX-00247: invalid Document Type Declaration (DTD)
Cause: Problems were encountered in the DTD declaration.
Action: Review the DTD and correct the problems.
LPX-00248: invalid entity declaration
Cause: Problems were encountered parsing an entity declaration.
Action: Check and correct the declaration syntax.
LPX-00249: invalid external ID declaration
Cause: Problems were encountered parsing an external ID declaration.
Action: Check and correct the declaration syntax.
LPX-00250: invalid attribute declaration
Cause: Problems were encountered parsing an attribute declaration.
Action: Check and correct the declaration syntax.
LPX-00251: conditional sections are valid only in external DTDs
Cause: A condition section is not permitted in internal DTDs.
Action: Remove the condition section.
LPX-00252: invalid entity replacement-text nesting
Cause: Markup included from an entity must nest/group properly. That is, open/close markup must occur within the same entity. For example, <!DOCTYPE doc [ <!ENTITY e "</foo><foo>"> ]> <doc><foo>&e;</foo></doc> Is invalid since foo's start-tag occurs in the top-level
Action: Examples, such as the ones above, are not permitted.
LPX-00253: missing required version number in XML declaration
Cause: An XML declaration was missing the required version#.
Action: Always provide a version#, which must come first in the declaration. XML is case sensitive, so only "version" (not "Version", and so on) is valid.
LPX-00254: invalid XML declaration
Cause: Problems were encountered parsing an XML declaration.
Action: Check and correct the declaration syntax.
LPX-00255: XML standalone declaration must be "yes" or "no"
Cause: The "standalone" parameter in the XML declaration had an invalid value.
Action: standalone must be set to either "yes" or "no". Case is sensitive, so "Yes", "YES", and so on, are invalid.
LPX-00256: invalid element declaration
Cause: Problems were encountered parsing an element declaration.
Action: Check and correct the declaration.
LPX-00257: invalid children specification in element declaration
Cause: The 'children' specification in an element declaration was invalid.
Action: Check and correct the declaration.
LPX-00258: invalid "Mixed" specification in element declaration
Cause: The 'Mixed' specification in an element declaration was invalid.
Action: Check and correct the declaration.
LPX-00259: invalid notation declaration
Cause: Problems were encountered parsing a notation declaration.
Action: Check and correct the declaration syntax.
LPX-00260: invalid xml:space attribute declaration
Cause: The xml:space attribute must be declared as an enumeration with choices "default" and "preserve". For example, <!ATTLIST foo xml:space (default|preserve) 'preserve').
Action: Declare the special attribute as above.
LPX-00261: invalid URL ~s
Cause: The specified URL was invalid and could not be parsed.
Action: Correct the URL; consult RFC-2396.
LPX-00262: unsupported protocol ~s
Cause: An URL was encountered which requested a protocol not supported by the XML parser. Only HTTP and file are currently allowed.
Action: Make the data available through the filesystem or HTTP.
LPX-00263: couldn't connect to host ~s port ~d
Cause: A TCP connection couldn't be opened to the named host.
Action: Verify the hostname and connectivity to the host.
LPX-00264: send failed to host ~s
Cause: An error occurred trying to send data over a TCP connection.
Action: Verify network connectivity, and so on.
LPX-00265: read failed from to host ~s
Cause: An error occurred trying to read data from a TCP connection.
Action: Verify network connectivity, and so on.
LPX-00266: invalid language specification ~s
Cause: The given language specification was invalid.
Action: Language specification has the format <language>_<territory>.<character set>. For example, "French_France".
LPX-00267: could not resolve relative URL ~s
Cause: The named relative URL couldn't be resolved against its parent.
Action: Make sure the relative makes sense in relation to its parent URL; see RFC-2396 sections 4, 5, and appendix C.
LPX-00268: invalid access method ~1d, must be 0 to ~2d
Cause: The provided access code was not in the valid range.
Action: The code should be one of the XMLACCESS_xxx codes defined in oraxml.h, in the range shown in the error message.
LPX-00269: all three access functions (open/close/read) must be provided
Cause: An attempt was made to set the access method callbacks, but all three functions were not provided.
Action: All three callback functions (open, close, and read) are required. They must all be provided, even if they are stub functions which do nothing.
LPX-00270: FTP error: ~s
Cause: An error was returned from the FTP server while trying to retrieve a file. See the specific message for details.
Action: Corrective action depends on the error.
LPX-00271: FTP login failed: ~s
Cause: The username/password combination was invalid for FTP login.
Action: Specify a valid pair.
LPX-00272: FTP server unavailable: ~s
Cause: The FTP server is unavailable for use.
Action: No action is possible from the client side. See server's error message.
LPX-00273: failed to initialize TCP/IP
Cause: The TCP/IP package could not be initialized.
Action: Check with system administrator to see if this is a configuration problem or a connectivity problem.
LPX-00274: can't import node type
Cause: Some node types (DOCUMENT_NODE & DOCUMENT_TYPE_NODE) cannot be imported with importNode().
Action: No action required.
LPX-00275: can't set output/data encoding AFTER parsing
Cause: Output/data encoding must be set after initialization but BEFORE any parsing has taken place.
Action: Set encoding before parsing any documents.
LPX-00276: bad HTTP/Mime header
Cause: An HTTP reply contained an invalid Mime header.
Action: Verify HTTP reply for accuracy. See RFC 2616.
LPX-00277: no closing quote was seen
Cause: A quoted string was started but not finished.
Action: Put a closing quote in the proper location.
LPX-00278: invalid ~s proxy "~s"
Cause: The proxy specification for the given protocol was invalid.
Action: Check and correct the proxy specification. For HTTP, this is the environment variable "http_proxy".
LPX-00279: invalid no_proxy "~s"
Cause: The no_proxy specification was invalid.
Action: Check and correct it. no_proxy is a comma- or space-separated list of machine or domain names, with an optional port part. If no port part is present, then it applies to all ports on that domain.
LPX-00280: HTTP error ~s
Cause: An HTTP protocol error occurred.
Action: Corrective action depends on the error..
LPX-00281: unsupported encoding "~s"
Cause: The specified encoding is known but not supported by the parser.
Action: Try a different encoding.
LPX-00282: document cannot have both internal/external and shared DTDs
Cause: A parser context which had a shared DTD set was used to parse a document which also contained a DTD. You cannot use both a shared DTD and and internal/external one.
Action: If a shared DTD is to be used, then the documents parsed must not contain or reference a DTD.
LPX-00283: document encoding is ~s-based but default input encoding is not
Cause: The input document was detected to be ASCII (or EBCDIC) based, but no encoding was specified in the XMLDecl and the default input coding was not ASCII (or EBCDIC) based, so could not be applied.
Action: Add an explicit encoding specification to the XMLDecl so the default input encoding is not needed, or pick a default encoding which matches the input document.
LPX-00284: namespace prefix to NULL URI is not allowed
Cause: An element's namespace prefix declarations was for a NULL URI, e.g. <foo xmlns:bar=""/> This is illegal presently in XML 1.0, but will be legal in XML 1.1
Action: Remove erroneous prefix definition.
LPX-00285: invalid Unicode surrogate ~X ~X
Cause: A Unicode document contained an invalid surrogate. If the first (high) surrogate is in the correct range 0xD800 to 0xDBFF, then the second (low) surrogate must be in the range 0xDC00 to 0xDFFF.
Action: Correct the document.
LPX-00300: no name in attribute set
Cause: The name attribute was not found in the attribute-set element.
Action: Add a name attribute for this element.
LPX-00301: error in XPATH evaluation
Cause: The XPATH evaluation returns an error.
Action: Check specified XPATH expression to determine the error.
LPX-00302: Incorrect stylesheet. The node is not valid.
Cause: The child node is of invalid type or has invalid name for this particular location in stylesheet, rendering the stylesheet as invalid XSLT.
Action: Fix the stylesheet by using valid nodes only.
LPX-00303: attribute value "~S" not expected for ~S
Cause: Attribute is found but its value is not the expected value.
Action: Set the attribute value to the correct value.
LPX-00304: input parameter to function is null
Cause: An input parameter passed into this function is null when it is not supposed to.
Action: Make sure the caller function is not passing null for this parameter.
LPX-00305: missing token
Cause: An expected token is not found.
Action: Check the input string to make sure the expected token is present.
LPX-00306: inputed string ended with no corresponding closing '}'
Cause: A closing '}' is expected.
Action: Add the closing '}' to the input string or remove the extra opening '{'.
LPX-00307: namespace prefix ~S used but not declared
Cause: Namespace prefix is used but not declared.
Action: Either declare the namespace or don't use this namespace prefix.
LPX-00308: attribute ~S not found in ~S
Cause: The expected attribute for this node is not found.
Action: Need to add this attribute to the node.
LPX-00309: cannot initialize XPATH
Cause: XPATH context could not be initialized.
Action: Check the initialization function LpxsutInitXpathCtx().
LPX-00310: element ~S not found in ~S
Cause: The expected element is not found.
Action: Check the initialization function LpxsutInitXpathCtx().
LPX-00311: unsupported feature: ~S
Cause: This feature is not supported.
Action: Do not use this feature.
LPX-00312: cannot construct XML PI with content: ~S
Cause: The content of XML PI node might be invalid.
Action: Make necessary changes to make the node valid according to spec.
LPX-00313: cannot construct XML comment with content: ~S
Cause: The content of XML comment node might be invalid.
Action: Make necessary changes to make the node valid according to spec.
LPX-00314: an internal failure occurred
Cause: An internal error occurred in the code.
Action: Contact appropriate developer.
LPX-00315: extension function ~S not supported
Cause: This extension function is not supported.
Action: Either contact appropriate developer for more information or don't use this extension function.
LPX-00316: invalid value ~S for ~S attribute ~S
Cause: The value for the specified attribute is invalid.
Action: Consult the XSL spec, use only legal values.
LPX-00317: undefined decimal-format "~S"
Cause: The named decimal-format is undefined (the name "#default" means the default format).
Action: Define the desired decimal-format before trying to use it.
LPX-00318: duplicate xsl:decimal-format "~S"
Cause: The named decimal-format was declared more than once.
Action: Make sure there is only a single declaration.
LPX-00319: The node specified is not valid
Cause: The node specified is not of expected type.
Action: Use only the nodes of legal type.
LPX-00320: No more attributes can be added to a non empty element
Cause: The element to which an attribute was being added is non empty and hence can not add anymore attributes to it.
Action: Modify the XSLT stylesheet so that all the attributes are added to an element before anything else is added to it. If you absolutely can not do that then select your output method to be DOM based rather then a stream or SAX based output which you are using presently.
LPX-00321: None of the output method (DOM, SAX, Stream) is selected
Cause: User is trying to process an XML file with out selecting any mechanism for output.
Action: User must select one of the output mechanisms (SAX/DOM/Stream) before attempting to process the XML file.
LPX-00322: A doc referred by XSLT stylesheet could not be opened : ~s
Cause: Either an import,include or document() function tried to open a document and failed.
Action: Make sure that document is present and can be opened.
LPX-00323: illegal apply-imports because of no current template: ~s
Cause: apply-imports was used even when there was no current template possibly with in for-each.
Action: Make sure that apply-imports are invoked only if there is a current template and it is not in a xsl:for-each.
LPX-00324: "~S" is not a valid value for the lang attribute of xsl:sort
Cause: An invalid language name was specified for sorting.
Action: Provide a valid value for the lang attribute of xsl:sort.
LPX-00400: an internal error has occurred in XPATH
Cause: An internal error has occurred in XPATH.
Action: Contact the appropriate developer.
LPX-00401: invalid QName in the XSL file
Cause: An invalid QName was passed to the XPATH parser.
Action: See whether there are any invalid QNames in the XSL file.
LPX-00402: invalid axisname in the XSL file
Cause: An invalid axis name was passed to the XPATH parser.
Action: See whether all axis names in the XSL file are correct.
LPX-00403: unmatched quote in the XSL file
Cause: An unmatched quote was found in the XSL file.
Action: Check for unmatched quotes in the XSL file.
LPX-00404: unable to resolve namespace URI
Cause: The namespace URI may not be valid.
Action: Make sure that the name space URIs are valid.
LPX-00405: unable to allocate memory
Cause: May be out of memory.
Action: Try increasing virtual memory.
LPX-00406: object of incorrect type passed to the function
Cause: An object of incorrect type was passed to the XPATH/XSL function.
Action: Do the required conversion before passing in an object of type which is different from the expected type.
LPX-00407: right square bracket missing in the XSL file
Cause: Right square bracket missing in the XSL file.
Action: Check for unmatched square bracket in the XSL file.
LPX-00408: right parenthesis missing in the XSL file
Cause: Right parenthesis missing in the XSL file.
Action: Check for unmatched parenthesis in the XSL file.
LPX-00409: incorrect token encountered while parsing
Cause: An unexpected token encountered while parsing the expression/ pattern.
Action: Check the syntax of the expressions/patterns.
LPX-00410: unable to resolve the variable reference
Cause: Variable reference may not be valid.
Action: Check whether the variable references are valid.
LPX-00411: unknown function name encountered
Cause: The function is not supported at this time or the name is invalid.
Action: Check the function names. If valid and this error occurs, then avoid using them at this time.
LPX-00413: loss of precision due to excessively large numerical constant
Cause: The numerical constant in the XPath expression is too big.
Action: Use a string constant instead if possible.
LPX-00601: Invalid token in: '~S'
Cause: Invalid token in XPath expression.
Action: Check the expression.
LPX-00602: Invalid child element '~1S' of element '~2S'.
Cause: Invalid child element in this stylesheet context.
Action: Check the stylesheet.
LPX-00603: Invalid attribute value '~1S': {element '~2S', attribute '~3S'}.
Cause: Invalid attribute value in this stylesheet context.
Action: Check the stylesheet.
LPX-00604: Invalid attribute value '~1S', for attribute '~2s'.
Cause: Invalid attribute value for this attribute.
Action: Check the stylesheet.
LPX-00605: Invalid attribute '~1S' in element '~2S'.
Cause: Invalid attribute for this element.
Action: Check the stylesheet.
LPX-00606: Missing attribute '~1s' in element '~2S'.
Cause: Missing attribute for this element.
Action: Check the stylesheet.
LPX-00607: Invalid reference: '~S'.
Cause: Invalid variable or parameter or template reference.
Action: Check the stylesheet.
LPX-00608: Repeated declaration of '~1S' in element '~2S'.
Cause: Only one declaration is allowed at this level.
Action: Check the stylesheet.
LPX-00609: Function call with invalid number of arguments in '~1S'.
Cause: Invalid number of arguments.
Action: Check the function signature.
LPX-00651: VM Stack overflow.
Cause: The XML data is too large.
Action: Increase the size of VM stacks in XmlXslVMCreate().
LPX-00652: SAX callback returns with error.
Cause: SAX callback returns an error.
Action: Check the callback function.
LPX-00653: Output attribute '~S' doesn't have a parent element.
Cause: Attribute is generated in a wrong context.
Action: Check the XSLT stylesheet.
LPX-00654: Output namespace attribute '~S' doesn't have a parent element.
Cause: Attribute generated in the wrong context.
Action: Check the XSLT stylesheet.
LPX-00655: Invalid output comment '~S'.
Cause: Invalid comment node.
Action: Check the XSLT stylesheet.
LPX-00656: XSLTVM terminate.
Cause: VM terminates.
Action: No action.
LPX-00657: Invalid output PI '~S'.
Cause: Invalid PI node.
Action: Check the XSLT stylesheet.
LPX-00658: Invalid XSLT object type.
Cause: Invalid object type in XPath evaluation.
Action: Check the XSLT stylesheet.
LPX-00659: Output write failed.
Cause: Write operation failed.
Action: Check the write method.
LPX-00660: Not a well-formed document or external entity.
Cause: The generated document is not well-formed.
Action: Check the XSLT stylesheet.
LPX-00661: Failed to load: '~s'.
Cause: Failed to load a document.
Action: Check the XSLT stylesheet.
LPX-00662: Invalid encoding.
Cause: Invalid encoding specified.
Action: Check the encoding string.
LPX-00663: VM String-Stack overflow.
Cause: The string data is too large.
Action: Increace the size of VM StringStack in XmlXslVMCreate().
LPX-00664: VM Node-Stack overflow.
Cause: Too many XML nodes.
Action: Increace the size of VM NodeStack in XmlXslVMCreate().
LPX-00690: Invalid argument.
Cause: Invalid or missing argument.
Action: Check the function signature.


63 LSX-00001 to LSX-00344

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous 		Go to next page
Next

63 LSX-00001 to LSX-00344

LSX-00001: NULL pointer
Cause: A NULL pointer was detected as an internal error condition.
Action: This is a programming error by the caller of the Schema processor. Contact someone who can fix the problem.
LSX-00002: root element is not <schema>
Cause: The top-level element of an XML Schema must be <schema>.
Action: Correct the Schema; consult the Schema specification.
LSX-00003: invalid attribute "~1S" for element "~2S"
Cause: The named Schema element had an invalid attribute.
Action: Correct the Schema; consult the Schema specification.
LSX-00004: unexpected XML node type
Cause: Schema contains an XML node other than element, text (or CDATA),
Action: Other node types are not permitted; remove them.
LSX-00008: feature "~s" is not implemented
Cause: An attempt was made to use a feature that is not yet implemented.
Action: Make an enhancement request for the feature.
LSX-00009: data missing for type "~S"
Cause: Data is missing for an element or attribute of a simple type.
Action: Add data in the element or attribute.
LSX-00010: extra element(s) at end of "~S"
Cause: Extra elements exist at the end of schema component declarations.
Action: Remove the extra elements.
LSX-00011: internal error: ~s
Cause: Implementation error.
Action: File a bug.
LSX-00013: element "~S" not from Schema of Schemas
Cause: Bogus element exists in the schema file. Its name is not from Schema of Schemas.
Action: Remove the bogus element.
LSX-00014: empty instance document
Cause: Instance document to be Schema validated was empty (no top-level element).
Action: Provide a complete XML instance document.
LSX-00015: failed to parse document
Cause: Failed to parse the schema document using the given URI.
Action: Provide the correct URI and make sure that the schema
LSX-00016: schema and instance document have incompatible character sets
Cause: Parsed schema components were in a simple-type character set while the parsed instance document data was not. A simple-type character set is single-byte, not shift sensitive, and has no linguistic specials in use.
Action: Reinitialize the schema global context with appropriate parser context settings, i.e. pass a parser context with its output encoding set to be a multibyte or Unicode character set.
LSX-00018: invalid schema context
Cause: An invalid schema context was provided to the processor. Multiple schema documents were loaded and assembled into the schema context. At least one of them is not fully valid with respect to a schema corresponding to the Schema for Schemas.
Action: Check the errors reported when schema documents were loaded, mapped, or validated. Correct errors found in the identified schema documents and reload them into a new schema context. Then provide the new schema context to the processor.
LSX-00020: unknown type "~S"
Cause: A specified type was unknown (not defined in any loaded Schemas).
Action: Make sure the type was defined and that the type usage referenced the correct Schema.
LSX-00021: undefined element "~S"
Cause: Element is undefined in the specified namespace.
Action: If the element name is misspelled, correct the spelling.
LSX-00022: unknown namespace prefix "~S"
Cause: Prefix in a QName is undefined in the current scope.
Action: Correct the prefix name if it's misspelled.
LSX-00023: unknown namespace URI "~S"
Cause: Namespace URI is unknown to the schema processor.
Action: Correct the namespace URI if it's misspelled.
LSX-00024: unknown attribute group "~S"
Cause: The name of attribute group is unknown to the schema processor in the current scope.
Action: Correct the name of attribute group if it's misspelled.
LSX-00025: unknown group "~S"
Cause: The name of group is unknown to the schema processor in the current scope.
Action: Correct the name of group if it's misspelled.
LSX-00026: unknown attribute "~S"
Cause: The name of attribute is unknown to the schema processor in the current scope.
Action: Correct the name of attribute if it's misspelled.
LSX-00027: property "~s" unknown
Cause: The named validation property was unknown.
Action: Refer to the documentation for the complete list of validation properties.
LSX-00102: duplicate element "~S"
Cause: Element declaration is not unique within its scope.
Action: Rename the element.
LSX-00103: duplicate group "~S"
Cause: Group declaration is not unique within its scope.
Action: Rename the group.
LSX-00104: duplicate type "~S"
Cause: Type definition is not unique within its scope.
Action: Rename the type.
LSX-00105: duplicate attribute group "~S"
Cause: Attribute group declaration is not unique within its scope.
Action: Rename the attribute group.
LSX-00106: duplicate attribute "~S"
Cause: Attribute declaration is not unique within its scope.
Action: Rename the attribute.
LSX-00110: facet "~S" should have single value attribute
Cause: A facet declaration did not have a value attribute.
Action: Each facet declaration must contain one and only one value attribute.
LSX-00111: type "~S" contains invalid facets
Cause: A specified facet was invalid for a type. Each datatype has a different set of facets which may apply.
Action: Use only applicable facets for the type.
LSX-00112: facet "~S" duplicated
Cause: A facet (other than "enumeration") was specified more than once.
Action: Only the enumeration facet may be used more than once for a type.
LSX-00113: facet "~1S" has invalid value "~2S"
Cause: Facet value contained illegal characters or its value was out of range.
Action: Remove illegal characters.
LSX-00114: facet "~S" not in schema schema
Cause: Facets are not defined in the XMLSchema namespace.
Action: Remove illegal facet declarations.
LSX-00116: mutually exclusive facets are not allowed
Cause: Mutual exclusiveness violations were found for facets. For example, both "length" and either "minLength" or "maxLength" are not allowed to be facets.
Action: Remove the facets that are at fault.
LSX-00117: "minLength" should not be greater than "maxLength"
Cause: The value of "minLength" must be less than or equal to the value of "maxLength".
Action: Correct either "minLength" or "maxLength".
LSX-00118: fixed facet value cannot be changed
Cause: The value of a fixed facet in the base type definition should remain the same.
Action: Remove the fixed facet specification in the parent's type for the erroneous facet component.
LSX-00119: value is not valid restriction of parent's minLength
Cause: There was an error in that minLength was among the members of {facets} of {base type definition} and {value} was less than the {value} of the parent minLength.
Action: Increase the {value} of minLength.
LSX-00120: value is not valid restriction of parent's maxLength
Cause: There was an error in that maxLength was among the members of {facets} of {base type definition} and {value} was greater than the {value} of the parent maxLength.
Action: Increase the {value} of maxLength.
LSX-00121: value is not valid restriction of parent's length
Cause: There was an error in that length was among the members of {facets} of {base type definition} and {value} was not equal to the {value} of the parent length.
Action: Make {value} the same as parent's.
LSX-00122: value is not valid restriction of parent's whiteSpace
Cause: There was an error in that whiteSpace was among the members of {facets} of {base type definition} and at least one of the following conditions was true: 1 {value} is replace or preserve and {value} of the parent whiteSpace is collapse 2 {value} is preserve and the {value} of the parent whiteSpace is replace
Action: Change the {value} of whiteSpace.
LSX-00123: base type is required
Cause: Missing base type declaration in the type definition.
Action: Define a base type.
LSX-00124: "list" element is improperly defined
Cause: A "list" element either must have its "itemType" attribute set or have one of its children be a "simpleType" element, but both conditions cannot exist.
Action: Remove the erroneous condition.
LSX-00125: "restriction" element is improperly defined
Cause: A "restriction" element either must have its "base" attribute set or have one of its children be a "simpleType" element, but both conditions cannot exist.
Action: Remove the erroneous condition.
LSX-00126: facet "~1S" has invalid value "~u"
Cause: Facet value contained illegal characters or its value was out of range.
Action: Remove illegal characters.
LSX-00130: attribute "processContents" has invalid value "~S"
Cause: Attribute "processContents" in the "any" element or "anyAttribute" declaration has an invalid value.
Action: Specify one of the following values: lax, skip, or strict.
LSX-00132: attribute "~1S" has invalid occurrences value "~2S"
Cause: A minOccurs or maxOccurs attribute had an invalid value (not a integer or less than zero).
Action: Use a legal "occurs" value.
LSX-00133: attribute "use" has invalid value "~S"
Cause: A "use" attribute had an invalid value. Choices for "use" are "default", "fixed", "optional", "prohibited", or "required".
Action: Change the attribute to one of the above values.
LSX-00134: attribute "~1S" has invalid qualification "~2S"
Cause: An attribute that specifies qualification (form, attributeFormDefault, elementFormDefault) was invalid; it must be one of "qualified" or "unqualified".
Action: Change the attribute to one of the above values.
LSX-00135: invalid min/max Occurs for <all> element, must be 0/1
Cause: "minOccurs" has a value other than 0/1 or "maxOccurs" has a value other than 1.
Action: Specify 0/1 for "minOccurs" or "maxOccurs".
LSX-00136: "maxOccurs" is less than "minOccurs"
Cause: The value of the "maxOccurs" specification is less than the value of the "minOccurs" specification.
Action: Correct "minOccurs" or "maxOccurs".
LSX-00141: ID type may only be used in attributes
Cause: For backward compatibility with DTD, ID type may only be used in attributes.
Action: Remove the ID type.
LSX-00142: invalid sub-element "~1S" for element "~2S"
Cause: There was an invalid sub-element in the content of either the attribute or the element declaration. This was because the sub-element was either at the wrong position or out of context.
Action: Remove the sub-element or move it to the correct position.
LSX-00143: element "~S" must have type or ref
Cause: A Schema element was declared but was neither type or reference.
Action: One of type or reference must be specified.
LSX-00144: attribute "~1S" invalid derivation-restriction value "~2S"
Cause: An attribute which specifies a derivation-restriction setting (block, content, final) had an invalid value. Choices are "#all", "extension", or "restriction".
Action: Change the attribute to one of the above values.
LSX-00145: attribute "~1S" invalid derived value "~2S"
Cause: A derivedBy attribute had an invalid value. Choices are "extension" or "restriction".
Action: Change the attribute to one of the above values.
LSX-00146: element or attribute is improperly defined
Cause: An element or attribute definition must have either its "type" attribute set or must have one of its children be a "simpleType" or "complexType" element but both conditions cannot exist.
Action: Remove the erroneous condition.
LSX-00147: "~1S" cannot contain "~2S"
Cause: An invalid schema component exists in the current declaration.
Action: Remove the schema component.
LSX-00148: annotation must come first in "~S"
Cause: "annotation" element must be the first in the content.
Action: Make "annotation" the first element.
LSX-00149: duplicated ID specified in "~S"
Cause: An attempt was made to specify two distinct members of {attribute uses}with {attribute declaration}s, both of whose {type definition}s are from ID or are derived from ID.
Action: Declare only one member of the {attribute uses} whose {type definition} is from ID or will be derived from ID.
LSX-00150: attributeGroup reference shouldn't have children
Cause: A reference-to-attributeGroup element has children. It is suppose to be empty except for annotations.
Action: Remove the children.
LSX-00151: invalid combination of attributes "ref" and "name"
Cause: If the item's parent is not <schema>, then either the "ref" or the "name" attribute must be present, but not both. Top-level elements or attributes must have a name.
Action: Specify either the "ref" or "name" attribute.
LSX-00152: only "minOccurs", "maxOccurs", or "id" is allowed
Cause: If the item's parent is not <schema> and "ref" is present, then "complexType", "simpleType", "key", "keyref", "unique", "nillable", "default", "fixed", "form", "block", and "type" must be absent.
Action: Remove the prohibited attribute.
LSX-00153: invalid combination of default and fixed attributes
Cause: It is an error for a declaration to contain both fixed and default attributes.
Action: Remove either the default or the fixed attributes.
LSX-00154: attribute "use" must have its value set to "optional"
Cause: If "default" and "use" are both present, use must have its value set to "optional".
Action: Remove the default attribute or change the value of the "use" attribute.
LSX-00155: invalid use of attribute "ref"
Cause: If the item's parent is not <schema> and the attribute "ref" is present, then the element "simpleType" and the attributes "form" and "type" must be absent.
Action: Remove the prohibited items.
LSX-00156: type is final and no derivations are allowed
Cause: Derivation from a type that is declared to be final occurred.
Action: Remove the final declaration from the base type.
LSX-00157: "~S" is abstract and cannot be used in an instance document
Cause: The element declaration or the type definition was abstract.
Action: When an element is declared to be abstract, a member of that element's substitution group must appear in the instance document. When an element's corresponding type definition is declared as abstract, all instances of that element must use xsi:type to indicate a derived type that is not abstract.
LSX-00158: base type of "~S" must be simple type or primitive datatype
Cause: The derivation constraint was violated.
Action: Use complexType instead of simpleType.
LSX-00159: list content of multiple simple types is not allowed
Cause: Two or more simple types were specified within the list content .
Action: Specify only one simple type.
LSX-00160: invalid substitution group affiliation between "~S" and "~S"
Cause: There was an error in that {substitution group exclusions} prevented substitution group affiliation by type restriction or type extension.
Action: Remove the offending deriving method from the {substitution group exclusions} list.
LSX-00161: disallowed type substitution between "~S" and "~S"
Cause: There was a substituted type whose deriving method falls in the union of the {disallowed substitutions} and the {type definition}'s {prohibited substitutions}.
Action: Remove the offending deriving method from the element's {disallowed substitutions} list or the {type definition}'s {prohibited substitutions} list.
LSX-00162: string "~S" is an invalid default for the complex type
Cause: If the {content type} is a simple type definition, then the string must be valid with regard to the simple type definition as defined by String Valid (3.14.4). If the {content type} is mixed, then the {content type}'s particle must be emptiable as defined by Particle Emptiable (3.9.6). However, one of these conditions was not met, resulting in this error.
Action: Make the default string a valid default with regard to the complex type definition.
LSX-00163: duplicated content specification in "~S"
Cause: There was a duplicate content specification in the children of complexType.
Action: Remove the duplicate content specification.
LSX-00164: no content specified in "~S"
Cause: In a simpleContent specification, either "restriction" or "extension" was not specified as a child.
Action: Add either a "restriction" or an "extension" element information item.
LSX-00165: content type of "~S" must be simple type
Cause: The content type of the type definition was not a simple type definition.
Action: Use complexContent instead of simpleContent .
LSX-00166: both content types must be mixed or both must be element-only
Cause: If the content types of the derived type and base type are not the same simple type definition and the content type of the base type is not empty, then both content types must be mixed or both must be element-only. This was not the case, resulting in this error.
Action: Add attribute mixed="true" or remove it.
LSX-00167: defining form of "~S" must occur at the top level
Cause: The defining form did not occur at the top level of a schema.
Action: Move attributeGroup or group definition to the top level of the schema.
LSX-00168: referring form of "~S" must NOT occur at the top level
Cause: The referring form did not occur within a complex type definition or an attribute group definition.
Action: Move the attributeGroup definition to within a complex type definition or an attribute group definition. Or, move the group definition to within a complex type, restriction, extension, choice, or sequence.
LSX-00169: circular group reference is disallowed outside <redefine>
Cause: There was a circular group reference.
Action: One of the group references needs to be changed to a group definition.
LSX-00170: union must have memberTypes attribute or some simpleType children
Cause: There was no member type definition for the union declaration.
Action: Add memberTypes attribute or simpleType children.
LSX-00171: missing required sub-element "~S"
Cause: The sub-element specified in the error message was required.
Action: Add the required sub-element.
LSX-00172: "~S" is not a valid restriction of "~S"
Cause: The schema component constraint, Derivation Valid (Restriction, Complex) or Particle Valid (Restriction), was violated.
Action: Modify the base type (particle) or the restricted type (particle) definition.
LSX-00173: ~S of ~S type is not a valid restriction of ~S of ~S type
Cause: The schema component constraint, Particle Restriction OK (Elt:Elt -- NameAndTypeOK), was violated.
Action: Modify either or both element declaration particles.
LSX-00174: "~S" is not a valid derivation of "~S"
Cause: The schema component constraint, Derivation Valid (Restriction, simple), (Restriction, complex) or (Extension), was violated.
Action: Modify the base type or the derived type definition.
LSX-00175: a complex base within "simpleContent" must have simple content
Cause: A complex base within "simpleContent" was not restricted to contain only simple content.
Action: Modify the base type or the derived type definition.
LSX-00176: circular reference detected in schema component named "~S"
Cause: An attempt was made to use a circular reference. This is not allowed. For example, it is not possible to return to an element declaration by repeatedly following the {substitution group affiliation} property. Or, within the {particles} of a group there must not be at any depth a particle whose {term} is the group itself.
Action: Modify one of the schema components in the loop.
LSX-00200: element "~S" not empty
Cause: Content of the element must be empty.
Action: Remove any schema components in the content.
LSX-00201: contents of "~S" should be elements only
Cause: Node with type other than "element", "processing instruction", or "comment" exists in the content of the violating element.
Action: Remove the offending nodes.
LSX-00202: contents of "~S" should be text only
Cause: Node with type other than "text", "processing instruction", or "comment" exists in the content of the violating element.
Action: Remove the offending nodes.
LSX-00204: extra data at end of complex element
Cause: Extra nodes exist at the end of an element with a complex type definition.
Action: Remove the offending nodes or check the definition of the complex type.
LSX-00205: element "~1S" value "~2S" is wrong (must be "~3S")
Cause: The element had a value other than its fixed value.
Action: Use the fixed value as its value.
LSX-00206: substitution for element "~S" is disallowed
Cause: An attempt was made to substitute an element that violated a constraint.
Action: Change to a valid new element that can be substituted for the headElement.
LSX-00210: value "~1S" out of range for type "~2S"
Cause: Value is out of range for the data with a specific type.
Action: Fix the value.
LSX-00211: value "~1S" whose fractional digits exceeds ~2d
Cause: Too many fractional digits after the decimal point.
Action: Remove the extra fractional digits.
LSX-00212: value "~1s" whose total digits exceeds ~2d
Cause: Too many digits in the decimal data.
Action: Remove the extra digits.
LSX-00213: only ~1d occurrences of particle "~2S", minimum is ~3d
Cause: Too few occurrences of particles in the node.
Action: Specify more particles.
LSX-00214: too many occurrences of particle "~1S", maximum is ~2d
Cause: Too many occurrences of particles in the node.
Action: Remove extra ones.
LSX-00215: value "~1S" whose total digits exceeds ~2d
Cause: There were too many digits in the decimal data.
Action: Remove the extra digits.
LSX-00220: "~1S" is wrong length, should be ~2d
Cause: Data of simple type has invalid length.
Action: Fix the length of the data.
LSX-00221: "~1S" is too short (minimum length is ~2d)
Cause: The length of the data is too short.
Action: Prepend extra characters (such as zeros or blank characters) to make the data longer.
LSX-00222: "~1S" is too long (maximum length is ~2d)
Cause: The length of the data is too long.
Action: Remove extra characters from the data.
LSX-00229: item type is not a valid type for a list simple type
Cause: The specified item type must not itself be a list type, and must be one of the types identified in [XML Schemas: Datatypes] as a suitable item type for a list simple type.
Action: Change the list schema component's declaration.
LSX-00230: invalid integer "~S"
Cause: Illegal characters exist in the "integer" or its derivative type declarations.
Action: Remove illegal characters.
LSX-00231: invalid unsigned integer "~S"
Cause: Illegal characters exist in the "unsignedLong", "unsignedInt", "unsignedShort", or "unsignedByte" declarations.
Action: Remove illegal characters.
LSX-00232: invalid unsigned long "~S"
Cause: Illegal characters exist in the "unsignedLong" declaration.
Action: Remove illegal characters.
LSX-00233: invalid long "~S"
Cause: Illegal characters exist in the "long" declaration.
Action: Remove illegal characters.
LSX-00234: invalid decimal "~S"
Cause: Illegal characters exist in the "decimal" declaration.
Action: Remove illegal characters.
LSX-00235: invalid URI "~S"
Cause: Invalid URI specification for data of "anyURI" type.
Action: Remove illegal characters.
LSX-00237: invalid Name "~S"
Cause: Invalid XML name.
Action: Remove illegal characters.
LSX-00238: invalid Nmtoken "~S"
Cause: Invalid Nmtoken.
Action: Remove illegal characters.
LSX-00240: bad float "~S"
Cause: Invalid value for "float" type data.
Action: Remove illegal characters.
LSX-00241: bad double "~S"
Cause: Invalid value for "double" type data.
Action: Remove illegal characters.
LSX-00242: bad Boolean "~S"
Cause: Boolean data must have a value from the following set: "1", "0", "true", or "false".
Action: Specify one of "1", "0", "true", or "false".
LSX-00243: invalid date "~S"
Cause: Invalid value for data of "date" type.
Action: Remove illegal characters.
LSX-00244: invalid NCName "~S"
Cause: Invalid value for data of "NCName" type.
Action: Remove illegal characters.
LSX-00245: invalid ID "~S"
Cause: Data specified is not of "NCName" type.
Action: Remove illegal characters.
LSX-00246: invalid QName "~S"
Cause: Invalid value for data of "QName" type.
Action: Remove illegal characters.
LSX-00247: invalid language specification "~S"
Cause: Invalid value for data of "language" type.
Action: Remove illegal characters.
LSX-00248: invalid duration "~S"
Cause: Invalid value for data of "duration" type.
Action: Remove illegal characters.
LSX-00249: invalid date or time "~S"
Cause: Invalid value for data of "dateTime", "time", "gYearMonth", "gYear", "gMonthDay", "gDay", or "gMonth" type.
Action: Remove illegal characters.
LSX-00250: invalid normalizedString "~S"
Cause: Invalid value for data of "normalizedString" type.
Action: Remove illegal characters.
LSX-00251: invalid token "~S"
Cause: Invalid value for data of "token" type.
Action: Remove illegal characters.
LSX-00252: invalid union "~S"
Cause: Data of simple type is not one of the union type.
Action: Use one of the union type as its type.
LSX-00253: branch is empty
Cause: The pattern specification "branch1 | branch2" has either "branch1" or "branch2" missing.
Action: Remove '|' or add either "branch1" or "branch2".
LSX-00255: mismatched parentheses
Cause: ")" found without a matching "(" in a pattern specification.
Action: Add "(" to the pattern specification.
LSX-00256: empty character class expression
Cause: "[]" found when processing a character class expression.
Action: Specify the character group within the brackets.
LSX-00257: atom specification is missing
Cause: A quantifier was found without an atom specification.
Action: Add an atom specification in front of the quantifier.
LSX-00258: invalid escape character
Cause: "x" in "\x" is not a valid escape character.
Action: Change "x" to a valid escape character.
LSX-00259: invalid character found in the pattern
Cause: An unexpected character was found in the pattern.
Action: Fix the pattern.
LSX-00260: unexpected end of pattern
Cause: Something is missing at the end of the pattern.
Action: Fix the pattern.
LSX-00261: invalid character property
Cause: An error occurred when processing the character property. For example, "{" is missing after "\p" or "\P".
Action: Fix the character property.
LSX-00262: attribute "~1S" cannot have complex type "~2S"
Cause: The type of the attribute is "complex".
Action: Specify the type of the attribute to be "simple".
LSX-00263: undefined attribute "~S"
Cause: Violating attribute is not defined in the current scope.
Action: Correct the attribute name if it's misspelled.
LSX-00264: attribute "~S" is prohibited (may not occur)
Cause: Global declarations cannot contain the attributes "ref", "minOccurs", or "maxOccurs", or the use of this attribute is explicitly declared as "prohibited" by the schema.
Action: Remove the attribute.
LSX-00265: attribute "~1S" value "~2S" is wrong (must be "~3S")
Cause: Attribute has a value other than its fixed value.
Action: Use fixed value as its value.
LSX-00266: missing required attribute "~S"
Cause: A required attribute is missing.
Action: Add the required attribute.
LSX-00270: hex-encoded binary has odd length
Cause: Data of "hexBinary" type has odd number of digits.
Action: Add missing digits as appropriate.
LSX-00271: invalid character "~c" in hex-encoded binary
Cause: Data of "hexBinary" type has invalid characters.
Action: Remove illegal characters.
LSX-00272: BASE64-encoded binary grouped improperly (not 4's)
Cause: Number of digits is not a multiple of four.
Action: Add missing digits as appropriate.
LSX-00273: invalid character "~c" in base64-encoded binary
Cause: Data of "base64Binary" type has invalid characters.
Action: Remove illegal characters.
LSX-00274: invalid padding in base64-encoded binary
Cause: Invalid padding characters at the end of data.
Action: Use "=" as the padding characters.
LSX-00280: duplicate ID "~S"
Cause: ID name is not unique within the schema scope.
Action: Rename the ID.
LSX-00281: referenced ID "~S" is not defined
Cause: Referenced ID name is not defined within the schema scope.
Action: Define the ID.
LSX-00282: duplicate notation name "~S"
Cause: The name of the "notation" element is not unique within the schema scope.
Action: Rename the element.
LSX-00283: referenced notation "~S" is not defined
Cause: Referenced notation name is not defined within the schema scope.
Action: Define the element.
LSX-00284: duplicate constraint name "~S"
Cause: Each constraint declaration has a name which exists in a single symbol space for constraints.
Action: Choose a different name.
LSX-00285: referenced key "~S" is not defined
Cause: Referenced key name is not defined within the schema scope.
Action: Define the key.
LSX-00286: duplicate key "~S" for {"~S"}"~S"
Cause: The key value was not unique within its scope.
Action: Change the key value.
LSX-00287: duplicate key "~S"
Cause: The key value was not unique within its scope.
Action: Change the key value.
LSX-00290: invalid enumeration choice "~S"
Cause: The value of the data is not one of the enumeration choice.
Action: Select one of the enumeration choice as its value.
LSX-00291: value "~1S" is less than minimum "~2S" (~3S)
Cause: Data has a value less than required minimum.
Action: Increase the value.
LSX-00292: value "~1S" is greater than maximum "~2S" (~3S)
Cause: Data has a value greater than maximum.
Action: Decrease the value.
LSX-00293: missing one or more fields from element "~S"
Cause: The required fields were missing from the content of the element.
Action: Add the fields.
LSX-00294: field "~S" produced multiple hits
Cause: XPath expressions relative to each element selected by a {selector}are specified by {fields}. These XPath expressions must identify a single node (element or attribute) whose content or value was used in the constraint. This content or value must be of a simple type.
Action: Remove duplicate elements or attributes.
LSX-00295: field element "~S" is not a simple type
Cause: The field element evaluated to a node-set with a member that was not a simple type.
Action: Change the field element's type.
LSX-00300: group must have name or ref but not both
Cause: "ref" or "name" attributes are either both missing or have both been specified.
Action: Specify either "ref", "name", but not both.
LSX-00310: local element or attribute should be namespace qualified
Cause: Element or attribute name is not namespace qualified.
Action: Add prefix or default namespace URI declaration.
LSX-00311: local element or attribute shouldn't be namespace qualified
Cause: Element or attribute name is namespace qualified.
Action: Remove prefix or default namespace URI declaration from itself or ancestors.
LSX-00320: missing required elements in <all>
Cause: Some required elements in "all" particle are missing.
Action: Add the missing elements.
LSX-00330: missing range start character
Cause: Missing range start character in a character range specification.
Action: Add the missing characters.
LSX-00331: missing comma
Cause: A comma is missing in a range specification.
Action: Add the missing characters.
LSX-00332: bad decimal digits in a quantifier specification
Cause: Quatifier has invalid characters.
Action: Remove illegal characters.
LSX-00333: literal "~S" is not valid with respect to the pattern
Cause: Literal is not valid with respect to the pattern.
Action: Choose correct characters in the literal.
LSX-00340: improper namespace value for the imported element
Cause: If the namespace attribute is present, then its actual value must not match the actual value of the enclosing schema's targetNamespace attribute. If the namespace attribute is not present, then the enclosing schema must have a targetNamespace attribute.
Action: Match namespace value.
LSX-00341: ENTITY or ENTITIES type may only be used in attributes
Cause: For compatibility, ENTITY or ENTITIES should be used only on attributes.
Action: Remove the ENTITY or ENTITIES.
LSX-00342: value of attribute "base" must be a complex type definition
Cause: If the "complexContent" alternative is chosen, then the type definition resolved to by the actual value of the attribute "base" must be a complex type definition.
Action: Choose a complex type definition as its base type.
LSX-00343: "~S" is not nillable
Cause: Attribute nillable was set to be "false" in element's declaration.
Action: Remove attribute xsi:nil from the instance document.
LSX-00344: namespace values "~1S" and "~2S" differ
Cause: The targetNamespace specified in the schema document differed from either: a) the value of the enclosing schema's namespace attribute, or b) the value of the namespace attribute identified in the import element information item.
Action: Match the namespace value to the enclosing schema's targetNamespace attribute or the actual value of the namespace attribute identified in the import element information item.


Index

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to previous page
Previous

Index

B I M U V

B

BACKGROUND_DUMP_DEST initialization parameter, 1.8

I

initialization parameters
BACKGROUND_DUMP_DEST, 1.8
USER_DUMP_DEST, 1.8

M

message stacks, 1.5

U

USER_DUMP_DEST initialization parameter, 1.8

V

variable text in messages, 1.4
Previous


Contents

Part Number B10744-01
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback
Go to next page
Next

Contents

Title and Copyright Information

Send Us Your Comments

Preface

Intended Audience
Documentation Accessibility
Related Documents
Conventions

1 Using Messages

Locating Message Documentation
Oracle Database Messages
Product Specific Messages
Operating System-Specific Messages
Accuracy of Messages
Message Format
Recognizing Variable Text in Messages
Message Stacks
Contacting Oracle Support Services
Oracle Exception Messages
Trace Files
The Alert File

2 ORA-00000 to ORA-00830

3 ORA-00910 to ORA-01497

4 ORA-01500 to ORA-02098

5 ORA-02140 to ORA-04099

6 ORA-04930 to ORA-07499

7 ORA-07500 to ORA-09859

8 ORA-09870 to ORA-12100

9 ORA-12150 to ORA-12236

10 ORA-12315 to ORA-12354

11 ORA-12400 to ORA-12497

12 ORA-12500 to ORA-12699

13 ORA-12700 to ORA-19361

14 ORA-19400 to ORA-24276

15 ORA-24280 to ORA-28674

16 ORA-29250 to ORA-32775

17 ORA-32800 to ORA-32846

18 ORA-33000 to ORA-37134

19 ORA-38029 to ORA-39961

20 ORA-40001 to ORA-40273

21 EXP-00000 to EXP-00105

22 IMP-00000 to IMP-00401

23 SQL*Loader-00100 to SQL*Loader-03121

24 KUP-00550 to KUP-11012

25 UDE-00001 to UDE-00053

26 UDI-00001 to UDI-00053

27 DBV-00200 to DBV-00200

28 NID-00001 to NID-00604

29 DGM-16900 to DGM-17002

30 LCD-00100 to LCD-00219

31 QSM-00501 to QSM-02188

32 RMAN-00550 to RMAN-20506

33 LRM-00100 to LRM-00123

34 LFI-00002 to LFI-01523

35 PLS-00049 to PLS-01913

36 PLW-05000 to PLW-07204

37 AMD-00100 to AMD-00160

38 CLSR-00001 to CLSR-06507

39 CLSS-00001 to CLSS-03202

40 PROC-00001 to PROC-00106

41 PROT-00001 to PROT-00807

42 TNS-00000 to TNS-12699

43 NNC-00001 to NNC-00501

44 NNO-00050 to NNO-00854

45 NNL-00001 to NNL-01078

46 NPL-00100 to NPL-00420

47 NNF-00001 to NNF-04009

48 NMP-00001 to NMP-00011

49 NCR-00001 to NCR-04023

50 NZE-28750 to NZE-29249

51 O2F-00301 to O2F-00341

52 O2I-00101 to O2I-00133

53 O2U-00200 to O2U-00212

54 PCB-00001 to PCB-00903

55 PCC-00001 to PCC-01515

56 PCC-02010 to PCC-02451

57 SQL-01075 to SQL-02157

58 AUD-00702 to AUD-00809

59 IMG-00001 to IMG-02014

60 VID-00702 to VID-00714

61 DRG-10000 to DRG-52210

62 LPX-00000 to LPX-00690

63 LSX-00001 to LSX-00344

Index

Go to next page


Oracle Corporation

Copyright Information

Copyright © 1994-2004, Oracle. All rights reserved.

Trademark Information

Oracle is a registered trademark of Oracle Corporation and/or its affiliates. Other names may be trademarks of their respective owners.


Documentation Feedback

We are constantly improving the content and delivery of our documentation. Tell us what you think. Comments sent to infodev_us@oracle.com will be delivered to the appropriate person. The address is for documentation comments only. Contact Oracle Support Services for software support.


Link Target Not Found

The destination you selected is not available in this set of documents. If you're viewing this from a CD, check the product software CD or the OTN documentation site for additional documents. If you're viewing this from OTN, search other document sets.