Oracle9i Database Error Messages -- Contents

 Skip Headers

Table of Contents Image Oracle9i Database Error Messages
Release 2 (9.2)
Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Index
Index
Master Index
Feedback

Go to next page

Contents

Title and Copyright Information

Send Us Your Comments

Preface

Audience
Organization
Related Documentation
Conventions
Documentation Accessibility

Part I Introduction

1 Using Messages

Locating Message Documentation
Oracle Database Server
Product Specific
Operating System-Specific
Accuracy of Messages
Message Format
Recognizing Variable Text in Messages
Message Stacks
Contacting Oracle Support Services
Oracle Exception Messages
Trace Files
The Alert File

Part II Oracle Database Server Messages

2 ORA-00000 to ORA-00899

3 ORA-00900 to ORA-01499

4 ORA-01500 to ORA-02099

5 ORA-02100 to ORA-04099

6 ORA-04100 to ORA-07499

7 ORA-07500 to ORA-09857

8 ORA-09858 to ORA-12299

9 ORA-12300 to ORA-12399

10 ORA-12400 to ORA-12699

11 ORA-12700 to ORA-19399

12 ORA-19400 to ORA-24279

13 ORA-24280 to ORA-29249

14 ORA-29250 to ORA-32799

15 ORA-32800 to ORA-32999

16 ORA-33000 to ORA-65535

Part III Oracle Database Server Utilities Messages

17 Export Messages (EXP)

18 Import Messages (IMP)

19 SQL*Loader Messages (SQL*Loader)

20 External Tables Messages (KUP)

21 DBVERIFY Messages (DBV)

22 DBNEWID Messages (NID)

23 Parameter Messages (LCD)

24 Summary Advisor, Explain Rewrite, and Explain Materialized View Messages (QSM)

25 Recovery Manager Messages (RMAN)

Part IV Core Library Messages

26 Parameter Messages (LRM)

27 BFILE-Related Messages (LFI)

Part V PL/SQL Messages

28 PL/SQL and FIPS Messages (PLS)

Part VI Oracle OLAP Catalog Metadata Messages

29 Oracle OLAP Catalog Metadata Messages (AMD)

Part VII Network Messages

30 Oracle Net Messages (TNS)

31 Oracle Names Client Messages (NNC)

32 Oracle Names Server Messages (NNO)

33 Oracle Names Control Utility Messages (NNL)

34 Oracle Names Server Network Presentation Layer Messages (NPL)

35 External Naming Messages (NNF)

36 Simple Network Management Protocol Messages (NMP)

37 Remote Operation Messages (NCR)

38 Network Security Messages (NZE)

Part VIII Precompiler Messages

39 SQL*Module Messages (MOD)

40 Object Type Translator Type File Messages (O2F)

41 Object Type Translator Initialization Messages (O2I)

42 Object Type Translator Unparser Messages (O2U)

43 Pro*COBOL Messages (PCB)

44 PCF FIPS Messages (PCF)

45 Pro*C/C++ Messages (PCC)

46 SQL Runtime Messages (SQL)

Part IX interMedia Messages

47 interMedia Audio Messages (AUD)

48 interMedia Image Messages (IMG)

49 interMedia Video Messages (VID)

Part X Oracle Text Messages

50 Oracle Text Messages (DRG)

Part XI XML Messages

51 XML Parser Messages (LPX)

52 XML Schema Processor Messages (LSX)

Part XII Oracle Trace Messages

53 Oracle Trace Collection Services Messages (EPC)

Index

Go to next page
Oracle
Copyright © 1996, 2002 Oracle Corporation.
All Rights Reserved.


Oracle9i SQL Reference
Part Number A96540-02
Go to Documentation Home
Home 		Go to Book List
Book List 		Go to Table of Contents
Contents 		Go to Index
Index 		Go to Master Index
Master Index 		Go to Feedback page
Feedback

资料来源

资料来源：Oracle OTN 文档库

收集整理：Snowywolf

整理时间：2003-07

适用版本：Oracle9i SQL Reference, Release 2 (9.2)

版权声明

您可以自由地将此文档复制发行，但请保留此声明页。

请勿将此文档用于任何商业用途。

联系作者

ITPUB号：Snowywolf

E m a i l：Snowywolf2008@yahoo.com.cn

姓 名：李绍俊

雪狼 作品
Oracle
Copyright © 2000, 2002 Oracle Corporation.


Oracle9i Database Error Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Oracle9i

Database Error Messages

Release 2 (9.2)

March 2002

Part No. A96525-01

Oracle9i Database Error Messages, Release 2 (9.2)

Part No. A96525-01

Copyright © 1996, 2002 Oracle Corporation. All rights reserved.

The Programs (which include both the software and documentation) contain proprietary information of Oracle Corporation; they are provided under a license agreement containing restrictions on use and disclosure and are also protected by copyright, patent and other intellectual and industrial property laws. Reverse engineering, disassembly or decompilation of the Programs, except to the extent required to obtain interoperability with other independently created software or as specified by law, is prohibited.

The information contained in this document is subject to change without notice. If you find any problems in the documentation, please report them to us in writing. Oracle Corporation does not warrant that this document is error-free. Except as may be expressly permitted in your license agreement for these Programs, no part of these Programs may be reproduced or transmitted in any form or by any means, electronic or mechanical, for any purpose, without the express written permission of Oracle Corporation.

If the Programs are delivered to the U.S. Government or anyone licensing or using the programs on behalf of the U.S. Government, the following notice is applicable:

Restricted Rights Notice Programs delivered subject to the DOD FAR Supplement are "commercial computer software" and use, duplication, and disclosure of the Programs, including documentation, shall be subject to the licensing restrictions set forth in the applicable Oracle license agreement. Otherwise, Programs delivered subject to the Federal Acquisition Regulations are "restricted computer software" and use, duplication, and disclosure of the Programs shall be subject to the restrictions in FAR 52.227-19, Commercial Computer Software - Restricted Rights (June, 1987). Oracle Corporation, 500 Oracle Parkway, Redwood City, CA 94065.

The Programs are not intended for use in any nuclear, aviation, mass transit, medical, or other inherently dangerous applications. It shall be the licensee's responsibility to take all appropriate fail-safe, backup, redundancy, and other measures to ensure the safe use of such applications if the Programs are used for such purposes, and Oracle Corporation disclaims liability for any damages caused by such use of the Programs.

Oracle is a registered trademark, and ConText, Express, Oracle Names, Oracle Store, Oracle7, Oracle8, Oracle8i, Oracle9i, PL/SQL, Pro*Ada, Pro*C, Pro*C/C++, Pro*COBOL, Pro*FORTRAN, Pro*Pascal, Pro*PL/1, SQL*Net, and SQL*Plus are trademarks or registered trademarks of Oracle Corporation. Other names may be trademarks of their respective owners.

Go to previous page Go to next page


Preface

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Preface

This manual describes error messages that may appear while using products that are part of Oracle. Each message listing in the manual contains the message statement, an explanation of the probable causes of the message, and a recommended action. If the message is a warning or indicates that an error occurred, the message listing indicates a corrective action.

This preface contains these topics:

  • Audience
  • Organization
  • Related Documentation
  • Conventions
  • Documentation Accessibility

Audience

Oracle9i Database Error Messages is intended for all Oracle users.

Organization

This document contains:

Part I, "Introduction"

Chapter 1, "Using Messages"

This chapter gives you general information and helpful tips about error messages.

Part II, "Oracle Database Server Messages"

Chapter 2, "ORA-00000 to ORA-00899"

This chapter lists error messages generated by the Oracle database server in the range ORA-00000 to ORA-00899.

Chapter 3, "ORA-00900 to ORA-01499"

This chapter lists error messages generated by the Oracle database server in the range ORA-00900 to ORA-01499.

Chapter 4, "ORA-01500 to ORA-02099"

This chapter lists error messages generated by the Oracle database server in the range ORA-01500 to ORA-02099.

Chapter 5, "ORA-02100 to ORA-04099"

This chapter lists error messages generated by the Oracle database server in the range ORA-02100 to ORA-04099.

Chapter 6, "ORA-04100 to ORA-07499"

This chapter lists error messages generated by the Oracle database server in the range ORA-04100 to ORA-07499.

Chapter 7, "ORA-07500 to ORA-09857"

This chapter lists error messages generated by the Oracle database server in the range ORA-07500 to ORA-09857.

Chapter 8, "ORA-09858 to ORA-12299"

This chapter lists error messages generated by the Oracle database server in the range ORA-09858 to ORA-12299.

Chapter 9, "ORA-12300 to ORA-12399"

This chapter lists error messages generated by the Oracle database server in the range ORA-12300 to ORA-12399.

Chapter 10, "ORA-12400 to ORA-12699"

This chapter lists error messages generated by the Oracle database server in the range ORA-12400 to ORA-12699.

Chapter 11, "ORA-12700 to ORA-19399"

This chapter lists error messages generated by the Oracle database server in the range ORA-12700 to ORA-19399.

Chapter 12, "ORA-19400 to ORA-24279"

This chapter lists error messages generated by the Oracle database server in the range ORA-19400 to ORA-24279.

Chapter 13, "ORA-24280 to ORA-29249"

This chapter lists error messages generated by the Oracle database server in the range ORA-24280 to ORA-29249.

Chapter 14, "ORA-29250 to ORA-32799"

This chapter lists error messages generated by the Oracle database server in the range ORA-29250 to ORA-32799.

Chapter 15, "ORA-32800 to ORA-32999"

This chapter lists error messages generated by the Oracle database server in the range ORA-32800 to ORA-32999.

Chapter 16, "ORA-33000 to ORA-65535"

This chapter lists error messages generated by the Oracle database server in the range ORA-33000 to ORA-65535.

Part III, "Oracle Database Server Utilities Messages"

Chapter 17, "Export Messages (EXP)"

This chapter lists error messages generated by the Export utility.

Chapter 18, "Import Messages (IMP)"

This chapter lists error messages generated by the Import utility.

Chapter 19, "SQL*Loader Messages (SQL*Loader)"

This chapter lists error messages generated by the SQL*Loader utility.

Chapter 20, "External Tables Messages (KUP)"

This chapter lists error messages generated by the external tables feature.

Chapter 21, "DBVERIFY Messages (DBV)"

This chapter lists error messages generated by the DBVERIFY utility.

Chapter 22, "DBNEWID Messages (NID)"

This chapter lists error messages generated by the DBNEWID utility.

Chapter 23, "Parameter Messages (LCD)"

This chapter lists parameter error messages.

Chapter 24, "Summary Advisor, Explain Rewrite, and Explain Materialized View Messages (QSM)"

This chapter lists Summary Advisor, Explain Rewrite, and Explain Materialized View error messages.

Chapter 25, "Recovery Manager Messages (RMAN)"

This chapter lists Recovery Manager messages.

Part IV, "Core Library Messages"

Chapter 26, "Parameter Messages (LRM)"

This chapter lists parameter error messages.

Chapter 27, "BFILE-Related Messages (LFI)"

Part V, "PL/SQL Messages"

Chapter 28, "PL/SQL and FIPS Messages (PLS)"

This chapter lists error messages generated by PL/SQL.

Part VI, "Oracle OLAP Catalog Metadata Messages"

Chapter 29, "Oracle OLAP Catalog Metadata Messages (AMD)"

This chapter lists Oracle OLAP Catalog Metadata messages.

Part VII, "Network Messages"

Chapter 30, "Oracle Net Messages (TNS)"
Chapter 31, "Oracle Names Client Messages (NNC)"
Chapter 32, "Oracle Names Server Messages (NNO)"
Chapter 33, "Oracle Names Control Utility Messages (NNL)"
Chapter 34, "Oracle Names Server Network Presentation Layer Messages (NPL)"
Chapter 35, "External Naming Messages (NNF)"
Chapter 36, "Simple Network Management Protocol Messages (NMP)"
Chapter 37, "Remote Operation Messages (NCR)"
Chapter 38, "Network Security Messages (NZE)"

Part VIII, "Precompiler Messages"

Chapter 39, "SQL*Module Messages (MOD)"

This chapter lists error messages generated by SQL*Module.

Chapter 40, "Object Type Translator Type File Messages (O2F)"
Chapter 41, "Object Type Translator Initialization Messages (O2I)"
Chapter 42, "Object Type Translator Unparser Messages (O2U)"
Chapter 43, "Pro*COBOL Messages (PCB)"
Chapter 44, "PCF FIPS Messages (PCF)"
Chapter 45, "Pro*C/C++ Messages (PCC)"

This chapter lists error messages generated by the Pro*C/C++ precompilers.

Chapter 46, "SQL Runtime Messages (SQL)"

Part IX, "interMedia Messages"

Chapter 47, "interMedia Audio Messages (AUD)"
Chapter 48, "interMedia Image Messages (IMG)"
Chapter 49, "interMedia Video Messages (VID)"

Part X, "Oracle Text Messages"

Chapter 50, "Oracle Text Messages (DRG)"

This chapter lists Oracle Text messages.

Part XI, "XML Messages"

Chapter 51, "XML Parser Messages (LPX)"

This chapter lists messages generated by the XML Parser.

Chapter 52, "XML Schema Processor Messages (LSX)"

This chapter lists messages generated by the XML Schema Processor.

Part XII, "Oracle Trace Messages"

Chapter 53, "Oracle Trace Collection Services Messages (EPC)"

Related Documentation

For more information, see these Oracle resources:

  • Oracle9i Database Concepts for general information about the Oracle database server and how it works
  • Oracle9i Database Administrator's Guide and the Oracle9i User-Managed Backup and Recovery Guide for information about administering the Oracle database server
  • Oracle9i Application Developer's Guide - Fundamentals, Oracle9i Supplied PL/SQL Packages and Types Reference, Oracle9i Application Developer's Guide - Large Objects (LOBs), and the Oracle9i Application Developer's Guide - Advanced Queuing for information about developing database applications within the Oracle database server
  • Oracle9i Database Migration for the procedures for upgrading an Oracle database to the latest release of the Oracle database server
  • Oracle9i SQL Reference for information on Oracle's SQL commands and functions
  • Oracle9i Database Utilities for information about the utilities bundled with the Oracle database server, including Export, Import, and SQL*Loader
  • Oracle9i Net Services Administrator's Guide for information about Oracle Net Services
  • Oracle Advanced Security Administrator's Guide for information about data encryption, external authentication services, and Oracle DCE integration, all included in the Oracle Advanced Networking Option
  • For information specific to the Oracle Server working on your host operating system, see your operating system-specific Oracle documentation (specific book titles vary by operating system) and system release bulletins, if available.

Many of the examples in this book use the sample schemas of the seed database, which is installed by default when you install Oracle. Refer to Oracle9i Sample Schemas for information on how these schemas were created and how you can use them yourself.

In North America, printed documentation is available for sale in the Oracle Store at

http://oraclestore.oracle.com/

Customers in Europe, the Middle East, and Africa (EMEA) can purchase documentation from

http://www.oraclebookshop.com/

Other customers can contact their Oracle representative to purchase printed documentation.

To download free release notes, installation documentation, white papers, or other collateral, please visit the Oracle Technology Network (OTN). You must register online before using OTN; registration is free and can be done at

http://otn.oracle.com/admin/account/membership.html

If you already have a username and password for OTN, then you can go directly to the documentation section of the OTN Web site at

http://otn.oracle.com/docs/index.htm

To access the database documentation search engine directly, please visit

http://tahiti.oracle.com

Conventions

This section describes the conventions used in the text and code examples of this documentation set. It describes:

  • Conventions in Text
  • Conventions in Code Examples
  • Conventions for Microsoft Windows Operating Systems

Conventions in Text

We use various conventions in text to help you more quickly identify special terms. The following table describes those conventions and provides examples of their use.

Convention Meaning Example

Bold

Bold typeface indicates terms that are defined in the text or terms that appear in a glossary, or both.

When you specify this clause, you create an index-organized table.

Italics

Italic typeface indicates book titles or emphasis.

Oracle9i Database Concepts

Ensure that the recovery catalog and target database do not reside on the same disk.

UPPERCASE monospace (fixed-width) font

Uppercase monospace typeface indicates elements supplied by the system. Such elements include parameters, privileges, datatypes, RMAN keywords, SQL keywords, SQL*Plus or utility commands, packages and methods, as well as system-supplied column names, database objects and structures, usernames, and roles.

You can specify this clause only for a NUMBER column.

You can back up the database by using the BACKUP command.

Query the TABLE_NAME column in the USER_TABLES data dictionary view.

Use the DBMS_STATS.GENERATE_STATS procedure.

lowercase monospace (fixed-width) font

Lowercase monospace typeface indicates executables, filenames, directory names, and sample user-supplied elements. Such elements include computer and database names, net service names, and connect identifiers, as well as user-supplied database objects and structures, column names, packages and classes, usernames and roles, program units, and parameter values.

Note: Some programmatic elements use a mixture of UPPERCASE and lowercase. Enter these elements as shown.

Enter sqlplus to open SQL*Plus.

The password is specified in the orapwd file.

Back up the datafiles and control files in the /disk1/oracle/dbs directory.

The department_id, department_name, and location_id columns are in the hr.departments table.

Set the QUERY_REWRITE_ENABLED initialization parameter to true.

Connect as oe user.

The JRepUtil class implements these methods.

lowercase italic monospace (fixed-width) font

Lowercase italic monospace font represents placeholders or variables.

You can specify the parallel_clause.

Run U old_release.SQL where old_release refers to the release you installed prior to upgrading.

Conventions in Code Examples

Code examples illustrate SQL, PL/SQL, SQL*Plus, or other command-line statements. They are displayed in a monospace (fixed-width) font and separated from normal text as shown in this example:

SELECT username FROM dba_users WHERE username = 'MIGRATE';

The following table describes typographic conventions used in code examples and provides examples of their use.

Convention Meaning Example
[ ]

Brackets enclose one or more optional items. Do not enter the brackets.

DECIMAL (digits [ , precision ])
{ }

Braces enclose two or more items, one of which is required. Do not enter the braces.

{ENABLE | DISABLE}
|

A vertical bar represents a choice of two or more options within brackets or braces. Enter one of the options. Do not enter the vertical bar.

{ENABLE | DISABLE}[COMPRESS | NOCOMPRESS]
...

Horizontal ellipsis points indicate either:

  • That we have omitted parts of the code that are not directly related to the example
  • That you can repeat a portion of the code
CREATE TABLE ... AS subquery;SELECT col1, col2, ... , coln FROM employees;
 . . .

Vertical ellipsis points indicate that we have omitted several lines of code not directly related to the example.

SQL> SELECT NAME FROM V$DATAFILE;NAME------------------------------------/fsl/dbs/tbs_01.dbf/fs1/dbs/tbs_02.dbf.../fsl/dbs/tbs_09.dbf9 rows selected.

Other notation

You must enter symbols other than brackets, braces, vertical bars, and ellipsis points as shown.

acctbal NUMBER(11,2);acct    CONSTANT NUMBER(4) := 3;
Italics

Italicized text indicates placeholders or variables for which you must supply particular values.

CONNECT SYSTEM/system_passwordDB_NAME = database_name
UPPERCASE

Uppercase typeface indicates elements supplied by the system. We show these terms in uppercase in order to distinguish them from terms you define. Unless terms appear in brackets, enter them in the order and with the spelling shown. However, because these terms are not case sensitive, you can enter them in lowercase.

SELECT last_name, employee_id FROM employees;SELECT * FROM USER_TABLES;DROP TABLE hr.employees;
lowercase

Lowercase typeface indicates programmatic elements that you supply. For example, lowercase indicates names of tables, columns, or files.

Note: Some programmatic elements use a mixture of UPPERCASE and lowercase. Enter these elements as shown.

SELECT last_name, employee_id FROM employees;sqlplus hr/hrCREATE USER mjones IDENTIFIED BY ty3MU9;

Conventions for Microsoft Windows Operating Systems

The following table describes conventions for Microsoft Windows operating systems and provides examples of their use.

Convention Meaning Example

Choose Start >

How to start a program.

To start the Oracle Database Configuration Assistant, choose Start > Programs > Oracle - HOME_NAME > Configuration and Migration Tools > Database Configuration Assistant.

File and directory names

File and directory names are not case sensitive. The following special characters are not allowed: left angle bracket (<), right angle bracket (>), colon (:), double quotation marks ("), slash (/), pipe (|), and dash (-). The special character backslash (\) is treated as an element separator, even when it appears in quotes. If the file name begins with \\, then Windows assumes it uses the Universal Naming Convention.

c:\winnt"\"system32 is the same as C:\WINNT\SYSTEM32

C:\>

Represents the Windows command prompt of the current hard disk drive. The escape character in a command prompt is the caret (^). Your prompt reflects the subdirectory in which you are working. Referred to as the command prompt in this manual.

C:\oracle\oradata>

The backslash (\) special character is sometimes required as an escape character for the double quotation mark (") special character at the Windows command prompt. Parentheses and the single quotation mark (') do not require an escape character. Refer to your Windows operating system documentation for more information on escape and special characters.

C:\>exp scott/tiger TABLES=emp QUERY=\"WHERE job='SALESMAN' and sal<1600\"

C:\>imp SYSTEM/password FROMUSER=scott TABLES=(emp, dept)

HOME_NAME

Represents the Oracle home name. The home name can be up to 16 alphanumeric characters. The only special character allowed in the home name is the underscore.

C:\> net start Oracle HOME_NAME TNSListener

ORACLE_HOME and ORACLE_BASE

In releases prior to Oracle8i release 8.1.3, when you installed Oracle components, all subdirectories were located under a top level ORACLE_HOME directory that by default used one of the following names:

  • C:\orant for Windows NT
  • C:\orawin98 for Windows 98

This release complies with Optimal Flexible Architecture (OFA) guidelines. All subdirectories are not under a top level ORACLE_HOME directory. There is a top level directory called ORACLE_BASE that by default is C:\oracle. If you install Oracle9i release 1 (9.0.1) on a computer with no other Oracle software installed, then the default setting for the first Oracle home directory is C:\oracle\ora90. The Oracle home directory is located directly under ORACLE_BASE.

All directory path examples in this guide follow OFA conventions.

Refer to Oracle9i Database Getting Started for Windows for additional information about OFA compliances and for information about installing Oracle products in non-OFA compliant directories.

Go to the ORACLE_BASE\ORACLE_HOME\rdbms\admin directory.

Documentation Accessibility

Our goal is to make Oracle products, services, and supporting documentation accessible, with good usability, to the disabled community. To that end, our documentation includes features that make information available to users of assistive technology. This documentation is available in HTML format, and contains markup to facilitate access by the disabled community. Standards will continue to evolve over time, and Oracle Corporation is actively engaged with other market-leading technology vendors to address technical obstacles so that our documentation can be accessible to all of our customers. For additional information, visit the Oracle Accessibility Program Web site at

http://www.oracle.com/accessibility/
Accessibility of Code Examples in Documentation

JAWS, a Windows screen reader, may not always correctly read the code examples in this document. The conventions for writing code require that closing braces should appear on an otherwise empty line; however, JAWS may not always read a line of text that consists solely of a bracket or brace.

Accessibility of Links to External Web Sites in Documentation

This documentation may contain links to Web sites of other companies or organizations that Oracle Corporation does not own or control. Oracle Corporation neither evaluates nor makes any representations regarding the accessibility of these Web sites.


Send Us Your Comments

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Send Us Your Comments

Oracle9i Database Error Messages, Release 2 (9.2)

Part No. A96525-01

Oracle Corporation welcomes your comments and suggestions on the quality and usefulness of this document. Your input is an important part of the information used for revision.

  • Did you find any errors?
  • Is the information clearly presented?
  • Do you need more information? If so, where?
  • Are the examples correct? Do you need more examples?
  • What features did you like most?

If you find any errors or have any other suggestions for improvement, please indicate the document title and part number, and the chapter, section, and page number (if available). You can send comments to us in the following ways:

  • Electronic mail: infodev_us@oracle.com
  • FAX: (650) 506-7227 Attn: Server Technologies Documentation Manager
  • Postal service:
    Oracle Corporation
    Server Technologies Documentation
    500 Oracle Parkway, Mailstop 4op11
    Redwood Shores, CA 94065
    USA

If you would like a reply, please give your name, address, telephone number, and (optionally) electronic mail address.

If you have problems with the software, please contact your local Oracle Support Services.


Introduction

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Part I
Introduction

This part contains the following chapter:

  • Chapter 1, "Using Messages"


Using Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

1
Using Messages

This chapter gives you general information and helpful tips about error messages. This chapter covers the following topics:

  • Locating Message Documentation
  • Accuracy of Messages
  • Message Format
  • Recognizing Variable Text in Messages
  • Message Stacks
  • Contacting Oracle Support Services
  • Oracle Exception Messages
  • Trace Files
  • The Alert File

Locating Message Documentation

Oracle Database Server

These messages are generated by the Oracle database server when running any Oracle program. This manual documents messages that are common across Oracle products and tools.

Product Specific

These messages are specific to one product and are documented in manuals for that product. For example, if you are working with Oracle Enterprise Manager, you would need to refer to the messages contained in the Oracle Enterprise Manager Messages Manual.

Operating System-Specific

These messages are specific to one operating system. A range of message code numbers are reserved for each operating system. For example, the range ORA-07500 to ORA-07999 is reserved for DEC VAX/VMS messages; these messages are listed in the appropriate operating system-specific documentation.

The prefix of the message indicates where to find information about the message. For example, some messages in this manual have the prefix "ORA". If you encounter a message without a prefix, first check the manuals for the release of Oracle you are using, then check this manual.

Accuracy of Messages

The accuracy of the messages in this manual is our primary concern. Occasionally, an enhancement to a message is not incorporated into the Oracle software. Should you encounter a message generated on your system that differs from the message in this book, be assured the improved message text is usually incorporated in the next release of the software. If you should encounter a discrepancy, then please contact us using the information contained in the Reader Comment Form at the front of this manual.

Message Format

All messages displayed are prefixed by text that indicates which program issued the message. For example, the prefix "ORA" shows that the message was generated by the Oracle products. The location of messages in this book depends on the prefix of the message.

All messages are listed in order by the message code number. To look up a message, use the message code number.

Recognizing Variable Text in Messages

To help you find and fix errors, Oracle embeds object names, numbers, and character strings in some messages. These embedded variables are represented by string, number, or character, as appropriate. For example:

ORA-00020: maximum number of processes (number) exceeded

The preceding message might actually appear as follows:

ORA-00020: maximum number of processes (50) exceeded

Message Stacks

Occasionally, you may see a message stack. This is simply a series of related messages issued at different levels of Oracle.

The following message stack is a generic example:

ORA-06502: PL/SQL: numeric or value errorORA-06512: at "SCOTT.VALUE_ERR", line 1ORA-06512: at line 1

The following message stack is a VAX/VMS example:

ORA-01034: Oracle not availableORA-07625: smsget: $MGBLSC failure%SYSTEM-W-NOSUCHSEC, no such (global) section

In this example, notice that the message at the bottom of the stack is issued by the VMS operating system. Seeing the messages at each level in the system may help you trace the originating event. For example, in this case, Oracle may not be available simply because it has not been started, and consequently there is no system global area (SGA). If you need the help of Oracle Support Services, then be sure to report all the messages in the stack.

Contacting Oracle Support Services

Some messages recommend contacting Oracle Support Services to report a problem. When you contact Oracle Support Services, please have the following information available:

  • The hardware, operating system, and release number of the operating system on which Oracle is running
  • The complete release number of the Oracle database server (for example, release 9.2.0.1.0 or release 9.0.1.1.2)
  • All Oracle programs (with version numbers) in use when the error occurred. For example, SQL*Net V2.0 or SQL*Forms V3.0
  • If you encountered one or more error codes or messages, then the exact code numbers and message text, in the order they appeared
  • The problem severity, according to the following codes:

    1 = Program not usable. Critical impact on operations.

    2 = Program usable. Operations severely restricted.

    3 = Program usable with limited functions. Not critical to overall operations.

    4 = Problem circumvented by customer. Minimal effect, if any, on operations.

You will also be expected to provide the following:

  • Your name
  • The name of your organization
  • Your Oracle Support ID Number
  • Your telephone number

Oracle Exception Messages

Oracle's extensive self-checking helps detect internal errors. Oracle uses the following catchall message for Oracle internal exceptions:

ORA-00600: internal error code, arguments: [num], [], [],[],[],[]

An actual message might appear as follows:

ORA-00600: internal error code, arguments: [1042], [3], [upilam], [], [], []

The message text can be followed by up to six arguments, which indicate the origin and attributes of the error. The first argument is the internal error number. Other arguments are various numbers, names, and character strings. Empty brackets may be ignored.

In addition to being returned to the user, internal errors are also written to the Alert file along with additional information about the event causing the message. The Alert file also lists any trace files that may have been generated because of an internal error. See the following sections for descriptions of the trace and alert files.

If you receive an ORA-00600 message, report it to Oracle Support Services.

Trace Files

A trace file is created each time an Oracle instance starts or an unexpected event occurs in a user process or background process. The name of the trace file includes the instance name, the process name, and the Oracle process number. The file extension or file type is usually TRC, and, if different, is noted in your operating system-specific Oracle documentation. The contents of the trace file may include dumps of the system global area, process global area, supervisor stack, and registers.

Two initialization parameters are used to specify the location of the trace files.

  • The BACKGROUND_DUMP_DEST initialization parameter specifies the location of trace files created by the Oracle background processes PMON, DBWR, LGWR, and SMON.
  • The USER_DUMP_DEST initialization parameter specifies the location of trace files created by user processes such as SQL*Loader or Pro*C.

The Alert file also describes the location of trace files generated when internal errors occur. See the next section for a description of the Alert file.

You may need to format the trace file before using it to diagnose problems. To format a trace file, use the DUMPFMT utility, which is available on most systems and is described in your operating system-specific Oracle documentation. Oracle Support Services may ask you for a formatted trace file to help solve a problem.

See Also:

Oracle9i Database Administrator's Guide for more information about trace files

The Alert File

The Alert file is a log file that records information about internal errors and administrative activities, such as backups. When an internal error occurs, the message is sent to the terminal screen as well as written to the Alert file. Oracle also writes additional information about internal errors to the Alert file, such as the location and name of any trace files generated because of the error.

The name of the Alert file is operating system-specific. The location of the Alert file is the same as the location of the background process trace files. This location is specified by the BACKGROUND_DUMP_DEST initialization parameter. For more information, see your Oracle operating system-specific documentation.

If your system uses an operator's console, some messages from Oracle may appear on the console. All important messages are written to the Alert file as well as the operator's console. Because non-Oracle messages also appear on this console, the Alert file is a better record for tracing all Oracle administrative activity and errors than the console log.

The Alert file also records information about administrative activities, such as backups and archiving online redo log files.

See Also:

Oracle9i Database Administrator's Guide for more information about the Alert file.


Oracle Database Server Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Part II
Oracle Database Server Messages

This part contains the following chapters:

  • Chapter 2, "ORA-00000 to ORA-00899"
  • Chapter 3, "ORA-00900 to ORA-01499"
  • Chapter 4, "ORA-01500 to ORA-02099"
  • Chapter 5, "ORA-02100 to ORA-04099"
  • Chapter 6, "ORA-04100 to ORA-07499"
  • Chapter 7, "ORA-07500 to ORA-09857"
  • Chapter 8, "ORA-09858 to ORA-12299"
  • Chapter 9, "ORA-12300 to ORA-12399"
  • Chapter 10, "ORA-12400 to ORA-12699"
  • Chapter 11, "ORA-12700 to ORA-19399"
  • Chapter 12, "ORA-19400 to ORA-24279"
  • Chapter 13, "ORA-24280 to ORA-29249"
  • Chapter 14, "ORA-29250 to ORA-32799"


ORA-00000 to ORA-00899

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

2
ORA-00000 to ORA-00899

ORA-00000 normal, successful completion

Cause: An operation has completed normally, having met no exceptions.

Action: No action required.

ORA-00001 unique constraint (string.string) violated

Cause: An UPDATE or INSERT statement attempted to insert a duplicate key.

Action: Either remove the unique restriction or do not insert the key.

ORA-00017 session requested to set trace event

Cause: The current session was requested to set a trace event by another session.

Action: This is used internally; no action is required.

ORA-00018 maximum number of sessions exceeded

Cause: All session state objects are in use.

Action: Increase the value of the SESSIONS initialization parameter.

ORA-00019 maximum number of session licenses exceeded

Cause: All licenses are in use.

Action: Increase the value of the LICENSE MAX SESSIONS initialization parameter.

ORA-00020 maximum number of processes (string) exceeded

Cause: All process state objects are in use.

Action: Increase the value of the PROCESSES initialization parameter.

ORA-00021 session attached to some other process; cannot switch session

Cause: The user session is currently used by others.

Action: Do not switch to a session attached to some other process.

ORA-00022 invalid session ID; access denied

Cause: Either the session specified does not exist or the caller does not have the privilege to access it.

Action: Specify a valid session ID that you have privilege to access, that is either you own it or you have the CHANGE_USER privilege.

ORA-00023 session references process private memory; cannot detach session

Cause: An attempt was made to detach the current session when it contains references to process private memory.

Action: A session may contain references to process memory (PGA) if it has an open network connection, a very large context area, or operating system privileges. To allow the detach, it may be necessary to close the session's database links and/or cursors. Detaching a session with operating system privileges is always disallowed.

ORA-00024 logins from more than one process not allowed in single-process mode

Cause: An attempt was made to log in more than once from different processes for Oracle started in single-process mode.

Action: Log off from the other process.

ORA-00025 failed to allocate string

Cause: An application failed because Oracle ran out of memory.

Action: Restart Oracle with a larger SGA heap.

ORA-00026 missing or invalid session ID

Cause: The session ID string specified in the ALTER SYSTEM KILL SESSION command was invalid, or no string was specified.

Action: Retry the command with a valid session ID.

ORA-00027 cannot kill current session

Cause: An attempt was made to use ALTER SYSTEM KILL SESSION to kill the current session.

Action: If it is necessary to kill the current session, do so from another session.

ORA-00028 your session has been killed

Cause: A privileged user killed the session and it is no longer logged in to the database.

Action: Contact the database administrator. The administrator may be attempting to perform an operation that requires users to be logged out. When the database administrator announces that the database is available, log in and resume work.

ORA-00029 session is not a user session

Cause: The session ID specified in an ALTER SYSTEM KILL SESSION command was not a user session. For example, the session may be recursively started.

Action: Retry the command with a valid session ID.

ORA-00030 User session ID does not exist.

Cause: The user session ID no longer exists, probably because the session was logged out.

Action: Use a valid session ID.

ORA-00031 session marked for kill

Cause: The session specified in an ALTER SYSTEM KILL SESSION command cannot be killed immediately because the session is involved in a non-interruptible operation (for example, rolling back a transaction or being blocked by a network operation). The session has been marked to be killed as soon as possible after the current operation is done.

Action: No action is required for the session to be killed, but further executions of the ALTER SYSTEM KILL SESSION command on this session may cause the session to be killed sooner.

ORA-00032 invalid session migration password

Cause: The session migration password specified in a session creation call was invalid (probably too long).

Action: Retry with a valid password (less than 30 characters).

ORA-00033 current session has empty migration password

Cause: An attempt was made to detach or clone the current session and it has an empty migration password. This is not allowed.

Action: Create the session with a non-empty migration password.

ORA-00034 cannot string in current PL/SQL session

Cause: An attempt was made to issue a commit or rollback from a PL/SQL object (procedure, function, package) in a session that has this disabled by a ALTER SESSION DISABLE COMMIT IN PROCEDURE statement.

Action: Enable commits from PL/SQL in this session, or do not attempt to use commit or rollback in PL/SQL when they are disabled in the current session.

ORA-00035 LICENSE_MAX_USERS cannot be less than current number of users

Cause: Specified values for LICENSE_MAX_USERS is less than the current number of users.

Action: Check the license limit and drop extra users or purchase more licenses.

ORA-00036 maximum number of recursive SQL levels (string) exceeded

Cause: An attempt was made to go more than the specified number of recursive SQL levels.

Action: Remove the recursive SQL, possibly a recursive trigger.

ORA-00037 cannot switch to a session belonging to a different server group

Cause: An attempt was made to switch to a session in a different server group. This is not allowed.

Action: Make sure the server switches to a session that belongs to its server group.

ORA-00038 Cannot create session: server group belongs to another user

Cause: An attempt was made to create a non-migratable session in a server group that is owned by a different user.

Action: A server group is owned by the first user who logs into a server in the server group in non-migratable mode. All subsequent non-migratable mode logins must be made by the user who owns the server group. To have a different user log in non-migratable mode, the ownership of the server group will have to be changed. This can be done by logging off all current sessions and detaching from all existing servers in the server group and then having the new user login to become the new owner.

ORA-00050 operating system error occurred while obtaining an enqueue

Cause: Could not obtain the operating system resources necessary to cover an Oracle enqueue. This is normally the result of an operating system user quota that is too low.

Action: Look up the operating system error in your system documentation and perform the needed action.

ORA-00051 timeout occurred while waiting for a resource

Cause: This message is usually caused by an instance that has terminated abnormally.

Action: Restart any non-recovered instances.

ORA-00052 maximum number of enqueue resources (string) exceeded

Cause: Ran out of enqueue resources.

Action: Increase the value of the ENQUEUE_RESOURCES initialization parameter.

ORA-00053 maximum number of enqueues exceeded

Cause: Ran out of enqueue state objects.

Action: Increase the value of the ENQUEUES initialization parameter.

ORA-00054 resource busy and acquire with NOWAIT specified

Cause: The NOWAIT keyword forced a return to the command prompt because a resource was unavailable for a LOCK TABLE or SELECT FOR UPDATE command.

Action: Try the command after a few minutes or enter the command without the NOWAIT keyword.

ORA-00055 maximum number of DML locks exceeded

Cause: Ran out of DML lock state objects.

Action: Increase the value of the DML_LOCKS initialization parameter and restart Oracle.

ORA-00056 DDL lock on object 'string.string' is already held in an incompatible mode

Cause: The attempted lock is incompatible with the DDL lock already held on the object. This happens if you attempt to drop a table that has parse locks.

Action: Before attempting to drop a table, check that it has no parse locks. Wait a few minutes before retrying the operation.

ORA-00057 maximum number of temporary table locks exceeded

Cause: The number of temporary tables equals or exceeds the number of temporary table locks. Temporary tables are often created by large sorts.

Action: Increase the value of the TEMPORARY_TABLE_LOCKS initialization parameter and restart Oracle.

ORA-00058 DB_BLOCK_SIZE must be string to mount this database (not string)

Cause: The value of the DB_BLOCK_SIZE initialization parameter used to start this database does not match the value used when that database was created. Potential reasons for this mismatch are:

  • mounting the wrong database
  • using the wrong initialization parameter file
  • the value of the DB_BLOCK_SIZE parameter was changed

Action: For one of the above causes, either:

  • mount the correct database
  • use the correct initialization parameter file
  • correct the value of the DB_BLOCK_SIZE parameter

ORA-00059 maximum number of DB_FILES exceeded

Cause: The value of the DB_FILES initialization parameter was exceeded.

Action: Increase the value of the DB_FILES parameter and restart Oracle.

ORA-00060 deadlock detected while waiting for resource

Cause: Your session and another session are waiting for a resource locked by the other. This condition is known as a deadlock. To resolve the deadlock, one or more statements were rolled back for the other session to continue work.

Action: Either:

  • Enter a ROLLBACK statement and re-execute all statements since the last commit or
  • Wait until the lock is released, possibly a few minutes, and then re-execute the rolled back statements.

ORA-00061 another instance has a different DML_LOCKS setting

Cause: The shared instance being started is using DML locks, and the running instances are not, or vice-versa.

Action: Either:

  • Do not use DML_LOCKS by setting DML_LOCKS to zero at all instances or
  • Use DML_LOCKS by setting DML_LOCKS to a positive integer at all instances.

ORA-00062 DML full-table lock cannot be acquired; DML_LOCKS is 0

Cause: The instance was started with the value of DML_LOCKS set to zero, and the statement being executed needs a full-table lock (S, X, or SSX).

Action: Restart the instance with DML_LOCKS not equal to zero, and re-execute the statement.

ORA-00063 maximum number of LOG_FILES exceeded

Cause: The value of the LOG_FILES initialization parameter was exceeded.

Action: Increase the value of the LOG_FILES initialization parameter and restart Oracle. The value of the parameter needs to be as large as the highest number of log files that currently exist rather than just the count of logs that exist.

ORA-00064 object is too large to allocate on this O/S (string,string)

Cause: An initialization parameter was set to a value that required allocating more contiguous space than can be allocated on this operating system.

Action: Reduce the value of the initialization parameter.

ORA-00065 initialization of FIXED_DATE failed

Cause: The FIXED_DATE string was not in date format yyyy-mm-dd:hh24:mi:ss.

Action: Make sure the initialization parameter is in the correct date format.

ORA-00066 LOG_FILES is string but needs to be string to be compatible

Cause: The maximum number of log files supported by this instance is not the same as for the other instances. All instances must be able to open all the files any instance can open.

Action: Change the value of the LOG_FILES initialization parameter to be compatible.

ORA-00067 invalid value string for parameter string; must be at least string

Cause: The value for the initialization parameter is invalid.

Action: Choose a value as indicated by the message.

ORA-00068 invalid value string for parameter string, must be between string and string

Cause: The value for the initialization parameter is invalid.

Action: Choose a value as indicated by the message.

ORA-00069 cannot acquire lock -- table locks disabled for string

Cause: A command was issued that tried to lock the table indicated in the message. Examples of commands that can lock tables are: LOCK TABLE, ALTER TABLE... ADD (...), and so on.

Action: Use the ALTER TABLE... ENABLE TABLE LOCK command, and retry the command.

ORA-00070 command string is not valid

Cause: An invalid debugger command was specified.

Action: Type HELP to see the list of available commands.

ORA-00071 process number must be between 1 and string

Cause: An invalid process number was specified.

Action: Specify a valid process number.

ORA-00072 process "string" is not active

Cause: An invalid process was specified.

Action: Specify a valid process.

ORA-00073 command string takes between string and string argument(s)

Cause: An incorrect number of arguments was specified.

Action: Specify the correct number of arguments. Type HELP to see the list of commands and their syntax.

ORA-00074 no process has been specified

Cause: No debug process has been specified.

Action: Specify a valid process.

ORA-00075 process "string" not found in this instance

Cause: The specified process was not logged on to the current instance.

Action: Specify a valid process.

ORA-00076 dump string not found

Cause: An attempt was made to invoke a dump that does not exist.

Action: Type DUMPLIST to see the list of available dumps.

ORA-00077 dump string is not valid

Cause: An attempt was made to invoke an invalid dump.

Action: Try another dump.

ORA-00078 cannot dump variables by name

Cause: An attempt was made to dump a variable by name on a system that does not support this feature.

Action: Try the PEEK command.

ORA-00079 variable string not found

Cause: An attempt was made to dump a variable that does not exist.

Action: Use a valid variable name.

ORA-00080 invalid global area specified by level string

Cause: An attempt was made to dump an invalid global area.

Action: Use level 1 for the PGA, 2 for the SGA, and 3 for the UGA. Use extra + level to dump global area level as well as extra bytes for every pointer; extra must be a multiple of 4.

ORA-00081 address range [string, string) is not readable

Cause: An attempt was made to read/write an invalid memory address range.

Action: Try another address or length.

ORA-00082 memory size of string is not in valid set of [1], [2], [4]stringstringstringstringstring

Cause: An invalid length was specified for the POKE command.

Action: Use a valid length (either 1, 2, 4, or possibly 8).

ORA-00083 warning: possibly corrupt SGA mapped

Cause: Even though there may be SGA corruptions, the SGA was mapped.

Action: Use the DUMPSGA command to dump the SGA.

ORA-00084 global area must be PGA, SGA, or UGA

Cause: An attempt was made to dump an invalid global area.

Action: Specify either PGA, SGA, or UGA.

ORA-00085 current call does not exist

Cause: An invalid attempt was made to dump the current call heap.

Action: Wait until the process starts a call.

ORA-00086 user call does not exist

Cause: An invalid attempt was made to dump the user call heap.

Action: Wait until the process starts a call.

ORA-00087 command cannot be executed on remote instance

Cause: Cluster database command issued for non cluster database ORADEBUG command.

Action: Issue the command without the cluster database syntax.

ORA-00088 command cannot be executed by shared server

Cause: A debug command was issued on a shared server.

Action: Reissue the command using a dedicated server.

ORA-00089 invalid instance number in ORADEBUG command

Cause: An invalid instance number was specified in a cluster database ORADEBUG command.

Action: Reissue the command with valid instance numbers.

ORA-00090 failed to allocate memory for cluster database ORADEBUG command

Cause: Could not allocate memory needed to execute cluster database oradebug.

Action: Reissue the command on each instance with single-instance ORADEBUG.

ORA-00091 LARGE_POOL_SIZE must be at least string

Cause: The value of LARGE_POOL_SIZE is below the minimum size.

Action: Increase the value of LARGE_POOL_SIZE past the minimum size.

ORA-00092 LARGE_POOL_SIZE must be greater than LARGE_POOL_MIN_ALLOC

Cause: The value of LARGE_POOL_SIZE is less than the value of LARGE_POOL_MIN_ALLOC.

Action: Increase the value of LARGE_POOL_SIZE past the value of LARGE_POOL_MIN_ALLOC.

ORA-00093 string must be between string and string

Cause: The parameter value is not in a valid range.

Action: Modify the parameter value to be within the specified range.

ORA-00094 string requires an integer value

Cause: The parameter value is not an integer.

Action: Modify the parameter value to be an integer.

ORA-00096 invalid value string for parameter string, must be from among string

Cause: The value for the initialization parameter is invalid.

Action: Choose a value as indicated by the message.

ORA-00097 use of Oracle SQL feature not in SQL92 string Level

Cause: An attempt was made to use an Oracle SQL feature that is not compliant with the SQL92 standard.

Action: Do not use the feature or use the ALTER SESSION SET FLAGGER command to set the appropriate level of SQL92 compliance.

ORA-00099 timed out while waiting for resource, potential PDML deadlock

Cause: The resource needed by the transaction was busy. The PDML transaction could not acquire the resource within the specified amount of time. This indicates potential deadlock involving this PDML transaction and other transactions currently running in the system.

Action: Increase the value of the PARALLEL_TRANSACTION_RESOURCE_TIMEOUT parameter; then retry the operation.

ORA-00100 no data found

Cause: An application made a reference to unknown or inaccessible data.

Action: Handle this condition within the application or make appropriate modifications to the application code.

ORA-00101 invalid specification for system parameter DISPATCHERS

Cause: The syntax for the DISPATCHERS initialization parameter is incorrect.

Action: Enter the DISPATCHERS initialization parameter into the initialization parameter file with the correct syntax and then shut down and restart the instance.

ORA-00102 network protocol string cannot be used by dispatchers

Cause: The network specified in DISPATCHERS does not have the functionality required by the dispatchers.

Action: Refer to your Oracle operating system-specific documentation for network protocols supported by the dispatchers.

ORA-00103 invalid network protocol; reserved for use by dispatchers

Cause: The network specified in the Net8 connect string is reserved for use by the dispatchers.

Action: Specify other network protocols in the connection string.

ORA-00104 deadlock detected; all public servers blocked waiting for resources

Cause: All available public servers are servicing requests that require resources locked by a client which is unable to get a public server to release the resources.

Action: Increase the limit for the system parameter MAX_SHARED_SERVERS as the system will automatically start new servers to break the deadlock until the number of servers reaches the value specified in MAX_SHARED_SERVERS.

ORA-00105 dispatching mechanism not configured for network protocol string

Cause: An attempt was made to alter the dispatcher's configuration for a network protocol that was not specified in the initialization parameter file.

Action: Do one of the following:

  • Include the network protocol in the definition for the DISPATCHERS initialization parameter and restart the system.
  • Use the ALTER SYSTEM SET DISPATCHERS statement with a network protocol that exists in the initialization parameter file.

ORA-00106 cannot startup/shutdown database when connected to a dispatcher

Cause: An attempt was made to start or shut down an instance while connected to a shared server via a dispatcher.

Action: Reconnect as user INTERNAL without going through the dispatcher. For most cases, this can be done by connect to INTERNAL without specifying a network connect string.

ORA-00107 failed to connect to ORACLE listener process

Cause: Most likely due to the fact that the network listener process has not been started.

Action: Check for the following:

  • The network configuration file is not set up correctly.
  • The client side address is not specified correctly.
  • The listener initialization parameter file is not set up correctly.

ORA-00108 failed to set up dispatcher to accept connection asynchronously

Cause: The network protocol used by the dispatcher does not support asynchronous operations.

Action: Contact Oracle Support Services.

ORA-00111 not all servers started because number of servers is limited to string

Cause: An attempt was made to start more servers than the maximum number specified by the system parameter MAX_SHARED_SERVERS.

Action: Increase the value of the MAX_SHARED_SERVERS initialization parameter as needed or re-issue the ALTER SYSTEM SET SHARED_SERVERS statement with an appropriate number of servers.

ORA-00112 only created up to string (maximum specified) dispatchers

Cause: An attempt was made to start more dispatchers than the maximum number specified by the system parameter MAX_DISPATCHERS.

Action: Increase the value of the MAX_DISPATCHERS initialization parameter as needed.

ORA-00113 protocol name string is too long

Cause: A protocol name specified in the DISPATCHERS initialization parameter is too long.

Action: Use a valid protocol name for the DISPATCHERS value.

ORA-00114 missing value for system parameter SERVICE_NAMES

Cause: No value was specified for the SERVICE_NAMES initialization parameter, nor for the DB_NAME parameter.

Action: Add an SERVICE_NAMES or DB_NAME definition to the initialization parameter file. By default, SERVICE_NAMES is the value of DB_NAME unless SERVICE_NAMES is explicitly specified.

ORA-00115 connection refused; dispatcher connection table is full

Cause: A connection request was refused by a dispatcher because the dispatcher cannot support any more connections.

Action: Connect to a different dispatcher or use a dedicated server.

ORA-00116 SERVICE_NAMES name is too long

Cause: The service name specified in the SERVICE_NAMES initialization parameter is too long.

Action: Use a shorter name for the SERVICE_NAMES value (less than or equal to 255 characters).

ORA-00117 value out of range for system parameter SHARED_SERVERS

Cause: The specified value of the SHARED_SERVERS initialization parameter is incorrect.

Action: SHARED_SERVERS must be greater than or equal to 0 and less than or equal to the value of MAX_SHARED_SERVERS.

ORA-00118 value out of range for system parameter DISPATCHERS

Cause: The value of the DISPATCHERS parameter is incorrect.

Action: The sum of all DISPATCHERS values must be greater than or equal to 0 and less than or equal to the value of MAX_DISPATCHERS.

ORA-00119 invalid specification for system parameter string

Cause: The syntax for the specified parameter is incorrect.

Action: Refer to the Oracle9i Database Reference for the correct syntax.

ORA-00120 dispatching mechanism not enabled or installed

Cause: Either the dispatching mechanism was not enabled or the Oracle executable image was not installed with the dispatching mechanism.

Action: Refer to the Oracle9i Database Administrator's Guide and your operating system-specific documentation for procedures for starting and configuring the dispatcher process.

ORA-00121 SHARED_SERVERS specified without DISPATCHERS

Cause: A definition for SHARED_SERVERS was specified in the initialization parameter file, but no definition for DISPATCHERS was specified. Without a value for DISPATCHERS, shared servers will never be used.

Action: Add a definition for DISPATCHERS in the initialization parameter file (or remove the definition for SHARED_SERVERS, if shared servers are not being used).

ORA-00122 cannot initialize network configuration

Cause: Oracle could not initialize Net8.

Action: See accompanying messages.

ORA-00123 idle public server terminating

Cause: Too many idle servers were waiting on the common queue.

Action: This error is used internally, no action is required.

ORA-00124 DISPATCHERS specified without MAX_SHARED_SERVERS

Cause: A definition for DISPATCHERS was specified in the initialization parameter file, but MAX_SHARED_SERVERS was specified as zero.

Action: Specify MAX_SHARED_SERVERS to be greater than zero.

ORA-00125 connection refused; invalid presentation

Cause: The PRESENTATION in the CONNECT_DATA of the TNS address DESCRIPTION is not correct or is not supported.

Action: Correct the PRESENTATION specified in the TNS address.

ORA-00126 connection refused; invalid duplicity

Cause: The DUPLICITY in the CONNECT_DATA of the TNS address DESCRIPTION is not correct or is not supported.

Action: Correct the DUPLICITY specified in the TNS address.

ORA-00127 dispatcher string does not exist

Cause: There is currently no dispatcher running with the specified name.

Action: Retry with a name of the form "D###" denoting an existing dispatcher process.

ORA-00128 this command requires a dispatcher name

Cause: Wrong syntax for ALTER SYSTEM SHUTDOWN.

Action: Use correct syntax:

ALTER SYSTEM SHUTDOWN [ IMMEDIATE ] 'dispatcher name'

ORA-00129 listener address validation failed 'string'

Cause: An error was encountered while validating the listener address.

Action: Resolve the error or contact Oracle Support Services.

ORA-00130 invalid listener address 'string'

Cause: The listener address specification is not valid.

Action: Make sure that all fields in the listener address (protocol, port, host, key, ...) are correct.

ORA-00131 network protocol does not support registration 'string'

Cause: The specified protocol does not support async notification.

Action: Refer to the manual for information on supported network protocols.

ORA-00132 syntax error or unresolved network name 'string'

Cause: Listener address has syntax error or cannot be resolved.

Action: If a network name is specified, check that it corresponds to an entry in TNSNAMES.ORA or other address repository as configured for your system. Make sure that the entry is syntactically correct.

ORA-00150 duplicate transaction ID

Cause: An attempt was made to start a new transaction with an ID already in use by an existing transaction.

Action: Check your application.

ORA-00151 invalid transaction ID

Cause: The specified transaction ID does not correspond to an existing valid transaction.

Action: Check your application.

ORA-00152 current session does not match requested session

Cause: The current session is not the same as the session that was passed into a UPIXADO() call.

Action: Check your application.

ORA-00153 internal error in XA library

Cause: The XA library could not access thread-specific pointers.

Action: Contact Oracle Support Services.

ORA-00154 protocol error in transaction monitor

Cause: The transaction monitor returned TMJOIN on an AX_REG call but the transaction was locally suspended.

Action: Contact the transaction monitor customer support.

ORA-00155 cannot perform work outside of global transaction

Cause: The application tried to perform some work on either an Oracle 7.3 server or an Oracle8 server with local transactions disabled while outside of a global transaction.

Action: Check if the application is connected to an Oracle 7.3 server. The Transaction monitor must not return a NULL XID on an AX_REG call when the resource manager is Oracle 7.3. If the application is connected to an Oracle8 server, either set nolocal=f in the xa_open string or start a global transaction prior to attempting the work.

ORA-00160 global transaction length string is greater than maximum (string)

Cause: An external global transaction ID with a too large length field was passed in.

Action: Report the problem to your external transaction coordinator vendor.

ORA-00161 transaction branch length string is illegal (maximum allowed string)

Cause: An external transaction branch ID with a length either too large or 0 was passed in.

Action: Report the problem to your external transaction coordinator vendor.

ORA-00162 external dbid length string is greater than maximum (string)

Cause: An external database name with too large a length field was passed in.

Action: Report the problem to your external transaction coordinator vendor.

ORA-00163 internal database name length string is greater than maximum (string)

Cause: An internal database name with a too large length field was passed in.

Action: Report the problem to your external transaction coordinator vendor.

ORA-00164 distributed autonomous transaction disallowed within migratable distributed transaction

Cause: A request was made by the application to start a distributed autonomous transaction when the application was in a migratable distributed transaction.

Action: Roll back or commit the current distributed transaction first.

ORA-00165 migratable distributed autonomous transaction with remote operation is not allowed

Cause: A request was made by the application to start a migratable distributed autonomous transaction with remote operation.

ORA-00200 controlfile could not be created

Cause: It was not possible to create the control file.

Action: Check that there is sufficient disk space and no conflicts in file names and try to create the control file again.

ORA-00201 controlfile version string incompatible with ORACLE version string

Cause: The control file was created by incompatible software.

Action: Either restart with a compatible software release or use CREATE CONTROLFILE to create a new control file that is compatible with this release.

ORA-00202 controlfile: 'string'

Cause: This message reports the name file involved in other messages.

Action: See associated error messages for a description of the problem.

ORA-00203 using the wrong controlfiles

Cause: The mount ID in the control file is not the same as the mount ID in the control file used by the first instance to mount this database. The control files are for the same database but they are not the same files. Most likely one instance is using a backup control file.

Action: Check that the correct control files were specified.

ORA-00204 error in reading (block string, # blocks string) of controlfile

Cause: A disk I/O failure was detected on reading the control file.

Action: Check that the disk is online. If it is not, bring it online and shut down and restart Oracle. If it is online, then look for operating system reasons for Oracle's inability to read the disk or control file. See the Oracle9i Database Administrator's Guide for information on recovering from the loss of a control file. See also your operating system-specific Oracle documentation.

ORA-00205 error in identifying controlfile, check alert log for more info

Cause: The system could not find a control file of the specified name and size.

Action: One of the following:

  • Check that the proper control file name is referenced in the CONTROL_FILES initialization parameter in the initialization parameter file and try again.
  • When using mirrored control files, that is, more than one control file is referenced in the initialization parameter file, remove the control file name listed in the message from the initialization parameter file and restart the instance. If the message does not recur, remove the problem control file from the initialization parameter file and create another copy of the control file with a new file name in the initialization parameter file.

ORA-00206 error in writing (block string, # blocks string) of controlfile

Cause: A disk I/O failure was detected on writing to the control file.

Action: Check that the disk is online. If it is not, bring it online and shut down and restart Oracle. If it is online, then look for operating system reasons for Oracle's inability to write to the disk or control file. See the Oracle9i Database Administrator's Guide for information on recovering from the loss of a control file. See also your operating system-specific Oracle documentation.

ORA-00207 controlfiles are not for the same database

Cause: The database ID in the control file is not the same as the database ID in the control file used by the first instance to mount this database. Most likely one of the mounts used the wrong control file or there are two databases with the same name.

Action: Check that the control file is for the correct database and is not an old version. When using multiplexed control files, that is, more than one control file is referenced in the initialization parameter file, remove the control file name listed in the message from the initialization parameter file and restart the instance. If the message does not recur, remove the problem control file from the initialization parameter file and create another copy of the control file using a new file name in the initialization parameter file.

ORA-00208 number of controlfile names exceeds limit of string

Cause: An attempt was made to use more control files than Oracle supports.

Action: Shut down Oracle. Reduce the number of control files specified in the CONTROL_FILES parameter in the initialization parameter file, and restart Oracle. Delete unused files.

ORA-00209 control file blocksize mismatch, check alert log for more info

Cause: The block size in the control file header does not match the size specified in the DB_BLOCK_SIZE parameter.

Action: Reduce the block size to the amount specified in the message and try again.

ORA-00210 cannot open the specified controlfile

Cause: Cannot open the control file.

Action: Check to make sure the control file exists and is not locked by some other program.

ORA-00211 controlfile does not match previous controlfiles

Cause: A control file was specified that belongs to another database.

Action: Find and install the correct control file.

ORA-00212 block size string below minimum required size of string bytes

Cause: The block size specified was too small. Space for the system overhead is required.

Action: Specify a larger block size and retry the operation.

ORA-00213 cannot reuse controlfile; old file size string, string required

Cause: To reuse a control file, it must be the same size as the one previously used.

Action: Either do not specify REUSE, or specify a matching combination of MAXDATAFILES, MAXLOGFILES, MAXLOGMEMBERS, MAXLOGHISTORY, and MAXINSTANCES clauses in the CREATE DATABASE or CREATE CONTROLFILE statement.

ORA-00214 controlfile 'string' version string inconsistent with file 'string' version string

Cause: An inconsistent set of control files, datafiles, and redo log files was used.

Action: Use a consistent set of control files, datafiles, and redo log files. That is, all the files must be for the same database and from the same time period.

ORA-00215 must be at least one controlfile

Cause: No control file is specified or the control file specified does not exist.

Action: Specify at least one valid control file and retry the operation.

ORA-00216 controlfile could not be resized for migration from 8.0.2

Cause: Control files created by release 8.0.2 were missing some records. These records are automatically added by resizing the control file when attempting to run a later release. The resize failed.

Action: Look in the alert log for the reason that the resize failed. If it can be fixed by giving the control file more space, then do that. Otherwise, use the CREATE CONTROLFILE script dumped to the trace file to create a new control file.

ORA-00217 controlfile could not be resized for migration from 9.0.1

Cause: Controlfiles created by release 9.0.1 were missing some records. These records are automatically added by resizing the controlfile when attempting to run a later release. The resize failed.

Action: Look in the alert log for the reason the resize failed. If it can be fixed by giving the controlfile more space, then do that. Otherwise, use the CREATE CONTROLFILE script dumpped to the trace file to create a new controlfile.

ORA-00218 block size string of controlfile does not match DB_BLOCK_SIZE (string)

Cause: The block size as stored in the control file header is different from the value of the initialization parameter DB_BLOCK_SIZE. This might be due to an incorrect setting of DB_BLOCK_SIZE, or else might indicate that the control file has either been corrupted or belongs to a different database.

Action: Restore a good copy of the control file.

ORA-00219 required controlfile size string exceeds maximum allowable size string

Cause: An invocation of CREATE DATABASE, CREATE CONTROLFILE, cfileCalcSizeList, or cfileCalcSizeArray was executed specifying a combination of parameters that would require the control file size in blocks to exceed the maximum allowable value.

Action: In the case of CREATE DATABASE or CREATE CONTROLFILE, use a different combination of MAXDATAFILES, MAXLOGFILES, MAXLOGMEMBERS, MAXLOGHISTORY, and MAXINSTANCES clauses. In the case of cfileCalcSizeList() or cfileCalcSizeArray(), use a different combination of record type counts.

ORA-00220 controlfile not mounted by first instance, check alert log for more info

Cause: The specified control file has a different mount ID than the other control files that are being mounted. This means that the first instance to mount the database did not use this control file.

Action: Find and install the correct control file.

ORA-00221 error on write to controlfile

Cause: An error occurred when writing to one or more of the control files.

Action: See accompanying messages.

ORA-00222 operation would reuse name of a currently mounted controlfile

Cause: The file name supplied as a parameter to the ALTER DATABASE BACKUP CONTROLFILE command or to cfileSetSnapshotName matches the name of the specified currently mounted control file.

Action: Retry the operation with a different file name.

ORA-00223 convert file is invalid or incorrect version

Cause: An Oracle7 to Oracle8 convert file contains invalid data or was created with an different version of the migration utility. This error can also be caused by incorrect ORACLE_HOME environment variable when the ALTER DATABASE CONVERT command is issued.

Action: Use a correct version of the convert file or regenerate it with the migration utility. Make sure that the migration utility is the same version as the Oracle8 RDBMS executable and that the ORACLE_HOME environment variable is properly set.

ORA-00224 controlfile resize attempted with illegal record type (string)

Cause: An attempt was made to expand or shrink the control file by calling cfileResizeSection using an invalid value for the RECORD_TYPE parameter.

Action: Use a value for the RECORD_TYPE parameter that specifies a valid record type other than type 0 (valid range is 1 to 16).

ORA-00225 expected size string of controlfile differs from actual size string

Cause: The expected size of the control file as stored in its header was different than the actual operating system file size. This usually indicates that the control file was corrupted.

Action: Restore a good copy of the control file.

ORA-00226 operation disallowed while alternate controlfile open

Cause: The attempted operation could not be executed at this time because this process had an alternate control file open for fixed table access.

Action: Retry the operation after calling cfileUseCurrent.

ORA-00227 corrupt block detected in controlfile: (block string, # blocks string)

Cause: A block header corruption or checksum error was detected on reading the control file.

Action: Use the CREATE CONTROLFILE or RECOVER DATABASE USING BACKUP CONTROLFILE command.

ORA-00228 length of alternate controlfile name exceeds maximum of string

Cause: The specified file name, which was supplied as a parameter to cfileSetSnapshotName or cfileUseCopy, exceeds the maximum file name length for this operating system.

Action: Retry the operation with a shorter file name.

ORA-00229 operation disallowed: already hold snapshot controlfile enqueue

Cause: The attempted operation cannot be executed at this time because this process currently holds the snapshot control file enqueue.

Action: Retry the operation after calling cfileUseCurrent to release the snapshot control file enqueue.

ORA-00230 operation disallowed: snapshot controlfile enqueue unavailable

Cause: The attempted operation cannot be executed at this time because another process currently holds the snapshot control file enqueue.

Action: Retry the operation after the concurrent operation that is holding the snapshot control file enqueue terminates.

ORA-00231 snapshot controlfile has not been named

Cause: During an invocation of cfileMakeAndUseSnapshot or cfileUseSnapshot, it was detected that no file name for the snapshot control file had previously been specified.

Action: Specify a name for the snapshot control file by calling cfileSetSnapshotName.

ORA-00232 snapshot controlfile is nonexistent, corrupt, or unreadable

Cause: The snapshot control file was found to be non-existent, corrupt, or unreadable during an invocation of cfileUseSnapshot.

Action: Call cfileMakeAndUseSnapshot again (or for the first time).

ORA-00233 copy controlfile is corrupt or unreadable

Cause: The specified copy control file was found to be corrupt or unreadable during an invocation of cfileUseCopy.

Action: Before retrying cfileUseCopy, use the ALTER DATABASE BACKUP CONTROLFILE command and specify the same file name that was specified for cfileUseCopy.

ORA-00234 error in identifying or opening snapshot or copy controlfile

Cause: A snapshot or copy control file of the specified name could not be found or opened during an invocation of cfileUseSnapshot, cfileMakeAndUseSnapshot, or cfileUseCopy.

Action: Re-create the snapshot or copy control file using cfileMakeAndUseSnapshot or ALTER DATABASE BACKUP CONTROLFILE, respectively.

ORA-00235 controlfile fixed table inconsistent due to concurrent update

Cause: Concurrent update activity on a control file caused a query on a control file fixed table to read inconsistent information.

Action: Retry the operation.

ORA-00236 snapshot operation disallowed: mounted controlfile is a backup

Cause: Attempting to invoke cfileSetSnapshotName, cfileMakeAndUseSnapshot, or cfileUseSnapshot when the currently mounted control file is a backup control file.

Action: Mount a current control file and retry the operation.

ORA-00237 snapshot operation disallowed: controlfile newly created

Cause: An attempt to invoke cfileMakeAndUseSnapshot with a currently mounted control file that was newly created with CREATE CONTROLFILE was made.

Action: Mount a current control file and retry the operation.

ORA-00238 operation would reuse a filename that is part of the database

Cause: The file name supplied as a parameter to the ALTER DATABASE BACKUP CONTROLFILE command or to cfileSetSnapshotName matches the name of a file that is currently part of the database.

Action: Retry the operation with a different file name.

ORA-00250 archiver not started

Cause: An attempt was made to stop automatic archiving, but the archiver process was not running.

Action: No action is required.

ORA-00251 LOG_ARCHIVE_DUPLEX_DEST cannot be the same destination as string string

Cause: The destination specified by the LOG_ARCHIVE_DUPLEX_DEST parameter is the same as the destination specified by an ALTER SYSTEM ARCHIVE LOG START TO command.

Action: Specify a different destination for parameter LOG_ARCHIVE_DUPLEX_DEST, or specify a different destination with the ALTER SYSTEM command.

ORA-00252 log string of thread string is empty, cannot archive

Cause: A log must be used for redo generation before it can be archived. The specified redo log was not been used since it was introduced to the database. However, it is possible that the instance died during a log switch and the log was empty.

Action: Empty logs do not need to be archived. Do not attempt to archive the redo log file.

ORA-00253 character limit string exceeded by archive destination string string

Cause: The destination specified by an ALTER SYSTEM ARCHIVE LOG START TO command was too long.

Action: Retry the ALTER SYSTEM command using a string shorter than the limit specified in the error message.

ORA-00254 error in archive control string 'string'

Cause: The specified archive log location is invalid in the archive command or the LOG_ARCHIVE_DEST initialization parameter.

Action: Check the archive string used to make sure it refers to a valid online device.

ORA-00255 error archiving log string of thread string, sequence # string

Cause: An error occurred during archiving.

Action: Check the accompanying message stack for more detailed information. If the online log is corrupted, then the log can be cleared using the UNARCHIVED option. This will make any existing backups useless for recovery to any time after the log was created, but will allow the database to generate redo.

ORA-00256 cannot translate archive destination string string

Cause: The destination specified by an ALTER SYSTEM ARCHIVE LOG START TO command could not be translated.

Action: Check the accompanying message stack for more detailed information. Then, retry the ALTER SYSTEM command using a different string.

ORA-00257 archiver error. Connect internal only, until freed.

Cause: The archiver process received an error while trying to archive a redo log. If the problem is not resolved soon, the database will stop executing transactions. The most likely cause of this message is the destination device is out of space to store the redo log file.

Action: Check the archiver trace file for a detailed description of the problem. Also, verify that the device specified in the initialization parameter ARCHIVE_LOG_DEST is set up properly for archiving.

ORA-00258 manual archiving in NOARCHIVELOG mode must identify log

Cause: The database is in NOARCHIVELOG mode and a command to manually archive a log did not specify the log explicitly by sequence number, group number or file name.

Action: Specify the log by file name, by group number or by thread and sequence number.

ORA-00259 log string of open thread string is the current log, cannot archive

Cause: An attempt was made to archive the current log of an open thread. This is not allowed because the redo log file may still be in use for the generation of redo entries.

Action: Force a log switch in the instance where the thread is open. If no instances are open, open the database so that instance recovery can recover the thread.

ORA-00260 cannot find online log sequence string for thread string

Cause: The log sequence number supplied in the ARCHIVE statement does not match any of the online logs for the thread. This can result from any of the following situations:

  • The log might have been reused for another sequence number.
  • The log might have been dropped.
  • The sequence number might be greater than the current log sequence number.
  • The thread might not have any logs.

Action: Check the ARCHIVE statement, then specify a valid log sequence number. Specify a valid log sequence number.

ORA-00261 log string of thread string is being archived or modified

Cause: The log is either being archived by another process or an administrative command is modifying the log. Operations that modify the log include clearing, adding a member, dropping a member, renaming a member, and dropping the log.

Action: Wait for the current operation to complete and try again.

ORA-00262 current log string of closed thread string cannot switch

Cause: The log cannot be cleared or manually archived because it is the current log of a closed thread, and it is not possible to switch logs so another log is current. All other logs for the thread need to be archived, or cleared, and cannot be reused.

Action: Archive another log in the same thread first, or complete the clearing. See attached errors for the reason the switch cannot be completed.

ORA-00263 there are no logs that need archiving for thread string

Cause: An attempt was made to manually archive the unarchived logs in this thread but no logs needed archiving.

Action: No action required.

ORA-00264 no recovery required

Cause: An attempt was made to perform media recovery on files that do not need any type of recovery.

Action: Do not attempt to perform media recovery on the selected files. Check to see that the file names were entered properly. If not, retry the command with the proper file names.

ORA-00265 instance recovery required, cannot set ARCHIVELOG mode

Cause: The database either crashed or was shut down with the ABORT option. Media recovery cannot be enabled because the online logs may not be sufficient to recover the current datafiles.

Action: Open the database and then enter the SHUTDOWN command with the NORMAL or IMMEDIATE option.

ORA-00266 name of archived log file needed

Cause: During media recovery, the name of an archived redo log file was requested, but no name was entered.

Action: Mount the correct redo log file and enter its name when it is requested.

ORA-00267 name of archived log file not needed

Cause: During media recovery, the name of an archived redo log file was entered, but no name was requested.

Action: Continue media recovery, but do not enter a new log name.

ORA-00268 specified log file does not exist 'string'

Cause: The given redo log file does not exist.

Action: Check the spelling and capitalization of the file name and retry the command.

ORA-00269 specified log file is part of thread string not string

Cause: The given redo log file is not part of the given thread.

Action: Check that the thread of the redo log file matches the thread on the command line. If not, use a redo log file from the appropriate thread. Retry the command after correcting the error.

ORA-00270 error creating archive log string

Cause: An error was encountered when either creating or opening the destination file for archiving.

Action: Check that the archive destination is valid and that there is sufficient space on the destination device.

ORA-00271 there are no logs that need archiving

Cause: An attempt was made to archive the unarchived redo log files manually, but there are no files that need to be archived.

Action: No action is required.

ORA-00272 error writing archive log string

Cause: An I/O error occurred while archiving a redo log file.

Action: Check that the output device is still available and correct any device errors that may have occurred. Also, make certain that sufficient space for archiving is available on the output device.

ORA-00273 media recovery of direct load data that was not logged

Cause: A media recovery session encountered a table that was loaded by the direct loader without logging any redo information. Some or all of the blocks in this table are now marked as corrupt.

Action: The table must be dropped or truncated so that the corrupted blocks can be reused. If a more recent backup of the file is available, try to recover this file to eliminate this error.

ORA-00274 illegal recovery option string

Cause: An illegal option was specified for a recovery command.

Action: Correct the syntax and retry the command.

ORA-00275 media recovery has already been started

Cause: An attempt was made to start a second media recovery operation in the same session.

Action: Complete or cancel the first media recovery session or start another session to perform media recovery.

ORA-00276 CHANGE keyword specified but no change number given

Cause: The CHANGE keyword was specified on the command line, but no change number was given.

Action: Retry the command using a valid change number after the CHANGE keyword.

ORA-00277 illegal option to the UNTIL recovery flag string

Cause: Only CANCEL, CHANGE and TIME can be used with the UNTIL keyword.

Action: Correct the syntax.

ORA-00278 log file 'string' no longer needed for this recovery

Cause: The specified redo log file is no longer needed for the current recovery.

Action: No action is required. The archived redo log file may be removed from its current location to conserve disk space, if needed. However, the redo log file may still be required for another recovery session in the future.

ORA-00279 change string generated at string needed for thread string

Cause: The requested log is required to proceed with recovery.

Action: Supply the requested log with ALTER DATABASE RECOVER LOGFILE filename or cancel recovery with ALTER DATABASE RECOVER CANCEL.

ORA-00280 change string for thread string is in sequence #string

Cause: This message helps to locate the redo log file with the specified change number requested by other messages.

Action: Use the information provided in this message to specify the required archived redo log files for other errors.

ORA-00281 media recovery may not be performed using dispatcher

Cause: An attempt was made to use a dispatcher process for media recovery. Memory requirements disallow this recovery method.

Action: Connect to the instance via a dedicated server process to perform media recovery.

ORA-00282 UPI string call not supported, use ALTER DATABASE RECOVER

Cause: The given UPI call is no longer supported.

Action: Use the ALTER DATABASE RECOVER command for all recovery actions.

ORA-00283 recovery session canceled due to errors

Cause: An error during recovery was determined to be fatal enough to end the current recovery session.

Action: More specific messages will accompany this message. Refer to the other messages for the appropriate action.

ORA-00284 recovery session still in progress

Cause: An error during recovery was determined to be minor enough to allow the current recovery session to continue.

Action: More specific messages will accompany this message. Refer to the other messages for the appropriate action.

ORA-00285 TIME not given as a string constant

Cause: UNTIL TIME was not followed by a string constant for the time.

Action: Enter the time enclosed in single quotation marks.

ORA-00286 no members available, or no member contains valid data

Cause: None of the members of a redo log file group are available, or the available members do not contain complete data.

Action: If a member is temporarily offline, attempt to make it available. Make sure that the correct file names are being used, especially if the redo log file is being accessed from a remote location.

ORA-00287 specified change number string not found in thread string

Cause: The given change number does not appear in any of the online redo logs for the given thread.

Action: Check the statement to make certain a valid change number is given. Perhaps try to use the NEXT option for archiving logs.

ORA-00288 to continue recovery type ALTER DATABASE RECOVER CONTINUE

Cause: During media recovery, a new log is not required but the continuation command is necessary to do a checkpoint and report errors.

Action: Type ALTER DATABASE RECOVER CONTINUE and recovery will resume.

ORA-00289 suggestion : string

Cause: This message reports the next redo log file name that is needed, according to the initialization parameters LOG_ARCHIVE_DEST and LOG_ARCHIVE_FORMAT. This message assumes that LOG_ARCHIVE_DEST and LOG_ARCHIVE_FORMAT are the same now as when the required redo log file was archived.

Action: Consider using this file name for the next log needed for recovery.

ORA-00290 operating system archival error occurred. See error below

Cause: While attempting to archive to a redo log file, the server encountered an unexpected operating system error.

Action: Correct the operating system error given in the messages and retry the operation. See also your operating system-specific Oracle documentation.

ORA-00291 numeric value required for PARALLEL option

Cause: A recovery command was specified incorrectly. The PARALLEL option must be followed by a numeric argument that specifies the degree of parallelism.

Action: Re-enter the command with a numeric argument specifying the degree of parallelism desired.

ORA-00292 parallel recovery feature not installed

Cause: A parallel recovery was requested when the parallel recovery option is not installed.

Action: Delete the PARALLEL clause from the RECOVER command. Also, delete the RECOVERY_PARALLELISM parameter in the initialization file.

ORA-00293 controlfile out of sync with redo log

Cause: The redo log file and control file are out of sync because a non-current control file was specified when the instance was started.

Action: Retry the RECOVER command using the current control file, or retry the RECOVER command using the USING BACKUP CONTROLFILE clause.

ORA-00294 invalid archivelog format specifier 'string'

Cause: An invalid format specifier was found in the LOG_ARCHIVE_FORMAT initialization parameter. The only characters permitted for string are s, S, t, and T.

Action: Correct the initialization file and restart the instance.

ORA-00295 datafile/tempfile number string is invalid, must be between 1 and string

Cause: An invalid file number was specified.

Action: Specify a valid datafile or tempfile number and retry the operation.

ORA-00296 maximum number of files (string) exceeded for RECOVER DATAFILE LIST

Cause: The RECOVER DATAFILE LIST command specified more datafiles than are allowed by the DB_FILES initialization parameter. This error occurs when doing recovery with Recovery Manager, and the instance has been started with a DB_FILES parameter specifying fewer datafiles than Recovery Manager needs to recover to satisfy the user's RECOVER command.

Action: Restart the instance with a higher value for DB_FILES.

ORA-00297 must specify RECOVER DATAFILE LIST before RECOVER DATAFILE START

Cause: The RECOVER DATAFILE START command was issued, but no RECOVER DATAFILE LIST commands had been issued. This only happens when doing recovery with Recovery Manager, and is an internal error in Recovery Manager, because Recovery Manager should always issue RECOVER DATAFILE LIST before RECOVER DATAFILE START.

Action: Contact Oracle Support Services.

ORA-00298 Missing or invalid attribute value

Cause: A nonzero integer value is required when the following keyword attributes are specified:

  • TIMEOUT
  • EXPIRE
  • DELAY
  • NEXT

Action: Correct the syntax and retry the command.

ORA-00299 must use file-level media recovery on data file string

Cause: The control file does not contain an entry for this file, so block media recovery cannot be done.

Action: Restore the data file and perform file-level media recovery.

ORA-00300 illegal redo log block size string specified - exceeds limit of string

Cause: The specified block size of the redo log is greater than the maximum block size for the operating system.

Action: Create the redo log on a device with a smaller block size.

ORA-00301 error in adding log file 'string' - file cannot be created

Cause: The creation of the redo log file failed

Action: Check whether:

  1. There is enough storage space on the device
  2. The name of the file is valid
  3. The device is online
  4. An I/O error occurred

Also, it is possible REUSE was specified on the command line and a file of the incorrect size exists. Either do not specify REUSE or use a file of the correct size.

ORA-00302 limit of string logs exceeded

Cause: The maximum number of redo log files has been exceeded. There is a limit, set at database creation, on the number of redo log files (typically 16).

Action: Use the CREATE CONTROLFILE command with a larger value for MAXLOGFILES.

ORA-00303 cannot process Parallel Redo

Cause: A redo log containing Parallel Redo has been detected. The current Oracle release cannot process this format of redo.

Action: Use a later release that supports Parallel Redo.

ORA-00304 requested INSTANCE_NUMBER is busy

Cause: An instance tried to start by using a value of the initialization parameter INSTANCE_NUMBER that is already in use.

Action: Either:

  • Specify another INSTANCE_NUMBER,
  • Shut down the running instance with this number, or
  • Wait for instance recovery to complete on the instance with this number.

ORA-00305 log string of thread string inconsistent; belongs to another database

Cause: The database ID in the redo log file does not match the database ID in the control file. This redo log file is not from the current database.

Action: Specify the correct redo log file, and then retry the operation.

ORA-00306 limit of string instances in this database

Cause: Starting this instance would exceed the maximum number of instances allowed for this database. This message occurs only with STARTUP shared and multiple instances.

Action: You cannot start more than the lower of:

  • the operating system-specific maximum or
  • the number of instances specified by the MAXINSTANCES option specified in the CREATE DATABASE statement

ORA-00307 requested INSTANCE_NUMBER out of range, maximum is string

Cause: The initialization parameter INSTANCE_NUMBER specified a number that was out of range.

Action: Change the value of INSTANCE_NUMBER to a valid range and restart the instance. The minimum value is 1 and the maximum value is the lower of the operating system-specific maximum or the value of the MAXINSTANCES option specified in the CREATE DATABASE statement. See also your operating system-specific Oracle documentation.

ORA-00308 cannot open archived log 'string'

Cause: The system cannot access a required archived redo log file.

Action: Check that the offline log exists, the storage device is online, and the archived file is in the correct location. Then attempt to continue recovery or restart the recovery session.

ORA-00309 log belongs to wrong database

Cause: The system cannot access the archived redo log because it belongs to another database.

Action: Specify the correct redo log file and then retry the operation.

ORA-00310 archived log contains sequence string; sequence string required

Cause: The archived log is out of sequence, probably because it is corrupted or the wrong redo log file name was specified during recovery.

Action: Specify the correct redo log file and then retry the operation.

ORA-00311 cannot read header from archived log

Cause: An I/O error occurred when attempting to read the log file header from the specified archived redo log file.

Action: Other messages will accompany this message. See the associated messages for the appropriate action to take.

ORA-00312 online log string thread string: 'string'

Cause: This message reports the file name for details of another message.

Action: Other messages will accompany this message. See the associated messages for the appropriate action to take.

ORA-00313 open failed for members of log group string of thread string

Cause: The online log cannot be opened. The file may not be in the expected location.

Action: Specify the correct redo log file or make the log available, if necessary. Also, see the accompanying messages.

ORA-00314 log string of thread string, expected sequence# string doesn't match string

Cause: The online log is corrupted or is an old version.

Action: Find and install the correct version of the log or reset the logs. Refer to the Oracle9i Database Administrator's Guide for recovery procedures.

ORA-00315 log string of thread string, wrong thread # string in header

Cause: The online log is corrupted or is an old version.

Action: Find and install the correct version of the log or reset the logs. Refer to the Oracle9i Database Administrator's Guide for recovery procedures.

ORA-00316 log string of thread string, type string in header is not log file

Cause: The online log is corrupted or is an old version.

Action: Find and install the correct version of the log or reset the logs. Refer to the Oracle9i Database Administrator's Guide for recovery procedures.

ORA-00317 file type string in header is not log file

Cause: This is not an archived log file.

Action: Find the correct file and try again. Refer to the Oracle9i Database Administrator's Guide for recovery procedures.

ORA-00318 log string of thread string, expected file size string doesn't match string

Cause: The file size indicated in the control file did not match the file size contained in the log file.

Action: Restore the correct file or reset the logs. Refer to the Oracle9i Database Administrator's Guide for recovery procedures.

ORA-00319 log string of thread string has incorrect log reset status

Cause: An online redo log has log reset data that is different from the log reset data in the control file. The log is probably an incorrectly restored backup.

Action: Restore the correct file or reset the logs. Refer to the Oracle9i Database Administrator's Guide for recovery procedures.

ORA-00320 cannot read file header from log string of thread string

Cause: The file is not available.

Action: Restore the log file.

ORA-00321 log string of thread string, cannot update log file header

Cause: Cannot write to the log file.

Action: Restore access to the file.

ORA-00322 log string of thread string is not current copy

Cause: An online log appears to be an incorrectly restored backup.

Action: Restore the correct file or reset the logs. Refer to the Oracle9i Database Administrator's Guide for recovery procedures.

ORA-00323 Current log of thread string not useable and all others need archiving

Cause: An attempt to open the thread failed because it is necessary to switch redo generation to another online log, but all the other logs need to be archived before they can be used.

Action: Archive the logs for the thread and then retry the open.

ORA-00324 log file 'string' translated name 'string' too long, string characters exceeds string limit

Cause: The translated name for a log file is too long.

Action: Choose an untranslated name that yields a shorter translated name.

ORA-00325 archived log for thread string, wrong thread # string in header

Cause: The archived log is corrupted or for another thread. Cannot use the log for applying the redo.

Action: Find the correct archived log.

ORA-00326 log begins at change string, need earlier change string

Cause: The archived log supplied for recovery was generated after the log that is needed. Cannot yet use the log for applying redo.

Action: Find the correct archived log.

ORA-00327 log string of thread string, physical size string less than needed string

Cause: A log file has shrunk in size. This is likely to have been caused by a computer operator's mistake or an operating system error.

Action: Restore the log file from backup. If a backup is not available, drop this log and re-create it. If the database was shut down cleanly, no further action should be required; otherwise, incomplete recovery may be required.

ORA-00328 archived log ends at change string, need later change string

Cause: The archived log supplied for recovery was generated before the log that is needed. Cannot use the log for applying redo.

Action: Find the correct archived log.

ORA-00329 archived log begins at change string, need change string

Cause: The archived log is not the correct log. An earlier log is needed.

Action: Restore the correct log file.

ORA-00330 archived log ends at change string, need change string

Cause: The archived log is not the correct log. A later log is needed.

Action: Restore the correct log file.

ORA-00331 log version string incompatible with ORACLE version string

Cause: The log was written by an incompatible version of Oracle.

Action: Recover the database with the compatible software, shut it down cleanly, and then restart Oracle with the current software.

ORA-00332 archived log is too small - may be incompletely archived

Cause: The log is smaller than the space allocated in it. May be the result of a SHUTDOWN ABORT while it was being written by the archiver.

Action: Get a complete version of this log and use it for recovery. There should either be an online version of it or a copy that was successfully archived.

ORA-00333 redo log read error block string count string

Cause: An I/O error occurred while reading the log described in the accompanying error.

Action: Restore accessibility to file, or get another copy of the file.

ORA-00334 archived log: 'string'

Cause: This message reports the file name involved with other errors.

Action: See associated error messages.

ORA-00335 online log string: No log with this number, log does not exist

Cause: This message reports the file name involved with other errors.

Action: See associated error messages.

ORA-00336 log file size string blocks is less than minimum string blocks

Cause: The log file size as specified in the CREATE DATABASE statement is too small.

Action: Increase the log file size.

ORA-00337 log file 'string' does not exist and no size specified

Cause: An attempt to add a log found neither an existing file nor a size for creating the file.

Action: Specify a size for the log file.

ORA-00338 log string of thread string is more recent than controlfile

Cause: The control file change sequence number in the log file is greater than the number in the control file. This implies that the wrong control file is being used. Note that repeatedly causing this error can make it stop happening without correcting the real problem. Every attempt to open the database will advance the control file change sequence number until it is great enough.

Action: Use the current control file or do backup control file recovery to make the control file current. Be sure to follow all restrictions on doing a backup control file recovery.

ORA-00339 archived log does not contain any redo

Cause: The archived log is not the correct log. It is a copy of a log file that has never been used for redo generation, or was an online log being prepared to be the current log.

Action: Restore the correct log file.

ORA-00340 IO error processing online log string of thread string

Cause: An I/O error occurred on the named online log.

Action: Restore accessibility to the file or restore the file from backup.

ORA-00341 log string of thread string, wrong log # string in header

Cause: The internal information in an online log file does not match the control file.

Action: Restore the correct file or reset the logs. Refer to the Oracle9i Database Administrator's Guide for recovery procedures.

ORA-00342 archived log was created before last RESETLOGS

Cause: Recovery was given a log that was created before the last ALTER DATABASE OPEN RESETLOGS command. There should be another log created since then that contains the correct redo.

Action: Supply the correct log file.

ORA-00343 too many errors, log member closed

Cause: The maximum number of errors on this log member has been exceeded.

Action: Correct the underlying problem by referring to the other error messages found with this one.

ORA-00344 unable to re-create online log 'string'

Cause: An I/O failure occurred when attempting to re-create an online log as part of either an ALTER DATABASE OPEN RESETLOGS or ALTER DATABASE CLEAR LOGFILE command.

Action: Correct the file/device as indicated by accompanying errors.

ORA-00345 redo log write error block string count string

Cause: An I/O error occurred while writing the log.

Action: Correct the cause of the error, and then restart the system. If the log is lost, apply media/incomplete recovery.

ORA-00346 log member marked as STALE

Cause: A log file member no longer is complete.

Action: Correct the underlying problem by referring to the other error messages found with this one.

ORA-00347 log string of thread string, expected block size string doesn't match string

Cause: During online recovery, the block size specified in the control file did not match the block size contained in the redo log file.

Action: Restore the correct redo file from a backup or reset the online redo log files.

ORA-00348 single-process redo failure. Must abort instance

Cause: A failure occurred during a critical portion of the log code during single process operation. This error does not occur during normal multi-process operation.

Action: SHUTDOWN ABORT and restart the database.

ORA-00349 failure obtaining block size for 'string'

Cause: The operating system was unable to determine the block size for the given file name.

Action: Consult the accompanying error message, and correct the device or specify another file name.

ORA-00350 log string of thread string needs to be archived

Cause: The command cannot be done because the log has not been archived, and media recovery has been enabled.

Action: Archive the log or disable media recovery. If the command supports an UNARCHIVED option, then it can be used. However, this may result in making backups unusable, and forcing the drop of some offline files.

ORA-00351 recover-to time invalid

Cause: The time specified in a recover-until statement must be after January 1st 1988.

Action: Specify a time after January 1st 1988.

ORA-00352 all logs for thread string need to be archived - cannot enable

Cause: An attempt was made to enable a thread with all logs needing to be archived, and media recovery has been enabled. There is no log that can be made the new current log for the thread.

Action: Archive a log for the thread or disable media recovery.

ORA-00353 log corruption near block string change string time string

Cause: Some type of redo log corruption has been discovered. This error describes the location of the corruption. Accompanying errors describe the type of corruption.

Action: Perform recovery with a good version of the redo log or do incomplete recovery up to the indicated change or time.

ORA-00354 corrupt redo log block header

Cause: The block header on the redo block indicated by the accompanying error is not valid. The block number and time-stamp are given in an accompanying message.

Action: Perform recovery with a good version of the redo log or perform cancel-based recovery up to, but not including, the corrupted redo log file. If this happens when archiving, archiving of the problem log can be skipped by clearing the log with the UNARCHIVED option. This must be followed by a backup of every datafile to insure recoverability of the database.

ORA-00355 change numbers out of order

Cause: A change number found in the redo log is lower than a previously encountered change number. The log is corrupted in some way. The corruption may be at the earlier change or at this one.

Action: Perform recovery with a good version of the log or perform time-based recovery up to the indicated time.

ORA-00356 inconsistent lengths in change description

Cause: A change record in the redo log contains lengths that do not add up to a consistent value. The log is corrupted in some way.

Action: Perform recovery with a good version of the log or do time-based recovery up to the indicated time.

ORA-00357 too many members specified for log file, the maximum is string

Cause: An ADD LOGFILE or ADD LOGFILE MEMBER command would result in a log with too many members. The number of members is set when the database is created.

Action: Use fewer log file members.

ORA-00358 Too many file members specified, the maximum is string

Cause: A CREATE or ALTER statement specified too many members in a parenthesised file list.

Action: Specify a number of file members that is within the port-defined limit.

ORA-00359 logfile group string does not exist

Cause: An ADD LOGFILE MEMBER or DROP LOGFILE request specified a log file group number that does not exist.

Action: Check the configuration of the log files and reissue the command.

ORA-00360 not a logfile member: string

Cause: A file name was given to DROP LOGFILE MEMBER command that is not a part of the database, or which is a datafile.

Action: Supply a valid log file member name.

ORA-00361 cannot remove last log member string for group string

Cause: An attempt has been made to remove the last member of a log file group.

Action: If desired, delete the entire log, by using DROP LOGFILE.

ORA-00362 member is required to form a valid logfile in group string

Cause: A request to drop a log file member was denied because it would remove data required to form a complete log file.

Action: If desired, delete the entire log (after archiving if required), by using DROP LOGFILE.

ORA-00363 log is not the archived version

Cause: The log given to recovery is a backup of the online version from the time it was the current log. The archived version of the log would not be marked as end of thread. This error can also be caused by failing to list the current log of an enabled thread in a CREATE CONTROLFILE command.

Action: Find the archived version of the log and supply its name. If this is media recovery immediately following a CREATE CONTROLFILE, be sure the current log for this thread was included.

ORA-00364 cannot write header to new log member

Cause: An I/O error occurred when attempting to write the header to a log member that is being added to an existing group.

Action: See accompanying errors. Fix the problem or use another file.

ORA-00365 the specified log is not the correct next log

Cause: The specified log failed to pass checks to ensure it corresponds to the log that was just applied. This is probably the result of using a log that was generated against a cold backup image of the database.

Action: Find the log that was generated by this copy of the database and give that file name to recovery.

ORA-00366 log string of thread string, checksum error in the file header

Cause: The file header for the redo log contains a checksum that does not match the value calculated from the file header as read from disk. This means the file header is corrupted.

Action: Find and install correct version of the log or reset the logs.

ORA-00367 checksum error in log file header

Cause: The file header for the redo log contains a checksum that does not match the value calculated from the file header as read from disk. This means the file header is corrupted.

Action: Find the correct file and try again.

ORA-00368 checksum error in redo log block

Cause: The redo block indicated by the accompanying error, is not valid. It has a checksum that does not match the block contents.

Action: Perform recovery with a good version of the log or do time-based recovery up to the indicated time. If this happens when archiving, archiving of the problem log can be skipped by clearing the log with the UNARCHIVED option. This must be followed by a backup of every datafile to insure recoverability of the database. Restore the correct file or reset logs.

ORA-00369 Current log of thread string not useable and other log being cleared

Cause: An attempt to open the thread failed because it is necessary to switch redo generation to another online log, but all the other logs are being cleared or need to be archived before they can be used.

Action: If the ALTER DATABASE CLEAR LOGFILE command is still active, then wait for it to complete. Otherwise, reissue the CLEAR command. If there are other online logs for the thread that are not being cleared, then archive the logs.

ORA-00371 not enough shared pool memory

Cause: The SHARED_POOL_SIZE initialization parameter is too small.

Action: Increase the parameter value.

ORA-00372 file string cannot be modified at this time

Cause: An attempt was made to modify the contents of a file that cannot be modified. The file is most likely part of a read-only tablespace but may be in the process of going offline, or the database may be in the process of closing.

Action: Check the status of the file and its tablespace.

ORA-00373 online log version string incompatible with ORACLE version string

Cause: The online log was written by an incompatible version of Oracle. This can occur when the log file was created by either a new or older version of Oracle.

Action: Recover the database with the compatible software, shut it down cleanly, and then restart with current software.

ORA-00374 parameter db_block_size = string invalid; must be a multiple of string in the range [string..string]

Cause: An invalid value was specified for the DB_BLOCK_SIZE parameter.

Action: Adjust the value of the parameter and restart the instance.

ORA-00375 unable to get default db_block_size

Cause: The system was unable to determine the default value for DB_BLOCK_SIZE.

Action: See the accompanying system-specific error. As a workaround, specify the block size in the initialization parameter file.

ORA-00376 file string cannot be read at this time

Cause: An attempt was made to read from a file that is not readable. Most likely the file is offline.

Action: Check the state of the file. Bring it online.

ORA-00377 Frequent backups of file string causing write operation to stall

Cause: Backups are occurring too frequently on this file. Each time a new backup is started for a file, any writes which have been previously issued (but not completed) have to be re-issued. If hot backups are started very, very frequently, it is possible that some writes will be re-issued repeatedly and never complete.

Action: Increase the interval between begin hot-backup commands for this file.

ORA-00378 buffer pools cannot be created as specified

Cause: The number of buffers or the number of LRU latches is too small to satisfy the specified buffer pool configuration.

Action: Either increase the number of buffers and/or number of LRU latches or configure smaller buffer pools.

ORA-00379 no free buffers available in buffer pool string for block size stringK

Cause: All buffers in the specified buffer pool for the specified block size are in use and no free buffers are available.

Action: Increase the number of buffers in the specified pool for the specified block size.

ORA-00380 cannot specify db_numberk_cache_size since numberK is the standard block size

Cause: User specified the parameter DB_nK_CACHE_SIZE (where n is one of 2,4,8,16,32), while the standard block size for this database is equal to n Kbytes. This is illegal.

Action: Specify the standard block size cache using DB_CACHE_SIZE (DEFAULT pool) (and DB_RECYCLE_CACHE_SIZE, DB_KEEP_CACHE_SIZE if additional buffer pools are required). Do NOT use the corresponding DB_nK_CACHE_SIZE parameter for the standard block size.

ORA-00381 cannot use both new and old parameters for buffer cache size specification

Cause: User specified one or more of {DB_CACHE_SIZE, DB_RECYCLE_CACHE_SIZE, DB_KEEP_CACHE_SIZE, DB_nK_CACHE_SIZE (where n is one of {2, 4, 8, 16, 32}) AND one or more of {DB_BLOCK_BUFFERS, BUFFER_POOL_KEEP, BUFFER_POOL_RECYCLE}. This is illegal.

Action: Use EITHER the old (pre-Oracle 9.0.0) parameters OR the new ones. Don't specify both. If old size parameters are specified in the parameter file, you may want to replace them with new parameters since the new parameters can be modified dynamically and allow you to configure additional caches for additional block sizes.

ORA-00382 string not a valid block size, valid range [string..string]

Cause: User specified a value for DB_nK_CACHE_SIZE where n is one of {2, 4, 8, 16, 32}, but nk is not a valid block size for this platform.

Action: Remove corresponding parameter from the initialization parameter file and restart the instance.

ORA-00383 DEFAULT cache for blocksize string cannot be reduced to zero

Cause: User attempted to reduce DB_CACHE_SIZE to zero, or attempted to reduce DB_nK_CACHE_SIZE to zero while there were still online tablespaces with block size nK. Note that since the SYSTEM tablespace cannot be taken offline, it is always illegal to set DB_CACHE_SIZE to zero.

Action: Offline any tablespaces with the corresponding block size and then perform the operation again.

ORA-00384 Insufficient memory to grow cache

Cause: The system could not allocate sufficient memory to grow the cache to the specified size.

Action: Attempt a smaller increase in the value of the parameter.

ORA-00390 log string of thread string is being cleared, cannot become current log

Cause: An attempt to switch to a new online log for the redo thread failed because no reusable log could be found. This log is being cleared and will be usable when the clearing completes. The command that began the clearing may have terminated without completing the clearing.

Action: If the clear command is still executing, then wait for its completion. If it terminated, then reissue the clear command, or drop the log.

ORA-00391 All threads must switch to new log format at the same time

Cause: An attempt to switch the current log of a single thread is not allowed because the compatibility requirements force a new log format version number. When changing log formats, all threads must switch to the new format at the same time.

Action: Open the database to cause the coordinated log switch. If that is not possible, then return to the same software version and compatibility setting last used to open the database.

ORA-00392 log string of thread string is being cleared, operation not allowed

Cause: An operation encountered this online log in the middle of being cleared. The command that began the clearing may have terminated without completing the clearing.

Action: If the clear command is still executing, then wait for its completion. If it terminated, then reissue the clear command or drop the log.

ORA-00393 log string of thread string is needed for recovery of offline datafiles

Cause: Log cannot be cleared because the redo in it is needed to recover offline datafiles. It has not been archived so there is no other copy available. If the log is cleared, the tablespaces containing the files will have to be dropped.

Action: Archive the log and then repeat the clear command. If archiving is not possible, and dropping the tablespaces is acceptable, then add the clause UNRECOVERABLE DATAFILE at the end of the clear command.

ORA-00394 online log reused while attempting to archive it

Cause: An attempt was made to reuse an online log file that is being archived.

Action: The online log file has been overwritten; it cannot be archived.

ORA-00395 online logs for the clone database must be renamed

Cause: A clone database open forces log file renaming to avoid overwriting the primary log files.

Action: Rename the log files manually or using the LOG_FILE_NAME_CONVERT initialization parameter.

ORA-00396 error string required fallback to single-pass recovery

Cause: The indicated error caused two-pass instance or crash recovery to fail. Recovery was retried with an alternate (slower) method to avoid the error.

Action: Correct the cause of the indicated error (also recorded) so that future instance or crash recovery can succeed with the new algorithm. This usually requires making more main storage available to the recovery process.

ORA-00397 lost write detected for file string, block string

Cause: The specified block is missing changes that should have been written to disk, indicating a lost write by the file I/O subsystem or volume manager.

Action: Run diagnostic checks on the I/O subsystem and resolve any errors

ORA-00398 abort thread recovery due to reconfiguration

Cause: Global enqueue service reconfiguration occurred during instance/crash recovery.

Action: This is used internally, no action is required.

ORA-00399 corrupt change description in redo log

Cause: A change vector in the redo log failed validation checks.

Action: Do recovery with a good version of the log or do time based recovery up to the indicated time.

ORA-00400 invalid release value string for parameter string

Cause: The release level given for the specified initialization parameter is invalid.

Action: Correct the parameter value in the parameter file and retry.

ORA-00401 the value for parameter string is not supported by this release

Cause: The value specified cannot be supported by this release of the software.

Action: Choose an appropriate value, or remove the parameter value to use the default value.

ORA-00402 database changes by release string cannot be used by release string

Cause: Changes have been made to the database that require a newer software release or that violate the compatibility parameters.

Action: Use a version of the software that can understand the changes or relax the compatibility requirements in the initialization file.

ORA-00403 string (string) is not the same as other instances (string)

Cause: Another instance has set the COMPATIBLE or COMPATIBLE NO RECOVERY parameters differently than this instance.

Action: Change the parameters of the current instance to match other instances already running.

ORA-00404 Convert file not found: 'string'

Cause: The file used for converting the database from V7 to V8 could not be found.

Action: Verify that the migration process has been started on this database and that the convert file name is accessible.

ORA-00405 compatibility type "string"

Cause: Reporting a type associated with another error.

Action: See the accompanying error.

ORA-00406 COMPATIBLE parameter needs to be string or greater

Cause: The value of the COMPATIBLE initialization parameter is not high enough to allow the operation. Allowing the command would make the database incompatible with the release specified by the current COMPATIBLE parameter.

Action: Shut down and restart with a higher compatibility setting.

ORA-00407 rolling upgrade from release string.string to string.string is not allowed

Cause: Another instance executing software at a different point release already has the database mounted.

Action: Shut down all instances then restart with the new software.

ORA-00408 parameter string is set to TRUE

Cause: Reporting the parameter that resulted in the compatibility error.

Action: Shut down and restart with a higher compatibility setting.

ORA-00409 COMPATIBLE needs to be string or higher to use AUTO SEGMENT SPACE MANAGEMENT

Cause: This is due to upgrading from an older release of Oracle with tablespaces created using automatic segment-space management. To open the database, the COMPATIBLE parameter needs to be set to the specified value or higher.

Action: Shut down and start up with the specified compatibility setting.

ORA-00436 ORACLE is not licensed. Contact Oracle Corp. for assistance

Cause: This installed Oracle software is not licensed to run on this CPU. This can also occur if Oracle software has been installed incorrectly, for example, with the wrong licensing codes.

Action: Check that Oracle is installed correctly. Then contact Oracle Support Services.

ORA-00437 ORACLE feature is not licensed. Contact Oracle Corp. for assistance

Cause: This installed Oracle feature is not licensed to run on this CPU. This can also occur if Oracle software has been installed incorrectly, for example, with the wrong licensing codes.

Action: Check that Oracle is installed correctly. Then contact Oracle Support Services.

ORA-00438 string Option not installed

Cause: The specified option is not installed.

Action: Either avoid calling the option, or purchase and install the option.

ORA-00439 feature not enabled: string

Cause: The specified feature is not enabled.

Action: Do not attempt to use this feature.

ORA-00443 background process "string" did not start

Cause: The specified process did not start.

Action: Ensure that the executable image is in the correct place with the correct protections, and that there is enough memory.

ORA-00444 background process "string" failed while starting

Cause: Usually due to a bad (or non-existent) background process image.

Action: Get a good background process image.

ORA-00445 background process "string" did not start after string seconds

Cause: The specified process did not start after the specified time.

Action: Ensure that the background did not die and leave a trace file.

ORA-00446 background process started when not expected

Cause: The background process specified started after Oracle was already running.

Action: Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the other messages. If no user on site started the process, report the message to Oracle Support Services.

ORA-00447 fatal error in background process

Cause: One of the background processes died unexpectedly.

Action: Restart the system. Check and, if necessary, correct the problem indicated by the background trace file in BACKGROUND_DUMP_DEST.

ORA-00448 normal completion of background process

Cause: One of the background processes completed normally as requested by the user.

Action: If you are solving a problem, check for other messages and the background process trace file. Correct the problem mentioned in the other messages. Then shut down and restart Oracle.

ORA-00449 background process 'string' unexpectedly terminated with error string

Cause: A foreground process needing service from a background process has discovered the process died.

Action: Refer to the message code given in the message and the trace file for the foreground and the background processes.

ORA-00470 LGWR process terminated with error

Cause: The Log Writer process terminated abnormally.

Action: Check the accompanying messages, and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.

ORA-00471 DBWR process terminated with error

Cause: The Database Writer process terminated abnormally.

Action: Check the accompanying messages, and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.

ORA-00472 PMON process terminated with error

Cause: The Process Monitor process terminated abnormally.

Action: Check the accompanying messages, and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.

ORA-00473 ARCH process terminated with error

Cause: The Archiver process terminated abnormally.

Action: Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.

ORA-00474 SMON process terminated with error

Cause: The System Monitor process terminated abnormally.

Action: Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.

ORA-00475 TRWR process terminated with error

Cause: The system tracing process terminated abnormally.

Action: Restart the instance.

ORA-00476 RECO process terminated with error

Cause: The distributed transaction (two-phase commit) recovery process terminated abnormally.

Action: Restart the instance.

ORA-00477 SNP* process terminated with error

Cause: A materialized view refresh process terminated abnormally.

Action: PMON will restart SNP process shortly. If SNP process does not get started, contact Oracle Support Services.

ORA-00478 SMON process terminated due to error string

Cause: SMON was unable to service the requests due to an error in cleanup of resources.

Action: Warm start the instance.

ORA-00480 LCK* process terminated with error

Cause: One Lock process terminated abnormally.

Action: Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.

ORA-00481 LMON process terminated with error

Cause: The global enqueue service monitor process terminated abnormally.

Action: Restart the instance.

ORA-00482 LMD* process terminated with error

Cause: A global enqueue service daemon process terminated abnormally.

Action: Restart the instance.

ORA-00483 During shutdown a process abnormally terminated

Cause: One of the background processes did not exit normally at or near the time of shutdown.

Action: Use the SHUTDOWN ABORT command. Check the accompanying messages, if any, and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, check the trace file for the mentioned process until the root message is found.

ORA-00484 LMS* process terminated with error

Cause: A global cache service process terminated abnormally.

Action: Warm start the instance.

ORA-00485 DIAG process terminated with error string

Cause: A global diagnostic process died.

Action: Wait for the process to restart.

ORA-00568 Maximum number of interrupt handlers exceeded

Cause: The number of registered interrupt handling routines for when the break key is entered exceeds the maximum allowed.

Action: Reduce the number of registered interrupt handlers.

ORA-00600 internal error code, arguments: [string], [string], [string], [string], [string], [string], [string], [string]

Cause: This is the generic internal error number for Oracle program exceptions. It indicates that a process has encountered a low-level, unexpected condition. Causes of this message include:

  • timeouts
  • file corruption
  • failed data checks in memory
  • hardware, memory, or I/O errors
  • incorrectly restored files

The first argument is the internal message number. Other arguments are various numbers, names, and character strings. The numbers may change meanings between different versions of Oracle.

Action: Report this error to Oracle Support Services after gathering the following information:

  • events that led up to the error
  • the operations that were attempted that led to the error
  • the conditions of the operating system and databases at the time of the error
  • any unusual circumstances that occurred before receiving the ORA-00600 message
  • contents of any trace files generated by the error
  • the relevant portions of the Alter files

Note: The cause of this message may manifest itself as different errors at different times. Be aware of the history of errors that occurred before this internal error.

ORA-00601 cleanup lock conflict

Cause: The Process Monitor encountered a lock conflict while trying to recover processes. This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-00602 internal programming exception

Cause: Internal programming exception occurred.

Action: Report this error as a program bug to Oracle Support Services.

ORA-00603 ORACLE server session terminated by fatal error

Cause: An Oracle Server session is in an unrecoverable state.

Action: Log in to Oracle again so a new server session will be created automatically. Examine the session trace file for more information.

ORA-00604 error occurred at recursive SQL level string

Cause: An error occurred while processing a recursive SQL statement (a statement applying to internal dictionary tables).

Action: If the situation described in the next error on the stack can be corrected, do so; otherwise contact Oracle Support Services.

ORA-00606 Internal error code

Cause: A call to deferred UPI functions was made in non-deferred mode.

Action: Contact Oracle Support Services.

ORA-00607 Internal error occurred while making a change to a data block

Cause: An internal error or memory exception occurred while Oracle was applying redo to a data block.

Action: Contact Oracle Support Services.

ORA-00701 object necessary for warmstarting database cannot be altered

Cause: An attempt was made to alter or drop a database object (table, cluster, or index) defined in the control file's bootstrap segment and needed to warm start the database.

Action: Correct the spelling of the object name or remove it from the ALTER or DROP statement.

ORA-00702 bootstrap verison 'string' inconsistent with version 'string'

Cause: The version of the bootstrap data is incompatible with the current version of the software.

Action: Restore a version of the software that is compatible with the datafiles.

ORA-00703 maximum number of row cache instance locks exceeded

Cause: There are not enough row cache enqueues.

Action: Increase the value of the ROW CACHE ENQUEUE parameter and restart the system.

ORA-00704 bootstrap process failure

Cause: Failure in processing bootstrap data. Refer to the accompanying messages for more information about the cause of the problem.

Action: Correct the problems mentioned in the other messages. If the problem persists, contact Oracle Support Services.

ORA-00705 inconsistent state during start up; shut down the instance, then restart it

Cause: A previous attempt to start an instance was terminated.

Action: Shut down the instance completely and then restart it.

ORA-00706 error changing format of file 'string'

Cause: An attempt to change the block0 format of the specified file failed because the file is read-only or offline.

Action: Make the file read-write or bring the file online and set the BLK0_FMTCHG event.

ORA-00816 error message translation failed

Cause: There is an internal error where a routine was unable to translate a message code.

Action: Contact Oracle Support Services.


ORA-00900 to ORA-01499

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

3
ORA-00900 to ORA-01499

ORA-00900 invalid SQL statement

Cause: The statement is not recognized as a valid SQL statement. This error can occur if the Procedural Option is not installed and a SQL statement is issued that requires this option (for example, a CREATE PROCEDURE statement). You can determine if the Procedural Option is installed by starting SQL*Plus. If the PL/SQL banner is not displayed, then the option is not installed.

Action: Correct the syntax or install the Procedural Option.

ORA-00901 invalid CREATE command

Cause: The CREATE command was not followed by a valid CREATE option.

Action: Correct the syntax.

ORA-00902 invalid datatype

Cause: The datatype entered in the CREATE or ALTER TABLE statement is not valid.

Action: Correct the syntax.

ORA-00903 invalid table name

Cause: A table or cluster name is invalid or does not exist. This message is also issued if an invalid cluster name or no cluster name is specified in an ALTER CLUSTER or DROP CLUSTER statement.

Action: Check spelling. A valid table name or cluster name must begin with a letter and may contain only alphanumeric characters and the special characters $, _, and #. The name must be less than or equal to 30 characters and cannot be a reserved word.

ORA-00904 string: invalid identifier

Cause: The column name entered is either missing or invalid.

Action: Enter a valid column name. A valid column name must begin with a letter, be less than or equal to 30 characters, and consist of only alphanumeric characters and the special characters $, _, and #. If it contains other characters, then it must be enclosed in double quotation marks. It may not be a reserved word.

ORA-00905 missing keyword

Cause: A required keyword is missing.

Action: Correct the syntax.

ORA-00906 missing left parenthesis

Cause: A required left parenthesis has been omitted. Certain commands, such as CREATE TABLE, CREATE CLUSTER, and INSERT, require a list of items enclosed in parentheses. Parentheses also are required around subqueries in WHERE clauses and in UPDATE table SET column = (SELECT...) statements.

Action: Correct the syntax, inserting a left parenthesis where required, and retry the statement.

ORA-00907 missing right parenthesis

Cause: A left parenthesis has been entered without a closing right parenthesis, or extra information was contained in the parentheses. All parentheses must be entered in pairs.

Action: Correct the syntax and retry the statement.

ORA-00908 missing NULL keyword

Cause: Either of the following: In a CREATE TABLE or ALTER TABLE statement, NOT was entered to specify that no null values are allowed in that column, but the keyword NULL was omitted. In the IS [NOT] NULL logical operator, the keyword NULL was not found. For example, the following statement generates this message:

SELECT * FROM EMP WHERE DEPTNO IS NOT;

The keyword NULL must follow the keywords IS NOT.

Action: Correct the syntax.

ORA-00909 invalid number of arguments

Cause: An Oracle function was referenced with an incorrect number of arguments. All Oracle functions, except for SYSDATE, require at least one argument.

Action: Correct the syntax of the function by entering the required number of arguments.

ORA-00910 specified length too long for its datatype

Cause: No size was specified for a character field or the size was invalid. A maximum length must be specified for each character column. The maximum value for this length varies for each character datatype, such as CHAR or VARCHAR2.

Action: Enter a maximum length for the field.

ORA-00911 invalid character

Cause: Special characters are valid only in certain places. If special characters other than $, _, and # are used in a name and the name is not enclosed in double quotation marks ("), this message will be issued. One exception to this rule is for database names; in this case, double quotes are stripped out and ignored.

Action: Remove the invalid character from the statement or enclose the object name in double quotation marks.

ORA-00913 too many values

Cause: The SQL statement requires two sets of values equal in number. This error occurs when the second set contains more items than the first set. For example, the subquery in a WHERE or HAVING clause may return too many columns, or a VALUES or SELECT clause may return more columns than are listed in the INSERT.

Action: Check the number of items in each set and change the SQL statement to make them equal.

ORA-00914 missing ADD keyword

Cause: The keyword ADD does not precede one of the following:

  • The keyword log file in an ALTER DATABASE statement
  • A column element or table constraint in an ALTER TABLE statement
  • The keyword DATAFILE in an ALTER TABLESPACE statement

Action: Specify the keyword ADD in the ALTER statement.

ORA-00915 network access of dictionary table not currently allowed

Cause: This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-00917 missing comma

Cause: A required comma has been omitted from a list of columns or values in an INSERT statement or a list of the form ((C,D),(E,F), ...).

Action: Correct the syntax.

ORA-00918 column ambiguously defined

Cause: A column name used in a join exists in more than one table and is thus referenced ambiguously. In a join, any column name that occurs in more than one of the tables must be prefixed by its table name when referenced. The column should be referenced as TABLE.COLUMN or TABLE_ALIAS.COLUMN. For example, if tables EMP and DEPT are being joined and both contain the column DEPTNO, then all references to DEPTNO should be prefixed with the table name, as in EMP.DEPTNO or E.DEPTNO.

Action: Prefix references to column names that exist in multiple tables with either the table name or a table alias and a period (.), as in the examples above.

ORA-00919 invalid function

Cause: An entry was formatted like a function call, but it is not recognizable as an Oracle function.

Action: Correct the syntax.

ORA-00920 invalid relational operator

Cause: A search condition was entered with an invalid or missing relational operator.

Action: Include a valid relational operator such as =, !=, ^=, <>, >, <, >=, <=, ALL, ANY, [NOT] BETWEEN, EXISTS, [NOT] IN, IS [NOT] NULL, or [NOT] LIKE in the condition.

ORA-00921 unexpected end of SQL command

Cause: The SQL command was not complete. Part of a valid command was entered, but at least one major component was omitted.

Action: Correct the syntax.

ORA-00922 missing or invalid option

Cause: An invalid option was specified in defining a column or storage clause. The valid option in specifying a column is NOT NULL to specify that the column cannot contain any NULL values. Only constraints may follow the datatype. Specifying a maximum length on a DATE or LONG datatype also causes this error.

Action: Correct the syntax. Remove the erroneous option or length specification from the column or storage specification.

ORA-00923 FROM keyword not found where expected

Cause: In a SELECT or REVOKE statement, the keyword FROM was either missing, misplaced, or misspelled. The keyword FROM must follow the last selected item in a SELECT statement or the privileges in a REVOKE statement.

Action: Correct the syntax. Insert the keyword FROM where appropriate. The SELECT list itself also may be in error. If quotation marks were used in an alias, check that double quotation marks enclose the alias. Also, check to see if a reserved word was used as an alias.

ORA-00924 missing BY keyword

Cause: The keyword BY was omitted in a GROUP BY, ORDER BY, or CONNECT BY clause. In a GRANT statement, the keyword IDENTIFIED must also be followed by the keyword BY.

Action: Correct the syntax. Insert the keyword BY where required and then retry the statement.

ORA-00925 missing INTO keyword

Cause: An INSERT statement has been entered without the keyword INTO.

Action: Correct the syntax. Insert the keyword INTO where required and then retry the statement.

ORA-00926 missing VALUES keyword

Cause: An INSERT statement has been entered without the keyword VALUES or SELECT. Either a VALUES clause or a SELECT subquery must follow the INSERT INTO clause.

Action: Correct the syntax. Enter either a VALUES clause or a subquery after the INSERT INTO clause.

ORA-00927 missing equal sign

Cause: An equal sign has been omitted in one of the following places:

  • In the SET clause of an UPDATE statement
  • Following "!" in a search condition to signify not equal

Action: Correct the syntax. Insert the equal sign where required and retry the statement.

ORA-00928 missing SELECT keyword

Cause: A SELECT subquery must be included in a CREATE VIEW statement.

Action: Correct the syntax. Insert the required SELECT clause after the CREATE VIEW clause and then retry the statement.

ORA-00929 missing period

Cause: This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-00930 missing asterisk

Cause: This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-00931 missing identifier

Cause: The specified string does not contain an identifier.

Action: Correct the string argument.

ORA-00932 inconsistent datatypes: expected string got string

Cause: One of the following:

  • An attempt was made to perform an operation on incompatible datatypes. For example, adding a character field to a date field (dates may only be added to numeric fields) or concatenating a character field with a long field.
  • An attempt was made to perform an operation on a database object (such as a table or view) that is not intended for normal use. For example, system tables cannot be modified by a user. Note that on rare occasions this error occurs because a misspelled object name matched a restricted object's name.
  • An attempt was made to use an undocumented view.

Action: If the cause is

  • different datatypes, then use consistent datatypes. For example, convert the character field to a numeric field with the TO_NUMBER function before adding it to the date field. Functions may not be used with long fields.
  • an object not intended for normal use, then do not access the restricted object.

ORA-00933 SQL command not properly ended

Cause: The SQL statement ends with an inappropriate clause. For example, an ORDER BY clause may have been included in a CREATE VIEW or INSERT statement. ORDER BY cannot be used to create an ordered view or to insert in a certain order.

Action: Correct the syntax by removing the inappropriate clauses. It may be possible to duplicate the removed clause with another SQL statement. For example, to order the rows of a view, do so when querying the view and not when creating it. This error can also occur in SQL*Forms applications if a continuation line is indented. Check for indented lines and delete these spaces.

ORA-00934 group function is not allowed here

Cause: One of the group functions, such as AVG, COUNT, MAX, MIN, SUM, STDDEV, or VARIANCE, was used in a WHERE or GROUP BY clause.

Action: Remove the group function from the WHERE or GROUP BY clause. The desired result may be achieved by including the function in a subquery or HAVING clause.

ORA-00935 group function is nested too deeply

Cause: This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-00936 missing expression

Cause: A required part of a clause or expression has been omitted. For example, a SELECT statement may have been entered without a list of columns or expressions or with an incomplete expression. This message is also issued in cases where a reserved word is misused, as in SELECT TABLE.

Action: Check the statement syntax and specify the missing component.

ORA-00937 not a single-group group function

Cause: A SELECT list cannot include both a group function, such as AVG, COUNT, MAX, MIN, SUM, STDDEV, or VARIANCE, and an individual column expression, unless the individual column expression is included in a GROUP BY clause.

Action: Drop either the group function or the individual column expression from the SELECT list or add a GROUP BY clause that includes all individual column expressions listed.

ORA-00938 not enough arguments for function

Cause: The function was referenced with too few arguments.

Action: Check the function syntax and specify the required number of arguments.

ORA-00939 too many arguments for function

Cause: The function was referenced with too many arguments.

Action: Check the function syntax and specify only the required number of arguments.

ORA-00940 invalid ALTER command

Cause: An invalid ALTER option was specified.

Action: Correct the syntax.

ORA-00941 missing cluster name

Cause: The cluster name was either missing or invalid.

Action: Specify a valid cluster name. A valid cluster name must start with a letter, be less than or equal to 30 characters, and contain only alphanumeric characters or the special characters $, _, and #. It may not be a reserved word. The name must be specified immediately following the keywords CREATE CLUSTER.

ORA-00942 table or view does not exist

Cause: The table or view entered does not exist, a synonym that is not allowed here was used, or a view was referenced where a table is required. Existing user tables and views can be listed by querying the data dictionary. Certain privileges may be required to access the table. If an application returned this message, the table the application tried to access does not exist in the database, or the application does not have access to it.

Action: Check each of the following:

  • the spelling of the table or view name.
  • that a view is not specified where a table is required.
  • that an existing table or view name exists.

Contact the database administrator if the table needs to be created or if user or application privileges are required to access the table.

Also, if attempting to access a table or view in another schema, make certain the correct schema is referenced and that access to the object is granted.

ORA-00943 cluster does not exist

Cause: The current user owns no cluster by the specified name.

Action: Specify a valid cluster name following the keyword CLUSTER, then retry the statement.

ORA-00944 insufficient number of clustered columns

Cause: An attempt was made to create a table with fewer cluster columns than were specified in the CREATE CLUSTER statement. The CLUSTER clause of a CREATE TABLE statement must specify all cluster columns that were defined when the cluster was created.

Action: Specify all cluster columns in the CREATE TABLE statement, then retry it.

ORA-00945 specified clustered column does not exist

Cause: A column specified in the cluster clause of a CREATE TABLE statement is not a column in this table.

Action: Re-execute the statement, using the names of columns defined for the table.

ORA-00946 missing TO keyword

Cause: A GRANT statement was specified without the keyword TO, or an invalid form of the GRANT command was entered.

Action: Check the syntax for the GRANT command, insert the keyword TO where required, and retry the statement.

ORA-00947 not enough values

Cause: This error occurs when a SQL statement requires two sets of values equal in number, but the second set contains fewer items than the first set. This can occur in a WHERE or HAVING clause in which a nested SELECT returns too few columns as in:

WHERE (A,B) IN (SELECT C FROM ...)

Another common cause of this error is an INSERT statement in which the VALUES or SELECT clause does not contain enough values needed for the INSERT, as in

INSERT INTO EMP(EMPNO,ENAME) VALUES('JONES')

Action: Check the number of items in each set and change the SQL statement to make them equal.

ORA-00948 ALTER CLUSTER statement no longer supported

Cause: The ALTER CLUSTER statement has been withdrawn.

Action: To add data to a cluster from an existing table, use the following series of SQL statements:

CREATE TABLE newtable SELECT * FROM oldtable CLUSTER clustername;DROP oldtable;RENAME TABLE newtable oldtable;

ORA-00949 illegal reference to remote database

Cause: This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-00950 invalid DROP option

Cause: A DROP command was not followed by a valid DROP option, such as CLUSTER, DATABASE LINK, INDEX, ROLLBACK SEGMENT, SEQUENCE, SYNONYM, TABLE, TABLESPACE, or VIEW.

Action: Check the command syntax, specify a valid DROP option, then retry the statement.

ORA-00951 cluster not empty

Cause: A DROP CLUSTER statement specified a cluster that is not empty. A cluster may not be dropped if it contains any tables, unless the optional INCLUDING TABLES clause is specified. Tables may also be removed from a cluster by using the DROP TABLE command.

Action: Either specify the INCLUDING TABLES clause in the DROP CLUSTER statement or remove all tables from the cluster with the DROP TABLE command before issuing the DROP CLUSTER command.

ORA-00952 missing GROUP keyword

Cause: Groups are not currently implemented.

Action: No user action required.

ORA-00953 missing or invalid index name

Cause: In a CREATE INDEX, DROP INDEX, or VALIDATE INDEX statement, the index name was missing or invalid.

Action: Specify a valid index name after the keyword INDEX. To drop or validate an existing index, check the name by querying the data dictionary. To create a new index, check the syntax before retrying.

ORA-00954 missing IDENTIFIED keyword

Cause: A GRANT CONNECT statement was issued without the keyword IDENTIFIED.

Action: Check the syntax and insert the keyword IDENTIFIED after the last username. The format is

GRANT CONNECT TO user-list IDENTIFIED BY password-list;

ORA-00955 name is already used by an existing object

Cause: An attempt was made to create a database object (such as a table, view, cluster, index, or synonym) that already exists. A user's database objects must have distinct names.

Action: Enter a unique name for the database object or modify or drop the existing object so it can be reused.

ORA-00956 missing or invalid auditing option

Cause: An AUDIT or NOAUDIT command was not followed by a valid option or the keyword ALL. For example, when AUDITing tables an option such as ALTER, AUDIT, COMMENT, DELETE, GRANT, INDEX, INSERT, LOCK, RENAME, SELECT, or UPDATE must be specified.

Action: Correct the syntax.

ORA-00957 duplicate column name

Cause: A column name was specified twice in a CREATE or INSERT statement. Column names must be unique within a table, view, or cluster.

Action: In a CREATE statement, change one of the column names to a new, unique column name. In an INSERT statement, remove one of the duplicate names.

ORA-00958 missing CHECK keyword

Cause: The keyword CHECK should follow the keyword WITH in the WITH OPTION clause of the CREATE VIEW statement.

Action: Check the statement syntax and insert the keyword CHECK where required. Then retry the statement.

ORA-00959 tablespace 'string' does not exist

Cause: A statement specified the name of a tablespace that does not exist.

Action: Enter the name of an existing tablespace. For a list of tablespace names, query the data dictionary.

ORA-00960 ambiguous column naming in select list

Cause: A column name in the order-by list matches more than one select list columns.

Action: Remove duplicate column naming in select list.

ORA-00961 bad datetime/interval value

ORA-00962 too many group-by / order-by expressions

Cause: The group-by or order-by column list contain more than 1000 expressions.

Action: Use no more than 1000 expressions in the group-by or order-by list.

ORA-00963 unsupported interval type

Cause: An unsupported interval type was encountered.

Action: Use a valid interval type.

ORA-00964 table name not in FROM list

Cause: A table specified in a query's SELECT list is not named in the FROM clause list.

Action: Check spelling of the table names, check that each table name in the SELECT list matches a table name in the FROM list, and then retry the statement.

ORA-00965 column aliases not allowed for '*'

Cause: An alias was used with the return-all-columns function (*) in the SELECT list. For example:

SELECT * COL_ALIAS FROM EMP;

Action: Either specify individual columns or do not specify an alias with a "*".

ORA-00966 missing TABLE keyword

Cause: A LOCK statement was specified and the keyword TABLE was missing, misspelled, or misplaced. A LOCK statement must begin with LOCK TABLE tablename.

Action: Correct the syntax.

ORA-00967 missing WHERE keyword

Cause: The keyword WHERE in a SELECT statement was missing, misspelled, or misplaced.

Action: Correct the syntax.

ORA-00968 missing INDEX keyword

Cause: The keyword INDEX in a CREATE UNIQUE INDEX or VALIDATE INDEX statement was missing, misspelled, or misplaced.

Action: Correct the syntax.

ORA-00969 missing ON keyword

Cause: The keyword ON in a GRANT, REVOKE, or CREATE INDEX statement was missing, misspelled, or misplaced.

Action: Check syntax and spelling, and use the keyword ON where required.

ORA-00970 missing WITH keyword

Cause: The keyword START was specified without the keyword WITH. Both keywords are necessary if a START WITH clause is desired in a tree-structured query.

Action: Change the keyword START to the keywords START WITH. Then retry the statement.

ORA-00971 missing SET keyword

Cause: The keyword SET in an UPDATE statement is missing, misspelled, or misplaced.

Action: Check syntax and spelling, and use the keyword SET after the name of the table to be updated.

ORA-00972 identifier is too long

Cause: The name of a schema object exceeds 30 characters. Schema objects are tables, clusters, views, indexes, synonyms, tablespaces, and usernames.

Action: Shorten the name to 30 characters or less.

ORA-00973 invalid row count estimate

ORA-00974 invalid PCTFREE value (percentage)

Cause: The percentage of free space specified in a CREATE INDEX statement is not between 0 and 100. A PCTFREE value of 0 means the entire block is available. The value 100 is not useful because it means that no data may be inserted. The default is 10.

Action: Specify a PCTFREE value between 0 and 100. Then retry the statement.

ORA-00975 date + date not allowed

Cause: An attempt was made to add two date fields together. Dates may be added only to numeric fields, not to other dates.

Action: Use the Oracle function TO_NUMBER to convert one of the date fields to a numeric field before adding it to the other date field.

ORA-00976 LEVEL, PRIOR, or ROWNUM not allowed here

Cause: The use of the PRIOR clause, the pseudo-column LEVEL, or ROWNUM is incorrect in this context.

Action: Check the syntax for the SQL statement. Then remove or relocate the keyword PRIOR, LEVEL, or ROWNUM.

ORA-00977 duplicate auditing option

Cause: An AUDIT or NOAUDIT statement specified the same option more than once.

Action: Either specify ALL without other auditing options or remove the duplicate auditing specifications.

ORA-00978 nested group function without GROUP BY

Cause: A group function, such as AVG, COUNT, MAX, MIN, SUM, STDDEV, or VARIANCE, was used within another group function, as in MAX(COUNT(*)), without a corresponding GROUP BY clause.

Action: Either add a GROUP BY clause or remove the extra level of nesting.

ORA-00979 not a GROUP BY expression

Cause: The GROUP BY clause does not contain all the expressions in the SELECT clause. SELECT expressions that are not included in a group function, such as AVG, COUNT, MAX, MIN, SUM, STDDEV, or VARIANCE, must be listed in the GROUP BY clause.

Action: Include in the GROUP BY clause all SELECT expressions that are not group function arguments.

ORA-00980 synonym translation is no longer valid

Cause: The synonym used is based on a table, view, or synonym that no longer exists.

Action: Replace the synonym with the name of the object it references or re-create the synonym so that it refers to a valid table, view, or synonym.

ORA-00981 cannot mix table and system auditing options

Cause: Both table-wide and system-wide options were specified within a single AUDIT statement.

Action: Check the AUDIT command syntax. Then retry one or more AUDIT statements.

ORA-00982 missing plus sign

Cause: A left parenthesis appeared in a join condition, but a plus sign (+) did not follow. A left parenthesis in a join condition usually signals an outer-join specification and so a plus sign is expected to follow. To specify an outer join on a column in a join operation, follow the column reference in the join condition with a plus sign (+) enclosed in parentheses.

Action: Correct the SQL syntax and retry the statement.

ORA-00984 column not allowed here

Cause: A column name was used in an expression where it is not permitted, such as in the VALUES clause of an INSERT statement.

Action: Check the syntax of the statement and use column names only where appropriate.

ORA-00985 invalid program name

Cause: Probably a syntax error.

Action: Correct syntax.

ORA-00986 missing or invalid group name(s)

Cause: Probably a syntax error.

Action: Correct syntax.

ORA-00987 missing or invalid username(s)

Cause: No username was specified in a GRANT statement or one of the specified usernames is invalid. Valid usernames must be specified following the keyword TO in a GRANT statement to define a user. A username must begin with a letter, consist only of alphanumeric characters and the special characters $, _, and #, and be less than or equal to 30 characters. If it contains other characters, it must be enclosed in double quotation marks. It may not be a reserved word.

Action: Specify a valid username, or list of usernames, following the keyword TO in the GRANT statement.

ORA-00988 missing or invalid password(s)

Cause: More usernames than passwords were specified in a GRANT statement. A valid password must be specified for each username listed in the GRANT statement.

Action: Enter a valid password for each username.

ORA-00989 too many passwords for usernames given

Cause: More passwords than usernames were specified in a GRANT statement. Only one password may be entered for each username listed in the GRANT statement.

Action: Enter an equal number of usernames and passwords.

ORA-00990 missing or invalid privilege

Cause: No privileges were specified in a GRANT privilege statement, or one of the specified privileges is invalid.

Action: Enter one or more valid privileges such as SELECT, INSERT, DELETE, UPDATE, ALTER, INDEX, REFERENCES, or ALL. More than one privilege may be granted by entering the privileges in a list separated by commas (,) or by specifying the keyword ALL to grant all privileges.

ORA-00991 only MAC privileges may be granted to procedures

Cause: Object privileges or non-MAC system privileges were granted to the procedure.

Action: Only grant MAC privileges using the PROCEDURE clause.

ORA-00992 invalid format for REVOKE command

Cause: An invalid form of the REVOKE command was entered. There are two forms of the REVOKE command. The first form is used to revoke a user's database access privileges. The second form is used to revoke a user's object privileges.

Action: Check the command syntax and retry the statement.

ORA-00993 missing GRANT keyword

Cause: The keyword WITH was specified at the end of a GRANT statement without the keyword GRANT. To grant privileges to a user and the permission to grant those privileges to another user, you must specify the keywords WITH GRANT OPTION at the end of the GRANT statement.

Action: Change the keyword WITH to the keywords WITH GRANT OPTION, then retry the statement.

ORA-00994 missing OPTION keyword

Cause: The keywords WITH GRANT were specified at the end of a GRANT statement without the keyword OPTION.

Action: Change the keywords WITH GRANT to the keywords WITH GRANT OPTION. Then retry the statement.

ORA-00995 missing or invalid synonym identifier

Cause: In a CREATE or DROP SYNONYM statement, the synonym name was either missing or invalid.

Action: Check syntax and spelling. A valid synonym name must be specified immediately following the keyword SYNONYM in both statements. Valid synonym names must begin with a letter, consist of alphanumeric characters and the special characters $, _, and #, and be less than or equal to 30 characters. They may not be reserved words.

ORA-00996 the concatenate operator is ||, not |

Cause: A single bar (|) was interpreted as an attempt to specify concatenation, but the concatenation operator is a double bar (||).

Action: Enter a double bar (||) for concatenation or remove the single bar (|) if concatenation was not intended.

ORA-00997 illegal use of LONG datatype

Cause: A value of datatype LONG was used in a function or in a DISTINCT, WHERE, CONNECT BY, GROUP BY, or ORDER BY clause. A LONG value can only be used in a SELECT clause.

Action: Remove the LONG value from the function or clause.

ORA-00998 must name this expression with a column alias

Cause: An expression or function was used in a CREATE VIEW statement, but no corresponding column name was specified. When expressions or functions are used in a view, all column names for the view must be explicitly specified in the CREATE VIEW statement.

Action: Enter a column name for each column in the view in parentheses after the view name.

ORA-00999 invalid view name

Cause: In a CREATE VIEW statement, the view name was missing or invalid.

Action: Enter a valid view name following CREATE VIEW. Valid view names must begin with a letter, consist of only alphanumeric characters and the special characters $, _, and #, be less than or equal to 30 characters, and may not be reserved words. If the view name contains other characters, it must be enclosed in double quotation marks.

ORA-01000 maximum open cursors exceeded

Cause: A host language program attempted to open too many cursors. The initialization parameter OPEN_CURSORS determines the maximum number of cursors per user.

Action: Modify the program to use fewer cursors. If this error occurs often, shut down Oracle, increase the value of OPEN_CURSORS, and then restart Oracle.

ORA-01001 invalid cursor

Cause: Either a host language program call specified an invalid cursor or the value of the MAXOPENCURSORS option in the precompiler command were too small. All cursors must be opened using the OOPEN call before being referenced in any of the following calls: SQL, DESCRIBE, NAME, DEFINE, BIND, EXEC, FETCH, and CLOSE. The Logon Data Area (LDA) must be defined by using OLON or OLOGON. If the LDA is not defined, this message is issued for the following calls: OPEN, COM, CON, ROL, and LOGOFF.

Action: Check the erroneous call statement. Specify a correct LDA area or open the cursor as required. If there is no problem with the cursor, it may be necessary to increase the MAXOPENCURSORS option value before precompiling.

ORA-01002 fetch out of sequence

Cause: In a host language program, a FETCH call was issued out of sequence. A successful parse-and-execute call must be issued before a fetch. This can occur if an attempt was made to FETCH from an active set after all records have been fetched. This may be caused by fetching from a SELECT FOR UPDATE cursor after a commit. A PL/SQL cursor loop implicitly does fetches and may also cause this error.

Action: Parse and execute a SQL statement before attempting to fetch the data.

ORA-01003 no statement parsed

Cause: A host language program call referenced a cursor with no associated parsed SQL statement. A SQL call (for example, OSQL3) must be used to pass a SQL statement to Oracle and to associate the statement with an open cursor. A cursor must already have an associated SQL statement if referenced in any of the following calls: DESCRIBE, NAME, DEFINE, BIND, EXECUTE, and FETCH.

Action: Do the SQL call, for example, OSQL, to pass the required SQL statement before referencing the cursor.

ORA-01004 default username feature not supported; logon denied

Cause: An attempt was made to use automatic logon on a system not supporting this feature.

Action: Provide the complete username and password to log on to Oracle.

ORA-01005 null password given; logon denied

Cause: An invalid password was given when logging on.

Action: Provide a valid password.

ORA-01006 bind variable does not exist

Cause: A program issued a BIND call for a variable not listed in the associated SQL statement. Only those variables prefixed by either a colon (:) or ampersand (&) in the SQL statement may be referenced in a BIND call, OBIND or OBINDN. This error may also be caused by a mismatch between a Precompiler program and the related library, SQLLIB.

Action: Modify the BIND call to reference one of the substitute variables specified in the associated SQL statement.

ORA-01007 variable not in select list

Cause: A reference was made to a variable not listed in the SELECT clause. In OCI, this can occur if the number passed for the position parameter is less than one or greater than the number of variables in the SELECT clause in any of the following calls: DESCRIBE, NAME, or DEFINE. In SQL*Forms or SQL*Report, specifying more variables in an INTO clause than in the SELECT clause also causes this error.

Action: Determine which of the problems listed caused the problem and take appropriate action.

ORA-01008 not all variables bound

Cause: A SQL statement containing substitution variables was executed without all variables bound. All substitution variables must have a substituted value before the SQL statement is executed.

Action: In OCI, use an OBIND or OBINDN call to substitute the required values.

ORA-01009 missing mandatory parameter

Cause: A host language program call did not pass all required parameters.

Action: Check the syntax for the call and enter all required parameters.

ORA-01010 invalid OCI operation

Cause: One of the following:

  • You attempted an invalid OCI operation.
  • You are using an Oracle client application linked with release 7.1 (or higher) libraries, the environment variable ORA_ENCRYPT_LOGIN is set to TRUE, and you attempted to connect to a release 7.0 (or lower) Oracle database server.
  • You are connected to a release 7.1 (or higher) Oracle database server, the DBLINK_ENCRYPT_LOGIN initialization parameter is set to TRUE, and you attempted to use a database link pointing to a release 7.0 (or lower) Oracle database server.
  • You are connected to a release 9.0.2(or higher) Oracle database server and you attempted to use a database link pointing to a release 9.0.1 (or lower) Oracle database server for distributed autonomous transactions.

Action: For the above causes:

  • Do not use the invalid OCI operation.
  • If you do not wish to use encrypted connect passwords in your distributed database, then set ORA_ENCRYPT_LOGIN to FALSE. If you wish to use encrypted connect passwords, then you must upgrade all Oracle database servers to release 7.1 (or higher).
  • If you do not wish to use encrypted database links in your distributed database, then set DBLINK_ENCRYPT_LOGIN to FALSE. If you wish to use encrypted database links, then you must upgrade all Oracle database servers to release 7.1 (or higher).
  • Do not attempt distributed autonomous transactions on release 9.0.1 (or lower) Oracle database servers.

ORA-01011 cannot use v7 compatibility mode when talking to v6 server

Cause: An attempt was made to use Oracle7 compatibility mode when accessing Oracle version 6.

Action: Use V6 SQL language type. You may need to use the SET COMPATIBILITY V6 command.

ORA-01012 not logged on

Cause: A host language program issued an Oracle call, other than OLON or OLOGON, without being logged on to Oracle. This can occur when a user process attempts to access the database after the instance it is connected to terminates, forcing the process to disconnect.

Action: Log on to Oracle, by calling OLON or OLOGON, before issuing any Oracle calls. When the instance has been restarted, retry the action.

ORA-01013 user requested cancel of current operation

Cause: The user interrupted an Oracle operation by entering CTRL-C, Control-C, or another canceling operation. This forces the current operation to end. This is an informational message only.

Action: Continue with the next operation.

ORA-01014 ORACLE shutdown in progress

Cause: A user tried to log on to Oracle while an instance shutdown was in progress. Oracle logons are disabled while Oracle is being shut down.

Action: Wait until Oracle is brought back up before attempting to log on.

ORA-01015 logon called recursively

Cause: This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-01016 This function can be called only after a fetch

Cause: The cursor is in an invalid state.

Action: Ensure the appropriate OCI/UPI function is called after the fetch and before the offending function.

ORA-01017 invalid username/password; logon denied

Cause: An invalid username or password was entered in an attempt to log on to Oracle. The username and password must be the same as was specified in a GRANT CONNECT statement. If the username and password are entered together, the format is: username/password.

Action: Enter a valid username and password combination in the correct format.

ORA-01018 column does not have a LONG datatype

Cause: An attempt was made to fetch data using the LONG fetch option, but the specified column was not LONG.

Action: Re-execute the fetch without the LONG fetch option or create the table with a LONG column.

ORA-01019 unable to allocate memory in the user side

Cause: The user side memory allocator returned an error.

Action: Increase the size of the process heap or switch to the old set of calls.

ORA-01020 unknown context state

Cause: This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-01021 invalid context size specified

Cause: This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-01022 database operation not supported in this configuration

Cause: The attempted database operation does not conform to the user programming interface (UPI) for the two communicating Oracle servers.

Action: You may need to upgrade one or more of your Oracle servers or re-link your user side application with new libraries. Report the problem to Oracle Support Services.

ORA-01023 Cursor context not found (Invalid cursor number)

Cause: The cursor number is not a valid open cursor.

Action: Make sure that the cursor is open.

ORA-01024 invalid datatype in OCI call

Cause: An OCI program call specified an invalid datatype. In OCI calls, Oracle datatypes are specified as numbers between 1 and 7.

Action: Check the datatype description and enter the correct number for the datatype.

ORA-01025 UPI parameter out of range

Cause: An integer parameter to a UPI function is out of range.

Action: This usually indicates an error in a tool built on top of the Oracle DBMS. Report the error to Oracle Support Services.

ORA-01026 multiple buffers of size > 4000 in the bind list

Cause: More than one long buffer in the bind list.

Action: Change the buffer size to be less than 4000 for the bind variable bound to a normal column.

ORA-01027 bind variables not allowed for data definition operations

Cause: An attempt was made to use a bind variable in a SQL data definition operation.

Action: Such bind variables are not allowed.

ORA-01028 internal two task error

Cause: Received send long message but do not have the cursor context.

Action: Contact Oracle Support Services.

ORA-01029 internal two task error

Cause: Received a request to send the long again when there is no long

Action: Contact Oracle Support Services.

ORA-01030 SELECT ... INTO variable does not exist

Cause: The SELECT... INTO specified in the bind call does not correspond to a variable in the SQL statement.

Action: If it is not possible to correct the statement, then contact Oracle Support Services.

ORA-01031 insufficient privileges

Cause: An attempt was made to change the current username or password without the appropriate privilege. This error also occurs if attempting to install a database without the necessary operating system privileges.

Action: Ask the database administrator to perform the operation or grant the required privileges.

ORA-01032 no such userid

Cause: This is an internal error message related to Export/Import.

Action: Contact Oracle Support Services.

ORA-01033 ORACLE initialization or shutdown in progress

Cause: An attempt was made to log on while Oracle is being started or shut down.

Action: Wait a few minutes. Then retry the operation.

ORA-01034 ORACLE not available

Cause: Oracle was not started. Possible causes include the following:

  • The SGA requires more space than was allocated for it.
  • The operating-system variable pointing to the instance is improperly defined.

Action: Refer to accompanying messages for possible causes and correct the problem mentioned in the other messages. If Oracle has been initialized, then on some operating systems, verify that Oracle was linked correctly. See the platform-specific Oracle documentation.

ORA-01035 ORACLE only available to users with RESTRICTED SESSION privilege

Cause: Logins are disallowed because an instance started in restricted mode. Only users with RESTRICTED SESSION system privilege can log on.

Action: Request that Oracle be restarted without the restricted option or obtain the RESTRICTED SESSION system privilege.

ORA-01036 illegal variable name/number

Cause: Unable to find bind context on user side.

Action: Make sure that the variable being bound is in the SQL statement.

ORA-01037 maximum cursor memory exceeded

Cause: An attempt was made to process a complex SQL statement which consumed all available memory of the cursor.

Action: Simplify the complex SQL statement. Alternatively, you can use the NO_EXPAND hint which prevents the cost-based optimizer from considering OR-expansion for queries having OR conditions or INLISTS in the WHERE clause. Usually, the optimizer considers using OR expansion and uses this method if it decides the cost is lower than not using it. Refer to the Oracle9i Database Performance Tuning Guide and Reference for information about using hints.

ORA-01038 cannot write database file version string with ORACLE version string

Cause: An attempt was made to write datafile headers in an old format. The new format cannot be used until after the database has been verified as being compatible with this software version.

Action: Open the database to advance to the new file formats, then repeat the operation. If the operation is required before the database can be opened, then use the previous software release to do the operation.

ORA-01039 insufficient privileges on underlying objects of the view

Cause: An attempt was made to explain plan on other people's view without the necessary privileges on the underlying objects of the view.

Action: Get necessary privileges or do not perform the offending operation.

ORA-01040 invalid character in password; logon denied

Cause: There are multibyte characters in the password or some characters in the password are not in US7ASCII range.

Action: Resubmit the password with valid characters.

ORA-01041 internal error. hostdef extension doesn't exist

Cause: Pointer to HSTDEF extension in HSTDEF is null.

Action: Contact Oracle Support Services.

ORA-01042 detaching a session with open cursors not allowed

Cause: An attempt was made to detach a session which had open cursors.

Action: Close all the cursors before detaching the session.

ORA-01043 user side memory corruption [string], [string], [string], [string]

Cause: The application code corrupted some of the user memory used by Oracle.

Action: Make sure that the application code is not overwriting memory.

ORA-01044 size string of buffer bound to variable exceeds maximum string

Cause: An attempt was made to bind a buffer whose total size would exceed the maximum size allowed. Total array size for arrays is calculated as:

(element_size)*(number of elements)

Action: Reduce the buffer size.

ORA-01045 user string lacks CREATE SESSION privilege; logon denied

Cause: A connect was attempted to a userid which does not have create session privilege.

Action: Grant the user CREATE SESSION privilege.

ORA-01046 cannot acquire space to extend context area

Cause: Oracle could not extend the current area any further because the operating system would not supply any more space. A system-specific message should appear following this message.

Action: Close some cursors and try again or check operating system quotas to use more virtual memory. See your operating system-specific Oracle documentation.

ORA-01047 The above error occurred in schema=string, package=string, procedure=string

Cause: This message is displayed after a previous message to provide more specific information.

Action: See the cause and action for the previous message.

ORA-01048 Couldn't find the specified procedure in the given context

Cause: The procedure user specified in deferred RPC does not exist.

Action: Check to make sure that the procedure exists and is visible to the replication process.

ORA-01049 Bind by name is not supportted in streamed RPC

Cause: This error occurs when a newer server version requests from an older server version an operation that is not supported.

Action: You may need to upgrade one or more of your Oracle servers or relink your user application with new libraries.

ORA-01050 cannot acquire space to open context area

Cause: Oracle could not open a new context area because the operating system would not supply any more space. A system-specific message should appear following this message.

Action: Close some cursors and try again or check operating system quotas to use more virtual memory. See your operating system-specific Oracle documentation.

ORA-01051 deferred rpc buffer format invalid

Cause: The deferred RPC data in SYS.DEF$_CALL is corrupted.

Action: Contact Oracle Support Services.

ORA-01052 required destination LOG_ARCHIVE_DUPLEX_DEST is not specified

Cause: A valid destination for parameter LOG_ARCHIVE_DUPLEX_DEST was not specified when parameter LOG_ARCHIVE_MIN_SUCCEED_DEST was set to 2.

Action: Either specify a value for parameter LOG_ARCHIVE_DUPLEX_DEST, or reduce the value for parameter LOG_ARCHIVE_MIN_SUCCEED_DEST to 1.

ORA-01053 user storage address cannot be read

Cause: A bind variable or other user area could not be read by Oracle.

Action: Check that binds are done correctly on valid user buffers, then retry the operation.

ORA-01054 user storage address cannot be written

Cause: A define, FETCH... INTO or SELECT... INTO, variable or other user area could not be written to by Oracle.

Action: Check that INTO variables and indicators are correctly specified. Then retry the operation.

ORA-01057 invalid or ambiguous block.field reference in user exit

Cause: The reference to a block.field identifier in a user exit is incorrect or ambiguous, probably because it is misspelled or incomplete.

Action: Check syntax and identifier spelling. Then correct the reference.

ORA-01058 internal New Upi interface error

Cause: Attempt to delete non-existent HSTDEF extension.

Action: Contact Oracle Support Services.

ORA-01059 parse expected before a bind or execute

Cause: The client application attempted to bind a variable or execute a cursor opened in a PL/SQL block before the statement was parsed.

Action: Ensure the statement is parsed before a bind or execute.

ORA-01060 array binds or executes not allowed

Cause: The client application attempted to bind an array of cursors or attempted to repeatedly execute against a PL/SQL block with a bind variable of type cursor.

Action: Bind a single cursor or execute the PL/SQL block once.

ORA-01061 cannot start up a V8 server using a V7 client application

Cause: You are using an Oracle client application linked with version 7 (or lower) libraries and you attempted to start up a V8 (or higher) server.

Action: Use a client application linked with V8 (or higher) libraries.

ORA-01062 unable to allocate memory for define buffer

Cause: Exceeded the maximum buffer size for current platform.

Action: Use piecewise fetch with a smaller buffer size.

ORA-01070 Using an old version of Oracle for the server

Cause: An attempt was made to run an older, obsolete Oracle Server.

Action: Upgrade the server.

ORA-01071 cannot perform operation without starting up ORACLE

Cause: An attempt was made to perform an operation before Oracle was started.

Action: Start Oracle. Then retry the operation.

ORA-01072 cannot stop ORACLE; ORACLE not running

Cause: An attempt was made to stop Oracle, but Oracle was not running.

Action: No action required.

ORA-01073 fatal connection error: unrecognized call type

Cause: An illegal internal operation was attempted.

Action: Contact Oracle Support Services.

ORA-01074 cannot shut down ORACLE; inside a login session - log off first

Cause: An attempt was made to shut down Oracle inside a logon session.

Action: Log off before shutting down Oracle.

ORA-01075 you are currently logged on

Cause: An attempt was made to log on while already logged on.

Action: No action required.

ORA-01076 multiple logons per process not yet supported

Cause: Oracle does not support multiple logons per process.

Action: No action required.

ORA-01077 background process initialization failure

Cause: A failure occurred during initialization of the background processes.

Action: Refer to the diagnostic information in the accompanying message stack or in the trace file and take appropriate action.

ORA-01078 failure in processing system parameters

Cause: Failure during processing of initialization parameters during system startup.

Action: Further diagnostic information should be in the error stack.

ORA-01079 ORACLE database was not properly created, operation aborted

Cause: There was an error when the database or control file was created.

Action: Check what error was signaled when the database was first created or when the control file was re-created. Take appropriate actions to re-create the database or a new control file.

ORA-01080 error in shutting down ORACLE

Cause: A failure occurred during system shutdown.

Action: Refer to the diagnostic information in the accompanying message stack and take appropriate action.

ORA-01081 cannot start already-running ORACLE - shut it down first

Cause: An attempt was made to start Oracle while it was already running.

Action: Shut down Oracle first, if you want to restart it.

ORA-01082 'row_locking = always' requires the transaction processing option

Cause: "row_locking = always" is specified in the INIT.ORA file. This feature is not supported by ORACLE without the transaction processing option.

Action: Remove it from INIT.ORA file or set it to "default" or "intent".

ORA-01083 value of parameter "string" is inconsistent with that of other instances

Cause: The value of the given initialization parameter is required to be the same for all instances in the cluster database configuration.

Action: Change the value of the initialization parameter in the initialization parameter file to match that of other cluster database instances.

ORA-01084 invalid argument in OCI call

Cause: The failing OCI call contains an argument with an invalid value.

Action: Use valid argument values. For more information, see the Oracle Call Interface Programmer's Guide and the appropriate programming language supplement.

ORA-01085 preceding errors in deferred rpc to "string.string.string"

Cause: Errors were encountered when the named procedure was executed as a deferred remote procedure call.

Action: Correct the cause of the preceding errors.

ORA-01086 savepoint 'string' never established

Cause: An attempt was made to roll back to a savepoint that was never established.

Action: No action is required.

ORA-01087 cannot start up ORACLE - currently logged on

Cause: An attempt was made to start up Oracle by a user who is currently logged on.

Action: Log off. Then issue the STARTUP command.

ORA-01088 cannot shut down ORACLE while active processes exist

Cause: Users are still logged into the instance.

Action: Either wait for all users to logoff or use SHUTDOWN IMMEDIATE.

ORA-01089 immediate shutdown in progress - no operations are permitted

Cause: The SHUTDOWN IMMEDIATE command was used to shut down a running Oracle instance, terminating any active operations.

Action: Wait for the instance to be restarted or contact the database administrator.

ORA-01090 shutdown in progress - connection is not permitted

Cause: The SHUTDOWN command was used to shut down a running Oracle instance, disallowing any connects to Oracle.

Action: Wait for the instance to restart or contact the database administrator.

ORA-01091 failure during startup force

Cause: Unable to destroy the old SGA.

Action: Manually remove the old SGA. See your operating system-specific Oracle documentation for instructions. Then retry the STARTUP command.

ORA-01092 ORACLE instance terminated. Disconnection forced

Cause: The instance connected to was terminated abnormally, probably due to a SHUTDOWN ABORT. The current process was forced to disconnect from the instance.

Action: Examine the alert log for more details. Contact the database administrator to determine when the instance is restarted. Attempt to reconnect after the instance is running again.

ORA-01093 ALTER DATABASE CLOSE only permitted with no sessions connected

Cause: There is at least one more session, other than the current one, logged in to the instance. ALTER DATABASE CLOSE is not permitted when other sessions are active.

Action: Find the other sessions and disconnect them. Then reissue the ALTER DATABASE CLOSE statement. Also, issue the SHUTDOWN IMMEDIATE command to force users off the system, or issue the SHUTDOWN ABORT command to shut down the database without waiting for users to be forced off.

ORA-01094 ALTER DATABASE CLOSE in progress. Connections not permitted

Cause: An attempt was made to connect while the database is being closed with the ALTER DATABASE CLOSE statement.

Action: Attempt to connect again when the database is open. Contact the database administrator to find out when the database will be open.

ORA-01095 DML statement processed zero rows

Cause: A DML cursor from the OTEX() call processed 0 rows when executed.

Action: Caller can either do a rollback or ignore the message and execute the rest of the cursors in the cursor array.

ORA-01096 program version (string) incompatible with instance (string)

Cause: The program was linked with a different version of the server than the instance to which it is attempting to connect.

Action: Relink the program against the same version of Oracle as the instance or restart (startup force) the database using the program's version of the SERVER.

ORA-01097 cannot shutdown while in a transaction - commit or rollback first

Cause: An attempt was made to shut down the database while a transaction was in progress.

Action: Either commit or rollback the current transaction and then attempt to shut down the database.

ORA-01098 program Interface error during Long Insert

Cause: The application program interface could not insert or update a LONG column because of an internal error when a TTCGETV call fails. For example, a network read error or one of the parameters passed to the call is invalid.

Action: Retry the insert or update.

ORA-01099 cannot mount database in SHARED mode if started in single process mode

Cause: An attempt was made to mount a database in parallel mode with the initialization parameter SINGLE_PROCESS set to TRUE.

Action: Either mount the database in EXCLUSIVE mode or set the initialization parameter SINGLE_PROCESS to FALSE before starting the instance in parallel (shared) mode.

ORA-01100 database already mounted

Cause: An attempt was made to mount a database with the name of a currently mounted database.

Action: No action is required.

ORA-01101 database being created currently mounted by some other instance

Cause: Some other instance has the database of same name currently mounted and you are trying to create it.

Action: Either change the database name or shut down the other instance.

ORA-01102 cannot mount database in EXCLUSIVE mode

Cause: Some other instance has the database mounted exclusive or shared.

Action: Shut down the other instance or mount in a compatible mode.

ORA-01103 database name 'string' in controlfile is not 'string'

Cause: The database name in the control file does not match your database name.

Action: Either find the correct control file or change your database name.

ORA-01104 number of controlfiles (string) does not equal string

Cause: The number of control files used by this instance disagrees with the number of control files in an existing instance.

Action: Check to make sure that all control files are listed.

ORA-01105 mount is incompatible with mounts by other instances

Cause: An attempt to mount the database discovered that another instance mounted a database by the same name, but the mount is not compatible. Additional errors are reported explaining why.

Action: See accompanying errors.

ORA-01106 database must be closed before dismounting

Cause: An attempt was made to dismount a database before it was closed.

Action: Close the database, then retry the operation.

ORA-01107 database must be mounted for media recovery

Cause: An attempt to perform media recovery was made but the database is not mounted.

Action: Mount the database.

ORA-01108 file string is in backup or media recovery"

Cause: Either media recovery is actively being applied to the file, or it is being backed up while the database is in NOARCHIVELOG mode. It cannot be used for normal database access or crash recovery.

Action: Complete or cancel the media recovery session or backup.

ORA-01109 database not open

Cause: A command was attempted that requires the database to be open.

Action: Open the database and try the command again.

ORA-01110 data file string: 'string'

Cause: This message reports the file name involved with other messages.

Action: See the associated messages for a description of the problem.

ORA-01111 name for data file string is unknown - rename to correct file

Cause: The datafile was missing from a CREATE CONTROLFILE command or BACKUP CONTROLFILE RECOVERY was done with a control file that was saved before the file was created.

Action: Rename the MISSING file to the name of the real file.

ORA-01112 media recovery not started

Cause: An attempt to continue media recovery is being made but media recovery was not started.

Action: No action is required.

ORA-01113 file string needs media recovery

Cause: An attempt was made to open a datafile that is in need of media recovery.

Action: First apply media recovery to the datafile identified in the message, then retry the operation.

ORA-01114 IO error writing block to file string (block # string)

Cause: The device on which the file resides is probably offline. If the file is a temporary file, then it is also possible that the device has run out of space. This could happen because disk space of temporary files is not necessarily allocated at file creation time.

Action: Restore access to the device or remove unnecessary files to free up space.

ORA-01115 IO error reading block from file string (block # string)

Cause: The device on which the file resides is probably off line.

Action: Restore access to the device, then retry the operation.

ORA-01116 error in opening database file string

Cause: Usually the file is not accessible.

Action: Make sure the datafile is in the expected location and can be accessed properly, then retry the operation.

ORA-01117 adding file 'string' with illegal block size: string; limit is string

Cause: An attempt was made to add a datafile with a block size that is greater than the maximum block size allowed.

Action: Retry the operation with a smaller block size.

ORA-01118 cannot add any more database files: limit of string exceeded

Cause: An attempt to add a datafile failed because the limit for such files had already been reached.

Action: If more database space is required, export the database and re-create it with a higher limit for datafiles and perhaps increased file size.

ORA-01119 error in creating database file 'string'

Cause: Insufficient space on device.

Action: Decrease the size of the requested file or allocate a file on another device with more available space. If a file size was not specified in the statement, then specify a file size smaller than the available space on the device.

ORA-01120 cannot remove online database file string

Cause: An attempt was made to drop a datafile when it is online.

Action: Take file offline before dropping.

ORA-01121 cannot rename database file string - file is in use or recovery

Cause: An attempt was made to use ALTER DATABASE RENAME to rename a datafile that is online in an open instance or is being recovered.

Action: Close database in all instances and end all recovery sessions.

ORA-01122 database file string failed verification check

Cause: The information in this file is inconsistent with information from the control file. See accompanying message for reason.

Action: Make certain that the database files and control files are the correct files for this database.

ORA-01123 cannot start online backup; media recovery not enabled

Cause: An attempt to start backup of an online tablespace failed because media recovery is not enabled.

Action: Enable media recovery and retry this operation.

ORA-01124 cannot recover data file string - file is in use or recovery

Cause: An attempt to do media recovery found that the file was not available for recovery. Either it is online and the database is open in some instance, or another process is currently doing media recovery on the file.

Action: Do not do media recovery.

ORA-01125 cannot disable media recovery - file string has online backup set

Cause: An attempt to disable media recovery found that an online backup is still in progress.

Action: End the backup of the offending tablespace and retry this command.

ORA-01126 database must be mounted EXCLUSIVE and not open for this operation

Cause: An operation failed because the database was not mounted in exclusive mode.

Action: Shut down Oracle and mount the database in exclusive mode.

ORA-01127 database name 'string' exceeds size limit of string characters

Cause: The specified database name is too long.

Action: Shorten the database name to eight characters or fewer, then retry the operation.

ORA-01128 cannot start online backup - file string is offline

Cause: An attempt to start an online backup found that one of the files is offline.

Action: Bring the offending files online and retry this command or do a cold backup.

ORA-01129 user's default or temporary tablespace does not exist

Cause: The user's default or temporary tablespace was dropped.

Action: Reassign the default or temporary tablespace.

ORA-01130 database file version string incompatible with ORACLE version string

Cause: The named datafile was created under an incompatible version of Oracle, or the file is invalid or non-existent.

Action: Shut down and restart the correct version of Oracle or check the references to the datafile and make sure it exists.

ORA-01131 DB_FILES system parameter value string exceeds limit of string

Cause: The specified value of the initialization parameter DB_FILES is too large.

Action: Reduce the value of the DB_FILES parameter and retry the operation.

ORA-01132 length of database file name 'string' exceeds limit of string characters

Cause: The specified datafile name is too long.

Action: Shorten the file name and retry the operation.

ORA-01133 length of log file name 'string' exceeds limit of string characters

Cause: The specified redo log file name is too long.

Action: Shorten the file name and retry the operation.

ORA-01134 database mounted exclusive by another instance

Cause: An attempt to access a database failed because it is mounted in exclusive mode by another instance.

Action: Either shut down the other instance or wait for the other instance to either close the database or mount it in parallel mode, before retrying the operation.

ORA-01135 file string accessed for DML/query is offline

Cause: An attempt was made to access a datafile that is offline.

Action: Bring the datafile back online.

ORA-01136 specified size of file string (string blocks) is less than original size of string blocks

Cause: A file size was specified in the AS clause of the ALTER DATABASE CREATE DATAFILE statement, and the size was smaller than the size needed.

Action: Create the file with a larger size.

ORA-01137 data file string is still in the middle of going offline

Cause: It was not possible to get the lock for a file that is offline when attempting to bring it online. The most likely cause is that the lock is still held by the instance that is took it offline.

Action: Wait for the other instance to release the lock on the file.

ORA-01138 database must either be open in this instance or not at all

Cause: The requested operation cannot be done when the database is mounted but not open in this instance, and another instance has the database open.

Action: Execute the operation in an open instance, open the database in this instance, or close the database in the other instances.

ORA-01139 RESETLOGS option only valid after an incomplete database recovery

Cause: The RESETLOGS option was given in ALTER DATABASE OPEN, but there has been no incomplete recovery session.

Action: Reissue the ALTER DATABASE OPEN statement without specifying '.

ORA-01140 cannot end online backup - all files are offline

Cause: All the files were found to be offline when attempting to end an online backup.

Action: No action required. Online backup does not need to be ended for this tablespace.

ORA-01141 error renaming data file string - new file 'string' not found

Cause: An attempt to change a datafile's name in the control file failed because no file was found with the new name.

Action: Make sure that the datafile has been properly renamed by the operating system and retry.

ORA-01142 cannot end online backup - none of the files are in backup

Cause: None of the files were found to be in online backup when attempting to end an online backup.

Action: No action required. Online backup does not need to be ended for this tablespace.

ORA-01143 cannot disable media recovery - file string needs media recovery

Cause: An attempt to disable media recovery found a file that needs media recovery, thus media recovery cannot be disabled.

Action: Recover the offending file or drop the tablespace it belongs to and retry this command.

ORA-01144 File size (string blocks) exceeds maximum of string blocks

Cause: Specified file size is larger than maximum allowable size value.

Action: Specify a smaller size.

ORA-01145 offline immediate disallowed unless media recovery enabled

Cause: ALTER TABLESPACE ... OFFLINE IMMEDIATE or ALTER DATABASE DATAFILE ... OFFLINE is only allowed if the database is in ARCHIVELOG mode.

Action: Take the tablespace offline as usual or do a shutdown abort before attempting the required operation. It is worthwhile reconsidering the backup strategy for the database. The attempted operations can be done if ARCHIVEREDO LOG mode is enabled.

ORA-01146 cannot start online backup - file string is already in backup

Cause: An attempt was made to start an online backup, but an online backup was already started for one of the datafiles.

Action: End the first backup before beginning another.

ORA-01147 SYSTEM tablespace file string is offline

Cause: A file belonging to the SYSTEM tablespace has been marked offline by the database administrator. The database cannot be started until all SYSTEM tablespace files are online and can be opened.

Action: Bring the file online.

ORA-01148 can not mount database PARALLEL without a lock manager installed

Cause: An attempt was made to mount the database PARALLEL without the existence of a Lock Manager.

Action: Mount the database in EXCLUSIVE mode.

ORA-01149 cannot shutdown - file string has online backup set

Cause: An attempt to shut down normally found that an online backup is still in progress.

Action: End the backup of the offending tablespace and retry this command.

ORA-01150 cannot prevent writes - file string has online backup set

Cause: Tablespace cannot be taken offline or made read-only when online backup is running. Ending the backup entails writing the file header, which this operation, were it permitted, would prevent.

Action: End the online backup and then take the tablespace offline or make it read-only.

ORA-01151 use media recovery to recover block, restore backup if needed

Cause: Crash recovery or instance recovery could not apply a change to a block because it was not the next change. This can happen if the block was corrupted and then repaired during recovery. This message is usually accompanied by ORA-01172.

Action: There is additional information for ORA-01172. Perform a RECOVER datafile for the file containing the block. If this does not resolve the problem, restore the file from a backup and recover it again.

ORA-01152 file string was not restored from a sufficiently old backup

Cause: An incomplete recovery session was started, but an insufficient number of redo logs were applied to make the database consistent. This file is still in the future of the last redo log applied. The most likely cause of this message is forgetting to restore the file from backup before doing incomplete recovery.

Action: Apply additional redo log files until the database is consistent or restore the datafiles from an older backup and repeat recovery.

ORA-01153 an incompatible media recovery is active

Cause: Attempted to start an incompatible media recovery or open resetlogs during media recovery or RMAN backup . Media recovery sessions are incompatible if they attempt to recover the same data file. Incomplete media recovery or open resetlogs is incompatible with any media recovery. Backup or restore by RMAN is incompatible with open resetlogs.

Action: Complete or cancel the other media recovery session or RMAN backup.

ORA-01154 database busy. Open, close, mount, and dismount not allowed now

Cause: Some operation is in progress that expects the state of the instance to remain open or mounted.

Action: Wait for the operation to complete and try again. If attempting a normal database shutdown, try SHUTDOWN ABORT.

ORA-01155 the database is being opened, closed, mounted or dismounted

Cause: The attempted operation will not succeed while the instance is in one of the states mentioned in the message.

Action: Wait for the open, close, mount, or dismount to complete and try again. If attempting a normal database shutdown, try SHUTDOWN ABORT.

ORA-01156 recovery in progress may need access to files

Cause: Either media or instance recovery is in progress. The recovery may need access to the files that the attempted operation tried to use.

Action: Wait for the recovery to complete and try again.

ORA-01157 cannot identify/lock data file string - see DBWR trace file

Cause: The background process was either unable to find one of the data files or failed to lock it because the file was already in use. The database will prohibit access to this file but other files will be unaffected. However, the first instance to open the database will need to access all online data files. The accompanying error from the operating system describes why the file could not be identified.

Action: At the operating system level, make the file available to the database. Then either open the database or do an ALTER SYSTEM CHECK DATAFILES.

ORA-01158 database string already mounted

Cause: Another instance has a database by this name mounted.

Action: Find which instance is still running. Perhaps you have not lost the control files after all.

ORA-01159 file is not from same database as previous files - wrong database id

Cause: Not all of the files specified in CREATE CONTROLFILE are from the same database. The database ID of this file does not match that from the first file specified.

Action: Check the list of files provided to the CREATE.

ORA-01160 file is not a string

Cause: The named file in the DATAFILE or LOGFILE section of the CREATE CONTROLFILE command does not appear to be as stated.

Action: Check the mentioned file.

ORA-01161 database name string in file header does not match given name of string

Cause: The database name given at the command line does not match the database name found in the file header.

Action: Chance are good that the database name specified at the command line is incorrect. Resolve the discrepancy, and resubmit the command. If you are attempting to change the database name, be sure to use the SET DATABASE option.

ORA-01162 block size string in file header does not match configured block sizes

Cause: CREATE CONTROLFILE discovered that the block size for this file is incompatible with any of the configured cache blocksizes in the initialization parameter file.

Action: Configure the appropriate cache for this block size using one of the (DB_2K_cache_size, DB_4K_cache_size, DB_8K_cache_size, DB_16K_cache_size, DB_32K_cache_size) parameters.

ORA-01163 SIZE clause indicates string (blocks), but should match header string

Cause: The size specified in bytes in the SIZE clause of the CREATE CONTROLFILE statement does not equate to the number of blocks recorded in the header.

Action: Specify the correct file name and size (in bytes).

ORA-01164 MAXLOGFILES may not exceed string

Cause: MAXLOGFILES specified on the command line too large.

Action: Resubmit the command with a smaller value for MAXLOGFILES.

ORA-01165 MAXDATAFILES may not exceed string

Cause: MAXDATAFILES specified on the command line too large.

Action: Resubmit the command with a smaller value for MAXDATAFILES.

ORA-01166 file number string is larger than string (string)

Cause: File mentioned in CREATE CONTROLFILE has a file number which is larger than that specified for MAXDATAFILES or MAXLOGFILES.

Action: Increase the maximum specified on the command line.

ORA-01167 two files are the same file/group number or the same file

Cause: There is an overlap of file numbers in the files specified on the command line or the same file is specified twice. If they are not the exact same file then one is likely to be a backup of the other. If they are two members of the same log they must be specified together in a group file specification. This message will also appear if the same control file appears more than once in the CONTROL_FILES parameter in the INIT.ORA file. If this happens, check for additional error messages.

Action: Confirm that the file mentioned is not a repeat of a file already mentioned in the command. If they are different files then omit the earlier backup. If they are members of the same log, insure they are in the same group file specification. If this message appears because of a duplicate control file, check the CONTROL_FILES parameter in the INIT.ORA file and see if a file is specified more than once. If all files names appear to be unique, check to make sure that the actual control files themselves are unique. For example, in UNIX check for a symbolic or a hard link to another control file in the list.

ORA-01168 physical block size string does not match size string of other members

Cause: The file is located on a device with a different physical block size than the other members in the group.

Action: Use a physical device with matching block size.

ORA-01169 DATAFILE number 1 not found. Must be present

Cause: Datafile number 1 was not specified in a CREATE CONTROLFILE command.

Action: Locate datafile number 1 and resubmit the CREATE CONTROLFILE command.

ORA-01170 file not found 'string'

Cause: A file specified in the CREATE CONTROLFILE statement was not found. All datafiles and all redo log files, if NORESETLOGS was used, must be accessible by the process that issues the CREATE CONTROLFILE statement.

Action: Check the statement for a typing mistake in the file name and check for the existence of all files. Then issue the statement again after correcting the file names.

ORA-01171 datafile string going offline due to error advancing checkpoint

Cause: The checkpoint in the file header could not be advanced. See accompanying errors for the reason. The datafile will be taken offline the same as for a write error of a data block.

Action: See accompanying errors for details. Restore access to the file, do media recovery, and bring it back online.

ORA-01172 recovery of thread string stuck at block string of file string

Cause: Crash recovery or instance recovery could not apply a change to a block because it was not the next change. This can happen if the block was corrupted and then repaired during recovery.

Action: Do a RECOVER DATAFILE for the file containing the block. If this does not resolve the problem, then restore the file from a backup and recover it.

ORA-01173 data dictionary indicates missing data file from system tablespace

Cause: One of the following:

  • The database is recovered to a point in time in the future of the control file.
  • A datafile from the system tablespace is omitted from the issued CREATE CONTROLFILE statement.

Action: One of the following:

  • Recover the database from a more recent control file.
  • Re-create the control file, ensuring all datafiles are included for the system tablespace in the command line.

ORA-01174 DB_FILES is string buts needs to be string to be compatible

Cause: The maximum number of database files supported by this instance is not the same as for the other instances. All instances must be able to open all the files any instance can open.

Action: Change the value of the DB_FILES parameter to be compatible.

ORA-01175 data dictionary has more than the string files allowed by the instance

Cause: The data dictionary is found to have more files than that which can be supported by this instance.

Action: Shut down the instance and restart with a larger value for DB_FILES.

ORA-01176 data dictionary has more than the string files allowed by the controlfie

Cause: After a CREATE CONTROLFILE, the data dictionary was found to have more datafiles than that supported by the control file.

Action: Re-create the control file with a larger value for MAXDATAFILES.

ORA-01177 data file does not match dictionary - probably old incarnation

Cause: When comparing the control file with the data dictionary after a CREATE CONTROLFILE or OPEN RESETLOGS, it was noted that this datafile was inconsistent with the dictionary. Most likely the file is a backup of a file that was dropped from the database, and the same file number was reused for a new file. It may also be that an incomplete recovery stopped at a time when this file number was used for another datafile.

Action: Do a CREATE CONTROLFILE with the correct file or none at all.

ORA-01178 file string created before last CREATE CONTROLFILE, cannot recreate

Cause: An attempt was made to use ALTER DATABASE CREATE DATAFILE to re-create a datafile that existed at the last CREATE CONTROL file command. The information needed to re-create the file was lost with the control file that existed when the file was added to the database.

Action: Find a backup of the file, and recover it. Do incomplete recovery to time before file was originally created.

ORA-01179 file string does not exist

Cause: During datafile recovery, a file was listed that was not part of the database.

Action: Recheck the file name. Remember to use single quotation marks at the SQL*DBA command line. Remember also that the file name is translated in the operating environment of SQL*DBA.

ORA-01180 can not create datafile 1

Cause: An attempt was made to create datafile 1 using ALTER DATABASE CREATE DATAFILE.

Action: Recover file from a backup or re-create the database.

ORA-01181 file string created before last RESETLOGS, cannot recreate

Cause: An attempt was made to use ALTER DATABASE CREATE DATAFILE to re-create a datafile that existed at the last RESETLOGS database open.

Action: Find a backup of the file, and recover it. Do incomplete recovery to time before file was originally created.

ORA-01182 cannot create database file string - file is in use or recovery

Cause: An attempt was made to use ALTER DATABASE CREATE DATAFILE to re-create a datafile that is online in an open instance or is being recovered.

Action: Close database in all instances and end all recovery sessions.

ORA-01183 cannot mount database in SHARED mode

Cause: Some other instance has the database mounted exclusive.

Action: Shut down the other instance and then mount shared.

ORA-01184 logfile group string already exists

Cause: An ALTER DATABASE ADD LOGFILE statement specified a log number for the new log which is already in use.

Action: Specify a different log file number, or let the database choose an unused value.

ORA-01185 logfile group number string is invalid

Cause: An ALTER DATABASE ADD LOGFILE statement specified a log number for the new log which is too large.

Action: Specify a correct log file number.

ORA-01186 file string failed verification tests

Cause: The datafile did not pass the checks to insure it is part of the database. See the accompanying error messages for the reason the verification failed.

Action: Make the correct file available to the database. Then, either open the database, or execute ALTER SYSTEM CHECK DATAFILES.

ORA-01187 cannot read from file string because it failed verification tests

Cause: The datafile did not pass the checks to insure it is part of the database. Reads are not allowed until it is verified.

Action: Make the correct file available to the database. Then, either open the database, or execute ALTER SYSTEM CHECK DATAFILES.

ORA-01188 Block size string in header does not match physical block size string

Cause: A log file member given to CREATE CONTROLFILE is on a physical device that has a different block size than the device originally used to create the log.

Action: Move the file to a device with the correct block size or use the RESETLOGS option to CREATE CONTROLFILE.

ORA-01189 file is from a different RESETLOGS than previous files

Cause: In a CREATE CONTROLFILE command, either this file or all previous files were backups from before the last RESETLOGS. This may also occur if this is a file that is offline and has been offline since before the last RESETLOGS.

Action: If the file was taken offline normal before the last RESETLOGS, and is still offline, omit it from the CREATE CONTROLFILE command. Rename and online the file after the database is open. Otherwise find the version of the mentioned file consistent with the rest of the datafiles and resubmit the command.

ORA-01190 controlfile or data file string is from before the last RESETLOGS

Cause: An attempt was made to use a datafile when the log reset information in the file does not match the control file. Either the datafile or the control file is a backup that was made before the most recent ALTER DATABASE OPEN RESETLOGS.

Action: Restore file from a more recent backup.

ORA-01191 file string is already offline - cannot do a normal offline

Cause: When attempting to do a normal tablespace offline, it was discovered that one of the files in the tablespace was already offline.

Action: Either bring the datafile online first, or use another tablespace offline option.

ORA-01192 must have at least one enabled thread

Cause: At least two redo log files from at least one thread must be specified in the CREATE CONTROLFILE command line.

Action: Find the missing redo log files and retry the command with the newly found redo log files included in the command line.

ORA-01193 file string is not the same file seen at start of recovery

Cause: A different copy of the file was accessed the last time media recovery looked at the file header. A backup of the file was restored or the meaning of the file name changed during recovery.

Action: Ensure the correct file is available, and then retry recovery.

ORA-01194 file string needs more recovery to be consistent

Cause: An incomplete recovery session was started, but an insufficient number of logs were applied to make the file consistent. The reported file was not closed cleanly when it was last opened by the database. It must be recovered to a time when it was not being updated. The most likely cause of this error is forgetting to restore the file from a backup before doing incomplete recovery.

Action: Either apply more logs until the file is consistent or restore the file from an older backup and repeat recovery.

ORA-01195 online backup of file string needs more recovery to be consistent

Cause: An incomplete recovery session was started, but an insufficient number of logs were applied to make the file consistent. The reported file is an online backup which must be recovered to the time the backup ended.

Action: Either apply more logs until the file is consistent or restore the database files from an older backup and repeat recovery.

ORA-01196 file string is inconsistent due to a failed media recovery session

Cause: The file was being recovered but the recovery did not terminate normally. This left the file in an inconsistent state. No more recovery was successfully completed on this file.

Action: Either apply more logs until the file is consistent or restore the backup again and repeat recovery.

ORA-01197 thread string only contains one log

Cause: During CREATE CONTROLFILE all threads represented in the logs must be represented by at least two logs. A "last log" and a second log. The named thread does not contain two such logs.

Action: Either find more logs from the named thread. Or use the RESETLOGS option to CREATE CONTROLFILE.

ORA-01198 must specify size for log file if RESETLOGS

Cause: File sizes must be given for all log files if doing a CREATE CONTROLFILE with the RESETLOGS option.

Action: Resubmit the command with the appropriate log file size.

ORA-01199 file string is not in online backup mode

Cause: An attempt was made to end an online backup for a file that is not in online backup.

Action: Do not enter command since it is not needed.

ORA-01200 actual file size of string is smaller than correct size of string blocks

Cause: The size of the file as returned by the operating system is smaller than the size of the file as indicated in the file header and the control file. Somehow the file has been truncated. Maybe it is the result of a half completed copy.

Action: Restore a good copy of the datafile and do recovery as needed.

ORA-01201 file string header failed to write correctly

Cause: An I/O error was reported for the file header. The error was trapped and a second attempt will be made.

Action: The file probably will require recovery. Further error messages will indicate what is needed.

ORA-01202 wrong incarnation of this file - wrong creation time

Cause: The creation time in the file header is not the same as the creation time in the control file. This is probably a copy of a file that was dropped.

Action: Restore a current copy of the datafile and do recovery as needed.

ORA-01203 wrong incarnation of this file - wrong creation SCN

Cause: The creation SCN in the file header is not the same as the creation SCN in the control file. This is probably a copy of a file that was dropped.

Action: Restore a current copy of the datafile and do recovery as needed.

ORA-01204 file number is string rather than string - wrong file

Cause: The file number in the file header is not correct. This is probably a restored backup of the wrong file, but from the same database.

Action: Restore a copy of the correct datafile and do recovery as needed.

ORA-01205 not a data file - type number in header is string

Cause: The file type in the header is not correct for a datafile. This is probably a log file or control file. If the type is not a small non-zero positive number then the header is corrupted.

Action: Restore a copy of the correct datafile and do recovery as needed.

ORA-01206 file is not part of this database - wrong database id

Cause: The database ID in the file header does not match the database ID in the control file. The file may be from a different database, or it may not be a database file at all. If the database was rebuilt, this may be a file from before the rebuild. Note that if you see this error when the file is supposed to be plugged in from another database via the Transportable Tablespace feature, it means the database ID in the file header does not match the one expected.

Action: Restore a copy of the correct datafile and do recovery as needed.

ORA-01207 file is more recent than controlfile - old controlfile

Cause: The control file change sequence number in the datafile is greater than the number in the control file. This implies that the wrong control file is being used. Note that repeatedly causing this error can make it stop happening without correcting the real problem. Every attempt to open the database will advance the control file change sequence number until it is great enough.

Action: Use the current control file or do BACKUP CONTROLFILE RECOVERY to make the control file current. Be sure to follow all restrictions on doing a BACKUP CONTROLFILE RECOVERY.

ORA-01208 data file is an old version - not accessing current version

Cause: The checkpoint in the file header is less recent than in the control file. If opening a database that is already open by another instance, or if another instance just brought this file online, the file accessed by this instance is probably a different version. Otherwise, a backup of the file probably was restored while the file was in use.

Action: Make the correct file available to the database. Then, either open the database, or execute ALTER SYSTEM CHECK DATAFILES.

ORA-01209 data file is from before the last RESETLOGS

Cause: The reset log data in the file header does not match the control file. If the database is closed or the file is offline, the backup is old because it was taken before the last ALTER DATABASE OPEN RESETLOGS statement. If opening a database that is open already by another instance, or if another instance just brought this file online, the file accessed by this instance is probably a different version. Otherwise, a backup of the file probably was restored while the file was in use.

Action: Make the correct file available to the database. Then, either open the database or execute ALTER SYSTEM CHECK DATAFILES.

ORA-01210 data file header is media corrupt

Cause: The file header block is internally inconsistent. The beginning of the block has a header with a checksum and other data for insuring the consistency of the block. It is possible that the last disk write did not operate correctly. The most likely problem is that this is not a datafile for any database.

Action: Have operating system make correct file available to database. If the trace file dump indicates that only the checksum is wrong, restore from a backup and do media recovery.

ORA-01211 Oracle7 data file is not from migration to Oracle8

Cause: The file is not a copy of the file LAST used under Oracle7. This datafile is either a backup taken from before the migration, or the database was opened by Oracle7 after the migration utility was run. When converting a database from Oracle7 to Oracle8, the migration program MUST be the LAST utility to access the database under Oracle7. Only the datafiles that were current when the migration was done may be accessed by Oracle8.

Action: Have operating system make correct datafile available to database, or repeat the Oracle7 to Oracle8 migration. Make sure that database is NOT opened after migration utility is run.

ORA-01212 MAXLOGMEMBERS may not exceed string

Cause: MAXLOGMEMBERS specified on the command line too large.

Action: Resubmit the command with a smaller value for MAXLOGMEMBERS.

ORA-01213 MAXINSTANCES may not exceed string

Cause: MAXINSTANCES specified on the command line too large.

Action: Resubmit the command with a smaller value for MAXINSTANCES.

ORA-01214 MAXLOGHISTORY may not exceed string

Cause: MAXLOGHISTORY specified on the command line too large.

Action: Resubmit the command with a smaller value for MAXLOGHISTORY.

ORA-01215 enabled thread string is missing after CREATE CONTROLFILE

Cause: A CREATE CONTROLFILE statement was given which did not list all the enabled threads for the database.

Action: Reissue the CREATE CONTROLFILE statement, including all enabled threads.

ORA-01216 thread string is expected to be disabled after CREATE CONTROLFILE

Cause: A thread that was given during CREATE CONTROLFILE is enabled, but the datafiles indicate that it should be disabled. This is probably because the logs supplied to the CREATE CONTROLFILE are old (from before the disabling of the thread).

Action: This thread is not required to run the database. The CREATE CONTROLFILE statement can be reissued without the problem thread, and, if desired, the thread can be re-created after the database is open.

ORA-01217 logfile member belongs to a different logfile group

Cause: A member of a multiple-member log file group specified in a CREATE CONTROLFILE is not part of the same group as previous members.

Action: Group together the correct members for the CREATE CONTROLFILE command.

ORA-01218 logfile member is not from the same point-in-time

Cause: A member of a multiple-member log file group is from a different point in time. One of the members specified may be an older (backup) copy of the log.

Action: Find the correct version of the log, or leave it out of the CREATE CONTROLFILE command.

ORA-01219 database not open: queries allowed on fixed tables/views only

Cause: A query was issued against an object not recognized as a fixed table or fixed view before the database has been opened.

Action: Re-phrase the query to include only fixed objects, or open the database.

ORA-01220 file based sort illegal before database is open

Cause: A query issued against a fixed table or view required a temporary segment for sorting before the database was open. Only in-memory sorts are supported before the database is open.

Action: Re-phrase the query to avoid a large sort, increase the values of the SORT_AREA_SIZE and/or SORT_AREA_RETAINED_SIZE initialization parameters to enable the sort to be done in memory.

ORA-01221 data file string is not the same file to a background process

Cause: When the database writer opens the datafile, it is accessing a different physical file than the foreground doing the recovery. The timestamp set in the file header by the foreground was not found by the background. It may be that the background process could not read the file at all.

Action: Look in the DBWR trace file for the error it received when attempting to read the file header. Reconfigure the operating system as needed to have the file name successfully access the same file when opened by a background process.

ORA-01222 MAXINSTANCES of string requires MAXLOGFILES be at least string, not string

Cause: An attempt was made to create a database or control file that does not have room for at least two logs per thread of redo. A thread of redo must have two online logs in order to be enabled. It does not make sense to allow more redo threads than can be supported by the logs.

Action: Either reduce the MAXINSTANCES argument or increase the value of MAXLOGFILES.

ORA-01223 RESETLOGS must be specified to set a new database name

Cause: The SET database name option was specified to CREATE CONTROLFILE, but RESETLOGS was not specified. The database name can only be changed when opening the database with RESETLOGS.

Action: Either add the RESETLOGS option or drop the SET option to CREATE CONTROLFILE.

ORA-01224 group number in header string does not match GROUP string

Cause: Group number specified at CREATE CONTROLFILE does not match the group number stored in the header. Most likely the specification is wrong.

Action: Omit the GROUP option or give the correct one.

ORA-01225 thread number string is greater than MAXINSTANCES string

Cause: The log is for a thread greater than the MAXINSTANCES argument.

Action: Increase the value for MAXINSTANCES and resubmit the command.

ORA-01226 file header of log member is inconsistent with other members

Cause: The log file member in the accompanying error is for the same group as the previous members, but other fields in the header are different. Either a file header is corrupted, or some file is a member of a deleted log.

Action: Find the correct log member or omit this member from the command.

ORA-01227 log string is inconsistent with other logs

Cause: The log file in the accompanying error is inconsistent with the contents of other logs given in the CREATE CONTROLFILE command. Either a file header is corrupted, or some file is an old copy rather than the current version. The problem may not be with the log listed since all that can be detected is that there is an inconsistency. All log files listed in the command must be the current versions of the online logs.

Action: Find the correct online logs or use the RESETLOGS option.

ORA-01228 SET DATABASE option required to install seed database

Cause: The SET DATABASE option was not included in the CREATE CONTROLFILE command when installing a seed database. The database does not have a database ID because it is intended to be installed at multiple sites, and each site needs to be a different database with its own database id. Both the SET DATABASE and RESETLOGS options must be specified to create the control file for this database.

Action: Resubmit command with the SET DATABASE and RESETLOGS options.

ORA-01229 data file string is inconsistent with logs

Cause: The datafile in the accompanying error is inconsistent with the contents of the logs given in the CREATE CONTROLFILE command. The most likely cause is that one or more of the online logs was missing from the command. It is also possible that one or more of the logs is an old copy rather than the current version. All online log files must be listed in the command and must be the current versions of the online logs.

Action: Find the correct online logs or use the RESETLOGS option.

ORA-01230 cannot make read only - file string is offline

Cause: An attempt to make a tablespace read only found that one of its files is offline.

Action: Bring the file online and retry this command.

ORA-01231 cannot make read write - file string is offline

Cause: An attempt to make a tablespace read write found that one of its files is offline.

Action: Bring the file online and retry this command.

ORA-01232 cannot start online backup - file string is read only

Cause: An attempt to start an online backup found that one of the files is marked read only. Read-only files do not need to be set into online backup mode.

Action: Make the backup without the begin backup command.

ORA-01233 file string is read only - cannot recover using backup controlfile

Cause: An attempt to do media recovery using a backup control file found that one of the files is marked read only. Read-only files do not normally need to be recovered, but recovery with a backup control file must recover all online files.

Action: If the file really is read only, take it offline before the recovery, and bring the read-only tablespace online after the database is open. If the file does need recovery use a control file from the time the file was read-write. If the correct control file is not available, use CREATE CONTROLFILE to make one.

ORA-01234 cannot end backup of file string - file is in use or recovery

Cause: An attempt was made to end an online backup of file when the file is busy. Some operation such as recovery or rename may be active, or there may still be some instance that has the database open with this file online.

Action: If there is an instance with the database open then the backup can be ended there by using the ALTER TABLESPACE command. Otherwise wait for the completion of the other operation.

ORA-01235 END BACKUP failed for string file(s) and succeeded for string

Cause: One or more of the files in an end backup command failed. Some other files given in the same command may have succeeded.

Action: See the accompanying error messages for the reason the backups could not be ended. Any files not listed in the error messages were successful.

ORA-01236 Error string occurred during initialization of file header access

Cause: The indicated error occurred while doing initialization processing of file headers.

Action: The error indicated should be corrected. An attempt is made to recover from this error by using a slower access algorithm.

ORA-01237 cannot extend datafile string

Cause: An operating system error occurred during the resize.

Action: Fix the cause of the operating system error and retry the command.

ORA-01238 cannot shrink datafile string

Cause: An operating system error occurred during the resize.

Action: The error is ignored, operation continues normally.

ORA-01239 database must be in ARCHIVELOG mode to use external cache

Cause: An online file uses an external cache, but the database is in NOARCHIVELOG mode. Since an external cache may require media recovery this cannot be allowed.

Action: Change database to be in ARCHIVELOG mode or do not use an external cache.

ORA-01240 too many data files to add in one command

Cause: The command specifies adding more datafiles than can be done in one command. It is necessary to fit all the file names into one log entry, but that would make the entry too large.

Action: If this is a CREATE TABLESPACE command, create with fewer files then add the other files later. If this is an ADD DATAFILE command, break it up into multiple commands.

ORA-01241 an external cache has died

Cause: The external cache may have been restarted.

Action: Take the file mentioned in the error stack offline, perform media recovery, bring the file online, and retry the attempted operation. You may also restart all instances to make sure they access all datafiles through consistent external caches.

ORA-01242 data file suffered media failure: database in NOARCHIVELOG mode

Cause: The database is in NOARCHIVELOG mode and a database file was detected as inaccessible due to media failure.

Action: Restore accessibility to the file mentioned in the error stack and restart the instance.

ORA-01243 system tablespace file suffered media failure

Cause: A system tablespace file was detected as inaccessible due to media failure.

Action: Restore accessibility to the file mentioned in the error stack and restart the instance.

ORA-01244 unnamed datafile(s) added to controlfile by media recovery

Cause: Media recovery with a backup control file or a control file that was rebuilt, encountered the creation of a datafile that was not in the control file. An entry has been added to the control file for the new datafiles, but with the file name UNNAMEDnnnn, where nnnn is the file number. Attached errors describe the file names that were originally used to create the files.

Action: Rename the files to valid file names and resume recovery. If necessary the ALTER DATABASE CREATE DATAFILE statement may be used to create a file suitable for recovery and do the rename. If the file is not going to be recovered then take it offline with the FOR DROP option.

ORA-01245 offline file string will be lost if RESETLOGS is done

Cause: An attempt was made to do an OPEN RESETLOGS with a file that will be lost because it is offline. The file was not taken offline with the FOR DROP option.

Action: Either bring the file online and recover it, or take it offline with the FOR DROP option.

ORA-01246 recovering files through TSPITR of tablespace string

Cause: The files named in the accompanying errors are backups that were made before a tablespace point in time recovery of this tablespace. They cannot be recovered to a time after the point in time recovery.

Action: Restore more recent backups and recover them.

ORA-01247 database recovery through TSPITR of tablespace string

Cause: Recovery of the whole database encountered redo indicating there was a point in time recovery of the tablespace. The new version of the files in the tablespace should be included in the recovery, but that was not done.

Action: If the tablespace should not be recovered, take its file offline for drop. If it should be recovered, then restore or rename as needed and restart the recovery.

ORA-01248 file string was created in the future of incomplete recovery

Cause: An attempt was made to do a RESETLOGS open with a file entry in the control file that was originally created after the UNTIL time of the incomplete recovery. Allowing such an entry may hide the version of the file that is needed at this time. The file number may be in use for a different file which would be lost if the RESETLOGS was allowed.

Action: If more recovery is desired then apply redo until the creation time of the file is reached. If the file is not wanted and the same file number is not in use at the stop time of the recovery, then the file can be taken offline with the FOR DROP option. Otherwise a different control file is needed to allow the RESETLOGS. Another backup can be restored and recovered, or a control file can be created via CREATE CONTROLFILE.

ORA-01249 archiving not allowed in a clone database

Cause: An attempt was made to archive an online redo log or enable archiving for a clone database.

Action: Do not attempt to archive from a clone. The archive log destination could easily be the same as the primary database destroying its archived logs. If archiving is needed, then re-create the database not as a clone.

ORA-01250 Error string occurred during termination of file header access

Cause: The indicated error occurred while terminating the processing of file headers. The error was other than a write error.

Action: The indicated error should be corrected.

ORA-01251 Unknown File Header Version read for file number string

Cause: Read of the file header returned a record but its version cannot be identified. Either the header has been corrupted, or the file is not a valid database file.

Action: Have the operating system make the correct file available to the database, or recover the file.

ORA-01252 cannot prevent writes - file string in recovery manager backup

Cause: An attempt to make a tablespace read only or offline normal found that a recovery manager proxy backup is in progress. If the file is made offline or read only, then the file header cannot be updated when the backup is complete.

Action: Wait for the Recovery Manager backup to complete and retry this command.

ORA-01253 cannot start online backup - file string in recovery manager backup

Cause: The specified file is being backed up by Recovery Manager.

Action: Wait for the Recovery Manager proxy backup to complete before starting another backup.

ORA-01254 cannot end online backup - file string in recovery manager backup

Cause: The specified file is being backed up by Recovery Manager.

Action: Wait for the Recovery Manager proxy backup to complete. Recovery Manager backup mode cannot be initiated or terminated manually.

ORA-01255 cannot shutdown - file string in recovery manager backup

Cause: An attempt to shut down normally found that a Recovery Manager backup is still in progress.

Action: Wait for the Recovery Manager proxy backup to complete and retry this command.

ORA-01256 error in locking database file string

Cause: The file is in use by another database instance.

Action: Determine which database instance legitimately owns the file.

ORA-01257 cannot reuse database file string, unknown file size

Cause: The size of the raw partion cannot be determined.

Action: Add the datafile/logfile by specifying the size parameter.

ORA-01258 unable to delete temporary file string

Cause: A DROP TABLESPACE INCLUDING CONTENTS AND DATAFILES or ALTER DATABASE TEMPFILE DROP INCLUDING DATAFILES operation was not able to delete a temporary file in the database.

Action: Subsequent errors describe the operating system error that prevented the file deletion. Fix the problem, if possible, and manually purge the file.

ORA-01259 unable to delete datafile string

Cause: A DROP TABLESPACE INCLUDING CONTENTS AND DATAFILES operation was not able to delete a datafile in the tablespace.

Action: Subsequent errors describe the operating system error that prevented the file deletion. Fix the problem, if possible, and manually purge the file.

ORA-01260 may not issue ALTER DATABASE END BACKUP when database is open

Cause: ALTER DATABASE END BACKUP was issued while the database was open.

Action: Either use ALTER DATABASE DATAFILE <filename> END BACKUP to end backup for specific files, or ALTER TABLESPACE <name> END BACKUP if backup is complete for all files in a tablespace.

ORA-01261 Parameter string destination string cannot be translated

Cause: The value for the specified parameter contained a destination string that could not be translated.

Action: Use a valid destination string in the specified parameter.

ORA-01262 Stat failed on a file destination directory

Cause: Unable to get information about an Oracle Managed Files destination directory.

Action: Check the permissions on the directory or use a different directory name.

ORA-01263 Name given for file destination directory is invalid

Cause: The name given for an Oracle Managed Files destination does not correspond to a directory.

Action: Use a different name.

ORA-01264 Unable to create string file name

Cause: Unable to create an Oracle Managed Files name for a datafile, logfile or control file.

Action: Check previous error messages for the reason Oracle was unable to create the file name. Take corrective action, if possible, and retry the command.

ORA-01265 Unable to delete file string

Cause: An error prevented the file from being deleted.

Action: Subsequent errors describe the operating system error that prevented the file deletion. Fix the problem, if possible, and manually purge the file.

ORA-01266 Unable to create unique file name

Cause: Unable to create a unique file name for an Oracle Managed Files datafile, logfile, or control file. Oracle tried several names but each file name was already in use in the default destination directory for the file type.

Action: Retry the operation. If that fails, it may be necessary to change the default destination directory for the file type and then retry.

ORA-01267 Failure getting date/time

Cause: Could not get date/time when trying to create unique file name.

Action: Internal error - contact Oracle Support Services.

ORA-01268 invalid TEMPFILE clause for alter of permanent TABLESPACE

Cause: A TEMPFILE clause was specified for an ALTER TABLESPACE for a permanent tablespace.

Action: Retry with a DATAFILE clause.

ORA-01269 Destination parameter string is too long

Cause: The value for DB_CREATE_FILE_DEST or DB_CREATE_ONLINE_LOG_DEST_n parameter is too long.

Action: Replace the destination value for the specified parameter with a shorter character string.

ORA-01270 string operation is not allowed if STANDBY_PRESERVES_NAMES is true

Cause: An operation that renames or adds/drops a file was attempted at a standby database and STANDBY_PRESERVES_NAMES is true.

Action: Set STANDBY_PRESERVES_NAMES to false if the operation must be performed.

ORA-01271 Unable to create new file name for file string

Cause: During standby database recovery an error occurred when trying to create a new file name for the indicated file.

Action: Use the ALTER DATABASE CREATE DATAFILE command with a new unique name and then resume the standby database recovery.

ORA-01272 REUSE only allowed when a file name is provided

Cause: The REUSE parameter was specified in a command without a file name.

Action: Either supply a file name or remove the REUSE parameter.

ORA-01273 STANDBY_FILE_MANAGEMENT = AUTO needs COMPATIBLE = string or higher

Cause: The COMPATIBLE initialization parameter was not set to the correct value for setting STANDBY_FILE_MANAGEMENT to AUTO.

Action: Restart the instance with COMPATIBLE set to the correct release.

ORA-01274 cannot add datafile 'string' - file could not be created

Cause: Automated standby file management was enabled but an added file could not automatically be created on the standby. The error from the creation attempt is displayed in another message. The controlfile file entry for the file will be 'UNNAMEDnnnnn'.

Action: Temporarily set STANDBY_FILE_MANAGEMENT to MANUAL and use the ALTER DATABASE CREATE DATAFILE statement to create the file. Then set STANDBY_FILE_MANAGEMENT to AUTO and restart standby recovery.

ORA-01275 Operation string is not allowed if standby file management is automatic.

Cause: An operation that renames, adds, or drops a file was attempted at a standby database and STANDBY_FILE_MANAGEMENT was set to AUTO.

Action: Set STANDBY_FILE_MANAGEMENT to MANUAL if the operation must be performed.

ORA-01276 Cannot add file string. File has an Oracle Managed Files file name.

Cause: An attempt was made to add to the database a datafile, log file, or control file with an Oracle Managed Files file name.

Action: Retry the operation with a new file name.

ORA-01277 file 'string' already exists

Cause: An ALTER DATABASE BACKUP CONTROLFILE TO TRACE AS 'filename' statement specified a file name which is already in use.

Action: Either specify a different file name or add the REUSE parameter to the statement to overwrite the existing file.

ORA-01278 error creating file 'string'

Cause: An operating system error occurred while attempting to create a trace file specified in the ALTER DATABASE BACKUP CONTROLFILE TO TRACE AS 'filename' statement.

Action: Check the error stack for more detailed information.

ORA-01279 DB_FILES too large

Cause: DB_FILES has been set too high to be supported by the system.

Action: Decrease the value of DB_FILES.

ORA-01280 Fatal LogMiner Error.

Cause: On of the following:

  • One or more input parameters in the DBMS_LOGMNR.START_LOGMNR() procedure may be invalid.
  • The start or the end SCN may not be available in the log files selected.
  • The dictionary file specified may be from a different database than the one that generated the log files.
  • LogMiner may have encountered an internal error from which it cannot recover.

Action: Check to see whether the input parameters are valid. The V$LOGMNR_LOGS view can be queried to see the SCN ranges that are valid for the set of log files specified, and the DB_ID of the database that generated the log files.

ORA-01281 SCN range specified in dbms_logmnr.start_logmnr() is invalid

Cause: StartSCN may be greater than EndSCN, or the SCN specified may be invalid.

Action: Specify a valid SCN range.

ORA-01282 date range specified in dbms_logmnr.start_logmnr() is invalid

Cause: The specified Date value is invalid for the log file.

Action: Specify a valid date range.

ORA-01283 Options specified is invalid

Cause: The specified Options is invalid for the procedure.

Action: Specify valid Options.

ORA-01284 file string cannot be opened

Cause: The specified file cannot be opened.

Action: Check to make sure the file or directory exists and is accessible.

ORA-01285 error reading file string

Cause: The file or directory may not exist or is inaccessible.

Action: Specify valid file or directory. Make sure that file and directory are accessible.

ORA-01286 cannot add file string due to DB_ID mismatch

Cause: The log file is produced by a different database than other log files already added to the list.

Action: Specify a log file produced by the same database.

ORA-01287 file string is from a different database incarnation

Cause: The logfile was produced by a different incarnation of the database.

Action: Add a logfile that is produced by the same incarnation.

ORA-01288 file string is from a different database incarnation

Cause: The logfile is produced by a different incarnation of the database.

Action: Add a logfile that is produced by the same incarnation.

ORA-01289 cannot add duplicate logfile string

Cause: The log file specified has already been added to the list of log files.

Action: Specify a different log file.

ORA-01290 cannot remove unlisted logfile string

Cause: The user attempted to remove a log file that is not present in the list.

Action: Specify a valid logfile.

ORA-01291 missing logfile

Cause: Not all logfiles corresponding to the data or scn range specified have been added to the list.

Action: Check the v$logmnr_logs view to determine the missing scn range, and add the relevant logfiles.

ORA-01292 no log file has been specified for the current LogMiner session

Cause: No log file has been specified for the LogMiner session.

Action: Specify at least one log file.

ORA-01293 time or SCN range not fully contained in the listed logfiles

Cause: The input date/SCN range is not fully contained within the log files specified for the session.

Action: Select out of V$LOGMNR_LOGS view to check the date or SCN range covered by the log files specified for the LogMiner session, and reissue the procedure with appropriate date or SCN range.

ORA-01294 error occurred while processing information in dictionary file string, possible corruption

Cause: The dictionary file is corrupt.

Action: Get a new dictionary file.

ORA-01295 DB_ID mismatch between dictionary string and logfiles

Cause: The dictionary file is produced by a database that is different from that produced the log files.

Action: Specify a compatible dictionary file.

ORA-01296 character set mismatch between dictionary string and logfiles

Cause: The character set of the database that produced the dictionary file is different from the character set of the database that produced the log files.

Action: Specify a dictionary file with the same character set.

ORA-01297 redo version mismatch between dictionary string and logfiles

Cause: The redo version of the database generating the dictionary is different from the one generating the logfiles.

ORA-01298 dictionary string and the earliest logfile are not SCN-compatible

Cause: The dictionary materialized view was taken at a SCN that does not correspond to the creation SCN of the earliest logfile.

Action: Get a correct dictionary materialized view.

ORA-01299 dictionary string corresponds to a different database incarnation

Cause: The dictionary file was extracted from a different incarnation of the database.

Action: Specify a dictionary file extracted from the correct database incarnation.

ORA-01300 enabled thread bit vector mismatch between dictionary string and the earliest logfile

ORA-01301 dbms_logmnr.USE_COLMAP can only be used with a valid dictionary

Cause: DBMS_LOGMNR.USE_COLMAP can only be used with a valid dictionary.

Action: Specify the dictionary file in DBMS_LOGMNR.START_LOGMNR().

ORA-01302 syntax error in logmnr.opt file

Cause: A syntax error was detected in the logmnr.opt file.

Action: Use correct syntax.

ORA-01303 schema string, specified in logmnr.opt file, does not exist

Cause: The schema specified does not exist.

Action: Specify a correct schema or a compatible dictionary file.

ORA-01304 table string, schema string, specified in logmnr.opt file, does not exist

Cause: The table specified in the logmnr.opt file does not exist in the dictionary provided to LogMiner.

Action: Make sure that the table specified is valid.

ORA-01305 column string, specified in logmnr.opt file, does not exist in table string, schema string

Cause: The column specified in the logmnr.opt file does not exist for the table definition in the dictionary provided for LogMiner.

Action: Make sure that the column specified is valid.

ORA-01306 dbms_logmnr.start_logmnr() must be invoked before selecting from v$logmnr_contents

Cause: A select was issued from V$LOGMNR_CONTENTS without first invoking the DBMS_LOGMNR.START_LOGMNR() procedure.

Action: Invoke the DBMS_LOGMNR.START_LOGMNR() procedure before issuing a select from the V$LOGMNR_CONTENTS view.

ORA-01307 no LogMiner session is currently active

Cause: A select was issued from V$LOGMNR_CONTENTS without first invoking the DBMS_LOGMNR.START_LOGMNR() procedure. Otherwise, DBMS_LOGMNR.END_LOGMNR() was called without a prior call to DBMS_LOGMNR.START_LOGMNR() or DBMS_LOGMNR.ADD_LOGFILE()

Action: Invoke the DBMS_LOGMNR.START_LOGMNR() procedure before issuing a select from the V$LOGMNR_CONTENTS view.

ORA-01308 initialization parameter utl_file_dir is not set

Cause: UTL_FILE_DIR is not set in the initialization parameter file.

Action: Set UTL_FILE_DIR to the appropriate directory.

ORA-01309 invalid session

Cause: The specified Logminer session ID or session handle is invalid.

Action: Use a valid Logminer session ID or session handle.

ORA-01310 requested return type not supported by the lcr_mine function

Cause: The return type requested by the user is not supported by LCR_MINE.

Action: Pick a return type supported by the LCR_MINE function.

ORA-01311 Illegal invocation of the mine_value function

Cause: An attempt was made to use the MINE_VALUE function on a column other than redo_value or undo_value columns of SYS.V$LOGMNR_CONTENTS fixed table/view.

Action: Rewrite the SQL statement with a legal invocation of MINE_VALUE.

ORA-01312 Specified table/column does not exist

Cause: The table/column specified in the LCR_MINE call does not exist at the the specified SCN. The table/column definition has to exist at the start SCN specified for lcr_mine to be able to identify the table/column correctly.

Action: Create a LogMiner session at a start SCN at which the table definition is available.

ORA-01313 LogMiner dictionary column type different from specified type

Cause: The return type specified for the column in the LCR_MINE call is different from the actual type of the column.

Action: Rewrite the LCR_MINE invocation with the right return type.

ORA-01314 Name of the column to be mined should be a string literal

Cause: The fully qualified name of the column to be mined by the LogMiner functions should be string literal.

Action: If the fully qualified name of the column to be mined is a.b.c.d, enclose the column name in quotes as in 'a.b.c.d'.

ORA-01315 Log file has been added or removed during select

Cause: A redo log file has been added or removed while selecting on the v$logmnr_logs fixed view.

Action: Re-issue the SQL select statement on the v$logmnr_logs view.

ORA-01316 Already attached to a Logminer session

Cause: A Logminer attach session was issued while already attached to a Logminer session.

Action: Detach from the current Logminer session and attach to the requested session.

ORA-01317 Not attached to a Logminer session

Cause: A command or procedure was issued which requires an attached Logminer session.

Action: Attach to a Logminer session before issuing the command or procedure.

ORA-01318 Logminer session not started

Cause: Logminer activate session was called before prepare session.

ORA-01319 Invalid Logminer session attribute

Cause: A session attribute was supplied which is invalid.

Action: Re-issue with a valid session attribute.

ORA-01320 Invalid Logminer dictionary attribute

Cause: A Logminer dictionary attribute was supplied which is invalid.

Action: Re-issue with a valid dictionary attribute.

ORA-01321 SCN range not fully contained in the listed logfiles

Cause: The input date/SCN range is not fully contained within the logfiles specified for the session.

Action: select out of v$logmnr_logs view to check the date or SCN range covered by the logfiles specified for the LogMiner session , and reissue the procedure with appropriate date or SCN range.

ORA-01322 No such table

Cause: An non-existent table was supplied to Logminer include_src_tbl() or exclude_src_table().

Action: Re-issue with a valid table name.

ORA-01323 Invalid state

Cause: A Logminer routine was called from the wrong state.

ORA-01324 cannot add file due to DB_ID mismatch

Cause: The logfile was produced by a different database than other logfiles already added to the list.

Action: Specify a logfile produced by the same database.

ORA-01325 archive log mode must be enabled to build into the logstream

Cause: The database does not have archivelog mode enabled.

Action: Ensure that initialization parameters enabling archivelog mode are set. For example:

log_archive_start=truelog_archive_dest="ORACLE_HOME/dbs"log_archive_format="archstring.log"

Mount the database and issue commands to enable archivelog mode.

startup pfile=initsid.ora mountALTER DATABASE ARCHIVELOGALTER DATABASE OPEN

ORA-01326 compatibility of 9.0.0 or greater required to build into the logstream

Cause: The COMPATIBLE initialization parameter is set to some value less than 9.0.0.

Action: Ensure that the COMPATIBLE initialization parameter is set to 9.0.0 or higher. For example:

COMPATIBLE = 9.0.0.0.0

ORA-01327 failed to exclusively lock system dictionary as required by build

Cause: Other users are performing DDL operations.

ORA-01328 only one build operation may occur at one time

Cause: Another process is simultaneously attempting to run build().

Action: Wait until the other process completes.

ORA-01329 unable to truncate required build table

Cause: The table may be missing or locked by another user.

Action: This error should not occur. If it does occur and there is reason to believe that required tables are missing, then as a last resort the package dbmslmd.sql may be reinstalled. Doing so will delete all existing Logminer Dictionary data.

ORA-01332 internal Logminer Dictionary error

Cause: Unexpected error condition.

Action: Check the trace file.

ORA-01333 failed to establish Logminer Dictionary

Cause: No previously established Logminer Dictionary is available and a complete gather of a source system data dictionary was not found in the logstream. build() may not have been run to force the gathering of a source system data dictionary, or add_log_file() may not have been called to add all log files which contain the complete gathered system data dictionary.

Action: If build() was not employed prior to this mining session, the Logminer Ad Hoc user may elect to employ an alternate dictionary such as the current system catalog or a previously built flat file dictionary. Other Logminer clients must run build() prior to mining. If build() has been run, ensure that all logfiles which comprise the gathered system dictionary have been added. The following query, run on the system which build() was run, can be helpful in identifying the required files.

select DICTIONARY_BEGIN, DICTIONARY_END, name from v$archived_log;

Minimally a set of files starting with one which has DICTIONARY_BEGIN = 'YES' and all subsequent log files through one which has DICTIONARY_END = \qYESmustbeadded.'

ORA-01336 specified dictionary file cannot be opened

Cause: The dictionary file or directory does not exist or is inaccessible.

Action: Make sure that the dictionary file and directory exist and are accessible.

ORA-01337 log file has a different compatibility version

Cause: The logfile has a different compatibility version than the rest of the logfiles in the session.

Action: Make sure that all logfiles in the session have the same compatibility version.

ORA-01338 Other process is attached to LogMiner session

Cause: Can not do this when other process is attached to LogMiner session.

ORA-01339 logfile is too old

Cause: An attempt was made to add an already processed logfile.

ORA-01340 NLS error

Cause: Could not load NLS package.

ORA-01341 LogMiner out-of-memory

Cause: The logfiles to be analyzed in the current LogMiner session require more system resources than what is currently available.

Action: Reduce the number of logfiles to be analyzed for a given LogMiner session and try again.

ORA-01342 LogMiner can not resume session due to inability of staging checkpointed data

Cause: Logminer can not resume session because there is not enough SGA memory available to read in checkpointed data. Logminer periodically checkpoints data to enable faster crash recovery.

Action: Specify a bigger max_sga for the given LogMiner session and try again.

ORA-01344 LogMiner coordinator already attached

Cause: A coordinator process is already attached to the specified logminer context.

Action: Detach from the active coordinator session and retry the attach.

ORA-01345 Supplemental log data must be enabled to build into the logstream

Cause: Supplemental log data must be enabled on this database instance.

Action: Enable supplemental log data.

ORA-01346 Dependent LogMiner sessions relying on supplementally logged data exist

Cause: LogMiner sessions exist on this database instance which rely on the existence of supplemental log data.

Action: Destroy all LogMiner sessions on this instance which are mining log files from this same instance. Then reissue the command.

ORA-01347 Supplemental log data no longer found

Cause: The source database instance producing log files for this LogMiner session was altered to no longer log supplemental data.

Action: Destroy this Logminer session. Re-enable supplemental log data on the source system and create a new LogMiner session.

ORA-01350 must specify a tablespace name

Cause: Invocation failed to specify either a dictionary tablespace or a spill tablespace.

Action: Reformat invocation of DBMS_LOGMNR_D.SET_TABLESPACE to include the name of one or more tablespaces.

  • NEW_TABLESPACE - A string naming an existing tablespace.

    Supply only this parameter to recreate all Logminer tables to employ this tablespace.

  • DICTIONARY_TABLESPACE - A string naming an existing tablespace.

    Supply this parameter when it is desired to place Logminer Dictionary data in a tablespace different from that where Logminer spill data is to be written. This parameter overrides the new_tablespace parameter with respect to Logminer Dictionary tables.

  • SPILL_TABLESPACE - a string naming an existing tablespace.

    Supply this parameter when it is desired to place Logminer spill data in a tablespace different from that where Logminer Dictionary data is to be written. This parameter overrides the new_tablespace parameter with respect to Logminer spill tables.

ORA-01351 tablespace given for Logminer dictionary does not exist

Cause: The tablespace name given as either the NEW_TABLESPACE or the DICTIONARY_TABLESPACE parameter to DBMS_LOGMNR_D.SET_TABLESPACE does not exist.

Action: Check the spelling of the tablespace name. If the spelling is correct, then verify that the named tablespace has already been created. DBMS_LOGMNR_D.SET_TABLESPACE will not create a tablespace.

ORA-01352 tablespace given for Logminer spill does not exist

Cause: The tablespace name given as either the NEW_TABLESPACE or the SPILL_TABLESPACE parameter to DBMS_LOGMNR_D.SET_TABLESPACE does not exist.

Action: Check the spelling of the tablespace name. If the spelling is correct, then verify that the named tablespace has already been created. DBMS_LOGMNR_D.SET_TABLESPACE will not create a tablespace.

ORA-01353 existing Logminer session

Cause: An attempt was made to execute DBMS_LOGMNR_D.SET_TABLESPACE while Logminer sessions existed. In general DBMS_LOGMNR_D.SET_TABLESPACE should be run before any Logminer activity has begun. If this error occurs, then this procedure has not been followed.

Action: First cause all Logminer sessions to be destroyed. A Logminer session can exist as a result of executing DBMS_LOGMNR.START_LOGMNR or as the result of running a product such as Logical Standby or Streams which uses Logminer. Next, execute DBMS_LOGMNR_D.SET_TABLESPACE.

ORA-01370 Specified restart SCN is too old

Cause: The specified restart scn is too old and Logminer could not find a proper checkpoint.

Action: Specify a bigger restart SCN to try again.

ORA-01371 Complete LogMiner dictionary not found

Cause: One or more log files containing the LogMiner dictionary was not found.

Action: Add into LogMiner all log files containing the dictionary.

ORA-01372 Insufficient processes for specified LogMiner operation

Cause: The number of processes requested by the caller can not be allocated.

Action: Increase the number of parallel servers allocated to the instance.

ORA-01373 insufficient memory for staging persistent LogMiner session

Cause: The maximum number of concurrent persistent LogMiner sessions allowed is limited by the LOGMNR_MAX_PERSISTENT_SESSIONS parameter. Not enough memory has been set aside at instance startup to allocate the new LogMiner session.

Action: Increase LOGMNR_MAX_PERSISTENT_SESSIONS and restart the instance.

ORA-01374 LOG_PARALLELISM greater than 1 not supported in this release

Cause: LogMiner does not mine redo records generated with LOG_PARALLELISM set to a value greater than 1.

ORA-01400 cannot insert NULL into (string)

Cause: An attempt was made to insert a NULL into the column "USER"."TABLE"."COLUMN".

For example, if you enter:

connect scott/tiger create table a (a1 number not null); insert into a values (null);

Oracle returns:

ORA-01400 cannot insert NULL into ("SCOTT"."A"."A1") :  which means you cannot insert NULL into "SCOTT"."A"."A1".

Action: Retry the operation with a value other than NULL.

ORA-01401 inserted value too large for column

Cause: The value entered is larger than the maximum width defined for the column.

Action: Enter a value smaller than the column width or use the MODIFY option with ALTER TABLE to expand the column width.

ORA-01402 view WITH CHECK OPTION where-clause violation

Cause: An INSERT or UPDATE statement was attempted on a view created with the CHECK OPTION. This would have resulted in the creation of a row that would not satisfy the view's WHERE clause.

Action: Examine the view's WHERE clause in the dictionary table VIEWS. If the current view does not have the CHECK OPTION, then its FROM clause must reference a second view that is defined using the CHECK OPTION. The second view's WHERE clause must also be satisfied by any INSERT or UPDATE statements. To insert the row, it may be necessary to insert it directly into the underlying table, rather than through the view.

ORA-01403 no data found

Cause: In a host language program, all records have been fetched. The return code from the fetch was +4, indicating that all records have been returned from the SQL query.

Action: Terminate processing for the SELECT statement.

ORA-01404 ALTER COLUMN will make an index too large

Cause: Increasing the length of a column would cause the combined length of the columns specified in a previous CREATE INDEX statement to exceed the maximum index length (255). The total index length is computed as the sum of the width of all indexed columns plus the number of indexed columns. Date fields are calculated as a length of 7, character fields are calculated at their defined width, and numeric fields are length 22.

Action: The only way to alter the column is to drop the affected index. The index cannot be re-created if to do so would exceed the maximum index width.

ORA-01405 fetched column value is NULL

Cause: The INTO clause of a FETCH operation contained a NULL value, and no indicator was used. The column buffer in the program remained unchanged, and the cursor return code was +2. This is an error unless you are running Oracle with DBMS=6, emulating version 6, in which case it is only a warning.

Action: You may do any of the following:

  • Use the NVL function to convert the retrieved NULL to another value, such as zero or blank. This is the simplest solution.
  • Use an indicator to record the presence of the NULL. You probably should use this option when you want a specific action to be taken when a NULL arises.
  • Revise the cursor definition so that no columns possibly containing NULL values are retrieved.

ORA-01406 fetched column value was truncated

Cause: In a host language program, a FETCH operation was forced to truncate a character string. The program buffer area for this column was not large enough to contain the entire string. The cursor return code from the fetch was +3.

Action: Increase the column buffer area to hold the largest column value or perform other appropriate processing.

ORA-01407 cannot update (string) to NULL

Cause: An attempt was made to update a table column "USER"."TABLE"."COLUMN" with a NULL value.

For example, if you enter:

connect scott/tiger update table a (a1 number not null); insert into a values (null);

Oracle returns:

ORA-01407 cannot update ("SCOTT"."A"."A1") to NULL

which means you cannot update the column "SCOTT"."A"."A1" to NULL.

Action: Retry the operation with a value other than NULL.

ORA-01408 such column list already indexed

Cause: A CREATE INDEX statement specified a column that is already indexed. A single column may be indexed only once. Additional indexes may be created on the column if it is used as a portion of a concatenated index, that is, if the index consists of multiple columns.

Action: Do not attempt to re-index the column, as it is unnecessary. To create a concatenated key, specify one or more additional columns in the CREATE INDEX statement.

ORA-01409 NOSORT option may not be used; rows are not in ascending order

Cause: Creation of index with NOSORT option when rows were not ascending. The NOSORT option may only be used for indexes on groups of rows that already are in ascending order.

For non-unique indexes the ROWID is considered part of the index key. This means that two rows that appear to be stored in ascending order may not be. If you create an index NOSORT, and two of the rows in the table have the same index values, but get split across two extents, the data block address of the first block in the second extent can be less than the data block address of the last block in the first extent. If these addresses are not in ascending order, the ROWIDs are not either. Since these ROWIDs are considered part of the index key, the index key is not in ascending order, and the create index NOSORT fails.

Action: Create the index without the NOSORT option or ensure that the table is stored in one extent.

ORA-01410 invalid ROWID

Cause: A ROWID was entered incorrectly. ROWIDs must be entered as formatted hexadecimal strings using only numbers and the characters A through F. A typical ROWID format is '000001F8.0001.0006'.

Action: Check the format, then enter the ROWID using the correct format. ROWID format: block ID, row in block, file ID.

ORA-01411 cannot store the length of column in the indicator

Cause: An attempt was made to fetch a column of size more than 64K and could not store the length of the column in the given indicator of size 2 bytes.

Action: Use the new bind type with call backs to fetch the long column.

ORA-01412 zero length not allowed for this datatype

Cause: The length for type 97 is 0.

Action: Specify the correct length.

ORA-01413 illegal value in packed decimal number buffer

Cause: The user buffer bound by the user as packed decimal number contained an illegal value.

Action: Use a legal value.

ORA-01414 invalid array length when trying to bind array

Cause: An attempt was made to bind an array without either a current array length pointer or a zero maximum array length.

Action: Specify a valid length.

ORA-01415 too many distinct aggregate functions

Cause: The query contains more distinct aggregates than can be processed. The current limit is 255.

Action: Reduce the number of distinct aggregate functions in the query.

ORA-01416 two tables cannot be outer-joined to each other

Cause: Two tables in a join operation specified an outer join with respect to each other. If an outer join is specified on one of the tables in a join condition, it may not be specified on the other table.

Action: Remove the outer join specification (+) from one of the tables, then retry the operation.

ORA-01417 a table may be outer joined to at most one other table

Cause: a.b (+) = b.b and a.c (+) = c.c is not allowed.

Action: Check that this is really what you want, then join b and c first in a view.

ORA-01418 specified index does not exist

Cause: An ALTER INDEX, DROP INDEX, or VALIDATE INDEX statement specified the name of an index that does not exist. Only existing indexes can be altered, dropped, or validated. Existing indexes may be listed by querying the data dictionary.

Action: Specify the name of an existing index in the ALTER INDEX, DROP INDEX, or VALIDATE INDEX statement.

ORA-01419 datdts: illegal format code

Cause: An attempt was made to use an incorrect format.

Action: Inspect the format, correct it if necessary, then retry the operation.

ORA-01420 datstd: illegal format code

Cause: An attempt was made to use an invalid format.

Action: Inspect the format, correct it if necessary, then retry the operation.

ORA-01421 datrnd/dattrn: illegal precision specifier

Cause: An attempt was made to use an invalid precision specifier.

Action: Inspect the precision specifier, correct it if necessary, then retry the operation.

ORA-01422 exact fetch returns more than requested number of rows

Cause: The number specified in exact fetch is less than the rows returned.

Action: Rewrite the query or change number of rows requested.

ORA-01423 error encountered while checking for extra rows in exact fetch

Cause: An error was encountered during the execution of an exact fetch. This message will be followed by more descriptive messages.

Action: See the accompanying messages and take appropriate action.

ORA-01424 missing or illegal character following the escape character

Cause: The character following the escape character in LIKE pattern is missing or not one of the escape character, '%', or '_'.

Action: Remove the escape character or specify the missing character.

ORA-01425 escape character must be character string of length 1

Cause: Given escape character for LIKE is not a character string of length 1.

Action: Change it to a character string of length 1.

ORA-01426 numeric overflow

Cause: Evaluation of an value expression causes an overflow/underflow.

Action: Reduce the operands.

ORA-01427 single-row subquery returns more than one row

Cause: The outer query must use one of the keywords ANY, ALL, IN, or NOT IN to specify values to compare because the subquery returned more than one row.

Action: Use ANY, ALL, IN, or NOT IN to specify which values to compare or reword the query so only one row is retrieved.

ORA-01428 argument 'string' is out of range

Cause: An illegal value for a mathematical function argument was specified. For example

SELECT SQRT(-1) "Square Root" FROM DUAL;

Action: See the Oracle9i SQL Reference for valid input and ranges of the mathematical functions.

ORA-01429 Index-Organized Table: no data segment to store overflow row-pieces

Cause: No overflow segment defined.

Action: Add overflow segment.

ORA-01430 column being added already exists in table

Cause: An ALTER TABLE ADD statement specified the name of a column that is already in the table. All column names must be unique within a table.

Action: Specify a unique name for the new column, then re-execute the statement.

ORA-01431 internal inconsistency in GRANT command

Cause: An internal error occurred while attempting to execute a GRANT statement.

Action: Contact Oracle Support Services.

ORA-01432 public synonym to be dropped does not exist

Cause: The synonym specified in DROP PUBLIC SYNONYM is not a valid public synonym. It may be a private synonym.

Action: Correct the synonym name or use DROP SYNONYM if the synonym is not public.

ORA-01433 synonym to be created is already defined

Cause: A CREATE SYNONYM statement specified a synonym name that is the same as an existing synonym, table, view, or cluster. Synonyms may not have the same name as any other synonym, table, view, or cluster available to the user creating the synonym.

Action: Specify a unique name for the synonym, then re-execute the statement.

ORA-01434 private synonym to be dropped does not exist

Cause: A DROP SYNONYM statement specified a synonym that does not exist. Existing synonym names may be listed by querying the data dictionary.

Action: Specify the name of an existing synonym in the DROP SYNONYM statement.

ORA-01435 user does not exist

Cause: This message is caused by any reference to a non-existent user. For example, it occurs if a SELECT, GRANT, or REVOKE statement specifies a username that does not exist. Only a GRANT CONNECT statement may specify a new username. All other GRANT and REVOKE statements must specify existing usernames. If specified in a SELECT statement, usernames must already exist.

Action: Specify only existing usernames in the SELECT, GRANT, or REVOKE statement or ask the database administrator to define the new username.

ORA-01436 CONNECT BY loop in user data

Cause: The condition specified in a CONNECT BY clause caused a loop in the query, where the next record to be selected is a descendent of itself. When this happens, there can be no end to the query.

Action: Check the CONNECT BY clause and remove the circular reference.

ORA-01437 cannot have join with CONNECT BY

Cause: A join operation was specified with a CONNECT BY clause. If a CONNECT BY clause is used in a SELECT statement for a tree-structured query, only one table may be referenced in the query.

Action: Remove either the CONNECT BY clause or the join operation from the SQL statement.

ORA-01438 value larger than specified precision allows for this column

Cause: When inserting or updating records, a numeric value was entered that exceeded the precision defined for the column.

Action: Enter a value that complies with the numeric column's precision, or use the MODIFY option with the ALTER TABLE command to expand the precision.

ORA-01439 column to be modified must be empty to change datatype

Cause: An ALTER TABLE MODIFY statement attempted to change the datatype of a column containing data. A column whose datatype is to be altered must contain only NULL values.

Action: To alter the datatype, first set all values in the column to NULL.

ORA-01440 column to be modified must be empty to decrease precision or scale

Cause: An ALTER TABLE MODIFY statement attempted to decrease the scale or precision of a numeric column containing data. In order to decrease either of these values, the column must contain only NULL values. An attempt to increase the scale without also increasing the precision will also cause this message.

Action: Set all values in the column to NULL before decreasing the numeric precision or scale. If attempting to increase the scale, increase the precision in accordance with the scale or set all values in the column to NULL first.

ORA-01441 cannot decrease column length because some value is too big

Cause: An ALTER TABLE MODIFY statement attempted to decrease the size of a character field containing data. A column whose maximum size is to be decreased must contain only NULL values.

Action: Set all values in column to NULL before decreasing the maximum size.

ORA-01442 column to be modified to NOT NULL is already NOT NULL

Cause: An ALTER TABLE MODIFY statement attempted to change a column specification unnecessarily, from NOT NULL to NOT NULL.

Action: No action required.

ORA-01443 internal inconsistency; illegal datatype in resultant view column

Cause: An internal error occurred in referencing a view.

Action: Contact Oracle Support Services.

ORA-01444 internal inconsistency; internal datatype maps to invalid external type

Cause: This is an internal error message not normally issued.

Action: Contact Oracle Support Services.

ORA-01445 cannot select ROWID from a join view without a key-preserved table

Cause: A SELECT statement attempted to select ROWIDs from a view derived from a join operation. Because the rows selected in the view do not correspond to underlying physical records, no ROWIDs can be returned.

Action: Remove ROWID from the view selection clause, then re-execute the statement.

ORA-01446 cannot select ROWID from view with DISTINCT, GROUP BY, etc.

Cause: A SELECT statement attempted to select ROWIDs from a view containing columns derived from functions or expressions. Because the rows selected in the view do not correspond to underlying physical records, no ROWIDs can be returned.

Action: Remove ROWID from the view selection clause, then re-execute the statement.

ORA-01447 ALTER TABLE does not operate on clustered columns

Cause: An ALTER TABLE MODIFY statement specified a column used to cluster the table. Clustered columns may not be altered.

Action: To alter the column, first re-create the table in non-clustered form. The column's size can be increased at the same time.

ORA-01448 index must be dropped before changing to desired type

Cause: An ALTER TABLE MODIFY statement attempted to change an indexed character column to a LONG column. Columns with the datatype LONG may not be indexed, so the index must be dropped before the modification.

Action: Drop all indexes referencing the column before changing its datatype to LONG.

ORA-01449 column contains NULL values; cannot alter to NOT NULL

Cause: An ALTER TABLE MODIFY statement attempted to change the definition of a column containing NULL values to NOT NULL. The column may not currently contain any NULL values if it is to be altered to NOT NULL.

Action: Set all NULL values in the column to values other than NULL before ALTERING the column to NOT NULL.

ORA-01450 maximum key length (string) exceeded

Cause: The combined length of all the columns specified in a CREATE INDEX statement exceeded the maximum index length. The maximum index length varies by operating system. The total index length is computed as the sum of the width of all indexed columns plus the number of indexed columns. Date fields have a length of 7, character fields have their defined length, and numeric fields have a length of 22. Numeric length = (precision/2) + 1. If negative, add +1.

Action: Select columns to be indexed so the total index length does not exceed the maximum index length for the operating system. See also your operating system-specific Oracle documentation.

ORA-01451 column to be modified to NULL cannot be modified to NULL

Cause: The column may already allow NULL values, the NOT NULL constraint is part of a primary key or check constraint, or an ALTER TABLE MODIFY statement attempted to change a column specification unnecessarily, from NULL to NULL.

Action: If a primary key or check constraint is enforcing the NOT NULL constraint, then drop that constraint.

ORA-01452 cannot CREATE UNIQUE INDEX; duplicate keys found

Cause: A CREATE UNIQUE INDEX statement specified one or more columns that currently contain duplicate values. All values in the indexed columns must be unique by row to create a UNIQUE INDEX.

Action: If the entries need not be unique, remove the keyword UNIQUE from the CREATE INDEX statement, then re-execute the statement. If the entries must be unique, as in a primary key, then remove duplicate values before creating the UNIQUE index.

ORA-01453 SET TRANSACTION must be first statement of transaction

Cause: A transaction was not processed properly because the SET TRANSACTION statement was not the first statement.

Action: Commit or roll back the current transaction before using the statement SET TRANSACTION.

ORA-01454 cannot convert column into numeric datatype

Cause: A non-numeric value could not be converted into a number value.

Action: Check the value to make sure it contains only numbers, a sign, a decimal point, and the character "E" or "e", then retry the operation.

ORA-01455 converting column overflows integer datatype

Cause: The converted form of the specified expression was too large for the specified datatype.

Action: Define a larger datatype or correct the data.

ORA-01456 may not perform insert/delete/update operation inside a READ ONLY transaction

Cause: A non-DDL insert/delete/update or select for update operation was attempted.

Action: Commit (or roll back) the transaction, and then re-execute.

ORA-01457 converting column overflows decimal datatype

Cause: The converted form of the specified expression was too large for the specified type. The problem also occurs in COBOL programs when using COMP-3 in the picture clause, which is acceptable to the Pro*COBOL Precompiler and to COBOL but results in this error.

Action: Define a larger datatype or correct the data.

ORA-01458 invalid length inside variable character string

Cause: An attempt was made to bind or define a variable character string with a buffer length less than the minimum requirement.

Action: Increase the buffer size or use a different type.

ORA-01459 invalid length for variable character string

Cause: The buffer length was less than the minimum required or greater than its length at bind time minus two bytes.

Action: Make sure the string size is long enough to hold the buffer.

ORA-01460 unimplemented or unreasonable conversion requested

Cause: The requested format conversion is not supported.

Action: Remove the requested conversion from the SQL statement. Check the syntax for the TO_CHAR, TO_DATE, and TO_NUMBER functions to see which conversions are supported.

ORA-01461 can bind a LONG value only for insert into a LONG column

Cause: An attempt was made to insert a value from a LONG datatype into another datatype. This is not allowed.

Action: Do not try to insert LONG datatypes into other types of columns.

ORA-01462 cannot insert string literals longer than 2000 characters

Cause: The longest literal supported by Oracle consists of 2000 characters.

Action: Reduce the number of characters in the literal to 2000 characters or fewer or use the VARCHAR2 or LONG datatype to insert strings exceeding 2000 characters.

ORA-01463 cannot modify column datatype with current constraint(s)

Cause: An attempt was made to modify the datatype of column which has referential constraints; or has check constraints which only allows changing the datatype from CHAR to VARCHAR or vise versa.

Action: Remove the constraint(s) or do not perform the offending operation.

ORA-01464 circular grant (granting to grant ancestor) of table or view

Cause: The user in the TO clause of the GRANT statement has already been GRANTed privileges on this table.

Action: Do not GRANT privileges on a table to the user who originally GRANTed privileges on that table. The statement in error is probably unnecessary.

ORA-01465 invalid hex number

Cause: In an UPDATE statement following a SELECT FOR UPDATE, part of the ROWID contains invalid characters. ROWID must be expressed in the proper and expected format for ROWID and within quotes.

Action: Enter the ROWID just as it was returned in the SELECT FOR UPDATE.

ORA-01466 unable to read data - table definition has changed

Cause: This is a time-based read consistency error for a database object, such as a table or index. Either of the following may have happened:

  • The query was parsed and executed with a materialized view older than the time the object was changed.
  • The creation time-stamp of the object is greater than the current system time. This happens, for example, when the system time is set to a time earlier than the creation time of the object.

Action: If the cause is:

  • an old snapshot, then commit or rollback the transaction and resume work.
  • a creation time-stamp in the future, ensure the system time is set correctly.

If the object creation time-stamp is still greater than the system time, then export the object's data, drop the object, re-create the object so it has a new creation time-stamp, import the object's data, and resume work.

ORA-01467 sort key too long

Cause: A DISTINCT, GROUP BY, ORDER BY, or SET operation requires a sort key longer than that supported by Oracle. Either too many columns or too many group functions were specified in the SELECT statement.

Action: Reduce the number of columns or group functions involved in the operation.

ORA-01468 a predicate may reference only one outer-joined table

Cause: A predicate in the WHERE clause has two columns from different tables with "(+)".

Action: Change the WHERE clause so that each predicate has a maximum of one outer-join table.

ORA-01469 PRIOR can only be followed by a column name

Cause: An invalid column name was specified after the PRIOR keyword.

Action: Check syntax, spelling, use a valid column name, and try again.

ORA-01470 In-list iteration does not support mixed operators

Cause: Constants of different types are specified in an in-list.

Action: Use constants of same type for in-lists.

ORA-01471 cannot create a synonym with same name as object

Cause: An attempt was made to create a private synonym with the same name as the object to which it refers. This error typically occurs when a user attempts to create a private synonym with the same name as one of their objects.

Action: Choose a different synonym name or create the synonym under a different username.

ORA-01472 cannot use CONNECT BY on view with DISTINCT, GROUP BY, etc.

Cause: CONNECT BY cannot be used on a view where there is not a correspondence between output rows and rows of the underlying table.

Action: Remove the DISTINCT or GROUP BY from the view or move the CONNECT BY clause into the view.

ORA-01473 cannot have subqueries in CONNECT BY clause

Cause: Subqueries cannot be used in a CONNECT BY clause.

Action: Remove the subquery or move it to the WHERE clause.

ORA-01474 cannot have START WITH or PRIOR without CONNECT BY

Cause: START WITH and PRIOR are meaningful only in connection with CONNECT BY.

Action: Check the syntax for the SQL statement and add a CONNECT BY clause, if necessary.

ORA-01475 must reparse cursor to change bind variable datatype

Cause: After executing a statement, an attempt was made to rebind a bind variable with a datatype different from that of the original bind.

Action: Re-parse the cursor before rebinding with a different datatype.

ORA-01476 divisor is equal to zero

Cause: An expression attempted to divide by zero.

Action: Correct the expression, then retry the operation.

ORA-01477 user data area descriptor is too large

Cause: This is an internal error message not normally issued.

Action: Contact Oracle Support Services.

ORA-01478 array bind may not include any LONG columns

Cause: User is performing an array bind with a bind variable whose maximum size is greater than 2000 bytes.

Action: Such bind variables cannot participate in array binds. Use an ordinary bind operation instead.

ORA-01479 last character in the buffer is not Null

Cause: A bind variable of type 97 does not contain null at the last position.

Action: Make the last character null.

ORA-01480 trailing null missing from STR bind value

Cause: A bind variable of type 5 (null-terminated string) does not contain the terminating null in its buffer.

Action: Terminate the string with a null character.

ORA-01481 invalid number format model

Cause: An invalid format parameter was used with the TO_CHAR or TO_NUMBER function.

Action: Correct the syntax, then retry the operation.

ORA-01482 unsupported character set

Cause: The character set used to perform the operation, such as the CONVERT function, is not a supported character set.

Action: Use one of the supported character sets.

kkORA-01484 arrays can only be bound to PL/SQL statements

Cause: At attempt was made to bind an array to a non-PL/SQL statement.

Action: Rewrite the offending code being careful to bind arrays only to PL/SQL statements.

ORA-01485 compile bind length different from execute bind length

Cause: You bound a buffer of type DTYVCS (VARCHAR with the two byte length in front) and at execute time the length in the first two bytes is more than the maximum buffer length, given in the bind call. The number of elements in the array and the current number of elements in the array cannot be more than the maximum size of the array.

Action: Ensure that the buffer size is sufficiently large to contain the array plus two bytes for the buffer length.

ORA-01486 size of array element is too large

Cause: An attempt was made to bind a data value that was either too large for the datatype, for example, NUMBER, or was greater than 2000 bytes, for example, VARCHAR or LONG.

Action: Find a way to convert or truncate the data value so that its length is acceptable.

ORA-01487 packed decimal number too large for supplied buffer

Cause: A conversion request cannot be performed because the buffer is too small to hold the result.

Action: Increase the size of the buffer.

ORA-01488 invalid nibble or byte in the input data

Cause: A conversion request cannot be performed because a digit was invalid.

Action: Fix the number and retry.

ORA-01489 result of string concatenation is too long

Cause: String concatenation result is more than the maximum size.

Action: Make sure that the result is less than the maximum size.

ORA-01490 invalid ANALYZE command

Cause: The syntax of the ANALYZE command was incorrect.

Action: Check the syntax and enter the command using the correct syntax.

ORA-01491 CASCADE option not valid

Cause: The CASCADE option should be used only for tables or clusters.

Action: Do not use the CASCADE option in this manner. Check the syntax of the statement and then retry.

ORA-01492 LIST option not valid

Cause: The LIST option can be used only for tables or clusters.

Action: Do not use the LIST option in this manner. Check the syntax of the statement and then retry.

ORA-01493 invalid SAMPLE size specified

Cause: The specified SAMPLE size is out of range

Action: Specify a value within the proper range.

ORA-01494 invalid SIZE specified

Cause: The specified histogram SIZE value was out of range.

Action: Specify a value within the proper range.

ORA-01495 specified chain row table not found

Cause: The specified table either does not exist or user does not have the proper privileges.

Action: Specify the correct table to use.

ORA-01496 specified chain row table form incorrect

Cause: The specified table does not have the proper field definitions.

Action: Specify the correct table to use.

ORA-01497 illegal option for ANALYZE CLUSTER

Cause: The FOR COLUMNS column_list clause cannot be used with ANALYZE CLUSTER.

Action: Retry with a legal syntax.

For more information about ANALYZE CLUSTER, see the Oracle9i SQL Reference.

ORA-01498 block check failure - see trace file

Cause: An error occurred while checking a block with the ANALYZE command.

Action: Check the trace file for more descriptive messages about the problem. Correct these errors. The name of the trace file is operating system-specific, for example, ORAxxxx.TRC. It is found in the directory specified by the initialization parameter USER_DUMP_DEST. If USER_DUMP_DEST is not set, trace files are not created. It may be necessary to re-create the object. See also your operating system-specific Oracle documentation.

ORA-01499 table/index cross reference failure - see trace file

Cause: An error occurred when validating an index or a table using the ANALYZE command. One or more entries does not point to the appropriate cross-reference.

Action: Check the trace file for more descriptive messages about the problem. Correct these errors. The name of the trace file is operating system-specific, for example, ORAxxxx.TRC. It is found in the directory specified by the USER_DUMP_DEST initialization parameter. If USER_DUMP_DEST is not set, trace files are not created. It may be necessary to re-create the object. See also your operating system-specific Oracle documentation.


ORA-01500 to ORA-02099

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

4
ORA-01500 to ORA-02099

ORA-01500 failure in getting date/time

Cause: During CREATE DATABASE or ALTER TABLESPACE, there was a failure in getting the date and time.

Action: Contact Oracle Support Services.

ORA-01501 CREATE DATABASE failed

Cause: An error occurred during CREATE DATABASE.

Action: See accompanying errors.

ORA-01502 index 'string.string' or partition of such index is in unusable state

Cause: An attempt has been made to access an index or index partition that has been marked unusable by a direct load or by a DDL operation.

Action: DROP the specified index, or REBUILD the specified index, or REBUILD the unusable index partition.

ORA-01503 CREATE CONTROLFILE failed

Cause: An error occurred during CREATE CONTROLFILE.

Action: See accompanying errors.

ORA-01504 database name 'string' does not match parameter db_name 'string'

Cause: The name in a database create or mount does not match the name given in the initialization parameter DB_NAME.

Action: Correct or omit one of the two names.

ORA-01505 error in adding log files

Cause: During CREATE or ALTER DATABASE, error(s) occurred when adding new log files.

Action: Check error stack for detailed error information.

ORA-01506 missing or illegal database name

Cause: No database name was specified in the CREATE/ALTER DATABASE statement, and no DB_NAME initialization parameter was specified.

Action: Either the database name must be given in the statement or in the DB_NAME initialization parameter. Note that the SVRMGR or SQL*PLUS STARTUP command issues an ALTER DATABASE statement using the database name specified as part of STARTUP (if any).

ORA-01507 database not mounted

Cause: A command was attempted that requires the database to be mounted.

Action: If you are using the ALTER DATABASE statement via the SVRMGR or SQL*PLUS STARTUP command, specify the MOUNT option to restart; else if you are directly doing an ALTER DATABASE DISMOUNT, do nothing; else specify the MOUNT option to ALTER DATABASE. If you are doing a backup or copy, you must first mount the desired database.

ORA-01508 cannot create database; error in file 'string' at line string

Cause: CREATE DATABASE was unable to process the specified file.

Action: Check the offending line in the specified file.

ORA-01509 specified name 'string' does not match actual 'string'

Cause: The database name specified in ALTER DATABASE does not match the name of the currently mounted database.

Action: Correct the database name spelling or DISMOUNT the mounted database.

ORA-01510 error in deleting log files

Cause: During ALTER DATABASE, an error occurred while dropping log files.

Action: Check the error stack for detailed error information.

ORA-01511 error in renaming log/data files

Cause: During ALTER DATABASE, an error occurred while renaming log or datafiles.

Action: Check the error stack for detailed error information.

ORA-01512 error renaming log file string - new file string not found

Cause: An attempt to change a log file's name in the control file failed because no file was found with the new name.

Action: Make sure that the log file has been properly renamed by the operating system and retry.

ORA-01513 invalid current time returned by operating system

Cause: The operating system returned a time that was not between 1988 and 2121.

Action: Correct the time kept by the operating system.

ORA-01514 error in log specification: no such log

Cause: A log file name, or list of member names, did not correspond to an existing log.

Action: Specify an existing log file.

ORA-01515 error dropping log group string: no such log

Cause: ALTER DATABASE is attempting to drop a log file which is not known to the database control file.

Action: Specify the name of an existing log file.

ORA-01516 nonexistent log file, datafile, or tempfile "string"

Cause: An attempt was made to use ALTER DATABASE to rename a log file, datafile, or tempfile; or to change attributes of a datafile or tempfile (for example, such as resize, autoextend, online/offline, and so on); or to re-create a datafile. The attempt failed because the specified file is not known to the database's control file or is not of a type supported by the request.

Action: Specify the name or number of an existing file of the correct type, as appropriate. Check the relevant V$ table for a list of possible files.

ORA-01517 log member: 'string'

Cause: This message indicates the filename involved with other messages.

Action: See the accompanying messages and take appropriate action.

ORA-01518 CREATE DATABASE must specify more than one log file

Cause: Only one log file was specified in the CREATE DATABASE statement.

Action: Specify at least two log files.

ORA-01519 error while processing file 'string' near line string

Cause: CREATE DATABASE encountered a problem while processing specified file. The specified file is bad.

Action: Retry your system installation procedure or contact Oracle Support Services.

ORA-01520 number of data files to add (string) exceeds limit of string

Cause: CREATE TABLESPACE statement specifies more files than is permitted for this database.

Action: Use fewer files or re-create the control file with a larger value of MAXDATAFILES.

ORA-01521 error in adding data files

Cause: During CREATE or ALTER TABLESPACE, an error was detected while adding datafiles.

Action: Check the error stack for detailed error information.

ORA-01522 file 'string' to be renamed does not exist

Cause: During ALTER TABLESPACE RENAME, a file to be renamed was not found in the database control file.

Action: Specify the correct file name.

ORA-01523 cannot rename data file to 'string' - file already part of database

Cause: During ALTER DATABASE RENAME or ALTER TABLESPACE RENAME, the new name of a file is already present in the control file.

Action: Rename the file to a name not already being used as part of the database.

ORA-01524 cannot create data file as 'string' - file already part of database

Cause: During ALTER DATABASE CREATE DATAFILE, the new name of a file is already present in the control file.

Action: Create the file as a name not already being used as part of the database.

ORA-01525 error in renaming data files

Cause: An error occurred when renaming files as part of ALTER TABLESPACE.

Action: Check the error stack for detailed information. All files are renamed except for those mentioned in the error stack.

ORA-01526 error in opening file 'string'

Cause: CREATE DATABASE was not able to open the specified file. This is probably due to a system installation error.

Action: Retry your system installation procedure or contact Oracle Support Services.

ORA-01527 error while reading file

Cause: CREATE DATABASE was not able to read the specified file. This is probably due to a system installation error.

Action: Retry your system installation procedure or contact Oracle Support Services.

ORA-01528 EOF while processing SQL statement

Cause: CREATE DATABASE unexpectedly hit EOF while reading the specified file. The SQL.BSQ file is bad.

Action: Retry your system installation procedure or contact Oracle Support Services.

ORA-01529 error closing file 'string'

Cause: CREATE DATABASE was not able to close the specified file.

Action: Retry your system installation procedure or contact Oracle Support Services.

ORA-01530 a database already mounted by the instance

Cause: During ALTER DATABASE MOUNT, an attempt is being made to mount a database on an instance in which a database is or has previously been mounted.

Action: If you wish to mount the database, shut down and then restart the instance and retry the operation.

ORA-01531 a database already open by the instance

Cause: During ALTER DATABASE, an attempt was made to open a database on an instance for which there is already an open database.

Action: If you wish to open a new database on the instance, first shut down and then restart the instance and retry the operation.

ORA-01532 cannot create database; instance being started elsewhere

Cause: During CREATE DATABASE, another user appears to be simultaneously altering the instance.

Action: Make sure no one else is simultaneously altering the instance. If no one is, contact Oracle Support Services; otherwise, retry the operation.

ORA-01533 cannot rename file 'string'; file does not belong to tablespace

Cause: During ALTER TABLESPACE RENAME, a file to be renamed was not found in the argument tablespace.

Action: Specify the correct file name or the correct tablespace name.

ORA-01534 rollback segment 'string' doesn't exist

Cause: During ALTER or DROP ROLLBACK SEGMENT, the specified rollback segment name is unknown.

Action: Use the correct rollback segment name.

ORA-01535 rollback segment 'string' already exists

Cause: Specified rollback segment already exists.

Action: Use a different name.

ORA-01536 space quota exceeded for tablespace 'string'

Cause: The space quota for the segment owner in the tablespace has been exhausted and the operation attempted the creation of a new segment extent in the tablespace.

Action: Either drop unnecessary objects in the tablespace to reclaim space or have a privileged user increase the quota on this tablespace for the segment owner.

ORA-01537 cannot add data file 'string' - file already part of database

Cause: During CREATE or ALTER TABLESPACE, a file being added is already part of the database.

Action: Use a different file name.

ORA-01538 failed to acquire any rollback segment

Cause: Failed to acquire any rollback segment during startup in shared mode.

Action: Restart in exclusive mode to create one more public segment or specify available private segments in the initialization parameter. ROLLBACK_SEGMENTS_REQUIRED, then start in shared mode

ORA-01539 tablespace 'string' is not online

Cause: Failed to either make a tablespace read only or offline because it is not online. A tablespace must be online before it can become read only or offline normal.

Action: Check the status of the tablespace. Use IMMEDIATE or TEMPORARY options to force all files offline. Bring the tablespace online before making it read only.

ORA-01540 tablespace 'string' is not offline

Cause: Failed to bring a tablespace online because it is not offline.

Action: Check the status of the tablespace.

ORA-01541 system tablespace cannot be brought offline; shut down if necessary

Cause: An attempt was made to bring system tablespace offline.

Action: Shut down if necessary to do recovery.

ORA-01542 tablespace 'string' is offline, cannot allocate space in it

Cause: An attempt was made to allocate space in an offline tablespace.

Action: Bring the tablespace online or create the object in other tablespace.

ORA-01543 tablespace 'string' already exists

Cause: An attempt was made to create a tablespace which already exists.

Action: Use a different name for the new tablespace.

ORA-01544 cannot drop system rollback segment

Cause: An attempt was made to drop system rollback segment.

Action: No action required.

ORA-01545 rollback segment 'string' specified not available

Cause: One of the following:

  1. An attempt was made to bring a rollback segment online that is unavailable during startup; for example, the rollback segment is in an offline tablespace.
  2. An attempt was made to bring a rollback segment online that is already online. This is because the rollback segment is specified twice in the ROLLBACK_SEGMENTS parameter in the initialization parameter file or the rollback segment is already online by another instance.
  3. An attempt was made to drop a rollback segment that is currently online.
  4. An attempt was made to alter a rollback segment that is currently online to use unlimited extents.
  5. An attempt was made to online a rollback segment that is corrupted. This is because the rollback is specified in _corrupted_rollback_segments parameter in initialization parameter file.

Action: One of the following:

  1. Make the rollback segment available; for example, bring an offline tablespace online.
  2. Remove the name from the ROLLBACK_SEGMENTS parameter if the name is a duplicate or if another instance has already acquired the rollback segment.
  3. Bring the rollback segment offline first. This may involve waiting for the active transactions to finish, or, if the rollback segment needs recovery, discover which errors are holding up the rolling back of the transactions and take appropriate actions.
  4. Same as 3).
  5. Remove the name from the _corrupted_rollback_segments parameter.

ORA-01546 tablespace contains active rollback segment 'string'

Cause: An attempt was made to make a tablespace that contains active rollback segment(s) offline or read only.

Action: Shut down instances that use the active rollback segments in the tablespace and then make the tablespace offline or read only.

ORA-01547 warning: RECOVER succeeded but OPEN RESETLOGS would get error below

Cause: Media recovery with one of the incomplete recovery options ended without error. However, if the ALTER DATABASE OPEN RESETLOGS command were attempted now, it would fail with the specified error. The most likely cause of this error is forgetting to restore one or more datafiles from a sufficiently old backup before executing the incomplete recovery.

Action: Rerun the incomplete media recovery using different datafile backups, a different control file, or different stop criteria.

ORA-01548 active rollback segment 'string' found, terminate dropping tablespace

Cause: An attempt was made to drop a tablespace that contains active rollback segment(s).

Action: Shut down instances that use the active rollback segments in the tablespace and then drop the tablespace.

ORA-01549 tablespace not empty, use INCLUDING CONTENTS option

Cause: An attempt was made to drop a non-empty tablespace.

Action: To drop all the objects in the tablespace, use the INCLUDING CONTENTS option.

ORA-01550 cannot drop system tablespace

Cause: An attempt was made to drop system tablespace. This is not allowed.

Action: No action required.

ORA-01551 extended rollback segment, pinned blocks released

Cause: Doing recursive extent of rollback segment, trapped internally by the system.

Action: No action required.

ORA-01552 cannot use system rollback segment for non-system tablespace 'string'

Cause: An attempt was made to use the system rollback segment for operations involving non-system tablespace. If this is a clone database then this will happen when attempting any data modification outside of the system tablespace. Only the system rollback segment can be online in a clone database.

Action: Create one or more private/public segment(s), shut down and restart. May need to modify the initialization parameter ROLLBACK_SEGMENTS to acquire private rollback segment. If this is a clone database being used for tablespace point in time recovery then this operation is not allowed.

ORA-01553 MAXEXTENTS must be no smaller than the string extents currently allocated

Cause: The number of extents allocated is greater than the MAXEXTENTS specified.

Action: Specify a larger MAXEXTENTS value.

ORA-01554 out of transaction slots in transaction tables

Cause: Too many concurrent transactions.

Action: Shut down the system, modify the initialization parameters TRANSACTIONS, ROLLBACK_SEGMENTS or ROLLBACK_SEGMENTS_REQUIRED, and then restart.

ORA-01555 snapshot too old: rollback segment number string with name "string" too small

Cause: Rollback records needed by a reader for consistent read are overwritten by other writers.

Action: If in Automatic Undo Management mode, increase the setting of UNDO_RETENTION. Otherwise, use larger rollback segments.

ORA-01556 MINEXTENTS for rollback segment must be greater than 1

Cause: Specified MINEXTENTS of less than 2 for rollback segment.

Action: Specify larger MINEXTENTS.

ORA-01557 rollback segment extents must be at least string blocks

Cause: Specified extent of less than minimum size for rollback segment.

Action: Specify larger extents.

ORA-01558 out of transaction ID's in rollback segment string

Cause: All the available transaction IDs have been used.

Action: Shut down the instance and restart using other rollback segment(s), then drop the rollback segment that has no more transaction IDs.

ORA-01559 MAXEXTENTS for rollback segment must be greater than 1

Cause: Specified MAXEXTENTS of less than 2 for rollback segment.

Action: Specify larger MAXEXTENTS.

ORA-01560 LIKE pattern contains partial or illegal character

Cause: Like pattern is not formed correctly.

Action: Make sure like pattern is specified correctly.

ORA-01561 failed to remove all objects in the tablespace specified

Cause: Failed to remove all objects when dropping a tablespace.

Action: Retry the drop tablespace until all objects are dropped.

ORA-01562 failed to extend rollback segment number string

Cause: Failure occurred when trying to extend rollback segment.

Action: This is normally followed by another error message that caused the failure. You may take the rollback segment offline to perform maintenance. Use SELECT SEGMENT_NAME FROM DBA_ROLLBACK_SEGS WHERE SEGMENT_ID=string (where string is the segment number from the message) to determine the rollback segment name. Then use the ALTER ROLLBACK SEGMENT OFFLINE command to take the rollback segment offline.

ORA-01563 rollback segment is PUBLIC, need to use the keyword PUBLIC

Cause: Did not use the keyword PUBLIC to identified public rollback segment.

Action: Use the keyword PUBLIC when identifying public rollback segment.

ORA-01564 rollback segment is not PUBLIC

Cause: The rollback segment identified is not public.

Action: Do not use the keyword PUBLIC when identifying private rollback segment.

ORA-01565 error in identifying file 'string'

Cause: An error occurred while trying to identify a file.

Action: Check the error stack for detailed information.

ORA-01566 file specified more than once in DROP LOGFILE

Cause: The list of files supplied to DROP LOGFILE contains at least one duplicate.

Action: Remove the duplicate file specification and retry.

ORA-01567 dropping log string would leave less than 2 log files in thread string

Cause: Dropping all the logs specified would leave fewer than the required two log files per enabled thread.

Action: Either drop fewer logs or disable the thread before deleting the logs. It may be possible to clear the log rather than drop it.

ORA-01568 cannot set space quota on PUBLIC

Cause: An attempt was made to set space quota on a tablespace for PUBLIC.

Action: If trying to grant system-wide or tablespace-wide space privileges to all users, use GRANT RESOURCE [ON tablespace] TO PUBLIC.

ORA-01569 data file too small for system dictionary tables

Cause: The datafile specified during creation of the database is too small to hold the system dictionary tables.

Action: Re-create the database by specifying a larger file or more files.

ORA-01570 MINEXTENTS must be no larger than the string extents currently allocated

Cause: The number of extents allocated is smaller than the MINEXTENTS specified.

Action: Specify a smaller MINEXTENTS value.

ORA-01571 redo version string incompatible with ORACLE version string

Cause: This software version cannot read the current redo logs, and either crash recovery is required or there are offline database files that need media recovery. If a file name is listed then it needs media recovery.

Action: Shut down and restart using the compatible software. Do any required media recovery, and open the database. Shut down and restart using the current software. If the file is going to be dropped then take it offline with the DROP option to skip this check.

ORA-01572 rollback segment string cannot be brought online, string extents exceeded

Cause: The number of extents in the rollback segment exceeds the hard limit. It cannot be brought online for writing.

Action: Drop and re-create the rollback segment.

ORA-01573 shutting down instance, no further change allowed

Cause: Some process tried to make changes while the database was being shut down.

Action: No action required.

ORA-01574 maximum number of concurrent transactions exceeded

Cause: The limit on the number of concurrent transactions has been hit.

Action: Shut down the system, increase the value of the initialization parameter TRANSACTIONS, and then restart the system.

ORA-01575 timeout waiting for space management resource

Cause: Failed to acquire necessary resource to do space management.

Action: Retry the operation.

ORA-01576 instance locking protocol version string incompatible with ORACLE version string

Cause: Current software uses incompatible locking protocol.

Action: Upgrade software used to start instances so that they use compatible locking protocol.

ORA-01577 cannot add log file 'string' - file already part of database

Cause: During CREATE or ALTER DATABASE, a file being added is already part of the database.

Action: Use a different file name.

ORA-01578 ORACLE data block corrupted (file # string, block # string)

Cause: The data block indicated was corrupted, probably due to program errors.

Action: Determine which object was corrupted using a command like the following:

SELECT SEGMENT_TYPE,OWNER||'.'||SEGMENT_NAME FROM DBA_EXTENTSWHERE file = FILE_ID AND block BETWEEN BLOCK_ID AND BLOCK_ID+BLOCKS -1;

where values for file and block are from the message.

Try to restore the segment containing the block indicated. This may involve dropping the segment and re-creating it. If there is a trace file, report the errors in it to Oracle Support Services.

ORA-01579 write error occurred during recovery

Cause: A write error occurred during recovery.

Action: Consult trace files for the nature of the write error, and correct error.

ORA-01580 error creating control backup file string

Cause: An operating system error occurred while attempting to create a control file backup.

Action: Check the error stack for more detailed information.

ORA-01581 attempt to use rollback segment (string) new extent (string) which is being allocated

Cause: Undo generated to extend a rollback segment has run out of current undo block space. Oracle is attempting to write into the new extent which has not been completely allocated.

Action: The rollback segment extending will be rolled back by the system, no more extension will be possible until the next extent is freed up by rolling back or committing other transactions.

ORA-01582 unable to open controlfile for backup

Cause: An operating system error occurred while attempting to open a control file for backup.

Action: Check the error stack for more detailed information.

ORA-01583 unable to get block size of controlfile to be backed up

Cause: An operating system error occurred while attempting to get the block size of a control file for backup.

Action: Check the error stack for more detailed information.

ORA-01584 unable to get file size of controlfile to be backed up

Cause: An operating system error occurred while attempting to get the file size of a control file for backup.

Action: Check the error stack for more detailed information.

ORA-01585 error identifying backup file string

Cause: An operating system error occurred when attempting to identify the file to be used for control file backup.

Action: Check the error stack for more detailed information.

ORA-01586 unable to open destination file string for backup

Cause: An operating system error occurred while attempting to open a control file for backup.

Action: Check the error stack for more detailed information.

ORA-01587 error during controlfile backup file copy

Cause: An operating system error occurred while attempting to copy a control file for backup.

Action: Check the accompanying message stack for detailed information and then take appropriate action.

ORA-01588 must use RESETLOGS option for database open

Cause: An earlier attempt to open the database with the RESETLOGS option did not complete, or recovery was done with a control file backup.

Action: Use the RESETLOGS option when opening the database.

ORA-01589 must use RESETLOGS or NORESETLOGS option for database open

Cause: Either incomplete or backup control file recovery has been performed. After these types of recovery you must specify either the RESETLOGS option or the NORESETLOGS option to open your database.

Action: Specify the appropriate option.

ORA-01590 number of segment free list (string) exceeds maximum of string

Cause: The value of the storage parameter FREELIST GROUPS is too large.

Action: Reduce the value of the storage parameter FREELIST GROUPS.

ORA-01591 lock held by in-doubt distributed transaction string

Cause: An attempt was made to access resource that is locked by a dead two-phase commit transaction that is in prepared state.

Action: The database administrator should query the PENDING_TRANS$ and related tables, and attempt to repair network connection(s) to coordinator and commit point. If timely repair is not possible, the database administrator should contact the database administrator at the commit point if known or the end user for correct outcome, or use heuristic default if given to issue a heuristic COMMIT or ABORT command to finalize the local portion of the distributed transaction.

ORA-01592 error converting Version 7 rollback segment (string) to Oracle 8 format

Cause: Look at the accompanying internal error; Version 7 database may not have shut down cleanly.

Action: Investigate the internal error; may have to reload the Version 7 database (from backup) and shut down the database cleanly.

ORA-01593 rollback segment optimal size (string blks) is smaller than the computed initial size (string blks)

Cause: Specified OPTIMAL size is smaller than the cumulative size of the initial extents during create rollback segment.

Action: Specify a larger OPTIMAL size.

ORA-01594 attempt to wrap into rollback segment (string) extent (string) which is being freed

Cause: Undo generated to free a rollback segment extent is attempting to write into the same extent due to small extents and/or there are too many extents to free.

Action: The rollback segment shrinking will be rolled back by the system; increase the optimal size of the rollback segment.

ORA-01595 error freeing extent (string) of rollback segment (string))

Cause: Some error occurred while freeing inactive rollback segment extents.

Action: Investigate the accompanying error.

ORA-01596 cannot specify system in string parameter

Cause: The system rollback segment is specified in the initialization parameter referred to in the error message.

Action: Change the value of the initialization parameter.

ORA-01597 cannot alter system rollback segment online or offline

Cause: An attempt was made to online or offline the system rollback segment.

Action: No action required.

ORA-01598 rollback segment 'string' is not online

Cause: Could have been taken offline before by the database administrator or cleaned up by SMON.

Action: Check the status of rollback segment in UNDO$ or DBA_ROLLBACK_SEGS to make sure the rollback segment is actually online.

ORA-01599 failed to acquire rollback segment (string), cache space is full

Cause: The amount statically allocated is not enough based on the value of the MAX_ROLLBACK_SEGMENTS parameter.

Action: For now, take another rollback segment offline or increase the value of the parameter MAX_ROLLBACK_SEGMENTS.

ORA-01600 at most one "string" in clause "string" of string

Cause: The initialization parameter was incorrectly specified.

Action: Correct the initialization parameter and restart the instance.

ORA-01601 illegal bucket size in clause "string" of string

Cause: The bucket size was invalid for this parameter.

Action: Correct the initialization parameter and restart the instance.

ORA-01603 illegal grouping size in clause "string" of string

Cause: The grouping size was invalid for this parameter.

Action: Correct the initialization parameter and restart the instance.

ORA-01604 illegal number range in clause "string" of string

Cause: The number range was invalid for this parameter.

Action: Correct the initialization parameter and restart the instance.

ORA-01605 missing numbers in clause "string" of string

Cause: The numbers were missing for this parameter.

Action: Correct the initialization parameter and restart the instance.

ORA-01606 gc_files_to_locks not identical to that of another mounted instance

Cause: The GC_FILES_TO_LOCKS parameters were different on two instances.

Action: Modify the initialization parameter GC_FILES_TO_LOCKS and restart.

ORA-01607 gc_lck_procs (string) is not the same as other instances (string)

Cause: The GC_LCK_PROCS initialization parameter is not the same as in other instances that already have the database open.

Action: Modify the GC_LCK_PROCS parameter and restart the instance.

ORA-01608 cannot bring rollback segment 'string' online, its status is (string)

Cause: Could have been brought online before by the database administrator or left as a result of process crash.

Action: Check the status of rollback segment in UNDO$ or DBA_ROLLBACK_SEGS

ORA-01609 log string is the current log for thread string - cannot drop members

Cause: A member of the current log for a thread cannot be dropped.

Action: If the thread is opened, request a log switch by the instance that is using it. If it is not open, disable the thread, manually archive the log, or clear it.

ORA-01610 recovery using the BACKUP CONTROLFILE option must be done

Cause: Either an earlier database recovery session specified BACKUP CONTROLFILE, or the control file was re-created with the RESETLOGS option, or the control file being used is a backup control file. After that only BACKUP CONTROLFILE recovery is allowed and it must be followed by a log reset at the next database open.

Action: Perform recovery using the BACKUP CONTROFILE option.

ORA-01611 thread number string is invalid - must be between 1 and string

Cause: A thread number in a command is greater than the number of threads supported by the control file.

Action: Use a thread number that is valid, or resize the thread record and/or checkpoint progress record sections of the control file.

ORA-01612 thread string is already enabled

Cause: An attempt was made to enable a thread that is already enabled.

Action: Either use this thread or enable another thread.

ORA-01613 thread string only has string logs - at least 2 logs required to enable

Cause: The thread cannot be enabled because it only has two online log files associated with it.

Action: Add logs to the thread or pick another thread to enable.

ORA-01614 thread string is busy - cannot enable

Cause: The mount enqueue for the thread could not be acquired when attempting to enable the thread. This probably means that another process has already started enabling this thread.

Action: Wait and try again, or find another thread to enable.

ORA-01615 thread string is mounted - cannot disable

Cause: Some instance, possibly this one, has allocated the thread for its use. The thread may not be disabled while in use.

Action: Shut down cleanly the instance using the thread.

ORA-01616 thread string is open - cannot disable

Cause: The thread is not closed. The last instance to use the thread died leaving the thread open. A thread cannot be disabled until it is closed. It is still required for crash or instance recovery.

Action: If the database is open, instance recovery should close the thread soon; wait a few minutes. Otherwise open the database; crash recovery will close the thread.

ORA-01617 cannot mount: string is not a valid thread number

Cause: The value of the initialization parameter THREAD is not between 1 and the number of threads allowed by the control file.

Action: Shut down the instance, change the value of the initialization parameter and restart, or resize the thread record and/or checkpoint progress record sections of the control file.

ORA-01618 thread string is not enabled - cannot mount

Cause: The value of the initialization parameter THREAD requests a thread that is not enabled. A thread must be enabled before it can be mounted.

Action: Shut down the instance, change the value of the initialization parameter and restart, mounting a different thread. If the database is open in another instance, then the thread may be enabled.

ORA-01619 thread string is mounted by another instance

Cause: The value of the initialization parameter THREAD requests a thread that has been mounted by another instance. Only one instance may use a thread.

Action: Shut down the instance, change the value of the initialization parameter and restart, mounting a different thread.

ORA-01620 no public threads are available for mounting

Cause: The value of the initialization parameter THREAD is zero, its default value. There are no threads which have been publicly enabled, and not mounted.

Action: Shut down the instance, change the value of the initialization parameter to a thread which is privately enabled and not mounted. If the database is open in another instance, then a thread may be publicly enabled.

ORA-01621 cannot rename member of current log if database is open

Cause: This is a rename command for a member of the current log for an open thread. If the database is open anywhere, the log may be in use, so the rename cannot be done.

Action: Wait until the log is not current, or mount the database exclusively.

ORA-01622 thread number must be specified - default not specific

Cause: The thread was not specified when adding a log, and the currently mounted thread was chosen by default at mount time. Since the current thread was not specified explicitly the user cannot know which thread the log will be added to.

Action: Explicitly specify the thread number either in the initialization parameter THREAD, or in the ADD command.

ORA-01623 log string is current log for thread string - cannot drop

Cause: A thread's current log cannot be dropped even if the thread is closed. A disabled thread usually does not have a current log, but a half completed disable may need to be disabled again.

Action: If the database is not open then disable the thread. If the database is open and an instance has the thread open, then the instance can be requested to switch logs. If the database is closed the log can be archived or cleared to force a switch.

ORA-01624 log string needed for crash recovery of thread string

Cause: A log cannot be dropped or cleared until the thread's checkpoint has advanced out of the log.

Action: If the database is not open then open it. Crash recovery will advance the checkpoint. If the database is open force a global checkpoint. If the log is corrupted so that the database cannot be opened, it may be necessary to do incomplete recovery until cancel at this log.

ORA-01625 rollback segment 'string' does not belong to this instance

Cause: An attempt was made to shrink or take a rollback segment offline that does not belong to this instance.

Action: Take only those rollback segments offline that belong to the current instance. To take the rollback segment offline, connect to the instance containing it.

ORA-01626 rollback segment number 'string' cannot handle more transactions

Cause: Too many transactions in this segment.

Action: Choose a different rollback segment, or reduce the number of concurrent transactions.

ORA-01627 rollback segment number 'string' is not online

Cause: Could have been taken offline before by the database administrator or cleaned up by SMON.

Action: Check the status of rollback segment in UNDO$ or DBA_ROLLBACK_SEGS to make sure the rollback segment is actually online.

ORA-01628 max # extents (string) reached for rollback segment string

Cause: An attempt was made to extend a rollback segment that was already at the MAXEXENTS value.

Action: If the value of the MAXEXTENTS storage parameter is less than the maximum allowed by the system, raise this value.

ORA-01629 max # extents (string) reached saving undo for tablespace string

Cause: Save undo for the offline tablespace at MAXEXTENTS.

Action: Check the storage parameters for the system tablespace. The tablespace needs to be brought back online so the undo can be applied.

ORA-01630 max # extents (string) reached in temp segment in tablespace string

Cause: A temporary segment tried to extend past MAXEXTENTS.

Action: If MAXEXTENTS for the tablespace is less than the system maximum, you can raise that. Otherwise, raise PCTINCREASE for the tablespace.

ORA-01631 max # extents (string) reached in table string.string

Cause: A table tried to extend past MAXEXTENTS.

Action: If MAXEXTENTS is less than the system maximum, raise it. Otherwise, you must re-create with larger initial, next or PCTINCREASE parameters.

ORA-01632 max # extents (string) reached in index string.string

Cause: An index tried to extend past MAXEXTENTS.

Action: If the value of MAXEXTENTS in the index storage clause is less than the maximum (based on your block size), raise it. Otherwise, re-create the index with larger extent sizes so that the total number of extents falls below the maximum.

ORA-01633 Real Application Clusters Option needed for this operation

Cause: System does not have Real Application Clusters configured.

Action: Obtain Real Application Clusters option.

ORA-01634 rollback segment number 'string' is about to go offline

Cause: The rollback segment specified was marked to go offline by the database administrator.

Action: Bring the rollback segment online first.

ORA-01635 rollback segment #string specified not available

Cause: One of the following:

  • You tried to acquire an offline rollback segment during startup.
  • You tried to drop a rollback segment that contains active transactions.

Action: For the above, one of the following:

  • Bring the tablespace containing the rollback segment online or do not specify the rollback segment in the initialization parameter file.
  • If the rollback segment is in use, shut down the instance using the rollback segment. Otherwise, if the rollback segment needs recovery, determine which errors are holding back the rolling back of the transactions and take appropriate action.

ORA-01636 rollback segment 'string' is already online

Cause: A rollback segment can only be used by one instance and an instance is trying to bring a rollback segment online that is already in use.

Action: Check that the values set in the initialization parameter file for parameters ROLLBACK_SEGMENTS, ROLLBACK_SEGMENT_INITIAL, and ROLLBACK_SEGMENT_COUNT are correctly set for the instance with the problem. Also check that the instance is using the correct initialization parameter file. Make sure you are not confused about the difference between private and public rollback segments. See the Oracle9i Database Administrator's Guide for more information about using rollback segments in parallel mode.

ORA-01637 rollback segment 'string' is being used by another instance (#string)

Cause: A rollback segment can only be used by one instance, and an instance is trying to access a rollback segment online that is already in use.

Action: Check that the values set in the initialization parameter file for parameters ROLLBACK_SEGMENTS, ROLLBACK_SEGMENT_INITIAL, and ROLLBACK_SEGMENT_COUNT are correctly set for the instance with the problem. Also check that the instance is using the correct initialization parameter file. Make sure you are not confused about the difference between private and public rollback segments. See the Oracle9i Database Administrator's Guide for more information about using rollback segments in parallel mode.

ORA-01638 parameter string does not allow ORACLE version string to mount cluster database

Cause: The value of the RECOVERY_COMPATIBLE parameter is set too low to allow this software version to mount in cluster database mode.

Action: Either use an earlier software release or advance the RECOVERY_COMPATIBLE parameter. If this happens when no RECOVERY_COMPATIBLE parameter has been specified then set it to the current software release.

ORA-01640 cannot make tablespace read only with active transactions

Cause: An attempt was made to make a tablespace read only while there are active transactions in the database. All transactions must commit or rollback to insure that there is no undo for a tablespace before it can be made read only. This includes in doubt distributed transactions.

Action: Prevent any more transactions from being started. Putting the database in restricted mode usually helps. If there are any in doubt transactions they must also be resolved.

ORA-01641 tablespace 'string' is not online - cannot add data file

Cause: An attempt was made to add a datafile to a tablespace that has been set to read only or offline.

Action: Make the tablespace online and read write then add the datafile.

ORA-01642 begin backup not needed for read only tablespace 'string'

Cause: An attempt was made to begin or end a backup for a tablespace that has been set to read only.

Action: Take the backup without any BEGIN or END commands. The files are not being modified so the backup will be consistent.

ORA-01643 system tablespace can not be made read only

Cause: An attempt was made to set the system tablespace to read only. The system tablespace must remain read write for database operation.

Action: Leave system tablespace read write.

ORA-01644 tablespace 'string' is already read only

Cause: An attempt was made to make tablespace read only that is already read only.

Action: Leave tablespace read only, or make read write then make read only again.

ORA-01645 previous attempt to make read write is half complete

Cause: A failure while making the tablespace read write left it read only, but the checkpoint was advanced. The tablespace will not be usable after a resetlogs if its files are offline.

Action: Repeat the command to make the tablespace read write.

ORA-01646 tablespace 'string' is not read only - cannot make read write

Cause: An attempt was made to make a tablespace read write that is not read only. It may be either online or offline.

Action: Leave tablespace read write.

ORA-01647 tablespace 'string' is read only, cannot allocate space in it

Cause: An attempt was made to allocate space in a read-only tablespace.

Action: Create the object in another tablespace.

ORA-01648 log string is the current log of disabled thread string

Cause: An attempt to enable the thread failed after it was half completed. This log was left as the current log even though the thread is still disabled. Since a log switch cannot be done until the thread is enabled, the log cannot be cleared or archived.

Action: Complete the thread enable by issuing the ENABLE command again.

ORA-01649 operation not allowed with a backup controlfile

Cause: An attempt is being made to perform a command that does not make sense when the control file is a restored backup.

Action: Wait until after the database has been opened and try again.

ORA-01650 unable to extend rollback segment string by string in tablespace string

Cause: Failed to allocate an extent for rollback segment in tablespace.

Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-01651 unable to extend save undo segment by string for tablespace string

Cause: Failed to allocate an extent for saving undo entries for the indicated offline tablespace.

Action: Check the storage parameters for the SYSTEM tablespace. The tablespace needs to be brought back online so the undo can be applied.

ORA-01652 unable to extend temp segment by string in tablespace string

Cause: Failed to allocate an extent for temporary segment in tablespace.

Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-01653 unable to extend table string.string by string in tablespace string

Cause: Failed to allocate an extent for table segment in tablespace.

Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-01654 unable to extend index string.string by string in tablespace string

Cause: Failed to allocate an extent for index segment in tablespace.

Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-01655 unable to extend cluster string.string by string in tablespace string

Cause: Failed to allocate an extent for cluster segment in tablespace.

Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-01656 max # extents (string) reached in cluster string.string

Cause: A cluster tried to extend past MAXEXTENTS.

Action: If MAXEXTENTS is less than the system maximum, raise it. Otherwise, you must re-create with larger initial, next or PCTINCREASE parameters.

ORA-01657 invalid SHRINK option value

Cause: The specified value must be an integer.

Action: Choose an appropriate integer value.

ORA-01658 unable to create INITIAL extent for segment in tablespace string

Cause: Failed to find sufficient contiguous space to allocate INITIAL extent for segment being created.

Action: Use ALTER TABLESPACE ADD DATAFILE to add additional space to the tablespace or retry with a smaller value for INITIAL.

ORA-01659 unable to allocate MINEXTENTS beyond string in tablespace string

Cause: Failed to find sufficient contiguous space to allocate MINEXTENTS for the segment being created.

Action: Use ALTER TABLESPACE ADD DATAFILE to add additional space to the tablespace or retry with smaller value for MINEXTENTS, NEXT or PCTINCREASE.

ORA-01660 tablespace 'string' is already permanent

Cause: An attempt was made to make tablespace permanent that is already permanent.

Action: Leave tablespace permanent.

ORA-01661 tablespace 'string' is already temporary

Cause: An attempt was made to make tablespace temporary that is already temporary.

Action: Leave tablespace permanent.

ORA-01662 tablespace 'string' is non-empty and cannot be made temporary

Cause: An attempt was made to convert a non-empty tablespace to a temporary tablespace

Action: Drop all the objects in the tablespace.

ORA-01663 the contents of tablespace 'string' is constantly changing

Cause: The contents of the tablespace is always changing between PERMANENT and TEMPORARY.

Action: Decide what the tablespace contents should be and stay with it.

ORA-01664 Transaction which has expanded the Sort Segment has aborted

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-01665 controlfile is not a standby controlfile

Cause: An attempt was made to mount, recover or activate a standby database without a standby control file.

Action: Create a standby control file before attempting to use the database as a standby database.

ORA-01666 controlfile is for a standby database

Cause: An attempt was made to mount, recover, or open a standby database without the appropriate command option to designate a standby database.

Action: Use the standby option or appropriate commands, or mount with the primary control file.

ORA-01667 cannot add any more tablespaces: limit of string exceeded

Cause: There is no more room in the control file for adding tablespaces.

Action: Resize the control file or drop other tablespaces.

ORA-01668 standby database requires DROP option for offline of data file

Cause: An attempt was made to take a datafile offline in a standby database without specifying the DROP option. Files that are offline in a standby database are not recovered, and are likely to be unusable if the standby is activated. Note that specifying DROP does not prevent bringing the file online later.

Action: Specify the DROP option or leave the file online.

ORA-01669 standby database controlfile not consistent

Cause: An attempt was made to activate a standby database with a control file that has not been recovered to the same point as the datafiles. Most likely the control file was just copied from the primary database and has not been used for recovery.

Action: Recover the standby database until all the files are consistent.

ORA-01670 new datafile string needed for standby database recovery

Cause: Standby database recovery noticed that a file was added to the primary database, but is not available on the standby.

Action: Either copy the file from the primary database or do an ALTER DATABASE CREATE DATAFILE command on the standby to create a file to recover.

ORA-01671 controlfile is a backup, cannot make a standby controlfile

Cause: The currently mounted control file is a backup control file, and attempting to create a control file for a standby database.

Action: Complete any needed recovery and open the database with the resetlogs option.

ORA-01672 controlfile may be missing files or have extra ones

Cause: An attempt was made to create a standby control file, but the control file was either recently created via CREATE CONTROLFILE or an incomplete recovery has been done. Thus the datafiles in the control file and the ones in the data dictionary may not match.

Action: Open the database, then retry the operation.

ORA-01673 data file string has not been identified

Cause: This datafile was not in the control file after an incomplete recovery or CREATE CONTROLFILE. Since information from its header is needed for standby database recovery, we cannot create a standby control file.

Action: Find the file and bring it online. If desired it may be taken offline again. If you intend to drop this file, then taking it offline with the DROP option will avoid this error.

ORA-01674 data file string is an old incarnation rather than current file

Cause: Recovery encountered redo that indicates this file was dropped from the database and another file was added using the same file number. This implies that a CREATE CONTROLFILE command was given the old file which was dropped rather than the latest file.

Action: Rebuild the control file using CREATE CONTROLFILE, and give the correct file.

ORA-01675 max_commit_propagation_delay inconsistent with other instances

Cause: The MAX_COMMIT_PROPAGATION_DELAY initialization parameter is inconsistent with those in other instances.

Action: Make sure all instances have the same MAX_COMMIT_PROPAGATION_DELAY.

ORA-01676 standby file name convert of 'string' exceeds maximum length of string

Cause: When the given file name is converted to the name used for the standby database, the converted name is bigger than the maximum allowed file name.

Action: Change the value of the initialization parameter DB_FILE_STANDBY_NAME_CONVERT or LOG_FILE_STANDBY_NAME_CONVERT to convert to a valid file name.

ORA-01677 standby file name convert parameters differ from other instance

Cause: The DB_FILE_STANDBY_NAME_CONVERT or LOG_FILE_STANDBY_NAME_CONVERT initialization parameters are not the same as in other instances that already have the database mounted.

Action: Change the value of the initialization parameters DB_FILE_STANDBY_NAME_CONVERT and LOG_FILE_STANDBY_NAME_CONVERT to match other instances.

ORA-01678 parameter string must be pairs of pattern and replacement strings

Cause: The initialization parameter does not have an even number of strings for its value. The odd numbered strings are patterns to be found in file names. The even numbered strings are used to replace the corresponding patterns when found in file names.

Action: Specify an even number of strings for the parameter, or omit the parameter.

ORA-01679 database must be mounted EXCLUSIVE and not open to activate

Cause: An attempt to activate a standby database was made when the database was not mounted EXCLUSIVE or was already open.

Action: Mount the database EXCLUSIVE and retry the ACTIVATE command.

ORA-01680 unable to extend LOB segment by string in tablespace string

Cause: Failed to allocate an extent for a LOB segment in tablespace.

Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-01681 max # extents (string) reached in LOB segment in tablespace string

Cause: A LOB segment tried to extend past MAXEXTENTS.

Action: If MAXEXTENTS for the tablespace is less than the system maximum, you can raise that. Otherwise, raise PCTINCREASE for the tablespace.

ORA-01682 read-only DB cannot allocate temporary space in tablespace string

Cause: Temporary space (usually for sorting) could not be allocated in either main storage or a temporary file. An attempt was made to allocate the space from the tablespace named, but the database is opened read only. The database open requires a sort work space.

Action: Either allow sufficient workspace in main storage (SORT_AREA_SIZE initialization parameter), or create a temporary tablespace before making the database read only. Use ALTER TABLESPACE ADD TEMPFILE statement to add temporary files to the temporary tablespace.

ORA-01683 unable to extend index string.string partition string by string in tablespace string

Cause: Failed to allocate an extent for index segment in tablespace.

Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-01684 max # extents (string) reached in table string.string partition string

Cause: A table tried to extend past MAXEXTENTS.

Action: If MAXEXTENTS is less than the system maximum, raise it. Otherwise, you must re-create with larger initial, next or PCTINCREASE parameters.

ORA-01685 max # extents (string) reached in index string.string partition string

Cause: An index tried to extend past MAXEXTENTS.

Action: If MAXEXTENTS is less than the system max, raise it. Otherwise, you must re-create with larger initial, next or PCTINCREASE parameters.

ORA-01686 max # files (string) reached for the tablespace string

Cause: The number of files for a given tablespace has reached its maximum value.

Action: Resize existing files in the tablespace, or partition the objects among multiple tablespaces, or move some objects to a different tablespace.

ORA-01687 specified logging attribute for tablespace 'string' is same as the existing

Cause: An attempt was made to change the tablespace default logging attribute (LOGGING or NOLOGGING) to be the same as the existing logging attribute.

Action: Change the specified logging attribute.

ORA-01688 unable to extend table string.string partition string by string in tablespace string

Cause: Failed to allocate an extent for table segment in tablespace.

Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-01689 syntax error in clause "string" of string

Cause: There was a syntax in the initialization parameter.

Action: Fix the syntax error and restart the instance.

ORA-01690 sort area size too small

Cause: The sort area size was too small to fit two records in memory.

Action: Increase the SORT_AREA_SIZE initialization parameter.

ORA-01691 unable to extend lob segment string.string by string in tablespace string

Cause: Failed to allocate an extent for LOB segment in tablespace.

Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-01692 unable to extend lob segment string.string partition string by string in tablespace string

Cause: Failed to allocate an extent for LOB segment in tablespace.

Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-01693 max # extents (string) reached in lob segment string.string

Cause: A LOB segment tried to extend past MAXEXTENTS.

Action: If MAXEXTENTS is less than the system max, raise it. Otherwise, you must re-create with larger initial, next or PCTINCREASE parameters.

ORA-01694 max # extents (string) reached in lob segment string.string partition string

Cause: A LOB segment tried to extend past MAXEXTENTS.

Action: If MAXEXTENTS is less than the system max, raise it. Otherwise, you must re-create with larger initial, next or PCTINCREASE parameters.

ORA-01695 error converting rollback segment string to version 8.0.2

Cause: Version 8.0.1 database may not have shut down cleanly.

Action: May have to reload the 8.0.1 database and shut down cleanly.

ORA-01696 controlfile is not a clone controlfile

Cause: An attempt was made to mount, a database as a clone when it is already mounted by another instance not as a clone or attempting to use a current control file for a clone.

Action: Mount without the clone option or use a backup control file and shut down the other instances before mounting as a clone.

ORA-01697 controlfile is for a clone database

Cause: An attempt was made to mount a clone database without the appropriate command option to designate a clone database.

Action: Use the clone option or appropriate commands, or mount with the primary control file.

ORA-01698 a clone database may only have SYSTEM rollback segment online

Cause: An attempt was made to online a rollback segment in a clone database.

Action: Do not use this command.

ORA-01699 tablespace 'string' is being imported for point in time recovery

Cause: An attempt was made to online a tablespace or begin another point in time import while a point in time import is already in progress.

Action: Wait until the import completes.

ORA-01700 duplicate username in list

ORA-01701 a cluster is not appropriate here

ORA-01702 a view is not appropriate here

ORA-01703 missing SYNONYM keyword

ORA-01704 string literal too long

Cause: The string literal is longer than 4000 characters.

Action: Use a string literal of at most 4000 characters. Longer values may only be entered using bind variables.

ORA-01705 an outer join cannot be specified on a correlation column

ORA-01706 user function result value was too large

ORA-01707 missing LIST keyword

ORA-01708 ACCESS or SESSION expected

ORA-01709 program does not exist

ORA-01710 missing OF keyword

ORA-01711 duplicate privilege listed

ORA-01712 you cannot grant a privilege which you do not have

ORA-01713 GRANT OPTION does not exist for that privilege

ORA-01714 error in execution of user function

ORA-01715 UNIQUE may not be used with a cluster index

Cause: An attempt was made to create a cluster index with the UNIQUE attribute.

Action: Remove UNIQUE from the CREATE INDEX statement.

ORA-01716 NOSORT may not be used with a cluster index

Cause: An attempt was made to create a cluster index using the NOSORT option.

Action: Remove NOSORT from the CREATE INDEX statement.

ORA-01717 seccta: invalid access mode token passed

ORA-01718 BY ACCESS | SESSION clause not allowed for NOAUDIT

Cause: Attempt to specify BY ACCESS | SESSION in a NOAUDIT statement.

Action: Remove BY ACCESS | SESSION.

ORA-01719 outer join operator (+) not allowed in operand of OR or IN

Cause: An outer join appears in an or clause.

Action: If A and B are predicates, to get the effect of (A(+) or B), try (select where (A(+) and not B)) union all (select where (B)).

ORA-01720 grant option does not exist for 'string.string'

Cause: A grant was being performed on a view and the grant option was not present for an underlying object.

Action: Obtain the grant option on all underlying objects of the view.

ORA-01721 USERENV(COMMITSCN) invoked more than once in a transaction

Cause: The USERENV('COMMITSCN') function can only be used once in a transaction.

Action: Re-write the transaction to use USERENV('COMMITSCN') only once.

ORA-01722 invalid number

Cause: The attempted conversion of a character string to a number failed because the character string was not a valid numeric literal. Only numeric fields or character fields containing numeric data may be used in arithmetic functions or expressions. Only numeric fields may be added to or subtracted from dates.

Action: Check the character strings in the function or expression. Check that they contain only numbers, a sign, a decimal point, and the character "E" or "e" and retry the operation.

ORA-01723 zero-length columns are not allowed

Cause: During CREATE TABLE, a zero-length column was specified, for example, CHAR(0).

Action: Correct the column declaration so that the length is at least 1 and try the operation again.

ORA-01724 floating point precision is out of range (1 to 126)

Cause: Floating point precision is too small or large.

Action: Correct and retry.

ORA-01725 USERENV('COMMITSCN') not allowed here

Cause: The function USERNEV('COMMMITSCN') is only allowed as a top-level expression in the VALUES clause of an INSERT statements, and on the right hand side of an assignment in an UPDATE statement.

Action: Correct the use of the function.

ORA-01726 a table is not appropriate here

Cause: A table name was used in a statement in which tables are not permitted.

Action: Enter a valid table statement or use the current statement on the appropriate object.

ORA-01727 numeric precision specifier is out of range (1 to 38)

Cause: The precision specified for a number column in a CREATE/ALTER TABLE or CREATE CLUSTER statement must be a digit between 1 and 38. If no precision is specified, a default precision of 22 digits is used.

Action: Specify numeric precision between 1 and 38 and retry the statement.

ORA-01728 numeric scale specifier is out of range (-84 to 127)

Cause: The scale specified for a numeric field in a CREATE/ALTER TABLE or CREATE CLUSTER statement is not in the valid range. It should be between -84 and 127.

Action: Specify a numeric scale between -84 and 127. If a number is not specified, the default scale of the column is 0 decimal places.

ORA-01729 database link name expected

Cause: A database link name does not follow the at-sign (@) in a reference to a table in a remote database.

Action: Correct the reference and retry the operation. The correct syntax for denoting a table in a remote database follows:

username.table_name@ database_name

Spaces before and after the at-sign (@) are optional.

ORA-01730 invalid number of column names specified

Cause: The number of column names specified in a CREATE VIEW statement did not correspond to the number of columns listed in the SELECT clause. If column names are specified in a CREATE VIEW statement, exactly one name must be specified for each column or expression in the SELECT clause.

Action: Specify one view column name for each column in the SELECT clause.

ORA-01731 circular view definition encountered

Cause: Through a series of CREATE and DROP VIEW statements, a view was defined that refers to itself. For example, VIEW1 might include a column from VIEW2 that is defined as a column in VIEW1. View definitions may be seen by querying the data dictionary.

Action: Check the view definitions, remove any circular references, and retry the statements.

ORA-01732 data manipulation operation not legal on this view

Cause: An attempt was made to use an UPDATE, INSERT, or DELETE statement on a view that contains expressions or functions or was derived from more than one table. If a join operation was used to create the view or the view contains virtual columns derived from functions or expressions, then the view may only be queried.

Action: UPDATE, INSERT, or DELETE rows in the base tables instead and restrict the operations on the view to queries.

ORA-01733 virtual column not allowed here

Cause: An attempt was made to use an INSERT, UPDATE, or DELETE statement on an expression in a view.

Action: INSERT, UPDATE, or DELETE data in the base tables, instead of the view.

ORA-01734 illegal parameters - EXTENT MIN higher than EXTENT MAX

Cause: An incorrect value is specified for the parameter.

Action: Correct the parameter and reissue the statement.

ORA-01735 invalid ALTER TABLE option

Cause: An invalid option was specified in an ALTER TABLE statement.

Action: Check the statement syntax, specify a valid option, and retry the statement.

ORA-01736 [NOT] SUCCESSFUL expected

Cause: An AUDIT or NOAUDIT statement contained WHENEVER followed by something other than SUCCESSFUL or NOT SUCCESSFUL.

Action: Correct the WHENEVER clause and retry the statement.

ORA-01737 valid modes: [ROW] SHARE, [[SHARE] ROW] EXCLUSIVE, SHARE UPDATE

Cause: The lock mode entered was not recognized.

Action: Enter one of the following: SHARE, ROW SHARE, EXCLUSIVE, ROW EXCLUSIVE, SHARE ROW EXCLUSIVE, or SHARE UPDATE.

ORA-01738 missing IN keyword

Cause: In a LOCK TABLE statement, the keyword IN was missing.

Action: Place the keyword IN and lock mode directly after the table name in the LOCK TABLE statement and retry the statement.

ORA-01739 missing MODE keyword

Cause: In a LOCK TABLE statement, the keyword MODE was missing. The keyword MODE must directly follow the specified lock mode.

Action: Check the statement syntax, insert the keyword MODE where required, and retry the statement.

ORA-01740 missing double quote in identifier

Cause: An initial double quote (") was found without a closing quote. If an identifier contains a blank or special characters other than $, #, or _, it must be enclosed in double quotes.

Action: Add a closing double quote (") to the end of the identifier.

ORA-01741 illegal zero-length identifier

Cause: An attempt was made to use two double quotes ("") as an identifier. An identifier must be at least one character long.

Action: Insert at least one character between the double quotes in the identifier. If a blank identifier is required, specify a blank space between the double quotes (" ").

ORA-01742 comment not terminated properly

Cause: The indicated comment or hint begun with the /* token did not have the terminating */.

Action: Properly terminate the comment or hint with a */.

ORA-01743 only pure functions can be indexed

Cause: The indexed function uses SYSDATE or the user environment.

Action: PL/SQL functions must be pure (RNDS, RNPS, WNDS, WNPS). SQL expressions must not use SYSDATE, USER, USERENV(), or anything else dependent on the session state. NLS-dependent functions are OK.

ORA-01744 inappropriate INTO

Cause: The INTO clause may not be used in a subquery.

Action: Check the syntax, place the INTO clause in the top-level query, and retry the statement.

ORA-01745 invalid host/bind variable name

Cause: A colon in a bind variable or INTO specification was followed by an inappropriate name, perhaps a reserved word.

Action: Change the variable name and retry the operation.

ORA-01746 indicator variable not permitted here

Cause: An indicator variable is not permitted in this context.

Action: Remove the indicator variable and retry the operation.

ORA-01747 invalid user.table.column, table.column, or column specification

Cause: A column name was specified improperly in the current SQL statement.

Action: Check the statement's syntax, especially references to column names, and retry the statement.

ORA-01748 only simple column names allowed here

Cause: This SQL statement does not allow a qualified column name, such as username.table.column or table.column.

Action: Remove the qualifications from the column and retry the operation.

ORA-01749 you may not GRANT/REVOKE privileges to/from yourself

Cause: Grantor is not allowed to grant or revoke object or system privileges to self.

Action: Issue the GRANT or REVOKE of system privileges from another database administrator account.

ORA-01750 UPDATE/REFERENCES may only be REVOKEd from the whole table, not by column

Cause: Although it is possible to GRANT update privileges on a column-by-column basis, it is only possible to REVOKE them for an entire table.

Action: Do not identify specific columns. To revoke update privileges for certain columns, use REVOKE for the entire table and GRANT the user privileges for specific columns.

ORA-01751 Invalid dump undo option

Cause: An invalid option is specified in the ALTER DUMP UNDO command.

Action: Correct and reissue the command.

ORA-01752 cannot delete from view without exactly one key-preserved table

Cause: The deleted table either had no key preserved tables, had more than one key-preserved table, or the key-preserved table was an unmerged view or a table from a read-only view.

Action: Redefine the view or delete it from the underlying base tables.

ORA-01753 column definition incompatible with clustered column definition

Cause: When adding a table to a cluster, the definition of the column in the table was inconsistent with the definition of the column in the cluster.

Action: The table cannot be added to the cluster until all cluster column definitions are consistent.

ORA-01754 a table may contain only one column of type LONG

Cause: An attempt was made to add a LONG column to a table which already had a LONG column. Note that even if the LONG column currently in the table has already been marked unused, another LONG column may not be added until the unused columns are dropped.

Action: Remove the LONG column currently in the table by using the ALTER TABLE command.

ORA-01755 Must specify an extent number or block number

Cause: Expecting an extent or block number but something else was specified.

Action: Correct the error and reissue the command.

ORA-01756 quoted string not properly terminated

Cause: A quoted string must be terminated with a single quote mark (').

Action: Insert the closing quote and retry the statement.

ORA-01757 Must specify an object number

Cause: Expecting an object number but something else was specified.

Action: Correct the error and reissue the command.

ORA-01758 table must be empty to add mandatory (NOT NULL) column

Cause: It is not possible to define a new column as NOT NULL if rows already exist in the table being modified.

Action: Retry the statement without the NOT NULL specification.

ORA-01759 user function is incorrectly defined

Cause: A user function has been improperly defined.

Action: Contact Oracle Support Services.

ORA-01760 illegal argument for function

Cause: The argument or arguments specified for the function are not valid in this context.

Action: Check the definition of the function and correct the arguments.

ORA-01761 DML operation does not map to a unique table in the join

Cause: The primary table is the base table against which the update, insert or delete operation is finally being done. For delete either there is no primary table in the join query or there is more than one. For update or insert the columns specified map to more than one base table.

Action: Change the join specification.

ORA-01762 vopdrv: view query block not in FROM

Cause: This is an internal error message not normally issued.

Action: Contact Oracle Support Services.

ORA-01763 update or delete involves outer joined table

Cause: For deletes, the table being deleted from is outer joined to some other table. For updates, either the table being updated is outer- joined to some other table, or some table reachable from the primary table is being outer joined to a table not reachable from the primary table.

Action: Change the join specification.

ORA-01764 new update value of join is not guaranteed to be unique

Cause: A row of a join query table is being updated using a row of a table that is not guaranteed to have exactly one value for the row being updated.

Action: Change the join specification.

ORA-01765 specifying table's owner name is not allowed

Cause: A table or view name was specified with a period (.) or identified with an invalid prefix.

Action: Check that the object is identified correctly and if necessary remove the period from the name.

ORA-01766 dictionary table not allowed in this context

Cause: The name of a data dictionary object was used outside the FROM clause of a SELECT statement. The only operation allowed on a data dictionary object is to SELECT from it.

Action: Restrict operations on data dictionary objects to queries.

ORA-01767 UPDATE ... SET expression must be a subquery

Cause: An attempt was made to use a single expression without a subquery to update a list of columns.

Action: Check the syntax for using subqueries to update data and add the necessary subquery.

ORA-01768 number string too long

Cause: A number entered exceeds the limit of 255 characters, including digits, sign, decimal point, and exponent.

Action: Shorten the number string, perhaps by expressing it in scientific notation, for example, 1.85E9 instead of 1,850,000,000.

ORA-01769 duplicate CLUSTER option specifications

Cause: During a CREATE of a clustered table, the user attempted to specify more than one CLUSTER option.

Action: Remove the extra CLUSTER option.

ORA-01770 CLUSTER option not allowed in CREATE CLUSTER command

Cause: An attempt was made to use the CLUSTER option within a CREATE CLUSTER statement.

Action: Remove the CLUSTER clause and try again.

ORA-01771 illegal option for a clustered table

Cause: During a CREATE or ALTER of a clustered table, the user attempted to enter one or more of the following options: INITRANS, MAXTRANS, PCTFREE, PCTUSED, STORAGE, TABLESPACE, CACHE, NOCACHE. These options may only be specified for the cluster itself.

Action: Remove the illegal option(s).

ORA-01772 Must specify a value for LEVEL

Cause: Expecting the value of LEVEL but something else was specified.

Action: Correct the error and reissue the command.

ORA-01773 may not specify column datatypes in this CREATE TABLE

Cause: Column datatypes were specified in a SELECT statement used to create and load a table directly.

Action: Remove column datatypes. The datatypes of the SELECT list expressions are automatically used as the column datatypes.

ORA-01774 Dump undo option specified more than once

Cause: The same option for ALTER DUMP UNDO was specified twice.

Action: Remove the redundant options and reissue the command.

ORA-01775 looping chain of synonyms

Cause: Through a series of CREATE synonym statements, a synonym was defined that referred to itself. For example, the following definitions are circular:

CREATE SYNONYM s1 for s2 CREATE SYNONYM s2 for s3 CREATE SYNONYM s3 for s1

Action: Change one synonym definition so that it applies to a base table or view and retry the operation.

ORA-01776 cannot modify more than one base table through a join view

Cause: Columns belonging to more than one underlying table were either inserted into or updated.

Action: Phrase the statement as two or more separate statements.

ORA-01777 WITH GRANT OPTION not allowed in this system

Cause: This version of Oracle does not support the WITH GRANT OPTION.

Action: Remove the WITH GRANT option.

ORA-01778 maximum subquery nesting level exceeded

Cause: An attempt was made to use more than 255 levels of nested subqueries.

Action: Merge some of the subqueries into their containing queries, until there are less than 255 levels of nesting.

ORA-01779 cannot modify a column which maps to a non key-preserved table

Cause: An attempt was made to insert or update columns of a join view which map to a non-key-preserved table.

Action: Modify the underlying base tables directly.

ORA-01780 string literal required

Cause: In a COMMENT statement, the Comment following the keyword IS must be a quoted string literal.

Action: Check that the Comment is a string literal.

ORA-01781 UNRECOVERABLE cannot be specified without AS SELECT

Cause: UNRECOVERABLE was specified in a CREATE TABLE statement without also specifying a populating subquery with an AS clause.

Action: Do not specify UNRECOVERABLE.

ORA-01782 UNRECOVERABLE cannot be specified for a cluster or clustered table

Cause: A CREATE CLUSTER, or clustered CREATE TABLE statement specified UNRECOVERABLE.

Action: Do not specify UNRECOVERABLE.

ORA-01783 only one RECOVERABLE or UNRECOVERABLE clause may be specified

Cause: RECOVERABLE was specified more than once, UNRECOVERABLE was specified more than once, or both RECOVERABLE and UNRECOVERABLE were specified in a CREATE TABLE or CREATE INDEX or ALTER INDEX REBUILD statement.

Action: Remove all but one of the RECOVERABLE or UNRECOVERABLE clauses and reissue the statement.

ORA-01784 RECOVERABLE cannot be specified with database media recovery disabled

Cause: A CREATE TABLE or CREATE INDEX statement specified RECOVERABLE when the database was running in NOARCHIVELOG mode. Since logs are not being archived, they will be overwritten and the object being created cannot be recovered from a backup taken before the object was created.

Action: Do not specify RECOVERABLE, or restart the database with media recovery enabled.

ORA-01785 ORDER BY item must be the number of a SELECT-list expression

Cause: Either an ORDER BY item for a set expression is not a column number, or the ORDER BY item is not the number of a SELECT list column.

Action: The ORDER BY item must be a number between 1 and the number of columns in the SELECT list. Check the column number and retry the statement.

ORA-01786 FOR UPDATE of this query expression is not allowed

Cause: An attempt was made to use a FOR UPDATE clause on the result of a set expression involving GROUP BY, DISTINCT, UNION, INTERSECT, or MINUS.

Action: Check the syntax, remove the FOR UPDATE clause, and retry the statement.

ORA-01787 only one clause allowed per query block

Cause: An attempt was made to use more than one WHERE, GROUP BY, CONNECT BY, or HAVING clause in the query.

Action: Combine the duplicate clauses into a single clause and retry the statement.

ORA-01788 CONNECT BY clause required in this query block

Cause: A START WITH clause was specified without a CONNECT BY clause.

Action: Check the syntax, specify a CONNECT BY clause, and retry the statement.

ORA-01789 query block has incorrect number of result columns

Cause: All of the queries participating in a set expression do not contain the same number of SELECT list columns.

Action: Check that all the queries in the set expression have the same number of SELECT list columns.

ORA-01790 expression must have same datatype as corresponding expression

Cause: A SELECT list item corresponds to a SELECT list item with a different datatype in another query of the same set expression.

Action: Check that all corresponding SELECT list items have the same datatypes. Use the TO_NUMBER, TO_CHAR, and TO_DATE functions to do explicit data conversions.

ORA-01791 not a SELECTed expression

Cause: There is an incorrect ORDER BY item. The query is a SELECT DISTINCT query with an ORDER BY clause. In this context, all ORDER BY items must be constants, SELECT list expressions, or expressions whose operands are constants or SELECT list expressions.

Action: Remove the inappropriate ORDER BY item from the SELECT list and retry the statement.

ORA-01792 maximum number of columns in a table or view is 1000

Cause: An attempt was made to create a table or view with more than 1000 columns, or to add more columns to a table or view which pushes it over the maximum allowable limit of 1000. Note that unused columns in the table are counted toward the 1000 column limit.

Action: If the error is a result of a CREATE command, then reduce the number of columns in the command and resubmit. If the error is a result of an ALTER TABLE command, then there are two options:

  • If the table contained unused columns, remove them by executing ALTER TABLE DROP UNUSED COLUMNS before adding new columns.
  • Reduce the number of columns in the command and resubmit.

ORA-01793 maximum number of index columns is 32

Cause: While creating an index, more than 32 columns were specified.

Action: Remove some columns from the index definition. If all the columns indexed are required, split them into two indexes.

ORA-01794 maximum number of cluster columns is 32

Cause: More than 32 columns were specified in the cluster key.

Action: Remove some of the columns from the cluster key definition. Consider concatenating multiple character strings into a single column.

ORA-01795 maximum number of expressions in a list is 1000

Cause: More than 254 columns or expressions were specified in a list.

Action: Remove some of the expressions from the list.

ORA-01796 this operator cannot be used with lists

Cause: A relational operator is not allowed in this context. When comparing lists, use only an operator that tests for equivalence, such as =, !=, or IN.

Action: Rephrase the query so that it only compares lists for equivalence. For example, the following clause is invalid:

WHERE (A,B) > ((C,D), (E,F))

It may be necessary to compare individual columns separately. For example, to see if A and B are respectively greater than C and D, use WHERE A>B AND C>D instead of WHERE (A,B)>(C,D).

ORA-01797 this operator must be followed by ANY or ALL

Cause: The keyword ANY or ALL was missing.

Action: Check the statement syntax and add ANY or ALL where appropriate.

ORA-01798 missing EXCEPTION keyword

Cause: The EXCEPTION keyword is missing from the ENABLE clause.

Action: Correct the syntax.

ORA-01799 a column may not be outer-joined to a subquery

Cause: expression(+) relop (subquery) is not allowed.

Action: Either remove the (+) or make a view out of the subquery. In V6 and before, the (+) was just ignored in this case.

ORA-01800 a literal in the date format was too large to process

Cause: A literal specified in a date format was too large. If a literal is entered as a date, it must be less than 220 characters long.

Action: Use only literals less than 220 characters long in the date format.

ORA-01801 date format is too long for internal buffer

Cause: The date format string was too long to process. This should occur only if several long literals are specified as part of a date.

Action: Remove long literals from the date format string.

ORA-01802 Julian date is out of range

Cause: An invalid Julian date was entered. Valid Julian dates run from 1 to 3,442,447.

Action: Enter a valid Julian date between 1 and 3,442,447.

ORA-01803 failure in getting date/time

Cause: This is an internal error message that is not likely to occur. It is usually caused by a failure in the system clock.

Action: Investigate the system clock and the process that requested the date or time. If necessary, contact Oracle Support Services.

ORA-01804 failure to initialize timezone information

Cause: The timezone information file was not properly read.

Action: Please contact Oracle Support Services.

ORA-01810 format code appears twice

Cause: A format code was listed twice in a date specification. Each format code may be specified only once in the function TO_DATE.

Action: Remove the duplicate format code from the date specification, then retry the operation.

ORA-01811 Julian date precludes use of day of year

Cause: Both a Julian date and a day of the year were specified in the TO_DATE function. If a Julian date is specified, the day of the year (DDD) may not be specified, as it is contained in the Julian date.

Action: Remove the day of the year or the Julian date from the specification, then retry the operation.

ORA-01812 year may only be specified once

Cause: More than one year format code was listed in a date specification. Only one of the following year format codes may be specified in a date: YYYY, YYY, YY, Y.

Action: Remove all but one year format from the date specification.

ORA-01813 hour may only be specified once

Cause: More than one hour format code was listed in a date specification. Only one of the following hour format codes may be specified in a date: HH, HH12, HH24.

Action: Remove all but one hour format from the date specification.

ORA-01814 AM/PM conflicts with use of A.M./P.M.

Cause: Both types of meridian indicators, AM and PM, were listed in a date specification. If one of the meridian indicator format masks, such as AM or A.M., is specified in the date, the other may not be specified.

Action: Use one meridian indicator format, with or without periods, consistently.

ORA-01815 BC/AD conflicts with use of B.C./A.D.

Cause: Both types of BC/AD indicators were listed in a date specification. If one of the BC/AD indicator format masks, such as BC or B.C., is specified in the date, the other may not be specified.

Action: Use one BC/AD indicator format, with or without periods, consistently.

ORA-01816 month may only be specified once

Cause: More than one month format code was listed in a date specification. Only one of the following month format codes may be specified in a date: MM, MON, MONTH.

Action: Remove all but one month format from the date specification.

ORA-01817 day of week may only be specified once

Cause: More than one day-of-the-week format code was listed in a date specification. Only one of the following day-of-the-week format codes may be specified in a date: D, DY, DAY.

Action: Remove all but one day-of-the-week format from the date specification.

ORA-01818 'HH24' precludes use of meridian indicator

Cause: A date specification contained both a 24-hour time format code and a meridian indicator code. If hours are specified using the 24-hour time format (HH24), a meridian indicator, AM or PM, may not be specified.

Action: Remove the meridian indicator format code, AM/PM or A.M./P.M., or the 24-hour time format code, HH24, from the date specification.

ORA-01819 signed year precludes use of BC/AD

Cause: A date specification contained both a signed year and a B.C./A.D. indicator. If the year is specified with a sign, such as SYYYY, then B.C. or A.D. is implicit in the date and must not be entered.

Action: Remove the B.C./A.D. indicator from the date specification.

ORA-01820 format code cannot appear in date input format

Cause: A date specification contained an invalid format code. Only the following may be specified when entering a date: year, month, day, hours, minutes, seconds, Julian day, A.M./P.M. and B.C./A.D.

Action: Remove the invalid format code from the date specification.

ORA-01821 date format not recognized

Cause: A date specification contained an invalid format code.

Action: Check that only valid date format codes are specified.

ORA-01822 era format code is not valid with this calendar

Cause: An era format code, E or EE, was specified with a calendar which does not use era information.

Action: Retry the operation using a date format mask which does not contain era format codes.

ORA-01830 date format picture ends before converting entire input string

Cause: A valid date format picture included extra data. The first part of the format picture was converted into a valid date, but the remaining data was not required.

Action: Check the specifications for date format pictures and correct the statement.

ORA-01831 year conflicts with Julian date

Cause: The wrong year was specified with a Julian day. If a year is specified with a Julian date, it must be the year in which the Julian date occurs.

Action: Remove the year value from the date specification or enter the correct year for the Julian date.

ORA-01832 day of year conflicts with Julian date

Cause: A Julian date was specified with the day of the year but the day did not correspond to the Julian date. If the day of the year is specified with a Julian date, it must be the same day as the Julian date.

Action: Remove the day of the year value from the date specification or enter the correct day for the Julian date.

ORA-01833 month conflicts with Julian date

Cause: The wrong month was specified with a Julian date. If a month is specified with a Julian date, it must be the month in which the Julian date occurs.

Action: Remove the month value from the date specification or enter the correct month for the Julian date.

ORA-01834 day of month conflicts with Julian date

Cause: A Julian date was specified with the day of the month, but the month day did not correspond to the Julian date. If the day of the month is specified with a Julian date, it must be the same day of the month as the Julian date.

Action: Remove the day of the month value from the date specification or enter the correct day of the month for the Julian date.

ORA-01835 day of week conflicts with Julian date

Cause: A Julian date was specified with the day of the week, but the weekday did not correspond to the Julian date. If the day of the week is specified with a Julian date, it must be the same day of the week as the Julian date.

Action: Remove the day of the week value from the date specification or enter the correct day of the week for the Julian date.

ORA-01836 hour conflicts with seconds in day

Cause: The wrong hour was specified with seconds in the day. If an hour is specified with seconds past midnight (SSSSS), it must be the hour in which the seconds value falls.

Action: Remove the hour value from the date specification or specify the correct hour for the seconds past midnight.

ORA-01837 minutes of hour conflicts with seconds in day

Cause: A date specification contained both minutes of the hour and seconds in the day but the values did not correspond. If both minutes in the hour (MI) and seconds past midnight (SSSSS) are specified, the minutes value must be the minute in which the seconds value will occur.

Action: Remove the minutes value from the date specification or enter the correct minute value for the specified seconds value.

ORA-01838 seconds of minute conflicts with seconds in day

Cause: A date specification contained both seconds of the minute and seconds in the day but the values did not correspond. If both types of seconds are specified, the seconds of the minute value (SS) must be the second in which the seconds past midnight value (SSSSS) will fall.

Action: Remove the seconds of the minute value from the date specification or enter a value that corresponds to the given seconds in the day.

ORA-01839 date not valid for month specified

Cause: The day of the month specified in the date is invalid for the given month. The day of the month (DD) must be between 1 and the number of days in the month.

Action: Enter a valid day of the month for the specified month.

ORA-01840 input value not long enough for date format

Cause: The data to be converted to date format was incomplete; the date format picture was longer than the input data.

Action: Either add more input or shorten the date picture format, then retry the operation.

ORA-01841 (full) year must be between -4713 and +9999, and not be 0

Cause: A date specified a year that is not in the valid date range. A valid date is any date between January 1, 4712 B.C. and December 31, 9999 A.D.

Action: Enter a valid date value between 4712 B.C. and 9999 A.D.

ORA-01842 quarter must be between 1 and 4

Cause: An invalid value was specified for the quarter of the year in a date. The quarter (Q) must be between 1 and 4.

Action: Enter a value for quarter between 1 and 4.

ORA-01843 not a valid month

Cause: A date specified an invalid month. Valid months are: January-December, for format code MONTH, and Jan-Dec, for format code MON.

Action: Enter a valid month value in the correct format.

ORA-01844 week of year must be between 1 and 52

Cause: An invalid value was specified for the week of the year in a date. Week of the year (WW) must be between 1 and 52.

Action: Enter a week of the year value between 1 and 52.

ORA-01845 week of month must be between 1 and 5

Cause: An invalid value was specified for the week of the month in a date. Week of the month (W) must be between 1 and 5.

Action: Enter a week of the month value between 1 and 5.

ORA-01846 not a valid day of the week

Cause: A date specified an invalid day of the week. Valid days are:

  • Monday-Sunday, for format code DAY
  • Mon-Sun, for format code DY
  • 1-7, for format code D

Action: Enter a valid day of the week value in the correct format.

ORA-01847 day of month must be between 1 and last day of month

Cause: The day of the month listed in a date is invalid for the specified month. The day of the month (DD) must be between 1 and the number of days in that month.

Action: Enter a valid day value for the specified month.

ORA-01848 day of year must be between 1 and 365 (366 for leap year)

Cause: An invalid day of the year was specified in a date. Day of the year (DDD) must be between 1 and 365 for a non-leap year or 1 and 366 for a leap year.

Action: Enter a day of the year value between 1 and 365 (or 366).

ORA-01849 hour must be between 1 and 12

Cause: An invalid hour was specified for a date using the 12-hour time format. If a 12-hour format code (HH or HH12) is used, the specified hour must be between 1 and 12.

Action: Enter an hour value between 1 and 12.

ORA-01850 hour must be between 0 and 23

Cause: An invalid hour was specified for a date using the 24-hour time format. If the 24-hour format code (HH24) is listed, the specified hour must be between 0 and 23.

Action: Enter an hour value between 0 and 23.

ORA-01851 minutes must be between 0 and 59

Cause: An invalid minute value was specified in a date. Minutes must be between 0 and 59.

Action: Enter a minute value between 0 and 59.

ORA-01852 seconds must be between 0 and 59

Cause: An invalid seconds value was specified in a date. Seconds must be between 0 and 59 if the seconds format code (SS) is used.

Action: Enter a seconds value between 0 and 59.

ORA-01853 seconds in day must be between 0 and 86399

Cause: An invalid value for seconds in the day was specified in a date. Seconds must be between 0 and 86399 if the seconds past midnight format code (SSSSS) is used.

Action: Specify a seconds value between 0 and 86399.

ORA-01854 julian date must be between 1 and 5373484

Cause: An invalid Julian date was entered.

Action: Enter a valid Julian date between 1 and 5373484.

ORA-01855 AM/A.M. or PM/P.M. required

Cause: A date specification contained a meridian indicator format code but a valid meridian indicator was not specified. If a meridian indicator code, A.M./P.M. or AM/PM, is included in a date format, the date must include a valid meridian indicator.

Action: Specify the meridian indicator in the correct format, A.M./AM or P.M./PM.

ORA-01856 BC/B.C. or AD/A.D. required

Cause: A date specification contained a BC/AD format code but a valid BC/AD indicator was not specified. If one of the BC/AD format codes, BC/AD or B.C./A.D., is specified in a date format, the date must include BC/B.C. or AD/A.D.

Action: Specify the BC/AD indicator in the date using the correct format.

ORA-01857 not a valid time zone

Cause: An incorrect time zone code was specified for the NEW_TIME function.

Action: Correct the invalid time zone code, then retry the operation.

ORA-01858 a non-numeric character was found where a numeric was expected

Cause: The input data to be converted using a date format model was incorrect. The input data did not contain a number where a number was required by the format model.

Action: Fix the input data or the date format model to make sure the elements match in number and type. Then retry the operation.

ORA-01859 a non-alphabetic character was found where an alphabetic was expected

Cause: The input data to be converted using a date format model was incorrect. The input data did not contain a letter where a letter was required by the format model.

Action: Fix the input data or the date format model to make sure the elements match in number and type. Then retry the operation.

ORA-01860 week of year must be between 1 and 53

Cause: A week number outside the range 1 to 53 was specified.

Action: Use only a value within the valid range for the week number.

ORA-01861 literal does not match format string

Cause: Literals in the input must be the same length as literals in the format string (with the exception of leading white space). If the "FX" modifier has been toggled on, the literal must match exactly, with no extra white space.

Action: Correct the format string to match the literal.

ORA-01862 the numeric value does not match the length of the format item

Cause: When the FX and FM format codes are specified for an input date, then the number of digits must be exactly the number specified by the format code. For example, 9 will not match the format specifier DD but 09 will.

Action: Correct the input date or turn off the FX or FM format specifier in the format string.

ORA-01863 the year is not supported for the current calendar

Cause: The year is not supported for the current calendar.

Action: Check the documentation to find out what years are supported for the current calendar.

ORA-01864 the date is out of range for the current calendar

Cause: Your calendar does not extend to the specified date.

Action: Specify a date which is legal for this calendar.

ORA-01865 not a valid era

Cause: Era input does not match a known era.

Action: Provide a valid era on input.

ORA-01866 the datetime class is invalid

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-01867 the interval is invalid

Cause: The character string you specified is not a valid interval.

Action: Specify a valid interval.

ORA-01868 the leading precision of the interval is too small

Cause: The leading precision of the interval is too small to store the specified interval.

Action: Increase the leading precision of the interval or specify an interval with a smaller leading precision.

ORA-01869 reserved for future use

Cause: Not an error.

Action: No action required.

ORA-01870 the intervals or datetimes are not mutually comparable

Cause: The intervals or datetimes are not mutually comparable.

Action: Specify a pair of intervals or datetimes that are mutually comparable.

ORA-01871 the number of seconds must be less than 60

Cause: The number of seconds specified was greater than 59.

Action: Specify a value for seconds that is 59 or smaller.

ORA-01872 reserved for future use

Cause: Not an error.

Action: No action required.

ORA-01873 the leading precision of the interval is too small

Cause: The leading precision of the interval is too small to store the specified interval.

Action: Increase the leading precision of the interval or specify an interval with a smaller leading precision.

ORA-01874 time zone hour must be between -12 and 13

Cause: The time zone hour specified was not in the valid range.

Action: Specify a time zone hour between -12 and 13.

ORA-01875 time zone minute must be between -59 and 59

Cause: The time zone minute specified was not in the valid range.

Action: Specify a time zone minute between -59 and 59.

ORA-01876 year must be at least -4713

Cause: The specified year was not in range.

Action: Specify a year that is greater than or equal to -4713.

ORA-01877 string is too long for internal buffer

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-01878 specified field not found in datetime or interval

Cause: The specified field was not found in the datetime or interval.

Action: Make sure that the specified field is in the datetime or interval.

ORA-01879 the hh25 field must be between 0 and 24

Cause: The specified hh25 field was not in the valid range.

Action: Specify an hh25 field between 0 and 24.

ORA-01880 the fractional seconds must be between 0 and 999999999

Cause: The specified fractional seconds were not in the valid range.

Action: Specify a value for fractional seconds between 0 and 999999999.

ORA-01881 timezone region id number is invalid

Cause: The region id referenced an invalid region.

Action: Please contact Oracle Support Services.

ORA-01882 timezone region string not found

Cause: The specified region name was not found.

Action: Please contact Oracle Support Services.

ORA-01883 overlap was disabled during a region transition

Cause: The region was changing state and the overlap flag was disabled.

Action: Please contact Oracle Support Services.

ORA-01890 NLS error detected

Cause: An NLS error was detected.

Action: Look for additional error messages and take appropriate action. If there are no additional errors, contact Oracle Support Services.

ORA-01891 Datetime/Interval internal error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-01898 too many precision specifiers

Cause: While trying to truncate or round dates, extra data was found in the date format picture.

Action: Check the syntax of the date format picture and retry.

ORA-01899 bad precision specifier

Cause: An invalid precision code was specified in a date.

Action: Enter a valid precision code in the date format. Valid precision types are: century, year, month, day, Julian date, hours, minutes, and seconds.

ORA-01900 LOGFILE keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01901 ROLLBACK keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01902 SEGMENT keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01903 EVENTS keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01904 DATAFILE keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01905 STORAGE keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01906 BACKUP keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01907 TABLESPACE keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01908 EXISTS keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01909 REUSE keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01910 TABLES keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01911 CONTENTS keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01912 ROW keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01913 EXCLUSIVE keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01914 invalid auditing option for sequence numbers

Cause: AUDIT or NOAUDIT on a sequence number specifies an auditing option that is not legal for sequence numbers.

Action: The following options may not be used for sequence numbers and should be removed: COMMENT, DELETE, INDEX, INSERT, LOCK, RENAME, UPDATE, REFERENCES, EXECUTE.

ORA-01915 invalid auditing option for views

Cause: AUDIT or NOAUDIT on a view specifies an auditing option that is not legal for views.

Action: The following options may not be used for views and should be removed: ALTER, INDEX, REFERENCES, EXECUTE.

ORA-01916 keyword ONLINE, OFFLINE, RESIZE, AUTOEXTEND or END/DROP expected

Cause: An expected keyword was not used for DATAFILE/TEMPFILE clause

Action: Use correct syntax.

ORA-01917 user or role 'string' does not exist

Cause: There is not a user or role by that name.

Action: Re-specify the name.

ORA-01918 user 'string' does not exist

Cause: User does not exist in the system.

Action: Verify the user name is correct.

ORA-01919 role 'string' does not exist

Cause: Role by that name does not exist.

Action: Verify you are using the correct role name.

ORA-01920 user name 'string' conflicts with another user or role name

Cause: There is already a user or role with that name.

Action: Specify a different user name.

ORA-01921 role name 'string' conflicts with another user or role name

Cause: There is already a user or role with that name.

Action: Specify a different role name.

ORA-01922 CASCADE must be specified to drop 'string'

Cause: Cascade is required to remove this user from the system. The user own's object which will need to be dropped.

Action: Specify cascade.

ORA-01923 CASCADE aborted, objects locked by another user

Cause: Cannot drop the user's objects; someone has them locked.

Action: Use the lock monitor to determine who has the objects locked.

ORA-01924 role 'string' not granted or does not exist

Cause: Set role can only be performed with roles granted directly to your account (for example, a sub-role cannot be enabled).

Action: Do not try to set the role.

ORA-01925 maximum of string enabled roles exceeded

Cause: The initialization parameter MAX_ENABLED_ROLES has been exceeded.

Action: Increase MAX_ENABLED_ROLES and warm start the database.

ORA-01926 cannot GRANT to a role WITH GRANT OPTION

Cause: Role cannot have a privilege with the grant option.

Action: Perform the grant without the grant option.

ORA-01927 cannot REVOKE privileges you did not grant

Cause: You can only revoke privileges you granted.

Action: Do not revoke these privileges.

ORA-01928 GRANT option not granted for all privileges

Cause: In order to grant a privilege, you must first have the privilege with the grant option.

Action: Obtain the privilege with the grant option and try again.

ORA-01929 no privileges to GRANT

Cause: "ALL" was specified but the user does not have any privileges with the grant option.

Action: Do not grant privileges on that object.

ORA-01930 auditing the object is not supported

Cause: AUDIT or NOAUDIT was specified for an object that cannot be audited.

Action: Do not attempt to AUDIT the object.

ORA-01931 cannot grant string to a role

Cause: UNLIMITED TABLESPACE, REFERENCES, INDEX, SYSDBA or SYSOPER privilege cannot be granted to a role.

Action: Grant privilege directly to the user.

ORA-01932 ADMIN option not granted for role 'string'

Cause: The operation requires the ADMIN option on the role.

Action: Obtain the grant option and retry.

ORA-01933 cannot create a stored object using privileges from a role

Cause: An attempt was made to create a stored object using privileges from a role. Stored objects cannot use privileges from roles.

Action: Grant the privileges required to the user directly.

ORA-01934 circular role grant detected

Cause: Roles cannot be granted circularly. Also, a role cannot be granted to itself.

Action: Do not perform the grant.

ORA-01935 missing user or role name

Cause: A user or role name was expected.

Action: Specify a user or role name.

ORA-01936 cannot specify owner when creating users or roles

Cause: Users and roles do not have owners.

Action: Do not specify an owner.

ORA-01937 missing or invalid role name

Cause: A valid role name was expected.

Action: Specify a valid role name.

ORA-01938 IDENTIFIED BY must be specified for CREATE USER

Cause: Cannot create a user without specifying a password or IDENTIFIED EXTERNALLY.

Action: Specify one of the password clauses.

ORA-01939 only the ADMIN OPTION can be specified

Cause: System privileges and Roles can only be granted with the ADMIN option. The grant option cannot be used with these privileges.

Action: Specify the ADMIN option.

ORA-01940 cannot drop a user that is currently connected

Cause: Attempt was made to drop a user that is currently logged in.

Action: Make sure user is logged off, then repeat command.

ORA-01941 SEQUENCE keyword expected

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-01942 IDENTIFIED BY and EXTERNALLY cannot both be specified

Cause: A user cannot be specified to have and not have a password.

Action: Specify only one of the options.

ORA-01943 IDENTIFIED BY already specified

Cause: The IDENTIFIED clause has been given twice.

Action: Use only one IDENTIFIED BY clause.

ORA-01944 IDENTIFIED EXTERNALLY already specified

Cause: The IDENTIFIED EXTERNALLY clause has been given twice.

Action: Use only one IDENTIFIED clause.

ORA-01945 DEFAULT ROLE[S] already specified

Cause: The DEFAULT ROLES clause has been given twice.

Action: Use only one DEFAULT ROLE clause.

ORA-01946 DEFAULT TABLESPACE already specified

Cause: The DEFAULT TABLESPACE clause has been given twice.

Action: Use only one DEFAULT TABLESPACE clause.

ORA-01947 TEMPORARY TABLESPACE already specified

Cause: The TEMPORARY TABLESPACE clause has been given twice.

Action: Use only one TEMPORARY TABLESPACE clause.

ORA-01948 identifier's name length (string) exceeds maximum (string)

Cause: A name has been specified that is too long. For example, DBMS_SESSION.IS_ROLE_ENABLED() specifies that is too long.

Action: Change the application or command to use a correct identifier.

ORA-01949 ROLE keyword expected

Cause: The ROLE keyword is required here.

Action: Specify the ROLE keyword.

ORA-01950 no privileges on tablespace 'string'

Cause: User does not have privileges to allocate an extent in the specified tablespace.

Action: Grant the user the appropriate system privileges or grant the user space resource on the tablespace.

ORA-01951 ROLE 'string' not granted to 'string'

Cause: The role you tried to revoke was not granted to the user.

Action: Do not try to revoke a privilege which is not granted.

ORA-01952 system privileges not granted to 'string'

Cause: A system privilege you tried to revoke was not granted to the user.

Action: Make sure the privileges you are trying to revoke are granted.

ORA-01953 command no longer valid, see ALTER USER

Cause: The syntax for assigning quotas on tablespaces has changed. The ALTER USER command is now used to perform the functionality.

Action: Use the ALTER USER command instead.

ORA-01954 DEFAULT ROLE clause not valid for CREATE USER

Cause: Default roles cannot be specified for create user.

Action: Grant and alter the user's default roles after creating the user.

ORA-01955 DEFAULT ROLE 'string' not granted to user

Cause: The user being altered does not have the specified role granted directly to the user. Note, sub-roles cannot be used in the DEFAULT ROLE clause.

Action: Grant the role to the user.

ORA-01956 invalid command when OS_ROLES are being used

Cause: This command cannot be used when the initialization parameter OS_ROLES is TRUE.

Action: Grant the role to the user in the operating system.

ORA-01957 Keyword MIN or MAX expected, not found

Cause: The keyword MIN or MAX was expected as an argument.

Action: Enter the keyword MIN or MAX and retry the operation.

ORA-01958 Must supply an integer for the LAYER option

Cause: An item other than an integer was entered for the LAYER option.

Action: Enter an integer for the LAYER option and retry the operation.

ORA-01959 Must supply an integer for the OPCODE option

Cause: An item other than an integer was entered for the OPCODE option. The value in ALTER SYSTEM DUMP ... OPCODE value must be an integer.

Action: Enter an integer for the OPCODE option and retry the operation.

For more information on the OPCODE option, see the Oracle9i SQL Reference.

ORA-01960 Invalid dump logfile option

Cause: An invalid option was entered for the ALTER SYSTEM DUMP LOGFILE option command.

Action: For a list of valid options for DUMP LOGFILE, see the Oracle9i SQL Reference.

ORA-01961 invalid dump option

Cause: An invalid option was entered for the ALTER SYSTEM DUMP statement.

Action: Enter a valid option for ALTER SYSTEM DUMP. Examples of valid options are LOGFILE and UNDO. For more information on the DUMP option, see the Oracle9i SQL Reference.

ORA-01962 Must specify a file number or log sequence number

Cause: An invalid file number or log sequence number was specified.

Action: Enter a valid file number or log sequence number and retry the operation. For more information on valid file and log sequence numbers, see the Oracle9i SQL Reference.

ORA-01963 Must specify a block number

Cause: An invalid block number was specified.

Action: Enter a valid block number and retry the operation. For more information on valid block numbers, see the Oracle9i SQL Reference.

ORA-01964 Must specify a time for the TIME option

Cause: A value was entered for the TIME option that could not be interpreted as a date.

Action: Enter a valid date. For more information on the TIME option, see the Oracle9i SQL Reference.

ORA-01965 Must specify a PERIOD

Cause: A period is missing between the file number and the block number.

Action: Enter a period between the file number and the block number, then retry the operation. For more information on file numbers and block numbers, see the Oracle9i SQL Reference.

ORA-01967 invalid option for CREATE CONTROLFILE

Cause: An invalid CREATE CONTROLFILE option is present.

Action: Specify only valid CREATE CONTROLFILE options.

ORA-01968 Only specify RESETLOGS or NORESETLOGS once

Cause: The keyword RESETLOGS or NORESETLOGS has appeared more than once.

Action: Be sure to specify RESETLOGS or NORESETLOGS exactly once.

ORA-01969 You must specify RESETLOGS or NORESETLOGS

Cause: Missing a RESETLOGS or a NORESETLOGS.

Action: Be sure to specify RESETLOGS or NORESETLOGS exactly once.

ORA-01970 You must specify a database name for CREATE CONTROLFILE

Cause: Missing a database name.

Action: Retype CREATE CONTROLFILE command with the DATABASE keyword.

ORA-01971 Illegal ALTER TRACING option

Cause: An invalid ALTER TRACING option is present.

Action: Specify only valid ALTER TRACING options. Examples of valid options are ENABLE and DISABLE. For more information, see the Oracle9i SQL Reference.

ORA-01972 Must specify a string for ALTER TRACING ENABLE or DISABLE

Cause: Something other than a valid identifier was specified for ALTER TRACING ENABLE or DISABLE.

Action: Specify a valid identifier for ALTER TRACING ENABLE or DISABLE and retry the operation. For more information on valid identifiers, see the Oracle9i SQL Reference.

ORA-01973 Missing change number

Cause: Keyword CHANGE found but change number not specified.

Action: Fix the command line and resubmit.

ORA-01974 Illegal archive option

Cause: An invalid option to the ALTER SYSTEM ARCHIVE command was specified.

Action: Check the syntax of the command and retry it.

ORA-01975 Illegal character in change number string

Cause: An invalid change number was supplied.

Action: Resubmit the command with a valid change number.

ORA-01976 Missing change number

Cause: A change number was required, but not supplied.

Action: Check the syntax of the command, supply a change number where needed, then retry the command.

ORA-01977 Missing thread number

Cause: Keyword THREAD found but thread number not specified.

Action: Fix the command line and resubmit.

ORA-01978 Missing sequence number

Cause: Keyword SEQUENCE found but sequence number not specified.

Action: Fix the command line and resubmit.

ORA-01979 missing or invalid password for role 'string'

Cause: An attempt was made to enable a role without giving the proper password.

Action: Use the IDENTIFIED BY clause in SET ROLE to specify the correct password.

ORA-01980 error during OS ROLE initialization

Cause: An operating system error occurred while loading a users OS ROLES.

Action: Check the operating system error.

ORA-01981 CASCADE CONSTRAINTS must be specified to perform this revoke

Cause: During this revoke some foreign key constraints will be removed. In order to perform this automatically, CASCADE CONSTRAINTS must be specified.

Action: Remove the constraints or specify CASCADE CONSTRAINTS.

ORA-01982 invalid auditing option for tables

Cause: AUDIT or NOAUDIT on a table specifies an auditing option that is not legal for tables.

Action: The following options may not be used for tables and should be removed: REFERENCES, EXECUTE.

ORA-01983 invalid auditing option for DEFAULT

Cause: AUDIT or NOAUDIT on a DEFAULT specifies an auditing option that is not legal for DEFAULT.

Action: The following options may not be used for DEFAULT and should be removed: REFERENCES.

ORA-01984 invalid auditing option for procedures/packages/functions

Cause: AUDIT or NOAUDIT on a DEFAULT specifies an auditing option that is not legal for procedures, packages, or functions.

Action: The following options may not be used for procedures, packages, and functions and should be removed: all but EXECUTE.

ORA-01985 cannot create user as LICENSE_MAX_USERS parameter exceeded

Cause: Maximum users in the database license limit exceeded.

Action: Increase license limit.

ORA-01986 invalid option for OPTIMIZER_GOAL

Cause: An invalid OPTIMIZER_GOAL option is present.

Action: Check the syntax for OPTIMIZER_GOAL, specify a valid option and re-execute the statement.

ORA-01987 client os username is too long

Cause: A client's operating system username is too long for the operating system logon to succeed.

Action: Use a shorter operating system username.

ORA-01988 remote os logon is not allowed

Cause: Remote operating system login attempted when not allowed.

Action: Use a local client, or use the REMOTE_OS_AUTHENT system parameter to turn on remote operating system logon.

ORA-01989 role 'string' not authorized by operating system

Cause: The operating system role does not exist, is not granted to you, or you did not provide the correct password.

Action: Re-attempt the SET ROLE with a valid operating system role and password, if necessary.

ORA-01990 error opening password file 'string'

Cause: An attempt to open the specified password file failed because of one of the following errors:

  • An operating system error occurred.
  • ORAPWD is already running, so the password file is locked.

The environment variables ORA_sid_PWFILE and ORA_PWFILE are not set.

Action: Check for the above causes and correct as necessary.

ORA-01991 invalid password file 'string'

Cause: The specified password file name is invalid.

Action: Specify a correct password file name.

ORA-01992 error closing password file 'string'

Cause: The password file could not be closed because of an operating system error or because an authentication action failed.

Action: Check for the above causes and correct as necessary.

ORA-01993 error writing password file 'string'

Cause: The password file could not be written to because of an operating system error or because an authentication action failed.

Action: Check for the above causes and correct as necessary.

ORA-01994 GRANT failed: cannot add users to shared password file

Cause: A grant failed because a user could not be added to the password file. This is because the value of the REMOTE_LOGIN_PASSWORDFILE initialization parameter is set to SHARED.

Action: To add a user to the password file, shut down the database, change the REMOTE_LOGIN_PASSWORDFILE initialization parameter to EXCLUSIVE, and restart the database.

ORA-01995 error reading password file 'string'

Cause: An operating system error occurred when trying to read the password file.

Action: Fix the operating system error.

ORA-01996 GRANT failed: password file 'string' is full

Cause: The grant failed when a user could not be added to the password file, because all available slots in it were used already.

Action: Either create a larger password file or free up slots in the password file by revoking the SYSOPER and SYSDBA privileges from some of the remote users. You can determine which remote users are valid and their privileges by issuing the following query in SQL*DBA:

SELECT * FROM V$REMOTE_USERS;

ORA-01997 GRANT failed: user 'string' is identified externally

Cause: You cannot grant the SYSOPER or SYSDBA privilege to a user created with the IDENTIFIED EXTERNALLY clause.

Action: If you wish to grant the user the SYSOPER or SYSDBA privileges, drop and re-create the user without the IDENTIFIED EXTERNALLY clause.

ORA-01998 REVOKE failed: user SYS always has SYSOPER and SYSDBA

Cause: You attempted to revoke one of the necessary privileges, SYSOPER or SYSDBA, from user SYS. These privileges cannot be revoked.

Action: Do not attempt this operation.

ORA-01999 password file mode has changed from 'string' to 'string'

Cause: Another instance has started with the FORCE_PASSWORD_FILEMODE initialization parameter, which is incompatible with the startup mode of your instance.

Action: Shut down your instance and start up later when the password file changes are completed for the other instance.

ORA-02000 missing string keyword

Cause: The statement entered requires the missing keyword.

Action: Use the specified keyword.

ORA-02001 user SYS is not permitted to create indexes with freelist groups

Cause: An attempt was made to create an index while running with SYS authorization.

Action: Indexes cannot be created with SYS authorization. Either do not create the index or switch to USER authorization.

ORA-02002 error while writing to audit trail

Cause: The auditing facility is unable to write to the AUDIT_TRAIL table. If this error occurs, SQL statements that are currently being audited may also fail. This error will occur if the SYSTEM tablespace runs out of disk space.

Action: Add space to the SYSTEM tablespace or delete rows from the AUDIT_TRAIL table. If these operations fail or do not eliminate the problem, shut down and restart Oracle with auditing disabled. This is done by setting the initialization parameter AUDIT_TRAIL to FALSE.

ORA-02003 invalid USERENV parameter

Cause: An invalid parameter was specified for the USERENV function.

Action: Specify one of the allowable parameters TERMINAL, SESSIONID, ENTRYID, or NLS_LANG.

ORA-02004 security violation

Cause: A user is attempting to perform an operation without the proper permission, and this fact is being recorded in the AUDIT_TRAIL table. This message only appears in the AUDIT_TRAIL table's return code column.

Action: For auditing information only; no action required.

ORA-02005 implicit (-1) length not valid for this bind or define datatype

Cause: A negative length for the define variable was passed to a define function.

Action: An explicit, non-negative, length parameter must be passed.

ORA-02006 invalid packed decimal format string

Cause: A packed decimal datatype was passed to a bind or define function, and the format string parameter was either not present or invalid.

Action: A valid format string parameter must be passed for a packed decimal variable. Check the programming manual for the definition of a packed decimal format string.

ORA-02007 can't use ALLOCATE or DEALLOCATE options with REBUILD

Cause: Allocate or deallocate storage and rebuild index are not compatible.

Action: Choose one or the other.

ORA-02008 non-zero scale specified for nonnumeric column

Cause: A scale factor was specified for a bind or define of a non-numeric variable.

Action: Set the scale factor to zero, then retry the operation.

ORA-02009 the size specified for a file must not be zero

Cause: A value of zero was specified in a SIZE or RESIZE clause of a file specification.

Action: Use correct syntax, or, if allowed, omit the SIZE or RESIZE clause.

ORA-02010 missing host connect string

Cause: A quoted character string does not follow the keyword USING in the USING clause of a CREATE DATABASE LINK statement.

Action: Specify the host connect string, then retry the operation.

ORA-02011 duplicate database link name

Cause: The database link name specified in a CREATE DATABASE LINK statement already exists.

Action: Either specify a new name or drop the existing link.

ORA-02012 missing USING keyword

Cause: The keyword USING does not follow the CONNECT TO clause in a CREATE DATABASE LINK statement.

Action: Specify the USING clause after the CONNECT TO clause.

ORA-02013 missing CONNECT keyword

Cause: The keyword CONNECT does not follow the database link name in a CREATE DATABASE LINK statement.

Action: Specify the CONNECT clause after the database link name.

ORA-02014 cannot select FOR UPDATE from view with DISTINCT, GROUP BY, etc.

Cause: An attempt was made to SELECT... FOR UPDATE from a view whose defining SELECT statement uses at least one of the following constructs in its outer block: outer join, GROUP BY clause, aggregate functions, SELECT DISTINCT, CONNECT BY clause, or set operation, UNION, INTERSECT, or MINUS.

Action: Do not use SELECT... FOR UPDATE on this view.

ORA-02015 cannot select FOR UPDATE from remote table

Cause: An attempt was made to SELECT... FOR UPDATE from a table in a remote database.

Action: It is not currently possible to SELECT... FOR UPDATE from a table in a remote database. Instead, log in or connect directly to the remote database before entering a SELECT... FOR UPDATE on its tables.

ORA-02016 cannot use a subquery in a START WITH on a remote database

Cause: An attempt was made to use a subquery in a START WITH clause. Such a subquery is not currently permitted if the table in the FROM clause of the tree query is in a remote database.

Action: It is necessary to connect directly to the remote database before using a subquery in the START WITH clause.

ORA-02017: integer value required

Cause: The specified value must be an integer.

Action: Specify an appropriate integer value, then retry the operation.

ORA-02018 database link of same name has an open connection

Cause: The user is currently connected to a PUBLIC database link with the same name as the database link name specified in a CREATE or DROP DATABASE LINK statement.

Action: Close the cursors that use the PUBLIC database link.

ORA-02019 connection description for remote database not found

Cause: An attempt was made to connect or log in to a remote database using a connection description that could not be found.

Action: Specify an existing database link. Query the data dictionary to see all existing database links. See your operating system-specific Net8 documentation for valid connection descriptors.

ORA-02020 too many database links in use

Cause: The current session has exceeded the INIT.ORA OPEN_LINKS maximum.

Action: Increase the OPEN_LINKS limit, or free up some open links by committing or rolling back the transaction and canceling open cursors that reference remote databases.

ORA-02021 DDL operations are not allowed on a remote database

Cause: An attempt was made to use a DDL operation on a remote database. For example, "CREATE TABLE tablename@remotedbname...".

Action: To alter the remote database structure, you must connect to the remote database with the appropriate privileges.

ORA-02022 remote statement has unoptimized view with remote object

Cause: The local view is unoptimized and contains references to objects at the remote database and the statement must be executed at the remote database.

Action: Create a similar view on the remote database and modify the violating view in the SQL statement with the new view@remote.

ORA-02023 START WITH or CONNECT BY predicate cannot be evaluated by remote data base

Cause: The statement contains a tree query on a remote database, and the tree query's START WITH or CONNECT BY predicate contains a term that cannot be evaluated at the remote database. Such terms include calls to user functions, calls to USERENV, and references to ROWID.

Action: Remove the disallowed term, directly connect, or log on to the remote database.

ORA-02024 database link not found

Cause: Database link to be dropped is not found in dictionary.

Action: Correct the database link name.

ORA-02025 all tables in the SQL statement must be at the remote database

Cause: A SQL statement referenced tables from multiple databases, and one or more of the remote databases are not Oracle Servers.

Action: Remote updates can be performed only if all databases in the SQL statement are Oracle Servers. Update the earlier version databases in a separate statement.

ORA-02026 missing LINK keyword

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-02027 multi-row UPDATE of LONG column is not supported

Cause: A bind variable with length greater than 4000 bytes is being used to update a column, and the update statement updates more than one row.

Action: You may only update a single row with such a bind variable.

ORA-02028 fetching an exact number of rows is not supported by the server

Cause: The server does not support UPIALL, so the fetch of an exact number of rows cannot be emulated on the user side.

Action: Connect to a valid server or do not use an exact fetch.

ORA-02029 missing FILE keyword

Cause: A keyword is missing.

Action: Supply the missing keyword.

ORA-02030 can only select from fixed tables/views

Cause: An attempt is being made to perform an operation other than a retrieval from a fixed table/view.

Action: You may only select rows from fixed tables/views.

ORA-02031 no ROWID for fixed tables or for external-organized tables

Cause: An attempt was made to access rowid from a fixed table or from an external-organized table.

Action: Do not access ROWID from a fixed table or from an external-organized table.

ORA-02032 clustered tables cannot be used before the cluster index is built

Cause: User attempted to perform a DML statement on a clustered table for which no cluster index has yet been created.

Action: Create the cluster index.

ORA-02033 a cluster index for this cluster already exists

Cause: A cluster index already exists for the cluster.

Action: No action required.

ORA-02034 speed bind not permitted

Cause: Speed bind not allowed with supplied bind variables. Trapped internally by the system.

Action: No action required.

ORA-02035 illegal bundled operation combination

Cause: User requested that the UPI bundled execution call perform an illegal combination of operations.

Action: Use a legal combination of operations and retry.

ORA-02036 too many variables to describe with automatic cursor open

Cause: UPI-bundled execution call tried to perform automatic cursor open and close on a describe operation. There were too many SELECT list items or bind variables to do this.

Action: Open and close cursor explicitly.

ORA-02037 uninitialized speed bind storage

Cause: An attempt was made to perform a speed-execution call on a SQL statement containing host variables without first performing a speed-bind call.

Action: Perform a speed-bind call before performing a speed-execution call.

ORA-02038 define is not allowed for array type

Cause: A user attempted to define a select list variable of type "array". Arrays may serve only as host bind variables.

Action: Correct the offending code.

ORA-02039 bind by value is not allowed for array type

Cause: User attempted to bind an array host variable by value. Arrays may be bound only by reference.

Action: Correct the offending code.

ORA-02040 remote database string does not support two-phase commit

Cause: A distributed update of more than one database was attempted, but the named database does not support the prepare phase of the two-phase commit, as determined by its logon transaction traits. The transaction was rolled back.

Action: Do not attempt to update the named database, unless it is the only database updated in the transaction. Distributed updates of more than one database in a single transaction can be performed only if all databases support the two-phase commit mechanism.

ORA-02041 client database did not begin a transaction

Cause: An update occurred at a coordinated database without the coordinator beginning a distributed transaction. This may happen if a stored procedure commits and then performs updates, and the stored procedure is invoked remotely. It could also happen if an external transaction monitor violates the XA protocol.

Action: If the cause is the former, check that any commit is not followed by an update.

ORA-02042 too many distributed transactions

Cause: The distributed transaction table is full because too many distributed transactions are active.

Action: Increase the DISTRIBUTED_TRANSACTIONS parameter in the initialization parameter file, shut down and restart Oracle, or run fewer transactions. If it is certain there are not too many concurrent distributed transactions, this may be an internal error. In this case, contact Oracle Support Services. Shutting down and restarting the instance could be a workaround.

ORA-02043 must end current transaction before executing string

Cause: A transaction was in progress and one of the following commands was issued:

  • COMMIT FORCE
  • ROLLBACK FORCE
  • ALTER SYSTEM ENABLE DISTRIBUTED RECOVERY in single process mode

Action: COMMIT or ROLLBACK the current transaction and retry the command.

ORA-02044 transaction manager login denied: transaction in progress

Cause: A remote transaction manager tried to log in while a distributed transaction is in progress. A protocol error occurred in the remote transaction manager.

Action: End the current transaction.

ORA-02045 too many local sessions participating in global transaction

Cause: There are too many sessions at this site to accommodate this transaction.

Action: Use an existing database link so that another session need not be created at the remote site.

ORA-02046 distributed transaction already begun

Cause: This is an internal error not normally encountered. A server session received a BEGIN_TRAN remote procedure call before finishing with a previous distributed transaction.

Action: Contact Oracle Support Services.

ORA-02047 cannot join the distributed transaction in progress

Cause: This can happen only when attempting to update an Oracle Version 6 and an Oracle7 database in the same transaction, because either

  • A transaction is in progress against a remote database that does not support two-phase commit.
  • Updates are pending and an attempt was made to update a different database that does not support two-phase commit.

Action: Complete the current transaction before attempting the action that caused the error.

ORA-02048 attempt to begin distributed transaction without logging on

Cause: The client program did not issue a distributed transaction login. This is an internal error.

Action: Contact Oracle Support Services.

ORA-02049 timeout: distributed transaction waiting for lock

Cause: Exceeded INIT.ORA DISTRIBUTED_LOCK_TIMEOUT seconds waiting for lock.

Action: Treat as a deadlock.

ORA-02050 transaction string rolled back, some remote DBs may be in-doubt

Cause: Network or remote failure during a two-phase commit.

Action: Notify operations; remote databases will automatically re-sync when the failure is repaired.

ORA-02051 another session in same transaction failed

Cause: A session at the same site with same global transaction ID failed.

Action: No action necessary; the transaction is automatically recovered.

ORA-02052 remote transaction failure at string

Cause: There was some error in a remote transaction at the named database link.

Action: More descriptive messages will follow. Correct the problem specified in the following messages and retry the operation.

ORA-02053 transaction string committed, some remote DBs may be in-doubt

Cause: There was a network failure or a remote failure during the two-phase commit.

Action: Notify the database administrator. The remote databases will resynchronize automatically when the failure is repaired.

ORA-02054 transaction string in-doubt

Cause: There was a network failure or a remote failure in the two-phase commit.

Action: Notify the database administrator. The remote databases will resynchronize automatically when the failure is repaired. Monitor the DBA_2PC_PENDING table for the outcome and resubmit the transaction, if necessary.

ORA-02055 distributed update operation failed; rollback required

Cause: A failure during a distributed update operation may not have rolled back all effects of the operation. Since some sites may be inconsistent with others, the transaction must roll back to a savepoint or roll back entirely.

Action: Roll back to a savepoint or roll back the entire transaction and resubmit the rolled-back statements.

ORA-02056 2PC: string: bad two-phase command number string from string

Cause: There was a two-phase commit protocol error.

Action: The transaction may automatically recover. Monitor the DBA_2PC_PENDING table to determine the resolution. Enter the transaction again, if necessary. Contact Oracle Support Services if necessary.

ORA-02057 2PC: string: bad two-phase recovery state number string from string

Cause: An internal error in the two-phase recovery protocol occurred.

Action: Contact Oracle Support Services.

ORA-02058 no prepared transaction found with ID string

Cause: No transaction with LOCAL_TRAN_ID or GLOBAL_TRAN_ID found in the PENDING_TRANS$ table in prepared state.

Action: Check the PENDING_TRANS$ table.

ORA-02059 ORA-2PC-CRASH-TEST-string in commit comment

Cause: This is a special comment used to test the two-phase commit.

Action: Do not use this special comment (string a number 1-10).

ORA-02060 select for update specified a join of distributed tables

Cause: An attempt was made to join tables in different remote databases in a SELECT... FOR UPDATE statement.

Action: Joined tables in a SELECT statement with the FOR UPDATE clause must reside at the same database. Simplify the SELECT... FOR UPDATE statement so that it joins only tables in the same database.

ORA-02061 lock table specified list of distributed tables

Cause: Tables in a LOCK TABLE statement must reside at the same database.

Action: Issue multiple LOCK TABLE commands.

ORA-02062 distributed recovery received DBID string, expected string

Cause: A database link at a coordinator no longer points to the expected database. Link may have been redefined, or a different database mounted.

Action: Restore the link definition or the remote database.

ORA-02063 preceding stringstring from stringstring

Cause: An Oracle error was received from a remote database link.

Action: Refer to the preceding error message(s).

ORA-02064 distributed operation not supported

Cause: One of the following unsupported operations was attempted:

  • Array execute of a remote update with a subquery that references a database link, or
  • An update of a long column with bind variable and an update of a second column with a subquery that both references a database link and a bind variable, or
  • A commit is issued in a coordinated session from an RPC with OUT parameters.

Action: Simplify the remote update statement.

ORA-02065 illegal option for ALTER SYSTEM

Cause: The option specified for ALTER SYSTEM is not supported.

Action: Refer to the Oracle9i SQL Reference for information about options supported.

ORA-02066 missing or invalid DISPATCHERS text

Cause: A character string literal was expected, but not found, following ALTER SYSTEM SET DISPATCHERS.

Action: Place the string literal containing the dispatcher's specification after ALTER SYSTEM SET DISPATCHERS.

ORA-02067 transaction or savepoint rollback required

Cause: A failure (typically a trigger or stored procedure with multiple remote updates) occurred such that the all-or-nothing execution of a previous Oracle call cannot be guaranteed.

Action: Roll back to a previous savepoint or roll back the transaction and resubmit.

ORA-02068 following severe error from stringstring

Cause: A severe error (disconnect, fatal Oracle error) was received from the indicated database link. See following error text.

Action: Contact the remote system administrator.

ORA-02069 global_names parameter must be set to TRUE for this operation

Cause: A remote mapping of the statement is required but cannot be achieved because GLOBAL_NAMES should be set to TRUE for it to be achieved.

Action: Issue ALTER SESSION SET GLOBAL_NAMES = TRUE if possible.

ORA-02070 database stringstring does not support string in this context

Cause: The remote database does not support the named capability in the context in which it is used.

Action: Simplify the SQL statement.

ORA-02071 error initializing capabilities for remote database string

Cause: Could not load a remote-specified capability table.

Action: Contact Oracle Support Services for the remote SQL*Connect product.

ORA-02072 distributed database network protocol mismatch

Cause: This should never happen between different PRODUCTION releases of ORACLE, but may happen between alpha and beta releases, for example.

Action: Upgrade the older release.

ORA-02073 sequence numbers not supported in remote updates

Cause: Sequence numbers may not be used in INSERTS, UPDATES, or DELETES on remote tables.

Action: Perform the operation without specifying a sequence number.

ORA-02074 cannot string in a distributed transaction

Cause: A commit or rollback was attempted from session other than the parent of a distributed transaction.

Action: Only commit or roll back from the parent session.

ORA-02075 another instance changed state of transaction string

Cause: A commit force or rollback force was issued from a session in another instance.

Action: Check if another Oracle instance is performing recovery of pending transactions. Query DBA_2PC_PENDING to determine the new state of the transaction.

ORA-02076 sequence not co-located with updated table or long column

Cause: All referenced sequences must be located on the same node as the updated table or the long column.

Action: Correct the problem and then reissue the statement.

ORA-02077 selects of long columns must be from co-located tables

Cause: All tables returning values of long columns in a SELECT statement must be located at the same node.

Action: Correct the problem, then reissue the statement.

ORA-02078 invalid setting for ALTER SYSTEM FIXED_DATE

Cause: An invalid value was used.

Action: Use a correct value.

ORA-02079 no new sessions may join a committing distributed transaction

Cause: A call to UPI2BG was issued in a session for a transaction that has begun to commit in a different branch; that is, a call to UPI2EN was issued for a branch of the same transaction in another session. This can only happen when using an external transaction manager.

Action: Contact Oracle Support Services.

ORA-02080 database link is in use

Cause: A transaction is active or a cursor is open on the database link given in the ALTER SESSION CLOSE DATABASE LINK link command.

Action: Commit or roll back, and close all cursors

ORA-02081 database link is not open

Cause: An attempt was made to use a database link that is not currently open.

Action: Resolve network problems or contact the remote database administrator to determine if the remote database's problem has been fixed. Contact the local database administrator to determine if network problems have been resolved. Wait until the link is open and try the operation again.

ORA-02082 a loopback database link must have a connection qualifier

Cause: An attempt was made to create a database link with the same name as the current database.

Action: This database link needs a trailing qualifier to make the name unique. These qualifiers are operating system-specific. See your operating system-specific Oracle documentation for more information about creating database links.

ORA-02083 database name has illegal character 'string'

Cause: The database name supplied contains an invalid character. For example, there can be no periods, semicolons, single quotes, double quotes, blanks, or non-printable characters in the database name. See the Oracle9i Database Administrator's Guide for naming rules.

Action: Specify a valid database name.

ORA-02084 database name is missing a component

Cause: The complete database name was not provided.

Action: Specify the full database name.

ORA-02085 database link string connects to string

Cause: The database link attempted to connect to a database with a different name. The name of the database link must be the same name as the name of the database.

Action: Create a database link with the same name as the database to which it connects.

ORA-02086 database (link) name is too long

Cause: The name of the database or database link is too long. Database and database link names can be no longer than 128 characters.

Action: Specify the correct database or database link name or specify a name with fewer characters.

ORA-02087 object locked by another process in same transaction

Cause: A database link is being used in the cluster database environment that loops back to the same instance. One session is trying to convert a lock that was obtained by the other session.

Action: Get the more restrictive lock first. For example, if session 1 gets a share lock and session 2 gets an exclusive lock on the same object, get the exclusive lock first. Or use the same session to access the object.

ORA-02088 distributed database option not installed

Cause: The distributed database option is not installed at this site, so the requested operation is not possible.

Action: Contact Oracle Support Services about obtaining the distributed database option.

ORA-02089 COMMIT is not allowed in a subordinate session

Cause: COMMIT was issued in a session that is not the two-phase commit global coordinator.

Action: Issue commit at the global coordinator only.

ORA-02090 network error: attempted callback+passthru

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02091 transaction rolled back

Cause: The distributed transaction is assigned to the system rollback segment and is trying to get into the prepared state, but the required number of non-PREPARED slots are not available, so the transaction is rolled back.

If the transaction aborted at a remote site, only ORA-02091 will be seen. If the transaction aborted at the host site, then both ORA-02091 and ORA-02092 will be seen.

Action: Complete the current transaction and then do the operation required.

ORA-02092 out of transaction table slots for distributed transaction

Cause: The transaction is assigned to the system rollback segment and is trying to get into the PREPARED state, but the required number of non-PREPARED slots are not available, hence the transaction is rolled back.

Action: Add a rollback segment and retry the transaction.

ORA-02093 TRANSACTIONS_PER_ROLLBACK_SEGMENT(string) more than maximum possible(string)

Cause: Value of the parameter specified is greater than allowed on this port.

Action: Use default or reduce it to less than the maximum.

ORA-02094 replication option not installed

Cause: The replication option was not installed at this site. Updatable materialized views, deferred RPCs, and other replication features were, therefore, unavailable.

Action: Install the replication option. The replication option is not part of the Oracle Server product and must be purchased separately. Contact an Oracle Sales representative if the replication option needs to be purchased.

ORA-02095 specified initialization parameter cannot be modified

Cause: Specified initialization parameter is not modifiable with this option.

Action: Check the Oracle9i Database Administrator's Guide for information about under what scope the parameter may be modified.

For more information about modifying an initialization parameter, see the Oracle9i Database Reference.

ORA-02096 specified initialization parameter is not modifiable with this option

Cause: Though the initialization parameter is modifiable, it cannot be modified using the specified command.

Action: Check the Oracle9i Database Administrator's Guide for information about under what scope the parameter may be modified

ORA-02097 parameter cannot be modified because specified value is invalid

Cause: Though the initialization parameter is modifiable, the modified value is not acceptable to the parameter.

Action: Check the Oracle9i Database Administrator's Guide for range of acceptable values for this parameter.

ORA-02098 error parsing index-table reference (:I)

Cause: An incorrect index-table (:I) syntax was encountered.

Action: This syntax is for Oracle internal use only.


ORA-02100 to ORA-04099

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

5
ORA-02100 to ORA-04099

ORA-02100 PCC: out of memory (i.e., could not allocate)

Cause: SQLLIB was unable to allocate enough memory to execute the program.

Action: Allocate more memory to the user session and then rerun the program. If the error persists, contact Oracle Support Services for assistance.

ORA-02101 PCC: inconsistent cursor cache (uce/cuc mismatch)

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

ORA-02102 PCC: inconsistent cursor cache (no cuc entry for this uce)

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

ORA-02103 PCC: inconsistent cursor cache (out-of-range cuc ref)

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

ORA-02104 PCC: inconsistent host cache (no cuc available)

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

ORA-02105 PCC: inconsistent cursor cache (no cuc entry in cache)

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

ORA-02106 PCC: inconsistent cursor cache (OraCursor nr is bad)

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

ORA-02107 PCC: this pgm too old for run-time library: please re-PCC it

Cause: The program was precompiled by an older version of the Oracle Precompilers, which is incompatible with this release of SQLLIB.

Action: Precompile the program with a newer version of the Oracle Precompilers.

ORA-02108 PCC: invalid descriptor passed to run-time library

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

ORA-02109 PCC: inconsistent host cache (out-of-range sit ref)

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

ORA-02110 PCC: inconsistent host cache (invalid sqi type)

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

ORA-02111 PCC: heap consistency error

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

ORA-02112 PCC: SELECT..INTO returns too many rows

Cause: A SELECT...INTO statement returned more rows than can be stored in the host variable provided.

Action: There are three possible solutions:

  1. Use the precompiler option SELECT_ERROR=NO.
  2. Declare a host variable with a larger array dimension.
  3. Declare a cursor or cursor variable for the select statement.

ORA-02140 invalid tablespace name

Cause: An identifier does not follow ALTER TABLESPACE.

Action: Specify a tablespace name following ALTER TABLESPACE.

ORA-02141 invalid OFFLINE option

Cause: An option other than NORMAL or IMMEDIATE follows OFFLINE.

Action: The user must either specify no option following OFFLINE or one of the options NORMAL or IMMEDIATE.

ORA-02142 missing or invalid ALTER TABLESPACE option

Cause: A valid option is not present.

Action: Use one of the valid options: add, rename, default, online, offline, read only, read write, begin, end, no, or force.

ORA-02143 invalid STORAGE option

Cause: An option other than INITIAL, NEXT, MINEXTENTS, MAXEXTENTS, or PCTINCREASE was specified in the STORAGE clause.

Action: Specify only valid options.

ORA-02144 no option specified for ALTER CLUSTER

Cause: No ALTER CLUSTER options are specified.

Action: Specify one or more of the following options: PCTFREE, PCTUSED, SIZE, STORAGE.

ORA-02145 missing STORAGE option

Cause: No STORAGE options were specified following STORAGE (.

Action: Specify one or more STORAGE option between the parentheses.

ORA-02146 SHARED specified multiple times

Cause: The SHARED option was specified in a CREATE DATABASE statement multiple times.

Action: Only specify the SHARED option once.

ORA-02147 conflicting SHARED/EXCLUSIVE options

Cause: Both the SHARED and EXCLUSIVE options were specified in a CREATE DATABASE statement.

Action: Specify SHARED or EXCLUSIVE, but not both.

ORA-02148 EXCLUSIVE specified multiple times

Cause: The EXCLUSIVE option was specified in a CREATE DATABASE statement multiple times.

Action: Only specify the EXCLUSIVE option once.

ORA-02149 Specified partition does not exist

Cause: Partition not found for the object.

Action: Retry with correct partition name.

ORA-02153 invalid VALUES password string

Cause: An encoded password string does not follow the VALUES clause.

Action: Place a proper encoded password string after the VALUES clause.

ORA-02155 invalid DEFAULT tablespace identifier

Cause: An identifier does not follow DEFAULT TABLESPACE.

Action: Place a tablespace name after DEFAULT TABLESPACE.

ORA-02156 invalid TEMPORARY tablespace identifier

Cause: An identifier does not follow TEMPORARY TABLESPACE.

Action: Place a tablespace name after TEMPORARY TABLESPACE.

ORA-02157 no options specified for ALTER USER

Cause: No options were specified.

Action: Specify at least one ALTER USER option.

ORA-02158 invalid CREATE INDEX option

Cause: An option other than COMPRESS, NOCOMPRESS, PCTFREE, INITRANS, MAXTRANS, STORAGE, TABLESPACE, PARALLEL, NOPARALLEL, RECOVERABLE, UNRECOVERABLE, LOGGING, NOLOGGING, LOCAL, or GLOBAL was specified.

Action: Choose one of the valid CREATE INDEX options.

ORA-02159 installed DLM does not support releasable locking mode

Cause: The parameter file specified GC_* parameters that allow locks to be release by the LCK process when not in use. This mode requires additional support from the DLM that is not available.

Action: Specify configuration parameters that do not require the additional function.

ORA-02160 index-organized table can not contain columns of type LONG

Cause: A column of type LONG defined for index-organized table.

Action: Do not use columns of type LONG in index-organized tables.

ORA-02161 invalid value for MAXLOGFILES

Cause: A number does not follow MAXLOGFILES.

Action: Specify a number after MAXLOGFILES.

ORA-02162 invalid value for MAXDATAFILES

Cause: A number does not follow MAXDATAFILES.

Action: Specify a number after MAXDATAFILES.

ORA-02163 invalid value for FREELIST GROUPS

Cause: A number does not follow FREELIST GROUPS.

Action: Specify a number after FREELIST GROUPS.

ORA-02164 DATAFILE clause specified more than once

Cause: The CREATE DATABASE command contains more than one DATAFILE clause.

Action: Specify at most one DATAFILE clause.

ORA-02165 invalid option for CREATE DATABASE

Cause: An invalid CREATE DATABASE option is present.

Action: Specify only valid CREATE DATABASE options.

ORA-02166 ARCHIVELOG and NOARCHIVELOG specified

Cause: Both ARCHIVELOG and NOARCHIVELOG are specified in a CREATE DATABASE statement.

Action: Specify at most one of these two options.

ORA-02167 LOGFILE clause specified more than once

Cause: The CREATE DATABASE command contains more than one LOGFILE clause.

Action: Specify at most one LOGFILE clause.

ORA-02168 invalid value for FREELISTS

Cause: A number does not follow FREELISTS.

Action: Specify a number after FREELISTS.

ORA-02169 FREELISTS storage option not allowed

Cause: An attempt was made to specify the FREELISTS storage option. This option may only be specified during create table or create index.

Action: Remove these options and retry the statement.

ORA-02170 FREELIST GROUPS storage option not allowed

Cause: An attempt was made to specify the FREELIST GROUPS storage option. This option may be specified only when using the CREATE TABLE command and when the ALLOW_FREELIST_GROUPS parameter is specified in the initialization parameter file.

Action: Retry the statement without the FREELIST GROUPS storage option or set the ALLOW_FREELIST_GROUPS parameter in the initialization parameter file.

ORA-02171 invalid value for MAXLOGHISTORY

Cause: A number does not follow MAXLOGHISTORY.

Action: Specify a number after MAXLOGHISTORY.

ORA-02172 The PUBLIC keyword is not appropriate for a disable thread

Cause: The PUBLIC keyword was specified for a disable.

Action: Remove the keyword and resubmit.

ORA-02173 invalid option for DROP TABLESPACE

Cause: Either a token other than INCLUDING was found following the tablespace name or some text was found following INCLUDING CONTENTS.

Action: Place nothing or only INCLUDING CONTENTS after the tablespace name.

ORA-02174 Missing required thread number

Cause: A thread number must be specified after THREAD keyword.

Action: Use correct syntax.

ORA-02175 invalid rollback segment name

Cause: In the CREATE or DROP ROLLBACK SEGMENT statements, an identifier was not found following ROLLBACK SEGMENT.

Action: Place the segment name following ROLLBACK SEGMENT.

ORA-02176 invalid option for CREATE ROLLBACK SEGMENT

Cause: An invalid option was specified in a CREATE ROLLBACK SEGMENT statement.

Action: Specify one of the valid options: TABLESPACE and STORAGE.

ORA-02177 Missing required group number

Cause: A group number must be specified after GROUP keyword.

Action: Check the syntax of the command, specify a group number after GROUP, and retry it.

ORA-02178 correct syntax is: SET TRANSACTION READ { ONLY | WRITE }

Cause: There is a syntax error in the user's statement.

Action: Correct the syntax as indicated.

ORA-02179 valid options: ISOLATION LEVEL { SERIALIZABLE | READ COMMITTED }

Cause: There is a syntax error in the user's statement.

Action: Correct the syntax as indicated.

ORA-02180 invalid option for CREATE TABLESPACE

Cause: An invalid option appears.

Action: Specify one of the valid options: DATAFILE, DEFAULT STORAGE, ONLINE, OFFLINE, or FORCE.

ORA-02181 invalid option to ROLLBACK WORK

Cause: A token other than TO follows ROLLBACK [WORK].

Action: Place nothing or TO SAVEPOINT name after ROLLBACK [WORK].

ORA-02182 savepoint name expected

Cause: An identifier does not follow ROLLBACK [WORK] TO [SAVEPOINT].

Action: Place a savepoint name following TO [SAVEPOINT].

ORA-02183 valid options: ISOLATION_LEVEL { SERIALIZABLE | READ COMMITTED }

Cause: There is a syntax error in the user's statement.

Action: Correct the syntax as indicated.

ORA-02184 resource quotas are not allowed in REVOKE

Cause: In a revoke statement, a resource quota was specified.

Action: Specify resource privilege without the quota.

ORA-02185 a token other than WORK follows COMMIT

Cause: A token other than WORK follows COMMIT.

Action: Place either nothing or WORK after COMMIT.

ORA-02186 tablespace resource privilege may not appear with other privileges

Cause: An attempt was made to grant or revoke a resource quota in the same statement in which other privileges are granted or revoked.

Action: Use a separate grant or revoke statement for the resource quota privilege.

ORA-02187 invalid quota specification

Cause: In a grant or revoke statement, an attempt was made to grant a tablespace quota above the upper limit.

Action: Grant a smaller tablespace quota.

ORA-02189 ON tablespace required

Cause: In a grant or revoke statement, the user specified a tablespace quota but did not follow it with the ON tablespace clause.

Action: Specify the tablespace on which the quota is to be applied with the ON tablespace clause.

ORA-02190 keyword TABLES expected

Cause: The keyword TABLES is expected following DROP CLUSTER name INCLUDING.

Action: Place TABLES after INCLUDING.

ORA-02191 correct syntax is: SET TRANSACTION USE ROLLBACK SEGMENT rbs

Cause: There is a syntax error in the user's statement.

Action: Correct the syntax as indicated.

ORA-02192 PCTINCREASE not allowed for rollback segment storage clauses

Cause: The storage parameter PCTINCREASE was specified in a CREATE or ALTER ROLLBACK SEGMENT command.

Action: Retry the command without the PCTINCREASE clause.

ORA-02194 event specification syntax error string (minor error string) near 'string'

Cause: There is a syntax error in an event specification.

Action: Check syntax and spelling and try again.

ORA-02195 Attempt to create string object in a string tablespace

Cause: The object type is inconsistent with a tablespace contents.

Action: Create an object in a different tablespace, or change the user defaults.

ORA-02196 PERMANENT/TEMPORARY option already specified

Cause: In CREATE TABLESPACE, the PERMANENT and/or TEMPORARY options were specified more than once.

Action: Specify at least one of REBUILD, INITRANS, MAXTRANS, or STORAGE.

For more information about the parameters of CREATE TABLESPACE, see the Oracle9i SQL Reference.

ORA-02197 file list already specified

Cause: In CREATE TABLESPACE, more than one DATAFILE/TEMPFILE clause was specified.

Action: Merge the DATAFILE/TEMPFILE clauses into a single clause.

ORA-02198 ONLINE/OFFLINE option already specified

Cause: In CREATE TABLESPACE, the ONLINE and/or OFFLINE options were specified more than once.

Action: Specify at most one of ONLINE or OFFLINE.

ORA-02199 missing DATAFILE/TEMPFILE clause

Cause: A CREATE TABLESPACE statement has no DATAFILE/TEMPFILE clause.

Action: Specify a DATAFILE/TEMPFILE clause.

ORA-02200 WITH GRANT OPTION not allowed for PUBLIC

Cause: An attempt was made to GRANT to PUBLIC WITH GRANT OPTION.

Action: Remove the WITH GRANT OPTION clause.

ORA-02201 sequence not allowed here

Cause: An attempt was made to reference a sequence in a from-list.

Action: A sequence can only be referenced in a select-list.

ORA-02202 no more tables permitted in this cluster

Cause: An attempt was made to create a table in a cluster which already contains 32 tables.

Action: Up to 32 tables may be stored per cluster.

ORA-02203 INITIAL storage options not allowed

Cause: An attempt was made to alter the INITIAL storage option of a table, cluster, index, or rollback segment. These options may only be specified when the object is created.

Action: Remove these options and retry the statement.

ORA-02204 ALTER, INDEX and EXECUTE not allowed for views

Cause: An attempt was made to grant or revoke an invalid privilege on a view.

Action: Do not attempt to grant or revoke any of ALTER, INDEX, or EXECUTE privileges on views.

ORA-02205 only SELECT and ALTER privileges are valid for sequences

Cause: An attempt was made to grant or revoke an invalid privilege on a sequence.

Action: Do not attempt to grant or revoke DELETE, INDEX, INSERT, UPDATE, REFERENCES or EXECUTE privilege on sequences.

ORA-02206 duplicate INITRANS option specification

Cause: INITRANS is specified more than once.

Action: Specify INITRANS at most once.

ORA-02207 invalid INITRANS option value

Cause: The INITRANS value is not an integer between 1 and 255 and less than or equal to the MAXTRANS value.

Action: Choose a valid INITRANS value.

ORA-02208 duplicate MAXTRANS option specification

Cause: MAXTRANS is specified more than once.

Action: Specify MAXTRANS at most once.

ORA-02209 invalid MAXTRANS option value

Cause: The MAXTRANS value is not an integer between 1 and 255 and greater than or equal to the INITRANS value.

Action: Choose a valid MAXTRANS value.

ORA-02210 no options specified for ALTER TABLE

Cause: No ALTER TABLE option was specified.

Action: Specify at least one alter table option.

ORA-02211 invalid value for PCTFREE or PCTUSED

Cause: The specified value for PCTFREE or PCTUSED is not an integer between 0 and 100.

Action: Choose an appropriate value for the option.

ORA-02212 duplicate PCTFREE option specification

Cause: PCTFREE option specified more than once.

Action: Specify PCTFREE at most once.

ORA-02213 duplicate PCTUSED option specification

Cause: PCTUSED option specified more than once.

Action: Specify PCTUSED at most once.

ORA-02214 duplicate BACKUP option specification

Cause: The BACKUP option to ALTER TABLE is specified more than once.

Action: Specify the option at most once.

ORA-02215 duplicate tablespace name clause

Cause: There is more than one TABLESPACE clause in the CREATE TABLE, CREATE INDEX, or CREATE ROLLBACK SEGMENT statement.

Action: Specify at most one TABLESPACE clause.

ORA-02216 tablespace name expected

Cause: A tablespace name is not present where required by the syntax for one of the following statements: CREATE/DROP TABLESPACE, CREATE TABLE, CREATE INDEX, or CREATE ROLLBACK SEGMENT.

Action: Specify a tablespace name where required by the syntax.

ORA-02217 duplicate storage option specification

Cause: A storage option (INIITAL, NEXT, MINEXTENTS, MAXEXTENTS, PCTINCREASE) is specified more than once.

Action: Specify all storage options at most once.

ORA-02218 invalid INITIAL storage option value

Cause: The specified value must be an integer.

Action: Choose an appropriate integer value.

ORA-02219 invalid NEXT storage option value

Cause: The specified value must be an integer.

Action: Choose an appropriate integer value.

ORA-02220 invalid MINEXTENTS storage option value

Cause: The specified value must be a positive integer less than or equal to MAXEXTENTS.

Action: Specify an appropriate value.

ORA-02221 invalid MAXEXTENTS storage option value

Cause: The specified value must be a positive integer greater than or equal to MINEXTENTS.

Action: Specify an appropriate value.

ORA-02222 invalid PCTINCREASE storage option value

Cause: The specified value must be a positive integer.

Action: Specify an appropriate value.

ORA-02223 invalid OPTIMAL storage option value

Cause: The specified value must be an integer.

Action: Choose an appropriate integer value.

ORA-02224 EXECUTE privilege not allowed for tables

Cause: An attempt was made to grant or revoke an invalid privilege on a table.

Action: Do not attempt to grant or revoke EXECUTE privilege on tables.

ORA-02225 only EXECUTE and DEBUG privileges are valid for procedures

Cause: An attempt was made to grant or revoke an invalid privilege on a procedure, function or package.

Action: Do not attempt to grant or revoke any privilege besides EXECUTE or DEBUG on procedures, functions or packages.

ORA-02226 invalid MAXEXTENTS value (max allowed: string)

Cause: The MAXEXTENTS specified is too large for the database block size. This applies only to SYSTEM rollback segment.

Action: Specify a smaller value.

ORA-02227 invalid cluster name

Cause: A cluster name was not properly formed.

Action: Check the rules for forming object names and enter an appropriate cluster name.

ORA-02228 duplicate SIZE specification

Cause: The SIZE option is specified more than once.

Action: Specify the SIZE option at most once.

ORA-02229 invalid SIZE option value

Cause: The specified value must be an integer number of bytes.

Action: Specify an appropriate value.

ORA-02230 invalid ALTER CLUSTER option

Cause: An option other than PCTFREE, PCTUSED, INITRANS, MAXTRANS, STORAGE, or SIZE is specified in an ALTER CLUSTER statement.

Action: Specify only legal options.

ORA-02231 missing or invalid option to ALTER DATABASE

Cause: An option other than ADD, DROP, RENAME, ARCHIVELOG, NOARCHIVELOG, MOUNT, DISMOUNT, OPEN, or CLOSE is specified in the statement.

Action: Specify only legal options.

ORA-02232 invalid MOUNT mode

Cause: A mode other than SHARED or EXCLUSIVE follows the MOUNT keyword in an ALTER DATABASE statement.

Action: Specify either SHARED, EXCLUSIVE, or nothing following MOUNT.

ORA-02233 invalid CLOSE mode

Cause: A mode other than NORMAL or IMMEDIATE follows the CLOSE keyword in an ALTER DATABASE statement.

Action: Specify either NORMAL, IMMEDIATE, or nothing following CLOSE.

ORA-02234 changes to this table are already logged

Cause: The log table to be added is a duplicate of another.

Action: Do not add this change log to the system; check that the replication product's system tables are consistent.

ORA-02235 this table logs changes to another table already

Cause: The table to be altered is already a change log for another table.

Action: Do not log changes to the specified base table to this table; check that the replication product's system tables are consistent.

ORA-02236 invalid file name

Cause: A character string literal was not used in the file name list of a LOGFILE, DATAFILE, or RENAME clause.

Action: Use correct syntax.

ORA-02237 invalid file size

Cause: A non-integer value was specified in the SIZE or RESIZE clause.

Action: Use correct syntax.

ORA-02238 filename lists have different numbers of files

Cause: In a RENAME clause in ALTER DATABASE or TABLESPACE, the number of existing file names does not equal the number of new file names.

Action: Make sure there is a new file name to correspond to each existing file name.

ORA-02239 there are objects which reference this sequence

Cause: The sequence to be dropped is still referenced by other objects.

Action: Make sure the sequence name is correct or drop the constraint or object that references the sequence.

ORA-02240 invalid value for OBJNO or TABNO

Cause: A number does not follow either OBJNO or TABNO.

Action: Specify a number after OBJNO or TABNO.

ORA-02241 must of form EXTENTS (FILE n BLOCK n SIZE n, ...)

Cause: There was an error in the extent storage clause.

Action: Respecify the storage clause using the correct syntax and retry the command.

ORA-02242 no options specified for ALTER INDEX

Cause: No options specified.

Action: Specify at least one of REBUILD, INITRANS, MAXTRANS, or STORAGE.

ORA-02243 invalid ALTER INDEX or ALTER MATERIALIZED VIEW option

Cause: An option other than INITRANS, MAXTRANS, or STORAGE is specified in an ALTER INDEX statement or in the USING INDEX clause of an ALTER MATERIALIZED VIEW statement.

Action: Specify only legal options.

ORA-02244 invalid ALTER ROLLBACK SEGMENT option

Cause: The STORAGE option is expected but not found.

Action: Specify the STORAGE option.

ORA-02245 invalid ROLLBACK SEGMENT name

Cause: An identifier was expected, but not found, following ALTER [PUBLIC] ROLLBACK SEGMENT.

Action: Place a rollback segment name following SEGMENT.

ORA-02246 missing EVENTS text

Cause: A character string literal was expected, but not found, following ALTER SESSION SET EVENTS.

Action: Place the string literal containing the events text after EVENTS.

ORA-02247 no option specified for ALTER SESSION

Cause: The option SET EVENTS was expected, but not found, following ALTER SESSION.

Action: Place the SET EVENTS option after ALTER SESSION.

ORA-02248 invalid option for ALTER SESSION

Cause: An option other than SET EVENTS was found following the ALTER SESSION command.

Action: Specify the SET EVENTS option after the ALTER SESSION command and try again.

ORA-02249 missing or invalid value for MAXLOGMEMBERS

Cause: A valid number does not follow MAXLOGMEMBERS. The value specified must be between 1 and the port-specific maximum number of log file members.

Action: Specify a valid number after MAXLOGMEMBERS.

ORA-02250 missing or invalid constraint name

Cause: The constraint name is missing or invalid.

Action: Specify a valid identifier name for the constraint name.

ORA-02251 subquery not allowed here

Cause: Subquery is not allowed here in the statement.

Action: Remove the subquery from the statement.

ORA-02252 check constraint condition not properly ended

Cause: The specified search condition for the check constraint is not properly ended.

Action: End the condition properly.

ORA-02253 constraint specification not allowed here

Cause: Constraint specification is not allowed here in the statement.

Action: Remove the constraint specification from the statement.

ORA-02254 DEFAULT expression not allowed here

Cause: Default value expression is not allowed for the column here in the statement.

Action: Remove the default value expression from the statement.

ORA-02255: NOT NULL not allowed after DEFAULT NULL

Cause: A NOT NULL specification conflicts with the NULL default value.

Action: Remove either the NOT NULL or the DEFAULT NULL specification and try again.

ORA-02256 number of referencing columns must match referenced columns

Cause: The number of columns in the foreign-key referencing list is not equal to the number of columns in the referenced list.

Action: Make sure that the referencing columns match the referenced columns.

ORA-02257 maximum number of columns exceeded

Cause: The number of columns in the key list exceeds the maximum number.

Action: Reduce the number columns in the list.

ORA-02258 duplicate or conflicting NULL and/or NOT NULL specifications

Cause: A duplicate or conflicting NULL and/or NOT NULL was specified.

Action: Remove one of the conflicting specifications and try again.

ORA-02259 duplicate UNIQUE/PRIMARY KEY specifications

Cause: A duplicate unique or primary key was specified.

Action: Remove the duplicate specification and try again.

ORA-02260 table can have only one primary key

Cause: Two or more primary keys were specified for the same table.

Action: Remove the extra primary keys and try again.

ORA-02261 such unique or primary key already exists in the table

Cause: A unique or primary key was specified that already exists for the table.

Action: Remove the extra key and try again.

ORA-02262 ORA-string occurs while type-checking column default value expressionexpression

Cause: New column datatype causes type-checking error for existing column default value expression.

Action: Remove the default value expression or do not alter the column datatype.

ORA-02263 need to specify the datatype for this column

Cause: The required datatype for the column is missing.

Action: Specify the required datatype.

ORA-02264 name already used by an existing constraint

Cause: The specified constraint name has to be unique.

Action: Specify a unique constraint name for the constraint.

ORA-02265 cannot derive the datatype of the referencing column

Cause: The datatype of the referenced column is not defined as yet.

Action: Make sure that the datatype of the referenced column is defined before referencing it.

ORA-02266 unique/primary keys in table referenced by enabled foreign keys

Cause: An attempt was made to drop or truncate a table with unique or primary keys referenced by foreign keys enabled in another table.

Action: Before dropping or truncating the table, disable the foreign key constraints in other tables. You can see what constraints are referencing a table by issuing the following command:

select constraint_name, table_name, statusfrom user_constraintswhere r_constraint_name in (select constraint_name from user_constraints where table_name ='tabnam');

ORA-02267 column type incompatible with referenced column type

Cause: The datatype of the referencing column is incompatible with the datatype of the referenced column.

Action: Select a compatible datatype for the referencing column.

ORA-02268 referenced table does not have a primary key

Cause: The referenced table does not have a primary key.

Action: Specify explicitly the referenced table unique key.

ORA-02269 key column cannot be of LONG datatype

Cause: An attempt was made to define a key column of datatype LONG. This is not allowed.

Action: Change the datatype of the column or remove the LONG column from the key, and try again.

ORA-02270 no matching unique or primary key for this column-list

Cause: An attempt was made to reference a unique or primary key in a table with a CREATE or ALTER TABLE statement when no such key exists in the referenced table.

Action: Add the unique or primary key to the table or find the correct names of the columns with the primary or unique key, and try again.

ORA-02271 table does not have such constraint

Cause: An attempt was made to reference a table using a constraint that does not exist.

Action: Check the spelling of the constraint name or add the constraint to the table, and try again.

ORA-02272 constrained column cannot be of LONG datatype

Cause: A constrained column cannot be defined as datatype LONG. This is not allowed.

Action: Change the datatype of the column or remove the constraint on the column, and try again.

ORA-02273 this unique/primary key is referenced by some foreign keys

Cause: A unique or primary key referenced by foreign keys cannot be dropped.

Action: Remove all references to the key before dropping it.

ORA-02274 duplicate referential constraint specifications

Cause: A referential constraint was specified more than once. This is not allowed.

Action: Remove the duplicate specification.

ORA-02275 such a referential constraint already exists in the table

Cause: An attempt was made to specify a referential constraint that already exists. This would result in duplicate specifications and so is not allowed.

Action: Be sure to specify a constraint only once.

ORA-02276 default value type incompatible with column type

Cause: The type of the evaluated default expression is incompatible with the datatype of the column.

Action: Change the type of the column, or modify the default expression.

ORA-02277 invalid sequence name

Cause: The specified sequence name is not a valid identifier name.

Action: Specify a valid identifier name for the sequence name.

ORA-02278 duplicate or conflicting MAXVALUE/NOMAXVALUE specifications

Cause: Duplicate or conflicting MAXVALUE and/or NOMAXVALUE specifications.

Action: Remove one of the conflicting specifications and try again.

ORA-02279 duplicate or conflicting MINVALUE/NOMINVALUE specifications

Cause: Duplicate or conflicting MINVALUE and/or NOMINVALUE clauses were specified.

Action: Remove one of the conflicting specifications and try again.

ORA-02280 duplicate or conflicting CYCLE/NOCYCLE specifications

Cause: Duplicate or conflicting CYCLE and/or NOCYCLE clauses were specified.

Action: Remove one of the conflicting specifications and try again.

ORA-02281 duplicate or conflicting CACHE/NOCACHE specifications

Cause: Duplicate or conflicting CACHE and/or NOCACHE clauses were specified.

Action: Remove one of the conflicting specifications and try again.

ORA-02282 duplicate or conflicting ORDER/NOORDER specifications

Cause: Duplicate or conflicting ORDER and/or NOORDER clauses were specified.

Action: Remove one of the conflicting specifications and try again.

ORA-02283 cannot alter starting sequence number

Cause: An attempt was made to alter a starting sequence number. This is not allowed.

Action: Do not try to alter a starting sequence number.

ORA-02284 duplicate INCREMENT BY specifications

Cause: A duplicate INCREMENT BY clause was specified.

Action: Remove the duplicate specification and try again.

ORA-02285 duplicate START WITH specifications

Cause: A duplicate START WITH clause was specified.

Action: Remove the duplicate specification and try again.

ORA-02286 no options specified for ALTER SEQUENCE

Cause: No ALTER SEQUENCE option was specified.

Action: Check the syntax. Then specify at least one ALTER SEQUENCE option.

ORA-02287 sequence number not allowed here

Cause: The specified sequence number reference, CURRVAL or NEXTVAL, is inappropriate at this point in the statement.

Action: Check the syntax. Then remove or relocate the sequence number.

ORA-02288 invalid OPEN mode

Cause: A mode other than RESETLOGS was specified in an ALTER DATABASE OPEN statement. RESETLOGS is the only valid OPEN mode.

Action: Remove the invalid mode from the statement or replace it with the keyword RESETLOGS, and try again.

ORA-02289 sequence does not exist

Cause: The specified sequence does not exist, or the user does not have the required privilege to perform this operation.

Action: Make sure the sequence name is correct, and that you have the right to perform the desired operation on this sequence.

ORA-02290 check constraint (string.string) violated

Cause: The value or values attempted to be entered in a field or fields violate a defined check constraint.

Action: Enter values that satisfy the constraint.

ORA-02291 integrity constraint (string.string) violated - parent key not found

Cause: A foreign key value has no matching primary key value.

Action: Delete the foreign key or add a matching primary key.

ORA-02292 integrity constraint (string.string) violated - child record found

Cause: An attempt was made to delete a row that is referenced by a foreign key.

Action: It is necessary to DELETE or UPDATE the foreign key before changing this row.

ORA-02293 cannot validate (string.string) - check constraint violated

Cause: An attempt was made via an ALTERTABLE statement to add a check constraint to a populated table that had no complying values.

Action: Retry the ALTER TABLE statement, specifying a check constraint on a table containing complying values. For more information about ALTER TABLE, see the Oracle9i SQL Reference.

ORA-02294 cannot enable (string.string) - constraint changed during validation

Cause: While one DDL statement was attempting to enable this constraint, another DDL changed this same constraint.

Action: Try again, with only one DDL changing the constraint this time.

ORA-02295 found more than one enable/disable clause for constraint

Cause: An attempt was made via a CREATE or ALTER TABLE statement to specify more than one ENABLE and/or DISABLE clause for a given constraint.

Action: Only one ENABLE or DISABLE clause may be specified for a given constraint.

ORA-02296 cannot enable (string.string) - null values found

Cause: An ALTER TABLE command with an ENABLE CONSTRAINT clause failed because the table contains values that do not satisfy the constraint.

Action: Make sure that all values in the table satisfy the constraint before issuing an ALTER TABLE command with an ENABLE CONSTRAINT clause. For more information about ALTER TABLE and ENABLE CONSTRAINT, see the Oracle9i SQL Reference.

ORA-02297 cannot disable constraint (string.string) - dependencies exist

Cause: An alter table disable constraint failed because the table has foreign keys that are dependent on the constraint.

Action: Either disable the foreign key constraints or use a DISABLE CASCADE command.

ORA-02298 cannot validate (string.string) - parent keys not found

Cause: An ALTER TABLE ENABLE CONSTRAINT command failed because the table has orphaned child records.

Action: Make sure that the table has no orphaned child records before issuing an ALTER TABLE ENABLE CONSTRAINT command. For more information about ALTER TABLE and ENABLE CONSTRAINT, see the Oracle9i SQL Reference.

ORA-02299 cannot validate (string.string) - duplicate keys found

Cause: An ALTER TABLE ENABLE CONSTRAINT command failed because the table has duplicate key values.

Action: Make sure that the table has no duplicate key values before issuing an ALTER TABLE ENABLE CONSTRAINT command. For more information about ALTER TABLE and ENABLE CONSTRAINT, see the Oracle9i SQL Reference.

ORA-02300 invalid value for OIDGENERATORS

Cause: A number was not specified for the value of OIDGENERATORS.

Action: Specify a number for OIDGENERATORS.

ORA-02301 maximum number of OIDGENERATORS is 255

Cause: A number greater than 255 was specified for the value of OIDGENERATORS.

Action: Make sure the number specified for OIDGENERATORS does not exceed 255.

ORA-02302 invalid or missing type name

Cause: An invalid or missing type name was entered in a statement.

Action: Enter a valid type name in the statement and retry the operation.

ORA-02303 cannot drop or replace a type with type or table dependents

Cause: An attempt was made to drop or replace a type that has dependents. There could be a substitutable column of a supertype of the type being dropped.

Action: Drop all types and tables depending on the type, then retry the operation using the VALIDATE option, or use the FORCE option.

ORA-02304 invalid object identifier literal

Cause: An attempt was made to enter an object identifier literal for CREATE TYPE that is either:

  • Not a string of 32 hexadecimal characters
  • An object identifier that already identifies an existing object
  • An object identifier different from the original object identifier already assigned to the type

Action: Do not specify the object identifier clause or specify a 32 hexadecimal-character object identifier literal that is unique or identical to the originally assigned object identifier. Then retry the operation.

ORA-02305 only EXECUTE, DEBUG, and UNDER privileges are valid for types

Cause: An attempt was made to GRANT or REVOKE an invalid privilege (not EXECUTE, DEBUG, or UNDER) on a type.

Action: GRANT or REVOKE only the EXECUTE, DEBUG, or UNDER privilege on types.

ORA-02306 cannot create a type that already has valid dependent(s)

Cause: An attempt was made to create a type that already has some valid dependent(s) (these dependents depend on the fact that the type does not exist).

Action: Drop the dependents first before creating the type, or do not create the type.

ORA-02307 cannot alter with REPLACE option a type that is not valid

Cause: An attempt was made to ALTER with REPLACE option a type that is not valid.

Action: Use the CREATE OR REPLACE TYPE command to modify the type.

ORA-02308 invalid option string for object type column

Cause: An attempt was made to specify an invalid option, such as PACKED or UNPACKED, for the object type column.

Action: Remove the invalid option from column specification and retry the operation.

ORA-02309 atomic NULL violation

Cause: An attempt was made to access the attributes of a NULL object instance.

Action: Ensure that the object instance is non-NULL before accessing.

ORA-02310 exceeded maximum number of allowable columns in table

Cause: The attributes in the object type column exceeded the maximum number of columns allowed in a table.

Action: Specify fewer attributes for the object type and retry the operation.

ORA-02311 cannot alter with COMPILE option a valid type with type or table dependents

Cause: An attempt was made to ALTER with COMPILE option a type that is valid and has type or table dependents.

Action: No need to perform this operation.

ORA-02313 object type contains non-queryable type string attribute

Cause: The specified object type contains a nested attribute whose type is non-queryable.

Action: Use an object type with queryable attribute types.

ORA-02315 incorrect number of arguments for default constructor

Cause: The number of arguments specified for the default constructor does not match the number of attributes of the object type.

Action: Specify the correct number of arguments for the default constructor and retry the operation.

ORA-02320 failure in creating storage table for nested table column string

Cause: An error occurred while creating the storage table for the specified nested table column.

Action: See the messages that follow for more details. If the situation they describe can be corrected, do so; otherwise contact Oracle Support Services.

ORA-02322 failure in accessing storage table of the nested table column

Cause: An error occurred while performing DML on the storage table of the nested table column.

Action: If the situation described in the following messages can be corrected, do so; otherwise contact Oracle Support Services.

ORA-02324 more than one column in the SELECT list of THE subquery

Cause: More than one column was selected in the THE subquery.

Action: Specify only one column in the SELECT list of the THE subquery and retry the operation.

ORA-02327 cannot create index on expression with datatype string

Cause: An attempt was made to create an index on a non-indexable expression.

Action: Change the column datatype or do not create the index on an expression whose datatype is one of VARRAY, nested table, object, LOB, or REF.

ORA-02329 column of datatype string cannot be unique or a primary key

Cause: An attempt was made to place a UNIQUE or a PRIMARY KEY constraint on a column of datatype VARRAY, nested table, object, LOB, FILE or REF.

Action: Change the column datatype or remove the constraint. Then retry the operation.

ORA-02330 datatype specification not allowed

Cause: An attempt was made to specify the data type in the column constraint specification of an object table.

Action: Remove data type specification and retry the operation.

ORA-02331 cannot create constraint on column of datatype string

Cause: An attempt was made to create a constraint on a column possessing a non-constrainable datatype: VARRAY, nested table, object, LOB, FILE, or REF.

Action: Change the column datatype, or remove the constraint.

ORA-02332 cannot create index on attributes of this column

Cause: An attempt was made to create an index on an attributes of an object type column.

Action: Do not specify the index on the attribute.

ORA-02333 cannot create constraints on attributes of this column

Cause: An attempt was made to create a constraint on an attribute of an object type column.

Action: Remove the constraint or change the object type.

ORA-02334 cannot infer type for column

Cause: A datatype was not declared for this column (in the CREATE TABLE) and an attempt was made to create a constraint on an attribute of this column.

Action: Declare a datatype for the column.

ORA-02335 invalid datatype for cluster column

Cause: An attempt was made to declare a CLUSTER column of datatype object, REF, nested table, VARRAY, LOB, or FILE.

Action: Remove the CLUSTER column or change the datatype of the column.

ORA-02336 column attribute cannot be accessed

Cause: An attempt was made to extract an attribute of an object type column.

Action: Change the object type for the column and retry the operation.

ORA-02337 not an object type column

Cause: An attempt was made to use dotted notation on a non-ADT column; that is, "a.b.c" where "a" is not an object type.

Action: Either change the column type to an object type or do not perform this operation.

ORA-02338 missing or invalid column constraint specification

Cause: A column constraint was not specified.

Action: Remove the column specification or specify a column constraint. Then retry the operation.

ORA-02339 invalid column specification

Cause: An attempt was made to specify the PACKED or UNPACKED keyword for a non-object type column.

Action: Remove the PACKED or UNPACKED keyword in the column specification and retry the operation.

ORA-02340 invalid column specification

Cause: An attempt was made to specify an UNPACKED column within a packed table.

Action: Remove the UNPACKED keyword in the column specification.

ORA-02342 replacement type has compilation errors

Cause: The use of the ALTER...REPLACE statement on a valid type caused a compilation error.

Action: Use the ALTER...REPLACE statement to replace the type with a valid type which does not cause compilation errors.

ORA-02344 cannot revoke execute on a type with table dependents

Cause: An attempt was made to revoke execute on a type that has dependents.

Action: Drop all table(s) depending on the type, then retry the operation, or use the FORCE option.

ORA-02345 cannot create a view with column based on CURSOR operator

Cause: A CURSOR operator was used as one of the SELECT elements in the subquery of a CREATE VIEW or CREATE TABLE ... AS SELECT statement.

Action: Remove the CURSOR operator and replace it with the CAST operator.

ORA-02347 cannot grant privileges on columns of an object table

Cause: An attempt was made to grant privileges on the columns of an object table.

Action: Choose another table. Privileges cannot be granted on columns of an object table.

ORA-02348 cannot create VARRAY column with embedded LOB

Cause: An attempt was made to create a column of a VARRAY type which has an embedded LOB attribute. The LOB could be an attribute of a subtype of the declared type of VARRAY's element.

Action: Remove the offending attribute from the type. If it is a subtype attribute then declare the VARRAY column NOT SUBSTITUTABLE.

ORA-02349 invalid user-defined type - type is incomplete

Cause: An attempt was made to use an incomplete type definition as a column or table datatype.

Action: Complete the type definition and retry the operation.

ORA-02351 Record string: Rejected - Error on table string, column string

Cause: The record indicated caused an Oracle error on insert.

Action: Determine the Oracle error and correct the record.

ORA-02352 Direct path connection must be homogeneous

Cause: The user-side to kernel-side connection is heterogeneous.

Action: In versions prior to 9.0.0, the connection must be between identical hardware and operating systems. In addition, the SQL*Loader and RDBMS versions must be the same.

ORA-02353 Multibyte character error

Cause: Text specified by POSITION or terminated by newlines is invalid.

Action: Edit the control file or the datafile to fix alignment of column.

ORA-02354 Conversion initialization error occurred on field string

Cause: An error occurred during conversion initialization for a field. This is an internal error.

Action: Contact Oracle Support Services.

ORA-02355 Conversion error occurred on CONSTANT field string

Cause: A CONSTANT field caused an Oracle error; all rows will be rejected.

Action: Determine the Oracle error and correct the record.

ORA-02356 The database is out of space. The load cannot continue

Cause: The load was discontinued due to space exhaustion in the database.

Action: Add space for the specified table.

ORA-02357 Packed Decimal conversion error

Cause: The column could not be converted from packed decimal to character.

Action: Check the column and make it conform to packed decimal format.

ORA-02358 Zoned Decimal conversion error

Cause: The column could not be converted from packed decimal to character.

Action: Check the column and make it conform to packed decimal format.

ORA-02359 Field in data file exceeded maximum specified length

Cause: The field is too long for the specified column.

Action: Shorten the field so that its length is less than or equal to the column length.

ORA-02360 Column not found before end of logical record (use TRAILING NULLCOLS)

Cause: A column started after the end of the logical record had been reached.

Action: Use the TRAILING NULLCOLS option or supply data for the column.

ORA-02361 Initial enclosing character not found

Cause: The initial enclosing character of an enclosed field was not found.

Action: Supply the character before the start of the field.

ORA-02362 Logical record ended - second enclosing character not present

Cause: The second enclosing character of an enclosed field was not found.

Action: Supply the character after the end of the field.

ORA-02363 No terminator found after TERMINATED and ENCLOSED field

Cause: No terminator was found after a terminated and enclosed field.

Action: Supply the character after the end of the field.

ORA-02364 Record string: Discarded - failed all WHEN clauses

Cause: The record was not loaded because it failed the WHEN clauses of all the tables.

Action: No action required.

ORA-02365 Index string was made Index Unusable due to

Cause: The index was not loaded. The cause of the error is stated after the message.

Action: Correct the cause of the error, then reload.

ORA-02366 The following index(es) on table string were processed:

Cause: The indexes listed for the named table were loaded.

Action: No action required.

ORA-02367 Index string was loaded.

Cause: The index specified in the message was loaded.

Action: No action required.

ORA-02368 Record string: Discarded - all columns null.

Cause: The record was not loaded because all of the columns in the table were null for that record.

Action: No action required.

ORA-02369 Warning: Variable length field was truncated.

Cause: A variable length field was truncated by the end of the logical record.

Action: This is just a warning, but since a variable length field has the length embedded in the data for each row, you may want to check your data.

ORA-02370 Record string - Warning on table string, column string

Cause: The record indicated caused an warning.

Action: Determine the warning and correct the record if necessary.

ORA-02371 Loader must be at least version string.string.string.string.string for direct path

Cause: The loader being used is incompatible with this version of the kernel.

Action: Upgrade your loader to at least the specified version or use the conventional path.

ORA-02372 Relative start position > absolute field end position.

Cause: A field specified as POSITION(*+n:y) had its relative start occur after the absolute position y.

Action: Check that you are not missing a delimiter and that the values of n and y are correct.

ORA-02373 Error parsing insert statement for table string.

Cause: A parsing error occurred.

Action: Check the message following this parsing error message.

ORA-02374 No more slots for read buffer queue.

Cause: There are no free read buffers.

Action: Use the READBUFFERS keyword in the loader to increase the number of read buffers.

ORA-02375 Record string: Rejected - Error on table string

Cause: The record indicated caused an Oracle error on insert.

Action: Determine the Oracle error and correct the record. The offending column(s) are not known.

ORA-02376 invalid or redundant resource

Cause: A resource that is not defined or that is specified twice appears in the CREATE or ALTER PROFILE statement.

Action: Define the resource before issuing a CREATE or ALTER PROFILE command. Also check the statement to see that each resource is listed only once.

ORA-02377 invalid resource limit

Cause: An invalid resource limit of 0 was specified.

Action: Specify a resource limit greater than 0.

ORA-02378 duplicate resource name string

Cause: The same resource was specified twice in a CREATE or ALTER PROFILE statement.

Action: Issue the statement again, carefully checking that each resource is used only once.

ORA-02379 profile string already exists

Cause: An attempt was made to create a profile that already exists.

Action: Create the profile with a name not already used by another profile.

ORA-02380 profile string does not exist

Cause: An attempt was made to assign a user to a non-existent profile.

Action: Assign the user to an existing profile.

ORA-02381 cannot drop PUBLIC_DEFAULT profile

Cause: An attempt was made to drop the PUBLIC_DEFAULT profile.

Action: The PUBLIC_DEFAULT profile cannot be dropped.

ORA-02382 profile string has users assigned, cannot drop without CASCADE

Cause: An attempt was made to drop a profile that had users assigned to it without using the CASCADE option of the DROP PROFILE statement. A profile that has users assigned to it cannot be dropped, unless the CASCADE option is specified. CASCADE reassigns users to the PUBLIC_DEFAULT profile before dropping the profile.

Action: To reassign all users to the PUBLIC_DEFAULT profile, issue the DROP PROFILE statement with the CASCADE option.

ORA-02383 illegal cost factor

Cause: A negative value or UNLIMITED cost was specified for this resource in the ALTER RESOURCE COST statement.

Action: Only positive integer values can be specified for resources in the ALTER RESOURCE COST statement. Issue the statement again, using a positive integer value for each resource specified.

ORA-02390 exceeded COMPOSITE_LIMIT, you are being logged off

Cause: The COMPOSITE_LIMIT for the profile is exceeded. That is, the weighted sum of the connection time, logical reads per session, CPU usage per session, and private SGA space used during the session exceeded the limit set by the COMPOSITE_LIMIT clause set in the user profile.

Action: If this happens often, ask the database administrator to raise the COMPOSITE_LIMIT of the user profile, or determine which resource is used the most and raise the limit on that resource.

ORA-02391 exceeded simultaneous SESSIONS_PER_USER limit

Cause: An attempt was made to exceed the maximum number of concurrent sessions allowed by the SESSIONS_PER_USER clause of the user profile.

Action: End one or more concurrent sessions or ask the database administrator to increase the SESSIONS_PER_USER limit of the user profile. For more information about SESSIONS_PER_USER and the database administrator's specific tasks of adjusting concurrent sessions, see the Oracle9i SQL Reference and the Oracle9i Database Administrator's Guide.

ORA-02392 exceeded session limit on CPU usage, you are being logged off

Cause: An attempt was made to exceed the maximum CPU usage allowed by the CPU_PER_SESSION clause of the user profile.

Action: If this happens often, ask the database administrator to increase the CPU_PER_SESSION limit of the user profile.

ORA-02393 exceeded call limit on CPU usage

Cause: An attempt was made to exceed the maximum CPU time for a call, a parse, execute, or fetch, allowed by the CPU_PER_CALL clause of the user profile.

Action: If this happens often, ask the database administrator to increase the CPU_PER_CALL limit of the user profile.

ORA-02394 exceeded session limit on IO usage, you are being logged off

Cause: An attempt was made to exceed the maximum I/O allowed by the LOGICAL_READS_PER_SESSION clause of the user profile.

Action: If this happens often, ask the database administrator to increase the LOGICAL_READS_PER_SESSION limit of the user profile.

ORA-02395 exceeded call limit on IO usage

Cause: An attempt was made to exceed the maximum I/O for a call, a parse, execute, or fetch, allowed by the LOGICAL_READS_PER_CALL clause of the user profile.

Action: If this happens often, ask the database administrator to increase the LOGICAL_READS_PER_CALL limit of the user profile.

ORA-02396 exceeded maximum idle time, please connect again

Cause: A user has exceeded the maximum time allowed to remain idle.

Action: The user must reconnect to the database.

ORA-02397 exceeded PRIVATE_SGA limit, you are being logged off

Cause: This error occurs only when using a multi-threaded server.

Action: Contact the database administrator to expand the PRIVATE_SGA limit.

ORA-02398 exceeded procedure space usage

Cause: Stored procedures used up too much space in the SYSTEM tablespace.

Action: Use fewer stored procedures or add an additional file to the system tablespace.

ORA-02399 exceeded maximum connect time, you are being logged off

Cause: A user has exceeded the maximum time allowed to be connected to the database.

Action: The user must reconnect to the database.

ORA-02401 cannot EXPLAIN view owned by another user

Cause: The view specified in the SQL statement belongs to another user and cannot be explained.

Action: Create a view with the same definition that belongs to current user.

ORA-02402 PLAN_TABLE not found

Cause: The table used by EXPLAIN to store row source information does not exist in the current schema.

Action: Create a plan table in the current schema or use the INTO clause of the statement to put the results of the explain command in an existing plan table.

ORA-02403 plan table does not have correct format

Cause: The explicit plan table does not have the appropriate field definitions.

Action: Redefine the plan table to have the appropriate field definitions.

ORA-02404 specified plan table not found

Cause: The specified plan table does cannot be found.

Action: Create the specified plan table or use an existing plan table.

ORA-02420 missing schema authorization clause

Cause: The AUTHORIZATION clause is missing from a create schema statement.

Action: Proceed the schema authorization identifier with the AUTHORIZATION keyword.

ORA-02421 missing or invalid schema authorization identifier

Cause: One of the following:

  • The schema authorization identifier is not recognized.
  • An attempt was made to use a schema authorization identifier for a user while not connected as that user.

Action: If the cause is

  • an unrecognized identifier, then use an existing identifier.
  • connected with a different user name, then disconnect and connect to the correct user name.

ORA-02422 missing or invalid schema element

Cause: A statement other than a CREATE TABLE, CREATE VIEW, or GRANT appears in a CREATE SCHEMA statement.

Action: See the Oracle9i SQL Reference or the valid elements of the CREATE SCHEMA statement.

ORA-02423 schema name does not match schema authorization identifier

Cause: A table definition with a schema name prepended to the table name does not match the schema name provided in the AUTHORIZATION clause of a CREATE SCHEMA STATEMENT.

Action: Check that the schema names match the one given in the CREATE SCHEMA statement.

ORA-02424 potential circular view references or unknown referenced tables

Cause: The CREATE SCHEMA statement contains a view that depends on other views contained in the CREATE SCHEMA statement, or they contain references to non-existing tables.

Action: Create the dependent views in a separate CREATE SCHEMA statement and ensure that all referenced tables are either defined in the CREATE SCHEMA statement or exist outside the statement.

ORA-02425 create table failed

Cause: A CREATE TABLE statement failed in the CREATE SCHEMA statement.

Action: The cause for failure will be presented below this message. Follow the appropriate actions as suggested by the subsequent messages.

ORA-02426 privilege grant failed

Cause: A GRANT statement failed in the CREATE SCHEMA statement.

Action: The cause for failure will be presented below this message. Follow appropriate actions, as suggested by the subsequent messages.

ORA-02427 create view failed

Cause: A CREATE VIEW statement failed in the CREATE SCHEMA statement.

Action: The cause for failure will be presented below this message. Follow appropriate actions, as suggested by the subsequent messages.

ORA-02428 could not add foreign key reference

Cause: Oracle could not add a foreign key reference because of an error in the declaration. Either the referenced table does not exist or the table does not have a unique key.

Action: Check that the referenced table exists and/or has a unique key.

ORA-02429 cannot drop index used for enforcement of unique/primary key

Cause: An attempt was made to drop an index that is being used as the enforcement mechanism for a unique or primary key.

Action: Drop the integrity constraint instead of dropping the index.

ORA-02430 cannot enable constraint (string) - no such constraint

Cause: The named constraint does not exist for this table.

Action: Check that a constraint exists before trying to enable it.

ORA-02431 cannot disable constraint (string) - no such constraint

Cause: The named constraint does not exist for this table.

Action: Check that a constraint exists before trying to disable it.

ORA-02432 cannot enable primary key - primary key not defined for table

Cause: An attempt was made to enable a primary key that is not defined for the table.

Action: Add a primary key definition for the table.

ORA-02433 cannot disable primary key - primary key not defined for table

Cause: An attempt was made to disable a primary key that is not defined for the table.

Action: Check that a primary key exists before trying to disable it.

ORA-02434 cannot enable unique(string) - unique key not defined for table

Cause: An attempt was made to enable a unique key that is not defined for the table.

Action: Check that a unique key exists before trying to enable it.

ORA-02435 cannot disable unique(string) - unique key not defined for table

Cause: An attempt was made to disable a unique key that is not defined for the table.

Action: Check that a unique key exists before trying to disable it.

ORA-02436 date or system variable wrongly specified in CHECK constraint

Cause: An attempt was made to use a date constant or system variable, such as USER, in a check constraint that was not completely specified in a CREATE TABLE or ALTER TABLE statement. For example, a date was specified without the century.

Action: Completely specify the date constant or system variable.

ORA-02437 cannot validate (string.string) - primary key violated

Cause: An attempt was made to validate a primary key with duplicate values or null values.

Action: Remove the duplicates and null values before enabling a primary key.

ORA-02438 Column check constraint cannot reference other columns

Cause: An attempt was made to define a column check constraint that references another column.

Action: Define it as a table check constraint.

ORA-02439 Unique index on a deferrable constraint is not allowed

Cause: An attempt was made to enable a deferrable primary key/unique constraint that has an existing unique index on the constraint columns.

Action: Drop the index on the constraint columns or make the constraint not deferrable.

ORA-02440 Create as select with referential constraints not allowed

Cause: Integrity constraints on a table cannot be created when creating the table using the CREATE TABLE... AS SELECT... form.

Action: First, create the table, and then alter the table to add the desired integrity constraints.

ORA-02441 Cannot drop nonexistent primary key

Cause: An attempt was made to drop the primary key constraint on a table, but there is no primary key constraint on this table.

Action: Ensure the correct table name is entered in the statement. Otherwise, no action required.

ORA-02442 Cannot drop nonexistent unique key

Cause: An attempt was made to drop a unique key constraint for a column that does not have a unique key constraint.

Action: Make certain the correct column name was entered. Otherwise, no action required.

ORA-02443 Cannot drop constraint - nonexistent constraint

Cause: An attempt was made to drop a constraint that does not exist.

Action: Make certain the constraint and table name are correct and attempt the procedure again.

ORA-02444 Cannot resolve referenced object in referential constraints

Cause: An attempt was made to define a foreign key with a reference to a schema object that cannot be resolved to a base table reference.

Action: Define referential constraints only with schema objects resolving to a base table.

ORA-02445 Exceptions table not found

Cause: The explicitly or implicitly declared exceptions table does not exist.

Action: If the correct exceptions table name was used, then create the table and retry the enable command.

ORA-02446 CREATE TABLE ... AS SELECT failed - check constraint violated

Cause: An attempt was made to use a CREATE TABLE ... AS SELECT statement when some rows violated one or more CHECK constraints.

Action: Do not select rows that violate constraints.

ORA-02447 cannot defer a constraint that is not deferrable

Cause: An attempt was made to defer a nondeferrable constraint.

Action: Drop the constraint and create a new one that is deferrable.

ORA-02448 constraint does not exist

Cause: The named constraint does not exist.

Action: Choose a constraint that does exist or do not perform this operation.

ORA-02449 unique/primary keys in table referenced by foreign keys

Cause: An attempt was made to drop a table with unique or primary keys referenced by foreign keys in another table.

Action: Before performing the above operations the table, drop the foreign key constraints in other tables. You can see what constraints are referencing a table by issuing the following command:

SELECT * FROM USER_CONSTRAINTS WHERE TABLE_NAME = "tabnam";

ORA-02450 Invalid hash option - missing keyword IS

Cause: Missing IS keyword.

Action: Specify HASH IS option.

ORA-02451 duplicate HASHKEYS specification

Cause: The HASHKEYS option is specified more than once.

Action: Only specify the HASHKEYS option once.

ORA-02452 invalid HASHKEYS option value

Cause: The specified HASHKEYS option must be an integer value.

Action: Specify an appropriate value.

ORA-02453 duplicate HASH IS specification

Cause: The HASH IS option is specified more than once.

Action: only specify the HASH IS option once.

ORA-02454 Number of hash keys per block (string) exceeds maximum of string

Cause: The SIZE argument is too small.

Action: Increase the SIZE argument.

ORA-02455 The number of cluster key column must be 1

Cause: When specifying the HASH IS option, the number of key columns must be 1.

Action: Either do not specify the HASH IS option or reduce the number of key columns.

ORA-02456 The HASH IS column specification must be NUMBER(*,0)

Cause: The column specification must specify an integer.

Action: Specify the column definition as type NUMBER(precision, 0).

ORA-02457 The HASH IS option must specify a valid column

Cause: The HASH IS column name is not specified in the cluster definition.

Action: Specify a valid column name.

ORA-02458 HASHKEYS must be specified for a HASH CLUSTER

Cause: The HASHKEYS option must be specified when creating a HASH CLUSTER.

Action: Specify the HASHKEYS option.

ORA-02459 Hashkey value must be a positive integer

Cause: The value of the hash key was not a positive number.

Action: Specify a positive integer.

ORA-02460 Inappropriate index operation on a hash cluster

Cause: An attempt to create a cluster index was issued on a hash cluster.

Action: Do not attempt to create such an index.

ORA-02461 Inappropriate use of the INDEX option

Cause: This option is only valid for non hash clusters.

Action: Do not specify this option.

ORA-02462 Duplicate INDEX option specified

Cause: The INDEX option is specified more than once.

Action: Only specify the INDEX option once.

ORA-02463 Duplicate HASH IS option specified

Cause: The HASH IS option is specified more than once.

Action: Only specify the HASH IS option once.

ORA-02464 Cluster definition can not be both HASH and INDEX

Cause: The cluster can either be a hash or indexed cluster, not both.

Action: Remove either the HASH IS or INDEX options.

ORA-02465 Inappropriate use of the HASH IS option

Cause: This option is only valid for clusters.

Action: Do not specify this option.

ORA-02466 The SIZE option is not allow to be altered for HASH CLUSTERS

Cause: The SIZE cannot be changed once the hash cluster has been created.

Action: Do not specify this option.

ORA-02467 Column referenced in expression not found in cluster definition

Cause: A column in the hash is expression was not present in cluster definition.

Action: Re-create the cluster and correct the error in hash expression.

ORA-02468 Constant or system variable wrongly specified in expression

Cause: A constant or system variable was specified in the hash expression.

Action: Re-create the cluster and correct the error in hash expression.

ORA-02469 Hash expression does not return an Oracle Number.

Cause: Result of evaluating hash expression is not an Oracle Number.

Action: Re-create the cluster and correct the error in hash expression.

ORA-02470 TO_DATE, USERENV, or SYSDATE incorrectly used in hash expression.

Cause: TO_DATE, USERENV and SYSDATE are not allowed in hash expressions.

Action: Re-create the cluster and correct the error in hash expression.

ORA-02471 SYSDATE, UID, USER, ROWNUM, or LEVEL incorrectly used in hash expression.

Cause: SYSDATE, UID, USER, ROWNUM, or LEVEL are not allowed in hash expressions.

Action: Re-create the cluster and remove the offending keywords.

ORA-02472 PL/SQL functions not allowed in hash expressions

Cause: A PL/SQL function was used in the hash expression.

Action: Re-create the cluster and remove the PL/SQL function.

ORA-02473 Error while evaluating the cluster's hash expression.

Cause: An error occurred while evaluating the clusters hash expression.

Action: Correct the query and retry.

ORA-02474 Fixed hash area extents used (string) exceeds maximum allowed (string)

Cause: The number of extents required for creating the fixed hash area exceeds the maximum number allowed.

Action: Reduce the number of extents required by increasing the extent allocation sizes within the STORAGE clause.

ORA-02475 maximum cluster chain block count of string has been exceeded

Cause: The number of blocks in a cluster chain exceeds the maximum number allowed.

Action: Increase SIZE parameter in CREATE CLUSTER statement or reconsider suitability of cluster key.

ORA-02476 can not create index due to parallel direct load on table

Cause: A parallel direct load is occurring to the specified table.

Action: Retry statement after load is complete.

ORA-02477 can not perform parallel direct load on object string

Cause: A parallel direct load is not possible because an index is being created on the table.

Action: Retry load after index creation is complete.

ORA-02478 merge into base segment would overflow MAXEXTENTS limit

Cause: Merge of temporary segment into base segment failed because MAXEXTENTS was larger than the total in the temporary and base segments.

Action: Use a larger value for MAXEXTENTS on the base segment or make the extents in the temporary segments larger.

ORA-02479 error while translating file name for parallel load

Cause: An invalid file name was specified to load data into.

Action: Specify a valid database file.

ORA-02481 Too many processes specified for events (max string)

Cause: Too many processes specified than allowed per event.

Action: Enter fewer processes by using ranges or wildcards if possible.

ORA-02482 Syntax error in event specification (string)

Cause: Illegal event string.

Action: Enter a legal event string.

ORA-02483 Syntax error in process specification (string)

Cause: Illegal process string.

Action: Enter a legal process string.

ORA-02486 Error in writing trace file string

Cause: Error occurred in creating/writing the file.

Action: Check the file name and make sure it is constructed properly. Also, check permissions for directories.

ORA-02490 missing required file size in RESIZE clause

Cause: No value was specified for the RESIZE clause.

Action: Use the correct syntax.

ORA-02491 missing required keyword ON or OFF in AUTOEXTEND clause

Cause: The keyword ON or OFF was not specified for the AUTOEXTEND clause.

Action: Use the correct syntax.

ORA-02492 missing required file block increment size in NEXT clause

Cause: No value was specified for the NEXT clause.

Action: Use the correct syntax.

ORA-02493 invalid file increment size in NEXT clause

Cause: A non-integer value was used for the NEXT clause of the DATAFILE list.

Action: Use the correct syntax.

ORA-02494 invalid or missing maximum file size in MAXSIZE clause

Cause: UNLIMITED was not specified, or an invalid integer value was specified, for the MAXSIZE clause in the DATAFILE file list. The MAXSIZE value cannot be smaller than the SIZE value.

Action: Use the correct syntax.

ORA-02495 cannot resize file string, tablespace string is read only

Cause: An attempt was made to resize a datafile in a tablespace that is read only.

Action: Change the tablespace to read/write and retry the resize operation.

ORA-02700 osnoraenv: error translating ORACLE_SID

Cause: Two-task driver could not find the value of ORACLE_SID in the environment.

Action: Make sure that the ORACLE_SID environment variable has been properly set and exported.

ORA-02701 osnoraenv: error translating oracle image name

Cause: ORACLE_HOME environment variable not set.

Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported.

ORA-02702 osnoraenv: error translating orapop image name

Cause: ORACLE_HOME environment variable not set.

Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported.

ORA-02703 osnpopipe: pipe creation failed

Cause: The pipe driver failed to create pipes for communications with the ORAPOP process.

Action: You have probably exceeded the maximum number of open file descriptors per user or the system file table is full. Note the operating system error code and contact your system administrator.

ORA-02704 osndopop: fork failed

Cause: The two-task driver could not fork ORAPOP.

Action: Verify that there are enough system resources to support another process. The user or system process limit may have been exceeded, or the amount of free memory or swap space may be temporarily insufficient.

ORA-02705 osnpol: polling of communication channel failed

Cause: The pipe driver failed while polling the communications channel.

Action: Contact Oracle Support Services.

ORA-02706 osnshs: host name too long

Cause: The length of your host-string specified by the TWO_TASK environment variable exceeds the Oracle system-imposed limit.

Action: Contact Oracle Support Services.

ORA-02707 osnacx: cannot allocate context area

Cause: The invoked UNIX two-task driver could not allocate heap space for the context area.

Action: Contact Oracle Support Services.

ORA-02708 osnrntab: connect to host failed, unknown ORACLE_SID

Cause: The invoked UNIX two-task driver failed to find an entry in ORATAB for the SID you supplied.

Action: First, check whether you have read access to ORATAB, and see if the desired sid is there. Add an entry to ORATAB for the desired SID, if necessary.

ORA-02709 osnpop: pipe creation failed

Cause: The pipe driver failed to create pipes for two-task communications with the Oracle shadow process.

Action: You have probably exceeded the maximum number of open file descriptors per user or the system file table is full. Note the operating system error code and contact your system administrator.

ORA-02710 osnpop: fork failed

Cause: The pipe driver could not fork the Oracle shadow process.

Action: Verify that there are enough system resources to support another process. The user or system process limit may have been exceeded, or the amount of free memory or swap space may be temporarily insufficient.

ORA-02711 osnpvalid: write to validation channel failed

Cause: The pipe driver failed to write to the ORAPOP process.

Action: Contact Oracle Support Services.

ORA-02712 osnpop: malloc failed

Cause: The pipe driver failed to allocate enough heap space for its context area buffers.

Action: Contact Oracle Support Services.

ORA-02713 osnprd: message receive failure

Cause: The pipe driver failed to read a message from the communications channel.

Action: Contact Oracle Support Services.

ORA-02714 osnpwr: message send failure

Cause: The pipe driver failed to write a message to the communications channel.

Action: Contact Oracle Support Services.

ORA-02715 osnpgetbrkmsg: message from host had incorrect message type

Cause: The pipe driver received a message having an unrecognizable message type.

Action: Contact Oracle Support Services.

ORA-02716 osnpgetdatmsg: message from host had incorrect message type

Cause: The Pipe driver received a message having an unrecognizable message type.

Action: Contact Oracle Support Services.

ORA-02717 osnpfs: incorrect number of bytes written

Cause: The Pipe driver sent a message that was apparently successful, but the number of bytes transmitted did not match the number of bytes furnished to the driver.

Action: Contact Oracle Support Services.

ORA-02718 osnprs: reset protocol error

Cause: The two-task driver could not reset the connection.

Action: Contact Oracle Support Services.

ORA-02719 osnfop: fork failed

Cause: The fast driver could not fork the Oracle shadow process.

Action: Verify that there are enough system resources to support another process. The user or system process limit may have been exceeded, or the amount of free memory or swap space may be temporarily insufficient.

ORA-02720 osnfop: shmat failed

Cause: When the fast driver was invoked, processes failed to attach to the shared memory buffer. You probably supplied an illegal shared memory attach address, or the system ran out of data space to accommodate the buffer.

Action: Try invoking the Fast driver later, or use the default attach address.

ORA-02721 osnseminit: cannot create semaphore set

Cause: The Fast driver failed to get a semaphore set.

Action: The system-imposed limit on semaphores or semaphore identifiers may have been exceeded. Read the returned operating system error code and check with your system administrator.

ORA-02722 osnpui: cannot send break message to orapop

Cause: The Pipe driver could not send a break message to ORAPOP.

Action: Contact Oracle Support Services.

ORA-02723 osnpui: cannot send break signal

Cause: The Pipe driver could not send a break message to the Oracle shadow process.

Action: Contact Oracle Support Services.

ORA-02724 osnpbr: cannot send break message to orapop

Cause: The Pipe driver could not send a break message to ORAPOP.

Action: Contact Oracle Support Services.

ORA-02725 osnpbr: cannot send break signal

Cause: The Pipe driver could not send a break message to the Oracle shadow process.

Action: Kill system call failed. Check the error code (errno) and contact Oracle Support Services.

ORA-02726 osnpop: access error on oracle executable

Cause: The Pipe driver could not access the Oracle executable.

Action: Check the permissions on the Oracle executable and each component of the ORACLE_HOME/bin path.

ORA-02727 osnpop: access error on orapop executable

Cause: The Pipe driver could not access the ORAPOP executable.

Action: Check the permissions on the ORAPOP executable and each component of the ORACLE_HOME/bin path.

ORA-02728 osnfop: access error on oracle executable

Cause: The Fast driver could not access the Oracle executable.

Action: Check the permissions on the Oracle executable and each component of the ORACLE_HOME/bin path.

ORA-02729 osncon: driver not in osntab

Cause: The driver you have specified is not supported.

Action: Check with your database administrator which drivers are supported.

ORA-02730 osnrnf: cannot find user logon directory

Cause: The driver you have specified could not find your logon directory while searching for your local .SQLNET file.

Action: Set and export the HOME environment variable to identify your home directory. Check with your system administrator to make sure that your UID and home directory are correct in the /etc/passwd file.

ORA-02731 osnrnf: malloc of buffer failed

Cause: The specified driver could not find enough heap space to MALLOC a buffer.

Action: Contact Oracle Support Services.

ORA-02732 osnrnf: cannot find a matching database alias

Cause: Database alias specified was not identified in either $HOME/.sqlnet or /etc/sqlnet.

Action: Create the alias in a file called .sqlnet in the home directory for personal use, or have system administrator create the alias in /etc/sqlnet for system-wide use.

ORA-02733 osnsnf: database string too long

Cause: While converting a database alias to a database ID, the resulting database ID string exceeded the Oracle system-imposed limit.

Action: Contact Oracle Support Services.

ORA-02734 osnftt: cannot reset shared memory permission

Cause: The Fast driver was unable to reset shared memory permissions.

Action: Contact Oracle Support Services.

ORA-02735 osnfpm: cannot create shared memory segment

Cause: The Fast driver failed to create a shared memory segment for two-task communication.

Action: Check whether the system-imposed limit on shared memory identifiers has already been reached for your system.

ORA-02736 osnfpm: illegal default shared memory address

Cause: The Fast driver failed to establish a default shared memory address.

Action: Contact Oracle Support Services.

ORA-02737 osnpcl: cannot tell orapop to exit

Cause: The Pipe driver failed to send ORAPOP the command to exit.

Action: Contact Oracle Support Services.

ORA-02738 osnpwrtbrkmsg: incorrect number of bytes written

Cause: The pipe driver apparently sent an incomplete break message.

Action: Contact Oracle Support Services.

ORA-02739 osncon: host alias is too long

Cause: The alias used for a SQLNET host is longer than 161 characters.

Action: Use a shorter alias.

ORA-02750 osnfsmmap: cannot open shared memory file ?/dbs/ftt_pid.dbf

Cause: The Fast driver failed to create a shared memory file for two-task communication.

Action: Check the permissions on the directory ?/dbs.

ORA-02751 osnfsmmap: cannot map shared memory file

Cause: The Fast driver failed to map a shared memory file for two-task communication.

Action: Contact Oracle Support Services.

ORA-02752 osnfsmmap: illegal shared memory address

Cause: The Fast driver failed to attach shared memory at the expected location.

Action: Contact Oracle Support Services.

ORA-02753 osnfsmmap: cannot close shared memory file

Cause: The Fast driver cannot close the shared memory file.

Action: Contact Oracle Support Services.

ORA-02754 osnfsmmap: cannot change shared memory inheritence

Cause: The Fast driver could not alter the inheritance attributes of the shared memory.

Action: Contact Oracle Support Services.

ORA-02755 osnfsmcre: cannot create chared memory file ?/dbs/ftt_pid.dbf

Cause: The Fast driver failed to create a file for shared memory.

Action: Check the permissions on the directory ?/dbs.

ORA-02756 osnfsmnam: name translation failure

Cause: The Fast driver encountered an error translating the shared memory file name ?/dbs/ftt_pid.dbf.

Action: Contact Oracle Support Services.

ORA-02757 osnfop: fork_and_bind failed

Cause: The Fast driver failed to fork a process onto the desired cluster and node number.

Action: Check the desired node number in sercose[0] and cluster ID in sercose[1]. If these seem valid, contact Oracle Support Services.

ORA-02758 Allocation of internal array failed

Cause: The package was unable to allocate memory for an array because the system ran out of memory.

Action: Either reclaim memory by killing other processes or restart the machine with more memory.

ORA-02759 Not enough request descriptors available

Cause: All of the package's request descriptors are in use performing other requests.

Action: Either wait until enough requests are done, or shut the package down and re-initialize it with more request descriptors.

ORA-02760 Client close of file failed.

Cause: The client was unable to close a file after forking the servers.

Action: This is a system problem; contact your System Administrator.

ORA-02761 File number to be canceled is negative.

Cause: The file number contained with the SFIOV structure is less than zero.

Action: This may be a programming error. If it is not, contact Oracle Support Services.

ORA-02762 file number to be cancelled is greater than the maximum.

Cause: The file number contained with the SFIOV structure is greater than the maximum.

Action: This may be a programming error. If it is not, contact Oracle Support Services.

ORA-02763 Unable to cancel at least one request

Cause: No requests were found that could be cancelled.

Action: This error can occur if all the requests dealing with that file number have already been filled.

ORA-02764 Invalid package mode

Cause: The mode of the package can only be parallel or duplex.

Action: See SFA.H for the correct values.

ORA-02765 Invalid maximum number of servers

Cause: The number of servers given was less than or equal to zero.

Action: Use a number greater than zero.

ORA-02766 Invalid maximum of request descriptors

Cause: The number of request descriptors was less than or equal to zero.

Action: Use a number greater than zero.

ORA-02767 Less than one request descriptor was allocated per server

Cause: The package requires that the number of request descriptors be greater than or equal to the number of servers used.

Action: Use a higher number

ORA-02768 Maximum number of files is invalid

Cause: The maximum number of files to be used by the package was less than or equal to zero.

Action: Use a positive number.

ORA-02769 Setting of handler for SIGTERM failed

Cause: The package was unable to set up handling by the server for the termination signal. This is an internal error.

Action: Contact Oracle Support Services.

ORA-02770 Total number of blocks is invalid

Cause: The total number of blocks to be allocated for use by the package was not greater than zero.

Action: Use a positive number.

ORA-02771 Illegal request time out value

Cause: The number was not a positive number.

Action: Use a positive number.

ORA-02772 Invalid maximum server idle time

Cause: The time given was not a positive number.

Action: Use a positive number.

ORA-02773 Invalid maximum client wait time

Cause: The time given was not a positive number.

Action: Use a positive number.

ORA-02774 Invalid request list latch time out value

Cause: The time given was not a positive number.

Action: Use a positive number.

ORA-02775 Invalid request done signal

Cause: The signal number was not a positive number.

Action: Use a positive number.

ORA-02776 Value for request done signal exceeds maximum

Cause: The value sent to the package for use as the "request done" signal exceeds the maximum allowed by the operating system.

Action: Contact your system administrator.

ORA-02777 Stat failed on log directory

Cause: The package was unable to get information about the directory in which the log files are to reside.

Action: Check the permissions on the directory or use a different directory name.

ORA-02778 Name given for the log directory is invalid

Cause: The name given for the directory in which the logs are to be kept does not correspond to a directory.

Action: Use a different name.

ORA-02779 Stat failed on core dump directory

Cause: The package was unable to get information about the directory into which the servers are to dump core in the event of an exception.

Action: Check the permissions on the directory or use a different directory name.

ORA-02780 Name given for the core dump directory is invalid

Cause: The name given for the directory in which the server processes are to dump core in the event of an exception does not correspond to a directory.

Action: Use a different name.

ORA-02781 Invalid value given for the timing wanted flag

Cause: The value given was not TRUE or FALSE.

Action: Specify TRUE or FALSE for the timing wanted flag.

ORA-02782 Both read and write functions were not specified

Cause: To ensure that the functions act symmetrically, pointers to both the read and write functions must be given.

Action: Either specify both functions or specify neither. The package will supply its own functions.

ORA-02783 Both post and wait functions were not specified

Cause: To ensure that the functions act symmetrically, pointers to both the posting and waiting functions must be given.

Action: Either specify both functions or specify neither. The package will supply its own functions.

ORA-02784 Invalid shared memory ID specified

Cause: The ID of the segment specified for use as the shared buffer region was invalid.

Action: Use a different ID, or let the package specify its own.

ORA-02785 Invalid shared memory buffer size

Cause: The size given for the shared memory segment to be used as the shared buffer region was less than or equal to zero.

Action: Use a positive number.

ORA-02786 Size needed for shared region is greater than segment size

Cause: The size of the shared segment that was specified for the shared buffer region is less than the number of bytes required. The first field of the "additional information" field is the size needed. The second is the size of the segment.

Action: Use a larger size segment or let the package allocate its own.

ORA-02787 Unable to allocate memory for segment list

Cause: The package cannot allocate memory for an internal segment list because the system has run out of memory. The "additional information" field is the amount of memory that the package attempted to allocate.

Action: Close some processes or contact your system administrator.

ORA-02788 Unable to find kernel process pointer in async process array

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02789 Maximum number of files reached

Cause: The maximum number of files that can be used for asynchronous I/O has been reached.

Action: Shut down the servers and re-initialize the package with a higher number.

ORA-02790 File name is too long

Cause: The length of the name of a file that is being opened for asynchronous I/O is longer than the maximum. The "additional information" field is the maximum length.

Action: Use a shorter name.

ORA-02791 Unable to open file for use with asynchronous I/O

Cause: The package could not open file for some reason.

Action: Check the file name.

ORA-02792 Unable to fstat() a file being used for asynchronous I/O.

Cause: The fstat(2) call on a file being used for asynchronous I/O failed.

Action: Check the file name.

ORA-02793 Close of asynchronous I/O failed.

Cause: The client was unable to close a file being used for asynchronous I/O.

Action: Contact Oracle Support Services.

ORA-02794 Client unable to get key for shared memory

Cause: The client was unable to get a key so that it obtain shared memory for use with shared memory. This is an internal error.

Action: Contact Oracle Support Services.

ORA-02795 Request list is empty

Cause: The client was signalled by a server that it was done with a request but the "done" list was empty. This is an internal error.

Action: Contact Oracle Support Services.

ORA-02796 Done request is not in correct state

Cause: A request is not in the right state. This is an internal error.

Action: Contact Oracle Support Services.

ORA-02797 No requests available

Cause: No free request descriptors are available.

Action: Wait until some requests are filled and then retry the request, or shut down the servers and initialize the package with a higher number of requests.

ORA-02798 Invalid number of requests

Cause: The number of operations sent to either SFARD() or SFAWRITE() is less than zero. This is a user programming error.

Action: Check the calling program.

ORA-02799 Unable to arm signal handler

Cause: The arming of a signal handler for the "done" signal failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-02800 Requests timed out

Cause: Some of the requests for asynchronous input or output were not serviced in the required amount of time.

Action: If the load on the system is high, it is possible that the timeout limit is too low. Reset it with SFAINIT(). If the server processes are dying due to unexpected signals, this is an internal error, and Oracle Support Services should be contacted.

ORA-02801 Operations timed out

Cause: Some asynchronous operations timed out in kernel mode. This is an internal error.

Action: Contact Oracle Support Services.

ORA-02802 No idle servers available in parallel mode

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02803 Retrieval of current time failed

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02804 Allocation of memory failed for log file name

Cause: The client was unable to allocated a buffer for the name of the log file.

Action: Contact your system administrator.

ORA-02805 Unable to set handler for SIGTPA

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02806 Unable to set handler for SIGALRM

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02807 Allocation of memory for I/O vectors failed.

Cause: The client was unable to allocate memory for the array of I/O vectors that the servers are to use.

Action: Contact your system administrator.

ORA-02808 Allocation of memory of open files array failed.

Cause: The client was unable to allocate memory for an array of flags that the servers are to use.

Action: Contact your system administrator.

ORA-02809 Jump buffer not valid

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02810 Unable to make temporary file name for memory mapped file

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02811 Unable to attach shared memory segment

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02812 Bad attach address

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02813 Unable to make temporary file name in order to get key

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02814 Unable to get shared memory

Cause: SHMGET(2) failed.

Action: Check the UNIX number. If you are unsure about what it means, contact Oracle Support Services.

ORA-02815 Unable to attach shared memory

Cause: SHMAT(2) failed.

Action: Check the UNIX number. If you are unsure about what it means, contact Oracle Support Services.

ORA-02816 Unable to kill a process

Cause: A server did not die after being sent a kill signal.

Action: The process may be a runaway; contact Oracle Support Services.

ORA-02817 Read failed

Cause: A server could not read a requested amount of data.

Action: Check the call to SFARD(). An incorrect file descriptor may have been sent to SFARD(). The number in the "additional information" field is the starting block number of the data segment being read in.

ORA-02818 Less than the number of blocks requested was read in

Cause: A server could not read in the request amount of data. The first number in the "additional information" field is the block number being read in. The second is the actual number of bytes that was read in. This is a programming error.

Action: Check the calling program.

ORA-02819 Write failed

Cause: A server was unable to perform a write. The number in the "additional information" field is the starting block number of the data segment being written out. The first number in the "additional information" field is the block number being written out. The second is the actual number of bytes that was written out. The disk may have filled up.

Action: Check the UNIX error number.

ORA-02820 Unable to write the requested number of blocks

Cause: A server could not write the requested amount of data out to disk. The disk may have run out of space.

Action: Check the UNIX error number.

ORA-02821 Unable to read the requested number of blocks.

Cause: A server could not read the number of blocks that was requested. The end of the file may have been read.

Action: Check the file on disk.

ORA-02822 Invalid block offset

Cause: A server was unable to seek to the designated block.

Action: Check the UNIX error number.

ORA-02823 Buffer is not aligned.

Cause: The buffer on which an I/O is being done is not on the correct boundary.

Action: Check the calling program.

ORA-02824 Request free list is empty

Cause: The list from which the package allocates request descriptors is empty because all of the descriptors is in use.

Action: Wait until some become free, or initialize the package with a higher number of request descriptors.

ORA-02825 Request on free list was not free

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02826 Illegal block size

Cause: A negative number was given for the I/O block size to be used by the asynchronous I/O package. This is a programming error.

Action: Use either a positive number or zero to get the default value.

ORA-02827 Invalid file number

Cause: The file number upon which an operation is to done is either less than zero or greater than the maximum number of files than can be open.

Action: Since the calling program should not touch this number, this is a programming error.

ORA-02828 Segment free list is empty

Cause: No segments are available to allocated.

Action: Free some segments or shut down the package and re-initialize it with a higher number of segments.

ORA-02829 No segment of the proper size is available

Cause: No segment of the proper size is ready for use by the caller.

Action: Free some segments and try again.

ORA-02830 Segment could not be split - no free segments available

Cause: A segment that is larger than that desired could not be split because no free segment was available.

Action: Free some segments and try again.

ORA-02831 Segment deallocation failed - empty segment list

Cause: The caller attempted to deallocate a segment but the "in use" list was empty. This is a programming error.

Action: Check the calling program.

ORA-02832 Segment deallocation failed - segment not on list

Cause: The caller attempted to deallocate a segment that was not on the "in use" list. This is a programming error.

Action: Check the calling program.

ORA-02833 Server was unable to close file

Cause: A server was unable to close a file being used for asynchronous I/O.

Action: See the UNIX error number for more information.

ORA-02834 Server unable to open file

Cause: The server was unable to open a file for use with asynchronous I/O.

Action: Check the UNIX error number for more information.

ORA-02835 Server unable to send signal to client

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02836 Unable to create temporary key file

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02837 Unable to unlink temporary file

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02838 Unable to arm signal handler for the alarm signal

Cause: The arming of a signal handler for the alarm signal failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-02839 Sync of blocks to disk failed.

Cause: The server was unable to flush its writes out to disk.

Action: Check the UNIX error number.

ORA-02840 Open of log file by client failed

Cause: The client process was unable to open its log file.

Action: Check the UNIX error number for more information.

ORA-02841 Server died on start up

Cause: A server exited during its initialization process.

Action: Check the servers' logs for more information.

ORA-02842 Client unable to fork a server

Cause: The client could not spawn a server. A possible reason is that the operating system has reached its limit on the number of processes that it can spawn.

Action: Either reduce the number of servers that are to be used, or reconfigure the operating system so that it can handle more processes.

ORA-02843 Invalid value for kernel flag

Cause: An illegal value was given for the kernel flag in the information structure. Only TRUE and FALSE are permitted. This is a programming error.

Action: Check the calling routine.

ORA-02844 Invalid value for the leave open flag

Cause: A value was given for the flag that determines whether a file is to be left open after the client checks it to see if the servers can use it. Only TRUE and FALSE are supported. This is a programming error.

Action: Check the calling routine.

ORA-02845 Invalid value for the timing wanted flag

Cause: A value was given for the flag that indicates that operations are to be timed out. Only TRUE and FALSE are supported. This is a programming error.

Action: Check the calling routine.

ORA-02846 Unkillable server

Cause: A server failed to respond to the termination signal. The first number is the number of the server. The second is its UNIX process number. This is an internal problem.

Action: Contact Oracle Support Services.

ORA-02847 Server did not terminate when posted

Cause: A server did not respond to a posted request to shut down. The first number is the number of the server. The second is its UNIX process number. This is an internal problem.

Action: Contact Oracle Support Services.

ORA-02848 Asynchronous I/O package is not running

Cause: An operation using the asynchronous I/O package was attempted without first initializing the package using SFAINIT().

Action: Call SFAINIT() before using the package.

ORA-02849 Read failed because of an error

Cause: A server could not read the requested amount of data from disk.

Action: Check the UNIX error number.

ORA-02850 File is closed

Cause: A file upon which an asynchronous I/O operation is to be performed has already been closed by the package. This is a programming error.

Action: Check the calling program.

ORA-02851 Request list is empty when it should not be

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-02852 Invalid critical-section time out value

Cause: The time given was not a positive number.

Action: Use a positive number.

ORA-02853 Invalid server list latch time out value

Cause: The time given was not a positive number.

Action: Use a positive number.

ORA-02854 Invalid number of request buffers

Cause: The value given for DB_SLAVE_BUFFERS in your INIT.ORA file is less than 0.

Action: Use a number that is greater than or equal to 0.

ORA-02855 Number of requests is less than the number of slaves

Cause: The value given for DB_SLAVE_BUFFERS in your INIT.ORA file is less than the number specified for the number of slaves, DB_SLAVES.

Action: Specify a number that is greater than that given for DB_SLAVES Alternatively, specify 0. The kernel will supply the appropriate number.

ORA-02875 smpini: Unable to get shared memory for PGA

Cause: Stated in error code (errno).

Action: Resolve the problem.

ORA-02876 smpini: Unable to attach to shared memory for PGA

Cause: Stated in error code (errno).

Action: Resolve the problem.

ORA-02877 smpini: Unable to initialize memory protection

Cause: The ADSPCINIT program has not been executed.

Action: Execute the ADSCPINIT program as shown in your Installation and Users' Guide. If the problem persists, try restarting your computer.

ORA-02878 sou2o: Variable smpdidini overwritten

Cause: The variable SMPDIDINI was overwritten, probably by client code.

Action: Verify client code (for example, in Pro*C check for illegal memory access). If the problem occurs outside Single Task operation, contact Oracle Support Services.

ORA-02879 sou2o: Could not gain access to protected memory

Cause: This is an internal error, note error code in errno.

Action: Restarting your application or your computer may cure the problem. If not, report the error to Oracle Support Services.

ORA-02880 smpini: Could not register PGA for protection

Cause: This is an internal error, note error code in errno.

Action: Restarting your application or your computer may cure the problem. If not, report the error to Oracle Support Services.

ORA-02881 sou2o: Could not revoke access to protected memory

Cause: This is an internal error, note error code in errno.

Action: Restarting your application or your computer may cure the problem. If not, report the error to Oracle Support Services.

ORA-02882 sou2o: Could not register SGA for protection

Cause: This is an internal error, note error code in errno.

Action: Restarting your application or your computer may cure the problem. If not, report the error to Oracle Support Services.

ORA-02899 smscre: Cannot create SGA with Extended Shared Memory feature

Cause: The environment variable EXTSHM was set before starting Oracle.

Action: Unset the environment variable EXTSHM and restart Oracle.

ORA-03001 unimplemented feature

Cause: At attempt was made to use a feature that is not currently implemented.

Action: Do not attempt to use this feature at this time.

ORA-03002 operator not implemented

Cause: At attempt was made to use an operator that is not currently implemented.

Action: Do not attempt to use this operator at this time.

ORA-03007 obsolete feature

Cause: An attempt was made to use a feature that is no longer supported.

Action: No action required.

ORA-03008 parameter COMPATIBLE >= string needed for string

Cause: An attempt was made to use a feature for a later Oracle version than the setting of the initialization parameter, COMPATIBLE.

Action: Set COMPATIBLE to the value in the message (or higher), and retry the command, but be aware that this will limit your downgrade options.

ORA-03100 communication area cannot be allocated; insufficient memory

Cause: An attempt to allocate stack space for communication purposes failed. This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-03105 internal protocol error

ORA-03106 fatal two-task communication protocol error

Cause: The communication path between Oracle and the user task has stopped. This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-03107 oranet buffer underflow

Cause: This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-03108 oranet: ORACLE does not support this interface version

Cause: The version of Oracle connected to via Net8 does not support this version of the Net8 protocol.

Action: Upgrade the older version of Oracle and try again.

ORA-03109 oranet buffer overflow

Cause: Data being transferred between the user program and Oracle overflowed the buffer space available. This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-03110 oranet: ORACLE does not support this SQL version

Cause: The version of Oracle connected to via Net8 does not support the version of the Net8 protocol.

Action: Upgrade the older version of Oracle and try again.

ORA-03111 break received on communication channel

Cause: A break was processed on the communications channel, but was not properly handled by Net8 software. This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-03112 a server linked as single-task cannot use SQL*Net

Cause: A statement containing a Net8t connect string was issued to the single-task server. For example, a database link was used in a SQL statement.

Action: Do not use Net8t connect strings in a single-task environment.

ORA-03113 end-of-file on communication channel

Cause: An unexpected end-of-file was processed on the communication channel. The problem could not be handled by the Net8 two-task software. This message could occur if the shadow two-task process associated with a Net8 connect has terminated abnormally, or if there is a physical failure of the interprocess communication vehicle, that is, the network or server machine went down.

In addition, this message could occur when any of the following statements/commands have been issued:

  • ALTER SYSTEM KILL SESSION ... IMMEDIATE
  • ALTER SYSTEM DISCONNECT SESSION ... IMMEDIATE
  • SHUTDOWN ABORT/IMMEDIATE/TRANSACTIONAL

Action: If this message occurs during a connection attempt, check the setup files for the appropriate Net8 driver and confirm Net8 software is correctly installed on the server. If the message occurs after a connection is well established, and the error is not due to a physical failure, check if a trace file was generated on the server at failure time. Existence of a trace file may suggest an Oracle internal error that requires the assistance of Oracle Support Services.

ORA-03114 not connected to ORACLE

Cause: A call to Oracle was attempted when no connection was established. Usually this happens because a user-written program has not logged on. It may happen if communication trouble causes a disconnection. In addition, this message could occur when ALTER SYSTEM KILL SESSION or ALTER SYSTEM DISCONNECT SESSION were issued with the IMMEDIATE qualifier because, in those cases, the client's connection to the database is terminated without waiting for the client to issue a request.

Action: Try again. If the message recurs and the program is user written, check the program.

ORA-03115 unsupported network datatype or representation

Cause: A user bind or define, or an Oracle function, is not supported by this heterogeneous Net8 connection.

Action: Upgrade the older version of Oracle and try again.

ORA-03116 invalid buffer length passed to a conversion routine

Cause: This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-03117 two-task save area overflow

Cause: This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-03118 two-task coroutine has invalid state

Cause: This is an internal error message not usually issued.

Action: Contact Oracle Support Services.

ORA-03119 two-task detected inconsistent datatype specification

Cause: Found both a datatype, and an anonymous datatype, declaration.

Action: Correct the specification.

ORA-03120 two-task conversion routine: integer overflow

Cause: An integer value in an internal Oracle structure overflowed when being sent or received over a heterogeneous connection. This can happen when an invalid buffer length or too great a row count is specified. It usually indicates a bug in the user application.

Action: Check parameters to Oracle calls. If the problem recurs, reduce all integer parameters, column values not included, to less than 32767.

ORA-03121 no interface driver connected - function not performed

Cause: This message occurs usually because the Net8 driver is not loaded into memory or there is a mismatch of the version of the driver. A user program linked with an obsolete library may also cause this message. Only programs provided by Oracle Corporation should use this interface.

Action: If the message occurred during use of a program provided by Oracle Corporation, contact Oracle Support Services. If a user program caused the message, relink the program with current versions of the Oracle libraries.

ORA-03122 attempt to close ORACLE-side window on user side

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-03123 operation would block

Cause: The attempted operation cannot complete now.

Action: Retry the operation later.

ORA-03124 two-task internal error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-03125 client-server protocol violation

Cause: The application received a bad escape sequence from the server and may indicate a problem with the client application user code.

Action: Contact Oracle Support Services.

ORA-03126 network driver does not support non-blocking operations

Cause: A non-blocking operation was attempted and the network driver does not support non-blocking operations.

Action: Use default blocking operations or use a driver supporting non-blocking operations.

ORA-03127 no new operations allowed until the active operation ends

Cause: An attempt was made to execute a new operation before the active non-blocking operation completed or a new operation was attempted before all the pieces of a column were inserted or fetched.

Action: Execute the new operation after the non-blocking operation completes. If piecewise binds/defines were done, execute the new operation after all the pieces have been inserted or fetched.

ORA-03128 connection is in blocking mode

Cause: The OCI test for non-blocking mode on a connection indicates that the connection is in blocking mode.

Action: If non-blocking mode is required use appropriate OCI calls to change the mode.

ORA-03129 the next piece to be inserted is required

Cause: The application performed a piecewise bind on a column.

Action: Provide the next piece of this bind variable.

ORA-03130 the buffer for the next piece to be fetched is required

Cause: The application performed a piecewise define on the column.

Action: Provide the next buffer for the next piece to be retrieved.

ORA-03131 an invalid buffer was provided for the next piece

Cause: The application either provided the length of the buffer for the next piece to be zero or provided a null pointer.

Action: Verify if the buffer pointer for the next piece is null or if the length is zero.

ORA-03132 two-task default value overflow

Cause: The default value specified for a record field was too large.

Action: Change the default value to fit the field size.

ORA-03200 the segment type specification is invalid

Cause: The segment type is not TABLE, INDEX, or CLUSTER.

Action: Use a correct segment type.

ORA-03201 the group number specification is invalid

Cause: The freelist group number is either negative or larger than the number of freelist groups in the segment.

Action: Use a correct group number.

ORA-03202 the scan limit specification is invalid

Cause: The scan limit does not have a positive integer value greater than the number of freelist groups in the segment.

Action: Use a correct scan limit.

ORA-03203 concurrent update activity makes space analysis impossible

Cause: High volume of user updates interfere with the space analysis.

Action: Retry the command or lock the underlying objects.

ORA-03204 the segment type specification should indicate partitioning

Cause: A partition name was specified for the space analysis, but the object type does not indicate partitioning.

Action: Specify PARTITION in the segment type if the object is partitioned, Otherwise, omit the partition name.

ORA-03205 partition name is required when partitioned type is specified

Cause: A partition name was not specified for the space analysis, but the object type indicates partitioning.

Action: Specify a partition name if the object is partitioned. Otherwise, specify a non-partitioned type.

ORA-03206 maximum file size of (string) blocks in AUTOEXTEND clause is out of range

Cause: The maximum file size for an autoextendable file has exceeded the maximum number of blocks allowed.

Action: Reduce the size and retry.

ORA-03207 subpartitioned type must be specified for composite object

Cause: A partition type is specified for the space analysis, but the object type indicates composite partitioning.

Action: Specify a subpartition name and a subpartition type.

ORA-03208 partitioned type must be specified for a non-composite object

Cause: A subpartition type is specified for the space analysis, but the object type indicates non-composite partitioning.

Action: Specify a partition name and a partition type.

ORA-03209 DBMS_ADMIN_PACKAGE invalid file/block specification

Cause: The value of file number or block number is outside of limits or inconsistent.

Action: Fix the file number/block number value.

ORA-03210 DBMS_ADMIN_PACKAGE invalid option specification

Cause: The value of one of the option parameters is incorrect.

Action: Fix the option value.

ORA-03211 The segment does not exist or is not in a valid state

Cause: The segment specified in the DBMS_SPACE_ADMIN or DBMS_SPACE operation does not exist or is not in a state appropriate for this operation.

Action: Fix the segment specification, or put the segment in the appropriate state.

ORA-03212 Temporary Segment cannot be created in locally-managed tablespace

Cause: An attempt was made to create a temporary segment for SORT/HASH/LOBS in a locally-managed permanent tablespace.

Action: Alter temporary tablespace of user to a temporary tablespace or a dictionary-managed permanent tablespace.

ORA-03213 Invalid Lob Segment Name for DBMS_SPACE package

Cause: The LOB segment specified in the DBMS_SPACE operation does not exist.

Action: Fix the segment specification.

ORA-03214 File Size specified is smaller than minimum required

Cause: File size specified for add/resize datafile/temporary file does not allow for the minimum required of one allocation unit.

Action: Increase the specification for the file size.

ORA-03215 File Size specified for resize is too small

Cause: File size specified for resize datafile/temporary file causes bitmap control structures to overlap.

Action: Increase the specification for the file size.

ORA-03216 Tablespace/Segment Verification cannot proceed

Cause: Corruption was detected during verification which cannot be dealt with

Action: Do manual verification.

ORA-03217 invalid option for alter of TEMPORARY TABLESPACE

Cause: Invalid option for alter of temporary tablespace was specified.

Action: Specify one of the valid options: ADD TEMPFILE, TEMPFILE ONLINE, TEMPFILE OFFLINE.

ORA-03218 invalid option for CREATE/ALTER TABLESPACE

Cause: Invalid option for create/alter tablespace of type locally-managed.

Action: Specify one of the valid options.

ORA-03219 Tablespace 'string' is dictionary managed, offline, or temporary.

Cause: An operation which is only applicable to permanent, online, locally managed tablespaces is specified for a tablespace that is either dictionary managed, offline, or temporary.

Action: Reissue the operation for a different tablespace, mount the tablespace, or do not issue it at all since it does not apply for the given tablespace.

ORA-03220 DBMS_ADMIN_PACKAGE required parameter is NULL or missing

Cause: Some of the procedures were called with missing or NULL parameters.

Action: Specify the missing parameter.

ORA-03221 temporary tablespaces and temporary segments must have standard block size

Cause: An attempt was made to do one of the following:

  1. Create a temporary tablespace with a non-standard block size
  2. Alter an existing permanent tablespace of non-standard block size to a temporary tablespace
  3. Issue a DDL statement that would result in the creation of a temporary segment in a tablespace of non-standard block size

Action: There are three possible solutions:

If creating a temporary tablespace, do not specify a block size different from the standard block size.
  4. If altering an existing permanent tablespace to a temporary tablespace, ensure that it is of standard block size.
  5. Ensure that the user's temporary tablespace is a tablespace having the standard block size.

ORA-03230 segment only contains string blocks of unused space above high water mark

Cause: Attempt to preserve too many blocks.

Action: Reduce the KEEP amount.

ORA-03231 the INITIAL extent may not be deallocated

Cause: Attempt to deallocate space from the segment which was truncated prior to the 7.3 release.

Action: Increase the KEEP amount, or truncate the segment, and reissue the command.

ORA-03233 unable to extend table string.string subpartition string by string in tablespace string

Cause: Failed to allocate an extent for table subpartition segment in tablespace.

Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-03234 unable to extend index string.string subpartition string by string in tablespace string

Cause: Failed to allocate an extent for index subpartition segment in tablespace.

Action: Use ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-03235 max # extents (string) reached in table string.string subpartition string

Cause: A table subpartition tried to extend past MAXEXTENTS.

Action: If the value of MAXEXTENTS is less than the system maximum, raise it. Otherwise, you must re-create with larger initial, next or PCTINCREASE parameters.

ORA-03236 max # extents (string) reached in index string.string subpartition string

Cause: An index subpartition tried to extend past MAXEXTENTS.

Action: If the value of MAXEXTENTS is less than the system maximum, raise it. Otherwise, you must re-create with larger initial, next or PCTINCREASE parameters.

ORA-03237 Initial Extent of specified size cannot be allocated in tablespace (string)

Cause: Too large a size for an initial extent due to freelist group specification.

Action: Reduce number of freelist groups specified for the segment.

ORA-03238 unable to extend LOB segment string.string subpartition string by string in tablespace string

Cause: An attempt was made to allocate an extent for LOB subpartition segment in tablespace, but the extent could not be allocated because there is not enough space in the tablespace indicated.

Action: Use the ALTER TABLESPACE ADD DATAFILE statement to add one or more files to the tablespace indicated.

ORA-03239 maxextents (string) reached in LOB segment string.string subpartition string

Cause: A LOB subpartition segment tried to extend past MAXEXTENTS.

Action: If the value of MAXEXTENTS is less than the system maximum, raise it. Otherwise, re-create the subpartition with larger INITIAL, NEXT, or PCTINCREASE parameters.

ORA-03240 User's temporary tablespace same as tablespace being migrated

Cause: Users default temporary tablespace must be different from the tablespace being migrated.

Action: alter users default temporary tablespace to be different.

ORA-03241 Invalid unit size

Cause: User specified an invalid unit size for the tablespace.

Action: Specify the correct unit size. To estimate unit size, refer to the Oracle9i Database Administrator's Guide.

ORA-03242 Tablespace migration retried 500 times

Cause: For migration to complete, temporary segments should not be present in the tablespace at the time of migration.

Action: Avoid migrating the tablespace when there is heavy temporary segment creation going on as with object drops.

ORA-03243 destination dba overlaps with existing control information

Cause: Cannot overlap control information during relocation.

Action: Choose another destination address.

ORA-03244 No free space found to place the control information

Cause: During migration of tablespace found no place to put the control information. If during bitmaps relocation, found no space at the specified destination.

Action: If during migration, add more space to the tablespace and retry migration. If during bitmaps relocation, specify a destination address where there is enough free space.

ORA-03245 Tablespace has to be dictionary managed, online and permanent to be able to migrate

Cause: Tablespace was not dictionary managed, online, or permanent.

Action: Make sure the tablespace is online, permanent, or dictionary managed.

ORA-03246 Invalid block number specified

Cause: Control information cannot be placed at the specified DBA either because the block number specified is beyond the file end or the file is not large enough to accomodate the control information at that location.

Action: specify a correct block number.

ORA-03247 Invalid block number specified

Cause: Relocation of bitmaps to the said destination will make the tablespace self descriptive.

Action: Choose another destination DBA.

ORA-03248 Too much of segment creation activity during migration

Cause: Temporary segments were attempted to be created during migration.

Action: The error is signalled after retrying migration for 500 times. Run migration when there is less segment creation activity going on.

ORA-03249 Uniform size for auto segment space managed tablespace should have atleast string blocks.

Cause: For the given blocksize, the specified uniform size is insufficient.

Action: Specify a larger extent size and retry.

ORA-03250 Cannot mark this segment corrupt

Cause: This segment cannot be marked corrupt because it contains data dictionary objects.

Action: Check the segment information and re-issue the command.

ORA-03251 Cannot issue this command on SYSTEM tablespace

Cause: It is not permitted to migrate SYSTEM tablespace from locally managed format to dictionary managed format or relocate bitmaps.

Action: Check the tablespace name and procedure name.

ORA-03274 both ALLOCATE EXTENT and DEALLOCATE UNUSED options are specified

Cause: The DEALLOCATE option and the ALLOCATE option are specified in the same command.

Action: Choose one of the options or issue two separate commands.

ORA-03275 duplicate DEALLOCATE option specification

Cause: The DEALLOCATE UNUSED option to ALTER TABLE or ALTER INDEX is specified more than once.

Action: Specify the option at most once.

ORA-03276 duplicate ALLOCATE EXTENT option specification

Cause: The ALLOCATE EXTENT option to ALTER TABLE or ALTER INDEX is specified more than once.

Action: Specify the option at most once.

ORA-03277 invalid SIZE specified

Cause: The specified value must be an integer.

Action: Choose an appropriate integer value.

ORA-03278 duplicate ALLOCATE EXTENT option specification

Cause: An option (DATAFILE, SIZE or INSTANCE) was specified more than once.

Action: Specify each option at most once.

ORA-03279 invalid INSTANCE specified

Cause: The specified value is not recognized as a valid instance name.

Action: Use a valid name.

ORA-03280 invalid DATAFILE filename specified

Cause: A character string literal is expected, but not found.

Action: Specify file names using character string literals.

ORA-03281 invalid ALLOCATE EXTENT option

Cause: An option other than DATAFILE, SIZE or INSTANCE was specified.

Action: Remove invalid option and retry the command.

ORA-03282 missing ALLOCATE EXTENT option

Cause: No ALLOCATE EXTENT options were specified.

Action: Specified one or more of the following options: DATAFILE, SIZE or INSTANCE.

ORA-03283 specified datafile string does not exist

Cause: The datafile does not exist.

Action: Retry the option with the correct datafile.

ORA-03284 datafile string is not a member of tablespace string

Cause: The specified datafile does not belong to the tablespace that the object resides in.

Action: Retry the option with the correct datafile.

ORA-03286 ALLOCATE EXTENT not valid for HASH CLUSTERS

Cause: The cluster cannot use the allocate extent option because it is a hash cluster.

Action: Do not use this command on a hash cluster.

ORA-03287 invalid FREELIST GROUP specified

Cause: The specified FREELIST GROUP number is invalid.

Action: Choose a number between 1 and the number of freelist groups for this object.

ORA-03288 both FREELIST GROUP and INSTANCE parameters may not be specified

Cause: Both FREELIST GROUP and INSTANCE were specified in clause.

Action: Remove one of the two parameters.

ORA-03289 partition name and segment type do not match

Cause: Partition name and segment type specified for space analysis do not match.

Action: Specify type PARTITION if the object is partitioned, specify SUBPARTITION if the object is composite.

ORA-03290 Invalid truncate command - missing CLUSTER or TABLE keyword

Cause: Invalid object specification given.

Action: Either specify TRUNCATE CLUSTER or TRUNCATE TABLE.

ORA-03291 Invalid truncate option - missing STORAGE keyword

Cause: Expected STORAGE keyword.

Action: Either specify DROP STORAGE or REUSE STORAGE.

ORA-03292 Table to be truncated is part of a cluster

Cause: The table being truncated is a member of a cluster.

Action: Either use TRUNCATE CLUSTER or DROP TABLE.

ORA-03293 Cluster to be truncated is a HASH CLUSTER

Cause: Only INDEX CLUSTERS can be truncated.

Action: Drop and re-create the HASH CLUSTER instead of using truncate.

ORA-03296 cannot resize datafile - file string not found

Cause: The specified datafile is not available for resizing.

Action: Ensure that the datafile name is valid, and if so, ensure the file is accessible.

ORA-03297 file contains used data beyond requested RESIZE value

Cause: Some portion of the file in the region to be trimmed is currently in use by a database object.

Action: Drop or move segments containing extents in this region prior to resizing the file, or choose a resize value such that only free space is in the trimmed.

ORA-03298 cannot shrink datafile - file string is under hot backup

Cause: Attempt to shrink a datafile while it is under hot backup. This is not allowed.

Action: Retry shrinking the file after the hot backup completes.

ORA-03299 cannot create dictionary table string

Cause: A dictionary table is created upon the first execution of the command ALTER DATABASE DATAFILE AUTOEXTEND ON for a database. This operation did not succeed. The most probable cause for this is insufficient space in the system tablespace.

Action: See action for next error message in error stack.

ORA-04000 the sum of PCTUSED and PCTFREE cannot exceed 100

Cause: The sum of PCTUSED and PCTFREE for a cluster or table exceeds 100.

Action: Create the table/cluster specifying values whose sum is less than or equal to 100.

ORA-04001 sequence parameter string must be an integer

Cause: string (a sequence parameter) specified was not an integer.

Action: Create the sequence, giving the specified parameter an integer value.

ORA-04002 INCREMENT must be a non-zero integer

Cause: A sequence increment was specified to be zero.

Action: Specify the increment to be a non-zero value.

ORA-04003 sequence parameter string exceeds maximum size allowed (string digits)

Cause: string (a sequencer parameter) had too many digits.

Action: Specify the parameter with the allowed number of digits.

ORA-04004 MINVALUE must be less than MAXVALUE

Cause: MINVALUE was specified to be greater than or equal to MAXVALUE.

Action: Specify a MINVALUE that is less than MAXVALUE.

ORA-04005 INCREMENT must be less than MAXVALUE minus MINVALUE

Cause: The INCREMENT specified is greater than or equal to MAXVALUE-MINVALUE.

Action: Specify an INCREMENT that is less than MAXVALUE-MINVALUE.

ORA-04006 START WITH cannot be less than MINVALUE

Cause: The given starting value is less than MINVALUE.

Action: Make sure that the starting value is greater than or equal to MINVALUE.

ORA-04007 MINVALUE cannot be made to exceed the current value

Cause: The given MINVALUE would be greater than the current value.

Action: Always make sure that MINVALUE is less than or equal to the current value.

ORA-04008 START WITH cannot be more than MAXVALUE

Cause: The starting value would be larger than MAXVALUE.

Action: Make sure that the starting value is less than MAXVALUE.

ORA-04009 MAXVALUE cannot be made to be less than the current value

Cause: The current value exceeds the given MAXVALUE.

Action: Make sure that the new MAXVALUE is larger than the current value.

ORA-04010 the number of values to CACHE must be greater than 1

Cause: The value in the CACHE clause was one.

Action: Specify NOCACHE, or a value larger than one.

ORA-04011 sequence string must range between string and string

Cause: The value specified for one of the sequence parameters exceeds limits.

Action: Specify a parameter within these limits.

ORA-04012 object is not a sequence

Cause: The object specified cannot have sequence DDLs performed on it.

Action: Re-enter the statement being careful with the spelling of the name.

ORA-04013 number to CACHE must be less than one cycle

Cause: The number to CACHE specified in a CREATE SEQUENCE statement exceeds the number of values in a cycle.

Action: Enlarge the cycle or cache fewer values, and try again.

ORA-04014 descending sequences that CYCLE must specify MINVALUE

Cause: A value was not specified in the CREATE SEQUENCE statement. Sequences that cycle must specify a value at which to begin again.

Action: Re-create the sequence, specifying the value at which it is to begin.

ORA-04015 ascending sequences that CYCLE must specify MAXVALUE

Cause: A value was not specified in the CREATE SEQUENCE statement. Sequences that cycle must specify a value at which to begin again.

Action: Recreate the sequence, specifying the value at which it is to begin.

ORA-04016 sequence string no longer exists

Cause: Sequence was dropped while processing its next value.

Action: Re-create the sequence.

ORA-04017 invalid value string (length = string) for parameter max_dump_file_ size

Cause: Neither did the string supplied for MAX_DUMP_FILE_SIZE parameter match the "UNLIMITED" string value nor did it represent a base 10 integer.

Action: Reassign a proper value to this parameter.

ORA-04018 invalid value string for parameter _scn_scheme

Cause: The value specified for initialization parameter _SCN_SCHEME is not recognized as one of the defined schemes.

Action: Reassign a proper value.

ORA-04019 SCN scheme incompatible with other instances

Cause: Either different instances are running incompatible Oracle releases or different values have been assigned to the _SCN_SCHEME initialization parameter on different instances.

Action: Make sure the _SCN_SCHEME initialization parameter is set to the same value on all instances.

ORA-04020 deadlock detected while trying to lock object stringstringstringstringstring

Cause: While trying to lock a library object, a deadlock is detected.

Action: Retry the operation later.

ORA-04021 timeout occurred while waiting to lock object stringstringstringstringstring

Cause: While waiting to lock a library object, a timeout is occurred.

Action: Retry the operation later.

ORA-04022 nowait requested, but had to wait to lock dictionary object

Cause: Had to wait to lock a library object during a nowait request.

Action: Retry the operation later.

ORA-04028 cannot generate diana for object stringstringstringstringstring

Cause: Cannot generate diana for an object because of lock conflict.

Action: Report this error to your support representative.

ORA-04029 error ORA-string occurred when querying stringstringstring

Cause: The table or view being queried might be missing. The error number indicates the error.

Action: Fix the error.

ORA-04030 out of process memory when trying to allocate string bytes (string,string)

Cause: Operating system process private memory has been exhausted.

Action: See the database administrator or operating system administrator to increase process memory quota. There may be a bug in the application that causes excessive allocations of process memory space.

ORA-04031 unable to allocate string bytes of shared memory ("string","string","string","string")

Cause: More shared memory is needed than was allocated in the shared pool.

Action: If the shared pool is out of memory, either use the DBMS_SHARED_ POOL package to pin large packages, reduce your use of shared memory, or increase the amount of available shared memory by increasing the value of the initialization parameters SHARED_POOL_RESERVED_SIZE and SHARED_ POOL_SIZE. If the large pool is out of memory, increase the initialization parameter LARGE_POOL_SIZE.

ORA-04032 pga_aggregate_target must be set before switching to auto mode

Cause: An attempt was made to set WORKAREA_SIZE_POLICY to AUTO while PGA_AGGREGATE_TARGET is not specified.

Action: Before setting WORKAREA_SIZE_POLICY, set PGA_AGGREGATE_TARGET to a value representing the total private memory available to the instance. This total is generally the total physical memory available in the system minus what is needed for the SGA minus what is needed for the operating system (for example, such as 500 MB).

ORA-04033 insufficient memory to grow pool

Cause: The system had insufficient memory to grow the pool to the specified size.

Action: Specify a smaller value to grow the pool.

ORA-04041 package specification must be created first before creating package body

Cause: Attempt to create a package body before creating its package specification.

Action: Create the package specification first before creating the package body.

ORA-04042 procedure, function, package, or package body does not exist

Cause: Attempt to access a procedure, function, package, or package body that does not exist.

Action: Make sure the name is correct.

ORA-04043 object string does not exist

Cause: An object name was specified that was not recognized by the system. Following are possible causes:

  • An invalid name for a table, view, sequence, procedure, function, package, or package body was entered. Since the system could not recognize the invalid name, it responded with the message that the named object does not exist.
  • An attempt was made to rename an index or a cluster, or some other object that cannot be renamed.

Action: Check the spelling of the named object and rerun the code. (Valid names of tables, views, functions, etc. can be listed by querying the data dictionary.)

ORA-04044 procedure, function, package, or type is not allowed here

Cause: A procedure, function, or package was specified in an inappropriate place in a statement.

Action: Make sure the name is correct or remove it.

ORA-04045 errors during recompilation/revalidation of string.string

Cause: This message indicates the object to which the following errors apply. The errors occurred during implicit recompilation/revalidation of the object.

Action: Check the following errors for more information, and make the necessary corrections to the object.

ORA-04046 results of compilation are too large to support

Cause: Attempt to compile and store a large stored procedure that results in compilation data that is too large for the system to support or store.

Action: Reduce the size of the store procedure by splitting it into smaller stored procedures.

ORA-04047 object specified is incompatible with the flag specified

Cause: The object type implied by the flag does not match the type of object specified.

Action: Specify the correct object, or use the appropriate flag.

ORA-04050 invalid or missing procedure, function, or package name

Cause: The required procedure, function, or package name is invalid or missing.

Action: Specify a valid name.

ORA-04051 user string cannot use database link string.string

Cause: During forwarding of a remote object access, an attempt was made to use a non-existent database link or one owned by a user other than the logon user or PUBLIC.

Action: Change your database link structure so that all indirect remote accesses are done from the same userid that originates the request.

ORA-04052 error occurred when looking up remote object stringstringstringstringstring

Cause: An error has occurred when trying to look up a remote object.

Action: Fix the error. Make sure the remote database system has run KGLR.SQL to create necessary views used for querying/looking up objects stored in the database.

ORA-04053 error occurred when validating remote object stringstringstringstringstring

Cause: An error has occurred when trying to validate a remote object.

Action: Fix the error. Make sure the remote database system has run KGLR.SQL to create necessary views used for querying/looking up objects stored in the database.

ORA-04054 database link string does not exist

Cause: During compilation of a PL/SQL block, an attempt was made to use a non-existent database link.

Action: Either use a different database link or create the database link.

ORA-04055 Aborted: "string" formed a non-REF mutually-dependent cycle with "string".

Cause: This compilation was aborted because the library unit that was compiled would have formed a non-REF mutually-dependent cycle with some other library units. This happens when an attempt is made to compile types that have attributes of other types that may participate in a cycle with this type. Example:

create type t1; create type t2 (a t1); create type t1 (a t2);

Action: Break the cycle (possibly by adding a REF or by using another type).

ORA-04060 insufficient privileges to execute string

Cause: Attempt to execute a stored procedure without sufficient privileges.

Action: Get necessary privileges.

ORA-04061 existing state of string has been invalidated

Cause: Attempt to resume the execution of a stored procedure using the existing state which has become invalid or inconsistent with the stored procedure because the procedure has been altered or dropped.

Action: Try again; this error should have caused the existing state of all packages to be re-initialized.

ORA-04062 string of string has been changed

Cause: Attempt to execute a stored procedure to serve an RPC stub which specifies a timestamp or signature that is different from the current timestamp/signature of the procedure.

Action: Recompile the caller in order to pick up the new timestamp.

ORA-04063 string has errors

Cause: Attempt to execute a stored procedure or use a view that has errors. For stored procedures, the problem could be syntax errors or references to other, non-existent procedures. For views, the problem could be a reference in the view's defining query to a non-existent table. Can also be a table which has references to non-existent or inaccessible types.

Action: Fix the errors and/or create referenced objects as necessary.

ORA-04064 not executed, invalidated string

Cause: Attempt to execute a stored procedure that has been invalidated.

Action: Recompile the stored procedure.

ORA-04065 not executed, altered or dropped string

Cause: Attempt to execute a stored procedure that has been altered or dropped thus making it not callable from the calling procedure.

Action: Recompile its dependents.

ORA-04066 non-executable object, string

Cause: Attempt to execute a non-procedure.

Action: Make sure that a correct name is given.

ORA-04067 not executed, string does not exist

Cause: Attempt to execute a non-existent stored procedure.

Action: Make sure that a correct name is given.

ORA-04068 existing state of packagesstringstringstring has been discarded

Cause: An error occurred when attempting to execute a stored procedure.

Action: Refer to the accompanying messages and fix the error mentioned. Try the procedure again after proper reinitialization of any application's state.

ORA-04070 invalid trigger name

Cause: An invalid trigger name was specified.

Action: Verify that trigger name is not a reserved keyword.

ORA-04071 missing BEFORE, AFTER or INSTEAD OF keyword

Cause: The trigger statement is missing the BEFORE/AFTER/INSTEAD OF clause.

Action: Specify either BEFORE, AFTER or INSTEAD OF.

ORA-04072 invalid trigger type

Cause: An invalid trigger type was given.

Action: Specify either INSERT, UPDATE or DELETE.

ORA-04073 column list not valid for this trigger type

Cause: A column list was specified for a non-update trigger type.

Action: Remove the column list.

ORA-04074 invalid REFERENCING name

Cause: An invalid name was given in the referencing clause.

Action: Verify the referencing name is not a reserved word.

ORA-04075 invalid trigger action

Cause: An statement was given for the trigger action.

Action: Re-specify the trigger action.

ORA-04076 invalid NEW or OLD specification

Cause: An invalid NEW or OLD specification was given for a column.

Action: Re-specify the column using the correct NEW or OLD specification.

ORA-04077 WHEN clause cannot be used with table level triggers

Cause: The when clause can only be specified for row level triggers.

Action: Remove the when clause or specify for each row.

ORA-04078 OLD and NEW values cannot be identical

Cause: The referencing clause specifies identical values for NEW and OLD.

Action: Re-specify either the OLD or NEW referencing value.

ORA-04079 invalid trigger specification

Cause: The create TRIGGER statement is invalid.

Action: Check the statement for correct syntax.

ORA-04080 trigger 'string' does not exist

Cause: The TRIGGER name is invalid.

Action: Check the trigger name.

ORA-04081 trigger 'string' already exists

Cause: The TRIGGER name or type already exists.

Action: Use a different trigger name or drop the trigger which is of the same name.

ORA-04082 NEW or OLD references not allowed in table level triggers

Cause: The trigger is accessing "new" or "old" values in a table trigger.

Action: Remove any new or old references.

ORA-04083 invalid trigger variable 'string'

Cause: The variable referenced in the trigger body is invalid.

Action: See the Oracle9i SQL Reference for valid trigger variable types.

ORA-04084 cannot change NEW values for this trigger type

Cause: New trigger variables can only be changed in before row insert or update triggers.

Action: Change the trigger type or remove the variable reference.

ORA-04085 cannot change the value of an OLD reference variable

Cause: Old values can only be read and not changed.

Action: Do not attempt to change an old variable.

ORA-04086 trigger description too long, move comments into triggering code

Cause: The trigger description is limited to 2000 characters (for dictionary storage reasons). The description does not include the text of the "when" clause or the text of the PL/SQL code executed for the trigger.

Action: If the trigger description contains a large comment, move that comment into the PL/SQL code for the trigger.

ORA-04087 cannot change the value of ROWID reference variable

Cause: ROWIDs can only be read and not changed.

Action: Do not attempt to change an ROWID value.

ORA-04088 error during execution of trigger 'string.string'

Cause: A runtime error occurred during execution of a trigger.

Action: Check the triggers which were involved in the operation.

ORA-04089 cannot create triggers on objects owned by SYS

Cause: An attempt was made to create a trigger on an object owned by SYS.

Action: Do not create triggers on objects owned by SYS.

ORA-04090 'string' specifies same table, event and trigger time as 'string'

Cause: Trigger is of duplicate event and trigger time.

Action: Combine the triggering information into one trigger which is fired at the given time.

ORA-04091 table string.string is mutating, trigger/function may not see it

Cause: A trigger (or a user defined PL/SQL function that is referenced in this statement) attempted to look at (or modify) a table that was in the middle of being modified by the statement which fired it.

Action: Rewrite the trigger (or function) so it does not read that table.

ORA-04092 cannot string in a trigger

Cause: A trigger attempted to commit or roll back.

Action: Rewrite the trigger so it does not commit or roll back.

ORA-04093 references to columns of type LONG are not allowed in triggers

Cause: A trigger attempted to reference a long column in the triggering table.

Action: Do not reference the long column.

ORA-04094 table string.string is constraining, trigger may not modify it

Cause: A trigger attempted to modify a table that was constraining for some referential constraint of a parent SQL statement.

Action: Rewrite the trigger so that it does not modify that table.

ORA-04095 trigger 'string' already exists on another table, cannot replace it

Cause: Cannot replace a trigger which already exists on a different table than the one being replaced.

Action: Drop the trigger with the same name and re-create it.

ORA-04096 trigger 'string' has a WHEN clause which is too large, limit 2K

Cause: A trigger's WHEN clause is limited to 2K for dictionary storage reasons. The trigger being created exceeded that size.

Action: Use a smaller WHEN clause. Note, the trigger body could be used to perform the same limiting action as the WHEN clause.

ORA-04097 DDL conflict while trying to drop or alter a trigger

Cause: An attempt was made to concurrently perform two DDL operations on a trigger or trigger table.

Action: Investigate the new state of the trigger and retry the DDL operation, if still appropriate.

ORA-04098 trigger 'string.string' is invalid and failed re-validation

Cause: A trigger was attempted to be retrieved for execution and was found to be invalid. This also means that compilation/authorization failed for the trigger.

Action: Options are to resolve the compilation/authorization errors, disable the trigger, or drop the trigger.

ORA-04099 trigger 'string' is valid but not stored in compiled form

Cause: A trigger was attempted to be retrieved for execution and was found to be valid, but not stored. This may mean the an upgrade was done improperly from a non-stored trigger release.

Action: Alter compile the trigger to create the trigger in stored form. Also, you may want to review that a proper upgrade was done.


ORA-04100 to ORA-07499

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

6
ORA-04100 to ORA-07499

ORA-04930 open sequence number failed or initial state is valid

Cause: Either Shared Sequence Number operating system component was not installed properly, or an MC hardware failure may have occurred or a previous instance was not shut down properly.

Action: Verify that there are no background or foreground Oracle processes from a previous instance on this node using the operating system command ps -ef | grep instance_name. Verify that there are no shared memory segments belonging to the user which owns the Oracle installation by issuing the ipcs -b operating system command. If there are shared memory segments or processes still on the system, use SVRMGRL to shut down the instance with the abort option. If the instance is not up, verify that the cluster software and/or the hardware is installed and working. Log in as superuser and issue the CNXSHOW command. Are all of the nodes in the cluster listed? Are they members of the cluster? Is the communications between nodes okay? If the answer to any of these questions is false, contact Digital's customer support organization.

ORA-04931 unable to set initial sequence number value

Cause: A call to the SSN failed to set the sequence number to its initial value, possibly caused by an MC hardware problem.

Action: Verify that the MC hardware is functioning properly. If it is not, contact Digital's customer support organization. If it is, contact Oracle Support Services.

ORA-04932 increment or adjust of sequence number failed

Cause: A call to the SSN failed to increment the sequence number.

Action: Verify that the MC hardware is functioning properly. If it is not, contact Digital's customer support organization. If it is, contact Oracle Support Services.

ORA-04933 initial service identifier is non-zero

Cause: A valid service identifier existed before the sequence number service was opened.

Action: Verify that the instance is completely shut down.

ORA-04934 unable to obtain the current sequence number

Cause: A call to the SSN failed to return its current value. Either there are many errors occurring on the MC hardware, or the sequence number has become invalid and cannot be validated.

Action: Verify that the MC hardware is functioning properly. If it is, contact Oracle Support Services.

ORA-04935 unable to get/convert SCN recovery lock

Cause: A process has timed out trying to get or convert the SCN recovery lock. Another process probably has the lock in EX or SHR mode, but is not releasing it.

Action: Contact Oracle Support Services.

ORA-04940 unsupported optimization of Oracle binary, check alert log for more info

Cause: ORACLE binary has been optimized with unsupported options or a required option has not been used.

Action: Check the documentation for a list of supported and required flags for the optimizing utility that you used to optimize ORACLE. Shutdown the instance, optimize ORACLE again with a supported combination of options, and restart the instance.

ORA-06000 NETASY: port open failure

Cause: Autologin unable to open port.

Action: Check log file for operating system-specific error code.

ORA-06001 NETASY: port set-up failure

Cause: Autologin unable to change port attributes.

Action: Check log file for operating system-specific error code.

ORA-06002 NETASY: port read failure

Cause: Autologin unable to read from port.

Action: Check log file for operating system-specific error code.

ORA-06003 NETASY: port write failure

Cause: Autologin unable to write to port.

Action: Check log file for operating system-specific error code.

ORA-06004 NETASY: dialogue file open failure

Cause: Autologin unable to open dialogue file.

Action: Check connect string for accuracy/typos.

ORA-06005 NETASY: dialogue file read failure

Cause: Autologin unable to read dialogue file.

Action: Check log file for operating system-specific error code.

ORA-06006 NETASY: dialogue execute failure

Cause: Expected response never received.

Action: Check log file for operating system-specific error code.

ORA-06007 NETASY: bad dialogue format

Cause: Dialogue file contains syntax error.

Action: Correct the dialogue file.

ORA-06009 NETASY: dialogue filename too long

Cause: Full file specification for dialogue file exceeds 64 bytes.

Action: Amend connect string accordingly.

ORA-06010 NETASY: dialogue file too long

Cause: Dialogue file exceeds 768 bytes in length.

Action: Simplify dialogue (for example, such as remove comments, redundant white space), or split into two and link with the MORE command.

ORA-06011 NETASY: dialogue too long

Cause: One of the following:

  • Dialogue contains more than 24 exchange blocks
  • Dialogue send string exceeds 84 bytes in length

Action: Simplify dialogue or split into two and link with the MORE command.

ORA-06017 NETASY: message receive failure

Cause: Asynchronous driver gets I/O error while doing network read operation.

Action: Check log file for operating system-specific error code and contact Oracle Support Services.

ORA-06018 NETASY: message send failure

Cause: Asynchronous driver gets I/O error while doing network write operation.

Action: Check log file for operating system-specific error code and contact Oracle Support Services.

ORA-06019 NETASY: invalid login (connect) string

Cause: Syntax error in login string.

Action: Resubmit with correct string.

ORA-06020 NETASY: initialisation failure

Cause: Asynchronous driver unable to complete initialization.

Action: Check log file for operating system-specific error code.

ORA-06021 NETASY: connect failed

Cause: Asynchronous driver unable to establish connection with partner.

Action: Check log file for operating system-specific error code.

ORA-06022 NETASY: channel open failure

Cause: No free channel.

Action: Contact Oracle Support Services.

ORA-06023 NETASY: port open failure

Cause: Asynchronous driver unable to open port.

Action: Check log file for operating system-specific error code.

ORA-06024 NETASY: VTM error

Cause: Virtual Terminal Manager unable to read/write to port.

Action: Check log file for operating system-specific error code.

ORA-06025 NETASY: Configuration error

Cause: Asynchronous driver generated for server-only, but client service requested.

Action: Contact Oracle Support Services.

ORA-06026 NETASY: port close failure

Cause: Asynchronous driver unable to close port.

Action: Check log file for operating system-specific error code.

ORA-06027 NETASY: channel close failure

Cause: Asynchronous driver unable to close channel.

Action: Check log file for operating system-specific error code.

ORA-06028 NETASY: unable to intialise for logging

Cause: Asynchronous driver unable to initialize for logging I/O.

Action: Contact Oracle Support Services.

ORA-06029 NETASY: port assignment failure

Cause: Asynchronous driver unable to assign port to channel.

Action: Contact Oracle Support Services.

ORA-06030 NETDNT: connect failed, unrecognized node name

Cause: Node name specified in host string is unknown (probably misspelled).

Action: Retry with correct node name.

ORA-06031 NETDNT: connect failed, unrecognized object name

Cause: Host string contains reference to object (which does not exist):

@d:node-obj => object is ORDNobj;
  • When node is VMS, the object is ORDNobj.COM
  • When node is UNIX, the object is ORDNobj @d:node::"task=obj" => object is obj;
  • When node is VMS, the object is obj.COM
  • When node is UNIX, the object is obj

Action: Retry with correct object name or create the required object on host node.

ORA-06032 NETDNT: connect failed, access control data rejected

Cause: Host string contains invalid username/password.

Action: Retry with correct username/password.

ORA-06033 NETDNT: connect failed, partner rejected connection

Cause: Connection with partner was made but was rejected.

Action: Contact your network administrator.

ORA-06034 NETDNT: connect failed, partner exited unexpectedly

Cause: Connection with host node was made but partner aborted.

Action: Make sure object (see 06031, above) is working (for VMS run the command file and make sure that the Oracle server process starts up); sometimes happens when the network/node is under stress; in this case, a retry often works.

ORA-06035 NETDNT: connect failed, insufficient resources

Cause: Insufficient system resources are available to complete the connection; for example, all DECnet channels are in use.

Action: Contact your network administrator.

ORA-06037 NETDNT: connect failed, node unreachable

Cause: Host node is down.

Action: Contact your network administrator.

ORA-06039 NETDNT: connect failed

Cause: Connect failed for unexpected reason (see OSD error).

Action: Contact Oracle Support Services.

ORA-06040 NETDNT: invalid login (connect) string

Cause: Syntax error in login string.

Action: Resubmit with correct string.

ORA-06041 NETDNT: disconnect failed

Cause: Driver gets error while doing network close operation.

Action: Contact Oracle Support Services.

ORA-06042 NETDNT: message receive failure

Cause: Driver gets I/O error while doing network read operation.

Action: Contact Oracle Support Services.

ORA-06043 NETDNT: message send failure

Cause: Driver gets I/O error while doing network write operation.

Action: Contact Oracle Support Services.

ORA-06044 NETDNT: connect failed, byte count quota exceeded

Cause: Connect failed because of insufficient byte count quota.

Action: Increase byte count quota.

ORA-06102 NETTCP: cannot allocate context area

Cause: Insufficient dynamic memory available for connection context area.

Action: Contact Oracle Support Services.

ORA-06105 NETTCP: remote host is unknown

Cause: Host name specified in the login (connect) string is unknown.

Action: Check spelling; make sure name is in the TCP/IP HOST file.

ORA-06106 NETTCP: socket creation failure

Cause: Process open file quota probably exceeded.

Action: Contact Oracle Support Services.

ORA-06107 NETTCP: ORACLE network server not found

Cause: No entry in SERVICES file for Oracle server.

Action: Add (ORASRV) entry to the TCP/IP SERVICES file.

ORA-06108 NETTCP: connect to host failed

Cause: Connection attempt to remote host has failed. Probably means that the SQL*Net TCP/IP server on the remote host is not up, or the host itself is not up (check the latter by targeting it with Telnet).

Action: Start the SQL*Net TCP/IP server process on the remote host.

ORA-06109 NETTCP: message receive failure

Cause: I/O error occurred while attempting network read operation.

Action: Contact Oracle Support Services.

ORA-06110 NETTCP: message send failure

Cause: I/O error occurred while attempting network write operation.

Action: Contact Oracle Support Services.

ORA-06111 NETTCP: disconnect failure

Cause: Error occurred while closing a socket.

Action: Contact Oracle Support Services.

ORA-06112 NETTCP: invalid buffer size

Cause: The buffer size specified in the login string exceeds the allowed maximum (of 4096).

Action: Re-submit with valid buffer size.

ORA-06113 NETTCP: Too many connections

Cause: The maximum no. of concurrently open connections has been reached.

Action: Exit an application with an open connection which is no longer required.

ORA-06114 NETTCP: SID lookup failure

Cause: From the remote host's SQL*Net TCP/IP server: the database SID, specified in the login (connect) string, was not recognized.

Action: Add the appropriate SID entry to the CONFIG.ORA file on the remote host (and restart the SQL*Net TCP/IP server).

ORA-06115 NETTCP: unable to create ORACLE logicals

Cause: The host's SQL*Net TCP/IP server was unable to create the necessary logical names required by the Oracle server process. See the SQL*Net TCP/IP server log file for more details.

Action: Contact your system administrator.

ORA-06116 NETTCP: unable to create ORASRV process

Cause: The host's SQL*Net TCP/IP server was unable to create the Oracle server process. See the SQL*Net TCP/IP server log file for more details.

Action: Contact your system administrator.

ORA-06117 NETTCP: unable to create ORASRV: quota exceeded

Cause: The host's SQL*Net TCP/IP server was unable to create the Oracle server process because of quota depletion.

Action: Increase quota allocations to the SQL*Net TCP/IP server process.

ORA-06118 NETTCP: unable to complete handshake with ORASRV

Cause: The Oracle server process was started but failed to complete its initialization.

Action: Contact Oracle Support Services.

ORA-06119 NETTCP: spurious client request

Cause: The host's SQL*Net TCP/IP server was unable to recognize this connection request. See the SQL*Net TCP/IP server log file for more details.

Action: Contact Oracle Support Services.

ORA-06120 NETTCP: network driver not loaded

Cause: The TCP/IP network driver is not loaded.

Action: Check that the TCP/IP driver is loaded correctly.

ORA-06121 NETTCP: access failure

Cause: The host's SQL*Net TCP/IP server was unable to test the accessibility of the SID mapping file (specified in CONFIG.ORA) associated with this connection request. See the SQL*Net TCP/IP server log file for more details.

Action: Contact Oracle Support Services.

ORA-06122 NETTCP: setup failure

Cause: The host's SQL*Net TCP/IP server was unable to set up the appropriate environment to service this connection request. See the SQL*Net TCP/IP server log file for more details.

Action: Contact Oracle Support Services.

ORA-06123 NETTCP: cannot set KEEPALIVE

Cause: The host's SQL*Net TCP/IP server was unable to set the socket KEEPLIVE option. See the SQL*Net TCP/IP server log file for more details.

Action: Contact Oracle Support Services.

ORA-06124 NETTCP: timeout waiting for ORASRV

Cause: The Oracle server process was started but failed to respond after N seconds.

Action: For heavily loaded systems this is not an uncommon occurrence. Increase the value of N (the default is 30) by placing the following entry in the CONFIG.ORA file: SQLNET ORASRV_WAIT = no_of_secs which will come into effect the next time the SQL*Net TCP/IP server is started.

ORA-06125 NETTCP: ORASRV exited unexpectedly

Cause: The Oracle server process was started but exited unexpectedly. Possible causes:

  1. Insufficient quotas to run ORASRV
  2. Oracle is not installed See the ORASRV output file for more details; the file will be in the ORA_SQLNET directory and will have a name of the form: ORA_SRVTnn_sid.OUT

Action: If appropriate action is not obvious from the ORASRV output file, then contact Oracle Support Services.

ORA-06126 NETTCP: ORASRV unable to open network connection

Cause: The Oracle server process was started but was unable to open the socket passed to it by ORASRV.

Action: Contact Oracle Support Services.

ORA-06127 NETTCP: unable to change username

Cause: The host's SQL*Net TCP/IP server could not establish a PROXY LOGIN connection because the client username is unknown (to the host operating system).

Action: Create new user account on host.

ORA-06128 NETTCP: unable to create mailbox

Cause: The host's SQL*Net TCP/IP server was unable to create a mailbox (needed for IPC communication with the Oracle server process). See the SQL*Net TCP/IP server log file for more details.

Action: Contact Oracle Support Services.

ORA-06129 NETTCP: unable to transfer socket ownership to ORASRV

Cause: The host's SQL*Net TCP/IP server was unable to transfer the network communication handle to the Oracle server process. See the SQL*Net TCP/IP server log file for more details.

Action: Contact Oracle Support Services.

ORA-06130 NETTCP: host access denied

Cause: The host's SQL*Net TCP/IP server rejected this connection request because the client node does not have access privilege - as determined by the contents of the Valid Node Table (VNT), a component of the host's CONFIG.ORA.

Action: To grant access, add appropriate entry to the host's VNT.

ORA-06131 NETTCP: user access denied

Cause: The host's SQL*Net TCP/IP server rejected this connection request because the client user(name) does not have access privilege, as determined by the contents of the Username Mapping Table (UMT), a component of the host's CONFIG.ORA.

Action: To grant access, add appropriate entry to the host's UMT.

ORA-06132 NETTCP: access denied, wrong password

Cause: The host SQL*Net TCP/IP server rejected this connection request because the client password did not match the host password.

Action: To grant access, get passwords in sync.

ORA-06133 NETTCP: file not found

Cause: The host's SQL*Net TCP/IP server could not find the SID mapping file (specified in CONFIG.ORA) associated with this connection request.

Action: Check CONFIG.ORA for spelling; make correct entry.

ORA-06134 NETTCP: file access privilege violation

Cause: The host's SQL*Net TCP/IP server did not have READ/ EXECUTE permission for the SID mapping file (specified in CONFIG.ORA) associated with this connection request.

Action: Change protection on SID mapping file.

ORA-06135 NETTCP: connection rejected; server is stopping

Cause: The host's SQL*Net TCP/IP server rejected this connection request because it is in the process of stopping.

Action: Restart SQL*Net TCP/IP server.

ORA-06136 NETTCP: error during connection handshake

Cause: Network I/O failure occurred while communicating with the host's SQL*Net TCP/IP server. See the SQL*Net TCP/IP server log file for more details.

Action: Contact Oracle Support Services.

ORA-06137 NETTCP: error during connection handshake

Cause: Network I/O failure occurred while communicating with the host's SQL*Net TCP/IP server. See the SQL*Net TCP/IP server log file for more details.

Action: Contact Oracle Support Services.

ORA-06138 NETTCP: error during connection handshake

Cause: Network I/O failure occurred while communicating with the host's SQL*Net TCP/IP server. See the SQL*Net TCP/IP server log file for more details.

Action: Contact Oracle Support Services.

ORA-06140 NETTCP: no such user

Cause: A proxy login connect attempt failed because the client username has no counterpart on the host.

Action: Try again with a user that has a counterpart on the host.

ORA-06141 NETTCP: no privilege for user

Cause: A proxy login connect attempt failed because the SQL*Net TCP/IP server had insufficient privileges to access the proxy account.

Action: Change account protection; change server privileges.

ORA-06142 NETTCP: error getting user information

Cause: A proxy login connect attempt failed because the SQL*Net TCP/IP server was unable to access the proxy account. See the SQL*Net TCP/IP server log file for more details.

Action: Contact Oracle Support Services.

ORA-06143 NETTCP: maximum connections exceeded

Cause: The connect failed because the maximum concurrent connections supported by the host's SQL*Net TCP/IP server has already been reached.

Action: Wait for a short period and retry.

ORA-06144 NETTCP: SID (database) is unavailable

Cause: The database administrator on the host has varied the SID offline.

Action: Wait for it to be varied back online.

ORA-06145 NETTCP: unable to start ORASRV: images not installed

Cause: The host's SQL*Net TCP/IP server was unable to start the Oracle server process because the Oracle protected images were not installed.

Action: Install the images.

ORA-06200 TWOTASK: connect failed, can't create mailbox

ORA-06201 TWOTASK: connect failed, can't attach to mailbox

ORA-06202 TWOTASK: connect failed, can't spawn ORASRV process

ORA-06203 TWOTASK: connect failed, handshake failure

ORA-06204 TWOTASK: connect failed, can't access ORASRV2.COM

ORA-06205 TWOTASK: connect failed, can't create logical name

ORA-06206 TWOTASK: message receive failure

ORA-06207 TWOTASK: message send failure

ORA-06208 TWOTASK: invalid login (connect) string

ORA-06209 TWOTASK: connect failed, mailbox already exists

ORA-06210 TWOTASK: connect failed, ORASRV exited unexpectedly

ORA-06211 TWOTASK: connect failed, timeout waiting for ORASRV

ORA-06212 TWOTASK: connect failed, logical name table is full

ORA-06213 TWOTASK: connect failed

ORA-06214 TWOTASK: connect failed, insufficient quotas to create ORASRV

ORA-06215 TWOTASK: connect failed, ORASRV protected image not installed

ORA-06216 TWOTASK: connect failed, can't find ORASRV image file

ORA-06250 NETNTT: cannot allocate send and receive buffers

Cause: Two-task driver could not allocate data buffers.

Action: There is insufficient memory to run your program. Kill off other processes to free up memory.

ORA-06251 NETNTT: cannot translate address file name

Cause: ORACLE_HOME environment variable not set.

Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported.

ORA-06252 NETNTT: cannot open address file

Cause: The NTT two-task driver could not open a file containing address information.

Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported. Make sure the instance you are attempting to connect to is actually up and running.

ORA-06253 NETNTT: cannot read arguments from address file

Cause: The NTT two-task driver could not read addressing information from its addressing file.

Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported. Make sure the instance you are attempting to connect to is actually up and running.

ORA-06254 NETNTT: cannot share connection to cube

Cause: The NTT two-task driver could not share a connection to the cube.

Action: Make sure that the ORACLE_HOME environment variable has been properly set and exported. Make sure the instance you are attempting to connect to is actually up and running.

ORA-06255 NETNTT: cannot read pid of remote process

Cause: An error occurred while reading the NTT communications link.

Action: Contact Oracle Support Services.

ORA-06256 NETNTT: remote fork failed

Cause: The Oracle listener process on the cube could not fork off a shadow process.

Action: The instance you are trying to connect to probably does not have enough memory to run another shadow process. Ask someone else to log off, or connect to a different instance.

ORA-06257 NETNTT: cannot send command line to shadow process

Cause: An error occurred while writing the NTT communications link.

Action: Contact Oracle Support Services.

ORA-06258 NETNTT: cannot allocate context area

Cause: Two-task driver could not allocate data buffers.

Action: There is insufficient memory to run your program. Kill off other processes to free up memory.

ORA-06259 NETNTT: cannot read from remote process

Cause: An error occurred while reading the NTT communications link.

Action: Contact Oracle Support Services.

ORA-06260 NETNTT: cannot write to remote process

Cause: An error occurred while writing the NTT communications link.

Action: Contact Oracle Support Services.

ORA-06261 NETNTT: nrange() failed

Cause: The call to NRANGE() failed while attempting to establish a connection.

Action: Contact Oracle Support Services.

ORA-06262 NETNTT: nfconn() failed

Cause: The call to NFCONN() failed while attempting to establish a connection.

Action: Contact Oracle Support Services.

ORA-06263 NETNTT: out of memory in pi_connect

Cause: Two-task driver could not allocate data buffers.

Action: There is insufficient memory to run your program. Kill off other processes to free up memory.

ORA-06264 NETNTT: data protocol error

Cause: The NTT two-task driver received an unexpected message type.

Action: Contact Oracle Support Services.

ORA-06265 NETNTT: break protocol error

Cause: The NTT two-task driver received an unexpected message type.

Action: Contact Oracle Support Services.

ORA-06266 NETNTT: bad write length

Cause: The NTT two-task driver failed on an internal consistency check.

Action: Contact Oracle Support Services.

ORA-06267 NETNTT: bad state

Cause: The NTT two-task driver failed on an internal consistency check.

Action: Contact Oracle Support Services.

ORA-06268 NETNTT: cannot read /etc/oratab

Cause: The NTT two-task driver could not read configuration information from /etc/oratab.

Action: Make sure /etc/oratab exists and is readable. This error may occur if the file is incorrectly formatted. It also may occur if the driver has run out of memory.

ORA-06300 IPA: Disconnect failure

Cause: A fatal error occurred during the disconnect from the server. This was probably caused by inaccessible message queues.

Action: If there is no message queue, restart the SQL*Net IPA servers using IPACTL. Otherwise contact Oracle Support Services.

ORA-06301 IPA: Cannot allocate driver context

Cause: The memory pool is exhausted.

Action: Check the circumstances and try to allocate less memory in your program or adjust the parameters in your initialization parameter file and retry.

ORA-06302 IPA: Cannot connect to remote host

Cause: One of the following:

  • There is no ADI server defined to reflect a connection to the specified host.
  • The remote host is not known by the local system.
  • The Oracle kernel on the remote host is not generated with the IPA driver

Action: Check sequentially for the above causes and eliminate the actual cause found.

ORA-06303 IPA: Message send error

Cause: The SQL*Net IPA driver could not write the message into the message queue.

Action: Make sure that the message queue exists and is accessible. If necessary rerun IPACTL.

ORA-06304 IPA: Message receive error

Cause: The SQL*Net IPA driver could not read a message from the message queue.

Action: Make sure that the message queue exists and is accessible. If necessary rerun IPACTL.

ORA-06305 IPA: Illegal message type

Cause: The communication between user and Oracle is out of synchronization. This message should not normally be issued.

Action: Contact Oracle Support Services.

ORA-06306 IPA: Message write length error

Cause: The IPA driver tried to write a message in the queue that was too big for the queue.

Action: Contact Oracle Support Services.

ORA-06307 IPA: Cannot reset connection

Cause: A fatal error occurred during the resetting of the connection.

Action: Contact Oracle Support Services.

ORA-06308 IPA: No more connections available

Cause: You have exhausted all your connections.

Action: Try again when some of the current users have logged off.

ORA-06309 IPA: No message queue available

Cause: The SQL*Net IPA servers have not been started.

Action: Run IPACTL.

ORA-06310 IPA: Environment variable(s) not set

Cause: Environment variable(s) not set correctly.

Action: Check and correct.

ORA-06311 IPA: Maximum number of servers reached

Cause: Maximum number of servers reached.

Action: Shut down and restart with an increased maximum number of servers. Note that database links consume one server per link. Be sure to start enough servers to support database links.

ORA-06312 IPA: Incorrect outgoing service name supplied

Cause: Incorrect outgoing service name supplied.

Action: Check and correct the service name.

ORA-06313 IPA: Shared memory failed to initialise

Cause: The shared memory has not been set up correctly.

Action: Contact your system administrator.

ORA-06314 IPA: Event set up failure

Cause: Fatal interprocess communication error.

Action: Contact your system administrator.

ORA-06315 IPA: Invalid connect string

Cause: The connect string is malformed.

Action: Check and correct.

ORA-06316 IPA: Invalid database SID

Cause: The SID is unknown at the remote side.

Action: Either the database does not exist, is not running, or there are no reserved servers for that SID.

ORA-06317 IPA: Local maximum number of users exceeded

Cause: The maximum number of simultaneous users of SQL*Net IPA has been exceeded on the local side.

Action: Wait for free connections to become available. If the problem persists, contact your system administrator.

ORA-06318 IPA: Local maximum number of connections exceeded

Cause: The maximum number of simultaneous connections that SQL*Net IPA can handle to different hosts has been exceeded on the local side.

Action: Wait for free connections to become available. If the problem persists, contact your system administrator.

ORA-06319 IPA: Remote maximum number of users exceeded

Cause: The maximum number of simultaneous users of SQL*Net IPA has been exceeded on the remote side.

Action: Wait for free connections to become available. If the problem persists, contact your system administrator.

ORA-06320 IPA: Remote maximum number of connections exceeded

Cause: The maximum number of simultaneous connections that SQL*Net IPA can handle from different hosts has been exceeded on the remote side.

Action: Wait for free connections to become available. If the problem persists, contact your system administrator.

ORA-06321 IPA: Cannot reach the remote side

Cause: There has been a timeout on an attempt to connect to a remote server the reason for which is most likely to be the remote SQL*Net IPA software is not running. An alternative reason could be that the remote initiator service name is incorrect.

Action: Check and start the remote SQL*Net software. Check that it is started with the correct service names supplied.

ORA-06322 IPA: Fatal shared memory error

Cause: An internal error has occurred in the shared memory handling.

Action: Contact Oracle Support Services.

ORA-06323 IPA: Cause event error

Cause: Fatal interprocess communication error.

Action: Contact your system administrator.

ORA-06400 NETCMN: No default host string specified

Cause: There was no default host string specified in the configuration and the user did not specify any explicit connect string.

Action: Either reconfigure the system specifying a default connect string or use an explicit connect string.

ORA-06401 NETCMN: invalid driver designator

Cause: The login (connect) string contains an invalid driver designator.

Action: Correct the string and re-submit.

ORA-06402 NETCMN: error receiving break message

Cause: Error occurred while attempting to read a break message.

Action: Contact Oracle Support Services.

ORA-06403 Unable to allocate memory.

Cause: System unable to allocate needed virtual memory.

Action: Configure more memory, reduce load, or try again.

ORA-06404 NETCMN: invalid login (connect) string

Cause: Syntax error in login string.

Action: Correct string and re-submit.

ORA-06405 NETCMN: reset protocol error

Cause: Unable to reset out of break state.

Action: Contact Oracle Support Services.

ORA-06406 NETCMN: error sending break message

Cause: Error occurred while attempting to send a break message.

Action: Contact Oracle Support Services.

ORA-06407 NETCMN: unable to set up break handling environment

Cause: Error occurred while attempting to set up asynchronous handlers for in-coming, out-of-band break messages.

Action: Contact Oracle Support Services.

ORA-06408 NETCMN: incorrect message format

Cause: Message from partner contains bad header.

Action: Contact Oracle Support Services.

ORA-06413 Connection not open.

Cause: Unable to establish connection.

Action: Use diagnostic procedures to ascertain exact problem.

ORA-06416 NETCMN: error on test

Cause: Error occurred while testing I/O status of the network connection.

Action: Contact Oracle Support Services.

ORA-06419 NETCMN: server can not start oracle

Cause: The remote server was unable to start an Oracle process on behalf of the client.

Action: Make sure permissions on the remote Oracle program are correctly set. Contact your system administrator.

ORA-06420 NETCMN: SID lookup failure

Cause: From the remote host's server: the database SID, specified in the login (connect) string, was not recognized.

Action: Add the appropriate SID entry to the CONFIG.ORA or ORATAB file on the remote host (restarting the remote server may be needed).

ORA-06421 NETCMN: Error detected in the read-in data

Cause: Error found during recomputation of checksum or CRC.

Action: Possible hardware failures of communication nodes. Contact system administrator immediately.

ORA-06422 NETCMN: Error in sending data

Cause: Unable to transmit data to remote host.

Action: Try reconnect to remote host, and contact your system administrator.

ORA-06423 NETCMN: Error in receiving data

Cause: Unable to receive data from remote host.

Action: Try reconnect to remote host, and contact your system administrator.

ORA-06430 ssaio: Seals do not match

Cause: A function was called with an invalid argument.

Action: Contact Oracle Support Services.

ORA-06431 ssaio: Invalid Block number

Cause: The file block number is out of range of the file. The additional information returns the block number.

Action: Verify that the block number is correct. Run DBFSIZE and check if the block number is in that range. Contact Oracle Support Services.

ORA-06432 ssaio: Buffer Not Aligned

Cause: The I/O buffer was not aligned on a 2K boundary.

Action: Contact Oracle Support Services.

ORA-06433 ssaio: LSEEK error, unable to seek to requested block.

Cause: The additional information returns the block number.

Action: Look up the additional information returned in your operating system reference manual. Verify that the block number is correct.

ORA-06434 ssaio: read error, unable to read requested block from database file.

Cause: The read system call returned an error.

Action: The additional information indicates the block number. Look up the additional information returned in your operating system manual.

ORA-06435 ssaio: write error, unable to write requested block to database file.

Cause: The write system call returned an error.

Action: The additional information indicates the block number. Look up the additional information returned in your operating system manual.

ORA-06436 ssaio: asynchronous I/O failed due to incorrect parameters.

Cause: The Asynchronous I/O system call returned an error.

Action: The additional information indicates the block number. Look up the additional information returned in your operating system manual.

ORA-06437 ssaio: the asynchronous write was unable to write to the database file.

Cause: The Asynchronous I/O system call returned an error.

Action: The additional information indicates the block number. Look up the additional information returned in your operating system manual.

ORA-06438 ssaio: the asynchronous read was unable to read from the database file.

Cause: The Asynchronous I/O system call returned an error.

Action: The additional information indicates the block number. Look up the additional information returned in your operating system manual.

ORA-06439 ssaio: the asynchronous write returned incorrect number of bytes

Cause: This write call may have been truncated. The additional information returns the block number and number of bytes.

Action: Verify that the block number and the number of bytes written are correct.

ORA-06440 ssaio: the asynchronous read returned incorrect number of bytes

Cause: This read call may have been truncated. The additional information returns the block number and number of bytes.

Action: Verify that the block number and the number of bytes read are correct.

ORA-06441 ssvwatev: Incorrect parameter passed to function call

Cause: Either the Oracle process ID, or wait time or event ID is invalid.

Action: The additional information indicates the process ID, time and event ID.

ORA-06442 ssvwatev: Failed with unexpected error number.

Cause: Some system problems may exist on your system; check the error logs.

Action: The additional information indicates the error number. Look up the additional information returned in your operating system manual.

ORA-06443 ssvpstev: Incorrect parameter passed to function call

Cause: An invalid event ID is passed in to this routine.

Action: The additional information indicates the event ID.

ORA-06444 ssvpstev: Failed with unexpected error number.

Cause: Some system problems may exist on your system; check the error logs.

Action: The additional information indicates the error number. Look up the additional information returned in your operating system manual.

ORA-06445 ssvpstevrg: Incorrect parameters passed to function call

Cause: An invalid event ID, or the low and high event ID do not exist.

Action: The additional information indicates the error number. It also contains the event ID, low boundary and high boundary.

ORA-06446 ssvpstevrg: Failed with unexpected error number.

Cause: Some system problems may exist on your system; check the error logs.

Action: The additional information indicates the error number. Look up the additional information returned in your operating system manual.

ORA-06447 ssvpstp: Incorrect parameter passed to function call

Cause: Invalid Oracle process ID is passed in to this routine.

Action: The additional information indicates the process ID.

ORA-06448 ssvpstp: Failed with unexpected error number.

Cause: Some system problems may exist on your system; check the error logs.

Action: The additional information indicates the error number. Look up the additional information returned in your operating system manual.

ORA-06449 The list IO or the sysvendor is not installed.

Cause: Oracle tries to use the SYSVENDOR interface (INIT.ORA parameter USE_SYSVENDOR=TRUE) but the UNIX kernel does not have the Oracle SYSVENDOR interface linked in.

Action: Set USE_SYSVENDOR=FALSE in INIT.ORA, if you do not want to use this interface or link the UNIX kernel with this interface so that Oracle can use it.

ORA-06500 PL/SQL: storage error

Cause: This is a rare internal error message. Memory has been exhausted or corrupted.

Action: Contact Oracle Support Services.

ORA-06501 PL/SQL: program error

Cause: This is an internal error message. An error has been detected in a PL/SQL program.

Action: Contact Oracle Support Services.

ORA-06502 PL/SQL: numeric or value error string

Cause: An arithmetic, numeric, string, conversion, or constraint error occurred. For example, this error occurs if an attempt is made to assign the value NULL to a variable declared NOT NULL, or if an attempt is made to assign an integer larger than 99 to a variable declared NUMBER(2).

Action: Change the data, how it is manipulated, or how it is declared so that values do not violate constraints.

ORA-06503 PL/SQL: Function returned without value

Cause: A call to PL/SQL function completed, but no RETURN statement was executed.

Action: Rewrite PL/SQL function, making sure that it always returns a value of a proper type.

ORA-06504 PL/SQL: Return types of Result Set variables or query do not match

Cause: Number and/or types of columns in a query does not match declared return type of a result set variable, or declared types of two Result Set variables do not match.

Action: Change the program statement or declaration. Verify what query the variable actually refers to during execution.

ORA-06505 PL/SQL: variable requires more than 32767 bytes of contiguous memory

Cause: A PL/SQL variable was declared with a constraint which required more than 32767 bytes of memory. PL/SQL does not currently support allocations of contiguous memory greater than 32767 bytes.

Action: Consider reducing the constraint in the variable declaration. If that is not possible, try changing the database or national character set to such, that requires less memory for the same constraint. Note: changing the character set will impact execution of all PL/SQL code.

ORA-06508 PL/SQL: could not find program unit being called

Cause: An attempt was made to call a stored program that could not be found. The program may have been dropped or incompatibly modified, or have compiled with errors.

Action: Check that all referenced programs, including their package bodies, exist and are compatible.

ORA-06509 PL/SQL: ICD vector missing for this package

Cause: This indicates a version clash between some package distributed with an Oracle product and the product executable.

Action: Contact Oracle Support Services.

ORA-06510 PL/SQL: unhandled user-defined exception

Cause: A user-defined exception was raised by PL/SQL code, but not handled.

Action: Fix the problem causing the exception or write an exception handler for this condition. Or you may need to contact your application administrator or database administrator.

ORA-06511 PL/SQL: cursor already open

Cause: An attempt was made to open a cursor that was already open.

Action: Close cursor first before reopening.

ORA-06512 at string line string

Cause: Backtrace message as the stack is unwound by unhandled exceptions.

Action: Fix the problem causing the exception or write an exception handler for this condition. Or you may need to contact your application administrator or database administrator.

ORA-06513 PL/SQL: index for PL/SQL table out of range for host language array

Cause: An attempt is being made to copy a PL/SQL table to a host language array. But an index in the table is either less than one or greater than the maximum size of the host language array. When copying PL/SQL tables to host language arrays, the table entry at index 1 is placed in the first element of the array, the entry at index 2 is placed in the second element of the array, etc. If an table entry has not been assigned then the corresponding element in the host language array is set to null.

Action: Increase size of host language array, or decrease size of PL/SQL table. Also make sure that you do not use index values less than 1.

ORA-06514 PL/SQL: The remote call cannot be handled by the server

Cause: The remote call has parameters that are cursor variables or lob variables. This cannot be handled by stored procedures on your server.

Action: Avoid using cursor variables or lob variables as parameters for stored procedures on this server or upgrade your server to a release that supports this.

ORA-06515 PL/SQL: unhandled exception string

Cause: An exception was raised by PL/SQL code, but not handled. The exception number is outside the legal range of Oracle errors.

Action: Fix the problem causing the exception or write an exception handler for this condition. Or you may need to contact your application administrator or database administrator.

ORA-06516 PL/SQL: the Probe packages do not exist or are invalid

Cause: A Probe operation, probably an attempt to initialize the Oracle server to debug PL/SQL, could not be completed because the Probe packages were not loaded or have become invalid.

Action: DBA should load the Probe packages. This can be done by running the PBLOAD.SQL script supplied with the RDBMS.

ORA-06517 PL/SQL: Probe error - string

Cause: An error occurred while passing a Probe operation to the server for execution.

Action: Refer to the entry for the embedded error message.

ORA-06518 PL/SQL: Probe version string incompatible with version string

Cause: The current version of Probe is incompatible with the version on the Oracle server.

Action: Refer to the documentation to ensure that this degree of compatibility is supported.

ORA-06519 active autonomous transaction detected and rolled back

Cause: Before returning from an autonomous PL/SQL block, all autonomous transactions started within the block must be completed (either committed or rolled back). If not, the active autonomous transaction is implicitly rolled back and this error is raised.

Action: Ensure that before returning from an autonomous PL/SQL block, any active autonomous transactions are explicitly committed or rolled back.

ORA-06520 PL/SQL: Error loading external library

Cause: An error was detected by PL/SQL trying to load the external library dynamically.

Action: Check the stacked error (if any) for more details.

ORA-06521 PL/SQL: Error mapping function

Cause: An error was detected by PL/SQL trying to map the mentioned function dynamically.

Action: Check the stacked error (if any) for more details.

ORA-06522 string

Cause: ORA-06520 or ORA-06521could stack this error with a system-specific error string.

Action: This error string should give the cause for errors ORA-06520 or ORA-06521

ORA-06523 Maximum number of arguments exceeded

Cause: There is an upper limit on the number of arguments that one can pass to the external function.

Action: Check the port-specific documentation on how to calculate the upper limit.

ORA-06524 Unsupported option : string

Cause: The option specified is an unsupported feature for external procedures.

Action: Correct the syntax in the external specification.

ORA-06525 Length Mismatch for CHAR or RAW data

Cause: The length specified in the length variable has an illegal value. This can happen if you have requested a PL/SQL INOUT, OUT or RETURN raw variable to be passed as a RAW with no corresponding length variable. This error can also happen if there is a mismatch in the length value set in the length variable and the length in the ORLVSTR or ORLRAW.

Action: Correct the external procedure code and set the length variable correctly.

ORA-06526 Unable to load PL/SQL library

Cause: PL/SQL was unable to instantiate the library referenced by this referenced in the EXTERNAL syntax. This is a serious error and should normally not happen.

Action: Report this problem to Oracle Support Services.

ORA-06527 External procedure SQLLIB error: string

Cause: An error occurred in SQLLIB during execution of a Pro* external procedure.

Action: The message text indicates the actual SQLLIB error that occurred.

ORA-06528 Error executing PL/SQL profiler

Cause: An error occurred during execution of a PL/SQL profiler procedure.

Action: Check the stacked errors for more details.

ORA-06529 Version mismatch - PL/SQL profiler

Cause: The PL/SQL profiler package (DBMSPB.SQL, PRVTPBP.PLB) does not match the version of the code in the server implementing the profiler.

Action: Run the package PROFLOAD.SQL in $ORACLE_HOME/rdbms/admin to load the correct version of the PL/SQL profiler packages.

ORA-06530 Reference to uninitialized composite

Cause: An object, LOB, or other composite was referenced as a left hand side without having been initialized.

Action: Initialize the composite with an appropriate constructor or whole-object assignment.

ORA-06531 Reference to uninitialized collection

Cause: An element or member function of a nested table or VARRAY was referenced (where an initialized collection is needed) without the collection having been initialized.

Action: Initialize the collection with an appropriate constructor or whole-object assignment.

ORA-06532 Subscript outside of limit

Cause: A subscript was greater than the limit of a VARRAY or non-positive for a VARRAY or nested table.

Action: Check the program logic and increase the VARRAY limit if necessary.

ORA-06533 Subscript beyond count

Cause: An in-limit subscript was greater than the count of a VARRAY or too large for a nested table.

Action: Check the program logic and explicitly extend if necessary.

ORA-06534 cannot access Serially Reusable package string in the context of a trigger

Cause: The program attempted to access a Serially Reusable package in the context of a trigger. Such an access is currently unsupported.

Action: Check the program logic and remove any references to Serially Reusable packages (procedure, function or variable references) which might happen in the context of a trigger.

ORA-06535 statement string in string is NULL or 0 length

Cause: The program attempted to use a dynamic statement string that was either NULL or 0 length.

Action: Check the program logic and ensure that the dynamic statement string is properly initialized.

ORA-06536 IN bind variable bound to an OUT position

Cause: The program attempted to bind an IN bind variable to a statement that was expecting an OUT bind variable at that position.

Action: Make sure that an OUT or IN OUT bind mode is specified for the bind argument.

ORA-06537 OUT bind variable bound to an IN position

Cause: The program attempted to bind an OUT bind variable to a statement that was expecting an IN bind variable at that position.

Action: Make sure that an IN or IN OUT bind mode is specified for the bind argument.

ORA-06538 statement violates string RESTRICT_REFERENCES pragma

Cause: The program attempted to execute a dynamic statement which does not meet the purity level specified (in the pragma RESTRICT_REFERENCES directive) for the module executing the statement.

Action: Ensure that the dynamic statement meets the purity level specified for the module executing the statement.

ORA-06539 target of OPEN must be a query

Cause: The program attempted to perform an OPEN cursor operation on a dynamic statement that was not a query.

Action: Ensure that the OPEN cursor operation is done on a dynamic query statement.

ORA-06540 PL/SQL: compilation error

Cause: A PL/SQL compilation error occurred. However, the user generally will not see this error message. Instead, there will be accompanying PLS-nnnnn error messages.

Action: See accompanying PLS-nnnnn error messages.

ORA-06541 PL/SQL: compilation error - compilation aborted

Cause: A PL/SQL compilation error occurred and the compilation was aborted; but the compilation unit was written out to the backing store. However, unlike ORA-06545, the user generally will not see this error message. Instead, there will be accompanying PLS-nnnnn error messages.

Action: See accompanying PLS-nnnnn error messages.

ORA-06544 PL/SQL: internal error, arguments: [string], [string], [string], [string], [string], [string], [string], [string]

Cause: A PL/SQL internal error occurred.

Action: Report as a bug; the first argument is the internal error number.

ORA-06545 PL/SQL: compilation error - compilation aborted

Cause: A PL/SQL compilation error occurred and the compilation was aborted completely without the compilation unit being written out to the backing store. Unlike ORA-06541, the user will always see this error along with the accompanying PLS-nnnnn error messages.

Action: See accompanying PLS-nnnnn error messages.

ORA-06546 DDL statement is executed in an illegal context

Cause: DDL statement is executed dynamically in illegal PL/SQL context.

  • Dynamic OPEN cursor for a DDL in PL/SQL
  • Bind variables used in the USING clause to EXECUTE IMMEDIATE a DDL
  • Define variables used in the INTO clause to EXECUTE IMMEDIATE a DDL

Action: Use EXECUTE IMMEDIATE without USING and INTO clauses to execute the DDL statement.

ORA-06547 RETURNING clause must be used with INSERT, UPDATE, or DELETE statements

Cause: EXECUTE IMMEDIATE with a RETURNING clause is used to execute dynamic UPDATE, INSERT, or DELETE statements only.

Action: Use the RETURNING clause in EXECUTE IMMEDIATE for INSERT, UPDATE, or DELETE statements only. For other statements, use the USING clause instead.

ORA-06548 no more rows needed

Cause: The caller of a pipelined function does not need more rows to be produced by the pipelined function.

Action: Catch the NO_DATA_NEEDED exception is an exception handling block.

ORA-06549 PL/SQL: failed to dynamically open shared object (DLL): string

Cause: One possible cause might be that there are too many DLLs open at the same time.

ORA-06550 line string, column string:string

Cause: A PL/SQL compilation error has occurred. The numbers given for line and column are the location in the PL/SQL block where the error occurred.

Action: Refer to the following PL/SQL messages for more information about the error.

ORA-06551 PL/SQL: Unhandled exception

ORA-06552 PL/SQL: string

ORA-06553 PLS-string: string

ORA-06554 package DBMS_STANDARD must be created before using PL/SQL

Cause: The DBMS-specific extensions to PL/SQL's package STANDARD are in package DBMS_STANDARD. This package must be created before using PL/SQL.

Action: Create package DBMS_STANDARD. The source for this PL/SQL stored package is provided with the distribution.

ORA-06555 this name is currently reserved for use by user SYS

Cause: An attempt was made to create a package named STANDARD, DBMS_STANDARD or DEBUG_IO. These are currently reserved for use by user SYS.

Action: Choose another name for your package.

ORA-06556 the pipe is empty, cannot fulfill the unpack_message request

Cause: There are no more items in the pipe.

Action: Check that the sender and receiver agree on the number and types of items placed on the pipe.

ORA-06557 null values are not allowed for any parameters to pipe icd's

Cause: Internal error from the DBMS_PIPE package.

Action: Contact Oracle Support Services.

ORA-06558 buffer in dbms_pipe package is full. No more items allowed

Cause: The pipe buffer size has been exceeded.

Action: Inspect the program to analyze the rate of input and output to the pipe. You might need to take items out of the pipe by executing RECEIVE_MESSAGE, or empty the entire pipe by executing PURGE on the pipe.

ORA-06559 wrong datatype requested, string, actual datatype is string

Cause: The sender put different datatype on the pipe than that being requested (package DBMS_PIPE). The numbers are:

  • 6 - number
  • 9 - char
  • 12 - date

Action: Check that the sender and receiver agree on the number and types of items placed on the pipe.

ORA-06560 pos, string, is negative or larger than the buffer size, string

Cause: Internal error from the DBMS_PIPE package.

Action: Contact Oracle Support Services.

ORA-06561 given statement is not supported by package DBMS_SQL

Cause: An attempt was made to parse an unsupported statement using procedure PARSE provided by package DBMS_SQL.

Action: Only statements which begin with SELECT, DELETE, INSERT, UPDATE, LOCK, BEGIN, DECLARE, or << (PL/SQL label delimiter) are supported.

ORA-06562 type of out argument must match type of column or bind variable

Cause: An attempt was made to get the value of a column or a bind variable by calling procedure COLUMN_VALUE or VARIABLE_VALUE of package DBMS_SQL but the type of the given out argument where to place the value is different from the type of the column or bind variable that was previously defined by calling procedure DEFINE_COLUMN (for defining a column) or BIND_VARIABLE (for binding a bind variable) of package DBMS_SQL.

Action: Pass in an out argument of the correct type when calling procedure COLUMN_VALUE or VARIABLE_VALUE. The right type is the type that was provided when defining the column or binding the bind variable.

ORA-06563 top level procedure/function specified, cannot have subparts

Cause: The name to be resolved was specified with three parts (a.b.c) but the a.b part resolves to a top level procedure or function (which do not have nested procedures). This can also happen with a two-part name, a.b, where a is a synonym for a top level package or procedure.

Action: Specify a procedure/function within a package, or a top level procedure/function.

ORA-06564 object string does not exist

Cause: The named object could not be found. Either it does not exist or you do not have permission to access it.

Action: Create the object or get permission to access it.

ORA-06565 cannot execute string from within stored procedure

Cause: The named procedure cannot be executed from within a stored procedure, function or package. This function can only be used from PL/SQL anonymous blocks.

Action: Remove the procedure from the calling stored procedure.

ORA-06566 invalid number of rows specified

Cause: An invalid number of rows was specified in a call to the procedure DEFINE_COLUMN in the package DBMS_SQL. For a given parsed statement in a given cursor, all columns must be defined to have the same number of rows, so all the calls to DEFINE_COLUMN must specify the same number of rows.

Action: Specify a number that matches that for previously defined columns.

ORA-06567 invalid number of values specified

Cause: An invalid number of values to be bound was specified in a call to the procedure BIND_VARIABLE in the package DBMS_SQL. In order to execute a given parsed statement in a given cursor, the same number of values must have been bound for all bind variables, so when EXECUTE is called, the latest calls to BIND_VARIABLE must have specified the same number of values to be bound for all bind variables.

Action: Make sure that the same number of values have been bound for all of the bind variables.

ORA-06568 obsolete ICD procedure called

Cause: An obsolete ICD procedure was called by a PL/SQL program. The PL/SQL program was probably written for an earlier release of RDBMS.

Action: Make sure that all PL/SQL programs have been upgraded to the latest release of the RDBMS. This can be accomplished by following upgrade instructions in the README file, or by running the CATPROC.SQL script supplied with the RDBMS.

ORA-06569 Collection bound by bind_array contains no elements

Cause: A collection with zero elements was bound to a bind variable in a call to procedure BIND_ARRAY in the package DBMS_SQL. In order to execute a bind of a collection, the collection must contain at least one element. If no elements are present, at execute time, there will be no value for this bind and the statement is meaningless.

Action: Fill the collection with the elements you want to bind and try the bind call again.

ORA-06570 shared pool object does not exist, cannot be pinned

Cause: The specified shared pool shared cursor could not be found, therefore it cannot be pinned.

Action: Make sure that a correct shared cursor name is given. Names are a string of the form 'HHHHHHHH,SDDDDDDDDDD' where the H's are an 8 digit hex number from the 'address' column of V$SQLAREA, and the D's are a 1 to 10 digit decimal number with an optional leading sign (from the HASH_VALUE column) Remove the procedure from the calling stored procedure.

ORA-06571 Function string does not guarantee not to update database

Cause: One of the following:

  • A SQL statement references a packaged, PL/SQL function that does not contain a pragma that prevents the database from being updated.
  • A SQL statement references a standalone, PL/SQL function that contains an instruction to update the database.

Action: If the referenced function is a packaged, PL/SQL function, re-create the PL/SQL function with the required pragma; be certain to include the 'Write No Database State' (WNDS) argument in the argument list of the pragma. If the referenced function is standalone, PL/SQL function, do not use the function.

ORA-06572 Function string has out arguments

Cause: A SQL statement references either a packaged or standalone PL/SQL function that contains an OUT parameter in its argument list. PL/SQL functions referenced by SQL statements must not contain the OUT parameter.

Action: Re-create the PL/SQL function without the OUT parameter in the argument list.

ORA-06573 Function string modifies package state, cannot be used here

Cause: One of the following:

  • A SQL statement references a packaged, PL/SQL function that does not contain a pragma containing the 'Write no Package State' (WNPS).
  • A SQL statement references a standalone, PL/SQL function that modifies a package state. A standalone, PL/SQL function referenced by a SQL statement cannot modify a package state.

Action: If the function is a packaged, PL/SQL function: Re-create the function and include a pragma containing the 'Write no Package State' (WNPS). If the function is standalone PL/SQL function, delete the function from the SQL statement.

ORA-06574 Function string references package state, cannot execute remotely

Cause: One of the following:

  • A remote, packaged function or a remote-mapped, local, packaged function that does not contain a pragma with the 'Write no Package State' (WNPS) and 'Read no Package State' (RNPS) arguments references a package state.
  • A remote, standalone function or a remote-mapped, local, standalone function contains a reference to a package state (reads or writes a package variable). Only local functions that are referenced in a SELECT list, VALUES clause of an INSERT statement, or SET clause of an UPDATE statement can modify a package state.

Action: If the function is a packaged function: Re-create the function and include a pragma containing the 'Write no Package State' (WNPS) and 'Read no Package State' (RNPS) arguments. If the function is a standalone function: Do not call the function.

ORA-06575 Package or function string is in an invalid state

Cause: A SQL statement references a PL/SQL function that is in an invalid state. Oracle attempted to compile the function, but detected errors.

Action: Check the SQL statement and the PL/SQL function for syntax errors or incorrectly assigned, or missing, privileges for a referenced object.

ORA-06576 not a valid function or procedure name

Cause: Could not find a function (if an INTO clause was present) or a procedure (if the statement did not have an INTO clause) to call.

Action: Change the statement to invoke a function or procedure.

ORA-06577 output parameter not a bind variable

Cause: The argument corresponding to an IN/OUT or OUT parameter for a function or a procedure or a function return value in a CALL statement must be a bind variable.

Action: Change the argument to a bind variable.

ORA-06578 output parameter cannot be a duplicate bind

Cause: The bind variable corresponding to an IN/OUT or OUT parameter for a function or a procedure or a function return value in a CALL statement cannot be a duplicate bind variable.

Action: Change the bind variable to be unique.

ORA-06580 Hash Join ran out of memory while keeping large rows in memory

Cause: Hash Join reserves 3 slots (each slot size = DB_BLOCK_SIZE * HASH_MULTIBLOCK_IO_COUNT) for a row. If a row is larger than that, this error will be raised.

Action: Increase HASH_MULTIBLOCK_IO_COUNT so that each joined row fits in a slot. HASH_AREA_SIZE may also need to be increased.

ORA-06592 CASE not found while executing CASE statement

Cause: A CASE statement must either list all possible cases or have an else clause.

Action: Add all missing cases or an ELSE clause.

ORA-06593 string is not supported with natively compiled PL/SQL modules

Cause: The specified feature is not yet supported for natively compiled PL/SQL modules.

Action: Recompile the relevant PL/SQL modules in non-native mode by setting the PLSQL_COMPILER_FLAGS parameter to INTERPRETED.

ORA-06600 LU6.2 Driver: SNA software is not loaded

Cause: The SNA software is not running.

Action: Start the SNA software and try again.

ORA-06601 LU6.2 Driver: Invalid database ID string

Cause: The database string in the connect was invalid.

Action: Provide a valid database string, as defined in documentation.

ORA-06602 LU6.2 Driver: Error allocating context area

Cause: Context area failure.

Action: Contact Oracle Support Services.

ORA-06603 LU6.2 Driver: Error allocating memory

Cause: Operating system refused request for memory.

Action: Contact Oracle Support Services.

ORA-06604 LU6.2 Driver: Unable to allocate session with remote LU

Cause: Allocate system call failed.

Action: Ensure that the SNA software is running and that sessions are free. If this is the case, then check your SNA configuration data for errors. You may have entered an incorrect parameter.

ORA-06605 LU6.2 Driver: Unexpected line turnaround

Cause: SNA software switched from send to receive unexpectedly.

Action: Check the SNA configuration data, particularly parameters associated with a session.

ORA-06606 LU6.2 Driver: Unexpected response from SNA

Cause: A parameter in an SNA call returned an unexpected value.

Action: Attempt to reproduce problem, debug and record the value of the 'what' data parameter at the time of error. Then contact your service representative.

ORA-06607 LU6.2 Driver: Reset occurred in send state

Cause: A reset was issued while in send state.

Action: Check the SNA LOG data, if relevant, for further information.

ORA-06608 LU6.2 Driver: Reset occurred in receive state

Cause: A reset was received from the partner while in receive state. This may be because the partner deallocated.

Action: Check the SNA LOG data, if relevant, for further information.

ORA-06610 LU6.2 Driver: Failed during deallocation

Cause: LU6.2 driver was unable to deallocate gracefully.

Action: Check the reason for deallocation. Consult the SNA LOG data.

ORA-06611 LU6.2 Driver: Request to send error

ORA-06612 LU6.2 Driver: Send data error

ORA-06613 LU6.2 Driver: Receive and wait error

ORA-06614 LU6.2 Driver: Receive Immediate error

ORA-06615 LU6.2 Driver: Send error

ORA-06616 LU6.2 Driver: Attach to LU failed

Cause: The SQL*Net LU6.2 driver was unable to attach to the LU specified in the connect string, or was unable to attach to the default LU.

Action: Check that the LU name specified in the connect string, or the default LU name if no LU was specified, is correctly configured and operational.

ORA-06617 LU6.2 Driver: Attach to PU failed

ORA-06618 LU6.2 Driver: Activation of subnetwork failed

ORA-06619 LU6.2 Driver: Unable to activate remote partner

ORA-06620 LU6.2 Driver: Invalid remote partner

ORA-06621 LU6.2 Driver: Allocation error

ORA-06622 LU6.2 Driver: Unable to attach to SNA

Cause: The SQL*Net LU6.2 driver could not attach to the SNA software on your machine. The most likely cause is that the SNA software is not operational.

Action: Check the status of the SNA software, ensure that it is operational and then try again.

ORA-06700 TLI Driver: incorrect message type from host

Cause: TLI received a message with an unrecognizable message type.

Action: Contact Oracle Support Services.

ORA-06701 TLI Driver: incorrect number of bytes written

Cause: TLI sent a message that was apparently successful, but the number of bytes transmitted did not match the number of bytes supplied to the driver.

Action: Contact Oracle Support Services.

ORA-06702 TLI Driver: cannot allocate context area

Cause: TLI could not allocate heap space for the context area.

Action: Contact Oracle Support Services.

ORA-06703 TLI Driver: send break message failed

Cause: TLI failed to send a break message across the connection.

Action: Contact Oracle Support Services.

ORA-06704 TLI Driver: receive break message failed

Cause: TLI failed to receive an expected break message.

Action: Contact Oracle Support Services.

ORA-06705 TLI Driver: remote node is unknown

Cause: TLI could not find your remote host information.

Action: Make sure you specified the host name correctly on the command line. (Also, check your capitalization and spelling.)

ORA-06706 TLI Driver: service not found

Cause: TLI could not find service information for the specified service name.

Action: If you specified the service name on the command line or with the environment variable TLI_SERVER, make sure you specified it correctly. If the service name is not in the SERVICES file for your protocol, ask your system administrator to add it.

ORA-06707 TLI Driver: connection failed

Cause: TLI failed to establish the connection to a SQL*Net TCP/IP server due to an error encountered by the remote server, which has supplied a string describing the remote error.

Action: See the SQL*Net TCP/IP User's Guide or the Oracle9i Net Services Administrator's Guide for the specific cause and action.

ORA-06708 TLI Driver: message receive failure

Cause: TLI encountered an error receiving a message from the communication channel.

Action: Contact Oracle Support Services.

ORA-06709 TLI Driver: message send failure

Cause: TLI encountered an error sending a message across the communication channel.

Action: Contact Oracle Support Services.

ORA-06710 TLI Driver: send interrupt break message failed

Cause: TLI failed to send a break message while handling an interrupt signal from the user.

Action: Contact Oracle Support Services.

ORA-06711 TLI Driver: error on bind

Cause: TLI failed to assign a network address to the communication channel.

Action: Contact Oracle Support Services.

ORA-06712 TLI Driver: error on accept

Cause: TLI failed to accept a connection request from the client.

Action: Contact Oracle Support Services.

ORA-06713 TLI Driver: error on connect

Cause: TLI failed to connect the client to the remote server. The network line to the remote host may be down.

Action: Use other network login programs to make sure that the remote host is accessible.

ORA-06720 TLI Driver: SID lookup failure

Cause: The database SID supplied in the database login string was not recognized by the remote host.

Action: Ask your system administrator to add the appropriate SID entry to ORATAB on the remote host.

ORA-06721 TLI Driver: spurious client req

Cause: The remote TLI server received an undefined request.

Action: Contact Oracle Support Services.

ORA-06722 TLI Driver: connection setup failure

Cause: The remote TLI server rejected the connection request, and the client was unable to retrieve an error code or message.

Action: Contact Oracle Support Services.

ORA-06730 TLI Driver: unable to open clone device

Cause: TLI failed to open the Streams clone device associated with the transport provider.

Action: Contact Oracle Support Services.

ORA-06731 TLI Driver: cannot alloc t_call

Cause: TLI cannot allocate space for the client's connection information.

Action: Contact Oracle Support Services.

ORA-06732 TLI Driver: cannot alloc t_discon

Cause: TLI cannot allocate space for the client's disconnection information.

Action: Contact Oracle Support Services.

ORA-06733 TLI Driver: failed to receive disconnect

Cause: TLI failed to receive an expected disconnection message during connection release.

Action: Contact Oracle Support Services.

ORA-06734 TLI Driver: cannot connect

Cause: TLI failed to connect the client to the remote server.

Action: Check that the remote TLI server is running.

ORA-06735 TLI Driver: client failed to close error conn

Cause: TLI failed to properly close a connection after an error was received.

Action: Contact Oracle Support Services.

ORA-06736 TLI Driver: server not running

Cause: TLI timed out while attempting to connect to the remote TLI server.

Action: Check that the remote TLI server is running with the status utility for the transport provider you are using. If it is not, ask your system administrator to start it.

ORA-06737 TLI Driver: connection failed

Cause: TLI could not establish a connection to the remote TLI server.

Action: Check that the remote TLI server is running with the status utility for the transport provider you are using.

ORA-06741 TLI Driver: unable to open protocol device

Cause: The TLI server failed to open the Streams device associated with the transport provider.

Action: Contact Oracle Support Services.

ORA-06742 TLI Driver: cannot alloc t_bind

Cause: The TLI server cannot allocate space for its requested network address.

Action: Contact Oracle Support Services.

ORA-06743 TLI Driver: cannot alloc t_bind

Cause: The TLI server cannot allocate space for its actual network address.

Action: Contact Oracle Support Services.

ORA-06744 TLI Driver: listener cannot bind

Cause: The TLI server failed to assign the correct network address on which to listen for connections.

Action: Contact Oracle Support Services.

ORA-06745 TLI Driver: listener already running

Cause: The network address on which the TLI server awaits connection requests is in use, possibly because the server is already running.

Action: Ensure that the TLI server is not already running. If it is not running and this error message recurs, contact Oracle Support Services.

ORA-06746 TLI Driver: cannot alloc t_call

Cause: TLI cannot allocate space for the TLI server's connection information.

Action: Contact Oracle Support Services.

ORA-06747 TLI Driver: error in listen

Cause: The TLI server encountered an error while listening for connection requests.

Action: Contact Oracle Support Services.

ORA-06748 TLI Driver: cannot allocate t_discon

Cause: TLI cannot allocate space for the TLI server's disconnection information.

Action: Contact Oracle Support Services.

ORA-06749 TLI Driver: option not allowed across network

Cause: The requested TLI server command must be issued from the same host on which the server is running.

Action: Log in to the remote host and try again.

ORA-06750 TLI Driver: sync failed

Cause: The Oracle process started by the TLI server was unable to synchronize its inherited connection.

Action: Contact Oracle Support Services.

ORA-06751 TLI Driver: bound addresses unequal

Cause: The OSN check server address failed. The bound server address was not the same as the requested binding address.

Action: Contact Oracle Support Services.

ORA-06752 TLI: error in signal setup

Cause: A call to SIGACTION() returned with a system error.

Action: Contact Oracle Support Services.

ORA-06753 TLI Driver: name-to-address mapping failed

Cause: For SVR4, the NETDIR_GETBYNAME() call failed for some unknown reason.

Action: Contact Oracle Support Services.

ORA-06754 TLI Driver: unable to get local host address

Cause: The name of the remote host to connect to was not specified, and the name of the local host cannot be retrieved from the HOSTS file.

Action: Contact your system administrator.

ORA-06755 TLI Driver: cannot close transport endpoint

Cause: The TLI server was unable to close a connection after passing it to an Oracle process.

Action: Contact Oracle Support Services.

ORA-06756 TLI Driver: cannot open oratab

Cause: The TLI server could not open the file used to define the locations of remotely accessible databases.

Action: Ask your system administrator to check that the file exists and has the correct permissions.

ORA-06757 TLI Driver: server got bad command

Cause: The TLI server received an invalid command.

Action: Contact Oracle Support Services.

ORA-06760 TLI Driver: timeout reading orderly release

Cause: TLI was not able to retrieve an expected disconnect message while closing the communication channel.

Action: Contact Oracle Support Services.

ORA-06761 TLI Driver: error sending orderly release

Cause: TLI encountered an error sending a disconnect message closing the communication channel.

Action: Contact Oracle Support Services.

ORA-06762 TLI Driver: error reading orderly release

Cause: TLI encountered an error receiving an expected disconnect message while closing the communication channel.

Action: Contact Oracle Support Services.

ORA-06763 TLI Driver: error sending disconnect

Cause: TLI encountered an error sending a disconnect message closing the communication channel.

Action: Contact Oracle Support Services.

ORA-06764 TLI Driver: error reading disconnect

Cause: TLI was not able to retrieve an expected disconnect message while closing the communication channel.

Action: Contact Oracle Support Services.

ORA-06765 TLI Driver: error awaiting orderly release

Cause: TLI encountered an error awaiting a disconnect message while closing the communication channel.

Action: Contact Oracle Support Services.

ORA-06766 TLI Driver: close failed during release

Cause: TLI failed to close the communication channel after receiving a disconnect message.

Action: Contact Oracle Support Services.

ORA-06767 TLI Driver: alloc failed during release

Cause: TLI cannot allocate space for disconnection information while closing the communication channel.

Action: Contact Oracle Support Services.

ORA-06770 TLI Driver: error sending version

Cause: TLI encountered an error while sending its version information during connection establishment.

Action: Contact Oracle Support Services.

ORA-06771 TLI Driver: error reading version

Cause: TLI encountered an error while awaiting the expected version information during connection establishment.

Action: Contact Oracle Support Services.

ORA-06772 TLI Driver: error sending command

Cause: TLI encountered an error while sending a command message during connection establishment.

Action: Contact Oracle Support Services.

ORA-06773 TLI Driver: error reading command

Cause: TLI encountered an error while awaiting the expected command message during connection establishment.

Action: Contact Oracle Support Services.

ORA-06774 TLI Driver: error sending break mode

Cause: TLI encountered an error while sending break-mode message during connection establishment.

Action: Contact Oracle Support Services.

ORA-06775 TLI Driver: error reading break mode

Cause: TLI encountered an error while awaiting the expected break-mode message during connection establishment.

Action: Contact Oracle Support Services.

ORA-06776 TLI Driver: error sending parms

Cause: TLI encountered an error while sending the connection parameters during connection establishment.

Action: Contact Oracle Support Services.

ORA-06777 TLI Driver: error reading parms

Cause: TLI encountered an error while awaiting the expected connection parameter message during connection establishment.

Action: Contact Oracle Support Services.

ORA-06778 TLI Driver: error sending ccode

Cause: TLI encountered an error while sending the completion status message during connection establishment.

Action: Contact Oracle Support Services.

ORA-06779 TLI Driver: error reading ccode

Cause: TLI encountered an error while awaiting the expected completion status message during connection establishment.

Action: Contact Oracle Support Services.

ORA-06780 TLI Driver: recv error code failed

Cause: TLI encountered an error while awaiting an expected error message during connection establishment.

Action: Contact Oracle Support Services.

ORA-06781 TLI Driver: error reading negotation string

Cause: TLI encountered an error while awaiting the expected negotiation message during connection establishment.

Action: Contact Oracle Support Services.

ORA-06790 TLI Driver: poll failed

Cause: TLI was unable to poll the communication channel for possible incoming messages.

Action: Contact Oracle Support Services.

ORA-06791 TLI Driver: poll returned error event

Cause: TLI received an unexpected event while polling the communication channel for possible incoming messages.

Action: Contact Oracle Support Services.

ORA-06792 TLI Driver: server cannot exec oracle

Cause: The remote TLI server was unable to start an Oracle process on behalf of the client.

Action: Note the operating system error message or number and contact your system administrator. The permissions on the remote Oracle program may be set incorrectly.

ORA-06793 TLI Driver: server cannot create new process

Cause: The remote TLI server was unable to start an Oracle process on behalf of the client.

Action: Note the operating system error message or number and contact your system administrator. The remote host may be unable to create any new processes due to a full process table.

ORA-06794 TLI Driver: shadow process could not retrieve protocol info

Cause: The Oracle process either failed to allocate memory to store the protocol information record, or the protocol rejected the request for some unknown reason.

Action: Contact Oracle Support Services.

ORA-06800 TLI Driver: SQL*Net SPX client went away during reconnect

Cause: The client process was aborted by the system or the user, and was unable to complete the connection establishment with the server listener process.

Action: Determine the cause of the client exit, and reattempt the connection.

ORA-06801 TLI Driver: listen for SPX server reconnect failed

Cause: An unknown event occurred on the client's listening socket.

Action: Contact Oracle Support Services.

ORA-06802 TLI Driver: could not open the /etc/netware/yellowpages file

Cause: The /etc/netware/yellowpages file does not exist, or is not readable by the TLI listener process.

Action: Insure the file exists and is readable. Make sure that the server machine's node name, network number, ethernet address, and listening socket number are encoded in the file.

ORA-06803 TLI Driver: the IPX device file could not be opened

Cause: The /dev/ipx file does not exist, or the driver has not been installed in the kernel correctly.

Action: Reinvoke the Oracle root installation. If problem continues, contact Oracle Support Services.

ORA-06804 TLI Driver: could not bind an IPX address at initialization

Cause: The IPX driver has not been correctly installed.

Action: Reinvoke the Oracle root installation. If problem continues, contact Oracle Support Services.

ORA-06805 TLI Driver: could not send datagram SAP packet for SPX

Cause: The socket endpoint for sending SAP packet was corrupted for some unknown reason.

Action: Contact Oracle Support Services.

ORA-06806 TLI Driver: could not complete protocol initialization for SPX

Cause: A step in the SPX/IPX protocol initialization failed.

Action: Check the previous error reported, and follow corrective action.

ORA-06807 TLI Driver: could not open ethernet device driver file

Cause: The file /dev/eth does not exist, or the driver it references could not be opened.

Action: The system's real ethernet device file, for example /dev/wd, for the Western Digital ethernet driver, should be linked to the file /dev/eth. If this has been done, insure that the ethernet driver has been installed by completing the TCP/IP installation on your system, and testing a connection. If problem continues, contact Oracle Support Services for a list of supported ethernet drivers.

ORA-06808 TLI Driver: could not link IPX and ethernet streams

Cause: Either the ethernet driver has not been installed in the system correctly, or the ethernet driver is not supported.

Action: Insure that the ethernet driver has been installed by completing the TCP/IP installation on your system, and testing a connection. If problem continues, contact Oracle Support Services for a list of supported ethernet drivers.

ORA-06809 TLI Driver: could not clear the IPX ethernet SAP at init

Cause: The IPX driver has not been correctly installed.

Action: Reinvoke the Oracle root installation. If problem continues, contact Oracle Support Services.

ORA-06810 TLI Driver: could not set the IPX ethernet SAP at init

Cause: The IPX driver has not been correctly installed.

Action: Reinvoke the Oracle root installation. If problem continues, contact Oracle Support Services.

ORA-06811 TLI Driver: could not set the IPX network number at init

Cause: The IPX driver has not been correctly installed, or the network number encoded in the /etc/netware/yellowpages file is invalid.

Action: The network number in the yellowpages file should match the four-byte network number of your Novell file server. If this is configured correctly, reinvoke the Oracle root installation. If problem continues, contact Oracle Support Services.

ORA-06812 TLI Driver: could not read the ethernet driver's node address

Cause: The ethernet driver is not installed correctly, or does not support this operation.

Action: Contact Oracle Support Services for a list of supported ethernet drivers.

ORA-06813 TLI Driver: the configured ethernet address is incorrect

Cause: The node address read from the ethernet driver does not match the value encoded in the /etc/netware/yellowpages file for this server.

Action: Confirm the correct ethernet node address for your LAN card, and enter this value in the yellowpages file.

ORA-06814 TLI Driver: the SPX device file could not be opened

Cause: The /dev/nspxd file does not exist, or the driver has not been installed in the kernel correctly.

Action: Reinvoke the Oracle root installation. If problem continues, contact Oracle Support Services.

ORA-06815 TLI Driver: could not link SPX and IPX streams

Cause: The SPX driver has not been correctly installed.

Action: Reinvoke the Oracle root installation. If problem continues, contact Oracle Support Services.

ORA-06816 TLI Driver: could not set the SPX SAP address

Cause: The SPX driver has not been correctly installed.

Action: Reinvoke the Oracle root installation. If problem continues, contact Oracle Support Services.

ORA-06817 TLI Driver: could not read the Novell network address

Cause: The file $ORACLE_HOME/spx/address could not be opened for reading and writing.

Action: Make sure ORACLE_HOME is set, and the permissions on the ORACLE_HOME are read, write. If this file has been unintentionally deleted, run SPXCTL (net option) to reset the configured Novell network number for SQL*Net SPX.

ORA-06900 CMX: cannot read tns directory

Cause: CMX is not started on your system.

Action: Install and/or start CMX on your system.

ORA-06901 CMX: no local name assigned to local application

Cause: Local application ORACMX has no local name assigned.

Action: Enter unique local name for ORACMX in the TNS directory.

ORA-06902 CMX: cannot attach to cmx subsystem

Cause: CCP-xxxx is not started.

Action: Start your CCP software on the communication controller.

ORA-06903 CMX: cannot read transport address of remote application

Cause: Remote application not entered in TNS directory.

Action: Enter remote application in TNS directory.

ORA-06904 CMX: no transport address available for remote application

Cause: No local name assigned to remote application.

Action: Assign local name to remote application.

ORA-06905 CMX: connect error

Cause: Remote partner not listening.

Action: Make sure remote node has CMX installed and running make sure ORACMX is running on remote host.

ORA-06906 CMX: cannot get maximum packet size from CMX

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06907 CMX: error during connect confirmation

Cause: Remote partner aborted.

Action: Contact Oracle Support Services.

ORA-06908 CMX: error during transfer of ORACLE_SID

Cause: Remote partner aborted.

Action: Contact Oracle Support Services.

ORA-06909 CMX: error during acknowledge of ORACLE_SID

Cause: Remote partner aborted.

Action: Contact Oracle Support Services.

ORA-06910 CMX: Cannot start oracle process on remote machine

Cause: Oracle process not found or wrong mode (should be 4751).

Action: Change /etc/oratab or set mode to 4751.

ORA-06911 CMX: t_event returns ERROR

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06912 CMX: write error in datarq

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06913 CMX: error during redirection of connection

Cause: ORACMX has been stopped, or user process has been aborted.

Action: Contact Oracle Support Services.

ORA-06914 CMX: unexepected event during start of oracle

Cause: Connect sequence out of sync.

Action: Contact Oracle Support Services.

ORA-06915 CMX: unknown t_event in datarq

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06916 CMX: error in data read (t_datain)

Cause: Remote partner aborted.

Action: Contact Oracle Support Services.

ORA-06917 CMX: error in data read (too many bytes read)

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06918 CMX: T_NOEVENT during wait for read event

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06919 CMX: error during write request (unknown event)

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06920 CMX: getbrkmsg illegal datatype

Cause: Received packets are corrupted.

Action: Contact Oracle Support Services.

ORA-06921 CMX: getdatmsg illegal datatype

Cause: Received packets are corrupted.

Action: Contact Oracle Support Services.

ORA-06922 CMX: bad write length

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06923 CMX: illegal break condition

Cause: Break handling out of sync.

Action: Contact Oracle Support Services.

ORA-06924 CMX: wrong break message length

Cause: Received packets are corrupted.

Action: Contact Oracle Support Services.

ORA-06925 CMX: disconnect during connect request

Cause: Partner is not responding.

Action: Make sure partner is up and running and reachable.

ORA-06926 CMX: T_ERROR during read data

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06927 CMX: T_DATAIN received before all data written

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06928 CMX: wrong ORACLE_SID

Cause: ORACLE_SID is not entered in remote ORATAB.

Action: Add ORACLE_SID to remote ORATAB.

ORA-06929 CMX: error when sending ORACLE_SID

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06930 CMX: error when checking ORACLE_SID

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06931 CMX: error during read_properties for server

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06932 CMX: error in local name

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06933 CMX: error during attach

Cause: Internal error in CMX.

Action: Contact Oracle Support Services.

ORA-06950 No error

Cause: SQL*Net AppleTalk error codes base. This is not an error.

Action: No action required.

ORA-06951 Operating system call error

Cause: AppleTalk API received error in VMS system service.

Action: Contact Oracle Support Services.

ORA-06952 Remote end of the communication issued a forward-reset packet.

Cause: Peer program may have aborted.

Action: Investigate network problems and try again.

ORA-06953 Not enough virtual memory

Cause: Not enough memory available.

Action: Check VMS process quotas and/or SYSGEN parameters.

ORA-06954 Illegal file name

Cause: Erroneous file name.

Action: Check path name for server output file, or SQL*Net Appletalk Logical names and symbols.

ORA-06955 Number of database servers exceed limit

Cause: Too many database connections.

Action: Check ATKSRV_MAXCON parameter in configuration file.

ORA-06956 Failed to get local host name

Cause: Unable to get Appletalk host name.

Action: Check Appletalk configuration.

ORA-06957 No SID is currently available

Cause: Incoming SQL*Net connection specified invalid SID name.

Action: Specify correct SID in connect string and retry.

ORA-06958 Failed to access configuration file

Cause: Unable to access CONFIG.ATK.

Action: Check file protections.

ORA-06959 Buffer I/O quota is too small

Cause: Buffered I/O quota exceeded.

Action: Increase BIOLM using AUTHORIZE utility and retry.

ORA-06960 Failed to access log file

Cause: SQL*Net Appletalk listener could not create log file.

Action: Check directory path and protections.

ORA-06961 Insufficient privilege for attempted operation

Cause: You do not have sufficient privileges for the attempted operation.

Action: Check process privileges and retry.

ORA-06970 X.25 Driver: remote host is unknown

Cause: Host name specified in the login (connect string) is unknown.

Action: Check spelling; make sure name is in the X.25 HOST file.

ORA-06971 X.25 Driver: error while receiving data

ORA-06972 X.25 Driver: error while sending data

ORA-06973 X.25 Driver: invalid buffer size

Cause: The buffer size specified in the login string must be between 5 and 4096.

Action: Re-submit with valid buffer size.

ORA-06974 X.25 Driver: SID lookup failure

Cause: From the remote host's SQL*Net X.25 server: the database SID, specified in the login (connect) string, was not recognized.

Action: Add the appropriate SID entry to the CONFIG.ORA file on the remote host (and restart the SQL*Net X.25 server).

ORA-06975 X.25 Driver: connect to host failed

Cause: Connection attempt to remote host has failed. Probably means that the SQL*Net X.25 server on the remote host is not up, or the host itself is not up.

Action: Start the SQL*Net X.25 server process on the remote host.

ORA-06976 X.25 Driver: endpoint creation failure

Cause: Process open file quota probably exceeded.

Action: Contact Oracle Support Services.

ORA-06977 X.25 Driver: X.25 Level 2 failure

Cause: X.25 level 2 is down. X.25 link is not working.

Action: Run system checks to verify functioning of X.25 software. Contact your hardware vendor.

ORA-06978 X.25 Driver: Too many callback tries

Cause: Call back address probably same as called address.

Action: Verify that the callback address and called address are different.

ORA-06979 X.25 Driver: server cannot start oracle

Cause: The remote X.25 server was unable to start an Oracle process on behalf of the client.

Action: Make sure permissions on the remote Oracle program are correctly set. Contact your system administrator.

ORA-07200 slsid: oracle_sid not set.

Cause: The environment variable $(ORACLE_SID) is not set.

Action: Set ORACLE_SID environment variable.

ORA-07201 slhom: oracle_home variable not set in environment.

Cause: $(ORACLE_HOME) environment variable not set.

Action: Set ORACLE_HOME.

ORA-07202 sltln: invalid parameter to sltln.

Cause: The SLTLN name translation routine was called with invalid arguments. The input, or output stings were either NULL or 0 length.

Action: Probable internal Oracle error. Contact Oracle Support Services.

ORA-07203 sltln: attempt to translate a long environment variable.

Cause: A string was passed to SLTLN containing a long environment variable. SLTLN accepts environment names of 30 or less characters.

Action: Shorten environment variable name to less than 30 characters.

ORA-07204 sltln: name translation failed due to lack of output buffer space.

Cause: The SLTLN routine is given a maximum length buffer to expand the name into. An overflow of this buffer occurred.

Action: Possible internal error. Check output buffer length stored in sercose[0]. Path names are limited to 255 characters.

ORA-07205 slgtd: time error, unable to obtain time.

Cause: Time() system call returned an error. Possible operating system error.

Action: Check additional information returned. Contact Oracle Support Services.

ORA-07206 slgtd: gettimeofday error, unable to obtain time.

Cause: GETTIMEOFDAY() system call returned an error. Possible operating system error.

Action: Check additional information returned. Contact Oracle Support Services.

ORA-07207 sigpidu: process ID string overflows internal buffer.

Cause: The SIGPIDU routine is given a maximum length buffer to hold process ID string. An overflow of this buffer occurred. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07208 sfwfb: failed to flush dirty buffers to disk.

Cause: The FSYNC system call returned an error. Possible operating system error.

Action: Check additional information returned. Contact Oracle Support Services.

ORA-07209 sfofi: file size limit was exceeded.

Cause: The size of the file to be opened exceeded the operating system limit imposed on this process.

Action: Run OSH to increase the file size limit.

ORA-07210 slcpu: getrusage error, unable to get cpu time.

Cause: GETRUSAGE system call returned an error. Possible operating system error.

Action: Check additional information returned. Contact Oracle Support Services.

ORA-07211 slgcs: gettimeofday error, unable to get wall clock.

Cause: GETTIMEOFDAY system call returned an error. Possible operating system error.

Action: Check additional information returned in the operating system reference manual. Contact Oracle Support Services.

ORA-07212 slcpu: times error, unable to get cpu time.

Cause: The times system call returned an error. Possible operating system error.

Action: Check additional information returned. Contact Oracle Support Services.

ORA-07213 slgcs: times error, unable to get wall clock.

Cause: Times system call returned an error. Possible operating system error.

Action: Check additional information returned in the operating system reference manual. Contact Oracle Support Services.

ORA-07214 slgunm: uname error, unable to get system information.

Cause: UNAME system call returned an error. Possible operating system error.

Action: Check additional information returned in the operating system reference manual. Contact Oracle Support Services.

ORA-07215 slsget: getrusage error.

Cause: GETRUSAGE system call returned an error. Possible operating system error.

Action: Check additional information returned. Look for information in the operating system reference manual. Contact Oracle Support Services.

ORA-07216 slghst: gethostname error, unable to get name of current host.

Cause: GETHOSTNAME system call returned an error. Possible operating system error.

Action: Check additional information returned in the operating system reference manual. Contact Oracle Support Services.

ORA-07217 sltln: environment variable cannot be evaluated.

Cause: GETENV call returned a null pointer.

Action: Set the environment variable and try again.

ORA-07218 slkhst: could not perform host operation

Cause: UNIX system() call failed.

Action: Examine system error message.

ORA-07219 slspool: unable to allocate spooler argument buffer.

Cause: MALLOC failed to allocate space to hold spooler arguments.

Action: Check additional information returned in the operating system reference manual. The process may have run out of heap space. Contact Oracle Support Services.

ORA-07220 slspool: wait error.

Cause: Wait returned an error, when waiting for spool job to complete. Possible spooler program error.

Action: Check additional information returned. Refer to the operating system reference manual. Contact Oracle Support Services.

ORA-07221 slspool: exec error, unable to start spooler program.

Cause: Exec failed when starting line printer spooler command. Likely that either the default line printer command, or ORACLE_LPPROG, is incorrectly set.

Action: Verify default line printer command and ORACLE_LPPROG are set correctly. Set ORACLE_LPPROG to working line printer spooler.

ORA-07222 slspool: line printer spooler command exited with an error.

Cause: The line printer spooler exited with a non-zero return value. This probably indicates an error in spooling file.

Action: Verify that line printer spooler is up. Verify that ORACLE_LPPROG, and ORACLE_LPARG are set properly. Check exit value returned as additional information.

ORA-07223 slspool: fork error, unable to spawn spool process.

Cause: Fork system call failed to create additional process. Probable resource limit reached.

Action: Check additional information returned. Retry operation. Contact system administrator.

ORA-07224 sfnfy: failed to obtain file size limit; errno = string.

Cause: The ULIMIT system call returned an error.

Action: Check errno and contact Oracle Support Services.

ORA-07225 sldext: translation error, unable to expand file name.

Cause: Additional information returned is error returned from SLTLN.

Action: Check additional information.

ORA-07226 rtneco: unable to get terminal mode.

Cause: The IOCTL call returned an error. Possible operating system error.

Action: Check additional information for errno. Contact Oracle Support Services.

ORA-07227 rtneco: unable to set noecho mode.

Cause: The IOCTL call returned an error. Possible operating system error.

Action: Check additional information for errno. Contact Oracle Support Services.

ORA-07228 rtecho: unable to restore terminal to echo mode.

Cause: The IOCTL call returned an error. Possible operating system error.

Action: Check additional information for errno. Contact Oracle Support Services.

ORA-07229 slcpuc: error in getting number of CPUs.

Cause: Error in MPCNTL system call.

Action: Examine errno. Contact your system administrator.

ORA-07230 slemcr: fopen error, unable to open error file.

Cause: FOPEN failed to open file.

Action: Try to determine which file was not opened. Check that file exists and is accessible.

ORA-07231 slemcc: invalid file handle, seals do not match.

Cause: Function was called with an invalid argument. The file handle used was not obtained be SLEMCR. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07232 slemcc: fclose error.

Cause: An error was encountered when closing the file. Possible operating system error.

Action: Contact system administrator.

ORA-07233 slemcw: invalid file handle, seals do not match.

Cause: Function was called with an invalid file handle. File handle was not obtained by SLEMCR. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07234 slemcw: fseek error.

Cause: Unable to seek to desired position in file. Possible operating system error. Possible internal error.

Action: Verify that error message file is intact. Try to regenerate error message file. Contact Oracle Support Services.

ORA-07235 slemcw: fwrite error.

Cause: Unable to write item to file. Possible operating system error. Possible permissions problem.

Action: Retry operation.

ORA-07236 slemop: open error.

Cause: Unable to open error file. Possible permissions problem.

Action: Verify permission on error message file. Check additional information for errno.

ORA-07237 slemcl: invalid file handle, seals do not match.

Cause: Function was called with an invalid file handle. Handle was not obtained by previous call to SLEMOP. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07238 slemcl: close error.

Cause: Unable to close file. Possible operating system error.

Action: Contact system administrator. Check additional information for errno.

ORA-07239 slemrd: invalid file handle, seals do not match.

Cause: Function was called with invalid file handle. Handle was not obtained by call to SLEMOP. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07240 slemrd: seek error.

Cause: Unable to seek to desired position in file. Possible operating system error.

Action: Check that error file is still intact. Verify space on device. Contact system administrator. Check additional information for errno.

ORA-07241 slemrd: read error.

Cause: Unable to read file. Possible operating system error.

Action: Verify that error file is intact. Regenerate error message file. Contact Oracle Support Services. Check additional information for errno.

ORA-07242 slembfn: translation error, unable to translate error file name.

Cause: Additional information indicates error returned from SLTLN.

Action: Check additional information.

ORA-07243 supplied buffer not big enough to hold entire line

Cause: The supplied buffer was not big enough. This is an internal error.

Action: Contact Oracle Support Services. Additional information indicates how big the supplied buffer was.

ORA-07244 ssfccf: create file failed, file size limit reached.

Cause: An attempt was made to create a file that exceeds the process's file size limit.

Action: Run OSH to raise the file size limit.

ORA-07245 sfccf: unable to lseek and write the last block.

Cause: An attempt was made to move and write to a bad device address.

Action: Check errno. Possible lack of space on device.

ORA-07246 sfofi: open error, unable to open database file.

Cause: SFOFI returns an error. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07247 sfrfb: read error, unable to read requested block from database file.

Cause: SFRFB returns an error. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07248 sfwfb: write error, unable to write database block.

Cause: SFWFB returns an error. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07249 slsget: open error, unable to open /proc/pid.

Cause: OPEN() returns an error.

Action: Check that /proc has the right permissions.

ORA-07250 spcre: semget error, unable to get first semaphore set.

Cause: An error occurred when trying to get first semaphore set.

Action: Check errno. Verify that system is configured to have semaphores. Verify that enough semaphores are available. Additional information indicates how many semaphores were requested.

ORA-07251 spcre: semget error, could not allocate any semaphores.

Cause: SEMGET failed to even allocate a single semaphore. Either they are all in use or the system is not configured to have any semaphores.

Action: Check to see if all semaphores are in use. Check to see if system is configured to have semaphores. Check errno.

ORA-07252 spcre: semget error, could not allocate semaphores.

Cause: SEMGET system call returned an error. Possible resource limit problem.

Action: Check errno. Verify that enough semaphores are available in system. If additional errors occur in destroying the semaphore sets then sercose[0] will be non-zero. If this occurs, remove the semaphore sets using IPCRM.

ORA-07253 spdes: semctl error, unable to destroy semaphore set.

Cause: SEMCTL system call returned an error.

Action: Check semaphore sets. May require manual cleanup. Check additional information returned. Consult operating system reference manual.

ORA-07254 spdcr: translation error while expanding ?/bin/oracle.

Cause: An error occurred while translating the name of the Oracle executable.

Action: Check sercose[0] for error returned from SLTLN. Perhaps $(ORACLE_HOME) is not set correctly.

ORA-07255 spini: cannot set up signal handler.

Cause: System failed to set up signal handler.

Action: Check errno and sercose[0] for the signal number that failed.

ORA-07256 sptrap: cannot set up signal handler to catch exceptions.

Cause: System failed to set up signal handler to catch exceptions.

Action: Check errno and sercose[0] for the signal number that failed.

ORA-07257 spdcr: translation error expanding program name.

Cause: Error occurred when expanding program name ora_PNAME_@. The result of this translation is put in argv[0] of Oracle process.

Action: Check error returned by SLTLN returned in sercose[0].

ORA-07258 spdcr: fork error, unable to create process.

Cause: An error occurred when creating a new process.

Action: Check errno. Perhaps a system limit on the number of processes has been exceeded.

ORA-07259 spdcr: exec error, detached process failed in startup.

Cause: An Oracle detached process died shortly after startup. Wait() indicated that a child process terminated.

Action: Check ?/dbs directory for trace or core files. Check errno.

ORA-07260 spdcr: wait error.

Cause: Wait system call returned an error.

Action: Check errno.

ORA-07261 spdde: kill error, unable to send signal to process.

Cause: Kill system call returned an error. Possibly an attempt to destroy an already gone process.

Action: Check errno.

ORA-07262 sptpa: sptpa called with invalid process id.

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-07263 sptpa: kill error.

Cause: Kill system call returned an error. Possible operating system error.

Action: Check errno. Additional information indicates the process ID tested.

ORA-07264 spwat: semop error, unable to decrement semaphore.

Cause: SEMOP system call returned an error. Semaphore set may not exist.

Action: Check errno. Semaphore ID is returned in sercose[0]. Verify semaphore set exists. A possible cause for this error is that a SHUTDOWN ABORT was done while this process was running.

ORA-07265 sppst: semop error, unable to increment semaphore.

Cause: SEMOP system call returned an error. Semaphore set may not exist.

Action: Check errno. Semaphore ID is returned in sercose[0]. Check semaphore set existence. A possible cause for this error is that a SHUTDOWN ABORT was done while this process was running.

ORA-07266 sppst: invalid process number passed to sppst.

Cause: Function was passed an invalid Oracle process ID. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07267 spwat: invalid process number.

Cause: Function was passed an invalid Oracle process ID. This is an internal error.

Action: Additional information indicates the invalid process ID. Contact Oracle Support Services.

ORA-07268 szguns: getpwuid error.

Cause: GETPWUID() could not find an entry in the passwd file for a user.

Action: Add an entry for the user in the passwd file.

ORA-07269 spdcr: detached process died after exec.

Cause: Detached process successfully executed, but died shortly thereafter. Additional information indicates exit code, and termination status.

Action: Check termination code for information as to why process exited. Check for core dump or trace file.

ORA-07270 spalck: setitimer error, unable to set interval timer.

Cause: An error occurred while trying to set an interval timer. Probable porting problem.

Action: Check errno.

ORA-07271 spwat: invalid oracle process number.

Cause: Function was called with an invalid Oracle process number (0).

Action: Internal Oracle error.

ORA-07272 spwat: invalid semaphore set id.

Cause: Semaphore ID fetched from SGA was not initialized to valid value. Additional information returned is semaphore set index, and Oracle process number. This is an internal error.

Action: Check semaphore set index. Check Oracle process number.

ORA-07273 sppst: invalid semaphore id.

Cause: Semaphore ID fetched from SGA contained an invalid value. Additional information returned is semaphore set index, and Oracle process number. This is an internal error.

Action: Check semaphore set index. Check Oracle process number.

ORA-07274 spdcr: access error, access to oracle denied.

Cause: Unable to access Oracle program. Verify ?/bin/oracle or $ORABCKPRG exist, and are executable.

Action: Check errno returned.

ORA-07275 unable to send signal to process

Cause: The kill system call returned an error. Possibly an attempt to signal a process which does not exist.

Action: Check errno.

ORA-07276 no dba group in /etc/group.

Cause: A group has not been set up for dba users.

Action: Contact system administrator. Set up dba group in /ETC/GROUP.

ORA-07277 spdde: illegal pid passed as argument.

Cause: A 0 PID was passed to SPDDE. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07278 splon: ops$username exceeds buffer length.

Cause: SPLON constructed an OPS$USERNAME logon which exceeded the allocated buffer space.

Action: Use a shorter UNIX username, or use an Oracle username. Contact Oracle Support Services.

ORA-07279 spcre: semget error, unable to get first semaphore set.

Cause: An error occurred when trying to get first semaphore set.

Action: Check errno. Verify that system is configured to have semaphores. Verify that enough semaphores are available. Additional information indicates how many semaphores were requested.

ORA-07280 slsget: unable to get process information.

Cause: The IOCTL call returned an error. Possible operating system error.

Action: Check additional information for errno. Contact Oracle Support Services.

ORA-07281 slsget: times error, unable to get cpu time.

Cause: Times system call returned an error. Possible operating system error.

Action: Check additional information returned. Contact Oracle Support Services.

ORA-07282 sksaprd: string overflow.

Cause: The internal buffer is not big enough to hold the archive control string.

Action: Internal restriction. Try a shorter archive control string.

ORA-07283 sksaprd: invalid volume size for archive destination.

Cause: An invalid volume size was specified.

Action: Specify a valid volume size in archive control string.

ORA-07284 sksaprd: volume size specification not terminated properly.

Cause: Some non-numeric text follows the volume size specification.

Action: Enter a correct archive control string.

ORA-07285 sksaprd: volume size should not be specified for a disk file.

Cause: Volume size was specified for a disk file.

Action: If you are archiving to a disk file, do not specify its volume size.

ORA-07286 sksagdi: cannot obtain device information.

Cause: STAT on the log archiving device failed.

Action: Check the returned OSD error for the reason of failure.

ORA-07287 sksagdi: unsupported device for log archiving.

Cause: Log archiving to this device is unsupported.

Action: Try log archiving to a supported device.

ORA-07290 sksagdi: specified directory for archiving does not exist.

Cause: The specified path name is not a directory.

Action: Verify that the archive destination directory exists.

ORA-07303 ksmcsg: illegal database buffer size.

Cause: The database buffer size must be a multiple of the database block size, and less than the maximum block size.

Action: Verify that the DB_BLOCK_SIZE initialization parameter is set properly in your initialization parameter file.

ORA-07304 ksmcsg: illegal redo buffer size.

Cause: The redo buffer size must be a multiple of machine block size.

Action: Verify that the LOG_BUFFER initialization parameter is set properly in your initialization parameter file.

ORA-07305 ksmcsg: illegal database buffer size.

Cause: The database buffer size must be a multiple of the extended cache mapping size for indirect data buffers to be used.

Action: Verify that the DB_BLOCK_SIZE initialization parameter is set properly in your initialization parameter file, or disable the USE_INDIRECT_DATA_BUFFERS initialization parameter.

ORA-07324 smpall: malloc error while allocating pga.

Cause: MALLOC library routine returned an error.

Action: Check errno. Possibly out of swap space.

ORA-07327 smpdal: attempt to destroy pga when it was not mapped.

Cause: SMPDAL was called when the PGA had not been previously created. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07339 spcre: maximum number of semaphore sets exceeded.

Cause: The internal buffer is not big enough to hold the number of semaphore set identifiers requested.

Action: Reconfigure operating system to have more semaphores per set.

ORA-07345 The datafile name must not contain the string '..'.

Cause: The specified datafile name contains '..'.

Action: Correct the datafile name and retry the operation.

ORA-07390 sftopn: translate error, unable to translate file name.

Cause: An error occurred while expanding the file name to open. Additional information returns error generated in translation routine.

Action: Look up additional error code for further information.

ORA-07391 sftopn: fopen error, unable to open text file.

Cause: FOPEN library routine returned an error.

Action: Verify existence and permissions.

ORA-07392 sftcls: fclose error, unable to close text file.

Cause: FCLOSE library routine returned an error.

Action: Possible internal Oracle error.

ORA-07393 unable to delete text file

Cause: An error occurred while deleting a text file.

Action: Verify that the file exists and check additional errors.

ORA-07394 unable to append string to text file

Cause: An error occurred while performing a string put operation.

Action: This is an internal error. Check additional information.

ORA-07400 slemtr: translated name for the message file is too long.

Cause: The name for the message file overflows internal buffer.

Action: Try making the complete path-name of the message file shorter by reorganizing the directory hierarchy.

ORA-07401 sptrap: cannot restore user exception handlers.

Cause: The system failed to restore user exception handlers.

Action: Check errno and sercose[0] for the signal number that failed.

ORA-07402 sprst: cannot restore user signal handler.

Cause: The system failed to restore user signal handlers.

Action: Check errno and sercose[0] for the signal number that failed.

ORA-07403 sfanfy: db_writers parameter not valid.

Cause: The DB_WRITERS initialization parameter in your initialization parameter file exceeds the system-dependent maximum or is less than 0.

Action: Change the DB_WRITERS initialization parameter in your initialization parameter file.

ORA-07404 sfareq: Timeout occurred waiting for request to complete.

Cause: The master database writer timed out waiting for a write or close to complete. One of the database writers may have stopped running.

Action: Check all database writer trace files. Shut down the database and try to warm start.

ORA-07406 slbtpd: invalid number.

Cause: An impossible request for binary to decimal conversion was made.

Action: This conversion cannot be performed.

ORA-07407 slbtpd: invalid exponent.

Cause: An impossible request for binary to decimal conversion was made.

Action: This conversion cannot be performed.

ORA-07408 slbtpd: overflow while converting to packed decimal.

Cause: An impossible request for binary to decimal conversion was made.

Action: This conversion cannot be performed.

ORA-07409 slpdtb: invalid packed decimal nibble.

Cause: An impossible request for decimal to binary conversion was made.

Action: This conversion cannot be performed.

ORA-07410 slpdtb: number too large for supplied buffer.

Cause: An impossible request for decimal to binary conversion was made.

Action: This conversion cannot be performed.

ORA-07411 slgfn: full path name too big for supplied buffer.

Cause: The supplied buffer is not big enough to hold the full path name.

Action: The construction of the full path name cannot be performed.

ORA-07412 sfaslv: Error getting entry in asynchronous write array.

Cause: One of the database writer processes could not locate its entry in the SGA.

Action: Contact Oracle Support Services.

ORA-07415 slpath: allocation of memory buffer failed.

Cause: MALLOC() failed to allocate buffer for storing ORACLE_PATH.

Action: System has run out of heap space. Additional information indicates errno.

ORA-07416 slpath: pathname construction failed; lack of output buffer space.

Cause: The SLPATH routine is given a maximum length buffer to expand the name into. An overflow of this buffer occurred. This may be an internal error.

Action: Check output buffer length stored in sercose[0] and constructed path name length in sercose[1].

ORA-07417 sfareq: One or more database writers not active.

Cause: One or more of the database writer processes is no longer running.

Action: Check the trace files for the database writers. Shut down the database and try to warm start.

ORA-07418 sfareq: Database writer got error in timing function.

Cause: An error occurred when the database writer called the system timing function.

Action: Check the database writer trace file. Shut down the database and try to warm start.

ORA-07419 sfareq: Database writer got error in timing function.

Cause: An error occurred when the database writer called the system timing function.

Action: Check the database writer trace file. Shut down the database and try to warm start.

ORA-07425 sdpri: error string in translating dump file location.

Cause: An Oracle error occurred when translating the location of the dump file.

Action: Check the Oracle error code.

ORA-07426 spstp: cannot obtain the location of dbs directory.

Cause: An Oracle error occurred when translating the location of the DBS directory.

Action: Check additional information for the error returned from SLTLN.

ORA-07427 spstp: cannot change directory to dbs.

Cause: CHDIR system call returned an error. Possible permission problems.

Action: Check additional information for the operating system error code.

ORA-07431 fork failed

Cause: The server process was unable to fork a child process.

Action: Verify that there are enough system resources to support another process. The user or system process limit may have been exceeded, or the amount of free memory or swap space may be temporarily insufficient.

ORA-07432 unable to perform nested sleep

Cause: An attempt was made to make a process sleep when it was already sleeping. This platform does not support this capability.

Action: Try the SLEEP command when the process is not sleeping.

ORA-07440 WMON process terminated with error

Cause: The wakeup monitor process died.

Action: Warm start instance.

ORA-07441 function address must be aligned on string byte boundary

Cause: An improperly aligned function address was specified.

Action: Use a properly aligned function address.

ORA-07442 function address must be in the range string to string

Cause: An invalid function address was specified.

Action: Use a valid function address.

ORA-07443 function string not found

Cause: An invalid function name was specified.

Action: Use a valid function name.

ORA-07444 function address string is not readable

Cause: An invalid function name/address was specified.

Action: Use a valid function name/address.

ORA-07445 exception encountered: core dump [string] [string] [string] [string] [string] [string]

Cause: An operating system exception occurred which should result in the creation of a core file. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07446 sdnfy: bad value 'string' for parameter string.

Cause: The directory specified as the value for the stated parameter could not be used.

Action: Make sure the directory you have specified is a valid directory/file specification.

ORA-07447 ssarena: usinit failed.

Cause: Oracle failed to create a shared arena file.

Action: Use SERCERRNO field to determine cause of failure.

ORA-07448 ssarena: maximum number of shared arenas exceeded.

Cause: Oracle attempted to create more shared arena files than permitted.

Action: Raise the value for MAX_ARENA in INIT.ORA.

ORA-07449 sc: usnewlock failed.

Cause: Oracle failed to acquire a shared arena lock.

Action: Check result code in SERCERRNO to determine the cause of failure.

ORA-07451 slskstat: unable to obtain load information.

Cause: KSTAT library returned an error. Possible operating system failure.

Action: Check result code in sercose[0] for more information.

ORA-07452 specified resource manager plan does not exist in the data dictionary

Cause: User tried to load a resource manager plan that does not exist.

Action: Use a resource manager plan that exists in the data dictionary.

ORA-07453 requested resource manager plan schema does not contain OTHER_GROUPS

Cause: User tried to load a resource manager plan schema that does not contain the OTHER_GROUPS group.

Action: Use a resource manager plan schema that contains the OTHER_GROUPS group.

ORA-07454 queue timeout, string second(s), exceeded

Cause: User session queued for longer than maximum specified queue duration time for consumer group.

Action: Re-submit the job at a later time or increase queue timeout.

ORA-07455 estimated execution time (string secs), exceeds limit (string secs)

Cause: User attempted to execute an operation whose estimated execution time exceeds the limit specified for the consumer group.

Action: Execute job on behalf of another group, or increase the limit.

ORA-07456 cannot set RESOURCE_MANAGER_PLAN when database is closed

Cause: An attempt was made to turn on the Resource Manager when the database was closed.

Action: Open the database and try again.

ORA-07468 spwat: mset error, unable to set semaphore.

Cause: The MSET routine returned an error. Semaphore may not exist.

Action: Check result code in SERCERRNO. Semaphore number returned in sercose[0].

ORA-07469 sppst: mclear error, unable to clear semaphore.

Cause: The MCLEAR routine returned an error. Semaphore may not exist.

Action: Check result code in SERCERRNO. Semaphore number returned in sercose[0].

ORA-07470 snclget: cannot get cluster number.

Cause: The CLUSTER_STATUS system call failed to get status information for the current cluster.

Action: Check result code in sercose[0]. Possible operating system failure.

ORA-07471 snclrd: name translation error of sgadef.dbf file name.

Cause: Unable to expand out ?/dbs/sgadef@.dbf file name.

Action: Verify $(ORACLE_HOME) and $(ORACLE_SID) are properly set. Check error number returned from SLTLN in sercose[0].

ORA-07472 snclrd: open error when opening sgadef.dbf file.

Cause: Open failed when opening the file ?/dbs/sgadef@.dbf.

Action: Check errno. Possible permission problem. Verify that the file ?/dbs/sgadef@.dbf exists.

ORA-07473 snclrd: read error when trying to read sgadef.dbf file.

Cause: Read had an error when reading SGADEF.DBF file.

Action: Check errno. Verify file exists, and is correct size.

ORA-07474 snclrd: close error, unable to close sgadef.dbf file.

Cause: An error occurred in close, while closing the file ?/dbs/sgadef@.dbf.

Action: Check errno. Possible operating system error.

ORA-07475 slsget: cannot get vm statistics.

Cause: The VM_STATISTICS system call failed to get virtual memory statistics.

Action: Check result code in SERCERRNO. Possible operating system failure.

ORA-07476 slsget: cannot get mapped memory statistics.

Cause: The VM_MAPMEM system call failed to get mapped memory statistics.

Action: Check result code in SERCERRNO. Possible operating system failure.

ORA-07477 scgcmn: lock manager not initialized.

Cause: Lock manager must be initialized before converting locks.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07478 scgcmn: cannot get lock status.

Cause: LM_STAT_LOCK failed.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07479 scgcmn: cannot open or convert lock.

Cause: LM_OPEN or LM_OPEN_CONVERT failed.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07480 snchmod: cannot change permissions on ?/dbs/sgalm.dbf.

Cause: When creating an instance, SNLMINI could not change the permissions on ?/dbs/sgalm.dbf.

Action: Contact Oracle Support Services.

ORA-07481 snlmatt: cannot attach to lock manager instance.

Cause: LM_ATTACH failed to attach to Lock Manager instance.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07482 snlmini: cannot create lock manager instance.

Cause: LM_CREATE failed to create Lock Manager instance.

Action: Check permissions on ?/dbs, and remove ?/dbs/sgalm.dbf if it exists, then retry.

ORA-07483 snlkget: cannot convert(get) lock.

Cause: LM_CONVERT failed to convert(get) lock.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07484 snlkput: cannot convert(put) lock.

Cause: LM_CONVERT failed to put lock value.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07485 scg_get_inst: cannot open instance number lock.

Cause: LM_OPEN failed.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07486 scg_get_inst: cannot convert(get) instance number lock.

Cause: LM_CONVERT failed to get lock value.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07487 scg_init_lm: cannot create lock manager instance.

Cause: LM_CREATE failed.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07488 scgrcl: lock manager not initialized.

Cause: Lock manager must be initialized before releasing locks.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07489 scgrcl: cannot get lock status.

Cause: LM_STAT_LOCK failed during lock release/cancel.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07490 scgrcl: cannot convert lock.

Cause: LM_CONVERT failed during lock release/cancel.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07491 scgrcl: cannot cancel lock request.

Cause: LM_CANCEL failed during lock release/cancel.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07492 scgrcl: cannot close lock.

Cause: LM_CLOSE failed during lock release/cancel.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07493 scgrcl: lock manager error.

Cause: An error was encountered releasing the lock.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07494 scgcm: unexpected error.

Cause: Unknown or unexpected error code.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07495 spwat: lm_wait failed.

Cause: LM_WAIT failed.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07496 sppst: lm_post failed.

Cause: LM_POST failed.

Action: Check result code in SERCERRNO. Possible Lock Manager failure.

ORA-07497 sdpri: cannot create trace file 'string'; errno = string.

Cause:

  1. The trace file could not be created for writing.
  2. The trace file is a symbolic link.

Action:

  1. Check if the dump directory exists and whether it is writable.
  2. Remove the symbolic link.

ORA-07498 spstp: Unable to open /dev/resched.

Cause: The rescheduling driver /dev/resched is not found or is not working properly.

Action: Check installation of the Oracle rescheduling driver in the AIX kernel.

ORA-07499 spglk: Cannot reschedule.

Cause: The rescheduling driver /dev/resched is not open. This is an internal error and should not occur.

Action: Contact Oracle Support Services.


ORA-07500 to ORA-09857

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

7
ORA-07500 to ORA-09857

ORA-07500 scglaa: $cantim unexpected return

Cause: VMS system service $CANTIM returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07501 scgtoa: $deq unexpected return

Cause: VMS system service $DEQ returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07502 scgcmn: $enq unexpected return

Cause: VMS system service $ENQ returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07503 scgcmn: $setimr unexpected return

Cause: VMS system service $SETIMR returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07504 scgcmn: $hiber unexpected return

Cause: VMS system service $HIBER returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07505 scggt: $enq parent lock unexpected return

Cause: VMS system service $ENQ returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07506 scgrl: $deq unexpected return on lockid string

Cause: VMS system service $DEQ returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07507 scgcm: unexpected lock status condition

Cause: A global locking system service returned an unexpected value.

Action: Check for system error message (if any) and refer to VMS documentation, or contact Oracle Support Services.

ORA-07508 scgfal: $deq all unexpected return

Cause: VMS system service $DEQ returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07509 scgfal: $deq parent lock unexpected return

Cause: VMS system service $DEQ returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07510 scgbrm: $getlki unexpected return on lockid string

Cause: VMS system service $GETLKI returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07511 sscggtl: $enq unexpected return for master termination lock

Cause: VMS system service $ENQ returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07512 sscggtl: $enq unexpected return for client termination lock

Cause: VMS system service $ENQ returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07513 sscgctl: $deq unexpected return on cancel of term. lock

Cause: VMS system service $DEQ returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07514 scgcan: $deq unexpected return while canceling lock

Cause: VMS system service $DEQ returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07534 scginq: $getlki unexpected return on lockid string

Cause: VMS system service $GETLKI returned an unexpected value.

Action: Check for system error message and refer to VMS documentation.

ORA-07548 sftopn: Maximum number of files already open

Cause: Too many test files open. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07549 sftopn: $OPEN failure

Cause: VMS system service $OPEN failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07550 sftopn: $CONNECT failure

Cause: VMS system service $CONNECT failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07551 sftcls: $CLOSE failure

Cause: VMS system service $CLOSE failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07552 sftget: $GET failure

Cause: VMS system service $GET failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07561 szprv: $IDTOASC failure

Cause: VMS system service $IDTOASC failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07562 sldext: extension must be 3 characters

Cause: An extension was found but it is of improper length. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07563 sldext: $PARSE failure

Cause: VMS system service $PARSE failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07564 sldext: wildcard in filename or extension

Cause: A wildcard was used in the file name.

Action: Re-enter the file name completely.

ORA-07565 sldext: $SEARCH failure

Cause: VMS system service $SEARCH failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07568 slspool: $OPEN failure

Cause: VMS system service $OPEN failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07569 slspool: $CLOSE failure

Cause: VMS system service $CLOSE failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07570 szrfc: $IDTOASC failure

Cause: VMS system service $IDTOASC failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07571 szrfc: $FIND_HELD failure

Cause: VMS system service $FIND_HELD failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07572 szrfc: insufficient rolename buffer space

Cause: An OS role name was too long.

Action: Re-define the role name to be of correct length.

ORA-07573 slkhst: could not perform host operation

Cause: VMS system service LIB$SPAWN failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07574 szrfc: $GETUAI failure

Cause: VMS system service $GETUAI failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07576 sspexst: $GETJPIW failure on process ID string

Cause: VMS system service $GETJPIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07577 no such user in authorization file

Cause: An attempt was made to set an INTERNAL password (for either DBA or OPER privilege), but the corresponding VMS account (either ORA_sid_DBA or ORA_sid_OPER) has not been created yet.

Action: Add a VMS account for ORA_sid_DBA and/or ORA_sid_OPER before trying to set a password for them.

ORA-07578 szprv: $FIND_HELD failure

Cause: VMS system service $FIND_HELD failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07579 spini: $DCLEXH failure

Cause: VMS system service $DCLEXH failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07580 spstp: $GETJPIW failure

Cause: VMS system service $GETJPIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07581 spstp: cannot derive SID from unexpected process name

Cause: A background process did not have name of correct form.

Action: If the job name was changed, restore it. Otherwise, this is an internal error; report it to Oracle Support Services.

ORA-07582 spstp: ORA_SID has illegal value

Cause: The ORA_SID must exist and be less than 6 characters.

Action: Consult the VMS Installation guide for information on setting the SID.

ORA-07584 spdcr: invalid value for ORA_sid_(proc_)PQL$_item

Cause: A logical name used to set a detached process quota value has an invalid value (probably non-numeric).

Action: Examine the values of these logical names, correct the one in error, and retry.

ORA-07585 spdcr: $PARSE failure

Cause: VMS system service $PARSE failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07586 spdcr: $SEARCH failure

Cause: VMS system service $SEARCH failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07587 spdcr: $CREPRC failure

Cause: VMS system service $CREPRC failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07588 spdcr: $GETJPIW get image name failure

Cause: VMS system service $GETJPIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07589 spdde: system ID not set

Cause: The logical name ORA_SID does not translate to a valid value.

Action: Check the value of ORA_SID in the process that gets the error, and correct the installation or command procedures that caused ORA_SID to be set incorrectly.

ORA-07590 spdde: $DELPRC failure

Cause: VMS system service $DELPRC failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07591 spdde: $GETJPIW failure

Cause: VMS system service $GETJPIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07592 sspgprv: Error obtaining required privileges

Cause: While obtaining needed privileges, an error was returned from SYS$SETPRV. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07593 ssprprv: Error release privileges

Cause: While releasing privileges, an error was returned from SYS$SETPRV. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07594 spiip: $GETJPIW failure

Cause: VMS system service $GETJPIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07595 sppid: $GETJPIW failure

Cause: VMS system service $GETJPIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07596 sptpa: $GETJPIW failure

Cause: VMS system service $GETJPIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07597 spguns: $GETJPIW failure

Cause: VMS system service $GETJPIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07598 spwat: $SETIMR failure

Cause: VMS system service $SETIMR failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07599 spwat: $SCHDWK failure

Cause: VMS system service $SCHDWK failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07600 slkmnm: $GETSYIW failure

Cause: VMS system service $GETSYIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07601 spguno: $GETJPIW failure

Cause: VMS system service $GETJPIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07602 spgto: $GETJPIW failure

Cause: VMS system service $GETJPIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07605 szprv: $ASCTOID failure

Cause: VMS system service $ASCTOID failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07606 szprv: $CHKPRO failure

Cause: VMS system service $CHKPRO failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07607 szaud: $SNDOPR failure

Cause: VMS system service $SNDOPR failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07608 szprv: $GETUAI failure

Cause: VMS system service $GETUAI failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07609 szprv: $HASH_PASSWORD failure

Cause: VMS system service $HASH_PASSWORD failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07610 $GETJPIW failed in retrieving the user's MAC priviledges

Cause: VMS system service $GETJPIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07612 $GETUAI failed in retrieving the user's clearance level

Cause: VMS system service $GETUAI failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07613 $GETJPIW failed in retrieving the user's process label

Cause: VMS system service $GETJPIW failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07614 $CHANGE_CLASS failed in retrieving the user's process label

Cause: VMS system service $CHANGE_CLASS failed.

Action: Examine system error message and refer to SEVMS documentation.

ORA-07615 $CHANGE_CLASS failed in retrieving the specified file label

Cause: VMS system service $CHANGE_CLASSS failed.

Action: Examine system error message and refer to SEVMS documentation.

ORA-07616 $CHANGE_CLASS failed in retrieving the specified device label

Cause: VMS system service $CHANGE_CLASS failed.

Action: Examine system error message and refer to SEVMS documentation.

ORA-07617 $FORMAT_CLASS failed translating the binary label to a string

Cause: VMS system service $FORMAT_CLASS failed because the given binary classification was not valid.

Action: Examine system error message and refer to SEVMS documentation.

ORA-07618 $IDTOASC failed translating a secrecy level

Cause: VMS system service $IDTOASC failed while looking up the string representation in the rights database of a secrecy level.

Action: Define the entry in the rights database which the binary label you specified references.

ORA-07619 $IDTOASC failed translating an integrity level

Cause: VMS system service $IDTOASC failed while looking up the string representation in the rights database of an integrity level.

Action: Define the entry in the rights database which the binary label you specified references.

ORA-07620 smscre: illegal database block size

Cause: An illegal database block size was specified in the parameter file. It must be positive, a multiple of 512, and less than the maximum physical i/o data size.

Action: Change DB_BLOCK_SIZE in the parameter file to conform to these limits.

ORA-07621 smscre: illegal redo block size

Cause: An illegal redo log buffer size was specified in the parameter file. It must be positive and a multiple of 512.

Action: Change LOG_BUFFER in the parameter file to conform to these limits.

ORA-07622 smscre: $CREATE failure

Cause: While creating the system global area (SGA) backing file, VMS system service $CREATE failed.

Action: Examine the system error message and refer to VMS documentation.

ORA-07623 smscre: $CRMPSC failure

Cause: While creating the system global area (SGA), VMS system service $CRMPSC failed.

Action: Examine the system error message and refer to VMS documentation.

ORA-07624 smsdes: $DGBLSC failure

Cause: While deleting the system global area (SGA), VMS system service $DGBLSC failed.

Action: Examine the system error message and refer to VMS documentation.

ORA-07625 smsget: $MGBLSC failure

Cause: While mapping the system global area (SGA) during logon, VMS system service $MGBLSC failed. The usual reason is that Oracle has not been started up.

Action: Examine the system error message and refer to VMS documentation. Start Oracle if it is not already started.

ORA-07626 smsget: sga already mapped

Cause: An attempt to map the SGA during logon failed because it was already mapped. This is an internal error.

Action: Exit your program and try again, and report this to Oracle Support Services.

ORA-07627 smsfre: $CRETVA failure

Cause: While unmapping the system global area (SGA) during logoff, VMS system service $CRETVA failed.

Action: Examine the system error message and refer to VMS documentation.

ORA-07628 smsfre: sga not mapped

Cause: An attempt to unmap the SGA during logoff failed because it was not mapped. This is an internal error.

Action: Exit your program and try again, and report this to Oracle Support Services.

ORA-07629 smpall: $EXPREG failure

Cause: While extending the program global area (PGA), VMS system service $EXPREG failed. This often happens when the virtual memory page count quota is exceeded.

Action: Examine the system error message and refer to VMS documentation.

ORA-07630 smpdal: $DELTVA failure

Cause: While deleting the program global area (PGA) during logoff, VMS system service $DELTVA failed.

Action: Examine the system error message and refer to VMS documentation.

ORA-07631 smcacx: $EXPREG failure

Cause: While creating or extending a context area, VMS system service $EXPREG failed. This often happens when the virtual memory page count quota is exceeded.

Action: Examine the system error message and refer to VMS documentation.

ORA-07632 smsrcx: $DELTVA failure

Cause: While deleting a context area, VMS system service $DELTVA failed.

Action: Examine the system error message and refer to VMS documentation.

ORA-07633 smsdbp: illegal protection value

Cause: The buffer debug function was called with an illegal value. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07634 smsdbp: $CRETVA failure

Cause: While attempting to set protection in the database buffer debug mechanism, VMS system service $CRETVA failed.

Action: Contact Oracle Support Services.

ORA-07635 smsdbp: $SETPRT failure

Cause: While attempting to set protection in the database buffer debug mechanism, VMS system service $SETPRT failed.

Action: Contact Oracle Support Services.

ORA-07636 smsdbp: $MGBLSC failure

Cause: While attempting to set protection in the database buffer debug mechanism, VMS system service $MGBLSC failed.

Action: Contact Oracle Support Services.

ORA-07637 smsdbp: buffer protect option not specified when sga created

Cause: An attempt was made to change the buffer protect mode when the SGA was not created with buffer protect debug option. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07638 smsget: SGA pad area not large enough for created SGA

Cause: An attempt was made to map an SGA with software in which the SGA pad area is not large enough.

Action: Create a smaller SGA, or relink the software with a larger pad.

ORA-07639 smscre: SGA pad area not large enough (string bytes required)

Cause: An attempt was made to create an SGA with software in which the SGA pad area is not large enough.

Action: Create a smaller SGA, or relink the software with a larger pad.

ORA-07640 smsget: SGA not yet valid. Initialization in progress

Cause: An attempt was made to map to the SGA while it was being initialized.

Action: Wait until initialization is complete, and try again.

ORA-07641 smscre: Unable to use the system pagefile for the SGA

Cause: The system global area (SGA) backing file could not be allocated using the system pagefile because the system-wide limit on global pages has been exceeded.

Action: Either increase the VMS system parameter GBLPAGFIL or use a disk file as the SGA backing file.

ORA-07642 smprtset: $CMKRNL failure

Cause: While attempting to set the protection of a region of memory, an error was returned from the $CMKRNL system service.

Action: Examine the system error message and refer to VMS documentation.

ORA-07643 smsalo: SMSVAR is invalid

Cause: This is an internal error.

Action: Report this error to Oracle Support Services; provide your initialization parameter file.

ORA-07645 sszfsl: $CHANGE_CLASS failure

Cause: While attempting to set the label on a file, SEVMS service $CHANGE_CLASS failed.

Action: Examine the system message and refer to SEVMS system documentation.

ORA-07646 sszfck: $CREATE failure

Cause: While attempting to create a file, VMS system service $CREATE failed.

Action: Examine the system message and refer to VMS system documentation.

ORA-07647 sszfck: $OPEN failure

Cause: While attempting to reopen a file, VMS system service $OPEN failed.

Action: Examine the system message and refer to VMS system documentation.

ORA-07650 sigunc: $GETJPIW failure

Cause: While attempting to get the user's terminal device name, user name, user program name, or process name during logon, VMS system service $GETJPIW failed.

Action: Examine the system error message and refer to VMS documentation.

ORA-07655 slsprom:$TRNLOG failure

Cause: While attempting to translate SYS$INPUT during a prompt for a password, VMS system service $TRNLOG failed.

Action: Examine the system error message and refer to VMS documentation.

ORA-07656 slsprom:$GETDVI failure

Cause: While attempting to get device characteristics during a prompt for a password, VMS system service $GETDVI failed.

Action: Examine the system error message and refer to VMS documentation.

ORA-07657 slsprom:$ASSIGN failure

Cause: While prompting for a password, VMS system service $ASSIGN failed.

Action: Examine the system error message and refer to VMS documentation.

ORA-07658 slsprom:$QIOW read failure

Cause: While prompting for a password, VMS system service $QIOW failed.

Action: Examine the system error message and refer to VMS documentation.

ORA-07665 ssrexhd: recursive exception encountered string string string string string string

Cause: A VMS exception occurred while executing in the Oracle exception handler. The message includes the signal number, first and second signal arguments, and exception PC, PSL and R0. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07670 $IDTOASC failed translating a secrecy category

Cause: VMS system service $IDTOASC failed while looking up the string representation in the rights database of a secrecy category.

Action: Define the entry in the rights database which the binary label you specified references.

ORA-07671 $IDTOASC failed translating an integrity category

Cause: VMS system service $IDTOASC failed while looking up the string representation in the rights database of an integrity category.

Action: Define the entry in the rights database which the binary label you specified references.

ORA-07672 $PARSE_CLASS failed translating the string into a binary label

Cause: SEVMS system service $PARSE_CLASS failed because the given string did not represent a valid classification.

Action: Examine system error message and refer to SEVMS documentation.

ORA-07680 sou2os: another call to ORACLE currently executing

Cause: A call to the Oracle shared image entry point occurred from within the shared image. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07681 sou2os: An error occurred while initializing Oracle

Cause: While attempting to set up the dispatch vectors for the shared image, an error occurred. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07682 sou2os: set kernel dispatch fail err

Cause: During Oracle shared image entry, a dispatch to kernel mode failed.

Action: Make sure that your shared image is installed with the CMKRNL privilege, then contact Oracle Support Services.

ORA-07683 sou2os: $SETPRV reset error

Cause: During an attempt to restore user privileges at Oracle shared image exit, VMS system service $SETPRV failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07684 sou2os: supervisor stack reset error

Cause: During an attempt to restore the supervisor-mode stack at Oracle shared image exit, VMS system service $SETSTK failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07685 sou2os: supervisor stack set error

Cause: During an attempt to set the Oracle supervisor-mode stack at Oracle shared image entry, VMS system service $SETSTK failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07700 sksarch: interrupt received

Cause: An interrupt was received while archiving the logs.

Action: Retry the operation.

ORA-07701 sksatln: internal exception: output buffer too small

Cause: Overflow of buffer for parsing archive control text string. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07702 unrecognized device type in archive text

Cause: Unrecognized device type in archive text. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07703 error in archive text: need '/' after device type

Cause: The archive control text in the ARCHIVE command is invalid; the device type (to indicate a file or tape) must be followed by a '/'.

Action: Refer to the Oracle9i User-Managed Backup and Recovery Guide for the proper syntax of the text.

ORA-07704 error in archive text: need ':' after device name

Cause: The archive control text in the ARCHIVE command is invalid; the device name must be followed by a ':'.

Action: Refer to the Oracle9i User-Managed Backup and Recovery Guide for the proper syntax of the text.

ORA-07705 sksaprs: device name buffer too small

Cause: The buffer supplied for the device name is too small. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07706 error in archive text: need disk file name

Cause: The archive control text in the ARCHIVE command is invalid; the disk file name is missing.

Action: Refer to the Oracle9i User-Managed Backup and Recovery Guide for the proper syntax of the text.

ORA-07707 error in archive text: need tape label name

Cause: The archive control text in the ARCHIVE command is invalid; the tape label name is missing.

Action: Refer to the Oracle9i User-Managed Backup and Recovery Guide for the proper syntax of the text.

ORA-07708 sksaprs: tape label name buffer too small

Cause: The buffer supplied for the tape label is too small. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07709 sksaprs: archiving to a remote host is not allowed

Cause: The user specified a remote disk for archiving via DECnet.

Action: Archive to a disk on the local host.

ORA-07710 sksaprs: file name buffer too small

Cause: The buffer supplied for the file name is too small. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07713 sksamtd: could not mount archival device (SYS$MOUNT failure)

Cause: VMS system service SYS$MOUNT failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07715 sksadtd: could not dismount archival device (SYS$DISMNT failure)

Cause: VMS system service SYS$DISMNT failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07716 sksachk: invalid device specification for ARCHIVE

Cause: VMS system service SYS$GETDVI failed".

Action: Specify a valid device in ARCHIVE control string.

ORA-07717 sksaalo: error allocating memory

Cause: VMS system service LIB$GET_VM failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07718 sksafre: error freeing memory

Cause: VMS system service LIB$FREE_VM failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07721 scgcm: not enough OS resource to obtain system enqueue

Cause: A call to SYS$ENQ returned an error indicating that the operating system lacked the resources necessary to create a lock. This is caused by the messages SS$_EXENQLM or SS$_INSFMEM.

Action: Free up some of the required resource to allow the creation of the required lock.

ORA-07740 slemop: incorrect handle size (programming error)

Cause: Structures used for reading error message files do not match. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07741 slemop: $OPEN failure

Cause: VMS system service $OPEN failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07742 slemop: $CONNECT failure

Cause: VMS system service $CONNECT failed.

Action: Examine system error message and refer to VMS documentation.

ORA-07743 slemop: incorrect error file attributes

Cause: An error message file is of incorrect format.

Action: Unless an error file has been changed, report this to Oracle.

ORA-07744 slemcl: invalid error message file handle

Cause: Seal in passed in handle does not match correct value. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07745 slemcl: $CLOSE failure

Cause: VMS system service $CLOSE failed.

Action: Check system error and refer to VMS documentation.

ORA-07746 slemrd: invalid error message file handle

Cause: seal in passed in handle does not match correct value. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07747 slemrd: $READ failure

Cause: VMS system service $READ failed.

Action: Check system error and refer to VMS documentation.

ORA-07750 slemcr: fopen failure

Cause: An attempt to create a message file failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07751 slemcr: malloc failure

Cause: An attempt to allocate a cache for a newly-created message file failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07753 slemcf: fseek before write failure

Cause: An attempt to seek before writing a message file cache element failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07754 slemcf: fwrite failure

Cause: An attempt to write a message file cache element failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07755 slemcf: fseek before read failure

Cause: An attempt to seek before reading a message file cache element failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07756 slemcf: fread failure

Cause: An attempt to read a message file cache element failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07757 slemcc: invalid handle

Cause: The seal in a passed-in handle does not match correct value. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07758 slemcw: invalid handle

Cause: The seal in a passed-in handle does not match correct value. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07759 slemtr: invalid destination

Cause: The destination string provided to the function is too short. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07760 slemtr: $open failure

Cause: The $open service failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07800 slbtpd: invalid number

Cause: An impossible request for binary to decimal conversion was made.

Action: This conversion cannot be performed.

ORA-07801 slbtpd: invalid exponent

Cause: An impossible request for binary to decimal conversion was made.

Action: This conversion cannot be performed.

ORA-07802 slbtpd: overflow while converting to packed decimal

Cause: An impossible request for binary to decimal conversion was made.

Action: This conversion cannot be performed.

ORA-07803 slpdtb: invalid packed decimal nibble

Cause: An impossible request for decimal to binary conversion was made.

Action: This conversion cannot be performed.

ORA-07804 slpdtb: number too large for supplied buffer

Cause: An impossible request for decimal to binary conversion was made.

Action: This conversion cannot be performed.

ORA-07820 sspscn: SYS$CRELNM failure

Cause: An error was returned from the SYS$CRELNM function.

Action: Check system error and refer to VMS documentation.

ORA-07821 sspsdn: SYS$DELLNM failure

Cause: An error was returned from the SYS$DELLNM function.

Action: Check system error and refer to VMS documentation.

ORA-07822 sspscm: SYS$CREMBX failure

Cause: An error was returned from the SYS$CREMBX function while trying to create the process dump mailbox.

Action: Check system error and refer to VMS documentation.

ORA-07823 sspsqr: $QIO failure

Cause: An error was returned from $QIO while trying to queue a read to the process dump mailbox.

Action: Check system error and refer to VMS documentation.

ORA-07824 sspain: $SETIMR failure

Cause: An error was returned from SYS$SETIMR while trying to queue a process spin-watch timer.

Action: Check system error and refer to VMS documentation.

ORA-07825 sspsck: $QIO failure at AST level

Cause: An error was returned from SYS$QIO while trying to read the process dump mailbox.

Action: Check system error and refer to VMS documentation.

ORA-07826 sspscm: SYS$GETDVIW failure

Cause: An error was returned from SYS$GETDVIW while trying to get information about the process dump mailbox.

Action: Check system error and refer to VMS documentation.

ORA-07840 sllfop: LIB$GET_VM failure

Cause: An error was returned from LIB$GET_VM while attempting to allocate memory for an I/O vector.

Action: Check system error and refer to VMS documentation.

ORA-07841 sllfop: SYS$OPEN failure

Cause: An error was returned from SYS$OPEN while attempting to open the datafile for reading.

Action: Check system error and refer to VMS documentation.

ORA-07842 sllfcl: SYS$CLOSE failure

Cause: An error was returned from SYS$CLOSE while attempting to close the input datafile.

Action: Check system error and refer to VMS documentation.

ORA-07843 sllfcl: LIB$FREE_VM failure

Cause: An error was returned from LIB$FREE_VM while attempting to free the memory for the I/O vector.

Action: Check system error and refer to VMS documentation.

ORA-07844 sllfop: LIB$GET_VM failure

Cause: An error was returned from LIB$GET_VM while attempting to allocate memory for data and index buffers.

Action: Check system error and refer to VMS documentation.

ORA-07845 sllfcl: LIB$FREE_VM failue

Cause: An error was returned from LIB$FREE_VM while attempting to free memory used by data and index buffers.

Action: Check system error and refer to VMS documentation.

ORA-07846 sllfop: string byte record too big for string byte user buffer

Cause: The longest record in the file will not fit into the largest data buffer that can be allocated.

Action: Modify the RMS file to have smaller records.

ORA-07847 sllfop: $CONNECT failure

Cause: An error was returned by SYS$CONNECT while attempting to open the datafile.

Action: Check system error and refer to VMS documentation.

ORA-07848 sllfrb: $GET failure

Cause: An error was returned by SYS$GET while attempting to read the datafile.

Action: Check system error and refer to VMS documentation.

ORA-07849 sllfsk: $GET failure

Cause: An error was returned by SYS$GET while attempting to skip records in the input file.

Action: Check system error and refer to VMS documentation.

ORA-07850 sllfop: bad option

Cause: You are using a bad option to loader Fixed= is one legal option. Check documentation for others.

Action: Check documentation.

ORA-07860 osnsoi: error setting up interrupt handler

Cause: An error occurred while setting up the control interrupt handler. This is an internal error.

Action: Contact Oracle Support Services.

ORA-07880 sdopnf: internal error

Cause: A list of all files open by this process could not be obtained. This is an internal error.

Action: Contact Oracle Support Services.

ORA-08000 maximum number of session sequence lists exceeded

Cause: The sequence parent state objects for this session are all used. This is an internal error.

Action: Quit the session and begin a new one.

ORA-08001 maximum number of sequences per session exceeded

Cause: The limit on the number of sequences usable by session has been hit.

Action: Increase initialization parameter USER_SEQUENCES to get more.

ORA-08002 sequence string.CURRVAL is not yet defined in this session

Cause: Sequence CURRVAL has been selected before sequence NEXTVAL.

Action: Select NEXTVAL from the sequence before selecting CURRVAL.

ORA-08003 sequence string.NEXTVAL exceeds internal limits

Cause: The sequence was created with unsafe values for some of the parameters. The calculation of NEXTVAL cannot be made because it exceeds the legal representation size.

Action: Alter or re-create the sequence number with legal limits.

ORA-08004 sequence string.NEXTVAL string stringVALUE and cannot be instantiated

Cause: Instantiating NEXTVAL would violate one of MAX/MINVALUE.

Action: Alter the sequence so that a new value can be requested.

ORA-08005 specified row does not exist

Cause: A row with the given ROWID does not exist in any of the tables given.

Action: Check the query for misspellings of table names and the ROWID.

ORA-08006 specified row no longer exists

Cause: The row has been deleted by another user since the operation began.

Action: Retry the operation.

ORA-08008 another instance is mounted with USE_ROW_ENQUEUES = string

Cause: The shared instance being started does not have the same value for USE_ROW_ENQUEUES as already running instances.

Action: Ensure that all instances' INIT.ORA files specify the same value for the parameter USE_ROW_ENQUEUES.

ORA-08100 index is not valid - see trace file for diagnostics

Cause: Validate Index detected an inconsistency in its argument index.

Action: Send trace file to Oracle Support Services.

ORA-08101 index key does not exist root dba string, dba string (string)

Cause: This is an internal error; possible inconsistency in index.

Action: Send trace file to Oracle Support Services, along with information on reproducing the error.

ORA-08102 index key not found, obj# string, dba string (string)

Cause: This is an internal error; possible inconsistency in index.

Action: Send trace file to Oracle Support Services, along with information on reproducing the error.

ORA-08103 object no longer exists

Cause: The object has been deleted by another user since the operation began.

Action: Remove references to the object.

ORA-08104 this index object string is being online built or rebuilt

Cause: The index is being created or rebuild or waited for recovering from the online (re)build.

Action: Wait the online index build or recovery to complete.

ORA-08105 Oracle event to turn off smon cleanup for online index build

Cause: Set this event only under the supervision of Oracle development.

Action: Debugging only.

ORA-08106 can not create journal table string.string

Cause: Online index builder cannot create its journal table.

Action: Rename your table in conflict.

ORA-08108 may not build or rebuild this type of index online

Cause: Only support normal index or IOT top-level index.

Action: Change your index type.

ORA-08109 nosort is not a supported option for online index build

Cause: May not specify NOSORT for online index build.

Action: Get rid of NOSORT in the index creation command.

ORA-08110 Oracle event to test SMON cleanup for online index build

Cause: Oracle Kernel test only.

Action: Do not set this event (for test only).

ORA-08111 a partitioned index may not be coalesced as a whole

Cause: User attempted to coalesce a partitioned index using ALTER INDEX COALESCE statement, which is illegal.

Action: Coalesce the index a (sub)partition at a time (using ALTER INDEX MODIFY (sub)PARTITION COALESCE).

ORA-08112 a composite partition may not be coalesced as a whole

Cause: User attempted to coalesce a composite partition.

Action: Coalesce the index a subpartition at a time (using ALTER INDEX MODIFY SUBPARTITION COALESCE).

ORA-08113 composite partition index may not be compressed

Cause: User attempted to compress a composite partition index.

Action: Create uncompressed composite partition index.

ORA-08114 can not alter a fake index

Cause: An attempt was made to alter a fake index.

Action: Drop the fake index.

ORA-08115 can not online create/rebuild this index type

Cause: User attempted to create index type that online does not support.

Action: Use offline index create/rebuild command.

ORA-08116 can not acquire DML enough lock(S mode) for online index build

Cause: User attempted to create index online without allowing DML Share lock.

Action: Allow DML share lock on the base table.

ORA-08117 Index Organized Table operation released its block pin

Cause: Block maintenance forced the release of a block pin.

Action: Contact Oracle Support Services.

ORA-08118 Deferred FK constraints cannot be enforced, index too big (string)

Cause: Deferred Foreign Key constraints cannot be enforced due to the index key being too big and built on a non-default DB_BLOCK_SIZE.

Action: First try to drop the Foreign Key and then the primary key.

ORA-08119 The new initrans will make the index too big

Cause: The specified initrans needs additional space to hold the index key, which might make the index too big.

Action: Try specifying a smaller initrans value.

ORA-08175 discrete transaction restriction violated (string)

Cause: An attempt was made to perform an action that is not currently supported in a discrete transaction.

Action: Roll back the transaction, and retry it as a normal transaction.

ORA-08176 consistent read failure; rollback data not available

Cause: Encountered data changed by an operation that does not generate rollback data: create index, direct load or discrete transaction.

Action: In read/write transactions, retry the intended operation. Read-only transactions must be restarted.

ORA-08177 can't serialize access for this transaction

Cause: Encountered data changed by an operation that occurred after the start of this serializable transaction.

Action: In read/write transactions, retry the intended operation or transaction.

ORA-08178 illegal SERIALIZABLE clause specified for user INTERNAL

Cause: Serializable mode is not supported for user INTERNAL.

Action: Reconnect as another user and retry the SET TRANSACTION command.

ORA-08179 concurrency check failed

Cause: Encountered data changed by an operation that occurred after a specific snapshot. This is usually used to indicate that a particular cached copy of a data block is stale. This is used for internal use for now.

Action: Refresh the cached copy of the data block and retry operation.

ORA-08180 no snapshot found based on specified time

Cause: Could not match the time to an SCN from the mapping table.

Action: Try using a larger time.

ORA-08181 specified number is not a valid system change number

Cause: The supplied scn was beyond the bounds of a valid scn.

Action: Use a valid scn.

ORA-08182 operation not supported while in Flashback mode

Cause: User tried to do DML or DDL while in Flashback mode.

Action: Disable Flashback and re-attempt the operation.

ORA-08183 Flashback cannot be enabled in the middle of a transaction.

Cause: User tried to do Flashback in the middle of a transaction.

Action: Issue a COMMIT statement.

ORA-08184 attempting to re-enable Flashback while in Flashback mode

Cause: An attempt was made to re-enable Flashback while in Flashback mode.

Action: Disable Flashback before re-enabling Flashback mode.

ORA-08185 Flashback not supported for user SYS.

Cause: User logged in as SYS.

Action: Log in as a different user.

ORA-08186 invalid timestamp specified

Cause: An invalid timestamp was specified.

Action: Enter a valid timestamp.

ORA-08187 snapshot expression not allowed here

Cause: A snapshot expression using AS OF was specified when not allowed.

Action: Do not use the AS OF clause.

ORA-08205 ora_addr: $ORACLE_SID not set in environment

Cause: The environment variable ORACLE_SID is not set.

Action: Set the ORACLE_SID environment variable.

ORA-08206 ora_addr: cannot translate address file name

Cause: Cannot translate $ORACLE_HOME/dbs/sgadef$ORACLE_SID.dbf.

Action: Ensure that ORACLE_HOME and ORACLE_SID are properly set.

ORA-08207 ora_addr: cannot open address file

Cause: The address file could not be opened.

Action: Check that Oracle is up. Check that the file $(ORACLE_HOME)/dbs/sgadef$(ORACLE_SID).dbf exists and has correct permissions.

ORA-08208 ora_addr: cannot read from address file

Cause: The address file could not be read.

Action: Check that the file $(ORACLE_HOME)/dbs/sgadef$(ORACLE_SID).dbf exists and contains a single line of text.

ORA-08209 scngrs: SCN not yet initialized

Cause: The System Commit Number has not yet been initialized.

Action: Contact Oracle Support Services.

ORA-08210 Requested I/O error

Cause: Oracle requested that an I/O error be returned for this operation.

Action: This should not occur in normal Oracle operation. Contact support.

ORA-08230 smscre: failed to allocate SGA

Cause: The N_CORE system call failed, maybe due to insufficient memory.

Action: Specify a smaller number of buffers. Check INIT.ORA parameters.

ORA-08231 smscre: unable to attach to SGA

Cause: The process cannot attach to the SGA. This can happen if either the listener cannot attach, or the process cannot communicate with the listener.

Action: Verify that the instance is up and running. Contact Oracle Support Services.

ORA-08232 smsdes: cannot detach from SGA

Cause: Probably the listener process has died.

Action: Contact Oracle Support Services.

ORA-08233 smsdes: cannot unmap SGA

Cause: The N_CORE system call failed while detaching from the SGA.

Action: Note NCX error returned; contact Oracle Support Services.

ORA-08234 smsget: cannot get instance listener address

Cause: The instance listener address cannot be read from the SGADEF file.

Action: Verify $(ORACLE_HOME) and $(ORACLE_SID) are set correctly. Additional information gives error return from ORA_ADDR.

ORA-08235 smsget: listener not on this node

Cause: A process wishing to attach to the SGA is on a different node from its instance's listener.

Action: Verify $(ORACLE_HOME) and $(ORACLE_SID) are set correctly. Contact Oracle Support Services.

ORA-08236 smsget: cannot share subcube with listener

Cause: The N_SHARE call failed, probably because the listener has died.

Action: Check if the listener is running, and contact Oracle Support Services.

ORA-08237 smsget: SGA region not yet created

Cause: An attempt was made to attach to an SGA which has not yet been created.

Action: Verify that the instance is running. Contact Oracle Support Services.

ORA-08238 smsfre: cannot detach from SGA

Cause: The N_CORE system call failed while detaching from the SGA.

Action: Check NCX error, and contact Oracle Support Services.

ORA-08260 ora_addr: cannot open nameserver

Cause: A process could not connect to the name server.

Action: Make sure the name server is up and running. Additional information gives name server's returned status.

ORA-08261 ora_addr: cannot find name in nameserver

Cause: The listener name server entry for an instance could not be found.

Action: Make sure the name server is up and running. Additional information gives name server's returned status.

ORA-08263 ora_addr: cannot free listener address

Cause: The listener name server entry could not be freed.

Action: Additional information gives name server's returned status. Contact Oracle Support Services.

ORA-08264 ora_addr: cannot close nameserver

Cause: The connection to the name server could not be closed.

Action: Additional information gives name server's returned status. Contact Oracle Support Services.

ORA-08265 create_ora_addr: cannot open nameserver

Cause: A process could not connect to the name server.

Action: Make sure the name server is up and running. Additional information gives name server's returned status.

ORA-08266 create_ora_addr: cannot register name in nameserver

Cause: The listener's addressing information could not be registered.

Action: Make sure the name server is up and running. Additional information gives name server's returned status.

ORA-08267 destroy_ora_addr: cannot close nameserver

Cause: The connection to the name server could not be closed.

Action: Additional information gives name server's returned status. Contact Oracle Support Services.

ORA-08268 create_ora_addr: cannot close nameserver

Cause: The connection to the name server could not be closed.

Action: Additional information gives name server's returned status. Contact Oracle Support Services.

ORA-08269 destroy_ora_addr: cannot destroy name

Cause: The listener's addressing information could not be removed.

Action: Additional information gives name server's returned status. Contact Oracle Support Services.

ORA-08270 sksachk: Illegal archival control string

Cause: Archive files cannot be created with the given archival control string.

Action: Check that the volume exists.

ORA-08271 sksabln: Buffer size not large enough for archive control string

Cause: The given archival control string expands into too many characters.

Action: Reduce archive control string length.

ORA-08274 Out of memory for environment variable

Cause: There is insufficient memory to return the requested value.

Action: Reduce memory usage and retry.

ORA-08275 Environment variable unset

Cause: The requested environment variable is not set.

Action: Ensure that the variable name requested is correct.

ORA-08276 No room in nameserver for pid

Cause: There is no room to record the PID for a background process.

Action: SHUTDOWN ABORT and restart the database.

ORA-08277 Cannot set environment variable

Cause: There is insufficient memory to expand the environment.

Action: Reduce memory usage and retry.

ORA-08278 Cannot get CPU statistics

Cause: Could not retrieve CPU times because N_STAT failed.

Action: Contact Oracle Support Services.

ORA-08308 sllfop: Cannot open file

Cause: Oracle could not open a file.

Action: Check the UNIX errno returned as additional information.

ORA-08309 sllfop: Cannot fstat file

Cause: Oracle could not obtain information about an open file.

Action: Check the UNIX errno returned as additional information.

ORA-08310 sllfop: Bad value for recsize

Cause: An illegal value for the record size was specified.

Action: Specify a value for the RECSIZE option that is greater than 0.

ORA-08311 sllfop: bad value for maxrecsize

Cause: An illegal value for the maximum record size was specified.

Action: Specify a value for the MAXRECSIZE option that is greater than 0.

ORA-08312 sllfop: unrecognized processing option

Cause: An unrecognized processing option was specified.

Action: Check the Oracle for nCUBE 2 Installation and User's Guide for valid options.

ORA-08313 sllfop: could not allocate buffers

Cause: Memory for the load buffers could not be allocated.

Action: Reduce the maximum record size. Eliminate any unnecessary processes on your current node before running SQL*Loader again.

ORA-08314 sllfcf: Error closing file

Cause: An error occurred trying to close a file.

Action: Check the UNIX errno returned as additional information.

ORA-08315 sllfrb: Error reading file

Cause: An error occurred trying to read from a file.

Action: Check the UNIX errno returned as additional information.

ORA-08316 sllfsk: Error seeking in file.

Cause: The LSEEK system call returned an error.

Action: Check the UNIX errno returned as additional information.

ORA-08317 sllfsk: Error seeking in file.

Cause: The LSEEK system call returned an error.

Action: Check the UNIX errno returned as additional information.

ORA-08318 sllfsk: Error reading file

Cause: An error occurred trying to read from a file.

Action: Check the UNIX errno returned as additional information.

ORA-08319 sllfsk: Error reading file

Cause: An error occurred trying to read from a file.

Action: Check the UNIX errno returned as additional information.

ORA-08320 scnget: Call to scnget before scnset or scnfnd.

Cause: This is an internal error

Action: Contact Oracle Support Services.

ORA-08321 scnmin: NOT IMPLEMENTED YET

Cause: This is an internal error

Action: Contact Oracle Support Services.

ORA-08322 scnmin: open/convert of bias lock failed

Cause: A call to the LKMGR failed to open and convert the bias lock.

Action: Check to make sure the LKMGR is up.

ORA-08323 scnmin: close of bias lock failed

Cause: A call to the LKMGR failed to close the bias lock.

Action: Check to make sure the LKMGR is up.

ORA-08330 Printing not supported

Cause: An attempt was made to automatically spool a file to the printer.

Action: No action required.

ORA-08331 Wait operation timed out

Cause: Oracle timed out waiting for an event.

Action: Contact Oracle Support Services.

ORA-08332 rollback segment #string specified not available

Cause: See ORA-01545.

Action: See ORA-1545. Also, make sure you have created enough rollback segments for the number of instances you are trying to start.

ORA-08340 This command not allowed on nCUBE, only one thread is ever used.

Cause: An illegal command was executed for the nCUBE platform.

Action: There is no need to issue this command.

ORA-08341 On nCUBE, this command can only be executed from instance 1.

Cause: A command that can only be issued on instance 1 was issued elsewhere.

Action: Log on to instance 1 and repeat the command.

ORA-08342 sropen: failed to open a redo server connection

Cause: An error occurred trying to connect to the redo server.

Action: The operating system-specific error message should tell you what to do.

ORA-08343 srclose: failed to close a redo server connection

Cause: An error occurred trying to close the redo server connection.

Action: The operating system-specific error message should tell you what to do.

ORA-08344 srapp: failed to send redo data to the redo server

Cause: An error occurred trying to send redo to the redo server.

Action: The operating system-specific error message should tell you what to do.

ORA-08401 invalid compiler name: string

Cause: An invalid compiler name comp_name was passed to a UTL_PG conversion routine.

Action: Correct the compiler name parameter in the PL/SQL code that called the conversion routine.

ORA-08412 error encountered in WMSGBSIZ, size for WMSGBLK is not big enough for warning message

Cause: The WMSGBSIZ is the maximum size for warning message block, it is recommended to be 1024 bytes to 8 kilobytes.

Action: Defined WMSGBLK of size between 1k to 8k bytes and update the WMSGBSIZ to the sizeof(WMSGBLK).

ORA-08413 invalid compiler type in FORMAT parameter at string

Cause: An invalid compiler type is defined in format control block. The format control block is invalid.

Action: Check to be sure that the format parameter was built by MAKE_RAW_TO_NUMBER_FORMAT or MAKE_NUMBER_TO_RAW_FORMAT, and that it was not accidentally overwritten or modified by the PL/SQL procedure.

ORA-08414 error encountered in string

Cause: The function routine returned an error. Where routine may be:

  • RAW_TO_NUMBER
  • NUMBER_TO_RAW
  • RAW_TO_NUMBER_FORMAT
  • NUMBER_TO_RAW_FORMAT
  • MAKE_NUMBER_TO_RAW_FORMAT
  • MAKE_RAW_TO_NUMBER_FORMAT

Action: This message will be preceded by messages providing details about the error. Check those messages to determine what action to take.

ORA-08429 raw data has invalid digit in display type data

Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine contained invalid data. The picture mask parameter specified a digit, but the corresponding input from the raw data did not contain a valid digit.

Action: Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.

ORA-08430 raw data missing leading sign

Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine had no leading sign, but the mask options parameter specified a leading sign.

Action: Correct the input raw data or the mask options so that they match.

ORA-08431 raw data missing zero as defined in picture

Cause: The picture mask parameter passed to a UTL_PG RAW_TO_NUMBER conversion routine contained a zero, but the corresponding input from the raw data was not a zero.

Action: Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.

ORA-08432 raw data has invalid floating point data

Cause: The input raw data passed to a UTL_PG RAW_TO_NUMBER conversion routine contained invalid floating point data.

Action: Correct the input raw data.

ORA-08433 invalid picture type in convert raw to number

Cause: The picture mask parameter passed to a UTL_PG RAW_TO_NUMBER conversion routine contained non-numeric characters, but the conversion was to a numeric data type.

Action: Correct the picture mask parameter.

ORA-08434 raw data has invalid trailing sign

Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine had no trailing sign, but the mask options parameter specified a trailing sign.

Action: Correct the input raw data or the mask options so that they match.

ORA-08435 PICTURE MASK missing the leading sign when SIGN IS LEADING specified

Cause: The input MASK passed to a UTL_PG RAW_TO_NUMBER conversion routine had no leading sign, but the mask options parameter specified a leading sign.

Action: Correct the input raw data or the mask options so that they match.

ORA-08436 raw data has invalid sign digit

Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine had an invalid sign digit in the position where the picture mask specified a sign.

Action: Correct the input raw data or the picture mask so that they match.

ORA-08437 invalid picture type in picture mask

Cause: The picture mask parameter passed to a UTL_PG NUMBER_TO_RAW conversion routine contained non-numeric characters, but the conversion was to a numeric data type.

Action: Correct the picture mask parameter.

ORA-08440 raw buffer is too short to hold converted data

Cause: The output raw buffer passed to a UTL_PG NUMBER_TO_RAW conversion routine was not large enough to contain the results of the conversion based on the picture mask.

Action: Increase the raw buffer size to the size necessary to hold the entire result of the conversion.

ORA-08441 closed parenthesis missing in picture mask

Cause: A closed parenthesis was missing from the picture mask passed to a UTL_PG conversion routine.

Action: Correct the picture mask.

ORA-08443 syntax error in BLANK WHEN ZERO clause in mask options

Cause: A syntax error was found in the BLANK WHEN ZERO clause in the mask options parameter passed to a UTL_PG conversion routine. Valid specifications are:

  • BLANK ZERO
  • BLANK ZEROS
  • BLANK ZEROES
  • BLANK WHEN ZERO
  • BLANK WHEN ZEROS
  • BLANK WHEN ZEROES

Action: Correct the mask options parameter.

ORA-08444 syntax error in JUSTIFIED clause in mask options

Cause: A syntax error was found in the JUSTIFIED clause in the mask options parameter passed to a UTL_PG conversion routine. Valid specifications are:

  • JUST
  • JUST RIGHT
  • JUSTIFIED
  • JUSTIFIED RIGHT

Action: Correct the mask options parameter.

ORA-08445 syntax error in SIGN clause in mask options

Cause: A syntax error was found in the SIGN clause in the mask options parameter passed to a UTL_PG conversion routine. Valid specifications are:

  • SIGN LEADING
  • SIGN LEADING SEPARATE
  • SIGN LEADING SEPARATE CHARACTER
  • SIGN TRAILING
  • SIGN TRAILING SEPARATE
  • SIGN TRAILING SEPARATE CHARACTER
  • SIGN IS LEADING
  • SIGN IS LEADING SEPARATE
  • SIGN IS LEADING SEPARATE CHARACTER
  • SIGN IS TRAILING
  • SIGN IS TRAILING SEPARATE
  • SIGN IS TRAILING SEPARATE CHARACTER

Action: Correct the mask options parameter.

ORA-08446 syntax error in SYNCHRONIZED clause in mask options

Cause: A syntax error was found in the SYNCHRONIZED clause in the mask options parameter passed to a UTL_PG conversion routine. Valid specifications are:

  • SYNC
  • SYNC LEFT
  • SYNC RIGHT
  • SYNCHRONIZED
  • SYNCHRONIZED LEFT
  • SYNCHRONIZED RIGHT

Action: Correct the mask options parameter.

ORA-08447 syntax error in USAGE clause in mask options

Cause: A syntax error was found in the USAGE clause in the mask options parameter passed to a UTL_PG conversion routine. Valid specifications are:

  • USAGE DISPLAY
  • USAGE COMP
  • USAGE COMP-3
  • USAGE COMP-4
  • USAGE COMPUTATIONAL
  • USAGE COMPUTATIONAL-3
  • USAGE COMPUTATIONAL-4
  • USAGE IS DISPLAY
  • USAGE IS COMP
  • USAGE IS COMP-3
  • USAGE IS COMP-4
  • USAGE IS COMPUTATIONAL
  • USAGE IS COMPUTATIONAL-3
  • USAGE IS COMPUTATIONAL-4

Action: Correct the mask options parameter.

ORA-08448 syntax error in DECIMAL-POINT environment clause

Cause: A syntax error was found in the DECIMAL-POINT environment clause parameter passed to a UTL_PG conversion routine. Valid specifications are: DECIMAL-POINT IS COMMA.

Action: Correct the environment clause parameter.

ORA-08449 invalid numeric symbol found in picture mask

Cause: An invalid numeric symbol was found in the picture mask parameter passed to a UTL_PG conversion routine.

Action: Correct the picture mask parameter.

ORA-08450 invalid specification of CR in picture mask

Cause: The CR suffix was incorrectly specified in the picture mask parameter passed to a UTL_PG conversion routine. The CR suffix can only appear at the end of a picture mask.

Action: Correct the picture mask parameter.

ORA-08451 invalid specification of DB in picture mask

Cause: The DB suffix was incorrectly specified in the picture mask parameter passed to a UTL_PG conversion routine. The DB suffix can only appear at the end of a picture mask.

Action: Correct the picture mask parameter.

ORA-08452 specification of E in picture mask is unsupported

Cause: The floating point exponent symbol 'E' was specified in the picture mask parameter passed to a UTL_PG conversion routine. The floating point data type is currently not supported by the UTL_PG conversion routines.

Action: Correct the picture mask parameter, and the data, if necessary.

ORA-08453 more than one V symbol specified in picture mask

Cause: The picture mask passed to a UTL_PG conversion routine contained more than one decimal point indicator ('V'). Only one decimal point indicator is allowed in the picture mask.

Action: Correct the picture mask parameter.

ORA-08454 more than one S symbol specified in picture mask

Cause: The picture mask passed to a UTL_PG conversion routine contained more than one operational sign indicator ('S'). Only one operational sign indicator is allowed in the picture mask.

Action: Correct the picture mask parameter.

ORA-08455 syntax error in CURRENCY SIGN environment clause

Cause: A syntax error was found in the CURRENCY SIGN environment clause parameter passed to a UTL_PG conversion routine. Valid specifications are: CURRENCY SIGN IS x where x is a valid currency sign.

Action: Correct the environment clause parameter.

ORA-08456 no sign in picture mask but SIGN clause in mask options

Cause: The picture mask parameter passed to a UTL_PG conversion routine contained no sign symbol ('S', '+', or '-'), but the mask options parameter contained a SIGN clause. A sign symbol is required in the picture mask parameter when the mask options parameter contains a SIGN clause.

Action: Correct the picture mask parameter or the mask options parameter.

ORA-08457 syntax error in SEPARATE CHARACTER option of SIGN clause

Cause: A syntax error was found in the SEPARATE CHARACTER option of the SIGN clause in the mask options parameter passed to a UTL_PG conversion routine. Valid specifications are: SEPARATE, SEPARATE CHARACTER.

Action: Correct the mask options parameter.

ORA-08458 invalid format parameter

Cause: The format parameter passed to a UTL_PG conversion routine was invalid. The format parameter should have been built by a prior call to either MAKE_RAW_TO_NUMBER_FORMAT or MAKE_NUMBER_TO_RAW_FORMAT.

Action: Check to be sure that the format parameter was built by MAKE_RAW_TO_NUMBER_FORMAT or MAKE_NUMBER_TO_RAW_FORMAT, and that it was not accidentally overwritten or modified by the PL/SQL procedure.

ORA-08459 invalid format parameter length

Cause: The format parameter passed to a UTL_PG conversion routine was not the correct length. Format parameters must be 2048 bytes in length.

Action: Check to be sure that the format parameter was built by MAKE_RAW_TO_NUMBER_FORMAT or MAKE_NUMBER_TO_RAW_FORMAT, and that it was not accidentally overwritten or modified by the PL/SQL procedure.

ORA-08460 invalid environment clause in environment parameter

Cause: The environment parameter passed to a UTL_PG conversion routine contained an unsupported or invalid environment clause. Only the CURRENCY SIGN and the DECIMAL-POINT IS COMMA environment clauses are supported.

Action: Correct the environment parameter.

ORA-08462 raw buffer contains invalid decimal data

Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine contains invalid decimal data.

Action: Correct the input data.

ORA-08463 overflow converting decimal number to Oracle number

Cause: The output variable passed to a UTL_PG RAW_TO_NUMBER was not large enough to hold the Oracle number resulting from the input decimal number.

Action: Be sure that the input decimal number is valid, and be sure that the output variable is large enough to hold the Oracle number value.

ORA-08464 input raw decimal data contains more than 42 digits

Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine contained more than 42 digits. This exceeds the maximum size of an Oracle number.

Action: Correct the raw input buffer.

ORA-08465 input mask contains more than 32 characters

Cause: The input mask passed to UTL_PG numeric conversion routine contained more the 32 characters.

Action: Correct the mask input buffer.

ORA-08466 raw buffer length string is too short for string

Cause: The input raw buffer passed to a UTL_PG RAW_TO_NUMBER conversion routine was less than string bytes long, but the picture mask parameter specified that string bytes of input data were to be converted.

Action: Either the input data is incorrect, or the picture mask is incorrect. Correct the appropriate item.

ORA-08467 error converting Oracle number to string

Cause: An error occurred when converting an Oracle number to a COBOL type of: DISPLAY COMP-3 or character variable. The Oracle number was not in the correct format.

Action: Correct the call to the conversion routine. The input must be a valid Oracle number variable.

ORA-08468 mask option string is not supported

Cause: The mask option clause was passed to a UTL_PG conversion routine, but is not supported by UTL_PG. The clause can be:

  • USAGE IS POINTER
  • USAGE IS INDEX
  • USAGE IS COMP-1
  • USAGE IS COMP-2 POINTER

Action: Remove the clause from the mask options parameter in the PL/SQL call to UTL_PG.

ORA-08498 Warning: picture mask 'string' overrides picture mask option 'USAGE IS string' to 'USAGE IS DISPLAY'

Cause: Picture mask USAGE option was overridden by the picture mask.

Action: This is an informational message only. The message may be eliminated by changing the USAGE option to match the picture mask.

ORA-08499 Warning: picture mask options 'string' ignored by UTL_PG

Cause: Picture mask options such as OCCUR, SYNC and others are not processed by the UTL_PG numeric conversion routines.

Action: This is an informational message only. The message may be eliminated by removing the unnecessary picture mask options from the parameter list passed to the UTL_PG routine.

ORA-09200 sfccf: error creating file

Cause: Could be out of disk space.

Action: See OSD error accompanying this message.

ORA-09201 sfcopy: error copying file

Cause: Block sizes may not match.

Action: See OSD error accompanying this message.

ORA-09202 sfifi: error identifying file

Cause: DB_BLOCK_SIZE specified in the INIT.ORA file could be incorrect.

Action: See OSD error accompanying this message.

ORA-09203 sfofi: error opening file

Cause: File attributes may have changed.

Action: See OSD error accompanying this message.

ORA-09204 sfotf: error opening temporary file

Cause: Incorrect path may have been specified for the file.

Action: See OSD error accompanying this message.

ORA-09205 sfqio: error reading or writing to disk

Cause: File may have been truncated or corrupted.

Action: See OSD error accompanying this message.

ORA-09206 sfrfb: error reading from file

Cause: File may have been truncated or corrupted.

Action: See OSD error accompanying this message.

ORA-09207 sfsrd: error reading from file

Cause: File may have been truncated or corrupted.

Action: See OSD error accompanying this message.

ORA-09208 sftcls: error closing file

Cause: File may have been corrupted.

Action: See OSD error accompanying this message.

ORA-09209 sftget: error reading from file

Cause: File may have been truncated or corrupted.

Action: See OSD error accompanying this message.

ORA-09210 sftopn: error opening file

Cause: Incorrect path may have been specified for the file.

Action: See OSD error accompanying this message.

ORA-09211 sfwfb: error writing to file

Cause: File may have been truncated or corrupted.

Action: See OSD error accompanying this message.

ORA-09212 sfwfbmt: error writing to file

Cause: File may have been truncated or corrupted.

Action: See OSD error accompanying this message.

ORA-09213 slgfn: error fabricating file name

Cause: File name may be too long.

Action: See OSD error accompanying this message.

ORA-09214 sfdone: I/O error detected

Cause: File may have been truncated or corrupted.

Action: See OSD error accompanying this message.

ORA-09215 sfqio: error detected in IOCompletionRoutine

Cause: File may have been truncated or corrupted.

Action: See OSD error accompanying this message.

ORA-09216 sdnfy: bad value 'string' for parameter string

Cause: The directory specified as the value for the stated parameter could not be used.

Action: Make sure the directory you have specified is a valid directory/file specification.

ORA-09217 sfsfs: failed to resize file

Cause: Could be out of disk space.

Action: See OSD error accompanying this message.

ORA-09218 sfrfs: failed to refresh file size

Cause: File may be corrupted or truncated.

Action: See OSD error accompanying this message.

ORA-09240 smpalo: error allocating PGA memory

Cause: Could be out of memory.

Action: See OSD error accompanying this message.

ORA-09241 smsalo: error allocating SGA memory

Cause: Could be out of memory.

Action: See OSD error accompanying this message.

ORA-09242 smscre: error creating SGA

Cause: An error occurred while creating SGA.

Action: See OSD error accompanying this message.

ORA-09243 smsget: error attaching to SGA

Cause: SGA may not have been created (database not started).

Action: See OSD error accompanying this message.

ORA-09244 smprset: error setting memory protections

Cause: An error occurred while setting memory protections.

Action: See OSD error accompanying this message.

ORA-09245 smcstk: error switching stacks

Cause: An error occurred while switching stacks.

Action: See OSD error accompanying this message.

ORA-09246 sfsmap: unable to map SGA

Cause: Unable to map SGA.

Action: See OSD error accompanying this message.

ORA-09247 smsdes: error destroying the SGA

Cause: An error occurred while destroying the SGA.

Action: See OSD error accompanying this message.

ORA-09260 sigpidu: error obtaining process id

Cause: May be out of resources.

Action: See OSD error accompanying this message.

ORA-09261 spdcr: error creating detached (background) process

Cause: Could be out of resources.

Action: See OSD error accompanying this message.

ORA-09262 spdde: error terminating detached (background) process

Cause: Could be out of resources.

Action: See OSD error accompanying this message.

ORA-09263 spini: error initializing process

Cause: Could be out of memory.

Action: See OSD error accompanying this message.

ORA-09264 sptpa: error flagging process

Cause: Could be out of resources.

Action: See OSD error accompanying this message.

ORA-09265 spwat: error temporarily suspending process

Cause: Could be out of resources.

Action: See OSD error accompanying this message.

ORA-09266 spawn: error starting an Oracle process

Cause: Could be out memory.

Action: See OSD error accompanying this message.

ORA-09270 szalloc: error allocating memory for security

Cause: Could be out of memory.

Action: See OSD error accompanying this message.

ORA-09271 szlon: error verifying user name

Cause: Username may be too long.

Action: See OSD error accompanying this message.

ORA-09272 remote os logon is not allowed

Cause: Remote operating system login attempted when not allowed.

Action: See OSD error accompanying this message.

ORA-09273 szrfc: error verifying role name

Cause: An operating system error was returned when verifying the role name.

Action: See OSD error accompanying this message.

ORA-09274 szrfc: insufficient role name buffer space

Cause: An OS role name was too long.

Action: See OSD error accompanying this message.

ORA-09275 CONNECT INTERNAL is not a valid DBA connection

Cause: CONNECT INTERNAL is no longer supported for DBA connections.

Action: Please try to connect AS SYSDBA or AS SYSOPER.

ORA-09280 sllfcf: error closing file

Cause: File may be corrupted.

Action: See OSD error accompanying this message.

ORA-09281 sllfop: error opening file

Cause: Possibly incorrect path specified to the file.

Action: See OSD error accompanying this message.

ORA-09282 sllfrb: error reading records

Cause: File could be corrupted.

Action: See OSD error accompanying this message.

ORA-09283 sllfsk: error skipping records

Cause: File could be corrupted.

Action: See OSD error accompanying this message.

ORA-09284 sllfop: cannot allocate read buffer

Cause: MALLOC() system call returned an error. The system might have run out of heap space.

Action: Check additional information for the operating system error.

ORA-09285 sllfop: unrecognizable processing option, incorrect format

Cause: Processing option passed is of incorrect format.

Action: Consult your IUG for permissible formats.

ORA-09290 sksaalo: error allocating memory for archival

Cause: Could be out of memory.

Action: See OSD error accompanying this message.

ORA-09291 sksachk: invalid device specified for archive destination

Cause: Unable to access directory.

Action: Specify a valid device in ARCHIVE control string.

ORA-09292 sksabln: unable to build archive file name

Cause: Bad directory or format specified.

Action: Specify a valid directory in LOG_ARCHIVE_FORMAT and a valid format string in LOG_ARCHIVE_FORMAT in the INIT.ORA file.

ORA-09293 sksasmo: unable to send message to console

Cause: An error was returned while attempting to send a message to the console operator.

Action: See OSD error accompanying this message.

ORA-09300 osncon: unable to connect, DPMI not available

Cause: Unable to detect the presence of DPMI.

Action: Restart Windows and retry.

ORA-09301 osncon: local kernel only supported in standard mode

Cause: An attempt was made to connect to S: while in enhanced mode.

Action: Restart Windows in standard mode.

ORA-09310 sclgt: error freeing latch

Cause: This is an internal error.

Action: See OSD error accompanying this message.

ORA-09311 slsleep: error temporarily suspending process

Cause: May be out of resources.

Action: See OSD error accompanying this message.

ORA-09312 slspool: error spooling file to printer

Cause: Could be out of resources.

Action: See OSD error accompanying this message.

ORA-09313 slsprom: error prompting user

Cause: May be out of resources.

Action: See OSD error accompanying this message.

ORA-09314 sltln: error translating logical name

Cause: Internal buffer may have overflowed.

Action: See OSD error accompanying this message.

ORA-09315 sql2tt: two-task error translating ORACLE_EXECUTABLE

Cause: This is an internal error.

Action: See OSD error accompanying this message.

ORA-09316 szrpc: unable to verify password for role

Cause: OS roles may not be supported for this platform.

Action: See OSD error accompanying this message.

ORA-09317 szprv: insufficient privileges

Cause: The password specified is invalid.

Action: See OSD error accompanying this message.

ORA-09318 slkhst: unable to host out to operating system

Cause: There might not be enough memory for the command or hosting out may not be supported on this platform.

Action: See OSD error accompanying this message.

ORA-09319 slgtd: unable to obtain the current date and time

Cause: The system time might be set incorrectly.

Action: See OSD error accompanying this message.

ORA-09320 szrfc: unable to obtain the list of valid OS roles

Cause: OS roles may not be supported on this platform.

Action: See OSD error accompanying this message.

ORA-09321 slzdtb: unable to convert zoned decimal to binary

Cause: This is an internal error.

Action: See OSD error accompanying this message.

ORA-09322 slpdtb: unable to convert packed decimal to binary

Cause: This is an internal error.

Action: See OSD error accompanying this message.

ORA-09330 Session terminated internally by Oracle or by an Oracle DBA

Cause: A client workstation that is abnormally disconnected would cause Oracle to terminate that session after about a minute. This message also appears in the trace file if a SHUTDOWN ABORT is performed.

Action: No action required.

ORA-09340 Specified ORACLE_SID is either invalid or too long

Cause: ORACLE_SID must be at the most 4 alphanumeric characters.

Action: Specify an ORACLE_SID with the correct format.

ORA-09341 scumnt: unable to mount database

Cause: Another instance is currently mounting the database.

Action: Try again later.

ORA-09342 Detached process terminated by Oracle during shutdown abort

Cause: The user performed a SHUTDOWN ABORT.

Action: No action required.

ORA-09344 spsig: error signalling thread

Cause: This function may not be implemented.

Action: No action required.

ORA-09350 Windows 32-bit Two-Task driver unable to allocate context area

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09351 Windows 32-bit Two-Task driver unable to allocate shared memory

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09352 Windows 32-bit Two-Task driver unable to spawn new ORACLE task

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09353 Windows 32-bit Two-Task driver unable to open event semaphore

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09354 Windows 32-bit Two-Task driver: ORACLE task unexpectedly died

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09360 Windows 3.1 Two-Task driver unable to allocate context area

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09361 Windows 3.1 Two-Task driver unable to lock context area

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09362 Windows 3.1 Two-Task driver unable to deallocate context area

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09363 Windows 3.1 Two-Task driver invalid context area

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09364 Windows 3.1 Two-Task driver unable to create hidden window

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09365 Windows 3.1 Two-Task driver unable to destroy hidden window

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09366 Windows 3.1 Two-Task driver unable to allocate shared memory

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09367 Windows 3.1 Two-Task driver unable to deallocate shared memory

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09368 Windows 3.1 Two-Task driver unable to spawn ORACLE

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09369 Windows 3.1 Two-Task driver bad instance handle

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09370 Windows 3.1 Two-Task driver ORACLE task timed out

Cause: See OSD error accompanying this message.

Action: See OSD error accompanying this message.

ORA-09700 sclin: maximum number of latches exceeded

Cause: Oracle wants to use more latches then available.

Action: Increase the value of the initialization parameter LATCH_PAGES or decrease the amount of shared memory you are using.

ORA-09701 scnfy: maximum number of processes exceeded

Cause: The value of the PROCESSES initialization parameter was exceeded.

Action: Decrease the PROCESSES parameter and restart.

ORA-09702 sem_acquire: cannot acquire latch semaphore

Cause: The semaphore used for accessing latches could not be seized.

Action: Send trace file to Oracle Support Services, along with information on reproducing the error.

ORA-09703 sem_release: cannot release latch semaphore

Cause: The semaphore used for accessing latches could not be released.

Action: Send trace file to Oracle Support Services, along with information on reproducing the error.

ORA-09704 sstascre: ftok error in creating test and set pages.

Cause: the FTOK() library call failed in SSTASTCRE().

Action: Verify that TASDEF@.DBF file exists. If it does then this is a possible system failure. Perhaps System V compatibility is not enabled.

ORA-09705 spcre: cannot initialize latch semaphore

Cause: The semaphore used for accessing latches could not be initialized.

Action: Send trace file to Oracle Support Services, along with information on reproducing the error.

ORA-09706 slsget: get_process_stats error.

Cause: GET_PROCESS_STATS system call returned an error. Possible operating system error.

Action: Check additional information returned. Look for information in operating system reference. Contact Oracle Support Services.

ORA-09708 soacon: failed to bind socket to port.

Cause: The bind system call failed on the socket.

Action: Check additional information for operating system error. Try connecting again.

ORA-09709 soacon: failed to accept a connection.

Cause: The accept system call failed on the socket.

Action: Check additional information for operating system error. Try connecting again.

ORA-09710 soarcv: buffer overflow.

Cause: The internal buffer is not big enough to hold the message read. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09711 orasrv: archmon already connected.

Cause: An existing connection has already been made from ARCHMON to ORASRV.

Action: Stop trying to connect.

ORA-09712 orasrv: log archiver already connected.

Cause: An existing connection has already been made from log archiver to ORASRV.

Action: Stop trying to connect.

ORA-09713 Global hardware clock failure caused instance termination.

Cause: The global hardware clock used to generate the System Change Number for Oracle has failed.

Action: Check the global hardware clock.

ORA-09714 Two Task interface: cannot obtain puname

Cause: The TXIPC driver cannot obtain the name of the PU. (Possible operating system error.)

Action: Check if the PUs are named (consistent).

ORA-09715 orasrv: cannot obtain puname

Cause: ORASRV cannot obtain the name of the PU (possible operating system error).

Action: Check if the PUs are named (consistent).

ORA-09716 kslcll: Unable to fix in-flux lamport latch.

Cause: One Oracle process died while still holding a LAMPORT latch.

Action: Exit (kill) all Oracle user processes. SHUTDOWN ABORT and restart Oracle RDBMS kernel.

ORA-09717 osnsui: maximum number of user interrupt handlers exceeded.

Cause: The internal limit on the number of user interrupt handlers has been exceeded.

Action: Reduce the number of simultaneous logons or reduce the number of user interrupt handlers.

ORA-09718 osnsui: cannot set up user interrupt handler.

Cause: MALLOC() failed to allocate space to hold user interrupt handler.

Action: Possible memory resource shortage.

ORA-09719 osncui: invalid handle.

Cause: The handle passed to OSNCUI is out of the valid range.

Action: Use a valid handle.

ORA-09740 slsget: cannot get virtual memory region statistics.

Cause: The VM_REGION system call failed to get virtual memory region statistics.

Action: Check return code in SERCERRNO. Possible operating system failure.

ORA-09741 spwat: error waiting for a post.

Cause: MSG_RECEIVE system call returned an error. This is an internal error.

Action: Check return code in SERCERRNO. Port name is returned in sercose[0].

ORA-09742 sppst: error during a post.

Cause: MSG_SEND system call returned an error. This is an internal error.

Action: Check return code in SERCERRNO. Port name is returned in sercose[0].

ORA-09743 smscre: could not attach shared memory.

Cause: The MMAP or write system call returned an error. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09744 smsget: mmap returned an error.

Cause: The MMAP system call returned an error. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09745 smscre: vm_allocate error, unable to create shared memory.

Cause: Error in system call VM_ALLOCATE. Failed to create SGA as a single shared memory segment.

Action: Check result code returned in SERCERRNO. Verify that the SGA attach address is valid.

ORA-09746 smscre: shared memory attach address incorrect.

Cause: The VM_ALLOCATE system call attached the SGA at an incorrect location.

Action: Verify that the SGA attach address is valid.

ORA-09747 pw_detachPorts: server call pws_detach failed.

Cause: The call PWS_DETACH to (Oracle helper) failed.

Action: Make sure the server is still active. Check the error code returned in SERCERRNO, and look for error messages in the server log file.

ORA-09748 pws_look_up: fork failed

Cause: The PWS_LOOK_UP call could not fork the (Oracle helper) process.

Action: Verify that there are enough system resources to support another process. The user or system process limit may have been exceeded, or the amount of free memory or swap space may be temporarily insufficient.

ORA-09749 pws_look_up: port lookup failure

Cause: The PWS_LOOK_UP could not find a port to (Oracle helper).

Action: Make sure the (Oracle helper) server has been started correctly by PWS_LOOK_UP, and that the network name server is still running.

ORA-09750 pw_attachPorts: port_rename failed.

Cause: The PORT_RENAME system call failed; possible internal error.

Action: Check return code in SERCERRNO, report to Oracle Support Services.

ORA-09751 pw_attachPorts: server call pws_attach failed.

Cause: The call PWS_ATTACH to (Oracle helper) failed.

Action: Make sure the server is still active. Check the error code returned in SERCERRNO, and look for error messages in the server log file.

ORA-09752 pw_attachPorts: port_allocate failed.

Cause: The PORT_ALLOCATE system call failed; possible resource exhaustion.

Action: Check return code in SERCERRNO, report to Oracle Support Services.

ORA-09753 spwat: invalid process number.

Cause: Function was passed an invalid Oracle process ID. This is an internal error.

Action: Additional information indicates the invalid process ID.

ORA-09754 sppst: invalid process number passed to sppst.

Cause: Function was passed an invalid Oracle process ID. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09755 osngpn: port allocation failure.

Cause: The PORT_ALLOCATE system call failed.

Action: Possible system resource shortage; check the error code in SERCERRNO.

ORA-09756 osnpns: no port in the name server.

Cause: OSNPNS could not find the given named port in the name server.

Action: Check the error code in SERCERRNO. Make sure the shadow process and network name server are still running.

ORA-09757 osnipn: port allocation failure.

Cause: The PORT_ALLOCATE system call failed.

Action: Possible system resource shortage; check the error code in SERCERRNO.

ORA-09758 osnipn: could not check port in name server.

Cause: The NETNAME_CHECK_IN call failed.

Action: Check the error code in SERCERRNO. Make sure the network name server is running.

ORA-09759 osnsbt: bad message received.

Cause: The MSG_RECEIVE system call failed, or received a bad message. This is an internal error.

Action: Report the error code returned in SERCERRNO.

ORA-09760 osnpui: cannot send break message

Cause: The Pipe driver could not send a break message to the Oracle shadow process break thread.

Action: Contact Oracle Support Services.

ORA-09761 pw_destroyPorts: server call pws_stop_instance failed.

Cause: The call PWS_STOP_INSTANCE to (Oracle helper) failed.

Action: Make sure the server is still active. Check the error code returned in SERCERRNO, and look for error messages in the server log file.

ORA-09762 sNeXT_instanceName: translation error.

Cause: A failure was detected while translating the value of ORACLE_SID.

Action: Make sure ORACLE_SID is defined, and that it is of legal length.

ORA-09763 osnmpx: send/receive error exchanging Mach ports.

Cause: The Mach driver failed to exchange port information with the other side of the connection. Either MSG_SEND (sercose[0] == 1) or MSG_RECEIVE (sercose[0] == 2) failed.

Action: Check return code in SERCERRNO. Make sure both sides of the connection are still running.

ORA-09764 osnmop: access error on oracle executable

Cause: The Mach driver could not access the Oracle executable.

Action: Check the permissions on the Oracle executable and each component of the ORACLE_HOME/bin path.

ORA-09765 osnmop: fork failed

Cause: The Mach driver could not fork the Oracle shadow process.

Action: Verify that there are enough system resources to support another process. The user or system process limit may have been exceeded, or the amount of free memory or swap space may be temporarily insufficient.

ORA-09766 osnmop: buffer allocation failure.

Cause: The Mach driver failed to allocate enough virtual memory space for its I/O buffers.

Action: Decrease the value of BUFFER_SIZE parameter in the Two-Task driver host string.

ORA-09767 osnmfs: bad return code from msg_send.

Cause: The MSG_SEND system call failed while flushing the Mach driver's send buffer. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09768 osnmgetmsg: could not read a message

Cause: The MSG_RECEIVE system call returned a failure code while waiting for a message in the Mach driver. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09769 osnmbr: cannot send break message

Cause: The Mach driver could not send a break message to the Oracle shadow process break thread. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09770 pws_look_up: translation failure.

Cause: The PWS_LOOK_UP routine failed to translate the name of the (Oracle helper) executable.

Action: Make sure ORACLE_SID and ORACLE_HOME are set and correct. Additional information gives the translation error code.

ORA-09771 osnmwrtbrkmsg: bad return code from msg_send.

Cause: The MSG_SEND system call failed while sending a Mach driver break. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09772 osnpmetbrkmsg: message from host had incorrect message type

Cause: The Mach driver received a message having an unrecognizable message type. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09773 osnmgetdatmsg: message from host had incorrect message type

Cause: The Mach driver received a message having an unrecognizable message type. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09774 osnmui: cannot send break message

Cause: The Mach driver could not send a break message to the Oracle shadow process break thread. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09775 osnmrs: reset protocol error

Cause: The Mach two-task driver could not reset the connection. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09776 pws_look_up: access error on (Oracle helper) executable

Cause: The PWS_LOOK_UP call could not access the (Oracle helper) executable.

Action: Check the permissions on the (Oracle helper) executable and each component of the ORACLE_HOME/bin path.

ORA-09777 osnpbr: cannot send break message

Cause: The pipe driver could not send a break message to the Oracle shadow process break thread. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09778 snynfyport: failure allocating the notify port.

Cause: The routine failed to allocate or set the task's notify port.

Action: Possible operating system error. Contact Oracle Support Services.

ORA-09779 snyGetPort: failure to allocate a port.

Cause: The PORT_ALLOCATE system call failed; system resources might be exhausted.

Action: Possible operating system error. Contact Oracle Support Services.

ORA-09786 sllfop: open error, unable to open file.

Cause: Open system call returned an error.

Action: Check errno.

ORA-09787 sllfop: unrecognizable processing option, incorrect format.

Cause: Processing option passed is of incorrect format.

Action: Consult your IUG for permissible formats.

ORA-09788 sllfrb: unable to read file.

Cause: Read system call returned an error.

Action: Check errno. Verify file exists.

ORA-09789 sllfsk: unable to read file.

Cause: Read system call returned an error.

Action: Check errno. Verify file exists.

ORA-09790 sllfcf: unable to close file.

Cause: Close system call returned an error.

Action: Check errno.

ORA-09791 slembdf: translation error, unable to translate error file name.

Cause: Additional information indicates error returned from SLTLN.

Action: Check additional information.

ORA-09792 sllfop: cannot allocate read buffer.

Cause: MALLOC system call returned an error. The system might have run out of heap space.

Action: Check additional information for the operating system error.

ORA-09793 szguns: length of user name is greater than buffer.

Cause: The length of the name of the user being looked up is longer than size of the buffer provided by the calling routine. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09794 szrbuild: length of role name is greater than buffer.

Cause: The length of the name of the role being looked up is longer than size of the buffer provided by the calling routine. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09795 szrbuild: malloc of role structure failed.

Cause: The allocation of memory for an internal structure used to hold a role descriptor failed.

Action: Check the UNIX error number for a possible operating system failure.

ORA-09796 szrbuild: malloc of role name failed.

Cause: The allocation of memory for an internal buffer used to hold the name of a role failed.

Action: Check the UNIX error number for a possible operating system failure.

ORA-09797 Failed to get O/S MAC privileges.

Cause: The operating system would not allow the retrieval of this process' privileges.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services.

ORA-09798 Label comparison failed.

Cause: The comparison of two binary labels failed.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services.

ORA-09799 File label retrieval failed.

Cause: Oracle was unable to get a label attached to a file.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services.

ORA-09800 Process sensitivity label retrieval failed.

Cause: Oracle was unable to get the sensitivity label for a process.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services.

ORA-09801 Unable to get user ID from connection

Cause: Oracle was unable to retrieve the user's ID number from the SQL*Net connection.

Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact Oracle Support Services.

ORA-09802 Conversion of binary label to string failed.

Cause: Oracle was unable to convert a binary label to a string.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services.

ORA-09803 Allocation of string buffer failed.

Cause: a buffer used to hold the name of the file for which a label was to be obtained could not be allocated.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services. The number of bytes that Oracle attempted to allocate is in the "Additional Information" field.

ORA-09804 Class conversion from binary to ORACLE failed.

Cause: Oracle was unable to convert a class component from binary format to Oracle format.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services.

ORA-09805 conversion of category number to string failed.

Cause: Oracle was unable to translate a category number to its corresponding string representation failed.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services. The category number is contained in the "Additional information" field.

ORA-09806 Allocation of label string buffer failed.

Cause: A temporary buffer used to hold a label could not be allocated.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services. The number of bytes that Oracle attempted to allocate is in the "Additional Information" field.

ORA-09807 Conversion of label from string to binary failed.

Cause: Oracle was unable to convert the string representation of a label to binary format.

Action: Re-enter a valid label.

ORA-09808 Could not obtain user clearance.

Cause: Oracle was unable to get a user's clearance level.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services.

ORA-09809 Unable to get user's group ID from connection

Cause: Oracle was unable to retrieve the user's group ID number from the SQL*Net connection.

Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact Oracle Support Services.

ORA-09810 Unable to get process ID from connection

Cause: Oracle was unable to retrieve the user's process ID number from the SQL*Net connection.

Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact Oracle Support Services.

ORA-09811 Unable to initialize package.

Cause: Oracle was unable to initialize the library used to obtain security information. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09812 Unable to get user clearance from connection

Cause: Oracle was unable to retrieve the user's operating system session clearance from the SQL*Net connection.

Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact Oracle Support Services.

ORA-09813 Unable to get directory status

Cause: Oracle was unable to determine if a directory is multilevel.

Action: Check the UNIX error number for a possible operating system error. If there is no error, contact Oracle Support Services.

ORA-09814 Unable to expand file name

Cause: Oracle was unable to expand the name of a file that resides in multilevel directory.

Action: Check the UNIX error number for a possible operating system error. If there is no error, contact Oracle Support Services.

ORA-09815 File name buffer overflow

Cause: The buffer that Oracle uses to hold the expanded name of a too small. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09816 Unable to set effective privileges

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-09817 Write to audit file failed.

Cause: Oracle was unable to write an entry to the file used as the audit trail.

Action: Check the UNIX error number for a possible operating system error. If there is no error, contact Oracle Support Services.

ORA-09818 Number is too large

Cause: Oracle was unable to convert a component string to a number because the number is larger than the largest possible value for an integer. The additional information field specifies the maximum.

Action: Correct the string and repeat the conversion.

ORA-09819 Number exceeds maximum legal value

Cause: the number specified for a component was greater than the maximum value allowed for that component.

Action: Change the component to a value less than the maximum and repeat the conversion. The maximum component number is contained in the "Additional information" field.

ORA-09820 Conversion of class string to numeric representation failed.

Cause: Oracle was unable to convert a class string to a number because all of the characters in the string were not numeric.

Action: Change the string to be either all numbers or all non-numeric characters and repeat the conversion.

ORA-09821 Numeric label is not valid

Cause: A label specified in Oracle numeric format was found not to be valid.

Action: Re-enter a valid label. Consult your system's encodings for valid numeric component values.

ORA-09822 Translation of audit file name failed.

Cause: Oracle was unable to translate the value of the AUDIT_TRAIL_DEST initialization parameter.

Action: Check the UNIX error number for a possible operating system error. If there is no error, contact Oracle Support Services.

ORA-09823 device name is too long

Cause: The name of a device was too long to fit into an internal buffer. The additional information field contains the length of the device name. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09824 Unable to enable allowmacaccess privilege.

Cause: Oracle was not able to turn on ALLOWMACACCESS privilege so that it could do a label comparison.

Action: Check the UNIX error number. If it indicates that Oracle does not have the ALLOWMACACCESS privilege, add the ALLOWMACACCESS privilege to the potential privilege set of $ORACLE_HOME/bin/oracle using CHPRIV (1M). If the executable already has the ALLOWMACACCESS privilege, contact Oracle Support Services.

ORA-09825 Unable to disable allowmacaccess privilege.

Cause: Oracle was not able to turn off the ALLOWMACACCESS privilege after doing a label comparison. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09826 SCLIN: cannot initialize atomic latch.

Cause: System call ATOMIC_OP() return error.

Action: Check additional information in the trace file.

ORA-09827 SCLGT: atomic latch return unknown error.

Cause: System call ATOMIC_OP() return unexpected error.

Action: Check additional information in the trace file.

ORA-09828 SCLFR: atomic latch return error.

Cause: System call ATOMIC_OP() return unexpected error.

Action: Check additional information in the trace file.

ORA-09829 pw_createPorts: server call pws_start_instance failed.

Cause: The call PWS_START_INSTANCE to (Oracle helper) failed; system resources might be exhausted.

Action: Make sure the server is still active. Check the error code returned in SERCERRNO, and look for error messages in the server log file.

ORA-09830 snyAddPort: failed to perform a remote procedure call.

Cause: The MSG_RPC system call returned an error. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09831 snyStartThread: failed to build the server port set.

Cause: The routine failed to build a port set on which to listen for requests. Possible operating system failure.

Action: Contact Oracle Support Services.

ORA-09832 infoCallback: bad message format.

Cause: The routine received an incorrectly formatted request. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09833 addCallback: bad message format.

Cause: The routine received an incorrectly formatted request. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09834 snyGetPortSet: failed to collect info on a port.

Cause: The PORT_STATUS system called failed. Possible operating system error.

Action: Contact Oracle Support Services.

ORA-09835 addCallback: callback port is already in a set.

Cause: The port to be added to the callback list is already in a port set. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09836 addCallback: could not add a port to the callback set.

Cause: The PORT_SET_ADD system called failed. Possible operating system error.

Action: Contact Oracle Support Services.

ORA-09837 addCallback: could not add allocate a callback link.

Cause: The MALLOC library call failed to allocate space for a callback link. Possible operating system error.

Action: Contact Oracle Support Services.

ORA-09838 removeCallback: failure removing the callback port.

Cause: The port PORT_SET_REMOVE system call failed. Possible operating system error.

Action: Contact Oracle Support Services.

ORA-09839 removeCallback: callback port is not in the callback set.

Cause: The port to be removed to the callback list is not in the callback port set. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09840 soacon: Name translation failure.

Cause: SLTLN() could not translate the named pipe ?/dbs/mon2arch_@.

Action: Make sure that the ORACLE_HOME specified for this ORACLE_SID in oratab is correct.

ORA-09841 soacon: Name translation failure.

Cause: SLTLN() could not translate the named pipe ?/dbs/arch2mon_@.

Action: Make sure that the ORACLE_HOME specified for this ORACLE_SID in ORATAB is correct.

ORA-09842 soacon: Archmon unable to create named pipe.

Cause: MKNOD() failed to create named pipe ?/dbs/mon2arch_@.

Action: Your current operating system login may lack write permission for the ORACLE_HOME/dbs directory. Only USERIDs in the DBA group of a given instance can run ARCHMON for that ORACLE_SID. Make sure that the ORACLE_HOME directory is correct in ORATAB.

ORA-09843 soacon: Archmon unable to create named pipe.

Cause: MKNOD() failed to create named pipe ?/dbs/arch2mon_@.

Action: Your current operating system login may lack write permission for the ORACLE_HOME/dbs directory. Only USERIDs in the dba group of a given instance can run ARCHMON for that ORACLE_SID. Make sure that the ORACLE_HOME directory is correct in ORATAB.

ORA-09844 soacon: Archmon unable to open named pipe.

Cause: OPEN() failed to open named pipe ?/dbs/mon2arch_@.

Action: Only the Oracle DBA can run ARCHMON. Make sure that your current operating system login has owner or group search permission for the ORACLE_HOME/dbs directory. The maximum number of open files may have been exceeded.

ORA-09845 soacon: Archmon unable to open named pipe.

Cause: OPEN() failed to open named pipe ?/dbs/arch2mon_@.

Action: Only the Oracle DBA can run ARCHMON. Make sure that your current operating system login has owner or group search permission for the ORACLE_HOME/dbs directory. The maximum number of open files may have been exceeded.

ORA-09846 soacon: ARCH unable to open named pipe.

Cause: OPEN() failed to open named pipe ?/dbs/mon2arch_@.

Action: Make sure that the operating system USERID of the currently running database has search permission for the ORACLE_HOME/dbs directory. The maximum number of open files may have been exceeded.

ORA-09847 soacon: ARCH unable to open named pipe.

Cause: OPEN() failed to open named pipe ?/dbs/arch2mon_@.

Action: Make sure that the operating system USERID of the currently running database has search permission for the ORACLE_HOME/dbs directory. The maximum number of open files may have been exceeded.

ORA-09850 soacon: Archmon unable to lock named pipe.

Cause: FCNTL() failed to set write lock on named pipe ?/dbs/arch2mon_@.

Action: Make sure that ARCHMON is not already active on another terminal for this ORACLE_SID. Only one ARCHMON session is allowed at a time for a given instance.

ORA-09851 soacon: Archmon unable to lock named pipe.

Cause: FCNTL() failed to set read lock on named pipe ?/dbs/mon2arch_@.

Action: Make sure that ARCHMON is not already active on another terminal for this ORACLE_SID. Only one ARCHMON session is allowed at a time for a given instance.

ORA-09853 snyRemovePort: bad return code from request.

Cause: The request to remove a port from the callback set returned a failure code. Possible operating system error.

Action: Contact Oracle Support Services.

ORA-09854 snyPortInfo: bad return code from request.

Cause: The request to collect information on a port in the callback set returned a failure code. Possible operating system error.

Action: Contact Oracle Support Services.

ORA-09855 removeCallback: bad message format.

Cause: The routine received an incorrectly formatted request. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09856 smpalo: vm_allocate error while allocating pga.

Cause: The VM_ALLOCATE system call returned an error.

Action: Check returned error. Possibly out of system resources.

ORA-09857 smprset: vm_protect error while protecting pga.

Cause: The VM_PROTECT system call returned an error. This is an internal error.

Action: Contact Oracle Support Services.


ORA-09858 to ORA-12299

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

8
ORA-09858 to ORA-12299

ORA-09870 spini: failure initializing maximum number of open files.

Cause: ULIMIT system call returned an error.

Action: Check errno.

ORA-09871 TASDEF_NAME: translation error while expanding ?/dbs/tasdef@.dbf.

Cause: Failure of sltln(?/tasdef@.dbf) while creating test and set pages.

Action: Check additional return error for more information.

ORA-09872 TASDEF_CREATE: create failure in creating ?/dbs/tasdef@.dbf.

Cause: CREATE() failed when trying to create the TASDEF file.

Action: Verify permissions on $(ORACLE_HOME)/dbs directory.

ORA-09873 TASDEF_OPEN: open error when opening tasdef@.dbf file.

Cause: Unable to open tasdef@.dbf file.

Action: Check errno. Possible permission problem. Verify that tasdef@.dbf file exists.

ORA-09874 TASDEF_READ: read error, unable to read tasdef@.dbf file.

Cause: Read system call returned an error when attempting to read ?/dbs/tasdef@.dbf.

Action: Check errno returned. SGADEF file may be corrupted or incompatible with Oracle version.

ORA-09875 TASDEF_WRITE: write error when writing ?/dbs/tasdef@.dbf file.

Cause: Write call failed.

Action: Check errno returned. Possibly out of space on device.

ORA-09876 TASDEF_CLOSE: unable to close ?/dbs/tasdef@.dbf file.

Cause: Close system call returned an error.

Action: Check errno returned. Possible operating system failure.

ORA-09877 sstascre: shmget error, unable to get a shared memory segment.

Cause: Error in SHMGET.

Action: Check errno returned. Verify that enough shared memory is available on the system.

ORA-09878 sstascre/sstasat: shmat error, unable to attach tas write page

Cause: Error in SHMAT.

Action: Check errno returned.Verify that enough shared memory is available on the system.

ORA-09879 sstascre/sstasat: shmat error, unable to attach tas read page

Cause: Error in SHMAT.

Action: Check errno returned.Verify that enough shared memory is available on the system.

ORA-09880 sstasfre/sstasdel: shmdt error, unable to detach tas write page

Cause: Error in SHMDT.

Action: Check errno returned.

ORA-09881 sstasfre/sstasdel: shmdt error, unable to detach tas read page

Cause: Error in SHMDT.

Action: Check errno returned.

ORA-09882 sstasfre/sstasdel: shmctl error, unable to remove tas shm page

Cause: Error in SHMCTL.

Action: Check errno returned.

ORA-09883 Two Task interface: oratab file does not exist

Cause: The ORATAB file does not exist.

Action: Install Oracle before you use it or re-create the ORATAB file.

ORA-09884 Two Task interface: SID doens't match current PU

Cause: You are trying to start Oracle on another PU than you configured Oracle on or there is no entry for this SID in the ORATAB file.

Action: Start Oracle with this SID on its designated PU (see the ORATAB file). Or install the new database with SID.

ORA-09885 osnTXtt: cannot create TXIPC channel

Cause: The TXIPC driver failed to create pipes for two-task communications with the Oracle shadow process.

Action: You have probably exceeded the maximum number of open file descriptors per user or the system file table is full. Note the operating system error code and contact your system administrator.

ORA-09886 osnTXtt: translation error while expanding txipc@.trc.

Cause: Failure of sltln(txipc@.trc) while creating debug channel.

Action: Check additional return error for more information.

ORA-09887 osnTXtt: Failed to create/open debug channel.

ORA-09888 osnTXtt: txipc channel creation failed

Cause: The TXIPC driver failed to create channels for two-task communications with the Oracle shadow process.

Action: You have probably exceeded the maximum number of open file descriptors per user or the system file table operating system error code and contact your system administrator.

ORA-09889 osnTXtt: access error on oracle executable

Cause: The TXIPC driver could not access the Oracle executable.

Action: Check the permissions on the Oracle executable and each component of the ORACLE_HOME/bin path.

ORA-09890 osnTXtt: malloc failed

Cause: The TXIPX driver failed to allocate enough heap space for its context area buffers.

Action: Contact Oracle Support Services.

ORA-09908 slkmnm: gethostname returned error code.

Cause: The system call GETHOSTNAME returned an error. This is most likely an internal error.

Action: Make sure GETHOSTNAME is successful in other contexts, and if so contact Oracle Support Services.

ORA-09909 Malloc of scratch buffer failed.

Cause: Memory needed for a temporary buffer could not be allocated. The additional information field contains the number of bytes that Oracle attempted to allocate.

Action: Check the UNIX error number. It is probable that the system has run out of memory. If there is no error, contact Oracle Support Services.

ORA-09910 Unable to find ORACLE password file entry for user.

Cause: No entry exists for the user in the Oracle password file.

Action: Have the database administrator install a password entry by running ORAPASSWD.

ORA-09911 Incorrect user password.

Cause: The password entered by the user was incorrect.

Action: Enter the correct password.

ORA-09912 Malloc of name buffer(s) failed.

Cause: Oracle was unable to allocate memory for one or both of the buffers that are used to hold the name of DBA and the operator users.

Action: Check the UNIX error number. It is probable that the system has run out of memory. If there is no error, contact Oracle Support Services.

ORA-09913 Malloc of dummy name failed.

Cause: Oracle was unable to allocate memory for the user name that is to be used in the encryption of the user's password.

Action: Check the UNIX error number. It is probable that the system has run out of memory. If there is no error, contact Oracle Support Services.

ORA-09914 Unable to open the ORACLE password file.

Cause: Oracle could not open the password file for reading.

Action: Check the UNIX error number. If the error number indicates that the file does not exist, have the database administrator create the file by running ORAPASSWD. If the error number indicates insufficient permissions, ask the database administrator to change the permissions. Otherwise, contact Oracle Support Services.

ORA-09915 Password encryption failed.

Cause: Oracle was unable to encrypt a password. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09916 Required password was not specified.

Cause: A user attempted to connect as "internal," but did not specify a password.

Action: Connect as internal again and specify a password.

ORA-09918 Unable to get user privileges from SQL*Net

Cause: Oracle was unable to retrieve the user's privilege set from the SQL*Net connection.

Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact Oracle Support Services.

ORA-09919 Unable to set label of dedicated server

Cause: Oracle was unable to set the label of the dedicated to server to the required value.

Action: Check the UNIX error number for a possible operating system error. Also, check the privileges on the Oracle executable. It should have at least ALLOWMACACCESS privilege.

ORA-09920 Unable to get sensitivity label from connection

Cause: Oracle was unable to retrieve the user's sensitivity label from the SQL*Net connection.

Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact Oracle Support Services.

ORA-09921 Unable to get information label from connection

Cause: Oracle was unable to retrieve the user's information label from the SQL*Net connection.

Action: Check the UNIX error number for a possible operating system error. Also check the "additional information" field for the SQL*Net error. If there is no error, contact Oracle Support Services.

ORA-09922 Can't spawn process - background log directory not created properly

Cause: Oracle was unable to spawn a background process because the directory that will hold trace files of the background processes was not created properly.

Action: Examine the directory pointed to by the initialization parameter BACKGROUND_DUMP_DEST. Make sure that all of the following is true:

  1. The directory exists.
  2. The name indeed points to a directory, and is not a file.
  3. The directory is accessible and writable to the Oracle user.

ORA-09923 Can't spawn process - user log directory not created properly

Cause: Oracle was unable to spawn a background process because the directory that holds the trace files of the dedicated server processes was not created properly.

Action: Examine the directory pointed to by the initialization parameter USER_DUMP_DEST. Make sure that all of the following is true:

  1. The directory exists.
  2. The name indeed points to a directory, and is not a file.
  3. The directory is accessible and writable to the Oracle user.

ORA-09924 Can't spawn process - core dump directory not created properly

Cause: Oracle was unable to spawn a background process because the directory that holds the core dumps produced by Oracle processes in the event of exceptions was not created properly.

Action: Examine the directory pointed to by the initialization parameter CORE_DUMP_DEST. Make sure that all of the following is true:

  1. The directory exists.
  2. The name indeed points to a directory, and is not a file.
  3. The directory is accessible and writable to the Oracle user.

ORA-09925 Unable to create audit trail file

Cause: Oracle was not able to create the file being used to hold audit trail records.

Action: Check the UNIX error number for a possible operating system error. If there is no error, contact Oracle Support Services.

ORA-09926 Unable to set effective privilege set of the server

Cause: A dedicated server was unable to set it's own privilege set.

Action: Check the privileges granted to the Oracle executable. It must have at least ALLOWMACACESS privilege.

ORA-09927 Unable to set label of server

Cause: Oracle was not able to set the label of a server to a new value.

Action: Check the privileges on $ORACLE_HOME/bin/oracle. Make sure that it has ALLOWMACACCESS privilege.

ORA-09928 Unable to restore the label of server

Cause: Oracle was unable to restore the label of the server to the value that it had before raising it to database high. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09929 GLB of two labels is invalid

Cause: The result of a greatest lower bound operation on two labels was not valid.

Action: Repeat the operation with two different labels. Consult the system encoding file for the values of valid labels.

ORA-09930 LUB of two labels is invalid

Cause: The result of a least upper bound operation on two labels was not valid.

Action: Repeat the operation with two different labels. Consult the system encoding file for the values of valid labels.

ORA-09931 Unable to open ORACLE password file for reading

Cause: An attempt to open a password file for reading failed.

Action: Make sure that the permissions on the file have not been changed so that the Oracle user cannot open it.

ORA-09932 Close of ORACLE password file failed.

Cause: An attempt to close a password file failed.

Action: Check the UNIX error number for the specific reason.

ORA-09933 Deletion of old password file failed.

Cause: The removal of the old password file failed.

Action: Check the UNIX error number for the specific reason.

ORA-09934 Link of current password file to old failed.

Cause: Oracle was unable to create a link so that the old password file could be saved.

Action: Check the UNIX error number for the specific reason.

ORA-09935 Unlink of current password file failed.

Cause: Oracle was unable to complete the saving of the current password file.

Action: Check the UNIX error number for the specific reason.

ORA-09936 Open of ORACLE password file for write failed.

Cause: Oracle was unable to create a password file.

Action: Check the UNIX error number for the specific reason.

ORA-09937 Chmod of ORACLE password file failed.

Cause: Oracle was unable to change a password file to be read only.

Action: Check the UNIX error number for the specific reason.

ORA-09938 Save of signal handlers failed.

Cause: Oracle was unable to save the previous values of selected signal handlers. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09939 Restoration of signal handlers failed.

Cause: Oracle was unable to restore the previous values of selected signal handlers. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09940 ORACLE password file header is corrupt

Cause: The header of one of the password files was not in the format that Oracle expected.

Action: Check the headers of both files. The header should be in the format "FILE VERSION: N.N.N.N.N EXECUTABLE VERSION: N.N.N.N.N" where N is a number. Remove the corrupt file(s) and re-run ORAPASSWD.

ORA-09941 Version of orapasswd or installer is older than file.

Cause: The version of ORAPASSWD or installer that is being run is older than that of the Oracle password file. Since the file version is only changed when the format is changed, this error means that the executable is using a different format than that with which the file was created.

Action: Run a version of the installer or ORAPASSWD whose version is the same or later than that of the file.

ORA-09942 Write of ORACLE password file header failed.

Cause: The attempt to write out the header of the Oracle password file failed.

Action: Check the operating system error number. It is possible that the file system became full.

ORA-09943 Allocation of memory for password list component failed.

Cause: When it is building a list of password file entries, Oracle allocates memory for various components. One of the allocations failed.

Action: Check the operating system error number. The system has probably run out of memory.

ORA-09944 Password entry is corrupt.

Cause: An entry in an Oracle password file was not in the format that Oracle expected.

Action: Removed the corrupt file(s) and re-run ORAPASSWD.

ORA-09945 Unable to initialize the audit trail file

Cause: Oracle was unable to write header information to the file being used as the audit trail.

Action: Check the UNIX error number for a possible operating system error. If there is no error, contact Oracle Support Services.

ORA-09946 File name too long for buffer

Cause: The buffer that was to be used to hold a file name was determined to be too short for the generated name. This will happen if the translated name for either a trace file or an audit file is longer than the maximum allowed, which on many ports is 256 characters.

Action: Use a shorter file name.

ORA-09947 Unable to allocate connection attributes structure

Cause: Oracle was not able to allocate the memory needed to hold the attributes of the SQL*Net connection. The "Additional Information" field holds the number of bytes that Oracle attempted to allocate.

Action: Check the UNIX error number. It is probable that the system has run out of memory. If there is no error, contact Oracle Support Services.

ORA-09948 Process information label retrieval failed.

Cause: Oracle was unable to get the information label for a process.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services.

ORA-09949 Unable to get client operating system privileges

Cause: Oracle was unable to get the operating system privileges for the client process.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services.

ORA-09950 Unable to get server operating system privileges

Cause: Oracle was unable to get its privileges from the operating system.

Action: This is an error that should never happen. Contact Oracle Support Services.

ORA-09951 Unable to create file

Cause: Oracle was unable to create a file.

Action: Check the UNIX error number for a possible operating system failure. If there is no error, contact Oracle Support Services.

ORA-09952 scgcmn: lk_open_convert unexpected return: open failed

Cause: The Distributed Lock Manager returned an unexpected value.

Action: Check for system error message and refer to the Distributed Lock Manager documentation or contact Oracle Support Services.

ORA-09953 scggc: unexpected return of a lock convert

Cause: The Distributed Lock Manager returned an unexpected value.

Action: Check for Lock Manager error messages and refer to the Distributed Lock Manager documentation or contact Oracle Support Services.

ORA-09954 scgcc: unexpected return status to callback of lock close

Cause: The Distributed Lock Manager returned an unexpected value.

Action: Check for Lock Manager error messages and refer to the Distributed Lock Manager documentation or contact Oracle Support Services.

ORA-09955 scgcan: unexpected return status when canceling a lock

Cause: DLM system service x returned an unexpected value.

Action: Check for system error message and refer to the Distributed Lock Manager documentation or contact Oracle Support Services.

ORA-09956 scgcm: unexpected lock status condition

Cause: A global locking system service returned an unexpected value.

Action: Check for system error message (if any) and refer to refer to the Distributed Lock Manager documentation or contact Oracle Support Services.

ORA-09957 Unable to send termination request to IMON

Cause: The attempt to send a termination signal to IMON failed. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09958 IMON: two processes with the same ORACLE pid are active

Cause: The IMON process was unable to add an entry for a server process because another active process occupies the slot. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09959 IMON: deletion of a process failed.

Cause: The IMON process was unable to delete a server process from its process ID array because no entry for the process could be found. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09960 Unable to establish signal handler for termination signal

Cause: Oracle was unable to set up a handler for the signal used to notify it that the instance was shutting down. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09961 Unable to restore termination signal handler

Cause: Oracle failed to set the handler for the termination signal to its previous value. This is an internal error.

Action: Contact Oracle Support Services.

ORA-09962 lk_group_create error in scggrc

ORA-09963 lk_group_attach error in scggra

ORA-09964 lk_group_detach error in scggrd

ORA-09966 scumnt: translation error while expanding ?/dbs/lk

Cause: Failure of SLTLN in SCUMNT.

Action: Check additional returned error for more information.

ORA-09967 scumnt: unable to create or open file

Cause: Open system call returned an error.

Action: Check errno.

ORA-09968 scumnt: unable to lock file

Cause: Lock file operating system call returned an error.

Action: Check errno.

ORA-09969 scurls: unable to close lock file

Cause: Close system call returned an error.

Action: Check errno.

ORA-09974 skxfidini: Error Initializing SDI Channel

Cause: The process was unable to initialize the SDI channel properly.

Action: Correct the operating system error and retry the operation.

ORA-09975 kxfspini: Error Initializing SDI Process

Cause: The process was unable to attach to the SDI channel.

Action: Verify that the SDI process specific limits correctly configured. Correct the operating system error and retry the operation.

ORA-09976 skxfqdini: Error Creating Port

Cause: The process was unable to create a communications endpoint.

Action: Verify that the SDI port specific limits correctly configured. Correct the operating system error and retry the operation.

ORA-09977 skxfqhini: Error Connecting

Cause: The process was unable to connect to another endpoint.

Action: Verify that the SDI port specific limits correctly configured. Check that the other node(s) is part of the cluster and operating properly. Correct the operating system error and retry the operation.

ORA-09978 skxfqhdel: Error Disconnecting from another endpoint.

Cause: The process was unable to disconnect cleanly from another endpoint.

Action: Check that the other node(s) are part of the cluster and operating properly. Check the instance and processes on the other node(s). Correct the operating system error and retry the operation.

ORA-09979 skxfqhsnd: Error Sending a message to another endpoint

Cause: The process was unable to send a message to an existing endpoint.

Action: Check that the other node(s) are part of the cluster and operating properly. Check the instance and processes on the other node(s). Correct the operating system error and retry the operation.

ORA-09980 skxfqdrcv: Error Receiving a message from another endpoint

Cause: The process encountered an error while trying to receive a message.

Action: Check that the other node(s) are part of the cluster and operating properly. Check the instance and processes on the other node(s). Correct the operating system error and retry the operation.

ORA-09981 skxfqdreg: Error Adding a page to the SDI buffer pool

Cause: The process was unable to add a page to the SDI buffer pool.

Action: Correct the operating system error and retry the operation.

ORA-09982 skxfqddrg: Error Removing a page from the SDI buffer pool

Cause: The process was unable to remove a page to the SDI buffer pool.

Action: Correct the operating system error and retry the operation.

ORA-09983 skxfidsht: Error shutting down SDI channel

Cause: The process was unable to shut down the SDI channel.

Action: Check the SDI persistent resources using SDI tools. Verify that all processes exited cleanly and the instance is safely shut down. Delete any remaining SDI channel IDs associated with the current instance.

ORA-09984 SGA file $ORACLE_HOME/dbs/sgadef$ORACLE_SID.dbf does not exist

Cause: File does not exist or is not accessible.

Action: Restart the instance to create the SGA definition file.

ORA-09985 SGA definition file could not be read

Cause: UNIX read() operation failed.

Action: Check errno and take appropriate action.

ORA-09986 wrong number of bytes read from SGA definition file

Cause: Struct SKGMSDEF size differs from the number of bytes read from the SGA file.

Action: Compare the two struct definitions and ensure that they are identical in size and structure.

ORA-09987 unable to attach to SGA in READ-ONLY mode

Cause: The instance is not up, or SGA segments are not read-accessible.

Action: Verify that the instance is up and read permissions for the SGA segments are set.

ORA-09988 error while detaching SGA

Cause: SKGMSDEF struct is corrupted and/or segment addresses are modified.

Action: Safely shut down the instance and mount the SGA segments again.

ORA-09989 attempt to use invalid skgmsdef struct pointer

Cause: Pointer to SKGMSDEF struct used without validating it.

Action: Assign a valid address to the SKGMSDEF struct pointer before using it.

ORA-10560 block type 'string'

Cause: Report block type for details of another error.

Action: See associated error message.

ORA-10561 block type 'string', data object# string

Cause: Report block type and data object number for details of another error.

Action: See associated error message.

ORA-10562 Error occurred while applying redo to data block (file# string, block# string)

Cause: See other errors on error stack.

Action: Investigate why the error occurred and how important is the data block. Media and standby database recovery usually can continue if user allows recovery to corrupt this data block.

ORA-10563 Test recovery had to corrupt data block (file# string, block# string) in order to proceed

Cause: Test recovery completed.

Action: No action is needed. Test recovery has ended successfully. See other messages on error stack for a summary of the result of the test recovery.

ORA-10564 tablespace string

Cause: Report tablespace name for details of another error.

Action: See associated error message.

ORA-10565 Another test recovery session is active

Cause: There can only be one test recovery session at any time. Another test recovery session is active.

Action: Wait until the other test recovery session completes.

ORA-10566 Test recovery has used all the memory it can use

Cause: Test recovery tests redo in memory. It can no longer proceed because it has consumed all the memory it can use.

Action: No action is needed. Test recovery has ended successfully. See other messages on error stack for a summary result of the test recovery.

ORA-10567 Redo is inconsistent with data block (file# string, block# string)

Cause: There are two possible causes of this error:

  1. A write issued by Oracle was lost by the underlying OS or storage system.
  2. An Oracle internal error.

Action: Investigate why the error occurred and how important is the data block. Media and standby database recovery usually can continue if user allows recovery to corrupt this data block.

ORA-10568 Failed to allocate recovery state object: out of SGA memory

Cause: Out of SGA memory.

Action: Restart the instance. If the problem persists, then contact Oracle Support Services.

ORA-10570 Test recovery complete

Cause: Test recovery completed.

Action: No action is needed. Test recovery has ended successfully. See other messages on error stack for a summary result of the test recovery.

ORA-10571 Test recovery canceled

Cause: User canceled test recovery.

Action: No action is needed. Test recovery has ended successfully. See other messages on error stack for a summary of the result of the test recovery.

ORA-10572 Test recovery canceled due to errors

Cause: See other errors on the error stack.

Action: See other messages on the error stack. It is possible that no action is needed. See other messages on error stack for a summary of the result of the test recovery so far.

ORA-10573 Test recovery tested redo from change string to string

Cause: This message shows the range of test recovery that has been tested.

Action: No action is needed. See other messages on the error stack.

ORA-10574 Test recovery did not corrupt any data block

Cause: This message summarizes test recovery result.

Action: No action is needed. See other messages on the error stack.

ORA-10575 Give up restoring recovered datafiles to consistent state: out of memory

Cause: There was not enough memory to restore recovered datafiles to consistent state.

Action: This error is just a warning: You may not be able to open the database with resetlogs immediately after this error. However, you may continue media/standby recovery, and that may make the datafiles recovered consistent again.

ORA-10576 Give up restoring recovered datafiles to consistent state: some error occurred

Cause: See alert file or other errors on the stack for a cause of the problem.

Action: This error is just a warning: You may not be able to open the database with resetlogs immediately after this error. However, you may continue media/standby recovery, and that may make the datafiles recovered consistent again.

ORA-10577 Can not invoke test recovery for managed standby database recovery

Cause: Test recovery option is used for managed standby database recovery.

Action: Either remove the test recovery option or invoke manual test standby database recovery.

ORA-10578 Can not allow corruption for managed standby database recovery

Cause: You used the allow corruption option for managed standby database recovery.

Action: Either remove the allow corruption option or invoke manual standby database recovery.

ORA-10579 Can not modify control file during test recovery

Cause: To proceed with recovery, test recovery needs to modify the control file. But test recovery is not allowed to modify the controlfile.

Action: No action is needed. Test recovery has ended successfully. It can only go so far in the redo stream.

ORA-10580 Can not modify datafile header during test recovery

Cause: To proceed with recovery, test recovery needs to modify a datafile header. But test recovery is not allowed to modify datafile headers.

Action: No action is needed. Test recovery has ended successfully. It can only go so far in the redo stream.

ORA-10581 Can not modify redo log header during test recovery

Cause: To proceed with recovery, test recovery needs to modify a redo log header. But test recovery is not allowed to modify redo log headers.

Action: No action is needed. Test recovery has ended successfully. It can only go so far in the redo stream.

ORA-10582 The control file is not a backup control file

Cause: User requested backup control file test recovery, but the control file is not a backup control file.

Action: Use a backup control file, or do not use the USING BACKUP CONTROLFILE option.

ORA-10583 Can not recover file string renamed as missing during test recovery

Cause: One of the files to be recovered is renamed as missing.

Action: Rename the file to the correct file or offline it.

ORA-10584 Can not invoke parallel recovery for test recovery

Cause: Both test recovery and parallel recovery are requested.

Action: Drop either one of the two recovery options.

ORA-10585 Test recovery can not apply redo that may modify control file

Cause: Test recovery has encountered a special redo that may modify control file.

Action: No action is needed. Test recovery has proceeded successfully as far as it could from its starting point.

ORA-10586 Test recovery had to corrupt 1 data block in order to proceed

Cause: This message summarizes test recovery result: Oracle may have to corrupt one block in order to apply the range of redo tested.

Action: See the alert log for details of the problem.

ORA-10587 Invalid count for ALLOW n CORRUPTION option

Cause: The number specified in the ALLOW n CORRUPTION option is too big.

Action: Use a smaller number.

ORA-10588 Can only allow 1 corruption for normal media/standby recovery

Cause: The number specified in the ALLOW n CORRUPTION option is too big.

Action: Change to allow zero or one corruption.

ORA-10589 Test recovery had to corrupt string data blocks in order to proceed

Cause: This message summarizes test recovery result: Oracle may have to corrupt a number of data blocks as specified in the message in order to apply the range of redo tested.

Action: See the alert log for details of the problems.

ORA-10614 Operation not allowed on this segment

Cause: This procedure can be used only on segments in tablespaces with AUTO SEGMENT SPACE MANAGEMENT.

Action: Recheck the segment name and type and re-issue the statement.

ORA-10615 Invalid tablespace type for temporary tablespace

Cause: Tablespace with AUTO SEGMENT SPACE MANAGEMENT specified cannot be used as a temporary tablespace.

Action: Recheck the tablespace name and re-issue the statement.

ORA-10616 Operation not allowed on this tablespace

Cause: Cannot perform the operation on tablespace with AUTO SEGMENT SPACE MANAGEMENT.

Action: Recheck the tablespace name and re-issue the statement.

ORA-10617 Cannot create rollback segment in dictionary managed tablespace

Cause: Rollback segments cannot be created in dictionary managed tablespaces when the SYSTEM tablespace is locally managed.

Action: Recheck the tablespace name and re-issue the statement.

ORA-10618 Operation not allowed on this segment

Cause: This DBMS_SPACE operation is not permitted on segments in tablespaces with AUTO SEGMENT SPACE MANAGEMENT.

Action: Recheck the segment name and type and re-issue the statement.

ORA-10620 Operation not allowed on this segment

Cause: Cannot alter freelist storage parameter for segments in tablespaces with AUTO SEGMENT SPACE MANAGEMENT.

Action: Recheck the segment name and re-issue the statement.

ORA-10621 data block does not belong to the segment

Cause: The specified file number and block number of the data block does not belong to the segment.

Action: Recheck the segment, file number, block number and re-issue the statement.

ORA-10640 Operation not permitted during SYSTEM tablespace migration

Cause: The SYSTEM tablespace is being migrated to locally managed format.

Action: Re-issue this command once SYSTEM tablespace migration is complete.

ORA-10641 Cannot find a rollback segment to bind to

Cause: SYSTEM tablespace migration requires rollback segment in locally managed tablespace.

Action: Drop rollback segments in dictionary managed tablespaces other than SYSTEM and create rollback segments in locally managed tablespace. Then retry migration.

ORA-10642 Found rollback segments in dictionary managed tablespaces

Cause: When SYSTEM tablespace is migrated, found rollback segments in dictionary managed tablespaces.

Action: Drop the rollback segments in dictionary managed tablespaces and re-issue the command.

ORA-10643 Database should be mounted in restricted mode and Exclusive mode

Cause: When SYSTEM tablespace is being migrated, database should be mounted in Exclusive mode and in Restricted mode.

Action: Re-issue this command after mounting the database in the correct mode.

ORA-10644 SYSTEM tablespace cannot be default temporary tablespace

Cause: When SYSTEM tablespace is being migrated, no user should have SYSTEM as the default temporary tablespace.

Action: Re-issue this command after altering the default temporary tablespace setting for all users.

ORA-10646 Too many recursive extensions during SYSTEM tablespace migration

Cause: When SYSTEM tablespace is being migrated, dictionary tables tried to extend recursively more than 1000 times.

Action: If SYSTEM tablespace is very large, then simply reissue the tablespace migration command.

ORA-10647 Tablespace other than SYSTEM,string, string not found in read only mode

Cause: When SYSTEM tablespace is being migrated, tablespaces other than the three should be ALTERed to read only.

Action: Alter the tablespace status to read only and retry migration.

ORA-10651 incorrect file number block number specified

Cause: The specified dba is not valid.

Action: Check if the specified dba belongs to the segment and is under the segment HWM and re-issue the statement.

ORA-12000 a materialized view log already exists on table 'string'

Cause: An attempt was made to create a materialized view log on a table that already has a materialized view log. Each master table can have only one materialized view log.

Action: All materialized views on a table can use the same materialized view log for that table. To make changes to the existing log, use the ALTER MATERIALIZED VIEW LOG command or drop the materialized view log and create it again.

ORA-12001 cannot create log: table 'string' already has a trigger

Cause: Materialized view logs are filled by a trigger on the master table. That trigger cannot be created.

Action: To create a materialized view log, drop the current trigger on the master.

ORA-12002 there is no materialized view log on table "string"."string"

Cause: There was no materialized view log on the master table.

Action: Create a materialized view log on the master table.

ORA-12003 materialized view "string"."string" does not exist

Cause: The materialized view with the given owner and name does not exist.

Action: Verify inputs and create a materialized view.

ORA-12004 REFRESH FAST cannot be used for materialized view "string"."string"

Cause: The materialized view log does not exist or cannot be used.

Action: Use just REFRESH, which will reinstantiate the entire table. If a materialized view log exists and the form of the materialized view allows the use of a materialized view log, REFRESH FAST will be available starting the next time the materialized view is refreshed.

ORA-12005 may not schedule automatic refresh for times in the past

Cause: An attempt was made to schedule an automated materialized view refresh for a time in the past.

Action: Choose a time in the future instead.

ORA-12006 a materialized view with the same user.name already exists

Cause: An attempt was made to create a materialized view with the name of an existing materialized view.

Action: Create the materialized view using a different name or drop the existing materialized view.

ORA-12007 materialized view reuse parameters are inconsistent

Cause: The CREATE MATERIALIZED VIEW .. or CREATE MATERIALIZED VIEW LOG .. REUSE command was given inconsistent parameters immediately after the REUSE.

Action: Examine the other messages on the stack to find the problem.

ORA-12008 error in materialized view refresh path

Cause: Table SNAP$_mview_name reads rows from the view MVIEW$_mview_name, which is a view on the master table (the master may be at a remote site). Any error in this path will cause this error at refresh time. For fast refreshes, the table master_owner.MLOG$_master is also referenced.

Action: Examine the other messages on the stack to find the problem. See if the objects SNAP$_mview_name, MVIEW$_mview_name, mowner.master@dblink, mowner.MLOG$_master@dblink still exist.

ORA-12009 materialized views may not contain long columns

Cause: An attempt was made to create a materialized view with a long column.

Action: Do not attempt to create materialized view logs with long columns.

ORA-12010 cannot create materialized view log on table owned by SYS

Cause: An attempt was made to create a materialized view log on the table owned by SYS. CREATE MATERIALIZED VIEW LOG attempts to create a trigger on the table, but triggers can not be created on SYS tables.

Action: Do not create a materialized view log on SYS tables.

ORA-12011 execution of string jobs failed

Cause: An error was caught in dbms_ijob.run from one or more jobs which were due to be run.

Action: Look at the alert log for details on which jobs failed and why.

ORA-12012 error on auto execute of job string

Cause: Some kind of error was caught while doing an automatic execute of a job.

Action: Look at the accompanying errors for details on why the execute failed.

ORA-12013 updatable materialized views must be simple enough to do fast refresh

Cause: The updatable materialized view query contained a join, subquery, union, connect by, order by, or group by clause.

Action: Make the materialized view simpler. If a join is really needed, make multiple simple materialized views then put a view on top of them.

ORA-12014 table 'string' does not contain a primary key constraint

Cause: The CREATE MATERIALIZED VIEW LOG command was issued with the WITH PRIMARY KEY option and the master table did not contain a primary key constraint or the constraint was disabled.

Action: Reissue the command using only the WITH ROWID option, create a primary key constraint on the master table, or enable an existing primary key constraint.

ORA-12015 cannot create a fast refresh materialized view from a complex query

Cause: Neither ROWIDs nor primary key constraints are supported for complex queries.

Action: Reissue the command with the REFRESH FORCE or REFRESH COMPLETE option or create a simple materialized view.

ORA-12016 materialized view does not include all primary key columns

Cause: The query that instantiates the materialized view did not include all of the columns in the master's primary key constraint.

Action: Include all of the master's primary key columns in the materialized view query or create a ROWID materialized view.

ORA-12017 cannot alter primary key mview 'string' to a rowid mview

Cause: An attempt was made to convert the primary key of a materialized view to a ROWID materialized view.

Action: Conversion of a primary key materialized view to a ROWID materialized view is not supported. Create a new materialized view with ROWIDs or drop and recreate the materialized view with ROWIDs.

ORA-12018 following error encountered during code generation for "string"."string"

Cause: The refresh operations for the indicated materialized view could not be regenerated due to errors.

Action: Correct the problem indicated in the following error messages and repeat the operation.

ORA-12019 master table is a synonym to a remote object

Cause: An attempt was made to create a materialized view or a materialized view log on a remote synonym which is unsupported.

Action: Do not create a materialized view or materialized view log on a remote synonym.

ORA-12020 materialized view string is not registered

Cause: An attempt was made to unregister a materialized view that is not registered.

Action: No action required.

ORA-12021 materialized view "string"."string" is corrupt

Cause: The indicated materialized view is no longer valid.

Action: Contact Oracle Support Services.

ORA-12022 materialized view log on "string"."string" already has rowid

Cause: Materialized view log on the indicated table already has ROWID information.

Action: No action required.

ORA-12023 missing index on materialized view "string"."string"

Cause: The specified ROWID materialized view did not have the required index on the ROWID column of its underlying table.

Action: Drop and recreate the materialized view.

ORA-12024 materialized view log on "string"."string" does not have primary key columns

Cause: Materialized view log on the indicated table does not have primary key information.

Action: Add primary keys to the materialized view log using the ALTER MATERIALIZED VIEW command.

ORA-12025 materialized view log on "string"."string" already has primary keys

Cause: Materialized view log on the indicated table already has primary key columns.

Action: No action required.

ORA-12026 invalid filter column detected

Cause: One or more of the specified filter columns did not exist or was a primary key column or a primary key based object identifier.

Action: Ensure that all specified filter columns exist in the master table and ensure that primary key columns or primary key based object identifiers are not included in the list of filter columns.

ORA-12027 duplicate filter column

Cause: One or more of the specified filter columns was already being recorded in the materialized view log.

Action: Describe the materialized view log table and reissue the SQL command with the filter columns that are already being recorded in the materialized view log.

ORA-12028 materialized view type is not supported by master site string

Cause: Pre-Oracle8 master sites are not able to support primary key or subquery materialized views that are able to perform a fast refresh.

Action: Create a ROWID materialized view or use a master table from an Oracle8 site.

ORA-12029 LOB columns may not be used as filter columns

Cause: An attempt was made to use LOB columns as filter columns.

Action: Remove LOB columns from the filter columns list and retry command.

ORA-12030 cannot create a fast refresh materialized view
  • For primary key materialized views, the master table's primary key columns must be logged.
  • For subquery materialized views, the filter columns, primary key, and ROWID values must be logged.

Cause: The materialized view log did not exist or did not log the information needed by the materialized view to perform a fast refresh.

Action: Ensure that the materialized view log exists and logs the necessary information.

  • For ROWID materialized views, the master table's ROWID must be logged.
  • For primary key materialized views, the master table's primary key columns must be logged.
  • For subquery materialized views, the filter columns, primary key, and ROWID values must be logged.

ORA-12031 cannot use primary key columns from materialized view log on "string"."string"

Cause: The materialized view log either did not have primary key columns logged, or the timestamp associated with the primary key columns was more recent than the last refresh time.

Action: A complete refresh is required before the next fast refresh. Add primary key columns to the materialized view log, if required.

ORA-12032 cannot use rowid column from materialized view log on "string"."string"

Cause: The materialized view log either does not have ROWID columns logged, or the timestamp associated with the ROWID columns is more recent than the last refresh time.

Action: A complete refresh is required before the next fast refresh. Add ROWID columns to the materialized view log, if required.

ORA-12033 cannot use filter columns from materialized view log on "string"."string"

Cause: The materialized view log either did not have filter columns logged, or the timestamp associated with the filter columns was more recent than the last refresh time.

Action: A complete refresh is required before the next fast refresh. Add filter columns to the materialized view log, if required.

ORA-12034 materialized view log on "string"."string" younger than last refresh

Cause: The materialized view log was younger than the last refresh.

Action: A complete refresh is required before the next fast refresh.

ORA-12035 could not use materialized view log on "string"."string"

Cause: The materialized view log did not exist or could not be used.

Action: Use just REFRESH, which will reinstantiate the entire table. If a materialized view log exists and the form of the materialized view allows the use of a materialized view log, REFRESH FAST will be available starting the next time the materialized view is refreshed.

ORA-12036 updatable materialized view log is not empty, refresh materialized view

Cause: The updatable materialized view log was not empty. The updatable materialized view log must be empty before an updatable rowid materialized view can be altered to a primary key materialized view.

Action: Ensure that updatable materialized view log is empty by refreshing the materialized view before converting the updatable ROWID materialized view to a primary key materialized view.

ORA-12037 unknown export format

Cause: An attempt was made to import a materialized view exported by an unknown export version (for example, from a newer release than the importing site).

Action: Re-export the file using a version of export known by the importing site.

ORA-12039 unable to use local rollback segment "string"

Cause: A local rollback segment was specified in the CREATE MATERIALIZED VIEW command, but automatic refresh parameters were not specified. Therefore a refresh group was not created to automatically refresh the materialized view and the local rollback segment can't be registered for future use.

Action: Either supply the automatic refresh parameters so that a refresh group will be created or do not specify a local rollback segment.

ORA-12040 master rollback segment option not support by master site string

Cause: An attempt was made to specify master rollback segment in the current operation. The master site of the current materialized view does not allow users to specify a rollback segment to be used for materialized view operations. This feature is only supported by Oracle8 or later master sites.

Action: Do not specify a master rollback segment in the current operation or choose a new master site.

ORA-12041 cannot record ROWIDs for index-organized table "string"."string"

Cause: Index-organized tables do not have ROWIDs. Therefore a materialized view log that records the ROWIDs of an index-organized table could not be created.

Action: Do not include the WITH ROWID option when using the CREATE MATERIALIZED VIEW command and do not include the ADD ROWID option when using the ALTER MATERIALIZED VIEW command if the master table is index-organized.

ORA-12042 cannot alter job_queue_processes in single process mode

Cause: An attempt was made to alter job_queue_processes in single process mode.

Action: Do not attempt to set job_queue_processes in single process mode.

ORA-12043 invalid CREATE MATERIALIZED VIEW option

Cause: An invalid option was used in a CREATE MATERIALIZED VIEW statement.

Action: Specify only valid options.

ORA-12044 invalid CREATE MATERIALIZED VIEW LOG option

Cause: An invalid option was used in a CREATE MATERIALIZED VIEW LOG statement.

Action: Specify only valid options.

ORA-12045 invalid ALTER MATERIALIZED VIEW LOG option

Cause: An invalid option was used in an ALTER MATERIALIZED VIEW LOG statement.

Action: Specify only valid options.

ORA-12051 ON COMMIT attribute is incompatible with other options

Cause: The ON COMMIT refresh attribute, incompatible with other refresh options such as automatic periodic refresh, was specified.

Action: Specify only valid options.

ORA-12052 cannot fast refresh materialized view string.string

Cause: Either ROWIDs of certain tables were missing in the definition or the inner table of an outer join did not have UNIQUE constraints on join columns.

Action: Specify the FORCE or COMPLETE option. If this error occurred during creation, the materialized view definition may have been changed. Refer to the documentation on materialized views.

ORA-12053 this is not a valid nested materialized view

Cause: The list of objects in the FROM clause of the definition of this materialized view had some dependencies upon each other.

Action: Refer to the documentation to see which types of nesting are valid.

ORA-12054 cannot set the ON COMMIT refresh attribute for the materialized view

Cause: The materialized view did not satisfy conditions for refresh at commit time.

Action: Specify only valid options.

ORA-12055 materialized view definition contains cyclic dependencies with existing materialized views

Cause: The materialized view query definition introduced a cyclic dependency with existing materialized views.

Action: Modify the materialized view query definition.

ORA-12056 invalid REFRESH method

Cause: The NEVER REFRESH option may not be used under the following conditions:

  • The materialized view is updatable
  • The materialized view refreshes ON COMMIT
  • Automatic refresh options are specified

Action: For updatable materialized views, reissue the SQL command using REFRESH FORCE, REFRESH FAST, or REFRESH COMPLETE. For read-only materialized views, reissue the SQL command using ON DEMAND.

ORA-12057 materialized view "string"."string" is INVALID and must complete refresh

Cause: The status of the materialized view was INVALID and an attempt was made to fast refresh the materialized view.

Action: Perform a complete refresh of the materialized view. Check the value of the STATUS column in dba_mviews, all_mviews, or user_mviews to verify that the materialized view is VALID after the complete refresh.

ORA-12058 materialized view cannot use prebuilt table

Cause: An attempt was made to use the prebuilt tables.

Action: Reissue the SQL command using BUILD IMMEDIATE or BUILD DEFERRED.

ORA-12059 prebuilt table "string"."string" does not exist

Cause: The specified prebuilt table did not exist.

Action: Reissue the SQL command using BUILD IMMEDIATE, BUILD DEFERRED, or ensure that the prebuilt table exists.

ORA-12060 shape of prebuilt table does not match definition query

Cause: The number of columns or the type or the length semantics of a column in the prebuilt table did not match the materialized view definition query.

Action: Reissue the SQL command using BUILD IMMEDIATE, BUILD DEFERRED, or ensure that the prebuilt table matches the materialized view definition query.

ORA-12061 invalid ALTER MATERIALIZED VIEW option

Cause: An invalid option was used in an ALTER MATERIALIZED VIEW statement.

Action: Specify only valid options.

ORA-12062 transaction string received out of sequence from site string

Cause: A transaction from the client site was received out of sequence. This implies that one or more transactions were missing.

Action: Ensure that the transaction queue at the client site is valid and has not been corrupted.

ORA-12063 unable to apply transaction from site string

Cause: The current transaction from the client site could not be applied to the master site.

Action: Ensure that the client site is still valid and that it has not been dropped from the master site.

ORA-12064 invalid refresh sequence number: string

Cause: The client site was attempting to perform a refresh with an invalid refresh sequence.

Action: Perform a complete refresh to synchronize the refresh sequence number.

ORA-12065 unknown refresh group identifier string

Cause: The specified refresh group did not exist at the master site.

Action: Ensure that the client site is still valid and that it has not been dropped from the master site.

ORA-12066 invalid CREATE MATERIALIZED VIEW command

Cause: The Replication API does not support the following options and types of materialized view:

  • ROWID materialized views
  • REFRESH ON COMMIT
  • ON PREBUILT TABLE
  • BUILD DEFERRED
  • NEVER REFRESH
  • ENABLE QUERY REWRITE

Action: Create a PRIMARY KEY materialized view using REFRESH WITH PRIMARY KEY and/or remove the invalid options.

ORA-12067 empty refresh groups are not allowed

Cause: The refresh group being instantiated did not contain any materialized views.

Action: Modify the template to include at least one materialized view.

ORA-12068 updatable mview log for mview "string"."string" does not exist

Cause: The updatable materialized view was missing the updatable materialized view log required to track updates made to the materialized view.

Action: Create the updatable materialized view log.

ORA-12069 invalid object for offline instantiation

Cause: Only materialized views can be offline instantiated. The object being offline instantiated was not a valid materialized view.

Action: Remove the object from the template or replace the object with a valid materialized view.

ORA-12070 cannot offline instantiate materialized view "string"."string"

Cause: Offline instantiation does not support materialized views using the following options:

  • ON PREBUILT TABLE
  • BUILD DEFERRED

Action: Remove the invalid options.

ORA-12071 definition query of "string"."string" is invalid for offline instantiation

Cause: Offline instantiation requires materialized view definition queries to observe the following constraints:

  • The database link that will be used by the materialized view site to connect to the master site must be included with each master table referenced in the query.
  • All master tables referenced must be located at the local site. References to other sites are not allowed.

Action: Modify the materialized view definition query.

ORA-12072 updatable materialized view log data for 'string'.'string' cannot be created

Cause: The updatable materialized view is missing the updatable materialized view log that is required to track updates made to the materialized view.

Action: Create the updatable materialized view log.

ORA-12073 request cannot be processed

Cause: An out-of-sequence request was made and it cannot be processed.

Action: Try again with a valid request.

ORA-12074 invalid memory address

Cause: An attempt was made to access an invalid memory region.

Action: Reconnect and try the command again.

ORA-12075 invalid object or field

Cause: ] An attempt was made to access an invalid field or object in the Java Virtual Memory.

Action: Retry the request.

ORA-12076 invalid threshold value

Cause: The result set threshold or LOB threshold value is not supported.

Action: Specify a threshold value below 64K.

ORA-12077 temporary updatable materialized view log does not exist

Cause: Temporary updatable materialized view log was not created or was dropped.

Action: Re-create the temporary updatable materialized view log.

Warning: This will cause a complete refresh of the materialized view.

ORA-12078 fast refresh of refresh group ID string failed

Cause: Refresh result set sent through client method REFRESH_REQ_RESULT returned an unknown value.

Action: Re-issue the refresh request.

ORA-12079 materialized view options require COMPATIBLE parameter to be string or greater

Cause: The following materialized view options require an 8.1 or higher compatibility setting:

  • ON COMMIT
  • ON PREBUILT TABLE
  • BUILD DEFERRED
  • NEVER REFRESH
  • ENABLE QUERY REWRITE

The following materialized view options require a 9.0.0 or higher compatibility setting:

  • materialized views with user-defined types

Action: Shut down and restart with an appropriate compatibility setting.

ORA-12081 update operation not allowed on table string.string

Cause: An attempt was made to update a read-only materialized view. Only Oracle is allowed to update a read-only materialized view.

Action: No action required.

ORA-12082 'string'.'string' cannot be index organized

Cause: An attempt was made to create an index-organized materialized aggregate view or an index-organized updatable ROWID materialized view. This is not supported.

Action: Try to create the materialized view without the index organization clause.

ORA-12083 must use DROP MATERIALIZED VIEW to drop string.string

Cause: An attempt was made to drop a materialized view using a command other than DROP MATERIALIZED VIEW.

Action: Use the DROP MATERIALIZED VIEW command.

ORA-12084 must use ALTER MATERIALIZED VIEW to alter string.string

Cause: An attempt was made to alter a materialized view using a command other than ALTER MATERIALIZED VIEW.

Action: Use the ALTER MATERIALIZED VIEW command.

ORA-12085 materialized view log on "string"."string" already has object id

Cause: Materialized view log on the indicated table already has object id information.

Action: No action required.

ORA-12086 table "string"."string" is not an object table

Cause: The CREATE MATERIALIZED VIEW LOG command was issued with the WITH OBJECT ID option and the master table is not an object table.

Action: Either specify the name of an object table, or remove the WITH OBJECT ID clause.

ORA-12087 online redefinition not allowed on tables owned by "string"

Cause: An attempt was made to online redefine a table owned by SYS or SYSTEM.

Action: Do not attempt to online redefine a table owned by SYS or SYSTEM.

ORA-12088 cannot online redefine table "string"."string" with unsupported datatype

Cause: An attempt was made to online redefine a table containing a LONG column, an ADT column, or a FILE column.

Action: Do not attempt to online redefine a table containing a LONG column, an ADT column, or a FILE column.

ORA-12089 cannot online redefine table "string"."string" with no primary key

Cause: An attempt was made to online redefine a table that does not have a primary key defined on it.

Action: Do not attempt to online redefine a table that does not have a primary key defined on it.

ORA-12090 cannot online redefine table "string"."string"

Cause: An attempt was made to online redefine a table that is either a clustered table, AQ table, temporary table, or IOT overflow table.

Action: Do not attempt to online redefine a table that is a clustered table, AQ table, temporary table, or IOT overflow table.

ORA-12091 cannot online redefine table "string"."string" with materialized views

Cause: An attempt was made to online redefine a table that had materialized views defined on it or had a materialized view log defined on it or is a master.

Action: Drop all materialized views and materialized view logs before attempting to online redefine the table.

ORA-12092 cannot online redefine replicated table "string"."string"

Cause: An attempt was made to online redefine a table that is either a materialized view or a replicated table.

Action: Do not attempt to online redefine a table that is either a materialized view or a replicated table.

ORA-12093 invalid interim table "string"."string"

Cause: The table is not the interim table of the corresponding table to be online redefined.

Action: Pass in the valid interim table.

ORA-12094 error during online redefinition

Cause: There was an error during the online redefinition process.

Action: Abort the online redefinition process.

ORA-12096 error in materialized view log on "string"."string"

Cause: There was an error originating from this materialized view log. One possible cause is that schema redefinition has occurred on the master table and one or more columns in the log is now a different type than the corresponding master columns. Another possible cause is that there is a problem accessing the underlying materialized view log table.

Action: Check further error messages in the stack for more detail about the cause. If there has been schema redefinition, drop the materialized view log and recreate it.

ORA-12097 changes in the master tables during refresh, try refresh again

Cause: There are some changes (that is, conventional DML, direct load, partition maintenance operation) in the master tables during materialized view refresh.

Action: Refresh the affected materialized views again.

ORA-12150 through ORA-12299

See Chapter 30, "Oracle Net Messages (TNS)" (the messages are listed with the prefix TNS in that chapter even though they are displayed with the prefix ORA).


ORA-12300 to ORA-12399

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

9
ORA-12300 to ORA-12399

ORA-12315 database link type is invalid for the ALTER DATABASE statement

Cause: The database link name you specified on the ALTER DATABASE statement is not an ROM: link. You must specify an ROM: link when using the ALTER DATABASE statement to mount or open a secondary database.

Action: Re-issue the ALTER DATABASE statement using a valid ROM: link to the database you want to mount or open. If a valid ROM: link does not exist, create one using the CREATE DATABASE LINK statement. See your documentation for Oracle security-related products for more information about creating database links using the ROM: link type.

ORA-12316 syntax error in database link's connect string

Cause: The connect string in the CREATE DATABASE LINK statement has a syntactical error.

Action: Drop the database link and re-create it using valid syntax. See the Oracle9i SQL Reference for more information about the connect string portion of the CREATE DATABASE LINK statement.

ORA-12317 logon to database (link name string) denied

Cause: There are several possible causes for this error. First, you can get this error if your username (and password, if you are using database instead of operating system authentication) in the secondary database are not identical to your username (and password) in the primary database. Second, you can get this error if your username in the secondary database is invalid (has not been created). Third, you can get this error if the username/password combination specified in the connect string of the database link definition is invalid (either not created or has an invalid password).

Action: In the first case, ensure that the secondary database contains a username (and password, if you are using database authentication) identical to the one you are using in the primary database. In the second case, ensure that your username in the secondary database has been created. In the third case, ensure that the username specified in the connect string has been created in the secondary database.

ORA-12318 database (link name string) is already mounted

Cause: You are attempting to mount a secondary database that has already been mounted by your instance.

Action: The database is already mounted, so you need not take additional action to mount it. To establish access, use the ALTER DATABASE linkname OPEN statement to open the database.

ORA-12319 database (link name string) is already open

Cause: You are attempting to open a secondary database that is already open.

Action: The database is open and you need not take additional action to establish access.

ORA-12321 database (link name string) is not open and AUTO_MOUNTING=FALSE

Cause: The secondary database that your instance is attempting to mount is not open and automatic mounting has not been enabled.

Action: Manually mount and open the secondary database using ALTER DATABASE linkname with the OPEN and MOUNT options. Alternately, to allow your instance to automatically mount and open secondary databases, set the AUTO_MOUNTING parameter in the parameter file to TRUE.

ORA-12322 unable to mount database (link name string)

Cause: This message should be accompanied by additional error messages that indicate the cause of the problem.

Action: Follow the steps outlined in the accompanying error messages to resolve the problem.

ORA-12323 unable to open database (link name string)

Cause: This message should be accompanied by additional error messages that indicate the cause of the problem.

Action: Follow the steps outlined in the accompanying error messages to resolve the problem.

ORA-12324 cannot use the ROM: link type on a private database link

Cause: You can only specify the ROM: link type on a public, not a private, database link.

Action: Determine if there is an existing public database link to the secondary database. If not, and if you wish to establish public access to the secondary database, create a public database link to the secondary database using the CREATE DATABASE LINK command.

ORA-12326 database string is closing immediately; no operations are permitted

Cause: The database you attempted to access is closing, so your operation has been terminated.

Action: Wait until the database has been reopened, or contact the database administrator.

ORA-12329 database string is closed; no operations are permitted

Cause: The database you attempted to access is closed, so your operation has been terminated.

Action: Wait until the database is reopened, or contact the database administrator.

ORA-12333 database (link name string) is not mounted

Cause: An attempt was made to open a database that has not been mounted.

Action: Mount the database with the ALTER DATABASE linkname MOUNT statement, then re-attempt to open the database.

ORA-12334 database (link name string) is still open

Cause: An attempt was made to dismount a database that is still open.

Action: Close the database with the ALTER DATABASE linkname CLOSE statement, then re-attempt to dismount the database.

ORA-12335 database (link name string) is not open

Cause: An attempt was made to close a database that is not open.

Action: The database is closed; you can proceed with dismounting it.

ORA-12336 cannot login to database (link name string)

Cause: An attempt was made to login while another user is mounting or dismounting the same database.

Action: Check to see if the database is in the middle of being mounted or opened and try your login again once the database is accessible.

ORA-12341 maximum number of open mounts exceeded

Cause: The number specified on the OPEN_MOUNTS parameter in the parameter file exceeds the maximum allowed (255).

Action: Change the value of this parameter so that it reflects the actual number of possible open mounts to secondary databases. This must be less than 255.

ORA-12342 open mounts exceeds limit set on the OPEN_MOUNTS parameter

Cause: The number of currently open mounts exceeds the value you specified on the OPEN_MOUNTS parameter.

Action: Increase the value of the OPEN_MOUNTS parameter so that it accommodates the maximum possible number of open mounts to secondary databases.

ORA-12345 user string lacks CREATE SESSION privilege in database link (linkname string)

Cause: There are several possible causes for this message: First, you will get this message if your username in the second database specified was not granted the CREATE SESSION system privilege. Second, you will get this message if the username specified in the connect string of the database link definition was not granted the CREATE SESSION system privilege.

Action: The action you take depends upon the cause of the message: In the first case, ensure that your username in the secondary database was granted the CREATE SESSION system privilege. In the second case, ensure the username specified in the connect string of the database link definition was granted the CREATE SESSION system privilege in the secondary database.

ORA-12350 database link being dropped is still mounted

Cause: An attempt was made to drop a ROM: database link that was still mounted and/or opened.

Action: Close and dismount the database and then re-issue the drop statement.

ORA-12351 cannot create view using a remote object which has a remote object reference

Cause: An attempt was made to create a view which references a remote object which, in turn, references an object on another database. Since the view that would have been created references a remote object, that object cannot reference an object on another database.

Action: Choose a different object to reference in your view or change the remote object so that it does not reference another database.

ORA-12352 object string.string@string is invalid

Cause: An attempt was made to reference (compile against) an object of a secondary database but the object is invalid and the system cannot validate or recompile it because it is in a secondary database.

Action: Manually recompile the invalid object in the secondary database.

ORA-12353 secondary stored object cannot reference remote object

Cause: An attempt was made to either select from a remote view or execute a remote procedure which references an object on another database. Since the remote view or procedure is on a secondary database, an additional reference to another database cannot be done.

Action: Choose a different object to reference or change the remote view or procedure so that it does not reference another database.

ORA-12354 secondary object being dropped

Cause: An attempt was made to access an object (for example, a table or view) on a secondary database that was in the process of being dropped.

Action: Repeat the operation. If you receive this message again, try to access the object from the secondary database. If you receive an internal error or a trace file, contact Oracle Support Services.


ORA-12400 to ORA-12699

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

10
ORA-12400 to ORA-12699

ORA-12400 invalid argument to facility error handling

Cause: An argument to a facility error handling function exceeded a maximum limit or referred to an invalid product/facility.

Action: Specify a valid facility error handling parameter value.

ORA-12401 invalid label string: string

Cause: The policy could not convert the label string to a valid internal label.

Action: Correct the syntax of the label string.

ORA-12402 invalid format string: string

Cause: The format string is not supported by the policy.

Action: Correct the syntax of the format string.

ORA-12403 invalid internal label

Cause: An internal label could not be converted to a valid label for the policy.

Action: Analyze any additional messages on the error stack and consult the policy documentation.

ORA-12404 invalid privilege string: string

Cause: The policy could not interpret the privilege string.

Action: Specify a privilege string that is supported by the policy.

ORA-12405 invalid label list

Cause: The policy determined that the label list was invalid for its intended use.

Action: Check the policy constraints on the specific list of labels.

ORA-12406 unauthorized SQL statement for policy string

Cause: The policy did not authorize the database session to perform the requested SQL statement.

Action: Grant the user or program unit the necessary policy privilege or additional authorizations.

ORA-12407 unauthorized operation for policy string

Cause: The policy did not authorize the database session to perform the requested operation.

Action: Grant the user or program unit the necessary policy privilege or additional authorizations.

ORA-12408 unsupported operation: string

Cause: The specified policy does not support the requested operation.

Action: Consult the policy documentation to determine the supported access mediation operations.

ORA-12409 policy startup failure for string policy

Cause: The policy encountered an error during startup processing; access to the data protected by the policy is prohibited.

Action: Check the alert log for additional information, correct the policy error, and restart the instance.

ORA-12410 internal policy error for policy: string Error: string

Cause: The policy enforcement encountered an internal error.

Action: Consult the policy documentation for details.

ORA-12411 invalid label value

Cause: The specified label value does not exist.

Action: Check the data dictionary views for the policy to identify valid labels.

ORA-12412 policy package string is not installed

Cause: The policy package does not exist in the database.

Action: Check that the policy package name is correct or install the required policy package.

ORA-12413 labels do not belong to the same policy

Cause: The labels being compared belong to different policies.

Action: Only compare labels that belong to the same policy.

ORA-12414 internal LBAC error: string Error: string

Cause: An internal label policy framework error occurred.

Action: Contact Oracle Support Services.

ORA-12415 A column of another datatype exists on the specified table

Cause: The datatype of the column present in the table is different from the datatype set for the policy column.

Action: Drop the column on the table or change the datatype for the policy column.

ORA-12416 policy string not found

Cause: The specified policy does not exist in the database.

Action: Enter the correct policy name or create the policy.

ORA-12417 database object "string" not found

Cause: The specified object was not in the database.

Action: Enter the correct name for the database object.

ORA-12418 user string not found

Cause: The specified user does not exist in the database.

Action: Correct the user name or create the user.

ORA-12419 null binary label value

Cause: A null value was provided for a binary label operation.

Action: Provide a valid binary label for the operation.

ORA-12420 required procedures and functions not in policy package "string"

Cause: The policy package did not contain all of the procedures and functions necessary to enforce the policy.

Action: Consult the label framework documentation for a list of required procedures and functions for a policy package.

ORA-12421 different size binary labels

Cause: The label sizes for the binary label operation were not equal.

Action: Provide binary labels with the same lengths for the operation.

ORA-12422 max policies exceeded

Cause: You tried to create a new policy, but the maximum number of policies for the instance had already been created.

Action: Increase the size of the MAX_LABEL_POLICIES initialization parameter and restart the server.

ORA-12423 invalid position specified

Cause: The position specified for a binary label operation was invalid.

Action: Provide a position that is within the label size limits.

ORA-12424 length exceeds binary label size

Cause: The length specified for a binary label operation exceeded the size of the binary label.

Action: Provide a bit or byte length that is within the label size limits.

ORA-12425 cannot apply policies or set authorizations for system schemas

Cause: You tried to either apply a policy to the SYS, SYSTEM, or LBACSYS schema or to set user labels/privileges for the SYS, SYSTEM, or LBACSYS user.

Action: Apply policies and set authorizations only for non-system users.

ORA-12426 invalid audit option

Cause: The option specified was not a valid audit option for the specified policy.

Action: Enter a correct audit option.

ORA-12427 invalid input value for string parameter

Cause: An input parameter was specified incorrectly.

Action: Correct the parameter value.

ORA-12429 label list range exceeded

Cause: The specified index value was not between 1 and 6.

Action: Correct the index value for the label list operation.

ORA-12430 invalid privilege number

Cause: The specified privilege number was not between 1 and 32.

Action: Correct the privilege number.

ORA-12431 invalid audit action

Cause: The specified audit action was not a valid audit action.

Action: Correct the audit action number.

ORA-12432 LBAC error: string

Cause: LBAC enforcement resulted in an error.

Action: Correct the problem identified in the error message.

ORA-12433 create trigger failed, policy not applied

Cause: The policy could not be applied due to errors during the creation of a DML trigger.

Action: Correct the SQL syntax of the label function specification.

ORA-12434 invalid audit type: string

Cause: The audit type must be BY ACCESS or BY SESSION.

Action: Correct the audit type value.

ORA-12435 invalid audit success: string

Cause: The audit success parameter must be SUCCESSFUL or NOT SUCCESSFUL.

Action: Correct the audit success value.

ORA-12436 no policy options specified

Cause: A NULL option string was specified, but no default schema or policy option string was found.

Action: Enter a valid option string, or alter the schema or policy to have a valid default option string.

ORA-12437 invalid policy option: string

Cause: A value that was not a valid policy option was entered.

Action: Correct the policy option value.

ORA-12438 repeated policy option: string

Cause: A policy option was entered more than once in the option string.

Action: Remove the duplicate policy option value.

ORA-12439 invalid combination of policy options

Cause: A set of contradictory policy options was entered.

Action: Provide a set of compatible policy options.

ORA-12440 insufficient authorization for the SYSDBA package

Cause: The use of the SYSDBA package requires the LBAC_DBA role.

Action: Grant the LBAC_DBA role to the database user.

ORA-12441 policy string already exists

Cause: You tried to create a policy with the same name as an existing one.

Action: Use a different name or drop the existing policy.

ORA-12442 policy column "string" already used by an existing policy

Cause: You tried to create a policy with the same policy column name as an existing policy.

Action: Use a different name for the policy column or drop the existing policy.

ORA-12443 policy not applied to some tables in schema

Cause: You applied a policy to a schema, and some of the tables in the schema already had the policy applied.

Action: No action necessary; the policy was applied to the remaining tables.

ORA-12444 policy already applied to table

Cause: You tried to apply a policy to a table that was already protected by the policy.

Action: To change the policy options, predicate, or label function, remove the policy from the table and re-apply it.

ORA-12445 cannot change HIDDEN property of column

Cause: You tried to specify a different HIDE option for a table with an existing policy column.

Action: Drop the column from the table and re-apply the policy with the new HIDE option.

ORA-12446 Insufficient authorization for administration of policy string

Cause: You tried to perform an administrative function for a policy, but you have not been granted the policy_DBA role.

Action: Grant the user the policy_DBA role for the specified policy.

ORA-12447 policy role already exists for policy string

Cause: The role named policy_DBA already exists.

Action: Correct the policy name or delete the existing policy.

ORA-12448 policy string not applied to schema string

Cause: You tried to alter a schema policy that was not applied.

Action: Correct the policy name or schema name.

ORA-12449 Labels specified for user must be of type USER

Cause: You tried to set labels for a user, but the labels in the list were not all designated as USER labels.

Action: Alter the labels to be USER labels.

ORA-12450 LOB datatype disabled in LBAC initialization file

Cause: You tried to specify a LOB datatype for a column or attribute, but the use of the LOB datatype has been disabled.

Action: Change the LBAC initialization file to allow the creation of LOB columns and attributes.

ORA-12451 label not designated as USER or DATA

Cause: A label is either a DATA label, a USER label, or both DATA and USER.

Action: Enter TRUE for at least DATA or USER.

ORA-12452 label tag string already exists

Cause: The label tag value you entered is already in use for another label.

Action: Enter a different value for the label tag.

ORA-12453 label string already exists

Cause: The label value you entered already exists.

Action: No action necessary; alter the label to change its tag or type.

ORA-12454 label string does not exist for policy string

Cause: The label tag or value you entered did not identify a label for the policy.

Action: Enter a label value or tag that is in use by the policy.

ORA-12461 undefined level string for policy string

Cause: The specified level is not defined for the policy.

Action: Correct the level identifier value.

ORA-12462 undefined compartment string for policy string

Cause: The specified compartment is not defined for the policy.

Action: Correct the compartment identifier value.

ORA-12463 undefined group string for policy string

Cause: The specified group is not defined for the policy.

Action: Correct the group identifier value.

ORA-12464 invalid characters in label component string

Cause: Label components can contain only alphanumeric characters, blanks, and underscores.

Action: Correct syntax of the label component.

ORA-12465 not authorized for read or write on specified groups or compartments

Cause: You included groups or compartments that are not in the user's list of groups and compartments authorized for read or write access.

Action: Include read access when authorizing groups or compartments for write access.

ORA-12466 default level is greater than the user's maximum

Cause: The default level cannot be greater than the user's maximum.

Action: Enter an authorized level.

ORA-12467 minimum label can contain a level only

Cause: You included compartments or groups in the minimum label.

Action: Enter only an authorized minimum level as the label.

ORA-12468 max write level does not equal max read level

Cause: The level in the max write label must equal the level in the max read label.

Action: Enter max read and max write labels with the same level component.

ORA-12469 no user levels found for user string and policy string

Cause: No levels have been specified for the user.

Action: Enter the maximum and minimum labels for the user.

ORA-12470 NULL or invalid user label: string

Cause: The label entered is NULL or not within the user's authorizations.

Action: Enter the authorized labels for the user.

ORA-12471 Specified compartment or group is not authorized for user

Cause: The specified compartment or group is not in user's authorizations or the user does not have read on compartment or group specified for write.

Action: Enter an authorized compartment or group.

ORA-12476 least upper bound resulted in an invalid OS label

Cause: You tried to do an operation that generated a least upper bound (LUB) label which is not a valid label on your operating system.

Action: Consult your OS label management documentation for information on invalid label generation.

ORA-12477 greatest lower bound resulted in an invalid OS label

Cause: You tried to do an operation that generated a greatest lower bound (GLB) label which is not a valid label on your operating system.

Action: Consult your OS label management documentation for information on invalid label generation.

ORA-12479 file label string must equal DBHIGH string

Cause: A database file had an OS label that did not match DBHIGH. Either DBHIGH was altered or the OS file was relabeled.

Action: Relabel the file so that its label matches DBHIGH, or alter DBHIGH so that it matches the label on the file.

ORA-12480 specified clearance labels not within the effective clearance

Cause: You specified a clearance range that was not within your authorized clearance; you can only specify clearance ranges that are within your clearance.

Action: Specify clearance labels that are within your own clearance range.

ORA-12481 effective label not within program unit clearance range

Cause: The effective label when the program unit was invoked was not within the range authorized for the program unit.

Action: Modify the program unit clearance range or invoke the program unit from a session with an authorized effective clearance.

ORA-12482 internal MLS error: string Error: string

Cause: An internal MLS policy error occurred.

Action: Contact Oracle Support Services.

ORA-12483 label not in OS system accreditation range

Cause: The specified label is above the OS maximum label or below the OS minimum label.

Action: Use a label that is within the accreditation range for the host OS.

ORA-12484 invalid OS label

Cause: The specified label does not exist in the OS host's label definition file.

Action: Use the OS label management tools to define the label.

ORA-12485 new effective label not within effective clearance

Cause: You attempted to enter a value for an effective label that did not dominate the effective min label or was not dominated by the effective max label.

Action: Enter a value between the min and the max labels.

ORA-12486 effective max labels and min labels cannot be changed

Cause: You attempted to enter a value for an effective min label or effective max label, but these labels cannot be changed.

Action: Enter NULL values for the effective minimum and maximum labels.

ORA-12487 clearance labels not between DBHIGH and DBLOW

Cause: You attempted to enter a value for a clearance label that was not dominated by DBHIGH or did not dominate DBLOW.

Action: Enter clearance label values between DBHIGH and DBLOW.

ORA-12488 maximum label does not dominate minimum label

Cause: You attempted to enter a value for a clearance label that did not preserve the dominance relationship between the minimum and maximum labels.

Action: Enter label values that preserves the dominance relationship between the minimum and maximum.

ORA-12489 default label not within clearance range

Cause: You attempted to enter a value for a default label that did not dominate the minimum clearance or was not dominated by the maximum clearance.

Action: Enter a default label value within the clearance range.

ORA-12490 DBHIGH cannot be lowered

Cause: You attempted to enter a value for DBHIGH that did not dominate the existing value of DBHIGH.

Action: Enter a value for DBHIGH that dominates the old value.

ORA-12491 DBHIGH value does not dominate DBLOW

Cause: You attempted to enter a value for DBHIGH that did not dominate DBLOW.

Action: Enter a value for DBHIGH that dominates DBLOW.

ORA-12492 DBLOW cannot be changed

Cause: You attempted to change the value of DBLOW after it had been set to any initial value. DBLOW can only be set once after initial database creation.

Action: To change DBLOW, you have to create a new database, set DBLOW to the new value, and import your data into the new database.

ORA-12493 invalid MLS binary label

Cause: The MLS binary label contained an invalid value, was not the correct size, or contained a level, category, or release category that was not enabled.

Action: Check the DBA_MLS_LABELS view for the valid MLS labels.

ORA-12494 cannot insert or delete a level, category, or release category

Cause: You attempted to insert or delete a level, category, or release category definition.

Action: If the label definition is no longer valid, change its name to one that identifies it as invalid. When any labels are converted to character strings, the new label definition will be used.

ORA-12495 cannot disable an enabled level, category, or release category

Cause: You attempted to disable a level, category, or release category that had previously been enabled. An enabled label definition may exist in some database label, so it cannot be disabled.

Action: If the label definition is no longer valid, change its name to one that identifies it as invalid. When any labels are converted to character strings, the new label definition will be used.

ORA-12496 cannot change existing level, category, or release numbers

Cause: You attempted to change the number assigned to level, category or releasability category.

Action: Change the character string representations, not the numbers.

ORA-12497 maximum combined categories exceeds string

Cause: The maximum number of descriptive categories plus release categories supported by the MLS policy was exceeded.

Action: Enter numbers that do not add up to more than the maximum.

ORA-12500 through ORA-12699

See Chapter 30, "Oracle Net Messages (TNS)" (the messages are listed with the prefix TNS in that chapter even though they are displayed with the prefix ORA).


ORA-12700 to ORA-19399

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

11
ORA-12700 to ORA-19399

ORA-12700 invalid NLS parameter value (string)

Cause: An invalid NLS initialization parameter was specified.

Action: Check the syntax and spelling of the parameter. Enter the correct parameter into the initialization parameter file.

ORA-12701 CREATE DATABASE character set is not known

Cause: The character set specified in the CREATE DATABASE command does not exist on the system.

Action: Refer to your Oracle operating system-specific documentation for more information about character sets on the system. Use a valid character set in the CREATE DATABASE command.

ORA-12702 invalid NLS parameter string used in SQL function

Cause: An invalid parameter or value was entered in the NLS parameter string in a SQL function.

Action: Check the syntax of the function and the parameters. Enter the command again using the correct syntax and valid values.

ORA-12703 this character set conversion is not supported

Cause: An attempt was made to use the CONVERT function to convert between two character sets, and the requested conversion is not possible due to unavailability of one or both character sets.

Action: Use character sets available on the system in the CONVERT function.

ORA-12704 character set mismatch

Cause: One of the following:

  • The string operands (other than an NLSPARAMS argument) to an operator or built-in function do not have the same character set.
  • An NLSPARAMS operand is not in the database character set.
  • String data with character set other than the database character set is passed to a built-in function not expecting it.
  • The second argument to CHR() or CSCONVERT() is not CHAR_CS or NCHAR_CS.
  • A string expression in the VALUES clause of an INSERT statement, or the SET clause of an UPDATE statement, does not have the same character set as the column into which the value would be inserted.
  • A value provided in a DEFAULT clause when creating a table does not have the same character set as declared for the column.
  • An argument to a PL/SQL function does not conform to the character set requirements of the corresponding parameter.

Action: Strings declared with NCHAR or NCHAR VARYING do not interoperate with strings declared with CHAR or VARCHAR2. Use TRANSLATE() function to explicitly convert one to the other.

ORA-12705 invalid or unknown NLS parameter value specified

Cause: There are two possible causes: Either an attempt was made to issue an ALTER SESSION statement with an invalid NLS parameter or value; or the NLS_LANG environment variable contains an invalid language, territory, or character set.

Action: Check the syntax of the ALTER SESSION statement and the NLS parameter, correct the syntax and retry the statement, or specify correct values in the NLS_LANG environment variable. For more information about the syntax of the ALTER SESSION statement, see the Oracle9i SQL Reference.

ORA-12706 this CREATE DATABASE character set is not allowed

Cause: An attempt was made to create a database on an ASCII-based machine using an EBCDIC-based character set or vice versa. This is not permitted.

Action: Create the database using either ASCII-based or EBCDIC-based character sets, depending on what is supported by the hardware. Refer to your Oracle operating system-specific documentation for more information about the type of character set supported.

ORA-12707 error while getting create database NLS parameter string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-12708 error while loading create database NLS parameter string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-12709 error while loading create database character set

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-12710 CREATE CONTROLFILE character set is not known

Cause: The character set specified when creating the control file is unknown.

Action: Specify a known character set.

ORA-12711 this CREATE CONTROLFILE character set is not allowed

Cause: It is not allowed to create a control file on a native ASCII-based machine using an EBCDIC-based character set, and vice versa.

Action: Create the correct control file for machine and character set.

ORA-12712 new character set must be a superset of old character set

Cause: When you ALTER DATABASE ... CHARACTER SET, the new character set must be a superset of the old character set. For example, WE8ISO8859P1 is not a superset of the WE8DEC.

Action: Specify a superset character set.

ORA-12713 Character data loss in NCHAR/CHAR conversion

Cause: When character set conversion happens between CHAR and NCHAR either implicitly or explicitly, some characters are lost due to no mapping characters in the destination character set.

Action: Make sure all the characters can be mapped to destination character set or set NLS_NCHAR_CONV_EXCP to false.

ORA-12714 invalid national character set specified

Cause: Only UTF8 and AL16UTF16 are allowed to be used as the national character set.

Action: Ensure that the specified national character set is valid.

ORA-12715 invalid character set specified

Cause: The character set specified is not allowed for this operation or is invalid.

Action: Ensure that the specified character set is valid.

ORA-12716 Cannot ALTER DATABASE CHARACTER SET when CLOB data exists

Cause: CLOB data changes representation to Unicode when converting to a multibyte character set and must be migrated.

Action: Remove CLOB data as listed in the alert file. CLOB data can be migrated by methods such as export/import.

ORA-12717 Cannot ALTER DATABASE NATIONAL CHARACTER SET when NCLOB data exists

Cause: NCLOB data changes representation to Unicode when converting to a multibyte character set and must be migrated.

Action: Remove NCLOB data as listed in the alert file. NCLOB data can be migrated by methods such as export/import.

ORA-12718 operation requires connection as SYS

Cause: This command can only be run when connecting as user SYS.

Action: Connect as user SYS to run this command.

ORA-12719 operation requires database is in RESTRICTED mode

Cause: This command can only be run when the database is in RESTRICTED mode.

Action: Ensure that the system is in RESTRICTED mode.

ORA-12720 operation requires database is in EXCLUSIVE mode

Cause: This command can only be run when the database is in EXCLUSIVE mode.

Action: Ensure that the system is in EXCLUSIVE mode.

ORA-12721 operation cannot execute when other sessions are active

Cause: This command can only be run when there are no other sessions active.

Action: Ensure there are no other connections to the database.

ORA-12800 system appears too busy for parallel query execution

Cause: Load on the system is too high to perform parallel queries.

Action: Re-execute serially or wait until the system load is reduced.

ORA-12801 error signaled in parallel query server string

Cause: A parallel query server reached an exception condition.

Action: Check the following error message for the cause.

ORA-12802 parallel query server lost contact with coordinator

Cause: A parallel query server lost contact with the foreground (coordinator) process/thread.

Action: Check your system for anomalies and reissue the statement. If this error persists, then contact Oracle Support Services.

ORA-12803 parallel query server lost contact with another server

Cause: A parallel query server lost contact with another server.

Action: Check your system for anomalies and reissue the statement. If this error persists, then contact Oracle Support Services.

ORA-12804 parallel query server appears to have died

Cause: Cannot find process information for a parallel query server thread.

Action: Check your system for anomalies and reissue the statement. If this error persists, then contact Oracle Support Services.

ORA-12805 parallel query server died unexpectedly

Cause: A parallel query server died unexpectedly, PMON cleaning up the process.

Action: Check your system for anomalies and reissue the statement. If this error persists, then contact Oracle Support Services. See trace file for more details.

ORA-12806 could not get background process to hold enqueue

Cause: This is an internal error.

Action: This error should not normally occur. If it persists, THEN contact Oracle Support Services.

ORA-12807 process queue could not receive parallel query message

Cause: This is an internal error.

Action: This error should not normally occur. If it persists, THEN contact Oracle Support Services.

ORA-12808 cannot set string_INSTANCES greater than number of instances string

Cause: An attempt was made to set SCAN_INSTANCES or CACHE_INSTANCES using the ALTER SYSTEM statement to a value larger than the number of available instances.

Action: See the accompanying message for the current allowable maximum value, or set SCAN_INSTANCES / CACHE_INSTANCES to ALL.

ORA-12809 cannot set string_INSTANCES when mounted in exclusive mode

Cause: An attempt was made to set SCAN_INSTANCES or CACHE_INSTANCES using the ALTER SYSTEM statement while the database was mounted in exclusive mode.

Action: SCAN_INSTANCES / CACHE_INSTANCES may not be set unless running Oracle9i Real Application Clusters mounted in CLUSTER_DATABASE mode.

ORA-12810 PARALLEL_MAX_SERVERS must be less than or equal to string

Cause: An attempt was made to set the PARALLEL_MAX_SERVERS parameter to a value higher than the maximum allowed by the system.

Action: Set PARALLEL_MAX_SERVERS to a value less than or equal to the maximum specified in the accompanying message and retry.

ORA-12811 PARALLEL_MIN_SERVERS must be less than or equal to PARALLEL_MAX_SERVERS, string

Cause: An attempt was made to set the PARALLEL_MIN_SERVERS parameter to a value higher than PARALLEL_MAX_SERVERS.

Action: Set PARALLEL_MIN_SERVERS to a value less than or equal to PARALLEL_MAX_SERVERS (indicated in the accompanying message) and retry.

ORA-12812 only one PARALLEL or NOPARALLEL clause may be specified

Cause: PARALLEL was specified more than once, NOPARALLEL was specified more than once, or both PARALLEL and NOPARALLEL were specified in a CREATE TABLE, CLUSTER, or INDEX or in an ALTER TABLE or CLUSTER statement, or in a RECOVER command.

Action: Remove all but one of the PARALLEL or NOPARALLEL clauses and reissue the statement.

ORA-12813 value for PARALLEL or DEGREE must be greater than 0

Cause: PARALLEL 0 or DEGREE 0 was specified in a CREATE TABLE, CLUSTER, or INDEX or in an ALTER TABLE or CLUSTER statement.

Action: Specify a degree of parallelism greater than 0 or specify default parallelism using PARALLEL with no degree or using DEGREE DEFAULT within a PARALLEL clause.

ORA-12814 only one CACHE or NOCACHE clause may be specified

Cause: CACHE was specified more than once, NOCACHE was specified more than once, or both CACHE and NOCACHE were specified in a CREATE TABLE or CLUSTER, or in an ALTER TABLE or CLUSTER statement.

Action: Remove all but one of the CACHE or NOCACHE clauses and reissue the statement.

ORA-12815 value for INSTANCES must be greater than 0

Cause: PARALLEL parameter specifying number of instances must be a positive integer or DEFAULT.

Action: specify a positive integer or DEFAULT for INSTANCES if parallelism across instances is desired.

ORA-12816 parallel create index fastpath operation

Cause: The parallel create index fastpath operation event has been set.

Action: Set this event only under the supervision Oracle development.

ORA-12817 parallel query option must be enabled

Cause: A parallel query option feature has been invoked but this option has not been enabled.

Action: Enable the parallel query option.

ORA-12818 invalid option in PARALLEL clause

Cause: An unrecognized option was used within a PARALLEL clause.

Action: specify any combination of DEGREE { n | DEFAULT } and INSTANCES { n | DEFAULT } within the PARALLEL clause.

ORA-12819 missing options in PARALLEL clause

Cause: PARALLEL clause cannot be empty.

Action: specify any combination of DEGREE { n | DEFAULT } and INSTANCES { n | DEFAULT } within the PARALLEL clause.

ORA-12820 invalid value for DEGREE

Cause: Invalid value for DEGREE was specified within a PARALLEL clause.

Action: Specify a positive integer or DEFAULT for the DEGREE option within a PARALLEL clause.

ORA-12821 invalid value for INSTANCES

Cause: An invalid value for INSTANCES was specified within a PARALLEL clause.

Action: Specify a positive integer or DEFAULT for the INSTANCES option within a PARALLEL clause.

ORA-12822 duplicate option in PARALLEL clause

Cause: DEGREE or INSTANCES was specified more than once within a PARALLEL clause.

Action: Specify each desired PARALLEL clause option only once.

ORA-12823 default degree of parallelism may not be specified here

Cause: The PARALLEL keyword was used alone or DEGREE DEFAULT was specified in the PARALLEL clause of an ALTER DATABASE RECOVER statement.

Action: Respecify with an explicit degree of parallelism.

ORA-12824 INSTANCES DEFAULT may not be specified here

Cause: INSTANCES DEFAULT was specified in the PARALLEL clause of an ALTER DATABASE RECOVER command.

Action: Respecify with an explicit value for INSTANCES or omit the INSTANCES option if single instance recovery is desired.

ORA-12825 explicit degree of parallelism must be specified here

Cause: The DEGREE option was omitted from an ALTER DATABASE RECOVER command.

Action: Respecify with an explicit degree of parallelism.

ORA-12826 hung parallel query server was killed

Cause: The parallel query server was hung and subsequently killed.

Action: Re-execute the query and report suspicious events in the trace file to Oracle Support Services if the error persists.

ORA-12827 insufficient parallel query slaves available

Cause: PARALLEL_MIN_PERCENT parameter was specified and fewer than minimum slaves were acquired.

Action: Either re-execute query with lower PARALLEL_MIN_PERCENT or wait until some running queries are completed, thus freeing up slaves.

ORA-12828 Can't start parallel transaction at a remote site

Cause: PDML transaction cannot be started because we are not in the coordinator site of the distributed transaction.

Action: Do not use PDML at remote sites.

ORA-12829 Deadlock - itls occupied by siblings at block string of file string

Cause: A parallel statement failed because all ITLS in the current block are occupied by siblings of the same transaction.

Action: Increase the value of MAXTRANS of the block or reduce the degree of parallelism for the statement. Re-execute the statement. Report suspicious events in the trace file to Oracle Support Services if the error persists.

ORA-12830 Must COMMIT or ROLLBACK after executing parallel INSERT/UPDATE/DELETE

Cause: After executing a parallel INSERT/UPDATE/DELETE statement, a command other than COMMIT or ROLLBACK was issued.

Action: Execute COMMIT or ROLLBACK before issuing another SQL command.

ORA-12831 Must COMMIT or ROLLBACK after executing INSERT with APPEND hint

Cause: After executing an INSERT statement with an APPEND hint, a command other than COMMIT or ROLLBACK was issued.

Action: Execute COMMIT or ROLLBACK before issuing another SQL command.

ORA-12832 Could not allocate slaves on all specified instances

Cause: After executing a query on a global v$ fixed view, one or more instances failed to allocate a slave to process query.

Action: To allow results to be returned by successfully allocated slaves, execute ALTER SESSION SET ALLOW_PARTIAL_SN_RESULTS=TRUE statement, or check parameters of instances.

ORA-12833 Coordinator's instance not a member of parallel_instance_group

Cause: The coordinator's instance must be a member of the PARALLEL_INSTANCE_GROUP in which this operation will be run.

Action: Either add the coordinator's instance to the current PARALLEL_INSTANCE_GROUP or change PARALLEL_INSTANCE_GROUP.

ORA-12834 Instance group name, 'string', too long, must be less than string characters

Cause: The instance group name is too long.

Action: Either shorten the name or get rid of the instance group.

ORA-12835 No instances are active in the GLOBAL_VIEW_ADMIN_GROUP

Cause: There must be at least one instance in the GLOBAL_VIEW_ADMIN_GROUP in order to execute a query on global views.

Action: Change the value of GLOBAL_VIEW_ADMIN_GROUP.

ORA-12838 cannot read/modify an object after modifying it in parallel

Cause: Within the same transaction, an attempt was made to add read or modification statements on a table after it had been modified in parallel or with direct load. This is not permitted.

Action: Rewrite the transaction, or break it up into two transactions: one containing the initial modification and the second containing the parallel modification operation.

ORA-12839 cannot modify an object in parallel after modifying it

Cause: Within the same transaction, an attempt was made to perform parallel modification operations on a table after it had been modified. This is not permitted.

Action: Rewrite the transaction or break it up into two transactions: one containing the parallel modification and the second containing the initial modification operation.

ORA-12840 cannot access a remote table after parallel/insert direct load txn

Cause: Within a transaction, an attempt was made to perform distributed access after a PDML or insert direct statement had been issued.

Action: Commit/roll back the PDML transaction first, and then perform the distributed access, or perform the distributed access before the first PDML statement in the transaction.

ORA-12841 Cannot alter the session parallel DML state within a transaction

Cause: Transaction in progress.

Action: Commit or roll back the transaction and then re-execute.

ORA-12842 schema modified during parallel execution

Cause: Schema modified during the parse phase of parallel processing.

Action: No action required.

ORA-12843 pdml lock not held properly on the table

Cause: The coodinator crashed or released the lock on the partition which the slave is trying to aquire.

Action: Check if the coordinator or some of the other slaves died. Also check that the lock has not been corrupted. Issue the PDML again.

ORA-12900 must specify a default temporary tablespace for a locally managed database

Cause: A locally managed database must have a temporary tablespace other than SYSTEM tablespace.

Action: Specify the default temporary tablespace when creating a locally managed database.

ORA-12901 Default temporary tablespace must be of TEMPORARY type

Cause: In a locally managed database, default temporary tablespace must be TEMPORARY type.

Action:

ORA-12902 default temporary tablespace must be SYSTEM or of TEMPORARY type

Cause: In a dictionary-managed database, default temporary tablespace must be SYSTEM or TEMPORARY type.

Action:

ORA-12903 default temporary tablespace must be an ONLINE tablespace

ORA-12904 default temporary tablespace cannot be altered to PERMANENT type

ORA-12905 default temporary tablespace cannot be brought OFFLINE

ORA-12906 cannot drop default temporary tablespace

ORA-12907 tablespace string is already the default temporary tablespace

ORA-12908 cannot specify SYSTEM as default temporary tablespace when creating database

ORA-12909 TEMPORARY keyword expected

ORA-12910 cannot specify temporary tablespace as default tablespace

Cause: An attempt was made to assign a temporary tablespace to be a user's default tablespace.

Action: Assign a permanent tablespace to be the default tablespace.

ORA-12911 permanent tablespace cannot be temporary tablespace

Cause: An attempt was made to assign a permanent tablespace to be a user's temporary tablespace.

Action: Assign a temporary tablespace to be user's temporary tablespace.

ORA-12912 Dictionary managed tablespace specified as temporary tablespace

Cause: An attempt was made to assign a dictionary managed tablespace to be a user's temporary tablespace.

Action: Assign a locally managed temporary tablespace to be the user's temporary tablespace.

ORA-12913 Cannot create dictionary managed tablespace

Cause: An attempt was made to create a dictionary managed tablespace in a database whose SYSTEM tablespace is locally managed.

Action: Create a locally managed tablespace.

ORA-12914 Cannot migrate tablespace to dictionary managed type

Cause: An attempt was made to migrate a locally managed tablespace to dictionary managed type when the database has a locally managed SYSTEM tablespace.

Action: Such an operation cannot be issued.

ORA-12915 Cannot alter dictionary managed tablespace to read write

Cause: An attempt was made to alter a dictionary managed tablespace to read write in a database whose SYSTEM tablespace is locally managed. This tablespace can only be dropped.

Action: Such an operation cannot be issued.

ORA-12920 database is already in force logging mode

Cause: The ALTER DATABASE FORCE LOGGING statement failed because the database is already in force logging mode.

Action: No action required.

ORA-12921 database is not in force logging mode

Cause: The ALTER DATABASE NO FORCE LOGGING statement failed because the database is not in force logging mode.

Action: No action required.

ORA-12922 concurrent ALTER DATABASE [NO] FORCE LOGGING command is running

Cause: There is a concurrent ALTER DATABASE FORCE LOGGING or ALTER DATABASE NO FORCE LOGGING statement running in the system.

Action: Contact the database administrator who is responsible for the concurrent statement.

ORA-12923 tablespace string is in force logging mode

Cause: An attempt to alter the specified temporary tablespace failed because the tablespace is in force logging mode.

Action: Put the tablespace out of force logging mode by issuing an ALTER TABLESPACE NO FORCE LOGGING statement.

ORA-12924 tablespace string is already in force logging mode

Cause: An attempt to alter the specified tablespace into force logging mode failed because it is already in force logging mode.

Action: No action required.

ORA-12925 tablespace string is not in force logging mode

Cause: An attempt to alter the specified tablespace out of force logging mode failed because it is not in force logging mode.

Action: No action required.

ORA-12926 FORCE LOGGING option already specified

Cause: In CREATE TABLESPACE, the FORCE LOGGING option was specified more than once.

Action: Remove all but one of the FORCE LOGGING options.

ORA-12980 checkpoint option not allowed with SET UNUSED

Cause: An attempt was made to specify checkpoint option with SET UNUSED.

Action: Remove the checkpoint option.

ORA-12981 cannot drop column from an object type table

Cause: An attempt was made to drop a column from an object type table.

Action: This action is not allowed.

ORA-12982 cannot drop column from a nested table

Cause: An attempt was made to drop a column from a nested table.

Action: This action is not allowed.

ORA-12983 cannot drop all columns in a table

Cause: An attempt was made to drop all columns in a table.

Action: Make sure at least one column remains in the table after the drop column operation.

ORA-12984 cannot drop partitioning column

Cause: An attempt was made to drop a column used as the partitioning key.

Action: This action is not allowed.

ORA-12985 tablespace 'string' is read only, cannot drop column

Cause: An attempt was made to drop column from a partition/subpartition on a read-only tablespace.

Action: Set the tablespace to read write and resubmit statement.

ORA-12986 columns in partially dropped state. Submit ALTER TABLE DROP COLUMNS CONTINUE

Cause: An attempt was made to access a table with columns in partially dropped state (that is, drop column operation was interrupted).

Action: Submit ALTER TABLE DROP COLUMNS CONTINUE to complete the drop column operation before accessing the table.

ORA-12987 cannot combine drop column with other operations

Cause: An attempt was made to combine drop column with other ALTER TABLE operations.

Action: Ensure that drop column is the sole operation specified in ALTER TABLE.

ORA-12988 cannot drop column from table owned by SYS

Cause: An attempt was made to drop a column from a system table.

Action: This action is not allowed.

ORA-12989 invalid value for checkpoint interval

Cause: An invalid checkpoint interval specified in statement. Checkpoint interval must be between 0 and (2^31-1).

Action: Correct checkpoint interval and resubmit statement.

ORA-12990 duplicate option specified

Cause: Duplicate option specified in statement.

Action: Remove the duplicate option and resubmit statement.

ORA-12991 column is referenced in a multi-column constraint

Cause: An attempt was made to drop a column referenced by some constraints.

Action: Drop all constraints referencing the dropped column or specify CASCADE CONSTRAINTS in statement.

ORA-12992 cannot drop parent key column

Cause: An attempt was made to drop a parent key column.

Action: Drop all constraints referencing the parent key column, or specify CASCADE CONSTRAINTS in statement.

ORA-12993 tablespace 'string' is offline, cannot drop column

Cause: An attempt was made to drop a column from a partition/subpartition on an offline tablespace.

Action: Bring the tablespace online and resubmit statement.

ORA-12994 drop column option only allowed once in statement

Cause: An attempt was made to repeat the drop column option in a single statement.

Action: Separate drop column options into different statements and resubmit statements.

ORA-12995 no columns in partially dropped state

Cause: An attempt was made to submit DROP COLUMNS CONTINUE statement while there are no partially dropped columns.

Action: Cannot submit this statement.

ORA-12996 cannot drop system-generated virtual column

Cause: An attempt was made to drop a virtual column generated by the system.

Action: This action is not allowed.

ORA-12997 cannot drop primary key column from an index-organized table

Cause: An attempt was made to drop a primary key column from an index- organized table.

Action: This action is not allowed.

ORA-13000 dimension number is out of range

Cause: The specified dimension is either smaller than 1 or greater than the number of dimensions encoded in the HHCODE.

Action: Make sure that the dimension number is between 1 and the maximum number of dimensions encoded in the HHCODE.

ORA-13001 dimensions mismatch error

Cause: The number of dimensions in two HHCODEs involved in a binary HHCODE operation do not match.

Action: Make sure that the number of dimensions in the HHCODEs match.

ORA-13002 specified level is out of range

Cause: The specified level is either smaller than 1 or greater than the maximum level encoded in an HHCODE.

Action: Verify that all levels are between 1 and the maximum number of levels encoded in the HHCODE.

ORA-13003 the specified range for a dimension is invalid

Cause: The specified range for a dimension is invalid.

Action: Make sure that the lower bound (lb) is less than the upper bound (ub).

ORA-13004 the specified buffer size is invalid

Cause: The buffer size for a function is not valid.

Action: This is an internal error. Contact Oracle Support Services.

ORA-13005 recursive HHCODE function error

Cause: An error occurred in a recursively called HHCODE function.

Action: This is an internal error. Contact Oracle Support Services.

ORA-13006 the specified cell number is invalid

Cause: The cell identifier is either less than 0 or greater than (2^ndim - 1).

Action: Make sure that the cell identifier is between 0 and (2^ndim - 1).

ORA-13007 an invalid HEX character was detected

Cause: A character that is not in the range [0-9] or [A-Fa-f] was detected.

Action: Verify that all characters in a string are in the range [0-9] or [A-Fa-f].

ORA-13008 the specified date format has an invalid component

Cause: Part of the specified date format is invalid.

Action: Verify that the date format is valid.

ORA-13009 the specified date string is invalid

Cause: The specified date string has a bad component or does not match the specified format string.

Action: Make sure that the components of the date string are valid and that the date and format strings match.

ORA-13010 an invalid number of arguments has been specified

Cause: An invalid number of arguments was specified for an SDO function.

Action: Verify the syntax of the function call.

ORA-13011 value is out of range

Cause: A specified dimension value is outside the range defined for that dimension.

Action: Make sure that all values to be encoded are within the defined dimension range.

ORA-13012 an invalid window type was specified

Cause: An invalid window type was specified.

Action: Valid window types are RANGE, PROXIMITY, POLYGON.

ORA-13013 the specified topology was not INTERIOR or BOUNDARY

Cause: A topology was specified that was not INTERIOR or BOUNDARY.

Action: Make sure that INTERIOR or BOUNDARY is used to describe an HHCODE's topology.

ORA-13014 a topology identifier outside the range of 1 to 8 was specified

Cause: A topology identifier outside the range of 1 to 8 was specified.

Action: Specify a topology in the range of 1 to 8.

ORA-13015 the window definition is not valid

Cause: The number of values used to define the window does not correspond to the window type.

Action: Verify that the number of values used to define the window is correct for the window type and number of dimensions.

ORA-13016 bad partition definition

Cause: The partition common code was not correctly decoded.

Action: This is an internal error. Contact Oracle Support Services.

ORA-13017 unrecognized line partition shape

Cause: The shape of a 2-D line partition could not be determined.

Action: This is an internal error. Contact Oracle Support Services.

ORA-13018 bad distance type

Cause: The specified distance type is invalid.

Action: The only supported distance functions are EUCLID and MANHATTAN.

ORA-13019 coordinates out of bounds

Cause: Vertex coordinates lie outside the valid range for the specified dimension.

Action: Re-define vertex coordinates within specified boundaries.

ORA-13020 coordinate is NULL

Cause: A vertex coordinate has a NULL value.

Action: Re-define vertex coordinate to have a non-NULL value.

ORA-13021 element not continuous

Cause: The coordinates defining a geometric element are not connected.

Action: Re-define coordinates for the geometric element.

ORA-13022 polygon crosses itself

Cause: The coordinates defining a polygonal geometric element represent crossing segments.

Action: Re-define the coordinates for the polygon.

ORA-13023 interior element interacts with exterior element

Cause: An interior element of a geometric object interacts with the exterior element of that object.

Action: Re-define coordinates for the geometric elements.

ORA-13024 polygon has less than three segments

Cause: The coordinates defining a polygonal geometric element represent less than three segments.

Action: Re-define the coordinates for the polygon.

ORA-13025 polygon does not close

Cause: The coordinates defining a polygonal geometric element represent an open polygon.

Action: Re-define the coordinates of the polygon.

ORA-13026 unknown element type for element string.string.string

Cause: The SDO_ETYPE column in the layer_SDOGEOM table contains an invalid geometric element type value.

Action: Re-define the geometric element type in the layer_SDOGEOM table for the specified geometric element using one of the supported SDO_ETYPE values. See the Oracle Spatial User's Guide and Reference for an explanation of SDO_ETYPE and its possible values.

ORA-13027 unable to read dimension definition from string

Cause: There was a problem reading the dimension definition from the layer_SDODIM table.

Action: Verify that the layer_SDODIM table exists and that the appropriate privileges exist on the table. Address any other errors that might appear with the message.

ORA-13028 Invalid Gtype in the SDO_GEOMETRY object

Cause: There is an invalid SDO_GTYPE in the SDO_GEOMETRY object.

Action: Verify that the geometries have valid gtypes.

ORA-13029 Invalid SRID in the SDO_GEOMETRY object

Cause: There is an invalid SDO_SRID in the SDO_GEOMETRY object. The specified SRID may be outside the valid SRID range.

Action: Verify that the geometries have valid SRIDs.

ORA-13030 Invalid dimension for the SDO_GEOMETRY object

Cause: There is a mismatch between the dimension in the SDO_GTYPE and the dimension in the SDO_GEOM_METADATA for the SDO_GEOMETRY object.

Action: Verify that the geometries have valid dimensionality.

ORA-13031 Invalid Gtype in the SDO_GEOMETRY object for point object

Cause: There is an invalid SDO_GTYPE in the SDO_GEOMETRY object where the VARRAYs are NULL but the SDO_GTYPE is not of type POINT.

Action: Verify that the geometries have valid gtypes.

ORA-13032 Invalid NULL SDO_GEOMETRY object

Cause: There are invalid SDO_POINT_TYPE, SDO_ELEM_INFO_ARRAY, or SDO_ORDINATE_ARRAY fields in the SDO_GEOMETRY object.

Action: Verify that the geometries have valid fields. To specify a NULL Geometry, specify the whole SDO_GEOMETRY as NULL instead of setting each field to NULL.

ORA-13033 Invalid data in the SDO_ELEM_INFO_ARRAY in SDO_GEOMETRY object

Cause: There is invalid data in the SDO_ELEM_INFO_ARRAY field of the SDO_GEOMETRY object. The triplets in this field do not make up a valid geometry.

Action: Verify that the geometries have valid data.

ORA-13034 Invalid data in the SDO_ORDINATE_ARRAY in SDO_GEOMETRY object

Cause: There is invalid data in the SDO_ORDINATE_ARRAY field of the SDO_GEOMETRY object. The coordinates in this field do not make up a valid geometry. There may be NULL values for X, Y, or both.

Action: Verify that the geometries have valid data.

ORA-13035 Invalid data (arcs in geodetic data) in the SDO_GEOMETRY object

Cause: There is invalid data in the SDO_ELEM_INFO_ARRAY field of the SDO_GEOMETRY object. There are arcs in a geometry that has geodetic coordinates.

Action: Verify that the geometries have valid data.

ORA-13036 Operation [string] not supported for Point Data

Cause: The specified geometry function is not supported for Point data.

Action: Make sure that the specified geometry function is not called on point data.

ORA-13037 SRIDs do not match for the two geometries

Cause: A Spatial operation is invoked with two geometries where one geometry has an SRID and the other geometry does not have an SRID.

Action: Make sure that the spatial operations are invoked between two geometries with compatible SRIDs.

ORA-13039 failed to update spatial index for element string.string.string

Cause: Another error will accompany this message that will indicate the problem.

Action: Correct any accompanying errors. If no accompanying error message appears, then contact Oracle Support Services.

ORA-13040 failed to subdivide tile

Cause: This is an internal error.

Action: Note any accompanying errors and contact Oracle Support Services.

ORA-13041 failed to compare tile with element string.string.string

Cause: The spatial relationship between a generated tile and the specified element could not be determined.

Action: This is an internal error. Verify the geometry using the VALIDATE_GEOMETRY procedure. If the procedure does not return any errors, then note any errors which accompany ORA-13041 and contact Oracle Support Services.

ORA-13042 invalid SDO_LEVEL and SDO_NUMTILES combination

Cause: An invalid combination of SDO_LEVEL and SDO_NUMTILES values was read from the layer_SDOLAYER table. The most likely cause is that the columns are NULL.

Action: Verify that the SDO_LEVEL and SDO_NUMTILES columns contain valid integer values as described in the Oracle Spatial User's Guide and Reference. Retry the operation.

ORA-13043 failed to read meta data from the layer_SDOLAYER table

Cause: An error was encountered reading the layer meta data from the layer_SDOLAYER table.

Action: This error is usually the result of an earlier error which should also have been reported. Address this accompanying error and retry the current operation. If no accompanying error was reported, then contact Oracle Support Services.

ORA-13044 the specified tile size exceeds the maximum resolution

Cause: The tile size specified for fixed size tessellation exceeds the maximum resolution as computed from the layer meta data.

Action: See the Oracle Spatial User's Guide and Reference for an explanation of tiling levels, tile size, and tiling resolution. Ensure that the tiling parameters are set such that any generated tile is always larger than or equal to a tile at the maximum level of resolution. This can be achieved by using a fewer number of tiles per geometric object or specifying a lesser tile size value than the current one.

ORA-13045 invalid compatibility flag

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13046 invalid number of arguments

Cause: An invalid number of arguments was specified for an SDO_GEOM function.

Action: Refer to the Oracle Spatial User's Guide and Reference for a description of the syntax and semantics of the relevant SDO_GEOM function.

ORA-13047 unable to determine ordinate count from table layer_SDOLAYER

Cause: An SDO_GEOM function was unable to determine the number of ordinates for the SDO layer layer.

Action: Verify that the layer_SDOLAYER table has a valid value for the column SDO_ORDCNT. Retry the operation.

ORA-13048 recursive SQL fetch error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13049 unable to determine tolerance value from table layer_SDODIM

Cause: An SDO_GEOM function was unable to determine the tolerance value for the SDO layer layer.

Action: Verify that the layer_SDODIM table has a valid value for the column SDO_TOLERANCE.

ORA-13050 unable to construct spatial object

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13051 failed to initialize spatial object

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13052 unsupported geometric type for geometry string.string

Cause: The geometry type for a specific instance in a layer_SDOGEOM table is not among the set of geometry types supported by the Oracle Spatial Cartridge.

Action: Check the Oracle Spatial User's Guide and Reference for the list of supported geometry types and workarounds that permit the storage and retrieval of non-supported geometric types with the SDO schema.

ORA-13053 maximum number of geometric elements in argument list exceeded

Cause: The maximum number of geometric elements that can be specified in the argument list for an SDO_GEOM function was exceeded.

Action: Check the Oracle Spatial User's Guide and Reference for the syntax of the SDO_GEOM function and use fewer arguments to describe the geometry, or check the description of the SDO_WINDOW package for a workaround that permits storing the object in a table and then using it as an argument in a call to the SDO_GEOM function.

ORA-13054 recursive SQL parse error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13055 Oracle object string does not exist in specified table

Cause: The requested object is not present in the specified table.

Action: Verify the syntax of the function or procedure that reported this error and verify that the object does indeed exist in the specified table. Retry the operation.

ORA-13108 spatial table string not found

Cause: The specified spatial table does not exist.

Action: Check the Spatial Data option data dictionary to make sure that the table is registered.

ORA-13109 spatial table string exists

Cause: The specified spatial table is registered in the Spatial Data option data dictionary.

Action: Remove the existing table from the Spatial Data option data dictionary or use a different name.

ORA-13110 spatial table string is not partitioned

Cause: The specified spatial table is not partitioned.

Action: Check the Spatial Data option data dictionary and make sure that a high water mark is set.

ORA-13111 spatial table string has no partition key defined

Cause: The specified spatial table does not have a partition key defined.

Action: Check the Spatial Data option data dictionary and make sure that the table is partitioned.

ORA-13112 invalid count mode string

Cause: The specified count mode is not valid.

Action: Alter the count mode. Valid count modes are ESTIMATE or EXACT.

ORA-13113 Oracle table string does not exist

Cause: The specified Oracle table does not exist.

Action: Check the Oracle7 data dictionary and make sure that the table exists.

ORA-13114 tablespace string not found

Cause: The specified tablespace does not exist.

Action: Check the Oracle7 data dictionary and make sure that the specified tablespace exists and that there is a space quota defined on it.

ORA-13115 tablespace string is already allocated

Cause: The specified tablespace is already allocated to the spatial table.

Action: Allocate another tablespace name to the table.

ORA-13116 tablespace string is not allocated to table string

Cause: The specified tablespace is not allocated to the specified spatial table.

Action: Allocate the tablespace to the spatial table.

ORA-13117 partition string not found

Cause: The specified partition does not exist.

Action: Verify the name of the partition by checking the Spatial Data option data dictionary.

ORA-13119 source and target tablespaces are identical

Cause: Identical source and target tablespaces were specified when trying to move partition.

Action: Specify different source and target tablespaces if you wish to move a partition.

ORA-13121 failed to create child partition

Cause: The creation of a child partition failed.

Action: Check for other errors that accompany this error and correct them first.

ORA-13122 child partition string not found

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13123 column string is already defined

Cause: The specified column is already defined for the spatial table.

Action: Use a different column name.

ORA-13124 unable to determine column id for column string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13125 partition key is already set

Cause: A partition key is already set for the spatial table.

Action: Only one partition key can be specified per spatial table.

ORA-13126 unable to determine class for spatial table string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13127 failed to generate target partition

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13128 current tiling level exceeds user specified tiling level

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13129 HHCODE column string not found

Cause: The specified spatial column does not exist.

Action: Verify that the specified column is a spatial column by checking the Spatial Data option data dictionary.

ORA-13135 failed to alter spatial table

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13136 null common code generated

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13137 failed to generate tablespace sequence number

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13138 could not determine name of object string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13139 could not obtain column definition for string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13140 invalid target type

Cause: The specified target type is not valid.

Action: Substitute a valid target type. Valid target types are TABLE or VIEW.

ORA-13141 invalid RANGE window definition

Cause: The RANGE window specified is not correctly defined.

Action: A RANGE window is defined by specifying the lower and upper boundary of each dimension as a pair of values (for example, such as: lower_bound1,upper_bound1,lower_bound2,upper_bound2,...). There should be an even number of values.

ORA-13142 invalid PROXIMITY window definition

Cause: The PROXIMITY window specified is not correctly defined.

Action: A PROXIMITY window is defined by specifying a center point and a radius. The center point is defined by ND values. There should be ND+1 values.

ORA-13143 invalid POLYGON window definition

Cause: The POLYGON window specified is not correctly defined.

Action: A POLYGON window is defined by specifying N pairs of values that represent the vertices of the polygon. There should be an even number of values.

ORA-13144 target table string not found

Cause: This is an internal error.

Action: Document messages and contact Oracle Support Services.

ORA-13145 failed to generate range list

Cause: This is an internal error.

Action: Document messages and contact Oracle Support Services.

ORA-13146 could not find table substitution variable string

Cause: The partition name substitution variable string was not found in the SQL filter.

Action: The substitution variable string must be in the SQL filter to indicate where that partition name should be placed.

ORA-13147 failed to generate MBR

Cause: This is an internal error.

Action: Document messages and contact Oracle Support Services.

ORA-13148 failed to generate SQL filter

Cause: This is an internal error.

Action: Document messages and contact Oracle Support Services.

ORA-13149 failed to generate next sequence number for spatial table string

Cause: This is an internal error.

Action: Document messages and contact Oracle Support Services.

ORA-13150 failed to insert exception record

Cause: Operation failed to insert a record into the exception table.

Action: Fix any other errors reported.

ORA-13151 failed to remove exception record

Cause: Operation failed to insert a record into the exception table.

Action: Fix any other errors reported.

ORA-13152 invalid HHCODE type

Cause: The specified HHCODE type is not valid.

Action: Substitute a valid HHCODE type. Valid HHCODE types are POINT and LINE.

ORA-13153 invalid high water mark specified

Cause: The highwater mark must be greater than or equal to zero.

Action: Make sure that the highwater mark is an integer greater than or equal to zero.

ORA-13154 invalid precision specified

Cause: The precision specified is out of range.

Action: The precision must be an integer greater than or equal to zero.

ORA-13155 invalid number of dimensions specified

Cause: The number of dimensions specified is out of range.

Action: The number of dimensions must be between 1 and 32.

ORA-13156 table to be registered string.string is not empty

Cause: The specified table has rows in it.

Action: Make sure that the table to be registered is empty.

ORA-13157 Oracle error ORAstring encountered while string

Cause: The specified Oracle error was encountered.

Action: Correct the Oracle error.

ORA-13158 Oracle object string does not exist

Cause: The specified object does not exist.

Action: Verify that the specified object exists.

ORA-13159 Oracle table string already exists

Cause: The specified table already exists.

Action: Drop the specified table.

ORA-13181 unable to determine length of column string_SDOINDEX.SDO_CODE

Cause: The length of the SDO_CODE column in the layer_SDOINDEX table could not be determined.

Action: Make sure that the layer_SDOINDEX table exists with the SDO_CODE column. Verify that the appropriate privileges exist on the table. Retry the operation.

ORA-13182 failed to read element string.string.string

Cause: The specified element could not be read from the layer_SDOGEOM table.

Action: Verify that the specified element exists in the table. Retry the operation.

ORA-13183 unsupported geometric type for geometry string.string

Cause: The geometry type in the layer_SDOGEOM table is unsupported.

Action: Modify the geometry type to be one of the supported types.

ORA-13184 failed to initialize tessellation package

Cause: Initialization of the tessellation package failed.

Action: Record the error messages that are returned and contact Oracle Support Services.

ORA-13185 failed to generate initial HHCODE

Cause: This is an internal error.

Action: Record the error messages that are returned and contact Oracle Support Services.

ORA-13186 fixed tile size tessellation failed

Cause: This is an internal error.

Action: Record the error messages that are returned and contact Oracle Support Services.

ORA-13187 subdivision failed

Cause: This is an internal error.

Action: Record the error messages that are returned and contact Oracle Support Services.

ORA-13188 cell decode failed

Cause: This is an internal error.

Action: Record the error messages that are returned and contact Oracle Support Services.

ORA-13189 recursive SQL parse failed

Cause: This is an internal error.

Action: Record the error messages that are returned and contact Oracle Support Services.

ORA-13190 recursive SQL fetch failed

Cause: This is an internal error.

Action: Record the error messages that are returned and contact Oracle Support Services.

ORA-13191 failed to read SDO_ORDCNT value

Cause: This is an internal error.

Action: Record the error messages that are returned and contact Oracle Support Services.

ORA-13192 failed to read number of element rows

Cause: This is an internal error.

Action: Record the error messages that are returned and contact Oracle Support Services.

ORA-13193 failed to allocate space for geometry

Cause: There was insufficient memory to read the geometry from the database.

Action: Validate the geometry. Record the error messages that are returned and contact Oracle Support Services.

ORA-13194 failed to decode supercell

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13195 failed to generate maximum tile value

Cause: This is an internal error.

Action: Record the error messages that are returned and contact Oracle Support Services.

ORA-13196 failed to compute supercell for element string.string.string

Cause: The system was unable to compute the minimum bounding HHCODE or supercell for the geometry.

Action: Another error might accompany this error. Correct the accompanying error. Also, validate the geometry for correctness.

ORA-13197 element string.string.string is out of range

Cause: Tessellation did not generate any tiles for this element. This error could be caused if the geometry definition puts the geometry outside the domain defined in the layer_SDODIM table.

Action: Verify that the geometry is valid and within the defined domain.

ORA-13198 Spatial Cartridge error: string

Cause: Internal error in some Spatial Cartridge stored procedure.

Action: Record the sequence of procedure calls or events that preceeded this error and contact Oracle Support Services if the error message text does not clearly specify the cause of the error.

ORA-13199 string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-13200 internal error [string] in spatial indexing.

Cause: This is an internal error.

Action: Contact Oracle Support Services with the exact error text.

ORA-13201 invalid parameters supplied in CREATE INDEX statement

Cause: An error was encountered while trying to parse the parameters clause for the spatial CREATE INDEX statement.

Action: Check the Spatial Cartridge User Guide for the number, syntax, and semantics of expected parameters for spatial index creation.

ORA-13202 failed to create or insert into the SDO_INDEX_METADATA table

Cause: An error was encountered while trying to create the SDO_INDEX_METADATA table or insert data into it.

Action: Verify that the current user has CREATE TABLE privilege and that the user has sufficient quota in the default or specified tablespace.

ORA-13203 failed to read USER_SDO_GEOM_METADATA table

Cause: An error was encountered while trying to read USER_SDO_GEOM_METADATA table.

Action: Check that USER_SDO_GEOM_METADATA has an entry for the current geometry table.

ORA-13204 failed to create spatial index table

Cause: An error was encountered while trying to create the index table.

Action: Check that user has create table privilege in the current schema and that the user has sufficient quota in the default or specified tablespace.

ORA-13205 internal error while parsing spatial parameters

Cause: An internal error was encountered while parsing the spatial parameters.

Action: Check to make sure that the parameters passed in the parameter string are all valid.

ORA-13206 internal error [string] while creating the spatial index

Cause: An internal error was encountered while creating the spatial index.

Action: Contact Oracle Support Services with the exact error text.

ORA-13207 incorrect use of the [string] operator

Cause: An error was encountered while evaluating the specified operator.

Action: Check the parameters and the return type of the specified operator.

ORA-13208 internal error while evaluating [string] operator

Cause: An internal error was encountered.

Action: Contact Oracle Support Services with the exact error text.

ORA-13209 internal error while reading SDO_INDEX_METADATA table

Cause: An internal error was encountered while trying to read SDO_INDEX_METADATA table.

Action: Contact Oracle Support Services. Note this and accompanying error numbers.

ORA-13210 error inserting data into the index table

Cause: An error was encountered while trying to insert data into the index table. Likely causes are:

  • Insufficient quota in the current tablespace
  • User does not appropriate privileges

Action: Check the accompanying error messages.

ORA-13211 failed to tessellate the window object

Cause: An internal error was encountered while trying to tessellate the window object.

Action: Verify the geometric integrity of the window object using the VALIDATE_GEOMETRY procedure.

ORA-13212 failed to compare tile with the window object

Cause: The spatial relationship between a generated tile and the specified window object could not be determined.

Action: This is an internal error. Verify the geometry using the VALIDATE_GEOMETRY procedure. If the procedure does not return any errors, then note any accompanying errors and contact Oracle Support Services.

ORA-13213 failed to generate spatial index for window object

Cause: Another error, indicating the real cause of the problem, should accompany this error.

Action: Correct any accompanying errors. If no accompanying error message appears, then contact Oracle Support Services.

ORA-13214 failed to compute supercell for window object

Cause: The system was unable to compute the minimum bounding tile or supercell for the geometry.

Action: Another error might accompany this error. Correct the accompanying error. Also, validate the geometry for correctness.

ORA-13215 window object is out of range

Cause: Tessellation did not generate any tiles for this geometry. This error could be caused if the geometry definition puts the geometry outside the domain defined in the USER_SDO_GEOM_METADATA view.

Action: Verify that the geometry is valid and within the defined domain.

ORA-13216 failed to update spatial index

Cause: Another error will accompany this message that will indicate the problem.

Action: Correct any accompanying errors. If no accompanying error message appears, then contact Oracle Support Services.

ORA-13217 invalid parameters supplied in ALTER INDEX statement

Cause: An error was encountered while trying to parse the parameters clause for the spatial ALTER INDEX statement.

Action: Check the Oracle Spatial User's Guide and Reference for the number, syntax, and semantics of expected parameters for spatial alter index command.

ORA-13218 max number of supported index tables reached for [string] index

Cause: An add_index parameter is passed to ALTER INDEX when the number of existing index tables is already at maximum.

Action: Delete one of the index tables before adding another index table.

ORA-13219 failed to create spatial index table [string]

Cause: An error was encountered while trying to create the index table.

Action: There is a table in the index's schema with the specified name. The create index will try to create an index table with this name. Either rename this table or change the name of the index.

ORA-13220 failed to compare tile with the geometry

Cause: The spatial relationship between a generated tile and the specified geometry could not be determined.

Action: This is an internal error. Verify the geometry using the VALIDATE_GEOMETRY procedure. If the procedure does not return any errors, then note any errors which accompany ORA-13220 and contact Oracle Support Services.

ORA-13221 unknown geometry type in the geometry object

Cause: The SDO_GTYPE attribute in the geometry object contains an invalid value.

Action: Re-define the geometric type in the geometry table using one of the supported SDO_GTYPE values. See the Oracle Spatial User's Guide and Reference for an explanation of SDO_GTYPE and its possible values.

ORA-13222 failed to compute supercell for geometry in string

Cause: The system was unable to compute the minimum bounding tile or supercell for a geometry in the specified table.

Action: Another error might accompany this error. Correct the accompanying error. Also, validate the geometry for correctness.

ORA-13223 duplicate entry for string in SDO_GEOM_METADATA table

Cause: There are duplicate entries for the given table and column value pair in the SDO_GEOM_METADATA table

Action: Check that the specified table and geometry column names are correct. There should be only one entry per table, geometry column pair in the SDO_GEOME_METADATA table.

ORA-13224 specified index name is too long for a spatial index

Cause: An index name was specified which is longer than the supported length of the spatial index name.

Action: Check the supported size of the index name and reduce the size of the index name.

ORA-13225 specified index table name is too long for a spatial index

Cause: An index table name was specified which is longer than the supported length of the spatial index table name.

Action: Check the supported size of the index table name and reduce the size of the index name.

ORA-13226 interface not supported without a spatial index

Cause: The geometry table does not have a spatial index.

Action: Verify that the geometry table referenced in the spatial operator has a spatial index on it.

ORA-13227 SDO_LEVEL values for the two index tables do not match

Cause: The SDO_LEVEL values for the two index tables used in the spatial join operator do not match.

Action: Verify that two compatible indexes are used for the spatial join operator. Indexes are compatible if they have the same SDO_LEVEL and SDO_NUMTILES values.

ORA-13228 Spatial index create failed due to invalid type

Cause: An Attempt was made to create a spatial index on a column of type other than SDO_GEOMETRY.

Action: Make sure that the index is created on a column of type SDO_GEOMETRY.

ORA-13230 failed to create temporary table [string] during R-tree creation

Cause: The specified temporary table either already exists or there is not enough tablespace.

Action: Delete the table if it already exists and verify if the current user has CREATE TABLE privleges and has sufficient space in the default or specified tablespace.

ORA-13231 failed to create index table [string] during R-tree creation

Cause: The specified index table either already exists or there is not enough tablespace. Otherwise, contact Oracle Support Services.

Action: Delete the table if it already exists and verify if the current user has CREATE TABLE privleges and has sufficient space in the default or specified tablespace.

ORA-13232 failed to allocate memory during R-tree creation

Cause: This feature assumes a minimum of 64 KB memory for bulk creation.

Action: Create the index for a small subset of the data. Then, use transactional inserts for the rest.

ORA-13233 failed to create sequence number [string] for R-tree

Cause: The specified sequence number exists.

Action: Delete the sequence object or contact Oracle Support Services.

ORA-13234 failed to access R-tree-index table [string]

Cause: The index table is either deleted or corrupted.

Action: Rebuild the index or contact Oracle Support Services with accompanying error messages.

ORA-13236 internal error in R-tree processing: [string]

Cause: An internal error occurred in R-tree processing.

Action: Contact Oracle Support Services with message text.

ORA-13237 internal error during R-tree concurrent updates: [string]

Cause: An inconsistency was encountered during concurrent updates possibly due to the use of serializable isolation level.

Action: Change the isolation level to "read committed" using alter session or contact Oracle Support Services with the message text.

ORA-13239 sdo_dimensionality not specified during n-d R-tree creation

Cause: An error occurred in reading the dimensionality parameter.

Action: Check the documentation for a valid range and specify the dimensionality as a parameter.

ORA-13240 specified dimensionality greater than that of the query mbr

Cause: An error occurred because of too few values in query mbr.

Action: Omit the dimensionality or use the dimensionality of the query.

ORA-13241 specified dimensionality does not match that of the data

Cause: An error occurred because the dimensionality specified in the CREATE INDEX does not match that of the data.

Action: Change it to the data dimensionality.

ORA-13242 failed to read tolerance values for n-d R-tree

Cause: An error occurred in reading the information for the specified table and column in USER_SDO_GEOM_METADATA table.

Action: Insert appropriate row specifying the tolerance.

ORA-13243 specified operator is not supported for n-d R-tree: [string]

Cause: Currently, an n-d R-tree only supports sdo_filter operator.

Action: Check the documentation for querytype parameters for sdo_filter or contact Oracle Support Services.

ORA-13249 string

Cause: An internal error was encountered in the extensible spatial index component. The text of the message is obtained from some other server component.

Action: Contact Oracle Support Services with the exact error text.

ORA-13250 insufficient privileges to modify metadata table entries

Cause: The user requesting the operation does not have the appropriate privileges on the referenced tables.

Action: Check that the specified feature and geometry table names are correct and then verify that the current user has at least SELECT privilege on those tables.

ORA-13251 duplicate entry string in metadata table

Cause: The specified entry already exists in the metadata table.

Action: Check that the specified feature and geometry table names are correct. A feature-geometry table association should be registered only once.

ORA-13260 layer table string does not exist

Cause: Data migration source table layer_SDOGEOM does not exist.

Action: Ensure that the specified layername is correct and that the corresponding spatial layer tables exist in the current schema.

ORA-13261 geometry table string does not exist

Cause: The specified geometry table does not exist in the current schema.

Action: Create a table containing a column of type SDO_GEOMETRY and a column of type NUMBER for the GID values.

ORA-13262 geometry column string does not exist in table string

Cause: The specified table does not have a column of type SDO_GEOMETRY.

Action: Alter or recreate the table such that it includes a column of type SDO_GEOMETRY and a column of type NUMBER.

ORA-13263 column string in table string is not of type SDO_GEOMETRY

Cause: The column intended for storing the geometry is not of type SDO_GEOMETRY.

Action: Alter the column definition to be of type SDO_GEOMETRY.

ORA-13264 geometry identifier column string does not exist in table string

Cause: The specified table does not contain a GID column.

Action: Confirm that the GID columnname was correctly specified and that it exists in the specified table.

ORA-13265 geometry identifier column string in table string is not of type NUMBER.

Cause: GID column is not of type NUMBER.

Action: Alter the table definition such that the column containing the geometry identifier (GID) is of type NUMBER.

ORA-13266 error inserting data into table string

Cause: An OCI error occurred or the user has insufficient quota in the active tablespace or the rollback segments are too small.

Action: There should be an accompanying error message that indicates the cause of the problem. Take appropriate action to correct the indicated problem.

ORA-13267 error reading data from layer table string

Cause: There was an error reading the geometry data from the layer_SDOGEOM table.

Action: Verify that layer_SDOGEOM and layer_SDODIM exist. If they do exist, then run VALIDATE_GEOMETRY on the specified layer.

ORA-13268 error obtaining dimension from USER_SDO_GEOM_METADATA

Cause: There is no entry in USER_SDO_GEOM_METADATA for the specified geometry table.

Action: Insert an entry for the destination geometry table with the dimension information obtained from the source layer_SDODIM table.

ORA-13269 internal error [string] encountered when processing geometry table

Cause: An internal error occurred.

Action: Contact Oracle Support Services with the exact error message text.

ORA-13270 OCI error string

Cause: An OCI error occurred while processing the layer or geometry tables.

Action: Take the appropriate steps to correct the OCI specific error.

ORA-13271 error allocating memory for geometry object

Cause: Insufficient memory.

Action: Make more memory available to the current session/process.

ORA-13272 geometric object string in table string is invalid

Cause: The specified object failed the geometric integrity checks performed by VALIDATE_GEOMETRY.

Action: Consult the Oracle Spatial User's Guide and Reference for information on the geometric integrity checks performed by VALIDATE_GEOMETRY and correct the geometry definition if required.

ORA-13273 dimension metadata table string does not exist

Cause: The layer_SDODIM table does not exist.

Action: Verify that the specified layer name is correct and that the layer_SDODIM table exists in the current schema.

ORA-13274 Operator invoked with non compatible SRIDs

Cause: A Spatial operator was invoked with a window geometry with an SRID and the layer without an SRID or window has no SRID and the layer has an SRID.

Action: Make sure that the layer and window both have an SRID or they both do not have an SRID.

ORA-13275 Spatial index creation failure on unsupported type

Cause: A spatial index create was invoked on a column that is not of type SDO_GEOMETRY.

Action: Spatial index can only be created on a column of type SDO_GEOMETRY. Make sure the indexed column has SDO_GEOMETRY type.

ORA-13276 internal error [string] in coordinate transformation

Cause: OCI internal error.

Action: Contact Oracle Support Services with the exact error message text.

ORA-13278 failure to convert SRID to native format

Cause: OCI internal error.

Action: Contact Oracle Support Services with the exact error message text.

ORA-13281 failure in execution of sql statement to retrieve WKT

Cause: OCI internal error or SRID does not match a table entry.

Action: Check that a valid SRID is being used.

ORA-13282 failure on initialization of coordinate transformation

Cause: Parsing error on source or destination coordinate system WKT or incompatible coordinate systems.

Action: Check validity of WKT for table entries and the legitimacy of the requested transformation.

ORA-13283 failure to get new geometry object for conversion in place

Cause: OCI internal error.

Action: Contact Oracle Support Services with the exact error message text.

ORA-13284 failure to copy geometry object for conversion in place

Cause: OCI internal error.

Action: Contact Oracle Support Services with the exact error message text.

ORA-13285 Geometry coordinate transformation error

Cause: A coordinate pair was out of valid range for a conversion/projection.

Action: Check that data to be transformed is consistent with the desired conversion/projection.

ORA-13287 can't transform unknown gtype

Cause: A geometry with a gtype of <= 0 was specified for transformation. Only a gtype >= 1 is allowed.

Action:

ORA-13288 Point coordinate transformation error

Cause: An internal error while transforming points.

Action: Check the accompanying error messages.

ORA-13290 The specified unit is not supported

Cause: Spatial function called with an unknown UNIT.

Action: Check the supported units by Spatial and call the spatial function with the correct UNIT parameter.

ORA-13291 Conversion error between the specified unit and standard unit

Cause: Cannot convert the specified unit from/to standard unit for linear distance, angle, or area.

Action: Check unit specification and respecify it.

ORA-13292 Incorrect ARC_TOLERANCE specification

Cause: When a SDO_BUFFER or SDO_AGGR_BUFFER function is called on a Geodetic geometry, or SDO_ARC_DENSIFY is called, ARC_TOLERANCE must be specified and it should not be less than the tolerance specified for the geometry.

Action: Check ARC_TOLERANCE specification and make sure it is correct.

ORA-13293 Cannot specify unit for geometry without a georeferenced SRID

Cause: A Spatial function with unit parameter is called on a geometry without a georeferenced SRID.

Action: Make sure that spatial functions with UNIT parameters are only called on geometries with georeferenced SRIDs.

ORA-13294 Cannot transform geometry containing circular arcs

Cause: It is impossible to transform a 3-point representation of a circular arc without distortion.

Action: Make sure a geometry does not contain circular arcs.

ORA-13295 Geometry objects are in different coordinate systems

Cause: A Spatial function is called with two geometries with two different SRIDs.

Action: Transform geometry objects to be in the same coordinate system and call the spatial function.

ORA-13296 Incorrect Coordinate System Specification

Cause: Wrong numbers in WKT for Earth radius or flattening for the current SRID.

Action: Check WKT in CS_SRS table for Earth radius and inverse flattening.

ORA-13300 Single point transform error

Cause: Low level coordinate transformation error trap.

Action: Check the accompanying error messages.

ORA-13303 failure to retrieve a geometry object from a table

Cause: OCI internal error.

Action: Contact Oracle Support Services with the exact error message text.

ORA-13304 failure to insert a transformed geometry object in a table

Cause: OCI internal error.

Action: Contact Oracle Support Services with the exact error message text.

ORA-13330 invalid MASK

Cause: The MASK you passed to RELATE function is not valid.

Action: Verify that the mask is not NULL. See the Oracle Spatial User's Guide and Reference for a list of supported masks.

ORA-13331 invalid LRS segment

Cause: The given LRS segment was not a valid linestring.

Action: A valid LRS geometric segment is a line string geometry in Oracle Spatial. It could be a simple or compound line string (made of lines or arcs, or both). The dimension information must include the measure dimension as the last element in Oracle Spatial metadata. Currently, the number of dimensions for an LRS segment must be greater than 2 (x/y or latitude/longitude plus measure).

ORA-13332 invalid LRS point

Cause: Given LRS point was not a point-geometry with measure information.

Action: Check the given point geometry.A valid LRS point is a point geometry in Oracle Spatial with additional measure dimension.

ORA-13333 invalid LRS measure

Cause: The given measure for linear referencing was out of range.

Action: Re-define the given measure.

ORA-13334 LRS segments not connected

Cause: The given geometric segments were not connected.

Action: Check the start/end points of the given geometric segments.

ORA-13335 LRS measure information not defined

Cause: The measure information of a given geometric segments was not assigned (IS NULL).

Action: Assign/define the measure information. An LRS geometric segment is defined if its start and end measure are assigned (non-null).

ORA-13336 Failure in converting standard diminfo/geometry to LRS dim/geom

Cause: No room for measure dimension in the given diminfo or the given standard geometry is not a point a linestring.

Action: Check if the diminfo dimensions are less than 3 or given geometry type is point or linestring.

ORA-13337 failure in concatenating LRS polygons

Cause: LRS concatenation involving LRS polygons is not supported.

Action: Check geometry and element type to make sure the concatenate operation is not called with a polygon type.

ORA-13338 failure in reversing LRS polygon/collection geometry

Cause: Reversing an LRS polygon/collection geometry produces an invalid geometry as this operation is not well defined for polygon geometry.

Action: Check the geometry type to make sure this operation is called on non polygon type geometry.

ORA-13339 LRS Polygon clipping across multiple rings

Cause: Clipping (dynseg) a polygon across multiple rings.

Action: Polygon clipping only allowed for a single ring.

ORA-13340 a point geometry has more than one coordinate

Cause: A geometry, specified as being a point, has more than one coordinate in its definition.

Action: A point has only one coordinate. If this geometry is intended to represent a point cluster, line, or polygon, then set the appropriate SDO_GTYPE or SDO_ETYPE value. If this is a single point object, then remove the extraneous coordinates from its definition.

ORA-13341 a line geometry has less than two coordinates

Cause: A geometry, specified as being a line, has less than two coordinates in its definition.

Action: A line must consist of at least two distinct coordinates. Correct the geometric definition or set the appropriate SDO_GTYPE or SDO_ETYPE attribute for this geometry.

ORA-13342 an arc geometry has less than three coordinates

Cause: A geometry, specified as being an arc, has less than three coordinates in its definition.

Action: An arc must consist of at least three distinct coordinates. Correct the geometric definition or set the appropriate SDO_GTYPE or SDO_ETYPE attribute for this geometry.

ORA-13343 a polygon geometry has less than four coordinates

Cause: A geometry, specified as being a polygon, has less than four coordinates in its definition.

Action: A polygon must consist of at least four distinct coordinates. Correct the geometric definition or set the appropriate SDO_GTYPE or SDO_ETYPE attribute for this geometry.

ORA-13344 an arcpolygon geometry has less than five coordinates

Cause: A geometry, specified as being an arcpolygon, has less than six coordinates in its definition.

Action: An arcpolygon must consist of at least five coordinates. An arcpolygon consists of an ordered sequence of arcs, each of which must be described using three coordinates. Since arcs are connected, the end-point of the first is the start of the second and does not have to be repeated. Correct the geometric definition or set the appropriate SDO_GTYPE or SDO_ETYPE attribute for this geometry.

ORA-13345 a compound polygon geometry has less than five coordinates

Cause: A geometry, specified as being a compound polygon, has less than five coordinates in its definition.

Action: A compound polygon must contain at least five coordinates. A compound polygon consists of at least one arc and one line, each of which must be described using three and at least two distinct coordinates, respectively. Correct the geometric definition or set the appropriate SDO_GTYPE or SDO_ETYPE attribute for this geometry.

ORA-13346 the coordinates defining an arc are collinear

Cause: Invalid definition of an arc. An arc is defined using three non-collinear coordinates.

Action: Alter the definition or the arc or set the SDO_ETYPE or SDO_GTYPE to the line type.

ORA-13347 the coordinates defining an arc are not distinct

Cause: Two or more of the three points defining an arc are the same.

Action: Alter the definition of the arc, ensuring that three distinct coordinate values are used.

ORA-13348 polygon boundary is not closed

Cause: The boundary of a polygon does not close.

Action: Alter the coordinate values or the definition of the SDO_GTYPE or SDO_ETYPE attribute of the geometry.

ORA-13349 polygon boundary crosses itself

Cause: The boundary of a polygon intersects itself.

Action: Correct the geometric definition of the object.

ORA-13350 two or more rings of a complex polygon touch

Cause: The inner or outer rings of a complex polygon touch.

Action: All rings of a complex polygon must be disjoint. Correct the geometric description of the object.

ORA-13351 two or more rings of a complex polygon overlap

Cause: The inner or outer rings of a complex polygon overlap.

Action: All rings of a complex polygon must be disjoint. Correct the geometric description of the object.

ORA-13352 the coordinates do not describe a circle

Cause: The set of coordinates used to describe a circle are incorrect.

Action: Confirm that the set of coordinates actually represent points on the circumference of a circle.

ORA-13353 ELEM_INFO_ARRAY not grouped in threes

Cause: The ELEM_INFO_ARRAY in SDO_GEOMETRY has more or fewer elements than expected.

Action: Confirm that the number of elements in ELEM_INFO_ARRAY is divisible by 3.

ORA-13354 incorrect offset in ELEM_INFO_ARRAY

Cause: The offset field in ELEM_INFO_ARRAY of SDO_GEOMETRY references an invalid array subscript in SDO_ORDINATE_ARRAY.

Action: Confirm that the offset is a valid array subscript in SDO_ORDINATE_ARRAY.

ORA-13355 SDO_ORDINATE_ARRAY not grouped by number of dimensions specified

Cause: The number of elements in SDO_ORDINATE_ARRAY is not a multiple of the number of dimensions supplied by the user.

Action: Confirm that the number of dimensions is consistent with data representation in SDO_ORDINATE_ARRAY.

ORA-13356 adjacent points in a geometry are redundant

Cause: There are repeated points in the sequence of coordinates.

Action: Remove the redundant point.

ORA-13357 extent type does not contain 2 points

Cause: Extent type should be represented by 2 points: lower left and upper right.

Action: Confirm that there are only 2 points for extent type.

ORA-13358 circle type does not contain 3 points

Cause: Circle type should be represented by 3 distinct points on the circumference.

Action: Confirm that there are only 3 points for circle type.

ORA-13359 extent does not have an area

Cause: The 2 points representing the extent are identical.

Action: Confirm that the 2 points describing the extent type are distinct.

ORA-13360 invalid subtype in a compound type

Cause: This subtype is not allowed within the ETYPE specified.

Action: Refer to Oracle Spatial User's Guide and Reference for type definitions.

ORA-13361 not enough sub-elements within a compound ETYPE

Cause: The compound type declare more sub-elements than actually defined.

Action: Confirm that the number of sub-elements is consistent with the compound type declaration.

ORA-13362 disjoint sub-element in a compound polygon

Cause: Compound polygon must describe an enclosed area.

Action: Confirm that all sub-elements are connected.

ORA-13363 no valid ETYPE in the geometry

Cause: None of the ETYPEs within the geometry is supported.

Action: Confirm that there is at least one valid ETYPE.

ORA-13364 Layer Dimensionality does not match geometry dimensions

Cause: Spatial layer has a geometry with a different dimensions than the dimensions specified for the layer.

Action: Make sure that all geometries in a layer have the same dimensions and they match the dimensions in the SDO_DIM_ARRAY object for the layer in USER_SDO_GEOM_METADATA.

ORA-13365 Layer SRID does not match geometry SRID

Cause: Spatial layer has a geometry with a different SRID than the SRID specified for the layer.

Action: Make sure that all geometries in a layer have the same SRID and the SRIDs match the SRID in USER_SDO_GEOM_METADATA for the layer.

ORA-13366 Invalid combination of interior exterior rings

Cause: In the Spatial geometry, interior and exterior rings are not used consistently.

Action: Make sure that the interior rings corresponding to an exterior ring follow the exterior ring in the ordinate array.

ORA-13367 Wrong orientation for interior/exterior rings

Cause: In a spatial geometry, the exterior and/or interior rings are not oriented correctly.

Action: The exterior rings should be oriented counter clock-wise and interior rings should be oriented clock wise.

ORA-13368 Simple Polygon type has more than one exterior ring

Cause: In a polygon type geometry, there is more than one exterior ring.

Action: Set the type to be multi-polygon if more than one exterior is present in the geometry.

ORA-13369 Invalid value for etype in the 4 digit format

Cause: A 4 digit etype for non polygon type element is used or the orientation is not a valid orientation for interior/exterior rings of the polygon.

ORA-13370 failure in applying 3D LRS functions

Cause: Only Non-geodetic 3D linestring geometry (made of line segments) are supported for 3D LRS package.

Action: Check the geometry and element types and SRID.

ORA-13371 invalid position of measure dimension

Cause: LRS measure dimension has to be after spatial dimensions. The position has to be either 3rd or 4th in dim_info_array.

Action: Check geometry gtype and its dim_info_array.

ORA-13372 failure in modifying metadata for a table with spatial index

Cause: Modifying the metadata after the index is created will cause inconsistency between geometry gtype and diminfo.

Action: Modify(or Prepare) metadata before creating index on sdo_geometry column.

ORA-13373 Element of type Extent is not supported for Geodetic data

Cause: Element type extent for a polygon geometry is not supported for geodetic data.

Action: Convert the extent type polygon to a regular 5 point polygon and set etype accordingly.

ORA-13374 SDO_MBR not supported for geodetic data

Cause: The SDO_MBR functionality is not supported for geodetic data.

Action: Find an alternative function that can be used in this context.

ORA-13375 The layer is of type [string] while geometry inserted has type [string]

Cause: The layer has a type that is different or inconsistent with the type of the current geometry.

Action: Change the geometry type to agree with the layer type or change the layer type to agree with the geometry type.

ORA-13376 Invalid type name specified for layer_gtype parameter

Cause: An invalid type name is specified for the layer gtype constraint.

Action: Consult the Oracle Spatial User's Guide and Reference to get a list of valid layer gtypes that can be used in defining a layer gtype constraint.

ORA-13377 Invalid combination of elements with orientation

Cause: An element of the geometry has orientation specified while some other element has no orientation specified (4 digit etype).

Action: Make sure all the polygon elements have orientation specified using the 4 digit etype notation.

ORA-13378 Invalid index for element to be extracted

Cause: An invalid (or out of bounds) index was specified for extracting an element from a geometry.

Action: Make sure the parameters to the extract function are in the valid range for the given geometry.

ORA-13379 Invalid index for sub-element to be extracted

Cause: An invalid (or out of bounds) index was specified for extracting a sub-element from a geometry.

Action: Make sure the parameters to the extract function are in the valid range for the given geometry.

ORA-13400 Oracle GeoImage internal error, arguments: [string], [string], [string], [string], [string]

Cause: This is an internal Oracle GeoImage error.

Action: Contact Oracle Support Services.

ORA-13401 unsupported geoimage format

Cause: The GeoImage format is not supported.

Action: Confirm that the GeoImage format is valid and supported.

ORA-13402 NULL destination

Cause: The object specified as the destination is NULL.

Action: Confirm that the object specified as the destination is not NULL.

ORA-13403 NULL source geometry

Cause: The source GeoImage has a NULL geometry.

Action: Verify that the geometry of the source GeoImage is not NULL.

ORA-13404 not a local source

Cause: An attempt has been made to modify a GeoImage which is not stored in the database.

Action: Import the GeoImage in order to modify it.

ORA-13405 NULL source

Cause: The object specified as the source is NULL.

Action: Confirm that the object specified as the source is not NULL.

ORA-13406 unsupported image processing command [string]

Cause: The image processing command specified is not supported for a GeoImage.

Action: Consult the Oracle interMedia User's Guide and Reference to verify which image processing commands are supported within an Oracle GeoImage method.

ORA-13407 unrecognized space type qualifier [string]

Cause: The GeoImage space type qualifier is invalid.

Action: Use a valid space type qualifier (RASTER or MODEL).

ORA-13408 NULL table name

Cause: The table name parameter is NULL.

Action: Verify that the parameter used for the table name is not NULL.

ORA-13409 Oracle table "string" does not exist.

Cause: The table specified does not exist.

Action: Verify that the table name used is valid and the table exists.

ORA-13410 NULL column name

Cause: The column name parameter is NULL.

Action: Verify that the parameter used for the column name is not NULL.

ORA-13411 Oracle column "string" does not exist.

Cause: The column specified does not exist.

Action: Verify that the column name used is valid and the column exists.

ORA-13412 invalid ROWID

Cause: The ROWID value used is not valid.

Action: Verify that the ROWID value used is valid.

ORA-13413 could not select the GeoImage for initialization

Cause: The GeoImage in the table could not be selected.

Action: Verify that the GeoIMage is present in the table and the supplied parameters are valid.

ORA-13414 could not update the table containing the GeoImage

Cause: The table containing the GeoImage could not be updated.

Action: Verify that the table exists and is valid.

ORA-13415 invalid domain

Cause: The SDO_DIMINFO value used is not valid or the SDO_GEOMETRY supplied is not defined in the domain.

Action: Verify that the SDO_DIMINFO value is valid, and that the SDO_GEOMETRY is defined within the domain specified.

ORA-13416 invalid geometry, arguments [string]

Cause: The SDO_GEOMETRY value used is not valid.

Action: Verify that the SDO_GEOMETRY is valid. Consult the Oracle Spatial User's Guide and Reference for a list of valid geometries.

ORA-13417 undefined raster to model space transformation

Cause: The raster to model space transformation associated with a GeoImage is undefined.

Action: Verify that the GeoImage format is valid and that the particular operation is supported for that format.

ORA-13418 undefined model to raster space transformation

Cause: The model to raster space transformation associated with a GeoImage is undefined.

Action: Verify that the GeoImage format is valid and that the particular operation is supported for that format.

ORA-13419 invalid latitude value

Cause: A latitude value outside the valid range [-90,90] has been used.

Action: Verify that the GeoImage geometry definition is within the domain.

ORA-13420 invalid model to raster space transformation

Cause: The model to raster space transformation associated with a GeoImage is not valid or cannot be calculated.

Action: Verify that the transformation is supported and that the GeoImage format is valid.

ORA-13421 invalid raster to model space transformation

Cause: The raster to model space transformation associated with a GeoImage is not valid or cannot be calculated.

Action: Verify that the transformation is supported and that the GeoImage format is valid.

ORA-13422 uninitialized source

Cause: The LOB used for the source is not initialized.

Action: Verify that the source is properly initialized.

ORA-13423 empty source

Cause: The LOB used for the source is empty.

Action: Verify that the source is properly initialized and data has been imported into it.

ORA-13424 uninitialized destination

Cause: The LOB used for the destination is not initialized.

Action: Verify that the destination is properly initialized.

ORA-13425 empty destination

Cause: The LOB used for the destination is empty.

Action: Verify that the destination is properly initialized and data has been imported into it.

ORA-13426 unsupported raster origin

Cause: The raster origin specified is not supported.

Action: Verify that the origin specified is supported.

ORA-13427 unknown raster origin

Cause: The value specified for the raster origin is invalid.

Action: Verify that the value used to specify the raster origin is valid and supported.

ORA-13428 source does not exist

Cause: The source does not exist or cannot be accessed.

Action: Verify that the source specification is correct and accessible.

ORA-13429 operation "string" not supported on GeoImage type "string"

Cause: The specified operation is not supported on the particular geoimage type.

Action: Verify that the operation is supported.

ORA-13430 model coordinate system not supported

Cause: The model specified for the definition of the coordinate system is not supported.

Action: Verify that the model value is correct.

ORA-13433 NULL crop geometry

Cause: The geometry used to crop a GeoImage is NULL.

Action: Verify that the geometry used for the crop operation is not NULL.

ORA-13442 invalid scaling parameters [string] [string]

Cause: The parameters used in the scale operation are invalid.

Action: Verify that the scaling parameters are greater than zero.

ORA-13443 unrecognized scale mode [string]

Cause: The scale mode used in the scale operation is invalid.

Action: Consult the Oracle interMedia User's Guide and Reference for a list of valid scale mode qualifiers.

ORA-13451 unsupported conversion format [string]

Cause: The format specified for conversion is invalid or unsupported.

Action: Verify that the conversion format specified is valid.

ORA-13461 invalid tag/key [string]

Cause: The tag or key is invalid.

Action: Verify that the format version is supported or the format is valid.

ORA-13462 invalid tie point

Cause: One of the tie points is invalid.

Action: Verify that the tie points used are valid (for example all raster tie points are >= 0).

ORA-13463 unsupported GeoTIFF geometry definition

Cause: The combination of keys/tags used to define the geometry footprint of the GeoImage is not supported.

Action: Verify that the GeoTIFF format version is supported and the format is valid.

ORA-13464 unsupported conversion

Cause: The format specified for conversion is not supported. In GeoTIFF, only a limited number of tags/keys combinations are supported for conversion.

Action: Verify that the GeoTIFF format version is supported and conversion to the desired format is available.

ORA-13465 invalid destination window

Cause: The window specified as destination in the command is not valid.

Action: Verify that the window definition is correct.

ORA-14000 only one LOCAL clause may be specified

Cause: CREATE INDEX statement contained more than one LOCAL clause.

Action: Specify LOCAL option at most once.

ORA-14001 LOCAL clause contradicts previosly specified GLOBAL clause

Cause: CREATE INDEX statement contained a GLOBAL clause and a LOCAL clause.

Action: Specify LOCAL or GLOBAL clause, but not both.

ORA-14002 only one GLOBAL clause may be specified

Cause: CREATE INDEX statement contained more than one GLOBAL clause.

Action: Specify GLOBAL option at most once.

ORA-14003 GLOBAL clause contradicts previosly specified LOCAL clause

Cause: CREATE INDEX statement contained a LOCAL clause and a GLOBAL clause.

Action: Specify GLOBAL or LOCAL clause, but not both.

ORA-14004 missing PARTITION keyword

Cause: Keyword PARTITION missing.

Action: Supply missing keyword.

ORA-14005 missing RANGE keyword

Cause: Keyword RANGE missing.

Action: Supply missing keyword.

ORA-14006 invalid partition name

Cause: A partition name of the form identifier is expected but not present.

Action: Enter an appropriate partition name.

ORA-14007 missing LESS keyword

Cause: Keyword LESS missing.

Action: Supply missing keyword.

ORA-14008 missing THAN keyword

Cause: Keyword THAN missing.

Action: Supply missing keyword.

ORA-14009 partition bound may not be specified for a LOCAL index partition

Cause: While parsing a CREATE INDEX statement to create a LOCAL partitioned index, partition_description of one of partitions was found to contain VALUES LESS THAN clause which is illegal since a LOCAL index inherits partition bounds from its base table.

Action: Remove all VALUES LESS THAN clauses from descriptions of LOCAL index partitions.

ORA-14010 this physical attribute may not be specified for an index partition

Cause: Unexpected option was encountered while parsing physical attributes of an index partition; valid options for range or composite range partitions are INITRANS, MAXTRANS, TABLESPACE, STORAGE, PCTFREE; only TABLESPACE may be specified for hash partitions.

Action: Remove invalid option(s) from the list of physical attributes of an index partition.

ORA-14011 names assigned to resulting partitions must be distinct

Cause: Names of partitions resulting from splitting of an existing table or index partition are not distinct.

Action: Rename resulting partition(s) to ensure that their names are distinct and different from those of any other partition of the table or index.

ORA-14012 resulting partition name conflicts with that of an existing partition

Cause: Name of a partition resulting from splitting of an existing table or index partition is identical to that of some other existing partition of that table or index.

Action: Rename resulting partition(s) to ensure that their names are distinct and different from those of any other partition of the table or index.

ORA-14013 duplicate partition name

Cause: Name of a partition of a table or index being created is not unique.

Action: Rename partition(s) to ensure that their names are unique among partitions of the table or index being created.

ORA-14014 maximum number of partitioning columns is 16

Cause: Number of columns in a partitioning column list exceeded the legal limit of 16.

Action: Modify partitioning column list so that it consists of at most 16 columns.

ORA-14015 too many partition descriptions

Cause: CREATE TABLE or CREATE INDEX contained too many partition descriptions; maximum number of partitions is 65535.

Action: Reduce the number of partitions to not exceed 65535.

ORA-14016 underlying table of a LOCAL partitioned index must be partitioned

Cause: An attempt was made to create a LOCAL partitioned index on a non-partitioned table which is illegal. Only GLOBAL indices (partitioned or otherwise) may be created on a non-partitioned table.

Action: Correct the statement and re-enter it.

ORA-14017 partition bound list contains too many elements

Cause: Partition bound list contained more elements than there are partitioning columns.

Action: Ensure that the number of elements in partition bound list is equal to the number of partitioning columns of the table or index.

ORA-14018 partition bound list contains too few elements

Cause: Partition bound list contained fewer elements than there are partitioning columns.

Action: Ensure that the number of elements in partition bound list is equal to the number of partitioning columns of the table or index.

ORA-14019 partition bound element must be one of: string, datetime or interval literal, number, or MAXVALUE

Cause: Partition bound list contained an element of invalid type (that is, not a number, non-empty string, datetime or interval literal, or MAXVALUE).

Action: Ensure that all elements of partition bound list are of valid type.

ORA-14020 this physical attribute may not be specified for a table partition

Cause: Unexpected option was encountered while parsing physical attributes of a table partition; valid options for range or composite range partitions are INITRANS, MAXTRANS, TABLESPACE, STORAGE, PCTFREE, and PCTUSED; only TABLESPACE may be specified for hash partitions.

Action: Remove invalid option(s) from the list of physical attributes of a table partition.

ORA-14021 MAXVALUE must be specified for all columns

Cause: In the VALUES LESS THAN clause for the highest (last) partition of a GLOBAL index, MAXVALUE must be specified for all columns.

Action: Ensure that VALUES LESS THAN clause for the last partition of a GLOBAL index has MAXVALUE specified for all columns.

ORA-14022 creation of LOCAL partitioned cluster indices is not supported

Cause: An attempt was made to create a LOCAL partitioned cluster index, which is currently illegal.

Action: Remove LOCAL along with partition_descriptions, if any, from the CREATE INDEX statement.

ORA-14023 creation of GLOBAL partitioned cluster indices is not supported

Cause: An attempt was made to create a GLOBAL partitioned cluster index, which is currently illegal.

Action: Remove PARTITION BY RANGE clause along with partition_descriptions from the CREATE INDEX statement.

ORA-14024 number of partitions of LOCAL index must equal that of the underlying table

Cause: An attempt was made to create a LOCAL partitioned index with a number of partitions which is different from that of the underlying table.

Action: Correct the CREATE INDEX statement to specify a correct number of partitions.

ORA-14025 PARTITION may not be specified for a materialized view or a materialized view log

Cause: PARTITION option was encountered while parsing a definition of a materialized view or a materialized view log.

Action: Ensure that a definition of a MATERIALIZED VIEW does not include invalid options.

ORA-14026 PARTITION and CLUSTER clauses are mutually exclusive

Cause: Definition of a table contained both PARTITION and CLUSTER clauses which is illegal.

Action: Remove one of the conflicting clauses.

ORA-14027 only one PARTITION clause may be specified

Cause: CREATE TABLE statement contained more than one PARTITION clause.

Action: Specify PARTITION option at most once.

ORA-14028 missing AT or VALUES keyword

Cause: Keyword AT or VALUES is missing.

Action: Supply missing keyword.

ORA-14029 GLOBAL partitioned index must be prefixed

Cause: The partitioning columns of a global partitioned index did not contain a prefix of the index's key columns.

Action: Ensure that the GLOBAL partitioned index being created is prefixed and retry the operation.

ORA-14030 non-existent partitioning column in CREATE TABLE statement

Cause: Partitioning column specified in CREATE TABLE statement is not one of columns of the table being created.

Action: Ensure that all columns in the partitioning column list are columns of the table being created.

ORA-14031 partitioning column may not be of type LONG or LONG RAW

Cause: Partitioning column specified by the user was of type LONG or LONG RAW, which is illegal.

Action: Ensure that no partitioning column is of type LONG or LONG RAW.

ORA-14032 partition bound of partition number string is too high

Cause: High bound of the partition whose number (partitions are numbered starting with 1) is displayed in this message did not collate lower than that of the following partition, which is illegal.

Action: Ensure that high bound of every partition (except for the last one) collates lower than that of a following partition.

ORA-14036 partition bound value too large for column

Cause: Length of partition bound value is longer than that of the corresponding partitioning column.

Action: Ensure that lengths of high bound values do not exceed those of corresponding partitioning columns.

ORA-14037 partition bound of partition "string" is too high

Cause: High bound of the partition whose name (explicitly specified by the user) is displayed in this message did not collate lower than that of the following partition, which is illegal.

Action: Ensure that high bound of every partition (except for the last one) collates lower than that of a following partition.

ORA-14038 GLOBAL partitioned index must be prefixed

Cause: An attempt was made to create a GLOBAL non-prefixed partitioned index which is illegal.

Action: If a non-prefixed index is desired, it must be created as LOCAL; otherwise, correct the list of key and/or partitioning columns to ensure that the index is prefixed. Then retry the operation.

ORA-14039 partitioning columns must form a subset of key columns of a UNIQUE index

Cause: An attempt was made to create a UNIQUE partitioned index whose partitioning columns do not form a subset of its key columns which is illegal.

Action: If you want to create an index whose partitioning columns do not form a subset of its key columns, it must be created as non-UNIQUE; otherwise, correct the list of key and/or partitioning columns to ensure that the index's partitioning columns form a subset of its key columns.

ORA-14041 partition bound may not be specified for resulting partitions

Cause: While parsing an ALTER {TABLE|INDEX} SPLIT PARTITION statement, partition_description of a resulting partition was found to contain VALUES LESS THAN clause which is illegal.

Action: Remove VALUES LESS THAN clause from the description(s) of partitions resulting from splitting an existing table or index partition.

ORA-14042 partition bound may not be specified for a partition being moved, modified or rebuilt

Cause: While parsing an ALTER {TABLE|INDEX} MODIFY PARTITION, ALTER TABLE MOVE PARTITION, or ALTER INDEX REBUILD PARTITION statement, description of new physical attributes of the partition being moved, modified, or rebuilt was found to contain VALUES LESS THAN clause which is illegal.

Action: Remove VALUES LESS THAN clause from the description of new attributes of the partition being moved, modified, or rebuilt.

ORA-14043 only one partition may be added

Cause: ALTER TABLE ADD PARTITION contained descriptions of more than one partition to be added.

Action: Ensure that the statement contains exactly one partition definition and that it does not contain any commas.

ORA-14044 only one partition may be moved

Cause: ALTER TABLE MOVE PARTITION contained descriptions of more than one partition to be moved.

Action: Ensure that the statement describes exactly one partition to be moved and that it does not contain any commas.

ORA-14045 only one partition may be modified

Cause: ALTER TABLE|INDEX MODIFY PARTITION contained descriptions of more than one partition to be modified.

Action: Ensure that the statement describes exactly one partition to be modified and that it does not contain any commas.

ORA-14046 a partition may be split into exactly two new partitions

Cause: ALTER TABLE|INDEX SPLIT PARTITION did not contain descriptions of exactly two new partitions into which an existing table or index partition was to be split.

Action: Ensure that the statement describes exactly two partition into which an existing partition is to be split.

ORA-14047 ALTER TABLE|INDEX RENAME may not be combined with other operations

Cause: ALTER TABLE or ALTER INDEX statement attempted to combine a RENAME operation with some other operation which is illegal.

Action: Ensure that RENAME operation is the sole operation specified in ALTER TABLE or ALTER INDEX statement.

ORA-14048 a partition maintenance operation may not be combined with other operations

Cause: The ALTER TABLE or ALTER INDEX statement attempted to combine a partition maintenance operation (for example, MOVE PARTITION) with some other operation (for example, ADD PARTITION or PCTFREE) which is illegal.

Action: Ensure that a partition maintenance operation is the sole operation specified in an ALTER TABLE or ALTER INDEX statement; operations other than those dealing with partitions, default attributes of partitioned tables/indices, or specifying that a table be renamed (ALTER TABLE RENAME) can be combined.

ORA-14049 invalid ALTER TABLE MODIFY PARTITION option

Cause: An option other than PCTFREE, PCTUSED, INITRANS, MAXTRANS, STORAGE, BACKUP, ALLOCATE EXTENT, or DEALLOCATE UNUSED was specified in an ALTER TABLE MODIFY PARTITION statement for a range or composite range partition.

Action: Specify only legal options.

ORA-14050 invalid ALTER INDEX MODIFY PARTITION option

Cause: An option other than INITRANS, MAXTRANS, STORAGE, or DEALLOCATE UNUSED was specified in an ALTER INDEX MODIFY PARTITION statement.

Action: Specify only legal options.

ORA-14051 invalid ALTER MATERIALIZED VIEW option

Cause: An option other than PCTFREE, PCTUSED, INITRANS, MAXTRANS, STORAGE, or BACKUP was specified in an ALTER MATERIALIZED VIEW statement.

Action: Specify only legal options.

ORA-14052 partition-extended table name syntax is disallowed in this context

Cause: An attempt was made to use partition-extended table name syntax in illegal context (that is, not in FROM-clause or INSERT, DELETE, or UPDATE statement).

Action: Avoid use of partition-extended table name in contexts other those mentioned above.

ORA-14053 illegal attempt to modify string in string statement

Cause: Certain attributes of objects (for example, tables) may be specified at creation time, but may not be modified using ALTER statement. Unfortunately, user specified one of such attributes.

Action: Ensure that ALTER statement specifies new values only for attributes which may be changed once an object has been created.

ORA-14054 invalid ALTER TABLE TRUNCATE PARTITION option

Cause: Name of the partition to be truncated may be followed by DROP STORAGE or REUSE STORAGE.

Action: Ensure that no options besides DROP STORAGE or REUSE STORAGE are specified with ALTER TABLE TRUNCATE PARTITION.

ORA-14055 keyword REBUILD in ALTER INDEX REBUILD must immediately follow index_name

Cause: ALTER INDEX statement contained REBUILD keyword following some index attributes (for example, INITRANS).

Action: Ensure that keyword REBUILD immediately follows the name of the index being altered.

ORA-14056 partition number string: sum of PCTUSED and PCTFREE may not exceed 100

Cause: The sum of PCTUSED and PCTFREE for a partition whose number (partitions are numbered starting with 1) is displayed in this message exceeds 100. Note that if PCTUSED and/or PCTFREE values for this partition were not specified explicitly, default values for the partitioned table or index would be used. If, in turn, default PCTUSED and/or PCTFREE values for the partitioned table or index were not specified, system defaults would be used.

Action: Ensure that a sum of PCTUSED and PCTFREE for the partition does not exceed 100.

ORA-14057 partition "string": sum of PCTUSED and PCTFREE may not exceed 100

Cause: The sum of PCTUSED and PCTFREE for a partition whose name (explicitly specified by the user) is displayed in this message exceeds 100. Note that if PCTUSED and/or PCTFREE values for this partition were not specified explicitly, default values for the partitioned table or index would be used. If, in turn, default PCTUSED and/or PCTFREE values for the partitioned table or index were not specified, system defaults would be used.

Action: Ensure that a sum of PCTUSED and PCTFREE for the partition does not exceed 100.

ORA-14058 partition number string: INITRANS value must be less than MAXTRANS value

Cause: Value of INITRANS was found to be greater than that of MAXTRANS for a partition whose number (partitions are numbered starting with 1) is displayed in this message. Note that if INITRANS and/or MAXTRANS values for this partition were not specified explicitly, default values for the partitioned table or index would be used. If, in turn, default INITRANS and/or MAXTRANS values for the partitioned table or index were not specified, system defaults would be used.

Action: Ensure that the value of INITRANS (whether specified explicitly or derived from the default value for the partitioned table or index) is no greater than that of MAXTRANS.

ORA-14059 partition "string": INITRANS value must be less than MAXTRANS value

Cause: Value of INITRANS was found to be greater than that of MAXTRANS for a partition whose name (explicitly specified by the user) is displayed in this message. Note that if INITRANS and/or MAXTRANS values for this partition were not specified explicitly, default values for the partitioned table or index would be used. If, in turn, default INITRANS and/or MAXTRANS values for the partitioned table or index were not specified, system defaults would be used.

Action: Ensure that the value of INITRANS (whether specified explicitly or derived from the default value for the partitioned table or index) is no greater than that of MAXTRANS.

ORA-14060 data type or length of a table partitioning column may not be changed

Cause: User issued ALTER TABLE statement attempting to modify data type and/or length of a column used to partition the table named in ALTER TABLE statement, which is illegal.

Action: Avoid modifying data type and/or length of table partitioning column(s).

ORA-14061 data type or length of an index partitioning column may not be changed

Cause: User issued ALTER TABLE statement attempting to modify data type and/or length of a column used to partition some index defined on the table named in ALTER TABLE statement, which is illegal.

Action: Avoid modifying data type and/or length of index partitioning column(s).

ORA-14062 one or more of table's partitions reside in a read-only tablespace

Cause: User issued ALTER TABLE statement attempting to modify an existing VARCHAR2 (or VARCHAR) column to be of type CHAR (or CHARACTER), increase length of an existing CHAR (or CHARACTER) column, or add a column with user-specified default for a table one or more partitions of which reside in read-only tablespaces, which is illegal.

Action: Avoid performing aforementioned operations on a partitioned table one or more partitions of which reside in read-only tablespaces.

ORA-14063 Unusable index exists on unique/primary constraint key

Cause: An attempt was made to add or enable a primary key/unique constraint on column(s) of a table on which there exists an index marked Index Unusable.

Action: Drop the existing index or rebuild it using ALTER INDEX REBUILD.

ORA-14064 Index with Unusable partition exists on unique/primary constraint key

Cause: An attempt was made to add or enable a primary key/unique constraint on column(s) of a table on which there exists an index one or more partitions of which are marked Index Unusable.

Action: Drop the existing index or rebuild unusable partitions it using ALTER INDEX REBUILD PARTITION.

ORA-14065 ALLOCATE STORAGE may not be specified for a partitioned table

Cause: User specified ALLOCATE STORAGE clause in ALTER TABLE statement issued against a partitioned table which is illegal.

Action: Remove the illegal option. If it is desired to add storage to individual partitions, ALLOCATE STORAGE clause may be specified with ALTER TABLE MODIFY PARTITION statement.

ORA-14066 illegal option for a non-partitioned index-organized table

Cause: An attempt was made to issue a CREATE or ALTER TABLE command on a non-partitioned index-organized table, but the command contains an option that is legal only for partitioned index-organized tables. Such options are: ENABLE ROW MOVEMENT and DISABLE ROW MOVEMENT.

Action: Remove the illegal options from the command.

ORA-14067 duplicate TABLESPACE_NUMBER specification

Cause: TABLESPACE_NUMBER clause was specified more than once for a table, an index, or an index partition.

Action: Correct the code generating text of CREATE INDEX statement sent to the slaves.

ORA-14068 TABLESPACE and TABLESPACE_NUMBER may not be both specified

Cause: Both TABLESPACE and TABLESPACE_NUMBER clauses were specified for a table, an index, or an index partition.

Action: Correct the code generating text of CREATE INDEX statement sent to the slaves.

ORA-14069 invalid TABLESPACE_NUMBER value

Cause: The TABLESPACE_NUMBER value is not an integer between 0 and 0x7FFFFFFF.

Action: Correct the code generating text of CREATE INDEX statement sent to the slaves.

ORA-14070 option may be specified only for partitioned indices or with REBUILD

Cause: User issued ALTER INDEX statement containing an option which is legal only for partitioned indices or in conjunction with REBUILD against a non-partitioned index. Such options are: PCTFREE, TABLESPACE, [NO]PARALLEL and INITIAL, FREELISTS, and FREELIST GROUPS inside STORAGE clause.

Action: Remove illegal option(s).

ORA-14071 invalid option for an index used to enforce a constraint

Cause: An option other than COMPRESS, NOCOMPRESS, PCTFREE, INITRANS, MAXTRANS, STORAGE, TABLESPACE, PARALLEL, NOPARALLEL, RECOVERABLE, UNRECOVERABLE, LOGGING, NOLOGGING, LOCAL, or GLOBAL was specified for an index used to enforce a constraint.

Action: Choose one of the valid index options.

ORA-14072 fixed table may not be truncated

Cause: An attempt was made to truncate a fixed table which is illegal.

Action: Ensure that the table being truncated is not a fixed table.

ORA-14073 bootstrap table or cluster may not be truncated

Cause: An attempt was made to truncate a bootstrap table or cluster which is illegal.

Action: Ensure that the table (or cluster) being truncated is not a bootstrap table (or cluster).

ORA-14074 partition bound must collate higher than that of the last partition

Cause: Partition bound specified in ALTER TABLE ADD PARTITION statement did not collate higher than that of the table's last partition, which is illegal.

Action: Ensure that the partition bound of the partition to be added collates higher than that of the table's last partition.

ORA-14075 partition maintenance operations may only be performed on partitioned indices

Cause: Index named in ALTER INDEX partition maintenance operation is not partitioned, making a partition maintenance operation, at best, meaningless.

Action: Ensure that the index named in ALTER INDEX statement specifying a partition maintenance operation is, indeed, partitioned.

ORA-14076 DROP/SPLIT PARTITION may not be applied to a LOCAL index partition

Cause: An attempt was made to drop or split a partition of a LOCAL index which is illegal.

Action: Ensure that the index named in such statement is a GLOBAL partitioned index.

ORA-14078 you may not drop the highest partition of a GLOBAL index

Cause: An attempt was made to drop highest partition of a GLOBAL index, which is illegal.

Action: Ensure that the partition specified in ALTER INDEX DROP PARTITION statement is not the highest partition of the index.

ORA-14079 illegal option for a partition marked Index Unusable

Cause: ALTER INDEX MODIFY PARTITION statement against an index partition marked Index Unusable contained STORAGE and/or DEALLOCATE SPACE clauses which is illegal.

Action: Ensure that only valid options are specified.

ORA-14080 partition cannot be split along the specified high bound

Cause: An attempt was made to split a partition along a bound which either collates higher than that of the partition to be split or lower than that of a partition immediately preceding the one to be split.

Action: Ensure that the bound along which a partition is to be split collates lower than that of the partition to be split and higher that of a partition immediately preceding the one to be split.

ORA-14081 new partition name must differ from the old partition name

Cause: User entered ALTER TABLE/INDEX RENAME PARTITION specifying new_partition_name which is identical to the name of the partition being renamed.

Action: Ensure that the new partition name is different from the name of any (including the one being renamed) existing partition of a given table or index.

ORA-14082 new partition name must differ from that of any other partition of the object

Cause: User entered ALTER TABLE/INDEX RENAME PARTITION specifying new_partition_name which is identical to the name of some existing partition of the object.

Action: Ensure that the new partition name is different from the name of any (including the one being renamed) existing partition of a given table or index.

ORA-14083 cannot drop the only partition of a partitioned table

Cause: A drop partition command is being executed when there is only one partition in the table.

Action: Ensure that there is at least one partition. Drop table to remove all partitions.

ORA-14084 you may specify TABLESPACE DEFAULT only for a LOCAL index

Cause: An attempt was made to specify TABLESPACE DEFAULT for an object other than a LOCAL index, which is illegal.

Action: Re-enter the statement without TABLESPACE DEFAULT clause.

ORA-14085 partitioned table cannot have column with LONG datatype

Cause: An attempt was made to create a partitioned table with a LONG datatype or tried to add a LONG datatype column to a partitioned table.

Action: LONG data types are not supported with partitioned tables. Create table without LONG column or change table to not partitioned. If adding column, do not use LONG datatype. If modifying attributes of a column to change data type to LONG, it has to be a non-partitioned table.

ORA-14086 a partitioned index may not be rebuilt as a whole

Cause: An attempt was made to rebuild a partitioned index using ALTER INDEX REBUILD statement, which is illegal.

Action: Rebuild the index a partition at a time (using ALTER INDEX REBUILD PARTITION) or drop and re-create the entire index.

ORA-14094 invalid ALTER TABLE EXCHANGE PARTITION option

Cause: Name of the table to be EXCHANGED has to be followed by [{INCLUDING|EXCLUDING} INDEXES][{WITH|WITHOUT} VALIDATION].

Action: Ensure that no options besides INCLUDING INDEXES or EXCLUDING INDEXES are specified with ALTER TABLE EXCHANGE PARTITION.

ORA-14095 ALTER TABLE EXCHANGE requires a non-partitioned, non-clustered table

Cause: The table in the EXCHANGE operation is either clustered or partitioned.

Action: Ensure that the table with which the partition is being exchanged for is not partitioned or clustered.

ORA-14096 tables in ALTER TABLE EXCHANGE PARTITION must have the same number of columns

Cause: The two tables specified in the EXCHANGE have different number of columns.

Action: Ensure that the two tables have the same number of columns with the same type and size.

ORA-14097 column type or size mismatch in ALTER TABLE EXCHANGE PARTITION

Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE PARTITION are of different type or size.

Action: Ensure that the two tables have the same number of columns with the same type and size.

ORA-14098 index mismatch for tables in ALTER TABLE EXCHANGE PARTITION

Cause: The two tables specified in the EXCHANGE have indexes which are not equivalent.

Action: Ensure that the indexes for the two tables have indexes which follow this rule For every non-partitioned index for the non-partitioned table, there has to be an identical LOCAL index on the partitioned table and vice versa. By identical, the column position, type and size have to be the same.

ORA-14099 all rows in table do not qualify for specified partition

Cause: There is at least one row in the non-partitioned table which does not qualify for the partition specified in the ALTER TABLE EXCHANGE PARTITION.

Action: Ensure that all the rows in the segment qualify for the partition. Perform the alter table operation with the NO CHECKING option. Run ANALYZE table VALIDATE on that partition to find out the invalid rows and delete them.

ORA-14100 partition extended table name cannot refer to a remote object

Cause: An attempt was made to use partition-extended table name syntax in conjunction with remote object name which is illegal.

Action: Correct the statement and re-enter it.

ORA-14101 partition extended table name cannot refer to a synonym

Cause: An attempt was made to use partition-extended table name syntax in conjunction with synonym name which is illegal.

Action: Correct the statement and re-enter it.

ORA-14102 only one LOGGING or NOLOGGING clause may be specified

Cause: LOGGING was specified more than once, NOLOGGING was specified more than once, or both LOGGING and NOLOGGING were specified.

Action: Remove all but one of the LOGGING or NOLOGGING clauses and reissue the statement.

ORA-14103 LOGGING/NOLOGGING may not be combined with RECOVERABLE/UNRECOVERABLE

Cause: A statement contained both [NO]LOGGING and [UN]RECOVERABLE clauses which is disallowed.

Action: Remove one of the offending clauses. [UN]RECOVERABLE is being deprecated in V8 and will be obsoleted in V9. To duplicate semantics of UNRECOVERABLE clause, create an object with NOLOGGING option and then ALTER it specifying LOGGING. To duplicate semantics of RECOVERABLE clause, create an object with LOGGING option.

ORA-14104 RECOVERABLE/UNRECOVERABLE may not be specified for partitioned tables/indices

Cause: CREATE TABLE/INDEX statement used to create a partitioned table/index contained RECOVERABLE or UNRECOVERABLE clause which is illegal.

Action: Remove offending clause. [UN]RECOVERABLE is being deprecated in V8 and will be obsoleted in V9. To duplicate semantics of UNRECOVERABLE clause, create an object with NOLOGGING option and then ALTER it specifying LOGGING. To duplicate semantics of RECOVERABLE clause, create an object with LOGGING option.

ORA-14105 RECOVERABLE/UNRECOVERABLE may not be specified in this context

Cause: RECOVERABLE/UNRECOVERABLE clause is not allowed in this context.

Action: Remove offending clause. RECOVERABLE/UNRECOVERABLE may only be specified in CREATE TABLE/INDEX statement describing a non-partitioned table or index and ALTER INDEX REBUILD statement. [UN]RECOVERABLE is being deprecated in V8 and will be obsoleted in V9. To duplicate semantics of UNRECOVERABLE clause, create an object with NOLOGGING option and then ALTER it specifying LOGGING. To duplicate semantics of RECOVERABLE clause, create an object with LOGGING option.

ORA-14106 LOGGING/NOLOGGING may not be specified for a clustered table

Cause: An attempt was made to specify LOGGING or NOLOGGING clause in CREATE TABLE or ALTER TABLE statement involving a clustered table.

Action: Remove offending clause.

ORA-14107 partition specification is required for a partitioned object

Cause: parameter which supplies partition name is missing. This parameter is optional for non-partitioned objects, but is required for partitioned objects.

Action: Supply the missing parameter.

ORA-14108 illegal partition-extended table name syntax

Cause: Partition to be accessed may only be specified using its name. An attempt was made to use a partition number or a bind variable.

Action: Modify the statement to refer to a partition using its name.

ORA-14109 partition-extended object names may only be used with tables

Cause: An attempt was made to use a partition-extended object name with an object which is not a table.

Action: Avoid using partition-extended name syntax with objects which are not tables.

ORA-14110 partitioning column may not be of type ROWID

Cause: Partitioning column specified by the user was of type ROWID, which is illegal.

Action: Ensure that no partitioning column is of type ROWID.

ORA-14111 creation of GLOBAL partitioned indices on clustered tables is not supported

Cause: An attempt was made to create a GLOBAL partitioned index on a clustered table which is currently illegal.

Action: Remove PARTITION BY RANGE() clause along with (partition_list) to create a GLOBAL non-partitioned index on a clustered table.

ORA-14112 RECOVERABLE/UNRECOVERABLE may not be specified for a partition or subpartition

Cause: Description of a partition or subpartition found in CREATE TABLE/INDEX statement contained RECOVERABLE or UNRECOVERABLE clause which is illegal.

Action: Remove offending clause. Use LOGGING or NOLOGGING instead.

ORA-14113 partitioned table cannot have column with LOB datatype

Cause: An attempt was made to create a partitioned table with a LOB datatype or tried to add a LOB datatype column to a partitioned table.

Action: LOB data types are not supported with partitioned tables. Create table without LOB column or change table to not partitioned. If adding column, do not use LOB datatype. If modifying attributes of a column to change data type to LOB, it has to be a non-partitioned table.

ORA-14114 partitioned table cannot have column with object, REF, nested table, array datatype

Cause: An attempt was made to create a partitioned table with a object datatype (object, REF, nested table, array) or tried to add a object datatype column to a partitioned table.

Action: object data types are not supported with partitioned tables. Create table without object column or change table to not partitioned. If adding column, do not use object datatypes. If modifying attributes of a column to change data type to object, it has to be a non-partitioned table.

ORA-14115 partition bound of partition number string is too long

Cause: Length of linear key representation of a high bound of the partition whose number (partitions are numbered starting with 1) is displayed in this message exceeded the legal limit (4K).

Action: Change representation of a partition high bound to bring its length within legal limit.

ORA-14116 partition bound of partition "string" is too long

Cause: Length of linear key representation of a high bound of the partition whose name (explicitly specified by the user) is displayed in this message exceeded the legal limit (4K).

Action: Change representation of a partition high bound to bring its length within legal limit.

ORA-14117 partition resides in offlined tablespace

Cause: User attempted an operation requiring that we access data in a partition which resides in a tablespace which was taken offline. Such operations include trying to drop a tablespace of a table which has indices defined on it or is referenced by a constraint.

Action: Bring the tablespace online before attempting the operation.

ORA-14118 CHECK constraint mismatch in ALTER TABLE EXCHANGE PARTITION

Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE PARTITION statement have CHECK constraint defined on them.

Action: Ensure that the two tables do not have CHECK constraint defined on any column.

ORA-14119 specified partition bound is too long

Cause: Length of a linear key representation of a high bound of a table partition being added or along which an existing table or index partition is being split exceeded the legal limit (4K).

Action: Change representation of a partition high bound to bring its length within legal limit.

ORA-14120 incompletely specified partition bound for a DATE column

Cause: An attempt was made to use a date expression whose format does not fully (that is, day, month, and year (including century)) specify a date as a partition bound for a DATE column. The format may have been specified explicitly (using TO_DATE() function) or implicitly (NLS_DATE_FORMAT).

Action: Ensure that date format used in a partition bound for a DATE column supports complete specification of a date (that is, day, month, and year (including century)). If NLS_DATE_FORMAT does not support complete (that is, including the century) specification of the year, use TO_DATE() (for example, TO_DATE('01-01-1999', 'MM-DD-YYYY') to fully express the desired date.

ORA-14121 MODIFY DEFAULT ATTRIBUTES may not be combined with other operations

Cause: ALTER TABLE or ALTER INDEX statement attempted to combine MODIFY DEFAULT ATTRIBUTES with some other operation (for example, ADD PARTITION or PCTFREE) which is illegal.

Action: Ensure that MODIFY DEFAULT ATTRIBUTES is the sole operation specified in ALTER TABLE or ALTER INDEX statement; operations other than those dealing with partitions, default attributes of partitioned tables/indices or specifying that a table be renamed (ALTER TABLE RENAME) may be combined at will.

ORA-14122 only one REVERSE or NOREVERSE clause may be specified

Cause: Both REVERSE and NOREVERSE were specified in CREATE INDEX statement.

Action: Remove all but one of the REVERSE or NOREVERSE clauses and reissue the statement.

ORA-14123 duplicate NOREVERSE clause

Cause: NOREVERSE was specified more than once in ALTER INDEX statement.

Action: Remove all but one of the NOREVERSE clauses and reissue the statement.

ORA-14124 duplicate REVERSE clause

Cause: REVERSE was specified more than once in ALTER INDEX or CREATE INDEX statements.

Action: Remove all but one of the REVERSE clauses and reissue the statement.

ORA-14125 REVERSE/NOREVERSE may not be specified in this context

Cause: REVERSE/NOREVERSE clause is not allowed in this context.

Action: Remove offending clause. REVERSE may be specified as an attribute of an index (not of an individual partition, if creating a partitioned index) in CREATE INDEX statement and ALTER INDEX REBUILD statement. NOREVERSE may be specified only in ALTER INDEX REBUILD statement.

ORA-14126 only a parallel_clause may follow description(s) of resulting partitions

Cause: Descriptions of partition(s) resulting from splitting of a table or index partition may be followed by an optional parallel_clause which applies to the entire statement and which, in turn, may not be followed by any other clause.

Action: Ensure that all partition attributes appear within the parenthesized list of descriptions of resulting partitions in ALTER TABLE/INDEX SPLIT PARTITION statement.

ORA-14128 FOREIGN KEY constraint mismatch in ALTER TABLE EXCHANGE PARTITION

Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE PARTITION statement have different FOREIGN KEY constraints.

Action: Ensure that the two tables do not have FOREIGN KEY constraints defined on any column or disable all FOREIGN KEY constraints on both tables. Then retry the operation.

ORA-14129 INCLUDING INDEXES must be specified as tables have enabled UNIQUE constraints

Cause: Matching UNIQUE constraints in both table are enabled and validated but INCLUDING INDEXES is not specified in ALTER TABLE EXCHANGE PARTITION|SUBPARTITION command.

Action: Disable currently enabled matching UNIQUE constraints on both tables or ensure that INCLUDING INDEXES option is used.

ORA-14130 UNIQUE constraints mismatch in ALTER TABLE EXCHANGE PARTITION

Cause: One of the tables named in the ALTER TABLE EXCHANGE PARTITION command has a UNIQUE constraint for which no matching (vis-a-vis key columns) constraint is defined on the other table or a matching constraint is defined on the other table, but it differs from that defined on the first table vis-a-vis being enabled and/or validated.

Action: Ensure that for every UNIQUE constraint defined on one of the tables named in the ALTER TABLE EXCHANGE PARTITION statement there is a matching (vis-a-vis key columns and being enabled and/or validated) UNIQUE constraint defined on the other table. If UNIQUE constrains are enabled, UNIQUE constraints on the partitioned table should be enforced using local indexes.

ORA-14131 enabled UNIQUE constraint exists on one of the tables

Cause: One of the tables referenced in the ALTER TABLE EXCHANGE PARTITION|SUBPARTITION statement has enabled UNIQUE constraint(s) defined on it, which prevents EXCHANGE from proceeding.

Action: Disable constraints defined on tables referenced in the ALTER TABLE EXCHANGE PARTITION|SUBPARTITION statement and retry the statement.

ORA-14132 table cannot be used in EXCHANGE

Cause: An attempt was made to issue an ALTER TABLE EXCHANGE PARTITION | SUBPARTITION command, but the non-partitioned table cannot be used in the EXCHANGE because one or more of the following apply:

  • it is a typed table
  • it contains ADT columns
  • it contains nested-table columns
  • it contains REF columns
  • it contains array columns
  • it is an index-organized table
  • it contains LOB columns
  • it is a nested table

Action: Make sure the non-partitioned table does not violate any of the above restrictions for the ALTER TABLE EXCHANGE PARTITION | SUBPARTITION command.

ORA-14133 ALTER TABLE MOVE cannot be combined with other operations

Cause: An attempt was made to combine an ALTER TABLE MOVE statement with another operation, such as MODIFY.

Action: Make sure that MOVE is the only operation specified in ALTER TABLE statement.

ORA-14134 indexes cannot use both DESC and REVERSE

Cause: An attempt was made to make a reverse index with some index columns marked DESC.

Action: Do not use DESC in reverse indexes. The rule-based optimizer can scan indexes backwards, which allows a normal reverse index to simulate a reverse index with columns marked DESC.

ORA-14135 a LOB column cannot serve as a partitioning column

Cause: An attempt was made to specify a column of type BLOB or CLOB as a partitioning or subpartitioning column.

Action: Ensure that no partitioning or subpartitioning column is of type BLOB or CLOB.

ORA-14136 ALTER TABLE EXCHANGE restricted by fine-grained security

Cause: User doing exchange does not have full table access due to VPD policies.

Action: Grant exempt priviliges to this user.

ORA-14150 missing SUBPARTITION keyword

Cause: Keyword SUBPARTITION missing.

Action: Supply the missing parameter.

ORA-14151 invalid table partitioning method

Cause: Invalid partitioning method was specified in CREATE TABLE statement. A table may be partitioned by RANGE, HASH, or composite range/hash (R+H).

Action: Specify one of valid partitioning methods.

ORA-14152 invalid number of partitions specified in PARTITIONS clause

Cause: number-of-partitions clause contained in CREATE TABLE or CREATE INDEX statement specified a number of partitions outside of legal range (1-65535).

Action: Specify a number between 1 and 65535 in the number-of-partitions clause.

ORA-14153 only one of STORE IN or partition_description clause may be specified

Cause: Both STORE IN and partition_description clauses were specified in a CREATE TABLE|INDEX command.

Action: Remove one of offending clauses.

ORA-14154 only one of STORE IN or subpartition_description clause may be specified

Cause: Both STORE IN and subpartition_description clauses were specified in a CREATE TABLE|INDEX, or ALTER TABLE ADD|SPLIT PARTITION or ALTER TABLE MERGE PARTITIONS command for a composite range-partitioned object.

Action: Remove one of offending clauses.

ORA-14155 missing PARTITION or SUBPARTITION keyword

Cause: Expected either the PARTITION or SUBPARTITION keyword but neither was supplied.

Action: Supply the missing keyword.

ORA-14156 invalid number of subpartitions specified in [SUBPARTITIONS | SUBPARTITION TEMPLATE] clause

Cause: Number-of-subpartitions clause contained in CREATE TABLE or CREATE INDEX statement specified a number of subpartitions outside of legal range (1-65535).

Action: Specify a number between 1 and 65535 in the number-of-subpartitions clause.

ORA-14157 invalid subpartition name

Cause: A subpartition name of the form identifier is expected but not present.

Action: Enter an appropriate subpartition name.

ORA-14158 too many subpartition descriptions

Cause: CREATE TABLE or CREATE INDEX contained too many subpartition descriptions; maximum number of subpartitions is 65535.

Action: Reduce the number of subpartitions to not exceed 65535.

ORA-14159 duplicate subpartition name

Cause: Name of a subpartition of a table or index being created is not unique.

Action: Rename the subpartition(s) to ensure that their names are unique among subpartitions of the table or index being created.

ORA-14160 this physical attribute may not be specified for a table subpartition

Cause: An unexpected option was encountered while parsing physical attributes of a table subpartition; TABLESPACE is the only valid option.

Action: Remove the invalid option(s).

ORA-14161 subpartition number string: sum of PCTUSED and PCTFREE may not exceed 100

Cause: The sum of PCTUSED and PCTFREE for a subpartition whose number (subpartitions are numbered starting with 1) is displayed in this message exceeds 100. Note that if PCTUSED and/or PCTFREE values for this subpartition were not specified explicitly, default values at partition-level would be used. If, in turn, default PCTUSED and/or PCTFREE values at partition-level were not specified, default values for the partitioned table or index would be used. If those values were also not specified explicitly, system defaults would be used.

Action: Ensure that a sum of PCTUSED and PCTFREE for the subpartition does not exceed 100.

ORA-14162 subpartition "string": sum of PCTUSED and PCTFREE may not exceed 100

Cause: The sum of PCTUSED and PCTFREE for a subpartition whose name (explicitly specified by the user) is displayed in this message exceeds 100. Note that if PCTUSED and/or PCTFREE values for this subpartition were not specified explicitly, default values at partition-level would be used. If, in turn, default PCTUSED and/or PCTFREE values at partition-level were not specified, default values for the partitioned table or index would be used. If those values were also not specified explicitly, system defaults would be used.

Action: Ensure that a sum of PCTUSED and PCTFREE for the subpartition does not exceed 100.

ORA-14163 subpartition number string: INITRANS value must be less than MAXTRANS value

Cause: The value of INITRANS was found to be greater than that of MAXTRANS for a subpartition whose number (subpartitions are numbered starting with 1) is displayed in this message. Note that if INITRANS and/or MAXTRANS values for this subpartition were not specified explicitly, default values at partition-level would be used. If, in turn, default INITRANS and/or MAXTRANS values at partition-level were not specified, default values for the partitioned table or index would be used. If those values were also not specified explicitly, system defaults would be used.

Action: Ensure that value of INITRANS (whether specified explicitly or derived from the default value at partition-level, table-level or index-level) is no greater than that of MAXTRANS.

ORA-14164 subpartition "string": INITRANS value must be less than MAXTRANS value

Cause: The value of INITRANS was found to be greater than that of MAXTRANS for a subpartition whose name (explicitly specified by the user) is displayed in this message. Note that if INITRANS and/or MAXTRANS values for this subpartition were not specified explicitly, default values at partition-level would be used. If, in turn, default INITRANS and/or MAXTRANS values at partition-level were not specified, default values for the partitioned table or index would be used. If those values were also not specified explicitly, system defaults would be used.

Action: Ensure that value of INITRANS (whether specified explicitly or derived from the default value at partition-level, table-level or index-level) is no greater than that of MAXTRANS.

ORA-14165 MODIFY DEFAULT ATTRIBUTES FOR PARTITION may not be combined with other operations

Cause: An ALTER TABLE or ALTER INDEX statement attempted to combine MODIFY DEFAULT ATTRIBUTES OF PARTITION with some other operation (for example, ADD PARTITION or PCTFREE) which is illegal.

Action: Ensure that MODIFY DEFAULT ATTRIBUTES is the sole operation specified in ALTER TABLE or ALTER INDEX statement; operations other than those dealing with partitions, default attributes of partitioned tables/indices or specifying that a table be renamed (ALTER TABLE RENAME) may be combined at will.

ORA-14166 missing INTO keyword

Cause: Keyword INTO missing.

Action: Supply the missing keyword.

ORA-14167 only one subpartition may be moved

Cause: ALTER TABLE MOVE SUBPARTITION contained descriptions of more than one subpartition to be moved.

Action: Ensure that the statement describes exactly one subpartition to be moved and that it does not contain any commas.

ORA-14168 only one subpartition may be modified

Cause: ALTER TABLE|INDEX MODIFY SUBPARTITION contained descriptions of more than one subpartition to be modified.

Action: Ensure that the statement describes exactly one subpartition to be modified and that it does not contain any commas.

ORA-14169 invalid ALTER TABLE MODIFY SUBPARTITION option

Cause: An option other than PCTFREE, PCTUSED, INITRANS, MAXTRANS, STORAGE, was specified in an ALTER TABLE MODIFY SUBPARTITION statement.

Action: Specify only legal options.

ORA-14170 cannot specify partition_description clause in CREATE TABLE|INDEX

Cause: User requested to generate default partition description(s) (possibly via PARTITIONS number_of_partitions) while at the same time specified partition_description clause which is illegal.

Action: Remove one of offending clauses.

ORA-14171 cannot specify subpartition_description clause in CREATE|ALTER TABLE

Cause: User requested to generate default subpartition description(s) (possibly via SUBPARTITIONS) while at the same time specified subpartition_description clause which is illegal.

Action: Remove one of offending clauses.

ORA-14172 invalid ALTER TABLE EXCHANGE SUBPARTITION option

Cause: Name of the table to be EXCHANGED has to be followed by [{INCLUDING|EXCLUDING} INDEX][{WITH|WITHOUT} VALIDATION].

Action: Ensure that no options besides INCLDING INDEX or EXCLUDING INDEX are specified with ALTER TABLE EXCHANGE SUBPARTITION.

ORA-14173 illegal subpartition-extended table name syntax

Cause: Subpartition to be accessed may only be specified using its name. An attempt was made to use a subpartition number or a bind variable.

Action: Modify statement to refer to a subpartition using its name.

ORA-14174 only a parallel_clause may follow COALESCE PARTITION|SUBPARTITION

Cause: ALTER TABLE COALESCE PARTITION|SUBPARTITION may be followed by an optional parallel_clause. No partition/subpartition attributes may be specified.

Action: Ensure that no partition/subpartition attribute was specified.

ORA-14175 a subpartition maintenance operation may not be combined with other operations

Cause: An ALTER TABLE or ALTER INDEX statement attempted to combine a subpartition maintenance operation (for example, MOVE SUBPARTITION) with some other operation (for example, MODIFY PARTITION ADD SUBPARTITION or PCTFREE) which is illegal.

Action: Ensure that a subpartition maintenance operation is the sole operation specified in ALTER TABLE or ALTER INDEX statement; operations other than those dealing with subpartitions, default attributes of partitioned tables/indices or specifying that a table be renamed (ALTER TABLE RENAME) may be combined at will.

ORA-14176 this attribute may not be specified for a hash partition

Cause: An invalid option was encountered while parsing physical attributes of a partition of a table partitioned using the HASH method. The TABLESPACE option is the only valid option for such partitions.

Action: Remove the invalid option(s).

ORA-14177 STORE-IN (Tablespace list) can only be specified for a LOCAL index on a table which is hash or composite partitioned

Cause: STORE-IN (Tablespace list) clause was used while creating a local index on a table which is range or list partitioned.

Action: Do not use the STORE_IN (Tablespace list) clause while creating a local index on range or list partitioned table.

ORA-14183 TABLESPACE DEFAULT can be specified only for Composite LOCAL index

Cause: An attempt was made to specify TABLESPACE DEFAULT for a partition of a range/system/hash-partitioned LOCAL index object, which is illegal.

Action: Replace TABLESPACE DEFAULT with TABLESPACE ts_name or remove it.

ORA-14185 incorrect physical attribute specified for this index partition

Cause: An unexpected option was encountered while parsing physical attributes of a local index partition; valid options for range composite range partitions are INITRANS, MAXTRANS, TABLESPACE, STORAGE, PCTFREE, PCTUSED, LOGGING and TABLESPACE; but only TABLESPACE may be specified for hash partitions STORE IN () is also disallowed for all but composite range partitions.

Action: Remove the invalid option(s) from the list of physical attributes of an index partition.

ORA-14186 number of sub-partitions of LOCAL index must equal that of the underlying table

Cause: An attempt was made to create a LOCAL partitioned index with a number of subpartitions which is different from that of the underlying table.

Action: Correct the CREATE INDEX statement to specify a correct number of subpartitions.

ORA-14187 partitioning method for LOCAL index is inconsistent with that of the underlying table

Cause: An attempt was made to create a LOCAL partitioned index that is not equipartitioned with the underlying table. The partitioning types are mismatched.

Action: Correct the CREATE INDEX statement to ensure that the index partitioning method is consistent with that of the base table.

ORA-14188 sub-partitioning columns must form a subset of key columns of a UNIQUE index

Cause: An attempt was made to create a UNIQUE partitioned index whose subpartitioning columns do not form a subset of its key columns which is illegal.

Action: If you want to create an index whose subpartitioning columns do not form a subset of its key columns, it must be created as non-UNIQUE; otherwise, correct the list of key and/or subpartitioning columns to ensure that the index's subpartitioning columns form a subset of its key columns.

ORA-14189 this physical attribute may not be specified for an index subpartition

Cause: An unexpected option was encountered while parsing physical attributes of an index subpartition; TABLESPACE is the only valid option.

Action: Remove the invalid option(s).

ORA-14190 only one ENABLE/DISABLE ROW MOVEMENT clause can be specified

Cause: One of the following:

  • ENABLE ROW MOVEMENT was specified more than once.
  • DISABLE ROW MOVEMENT was specified more than once.
  • Both ENABLE ROW MOVEMENT and DISABLE ROW MOVEMENT were specified.

Action: Remove all but one of the ENABLE ROW MOVEMENT or DISABLE ROW MOVEMENT clauses and then reissue the command.

ORA-14191 ALLOCATE STORAGE may not be specified for Composite Range partitioned object

Cause: User specified ALLOCATE STORAGE clause in ALTER TABLE/ALTER INDEX statement issued against a range-partitioned index which is illegal.

Action: Remove the illegal option. If it is desired to add storage to individual partitions, ALLOCATE STORAGE clause may be specified with ALTER TABLE/INDEX MODIFY PARTITION statement.

ORA-14192 cannot modify physical index attributes of a Hash index partition

Cause: An attempt was made to modify one of INITRANS/MAXTRANS/LOGGING/STORAGE clause for an index partition of a hash-partitioned index.

Action: Remove the physical attributes one is trying to modify.

ORA-14193 invalid ALTER INDEX MODIFY SUBPARTITION option

Cause: An option other than UNUSABLE, ALLOCATE EXTENT, DEALLOCATE UNUSED was specified in an ALTER INDEX MODIFY SUBPARTITION statement.

Action: Specify only legal options.

ORA-14194 only one subpartition may be rebuilt

Cause: ALTER INDEX REBUILD SUBPARTITION contained descriptions of more than one subpartition to be rebuilt.

Action: Ensure that the statement describes exactly one subpartition to be rebuilt and that it does not contain any commas.

ORA-14195 ALLOCATE STORAGE may not be specified for RANGE or LIST partitioned object

Cause: User specified ALLOCATE STORAGE clause in ALTER TABLE/ALTER INDEX statement issued against a range-partitioned index which is illegal.

Action: Remove the illegal option. If it is desired to add storage to individual partitions, ALLOCATE STORAGE clause may be specified with ALTER TABLE/INDEX MODIFY PARTITION statement.

ORA-14251 Specified subpartition does not exist

Cause: Subpartition not found for the object.

Action: Retry with correct subpartition name.

ORA-14252 invalid ALTER TABLE MODIFY PARTITION option for a Hash partition

Cause: Only ALLOCATE EXTENT and DEALLOCATE UNUSED may be specified in ALTER TABLE MODIFY PARTITION for a hash partition.

Action: Specify only legal options.

ORA-14253 table is not partitioned by Composite Range method

Cause: The table in a subpartition maintenance operation (ALTER TABLE EXCHANGE/MODIFY/MOVE/TRUNCATE SUBPARTITION, or ALTER TABLE MODIFY PARTITION ADD/COALESCE SUBPARTITION command must be partitioned by composite range method.

Action: Ensure that the table is partitioned by composite range method.

ORA-14254 cannot specify ALLOCATE STORAGE for a (Composite) Range or List partitioned table

Cause: User specified ALLOCATE STORAGE clause in ALTER TABLE statement issued against a range or composite range partitioned table which is illegal.

Action: Remove the illegal option. If it is desired to add storage to individual partitions/subpartitions, ALLOCATE STORAGE clause may be specified with ALTER TABLE MODIFY PARTITION/SUBPARTITION statement. If it is desired to add storage to all subpartitions of a Composite partition, ALLOCATE STORAGE clause may be specified with ALTER TABLE MODIFY PARTITION.

ORA-14255 table is not partitioned by Range or Composite Range or List method

Cause: ALTER TABLE SPLIT/DROP PARTITION or ALTER TABLE MERGE PARTITIONS command is only valid for table partitioned by range, list, or composite range method.

Action: Ensure that the table is partitioned by range, list, or composite range method.

ORA-14256 invalid resulting partition description(s)

Cause: User specified STORE-IN clause, SUBPARTITIONS clause, and/or subpartition_description clause in partition description(s) in ALTER TABLE SPLIT PARTITION or ALTER TABLE MERGE PARTITIONS statement but the table in the maintenance operation is not a composite range-partitioned table which is illegal.

Action: Remove the invalid clause(s), or ensure that the table is partitioned by composite range method.

ORA-14257 cannot move partition other than a Range or Hash partition

Cause: An attempt was made to move a partition that is not a range or hash partition which is illegal.

Action: Specify MOVE PARTITION for a range or hash partition only.

ORA-14258 invalid partition description

Cause: User specified STORE-IN clause, SUBPARTITIONS clause, and/or subpartition_description clause in ALTER TABLE ADD PARTITION statement but the table in the maintenance operation is not a composite range/hash-partitioned table which is illegal.

Action: Remove the invalid clause(s), or ensure that the table is partitioned by composite range/hash method.

ORA-14259 table is not partitioned by Hash method

Cause: ALTER TABLE COALESCE PARTITION is only valid for table partitioned by Hash method.

Action: Specify a valid ALTER TABLE option for the table, or ensure that the table is partitioned by Hash method.

ORA-14260 incorrect physical attribute specified for this partition

Cause: User specified INITRANS, MAXTRANS, STORAGE, PCTFREE, PCTUSED, and/or [NO]LOGGING option to a hash partition via ALTER TABLE ADD/MOVE PARTITION command which is illegal. Only TABLESPACE may be specified.

Action: Remove the invalid option(s).

ORA-14261 partition bound may not be specified when adding this Hash partition

Cause: User specified VALUES LESS THAN clause when adding a partition (via ALTER TABLE ADD PARTITION) to a hash-partitioned table which is illegal.

Action: Remove the VALUES LESS THAN clause from the description of partition being added.

ORA-14262 new subpartition name must differ from the old subpartition name

Cause: User entered ALTER TABLE/INDEX RENAME SUBPARTITION specifying new_subpartition_name which is identical to the name of the subpartition being renamed.

Action: Ensure that the new subpartition name is different from the name of any (including the one being renamed) existing subpartition of a given table or index.

ORA-14263 new subpartition name must differ from that of any other subpartition of the object

Cause: User entered ALTER TABLE/INDEX RENAME SUBPARTITION specifying new_subpartition_name which is identical to the name of some existing subpartition of the object.

Action: Ensure that the new subpartition name is different from the name of any (including the one being renamed) existing subpartition of a given table or index.

ORA-14264 table is not partitioned by Composite Range method

Cause: The table in the MODIFY DEFAULT ATTRIBUTES FOR PARTITION operation is partitioned by method other than Composite method.

Action: Ensure that the table is partitioned by Composite method.

ORA-14265 data type or length of a table subpartitioning column may not be changed

Cause: User issued ALTER TABLE statement attempting to modify data type and/or length of a column used to subpartition the table named in ALTER TABLE statement, which is illegal.

Action: Avoid modifying data type and/or length of table subpartitioning column(s).

ORA-14266 data type or length of an index subpartitioning column may not be changed

Cause: User issued ALTER TABLE statement attempting to modify data type and/or length of a column used to subpartition some index defined on the table named in ALTER TABLE statement, which is illegal.

Action: Avoid modifying data type and/or length of index subpartitioning column(s).

ORA-14267 cannot specify PARALLEL clause when adding a (Composite) Range partition

Cause: User issued ALTER TABLE ADD PARTITION statement with PARALLEL clause for a range or composite range partition which is illegal.

Action: Remove the PARALLEL clause.

ORA-14268 subpartition 'string' of the partition resides in offlined tablespace

Cause: User attempted an operation requiring that we access data in a subpartition which resides in a tablespace which was taken offline. Such operations include trying to drop a tablespace of a table which has indices defined on it or is referenced by a constraint.

Action: Bring tablespace online before attempting the operation.

ORA-14269 cannot exchange partition other than a Range or Hash partition

Cause: User attempt to exchange a partition with a non-partitioned table but the specified partition is not a range or hash partition which is illegal.

Action: Specify EXCHANGE PARTITION for a range or hash partition only.

ORA-14270 table is not partitioned by Range or Hash or List method

Cause: The table in ALTER TABLE MODIFY PARTITION {UNUSABLE LOCAL INDEXES | REBUILD UNUSABLE LOCAL INDEXES} statement is not partitioned by range or hash method which is illegal.

Action: Ensure that the table is partitioned by range or hash method.

ORA-14271 table is not partitioned by Composite Range method

Cause: The table in ALTER TABLE MODIFY SUBPARTITION {UNUSABLE LOCAL INDEXES | REBUILD UNUSABLE LOCAL INDEXES} statement is not partitioned by composite range method which is illegal.

Action: Ensure that the table is partitioned by composite range method.

ORA-14272 only a partition with higher bound can be reused

Cause: User attempt to reuse a lower-bound partition in ALTER TABLE MERGE PARTITIONS statement as the resulting partition which is illegal.

Action: Use the higher-bound partition to be the resulting partition or specify a new partition name.

ORA-14273 lower-bound partition must be specified first

Cause: User specified higher-bound partition before lower-bound partition in ALTER TABLE MERGE PARTITIONS statement which is illegal.

Action: Specify lower-bound partition then higher-bound partition.

ORA-14274 partitions being merged are not adjacent

Cause: User attempt to merge two partitions that are not adjacent to each other which is illegal.

Action: Specify two partitions that are adjacent.

ORA-14275 cannot reuse lower-bound partition as resulting partition

Cause: User attempt to reuse lower-bound partition of the partitions being merged which is illegal.

Action: Specify new resulting partition name or reuse the higher-bound partition only.

ORA-14276 EXCHANGE SUBPARTITION requires a non-partitioned, non-clustered table

Cause: The table in the ALTER TABLE EXCHANGE SUBPARTITION operation is either clustered or partitioned.

Action: Ensure that the table with which the subpartition is being exchanged for is not partitioned or clustered.

ORA-14277 tables in EXCHANGE SUBPARTITION must have the same number of columns

Cause: The two tables specified in the ALTER TABLE EXCHANGE SUBPARTITION have different number of columns.

Action: Ensure that the two tables have the same number of columns with the same type and size.

ORA-14278 column type or size mismatch in EXCHANGE SUBPARTITION

Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE SUBPARTITION are of different type or size.

Action: Ensure that the two tables have the same number of columns with the same type and size.

ORA-14279 index mismatch for tables in ALTER TABLE EXCHANGE SUBPARTITION

Cause: The two tables specified in the ALTER TABLE EXCHANGE SUBPARTITION have indexes which are not equivalent.

Action: Ensure that the indexes for the two tables have indexes which follow this rule For every non-partitioned index for the non-partitioned table, there has to be an identical LOCAL index on the partitioned table and vice versa. By identical, the column position, type and size have to be the same.

ORA-14280 all rows in table do not qualify for specified subpartition

Cause: There is at least one row in the non-partitioned table which does not qualify for the subpartition specified in the ALTER TABLE EXCHANGE SUBPARTITION.

Action: Ensure that all the rows in the segment qualify for the subpartition. Perform the alter table operation with the NO CHECKING option. Run ANALYZE table VALIDATE on that subpartition to find out the invalid rows and delete them.

ORA-14281 CHECK constraint mismatch in ALTER TABLE EXCHANGE SUBPARTITION

Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE SUBPARTITION statement have CHECK constraint defined on them.

Action: Ensure that the two tables do not have CHECK constraint defined on any column.

ORA-14282 FOREIGN KEY constraint mismatch in ALTER TABLE EXCHANGE SUBPARTITION

Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE SUBPARTITION statement have different FOREIGN KEY constraints.

Action: Ensure that the two tables do not have FOREIGN KEY constraints defined on any column or disable all FOREIGN KEY constraints on both tables. Then retry the operation.

ORA-14283 UNIQUE constraints mismatch in ALTER TABLE EXCHANGE SUBPARTITION

Cause: One of the tables named in the ALTER TABLE EXCHANGE SUBPARTITION command has a UNIQUE constraint for which no matching (vis-a-vis key columns) constraint is defined on the other table or a matching constraint is defined on the other table, but it differs from that defined on the first table vis-a-vis being enabled and/or validated.

Action: Ensure that for every UNIQUE constraint defined on one of the tables named in the ALTER TABLE EXCHANGE SUBPARTITION statement there is a matching (vis-a-vis key columns and being enabled and/or validated) UNIQUE constraint defined on the other table. If UNIQUE constrains are enabled, UNIQUE constraints on the partitioned table should be enforced using local indexes.

ORA-14284 one or more of table's subpartitions reside in a read-only tablespace

Cause: User issued ALTER TABLE statement attempting to modify an existing VARCHAR2 (or VARCHAR) column to be of type CHAR (or CHARACTER), increase length of an existing CHAR (or CHARACTER) column, or add a column with user-specified default for a table one or more subpartitions of which reside in read-only tablespaces, which is illegal.

Action: Avoid performing aforementioned operations on a partitioned table one or more subpartitions of which reside in read-only tablespaces.

ORA-14285 cannot COALESCE the only partition of this partitioned table

Cause: A COALESCE PARTITION command was issued when there is only one partition in the table which is illegal.

Action: Ensure that there is at least one partition. Drop table to remove all partitions.

ORA-14286 cannot COALESCE the only subpartition of this table partition

Cause: A COALESCE SUBPARTITION command was issued when there is only one subpartition in the partition which is illegal.

Action: Ensure that there is at least one subpartition. Drop partition to remove all subpartitions.

ORA-14287 cannot REBUILD a partition of a Composite Range partitioned index

Cause: An attempt was made to rebuild a partition of a composite range-partitioned index which is illegal.

Action: REBUILD the index partition, a subpartition at a time.

ORA-14288 index is not partitioned by Composite Range method

Cause: The index in a partition or subpartition maintenance operation (ALTER INDEX MODIFY [SUBPARTITION|DEFAULT ATTRIBUTES FOR PARTITION] or ALTER INDEX REBUILD SUBPARTITION command must be partitioned by composite range method.

Action: No action required.

ORA-14289 cannot make local index partition of Composite Range partitioned table unusable

Cause: An attempt was made to rebuild a partition of a composite range partitioned index which is illegal.

Action: No action required.

ORA-14290 PRIMARY KEY constraint mismatch in ALTER TABLE EXCHANGE [SUB]PARTITION

Cause: The corresponding columns in the tables specified in the ALTER TABLE EXCHANGE [SUB]PARTITION statement have different PRIMARY KEY constraints.

Action: Ensure that the two tables do not have PRIMARY KEY constraints defined on any column or disable all PRIMARY KEY constraints on both tables. Then retry the operation.

ORA-14291 cannot EXCHANGE a composite partition with a non-partitioned table

Cause: A composite partition can only be exchanged with a partitioned table.

Action: Ensure that the table being exchanged is partitioned or that that the partition being exchanged is non-composite.

ORA-14292 Partitioning type of table must match subpartitioning type of composite partition

Cause: When exchanging a partitioned table with a composite partition, the partitioning type of the table must match the subpartitioning type of the composite partition.

Action: Ensure that the partitioning type of partitioned table is the same as the subpartitioning type of the composite partition.

ORA-14293 Number of partitioning columns does not match number of subpartitioning columns

Cause: When exchanging a partitioned table with a composite partition, the number of partitioning columns of the table must match the number of subpartitioning columns of the composite partition.

Action: Ensure that the number of partitioning columns in the partitioned table is the same as the number of subpartitioning columns in the composite partition.

ORA-14294 Number of partitions does not match number of subpartitions

Cause: When exchanging a partitioned table with a composite partition, the number of partitions of the table must match the number of subpartitions of the composite partition.

Action: Ensure that the number of partitions in the partitioned table is the same as the number of subpartitions in the the composite partition.

ORA-14295 column type or size mismatch between partitioning columns and subpartitioning columns

Cause: When exchanging a partitioned table with a composite partition, the type and size of the partitioning columns of the table must match the type and size of the subpartitioning columns of the composite partition.

Action: Ensure that the type and size of the partitioning columns of the partitioned is the same as the type and size of the subpartitioning columns of the composite partition.

ORA-14296 Table block size mismatch in ALTER TABLE EXCHANGE [SUB]PARTITION

Cause: The block sizes of the two tables specified in the ALTER TABLE EXCHANGE [SUB]PARTITION statement are different. For index organized tables, either the block sizes of the index or the overflow (or both) do not match.

Action: Ensure that the block sizes of the tables involved in the ALTER TABLE EXCHANGE [SUB]PARTITION statement are the same. For index organized tables, ensure that the block sizes of both the index and the overflow of the two tables match.

ORA-14297 Index block size mismatch in ALTER TABLE EXCHANGE [SUB]PARTITION

Cause: The block sizes of a pair of indexes being exchanged in the ALTER TABLE EXCHANGE [SUB]PARTITION statement are different.

Action: Ensure that the block sizes of the corresponding pairs of indexes that need to be exchanged in the ALTER TABLE EXCHANGE [SUB]PARTITION statement are the same.

ORA-14298 LOB column block size mismatch in ALTER TABLE EXCHANGE [SUB]PARTITION

Cause: The block sizes of a pair of corresponding LOB columns of the two tables specified in the ALTER TABLE EXCHANGE [SUB]PARTITION statement are different.

Action: Ensure that the block sizes of corresponding pairs of LOB columns of the tables involved in the ALTER TABLE EXCHANGE [SUB]PARTITION statement are the same.

ORA-14301 table-level attributes must be specified before partition-level attributes

Cause: While processing an ALTER TABLE ADD COLUMN statement, table-level attributes of LOB columns were encountered after processing partition-level attributes of LOB columns or while processing CREATE TABLE statement, table-level attributes of LOB columns were encountered after processing partition descriptions.

Action: Modify the SQL statement to specify table-level attributes prior to partition-level attributes or partition descriptions; then retry the statement.

ORA-14302 only one list of added-LOB-storage-clauses can be specified in a statement

Cause: While parsing an ALTER TABLE ADD COLUMN statement, one list of added-LOB-storage-clauses was parsed when another list of added-LOB-storage-clauses was encountered. There cannot be more than one list of added-LOB-storage-clauses in a statement; all added-LOB-storage-clauses must be combined into one list.

Action: Combine all of the lists of added-LOB-storage-clauses into one list and retry the statement.

ORA-14303 partitions or subpartitions are not in the right order

Cause: Descriptions of partitions or subpartitions in an ALTER TABLE ADD COLUMN statement were ordered differently from the DDL order of partitions or subpartitions.

Action: Re-order the partitions or subpartitions in the added LOB storage clause by partition or subpartition DDL order, and retry the statement.

ORA-14304 List partitioning method expects a single partitioning column

Cause: Number of columns in a partitioning column list exceeded the legal limit of 1 for list partitioned objects.

Action: Modify partitioning column list so that it consists of at most 1 column.

ORA-14305 List value 'string' specified twice in partition 'string'

Cause: A list value cannot be specified more that once.

Action: Remove one of the specifications of the value.

ORA-14306 List value 'string' specified twice in partitions 'string', 'string'

Cause: A list value cannot be specified more that once.

Action: Remove one of the specifications of the value.

ORA-14307 partition contains too many list values

Cause: Partition list contains more than 65535 list values.

Action: Reduce the number of values to not exceed 65535 values.

ORA-14308 partition bound element must be one of: string, datetime or interval literal, number, or NULL

Cause: Partition bound list contained an element of invalid type (i.e. not a number, non-empty string, datetime or interval literal, or NULL).

Action: Ensure that all elements of partition bound list are of valid type.

ORA-14309 Total count of list values exceeds maximum allowed

Cause: Partitioned object contains more than 65535 list values.

Action: Reduce number of values to less than 65535.

ORA-14310 VALUES LESS THAN or AT clause cannot be used with List partitioned tables

Cause: VALUES LESS THAN or AT clause can be used only with range partitioned tables.

Action: Use VALUES (<value list>) clause with list partitioned tables.

ORA-14311 Expecting VALUES LESS THAN or AT clause

Cause: VALUES (<value list>) clause can be used only with list partitioned tables.

Action: Use VALUES LESS THAN clause with range partitioned tables.

ORA-14312 Value string already exists in partition string

Cause: One of the list values in the ADD PARTITION or ADD VALUES statement already exists in another partition.

Action: Remove the duplicate value from the statement and try again.

ORA-14313 Value string does not exist in partition string

Cause: One of the list values in the SPLIT PARTITION or DROP VALUES statement does not exist in the partition.

Action: Remove the value from the statement and try again.

ORA-14314 resulting List partition(s) must contain atleast 1 value

Cause: After a SPLIT/DROP VALUE of a list partition, each resulting partition(as applicable) must contain at least 1 value.

Action: Ensure that each of the resulting partitions contains at least 1 value.

ORA-14315 cannot merge a partition with itself

Cause: The same partition name was specified twice for the merge operation.

Action: Re-submit operation with 2 distinct partition names.

ORA-14316 table is not partitioned by List method

Cause: ALTER TABLE ADD|DROP VALUES can only be performed on list partitioned objects.

Action: reissue the command against a list partitoned object.

ORA-14317 cannot drop the last value of partition

Cause: ALTER TABLE DROP VALUES tried to drop the last value of the partition.

Action: Cannot execute the command, unless two or more values exist for partition.

ORA-14318 DEFAULT partition must be last partition specified

Cause: A partition description follows the one describing the default partition.

Action: Ensure that the DEFAULT partition is the last partition description.

ORA-14319 DEFAULT cannot be specified with other values

Cause: DEFAULT keyword has been specified along with other values when specifying the values for a list partition.

Action: Ensure that if DEFAULT is specified, it is the only value specified.

ORA-14320 DEFAULT cannot be specified for ADD/DROP VALUES or SPLIT

Cause: DEFAULT keyword has been specified when performing an ADD VALUES, DROP VALUES, SPLIT partition, or subpartition.

Action: Ensure that DEFAULT is not specified for ADD/DROP VALUES or SPLIT partition/subpartition operations.

ORA-14321 cannot add/drop values to DEFAULT partition

Cause: An ADD/DROP VALUES operation is being performed on the default partition.

Action: Ensure that ADD/DROP VALUES is not performed on the DEFAULT partition.

ORA-14322 DEFAULT partition already exists

Cause: A partition already exists with DEFAULT value.

ORA-14323 cannot add partition when DEFAULT partition exists

Cause: An ADD PARTITION operation cannot be executed when a partition with DEFAULT values exists.

Action: Issue a SPLIT of the DEFAULT partition instead.

ORA-14324 values being added already exist in DEFAULT partition

Cause: An ADD VALUE operation cannot be executed because the values being added exist in the DEFAULT partition.

Action: Issue a SPLIT of the DEFAULT partition and then MERGE the split partition into the partition to which values need to be added.

ORA-14400 inserted partition key does not map to any partition

Cause: An attempt was made to insert a record into, a range or composite range object, with a concatenated partition key that is beyond the concatenated partition bound list of the last partition -OR- an attempt was made to insert a record into a list object with a partition key that did not match the literal values specified for any of the partitions.

Action: Do not insert the key. Or, add a partition capable of accepting the key. Or, add values matching the key to a partition specification.

ORA-14401 inserted partition key is outside specified partition

Cause: The concatenated partition key of an inserted record is outside the ranges of the two concatenated partition bound lists that delimit the partition named in the INSERT statement.

Action: Do not insert the key or insert it in another partition.

ORA-14402 updating partition key column would cause a partition change

Cause: An UPDATE statement attempted to change the value of a partition key column causing migration of the row to another partition.

Action: Do not attempt to update a partition key column or make sure that the new partition key is within the range containing the old partition key.

ORA-14403 cursor invalidation detected after getting DML partition lock

Cause: Cursor invalidation was detected after acquiring a partition lock during an INSERT, UPDATE, DELETE statement.

Action: No action required.

ORA-14404 partitioned table contains partitions in a different tablespace

Cause: An attempt was made to drop a tablespace which contains tables whose partitions are not completely contained in this tablespace.

Action: Find tables with partitions which span the tablespace being dropped and some other tablespace(s). Drop these tables or move partitions to a different tablespace.

ORA-14405 partitioned index contains partitions in a different tablespace

Cause: An attempt was made to drop a tablespace which contains indexes whose partitions are not completely contained in this tablespace, and which are defined on the tables which are completely contained in this tablespace.

Action: Find indexes with partitions which span the tablespace being dropped and some other tablespace(s). Drop these indexes, or move the index partitions to a different tablespace, or find the tables on which the indexes are defined, and drop (or move) them.

ORA-14406 updated partition key is beyond highest legal partition key

Cause: At attempt was made to update a record with a concatenated partition key that is beyond the concatenated partition bound list of the last partition.

Action: Do not update the key. Or, add a partition capable of accepting the key.

ORA-14407 partitioned table contains subpartitions in a different tablespace

Cause: An attempt was made to drop a tablespace which contains tables whose subpartitions are not completely contained in this tablespace.

Action: Find tables with subpartitions which span the tablespace being dropped and some other tablespace(s). Drop these tables or move subpartitions to a different tablespace.

ORA-14408 partitioned index contains subpartitions in a different tablespace

Cause: An attempt was made to drop a tablespace which contains indexes whose subpartitions are not completely contained in this tablespace, and which are defined on the tables which are completely contained in this tablespace.

Action: Find indexes with subpartitions which span the tablespace being dropped and some other tablespace(s). Drop these indexes, or move the index partitions to a different tablespace, or find the tables on which the indexes are defined, and drop (or move) them.

ORA-14409 inserted partition key is outside specified subpartition

Cause: The concatenated partition key of an inserted record is outside the ranges of the two concatenated subpartition bound lists that delimit the subpartition named in the INSERT statement.

Action: Do not insert the key or insert it in another subpartition.

ORA-14450 attempt to access a transactional temp table already in use

Cause: An attempt was made to access a transactional temporary table that has been already populated by a concurrent transaction of the same session.

Action: Do not attempt to access the temporary table until the concurrent transaction has committed or aborted.

ORA-14451 unsupported feature with temporary table

Cause: An attempt was made to create an IOT, specify physical attributes, specify partition or parallel clause.

Action: No action required.

ORA-14452 attempt to create, alter or drop an index on temporary table already in use

Cause: An attempt was made to create, alter or drop an index on temporary table which is already in use.

Action: All the sessions using the session-specific temporary table have to truncate table and all the transactions using transaction specific temporary table have to end their transactions.

ORA-14453 attempt to use a LOB of a temporary table, whose data has already been purged

Cause: An attempt was made to use LOB from a temporary table whose data has been dropped either because table was transaction-specific and transaction has committed or aborted, table was truncated or session which created this LOB has ended.

Action: This LOB locator is invalid and cannot be used.

ORA-14454 attempt to reference temporary table in a referential integrity constraint

Cause: An attempt was made to reference temporary table in a referential integrity constraint. This is not supported.

Action: Use triggers.

ORA-14455 attempt to create referential integrity constraint on temporary table

Cause: An attempt was made to create a referential integrity constraint on a temporary table. This is not supported.

Action: Use triggers.

ORA-14456 cannot rebuild index on a temporary table

Cause: An attempt was made to rebuild an index on a temporary table.

Action: The index data is anyway lost at end of session/transaction.

ORA-14457 disallowed VARRAY and Nested Table column in a Temporary table

Cause: An attempt made to create a VARRAY or Nested Table column in a temporary table. This is not supported.

Action: Do not specify these datatypes for temporary tables.

ORA-14458 attempt was made to create a temporary table with INDEX organization

Cause: An attempt was made to create an Index Organized Temporary table. This is not supported.

Action: Create the table with HEAP organization and the primary key.

ORA-14459 missing GLOBAL keyword

Cause: Keyword GLOBAL is missing while creating temporary table.

Action: Supply the missing keyword.

ORA-14460 only one COMPRESS or NOCOMPRESS clause may be specified

Cause: COMPRESS was specified more than once, NOCOMPRESS was specified more than once, or both COMPRESS and NOCOMPRESS were specified.

Action: Specify each desired COMPRESS or NOCOMPRESS clause option only once.

ORA-14500 LOCAL option not valid without partition name

Cause: Incorrect syntax specified.

Action: Retry the command.

ORA-14501 object is not partitioned

Cause: Table or index is not partitioned. Invalid syntax.

Action: Retry the command with correct syntax.

ORA-14503 only one partition name can be specified

Cause: More than one partition name has been specified for analyze.

Action: Specify one partition name.

ORA-14504 syntax not supported for analyze

Cause: A partition/subpartition number or bind variable has been used.

Action: Specify a valid partition/subpartition name.

ORA-14505 LOCAL option valid only for partitioned indexes

Cause: Incorrect syntax specified.

Action: Retry the command.

ORA-14506 LOCAL option required for partitioned indexes

Cause: Incorrect syntax specified.

Action: Retry the command.

ORA-14507 partition corrupt. all rows do not fall within partition bounds

Cause: The partition contains rows which should really be in some other partition. Possibly due to an exchange partition without validation.

Action: Delete rows in partition which do not qualify.

ORA-14508 specified VALIDATE INTO table not found

Cause: The specified table either does not exist or user does not have the proper privileges.

Action: Specify the correct table to use.

ORA-14509 specified VALIDATE INTO table form incorrect

Cause: The specified table does not have the proper field definitions.

Action: Specify the correct table to use. See UTLVALID.SQL for more information.

ORA-14510 can specify VALIDATE INTO clause only for partitioned tables

Cause: The VALIDATE INTO has been specified for a non-partitioned table or cluster or index.

Action: Use the syntax correctly.

ORA-14511 cannot perform operation on a partitioned object

Cause: An attempt was made to perform an operation that is not allowed on partitioned tables or indexes.

Action: Retry the command with correct syntax.

ORA-14512 cannot perform operation on a clustered object

Cause: An attempt was made to perform an operation that is not allowed on clustered tables or indexes.

Action: Retry the command with correct syntax.

ORA-14513 partitioning column may not be of object datatype

Cause: Partitioning column specified by the user was an object datatype (object, REF, nested table, array) which is illegal.

Action: Ensure that no partitioning column is an object datatype.

ORA-14514 LOCAL option not valid without subpartition name

Cause: Incorrect syntax specified.

Action: Retry the command.

ORA-14515 only one aubpartition name can be specified

Cause: More than one subpartition name has been specified for analyze.

Action: Specify one subpartition name.

ORA-14516 subpartition corrupt. all rows do not fall within subpartition bounds

Cause: The subpartition contains rows which should really be in some other subpartition. Possibly due to an exchange subpartition without validation.

Action: Delete rows in subpartition which do not qualify.

ORA-14517 subpartition of index 'string.string' is in unusable state

Cause: An attempt has been made to access an index subpartition that has been marked unusable by a direct load or by a DDL operation.

Action: REBUILD the unusable index subpartition.

ORA-14518 partition contains rows corresponding to values being dropped

Cause: A table partition contains rows for the values being dropped.

Action: DELETE all rows for the values being dropped and reissue statement.

ORA-14519 Conflicting tablespace blocksizes for string string: Tablespace string block size string [string] conflicts with previously specified/implied tablespace string block size string [string]

Cause: An attempt has been made to create a partitioned object in a manner that would require the partitioned object to span tablespaces of more than one block size.

Action: Ensure that all tablespaces specified in the DDL command for the given object as well as any tablespaces implicitly assigned to partitions or subpartitions of the object being created are all of the same block size.

ORA-14520 Tablespace string block size [string] does not match existing object block size [string]

Cause: A DDL statement was issued that would require a tablespace of a block size different from the block size of the specified partitioned object to be assigned either: (1) As the object's default tablespace (or one of the object's partition-level default tablespaces, if composite partitioning is being used) OR (2) To one of the object's partitions/subpartitions.

Action: Specify a tablespace of the same block size as the partitioned object.

ORA-14521 Default tablespace string block size [string] for string string does not match existing string block size [string]

Cause: A DDL statement was issued that would require creation of a new partition/subpartition in the object-level default tablespace of an existing partitioned object. However, the object-level default tablespace block size does not match the block size of the partitioned object.

Action: Either (1) Modify the default tablespace of the partitioned object to a tablespace of the same block size as the object and then retry the DDL command, OR (2) Ensure that tablespaces of the correct block size are specified for all new partitions/subpartitions being created.

ORA-14522 Partition-level default tablespace string block size [string] for string string does not match existing string block size [string]

Cause: A DDL statement was issued that would require creation of a new subpartition in one of the partition-level default tablespaces of an existing composite partitioned object. However, the partition-level default tablespace block size does not match the block size of the partitioned object.

Action: Either (1) Modify the partition-level default tablespace of the appropriate partition of the partitioned object to a tablespace of the same block size as the object and then retry the DDL command, OR (2) Ensure that tablespaces of the correct block size are specified for all new subpartitions being created.

ORA-14523 Cannot co-locate [sub]partition of string string with table [sub]partition because string block size [string] does not match table block size [string]

Cause: A DDL statement was issued that would require a partition/subpartition of a local index/LOB column to be co-located with the corresponding partition/subpartition of the base table. However, this is not possible because the block sizes of the table and the LOB column/local index are different.

Action: Either (1) Specify an object-level default tablespace (or partition-level default tablespace for the appropriate partition, if composite partitioning is used) for the partitioned local index/LOB column and then retry the DDL command, OR (2) Ensure that tablespaces of the correct block size are specified for all new partitions/subpartitions being created. Also ensure that neither of TABLESPACE DEFAULT and STORE IN (DEFAULT) is specified for a local index whose block size does not match that of the base table.

ORA-14551 cannot perform a DML operation inside a query

Cause: DML operation like insert, update, delete or select-for-update cannot be performed inside a query or under a PDML slave.

Action: Ensure that the offending DML operation is not performed or use an autonomous transaction to perform the DML operation within the query or PDML slave.

ORA-14552 cannot perform a DDL, commit or rollback inside a query or DML

Cause: DDL operations like creation tables, views etc. and transaction control statements such as commit/rollback cannot be performed inside a query or a DML statement.

Action: Ensure that the offending operation is not performed or use autonomous transactions to perform the operation within the query/DML operation.

ORA-14553 cannot perform a lob write operation inside a query

Cause: A LOB write operation cannot be performed inside a query or a PDML slave.

Action: Ensure that the offending LOB write operation is not performed or use an autonomous transaction to perform the operation within the query or PDML slave.

ORA-14601 Illegal to specify SUBPARTITIONS or STORE-IN while specifying a subpartition template

Cause: Cannot specify these clauses while specifying a template.

Action: Correct the subpartition template clause.

ORA-14602 SUBPARTITION TEMPLATE is legal only for a composite partitioned table

Cause: SUBPARTITION TEMPLATEs can only be specified for composite partitioned tables.

Action: Do not use SUBPARTITION TEMPLATEs on non-partitioned or non-composite partitioned tables.

ORA-14603 [SUBPARTITIONS | SUBPARTITION TEMPLATE] subpartition_count syntax is valid only for range-hash tables

Cause: This syntax is valid only if subpartitioning dimension is hash.

ORA-14604 During CREATE TABLE time it is illegal to specify SUBPARTITIONS or STORE IN once a SUBPARTITION TEMPLATE has been specified

Cause: Once a subpartition template has been specified during CREATE TABLE, it is illegal to specify SUBPARTITIONS or STORE IN anywhere else.

Action: Remove either SUBPARTITIONS or STORE IN, or remove the SUBPARTITION TEMPLATE clause.

ORA-14605 Name missing for subpartition / lob segment in template

Cause: A subpartition / lob segment was not specified a name in the template descriptions.

Action: All subpartitions / lob segments must have names specified in the template.

ORA-14606 Tablespace was specified for previous subpartitions in template but is not specified for string

Cause: Tablespaces may either be specified for all subpartitions or must not be specified for any subpartitions.

Action: Either specify tablespaces for all or for none of the subpartitions.

ORA-14607 Tablespace was not specified for previous subpartitions in template but is specified for string

Cause: Tablespaces may either be specified for all subpartitions or must not be specified for any subpartitions.

Action: Either specify tablespaces for all or for none of the subpartitions.

ORA-14608 Tablespace was specified for the previous lob segments of column string in template but is not specified for string

Cause: Tablespaces may either be specified for all lob segments of a column or must not be specified for any lob segments of this column.

Action: Either specify tablespaces for all or for none of the lob segments.

ORA-14609 Tablespace was not specified for the previous lob segments of column string in template but is specified for string

Cause: Tablespaces may either be specified for all lob segments of a column or must not be specified for any lob segments of this column.

Action: Either specify tablespaces for all or for none of the lob segments.

ORA-14610 Lob attributes not specified for lob column string for subpartition string

Cause: Lob attributes of a column must be specified for all subpartitions or must not be specified at all.

Action: Ensure lob attributes of a column are specified for all subpartitions or not specified at all.

ORA-14611 Duplicate subpartition name string in template

Cause: A subpartition name cannot be duplicated within the template.

Action: Rename one of the subpartitions.

ORA-14612 Duplicate lob segment name string for lob column string in template

Cause: Two lob segments of the same column were given the same name in the template.

Action: Rename one of the lob segments.

ORA-14613 Attempt to generate name from parent name string and template name string failed as the combine named would have been longer than allowed

Cause: Any name generated from a partition name and template name must be less than the maximum permissible name for an identifier.

Action: Shorten either the partition name or the template name.

ORA-14614 List value 'string' specified twice in subpartition 'string'

Cause: A list value cannot be specified more than once.

Action: Remove one of the specifications of the value.

ORA-14615 List value 'string' specified twice in subpartitions 'string', 'string'

Cause: A list value cannot be specified more than once.

Action: Remove one of the specifications of the value.

ORA-14616 table is not subpartitioned by List method

Cause: A subpartition maintenance operation such as ALTER TABLE MODIFY SUBPARTITION ADD | DROP VALUES or ALTER TABLE DROP | SPLIT | MERGE SUBPARTITION can only be performed on List subpartitioned objects.

Action: Re-issue the command against a List subpartitioned object.

ORA-14617 cannot add/drop values to DEFAULT subpartition

Cause: An ADD/DROP VALUES operation is being performed on the default subpartition.

Action: Ensure that ADD/DROP VALUES is not done on the DEFAULT subpartition.

ORA-14618 cannot drop the last value of subpartition

Cause: ALTER TABLE DROP VALUES tried to drop the last value of the subpartition.

Action: Cannot execute the command, unless two or more values exist for subpartition.

ORA-14619 resulting List subpartition(s) must contain at least 1 value

Cause: After a SPLIT/DROP VALUE of a list subpartition, each resulting subpartition(as applicable) must contain at least 1 value.

Action: Ensure that each of the resulting subpartitions contains at least 1 value.

ORA-14620 DEFAULT subpartition already exists

Cause: A subpartition already exists with DEFAULT value.

Action: Remove the DEFAULT value from the specified list.

ORA-14621 cannot add subpartition when DEFAULT subpartition exists

Cause: An ADD SUBPARTITION operation cannot be executed when a subpartition with DEFAULT values exists.

Action: Issue a SPLIT of the DEFAULT subpartition instead.

ORA-14622 Value string already exists in subpartition string

Cause: One of the list values in the ADD SUBPARTITION or ADD VALUES statement already exists in another subpartition.

Action: Remove the duplicate value from the statement and try again.

ORA-14623 Value string does not exist in subpartition string

Cause: One of the list values in the SPLIT PARTITION or DROP VALUES statement does not exist in the subpartition.

Action: Remove the value from the statement and try again.

ORA-14624 DEFAULT subpartition must be last subpartition specified

Cause: A subpartition description follows the one describing the default subpartition.

Action: Ensure that the DEFAULT subpartition is the last subpartition description.

ORA-14625 subpartition contains rows corresponding to values being dropped

Cause: Table subpartition contains rows for the values being dropped.

Action: DELETE all rows for the values being dropped and re-issue the statement.

ORA-14626 values being added already exist in DEFAULT subpartition

Cause: An ADD VALUE operation cannot be executed because the values being added exist in the DEFAULT subpartition.

Action: Issue a SPLIT of the DEFAULT subpartition and then MERGE the split subpartition into the subpartition to which values need to be added.

ORA-14627 Invalid operation was specified on a GLOBAL partitioned index

Cause: An invalid operation such as ALTER INDEX DROP|SPLIT SUBPARTITION was specified on the global index.

Action: Ensure that subpartition level operations are not specified on a GLOBAL index, since these are only RANGE partitioned.

ORA-14628 specification of bounds is inconsistent with LIST method

Cause: An operation such as ALTER TABLE SPLIT | ADD SUBPARTITION specified bounds that were inconsistent with List subpartitioning method.

Action: Specify VALUES/subpartition descriptions correctly for SPLIT/ADD of List subpartitions.

ORA-14629 cannot drop the only subpartition of a partition

Cause: A drop subpartition command is being executed when there is only one subpartition in the partition.

ORA-14630 subpartition resides in offlined tablespace

Cause: User attempted an operation requiring that we access data in a subpartition which resides in a tablespace which was taken offline. Such operations include trying to drop a tablespace of a table which has indexes defined on it or is referenced by a constraint.

Action: Bring the tablespace online before attempting the operation.

ORA-14631 the partition bounds do not match the subpartition bounds of the partition

Cause: When exchanging a partitioned table with a composite partition, the bounds that describe the partitions of the table must match the bounds that describe the subpartitions of the composite partition.

Action: Ensure that the bounds describing partitions in the partitioned table are the same as the bounds of the subpartitions in the composite partition.

ORA-14632 cannot specify PARALLEL clause when adding a List subpartition

Cause: An ALTER TABLE ADD SUBPARTITION statement was issued with a PARALLEL clause for a List subpartition of a Range/List partitioned object. This is not allowed.

Action: Remove the PARALLEL clause.

ORA-14633 Index maintainence clause not allowed for ADD list subpartition to a Composite partitioned table

Cause: The clause INVALIDATE or UPDATE GLOBAL INDEXES is allowed only for ADD hash subpartition to a composite partitioned table.

Action: Remove clause and re-issue the operation.

ORA-14634 Subpartition descriptions cannot be specified during the SPLIT/MERGE of a partition of a Range-List partitioned table

Cause: During a split or a merge of a partition of a range list partitioned table, you cannot specify any subpartitioning information for the resulting partitions.

Action: Remove all subpartitioning information from the DDL.

ORA-14635 only one resulting subpartition can be specified for MERGE SUBPARTITIONS

Cause: ALTER TABLE MERGE SUBPARTITIONS contained more than one resulting subpartition for the MERGE.

Action: Ensure that the statement describes exactly one subpartition as the target that needs to be MERGEd.

ORA-14636 only 2 resulting subpartition can be specified for SPLIT SUBPARTITION

Cause: ALTER TABLE SPLIT SUBPARTITION contained more than 2 resulting subpartition for the SPLIT.

Action: Ensure that the statement describes exactly 2 subpartitions as the target of the SPLIT operation.

ORA-14637 cannot merge a subpartition with itself

Cause: The same subpartition name was specified twice for the merge operation.

Action: Re-submit operation with 2 distinct subpartition names within the same composite partition.

ORA-14638 cannot MERGE subpartitions in different Range Composite partitions

Cause: An attempt was made to MERGE subpartitions in different Range Composite partitions.

Action: Re-issue the command after ensuring that the 2 subpartitions being merged lie within the same composite partition.

ORA-14639 SUBPARTITIONS clause can be specified only for Hash, Composite Range Hash table/partition

Cause: Attempted to specify SUBPARTITIONS clause on table that is not partitioned by the Composite Range-Hash method.

Action: Re-issue the command after ensuring that the SUBPARTITIONS clause is not specified. To specify a template for a Composite Range List object use the SUBPARTITION TEMPLATE clause.

ORA-14640 DROP/SPLIT SUBPARTITION may not be applied to a LOCAL index subpartition

Cause: User attempted to drop or split a subpartition of a LOCAL index which is illegal.

Action: Issue the statement on a table subpartition instead.

ORA-14641 STORE-IN clause can be specified only for a Hash, Composite Range Hash table/partition

Cause: Specifying a STORE-IN clause during CREATE/ALTER of a Range, Composite Range List partitioned table which is not allowed.

Action: Re-issue the statement after removing the STORE-IN clause.

ORA-14642 Bitmap index mismatch for tables in ALTER TABLE EXCHANGE PARTITION

Cause: The two tables in the EXCHANGE have usable bitmap indexes, and the INCLUDING INDEXES option has been specified and the tables have different hakan factors.

Action: Perform the exchange with the EXCLUDING INDEXES option or alter the bitmap indexes to be unusable.

ORA-14643 Hakan factor mismatch for tables in ALTER TABLE EXCHANGE PARTITION

Cause: Either records_per_block has been minimized for one of the tables to be exchanged, but not the other, or the hakan factors for the tables to be exchanged are not equal.

Action: If records_per_block has been minimized for one of the tables, but not the other, either perform alter table with the NOMINIMIZE RECORDS_PER_BLOCK option for both tables, or perform alter table with the MINIMIZE RECORDS_PER_BLOCK for both tables. If the hakan factors do not match, then perform alter table with the NOMINIMIZE RECORDS_PER_BLOCK option for both tables.

ORA-14644 table is not subpartitioned by Hash method

Cause: A subpartition maintenance operation such as ALTER TABLE MODIFY PARTITION COALESCE SUBPARTITION can only be performed on Hash subpartitioned objects.

Action: Re-issue the command against a Hash subpartitioned object.

ORA-14645 STORE IN clause cannot be specified for Range List objects

Cause: A STORE IN clause was specified for Range List partitioned object.

Action: Re-issue the command after removing the STORE IN clause.

ORA-16000 database open for read-only access

Cause: The database has been opened for read-only access. Attempts to modify the database using inappropriate DML or DDL statements generate this error.

Action: In order to modify the database, it must first be shut down and reopened for read-write access.

ORA-16001 database already open for read-only access by another instance

Cause: The database has been opened for read-only access by another instance, and cannot be opened for read-write access by this instance.

Action: This instance must be opened for read-write access, or all other instances must first be shut down and reopened for read-only access.

ORA-16002 database already open for read-write access by another instance

Cause: The database has been opened for read-write access by another instance, and cannot be opened for read-only access by this instance.

Action: This instance must be opened for read-only access, or all other instances must first be shut down and reopened for read-write access.

ORA-16003 standby database is restricted to read-only access

Cause: To ensure its integrity, a standby database can only be opened for read-only access.

Action: reissue the ALTER DATABASE OPEN specifying READ ONLY.

ORA-16004 backup database requires recovery

Cause: The control file is for a backup database which requires recovery, and cannot be opened for read-only access by this instance.

Action: Perform the necessary recovery and re-open for read-only access.

ORA-16005 database requires recovery

Cause: The database requires recovery, and therefore cannot be opened for read-only access by this instance.

Action: Perform the necessary recovery and re-open for read-only access.

ORA-16006 audit_trail destination incompatible with database open mode

Cause: The AUDIT_TRAIL initialization parameter was set to "DB" (or TRUE), which is incompatible with a database opened for read-only access.

Action: When the database is opened for read-only access, the AUDIT_TRAIL initialization parameter can only be set to "OS" or "NONE" (FALSE).

ORA-16007 invalid backup control file checkpoint

Cause: The backup control file being opened for read-only access does not contain a valid control file checkpoint. Therefore the database cannot be opened for read-only access.

Action: First open the database for read-write access which will result in a valid control file checkpoint. Then re-open the database for read-only access.

ORA-16008 indeterminate control file checkpoint

Cause: The control file for the database being opened for read-only access was created via CREATE CONTROLFILE. Therefore a control file checkpoint could not be calculated and the database cannot be opened for read-only access.

Action: First open the database for read-write access which will result in a valid control file checkpoint. Then re-open the database for read-only access.

ORA-16009 remote archive log destination must be a STANDBY database

Cause: The database associated with the archive log destination service name is other than the required STANDBY type database. Remote archival of redo log files is not allowed to non-STANDBY database instances.

Action: Take the necessary steps to create the required compatible STANDBY database before retrying the ARCHIVE LOG processing.

ORA-16010 remote archive log destination database is opened for update

Cause: The database associated with the archive log destination service name is opened for update access. Remote archival of redo log files to standby databases opened for update access is not allowed.

Action: Shut down the standby destination instance and re-open for read-only access or simply leave the standby instance mounted and unopened.

ORA-16011 Archivelog Remote File Server process in Error state

Cause: The archivelog remote file server (RFS) process at the specified standby database site has experienced an unrecoverable error and is unable to receive further archive log data.

Action: Correct the problem at the standby database site.

ORA-16012 Archive log standby database identifier mismatch

Cause: The database identifiers of the Primary and Standby database do not match. Remote archival of redo log files is not allowed to incompatible STANDBY database instances.

Action: Take the necessary steps to create the required compatible STANDBY database before retrying the ARCHIVE LOG processing.

ORA-16013 log string sequence# string does not need archiving

Cause: An attempt was made to archive the named file manually, but the file did not require archiving. The file had previously been successfully archived.

Action: No action is required.

ORA-16014 log string sequence# string not archived, no available destinations

Cause: An attempt was made to archive the named log, but the archive was unsuccessful. The archive failed because there were no archive log destinations specified or all destinations experienced debilitating errors.

Action: Verify that archive log destinations are being specified and/or take the necessary step to correct any errors that may have occurred.

ORA-16015 log string sequence# string not archived, media recovery disabled

Cause: An attempt was made to archive the named log, but the archive was unsuccessful. A standby archive log destination was specified and the database was not media recovery enabled. This is not allowed.

Action: Disable the standby destination or enable media recovery and retry.

ORA-16016 archived log for thread string sequence# string unavailable

Cause: The managed standby database recovery operation has timed out waiting for the requested archived log file.

Action: Verify that the primary database is still archiving redo logs to the standby recovery database site and reissue the RECOVER STANDBY DATABASE WAIT command.

ORA-16017 cannot use LOG_ARCHIVE_DUPLEX_DEST without a primary archive destination

Cause: The LOG_ARCHIVE_DUPLEX_DEST parameter was set to a non-NULL value when the primary archive destination was explicitly set to NULL.

Action: Set the primary archive destination to a valid non-NULL value.

ORA-16018 cannot use string with LOG_ARCHIVE_DEST_n

Cause: One of the following events caused an incompatibility:

  • The LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST initialization parameter was in use when a LOG_ARCHIVE_DEST_n parameter (n = 1, 2, ... 10) was encountered while fetching initialization parameters.
  • An ALTER SYSTEM ARCHIVE LOG START TO command was in effect when a LOG_ARCHIVE_DEST_n parameter was encountered while fetching initialization parameters.
  • A LOG_ARCHIVE_DEST_n parameter was in use when an ALTER SYSTEM statement was used to define a value for either the LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST parameter.

Action: Eliminate any incompatible parameter definitions.

ORA-16019 cannot use string with LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST

Cause: One of the following events caused an incompatibility:

  • The LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST initialization parameter was in use when the specified LOG_ARCHIVE_DEST_n parameter (n = 1, 2, ... 10) was encountered while fetching initialization parameters.
  • The LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST initialization parameter was in use when an attempt was made to use an ALTER SYSTEM or ALTER SESSION statement to define a value for the specified LOG_ARCHIVE_DEST_n parameter.
  • An ALTER SYSTEM ARCHIVE LOG START TO statement was in effect when the specified LOG_ARCHIVE_DEST_n parameter was encountered while fetching initialization parameters.
  • An ALTER SYSTEM ARCHIVE LOG START TO command was in effect when an attempt was made to use an ALTER SYSTEM or ALTER SESSION command to define a value for the specified LOG_ARCHIVE_DEST_n parameter.

Action: Eliminate any incompatible parameter definitions.

ORA-16020 less destinations available than specified by LOG_ARCHIVE_MIN_SUCCEED_DEST

Cause: With automatic archiving enabled, the number of archive log destinations that could be used for the database was less than the LOG_ARCHIVE_MIN_SUCCEED_DEST parameter value.

Action: Either adjust the settings of the log archive destination parameters, or lower the value of LOG_ARCHIVE_MIN_SUCCEED_DEST.

ORA-16021 session string destination cannot be the same as session string destination

Cause: An attempt was made to change the first specified archive log parameter using ALTER SESSION to have a destination value that duplicates the session-level destination value of the second specified archive log parameter.

Action: Specify a different session destination value for one of the LOG_ARCHIVE_DEST_n parameters.

ORA-16022 LOG_ARCHIVE_DEST cannot be NULL because LOG_ARCHIVE_DUPLEX_DEST is non-NULL

Cause: An attempt was made to change the LOG_ARCHIVE_DEST initialization parameter to NULL when the LOG_ARCHIVE_DUPLEX_DEST initialization parameter is non-NULL.

Action: Either set the LOG_ARCHIVE_DEST initialization parameter to a non-NULL value, or set the LOG_ARCHIVE_DUPLEX_DEST initialization parameter to a NULL value.

ORA-16023 system string destination cannot be the same as session string destination

Cause: An attempt to change the first specified LOG_ARCHIVE_DEST_n parameter (n = 1, 2, ... 10) produced a destination that duplicates the session destination value of the second specified LOG_ARCHIVE_DEST_n parameter. This error can occur when setting a non-NULL value with the ALTER SYSTEM statement. Or, this error can occur when setting a NULL value with ALTER SESSION command, because then the associated system destination value may appear as a duplicate.

Action: Specify a different destination value for the first specified LOG_ARCHIVE_DEST_n parameter.

ORA-16024 parameter string cannot be parsed

Cause: The value for the indicated LOG_ARCHIVE_DEST_n parameter (n = 1, 2, ... 10) could not be parsed. Common causes for this error are a misplaced equal sign, an unrecognized attribute, or an attribute that is missing a required value.

Action: Correct the value for the indicated LOG_ARCHIVE_DEST_n parameter.

ORA-16025 parameter string contains repeated or conflicting attributes

Cause: The value for the specified LOG_ARCHIVE_DEST_n parameter (n = 1, 2, ... 10) contained either repeated attributes or attributes that conflicted with each other.

Action: Correct the value for the indicated LOG_ARCHIVE_DEST_n parameter.

ORA-16026 parameter string contains an invalid numeric attribute value

Cause: The value for the specified LOG_ARCHIVE_DEST_n parameter (n = 1, 2, ... 10) contained a REOPEN attribute with an invalid numeric value. The valid range is 0 - 65535.

Action: Correct the value for the indicated LOG_ARCHIVE_DEST_n parameter.

ORA-16027 parameter string is missing a destination option

Cause: The value for the indicated LOG_ARCHIVE_DEST_n parameter (n = 1, 2, ... 10) failed to include a destination option. A destination option is specified using either the LOCATION or SERVICE attribute.

Action: Correct the value for the indicated LOG_ARCHIVE_DEST_n parameter.

ORA-16028 new string causes less destinations than LOG_ARCHIVE_MIN_SUCCEED_DEST requires

Cause: With automatic archiving enabled, an attempt was made to change the indicated LOG_ARCHIVE_DEST_n or a LOG_ARCHIVE_DEST_STATE_n parameter (n = 1, 2, ... 10) to a value that reduces the number of archive log destinations to less than the specified LOG_ARCHIVE_MIN_SUCCEED_DEST value.

Action: Either select different options for the LOG_ARCHIVE_DEST_n or LOG_ARCHIVE_DEST_STATE_n parameters, or reduce the value for the LOG_ARCHIVE_MIN_SUCCEED_DEST parameter.

ORA-16029 cannot change LOG_ARCHIVE_MIN_SUCCEED_DEST, no archive log destinations

Cause: An attempt was made to change the LOG_ARCHIVE_MIN_SUCCEED_DEST parameter when there are no archive log destinations.

Action: Define one or more log archive destinations using the LOG_ARCHIVE_DEST, LOG_ARCHIVE_DUPLEX_DEST, or LOG_ARCHIVE_DEST_n parameters (n = 1, 2, ... 10). Then, change the value of the LOG_ARCHIVE_MIN_SUCCEED_DEST parameter.

ORA-16030 session specific change requires a LOG_ARCHIVE_DEST_n destination

Cause: The following event caused an incompatibility: Parameter LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST was in use when an attempt was made to change the LOG_ARCHIVE_MIN_SUCCEED_DEST parameter with an ALTER SESSION statement.

Action: Replace any LOG_ARCHIVE_DEST and LOG_ARCHIVE_DUPLEX_DEST parameters with LOG_ARCHIVE_DEST_n (n = 1, 2, ... 10) parameters.

ORA-16031 parameter string destination string exceeds string character limit

Cause: The value for the specified parameter contained a destination string that is too long.

Action: Replace the destination value for the specified parameter with a character string that has a length below the limit specified in the error message.

ORA-16032 parameter string destination string cannot be translated

Cause: The value for the specified parameter contained a destination string that could not be translated.

Action: Use a valid destination string in the specified parameter.

ORA-16033 parameter string destination cannot be the same as parameter string destination

Cause: An attempt was made to change the first specified archive log parameter to have a destination value that duplicates the system-level destination value of the second specified archive log parameter.

Action: Specify a different value for one of the archive log parameters.

ORA-16034 FROM parameter is incompatible with MANAGED recovery

Cause: Use of the FROM 'location' parameter is not allowed when MANAGED recovery has been specified.

Action: Correct the syntax and retry the command.

ORA-16035 missing required keyword string

Cause: The indicated keyword is required but was not specified.

Action: Correct the syntax and retry the command.

ORA-16036 invalid MANAGED recovery CANCEL option

Cause: A mode other than IMMEDIATE follows the CANCEL keyword in RECOVER MANAGED STANDBY DATABASE statement.

Action: Specify either nothing or IMMEDIATE following CANCEL.

ORA-16037 user requested cancel of managed recovery operation

Cause: The managed standby database recovery operation has been canceled per user request.

Action: No action is required.

ORA-16038 log string sequence# string cannot be archived

Cause: An attempt was made to archive the named file, but the file could not be archived. Examine the secondary error messages to determine the cause of the error.

Action: No action is required.

ORA-16039 RFS request version mismatch

Cause: A request to archive a redo log to a standby site failed because the request was incompatible with the Remote File Server (RFS) at the standby site.

Action: Verify that compatible versions of Oracle are running on the primary and all standby sites.

ORA-16040 standby destination archive log file is locked

Cause: The target standby destination archive log file is currently locked. This indicates that the file is being archived to by another Remote File Server (RFS) process.

Action: Check for and eliminate duplicate standby destination archive log service names defined for the primary database.

ORA-16041 Remote File Server fatal error

Cause: The Remote File Server (RFS) process at the standby destination archive log site has encountered a disabling error and is no longer available. Further archiving to the standby site may not be possible.

Action: Refer to the appropriate RFS trace file located at the standby site for details regarding the error encountered and if possible, take corrective action.

ORA-16042 user requested cancel immediate of managed recovery operation

Cause: The managed standby database recovery operation has been canceled immediately per user request. Processing of the current archive log file has been interrupted and therefore the database is in an inconsistent state.

Action: No action required.

ORA-16043 managed recovery session canceled

Cause: The standby database managed recovery operation has been canceled per user request or operation timeout.

Action: More specific messages will accompany this message.

ORA-16044 destination string attribute cannot be specified at session level

Cause: An archive log destination attribute was attempted to be modified at the session level.

Action: Use the ALTER SYSTEM command to modify the destination attribute.

ORA-16045 circular archive log destination dependency chain

Cause: An archive log destination contains a dependency to another archive log destination that also contains a dependency.

Action: The parent archive log destination cannot be dependent on another archive log destination. Use the ALTER SYSTEM statement to remove one of the dependency attributes.

ORA-16046 Archive log destination failed due to failed dependent destination

Cause: The archive log destination is dependent upon another destination, which has failed. Therefore, this destination also fails.

Action: No action required.

ORA-16047 Dependent archive log destination cannot be a standby database

Cause: The parent archive log destination cannot be a standby database. It must be a local archive log destination.

Action: Change the parent archive log destination from referencing a standby database to referencing a local archive log repository.

ORA-16048 enable simulated error on archive log write

Cause: Causes an I/O error to be signalled during the writing of an archival operation.

Action: No action required.

ORA-16049 simulated error on archive log write

Cause: I/O error returned for a simulated archival failure during an archival operation.

Action: No action required.

ORA-16050 destination exceeded specified quota size

Cause: An archive log was attempted to be created in a destination with a specified maximum quota size. The creation of the archive log exceeded the specified quota size. Therefore, the destination has been made inaccessible to future archival operations.

Action: No action required.

ORA-16051 parameter string contains an invalid delay time

Cause: The value for the specified LOG_ARCHIVE_DEST_n (n = 1...10) parameter contained a DELAY attribute with an invalid numeric value. The valid range is 0-5760 (in minutes).

Action: Correct the value for the indicated LOG_ARCHIVE_DEST_n parameter.

ORA-16052 Problem with fetching gap sequence, media recovery cancelled.

Cause: A gap sequence is detected on the standby database while it was trying to perform managed standby recovery. The fetching of the gap sequence fails. The failures are logged in the alert log on the primary database.

Action: Check the alert log on primary and standby database. Take appropriate action to make the gap sequence available again. Managed standby recovery on the standby database cannot proceed further until the standby database is able to get the gap sequence redo log files.

ORA-16053 FAL archive failed, cannot archive thread# string sequence# string

Cause: The FAL server on the primary database has problem archiving a redo log file requested by the standby database. The cause for this failure is logged in the alert log file.

Action: Check the alert log on the primary database. Take the appropriate action to solve the problem. Re-issue Managed Standby Recovery on the standby database again.

ORA-16055 FAL request rejected

Cause: FAL server rejects the FAL request from the FAL client. This may be caused by different reasons.

Action: Check the alert log on the primary database. Take the appropriate action to solve the problem.

ORA-16056 backup control file archival requires proper syntax

Cause: An attempt was made to perform an online log file archival using a backup control file. However, the USING BACKUP CONTROLFILE syntax was not specified.

Action: If the archival operation is correct when using a backup control file, then the USING BACKUP CONTROLFILE syntax is required.

ORA-16057 current control file archival requires proper syntax

Cause: An attempt was made to perform an online log file archival using a current control file. However, the USING BACKUP CONTROLFILE syntax was specified.

Action: If the archival operation is correct when using a current control file, then the USING BACKUP CONTROLFILE syntax is not required.

ORA-16058 standby database instance is not mounted

Cause: The RFS process on the standby database received an internal error.

Action: Check the standby alert log and RFS trace files for more information.

ORA-16059 Log file is empty or invalid next available block

Cause: Archiving not allowed of an empty or invalid log file.

Action: No action required.

ORA-16060 Log file is current

Cause: The current log file cannot be archived using its file name.

Action: No action required.

ORA-16061 Log file status has changed

Cause: It is possible the online log file was reclaimed as a new log file either before archival started, or during the archival operation.

Action: No action required.

ORA-16062 The log was NOT archived

Cause: Archiving not allowed of current log file.

Action: Check the alert log and archive trace files for additional information.

ORA-16063 remote archival is enabled by another instance

Cause: Remote archival of database REDO log files has been enabled by another instance, and cannot be disabled for this instance.

Action: Set the REMOTE_ARCHIVE_ENABLE parameter to true and restart this instance.

ORA-16064 remote archival is disabled by another instance

Cause: Remote archival of database REDO log files has been disabled by another instance, and cannot be enabled for this instance.

Action: Set the REMOTE_ARCHIVE_ENABLE parameter to false and restart this instance.

ORA-16065 remote archival disabled at standby destination

Cause: Receipt of remote archived REDO log files has been disabled at the associated standby destination host database.

Action: If appropriate, change the associated archive log parameter to specify a local destination with the LOCATION keyword or defer the associated archive log destination. Or, if possible, set the standby REMOTE_ARCHIVE_ENABLE parameter to true and restart the standby database instance before further REDO log file archivals occur.

ORA-16066 remote archival disabled

Cause: An archive log destination parameter has specified a remote destination with the SERVICE keyword. Remote archival of REDO log files has been disabled for this database. The associated archive log destination has been disabled.

Action: If appropriate, change the archive log parameter to specify a local destination with the LOCATION keyword or (if appropriate) set the REMOTE_ARCHIVE_ENABLE parameter to true and restart the database instance before further REDO log file archivals occur.

ORA-16067 activation identifier mismatch in archive log string

Cause: The activation identifier contained in the archive log file header does not match the activation identifier of the database being recovered. The indicated archive log cannot be applied to the database.

Action: Locate the appropriate archive log for the database.

ORA-16068 redo log file activation identifier mismatch

Cause: The activation identifier of the indicated redo log file does not match the activation identifier of the database.

ORA-16069 Archive Log standby database activation identifier mismatch

Cause: The activation identifiers of the Primary and Standby database do not match. Remote archival of redo log files is not allowed to incompatible STANDBY database instances. This can occur when trying to apply an incorrect archive log to a standby database, or when trying to archive to a standby database that does not match the primary database.

Action: Take the necessary steps to create the required compatible STANDBY database before retrying the ARCHIVE LOG processing.

ORA-16070 parameter string contains an invalid REGISTER attribute value

Cause: The value for the specified LOG_ARCHIVE_DEST_n (n = 1...10) parameter contained a REGISTER attribute that specified an invalid file name template string. If specified, the REGISTER file name template string must indicate an operating system-specific file path name including thread and log sequence number substitution directives (%t, %T, %s, %S).

Action: Correct the value for the LOG_ARCHIVE_DEST_n parameter.

ORA-16071 dependency archived log file not found string

Cause: The specified archived log file was not found at the indicated standby destination.

Action: Verify the correctness of the dependency archived log file name template specified for the indicated standby destination against the actual dependency archived log file.

ORA-16072 a minimum of one standby database destination is required

Cause: No standby database archive log destinations were specified.

Action: Specify a standby archive log destination in the initialization parameter file.

ORA-16073 archiving must be enabled

Cause: Online log file archiving is disabled.

Action: Enable log file archiving.

ORA-16074 ARCH processes must be active

Cause: There are no active ARCH processes.

Action: It is required that at least one ARCH process be active.

ORA-16075 standby database destination mismatch

Cause: A standby database destination was specified that is not accessed by another instance.

Action: All database instances must access the same standby databases.

ORA-16076 unknown standby database destination

Cause: A standby database destination was specified that is not accessed by another instance.

Action: All database instances must access the same standby databases.

ORA-16078 media recovery disabled

Cause: The database is not in ARCHIVELOG mode.

Action: Place the database in ARCHIVELOG mode.

ORA-16079 standby archival not enabled

Cause: The standby database does not have archival enabled.

Action: In order to allow the standby database to access the standby log files, the ARCH process must be enabled and active.

ORA-16080 invalid LogMiner session string for APPLY

Cause: Logical standby apply engine was started with an invalid LogMiner session identifier.

Action: Fix the problem with the LogMiner session or create a new session.

ORA-16081 insufficient number of processes for APPLY

Cause: Logical standby apply engine was started with fewer processes available than needed.

Action: Increase the values of the initialization parameters PROCESSES and PARALLEL_MAX_SERVERS, or the MAX_SLAVES parameter seen in the DBA_LOGSTDBY_PARAMETERS view.

ORA-16082 logical standby is not initialized correctly

Cause: Logical standby apply engine was started but it found inconsistencies in its metadata.

Action: Look in the trace file for more information.

ORA-16083 LogMiner session has not been created

Cause: Logical standby apply engine was started without creating a LogMiner session.

Action: Create a LogMiner session and restart the apply engine.

ORA-16084 an apply engine is already running

Cause: A logical standby apply engine was running when another was created.

Action: Shut down the previous apply engine before starting a new one.

ORA-16086 standby database does not contain available standby log files

Cause: The primary database is in "no data loss" mode, but the standby database does not contain any "standby log files".

Action: Add one or more standby log files to the standby database. This can be done while the standby database is mounted.

ORA-16087 graceful switchover requires standby or current control file

Cause: An attempt was made to perform a graceful switchover operation using a backup or clone control file.

Action: Convert the backup control file into a current control file prior to attempting a graceful switchover operation. A clone control file cannot be used for a graceful switchover operation.

ORA-16088 archive log has not been completely archived

Cause: An attempt was made to register an archive log that has not been completely archived. The specified archive log may be a "current" log file.

Action: Specify a completed archive log.

ORA-16089 archive log has already been registered

Cause: An attempt was made to register an archive log that already has a corresponding thread# and sequence# entry in the standby database control file. Duplicate information is not permitted.

Action: Use the V$ARCHIVED_LOG fixed view to verify the archive log information.

ORA-16090 archive log to be replaced not created by managed standby process

Cause: An attempt was made to replace an archive log entry that was not originally created by the managed standby operation.

Action: No user action required.

ORA-16091 dependent archive log destination already archived

Cause: An archive log destination contains a dependency to another archive log destination that has previously been archived.

Action: The parent archive log destination cannot be dependent on another archive log destination. Use the ALTER SYSTEM statement to remove one of the dependency attributes.

ORA-16092 dependent archive log destination is not active

Cause: An archive log destination contains a dependency to another archive log destination that is not active.

Action: The child archive log destination cannot be dependent on another invalid archive log destination. Use the ALTER SYSTEM statement to remove one of the dependency attributes.

ORA-16093 dependent archive log destination is not LGWR-enabled

Cause: An archive log destination contains a dependency to another archive log destination that is not enabled for the LGWR process.

Action: The child archive log destination cannot be dependent on another archive log destination not archived by the LGWR. Use the ALTER SYSTEM statement to change the parent archive log to specify the LGWR process.

ORA-16094 database shutdown during archival operation

Cause: The database was shut down while an online log file archival was active.

Action: No action required. The ARCH process is terminated.

ORA-16095 Dependent destination removal for inactivation

Cause: A dependent archive log destination was inactivated due to the parent archive log destination becoming inelligible for archival. This may be due to the parent destination being manually deferred by an application user.

Action: No action required.

ORA-16098 inaccessible standby database forced shutdown to protect primary

Cause: No standby database archive log destinations remain accessible and the primary database is in "protected" no-data-loss mode.

Action: Specify an alternate standby archive log destination in the initialization parameter file.

ORA-16099 internal error ORA-00600 occurred at standby database

Cause: The RFS process on the standby database received an internal error.

Action: Check the standby alert log and RFS trace files for more information.

ORA-16100 not a valid Logical Standby database

Cause: This database has not been completely configured as a Logical Standby database.

Action: Verify that the database is the intended Logical Standby database. Ensure that you already started logical standby apply with the ALTER DATABASE START LOGICAL APPLY INITIAL statement. See the Oracle9i SQL Reference for the statement syntax.

ORA-16101 a valid start SCN could not be found

Cause: An SCN from which to start could not be found.

Action: Register the first log file following the backup from which this database was generated. Using the ALTER DATABASE REGISTER LOGFILE statement to register the database is recommended. Alternatively, you can provide a starting SCN value with this statement.

ORA-16102 remote information is not available on the specified primary

Cause: The new primary has not completed generating the necessary information for the standby to begin consuming its log stream.

Action: Verify that the database link provided references a system that is about to become a new primary. Wait a short time before retrying the command to allow the primary some time to generate the necessary information.

ORA-16103 Logical Standby apply must be stopped to allow this operation

Cause: Logical Standby is currently applying changes. The apply must complete or be stopped to allow the requested operation.

Action: Execute the ALTER DATABASE STOP LOGICAL STANDBY APPLY statement, then re-enter or re-specify the operation.

ORA-16104 invalid Logical Standby option requested

Cause: The option requested is not valid.

Action: Check spelling or refer to the Oracle9i SQL Reference for the correct statement syntax, then re-enter the request.

ORA-16105 Logical Standby is already running in background

Cause: A Logical Standby apply operation is already running.

Action: no action required.

ORA-16107 all log data from primary has been processed

Cause: On the primary system, the log stream has been ended by the ALTER DATABASE PREPARE TO SWITCHOVER TO LOGICAL STANDBY statement.

Action: Issue one of the following statements to make this standby a primary or resume applying changes from a new primary:

ALTER DATABASE PREPARE TO SWITCHOVER TO LOGICAL PRIMARY;ALTER DATABASE START LOGICAL STANDBY APPLY NEW PRIMARY dblink;

ORA-16108 database is no longer a standby database

Cause: The current database has already been made a primary database.

Action: Issue the following statements to make this primary a standby:

ALTER DATABASE PREPARE TO SWITCHOVER TO LOGICAL STANDBY;ALTER DATABASE START LOGICAL STANDBY APPLY NEW PRIMARY dblink;

ORA-16109 failed to apply log data from previous primary

Cause: Log data from previous primary could not be completely applied.

Action: Check DBA_LOGSTDBY_EVENTS for failures and take corrective action. Then, re-issue command.

ORA-16110 user procedure processing of logical standby apply DDL

Cause: A user provided stored procedure has been called to inspect a DDL statement prior to it being processed.

Action: No action required; this informational statement is provided to record user involvement in the processing of a statement. Additional information can be found in the DBA_LOGSTDBY_EVENTS and the DBA_LOGSTDBY_SKIP views.

ORA-16111 log mining and apply setting up

Cause: This logical standby process is setting up to begin processing changes.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16112 log mining and apply stopping

Cause: This logical standby process is cleaning up and stopping Logical Standby apply.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16113 applying change to table or sequence object number string

Cause: The process is applying changes to a specific schema object.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16114 applying DDL transaction with commit SCN string

Cause: The process is applying a DDL change that's committed at the given SCN.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16115 loading Log Miner dictionary data

Cause: The process is loading dictionary information from the redo stream. This activity may take a few minutes.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16116 no work available

Cause: The process is idle waiting for additional changes to be made available.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16117 processing

Cause: The process is performing its primary function and is not waiting on any significant event.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16119 building transaction at SCN string

Cause: The transaction being committed at the given SCN is being prepared for apply.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16120 dependencies being computed for transaction at SCN string

Cause: The transaction committed at the given SCN is being analyzed for dependencies.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16121 applying transaction with commit SCN string

Cause: The transaction committed at the given SCN is being applied.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16122 applying large dml transaction at SCN string

Cause: A large transaction is being applied before the commit has been seen. The current redo being applied ends as the given SCN.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16123 transaction string string string is waiting for commit approval

Cause: The apply process is waiting for approval to commit a transaction. This transaction may depend on another or other synchronization activity may delay the committing of a transaction.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16124 transaction string string string is waiting on another transaction

Cause: The apply process is waiting to apply additional changes. This transaction likely depends on another.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16125 large transaction string string string is waiting on another transaction

Cause: The apply process is waiting until additional changes for a large transaction are retrieved from the log stream.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16126 loading table or sequence object number string

Cause: Information on the given table or sequence is being loaded into an in memory cache for future use.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16127 stalled waiting for additional transactions to be applied

Cause: This process is waiting for additional memory before continuing. Additional log information cannot be read into memory until more transactions have been applied to the database, thus freeing up additional memory.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes. If this message occurs often and changes are not being applied quickly, then increase available SGA or the number of apply processes.

ORA-16128 User initiated shut down successfully completed

Cause: Logical standby was shutdown in an orderly fashion.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16129 unsupported dml encountered

Cause: DML to tables in the SYS schema have been updated and are not part of a DDL operation. This may be due to some DBA activity or DML associated with a kernel PL/SQL request that Logical Standby does not yet support.

Action: Check the DBA_LOGSTDBY_EVENTS table for the name of the table being processed. Possibly use Log Miner to understand the transaction, and provide a compensating transaction on the standby system. Once complete, call DBMS_LOGSTDBY.SKIP_TRANSACTION with the associated transaction id, and resume apply.

ORA-16130 supplemental log information is missing from log stream

Cause: Supplemental logging is not enabled at the primary database.

Action: Issue the following statement to enable supplemental logging:

ALTER DATABASE ADD SUPPLEMENTAL LOG DATA (PRIMARY KEY, UNIQUE INDEX) COLUMNS;

ORA-16131 An error occurred during a Terminal Recovery of the standby.

Cause: An error occurred during a Terminal Recovery of the standby.

Action: Check the standby alert log additional information.

ORA-16132 An error occurred during activation of the standby.

Cause: An error occurred during activation of the standby database following a Terminal Recovery.

Action: Check the standby alert log additional information.

ORA-16133 Datafile string has incorrect terminal recovery stamp.

Cause: After activation of a standby database following a terminal recovery (recovery of standby using current logs), recovery of a datafile from before the activation must have completed the same terminal recovery to avoid corruption.

Action: A backup of the datafile taken after the terminal recovery and before activating the standby must be used for recovery.

ORA-16134 invalid MANAGED recovery FINISH option

Cause: A mode other than NOWAIT follows the FINISH keyword in the RECOVER MANAGED STANDBY DATABASE statement.

Action: Specify either nothing or NOWAIT following FINISH.

ORA-16135 terminal recovery could not find log for thread# string seq# string.

Cause: A terminal recovery (initiated by the RECOVER MANAGED STANDBY FINISH command) could not find the current log for the requested thread and sequence.

Action: Check that the standby current logs are in the correct location.

ORA-16136 Managed Standby Recovery not active

Cause: An attempt was made to cancel a managed recovery session but no managed recovery session was active.

Action: No action required.

ORA-16137 No terminal recovery is required

Cause: All archived logs have been applied, and there are no current logs to be applied. Terminal recovery is not required.

Action: No action required. The standby database may be activated as a new primary or may continue as a standby.

ORA-16138 end of log stream not received from primary

Cause: The standby system has not received notification that the primary system log stream has been terminated. A graceful switchover is not possible.

Action: Verify that the primary log stream has been terminated. Ensure that the standby has applied all necessary redo from the primary system and, if appropriate, reissue the graceful switchover command.

ORA-16139 media recovery required

Cause: The database has not been recovered through the end of log stream. Graceful switchover is not possible.

Action: Ensure that the entire log stream has been applied. If appropriate, re-issue the graceful switchover command.

ORA-16140 standby online logs have not been recovered

Cause: The standby database has online logs containing redo that has not been recovered. Activating the standby would lose redo contained in the online logs.

Action: To recover the standby online logs issue the following command:

ALTER DATABASE RECOVER MANAGED STANDBY DATABASE FINISH;

Then re-issue the ALTER DATABASE ACTIVATE STANDBY DATABASE statement. To activate the standby without recovering the online logs, issue the following command:

ALTER DATABASE ACTIVATE STANDBY DATABASE SKIP STANDBY LOGFILE;

ORA-16143 RFS connections not allowed during or after terminal recovery

Cause: An attempt was made, by an RFS process, to access a standby online log file during or after a terminal recovery.

Action: The primary must not attempt to archive to the standby after a terminal recovery.

ORA-16145 archival for thread# string sequence# string in progress

Cause: The indicated archived log file is not available for recovery due to the fact that it is still being archived.

Action: Verify that archival of the indicated log file has completed and re-issue the RECOVER STANDBY DATABASE command.

ORA-16146 standby destination control file enqueue unavailable

Cause: The target standby destination control file is currently unavailable to the Remote File Server (RFS) process. This indicates that the target destination is the primary database itself.

Action: Check for and eliminate the standby destination archive log parameter in question.

ORA-16147 standby database referenced by multiple archive log destinations

Cause: Multiple archive log destinations reference the same standby database, using different service names. This is not allowed.

Action: Remove one of the duplicate archive log destinations.

ORA-16148 user requested expiration of managed recovery operation

Cause: The managed standby database recovery operation has been canceled per user specified EXPIRE option of the RECOVER MANAGED STANDBY DATABASE statement.

Action: No action required.

ORA-16150 FINISH recovery performed on another, older standby database

Cause: An archive log containing a FINISH recovery indicator was received by a standby database that has received archive logs in the future of the received archive log. Because of the possibility that these future archive logs have been applied to this standby database, the received archive log must be rejected.

Action: No action required.

ORA-16151 Managed Standby Recovery not available

Cause: The attempted operation failed because of a pending CANCEL of the managed standby recovery operation.

Action: Wait for the managed standby recovery session to end. Then retry the operation.

ORA-16152 standby database is in 'no-data-loss' protected mode

Cause: The attempted database operation is not allowed while the standby database is in 'no-data-loss' protected mode.

Action: Verify that the attempted database operation is warranted, ALTER DATABASE SET STANDBY DATABASE UNPROTECTED and re-issue the statement.

ORA-16154 suspect attribute: string

Cause: Use of the indicated attribute is illegal in the given context.

Action: Make the appropriate changes and re-issue the statement.

ORA-16156 LGWR archive log dependency not allowed if database is standby protected

Cause: The use of a LGWR archive log dependency is not allowed when the primary is protected by a standby database, as this requires use of the standby redo log files.

Action: Remove the LGWR archive log dependency and use normal LGWR archival instead.

ORA-16157 media recovery not allowed following successful FINISH recovery

Cause: A RECOVER MANAGED STANDBY DATABASE FINISH command has previously completed successfully. Another media recovery is not allowed.

Action: Issue one of these operations following a FINISH recovery:

ALTER DATABASE OPEN READ ONLY;ALTER DATABASE COMMIT TO SWITCHOVER TO PRIMARY;

ORA-16159 Cannot change protected standby destination attributes

Cause: An attempt was made to change the LGWR/ARCH or SYNC/ASYNC attributes for a destination that is participating in the standby protection mode of the database.

Action: No action required.

ORA-16160 Cannot change protected standby database configuration

Cause: An attempt was made to change the standby database configuration when the primary database is in standby protected mode.

Action: The standby database must be added to the configuration before the primary database is opened.

ORA-16161 Cannot mix standby and online redo log file members for group string

Cause: An attempt was made to add a log file member that does not match the other member types. This problem typically occurs when adding a standby log file member to an online redo logfile group, or adding an online redo log file member to a standby redo log file group.

Action: Verify the log file group type using the TYPE column of the V$LOG fixed view.

ORA-16162 Cannot add new standby databases to protected configuration

Cause: An attempt was made to enable a new standby database destination when the primary database is in standby protected mode.

Action: The standby database must be added to the configuration before the primary database is opened.

ORA-16163 LGWR network server host attach error

Cause: The LGWR network server could not attach to remote host.

Action: The alert log contains more problem-specific information.

ORA-16164 LGWR network server host detach error

Cause: The LGWR network server could not detach from remote host.

Action: The alert log contains more problem-specific information.

ORA-16165 LGWR failed to hear from network server

Cause: The LGWR lost its connection to the network server.

Action: The alert log contains more problem-specific information.

ORA-16166 LGWR network server failed to send remote message

Cause: The LGWR network server could not communicate with the remote host.

Action: The alert log contains more problem-specific information.

ORA-16167 LGWR network server could not switch to non-blocking mode

Cause: The LGWR network server could not switch to non-blocking mode.

Action: The alert log contains more problem-specific information.

ORA-16168 LGWR network server could not switch to blocking mode

Cause: The LGWR network server could not switch to blocking mode.

Action: The alert log contains more problem-specific information.

ORA-16169 LGWR network server invalid parameters

Cause: The LGWR network server could not switch to blocking mode.

Action: The alert log contains more problem-specific information.

ORA-16170 Parallel terminal recovery may lose more data than necessary

Cause: Serial terminal recovery can always recover the standby database to the last consistent point in the redo stream. Parallel terminal recovery cannot.

Action: Retry with serial terminal recovery.

ORA-16171 RECOVER...FINISH not allowed due to gap for the string, seq string-string

Cause: See alert log for more details.

Action: Copy missing archived logs from primary or another standby. Register the logs and re-issue the RECOVER...FINISH command. If the logs are not available, then issue the ALTER DATABASE RECOVER MANAGED STANDBY SKIP statement to ignore the standby redo log files.

ORA-16172 archive logs detected beyond Terminal End-Of-Redo

Cause: An attempt to archive a Terminal End-Of-Redo archive log to a remote destination failed due to the existence, at the remote site, of archive logs containing REDO in the future of the Terminal EOR.

ORA-16173 incompatible archival network connections active

Cause: One of two situations can cause this error:

  1. An attempt to start a Terminal Incomplete Recovery operation failed due to an active Remote File Server process detected.
  2. An attempt to archive a Terminal End-Of-Redo archive log to a remote destination failed due to an active Remote File Server process at the remote site.

    An active Remote File Server (RFS) process implies connectivity with the primary database which may indicate that a Terminal Incomplete Recovery operation is not warrented.

Action: Verify the Managed Standby environment and re-evaluate the necessity of a Terminal Incomplete Recovery operation.

ORA-16174 user requested thread/sequence termination of managed recovery

Cause: The managed standby database recovery operation has been terminated per user specified THROUGH THREAD/SEQUENCE option of the RECOVER MANAGED STANDBY DATABASE statement.

Action: No action required.

ORA-16175 cannot shut down database when media recovery is active

Cause: An attempt was made to shut down a standby database while media recovery was active.

Action: Cancel media recovery to proceed with the shutdown.

ORA-16199 Terminal recovery failed to recover to a consistent point

Cause: See alert log for more details.

Action: Try to resolve the problem. Retry terminal recovery. If the problem occurs repeatedly and cannot be resolved, then contact Oracle Support Services.

ORA-16200 Skip procedure requested to skip statement

Cause: Logical standby called a skip procedure that requested for a particular statement not to be applied.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16201 Skip procedure requested to apply statement

Cause: Logical standby called a skip procedure that requested for a particular statement to be applied.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16202 Skip procedure requested to replace statement

Cause: Logical standby called a skip procedure that requested for a particular statement to be replaced with a new statement.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16203 Unable to interpret skip procedure return values

Cause: The skip procedure returned conflicting or invalid values.

Action: Ensure that the new_statement output parameter is non-NULL when returning DBMS_LOGSTDBY.SKIP_ACTION_REPLACE, and NULL otherwise. Also ensure SKIP_ACTION is specified correctly.

ORA-16204 DDL successfully applied

Cause: A DDL statement has successfully committed on the logical standby database.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16205 DDL skipped due to skip setting

Cause: A setting in the logical standby skip table indicates that this type of DDL should always be skipped.

Action: No action required; this informational statement is provided to record the event for diagnostic purposes.

ORA-16206 database already configured as Logical Standby database

Cause: This database has been previously configured as a Logical Standby database. A Logical Standby database is not capable of processing the requested operation.

Action: Ensure that you entered the command on the correct database as this database is a Logical Standby and is not capable of servicing the request.

ORA-16207 Logical standby dictionary build not permitted.

Cause: A dictionary build is currently in progress. Only one build can be active at a time.

Action: Wait for the active build to complete before invoking a new build.

ORA-16208 Logical standby dictionary build failed to start.

Cause: Failure to start the logical standby dictionary build process (LSP1).

Action: Check the accompanying messages and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, then check the trace file for the mentioned process until the root message is found.

ORA-16209 Logical standby dictionary build failed to complete.

Cause: The logical standby dictionary build process terminated abnormally.

Action: Check the accompanying messages and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, then check the trace file for the mentioned process until the root message is found.

ORA-16210 Logical standby coordinator process terminated with error

Cause: The logical standby coordinator process terminated abnormally.

Action: Check the accompanying messages and the background process trace file. Correct the problem mentioned in the messages. Then shut down and restart the instance. If the trace file mentions any other background process messages, then check the trace file for the mentioned process until the root message is found.

ORA-16211 unsupported record found in the archived redo log

Cause: Log apply services encountered a record in the archived redo log that could not be interpreted.

Action:

  1. Use DBMS_LOGSTDBY.INSTANTIATE_TABLE to re-create the table on the standby database or simply drop the table if it's unimportant.
  2. ALTER DATABASE START LOGICAL STANDBY APPLY;
  3. Examine the current_scn column in the DBA_LOGSTDBY_EVENTS view to determine which log file contains the unsupported record.
  4. Provide the log file to Oracle Support Services.

ORA-16212 number processes specified for APPLY is too great

Cause: Logical standby apply engine was started with more processes requested than are available.

Action: Adjust the values of the initialization parameters PROCESSES and PARALLEL_MAX_SERVERS, or the MAX_SLAVES parameter seen in the DBA_LOGSTDBY_PARAMETERS view.

ORA-16213 ddl encountered, stopping apply engine

Cause: stop_on_ddl callout specified and DDL was encountered.

Action: Either disable stop_on_ddl callout or remove DDL.

ORA-16214 apply stalled for apply delay

Cause: A delay has been specified on the primary database for this destination.

Action: Either turn off the delay on the primary or use DBMS_LOGSTDBY.APPLY_UNSET('APPLY_DELAY'); to override.

ORA-16501 the Data Guard broker operation failed

Cause: The Data Guard broker operation failed.

Action: See other messages for details.

ORA-16502 the Data Guard broker operation succeeded with warnings

Cause: The Data Guard broker operation succeeded with warnings.

Action: See other messages for details.

ORA-16503 site ID allocation failure

Cause: Number of sites in the Data Guard configuration has exceeded the limit.

Action: Delete unused sites.

ORA-16504 the Data Guard configuration already exists

Cause: A request to create a Data Guard configuration was made on a site that is part of an existing configuration.

Action: Delete the existing configuration if you desire to create a new configuration.

ORA-16505 site ID is invalid

Cause: The request contained an invalid site ID.

Action: Make the request again with a valid site ID.

ORA-16506 out of memory

Cause: Process exceeded private or shared memory limits.

Action: Check for memory leaks, increase system parameters, and restart.

ORA-16507 unrecognized request identifier

Cause: The specified request identifier was not recognized by the Data Guard broker.

Action: Re-issue the request using a valid request identifier.

ORA-16508 channel handle not initialized

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16509 the request timed out

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16510 messaging error using ksrwait

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16511 messaging error using ksrget

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16512 parameter exceeded maximum size limit

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16513 maximum requests exceeded

Cause: Non-blocking commands were issued but responses are not read or the commands did not complete execution.

Action: Read pending responses or delete outstanding requests and try again.

ORA-16514 the request was not found

Cause: An attempt was made to read a response but a matching request was not found.

Action: Verify request identifier is valid and references a previously issued request.

ORA-16515 no rcv channel

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16516 the resource state is invalid for the attempted operation

Cause: The broker will return this error for switchover operations and for resource state change operations. If this error is returned for a switchover operation, then the broker has determined that either:

  • The sites changing roles are offline.
  • The primary database is not shipping log files.
  • The standby database that will become the primary is not applying log files.

The broker returns this error for resource state change operations if the resource state specified is invalid for the resource.

Action: If this error is returned when attempting a switchover operation, then make sure that:

  • The sites changing roles are online.
  • The primary database is shipping log files.
  • The standby database is applying log files.

If this error is returned when attempting a resource state change operation, then make sure you specify a valid state for the resource.

ORA-16517 the object handle is invalid

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16518 unable to allocate virtual instance id

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16519 the resource handle is invalid

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16520 unable to allocate resource id

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16521 unable to create generic template id

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16522 generic template not found

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16523 property count exhausted

Cause: Total number of resource properties exceeded the limit.

ORA-16524 unsupported operation

Cause: A command or option is not supported in this release.

Action: Contact Oracle Support Services.

ORA-16525 the Data Guard broker is not yet available

Cause: The Data Guard broker process has not yet been started, is initializing, or has failed to start.

Action: If the broker has not been started, then set DG_BROKER_START to true and allow the broker to finish initializing before making the request. If the broker failed to start, then check the Data Guard log for possible errors. Otherwise, retry the operation.

ORA-16526 unable to allocate task element

Cause: The Data Guard broker was unable to allocate memory for a request.

Action: Increase the size of your SGA.

ORA-16527 unable to allocate SGA heap

Cause: The Data Guard broker was unable to allocate a heap within the SGA.

Action: Increase SGA memory.

ORA-16528 unable to allocate PGA heap

Cause: No space in PGA to allocate heap.

Action: Increase process virtual memory.

ORA-16529 bad sender id

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16530 invalid buffer or length

Cause: A NULL buffer or a length of zero was specified.

Action: Correct command parameters and retry.

ORA-16531 unable to post message

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16532 Data Guard configuration does not exist

Cause: The Data Guard configuration does not exist.

Action: Create a DRC prior to issuing other requests.

ORA-16533 inconsistent Data Guard broker state

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16534 no more requests accepted

Cause: The Data Guard broker returns this status when:

  • A failover operation has been submitted or is currently in progress
  • A switchover operation has been submitted or is currently in progress
  • An instance restart is pending for one or more sites

Action: Wait until the operation is complete and then re-issue the request.

ORA-16535 failover request rejected

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16536 unknown object type

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16537 child count exceeded

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16538 no match on requested item

Cause: The Data Guard broker did not recognize the specified property or state name.

Action: Verify command parameters and re-issue the request.

ORA-16539 task element not found

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16540 invalid argument

Cause: One of the arguments for the specified request is invalid for the request type. In the case of failover, the failover level must be specified. That is, a graceful failover or a forced failover.

Action: Verify arguments and then re-issue the request.

ORA-16541 site is not enabled

Cause: The site specified in the request is not enabled.

Action: Select an enabled site and re-issue the request.

ORA-16542 unrecognized operation

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16543 invalid request made to broker

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16544 unable to make request

Cause: The Data Guard broker was unable to accept the request.

Action: Contact Oracle Support Services.

ORA-16545 unable to get response

Cause: The Data Guard broker was unable to return the result of a previous request.

Action: Contact Oracle Support Services.

ORA-16546 missing or invalid piece

Cause: The piece of the request to return was not specified or is invalid.

Action: Specify the piece of the response starting from 1.

ORA-16547 unable to delete request

Cause: The Data Guard broker was unable to delete the given request.

Action: Contact Oracle Support Services.

ORA-16548 the resource is not enabled

Cause: An attempt was made to modify or query a disabled Data Guard resource. This error is also returned on an attempt to enable, modify, or query a resource that the broker has permanently disabled. A permanently disabled resource cannot be re-enabled. The broker permanently disables site resources when it detects that the database on that site needs to be reinstantiated. The broker also permanently disables sites that lag behind in terms of DRC Unique ID sequence value.

Action: If the resource is not permanently disabled, enable the resource and re-issue the request.

ORA-16549 invalid string

Cause: A request contains an invalid or NULL string value.

Action: Correct command parameters and retry.

ORA-16550 truncated result

Cause: A string property value was truncated due to insufficient buffer size.

Action: Specify a larger recieve buffer.

ORA-16551 short string copied

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16552 the Data Guard broker process (DMON) failed to start

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16553 the Data Guard broker process (DMON) failed to shutdown

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16554 translation not valid

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16555 the Data Guard resource is not active

Cause: An operation was attempted on a resource that is currently not active (off path).

Action: Verify that the resource is active.

ORA-16557 the resource is already in use

Cause: An attempt was made to create a duplicate resource.

Action: Check the resource to be added and be sure there are no duplicates.

ORA-16558 the site specified for switchover is not a standby

Cause: An attempt was made to switchover to a site that is not a standby site.

Action: Locate an enabled standby site and select that site as the target of the switchover.

ORA-16559 out of memory at string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16560 unable to convert document, syntax error at "string"

Cause: There was an error at the given token.

Action: Correct the errors and resubmit the request.

ORA-16561 must use ONLINE parent state, syntax error at "string"

Cause: There was an error at the given token.

Action: Correct the errors and resubmit the request.

ORA-16562 intended_state not used here, syntax error at "string"

Cause: There was an error at the given token.

Action: Correct the errors and resubmit the request.

ORA-16563 unable to add value, syntax error at "string"

Cause: There was an error at the given token.

Action: Correct the errors and resubmit the request.

ORA-16564 lookup failed, syntax error at string

Cause: There was an error at the given token.

Action: Correct the errors and resubmit the request.

ORA-16565 duplicate property, syntax error at "string"

Cause: There was an error at the given token.

Action: Correct the errors and resubmit the request.

ORA-16566 unsupported document type

Cause: The submitted XML document is not supported.

Action: Correct the errors and resubmit the request.

ORA-16567 Data Guard broker internal parser error at "string"

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16568 cannot set property string

Cause: The named property could not be modified. The property may not be editable or may not exist.

Action: Retry the operation with a valid property.

ORA-16569 Data Guard configuration is not enabled

Cause: The requested operation requires the Data Guard configuration to be enabled.

Action: Enable the Data Guard configuration and re-issue the request.

ORA-16570 Operation requires restart of site "string"

Cause: Some Data Guard broker operations require the given site to be shut down and restarted.

Action: If the client has not already done so, then shut down the Oracle instance at the given site and then restart it.

ORA-16571 Data Guard configuration file creation failure

Cause: The Data Guard broker was unable to create the configuration file on permanent storage.

Action: Verify space, permissions, and filename as indicated by the DG_BROKER_CONFIG_FILE[1 | 2] parameter and retry.

ORA-16572 Data Guard configuration file not found

Cause: The Data Guard broker configuration file is either unavailable or does not exist.

Action: Verify that the configuration file was successfully created. If the DG_BROKER_CONFIG_FILE[1 | 2] parameter was changed, then ensure the filename on disk and the parameter value match, there is space on the device, and you have the right permissions.

ORA-16573 attempt to change configuration file in an enabled DRC

Cause: An attempt was made to change the Data Guard broker configuration file parameter while a DRC was enabled.

Action: Disable the configuration and shut down the Data Guard broker before changing this value. Also be sure to rename the file at the operating system level.

ORA-16574 switchover disallowed when required resources are offline

Cause: Switchover fails because the primary database resource and/or the designated standby database resource are offline.

Action: Check the states of the configuration, primary site, primary database resource, standby site, and standby database resource. Set their states to ONLINE if necessary.

ORA-16575 request terminated at broker discretion

Cause: This status is returned when the Broker terminates a user-initiated request. The broker will terminate all other current and pending requests when it begins processing a failover request. These other requests are terminated with this status.

Action: No action required.

ORA-16576 failed to update Data Guard configuration file

Cause: A failure was encountered while the broker was updating the Data Guard broker configuration file on permanent storage.

Action: Contact Oracle Support Services.

ORA-16577 corruption detected in Data Guard configuration file

Cause: The Data Guard broker detected errors while loading the configuration file.

Action: Contact Oracle Support Services.

ORA-16578 failed to read Data Guard configuration file

Cause: A failure was encountered while the broker was reading the configuration file on permanent storage.

Action: Contact Oracle Support Services.

ORA-16579 bad Data Guard NetSlave state detected

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16580 bad Data Guard NetSlave network link

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16581 Data Guard NetSlave failed to send message to DRCX

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16582 Data Guard connection process received error from NetSlave

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16583 bad Data Guard Connection Process DRCX state

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16584 illegal operation on a standby site

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16585 illegal operation on a primary site

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16586 Data Guard broker unable to update configuration on site

Cause: The Data Guard broker was unable to update the configuration file on a particular site.

Action: Verify that your Oracle Net connections are operational between the Data Guard sites.

ORA-16587 ambiguous object handle

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16588 no more internal buffers

Cause: See trace file.

Action: Contact Oracle Support Services.

ORA-16589 Data Guard Connection process detected a network transfer error

Cause: The Data Guard Connection Process (DRCX) detected an error while transferring data from one site to another. This error is returned in the following situations:

  • While transmitting the configuration file between sites, DRCX detected an inconsistency in the block count of the file.
  • The DRCX process got an error while writing the configuration file.

Action: Contact Oracle Support Services.

ORA-16590 no primary established in Data Guard configuration

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16591 unknown field "string" in document

Cause: There was an error at the given token.

Action: Correct the errors and resubmit the request.

ORA-16592 missing field "string" in document

Cause: There was an error at the given token.

Action: Correct the errors and resubmit the request.

ORA-16593 XML conversion failed

Cause: There was an error in the XML request document.

Action: Correct the errors and resubmit the request.

ORA-16594 string process discovered that DMON process does not exist

Cause: The Data Guard NetSlave (NSV*) processes discovered that the Data Guard broker process (DMON) is not running.

Action: Check the Data Guard console log and DMON process trace file to determine why the DMON process is missing.

ORA-16595 NetSlave process string failed to terminate

Cause: The specified NetSlave process did not terminate at the request of the Data Guard broker.

Action: Contact Oracle Support Services.

ORA-16596 site is not a member of the Data Guard configuration

Cause: A request was made on a site that is not a member of the Data Guard configuration.

Action: Re-issue the request on a site that is a part of the configuration.

ORA-16597 Data Guard broker detects two or more primaries

Cause: The Data Guard broker has detected two or more primaries in the configuration and cannot continue.

Action: Contact Oracle Support Services.

ORA-16598 The Data Guard broker has detected a mismatch in configuration

Cause: The Data Guard broker on this site has detected a mismatch in configuration generation. This can occur when the primary site has a stale configuration.

Action: Contact Oracle Support Services.

ORA-16599 The Data Guard broker has detected a stale configuration

Cause: The Data Guard broker has detected a stale configuration during initialization on this site.

Action: The broker will automatically resolve this situation once the primary site completes its initialization.

ORA-16600 Failover operation can only be submitted on target site

Cause: This error is returned when a failover request specifies a different site than the site the client is currently connected to.

Action: Explicitly connect to the site you wish to failover to and re-issue the failover request.

ORA-16601 site contains required resources that are disabled

Cause: The Data Guard broker detected disabled, required resources prior to performing an operation that needs those resources to be enabled.

Action: Enable all required resources and re-issue the request.

ORA-16602 resource must be disabled to perform this operation

Cause: An attempt was made to modify a resource that can only be changed while that resource is disabled.

Action: Disable the resource and re-issue the request.

ORA-16603 Data Guard broker detected mismatch in configuration ID

Cause: The Data Guard broker on this site has detected a mismatch in configuration Unique ID. This can occur if the original configuration was re-created while this site was disconnected from the network or the same site was added to two different configurations.

Action: Make sure the site belongs to only one configuration. Remove Data Guard broker configuration files and restart the server.

ORA-16604 unable to describe template using package "string"

Cause: The Data Guard broker was unable to execute the OnDescribe function in the named package.

Action: Verify that the named package is loaded on the primary site. Also verify that the OnDescribe function is in the package.

ORA-16605 unable to delete template, template is in use

Cause: The Data Guard broker was unable to delete the template because the template is still being used by one or more resources.

Action: Delete all resources using the template before deleting the template. You cannot delete the database template.

ORA-16606 unable to find property "string"

Cause: The named property does not exist.

Action: Specify a valid property name and re-issue the request.

ORA-16607 one or more sites have failed

Cause: The Data Guard broker detected a failure on one or more sites.

Action: Locate the sites with a failure status and correct it.

ORA-16608 one or more sites have warnings

Cause: The Data Guard broker detected a warning status on one or more sites.

Action: Locate the sites with a warning status and correct it.

ORA-16609 one or more resources have failed

Cause: The Data Guard Broker detected a failure on one or more resources on a site.

Action: Locate the resources with a failure status and correct it.

ORA-16610 one or more resources have warnings

Cause: The Data Guard broker detected a warning status on one or more resources on a site.

Action: Locate the resources with a warning status and correct it.

ORA-16611 operation aborted at user request

Cause: The Data Guard broker aborted an operation at the user's request.

Action: No action required.

ORA-16612 string value too long for attribute "string"

Cause: The string value for the named attribute is too long.

Action: Use a shorter string.

ORA-16613 initialization in progress for site

Cause: The site received a directive to change its initialization state or a change in its configuration before it has completed initialization.

Action: Wait until the site has completed initialization before issuing requests to modify run-time state or configuration.

ORA-16614 object has an ancestor that is disabled

Cause: A request to enable an object that has an ancestor that is disabled was received by the server. The Data Guard broker has enabled the object to the extent that it can, but cannot fully enable the object until its ancestor is enabled.

Action: Determine the ancestor object that is disabled and enable that ancestor prior to enabling the child object.

ORA-16617 Unknown object identifier specified in request

Cause: The Data Guard broker returns this error when the object identifier specified in the request is invalid or unknown. For example, this error is returned if an invalid or unknown site object identifier is specified in a request that requires a site object identifier.

Action: Verify that a valid object identifier was specified in the request and then re-issue the request.

ORA-16618 response document of size "string" bytes is too large

Cause: The document response cannot be returned because the size of the document is too large. This can occur when displaying the Data Guard console log.

Action: View the console log on the given site directly.

ORA-16619 Health Check timed out

Cause: This status is returned when the Data Guard broker could not reach a standby site during routine health check.

Action: This typically indicates a network problem where the standby site is unable to respond to the primary within the predefined time frame.

ORA-16620 one or more sites could not be contacted for a delete operation

Cause: This status is returned when the Data Guard broker could not reach one or more standby sites for either a delete site or a delete configuration operation.

Action: This typically indicates a network problem where the standby site is unable to respond to the primary. In the event of this situation, examine the Data Guard broker log file on the primary site to determine which standby sites could not be reached. Then for each standby site not reached, connect to that site and shut down the broker by setting the DG_BROKER_START initialization parameter to false. After the broker has been shut down on the standby site, locate the Data Guard broker configuration files from the standby site's DG_BROKER_CONFIG_FILE[1 | 2] parameter values and delete them.

ORA-16621 host and SID names for create site must be unique

Cause: This status is returned when an attempt is made to add a site whose host and SID names match those of an existing site.

Action: Verify that you have specified a unique host and SID name pair for the new site you wish to add. This can be done by checking that there are no sites with the same host and SID names.

ORA-16622 two or more Broker sites resolve to the same physical site

Cause: This status is returned when the Broker determines that there are multiple site objects referring to the same physical or material site.

Action: Examine the host names, SID names, and connect descriptors of all sites in the configuration and verify that there are not two or more sites that refer to the same physical site. If you detect this situation, then correct the site definition to eliminate the ambiguity.

ORA-16623 stale DRC UID sequence number detected

Cause: This status is returned when the Broker detects a stale sequence value during bootstrap or during health check. The sequence value is changed each time a role change occurs. A site that is unavailable for the role change operation will end up with a stale sequence number. Should that site attempt to rejoin the configuration, the broker will determine that it missed a role change and disable that site. The broker permanently disables the site since it may no longer be a viable standby site for the new primary.

Action: Examine the configuration and the sites that were permanently disabled to determine if they require manual intervention.

ORA-16624 broker protocol version mismatch detected

Cause: This status is returned when the Broker detects a network protocol version number mismatch. This can happen if the sites in question are not running the same release of Oracle. The broker will permanently disable the sites that do not have the same network protocol version number as the primary.

Action: Examine the release of Oracle installed on all sites to make sure they are identical. Once the Oracle releases are the same on all sites, delete and re-add the sites that were permanently disabled.

ORA-16625 cannot reach the primary site

Cause: This status is returned when the Broker rejects a write operation requested by the client when the primary site is not reachable from the site the request is made. All write operations made to the DataGuard configuration must be processed by the primary site.

Action: Check your network connection from the site your client is connected to, to the primary site. Alternatively, you can connect your client to a different site in the DataGuard Configuration and try your request again.

ORA-16626 failed to enable specified object

Cause: This status is returned when the broker fails to enable an object (most typically a standby site). You can expect to see this status when attempting to enable a standby site that:

  • Cannot locate itself in the configuration
  • Fails to distiguish itself from two or more site objects in the configuration
  • Determines it was not part of a change of primary due to failover

Action: To correct the problem, try one of these actions:

  • Confirm that the host and SID names you specified when you created the site exactly match the values in the HOST_NAME and INSTANCE_NAME columns of V$INSTANCE.
  • Confirm that you have not created two or more sites with the same connect descriptor. That is, the site objects should not lead you to the same material site.
  • If you had performed a failover and have re-instantiated your old primary site (or standby site that had to be reinstantiated), then make sure the Data Guard Broker configuration files have been removed from that site. Do NOT remove the configuration files that are in use by the new primary.

ORA-16627 no standby databases support overall protection mode

Cause: This status is returned in the following situations:

  • The Broker rejects an attempt to change the configuration's overall protection mode since it could not find any online, managed standby databases that support the proposed protection mode.
  • The Broker rejects an attempt to enable the configuration if it determines that there are no online managed standby databases that support the overall protection mode.
  • The Broker rejects an attempt to disable or delete a site or database resource, that if disabled or deleted, would result in no standby databases that support the configuration's overall protection mode.
  • The Broker rejects an attempt to set the configuration offline if doing so would violate the configuration's overall protection mode.
  • The Broker rejects an attempt to set a standby site or database offline if doing so would violate the configuration's overall protection mode.
  • The Broker rejects a switchover attempt if doing so would violate the configuration's overall protection mode.
  • The Broker returns this error during a health check.

Action:

  • If changing the overall protection mode, then confirm that at least one standby database satisfies the new protection mode.
  • For enable failures, confirm that at least one standby database has a LogXptMode configuration property setting that supports the current overall protection mode.
  • For delete and disable failures, confirm that at least one other standby database has a LogXptMode configuration property setting that supports the overall protection mode.
  • For the state change failures, confirm that at least one other standby database has a LogXptMode configuration property setting that supports the overall protection mode. If setting the configuration OFFLINE, you may have to downgrade the protection mode setting to maximum performance beforehand.
  • For switchover failures, confirm that at least one other standby database has a LogXptMode configuration property setting that supports the overall protection mode. If your configuration contains a primary and a single standby, then ensure that the LogXptMode configuration property established for the primary site supports the overall protection mode. After the switchover the old primary will become the standby and its LogXptMode configuration property setting must support the overall protection mode.
  • For health check error, confirm that at least one standby database has a LogXptMode configuration property setting that supports the current overall protection mode.

ORA-16628 The Broker protection mode is inconsistent with the database setting

Cause: The Data Guard Broker protection mode saved in metadata is inconsistent with the actual database setting.

Action: Reset the protection mode through the Data Guard Broker.

ORA-16629 database reports a different protection level from the protection mode

Cause: The actual protection level supported by the standby database is different from the protection mode set on the primary. This is likely caused by the log transport problems.

Action: Check the database alert logs and Data Guard Broker console logs for more details. Check the log transport status. Make sure at least one standby log transport is supporting the protection mode and that the network to the standby has no problems.

ORA-16701 generic resource guard request failed

Cause: Request to modify or query the resource failed.

Action: Check the Data Guard console log for the reason for the failure, and re-issue the request.

ORA-16702 generic resource manager warning

Cause: Request to modify or query the resource resulted in a warning.

Action: Check the console log for the reason for the warning, and re-issue the request if necessary.

ORA-16703 status of request is unknown

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16704 a previous set state operation is pending

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16705 severe internal error in resource guard

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16706 no resource guard is available

Cause: No resource guard is available to service the request.

Action: Contact Oracle Support Services.

ORA-16707 the value supplied to resource guard is invalid

Cause: The value specified in the request is invalid.

Action: Check value and re-issue the request.

ORA-16708 the state supplied to resource guard is invalid

Cause: The state name specified is invalid for the resource.

Action: Check the state name and re-issue the request.

ORA-16709 the resource guard is busy and cannot service the request

Cause: Request to resource guard failed because the guard is busy.

Action: Wait for resource guard to finish previous request and then re-issue the request.

ORA-16710 the resource guard is out of memory

Cause: The resource guard was unable to allocate memory while trying to service a request.

Action: Disable the configuration, shutdown oracle, increase SGA size, and restart.

ORA-16711 the resource guard index is out of bounds

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16712 the resource handle is invalid

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16713 the resource guard timed out while servicing the request

Cause: The resource guard timed out while servicing the request.

Action: Verify that the operation is valid for the resource and then re-issue the request.

ORA-16714 the resource guard exceeded its retry limit

Cause: The resource guard exceeded its retry limit while trying to service a request.

Action: Verify that the resource is operational and then re-issue the request.

ORA-16715 the logical standby database requires instantiation

Cause: The resource guard could not execute the request since the logical standby database requires instantiation.

Action: Instantiate logical standby on the site and then re-issue the request.

ORA-16716 clearing parameter LOG_ARCHIVE_DEST failed

Cause: An attempt to clear the LOG_ARCHIVE_DEST initialization parameter failed.

Action: Contact Oracle Support Services.

ORA-16717 clearing parameter LOG_ARCHIVE_DUPLEX_DEST failed

Cause: An attempt to clear the LOG_ARCHIVE_DUPLEX_DEST initialization parameter failed.

Action: Contact Oracle Support Services.

ORA-16718 failed to locate the database resource

Cause: The resource guard was unable to locate the database resource in the configuration.

Action: Add the database resource and then re-issue the request.

ORA-16719 unable to query V$ARCHIVE_DEST fixed view

Cause: A SQL statement to query V$ARCHIVE_DEST failed.

Action: Test and clear the problem using SQL*Plus.

ORA-16720 no available LOG_ARCHIVE_DEST_n parameters to use

Cause: All LOG_ARCHIVE_DEST_n parameters have been defined.

Action: Set some of the LOG_ARCHIVE_DEST_n parameters to an empty string.

ORA-16721 unable to set LOG_ARCHIVE_DEST_n parameters

Cause: An attempt of setting some of the LOG_ARCHIVE_DEST_n parameters failed.

Action: Check the Data Guard console log and database alert logs for further details.

ORA-16722 unable to set LOG_ARCHIVE_DEST_STATE_n parameters

Cause: An attempt of setting some of the LOG_ARCHIVE_DEST_STATE_n parameters failed.

Action: Check the Data Guard console log and database alert logs for further details.

ORA-16723 the connect descriptor is missing from V$ARCHIVE_DEST

Cause: The resource guard was unable to locate a connect descriptor to a certain standby site in V$ARCHIVE_DEST.

Action: Check the Data Guard console log for further details. One may need to reset log transport service.

ORA-16724 the intended state for resource has been set to OFFLINE

Cause: The intended state of the resource has been set to offline.

Action: If resource is managed, change intended state to online.

ORA-16725 the phase supplied to resource manager is invalid

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16726 the external condition supplied to resource manager is invalid

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-16727 resource guard cannot close database

Cause: The resource guard could not close the database.

Action: If there are any active sessions connected to the database, then terminate them and re-issue the request.

ORA-16728 Log archive destination could not be set

Cause: The resource guard could not set the log archive destination.

Action: Check the Data Guard console log and the Oracle Alert log for further details.

ORA-16729 Error executing dbms_logstdby.log procedure

Cause: Logical standby package may not be installed.

Action: Install logical standby packages and re-issue the request.

ORA-16730 Error executing dbms_logstdby.skip_txn procedure

Cause: Logical standby package may not be installed.

Action: Install logical standby packages and re-issue the request.

ORA-16731 Error executing dbms_logstdby.unskip_txn procedure

Cause: Logical standby package may not be installed.

Action: Install logical standby packages and re-issue the request.

ORA-16732 Error executing dbms_logstdby.skip procedure

Cause: Logical standby package may not be installed.

Action: Install logical standby packages and re-issue the request.

ORA-16733 Error executing dbms_logstdby.unskip procedure

Cause: Logical standby package may not be installed.

Action: Install logical standby packages and re-issue the request.

ORA-16734 Error executing dbms_logstdby.skip_error procedure

Cause: Logical standby package may not be installed.

Action: Install logical standby packages and re-issue the request.

ORA-16735 Error executing dbms_logstdby.unskip_error procedure

Cause: Logical standby package may not be installed.

Action: Install logical standby packages and re-issue the request.

ORA-16736 Standby log archive destination parameter could not be set

Cause: Resource guard could not set the standby log archive destination parameter.

Action: Check the Data Guard console log for further details.

ORA-16737 Log archive format parameter could not be set

Cause: Resource guard could not set the log archive format parameter.

Action: Check the Data Guard console log for further details.

ORA-16738 Database file name convert parameter could not be set

Cause: Resource guard could not set the database file name convert parameter.

Action: Check the Data Guard console log for further details.

ORA-16739 Log file name convert parameter could not be set

Cause: Resource guard could not set log file name convert parameter.

Action: Check the Data Guard console log for further details.

ORA-16740 Log archive trace parameter could not be set

Cause: Resource guard could not set log archive trace parameter.

Action: Check the Data Guard console log for further details.

ORA-16741 Control files parameter could not be set

Cause: Resource guard could not set the control files parameter.

Action: Check the Data Guard console log for further details.

ORA-16742 lock name trace parameter could not be set

Cause: Resource guard could not set lock name trace parameter.

Action: Check the Data Guard console log for further details.

ORA-16743 FAL client parameter could not be set

Cause: Resource guard could not set FAL client parameter.

Action: Check the Data Guard console log for further details.

ORA-16744 FAL server parameter could not be set

Cause: Resource guard could not set FAL server.

Action: Check the Data Guard console log for further details.

ORA-16745 Resource guard encountered error during database dismount

Cause: Resource guard could not dismount database.

Action: Check the Data Guard console log for further details.

ORA-16746 Resource guard encountered error during database mount

Cause: Resource guard could not mount database.

Action: Check the Data Guard console log for further details.

ORA-16747 Logical standby guard could not be turned on

Cause: Resource guard could not turn on the logical standby guard.

Action: Check the Data Guard console log for further details.

ORA-16748 Resource guard encountered errors during database open

Cause: Resource guard could not open database.

Action: Check the Data Guard console log for further details.

ORA-16749 Resource guard encountered errors in switchover to logical primary

Cause: Resource guard could not prepare to switch to logical primary.

Action: Check the Data Guard console log for further details.

ORA-16750 Resource guard encountered errors while activating logical primary

Cause: Resource guard could not activate logical primary.

Action: Check the Data Guard console log for further details.

ORA-16751 Resource guard encountered errors in switchover to primary

Cause: Resource guard could not prepare to switch to primary.

Action: Check the Data Guard console log for further details.

ORA-16752 Resource guard could not mount standby

Cause: Resource guard could not mount standby.

Action: Check the Data Guard console log for further details.

ORA-16753 Resource guard could not open standby database

Cause: Resource guard could not open standby database.

Action: Check the Data Guard console log for further details.

ORA-16754 Resource guard could not activate standby

Cause: Resource guard could not activate standby.

Action: Check the Data Guard console log for further details.

ORA-16755 Resource guard could not dismount standby

Cause: Resource guard could not dismount standby.

Action: Check the Data Guard console log for further details.

ORA-16756 Resource guard could not open standby read-only

Cause: Resource guard could not open standby read-only.

Action: Check the Data Guard console log for further details.

ORA-16757 Resource guard could not get property

Cause: Resource guard failed to get property.

Action: Check the Data Guard console log for further details.

ORA-16758 Resource guard could not verify property

Cause: Resource guard failed to verify property.

Action: Check the Data Guard console log for further details.

ORA-16759 Resource guard unable to start logical apply engine with initial SCN

Cause: Resource guard failed to start logical apply engine with an initial SCN.

Action: Check the Data Guard console log for further details.

ORA-16760 Resource guard could not start logical apply engine

Cause: Resource guard failed to start logical apply engine.

Action: Check the Data Guard console log for further details.

ORA-16761 Resource guard could not stop logical apply engine

Cause: Resource guard failed to stop logical apply engine correctly.

Action: Check the Data Guard console log for further details.

ORA-16762 Invalid database state

Cause: Database is not in the intended state.

Action: Determine the reason for invalid state, and re-issue get status request.

ORA-16763 Log transport service for some site unexpectedly online

Cause: Log transport service for some site is online when it should be offline.

Action: Check the Data Guard console log for further details. If necessary, stop the log transport service for the site.

ORA-16764 Log transport service for some site unexpectedly offline

Cause: Log transport service for some site is offline when it should be online.

Action: Check the Data Guard console log for further details. If necessary, start the log transport service.

ORA-16765 Physical apply service unexpectedly online

Cause: Physical apply service is online when it should be offline.

Action: If necessary, stop the physical apply service.

ORA-16766 Physical apply service unexpectedly offline

Cause: Physical apply service is offline when it should be online.

Action: If necessary, start the physical apply service.

ORA-16767 Logical apply service unexpectedly online

Cause: Logical apply service is online when it should be offline.

Action: If necessary, stop the logical apply service.

ORA-16768 Logical apply service unexpectedly offline

Cause: Logical apply service is offline when it should be online.

Action: If necessary, start the logical apply service.

ORA-16769 Error executing apply_set procedure

Cause: There was an error executing dbms_logstdby$apply_set procedure.

Action: Check the values for the property, and set configuration property again.

ORA-16770 Error executing apply_unset procedure

Cause: There was an error executing dbms_logstdby$apply_unset procedure.

Action: Check the values for the property, and set configuration set property again.

ORA-16771 Error starting ARCH process(es)

Cause: There was an error starting the archival processes.

Action: Check the Data Guard console log for further details.

ORA-16772 Error in switching over between primary and standby databases

Cause: There was an error during switchover of primary and standby databases.

Action: Check the Data Guard console log for further details.

ORA-16773 Error in starting the physical apply service (MRP process)

Cause: There was an error in starting the physical apply service (MRP process).

Action: Check the Data Guard console log for further details.

ORA-16774 Error in stopping the physical apply service (MRP process)

Cause: There was an error in stopping the physical apply service (MRP process).

Action: Check the Data Guard console log for further details.

ORA-16775 The physical apply service terminated prematurely

Cause: The physical apply service terminated prematurely with an error.

Action: Check the Data Guard console log and Oracle Alert log for further details.

ORA-16776 Health check of the log transport service failed

Cause: Due to some internal failure, the database resource guard cannot complete the health check of the log transport service.

Action: Check the Data Guard console log and Oracle Alert log for further details.

ORA-16777 Unable to find the destination entry of a site in V$ARCHIVE_DEST

Cause: Some destination may be manually deleted, or no entry is available for Data Guard.

Action: Check the Data Guard console log and Oracle Alert log for further details. One may need to reset log transport service.

ORA-16778 The log transport service for some site has an error

Cause: Some problem in communicating with a standby site causes the log transport to fail.

Action: Check the Data Guard console log and Oracle Alert log for further details. Query the LogXptStatus property to see the error message.

ORA-16779 The destination parameter of some site has wrong syntax

Cause: The destination is defined in the initialization parameter file with wrong syntax, and the Data Guard broker fails to update the destination when the log transport is turned on.

Action: Check the Data Guard console log to see which site has the problem. Fix the syntax error in the initialization parameter file or remove the entry. Check if the syntax of the log transport related properties are correct.

ORA-16780 Some site has used up its quota

Cause: Some site has used up its quota for storing archived redo logs.

Action: Check the Data Guard console log to see which site has the problem. Remove some archived logs at the standby site or increase its quota.

ORA-16781 The status of log transport service for some site is unknown

Cause: Log transport to some site has an unknown status.

Action: Check the Data Guard console log and Oracle Alert log for further details.

ORA-16782 Unable to get values of some critical configurable properties

Cause: Log transport cannot be turned on because some critical property values cannot be retrieved from Data Guard metadata.

Action: Check the Data Guard console log and Oracle Alert log for further details.

ORA-16783 Some critical configurable property has not been set

Cause: Log transport cannot be turned on because some critical property has not been set.

Action: Check the Data Guard console log to see which property has not been set, and set it properly.

ORA-16784 The site name given in property Dependency or Alternate is incorrect

Cause: Site name provided in property Dependency or Alternate is wrong.

Action: Reset property to the correct name of the site.

ORA-16785 The database is not in ARCHIVELOG mode

Cause: The database is in NOARCHIVELOG mode, when it is either a primary database or a standby database that is being switched over to the primary database.

Action: Reset the primary database to ARCHIVELOG mode by issuing the ALTER DATABASE ARCHIVELOG statement.

ORA-16786 Resource guard cannot access Data Guard metadata

Cause: The Data Guard broker configuration files do not exist or the resource guard cannot access the Data Guard metadata.

Action: Check the Data Guard console log for further details.

ORA-16788 Unable to set one or more database configuration property values

Cause: This situation occurs when database resource guard attempts to set database configuration property values into the database by issuing ALTER SYSTEM or ALTER DATABASE statements. Typical causes of this error are:

  • The values of log transport related properties have syntax errors
  • The Value of LogArchiveTrace is out of range
  • Database initialization parameter STANDBY_FILE_MANAGEMENT cannot be set to AUTO because the database compatability is not set to 9.0.0.0.0 or higher.

Action: Check the Data Guard console log to see which property has the problem and reset the property correctly.

ORA-16789 Missing standby redo logs

Cause: Standby redo logs are missing when needed for certain log transport modes.

Action: Check the Data Guard documentation to create standby redo logs on the standby.

ORA-16790 The value of the configurable property is invalid

Cause: An invalid property value was entered.

Action: Reset the value to a correct one.

ORA-16791 Unable to check the existence of the standby redo logs

Cause: The database may not be mounted, or the query of V$STANDBY_LOG failed.

Action: Bring the database to an online state, or fix the problem during the query of V$STANDBY_LOG.

ORA-16792 Some configurable property value is inconsistent with the database setting

Cause: The values of one or more configurable properties are inconsistent with database in-memory settings or SPFILE settings. This may be caused by a user operation on database outside of the Data Guard broker control.

Action: Query property InconsistentProperties on the site or check the Data Guard console log to find which properties are inconsistent. Reset these properties to make them consistent with the database settings.

ORA-16793 Logical Standby Database Guard is unexpectedly OFF

Cause: The logical standby database guard is OFF.

Action: Issue the ALTER DATABASE GUARD ALL statement to turn the guard ON and verify that Data Guard health check error/warning is cleared.

ORA-16794 Database Guard is ON for primary database

Cause: Primary database has database guard ON, which is not normal.

Action: Issue the ALTER DATABASE GUARD NONE statement to turn the guard OFF and verify that Data Guard health check error/warning is cleared.

ORA-16795 Database resource guard detects that database reinstantiation is required

Cause: In the act of failover or switchover, the database resource guard may detect that reinstantiation of the database is necessary due to the impending role change. This occurs when the database resource guard recognizes a situation in which the database in question cannot be a viable standby database for the new primary database.

Action: Reinstantiate the database on the site indicated by the broker and then re-add that site to your broker configuration.

ORA-16796 One or more property cannot be imported from database

Cause: Importing existing database settings into the Data Guard properties failed for one or more properties. The cause may be that the database is not mounted or open, or the connection to the standby database being imported is down.

Action: Check the Data Guard console log to find more details about the problem.

ORA-16797 SPFILE is missing in the Data Guard Broker environment

Cause: Server parameter file is not being used in the database, or the resource guard failed to retrieve the status of the SPFILE.

Action: Issue a CREATE SPFILE='...' FROM PFILE='...' statement to create an SPFILE, and restart the database to use the SPFILE.

ORA-16798 Unable to complete terminal recovery on the standby

Cause: Terminal recovery on the standby failed during the graceful failover operation.

Action: Check Data Guard console log and alert logs to see more details on the reason of the failure.

ORA-16799 Physical apply service is offline

Cause: Either the Data Guard metadata indicates the physical apply service is turned off, or the recovery process MRP0 is not running. In either of the cases, physical apply related properties cannot be set.

Action: Turn on the physical apply service through Data Guard broker, then reset the physical apply related property again.

ORA-16800 Log transport service for some site is incorrectly set to ALTERNATE

Cause: Log transport service for some site is currently set to ALTERNATE while no other destinations is set to alternate to this site.

Action: Check the Data Guard console log for further details. Reset database state to turn on log transport again if necessary.

ORA-16801 Some log transport related property is inconsistent

Cause: The values of one or more log transport related configurable properties of a standby database resource are inconsistent with the primary's log transport service settings. This may be caused by a user operation on database outside of the Data Guard broker control.

Action: Query property InconsistentLogXptProps on the primary or Check the Data Guard console log to find which properties are inconsistent. Reset these properties on the appropriate standby to make them consistent with the primary's log transport settings.

ORA-16802 Cannot set property 'Alternate' to the primary site name

Cause: Data Guard Broker does not allow the primary site to be an alternate archival destination for a standby site.

Action: Set property Alternate to empty or to the name of a standby site.

ORA-16803 Unable to query a database table or fixed view

Cause: Failed to query a database table or fixed view. The database may not be open or mounted.

Action: Check Data Guard console log for more details.

ORA-16804 One or more configuration properties in metadata have invalid values

Cause: Data Guard Broker health check detects that one or more configuration properties in metadata have invalid values. They may be entered during the disabled period of database resource or through other means.

Action: Check Data Guard console log for more details on which properties have invalid values and reset them through Data Guard Broker.

ORA-16805 Change of LogXptMode property violates overall protection mode

Cause: The standby database resource guard rejected the attempt to change the LogXptMode configuration property for the standby database resource. The rejection was necessary since doing so would violate the overall protection mode for the configuration.

Action: If the LogXptMode configuration property must be changed for the specified standby database resource, then first downgrade the overall protection mode for the configuration. After that operation has completed, you will be able to change the LogXptMode configuration property for the standby database resource.

ORA-16806 Supplemental logging is not turned on

Cause: Supplemental logging is not turned on while there is a logical standby database in the configuration. This could happen either6854// on the primary or on the logical standby that is being switched over to the primary.

Action: Check Data Guard console log for more details. Issue ALTER DATABASE ADD SUPPLEMENTAL LOG DATA (PRIMARY KEY, UNIQUE INDEX) COLUMNS to add supplemental logging.

ORA-16807 unable to set protection mode to the database

Cause: An attempt to issue an ALTER DATABASE SET STANDBY TO ... statement failed.

Action: Check database alter logs and Data Guard console logs for more information.

ORA-16900 Unable to initialize client

Cause: The client could not be initialized.

Action: This is an internal error. Contact Oracle Support Services.

ORA-16901 Unable to initialize environment

Cause: The database environment could not be allocated and initialized.

Action: This is an internal error. Contact Oracle Support Services.

ORA-16902 Unable to allocate handle

Cause: The database handles could not be allocated.

Action: This is an internal error. Contact Oracle Support Services.

ORA-16903 Unable to connect to database

Cause: The specified database was unreachable because it does not exist or was not started.

Action: Correct the request or start the database and try again.

ORA-16904 Unable to set attribute

Cause: The server attributes could not be set.

Action: check additional error messages.

ORA-16905 Failed.

Cause: The given action failed.

Action: check additional error messages.

ORA-16906 Unable to accept commands: no memory

Cause: No memory was available for the program.

Action: Increase memory and try again.

ORA-16907 missing field

Cause: A required field was missing.

Action: Type "help" for syntax and try again.

ORA-16908 Unknown option: "string"

Cause: The given option is not supported.

Action: Try again using the proper command line syntax.

ORA-16909 Fatal Error. quitting...

Cause: A fatal error was encountered.

Action: See additional error messages and contact Oracle Support Services.

ORA-16910 unable to issue command to server

Cause: Commands cannot be issued to the server.

Action: See additional error messages and contact Oracle Support Services.

ORA-16911 Warning:

Cause: An action succeeded with warnings.

Action: See error message and take appropriate action.

ORA-16912 Unknown command "string". Try "help"

Cause: An unknown command was issued.

Action: Try again using a valid command.

ORA-16914 Missing connect string. Try "help"

Cause: The connect string for the database is missing.

Action: Try the command again with a valid connect string.

ORA-16916 Missing site. Try "help"

Cause: The site name is missing.

Action: Try the command again using correct syntax.

ORA-16917 Missing XML document. Try "help"

Cause: The XML document argument was missing.

Action: Try the command again using correct syntax.

ORA-16939 Could not start up "string" as primary

Cause: The named site could not be started in the primary role.

Action: See additional messages.

ORA-16940 Started "string" as new primary

Cause: The named site was started as the new primary site.

Action: No action is required.

ORA-16942 Could not start up "string" as standby

Cause: The named site could not be started in the standby role.

Action: See additional messages..

ORA-16943 Started "string" as standby

Cause: The named site was started as the new primary site.

Action: No action required.

ORA-16944 Failover succeeded. New primary is "string"

Cause: The failover operation succeeded.

Action: No action required.

ORA-16945 Syntax error before or at "string"

Cause: The given command could not be processed because a syntax error occurred at the named token.

Action: Try the command again using valid syntax.

ORA-16946 Site "string" was not found

Cause: The named site could not be found.

Action: Try the command again using a valid site.

ORA-16947 "string" does not run in the primary role

Cause: The named resource does not run in the primary role.

Action: Try the command again using a resource that runs in the primary role.

ORA-16948 "string" does not run in the standby role

Cause: The named resource does not run in the standby role.

Action: Try the command again using a resource that runs in the standby role.

ORA-16949 Resource "string" was not found

Cause: The named resource was not found.

Action: Try the command again using a valid resource.

ORA-16950 Unable to retrieve "string" for editing

Cause: The named object could not be retrieved for editing.

Action: Contact Oracle Support Services.

ORA-16951 manager information not found

Cause: The manager information could not be retrieved for a generic resource.

Action: Contact Oracle Support Services.

ORA-16952 unable to describe configuration

Cause: The configuration could not be described.

Action: The framework could not be contacted. Check to see that the DMON process is running.

ORA-16953 site or resource "string" does not exist

Cause: The named site or resource does not exist.

Action: Try the command again using a valid site or resource.

ORA-16954 a resource cannot run on multiple sites this way

Cause: An attempt was made to create a resource that depends on multiple sites. This is not possible using one command.

Action: Issue the command twice; one with the first site and the second using the second site.

ORA-16955 unable to create or locate template

Cause: The template could not be found.

Action: See additional error messages.

ORA-16956 missing template name

Cause: The template name was omitted from the command.

Action: Try the command again using a valid template name.

ORA-16957 template "string" was not found

Cause: The named template could not be found.

Action: Try the command again using a valid template name.

ORA-16958 unable to convert document

Cause: The document could not be converted.

Action: Contact Oracle Support Services.

ORA-16959 NULL answer from framework

Cause: No answer came from the framework.

Action: The framework is not available. Check to see that the DMON process exists.

ORA-16960 status not available

Cause: The status could not be retrieved.

Action: The framework is not available. Check to see that the DMON process exists.

ORA-16991 ambiguous resource name

Cause: The named resource exists on more than one site.

Action: The request must be more specific. Issue the command again using the ON SITE clause.

ORA-16992 You must restart site "string" manually.

Cause: The operation was successfully completed, and it requires a restart of given site. However, DGMGRL was unable to perform an automatic restart. The user has to shutdown and startup the site manually.

Action: Shut down the given site and start it up.

ORA-17500 ODM err:string

Cause: An error returned by ODM library

Action: Look at error message and take appropriate action or contact Oracle Support Services for further assistance.

ORA-17501 logical block size string is invalid

Cause: logical block size for oracle files must be a multiple of the physical block size, and less than the maximum

Action: check parameters in the initialization parameter file.

ORA-17502 ksfdcre: string Failed to create file string

Cause: file creation failed due to either insufficient OS permission or the file already exists

Action: check additional error messages

ORA-17503 ksfdopn: string Failed to open file string

Cause: file open failed due to either insufficient OS permission or the name of file exceeds maximum file name length.

Action: check additional error messages

ORA-17504 ksfddel:Failed to delete file string

Cause: The file thats being deleted is still in use or the process has insufficient permission to delete file.

Action: check additional error messages

ORA-17505 ksfdrsz: string Failed to resize file to size number blocks

Cause: There is insufficient space left on the device or the process has insufficient permission to resize file.

Action: check additional error messages

ORA-17506 I/O Error Simulation

Cause: The i/o request is marked with error because the i/o error simulation event is turned on.

Action: none

ORA-17507 I/O request size string is not a multiple of logical block size

Cause: i/o's are done in multiple of logical block size

Action: Check additional error messages

ORA-17508 I/O request buffer ptr is not alligned

Cause: i/o request buffer should be alligned, check additional information for buffer ptr value

Action: Contact Oracle Support Services.

ORA-17509 Attempt to do i/o beyond block1 offset

Cause: When a file is identified with logical block size of 0, only i/o's to block1 is allowed.

Action: check additional error messages and contact Oracle Support Services.

ORA-17510 Attempt to do i/o beyond file size

Cause: The i/o request points to a block beyond End Of File

Action: check additional error messages and contact Oracle Support Services.

ORA-17610 file 'string' does not exist and no size specified

Cause: An attempt to create a file a file found neither an existing file nor a size for creating the file.

Action: Specify a size for the file.

ORA-17611 ksfd: file 'string' cannot be accessed, global open closed

Cause: An attempt to write to a file which has gone offline/unidentified.

Action: Check for other errno in the stack.

ORA-18000 invalid outline name

Cause: The parser detected a missing or invalid outline name.

Action: reissue the command, specifying a valid outline name.

ORA-18001 no options specified for ALTER OUTLINE

Cause: The parser detected that no clause was specified on the command.

Action: reissue the command, specifying a valid ALTER OUTLINE clause.

ORA-18002 the specified outline does not exist

Cause: Either the outline did not exist to begin with, or a timing window allowed for another thread to drop or alter the outline midstream.

Action: Check for the existence of the outline and try again.

ORA-18003 an outline already exists with this signature

Cause: The signature generation algorithm generates signatures that are 16 bytes in length so it is highly unlikely that any 2 signatures will be identical. This message is raised in such a rare case.

Action: Either reissue the statement that led to the outline being created with some white space added or force the outline to be created in a different category.

ORA-18004 outline already exists

Cause: An outline already exists, either with the specified name, or for the specified SQL text.

Action: Try again with another name.

ORA-18005 create any outline privilege is required for this operation

Cause: Create any outline privilege is required for the attempted operation.

Action: Make sure you have create any outline privilege and retry the operation.

ORA-18006 drop any outline privilege is required for this operation

Cause: Drop any outline privilege is required for the attempted operation.

Action: Make sure you have drop any outline privilege and retry the operation.

ORA-18007 alter any outline privilege is required for this operation

Cause: Alter any outline privilege is required for the attempted operation.

Action: Make sure you have alter any outline privilege and retry the operation.

ORA-18008 cannot find OUTLN schema

Cause: The database creation script that creates this schema must not have been executed.

Action: Review the log files to see what happened when the database was created.

ORA-18009 one or more outline system tables do not exist

Cause: Either the database creation script that creates these tables was not executed or a user accidently deleted the table.

Action: Review the log files to see what happened when the database was created.

ORA-18010 command missing mandatory CATEGORY keyword

Cause: User failed to specify the CATEGORY keyword.

Action: reissue the command with the CATEGORY keyword included.

ORA-18011 the outline specified in the FROM clause does not exist

ORA-18012 select_catalog_role role is required for this operation

ORA-18013 timed out while waiting for resource string

ORA-18014 deadlock detected while waiting for resource string

ORA-18015 invalid source outline signature

Cause: User imported an 8i outline into a 9i database without updating signatures.

Action: Execute dbms_outln.update_signatures.

ORA-19000 missing RELATIONAL keyword

Cause: The keyword RELATIONAL in the work OBJECT RELATIONAL is missing in the XMLTYPE storage clause specification.

Action: Supply the RELATIONAL keyword in the storage clause

ORA-19001 Invalid storage option specified

Cause: An invalid storage option was specified for the XMLType.

Action: Supply a valid storage option.

ORA-19002 Missing XMLSchema URL

Cause: A XML schema URL must be specified in the storage option.

Action: Specify a URL for the XMLSchema.

ORA-19003 Missing XML root element name

Cause: A root element in the XMLSchema must be specified if the XML schema is given.

Action: Specify a root element in the XML schema.

ORA-19004 Duplicate XMLType OBJECT RELATIONAL storage option

Cause: A duplicate storage option for the XMLType column was specified

Action: Specify a single storage option for an XMLType column

ORA-19005 Duplicate XMLType LOB storage option

Cause: A duplicate storage option for the XMLType column was specified

Action: Specify a single storage option for an XMLType column

ORA-19006 XMLType TYPE storage option not appropriate for storage type

Cause: The TYPE option can only be used in case of OBJECT RELATIONAL storage option

Action: Remove the TYPE option or specify an OBJECT RELATIONAL storage for the XMLType column

ORA-19007 Schema and element do not match

Cause: The schema and element specified in the inserted data does not match that of the column

Action: Insert/Update only the XML documents that conform to that particular schema and element.

ORA-19008 Invalid version of the XMLType

Cause: An invalid version of the XMLType was found.

Action: This is possible due to data corruption or an internal error or running an older client against a newer version of the database. Make sure that the version of the client can understand the XMLType in the database.

ORA-19009 Missing XMLSchema keyword

Cause: The XMLSchema keyword is missing

Action: Specify the XMLSchema URL and element name.

ORA-19010 Cannot insert XML fragments

Cause: XML fragments got from extractNode cannot be inserted into the database.

Action: Convert the fragment into a proper XML document before insertion.

ORA-19011 Character string buffer too small

Cause: The string result asked for is too big to return back

Action: Get the result as a lob instead

ORA-19012 Cannot convert XML fragment to the required datatype

Cause: A conversion to a datatype was requested which cannot be performed

Action: The XMLType may contain fragments and other elements which cannot be converted to the appropriate datatype.

ORA-19013 Cannot create VARRAY columns containing XMLType

Cause: An attempt was made to create a VARRAY column which contains a XMLType

Action: You cannot store VARRAYs containing XMLTypes in tables. Use nested tables instead

ORA-19015 Invalid XML tag identifier (string)

Cause: An invalid XML identifier was detected during XML generation.

Action: Fix the offending tag so it does not contain characters or symbols that are not allowed by the XML specification.

ORA-19016 attributes cannot occur after element specifications

Cause: Attributes specified using the "@" identifier can only occur before any other element definition when creating XML.

Action: Change the order of the types so that the attributes occur at the beginning.

ORA-19017 Attributes can only be simple scalars

Cause: Attribute values can only be simple scalar values.

Action: Use only simple datatypes for attribute values.

ORA-19018 Invalid character in XML tag 'string'

Cause: A tag name was found to have an invalid XML character during XML generation.

Action: Rewrite the query so that the generated XML tag, corresponding to a column name or alias, contains only valid characters.

ORA-19019 Invalid context passed to DBMS_XMLGEN.GETXML

Cause: The value of context passed to GETXML was invalid.

Action: Rewrite the query so that the value of context passed to GETXML is valid.

ORA-19020 invalid dereference of XMLType columns

Cause: An attempt was made to dereference the attributes of an XMLType column which is not part of a base table.

Action: You can only dereference the attributes of a base table XMLType column.

ORA-19023 The first argument to UPDATEXML operator has to be an XMLTYPE

Cause: The first argument passed to the update value operator was not an XMLTYPE.

Action: Rewrite the query so that the first argument to the UPDATEXML operator is XMLTYPE.

ORA-19024 Cursor expression must be named

Cause: The value of context passed to GETXML was invalid.

Action: Rewrite the query so that the value of context passed to GETXML is valid.

ORA-19025 EXTRACTVALUE returns value of only one node

Cause: Given XPath points to more than one node.

Action: Rewrite the query so that exactly one node is returned.

ORA-19026 EXTRACTVALUE can only retrieve value of leaf node

Cause: Given XPath does not point to a leaf node.

Action: Rewrite the query so that a leaf node is returned.

ORA-19028 Invalid ADT parameter passed to toObject() function

Cause: The object passed as ADT parameter to sys.XMLType.toObject() is not the same type, or a super-type, of the mapped type.

Action: Pass an object of the correct type to toObject().

ORA-19029 Cannot convert the given XMLType to the required type

Cause: The passed in XMLType could not be converted to the required type.

Action: Binary XMLtype instances or other objects cannot be converted to the required object or collection types.

ORA-19030 Method invalid for non-schema based XML Documents.

Cause: The method can be invoked on only schema based xmltype objects.

Action: Don't invoke the method for non schema based xmltype objects.

ORA-19031 XML element or attribute string does not match any in type string.string

Cause: The passed in XML tag does not match any in the object type.

Action: Pass a valid canonical XML that can map to the given object type.

ORA-19032 Expected XML tag string got string

Cause: When converting XML to object, a wrong tag name was present.

Action: Pass a valid canonical XML that can map to the given object type

ORA-19033 schema specified in the XML document does not match the schema parameter

Cause: When creating schema-based XML, the schema specified in the XML document is different from the schema passed in as the 'schema' parameter.

Action: Change the schema parameter to match the schema specified in the XML document.

ORA-19034 Type not supported during schema generation

Cause: The object type contained a type that is not supported for schema generation.

Action: Use a different type or do not generate a schema.

ORA-19200 Invalid column specification

Cause: All input arguments must be valid columns

Action: Specify a valid list of columns

ORA-19201 Datatype not supported

Cause: The particular datatype is not supported in the XMLGEN operator

Action: Specify only supported datatypes as arguments to the XMLGEN operator

ORA-19202 Error occurred in XML processing string

Cause: An error occurred when processing the XML function

Action: Check the given error message and fix the appropriate problem

ORA-19203 Error occurred in DBMS_XMLGEN processing string

Cause: An error occurred when processing the DBMS_XMLGEN functions

Action: Check the given error message and fix the appropriate problem

ORA-19204 Non-scalar value 'string' is marked as XML attribute

Cause: Only scalar values (that is values which are not of object or collection type) can be marked as XML attribute, that is prefixed by '@'. In this case, a non-scalar value was prefixed with '@'.

Action: Remove the '@' sign, or make the value a scalar.

ORA-19205 Attribute 'string' qualifies a non-scalar value in the select list

Cause: The attribute immediately follows a value of object or collection type in the select list or type definition.

Action: Remove the '@' sign, or make the previous value a scalar.

ORA-19206 Invalid value for query or REF CURSOR parameter

Cause: The queryString argument passed to DBMS_XMLGEN.newContext was not a valid query or REF CURSOR.

Action: Rewrite the query so that the queryString argument is a valid query or REF CURSOR.

ORA-19207 scalar parameter string of XMLELEMENT cannot have an alias.

Cause: The scalar parameter to XMLELEMENT has been qualified with an alias.

Action: Remove the AS clause of the scalar element.

ORA-19208 parameter string of function string must be aliased

Cause: The indicated parameter of the XML generation function has not been aliased, although it is an expression.

Action: Specify an alias for the expression using the AS clause.

ORA-19209 invalid or unsupported formatting argument

Cause: An invalid or unsupported formatting argument was supplied.

Action: Change the formatting argument to legal supported values.

ORA-19300 Error occurred in uri processing string

Cause: An error occurred when processing the URL

Action: Check the given error message and fix the appropriate problem

ORA-19320 Host name not specified in HTTP URL

Cause: A host name was not specified in the HTTP url

Action: Specify a host name in the HTTP url when creating the URL string

ORA-19321 Could not open HTTP connection to host (string): port (string)

Cause: A HTTP connection could not be opened to the host

Action: Specify a valid host name and port to connect to

ORA-19322 An error occurred while reading from host (string): port (string)

Cause: An error occurred while reading from the HTTP host

Action: Specify a valid host name and port to read from

ORA-19323 Invalid url string

Cause: The URL must be a valid URL string

Action: Specify a valid url string

ORA-19330 Type 'string'.'string' not installed. Please install the type before using the CREATE_DBURI operator

Cause: The type required for the CREATE_DBURI operator has not been installed correctly.

Action: Read the installation notes to install the type correctly.

ORA-19331 Last argument to CREATE_DBURI operator must be a column

Cause: The final argument to the CREATE_DBURI operator must be a column to which the reference is being created.

Action: Specify a valid column name in the query.

ORA-19332 Invalid column in the CREATE_DBURI operator

Cause: The argument to the CREATE_DBURI operator can only be a column.

Action: Specify a valid column name for the operator

ORA-19333 Invalid flags for the CREATE_DBURI operator

Cause: The flags argument given to the DBURI operator is invalid

Action: Specify a valid flag value (TEXT) for the DBURI operator

ORA-19334 Invalid column specification for CREATE_DBURI operator

Cause: All columns must be valid and pointing to the same table or view

Action: Specify valid list of columns that are from the same table or view.

ORA-19335 Invalid format type object

Cause: An invalid format type object was specified for the XML function

Action: Specify a valid format type object

ORA-19336 Missing XML root element

Cause: The XML being generated does not have an enclosing root element.

Action: The generated XML must have a root element.


ORA-19400 to ORA-24279

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

12
ORA-19400 to ORA-24279

ORA-19400 System type conflict with object SYS.string

Cause: The user had an object with the same name as one of the system types. The system types were not initialized properly.

Action: Remove the conflicting object and re-run migration.

ORA-19500 device block size string is invalid

Cause: The device block size returned by sequential I/O OSD is invalid.

Action: If the block size was set by using the PARMS option of the Recovery Manager ALLOCATE CHANNEL command, then the specified block size must be changed. If no PARMS option was specified on the ALLOCATE CHANNEL command, then this is an internal error that should be reported to Oracle.

ORA-19501 read error on file "string", blockno string (blocksize=string)

Cause: Read error on input file.

Action: Check the file.

ORA-19502 write error on file "string", blockno string (blocksize=string)

Cause: Write error on output file.

Action: Check the file.

ORA-19503 cannot obtain information on device, name="string", type="string", parms="string"

Cause: Call to get device information returned an error.

Action: Check device name, type, and parameters.

ORA-19504 failed to create file "string"

Cause: Call to create file returned an error.

Action: Check additional messages and check access permissions.

ORA-19505 failed to identify file "string"

Cause: Call to identify the file returned an error.

Action: Check additional messages, and check whether the file exists.

ORA-19506 failed to create sequential file, name="string", parms="string"

Cause: Call to create the sequential file returned an error.

Action: Check additional messages, check access permissions.

ORA-19507 failed to retrieve sequential file, handle="string", parms="string"

Cause: Call to retrieve the sequential file returned an error.

Action: Check additional messages, and check if the file exists.

ORA-19508 failed to delete file "string"

Cause: Call to delete the file returned an error.

Action: Check additional messages.

ORA-19509 failed to delete sequential file, handle="string", parms="string"

Cause: Call to delete the sequential file returned an error.

Action: Check additional messages.

ORA-19510 failed to set size of string blocks for file "string" (blocksize=string)

Cause: Call to resize the file returned an error.

Action: Check additional messages.

ORA-19511 Error received from media manager layer, error text: string

Cause: An error occurred in the media management software which is linked with the Oracle server to perform backup and restore in cooperation with Recovery Manager.

Action: If the text of message 19511 does not provide enough information to resolve the problem, then you should contact the vendor of the media management software.

ORA-19550 cannot use backup/restore functions while using dispatcher

Cause: An attempt was made to use backup/restore functions while connected to the dispatcher in a shared server. This is not allowed because the device that is used for backup and restore must remain allocated to a single process.

Action: Connect directly to the instance then re-execute the backup or restore function.

ORA-19551 device is busy, device type: string, device name: string

Cause: The indicated device could not be allocated because it is allocated to another session, or no device was named, or all devices of the requested type are busy.

Action: Either attempt to allocate another device or wait until the required device is no longer busy.

ORA-19552 device type string is invalid

Cause: The device type indicated is invalid.

Action: Supply a correct device type and retry the allocation.

ORA-19553 device name string is invalid

Cause: The device name indicated is invalid.

Action: Supply a correct device name and retry the allocation.

ORA-19554 error allocating device, device type: string, device name: string

Cause: The specified device could not be allocated.

Action: One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error and retry the allocation.

ORA-19555 invalid LOG_ARCHIVE_MIN_SUCCEED_DEST parameter value

Cause: The value of parameter LOG_ARCHIVE_MIN_SUCCEED_DEST was not set within the valid range.

Action: Specify a correct value for parameter LOG_ARCHIVE_MIN_SUCCEED_DEST. If the archive log parameters LOG_ARCHIVE_DEST or LOG_ARCHIVE_DUPLEX_DEST are in use, set parameter LOG_ARCHIVE_MIN_SUCCEED_DEST to either 1 or 2.

ORA-19556 required destination LOG_ARCHIVE_DUPLEX_DEST currently is deferred

Cause: The destination for parameter LOG_ARCHIVE_DUPLEX_DEST was deferred when it was required to be enabled. The destination was deferred automatically when an ALTER SYSTEM command for parameter LOG_ARCHIVE_DEST defined a destination which duplicated an existing LOG_ARCHIVE_DUPLEX_DEST parameter destination.

Action: Change the destination value for the LOG_ARCHIVE_DUPLEX_DEST parameter.

ORA-19557 device error, device type: string, device name: string

Cause: An error occurred in the platform-specific device code.

Action: One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error and retry the allocation.

ORA-19558 error de-allocating device

Cause: The specified device could not be de-allocated.

Action: One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error and retry the allocation.

ORA-19559 error sending device command: string

Cause: An error occurred while sending the indicated command to the session device.

Action: One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error and retry the allocation.

ORA-19560 string is not a valid device limit

Cause: An invalid type of device limit was specified in a call to X$DBMS_BACKUP_RESTORE.SETLIMIT.

Action: Use one of the documented limits: KBYTES, READRATE, or PARALLEL.

ORA-19561 string requires a DISK channel

Cause: The attempted command requires that a DISK device channel be allocated to the session, but a non-DISK device was found.

Action: Deallocate the current device and allocate a DISK channel, then retry the command.

ORA-19562 file string is empty

Cause: The indicated file, which is an archive log, control file, or datafile was found to be empty during a copy, backup, or scan] operation.

Action: Ensure that the correct files are being specified for the copy or backup operation.

ORA-19563 string header validation failed for file string

Cause: When opening the file to be placed in a copy or backup set, to be inspected, or used as the target for an incremental restore, the header was not recognized as a valid file header for a file of the indicated type (datafile, archived log, or control file), belonging to the current database.

Action: Ensure that the correct files are being specified for the copy or backup operation.

ORA-19564 error occurred writing string bytes at block number string

Cause: An error occurred while writing to a file.

Action: One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error if possible, then retry the copy, backup, or restore operation.

ORA-19565 BACKUP_TAPE_IO_SLAVES not enabled when duplexing to sequential devices

Cause: An attempt was made to specify duplexing to sequential devices, but the BACKUP_TAPE_IO_SLAVES initialization parameter was not enabled.

Action: Specify BACKUP_TAPE_IO_SLAVES=TRUE in the INIT.ORA file, or do not specify duplexing to sequential devices.

ORA-19566 exceeded limit of string corrupt blocks for file string

Cause: The user specified limit of allowable corrupt blocks was exceeded while reading the specified datafile for a datafile copy or backup.

Action: No action required. The copy or backup operation fails. The session trace file contains detailed information about which blocks were corrupt.

ORA-19567 cannot shrink file string because it is being backed up or copied

Cause: An ALTER statement attempted to reduce the size of the indicated file while the same file is being backed up or copied.

Action: Retry the resize after the backup or copy is complete.

ORA-19568 a device is already allocated to this session

Cause: A device cannot be allocated to a session if another device is already allocated.

Action: Deallocate the current device.

ORA-19569 no device is allocated to this session

Cause: An operation was attempted which requires a device to be allocated to the current session, and there is no device allocated.

Action: Allocate a device then retry the operation.

ORA-19570 file number string is outside valid range of 1 through string

Cause: A file number used in a copy, backup, or restore operation is not valid for the current database.

Action: Specify a valid file number.

ORA-19571 string recid string stamp string not found in controlfile

Cause: The input file specified for a copy or backup operation could not be opened because the record describing the file is not found in the control file.

Action: Specify a correct RECID/stamp and retry the copy or backup.

ORA-19572 cannot process file string, file is being being resized

Cause: The input file specified for a copy or backup operation could not be opened because the file is being resized.

Action: Wait for the resize to complete then retry the copy or backup.

ORA-19573 cannot obtain string enqueue for datafile string

Cause: The file access enqueue could not be obtained for a file specified in a backup, copy or restore operation. If the enqueue type shown is SHARED, then the file is the input file for a backup or copy. If the type is EXCLUSIVE, then the file is the output file for a datafile copy or restore which is attempting to overwrite the currently active version of that file. In this case, the file must be offline or the database must be closed. If the type is read-only, then you are attempting to back up or copy this file while the database is in NOARCHIVELOG mode.

Action: Wait until the conflicting operation is complete, then retry the copy or backup. If the database is in NOARCHIVELOG mode, then all files being backed up must be closed cleanly.

ORA-19574 output filename must be specified

Cause: This type of copy or restore requires an output file name.

Action: Specify an output file name and retry the copy.

ORA-19575 expected string blocks in file string, found string

Cause: During a backup, restore, copy, or scan operation, the indicated file did not contain as many blocks as were indicated in the file header.

Action: The input copy or backup piece is probably corrupt. If another backup or copy exists of the file that is being restored, then the corrupt file can be deleted from the recovery catalog and the operation can be restarted.

ORA-19576 datafile string not defined in control file

Cause: The specified file number was not found in the control file.

Action: Specify a correct file number and retry the operation.

ORA-19577 file string is MISSING

Cause: A copyDataFileCopy, restoreDataFileTo or proxyRestoreDataFile function specified a file number but no output file name, indicating that the output file name should be taken from the control file. However, the control file entry for this file indicates that it was created for a file that was present in the data dictionary but not named during the last CREATE CONTROLFILE statement, so the name in the control file cannot be used for restoration.

Action: Either specify an output file name or issue a SQL RENAME command to enter a valid name for this file in the control file.

ORA-19578 end of volume while duplexing to sequential files, backup piece incomplete

Cause: An end of volume (EOV) condition was detected while duplexing to sequential files, and this condition cannot be handled currently.

Action: Before retrying the backup, make sure the backup pieces will fit in the volume, or disable duplexing.

ORA-19579 archivelog record for string not found

Cause: No archived log record corresponding to the input file could be found in the control file.

Action: Specify a valid archive log file name and retry the operation.

ORA-19580 string conversation not active

Cause: A backup or restore operation was attempted before a conversation was started.

Action: Start a conversation then retry the operation.

ORA-19581 no files have been named

Cause: An attempt was made to proceed from the file naming phase to the piece processing phase of a backup or restore conversation before any files have been specified for backup or restore.

Action: Specify some files then retry the operation.

ORA-19582 archivelog file header validation for string failed

Cause: The archived log file header is corrupt and could not be validated.

Action: Provide a valid archive log file and retry the operation.

ORA-19583 conversation terminated due to error

Cause: An error occurred which forced the termination of the current backup or restore conversation.

Action: There should be other error messages to help identify the cause of the problem. Correct the error and begin another conversation.

ORA-19584 file string already in use

Cause: The indicated file, which was specified as the target for a copy, restore, or delete operation is already in use by the database.

Action: Specify a different name and retry the operation.

ORA-19585 premature end of volume on piece string

Cause: While creating the indicated backup piece, an end-of-volume condition was encountered before all of the backup set control data was written to the backup piece. This is most likely a media error, because the amount of backup set control data is very small in relation to the total amount of data in a backup set.

Action: Retry the piece with a larger piece of output media.

ORA-19586 string k-byte limit is too small to hold piece directory

Cause: The user-specified limit of k-bytes per backup piece is not enough to hold the backup set control data.

Action: Use the setLimit procedure to increase the k-byte limit and retry the operation.

ORA-19587 error occurred reading string bytes at block number string

Cause: An error occurred while reading from a file.

Action: One or more other messages should be displayed to help pinpoint the cause of the error. Correct the error then retry the copy, backup, or restore operation.

ORA-19588 string recid string stamp string is no longer valid

Cause: The indicated record has been marked as deleted. This indicates that the corresponding file has either been overwritten by another copy or restore, or that the copy was 'consumed' by a switchToCopy operation.

Action: If you know the name of the file you wish to copy, then inspect it and then retry the copy specifying the new RECID.

ORA-19589 string is not a snapshot or backup controlfile

Cause: The control file that is the source for a backup or copy operation is not a snapshot or backup control file.

Action: Specify the name of a snapshot or backup control file.

ORA-19590 conversation already active

Cause: An attempt was made to begin a backup or restore conversation, but another conversation is already active in this session.

Action: Either continue the current conversation, or call backupCancel or restoreCancel to end the current conversation before starting a new one.

ORA-19592 wrong string conversation type

Cause: An attempt was made to specify a type of file to be backed-up or restored, but the current conversation cannot process this type of file. For example, you specified an archived log to be included in a datafile backup set. The specified file will not be included in the backup or restore operation.

Action: No action required. The conversation is still active, and more files can be specified.

ORA-19593 datafile number string already included as string

Cause: This datafile is already specified for inclusion in this backup or restore conversation. A backup or restore conversation may process only a single instance of a datafile.

Action: No action required. The conversation is still active, and more files can be specified.

ORA-19594 controlfile already included as string

Cause: The control file is already specified for inclusion in this backup or restore conversation. A backup or restore conversation may process only a single instance of the control file.

Action: No action required. The conversation is still active, and more files can be specified.

ORA-19595 archivelog string already included in backup conversation

Cause: The indicated archive log has already been specified for inclusion in this backup conversation.

Action: No action required. The conversation is still active, and more files can be specified.

ORA-19596 SPFILE already included

Cause: The SPFILE is already specified for inclusion in this backup or restore conversation. A backup or restore conversation may process only a single instance of the SPFILE.

Action: No action required. The conversation is still active, and more files can be specified.

ORA-19597 file string blocksize string does not match set blocksize of string

Cause: A file was specified for inclusion in a backup set but it has a logical block size different from the rest of the files in the backup set. All files in a backup set must have the same logical block size.

Action: Specify a file that has the same block size as the rest of the files in the backup set. The conversation is still active and more files can be specified.

ORA-19598 can not backup SPFILE because the instance was not started with SPFILE

Cause: A backup command requested a backup of the SPFILE, but no SPFILE was used to start up the instance.

Action: Create an SPFILE and restart the instance using the SPFILE.

ORA-19599 block number string is corrupt in string string

Cause: A corrupt block was found in a controlfile, archivelog, or backup piece that is being read for a backup or copy. Corruption is not tolerated in controlfiles, archivelogs, or backup pieces.

Action: No action required. The copy or backup operation fails. Note that in the case of a backup set, the conversation is still active and the piece may be retried.

ORA-19600 input file is string string (string)

Cause: This message identifies the input file for a failed copy operation. Both the file number and name (if the name has been determined) are shown.

  • For a datafile, the file number refers to the datafile's absolute file number as shown in the DBA_DATA_FILES view.
  • For a datafile-copy, the file number refers to the copy's control file record number as shown in the V$DATAFILE_COPY view.
  • For a datafile-copy, the file number refers to the copy's control file record number as shown in the RECID column of the V$DATAFILE_COPY view.
  • For an archived log, the file number refers to the log's control file record number as shown in the RECID column of the V$ARCHIVED_LOG view.

Action: Other messages should display to help pinpoint the cause and the solution.

ORA-19601 output file is string string (string)

Cause: This message identifies the output file for a failed copy operation. The fields are as described in message 19600. When creating a new datafile copy, its control file record number may not have been determined when the message is printed. In that case, the record number shown is zero.

Action: See other error message.

ORA-19602 cannot backup or copy active file in NOARCHIVELOG mode

Cause: An attempt was made to copy or backup a file that was not closed cleanly, and the database was in NOARCHIVELOG mode. This is not allowed because when restored, the file will require redo application before it is usable, and redo is not currently being saved beyond the contents of the online redo logs.

Action: Take the tablespace offline clean or close the database and retry the copy or backup.

ORA-19603 cannot backup or copy active file with KEEP .. UNRECOVERABLE option

Cause: The user tried to copy or backup a file that was not closed cleanly, with the KEEP .. UNRECOVERABLE option. This is not allowed because when restored, the file will require redo application before it is usable, and redo will not be saved because of the KEEP .. UNRECOVERABLE option.

Action: Take the tablespace offline cleanly, or close the database and retry the copy or backup.

ORA-19604 conversation file naming phase is over

Cause: A call was made to specify a file to be backed up or restored after the first backup piece has been processed.

Action: You cannot specify more files to be processed during a backup or restore conversation after the first backup piece has been processed. If more files must be specified, you must begin a new conversation.

ORA-19605 input filename must be specified

Cause: The input file name was not specified for a control file copy operation.

Action: Specify an input file name and retry the operation.

ORA-19606 Cannot copy or restore to snapshot controlfile

Cause: A control file copy or restore operation specified the name of the snapshot control file as the output file. It is not permitted to overwrite the snapshot control file in this manner. Other methods are available to create the snapshot control file.

Action: Specify a different file name and retry the operation. If this is a restore, then the restore conversation remains active and more files may be specified.

ORA-19607 string is an active controlfile

Cause: A control file copy, restore, or backup specified the name of a control file named in the INIT.ORA file as the input or output file.

Action: Specify a different file name and retry the operation. If this is a backup or restore conversation, then the conversation remains active and more files may be specified.

ORA-19608 string is not a backup piece

Cause: The specified file is not a backup piece produced by the DBMS_BACKUP_RESTORE package. Either the first block of the backup piece is corrupt or this file is not a backup piece.

Action: Specify a different file name and retry the operation.

ORA-19609 string is from different backup set: stamp string count string

Cause: The specified file is not from the backup set which is currently being processed. It is part of a different backup set. The identification of the set containing this piece is shown.

Action: Specify the correct backup piece and retry the operation.

ORA-19610 directory block string is corrupt

Cause: The indicated directory block failed checksum validation. This backup piece is unusable.

Action: Supply another copy of the same backup piece, or terminate the restore conversation.

ORA-19611 backup piece out of order. Expected string but found string

Cause: This backup piece is out of sequence.

Action: Supply the correct backup piece.

ORA-19612 datafile string not restored due to string

Cause: The indicated file could not be restored, because all of its data blocks were not found in the backup piece.

Action: The restore conversation remains active, and the current piece must be reprocessed. If the failure cannot be resolved by reprocessing the current piece, then the restore conversation must be cancelled.

ORA-19613 datafile string not found in backup set

Cause: The indicated file could not be restored, because it is not in this backup set. If the file number is zero, then this refers to the control file.

Action: This message is issued when the directory from the first backup piece is read and one or more files named for restoration were not found. The restore conversation is still active, but no data has been read and you must supply the first backup piece of a backup set that contains all of the requested files.

ORA-19614 archivelog thread string sequence string not found in backup set

Cause: The indicated archived log file was named explicitly for restoration but is not contained in this backup set.

Action: This message is issued when the directory from the first backup piece is read and one or more files named for restoration were not found. The restore conversation is still active, but no data has been read and you must supply the first backup piece of a backup set that contains all of the requested files.

ORA-19615 some files not found in backup set

Cause: Some files that were specified for restoration were not found in the backup set directory. Message 19613 or 19614 is issued for each file that was not found.

Action: See the instructions for message 19613.

ORA-19616 output filename must be specified if database not mounted

Cause: A datafile restore specified no target file name, but the database is not mounted. The database must be mounted when no target file name is specified, so that the target file name can be obtained from the control file.

Action: The restore conversation remains active. If you wish to restore datafiles without their target file names, then mount the database before continuing. Otherwise, a target file name must be specified on all datafile restoration calls.

ORA-19617 file string contains different resetlogs data

Cause: The indicated file contains resetlogs data which is different from the archived log files which are already included in the backup set. All archived log files in a backup set must have the same resetlogs data.

Action: The restore conversation remains active, and you may continue to specify archived log files for inclusion in the backup set.

ORA-19618 cannot name files after restoreValidate has been called

Cause: A call was made to specify a file to restore from a backup set, but a previous call to restoreValidate has already been made.

Action: You must cancel and restart the conversation if you wish to specify files to restore.

ORA-19619 cannot call restoreValidate after files have been named

Cause: restoreValidate was called after some files had already been specified for restoration.

Action: You must cancel and restart the conversation if you wish to call restoreValidate.

ORA-19621 archivelog range has already been specified

Cause: A range of logs has already been specified. Only one SCN range may be specified per conversation.

Action: The restore conversation remains active and more logs may be specified by thread and sequence number, if desired.

ORA-19622 archivelog thread string sequence string not restored due to string

Cause: The indicated file could not be restored, because all of its data blocks were not found in the backup piece.

Action: The restore conversation remains active, and the current piece must be reprocessed. If the failure cannot be resolved by reprocessing the current piece, then the restore conversation must be cancelled.

ORA-19623 file string is open

Cause: A SwitchToCopy operation specified a datafile copy whose parent datafile is open.

Action: Take the owning tablespace offline or close the database, then retry the operation.

ORA-19624 operation failed, retry possible

Cause: A backup, restore or image copy operation failed with an I/O error. If the source of the I/O error can be corrected, then the operation may be retried.

Action: This message is used by Recovery Manager to decide whether or not to retry the operation.

ORA-19625 error identifying file string

Cause: A file specified as input to a copy or backup operation, or as the target for an incremental restore, could not be identified as an Oracle file. An operating system-specific error accompanies this error to help pinpoint the problem.

Action: Specify an different file and retry the operation.

ORA-19626 backup set type is string - can not be processed by this conversation

Cause: The data in the backup set is not compatible with the current conversation.

Action: Either supply the first piece from a backup set that matches the current conversation or start a new restore conversation which can process this backup set.

ORA-19627 cannot read backup pieces during controlfile application

Cause: This is a control file restore conversation, which is using the offline range information from one or more control files to update datafile checkpoint data. Backup sets are not used during this type of conversation.

Action: The conversation is still active and more control files may be applied.

ORA-19628 invalid SCN range

Cause: The starting SCN for restoreRedoLogRange is greater than the ending SCN.

Action: Specify a starting SCN which is less than or equal to the ending SCN.

ORA-19629 no files in specified archivelog SCN range

Cause: This backup set contains no files in the specified range.

Action: Either supply a backup set that contains files in the correct range or start a new conversation and specify a range which will select some files from this backup set.

ORA-19630 end of volume encountered while copying backup piece

Cause: While copying a backup piece from the operating system native file system to an output device, the output device encountered end-of-volume.

Action: The copy fails. This could happen if a tape was used which is not large enough to hold the entire backup piece.

ORA-19631 archivelog record contains no file name

Cause: This archive log record represents a switch into an active log that took place without archiving its prior contents. The prior contents of the log file are lost.

Action: Specify the RECID of an archive log record that contains a file name. Fixed view V$ARCHIVED_LOG can be used to examine the archived logs.

ORA-19632 file name not found in controlfile

Cause: The name passed to getFno was not found in the control file.

Action: Supply a valid file name.

ORA-19633 controlfile record string is out of sync with recovery catalog

Cause: The control file record describing the file to be deleted in a call to deleteBackupPiece, deleteDataFilecopy, proxyDelete or deleteArchivedLog does not match the validation data supplied by Recovery Manager.

Action: Contact Oracle Support Services.

ORA-19634 filename required for this function

Cause: The FNAME or handle parameter was not specified for deletePiece, deleteDataFileCopy, deleteRedoLog or proxyDelete.

Action: Specify the FNAME or handle parameter when calling these functions.

ORA-19635 input and output filenames are identical

Cause: Identical input and output file names were specified for a datafile copy operation.

Action: Specify an output file name which is different from the input file name.

ORA-19636 archivelog thread string sequence string already included

Cause: The indicated archive log has already been specified for inclusion in this restore conversation. A restore conversation may process only one copy of any archive log.

Action: No action required. The conversation is still active, and more files can be specified.

ORA-19637 backupPieceCreate requires file name when using DISK device

Cause: The session device is currently allocated to disk, and so a file name is required.

Action: Supply a file name and retry the operation.

ORA-19638 file string is not current enough to apply this incremental backup

Cause: The checkpoint of the target for this incremental backup is less than the start of the incremental backup. If this backup were applied, then any changes made between the datafile checkpoint and the start of the incremental backup could be lost.

Action: Supply a backup set that can be applied and retry the operation.

ORA-19639 file string is more current than this incremental backup

Cause: The checkpoint of the target for this incremental backup is greater than or equal to the checkpoint of the file in the incremental backup set. This backup cannot advance the checkpoint of the target file, so there is no point in applying it.

Action: Supply a backup set that can be applied and retry the operation.

ORA-19640 datafile checkpoint is SCN string time string

Cause: This message identifies the datafile checkpoint for a datafile that was too old to take an incremental backup from, or the target of an incremental restore that could not be applied.

Action: See other error message.

ORA-19641 backup datafile checkpoint is SCN string time string

Cause: This message identifies the checkpoint of a datafile in an incremental backup set that could not be applied.

Action: See other error message.

ORA-19642 incremental-start SCN is string

Cause: This message identifies the starting SCN of an incremental backup that could not be applied.

Action: See other error message.

ORA-19643 datafile string: incremental-start SCN is too recent

Cause: The incremental-start SCN which was specified when starting an incremental datafile backup is greater than the datafile checkpoint SCN, which could cause some blocks to be missed.

Action: Specify a smaller incremental-start SCN.

ORA-19644 datafile string: incremental-start SCN is prior to resetlogs SCN string

Cause: The incremental-start SCN which was specified when starting an incremental datafile backup is less than the resetlogs SCN.

Action: Specify a larger incremental-start SCN.

ORA-19645 datafile string: incremental-start SCN is prior to creation SCN string

Cause: The incremental-start SCN which was specified when starting an incremental datafile backup is less than the datafile's creation SCN.

Action: Specify a larger incremental-start SCN.

ORA-19646 cannot change size of datafile string from string to string

Cause: The indicated file was resized before this incremental backup was taken, but the incremental backup failed to set the file to the new size.

Action: Examine the other messages which should be present to indicate the cause of the failure.

ORA-19647 non-zero LEVEL cannot be specified when INCREMENTAL is FALSE

Cause: BackupSetDataFile was called with a non-zero BACKUP_LEVEL and a FALSE incremental indication.

Action: Either set incremental to TRUE or change BACKUP_LEVEL to zero.

ORA-19648 datafile string: incremental-start SCN equals checkpoint SCN

Cause: The incremental-start SCN which was specified when starting an incremental datafile backup is equal to the datafile's checkpoint SCN. Since an incremental backup can only be applied to a datafile whose checkpoint SCN is between the backup set incremental-start SCN (inclusive) and the backup set checkpoint SCN (exclusive), there is no datafile that this backup set could ever be applied to.

Action: Specify a smaller incremental-start SCN.

ORA-19649 offline-range record recid string stamp string not found in file string

Cause: applyOfflineRange was called with a RECID/stamp which was not found in the indicated control file. This probably means that the specified control file is no longer the same control file that Recovery Manager thinks it is.

Action: Specify the RECID/stamp of a record that exists in the control file copy.

ORA-19650 Offline-range record recid string stamp string in file string has SCN string

Cause: This messages identifies the offline-clean SCN from the indicated offline-range record in the indicated file.

Action: See other error message.

ORA-19651 cannot apply offline-range record to datafile string: SCN mismatch

Cause: applyOfflineRange cannot apply an offline-range record to a target datafile unless the datafile's checkpoint SCN exactly matches the offline-clean SCN in the specified offline-range record.

Action: Specify an offline-range record whose offline-clean SCN matches the target datafile's checkpoint.

ORA-19652 cannot apply offline-range record to datafile string: file is fuzzy

Cause: The target datafile for an applyOfflineRange call is fuzzy.

Action: Specify a target datafile that is closed cleanly.

ORA-19653 cannot switch to older file incarnation

Cause: SwitchToCopy was called with a datafile copy for a datafile that was dropped prior to the time this control file was backed up.

Action: Restore and mount an earlier control file. It is acceptable to use a control file that was backed up prior to the creation of the specified datafile.

ORA-19654 must use backup controlfile to switch file incarnations

Cause: This switchToCopy operation is attempting to switch incarnations of a datafile, but the currently mounted control file is not a backup control file.

Action: Restore and mount a backup control file.

ORA-19655 cannot switch to incarnation with different resetlogs data

Cause: This switchToCopy operation is attempting to switch to a datafile which comes from a different resetlogs version of the database.

Action: Either restore a backup control file that was taken from the same database version as the target datafile-copy, or switch to a different datafile-copy.

ORA-19656 cannot backup, copy, or delete online log string

Cause: The indicated log file is an active log. You can only backup, copy, or delete archived logs.

Action: The indicated log file cannot be processed. Select another file.

ORA-19657 cannot inspect current datafile string

Cause: The file being inspected is already part of the currently mounted database.

Action: No action required. The file is already part of the database.

ORA-19658 cannot inspect string - file is from different resetlogs

Cause: The resetlogs data in the log file being inspected does not match that in the currently mounted control file.

Action: The indicated file cannot be processed; inspect another file.

ORA-19659 incremental restore would advance file string past resetlogs

Cause: This incremental backup cannot be applied to the specified datafile, because the datafile is from an earlier incarnation of the database, and its checkpoint would be advanced too far to be recoverable in the current incarnation of the database.

Action: This incremental cannot be applied to this datafile. If you wish to recover the file to the resetlogs SCN so that the database can be opened with the RESETLOGS option, then you must use redo-log recovery, not incremental restore, to continue recovering this file.

ORA-19660 some files in the backup set could not be verified

Cause: A restore conversation was made to verify all the files in a backup set, and the files which were printed in messages 19661 or 19662 could not be verified because corrupt blocks for those files were found in the backup set.

Action: Unless the damage to the backup set can be repaired, the indicated files cannot be restored from this backup set.

ORA-19661 datafile string could not be verified

Cause: Some data blocks for the indicated datafile were corrupt in the backup set.

Action: Unless the damage to the backup set can be repaired, the indicated datafile cannot be restored from this backup set.

ORA-19662 archived log thread string sequence string could not be verified

Cause: Some data blocks for the indicated archived log were corrupt in the backup set.

Action: Unless the damage to the backup set can be repaired, the indicated archived log cannot be restored from this backup set.

ORA-19663 cannot apply current offline range to datafile string

Cause: An attempt was made to apply the current offline range to the specified datafile, but the datafile is either not current enough or is not at the correct SCN to apply the offline range.

Action: The datafile remains unchanged.

ORA-19664 file type: string, file name: string

Cause: This message is issued to identify the file which is the subject of an error.

Action: No action required. This is an informational message. There should be other Oracle messages explaining the cause of the error.

ORA-19665 size string in file header does not match actual file size of string

Cause: The size of the file as indicated in the file header does not match the true size of the file. The two differing sizes are shown in units of logical blocks.

Action: This file is not usable; it has most likely been truncated.

ORA-19666 cannot do incremental restore of the controlfile

Cause: The control file was included in an incremental restore conversation

Action: If you wish to restore the control file, you must do a full restore of the control file.

ORA-19667 cannot do incremental restore of datafile string

Cause: The backup of the datafile is a full backup.

Action: If you wish to restore the datafile, you must do a full restore of the datafile.

ORA-19668 cannot do full restore of datafile string

Cause: The backup of the datafile is an incremental backup.

Action: If you wish to restore the datafile, you must do an incremental restore of the datafile.

ORA-19669 proxy copy functions cannot be run on DISK channel

Cause: A proxy copy procedure was called, but the device which is allocated to the current session has type DISK.

Action: Allocate a non-DISK channel and retry the operation. Note that proxy copy requires a third-party media management software product that supports the this backup/restore feature.

ORA-19670 file string already being restored

Cause: A proxy restore function has already named this file as a restore destination.

Action: Use a different file name. If this message occurs during a Recovery Manager job, then this is an internal error in Recovery Manager, and you should contact Oracle Support Services.

ORA-19671 media management software returned invalid proxy handle

Cause: During a proxy backup or restore, the media management software returned an invalid file handle. This is an internal error in the media management software which is linked with Oracle to provide backup/restore services.

Action: Contact the media management software vendor.

ORA-19672 media management software returned invalid file status

Cause: During a proxy backup or restore, the media management software returned an invalid file status. This is an internal error in the media management software which is linked with Oracle to provide backup/restore services.

Action: Contact the media management software vendor.

ORA-19673 error during proxy copy of file string

Cause: During a proxy backup or restore, an error occurred while copying this file, but other files may have been copied successfully.

Action: There should be other errors on the error stack which explain why the file could not be successfully copied.

ORA-19674 file string is already being backed up with proxy copy

Cause: Recovery Manager attempted to back up the specified file with proxy copy, but the file is already being backed up by another Recovery Manager job.

Action: Wait until the other Recovery Manager backup of this file is complete, then retry the backup.

ORA-19675 file string was modified during proxy copy

Cause: A proxy backup of the specified file failed because the file was brought online or otherwise modified while the proxy backup was in progress. This file was offline or read only when the backup began, so the file was not put into hot-backup mode, therefore no modifications are permitted while the backup is in progress.

Action: Take another backup of this file.

ORA-19676 one or more files failed during proxy backup or restore

Cause: During a proxy backup or restore, errors were encountered while processing some files. The files for which no error messages are shown were processed successfully.

Action: Examine the messages regarding the specific files to determine the cause of the problems.

ORA-19677 RMAN configuration name exceeds maximum length of string

Cause: The configuration name string exceeds the maximum length.

Action: Supply a correct configuration name and retry the function.

ORA-19678 RMAN configuration value exceeds maximum length of string

Cause: The configuration value string exceeds the maximum length.

Action: Supply a correct configuration value and retry the operation.

ORA-19679 RMAN configuration number string is outside valid range of 1 through string

Cause: An invalid RMAN Configuration number was specified.

Action: Specify a correct datafile number and retry the operation.

ORA-19680 some blocks not recovered. See trace file for details

Cause: Some blocks were not recovered during block media recovery.

Action: See trace files for details of the problem.

ORA-19681 block media recovery on control file not possible

Cause: File number 0 was specified in block media recovery.

Action: Check file number.

ORA-19683 real and backup blocksize of file string are unequal

Cause: The block size changed between the backup & the real file.

Action: Use the correct backup.

ORA-19684 block media recovery failed because database is suspended

Cause: Database is suspended, probably by an ALTER SYSTEM SUSPEND statement.

Action: Execute ALTER SYSTEM RESUME then retry block media recovery.

ORA-19690 backup piece release string incompatible with Oracle release string

Cause: The backup piece was created by incompatible software.

Action: Either restart with a compatible software release or create another backup using the current release.

ORA-19700 device type exceeds maximum length of string

Cause: The device type indicated is invalid.

Action: Supply a correct device type and retry the allocation.

ORA-19701 device name exceeds maximum length of string

Cause: The device name indicated is invalid.

Action: Supply a correct device name and retry the allocation.

ORA-19702 device parameter exceeds maximum length of string

Cause: The device parameter exceeds the port-specific maximum length.

Action: Correct the parameter and retry the operation.

ORA-19703 device command string exceeds maximum length of string

Cause: The device command string exceeds maximum length.

Action: Correct the command and retry the operation.

ORA-19704 file name exceeds maximum length of string

Cause: The specified file name, which was a parameter to a copy, backup, or restore operation, exceeds the maximum file name length for this operating system.

Action: Retry the operation with a shorter file name.

ORA-19705 tag value exceeds maximum length of string characters

Cause: During a backup or copy operation, the user supplied a tag value too long to fit in the file header.

Action: Supply a shorter tag and retry the operation.

ORA-19706 invalid SCN

Cause: The input SCN is either not a positive integer or too large.

Action: Check the input SCN and make sure it is a valid SCN.

ORA-19707 invalid record block number - string

Cause: The input number is either negative or too large.

Action: Check the input record block number and make sure it is a valid number clauses in the CREATE DATABASE statement.

ORA-19708 log destination exceeds maximum length of string characters

Cause: When starting a restore conversation, the user specified a log restore destination longer than the port-specific maximum.

Action: Supply a shorter destination and retry the operation.

ORA-19709 numeric parameter must be non-negative integer

Cause: A numeric parameter to an X$DBMS_BACKUP_RESTORE procedure is negative or contains a fractional portion.

Action: Supply a valid numeric parameter.

ORA-19710 unsupported character set string

Cause: When the target database is not mounted, RMAN sets the target database character set to the value specified in the users environment.

Action: Specify a valid character set in the environment. This is usually done via the NLS_LANG environment variable.

ORA-19711 cannot use reNormalizeAllFileNames while database is open

Cause: An attempt was made to re-normalize all the file names in the control file while the database is open.

Action: Close the database before using the reNormalizeAllFileNames procedure.

ORA-19712 table name exceeds maximum length of string

Cause: The table name string exceeds the maximum length.

Action: Retry the operation with a shorter table name.

ORA-19713 invalid copy number: string

Cause: The copy number is not in a valid range or you have reached the maximum limit.

Action: Report the error and other information to support.

ORA-19714 length for generated piece name longer than string

Cause: The specified format exceeds the maximum length for the piece name.

Action: Change the format to create shorter piece names.

ORA-19715 invalid format for piece name

Cause: A restricted format was used incorrectly.

Action: Change the format by removing the restricted format.

ORA-19720 Error occurred when converting an OCI number into an SCN

Cause: This is most likely caused by an invalid SCN number that came from an external file, such as an export file.

Action: See other errors on the error stack to look for the source of the problem.

ORA-19721 Cannot find datafile with absolute file number string in tablespace string

Cause: Cannot find one of the data files that should be in the pluggable set.

Action: Make sure all datafiles are specified via import command line option or parameter files.

ORA-19722 datafile string is an incorrect version

Cause: The datafile is an incorrect version. It contains either less or more changes then the desired version.

Action: Make sure the right datafiles are transported. Make sure the datafile is copied while its tablespace is read only.

ORA-19723 Cannot recreate plugged in read-only datafile string

Cause: The datafile is plugged in read only. It cannot re-created.

Action: Use ALTER DATABASE RENAME FILE command instead.

ORA-19724 snapshot too old: snapshot time is before file string plug-in time

Cause: The snapshot SCN is before the SCN at which the referred datafile is plugged into the database.

Action: retry the query.

ORA-19725 can not acquire plug-in enqueue

Cause: There maybe another ALTER DATABASE RESET COMPATIBILITY command issued concurrently, preventing this process from acquiring the plug-in enqueue.

Action: Retry the operation.

ORA-19726 cannot plug data [string] at level string into database running at compatibility level string

Cause: Some of the data in the pluggable set requires a compatibility level higher than what is currently allowed by the database. The string in square bracket is the name of the compatibility type associated with the data.

Action: Raise the value of the COMPATIBLE initialization parameter and retry the operation.

ORA-19727 cannot plug data [string] at level string into database running Oracle string

Cause: Some of the data in the pluggable set requires a compatibility level higher than the release level of the Oracle executable. The string in square bracket is the name of the compatibility type associated with the data.

Action: Upgrade Oracle and retry the operation.

ORA-19728 data object number conflict between table string and partition string in table string

Cause: The non-partitioned table has the same data object number as one of the partitions in the partitioned table. One cannot exchange the table with the partition in this case.

Action: Use the ALTER TABLE MOVE PARTITION command to move the offending partition, so that the partition will get a new data object number. Retry the operation then.

ORA-19729 File string is not the initial version of the plugged in datafile

Cause: The file is not the initial version of the plugged in datafile.

Action: Use the correct initial version of the plugged in datafile.

ORA-19730 can not convert offline plugged-in datafile string

Cause: As part of making a tablespace read-write, we need to convert datafiles that are plugged in read only. The file must be online.

Action: Bring the datafile online and retry the operation.

ORA-19731 cannot apply change to unverified plugged-in datafile string

Cause: Recovery was not able to verify the referred datafile according to information in the control file. Before encountering this change vector for this file, somehow recovery did not encounter the file conversion redo that is supposed to verify the file. This may happen due to corrupted or incorrect control file used for media recovery.

Action: Use the correct control file and continue recovery.

ORA-19732 incorrect number of datafiles for tablespace string

Cause: The number of datafiles in the export file for the referred tablespace is not the same as expected. This is most likely caused by a user editing the export file.

Action: Use the correct export file and retry the operation.

ORA-19733 COMPATIBLE parameter needs to be string or greater

Cause: The COMPATIBLE initialization parameter is not high enough to allow the operation. Allowing the command would make the database incompatible with the release specified by the current COMPATIBLE parameter.

Action: Shutdown and restart with a higher compatibility setting.

ORA-19734 wrong creation SCN - control file expects converted plugged-in datafile

Cause: When a tablespace is plugged into a database, the tablespace is initially read only. Oracle converts the header of the plugged-in datafiles (assign them a new creation SCN) when the tablespace is first made read-write. This error occurs when the creation SCN in the file header is different from the creation SCN in the control file, possibly because this is the initial version of plugged-in datafile.

Action: Either restore the converted datafile or continue recovering the datafile.

ORA-19735 wrong creation SCN - control file expects initial plugged-in datafile

Cause: When a tablespace is plugged into a database, the tablespace is initially read only. Oracle converts the header of the plugged-in datafiles (assign them a new creation SCN) when the tablespace is first made read-write. This error occurs when the creation SCN in the file header is different from the creation SCN in the control file, possibly because this is the converted datafile.

Action: Either restore the initial version of the plugged-in datafile, or continue database recovery, which will recover the control file.

ORA-19736 can not plug a tablespace into a database using a different national character set

Cause: Oracle does not support plugging a tablespace into a database using a different national character set.

Action: Use import/export or unload/load to move data instead.

ORA-19999 skip_row procedure was called

Cause: The SKIP_ROW procedure was called which raises this error.

Action: SKIP_ROW should only be called within a trigger or a procedure called by a trigger.

ORA-20000 string

Cause: The stored procedure RAISE_APPLICATION_ERROR was called which causes this error to be generated.

Action: Correct the problem as described in the error message or contact the application administrator or database administrator for more information.

ORA-21000 error number argument to raise_application_error of stringstring is out of range

Cause: An attempt was made to specify a number not in the allowed range.

Action: Use an error number in the range of -20000 to -20999, inclusive.

ORA-21001 error number argument to raise_system_error of stringstring is out of range

Cause: An attempt was made to specify a number not in the allowed range.

Action: Use an error number in the range of -23300 to -24299, or -29300 to -29399, inclusive.

ORA-21300 objects option not installed

Cause: The objects option is not installed at this site. object types and other object features are, therefore, unavailable.

Action: Install the objects option. The objects option is not part of the Oracle Server product and must be purchased separately. Contact Oracle Support Services if the objects option needs to be purchased.

ORA-21301 not initialized in object mode

Cause: This function requires the OCI process to be initialized in object mode.

Action: Specify OCI_OBJECT mode when calling OCIInitialize().

ORA-21500 internal error code, arguments: [string], [string], [string], [string], [string], [string], [string], [string]

Cause: This is the generic error number for the OCI environment (client-side) internal errors. This indicates that the OCI environment has encountered an exceptional condition.

Action: Report to Oracle Support Services. The first argument is the internal error number.

ORA-21501 program could not allocate memory

Cause: The operating system has run out of memory.

Action: Take action to make more memory available to the program.

ORA-21503 program terminated by fatal error

Cause: A program is in an unrecoverable error state.

Action: Report to Oracle Support Services.

ORA-21520 database server driver not installed

Cause: User attempted to access a database server through an object-mode OCI environment but the necessary driver for supporting such access to the database server is not installed or linked in.

Action: Check if the driver corresponding to the database server has been installed/linked in and entered in the server driver table.

ORA-21521 exceeded maximum number of connections in OCI (object mode only)

Cause: User exceeded the maximum number of connections (255) that can be supported by an OCI environment in object mode.

Action: Close some of existing and unused connections before opening more connections.

ORA-21522 attempted to use an invalid connection in OCI (object mode only)

Cause: User attempted to use an invalid connection or a connection that has been terminated in an OCI environment (object mode), or user attempted to de-reference a REF obtained from a connection which has been terminated.

Action: Ensure that the connection exists and is still valid.

ORA-21523 functionality not supported by the server (object mode only)

Cause: User attempted to use a functionality that the server does not support.

Action: Upgrade the server.

ORA-21524 object type mismatch

Cause: The object type of the object is different from what is specified.

Action: Check the type of the object and correct it.

ORA-21525 attribute number or (collection element at index) string violated its constraints

Cause: Attribute value or collection element value violated its constraint.

Action: Change the value of the attribute or collection element such that it meets its constraints. The constraints are specified as part of the attribute or collection element's schema information.

ORA-21526 initialization failed

Cause: The initialization sequence failed. This can happen, for example, if an environment variable such as NLS_DATE_FORMAT is set to an invalid value.

Action: Check that all NLS environment variables are well-formed.

ORA-21560 argument string is null, invalid, or out of range

Cause: The argument is expecting a non-null, valid value but the argument value passed in is null, invalid, or out of range. Examples include when the LOB/FILE positional or size argument has a value outside the range 1 through (4GB - 1), or when an invalid open mode is used to open a file, and so on.

Action: Check your program and correct the caller of the routine to not pass a null, invalid or out-of-range argument value.

ORA-21561 OID generation failed

Cause: The handles passed in may not be valid.

Action: Check the validity of the env, svc handles.

ORA-21600 path expression too long

Cause: The path expression that is supplied by the user is too long. The path expression is used to specify the position of an attribute in an object. This error occurs when one of the intermediate elements in the path expression refers to an attribute of a built-in type. Thus, the OCI function cannot proceed on to process the rest of the elements in the path expression.

Action: Pass in the correct path expression to locate the attribute.

ORA-21601 attribute is not an object

Cause: The user attempts to perform an operation (that is valid only for an object) to an attribute of a built-in type. An example of such an illegal operation is to dynamically set a null structure to an attribute of a built-in type.

Action: Avoid performing such operation to an attribute of built-in type.

ORA-21602 operation does not support the specified typecode

Cause: The user attempts to perform an operation that does not support the specified type code.

Action: Use the range of valid type codes that are supported by this operation.

ORA-21603 property id [string] is invalid

Cause: The specified property ID is invalid.

Action: Specify a valid property ID. Valid property IDs are enumerated by OCIObjectPropId.

ORA-21604 property [string] is not a property of transient or value instances

Cause: An attempt was made to get a property which applies only to persistent objects.

Action: Check the lifetime and only get this property for persistent objects.

ORA-21605 property [string] is not a property of value instances

Cause: An attempt was made to get a property which applies only to persistent and transient objects.

Action: Check the lifetime and only get this property for persistent and transient objects.

ORA-21606 can not free this object

Cause: An attempt was made to free an object that is persistent and dirty and the OCI_OBJECTFREE_FORCE flag is not specified.

Action: Either flush the persistent object or set the flag to OCI_OBJECTFREE_FORCE

ORA-21607 memory cartridge service handle not initialized

Cause: Attempt to use the handle without initializing it.

Action: Initialize the memory cartridge service handle.

ORA-21608 duration is invalid for this function

Cause: Attempt to use a duration not valid for this function.

Action: Use a valid duration: a previously created user duration or OCI_DURATION_STATEMENT or OCI_DURATION_SESSION. For callout duration or external procedure duration, use OCIExtProcAllocCallMemory.

ORA-21609 memory being resized without being allocated first

Cause: Attempt to resize memory without allocating it first.

Action: Allocate the memory first before resizing it.

ORA-21610 size [string] is invalid

Cause: Attempt to resize memory with invalid size.

Action: Pass in a valid size (must be a positive integer).

ORA-21611 key length [string] is invalid

Cause: Attempt to use an invalid key length.

Action: Key length is invalid and valid range is 0 to 64.

ORA-21612 key is already being used

Cause: Attempt to use a key that is already used.

Action: Use a new key that is not yet being used.

ORA-21613 key does not exist

Cause: Attempt to use a non-existent key.

Action: Use a key that already exists.

ORA-21614 constraint violation for attribute number string

Cause: Constraints on the attribute were violated.

Action: Correct the value (of the attribute) so that it satisfies constraints.

ORA-21615 copy of an OTS (named or simple) instance failed

Cause: See following message.

Action: Check that no attribute value violates constraints.

ORA-21700 object does not exist or is marked for delete

Cause: User attempted to perform an inappropriate operation to an object that is non-existent or marked for delete. Operations such as pinning, deleting and updating cannot be applied to an object that is non-existent or marked for delete.

Action: Re-initialize the reference to reference an existent object or unmark the object.

ORA-21701 attempt to flush objects to different servers

Cause: User attempted to flush objects to different servers in one function call. These objects are obtained by calling a callback functions provided by the program.

Action: Avoid performing this operation.

ORA-21702 object is not instantiated or has been de-instantiated in cache

Cause: User attempted to perform an inappropriate operation to a transient object that is not instantiated in the object cache. Operations that cannot be applied to a not-instantiated transient object include deleting or pinning such an object.

Action: Check their code to see if they are performing such an operation without instantiating the object first, or performing such an operation after the allocation duration of the object has expired.

ORA-21703 cannot flush an object that is not modified

Cause: See the error message.

Action: The object should not be flushed.

ORA-21704 cannot terminate cache or connection without flushing first

Cause: See the error message.

Action: The transaction should be aborted or committed before terminating the cache or connection.

ORA-21705 service context is invalid

Cause: The service context that is supplied by the user is not valid.

Action: Establish the service context.

ORA-21706 duration does not exist or is invalid

Cause: The duration number that is supplied by the user is not valid.

Action: Establish the duration or use a correct predefined duration.

ORA-21707 pin duration is longer than allocation duration

Cause: The pin duration supplied by the user is longer than the allocation duration. This affects operations such as pinning and setting default parameters.

Action: Use a shorter pin duration or use the null duration.

ORA-21708 inappropriate operation on a transient object

Cause: An attempt was made to perform an inappropriate operation on a transient object. Operations that cannot be applied to a transient object include flushing and locking.

Action: Avoid performing such operations on a transient object.

ORA-21709 cannot refresh an object that has been modified

Cause: An attempt was made to refresh an object that has been marked for delete, update or insert (new).

Action: Unmark the object before refreshing it.

ORA-21710 argument is expecting a valid memory address of an object

Cause: The object memory address that is supplied by the user is invalid. The user may have passed in a bad memory address to a function that is expecting a valid memory address of an object.

Action: Pass in a valid memory address of an object to the function.

ORA-21779 duration not active

Cause: An attempt was made to use a duration that has been terminated.

Action: Avoid performing such operation.

ORA-22053 overflow error

Cause: This operation's result is above the range of Oracle number.

Action: Decrease the input value(s) so that the result is in the range of Oracle number.

ORA-22054 underflow error

Cause: This operation's result is below the range of Oracle number.

Action: Increase the input value(s) so that the result is in the range of Oracle number.

ORA-22055 unknown sign flag value [string]

Cause: Signed flag used is not OCI_NUMBER_SIGNED or OCI_NUMBER_UNSIGNED.

Action: Use either OCI_NUMBER_SIGNED or OCI_NUMBER_UNSIGNED as sign flag.

ORA-22056 value [string] is divided by zero

Cause: Given value is divided by zero.

Action: Modify divisor value to be non-zero.

ORA-22057 bad integer length [string]

Cause: The length of the integer (that is, number of bytes) to be converted to or from an Oracle number is invalid.

Action: Use integer length 1, 2, 4 or 8 bytes only.

ORA-22059 buffer size [string] is too small - [string] is needed

Cause: The buffer to hold the resulting text string is too small.

Action: Provide a buffer of the required size.

ORA-22060 argument [string] is an invalid or uninitialized number

Cause: An invalid or uninitialized number was passed in.

Action: Use a valid number. To initialize a number, call OCINumberSetZero().

ORA-22061 invalid format text [string]

Cause: The numeric format string for converting characters to or from an Oracle number is invalid.

Action: Use valid format string as documented in the Oracle Call Interface Programmer's Guide.

ORA-22062 invalid input string [string]

Cause: The text string for converting to numbers is invalid.

Action: Use a valid input string as documented in the Oracle Call Interface Programmer's Guide.

ORA-22063 reading negative value [string] as unsigned

Cause: An attempt was made to convert a negative number to an unsigned integer.

Action: Use the sign flag ORLTSB to convert a signed number.

ORA-22064 invalid NLS parameter string [string]

Cause: The NLS parameter string for converting characters to or from an Oracle number is invalid.

Action: Use valid format string as documented in the Oracle Call Interface Programmer's Guide.

ORA-22065 number to text translation for the given format causes overflow

Cause: Rounding done due to the given string format causes overflow.

Action: Change the string format such that overflow does not occur.

ORA-22130 buffer size [string] is less than the required size [string]

Cause: The size of the buffer into which the hexadecimal REF string is to be written is too small.

Action: Provide a buffer of the required size.

ORA-22131 hexadecimal string length is zero

Cause: The given hexadecimal string length must be greater than zero.

Action: Specify a length greater than zero.

ORA-22132 hexadecimal string does not correspond to a valid REF

Cause: The given hexadecimal string is invalid.

Action: Provide a valid hexadecimal string which was previously returned by a call to OCIRefToHex().

ORA-22140 given size [string] must be in the range of 0 to [string]

Cause: The given resize size is invalid.

Action: Ensure that the given size is in the required range.

ORA-22150 variable-length array has not been initialized

Cause: An un-initialized variable-length array is being operated upon.

Action: Initialize the variable-length array prior to calling this function.

ORA-22151 cannot resize non-zero variable-length array to zero elements

Cause: An attempt was made to resize a non-zero variable-length array to 0 elements.

Action: Specify a non-zero size.

ORA-22152 destination variable-length array is not initialized

Cause: The variable-length array on the right-hand-side of an assignment or the destination array of an append is not initialized.

Action: Initialize the destination variable-length array prior to calling this function.

ORA-22153 source variable-length array is not initialized

Cause: The variable-length array on the left-hand-side of an assignment or the source array of an append is not initialized.

Action: Initialize the destination variable-length array prior to calling this function.

ORA-22160 element at index [string] does not exist

Cause: Collection element at the given index does not exist.

Action: Specify the index of an element which exists.

ORA-22161 type code [string] is not valid

Cause: Given type code is not valid.

Action: Use one of the type codes enumerated in OCITypeCode.

ORA-22162 element at index [string] has been previously deleted

Cause: An attempt was made to delete a non-existent collection element.

Action: Check for the existence of the element prior to calling this function.

ORA-22163 left hand and right hand side collections are not of same type

Cause: Left hand and right side collections are not of same type.

Action: Ensure that the same collection type is passed for both left hand and right hand side of this function.

ORA-22164 delete element operation is not allowed for variable-length array

Cause: An attempt was made to delete an element of a variable-length array.

Action: Ensure that the collection is not a variable-length array prior to calling this function.

ORA-22165 given index [string] must be in the range of 0 to [string]

Cause: Given index is not in the required range.

Action: Ensure that the given index is in the required range.

ORA-22166 collection is empty

Cause: Given collection is empty.

Action: Test if collection is empty prior to invoking this function.

ORA-22167 given trim size [string] must be less than or equal to [string]

Cause: Given trim size is greater than the current collection size.

Action: Ensure that the given size is less than or equal to the collection size prior to calling this function.

ORA-22275 invalid LOB locator specified

Cause: There are several causes:

  1. The LOB locator was never initialized
  2. The locator is for a BFILE and the routine expects a BLOB/CLOB/NCLOB locator
  3. The locator is for a BLOB/CLOB/NCLOB and the routine expects a BFILE locator
  4. Trying to update the LOB in a trigger body -- LOBs in trigger bodies are read-only
  5. The locator is for a BFILE/BLOB and the routine expects a CLOB/NCLOB locator
  6. The locator is for a CLOB/NCLOB and the routine expects a BFILE/BLOB locator

Action: For (1), initialize the LOB locator by selecting into the locator variable or by setting the LOB locator to empty. For (2),(3), (5), and (6),pass the correct type of locator into the routine. For (4), remove the trigger body code that updates the LOB value.

ORA-22276 invalid locator for LOB buffering

Cause: One of the following:

  1. The locator was never enabled for buffering.
  2. It is not an updated locator but is being used for a write/flush operation.

Action: For (1) enable the locator for buffering; (2) ensure that only an updated locator is used for a LOB update operation.

ORA-22277 cannot use two different locators to modify the same LOB

Cause: LOB buffering is enabled and an attempt was made to modify the LOB using two different LOB locators.

Action: When using LOB buffering, modify the LOB through one LOB locator only.

ORA-22278 must update the LOB only through the LOB buffers

Cause: LOB buffering is enabled for this LOB and there are buffers for this LOB in the buffer pool. Thus, updating the LOB through means other than the LOB buffers is not allowed.

Action: Update the LOB through the LOB buffers using the locator that has LOB buffering enabled. If this operation is required, buffers associated with this LOB should either be flushed as necessary or buffering should be disabled. Once this is done, reissue the command.

ORA-22279 cannot perform operation with LOB buffering enabled

Cause: The operation attempted is not allowed when LOB buffering is enabled.

Action: If the operation is required, LOB buffering should not be used. In this case, flush buffers associated with the input LOB locator as necessary, disable buffering on the input LOB locator and reissue the command.

ORA-22280 no more buffers available for operation

Cause: One of the following:

  1. All buffers in the buffer pool have been used up by previous operations.
  2. An attempt was made to flush a LOB without any previous buffered update operations.

Action: For (1), flush the LOB(s) through the locator that is being used to update the LOB. For (2), write to the LOB through a locator enabled for buffering before attempting to flush buffers.

ORA-22281 cannot perform operation with an updated locator

Cause: The input locator has buffering enabled and was used to update the LOB value through the LOB buffering subsystem. The modified buffer has not been flushed since the write that was performed by the input locator; thus, the input locator is considered an updated locator. Updated locators cannot be the source of a copy operation. Only one locator per LOB may be used to modify the LOB value through the LOB buffering subsystem.

Action: Depending on whether the modifications made through the input locator to the LOB buffering subsystem should be written to the server, either flush the buffer to write the modifications, or, disable buffering on the locator to discard the modifications. Then, reissue the command.

ORA-22282 non-contiguous append to a buffering enabled LOB not allowed

Cause: The buffered write operation has an input offset value more than one byte or character past the end of the LOB.

Action: Specify an input offset value which is exactly one character or byte greater than the length of the LOB that you are attempting to update through a buffered write operation.

ORA-22283 filename contains characters that refer to parent directory

Cause: Filename contains a path "../" which references a parent directory.

Action: Ensure that the filename does not contain characters which reference a parent directory.

ORA-22285 non-existent directory or file for string operation

Cause: An attempt was made to access a directory that does not exist, or attempted to access a file in a directory that does not exist.

Action: Ensure that a system object corresponding to the specified directory exists in the database dictionary, or make sure the name is correct.

ORA-22286 insufficient privileges on file or directory to perform string operation

Cause: The user does not have the necessary access privileges on the directory alias and/or the file for the operation.

Action: Ask the database/system administrator to grant the required privileges on the directory alias and/or the file.

ORA-22287 invalid or modified directory occurred during string operation

Cause: The directory alias used for the current operation is not valid if being accessed for the first time, or has been modified by the database administrator since the last access.

Action: If you are accessing this directory for the first time, provide a valid directory name. If you have been already successful in opening a file under this directory before this error occurred, then close the file and retry the operation with a valid directory alias as modified by your database administrator. Oracle recommends that directories should be modified only during quiescent periods.

ORA-22288 file or LOB operation string failed string

Cause: The operation attempted on the file or LOB failed.

Action: See the next error message in the error stack for more detailed information. Also, verify that the file or LOB exists and that the necessary privileges are set for the specified operation. If the error still persists, report the error to the database administrator.

ORA-22289 cannot perform string operation on an unopened file or LOB

Cause: The file or LOB is not open for the required operation to be performed.

Action: Precede the current operation with a successful open operation on the file or LOB.

ORA-22290 operation would exceed the maximum number of opened files or LOBs

Cause: The number of open files or LOBs has reached the maximum limit.

Action: Close some of the opened files or LOBs and retry the operation.

ORA-22291 Open LOBs exist at transaction commit time

Cause: An attempt was made to commit a transaction with open LOBs at transaction commit time.

Action: Close the LOBs before committing the transaction.

ORA-22292 Cannot open a LOB in read-write mode without a transaction

Cause: An attempt was made to open a LOB in read-write mode before a transaction was started.

Action: Start a transaction before opening the LOB in read-write mode. Ways to start a transaction include issuing a SQL DML or SELECT FOR UPDATE command. Opening the LOB in read-only mode does not require a transaction.

ORA-22293 LOB already opened in the same transaction

Cause: An attempt was made to open a LOB that already is open in this transaction.

Action: Close the LOB before attempting to reopen it.

ORA-22294 cannot update a LOB opened in read-only mode

Cause: An attempt was made to write to or update a LOB opened in read-only mode.

Action: Close the LOB and reopen it in read-write mode before attempting to write to or update the LOB.

ORA-22295 cannot bind more than 4000 bytes data to LOB and LONG columns in 1 statement

Cause: An attempt was made to bind more than 4000 bytes of data to both LOB and LONG columns in the same insert or update statement. You can bind more than 4000 bytes of data to either a LONG column or one or more LOB columns, but not both.

Action: Bind more than 4000 bytes of data to either the LONG column or one or more LOB columns, but not both.

ORA-22296 invalid ALTER TABLE option for conversion of LONG datatype to LOB

Cause: An attempt was made to specify ALTER TABLE options which are disallowed during conversion of LONG datatype to LOB. The only ALTER TABLE options allowed during conversion of LONG datatype to LOB are the default clause and LOB storage clause for the column being converted to LOB.

Action: Remove the disallowed options.

ORA-22297 warning: Open LOBs exist at transaction commit time

Cause: An attempt was made to commit a transaction with open LOBs at transaction commit time.

Action: This is just a warning. The transaction was commited successfully, but any domain or functional indexes on the open LOBs were not updated. You may want to rebuild those indexes.

ORA-22303 type "string"."string" not found

Cause: An attempt was made to obtain information for a type that cannot be found.

Action: Check that the schema is correct and that the type has been created correctly.

ORA-22304 input type is not an object type

Cause: An attempt was made to obtain the supertype information for a non-object type.

Action: Pass in only an object type.

ORA-22305 attribute/method/parameter "string" not found

Cause: Type element with the given name is not found in the type.

Action: Check to make sure that the type element exists.

ORA-22306 type "string"."string" already exists

Cause: An attempt was made to create a type that already exists.

Action: Check to make sure that the type has not been created prior to this.

ORA-22307 operation must be on a user-defined type

Cause: An attempt was made to perform an operation that is allowed only on a user-defined type, and the type is not a user-defined type.

Action: Check to make sure that only user-defined types are being operated on.

ORA-22308 operation not allowed on evolved type

Cause: An attempt was made to replace a type whose attribute definition has been altered.

Action: Submit ALTER TYPE ADD/DROP statement instead of ALTER TYPE REPLACE.

ORA-22309 attribute with name "string" already exists

Cause: An attempt was made to create an object type where more than one attributes have the same name.

Action: Check to make sure that all attribute names are unique.

ORA-22310 ALTER TYPE error. Refer to table "string"."string" for errors

Cause: An invalid alter type statement was submitted.

Action: Correct the errors listed in the specified table and resubmit the statement.

ORA-22311 type for attribute "string" does not exist

Cause: The type of the attribute does not exist.

Action: No types were created/modified for this DDL transaction. Redo the DDL transaction and add the creation of the attribute's type in the DDL transaction.

ORA-22312 must specify either CASCADE or INVALIDATE option

Cause: An attempt was made to alter a type which has a dependent type or table without specifying the CASCADE or INVALIDATE option.

Action: Resubmit the statement with either the CASCADE or INVALIDATE option. Specify CASCADE if you want to cascade the type change to dependent types and tables; otherwise, specify INVALIDATE to invalidate all dependents.

ORA-22313 cannot use two versions of the same type "string"

Cause: The version of this type conflicts with the version of this type used by another library that was linked in with the application. An application may only use one version of a type.

Action: Check that the libraries being linked with this application and use the same versions of the type.

ORA-22314 method information mismatch in ALTER TYPE

Cause: The number of methods or the method signature do not match that of the original type declaration. This is not supported.

Action: Make sure the method signature stay identical for the previously declared method. Do not drop existing methods.

ORA-22315 type "string" does not contain a map or order function

Cause: The input type does not contain a map or order function so one cannot be returned.

Action: Add a map or order function to the type or catch this error.

ORA-22316 input type is not a collection type

Cause: An attempt was made to obtain information for collection types on a non-named collection type.

Action: Use a named collection type for the function.

ORA-22317 typecode number is not legal as a number type

Cause: An attempt was made to use a number type code that is not valid.

Action: Use only OCI_TYPECODE_SMALLINT, OCI_TYPECODE_INTEGER, OCI_TYPECODE_REAL, OCI_TYPECODE_DOUBLE, OCI_TYPECODE_FLOAT, OCI_TYPECODE_NUMBER, or OCI_TYPECODE_DECIMAL.

ORA-22318 input type is not an array type

Cause: An attempt was made to obtain the number of elements for a non-array type.

Action: Pass in only a named collection type which is an array.

ORA-22319 type attribute information altered in ALTER TYPE

Cause: The type attribute information does not match that of the original type declaration when altering type. Attributes cannot be altered during ALTER TYPE. Only new methods can be added.

Action: Check that all type alterations are legal.

ORA-22320 missing user version string

Cause: The VERSION option is specified without a user version string.

Action: Resubmit the statement with the version string following the VERSION keyword.

ORA-22321 method does not return any result

Cause: OCITypeResult() was called on a method that does not return any results.

Action: Check that you are passing in the correct method descriptor, or that your method creation was done correctly.

ORA-22322 error table "string"."string" has incorrect structure

Cause: The specified error table does not have the expected table structure.

Action: Execute the DBMS_UTILITY.CREATE_ALTER_TYPE_ERROR_TABLE procedure to create an error table, then resubmit the statement using the new error table.

ORA-22323 error table "string"."string" does not exist

Cause: The error table does not exist.

Action: Resubmit the statement with a correct error table name.

ORA-22324 altered type has compilation errors

Cause: The use of the ALTER TYPE statement caused a compilation error.

Action: Correct the error reported and resubmit the statement.

ORA-22326 cannot change a type to FINAL if it has subtypes

Cause: An attempt was made to change a type with subtypes to FINAL.

Action: Drop all subtypes of the target type before changing it to FINAL.

ORA-22327 cannot change a type to NOT INSTANTIABLE if it has dependent tables

Cause: An attempt was made to change a type with dependent tables to NOT INSTANTIABLE.

Action: Drop all dependent tables of the target type and resubmit the statement.

ORA-22328 object "string"."string" has errors. string

Cause: Altering the target type causes errors in its dependent object.

Action: Correct the problem in the dependent object and resubmit the statement.

ORA-22329 cannot alter a non-object type

Cause: An attempt was made to execute ALTER TYPE on a non-object type.

Action: Drop the non-object type first, then re-create it as an object type.

ORA-22330 cannot alter a type that is not valid

Cause: An attempt was made to perform ALTER TYPE on an invalid type.

Action: Use the CREATE OR REPLACE TYPE command to modify the type.

ORA-22331 cannot alter an incomplete type

Cause: An attempt was made to perform ALTER TYPE on an incomplete type.

Action: Use CREATE TYPE to completely define the original type before executing the ALTER TYPE.

ORA-22332 a dependent object in schema "string" has errors. string

Cause: Altering the target type causes errors in its dependent object.

Action: Correct the problem in the dependent object and resubmit the statement.

ORA-22333 cannot reset type "string"."string" due to invalid dependent types and tables

Cause: An attempt was made to reset the type version with invalid dependent types and tables.

Action: Use the ALTER TYPE COMPILE statement to compile all invalid dependent types and use the ALTER TABLE UPGRADE INCLUDING DATA statement to upgrade all the dependent tables, then resubmit the statement.

ORA-22334 cannot reset type "string"."string". Dependent tables must be upgraded to latest version.

Cause: An attempt was made to reset the type version when the data in the dependent table has not been upgraded to the latest type version.

Action: Use the ALTER TABLE UPGRADE INCLUDING DATA statement to upgrade the data in the dependent tables then resubmit the statement.

ORA-22335 The client cannot work with an altered type

Cause: A pre 9.0.0 client has requested a type that has been altered on the server.

Action: Only 9.0.0 and higher clients can access altered types.

ORA-22336 table contained 8.0 image format, must specify INCLUDING DATA

Cause: One of the following:

  1. An attempt was made to alter a type with a dependent table in 8.0 image format and the NOT INCLUDING TABLE DATA option was specified.
  2. An attempt was made to upgrade a table in 8.0 image format with the NOT INCLUDING DATA option specified.

Action: Resubmit the statement with the INCLUDING DATA option.

ORA-22337 the type of accessed object has been evolved

Cause: The type of the accessed object has been altered and the client's object is based on an earlier type definition.

Action: The user needs to exit the application and modify the application to accommodate the type change. From SQL/PLUS, reconnect and resubmit the statement.

ORA-22338 must specify CASCADE INCLUDING DATA when altering the final property

Cause: An attempt was made to alter the final property of a type with dependent tables without specifying the CASCADE INCLUDING DATA option.

Action: Resubmit the statement with the CASCADE INCLUDING DATA option.

ORA-22339 cannot alter to not final since its attribute column is substitutable

Cause: An attempt was made to alter a type to not final when its embedded attribute is defined as substitutable in some tables. Note, this is a restriction in 9.0 version because when a type is altered to not final, column of that type is set to not substitutable at all levels; thus, it is an error if one of its embedded attribute column is already marked substitutable.

Action: Recreate the table and specify NOT SUBSTITUTABLE AT ALL LEVELS for all columns of non final type. Then resubmit the ALTER TYPE statement.

ORA-22340 cannot string type "string"."string". Dependent tables must be upgraded to latest version

Cause: An attempt was made to reset the version, drop or alter a type when the data in dependent table has not been upgraded to the latest version.

Action: Use the ALTER TABLE UPGRADE INCLUDING DATA statement to upgrade the data in the dependent tables then resubmit the statement.

ORA-22341 cannot assign supertype instance to subtype

Cause: An attempt was made to assign or copy a supertype instance to a container (destination) that can only hold a subtype instance.

Action: Make sure the runtime type of the source of the assignment or copy is the same type as the destination or is a subtype of the destination type.

ORA-22342 dependent VARRAY column exceeds the maximum inline column size

Cause: An attempt was made to alter a type (add or modify attribute) which causes the size of its dependent VARRAY column to exceed the maximum inline column size. However, the VARRAY column was not specified to be stored as LOB at the table level when the table was created.

Action: Specify the VARRAY column to be stored as LOB at the table level when the table is created.

ORA-22343 Compilation error for type invalidated by ALTER TYPE

Cause: Compilation failed for a type which was invalidated by ALTER TYPE.

Action: Check what is causing the compilation error, correct it, and try again.

ORA-22344 can not specify CONVERT TO SUBSTITUTABLE option for ALTER TYPE other than NOT FINAL change

Cause: An attempt was made to specify CONVERT TO SUBSTITUTABLE option for ALTER TYPE other than NOT FINAL change.

Action: Specify CONVERT TO SUBSTITUTABLE option only for ALTER TYPE NOT FINAL change.

ORA-22345 recompile type string.string before attempting this operation

Cause: An attempt was made to perform an operation which requires the specified datatype to be valid, but the datatype is invalid.

Action: Recompile the specified type and retry the operation.

ORA-22369 invalid parameter encountered in method string

Cause: An invalid parameter is being passed to this method of SYS.AnyType, SYS.AnyData, or SYS.AnyDataSet.

Action: Check the parameters being passed to this method and make sure that the parameters are allowed.

ORA-22370 incorrect usage of method string

Cause: This method of SYS.AnyType, SYS.AnyData, or SYS.AnyDataSet is being used inappropriately.

Action: Check the documentation for correct usage.

ORA-22371 Table contains data of type string.string, version string, which does not exist

Cause: Some of the older versions of the type may have been deleted because one or more of the referenced types was dropped.

Action: These data could not be read as the whole ADT. Read the data at individual scalar attribute level.

ORA-22600 encountered 8.0.2 (Beta) VARRAY data that cannot be processed

Cause: Production Oracle8 (8.0.3 and beyond) encountered some VARRAY data which was created and stored by Oracle8 8.0.2 (Beta 2). Production Oracle8 cannot understand or process such VARRAY data.

Action: Delete the VARRAY data from the table by dropping the table, deleting the rows, or nulling out the VARRAY columns, and then reinsert the VARRAY data. There is no provided script or tool to help automate this conversion.

ORA-22601 pickler TDS context [string] is not initialized

Cause: An attempt was made to use the pickler TDS context without initializing it.

Action: Use OCIPicklerTdsCtxInit to initialize the context.

ORA-22602 pickler TDS handle [string] is not well-formed

Cause: An attempt was made to use the pickler TDS handle without initializing or constructing it.

Action: Use OCIPicklerTdsInit to initialize the handle before it is constructed. Use OCIPicklerTdsGenerate to generate the TDS before its attributes can be accessed.

ORA-22603 cannot add an attribute to the already generated TDS handle

Cause: An attempt was made to add an attribute to the already constructed TDS.

Action: Use a TDS handle that is initialized but not yet constructed.

ORA-22604 TDS handle already generated

Cause: An attempt was made to generate TDS that is already generated.

Action: Use a TDS handle that is initialized but not yet generated.

ORA-22605 FDO handle [string] is not initialized

Cause: An attempt was made to use an uninitialized FDO handle.

Action: Use OCIPicklerFdoInit to initialize FDO handle.

ORA-22606 pickler image handle [string] is not well-formed

Cause: An attempt was made to use the image handle without initializing/ constructing it.

Action: Use OCIPicklerImageInit to initialize the handle before it is constructed. Use OCIPicklerImageGenerate to generate the image before its attributes can be accessed.

ORA-22607 image handle already generated

Cause: An attempt was made to generate image that is already generated.

Action: Use a image handle that is initialized but not yet generated.

ORA-22608 cannot add an attribute to the already generated image handle

Cause: An attempt was made to add an attribute to the already constructed image.

Action: Use a image handle that is initialized but not yet constructed.

ORA-22609 error string during initialization of FDO

Cause: An error occurred during FDO initialization.

Action: Take an action based on the specified error.

ORA-22610 error while adding a scalar to the image handle

Cause: An error occurred while adding a scalar attribute to the image handle.

Action: Make sure image handle is initialized before adding scalar.

ORA-22611 TDS version is not recognized

Cause: Incorrect TDS handle is passed.

Action: Make sure image handle is initialized with the correct TDS.

ORA-22612 TDS does not describe a collection TDS

Cause: Collection construct/access routines are being on an image but the TDS does not describe that a collection TDS.

Action: Make sure a collection TDS is used before invoking collection routines on the image handle.

ORA-22613 buflen does not match the size of the scalar

Cause: BUFLEN is incorrect.

Action: Make sure BUFLEN is correct and matches the size of the scalar.

ORA-22614 error while construction the collection in the image

Cause: An error occurred during the construction of collection.

Action: Make sure image handle is initialized and OCIPicklerImageCollBegin is called to begin collection.

ORA-22615 attribute is not a collection

Cause: Collection routine is invoked upon a non-collection attribute.

Action: Make sure attribute is a collection.

ORA-22616 image is not of Oracle 8.1 format

Cause: The function being invoked is applicable only for 8.1 images.

Action: Make sure image is of 8.1 format.

ORA-22617 error while accessing the image handle collection

Cause: An error occurred while accessing collection in the image handle.

Action: Make sure image is initialized correctly and the collection is constructed properly.

ORA-22618 attribute is a BAD NULL in the image handle

Cause: The attribute in question is probably the attribute of a null embedded image.

Action: Make sure attribute number is valid or it is NULL or NOT NULL.

ORA-22619 all collection elements have already been accessed

Cause: An attempt was made to access a collection element after all the collection elements are already accessed.

Action: This function should not be invoked any more.

ORA-22620 buffer size too small to hold the value

Cause: Buffer size is not enough to hold the value. Most likely while doing the character set conversion, a bigger buffer is needed.

Action: Pass in a bigger buffer. If the client character set format differs from that of server, doing the conversion may result in 4X expansion.

ORA-22621 error transfering an object from the agent

Cause: An error was returned from the pickler routines on the agent side.

Action: Contact Oracle Support Services.

ORA-22625 OCIAnyData is not well-formed

Cause: Attempt to use the OCIAnyData without initializing constructing it.

Action: Use OCIAnyDataBeginConstruct to initialize the handle before it is adding attributes. Use OCIAnyDataEndConstruct to complete the construction. Or use OCIAnyDataConvert to do the construction. MAke sure it is properly constructed before accessing attributes.

ORA-22626 Type Mismatch while constructing or accessing OCIAnyData

Cause: Type supplied is not matching the type of the AnyData. If piece wise construction or access is being attempted, the type supplied is not matching the type of the current attribute.

Action: Make sure the type supplied matches the type of object to be constructed or accessed.

ORA-22627 tc [string] must be that of object/varray/nested table

Cause: Type code is not that of object/varray/nested table

Action: Make sure the type code is OCI_TYPECODE_OBJECT, OCI_TYPECODE_VARRAY, or OCI_TYPECODE_TABLE

ORA-22628 OCIAnyData already constructed

Cause: Attempt to add attributes to OCIAnyData that is already constructed.

Action: Use the OCIAnyData that is initialized but not yet constructed.

ORA-22629 OCIAnyData is null

Cause: Attempting an operation that is not valid on null OCIAnyData.

Action: Make sure OCIAnyData is not null.

ORA-22630 attribute [string] is null or it is not well-formed

Cause: Passing an attribute that is null or not well-formed.

Action: Make sure the attribute is not null or is well-formed.

ORA-22631 attribute [string] is is not well-formed or does not match the type

Cause: Passing an attribute that is not well-formed or does not match the input type.

Action: Make sure the attribute is well-formed and matches the type specified.

ORA-22632 AnyDataSet parameter is not valid for the current operation

Cause: The AnyDataSet parameter is null or invalid for the current operation.

Action: Check the documentation for the current operation.

ORA-22633 Error freeing AnyDataSet

Cause: AnyDataSet that is passed in may not be valid.

Action: Check all the AnyDataSet parameters.

ORA-22634 Error adding new instance to AnyDataSet

Cause: Current instance in the AnyDataSet has not been fully constructed.

Action: Make sure that the current instance is fully constructed before adding new instance.

ORA-22800 invalid user-defined type

Cause: An attempt was made to use an incomplete type as a constructor.

Action: Complete the type definition before using it in a query.

ORA-22801 invalid object row variable

Cause: The specified object row variable is not available in the scope of name resolution.

Action: Verify the specified object row variable is correct, or use an object row variable visible in scope.

ORA-22803 object type contains zero attributes

Cause: An attempt was made to create or specify a column or constructor of an object type that has no attributes. Only object types that have at least one attribute are allowed in this context.

Action: Specify a valid object type.

ORA-22804 remote operations not permitted on object tables or user-defined type columns

Cause: An attempt was made to perform queries or DML operations on remote object tables or on remote table columns whose type is one of object, REF, nested table or VARRAY.

Action: Remove the reference to remote tables in the statement.

ORA-22805 cannot insert NULL object into object tables or nested tables

Cause: An attempt was made to insert a NULL object into an object table or a Nested Table.

Action: Ensure that a non-NULL object is inserted into the table or insert an object with attributes whose values are NULL.

ORA-22806 not an object or REF

Cause: An attempt was made to extract an attribute from an item that is neither an object nor a REF.

Action: Use an object type or REF type item and retry the operation.

ORA-22807 cannot resolve to a scalar type or a collection type

Cause: Invalid use of a non-scalar (for example, object type) item.

Action: Change the item's data type and retry the operation.

ORA-22808 REF dereferencing not allowed

Cause: An attempt was made to access an object type's attributes by de-referencing a REF item.

Action: Make the item an object type instead of a REF to an object type.

ORA-22809 nonexistent attribute

Cause: An attempt was made to access a non-existent attribute of an object type.

Action: Check the attribute reference to see if it is valid. Then retry the operation.

ORA-22810 cannot modify object attributes with REF dereferencing

Cause: An attempt was made to modify the attributes an object by de-referencing a REF column in an UPDATE statement.

Action: Update the table containing the object that the REF points to, or change the REF column to an object type column.

ORA-22812 cannot reference nested table column's storage table

Cause: An attempt to access the nested table column's storage table is not allowed in the given context.

Action: Issue the statement against the parent table containing the nested table column.

ORA-22813 operand value exceeds system limits

Cause: Object or Collection value was too large. The size of the value might have exceeded 30k in a SORT context, or the size might be too big for available memory.

Action: Choose another value and retry the operation.

ORA-22814 attribute or element value is larger than specified in type

Cause: Value provided for the object type attribute or collection element exceeded the size specified in the type declaration.

Action: Choose another value and retry the operation.

ORA-22816 unsupported feature with RETURNING clause

Cause: RETURNING clause is currently not supported for object type columns, LONG columns, remote tables, INSERT with subquery, and dereferencing inside returning clause.

Action: Use separate SELECT statements to get the values.

ORA-22817 subquery not allowed in the default clause

Cause: An attempt was made to use a subquery in the column default clause expression.

Action: Remove the subquery from the default clause.

ORA-22818 subquery expressions not allowed here

Cause: An attempt was made to use a subquery expression where these are not supported.

Action: Rewrite the statement without the subquery expression.

ORA-22819 scope of input value does not correspond to the scope of the target

Cause: An attempt was made to operate on a REF value scoped to a different table than the expected one.

Action: Use a REF which is scoped to the expected table and retry the operation.

ORA-22826 cannot construct an instance of a non instantiable type

Cause: An attempt was made to use a non instantiable type as a constructor.

Action: None.

ORA-22828 input pattern or replacement parameters exceed 32K size limit

Cause: Value provided for the pattern or replacement string in the form of VARCHAR2 or CLOB for LOB SQL functions exceeded the 32K size limit.

Action: Use a shorter pattern or process a long pattern string in multiple passes.

ORA-22850 duplicate LOB storage option specificed

Cause: A LOB storage option (CHUNK, PCTVERSION, CACHE, NOCACHE, TABLESPACE, STORAGE, INDEX) was specified more than once.

Action: Specify all LOB storage options only once.

ORA-22851 invalid CHUNK LOB storage option value

Cause: The specified CHUNK LOB storage option value must be an integer.

Action: Choose an appropriate integer value and retry the operation.

ORA-22852 invalid PCTVERSION LOB storage option value

Cause: The specified PCTVERSION LOB storage option value must be an integer.

Action: Choose an appropriate integer value and retry the operation.

ORA-22853 invalid LOB storage option specification

Cause: A LOB storage option was not specified.

Action: Specify one of CHUNK, PCTVERSION, CACHE, NOCACHE, TABLESPACE, STORAGE, INDEX as part of the LOB storage clause.

ORA-22854 invalid option for LOB storage index

Cause: A valid LOB store index option was not specified.

Action: Specify one of (INITTRANS, MAXTRANS, TABLESPACE, STORAGE) as part of the LOB storage index.

ORA-22855 optional name for LOB storage segment incorrectly specified

Cause: The optional name for LOB storage segment was specified with multiple columns in the column list.

Action: Specify each column LOB storage only with optional name(s).

ORA-22856 cannot add columns to object tables

Cause: An attempt was made to add columns to an object table. Object tables cannot be altered to add columns since its definition is based on an object type.

Action: Create a new type with additional attributes, and use the new type to create an object table. The new object table will have the desired columns.

ORA-22857 cannot modify columns of object tables

Cause: An attempt was made to alter the object table by modifying existing columns. An object table cannot be altered to modify existing columns since it is based on an object type. The table definition must be in sync with the corresponding type.

Action: Create a new type with the desired attribute types and use it to create an object table. The new object table will have the desired columns.

ORA-22858 invalid alteration of datatype

Cause: An attempt was made to modify the column type to object, REF, nested table, VARRAY or LOB type.

Action: Create a new column of the desired type and copy the current column data to the new type using the appropriate type constructor.

ORA-22859 invalid modification of columns

Cause: An attempt was made to modify an object, REF, VARRAY, nested table, or LOB column type.

Action: Create a new column of the desired type and copy the current column data to the new type using the appropriate type constructor.

ORA-22860 object type expected

Cause: An attempt was made to create an object table using a non- object type, or to create a column that is a REF to a non-object type.

Action: Use a valid object type in the table or column definition.

ORA-22861 invalid user-defined type

Cause: An attempt was made to create a column or object table of a non-existent type.

Action: Specify a valid type in the table or column definition.

ORA-22862 specified object identifier doesn't match existing object identifier

Cause: An attempt was made to specify an object identifier for the type that does not match the existing identifier of the incomplete type of the same name.

Action: Specify the correct object identifier or leave it out of the statement.

ORA-22863 synonym for datatype string.string not allowed

Cause: A synonym specification for a datatype is not supported.

Action: Do not use the synonym for the datatype.

ORA-22864 cannot ALTER or DROP LOB indexes

Cause: An attempt was made to ALTER or DROP a LOB index.

Action: Do not operate directly on the system-defined LOB index. Perform operations on the corresponding LOB column.

ORA-22865 more than one column specified

Cause: An attempt was made to specify multiple columns where only one is allowed.

Action: Specify a single column and retry the operation.

ORA-22866 default character set is of varying width

Cause: A character LOB was defined but the default character set is not fixed width.

Action: Ensure that the character set is of fixed width before defining character LOBs.

ORA-22868 table with LOBs contains segments in different tablespaces

Cause: An attempt was made to drop a tablespace which contains the segment(s) for the LOB columns of a table but does not contain the table segment.

Action: Find table(s) with LOB columns which have non-table segments in this tablespace. Drop these tables and reissue drop tablespace.

ORA-22869 depth of type dependency hierarchy exceeds maximum limit

Cause: The type dependency hierarchy was structured to have depth greater than 1024.

Action: Restructure the type dependency hierarchy to a shorter depth.

ORA-22870 ALTER TYPE with REPLACE option a non-object type

Cause: An attempt was made to perform ALTER TYPE with REPLACE option a non-object type.

Action: Drop the non-object type first, then re-create it as an object type.

ORA-22871 ALTER TYPE with REPLACE is not allowed for pure incomplete types

Cause: An attempt was made to perform ALTER TYPE with REPLACE option for a pure incomplete type.

Action: Completely define the original type, before using the ALTER TYPE with REPLACE option.

ORA-22872 OID INDEX clause not allowed on tables with primary key based object identifiers

Cause: An attempt was made to create an OID INDEX on a table with primary key-based object identifiers.

Action: Remove the OID INDEX clause.

ORA-22873 primary key not specified for primary key based object table

Cause: An attempt was made to create a primary key based object table without specifying a primary key.

Action: Specify a primary key and retry the operation.

ORA-22874 attribute "string" is not part of the type "string"

Cause: Attribute specified in the USER_DEFINED clause is not an attribute of the REF type.

Action: Ensure that the name specified in the USER_DEFINED clause is the name of a valid attribute of the REF type.

ORA-22875 cannot drop primary key of an object table whose object identifier is primary key based

Cause: An attempt was made to drop the primary key of an object table which has a primary key based object identifier.

Action: Remove the drop primary key clause.

ORA-22876 this user-defined type is not allowed or it cannot be used in this context

Cause: An attempt was made to create a kind of user-defined type which is not allowed, or an attempt to create table columns or use default constructor with a type on which these are not supported.

Action: Ensure that the type is permitted in this context.

ORA-22877 invalid option specified for a HASH partition or subpartition of a LOB column

Cause: One or more invalid options were encountered while parsing the physical attributes of a LOB partition or subpartition. Either the LOB partition is in a table partitioned using the HASH method, or the LOB subpartition is in a table subpartitioned using the HASH method. TABLESPACE is the only valid option for a HASH partition or subpartition.

Action: Remove the invalid option(s).

ORA-22878 duplicate LOB partition or subpartition specified

Cause: An attempt was made was made to specify a partition or subpartition that has already been specified for the LOB column.

Action: Remove the duplicate specification.

ORA-22879 cannot use the LOB INDEX clause for partitioned tables

Cause: An attempt was made to specify a LOB INDEX clause in a CREATE TABLE or ALTER TABLE statement for a partitioned table.

Action: Remove the LOB INDEX clause.

ORA-22880 invalid REF

Cause: An invalid REF was accessed.

Action: Modify the REF and retry the operation.

ORA-22881 dangling REF

Cause: The object corresponding to the REF that was accessed does not exist.

Action: Ensure that the REF value is pointing to an existing object.

ORA-22882 object creation failed

Cause: The object cannot be created in the database.

Action: Check to see if the object table exists and the object size is not too big. Then retry the operation.

ORA-22883 object deletion failed

Cause: The object could not be deleted from the database.

Action: Check to see if the object table exists. Then retry the operation.

ORA-22884 object modification failed

Cause: The object could not be modified in the database.

Action: Check to see if the object table exists and the object size is not too big. Then retry the operation.

ORA-22885 cannot get REF to a non-persistent object

Cause: An attempt was made to get a REF for something other than an object in an object table. REFs can only be taken for objects in object tables.

Action: Rewrite the query to obtain REF values from object tables.

ORA-22886 scoped table "string" in schema "string" is not an object table

Cause: The scoped table specified for a REF column is not an object table.

Action: Ensure that the scoped table is an object table. Then retry the operation.

ORA-22887 type of REF column is not the same as that of its scoped table

Cause: The type specified for the REF column and the type specified for the scope table are different.

Action: Ensure that the types of a REF column and its scoped table are the same.

ORA-22888 duplicate SCOPE clauses for a REF column

Cause: Multiple SCOPE clauses were specified for a single REF column.

Action: Remove the duplicate SCOPE clauses and retry the operation.

ORA-22889 REF value does not point to scoped table

Cause: An attempt was made to insert a REF value that does not point to the scoped table.

Action: Ensure that the REF values point to the scoped table.

ORA-22890 cannot specify name for REF column constraint

Cause: An attempt was made to specify a constraint name for a constraint on a REF column.

Action: Remove the constraint name and retry the operation.

ORA-22891 cannot have multiple columns in REF constraint

Cause: An attempt was made to specify multiple columns in a single REF constraint.

Action: Specify separate constraints for each column and retry the operation.

ORA-22892 scoped table "string" does not exist in schema "string"

Cause: The scoped table specified for a REF column does not exist.

Action: Ensure that the scoped table exists and retry the operation.

ORA-22893 constraint can be specified only for REF columns

Cause: The constraint specified does not apply to non-REF columns.

Action: Remove the constraint and retry the operation.

ORA-22894 cannot add constraint on existing unscoped REF columns of non-empty tables

Cause: An attempt was made to add a constraint to existing unscoped REF columns of a table which contains one or more rows.

Action: Remove the constraint specification or add the constraint after emptying the table.

ORA-22895 referenced table "string" in schema "string" is not an object table

Cause: The referenced table specified for a REF column is not an object table.

Action: Ensure that the referenced table is an object table. Then retry the operation.

ORA-22896 cannot have both scope and referential constraint on REF column "string"

Cause: REF column has both a referential and a scope constraint. A referential constraint implies a scope constraint.

Action: Remove either the referential or scope constraint and then retry the operation.

ORA-22897 no scope clause specified for user-defined REF column "string"

Cause: User-defined REF column does not have a scope constraint.

Action: Specify a scope constraint for the user-defined REF column and retry the operation.

ORA-22898 existing scope clause on "string" points to a table other than the one mentioned in the referential constraint

Cause: Table mentioned in the referential integrity constraint is different from the scope table of the REF column.

Action: Specify the scope table of the REF column in the referential integrity constraint and then retry the operation.

ORA-22899 cannot specify both scope and rowid constraint on ref column

Cause: An attempt was made to specify both a scope and a ROWID constraint on a REF column.

Action: Remove either the ROWID or scope constraint and then retry the operation.

ORA-22900 the SELECT list item of THE subquery is not a collection type

Cause: The THE subquery must SELECT a nested table or VARRAY item.

Action: Change the subquery to SELECT a nested table or VARRAY item.

ORA-22901 cannot compare nested table or VARRAY or LOB attributes of an object type

Cause: Comparison of nested table or VARRAY or LOB attributes of an object type was attempted in the absence of a MAP or ORDER method.

Action: Define a MAP or ORDER method for the object type.

ORA-22902 CURSOR expression not allowed

Cause: CURSOR on a subquery is allowed only in the top-level SELECT list of a query.

Action: Remove the CURSOR expression and retry the operation.

ORA-22903 MULTISET expression not allowed

Cause: MULTISET expressions are allowed only inside a CAST to a nested table or VARRAY type.

Action: put the MULTISET (subquery) expression inside a CAST to a nested table or VARRAY type.

ORA-22904 invalid reference to a nested table column

Cause: An invalid reference was made to a nested table column.

Action: Remove invalid reference to the nested table column and retry the operation.

ORA-22905 cannot access rows from a non-nested table item

Cause: An attempt was made to access rows of an item whose type is not known at parse time or that is not of a nested table type.

Action: Use CAST to cast the item to a nested table type.

ORA-22906 cannot perform DML on expression or on nested table view column

Cause: An attempt was made to perform a DML on an expression or on a nested table view column where a nested table column of a base table is expected.

Action: Only nested table column of a base table is allowed in the DML.

ORA-22907 invalid CAST to a type that is not a nested table or VARRAY

Cause: An attempt was made to CAST to a type that is not a nested table or VARRAY.

Action: Respecify CAST to a nested table or VARRAY type.

ORA-22908 reference to NULL table value

Cause: The evaluation of the THE subquery or nested table column resulted in a NULL value implying a NULL table instance. The THE subquery or nested table column must identify a single non-NULL table instance.

Action: Ensure that the evaluation of the THE subquery or nested table column results in a single non-null table instance. If happening in the context of an INSERT statement where the THE subquery is the target of an insert, then ensure that an empty nested table instance is created by updating the nested table column of the parent table's row specifying an empty nested table constructor.

ORA-22909 exceeded maximum VARRAY limit

Cause: The total number of elements used in VARRAY construction exceeds the specified VARRAY limit.

Action: Do not use the more than the specified limit of elements for VARRAY construction.

ORA-22910 cannot specify schema name for nested tables

Cause: Table name was qualified with schema name in the nested table column's (or attribute's) storage clause.

Action: Respecify the nested table item's storage clause without the schema name qualification. By default, the storage table for the nested table item is created in the same schema as the containing table.

ORA-22911 duplicate storage specification for the nested table item

Cause: The storage clause is specified more than once for the NESTED TABLE column.

Action: Remove the duplicate storage specification.

ORA-22912 specified column or attribute is not a nested table type

Cause: The storage clause is specified for a column or attribute that is not a nested table column or attribute.

Action: Specify a valid nested table column or attribute.

ORA-22913 must specify table name for nested table column or attribute

Cause: The storage clause is not specified for a nested table column or attribute.

Action: Specify the nested table storage clause for the nested table column or attribute.

ORA-22914 DROP of nested tables not supported

Cause: An attempt was made to DROP a nested table.

Action: Nested tables cannot be explicitly dropped. nested tables can only be dropped by dropping their containing parent table.

ORA-22915 cannot ALTER nested tables to ADD/MODIFY columns

Cause: An attempt was made to ADD or MODIFY columns of a nested table. Columns cannot be added or modified for a nested table.

Action: Instead, alter the parent table's nested table column to cause any such change.

ORA-22916 cannot do an exact FETCH on a query with Nested cursors

Cause: Exact FETCH on a query was specified which is not allowed if the query returns any cursors.

Action: Do not use an exact FETCH.

ORA-22917 use VARRAY to define the storage clause for this column or attribute

Cause: Not using VARRAY to define storage clause for VARRAY column or attribute.

Action: Specify VARRAY before the column storage clause and resubmit the statement.

ORA-22918 specified column or attribute is not a VARRAY type

Cause: An attempt was made to define a VARRAY storage clause for a column or attribute which is not VARRAY type.

Action: Specify VARRAY storage clause for a VARRAY column or attribute.

ORA-22919 dangling REF error or lock object failed for no wait request

Cause: The error could be one of the following: the object corresponding to the REF does not exist or the object was locked by another user and the lock with nowait request failed.

Action: Ensure that the REF value is pointing to an existing object or issue a lock request without the nowait option.

ORA-22920 row containing the LOB value is not locked

Cause: The row containing the LOB value must be locked before updating the LOB value.

Action: Lock the row containing the LOB value before updating the LOB value.

ORA-22921 length of input buffer is smaller than amount requested

Cause: The buffer length is not big enough to hold the amount of data requested.

Action: Verify that the number of bytes/characters specified in the input amount parameter is not bigger than the number of bytes specified in the input buffer length parameter. Allocate more space for the input buffer if necessary.

ORA-22922 nonexistent LOB value

Cause: The LOB value associated with the input locator does not exist. The information in the locator does not refer to an existing LOB.

Action: Repopulate the locator by issuing a SELECT statement and retry the operation.

ORA-22923 amount of data specified in streaming LOB write is 0

Cause: An attempt was made to write LOB value via the streaming mechanism (that is, unlimited write) but the input amount of data to stream was specified as 0. Thus, the user is trying to write 0 bytes to the LOB value.

Action: Write more than 0 bytes to the LOB value.

ORA-22924 snapshot too old

Cause: The version of the LOB value needed for the consistent read was already overwritten by another writer.

Action: Use a larger version pool.

ORA-22925 operation would exceed maximum size allowed for a LOB value

Cause: An attempt was made to write too much data to the LOB value. LOB size is limited to 4 gigabytes.

Action: Either start writing at a smaller LOB offset or write less data to the LOB value.

ORA-22926 specified trim length is greater than current LOB value's length

Cause: The input length for which to trim the LOB value to is greater than the current length of the LOB value.

Action: May not need to trim the LOB value because it's already smaller than the trim length specified. Or, if trimming the LOB value really is required, use a smaller trim length.

ORA-22927 invalid LOB locator specified

Cause: One of the following:

  1. The LOB locator was never initialized.
  2. The locator is for a BFILE and the routine expects a BLOB/CLOB/NCLOB locator.
  3. The locator is for a BLOB/CLOB/NCLOB and the routine expects a BFILE locator.
  4. An attempt was made to update the LOB in a trigger body -- LOBs in trigger bodies are read only.

Action: For (1), initialize the LOB locator by selecting into the locator variable or by setting the LOB locator to empty. For (2) and (3), pass the correct type of locator into the routine. For (4), remove the trigger body code that updates the LOB value.

ORA-22928 invalid privilege on directories

Cause: An attempt was made to grant or revoke an invalid privilege on a directory.

Action: Only CREATE, DELETE, READ and WRITE privileges can be granted or revoked on directories. Do not grant or revoke other privileges.

ORA-22929 invalid or missing directory name

Cause: The required directory name is invalid or missing.

Action: Specify a valid name.

ORA-22930 directory does not exist

Cause: An attempt was made to access a directory that does not exist.

Action: Make sure the name is correct.

ORA-22931 MOVE of nested table to a different tablespace not supported

Cause: An attempt was made to move a nested table to a different tablespace.

Action: Nested tables always collocate in the same tablespace as the parent. A nested table can be moved to a different tablespace only by moving its containing table to the target tablespace.

ORA-22933 cannot change object with type or table dependents

Cause: An attempt was made to replace, drop, or rename an object with type or table dependents.

Action: Drop depending objects or use FORCE option if available.

ORA-22950 cannot ORDER objects without MAP or ORDER method

Cause: An object type must have a MAP or ORDER method defined for all comparisons other than equality and inequality comparisons.

Action: Define a MAP or ORDER method for the object type.

ORA-22951 NULL returned by ORDER method

Cause: ORDER method used to compare two object values returned NULL which is not allowed.

Action: Redefine the ORDER method to not return a NULL.

ORA-22970 name does not correspond to an object view

Cause: Either the expression is not a view name or the name specified does not correspond to an object view.

Action: Replace the expression with the name of an object view.

ORA-22971 invalid datatype for PRIMARY KEY-based object identifier

Cause: When creating an object view, the datatype of an expression in the WITH OBJECT OID clause is not allowed for PRIMARY KEY-based OID.

Action: Replace the expression with one of appropriate scalar datatype.

ORA-22972 NULL value not allowed in PRIMARY KEY-based object identifier

Cause: A value constituting the PRIMARY KEY-based object identifier is NULL.

Action: Ensure the expressions in MAKE_REF system function or attributes in the WITH OBJECT OID clause of an object view do not evaluate to NULL.

ORA-22973 size of object identifier exceeds maximum size allowed

Cause: Size of the PRIMARY KEY-based object identifier of an object view exceeded the maximum size of 1000 bytes.

Action: Specify fewer or smaller PRIMARY KEY attributes in the WITH object OID clause when creating the object view.

ORA-22974 missing WITH OBJECT OID clause

Cause: WITH OBJECT OID clause was not specified when creating an object view.

Action: Specify the WITH OBJECT OID clause.

ORA-22975 cannot create a PRIMARY KEY-based REF to this object view

Cause: The object view specified in the MAKE_REF function does not have a PRIMARY KEY-based object identifier. A PRIMARY KEY-based REF cannot be created for such a view.

Action: Specify an object view that has a PRIMARY KEY-based object identifier in the MAKE_REF function.

ORA-22976 incorrect number of arguments to MAKE_REF

Cause: Number of arguments for MAKE_REF is different from the number of PRIMARY KEY attributes of the object view.

Action: Specify all the necessary arguments for MAKE_REF.

ORA-22977 missing or invalid attribute

Cause: Either the attribute name is missing in the WITH OBJECT OID clause or it is invalid.

Action: Specify a valid attribute of the object type of the object view.

ORA-22978 only simple attribute name is allowed in the WITH OBJECT OID clause

Cause: An attempt was made to specify a Nested attribute in the WITH OBJECT OID clause.

Action: Specify a top-level attribute of the object type of the object view.

ORA-22979 cannot INSERT object view REF or user-defined REF

Cause: An attempt was made to insert an object view REF or user-defined REF in a REF column created to store system generated REF values.

Action: Make sure the REF to be inserted is not from an object view or from a user-defined REF column

ORA-22980 must specify a set of attributes for the WITH OBJECT OID clause

Cause: The WITH OBJECT OID DEFAULT clause was used, but the underlying view or table does not have a OID.

Action: Specify attributes for the WITH OBJECT OID clause to create a primary key based object identifier for the object view.

ORA-22981 must specify a table/view having system generated OID

Cause: The super-view is based on a table/view having the system generated OID and the sub-view must also be based on a similar table/view.

Action: Specify a table/view having the system generated OID and retry the operation.

ORA-22982 cannot create sub-view under this view

Cause: The view derives its OID from a table/view having primary key based OID and sub-views cannot be created under such views.

Action: Specify a view having the system generated OID or a view created with the specification of attributes in the WITH OBJECT ID clause and retry the operation.

ORA-22983 not a user-defined REF

Cause: Attempt to use a system generated REF value where a user-defined REF value should be used.

Action: Make sure the REF value is user-defined.

ORA-22984 view query cannot contain references to a super view

Cause: The query defining the view contains references to a super-view of the view being created.

Action: Make sure that the view query does not reference a super-view.

ORA-22990 LOB locators cannot span transactions

Cause: A LOB locator selected in one transaction cannot be used in a different transaction.

Action: Reselect the LOB locator and retry the operation.

ORA-22991 insufficient space allocated for argument string

Cause: The data to be returned in the argument is greater than the amount of space allocated for the argument.

Action: Allocate more space for the argument.

ORA-22992 cannot use LOB locators selected from remote tables

Cause: A remote LOB column cannot be referenced.

Action: Remove references to LOBs in remote tables.

ORA-22993 specified input amount is greater than actual source amount

Cause:

  1. For LOB write, the amount of data received is different from the amount that was indicated would be sent.
  2. For LOB copy and load from file, the end of the source LOB/FILE value was reached before the specified input amount was copied/loaded.

Action: (1) will happen when using OCI's piecewise mechanism with polling or with a callback function. Modify the code either to send the amount specified or to pass 0 as the input amount so that any amount of data can be sent. (2) will happen if the specified input amount is too large for the source LOB/FILE given the starting source offset. Either decrease the starting source offset, or decrease the amount to copy/load.

ORA-22994 source offset is beyond the end of the source LOB

Cause: The source offset for a LOB COPY or LOB LOADFROMFILE is beyond the end of the source LOB.

Action: Check the length of the LOB and then adjust the source offset.

ORA-22995 TABLESPACE DEFAULT option is invalid in this context

Cause: TABLESPACE DEFAULT option can be specified for LOB columns only in the following contexts:

  • at the table level for a partitioned table
  • at the partition level for a composite partition

An attempt was made to use the TABLESPACE DEFAULT option in a different context.

Action: Remove the TABLESPACE DEFAULT option.

ORA-22996 NEXT extent size is smaller than LOB chunksize

Cause: An attempt was made to create or alter a LOB segment so that its NEXT extent size was less than the LOB chunk size.

Action: Specify a NEXT extent size that is greater than or equal to the LOB chunk size.

ORA-22997 VARRAY | OPAQUE stored as LOB is not specified at the table level

Cause: An attempt was made to specify a VARRAY|OPAQUE column to be stored as LOB at the partition/subpartition/template level. However, the VARRAY|OPAQUE column was not specified to be stored as LOB at the table level when the table was created.

Action: Specify the VARRAY | OPAQUE column to be stored as LOB at the table level when the table is created. Alternatively, do not specify the VARRAY | OPAQUE column to be stored as LOB at the partition/subpartition/template level if it is not specified at the table level when the table is created.

ORA-22998 CLOB or NCLOB in multibyte character set not supported

Cause: A CLOB or NCLOB in a fixed-width or varying-width multibyte character set was passed to a SQL character function which does not support multibyte LOB data.

Action: Use DBMS_LOB functions such as DBMS_LOB.INSTR() and DBMS_LOB.SUBSTR() or use PLSQL DBMS_LOB.READ/WRITE to access LOB data.

ORA-23290 This operation may not be combined with any other operation

Cause: An ALTER TABLE RENAME [COLUMN | CONSTRAINT] operation was given in conjunction with another ALTER TABLE Operation. This is not allowed.

Action: Ensure that RENAME COLUMN/RENAME CONSTRAINT is the only operation specified in the ALTER TABLE statement.

ORA-23291 Only base table columns may be renamed

Cause: An attempt was made to rename a column of a non-base table, such as an object table, nested table, or materialized view table. This is not allowed.

Action: No action required.

ORA-23292 The constraint does not exist

Cause: The given constraint name does not exist.

Action: Give an existing constraint's name.

ORA-23293 Cannot rename a column which is part of a join index

Cause: The column participates in a join index.

Action: If you need to rename the column, then you need to drop the join index.

ORA-23300 string

Cause: The stored procedure RAISE_SYSTEM_ERROR was called which causes this error to be generated.

Action: Correct the problem as described in the error message or contact the application administrator or database administrator for more information.

ORA-23301 mixed use of deferred rpc destination modes

Cause: Replication catalog determined deferred RPC destinations were mixed with destination determined by other mechanisms in the same transaction.

Action: Do not mix destination types in the same transaction.

ORA-23302 application raised communication failure during deferred RPC

Cause: An application declared a communication failure during a deferred RPC.

Action: Retry the application when communication is restored.

ORA-23303 application raised generic exception during deferred RPC

Cause: An application declared a generic failure during a deferred RPC.

Action: Determined by the application.

ORA-23304 malformed deferred rpc at arg string of string in call string, in tid string

Cause: A deferred RPC call was issued without the correct number of arguments as determined by the count parameter to DBMS_DEFER.CALL.

Action: Be sure the number of arguments matches the count.

ORA-23305 internal deferred RPC error: string

Cause: An internal error occurred in deferred RPC.

Action: Report the error and other information to support.

ORA-23306 schema string does not exist

Cause: The schema name was null or misspelled, or the schema does not exist locally.

Action: Specify the schema correctly, or create it with CREATE USER.

ORA-23307 replicated schema string already exists

Cause: The given database already replicates the given schema.

Action: Choose a different schema or a different database.

ORA-23308 object string.string does not exist or is invalid

Cause: The given name was null or misspelled, the given type was wrong, the object does not exist as a valid database object, or the object does not exist as a replicated object with the appropriate status.

Action: Ensure the object is valid in the database, is visible to the user, and, if appropriate, is a valid object in ALL_REPOBJECT.

ORA-23309 object string.string of type string exists

Cause: An object in the same name space exists, perhaps with a different type or shape, or the same object has already been registered as an REPOBJECT in another object group.

Action: Remove the offending object with the SQL DROP command, unregister the offending object with DBMS_REPCAT.DROP_MASTER_REPOBJECT(), or reinvoke the request using TRUE for a boolean parameter such as retry or USE_EXISTING_OBJECT.

ORA-23310 object group "string"."string" is not quiesced

Cause: The requested operation requires the object group to be suspended.

Action: Invoke SUSPEND_MASTER_ACTIVITY at the REPGROUP's MASTERDEF, wait until the status has changed to quiesced, and then retry the original request.

ORA-23312 not the masterdef according to string

Cause: The group name is null, the group name is misspelled, the invocation or given database is not the MASTERDEF, or one of the masters does not believe the invocation database is the MASTERDEF.

Action: If the given group name and MASTERDEF were both correct, connect to the MASTERDEF and retry the request, or relocate the MASTERDEF at the (errant) databases using RELOCATE_MASTERDEF.

ORA-23313 object group "string"."string" is not mastered at string

Cause: The group name is null, the group name is misspelled, the invocation database is not a master, or the invocation database does not believe the given database is a master.

Action: If the given group name was correct, connect to a current master and retry the request, make the invocation database a master with ADD_MASTER_DATABASE, or use SWITCH_MVIEW_MASTER if the invocation database is a materialized view site.

ORA-23314 database is not a materialized view site for "string"."string"

Cause: The invocation database is not a snapshot database for the given object group.

Action: Connect to the desired materialized view database and retry the request, or make the invocation database a materialized view site with CREATE_MVIEW_REPSCHEMA or CREATE_MVIEW_REPGROUP.

ORA-23315 repcatlog version or request string is not supported by version string

Cause: Either incompatible REPCAT versions are used, or a REPCATLOG record has been corrupted.

Action: Convert the master to a compatible version of REPCAT or retry the request.

ORA-23316 the masterdef is string

Cause: The requested operation is not permitted on a MASTERDEF site.

Action: Relocate the MASTERDEF to another master and retry the operation.

ORA-23317 a communication failure has occurred

Cause: The remote database is inaccessible.

Action: Ensure the remote database is running, the communications network is functioning, and the appropriate database links are present.

ORA-23318 a ddl failure has occurred

Cause: User-supplied or system-generated DDL did not execute successfully.

Action: Examine DDL, database state, REPCATLOG, and ALL_ERRORS to determine why the failure occurred.

ORA-23319 parameter value string is not appropriate

Cause: The given value of a parameter is either null, misspelled, or not supported.

Action: Refer to the documentation and use parameter values that are appropriate for the given situation.

ORA-23320 the request failed because of values string and string

Cause: A missing DDL record for a REPCATLOG record, or inconsistency in REPCAT views.

Action: Retry the request, or make the views consistent.

ORA-23321 Pipename may not be null

Cause: You called DBMS_PIPE with a null pipe name.

Action: Find out the name of the pipe and call function with non-null pipe name.

ORA-23322 Privilege error accessing pipe

Cause: You either tried to create a pipe that already existed and belonged to someone else, or remove a pipe that you were not authorized to use, or put a message into a pipe that you were not authorized for, or get a message from a pipe that you were not authorized for.

Action: You may have to use a different pipe name.

ORA-23323 parameter length exceeds deferred RPC limits

Cause: A deferred RPC parameter was longer than the deferred RPC limits of 4000 bytes for char/varchar2 parameters and 2000 bytes for raw parameters.

Action: Use smaller parameters.

ORA-23324 error string, while creating deferror entry at "string" with error string

Cause: The given error was encountered while attempting to create a DEFERROR entry for the give error code and the give database.

Action: Correct the cause of the given error.

ORA-23325 parameter type is not string

Cause: A conflict resolution priority function was given a type different than the type assigned to the priority group; or the priority group has no type assigned or a function; or DBMS_DEFER_SYS_QUERY was called to retrieve a deferred RPC parameter from the deferred RPC queue, but the type of the parameter does not match the return type of the function.

Action: Use the function corresponding to the parameter type.

ORA-23326 object group "string"."string" is quiesced

Cause: Either SUSPEND_MASTER_ACTIVITY has been called before the object group has resumed normal operation or a (deferred) RPC operation was attempted while the object group was quiesced.

Action: If SUSPEND_MASTER_ACTIVITY has been called and a RESUME_MASTER_ACTIVITY request is pending, wait until it completes, and then reinvoke SUSPEND_MASTER_ACTIVITY. Otherwise, resume database activity with the RESUME_MASTER_ACTIVITY call.

ORA-23327 imported deferred rpc data does not match string of importing db

Cause: Deferred RPC queues were imported from a database with a different global name or operating system than importing database.

Action: Deferred RPC data should only be imported into a database with the same global name and hardware and operating system.

ORA-23328 mview base table "string"."string" differs from master table "string"."string"

Cause: When creating a materialized view through REPCAT, the materialized view base table name did not match a replicated table name at the master.

Action: Change the materialized view DDL to use the same base table as the replicated table name at the master.

ORA-23329 successful user-provided ddl but no materialized view "string"."string"

Cause: The DDL provided by the user to create a materialized view was executed without error, but materialized view does not exist.

Action: Manually back-out the DDL, and reregister with matching DDL and materialized view.

ORA-23330 column group string already exists

Cause: The column group was already registered in the object group.

Action: Use a column group name not yet registered in the replicated object group.

ORA-23331 column group string does not exist

Cause: The given column group is either null, misspelled or not registered.

Action: Use a registered column group.

ORA-23332 group string is in use; cannot drop

Cause: The given column group or priority group is being used to resolve conflicts.

Action: Call DBMS_REPCAT procedures DROP_UPDATE_RESOLUTION, DROP_DELETE_RESOLUTION, DROP_UNIQUE_RESOLUTION so that the column group or priority group is no longer in use before dropping.

ORA-23333 column string is already part of a column group

Cause: An attempt was made to add a column to a column group when the column was already a member of a column group.

Action: Drop the column from its existing column group before trying to add it to another.

ORA-23334 column string does not exist in table or column group

Cause: The given column is either null, misspelled or is not part of the given table or column group.

Action: Use a column that is a member of the table or column group.

ORA-23335 priority group string already exists

Cause: The priority group was already registered in the object group.

Action: Use a column group name not yet registered in the object group.

ORA-23336 priority group string does not exist

Cause: The priority group was already registered in the object group.

Action: Use a priority group name not yet registered in the object group.

ORA-23337 priority or value not in priority group string

Cause: The specified value or priority has not been registered as part of the priority group.

Action: Either specify a different value or priority that is already part of the priority group, or add the value to the priority group.

ORA-23338 priority or value already in priority group string

Cause: The specified value or priority has already been registered as part of the priority group.

Action: Either specify a different value or priority that not already part of the priority group, or drop the value to the priority group.

ORA-23339 duplicate conflict resolution information

Cause: The specified combination of column group, sequence, conflict type and/or parameter table name, parameter column name, and parameter sequence number has already been registered.

Action: Verify that additional conflict resolution information needs to be added and provide a new sequence number. If modifying existing information, the existing information must be dropped first.

ORA-23340 incorrect resolution method string

Cause: User function is specified when conflict resolution method was not "USER FUNCTION" or specified resolution method is not one of the predefined methods.

Action: If user function is specified when conflict resolution method was not "USER FUNCTION", either reregister function with method as "USER FUNCTION" or specify a NULL user function. Otherwise, specify one of the documented supported conflict resolution methods.

ORA-23341 user function required

Cause: A NULL user function was specified for the "USER FUNCTION" method.

Action: Provide user function name (for example, "schema"."package"."function") that conforms to the documented user function specifications or specify one of the documented supported conflict resolution methods.

ORA-23342 invalid parameter column string

Cause: The parameter column name is null or misspelled, the invocation database is not a master, or is of the wrong type for the specified conflict resolution method.

Action: Specify a parameter column from the specified column group that has a correct type for the conflict resolution method.

ORA-23343 no match for specified conflict resolution information

Cause: The specified combination of column group, sequence, conflict type has not been registered (for example, for adding a comment).

Action: Specify a combination of column group, sequence, conflict type has been registered.

ORA-23344 constraint (string.string) does not exist

Cause: A null, misspelled or non-existent constraint was specified when registering a uniqueness conflict.

Action: Register a named constraint for the specified table.

ORA-23345 table "string"."string" not registered to collect statistics

Cause: A procedure that deals with conflict resolution statistics-gathering was called for a table that was not registered to collect statistics.

Action: Call DBMS_REPCAT.REGISTER_STATISTICS to register the table.

ORA-23346 primary key or object ID is undefined for table or materialized view string

Cause: An attempt was made to generate replication support for a table or materialized view without a primary key (as defined by a constraint or DBMS_REPCAT.SET_COLUMNS) or an object ID.

Action: For a table, add a primary key constraint or define a primary key using DBMS_REPCAT.SET_COLUMNS or use object tables. For a ROWID materialized view, set min_communication to false or use primary key or object ID materialized views.

ORA-23347 datatype string for column string table string not supported

Cause: The table has a column whose datatype is not supported by REPCAT.

Action: Remove the column from the table, or alter the column to have one of the supported datatypes.

ORA-23348 cannot replicate procedure string; only IN parameters supported

Cause: An attempt was made to generate replication support for a package that has a procedure with OUT or IN OUT parameters.

Action: Remove the procedure from the package, or remove the OUT or IN OUT parameters from the procedure.

ORA-23349 cannot generate replication support for functions

Cause: An attempt was made to generate replication support for a package that has a public function, or for a standalone function.

Action: Remove the public function from the package, or alter the function to be a procedure.

ORA-23350 maximum number of recursive calls exceeded

Cause: This usually occurs when trying to resolve conflicts in a table while concurrent updates to the same row create more conflicts.

Action: Re-execute the deferred transaction from DefError using DBMS_DEFER_SYS.EXECUTE_ERROR.

ORA-23351 parameter datatype string for procedure string not supported

Cause: The procedure has a parameter whose datatype is not supported by REPCAT.

Action: Remove the parameter from the procedure, or alter the parameter to have one of the supported datatypes.

ORA-23352 duplicate destination for deferred transaction

Cause: A duplicate destination was specified for a deferred transaction either in a DBMS_DEFER.CALL call or an earlier DBMS_DEFER.TRANSACTION call or a dbms_defer_sys.add_default_dest call.

Action: Remove the duplicate entry.

ORA-23353 deferred RPC queue has entries for object group "string"."string"

Cause: The requested action cannot be performed until the queue is empty for the given object group.

Action: Use DBMS_DEFER_SYS.EXECUTE or DBMS_DEFER_SYS.DELETE_TRAN to empty the queue.

ORA-23354 deferred RPC execution disabled for "string" with "string"

Cause: Deferred RPC cannot be executed at the destination with the specified catchup value because their propagation has been disabled.

Action: Enable deferred RPC execution with the DBMS_DEFER_SYS.SET_DISABLED call.

ORA-23355 object string.string does not exist or is invalid at master site

Cause: The given name was null or misspelled, the given type was wrong, the object does not exist as a valid database object at the master site, or the object does not exist as a replicated object with the appropriate status.

Action: Ensure the object is valid in the master database, and is visible to the user, and, if appropriate, is a valid object in ALL_REPOBJECT.

ORA-23356 masterdef recognizes a master which does not recognize the masterdef

Cause: Possibly DROP_MASTER_REPGROUP was run at a master site but REMOVE_MASTER_DATABASES was not run at master definition site for that master.

Action: Run REMOVE_MASTER_DATABASES from master definition site to remove the appropriate master (see associated error messages).

ORA-23357 the propagator does not exist

Cause: The propagator does not exist.

Action: Register a new propagator.

ORA-23358 invalid remote user

Cause: The local user does not match the remote user connected via a database link.

Action: Drop and re-create the identified database link with the connect-to user identical to the owner of the database link.

ORA-23359 error on creating a ddl record for a repcatlog record

Cause: The USERID in the REPCATLOG record does not match the USERID of the connected user.

Action: Retry the operation with a different user.

ORA-23360 only one materialized view for master table "string" can be created

Cause: An attempt was made to create more than one materialized view on a given master table in the same rep group.

Action: Create these other materialized views in a different rep group at another site.

ORA-23361 materialized view "string" does not exist at master site

Cause: The materialized view does not exist at the master site for offline instantiation of the materialized view.

Action: The correct procedure is to create the materialized view in a different schema at the master site, and then follow the instructions for offline instantiation of materialized views.

ORA-23362 invalid user

Cause: The given user does not exist.

Action: Enter the name of a valid user and retry the operation.

ORA-23363 mismatch of mview base table "string" at master and mview site

Cause: The name of the base table of the materialized view at the master site is different from the base table at the materialized view site. This error may arise during offline instantiation of materialized views.

Action: Retry offline instantiation with a materialized view name less than 24 bytes.

ORA-23364 Feature not enabled: Advanced replication

Cause: The Advanced Replication feature is not enabled at this site. Updatable materialized views, deferred RPCs, and other replication features are, therefore, unavailable.

Action: Do not attempt to use this feature. Contact Oracle Support Services if the Advanced Replication feature has been purchased but not enabled.

ORA-23365 site string does not exist

Cause: site specified in argument REFERENCE_SITE or argument COMPARISON_SITE in call to DIFFERENCES() routine or RECTIFY() routine does not name an existing site.

Action: Make sure that database sites specified really do exist, and rerun the routine.

ORA-23366 integer value string is less than 1

Cause: Value of argument MAX_MISSING to routine DIFFERENCES() cannot be less than 1. Value of argument COMMIT_ROWS to routines DIFFERENCES() and RECTIFY() cannot be less than 1.

Action: Choose an integer value for those arguments to be 1 or greater.

ORA-23367 table string is missing the primary key

Cause: Table specified in argument "oname1" or "oname2" in call to "differences()" routine does not contain either a primary key or a virtual primary key (defined through DBMS_REPCAT package under symmetric replication).

Action: Make sure the tables specified have a primary key defined.

ORA-23368 name string cannot be null or the empty string

Cause: Argument SNAME1, SNAME2, ONAME1, ONAME2, MISSING_ROWS_SNAME, MISSING_ROWS_ONAME1, MISSING_ROWS_ONAME2 to DIFFERENCES() or RECTIFY() cannot be NULL or '' (empty string).

Action: Change argument to non-null or non-empty string.

ORA-23369 value of "string" argument cannot be null

Cause: Argument MAX_MISSING to DIFFERENCES() routine cannot be NULL.

Action: Legal values for MAX_MISSING are integers 1 or greater.

ORA-23370 table string and table string are not shape equivalent (string)

Cause: The tables specified are not shape equivalent, which means intuitively that the number of columns, the names, their datatypes and lengths are not the same. Specifically, problem is in the parentheses and is one of the following: the number of columns are not equal, datatypes of columns with same name in different tables are different, lengths of varchar2 and char columns are not equal, precision and scale of number datatypes are not equal.

Action: Make sure the two tables being compared have the same number of columns, same column names, and same datatypes.

ORA-23371 column string unknown in table string

Cause: Some column in ARRAY_COLUMNS argument (or COLUMN_LIST argument) to DIFFERENCES() routine does not correspond to a column in the specified table.

Action: Make sure that all the columns in either ARRAY_COLUMNS or COLUMN_LIST are present in the specified table.

ORA-23372 type string in table string is unsupported

Cause: Certain types in the table comparison utility are not supported.

Action: Make sure that the types of columns in the tables to be compared are the ones supported by symmetric replication.

ORA-23373 object group "string"."string" does not exist

Cause: The group name was null or misspelled, or the group does not exist locally.

Action: Specify the group correctly, or create it with DBMS_REPCAT.CREATE_MASTER_REPGROUP().

ORA-23374 object group "string"."string" already exists

Cause: The given database already replicates the given object group. A materialized view repgroup cannot be created at a given site where a master repgroup with the same name already exists.

Action: Choose a different group or a different database.

ORA-23375 feature is incompatible with database version at string

Cause: A feature not compatible with the specified database was used.

Action: Set or raise the value of the COMPATIBLE initialization parameter to match the necessary compatibility level.

ORA-23376 node string is not compatible with replication version "string"

Cause: A feature not compatible with the remote database was used.

Action: Upgrade the remote database and retry the operation.

ORA-23377 bad name string for missing_rows_oname1 argument

Cause: An attempt was made to use the name of the reference site table as the name of the missing_rows_oname1 argument.

Action: Provide a separately created table with a different name for MISSING_ROWS_ONAME1 argument. The separately created table will contain the differences between the tables being compared.

ORA-23378 connection qualifier "string" is not valid for object group "string"."string"

Cause: The connection qualifier used in the database link for the specified object group does not match the qualifier specified for the group in CREATE_MASTER_REPGROUP.

Action: Use or create a database link which contains the correct connection qualifier.

ORA-23379 connection qualifier "string" is too long

Cause: The maximum length of a database link, including the connection qualifier, is 128 bytes.

Action: Use a shorter connection qualifier, or shorten the name of the database link

ORA-23380 propagation mode "string" is not valid

Cause: The specified propagation is misspelled, or is not supported. For materialized view sites, all materialized view object groups at the same materialized view site with the same master object group must all have the same propagation method.

Action: Refer to Oracle9i Replication for valid propagation modes. For materialized view sites, also ensure that the propagation modes of all materialized view object groups with the same master object group are the same.

ORA-23381 generated object for base object string.string@string does not exist

Cause: The system generated object(s) for the specified base object do not exist at the specified site. The current operation requires the base object to have generated replication support.

Action: Ensure that the generated replication object(s) for the base object exist and are valid at the specified site. If the generated object(s) do not exist, then the procedure DBMS_REPCAT.GENERATE_REPLICATION_SUPPORT() needs to be called from the master definition site for the base object. missing_rows_oname1 argument. The separately created table will contain the differences between the tables being compared.

ORA-23382 materialized view repgroup "string"."string" is not registered at site string

Cause: The materialized view REPGROUP is not currently registered at the master and so cannot be unregistered.

Action: No action required.

ORA-23383 registration for materialized view repgroup "string"."string" failed at site string

Cause: Insertion into local REPSCHEMA table failed.

Action: No action required.

ORA-23384 replication parallel push string argument out of range

Cause: Specified numeric argument to DBMS_DEFER_SYS.PUSH is invalid.

Action: Fix the argument value and try again.

ORA-23385 replication parallel push string argument not valid

Cause: Specified string argument to DBMS_DEFER_SYS.PUSH is invalid.

Action: Fix the argument value and try again.

ORA-23386 replication parallel push cannot create slave processes

Cause: An error was occurred while creating slave processes for parallel push.

Action: If the PARALLEL_MAX_SERVERS initialization parameter is zero, reconfigure the parameter to be greater than zero. Otherwise, contact Oracle Support Services.

ORA-23387 replication parallel push dequeue error

Cause: An attempt to dequeue a deferred transaction failed while trying to assign a new queue batch number.

Action: Contact Oracle Support Services.

ORA-23388 replication parallel push watermark error

Cause: An error occurred during parallel push while trying to update the high-water-mark information in SYSTEM.DEF$_DESTINATION.

Action: Contact Oracle Support Services.

ORA-23389 obsolete procedure; drop objects and recreate using new master

Cause: DBMS_REPCAT.SWITCH_MVIEW_MASTER is no longer supported.

Action: Drop the objects in the object group and re-create them using the new master.

ORA-23392 could not find materialized view to be associated with "string"."string"

Cause: Could not find materialized view associated with a trigger or index that is being pulled from the master site.

Action: Ensure that materialized view, master, and master index or trigger are registered as replicated objects.

ORA-23393 the user is already the propagator

Cause: The given user is already the current propagator.

Action: No action required.

ORA-23394 duplicate propagator

Cause: More than one valid propagator exists.

Action: Unregister any duplicate propagator.

ORA-23395 object "string"."string" of type "string" does not exist or is invalid

Cause: The given name was null or misspelled, the given type was wrong, the object does not exist as a valid database object, or the object does not exist as a replicated object with the appropriate status.

Action: Ensure the object is valid in the database, is visible to the user, and, if appropriate, is a valid object in ALL_REPOBJECT.

ORA-23396 database link "string" does not exist or has not been scheduled

Cause: The database link does not exist in the schema of the replication propagator or has not been scheduled.

Action: Ensure that the database link exists in the database, is accessible and is scheduled for execution.

ORA-23397 global name "string" does not match database link name "string"

Cause: The database link name at the local node does not match the global name of the database that the link accesses.

Action: Ensure that global names is set to true and the link name matches the global name.

ORA-23398 user name "string" at database link "string" does not match local user name "string"

Cause: The user name of the replication administration user at the local node and the user name at the node corresponding to the database link are not the same. Symmetric replication expects the two users to be the same.

Action: Ensure that the user ID of the replication administration user at the local node and the user ID at the node corresponding to the database link are the same.

ORA-23399 generation of replication support for "string"."string" is not complete

Cause: Replication support for the specified object has not been generated or the generation process is not yet complete.

Action: Ensure that replication support has been generated for the object. Use DBMS_REPCAT.GENERATE_REPLICATION_SUPPORT() to generate replication support for the object.

ORA-23400 invalid materialized view name "string"

Cause: A null, misspelled, or badly formed materialized view name was given to DBMS_MVIEW.REFRESH.

Action: Provide a valid materialized view name to DBMS_MVIEW.REFRESH.

ORA-23401 materialized view "string"."string" does not exist

Cause: A materialized view name was given to DBMS_MVIEW.REFRESH that is not in SYS.SNAP$ or its associated views.

Action: Provide a materialized view name that is in SYS.SNAP$, ALL_MVIEWS or USER_MVIEWS.

ORA-23402 refresh was aborted because of conflicts caused by deferred txns

Cause: There are outstanding conflicts logged in the DefError table at the materialized view's master.

Action: Resolve the conflicts in the master DefError table and refresh again after the table is empty. Alternatively, refresh with REFRESH_AFTER_ERRORS set to TRUE, which will proceed with the refresh even if there are conflicts in the master's DefError table. Proceeding despite conflicts can result with an updatable materialized view's changes appearing to be temporarily lost (until a refresh succeeds after the conflicts are resolved).

ORA-23403 refresh group "string"."string" already exists

Cause: Making a new refresh group when there is already a group of the same name in SYS.RGROUP$.

Action: Choose a different refresh group name.

ORA-23404 refresh group "string"."string" does not exist

Cause: A refresh group name was given that is not in SYS.RGROUP$.

Action: Provide a refresh group name that is in SYS.RGROUP$ or DBS_RGROUP.

ORA-23405 refresh group number string does not exist

Cause: A refresh group number was given that is not in SYS.RGROUP$.

Action: Provide a refresh group number that is in SYS.RGROUP$ or DBS_RGROUP.

ORA-23406 insufficient privileges on user "string"

Cause: The caller is not the owner of the materialized view and does not have ALTER ANY MATERIALIZED VIEW privileges.

Action: Perform the operation as the owner of the materialized view or as a user with ALTER ANY MATERIALIZED VIEW privileges.

ORA-23407 object name string must be shaped like "schema"."object" or "object"

Cause: The object name (for example, the rollback segment, the materialized view name, the refresh group) was incorrectly specified.

Action: Retry the operation with the object name properly specified (like "schema"."object" or "object").

ORA-23408 this replication operation is not supported in a mixed configuration

Cause: Operation is not supported if the object group is replicated at a pre-V8 node.

Action: Ensure that all nodes of the replicated object group are V8.

ORA-23409 could not find an unused refresh group number

Cause: 1000 consecutive refresh group numbers, as defined by the RGROUPSEQ number, were already used by rows in SYS.RGROUP$.

Action: Alter the sequence number to be within a legal unused range and destroy unneeded refresh groups.

ORA-23410 materialized view "string"."string" is already in a refresh group

Cause: A materialized view of the same name is already in a refresh group.

Action: Subtract the materialized view from the current refresh group and add it to its new refresh group, or combine the two refresh groups into a single refresh group.

ORA-23411 materialized view "string"."string" is not in refresh group "string"."string"

Cause: The specified materialized view is not in the specified refresh group.

Action: Try again with the proper materialized view and refresh group names.

ORA-23412 master table's primary key columns have changed

Cause: The master table's primary key constraint was modified after the primary key materialized view was created.

Action: Drop and re-create the primary key materialized view.

ORA-23413 table "string"."string" does not have a materialized view log

Cause: The fast refresh cannot be performed because the master table does not contain a materialized view log.

Action: Use the CREATE MATERIALIZED VIEW LOG command to create a materialized view log on the master table.

ORA-23414 materialized view log for "string"."string" does not record rowid values

Cause: A ROWID materialized view is being fast refreshed, but the materialized view log does not record ROWID information.

Action: Use the CREATE MATERIALIZED VIEW LOG...ADD ROWID command to begin recording ROWID information in the materialized view log.

ORA-23415 materialized view log for "string"."string" does not record the primary key

Cause: A primary key materialized view is being fast refreshed, but the materialized view log does not record primary key information.

Action: Use the CREATE MATERIALIZED VIEW LOG...ADD PRIMARY KEY command to begin recording primary key information in the materialized view log.

ORA-23416 table "string"."string" does not contain a primary key constraint

Cause: The master table does not contain a primary key constraint or the primary key constraint has been disabled.

Action: Create a primary key constraint on the master table or enable the existing constraint.

ORA-23417 unknown materialized view type: string

Cause: A fast refresh is being performed on a materialized view of an unknown or unsupported type.

Action: Check ALL_MVIEWS and ensure that the materialized view being refreshed is a valid materialized view.

ORA-23418 cannot unregister the propagator who is currently in use

Cause: The propagator is currently used in propagating replication RPCs.

Action: Try again later when there is no transaction active in propagating replication RPCs.

ORA-23419 regenerate replication support before resuming master activity

Cause: There are tables in the object group that require regeneration of replication support.

Action: Check the GENERATION_STATUS column in the ALL_REPOBJECT view. Regenerate replication support for any table in the object group with a 'NEEDSGEN' status. Resume master activity.

ORA-23420 interval must evaluate to a time in the future

Cause: The parameter INTERVAL evaluates to a time earlier than SYSDATE.

Action: Choose an expression that evaluates to a time later than SYSDATE.

ORA-23421 job number string is not a job in the job queue

Cause: There is no job visible to the caller with the given job number.

Action: Choose the number of a job visible to the caller.

ORA-23422 Oracle Server could not generate an unused job number

Cause: Oracle Server could not generate a job number that was not used to identify another job.

Action: Retry the operation.

ORA-23423 job number string is not positive

Cause: The given job number is less than 1.

Action: Choose a positive integer.

ORA-23424 materialized view "string"."string" at string not registered

Cause: The specified materialized view has not been successfully registered at this site.

Action: Register the materialized view manually at either the master site or the materialized view site.

ORA-23425 invalid materialized view identifier string

Cause: The argument provided to DBMS_MVIEW.PURGE_MVIEW_FROM_LOG is an invalid materialized view identifier or it does not identify an Oracle8 fast refreshable materialized view or the materialized view has already been purged.

Action: If the materialized view is an Oracle8 fast refreshable materialized view then provide PURGE_MVIEW_FROM_LOG with its valid materialized view identifier.

ORA-23426 deferred RPC queue has entries for string

Cause: The requested action cannot be performed until the queue is empty for the given site/database link.

Action: Use DBMS_DEFER_SYS.PUSH, DBMS_DEFER_SYS.PURGE_QUEUE or DBMS_DEFER_SYS.DELETE_TRAN to empty the queue.

ORA-23427 deferred purge queue argument string out of range

Cause: Specified numeric argument to DBMS_DEFER_SYS.PURGE_QUEUE is invalid.

Action: Fix the argument value and try again.

ORA-23428 job associated instance number string is not valid

Cause: A job is associated with an instance that is not running.

Action: Choose a running instance for job affinity, or set force parameter to TRUE.

ORA-23430 argument "string" cannot be NULL or empty string

Cause: The caller has provided an argument whose value cannot be NULL or the empty string.

Action: Check that the varchar2 value provided is not NULL or the empty string, and retry the call.

ORA-23431 wrong state: string

Cause: The routine was executed against a replicated object group that was in the wrong state.

Action: Make sure that the replicated object group is in the state given in the error message.

ORA-23432 master site string already exists

Cause: An attempt was made to instantiate a replicated object group at a master site that was already a part of the object group.

Action: If you were trying to add this site, do nothing because it already exists; otherwise, pick the name of another site, and rerun the routine.

ORA-23433 executing against wrong master site string

Cause: An attempt was made to execute the routine at a site that is different from the site specified in the argument of the routine.

Action: Provide an argument to the routine that correctly indicates the site against which the routine should be executing.

ORA-23434 master site string not known for object group

Cause: The site name given as an argument to a routine was not already known to the replicated object group.

Action: Execute the DBMS_OFFLINE_OG.BEGIN_INSTANTIATION() routine to add a new site to the replicated object group.

ORA-23435 cannot create an updatable ROWID materialized view with LOB columns

Cause: The propagation of LOB data from materialized view sites to the master site requires a primary key on the replicated table. Thus updatable ROWID materialized views that contain LOB columns are not supported.

Action: Create a primary key materialized view instead of a ROWID materialized view. If the materialized view already exists, it can be converted to a primary key materialized view using the ALTER MATERIALIZED VIEW DDL command.

ORA-23436 missing template authorization for user

Cause: The specified template authorization does not exist.

Action: Check the values for user name and refresh template name to ensure a valid row exists in the DBA_REPCAT_USER_AUTHORIZATIONS view.

ORA-23437 template authorization already exists for user

Cause: The specified user already has been authorized to use the specified refresh group template.

Action: Check the values for user name and refresh template name or query the DBA_REPCAT_USER_AUTHORIZATIONS view to ensure that the correct values were passed as parameters.

ORA-23438 missing refresh group template

Cause: The specified refresh group template does not exist.

Action: Verify that the refresh group template does not exist by querying the DBA_REPCAT_REFRESH_TEMPLATES view.

ORA-23439 refresh group template already exists

Cause: The specified refresh group template already exists.

Action: Verify that the refresh group template exists by querying the DBA_REPCAT_REFRESH_TEMPLATES view.

ORA-23440 incorrect public template value

Cause: The public template parameter is not 'Y', 'N' or NULL.

Action: Correct the value of the public template parameter. It must be 'Y','N' or NULL.

ORA-23441 object does not exist for refresh group template

Cause: The specified object does not exist in the refresh group template.

Action: Correct the object name and object type parameters. Check the DBA_REPCAT_TEMPLATE_OBJECTS view to verify the correct name and type of the object.

ORA-23442 object already exists for the refresh group template

Cause: The specified object already exists in the refresh group template.

Action: Change the object name and object type parameters. Query the DBA_REPCAT_REMPLATE_OBJECTS view to verify the correct name and type of the object.

ORA-23443 missing template parameter

Cause: The specified template parameter does not exist.

Action: Correct the template parameter value and execute the procedure again. Use the DBA_REPCAT_TEMPLATE_PARMS view to verify the name of the refresh group template and parameter name.

ORA-23444 duplicate template parameter

Cause: The template parameter already exists for the specified refresh group template.

Action: Correct the template parameter value and execute the procedure again. Use the DBA_REPCAT_TEMPLATE_PARMS view to verify the name of the refresh group template and parameter name.

ORA-23445 missing template site

Cause: The template site specified by the site name, user name and refresh group template name does not exist.

Action: Correct the invalid parameter and execute the procedure again. Use the DBA_REPCAT_TEMPLATE_SITES view to query the existing template sites.

ORA-23446 duplicate template site

Cause: The template site specified by the site name, user name and refresh group template name already exists.

Action: Correct the invalid parameter and execute the procedure again. Use the DBA_REPCAT_TEMPLATE_SITES view to query the existing template sites.

ORA-23447 missing user parameter value

Cause: The user parameter value specified by the user name, parameter name and refresh group template name does not exist.

Action: Correct the invalid parameter and execute the procedure again. Use the DBA_REPCAT_USER_PARM_VALUES view to query the existing user parameters.

ORA-23448 duplicate user parameter value

Cause: The user parameter value specified by the user name, parameter name and refresh group template name already exists.

Action: Correct the invalid parameter and execute the procedure again. Use the DBA_REPCAT_USER_PARM_VALUES view to query the existing user parameters.

ORA-23449 missing user name

Cause: The user specified by the user name parameter does not exist in the database.

Action: Correct an invalid user name or create the user in the master database. Use the DBA_USERS view to select the valid database users.

ORA-23450 flavor already contains object "string"."string"

Cause: The flavor already contains the specified object.

Action: Check that the specified object is correct. To add all columns of a table object, delete the object from the flavor and then add it again.

ORA-23451 flavor string already defined for object group "string"."string"

Cause: The given object group already contains a (possibly unpublished) definition of the specified flavor.

Action: Check the spelling of the flavor name. Check for an unpublished flavor of the desired name.

ORA-23452 flavor string of object group "string"."string" is already published

Cause: The given object group already contains a (published) definition of the specified flavor.

Action: Check the spelling of the flavor name.

ORA-23453 requested operation is not supported on top flavor

Cause: The TOP flavor has a NULL name and may not be directly defined or deleted.

Action: Supply the name of a flavor other than the TOP flavor or use DBMS_REPCAT routines to implicitly change the TOP flavor.

ORA-23454 flavor string not defined for object group "string"."string"

Cause: The given object group does not contain a (published) definition of the specified flavor.

Action: Check the spelling of the flavor name. Ensure the flavor has been defined (and published) for the object group.

ORA-23455 flavor string contains object "string"

Cause: The given flavor contains the object to be dropped.

Action: Purge the flavor or choose another object to drop.

ORA-23456 flavor string does not contain "string"

Cause: The flavor does not contain the given object, column, or attribute.

Action: Either drop the flavor or choose a different object, column, or attribute.

ORA-23457 invalid flavor ID string

Cause: The given flavor ID is invalid.

Action: Make sure this flavor has been instantiated. If the flavor ID is outside the range (-2147483647, 2147483647), contact Oracle Support Services.

ORA-23458 inappropriate flavor string at string

Cause: The given flavor at the given database prevents the operation from succeeding.

Action: Either change the database flavor or choose a different operation.

ORA-23459 flavor string must contain "string"

Cause: The flavor must contain the given object, column, or attribute.

Action: Either choose a different database flavor or ensure the object, column, or attribute is available.

ORA-23460 missing value for column string in resolution method "string" for "string"."string"."string"

Cause: Before resolving conflicts, some values necessary for resolving conflicts are not available; or, after resolving conflicts, some values necessary for retrying the SQL are not available.

Action: define appropriate flavors, provide necessary values through availability vector in USER FLAVOR FUNCTION for conflict resolution.

ORA-23461 fail to resolve conflict for "string"."string"."string"

ORA-23462 flavor string in use at site string

Cause: The given flavor cannot be deleted because it is being used at the given site.

Action: Change the flavor of the site, or unregister it if it is a materialized view site.

ORA-23463 flavor incompatible with object "string"."string"

Cause: An existing flavor includes the specified object with an incompatible type.

Action: Change the type of the object, or delete the flavor if it is not in use.

ORA-23464 flavor lacks column string of "string"."string"

Cause: The flavor includes some columns of an object group but not all the required columns.

Action: Change the flavor definition to include all required columns.

ORA-23465 flavor already includes column string of "string"."string"

Cause: The flavor includes the specified column which is being added.

Action: Check that the specified column is correct.

ORA-23466 flavor requires missing object "string"."string"

Cause: The flavor includes the specified object which does not exist.

Action: Check that the specified object name is correct, and create the object if appropriate.

ORA-23467 flavor lacks object "string"."string"

Cause: The flavor does not include the specified object which is being dropped.

Action: Check that the specified object is correct.

ORA-23468 missing string string

Cause: The template is missing the object with the specified key.

Action: Add the object to the template.

ORA-23469 string is different between templates

Cause: The values for the specified columns are different in each template for the same key values.

Action: Correct the column values to make the templates the same.

ORA-23470 invalid status

Cause: The status should be DELETED, INSTALLING or INSTALLED. Any other status is invalid.

Action: Check that the specified status value is correct.

ORA-23471 template not authorized for user

Cause: The refresh template is private and the user has not been authorized to instantiate the template.

Action: Authorize the user to use the template.

ORA-23472 materialized view "string"."string" must be atomically refreshed

Cause: Non-atomic refresh is not supported for the specified materialized view.

Action: Set the value of the ATOMIC parameter to FALSE in the refresh procedure being used or remove the specified materialized view from the set of materialized views being refreshed.

ORA-23473 replication RPC processing for "string"."string" is disabled

Cause: The processing of replication RPCs for the object group that contains this object is disabled. This includes RPCs in the error queue.

Action: Processing of replication RPCs is disabled when the object group is being offline instantiated. Wait until offline instantiation is finished.

ORA-23474 definition of "string"."string" has changed since generation of replication support

Cause: The current columns in the specified table and their column types do not match the columns and column types when replication support was last generated.

Action: Regenerate replication support for the affected table. All flavors that include the specified table should be checked for validity. Types for any UDT columns should also be checked for validity.

ORA-23475 key column string must be sent and compared

Cause: The specified column is a key column and must be sent and compared during replication propagation.

Action: Make sure every key column is sent and compared.

ORA-23476 cannot import from string to string

Cause: This object was imported from a database with a different global name than the importing database.

Action: Only import this object into a database with the same global name.

ORA-23477 unable to alter propagation mode for object group "string"."string"

Cause: The propagation method of a materialized view object group can only be altered when no other object groups with the same master object group are sharing the materialized view site.

Action: Ensure that there are no other materialized view object groups at the local site with the same master object group.

ORA-23478 object group string is already mastered at string

Cause: There is at least one other materialized view repgroup at the local site with the same group name but a different master site.

Action: Ensure that all materialized view repgroups at the local site with the same group name have the same master.

ORA-23480 Column string is not a top-level column of "string"."string".

Cause: The column is either not a top-level column or is not present in the table or materialized view.

Action: Ensure only valid top-level columns are used.

ORA-23482 column string of "string"."string": object types not allowed.

Cause: The column is of Object Type.

Action: Ensure that all the columns are not of Object Type.

ORA-23483 object "string"."string" not allowed in this operation.

Cause: The specified operation does not support the given object.

Action: Do not invoke the operation for this object.

ORA-23484 internal internet Application Server error: string

Cause: An internal error occurred in internet Application Server.

Action: Report the error and other information to support.

ORA-23485 Column group "string" must consist of a single numeric column only

Cause: The column group doesn't contain only one numeric column.

Action: Use a column group containing a single numeric column.

ORA-23487 object groups "string"."string" and "string"."string" do not have the same connection qualifier

Cause: The specified two object groups do not have the same connection qualifier.

Action: Do not invoke the operation on the above object groups, or ensure they have the same connection qualifier.

ORA-23488 propagation mode "string" for "string" is not allowed for this operation

Cause: This operation does not support the specified dblink in the above propagation mode.

Action: Do not invoke the operation for this dblink, or change the propagation mode for this dblink.

ORA-23489 duplicate entry "string"

Cause: The specified value is duplicated in the parameter list.

Action: Remove duplicated entries in the parameter list.

ORA-23490 extension request "string" with status "string" not allowed in this operation

Cause: The specified operation is not allowed for the extension request with the specified status.

Action: Ensure the extension request has the appropriate status before retrying this operation.

ORA-23491 no valid extension request at "string"

Cause: The specified database does not have a valid extension request.

Action: Ensure there is a valid extension request in the DBA_REPEXTENSIONS view before retrying this operation.

ORA-23492 no new sites for extension request "string"

Cause: There is no new site with the specified extension request.

Action: Ensure there is at least one new site in the DBA_REPSITES_NEW view for this request before retrying this operation.

ORA-23493 "string" is not a new site for extension request "string"

Cause: The specified extension request does not include the specified site as a new site.

Action: Ensure the specified site is a new site for this extension request before retrying this operation.

ORA-23494 too many rows for destination "string"

Cause: The specified destination has too many rows in the system.def$_destination table.

Action: Ensure the specified destination has at most two valid rows before retrying this operation.

ORA-23495 serial propagation can not be used for "string"

Cause: The sites involved may be in the process of adding a new site without quiescing.

Action: Check the def$_destination table for this destination and try parallel propagation.

ORA-23496 can not change disabled status for "string" and "string"

Cause: The disabled status for this site is set internally for synchronization during adding a new master without quiescing.

Action: Ensure adding a new master without quiescing finished before invoking this procedure.

ORA-23500 cannot switch master for a multi-tier materialized view repgroup "string"."string"

Cause: An attempt was made to switch master for a materialized view repgroup when its parent repgroup is also a materialized view repgroup. This is not allowed.

Action: Drop and recreate the materialized view repgroup based on a proper parent repgroup.

ORA-23501 refresh template cannot be instantiated for database with compatibility equal to or less than 8.0

Cause: Instantiation of a refresh template is not supported for database compatibility equal to or less than 8.0.

Action: Be sure the database compatibility is equal to 8.1 or higher.

ORA-23502 valid directory for offline instantiation is not specified

Cause: An attempt was made to offline instantiate to a directory which is not specified or null.

Action: There are two ways to specify the directory:

  • As a parameter OFFLINE_DIRPATH to the API
  • As an initialization parameter named UTL_FILE_DIR

Make sure you have specified an appropriate directory in which the offline file can be created.

ORA-23503 error occurred during IAS instantiation

Cause: An attempt was made to instantiate a IAS site. Error occurred during IAS instantiation.

Action: See the other errors on the error stack to look for the source of the problem. If the error still persists, contact Oracle Support Services.

ORA-23504 columns added to table do not match list of columns to be added

Cause: The list of columns passed as a parameter does not match the columns to be added to the table.

Action: Correct the DDL string or list of columns and rexecute.

ORA-23505 Object "string"."string" is missing.

Cause: The specified object does not exist.

Action: Check that the specified object is correct.

ORA-23514 invalid or incorrect number of arguments

Cause: The arguments passed to the online redefinition API were invalid or missing.

Action: Call the online redefinition API with the right number of valid arguments.

ORA-23515 materialized views and/or their indices exist in the tablespace

Cause: An attempt was made to drop a tablespace which contains materialized views and/or their indices.

Action: Drop the materialized views in this tablespace. Also, find indices belonging to materialized views in this tablespace and drop then. Then try dropping the tablespace.

ORA-23531 site owner already exists in the template

Cause: Site owner for the template already exists.

Action: Do not create multiple siteowners for this template.

ORA-23532 tables with different synchronization mechanisms are in the same group

Cause: Tables belonging to the same replication group were specified to be cached with different synchronization mechanisms.

Action: Do not specify different synchronization mechanisms while caching tables belonging to the same replication group.

ORA-23533 object "string"."string" can not be cached

Cause: An attempt was made to cache an object which is not supported.

Action: Do not cache an object which is not supported.

ORA-23534 missing column in materialized view container table "string"."string"

Cause: After import, the materialized view container table has missing columns.

Action: Check if materialized view container table was imported correctly.

ORA-23535 instantiating templates from multiple back ends is not allowed

Cause: An attempt was made to set a new non-null back end database for an iAS site.

Action: Call dbms_ias_configure.set_back_end_db procedure with null dblink. Then, call the same procedure with the new non-null dblink.

ORA-23536 the object "string"."string" is not cached at the middle tier as expected.

Cause: The object may have been dropped or renamed at the back end after dbms_ias_inst.start_ias_inst was executed.

Action: Check the validity of the object at the back end and retry the instantiation.

ORA-23537 function or procedure string is not allowed to be invoked from this site.

Cause: This function or procedure is restricted to the backend or middle tier site.

Action: Connect to the proper site before calling this function or procedure.

ORA-23538 cannot explicitly refresh a NEVER REFRESH materialized view ("string")

Cause: An attempt was made to explicitly refresh a NEVER REFRESH materialized view.

Action: Do not perform this refresh operation or remove the materialized views from the list.

ORA-23600 cannot create PROPAGATION, string already exists

Cause: The propagate_name already exists.

Action: Drop the propagate_name using DROP_PROPAGATE command or specify propagate_name.

ORA-23601 PROPAGATION_NAME string does not exist

Cause: Propagation does not exist.

Action: Query the DBA_PROPAGATION view to find existing propagation_name.

ORA-23602 Invalid streams process type string

Cause: Specified streams process type is not valid.

Action: Specify either capture or apply.

ORA-23605 invalid value "string" for STREAMS parameter string

Cause: An attempt was made to specify an invalid parameter value.

Action: Specify a valid value for the parameter. Check the documentation for valid parameter values.

ORA-23606 invalid object string

Cause: An attempt was made to specify an invalid object.

Action: Specify a valid object.

ORA-23607 invalid column "string"

Cause: An invalid column was specified in the column list.

Action: Check the columns in the object and specify the right column name.

ORA-23608 invalid resolution column "string"

Cause: An invalid column was specified as the resolution column. The resolution column must belong to the list of columns specified in the 'column_list' parameter.

Action: Check the columns in the column_list and specify the right resolution column name.

ORA-23619 non-Oracle system error: string

Cause: A non-Oracle database has returned an error message to STREAMS when attempting to apply a DML statement. The non-Oracle system error message is a parameter to this Oracle error.

Action: Corrective action may or may not be possible (depending on the non-Oracle system error). If corrective action is possible, then correct the problem and try applying the transaction again.

ORA-24000 invalid value string, string should be of the form [SCHEMA.]NAME

Cause: An invalid value was specified for the parameter.

Action: Specify a string of the form [SCHEMA.]NAME.

ORA-24001 cannot create QUEUE_TABLE, string already exists

Cause: The queue table already exists in the queueing system.

Action: Drop the table first using the DROP_QUEUE_TABLE() command or specify another table.

ORA-24002 QUEUE_TABLE string does not exist

Cause: QUEUE_TABLE does not exist.

Action: Query on the user view USER_QUEUE_TABLES to find out existing queue tables.

ORA-24003 Queue table index string inconsistent with queue table string

Cause: The queue table index has not yet been successfully imported.

Action: Import the queue table index before attempting to use the queue table. If the import failed, correct the problem and try to import the queue table index again.

ORA-24004 invalid column name string in SORT_LIST, should be ENQ_TIME or PRIORITY

Cause: Invalid column name was specified in the SORT_LIST.

Action: The valid column names are ENQ_TIME and PRIORITY.

ORA-24005 must use DBMS_AQADM.DROP_QUEUE_TABLE to drop queue tables

Cause: An attempt was made to use the SQL command DROP TABLE for queue tables, but DROP TABLE is not supported for queue tables.

Action: Use the DBMS_AQADM.DROP_QUEUE_TABLE procedure instead of the DROP TABLE command.

ORA-24006 cannot create QUEUE, string already exists

Cause: The queue requested to be created already exists.

Action: Specify another queue name. Query USER_QUEUES for all the existing queues in the users's schema.

ORA-24007 invalid value string, MAX_RETRIES should be non-negative integer

Cause: An invalid value was specified for MAX_RETRIES.

Action: Specify a non-negative integer.

ORA-24008 queue table string.string must be dropped first

Cause: An error was detected when dropping a queue table in a cluster, tablespace, or schema.

Action: Use the DBMS_AQADM.DROP_QUEUE_TABLE procedure to drop the specified queue table first; then, retry the operation.

ORA-24009 invalid value string, QUEUE_TYPE should be NORMAL_QUEUE or EXCEPTION_QUEUE

Cause: Invalid queue type parameter.

Action: Valid values are NORMAL_QUEUE for normal queue and EXCEPTION_QUEUE for exception queue.

ORA-24010 QUEUE string does not exist

Cause: The specified queue does not exist.

Action: Specify a valid queue. Query USER_QUEUES for all the valid queues.

ORA-24011 cannot drop QUEUE, string should be stopped first

Cause: The queue has not been stopped. That is, either enqueue or dequeue is still enabled.

Action: Stop the queue first using the STOP_QUEUE command and disable it from both enqueueing and dequeueing.

ORA-24012 cannot drop QUEUE_TABLE, some queues in string have not been dropped

Cause: A queue exists in the queue table which has not been dropped. All queues need to be dropped first.

Action: Drop all queues belonging to this queue table using the DROP_QUEUE() command. Be sure to stop the queues appropriately before dropping them. Alternately, use the force option in DROP_QUEUETABLE.

ORA-24013 invalid value string, RETRY_DELAY should be non-negative

Cause: A negative value was specified for RETRY_DELAY.

Action: Specify a non-negative value for RETRY_DELAY.

ORA-24014 invalid value string, RETENTION_TIME should be FOREVER or non-negative

Cause: Queue retention was specified, but the retention time was specified to be less than zero.

Action: Specify the retention time to be non-negative or FOREVER. Alternately do not specify retention.

ORA-24015 cannot create QUEUE_TABLE, QUEUE_PAYLOAD_TYPE string.string does not exist

Cause: An invalid QUEUE_PAYLOAD_TYPE specified during CREATE_QUEUE_TABLE.

Action: The QUEUE_PAYLOAD_TYPE should be RAW or an object type that already exists in the database.

ORA-24016 cannot create QUEUE_TABLE, user string does not have execute privileges on QUEUE_PAYLOAD_TYPE string.string

Cause: An invalid object type specified for QUEUE_PAYLOAD_TYPE during CREATE_QUEUE_TABLE.

Action: Make sure you have execute privileges on the object type specified for the queue.

ORA-24017 cannot enable enqueue on QUEUE, string is an exception queue

Cause: An attempt was made to enable enqueueing to an exception queue.

Action: No action required.

ORA-24018 STOP_QUEUE on string failed, outstanding transactions found

Cause: There were outstanding transactions on the queue, and WAIT was set to false, so STOP_QUEUE was unsuccessful in stopping the queue.

Action: Set WAIT to TRUE and try STOP_QUEUE again. It will hang till all outstanding transactions are completed.

ORA-24019 identifier for string too long, should not be greater than string characters

Cause: The identifier specified is too long.

Action: Try again with a shorter identifier.

ORA-24020 Internal error in DBMS_AQ_IMPORT_INTERNAL, string

Cause: An internal error occurred in the package. DBMS_AQ_IMPORT_INTERNAL.

Action: Contact Oracle Support Services.

ORA-24021 queue table definition not imported for string.string

Cause: The queue definition is not updated because the queue table was not imported properly.

Action: Import the queue table again.

ORA-24022 the specified parameters has no effect on the queue

Cause: The parameter combination will not cause the queue to be started or stopped.

Action: No action required. This is a warning.

ORA-24023 Internal error in DBMS_AQ_EXP_INTERNAL.string [string] [string]

Cause: An internal error occurred in the package DBMS_AQ_EXP_INTERNAL.

Action: Contact Oracle Support Services.

ORA-24024 Internal error in DBMS_AQ_IMP_INTERNAL.string [string] [string]

Cause: An internal error occurred in the package DBMS_AQ_IMP_INTERNAL.

Action: Contact Oracle Support Services.

ORA-24025 invalid value string, QUEUE_PAYLOAD_TYPE should be RAW or an object type

Cause: Parameter QUEUE_PAYLOAD_TYPE has invalid value.

Action: Specify a valid object type or RAW.

ORA-24026 operation failed, queue string.string has errors

Cause: An attempt was made to enqueue, dequeue or administer a queue which has errors.

Action: Drop the queue table setting the force option to true.

ORA-24027 AQ HTTP propagation encountered error, status-code string, string

Cause: AQ propagation's HTTP request to the propagation servlet at the specified address encountered an error.

Action: Specify a valid address in the connect string of the propagation destination dblink, the dblink user has the correct permissions, check if the AQ propagation servlet was properly installed.

ORA-24028 cannot create a reciever non-repudiable single consumer queue

Cause: Tried to create a reciever non-repudiable single consumer queue.

Action: This feature is not supported.

ORA-24029 operation not allowed on a single-consumer queue

Cause: Tried an operation not allowed on a single-consumer queue.

Action: Specify the operation on a multi-consumer queue.

ORA-24030 Only one of rule or rule-set must be specified

Cause: Specified both a rule and rule-set for the operation.

Action: Specify only one of rule or rule-set.

ORA-24031 invalid value, string should be non-NULL

Cause: Parameter is NULL.

Action: Specify a non-NULL value for the parameter.

ORA-24032 object string exists, index could not be created for queue table string

Cause: Oracle AQ tried to create an index with the name specified in the error message. The index could not be created for the specified queue table because a object exists with the same name.

Action: Drop the object specified in the error message and retry the command. You can also choose a different name for the queue table.

ORA-24033 no recipients for message

Cause: An enqueue was performed on a queue that has been set up for multiple dequeuers but there were neither explicit recipients specified in the call nor were any queue subscribers determined to be recipients for this message.

Action: Either pass a list of recipients in the enqueue call or add subscribers to the queue for receiving this message.

ORA-24034 application string is already a subscriber for queue string

Cause: An application name that was already a subscriber for the queue was specified in the DBMS_AQ.SUBSCRIBE call.

Action: Choose another application name and retry the call.

ORA-24035 AQ agent string is not a subscriber for queue string

Cause: An AQ agent that was not a subscriber for the queue was specified.

Action: Check the name and/or address of the agent and retry the call.

ORA-24036 invalid SORT_ORDER column string specified for queue table

Cause: The CREATE QUEUE TABLE command was issued with MESSAGE_GROUPING set to TRANSACTIONAL and a sort order column other than priority. Only the priority column can be specified in the sort order for queue tables with transactional grouping.

Action: Change the sort order list in the CREATE QUEUE TABLE command and retry the call.

ORA-24037 schema string in QUEUE_NAME is not same as schema string in QUEUE_TABLE

Cause: The schema specified in the QUEUE_NAME parameter of CREATE_QUEUE is not the same as the schema specified in the QUEUE_TABLE parameter.

Action: Use the same schema name for both the QUEUE_NAME and QUEUE_TABLE parameters and retry the command.

ORA-24038 RETRY_DELAY and MAX_RETRIES cannot be used for a 8.0 compatible multiple consumer queue

Cause: The CREATE_QUEUE or ALTER_QUEUE command was issued with a non-zero RETRY_DELAY and a QUEUE_TABLE that was created for multiple consumers and with COMPATIBLE parameter set to '8.0'.

Action: Either set the RETRY_DELAY to zero or upgrade the queue table to 8.1 compatible using the DBMS_AQADM.MIGRATE_QUEUE_TABLE procedure.

ORA-24039 Queue string not created in queue table for multiple consumers

Cause: Either an ADD_SUBSCRIBER, ALTER_SUBSCRIBER, or REMOVE_SUBSCRIBER procedure, or an ENQUEUE with a non-empty recipient list, was issued on a queue that was not created for multiple consumers.

Action: Create the queue in a queue table that was created for multiple consumers and retry the call.

ORA-24041 propagation schedule exists for QUEUE string and DESTINATION string

Cause: A SCHEDULE_PROPAGATION was issued for a queue and destination pair which has an existing propagation schedule.

Action: Issue UNSCHEDULE_PROPAGATION to remove the existing schedule and then reissue the SCHEDULE_PROPAGATION call.

ORA-24042 no propagation schedule exists for QUEUE string and DESTINATION string

Cause: AN UNSCHEDULE_PROPAGATION was issued for a queue and destination pair which has no existing propagation schedule.

Action: Verify the spelling of the specified QUEUE and DESTINATION and then reissue the call with the correct spelling.

ORA-24043 destination string uses a reserved name, names with AQ$_ prefix are not valid

Cause: An attempt was made to specify a reserved name for a destination.

Action: Enter a different value or NULL for the local destination. Then retry the operation.

ORA-24044 source string and destination string object types do not match

Cause: A message recipient's queue has a different object structure than the sender's queue. The message cannot be propagated.

Action: Either remove the recipient from the subscriber's list for the sender's queue or create the destination queue with an object type that matches the source queue's object type.

ORA-24045 invalid agent address string, agent address should be of the form [SCHEMA.]NAME[@DATABASE LINK]

Cause: An invalid value was specified for the agent address parameter.

Action: Specify a string of the form [SCHEMA.]NAME[@DATABASE LINK].

ORA-24046 protocol attribute reserved for future use

Cause: The protocol attribute of the AQ agent object type is reserved for future use.

Action: Do not specify the protocol attribute in the agent object type.

ORA-24047 invalid agent name string, agent name should be of the form NAME

Cause: An invalid value was specified for the agent name parameter.

Action: Specify a string of the form NAME. Then retry the operation.

ORA-24048 cannot create QUEUE_TABLE, user does not have access to AQ object types

Cause: An attempt was made to issue the CREATE_QUEUE_TABLE command, but the user who issued the command does not have access to internal AQ object types.

Action: Use the DBMS_AQADM.GRANT_TYPE_ACCESS procedure to grant the user access to the AQ object types.

ORA-24049 invalid agent name string, names with AQ$_ prefix are not valid

Cause: An attempt was made to use a reserved prefix in the agent name.

Action: Enter a different value for the agent name. Then, retry the operation.

ORA-24050 subscribers are not supported for exception queue string

Cause: An ADD_SUBSCRIBER, ALTER_SUBSCRIBER, or REMOVE_SUBSCRIBER procedure was issued on a queue that was created as an EXCEPTION_QUEUE.

Action: Specify a NORMAL_QUEUE in the procedure.

ORA-24051 cannot propagate object type payloads that have a REF or BFILE attribute

Cause: An ADD_SUBSCRIBER or ENQUEUE procedure with a non-NULL address field in the agent type was issued on a queue whose payload has a REF or BFILE attribute. Propagation of object type payloads that have a REF or BFILE attribute currently is not supported.

Action: Specify an agent with a NULL address field so that the agent can dequeue from the same queue. Or, change the object type definition to one that does not use REF or BFILE attributes.

ORA-24052 cannot propagate object type payloads with LOB attributes to an 8.0 release

Cause: The recipient of a message with LOB attributes was using an Oracle 8.0 release. Propagation of LOB attributes is supported only in Oracle 8.1 and higher releases.

Action: Upgrade the target release to Oracle 8.1 and retry. Or, change the object type definition to one that does not use LOBs.

ORA-24053 PRIMARY_INSTANCE and SECONDARY_INSTANCE must be non-negative

Cause: One of PRIMARY_INSTANCE or SECONDARY_INSTANCE was negative.

Action: Specify non-negative integers for PRIMARY_INSTANCE and SECONDARY_INSTANCE.

ORA-24054 cannot propagate to an Oracle 8.0.3 release or lower release

Cause: The recipient of a message was using an Oracle 8.0.3 release or lower release. Propagation is supported only in Oracle 8.0.4 and higher releases.

Action: Upgrade the target release to Oracle 8.0.4 or higher and retry.

ORA-24055 cannot delete propagation status rows that are in prepared state

Cause: An attempt was made to use the internal administration procedure to delete status rows from the SYS.AQ$_PROPAGATION_STATUS table that were in the prepared state.

Action: Wait for the propagation to complete successfully before retrying the operation.

ORA-24056 internal inconsistency for QUEUE string and destination string

Cause: The sequence numbers used in the SYS.AQ$_PROPAGATION_STATUS table were inconsistent for the given queue and destination.

Action: Contact Oracle Support Services.

ORA-24057 cannot define subscriber with rule for queue string

Cause: An ADD_SUBSCRIBER or ALTER_SUBSCRIBER procedure with a rule was issued on a queue for which rule based subscribers are not supported. Rule based subscribers currently are supported only for NORMAL (persistent) multi-consumer queues created using an Oracle release 8.1.0 or higher compatible queue table.

Action: Create a NORMAL multi-consumer queue in an Oracle release 8.1.0 or higher compatible queue table, and retry the call. Or, if the queue is a normal (persistent) multi-consumer queue, convert the queue table to Oracle 8.1.0 or higher compatibility and retry.

ORA-24058 cannot downgrade QUEUE_TABLE that has propagation in a prepared state

Cause: An attempt was made to downgrade the queue table when there were messages being propagated that were in the prepared state.

Action: Wait for the propagation to complete before retrying the operation.

ORA-24059 invalid COMPATIBLE parameter setting string specified in DBMS_AQADM.string

Cause: An invalid compatible parameter was specified in the DBMS_AQADM procedure. The parameter setting must be of the form '8.x.y' where x is the release number and y is the update number.

Action: Specify a valid COMPATIBLE parameter setting, and retry the operation.

ORA-24060 cannot convert QUEUE_TABLE, string already is compatible with release string

Cause: The source queue table in the DBMS_AQADM procedure is compatible with the specified COMPATIBLE parameter setting.

Action: Choose a different COMPATIBLE parameter setting to convert the queue table to the desired compatibility.

ORA-24061 cannot specify non-zero SECONDARY_INSTANCE if PRIMARY_INSTANCE was zero

Cause: A non-zero value was specified for SECONDARY_INSTANCE when PRIMARY_INSTANCE was zero.

Action: Specify a non-zero primary instance before you specify a non-zero secondary instance.

ORA-24062 Subscriber table string inconsistent with queue table string

Cause: The subscriber table has not yet been successfully imported.

Action: Import the subscriber table before attempting to use the queue table. If the import failed, correct the problem and try to import the subscriber table again.

ORA-24063 cannot downgrade QUEUE_TABLE that has queues with rule-based subscribers

Cause: An attempt was made to downgrade the queue table when there were queues on which rule-based subscribers are defined.

Action: Remove the rule-based subscribers for all queues in this queue table and retry.

ORA-24064 propagation for QUEUE string and DESTINATION string already enabled

Cause: An ENABLE_SCHEDULE_PROPAGATION command was issued for a queue and destination pair whose propagation schedule already was enabled.

Action: Make sure the QUEUE and DESTINATION are correct when you issue the ENABLE_SCHEDULE_PROPAGATION command.

ORA-24065 propagation for QUEUE string and DESTINATION string already disabled

Cause: A DISABLE_SCHEDULE_PROPAGATION command was issued for a queue and destination pair whose propagation schedule already was disabled.

Action: Make sure the QUEUE and DESTINATION are correct when you issue the DISABLE_SCHEDULE_PROPAGATION command.

ORA-24066 invalid privilege specified

Cause: An invalid privilege is specified for granting or revoking privilege.

Action: Specify a valid privilege.

ORA-24067 exceeded maximum number of subscribers for queue string

Cause: An attempt was made to add new subscribers to the specified, but the number of subscribers for this queue has exceeded the maximum number (1024) of subscribers allowed per queue.

Action: Remove existing subscribers before trying to add new subscribers.

ORA-24068 cannot start queue string, queue table string is being migrated

Cause: An attempt was made to start a queue in a queue table that is being migrated.

Action: Complete the queue table migration, and retry the operation.

ORA-24069 cannot downgrade queue table string while it is being upgraded

Cause: An attempt was made to downgrade a queue table, but a previous command to upgrade the queue table has not yet completed successfully.

Action: Complete the upgrade of the queue table by re-executing the DBMS_AQADM.MIGRATE_QUEUE_TABLE procedure. Then, downgrade the queue table.

ORA-24070 cannot upgrade queue table string while it is being downgraded

Cause: An attempt was made to upgrade a queue table, but a previous command to downgrade the queue table has not yet completed successfully.

Action: Complete the downgrade of the queue table by re-executing the DBMS_AQADM.MIGRATE_QUEUE_TABLE procedure. Then, upgrade the queue table.

ORA-24071 cannot perform operation string, queue table string is being migrated

Cause: An attempt was made to perform an operation on a queue in a queue table that is being migrated.

Action: Complete the queue table migration, and retry the operation.

ORA-24072 cannot execute MIGRATE_QUEUE_TABLE procedure; must own queue table

Cause: An attempt was made to upgrade or downgrade a queue table using the DBMS_AQADM.MIGRATE_QUEUE_TABLE procedure, but the user who executed the procedure does not own the queue.

Action: Reconnect as the owner of the queue table, and then execute the DBMS_AQADM.MIGRATE_QUEUE_TABLE procedure.

ORA-24073 cannot specify RETENTION_TIME on exception queue string.string

Cause: An attempt was made to create or alter an exception queue by specifying a non-zero RETENTION_TIME.

Action: Use the default RETENTION_TIME parameter value for exception queues.

ORA-24074 RETRY_DELAY and MAX_RETRIES cannot be used for exception queue string

Cause: The CREATE_QUEUE or ALTER_QUEUE command was issued with a non-zero RETRY_DELAY and an exception queue.

Action: Do not specify RETRY_DELAY or MAX_RETRIES for exception queues.

ORA-24075 cannot specify agent with NULL address and non-NULL protocol

Cause: An ADD_SUBSCRIBER or enqueue was attempted with an agent that had a NULL address and a non-NULL protocol.

Action: Either specify a non-NULL address or set the protocol to NULL.

ORA-24076 cannot perform operation string for NON_PERSISTENT queue string.string

Cause: One of the operations, SCHEDULE_PROPAGATION, ALTER_QUEUE, LISTEN, DEQUEUE was issued for a NON_PERSISTENT queue.

Action: Do not specify a NON_PERSISTENT queue for these operations.

ORA-24077 cannot create propagation schedule for EXCEPTION queue string.string

Cause: A SCHEDULE_PROPAGATION was issued for an EXCEPTION queue. Propagation schedules can be created only for NORMAL queues.

Action: To propagate messages from a queue, specify the queue type as NORMAL.

ORA-24078 cannot specify a non-NULL SECONDARY_INSTANCE if PRIMARY_INSTANCE was NULL

Cause: A non-NULL value was specified for SECONDARY_INSTANCE when PRIMARY_INSTANCE was NULL.

Action: Specify a non-NULL primary instance before you specify a non-NULL secondary instance.

ORA-24079 invalid name string, names with AQ$_ prefix are not valid for string

Cause: An attempt was made to use a reserved prefix for the object name.

Action: Enter a different name for this object. Then, retry the operation.

ORA-24080 unschedule_propagation pending for QUEUE string and DESTINATION string

Cause: A propagation administration command was issued for a queue and destination pair whose propagation is being unscheduled.

Action: Do not issue propagation administration commands for a propagation schedule on which there is a pending unschedule request.

ORA-24081 compatible parameter needs to be string or greater

Cause: The value of the COMPATIBLE parameter was not high enough to allow the operation.

Action: Shut down and restart with a higher compatibility setting.

ORA-24082 propagation may still be happening for the schedule for QUEUE string and DESTINATION string

Cause: The snapshot process executing the propagation schedule did not respond to the disable propagation command.

Action: Make sure that the job for the propagation schedule has been ended.

ORA-24083 cannot specify remote subscribers for string QUEUE string

Cause: An ADD_SUBSCRIBER call with a non-null address field was issued on a queue which does not support remote subscribers. Remote subscribers are not supported for NON_PERSISTENT QUEUES.

Action: Specify a null address field and retry the call.

ORA-24084 DBLINK name in address field of agent string is not unique within the first 24 bytes"

Cause: Advanced Queuing requires that the agent's DBLINK name should be unique within the first 24 bytes (for 8.0 compatible queue tables)

Action: Specify a DBLINK name that is unique within the first 24 bytes or migrate to 8.1 compatible queue tables where this restriction is not there.

ORA-24085 operation failed, queue string is invalid

Cause: An attempt was made to enqueue, dequeue or administer a queue which is invalid. This could have occurred because the payload type of the queue's queue table was dropped.

Action: Drop the queue table setting the force option to true.

ORA-24086 cannot create an 8.0 compatible string queue

Cause: An attempt was made to create an 8.0 compatible queue table and enable a feature that is supported only on 8.1 style queue tables.

Action: This feature is not supported.

ORA-24087 Invalid database user string

Cause: An invalid database username was specified.

Action: Specify a valid database user.

ORA-24088 AQ Agent string does not exist

Cause: This AQ Agent does not exist.

Action: Specify a valid AQ agent. Check the DBA_AQ_AGENTS view for a list of valid aq agents.

ORA-24089 AQ Agent string already exists

Cause: This AQ agent has already been created.

Action: Specify another agent name or use the ALTER api to modify the agent.

ORA-24090 at least one protocol must be enabled

Cause: No protocol was enabled for aq agent.

Action: Enable one of the protocols by setting one of the enable parameters to true.

ORA-24093 AQ agent string not granted privileges of database user string

Cause: The specified AQ agent does not have privileges of the specified database user.

Action: Specify a valid combination of AQ agent and database user. Check the DBA_AQ_AGENT_PRIVS or USER_AQ_AGENT_PRIVS view for user/agent mappings.

ORA-24094 invalid transformation, target type does not match that of the queue

Cause: The target type of the transformation specified was different from the type of the queue.

Action: Provide a valid transformation whose target type is the same as the queue type.

ORA-24095 invalid transformation, source type does not match that of the queue

Cause: The source type of the transformation specified was different from the type of the queue.

Action: Provide a valid transformation whose source type is the same as the queue type.

ORA-24096 invalid message state specified

Cause: Invalid value was specified for message state.

Action: Provide a valid message state as specified in the documentation.

ORA-24097 Invalid value string, string should be non-negative

Cause: A negative value or NULL was specified for the parameter.

Action: Specify a non-negative integer.

ORA-24098 invalid value string for string

Cause: An Invalid value or NULL was specified for the parameter.

Action: Check the documentation for valid values.

ORA-24099 operation not allowed for 8.0 compatible queues

Cause: The specified operation is only supported for queues with compatibility equal to 8.1 or higher.

Action: Upgrade the 8.0 compatible queue to release 8.1 using DBMS_AQADM.MIGRATE_QUEUE_TABLE or specify a queue with compatibility euqal to 8.1 or higher.

ORA-24100 error in ktz testing layer

Cause: There is an error in the Transaction layer test ICDs.

ORA-24120 invalid string parameter passed to DBMS_REPAIR.string procedure

Cause: An invalid parameter was passed to the specified DBMS_REPAIR procedure.

Action: Specify a valid parameter value or use the parameter's default.

ORA-24121 both cascade and a block range passed to DBMS_REPAIR.CHECK_OBJECT procedure

Cause: Both cascade and a block range were specified in a call to DBMS_REPAIR.CHECK_OBJECT.

Action: Use either cascade or a block range, or do not use either one.

ORA-24122 invalid block range specification

Cause: An incorrect block range was specified.

Action: Specify correct values for the BLOCK_START and BLOCK_END parameters.

ORA-24123 feature string is not yet implemented

Cause: An attempt was made to use the specified feature, but the feature is not yet implemented.

Action: Do not attempt to use the feature.

ORA-24124 invalid ACTION parameter passed to DBMS_REPAIR.string procedure

Cause: An invalid ACTION parameter was specified.

Action: Specify CREATE_ACTION, PURGE_ACTION or DROP_ACTION for the ACTION parameter.

ORA-24125 Object string.string has changed

Cause: An attempt was made to fix corrupt blocks on an object that has been dropped or truncated since DBMS_REPAIR.CHECK_OBJECT was run.

Action: Use DBMS_REPAIR.ADMIN_TABLES to purge the repair table and run DBMS_REPAIR.CHECK_OBJECT to determine whether there are any corrupt blocks to be fixed.

ORA-24126 invalid CASCADE_FLAG passed to DBMS_REPAIR.string procedure

Cause: CASCADE_FLAG was specified for an object that is not a table.

Action: Use CASCADE_FLAG only for tables.

ORA-24127 TABLESPACE parameter specified with an ACTION other than CREATE_ACTION

Cause: The TABLESPACE parameter can only be used with CREATE_ACTION.

Action: Do not specify TABLESPACE when performing actions other than CREATE_ACTION.

ORA-24128 partition name specified for a non-partitioned object

Cause: A partition name was specified for an object that is not partitioned.

Action: Specify a partition name only if the object is partitioned.

ORA-24129 table name string does not start with string prefix

Cause: An attempt was made to pass a table name parameter without the specified prefix.

Action: Pass a valid table name parameter.

ORA-24130 table string does not exist

Cause: An attempt was made to specify a map, repair, or sync table that does not exist.

Action: Specify a valid table name parameter.

ORA-24131 table string has incorrect columns

Cause: An attempt was made to specify a map, repair, or sync table that does not have a correct definition.

Action: Specify a table name that refers to a properly created table.

ORA-24132 table name string is too long

Cause: An attempt was made to specify a table name is greater than 30 characters long.

Action: Specify a valid table name parameter.

ORA-24141 rule set string.string does not exist

Cause: An attempt to access or modify a ruleset was made, which failed because the ruleset does not exist.

Action: Only access or modify existing rulesets.

ORA-24142 invalid ruleset name

Cause: An attempt to create a ruleset with an invalid name was made. The ruleset name cannot be NULL, and cannot be more than 26 characters, unless a RULES_TABLE_NAME is also specified, in which case the ruleset name may be up to 30 characters.

Action: Retry the create with a valid ruleset name.

ORA-24143 invalid evaluation context name

Cause: An attempt to create a rule/ruleset on an invalid evaluation name was made. The evaluation_context can not be more than 30 characters. The evaluation context with the name specified must exist.

Action: Retry the create with a valid evaluation context name.

ORA-24144 rules engine internal error, arguments: [string], [string]

Cause: An internal error occurred in the rules engine. This indicates that the rules engine has encountered an exception condition.

Action: Contact Oracle Support Services. The first argument is the error and the second argument is the package.

ORA-24145 evaluation context string.string already exists

Cause: An evaluation context of the given name already exists.

Action: Specify another name for the evaluation context being created.

ORA-24146 rule string.string already exists

Cause: A rule of the given name already exists.

Action: Specify another name for the rule being created.

ORA-24147 rule string.string does not exist

Cause: The rule of the given name does not exist.

Action: Create the rule or specify one that exists.

ORA-24148 cannot drop rule string.string with dependents

Cause: The rule still belongs to some rulesets, cannot be dropped.

Action: Do not drop a rule that belongs to rulesets without force option.

ORA-24149 invalid rule name

Cause: An attempt to create a rule with an invalid name was made.

Action: The rule name can not be NULL, and can not be more than 30 characters.

ORA-24150 evaluation context string.string does not exist

Cause: The evaluation context of the given name does not exist.

Action: Create the evaluation context or specify one that exists.

ORA-24151 no evaluation context is associated with rule string.string or rule set string.string

Cause: When adding a rule to a rule set, either the rule or the rule set must have an evaluation context associated with it.

Action: Do not add a rule without an evaluation context to a ruleset that does not have a default evaluation context.

ORA-24152 cannot drop evaluation context string.string with dependents

Cause: The evaluation context still belongs to some rules or rule sets, cannot be dropped.

Action: Do not drop an evaluation context with dependents without force option.

ORA-24153 rule set string.string already exists

Cause: A rule set of the given name already exists.

Action: Specify another name for the rule set being created.

ORA-24154 rule string.string already in rule set string.string

Cause: A rule can be added to a rule set only once.

Action: Do not add a rule to a rule set that already contains this rule.

ORA-24155 rule string.string not in rule set string.string

Cause: The rule to be removed from the rule set is not in the rule set.

Action: Do not remove a rule from a rule set that does not contain the rule.

ORA-24156 duplicate table alias string

Cause: There is a table alias of the same name in the evaluation context.

Action: Do not add two table aliases of the same name to an evaluation context.

ORA-24157 duplicate variable name string

Cause: There is a variable of the same name in the evaluation context.

Action: Do not add two variables of the same name to an evaluation context.

ORA-24158 invalid table alias

Cause: Table alias name or base table name is not specified in the table alias definition.

Action: Specify both alias name and alias base table in the table alias structure.

ORA-24159 invalid variable definition

Cause: Variable name or variable type is not specified in the variable definition.

Action: Specify both variable name and variable type in the variable definition structure.

ORA-24160 name string already exists in the name value pair list

Cause: There is already a name-value pair with the same name in the NVlist.

Action: Try another name.

ORA-24161 name string does not exist in the name value pair list

Cause: There is not such a name-value pair in the NVlist.

Action: Check that the name-value pair exists in the NVList.

ORA-24162 name value pair list is full, cannot add another entry

Cause: The NVList is full (1024 elements) and cannot hold more elements.

Action: Do not add elements to a full list.

ORA-24163 dblink is not supported in rules engine DDLs

Cause: The object name has a database link in it, which is not supported.

Action: Do not specify remote objects in rules engine DDLs.

ORA-24164 invalid rule engine system privilege: string

Cause: No such system privilege number for rule engine objects.

Action: Check specification of dbms_rule_adm for valid system privilege numbers.

ORA-24165 invalid rule engine object privilege: string

Cause: No such object privilege number for rule engine objects.

Action: Check specification of dbms_rule_adm for valid object privilege numbers.

ORA-24166 evaluation context string.string has errors

Cause: Cannot resolve the table aliases and the variable types specified in the evaluation context.

Action: Make sure all base tables exist and all variable types are correct.

Action: ORA-24167 incompatible rule engine objects, cannot downgrade

Cause: There are rule engine objects in the database that cannot be downgraded.

Action: Check utlincmp.sql and remove all incompatible rules engine objects before downgrading.

ORA-24168 rule string.string cannot have default evaluation context

Cause: If a rule is added to a rule set with more than one evaluation context, then it must not have an evaluation context itself.

Action: Do not set the evaluation context of such rules to a non-null value.

ORA-24169 rule condition has unrecognized variables

Cause: The rule references variables not in the evaluation context.

Action: Modify the rule condition to remove illegal reference.

ORA-24180 invalid transformation expression, the transformation expression does not evaluate to the target type/attribute

Cause: The transformation expression does not evaluate to the target type or the target type's specified attribute.

Action: Provide valid transformation expression which evaluates to the target type or the target type's specified attribute.

ORA-24181 The type string does not exist

Cause: The source or destination type for the transformation does not exist

Action: Create the type or specify one that exists.

ORA-24182 attribute number specified does not exist

Cause: The target type of the transformation does not have the attribute number specified in the ADD_ATTRIBUTE_TRANSFORMATION command.

Action: check the target type definition and specify a valid attribute number.

ORA-24183 invalid transformation

Cause: The transformation specified is invalid because the source or the target type have been dropped/modified.

Action: Drop and recreate the transformation.

ORA-24184 transformation string.string, already exists

Cause: A transformation of the given name already exists.

Action: Specify another name for the transformation being created.

ORA-24185 Transformation string.string, does not exist

Cause: The transformation being specified does not exist.

Action: Create the transformation before using it or specify an existing transformation.

ORA-24186 wrong object type, could not transform message

Cause: The object type of the message to be transformed does not match the source type of the specified transfomation.

Action: Specify another transformation or specify a message of the correct type.

ORA-24190 length of payload excceeds string

Cause: The length of payload being taken excceeds the limit of varchar2 or raw.

Action: Use clob type or blob type to call get_text or get_bytes.

ORA-24191 the property name string has existed

Cause: The property name being set has existed.

Action: Use another property name.

ORA-24192 the property name cannot be null

Cause: The property name cannot be null.

Action: Make sure the property name is not null.

ORA-24193 the property value exceeds the valid range string

Cause: The property values being set exceeds the valid range.

Action: Make sure the property value is within the valid range.

ORA-24201 duplicate publisher, publisher already added to the queue

Cause: Attempted to add a publisher to the queue again.

Action: Specify another publisher or use DBMS_AQADM.ALTER_PUBLISHER to alter the publisher's properties.

ORA-24202 publisher does not exist for the queue

Cause: Attempted to alter or drop a non existent publisher from a queue.

Action: Specify another publisher.

ORA-24270 a row already exists in the string table for these parameters

Cause: A call was made to create a new row in the specified table. A row already exists in the table with the specified values.

Action: Delete the existing row using the appropriate API or check the parameters used to create the row.

ORA-24271 translation type must be either T, S or M

Cause: The translation type parameter is not a T, S or an M. A value other than T, S or M was specified.

Action: Correct the translation type and re-execute the API call.

ORA-24272 initialization value must be either F or T

Cause: The initialization value must be either F or T. A value other than F or T was specified.

Action: Correct the initialization value and re-execute the API call.

ORA-24273 translation text is required if translation type is T or S

Cause: If a translation type of T or S is specified, translation text must be supplied.

Action: Provide translation text and re-execute the API call.

ORA-24274 no row exists in the string table for these parameters

Cause: A call was made to update a row that does not exist or a foreign key value supplied to create a table does not exist.

Action: Create the row using the appropriate API or check the parameters used to create the new row to ensure that all specified values exist.

ORA-24275 function 'string' parameter 'string' missing or invalid

Cause: The function pkgname.funcname was called with a parameter parmname that was null, 0 length, or had an invalid value.

Action: Correct the parameter to supply values that comply with its datatype and limits as specified in the documentation.

ORA-24276 function 'string' output 'string' maximum value exceeded

Cause: The function pkgname.funcname computed a value for the output parmname that exceeded the maximum allowed. This can occur when multiple input parameters, each valid separately, combine to specify an invalid result. For example, when a length parameter multiplied by a copies parameter yields a total length exceeding the maximum for the output datatype.

Action: Correct the input values to produce a result that will comply with the limits as specified in the documentation.


ORA-24280 to ORA-29249

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

13
ORA-24280 to ORA-29249

ORA-24280 invalid input value for parameter string

Cause: The parameter has been provided a negative, out of range, or NULL input value.

Action: Correct the input value such that it is valid, and is within the range as specified in the documentation.

ORA-24281 invalid access past the maximum size of LOB parameter string

Cause: The value of positional or size parameters exceeds the maximum allowed LOB size of 4 Gigabytes.

Action: Correct the input values for amount and offset such that their sum is less than or equal to 4 Gigabytes. If error occurs in a read or write loop, check the looping conditions and/or offset increments.

ORA-24300 bad value for mode

Cause: An undefined mode value was specified.

Action: Check that the correct mode is selected and that an allowed value for that mode is specified.

ORA-24301 null host specified in thread-safe logon

Cause: An HDA was not specified in the logon call while running in a thread safe environment.

Action: Make sure that HDA is not NULL when calling the logon routine.

ORA-24302 host connection in use by another thread

Cause: An attempt was made to use the host connection while it was in use by another thread.

Action: Wait for another thread to finish before using this connection.

ORA-24303 call not supported in non-deferred linkage

Cause: One of the calls that is supported in deferred mode linkage exclusively was invoked when the client was linked non-deferred.

Action: Use this call in deferred mode of linkage.

ORA-24304 datatype not allowed for this call

Cause: Data of this datatype cannot be sent or fetched in pieces.

Action: Use other bind or define calls for this datatype.

ORA-24305 bad bind or define context

Cause: The call was executed on a cursor for which this is invalid.

Action: Verify that this call is valid for this cursor. For example, Get piece information and set piece information are valid on a cursor if appropriate binds and defines have been done on this cursor.

ORA-24306 bad buffer for piece

Cause: A zero length buffer or a null buffer pointer was provided.

Action: Verify that the buffer pointing to this piece or its length is non-zero. The buffer pointer for the next piece or its length can be zero if it is the last piece to be inserted and there are no more data for the column.

ORA-24307 invalid length for piece

Cause: The length of the piece exceeded the maximum possible size.

Action: Verify that the length of this piece and the cumulative length of all the previous pieces is not more than the desired value supplied by the application.

ORA-24308 illegal define position

Cause: Call to modify attributes was done for a non-existent position.

Action: Verify that a define has been done for this position.

ORA-24309 already connected to a server

Cause: This server handle is already attached to a server.

Action: Disconnect from the server and then retry the call to establish a connection.

ORA-24310 length specified for null connect string

Cause: The connect string is null, but a length was specified for it.

Action: Set length to zero if connect string is null.

ORA-24311 memory initialization failed

Cause: Cannot initialize user memory.

Action: Contact Oracle Support Services.

ORA-24312 illegal parameters specified for allocating user memory

Cause: An illegal size or null pointer was specified for user memory.

Action: Specify a legal size and a valid pointer for user memory.

ORA-24313 user already authenticated

Cause: A user has already been authenticated on this service handle.

Action: Terminate the service context before using it for another user.

ORA-24314 service handle not initialized

Cause: The server context does not done exist.

Action: Establish the server context in the service context.

ORA-24315 illegal attribute type

Cause: An illegal attribute type was specified for the handle.

Action: Consult the Oracle Call Interface Programmer's Guide to specify an attribute valid for this handle.

ORA-24316 illegal handle type

Cause: An illegal handle type was specified.

Action: Consult the Oracle Call Interface Programmer's Guide to specify a valid handle type.

ORA-24317 define handle used in a different position

Cause: A define was done with an existing handle on a different position.

Action: Specify the same position as before on a redefine.

ORA-24318 call not allowed for scalar data types

Cause: This call is valid only for object types.

Action: Verify that the data-type for this variable is an object type.

ORA-24319 unable to allocate memory

Cause: Process was unable to allocate memory to store diagnostics.

Action: Terminate other processes in order to reclaim needed memory.

ORA-24320 unable to initialize a mutex

Cause: An attempt to initialize a MUTEX failed.

Action: Contact Oracle Support Services.

ORA-24321 inconsistent parameters passed

Cause: One of the three memory function pointers is null or non-null.

Action: Verify that either all the memory functions are null or non-null.

ORA-24322 unable to delete an initialized mutex

Cause: An attempt to delete an initialized MUTEX failed.

Action: Contact Oracle Support Services.

ORA-24323 value not allowed

Cause: A null or invalid value was passed in for a mandatory parameter.

Action: Verify that all mandatory parameters are properly initialized.

ORA-24324 service handle not initialized

Cause: An attempt was made to use an improper service context handle.

Action: Verify that the service context handle has all the parameters initialized prior to this call.

ORA-24325 this OCI operation is not currently allowed

Cause: An attempt was made to use a context handle outside its scope.

Action: Verify that the context handle is set to a service context handle that has been converted to a logon data area for other OCI calls. The logon data area must be converted back to a service context before it can be used.

ORA-24326 handle passed in is already initialized

Cause: An attempt was made to pass an initialized handle.

Action: Verify that the parameter passed in to retrieve a handle does not already point to a handle.

ORA-24327 need explicit attach before authenticating a user

Cause: A server context must be initialized before creating a session.

Action: Create and initialize a server handle.

ORA-24328 illegal attribute value

Cause: The attribute value passed in is illegal.

Action: Consult the Oracle Call Interface Programmer's Guide and specify a legal attribute value for the handle.

ORA-24329 invalid character set identifier

Cause: The character set identifier specified is invalid.

Action: Specify a valid character set identifier in the OCI call.

ORA-24330 internal OCI error

Cause: An internal OCI error has occurred.

Action: Contact Oracle Support Services.

ORA-24331 user buffer too small

Cause: The user buffer to contain the output data is too small.

Action: Specify a bigger buffer.

ORA-24332 invalid object type

Cause: An invalid object type is requested for the describe call.

Action: Specify a valid object type to the describe call.

ORA-24333 zero iteration count

Cause: An iteration count of zero was specified for the statement.

Action: Specify the number of times this statement must be executed.

ORA-24334 no descriptor for this position

Cause: The application is trying to get a descriptor from a handle for an illegal position.

Action: Check the position number.

ORA-24335 cannot support more than 1000 columns

Cause: The number of columns exceeds the maximum number supported.

Action: Specify a number of columns less than 1000.

ORA-24336 invalid result set descriptor

Cause: The result set descriptor should have valid data fetched into it before it can be converted to a statement handle.

Action: Fetch valid data into the descriptor before attempting to convert it into a statement handle.

ORA-24337 statement handle not prepared

Cause: A statement cannot be executed before making preparing a request.

Action: Prepare a statement before attempting to execute it.

ORA-24338 statement handle not executed

Cause: A fetch or describe was attempted before executing a statement handle.

Action: Execute a statement and then fetch or describe the data.

ORA-24339 cannot set server group name after connecting to server

Cause: An attempt was made to set the server group in a server handle after connecting to the server. However, once the connection is established to a server, the server group name cannot be set anymore.

Action: Attach to the server after setting the server group name in the server handle.

ORA-24340 cannot support more than 255 columns

Cause: The number of columns exceeds maximum supported by the server.

Action: Limit your operation to 255 columns.

ORA-24341 bad mode specified

Cause: OCI_ENV_NO_MUTEX mode was specified for a non-threaded client.

Action: OCI_ENV_NO_MUTEX may be specified when OCI_THREADED had been specified at process initialization.

ORA-24342 unable to destroy a mutex

Cause: An attempt to destroy a MUTEX failed.

Action: Contact Oracle Support Services.

ORA-24343 user defined callback error

Cause: The only valid return value for a user defined callback function is OCI_CONTINUE. Any other value will cause this error.

Action: Make sure that OCI_CONTINUE is returned from the user-defined callback function.

ORA-24344 success with compilation error

Cause: A SQL or PL/SQL compilation error occurred.

Action: Return OCI_SUCCESS_WITH_INFO along with the error code.

ORA-24345 A Truncation or null fetch error occurred

Cause: A truncation or a null fetch error.

Action: Make sure that the buffer size is long enough to store the returned data.

ORA-24346 cannot execute without binding variables

Cause: None of the bind variables in the SQL statement are bound.

Action: Bind all the variables before the execute is done.

ORA-24347 Warning of a NULL column in an aggregate function

Cause: A null column was processed by an aggregate function.

Action: An OCI_SUCCESS_WITH_INFO is returned.

ORA-24348 Update or Delete without Where

Cause: An UPDATE or DELETE was executed without a WHERE clause.

Action: An OCI_SUCCESS_WITH_INFO is returned.

ORA-24350 OCI call not allowed

Cause: OCI used is not permitted from external procedures.

Action: Refer to the Oracle Call Interface Programmer's Guide for usage restrictions.

ORA-24351 invalid date passed into OCI call

Cause: A bad date was passed into one of the OCI calls.

Action: Check your date bind values and correct them.

ORA-24352 invalid COBOL display type passed into OCI call

Cause: A bad COBOL display type was passed into one of the OCI calls.

Action: Check your COBOL display type bind values and correct them.

ORA-24353 user buffer too small to accommodate COBOL display type

Cause: User supplied buffer for a COBOL display type was too small to accommodate fetched number.

Action: Increase the allocation for COBOL display type buffer.

ORA-24354 number fetched too large to fit in COBOL display type buffer.

Cause: The number fetched was beyond the range that can be displayed.

Action: Check the number in the database.

ORA-24355 attempt to store a negative number in an Unsigned Display type.

Cause: An attempt was made to convert a negative number into an unsigned display type.

Action: Check the number in the database or change the defined datatype.

ORA-24356 internal error while converting from to COBOL display type.

Cause: An internal error was encountered during conversion to COBOL display type.

Action: Contact Oracle Support Services.

ORA-24357 internal error while converting from to OCIDate.

Cause: An internal error was encountered during conversion to OCIDate type.

Action: Contact Oracle Support Services.

ORA-24358 OCIBindObject not invoked for a Object type or Reference

Cause: OCIBindObject was not invoked resulting in an incomplete bind specification for a Object Type or Reference.

Action: Invoke the OCIBindObject call for all Object Types and References.

ORA-24359 OCIDefineObject not invoked for a Object type or Reference

Cause: OCIDefineObject was not invoked resulting in an incomplete bind specification for a Object Type or Reference.

Action: Invoke the OCIDefineObject call for all Object Types and References.

ORA-24360 Type Descriptor Object not specified for Object Bind/Define

Cause: Type Descriptor Object is a mandatory parameter for Object Types Binds and Defines.

Action: Invoke the OCIBindObject() or OCIDefineObject() call with a valid Type Descriptor Object.

ORA-24361 basic bind call not invoked before invoking advanced bind call

Cause: One of the basic bind calls was not invoked on this bind handle before performing an advanced bind call.

Action: Invoke the advanced bind call on this bind handle only after performing a basic bind call.

ORA-24362 improper use of the character count flag

Cause: When the character count flag is set, then the maximum size of the buffer in the server should be specified as a non-zero value.

Action: Use a non-zero value for the maximum size of the buffer in the server.

ORA-24363 measurements in characters illegal here

Cause: Measurements in characters instead of bytes are illegal if either the server's or client's character set is varying width.

Action: If either the client's or server's character set is varying width then do not use the OCI_ATTR_CHAR_COUNT attribute for the bind handle. Use OCI_ATTR_MAXDATA_SIZE instead.

ORA-24364 internal error while padding blanks

Cause: An internal error has occurred while attempting to blank pad string data. This error should not occur normally.

Action: Contact Oracle Support Services.

ORA-24365 error in character conversion

Cause: This usually occurs during conversion of a multibyte character data when the source data is abnormally terminated in the middle of a multibyte character.

Action: Make sure that all multibyte character data is properly terminated.

ORA-24366 migratable user handle is set in service handle

Cause: This occurs during user authentication, a migratable user handle has been set in the service handle.

Action: Service handle must not be set with migratable user handle when it is used to authenticate another user.

ORA-24367 user handle has not been set in service handle

Cause: This occurs during authentication of a migratable user. the service handle has not been set with non-migratable user handle.

Action: Service handle must be set with non-migratable user handle when it is used to authenticate a migratable user.

ORA-24368 OCI mutex counter non-zero when freeing a handle

Cause: This is an internal OCI error.

Action: Contact Oracle Support Services.

ORA-24369 required callbacks not registered for one or more bind handles

Cause: No callbacks have been registered for one or more of the bind handles which are part of the RETURNING clause.

Action: The bind handles which are to receive data in a DML statement with a RETURNING clause must have their mode set as DATA_AT_EXEC and callback functions must be registered for these bind handles using OCIBindDynamic.

ORA-24370 illegal piecewise operation attempted

Cause: Data of a certain datatype that does not support piecewise operation is being sent or fetched in pieces.

Action: Always set the piece value to OCI_ONE_PIECE for datatypes that does not support piecewise operation.

ORA-24371 data would not fit in current prefetch buffer

Cause: An internal OCI error has occurred.

Action: Contact Oracle Support Services.

ORA-24372 invalid object for describe

Cause: The object to be described is not valid. It either has compilation or authorization errors.

Action: The object to be described must be valid.

ORA-24373 invalid length specified for statement

Cause: The length specified for the statement is either 0 or too large.

Action: Specify a valid length for the statement.

ORA-24374 define not done before fetch or execute and fetch

Cause: The application did not define output variables for data being fetched before issuing a fetch call or invoking a fetch by specifying a non-zero row count in an execute call.

Action: Issue OCI define calls for the columns to be fetched.

ORA-24375 Cannot use V6 syntax when talking to a V8 server

Cause: V6 syntax is no longer supported in V8 server.

Action: Change syntax to V7 syntax or higher.

ORA-24376 cannot register/get user callback for non-environment handle

Cause: A user callback registration or get was attempted on a handle which is not an environment handle.

Action: Pass the environment handle to register/get user callback.

ORA-24377 invalid OCI function code

Cause: An invalid function code was used to register or get user callback.

Action: Use a valid OCI function code.

ORA-24378 user callbacks not allowed for this call

Cause: An attempt was made to register a user callback for an OCI call for which it not allowed to register user callbacks.

Action: Do not register user callback for this OCI call.

ORA-24379 invalid user callback type

Cause: An invalid type of user callback was specified.

Action: Specify a valid user callback type.

ORA-24380 invalid mode specification

Cause: The mode parameter in an OCIU* call is invalid.

Action: Use only a valid mode parameter.

ORA-24381 error(s) in array DML

Cause: One or more rows failed in the DML.

Action: Refer to the error stack in the error handle.

ORA-24382 statement handled already executed or described

Cause: The statement handle was executed or described successfully before.

Action: Perform a OCIStmtPrepare again before OCI_PARSE_ONLY.

ORA-24383 Overflow segment of an IOT cannot be described

Cause: The name specified in the OCIDescribeAny call referred to an IOT overflow segment.

Action: Use OCIDescribeAny to describe only documented objects.

ORA-24384 Application context size is not initialized

Cause: The size of the application context must be initialized before populating each context element.

Action: Issue OCIAttrSet with OCI_ATTR_CTX_SIZE to initialize context size.

ORA-24385 Application context size or index is not valid

Cause: The size or index of the application context must be non-zero and non-negative.

Action: Use an appropriate value for the size.

ORA-24386 statement/server handle is in use when being freed

Cause: This is an internal OCI error.

Action: The user should reset in-use flag in statement handle before freeing the handle.

ORA-24387 Invalid attach driver

Cause: Trying to attach using the wrong driver.

Action: Relink the application in the correct mode.

ORA-24388 Unsupported functionality in fast path mode

Cause: Feature not supported in fast path mode.

Action: Avoid using the functionality in this mode.

ORA-24389 Invalid scrollable fetch parameters

Cause: All the requested rows in this fetch could not be received.

Action: Check the fetch orientation, scroll offset, OCI_ATTR_CURRENT_POSITION, and the number of rows in the OCIStmtFetch2 call. If required, change some of the above parameters and fetch again.

ORA-24390 Unsupported scrollable cursor operation

Cause: The scrollable cursor execute or fetch has failed.

Action: Check the documentation for supported types, and other restrictions while using scrollable cursors.

ORA-24391 invalid fetch operation

Cause: Scrollable cursor operation requested with non-scrollable cursor.

Action: Check if the statement was executed in the scrollable mode. The only acceptable orientation is OCI_FETCH_NEXT that ignores the scroll offset parameter.

ORA-24392 no connection pool to associate server handle

Cause: OCIServerAttach was called in OCI_POOL mode but no connection pool was found to associate the server handle.

Action: 1) Verify that OCIConnectionPoolCreate is called before calling OCIServerAttach. 2) Verify that the database link specified in OCIServerAttach matches with that of the connection pool database link.

ORA-24393 invalid mode for creating connection pool

Cause: The mode specified in OCIConnectionPoolCreate is invalid.

Action: Use a valid mode.

ORA-24394 invalid mode for destroying connection pool

Cause: The mode specified in OCIConnectionPoolDestroy is invalid.

Action: Use a valid mode.

ORA-24395 cannot reinitialize non-existent pool

Cause: OCIConnectionPoolCreate was not called in OCI_DEFAULT mode for this pool handle.

Action: Create a connection pool prior to reinitializing it.

ORA-24396 invalid attribute set in server handle

Cause: Attribute OCI_ATTR_NONBLOCKING_MODE has been set on the server handle and attached in OCI_POOL mode. Connection pooling does not support non blocking mode.

Action: Do not set the OCI_ATTR_NONBLOCKING_MODE attribute on the server handle while attaching in OCI_POOL mode.

ORA-24397 error occurred while trying to free connections

Cause: An internal error occurred while trying to free connections.

Action: Contact Oracle Support Services.

ORA-24398 connection pool already exists

Cause: A connection pool has already been created for the specified pool handle.

Action: 1) Specify a different pool handle to create a new connection pool. 2) If you wish to modify the pool parameters, call OCIConnectionPoolCreate in OCI_CPOOL_REINITIALIZE mode.

ORA-24399 invalid number of connections specified

Cause: An invalid combination of minimum, maximum and increment number of connections was specified in the OCIConnectionPoolCreate call.

Action: Specify a valid combination of parameters.

ORA-24400 error occurred while creating connections in the pool

Cause: The database link specified in OCIConnectionPoolCreate might be invalid.

Action: Specify a valid database link.

ORA-24401 cannot open further connections

Cause: Sufficient number of connections are not present in the pool to execute the call. No new connections can be opened as the connMax parameter supplied in OCIConnectionPoolCreate has been reached.

Action: Call OCIConnectionPoolCreate in OCI_CPOOL_REINITIALIZE mode and increase the value of the connMax parameter.

ORA-24402 error occurred while creating connections in the pool

Cause: The username and password specified in OCIConnectionPoolCreate might be invalid.

Action: Specify a valid username and password.

ORA-24403 error occurred while trying to destroy the connection pool

Cause: Some connections in the pool were busy when an attempt to destroy the connection pool was made.

Action: Ensure no connections from the pool are being used.

ORA-24404 connection pool does not exist

Cause: An attempt was made to use the connection pool before it was created.

Action: Create the connection pool.

ORA-24405 error occurred while trying to create connections in the pool

Cause: An internal error occurred while creating connections in the pool.

Action: Contact Oracle Support Services.

ORA-24406 API mode switch is disallowed when a call is in progress.

Cause: A mode switch from OCI8 to OCI7 was attempted in a callback.

Action: The user should perform the API mode switch either prior to initiating the top call or after the main call has completed.

ORA-24407 connection pool already exists

Cause: A connection pool has already been created for the specified pool name.

Action: Specify a different pool name to create a new connection pool.

ORA-24408 could not generate unique server group name

Cause: An internal error occurred while generating unique server group name.

Action: Contact Oracle Support Services.

ORA-24409 client cannot understand the object

Cause: The client cannot process all the new features in the object.

Action: Upgrade the client so that features like inheritance and SQLJ objects can be used.

ORA-24410 scrollable cursor max size exceeded

Cause: Result set size exceeded the max limits.

Action: Check the documentation for allowable maximum result set size for scrollable cursors. Re-execute with a smaller expected result set size or make the cursor non-scrollable.

ORA-24411 Session pool already exists.

Cause: A session pool has already been created for the specified pool handle.

Action:

  1. Specify a different pool handle to create a new session pool.
  2. If you wish to modify the pool parameters, then call OCISessionPoolCreate in OCI_SPOOL_REINITIALIZE mode.

ORA-24412 Cannot reinitialize non-existent pool

Cause: OCISessionPoolCreate was not called in OCI_DEFAULT mode for this pool handle.

Action: Create a session pool prior to reinitializing it.

ORA-24413 Invalid number of sessions specified

Cause: An invalid combination of minimum, maximum, and increment number of sessions was specified in the OCISessionPoolCreate call.

Action: Specify a valid combination of parameters.

ORA-24414 Only number sessions could be started.

Cause: The number of sessions specified by the minSess parameter of OCISessionPoolCreate could not be started, possibly because the value supplied was larger than that supported by the server.

Action: This is a warning. Check the maximum number of sessions allowed on the server.

ORA-24415 Missing or null username.

Cause: Username and password must be specified when pool is created in this mode.

Action: Specify a valid username and password.

ORA-24416 Invalid session Poolname was specified.

Cause: An attempt was made to use a Session Pool that does not exist.

Action: Create a Session Pool before using it.

ORA-24417 Session pool size has exceeded the maximum limit

Cause: The number of sessions has exceeded the maximum size of the Session Pool.

Action: This is a warning. You can tune the session pool with appropriate minimum and maximum parameters.

ORA-24418 Cannot open further sessions.

Cause: Sufficient number of sessions are not present in the pool to execute the call. No new sessions can be opened as the sessMax parameter supplied in OCISessionPoolCreate has been reached.

Action: Call OCISessionPoolCreate in OCI_SPOOL_REINITIALIZE mode and increase the value of the sessMax parameter.

ORA-24419 Proxy sessions are not supported in this mode.

Cause: A proxy session was requested from a Session Pool which does not support proxy sessions.

Action: Do not specify mode OCI_CRED_PROXY.

ORA-24420 OCISessionRelease must be used to release this session.

Cause: The session was retrieved using OCISessionGet, and an attempt has been made to release it using a call other than OCISessionRelease.

Action: Call OCISessionRelease.

ORA-24421 OCISessionRelease cannot be used to release this session.

Cause: The session was not retrieved using OCISessionGet, and an attempt has been made to release it using OCISessionRelease.

Action: Release the session using an appropriate call.

ORA-24422 error occurred while trying to destroy the Session Pool

Cause: An attempt was made to destroy the session pool while some sessions in the pool were busy.

Action: Ensure that no sessions from the pool are being used OR call OCISessionPoolDestroy with mode set to OCI_SPD_FORCE.

ORA-24430 Null values for sqltext and key were specified.

Cause: An attempt was made to call OCIStmtPrepare2 and neither sqltext nor key were specified.

Action: Specify valid values for sqltext, key, or both.

ORA-24431 Statement does not exist in the cache

Cause: The statement that was requested does not exist in the statement cache.

Action: Request a valid statement.

ORA-24432 The statement that was returned is not tagged.

Cause: A tagged statement was requested, but an untagged statement has been returned.

Action: This is a warning. Please modify and tag the statement as desired.

ORA-24433 This statement has already been prepared using OCIStmtPrepare2.

Cause: A statement that was earlier prepared using OCIStmtPrepare2 is now being reprepared using OCIStmtPrepare.

Action: Use a different statement handle.

ORA-24434 OCIStmtRelease called before OCIStmtPrepare2.

Cause: An attempt was made to release a statement without first preparing it using OCIStmtPrepare2.

Action: Call OCIStmtPrepare2 before OCIStmtRelease.

ORA-24435 Invalid Service Context specified.

Cause: The statement was prepared using a service context that is different from the one specified in OCIStmtExecute.

Action: Please specify the same service context that the statement was prepared with.

ORA-24436 Invalid statement Handle.

Cause: OCIHandleFree called on a statement that was prepared using OCIstmtPrepare2.

Action: Release the statement using OCIStmtRelease.

ORA-24437 OCIStmtExecute called before OCIStmtPrepare2.

Cause: An attempt was made to execute a statement without first preparing it using OCIStmtPrepare2.

Action: Call OCIStmtPrepare2 before OCIStmtExecute.

ORA-24438 Invalid Authentication Handle specified.

Cause: The statement was prepared using an authentication handle that is different from the one specified in OCIStmtExecute.

ORA-24500 invalid UTF16 mode

Cause: UTF16 mode is allowed only at environment handle creation time.

Action: Remove UTF16 mode for functions other than OCIEnvCreate().

ORA-24501 invalid UTF16 string passed in

Cause: Non-UTF16 string is passed in while UTF16 string is expected.

Action: Check the parameter which is actually a string.

ORA-24502 codepoint length overflows

Cause: Returned buffer has more codepoints than allowed.

Action: Set OCI_MAXCHAR_SIZE large enough to accommodate.

ORA-24503 codepoint length overflows for piecewise operation

Cause: Accumulated codepoint length exceeds allowed codepoint length.

Action: Set OCI_MAXCHAR_SIZE large enough to accommodate.

ORA-24504 data length larger than expected

Cause: Incoming data larger than receiving buffer.

Action: Set OCI_MAXDATA/OCI_MAXCHAR_SIZE appropriately or remove the setting.

ORA-24505 cannot change character set id on the handle

Cause: An attempt was made to change character set id on non-environment handles.

Action: Only try to change character set id on environment handles.

ORA-24506 invalid attempt to change character set id on env handle

Cause: An attempt was made to change character set id after other handles have been allocated from the env handle.

Action: Change character set id after creating environment handle but before allocating any handles from it.

ORA-24507 invalid combination of character set ids

Cause: Attempts to set one character set id as zero.

Action: Set both charset and ncharset as zero or non-zero in OCIEnvNlsCreate()

ORA-24750 incorrect size of attribute

Cause: Transaction ID attribute size is incorrect.

Action: Verify that the size parameter is correct.

ORA-24752 OCI_TRANS_NEW flag must be specified for local transactions

Cause: Application attempted to start a local transaction without using OCI_TRANS_NEW.

Action: Use OCI_TRANS_NEW when starting local transactions.

ORA-24753 local transactions cannot be detached

Cause: An attempt to detach a local transaction was made.

Action: Local transactions may only be committed or rolled back.

ORA-24754 cannot start new transaction with an active transaction

Cause: An attempt to start a new transaction was made when there was an active transaction.

Action: Commit, rollback or detach the existing transaction before starting a new transaction.

ORA-24755 OCI_TRANS_NOMIGRATE, OCI_TRANS_JOIN options are not supported

Cause: These flags are currently not supported.

Action: No action required.

ORA-24756 transaction does not exist

Cause: An invalid transaction identifier or context was used or the transaction has completed.

Action: Supply a valid identifier if the transaction has not completed and retry the call.

ORA-24757 duplicate transaction identifier

Cause: An attempt was made to start a new transaction with an identifier already in use by an existing transaction.

Action: Verify that the identifier is not in use.

ORA-24758 not attached to the requested transaction

Cause: An attempt was made to detach or complete a transaction that is not the current transaction.

Action: Verify that the transaction context refers to the current transaction.

ORA-24759 invalid transaction start flags

Cause: An invalid transaction start flag was passed.

Action: Verify that one of the values OCI_TRANS_NEW, OCI_TRANS_JOIN, or OCI_TRANS_RESUME was specified.

ORA-24760 invalid isolation level flags

Cause: An invalid isolation level flag was passed.

Action: Verify that only one of following values - OCI_TRANS_READONLY, OCI_TRANS_READWRITE, OCI_TRANS_SERIALIZABLE is used.

ORA-24761 transaction rolled back

Cause: The application tried to commit a transaction and the server rolled it back.

Action: No action required.

ORA-24762 server failed due to unspecified error

Cause: An internal error has occurred in the server commit protocol.

Action: Contact Oracle Support Services.

ORA-24763 transaction operation cannot be completed now

Cause: The commit or rollback cannot be performed now because the session cannot switch to the specified transaction.

Action: Retry the operation later.

ORA-24764 transaction branch has been heuristically committed

Cause: This is an informational message.

Action: No action required.

ORA-24765 transaction branch has been heuristically rolled back

Cause: This is an informational message.

Action: No action required.

ORA-24766 transaction branch has been partly committed and aborted

Cause: This is an informational message.

Action: No action required.

ORA-24767 transaction was read-only and has been committed

Cause: This is an informational message.

Action: No action required.

ORA-24768 commit protocol error occured in the server

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-24769 cannot forget an active transaction

Cause: Transaction identifier refers to an active transaction.

Action: Verify that the identifier of an active transaction was not passed as an argument.

ORA-24770 cannot forget a prepared transaction

Cause: Transaction identifier refers to a prepared transaction.

Action: Verify that the identifier of a prepared transaction was not passed as an argument.

ORA-24771 cannot detach, prepare or forget a local transaction

Cause: Service handle contains a local transaction context.

Action: Verify that the transaction context does not refer to a local transaction.

ORA-24772 Cannot mix tightly-coupled and loosely-coupled branches

Cause: Application attempted to start a transaction with a global transaction identifier and a wrong option.

Action: Verify that all branches of a global transaction are started with either OCI_TRANS_TIGHT or OCI_TRANS_LOOSE option. If the application is correct and uses distributed updates, contact Oracle Support Services.

ORA-24773 invalid transaction type flags

Cause: OCI_TRANS_TIGHT or OCI_TRANS_LOOSE mode was not specified.

Action: Verify that the right parameters are being used.

ORA-24774 cannot switch to specified transaction

Cause: The transaction specified in the call refers to a transaction created by a different user.

Action: Create transactions with the same authentication so that they can be switched.

ORA-24775 cannot prepare or commit transaction with non-zero lock value

Cause: An attempt was made to detach the transaction with a non-zero lock value.

Action: Detach the transaction with lock value set to zero and then try to prepare or commit the transaction.

ORA-24776 cannot start a new transaction

Cause: An attempt was made to start a new transaction when session was already attached to an existing transaction.

Action: End the current transaction before creating a new transaction.

ORA-24777 use of non-migratable database link not allowed

Cause: The transaction, which needs to be migratable between sessions, tried to access a remote database from a non-multithreaded server process.

Action: Perform the work in the local database or open a connection to the remote database from the client. If the multithreaded server option is installed, connect to the Oracle instance through the dispatcher.

ORA-24778 cannot open connections

Cause: The migratable transaction tried to access a remote database when the session itself had opened connections to remote database(s).

Action: Close the connection(s) in the session and then try to access the remote database from the migratable transaction. If the error still occurs, contact Oracle Support Services.

ORA-24779 detach not allowed with open remote cursor

Cause: The migratable transaction tried to detach from the current session while an open remote cursor exists.

Action: Close any open remote cursor prior to detach.

ORA-24780 cannot recover a transaction while in an existing transaction

Cause: An attempt was made to commit or roll back a transaction while in a different transaction, and the transaction for which the action is requested is in a recovery state (this happens if it is idle too long).

Action: Detach from the current transaction and retry the operation.

ORA-24781 branches don't belong to the same global transaction

Cause: The list of xids passed into kpotxmp() do not have the same gtrid

ORA-24782 Cannot detach from a non-migratable transaction

Cause: An attempt was made to detach from a non-migrateable transaction.

Action: Either commit or rollback the transaction.

ORA-24783 Cannot switch non-migratable transactions

Cause: An attempt was made to prepare/commit a txn different from current.

ORA-24784 Transaction exists

Cause: An attempt was made to start a transaction, while attached to a non-migrateable transaction.

ORA-24785 Cannot resume a non-migratable transaction

Cause: An attempt was made to resume a non-migrateable transaction.

ORA-24786 separated transaction has been completed

Cause: The current transaction has been completed by another process.

Action: Start a new transaction.

ORA-24787 remote cursors must be closed before a call completes

Cause: The previous operation did not close all the remote cursors it opened. Since separated transactions are enabled, this is not allowed.

Action: Close all remote cursors in each call, or start a regular (non-separated) transaction.

ORA-24788 cannot switch to specified transaction (server type)

Cause: The transaction specified was created by a shared server and the requestor is a dedicated server, or the transaction was created by a dedicated server and the requestor is a shared server.

Action: All parts of this application should connect as dedicated or as shared.

ORA-24790 cannot mix OCI_TRANS_RESUME and transaction isolation flags

Cause: An attempt was made to change the isolation level of an existing transaction.

Action: No action required.

ORA-24801 illegal parameter value in OCI lob function

Cause: One of the parameter values in the OCI LOB function is illegal.

Action: Check every parameter in the OCI Lob function call to make sure they are correct. Offsets should be greater than or equal to one.

ORA-24802 user defined lob read callback error

Cause: The only valid return value for a user defined LOB read callback function is OCI_CONTINUE. Any other value will cause this error.

Action: Verify that OCI_CONTINUE is returned from the user defined LOB read callback function.

ORA-24803 illegal parameter value in lob read function

Cause: This is an internal error.

Action: This error should not normally occur. If it persists, contact Oracle Support Services.

ORA-24804 illegal parameter value in lob write function

Cause: This is an internal error.

Action: This error should not normally occur. If it persists, contact Oracle Support Services.

ORA-24805 LOB type mismatch

Cause: When copying or appending LOB locators, both source and destination LOB locators should be of the same type.

Action: Pass the same type of LOB locators for copying or appending.

ORA-24806 LOB form mismatch

Cause: When reading from or writing into LOBs, the character set form of the user buffer should be same as that of the LOB.

Action: Make sure that the buffer you are using to read or write has the same form as that of the LOB.

ORA-24807 LOB form mismatch

Cause: When copying or appending LOBs, both source and destination LOB locators should have the same character set form.

Action: Pass locators of the same character set form for copying or appending LOBs.

ORA-24808 streaming of lob data is not allowed when using lob buffering

Cause: An attempt was made to stream LOB data via the polling mode or a callback when LOB buffering was enabled for the input LOB locator.

Action: Lob buffering is useful when reading/writing small amounts of LOB data so streaming should not be necessary. Rewrite the OCILobRead/OCILobWrite call so that it does not use streaming. If streaming of data is required, LOB buffering should not be used. In this case, flush buffers associated with the input LOB locator as necessary, disable buffering on the input LOB locator and reissue the OCILobRead/OCILobWrite call.

ORA-24809 amount specified will not fit in the lob buffers

Cause: LOB buffering is enabled for the input LOB locator so buffering will be used. However, the amount of LOB data to read or write is larger than what the LOB buffers can hold.

Action: Either disable buffering on the input LOB locator and reissue the command or pass a smaller amount.

ORA-24810 attempting to write more data than indicated

Cause: While writing into a LOB, more data was supplied than indicated.

Action: If data is written in pieces, then make sure that you do not provide more data in the pieces (cumulatively), than you indicated.

ORA-24811 less data provided for writing than indicated

Cause: While writing into a LOB, less data was provided than indicated.

Action: If writing data in single pieces, then make sure that the buffer length specified is big enough to accommodate the data being provided. If data is written in pieces, then make sure that all the data has been provided before specifying OCI_LAST_PIECE.

ORA-24812 character set conversion to or from UCS2 failed

Cause: If the database character set is varying-width, the CLOB/NCLOB value is implicitly converted to or from UCS2. This implicit conversion failed.

Action: Contact Oracle Support Services.

ORA-24813 cannot send or receive an unsupported LOB

Cause: An attempt was made to send a LOB across the network, but either the server does not support the LOB sent by the client, or the client does not support the LOB sent by the server. This error usually occurs when the client and server are running different versions of Oracle.

Action: Use a version of the Oracle that supports the LOB on both the client and the server.

ORA-24814 operation not allowed for temporary LOBs

Cause: Temporary LOB locators are not allowed in the operation. For example, OCILobAssign only takes persistent LOB locators as parameters, not temporary LOBs.

Action: Use OCILobLocatorAssign for temporary LOBs instead. Note that OCILobLocatorAssign can also be used for persistent LOBs, in which case it will behave the same as OCILobAssign.

ORA-24850 failed to startup shared subsystem

Cause: While attempting to initialize OCI in shared mode, a problem was encountered in starting the shared subsystem.

Action: Contact Oracle Support Services.

ORA-24851 failed to connect to shared subsystem

Cause: While attempting to initialize OCI in shared mode, a problem was encountered in connecting the process to the shared subsystem.

Action: Contact Oracle Support Services.

ORA-24852 protocol error during statement execution

Cause: An internal protocol error occurred while receiving describe data from the server during execution of a statement.

Action: Contact Oracle Support Services.

ORA-24853 failed to connect thread to shared subsystem

Cause: While attempting to initialize OCI in shared mode, a problem was encountered in connecting the thread to the shared subsystem.

Action: Contact Oracle Support Services.

ORA-24900 invalid or unsupported mode paramater passed in call

Cause: The mode parameter passed into the OCI Client Notification call is incorrect.

Action: Correct the mode parameter passed into OCI.

ORA-24901 handles belonging to different environments passed into an OCI call

Cause: All handles passed into an OCI call should belong to the same environment. In the call that returned this error, handles belonging to different environments were passed in.

Action: Make sure that the handle parameters in the call to come from the same OCI Environment.

ORA-24902 invalid subscription name or name-length in subscription handle

Cause: The subscription handle passed into the OCI call does not have a proper name or name-length attribute.

Action: Set the name and name-length attributes using the OCIAttrSet() call.

ORA-24903 invalid namespace attribute passed into OCI call

Cause: The subscription handle passed into the OCI call does not have a proper NAMESPACE attribute.

Action: Set the NAMESPACE attribute using the OCIAttrSet() call.

ORA-24904 invalid callback attribute passed into OCI call

Cause: The subscription handle passed into the OCI call does not have a proper callback attribute.

Action: Set the callback attribute using the OCIAttrSet() call.

ORA-24905 invalid recepient protocol attribute passed into OCI call

Cause: The subscription handle passed into the OCI call does not have a proper recepient protocol attribute.

Action: Set the recepient protocol attribute using the OCIAttrSet() call.

ORA-24906 invalid recepient attribute passed into OCI call

Cause: The subscription handle passed into the OCI call does not have a proper recepient attribute.

Action: Set the recepient attribute using the OCIAttrSet() call.

ORA-24907 invalid pair of callback and recepient protocol attributes

Cause: The subscription handle passed into the OCI call can't have both the callback defined and a recepient protocol other than OCI_SUBSCR_PROTO_OCI at the same time.

Action: Set the appropriate callback and recepient protocol attributes using the OCIAttrSet() call.

ORA-24908 invalid recipient presentation attribute

Cause: The subscription handle passed into the OCI call does not have a valid recipient presentation attribute.

Action: Set the recipient presentation attribute using the OCIAttrSet() call.

ORA-24950 unregister failed, registeration not found

Cause: The registeration that was asked to be unregistered could not be found.

Action: Check the callback function name and the subscription name in the unregister call.

ORA-25000 invalid use of bind variable in trigger WHEN clause

Cause: A bind variable was used in the when clause of a trigger.

Action: Remove the bind variable. To access the table columns use (new/old).column_name.

ORA-25001 cannot create this trigger type on views

Cause: Only INSTEAD OF triggers can be created on a view.

Action: Change the trigger type to INSTEAD OF.

ORA-25002 cannot create INSTEAD OF triggers on tables

Cause: Only BEFORE or AFTER triggers can be created on a table.

Action: Change the trigger type to BEFORE or AFTER.

ORA-25003 cannot change NEW values for this column type in trigger

Cause: Attempt to change NEW trigger variables of datatype object, REF, nested table, VARRAY or LOB datatype which is not supported.

Action: Do not change the NEW trigger variables in the trigger body.

ORA-25004 WHEN clause is not allowed in INSTEAD OF triggers

Cause: WHEN clause is specified in an INSTEAD OF trigger.

Action: Remove the WHEN clause when creating an INSTEAD OF trigger.

ORA-25005 cannot CREATE INSTEAD OF trigger on a read-only view

Cause: Attempt to create an INSTEAD OF trigger on a view created with read-only option. The view cannot be updated using INSTEAD OF triggers.

Action: Do not create the trigger.

ORA-25006 cannot specify this column in UPDATE OF clause

Cause: Attempt to create a trigger on update of a column whose datatype is disallowed in the clause, such as LOB and nested table.

Action: Remove the UPDATE OF clause.

ORA-25007 functions or methods not allowed in WHEN clause

Cause: PL/SQL function call or method invocation is not allowed in the WHEN clause when creating a trigger.

Action: Remove the function call or method invocation from the WHEN clause.

ORA-25008 no implicit conversion to LOB datatype in instead-of trigger

Cause: When inserting or updating a view using instead-of trigger, the new value for a LOB view column is of a different datatype.

Action: Specified a LOB value as the new value for the LOB view column.

ORA-25009 Nested table clause allowed only for INSTEAD OF triggers

Cause: Triggers on nested tables can only be created on view columns using INSTEAD OF triggers.

Action: Use view nested table columns for defining nested table triggers.

ORA-25010 Invalid nested table column name in nested table clause

Cause: The column name specified in the nested table clause of an INSTEAD OF trigger does not correspond to a nested table column.

Action: Specify a nested table column on which the trigger is to be defined.

ORA-25012 PARENT and NEW values cannot be identical

Cause: The referencing clause specifies identical values for PARENT and OLD.

Action: Respecify either the PARENT or NEW referencing value.

ORA-25013 OLD and PARENT values cannot be identical

Cause: The referencing clause specifies identical values for OLD and PARENT.

Action: Respecify either the OLD or PARENT referencing value.

ORA-25014 cannot change the value of a PARENT reference variable

Cause: Parent values can only be read and not changed.

Action: Do not attempt to change a Parent variable.

ORA-25015 cannot perform DML on this nested table view column

Cause: DML cannot be performed on a nested table view column except through an INSTEAD OF trigger.

Action: Create an INSTEAD OF trigger over the nested table view column and then perform the DML.

ORA-25016 cannot specify column list for insert into nested table view column

Cause: A column list cannot be specified for inserts into the nested table view column.

Action: Specify all the columns for insert into the nested table.

ORA-25017 cannot reference NEW ROWID for movable rows in before triggers

Cause: NEW ROWID was referenced in a before row trigger which is defined on an index-organized table, or a partitioned table with enabled movement of rows. The ROWID cannot be computed in a before row update trigger because it depends on the actual values of the row.

Action: Remove references to NEW ROWID from the trigger definition.

ORA-25018 conflicting trigger string already exists

Cause: Conflicting instead of DDL trigger on schema/database already exists.

Action: Remove the old trigger.

ORA-25019 too much concurrency

Cause: Cannot pin the database/schema because of too much concurrency.

Action: Try the operation later.

ORA-25020 renaming system triggers is not allowed

Cause: renaming system triggers is not allowed.

Action: Drop the trigger and create a new one.

ORA-25100 TABLESPACE option can only be used with ALTER INDEX REBUILD

Cause: The TABLESPACE option to ALTER INDEX was used without the REBUILD option.

Action: Use ALTER INDEX REBUILD TABLESPACE tablespace name.

ORA-25101 duplicate REBUILD option specification

Cause: The REBUILD option to ALTER INDEX is specified more than once.

Action: Specify the option at most once.

ORA-25102 PARALLEL option can only be used with ALTER INDEX REBUILD

Cause: The PARALLEL option to ALTER INDEX was used without the REBUILD option.

Action: Use ALTER INDEX REBUILD.

ORA-25103 NOPARALLEL option can only be used with ALTER INDEX REBUILD

Cause: The NOPARALLEL option to ALTER INDEX was used without the REBUILD option.

Action: Use ALTER INDEX REBUILD.

ORA-25104 UNRECOVERABLE option can only be used with ALTER INDEX REBUILD

Cause: The UNRECOVERABLE option to ALTER INDEX was used without the REBUILD option.

Action: Use ALTER INDEX REBUILD.

ORA-25105 RECOVERABLE option can only be used with ALTER INDEX REBUILD

Cause: The RECOVERABLE option to ALTER INDEX was used without the REBUILD option.

Action: Use ALTER INDEX REBUILD.

ORA-25106 only one of PARALLEL or NOPARALLEL clause may be specified

Cause: PARALLEL was specified more than once, NOPARALLEL was specified more than once, or both PARALLEL and NOPARALLEL were specified in an ALTER INDEX REBUILD statement.

Action: Remove all but one of the PARALLEL or NOPARALLEL clauses.

ORA-25107 duplicate TABLESPACE option specification

Cause: the TABLESPACE was specified more than once in an ALTER INDEX REBUILD statement.

Action: Remove all but one of the TABLESPACE clauses.

ORA-25108 standby lock name space exceeds size limit of string characters

Cause: The lock name space for the standby database exceeded the maximum string length.

Action: Change initialization parameter _STANDBY_LOCK_NAME_SPACE to a character string of less than the specified characters.

ORA-25109 standby lock name space has illegal character 'string'

Cause: An invalid lock name space was specified for the standby database. The lock name space for the standby database can only contain A-Z, 0-9, '_', '#', '$', '.' and '@' characters.

Action: Change initialization parameter _STANDBY_LOCK_NAME_SPACE to a valid character string.

ORA-25110 NOSORT may not be used with a bitmap index

Cause: An attempt was made to create a bitmap index using the NOSORT option.

Action: Remove NOSORT from the CREATE BITMAP INDEX statement.

ORA-25111 creation of BITMAP cluster indices is not supported

Cause: An attempt was made to create a cluster index with the BITMAP attribute.

Action: Remove BITMAP from the CREATE INDEX statement.

ORA-25112 maximum number of BITMAP index columns is 30

Cause: Too many columns were specified for the index.

Action: Create an index on fewer columns.

ORA-25113 GLOBAL may not be used with a bitmap index

Cause: An attempt was made to create a bitmap index using the GLOBAL option.

Action: Remove GLOBAL from the CREATE BITMAP INDEX statement, and/or add a LOCAL partition descriptor if the table is partitioned.

ORA-25114 invalid file number specified in the DUMP DATAFILE/TEMPFILE command

Cause: An invalid file number was used in dumping a datafile or temporary file.

Action: Specify a valid file number.

ORA-25115 duplicate BLOCK option specification

Cause: BLOCK (MIN/MAX) was specified more than once in the DUMP DATAFILE/TEMPFILE command.

Action: Specify only one BLOCK option.

ORA-25116 invalid block number specified in the DUMP DATAFILE/TEMPFILE command

Cause: An invalid block number was used in dumping a datafile or temporary file.

Action: Specify a valid block number.

ORA-25117 MIN/MAX/Block Number expected

Cause: A value other than MIN/MAX, or a block number was entered in the DUMP DATAFILE/TEMPFILE command.

Action: Correct the syntax.

ORA-25118 invalid DUMP DATAFILE/TEMPFILE option

Cause: An invalid option was specified for the DUMP DATAFILE/TEMPFILE command.

Action: Correct the syntax.

ORA-25119 LOGGING/NOLOGGING option already specified

Cause: In CREATE TABLESPACE, the LOGGING and/or NOLOGGING options were specified more than once.

Action: Remove all but one of the logging specifications.

ORA-25120 MINIMUM EXTENT option already specified

Cause: In CREATE TABLESPACE, the MINIMUM EXTENT option was specified more than once.

Action: Remove all but one of the MINIMUM EXTENT specifications.

ORA-25121 MINIMUM EXTENT value greater than maximum extent size

Cause: In CREATE/ALTER TABLESPACE, the value specified for the MINIMUM EXTENT option was greater than the maximum extent size.

Action: Choose a lower value for the MINIMUM EXTENT option.

ORA-25122 Only LOCAL bitmap indexes are permitted on partitioned tables

Cause: An attempt was made to create a global bitmap index on a partitioned table.

Action: Create a local bitmap index instead.

ORA-25123 Too many components specified in the name.

Cause: More components per name than is allowed were specified.

Action: Check the name specified for the operation.

ORA-25124 Database link name not allowed.

Cause: A database link name was specified when it is not permitted.

Action: Check the name specified for the operation.

ORA-25125 BUFFER_POOL storage option not allowed

Cause: An attempt was made to specify the BUFFER_POOL storage option. This option may only be specified during CREATE/ALTER TABLE/CLUSTER/INDEX.

Action: Remove this option and retry the statement.

ORA-25126 Invalid name specified for BUFFER_POOL

Cause: The name of the buffer pool specified by the user is invalid. The only valid names are KEEP, RECYCLE and DEFAULT.

Action: Use a valid name or remove the BUFFER_POOL clause.

ORA-25127 RELY not allowed in NOT NULL constraint

Cause: An attempt was made to set RELY on for NOT NULL constraint.

Action: Only NORELY may be specified for a NOT NULL constraint.

ORA-25128 No insert/update/delete on table with constraint (string.string) disabled and validated

Cause: An attempt was made to insert/update/delete on table with DISABLE VALIDATE constraint.

Action: Change the constraint's states.

ORA-25129 cannot modify constraint (string) - no such constraint

Cause: The named constraint does not exist for this table.

Action: Try again with a constraint that does exist for this table.

ORA-25130 cannot modify primary key - primary key not defined for table

Cause: An attempt was made to modify a primary key that is not defined for the table.

Action: No action required.

ORA-25131 cannot modify unique(string) - unique key not defined for table

Cause: An attempt was made to modify a unique key that is not defined for the table.

Action: No action required.

ORA-25132 UNIQUE constraint (string.string) disabled and validated in ALTER TABLE EXCHANGE PARTITION

Cause: Cannot ALTER TABLE EXCHANGE PARTITION when the partition and the table have a disabled and validated unique constraints AND the unique keys in the partition is not mutually exclusive from the rest of the table.

Action: Change the constraint's status.

ORA-25133 duplicate SINGLE TABLE option specified

Cause: The SINGLE TABLE option was specified more than once.

Action: Specify the SINGLE TABLE option only once.

ORA-25134 keyword TABLE expected

Cause: The keyword TABLE is missing from the SINGLE TABLE option.

Action: Place the keyword TABLE after the keyword SINGLE in the command.

ORA-25135 cannot use the SINGLE TABLE option

Cause: The SINGLE TABLE option is only valid for hash clusters.

Action: Do not specify the SINGLE TABLE option.

ORA-25136 this cluster can contain only one table

Cause: An attempt was made to store more than one table in a cluster that was created with the SINGLE TABLE option.

Action: Do not attempt to store more than one table in the cluster.

ORA-25137 Data value out of range

Cause: Value from cast operand is larger than cast target size.

Action: Increase size of cast target.

ORA-25138 string initialization parameter has been made obsolete

Cause: An obsolete initialization parameter has been specified.

Action: The system will come up, but parameters must be examined.

ORA-25139 invalid option for CREATE TEMPORARY TABLESPACE

Cause: An invalid option appears.

Action: Specify one of the valid options: TEMPFILE, EXTENT MANAGEMENT LOCAL, UNIFORM.

ORA-25140 string space policy cannot be specified for the string extent management

Cause: An invalid option appears.

Action: Make sure that for LOCAL extent management UNIFORM or AUTOALLOCATE is specified, and for DICTIONARY extent management UNIFORM or AUTOALLOCATE are not specified

ORA-25141 invalid EXTENT MANAGEMENT clause

Cause: An invalid option appears for EXTENT MANAGEMENT clause.

Action: Specify one of the valid options: UNIFORM SIZE, AUTOALLOCATE.

ORA-25142 default storage clause specified twice

Cause: Default storage clause was specified twice for create tablespace.

Action: Specify it once.

ORA-25143 default storage clause is not compatible with allocation policy

Cause: Default storage clause was specified for a tablespace with AUTOALLOCATE or UNIFORM policy.

Action: Omit the storage clause.

ORA-25144 invalid option for CREATE TABLESPACE with TEMPORARY contents

Cause: An invalid option appears.

Action: Specify one of the valid options: EXTENT MANAGEMENT DICTIONARY, USER.

ORA-25145 allocation policy already specified

Cause: In CREATE TABLESPACE, the allocation policy was specified more than once, for example, AUTOALLOCATE and UNIFORM.

Action: Remove all but one of the allocation policy specifications.

ORA-25146 EXTENT MANAGEMENT option already specified

Cause: In CREATE TABLESPACE, the EXTENT MANAGEMENT option was specified more than once.

Action: Remove all but one of the EXTENT MANAGEMENT specifications.

ORA-25147 UNIFORM SIZE value greater than maximum extent size

Cause: In CREATE/ALTER TABLESPACE, the value specified for the UNIFORM SIZE option was greater than the maximum extent size.

Action: Choose a lower value for the UNIFORM SIZE option.

ORA-25148 ONLINE option not permitted

Cause: An attempt was made to specify ONLINE for ALTER TABLE MOVE on a table that is not index-organized. The ONLINE option is currently supported only for index-organized tables.

Action: Remove the ONLINE option from the command.

ORA-25149 Columns of UROWID type may not be indexed

Cause: An attempt was made to create an index on a column of UROWID type.

Action: Remove the column from the list of indexed columns.

ORA-25150 ALTERING of extent parameters not permitted

Cause: An attempt was made to alter the extent parameters for a segment in a tablespace with autoallocate or uniform extent allocation policy.

Action: Remove the appropriate extent parameters from the command.

ORA-25151 Rollback Segment cannot be created in this tablespace

Cause: An attempt was made to create a rollback segment in a tablespace with autoallocate extent allocation policy.

Action: Specify a different tablespace for the rollback segment.

ORA-25152 TEMPFILE cannot be dropped at this time

Cause: An attempt was made to drop a TEMPFILE being used by online users.

Action: The TEMPFILE has been taken offline. Try again later.

ORA-25153 Temporary Tablespace is Empty

Cause: An attempt was made to use space in a temporary tablespace with no files.

Action: Add files to the tablespace using ADD TEMPFILE command.

ORA-25154 column part of USING clause cannot have qualifier

Cause: Columns that are used for a named-join (either a NATURAL join or a join with a USING clause) cannot have an explicit qualifier.

Action: Remove the qualifier.

ORA-25155 column used in NATURAL join cannot have qualifier

Cause: Columns that are used for a named-join (either a NATURAL join or a join with a USING clause) cannot have an explicit qualifier.

Action: Remove the qualifier.

ORA-25156 old style outer join (+) cannot be used with ANSI joins

Cause: When a query block uses ANSI style joins, the old notation for specifying outer joins (+) cannot be used.

Action: Use ANSI style for specifying outer joins also.

ORA-25157 Specified block size string is not valid

Cause: An attempt was made to create a tablespace with a block size which is not supported.

Action: Specify either the standard blocksize or one of (2k, 4k, 8k, 16k, 32k) subject to the maximum and minimum blocksizes supported by the platform.

ORA-25175 no PRIMARY KEY constraint found

Cause: A PRIMARY KEY constraint must be defined for a table with this organization.

Action: Define a PRIMARY KEY.

ORA-25176 storage specification not permitted for primary key

Cause: Storage parameters cannot be defined for a PRIMARY KEY constraint for a table with this organization.

Action: Remove storage specification for primary key.

ORA-25177 UNRECOVERABLE option not permitted

Cause: The UNRECOVERABLE option may not be specified for a primary key for a table with this organization.

Action: Remove UNRECOVERABLE option for primary key.

ORA-25178 duplicate PCTTHRESHOLD storage option specification

Cause: The storage option PCTTHRESHOLD is specified more than once.

Action: Specify storage options at most once.

ORA-25179 invalid PCTTHRESHOLD storage option value

Cause: The specified value must be a positive integer.

Action: Specify an appropriate value.

ORA-25180 PCTTHRESHOLD only valid for certain table organizations

Cause: PCTTHRESHOLD can only be specified for tables with certain organizations.

Action: Remove the PCTTHRESHOLD option.

ORA-25181 missing ON keyword for NESTED INDEX

Cause: The ON keyword is required to specify nested index column nest.

Action: Add ON keyword.

ORA-25182 feature not currently available for index-organized tables

Cause: An attempt was made to use one or more of the following feature(s) not currently supported for index-organized tables:

  • CREATE TABLE with LOB/BFILE/VARRAY columns
  • partitioning/PARALLEL/CREATE TABLE AS SELECT options
  • ALTER TABLE with ADD/MODIFY column options
  • CREATE INDEX

Action: Do not use the disallowed feature(s) in this release.

ORA-25183 index-organized table top index segment is in a different tablespace

Cause: An attempt was made to drop a tablespace which contains an index only table's overflow segment but not the top index segment.

Action: Find index-organized tables which span the tablespace being dropped and some other tablespace(s). Drop these tables.

ORA-25184 column name expected

Cause: A column name is not present where required by the CREATE TABLE for specifying last column to be included in the index segment of the index-organized table.

Action: Specify a column name where required by the syntax.

ORA-25185 index column other than last can not be specified for INCLUDE clause

Cause: An index column name other than the last was specified as including column.

Action: Specify either a column name which is not part of index-organized table primary key index, or the last key column of the primary key for the INCLUDING clause.

ORA-25186 INCLUDING clause specified for index-organized table without OVERFLOW

Cause: INCLUDING clause of a CREATE TABLE is an valid option only for index-organized tables with OVERFLOW clause (at creation time) or if an OVERFLOW segment already exists (at ALTER time).

Action: Specify OVERFLOW clause for the index-organized table: For ALTER, perform ADD OVERFLOW first.

ORA-25187 specified exceptions table form incorrect

Cause: The specified table does not have the proper field definitions.

Action: Specify the correct table to use.

ORA-25188 cannot drop/disable/defer the primary key constraint for index-organized tables

Cause: An attempt was made to DROP, DISABLE, or DEFER the primary key constraint for an index-only table. This is not allowed.

Action: Do not DROP, DISABLE, or DEFER the primary key constraint for an index-only table.

ORA-25189 illegal ALTER TABLE option for an index-organized table

Cause: During ALTER of a index-organized table, the user attempted to enter one or more of the following options: TABLESPACE, ALLOCATE/DEALLOCATE EXTENT, PCTFREE/PCTUSED for IOT top index segment

Action: Remove the illegal option(s).

ORA-25190 an index-organized table maintenance operation may not be combined with other operations

Cause: ALTER TABLE statement attempted to combine an index-organized table maintenance operation (for example, changing physical attributes) with some other operation (for example, ADD constraint) which is illegal

Action: Ensure that a index-organized table maintenance operation is the sole operation specified in ALTER TABLE statement.

ORA-25191 cannot reference overflow table of an index-organized table

Cause: An attempt was made to directly access the overflow table of an index-organized table.

Action: Issue the statement against the parent index-organized table containing the specified overflow table.

ORA-25192 invalid option for an index-organized table

Cause: An attempt was made to specify one or more of the following options for an index-organized table: [NO]CACHE, NO LOGGING, CLUSTER.

Action: Remove the illegal option(s).

ORA-25193 cannot use COMPRESS option for a single column key

Cause: An attempt was made to use COMPRESS option on single column key.

Action: Remove the COMPRESS option.

ORA-25194 invalid COMPRESS prefix length value

Cause: The specified value must be a positive integer less than the number of key columns.

Action: Specify an appropriate value.

ORA-25195 invalid option for index on an index-organized table

Cause: An attempt was made to specify one or more of the following options for index on an IOT: BITMAP, REVERSE, PCTUSED.

Action: Specify an appropriate option.

ORA-25196 keyword MOVE in ALTER TABLE MOVE must immediately follow table_name

Cause: MOVE specified after one/more other ALTER options.

Action: Change order of options, MOVE should be first or remove the illegal option(s).

ORA-25197 an overflow segment already exists for the indexed-organized table

Cause: An attempt was made to ADD OVERFLOW segment on an index-organized table that already has an overflow segment.

Action: No action required.

ORA-25198 only range and hash partitioning are supported for index-organized table

Cause: System or composite partitioning schemes are not supported.

Action: Select a different partitioning scheme.

ORA-25199 partitioning key of a index-organized table must be a subset of the primary key

Cause: An attempt was made to specify a partitioning key which is not a prefix of the primary key of the index-organized table.

Action: Select a different partitioning key.

ORA-25200 invalid value string, QUEUE_NAME should be [SCHEMA.]NAME

Cause: A NULL parameter was specified for QUEUE_NAME.

Action: Specify a non-NULL queue name.

ORA-25201 invalid value, VISIBILITY should be ON_COMMIT or IMMEDIATE

Cause: An invalid value specified for parameter VISIBILITY.

Action: Specify either ON_COMMIT or IMMEDIATE.

ORA-25202 invalid value NULL, string should be non-NULL

Cause: A NULL value was specified for the parameter.

Action: Specify a non-NULL value.

ORA-25203 invalid value string, DELAY should be non-negative

Cause: A negative value or NULL was specified for DELAY.

Action: Specify a non-negative integer for DELAY.

ORA-25204 invalid value, SEQUENCE_DEVIATION should be BEFORE or TOP

Cause: An invalid SEQUENCE_DEVIATION was specified.

Action: Specify either the option 'BEFORE' or 'TOP'.

ORA-25205 the QUEUE string.string does not exist

Cause: The specified queue does not exist.

Action: Create the queue first before specifying it for enqueue or dequeue.

ORA-25206 enqueue failed, enqueue to exception queue string.string not permitted

Cause: An attempt was made to enqueue to an exception queue.

Action: Try enqueueing to another queue.

ORA-25207 enqueue failed, queue string.string is disabled from enqueueing

Cause: The queue has been stopped to prevent any further enqueueing.

Action: Enable the queue first by using an administrative operation.

ORA-25208 RELATIVE_MSGID must be specified if SEQUENCE_DEVIATION is BEFORE

Cause: A relative message identifier should be specified if sequence deviation is specified as BEFORE.

Action: Either specify an existing relative message identifier or do not specify sequence deviation as BEFORE.

ORA-25209 invalid value string, EXPIRATION should be non-negative or NEVER

Cause: The expiration is less than zero or NULL.

Action: Specify a valid value for EXPIRE_AFTER which should be greater than or equal to zero or NEVER.

ORA-25210 invalid value for RELATIVE_MSGID, no message in queue with that msgid

Cause: No message in the queue with the MSGID equal to the specified RELATIVE_MSGID.

Action: Try again with a valid RELATIVE_MSGID.

ORA-25211 invalid DELAY specified when using sequence deviation

Cause: The DELAY specified in the enqueue is greater than the delay of the message with the given relative message ID.

Action: Set the DELAY to be less than or equal to the delay of the message with the given relative message ID. If the TOP option is used the delay must be less than or equal to the delay of all the messages in the queue.

ORA-25212 invalid PRIORITY specified when using sequence deviation

Cause: The PRIORITY specified in the enqueue is less than the priority of the message with the given relative message ID.

Action: Set the PRIORITY to be less than the delay of the message with the given relative message ID. If the TOP option is used the priority must be greater than or equal to the priority of all the messages in the queue.

ORA-25213 message with specified RELATIVE_MSGID has been dequeued

Cause: The message specified by the RELATIVE_MSGID field in the sequence deviation BEFORE option has been dequeued.

Action: No action required. This is an informational message only.

ORA-25214 cannot specify delay or expiration for enqueue to exception queue

Cause: A message was enqueued to the exception queue with either delay or expiration specified.

Action: Enqueue a message without delay or expiration.

ORA-25215 user_data type and queue type do not match

Cause: A user tries to enqueue an object to a queue that was created for objects of different type.

Action: Try enqueue again with an object of the right type.

ORA-25216 invalid recipient, either NAME or ADDRESS must be specified

Cause: Both attributes, NAME and ADDRESS, were specified null for one of the recipients in the recipient list.

Action: Specify a non-null NAME or ADDRESS for the recipient.

ORA-25217 enqueue failed, visibility must be IMMEDIATE for queue string.string

Cause: An attempt was made to enqueue to a non-persistent queue without setting visibility to IMMEDIATE.

Action: Set visibility to IMMEDIATE.

ORA-25218 enqueue failed, delay must be zero for queue string.string

Cause: An attempt was made to enqueue to a non-persistent queue with delay greater than zero seconds.

Action: Set delay to zero.

ORA-25219 enqueue failed, sequence deviation not allowed for queue string.string

Cause: An attempt was made to enqueue to a non-persistent queue with sequence deviation specified.

Action: Do not specify sequence deviation.

ORA-25220 enqueue failed, signature not specified for a non-repudiable queue

Cause: An attempt was made to enqueue to a non-repudiable queue without specifying the signature.

Action: Specify the signature.

ORA-25221 enqueue failed, signature specified queue not supporting non-repudiation

Cause: An attempt was made to enqueue to a queue specifying the signature for a queue not supporting non-repudiation.

Action: Remove the signature.

ORA-25222 enqueue failed, complete sender info. not provided for a queue supporting non-repudiation

Cause: An attempt was made to enqueue to a queue without giving the complete sender information (name) for a queue supporting non-repudiation.

Action: Provide the sender information.

ORA-25223 user_data type used is not supported

Cause: An attempt was made to enqueue data into a non persistent queue that is of a type other than the supported raw or object type.

Action: Enqueue the message again with data of raw or object type.

ORA-25224 sender name must be specified for enqueue into secure queues

Cause: An attempt was made to enqueue into a secure queue without specifying a sender name.

Action: Enqueue the message with sender name specified.

ORA-25225 invalid value string, DEQUEUE_MODE should be REMOVE or BROWSE or LOCKED

Cause: An invalid parameter has been specified for DEQUEUE_MODE.

Action: Specify either REMOVE, BROWSE or LOCKED.

ORA-25226 dequeue failed, queue string.string is not enabled for dequeue

Cause: The queue has not been enabled for dequeue.

Action: Enable the queue using START_QUEUE.

ORA-25228 timeout or end-of-fetch during message dequeue from string.string

Cause: User-specified dequeue wait time has passed or the end of the queue has been reached but no message has been retrieved.

Action: Try dequeue again with the appropriate WAIT_TIME or the FIRST_MESSAGE option.

ORA-25229 error on transformation of message string string

Cause: There was an error when transforming a message at enqueue, dequeue, or propagation time.

Action: Correct the transformation function.

ORA-25230 invalid value string, WAIT should be non-negative

Cause: A negative value has been specified for WAIT.

Action: Specify a non-negative value or FOREVER.

ORA-25231 cannot dequeue because CONSUMER_NAME not specified

Cause: A user tried to dequeue from a queue that has been created for multiple consumers but a CONSUMER_NAME was not been specified in the dequeue options.

Action: Specify the CONSUMER_NAME in the dequeue options.

ORA-25232 duplicate recipients specified for message

Cause: An enqueue was performed with duplicate queue agents in the recipients parameter.

Action: Remove the duplicate queue agent and retry the call.

ORA-25233 invalid parameter specified for NAVIGATION

Cause: An invalid parameter has been specified for NAVIGATION.

Action: Choose one of FIRST_MESSAGE, NEXT_MESSAGE or NEXT_TRANSACTION. Use FIRST_MESSAGE for dequeuing the first message that satisfies the criterion, NEXT_MESSAGE for dequeuing the next message that satisfies the criterion and NEXT_TRANSACTION for moving to a set of messages enqueued by another transaction.

ORA-25234 NEXT_TRANSACTION navigation option invalid for queue table string.string

Cause: The NEXT_TRANSACTION navigation option was used in a dequeue from a queue in a queue table that was not created for transactional grouping.

Action: Specify either FIRST_MESSAGE or NEXT_MESSAGE as the navigation option. If you want to dequeue messages using transactional grouping create the queue in a queue table that has transactional grouping enabled.

ORA-25235 fetched all messages in current transaction

Cause: The NEXT_TRANSACTION navigation option was used in a dequeue when there were no more messages that belong to the same transaction.

Action: Use the NEXT_TRANSACTION navigation option to move to the next also use the FIRST_MESSAGE option to start from the head of the queue again.

ORA-25236 buffer too small for user data

Cause: The variable or buffer used for the out parameter payload is too small for the user data dequeued.

Action: Increase the size of the buffer or the size of the variable. Maximum size allowed is 32K.

ORA-25237 navigation option used out of sequence

Cause: The NEXT_MESSAGE or NEXT_TRANSACTION option was specified after dequeuing all the messages.

Action: Reset the dequeuing position using the FIRST_MESSAGE navigation option and then specify the NEXT_MESSAGE or NEXT_TRANSACTION option.

ORA-25238 too many recipients specified for message destination string

Cause: An ENQUEUE was performed with more than 32 recipients for the given destination (address).

Action: Reduce the number of recipients to 32 or less, and retry the call.

ORA-25239 message ID not supplied when dequeuing from exception queue string.string

Cause: An attempt was made to dequeue from a release 8.0-compatible exception queue without including a message ID in the dequeue options.

Action: Check the application to ensure that the queue name has been specified correctly. If the queue name is correct supply a message ID when dequeuing from a release 8.0-compatible exception queue. Otherwise, upgrade the QUEUE_TABLE containing the queue to release 8.1-compatible using the DBMS_AQADM.MIGRATE_QUEUE_TABLE procedure.

ORA-25240 message ID and dequeue condition/correlation ID specified in dequeue options

Cause: An attempt was made to dequeue by including both a message ID and a dequeue condition/correlation ID in the dequeue options. In the dequeue options, you are permitted to specify either a message ID or a dequeue condition/correlation ID, or neither.

Action: To dequeue a message, specify a message ID or a dequeue condition/correlation ID in the dequeue options, but do not specify both. If you want to dequeue in the queue's sort order, then do not specify either the message ID or dequeue condition/correlation ID in the dequeue options.

ORA-25241 cannot change correlation ID from string to string without FIRST_MESSAGE option

Cause: An attempt was made to change the correlation ID while using the NEXT_MESSAGE or NEXT_TRANSACTION option for dequeuing.

Action: To use a correlation ID that is different from the previous dequeue call, reset the dequeuing position by using the FIRST_MESSAGE navigation option.

ORA-25242 cannot change subscriber name from string to string without FIRST_MESSAGE option

Cause: An attempt was made to change the subscriber name while using the NEXT_MESSAGE or NEXT_TRANSACTION option for dequeuing.

Action: To use a subscriber name that is different from the previous dequeue call, reset the dequeuing position by using the FIRST_MESSAGE navigation option.

ORA-25243 CONSUMER_NAME cannot be specified when dequeuing from exception queue string.string

Cause: An attempt was made to dequeue from an exception queue by specifying the CONSUMER_NAME in the dequeue options. CONSUMER_NAME can only be specified when dequeuing from a normal queue created for multiple consumers.

Action: Specify only the message ID in the dequeue options to dequeue a message from an exception queue.

ORA-25244 dequeue index key not found, QUEUE string, rowid string

Cause: An internal error was encountered. There may be an inconsistency in the queue table index.

Action: Contact Oracle Support Services. You may need to provide the trace file and information about reproducing the error.

ORA-25245 agent name cannot be specified if address is a single-consumer queue or an exception queue

Cause: The agent name for the agent in the LISTEN call was specified when the agent address was a single-consumer queue or an exception queue.

Action: Do not specify the agent name.

ORA-25246 listen failed, the address string is an 8.0 style exception queue

Cause: An 8.0 style exception queue was specified in the agent-list for the LISTEN call.

Action: Specify a normal 8.0 style queue or an 8.1 style queue in the agent-list.

ORA-25247 string is not a recipient of specified message

Cause: The consumer name specified in the dequeue options is not a recipient of the message specified by the message ID.

Action: Ensure that the agent specified by the consumer name is a recipient of the message specified by the message ID.

ORA-25248 duplicate agent specified in the agent list

Cause: An agent was specified more than once in the agent list of the LISTEN call.

Action: Remove the duplicate agent specification(s), and retry the call.

ORA-25249 dequeue failed, dequeue not allowed for queue string.string

Cause: An attempt was made to dequeue from a non-persistent queue.

Action: Dequeue from a different queue.

ORA-25250 Cannot specify a remote recipient for the message

Cause: A recipient for the message enqueued to a non-persistent queue had a non-local address.

Action: Do not specify the address field or specify the queue which is the target of the enqueue

ORA-25251 exceeded maximum number of recipients for message

Cause: An attempt was made to issue an ENQUEUE call that exceeded the maximum number (1024) of recipients per message.

Action: Reduce the number of recipients to 1024 or less, and retry the call.

ORA-25252 listen failed, the address string is a non-persistent queue

Cause: A non-persistent queue was specified as an address for an agent in the LISTEN call.

Action: Specify a normal queue as address for the agent, and retry the LISTEN call.

ORA-25253 listen failed, queue string.string is not enabled for dequeue

Cause: An attempt was made to specify a queue that is not enabled for dequeue in a LISTEN call.

Action: Enable the queue for dequeue using START_QUEUE, and retry the LISTEN call.

ORA-25254 time-out in LISTEN while waiting for a message

Cause: The specified wait time has elapsed and there were no messages for any of the agents in the agent-list.

Action: Try the LISTEN call with an appropriate time-out.

ORA-25255 incorrect subscription string string

Cause: An incorrect subscription string was specified with OCIRegister.

Action: Specify a subscription string using the [CONSUMER:]SCHEMA.QUEUE form.

ORA-25256 consumer cannot be specified with a single-consumer queue or an exception queue

Cause: An attempt was made to specify a consumer in the subscription string when registering for notification on a single-consumer queue or an exception queue.

Action: Do not specify the consumer in the subscription string.

ORA-25257 consumer must be specified with a multi-consumer queue

Cause: An attempt was made to register on a multi-consumer queue without specifying a consumer in the subscription string.

Action: Specify a consumer in the subscription string.

ORA-25258 cannot register for notifications on an 8.0 style exception queue

Cause: An attempt was made to specify an 8.0 style exception queue in the subscription string of OCIRegister.

Action: Specify a normal queue or a non-persistent queue.

ORA-25259 cannot specify protocol for agent

Cause: The user specified the protocol attribute for an agent in the agent list.

Action: Do not specify the protocol attribute of the agent object type.

ORA-25261 JOB_QUEUE_PROCESSES must be at least 2 for AQ propagation

Cause: AQ Propagator encountered a setting for JOB_QUEUE_PROCESSES that is insufficient for AQ propagation.

Action: Set the number of JOB_QUEUE_PROCESSES to at least 2 for AQ propagation.

ORA-25262 agent name cannot be NULL if address is a multi-consumer queue

Cause: The name for the agent in the LISTEN call was not specified when the agent address was a multi-consumer queue.

Action: Specify a non-NULL name for the agent.

ORA-25263 no message in queue string.string with message ID string

Cause: An attempt was made to dequeue a message with a specific message ID, but no such message exists in the queue.

Action: Try dequeue again with a valid message ID.

ORA-25264 can't get signature for this queue

Cause: An attempt was made to dequeue the signature from this queue, which is not reciever non-repidiable.

Action: Try dequeue again without the get signature option.

ORA-25265 specified signature for a queue which does not support reciever non-repudiation

Cause: An attempt was made to dequeue the message from a queue which does not support reciever non-repudiation, but the signature was specified for verification.

Action: Try dequeue again without the signature.

ORA-25266 didn't try to dequeue by message id with the signature

Cause: The signature was specified for a queue, but the dequeue was not done by message id.

Action: Try dequeue again by message id.

ORA-25267 didn't specify the signature for a reciever non-repudiable queue

Cause: The signature was not specified for a reciever non-repudiable queue.

Action: Try dequeue again along with the signature.

ORA-25268 didn't dequeue in browse mode with get signature option

Cause: The dequeue was not performed in browse mode with get signature option.

Action: Try dequeue again in browse mode.

ORA-25269 can't specify signature with get signature option

Cause: The signature is not required for the dequeue with get signature option.

Action: Try dequeue again without the signature in dequeue options.

ORA-25270 sender info does not match with the actual sender of the message

Cause: The sender info and the message id do not match.

Action: Provide the correct sender info or try dequeue again without the signature in dequeue options.

ORA-25271 queue table not found for the given queue

Cause: The queue table does not exist for the given queue.

Action: Provide the correct queue name.

ORA-25272 Signature does not exist for the given reciever and message id

Cause: Signature does not exist for the given reciever and message id.

Action: Check the message id and the reciever's information.

ORA-25276 table specified is not a queue table

Cause: An invalid queue table name is specified.

Action: Check the dictionary views to see if the table is a queue table.

ORA-25277 cannot grant or revoke object privilege on release 8.0 compatible queues

Cause: An attempt was made to grant or revoke object privilege on release 8.0 style queues.

Action: Convert the release 8.0 compatible queue table to release 8.1 compatible using DBMS_AQADM.MIGRATE_QUEUE_TABLE before granting or revoking object privilege.

ORA-25278 grantee name cannot be NULL

Cause: An attempt was made to specify NULL for the grantee parameter.

Action: Specify a valid grantee parameter.

ORA-25279 dequeue as select not supported before 9.0.0

Cause: Dequeue as select not supported before 9.0.0.

Action: Don't use select condition while dequeuing.

ORA-25280 complete sender information not provided to non-repudiate sender

Cause: Complete sender information not provided to non-repudiate sender.

Action: Provide the complete sender information.

ORA-25281 complete reciever information not provided to non-repudiate reciever

Cause: Complete reciever information not provided to non-repudiate reciever.

Action: Provide the complete reciever information.

ORA-25282 message id not provided for non-repudiation

Cause: Message id was not provided.

Action: Provide the message id.

ORA-25283 either agent's name or address needed for non-repudiation

Cause: neither agent's name nor address provided for non-repudiation.

Action: Provide the agent info.

ORA-25284 Invalid value string for string

Cause: An Invalid value or NULL was specified for the parameter.

Action: Check the documentation for valid values.

ORA-25285 Invalid value string for array_mode

Cause: An Invalid value or NULL was specified for the array_mode.

Action: Check the documentation for valid values.

ORA-25286 Invalid number of elements in the message properties array

Cause: Number of elements in the message properties array does not match the number of elements in the payload array.

Action: Create a message property array with one element (that applies for all the elements in the payload array) or create a message property array with the same number of elements as there are in the payload array.

ORA-25287 Invalid value string, string should be non-negative

Cause: An Invalid value or NULL was specified for the parameter.

Action: Specify a non negative integer.

ORA-25288 AQ HTTP propagation encountered error, status-code number, string

Cause: AQ propagation's HTTP request to the propagation servlet at the specified address encountered an error.

Action: Specify a valid address in the connect string of the propagation destination dblink, make sure the dblink user has the correct permissions, and check if the AQ propagation servlet was properly installed.

ORA-25289 Buffer Already Exists

Cause: Buffer already exists for the specified queue.

Action: No action required.

ORA-25290 Cannot complete operation on queue string with existing messages

Cause: Queue already has messages. Cannot complete operation.

Action: Truncate the queue before adding/dropping a buffer.

ORA-25291 Buffer does not exist for the specified queue

Cause: Buffer does not exist for the specified queue.

Action: Operation on the buffer cannot be performed. create the buffer.

ORA-25292 Cannot add buffer on the specified queue

Cause: Buffer cannot be added on the Specified Queue.

Action: Can only add buffers to 8.1 style non-exception multi-consumer queues, which do not have priority, non_repudiation, message_grouping, max_retries, and retention.

ORA-25293 Remote Recipient Subscribers and buffered operations not possible for Queue string

Cause: Specified Queue has remote recipient subscribers.

Action: Cannot add buffers/add buffered subscribers to queues with remote recipient subscribers.

ORA-25294 Queue string has a buffer

Cause: Specified Queue has a buffer.

Action: Drop the buffer first.

ORA-25295 Subscriber is not allowed to dequeue buffered messages

Cause: Subscriber is only allowed to dequeue persistent messages.

Action: Drop the subscriber and re-create it.

ORA-25296 Queue Table string has a buffered queue string

Cause: Cannot downgrade the queue table because it has a buffered queue.

Action: Drop the buffer or the buffered queue.

ORA-25297 The message options only make sense for buffered messages

Cause: The message options only make sense for buffered messages.

Action: Check the enqueue/dequeue options.

ORA-25298 The memory threshold for a queue cannot be negative

Cause: The memory threshold for a queue cannot be negative.

Action: Correct the memory threshold.

ORA-25299 Cannot add buffered subscriber for a non-buffered queue

Cause: Cannot add buffered subscriber for a non-buffered queue.

Action: Either add buffer to the queue, or make the subscriber non-buffered.

ORA-25300 Cannot drop buffer for queue with buffered subscribers

Cause: Cannot drop buffer for queue with buffered subscribers.

Action: Either drop buffered subscribers or forcibly drop the buffer.

ORA-25301 cannot specify recipient list during enqueue

Cause: Recipient list for buffered queue not supported.

Action: Don't specify recipient list for buffered enqueues.

ORA-25302 Operation not possible for non-buffered queue string

Cause: Last enqd/ackd message is only supported for buffered queues.

Action: The operation is not supported.

ORA-25350 maximum number of concurrent transaction branches exceeded

Cause: The limit on the number of concurrent transaction branches has been reached.

Action: Increase the initialization parameter TRANSACTIONS and restart the system.

ORA-25351 transaction is currently in use

Cause: The transaction is currently used by a different session.

Action: Do not switch to a transaction attached to some other session.

ORA-25352 no current transaction

Cause: The user session is not attached to any transaction.

Action: Do not attempt to detach when there is no current transaction.

ORA-25353 branch marked for deletion

Cause: The branch specified cannot be killed immediately because another session is using the branch, but it has been marked for kill. This means it will be deleted as soon as possible after the current uninterruptable operation is completed.

Action: No action is required for the branch to be deleted.

ORA-25400 must replay fetch

Cause: A failure occurred since the last fetch on this statement. Failover was able to bring the statement to its original state to allow continued fetches.

Action: This is an internally used error message and should not be seen by the user.

ORA-25401 can not continue fetches

Cause: A failure occurred since the last fetch on this statement. Failover was unable to bring the statement to its original state to allow continued fetches.

Action: Re-execute the statement and start fetching from the beginning.

ORA-25402 transaction must roll back

Cause: A failure occurred while a transaction was active on this connection.

Action: The client must roll back.

ORA-25403 could not reconnect

Cause: The connection to the database has been lost, and attempts to reconnect have failed.

Action: Manually reconnect.

ORA-25404 lost instance

Cause: The primary instance has died.

Action: This is an internally used error message and should not be seen by the user.

ORA-25405 transaction status unknown

Cause: A failure occurred while a transaction was attempting to commit. Failover could not automatically determine instance status.

Action: The user must determine the transaction's status manually.

ORA-25406 could not generate a connect address

Cause: Failover was unable to generate an address for a backup instance.

Action: Contact Oracle Support Services.

ORA-25407 connection terminated

Cause: The connection was lost while doing a fetch.

Action: This is an internally used error message and should not be seen by the user.

ORA-25408 can not safely replay call

Cause: The connection was lost while doing this call. It may not be safe to replay it after failover.

Action: Check to see if the results of the call have taken place, and then replay it if desired.

ORA-25425 connection lost during rollback

Cause: The connection was lost while issuing a rollback.

Action: If the transaction is not externally coordinated, then Oracle implicitly rolled back, so no action is required. Otherwise examine PENDING_TRANS$ to determine if ROLLBACK FORCE is required.

ORA-25426 remote instance does not support shared dblinks

Cause: A shared database link is being used to connect to a remote instance that does not support this feature because it is an older version.

Action: Use a normal database link if you need to connect to this instance.

ORA-25436 invalid table alias: string

Cause: An attempt to evaluate was made, which failed because one of the table values specified had an invalid alias.

Action: Check the valid table aliases in the evaluation context, and try again with a valid alias.

ORA-25437 duplicate table value for table alias: string

Cause: An attempt to evaluate was made, which failed because some of the table values specified had the same table alias.

Action: Check the table values specified, and try again with only one value per table.

ORA-25438 invalid variable name: string

Cause: An attempt to evaluate was made, which failed because one of the variable values specified had an invalid name.

Action: Check the valid variable names in the evaluation context, and try again with a valid name.

ORA-25439 duplicate variable value for variable: string

Cause: An attempt to evaluate was made, which failed because some of the variable values specified had the same variable name.

Action: Check the variable names specified, and try again with only one value per variable.

ORA-25440 invalid table alias: string

Cause: An attempt to evaluate was made, which failed because one of the column values specified had an invalid table alias.

Action: Check the valid table aliases in the evaluation context, and try again with a valid name.

ORA-25441 duplicate column value for table alias: string

Cause: An attempt to evaluate was made, which failed because one of the column values supplied a value for a table alias, which already had a table value supplied.

Action: Check the table and column values specified, and try again with either a table value or column values for each table alias.

ORA-25442 too many column values for table alias: string

Cause: An attempt to evaluate was made, which failed because too many column values were supplied for the specified table alias.

Action: Check the column values specified, and try again with the right number of column values.

ORA-25443 duplicate column value for table alias: string, column number: string

Cause: An attempt to evaluate was made, which failed because duplicate column values were supplied for the specified table alias and column number.

Action: Check the column values specified, and try again with only one column value for each table alias and column number.

ORA-25444 invalid ROWID: string for table alias: string

Cause: An attempt to evaluate was made, which failed because an invalid ROWID was supplied for the specified table alias.

Action: Check the column values specified, and try again with only one column value for each table alias and column number.

ORA-25445 invalid column number: string for table alias: string

Cause: An attempt to evaluate was made, which failed because an invalid column number was supplied for the specified table alias as a part of a column value.

Action: Check the column values specified, and try again with a valid column number.

ORA-25446 duplicate column value for table alias: string, column: string

Cause: An attempt to evaluate was made, which failed because duplicate column values were supplied for the specified table alias and column name.

Action: Check the specified column values, and try again with only one column value for each table alias and column name.

ORA-25447 encountered errors during evaluation of rule string.string

Cause: An attempt to evaluate was made, which failed during the evaluation of the specified rule.

Action: Check the rule and the values passed to evaluate, and try again with valid values.

ORA-25448 rule string.string has errors

Cause: An attempt to load the specified rule failed due to errors in the rule.

Action: Check the rule and retry the operation.

ORA-25461 rule set not specified

Cause: An attempt to evaluate was made, which failed because the ruleset name specified was null.

Action: Check the rule set name, and try again with a valid name.

ORA-25462 evaluation context not specified

Cause: An attempt to evaluate was made, which failed because the evaluation context specified was null.

Action: Check the evaluation context name, and try again with a valid name.

ORA-25463 table alias not specified

Cause: An attempt to evaluate was made, which failed because one of the table values specified had a NULL alias name.

Action: Check the list of table values, and try again with a valid alias name.

ORA-25464 ROWID not specified for table alias: string

Cause: An attempt to evaluate was made, which failed because the table value for the specified table alias had a NULL ROWID.

Action: Check the list of table values, and try again with a valid ROWID.

ORA-25465 variable name not specified

Cause: An attempt to evaluate was made, which failed because one of the variable values specified had a NULL variable name.

Action: Check the list of variable values, and try again with a valid variable name.

ORA-25466 data not specified for variable name: string

Cause: An attempt to evaluate was made, which failed because the variable value for the specified variable name had NULL data.

Action: Check the list of variable values, and try again with valid data.

ORA-25467 table alias not specified

Cause: An attempt to evaluate was made, which failed because one of the column values specified had a NULL alias name.

Action: Check the list of column values, and try again with a valid alias name.

ORA-25468 column name not specified for alias: string

Cause: An attempt to evaluate was made, which failed because one of the column values for the specified alias name had a NULL column name.

Action: Check the list of column values, and try again with a valid column name.

ORA-25469 data not specified for alias: string column name: string

Cause: An attempt to evaluate was made, which failed because the column value for the specified alias and column name had NULL data.

Action: Check the list of column values, and try again with valid data.

ORA-25500 database is not open

Cause: Database must be open to perform ALTER SYSTEM QUIESCE RESTRICTED command.

Action: Open the database and retry this command.

ORA-25501 ALTER SYSTEM QUIESCE RESTRICTED command failed

Cause: Database resource manager failed to change plan.

Action: Look at the alert logs to see a detailed description of the error.

ORA-25502 concurrent ALTER SYSTEM QUIESCE/UNQUIESCE command is running

Cause: There is a concurrent ALTER SYSTEM QUIESCE RESTRICTED or ALTER SYSTEM UNQUIESCE command running in the system.

Action: Contact the database administrator who is responsible for the concurrent command.

ORA-25503 cannot open database because the database is being quiesced

Cause: Database cannot be opened because the system is being or has been quiesced.

Action: Open the database after the system has been quiesced.

ORA-25504 the system is already in quiesced state

Cause: Cannot quiesce the system because the system is already quiesced.

ORA-25505 the system is not in quiesced state

Cause: Cannot unquiesce the system because the system is not in quiesced state.

ORA-25506 resource manager has not been continuously on in some instances

Cause: Cannot quiesce the system because resource manager has not been continuously on since startup in this or some other instances.

ORA-25507 resource manager has not been continuously on

Cause: Cannot quiesce the system because resource manager has not been continuously on since startup.

ORA-25508 database is not mounted

Cause: Database must be mounted to perform ALTER SYSTEM UNQUIESCE command.

Action: Mount the database and retry this command.

ORA-25509 operation on "string"."string".string not allowed

Cause: A column has been added to a replicated table, but replication support processing has not completed.

Action: Wait until replication support processing has completed before updating the column.

ORA-25526 bad format of _DB_MTTR_SIM_TARGET: string

Cause: One value in _DB_MTTR_SIM_TARGET is not a valid MTTR.

Action: Alter the value of _DB_MTTR_SIM_TARGET.

ORA-25527 bad format of _DB_MTTR_SIM_TARGET

Cause: One value in _DB_MTTR_SIM_TARGET is empty.

Action: Set the value of _DB_MTTR_SIM_TARGET properly.

ORA-25528 too many candidate MTTRs are specified in _DB_MTTR_SIM_TARGET

Cause: Too many candidate MTTRs are specified in _DB_MTTR_SIM_TARGET.

Action: Alter the value of _DB_MTTR_SIM_TARGET.

ORA-25530 FAST_START_MTTR_TARGET is not specified

Cause: An attempt to start MTTR advisory was made, which failed because FAST_START_MTTR_TARGET was not specified.

Action: Set FAST_START_MTTR_TARGET.

ORA-25531 MTTR specified is too small: number

Cause: The current FAST_START_MTTR_TARGET setting or a candidate MTTR setting is too small for MTTR advisory.

Action: Set a larger FAST_START_MTTR_TARGET or candidate MTTR.

ORA-25532 MTTR specified is too large: number

Cause: The current FAST_START_MTTR_TARGET setting or a candidate MTTR setting is too large for MTTR advisory.

Action: Set a smaller FAST_START_MTTR_TARGET or candidate MTTR.

ORA-25950 missing where clause in join index specification

Cause: An attempt to create a join index was made, which failed because no valid where clause was found.

Action: Ensure that a where clause with valid join conditions is specified in the create index statement.

ORA-25951 join index where clause cannot contain OR condition

Cause: An attempt to create a join index was made, which failed because there was an OR branch in the where clause.

Action: Reformulate the where clause without using ORs.

ORA-25952 join index must only contain inner equi-joins

Cause: An attempt to create a join index was made, which failed because it included a predicate which wasn't an equi-inner join.

Action: Remove the inappropriate predicate.

ORA-25953 join index cannot be a functional index

Cause: An attempt to create a join index was made, which failed because a functional index was requested or necessary (such as is the case for indexing columns using timezone).

Action: Remove any functional indexing columns.

ORA-25954 missing primary key or unique constraint on dimension

Cause: An attempt to create a join index was made, which failed because one or more dimensions did not have an appropriate constraint matching the join conditions.

Action: Ensure that the where clause is correct (contains all of the constraint columns) and that an enforced constraint is on each dimension table.

ORA-25955 all tables must be joined in the where clause

Cause: An attempt to create a join index was made, which failed because one of the tables in the from clause did not appear in the where clause.

Action: Ensure that the where clause contains all from clause tables.

ORA-25956 join index cannot be created on tables owned by SYS

Cause: An attempt to create a join index was made, which failed because one of the tables was owned by SYS.

Action: Ensure that no join index related table is owned by SYS.

ORA-25957 join index where clause cannot contain cycles

Cause: An attempt to create a join index was made, which failed because the where clause contains a cycle.

Action: Ensure that the where clause is in the form of a star or snowflake schema.

ORA-25958 join index where clause predicate may only contain column references

Cause: An attempt to create a join index was made, which failed because a predicate in the where clause contained something other than a simple column.

Action: Ensure that the where clause only contains columns.

ORA-25959 join index must be of the bitmap type

Cause: An attempt to create a join index was made, which failed because no bitmap keyword was used.

Action: Make the index a bitmap index.

ORA-25960 join index cannot be based on a temporary table

Cause: An attempt to create a join index was made, which failed because one of the tables was temporary.

Action: Ensure no underlying tables are temporary.

ORA-25961 join index prevents dml cascade constraint operation

Cause: An attempt to execute dml resulted in the need to perform dml on another table because of a cascade constraint. The join index only allows one of its underlying tables to me modified at a time.

Action: Drop the join index or remove the constraint.

ORA-25962 join index prevents multitable insert or merge

Cause: An attempt to execute an merge or multitable insert on a table that was used to create a bitmap join index was made. Merge and multitable inserts are not supported on tables that were used to create a bitmap join index.

Action: Drop the join index.

ORA-25963 join index must be created on tables

Cause: An attempt to create a join index was made, which failed because the from clause contains non table object.

Action: Ensure that the from clause only contains tables.

ORA-25964 column type incompatible with join column type

Cause: The datatype of the join column is incompatible with the datatype of the joined column.

Action: Select a compatible datatype for the join column.

ORA-26000 partition load specified but table string is not partitioned

Cause: The Loader control file contains a PARTITION clause but the table being loaded is not partitioned.

Action: Remove the partition specification from the SQL*Loader control file and retry the load.

ORA-26001 Index string specified in SORTED INDEXES does not exist on table string

Cause: A non-existent index was specified in the SORTED INDEXES clause.

Action: Do not specify as a SORTED INDEX.

ORA-26002 Table string has index defined upon it.

Cause: Parallel load was specified into a table which has index defined upon it.

Action: Drop index(es) defined upon table, or do not use parallel load, or use SKIP_INDEX_MAINTENANCE option.

ORA-26003 parallel load not supported for index-organized table string

Cause: Parallel load is not supported for index-organized tables.

Action: Load the index-organized table without the PARALLEL option.

ORA-26004 Tables loaded through the direct path may not be clustered

Cause: An attempt was made to load a clustered table via the direct path.

Action: Use the conventional path.

ORA-26005 Invalid handle for direct path load

Cause: In direct path load, the handle passed in does not match the type listed.

Action: Verify the handle and type are correct.

ORA-26006 Incorrect bind variable in column string's sql expression - string

Cause: In direct path load, the bind variables listed in the sql expression do not match the input argument column names.

Action: Verify all the input arguments are listed in the expression as bind variables, and all the bind variables are listed as input arguments to the expression. Or verify that there were no errors in executing the OCI statements when getting the bind variable list.

ORA-26007 For INSERT option, table must be empty. Error on table string

Cause: The user tried to use the INSERT option on a non-empty table.

Action: Empty the table from SQL*Plus, or use the REPLACE option.

ORA-26008 NOT NULL column string has a nullif clause

Cause: A column which is NOT NULL in the database has a SQL*Loader NULLIF clause on it.

Action: Remove the NULLIF clause in the SQL*Loader control file.

ORA-26009 NOT NULL column string has a defaultif clause which may evaluate to null

Cause: A column which is NOT NULL in the database has a SQL*Loader DEFAULTIF clause which may evaluate to null.

Action: Remove the DEFAULTIF clause in the SQL*Loader control file.

ORA-26010 Column string in table string is NOT NULL and is not being loaded

Cause: A column which is NOT NULL in the database is not being loaded and will cause every row to be rejected.

Action: Load the column by specifying the NOT NULL column in the INTO TABLE clause in the SQL*Loader control file.

ORA-26011 Cannot load type string into column string in table string

Cause: A column can only store data of type declared for that column and a substitutable column can only store data of valid subtypes of the supertype declared for that column.

Action: Check that the type or subtype specified is valid for that column.

ORA-26012 No data found while executing sql statement string for column string - check input for: string

Cause: Executing sql statement against the data dictionary tables returned "ORA-01403: no data found".

Action: No data retrieved when selecting against the data dictionary tables most likely means that there's an error in user input. Check that the input listed is correct.

ORA-26013 List allocated may not be big enough

Cause: There seems to be a discrepancy between the size for a list or buffer allocated by direct path api and the size needed.

Action: Contact Oracle Support Services.

ORA-26014 OCI_ATTR_DIRPATH_SUBST_OBJ_TBL is set for non-final object table string

Cause: Client set OCI_ATTR_DIRPATH_SUBST_OBJ_TBL for either a non-object table or for a final object table. This attribute can only be, and must be, set for non-final object tables.

Action: Check the type of the loading table. Do not set this attribute if the table is not a non-final object table.

ORA-26015 Array column string in table string is not supported by direct path

Cause: User attempted to load an array column via the direct path.

Action: Use the conventional path.

ORA-26016 Record string: Rejected - Error on table string, partition string

Cause: The record indicated caused an Oracle error on insert.

Action: Determine the Oracle error and correct the record. The offending column(s) are not known.

ORA-26017 Global indexes not allowed on direct path partition load, table string

Cause: Global indexes are defined on a table when direct path loading a single partition of the table.

Action: Remove the global index from the named table and retry the operation.

ORA-26018 Column string in table string does not exist

Cause: Column specified in the loader control file does not exist.

Action: Make sure the column exists and that you have privileges on it. Correct the loader control file if it is wrong.

ORA-26019 Column string in table string of type string not supported by direct path

Cause: The specified column of SQL column type string is not supported by the direct path loader.

Action: If the column is NULLable, remove it from the control file description. Then it will be loaded as a NULL.

ORA-26020 index string.string loaded successfully with string keys

Cause: Non-partitioned index information put to loader log file.

Action: No action required. This is an informational message.

ORA-26021 index string.string partition string loaded successfully with string keys

Cause: Partitioned index information put to loader log file.

Action: No action required. This is an informational message.

ORA-26022 index string.string was made unusable due to:

Cause: A non-partitioned index was made index unusable due to the error displayed below this error.

Action: Depending on the error, either rebuild the index, or drop and re-create it.

ORA-26023 index string.string partition string was made unusable due to:

Cause: A partition of a partitioned index was made index unusable due to error displayed below this error.

Action: Depending on the error, either rebuild the index partition, or drop and re-create the entire index.

ORA-26024 SKIP_UNUSABLE_INDEXES requested and index segment was initially unusable

Cause: User requested SKIP_UNUSABLE_INDEXES option, and the index segment was in unusable state prior to the beginning of the load.

Action: Informational only. User will need to either rebuild the index or index partition, or re-create the index.

ORA-26025 SKIP_INDEX_MAINTENANCE option requested

Cause: A request was made that index maintenance be skipped on a direct path load.

Action: The listed index was put into Index Unusable state due to the user requesting that index maintenance be skipped. Either rebuild the index or index partitions, or drop and re-create the index.

ORA-26026 unique index string.string initially in unusable state

Cause: A unique index is in IU state (a unique index cannot have index maintenance skipped via SKIP_UNUSABLE_INDEXES).

Action: Either rebuild the index or index partition, or use SKIP_INDEX_MAINTENANCE if the client is SQL*Loader.

ORA-26027 unique index string.string partition string initially in unusable state

Cause: A partition of a unique index is in IU state (a unique index cannot have index maintenance skipped via SKIP_UNUSABLE_INDEXES).

Action: Either rebuild the index or index partition, or use SKIP_INDEX_MAINTENANCE if the client is SQL*Loader.

ORA-26028 index string.string initially in unusable state

Cause: An index is in IU state prior to the beginning of a direct path load, it cannot be maintained by the loader.

Action: Either rebuild the index, re-create the index, or use either SKIP_UNUSABLE_INDEXES or SKIP_INDEX_MAINTENANCE (SQL*Loader only).

ORA-26029 index string.string partition string initially in unusable state

Cause: A partition of an index is in IU state prior to the beginning of a direct path load, it cannot be maintained by the loader.

Action: Either rebuild index partition, re-create the index, or use either SKIP_UNUSABLE_INDEXES or SKIP_INDEX_MAINTENANCE (SQL*Loader only).

ORA-26030 index string.string had string partitions made unusable due to:

Cause: A logical index error occurred on a partitioned index which affected one or more index partitions, which are listed below this message.

Action: The affected index partitions will have to be rebuilt, or, the entire index dropped and re-created.

ORA-26031 index maintenance error, the load cannot continue

Cause: A index error occurred during the index maintenance phase of a direct path load. The load cannot continue. See error message below this message.

Action: See action for the error message which follows this one.

ORA-26032 index string.string loading aborted after string keys

Cause: An index error occurred during direct-load of an index-organized table. Loading had to be aborted. No rows were loaded.

Action: Check the key just following the number of keys mentioned above. This key caused the index problem mentioned in an earlier message.

ORA-26033 error while evaluating index string.string, row string due to:

Cause: An index error occurred while attempting to evaluate an expression on a functional index.

Action: Verify that the input data is valid for the functional index.

ORA-26034 end of logical record found when reading length of varying length field

Cause: While attempting to read the length portion of a varying length field, then end of the logical record was reached.

Action: Verify that the control file describes the data correctly and that the data in the datafile matches the description in the control file

ORA-26035 Record string: Rejected - Error on table string, subpartition string

Cause: The record indicated caused an Oracle error on insert.

Action: Determine the Oracle error and correct the record. The offending column(s) are not known.

ORA-26036 subpartition load specified but table string is not subpartitioned

Cause: The Loader control file contains a PARTITION clause but the table being loaded is not subpartitioned.

Action: Remove the subpartition specification from the SQL*Loader control file and retry the load.

ORA-26037 Record string: Rejected - Error on table string, subpartition string

Cause: The record indicated caused an Oracle error on insert.

Action: Determine the Oracle error and correct the record. The offending column(s) are not known.

ORA-26038 error converting character length field to a number

Cause: An error occurred while attempting to convert the characters containing the count portion of a VARCHARC or VARRAWC field.

Action: Verify that the count portion for the field has the correct value.

ORA-26039 Table string has domain index defined upon it

Cause: Direct path load was specified for a table which has a domain index defined upon it.

Action: Drop domain index(es) defined on the table or use the conventional path.

ORA-26040 Data block was loaded using the NOLOGGING option

Cause: An attempt was made to access data in a block that was loaded without redo generation using the NOLOGGING/UNRECOVERABLE option.

Action: Drop the object containing the block.

ORA-26041 DATETIME/INTERVAL datatype conversion error

Cause: The column could not be converted from DATETIME datatype to internal DATETIME/CHARACTER datatype.

Action: Contact Oracle Support Services.

ORA-26042 unable to convert format string into internal form

Cause: An attempt to convert a DATETIME format string into internal format in preparation for DATETIME datatype processing failed.

Action: Contact Oracle Support Services.

ORA-26043 unable to convert time zone for DATETIME/INTERVAL processing

Cause: An attempt to convert the time zone specified by the ORA_STDZ environment variable to internal format failed.

Action: Verify that the setting for ORA_STDZ is valid.

ORA-26044 unable to to get DATETIME/INTERVAL reference date

Cause: An attempt to retrieve the system reference date for DATETIME/INTERVAL datatypes failed.

Action: Contact Oracle Support Services.

ORA-26045 REF column string expects string arguments; found string.

Cause: The number of arguments for the REF column is incorrect.

Action: Specify the correct number of input arguments for REFs.

  • Unscoped system-generated REFs can have exactly 1 or 2 input arguments.

    It has exactly 1 input argument (one for the OID value) if a fixed table name was specified through OCI_DIRPATH_EXPR_REF_TBLNAME.

    It has exactly 2 input arguments (one for the table name and one for the OID value) if a fixed table name was not specified through OCI_DIRPATH_EXPR_REF_TBLNAME.

  • Scoped system-generated REFs can have 1 or 2 input arguments.

    Because a table name argument is not needed for a scoped ref, only 1 argument (OID value) is expected. But if the table name argument is given, it's still accepted.

  • Scoped primary-key REFs with N columns in its primary-key OID can have N or N+1 input arguments.

    Because a table name argument is not needed for a scoped ref, only N arguments (making up the OID value) is expected. But if the table name argument is given, it's still accepted.

ORA-26046 REF column string expects scoped table name string; user passed in string.

Cause: The scoped table name passed in by the user does not match the name in the schema.

Action: Specify the correct table name for the scoped REF column.

ORA-26047 REF column has invalid value for system generated oid

Cause: The value passed in by the user for the system generated oid does not consist of valid hexadecimal digits.

Action: Specify a valid oid value for the REF column.

ORA-26048 Scoped REF column has wrong table name.

Cause: The scoped table name passed in by the user does not match the name in the schema.

Action: Specify the correct table name for the scoped REF column.

ORA-26049 Unscoped REF column has non-existent table name.

Cause: The table name passed in by the user does not exist in the schema.

Action: Specify a valid table name for the unscoped REF column.

ORA-26050 Direct path load of domain index is not supported for this column type.

Cause: Direct path can not load a domain index of that column type.

Action: Drop the index and try again or load using conventional path.

ORA-26051 internal error parsing packed decimal format string

Cause: A packed decimal field with a nonzero scale factor is mapped to a character column. In order to perform the datatype conversion, a numeric format string must be created based on the input field's precision and scale specifications. Direct path loader encountered an error in creating this format string.

Action: Examine the packed decimal field's precision and scale specifications and make sure that they contain valid values.

ORA-26052 Unsupported type number for SQL expression on column string.

Cause: The direct path api does not support a SQL expression on a column of that type.

Action: Make sure the types are correct.

ORA-26076 cannot set or reset value after direct path structure is allocated

Cause: Client attempted to set or reset the number of rows in a direct path structure after it has already been allocated and initialized. Attributes used is one of the following:

  • OCI_ATTR_NUM_ROWS: to set # of rows in a direct path column array
  • OCI_ATTR_DIRPATH_DCACHE_SIZE: to set size of a date cache (default is 0)
  • OCI_ATTR_DIRPATH_DCACHE_DISABLE: to set whether date cache will be disabled on overflow (default is FALSE)

Action: Set the following attributes before:

  • OCI_ATTR_NUM_ROWS: before calling OCIHandleAlloc for column array
  • OCI_ATTR_DIRPATH_DCACHE_SIZE: before calling OCIDirPathPrepare
  • OCI_ATTR_DIRPATH_DCACHE_DISABLE: before calling OCIDirPathPrepare

ORA-26077 direct path column array is not initialized

Cause: Client attempted to allocate a column array for a direct path function context before allocating a column array for the table-level direct path context.

Action: Allocate the table-level direct path context's column array via OCIHandleAlloc before allocating column arrays for direct path function contexts.

ORA-26078 file string is not part of database being loaded

Cause: A parallel load file was specified which is not part of the database.

Action: Check filename and pathname for correctness.

ORA-26079 file string is not part of table string.string

Cause: A parallel load file was specified which is not in the tablespace of the table being loaded.

Action: Check to make sure that the specified parallel load file is in the tablespace of the table being loaded.

ORA-26080 file string is not part of table string.string partition string

Cause: A parallel load file was specified which is not in the tablespace of the table (partition, subpartition) being loaded. When a partitioned table is being loaded, the file must be in the tablespace of every partition or subpartition (that is, each (sub)partition must be in the same tablespace).

Action: Specify a different parallel load file, or no file at all.

ORA-26081 load stream synchronization error

Cause: The row header flag byte contains an unexpected value, this indicates that an error has occurred in either the generation of, or the pushing of the load stream from the client to the server.

Action: Usually due to an application programming error when dealing with error handling, or not resetting the stream state.

ORA-26082 load of overlapping segments on table string.string is not allowed

Cause: Client application is attempting to do multiple direct path load operations on the same table, but the segments overlap.

Action: Check the partition names (subname attribute of the direct path context) being loaded. Make sure you are not loading a table and a partition of the same table. Make sure you are not loading a partition, and a sub-partition within the same partition.

ORA-26084 direct path context already finished

Cause: An OCIDirPathLoadStream operation was attempted after OCIDirPathFinish was called. Once a direct path operation has been finished, no more data can be loaded.

Action: Check program logic to make sure OCIDirPathLoadStream is not called after OCIDirPathFinish.

ORA-26085 direct path operation must start its own transaction

Cause: A direct path operation is being attempted within a transaction that has already been started.

Action: Commit the transaction and Prepare the direct path operation again.

ORA-26086 direct path does not support triggers

Cause: A direct path operation is being attempted on a table which has enabled triggers.

Action: Disable the triggers on the table and try again.

ORA-26087 direct path does not support referential constraints

Cause: A direct path operation was attempted on a table which has enabled referential integrity constraints.

Action: Disable the referential integrity constraints on the table and try again.

ORA-26088 scalar column 'string' must be specified prior to LOB columns

Cause: All scalar columns (that is, non-LOB and non-LONG columns) must be specified by the client of the direct path API prior to specifying any LOB columns.

Action: Specify all scalar columns prior to specifying any LOB columns.

ORA-26089 LONG column 'string' must be specified last

Cause: A client of the direct path API specified a LONG column to be loaded, but the LONG column was not the last column to be specified.

Action: Specify the LONG column last.

ORA-26090 row is in partial state

Cause: A direct path operation is being finished or a data save request has been made, but the table for which the request is being made on has a row in partial state. The row must be completed before the segment high water marks can be moved.

Action: Either complete the row, or abort the direct path operation.

ORA-26091 requested direct path operation not supported

Cause: A direct path operation was requested that is not supported

Action: Do not use that operation. Currently, UNLOAD is not supported.

ORA-26092 only LONG or LOB types can be partial

Cause: A column which is not a LONG or LOB had the OCI_DIRPATH_COL_PARTIAL flag associated with it. Only LONG or LOB type columns can be loaded in pieces.

Action: Do not use the OCI_DIRPATH_COL_PARTIAL flag for the column.

ORA-26093 stream offset does not map to a column array

Cause: The ROW_COUNT attribute was being read from a direct path stream handle and it was found that the stream offset for the last processed row did not map to a column array offset.

Action: Make sure the stream was sourced from a column array.

ORA-26094 stream format error: input column overflow

Cause: An input stream contained data for more input columns than specified by the client of the direct path API.

Action: Make sure that the stream being loaded is for the correct table. Check initialization sequence.

ORA-26095 unprocessed stream data exists

Cause: Either a OCIDirPathLoadStream call was made which provided more stream data prior to the server being able to fully process the stream data that it already has, or a OCIDirPathFinish call was made when the server had unprocessed stream data.

Action: Most likely an application misuse of the direct path API. Make sure that the stream is not being reset inadvertently prior to any previous stream data being processed, or, that OCIDirPathFinish is not being called prematurely (that is, stream pushed, error encountered and LoadStream not called to process the remainder of the stream before Finish is called).

ORA-26096 transfer size too small for row data (number bytes required)

Cause: Either the transfer buffer size specified, or the default transfer buffer size (if you did not specify a size), is too small to contain a single row of the converted row data.

Action: Set the transfer buffer size attribute of the direct path context to be larger.

ORA-26097 unsupported conversion for column string (from type number to type number)

Cause: The direct path API does not support the required conversion.

Action: Make sure the types are correct.

ORA-26098 direct path context is not prepared

Cause: A direct path API function was called with a direct path context which has not been prepared.

Action: Make sure all necessary attributes in the direct path context have been set, and the context is prepared via OCIDirPathPrepare.

ORA-26099 direct path context is already prepared

Cause: OCIDirPathPrepare was called with a context that has already been prepared.

Action: Free the direct path context, set necessary attributes, and call OCIDirPathPrepare.

ORA-26100: unused error

Cause: This error is not used.

Action: No action required.

ORA-26101 tablespace # in file header is string rather than string for file string

Cause: The tablespace number in the file header is inconsistent with that in the control file.

Action: Check if the control file has been migrated correctly. Retry with the correct control file and datafile.

ORA-26102 relative file # in file header is string rather than string for file string

Cause: The relative file number in the file header is inconsistent with that in the control file.

Action: Check if the control file has been migrated correctly. Retry with the correct control file and datafile.

ORA-26103 V6 or V7 data file used to create control file

Cause: The file header of the referenced file is in V6 or V7 format.

Action: Either remove the file from the create control file command, or somehow migrate the file header to V8 format.

ORA-26500 error on caching "string"."string"

Cause: Attempt to cache the replication information which is unavailable in the catalog for the object.

Action: Use DBMS_REPUTIL.SYNC_UP_REP to validate the replication catalog, or use DBMS_REPUTIL.MAKE_INTERNAL_PKG to validate internal package.

ORA-26501 RepAPI operation failure

Cause: An external RepAPI operation failed.

Action: Consult detail error message.

ORA-26502 error resignal

Cause: An internal service failed and signalled an error.

Action: Consult detail error message.

ORA-26503 internal RepAPI operation failure on object string.string

Cause: An unexpected internal RepAPI failure was detected.

Action: Contact Oracle Support Services.

ORA-26504 operation not implemented

Cause: The caller requested a RepAPI operation that was not implemented.

Action: Do not issue this call.

ORA-26505 unexpected internal null

Cause: An internal buffer control structure was NULL.

Action: Verify that sufficient memory resources are available to RepAPI.

ORA-26506 null global context

Cause: An internal buffer control structure was NULL.

Action: Verify that sufficient memory resources are available to RepAPI.

ORA-26507 null master connection

Cause: The master connection handle was or became invalid.

Action: Verify that the master connection is valid.

ORA-26508 null materialized view connection

Cause: The client connection handle was or became invalid.

Action: Verify that the client connection is valid.

ORA-26509 null materialized view control structure

Cause: An internal materialized view control structure could not be obtained.

Action: Check that the owner and users provided are correct.

ORA-26510 materialized view name: 'string' is greater than max. allowed length of string bytes

Cause: The specified materialized view name was too long.

Action: Shorten the materialized view name.

ORA-26511 master table 'string.string' not found

Cause: A RepAPI operation was attempted against a non-existent or invalid master table.

Action: Verify that the master table object exists.

ORA-26512 error pushing transaction to def$error

Cause: An unexpected error occurred while sending an DEF$ERROR RPC to the master site.

Action: Verify that the DBMS_DEFER package is valid and executable by the RepAPI client. Contact the local or master site administrator, if necessary.

ORA-26513 push error: master proc. string$RP.string failed for trans:string seq:string

Cause: A conflict/error occurred at the master site while executing a $RP.rep_insert(), rep_update(), or rep_delete() function which was not handled by conflict resolution logic at the master.

Action: Notify master site system administrator or database administrator.

ORA-26514 object 'string.string' not found

Cause: The specified object was expected but not found.

Action: Verify that the specified object exists and is valid.

ORA-26515 no master log available for 'string.string'

Cause: The specified master log was not found or available for the named table.

Action: Create the master log at the master site or correct any problems that may exist with the log.

ORA-26516 no push transaction acknowledgement

Cause: RepAPI was unable to confirm that the last pushed transaction was successfully committed by the master site.

Action: Verify that the communications link between the local site and the master site is still valid. If the transaction has not been committed at the master, repush the transaction.

ORA-26517 materialized view control entry for 'string.string' was not found

Cause: The specified materialized view catalog control record was not found.

Action: Verify that the local materialized view catalog is valid and that the local materialized view is properly defined.

ORA-26518 push queue synchronization error detected

Cause: Client tried to repush a transaction has already been committed at the master site. A common cause of this problem is an error at the local site in initializing or updating the local site transaction sequence mechanism.

Action: Verify that transaction data that RepAPI was attempting to repushed to the master site exists at the master table and is valid and consistent with the local site. If this error occurs, redundantly identified transactions are ignored and then purged from the local updatable materialized view logs. Check that the local site is correctly assigning new transaction IDs and is not accidently generating non-unique values.

ORA-26519 no memory available to allocate

Cause: There was no memory left for the RepAPI process. This error may occur when RepAPI is trying to allocate a new table buffer area.

Action: Shut down one or more local applications to attempt to free heap memory and retry the RepAPI operation.

ORA-26520 internal memory failure

Cause: An internal memory error was detected.

Action: Check if other errors have occurred or determine if any local application may have corrupted the memory subsystem.

ORA-26521 rpc initialization error

Cause: An error occurred during the initialization of a PL/SQL RPC.

Action: Verify that the procedure to be invoked exists and is valid at the master site and is executable by the RepAPI user.

ORA-26522 rpc execution error

Cause: An error occurred during the execution of a PL/SQL RPC.

Action: Check the error messages from the remote procedure and fix any remote site problems that may be preventing the execution of the invoked RPC.

ORA-26523 rpc termination error

Cause: An error occurred during the termination of a PL/SQL RPC. This is usually caused by master site being unable to close an opened cursor or if RepAPI cannot deallocate internal memory.

Action: Fix any server side problems first, determine if the RepAPI memory subsystem has been corrupted.

ORA-26524 nls subsystem initialization failure for product=string, facility=string

Cause: The NLS product/facility error message file could not be located or properly initialized.

Action: Check that the error message directory and file(s) have been properly installed.

ORA-26525 session connection attempt failed for string (@string)

Cause: A connection could not be established to the specified database using the provided connection string.

Action: Check that the user, password, connect string, names services, network, and any remote site listener process are properly installed and working.

ORA-26526 materialized view sql ddl parse/expansion failed for string.string

Cause: The client SQL materialized view definition query could not be properly parsed by the master Oracle site.

Action: Check that materialized view DDL SQL is compatible with the currently connected version of Oracle and does not violate any of the RepAPI SQL limitations or restrictions.

ORA-26527 local store callback init phase failed for 'string.string'

Cause: The client callback failed during its INIT phase for the named object.

Action: Verify that the objects referenced by the client callback exist and are valid. Refer to the vendor-specific callback error code reference to diagnose the local problem. Record all error states and notify Oracle Support Services.

ORA-26528 local store callback proc phase failed for 'string.string'

Cause: The client callback failed during its PROC phase for the named object.

Action: Refer to the vendor-specific callback error code reference to diagnose the local problem. Record all error states and notify Oracle Support Services.

ORA-26529 local store callback term phase failed for 'string.string'

Cause: The client callback failed during its TERM phase for the named object.

Action: Refer to the vendor-specific callback error code reference to diagnose the local problem. Record all error states and notify Oracle Support Services.

ORA-26530 unable to build materialized view refresh control list

Cause: The materialized view control list could not be constructed. This is generally the result of an error while accessing the local materialized view catalog.

Action: Verify that the named materialized view(s) are properly defined and valid.

ORA-26532 replication parallel push simulated site failure

Cause: A parallel push executed with event 26531 enabled raises this error to simulation failure of network or destination site.

Action: Do not enable the event for normal operation.

ORA-26534 collision: tranID number ignored and purged

Cause: A transaction that was pushed had a transaction ID that collided with a transaction that was previously pushed and committed at the master site.

Action: See the action section for E_QUEUESYNC (26518).

ORA-26535 number byte row cache insufficient for table with rowsize=number

Cause: A transaction that was pushed had a transaction ID that collided with a transaction that was previously pushed and committed at the master site.

Action: Increase the RepAPI row buffer size or reduce the width of the replicated tables.

ORA-26536 refresh was aborted because of conflicts caused by deferred transactions

Cause: There are outstanding conflicts logged in the DEFERROR table at the materialized view's master site.

Action: Resolve the conflicts in the master DEFERROR table and refresh again after the table is empty. Alternatively, refresh with REFRESH_AFTER_ERRORS, even if there are conflicts in the master's DEFERROR table. Proceeding despite conflicts can result in an updatable materialized view's changes appearing to be temporarily lost, until a refresh succeeds after the conflicts are resolved.

ORA-26563 renaming this table is not allowed

Cause: Attempt to rename a replicated table, an updatable materialized view table or the master table of a materialized view for which a materialized view log has been created.

Action: If desired, unregister the replicated table with DBMS_REPCAT.DROP_MASTER_REPOBJECT, or use the recommended procedure to rename the master table of a materialized view.

ORA-26564 string argument is not of specified type

Cause: User passed type of the given argument number does not match with the type of the argument in the stored arguments.

Action: Invoke correct type procedure (that is, get_XXX_arg).

ORA-26565 Call to type_arg made before calling dbms_defer.call

Cause: User invoked type_arg procedure before starting a deferred call.

Action: Invoke various procedures in the correct order.

ORA-26566 Couldn't open connect to string

Cause: Failed to open connection using given database link.

Action: Make sure that the database link is valid and remote m/c is up.

ORA-26571 string.string.string: number of arguments (string) does not match replication catalog

Cause: The number of arguments does not match the replication catalog.

Action: Examine the total number of arguments for the RPC call.

ORA-26572 string.string.string: argument string does not match replication catalog

Cause: The (RPC) call is corrupted.

Action: Examine total number of arguments and each argument for the RPC call.

ORA-26575 remote database does not support replication parallel propagation

Cause: The remote database has a version lower than Oracle 8.0 and hence does not understand replication parallel propagation.

Action: Use serial propagation or upgrade the remote database to Oracle 8.0 or above.

ORA-26650 string background process string might not be started successfully

Cause: An error occurred during creation of a capture or apply background process.

Action: Review V$Capture and V$Apply_coordinator views for the status of these processes. Also check the trace file for more information.

ORA-26660 Invalid action context value for string

Cause: The value specified in the action context is invalid for use in STREAMS.

Action: Check that the type and value are correct.

ORA-26665 STREAMS process string already exists

Cause: An attempt was made to create a STREAMS process that already exists.

Action: Either specify another STREAMS process or remove the existing STREAMS process.

ORA-26666 cannot alter STREAMS process string

Cause: An attempt was made to alter a STREAMS process that is currently running.

Action: Stop the STREAMS process and re-issue the command.

ORA-26667 invalid STREAMS parameter string

Cause: An attempt was made to specify an invalid parameter.

Action: Check the documentation for valid parameters.

ORA-26669 parameter string inconsistent with parameter string

Cause: An attempt was made to specify a subprogram parameter value that is inconsistent with another parameter value.

Action: Check the documentation for valid parameter values.

ORA-26670 STREAMS option requires COMPATIBLE parameter to be string or higher

Cause: Streams requires compatibility to be 9.2.0 or higher.

Action: Shut down and restart with an appropriate compatibility setting.

ORA-26671 maximum number of STREAMS processes exceeded

Cause: Cannot create additional STREAMS processes since the maximum number of STREAMS processes has been reached.

Action: Remove existing STREAMS processes and retry the operation.

ORA-26672 timeout occurred while stopping STREAMS process string

Cause: Timeout occurred while waiting for a STREAMS process to shut down.

Action: Retry the operation. If the error persists, then try stopping the process with the FORCE option, or contact Oracle Support Services.

ORA-26680 object type not supported

Cause: The specified object type is not supported.

Action: Retry with a supported object type.

ORA-26681 command type not supported

Cause: The specified command type is not supported.

Action: Retry with a supported command type.

ORA-26682 invalid value for publication_on

Cause: The publication_on parameter should be either 'Y' or 'N'.

Action: Retry with a proper value for publication_on.

ORA-26683 invalid value for value_type

Cause: The value_type parameter should be either 'OLD' or 'NEW'.

Action: Retry with proper value_type.

ORA-26684 invalid value for value_type

Cause: The value_type parameter should be one of 'OLD', 'NEW', or '*'.

Action: Retry with proper value_type.

ORA-26685 cannot apply transactions from multiple sources

Cause: Transactions from multiple sources were sent to the same apply process.

Action: Create multiple apply processes and create appropriate rules so that transactions from only one source reach an apply process.

ORA-26686 cannot capture from specified SCN

Cause: An attempt was made to specify an invalid SCN.

Action: Retry with a valid SCN.

ORA-26687 no instantiation SCN provided

Cause: Object SCN has not been set.

Action: Set the SCN by calling DBMS_APPLY_ADM.SET_INSTANTIATION_SCN.

ORA-26688 missing key in LCR

Cause: Metadata mismatch, or not enough information in the user generated LCR.

Action: Alter the database object, or provide all defined keys in the LCR.

ORA-26689 column datatype mismatch in LCR

Cause: The datatypes of columns in the LCR are not the same as the datatypes in the database object.

Action: Alter the database object.

ORA-26690 datatype not supported at non-Oracle system

Cause: One of the columns of the LCR being applied was of a datatype not supported by either the target non-Oracle system or by the Oracle transparent gateway through which the apply is being done.

Action: Do not apply data of this type. If possible, filter out columns containing such datatypes before applying.

ORA-26691 operation not supported at non-Oracle system

Cause: The apply process attempted an operation that is either not supported by the non-Oracle system or by the Oracle transparent gateway through which the apply is being done. Some kinds of DML (like procedure and function calls) and all DDL will cause this error to be raised.

Action: Do not attempt to apply such LCRs to non-Oracle systems. If possible, filter out such LCRs before applying.

ORA-26701 STREAMS process string does not exist

Cause: An attempt was made to access a STREAMS process which does not exist.

Action: Check with the relevant security views for the correct name of the object.

ORA-27000 skgfqsbi: failed to initialize storage subsystem (SBT) layer

Cause: SBTINIT returned an error, additional information indicates error.

Action: Verify that vendor's storage subsystem product is operating correctly.

ORA-27001 unsupported device type

Cause: The specified device type is supported on this platform.

Action: Check V$BACKUP_DEVICE for supported device types.

ORA-27002 function called with invalid device structure

Cause: An internal error occurred. Additional information indicates which function encountered error.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27003 cannot open file on device allocated with NOIO option

Cause: An internal error occurred. A file is being created/retrieved on a device allocated with NOIO option, additional information indicates which function encountered error.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27004 invalid blocksize specified

Cause: An internal error occurred. The block size specified is incorrect for the device on which file is being created, additional information indicates block size specified, and the function that encountered the error.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27005 cannot open file for async I/O on device not supporting async

Cause: An internal error occurred. A file is being opened for asynchronous I/O on a device that does not support asynchronous I/O, additional information indicates which function encountered error.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27006 sbtremove returned error

Cause: Additional information indicates error returned by SBTREMOVE, and the function that encountered the error.

Action: Verify that the vendor's storage subsystem product is operating correctly.

ORA-27007 failed to open file

Cause: SBTOPEN returned error, additional information indicates error returned from SBTOPEN, and the function that encountered the error.

Action: Verify that the vendor's storage subsystem product is operating correctly.

ORA-27008 function called with invalid file structure

Cause: An internal error occurred. Additional information indicates which function encountered error.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27009 skgfwrt: cannot write to file opened for read

Cause: An internal error occurred.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27010 skgfwrt: write to file failed

Cause: SBTWRITE returned error, additional information indicates error returned from SBTWRITE.

Action: Verify that the vendor's storage subsystem product is operating correctly.

ORA-27011 skgfrd: cannot read from file opened for write

Cause: An internal error occurred.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27012 skgfrd: read from file failed

Cause: SBTREAD returned error, additional information indicates error returned from SBTREAD.

Action: Verify that the vendor's storage subsystem product is operating correctly.

ORA-27013 skgfqdel: cannot delete an open file

Cause: An internal error occurred.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27014 skgfqpini: translation error while expanding SS_UDMPDIR

Cause: Failure of SLTLN in SKGFQPINI.

Action: Check additional return error for more information.

ORA-27015 skgfcls: failed to close the file

Cause: SBTCLOSE returned an error. Additional information indicates error returned from SBTCLOSE.

Action: Verify that the vendor's storage subsystem product is operating correctly.

ORA-27016 skgfcls: sbtinfo returned error

Cause: Additional information indicates error returned from SBTINFO.

Action: Verify that the vendor's storage subsystem product is operating correctly.

ORA-27017 skgfcls: media handle returned by sbtinfo exceeds max length(SSTMXQMH)

Cause: Media handle string length exceeds SSTMXQMH.

Action: Verify that the vendor's storage subsystem product is operating correctly, and that the platform limit (SSTMXQMH) is at least 64 (the limit specified for SBTINFO). additional information indicates the media handle string length returned by SBTINFO, and the limit (SSTMXQMH).

ORA-27018 BLKSIZE is not a multiple of the minimum physical block size

Cause: User-specified BLKSIZE (blocking factor) is not a multiple of the minimum block size that is permitted on this platform.

Action: Two ADDITIONAL INFORMATION messages are displayed which show the blocking factor provided by the user and the minimum physical block size. Specify a BLKSIZE that is an integral multiple of the minimum block size.

ORA-27019 tape filename length exceeds limit (SBTOPMXF)

Cause: The length of the tape file name provided to sequential I/O OSD functions is too long.

Action: Additional information indicates in which function this error is encountered, the length of file name provided, and the limit on file name.

ORA-27020 named devices not supported

Cause: The platform or the specified device type does not support named devices.

Action: Do not specify device name or use a device type that supports named devices. Use V$BACKUP_DEVICE view to see what device types and names (if any) are available.

ORA-27021 sequential file handle must be specified

Cause: The file name which will be passed to SBTOPEN was not specified.

Action: Specify a file name and continue. If this is a backup set being created via Recovery Manager, use the 'format' option to specify the backup piece handle name.

ORA-27022 skgfqsbi: could not allocate memory for media manager

Cause: Oracle could not allocate memory required by the media management software which is linked with Oracle to provide backup/restore services.

Action: Increase the amount of memory available to the Oracle process and retry the backup/restore.

ORA-27023 skgfqsbi: media manager protocol error

Cause: The media management software which is linked with Oracle to provide backup/restore services did not provide its function pointer structure to Oracle. This is an internal error in the media management product.

Action: Contact the media management vendor.

ORA-27024 skgfqsbi: sbtinit2 returned error

Cause: SBTINIT2 returned an error. This happens during a backup or restore operation.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27025 skgfqsbi: invalid media manager context area size

Cause: The media management software requested a context area size which is greater than the maximum allowable size. This is an internal error in the media management product.

Action: Contact the media management vendor.

ORA-27026 skgfrls: sbtend returned error

Cause: SBTEND returned an error. This happens during a backup or restore operation.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27027 sbtremove2 returned error

Cause: SBTREMOVE2 returned an error. This happens when deleting a backup file.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27028 skgfqcre: sbtbackup returned error

Cause: SBTBACKUP returned an error. This happens when creating a backup file during a backup operation.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27029 skgfrtrv: sbtrestore returned error

Cause: SBTRESTORE returned an error. This happens when retrieving a backup file during a restore operation.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27030 skgfwrt: sbtwrite2 returned error

Cause: SBTWRITE2 returned an error. This happens while writing a backup file during a backup operation.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27031 mirror resilvering functions not supported

Cause: An internal error occurred.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27032 skgfrpini: failed to obtain file size limit

Cause: GETRLIMIT system call returned an error.

Action: Check errno.

ORA-27033 skgfrpini: failed to obtain file size limit

Cause: ULIMIT system call returned an error.

Action: Check errno.

ORA-27034 skgfrcre: maximum length of ORACLE_SID exceeded

Cause: Too many characters in the ORACLE_SID string.

Action: Rename the ORACLE_SID to a string of up to the maximum number of characters specified for your system.

ORA-27035 logical block size is invalid

Cause: Logical block size for Oracle files must be a multiple of the physical block size, and less than the maximum.

Action: Block size specified is returned as additional information, check initialization parameters, additional information also indicates which function encountered the error.

ORA-27036 translation error, unable to expand file name

Cause: Additional information indicates SLTLN/SLNRM error, and also indicates which function encountered the error.

Action: Check additional information.

ORA-27037 unable to obtain file status

Cause: STAT system call returned an error, additional information indicates which function encountered the error.

Action: Check errno.

ORA-27038 skgfrcre: file exists

Cause: Trying to create a database file, but file by that name already exists.

Action: Verify that name is correct, specify reuse if necessary.

ORA-27039 create file failed, file size limit reached

Cause: An attempt was made to create a file that exceeds the process' file size limit, additional information indicates which function encountered the error.

Action: Raise the file size limit.

ORA-27040 skgfrcre: create error, unable to create file

Cause: Create system call returned an error, unable to create file.

Action: Verify the file name and permissions.

ORA-27041 unable to open file

Cause: Open system call returned an error, additional information indicates which function encountered the error.

Action: Check errno.

ORA-27042 not enough space on raw partition to fullfill request

Cause: This is an internal error. The file is too large for the raw partition. Additional information indicates which function encountered the error.

Action: Check for trace file and contact Oracle Support Services.

ORA-27043 unable to seek to beginning of file

Cause: Seek system call failed, additional information indicates which function encountered the error.

Action: Check errno.

ORA-27044 unable to write the header block of file

Cause: Write system call failed, additional information indicates which function encountered the error.

Action: Check errno.

ORA-27045 unable to close the file

Cause: Close system call failed, additional information indicates which function encountered the error.

Action: Check errno.

ORA-27046 file size is not a multiple of logical block size

Cause: File size as indicated by STAT is not correct, additional information indicates which function encountered the error.

Action: Verify that the file has not been overwritten or truncated.

ORA-27047 unable to read the header block of file

Cause: Read system call failed, additional information indicates which function encountered the error.

Action: Check errno.

ORA-27048 skgfifi: file header information is invalid

Cause: Possibly trying to use a non-database file as a database file.

Action: Verify that file is a database file.

ORA-27049 unable to seek to and read the last block

Cause: An attempt was made to seek to and read the last block in file, additional information indicates which function encountered error.

Action: Check errno.

ORA-27050 function called with invalid FIB/IOV structure

Cause: This is an internal error. Additional information indicates which function encountered error.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27052 unable to flush file data

Cause: FSYNC system call returned error, additional information indicates which function encountered the error.

Action: Check errno.

ORA-27053 skgfifi: blocksize in file header not a multiple of logical block size

Cause: The logical block size is invalid, additional information indicates the logical block size and the block size in the file header.

Action: Use a different logical block size, or do not reuse file.

ORA-27056 skgfrdel: could not delete file

Cause: Unlink system call returned error.

Action: Check errno.

ORA-27057 skgfask: cannot perform async I/O to file

Cause: This is an internal error. The query is being asked about asynchronous vector I/O when the file does not support asynchronous I/O.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27058 skgfask: question parameter is invalid

Cause: This is an internal error. An invalid query is being asked.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27059 skgfrsz: could not reduce file size

Cause: FTRUNCATE system call returned error.

Action: Check errno.

ORA-27060 skgfofi: could not set close-on-exec bit on file

Cause: FCNTL system call returned error.

Action: Check errno.

ORA-27061 skgfospo: waiting for async I/Os failed

Cause: AIOWAIT function returned error.

Action: Check errno.

ORA-27062 skgfospo: could not find pending async I/Os

Cause: There should have been some asynchronous I/Os in the system but a blocking aiowait indicates that there are no more I/Os. It could be due to an Oracle bug, a vendor OS bug, or an NFS server not responding.

Action: Check the Oracle trace file, OS message files, and contact Oracle Support Services.

ORA-27063 skgfospo: number of bytes read/written is incorrect

Cause: The number of bytes read/written as returned by AIOWAIT does not match the original number, additional information indicates both these numbers.

Action: Check errno.

ORA-27064 skgfdisp: cannot perform async I/O to file

Cause: This is an internal error. A request was made to perform asynchronous I/O when IOV indicates that it cannot be performed on the file.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27065 skgfdisp: cannot perform async vector I/O to file

Cause: This is an internal error. A request was made to perform asynchronous vector I/O when it cannot be performed on the file.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27066 skgfdisp: number of buffers in vector I/O exceeds maximum

Cause: This is an internal error. The number of buffers in vector I/O exceeds maximum allowed by the OSD, additional information indicates both these numbers.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27067 skgfdisp: size of buffer is invalid

Cause: This is an internal error. The buffer size is either 0, or greater than SSTIOMAX or not a multiple of logical block size, additional information indicates where in function the error was encountered and the buffer size.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27068 skgfdisp: buffer is not aligned properly

Cause: This is an internal error. The buffer is not aligned to SSIOALIGN boundary, additional information indicates where in function the error was encountered and the buffer pointer.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27069 skgfdisp: attempt to do I/O beyond the range of the file

Cause: This is an internal error. The range of blocks being read or written is outside the range of the file, additional information indicates the starting block number, number of blocks in I/O, and the last valid block in the file.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27070 skgfdisp: async read/write failed

Cause: AIOREAD/AIOWRITE system call returned error, additional information indicates starting block number of I/O.

Action: Check errno.

ORA-27071 skgfdisp: unable to seek to desired position in file

Cause: LSEEK system call returned error, additional information indicates block number in file to which seek was attempted.

Action: Check errno.

ORA-27072 skgfdisp: I/O error

Cause: READ/WRITE/READV/WRITEV system call returned error, additional information indicates starting block number of I/O.

Action: Check errno.

ORA-27073 skgfcfi: async I/Os remaining to be dequeued for this file

Cause: This is an internal error. The file is being closed but not all asynchronous I/Os to the file have been dequeued, additional information indicates number of I/Os pending on the file.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27074 skgfrofl: unable to determine limit for open files

Cause: GETRLIMIT system call returned error.

Action: Check errno.

ORA-27075 skgfrofl: SSTMOFRC constant too large

Cause: This is an internal error.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27076 skgfrofl: unable to set limit for open files

Cause: SETRLIMIT system call returned error.

Action: Check errno.

ORA-27077 skgfofi: too many files open

Cause: This is an internal error. The number of files opened through SKGFOFI has reached the limit.

Action: Check for a trace file and contact Oracle Support Services.

ORA-27080 skgfrdup: too many files open

Cause: the number of files opened has reached system limit.

Action: check error, and set system configuration values.

ORA-27084 skgfqio: unable to get/set file status flags

Cause: System call FCNTL with F_GETFL/F_SETFL flag returned error.

Action: Check errno.

ORA-27086 skgfglk: unable to lock file - already in use

Cause: The file is locked by another process, indicating that it is currently in use by a database instance.

Action: Determine which database instance legitimately owns this file.

ORA-27087 skgfglk: unable to get share lock - file not readable

Cause: Share lock request was made on a file not open for read access.

Action: File must be open read-only or read-write to get a share lock.

ORA-27088 skgfglk: unable to get file status

Cause: The file is not open or the file descriptor is invalid.

Action: Make sure the file is open and the descriptor is valid.

ORA-27089 skgfrlk: unable to release advisory lock

Cause: The file lock release failed.

Cause: See the errno.

ORA-27091 skgfqio: unable to queue I/O

Cause: A read/write/readv/writev system call returned error. Additional information indicates the starting block number of the I/O.

Action: Check the errno.

ORA-27092 skgfofi: size of file exceeds file size limit of the process

Cause: An attempt was made to open a file that exceeds the process's file size limit (ulimit), additional information shows the current limit (logical blocks) and the size of the file (logical blocks).

Action: increase the processes file size limit (ulimit) and retry.

ORA-27100 shared memory realm already exists

Cause: An attempt was made to start duplicate instances, or tried to restart an instance that had not been properly shut down.

Action: Use a different instance name, or cleanup the failed instance's SGA.

ORA-27101 shared memory realm does not exist

Cause: Unable to locate shared memory realm.

Action: Verify that the realm is accessible.

ORA-27102 out of memory

Cause: Out of memory.

Action: Consult the trace file for details.

ORA-27103 internal error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-27120 unable to removed shared memory segment

Cause: SHMCTL() call failed.

Action: check permissions on segment, contact Oracle Support Services.

ORA-27121 unable to determine size of shared memory segment

Cause: SHMCTL() call failed.

Action: check permissions on segment, contact Oracle Support Services.

ORA-27122 unable to protect memory

Cause: MPROTECT() call failed.

Action: Contact Oracle Support Services.

ORA-27123 unable to attach to shared memory segment

Cause: SHMAT() call failed.

Action: Check permissions on segment, contact Oracle Support Services.

ORA-27124 unable to detach from shared memory segment

Cause: SHMDT() call failed.

Action: Contact Oracle Support Services.

ORA-27125 unable to create shared memory segment

Cause: SHMGET() call failed.

Action: Contact Oracle Support Services.

ORA-27126 unable to lock shared memory segment in core

Cause: Insufficient privileges to lock shared memory segment in core.

Action: Make sure the process is running with the necessary privileges.

ORA-27127 unable to unlock shared memory segment

Cause: Insufficient privileges to unlock shared memory segment.

Action: Make sure the process is running with the necessary privileges.

ORA-27128 unable to determine pagesize

Cause: SYSCONF() call failed.

Action: Contact Oracle Support Services.

ORA-27141 invalid process ID

Cause: Process operation attempted using invalid process ID.

Action: Contact Oracle Support Services.

ORA-27142 could not create new process

Cause: Operating system call error.

Action: Check errno and if possible increase the number of processes.

ORA-27143 OS system call failure

Cause: Operating system call failed.

Action: Check errno and contact Oracle Support Services.

ORA-27144 attempt to kill process failed

Cause: Operating system call error.

Action: Check errno and contact Oracle Support Services.

ORA-27145 insufficient resources for requested number of processes

Cause: Operating system call error.

Action: Check errno and contact Oracle Support Services.

ORA-27146 post/wait initialization failed

Cause: Operating system call failed.

Action: Check errno and contact Oracle Support Services.

ORA-27147 post/wait reset failed

Cause: Operating system call failed.

Action: Check errno and contact Oracle Support Services.

ORA-27148 spawn wait error

Cause: Operating system call failed.

Action: Check errno and contact Oracle Support Services.

ORA-27149 assignment out of range

Cause: This is an internal error. A request was made for a conversion too large for the type.

Action: Contact Oracle Support Services.

ORA-27150 attempt to notify process of pending oradebug call failed

Cause: Operating system call failed.

Action: Check errno and contact Oracle Support Services.

ORA-27151 buffer not large enough to hold process ID string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-27152 attempt to post process failed

Cause: Operating system call failed.

Action: Check errno and contact Oracle Support Services.

ORA-27153 wait operation failed

Cause: Operating system call failed.

Action: Check errno and contact Oracle Support Services.

ORA-27154 post/wait create failed

Cause: This is an internal error. Multiple post/wait creates were attempted simultaneously.

Action: Check errno and contact Oracle Support Services.

ORA-27155 could not execute file

Cause: Operating system call failed.

Action: Check errno and contact Oracle Support Services.

ORA-27156 request for process information failed

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-27157 OS post/wait facility removed

Cause: The post/wait facility for which the calling process is awaiting action was removed from the system.

Action: Check errno and contact Oracle Support Services.

ORA-27190 skgfrd: sbtread2 returned error

Cause: SBTREAD2 returned an error. This happens while reading a backup file during a restore operation.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27191 sbtinfo2 returned error

Cause: SBTINFO2 returned an error. This happens while retrieving backup file information from the media manager's catalog.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27192 skgfcls: sbtclose2 returned error - failed to close file

Cause: SBTCLOSE2 returned an error. This happens while closing a backup file during a backup or restore operation.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27193 sbtinfo2 did not return volume label

Cause: SBTINFO2 did not return the volume label information for the backup file that was just created. This is an internal error in the media management product.

Action: Contact the media management vendor.

ORA-27194 skgfdvcmd: sbtcommand returned error

Cause: SBTCOMMAND returned an error. This happens when an RMAN SEND command is issued.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27195 proxy copy not supported

Cause: An attempt was made to do a proxy backup or restore, but the media management software installed with Oracle does not support proxy copy.

Action: Rerun the backup in non-proxy mode, or contact the media management vendor if the software is supposed to support proxy copy.

ORA-27196 skgfpbk: sbtpcbackup returned error

Cause: SBTPCBACKUP returned an error. This happens when a proxy backup is begun.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27197 skgfprs: sbtpcrestore returned error

Cause: SBTPCRESTORE returned an error. This happens when a proxy restore is begun.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27198 skgfpvl: sbtpcvalidate returned error

Cause: SBTPCVALIDATE returned an error. This happens during a proxy backup or restore.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27199 skgfpst: sbtpcstatus returned error

Cause: SBTPCSTATUS returned an error. This happens during a proxy backup or restore.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27200 skgfpgo: sbtpcstart returned error

Cause: SBTPCSTART returned an error. This happens during a proxy backup or restore.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27201 skgfpcm: sbtpccommit returned error

Cause: SBTPCCOMMIT returned an error. This happens during a proxy backup or restore.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27202 skgfpen: sbtpcend returned error

Cause: SBTPCEND returned an error. This happens during a proxy backup or restore.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27203 skgfpqb: sbtpcquerybackup returned error

Cause: SBTPCQUERYBACKUP returned an error. This happens during a proxy backup.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27204 skgfpqr: sbtpcqueryrestore returned error

Cause: SBTPCQUERYRESTORE returned an error. This happens during a proxy restore.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27205 skgfpcn: sbtpccancel returned error

Cause: SBTPCCANCEL returned an error. This happens during a proxy restore.

Action: This error is returned from the media management software which is linked with Oracle. There should be additional messages which explain the cause of the error. This error usually requires contacting the media management vendor.

ORA-27206 requested file not found in media management catalog

Cause: A backup file used in a recovery manager catalog maintenance command was not found in the media management catalog.

Action: Retry the command with a different file.

ORA-27207 syntax error in device PARMS - parentheses mismatch or missing

Cause: User-supplied PARMS value has incorrect syntax.

Action: Retry the command with the correct syntax: ENV=(..) BLKSIZE=nnnn

ORA-27208 syntax error in device PARMS - environment variable value missing

Cause: User-supplied PARMS value has incorrect syntax.

Action: Retry the command with the correct syntax: ENV=(var1=val1,var2=val2,..)

ORA-27209 syntax error in device PARMS - unknown keyword or missing =

Cause: User-supplied PARMS value has incorrect syntax. The server expected to find ENV or BLKSIZE, but found an unknown keyword.

Action: Retry the command with the correct syntax: ENV=(..) BLKSIZE=nnnn

ORA-27210 syntax error in device PARMS

Cause: User-supplied PARMS value has incorrect syntax.

Action: Retry the command with the correct syntax: ENV=(..) BLKSIZE=nnnn

ORA-27211 Failed to load Media Management Library

Cause: User-supplied SBT_LIBRARY or libobk.so could not be loaded. Call to dlopen for media library returned error. See Additional information for the error code.

Action: Retry the command with proper media library. Or re-install Media management module for Oracle.

ORA-27212 some entrypoints in Media Management Library are missing

Cause: Media library does not have one of the following entrypoints : sbtinfo, sbtread, sbtwrite, sbtremove, sbtopen, sbtclose, or sbtinit.

Action: Retry the command with proper media library.

ORA-27213 failed to unload Media Management Library

Cause: The dlclose for media library returned an error. See Additional information for the error code.

Action: Contact Oracle Support Services.

ORA-27300 OS system dependent operation:string failed with status: string

Cause: Operating system call error.

Action: Contact Oracle Support Services.

ORA-27301 OS failure message: string

Cause: Operating system call error.

Action: Contact Oracle Support Services.

ORA-27302 failure occurred at: string

Cause: Operating system call error.

Action: Contact Oracle Support Services.

ORA-27303 additional information: string

Cause: Operating system call error.

Action: Contact Oracle Support Services.

ORA-27500 inter-instance IPC error

Cause: This is an operating system/cluster interconnect error.

Action: Check the extra information and contact Oracle Support Services.

ORA-27501 IPC error creating a port

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27502 IPC error deleting OSD context

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27505 IPC error destroying a port

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27506 IPC error connecting to a port

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27507 IPC error disconnecting from a port

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27508 IPC error sending a message

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27509 IPC error receiving a message

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27510 IPC error waiting for a request to complete

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27512 IPC error posting a process

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27542 Failed to unprepare a buffer prepared for remote update

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27543 Failed to cancel outstanding IPC request

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27544 Failed to map memory region for export

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27545 Fail to prepare buffer for remote update

Cause: This is an operating system/cluster interconnect error.

Action: Check the value of errno and contact Oracle Support Services.

ORA-27546 Oracle compiled against IPC interface version string.string found version string.string

Cause: A misconfiguration or installation error occurred.

Action: Install the IPC library for this release of Oracle.

ORA-27547 Unable to query IPC OSD attribute string

Cause: This is an operating system-dependent IPC error.

Action: Contact Oracle Support Services.

ORA-27548 Unable to unprepare IPC buffer

Cause: This is an operating system-dependent IPC error.

Action: Contact Oracle Support Services.

ORA-28000 the account is locked

Cause: The user has entered wrong password consequently for maximum number of times specified by the user's profile parameter FAILED_LOGIN_ATTEMPTS, or the database administrator has locked the account.

Action: Wait for PASSWORD_LOCK_TIME or contact the database administrator.

ORA-28001 the password has expired

Cause: The user's account has expired and the password needs to be changed.

Action: Change the password or contact the database administrator.

ORA-28002 the password will expire within string days

Cause: The user's account is about to about to expire and the password needs to be changed.

Action: Change the password or contact the database administrator.

ORA-28003 password verification for the specified password failed

Cause: The new password did not meet the necessary complexity specifications and the PASSWORD_VERIFY_FUNCTION failed.

Action: Enter a different password. Contact the database administrator to find out the rules for choosing the new password.

ORA-28004 invalid argument for function specified in PASSWORD_VERIFY_FUNCTION string

Cause: The password verification function does not have the required number and type of input/output arguments and/or the return argument.

Action: Check the Oracle9i Security Overview to find out the format of the password verification function.

ORA-28005 invalid logon flags

Cause: The flags are not properly set or conflicting flags are set in making calls.

Action: Call the function with appropriate flags set.

ORA-28006 conflicting values for parameters string and string

Cause: The parameters PASSWORD_REUSE_TIME and PASSWORD_REUSE_MAX cannot both be set. One parameter should be unlimited while other is set.

Action: Set one value to UNLIMITED explicitly.

ORA-28007 the password cannot be reused

Cause: The password cannot be reused for the specified number of days or for the specified number of password changes.

Action: Try the password that you have not used for the specified number of days or the specified number of password changes Refer to the password parameters in the CREATE PROFILE statement.

ORA-28008 invalid old password

Cause: Old password supplied is wrong; Hence user cannot be authenticated using old password.

Action: Supply the correct old password for authentication.

ORA-28009 connection to sys should be as sysdba or sysoper

Cause: Connect sys/password is no longer a valid syntax.

Action: Try connect sys/password as sysdba or connect sys/password as sysoper.

ORA-28010 cannot expire external or global accounts

Cause: If a user account is created as IDENTIFIED EXTERNALLY, or IDENTIFIED GLOBALLY, this account cannot be expired.

Action: Try to expire the password of the user that has database password.

ORA-28011 the account will expire soon; change your password now

Cause: The user's account is marked for expire; the expiry period is unlimited.

Action: Change the password or contact the DBA.

ORA-28020 IDENTIFIED GLOBALLY already specified

Cause: The IDENTIFIED GLOBALLY clause was specified twice.

Action: Use only one IDENTIFIED GLOBALLY clause.

ORA-28021 cannot grant global roles

Cause: A role granted was IDENTIFIED GLOBALLY. Global roles can only be granted via a central authority for the domain.

Action: Use ALTER ROLE to change the type of role (from IDENTIFIED GLOBALLY to other, such as IDENTIFIED BY password), or allocate it to a global user via the central authority.

ORA-28022 cannot grant external roles to global user or role

Cause: A role granted was IDENTIFIED EXTERNALLY. External roles cannot be granted to global users or global roles.

Action: Use ALTER ROLE to change the type of the role being granted (from IDENTIFIED EXTERNALLY to other, such as IDENTIFIED BY password), or use ALTER ROLE or ALTER USER to change the type of the user or role that is the grantee.

ORA-28023 must revoke grants of this role to other user(s) first

Cause: The role altered to IDENTIFIED GLOBALLY was granted to one or more other users and/or roles. Global roles cannot be granted to any user or role.

Action: Use REVOKE to revoke the role from other users or roles first.

ORA-28024 must revoke grants of external roles to this role/user

Cause: The user or role altered to IDENTIFIED GLOBALLY has external roles directly granted; these must be revoked, since external roles cannot be granted to global users or roles.

Action: Use REVOKE to revoke the external roles from the user or role to be ALTERed.

ORA-28025 missing or null external name

Cause: The IDENTIFIED EXTERNALLY AS or IDENTIFIED GLOBALLY AS clause was specified with a valid external name.

Action: Provide a valid external name.

ORA-28026 user with same external name already exists

Cause: The external name specified for the user being created or altered already exists for another user.

Action: External names must be unique among users. Specify another.

ORA-28027 privileged database links may be used by global users

Cause: Only users IDENTIFIED GLOBALLY may use a privileged database link.

Action: Either change the user to a global user or try to use a different database link.

ORA-28028 could not authenticate remote server

Cause: During the course of opening a privileged database link, the remote server was not securely identified using the network security service. Additional errors should follow.

Action: Consult the network security service documentation on how to properly configure the remote server.

ORA-28029 could not authorize remote server for user string

Cause: During the course of opening a privileged database link, the remote server was found to lack the necessary authorizations to connect as the current global user. This may be because the server was not authorized by the network security service. Or it may be because the local server is restricting access by the remote server using the DBMS_SECURITY_DOMAINS_ADMIN package.

Action: Grant the remote server the proper authorization to connect as the given global user, and check that the local server is not restricting access.

ORA-28030 Server encountered problems accessing LDAP directory service

Cause: Unable to access LDAP directory service.

Action: Contact your system administrator.

ORA-28035 Cannot Get Session Key for Authentication

Cause: Client and server cannot negotiate shared secret during logon.

Action: Contact your system administrator.

ORA-28100 policy function schema string is invalid

Cause: The schema was dropped after the policy associated with the function had been added to the object.

Action: Drop the policy and re-create it with a policy function owned by a valid user. Or re-create the user and the policy function under the new user.

ORA-28101 policy already exists

Cause: A policy with the same name for the same object already exists.

Action: Check if the policy has already been added or use a different policy name.

ORA-28102 policy does not exist

Cause: Try to drop/enable/refresh a non-existent policy.

Action: Correct the policy name argument.

ORA-28103 adding a policy to an object owned by SYS is not allowed

Cause: Try to add a policy to a table or a view owned by SYS.

Action: You cannot perform this operation.

ORA-28104 policy function or package is invalid

Cause: The function or package implementing a policy does not exist or was created with errors.

Action: Correct the function or package.

ORA-28106 input value for argument #string is not valid

Cause: Input values for the argument is missing or invalid.

Action: Correct the input values.

ORA-28107 policy was disabled

Cause: Try to flush a disabled policy.

Action: If the policy is supposed to be enforced, it must be enabled.

ORA-28108 circular security policies detected

Cause: Policies for the same object reference each other.

Action: Drop the policies.

ORA-28109 the number of related policies has exceeded the limit of 16

Cause: Too many policies are involved in the same objects.

Action: Drop one or more policies. Or combine a few of them into one.

ORA-28110 policy function or package string.string has error

Cause: The policy function may have been dropped, or is no longer valid.

Action: Check the status of the function and correct the problem. Or re-create the policy with a valid function.

ORA-28111 insufficient privilege to evaluate policy predicate

Cause: Predicate has a subquery which contains objects that the owner of policy function does not have privilege to access.

Action: Grant appropriate privileges to the policy function owner.

ORA-28112 failed to execute policy function

Cause: The policy function has one or more error during execution.

Action: Check the trace file and correct the errors.

ORA-28113 policy predicate has error

Cause: Policy function generates invalid predicate.

Action: Review the trace file for detailed error information.

ORA-28115 policy with check option violation

Cause: Policy predicate was evaluated to FALSE with the updated values.

Action: Check the trace file and correct the errors.

ORA-28116 insufficient privileges to do direct path access

Cause: Users with insufficient privileges attempting to do direct path access of tables with fine grain access control policies.

Action: Ask the database administrator to do the operation. Note that users can work with security administrator to temporarily drop/disable the policies at time of export, import, or load, but this has security implication, and thus access of the database must be controlled carefully.

ORA-28117 integrity constraint violated - parent record not found

Cause: tried to update/insert a child record with new foreign key values, but the corresponding parent row was not visible because of fine-grained security in the parent.

Action: make sure that the updated foreign key values are visible in the parent.

ORA-28118 policy group already exists

Cause: tried to create a policy group that already exists.

ORA-28119 policy group does not exist

Cause: tried to drop a policy group that does not exist.

ORA-28120 driving context already exists

Cause: tried to create a driving context that already exists.

ORA-28121 driving context does not exist

Cause: tried to drop a driving context that does not exist.

ORA-28132 Merge into syntax does not support security policies.

Cause: Merge into syntax currently does not support a security policy on the destination table.

Action: use the insert / update DML stmts on the table that has a security policy defined on it.

ORA-28133 full table access is restricted by fine-grained security

Cause: The user is not SYS and doesn't have full table access due to VPD policies. This only happens for internal DML/query under a DDL.

Action: Grant the appropriate privilege or contact Oracle Support Services if this is too restrictive.

ORA-28134 object cannot have fine-grained access control policy

Cause: Only tables, views, or synonyms of tables or views may have VPD policies.

Action: No action required.

ORA-28150 proxy not authorized to connect as client

Cause: A proxy user attempted to connect as a client, but the proxy was not authorized to act on behalf of the client.

Action: Grant the proxy user permission to perform actions on behalf of the client by using the ALTER USER... GRANT CONNECT command.

ORA-28151 more than one user name specified for command

Cause: More than one user name was specified for an ALTER USER command.

Action: Try the command again with only one user name.

ORA-28152 proxy user 'string' may not specify initial role 'string' on behalf of client 'string'

Cause: A proxy user attempted to specify an initial role for a client, but the client does not possess the role.

Action: Change the proxy user so that it does not specify the role or grant the role to the client.

ORA-28153 Invalid client initial role specified: 'string'

Cause: A role specified by a proxy user as an initial role to be activated upon connecting on behalf of a client is invalid.

Action: Connect again as the client specifying a valid role.

ORA-28154 Proxy user may not act as client 'string'

Cause: A proxy user cannot assume the identity of a privileged user in order to limit the privileges that a proxy can possess.

Action: Execute the statement again, specifying a client other than a privileged user.

ORA-28155 user 'string' specified as a proxy is actually a role

Cause: A user specified in an AUDIT operation BY proxy ON BEHALF OF client is actually a role.

Action: Execute the statement again with a valid proxy user.

ORA-28156 Proxy user 'string' not authorized to set role 'string' for client 'string'

Cause: A proxy user has not been granted the right to use a role on behalf of a client.

Action: Execute the command ALTER USER client GRANT CONNECT THROUGH PROXY proxy to grant the needed role.

ORA-28157 Proxy user 'string' forbidden to set role 'string' for client 'string'

Cause: A proxy user was forbidden to use a role on behalf of a client through the command ALTER USER client GRANT CONNECT THROUGH proxy WITH ALL ROLES EXCEPT role.

Action: Execute the command ALTER USER client GRANT CONNECT THROUGH PROXY proxy to grant the needed role.

ORA-28158 missing ALL keyword

Cause: Keyword missing.

Action: Provide missing keyword.

ORA-28159 missing BEHALF keyword

Cause: Keyword missing.

Action: Provide missing keyword.

ORA-28160 missing EXCEPT keyword

Cause: Keyword missing.

Action: Provide missing keyword.

ORA-28161 missing ROLES keyword

Cause: Keyword missing.

Action: Provide missing keyword.

ORA-28162 missing THROUGH keyword

Cause: Keyword missing.

Action: Provide missing keyword.

ORA-28163 GRANT already specified

Cause: The GRANT clause was specified twice.

Action: Use only one GRANT clause.

ORA-28164 REVOKE already specified

Cause: The REVOKE clause was specified twice.

Action: Use only one REVOKE clause.

ORA-28165 proxy 'string' may not specify password-protected role 'string' for client 'string'

Cause: A proxy user attempted to activate a role on behalf of a client which has a password associated with it. Since the proxy does not have a password, this activation cannot be allowed.

Action: Attempt to activate a different role or change the role administratively so that there is no password.

ORA-28166 duplicate rolename in list

Cause: The name of a role was specified more than once in a list.

Action: Repeat the command specifying the role once.

ORA-28168 attempted to grant password-protected role

Cause: An ALTER USER ... GRANT CONNECT command was attempted specifying a role that is protected by a password as a role which the proxy may execute on behalf of a client.

Action: Either specify a role that does not have a password or alter the role so that a password is not required.

ORA-28169 unsupported certificate type

Cause: The type of certificate from which the server is to extract the credentials of the client is not supported.

Action: Specify a supported type.

ORA-28170 unsupported certificate version

Cause: The version of the certificate from which the server is to extract the credentials of the client is not supported.

Action: Specify a supported version.

ORA-28171 unsupported Kerberos version

Cause: The version of the Kerberos ticket which the server is to use to validate the identity of the client is not supported.

Action: Specify a supported version.

ORA-28172 distinguished name not provided by proxy

Cause: A client user is to be identified using a distinguished name, but none was provided by the proxy user.

Action: Provide a distinguished name.

ORA-28173 certificate not provided by proxy

Cause: A client user is to be identified using a certificate but none was provided by the proxy user.

Action: Provide a certificate.

ORA-28174 Kerberos ticket not provided by proxy

Cause: A client user is to be authenticated using a Kerberos ticket but none was provided by the proxy user.

Action: Provide a Kerberos ticket.

ORA-28175 incorrect certificate type

Cause: the type of certificate provided by the proxy user to identify a client user does not match the type that is required.

Action: Provide a certificate of the correct type.

ORA-28176 incorrect certificate version

Cause: The version of the certificate provided by the proxy user to identify a client user does not match the version that is required.

Action: Provide a certificate of the correct version.

ORA-28177 incorrect Kerberos ticket version

Cause: the version of the Kerberos ticket provided by the proxy user to authenticate a client user does not match the version that is required.

Action: Provide a Kerberos ticket of the correct version.

ORA-28178 password not provided by proxy

Cause: A client user is to be authenticated using a database password but none was provided by the proxy user.

Action: Provide a password.

ORA-28179 client user name not provided by proxy

Cause: No user name was provided by the proxy user for the client user.

Action: Either specify a client database user name, a distinguished name or an X.509 certificate.

ORA-28180 multiple authentication methods provided by proxy

Cause: More than one authentication method was specified by the proxy user for the client user.

Action: Specify only one of the following:

  • A client database user name
  • A distinguished name
  • An X.509 certificate.

ORA-28200 IDENTIFIED USING already specified

Cause: The IDENTIFIED USING clause was specified twice.

Action: Use only one IDENTIFIED USING clause.

ORA-28201 Not enough privileges to enable application role 'string'

Cause: An attempt to enable application role outside the scope of the designated package.

Action: Enable the role directly or indirectly using the designated package.

ORA-28221 REPLACE not specified

Cause: User is changing password but password verification function is turned on, the original password is not specified, and the user does not have the alter user system privilege.

Action: Supply the original password.

ORA-28231 no data passed to obfuscation toolkit

Cause: A NULL value was passed to a function or procedure.

Action: Make sure that the data passed is not empty.

ORA-28232 invalid input length for obfuscation toolkit

Cause: Length of data submitted for encryption or decryption is not a multiple of 8 bytes.

Action: Make sure that the length of the data to be encrypted or decrypted is a multiple of 8 bytes.

ORA-28233 double encryption not supported

Cause: The obfuscation toolkit does not support the encryption of already-encrypted data.

Action: Do not attempt to encrypt already-encrypted data.

ORA-28234 key length too short

Cause: The key specified is too short for the algorithm. DES requires a key of at least 8 bytes. Triple DES requires a key of at least 16 bytes in two-key mode and 24 bytes in three-key mode.

Action: Specify a longer key.

ORA-28235 algorithm not available

Cause: The desired encryption algorithm is not available.

Action: Run the installer to install the needed algorithm in Oracle Advanced Security.

ORA-28236 invalid Triple DES mode

Cause: An unknown value was specified for the mode in which triple DES encryption is to run.

Action: Specify a valid value. See the package declaration for a list of valid values.

ORA-28237 seed length too short

Cause: The seed specified for the key generation routine must be at least 80 characters.

Action: Specify a longer seed.

ORA-28238 no seed provided

Cause: A NULL value was passed in as the seed to be used in generating a key.

Action: Provide a non-NULL value for the seed.

ORA-28239 no key provided

Cause: A NULL value was passed in as an encryption or decryption key.

Action: Provide a non-NULL value for the key.

ORA-28261 CURRENT_USER can not be used in PLSQL Definer's Right procedure.

Cause: An attempt to retrieve CURRENT_USER using SYS_CONTEXT PLSQL interface.

Action: Use a SQL statement to query CURRENT_USER inside a DR procedure.

ORA-28262 global_context_pool_size has invalid value.

Cause: Initialization parameter GLOBAL_CONTEXT_POOL_SIZE has a value less than the minimum required value (10K).

Action: Specify a value for the initialization parameter GLOBAL_CONTEXT_POOL_SIZE that is atleast 10k.

ORA-28263 Insufficient memory in global context pool

Cause: Allocations for the global context heap exceeded the value set in the initialization parameter file.

Action: Increase the value of the GLOBAL_CONTEXT_POOL_SIZE initialization parameter or clear unused global context.

ORA-28264 Client identifier is too long

Cause: The length of the client identifier is longer than 64.

Action: Set a client identifier whose length is less than 64.

ORA-28265 NameSpace beginning with 'sys_' is not allowed

Cause: Namespace beginning with 'sys_' is not allowed.

Action: Use a namespace that does not begin with 'sys_'.

ORA-28270 Malformed user nickname for password authenticated global user

Cause: An attempt to login as password-auuthenticated global user with a malformed user nickname.

Action: Make sure the nickname is valid and re-login.

ORA-28271 No permission to read user entry in LDAP directory service

Cause: ORACLE server does not have read permission on user nickname's X.500 user entry.

Action: Make sure ORACLE server is using the correct SSL credentials to connect to LDAP directory services. Make sure permissions for LDAP user entries are correct.

ORA-28272 Domain policy restricts password based GLOBAL user authentication

Cause: Domain policy does not allow password-authenticated GLOBAL users.

Action: Make sure ORACLE server is using the correct SSL credentials to connect to LDAP directory services. Make sure orclDBAuthTypes attributes within Oracle enterprise domain object is either set to PWD or ALL.

ORA-28273 No mapping for user nickname to LDAP distinguished name exists

Cause: ORACLE server cannot map the given user nickname to LDAP distinguished name.

Action: Make sure user entries in LDAP are correctly provisioned with correct user nickname attribute values.

ORA-28274 No ORACLE password attribute corresponding to user nickname exists

Cause: LDAP user entry corresponding to user nickname does not have a ORACLE password attribute or the attribute is not initialized.

Action: Make sure user entries in LDAP are correctly provisioned with correct ORACLE password attribute values.

ORA-28275 Multiple mappings for user nickname to LDAP distinguished name exist

Cause: The given user nickname maps to more than one LDAP distinguished name.

Action: Make sure user nickname is unique within the enterprise.

ORA-28276 Invalid ORACLE password attribute

Cause: The ORACLE password attribute of a user entry has an invalid format.

Action: Make sure ORACLE password attribute value is RFC-2307 compliant.

ORA-28277 LDAP search, while authenticating global user with passwords, failed

Cause: The LDAP search for finding the appropriate user entry and ORACLE password failed.

Action: Make sure LDAP directory service is up and running.

ORA-28278 No domain policy registered for password based GLOBAL users

Cause: No policy about password authenticated GLOBAL users has been registered.

Action: Add attribute orclDBAuthTypes to the database server's Enterprise domain.

ORA-28279 Error reading rdbms_server_dn parameter in INIT.ORA

Cause: The initialization parameter RDBMS_SERVER_DN is not specified corrrectly (cannot be normalized).

Action: Make sure the RDBMS_SERVER_DN initialization parameter is set to a correct value.

ORA-28280 Multiple entries for ORACLE database password exist.

Cause: The ORACLE password attribute of a user entry has multiple entries of ORACLE database password.

Action: Make sure ORACLE password attribute has one entry for ORACLE Database password.

ORA-28500 connection from ORACLE to a non-Oracle system returned this message:

Cause: The cause is explained in the forwarded message.

Action: See the non-Oracle system's documentation of the forwarded message.

ORA-28501 communication error on heterogeneous database link

Cause: An unexpected communication failure occurred on a heterogeneous database link to a non-Oracle system. The message above will be followed by a second message generated by the connected non-Oracle system.

Action: See the documentation for the non-Oracle system for an explanation of the second error message.

ORA-28502 internal communication error on heterogeneous database link

Cause: A communication error internal to Oracle's heterogeneous services has occurred.

Action: Contact Oracle Support Services.

ORA-28503 bind value cannot be translated into SQL text for non-Oracle system

Cause: A SQL statement used bind variables on a Heterogeneous Services database link to a non-Oracle system, but the non-Oracle system does not support bind variables.

Action: Change your SQL statement so that it does not use bind variables.

ORA-28504 ROWID not found in ROWID cache for heterogeneous database link

Cause: The ROWID cache for Heterogeneous Services held no entry that corresponds to the specified ROWID. The ROWID entry may have been overwritten in the ROWID cache.

Action: Enlarge the Heterogeneous Services ROWID cache size by increasing the value of the HS_ROWID_CACHE_SIZE Heterogenious Services initialization parameter.

ORA-28505 cannot get non-Oracle system capabilities from string

Cause: Oracle was unable to retrieve capability information for the non-Oracle system connected through a heterogeneous database link. This capability information should be stored in data dictionary tables viewable with the HS_CLASS_CAPS or HS_INST_CAPS data dictionary views.

Action: Contact the database administrator to check the server data dictionary table named in the error message. If table contents are incorrect, the database administrator should restore all data dictionary content for this FDS_CLASS_NAME and/or FDS_INST_NAME. It usually is sufficient to delete all current data dictionary content for this class and/or instance and initiate a new connection to let the connected agent upload new data dictionary content to the server.

ORA-28506 parse error in data dictionary translation for string stored in string

Cause: A reference to an Oracle data dictionary table or view name on a heterogeneous database link to a non-Oracle system could not be translated. The Oracle data dictionary tables shown with view HS_CLASS_DD contain invalid SQL for the data dictionary translation.

Action: Contact customer support of the agent vendor.

ORA-28507 error in data dictionary view string

Cause: The initialization parameter table for the Heterogeneous Services was not available, or its structure (number of columns or column types) was incorrect.

Action: Verify correct installation of the following Heterogeneous Services' initialization parameter views: HS_CLASS_INIT and HS_INST_INIT. If these views are not available, make sure you ran the script CATHS.SQL in the $ORACLE_HOME/rdbms/admin directory.

ORA-28508 invalid value string for Heterogeneous Services initialization parameter string

Cause: The specified Heterogeneous Services initialization parameter had an invalid value when attempting to connect to a non-Oracle system.

Action: Check the Heterogeneous Services and agent documentation to determine acceptable values.

ORA-28509 unable to establish a connection to non-Oracle system

Cause: Initialization of a database link to a non-Oracle system failed to connect to the Heterogeneous Services agent process for this non-Oracle system.

Action: Check the Net8 service name definition in the following places:

  • the USING clause of the CREATE DATABASE LINK statement
  • the TNSNAMES.ORA file
  • the Oracle Names Server

The following are possible reasons for name mismatches:

  • The USING clause in the CREATE DATABASE LINK statement has to match the service name defined in the TNSNAMES.ORA file or in the Oracle Names Server.
  • The protocol-specific information in the service name definition must match the protocol-specific definition of the responding listener.
  • The SID=name in the service name definition (in the TNSNAMES.ORA file or in Oracle Names Server) must match the value in the LISTENER.ORA file for the responding listener.

ORA-28510 heterogeneous database link initialization failed

Cause: Initialization of a heterogeneous database link to a non-Oracle system failed due to an error identified by the agent for this non-Oracle system.

Action: Make sure the non-Oracle system is up and running and that all of the environment and initialization values for the agent are set correctly.

ORA-28511 lost RPC connection to heterogeneous remote agent using SID=string

Cause: A fatal error occurred in one of the following places:

  • the connection between the Oracle server and the agent
  • the heterogeneous services remote agent itself
  • the connection to the non-Oracle system

This error occurred after communication had been established successfully.

Action: Check for network problems and remote host crashes. The problem is probably in the agent software. If so, contact customer support of the agent vendor.

ORA-28512 cannot get data dictionary translations from string

Cause: Oracle was unable to retrieve data dictionary translation information for the non-Oracle system connected through a heterogeneous database link. This data dictionary translation information should be stored in data dictionary tables viewable with the HS_CLASS_DD or HS_INST_DD data dictionary views.

Action: Ask your database administrator to check the server data dictionary table named in the error message. If table contents are incorrect, the database administrator should restore all data dictionary content for this FDS_CLASS_NAME and/or FDS_INST_NAME. It usually is sufficient to delete all current data dictionary content for this class and/or instance and initiate a new connection to let the connected agent upload new data dictionary content to the server.

ORA-28513 internal error in heterogeneous remote agent

Cause: An internal error has occurred in the Oracle remote agent supporting a heterogeneous database link.

Action: Make a note of how the error was produced and contact customer support of the agent vendor.

ORA-28514 heterogeneous database link initialization could not convert system date

Cause: The system date was not retrievable.

Action: Verify that the Oracle server's host machine and operating system are operational. This error should not occur unless low level system functions are failing.

ORA-28515 cannot get external object definitions from string

Cause: Oracle was unable to retrieve definitions of distributed external procedures or remote libraries registered for the non-Oracle system instance, probably because the underlying data dictionary table does not exist or is malformed.

Action: Verify that the Oracle server's Heterogeneous Services data dictionary was installed correctly. If the Heterogeneous Services data dictionary is not installed, execute the CATHS.SQL script in the $ORACLE_HOME/rdbms/admin directory.

ORA-28518 data dictionary translation has illegal translation type

Cause: A data dictionary translation definition, either in the Oracle server data dictionary or in data dictionary content uploaded from a Heterogeneous Services agent, specified an illegal translation type code. Legal values are 'T' or 't' for 'translate', 'M' or 'm' for 'mimic'. Information on the exact data dictionary translation causing the error is written to a trace (*.TRC) file for the Oracle instance and to the Oracle instance's alert log. This error occurs when a Heterogeneous Services agent uploads data dictionary content to an Oracle server on the first connection from the server to the agent.

Action: Contact the customer support of the agent vendor.

ORA-28519 no heterogeneous data dictionary translations available

Cause: The Oracle server's data dictionary did not define data dictionary translations for the connected non-Oracle system, and automatic self-registration (data dictionary upload) was disabled.

Action: Ask a database administrator to resolve this problem. The easiest solution is to enable automatic self-registration by setting the Oracle server's HS_AUTO_REGISTER initialization parameter to TRUE. An alternative is to load the Heterogeneous Services data dictionary with information specific for the non-Oracle system by executing a SQL script supplied by the agent vendor. If the script is run and the error persists, contact customer support of the agent vendor.

ORA-28520 error initializing heterogeneous data dictionary translations

Cause: Oracle was unable to retrieve data dictionary translations for the non-Oracle system instance, probably because the underlying data dictionary table does not exist or is formed incorrectly.

Action: Verify that the Oracle server's Heterogeneous Services data dictionary was installed correctly. If the Heterogeneous Services data dictionary is not installed, execute the CATHS.SQL script in the $ORACLE_HOME/rdbms/admin directory. If the connected agent, identified by FDS_CLASS_NAME, requires a custom installation script for the Oracle server, verify that the script has been run. If both scripts were executed and the error persists, contact customer support of the agent vendor.

ORA-28521 no heterogeneous capability information available

Cause: The Oracle server's data dictionary did not contain capability definitions for the connected non-Oracle system, and automatic self-registration (data dictionary upload) was disabled.

Action: Ask a database administrator to resolve this problem. The easiest resolution is to enable automatic self-registration by setting the Oracle server's HS_AUTO_REGISTER initialization parameter to TRUE. An alternative is to load the Heterogeneous Services data dictionary with information specific for the non-Oracle system by executing a SQL script supplied by the agent vendor. If the script is run and the error persists, contact customer support of the agent vendor.

ORA-28522 error initializing heterogeneous capabilities

Cause: Oracle was unable to retrieve capability definitions for the non-Oracle system instance, probably because the underlying data dictionary table does not exist or is formed incorrectly.

Action: Verify that the Oracle server's Heterogeneous Services data dictionary was installed correctly. If the Heterogeneous Services data dictionary is not installed, execute the CATHS.SQL script in the $ORACLE_HOME/rdbms/admin directory. If the connected agent, identified by FDS_CLASS_NAME, requires a custom installation script for the Oracle server, verify that the script has been run. If both scripts were executed and the error persists, contact customer support of the agent vendor.

ORA-28523 ORACLE and heterogeneous agent are incompatible versions

Cause: An operation on a database link attempted to connect to a non-Oracle system, but the Oracle instance and the agent process for the non-Oracle system are incompatible.

Action: Ask your database administrator to confirm configuration of both the Oracle instance and the agent. Additional information on the version incompatibility is logged in trace (*.TRC) files, the Oracle instance and the agent, and in the Oracle instance's alert log. Check the documentation for your agent to find out which releases of the Oracle Server are supported.

ORA-28525 unable to create Heterogeneous Services error message text

Cause: Incorrect arguments were passed into the error message creation routine.

Action: Contact Oracle Support Services.

ORA-28526 invalid describe information returned to Heterogeneous Services

Cause: The Heterogeneous Services received invalid describe information for a select list, bind list, or stored procedure from the Heterogeneous Services agent. This indicates a problem with the Heterogeneous Services' non-Oracle system agent.

Action: Contact customer support of the agent vendor.

ORA-28527 Heterogeneous Services datatype mapping error

Cause: Either an Oracle datatype could not be mapped to a non-Oracle datatype, or a non-Oracle datatype could not be mapped to an Oracle datatype. These mappings are defined as capability definitions in the Oracle server's data dictionary.

Action: Verify that the Oracle server's data dictionary has been initialized with correct capability definitions for the connected FDS_CLASS_NAME and FDS_INST_NAME. If table contents are incorrect, a database administrator should restore all data dictionary content for this FDS_CLASS_NAME and/or FDS_INST_NAME. It usually is sufficient to delete all current data dictionary content for this class and/or instance and initiate a new connection to let the connected agent upload new data dictionary content to the server. If the error persists contact customer support of the agent vendor.

ORA-28528 Heterogeneous Services datatype conversion error

Cause: Either an Oracle datatype could not be converted to a non-Oracle datatype, or a non-Oracle datatype could not be converted to an Oracle datatype. The following are possible reasons for the conversion failure:

  • overflow problems (in the case of numbers)
  • length limitations (in the case of character strings)
  • invalid values passed into the conversion routines

Action: Contact customer support of the agent vendor. If the problem is due to size discrepancies between Oracle and the non-Oracle system, it may not be possible to convert the value.

ORA-28529 invalid or missing parameter in Net8 service name definition

Cause: There was an invalid or missing Heterogeneous Services parameter in the Net8 service name definition stored in either the TNSNAMES.ORA file or in the Oracle Names Server.

Action: Ask your database administrator to make sure the information in the Net8 service definition is correct and complete. The correct information that should be included in the Net8 service definition can be found in the agent's documentation.

ORA-28530 Heterogeneous Services initialization error in NLS language ID

Cause: Heterogeneous Services was unable to initialize an NLS language ID. Both the Oracle server and the Heterogeneous Services agent for the connected non-Oracle system must have language IDs.

Action: Contact Oracle Support Services.

ORA-28533 Heterogeneous Services coercion handling error

Cause: The Heterogeneous Services encountered an error in coercion handling. The HS can, if the agent vendor so chooses, perform extra processing on SQL statements that contain implicit coercions or that contain coercion functions such as TO_CHAR, TO_NUMBER or TO_DATE. This functionality is controlled by coercion-related capabilities. HS logic reports this error when it encounters an error in one of these capability definitions.

Action: The capability table settings are controlled by the agent vendor and can be modified by the database administrator. Contact your database administrator and agent vendor and get the correct set of capabilities installed.

ORA-28534 Heterogeneous Services preprocessing error

Cause: One of the things that the Heterogeneous Services can do is to preprocess parts of SQL statements that contain implicit coercions or calls to explicit coercion functions like TO_CHAR TO_NUMBER or TO_DATE. For example, it could convert a call to TO_DATE to a bind variable, pre-evaluate the TO_DATE function call and pass the resulting value to the non-Oracle system as the bind value. This behavior is controlled by some coercion related capabilities. If the capabilities are set incorrectly, the HS could encounter errors when it attempts to do the preprocessing. If it does then this error will be signaled.

Action: The capability table settings are controlled by the agent vendor and can be modified by the database administrator. Contact your database administrator and agent vendor and get the correct set of capabilities installed.

ORA-28535 invalid Heterogeneous Services context

Cause: A Heterogeneous Services agent's driver module called an HS service routine with an invalid HS context value. This probably is a logic error in the driver.

Action: Contact customer support of the agent vendor.

ORA-28536 error in processing Heterogeneous Services initialization parameters

Cause: An error described by a subsequent error message prevented successful processing of Heterogeneous Services initialization parameters from the Oracle server data dictionary.

Action: Check server data dictionary views HS_CLASS_INIT, HS_INST_INIT, and HS_ALL_INITS. Look for conditions which could produce the error identified in the error message immediately following this one.

ORA-28538 result set not found

Cause: The client program tried fetching from a result set that is no longer open. Many gateways will, on execution of a stored procedure, automatically close all result sets that were returned by any previously executed stored procedure.

Action: Check the documentation for the gateway that you are using and see if it will automatically close currently open result sets each time a stored procedure is executed. Then check if your client program is violating this rule. If it is, fix your program. If it is not, contact Oracle Support Services.

ORA-28539 gateway does not support result sets

Cause: The client program tried executing a stored procedure that returns one or more result sets through a gateway that does not have result set support.

Action: Check the documentation for the gateway that you are using and see if it supports result sets returned from stored procedures. If it does not, then the only way of accessing such stored procedures is to upgrade to a version of the gateway that does support result sets (if such a version exists). If the gateway does have result set support and you are still seeing this error, contact Oracle Support Services.

ORA-28541 Error in HS init file on line number.

Cause: A syntax error occurred in the gateway initialization file.

Action: Check the gateway init file to correct the syntax error. For further information, check the error message in the gateway trace file.

ORA-28542 Error in reading HS init file

Cause: Reading the gateway init file generated an error.

Action: Check the gateway initialization file name to see that the gateway initialization file acctually exists. Check the ifile parameter to see that it points to the correct location.

ORA-28543 Error initializing apply connection to non-Oracle system

Cause: Attempt to initialize connection to non-Oracle for heterogeneous replication failed.

Action: Check if the listener used to connect to the gateway is up and is correctly configured. Make sure that the database link used has been configured correctly and, if a tnsnames alias has been used in the database link definition, make sure that the configuration of the entry in tnsnames.ora has been done correctly.

ORA-28544 connect to agent failed, probable Net8 administration error

Cause: Net8 reported a failure to make a RSLV connection or a protocol mode error when the Oracle database server attempted to establish communication with a Heterogeneous Services agent or an external procedure agent. This usually is due to an administration error in setting up Net8 service definitions in TNSNAMES.ORA or LISTENER.ORA: A basic network connection is opened, but it connects to a program which does not use the appropriate protocol. This often is a sign that the connection goes to the wrong program.

Action: Check Net8 administration in the following ways:

  • When using TNSNAMES.ORA or an Oracle Names server, make sure that the connection from the ORACLE server uses the correct service name or SID.
  • Check LISTENER.ORA on the agent's host machine to assure that the service name or SID refers to the correct agent executable in its (PROGRAM=...) clause.
  • Confirm in TNSNAMES.ORA or the equivalent service definition that service 'extproc_connection_data' does NOT contain (HS=), or that the service definition used by a Heterogeneous Services database link DOES contain (HS=).

ORA-28545 error diagnosed by Net8 when connecting to an agent

Cause: An attempt to call an external procedure or to issue SQL to a non-Oracle system on a Heterogeneous Services database link failed at connection initialization. The error diagnosed by Net8 NCR software is reported separately.

Action: Refer to the Net8 NCRO error message. If this isn't clear, check connection administrative setup in tnsnames.ora and listener.ora for the service associated with the Heterogeneous Services database link being used, or with 'extproc_connection_data' for an external procedure call.

ORA-28546 connection initialization failed, probable Net8 admin error

Cause: A failure occurred during initialization of a network connection from the Oracle database server to a second process: The connection was completed but a disconnect occurred while trying to perform protocol-specific initialization, usually due to use of different network protocols by opposite sides of the connection. This usually is caused by incorrect Net8 administrative setup for database links or external procedure calls. The most frequent specific causes are:

  • Database link setup for an Oracle-to-Oracle connection instead connects to a Heterogeneous Services agent or an external procedure agent.
  • Database link setup for a Heterogeneous Services connection instead connects directly to an Oracle database server.
  • The extproc_connection_data definition in tnsnames.ora connects to an Oracle instance instead of an external procedure agent.
  • Connect data for a Heterogeneous Services database link, usually defined in tnsnames.ora, does not specify (HS=).
  • Connect data for an Oracle-to-Oracle database link, usually defined in tnsnames.ora, specifies (HS=).

Action: Check Net8 administration in the following ways:

  • When using TNSNAMES.ORA or an Oracle Names server, make sure that the connection from the ORACLE server uses the correct service name or SID.
  • Check LISTENER.ORA on the connection end point's host machine to assure that this service name or SID connects to the correct program.
  • Confirm in TNSNAMES.ORA or the equivalent service definition that service 'extproc_connection_data' does NOT contain (HS=), or that the service definition used by a Heterogeneous Services database link DOES contain (HS=).

ORA-28550 pass-through SQL: cursor not found

Cause: A value passed to a pass-through SQL function or procedure call as a cursor does not identify a currently open cursor.

Action: Use a cursor number returned by the pass-through SQL OPEN_CURSOR call.

ORA-28551 pass-through SQL: SQL parse error

Cause: A non-Oracle system rejected text supplied as a pass-through SQL statement.

Action: Ensure that the SQL supplied to the pass-through SQL PARSE call is legal for the non-Oracle system.

ORA-28552 pass-through SQL: call flow error

Cause: A pass-through SQL function was called in an invalid order.

Action: Correct program flow by changing the order of API calls to match the flow described in the manual.

ORA-28553 pass-through SQL: invalid bind-variable position

Cause: A pass-through SQL function referring to the position of a bind variable in the currently-parsed SQL statement supplied an invalid bind-variable position. Valid values are 1 through n, where n is the number of bind-variable place-holders in the SQL text.

Action: Verify that the bind-variable position parameter is in the correct range to represent a place-holder in the SQL text. Confirm that the SQL text uses the correct syntax for a bind-variable place-holder, as required by the non-Oracle system.

ORA-28554 pass-through SQL: out of cursors

Cause: The maximum number of open cursors has been exceeded.

Action: Close open cursors by using the pass-through SQL CLOSE_CURSOR function.

ORA-28555 pass-through SQL: required parameter missing or NULL

Cause: An attempt was made to pass a NULL value to a non-NULL parameter.

Action: Use a non-NULL value for the parameter.

ORA-28556 authorization insufficient to access table

Cause: A query attempted to access a table in the non-Oracle system that is either privileged or has privileged columns.

Action: Contact the database administrator for the non-Oracle system. The database administrator can grant permission to access the privileged table or columns.

ORA-28557 unknown string for database link to non-Oracle system

Cause: When attempting to connect to a non-Oracle system through a Heterogeneous Services database link, the agent supporting this non-Oracle system failed to return FDS_CLASS_NAME and/or FDS_INST_NAME. Oracle requires these names to configure the heterogeneous database link.

Action: Contact the database administrator to check setup of the connection and the Heterogeneous Services agent.

ORA-28558 HS_FDS_CONNECT_STRING undefined for non-Oracle system

Cause: A database link to a non-Oracle system had no HS_FDS_CONNECT_STRING initialization parameter in the Oracle server's data dictionary for Heterogeneous Services. Without this parameter, the connection could not be completed.

Action: Contact your database administrator to verify correct setup of an HS_FDS_CONNECT_STRING entry in the Oracle Heterogeneous Services data dictionary.

ORA-28559 FDS_CLASS_NAME is string, FDS_INST_NAME is string

Cause: An associated error was reported in another message, and this message supplies supplementary information to assist diagnosis of that error. FDS_CLASS_NAME and FDS_INST_NAME are used to access information in tables and views of the Oracle data dictionary that direct operation of Heterogeneous Services on a database link to a non-Oracle data store.

Action: Use the FDS_CLASS_NAME and FDS_INST_NAME values to check Oracle data dictionary contents when necessary to diagnose the cause of the associated error.

ORA-28560 error in configuration of agent process

Cause: An Oracle server invoked a function not supported by the connected agent (Heterogeneous Services or external procedures). The most probable cause is incorrect Net8 setup, resulting in use of the wrong agent executable.

Action: Check Net8 administration in the following ways:

  • When using TNSNAMES.ORA or an Oracle Names server, make sure that the connection from the Oracle server uses the correct SID.
  • Check LISTENER.ORA on the agent's host machine to assure that this SID refers to the correct agent executable in its (PROGRAM=...) clause.

ORA-28561 unable to set date format on non-Oracle system

Cause: Initialization of a Heterogeneous Services connection to set the date format to be used on the connected non-Oracle system.

Action: If the Oracle data dictionary supplies a value for the HS_NLS_DATE_FORMAT parameter, confirm that this value is formatted correctly by the rules of the non-Oracle system. Also check for additional information in log and trace files generated by the Heterogeneous Services agent.

ORA-28575 unable to open RPC connection to external procedure agent

Cause: Initialization of a network connection to the external procedure agent did not succeed. This problem can be caused by network problems, incorrect listener configuration, or incorrect transfer code.

Action: Check listener configuration in LISTENER.ORA and TNSNAMES.ORA, or check Oracle Names Server.

ORA-28576 lost RPC connection to external procedure agent

Cause: A fatal error occurred in either an RPC network connection, the external procedure agent, or the invoked 3GL after communication had been established successfully.

Action: First check the 3GL code you are invoking; the most likely cause of this error is abnormal termination of the invoked "C" routine. If this is not the case, check for network problems. Correct the problem if you find it. If all components appear to be normal but the problem persists, the problem could be an internal logic error in the RPC transfer code. Contact Oracle Support Services.

ORA-28577 argument string of external procedure string has unsupported datatype string

Cause: While transferring external procedure arguments to the agent, an unsupported datatype was detected.

Action: Check your documentation for the supported datatypes of external procedure arguments.

ORA-28578 protocol error during callback from an external procedure

Cause: An internal protocol error occurred while trying to execute a callback to the Oracle server from the user's 3GL routine.

Action: Contact Oracle Support Services.

ORA-28579 network error during callback from external procedure agent

Cause: An internal network error occurred while trying to execute a callback to the Oracle server from the user's 3GL routine.

Action: Contact Oracle Support Services.

ORA-28580 recursive external procedures are not supported

Cause: A callback from within a user's 3GL routine resulted in the invocation of another external procedure.

Action: Make sure that the SQL code executed in a callback does not directly call another external procedure, or indirectly results in another external procedure, such as triggers calling external procedures, PL/SQL procedures calling external procedures, and so on.

ORA-28581 protocol error while executing recursive external procedure

Cause: An internal protocol error occurred while trying to execute an external procedure resulting from a callback in another external procedure.

Action: Contact Oracle Support Services.

ORA-28582 a direct connection to this agent is not allowed

Cause: A user or a tool tried to establish a direct connection to either an external procedure agent or a Heterogeneous Services agent, for example: "SVRMGR> CONNECT SCOTT/TIGER@NETWORK_ALIAS". This type of connection is not allowed.

Action: When executing the CONNECT statement, make sure your database link or network alias is not pointing to a Heterogeneous Option agent or an external procedure agent.

ORA-28583 remote references are not permitted during agent callbacks

Cause: A Heterogeneous Services agent issued a callback to the Oracle database server which attemted to access a remote system. This is not supported.

Action: Make sure that SQL code issued by Heterogeneous Services agents does not reference a database link.

ORA-28584 heterogeneous apply internal error

Cause: The apply slave process encountered an error while trying to apply changes through a gateway to a non-Oracle system.

Action: Make sure that the apply database link is correctly configured and that the gateway listener and the non-Oracle system are correctly set up and are up and running. If everything is configured correctly and the problem still occurs, then contact Oracle Support Services.

ORA-28590 agent control utility: illegal or badly formed command

Cause: The user has issued an unrecognized or syntactically incorrect command.

Action: Refer to documentation and correct the syntax of the command.

ORA-28591 agent control utility: unable to access parameter file

Cause: The agent control utility was unable to access its parameter file. This could be because it could not find its ADMIN directory or because permissions on directory were not correctly set.

Action: The agent control utility puts its parameter file in either the directory pointed to by the environment variable AGTCTL_ADMIN or in the directory pointed to by the environment variable TNS_ADMIN. Make sure that at least one of these environment variables is set and that it points to a directory that the agent has access to.

ORA-28592 agent control utility: agent SID not set

Cause: The agent needs to know the value of the AGENT_SID parameter before it can process any commands. If it does not have a value for AGENT_SID then all commands will fail.

Action: Issue the command SET AGENT_SID value and then retry the command that failed.

ORA-28593 agent control utility: command terminated with error

Cause: An error occurred during the processing of the command. There could be several causes. A SET or an UNSET command could have been issued after the agent was started. This is illegal. The user may have attempted to start two agents with the same SID value or the user could have attempted to shut down an agent that is no longer running.

Action: If the user wishes to issue a SET or an UNSET command, he should make sure the agent is shut down first by issuing the SHUTDOWN command.

ORA-28594 agent control utility: invalid parameter name

Cause: The user tried to set or unset an invalid agent parameter.

Action: Refer to documentation and correct the parameter name.

ORA-28601 invalid [no]MINIMIZE option

Cause: User did not type this alter table table_name MINIMIZE RECORDS_PER_BLOCK or alter table table_name NOMINIMIZE RECORDS_PER_BLOCK.

Action: Re-enter correct SQL command.

ORA-28602 statement not permitted on tables containing bitmap indexes

Cause: Table has bitmap indexes and user is minimizing or nominalizing RECORDS_PER_BLOCK.

Action: Drop all bitmap indexes before changing RECORDS_PER_BLOCK.

ORA-28603 statement not permitted on empty tables

Cause: Table is empty and statement does not work on empty tables.

Action: Try statement after loading your data.

ORA-28604 table too fragmented to build bitmap index (string,string,string)

Cause: The table has one or more blocks that exceed the maximum number of rows expected when creating a bitmap index. This is probably due to deleted rows. The values in the message are: (data block address, slot number found, maximum slot allowed)

Action: Defragment the table or block(s). Use the values in the message to determine the FIRST block affected (there may be others).

ORA-28605 bitmap indexes cannot be reversed

Cause: An attempt was made to create reverse bitmap index. This is not supported.

Action: No action required.

ORA-28611 bitmap index is corrupted - see trace file for diagnostics

Cause: Validate Index detected bitmap corruption in its argument index.

Action: Drop this bitmap index and create a new one.

ORA-28650 Primary index on an IOT cannot be rebuilt

Cause: An attempt was made to issue alter index rebuild on IOT-TOP.

Action: Use Alter table MOVE to reorganize the table(IOT).

ORA-28651 Primary index on IOTs can not be marked unusable

Cause: An attempt was made to mark IOT-TOP unusable through ALTER INDEX.

Action: Remove the option UNUSABLE.

ORA-28652 overflow segment attributes cannot be specified

Cause: During ALTER MOVE ONLINE of a index-organized table, the user attempted to enter one or more of the following options: OVERFLOW, PCTTHRESHOLD,INCLUDING.

Action: Remove the illegal option(s).

ORA-28653 tables must both be index-organized

Cause: An attempt was made to exchange a non-IOT table/partition with a partition/table respectively.

Action: Ensure that non-partitioned and partitioned tables are both index-organized.

ORA-28654 table and partition not overflow compatible

Cause: If one of the tables (partitioned/non-partitioned) has overflow data segment and the other one does not.

Action: Ensure that non-partitioned and partitioned tables both have overflow data segment or neither one does.

ORA-28655 Alter table add overflow syntax error

Cause: Syntax error.

Action: Check the syntax.

ORA-28656 incomplete attribute specification

Cause: The attribute specification is not done for all partitions.

Action: Specify the storage attributes either for ALL partitions or NONE.

ORA-28658 This operation is supported only for Index-Organized tables

Cause: Attempt to perform some IOT specific operation on a non-IOT. This is not supported.

Action: No action required.

ORA-28659 COMPRESS must be specified at object level first

Cause: An attempt was made to specify COMPRESS at the partition level without first specifying it at the table level.

Action: Specify COMPRESS at the table level. Use ALTER TABLE xxx MODIFY DEFAULT ATTRIBUTES COMPRESS ...

ORA-28660 Partitioned Index-Organized table may not be MOVEd as a whole

Cause: An attempt was made to MOVE a partitioned index-organized table as a whole. This is not supported.

Action: Do not try to MOVE a partitioned index-organized table as a whole.

ORA-28661 Object already has COMPRESS clause specified

Cause: An attempt was made to specify COMPRESS for an index-organized table/index which already has a compression clause. This attribute can only be specified at creation time.

Action: Do not specify COMPRESS for an index-organized table/index which already has a compression clause.

ORA-28662 IOT index and overflow segments must share the same LOGGING attribute

Cause: An attempt was made to specify LOGGING for one segment and NOLOGGING for the other segment.

Action: Use the same attribute value for both segments.

ORA-28663 Logging/Nologging attribute can not be specified in the statement ALTER TABLE ADD OVERFLOW

Cause: An attempt was made to specify LOGGING for an ALTER TABLE ADD OVERFLOW statement.

Action: Do not specify LOGGING in this context.

ORA-28664 a partitioned table may not be coalesced as a whole

Cause: User attempted to coalesce a partitioned IOT using ALTER TABLE COALESCE statement, which is illegal.

Action: Coalesce the table a partition at a time (using ALTER TABLE MODIFY PARTITION COALESCE).

ORA-28665 table and partition must have same compression attribute

Cause: User attempted to EXCHANGE a compression enabled partition with a compression disabled table or vice versa OR the # of columns compressed is different for table and partition.

Action: Make sure the compression attributes match. If they don't, fix it using ALTER TABLE MOVE [PARTITION] COMPRESS.

ORA-28666 option not allowed for an index on UROWID column(s)

Cause: User attempted to build a REVERSE or COMPRESSED or GLOBAL partitioned index on UROWID column(s).

Action: Build the index without these options.

ORA-28667 USING INDEX option not allowed for the primary key of an IOT

Cause: User attempted to define storage attributes for the primary key index of an Index-Organized table with USING INDEX clause. All the storage attribute defined for the (IOT)table applies to the primary key index and a separate USING INDEX clause is not required.

Action: Remove the USING INDEX clause and specify all attributes directly for the table.

ORA-28668 cannot reference mapping table of an index-organized table

Cause: An attempt to directly access the mapping table of an index-organized table.

Action: Issue the statement against the parent index-organized table containing the specified mapping table.

ORA-28669 bitmap index can not be created on an IOT with no mapping table

Cause: User attempted to create a bitmap index on an index-organized table without a mapping table.

Action: Enable bitmap indexes on the Index-organized table by creating a mapping table using 'ALTER TABLE ... MOVE MAPPING TABLE'.

ORA-28670 mapping table cannot be dropped due to an existing bitmap index

Cause: User attempted to drop the mapping table with NOMAPPING option when the IOT has one or more bitmap indexes.

Action: Drop the bitmap index(es) before dropping the mapping table.

ORA-28671 UPDATE BLOCK REFERENCES may not be used on a partitioned index as a whole

Cause: User attempted to UPDATE BLOCK REFERENCES on a partitioned index using ALTER INDEX UPDATE BLOCK REFERENCES statement, which is illegal.

Action: Issue a partition level operation with ALTER INDEX ... PARTITION ... UPDATE BLOCK REFERENCES.

ORA-28672 UPDATE BLOCK REFERENCES may not be used on a global index

Cause: User attempted to UPDATE BLOCK REFERENCES on a global partitioned or non-partitioned index. This feature is not supported for non-partitioned or global partitioned indexes on a partitioned IOT and a global partitioned index on a non-partitioned IOT.

Action: Use online index [partition] rebuild to fix the block references.

ORA-28673 Merge operation not allowed on an index-organized table

Cause: User attempted merge operation on an index-organized table. Merge is not supported on an IOT .

Action: Use updates and inserts on the index-organized table.


ORA-29250 to ORA-32799

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

14
ORA-29250 to ORA-32799

ORA-29250 Invalid index specifed in call to dbms_sql.bind_array

Cause: An invalid index was specified in a call to BIND_ARRAY of DBMS_SQL. The index may have been null or of an improper value.

Action: Correct the index value by modifying your PL/SQL program and try the BIND_ARRAY call again.

ORA-29251 Index1 is greater than Index2 in call to dbms_sql.bind_array

Cause: The value of index1 was greater than the value for index2 in the call to BIND_ARRAY. This is illegal since the elements of the table that will be bound are those with indexes greater than or equal to index1 and less than or equal to index2.

Action: Correct the value of the two indexes and try the call to again BIND_ARRAY.

ORA-29252 collection does not contain elements at index locations in call to dbms_sql.bind_array

Cause: The bound table does not contain elements at both index locations in call to BIND_ARRAY of DBMS_SQL. This is illegal. Both index locations must contain elements. In other words tab.exists(index1) and tab.exists(index2) must both return true.

Action: Either modify the two indexes or the contents of the table and try the call again.

ORA-29253 Invalid count argument passed to procedure dbms_sql.define_array

Cause: The count argument specified in the call to procedure DEFINE_ARRAY of package DBMS_SQL had an invalid value. Invalid values are negative numbers and nulls. The argument must be a positive integer.

Action: Correct your PL/SQL program so that only valid arguments are passed to DEFINE_ARRAY and try again.

ORA-29254 Invalid lower_bound argument passed to procedure dbms_sql.define_array

Cause: The LOWER_BOUND argument specified in the call to procedure DEFINE_ARRAY had an invalid value. Legal values are all integers (both positive and negative) including zero. The null value is illegal.

Action: Correct your PL/SQL program so that only valid arguments are passed to DEFINE_ARRAY and try again.

ORA-29255 Cursor contains both bind and define arrays which is not permissible

Cause: Both DEFINE_ARRAY and BIND_ARRAY have been called on this cursor. This is illegal. It is not possible for a cursor to both contain array binds and array defines. The semantics of this setting are nonsensical. Array defines are used to move data from select queries into PL/SQL tables and array binds to bind PL/SQL tables to non-select queries.

Action: Modify your PL/SQL program to only perform calls to one of the two functions depending on the kind of cursor at hand.

ORA-29256 Cursor contains both regular and array defines which is illegal

Cause: Both DEFINE_ARRAY and DEFINE_COLUMN have been called on this cursor. This is illegal. It is not possible for a cursor to both contain regular and array defines. The semantics of this setting are nonsensical. Array defines are used to move data from select queries into PL/SQL tables and regular defines to move data from select queries into PL/SQL variables.

Action: Modify your PL/SQL program to only perform calls to one of the two functions depending on the situation at hand.

ORA-29257 host string unknown

Cause: The specified host name was unknown.

Action: Check the spelling of the host name or the IP address. Make sure that the host name or the IP address is valid.

ORA-29258 buffer too small

Cause: The input or output buffer was too small for the operation.

Action: Increase the size of the buffer and retry the operation.

ORA-29259 end-of-input reached

Cause: The end of the input was reached.

Action: If the end of the input is reached prematurely, check if the input source terminates prematurely. Otherwise, close the connection to the input.

ORA-29260 network error: string

Cause: A network error occurred.

Action: Fix the network error and retry the operation.

ORA-29261 bad argument

Cause: A bad argument was passed to the PL/SQL API.

Action: Check the arguments passed to the PL/SQL API and retry the call.

ORA-29262 bad URL

Cause: An improperly formed URL was passed to the PL/SQL API.

Action: Check the URL and retry the call.

ORA-29263 HTTP protocol error

Cause: An HTTP protocol error occurred during the HTTP operation.

Action: Check the HTTP server on which the HTTP operation was performed to make sure that it follows the HTTP protocol standard.

ORA-29264 unknown or unsupported URL scheme

Cause: The URL scheme was unknown or unsupported.

Action: Check the URL to make sure that the scheme is valid and supported.

ORA-29265 HTTP header not found

Cause: The requested HTTP header was not found.

Action: Check to make sure that the requested HTTP header is present.

ORA-29266 end-of-body reached

Cause: The end of the HTTP response body was reached.

Action: If the end of the HTTP response is reached prematurely, check if the HTTP response terminates prematurely. Otherwise, end the HTTP response.

ORA-29267 illegal call

Cause: The call to the PL/SQL API was illegal at the current stage of the operation.

Action: Retry the call at a different stage of the operation.

ORA-29268 HTTP client error string

Cause: The HTTP response indicated that the HTTP client error occurred.

Action: Fix the HTTP client error and retry the HTTP request.

ORA-29269 HTTP server error string

Cause: The HTTP response indicated that the HTTP server error occurred.

Action: Fix the HTTP server error and retry the HTTP request. Contact the administrator of the HTTP server when necessary.

ORA-29270 too many open HTTP requests

Cause: Too many HTTP requests were opened.

Action: End some HTTP requests and retry the HTTP request.

ORA-29271 not connected

Cause: The network connection was not made while the network operation was attempted.

Action: Retry the network operation after the network connection is made successfully.

ORA-29272 initialization failed

Cause: The UTL_HTTP package failed to initialize.

Action: Free up some memory or other system resources and retry the operation.

ORA-29273 HTTP request failed

Cause: The UTL_HTTP package failed to execute the HTTP request.

Action: Use get_detailed_sqlerrm to check the detailed error message. Fix the error and retry the HTTP request.

ORA-29274 fixed-width multibyte character set not allowed for a URL

Cause: The character set used as an encoding of the URL is a fixed-width multibyte character set and is not allowed for a URL.

Action: Use the corresponding variable-width multibyte character set for the URL instead.

ORA-29275 partial multibyte character

Cause: The requested read operation could not complete because a partial multibyte character was found at the end of the input.

Action: Ensure that the complete multibyte character is sent from the remote server and retry the operation. Or read the partial multibyte character as RAW.

ORA-29276 transfer timeout

Cause: Timeout occurred while reading from or writing to a network connection.

Action: Check the remote server or the network to ensure that it responds within the timeout limit. Or increase the timeout value.

ORA-29277 invalid SMTP operation

Cause: The SMTP operation was invalid at the current stage of the SMTP transaction.

Action: Retry the SMTP operation at the appropriate stage of the SMTP transaction.

ORA-29278 SMTP transient error: string

Cause: An SMTP transient error occurred.

Action: Correct the error and retry the SMTP operation.

ORA-29279 SMTP permanent error: string

Cause: An SMTP permanent error occurred.

Action: Correct the error and retry the SMTP operation.

ORA-29280 invalid directory path

Cause: A corresponding directory object does not exist.

Action: Correct the directory object parameter, or create a corresponding directory object with the CREATE DIRECTORY command.

ORA-29281 invalid mode

Cause: An invalid value was specified for file open mode.

Action: Correct the mode to be one of the values: 'r', 'a', or 'w'.

ORA-29282 invalid file ID

Cause: A file ID handle was specified for which no corresponding open file exists.

Action: Verify that the file ID handle is a value returned from a call to UTL_FILE.FOPEN.

ORA-29283 invalid file operation

Cause: An attempt was made to read from a file or directory that does not exist, or file or directory access was denied by the operating system.

Action: Verify file and directory access privileges on the file system, and if reading, verify that the file exists.

ORA-29284 file read error

Cause: An attempt to read from a file failed.

Action: Verify that the file exists, and that it is accessible, and that it is open in read mode.

ORA-29285 file write error

Cause: Failed to write to, flush, or close a file.

Action: Verify that the file exists, that it is accessible, and that it is open in write or append mode.

ORA-29286 internal error

Cause: A fatal error occurred while allocating PL/SQL session memory.

Action: Verify that the PL/SQL session is connected and that adequate memory resources are available.

ORA-29287 invalid maximum line size

Cause: An invalid maximum line size value was specified.

Action: Correct the maximum line size to be in the range [1, 32767].

ORA-29288 invalid file name

Cause: A NULL or zero length file name was specified.

Action: Correct the file name to be a nonzero length string.

ORA-29289 directory access denied

Cause: A directory object was specified for which no access is granted.

Action: Grant access to the directory object by issuing the statement GRANT READ ON DIRECTORY [object] TO [username];.

ORA-29290 invalid offset specified for seek

Cause: An attempt was made to seek past the end of the file, both the absolute and relative offsets were NULL, or the absolute offset was less than zero.

Action: If specifying an absolute offset, then ensure it is in the range [0, <total number of bytes in the file>], or if specifying a relative offset, then ensure it is no greater than the current byte position plus the number of bytes remaining in the file.

ORA-29291 file remove operation failed

Cause: A file deletion attempt was refused by the operating system.

Action: Verify that the file exists and delete privileges granted on the directory and the file.

ORA-29292 file rename operation failed

Cause: A file rename attempt was refused by the operating system either because the source or destination directory does not exist or is inaccessible, the source file isn't accessible, or the destination file exists.

Action: Verify that the source file, source directory, and destination directory exist and are accessible, and that the destination file does not already exist.

ORA-29300 ORACLE error, tablespace point-in-time recovery

Cause: Another Oracle error occurred in the DBMS_PITR package.

Action: See the text of the error message for a description of the error.

ORA-29301 wrong DBMS_PITR package function/procedure order

Cause: The DBMS_PITR package function/procedure was called in an incorrect order.

Action: Restart tablespace point-in-time recovery with a correct procedure.

ORA-29302 database is not open clone

Cause: The database was not opened as a clone database.

Action: Mount the database clone and open the database.

ORA-29303 user does not login as SYS

Cause: The user did not log in as SYS to perform tablespace point-in-time recovery in a clone database.

Action: Log in as SYS and restart tablespace point-in-time recovery.

ORA-29304 tablespace 'string' does not exist

Cause: The selected tablespace does not exist in the database.

Action: Check the list of tablespaces in V$TABLESPACE and select a valid tablespace.

ORA-29305 cannot point-in-time recover tablespace 'string'

Cause: An attempt was made to ALTER the tablespace to be read only.

Action: Check if the tablespace is SYSTEM or with online rollback segment.

ORA-29306 datafile string is not online

Cause: The selected datafile was not online.

Action: Bring the datafile online and rename it if necessary.

ORA-29307 datafile string error, string

Cause: The datafile is not ready for tablespace point-in-time recovery.

Action: Check the correct tablespace point-in-time recovery procedure.

ORA-29308 view TS_PITR_CHECK failure

Cause: Some objects which crossed the boundary of the recovery set were not allowed in the tablespace point-in-time recovery.

Action: Query TS_PITR_CHECK and resolve the boundary crossing objects.

ORA-29309 export dump file was generated by different version of DBMS_PITR package

Cause: The version of DBMS_PITR is different from the version of the cloned database.

Action: Load the version of DBMS_PITR which matches the version of the cloned database.

ORA-29310 database is not open, or opened as a clone

Cause: Either the database was not open, or an attempt was made to open it as a cloned database.

Action: Open the production database instead.

ORA-29311 export dump file was not generated by this database, string does not match

Cause: The export dump files were imported to an incorrect database.

Action: Open the correct production database and try the import again.

ORA-29312 database not compatible, string string

Cause: A point-in-time tablespace was chosen to perform the recovery, but the current database is not compatible with the database that was used to create the point-in-time tablespace.

Action: Choose a point-in-time and retry the operation.

ORA-29313 tablespace 'string' cannot be imported twice

Cause: This is an internal error.

Action: Contact your database administrator.

ORA-29314 tablespace 'string' is not OFFLINE FOR RECOVER nor READ ONLY

Cause: Tablespace clean SCN is either 0 or invalid.

Action: ALTER the tablespace OFFLINE FOR RECOVER.

ORA-29315 tablespace 'string' has been recreated

Cause: An attempt was made to recover a tablespace to a point-in-time before it was re-created.

Action: Choose a different point in time for recovery.

ORA-29316 datafile string been imported twice

Cause: This is an internal error.

Action: Contact your database administrator.

ORA-29317 datafile string does not exist

Cause: The specified datafile could not be found in the production database.

Action: Copy the datafile from the clone database.

ORA-29318 datafile string is online

Cause: The datafile is online.

Action: Take the datafile offline.

ORA-29319 datafile string is not correct

Cause: An incorrect datafile was copied to the production database. The datafile information in the export dump file differs with the information in the datafile in the production database.

Action: Copy the datafile from the clone database to the production database.

ORA-29320 datafile header error

Cause: An error occurred during reading datafile header.

Action: Copy the correct datafile from the clone database to the production database, then retry the operation.

ORA-29321 too many datafiles added since the point-in-time

Cause: Too many datafiles were added to the recovery set since the point-in-time recovery.

Action: Divide the recovery set into smaller subsets and retry.

ORA-29322 SCN string size too long -- maximum size 58 bytes/characters

Cause: Too many characters in specifying the SCN string

Action: Remove all unnecessary characters. Only 15 characters are required for both the hex and decimal representation of the 48 bit SCN.

ORA-29323 SET COMPATIBILITY command cannot be used for releases before 8.0.0

Cause: The rolling release feature was first implemented in 8.0.3.

Action: Try 8.0.3 or later.

ORA-29324 SET COMPATIBILITY release string format is wrong

Cause: It should be of the form 8.x.x.

Action: Use the correct format.

ORA-29325 SET COMPATIBILITY release number mismatches compatibility release number

Cause: In 8.0.3, it should be the same as compatibility release number.

Action: Specify the same as the COMPATIBLE initialization parameter. Note that this cannot be a release number less than 8.0.0.

ORA-29326 specified SET COMPATIBILITY release number reduced to string.string.string.string.string

Cause: One or more instances had a lower release number.

Action: To roll the release to the specified number, all instances will need to migrate to the same release number or higher.

ORA-29327 unsupported client compatibility mode used when talking to the server

Cause: The client compatibility mode is higher than the version of the server.

Action: Using SET COMPATIBILITY command, specify the same release number as the server.

ORA-29328 too many datafiles in this tablespace 'string'

Cause: Too many datafiles in this bitmap tablespace.

Action: Contact Oracle Support Services.

ORA-29335 tablespace 'string' is not read only

Cause: The tablespace is not read only.

Action: Make the tablespace read only and retry the operation.

ORA-29336 Internal error [string] [string] from DBMS_PLUGTS

Cause: Internal error from package DBMS_PLUGTS.

Action: Contact Oracle Support Services.

ORA-29337 tablespace 'string' has a non-standard block size (string)

Cause: The tablespace has a non-standard block size and making such a tablespace read-write is not permitted.

Action: Use some other mechanism to import the data.

ORA-29338 datafile string is in an undesired state (string, string)

Cause: The referred datafile is not in a state ready for tablespace copy operation. For example, the datafile may be offline. The datafile needs to be ONLINE, and either READ ONLY or READ WRITE.

Action: Put the datafile into the desired state.

ORA-29339 tablespace block size string does not match configured block sizes

Cause: The block size of the tablespace to be plugged in or created does not match the block sizes configured in the database.

Action: Configure the appropriate cache for the block size of this tablespace using one of the various (db_2k_cache_size, db_4k_cache_size, db_8k_cache_size, db_16k_cache_size, db_32K_cache_size) parameters.

ORA-29340 export file appears to be corrupted: [string] [string] [string]

Cause: This is caused either by a corrupted export file or by an Oracle internal error.

Action: Make sure the export file used for transportable tablespace is not corrupted. If the error still occurs, then contact Oracle Support Services.

ORA-29341 The transportable set is not self-contained

Cause: The set of objects in the set of tablespaces selected are not self-contained.

Action: Consider using different export options, or removing some of the pointers that caused the violation, or selecting a different set of tablespaces.

ORA-29342 user string does not exist in the database

Cause: The referred user is one of the owners of data in the pluggable set. This user does not exist in the database.

Action: Consider either creating the user in the database or map the user to a different user via FROM_USER and TO_USER import options.

ORA-29343 user string (mapped from user string) does not exist in the database

Cause: The referred user is one of the owners of data in the pluggable set. This user does not exist in the database.

Action: Consider either creating the user or map the original user to a different user.

ORA-29344 Owner validation failed - failed to match owner 'string'

Cause: The system failed to match the referenced owner. There are two cases in which this may occur:

  • This user owns data in the transportable set, but this user is not specified in the TTS_OWNERS list of the import command line option, assuming that TTS_OWNERS is specified.
  • This user is specified in the TTS_OWNER list, but this user does not own any data in the transportable set.

Action: Retry the import with a different OWNER list.

ORA-29345 can not plug a tablespace into a database using a different character set

Cause: Oracle does not support plugging a tablespace into a database using a different character set.

Action: Use import/export or unload/load to move data instead.

ORA-29346 invalid tablespace list

Cause: The tablespace list supplied to DBMS_TTS.TRANSPORT_SET_CHECK. PL/SQL routine is in an incorrect format.

Action: Check the PL/SQL User's Guide and Reference and use the correct format.

ORA-29347 Tablespace name validation failed - failed to match tablespace 'string'

Cause: The system failed to match the referenced tablespace. There are two case in which this may happen:

  • This tablespace is in the transportable set, but it is not specified in the TABLESPACES list of the import command line option, assuming that TABLESPACES is specified.
  • This tablespace is in the TABLESPACES list, but it is not in the transportable set.

Action: Retry the operation with the correct TABLESPACES list.

ORA-29348 You must specify the datafiles to be plugged in

Cause: The datafiles to be plugged in are not specified.

Action: Specify the datafiles via the import DATAFILES command line option.

ORA-29349 tablespace 'string' already exists

Cause: An attempt was made to plug-in a tablespace which already exists.

Action: Drop the offending tablespace if possible. Otherwise use a different method (for example, import/export) to move data.

ORA-29350 server version string incompatible with package string version string

ORA-29351 can not transport system or temporary tablespace 'string'

Cause: The referenced tablespace is either the system tablespace or a temporary tablespace.

Action: Do not include this tablespace in the transportable set.

ORA-29353 The transportable list is too long.

Cause: The transportable list exceeds the buffer size of 32767.

Action: Reduce the list of tablespaces to transport.

ORA-29355 NULL or invalid string argument specified

Cause: The named argument was either invalid or specified as a NULL.

Action: Specify non-null, valid arguments.

ORA-29356 These parameters can be specified only for directives that refer to consumer groups

Cause: The below parameters were specified as an argument to the procedure CREATE_PLAN_DIRECTIVE or UPDATE_PLAN_DIRECTIVE of package DBMS_RESOURCE_MANAGER where the GROUP_OR_SUBPLAN argument is a resource plan. "ACTIVE_SESS_POOL_P1", "QUEUEING_P1", "PARALLEL_DEGREE_LIMIT_P1", "SWITCH_P1", "SWITCH_P2", "SWITCH_P3", "MAX_EST_EXEC_TIME", "UNDO_POOL"

Action: Specify these parameters only for consumer group directives.

ORA-29357 object string already exists

Cause: The name specified as argument to procedure CREATE_PLAN, CREATE_CONSUMER_GROUP of package DBMS_RESOURCE_MANAGER was already in use.

Action: Specify an unused name.

ORA-29358 resource plan string does not exist

Cause: An invalid plan name was specified as an argument to procedure UPDATE_PLAN of package DBMS_RESOURCE_MANAGER.

Action: Specify an existing plan name.

ORA-29359 invalid method name string specified for resource plan string

Cause: An invalid method was specified as an argument to procedure CREATE_PLAN or UPDATE_PLAN of package DBMS_RESOURCE_MANAGER.

Action: Specify a valid method name.

ORA-29360 retry operation. Too much concurrent activity

Cause: An attempt was made to revoke the switch consumer group privilege from a user for his/her initial consumer group but someone is modifying the user in another session.

Action: Retry the operation later.

ORA-29361 percentage string is outside valid range of 0 to 100

Cause: An invalid percentage value was specified.

Action: Specify a percentage value between 0 and 100 inclusive.

ORA-29362 plan directive string, string does not exist

Cause: A non-existent plan directive was specified for procedure UPDATE_PLAN_DIRECTIVE of package DBMS_RESOURCE_MANAGER.

Action: Specify an existing plan directive for update.

ORA-29363 plan directive string, string is mandatory and cannot be modified or deleted

Cause: An attempt was made to modify a mandatory plan directive.

Action: Do not attempt to modify mandatory plan directives because they are required by the Resource Manager and cannot be modified.

ORA-29364 plan directive string, string already exists

Cause: An attempt was made to create a plan directive that already exists.

Action: Retry the create operation using different values.

ORA-29365 NULL or invalid GROUP_OR_SUBPLAN argument specified

Cause: A NULL or invalid GROUP_OR_SUBPLAN was specified as an argument to procedure CREATE_PLAN_DIRECTIVE or UPDATE_PLAN_DIRECTIVE of package DBMS_RESOURCE_MANAGER.

Action: Specify a non-NULL, valid argument.

ORA-29366 invalid CONSUMER_GROUP argument specified

Cause: An invalid consumer group name was specified.

Action: Specify a non-NULL, valid consumer group name.

ORA-29367 object string does not exist

Cause: A non-existent object name was specified as an argument to procedure CREATE_PLAN_DIRECTIVE of package DBMS_RESOURCE_MANAGER.

Action: Specify a valid plan or consumer group name.

ORA-29368 consumer group string does not exist

Cause: An non-existent consumer group was specified.

Action: Specify an existing consumer group.

ORA-29369 invalid method name string specified for consumer group string

Cause: An invalid method name was specified as an argument to procedure CREATE_CONSUMER_GROUP or UPDATE_CONSUMER_GROUP of package DBMS_RESOURCE_MANAGER.

Action: Specify a valid method name.

ORA-29370 pending area is already active

Cause: An attempt was made to activate a pending area that is already active.

Action: Wait until the pending area is no longer active; then, retry the operation.

ORA-29371 pending area is not active

Cause: An attempt was made to make changes without creating a pending area.

Action: Invoke procedure CREATE_PENDING_AREA before making any changes.

ORA-29372 identifier string is too long; it must be less than string characters

Cause: An attempt was made to specify an identifier that is more than 30 characters long.

Action: Use an identifier that is 30 characters or less in length.

ORA-29373 resource manager is not on

Cause: An attempt was made to execute an operation that cannot be executed with the resource manager being off.

Action: Turn on the resource manager and try again.

ORA-29374 resource plan string in top-plan string has no plan directives

Cause: A plan was created in the pending area that is an orphan or standalone.

Action: Create plan directives if needed. Otherwise, delete the plan.

ORA-29375 sum of percentages string for level string, plan string exceeds string

Cause: The sum of percentages for the specified plan, level exceeds 100.

Action: Alter the percentages for the level so that they sum to 100.

ORA-29376 number of consumer groups string in top-plan string exceeds string

Cause: The number of consumer groups in the specified top-plan is more than 32.

Action: Change the top-plan to have no more than 32 consumer groups.

ORA-29377 consumer group string is not part of top-plan string

Cause: OTHER_GROUPS was not included as part of the specified top-plan. Each top plan must include the built-in consumer group OTHER_GROUPS.

Action: Create a plan directive with the argument GROUP_OR_SUBPLAN being OTHER_GROUPS somewhere in the top-plan.

ORA-29379 resource plan string is involved in a loop in top-plan string

Cause: A loop was discovered while validating a top-plan.

Action: Check the plans that have the specified plan as a GROUP_OR_SUBPLAN, and remove the plan directive that causes the loop.

ORA-29380 resource plan string is currently active and cannot be deleted

Cause: An attempt was made to delete an active plan in the pending area. No changes can be made to active plans.

Action: Delete the plan when it is not in use.

ORA-29381 plan/consumer_group string referred to by another plan and cannot be deleted

Cause: An attempt was made to delete a plan or consumer group that is referred to by another plan.

Action: Remove all plan directives that have the plan or consumer group as GROUP_OR_SUBPLAN; then delete the plan or consumer group.

ORA-29382 validation of pending area failed

Cause: Invalid changes were attempted in the pending area.

Action: See documentation and the error messages that follow this one.

ORA-29383 all leaves of top-plan string must be consumer groups

Cause: An attempt was made to create or modify the specified top-plan but it has some plans as leaves.

Action: To identify which plans and/or plan directives need to be modified, look at all plans that have no plan directives. Then, alter the top-plan so that all its leaves are consumer groups.

ORA-29384 number of children for plan string exceeds string

Cause: An attempt was made to create or modify the specified plan, but the plan has more than 32 children.

Action: Make sure the specified plan points to no more than 32 distinct nodes.

ORA-29385 cannot create plan directive from string to string

Cause: An attempt was made to create a plan directive from a plan to itself.

Action: Make sure the arguments PLAN and GROUP_OR_SUBPLAN to procedure CREATE_PLAN_DIRECTIVE of package DBMS_RESOURCE_MANAGER are different.

ORA-29386 plan or consumer group string is mandatory and cannot be deleted or modified

Cause: An attempt was made to delete or modify the specified mandatory plan or consumer group.

Action: Do not attempt to delete or modify mandatory plans and consumer groups.

ORA-29387 no top-plans found in the pending area

Cause: The VALIDATE_PENDING_AREA procedure found that either the intended top-plan(s) are involved in a loop or there are no top-plans.

Action: Check all edges going from a subplan to the intended top-plan. Make sure the top plan does not have any plan referring to it.

ORA-29388 plan/consumer_group string is part of more than one top-plan

Cause: An attempt was made to delete a subtree that includes a plan or consumer group that is part of more than one top-plan as part of procedure DELETE_PLAN_CASCADE or package DBMS_RESOURCE_MANAGER. Such a plan or consumer group cannot be deleted.

Action: Check the ancestors of the plan or consumer group and make sure it is only part of the top-plan that includes the subtree being deleted.

ORA-29389 too many errors during validation

Cause: The number of errors detected during validation is too high.

Action: Perform the necessary actions to remove some errors, and retry validation.

ORA-29390 some resource plans are not part of any top-plan

Cause: An attempt was made to create or modify some plans in the pending area that are not part of any top-plan.

Action: Remove these plans are try validation again.

ORA-29391 string and string must be mandatory to create a mandatory plan directive

Cause: An attempt was made to create a mandatory plan directive where either PLAN or GROUP_OR_SUBPLAN or both were not mandatory.

Action: Re-create these objects as mandatory and then create the plan directive.

ORA-29393 user string does not exist or is not logged on

Cause: An invalid user name was specified as argument to procedure SET_INITIAL_CONSUMER_GROUP of package DBMS_RESOURCE_MANAGER or SWITCH_CONSUMER_GROUP_FOR_USER of package DBMS_SYSTEM or the specified user was not logged on.

Action: Specify a valid user name.

ORA-29394 session id string and serial# string do not exist

Cause: Invalid session id and serial# were specified as arguments to procedure SWITCH_CONSUMER_GROUP_FOR_SESS of package DBMS_SYSTEM.

Action: Specify valid values from the view V$SESSION.

ORA-29395 cannot set the initial consumer group to string

Cause: An attempt was made to set the initial consumer group of a user to OTHER_GROUPS.

Action: OTHER_GROUPS is for the resource manager's internal use. Specify another consumer group.

ORA-29396 cannot switch group to string

Cause: An attempt was made to switch the consumer group of a user or a session to OTHER_GROUPS.

Action: OTHER_GROUPS is for the resource manager's internal use. Specify another consumer group.

ORA-29397 cannot grant/revoke switch privilege for string

Cause: An attempt was made to grant or revoke the privilege to switch to OTHER_GROUPS.

Action: OTHER_GROUPS is for the resource manager's internal use. Specify another consumer group.

ORA-29398 invalid privilege name specified

Cause: An invalid privilege name was specified as an argument to procedure GRANT_SYSTEM_PRIVILEGE or REVOKE_SYSTEM_PRIVILEGE of package DBMS_RESOURCE_MANAGER_PRIVS.

Action: Specify a valid privilege name.

ORA-29399 user string does not have privilege to switch to consumer group string

Cause: An attempt was made to set the initial consumer group of the specified user but the user does not have the privilege to switch to that group.

Action: Grant the privilege to switch to the consumer group to the user and then set the initial group.

ORA-29400 data cartridge errorstring

Cause: An error has occurred in a data cartridge external procedure. This message will be followed by a second message giving more details about the data cartridge error.

Action: See the Oracle9i Data Cartridge Developer's Guide for an explanation of the second error message.

ORA-29500 NAMED keyword is invalid in CREATE JAVA CLASS

Cause: A NAMED keyword was specified in the CREATE JAVA CLASS statement. NAMED keywords are valid only in CREATE JAVA SOURCE or RESOURCE statements.

Action: Remove the NAMED keyword from the CREATE JAVA CLASS statement.

ORA-29501 invalid or missing Java source, class, or resource name

Cause: The required name for a Java source, class, or resource was invalid or missing.

Action: Specify a valid name.

ORA-29502 NAMED keyword required in CREATE JAVA RESOURCE

Cause: The name for a Java resource was not specified. The name must be specified with the NAMED keyword.

Action: Specify a valid name with the NAMED keyword.

ORA-29503 SCHEMA keyword not valid with NAMED keyword

Cause: SCHEMA and NAMED keywords were used together in the same CREATE JAVA command, but only one may be used in a CREATE JAVA command.

Action: Remove either the NAMED or the SCHEMA keyword.

ORA-29504 invalid or missing schema name

Cause: The required schema name was invalid or missing.

Action: Specify a valid schema name.

ORA-29505 AS keyword is invalid in CREATE JAVA CLASS or RESOURCE

Cause: The AS keyword was used in CREATE JAVA CLASS or RESOURCE. The AS keyword is valid only in CREATE JAVA SOURCE.

Action: Use the USING keyword in CREATE JAVA CLASS or RESOURCE.

ORA-29506 invalid query derived from USING clause

Cause: The USING clause did not form a valid query.

Action: Correct the USING clause.

ORA-29507 query derived from USING clause found zero or many rows

Cause: The USING clause defined a query that either did not return any values, or returned more than one value.

Action: Correct the USING clause.

ORA-29508 query derived from USING clause did not select a value of type string

Cause: The USING clause did not form a query that selects a value of the type specified by the term following the USING keyword.

Action: Correct the USING clause.

ORA-29509 incorrectly formed Java binary class definition

Cause: An attempt was made to create a Java class using data expected to be in binary (Java .class) format. The data was found not to be in this format, or to be incorrectly formed.

Action: Correct the definition data.

ORA-29510 name, string.string, already used by an existing object

Cause: A CREATE JAVA command attempted to create a source, class, or resource object with a name that is already in use.

Action: Drop the existing object that is using the desired name, or use a different name for the new object.

ORA-29511 could not resolve Java class

Cause: A CREATE AND RESOLVE NOFORCE JAVA CLASS command specified definition data that could not be resolved, or resolution failed for some referenced class.

Action: Remove the NOFORCE option or remove impediments to resolution.

ORA-29512 incorrectly formed name resolver specification

Cause: A name resolver was not specified in the required form: (( name_pattern , schema_name) ...).

Action: Correct the specification.

ORA-29513 referenced class name too long

Cause: An attempt was made to import a .class file containing a class name of length greater than number. The .class file could not be imported because the referenced class name was too long.

Action: Shorten the referenced class name in the .class file.

ORA-29514 class name contains illegal character

Cause: An attempt was made to import a .class file containing a character that cannot be converted to the server character set. The .class file could not be imported because of the illegal character.

Action: Correct the illegal character in the .class file.

ORA-29515 exit called from Java code with status string

Cause: Java code included a call to java.lang.Runtime.exitInternal.

Action: Do not include this call unless non-local exit is desired.

ORA-29516 Aurora assertion failure: string

Cause: An internal error occurred in the Aurora module.

Action: Contact Oracle Support Services.

ORA-29517 recursive resolution failed for a referenced class

Cause: An attempt to resolve a referenced class failed.

Action: Review the errors for referenced classes and complete the necessary actions to correct them.

ORA-29518 name string resolved to an object in schema string that is not a Java class

Cause: A referenced name was resolved to an object that is not a Java class.

Action: Adjust name resolver or add missing Java class.

ORA-29519 name string resolved via a synonym in schema string to a class with a different name

Cause: A referenced name was resolved to a synonym, which translated to a class whose name does not match the referenced name.

Action: Adjust name resolver or add missing Java class.

ORA-29520 name string resolved to a class in schema string that could not be accessed

Cause: An attempt to access a referenced class failed.

Action: Adjust authorizations or name resolution.

ORA-29521 referenced name string could not be found

Cause: Name resolution failed to find an object with the indicated name.

Action: Adjust name resolver or add missing Java class.

ORA-29522 authorization error for referenced name string.string

Cause: An attempt was made to resolve a class that is not authorized to use the indicated referenced class.

Action: Adjust authorizations or name resolution.

ORA-29523 authorization error for unknown referenced name

Cause: An attempt was made to resolve a class that is not authorized to use a referenced class. The name of the referenced class could not be determined.

Action: Adjust authorizations or name resolution.

ORA-29524 wrong types of arguments in call to 'string'

Cause: A method was called with argument(s) of incompatible type(s).

Action: Adjust caller.

ORA-29525 referenced name is too long: 'string'

Cause: An attempt was made to create a class that references a name longer than 4000 characters. The class could not be created because the name is too long.

Action: Adjust the definition.

ORA-29526 created Java class string"string"

Cause: An informational message, not an error.

Action: No action required.

ORA-29527 created Java source string"string"

Cause: An informational message, not an error.

Action: No action required.

ORA-29528 invalid Java call in trigger string

Cause: The Java method specified in trigger does not exist or cannot be called as used.

Action: Adjust trigger definition.

ORA-29529 invalid function or method call string in trigger string

Cause: The function or method specified in Java trigger call expression could not be resolved.

Action: Adjust trigger definition.

ORA-29530 could not create shortened name for string

Cause: Insert into shortened name translation table failed.

Action: Retry the insert.

ORA-29531 no method string in class string

Cause: An attempt was made to execute a non-existent method in a Java class.

Action: Adjust the call or create the specified method.

ORA-29532 Java call terminated by uncaught Java exception: string

Cause: A Java exception or error was signaled and could not be resolved by the Java code.

Action: Modify Java code, if this behavior is not intended.

ORA-29533 attempt to overwrite class or resource string while defining or compiling string.string

Cause: A class or resource defined by a SQLJ source conflicted with an existing object.

Action: Remove existing object, or modify SQLJ source.

ORA-29534 referenced object string.string could not be resolved

Cause: Name resolution determined that the indicated object is referenced but could not be resolved.

Action: Correct name resolver or address resolution problems in the referenced class, or correct compilation problems in its source.

ORA-29535 source requires recompilation

Cause: The reason the current class object was invalid is recorded with the source object from which it was compiled.

Action: Inspect errors in the source object and take the necessary corrective actions.

ORA-29536 badly formed source: string

Cause: An attempt was made to create a Java source object with text that could not be parsed adequately to determine the class(es) defined by it.

Action: Correct errors in source.

ORA-29537 class or resource cannot be created or dropped directly

Cause: An attempt was made to create or drop a Java class or resource that is known to result from compilation of an existing Java source object.

Action: Act on the class or resource by acting on the source, or change the source so that it no longer defines the class or resource.

ORA-29538 Java not installed

Cause: An attempt was made to use a Java command when Java is not installed.

Action: Install Java, or do not use the command.

ORA-29539 Java system classes already installed

Cause: An attempt was made to use the CREATE JAVA SYSTEM command in a database where the Java system classes already are installed.

Action: Use CREATE OR REPLACE JAVA SYSTEM.

ORA-29540 class string does not exist

Cause: Java method execution failed to find a class with the indicated name.

Action: Correct the name or add the missing Java class.

ORA-29541 class string.string could not be resolved

Cause: An attempt was made to execute a method in a Java class that had not been previously and cannot now be compiled or resolved successfully.

Action: Adjust the call or make the class resolvable.

ORA-29542 class string already defined by source string

Cause: An attempt was made to create a Java source object that would define a class that is already defined by a different Java source object.

Action: Either drop the old source or modify the new source.

ORA-29543 Java command string not yet implemented

Cause: An attempt was made to use a Java command that is not yet implemented.

Action: Do not use the command.

ORA-29544 invalid type

Cause: The type argument in a call to a Java export or import command did not have a recognized value.

Action: Correct the value.

ORA-29545 badly formed class: string

Cause: An attempt was made to create a Java class object with bytecodes that were rejected by the Java verifier.

Action: It is possible that an attempt was made to create the Java class from a damaged class file, in which case the CREATE should be reattempted with a correct class file. It is also possible that the message is the result of using "-" in the resolver so that the verifier could not check the correctness of some code. In that case, the class needs to be created with a resolver.

ORA-29546 badly formed resource: string

Cause: An attempt was made to create a Java resource object with data that was rejected by the Java verifier.

Action: Correct the data.

ORA-29547 Java system class not available: string

Cause: An attempt was made to use a command that requires a Java system class that was not yet present or was invalid.

Action: Load the system classes, or do not use the command.

ORA-29548 Java system class reported: string

Cause: A command that uses a Java system class was aborted due to an error reported by the Java system class.

Action: Correct the error that was reported.

ORA-29549 class string.string has changed, Java session state cleared

Cause: A class in use by the current session was redefined or dropped, invalidating the current Java session state and requiring that it be cleared.

Action: No action required.

ORA-29550 Java session state cleared

Cause: The Java state in the current session became inconsistent and was cleared.

Action: No action required.

ORA-29551 could not convert string to Unicode

Cause: A string in the database character set could not be converted to Unicode, as required for use by Java.

Action: Correct the string.

ORA-29552 verification warning: string

Cause: An attempt was made to create a Java class object with bytecodes that caused the Java verifier to issue a warning.

Action: It is possible that the Java class was created from a damaged class file, in which case the CREATE should be reattempted with a correct class file. It is also possible that the message is the result of using "-" in the resolver so that the verifier could not check the correctness of some code. In that case, the class needs to be created with a resolver.

ORA-29553 class in use: string.string

Cause: An attempt was made to modify a Java class that is in use in the current call.

Action: Correct the code in use in this call.

ORA-29554 unhandled Java out of memory condition

Cause: The session encountered an out of memory condition in Java from which it could not recover. Java session state was cleared.

Action: No action required.

ORA-29555 Java source, class or resource is not allowed here

Cause: A Java source, class, or resource was specified in an inappropriate place in a statement.

Action: Make sure the name is correct or remove it.

ORA-29556 object type has changed

Cause: A database object name that named a Java source, class, or resource now names an object of a different type.

Action: No action required.

ORA-29557 Java system class string cannot be modified

Cause: A command was attempted that would have modified a Java system class.

Action: No action required.

ORA-29655 USING clause is incompatible with its supertype

Cause: The USING clause of a type has to be the same as its supertype or compatible with it.

Action: Make sure the USING clause is compatible with its supertype.

ORA-29656 Invalid option for USING

Cause: The class has to implement the required interface for the value of the option for USING.

Action: Make sure the USING clause is supported.

ORA-29657 class defined in EXTERNAL NAME clause is used in another subtype

Cause: The supertype has an existing type that has the same value for the EXTERNAL NAME.

Action: Make sure the EXTERNAL NAME clause is unique among subtypes.

ORA-29658 EXTERNAL NAME clause is not compatible with its supertype

Cause: The EXTERNAL NAME clause of the type is not a subclass of the supertype EXTERNAL NAME.

Action: Make sure the EXTERNAL NAME clause of the type is a subclass of the EXTERNAL NAME of its supertype.

ORA-29659 SQLJ Object Type validation failed to get default connection

Cause: Unable to connect using the JDBC default connection.

Action: No action required.

ORA-29660 Unable to find the class defined in the EXTERNAL NAME clause

Cause: The class is not loaded in the database.

Action: Make sure the EXTERNAL NAME corresponds to a loaded class in the database.

ORA-29661 Unable to find the superclass of the defined in the EXTERNAL NAME

Cause: The class is not loaded in the database.

Action: Make sure the superclass of the EXTERNAL NAME is loaded in the database.

ORA-29662 Unable to find a field that matches one or more of the attributes

Cause: The EXTERNAL NAME option of one or more attributes do not match any fields in the defined class.

Action: Make sure the EXTERNAL NAME option of each attribute matches a field in the defined in the defined class.

ORA-29663 Unable to find a method that matches one or more of the functions

Cause: The EXTERNAL NAME option of one or more functions do not match any method in the defined class.

Action: Make sure the EXTERNAL NAME option of each function matches a method in the defined in the defined class.

ORA-29664 Unable to generate the helper class for the defined type

Cause: The helper class used for supporting SQLJ Object Type is not generated.

Action: No Action required.

ORA-29665 Java thread deadlock detected

Cause: The Java VM has detected a thread deadlock.

Action: Modify the Java program to avoid the deadlock condition.

ORA-29701 unable to connect to Cluster Manager

Cause: Connect to the Cluster Manager (CM) failed or timed out.

Action: Verify that the CM was started. If the CM was not started, start it and then retry the database startup. If the CM died or is not responding, check the Oracle and CM trace files for errors.

ORA-29702 error occurred in Cluster Group Service operation

Cause: An unexpected error occurred while performing a CGS operation.

Action: Verify that the LMON process is still active. Also, check the Oracle LMON trace files for errors.

ORA-29703 error occurred in global enqueue service operation

Cause: An unexpected error occurred while performing a global enqueue service operation.

Action: Check Oracle trace files for errors.

ORA-29704 cannot specify ACTIVE_INSTANCE_COUNT in 8.1.5 or earlier release

Cause: The ACTIVE_INSTANCE_COUNT initialization parameter was specified when one of the instances in the cluster was running Oracle 8.1.5 or an earlier release.

Action: Restart the instance without specifying the ACTIVE_INSTANCE_COUNT initialization parameter. Or, upgrade all instances to Oracle 8.1.6 or later release and then specify the parameter.

ORA-29705 ACTIVE_INSTANCE_COUNT is string which is incompatible with the value in other instances

Cause: The value of the ACTIVE_INSTANCE_COUNT initialization parameter must be the same in all Oracle cluster database instances.

Action: Check your initialization parameter files in all instances and ensure that the ACTIVE_INSTANCE_COUNT initialization parameter has the same value. Then restart the instance.

ORA-29706 incorrect value string for parameter ACTIVE_INSTANCE_COUNT

Cause: The ACTIVE_INSTANCE_COUNT initialization parameter must be set to 1 in a two node cluster database configuration or unspecified if a secondary instance is not needed.

Action: Check your initialization parameter files and correct the value of the ACTIVE_INSTANCE_COUNT initialization parameter. If you are configuring a two node primary/secondary cluster database, then set this value to 1. Otherwise, do not specify any value for the parameter.

ORA-29740 evicted by member string, group incarnation string

Cause: This member was evicted from the group by another member of the cluster database for one of several reasons, which may include a communications error in the cluster, failure to issue a heartbeat to the control file, and so on.

Action: Check the trace files of other active instances in the cluster group for indications of errors that caused a reconfiguration.

ORA-29741 IMR active for some, but not all members of cluster

Cause: The IMR feature is not active for this instance, but is active for another instance in the cluster database.

Action: Ensure that all instances have the same value for the _imr_active initialization parameter.

ORA-29760 instance_number parameter not specified

Cause: The initialization parameter file did not contain a value for the INSTANCE_NUMBER parameter which is required to identify this instance to other instances of the database running on the same cluster.

Action: Assign a value to the INSTANCE_NUMBER parameter in the initialization parameter file.

ORA-29800 invalid name for operator

Cause: The name specified for the operator is incorrect.

Action: Specify a correct name for the operator.

ORA-29801 missing RETURN keyword

Cause: The RETURN keyword has not been specified.

Action: Specify the RETURN keyword or check the SQL statement.

ORA-29802 missing CONTEXT keyword

Cause: The CONTEXT keyword has not been specified.

Action: Specify the CONTEXT keyword or check the SQL statement.

ORA-29803 missing ANCILLARY keyword

Cause: The ANCILLARY keyword has not been specified.

Action: Specify the ANCILLARY keyword or check the SQL statement.

ORA-29804 missing DATA keyword

Cause: The DATA keyword has not been specified.

Action: Specify the DATA keyword or check the SQL statement.

ORA-29805 missing COLUMN keyword

Cause: Keyword COLUMN is expected.

Action: Either specify the COLUMN keyword or specify another option.

ORA-29806 specified binding does not exist

Cause: The operator binding which has been specified does not exist.

Action: Ensure that the operator binding that has been specified does exist.

ORA-29807 specified operator does not exist

Cause: The operator which has been specified does not exist.

Action: Ensure that the operator that has been specified does exist.

ORA-29808 specified primary operator binding does not exist

Cause: The specified binding for the primary operator does not exist.

Action: Ensure that the specified binding for the primary operator exists.

ORA-29809 cannot drop an operator with dependent objects

Cause: The operator which is being dropped has some dependent objects.

Action: Either drop the dependent objects first and then issue the DROP OPERATOR command or specify the FORCE option with DROP OPERATOR.

ORA-29810 inadequate operator privileges

Cause: The user does not have the appropriate privileges to perform the specified operation on the operator.

Action: Grant the appropriate privileges to the user and then reissue the statement.

ORA-29811 missing STATISTICS keyword

Cause: This is not a valid option with the ASSOCIATE command.

Action: Specify STATISTICS keyword after the ASSOCIATE command.

ORA-29812 incorrect object name specified

Cause: The specified name is not a valid name.

Action: Specify the correct name of the object with for which an association needs to be defined.

ORA-29813 non-supported object type with associate statement

Cause: The type of object specified is not supported with the associate statistics statement.

Action: Use a valid object type with the associate command.

ORA-29814 expecting USING or DEFAULT keyword

Cause: Expecting the USING or DEFAULT keyword after the names of object(s).

Action: Provide the USING or DEFAULT keyword.

ORA-29815 object being associated is not present

Cause: The object for which the association is being defined is not present.

Action: Ensure that all the objects for which the association is being defined are present.

ORA-29816 object being disassociated is not present

Cause: Object which is being disassociated is not present.

Action: Ensure that the object which needs to be disassociated is present.

ORA-29817 non-supported option with disassociate statement

Cause: The type of object specified is not supported with the disassociate statistics statement.

Action: Use a object type which is supported with the disassociate command.

ORA-29818 column name not properly specified

Cause: Name of the column should contain the table and the column name.

Action: Specify a valid column name.

ORA-29819 cannot associate default values with columns

Cause: An attempt was made to associate DEFAULT values with columns which is not a valid option.

Action: Specify a valid option.

ORA-29820 the statistics type is not present

Cause: The statistics type which is being associated with object(s) is not present.

Action: Ensure that the type which contains the statistics functions is present.

ORA-29821 specified primary operator does not exist

Cause: The specified primary operator does not exist.

Action: Check the primary operator and the signature specified.

ORA-29822 selectivity cannot be specified for the type of object

Cause: An attempt was made to associate selectivity with index or index types which is not allowed.

Action: Specify a valid option.

ORA-29823 object being analyzed is not a table

Cause: The object being analyzed is not a table and is not supported.

Action: Specify only a supported option.

ORA-29824 operator is invalid

Cause: The operator is invalid.

Action: Drop and re-create the operator.

ORA-29825 invalid name for indextype

Cause: Index type name or index type schema name has invalid characters.

Action: Verify that the name has valid characters and it is not a reserved word.

ORA-29826 keyword FOR is missing

Cause: FOR keyword must be provided with CREATE INDEXTYPE statement.

Action: Use FOR keyword and provide relevant operator information.

ORA-29827 keyword USING is missing

Cause: USING keyword and corresponding implementation details must be provided.

Action: Provide USING keyword and relevant implementation details with CREATE INDEXTYPE statement.

ORA-29828 invalid name for implementation type

Cause: Implementation type or Implementation schema name is invalid.

Action: Verify that the name has valid characters and it is not a reserved word.

ORA-29829 implementation type does not exist

Cause: The implementation type specified with USING clause could not be found.

Action: Check to see if the type exists and the user has EXECUTE privilege on this type.

ORA-29830 operator does not exist

Cause: The operator could not be found.

Action: Verify that the operator exists and the user has EXECUTE privilege for this operator.

ORA-29831 operator binding not found

Cause: The specified binding for the operator is not available from the operator schema object.

Action: Verify that the operator with the specified binding exists.

ORA-29832 cannot drop or replace an indextype with dependent indexes

Cause: One or more indexes are dependent upon the index type.

Action: Drop all the indexes which are dependent upon the index type before dropping the index type itself.

ORA-29833 indextype does not exist

Cause: There is no index type by the specified name.

Action: Use public views for the index types to see if an index type by the specified name has been created.

ORA-29834 REF datatype not supported with operators

Cause: The user specified a REF datatype which is not supported in CREATE OPERATOR.

Action: Reissue the CREATE OPERATOR statement without the REF datatype.

ORA-29835 ODCIGETINTERFACES routine does not return required interface(s)

Cause: The ODCIObjectList returned by the ODCIGetInterfaces routine does not contain the interface(s) required by the current usage.

Action: Ensure that the ODCIGetInterfaces routine returns the name(s) of the required interface(s).

ORA-29836 failed to validate referenced operators

Cause: One of the operators referenced cannot be compiled.

Action: Try to recompile the operators which are referenced by this index type. Use USER_INDEXTYPE_OPERATORS view to find out the referenced operators.

ORA-29837 insufficient privileges to execute implementation type

Cause: User does not have privileges to execute the implementation type.

Action: The owner of the implementation type must grant appropriate privileges to the user.

ORA-29838 insufficient privileges to execute the operator(s)

Cause: User does not have privileges to execute one of the operators.

Action: The owner of the operators must grant appropriate privileges to the user.

ORA-29839 failed to validate implementation type

Cause: Implementation type cannot be compiled.

Action: Try to compile the implementation type.

ORA-29840 indextype and implementation type are not in same schema

Cause: Index type and implementation type are in different schema.

Action: Put the index type and implementation type in the same schema.

ORA-29841 invalid option for ALTER INDEXTYPE

Cause: The user specified an invalid option with the ALTER INDEXTYPE command.

Action: Choose a valid option with the ALTER INDEXTYPE command.

ORA-29842 option not supported with the version string of the indextype interface

Cause: User specified an option which is not supported with the version of the indextype interface provided.

Action: User should either not request for this option or should provide an implementation type that implements the correct version of the indextype interface.

ORA-29843 indextype should support atleast one operator

Cause: User attempted to drop all the operators from the indextype.

Action: Do not drop all the operators from the indextype.

ORA-29844 duplicate operator name specified

Cause: User attempted to add an operator name to an indextype which is already supported by the indextype.

Action: Remove the duplicate operator and retry the command.

ORA-29845 indextype does not support local domain index on string partitioned table

Cause: User specified a create local domain index statement using an indextype that does not support local domain indexes on tables partitioned with the given method.

Action: Use a different indextype or build a global domain index.

ORA-29846 cannot create a local domain index on a string partitioned table

Cause: User specified a create local domain index statement on a table partitioned using a method not supported by domain indexes.

Action: Build a global domain index on the partitioned table.

ORA-29847 cannot create a local domain index on a partitioned index-organized table

Cause: User specified a create local domain index statement on a partitioned index-organized table.

Action: Build a global domain index on the partitioned index-organized table.

ORA-29848 error occurred in the execution of ODCIINDEXMERGEPARTITION routine

Cause: Failed to successfully execute the ODCIIndexMergePartition routine.

Action: Check to see if the routine has been coded correctly.

ORA-29849 error occurred in the execution of ODCIINDEXSPLITPARTITION routine

Cause: Failed to successfully execute the ODCIIndexSplitPartition routine.

Action: Check to see if the routine has been coded correctly.

ORA-29850 invalid option for creation of domain indexes

Cause: The user specified an invalid option like ASC, DESC, SORT or a parallel clause, partitioning clause or physical attributes clause.

Action: Choose one of the valid clauses for creation of domain indexes.

ORA-29851 cannot build a domain index on more than one column

Cause: User attempted to build a domain index on more than one column.

Action: Build the domain index only on a single column.

ORA-29852 keyword IS is missing

Cause: IS keyword must be specified with Create Index statement for domain indexes.

Action: Use IS keyword and then specify the index type name.

ORA-29853 keyword UNIQUE may not be used in creating domain indexes

Cause: An attempt was made to create a domain index with the UNIQUE attribute.

Action: Remove UNIQUE from the CREATE INDEX statement.

ORA-29854 keyword BITMAP may not be used in creating domain indexes

Cause: An attempt was made to create a domain index with the BITMAP attribute.

Action: Remove BITMAP from the CREATE INDEX statement.

ORA-29855 error occurred in the execution of ODCIINDEXCREATE routine

Cause: Failed to successfully execute the ODCIIndexCreate routine.

Action: Check to see if the routine has been coded correctly.

ORA-29856 error occurred in the execution of ODCIINDEXDROP routine

Cause: Failed to successfully execute the ODCIIndexDrop routine.

Action: Check to see if the routine has been coded correctly.

ORA-29857 domain indexes and/or secondary objects exist in the tablespace

Cause: An attempt was made to drop a tablespace which contains secondary objects and/or domain indexes.

Action: Drop the domain indexes in his tablespace. Also, find the domain indexes which created secondary objects in this tablespace and drop them. Then try dropping the tablespace.

ORA-29858 error occurred in the execution of ODCIINDEXALTER routine

Cause: Failed to successfully execute the ODCIIndexAlter routine.

Action: Check to see if the routine has been coded correctly.

ORA-29859 error occurred in the execution of ODCIINDEXTRUNCATE routine

Cause: Failed to successfully execute the ODCIIndexTruncate routine.

Action: Check to see if the routine has been coded correctly.

ORA-29860 cannot truncate a table with domain indexes marked LOADING

Cause: The table has domain indexes defined on it that are marked LOADING.

Action: Wait to see if the ongoing index DDL ends and the index state changes from LOADING state. Else, drop the domain indexes marked as LOADING with the FORCE option.

ORA-29861 domain index is marked LOADING/FAILED/UNUSABLE

Cause: An attempt has been made to access a domain index that is being built or is marked failed by an unsuccessful DDL or is marked unusable by a DDL operation.

Action: Wait if the specified index is marked LOADING Drop the specified index if it is marked FAILED Drop or rebuild the specified index if it is marked UNUSABLE.

ORA-29862 cannot specify FORCE option for dropping non-domain index

Cause: A DROP INDEX FORCE was issued for a non-domain index.

Action: Reissue the command without the FORCE option.

ORA-29863 warning in the execution of ODCIINDEXCREATE routine

Cause: A warning was returned from the ODCIIndexCreate routine.

Action: Check to see if the routine has been coded correctly Check user specified log tables for greater detail.

ORA-29864 analyzing domain indexes marked LOADING/FAILED not supported

Cause: An attempt was made to analyze a domain index which was marked as LOADING or FAILED.

Action: If the index was marked LOADING, wait till it is marked valid before retrying the analyze. If index was marked FAILED, drop it OR rebuild it and retry the analyze.

ORA-29865 indextype is invalid

Cause: The index type is invalid.

Action: Drop and re-create the index type.

ORA-29866 cannot create domain index on a column of index-organized table

Cause: An attempt was made to create a domain index on a column of an index-organized table.

Action: Do not attempt to create a domain index on columns of an index-organized table.

ORA-29867 cannot create a domain index on a LONG column

Cause: The user attempted to create a domain index on a column of LONG datatype.

Action: Do not create a domain index on a LONG column.

ORA-29868 cannot issue DDL on a domain index marked as LOADING

Cause: An attempt was made to issue a DROP/ALTER/TRUNCATE on a domain index in a LOADING state.

Action: Wait till the index operation completes OR issue a DROP INDEX FORCE to drop the index.

ORA-29869 cannot issue ALTER without REBUILD on a domain index marked FAILED

Cause: Tried to issue a DROP/ALTER on a domain index in a FAILED state.

Action: Truncate the table to mark the index as valid OR do ALTER INDEX REBUILD to rebuild the index.

ORA-29870 specified options are only valid for altering a domain index

Cause: Specified the ONLINE or PARAMETERS clause with a non-domain index.

Action: Reissue the statement with the correct syntax for alter.

ORA-29871 invalid alter option for a domain index

Cause: The user specified an invalid option for altering a domain index.

Action: Reissue the alter statement with a valid option.

ORA-29872 parameters clause cannot be combined with the specified options

Cause: The user combined PARAMETERS clause with other alter index options.

Action: Reissue the statement with the correct syntax for alter.

ORA-29873 warning in the execution of ODCIINDEXDROP routine

Cause: A warning was returned from the ODCIIndexDrop routine.

Action: Check to see if the routine has been coded correctly Check the user defined warning log tables for greater details.

ORA-29874 warning in the execution of ODCIINDEXALTER routine

Cause: A warning was returned from the ODCIIndexAlter routine.

Action: Check to see if the routine has been coded correctly Check the user defined warning log tables for greater details.

ORA-29875 failed in the execution of the ODCIINDEXINSERT routine

Cause: Failed to successfully execute the ODCIIndexInsert routine.

Action: Check to see if the routine has been coded correctly.

ORA-29876 failed in the execution of the ODCIINDEXDELETE routine

Cause: Failed to successfully execute the ODCIIndexDelete routine.

Action: Check to see if the routine has been coded correctly.

ORA-29877 failed in the execution of the ODCIINDEXUPDATE routine

Cause: Failed to successfully execute the ODCIIndexUpdate routine.

Action: Check to see if the routine has been coded correctly.

ORA-29878 warning in the execution of ODCIINDEXTRUNCATE routine

Cause: A warning was returned from the ODCIIndexTruncate routine.

Action: Check to see if the routine has been coded correctly. Check the user defined warning log tables for greater details.

ORA-29879 cannot create multiple domain indexes on a column list using same indextype

Cause: An attempt was made to define multiple domain indexes on the same column list using identical indextypes.

Action: Check to see if a different indextype can be used or if the index can be defined on another column list.

ORA-29880 such column list already indexed using another domain index and indextype

Cause: An attempt was made to create multiple domain indexes on a column list using indextypes which do not have disjoint operators.

Action: Check to see if the operator sets for the indextypes can be made disjoint.

ORA-29881 failed to validate indextype

Cause: Index type cannot be compiled.

Action: Try to compile the index type which is referenced by the domain index.

ORA-29882 insufficient privileges to execute indextype

Cause: User does not have privileges to execute the index type.

Action: The owner of the index type must grant appropriate privileges to the user.

ORA-29883 cannot create a domain index on column expressions

Cause: User specified an expression in the column list.

Action: Specify only simple columns in the column list for domain index.

ORA-29884 domain index is defined on the column to be dropped

Cause: An ALTER TABLE DROP COLUMN was issued on a column on which a domain index exists.

Action: Drop the domain index before attempting to drop the column.

ORA-29885 domain index is defined on the column to be modified

Cause: An ALTER TABLE MODIFY COLUMN was issued on a column on which a domain index exists.

Action: Drop the domain index before attempting to modify the column.

ORA-29886 feature not supported for domain indexes

Cause: Feature is not supported for domain indexes.

Action: No action required.

ORA-29887 cannot support row movement if domain index defined on table

Cause: An ALTER TABLE ENABLE ROW MOVEMENT was issued on a table which has a domain index defined on it.

Action: Drop the domain index if you want to enable row movement and then reissue the command.

ORA-29888 cannot create domain index on a table with row movement enabled

Cause: A CREATE DOMAIN INDEX statement was issued on a table that has row movement enabled.

Action: Disable the row movement in the table and then reissue the create domain index statement.

ORA-29890 specified primary operator does not have an index context

Cause: The primary operator does not have an index and scan contexts.

Action: Create the primary operator with a context clause.

ORA-29900 operator binding does not exist

Cause: There is no binding for the current usage of the operator.

Action: Change the operator arguments to match any of the existing bindings or add a new binding to the operator.

ORA-29901 function underlying operator binding does not exist

Cause: The function underlying the operator binding does not exist.

Action: Ensure that the function corresponding to the operator invocation exists.

ORA-29902 error in executing ODCIIndexStart() routine

Cause: The execution of ODCIIndexStart routine caused an error.

Action: Examine the error messages produced by the index type code and take appropriate action.

ORA-29903 error in executing ODCIIndexFetch() routine

Cause: The execution of ODCIIndexFetch routine caused an error.

Action: Examine the error messages produced by the index type code and take appropriate action.

ORA-29904 error in executing ODCIIndexClose() routine

Cause: The execution of ODCIIndexClose routine caused an error.

Action: Examine the error messages produced by the index type code and take appropriate action.

ORA-29905 method string does not exist in type string.string

Cause: A required method with the required signature does not exist in the specified type.

Action: Add the required method to the type.

ORA-29906 indextype string.string does not exist

Cause: The index type does not exist.

Action: Create the index type.

ORA-29907 found duplicate labels in primary invocations

Cause: There are multiple primary invocations of operators with the same number as the label.

Action: Use distinct labels in primary invocations.

ORA-29908 missing primary invocation for ancillary operator

Cause: The primary invocation corresponding to an ancillary operator is missing.

Action: Add the primary invocation with the same label as the ancillary operator.

ORA-29909 label for the ancillary operator is not a literal number

Cause: The label used for invoking the ancillary operator is not a literal number.

Action: Use a literal number as the label.

ORA-29910 invalid callback operation

Cause: Encountered an invalid callback operation.

Action: Ensure that all the callbacks executed from callouts are valid in the statement context.

ORA-29911 null scan context returned by ODCIIndexStart() routine

Cause: The ODCIIndexStart() routine returned a null scan context.

Action: Ensure that the ODCIIndexStart() routine returns a non-null scan context.

ORA-29913 error in executing string callout

Cause: The execution of the specified callout caused an error.

Action: Examine the error messages take appropriate action.

ORA-29914 ODCIGETINTERFACES routine does not return required stream version

Cause: The ODCIObjectList returned by the ODCIGetInterfaces routine does not contain the required stream version for external tables.

Action: Ensure that the ODCIGetInterfaces routine returns the required stream version.

ORA-29915 cannot select FOR UPDATE from collection operand

Cause: Collection operands cannot be updated.

Action: Remove the FOR UPDATE clause.

ORA-29925 cannot execute string

Cause: The specified function does not exist or does not have an appropriate signature.

Action: Implement the function with the appropriate signature.

ORA-29926 association already defined for the object

Cause: The object for which the association is being defined, already has a statistics type associated with it.

Action: Disassociate the object and then associate the object.

ORA-29927 error in executing the ODCIStatsCollect / ODCIStatsDelete routine

Cause: The ODCIStatsCollect/ODCIStatsDelete function is causing an error.

Action: Check the ODCIStatsCollect/ODCIStatsDelete function.

ORA-29928 duplicate default selectivity specified

Cause: The keyword DEFAULT SELECTIVITY can only be specified once.

Action: Remove the duplicate keyword.

ORA-29929 missing SCAN Keyword

Cause: The scan context is not specified.

Action: Supply the SCAN keyword.

ORA-29930 COMPUTE ANCILLARY DATA specified without the INDEX CONTEXT clause

Cause: The COMPUTE ANCILLARY DATA option was specified without the WITH INDEX CONTEXT clause.

Action: Specify the WITH INDEX CONTEXT option.

ORA-29931 specified association does not exist

Cause: One or more of the object(s) that have been specified to be disassociated, do not have an association defined for them.

Action: Verify the objects which have an association defined and issue the disassociate command again.

ORA-29932 the type being dropped is a statistics type

Cause: Some objects have defined their statistics methods in the type being dropped.

Action: First drop the relevant associations using the DISASSOCIATE command and then retry the DROP command, or use the FORCE option with DROP TYPE command.

ORA-29933 object being disassociated has some user defined statistics stored

Cause: There are some user-defined statistics collected for the object being disassociated.

Action: First delete the user-defined statistics and then reissue the DISASSOCIATE command or specify the FORCE option with DISASSOCIATE.

ORA-29934 index specified for association is not a domain index

Cause: The user issued an ASSOCIATE STATISTICS command with an index which is not a domain index.

Action: Issue an ASSOCIATE STATISTICS WITH INDEXES command on a domain index only.

ORA-29935 missing FROM keyword

Cause: The keyword FROM is missing.

Action: Specify the FROM keyword or check the SQL statement.

ORA-29936 NULL association is allowed only with a column or an index

Cause: User tried to use the ASSOCIATE command with a schema object other than a column or an index.

Action: Specify the NULL clause only with a column or an index.

ORA-29950 warning in the execution of ODCIINDEXMERGEPARTITION routine

Cause: A warning was returned from the ODCIIndexMergePartition routine.

Action: Check to see if the routine has been coded correctly. Check user specified log tables for greater detail.

ORA-29951 warning in the execution of ODCIINDEXSPLITPARTITION routine

Cause: A warning was returned from the ODCIIndexSplitPartition routine.

Action: Check to see if the routine has been coded correctly. Check user specified log tables for greater detail.

ORA-29952 cannot issue DDL on a domain index partition marked as LOADING

Cause: Tried to issue a DROP/ALTER/TRUNCATE on a domain index partition in a LOADING state.

Action: Wait until the index partition operation completes, issue a DROP INDEX FORCE to drop the index, OR issue an ALTER TABLE DROP PARTITION to drop the partition.

ORA-29953 cannot issue DDL on a domain index partition marked as FAILED

Cause: Tried to issue a DROP/ALTER on a domain index partition in a FAILED state.

Action: do ALTER INDEX REBUILD PARTITION to rebuild the index partition OR ALTER TABLE TRUNCATE PARTITION to mark the index partition as valid.

ORA-29954 domain index partition is marked LOADING/FAILED/UNUSABLE

Cause: An attempt has been made to access a domain index that is being built or is marked failed by an unsuccessful DDL or is marked unusable by a DDL operation.

Action: Wait if the specified index partition is marked LOADING. Rebuild the specified index partition if it is marked FAILED or UNUSABLE.

ORA-29955 error occurred in the execution of ODCIINDEXEXCHANGEPARTITION routine

Cause: Failed to successfully execute the ODCIIndexExchangePartition routine.

Action: Check to see if the routine has been coded correctly.

ORA-29956 warning in the execution of ODCIINDEXEXCHANGEPARTITION routine

Cause: A warning was returned from the ODCIIndexExchangePartition routine.

Action: Check to see if the routine has been coded correctly. Check user specified log tables for greater detail.

ORA-29957 cannot create a function-based domain index on a string table

Cause: User specified an unsupported create function-based domain index statement.

Action: Issue the create function-based domain index statement only on supported types of tables.

ORA-29958 fatal error occurred in the execution of ODCIINDEXCREATE routine

Cause: Failed to successfully execute the ODCIIndexCreate routine.

Action: Check to see if the routine has been coded correctly.

ORA-29959 error in the execution of the string routine for one or more of the index partitions

Cause: An error occurred during execution of the routine for one or more of the index partitions.

Action: Check the *_IND_PARTITIONS view to see which partitions are marked FAILED. Rebuild or Truncate the FAILED index partitions.

ORA-29960 line string, stringThe ODCIIndex DDL routine has put a warning message into table SYS.ODCI_WARNINGS$.

Action: Check the warning message.

ORA-29961 too many warnings occurred in the execution of ODCIIndex DDL routine

Cause: The number of warnings during the ODCIIndex DDL routine is too high.

Action: Query table SYS.ODCI_WARNINGS$ to get more warning messages.

ORA-29962 fatal error occurred in the execution of ODCIINDEXALTER routine

Cause: Failed to successfully execute the ODCIIndexAlter routine.

Action: Check to see if the routine has been coded correctly.

ORA-30000 missing either trim specification or char expression in TRIM

Cause: Since FROM is specified in TRIM function, either trim specification (TRAILING, HEADING, BOTH) or trim character or both must be specified.

Action: Add either trim specification (TRAILING, HEADING, BOTH) or trim character or both.

ORA-30001 trim set should have only one character

Cause: Trim set contains more or less than 1 character. This is not allowed in TRIM function.

Action: Change trim set to have only 1 character.

ORA-30002 SYS_CONNECT_BY_PATH function is not allowed here

Cause: SYS_CONNECT_BY_PATH function is called at places other than select list.

Action: Remove calls to SYS_CONNECT_BY_PATH function at places other than select list.

ORA-30003 illegal parameter in SYS_CONNECT_BY_PATH function

Action: use a non-empty constant string as the second argument and retry the operation.

ORA-30004 when using SYS_CONNECT_BY_PATH function, cannot have seperator as part of column value

Action: Use another seperator which does not occur in any column value and retry.

ORA-30005 missing or invalid WAIT interval

Cause: A non-zero integer must be specified for wait interval (in seconds) after the WAIT keyword.

Action: Correct the syntax and retry.

ORA-30006 resource busy; acquire with WAIT timeout expired

Cause: The requested resource is busy.

Action: Retry the operation later.

ORA-30012 undo tablespace 'string' does not exist or of wrong type

Cause: the specified undo tablespace either does not exist or is of the wrong type.

Action: Correct the tablespace name and reissue the statement.

ORA-30013 undo tablespace 'string' is currently in use

Cause: the specified undo tablespace is currently used by another instance.

Action: Wait for the undo tablespace to become available or change to another name and reissue the statement.

ORA-30014 operation only supported in Automatic Undo Management mode

Cause: the operation is only supported in automatic undo mode.

Action: restart the instance in Automatic Undo Management mode before retrying the operation.

ORA-30015 previously offlined undo tablespace 'string' is still pending

Cause: the current operation is not allowed because an undo tablespace containing active transactions is pending from a previous SWITCH UNDO operation. The operation will be allowed again after all transactions in the previous undo tablespace are committed.

Action: Wait for all previous transactions to commit before reissuing the current statement.

ORA-30016 undo tablespace 'string' is already in use by this instance

Cause: the specified undo tablespace is currently used by this instance. The operation failed.

Action: If the specified undo tablespace name is incorrect, reissue the statement with the correct name.

ORA-30017 segment 'string' is not supported in string Undo Management mode

Cause: The type of the specified undo segment is incompatible with the current undo management mode of the instance.

Action: Check the undo segment name and the undo management mode and reissue the statement if necessary.

ORA-30018 Create Rollback Segment failed, USN string is out of range

Cause: the system runs out of undo segment number. Too many undo segments exist.

Action: drop some of the unused undo segments and retry the operation.

ORA-30019 Illegal rollback Segment operation in Automatic Undo mode

Cause: This operation is only allowed in Manual Undo mode.

Action: Restart the instance in Manual Undo_Management mode and retry the operation.

ORA-30020 UNDO_MANAGEMENT=AUTO needs Compatibility string or greater

Cause: Auto undo management mode is not allowed in the specified compatibility release.

Action: restart the instance in correct compatibility release.

ORA-30021 Operation not allowed on undo tablespace

Cause: This operation is not allowed on undo tablespaces.

Action: Check the tablespace name and reissue the command if necessary.

ORA-30022 Cannot create segments in undo tablespace

Cause: Cannot create segments in undo tablespace.

Action: Check the tablespace name and reissue the command.

ORA-30023 Duplicate undo tablespace specification

Cause: Cannot create more than one undo tablespace during database creation.

Action: Modify the command to contain only one undo tablespace.

ORA-30024 Invalid specification for CREATE UNDO TABLESPACE

Cause: You have specified a clause that should not be used with CREATE UNDO TABLESPACE.

Action: Drop the clause from the command and reissue it.

ORA-30025 DROP segment 'string' (in undo tablespace) not allowed

Cause: Explicit DROP operation is not allowed on undo tablespace segments.

Action: Check the undo segment name and reissue the statement if necessary.

ORA-30026 Undo tablespace 'string' has unexpired undo with string(sec) left, Undo_Retention=string(sec)

Cause: Tried to drop a tablespace that contains unexpired undo information.

Action: lower the setting of UNDO_RETENTION or wait a while before reissuing the command to drop undo tablespace.

ORA-30027 Undo quota violation - failed to get string (bytes)

Cause: the amount of undo assigned to the consumer group of this session has been exceeded.

Action: ask the database administrator to increase undo quota, or wait until other transactions commit.

ORA-30029 no active undo tablespace assigned to instance

Cause: the current instance does not have an active undo tablespace assigned to execute transactions.

Action: ask the database administrator to create an undo tablespace, online the undo tablespace and then retry the operation.

ORA-30031 the suspended (resumable) statement has been aborted

Cause: The database administrator or the user aborted the execution of the suspended statement in the resumable session.

Action: No action required.

ORA-30032 the suspended (resumable) statement has timed out

Cause: A correctable error was signaled in the resumable session and the error was not cleared within the timeout interval.

Action: Fix the correctable error within the timeout. The default is 2 hours. Alternatively, increase the (resumable) timeout.

ORA-30033 Undo tablespace cannot be specified as default user tablespace

Cause: It is incorrect to specify undo tablespace as default user tablespace.

Action: Check the tablespace name and reissue the command.

ORA-30034 Undo tablespace cannot be specified as temporary tablespace

Cause: Undo tablespace cannot be specified as default temporary tablespace for the user.

Action: Check the tablespace name and reissue the command.

ORA-30035 Undo tablespace cannot be specified as default temporary tablespace

Cause: Undo tablespace cannot be specified as default temporary tablespace for the database.

Action: Check the tablespace name and reissue the command.

ORA-30036 unable to extend segment by string in undo tablespace 'string'

Cause: the specified undo tablespace has no more space available.

Action: Add more space to the undo tablespace before retrying the operation. An alternative is to wait until active transactions to commit.

ORA-30037 Cannot perform parallel DML after a prior DML on the object

Cause: Attempt to perform parallel DML after another DML on the same object in the same transaction.

Action: Use bitmap segments to perform multiple (parallel) DML operations on the same object. Alternatively, commit before issueing the DML.

ORA-30038 Cannot perform parallel insert on non-partitioned object

Cause: Attempt to perform parallel insert on a non-partitioned object after a previous DML on the object in the same transaction.

Action: Commit before issueing the insert.

ORA-30039 Cannot drop the undo tablespace

Cause: Cannot drop an undo tablespace that is in use.

Action: Switch to a different undo tablespace and then try to drop.

ORA-30040 Undo tablespace is offline

Cause: Cannot operate on an offlined undo tablespace.

Action: Online the undo tablespace and redo the operation.

ORA-30041 Cannot grant quota on the tablespace

Cause: User tried to grant quota on an undo tablespace.

Action: Check the tablespace name and reissue the command.

ORA-30042 Cannot offline the undo tablespace

Cause: Cannot offline an undo tablespace that is in use.

Action: Switch to a different undo tablespace and then try to offline.

ORA-30043 Invalid value 'string' specified for parameter 'Undo_Management'

Cause: The specified undo management mode is invalid.

Action: Correct the parameter value in the initialization parameter file and retry the operation.

ORA-30045 No undo tablespace name specified

Cause: If Create Database has the datafile clause, then undo tablespace name has to be specified, unless using OMF.

Action: Specify the undo tablespace name.

ORA-30071 conversion between datetime/interval and string fail

Cause: An error occurred during a conversion between datetime/interval and string data type due to one of the following reasons:

  • The buffer is too short to hold the result.
  • The format string is bad.

Action: Correct the problem and try again.

ORA-30072 invalid time zone value

Cause: The value specified for the time zone string, which appears in ALTER SESSION statement, environment variable ORA_SDTZ, or a datetime factor, is not valid.

Action: Specify a valid time zone value.

ORA-30073 invalid adjustment value

Cause: The value is none of the followings: 'ADJUST', 'NO_ADJUST', 'ANSI_DATE', 'ADJUST_WITH_ANSI_DATE'. 'NO_ADJUST' is the default value.

Action: Set it to one of the three values.

ORA-30074 GLOBAL partitioned index on TIME/TIMESTAMP WITH TIME ZONE not allowed

Cause: An attempt was made to GLOBAL partition an index on TIME/TIMESTAMP WITH TIME ZONE.

Action: Do not GLOBAL partition an index on TIME/TIMESTAMP WITH TIME ZONE.

ORA- 30075 TIME/TIMESTAMP WITH TIME ZONE literal must be specified in CHECK constraint

Cause: An attempt was made to create a constraint on a time or timestamp with or without time zone column without explicitly specifying the time zone.

Action: Use time or timestamp with time zone literals only.

ORA-30076 invalid extract field for extract source

Cause: The extract source does not contain the specified extract field.

Action: Specify a valid extract field for the extract source.

ORA-30077 illegal casting between specified datetime types

Cause: Cannot cast between the specified datetime types.

Action: No action required.

ORA-30078 partition bound must be TIME/TIMESTAMP WITH TIME ZONE literals

Cause: An attempt was made to use a time/timestamp expression whose format does not explicitly have time zone on a TIME/TIMESTAMP WITH TIME ZONE column.

Action: Explicitly use the TIME/TIMESTAMP WITH TIME ZONE literal.

ORA-30081 invalid data type for datetime/interval arithmetic

Cause: The data types of the operands are not valid for datetime/interval arithmetic.

Action: Specify valid data types for datetime/interval arithmetic.

ORA-30082 datetime/interval column to be modified must be empty to decrease fractional second or leading field precision

Cause: Datetime/interval column with existing data is being modified to decrease fractional second or leading field precisions.

Action: Such columns are only allowed to increase the precisions.

ORA-30083 syntax error was found in interval value expression

Cause: A syntax error was found during parsing an interval value expression.

Action: Correct the syntax.

ORA-30084 invalid data type for datetime primary with time zone modifier

Cause: When a time zone modifier is specified, the data type of datetime primary must be one of the following: TIME, TIME WITH TIME ZONE, TIMESTAMP, TIMESTAMP WITH TIME ZONE.

Action: Specify a valid data type.

ORA-30085 syntax error was found in overlaps predicate

Cause: A syntax error was found during parsing an overlaps predicate.

Action: Correct the syntax.

ORA-30086 interval year-month result not allowed for datetime subtraction

Cause: An attempt was made to specify interval year to month as the result of datetime subtraction.

Action: This is not allowed currently due to unclear specification in SQL Standards for this interval type. Change the interval type to interval day to second and resubmit statement.

ORA-30087 Adding two datetime values is not allowed

Cause: An attempt was made to add two datetime values.

Action: This addition is not allowed.

ORA-30088 datetime/interval precision is out of range

Cause: The specified datetime/interval precision was not between 0 and 9.

Action: Use a value between 0 and 9 for datetime/interval precision.

ORA-30089 missing or invalid datetime_field

Cause: A datetime_field (YEAR, MONTH, DAY, HOUR, MINUTE, SECOND) is expected but not found, or a datetime_field specified the end_field in an interval_qualifier is more significant than its start_field.

Action: Specify a valid datetime field.

ORA-30100 internal error [number]

Cause: An internal error has occurred.

Action: Contact Oracle Support Services and report the error.

ORA-30101 unknown parameter name 'string'

Cause: You have misspelled the parameter name.

Action: Spell the parameter name correctly.

ORA-30102 'string' is not in the legal range for 'string'

Cause: The value of the parameter is not within the legal range.

Action: Refer to the Oracle9i SQL Reference for the allowable values for this parameter.

ORA-30103 'string' contains an illegal integer radix for 'string'

Cause: An illegal integer radix specification was found.

Action: Only 'd', 'h', 'D', and 'H' may be used as radix specifications.

ORA-30104 'string' is not a legal integer for 'string'

Cause: The value is not a valid integer.

Action: Specify only valid integers for this parameter.

ORA-30105 'string' is not a legal boolean for 'string'

Cause: The value is not a valid boolean.

Action: Refer to the Oracle9i SQL Reference for allowable boolean values.

ORA-30106 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30107 parameter name abbreviation 'string' is not unique

Cause: The abbreviation given was not unique.

Action: Use a longer abbreviation to make the parameter name unique.

ORA-30108 invalid positional parameter value 'string'

Cause: An invalid positional parameter value has been entered.

Action: Remove the invalid positional parameter.

ORA-30109 could not open parameter file 'string'

Cause: The parameter file does not exist.

Action: Create an appropriate parameter file.

ORA-30110 syntax error at 'string'

Cause: A syntax error was detected.

Action: Change the input so that the correct syntax is used.

ORA-30111 no closing quote for value 'string'

Cause: A quoted string was begun but not finished.

Action: Put a closing quote in the proper location.

ORA-30112 multiple values not allowed for parameter 'string'

Cause: An attempt was made to specify multiple values for a parameter which can take only one value.

Action: Do not specify more than one value for this parameter.

ORA-30113 error when processing file 'string'

Cause: A problem occurred when processing this file.

Action: Examine the additional error messages and correct the problem.

ORA-30114 error when processing from command line

Cause: A problem occurred when processing the command line.

Action: Examine the additional error messages and correct the problem.

ORA-30115 error when processing an environment variable

Cause: A problem occurred when processing an environment variable.

Action: Examine the additional error messages and correct the problem.

ORA-30116 syntax error at 'string' following 'string'

Cause: A syntax error was detected.

Action: Change the input so that the correct syntax is used.

ORA-30117 syntax error at 'string' at the start of input

Cause: A syntax error was detected.

Action: Change the input so that the correct syntax is used.

ORA-30118 syntax error at 'string' at the end of input

Cause: A syntax error was detected.

Action: Change the input so that the correct syntax is used.

ORA-30119 unable to obtain a valid value for 'string'

Cause: No valid value was obtained for this parameter.

Action: Rerun the application and enter a valid value.

ORA-30120 'string' is not a legal oracle number for 'string'

Cause: The value is not a valid Oracle number.

Action: Refer to the Oracle9i SQL Reference for allowable Oracle number values.

ORA-30121 'string' is not an allowable value for 'string'

Cause: The value is not a legal value for this parameter.

Action: Refer to the manual for allowable values.

ORA-30122 value 'string' for 'string' must be between 'number' and 'number'"

Cause: The value of the parameter is not within the legal range.

Action: Specify a value that is within the legal range.

ORA-30129 invalid function argument received

Cause: A function received an invalid argument.

Action: Check function calls and make sure correct arguments are being passed.

ORA-30130 invalid parameter key type received

Cause: A function received an invalid parameter key type.

Action: Check parameter key types in function calls.

ORA-30131 number of keys being set exceeds allocation

Cause: The number of parameter keys being set exceeds allocation.

Action: Reduce the number of keys being set or increase allocation.

ORA-30132 invalid key index supplied

Cause: The key index specified was not within bounds.

Action: Change key index to ensure it lies within bounds.

ORA-30135 OCI Thread operation fails

Cause: An OCI Thread function call has failed.

Action: Check the function call to make sure that the correct parameters are being passed and take the appropriate action.

ORA-30150 Invalid argument passed to OCIFile function

Cause: An invalid argument is passed to the OCIFile function. The most common cause is that a NULL pointer is passed where a non-NULL pointer is expected.

Action: Make sure that the values passed as arguments are valid. Check for NULL pointers.

ORA-30151 File already exists

Cause: An attempt was made to open a file with OCI_FILE_EXCL flag and the file already exists.

Action: OCIFile is supposed throw this exception in this case.

ORA-30152 File does not exist

Cause: The OCIFile function requires the file to exist, but it does not.

Action: Make sure that the file exists.

ORA-30153 An invalid File Object is passed to the OCIFile function

Cause: An invalid File Object is passed to the OCIFile function.

Action: Make sure that the file object is a valid one. Create a new file object by calling OCIFileOpen if needed.

ORA-30154 The memory address given as buffer for OCIFileRead/Write is invalid

Cause: An invalid memory address is given as the buffer pointer for OCIFileRead/Write.

Action: Make sure that the required memory is allocated and pass a valid memory address as buffer pointer.

ORA-30155 An I/O Error occured during an OCIFile function call

Cause: An I/O error occurred at the system level.

Action: This is a system error and the action will depend on the error.

ORA-30156 Out of disk space

Cause: The disks associated with the underlying file system are full.

Action: Create more disk space.

ORA-30157 An invalid argument was given to operating system call

Cause: The operating system call was called with an invalid argument.

Action: Check the values passed. If you are unable to solve the problem, then contact Oracle Support Services.

ORA-30158 The OCIFileWrite causes the file to exceed the maximum allowed size

Cause: There is no space to write to the file. Its size is at the maximum limit.

Action: If you can, increase the limit.

ORA-30159 OCIFileOpen: Cannot create the file or cannot open in the requested mode

Cause: The create flag was specified in OCIFileOpen such that the file was to be created. But unable to do so. Or the file already exists and the permissions on it does not allow the file to be opened in the requested open mode.

Action: Check whether the user has permissions to create the specified file or if the file exists whether the permissions on it allow the requested open mode.

ORA-30160 Unable to access the file

Cause: The function was unable to access the existing the file.

Action: Check if the user has the required permissions on the file.

ORA-30161 A system error occurred during the OCIFile function call

Cause: A system error occurred while executing the OCIFile function.

Action: Investigate and solve the system error.

ORA-30162 The OCIFile context is not initialzed

Cause: The function OCIFileInit need to be called before calling any other OCIFile function to initialize the OCIFile context.

Action: Call the function OCIFileInit need to be called before calling any other OCIFile function.

ORA-30163 The thread safety initialization failed

Cause: The call to SlgInit failed in OCIFileInit.

Action: Contact Oracle Support Services.

ORA-30175 invalid type given for an argument

Cause: There is an argument with an invalid type in the argument list.

Action: Use the correct type wrapper for the argument.

ORA-30176 invalid format code used in the format string

Cause: There is an invalid format code in the format string.

Action: Replace the invalid format code with a valid one.

ORA-30177 invalid flag used in a format specification

Cause: There is an invalid flag in a format specification.

Action: Replace the invalid flag with a valid one.

ORA-30178 duplicate flag used in a format specification

Cause: There is a duplicate flag in a format specification.

Action: Remove the duplicate flag.

ORA-30179 invalid argument index used in a format code

Cause: Zero or negative argument index or index not following (.

Action: Replace the invalid argument index with a valid one.

ORA-30180 argument index is too large

Cause: An argument index exceeds actual number of arguments supplied.

Action: Fix format string or pass additional arguments.

ORA-30181 integer in argument index is not immediately followed by )

Cause: Missing closing parenthesis in argument index.

Action: Fix the format specification.

ORA-30182 invalid precision specifier

Cause: Period in format specification not followed by valid format.

Action: Replace the invalid precision specifier with a valid one.

ORA-30183 invalid field width specifier

Cause: Invalid field width supplied.

Action: Replace the invalid field width with a valid one.

ORA-30184 argument type not compatible with a format code

Cause: Bad argument type given for a format code.

Action: Make format and arguments be compatible.

ORA-30185 output too large to fit in the buffer

Cause: The buffer is not large enough to hold the entire output string.

Action: Fix the buffer size and length passed in.

ORA-30186 '\' must be followed by four hexadecimal characters or another '\'

Cause: In the argument of SQL function UNISTR, a '\' must be followed by four hexadecimal characters or another '\'.

Action: Fix the string format.

ORA-30187 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30188 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30189 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30190 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30191 missing argument list

Cause: No argument list supplied.

Action: Modify the argument list to have at least OCIFormatEnd in it.

ORA-30192 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30193 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30194 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30195 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30196 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30197 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30198 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30199 reserved for future use

Cause: This message is reserved for future use.

Action: No action required.

ORA-30200 Wrong NLS item was passed into OCINlsGetInfo()

Cause: The item is not supported NLS item.

Action: Correct the item number passed to OCINlsGetInfo().

ORA-30201 Unable to load NLS data object

Cause: It may be caused by invalid NLS environment setting.

Action: Check your NLS environment setting such as ORA_NLS33.

ORA-30202 NULL pointer to OCIMsgh was passed to OCIMsg function

Cause: The NULL pointer was passed.

Action: Check the value of the OCIMsgh pointer.

ORA-30203 Cannot open mesage file

Cause: The message may not exist in your system.

Action: Check the message for the given product and facility.

ORA-30204 buffer is not large enough

Cause: The destination buffer is not large enough for storing converted data.

Action: Check the size of the destination buffer.

ORA-30205 invalid Character set

Cause: The specified character set is invalid.

Action: Check if the character set ID is valid.

ORA-30331 summary does not exist

Cause: A non-existent summary name was specified.

Action: Check the spelling of the summary name.

ORA-30332 container table already in use by other summary

Cause: Another summary is already using this table as a container table.

Action: Select another table or materialized view as the container table for this summary.

ORA-30333 dimension does not exist

Cause: The dimension named in a dimension DDL statement does not exist.

Action: Check the spelling of the dimension name.

ORA-30334 illegal dimension level name

Cause: A level name in a dimension DDL statement did not conform to SQL identifier rules.

Action: Use a level name that begins with a letter, consists of only letters, digits, and underscores and contains no more than 30 characters.

ORA-30335 JOIN KEY clause references a level not in this hierarchy

Cause: The level name specified with the REFERENCES portion of a JOIN KEY clause in a dimension DDL statement does not reference a level in the hierarchy that contains the JOIN KEY clause.

Action: Check the spelling of the level name.

ORA-30336 no child for specified JOIN KEY

Cause: The level specified in the REFERENCES portion of a JOIN KEY clause in a dimension DDL statement does not have a child level.

Action: Check the spelling of the level name referenced in the JOIN KEY clause. If the referenced level is the first level in the hierarchy, you need not and must not specify a JOIN KEY clause.

ORA-30337 multiple JOIN KEY clauses specified for the same parent level

Cause: More than one JOIN KEY clause was specified for a given parent level in a dimension hierarchy.

Action: Match up each JOIN KEY clause with the level it references in the hierarchy. Eliminate the redundant JOIN KEY clause.

ORA-30338 illegal dimension hierachy name

Cause: An illegal dimension hierarchy name was specified in a dimension DDL statement.

Action: Make sure the name begins with a letter, contains only letters, digits and underscore and contains no more than 30 characters. If you qualify the name with the owner name, make sure the owner name conforms with the requirements for an owner name on your system.

ORA-30339 illegal dimension attribute name

Cause: An illegal dimension attribute name was specified in a dimension DDL statement.

Action: Make sure the name begins with a letter, contains only letters, digits and underscore and contains no more than 30 characters. If you qualify the name with the owner name, make sure the owner name conforms with the requirements for an owner name on your system.

ORA-30340 illegal dimension name

Cause: An illegal dimension name was specified in a dimension DDL statement.

Action: Make sure the name begins with a letter, contains only letters, digits and underscore and contains no more than 30 characters. If you qualify the name with the owner name, make sure the owner name conforms with the requirements for an owner name on your system.

ORA-30341 dropped level has references

Cause: An attempt was made to drop a level using the default or RESTRICT option in a dimension while references to that level remain in the dimension. References can occur in hierarchies and attributes within the dimension.

Action: First remove any references to the level prior to dropping it, or specify the CASCADE option with the DROP LEVEL clause.

ORA-30342 referenced level is not defined in this dimension

Cause: A reference to a level not defined within the dimension was found.

Action: Check the spelling of the level name.

ORA-30343 level name is not unique within this dimension

Cause: Two or more levels were defined with the same name.

Action: Check the spelling of the level names.

ORA-30344 number of child cols different from number of parent level cols

Cause: The number of child columns specified in a JOIN KEY clause is not the same as the number of columns in the specified parent level.

Action: Check the child columns and the columns in the definition of the referenced parent level and correct the discrepancy.

ORA-30345 circular dimension hierarchy

Cause: A circularity was found the dimension hierarchy.

Action: Check the hierarchy for a level name that occurs more than once.

ORA-30346 hierarchy name must be unique within a dimension

Cause: The same name was used for more than one hierarchy in a dimension.

Action: Check the spelling of the hierarchy name.

ORA-30347 a table name is required to qualify the column specification

Cause: A table name was omitted in a column specification where the column must be qualified by the table name.

Action: Qualify the column with the table name.

ORA-30348 ADD and DROP cannot both be specified

Cause: One or more ADD clauses were found in the same ALTER DIMENSION statement with one or more DROP clauses.

Action: Separate your ADD operations into one ALTER DIMENSION statement and your DROP operations into another.

ORA-30349 specified dimension hierarchy does not exist

Cause: A hierarchy name was encountered that is not defined within the dimension.

Action: Check the spelling of the hierarchy name.

ORA-30350 specified dimension attribute does not exist

Cause: An attribute name was encountered that is not defined within the dimension.

Action: Check the attribute name spelling.

ORA-30351 query rewrite does not currently support this expression

Cause: A complex expression was specified that is not currently supported by query rewrite.

Action: Reduce the complexity of the expression.

ORA-30352 inconsistent numeric precision or string length

Cause: The SELECT expression was of a different numeric precision or string length than the corresponding container column. Therefore, query rewrite cannot guarantee results that are identical to the results obtained with the un-rewritten query.

Action: Correct the precision or string length difference, specify the WITH REDUCED PRECISION option, or disable the REWRITE option on the materialized view.

ORA-30353 expression not supported for query rewrite

Cause: The select clause referenced UID, USER, ROWNUM, SYSDATE, CURRENT_TIMESTAMP, MAXVALUE, a sequence number, a bind variable, correlation variable, a set result, a trigger return variable, a parallel table queue column, collection iterator, and so on.

Action: Remove the offending expression or disable the REWRITE option on the materialized view.

ORA-30354 Query rewrite not allowed on SYS relations

Cause: A SYS relation was referenced in the select clause for a materialized view with query rewrite enabled.

Action: Remove the reference to the SYS relation from the select clause or disable the REWRITE option on the materialized view.

ORA-30355 materialized view container does not exist

Cause: A DROP TABLE command was issued directly against the materialized view container table.

Action: Use the DROP MATERIALIZED VIEW command to clean up the residual metadata for the materialized view. Then use the CREATE MATERIALIZED VIEW statement to re-create the materialized view. Thereafter, use the DROP MATERIALIZED VIEW command rather than the DROP TABLE command to drop a materialized view.

ORA-30356 the specified refresh method is not supported in this context

Cause: The refresh method that was specified is not currently supported.

Action: Specify a different refresh method or change the context to enable support of the chosen refresh method.

ORA-30357 this PL/SQL function cannot be supported for query rewrite

Cause: The statement referenced a PL/SQL function that is not marked DETERMINISTIC.

Action: Perform one of the following actions:

  • Remove the use of the PL/SQL function.
  • Mark the PL/SQL function as DETERMINISTIC.
  • Disable the REWRITE option on the materialized view.

The function should be marked DETERMINISTIC only if it always returns the same result value for any given set of input argument values, regardless of any database state or session state. Do not mark the function as DETERMINISTIC if it has any meaningful side-effects.

ORA-30358 summary and materialized view are not in same schema

Cause: An internal error occurred.

Action: Contact Oracle Support Services.

ORA-30359 Query rewrite is not supported on SYS materialized views

Cause: An attempt was made to enable the REWRITE option on a materialized view in the SYS schema.

Action: Create the materialized view in a different schema or disable the REWRITE option.

ORA-30360 REF not supported with query rewrite

Cause: The statement contained a REF operator. Repeatable behavior cannot be guaranteed with the REF operator. Therefore, query rewrite cannot support the REF operator.

Action: Remove the reference to the REF operator or disable the REWRITE option on the materialized view.

ORA-30361 unrecognized string type

Cause: An internal error occurred.

Action: Contact Oracle Support Services.

ORA-30362 dimension column cannot be a sequence

Cause: The dimension statement referenced a column that is a sequence.

Action: Remove the reference to the sequence.

ORA-30363 columns in a dimension column list must be in the same relation

Cause: The dimension statement contained a column list where the columns are not all from the same relation.

Action: Specify the list of columns using only columns from a single relation.

ORA-30364 this level has the same set of columns as another

Cause: The level definition contained the same set of columns as another level.

Action: Eliminate the redundant level definition.

ORA-30365 left relation in the JOIN KEY clause cannot be same as right

Cause: The relation of the child columns on the left side of the JOIN KEY clause was the same as that of the parent level on the right side.

Action: Remove the JOIN KEY clause. It is not required or allowed when the child and the parent are in the same relation.

ORA-30366 child JOIN KEY columns not in same relation as child level

Cause: The relation of the child columns on the left side of the JOIN KEY clause differed from that of that child level.

Action: Specify the correct child columns in the JOIN KEY clause.

ORA-30367 a JOIN KEY clause is required

Cause: A JOIN KEY clause was omitted in a dimension statement. A JOIN KEY clause is required when the child level and the parent level are not in the same relation.

Action: Specify a JOIN KEY clause to indicate how the relation of the child level joins to the relation of the parent level.

ORA-30368 ATTRIBUTE cannot determine column in a different relation

Cause: An ATTRIBUTE clause in a dimension statement specified a determined column on the right that is in a different relation than that of the level on the left.

Action: Specify attributes only for those dimension levels that functionally determine other columns within the same relation.

ORA-30369 maximum number of columns is 32

Cause: A list of columns was specified using more than 32 columns.

Action: Specify the list using no more than 32 columns.

ORA-30370 set operators are not supported in this context

Cause: A set operator such as UNION, UNION ALL, INTERSECT, or MINUS was encountered in an unsupported context, such as in a materialized view definition.

Action: Re-specify the expression to avoid the use of set operators.

ORA-30371 column cannot define a level in more than one dimension

Cause: A column was used in the definition of a level after it had already been used to define a level in a different dimension.

Action: Reorganize dimension levels and hierarchies into a single dimension such that no column is used to define levels in different dimensions. There is no limit on the number of levels or hierarchies you can place in a dimension. A column can be used to define any number of levels provided all such levels are in the same dimension and provided no two levels contain identical sets of columns.

ORA-30372 fine grain access policy conflicts with materialized view

Cause: A fine grain access control procedure has applied a non-null policy to the query for the materialized view.

Action: In order for the materialized view to work correctly, any fine grain access control procedure in effect for the query must return a null policy when the materialized view is being created or refreshed. This may be done by ensuring that the usernames for the creator, owner, and invoker of refresh procedures for the materialized view all receive a null policy by the user-written fine grain access control procedures.

ORA-30373 object data types are not supported in this context

Cause: An object data type was encountered in an unsupported context.

Action: Re-specify the expression to avoid the use of objects.

ORA-30374 materialized view is already fresh

Cause: If the materialized view is fresh, ORACLE ignores the ALTER MATERIALIZED VIEW <mv> RELY FRESH command, and issues this error message.

Action: No action required.

ORA-30375 materialized view cannot be considered fresh

Cause: If the materialized view is invalid or unusable, it cannot be considered fresh with the ALTER MATERIALIZED VIEW <mv> CONSIDER FRESH command.

Action: No action required.

ORA-30376 prevent sharing of a parsed query of an explain rewrite session

Cause: Explain rewrite generates a shared cursor after parsing the user query. Raising this error will prevent the cursor from being shared.

Action: No action required.

ORA-30377 MV_CAPABILITIES_TABLE not found

Cause: You have used the DBMS_MVIEW.EXPLAIN_MVIEW() API before you have defined the MV_CAPABILITIES_TABLE.

Action: Invoke the ORACLE_HOME/rdbms/admin/utlxmv.sql script after connecting to the desired schema.

ORA-30378 MV_CAPABILITIES_TABLE is not compatible with Oracle version

Cause: One or more column definitions in the MV_CAPABILITIES_TABLE is either missing or incompatible with the current Oracle version.

Action: Connect to the appropriate schema, DROP TABLE MV_CAPABILITIES_TABLE, and recreate it by invoking the ORACLE_HOME/rdbms/admin/utlxmv.sql script prior to invoking the DBMS_MVIEW.EXPLAIN_MVIEW() API.

ORA-30379 query txt not specified

Cause: You have attempted to use the DBMS_MVIEW.EXPLAIN_REWRITE() API with an empty query text argument.

Action: Input a valid SQL query.

ORA-30380 REWRITE_TABLE does not exist.

Cause: You have used the DBMS_MVIEW.EXPLAIN_REWRITE() API before you have created the REWRITE_TABLE.

Action: Create it using the ORACLE_HOME/rdbms/admin/utlxrw.sql script after connecting to the desired schema.

ORA-30381 REWRITE_TABLE is not compatible with Oracle version

Cause: One or more column definitions in the REWRITE_TABLE is either missing or incompatible with the current Oracle version.

Action: Connect to the appropriate schema, DROP TABLE REWRITE_TABLE and recreate it by invoking the ORACLE_HOME/rdbms/admin/utlxrw.sql script prior to invoking the DBMS_MVIEW.EXPLAIN_REWRITE() API.

ORA-30382 DROP MATERIALIZED VIEW string.string operation is not complete

Cause: The drop materialized view operation got an unexpected error while dropping a summary object.

Action: Re-issue the drop materialized view command.

ORA-30430 list does not contain any valid summaries

Cause: List is empty or does not contain the names of existing summaries.

Action: Verify that the list of names passed to refresh contains the name of at least one existing summary object

ORA-30431 refresh method must be ANY or INCREMENTAL or FORCE_FULL, not string

Cause: An invalid refresh method was specified.

Action: Verify that the refresh method is one of 'ANY' or 'INCREMENTAL' or 'FORCE_FULL'.

ORA-30432 summary 'string.string' is in INVALID state

Cause: The summary is in INVALID state and cannot be refreshed.

ORA-30433 'string.string' is not a summary

Cause: There is no such summary, therefore it cannot be refreshed.

Action: Verify the correct name of the summary.

ORA-30434 refresh method must be one of FC?AN, not 'string'

Cause: An invalid refresh method was specified.

Action: Verify that the refresh method is one of 'FC?AN'.

ORA-30435 job_queue_processes must be non-zero in order to refresh summaries

Cause: The server must be started with parameter JOB_QUEUE_PROCESSES greater than zero.

Action: Correct the value of JOB_QUEUE_PROCESSES and restart the server instance.

ORA-30436 unable to open named pipe 'string'

Cause: The refresh process was unable to open a named pipe to the job queue process usually because of insufficient system resources. This is an internal error.

Action: Contact Oracle Support Services.

ORA-30437 all job queue processes have stopped running

Cause: All of the job queue processes used by refresh have stopped for some reason. At least one job queue process must be running in order to refresh summaries. This is an internal error.

Action: Contact Oracle Support Services.

ORA-30438 unable to access named pipe 'string'

Cause: The refresh process was unable to access a named pipe to the job queue process after it successfully opened the pipe. This usually indicates an internal or operating system error condition. This is an internal error.

Action: Contact Oracle Support Services.

ORA-30439 refresh of 'string.string' failed because of string

Cause: The refresh job queue process encountered an error and is reporting it. The accompanying text of the message indicates cause of the error.

Action: Varies, depending upon the reported cause.

ORA-30440 can't fast refresh;refresh complete or set event 30441 for partial refresh

Cause: Both DML and direct-load are performed against detail tables. Fast refresh can only process direct-load inserts.

Action: Refresh complete or set event 30441 to enable partial refresh with only direct-load inserts.

ORA-30442 can not find the definition for filter string

Cause: For the specified filterid parameter, there is no corresponding filter definition found in the advisor repository.

Action: Use a valid filterid generated by the create_filter function.

ORA-30443 definition for filter string's item string is invalid

Cause: The specified filter is invalid. It contains at least one invalid filter item. If a filter item has a string list, it becomes illegal when the string list cannot be successfully parsed. If the filter item contains a range definition, and the lower bound of the range is greater than the higher bound, the item also becomes invalid.

Action: Remove the illegal filter with the purge_filter sub-program and redefine a correct filter.

ORA-30445 workload queries not found

Cause: No workload queries in the advisor repository can satisfy the specified filter.

Action: Redefine a new filter or load additional workload queries that can satisfy the specified filter.

ORA-30446 valid workload queries not found

Cause: None of the specified queries can be successfully parsed. The error may come from many sources: SQL syntax error or the owner specified by the load_workload() subprograms do not match the real user who generates the SQL statement.

Action: Only load valid SQL statements into the advisor repository. Make sure the statements can be parsed with privilege of the owner as specified in the owner parameter of the load_workload() subprogram.

ORA-30447 internal data for run number string is inconsistent

Cause: Users should not explicitly modify summary advisor's internal tables. Such modifications may cause inconsistency in the internal tables and result in this error.

Action: Users can call the DBMS_OLAP.PURGE_RESULTS subprogram to remove the inconsistent data from summary advisor's internal tables.

ORA-30449 syntax error in parameter string

Cause: The syntax for the specified parameter is incorrect.

Action: Check ORACLE documentation for the correct syntax.

ORA-30450 refresh_after_errors was TRUE; The following MVs could not be refreshed: string

Cause: One or more errors occurred during a refresh of multiple summaries.

Action: The NUMBER_OF_FAILURES parameter returns the count of how many failures occurred. The trace logs for each refresh operation describe the each individual failure in more detail.

ORA-30451 internal error

Cause: An internal error was detected by the summary refresh subsystem, and aborted the refresh operation.

Action: Contact Oracle Support Services.

ORA-30452 cannot compute AVG(X), VARIANCE(X) or STDDEV(X), without COUNT(X) or SUM(X)

Cause: Incremental refresh of summaries requires a COUNT(X) column in order to incrementally refresh AVG(X). It requires both SUM(X) and COUNT(X) columns in order to in refresh STDDEV(X) or VARIANCE(X).

Action: Make sure that the required columns are part of the summary definition if incremental refresh capability is desired.

ORA-30453 summary contains AVG without corresponding COUNT

Cause: Incremental refresh of summaries with AVG(X) requires a COUNT(X) column to be included in the summary definition.

Action: Make sure that the required columns are part of the summary definition if incremental refresh capability is desired.

ORA-30454 summary contains STDDEV without corresponding SUM & COUNT

Cause: Incremental refresh of summaries with STDDEV(X) requires COUNT(X) and SUM(X) columns to be included in the summary definition.

Action: Make sure that the required columns are part of the summary definition if incremental refresh capability is desired.

ORA-30455 summary contains VARIANCE without corresponding SUM & COUNT

Cause: Incremental refresh of summaries with VARIANCE(X) requires COUNT(X) and SUM(X) columns to be included in the summary definition.

Action: Make sure that the required columns are part of the summary definition if incremental refresh capability is desired.

ORA-30456 'string.string' cannot be refreshed because of insufficient privilege

Cause: The user lacks one or more permissions that are required in order to refresh summaries.

Action: Make sure that the user is granted all required privileges.

ORA-30457 'string.string' cannot be refreshed because of unmnanaged NOT NULL columns in container

Cause: The container object for the summary contains one or more unmanaged columns do not allow nulls, and which do not specify a default value for those columns.

Action: Make sure that default values are specified for all NOT NULL columns that are not part of the summary definition.

ORA-30458 'string.string' cannot be refreshed because the refresh mask is string

Cause: An attempt was made to incrementally refresh a summary that is not incrementally refreshable.

Action: Do not attempt to incrementally refresh the summary; use full refresh instead.

ORA-30459 'string.string' cannot be refreshed because the refresh method is NONE

Cause: An attempt was made to refresh a summary whose refresh method is NONE.

Action: Summaries whose refresh method is NONE (NEVER REFRESH) cannot be refreshed. Alter the summary to change the default refresh method from NONE to some other value.

ORA-30460 'string.string' cannot be refreshed because it is marked UNUSABLE

Cause: An attempt was made to refresh a summary which is UNUSABLE.

Action: Determine why the summary is UNUSABLE, re-enable it, and retry the refresh.

ORA-30461 'string.string' cannot be refreshed because it is marked DISABLED

Cause: An attempt was made to refresh a summary which is DISABLED.

Action: Determine why the summary is DISABLED, re-enable it, and retry the refresh.

ORA-30462 unsupported operator: string

Cause: An attempt was made to refresh a summary containing an unsupported operator.

Action: Verify that all columns of the summary contain expressions that are refreshable.

ORA-30463 'string' is not a detail table of any summary

Cause: The list of tables passed to REFRESH_DEPENDENT contains at least one invalid table name. That table is not a detail table of any summary and is therefore an invalid input to REFRESH_DEPENDENT.

Action: Verify the correct name of all tables in the list.

ORA-30464 no summaries exist

Cause: A call was made to REFRESH_ALL_MVIEWS, but no summaries exist. At least one summary must exist before calling REFRESH_ALL_MVIEWS.

Action: Create one or more summaries.

ORA-30465 supplied run_id is not valid: string

Cause: There are three possible causes: The specified run_id does not exist; the run_id was created by another user other than the current user; the run_id has already been used.

Action: Call DBMS_OLAP.CREATE_ID to create a new id.

ORA-30466 cannot find the specified workload string

Cause: The specified workload_id is not valid.

Action: Use a valid workload_id or DBMS_OLAP.WORKLOAD_ALL.

ORA-30467 internal data for filter number string is inconsistent

Cause: Users should not explicitly modify summary advisor's internal tables. Such modifications may cause inconsistency in the internal tables and result in this error.

Action: Users can call the DBMS_OLAP.PURGE_FILTER subprogram to remove the inconsistent data from summary advisor's internal tables.

ORA-30475 feature not enabled: string

Cause: The specified feature is not enabled.

Action: Do not attempt to use this feature.

ORA-30476 PLAN_TABLE does not exist in the user's schema

Cause: Estimate_Summary_Size uses Oracle SQL "EXPLAIN PLAN" command to estimate cardinality of the specified select-clause. This requires a table called the PLAN_TABLE in the user's schema. For more information, refer to the Oracle9i SQL Reference.

Action: Create the PLAN_TABLE as described for EXPLAIN PLAN. On most systems a script UTLXPLAN.SQL will create this table.

ORA-30477 The input select_clause is incorrectly specified

Cause: The input select-clause parameter to Estimate_Summary_Size is incorrectly specified and cannot be compiled.

Action: Check the syntax of the select-clause.

ORA-30478 Specified dimension does not exist

Cause: The specified dimension to be verified does not exist.

Action: Check the spelling of the dimension name.

ORA-30479 Summary Advisor errorstring

Cause: An error has occurred in the Summary Advisor package. This message will be followed by a second message giving more details about the nature of the error.

Action: See the Summary Advisor documentation for an explanation of the second error message.

ORA-30480 DISTINCT option not allowed with GROUP BY CUBE or ROLLUP

ORA-30481 GROUPING function only supported with GROUP BY CUBE or ROLLUP

ORA-30483 window functions are not allowed here

Cause: Window functions are allowed only in the SELECT list of a query. A window function cannot be a group function.

ORa-30484 missing window specification for this function

Cause: All window functions should be followed by window specification, like <function>(<argument list>) OVER (<window specification>)

ORA-30485 missing ORDER BY expression in the window specification

Cause: Either the ORDER BY expression is mandatory for this function, or there is an aggregation group without any ORDER by expression.

ORA-30486 invalid window aggregation group in the window specification

Cause: If the window specification is specified using RANGE option and there are multiple ORDER BY expressions, then the aggregation group cannot contain any expression (It can only have CURRENT ROW, UNBOUNDED PRECEDING, or UNBOUNDED FOLLOWING). First end point (bound) cannot be UNBOUNDED FOLLOWING and second end point cannot be UNBOUNDED PRECEDING. If the first end point is CURRENT ROW, then second end point can only be CURRENT ROW or <expr> /UNBOUNDED FOLLOWING. If the first end point is <expr> FOLLOWING, then second end point can only be <expr>/UNBOUNDED FOLLOWING.

ORA-30487 ORDER BY not allowed here

Cause: DISTINCT functions and RATIO_TO_REPORT cannot have an ORDER BY clause.

ORA-30488 argument should be a function of expressions in PARTITION BY

Cause: The argument of the window function should be a constant for a partition.

ORA-30489 Cannot have more than one rollup/cube expression list

Cause: GROUP BY clause has more than one rollup/cube expression list.

Action: Modify the query such that only one rollup/cube expression appears per sub-query.

ORA-30490 Ambiguous expression in GROUP BY ROLLUP or CUBE list

Cause: An expression in the GROUP BY ROLLUP or CUBE list matches an expression in the ordinary GROUP BY expression list.

Action: Remove the expression from either ordinary GROUP BY expression list or ROLLUP or CUBE expression list.

ORA-30493 The percentile value should be a number between 0 and 1.

Cause: A percentile value for PERCENTILE_CONT or PERCENTILE_DISC function is specified out of range.

Action: Specify a value from [0,1].

ORA-30500 database open triggers and server error triggers cannot have BEFORE type

Cause: An attempt was made to create a trigger that fires before the database is open or before server errors, but these types of triggers are not supported.

Action: Do not attempt to create a trigger that fires before the database is open or before server errors.

ORA-30501 instance shutdown triggers cannot have AFTER type

Cause: An attempt was made to create a trigger that fires after an instance shutdown, but this type of trigger is not supported.

Action: Do not attempt to create a trigger that fires after an instance shutdown.

ORA-30502 system triggers cannot have INSERT, UPDATE, or DELETE as triggering events

Cause: An attempt was made to create a system trigger with INSERT, UPDATE, or DELETE triggering events, but this type of trigger is not supported because a system trigger does not have a base table.

Action: Do not attempt to create a system trigger with INSERT, UPDATE, or DELETE triggering events.

ORA-30503 system triggers cannot have a REFERENCING clause

Cause: An attempt was made to use a REFERENCING clause with a system trigger, but this type of trigger is not supported because a system triggers does not have a base table.

Action: Do not use a REFERENCING clause with a system trigger.

ORA-30504 system triggers cannot have a FOR EACH ROW clause

Cause: An attempt was made to use a FOR EACH ROW clause with a system trigger, but this type of trigger is not supported because a system triggers does not have a base table.

Action: Do not use a FOR EACH ROW clause with a system trigger.

ORA-30505 system triggers should not reference a column in a WHEN clause

Cause: An attempt was made to use a WHEN clause to reference a column with a system trigger, but this type of trigger is not supported because a system trigger does not have a base table.

Action: Change the WHEN clause to an appropriate clause.

ORA-30506 system triggers cannot be based on tables or views

Cause: An attempt was made to base a system trigger on a table or a view.

Action: Make sure the type of the trigger is compatible with the base object.

ORA-30507 normal triggers cannot be based on a schema or a database

Cause: An attempt was made to base a normal trigger on a schema or a database, but normal triggers can be based only on tables or views.

Action: Make sure the type of the trigger is compatible with the base object.

ORA-30508 client logon triggers cannot have BEFORE type

Cause: An attempt was made to create a trigger that fires before logon. This type of trigger is not supported.

Action: Do not attempt to create a trigger that fires before logon.

ORA-30509 client logoff triggers cannot have AFTER type

Cause: An attempt was made to create a trigger that fires after logoff. This type of trigger is not supported.

Action: Do not attempt to create a trigger that fires after logoff.

ORA-30510 system triggers cannot be defined on the schema of SYS user

Cause: An attempt was made to define a system trigger on the schema of SYS user. This type of trigger is not supported currently.

Action: Do not attempt to create a system trigger defined on the schema of SYS user.

ORA-30511 invalid DDL operation in system triggers

Cause: An attempt was made to perform an invalid DDL operation in a system trigger. Most DDL operations currently are not supported in system triggers. The only currently supported DDL operations are table operations and ALTER?COMPILE operations.

Action: Remove invalid DDL operations in system triggers.

ORA-30512 cannot modify string.string more than once in a transaction

Cause: An attempt was made to modify an object more than once in a transaction. This error is usually caused by a DDL statement that fires a system trigger that tries to modify the same object. It can also happen when an attempt is made to perform more than one DDL operation on a queue table in the same transaction without issuing a commit between operations.

Action: Do not create system triggers that might modify an already modified object. Also, do not specify more than one DDL operation on a queue table in the same transaction.

ORA-30513 cannot create system triggers of INSTEAD OF type

Cause: Only BEFORE or AFTER triggers can be created on system events.

Action: Change the trigger type to BEFORE or AFTER.

ORA-30514 system trigger cannot modify tablespace being made read only

Cause: A beofre trigger tries to modify a tablespace which is being made READ ONLY as the part of DDL oepration.

Action: Modify the trigger to avoid modifications to the objects in the same tablespace as the one which is being made read only, or use autonomous transactions to commit modifications.

ORA-30515 suspend triggers cannot have BEFORE type

Cause: An attempt was made to create a trigger that fires before execution suspended. This type of trigger is not supported.

Action: Do not attempt to create a trigger that fires before execution suspended.

ORA-30550 index depends on a package/function spec/body which is not valid

Cause: The functional indexes depend on some invalid/non-existent package/function specification/body.

Action: Verify that all the package/functions which the index depends on exist and are valid.

ORA-30551 The index depends on a package/type body which does not exist

Cause: The functional indexes depend on a package/type body which does not exist.

Action: Create the package/type body.

ORA-30552 The package/procedure/function cannot be changed

Cause: The package/procedure/function is deterministic and some object depends on it.

Action: Drop the other object which depends on the package/function/procedure you are trying to change.

ORA-30553 The function is not deterministic

Cause: The function on which the index is defined is not deterministic.

Action: Mark the function deterministic.

ORA-30554 function-based index string.string is disabled

Cause: An attempt was made to access a function-based index that has been marked disabled because the function on which the index depends has been changed.

Action: Perform one of the following actions:

  • drop the specified index using the DROP INDEX command
  • rebuild the specified index using the ALTER INDEX REBUILD command
  • enable the specified index using the ALTER INDEX ENABLE command
  • make the specified index usable using the ALTER INDEX UNUSABLE command

ORA-30555 global index partitioning key is an expression

Cause: An attempt was made to use an expression as a partitioning key in an index.

Action: Do not attempt to use an expression as index partitioning key.

ORA-30556 functional index is defined on the column to be modified

Cause: An ALTER TABLE MODIFY COLUMN was issued on a column on which a functional index exists.

Action: Drop the functional index before attempting to modify the column.

ORA-30557 function based index could not be properly maintained

Cause: The user updated a column on which a function based index is present which was not successfully updated.

Action: Determine the error in updating the index and fix the problem.

ORA-30558 internal error [string] in function based index

Cause: This is an internal error.

Action: Contact Oracle Support Services with the exact error text.

ORA-30560 SAMPLE option not allowed with index-organized tables

ORA-30561 SAMPLE option not allowed in statement with multiple table references

ORA-30562 SAMPLE percentage must be in the range [0.000001,100)

ORA-30563 outer join operator (+) not allowed in select-list

Cause: An attempt was made to reference (+) in select-list.

Action: Do not use the operator in select-list.

ORA-30564 Index maintainence clause not allowed for ADD partition to RANGE partitioned tables

Cause: The clause INVALIDATE or UPDATE GLOBAL INDEXES is allowed only for ADD partition to a HASH partitioned table or ADD subpartition to a composite partitioned table.

Action: Remove the clause and reissue the operation.

ORA-30565 Only one INVALIDATE or UPDATE GLOBAL INDEXES clause may be specified

Cause: The clause INVALIDATE or UPDATE GLOBAL INDEXES was specified more than once.

Action: Remove all but one of the INVALIDATE or UPDATE GLOBAL INDEXES clauses and reissue the statement.

ORA-30566 Index maintainence clause not allowed for this command

Cause: The clause INVALIDATE or UPDATE GLOBAL INDEXES is not allowed for this command.

Action: Remove the clause and reissue the operation.

ORA-30567 name already used by an existing log group

Cause: The specified log group name has to be unique.

Action: Specify a unique name for the log group. The name cannot be the same as any other log group, constraint, or cluster hash expression.

ORA-30568 cannot drop log group - nonexistent log group

Cause: The <log_group_name> specified in alter table drop log group is incorrect or nonexistent.

Action: Reenter the statement using the correct log group name.

ORA-30569 data type of given column is not supported in a log group

Cause: An attempt was made to include a column with one of these unsupported data types: LONG, VARRAY, nested table, object, LOB, FILE, or REF in a log group.

Action: Change the column data type or remove the log group. Retry the operation.

ORA-30570 SEGMENT SPACE MANAGEMENT option already specified

Cause: In CREATE TABLESPACE, the SEGMENT SPACE MANAGEMENT option was specified more than once.

Action: Remove all but one of the SEGMENT SPACE MANAGEMENT specifications.

ORA-30571 invalid SEGMENT SPACE MANAGEMENT clause

Cause: An invalid option appears for SEGMENT SPACE MANAGEMENT clause.

Action: Specify one of the valid options:

  • AUTO
  • MANUAL

ORA-30572 AUTO segment space management not valid with DICTIONARY extent management

Cause: In CREATE TABLESPACE, the AUTO SEGMENT SPACE MANAGEMENT was used with a DICTIONARY extent management clause.

Action: Either specify LOCAL extent management or remove the AUTO SEGMENT SPACE MANAGEMENT specification.

ORA-30573 AUTO segment space management not valid for this type of tablespace

Cause: In CREATE TABLESPACE, the AUTO SEGMENT SPACE MANAGEMENT was used while creating an UNDO or TEMPORARY tablespace.

Action: Remove the AUTO SEGMENT SPACE MANAGEMENT clause.

ORA-30574 Cannot create rollback segment in tablespace with AUTO segment space management

Cause: A rollback segment is being created in a tablespace that was created with AUTO segment space management.

Action: Create the rollback segment in a different tablespace.

ORA-30575 ConText Option not installed

Cause: Oracle executable does not have ConText Option linked in.

Action: Get the correct version of Oracle.

ORA-30576 ConText Option dictionary loading error

Cause: ConText dictionary tables may be corrupted. This is an internal error.

Action: Contact Oracle Support Services.

ORA-30625 method dispatch on NULL SELF argument is disallowed

Cause: A member method of a type is being invoked with a NULL SELF argument.

Action: Change the method invocation to pass in a valid self argument.

ORA-30645 reject limit out of range

Cause: Reject limit specifies the number of records rejected before terminating a table scan. The range is either a number between 1..100000 or UNLIMITED if no limit is intended.

Action: Change the token representing the reject limit to either a number in the range of 0 and 100000 or the keyword UNLIMITED.

ORA-30646 schema for external table type must be SYS

Cause: A schema other then SYS was specified for the TYPE.

Action: For this version of the oracle server, always use schema name SYS.

ORA-30647 error retrieving access parameters for external table string.string

Cause: an error occurred when fetching the access parameters for the specified external table.

Action: If the access parameter is a query which returns a CLOB, check EXTERNAL_TAB$ to make sure the query is correct.

ORA-30649 missing DIRECTORY keyword

Cause: DEFAULT DIRECTORY clause missing or incorrect.

Action: Provide the DEFAULT DIRECTORY.

ORA-30653 reject limit reached

Cause: The reject limit has been reached.

Action: Either cleanse the data, or increase the reject limit.

ORA-30654 missing DEFAULT keyword

Cause: DEFAULT DIRECTORY clause not specified or incorrect.

Action: Provide the DEFAULT DIRECTORY.

ORA-30655 cannot select FOR UPDATE from external organized table

Cause: A select for update on an external table was attempted.

Action: Do not select for update on an external table.

ORA-30656 column type not supported on external organized table

Cause: An attempt was made to create an external organized table with a column of type LONG, LOB, BFILE, ADT, or VARRAY.

Action: These column types are not supported, change the DDL.

ORA-30657 operation not supported on external organized table

Cause: User attempted on operation on an external table which is not supported.

Action: Do not attempt the operation.

ORA-30658 attempt was made to create a temporary table with EXTERNAL organization

Cause: An attempt was made to create an External Organized Temporary table. This is not supported.

Action: Do not attempt to create External Organized Temporary tables.

ORA-30676 socket read or write failed

Cause: A problem kept a socket from reading or writing the expected amount of data. More specific information is not available.

Action: Try re-establishing a connection. You may need to restart whatever program is at the other end of the socket that failed, or you may need to have some problem on your network fixed.

ORA-30677 session is already connected to a debugger

Cause: An attempt to connect a session to a debugger could not proceed because the session is already connected to some debugger.

Action: Either use the option to force a connection or first disconnect the session from it's existing debugger.

ORA-30678 too many open connections

Cause: An attempt to open a connection failed because too many are already open by this session. The number of allowed connections varies as some may be in use through other components which share the same pool of allowed connections.

Action: Retry after closing some other connection. The number of connections supported is currently not adjustable.

ORA-30679 JDWP-based debugging not supported in this configuration

Cause: An attempt to open a debugging connection failed because this server configuration cannot support the required asynchronous socket traffic detection.

Action: This feature will not work under this server configuration. Either the feature is not supported on this platform at all, or is available only through use of a protocol=tcp dispatcher in shared-server configurations. Please consult the platform-specific documentation and "readme" material.

ORA-30680 debugger connection handshake failed

Cause: A problem occurred when trying to establish a debugger connection. This might indicate that the port specified as the location of the debugger is actually being used by some other type of application.

Action: Correct the host or port specifications if they are incorrect, and verify that the debugger is properly waiting for a connection.

ORA-30681 improper value for argument EXTENSIONS_CMD_SET

Cause: An improper parameter value was provided in a call to DBMS_DEBUG_JDWP.CONNECT_TCP.

Action: Correct the indicated parameter value and try again.

ORA-30682 improper value for argument OPTION_FLAGS

Cause: An improper parameter value was provided in a call to DBMS_DEBUG_JDWP.CONNECT_TCP.

Action: Correct the indicated parameter value and try again.

ORA-30683 failure establishing connection to debugger

Cause: An error was indicated when trying to establish a connection to a debugger. Usually a TNS error will display along with this message to further explain the problem, although this TNS error will likely be hidden if you choose to trap the error.

Action: Correct the indicated parameter value and try again.

ORA-30684 specified role could not be enabled

Cause: The role specified for use by the debugger could not be enabled. The role may not exist or may not be granted to this user, the password specified may be incorrect, or the authenticating routine for the role is not currently active.

Action: Correct or remove the role or password argument in the debugger connection request.

ORA-30685 versions of DBMS_DEBUG_JDWP and Oracle are inconsistent

Cause: The installed version of the DBMS_DEBUG_JDWP package is not compatible with the release of Oracle that is being used.

Action: Install the correct version of the DBMS_DEBUG_JDWP package.

ORA-30686 no dispatcher accepted TCP/IP connection request

Cause: rather than a dispatcher. When this occurs, shared servers are less beneficial because the session that owns the socket cannot relinquish the process until the socket is closed. The most likely cause is that no dispatcher is configured for protocol=tcp.

Action: To improve the scalability of your configuration, configure a dispatcher for protocol=tcp. To route these particular connections through a particular set of dispatchers, you can specify presentation=kgas. However, if you haven't done so, any protocol=tcp dispatcher will be used.

ORA-30687 session terminated by debugger

Cause: Your program's execution has been stopped by the debugger. This can occur because of an explicit request to do so sent by the debugger, or because the debugger disconnected without first telling Oracle to let your program continue to run after the disconnection. To stop your program completely, Oracle needs to fully terminate the process.

Action: This is in response to a debugger request; it is not an error. No action required.

ORA-30688 maximum program calling depth exceeded

Cause: Your program contains a set of calls that are too deep to be handled. Only transitions between the different execution engines (SQL, PL/SQL, and Java) count in reaching this limit; calls within the same engine don't count.

Action: Restructure your program so as to not call so deeply. Perhaps some recursion can be replaced with iteration.

ORA-30689 improper value for ORA_DEBUG_JDWP

Cause: An improper value was used for ORA_DEBUG_JDWP when trying to establish a connection to a debugger. The value either did not conform to the format of ORA_DEBUG_JDWP or was too long.

Action: Correct the value for ORA_DEBUG_JDWP and try again.

ORA-30690 timeout occurred while registering a TCP/IP connection for data traffic detection

Cause: A timeout occurred while registering a TCP/IP connection for data traffic detection.

Action: Retry the operation later.

ORA-30691 failed to allocate system resources while registering a TCP/IP connection for data traffic detection

Cause: System resources ran out while registering a TCP/IP connection for data traffic detection.

Action: Retry the operation later.

ORA-30695 JDWP message format problem

Cause: A message passed from one software subcomponent to another using the JDWP protocol appears invalidly formatted.

Action: This is an internal error. Contact Oracle Support Services.

ORA-30725 JDWP-based debugging is not yet available

Cause: This feature is not yet available for use.

Action: Please wait for a future release.

ORA-30726 cannot specify referenced column list here

Cause: An attempt was made to specify a referenced column list for a referential constraint involving a REF column.

Action: Remove the referenced column list specification.

ORA-30727 duplicate referential constraint for a REF column

Cause: Multiple referential constraints were specified for a single REF column.

Action: Remove the duplicate referential constraint and retry the operation.

ORA-30728 maximum number of columns exceeded

Cause: Adding referential constraint on a REF column requires the creation of an additional column.

Action: Drop some columns and retry the operation.

ORA-30729 maximum number of columns exceeded

Cause: Adding scope or referential constraint on a REF column requires the creation of additional columns if the target table's object identifier is primary key based.

Action: Drop some columns and retry the operation.

ORA-30730 referential constraint not allowed on nested table column

Cause: An attempt was made to define a referential constraint on a nested table column.

Action: Do not specify referential constraints on nested table columns.

ORA-30731 scope constraint not allowed on nested table column when the nested table is being created

Cause: An attempt was made to define a scope constraint on a nested table column when the nested table is being created.

Action: Do not specify a scope constraint on a nested table column when creating it. Instead, specify it using the ALTER TABLE statement.

ORA-30732 table contains no user-visible columns

Cause: An attempt was made to query on a system table which has no user-visible columns.

Action: Do not query on a system table that has no user-visible columns.

ORA-30733 cannot specify rowid constraint on scoped ref column

Cause: An attempt was made to specify ROWID constraint on a scoped REF column.

Action: Remove the ROWID constraint and then retry the operation.

ORA-30734 cannot specify scope constraint on ref column with rowid

Cause: An attempt was made to specify scope constraint on a REF column with the ROWID constraint.

Action: Remove the scope constraint and then retry the operation.

ORA-30735 cannot create multiple subtables of the same type under a supertable

Cause: An attempt was made to create under a supertable (superview), a subtable(subview) of the same type as another existing subtable (subview).

Action: Drop the existing subtable(subview) and retry the operation.

ORA-30736 objects in a table or view hierarchy have to be in the same schema

Cause: An attempt was made to create a subtable(subview) under a supertable(superview) located in another schema.

Action: Connect as schema owner of the superobject and retry the operation.

ORA-30737 cannot create subtable of a type which is not a subtype of the type of the supertable

Cause: An attempt was made to create a subtable(subview) of a type which is not a subtype of the type of the super object.

Action: Change the type of the subtable to be a subtype of the superobject's type and then retry the operation.

ORA-30738 object "string" does not exist in schema "string"

Cause: The specified object does not exist.

Action: Ensure that the specified object exists and retry the operation.

ORA-30739 cannot drop a table that has subtables

Cause: The user tried to drop a table that has subtables defined under it.

Action: Drop all subtables before trying this operation.

ORA-30740 cannot grant UNDER privilege on this object

Cause: The user tried to grant UNDER privilege on an object that is not one of the following : non final object type, object table of non final type, object view of non final type.

Action: Ensure that the UNDER privilege is granted on a valid object.

ORA-30741 WITH HIERARCHY OPTION can be specified only for SELECT privilege

Cause: The user tried to specify WITH HIERARCHY OPTION for a privilege other than SELECT privilege.

Action: Ensure that the HIERARCHY OPTION is specified only with the SELECT privilege.

ORA-30742 cannot grant SELECT privilege WITH HIERARCHY OPTION on this object

Cause: The user tried to grant SELECT privilege WITH HIERARCHY OPTION on an object that is not one of the following : object table of non final type or object view of non final type.

Action: Ensure that the SELECT privilege WITH HIERARCHY OPTION is granted on a valid object.

ORA-30743 "string" is not an object view

Cause: The specified object is not an object view.

Action: Specify an object view and retry the operation.

ORA-30744 "string" is not an object table

Cause: The specified object is not an object table.

Action: Specify an object table and retry the operation.

ORA-30745 error occurred while trying to add column "string" in table "string"

Cause: The user tried to add a subtype which tried to alter the tables dependent on the supertype.

Action: Ensure that the table will not exceed the columnlimit on adding this subtype.

ORA-30746 error occurred while trying to drop column "string" in table "string"

Cause: The user tried to drop a subtype with VALIDATE option which tried to check for stored instances of the type in the stated table.

Action: Delete all instances of this subtype and then drop the type.

ORA-30747 cannot create substitutable tables or columns of non final type string.string

Cause: The user tried to create substitutable table or column of a non final type. This operation is not currently supported.

Action: Change the statement to create a non substitutable table/column.

ORA-30748 column string already enabled to store objects of type string.string

Cause: The user is trying to enable a column to store instances of a type for which it is already enabled.

Action: No action required.

ORA-30749 column string not enabled to store objects of type string.string

Cause: The user is trying to disable a column from storing instances of a type for which it is already enabled.

Action: No action required.

ORA-30750 cannot enable column string to store objects of type string.string

Cause: The user is trying to enable a column to store instances of a subtype. The error is raised due to one of the following:

Action: Fix the cause of the error and retry the operation.

ORA-30751 cannot disable column string from storing objects of type string.string

Cause: The user is trying to drop a type from being stored in a substitutable column or table. This error is raised due to one of the following reasons :

  • the column is enabled to store instances of some subtype of the type being dropped.
  • the column is enabled to store instances of only one type.

Action: Fix the cause of the error and retry the operation.

ORA-30752 column or table string is not substitutable

Cause: The user is performing an operation that is not allowed on non substitutable column or table.

Action: No action required.

ORA-30753 column or table string is substitutable

Cause: The user is performing an operation that is not allowed on a substitutable column or table.

Action: No action required.

ORA-30754 column or table string stores objects of only one type

Cause: The user is trying to perform an operation that is not allowed on an object column or table that is enabled to store instances of a single type.

Action: No action required.

ORA-30755 error during expansion of view hierarchy

Cause: There was an error while trying to expand a view hierarchy. This could be due to invalid subviews (or subviews with errors).

Action: Ensure that all subviews are valid. For example alter view ... compile and retry the operation.

ORA-30756 cannot create column or table of type that contains a supertype attribute

Cause: The user tried to create a column or table of an object type that contains a supertype attribute. This is not supported because it leads to infinite recursion in the current storage model. Note that creating a column of a type implies that we create columns corresponding to all subtype attributes as well.

Action: Change the type definition to contain a supertype REF attribute instead of the supertype object attribute.

ORA-30757 cannot access type information

Cause: Either a subtype was created and operations performed with this new type while the session was in progress, or the type information was unpinned from the object cache.

Action: Commit necessary changes, end the user session, reconnect again and re-try the object operations. If the problem persists, then contact Oracle Support Services.

ORA-30765 cannot modify scope for an unscoped REF column

Cause: An attempt was made to modify the scope for an unscoped REF column.

Action: Use an ALTER TABLE ADD SCOPE FOR command instead.

ORA-30766 cannot modify scope for a REF column with a REFERENCES constraint

Cause: An attempt was made to modify the scope for a REF column with a REFERENCES constraint.

Action: Drop the REFERENCES constraint, and retry the operation.

ORA-30767 OID type mismatch

Cause: An attempt was made to modify the scope for a REF column to a table whose object identifier's type is different from that of the original scoped table.

ORA-30768 Cannot evaluate pipelined function

Cause: Pipelined functions can only be used in a TABLE expression in the FROM clause.

Action: Use a non-pipelined function instead.

ORA-30770 Cannot specify storage options for fixed size opaque type

Cause: Storage clause was specified during table creation for a fixed size opaque type.

Action: Do not provide storage option clause.

ORA-30771 Cannot add more than one referential constraint on REF column "string"

Cause: Multiple referential constraints were specified for a single REF column.

Action: Remove the additional referential constraints and retry the operation.

ORA-30772 opaque types do not have default constructors

Cause: Constructor invocation did not succeed, since no user-defined constructors were defined for the opaque type, and since opaque types do not have default constructors.

Action: Add user-defined constructors to opaque type, or specify a member or static method for the opaque type.

ORA-30926 unable to get a stable set of rows in the source tables

Cause: A stable set of rows could not be got because of a large amount of DML activity or a non-deterministic where clause.

Action: Remove any non-deterministic where clauses and reissue the DML.

ORA-30927 Unable to complete execution due to failure in temporary table transformation

Cause: In memory temporary tables we create are aged out of shared pool before we are able to grab them again.

Action: Reduce activities that use a lot of shared pool space or wait for a while, then retry.

ORA-30928 Connect by filtering phase runs out of temp tablespace

Cause: It is probably caused by the fact that there is a loop in the data.

Action: Retry the query with the NO_FILTERING hint. If the same error still occurs, then increase temp tablespace.

ORA-30929 ORDER SIBLINGS BY clause not allowed here

Cause: ORDER SIBLINGS BY clause is specified in a query which doesn't have CONNECT BY clause.

Action: Remove ORDER SIBLINGS BY clause or add CONNECT BY clause.

ORA-31000 Resource 'string' is not an XDB schema document

Cause: The given schema URL does not refer to a registered XDB schema.

Action: Make sure the specified schema has been registered in XDB.

ORA-31001 Invalid resource handle or path name "string"

Cause: An invalid resource handle or path name was passed to the XDB hierarchical resolver.

Action: Pass a valid resource handle or path name to the hierarchical resolver.

ORA-31002 Path name string is not a container

Cause: XDB expected the given path name to represent a container.

Action: Pass a path name or resource handle that represents a container.

ORA-31003 Parent string already contains child entry string

Cause: An attempt was made to insert a duplicate child into the XDB hierarchical resolver.

Action: Insert a unique name into the container.

ORA-31004 Length string of the BLOB in XDB$H_INDEX is below the minimum string

Cause: In the XDB$H_INDEX table, the CHILDREN column, a BLOB, must have a certain minimum length without being chained. The calculated length of the LOB was less than the stated minimum.

Action: Set the value of the DB_BLOCK_SIZE initialization parameter to at least 2 KB. For XDB to run at its fastest, set DB_BLOCK_SIZE to 8 KB.

ORA-31005 Path name length string exceeds maximum length string

Cause: The length of a path name passed to the XDB hierarchical resolver exceeded the maximum length.

Action: Choose a shorter path name.

ORA-31006 Path name segment length string exceeds maximum length string

Cause: The length of a path name segment passed to the XDB hierarchical resolver exceeded the maximum length of a path name segment.

Action: Choose a shorter path name segment.

ORA-31007 Attempted to delete non-empty container string/string

Cause: An attempt was made to delete a non-empty container in the XDB hierarchical resolver.

Action: Either perform a recursive deletion or first delete the contents of the container.

ORA-31008 stream error in XDB, error code [string], stream type [string]

Cause: A stream error occurred in XDB.

ORA-31010 XML element index string exceeds maximum insertion index string

Cause: An attempt was made to insert an XML element at an invalid index location in the node.

Action: Choose a new index that falls within the allowed range.

ORA-31011 XML parsing failed

Cause: The XML parser returned an error while trying to parse the document.

Action: Check if the document to be parsed is valid.

ORA-31012 Given XPATH expression not supported

Cause: XPATH expression passed to the function is currently unsupported.

Action: Check the xpath expression and change it to use a supported expression.

ORA-31013 Invalid XPATH expression

Cause: XPATH expression passed to the function is invalid.

Action: Check the xpath expression for possible syntax errors.

ORA-31014 Attempted to delete the root container

Cause: An attempt was made to delete the root container in the hierarchical index.

Action: Do not delete the root container.

ORA-31015 Attempted to insert entry without name

Cause: An attempt was made to insert an entry into the hierarchical resolver without a child name.

Action: Supply a child name and try inserting again.

ORA-31016 Attempted to delete entry without name

Cause: An attempt was made to delete an entry from the hierarchical resolver without a child name.

Action: Supply a child name and try deleting again.

ORA-31017 Error generating unique OID for XML document

Cause: An error occurred while generating a globally unique OID for storing an XML document.

ORA-31018 Error deleting XML document

Cause: The XMLType object pointed to by the given REF could not be deleted because either the REF was invalid or it pointed to a non-existent table.

Action: Either use FORCE deletion or supply a valid REF.

ORA-31019 Recursive deletion snapshot too old for string/string

Cause: Changes were made to the structure of a directory while it was being recursively deleted.

Action: Try deleting the directory again.

ORA-31020 The operation is not allowed, Reason: string

Cause: The attempted operation is not allowed.

Action: See reason and change to a valid operation.

ORA-31021 Element definition not found

Cause: The element definition was not found.

Action: Supply the definition for the element or use a defined element.

ORA-31022 Element not found

Cause: The element was not found.

Action: Make sure the specified element exists.

ORA-31023 Index size error

Cause: The index is greater than the allowed value.

Action: Make sure the index is less than the allowed value.

ORA-31024 Exceeded maximum number string of XML node elements

Cause: An attempt was made to insert more than the allowed number of elements into an XML document node.

Action: Do not attempt to add more than the maximum number of elements to XML document nodes that maintain order.

ORA-31025 Invalid document element

Cause: An attempt was made to replace the data at an invalid index number in the XML document.

Action: Supply a correct occurrence number and try again.

ORA-31026 XML maxoccurs value string exceeded

Cause: An attempt was made to insert more than maxoccurs values into a schema-based XML document.

Action: Do not insert more than maxoccurs values into the document.

ORA-31027 Path name or handle string does not point to a resource

Cause: An attempt was made to retrieve a resource based on a path name or resource handle that points to an entity other than a resource.

Action: Do not attempt to retrieve a resource based on that path name or resource handle.

ORA-31028 XML node string has length string, exceeding maximum string

Cause: An attempt was made to store an XML text or attribute node whose length exceeded the maximum specified by the XML schema.

Action: Shorten the data so that it conforms to its XML schema definition.

ORA-31029 Cannot bind to unsaved resource

Cause: An attempt was made to bind to a resource that had not been saved to disk.

Action: Bind only to saved resources.

ORA-31030 Unable to retrieve XML document

Cause: The resource had an invalid (dangling) REF to an XML document.

Action: Rebind the resource using a valid XMLType REF.

ORA-31031 Cannot insert non-schema data into unordered XML nodes

Cause: An attempt was made to insert non-schema-based XML data (for example, such as a comment or processing instruction) into an XML node that did not maintain ordering.

Action: In the schema, define the element with maintainOrder=true in order to add non-schema data.

ORA-31032 XML element index string out-of-range for string-element node

Cause: An attempt was made to access an out-of-range element in an XML document node.

Action: Access data only at indexes that do not exceed the maximum value.

ORA-31033 Requested number of XML children string exceeds maximum string

Cause: An attempt was made to add more than the maximum number of allowable children in an XML element.

Action: Redefine the schema to allow breaking up of the children among siblings.

ORA-31034 Could not delete at index string in a string-element node

Cause: An attempt was made to delete an XML element at an index that exceeds the node's total number of elements.

Action: Delete data only at valid indexes.

ORA-31035 Could not bind locked resource to path string/string

Cause: An attempt was made to bind an existing resource to a new location in the hierarchy, but a lock could not be obtained on the resource.

Action: Commit or roll back the transaction that has the lock on the resource.

ORA-31036 Cannot store an XML prefix without an associated namespace

Cause: An attempt was made to store an XML prefix without supplying the namespace to which it should be associated.

Action: Store prefixes only with their associated namespaces.

ORA-31037 Invalid XML attribute name string

Cause: The attribute name in the XML document did not match anything in the associated schema.

Action: Supply only schema-defined or XML standard attributes.

ORA-31038 Invalid string value string

Cause: The text in the XML document did not represent a valid value given the datatype and other constraints in the schema.

Action: Ensure that the specified value in XML documents is valid with respect to the datatype and other constraints in the schema.

ORA-31039 XML namespace length string exceeds maximum string

Cause: The length of the disk-formatted XML namespace exceeded the maximum.

Action: Keep XML namespace declarations below the maximum length.

ORA-31040 Property string: XML type (string) not compatible with internal memory type (string)

Cause: The XML datatype given is inconsistent with the database datatype and a conversion cannot be made.

Action: This is an internal error, generally resulting from corruption of the compiled XML schema. Re-register schemas or contact Oracle Support Services.

ORA-31041 Property string: Memory type (string) not compatible with database type (string)

Cause: The memory type associated with this property is mapped to an incompatible database type and a conversion cannot be made.

Action: This is an internal error, generally resulting from corruption of the compiled XML schema. Re-register schemas or contact Oracle Support Services.

ORA-31042 Too many properties in type 'string'

Cause: The type can only have the same number of properties (elements and attributes) as a table can have columns.

Action: Modify the XML schema to move properties into subelements that are not inlined.

ORA-31043 Element 'string' not globally defined in schema 'string'

Cause: The specified element name has not been defined at the top level of the XML schema (that is, globally). Elements must be defined globally to be the root of an XMLType object.

Action: Check the XML schema definition to make sure the specified element name has been defined at the top level.

ORA-31044 Top-level prefix length string exceeds maximum string

Cause: An attempt was made to save to disk a top-level XML namespace prefix whose length exceeded the maximum.

Action: Do not define XML namespace prefixes that exceed the maximum length.

ORA-31045 Cannot store more than string extras outside the root XML node

Cause: An attempt was made to store more than the maximum number of XML extras (for example, such as comments and processing instructions) either before or after the document's root node.

Action: Keep the number of extras outside the root node below the maximum.

ORA-31046 Incorrect argument(s) specified in the operator

Cause: One or more of the arguments specified in the operator in the query are incorrect.

Action: Correct the arguments specified in the operator.

ORA-31047 Could not retrieve resource data at path string

Cause: An error occurred while retrieving the contents of a resource, the metadata of a resource, or both.

Action: Contact Oracle Support Services.

ORA-31048 Unsaved resources cannot be updated

Cause: An attempt was made to update a resource that was never saved to disk.

Action: Perform a resource insertion instead.

ORA-31050 Access denied

Cause: The requested access privileges have not been granted to the current user. Users must be granted privileges prior to resource access.

Action: Check the set of requested access privileges to make sure that they are included in the set of access privileges granted to the user.

ORA-31051 Requested access privileges not supported

Cause: The requested access privileges are not supported for the specified resource.

Action: Ensure that the set of requested access privileges are valid access privileges for the specified resource.

ORA-31052 Cannot delete ACL with other references

Cause: The requested deletion of an ACL resource cannot proceed. The ACL is in use by other resources.

Action: Remove the resources that are making reference to the ACL in question and try again.

ORA-31053 The value of the depth argument in the operator cannot be negative

Cause: The value of the depth argument passed to the primary operator was not a positive integer.

Action: Pass a positive value in the depth argument.

ORA-31054 The string operator cannot have an ancillary operator

Cause: An ancillary operator was used with an operator which does not support ancillary operators.

Action: Remove the ancillary operator in the query.

ORA-31055 A null XMLType element cannot be inserted into RESOURCE_VIEW

Cause: The element which is being inserted into the RESOURCE_VIEW is NULL.

Action: Specify a non-null XMLType element to insert into RESOURCE_VIEW.

ORA-31056 The document being inserted does not conform to Resource Schema

Cause: The XMLType element being inserted into the RESOURCE_VIEW does not conform to the Resource Schema.

Action: Insert an element which conforms to the Resource Schema.

ORA-31057 Display Name of the element being inserted is null

Cause: The Display Name of the element which is being inserted into the RESOURCE_VIEW is null.

Action: Specify the Display Name and insert the element into RESOURCE_VIEW.

ORA-31058 cannot modify read-only XOBs

Cause: Read-Only XOBs cannot be modified.

Action: Use only read operations on such a XOB.

ORA-31059 Cannot insert root XML document node if it already exists

Cause: An attempt was made to insert a root node into an XML document that already had a root node.

Action: Call the appropriate replace function to replace the node instead of inserting it anew.

ORA-31060 Resource at path string could not be deleted

Cause: An error occurred while deleting the named resource. The specific error can be found one lower on the error stack.

Action: Look at the next error on the stack and take approprate action.

ORA-31062 Cannot delete an unsaved resource

Cause: An attempt was made to delete a resource that has not been saved to disk.

Action: Delete only saved resources.

ORA-31065 Cannot modify read-only property [string]

Cause: An attempt was made to modify an immutable XML node.

Action: Use only read operations on such properties.

ORA-31066 Insertion of string into string creates a cycle

Cause: An attempt was made to insert a link into the XDB hierarchy that would create a cycle in the tree.

Action: Ensure that links to existing resources do not cause cycles.

ORA-31067 XML nodes must be updated with nodes of the same type

Cause: An attempt was made to use updateXML to update an XML node with a node of another type.

Action: Ensure that the node specified by the XPath matches the type of the new data provided.

ORA-31068 updateXML expected data format [string] instead of [string]

Cause: An attempt was made to use updateXML to update data with a node of the incorrect type. Text and attribute nodes must be updated with string data, whereas element nodes must be updated with XMLType data.

Action: Use CREATEXML or getStringVal to coerce the new data to the proper format.

ORA-31069 Cannot apply typed changes to non-schema-based XMLType nodes

Cause: An attempt was made to insert, delete, or update a non-schema-based XMLType node using an XML schema definition.

Action: Make changes to non-typed nodes only by referencing their tag names.

ORA-31070 Invalid database user ID string

Cause: An attempt was made to set an invalid user ID into an XDB resource metadata property.

Action: Verify the validity of the user ID and try again.

ORA-31071 Invalid database username or GUID string

Cause: An attempt was made to set an invalid username or GUID into an XDB resource metadata property.

Action: Verify the validity of the username or GUID and try again.

ORA-31072 Too many child nodes in XMLType fragment for updateXML

Cause: An attempt was made to pass an XMLType fragment with multiple children as new data for the updateXML operator.

Action: Extract the desired child from the XMLType before passing it to updateXML as the desired new XML node.

ORA-31073 Resource not retrieved using path name

Cause: An attempt was made to access the path name of a resource that was either never saved to disk or was loaded using a method other than with its path name.

Action: Perform path name operations only on resources obtained using a path name.

ORA-31075 invalid string declaration in XML Schema

Cause: The XML schema contains an invalid declaration identified by the message.

Action: Fix the identified error and try again.

ORA-31076 required attribute "string" not specified

Cause: The XML schema does not specify a required attribute.

Action: Specify a value for the required attribute.

ORA-31077 invalid attribute "string" specified

Cause: The XML schema specifies an invalid attribute.

Action: Remove the specification of the invalid attribute.

ORA-31078 error in SQL mapping information

Cause: There is an error in the SQL type and table specification within the XML Schema.

Action: Ensure that all specified SQL types and tables are valid and compatible with the corresponding XML types.

ORA-31079 unable to resolve reference to string "string"

Cause: The identified type, attribute, or element could not be resolved.

Action: Make sure that the name corresponds to a valid XML (simple/complex) type or attribute or element and try again.

ORA-31080 type not specified for attribute or element "string"

Cause: The identified attribute or element does not have a type.

Action: Make sure that every attribute and element has a valid type specification.

ORA-31081 name not specified for global declaration

Cause: The XML schema does not specify the name for the global declaration of attribute, element, simpleType, or complexType.

Action: Specify names for all global declarations.

ORA-31082 invalid attribute "string" specified in declaration of "string"

Cause: The XML schema specifies an invalid attribute.

Action: Remove the specification of the invalid attribute.

ORA-31083 error while creating SQL type "string"."string"

Cause: An error occurred while trying to create the SQL type based on the specification of a complex type.

Action: Fix the identified error and try again.

ORA-31084 error while creating table "string"."string" for element "string"

Cause: An error occurred while trying to create the table based on the declaration of the identified element.

Action: Fix the identified error and try again.

ORA-31085 schema "string" already registered

Cause: An attempt was made to register a schema with the same URL as a previously registered schema.

Action: Register the schema with a different URL.

ORA-31086 insufficient privileges to register global schema "string"

Cause: An attempt was made to register a global schema without sufficient privileges.

Action: Make sure that the user has sufficient privileges to register a global schema.

ORA-31087 insufficient privileges to delete schema "string"

Cause: An attempt was made to delete a schema resource without sufficient privileges.

Action: Make sure that the user has sufficient privileges to delete the schema.

ORA-31088 object "string"."string" depends on the schema

Cause: An attempt was made to delete a schema which has dependent objects.

Action: Either drop the dependent objects prior to deleting the schema or use the CASCADE or FORCE options.

ORA-31089 schema "string" does not target namespace "string"

Cause: The schema document contains references (through include and import definitions) to other schemas that do not belong to valid namespaces.

Action: Make sure that all schemas referenced through include definitions target the same namespace as the parent schema. Further more, make sure that the namespace specified in the import definition matches the actual target namespace of the specified schema.

ORA-31090 invalid database schema name "string"

Cause: The XML schema document contains an invalid database schema name For example, the value of attribute SQLSchema.

Action: Make sure that all database user/schema names specified in the XML schema document refer to existing database users/schemas.

ORA-31091 empty string specified as a SQL name

Cause: The XML schema document contains a null SQL name. For example, the values of attributes SQLName, SQLType, defaultTable.

Action: Make sure that all names of SQL schema objects specified in the XML schema document are valid SQL names. Otherwise, remove such attributes from the schema and try again.

ORA-31092 invalid SQL name "string"

Cause: The XML schema document contains an invalid SQL name. For example, the values of attributes SQLName, SQLType, defaultTable.

Action: Make sure that all names of SQL schema objects specified in the XML schema document are valid SQL names. This implies that the database length and other restrictions on names be satisfied.

ORA-31093 null or invalid value specified for parameter : string

Cause: The argument value passed for the given parameter is null or invalid.

Action: Make sure that all the input argument values are valid.

ORA-31094 incompatible SQL type "string" for attribute or element "string"

Cause: The SQL type information provided in the XML schema is not compatible with the XML datatype for the specified attribute or element.

Action: Make sure that the specified SQL types are compatible with the declared XML datatypes.

ORA-31095 cannot generate string : "string.string" already exists

Cause: The type/table name specified in the XML schema document cannot be generated because it is already being used.

Action: Use different names for types/tables or use the NOGEN mode so that schema compiler does not generate new types/tables.

ORA-31096 validation failed for schema

Cause: The XML Schema could not be validated.

Action: Make sure that the SQLType and other datatype mapping is valid.

ORA-31097 Hierarchical Index not empty

Cause: An attempt was made to rebuild the hierarchical index which is not empty.

Action: Delete all rows in the hierarchical index and then rebuild it.

ORA-31099 XDB Security Internal Error

Cause: An XDB Security internal error has occurred.

Action: Contact Oracle Support Services.

ORA-31100 XDB Locking Internal Error

Cause: An XDB Locking Internal error has occurred.

Action: Contact Oracle Support Services.

ORA-31101 Token "string" not given while locking resource "string"

Cause: Locking attempted on resource when the principal already owns a lock given by the token above.

Action: Reattempt the lock with the token.

ORA-31102 Already locked in exclusive mode. Cannot add lock.

Cause: The resource is already locked in exclusive mode. Cannot add another lock.

Action: Unlock the existing lock.

ORA-31103 Resource locked in shared mode. Cannot add exclusive lock.

Cause: The resource is locked in shared mode. Cannot add a shared lock.

Action: Try locking in shared mode or unlocking the existing lock.

ORA-31104 Cannot find lock with token "string" on "string" for unlock

Cause: The lock may have been unlocked or it may have expired.

Action: No action required. Unlock already successful.

ORA-31105 User does not own lock "string"

Cause: The lock to be unlocked is not owned by the user.

ORA-31106 Action failed as the parent container is locked

Action: Supply the lock token on parent container or unlock it.

ORA-31107 Action failed as resource "string" is locked by name lock

Cause: Lock requests cause the whole request URI to be locked.

Action: Supply lock token or unlock the lock.

ORA-31108 Action failed as resource string is locked

Cause: Delete/Rename failed because of an existing lock.

Action: Do lockdiscovery to find the lock and delete it.

ORA-31109 Action failed as parent resource string is locked

Cause: Delete/Rename failed because of a lock on parent resource.

Action: Do lockdiscovery to find the lock and delete it.

ORA-31110 Action failed as resource string is locked by name

Cause: Delete/Rename failed because one of the children is locked.

Action: Do lockdiscovery to find the lock and delete it.

ORA-31111 table string cannot be hierarchically enabled

Cause: Trigger <tabname>_xdb_pitrigger already exists.

Action: Either the table is already hierarchically enabled or the user trigger <tabname>_xdb_pitrigger needs to be dropped. Delete all rows in the hierarchical index and then rebuild it.

ORA-31112 fail to string for string port using xdb configuration

Cause: port number for the defined presentation is not valid.

Action: Either the port number is already in use or it is protected. Specify another port number.

ORA-31113 XDB configuration may not be updated with non-schema compliant data

Cause: An attempt was made to update the XDB configuration resource with non-schema or non-schema compliant data.

Action: Check the document to make sure it is schema based and schema compliant.

ORA-31114 XDB configuration has been deleted or is corrupted

Cause: The XDB configuration resource has been deleted or corrupted.

Action: Reinstall XDB, or reinsert a valid configuration document.

ORA-31115 XDB configuration error: string

Cause: An error related to XDB configuration has occurred.

Action: Make sure the configuration resource contains valid data.

ORA-31121 The string operator can not be FALSE

Cause: The value of the operator that is specified is FALSE.

Action: Specify an operator that evaluates to TRUE.

ORA-31122 The string operator has incorrect RHS value

Cause: The right hand side value that has been specified for the operator does not evaluate to TRUE.

Action: Specify a value on the right hand side that evaluates to TRUE.

ORA-31151 Cyclic definition encountered for string: "string"

Cause: The schema definition for this type has cycles.

Action: Remove the cyclic definition and re-compile schema.

ORA-31153 Cannot create schema URL with reserved prefix "http://xmlns.oracle.com/xdb/schemas/"

Cause: This prefix is reserved for XDB extended schema URLs and cannot be used in a user specified URL.

Action: Modify the prefix to a different one.

ORA-31154 invalid XML document

Cause: The XML document is invalid with respect to its XML Schema.

Action: Fix the errors identified and try again.

ORA-31155 attribute string not in XDB namespace

Cause: The specified attribute should be prefixed with XDB's namespace.

Action: Ensure that all XDB specified attributes are prefixed with XDB's namespace and try again.

ORA-31190 Resource string is not a version-controlled resource

Cause: Either one of the following is the cause:

  • Checkout is requested for a resource that isn't under version control.

    Only version-controlled resources can be checked out.

  • Checkout is requested for a row of a non-versioned table.

Action: Put the resource under version-control before checking out.

ORA-31191 Resource string is already checked out

Cause: Checkout is requested for a resource that is already checked out to the workspace by the same or different user.

Action: Checked in the resource from the workspace before checking out.

ORA-31192 Resource string has not been checked out

Cause: Checkin or uncheckout is requested for a resource that has not been checked out to the workspace by any user in a workspace.

Action: Checked in the resource from the workspace before checking out.

ORA-31193 This versioning feature isn't supported for resource string

Cause: Container cannot be put under version-controlled.

Action: Avoid using these features.

ORA-31194 Resource string is already deleted

Cause: Accessed a version-controlled resource that is already deleted.

Action: Re-create the resource.

ORA-31201 DBMS_LDAP: generic error: string

Cause: There has been an error in the DBMS_LDAP package.

Action: Please report the error number and description to Oracle Support Services.

ORA-31202 DBMS_LDAP: LDAP client/server error: string

Cause: There is a problem either on the LDAP server or on the client.

Action: Please report this error to the LDAP server administrator or your Database administrator.

ORA-31203 DBMS_LDAP: PL/SQL - Init Failed

Cause: There has been an error in the DBMS_LDAP Init operation.

Action: Please check the host name and port number, or report the error number and description to Oracle Support Services.

ORA-31204 DBMS_LDAP: PL/SQL - Invalid LDAP Session

Cause: There has been an error in the DBMS_LDAP bind operation.

Action: Please check the session handler that you use for binding, or report the error number and description to Oracle Support Services.

ORA-31205 DBMS_LDAP: PL/SQL - Invalid LDAP Auth method

Cause: There has been an error in the DBMS_LDAP bind operation.

Action: Please check the authentication credentials that you used for binding, or report the error number and description to Oracle Support Services.

ORA-31206 DBMS_LDAP: PL/SQL - Invalid LDAP search scope

Cause: There has been an error in the DBMS_LDAP search operation.

Action: Please check the search scope that you use for search, or report the error number and description to Oracle Support Services.

ORA-31207 DBMS_LDAP: PL/SQL - Invalid LDAP search time value

Cause: There has been an error in the DBMS_LDAP search operation.

Action: Please check the search time value that you use for search, or report the error number and description to Oracle Support Services.

ORA-31208 DBMS_LDAP: PL/SQL - Invalid LDAP Message

Cause: There has been an error in the DBMS_LDAP operation.

Action: Please check the LDAP message that you use for LDAP operation, or report the error number and description to Oracle Support Services.

ORA-31209 DBMS_LDAP: PL/SQL - LDAP count_entry error

Cause: There has been an error in the DBMS_LDAP count_entry operation.

Action: Please check the LDAP count_operation, or report the error number and description to Oracle Support Services.

ORA-31210 DBMS_LDAP: PL/SQL - LDAP get_dn error

Cause: There has been an error in the DBMS_LDAP get_dn operation.

Action: Please check the LDAP get_dn, or report the error number and description to Oracle Support Services.

ORA-31211 DBMS_LDAP: PL/SQL - Invalid LDAP entry dn

Cause: There has been an error in the DBMS_LDAP operation.

Action: Please check the entry dn that you use for LDAP operation, or report the error number and description to Oracle Support Services.

ORA-31212 DBMS_LDAP: PL/SQL - Invalid LDAP mod_array

Cause: There has been an error in the DBMS_LDAP operation.

Action: Please check the LDAP mod_array that you use for LDAP operation, or report the error number and description to Oracle Support Services.

ORA-31213 DBMS_LDAP: PL/SQL - Invalid LDAP mod option

Cause: There has been an error in the DBMS_LDAP populate_mod_array operation.

Action: Please check the LDAP mod option that you use for LDAP populate_mod_array operation, or report the error number and description to Oracle Support Services.

ORA-31214 DBMS_LDAP: PL/SQL - Invalid LDAP mod type

Cause: There has been an error in the DBMS_LDAP populate_mod_array operation.

Action: Please check the LDAP mod type that you use for LDAP populate_mod_array operation, or report the error number and description to Oracle Support Services.

ORA-31215 DBMS_LDAP: PL/SQL - Invalid LDAP mod value

Cause: There has been an error in the DBMS_LDAP populate_mod_array operation.

Action: Please check the LDAP mod value that you use for LDAP populate_mod_array operation, or report the error number and description to Oracle Support Services.

ORA-31216 DBMS_LDAP: PL/SQL - Invalid LDAP rdn

Cause: There has been an error in the DBMS_LDAP operation.

Action: Please check the LDAP rdn value that you use for LDAP operation, or report the error number and description to Oracle Support Services.

ORA-31217 DBMS_LDAP: PL/SQL - Invalid LDAP newparent

Cause: There has been an error in the DBMS_LDAP rename_s operation.

Action: Please check the LDAP newparent value that you use for LDAP rename_s operation, or report the error number and description to Oracle Support Services.

ORA-31218 DBMS_LDAP: PL/SQL - Invalid LDAP deleteoldrdn

Cause: There has been an error in the DBMS_LDAP rename_s operation.

Action: Please check the LDAP deleteoldrdn value that you use for LDAP rename_s operation, or report the error number and description to Oracle Support Services.

ORA-31219 DBMS_LDAP: PL/SQL - Invalid LDAP notypes

Cause: There has been an error in the DBMS_LDAP explode_dn or explode_rdn operation.

Action: Please check the LDAP notypes value that you use for LDAP explode_dn or explode_rdn operation, or report the error number and description to Oracle Support Services.

ORA-31220 DBMS_LDAP: PL/SQL - Invalid LDAP SSL wallet location

Cause: There has been an error in the DBMS_LDAP operation.

Action: Please check the LDAP sslwrl value that you use for LDAP operation, or report the error number and description to Oracle Support Services.

ORA-31221 DBMS_LDAP: PL/SQL - Invalid LDAP SSL wallet passwd

Cause: There has been an error in the DBMS_LDAP operation.

Action: Please check the LDAP sslpasswd value that you use for LDAP operation, or report the error number and description to Oracle Support Services.

ORA-31222 DBMS_LDAP: PL/SQL - Invalid LDAP SSL authentication mode

Cause: There has been an error in the DBMS_LDAP operation.

Action: Please check the LDAP sslauth value that you use for LDAP operation, or report the error number and description to Oracle Support Services.

ORA-31398 DBMS_LDAP: Shared servers are not supported.

Cause: The session executing functions from the DBMS_LDAP package is being handled by a shared server in the Database.

Action: Use dedicated database sessions to execute functions in the DBMS_LDAP package.

ORA-31399 Cannot contact LDAP server string at port number

Cause: The specified LDAP server could not be contacted. This can happen if the server is down or inaccessible.

Action: Contact the administrator of the LDAP server.

ORA-31401 change source string is not an existing asynchronous change source

Cause: The caller did not use the name of an existing asynchronous change source. The name given does not match the name of any existing asynchronous change source.

Action: Check the spelling of the change source name. Choose an existing change source.

ORA-31402 unrecognized parameter string

Cause: An unrecognized parameter was detected.

Action: Check for too many parameters in the call.

ORA-31403 change table string already contains a column string

Cause: Issued ALTER_CHANGE_TABLE with an add operation but a column with this name already exists in the specified table.

Action: Check the names and call the procedure again.

ORA-31404 all input parameters are null

Cause: All input parameters are null. At least one property must be altered.

Action: Call the procedure again, making sure that all the required parameters have been specified. Ensure that at least one parameter is not null. Refer to the documentation for the correct method of calling this procedure.

ORA-31405 cannot make changes while change set string is advancing

Cause: The change set is currently advancing. Change sources related to an advancing change set cannot be altered. Change tables related to the advancing change set cannot be created, altered, or dropped. Some or all of the parameters of the change set cannot be altered while the set is advancing.

Action: Wait until the change set has finished advancing, then reissue the command. If altering the change set, only the advance_enable parameter can be altered during an advance.

ORA-31406 change source string is referenced by a change set

Cause: The operation cannot complete because this change source is referenced by one or more change sets.

Action: Drop the change sets first, then re-issue the command. May have to drop some change tables before the change sets are dropped.

ORA-31407 end_date must be greater than the begin_date

Cause: The end data of the change set is earlier than the begin date. The end date must always be later in time than the begin date, so that the duration between the begin and end dates is a positive amount of time.

Action: Change the begin date and/or the end date, so that the end date is later than the begin date.

ORA-31408 illegal value specified for begin_scn or end_scn

Cause: The begin_scn is not greater than zero. The end_scn is less than zero. The end_scn is less than the begin_scn.

Action: Check the values of both begin_scn and end_scn. Correct them to make sure that they form a legal SCN range. An end_scn value of zero indicates an infinite scn range.

ORA-31409 one or more values for input parameters are incorrect

Cause: One or more of the inputs to the procedure had illegal values.

Action: Identify the bad parameter(s) and supply correct values to the procedure.

ORA-31410 change set string is not an asynchronous change set

Cause: Could not find an asynchronous change set by this name.

Action: Check the spelling of the change set name. Call the procedure again, passing the correct change set name.

ORA-31411 change set string is referenced by a change table

Cause: The operation cannot be performed because the change set contains one or more change tables.

Action: You will need to drop the change table(s) first, then repeat the operation.

ORA-31412 change set string is disabled and cannot be advanced

Cause: The specified change set is disabled. The change set needs to be enabled for the operation to succeed.

Action: Determine why the change set is disabled and correct this condition. Alter the change set specifying 'y' for advance_enable then retry the operation.

ORA-31413 change set string is currently being advanced

Cause: An advance operation is in progress for this change set when only one is allowed at a time.

Action: Since the change set is currently being advanced, the best action is to wait for it to finish advancing. Only one caller at a time can advance the change set. Check for the cause of long running advance operations.

ORA-31414 error(s) occurred during change table advance

Cause: One or more errors occurred during the advance operation.

Action: Check the log file(s) for a more detailed report of the underlying errors.

ORA-31415 change set string does not exist

Cause: The specified change set does not exist or the user does not have access to the publications in that change set. The specified name did not match the name of any existing change set. Certain privileges are required to access the publications within that change set.

Action: Check the name and call the procedure again, with the name of an existing change set. Contact the publisher or database administrator if user privileges are required to access the publications in the change set.

ORA-31416 illegal SOURCE_COLMAP value

Cause: Cannot specify a source_colmap value of 'y' for asynchronous.

Action: Specify 'n' for the source_colmap option and call the procedure again.

ORA-31417 column list contains control column string

Cause: Reserved column name was specified in a column list or column type parameter.

Action: Control columns are selected with separate parameters. If you did not want a control column, then change the name of the specified column so that it does not conflict with a reserved column name.

ORA-31418 source schema string does not exist

Cause: Tried to create a synchronous change table and the source schema did not match any existing schema names in the database.

Action: Specify the name of an existing schema.

ORA-31419 source table string does not exist

Cause: When creating a synchronous change table, the underlying source table must exist when the procedure is called. In this case, the source table did not exist.

Action: Specify the name of an existing table.

ORA-31420 unable to submit the purge job

Cause: When creating the first change table, a purge job is submitted to the job queue. Submission of this purge job failed.

Action: Make sure that job queue processes are enabled and are currently running. If this does not solve the problem, then contact Oracle Support Services.

ORA-31421 change table does not exist

Cause: The specified change table does not exist.

Action: Recheck the name and call the procedure again using an existing change table.

ORA-31422 owner schema string does not exist

Cause: The value specified for the owner parameter does not contain the name of an existing schema in the database.

Action: Recheck the name and call the procedure again using an existing schema name.

ORA-31423 change table string does not contain column string

Cause: Issued ALTER_CHANGE_TABLE with a drop operation and the specified column does not exist in the change table.

Action: Recheck the names and call the procedure again.

ORA-31424 change table has active subscriptions

Cause: The change table is subscribed to, so it cannot be dropped.

Action: Do not drop a change table while there are active subscribers. If this is an emergency, use the FORCE parameter. This will forcibly drop the change table out from under all subscribers.

ORA-31425 subscription handle does not exist

Cause: The subscription handle does not exist or does not belong to this user.

Action: Call the function again with a valid subscription handle.

ORA-31426 cannot modify active subscriptions

Cause: The subscription handle has been activated; additional calls to SUBSCRIBE are prohibited.

Action: Subscribe to all the desired tables and columns before activating the subscription. Ensure that the correct subscription handle was specified.

ORA-31427 source table string already subscribed

Cause: The subscription represented by the subscription handle already contains source_schema.source_table.

Action: Check the values of the subscription_handle, source_schema, and source_table. Do not attempt to subscribe to the same table more than once using the same subscription handle.

ORA-31428 no publication contains all the specified columns

Cause: One or more of the specified columns cannot be found in a single publication.

Action: Change the subscription request to select only columns that are in the same publication. Consult the USER_PUBLISHED_COLUMNS view to see current publications.

ORA-31429 subscription handle has not been activated

Cause: The called procedure requires an activated subscription.

Action: Check the subscription handle and correct if necessary. Call the ACTIVATE_SUBSCRIPTION procedure for this subscription handle and then reissue the original command.

ORA-31430 change view exists

Cause: The change view was not dropped prior to making this call.

Action: Call the DROP_SUBSCRIBER_VIEW procedure and then retry the original command.

ORA-31431 all source tables must belong to the synchronous change set

Cause: Not all of the source tables belong to the synchronous change set.

Action: Check the spelling of the source tables. Make sure that all of the source tables belong to the synchronous change set.

ORA-31432 invalid source table

Cause: The schema_name.source_table does not exist or does not belong to this subscription.

Action: Check the spelling of the schema_name and source_table. Verify that the specified table exists in the specified schema and is subscribed to by the subscription handle.

ORA-31433 change view does not exist

Cause: Specified an incorrect change view or the view is already dropped.

Action: Recheck the name and specify the name of an existing change view.

ORA-31434 purge is currently running

Cause: Called the PURGE procedure while a purge job was currently running.

Action: Wait for purge to complete before reissuing this command.

ORA-31435 an error occurred during the purge operation

Cause: An error occurred during the purge operation.

Action: Check the logfile for a more detailed report of the underlying errors.

ORA-31436 duplicate change source string

Cause: A change source by the specified name already exists.

Action: Recreate the change source with a unique name.

ORA-31437 duplicate change set string

Cause: A change set by the specified name already exists.

Action: Recreate the change set with a unique name.

ORA-31438 duplicate change table string

Cause: A change table by the specified name already exists.

Action: Recreate the change table with a unique name.

ORA-31439 subscription is already active

Cause: The subscription is already active.

Action: Check name and retry.

ORA-31440 change set string is empty and cannot be advanced

Cause: User attempted to advance a change set which does not contain any change tables. Without change tables, a change set cannot be advanced.

Action: Create change tables in the change set, then retry the advance.

ORA-31441 table is not a change table

Cause: User attempted to execute the DROP_CHANGE_TABLE procedure on a table that is not a CHANGE table. This can also occur when a CHANGE table object has been orphaned. CHANGE tables can become orphaned after a CREATE_CHANGE_TABLE failure or an incomplete DROP_CHANGE_TABLE.

Action: Check spelling. If error was due to an incorrect name, then retry the procedure using the correct name. To drop a table that is not a CHANGE table, or an orphaned CHANGE table, use the DROP TABLE DDL command instead.

ORA-31442 operation timed out while acquiring lock on string

Cause: CDC attempted to acquire a lock on the resource, but the operation timed out.

Action: Retry the operation later.

ORA-31443 deadlock detected while acquiring lock on string

Cause: CDC attempted to acquire a lock on the resource, but encountered a deadlock.

Action: Contact Oracle Support Services.

ORA-31444 parameter error while acquiring lock on string

Cause: CDC attempted to acquire a lock on the resource, but encountered a problem passing parameters to the lock manager.

Action: Contact Oracle Support Services.

ORA-31445 invalid lock handle while acquiring lock on string

Cause: CDC attempted to acquire a lock on the resource, but encountered an invalid lock handle, which did not correspond to any existing handle.

Action: Contact Oracle Support Services.

ORA-31447 cannot create change tables in the SYS schema

Cause: Attempted to create a change table in the SYS schema. This is not allowed.

Action: Use a different, existing schema and retry the command.

ORA-31448 illegal value for change_source

Cause: The specified value is not a valid name for a Change Source.

Action: Specify a valid name and retry the command.

ORA-31449 illegal value for set_name

Cause: The specified value is not a valid name for a Change Set.

Action: Specify a valid name and retry the command.

ORA-31450 illegal value for change_table_name

Cause: The specified value is not a valid name for a Change Table.

Action: Specify a valid name and retry the command.

ORA-31451 illegal value string for capture_values, expecting: OLD, NEW, or BOTH

Cause: The specified value is not a valid option for a capture_values.

Action: Specify a valid option and retry the command.

ORA-31452 illegal value string for parameter, expecting: Y or N

Cause: The specified value is not Y or N.

Action: Specify Y or N for the parameter and retry the command.

ORA-31453 illegal value string for parameter, expecting: Y, N, or NULL

Cause: The specified value is not Y, N, or NULL.

Action: Specify Y, N, or NULL for the parameter and retry the command.

ORA-31454 illegal value string for operation parameter, expecting: ADD or DROP

Cause: The specified value is not ADD or DROP.

Action: Specify ADD or DROP and retry the command.

ORA-31455 nothing to ALTER

Cause: The specified column list is NULL and all optional control columns are 'N'.

Action: Specify one or more columns to ALTER.

ORA-31456 error executing a procedure in the DBMS_CDC_UTILITY package

Cause: An internal attempt to invoke a procedure within the DBMS_CDC_UTILITY package failed.

Action: Check the trace logs for more information. Ensure that the package has been installed successfully. Try issuing a DESCRIBE command from SQL on the package. If it fails, then try reinstalling the package. If it succeeds, try invoking one of the procedures from SQL.

ORA-31457 maximum length of description field exceeded

Cause: The maximum number of characters permitted in the description field was exceeded.

Action: The maximum length of the description field is 30 characters. Ensure the length does not exceed this value and retry the command.

ORA-31459 system triggers for DBMS_CDC_PUBLISH package are not installed

Cause: One or more required system triggers are not installed. These triggers are required for the proper operation of Change Data Capture. Operations on Change tables cannot continue.

Action: Install or reenable the triggers, or reinstall the package.

ORA-31460 logfile location string is not an existing directory

Cause: The directory specification for logfile location for the change source, does not correspond with an existing directory, or the directory was not accessible.

Action: Create the directory if it does not exist. If the directory does exist, change the file system permissions so the directory can be accessed. Alternatively, perform ALTER CHANGE SOURCE and change the logfile_location to be an existing directory that contains the logfiles.

ORA-31461 logfile location string contains no files that match pattern string

Cause: The directory specification for logfile location for the change source, does not contain any files whose names pattern-match the logfile_suffix.

Action: Make sure that the logfile location contains logfiles whose names match the logfile_suffix pattern for the change set. Alternatively, perform ALTER CHANGE SOURCE and change the logfile_suffix such that it matches the names of existing logfiles in the directory.

ORA-31462 internal error while accessing metadata

Cause: An unexpected internal error occurred while CDC was accessing its internal Metadata.

Action: Contact Oracle Support Services.

ORA-31463 logfile location string is an empty directory

Cause: The directory specification for logfile location for the change source, is an empty directory.

Action: Make sure it is the correct location of the logfiles. If it is, make sure the directory contains logfiles. Alternatively, perform ALTER CHANGE SOURCE and change the logfile_location to be an existing directory that contains the logfiles.

ORA-31464 target table for the change table no longer exists

Cause: User tried to drop a change table but its underlying storage table (that contains the change data) has been dropped.

Action: Contact Oracle Support Services.

ORA-31465 cannot obtain a lock on the subscription handle

Cause: A timeout occurred while trying to place a lock on the subscription handle. Another session has already aquired the lock on the subscription handle.

Action: Ensure the subscription handle is correct and correct it if necessary. If it was correct, retry the operation after the session holding the lock has released it.

ORA-31466 no publications found

Cause: Did not find any publications that matched the input parameters or the user does not have the privileges to access the specified publication.

Action: Check the input parameters on the call to SUBSCRIBE. Validate that the proposed source table has been published by checking the USER_PUBLICATIONS view for that source table. Contact the publisher if user privileges are required to access the publication. Retry the command with correct security or publication information.

ORA-31467 no column found in the source table

Cause: The OBJECT_ID flag was set to 'Y' on the call to CREATE_CHANGE_TABLE and change table belongs to the synchronous change set. The corresponding object column was not detected in the source table.

Action: Create the change table with the OBJECT_ID flag set to 'N' or investigate why the object column is not in the source table and add it to the source table.

ORA-31470 asynchronous change tables must contain the RSID$ column

Cause: If creating an asynchronous change table, the RSID was set to 'N'. If altering an asynchronous change table with an operation parameter of 'DROP' RSID was set to 'Y'.

Action: When creating asynchronous change tables, always specify 'Y' for the RSID parameter. When altering asynchronous change tables, always specify 'N' for RSID.

ORA-31471 illegal OBJECT_ID value

Cause: Cannot specify an object_id value of 'y' for asynchronous change tables.

Action: Specify 'n' for the object_id option and call the procedure again.

ORA-31472 Importing Change Data Capture version string.string is too new

Cause: An attempt was made to Import a file that was exported by a newer version of Oracle than the target instance.

Action: If possible, re-export the file using a version of export that matches the import target. Objects can not be imported into previous versions of Oracle that did not support them.

ORA-31475 redo log catalog contains no metadata for the source table

Cause: While advancing a change set, a CDC attempted to query the LogMiner dictionary system tables to obtain the columns from the source table. The query returned no rows. This may be because none of the redo logs contains a catalog, or it may be an internal error.

Action: First, verify that the source system contains the source table. execute dbms_logmnr_d.build procedure to populate the redos log with logminer dictionary information. If this has been done and the problem persists, then contact Oracle Support Services.

ORA-31476 a change table data column is missing from the source table

Cause: While advancing a change set, a CDC determined that at least one of the data columns in a change table does not match the name of any of the columns in the source table. The source table column list is stored in dictionary table SYSTEM.LOGMNR_OBJ$.

Action: Make sure that all of the data columns of the change table have the same names as the corresponding columns in the source table, and that all the columns exist in the source table.

ORA-31495 error in synchronous change table on "string"."string"

Cause: There was an error originating from this synchronous change table. One possible cause is that schema redefinition has occurred on the source table and one or more columns in the change table are now a different type than the corresponding source columns. Another possible cause is that there is a problem accessing the synchronous change table.

Action: Check further error messages in the stack for more detail about the cause. If there has been schema redefinition, drop and recreate the synchronous change table.

ORA-31496 must use DBMS_CDC_PUBLISH.DROP_CHANGE_TABLE to drop change tables

Cause: An attempt was made to use the SQL command DROP TABLE for change tables, but DROP TABLE is not supported for change tables.

Action: Use the DBMS_CDC_PUBLISH.DROP_CHANGE_TABLE procedure instead of the DROP TABLE command.

ORA-31600 invalid input value string for parameter string in function string

Cause: A NULL or invalid value was supplied for the parameter.

Action: Correct the input value and try the call again.

ORA-31601 Function string cannot be called now that fetch has begun

Cause: The function was called after the first call to FETCH_xxx.

Action: Correct the program.

ORA-31602 parameter string value "string" in function string inconsistent with string

Cause: The parameter value is inconsistent with another value specified by the program. It may be inconsistent with the object type associated with the OPEN context, or it may be of the wrong datatype (a boolean rather than a text string or vice versa).

Action: Correct the program.

ORA-31603 object "string" of type string not found in schema "string"

Cause: The specified object was not found in the database.

Action: Correct the object specification and try the call again.

ORA-31604 invalid string parameter "string" for object type string in function string

Cause: The specified parameter value is not valid for this object type.

Action: Correct the parameter and try the call again.

ORA-31605 the following was returned from string in routine string: LPX-number: string

Cause: An LPX routine (XML/XSL processing) returned an internal error number to its PL/SQL wrapper routine in facility KUX which provides the implementation for package UTL_XML.

Action: Look up the LPX error number and follow its corrective action.

ORA-31606 XML context number does not match any previously allocated context

Cause: A method in package UTL_XML was called with an invalid XML context handle. All handles must have previously been allocated by UTL_XML.XMLINIT.

Action: Always call XMLINIT before any other methods in pkg. UTL_XML.

ORA-31607 Function string is inconsistent with transform.

Cause: Either FETCH_XML was called when the "DDL" transform was specified or FETCH_DDL was called when the "DDL" transform was omitted.

Action: Correct the program.

ORA-31608 specified object of type string not found

Cause: The specified object was not found in the database.

Action: Correct the object specification and try the call again.

ORA-31609 error loading file "string" from file system directory "string"

Cause: The installation script initmeta.sql failed to load the named file from the file system directory into the database.

Action: Examine the directory and see if the file is present and can be read.

ORA-32001 write to SPFILE requested but no SPFILE specified at startup

Cause: An alter system command or an internal self tuning mechanism requested a write to the SPFILE but no SPFILE was used to startup the instance.

Action: Create an SPFILE and re-start the instance using the SPFILE.

ORA-32002 cannot create SPFILE already being used by the instance

Cause: A create spfile command is trying to write to an SPFILE that was used to startup the instance.

Action: Specify a different SPFILE name.

ORA-32004 obsolete and/or deprecated parameter(s) specified

Cause: One or more obsolete parameters were specified in the SPFILE or the PFILE on the server side.

Action: See alert log for a list of parameters that are obsolete or deprecated. Remove them from the SPFILE or the server side PFILE.

ORA-32005 error while parsing size specification [string]

Cause: The value specified for an alter operation on a size parameter is not valid.

Action: Correct the value and retry the operation.

ORA-32006 string initialization parameter has been deprecated

Cause: A deprecated parameter was specified at startup.

Action: Consult Oracle documentation to find new parameters to use instead.

ORA-32008 error while processing parameter update at instance string

Cause: An error occurred while processing a parameter on a remote instance.

Action: See accompanying error messages.

ORA-32009 cannot reset the memory value for instance string from instance string

Cause: Memory resets of local parameters are only allowed.

Action: Retry the query for the local instance if needed.

ORA-32010 cannot find entry to delete in SPFILE

Cause: The SPFILE did not contain the sid.parameter entry.

Action: Change the sid and/or the parameter.

ORA-32011 cannot restore SPFILE to location already being used by the instance

Cause: A restore operation trying to write to an SPFILE that was used to startup the instance.

Action: Specify a different SPFILE name.

ORA-32012 failure in processing system parameters from restored SPFILE

Cause: Failure during processing of parameters from restored SPFILE.

Action: Further diagnostic information should be in the error stack.

ORA-32013 failure in verifying parameters from the restored SPFILE

Cause: Failure during processing of parameters from restored SPFILE. It could be that the restored image of the SPFILE is corrupted.

Action: Further diagnostic information should be in the error stack.

ORA-32014 error processing parameter "string" from the SPFILE restore image

Cause: Failure during processing of parameters from restored SPFILE. It could be that the restored image of the SPFILE is corrupted.

Action: Further diagnostic information should be in the error stack.

ORA-32015 unable to restore SPFILE

Cause: Failure during SPFILE restore. It could be that the restore destination is not valid.

Action: Further diagnostic information should be in the error stack.

ORA-32016 parameter "string" cannot be updated in SPFILE

Cause: The database is mounted.

Action: Unmount the database to update the parameter in the SPFILE.

ORA-32017 failure in updating SPFILE

Cause: A failure occurred while updating the SPFILE.

Action: See associated errors.

ORA-32031 illegal reference of a query name in WITH clause

Cause: Forward or recursive reference of a query name in WITH clause is not allowed.

Action: Correct the query statement and retry.

ORA-32032 free temporary object number not available

Cause: Too many queries using temp table transformation are currently being run to use up all temporay object numbers.

Action: Turn off temporary table transformation or wait, then retry.

ORA-32033 unsupported column aliasing

Cause: Column aliasing in WITH clause is not supported.

Action: Specify aliasing in definition subquery and retry.

ORA-32034 unsupported use of WITH clause

Cause: Improper use of WITH clause due to one of the following:

  1. Nesting of WITH clause within WITH clause not supported.
  2. For a set query, WITH clause can't be specified for a branch.
  3. WITH clause cantbespecifiedwithinparentheses.'

Action: correct the query and retry.

ORA-32035 unreferenced query name defined in WITH clause

Cause: There is at least one WITH clause query name that is not referenced in any place.

Action: remove the unreferenced query name and retry.

ORA-32036 unsupported case for inlining of query name in WITH clause

Cause: There is at least one query name which is inlined more than once because its definition query is too simple and references another query name. This is not currently supported.

Action: remove such a query name and retry.

ORA-32037 unsupported use of LEVEL in membership condition

Cause: An attempt was made to use LEVEL in membership condition with subquery that is not supported.

Action: Rewrite query to avoid using LEVEL in membership condition.

ORA-32050 string operation failed

Cause: A mapping operation failed.

Action: Check FMON trace files for errors.

ORA-32051 mapping service not available

Cause: The mapping service was never started or previously failed to start properly.

Action: Set FILE_MAPPING to true if it is not currently set. Otherwise, check FMON trace files for an ORA-32052 error.

ORA-32052 failed to start mapping service

Cause: The mapping service failed to start properly.

Action: Check FMON trace files for errors.

ORA-32053 operation not supported

Cause: Mapping libraries do not support this operation.

Action: Check whether mapping libraries are available and whether the operation is supported by the libraries.

ORA-32054 lost communication with FMPUTL process

Cause: Lost communication with mapping utility.

Action: Check FMON and FMPUTL trace files for errors.

ORA-32055 invalid file type

Cause: Invalid file type used when mapping files.

Action: Specify one of the expected file types.

ORA-32056 invalid number of extents

Cause: Invalid number of extents were used for a map operation.

Action: Specify a non-negative number of extents.

ORA-32057 invalid lock mode

Cause: An invalid mode was used for a lock operation.

Action: Specify one of the expected lock modes.

ORA-32058 operation restricted to SYSDBA users

Cause: This operation requires SYSDBA priviliges.

Action: Connect to the database as a user with SYSDBA privileges.

ORA-32059 deadlock detected on mapping structures

Cause: Mapping structures are already locked by the same session.

Action: Unlock mapping structures before proceeding with the current operation.

ORA-32060 channel failure

Cause: Channel failure between foreground and background process.

Action: Check foreground trace files for errors.

ORA-32100 operation invalid on transient object

Cause: Trying to perform an operation on transient object which is valid only on persistent objects.

Action: Make sure object is persistent.

ORA-32101 cannot create OCI Environment

Cause: An OCI Environment could not be created for OCCI.

Action: Ensure that the parameters to the creatEnvironment method are valid.

ORA-32105 invalid connection passed to the migrate method

Cause: An invalid Connection was passed to the Session::migrate method.

Action: Pass a valid Connection to the migrate method.

ORA-32106 array fetch not allowed without setBuffer on all columns

Cause: The setBuffer method was not called for all column positions and the next method was called to fetch more than one row.

Action: Call the setBuffer method for all column positions if next is to be called to fetch more than one row.

ORA-32107 internal OCI memory allocation failure

Cause: Memory could not be allocated from an OCI heap.

Action: Increase the process memory size.

ORA-32108 max column or parameter size not specified

Cause: The max column or parameter size is not specified.

Action: Specify the max size by setMaxColumnSize or setMaxParamSize.

ORA-32109 invalid column or parameter position

Cause: An invalid column or parameter position was specified.

Action: Specify a valid column or position number.

ORA-32110 Connection not specified

Cause: A null connection was passed.

Action: Pass a valid, non-null connection.

ORA-32111 The size of the vector does not match the size of the VARRAY

Cause: The number of elements in the vector passed to the setVector method was not equal to the size of the VARRAY.

Action: Pass a vector of size equal to the size of the VARRAY.

ORA-32112 Call not applicable until an attribute has been fetched

Cause: An attribute was fetched after a call to wasLastAttrNull().

Action: Fetch an attribute value before making this call.

ORA-32113 Null object passed

Cause: A Null object was passed.

Action: Pass a non-null object.

ORA-32114 Cannot perform operation on a null LOB

Cause: The LOB instance on which the operation was attempted was null.

Action: Use a valid, non-null LOB instance to perform this operation.

ORA-32115 LOBs do not belong to any connection

Cause: Neither of the LOBs being compared had associated connection information.

Action: At least one of the LOBs being compared must be associated with a valid connection.

ORA-32116 Buffer size is less than amount specified

Cause: The buffer size specified for the LOB read or write operation was less than the amount to be read or written.

Action: The buffer size must be equal to or greater than than the amount to be read from or written to the LOB.

ORA-32117 Source LOB is null

Cause: The source LOB instance on which the operation was attempted was null.

Action: Use a valid, non-null source LOB instance for this operation.

ORA-32118 Cannot perform operation on a null FILE

Cause: The FILE instance on which the operation was attempted was null.

Action: Use a valid, non-null FILE instance to perform this operation.

ORA-32119 FILEs do not belong to any connection

Cause: Neither of the FILEs being compared had associated connection information.

Action: At least one of the FILEs being compared must be associated with a valid connection.

ORA-32120 Buffer size is less than amount specified

Cause: The buffer size specified for the FILE read or write operation was less than the amount to be read or written.

Action: The buffer size must be equal to or greater than than the amount to be read from or written to the FILE.

ORA-32121 Source FILE is null

Cause: The source FILE instance on which the operation was attempted was null.

Action: Use a valid, non-null source FILE instance for this operation.

ORA-32122 Statement invalidated, cannot get metadata

Cause: An attempt was made to get metadata for a terminated statement.

Action: No action required.

ORA-32123 Attribute number is out of range

Cause: The attribute number passed is greater than the total number of attributes of the described object.

Action: Pass the attribute number within the allowable range.

ORA-32124 Illegal attribute passed

Cause: The attribute passed is not applicable for the described object.

Action: Pass a valid attribute.

ORA-32125 Attribute type is not appropriate

Cause: The return type of the get method does not match the type of the attribute being passed.

Action: Call the appropriate get method.

ORA-32126 Cannot perform operations on a null REF

Cause: The REF instance on which the operation was attempted was null.

Action: Use a valid, non-null REF instance to perform this operation.

ORA-32127 REFs do not belong to any connection

Cause: Neither of the REFs being compared had associated connection information.

Action: At least one of the REFs being compared must be associated with a valid connection.

ORA-32128 setDataBuffer called after fetch has started

Cause: Fetch from result set has already started and the setDataBuffer call was made.

Action: Call the setDataBuffer method before calling the next() method.

ORA-32129 cannot get information about this column

Cause: The setDataBuffer method was called to get information about this column. Therefore, the current method cannot be called.

Action: Use the information from the buffers specified in the setDataBuffer call.

ORA-32130 invalid offset/index referenced in Bytes

Cause: The offset/index is out of range of valid data locations in Bytes offsets.

Action: Ensure that offsets or index is within the range of Bytes object.

ORA-32131 bind data type cannot be changed

Cause: The setXXX method is called again with a different data type than originally specified, or the setXXX method is called for a subsequent iteration without being called before the first iteration.

Action: Call the setXXX method with the same data type as done before the first iteration. If no setXXX method was called for this parameter, position the first iteration and make sure that a setXXX method is called before the first addIteration method is called.

ORA-32132 maximum iterations cannot be changed

Cause: The setMaxIterations was called after a setXXX method has been called.

Action: Call the setMaxIterations method before calling any setXXX methods.

ORA-32133 Cannot get stream from LOB/FILE

Cause: An open stream exists on the LOB/FILE on which the operation was attempted.

Action: Close the stream before getting another.

ORA-32134 Cannot assign LOBs

Cause: An open stream exists on the target LOB.

Action: Close the stream on the target LOB before assigning the LOBs.

ORA-32135 Cannot assign FILEs

Cause: An open stream exists on the target FILE.

Action: Close the stream on the target FILE before assigning the FILEs.

ORA-32136 Cannot perform operation on an invalid stream

Cause: The LOB/FILE from which the stream was obtained had been nullified or destroyed.

Action: Use a valid stream.

ORA-32137 Cannot perform read/write operation on stream

Cause: The readBuffer() or the writeBuffer() method was called on a UTF16 character set stream.

Action: Use the readUBuffer() or the writeUBuffer() method.

ORA-32138 Cannot perform read/write operation on stream

Cause: The readUBuffer() or the writeUBuffer() method was called on a non-UTF16 character set stream.

Action: Use the readBuffer() or the writeBuffer() method.

ORA-32139 Cannot write to the stream

Cause: A write was performed after the last buffer was written.

Action: Close this stream and get a new stream to perform the write.

ORA-32140 cannot perform this operation on stream

Cause: Either a read is attempted from a stream in write mode, or a write is attempted on a stream in read mode.

Action: Check the status of the stream to find out the valid operations that can be performed.

ORA-32141 get method does not match the type of the parameter

Cause: The getXXX method called on the Statement object does not match the type of the bind parameter.

Action: Call the getXXX method that is the same as the type of the parameter.

ORA-32142 maximum number of iterations exceeded

Cause: The addIteration exceeds the maximum number of iterations set by the setMaxIterations method.

Action: Increase the maximum number of allowed iterations.

ORA-32143 Environment not specified

Cause: A null environment was passed.

Action: Pass a valid, non-null environment.

ORA-32144 Cannot perform operation on a null interval

Cause: The interval involved in this operation is null.

Action: Use a valid, non-null interval instance to perform this operation.

ORA-32145 Environment not specified

Cause: The interval on which the operation was attempted was null and no environment was specified.

Action: Specify a non-null environment or perform the operation on a non null instance.

ORA-32146 Cannot perform operation on a null date

Cause: The date involved in this operation is null.

Action: Use a valid, non-null date instance to perform this operation.

ORA-32147 Environment not specified

Cause: The date on which the operation was attempted was null and no environment was specified.

Action: Specify a non-null environment or perform the operation on a non null instance.

ORA-32148 Cannot perform operation on a null time

Cause: The time involved in this operation is null.

Action: Use a valid, non-null time instance to perform this operation.

ORA-32149 Environment not specified

Cause: The time on which the operation was attempted was null and no environment was specified.

Action: Specify a non-null environment or perform the operation on a non null instance.

ORA-32150 Cannot perform operation on a null timestamp

Cause: The timestamp involved in this operation is null.

Action: Use a valid, non-null timestamp instance to perform this operation.

ORA-32151 Environment not specified

Cause: The timestamp on which the operation was attempted was null and no environment was specified.

Action: Specify a non-null environment or perform the operation on a non null instance.

ORA-32152 Cannot perform operation on a null number

Cause: The number involved in this operation was null.

Action: Use a valid, non-null number instance to perform this operation.

ORA-32153 Environment not specified

Cause: The number on which the operation was attempted was null and no environment was specified.

Action: Specify a non-null environment or perform the operation on a non null instance.

ORA-32154 Anydata context not specified

Cause: A null anydata context was passed.

Action: Pass a valid, non-null anydata context.

ORA-32155 Anydata not specified

Cause: A null anydata was passed.

Action: Pass a valid, non-null anydata.

ORA-32156 Cannot perform operation on stream

Cause: This operation is not applicable to streams obtained from LOBs.

ORA-32158 Invalid type passed

Cause: An inapplicable type was passed to this call.

Action: Pass an applicable type.

ORA-32159 Cannot set prefetch options for a null Type

Cause: A null Type name was passed.

Action: Pass an non-null Type name.

ORA-32160 Argument out of range

Cause: A zero or negative value was passed.

Action: Pass a positive value.

ORA-32161 Cannot perform piecewise fetch

Cause: Zero amount was passed and buffer size was less than LOB size.

Action: Specify a larger buffer or use Stream.

ORA-32162 Read/Write SQL method not registered

Cause: readSQL/writeSQL method was NULL or was not registered.

Action: Register readSQL/writeSQL by calling put method in Map.

ORA-32300 cannot drop a secondary materialized view "string"."string"

Cause: An attempt was made to drop a materialized view of a nested table column's storage table.

Action: Drop the materialized view that contains the nested table column. This will implicitly drop all materialized views.

ORA-32301 object-relational materialized views must be primary key based

Cause: An attempt was made to create an object-relational materialized view that is not primary key based.

Action: Create the materialized view with the PRIMARY KEY keyword.

ORA-32302 object materialized views must be object ID based

Cause: An attempt was made to create an object materialized view that is not object ID based.

Action: Create the materialized view using the OF clause but omit any ROWID or PRIMARY KEY clauses.

ORA-32303 mviews with user-defined types cannot reference multiple master sites

Cause: For materialized views with user-defined types, the definition query cannot reference tables from different master sites.

Action: Do not create materialized views with user-defined types referencing multiple master sites.

ORA-32304 materialized views with user-defined types cannot use prebuilt table

Cause: An attempt was made to create a materialized view with the ON PREBUILT TABLE option.

Action: Do not create the materialized view with the ON PREBUILT TABLE option.

ORA-32305 RepAPI materialized views with user-defined types are not supported

Cause: An attempt was made to create a RepAPI materialized view with user-defined types.

Action: Do not create a RepAPI materialized view with user-defined types.

ORA-32306 updatable materialized views with user-defined types must use SELECT *

Cause: An attempt was made to create an updatable materialized view with user-defined types where the definition query did not use SELECT * at the topmost level.

Action: Rewrite the definition query so that SELECT * is used at the topmost level.

ORA-32307 must use FROM ONLY clause when referencing an object table

Cause: An attempt was made to create a materialized view whose definition query references object tables without the FROM ONLY clause.

Action: Rewrite the definition query to use the FROM ONLY clause for all the object tables in the query.

ORA-32308 object materialized views must use SELECT *

Cause: An attempt was made to create an object materialized view where the definition query did not use SELECT * at the topmost level.

Action: Rewrite the definition query so that SELECT * is used at the topmost level.

ORA-32309 object mview type "string"."string" does not match the master table type

Cause: An attempt was made to create an object materialized view whose type does not match the type of the master object table.

Action: Redefine the type so that it matches the type of the master object table.

ORA-32310 object materialized views must select from an object table

Cause: An attempt was made to create an object materialized view whose definition query did not select from an object table.

Action: Rewrite the definition query to select from an object table.

ORA-32311 materialized view definition query selects an unsupported user-defined type

Cause: An attempt was made in the definition query to select an embedded user-defined type function, returning a user-defined type, or a function whose arguments are user-defined types.

Action: Rewrite the definition query to exclude these unsupported user-defined types.

ORA-32312 cannot refresh a secondary materialized view "string"."string"

Cause: An attempt was made to refresh a materialized view of a nested table column's storage table.

Action: Refresh the materialized view that contains the nested table column. This will implicitly refresh all secondary materialized views.

ORA-32313 REFRESH FAST of "string"."string" unsupported after PMOPs

Cause: A Partition Maintenance Operation (PMOP) has been performed on a detail table, and the specified materialized view does not support fast refersh after PMOPs.

Action: Use REFRESH COMPLETE. You can determine why your materialized view does not support fast refresh after PMOPs using the DBMS_MVIEW.EXPLAIN_MVIEW() API.

ORA-32314 REFRESH FAST of "string"."string" unsupported after deletes/updates

Cause: One or more deletions or updates has been performed on one or more of the detail tables referenced by the specified materialized view. This materialized view does not support fast refresh after deletions or updates.

Action: Use REFRESH COMPLETE. You can determine why your materialized view does not support fast refresh after deletions or updates using the DBMS_MVIEW.EXPLAIN_MVIEW() API.

ORA-32315 REFRESH FAST of "string"."string" unsupported after mixed DML and Direct Load

Cause: One or more of the materialized view logs on the detail tables referenced by the specified materialized view omits the sequence number option. Such a log cannot be used to refresh a materialized view after deletions or updates and direct path insert.

Action: Use REFRESH COMPLETE. You can use the DBMS_MVIEW.EXPLAIN_MVIEW() API to determine which materialized view logs omit the sequence number option.

ORA-32316 REFRESH FAST of "string"."string" unsupported after mixed DML

Cause: One or more of the materialized view logs on the detail tables referenced by the specified materialized view omits the sequence number option. Such a log cannot be used to refresh a materialized view after deletions or updates have been performed on multiple detail tables.

Action: Use REFRESH COMPLETE. You can use the DBMS_MVIEW.EXPLAIN_MVIEW() API to determine which materialized view logs omit the sequence number option.

ORA-32317 cannot run a job from a job

Cause: An attempt was made to execute a job from within another job.

Action: Do not submit jobs that run other jobs.

ORA-32318 cannot rename a materialized view

Cause: Renaming a materialized view or its base table is not supported.

Action: Do not rename the base table of a materialized view.

ORA-32319 Cannot use direct loader log to FAST REFRESH materialized view "string"."string"

Cause: The direct loader log might have been dropped.

Action: Need to perform a complete refresh.

ORA-32320 REFRESH FAST of "string"."string" unsupported after container table PMOPs

Cause: A Partition Maintenance Operation (PMOP) has been performed on the materialized view, and no materialized view supports fast refersh after container table PMOPs.

Action: Use REFRESH COMPLETE. Note: you can determine why your materialized view does not support fast refresh after PMOPs using the DBMS_MVIEW.EXPLAIN_MVIEW() API.

ORA-32321 REFRESH FAST of "string"."string" unsupported after detail table TRUNCATE

Cause: A detail table has been truncated and no materialized view supports fast refersh after a detail table has been truncated.

Action: Use REFRESH COMPLETE. Note: you can determine why your materialized view does not support fast refresh after TRUNCATE using the DBMS_MVIEW.EXPLAIN_MVIEW() API.

ORA-32330 invalid operation on online redefinition interim table "string"."string"

Cause: An invalid operation was performed on an interim table which was being used for online redefinition of a table.

Action: Do not perform any unsupported operation on the interim table.

ORA-32331 type "string"."string" is incompatible with the master site

Cause: A type used by the materialized view was found to be incompatible with it's coressponding type on the master site. This could be because the type does not exist on the master site or has been evolved to a different version from that on the materialized view site.

Action: Make sure that the types used by the materialized view are the same on both the materialized view and master sites.

ORA-32332 cannot refresh materialized view "string"."string" as type evolution has occurred

Cause: The types used by the materialized view or its master tables have been evolved.

Action: Ensure that the types used by the materialized view have been evolved to the same version at both the master and materialized sites. Before refreshing the materialized view, evolve the materialized view using ALTER MATERIALIZED VIEW.

ORA-32333 disable table scn update for Materialized view

Cause: An event is set for disabling table scn update to prevent deadlock situation.

Action: Disable null refresh and/or base table scn update for Materialized view.

ORA-32334 cannot create prebuilt materialized view on a table already referenced by a materialized view

Cause: The table on which the materialized view is created as prebuilt is already referenced by a materialized view.

Action: Create the materialized view on a different table.

ORA-32335 dimension must have at least one level

Cause: A level-less dimension is not allowed.

Action: Do not drop the only level of a dimension.

ORA-32336 cannot use USING NO INDEX to create materialized view "string"."string"

Cause: The USING NO INDEX option was specified to create an updatable primary key based materialized view, an index-organized materialized view, or an object-id materialized view.

Action: Do not use the USING NO INDEX option to create an updatable primary key based materialized view, an index-organized materialized view, or an object-id materialized view.

ORA-32337 cannot alter materialized view with pending changes refresh on commit

Cause: There are some pending changes in the detail tables.

Action: Execute an on-demand refresh on the materialized view to synchronize the data between the materialized view and the detail tables and then issue an ALTER MATERIALIZED VIEW statement.

ORA-32400 cannot use object id columns from materialized view log on "string"."string"

Cause: The materialized view log either does not have object id columns logged, or the timestamp associated with the object id columns is more recent than the last refresh time.

Action: A complete refresh is required before the next fast refresh. Add object id columns to the materialized view log, if required.

ORA-32401 materialized view log on "string"."string" does not have new values

Cause: The materialized view log on the indicated table does not have new values information.

Action: Add new values to the materialized view log using the ALTER MATERIALIZED VIEW LOG command.

ORA-32403 cannot use new values from mv log on "string"."string"

Cause: The materialized view log either does not have new values logged, or the timestamp associated with the new values columns is more recent than the last refresh time.

Action: Perform a complete refresh is required before the next fast refresh.

ORA-32404 snapshot log uses Change Data Capture which is not enabled for this database

Cause: A snapshot log that utilizes Change Data Capture is being imported to a database where Change Data Capture has not been enabled.

Action: First enable Change Data Capture on the database then retry the import.

ORA-32500 Dirname 'string' cannot exceed 'number' characters

Cause: Path name too long.

Action: Use shorter pathname than maximum specified for dirname.

ORA-32501 Writing SGA to file failed

Cause: Underlying OSDs encountered an error.

Action: Check additional information. slercerrno contains errno.

ORA-32502 Cannot execute command. Flash Freeze is not in effect

Cause: This command can only be issued after a flash freeze.

Action: Refer to instructions for flash freeze and Oracle diagnostics.

ORA-32503 Mapping SGA from file failed

Cause: Underlying OSDs encountered an error.

Action: Check additional information. slercerrno contains errno.

ORA-32504 expecting one of string, string, string, or string but found string

Cause: An illegal value was specified for create watchpoint mode.

Action: Specify one of the expected modes.

ORA-32505 too many watchpoints

Cause: Too many watchpoints created.

Action: Increase appropriate initialization parameters.

ORA-32506 expecting one of string, string, or string but found string

Cause: Invalid arguments were provided.

Action: Provide one of the expected arguments.

ORA-32507 expecting string but found string

Cause: Invalid arguments to the command were provided.

Action: Provide one of the expected arguments.

ORA-32508 no such watchpoint id

Cause: Invalid watchpoint ID.

Action: Use oradebug show to list valid watchpoint IDs.

ORA-32509 watchpoint was already deleted

Cause: An attempt was made to delete an already deleted watchpoint.

Action: Use oradebug show to list valid watchpoint IDs.

ORA-32510 cannot create watchpoint on unreadable memory

Cause: An attempt was made to create a watchpoint on an invalid address.

Action: Provide a different valid address.

ORA-32511 cannot create watchpoint in memory needed by watchpointing code

Cause: Overlap exists between requested memory range to watch and internal memory structures that watchpointing operations need.

Action: Provide a different address range.

ORA-32550 Replacement occurred despite hint to the contrary

Cause: This is an internal error.

Action: Contact Oracle Support Services.

ORA-32575 Explicit column default is not supported for modifying views

Cause: Default keyword was used to modify views.

Action: Use implicit default - omitting column-value pair.

ORA-32576 missing TYPE keyword

Cause: keyword TYPE is missing.

Action: Use TYPE keyword.

ORA-32577 username must be SYS or SYSTEM

Cause: A user name of SYS or SYSTEM was not specified when providing a password in the CREATE DATABASE statement.

Action: Only passwords for the SYS and SYSTEM users can be provided in the CREATE DATABASE statement. Re-issue the statement with passwords for users SYS or SYSTEM.

ORA-32578 password for SYS already specified

Cause: A password for the SYS user was specified twice in the CREATE DATABASE statement.

Action: Re-issue the CREATE DATABASE statement with only one password for the SYS user.

ORA-32579 password for SYSTEM already specified

Cause: A password for the SYSTEM user was specified twice in the CREATE DATABASE statement.

Action: Re-issue the CREATE DATABASE statement with only one password for the SYSTEM user.

ORA-32580 both SYS and SYSTEM passwords must be provided

Cause: Passwords for both the SYS and SYSTEM users were not provided in the CREATE DATABASE statement. If one of the passwords was provided, then both should be provided.

Action: Re-issue the CREATE DATABASE statement with a password for both the SYS and SYSTEM users.

ORA-32581 missing or invalid password

Cause: An incorrect password was provided for the SYS or SYSTEM users in the CREATE DATABASE statement.

Action: Re-issue the CREATE DATABASE statement with a valid password.

ORA-32582 table function with left correlation to a table cannot also be left outer-joined to the table

Cause: A table function T2 contains a reference to a table T1. Table function T2 is also left outer-joined to T1. This is not allowed.

Action: Remove the reference to T1 from T2 or remove the left outer-join specification.

ORA-32600 RETENTION and PCTVERSION cannot be used together

Cause: cannot use both RETENTION and PCTVERSION together.

Action: Use either RETENTION or PCTVERSION.

ORA-32601 value for retention cannot be provided

Cause: cannot give a value for Retention Period.

Action: do not provide the value for parameter.

ORA-32602 FREEPOOLS and FREELIST GROUPS cannot be used together

Cause: cannot use both FREEPOOLS and FREELIST GROUPS together.

Action: Use either FREEPOOLS or FREELIST GROUPS.

ORA-32603 invalid FREEPOOLS LOB storage option value

Cause: The specified FREEPOOLS LOB storage option value must be an integer.

Action: Choose an appropriate integer value and retry the operation.

ORA-32604 invalid REBUILD option

Cause: Keyword FREEPOOLS expected after the REBUILD keyword.

Action: User must specify FREEPOOLS keyword.

ORA-32605 invalid REBUILD option

Cause: Cannot rebuild freepools while creating table with lob column.

Action: User must not specify REBUILD ... in this context.

ORA-32700 error occurred in DIAG Group Service

Cause: An unexpected error occurred while performing a DIAG Group Service operation.

Action: Verify that the DIAG process is still active. Also, check the Oracle DIAG trace files for errors.

ORA-32730 Command cannot be executed on remote instance

Cause: DIAG is not registered with DIAG Group Service.

Action: Issue the command without the cluster database syntax.

ORA-32731 Another Parallel Oradebug session is in progress

Cause: Another session for Parallel Oradebug is in progress with the database.

Action: Issue the command later when the current session has finished.

ORA-32732 Parallel Oradebug session is aborted

Cause: Group reconfiguration is occurring among DIAGs.

Action: Issue the command later when group reconfiguration completes.

ORA-32733 Error occurred when executing Parallel Oradebug

Cause: Error is encountered during executing command at local node.

Action: Check alert log and DIAG trace file for error detail.

ORA-32734 Error occurred when sending Oradebug command to remote DIAGs

Cause: IPC communication problem encountered.

Action: Check IPC communication between DIAGs and issue the command again at a later time.

ORA-32735 DIAG process is not running in the instance

Cause: DIAG process is not alive.

Action: Check error in DIAG trace file and issue the command again when DIAG is restarted.

ORA-32736 Hang analysis aborted due to wrong message type

Cause: DIAG received wrong message.

Action: Check DIAG trace files for errors.

ORA-32737 Hang analysis aborted due to failed memory allocation

Cause: DIAG couldn't allocate buffer for remote copy.

Action: Check DIAG trace files for errors.

ORA-32738 Hang analysis aborted due to failed memory copy

Cause: DIAG couldn't copy buffer to remote node.

Action: Check DIAG trace files for errors.

ORA-32739 Hang analysis aborted due to failed heap re-grow

Cause: DIAG couldn't re-grow the heap for wait-for-graphs.

Action: Check DIAG trace files for errors.

ORA-32766 instr with negative offset: use varchar semantics on LOBs

Cause: The current varchar behavior is different. That is, instr('abcd', 'cd', -2, 1) returns 3, whereas instr(to_clob('abcd'), 'cd', -2, 1) returns 0, (for example, no match), because the reverse search starts from offset -2, which points to 'c' and moving backward, 'd' is ignored. This is symmetric to instr('dcba','dc',2,1), which returns 0.

Action: ORACLE uses the same varchar semantics on LOBs (instr). Using the same example, instr(to_clob('abcd'), 'cd', -2, 1) will return 3 as in the varchar case.


ORA-32800 to ORA-32999

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

15
ORA-32800 to ORA-32999

ORA-32800 internal error string

Cause: An unexpected error condition occurred.

Action: Contact Oracle Support Services.

ORA-32801 invalid value string for string

Cause: An invalid value was given for a parameter.

Action: Specify a valid value for the parameter.

ORA-32802 value for string must be string

Cause: An invalid value was given for a parameter.

Action: Specify the value as indicated by the message.

ORA-32803 value for string cannot be altered

Cause: An attempt was made to alter a value that cannot be altered.

Action: Retry the operation without altering the indicated value.

ORA-32804 invalid value string, string should have form string

Cause: A value specified for a parameter has the incorrect form.

Action: Specify a string of the correct form.

ORA-32805 identifier for string too long, maximum length is string characters

Cause: An identifier string exceeded the maximum allowed length.

Action: Specify a string whose length is less than the maximum.

ORA-32806 value for string is too long, maximum length is string

Cause: A value exceeded it's maximum allowed length.

Action: Specify a value whose length is less than the maximum.

ORA-32807 message system link string already exists

Cause: A message system link of the specified name already exists.

Action: Specify a different name.

ORA-32808 message system link string does not exist

Cause: A message system link of the specified name does not exist.

Action: Specify a message system link name that already exists.

ORA-32809 foreign queue string is already registered

Cause: The foreign queue has already been registered for this message system link (NAME@MSGLINK).

Action: Specify a different name that is not being used for this message system link.

ORA-32810 foreign queue string is not registered

Cause: The foreign queue (NAME@MSGLINK) has not been registered for this message system link.

Action: Specify the name of a registered foreign queue.

ORA-32811 subscriber string already exists

Cause: The specified subscriber identifier already exists.

Action: Specify a different identifier.

ORA-32812 subscriber string does not exist

Cause: The specified subscriber identifier does not exist.

Action: Specify a subscriber identifier that already exists.

ORA-32813 propagation schedule string already exists

Cause: The specified propagation schedule identifier already exists.

Action: Specify a different identifier.

ORA-32814 propagation schedule string does not exist

Cause: The specified propagation schedule identifier does not exist.

Action: Specify a schedule identifier that already exists.

ORA-32815 message system link string is referenced by a foreign queue

Cause: An attempt was made to remove a message system link currently referenced by one or more registered foreign queues.

Action: Unregister all foreign queues using this message system link and retry the operation.

ORA-32816 foreign queue string is referenced by a subscriber or schedule

Cause: An attempt was made to unregister a foreign queue currently referenced by one or more subscribers or propagation schedules.

Action: Remove all subscribers and propagation schedules using this foreign queue and retry the operation.

ORA-32817 message system link string is not configured with a log queue for string

Cause: An attempt was made to add a propagation subscriber but the message system link was not configured with a log queue for the indicated propagation type.

Action: Alter the message system link to configure the link with a log queue for this propagation type.

ORA-32818 AQ queue string does not exist

Cause: An operation was attempted where the specified AQ queue does not exist.

Action: Specify the name of an AQ queue that already exists.

ORA-32819 AQ queue string must be a normal queue

Cause: An operation was attempted where the specified AQ queue exists but is not a normal queue.

Action: Specify the name of an AQ queue which was created as a normal queue (NORMAL_QUEUE).

ORA-32820 subscriber queue and exception queue must use same message system link

Cause: An operation for INBOUND propagation was attempted where the specified subscriber queue and exception queue reference different message system links.

Action: Specify an exception queue that is a registered foreign queue of the same message system link as the subscriber queue.

ORA-32821 subscriber queue and exception queue must have same payload type

Cause: An operation for OUTBOUND propagation was attempted where the AQ queues used for the subscriber queue and exception queue have different payload types.

Action: Specify an exception queue that has the same payload type as the subscriber queue.

ORA-32822 subscriber string is marked for removal

Cause: An administration operation for a subscriber was attempted which is marked for removal. If attempting to remove a subscriber, then the Messaging Gateway agent is not running or is running but unable to remove the subscriber at this time.

Action: Do not issue propagation administration commands for a subscriber for which removal is pending. Wait for the subscriber to be removed by the agent or issue REMOVE_SUBSCRIBER with the FORCE option to force the subscriber to be removed.

ORA-32823 subscriber exists for queue string and destination string

Cause: An attempt was made to create a propagation subscriber when one already exists for the specified queue and destination pair.

Action: Specify a different queue and destination pair, or remove the subscriber using that pair and retry the operation.

ORA-32824 schedule exists for source string and destination string

Cause: An attempt was made to create a propagation schedule when one already exists for the specified source and destination pair.

Action: Specify a different source and destination pair, or remove the schedule using that pair and retry the operation.

ORA-32825 Messaging Gateway agent has not been started

Cause: An attempt was made to shut down Messaging Gateway agent when it is not started.

Action: No action required.

ORA-32826 Messaging Gateway agent has already been started

Cause: An attempt was made to start Messaging Gateway agent when it is already started.

Action: No action required.

ORA-32827 Messaging Gateway agent must be shut down

Cause: An operation was attempted that requires the Messaging Gateway agent to be shut down.

Action: Issue SHUTDOWN, wait for MGW_GATEWAY view to show NOT_STARTED status, and retry the operation. CLEANUP_GATEWAY may need to be issued to reset the gateway state if the agent fails to shut down after a reasonable amount of time.

ORA-32828 Messaging Gateway agent must be running

Cause: An operation was attempted that requires the Messaging Gateway agent to be started and responsive.

Action: Issue STARTUP, wait for MGW_GATEWAY view to show RUNNING status, and retry the operation.

ORA-32829 Messaging Gateway agent cannot be shut down while it is starting

Cause: An attempt was made to shut down Messaging Gateway agent when it is in the process of starting and initializing.

Action: Wait for MGW_GATEWAY view to show RUNNING status and retry the operation. CLEANUP_GATEWAY may need to be issued to reset the gateway state if the gateway fails to start after a reasonable amount of time.

ORA-32830 result code string returned by Messaging Gateway agent

Cause: Messaging Gateway agent terminated abnormally due to an unexpected error.

Action: Review the Messaging Gateway log file for further information regarding the problem. Resolve the problem and start the Messaging Gateway agent. Contact Oracle Support Services if the problem is unable to be resolved.

ORA-32831 timed out trying to acquire administration lock

Cause: A timeout occurred when attempting an administration operation. An attempt was made to perform an administration operation while Messaging Gateway agent is starting and initializing, or two administration operations were attempted at the same time.

Action: Retry the operation. If Messaging Gateway agent is starting, then wait for MGW_GATEWAY view to show RUNNING status.

ORA-32832 failure string trying to acquire administration lock

Cause: An unexpected error occurred trying to acquire administration lock.

Action: Retry the operation. Contact Oracle Support Services if the error persists.

ORA-32833 failure string trying to release administration lock

Cause: An unexpected error occurred trying to release administration lock.

Action: Contact Oracle Support Services if the error persists.

ORA-32834 Messaging Gateway agent user has not been set

Cause: Messaging Gateway agent user has not been configured.

Action: Create a database user having role MGW_AGENT_ROLE and issue DB_CONNECT_INFO to configure an agent user.

ORA-32835 database user string does not exist

Cause: The specified database user does not currently exist.

Action: Create the user and grant all necessary privileges and roles.

ORA-32836 database user string must be granted role string

Cause: The specified database user does not have a required role.

Action: Grant the user the indicated role.

ORA-32837 invalid configuration state string

Cause: Unexpected configuration state.

Action: Remove and re-create the configured entities. Contact Oracle Support Services if the problem is unable to be identified or resolved.

ORA-32838 exceeded maximum number of properties

Cause: An attempt was made to alter a property list where the number of properties in the resulting list exceeds the maximum allowed.

Action: Order the elements of the alter list differently so the number of elements in the resulting list is less than the maximum.

ORA-32839 property string is reserved, names with MGWPROP$_ prefix are not valid

Cause: An attempt was made to specify a reserved name for a property name.

Action: Use a non-reserved name.

ORA-32840 property name cannot be NULL

Cause: An attempt was made to use NULL for a property name.

Action: Specify a non-NULL name.

ORA-32841 invalid value for property string

Cause: An attempt was made to specify an invalid value for a property.

Action: Specify a valid property value.


ORA-33000 to ORA-65535

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

16
ORA-33000 to ORA-65535

ORA-33000 (AGOPEN00) %a workspace object string AGGMAP %p cannot be accessed because it was compiled by a more recent version of %p.

Cause: The AGGMAP was already compiled by a more recent version of the product than was being used to execute this command.

Action: Recompile the AGGMAP in the current version.

ORA-33002 (XSAGDNGL00) %a workspace object number number In AGGMAP %p, the FLOOR argument of %p must be less than the CEILING argument of %p.

Cause: A floor argument greater than the ceiling argument was specified.

Action: Adjust the floor and ceiling arguments so that the floor is less than the ceiling.

ORA-33004 (XSAGDNGL01) workspace object is not a relationship array.

Cause: A RELATION clause in the AGGMAP named a workspace object that is not a relation.

Action: Name a valid self-relation in the RELATION statement.

ORA-33006 (XSAGDNGL02) The relation workspace object is not related to itself.

Cause: A relation was named in a RELATION clause of the AGGMAP that is not a self-relation.

Action: Name a valid self-relation in the RELATION statement.

ORA-33008 (XSAGDNGL03) %a workspace object workspace object The relation %p is not a relation over a base dimension of AGGMAP %p.

Cause: A relation was named in a RELATION clause of the AGGMAP that is not a relation for a base dimension of the AGGMAP.

Action: Name a valid self-relation in the RELATION statement, that is, one that has a dimension that dimensions the AGGMAP.

ORA-33010 (XSAGDNGL04) %a workspace object workspace object Relation %p is duplicated in the AGGMAP %p.

Cause: Two RELATION statements in the AGGMAP reference the same relation object.

Action: Remove the duplicate RELATION statement.

ORA-33012 (XSAGDNGL05) AGGMAP workspace object contains invalid syntax.

Cause: A line in the AGGMAP contains invalid syntax.

Action: Change the line to have valid syntax.

ORA-33014 (XSAGDNGL06) %a workspace object workspace object workspace object In AGGMAP %p, variable operator %p cannot be dimensioned by rollup dimension %p.

Cause: Operator variables cannot have the rollup dimension as one of their base dimensions.

Action: Modify the definition of the operator variable so that the current rollup dimension is not one of its bases.

ORA-33016 (XSAGDNGL07) %a workspace object workspace object In AGGMAP %p, %p is not a valid operator or variable name.

Cause: An invalid argument was supplied to the OPERATOR clause in the relation statement.

Action: Fix the OPERATOR clause so that it specifies either a valid variable name or a valid operator.

ORA-33018 (XSAGDNGL08) %a workspace object workspace object string In AGGMAP %p, the datatype of %p must be TEXT, not %p.

Cause: An operator variable was supplied whose datatype is not TEXT.

Action: Change the operator clause to reference a TEXT variable.

ORA-33020 (XSAGDNGL09) %a workspace object number number In AGGMAP %p, the MIN argument of %p must be less than the MAX argument of %p.

Cause: The min argument was greater than the max argument.

Action: Adjust the min and max arguments so that min is less than max.

ORA-33022 (XSAGDNGL10) %a workspace object workspace object The measure dimension %p must be a TEXT or ID base dimension that does not dimension AGGMAP %p, but is in the same analytic workspace.

Cause: A MEASUREDIM was supplied in the AGGMAP that was not acceptable.

Action: Modify the MEASUREDIM clause to specify a valid dimension.

ORA-33024 (XSAGDNGL11) AGGMAP workspace object contains duplicate information.

Cause: The aggmap contains multiple instances of a clause that can only be specified once.

Action: Remove the extra clause.

ORA-33030 (XSAGDNGL14) In AGGMAP workspace object, you can have either a single independent PROTECT statement or PROTECT statements in your RELATION statements.

Cause: The AGGMAP either specified multiple PROTECT statements not on a RELATION line, or specified PROTECT statements both independently and on RELATION lines.

Action: Correct the AGGMAP to have valid syntax.

ORA-33036 (XSAGDNGL17) ARGS option workspace object must be a TEXT variable.

Cause: An ARGS value had a non-text datatype.

Action: Use a text variable for ARGS.

ORA-33046 (XSAGDNGL22) In AGGMAP workspace object, you can specify only one SCREENBY clause.

Cause: The AGGMAP contained multiple SCREENBY clauses.

Action: Remove one of the SCREENBY clauses from the AGGMAP.

ORA-33048 (XSAGDNGL23) %a workspace object workspace object workspace object In AGGMAP %p, the relation %p and the relation %p are both over the same base dimension.

Cause: The AGGMAP contains incompatible RELATION statements.

Action: Remove one of the RELATION statements from the AGGMAP.

ORA-33050 (XSAGDNGL24) %a workspace object workspace object AGGMAP %p cannot be used to aggregate %p, because %p is defined in a different analytic workspace.

Cause: The user attempted to aggregate a variable in another analytic workspace.

Action: Create an AGGMAP in the other analytic workspace to aggregate that variable.

ORA-33052 (XSAGDNGL25) AGGMAP workspace object is a dimensioned AGGMAP; it can only be used to aggregate like-dimensioned variables.

Cause: The user attempted to aggregate a variable with different dimensions than the AGGMAP. This is only possible with undimensioned AGGMAPs.

Action: Create a new undimensioned AGGMAP.

ORA-33054 (XSAGDNGL26) %a workspace object number number In AGGMAP %p, a MIN argument of %p must be less than a FLOOR argument of %p.

Cause: The user specified a MIN argument that was greater than or equal to the FLOOR argument.

Action: Reduce the MIN argument.

ORA-33056 (XSAGDNGL27) %a workspace object number number In AGGMAP %p, the MAX argument of %p must be greater than the CEILING argument of %p.

Cause: The user specified a MAX argument that was less than or equal to the CEILING argument.

Action: Increase the MAX argument.

ORA-33058 (XSAGDNGL28) %a workspace object string number In AGGMAP %p, error code %p is greater than the maximum error code of %p.

Cause: An invalud ERRORMASK value was specified.

Action: Remove the invalid value from the ERRORMASK list.

ORA-33060 (XSAGDNGL29) In AGGMAP workspace object, the value for the ERRORLOG MAX option must be greater than 0.

Cause: The user specified an ERRORLOG MAX of 0 or a negative number.

Action: Adjust the AGGMAP so that it uses a positive number.

ORA-33064 (XSAGDNGL31) %a workspace object workspace object In AGGMAP %p, the hierarchy dimension QDR %p cannot refer to the related dimension of the relation.

Cause: The user specified an invalid hierarchy dimension qualified data reference.

Action: Adjust the AGGMAP so that it uses a valid dimension value qualified data reference.

ORA-33066 (XSAGDNGL32) %a workspace object workspace object In AGGMAP %p, the hierarchy dimension QDR %p must be a hierarchy dimension of the relation.

Cause: The user specified an invalid qualified data reference for the hierarchy dimension.

Action: Adjust the AGGMAP so that it uses a valid dimension value qualified data reference.

ORA-33068 (XSAGDNGL33) %a workspace object workspace object In AGGMAP %p, the hierarchy dimension QDR over dimension %p must specify a positive dimension offset.

Cause: The user specified an invalid qualified data reference for the hierarchy dimension.

Action: Adjust the AGGMAP so that it uses a valid dimension value qualified data reference.

ORA-33070 (XSAGDNGL34) %a workspace object workspace object In AGGMAP %p, all QDRs of dimension %p must map to the same dimension position.

Cause: The user specified two conflicting hierarchy dimension qualified data references.

Action: Adjust the AGGMAP so that it uses a consistent qualified data reference.

ORA-33072 (XSAGDNGL35) %a workspace object workspace object In AGGMAP %p, the hierarchy dimension QDR over dimension %p must be specified for every relation dimensioned by that hierarchy dimension.

Cause: Multiple dimensions share the same hierarchy dimension, but it is only qualified within a subset of the AGGMAP relations.

Action: Adjust the AGGMAP so that it uses consistent qualified data references.

ORA-33074 (XSAGDNGL36) %a workspace object workspace object number In AGGMAP %p, the offset %p is not a valid offset into dimension %p.

Cause: The hierarchy dimension offset is an invalid dimension position.

Action: Adjust the AGGMAP so that it uses valid qualified data references.

ORA-33076 (XSAGDNGL37) %a workspace object workspace object number In AGGMAP %p, the value '%p' is not a valid value of dimension %p.

Cause: The hierarchy dimension offset is an invalid dimension position.

Action: Adjust the AGGMAP so that it uses valid qualified data references.

ORA-33078 (XSAGDNGL39) %a workspace object workspace object In AGGMAP %p, the hierarchy dimension QDR %p must refer to a dimension.

Cause: The user specified an invalid qualified data reference for the hierarchy dimension.

Action: Adjust the AGGMAP so that it uses a valid dimension value qualified data reference.

ORA-33080 (XSAGDNGL40) %a workspace object workspace object In AGGMAP %p, you cannot reference dimension %p with both a RELATION statement and a DIMENSION statement.

Cause: The user included both RELATION and DIMENSION statements in the AGGMAP referring to the same AGGMAP.

Action: Remove one of the conflicting clauses.

ORA-33082 (XSAGDNGL41) %a workspace object workspace object In AGGMAP %p, the non-dimensioned valueset %p must have a parent QDR in its VALUESET statement over the VALUESET's base dimension.

Cause: The VALUESET statement specified a scalar valueset but did not include a qualified data reference to specify the parent.

Action: Add a qualified data reference specifying the parent to the VALUESET statement.

ORA-33084 (XSAGDNGL42) %a workspace object workspace object In AGGMAP %p, you cannot qualify the dimensioned valueset %p.

Cause: The VALUESET line referred to a dimensioned valueset.

Action: Use a non-dimensioned valueset to limit the status of the dimensioned one.

ORA-33086 (XSAGINIT01) %a workspace object workspace object AGGMAP %p cannot be dimensioned by a conjoint dimension.

Cause: The specified AGGMAP was dimensioned by a conjoint dimension.

Action: Use the CHGDFN command to change the conjoint to a composite dimension.

ORA-33092 (XSAGCOMP04) number is not the name of a MODEL in any attached analytic workspace.

Cause: An invalid model name was attached to an AGGMAP.

Action: Remove the model from the AGGMAP or create a model with that name.

ORA-33098 (APABBR01) %a string workspace object A value of '%p' is not valid for the %p option.

Cause: An inappropriate value was specified for the named option.

Action: Set a legal value for the option.

ORA-33100 (APABBR02) %a number workspace object Value '%p' is not valid for the %p option.

Cause: An inappropriate value was specified for the named option.

Action: Set a legal value for the option.

ORA-33218 (CINSERT04) %a value workspace object number number %p is not a valid value for the %p dimension. Values for this dimension can have at most %p significant digits after rounding to %p decimal places.

Cause: The user attempted to insert a value that had too many digits into a NUMBER dimension. For instance, the user might have tried to insert the value 99999 (5 digits) into a dimension with datatype NUMBER(4).

Action: Use a smaller number for the dimension value, or define a new dimension with a larger precision and replace the old dimension with the new one.

ORA-33300 (DBERR22) %a string string Analytic workspace %p cannot be opened because it was last modified by an incompatible version of %p.

Cause: The user attempted to attach an old OLAP Services analytic workspace that cannot be converted by this version of OLAP Services.

Action: Either create a new analytic workspace or try using a version of OLAP Services compatible with the one that created this analytic workspace.

ORA-33332 (DSSEXIST01) Use the AW command to establish a current analytic workspace. Then start your current activity again.

Cause: There is no currently active analytic workspace. The command that generated the error requires an active analytic workspace on which to operate.

Action: Execute an AW ATTACH or AW CREATE command to establish an active workspace.

ORA-33334 (DSSEXIST04) Analytic workspace string is not attached.

Cause: The specified analytic workspace is currently not attached to the session, or the name is misspelled.

Action: Attach the analytic workspace with the AW ATTACH command, or correct the spelling of the name .

ORA-33336 (DSSEXIST04A) Analytic workspace string is not attached.

Cause: The specified analytic workspace is currently not attached to the session, or the name is misspelled.

Action: Attach the analytic workspace with the AW ATTACH command, or correct the spelling of the name .

ORA-33338 (DSSEXIST05) You cannot specify the EXPTEMP analytic workspace.

Cause: The command requires a non-temporary analytic workspace on which to operate.

Action: Specify an analytic workspace other than EXPTEMP.

ORA-33425 (EIFMAKEF15) CAUTION: Exporting NTEXT objects using string for the EIF file character set can cause loss of data. To preserve all NTEXT data, export using the UTF8 character set for the EIF file.

Cause: The user exported an object with datatype NTEXT, but the EIF file that will result from the EXPORT command is not written in Unicode. Because no non-Unicode file can represent all possible Unicode data, it is possible that some data will be lost when converting from the Unicode NTEXT object to the EIF file. The EIF file will be written in the character set indicated by the "nls_charset" argument of the EXPORT command, or, if no such argument is present, in the database character set.

Action: If the user is certain that the contents of the NTEXT object can be represented in the specified character set, then no action is necessary. Otherwise, the user can add "nls_charset 'UTF8'" to the EXPORT command string. This will result in the EIF file being written in UTF8 Unicode, which can represent all the data contained in NTEXT objects.

ORA-33427 (EIFMAKEF16) CAUTION: NTEXT object workspace object will be exported with type TEXT.

Cause: User attempted to export an object whose datatype is NTEXT, but the EIFVERSION option indicates a version of Express / Oracle OLAP that does not support the NTEXT datatype. The object will be exported as a TEXT object instead.

Action: No action required.

ORA-33429 (EIFMAKEF17) CAUTION: NTEXT expression will be exported with type TEXT.

Cause: User attempted to export an expression whose datatype is NTEXT, but the EIFVERSION option indicates a version of Express / Oracle OLAP that does not support the NTEXT datatype. The expression will be exported as a TEXT object instead.

Action: No action required.

ORA-33443 (ESDREAD14) %a workspace object string Discarding compiled code for %p because analytic workspace %p is not attached.

Cause: A program used an analytic workspace name in a qualified object name. The named analytic workspace is not attached at program run time.

Action: No action required. The program will be automatically recompiled. It is likely that the recompile will fail with an appropriate exception code, in which case the signaled condition should be corrected and the program re-run.

ORA-33468 (ESDREAD13) %a workspace object number workspace object Discarding compiled code for %p because %p is no longer a surrogate of dimension %p.

Cause: When the compiled code was saved, the specified object was a surrogate of a certain dimension. Now the specified object is a surrogate of a different dimension.

Action: No action required; program automatically recompiles.

ORA-33918 (MAKEDCL33) %a workspace object string You cannot define a surrogate of dimension %p because it is a %p.

Cause: Not all kinds of dimensions can have surrogates. The user attempted to define a surrogate of a prohibited kind of dimension.

Action: Do not attempt to define a surrogate on this dimension.

ORA-33920 (MAKEDCL34) The string SURROGATE must have one of the following datatypes: ID, NTEXT, TEXT, NUMBER, or INTEGER.

Cause: The user attempted to define a surrogate without specifying a valid datatype.

Action: Specify the datatype (ID, NTEXT, TEXT, NUMBER, or INTEGER) in the definition of the surrogate.

ORA-33922 (MAKEDCL35) You cannot define a surrogate of dimension workspace object because it is a date dimension.

Cause: The user attempted to define a surrogate on a dimension that has type DAY, WEEK, MONTH, or YEAR.

Action: Do not attempt to define a surrogate on this dimension.

ORA-33998 (MODCOMP12) %a workspace object workspace object workspace object workspace object You cannot use both %p and %p as model dimensions, because %p is a surrogate of %p.

Cause: The user attempted to include both a dimension and its surrogate in the DIMENSION statement of a model.

Action: Use either the dimension or the surrogate in the DIMENSION statement of the model, but not both.

ORA-34000 (MODCOMP13) %a workspace object workspace object workspace object You cannot use both %p and %p as model dimensions, because they are both surrogates of dimension %p.

Cause: The user attempted to include two dimension surrogates of the same dimension in the DIMENSION statement of a model.

Action: Use either of the two surrogates in the DIMENSION statement of the model, but not both.

ORA-34141 (MXCGPUT00) You cannot use the ASSIGN keyword with DIMENSION workspace object.

Cause: User used the ASSIGN keyword on a DIMENSION target in a FILEREAD or SQL FETCH command.

Action: To create a new dimension value in a FILEREAD or SQL FETCH command, use the APPEND keyword.

ORA-34143 (MXCGPUT02) You cannot assign values to SURROGATE workspace object because it is type INTEGER.

Cause: The user attempted to assign a value to a dimension surrogate whose datatype is INTEGER. INTEGER surrogates, like INTEGER dimensions, cannot have values assigned to them. They can only be referenced by position.

Action: Do not attempt to assign values to an INTEGER surrogate. Values will automatically appear and disappear from the INTEGER surrogate as positions are added to or removed from the underlying dimension.

ORA-34145 (MXCGPUT03) You cannot use the APPEND keyword with SURROGATE workspace object.

Cause: User used the APPEND keyword on a SURROGATE target in a FILEREAD or SQL FETCH command.

Action: To assign a value to a SURROGATE in a FILEREAD or SQL FETCH command, use the ASSIGN keyword.

ORA-34210 (MXCHGDCL18) You cannot change workspace object to a dimension composite because one or more surrogates has been defined for it.

Cause: The user attempted to redefine a conjoint dimension as a composite, but the conjoint has one or more surrogates defined. A dimension that has surrogates cannot be redefined as a composite.

Action: Either delete all surrogates for the dimension, or do not attempt to redefine the dimension as a composite.

ORA-34276 (MXDCL33) (Precision, Scale) arguments can only be used with a NUMBER variable or dimension.

Cause: The user attempted to use NUMBER(Precision) or NUMBER(Precision, Scale) as the datatype in a definition for some object other than a DIMENSION or VARIABLE, such as a FORMULA or PROGRAM. This error can also be produced in cases where a NUMBER datatype is not allowed at all.

Action: Use the NUMBER type without specifying a precision or scale. If a NUMBER datatype is not allowed at all, then this fix will only change the exception message to something more specific.

ORA-34296 (MXDCL36) A NUMBER dimension must be defined with a fixed precision and scale, using the form NUMBER(precision) or NUMBER(precision, scale).

Cause: The user attempted to define a NUMBER dimension without specifying a precision. The proper format for declaring a number dimension is NUMBER(Precision) or NUMBER(Precision, Scale). NUMBER with no precision or scale is not allowed.

Action: Use NUMBER(Precision) or NUMBER(Precision, Scale) to specify the datatype of a NUMBER dimension.

ORA-34342 (MXDSS01) IMPORTANT: Analytic workspace string is read-only. Therefore, you will not be able to use the UPDATE command to save changes to it.

Cause: This is an informational message that reminds you that you may not save changes to the specified analytic workspace.

Action: No action required, unless it was desired to save changes to the analytic workspace. In that case, detach and reattach the analytic workspace read-write.

ORA-34344 (MXDSS03) Analytic workspace string is not attached.

Cause: The command attempted to operate on an analytic workspace that is not currently attached, or the name of the analytic workspace is misspelled.

Action: Attach the analytic workspace or correct the spelling.

ORA-34346 (MXDSS04) The string analytic workspace cannot be detached.

Cause: The specified analytic workspace is an internal workspace and may not be detached by the user.

Action: Specify a different analytic workspace to detach.

ORA-34348 (MXDSS05) string is used only for internal purposes and cannot be accessed as an analytic workspace.

Cause: The command attempted to operate on an internal analytic workspace used by the system.

Action: Specify a different analytic workspace.

ORA-34350 (MXDSS06) string is an open analytic workspace.

Cause: The specified analytic workspace is currently in use.

Action: The desired action requires an analytic workspace that is not currently in use.

ORA-34357 (MXDSS10) %a string string %p is not an alias of analytic workspace %p.

Cause: User attempted to use AW UNALIAS on a non-existent alias.

Action: Make sure that the command specified the correct analytic workspace and alias. The alias must have been assigned (using AW ALIAS) during the current session and must not have been removed by a previous AW UNALIAS or AW DETACH command.

ORA-34359 (MXDSS11) string appears twice in the alias list.

Cause: User included the same name twice in the alias list of an AW ALIAS or AW UNALIAS command.

Action: Remove the duplicate name and try again.

ORA-34489 (MXMAINT06) You cannot maintain workspace object because it is a SURROGATE.

Cause: The user attempted to use the MAINTAIN command on a dimension surrogate. The MAINTAIN command can only be used with real dimensions, not surrogates.

Action: Use the MAINTAIN command to modify the underlying dimension of the surrogate instead.

ORA-34514 (MXOPERR) %a string string string You cannot %p %p data in the expression that begins with '%p'.

Cause: The user attempted an invalid operation.

ORA-34719 (NLSCHARSET03) Character data loss in NTEXT/TEXT conversion

Cause: When character set conversion happens between TEXT and NTEXT either implicitly or explicitly, some characters are lost due to no mapping characters in the destination character set.

Action: Make sure all the characters can be mapped to destination character sets or set the NLS_NCHAR_CONV_EXCP initialization parameter to false.

ORA-35276 (SNSYN163) The format of the ALLOCATE command is: ALLOCATE varname [SOURCE svarname] [BASIS bvarname [ACROSS dimname]] [TARGET tvarname [TARGETLOG logvarname]] USING aggmap

Cause: The user used incorrect syntax for the ALLOCATE command.

Action: Correct the calling syntax.

ORA-35280 (SNSYN165) The format of the AGGREGATE command is: AGGREGATE varname1 [varname2 varname3 ...] USING aggmap-name [COUNTVAR intvar-name1 [intvar-name2 intvar-name3 ...]] [FUNCDATA] [THREADS #]

Cause: The user used incorrect syntax for the AGGREGATE command.

Action: Correct the calling syntax.

ORA-35282 (SNSYN166) The format of the AGGREGATE function is: AGGREGATE(varname USING aggmap-name [COUNTVAR intvar-name] [FORCECALC])

Cause: The user used incorrect syntax for the AGGREGATE function.

Action: Correct the calling syntax.

ORA-36178 (XSAGGR01) To be used with AGGREGATE, AGGMAP workspace object must be declared with the AGGMAP command.

Cause: The user used the ALLOCMAP command to define the AGGMAP, so the AGGMAP can only be used with the ALLOCATE command, or the AGGMAP has no contents attached to it.

Action: Use the AGGMAP command to define the AGGMAP.

ORA-36180 (XSAGGR08) AGGREGATE cannot function because there is a permission clause associated with variable workspace object.

Cause: When using AGGREGATE, only simple permissions and permissions on base dimensions are valid.

Action: Remove the permissions clause from the variable causing problems.

ORA-36182 (XSAGGR09) %a workspace object number Could not locate a value for variable %p in measure dimension %p.

Cause: A measure dimension was supplied in the AGGMAP, but a position for the variable was not found in it.

Action: Add a position for the variable in the measure dimension.

ORA-36184 (XSAGGR10) You do not have sufficient permissions for the variable workspace object.

Cause: The user lacked the permissions necessary for the aggregation variable.

Action: Remove the restricting permissions from the variable or base dimension.

ORA-36188 (XSAGGR16) AGGREGATE read a value less than 1 out of COUNTVAR variable workspace object. Either the values of the COUNTVAR variable are stored improperly, or there is a problem in AGGREGATE. If no one has modified the values in this COUNTVAR, contact Oracle Support Services.

Cause: Either someone improperly changed the COUNTVAR variable, or AGGREGATE has an error.

Action: Set the COUNTVAR variable to NA before starting AGGREGATE. If you previously set the COUNTVAR variable to NA, then contact Oracle Support Services.

ORA-36198 (XSAGGR33) %a string workspace object number workspace object The AGGREGATE operator %p does not require a weight, but ARGS variable %p with text 'number' specified %p as a weight.

Cause: The ARGS variable specified a weight even though one is not needed.

Action: Modify the ARGS variable so that it does not specify a weight for that operation.

ORA-36200 (XSAGGR34) %a string workspace object string AGGREGATE operator %p requires a WEIGHTBY clause, but ARGS variable %p did not specify one with text expression "%p".

Cause: The given operator requires a WEIGHT specification, but the ARGS variable did not supply one.

Action: Modify the ARGS variable to specify a weight for the operation.

ORA-36202 (XSAGOP01) 'number' is not a valid aggregation operator.

Cause: An invalid string was provided for an aggregation operator.

Action: Check the spelling of the operator to make sure you are specifying a valid one.

ORA-36204 (XSAGOP04N) %a workspace object string In AGGMAP %p, the NAOPERATOR %p must be HFIRST, HLAST or HEVEN.

Cause: An invalid NAOPERATOR was specified.

Action: Specify HFIRST, HLAST or HEVEN.

ORA-36206 (XSAGOP04R) %a workspace object string In AGGMAP %p, REMOPERATOR %p must be MIN, MAX, FIRST, LAST, HFIRST, or HLAST.

Cause: An invalid REMOPERATOR was specified.

Action: Specify one of the legal operators.

ORA-36208 (XSAGOP05N) %a workspace object string string In AGGMAP %p, you can only specify NAOPERATOR %p with the PROPORTIONAL or EVEN operators, not %p.

Cause: The user specified an NAOPERATOR when you were not using PROPORTIONAL or EVEN.

Action: Remove the NAOPERATOR clause from the RELATION line.

ORA-36210 (XSAGOP05R) %a workspace object string string In AGGMAP %p, you can only specify the REMOPERATOR %p with the PROPORTIONAL, EVEN, or HEVEN operators, not %p.

Cause: The user specified a REMOPERATOR without using PROPORTIONAL, EVEN, or HEVEN.

Action: Remove the REMOPERATOR clause from the RELATION line.

ORA-36212 (XSAGOP06) %a workspace object string In AGGMAP %p, you can only specify the MIN, MAX, FLOOR, and CEILING arguments while using the PROPORTIONAL operator, not %p.

Cause: The user specified MIN, MAX, FLOOR, or CEILING when using an operator other than PROPORTIONAL.

Action: Remove the incorrect argument from the RELATION line.

ORA-36258 (XSAGINFO00) When the AGGMAPINFO function is called, workspace object must be an AGGMAP.

Cause: The AGGMAPINFO function was called with an object that is not an AGGMAP.

Action: Modify the call to AGGMAPINFO to specify an AGGMAP object.

ORA-36260 (XSAGINFO01) You specified an invalid keyword when calling the AGGMAPINFO function.

Cause: The call to AGGMAPINFO is invalid.

Action: Modify the call to specify a valid syntax.

ORA-36290 (EIFMAKEF14) %a workspace object number You cannot export object %p, because EIFVERSION is set to %p. That version does not support dimensions of type NUMBER.

Cause: The user tried to export a NUMBER dimension to an EIF file with the EIFVERSION option set to a number less than 80000. Versions previous to that eversion do not support NUMBER dimensions.

Action: A NUMBER dimension cannot be used in a version older than 9.2.0. If the EXPORT file is going to be read by version 9.2.0 or higher, then set EIFVERSION to a number greater than or equal to 80000 and execute the EXPORT command again.

ORA-36342 (SNSYN200) The format of the CLEAR command is: CLEAR [ ALL | STATUS ] [ CHANGES | PRECOMPUTES | NONPRECOMPUTES | CACHE ] FROM var1 [var2, var3...] [USING aggmap]

Cause: The syntax for the CLEAR command was invalid.

Action: Modify your syntax using the correct format.

ORA-36376 (XSAGZERO) AGGREGATE attempted to divide by zero. Set DIVIDEBYZERO to YES if you want NA to be returned as the result of a division by zero.

Cause: A calculation in the current AGGREGATE command attempted to divide by zero as a result of an AVERAGE, WAVERAGE, HAVERAGE or HWAVERAGE operation.

Action: Either fix the data, or set DIVIDEBYZERO to YES to return NA instead of signalling an error.

ORA-36378 (XSAGTHRWEIGHT) %a workspace object workspace object workspace object While running AGGREGATE with multiple threads, the weight variable %p specified by your ARGS variable %p must exist in the same analytic workspace as your AGGMAP %p.

Cause: While running AGGREGATE in threaded mode, you attempted to specify a WEIGHT variable in another analytic workspace.

Action: Use a weight variable from the same analytic workspace as the aggmap and rollup variable.

ORA-36380 (AGGRECURSE) AGGREGATE was called recursively, which is not allowed.

Cause: A model, NATRIGGER, or other object called the AGGREGATE function or command while another AGGREGATE function or command was already in progress.

Action: Modify your objects so that they do not need to have two AGGREGATE commands or functions executing at once.

ORA-36608 (XSAGHOVERFLOW) The depth of the hierarchies encountered while processing a composite dimension in AGGREGATE caused a counter overflow.

Cause: The depth of the hierarchies that are part of a composite exceeded 4 billion levels during the merge.

Action: Reduce the number of levels in the hierarchies, reduce the number of dimensions in the composite, or do not aggregate over all dimensions at once.

ORA-36610 (XSLMS00) %a value value Unable to locate a message file for product '%p' and facility '%p'.

Cause: An application called the INTL.MESG function with an incorrect or uninstalled product / facility combination.

Action: Make sure that the appropriate binary message file is stored on the host in the correct location:

ORACLE_HOME/product/facilitylanguage.msb

ORA-36612 (XSLMS01) %a value value value An application attempted to retrieve a non-existent user message. (Product: %p, Facility: %p, Message Number: %p)

Cause: The caller of INTL.MESG tried to retrieve a non-existent message.

Action: Add the message to the application's message file, and recompile or reinstall the binary message file.

ORA-36614 (XSLMS02) %a string number %p attempted to retrieve a nonexistent user message. (Message number %p)

Cause: An internal Oracle OLAP error occurred. Oracle OLAP attempted to retrieve a message that does not exist in the installed message file OLAP_HOME/aps*.msb.

Action: Ignore this error message.

ORA-36616 (XSAGMODHIER01) %a workspace object workspace object MODEL %p cannot be added to AGGMAP %p, because it is dimensioned by a dimension not contained in the AGGMAP.

Cause: The dimension of the model is not a dimension of the aggmap.

ORA-36628 (XSAGMODLIST03) %a workspace object workspace object MODEL %p could not be added to AGGMAP %p.

Cause: The dimension of the model must match a hierarchy of the aggmap.

Action: Add a RELATION statement to the AGGMAP for that dimension.

ORA-36630 (XSDUNION00) An empty CONCAT dimension list was specified.

Cause: An empty union DIMENSION list was specified.

Action: Specify a valid list of dimensions when defining a union DIMENSION.

ORA-36634 (XSDUNION02) INTEGER dimension workspace object cannot be used as a CONCAT dimension base.

Cause: The user cannot specify a prefix list or the UNIQUE keyword when defining a MERGE DIMENSION.

ORA-36636 (XSDUNION03) The CONCAT base dimensions have inconsistent datatypes.

Cause: The union dimension's base dimensions have inconsistent datatypes.

Action: Specify a valid list of dimensions when defining CONCAT DIMENSION.

ORA-36638 (XSDUNION04) workspace object is an invalid CONCAT prefix dimension.

Cause: An invalid prefix list dimension was specified.

Action: Specify a valid prefix list when defining CONCAT DIMENSION.

ORA-36640 (XSDUNION05) An invalid or ambiguous prefix was specified for workspace object.

Cause: An invalid or ambiguous prefix was specified.

Action: Specify a valid prefix list when defining a union DIMENSION.

ORA-36642 (XSDUNION06) Duplicate CONCAT dimension workspace object found

Cause: A duplicate CONCAT dimension was found.

ORA-36644 (XSDUNION07) CONCAT dimension workspace object contains a previously detected leaf dimension.

Cause: Union dimension contains a previously detected leaf dimension.

ORA-36688 (NTEXTCNV00) Error during conversion from TEXT to NTEXT

Cause: An unknown character set conversion error occurred when converting a TEXT value to an NTEXT value.

ORA-36690 (NTEXTCNV01) Error during conversion from NTEXT to TEXT

Cause: An unknown character set conversion error occurred when converting an NTEXT value to a TEXT value.

ORA-36691 (NTEXTCNV02) Invalid escape sequence in argument to UNISTR function: string

Cause: The user called the UNISTR function on a string that had an invalid escape sequence. The only valid escape sequences in UNISTR are:

  1. An escape-escape sequence
  2. An escape, followed by exactly four hexadecimal digits

Action: Make sure that all escape sequences in UNISTR arguments are exactly four hexadecimal digits. To represent codepoints whose value is less than 0x1000, use preceding zeros. WRONG: 0x10; RIGHT: 0x0010.

ORA-36692 (XSRELTBL00) The format of the HIERHEIGHT command is: HIERHEIGHT relation1[(dimension dimvalue, ...)] into relation2 [using relation3 | a | d]

Cause: The user input the wrong format or object types.

Action: Make sure number of arguments and all object types are correct.

ORA-36694 (XSRELTBL01) The value cannot be added to dimension workspace object.

Action: Check the context and permission for dimension maintainance.

ORA-36696 (XSRELTBL02) QDR dimension workspace object should not be the related dimension of the relation.

Cause: Try to limit relation dimension using qdr list.

Action: Delete the part of qdr list for relation dimension.

ORA-36698 (XSRELTBL03) QDR dimension workspace object should be in the dimension list that dimensions the relation.

Cause: Use other dimensions than dimensions in relation dimensions.

Action: Make sure all dimensions of qdrs dimension the relation.

ORA-36700 (XSRELTBL04) QDR dimension workspace object repeats.

Cause: Repeat the qdr dimension.

Action: Delete the repeated qdr.

ORA-36702 (XSRELTBL05) The format of the HIERHEIGHT function is: HIERHEIGHT(relation [,] level) level >= 1.

Cause: The HIERHEIGHT function was specified incorrectly.

Action: Make sure the format is correct.

ORA-36704 (XSRELTBL06) %a workspace object workspace object %p should be dimensioned by %p.

Cause: The level relation is not dimensioned by the source relation dimension.

Action: Make sure the level relation has the correct definition.

ORA-36706 (XSRELTBL07) %a workspace object workspace object %p should be dimensioned by %p and one integer/number dimension.

Cause: The destination relation has the wrong definition.

Action: Make sure the destination relation has the correct dimensions.

ORA-36708 (XSMXALLOC00) Variable workspace object must be dimensioned to be used by the ALLOCATE command.

Cause: The user supplied an undimensioned (scalar) variable to the ALLOCATE command.

Action: Use a dimensioned variable.

ORA-36710 (XSMXALLOC01) %a workspace object workspace object TARGETLOG variable %p must be dimensioned identically to TARGET variable %p.

Cause: The user attempted to execute ALLOCATE with mismatching TARGET and TARGETLOG variables.

Action: Use TARGET and TARGETLOG variables with matching dimensionality.

ORA-36712 (XSMXALLOC02) Relation workspace object must be a one-dimensional self-relation to be used as a SOURCE or BASIS with ALLOCATE.

Cause: The user specified an invalid source or basis relation on the ALLOCATE command line.

Action: Modify the relation to be a one-dimensional self-relation.

ORA-36714 (XSMXALLOC03) %a workspace object workspace object TARGETLOG variable %p must have the same datatype as TARGET variable %p.

Cause: The user specified a TARGETLOG variable that had a different datatype from the TARGET variable.

Action: Use TARGETLOG and TARGET variables with an identical datatype.

ORA-36716 (XSMXALLOC04) %a workspace object workspace object You can only use the ACROSS phrase when allocation BASIS %p is a FORMULA.

Cause: The user specified an ACROSS composite when the BASIS is not a FORMULA.

Action: Remove the ACROSS phrase or use a FORMULA for the BASIS.

ORA-36718 (XSALLOC00) You do not have the necessary permissions to use AGGMAP workspace object.

Cause: The user did not have sufficient permissions to run the ALLOCATE command.

Action: Change to a user ID with the appropriate permissions, or use objects that you have permission to use.

ORA-36720 (XSALLOC01) To be used with ALLOCATE, your AGGMAP workspace object must be defined with the ALLOCMAP command.

Cause: The user used the AGGMAP command to define the AGGMAP, so either the AGGMAP can only be used with the AGGREGATE command, or the AGGMAP has no contents attached to it.

Action: Use the ALLOCMAP command to define the AGGMAP.

ORA-36722 (XSALLOC02) %a workspace object workspace object In AGGMAP %p, you specified an NA or ZERO sourceval but supplied formula %p as your source for ALLOCATE.

Cause: The user requested that source values be modified during the allocation, but that is not possible when using a formula source.

Action: Either use a VARIABLE source or remove the SOURCEVAL specification for your ALLOCMAP.

ORA-36726 (XSALERR00) The character 'character' is not a valid format specifier for the ALLOCATE error log.

Cause: The user specified an invalid formatter in the ALLOCERRLOGHEADER or ALLOCERRLOGFORMAT options.

Action: Correct the option to have a valid format.

ORA-36728 (XSALERR01) %a workspace object number While performing the ALLOCATE command with AGGMAP %p, the error logging limit of %p was exceeded.

Cause: The user specified an ERRORLOG MAX value in the ALLOCMAP, but more errors were encountered while performing the allocation.

Action: Either set ERRORLOG NOSTOP, reduce the allocation errors, or// increase the ERRORLOG MAX setting.

ORA-36742 (XSRELTBL08) %a string workspace object %p is not a valid qualified data reference for dimension %p.

Cause: The qdr is not in its dimension.

Action: Make sure the qdr is in its dimension.

ORA-36744 (XSRELTBL09) workspace object is not a valid level relation.

Cause: The level relation includes the invalid content.

Action: In level relation, all parents should be always either greater or less than their children.

ORA-36746 (XSRELTBL10) workspace object must be a dimension.

Cause: Use other objects than dimension in qdr list.

Action: Must use dimensions only in qdr list.

ORA-36748 (XSRELTBL11) workspace object must be a relation.

Cause: Wrong object type for either source or destination.

Action: Give the correct object.

ORA-36750 (XSRELTBL12) workspace object must be a self-relation.

Cause: Source relation is not self-relation.

Action: Give a self-relation as source.

ORA-36752 (XSRELTBL13) %a workspace object workspace object Relation %p must be dimensioned by %p.

Cause: Destination relation is not dimensioned by source relation dimension.

Action: Give a correct destination relation.

ORA-36756 (XSRELGID00) The format of the GROUPINGID command is: GROUPINGID relation1 INTO {variable | relation2}

Cause: Command format is not correct.

Action: Check the object type and number, and give the correct format.

ORA-36758 (XSRELGID01) workspace object must be a self-relation.

Cause: Source relation is not a self-relation.

Action: Give a source relation as self-relation.

ORA-36760 (XSRELGID02) Variable workspace object must have a numeric datatype.

Cause: Destination variable is not numeric type variable.

Action: Make sure the variable is numeric.

ORA-36762 (XSRELGID03) The grouping variable/relation workspace object must be dimensioned by all dimensions of the source relation workspace object which have more than one element in status.

Cause: Destination variable/relation does not have enough dimensionality to hold the result from the multi-dimensional source relation.

Action: Either limit the status of hierarchy dimensions or redefine the destination variable/relation with the extended dimensionality.

ORA-36764 (XSRELGID04) A value cannot be inserted into dimension workspace object.

Action: Make sure the dimension can be inserted.

ORA-36766 (XSRELGID05) %a workspace object workspace object Relation %p must be dimensioned by %p.

Cause: The destination relation is not dimensioned by the dimension of the source relation.

Action: Change the definition of the destination relation to be dimensioned by the dimension of the source relation.

ORA-36768 (XSRELGID06) The related dimension of relation workspace object must be of type NUMBER.

Cause: The destination relation has the wrong dimension type.

Action: Change the definition of the destination relation so that its dimension is an Oracle number.

ORA-36780 (IOSEC01) Current Directory Alias is not set. Cannot complete string.

Action: Use CDA command to set current directory alias or include the directory alias in the file name.

ORA-36782 (IOSEC02) Directory Alias used in string does not exist, or you do not have sufficient privileges to access it.

Action: Use CREATE DIRECTORY name AS 'path'. Then grant privileges to that directory alias.

ORA-36788 (IOSEC05) Access to the directory specified by string denied.

Action: Use GRANT command to assign permissions to the directory alias.

ORA-36800 (XSTBLFUNC00) The OLAP_TABLE function can only have a single LOOP statement within the LIMITMAP

Cause: The given olap table function used more than one LOOP statement.

Action: It is currently impossible to specify more than one LOOP composite, either remove one of the statements (and loop densly over relevant dimensions), or create a new composite that encompasses both loops and have a single loop statement refer to that.

ORA-36802 (XSTBLFUNC01) The OLAP_TABLE function must contain a DATAMAP that executes a FETCH command or a LIMITMAP

Cause: There is no limitmap on the table function and either the datamap does not contain a fetch, or it errored before the fetch was called.

Action: Check the datamap for errors, make sure that it executes a fetch statement, if it is not intended to execute the fetch then make sure that the table function has a valid limitmap.

ORA-36804 (XSTBLFUNC02) The OLAP_TABLE function encountered an error while parsing the LIMITMAP

Cause: Invalid LIMITMAP syntax, or the name resolution failure of an ANALYTIC WORKSPACE OBJECT.

Action: Check the syntax of the limit map, check that the OLAP_TABLE function refers to a valid analytic workspace, and check that all analytic workspace objects within the limitmap actually exist within the analytic workspace.

ORA-36806 (XSTBLFUNC03) The OLAP_TABLE function refers to an invalid ADT attribute: string

Cause: The limitmap refers to a matching of ADT attribute to AW object, but the ADT attribute is not an element of the specified ADT table. Most commonly this is a typographical error.

Action: Add the attribute to the ADT, correct the LIMITMAP, or remove the reference from the LIMITMAP.

ORA-36902 (XSAGDNGL43) %a workspace object workspace object In AGGMAP %p, MODEL %p cannot be calculated dynamically because it contains simultaneous/step equations or equations which refer to variables.

Cause: Model may include equations other than dimension values, or blocks other than simple blocks.

Action: Make sure model only includes the simple blocks with dimension values.

ORA-36904 (XSAGDNGL44) %a workspace object workspace object In AGGMAP %p, RELATION %p occurs after a dynamic model. The dynamic model must be the last calculation within the AGGMAP.

Cause: Before the current relation, dynamic model exists.

Action: Make sure the dynamic model is the last statement.

ORA-36906 (XSAGDNGL45) %a workspace object workspace object AGGMAP %p, MODEL %p occurs after a dynamic model. The dynamic model must be the last calculation within the AGGMAP.

Cause: Before the current model, the dynamic model exists.

Action: Make sure the dynamic model as the last calculation statement, and only at most one dynamic model exists.

ORA-36950 (XSFCAST22) %a string number number The list of %p values cannot have more than %p members. You supplied %p.

Cause: There are more than the maximum number of OFFSET or PERIODICITY values.

Action: Remove some of the values.

ORA-36952 (XSFCAST23) You cannot specify a cycle number when querying the string forecasting option.

Cause: A cycle number was specified in a call to FCQUERY to retrieve forecast data not related to a cycle.

Action: Remove the cycle specification from the call to FCQUERY.

ORA-36954 (XSFCAST24) %a number number The cycle number must be between 1 and %p. You specified %p.

Cause: A cycle number less than 1 or greater than the maximum value was specified in a call to FCQUERY.

Action: Specify a number in the indicated range.

ORA-36956 (XSFCAST25) There are only number PERIODICITY values. You cannot specify more OFFSET values.

Cause: More OFFSET values were specified than PERIODICITY values.

Action: Supply only as many OFFSETs as there are PERIODICITY values.

ORA-36958 (XSFCAST26) %a number number number The OFFSET value for cycle %p cannot be greater than the cycle's PERIODICITY, which is %p. You specified %p.

Cause: The OFFSET for a cycle exceeded the PERIODICITY for that cycle.

Action: Supply an OFFSET less than or equal to the PERIODICITY for the corresponding cycle.

ORA-36960 (XSFCAST27) %a string number The value of the %p expression must be an odd number. You specified %p.

Cause: An even number was given for an option that requires an odd number.

Action: Supply an odd number or let the option default.


Oracle Database Server Utilities Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Part III
Oracle Database Server Utilities Messages

This part contains the following chapters:

  • Chapter 17, "Export Messages (EXP)"
  • Chapter 18, "Import Messages (IMP)"
  • Chapter 19, "SQL*Loader Messages (SQL*Loader)"
  • Chapter 20, "External Tables Messages (KUP)"
  • Chapter 21, "DBVERIFY Messages (DBV)"
  • Chapter 22, "DBNEWID Messages (NID)"
  • Chapter 23, "Parameter Messages (LCD)"
  • Chapter 24, "Summary Advisor, Explain Rewrite, and Explain Materialized View Messages (QSM)"
  • Chapter 25, "Recovery Manager Messages (RMAN)"


Export Messages (EXP)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

17
Export Messages (EXP)

This chapter lists messages generated by the Export utility. For more information about this utility, refer to Oracle9i Database Utilities.

EXP-00000 Export terminated unsuccessfully

Cause: Export encountered an Oracle error.

Action: Look up the accompanying Oracle message in the ORA message chapters of this manual, and take appropriate action.

EXP-00001 data field truncation - column length=number, buffer size=number actual size=number

Cause: Export could not fit a column in the data buffer.

Action: Record the given size parameters and the accompanying messages and report this as an Export internal error to Oracle Support Services. (Part of the table has been exported. Export will continue with the next table.)

EXP-00002 error in writing to export file

Cause: Export could not write to the export file, probably because of a device error. This message is usually followed by a device message from the operating system.

Action: Take appropriate action to restore the device.

EXP-00003 no storage definition found for segment(number, number)

Cause: Export could not find the storage definitions for a cluster, index, or table.

Action: Record the accompanying messages and report this as an Export internal error to Oracle Support Services.

EXP-00004 invalid username or password

Cause: An invalid username or password was specified.

Action: Retry with a valid username and password.

EXP-00005 all allowable logon attempts failed

Cause: Attempts were repeatedly made to log on with an invalid username or password.

Action: Shut down the utility, then restart and retry with a valid username and password.

EXP-00006 internal inconsistency error

Cause: Export's data structure was corrupted.

Action: Record the accompanying messages and report this as an Export internal error to Oracle Support Services.

EXP-00007 dictionary shows no columns for string.string

Cause: Export failed to gather column information from the data dictionary. The table may have been dropped.

Action: Retry the export and, if this error recurs, report it as an Export internal error to Oracle Support Services.

EXP-00008 ORACLE error number encountered

Cause: Export encountered the referenced Oracle error.

Action: Look up the Oracle message in the ORA message chapters of this manual and take appropriate action.

EXP-00009 no privilege to export string's table string

Cause: An attempt was made to export another user's table. Only a database administrator can export another user's tables.

Action: Ask your database administrator to do the export.

EXP-00010 string is not a valid username

Cause: An invalid username was specified.

Action: Shut down the utility, then restart and retry with a valid username.

EXP-00011 string.string does not exist

Cause: Export could not find the specified table.

Action: Retry with the correct table name.

EXP-00012 string is not a valid export mode

Cause: An invalid export mode was specified.

Action: Retry with a valid export mode.

EXP-00013 respond with either 'Y', 'N', RETURN or '.' to quit

Cause: An invalid response was entered.

Action: Enter any of the responses shown in the message.

EXP-00014 error on row number of table string

Cause: Export encountered an Oracle error while fetching rows.

Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action.

EXP-00015 error on row number of table string, column string, datatype number

Cause: Export encountered an error while fetching or writing the column. An accompanying message gives more information.

Action: Correct the error and try again.

EXP-00016 ORACLE error encountered while reading default auditing options

Cause: Export encountered an Oracle error while reading the default auditing options (those for updates, deletes, and so on).

Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action.

EXP-00017 feature 'string' is needed, but not present in database"

Cause: The command entered requires the specified feature. Either that feature is not installed, or the row describing the feature is missing from table V$OPTION.

Action: Re-install Oracle with the feature specified in the message.

EXP-00018 datatype (number) for column string, table string.string is not supported

Cause: Export does not support the referenced datatype.

Action: Retry with an acceptable datatype (CHAR, NUMBER, DATE, LONG, or RAW).

EXP-00019 failed to process parameters, type 'EXP HELP=Y' for help

Cause: Invalid command-line parameters were specified.

Action: Check the online help screen for the set of valid parameters, then retry.

EXP-00020 failed to allocate memory of size number

Cause: Export failed to allocate the necessary memory.

Action: Decrease the export buffer size so that less memory is required, or increase the runtime memory size for Export.

EXP-00021 can only perform incremental export in Full Database mode

Cause: USER or TABLE mode was specified when doing an incremental export.

Action: Specify FULL database mode (FULL=Y) and retry.

EXP-00022 must be SYS or SYSTEM to do incremental export

Cause: The privileges needed to do an incremental export do not exist. Only a data base administrator can do incremental exports.

Action: Ask the database administrator to do the incremental export.

EXP-00023 must be a DBA to do Full Database or Tablespace export

Cause: The privileges needed to do a FULL database export do not exist. Only a database administrator can do a FULL database export.

Action: Ask the database administrator to do the FULL database export.

EXP-00024 Export views not installed, please notify your DBA

Cause: The necessary Export views were not installed.

Action: Ask the database administrator to install the required Export views.

EXP-00025 dictionary shows no column for constraint string.number

Cause: Export failed to gather column information about the referenced constraint from the data dictionary. The constraint may have been altered.

Action: Retry the export and, if this error recurs, report it as an Export internal error to Oracle Support Services.

EXP-00026 conflicting modes specified

Cause: Conflicting export modes were specified.

Action: Specify only one parameter and retry.

EXP-00027 failed to calculate ORACLE block size

Cause: Export failed to calculate the Oracle block size.

Action: Report this as an Export internal error to Oracle Support Services.

EXP-00028 failed to open string for write

Cause: Export failed to open the export file for writing. This message is usually followed by device messages from the operating system.

Action: Take appropriate action to restore the device.

EXP-00029 Incremental export mode and consistent mode are not compatible

Cause: Both consistent and incremental exports were specified.

Action: No action is required. Consistent mode is turned off.

EXP-00030 Unexpected End-Of-File encountered while reading input

Cause: Encountered an End-Of-File while reading the user input.

Action: If input to export is being redirected, check the file for errors.

EXP-00031 Arraysize not in valid range. Using arraysize=number

Cause: The array size value specified is not in the valid range.

Action: No action required.

EXP-00032 Non-DBAs may not export other users

Cause: Only database administrators can export to other users. A non-database administrator attempted to specify OWNER=USER where exporter is not the user.

Action: Request that this operation be performed by the database administrator.

EXP-00033 Could not find environment character set

Cause: The environment character set is missing or incorrectly specified.

Action: Ensure that the environment character set is correctly specified and is present.

EXP-00034 error on rowid: file# number block# number slot# number

Cause: Identifies the ROWID on which an error occurred.

Action: This is an information message. No action is required.

EXP-00035 QUERY parameter valid only for table mode exports

Cause: You specified the QUERY parameter in an export command, but you are not performing a table mode export. The QUERY parameter cannot be used for a user mode export, a full export, nor a point in time recovery export.

Action: If you want to select a subset of rows for a table, you must export the table independently with a table mode export. Issue a table mode export command that specifies the table name and the query you want to execute during export.

EXP-00036 Object number non-existent in dictionary

Cause: The specified object could not be found in the dictionary. The object might have been dropped during the export

Action: The object no longer exists; no action is needed.

EXP-00037 Export views not compatible with database version

Cause: The Export utility is at a higher version than the database version and is thereby incompatible.

Action: Use the same version of Export utility as the database.

EXP-00038 Bad Hash cluster id in clu$

Cause: The function ID in CLU$ is not a legal number. CLU$ has become corrupted.

Action: Contact Oracle Support Services.

EXP-00039 export file string must be on a disk

Cause: On some platforms, export can read files from tape. This message is displayed if the first file in an export file set was on disk and you specified a tape device for a second or subsequent file.

Action: Verify that you have specified the correct file name for the export file. Remember that all export files can be either on disk or all files can be on tape, but not mixed both tape and disk.

EXP-00040 Dump file and log file must be different

Cause: The dump file and log file cannot be the same file.

Action: Specify different file names for the dump file and the log file, then retry the operation.

EXP-00041 INCTYPE parameter is obsolete

Cause: Export encountered the INCTYPE parameter when parsing Export options. Incremental Exports are no longer supported.

Action: Consult the Oracle9i User-Managed Backup and Recovery Guide. Export will attempt to continue.

EXP-00042 Missing NLS_CHARACTERSET/NLS_NCHAR_CHARACTERSET in props$

Cause: A value for NLS_CHARACTERSET/NLS_NCHAR_CHARACTERSET was not entered in the props$ table. This is an internal error.

Action: Contact Oracle Support Services.

EXP-00043 Invalid data dictionary information in the row where column "string" is "string" in table string

Cause: The export utility retrieved invalid data from the data dictionary.

Action: Contact Oracle Support Services.

EXP-00044 must be connected 'AS SYSDBA' to do Point-in-time Recovery or Transportable Tablespace import

Cause: The user must log in 'as SYSDBA' to perform transportable tablespace imports or Point-In-Time Recovery imports.

Action: Ask your database adminstrator to perform the Transportable Tablespace import or the Tablespace Point-in-time Recovery import.

EXP-00045 Cannot export SYSTEM Tablespace for Point-in-time Recovery or Transportable Tablespace

Cause: SYSTEM tablespace cannot be part of recovery set or transportable tablespace set.

Action: Contact Oracle Support Services.

EXP-00046 Tablespace named string does not exist

Cause: The specified tablespace does not exist in dictionary.

Action: Contact Oracle Support Services.

EXP-00047 Missing tablespace name(s)

Cause: Tablespace name(s) were not supplied.

Action: Provide tablespace name(s).

EXP-00049 string option is not compatible with Point-in-time Recovery or Transportable Tablespace export

Cause: An option was specified that is incompatible with Point-in-time Recovery or Transportable Tablespace Export.

Action: Retry the export without the displayed option.

EXP-00050 Cannot perform Partition Export "string" on non-partitioned table "string"

Cause: The table specified in this Partition Export is not a partitioned table.

Action: Use Table mode, or specify a non-partitioned table.

EXP-00051 "string" - given partition or subpartition name is not part of "string" table

Cause: The specified partition or subpartition name is not in the specified table.

Action: Check if the correct table, partition or subpartition name was specified.

EXP-00052 error on row number of partition string

Cause: Export encountered the referenced Oracle error while fetching rows.

Action: Look up the Oracle message in the ORA message chapters of this manual and take appropriate action.

EXP-00053 unable to execute QUERY on table string because the table has inner nested tables

Cause: You specified the QUERY parameter on a table that has one or more inner nested tables. The QUERY parameter cannot be specified on tables that have inner nested tables.

Action: Export the entire table by omitting the QUERY parameter.

EXP-00054 error on row number of subpartition string

Cause: Export encountered the referenced Oracle error while fetching rows.

Action: Look up the Oracle message in the ORA message chapters of this manual and take appropriate action.

EXP-00055 string.string is marked not exportable

Cause: An object was marked as non-exportable in the NOEXP$ table.

Action: Consult your database administrator.

EXP-00057 Failure to initialize parameter manager

Cause: The parameter manager failed in intialization.

Action: Record the messages that follow and report this to Oracle Support Services as an Export internal bug.

EXP-00058 Password Verify Function for string profile does not exist

Cause: Cannot find the function for the profile.

Action: Check if the profile was created properly.

EXP-00059 error converting an object type's identifier to characters

Cause: An invalid length of an object type identifier prevented its conversion.

Action: Contact Oracle Support Services.

EXP-00060 an object type had multiple TYPE BODYs

Cause: More than one TYPE BODY was found for an object type.

Action: Try dropping the TYPE BODY, if that is not successful, contact Oracle Support Services.

EXP-00061 unable to find the outer table name of a nested table

Cause: While exporting a bitmap index or postable action on an inner nested table, the name of the outer table could not be located, using the NTAB$ table.

Action: Verify the table is properly defined.

EXP-00062 invalid source statements for an object type

Cause: TYPE was not found in the statements in SOURCE$ for an Object Type.

Action: Contact Oracle Support Services.

EXP-00063 error in changing language handle

Cause: Unable to change language handle.

Action: Contact Oracle Support Services.

EXP-00064 string is an inner nested table and connot be exported.

Cause: An attempt was made to export an inner nested table without its parent table.

Action: Export the parent of the inner nested table.

EXP-00065 Error writing lob to the dump file.

Cause: The current LOB could not be written to the dump file.

Action: Identify the cause of the write failure and fix it.

EXP-00066 Object table string is missing its object identifier index

Cause: All object tables must have an object identifier index, but the specified table was missing an index on its object identifier column.

Action: Re-create the type table and retry the operation.

EXP-00068 tablespace string is offline

Cause: Export failed to export tablespace (tablespace being offline).

Action: Make tablespace online and re-export.

EXP-00070 attempt to free unallocated memory

Cause: An attempt was made to free memory that was not allocated.

Action: Contact Oracle Support Services.

EXP-00071 QUERY parameter not compatible with Direct Path export

Cause: You specified a value for the QUERY parameter for a direct path export. The QUERY parameter cannot be used with a direct path export.

Action: Re-issue the export command with DIRECT=N or omit the DIRECT parameter from the command line.

EXP-00072 error closing export file string

Cause: An error occurred while trying to close the export file.

Action: Contact Oracle Support Services.

EXP-00073 dump file size too small

Cause: You specified either the FILESIZE parameter or the VOLSIZE parameter (if your platform supports it), and the value of the parameter is too small to hold the header information for the export file, plus any data.

Action: Increase the value of the FILESIZE or VOLSIZE parameter.

EXP-00074 rounding VOLSIZE down, new value is string

Cause: The VOLSIZE parameter must be a multiple of the RECORDLENGTH, but the value you specified for VOLSIZE does not meet this requirement. The value of VOLSIZE has been rounded down to be a multiple of the RECORDLENGTH used for the dump file.

Action: No action is required. You can adjust the VOLSIZE or RECORDLENGTH parameter to avoid this message. When importing this file, you must specify the VOLSIZE value reported by this message.

EXP-00075 rounding FILESIZE down, new value is string

Cause: The FILESIZE parameter must be a multiple of the RECORDLENGTH, but the value you specified for FILESIZE does not meet this requirement. The value of FILESIZE has been rounded down to be a multiple of the RECORDLENGTH used for the dump file.

Action: No action is required. You can adjust the FILESIZE or RECORDLENGTH parameter to avoid this message. When importing this file, you must specify the FILESIZE value reported by this message.

EXP-00076 multiple devices specified for tape output

Cause: You specified multiple file names when doing an export to a tape device. EXPORT uses the same device for writing all files, of the number of tape volumes required. For this reason, export will accept only one value for the FILE parameter when writing to tape.

Action: Re-enter the EXPORT command, but specify only one tape device in the FILE parameter.

EXP-00077 multiple output files specified for unbounded export file

Cause: You specified multiple file names when doing an export and you also specified a value of 0 for the FILESIZE parameter. Note that 0 is the value used if FILESIZE is not specified on the command line. Since a value of 0 for FILESIZE means that only one file will be written and there is no size limit for that file, the other files you specified in the FILE parameter can never be used.

Action: If you intended to write multiple files, respecify the command but use the FILESIZE to specify the maximum number of bytes that EXPORT should write to each file. If you intended to write only one file with no limits on it's size, reissue the EXPORT command but specify only one file name for the FILE parameter.

EXP-00078 Error exporting metadata for index string. Index creation will be skipped

Cause: Domain indexes export private metadata via anonymous PL/SQL blocks prior to the CREATE INDEX statement. Export does this by calling the ODCIIndexGetMetadata method on the implementation type associated with the index. A problem occurred inside this routine. Because the metadata is considered an integral part of the index, the CREATE INDEX statement was not written to the dump file.

Action: Contact the developer of the index's implementation type. If this is an Oracle-supplied index (perhaps via a data cartridge), contact Oracle Support Services.

EXP-00079 Data in table "string" is protected. Conventional path may only be exporting partial table.

Cause: User without the execute privilege on DBMS_RLS, the access control package, tries to export a table that has access control. Since table owner is also subjected to access control, the owner may not be able to export all rows in the table, but only the ones he can see. Also, to preserve integrity of the table, user exporting the table should have enough privilege to re-create the table with the security policies at import time. Therefore, it is strongly recommended the database administrator should be handling exporting of this table. Granting the table owner execute privilege would also satisfy this security check, though it might have other security implications. If the table does not have objects, can use direct mode.

Action: Ask the database administrator to export/import this table/view.

EXP-00080 Data in table "string" is protected. Using conventional mode.

Cause: User without the execute privilege on DBMS_RLS, the access control package, tries to direct export a table that has access control enabled. Using conventional export mode instead. Note that because of access control, only a partial table may be exported.

Action: Ask the database administrator to export/import this table/view.

EXP-00081 Exporting access control for table/view "string" as non-DBA.

Cause: A non-DBA user tries to export table/view and the associated fine grain access control policies. The user may not have enough privilege to re-create the access control policies when importing the table/view. And such an event may cause inconsistency in the security model of the table/view.

Action: Ask the database administrator to export/import this table/view.

EXP-00082 Invalid function name passed to procedural object support: string

Cause: Internal inconsistency error: The listed function is not a method on export's procedural object interface specification.

Action: Contact Oracle Support Services.

EXP-00083 The previous problem occurred when calling string.string.string

Cause: The listed package provides export/import support for procedural actions. The previously listed error occurred while calling the specified function.

Action: Contact Oracle Support Services. Most packages are supplied by Oracle internal cartridge or server development groups. The package name will help Oracle Support Services determine the correct owner of the problem.

EXP-00084 Unexpected DbmsJava error number at step number

Cause: The error was returned from a call to a DbmsJava procedure.

Action: Record the accompanying messages and report this as an Export internal error to Oracle Support Services.

EXP-00085 The previous problem occurred when calling string.string.string for object number

Cause: The listed package provides export/import support for procedural objects, i.e., those whose DDL is supplied by stored procedures. The previously listed error occurred while calling the specified function.

Action: Contact Oracle Support Services. Most packages are supplied by Oracle internal cartridge or server development groups. The package name will help Oracle Support Services determine the correct owner of the problem.

EXP-00086 Primary key REFs in table "string"may not be valid on import

Cause: The specified table contains primary key REFs which may not be valid in the import database.

Action: Do not use Export/Import to move Primary key REFs between databases having differing character sets.

EXP-00087 Problem with internal hash table of schema/table names

Cause: Most likely a problem with allocating memory for the hash table entries.

Action: Contact Oracle Support Services.

EXP-00089 invalid FILE_FORMAT specification

Cause: The FILE_FORMAT specification did not contain an instance of "string". This wildcard string must be present.

Action: Correct the error and re-enter the EXPORT command.

EXP-00090 cannot pin type "string"."string"

Cause: Export was unable to pin the specified type in the object cache. This is typically caused because a type could not be made valid (for example because of authorization violations in accessing subtypes).

Action: Fix the problem with the offending type until the type can be successfully compiled.

EXP-00091 Exporting questionable statistics

Cause: Export was able to export statistics, but the statistics may not be useable. The statistics are questionable because one or more of the following happened during export: a row error occurred, client character set or NCHARSET does not match with the server, a query clause was specified on export, only certain partitions or subpartitions were exported, or a fatal error occurred while processing a table.

Action: To export non-questionable statistics, change the client character set or NCHARSET to match the server, export with no query clause, or export complete tables. If desired, import parameters can be supplied so that only non-questionable statistics will be imported, and all questionable statistics will be recalculated.

EXP-00092 unable to set NLS_NUMERIC_CHARACTERS to required defaults

Cause: Export was unable to set NLS_NUMERIC_CHARACTERS to '.,'.

Action: Record the accompanying messages and report this as an Export internal error to Oracle Support Services.

EXP-00093 could not convert to server character set's handle

Cause: Internal error.

Action: Contact Oracle Support Services.

EXP-00094 could not convert to server national character set's handle

Cause: Internal error.

Action: Contact Oracle Support Services.

EXP-00095 Flashback_time and Flashback_scn are not compatible

Cause: Both flashback_time and flashback_scn parameters were specified.

Action: Reissue the command with only one flashback parameter.

EXP-00096 The template name specified can not be found.

Cause: The specified template name does not exist.

Action: Verify the template name by looking up view %_ias_template.

EXP-00097 Object type "string"."string" is not in a valid state, type will not be exported.

Cause: The object type's status is invalid which may be caused by a dependant type's modification (or removal) without cascading the change.

Action: The type must be recompiled using ALTER TYPE COMPILE.

EXP-00098 Data in table has not been upgraded, table will not be exported.

Cause: Export is attempting to process a table containing references to a type which has evolved. In order for Export to process the table successfully, all data within each table must be upgraded to the latest revision of each referenced type.

Action: The table must be updated using ALTER TABLE UPGRADE DATA.

EXP-00099 Table "string"."string" is not in a valid state, table will not be exported.

Cause: A table or one of its dependant types has modified without cascading the change. This left the table in an INVALID state.

Action: The table must be updated using ALTER TABLE UPDATE.

EXP-00100 error converting an object type's hashcode to characters

Cause: An invalid length of an object type identifier prevented its conversion.

Action: Contact Oracle Support Services.

EXP-00101 Version 1 extensible index "string"."string" can not be included in Transportable Tablespace Export.

Cause: Transportable Tablespace extensible indexes must be at least version 2.

Action: Upgrade the extensible index implementation to version 2 specifications.

EXP-00102 Resumable parameters ignored -- current session not resumable

Cause: The current session is not resumable.

Action: Must specify RESUMABLE=Y to enable resumable sessions in order for the RESUMABLE_NAME and RESUMABLE_TIMEOUT parameters to take effect.


Import Messages (IMP)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

18
Import Messages (IMP)

This chapter lists messages generated by the Import utility. For more information about this utility, refer to Oracle9i Database Utilities.

IMP-00000 Import terminated unsuccessfully

Cause: Import encountered an Oracle error.

Action: Look up the accompanying Oracle message in the ORA message chapters of this manual, and take appropriate action.

IMP-00001 respond with either string, string, RETURN or '.' to quit

Cause: An invalid response was entered.

Action: Enter any of the responses shown in the message.

IMP-00002 failed to open string for read

Cause: Import failed to open the export file for reading. This message is usually followed by a device message from the operating system.

Action: Take appropriate action to restore the device.

IMP-00003 ORACLE error number encountered

Cause: Import encountered the referenced Oracle error.

Action: Look up the Oracle message in the ORA message chapters of this manual, and take appropriate action.

IMP-00004 invalid username or password

Cause: An invalid username or password was specified.

Action: Retry with a valid username and password.

IMP-00005 all allowable logon attempts failed

Cause: An attempt was repeatedly made to log on with an invalid username or password.

Action: Retry with valid username and password.

IMP-00006 failed to allocate memory of size number

Cause: Import failed to allocate the necessary memory.

Action: Decrease the import buffer size so that less memory is required, or increase the runtime memory size for Import.

IMP-00007 must be a DBA to import objects to another user's account

Cause: The privileges needed to import into another user's account do not exist. Only a database administrator can import into another user's account.

Action: Ask the database administrator to do the import.

IMP-00008 unrecognized statement in the export file: string

Cause: Import did not recognize a statement in the export file. Either the export file was corrupted, or an Import internal error has occurred.

Action: If the export file was corrupted, retry with a new export file. Otherwise, report this as an Import internal error and submit the export file to Oracle Support Services.

IMP-00009 abnormal end of export file

Cause: The export file is probably from an aborted Export session.

Action: If so, retry the export and import. Otherwise, report this as an Import bug and submit the export file that caused this error to Oracle Support Services.

IMP-00010 not a valid export file, header failed verification

Cause: Either the file was not generated by Export or it was corrupted.

Action: If the file was indeed generated by Export, report this an Import bug and submit the export file to Oracle Support Services.

IMP-00011 formatted table data not currently supported

Cause: An attempt was made to import an export file that contains formatted table data. Import only supports export files containing binary table data.

Action: Retry using an export file that contains only binary table data.

IMP-00012 invalid export mode (character) in header

Cause: The Export mode specified in the export file header is invalid.

Action: Check the export file to see if it was corrupted. If it was not, report this as an Import bug and submit the export file to Oracle Support Services.

IMP-00013 only a DBA can import a file exported by another DBA

Cause: The privileges needed to Import an export file generated by a database administrator do not exist. Only a database administrator can import such files.

Action: Ask the database administrator to do the import.

IMP-00014 option "string" is needed, but not present in database

Cause: The command entered requires the specified option. Either that option is not installed, or the row describing the option is missing from table V$OPTION.

Action: Reinstall Oracle with the option specified by the message.

IMP-00015 following statement failed because the object already exists:

Cause: Import failed to create an object because it already exists.

Action: Specify IGNORE=Y to ignore such errors and import rows even when tables are not created because they already exist.

IMP-00016 required character set conversion (type number to number) not supported

Cause: Import could not convert the character format of the export file into the native character format.

Action: Change the user character set by setting the NLS_LANG environment variable to match the character set of the export file.

IMP-00017 following statement failed with ORACLE error number:

Cause: Import failed to execute the statement from the export file because of an Oracle error.

Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action.

IMP-00018 partial import of previous table completed: number rows imported

Cause: A table was only partially imported because of an Oracle error.

Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action.

IMP-00019 row rejected due to ORACLE error number

Cause: Import encountered the referenced Oracle error while trying to import a row.

Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action.

IMP-00020 long column too large for column buffer size (number)

Cause: The column buffer is too small. This usually occurs when importing LONG data.

Action: Increase the insert buffer size 10,000 bytes at a time (for example). Use this step-by-step approach because a buffer size that is too large may cause a similar problem.

IMP-00021 INCTYPE parameter is obsolete

Cause: Import encountered the INCTYPE parameter when parsing Import options. Incremental Imports are no longer supported.

Action: Consult the Oracle9i User-Managed Backup and Recovery Guide. Import will attempt to continue.

IMP-00022 failed to process parameters, type 'IMP HELP=Y' for help

Cause: Invalid command-line parameters were specified.

Action: Check the online help screen for the set of valid parameters, then retry.

IMP-00023 Import views not installed, please notify your DBA

Cause: The necessary Import views were not installed.

Action: Ask your database administrator to install the required Import views.

IMP-00024 Only one mode (TABLES, FROMUSER, or FULL) can be specified

Cause: Parameters were specified that conflict with the import specification FULL=Y.

Action: Retry, making sure not to specify FULL=Y.

IMP-00025 for DBA export files, FROMUSER must be specified with TOUSER option

Cause: When importing a database administrator export file, you specified the TOUSER parameter but not the FROMUSER parameter.

Action: Specify the FROMUSER parameter so that Import knows which user's objects to import.

IMP-00027 failed to rollback partial import of previous table

Cause: Import encountered an Oracle error while trying to roll back a partial import.

Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action. Then, log on to Oracle and check that the partial import was not committed.

IMP-00028 partial import of previous table rolled back: number rows rolled back

Cause: Import encountered an Oracle error while trying to import a table.

Action: Look up the accompanying Oracle message in the ORA message chapters of this manual and take appropriate action. Then, if necessary, re-import the table.

IMP-00029 cannot qualify table name by owner (string), use FROMUSER parameter

Cause: A table name was qualified with the name of its owner, as shown in the following example:

IMP SYSTEM/MANAGER TABLES=(SCOTT.EMP)

This is not allowed.

Action: Use the FROMUSER parameter to specify the table's owner, as shown in the following example:

IMP SYSTEM/MANAGER FROMUSER=SCOTT TABLES=(EMP, DEPT)

IMP-00030 failed to create file string for write

Cause: Import was unable to create the specified file with write enabled.

Action: Check the file name and file system for the source of the error.

IMP-00031 Must specify FULL=Y or provide FROMUSER/TOUSER or TABLES arguments

Cause: The database administrator did not specify full or partial import.

Action: The database administrator must specify FROMUSER/TOUSER or table arguments if not a full import.

IMP-00032 SQL statement exceeded buffer length

Cause: The buffer was too small for the SQL statement being read.

Action: Rerun with a larger buffer. This can also be an indication of a corruption in the import datafile.

IMP-00033 Warning: Table "string" not found in export file

Cause: A table name was specified that does not exist in export file.

Action: Correct the table specification.

IMP-00034 Warning: FromUser "string" not found in export file

Cause: The user specified a FROMUSER name that does not exist in export file.

Action: Correct the FROMUSER specification.

IMP-00035 input file string must be on a disk

Cause: On some platforms, import can read files from tape. This message is displayed if the first file in an export file set was on disk and you specified a tape device for a second or subsequent file.

Action: Verify that you have specified the correct file name for the import file. Remember that all input files can be either on disk or all files can be on tape, but not mixed both tape and disk.

IMP-00036 Could not find environment character set

Cause: An environment character set was specified that was not recognized by the Import utility.

Action: Ensure that the spelling of the character set specified in the command line parameter CHARSET (for Release 6 only) or the environment variable NLS_LANG is correct.

IMP-00037 Character set marker unknown

Cause: The export file is corrupted.

Action: Try to obtain an uncorrupted version of the export file. If the export file is not corrupted, report this as an Import internal error and submit the export file to Oracle Support Services.

IMP-00038 Could not convert to environment character set's handle

Cause: This is an internal error.

Action: Contact Oracle Support Services.

IMP-00039 VOLSIZE does not match the value used for export: string

Cause: The value specified for VOLSIZE does not match the value specified during the creation of the export file.

Action: If you believe that the specified VOLSIZE value is correct, verify that you specified the correct file for import. If you specified the correct file but are unsure about the correct value, re-execute the import command but specify VOLSIZE=0.

IMP-00040 FILESIZE does not match the value used for export: string

Cause: The value specified for FILESIZE does not match the value specified during the creation of the export file.

Action: If you believe the specified FILESIZE value is correct, verify that you specified the correct file for import. If you specified the correct file but are unsure about the correct value, re-execute the import command but specify FILESIZE=0.

IMP-00041 Warning: object created with compilation warnings

Cause: The object in the SQL statement following this error was created with compilation errors. If this error occurred for a view, it is possible that the base table of the view was missing.

Action: This is a warning. The object may have to be recompiled before being used.

IMP-00042 CHARSET used, but the export file has specific character set

Cause: The user requested that a specific character set be used to process an export file that has a specific embedded character set ID. The ID in the export file is accurate and should be used.

Action: Remove the CHARSET keyword from the command line.

IMP-00043 export file character set inconsistent

Cause: The character set of the export file and the environment character set (or the character set specified with the CHARSET keyword) are inconsistent. One character set is ASCII-based while the other is EBCDIC based.

Action: Specify the correct character set with the CHARSET keyword.

IMP-00044 unable to allocate enough memory for statement

Cause: Import was unable to allocate sufficient memory to read in the specified statement and execute it.

Action: Run the Import command again with a larger value for the buffer option.

IMP-00045 using VOLSIZE value from export file of string

Cause: Either you did not specify the VOLSIZE parameter in your IMPORT command, or you specified VOLSIZE=0 and the export was created with a non-zero value for VOLSIZE. Import will use the value specified in the export file.

Action: No action required.

IMP-00046 using FILESIZE value from export file of string

Cause: Either you did not specify the FILESIZE parameter in your IMPORT command, or you specified FILESIZE=0 and the export file was created with a non-zero value for FILESIZE. Import will use the value specified in the export file.

Action: No action required.

IMP-00047 unexpected file sequence number; expected number but found number

Cause: The header in the export file contains a sequence number that is used to track the order in which multiple export files are written. The first export file is assigned sequence number one, the second file is assigned sequence number two and so on. This message is displayed when a number other than the expected sequence number is found in the file header

Action: Execute the import command again, but specify the files in the order in which Export wrote them.

IMP-00048 mismatched file header

Cause: During verification of the 2nd or subsequent file in a multi-file export, Import found header fields in the file that did not match values in the first file.

Action: Check the names of the files created by Export and verify that you specified them correctly for the import operation.

IMP-00049 Unknown language specified in CHARSET

Cause: An unknown language was listed in the CHARSET option.

Action: Use a known character set.

IMP-00050 Dump file and log file cannot be identical

Cause: Identical names were given to the dump file and log file.

Action: Specify different names for the dump file and log file and retry the operation.

IMP-00051 Direct path exported dump file contains illegal column length

Cause: An invalid column length was encountered while processing column pieces.

Action: Check to make sure the export file is not corrupted, or else report this to Oracle Support Services as an Import/Export internal bug and submit the export file.

IMP-00052 Warning: Unable to set event for freelist communication with server

Cause: An event could not be set for current the session.

Action: If Import fails, give the Import user ALTER SESSION PRIV and retry the operation.

IMP-00053 Import mode incompatible with Export dump file

Cause: The specified import option is incompatible with point-in-time- recovery dump file.

Action: Generate a proper dump file or use point-in-time-recovery import mode.

IMP- 00054 must be connected 'AS SYSDBA' to do Point-in-time Recovery or Transportable Tablespace import

Cause: The user must log in 'as SYSDBA' to perform transportable tablespace imports or Point-In-Time Recovery imports.

Action: Ask your database administrator to perform the Transportable Tablespace import or the Tablespace Point-in-time Recovery import.

IMP-00055 Warning: partition or subpartition "string":"string" not found in export file

Cause: A partition or subpartition name was specified that does not exist in export file.

Action: Check to make sure the partition or subpartition name belongs to the table.

IMP-00056 multiple devices specified for tape input

Cause: You specified multiple file names when doing an import from a tape device. Import uses the same device for reading all tapes, regardless of the number of tape volumes required. For this reason, export will accept only one value for the FILE parameter when writing to tape.

Action: Re-enter the IMPORT command, but specify only one tape device in the FILE parameter.

IMP-00057 Warning: Dump file may not contain data of all partitions of this table

Cause: The dump file used for this Table Import might not contain all of the data belonging to the exported table.

Action: Check to see if the export was done as intended, or try performing a Partition Import.

IMP-00059 Failure to initialize parameter manager

Cause: Parameter manager failed in initialization.

Action: Report this to Oracle Support Services as an Import internal bug.

IMP-00060 Warning: Skipping table "string"."string" because object type "string"."string" does not exist or has different identifier

Cause: An object type needed by the table, either does not exist on the target system or, if it does exist, it has a different object identifier.

Action: Create the object type on the target system with a valid identifier.

IMP-00061 Warning: Object type "string"."string" already exists with a different identifier

Cause: An object type cannot be created because it already exists on the target system, but with a different identifier.

Action: Drop the object type from the target system and retry the operation.

IMP-00062 Warning: The identifier on the dump file for object type "string"."string" is invalid

Cause: The character string representing the object type's identifier could not be converted to an object identifier. This is an internal error.

Action: Contact Oracle Support Services.

IMP-00063 Warning: Skipping table "string"."string" because object type "string"."string" cannot be created or has different identifier

Cause: An error occurred creating an object type that is used by the table.

Action: Examine the import log to determine why the object type could not be created. If the object type already existed, with a different object identifier, then drop the object type and retry the import.

IMP-00064 Definition of LOB was truncated by export

Cause: While producing the dump file, Export was unable to write the entire contents of a LOB. Import is therefore unable to reconstruct the contents of the LOB. The remainder of the import of the current table will be skipped.

Action: Delete the offending row in the exported database and retry the export.

IMP-00065 Import is unable to recreate lobs within objects.

Cause: An error occurred while re-creating a LOB within an imported object.

Action: Report this to Oracle Support Services as an Import internal error.

IMP-00066 Missing NLS_CHARACTERSET in props$

Cause: No value for NLS_CHARACTERSET in props$.

Action: Contact Oracle Support Services.

IMP-00067 Could not convert to server character set's handle

Cause: This is an internal error.

Action: Contact Oracle Support Services.

IMP-00068 Could not find environment national character set

Cause: An environment national character set was specified that was not recognized by the Import utility.

Action: Ensure that the spelling of the national character set specified in the environment variable NLS_NCHAR is correct.

IMP-00069 Could not convert to environment national character set's handle

Cause: This is an internal error.

Action: Contact Oracle Support Services.

IMP-00070 Lob definitions in dump file are inconsistent with database.

Cause: The number of LOBS per row in the dump file is different than the number of LOBS per row in the table being populated.

Action: Modify the table being imported so that it matches the column attribute layout of the table that was exported.

IMP-00071 Object identifier of imported table mismatches object identifier of existing table

Cause: An attempt was made to import data into a table that was re-created under a different object identifier than the object identifier used for the exported object table. Under this situation, REF's to this table that are contained within the dump file will also be invalid.

Action: Drop the offending object table prior to import.

IMP-00072 Warning: The object table's object identifier is invalid.

Cause: The character string representing the table's object identifier could not be converted to an internal object identifier. This is an internal error.

Action: Contact Oracle Support Services.

IMP-00073 FILE locator "string" "string" is truncated to "string" "string" in server character set

Cause: The conversion of the specified directory and name strings for a file attribute or column from the export server's character set into the import server's character set exceeded the maximum string lengths allowed within FILE descriptors. The strings will be truncated to the maximum supported lengths.

Action: Rename the directory aliases and external file names to match the truncated names in the specified FILE column or attribute.

IMP-00074 The constraints flagged by ALL_CONSTRAINTS.BAD will break in 2000 A.D.

Cause: Constraints exist in the data base that specify date values without fully specifying the year. These constraints could break in the year 2000 A.D.

Action: Query ALL_CONSTRAINTS and correct those constraints marked as bad.

IMP-00075 Warning: The nested table may contain partial rows or duplicate rows

Cause: An error occurred inserting data into an outer or inner nested table. If the error occurred in the outer table, rows are still inserted into the inner tables. If the error occurred in an inner table, data is still inserted into the outer table and other inner tables. This can result in duplicate inner table rows or partial logical rows.

Action: Examine the data in the tables. Delete the incorrect rows or drop the entire table and perform the import again.

IMP-00076 Missing NLS_NCHAR_CHARACTERSET in props$

Cause: No value for NLS_NCHAR_CHARACTERSET in props$.

Action: Contact Oracle Support Services.

IMP-00077 Could not convert to server national character set's handle

Cause: This is an internal error.

Action: Contact Oracle Support Services.

IMP-00078 Cannot translate FILE locator to "string" "string" in server character set

Cause:

  1. The current export dump file was generated using Beta-2 of Oracle8.0 and
  2. there was a File that appeared as an attribute of an ADT within a table's column and
  3. the character set of the export server's database was different than the character set of the import server's database and
  4. when the file name or the aliasing of the File increased in size when it was translated to the character set of the import server.

When all of these conditions are true, translation of the strings could yield corruption of the data in the column. Rather than proceeding with the translation, import will leave the character strings in the File in the old character set.

Action: After import completes, rename the directory aliases and external file names to match the real names used for the target database.

IMP-00079 Warning: National character set data in this table may be incorrect

Cause: Due to a problem in 8.0.2 Export, national character data in NCHAR and NVARCHAR2 columns was incorrectly assumed to be in the export server's data base character set and was converted to the export client's data base character set. This conversion would only be correct if the export server's data base character set was the same as the export server's national character set and the export client's data base character set was the same as the export client's national character set. All other combinations would likely be incorrect. This export dump file was generated by 8.0.2 Export and the export client and server character sets did not fit that criteria.

Action: Examine the national character data. If incorrect, update the data with correct data.

IMP-00080 Error during character conversion of long column or long command

Cause: During piecewise character conversion of the data in a long column or of a long command, a fatal conversion error occurred. Either character truncation occurred or an invalid character set handle was used.

Action: Retry the import with a different character set.

IMP-00081 attempt to free unallocated memory

Cause: An attempt was made to free memory that was not allocated.

Action: Contact Oracle Support Services.

IMP-00082 Error during conversion ROWID from string format to internal

Cause: An error occurred while attempting to convert a ROWID from an export dump file into an internal format.

Action: Report this to Oracle Support Services as an Import internal error.

IMP-00083 dump file does not contain an incremental export

Cause: An incremental import was requested and the dump file specified for the import command is either a user or table export.

Action: Reissue the command import command but specify the name of a dump file containing an incremental export.

IMP-00084 attempt to mix incremental import with user or table import

Cause: An incremental import was requested along with the FROMUSER, TOUSER, or TABLE qualifier. An incremental import cannot be done if any of these other qualifiers are also specified.

Action: Determine whether you want to do an incremental import, full import, user import or table import and reissue the import command with the appropriate qualifiers.

IMP-00085 multiple input files specified for unbounded export file

Cause: You specified multiple file names for the FILE parameter when doing an import, but the header in the export file indicates that the export operation could create only one file. Specifying multiple file names is valid for an import operation only if the export files were created by an export operation in which the user specified a non-zero value for the FILESIZE parameter.

Action: If you believe the export contains multiple files, verify that you have specified the correct files. If you believe the export should be in only one file then try the import operation again, but specify only one value for the FILE parameter.

IMP-00086 TOID "string" not found in export file

Cause: Import did not find the type identification specified in the TOID_NOVALIDATE parameter. The specified type identification does not exist in export file.

Action: Correct or omit the TOID_NOVALIDATE parameter.

IMP-00087 Problem with internal hash table of schema/table names

Cause: Most likely a problem with allocating memory for the hash table entries.

Action: Contact Oracle Support Services.

IMP-00088 Problem importing metadata for index string. Index creation will be skipped

Cause: Domain indexes import private metadata via anonymous PL/SQL blocks prior to the CREATE INDEX statement. The execution of one of these PL/SQL blocks failed. Because the metadata is considered an integral part of the index, the subsequent CREATE INDEX statement was skipped.

Action: Contact the developer of the index's implementation type. If this is an Oracle-supplied index (perhaps via a data cartridge), contact Oracle Support Services.

IMP-00089 Fine grain policy "string" not recreated on table/view "string"

Cause: Import user fails to recreate fine grained policies of the table/view being imported. To recreate the policy, the user doing the import needs execute privilege on the package DBMS_RLS for access policies or DBMS_FGA for audit policies.

Action: Ask the database administrator to perform the export/import of this table/view.

IMP-00090 Unexpected DbmsJava error number at step number while creating string

Cause: The error was returned from a call to a DbmsJava procedure.

Action: Record the accompanying messages and report this as an Import internal error to Oracle Support Services.

IMP-00091 Above error occurred on the following function and object: string. Remaining PL/SQL blocks for this object will be skipped.

Cause: An error occurred while executing a PL/SQL block that implements the DDL for the named function and procedural object. A procedural object is one whose DDL is implemented as stored procedures rather than as standard SQL statements.

Action: Contact Oracle Support Services so they may determine the development group responsible for the package that failed.

IMP-00092 Java object "string"."string" already exists, cannot be created

Cause: Import failed to create the Java source, class or resource object because it already exists.

Action: Drop the object type from the target system and retry the operation.

IMP-00093 Inconsistency between dumpfile constraint definition for table string with columns (string)

Cause: Import failed to locate a base table for a constraint that was defined in the dump file and statistics were not imported.

Action: Check to see if the table and constraint exist. If the table and constraint exist, then report this to Oracle Support Services as an Import internal error.

IMP-00094 Warning: The identifier on the dump file for object type "string"."string" is invalid.

Cause: The character string representing the object type's identifier could not be converted.

Action: Contact Oracle Support Services.

IMP-00095 Resumable parameters ignored -- current session not resumable

Cause: The current session is not resumable.

Action: Must specify RESUMABLE=Y to enable resumable sessions in order for the RESUMABLE_NAME and RESUMABLE_TIMEOUT parameters to take effect.

IMP-00096 Warning: Skipping table "string"."string" because type synonym "string"."string" cannot be created

Cause: An error occurred creating a synonym for a type that is used by the table.

Action: Examine the import log to determine why the type synonym could not be created. If the synonym already existed, but is not needed, then drop the synonym and retry the import. If the synonym is PUBLIC but the importer does not have the CREATE PUBLIC SYNONYM system privilege, then the import must be done by someone possessing that privilege, or the importer must be granted the privilege.

IMP-00097 STREAMS_CONFIGURATION=Y ignored, only valid with FULL=Y

Cause: STREAMS_CONFIGURATION=Y can only be used when FULL=Y is present on the command line.

Action: Remove conflicting command arguments.

IMP-00098 INTERNAL ERROR: string

Cause: An INTERNAL error has occurred.

Action: Contact Oracle Support Services.


SQL*Loader Messages (SQL*Loader)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

19
SQL*Loader Messages (SQL*Loader)

This chapter lists messages generated by the SQL*Loader utility. For more information about this utility, refer to Oracle9i Database Utilities.

SQL*Loader-00100 Syntax error on command-line

Cause: Possible causes for this error include: placing a positional argument after keyword arguments, misspelling a keyword, not balancing parentheses or quotes, or leaving space between the operator, '=', and an argument.

Action: Check the command syntax and the spelling, then retry.

SQL*Loader-00101 Invalid argument for username/password

Cause: The username/password argument specified on the command line was not recognized. Another argument (not identified by a keyword) could be in the position where username/password is expected. This error could also result from a spelling mistake. The password, if present, must be separated by a slash (/). No spaces can appear between the slash and username or password. Otherwise, SQL*Loader sees them as multiple arguments.

Action: Check the format of the username/password argument, which is the first argument on the command line, if arguments are given without keywords.

SQL*Loader-00102 Invalid control file name on command line

Cause: The control file name specified on the command line was not recognized. It could be misspelled, or another argument (not identified by a keyword) could be in its place. One possible cause is the existence of a space between username and password. See error 101, above.

Action: Check the spelling and position of the arguments on the command line.

SQL*Loader-00103 Invalid log file name on command line

Cause: The log file name specified on the command line was not recognized. It could be misspelled, or another argument (not identified by a keyword) could be in its place.

Action: Check the spelling and position of the arguments on the command line.

SQL*Loader-00104 Invalid bad file name on command line

Cause: The bad file name specified on the command line was not recognized. It could be misspelled, or another argument (not identified by a keyword) could be in its place.

Action: Correct it.

SQL*Loader-00105 Invalid data file name on command line

Cause: The datafile name specified on the command line was not recognized. It could be misspelled, or another argument (not identified by a keyword) could be in its place.

Action: Check the spelling and position of the arguments on the command line.

SQL*Loader-00106 Invalid discard file name on command line

Cause: The discard file name specified on the command line was not recognized. It could be misspelled, or another argument (not identified by a keyword) could be in its place.

Action: Check the spelling and position of the arguments on the command line.

SQL*Loader-00107 Invalid maximum number of discards

Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.

Action: Check the command line and retry.

SQL*Loader-00108 Invalid number of logical records to load

Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.

Action: Check the command line and retry.

SQL*Loader-00109 Invalid number of logical records to skip

Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.

Action: Check the command line and retry.

SQL*Loader-00110 Invalid maximum number of errors

Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.

Action: Check the command line and retry.

SQL*Loader-00111 Invalid number of rows for bind array or data saves

Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.

Action: Check the command line and retry.

SQL*Loader-00112 Invalid maximum bind array size

Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.

Action: Check the command line and retry.

SQL*Loader-00113 Invalid silent mode option

Cause: The only valid options for the SILENT command-line argument are ALL, ERROR, FEEDBACK, or HEADER. The argument could be misspelled, or another argument (not identified by a keyword) could be in its place.

Action: Check the command line and retry.

SQL*Loader-00114 Error in OPTIONS statement

Cause: Command line options specified in the SQL*Loader control file with the OPTIONS clause were found to be incorrect.

Action: Check the format of the OPTIONS clause in the SQL*Loader control file.

SQL*Loader-00115 Invalid direct path option

Cause: The only valid options for the DIRECT command-line argument are TRUE or FALSE. The argument could be misspelled, or another argument (not identified by a keyword) could be in its place.

Action: Check the command line and retry.

SQL*Loader-00116 Error prompting for password

Cause: An internal error has occurred.

Action: Contact Oracle Support Services.

SQL*Loader-00118 Invalid parallel load option

Cause: The command-line argument used for the parallel load is incorrect.

Action: Use only TRUE or FALSE as the value for the parallel load option.

SQL*Loader-00119 Invalid parallel file (data file) name on command line

Cause: The command-line argument for the parallel file was entered incorrectly.

Action: Check the command line argument and retry the operation.

SQL*Loader-00121 Invalid skip_unusable_indexes option

Cause: The command line argument for SKIP_UNUSABLE_INDEXES is incorrect.

Action: Use only TRUE or FALSE as the value for the SKIP_UNUSABLE_INDEXES option.

SQL*Loader-00122 Invalid skip_index_maintenance option

Cause: The command line argument for SKIP_INDEX_MAINTENANCE is incorrect.

Action: Use only true or false as the value for the SKIP_INDEX_MAINTENANCE option. (Note: only on direct loads!)

SQL*Loader-00123 specified value for bindsize(number) less than readsize(number)

Cause: The command line argument specified for BINDSIZE was less than the value of READSIZE.

Action: No action is required. SQL*Loader automatically adjusts the value of BINDSIZE to equal the value of READSIZE.

SQL*Loader-00124 specified value for readsize(number) less than bindsize(number)

Cause: The command line argument specified for READSIZE was less than the value of BINDSIZE.

Action: No action is required. SQL*Loader automatically adjusts the value of READSIZE to equal the value of BINDSIZE.

SQL*Loader-00125 specified value for readsize(number) less than max_record_size(number)

Cause: The command line argument specified for read size was less than the value of MAX_RECORD_SIZE.

Action: No action is required. SQL*Loader automatically adjusts the value of read size to equal the value of MAX_RECORD_SIZE.

SQL*Loader-00126 Invalid read size

Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.

Action: Check the command line and retry.

SQL*Loader-00127 Invalid maximum record size

Cause: The argument's value is inappropriate, or another argument (not identified by a keyword) is in its place.

Action: Check the command line and retry.

SQL*Loader-00128 unable to begin a session

Cause: An error occurred when attempting to start a session on the database.

Action: See the message that follows this message for information on the cause of the error.

SQL*Loader-00129 Invalid number of rows for direct path column array

Cause: The argument's value is inappropriate.

Action: Check the command line and retry.

SQL*Loader-00130 Invalid direct path stream size

Cause: The argument's value is inappropriate.

Action: Check the command line and retry.

SQL*Loader-00131 Invalid multithreading option

Cause: The only valid options for the MULTITHREADING command-line argument are TRUE or FALSE. The argument could be misspelled or another argument (not identified by a keyword) could be in it's place.

Action: Check the command line and retry.

SQL*Loader-00132 invalid argument for external table option

Cause: The command line argument specified for external_tables was not TRUE or FALSE.

Action: Check the command line and retry.

SQL*Loader-00133 Can't specify both direct path and external tables

Cause: Both options for direct path and external tables were indicated. Only one of these can be applied at a time.

Action: Change at least one of the parameters to enable only one.

SQL*Loader-00134 invalid option specified for EXTERNAL_TABLE parameter

Cause: An invalid value was specified for the EXTERNAL_TABLE parameter.

Action: Specify one of the following values:

  • NOT_USED disables use of external tables.
  • GENERATE_ONLY generates the SQL statements that will use external tables to load the data.
  • EXECUTE both generates the SQL statements and then executes them.

SQL*Loader-00135 Invalid argument for RESUMABLE

Cause: The command-line argument specified for RESUMABLE was not TRUE or FALSE.

Action: Check the command line and retry.

SQL*Loader-00136 Invalid argument for RESUMABLE_NAME

Cause: The command-line argument specified for RESUMABLE_NAME was not a valid string.

Action: Check the command line and retry.

SQL*Loader-00137 Invalid value for RESUMABLE_TIMEOUT

Cause: The command-line argument specified for RESUMABLE_TIMEOUT was not a valid positive integer.

Action: Check the command line and retry.

SQL*Loader-00138 Invalid value for DATE_CACHE

Cause: The command-line argument specified for DATE_CACHE was not a valid positive integer.

Action: Check the command line and retry.

SQL*Loader-00200 FORMAT clause should not be present - flat data files only

Cause: SQL/DS FORMAT clause is not supported.

Action: Remove the FORMAT command from the SQL*Loader control file or comment it out.

SQL*Loader-00250 Work data sets are not used by SQL*Loader

Cause: The SQL*Loader control file contains a WRKDDN statement. SQL*Loader ignores this clause. This is an informational message.

Action: No action required.

SQL*Loader-00251 Sort devices are not used by SQL*Loader

Cause: The SQL*Loader control file contains a SORTDEVT statement. SQL*Loader ignores this clause. This is an informational message.

Action: No action required.

SQL*Loader-00252 Sort data sets are not used by SQL*Loader

Cause: The SQL*Loader control file contains a SORTNUM statement. SQL*Loader ignores this clause. This is an informational message.

Action: No action required.

SQL*Loader-00253 DB2 partition number has no significance -- ignored

Cause: The SQL*Loader control file contains a PART statement. SQL*Loader ignores this clause. This is an informational message.

Action: No action required.

SQL*Loader-00254 Cannot have DISCARDFILE specs here when multiple data files

Cause: The control file contained multiple INFILE statements and a DISCARDFILE statement was found below the RESUME clause.

Action: Move the DISCARDFILE statement above the RESUME clause, so it is adjacent to one of the INFILE statements.

SQL*Loader-00255 Log file for error recovery not used by SQL*Loader

Cause: The SQL*Loader control file contains a LOG statement. SQL*Loader ignores this clause. This is an informational message.

Action: No action required.

SQL*Loader-00256 SORTED INDEXES option allowed only for direct path

Cause: The SQL*Loader control file contains a SORTED INDEXES statement, but it was not used in a direct path load.

Action: Specify a direct path load with DIRECT=TRUE on the command line, remove the statement from the SQL*Loader control file, or comment it out.

SQL*Loader-00257 TERMINATED BY EOF option not valid with ENCLOSED BY option

Cause: A field description in the SQL*Loader control file contains both the TERMINATED BY EOF and the ENCLOSED BY options. These options are mutually exclusive.

Action: Remove either or both of the clauses.

SQL*Loader-00258 Maximum number of SORTED INDEXES (number) exceeded on table string

Cause: There are too many indexes in the SORTED INDEX clause. The message displays the maximum number that are permitted.

Action: Reduce the number of indexes specified in the SORTED INDEX clause or use the conventional path load instead of the direct path load.

SQL*Loader-00259 Could not escalate DDL share lock to exclusive on table string

Cause: This error occurs when another user has a parse lock on the table, for example, when another user is doing a select on the table. The parse lock should clear momentarily.

Action: Give the parse lock a chance to clear and then retry or else use the conventional path load.

SQL*Loader-00260 TERMINATED BY EOF option available only with LOBFILE option

Cause: The TERMINATED BY EOF option can be used only when describing data to be loaded from a LOBFILE. It cannot be specified at the table level and it cannot be for data in "regular" datafiles.

Action: Verify that you have specified the correct option for TERMINATED BY and verify that the TERMINATED BY option is specified for the correct fields.

SQL*Loader-00261 illegal use of TERMINATED BY for RAW field

Cause: The TERMINATED BY option cannot be used for loading data of type RAW from the datafile. The only exception is when loading RAW data from LOBFILES. In that case, you may specify the TERMINATED BY EOF option.

Action: Remove the TERMINATED BY option from the RAW field in the SQL*Loader control file.

SQL*Loader-00262 PIECED keyword (on column string) allowed only when path is direct

Cause: The PIECED keyword cannot be used in a conventional path load.

Action: Remove the PIECED keyword or use the direct path load.

SQL*Loader-00263 PIECED column string must be last specified column in table string

Cause: A column that is not the last column was specified as PIECED.

Action: Remove the PIECED keyword or place the column last.

SQL*Loader-00264 File mode token string parsed but ignored

Cause: An obsolete file mode token was used in the SQL*Loader control file. As of Release 1.1 of SQL*Loader, the file-processing options string is used to control file processing, rather than keywords like STREAM, RECORD, FIXED, and VARIABLE.

Action: No action required. This message is informational. Removing the obsolete keywords will eliminate the message without changing the way in which the datafile is processed.

SQL*Loader-00265 Unable to get default character set name.

Cause: SQL*Loader was unable to locate the default character set name for the environment.

Action: Supply a character set name with the CHARACTERSET keyword.

SQL*Loader-00266 Unable to locate character set handle for string.

Cause: SQL*Loader could not find the character set handle for the named character set.

Action: Correct the character set name.

SQL*Loader-00267 Control file must be first data file.

Cause: The SQL*Loader control file is specified as containing data using the INFILE "*" clause, but other datafiles were named first.

Action: Move the INFILE "*" clause so that it is the first datafile declared in the SQL*Loader control file.

SQL*Loader-00268 UNRECOVERABLE keyword may be used only in direct path.

Cause: The UNRECOVERABLE keyword can only be specified in the direct path load.

Action: Use the direct path load or remove the keyword (conventional path loads are always recoverable).

SQL*Loader-00269 Null string not allowed as clause comparison text.

Cause: A clause is being compared to a null string.

Action: Modify the clause to compare to at least one character.

SQL*Loader-00270 TERMINATED BY EOF valid only for CHAR or RAW datatypes

Cause: A field description in the SQL*Loader control file used the TERMINATED BY EOF option when the field was not a RAW or CHAR datatype.

Action: Modify the SQL*Loader control file to either remove the TERMINATED BY EOF clause or change the datatype for the field to be CHAR or RAW.

SQL*Loader-00271 Not a Parallel load. Table level OPTIONS statement ignored.

Cause: A table-level OPTIONS statement was specified for a non-parallel load.

Action: Remove the OPTIONS statement from the SQL*Loader control file.

SQL*Loader-00272 Table level OPTIONS statement ignored.

Cause: In the parallel load option, the file specified on the command line overrides the file specified in the SQL*Loader control file.

Action: Remove the OPTIONS statement from the SQL*Loader control file.

SQL*Loader-00273 READBUFFERS may be used only in direct path.

Cause: The READBUFFERS specification was not entered as part of a direct path.

Action: Use the direct path or remove the READBUFFERS specification from the SQL*Loader control file.

SQL*Loader-00274 At least 2 read buffers have to be specified.

Cause: Fewer than 2 read buffers have been specified.

Action: Specify at least 2 read buffers in the READBUFFERS statement in the SQL*Loader control file.

SQL*Loader-00275 Data is in control file but "INFILE *" has not been specified.

Cause: The INFILE specification was not entered in the SQL*Loader control file.

Action: If data in the SQL*Loader control file is to be read, specify INFILE * in the SQL*Loader control file.

SQL*Loader-00276 Local storage option overrides global storage.

Cause: A storage clause has been specified in the table level options statement and also in the global options statement. Table level options take precedence over global options. This is a warning message.

Action: Drop the table level options statement if this is not the intent.

SQL*Loader-00277 Local file specification overrides global file specification.

Cause: A file name has been specified in the table level options statement and also in the global options statement. Table level options take precedence over global options. This is a warning message.

Action: Drop the table level options statement if this is not the intent.

SQL*Loader-00278 Incorrect file specification for parallel load.

Cause: The file name used to perform the parallel load was entered incorrectly.

Action: Correct the file name and re-invoke parallel loader.

SQL*Loader-00279 Only APPEND mode allowed when parallel load specified.

Cause: INSERT, REPLACE, or TRUNCATE mode was used in a parallel load specification.

Action: Change the SQL*Loader control file to use the APPEND keyword and re-invoke the parallel loader.

SQL*Loader-00280 table string is a temporary table

Cause: The SQLLDR utility does not load temporary tables. Note that if SQLLDR did allow loading of temporary tables, the data would disappear after the load completed.

Action: Load the data into a non-temporary table.

SQL*Loader-00281 Warning: ROWS parameter ignored in parallel mode.

Cause: Specifying save points using the ROWS parameter is not supported for parallel loads.

Action: Remove the ROWS parameter from the command-line arguments or specify a non-parallel direct load to have save points performed.

SQL*Loader-00282 Unable to locate character set handle for character set ID (number).

Cause: SQL*Loader could not find the character set handle for the given character set ID.

Action: The character set ID was obtained from the database server, the SQL*Loader client does not have knowledge of the given character set ID. Possible mismatch of NLS data on the client and server side.

SQL*Loader-00283 file processing string 'string' ignored for INFILE *

Cause: The SQL*Loader control file specified INFILE * for a load data file along with an optional file processing string. This message is a warning that the file processing string will be ignored since SQLLDR will expect the data to have the same record format as the SQL*Loader control file.

Action: If the data in the SQL*Loader control file is in the same format as the rest of the SQL*Loader control file, then you do not need to do anything. Removing the file processing string will get rid of this error message. If the data in the SQL*Loader control file has a different record format, then you need to copy the data into a separate file and use that file's name in the INFILE clause.

SQL*Loader-00284 Warning: Input data file string specified multiple times.

Cause: The same input datafile is loaded multiple times. This can occur if the INFILE keyword is placed out of order in the load syntax statement, which causes the filename of the first datafile loaded to default to the name of the control file with an extension or file type of DAT.

Action: Check that INFILE keyword is not placed after one of these - BADFILE/BADDN/DISCARDFILE/DISCARDDN/DISCARDS.

SQL*Loader-00285 string may be used only in conventional path

Cause: HIDDEN can only be specified in the conventional path load.

Action: Use the conventional path load.

SQL*Loader-00286 ROWS parameter is not supported when loading an IOT.

Cause: Specifying save points using the ROWS parameter is not supported when loading an IOT.

Action: Remove the ROWS parameter from the command-line arguments.

SQL*Loader-00287 No control file name specified

Cause: No control file name was provided at the control prompt.

Action: Provide the name of a valid control file at the prompt or on the command line.

SQL*Loader-00288 Delimiters may not be specified for collections stored in SDF

Cause: A TERMINATED BY or ENCLOSED BY clause was found along with an SDF (secondary data files) clause for a nested table or varray field.

Action: The TERMINATED BY and ENCLOSED BY clauses may be specified only if the nested table or VARRAY data is stored in the record in the main data file. If you are loading nested table or VARRAY data from a secondary data file, you must use COUNT to indicate the number of elements in the secondary data file that are stored in the file.

SQL*Loader-00289 SQL string for column string occludes SQL string for column string

Cause: A SQL string has been associated with both a column object and one of it's attributes in the control file. Because the SQL string of the column object will replace the entire column object in the VALUE clause of the INSERT statement, the SQL string of the attribute is ignored. This could cause unexpected or incorrect values to be loaded.

Action: Correct the control file so that only the column object or it's attribute has a SQL string, but not both.

SQL*Loader-00290 PIECED keyword (on column string) allowed only for lob or long columns

Cause: The PIECED keyword cannot be used for non lob or long columns.

Action: Remove the PIECED keyword or use lob or long column type.

SQL*Loader-00291 Invalid bind variable string in SQL string for column string.

Cause: A bind variable may not refer to a filler field or to a non-existent field. Also, when running in direct-path mode, a bind variable may not refer to field that represents a LOB stored in a secondary file or a collection.

Action: Remove the offending bind variable from the SQL string.

SQL*Loader-00303 Non-hex character encountered where hex char expected

Cause: A non-hex character was found in a hexadecimal string.

Action: Change it to the intended hexadecimal character.

SQL*Loader-00304 Illegal combination of non-alphanumeric characters

Cause: The SQL*Loader control file contains a combination of non-alphanumeric characters that SQL*Loader does not recognize. For example, the combination != is recognized as "not equal", but the combination =! is not valid.

Action: Remove the unrecognized characters from the control file.

SQL*Loader-00305 More than one end of file character encountered

Cause: The file contains multiple end-of-file marks.

Action: Remove the excess end-of-file characters.

SQL*Loader-00306 Token longer than max allowable length of number chars

Cause: The SQL*Loader control file contains a single word or combination of characters (a token) that is longer than the maximum permissible value. The maximum possible value is shown. This error could result from missing spaces, so that multiple tokens are joined.

Action: Check that the proper SQL*Loader control file is being executed. Separate tokens, if joined, or shorten the token.

SQL*Loader-00307 Warning: conflicting lengths number and number specified for column string table string

Cause: The SQL*Loader control file specifies two different lengths for the named column. There are three ways to specify the length of a field:

  • with the POSITION keyword: POSITION(1:3)
  • with the length specifier: CHAR(6)
  • with the implied length of a datatype; for example, INTEGER

A conflict could occur between any two of these specifications (or among all three, but only two are shown). A common cause of this error is the specification of some numeric datatype, such as INTEGER, when the numeric external form is intended (INTEGER EXTERNAL). The external form consists of character data, so it is considerably longer than the numeric form, which consists of binary data.

Action: No action is necessarily required, because SQL*Loader uses only one of the lengths. Check the log file under the heading "Len" in the table-description section to see which length was used. Adjusting the SQL*Loader control file to produce uniform length specifications will remove the warning.

SQL*Loader-00308 string SQL string of column string must be in double quotes

Cause: A SQL string was found that was not quoted or in single quotes.

Action: Use double quotes for the SQL string, rather than single quotes.

SQL*Loader-00309 No SQL string allowed as part of string field specification

Cause: Particular field types do not allow SQL strings as part of their field specification (e.g. field corresponding to a LOB column). This was violated and needs to be corrected.

Action: Remove the SQL string from the particular field specification.

SQL*Loader-00350 Syntax error at line number.

Cause: number identifies the line in the SQL*Loader control file at which the error occurred. This message is followed by another of the form:

Expecting str1, found str2

where str1 is a description of what SQL*Loader expected in the SQL*Loader control file, and str2 is what was found. Then SQL*Loader displays the offending line from the SQL*Loader control file, indicating the location of the error in the line by a carat (^). or an asterisk (*). An example follows:

SQL*Loader-350: Syntax error at line 28 Expecting column name, found keyword CHAR col3 ENCLOSED BY '"', CHAR ENCLOSED "'",

Action: Compare the DDL syntax against the syntax diagrams in Oracle9i Database Utilities and make any necessary corrections.

SQL*Loader-00401 End field position number must be greater than or equal to start number

Cause: The named field contains a (START:END) clause in which end is less than start.

Action: Modify the clause so that end is greater than or equal to start.

SQL*Loader-00402 Unable to determine length of column string from specification

Cause: The specified datatype does not have an implied length (for example, a numeric external or RAW datatype), it is not specified with delimiters, no length was specified, and a length cannot be determined from a POSITION clause.

Action: If a POSITION clause is specified, adding an end location to it produces a length specification. This clause then has the form:

POSITION(start:end)

A length can also specified after the datatype, as in:

INTEGER EXTERNAL (6)

Finally, the field could be specified with delimiters, or the datatype changed to one that has an implied length.

SQL*Loader-00403 Referenced column string not present in table string.

Cause: The named column is not present in the given table.

Action: Correct the column name or table name.

SQL*Loader-00404 Column string present more than once in string's INTO TABLE block.

Cause: The named column is specified more than once in a single INTO TABLE statement.

Action: Remove the extraneous column specification.

SQL*Loader-00405 Need termination delim with optional enclosure delim: column string table string

Cause: The named column was specified with an optional enclosure delimiter, but no termination delimiter. Enclosure delimiters can only be optional when termination delimiters are present.

Action: Specify a termination delimiter or make the enclosure delimiters non-optional.

SQL*Loader-00406 If data is all generated, number to load cannot be ALL

Cause: When only generated data is loaded, a number to load must be given so SQL*Loader knows when to stop.

Action: Specify a number to load.

SQL*Loader-00407 If data is all generated, number to skip is meaningless

Cause: When all data is generated, no file is read, and there are no records to skip.

Action: Remove the number to skip.

SQL*Loader-00408 Physical record stack overflow

Cause: An internal error has occurred.

Action: Contact Oracle Support Services.

SQL*Loader-00409 Number to skip must be table-level, not load-level on continued loads

Cause: The SKIP parameter was specified on the command line or in the OPTIONS statement, but the load was specified as continued with CONTINUE_LOAD. When a multiple-table direct load is interrupted, it is possible that a different number of records were loaded into each table. As a result, the number of records to skip must be specified for each table when continuing the load. In this case, the load is specified as continued with the CONTINUE_LOAD statement, and the number of records to skip is given in each INTO TABLE statement. See also messages 410 and 411 for more information.

Action: Check the log file to determine the appropriate number of records to skip for each table and specify this number in the INTO TABLE statement for each table in a continued load or with the command-line SKIP parameter in a standard load.

SQL*Loader-00410 Number to skip must be load-level, not table-level

Cause: A SKIP clause was found in the INTO TABLE statement of a standard (non-continued) load. In a standard load, specified with LOAD DATA, it is not possible to skip a different number of records for each table. The number of records to skip must be specified for the entire load by using the SKIP parameter on the command line or in the OPTIONS clause. If table-level skip is required, because a different number of records were loaded into each table (only possible for a multiple-table direct load), then specify a continued load with the CONTINUE_LOAD statement. See also messages 409 and 411 for more information.

Action: If the load was not a multiple-table, direct path load, then move the SKIP clause from the INTO TABLE statements to the command line or to the OPTIONS clause. Otherwise, specify the load as continued with CONTINUE_LOAD.

SQL*Loader-00411 Only a direct path load may be continued

Cause: The load is specified with CONTINUE_LOAD, but DIRECT=FALSE. CONTINUE_LOAD is only possible for a direct path load and is only necessary for a multiple-table, direct path load when a different number of records have been loaded into each table. See also messages 409 and 410 for more information.

Action: If CONTINUE_LOAD is necessary, specify a direct load and put the number of records to skip in each INTO TABLE statement. Otherwise, use the command line or OPTIONS clause to specify the number of records to skip and use LOAD DATA instead of CONTINUE_LOAD.

SQL*Loader-00412 More columns specified for table string than the maximum (number)

Cause: More columns were specified for the table than the maximum number allowed by the database.

Action: Remove the extraneous columns.

SQL*Loader-00413 NULLIF or DEFAULTIF clause specified for filler field string in table string.

Cause: A NULLIF or DEFAULTIF clause was specified in the SQL*Loader control file for the named filler field. These options cannot be specified for filler fields.

Action: Remove the NULLIF or DEFAULTIF clause from the field definition.

SQL*Loader-00414 no columns to load for table string

Cause: There were no fields in the datafile to be loaded for the table. Probably all fields were identified as FILLER fields.

Action: Verify that the FILLER attribute was set correctly for the fields.

SQL*Loader-00415 column string in table string cannot use and be the object of an SDF or LOBFILE.

Cause: The named column is identified as the target of a secondary datafile (SDF) or LOBFILE clause. However, the column also gets its value from an SDF or LOBFILE. If a field name is named in an SDF or LOBFILE clause, then that field cannot have an SDF or LOBFILE clause.

Action: Verify that the SDF and LOBFILE clauses in the SQL*Loader control file name the correct fields. Also verify that the SDF and LOBFILE clauses are specified for the correct field.

SQL*Loader-00416 SDF caluse for field string in table string references a non existent field.

Cause: The secondary datafile clause for the field identified another field that does not exist in the table definition for the SQL*Loader control file.

Action: Verify the definition of the secondary datafile to make sure it identifies the intended field.

SQL*Loader-00417 SQL string (on column string) not allowed in direct path.

Cause: Because the direct path bypasses SQL processing, the SQL string cannot be used.

Action: Remove the SQL string or use the conventional path.

SQL*Loader-00418 Bad datafile datatype for column string

Cause: The datatype in the data file specified for the column cannot be used to load the column. This message is often displayed for columns that need to be loaded with special features. For example, BFILE columns can only be loaded via the BFILE directive in the control file; same goes for REF fields in the SQL*Loader control file. Similarly, REF columns can only be loaded with the REF datatype in the SQL*Loader control file.

Action: Determine the datatype of the column in the database check the documentation for the correct mechanisms to use to load columns of that type.

SQL*Loader-00419 input datatype for column string is not supported when loading varrays

Cause: The datatype in the SQL*Loader control file for the column is cannot be used to load data in a VARRAY.

Action: Use a different datatype.

SQL*Loader-00420 unsupported datatype conversion requested for column string in table string

Cause: The column needs to have its data converted to another datatype before loading the data. The required conversion cannot be done by SQLLDR.

Action: Verify that the correct datatype was specified for the column.

SQL*Loader-00421 error converting data

Cause: This message can be displayed as one of the reasons for rejecting a row. The SQLLDR utility was attempting to convert data for the column from its datatype in the datafile to the datatype for the column in the database. This message should be followed with another message describing the conversion error.

Action: Correct the data in the datafile so that it can be converted.

SQL*Loader-00422 constant element count of number for column string is greater than maximum, number

Cause: The number of elements specified for a VARRAY column in a table is greater than the maximum number of elements allowed for the type of the VARRAY column.

Action: Increase the number of elements allowed for the type or remove unwanted elements from the datafile.

SQL*Loader-00423 element count is greater than maximum allowed for the column

Cause: When building a VARRAY from the datafile, SQL*Loader encountered more VARRAY elements than are allowed for the column.

Action: The previous error messages contain the name of the column and the row number containing the bad data.

SQL*Loader-00424 table string makes illegal reference to collection field string

Cause: A WHEN, OID or SID clause for the table refers to a field declared inside of a collection.

Action: Move the data containing the value for a SID or OID clause outside of the collection definition.

SQL*Loader-00425 column string makes illegal reference to collection field string

Cause: A clause, such as NULLIF or BFILE clause, for the column refers to a field declared inside of a collection.

Action: Move the data containing the value for a SID or OID clause outside of the collection definition.

SQL*Loader-00426 count of elements in VARRAY string comes after the data for the varray

Cause: The COUNT clause for a VARRAY field indicates that the count of elements in the VARRAY is stored in another data field. However, that data field comes after the VARRAY data in the datafile. Since finding the count field would require SQL*Loader to know the number of elements in the VARRAY first, SQL*Loader requires that the count field come before the VARRAY data.

Action: Move the count field to be before the collection data in the data file.

SQL*Loader-00427 a field condition references a non-scalar field or a LOB field string

Cause: The field condition is referencing a field which is either a nested table, VARRAY, column object, LOB or BILE field. These fields with these types cannot be referenced by other fields.

Action: Correct the NULLIF, DEFAULTIF, or WHEN clauses to reference only non-LOB scalar data fields.

SQL*Loader-00428 count for field string not stored in character or integer field

Cause: The count clause for a field references another field, but the referenced field is not a character or integer datatype.

Action: Modify the count field so that it reference a a data field that has the count in an integer or character format.

SQL*Loader-00429 insufficient number of elements found for varray

Cause: The COUNT directive was specified for a VARRAY, but the number of elements found is less than the number specified by the COUNT directive.

Action: Correct the data so that the count and the number of elements agree.

SQL*Loader-00430 NULL nested table element is not allowed

Cause: A row in a nested table was set to NULL. Nested tables cannot contain NULL fields.

Action: Correct the data so that there are no NULL rows in the nested table.

SQL*Loader-00431 illegal NULLIF or DEFAULTIF clause specified for nested table column string

Cause: Rows in a nested table cannot be set to NULL. SQLLDR displays this error when a NULLIF clause was specified for the element that defines the row that makes up a nested table. SQLLDR also displays this error if a DEFAULTIF clause is specified for an element that is a named type, since SQLLDR will set a named type to NULL if the DEFAULTIF evaluates to TRUE.

Action: Use only legal clauses.

SQL*Loader-00432 converted data too large

Cause: This message is preceded by a message identifying a row and column. It is displayed when there is insufficient room to convert the data from the datatype in the input file to the datatype for the column in the database.

Action: Modify the data so that it fits in the database field.

SQL*Loader-00433 no attributes found for column object string in table string

Cause: No attributes are to be loaded for a column object named in the control file. This can happen if all fields in the definition for the column object in the control are designated as FILLER fields.

Action: Either specify attributes to load for the column object or remove the column object from the control file.

SQL*Loader-00434 Can not load LOBs in a nested table along with the parent table

Cause: Loading LOBs within a nested table at the same time as the parent table is not supported.

Action: Load the nested table with the LOB separately from the parent table.

SQL*Loader-00440 Invalid table specified as scope of a REF

Cause: As part of the REF directive one specifies the table name or another fields name which contains the table name of the table which the REF references.

Action: Make sure that the right referenced table name is specified.

SQL*Loader-00456 end of collection found after number elements when looking for number elements

Cause: A count value was specified for a VARRAY or nested table column and the number of rows found is less than the number of rows specified.

Action: Verify that the count field has the correct value and that there is no missing data for the collection.

SQL*Loader-00457 Comparison text of CONTINUEIF LAST must have length 1 not number

Cause: The comparison text is too long. It can only be one character.

Action: Reduce the comparison text to one character.

SQL*Loader-00458 Comparison text ('string') of CONTINUEIF LAST must be non-whitespace

Cause: The comparison text is a white space character (blank or tab).

Action: Change the comparison text to a non-white space character.

SQL*Loader-00459 error fetching numeric value for sequence on column (string)

Cause: An attempt was made to retrieve a non-numeric value for a sequenced column.

Action: Verify that the data for the sequenced column is numeric. Then retry the operation.

SQL*Loader-00460 Column (string), form of use (number) does not match char set id of (number)

Cause: The given column with the given form of use does not have the same character set ID as a previous column with the same form of use.

Action: This should not happen. Contact Oracle Support Services and supply the following information: DDL for the table being loaded, and the SQL*Loader control file.

SQL*Loader-00461 direct path loading of datatype for column string not supported

Cause: The datatype for the specified column is one that cannot be loaded with direct path.

Action: If the datatype is supported with conventional path, load the table using conventional path.

SQL*Loader-00462 error inserting LOB into column string, row number, table string

Cause: An error occurred while attempting to write a lob into a row.

Action: See accompanying messages describing why the LOB could not be loaded, what actions SQL*Loader took (if any), and where the errors may be in order to reload.

SQL*Loader-00463 secondary data file for LOB is string

Cause: This message identifies the secondary data file that was in use for populating the LOB when an error occurred.

SQL*Loader-00464 file offset for beginning of lob is string

Cause: This message identifies the offset into the secondary data file that contains the start of the LOB that was being written when an error occurred.

SQL*Loader-00465 string directive expects number arguments, number found.

Cause: A directive such as COUNT() or BFILE() was specified in the control file. The directive specifies a fixed number of arguments, but the SQL*Loader control file contains a different number of arguments.

Action: Correct the SQL*Loader control file so that the directive contains the correct number of arguments.

SQL*Loader-00466 Column string does not exist in table string.

Cause: The SQL*Loader control file specified a table column that does not exist.

Action: Check the name of the table column.

SQL*Loader-00467 attribute string does not exist in type string for table string.

Cause: The SQL*Loader control file specified an attribute that does not exist for the specified type. The table that contains the type is also identified in the error message.

Action: Verify that the correct table in the correct schema is named in the SQL*Loader control file. Also verify that the column name is spelled correctly.

SQL*Loader-00468 OID directive expects 1 argument, number found.

Cause: More than one argument was specified for an OID clause.

Action: Specify the name of the field containing the value to use for the OID. If the OID for the table is user-defined, then do not use the OID clause in the control file.

SQL*Loader-00469 SID directive expects 1 argument, number found.

Cause: More than one argument was specified for a SID clause.

Action: Only specify the name of the field containing the value to use for the SID in the SID clause.

SQL*Loader-00470 table string does not have system generated OID

Cause: You specified an OID clause for a table but the table is either not an object table or the table is an object table but the OIDs for the rows are not system generated.

Action: Verify that the you are loading the correct table. If you are, then you must not specify the OID clause for this table. You should use the OID clause only when the table is an object table, has system generated OIDs and when you want to specify OIDs to be assigned to each row of the table.

SQL*Loader-00471 OID clause has an argument that is CONSTANT

Cause: You specified a CONSTANT as an argument in the OID clause. Since every OID must be unique, you are not allowed to specify a constant.

Action: Store the OID for each row in a filler field and specify the name of the filler field as an argument.

SQL*Loader-00472 collections can contain only one non FILLER field specification.

Cause: More than one non filler field specification is found in a collection field's member field list.

Action: See the correct syntax in Oracle9i Database Utilities. If indeed there is more than one attribute that makes up the particular collection, then it must be a collection of a object type which needs to be specified using the COLUMN OBJECT field specification syntax.

SQL*Loader-00473 nesting of collections is not allowed.

Cause: Nesting of one collection type field description within another is not allowed.

Action: Verify that indeed collection nesting is attempted in the SQL*Loader control file. Correct the mistake.

SQL*Loader-00474 no value set for dynamic file for column string in table string row number

Cause: The data for the named column is in a dynamic LOBFILE or secondary data file. This message is returned when the field containing the name of the file with the data for this field has not been set or is NULL. This could be because the record in the datafile does not match the format described by the SQL*Loader control file.

Action: Correct any errors in the datafile or the SQL*Loader control file.

SQL*Loader-00475 field for dynamic file name is string in table string

Cause: This message is always displayed after message 474.

SQL*Loader-00476 count of elements for collection is not set or null, 0 will be used

Cause: This message is displayed following a message that identifies the column and row that contained the problem. The message indicates that the collection field named in the previous message has the count of elements in the collection stored in another field. This message is displayed if the field containing the count does not have a value or is set to NULL. When this happens, SQL*Loader uses 0 as the number of elements.

Action: If 0 is not the count of elements for the collection, correct the data in the data file.

SQL*Loader-00477 REF directive for field string requires at least two arguments

Cause: The SQL Loader control file contains a REF directive for the field, but only one argument was supplied for the directive. The REF directive always requires at least two arguments.

Action: Supply the missing argument to the REF directive. Remember that you must always supply a table name to the REF directive even if the REF is scoped.

SQL*Loader-00478 unable to continue due to missing filename for LOBFILE or SDF

Cause: The name for a LOBFILE or secondary data file is either missing or NULL for the current row. SQL*Loader is unable to continue loading since it cannot determine how to get the LOB for the next row.

Action: Correct the data file so that there are valid values for all fields containing the names of LOBFILEs and secondary data files.

SQL*Loader-00479 REF directive for column string expects number arguments; found number.

Cause: The number of arguments in the REF directive for the column is incorrect.

Action: Specify the correct number of arguments for REF. Remember that the REF directive always requires a table name. Also, primary key REFs require one arguments for each field in the primary key.

SQL*Loader-00480 EXPRESSION may not be used with elements of a collection

Cause: The EXPRESSION keyword is followed by a required SQL string expression and is used to load a column with the result of the SQL string expression instead of with a value from the input data file. However, this capability is not allowed with elements of a collection.

Action: Remove the EXPRESSION keyword and associated SQL string from the collection element in the control file.

SQL*Loader-00481 HIDDEN may not be used with non-scalar fields

Cause: The HIDDEN keyword is only allowed for scalar fields.

Action: Remove the HIDDEN keyword from the non-scalar field in the control file.

SQL*Loader-00500 Unable to open file (string)

Cause: SQL*Loader could not open the named file.

Action: Check the operating system messages below this one in the log file.

SQL*Loader-00501 Unable to read file (string)

Cause: SQL*Loader could not read the named file.

Action: Check the operating system messages following this message in the log file.

SQL*Loader-00502 unable to open data file 'string' for field string table string

Cause: An attempt to open a LOBFILE or secondary datafile failed.

Action: Check the operating system messages following this message for information on why the open failed. Verify that the correct name is specified for the LOBFILE or secondary datafile.

SQL*Loader-00503 Error appending extension to file (string)

Cause: SQL*Loader could not append the default extension to create the file name. The given name could be too long or contain illegal characters.

Action: Check the specified file name.

SQL*Loader-00504 Error skipping records in file (string)

Cause: SQL*Loader could not open the file or could not read from it.

Action: Check that the file is where it is expected and that read access has been granted.

SQL*Loader-00505 error reading LOBFILE

Cause: An attempt to read a secondary datafile failed.

Action: Check the operating system message that follows this message for more information.

SQL*Loader-00506 formatting error reading SDF or LOBFILE string for column string in table string

Cause: The record format of the named LOBFILE or SDF file is incorrect.

Action: Fix the record formatting problems in the file.

SQL*Loader-00507 unexpected EOF reading SDF or LOBFILE string for column string in table string

Cause: The end of file was reached for a secondary datafile or LOBFILE before the data for the current row was found.

Action: If the file is a LOBFILE, verify the correct datatype was specified for the field. If the file is a secondary datafile, make sure the record format is specified correctly in the SQL*Loader control file.

SQL*Loader-00508 record formating error in data file string

Cause: The data found in the datafile does not correspond to the record format in the SQL*Loader control file.

Action: Verify that all records in the datafile match the format as described in the SQL*Loader control file.

SQL*Loader-00509 System error: string

Cause: A platform-specific error was returned during an operation. This message is used to display the text of the error.

SQL*Loader-00510 Physical record in data file (string) is longer than the maximum(number)

Cause: The datafile has a physical record that is too long.

Action: Use CONCATENATE or CONTINUEIF. Break up the physical records.

SQL*Loader-00511 Unable to initialize read functions

Cause: SQL*Loader could not initialize the read functions.

Action: Check the errors below this message in the log file for more information.

SQL*Loader-00512 Unable to free read buffer

Cause: An internal error has occurred.

Action: Contact Oracle Support Services.

SQL*Loader-00513 Unable to close file (string)

Cause: SQL*Loader could not close the named file.

Action: Check the errors below this message in the log file for more information.

SQL*Loader-00514 Error getting elapsed time

Cause: SQL*Loader could not get the elapsed time from the system.

Action: No action required.

SQL*Loader-00515 Error getting CPU time

Cause: SQL*Loader could not get the CPU time from the system.

Action: No action required.

SQL*Loader-00516 Control file (string) has no contents

Cause: The named file was found to be empty.

Action: Check that the intended file was referenced and that it is not empty.

SQL*Loader-00517 Error decomposing file name (string)

Cause: SQL*Loader could not break down the file name into its component parts.

Action: Check the file name for illegal characters.

SQL*Loader-00518 Error reassembling file name (string)

Cause: SQL*Loader could not put the file name back together again from its components.

Action: Check the file name for illegal characters.

SQL*Loader-00520 lfimknam failed for file (string)

Cause: LFI failed to make a name object for the file.

Action: Contact Oracle Support Services.

SQL*Loader-00521 lfilini failed for file (string)

Cause: LFI failed to create or initialize a file object for the file.

Action: Contact Oracle Support Services.

SQL*Loader-00522 lfiopn failed for file (string)

Cause: LFI failed to open the file.

Action: Check for any possible operating system errors and/or potential memory problems.

SQL*Loader-00523 error number writing to file (string)

Cause: Could not write to specified file.

Action: Check the following:

  • the file resides in the specified location
  • you have write privileges on the file
  • you have sufficient disk space
  • you have not exceeded your disk quota

If all of these conditions are satisfied, then retry the operation.

SQL*Loader-00524 partial record found at end of datafile (string)

Cause: An incomplete record was found at the end of the indicated datafile.

Action: Make sure the last record in the datafile is complete and has the correct terminating character(s). Also, if fixed-length records are in use, verify that no record exceeds the platform-specific length for a single record.

SQL*Loader-00525 OCI return status: success

Cause: The message describes the status code returned by an OCI call.

Action: See surrounding messages for more information.

SQL*Loader-00526 OCI return status: success with info

Cause: The message describes the status code returned by an OCI call.

Action: See surrounding messages for more information.

SQL*Loader-00527 OCI return status: no data

Cause: The message describes the status code returned by an OCI call.

Action: See surrounding messages for more information.

SQL*Loader-00528 OCI return status: error

Cause: The message describes the status code returned by an OCI call.

Action: See surrounding messages for more information.

SQL*Loader-00529 OCI return status: invalid handle

Cause: The message describes the status code returned by an OCI call.

Action: See surrounding messages for more information.

SQL*Loader-00530 OCI return status: need data

Cause: The message describes the status code returned by an OCI call.

Action: See surrounding messages for more information.

SQL*Loader-00531 OCI return status: still executing

Cause: The message describes the status code returned by an OCI call.

Action: See surrounding messages for more information.

SQL*Loader-00532 OCI return status: continue

Cause: The message describes the status code returned by an OCI call.

Action: See surrounding messages for more information.

SQL*Loader-00533 OCI return status: unknown, value is number

Cause: An unknown status was returned by an OCI call.

Action: See surrounding messages for more information.

SQL*Loader-00552 insufficient privilege to open file

Cause: SQL*Loader does not have the privileges required to open the file.

Action: Verify that the correct file was specified and that the file has the appropriate permissions.

SQL*Loader-00553 file not found

Cause: The specified file cannot be found.

Action: verify that the correct name exists and whether the file is in the intended location.

SQL*Loader-00554 error opening file

Cause: An error occurred while trying to open the file. No further information is available.

Action: Verify that the file is accessible.

SQL*Loader-00555 unrecognized processing option

Cause: The processing option specified for the file cannot be processed.

Action: Verify that the processing options specified for the file contain legal syntax for the platform where SQL*Loader is running.

SQL*Loader-00556 unable to allocate read buffer

Cause: Attempt to allocate the read buffer failed.

Action: If possible, try specifying a smaller size for the read buffer.

SQL*Loader-00557 unable to allocate memory

Cause: An attempt to allocate some memory to track I/O for the file failed.

Action: Contact Oracle Support Services.

SQL*Loader-00558 attempt to use SKIP parameter with linked-in loader

Cause: SKIP parameter was specified with a linked-in file processor.

Action: Do not use the SKIP parameter in this case.

SQL*Loader-00559 error closing file

Cause: An error occurred while closing the file.

Action: Contact Oracle Support Services.

SQL*Loader-00560 error reading file

Cause: An error occurred while reading the file.

Action: Make sure the file is still accessible.

SQL*Loader-00561 end of file

Cause: End of file reached.

SQL*Loader-00562 record too big

Cause: A record in the file is larger than the read buffer.

Action: Verify that the file is not corrupt. If not, try specifying a larger size for the read buffer.

SQL*Loader-00563 bad length for VAR record

Cause: The length portion of a VAR record contains non-numeric data.

Action: Fix the data in the file.

SQL*Loader-00564 illegal hexadecimal literal specified for record delimiter

Cause: A hexadecimal literal that contains the record delimiter for the file does not contain a valid hexadecimal string.

Action: Verify that the correct hexadecimal value was specified in the processing options for the file.

SQL*Loader-00565 unexpected error during skip

Cause: an unexpected error occurred while attempting to skip records.

Action: This message should be followed by another message giving more specific information about the error.

SQL*Loader-00600 Bind size of number bytes increased to number bytes to hold 1 row.

Cause: The space needed to contain a single row is longer than the specified bind size. The value used for the bind size will be increased to handle the larger size.

Action: No action is required. This message will go away if the new value in the error message is specified for the bind size.

SQL*Loader-00601 For INSERT option, table must be empty. Error on table string

Cause: A non-empty table is being loaded with the INSERT option.

Action: Use the REPLACE keyword to empty the old table and store the new data in its place. Use the APPEND keyword to leave the table's contents intact and add the new data to it.

SQL*Loader-00602 Maximum converted length number of column string is too big for bind array

Cause: The named column cannot undergo the specified character set conversion and still be placed in a contiguous piece of memory on the system.

Action: Specify a shorter data column or eliminate the conversion.

SQL*Loader-00603 Maximum length number of column string is too big for bind array

Cause: The named column cannot be put in a contiguous piece of memory on the system.

Action: Specify a shorter data column.

SQL*Loader-00604 Error occurred on an attempt to commit

Cause: An error occurred while trying to commit changes to the database.

Action: Look at the message listed below this one in the log file for more information.

SQL*Loader-00605 Non-data dependent ORACLE error occurred -- load discontinued.

Cause: An error occurred that is independent of the data. For example, an out-of-space condition. Because all further rows will be rejected, the load is discontinued. (If the error were data dependent, then other rows might succeed.)

Action: See the errors below this one in the log file for more information.

SQL*Loader-00606 Object string in INTO TABLE clause is not a local table

Cause: The synonym specified in the INTO TABLE clause in the SQL*Loader control file specifies a remote object via a database link. Only a synonym for an existing local table can be specified in the INTO TABLE clause.

Action: Ensure that a local table name or a synonym for a local table is fully specified in the INTO TABLE clause. The table must already exist.

SQL*Loader-00607 partition not empty for INSERT option; table string, partition string

Cause: An attempt was made to use the INSERT option on a non-empty partition.

Action: Empty the partition, or use the REPLACE or TRUNCATE option.

SQL*Loader-00608 subpartition not empty for INSERT option; table string, subpartition string

Cause: An attempt was made to use the INSERT option on a non-empty subpartition.

Action: Empty the subpartition, or use the REPLACE or TRUNCATE option.

SQL*Loader-00620 Initial enclosure character not found

Cause: A mandatory initial enclosure delimiter was not present. Either it is missing on the current field or the previous field is missing an identical closing delimiter.

Action: Supply the missing delimiters.

SQL*Loader-00621 Field in data file exceeds maximum length

Cause: A field exceeded its maximum allowable length. The maximum length is either the length specified in the SQL*Loader control file, or, for delimitable fields without a length specified, the default maximum length (255 bytes).

Action: Check for missing delimiters and/or shorten the field.

SQL*Loader-00622 Column not found before end of logical record (use TRAILING NULLCOLS)

Cause: The logical record ended before all specified fields were found.

Action: If the missing fields should be loaded as null, use the TRAILING NULLCOLS clause. Otherwise, correct the data.

SQL*Loader-00623 second enclosure string not present

Cause: The logical end of record or the end of a LOBFILE was reached before a second enclosure delimiter was found.

Action: Correct the datafile to include the missing delimiter.

SQL*Loader-00624 no terminator found after TERMINATED and ENCLOSED field

Cause: No termination delimiter was found after the enclosed field ended.

Action: Supply the missing termination delimiter.

SQL*Loader-00625 Multibyte character error in control file.

Cause: Incomplete multi-byte character strings were found in the SQL*Loader control file.

Action: Edit the SQL*Loader control file to check that all multi-byte character data is valid.

SQL*Loader-00626 Character set conversion buffer overflow.

Cause: A conversion from the datafile character set to the client character set required more space than that allocated for the conversion buffer. The size of the conversion buffer is limited by the maximum size of a varchar2 column.

Action: The input record is rejected. The data will not fit into the column.

SQL*Loader-00627 Character set conversion graph not available.

Cause: A conversion from the datafile character set to the client character failed due to the conversion graph not being available.

Action: Contact Oracle Support Services. Check NLSRTL installation.

SQL*Loader-00628 Character set conversion error.

Cause: A character set conversion error occurred.

Action: Contact Oracle Support Services. Check NLSRTL installation. Provide a reproducible test case.

SQL*Loader-00640 Variable length field was truncated.

Cause: The end of the logical record was encountered before the end of a variable length field. The length of each variable-length field is embedded in the field, so SQL*Loader knows that more data should have been present.

Action: Check the data for inadvertent truncation and verify the SQL*Loader control file specifications against the log file; the field may be starting in the wrong place.

SQL*Loader-00641 Invalid packed decimal nibble.

Cause: Each byte in a packed decimal field contains two 4-bit nibbles. Each nibble must have a valid value.

Action: Check the SQL*Loader control file's specifications against the log file to ensure that the field location was specified correctly. Check the contents of the field.

SQL*Loader-00642 Relative start position > absolute field end position.

Cause: A field specified as POSITION(*+n:y) had its relative start occur after the absolute position y.

Action: Check that a delimiter is not missing and that the values of n and y are correct.

SQL*Loader-00643 error executing INSERT statement for table string

Cause: A fatal error occurred while attempting to insert data into the table.

Action: Refer to the messages that follow for more information. If you specified SQL stings for any of your columns, verify that strings are correct. Specifically, check for balanced parenthesis and correct use of quotation marks. Another format error

SQL*Loader-00644 end of logical record found when reading length of varying length field

Cause: While attempting to read the length portion of a varying length field, then end of the logical record was reached.

Action: Verify that the SQL*Loader control file describes the data correctly and that the data in the datafile matches the description in the SQL*Loader control file.

SQL*Loader-00645 error converting character length field to a number

Cause: An error occurred while attempting to convert the characters containing the count portion of a VARCHARC or VARRAWC field.

Action: Verify that the count portion for the column has the correct value.

SQL*Loader-00646 lob set to EMPTY in column string, row number, table string

Cause: Encountered errors (for example parsing errors in LOBFILE) while loading LOBs. The row will remain in the table and its LOB column will be initialized to empty. Loading of other records will continue.

Action: Correct the data file (see accompanying messages) and reload.

SQL*Loader-00647 Integer to number conversion error

Cause: An error occurred while attempting to convert an integer to Oracle number format.

Action: Verify that the integer field in the data file is a valid integer. If the INTEGER(N) syntax was used, then verify that the specified length is valid.

SQL*Loader-00649 Quoted string missing closing quote

Cause: A quoted string in the control file is missing a closing quote.

Action: Insert the closing quote as appropriate.

SQL*Loader-00650 incomplete lob data written for column string, row number, table string

Cause: Encountered errors (for example, such as parsing errors in LOBFILE) while loading LOBs using direct path. The row will remain in the table and its LOB column may not be complete. Loading of other records will continue.

Action: Correct the data file (see accompanying messages) and reload.

SQL*Loader-00651 error skipping lob for column string, row number, table string

Cause: Encountered errors (for example, such as parsing errors in LOBFILE) while skipping LOBs.

Action: Correct the data file (see accompanying messages) and reload.

SQL*Loader-00652 Invalid zoned decimal byte.

Cause: Each byte of a zoned decimal field must have a valid value based on the character set encoding used. ASCII-based zoned decimals must follow the formats specified in the VAX Architecture Reference Manual. EBCDIC-based zoned decimals must follow the formats specified in the ESA/390 Principles of Operations, version 8.1.

Action: Check the SQL*Loader control file's specifications against the log file to ensure that the field location was specified correctly. Check the contents of the field.

SQL*Loader-00653 XML data set to NULL in column string, row number, table string

Cause: Encountered errors (for example, such as parsing errors in LOBFILE) while loading LOBs into an XML column. The row will remain in the table and its XML column will be initialized to null. Loading of other records will continue.

Action: Correct the data file (see accompanying messages) and reload.

SQL*Loader-00654 Variable length field exceeds maximum length.

Cause: A variable length field (with a leading length subfield) exceeded its maximum allowable length. The maximum length is either the length specified in the SQL*Loader control file, or, the default if not specified (4 KB).

Action: Shorten the field and its length.

SQL*Loader-00700 Out of memory while performing essential allocations [number]

Cause: SQL*Loader could not allocate the memory it needs.

Action: Check the operating system and process memory. Increase memory available to SQL*Loader, if possible. If using direct path, try lowering the columnarrayrows option (see log file for current default value).

SQL*Loader-00702 Internal error - string

Cause: An internal error has occurred.

Action: Make a note of the message and contact Oracle Support Services.

SQL*Loader-00703 Internal error: argument number

Cause: An internal error has occurred.

Action: Make a note of the message and the number, then contact Oracle Support Services.

SQL*Loader-00704 Internal error: string [number]

Cause: An internal error has occurred.

Action: Make a note of the message and the number, then contact Oracle Support Services.

SQL*Loader-00705 Internal error

Cause: An internal error has occurred.

Action: Contact Oracle Support Services.

SQL*Loader-00706 Bad argument to ulerr [number].

Cause: An internal error has occurred.

Action: Contact Oracle Support Services.

SQL*Loader-00707 Sql*Loader exiting with return code=[number].

Cause: An internal error has occurred.

Action: Contact Oracle Support Services.

SQL*Loader-00708 Internal error: unknown status number returned from sllf layer

Cause: An unknown status was returned by a call to the sllf layer.

Action: Contact Oracle Support Services.

SQL*Loader-00709 Internal error calling SLTS layer: string failed

Cause: A nonsuccess status was returned by a call to the SLTS layer.

Action: Contact Oracle Support Services.

SQL*Loader-00710 Internal error: direct path stream buffer not loaded

Cause: A direct path stream buffer was built but not loaded.

Action: Contact Oracle Support Services.

SQL*Loader-00711 Internal error: bad address for little endian UTF16 conversion

Cause: Address for little endian UTF16 data not in a valid buffer.

Action: Contact Oracle Support Services.

SQL*Loader-00712 Internal error: bad address for big endian UTF16 conversion

Cause: Address for big endian UTF16 data not in a valid buffer.

Action: Contact Oracle Support Services.

SQL*Loader-00800 string specified and ignored

Cause: An option was specified that is not supported by External Table load.

Action: Do not specify the unsupported option or do not use External Table load.

SQL*Loader-00801 all INTO TABLE clauses must have the same options (string)

Cause: At least two INTO TABLE clauses have different options set.

Action: Set the options to be the same or do the loads separately.

SQL*Loader-00802 numeric EXTERNAL with DEFAULTIF clause not supported by External Table

Cause: A numeric EXTERNAL type was specified with a DEFAULTIF clause and that is not supported by External Table Load.

Action: Remove the clause if possible or do not use External Table Load.

SQL*Loader-00803 string field type not supported by External Table

Cause: The specified field type is not supported by External Table Load.

Action: Remove the specified field type or do not use External Table Load.

SQL*Loader-00804 SEQUENCES with intervals are not supported by External Table Load.

Cause: A sequence with an interval is specified and is not supported by External Table Load.

Action: Remove the interval from the sequence, or the sequence itself, or do not use External Table Load.

SQL*Loader-00805 string not supported by External Table

Cause: The specified option is not supported by External Table Load.

Action: Remove the specified option or do not use External Table Load.

SQL*Loader-00806 unknown record format specified for data file

Cause: The osd string containing file processing options in the control file specified an unknown file processing option.

Action: Verify the correct options are specified for the platform being used.

SQL*Loader-00807 error loading table

Cause: An INSERT statement used to load a table from an external table or a temporary internal table failed. The statement that failed is shown immediately preceding this message.

Action: See subsequent messages for more information about the error.

SQL*Loader-00808 error creating sequence: string

Cause: An attempt to create a sequence needed for the load failed.

Action: See messages that follow this one for information about the failure.

SQL*Loader-00809 error dropping sequence: string

Cause: A sequence needed to be dropped either because SQL*Loader found a sequence with the same name it is trying to create or because SQL*Loader is cleaning up from sequences it created at the beginning of the load.

Action: See messages that follow this one for information about why the attampt to drop the sequence failed.

SQL*Loader-00810 error creating external table: string

Cause: An attempt to create the external table sued for the load failed.

Action: See messages that follow for more information about the failure.

SQL*Loader-00811 error dropping external table: string

Cause: An error occurred when trying to drop an external table. Note that the table may have been left from a previous load.

SQL*Loader-00812 error creating internal table: string

Cause: An error was encountered trying to create a temporary internal table. The internal table is used only when loading multiple tables from the same data file. The internal table is loaded once and the target tables are loaded from the internal table.

SQL*Loader-00813 error dropping internal table: string

Cause: An error was encountered trying to drop a temporary internal table. The internal table is used only when loading multiple tables from the same data file. The internal table is loaded once and the target tables are loaded from the internal table. The internal table may have been left from a previous build.

SQL*Loader-00814 error loading internal table: string

SQL*Loader-00815 error enabling parallel DML for external table load

SQL*Loader-00816 error creating temporary directory object string for file string

Cause: No existing directory object was found in the database for the directory containing the file. Since all files loaded by external tables must be in a directory named by a directory object, SQL*Loader tried to create a directory object for the file.

Action: See error messages that follow this message for more information.

SQL*Loader-00817 error dropping directory object string

Cause: SQL*Loader created a directory object as part of an external table load. An attempt to cleanup the directory object failed.

Action: See messages following this one for more information about the error.

SQL*Loader-00818 creating external table: string

SQL*Loader-00819 executing insert statement for database table: string

SQL*Loader-00820 cannot create where clause with range for table string

Cause: The EXTERNAL_TABLE parameter was specified for a multi-table load, and a WHEN clause for one of the tables contains a reference to a range of bytes in the record. SQL*Loader uses the WHEN clause from the control file to generate the WHERE clause in the INSERT statement. If the WHERE clause contains a reference to a range of bytes in the table, then a valid WHERE clause can not be generated. Note that SQL*Loader will proceed as if GENERATE_ONLY was specified for the EXTERNAL_TABLE parameter.

Action: Modify the control file to only use field references in the WHEN clause. Note that this may require creating a filler field. Another alternative is to create one control file for each table to be loaded and load the table separately.

SQL*Loader-00821 switching to GENERATE_ONLY

Cause: SQL Loader is not able to execute the SQL statements it generated for loading the data using external tables. See previous messages for more information.

SQL*Loader-00901 Error logging on to ORACLE:

Cause: An attempt was made to log on to Oracle in direct path load mode.

Action: Ensure that the instance is up and running. Check the Oracle messages below this one in the log file for more information.

SQL*Loader-00902 Error opening cursor: [number]

Cause: An internal error has occurred.

Action: Check the Oracle messages below this one in the log file and contact Oracle Support Services.

SQL*Loader-00903 Database must be at least version number.number.number.number.number for direct path

Cause: The direct path load mode is being used with an incompatible database.

Action: Upgrade the database to the specified version or else use the conventional path load.

SQL*Loader-00904 You cannot used the direct path when linked with v5 of the database

Cause: The direct path mode is being used after SQL*Loader has been linked with a Version 5 database.

Action: Use the conventional path.

SQL*Loader-00905 Error parsing SQL statement for upi: [number]

Cause: This is a header message.

Action: Check the message below this one in the log file for more information.

SQL*Loader-00906 Error executing SQL statement for upi: [number]

Cause: An internal error has occurred.

Action: Check the message below this one in the log file for more information.

SQL*Loader-00908 Unable to lock table string due to ORACLE error number

Cause: SQL*Loader could not get a DML exclusive lock on the table it needed.

Action: Check the message below this one in the log file for more information. Find the object number of the table in the catalog view USER_OBJECTS. Use the SQL*DBA MONITOR LOCK command to list all processes with outstanding locks. Identify the process that has the lock on the table. Then use the MONITOR PROCESS command to find out who is connected as the Oracle process holding the lock and get them to relinquish it, or wait and retry.

SQL*Loader-00909 Loader views must be loaded (as SYS) for direct path to be used

Cause: Database views required for the direct path mode are not present.

Action: The Oracle9i Database Administrator's Guide details how to run the required scripts as user SYS for loading the required views.

SQL*Loader-00910 Error binding input variables for upi: [number]

Cause: This is a header message.

Action: Check the message below this one in the log file for more information.

SQL*Loader-00911 Error defining output variable(s) for upi: [number]

Cause: This is a header message.

Action: Check the message below this one in the log file for more information.

SQL*Loader-00913 Error fetching results of select statement (upi): [number]

Cause: This is a header message.

Action: Check the message below this one in the log file for more information.

SQL*Loader-00914 Error locking table string in exclusive mode.

Cause: The direct path mode could not lock the named table.

Action: Check the message below this one in the log file for more information. Check that the necessary privileges have been granted.

SQL*Loader-00915 Error closing cursor: [number]

Cause: This is a header message.

Action: Check the message below this one in the log file for more information.

SQL*Loader-00916 Error checking path homogeneity

Cause: To do a direct path load when the front end and back end of the database are on separate hardware systems, the systems must be identical, using the same machine, operating system, and character set. This error occurs when SQL*Loader detects a difference between the systems that will prevent a direct load from operating properly.

Action: Use a conventional path load for this configuration.

SQL*Loader-00918 The catalog must be loaded (as SYS) for SQL*Loader to be used

Cause: The catalog is not loaded.

Action: Logon as user SYS and load the Oracle catalog and the views in the script ULVIEW.SQL.

SQL*Loader-00919 Error during upi fetch: [number]

Cause: An internal error has occurred.

Action: Check the message below this one in the log file for more information.

SQL*Loader-00925 Error while string

Cause: An internal error has occurred.

Action: Check the message below this one in the log file for more information. The table or column referenced may not be accessible.

SQL*Loader-00926 OCI error while string for table string

Cause: An OCI error has occurred.

Action: Check the message below this one in the log file for more information. The table or column referenced may not be accessible.

SQL*Loader-00927 Table string does not exist

Cause: SQL*Loader could not find the named table. The specified table may not exist. On some systems, this message will also appear if the necessary privileges have not been granted.

Action: Check that the table exists, its name is spelled properly, and that the necessary privileges on it have been granted.

SQL*Loader-00929 Error parsing insert statement for table string.

Cause: The table's insert statement caused a parse error.

Action: Check all SQL strings that were used.

SQL*Loader-00930 Error parsing insert statement for table string column string.

Cause: The named column's INSERT statement caused a parse error.

Action: Check the message below this one in the log file for more information. Check the SQL string used for this column.

SQL*Loader-00931 OCI error while binding variable for column string in table string

Cause: An OCI error has occurred.

Action: Check the errors below it for more information. The SQL string for this column may be in error.

SQL*Loader-00932 Could not truncate table string.

Cause: Truncation of the table was attempted and failed.

Action: Check the following errors for more information. Truncation due to referential constraints should not occur.

SQL*Loader-00933 Specified file string not part of database

Cause: The specified file name to load the table is not a database file.

Action: Specify a valid datafile.

SQL*Loader-00934 Incorrect data file string specified for table string

Cause: A datafile name was given to load the table that is not a part of the tablespace in which the table resides.

Action: Specify a valid datafile.

SQL*Loader-00935 Error verifying required option for parallel load.

Cause: An error was encountered because a required option was not found or was invalid.

Action: Correct the problem as described in the accompanying Oracle message.

SQL*Loader-00936 Unable to lock table string partition/subpartition string due to ORACLE error number

Cause: Loader could not lock the partition/subpartition it needed.

Action: Have the holder of the lock relinquish it or retry the operation.

SQL*Loader-00937 parallel load requested and string has enabled triggers or constraints

Cause: A request was made for a parallel direct load, but the object to be loaded has an enabled constraint (check, referential) and/or enabled triggers.

Action: Disable the offending enabled constraints and/or triggers and retry the parallel direct load.

SQL*Loader-00938 partition load requested and string has enabled triggers or constraints

Cause: A request was made for a direct load of a single partition, but the object to be loaded has an enabled constraint (check, referential) and/or enabled triggers.

Action: Disable the offending enabled constraints and/or triggers and retry the parallel direct load.

SQL*Loader-00939 OCI error while string for table string partition string

Cause: This is a header message.

Action: Check the following errors for more information. The table or partition referenced may not be accessible.

SQL*Loader-00940 UPI error while setting NCHAR bind attributes for column string table string

Cause: An error occurred while setting the CHARSETFORM attribute of an NCHAR column.

Action: This is an internal error. Report to Oracle Support Services.

SQL*Loader-00941 Error during describe of table string

Cause: An error occurred while executing a DESCRIBE of a SELECT list on the given table. Check the error immediately preceding this error.

Action: Check to make sure that the table name, and all column names specified in the SQL*Loader control file are correct.

SQL*Loader-00942 partition string not part of table string

Cause: The specified partition is not part of the specified table.

Action: Check to make sure that the partition specified is correct (that it is indeed a partition of the specified table.

SQL*Loader-00943 incorrect datafile string specified for table string partition string

Cause: The specified datafile is not in the tablespace of the specified partition. This error is most likely due to the use of FILE= keyword on a partitioned table. When loading all partitions of a partitioned table, the partitions must be in the same tablespace. When loading a single partition, the tablespace of the partition being loaded must be the same as the tablespace in which the specified datafile file resides.

Action: Check to make sure that the datafile specified via the FILE=keyword is in the tablespace of the partition being loaded.

SQL*Loader-00944 error preparing insert statement for table string.

Cause: A call to OCIStmtPrepare for the table's insert statement returned an error.

Action: Refer to the message that follows for information about the error returned by OCIStmtPrepare. Make sure the syntax is correct for all SQL strings specified in the SQL*Loader control file.

SQL*Loader-00945 record size number too large for direct path

Cause: The maximum size of records in the datafile is larger than the maximum size supported by direct path, which is 65535

Action: Load the datafile using conventional path.

SQL*Loader-00946 OCI error while string for table string subpartition string

Cause: This is a header message.

Action: Check the following errors for more information. The table or subpartition referenced may not be accessible.

SQL*Loader-00947 subpartition load requested and string has enabled triggers or constraints

Cause: A request was made for a direct load of a single subpartition, but the object to be loaded has an enabled constraint (check, referential) and/or enabled triggers.

Action: Disable the offending enabled constraints and/or triggers and retry the parallel direct load.

SQL*Loader-00948 subpartition string not part of table string

Cause: The specified subpartition is not part of the specified table.

Action: Check the subpartition and table names.

SQL*Loader-00949 incorrect datafile string specified for table string subpartition string

Cause: The specified datafile is not in the tablespace of the specified subpartition. Due to use of FILE=keyword on a subpartitioned table. When loading all subpartitions of a subpartitioned table, the subpartitions must be in the same tablespace. When loading a single subpartition, the tablespace of the subpartition being loaded must be the same as the tablespace in which the specified datafile file resides.

Action: When loading a single subpartition, make sure the tablespace of the subpartition being loaded is the same as the tablespace in which the specified datafile file resides.

SQL*Loader-00950 Error shipping data structures across 2-task

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00951 Error calling once/load initialization

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00952 Error calling once/data file initialization

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00953 Error shipping read buffer across 2-task

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00954 Error shipping index to read buffer across 2-task

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00955 Error calling col array build, block formatter

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00956 Error calling once/data file finishing

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00957 Error shipping text string across 2-task

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00958 Error popping data relocation address stack

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00959 Error shipping buffer across 2-task

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00961 Error calling once/load finishing for table string

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00962 Error setting user-side Ctrl-C handler

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00963 Error clearing user-side Ctrl-C handler

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00965 Error number disabling constraint string on table string

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00966 Error number disabling all triggers on table string

Cause: This is a header message.

Action: Check the error(s) below it for more information.

SQL*Loader-00969 Error performing file name translation on kernel side

Cause: File specified for parallel load is probably not a valid database file.

Action: Specify a valid database file.

SQL*Loader-02026 The load was aborted because SQL Loader cannot continue.

Cause: The load cannot continue. See the error message before this message for the cause of the error.

Action: See the action for the error message that precedes this one.

SQL*Loader-02050 Multibyte character error.

Cause: Text specified by POSITION or terminated by newlines is invalid.

Action: Edit the SQL*Loader control file or the datafile to fix alignment of the column.

SQL*Loader-03120 Resumable parameters ignored -- current session not resumable

Cause: Current session is not resumable.

Action: Must specify RESUMABLE=TRUE to enable resumable session in order for the RESUMABLE_NAME and RESUMABLE_TIMEOUT parameters to take effect.

SQL*Loader-03121 Maximum record length of [number] exceeded for bad or discard file

Cause: There is a limit on the maximum size of the record which can be written to the bad or discard file. SQL*Loader encountered a record that exceeded this limit.

Action: See the next message which follows this message to know which record exceeded the limit. Modify that record, if necessary, and try to load again.


External Tables Messages (KUP)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

20
External Tables Messages (KUP)

This chapter lists messages generated by the external tables feature. For more information about the external tables feature, refer to Oracle9i Database Utilities.

KUP-00550 parser package failed to load

Cause: An attempt to load parser package returned an error indication.

Action: This message should be accompanied by other error messages indicating the cause of the error.

KUP-00552 internal XAD package failed to load

Cause: An error was encountered while attempting to initialize the XAD package.

Action: This message should be accompanied by other error messages indicating the cause of the error.

KUP-00554 error encountered while parsing access parameters

Cause: The parser detected a syntax error.

Action: This message should be accompanied by other error messages indicating the cause of the error.

KUP-00561 invalid length for binary integer field string

Cause: An integer field was specified with an invalid length. The only supported lengths for binary integer fields are 1, 2, 4, and 8.

KUP-00562 unknown escape sequence

Cause: An unknown escape sequence was specified to the parser. An escape sequence is a backslash followed by a character.

Action: Consult the documentation for a list of allowable control characters.

KUP-00600 internal error, arguments [string] [string] [string] [string] [string]

Cause: An internal XAD error occurred.

Action: Contact Oracle Support Services.

KUP-00601 fatal XAD error

Cause: A fatal error has occurred.

Action: This message should be accompanied by other error messages indicating the cause of the error.

KUP-01006 error signalled during parse of access parameters

Cause: An error was signalled during parsing of the access parameters.

Action: This message should be accompanied by other error messages indicating the cause of the error.

KUP-01007 at line number column number

Cause: This is an informational message indicating the line and column where a syntax error was detected.

KUP-01008 the bad identifier was: string

Cause: This is an informational message indicating the identifier token that caused a syntax error.

KUP-02000 wrong message file version (msg number not found)

Cause: The kupxx.msb file is not the correct version.

Action: Check that the installation was done correctly.

KUP-02001 unrecognized punctuation symbol "string"

Cause: An illegal punctuation character was encountered.

Action: Remove the illegal character.

KUP-02002 unexpected end of input file reached

Cause: This is probably caused by failure to supply the closing quote for a quoted string.

Action: Correct the input.

KUP-02003 unrecognized character: string

Cause: An input character that is neither an alpha, digit, or punctuation was encountered.

Action: Remove the offending character.

KUP-02004 quoted string too big

Cause: A quoted string longer than 2000 bytes was encountered.

Action: This may be caused by a missing closing quote. If so, then add the missing quote. Otherwise, shorten the string.

KUP-02005 token too big

Cause: A token longer than 1000 bytes was encountered.

Action: Tokens must be separated by whitespace or punctuation. Either add the missing whitespace or punctuation, or shorten the token.

KUP-02006 script line too long

Cause: A line longer than 500 bytes was encountered.

Action: Break the line up into shorter lines.

KUP-03001 fatal error during library cache pre-loading

Cause: This message should be accompanied by other error messages indicating the cause of the error.

Action: Check the accompanying errors.

KUP-03002 end position (number) <= start position (number) for field: string

Cause: Error in specifying position for the specified field in the access parameters.

Action: Check that the specified end position is greater than the specified start position.

KUP-03003 absolute end(number) - start(number) != fieldlength (number) for field string

Cause: The number of bytes occupied by the field as specified by the starting offset and ending offset of the field is not the same as the number of bytes specified for the datatype of the field.

Action: Verify that the specified absolute begin/end positions match the length of the field.

KUP-03004 absolute end (number) specified with relative start (number) for field string

Cause: The position of field was specified with a relative start and an absolute end.

Action: Use relative end with relative start.

KUP-03005 relative end (number) specified does not match fieldlen(number) for field string

Cause: The number of bytes specified by the relative end position for the field does not match the number of bytes in the datatype.

Action: Correct either the datatype length or the relative end position.

KUP-03006 error initializing handle for character set string

Cause: Error attempting to retrieve information for the character set.

Action: Verify that the character set name is valid.

KUP-03007 end position (number) is less than start position (number) for range

Cause: A byte range specified a start position that comes after the end position.

Action: Verify the start and end positions are correctly specified.

KUP-03008 OCI error getting column parameters.

Cause: An error occurred while trying to obtain column parameters.

Action: Contact Oracle Support Services.

KUP-03009 OCI error getting column name.

Cause: An error occurred while trying to obtain column name.

Action: Contact Oracle Support Services.

KUP-03010 OCI error getting database column type.

Cause: An error occurred while trying to obtain database column type.

Action: Contact Oracle Support Services.

KUP-03011 OCI error getting database column size.

Cause: An error occurred while trying to obtain database column size.

Action: Contact Oracle Support Services.

KUP-03012 OCI error getting database column precision.

Cause: An error occurred while trying to obtain database column precision.

Action: Contact Oracle Support Services.

KUP-03013 OCI error getting database column scale.

Cause: An error occurred while trying to obtain database column scale.

Action: Contact Oracle Support Services.

KUP-03014 OCI error getting datetime fsprecision.

Cause: An error occurred while trying to obtain a datetime column precision value.

Action: Contact Oracle Support Services.

KUP-03015 OCI error getting datetime lfprecision.

Cause: An error occurred while trying to obtain database column precision.

Action: Contact Oracle Support Services.

KUP-03016 length specified for FIXED records must be greater than 0

Cause: A record format of FIXED was specified with a length of 0.

KUP-03017 length specified for VARIABLE records must be greater than 0

Cause: A record format of VARIABLE was specified with a length of 0.

KUP-03020 empty delimiter specified for record

Cause: An empty delimiter string was specified for a record delimiter.

Action: Specify the string used to delimiter records.

KUP-03021 clause references unknown field string

Cause: A WHEN, NULLIF, or DEFAULTIF clause referenced a field that doesn't exist in the data file.

KUP-03022 lob data could not be found for field string

Cause: The field specified in the data source that contains the name of the lob file for the record could not be identified.

KUP-03999 error occurred while processing a date format: ORA-number: string

Cause: Error converting a date format string into an internal representation.

Action: Verify that the date format strings specified in the access parameters are valid.

KUP-04000 error initializing IO state for file string in string

Cause: An unexpected error occurred while preparing the file.

Action: Contact Oracle Support Services.

KUP-04001 error opening file string

Cause: An error occurred while attempting to open the specified file. This message should be followed by another message with more information about the error.

Action: See the error that follows to determine the action to be taken.

KUP-04002 error getting file size for file string

Cause: An error occurred while retrieving the number of bytes in the specified file.

Action: See the error that follows to determine the action to be taken.

KUP-04003 error while closing file string

Cause: An error occurred while closing the specified file.

Action: See the error that follows to determine the action to be taken.

KUP-04004 error while reading file string

Cause: An error occurred while reading the specified file.

Action: See the error that follows to determine the action to be taken.

KUP-04005 file operation successful

Cause: A file operation succeeded.

Action: No action required.

KUP-04006 file operation failed

Cause: An operation on a file failed. The file is named in the message preceeding this one.

Action: See the subsequent message for more information about the error.

KUP-04007 end of file reached

Cause: The end of file was reached for a file. The file is named in the message preceding this one.

Action: See the message that follows this one for more information.

KUP-04008 access to file denied

Cause: Acess to a file was denied. The file is named in the message preceding this one.

Action: See the message that follows for more information. Verify that the correct files are being used and that the appropriate access is allowed to those files.

KUP-04009 invalid SLF handle

Cause: An internal error caused a data structure associated with the file to become corrupt.

Action: Contact Oracle Support Services.

KUP-04010 file does not exist

Cause: A file operation failed because a file does not exist. The message preceding this message contains the name of the file.

Action: Verify that the correct file name was specified.

KUP-04011 file system is full

Cause: An operation on a file failed because the file system is full. The message preceding this one contains the name of the file.

Action: Free space on the file system or move the file to a different file system.

KUP-04012 file length is too large for output field

Cause: Size of a file is too large.

Action: Break the file up into smaller files.

KUP-04013 other system error

Cause: Internal SLF component was unable to complete an operation because of a system error.

Action: The message displayed before this message describes the operation that was being performed when the error occurred.

KUP-04014 invalid SLF parameter

Cause: An invalid parameter was passed in a call to the internal SLF component.

Action: Contact Oracle Support Services.

KUP-04015 internal SLF error

Cause: Internal SLF component encountered an internal error.

Action: Contact Oracle Support Services.

KUP-04016 unknown SLF status code number

Cause: Internal SLF component returned an unknown error code.

Action: Contact Oracle Support Services.

KUP-04017 OS message: string

Cause: An error occurred. This message contains the message associated with this error that was returned by the operating system. The message displayed before this one should indicate the operation that failed.

KUP-04018 partial record at end of file string

Cause: An incomplete record was found at the end of the file.

Action: Verify the file is not corrupt or missing data.

KUP-04019 illegal length found for VAR record in file string

Cause: A record in a VAR file has a length field containing either no numeric characters or non-numeric characters.

Action: Verify that the records in the file have the correct specified length.

KUP-04020 found record longer than buffer size supported, number, in string

Cause: a record in the data source was longer than the maximum data size supported. The number reported is the maximum supported size of a record.

KUP-04021 field formatting error for field string

Cause: There was an error trying to find the contents of the specified field in a record.

Action: This message should be followed by another message containing more specific information about the cause of the error.

KUP-04022 field start is before start of record

Cause: The position of the start of a field is before the start of a record. This can occur if a negative number is used to indicate the relative start of a field.

Action: Verify that the definition of the layout of fields in the data file is correct.

KUP-04023 field start is after end of record

Cause: This can happen when specifying either absolute or relative positioning for a field.

Action: Verify that the definition of the layout of fields in the data file is correct. If it is valid for fields at the end of the record to be missing, then use the MISSING FIELD VALUES ARE NULL clause in the access parameters.

KUP-04024 field end is before field start

Cause: The end of the field comes after the start of the field. This can happen if the field is defined with a relative start position and an absolute end position.

Action: Verify that the definition of the layout of fields in the data file is correct.

KUP-04025 field extends beyond end of record

Cause: This can happen when specifying either absolute or relative positioning for a field.

Action: Verify that the definition of the layout of fields in the data file is correct.

KUP-04026 field too long for datatype

Cause: The character field in the record is larger than the maximum length specified.

Action: Make sure the definition of the layout of the fields in the data file is correct. Also make sure the correct maximum size was specified for a character datatype.

KUP-04028 conversion of character length to a number failed

Cause: The character length portion of the field could not be converted to a number. This message is followed by another message with information on why the conversion failed.

Action: Make sure the data is correct. Also verify the specified datatypes for the fields are correct.

KUP-04029 numeric field overflowed

Cause: An attempt to convert a character string to a number failed because the value of the number in the string was too large.

KUP-04030 invalid numeric data

Cause: An attempt to convert a character string to a number failed because non-numeric characters were found.

KUP-04032 internal error string while parsing field string:

Cause: An internal error occurred while parsing a field.

Action: Contact Oracle Support Services.

KUP-04035 beginning enclosing delimiter not found

Cause: The beginning enclosure was not found for a field that is enclosed by delimiters.

Action: Verify that the data is correct. Also verify that the correct enclosing delimiters were specified and whether the enclosing delimiter should be optional.

KUP-04036 second enclosing delimiter not found

Action: Verify that the data is correct. Also verify that the correct enclosing delimiters were specified.

KUP-04037 terminator not found

Cause: The terminator for the field is missing.

Action: Verify that the records are formatted correctly.

KUP-04038 internal error: string

Cause: an unexpected error condition was detected.

Action: contact Oracle Support Services.

KUP-04039 unexpected error while trying to find file string in string

Cause: An error occurred while trying to find path containing the file.

Action: This message should be followed by another message with more information about the error.

KUP-04040 file string in string not found

Cause: The file was not found in the specified directory.

Action: Verify that the correct file and directory names were specified.

KUP-04041 error generating full file name for string in string

Cause: An unexpected error occurred while trying to form a file name.

KUP-04042 error string

KUP-04043 table column not found in external source: string

Cause: A column in the external table was not found in the access parameters that define the contents of the data source.

Action: Verify that the external table is defined correctly and that the abstract parameters are also correct.

KUP-04044 error positioning file string

Cause: An attempt to position a file to an absolute file offset failed.

Action: See messages that follow for more information.

KUP-04045 unexpected OCI status string

Cause: An OCI call returned a status that cannot be handled.

Action: Contact Oracle Support Services.

KUP-04047 error parsing record from external data source

Cause: An error occurred while trying to extract a record from the data source.

Action: Examine the log file for more messages about the error.

KUP-04048 internal error parsing record from external data source

Cause: An unexpected or unhandled error occurred while getting a record from the data source.

Action: Contact Oracle Support Services.

KUP-04049 record number discarded from file string

Cause: This is an informational message displayed whenever the WHEN clause has been satisfied. If a DISCARD file has been specified for the operation, then the record will be written to that file.

Action: No action required.

KUP-04050 error while attempting to allocate number bytes of memory

Cause: An error occurred while trying to allocate memory. This is likely caused by insufficient memory.

Action: Reconnect to the instance and retry the operation.

KUP-04051 error processing column string in row number for datafile string

Cause: An error occurred while trying to convert the data from the data file into the type of a column in the external table.

Action: See messages that follow for more details.

KUP-04052 error processing column string in a row for datafile string

Cause: An error occurred while trying to convert the data from the data file into the type of a column in the external table.

Action: See messages that follow for more details.

KUP-04053 record number number

Cause: This message identifies a record number in a file for a record that had an error. The message preceding this one contains information about the error and the name of the file.

KUP-04054 internal error: invalid bad row number identified for bad column number

Cause: This is an internal error.

Action: Contact Oracle Support Services.

KUP-04056 internal error: OCI error while fetching record: number

Cause: An OCI error occurred while processing the granule.

Action: Contact Oracle Support Services.

KUP-04057 internal error: OCI error while fetching record.

Cause: An OCI error occurred while processing the granule.

Action: Contact Oracle Support Services.

KUP-04058 unrecoverable error occurred, operation aborted.

Cause: An unrecoverable error occurred during processing.

Action: See preceding error messages for more information.

KUP-04059 found EOF in length portion of VARIABLE record in file string

Cause: The record parser was looking for the size portion of a file a record format of VARIABLE. It found EOF before finding all the bytes for the length.

Action: Correct the corruption in the file.

KUP-04062 no data source specified

Cause: No location for the data source of the external table was specified when the external table was created. An empty string is not valid.

Action: Specify the name of the data source in the LOCATION clause when creating an external table.

KUP-04063 unable to open log file string OS error string

Cause: An attempt to open the log file failed.

Action: Specify a different log file or use NO LOGFILE to disable logging.

KUP-04064 fatal error during initialization

Cause: An unexpected error occurred while initializing access to an external table.

Action: Contact Oracle Support Services.

KUP-04066 error initializing access to external table source

Cause: An error occurred while attempting to retrieve information about a data source.

Action: See messages preceding this one for more information about the error.

KUP-04067 internal error allocating handle type string

Cause: An attempt to create an internal object failed.

Action: Contact Oracle Support Services.

KUP-04068 internal error fetching attribute string

Cause: An attempt to fetch information about an internal object failed.

Action: Contact Oracle Support Services.

KUP-04069 error fetching data for external table

Cause: An error occurred while atempting to fetch data from an external table.

Action: See messages preceding this one for more information about the error.

KUP-04071 record discarded from file string

Cause: This is an informational message displayed whenever the WHEN clause has been satisfied. If a DISCARD file has been specified for the operation, then the record will be written to that file. The record number in the source data file was not known because multiple servers are loading from the file.

KUP-04072 error writing to file string

Cause: An error occurred while attempting to write to the named file.

Action: See messages that follow this message for more information about the error.

KUP-04073 record ignored because all referenced fields are null for a record

Cause: A record was rejected because all fields in the data file referenced by the query were NULL.

KUP-04074 no write access to directory object string

Cause: The user does not have write access to the directory object used for a log, bad, or reject file.

KUP-04075 no read access to directory object string

Cause: The user does not have read access to the directory object used for a data file.

KUP-04076 file name cannot contain a path specification: string

Cause: The name of a data file, log file, bad file, or reject file contained a path specification.

Action: Use the name of a directory object to indicate where the file should be stored.

KUP-04077 unknown format specifier in file name string

Cause: A format specifier is a percent sign followed by a character. The percent sign and character are replaced by a value depending on the character. This error occurs when the character following the percent sign is not defined to have a value.

Action: See the documentation for information on valid format specifiers. If the file to be opened needs to have a percent sign in its name, then use two percent signs. They will get replaced by a single percent sign in the resulting file name.

KUP-04078 invalid file name specified: string

Cause: An attempt to parse the file name failed.

Action: Specify a valid file name.

KUP-04079 error fetching list of valid directories

Cause: An attempt to retrieve a list of valid directories that can be used by the user to open files failed. See messages that follow for more information.

Action: Contact Oracle Support Services. As a workaround, try specifying no log file, no discard files, and no bad files.

KUP-04080 directory object string not found

Cause: The directory object specified for an input file or a log, bad or discard file, does not exist in the database or the user has no privileges to access this directory.

KUP-04088 data sampling is not supported by this access driver

Cause: A query of an external table requested a sample of the data returned. The access driver for the external table does not support sampling.

Action: Do not try to use sampling for this external table.

KUP-04090 big endian byte order mark found when little endian expected in string

Cause: A big endian byte order mark was found at the beginning of the specified file. Either the access parameters specified that the data was in little endian order or the byte order mark for a previous file was little endian.

Action: The file needs to be loaded separately. If a byte order was specified in the access parameters, then make sure it is changed to big endian.

KUP-04091 little endian byte order mark found when big endian expected in string

Cause: A little endian byte order mark was found at the beginning of the specified file. Either the access parameters specified that the data was in big endian order or the byte order mark for a previous file was big endian.

Action: The file needs to be loaded separately. If a byte order was specified in the access parameters, then make sure it is changed to little endian.

KUP-04100 record rejected in file string

Cause: A record in the data file was not loaded into the table because of an error while finding fields in the record. See the previous error for more information. The record will be written to the BAD file, if one is being used. The record number in the source data file is not known because multiple servers are loading from the file.

KUP-04101 record number rejected in file string

Cause: A record in the data file was not loaded into the table because of an error while finding fields in the record. See the previous error for more information. The record will be written to the BAD file, if one is being used.

KUP-04102 record number discarded from file string

Cause: This is an informational message displayed whenever the WHEN clause has been satisfied. If a DISCARD file has been specified for the operation, then the record will be written to that file.

KUP-04103 error converting zoned decimal field to number for string

Cause: An error occurred converting a zoned decimal number to an Oracle number.

Action: Verify that the zoned decimal number is formatted correctly.

KUP-04104 zoned decimal field has bad values for string

Cause: A zoned decimal number has an invalid format.

Action: Verify that the zoned decimal number is formatted correctly.

KUP-04105 zoned decimal to number conversion caused overflow for string

Cause: A zoned decimal number could not be converted to an Oracle number because the number is too big for an oracle number.

Action: Verify that the zoned decimal number is formatted correctly.

KUP-04106 precision for zoned decimal number is too large for string

Cause: The precision of a zoned decimal number is larger than the precision that can be stored in an Oracle number.

Action: Verify that the zoned decimal number is formatted correctly.

KUP-04108 unable to reread file string

Cause: The query that is executing requires that a data source for an external table be read multiple times. However, the data source is a sequential device that cannot be reread. Examples of this type of data source is a tape or pipe.

Action: There are a few ways around this problem. One is to rewrite the query so that the external table is referenced only once. Another option is to move the data source to a rereadable device such as a disk file. A third option is to load the data for the external table into a temporary table and change the query to reference the temporary table.


DBVERIFY Messages (DBV)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

21
DBVERIFY Messages (DBV)

This chapter lists messages generated by the DBVERIFY utility. For more information about this utility, refer to Oracle9i Database Utilities.

DBV-00100 Specified FILE (string) not accessible

DBV-00101 LOGFILE (string) not accessible

DBV-00102 File I/O error on FILE (string) during string operation (number)

DBV-00103 Specified BLOCKSIZE (number) differs from actual (number)

DBV-00104 START (number) exceeds file size

DBV-00105 END (number) exceeds file size

DBV-00106 LOGIN failed with error code (number)"

DBV-00 OCI failure (number) (string)

DBV-00112 USERID incorrectly specified

DBV-00200 Block, dba number, already marked corrupted

Cause: The block was previously corrupted. It has been marked as corrupt by the Oracle database server.

Action: If the block is not currently allocated to a database object, then no action is required. If the block is allocated, then the options and required action depend on the type and nature of the object which owns the block. To repair an allocated block, perform block or file media recovery.


DBNEWID Messages (NID)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

22
DBNEWID Messages (NID)

This chapter lists messages generated by the DBNEWID utility. For more information about this utility, refer to Oracle9i Database Utilities.

NID-00100 Cannot open datafile "string"

Cause: The specified datafile could not be opened.

Action: Ensure that the specified datafile exists and is writable.

NID-00101 LOGFILE (string) not accessible

Cause: The specified log file could not be opened.

Action: Specify a log file that is writable.

NID-00102 Garbled target string

Cause: The supplied connect string could not be parsed. The connect string does not have the correct format.

Action: Refer to Oracle9i Database Concepts.

NID-00103 Missing password in connect string "string"

Cause: Could not find the password in the supplied connect string. The connect string does not have the correct format.

Action: Refer to Oracle9i Database Concepts.

NID-00104 Need to specify TARGET connection parameter in command line

Cause: The mandatory parameter TARGET was not specified.

Action: Specify TARGET=username/password when invoking this utility.

NID-00105 Need to specify "LOGFILE=<logfile>" when using APPEND=YES option

Cause: The APPEND parameter was specified without LOGFILE.

Action: Specify APPEND=YES only when LOGFILE is also specified.

NID-00106 LOGIN to target database failed with Oracle error: string

Cause: An Oracle error was reported while attempting to log in to the target database.

Action: Follow the actions for the specified Oracle error.

NID-00107 File I/O error on datafile "string" during string operation (number/string)

Cause: An operating system error was reported while performing the specified operation in the specified file.

Action: Verify the datafile and check for operating system errors.

NID-00109 DBNAME string length number exceeds maximum length of number

Cause: The specified new database name exceeded the maximum size.

Action: Specify a shorter, valid name.

NID-00110 Cannot use REVERT and specify a database name at the same time

Cause: Conflicting options were specified on the command line.

Action: Choose only one of the options.

NID-00111 Oracle error reported from target database while executing string string

Cause: An Oracle error was reported when executing an OCI operation.

Action: Follow the actions for the specified Oracle error.

NID-00113 Error reading answer - aborting

Cause: Response caused an error.

Action: Retry the operation.

NID-00114 Must specify new database name when SETNAME is used

Cause: SETNAME=YES was specified but no DBNAME was provided.

Action: Specify DBNAME or remove the SETNAME=YES option.

NID-00115 Database should be mounted

Cause: The database was not mounted.

Action: Mount the database.

NID-00120 Database should be mounted exclusively

Cause: The database was started in parallel mode. To change the DBID, the database must be mounted exclusively.

Action: Shut down the database and start it in exclusive mode.

NID-00121 Database should not be open

Cause: The database was open. To change the DBID, the database must be mounted exclusively.

Action: Shut down the database and mount it in exclusive mode.

NID-00122 Database should have no offline immediate datafiles

Cause: The database has one or more datafiles that are in OFFLINE IMMEDIATE mode.

Action: Drop the datafiles or recover them and bring them online.

NID-00123 Magic number for datafile "string" is incorrect

Cause: Block 0 header has an incorrect magic number for the specified datafile.

Action: Verify that the datafile is correct and retry the operation.

NID-00124 Mismatched dbid for datafile string, expected number, found number

Cause: The dbid of the datafile does not match the old DBID or the new DBID.

Action: Verify that this datafile belongs to the database. You may need to restore a backup of the datafile.

NID-00125 Database should have no disabled datafiles

Cause: The database has one or more datafiles that are disabled.

Action: Drop the datafiles or recover them and bring them online.

NID-00126 Database should have no datafiles in unknown state

Cause: The database has one or more datafiles that are in an unknown state.

Action: Drop the datafiles or recover them and bring them online.

NID-00127 All online files in the database must have the same checkpoint SCN

Cause: The database has one or more datafiles that have a checkpoint SCN that does not match the database checkpoint SCN.

Action: Restart the database and shut it down cleanly, then retry the operation.

NID-00128 Cannot revert change of database, change not in progress

Cause: The REVERT option was used, but the control file does not show that a change of DBID was in progress.

Action: Do not use the REVERT option, or possibly restore the control file that was in place when the utility was started.

NID-00129 Invalid DBID for datafile "string", expecting number, found number

Cause: A datafile header shows a different DBID from the rest of the database files.

Action: Ensure that the file belongs to this database.

NID-00130 Mismatched CHECKPOINT_CHANGE# in datafile "string", expecting string, found string

Cause: The datafile header does not match information in the control file.

Action: Revert the change, open the database, and verify that all datafiles are consistent. Then, shut down the database and retry the operation.

NID-00131 Control file is not current

Cause: A non-current control file is currently mounted.

Action: Perform necessary actions to make the control file current and retry.

NID-00132 CHECKPOINT_CHANGE# in datafile "string": string in the future of controlfile: string

Cause: The checkpoint in the datafile header is ahead of the checkpoint in the control file.

Action: Make the database consistent and retry.

NID-00133 Database should have only consistent datafiles

Cause: The database has one or more datafiles that are marked FUZZY in the control file.

Action: Restart the database and shut down consistently, then retry the operation.

NID-00134 Datafile "string" is not consistent

Cause: The datafile is marked as fuzzy in its header.

Action: Restart the database and shut down cleanly, then retry the operation.

NID-00135 There are number active threads

Cause: There are active threads in the database. The most likely cause is that the database crashed the last time it was shut down.

Action: Ensure that all threads are closed before retrying the operation. Start and open the database to perform crash recovery, then shut down with the NORMAL or IMMEDIATE options to close it cleanly. Finally, try running the utility again.

NID-00137 All datafiles that are not dropped should be readable

Cause: The database had one or more files that could not be read.

Action: Restore the missing files and retry the operation.

NID-00138 Block verification failed for datafile string (number)

Cause: Block header checksum yields a nonzero value for the specified datafile.

Action: Verify that the datafile is correct and retry the operation.

NID-00139 Mismatched dbname for datafile string, expected string, found string

Cause: The dbname of the datafile does not match the old dbname or the new dbname.

Action: Verify that this datafile belongs to the database. You may need to restore a backup of the datafile.

NID-00140 Specified database name string does not match previous name used string

Cause: This is a continuation of a failed attempt. However in the failed attempt, the database name is different than the one used in the last attempt.

Action: Retry the command using the original database name.

NID-00141 No database name specified, previous attempt used string

Cause: This is a continuation of a failed attempt. However, in the failed attempt, a database name was provided.

Action: Retry the command using the original database name.

NID-00142 Only changing database name, previous attempt changed dbid to number

Cause: This is a continuation of a failed attempt. However, in the failed attempt, the database id was also being changed.

Action: Retry the command removing SETNAME=YES.

NID-00143 Mismatched controlfile string

Cause: A controlfile did not have the correct status.

Action: Shut down the database, remove the mismatched controlfile, mount the database, and retry the operation.

NID-00144 New name for database string is the same as current name string

Cause: The specified name is the same as the current name of the database.

Action: Specify a different name or do not use the DBNAME option.

NID-00145 nls subsystem initialization failure for product=string, facility=string

Cause: The NLS product/facility error message file could not be located or properly initialized.

Action: Check that the error message directory and files have been properly installed.


Parameter Messages (LCD)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

23
Parameter Messages (LCD)

LCD-00100 internal error, argument [number]

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the circumstances leading to the error and the complete set of messages.

LCD-00111 value not in legal range [string]

Cause: The value of the parameter was outside the valid range.

Action: Check the valid range and retry using a new value.

LCD-00112 illegal integer radix specification [string]

Cause: An invalid character was specified.

Action: Valid characters are 'd', 'h', 'D' and 'H'.

LCD-00113 integer conversion error or negative integer [string]

Cause: A non-integer or negative integer was assigned to an integer parameter.

Action: Retry using a valid integer value.

LCD-00114 illegal boolean response [string]

Cause: An attempt was made to assign a value other than TRUE or FALSE to a boolean parameter.

Action: Use only TRUE or FALSE for boolean parameters.

LCD-00122 unrecognized keyword [string]

Cause: The parameter name has been misspelled.

Action: Spell the parameter name correctly.

LCD-00128 invalid positional parameter value [string]

Cause: An invalid positional parameter value has been entered.

Action: Remove the invalid positional parameter.

LCD-00161 ORACLE error (possible syntax error) parameter [string]

Cause: Possible syntax error. Additional messages follow.

Action: Correct the parameter shown in the error.

LCD-00201 could not open specified filename [string]

Cause: The file specified does not exist.

Action: Create an appropriate parameter file.

LCD-00203 missing keyword [string]

Cause: A keyword is expected but none was found.

Action: Add a keyword followed by an '=' sign and a parameter value.

LCD-00204 left parenth and no parameter specified [string]

Cause: A parameter list was started but no parameter was specified.

Action: Add an appropriate list of values and close the parameter list.

LCD-00205 unbalanced parentheses [string]

Cause: An odd number of parentheses was found, indicating that one is missing or one is extra.

Action: Retry the statement using the correct number of parentheses.

LCD-00206 positional parameter entered after keyword [string]

Cause: An '=' sign is missing.

Action: All keywords must be followed by '=' signs.

LCD-00207 nested parentheses encountered [string]

Cause: Only one set of parentheses is permitted.

Action: Remove the nested parentheses.

LCD-00208 unexpected keyword in value list [string]

Cause: A keyword was found instead of a value.

Action: Insert an appropriate value for the given parameter.

LCD-00209 missing value for keyword at end of string [string]

Cause: A keyword is specified with no value.

Action: Specify a valid value for the keyword.

LCD-00210 illegal assignment operator [string]

Cause: A sign other than '=' was used to assign a keyword a value.

Action: Use only the '=' sign.

LCD-00211 unexpected delimiter [string]

Cause: An invalid delimiter was found between values.

Action: A comma or a space is a valid delimiter.

LCD-00212 runaway quoted string [string]

Cause: The parameter value was quoted on the left side but not on the right.

Action: Quote the parameter value on both sides.

LCD-00215 parameter files nested too deep [string]

Cause: Too many levels of indirection of file parameters. The maximum is three.

Action: Reduce the level of indirection to less than three.

LCD-00217 failure while processing file parameter [string]

Cause: An error occurred while processing the specified file parameter.

Action: Specific details will appear in other messages.

LCD-00218 error in file [string]

Cause: An error occurred in the particular file.

Action: Refer to the other messages for the specific error.

LCD-00219 nested include file [string] is too large

Cause: There is a limit on the size of a parameter file, and it was exceeded. This limit is now 8192 bytes.

Action: Remove characters from the file to make it smaller, or use another level of nesting.


Summary Advisor, Explain Rewrite, and Explain Materialized View Messages (QSM)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

24
Summary Advisor, Explain Rewrite, and Explain Materialized View Messages (QSM)

QSM-00501 unable to initialize Summary Advisor environment

Cause: The Summary Advisor external procedure initialization process failed.

Action: Contact Oracle Support Services.

QSM-00502 OCI error

Cause: An OCI callback routine reported an error

Action: Contact Oracle Support Services.

QSM-00503 out of memory

Cause: Summary Advisor failed to allocate the necessary memory.

Action: Contact Oracle Support Services.

QSM-00504 internal error

Cause: An internal error occurred.

Action: Contact Oracle Support Services.

QSM-00505 syntax error

Cause: A syntax error occurred.

Action: Correct syntax error if possible or contact Oracle Support Services.

QSM-00506 no fact-tables could be found

Cause: The fact-filter is not specified, and there are no fact-tables in the warehouse. A fact-table is a table having foreign-key constraints to one or more of the dimension-tables in the data warehouse.

Action: Check whether:

  • The fact-filter is correctly specified
  • The appropriate constraints exist
  • The user has privileges to access the tables

QSM-00507 no dimensions could be found

Cause: The database does not have any dimensions.

Action: Create the dimensions in your warehouse.

QSM-00508 statistics missing on tables/columns

Cause: The system metadata does not contain statistics on one or more tables or columns. The Advisor needs cardinalities of all fact-tables, and of the level-keys of all dimensions in the data warehouse.

Action: Run ANALYZE on the tables and summaries in the warehouse to collect statistics.

QSM-00509 invalid parameter

Cause: The indicated parameter has an invalid value.

Action: Supply a value in the proper range.

QSM-00510 statistics missing on summaries

Cause: The system metadata does not contain statistics on one or more summaries. The Advisor needs cardinalities of all summaries in the data warehouse.

Action: Run ANALYZE on the tables and summaries in the warehouse to collect statistics.

QSM-00511 invalid fact-tables specified in fact-filter

Cause: The tables specified in the fact-filter are not valid fact-tables. A fact-table must have foreign-key constraints to one or more of the dimension-tables in the data warehouse.

Action: Check whether:

  • The fact-filter is correctly specified
  • The appropriate constraints exist
  • The user has privileges to access the tables

QSM-00512 invalid summaries specified in the retention-list

Cause: The summaries specified in the retention-list are not valid.

Action: Check:

  • The spelling of the summary-names
  • Whether the summary-names are valid
  • The user has privileges to access the summary-names

QSM-00513 one or more of the workload tables is missing

Cause: One or both of the workload tables are missing. The two workload tables which should be present in the user's schema are V_192216243_F_5_E_14_8_1 and V_192216243_F_5_E_15_8_1; the former is mapped to WORK$_IDEAL_MVIEW and the latter to WORK$_MVIEW_USAGE. The workload tables are created by the Oracle Trace Formatter when the data-collection-file (ORACLESM.DAT) is formatted by the user.

Action: Check whether the Formatter succeeded in formatting the data collection. Sometimes the V_192216243_F_5_E_14_8_1 (that is, WORK$_IDEAL_MVIEW) may not be created whereas the other table is created. The most likely cause of this is the initialization parameters needed to invoke mview-rewrite are not enabled. Check your documentation for all the initialization parameters which need to be set for mview-rewrite to occur. Another possibility is no GROUP BY queries were issued during the time the data was collected, in which case, run the Trace collection for a longer time to get a representative sampling of the queries issued in the data warehouse.

QSM-00514 the size of must-retain summaries exceeds specified space limit

Cause: The specified space limit is greater than the size of must-retain summaries.

Action: Reduce the number of must-retain summaries or increase the space limit.

QSM-00515 operation cancelled by user

Cause: The operation has been cancelled by the user.

Action: No action required.

QSM-00516 illegal status detected for run

Cause: The run has encountered an illegal value in the status field of the mview$_adv_log table. This could be an internal error or an application error.

Action: Contact Oracle Support Services.

QSM-00517 Summary Advisor requires a COMPATIBLE setting of 8.1.0.0 or greater

Cause: The current database has a compatibility setting that is earlier than the supported server version.

Action: Adjust the COMPATIBLE instance parameter to 8.1.0.0 or higher.

QSM-00518 Java is not enabled. Please execute INITJVM.SQL and INITQSMA.SQL

Cause: The current database has not been created or upgraded to support Java stored procedures. Summary Advisor requires Java stored procedures.

Action: Connect to the database as a user with SYSDBA privileges. Execute the ORACLE_HOME/javavm/install/initjvm.sql script. Next, execute the ORACLE_HOME/rdbms/admin/initqsma.sql script.

QSM-00519 Summary Advisor is not installed. Please execute INITQSMA.SQL.

Cause: The current database has not been created or upgraded to support Summary Advisor. Summary Advisor requires several Java stored procedures.

Action: Connect to the database as a user with SYSDBA privileges. Execute the ORACLE_HOME/rdbms/admin/initqsma.sql script.

QSM-01001 query rewrite not enabled

Cause: When query rewrite is disabled, no query rewrite will take place.

Action: Enable query rewrite with ALTER SESSION SET QUERY_REWRITE ENABLE command.

QSM-01002 no query rewrite when OPTIMIZER_GOAL is rule based

Cause: Query rewrite will not occur when OPTIMIZER_GOAL is set to rule based.

Action: Change optimizer goal with ALTER SESSION SET OPTIMIZER_GOAL = "goal" command, where goal can be one of "CHOOSE", "FIRST_ROWS" or "ALL_ROWS".

QSM-01003 no query rewrite on DDL queries

Cause: If query contains any data definition operations, no query rewrite will take place. Note that some SELECT statements which are part of a DDL expression may be eligible for rewrite. These include CREATE AS SELECT and CREATE OUTLINE statements.

Action: No action required.

QSM-01007 query has NOREWRITE hint

Cause: When query contains a NOREWRITE hint, no query rewrite will take place for that query block.

Action: Remove the NOREWRITE hint from the query.

QSM-01008 no query rewrite for update queries

Cause: If a query has any SELECT FOR UPDATE operations, no query rewrite will take place.

Action: No action rquired.

QSM-01009 materialized view, string, matched query text

Cause: The query was rewritten using a materialized view, because query text matched the materialized view text.

Action: No action required.

QSM-01010 table(s) in the query not found in materialized view, string

Cause: Either the materialized view does not reference the base tables found in the query or it was found to be ineligible by query rewrite.

Action: No action required.

QSM-01011 when heuristic rewrite not set, rewrite hint required

Cause: When using a stored outline, a rewrite hint is required for query rewrite.

Action: No action required.

QSM-01012 SAMPLE clause present in FROM

Cause: If a query contains a SAMPLE clause, query rewrite will not take place.

Action: No action required.

QSM-01013 nested aggregates or CONNECT BY/START WITH clause present

Cause: If the query contains nested aggregates, CONNECT BY clause, or START WITH clause, query rewrite will not take place.

Action: No action required.

QSM-01014 top level operator in WHERE clause of the query is an OR

Cause: If the top-level operator in the WHERE clause is an OR and there is more than one table in the FROM list, then query rewrite will not take place.

Action: No action required.

QSM-01015 GROUP BY clause has non-columns

Cause: No query rewrite, if there is no valid column in the GROUP BY clause.

Action: No action required.

QSM-01016 Query rewrite does not support aggregate string

Cause: No query rewrite, if the query contains any DISTINCT aggregates other than COUNT, MIN, or MAX.

Action: No action required.

QSM-01018 single table materialized join view rewrite not required

Cause: Unless a REWRITE hint is used or cost based rewrite is turned on,a single base table is not replaced with a materialized join view as this will likely be larger.

Action: No action required.

QSM-01019 no suitable materialized view found to rewrite this query

Cause: There doesn't exist any materialized view that can be used to rewrite this query.

Action: Consider creating a new materialized view.

QSM-01020 materialized view, string, is ineligible

Cause: Materialized view is probably disabled or stale.

Action: Consider refreshing the materialized view or enabling it for rewrite.

QSM-01021 materialized view, string, not found in the hint list

Cause: There is a rewrite hint list specified in the query, but this materialized view is not among the hinted ones.

Action: Include this materialized view in the rewrite hint list.

QSM-01022 a more optimal materialized view than string was used to rewrite

Cause: Query Rewrite always chooses the most optimal materialized view based on certain parameters, such as cardinality of the materialized view, number of joins etc. The specified materialized view was found to be less optimal.

Action: To force using a materialized view, consider using a rewrite hint.

QSM-01025 materialized view, string, not found

Cause: The specified materialized view is not found in the database.

Action: Check the spelling or create a new materialized view.

QSM-01026 query rewrite is disabled for, string

Cause: Query rewrite could not use this materialized view, because query rewrite was not enabled for it.

Action: Enable query rewrite for the materialized view with ALTER MATERIALIZED VIEW "mv" ENABLE QUERY REWRITE command, where "mv" is the name of the materialized view.

QSM-01028 materialized view, string, is currently being refreshed

Cause: Materialized view cannot be used for query rewrite while it is being refreshed.

Action: Rerun the query, after the refresh operation is completed.

QSM-01029 materialized view, string, is stale in ENFORCED integrity mode

Cause: A stale materialized view cannot be used for query rewrite when the query rewrite integrity mode is set to ENFORCED.

Action: Refresh the materialized view or alter the rewrite integrity mode with ALTER SESSION QUERY_REWRITE_INTEGRITY = STALE TOLERATED command.

QSM-01030 materialized view, string, has PL/SQL functions in ENFORCED integrity mode

Cause: A materialized view with PL/SQL functions in its definition cannot be used for query rewrite when query rewrite integrity is set to ENFORCED.

Action: Consider running the query in STALE TOLERATED mode.

QSM-01031 materialized view, string, is stale in TRUSTED integrity mode

Cause: A stale materialized view cannot be used for query rewrite when the query rewrite integrity mode is set to TRUSTED.

Action: Refresh the materialized view or alter the rewrite integrity mode with ALTER SESSION QUERY_REWRITE_INTEGRITY = STALE TOLERATED command.

QSM-01032 materialized view, string, not found

Cause: There was no associated metadata for the materialized view.

Action: Check the spelling and re-run the query.

QSM-01033 query rewritten with materialized view, string

Cause: The specified materialized view was used to rewrite the given query.

Action: No action required.

QSM-01034 materialized view, string, needs a dimension level to join table, string

Cause: One or more hierarchical relationship(s) in the table(s) could not be established.

Action: Consider adding a level in the dimension to provide the missing intra-table relationships.

QSM-01039 selection present on right hand side of an outer join

Cause: Query cannot be rewritten if any predicate contains a selection on the right hand side of an outer join.

Action: No action required.

QSM-01040 match between the materialized view (string) and query join graphs failed

Cause: Query rewrite will not take place if the joins in the query and the materialized view do not have any match.

Action: No action required.

QSM-01041 materialized view, string, does not match with a measure in the query

Cause: If a measure (such as SUM, AVERAGE) in the query cannot be matched or computed from the materialized view, it will not be used for rewrite.

Action: No action required.

QSM-01042 anchor and matching join arc check failed for string

Cause: If there is a lossy join in the materialized view that doesn't exist in the query, query rewrite will not take place.

Action: No action required.

QSM-01043 join back attempted on a table to the RHS of a semi or anti join for string

Cause: Query Rewrite will not occur if a join back is required to a table that appears to the right hand side of a semi or anti-join.

Action: No action required.

QSM-01044 join back attempted on a view for string

Cause: Query Rewrite will not occur if a join back to a table is required to find any missing columns.

Action: No action required.

QSM-01046 complex join back on correlated columns not allowed (string)

Cause: Query Rewrite will not occur if a join back is required on a column that is referenced by a sub-query.

Action: No action required.

QSM-01047 complex join back on non-MAV rewrite not allowed (string)

Cause: Query Rewrite can occur by means of a complex join back only during a MAV rewrite.

Action: No action required.

QSM-01048 join back level(s) not present (string)

Cause: Query Rewrite requires joining back to a level of a dimension to find a missing information.

Action: Consider creating a dimension.

QSM-01050 roll-up check failed for materialized view, string

Cause: A column in the query cannot be computed from the materialized view.

Action: Consider creating a dimension to supply the missing information.

QSM-01051 no support for rollup when a window function is present on the column

Cause: No query rewrite if a window function is present on a column that requires a roll-up to compute a measure.

Action: No action required.

QSM-01052 referential integrity constraint on table, string, not VALID in ENFORCED integrity mode

Cause: A join present in the materialized view requires validated primary/foreign key constraints in ENFORCED query rewrite integrity mode.

Action: Validate the constraint or change the integrity mode with ALTER SESSION SET QUERY_REWRITE_INTEGRITY = STALE_TOLERATED command.

QSM-01053 NORELY referential integrity constraint on table, string, in TRUSTED/STALE TOLERATED integrity mode

Cause: A join present in the materialized view requires RELY mode to be set on the primary/foreign key constraints.

Action: Set the RELY mode with ALTER TABLE <table> MODIFY CONSTRAINT <constraint> RELY command. Alternatively validate the constraint with ALTER TABLE <table> VALIDATE CONSTRAINT <constraint>.

QSM-01055 Query Rewrite failed to allocate the necessary materialized view join graph

Cause: Join graph allocation and initialization failed, possibly due to one or more undetermined operand(s).

Action: No action required.

QSM-01056 no query rewrite for this DDL expression

Cause: Some SELECT statements which are part of a DDL expression may be eligible for rewrite. These include CREATE AS SELECT and CREATE OUTLINE statements. The given query expression is a DDL expression, which doesn't fall in this category.

Action: No action required.

QSM-01057 no query rewrite for this DML expression

Cause: Current DML is being done using an updatable view, so it is not eligible for rewrite.

Action: No action required.

QSM-01058 materialized view, string, does not have column, string, for a joinback

Cause: A GROUP BY column in the query is not present in the GROUP BY clause of the materialized view. This usually requires a join back to a third table.

Action: No action required.

QSM-01059 HAVING clause in the query block is malformed

Cause: An illegal HAVING clause has been specified in the query.

Action: Correct the query syntax and run the query again.

QSM-01060 illegal subquery in the HAVING clause

Cause: When a HAVING clause has a subquery, then any references to the tables in the outer query should only reference the tables in the GROUP BY clause.

Action: Correct the error in the syntax and rerun the query.

QSM-01061 illegal query expression

Cause: An illegal query was specified. Specifically one of the following criteria was not satisfied: (a) All (non-constant, non-aggregate) SELECT expressions in the query should be made up of group expressions. (b) All column references in the HAVING clause should come from the GROUP BY expressions. (c) If there is an ORDER BY clause, then all column references should come from the GROUP BY or SELECT clause, depending on whether the query selects DISTINCT.

Action: Correct the error in the syntax and rerun the query.

QSM-01062 query has one or more manual partition(s)

Cause: Query rewrite is not possible if query has any manual partitions.

Action: No action required.

QSM-01063 query has a dictionary table or view

Cause: Query rewrite is not allowed if query references any dictionary tables or views.

Action: No action required.

QSM-01064 query has a fixed table or view

Cause: Query rewrite is not allowed if query references any fixed tables or views.

Action: No action required.

QSM-01065 materialized view, string, cannot compute measure, string, in the query

Cause: If the materialized view cannot compute a measure in the query using the measures in its definition, then query rewrite will not occur.

Action: No action required.

QSM-01066 materialized view, string, does not have the column, string, from query

Cause: Query rewrite will not occur, if the materialized view cannot provide all the columns that the query has.

Action: No action required.

QSM-01067 materialized view, string, cannot support the query measure, string

Cause: An attempt was made to push a grouping function through an expression specified in the query to transform a measure. Query rewrite will not occur if this measure transformation failed.

Action: No action required.

QSM-01068 no dimensions present

Cause: An attempt was made to load a dimension, but there were no dimensions present.

Action: No action required.

QSM-01069 summary join graph for, string, does not have table, string

Cause: An attempt to locate an object that is part of a join failed.

Action: No action required.

QSM-01071 a lossy join in materialized view, string, from table, string, not found in query

Cause: All lossy joins in the materialized view must be present in the query for query rewrite to occur.

Action: No action required.

QSM-01072 materialized view, string, and query have different joins between tables, string

Cause: Anchors, if any, in the MV and query match, but the joins between these anchors in the MV and query are different.

Action: No action required.

QSM-01073 materialized view, string, has a join not found in query

Cause: Query rewrite may not be possible if the materialized view has some joins that query does not have

Action: No action required.

QSM-01074 materialized view, string, and query have different no of joins between tables, string

Cause: Query rewrite may not be possible if the query has some joins that the materialized view does not have between the same pair of tables.

QSM-01075 materialized view, string, does not support aggregate function, string

Cause: The specified aggregate function is not found in the materialized view.

Action: No action required.

QSM-01077 materialized view, string, is grouping at a higher level than query

Cause: If a query column, which is not present in the materialized view, can be obtained by a rollup within the materialized view, then it should group at a higher level than the materialized view.

Action: No action required.

QSM-01079 DML operation occurred on a table referenced by MV, string

Cause: If any dependent tables of a materialized view undergoes a DML operation, query rewrite may be restricted depending on the query rewrite integrity mode for the session. In this situation, query rewrite will take place only if the rewrite integrity mode is STALE_TOLERATED.

Action: Consider refreshing the materialized view chaning the rewrite integrity mode to STALE_TOLERATED.

QSM-01080 invalid dimension, string

Cause: This dimension table has authorization or compilation problems.

Action: No action required.

QSM-01081 no primary key or row id found for table, string, in MV, string

Cause: In order to obtain a missing column, the materialized view needs to join back to the above table. But it lacks the primary key or rowid for the table.

Action: No action required.

QSM-01082 Joining materialized view, string, with table, string, not possible

Cause: A column in the query is not found in the summary. To obtain the column, a join back of materialized view to the table by means of either the primary key, foreign key or rowid of the table is required. The specified materialized view does not have the primary key, foreign key, or rowid of the table to perform the join operation.

Action: Consider building a dimension-table to provide the missing information.

QSM-01083 query text not available - possible inline view

Cause: During the query rewrite transformation, the original query was possibly transformed into an inline view.

Action: No action required.

QSM-01084 materialized view, string, has anchor, string, not found in query

Cause: A table in a materialized view is an anchor, if it is not joined to any other table, or joined to other tables but each of its joins is either lossy or lossless with the above table being child-side table. If an anchor which is present in the materialized view is not found in the query, then query rewrite will not take place.

Action: No action required.

QSM-01085 materialized view, string, has a lossy join between tables, string

Cause: There are no primary key or foreign key constraints between these tables. Query rewrite is still possible if the lossy join between the above tables also appears in the query.

Action: No action required.

QSM-01086 dimension(s) not present or not used in ENFORCED integrity mode

Cause: Query rewrite does not use dimensions in ENFORCED query rewrite integrity mode. If a suitable dimension is present, consider chaning the current integrity mode to either TRUSTED or STALE_TOLERATED by using ALTER SESSION SET QUERY_REWRITE_INTEGRITY command.

Action: No action required.

QSM-01087 query grouping on a column that cannot be derived from materialized view, string

Cause: Query is grouping on undetermined columns.

Action: No action required.

QSM-01091 cost based optimizer found query rewrite is more expensive

Cause: When cost based optimizer is ON, cost of the rewritten cursor is compared to the cursor generated without query rewrite, and the cheaper one is chosen for execution.

Action: No action required.

QSM-01092 mjv tries to rewrite a semi-join and primary key or rowid missing

Cause: Materialized join view tries to rewrite a semi-join (IN sub-query) and the primary keys or rowids of left tables of semi-joins are missing from MJV.

Action: No action required.

QSM-01093 anti-join marker not found in materialized join view

Cause: Materialized join view has outer join while the query inner join. For rewrite to succeed, MV must have an anti-join marker like the rowid or primary key of the right tables of outer join.

Action: No action required.

QSM-01094 outer-join filter not found in materialized join view

Cause: Materialized join view has outer join while the query inner join. For rewrite to succeed, MV must have an anti-join marker like the rowid or primary key of the right tables of outer join.

Action: No action required.

QSM-01095 no suitable grouping_id found in materialized view with grouping sets

Cause: If materialized aggregate view contains grouping sets, then it must also contain the grouping_id() function. This function must contain all columns in the MV GROUP BY.

Action: No action required.

QSM-01096 Materialized view with grouping sets contains duplicates

Cause: Materialized view with grouping sets contains duplicates and no rewrite is supported for it. For example, GROUP BY GROUPING SET ((a), (a)) is not supported for rewrite.

Action: No action required.

QSM-01097 Materialized view with grouping sets has too long key

Cause: Materialized view with grouping sets has more that 64 different keys in its GROUP BY. No rewrite is supported.

Action: No action required.

QSM-01098 materialized view string clause more restrictive than query string clause

Cause: The materialized view contains a selection condition in the WHERE or HAVING clause that is more restrictive than the corresponding selection condition in the request query.

Action: Change the selection criteria in the request query to be at least as restrictive as the selection criteria in the materialized view, or drop and recreate the materialized view using less restrictive selection criteria.

QSM-01099 non-tolerated reference to stale portion of materialized view for table string

Cause: The materialized view is partially stale. It is stale with respect to one or more partitions in one or more of its detail tables. The request query references one or more such detail partitions.

Action: Change the selection criteria of the request to restrict the query to only the fresh portion of the materialized view, ALTER {SYSTEM|SESSION} QUERY_REWRITE_INTEGRITY = STALE_TOLERATED, or refresh the materialized view.

QSM-01100 containment check failed for mv, string

Cause: The materialized view contains a selection condition in the WHERE or HAVING clause that is more restrictive than the corresponding selection condition in the request query.

Action: Change the selection criteria in the request query to be at least as restrictive as the selection criteria in the materialized view, or drop and recreate the materialized view using less restrictive selection criteria.

QSM-01101 rollups took place on mv, string

Cause: If query's GROUP BY has one of the higher levels of columns found in the materialized view, then the lower level columns in the materialized view will be rolled up to compute the desired results.

Action: No action required.

QSM-01102 materialized view, string, requires join back to table, string, on column, string

Cause: A column in the query does not appear in the materialized view. Query rewrite will try to obtain this column from the base table, by doing a join back to that column with the materialized view.

Action: No action required.

QSM-01103 there is a remote table, string, referenced in the query

Cause: Query rewrite does not support query with remote tables.

Action: No action required.

QSM-01104 query is using flashback

Cause: Query rewrite does not support flashback.

Action: No action required.

QSM-02001 clustered materialized view container table

Cause: The capability in question is not supported on a materialized view that has a clustered container table.

Action: Recreate the materialized view using a conventional container table.

QSM-02002 DISTINCT aggregate measure in SELECT list

Cause: The capability in question is not supported when the materialized view uses the DISTINCT qualifier on an aggregate function.

Action: Remove the DISTINCT qualifier.

QSM-02003 aggregate function nested within an expression

Cause: The capability in question is not supported when the materialized view contains an aggregate function invocation nested within an outer expression.

Action: Re-phrase the expression such that the aggregate function invocation is not nested.

QSM-02004 grouping column omitted from SELECT list

Cause: The capability in question is not supported when the materialized view contains a column or expression in the GROUP BY clause that is not also present in the list of output select expressions.

Action: Include all GROUP BY expressions in the output select list.

QSM-02005 named view in FROM list

Cause: The capability in question is not supported when a named view appears in the FROM list.

Action: Remove the named view from the FROM list.

QSM-02006 subquery in FROM list

Cause: The capability in question is not supported when a subquery appears in the FROM list.

Action: Remove the subquery from the FROM list.

QSM-02007 multiple instances of the same table or view

Cause: The capability in question is not supported when the same table or view occurs more than once in the FROM list.

Action: Re-phrase the query to avoid multiple instances of the same table.

QSM-02008 non-join filter condition in WHERE or HAVING clause

Cause: The capability in question is not supported when the materialized view has a selection condition (an expression not representing a join) in the WHERE or HAVING clause.

Action: Remove the selection filter expression.

QSM-02009 non-inner join

Cause: The capability in question is only supported with inner joins.

Action: Re-phrase the query using an inner join. Remove any outer joins.

QSM-02010 join predicate with operator other than equals (=)

Cause: The capability in question is not supported when the materialized view uses a relationship operator other than equals ("=") in a join in the WHERE clause. This is known as a non-equijoin.

Action: Re-phrase the query to avoid the non-equijoin.

QSM-02011 a HAVING clause is present

Cause: The capability in question is not supported when the materialized view uses a HAVING clause.

Action: Remove the HAVING clause.

QSM-02012 a CONNECT BY clause is present

Cause: The capability in question is not supported when the materialized view uses a CONNECT BY clause.

Action: Re-phrase the query to avoid use of the CONNECT BY clause.

QSM-02013 SELECT list includes a RAW data type expression

Cause: The capability in question is not supported when the materialized view uses RAW data type in an expression.

Action: Remove the reference to the RAW expression.

QSM-02014 GROUP BY expression other than a column

Cause: The capability in question is not supported when the materialized view uses an expression other than a simple column reference in the GROUP BY clause.

Action: Re-phrase the query to use only simple column expressions in the GROUP BY clause.

QSM-02015 Index-Organized Table (IOT) present in FROM list

Cause: The capability in question is not supported when the materialized// view references an Index-Organized Table in the FROM list.

Action: Remove the reference to the Index-Organized Table.

QSM-02016 clustered table in FROM list

Cause: The capability in question is not supported when the materialized view references a clustered table in the FROM list.

Action: Remove the reference to the clustered table in the FROM list.

QSM-02017 subquery present in the HAVING clause

Cause: The capability in question is not supported when the materialized view uses a subquery in the HAVING clause.

Action: Re-phrase the query to avoid the subquery in the HAVING clause.

QSM-02018 subquery present in the WHERE clause

Cause: The capability in question is not supported when the materialized view uses a subquery in the WHERE clause.

Action: Re-phrase the query to avoid the subquery in the WHERE clause.

QSM-02019 materialized view references another materialized view in FROM clause

Cause: The capability in question is not supported when the materialized view is nested (that is, when it references another materialized view in its FROM list).

Action: Re-phrase the query to avoid reference to the other materialized view.

QSM-02020 container column not in SELECT list with NOT NULL constraint

Cause: The capability in question is not supported when the materialized view's container table has a column that does not correspond to an output expression in the select list, and that column has a NOT NULL constraint. This situation can result in problems during refresh since any new rows inserted into the materialized view will set that column to NULL.

Action: Disable or remove the NOT NULL constraint.

QSM-02021 set operator encountered in materialized view

Cause: The capability in question is not supported when the materialized view uses set operators such as UNION, UNION ALL, MINUS, and so on.

Action: Re-phrase the query to avoid the use of set operators.

QSM-02022 aggregate selections

Cause: The capability in question is not supported when the materialized view uses an aggregate expression in the HAVING clause.

Action: Re-phrase the query to avoid the use of an aggregate in the HAVING clause.

QSM-02023 nested cursor

Cause: The capability in question is not supported when the materialized view uses a nested cursor expression.

Action: Re-phrase the query to avoid use of a nested cursor expression.

QSM-02024 no GROUP BY clause

Cause: The capability in question is not supported when the materialized view does not use a GROUP BY clause.

Action: Re-phrase the query to use a GROUP BY clause.

QSM-02025 no aggregate functions

Cause: The capability in question is not supported when the materialized view uses no aggregate functions.

Action: Re-phrase the query to use aggregate functions.

QSM-02026 non-AND conjunction in WHERE clause

Cause: The capability in question is not supported when the materialized view uses a conjunction other than AND (such as OR) in the WHERE clause.

Action: Re-phrase the query to avoid use of the non-AND conjunction.

QSM-02027 group by ROLLUP

Cause: The capability in question is not supported when the materialized view uses the ROLLUP operator in the GROUP BY clause.

Action: Re-phrase the query to avoid use of the ROLLUP operator.

QSM-02028 group by CUBE

Cause: The capability in question is not supported when the materialized view uses the CUBE operator in the GROUP BY clause.

Action: Re-phrase the query to avoid use of the CUBE operator.

QSM-02029 PL/SQL function invocation

Cause: The capability in question is not supported when the materialized view invokes a PL/SQL function.

Action: Re-phrase the query to avoid use of PL/SQL functions.

QSM-02030 reduced precision specified for prebuilt materialized view

Cause: The capability in question is not supported when the materialized view is created with the WITH REDUCED PRECISION clause.

Action: DROP the materialized view and re-create it without using the WITH REDUCED PRECISION clause.

QSM-02031 materialized view cannot support any type of query rewrite

Cause: The materialized view cannot be used with query rewrite.

Action: Examine the other messages and documentation to determine the cause of the problem.

QSM-02032 no joins are present in the WHERE clause

Cause: The capability in question is not supported when the materialized view includes no join conditions in the WHERE clause.

Action: Re-phrase the query to include a join.

QSM-02033 no filter conditions are present in the WHERE clause

Cause: The capability in question is not supported when the materialized view includes no filter selection conditions in the WHERE clause.

Action: Add a filter condition.

QSM-02034 no joins are present in the HAVING clause

Cause: The capability in question is not supported when the materialized view includes no joins in the HAVING clause.

Action: Re-phrase the query to include a join.

QSM-02035 no filter conditions are present in the HAVING clause

Cause: The capability in question is not supported when the materialized view includes no filter condition in the HAVING clause.

Action: Re-phrase the query to include a join.

QSM-02036 in-list present in materialized view

Cause: The capability in question is not supported when the materialized view uses an IN list.

Action: Re-phrase the query to avoid the use of IN lists.

QSM-02037 cannot evaluate constant expression at compile time

Cause: The capability in question is not supported when the materialized view uses a compile-time non-constant expression in a filter condition in the WHERE or HAVING clauses. For example, WHERE X=1 uses a compile-time constant expression in a filter condition. WHERE X=MY_PLSQL_FUNCTION() uses a compile-time non-constant expression in a filter condition.

Action: Re-phrase the query to avoid the use of compile-time non-constant expressions in filter conditions.

QSM-02038 Partition Change Tracking (PCT) is enabled

Cause: The Partition Change Tracking (PCT) capability is supported for this materialized view.

Action: No action required.

QSM-02039 top level materialized view query uses grouping sets

Cause: The capability in question is not supported when the materialized view uses grouping sets.

Action: Re-phrase the query to avoid the use of grouping sets.

QSM-02040 top level query contains GSets and the key is too long for rewrite

Cause: The capability in question is not supported when the materialized view uses a grouping set with too many keys.

Action: Reduce the number of grouping set keys.

QSM-02041 nested aggregate function

Cause: The capability in question is not supported when the materialized view nests an aggregate function invocation as an argument to another aggregate function.

Action: Re-phrase the query to avoid the nested aggregate function invocation.

QSM-02042 view or subquery in from list

Cause: The capability in question is not supported when the materialized view references a view or subquery in the FROM list.

Action: Re-phrase the query to avoid the use of views or subqueries in the FROM list.

QSM-02044 ORDER BY clause in materialized view

Cause: The capability in question is not supported when the materialized view includes an ORDER BY clause.

Action: Remove the ORDER BY clause.

QSM-02045 START WITH clause in materialized view

Cause: The capability in question is not supported when the materialized view includes a START WITH clause.

Action: Re-phrase the query to avoid the use of the START WITH clause.

QSM-02047 window function in materialized view

Cause: The capability in question is not supported when the materialized view uses a window function.

Action: Re-phrase the query to avoid the use of window functions.

QSM-02048 outer join in materialized view

Cause: The capability in question is not supported when the materialized view uses an outer join.

Action: Re-phrase the query to avoid the use of outer joins.

QSM-02049 subquery using the ANY clause in materialized view

Cause: The capability in question is not supported when the materialized view uses the ANY clause with a subquery.

Action: Re-phrase the query to avoid the use of the ANY clause.

QSM-02050 subquery using the ALL clause in materialized view

Cause: The capability in question is not supported when the materialized view uses the ALL clause with a subquery.

Action: Re-phrase the query to avoid the use of the ALL clause.

QSM-02051 subquery using the NOT EXISTS clause in materialized view

Cause: The capability in question is not supported when the materialized view uses the NOT EXISTS clause with a subquery.

Action: Re-phrase the query to avoid the use of the NOT EXISTS clause.

QSM-02052 subquery using a select list in materialized view

Cause: The capability in question is not supported when the materialized view uses a select list.

Action: Re-phrase the query to avoid the use of a select list.

QSM-02053 collection subquery in materialized view

Cause: The capability in question is not supported when the materialized view uses a collection subquery.

Action: Re-phrase the query to avoid the use of collection subqueries.

QSM-02054 DISTINCT clause in select list in materialized view

Cause: The capability in question is not supported when the materialized view uses the DISTINCT clause in the select list.

Action: Re-phrase the query to avoid the use of the DISTINCT clause.

QSM-02055 materialized view references a packed object table or view

Cause: The capability in question is not supported when the materialized view references a packed object table or view.

Action: Re-phrase the query to avoid the use of packed object tables or views.

QSM-02056 correlated variable and outer join in materialized view

Cause: The capability in question is not supported when the materialized view uses a correlated variable and an outer join.

Action: Re-phrase the query to avoid the use of correlated variables or outer joins.

QSM-02057 ROWNUM referenced in materialized view

Cause: The capability in question is not supported when the materialized view references the ROWNUM function.

Action: Re-phrase the query to avoid the use of the ROWNUM function.

QSM-02058 set operator in materialized view and compatibility mode is less than 9.0

Cause: The capability in question is not supported when the materialized view uses a set operator and the compatibility mode is less than 9.0.

Action: Re-phrase the query to avoid the use of set operators or set the compatibility mode to 9.0 or higher.

QSM-02059 join may produce duplicate rows in materialized view

Cause: The capability in question is not supported when the materialized view contains a join condition that can result in duplicate rows in the materialized view.

Action: Re-phrase the query to avoid the occurrence of duplicate rows in the materialized view.

QSM-02061 one or more joins present in materialized view

Cause: The capability in question is not supported when the materialized view contains joins.

Action: Re-phrase the query to avoid the use of the joins.

QSM-02062 GROUP BY clause in materialized view

Cause: The capability in question is not supported when the materialized view uses the GROUP BY clause.

Action: Re-phrase the query to avoid the use of the GROUP BY clause.

QSM-02063 aggregate function in materialized view

Cause: The capability in question is not supported when the materialized view uses an aggregate function.

Action: Re-phrase the query to avoid the use of aggregate functions.

QSM-02064 subquery in materialized view

Cause: The capability in question is not supported when the materialized view uses a subquery.

Action: Re-phrase the query to avoid the use of subqueries.

QSM-02066 Oracle error: see RELATED_NUM and RELATED_TEXT for details

Cause: The capability in question is not supported because an attempt to create the materialized view would result in an error.

Action: Examine the associated Oracle error code in the RELATED_NUM column and the Oracle error text in the RELATED_TEXT column and address the problem.

QSM-02067 no partition key or PMARKER in select list

Cause: The capability in question is not supported when the materialized view unless the select list (and group by list if a GROUP BY clause is present) includes either the partition key of or a PMARKER function reference to the table in question.

Action: Add the partition key or a PMARKER function reference to the select list (and the GROUP BY clause, if present).

QSM-02068 relation is not a partitioned table

Cause: The capability in question is not supported when the relation in question is not a partitioned table.

Action: Change the query to reference a partitioned table.

QSM-02069 PCT not supported with multi-column partition key

Cause: The capability in question is not supported when the table in question is partitioned on a multi-column key.

Action: Re-phrase the query to reference a table partitioned on a single column key.

QSM-02070 PCT not supported with this type of partitioning

Cause: The capability in question is not supported when the table in question uses certain types of partitioning.

Action: Re-phrase the query to reference a table that uses a type of partitioning that is supported for this capability.

QSM-02071 internal error: undefined PCT failure code

Cause: An internal Oracle error has occurred.

Action: Contact Oracle Support Services.

QSM-02072 requirements not satisfied for fast refresh of nested materialized view

Cause: The capability in question is not supported because one or more of the requirements for this capability have not been satisfied.

Action: Examine the relevant nested materialized view documentation in the Oracle9i Data Warehousing Guide and address the problem.

QSM-02073 non-primary key RepAPI materialized view is not fast refreshable

Cause: Fast refresh is supported for RepAPI materialized views only if it is also a primary key materialized view.

Action: Re-design the materialized view to be a primary key materialized view.

QSM-02074 materialized view over Heterogeneous Services link

Cause: The capability in question is not supported when the materialized view uses a heterogeneous link.

Action: Re-design the materialized view to avoid the use of the heterogeneous links.

QSM-02075 materialized view on synonym

Cause: The capability in question is not supported when the materialized view references a synonym.

Action: Re-phrase the query to avoid the use of synonyms.

QSM-02077 materialized view log is newer than last full refresh

Cause: The capability in question is not supported when the relevant materialized view log was created after the creation or most recent complete refresh of the materialized view.

Action: Perform a complete refresh of the materialized view.

QSM-02078 materialized view log must have new values

Cause: The capability in question is not supported when the relevant materialized view log omits new values.

Action: Re-create the materialized view log using the NEW VALUES clause.

QSM-02079 materialized view log must have ROWID

Cause: The capability in question is not supported when the relevant materialized view log omits ROWIDs.

Action: Re-create the materialized view log using the ROWID clause.

QSM-02080 materialized view log must have primary key

Cause: The capability in question is not supported when the relevant materialized view log omits primary keys.

Action: Re-create the materialized view log using the PRIMARY KEY clause.

QSM-02081 materialized view log does not have all necessary columns

Cause: The capability in question is not supported when the relevant materialized view log omits columns referenced in the select list of the materialized view.

Action: Re-create the materialized view log and include all columns referenced in the select list.

QSM-02082 problem with materialized view log

Cause: The capability in question is not supported because of a problem with the materialized view log.

Action: Examine the relevant materialized view log and fast refresh documentation in the Oracle9i Data Warehousing Guide and address the problem.

QSM-02083 materialized view references PL/SQL function that maintains state

Cause: The capability in question is not supported when the materialized view references a PL/SQL function that maintains state and which may not return the same value every time it is invoked against the same set of rows.

Action: Either re-phrase the query to avoid such a PL/SQL function or modify the PL/SQL function to avoid state maintenance and change its declaration accordingly.

QSM-02084 DISTINCT clause on a duplicate sensitive aggregate function

Cause: The capability in question is not supported when the materialized view uses the DISTINCT clause in this context.

Action: Re-phrase the query to avoid the use of the DISTINCT clause.

QSM-02086 materialized view uses the MIN or MAX aggregate functions

Cause: The capability in question is not supported when the materialized view uses the MIN or MAX function.

Action: Re-phrase the query to avoid the use of the MIN or MAX functions.

QSM-02088 materialized view omits at least one grouping key from the select list

Cause: The capability in question is not supported when the materialized view omits any grouping expressions from the select list.

Action: Include all GROUP BY expressions in the select list.

QSM-02090 SELECT includes an expression that is not just a column

Cause: The capability in question is not supported when the materialized view uses an expression in the select list that is not a simple column reference.

Action: Re-phrase the query to avoid the use of the expressions that are not simple column references.

QSM-02091 materialized view references a non-repeatable or session-sensitive expression

Cause: The capability in question is not supported when the materialized view uses an expression that may not return the same value each time it is invoked against the same set of rows or that may return different values depending on session parameters.

Action: Re-phrase the query to avoid the use of such expressions.

QSM-02092 materialized view references a sequence number

Cause: The capability in question is not supported when the materialized view references a sequence number.

Action: Re-phrase the query to avoid the reference to sequence numbers.

QSM-02093 materialized view uses an object REF clause

Cause: The capability in question is not supported when the materialized view uses an object REF clause.

Action: Re-phrase the query to avoid the use of an object REF clause.

QSM-02096 materialized view references a named view

Cause: The capability in question is not supported when the materialized view references a view.

Action: Re-phrase the query to avoid references to views.

QSM-02099 materialized view references a remote table or view in the FROM list

Cause: The capability in question is not supported when the materialized view references a remote table or view in the FROM list.

Action: Re-phrase the query to avoid references to remote tables or views.

QSM-02101 materialized view references a synonym in the FROM list

Cause: The capability in question is not supported when the materialized view references a synonym in the FROM list.

Action: Re-phrase the query to avoid the reference to the synonym.

QSM-02102 materialized view FROM list references an object in the SYS schema

Cause: The capability in question is not supported when the materialized view references an object in the SYS schema.

Action: Re-phrase the query to avoid the reference to the SYS schema.

QSM-02104 aggregate function in a filter condition in the HAVING clause

Cause: The capability in question is not supported when the materialized view references an aggregate function in a filter condition in the HAVING clause.

Action: Re-phrase the query to avoid the use of aggregates in filter conditions in the HAVING clause.

QSM-02106 materialized view uses a filter condition in the WHERE or HAVING clause

Cause: The capability in question is not supported when the materialized view includes a filter condition in the WHERE or HAVING clause.

Action: Re-phrase the query to avoid the use of filter conditions in the WHERE or HAVING clauses.

QSM-02112 top level query has LEFT OUTER, RIGHT OUTER, or FULL OUTER join

Cause: The capability in question is not supported when the materialized view uses these types of joins.

Action: Re-phrase the query to avoid the use of these types of joins.

QSM-02113 expression in select list references multiple tables or views

Cause: The capability in question is not supported when the materialized view includes an expression in the select list that references multiple tables or views.

Action: Re-phrase the query to avoid the use of such expressions.

QSM-02114 no GROUP BY clause, no aggregates, and not >= 9.0 compatibility

Cause: The capability in question is not supported when the materialized view has no GROUP BY clause, no aggregates, and compatibility mode is less than 9.0.

Action: Either re-phrase the query to avoid the include a GROUP BY clause or an aggregate function, or set compatibility mode to 9.0 or higher.

QSM-02115 materialized view references a remote object and is refreshed ON COMMIT

Cause: The capability in question is not supported when the materialized view references a remote object and is refreshed ON COMMIT.

Action: Re-phrase the query to avoid the reference to the remote object or alter the materialized view to be refreshed ON DEMAND.

QSM-02116 multiple master sites

Cause: The capability in question is not supported when the materialized view references multiple remote objects that reside at different remote instances.

Action: Re-phrase the query to avoid the use of multiple master sites.

QSM-02117 missing GROUPING_ID or GROUPING functions on GROUP BY columns

Cause: The capability in question is not supported when the materialized view uses grouping sets but omits the relevant GROUPING_ID or GROUPING functions.

Action: Re-phrase the query to include the relevant GROUPING_ID or GROUPING functions.

QSM-02118 duplicate grouping sets

Cause: The capability in question is not supported when the materialized view redundantly references grouping sets.

Action: Re-phrase the query to avoid the use of the redundant grouping sets.

QSM-02119 internal error while analyzing required supporting aggregates

Cause: An internal Oracle error has occurred.

Action: Contact Oracle Support Services.

QSM-02120 compatibility mode must be 9.0 or higher

Cause: The capability in question is not supported when the compatibility mode is less than 9.0.

Action: Set the compatibility mode to 9.0 or higher.

QSM-02121 set operator in a context not supported for fast refresh

Cause: The capability in question is not supported when the materialized view uses a set operator in this context.

Action: Re-phrase the query to avoid the use of the set operator.

QSM-02122 compatibility mode must be 8.1 or higher

Cause: The capability in question is not supported when the compatibility mode is less than 8.1.

Action: Set the compatibility mode to 8.1 or higher.

QSM-02123 subquery and UNION materialized views must be primary key materialized views

Cause: The capability in question is not supported when the materialized view is not a primary key materialized view and uses subqueries or the union operator in this context.

Action: Re-create the materialized view as a primary key materialized view.

QSM-02124 object type in WHERE clause

Cause: The capability in question is not supported when the materialized view references an object type in the WHERE clause.

Action: Re-phrase the query to avoid the reference to the object type.

QSM-02125 subquery join conditions don't meet requirements for capability

Cause: The capability in question is not supported when the materialized view uses a subquery in a join in this way.

Action: Examine the relevant replication documentation concerning subquery materialized views and address the problem.

QSM-02126 no rowid at master site

Cause: The capability in question is not supported when the materialized view references a remote site that does not support rowids.

Action: Re-phrase the query to avoid the reference to the remote site.

QSM-02127 not supported for this type materialized view by Oracle version at master site

Cause: The capability in question is not supported when the materialized view uses certain constructs and references an older version, remote Oracle instance.

Action: Re-phrase the query to avoid the use of the construct or upgrade the remote Oracle instance.

QSM-02128 does not meet the requirements of a primary key materialized view

Cause: The capability in question is not supported when the materialized view fails to meet the requirements of a primary key materialized view.

Action: Examine the relevant primary key materialized view replication documentation and address the problem.

QSM-02129 join or filter conditions are complex

Cause: The capability in question is not supported when the materialized view uses a complex join or filter condition.

Action: Re-phrase the query to simplify the join or filter condition.

QSM-02130 expression not supported for fast refresh

Cause: The capability in question is not supported when the materialized view references certain, complex expressions.

Action: Re-phrase the query to simplify the expression.

QSM-02131 agg(expr) requires corresponding SUM(expr) function

Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the SUM function on the same argument.

Action: Add the SUM function to the select list.

QSM-02132 agg(expr) requires corresponding COUNT(expr) function

Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the COUNT function on the same argument.

Action: Add the COUNT function to the select list.

QSM-02133 agg(expr) requires corresponding MIN(expr) function

Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the MIN function on the same argument.

Action: Add the MIN function to the select list.

QSM-02134 agg(expr) requires corresponding MAX(expr) function

Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the MAX function on the same argument.

Action: Add the MAX function to the select list.

QSM-02135 agg(expr) requires corresponding AVG(expr) function

Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the AVG function on the same argument.

Action: Add the AVG function to the select list.

QSM-02136 agg(expr) requires corresponding VARIANCE(expr) function

Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the VARIANCE function on the same argument.

Action: Add the VARIANCE function to the select list.

QSM-02137 agg(expr) requires corresponding STDDEV(expr) function

Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the STDDEV function on the same argument.

Action: Add the STDDEV function to the select list.

QSM-02138 agg(expr) requires corresponding agg(expr*expr) function

Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of that same aggregate function on the square of the same argument.

Action: Add an invocation of the same aggregate function on the square of the same argument (that is, the argument multiplied by itself).

QSM-02139 agg(expr) requires corresponding agg(expr+expr) function

Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of that same aggregate function on the same argument added to the same argument.

Action: Add the indicated aggregate function to the select list.

QSM-02140 agg(expr) requires corresponding SUM(expr*expr) function

Cause: The capability in question is not supported when the materialized view uses certain aggregate functions but omits an invocation of the SUM function on the square of the same argument (the argument multiplied by itself).

Action: Add the SUM function on the square of the argument.

QSM-02141 the reason why the capability is disabled has escaped analysis

Cause: The EXPLAIN_MV analysis engine has failed to capture the reason why the given capability is not possible.

Action: Contact Oracle Support Services.

QSM-02142 COUNT(*) is not present in the select list

Cause: The materialized view query omits COUNT(*) from the select list.

Action: Add COUNT(*) to the select list.

QSM-02143 SUM(expr) without COUNT(expr)

Cause: SUM(expr) occurs in the select list without a corresponding COUNT(expr).

Action: Add COUNT(expr) to the select list.

QSM-02144 aggregate functions are present without a GROUP BY clause

Cause: One or more aggregate functions are present in the select list but a GROUP BY clause is not used.

Action: Add a GROUP BY clause.

QSM-02145 GROUP BY clause is present but no aggregate functions are used

Cause: A GROUP BY clause is used but no aggregate functions are present in the select list.

Action: Add an aggregate function to the select list.

QSM-02146 see the reason why REFRESH_FAST_AFTER_INSERT is disabled

Cause: REFRESH_FAST_AFTER_ONETAB_DML is disabled for the same reason that REFRESH_FAST_AFTER_INSERT is disabled.

Action: Correct the problem with REFRESH_FAST_AFTER_INSERT.

QSM-02147 default date format is sensitive to session settings

Cause: You have specified a date conversion operation using either the default format or an incomplete format. The default date format or an incomplete format is sensitive to session settings, and therefore may not be reproducible across different environments.

Action: Specify a complete date format string.

QSM-02148 many to many subquery joins require 9.0 compatibility or higher

Cause: You have specified a many to many join in your materialized view while running in less than 9.0 compatibility mode.

Action: Set your compatibility mode to 9.0 or higher or restructure the materialized view query.

QSM-02149 ON COMMIT with this materialized view requires 9.0 compatibility or higher

Cause: You have specified a materialized view that uses some combination of the following in combination with the REFRESH ON COMMIT option while running in less than 9.0 compatibility mode:

  • Joins
  • Aggregation
  • Filter conditions in the WHERE clause
  • A remote relation in the FROM list
  • A SUM(x) function without a corresponding COUNT(x) function
  • An omitted COUNT(*) aggregate function
  • A MIN() or MAX() aggregate function

Action: Set your compatibility mode to 9.0 or higher or restructure the materialized view query.

QSM-02150 select lists must be identical across the UNION operator

Cause: You have specified a materialized view using the UNION operator and the respective queries on each side of the UNION operator do not have the same select list. The RELATED_NAME column shows the alias of the first different select list item. The RELATED_NUM column shows the offset from the SELECT keyword to the start of this select list item.

Action: Restructure the materialized view query such that the respective sides of the UNION operator have identical select lists.

QSM-02151 subquery or named view in FROM list and < 9.0 compatibility

Cause: You have specified a materialized view that references a subquery or named view in its top level FROM list while running in less than 9.0 compatibility mode.

Action: Set compatibility mode to 9.0 or higher or restructure the materialized view query.

QSM-02152 subquery or named view in FROM list even after view merging

Cause: You have specified a materialized view that references a subquery ore named view in its top level FROM list that could not be merged during the view merging process.

Action: Restructure the materialized view query.

QSM-02153 view or subquery in FROM list not supported for this type materialized view

Cause: You have specified a materialized view that references a view or a subquery in the top level FROM list but does not include aggregation. The indicated capability is not supported for this type of materialized view.

Action: Restructure the materialized view query.

QSM-02154 MV is not fast refreshable even with view merging

Cause: You have a materialized view with view in the FROM clause, however it does not meet the criteria for fast refresh after view merging.

Action: Restructure the materialized view query to remove the offending view or the complex construct in the view.

QSM-02161 see the reason why REFRESH_FAST_AFTER_ONETAB_DML is disabled

Cause: REFRESH_FAST_AFTER_ANY_DML is disabled for the same reason that REFRESH_FAST_AFTER_ONETAB_DML is disabled.

Action: Correct the problem with REFRESH_FAST_AFTER_ONETAB_DML.

QSM-02162 the detail table does not have a materialized view log

Cause: The fast refresh cannot be performed because the master table does not contain a materialized view log.

Action: Use the CREATE MATERIALIZED VIEW LOG statement to create a materialized view log on the master table.

QSM-02163 cannot use object id columns from materialized view log

Cause: The materialized view log either does not have object id columns logged, or the timestamp associated with the object id columns is more recent than the last refresh time.

Action: A complete refresh is required before the next fast refresh. Add object id columns to the materialized view log, if required.

QSM-02170 tables must be identical across the UNION operator

Cause: A materialized view using the UNION operator was specified and the tables on each side of the UNION operator do not match. Fast refresh is not supported in this context.

Action: Restructure the materialized view query such that the respective sides of the UNION operator have the same table.

QSM-02171 the materialized view has a join operation in the outer UNION block

Cause: Fast refresh is not supported if a materialized view having the UNION operator contains a join operation.

Action: Rewrite the materialized view query without the join.

QSM-02172 the SELECT list does not have the rowids of all the detail tables

QSM-02173 the unique constraints does not exist on the join columns of the inner table

Cause: If there are outer joins, unique constraints must exist on the join columns of the inner table. Otherwise, the materialized view can not be fast refreshable.

QSM-02174 the materialized view does not have a UNION ALL marker column

Cause: For a materialized view with UNION ALL to be fast refreshable, it must have a UNION ALL marker column. This is a constant column, at the same ordinal position in each query block and must have distinct values in each query block.

Action: Add a UNION ALL marker column to each query block in the UNION ALL query defining the materialized view.

QSM-02175 some query block in UNION ALL MV is not fast refreshable

Cause: For a materialized view with UNION ALL to be fast refreshable, each query block must conform to a fast refreshable materialized join view or materialized aggregate view.

Action: Check each query block in the UNION ALL to ensure it is either a materialized view with joins or aggregates.

QSM-02176 MV with UNION ALL in a view is too complex

Cause: If a materialized view has a view whose definition involves a UNION ALL query, then the materialized view's defining query cannot have any clauses other than SELECT or FROM. Other clauses such as WHERE, HAVING, CONNECT BY, or GROUP BY are not allowed. Further more, the FROM clause should have only one item.

Action: Remove any clauses besides SELECT and FROM from the materialized view's defining query.

QSM-02177 MV with UNION ALL in a view must match the view's SELECT list

Cause: If a materialized view has a view whose definition involves a UNION ALL query, then the materialized view's select list must match the underlying view's select list exactly. It must not have any expressions and must not have add/drop/reorder columns from the underlying view.

Action: Use SELECT * when defining a materialized view with a UNION ALL in a view.

QSM-02178 MV has a view with UNION ALL that is not fast refreshable

Cause: The materialized view has a view whose definition involves a UNION ALL query that does not satisfy the requirements for fast refresh.

Action: Check that the defining query of the view being referenced in the materialized view satisfies conditions for fast refresh of a UNION ALL materialized view.

QSM-02179 MV with UNION ALL requires compatibility >= 9.2.0

Cause: The setting of the COMPATIBLE initialization parameter is less than 9.2.0.

Action: Set COMPATIBLE to 9.2.0 or higher.

QSM-02180 no primary key constraint in the master table

Cause: The explain_mview assumes that the materialized view is going to be created as the Primary Key materialized view. A Primary Key materialized view can not be created if the base table does not have a primary key constraint.

Action: Add a primary key constraint to the base table, or create the materialized view as Rowid MV by specifying the WITH ROWID option. If the materialized view is a Rowid MV, then it should be able to do complete refresh and even fast refresh, given that the materialized view log on the master table has a rowid.


Recovery Manager Messages (RMAN)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

25
Recovery Manager Messages (RMAN)

For more information about the Recovery Manager, refer to the Oracle9i Recovery Manager User's Guide and the Oracle9i User-Managed Backup and Recovery Guide.

RMAN-00550 parser package failed to load

Cause: LPMLOADPKG() return an error indication.

Action: This message should be accompanied by one or more other error messages indicating the cause of the error.

RMAN-00551 initialization of parser package failed

Cause: The parser package initialization routine returned an error.

Action: This message should be accompanied by one or more other error messages indicating the cause of the error.

RMAN-00552 syntax error in command line arguments

Cause: The arguments supplied to RMAN could not be parsed, or no arguments were supplied at all.

Action: This message should be accompanied by one or more other error messages indicating the cause of the error.

RMAN-00553 internal recovery manager package failed to load

Cause: LPMLOADPKG() return an error indication.

Action: This message should be accompanied by one or more other error messages indicating the cause of the error.

RMAN-00554 initialization of internal recovery manager package failed

Cause: The internal package initialization routine returned an error.

Action: This message should be accompanied by one or more other error messages indicating the cause of the error.

RMAN-00555 target database connect string must be specified

Cause: The TARGET parameter was not specified.

Action: Supply the necessary parameter.

RMAN-00556 could not open CMDFILE "string"

Cause: An error occurred when trying to open the file.

Action: Check that the file name was specified correctly and that the file exists and that the user running RMAN has read permission for the file.

RMAN-00557 could not open MSGLOG "string"

Cause: An error occurred when trying to open the file.

Action: Check that the file name was specified correctly and that the file exists and that the user running RMAN has write permission for the file.

RMAN-00558 error encountered while parsing input commands

Cause: The parser detected a syntax error.

Action: This message should be accompanied by one or more other error messages indicating the cause of the error.

RMAN-00562 username too long

Cause: The specified username exceeds the maximum allowable username length.

Action: Correct the username.

RMAN-00563 password too long

Cause: The specified password exceeds the maximum allowable password length.

Action: Correct the password.

RMAN-00564 host data too long

Cause: The SQL*Net host connect string exceeds the maximum allowable length.

Action: Correct the host string.

RMAN-00565 unable to read input file

Cause: An error occurred while trying to read from STDIN or from the CMDFILE.

Action: Ensure that the CMDFILE is readable. The CMDFILE must be a text file with one line per record.

RMAN-00566 could not open TRACE "string"

Cause: An error occurred when trying to open the file.

Action: Check that the file name was specified correctly and that the user running RMAN has write permission for the file.

RMAN-00567 Recovery Manager could not print some error messages

Cause: An error occurred while trying to print the error message stack.

Action: If the associated error message indicates a condition that can be corrected, do so, otherwise contact Oracle Support Services.

RMAN-00568 user interrupt received

Cause: The user typed ^C or ATTN.

Action: No action required.

RMAN-00569 =============== ERROR MESSAGE STACK FOLLOWS ===============

Cause: This message precedes an error message stack.

Action: The errors are printed in last-in first-out order. So to interpret them correctly, read from the bottom to the top.

RMAN-00570 **end-of-file**

Cause: The end of an inline CMDFILE was reached. This is just an informational message.

Action: No action required.

RMAN-00571 ===========================================================

Action: The errors are printed in last-in first-out order. So to interpret them correctly, read from the bottom to the top.

RMAN-00572 waiting for dbms_pipe input

Cause: This message is used only when the PIPE option was specified.

Action: Enqueue some RMAN input into the pipe.

RMAN-00573 dbms_pipe.next_item_time returned unknown type code: number

Cause: This is an internal error

Action: Contact Oracle Support Services.

RMAN-00574 rman aborting due to errors read/writing dbms_pipe

Cause: RMAN was run with input/output being sent to DBMS_PIPE. An error was encountered while reading from or writing to the pipe. This error should be preceded by information describing the error.

Action: RMAN terminates. Refer to the cause/action for the preceding errors.

RMAN-00575 timeout while trying to write to dbms_pipe

Cause: RMAN was running in DBMS_PIPE mode. A timeout occurred while calling DBMS_PIPE.SEND_MESSAGE. This occurs when the pipe is full and no process has dequeued any of the messages. This is usually caused by death of the process that was talking to RMAN.

Action: RMAN will abort.

RMAN-00576 PIPE cannot be used with CMDFILE

Cause: The PIPE and CMDFILE options cannot be used together. When using the PIPE option, RMAN must obtain its input from the input pipe.

Action: Remove either the PIPE or CMDFILE option.

RMAN-00577 PIPE requires that TARGET be specified on the command line

Cause: The PIPE option obtains its input from, and writes its output to, an Oracle database pipe in the target database. Therefore, the target database connection must be specified on the command line, so that RMAN can connect to the target database to receive its input from the pipe.

Action: Specify the TARGET option on the RMAN command line.

RMAN-00578 pipe string is not private and owned by SYS

Cause: The pipe that RMAN needs to use for its input or output is either a public pipe or a private pipe that is not owned by SYS. This is a potential security problem, because it allows a non-SYS user to issue commands to RMAN or to retrieve the RMAN output.

Action: If you are attempting to put data on the RMAN input pipe prior to starting RMAN, so RMAN will process the data on the pipe as soon as it starts, you must be connected as SYS and you must first use the dbms_pipe.create_pipe function to explicitely create the pipe as a private pipe.

RMAN-00600 internal error, arguments [string] [string] [string] [string] [string]

Cause: An internal error in Recovery Manager occurred.

Action: Contact Oracle Support Services.

RMAN-00601 fatal error in recovery manager

Cause: A fatal error has occurred.

Action: This message should be accompanied by one or more other error messages indicating the cause of the error.

RMAN-01006 error signalled during parse

Cause: An error was signalled during parsing.

Action: This message should be accompanied by one or more other error messages indicating the cause of the error.

RMAN-01007 at line number column number file: string

Cause: This is an informational message indicating the line and column where a syntax error was detected.

Action: No action required.

RMAN-01008 the bad identifier was: string

Cause: This is an informational message indicating the identifier token that caused a syntax error.

Action: No action required.

RMAN-02000 wrong message file version (msg number not found)

Cause: The RMANXX.MSB file is not the correct version.

Action: Check that the installation was done correctly. The RMAN binary (executable, load module, whatever it is called on your operating system) and the RMANXX.MSB file must be from the same version, release, and patch level.

RMAN-02001 unrecognized punctuation symbol "string"

Cause: An illegal punctuation character was encountered.

Action: Remove the illegal character.

RMAN-02002 unexpected end of input file reached

Cause: This is probably caused by failure to supply the closing quote for a quoted string.

Action: Correct the input.

RMAN-02003 unrecognized character: string

Cause: An input character that is neither an alpha, digit, or punctuation was encountered.

Action: Remove the character.

RMAN-02004 quoted string too big

Cause: A quoted string longer than 2000 bytes was encountered.

Action: This may be caused by a missing close quote. If so, add the missing quote, otherwise shorten the string.

RMAN-02005 token too big

Cause: A token longer than 1000 bytes was encountered.

Action: Tokens must be separated by white space or punctuation. Either add the missing white space or punctuation, or shorten the token.

RMAN-02006 script line too long

Cause: A line longer than 500 bytes was encountered.

Action: Break the line up into shorter lines.

RMAN-02007 Integer value overflow

Cause: Parser failed to convert input string to an integer.

Action: values for integer are from 0 to 2147483648. Retry the tcommand using a valid integer value.

RMAN-03000 recovery manager compiler component initialization failed

Cause: This message should be accompanied by one or more other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-03001 recovery manager command sequencer component initialization failed

Cause: This message should be accompanied by one or more other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-03002 failure of string command at string

Cause: This message should be accompanied by one or more other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-03003 command not implemented yet: string

Cause: The command is not implemented in the current release.

Action: Avoid using the command.

RMAN-03004 fatal error during execution of command

Cause: This message should be accompanied by one or more other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-03008 error while performing automatic resync of recovery catalog

Cause: This message should be accompanied by one or more other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-03009 failure of string command on string channel at string

Cause: This message should be accompanied by other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-03010 fatal error during library cache pre-loading

Cause: This message should be accompanied by one or more other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-03012 fatal error during compilation of command

Cause: A fatal error occurred during compilation of a command.

Action: This message should be accompanied by other errors explaining the cause of the failure.

RMAN-03014 implicit resync of recovery catalog failed

Cause: This message is accompanied by other errors explaining the cause of the failure.

Action: Check the accompanying errors.

RMAN-03015 error occurred in stored script string

Cause: Informational message only.

Action: No action required.

RMAN-03017 recursion detected in stored script string

Cause: A stored script is calling itself or another script which calls itself.

Action: Remove the recursion.

RMAN-03018 async RPCs are working correctly

Cause: This is an informational message.

Action: No action required.

RMAN-03019 async RPCs are NOT working

Cause: The RPCTEST command has determined that RPCs are not executing asynchronously. Instead, they are blocking. This is caused by using a SQL*Net driver that does not support non-blocking UPI.

Action: Try using a different SQL*Net driver.

RMAN-03020 async RPC test will take 1 minute

Cause: This is an informational message.

Action: No action required.

RMAN-03021 executing script: string

Cause: This is an informational message.

Action: No action required.

RMAN-03023 executing command: string

Cause: This is an informational message.

Action: No action required.

RMAN-03027 printing stored script: string

Cause: This is an informational message.

Action: No action required.

RMAN-03028 fatal error code for command string : number

Cause: Informational message. This precedes error 3012.

Action: No action required.

RMAN-03029 echo set on

Cause: A SET ECHO ON command was issued.

Action: No action required.

RMAN-03030 echo set off

Cause: A SET ECHO OFF command was issued.

Action: No action required.

RMAN-03031 this option of set command needs to be used inside a run block

Cause: The option used with the SET command is not valid outside a run block.

Action: Change the SET command or place it inside a run block.

RMAN-03032 this option of set command needs to be used outside of a run block

Cause: The option used with the SET command is not valid inside of a run block.

Action: Change the SET command or place it outside a run block.

RMAN-03033 current log archived

Cause: A "ALTER SYSTEM ARCHIVE LOG CURRENT" command completed successfully.

Action: No action required; this is an informational message.

RMAN-03034 LEVEL number is invalid. LEVEL must be between string and string

Cause: An invalid DEBUG LEVEL was used.

Action: Change the DEBUG LEVEL argument.

RMAN-03099 job cancelled at user request

Cause: The user interrupted the current job.

Action: No action required.

RMAN-03999 Oracle error occurred while converting a date: ORA-number: string

Cause: An internal error occurred while converting a date.

Action: Contact Oracle Support Services.

RMAN-04000 memory allocation failure

Cause: A memory allocation request could not be satisfied.

Action: Increase the amount of memory available to RMAN.

RMAN-04001 heap initialization failure

Cause: This message should be accompanied by one or more other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-04002 ocipi failed, ORA-string

Cause: OCI process level initialization failed.

Action: This error should not normally occur.

RMAN-04003 ociinit failed

Cause: The call to OCIEnvInit failed.

Action: This error should not normally happen. Contact Oracle Support Services.

RMAN-04004 error from recovery catalog database: string

Cause: An error was received from the recovery catalog database.

Action: The cause of the failure is included in the error message. Correct the cause of the failure and retry the command.

RMAN-04005 error from target database: string

Cause: An error was received from the target database.

Action: The cause of the failure is included in the error message. Correct the cause of the failure and retry the command.

RMAN-04006 error from auxiliary database: string

Cause: An error was received from the clone or duplicate database.

Action: The cause of the failure is included in the error message. Correct the cause of the failure and retry the command.

RMAN-04007 WARNING from recovery catalog database: string

Cause: A warning was received from the recovery catalog database.

Action: The cause of the failure is included in the error message. Correct the cause of the failure and retry the command.

RMAN-04008 WARNING from target database: string

Cause: A warning was received from the target database.

Action: The cause of the failure is included in the error message. Correct the cause of the failure and retry the command.

RMAN-04009 WARNING from auxiliary database: string

Cause: A warning was received from the clone or duplicate database.

Action: The cause of the failure is included in the error message. Correct the cause of the failure and retry the command.

RMAN-04010 target database Password:

Cause: This is an informational message.

Action: No action required.

RMAN-04011 recovery catalog database Password:

Cause: This is an informational message.

Action: No action required.

RMAN-04012 auxiliary database Password:

Cause: This is an informational message.

Action: No action required.

RMAN-04013 must connect before startup

Cause: A connection is required before startup.

Action: Connect and retry the command.

RMAN-04014 startup failed: string

Cause: The database failed to start.

Action: The cause of the failure is included in the error message. Correct the cause of the failure and retry the STARTUP command.

RMAN-04015 error setting target database character set to string

Cause: An error was received while setting the session character set in the target database.

Action: This error should not normally happen. Contact Oracle Support Services.

RMAN-04016 could not get OCI error handle

Cause: An error was received while initializing the OCI layer.

Action: This error should not normally happen. Contact Oracle Support Services.

RMAN-04020 target database name "string" does not match channel's name: "string"

Cause: The CONNECT clause of the ALLOCATE command has resulted in a connection to a database which is not the same as the one used to connect to the target database.

Action: Verify that the CONNECT string connects to the same database as the one specified in the TARGET connection for the CONNECT command.

RMAN-04021 target database DBID string does not match channel's DBID string

Cause: The CONNECT clause of the ALLOCATE command has resulted in a connection to a database which is not the same as the one used to connect to the target database.

Action: Verify that the CONNECT string connects to the same database as the one specified in the TARGET connection for the CONNECT command.

RMAN-04022 target database mount id string does not match channel's mount id string

Cause: The CONNECT clause of the ALLOCATE command has resulted in a connection to a database which is not the same as the one used to connect to the target database.

Action: Verify that the CONNECT string connects to the same database as the one specified in the TARGET connection for the CONNECT command.

RMAN-05000 SET AUXNAME required for datafile string

Cause: One of the following:

  • The control file mounted by the auxiliary database does not have an entry for this datafile, therefore file name conversion is not possible.
  • A COPY DATAFILE TO AUXNAME command was issued, but no auxiliary name was set for this datafile.

Action: Use the SET AUXNAME command to specify a file name that the auxiliary database can use as a restore destination.

RMAN-05001 auxiliary filename string conflicts with a file used by the target database

Cause: RMAN is attempting to use the specified file name as a restore destination in the auxiliary database, but this name is already in use by the target database.

Action: Use the SET AUXNAME command to specify a name for the datafile that does not conflict with a file name in use by the target database.

RMAN-05002 aborting point-in-time tablespace recovery

Cause: Previously encountered error(s) were issued which require corrective action.

Action: Resolve the error conditions, and then re-issue the RECOVER command.

RMAN-05003 point-in-time recovery is not allowed for tablespace string

Cause: The SYSTEM tablespace or a tablespace containing rollback segments is not allowed in point-in-time recovery.

Action: Remove the indicated tablespace from the recovery set and retry the operation.

RMAN-05004 target database log mode is NOARCHIVELOG

Cause: An attempt was made to apply TSPITR to a database that is in NOARCHIVELOG mode.

Action: If all required archive log files are available to TSPITR, alter the target database log mode to ARCHIVELOG and retry the TSPITR operation. Otherwise, TSPITR cannot be applied to this database.

RMAN-05005 point-in-time recovery is not allowed for re-created tablespace string

Cause: The requested tablespace has been re-created and is not allowed in point-in-time recovery.

Action: Remove the indicated tablespace from the recovery set and retry the operation.

RMAN-05006 cannot recover clone standby single tablespaces

Cause: Standby recover can only be performed for the whole database.

Action: Change the tablespace list to a database specification.

RMAN-05007 no channel allocated

Cause: A command was entered that requires a channel, and no channel is allocated.

Action: Use ALLOCATE CHANNEL before using the command.

RMAN-05008 SET NEWNAME TO NEW not allowed (datafile string)

Cause: SET NEWNAME ... TO NEW is not allowed with TSPITR.

Action: Set the new name to a specific file name and retry.

RMAN-05009 Block Media Recovery requires Enterprise Edition

Cause: The BLOCKRECOVER command was specified.

Action: Remove the BLOCKRECOVER command.

RMAN-05010 target database must be opened in READ WRITE mode for TSPITR

Cause: The target database was not opened in read write mode.

Action: Open the database in read write mode.

RMAN-05011 auxiliary instance must be in nomount state for TSPITR

Cause: The Auxiliary instance was not in nomount state.

Action: Open the auxiliary instance in nomount state.

RMAN-05012 trying to start the Oracle instance without parameter files ...

Cause: The instance could not be started because no default parameter file (either PFILE or SPFILE) could be found. The instance will 421// be started in restricted mode with default parameters.

Action: No action required. This is an informational message.

RMAN-05013 unable to generate a temporary file

Cause: Creation of a temporary file failed. It could be that the system does not have enough resources (disk space, memory, or similar).

Action: Verify and free some system resources memory and try again.

RMAN-05014 unable to open a temporary file: "string"

Cause: Opening of a temporary file failed. It could be that the system does not have enough resources (disk space, memory, or similar).

Action: Verify and free some system resources memory and try again.

RMAN-05015 unable to write to a temporary file: "string"

Cause: Writing to a temporary file failed. It could be that the system does not have enough resources (disk space, memory, or similar).

Action: Verify and free some system resources memory and try again.

RMAN-05500 the auxiliary database must be not mounted when issuing DUPLICATE command

Cause: A DUPLICATE command was issued, but the auxiliary database is mounted.

Action: Dismount the auxiliary database.

RMAN-05501 aborting duplication of target database

Cause: Previously encountered errors require corrective action.

Action: Resolve the error conditions, and reissue the DUPLICATE TARGET DATABASE command.

RMAN-05502 the target database must be mounted when issuing a DUPLICATE command

Cause: A DUPLICATE command was issued, but the target database control file is not mounted.

Action: Mount the target database control file by issuing ALTER DATABASE MOUNT via Enterprise Manager or Server Manager.

RMAN-05503 at least one auxiliary channel must be allocated to execute this command

Cause: No auxiliary channels are allocated.

Action: Allocate an auxiliary channel.

RMAN-05504 at least two redo log files or groups must be specified for this command

Cause: Only one redo log file or group was specified.

Action: Specify at least one more redo log file or group.

RMAN-05505 auxiliary filename conversion of 'string' exceeds maximum length of string

Cause: When the given file name is converted to the name used for the auxiliary database, the converted name is larger than the maximum allowed file name.

Action: Change initialization parameter DB_FILE_NAME_CONVERT to convert to a valid file name.

RMAN-05506 error during recursive execution

Cause: This message should be accompanied by other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-05507 standby controlfile checkpoint (string) is more recent than duplication point in time

Cause: A DUPLICATE FOR STANDBY command was issued, but the checkpoint of the controlfile is more recent than the last archivelog or the specified point in time.

Action: If an explicit point in time was specified, change it to be at least the controlfile checkpoint; otherwise archive (and backup/copy) the current log.

RMAN-05508 SET NEWNAME TO NEW not allowed (datafile string)

Cause: SET NEWNAME ... TO NEW is not allowed with the DUPLICATE command.

Action: Set the new name to a specific file name and retry.

RMAN-05510 Duplicate finished

Cause: This is an informational message.

Action: No Action Required.

RMAN-05511 Datafile string skipped by request

Cause: This is an informational message.

Action: No Action Required.

RMAN-05512 tablespace SYSTEM cannot be skipped from duplication

Cause: The SYSTEM tablespace must be included in the duplicate database.

Action: Remove the SYSTEM tablespace from the SKIP list and retry the operation.

RMAN-05513 Cannot duplicate, controlfile is not current or backup

Cause: DUPLICATE requires that the target database has a current controlfile.

Action: Open the target database and retry operation.

RMAN-05514 tablespace string has undo information, cannnot skip

Cause: All tablespaces that have undo information must be included in the duplication.

Action: Remove the specified tablespace from the SKIP list and retry the operation.

RMAN-06000 could not open recovery manager library file: string

Cause: The RECOVER.BSQ file could not be opened.

Action: Check that the file was installed correctly and that the user running RMAN has authority to read the file.

RMAN-06001 error parsing job step library

Cause: A syntax error was encountered while parsing RECOVER.BSQ.

Action: Ensure that the correct version of the file is installed and that it has not been modified in any way.

RMAN-06002 command not allowed when not connected to a recovery catalog

Cause: A command that is allowed only when a recovery catalog connect string was supplied was attempted.

Action: Avoid using the command, or restart RMAN and supply a recovery catalog connect string via the RCVCAT parameter.

RMAN-06003 ORACLE error from target database: string

Cause: This message should be accompanied by other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-06004 ORACLE error from recovery catalog database: string

Cause: This message should be accompanied by other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-06005 connected to target database: string (DBID=string)

Cause: This is an informational message.

Action: No action is required.

RMAN-06006 connected to target database: string (not mounted)

Cause: This is an informational message.

Action: No action is required.

RMAN-06007 target database not mounted and db_name not set in init.ora

Cause: The target database has not mounted the control file, and its INIT.ORA file does not specify the DB_NAME parameter.

Action: MOUNT the target database, or add the DB_NAME parameter to its INIT.ORA file and restart the instance.

RMAN-06008 connected to recovery catalog database

Cause: This is an informational message.

Action: No action is required.

RMAN-06009 using target database controlfile instead of recovery catalog

Cause: This is an informational message.

Action: No action is required.

RMAN-06010 error while looking up datafile: string

Cause: An error occurred while looking up the specified datafile in the recovery catalog or target database control file.

Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the file name is entered correctly. If the datafile was added recently, then a RESYNC CATALOG must be done to update the recovery catalog.

RMAN-06011 invalid level specified: number

Cause: An invalid incremental backup level was specified.

Action: Incremental backup level must be between 0 and 8.

RMAN-06012 channel: string not allocated

Cause: A RELEASE or SETLIMIT command was found for a channel identifier that was not yet allocated.

Action: Correct the channel identifier, or add an ALLOCATE CHANNEL command.

RMAN-06013 duplicate channel identifier found: string

Cause: A channel identifier was reused without first releasing the channel.

Action: Add a RELEASE CHANNEL command.

RMAN-06014 command not implemented yet: string

Cause: Not all commands are implemented for the beta release.

Action: Avoid using the command.

RMAN-06015 error while looking up datafilecopy name: string

Cause: An error occurred while looking up the specified datafile copy name in the recovery catalog or target database control file.

Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the file name is entered correctly. If the datafile copy was created when the recovery catalog was not available, then a RESYNC CATALOG must be done to update the recovery catalog.

RMAN-06016 duplicate backup operand specified: string

Cause: The specified operand appears more than once in the same backup specifier or backup command.

Action: Delete the duplicate operand.

RMAN-06017 initialization of parser failed

Cause: The parser package initialization routine returned an error.

Action: This message should be accompanied by other error messages indicating the cause of the error.

RMAN-06018 duplicate operand specified in backup specification: string

Cause: A backup specification operand appears more than once in a backup specification.

Action: Delete the duplicate operand.

RMAN-06019 could not translate tablespace name "string"

Cause: An error occurred while looking up the specified tablespace name in the recovery catalog or target database control file.

Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the tablespace is entered correctly. If the tablespace was added recently, then a RESYNC CATALOG must be done to update the recovery catalog.

RMAN-06020 connected to auxiliary database

Cause: This is an informational message.

Action: No action is required.

RMAN-06021 FROM DATAFILECCOPY/BACKUPSET may not be specified with archivelogs

Cause: The FROM DATAFILECCOPY/BACKUPSET option applies only to datafile and control file restores.

Action: Use this option only for datafile and control file restores.

RMAN-06023 no backup or copy of datafile number found to restore

Cause: A datafile, tablespace, or database restore could not proceed because no backup or copy of the indicated file was found. It may be the case that a backup or copy of this file exists but does not satisfy the criteria specified in the user's restore operands.

Action: No action required. This is an informational message. See message 6026 for further details.

RMAN-06024 no backup or copy of the controlfile found to restore

Cause: A control file restore could not proceed because no backup or copy of the control file was found. It may be the case that a backup or copy of this file exists but does not satisfy the criteria specified in the user's restore operands.

Action: No action required. This is an informational message. See message 6026 for further details.

RMAN-06025 no backup of log thread number seq number scn string found to restore

Cause: An archive log restore could not proceed because no backup of the indicated archived log was found. It may be the case that a backup of this file exists but does not satisfy the criteria specified in the user's restore operands.

Action: No action required This is an informational message. See message 6026 for further details.

RMAN-06026 some targets not found - aborting restore

Cause: Some of the files specified for restore could not be found. Message 6023, 6024, or 6025 is also issued to indicate which files could not be found. Some common reasons why a file cannot be restored are that there is no backup or copy of the file that is known to Recovery Manager, or there are no backups or copies that fall within the criteria specified on the RESTORE command, or some datafile copies have been made but not cataloged.

Action: The Recovery Manager LIST command can be used to display the backups and copies that Recovery Manager knows about. Select the files to be restored from that list.

RMAN-06027 no archivelogs found that match specification

Cause: An archive log record specifier did not match any archive logs in the recovery catalog.

Action: Resubmit the command with a different archive log record specifier. The RMAN LIST command can be used to display all archive logs that Recovery Manager knows about.

RMAN-06028 duplicate operand specified in restore specification: string

Cause: The CHANNEL, TAG, FROM, PARMS, VALIDATE, or CHECK READONLY option was specified more than once in the restore command or in one of the restore specifications.

Action: Correct and resubmit the command.

RMAN-06029 the controlfile may be included only in a datafile backup set

Cause: The INCLUDE CURRENT/STANDBY CONTROLFILE option was specified for an archive log backup set.

Action: Use this option only for datafile backup sets.

RMAN-06030 the DELETE INPUT option may not be used with a datafile backup set

Cause: The DELETE INPUT option was specified for a backup that contains the current control file or datafiles.

Action: Remove the option and resubmit the command.

RMAN-06031 could not translate database keyword

Cause: An error was received when calling DBMS_RCVMAN.

Action: This message should be accompanied by other error messages indicating the cause of the error.

RMAN-06032 at least 1 channel of TYPE DISK must be allocated to execute a COPY command

Cause: No channel of TYPE DISK was allocated.

Action: Allocate a channel of TYPE DISK and re-issue the command.

RMAN-06033 channel string not allocated

Cause: An RMAN command requests a specific channel, but the requested channel has not been allocated.

Action: ALLOCATE the channel, or correct the channel identifier.

RMAN-06034 at least 1 channel must be allocated to execute this command

Cause: No channels are allocated.

Action: ALLOCATE a channel.

RMAN-06035 wrong version of recover.bsq, expecting string, found string

Cause: The RECOVER.BSQ file is incompatible with the RMAN executable.

Action: Install the correct version of RECOVER.BSQ.

RMAN-06036 datafile number is already restored to file string

Cause: A SET NEWNAME command was issued to restore a datafile to a location other than the original datafile, and Recovery Manager determined that the best candidate for restoring the file is the datafile copy with the same name, therefore the file is already restored and no action need be taken.

Action: No action required. This is an informational message.

RMAN-06037 incremental backups feature not implemented

Cause: An incremental backup of a datafile copy was requested.

Action: Change the incremental level to 0, or request a full backup.

RMAN-06038 recovery catalog package detected an error

Cause: A call to DBMS_RCVMAN returned an error.

Action: This message should be accompanied by other error messages indicating the cause of the error.

RMAN-06039 no set newname command has been issued for datafile number

Cause: A SWITCH command was specified for a datafile, but no destination was specified and no SET NEWNAME command has been previously issued for that file. An explicit file to switch to must be specified if no SET NEWNAME command has been issued.

Action: Correct and resubmit the SWITCH command.

RMAN-06040 controlfile is already restored to file string

Cause: The best candidate control file for restoration is the one that is named in the RESTORE (control file) command, hence no action need be taken.

Action: No action required. This is an informational message.

RMAN-06041 cannot switch file number to copy of file number

Cause: An attempt was made to switch a datafile to a copy of a different datafile.

Action: Correct and resubmit the SWITCH command.

RMAN-06042 TAG option not supported for archivelog backup sets

Cause: The tag option was supplied but does not apply to this type of backup.

Action: Remove the TAG operand and re-enter the command.

RMAN-06043 TAG option not supported for archivelog or current/standby controlfile copies

Cause: The tag option was supplied but does not apply to this type of copy.

Action: Remove the TAG operand and re-enter the command.

RMAN-06044 duplicate operand specified in copy specification: string

Cause: The specified operand appears more than once in the same copy specification.

Action: Remove the redundant operand.

RMAN-06045 LEVEL option not supported for archivelog or current/standby controlfile copies

Cause: The LEVEL option was supplied but does not apply to this type of copy.

Action: Remove the LEVEL operand and re-enter the command.

RMAN-06046 archivelog name: string

Cause: An error occurred while translating an archive log name to its recovery catalog RECID/timestamp. This message should be accompanied by other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-06047 duplicate datafile number specified for restoration from copy

Cause: The indicated datafile was specified more than once in the same restore command.

Action: Correct and resubmit the RESTORE command.

RMAN-06048 duplicate controlfile specified for restoration from copy

Cause: The control file was specified more than once in the same RESTORE command.

Action: Correct and resubmit the RESTORE command.

RMAN-06049 CHECK LOGICAL option not supported for archive log or current/standby controlfile copies

Cause: The check logical option was supplied but does not apply to this type of copy.

Action: Remove the CHECK LOGICAL operand and re-enter the command.

RMAN-06050 archivelog thread number sequence number is already on disk as file string

Cause: An archive log which was requested to be restored (either explicitly or via a range specification) does not need to be restored because it already exists on disk.

Action: No action required. This is an informational message.

RMAN-06051 DELETE INPUT option not implemented yet

Cause: This option was specified in a backup specification.

Action: Remove the DELETE INPUT option.

RMAN-06052 no parent backup or copy of datafile number found

Cause: An incremental backup at level 1 or higher could not find any parent backup or copy of the indicated datafile. A level 0 backup of the datafile will be taken automatically.

Action: This is an informational message only.

RMAN-06053 unable to perform media recovery because of missing log

Cause: This message is accompanied with another message identifying the missing log. The log would be needed to perform the media recovery, but the log is not on disk and no backup set containing the log is available.

Action: Determine if a backup set containing the log can be made available. If so, then use the CHANGE command to make the backup set available and retry the command. If not, then a point in time recovery up to the missing log is the only alternative.

RMAN-06054 media recovery requesting unknown log: thread string scn string

Cause: Media recovery is requesting a log whose existence is not recorded in the recovery catalog or control file.

Action: If a copy of the log is available, then add it to the recovery catalog and/or control file via a CATALOG command and then retry the RECOVER command. If not, then a point in time recovery up to the missing log is the only alternative.

RMAN-06055 could not find log sequence string thread string

Cause: A log which was on disk at the start of media recovery or which should have been restored from a backup set could not be found.

Action: Check the Recovery Manager message log to see if the log was restored by a previous job step. If so, then check the V$ARCHIVED_LOG view to see if the log is listed in the control file. If so, then validate that the log exists on disk and is readable. If the log was not restored, or was restored but no record of the log exists in V$ARCHIVED_LOG, then contact Oracle Support Services.

RMAN-06056 could not access datafile number

Cause: A backup or copy could not proceed because the datafile header could not be read or the header was not valid.

Action: Make the datafile accessible or skip it.

RMAN-06057 a standby controlfile cannot be included along with a current controlfile

Cause: "current controlfile" was specified along with "standby controlfile".

Action: Remove "current controlfile" or "standby controlfile" from the backup specification.

RMAN-06058 a current controlfile cannot be included along with a standby controlfile

Cause: "standby controlfile" was specified along with "current controlfile".

Action: Remove "standby controlfile" or "current controlfile" from the backup specification.

RMAN-06059 expected archived log not found, loss of archived log compromises recoverability

Cause: The archived log was not found. The repository thinks it does exist. If the archived log has in fact been lost and there is no backup, then the database is no longer recoverable across the point in time covered by the archived log. This may occur because the archived log was removed by an outside utility without updating the repository.

Action: If the archived log has been removed with an outside utility and the archivelog has already been backed up, then you can synchronize the repository by running CROSSCHECK ARCHIVELOG ALL. If the archivelog has not been previously backed up, then you should take a full backup of the database and archivelogs to preserve recoverability. Previous backups are not fully recoverable.

RMAN-06060 WARNING: skipping datafile compromises tablespace string recoverability

Cause: SKIP INACCESSIBLE or SKIP OFFLINE option resulted in skipping datafiles during BACKUP. If the datafile has in fact been lost and there is no backup, then the tablespace is no longer recoverable without ALL archive logs since datafile creation. This may occur because the datafile was deleted by an outside utility or the datafile was made OFFLINE [DROP].

Action: If there is no backup of skipped datafiles and the tablespace has to be recoverable without ALL archive logs since datafile creation, then you should make these datafiles available for backup.

RMAN-06061 WARNING: skipping archivelog compromises recoverability

Cause: SKIP INACCESSIBLE option resulted in skipping archivelogs during BACKUP. If the archived log has in fact been lost and there is no backup, then the database is no longer recoverable across the point in time covered by the archived log. This may occur because archived log was removed by an outside utility without updating the repository.

Action: If the archived log has been removed with an outside utility and the archivelog has already been backed up, then you can synchronize the repository by running CROSSCHECK ARCHIVELOG ALL. If the archivelog has not been previously backed up, then you should take a full backup of the database and archivelogs to preserve recoverability. Previous backups are not fully recoverable.

RMAN-06062 can not backup SPFILE because the instance was not started with SPFILE

Cause: A backup command requested a backup of the SPFILE, but no SPFILE was used to start the instance.

Action: Create an SPFILE and re-start the instance using the SPFILE or modify the command.

RMAN-06063 DBID is not found in the recovery catalog

Cause: DBID is not found in the recovery catalog.

Action: Verify that the DBID is correct and restart the command.

RMAN-06066 the target database must be mounted when issuing a RECOVER command

Cause: A RECOVER command was issued, but the target database control file is not mounted.

Action: Mount the target database control file by issuing ALTER DATABASE MOUNT via Enterprise Manager or Server Manager.

RMAN-06067 RECOVER DATABASE required with a backup or created controlfile

Cause: The control file has been restored from a backup or was created via ALTER DATABASE CREATE CONTROLFILE.

Action: Use the RECOVER DATABASE command to perform the recovery.

RMAN-06068 recovery aborted because of missing datafiles

Cause: This error should be accompanied by one or more instances of message RMAN-06094.

Action: Refer to message RMAN-06094.

RMAN-06069 controlfile is missing the filename for datafile string

Cause: Media recovery of a backup control file added this datafile to the control file, but it does not set the file name because that is unsafe.

Action: If the datafile is on disk, then issue ALTER DATABASE RENAME to correct the control file. Otherwise, RESTORE the datafile, and then use SWITCH to make it known to the control file. If the tablespace containing this datafile will be dropped, then reissue the RECOVER command with a SKIP clause to skip recovery of this tablespace.

RMAN-06070 DBWR could not identify datafile string

Cause: DBWR could not find the specified datafile.

Action: Check the location of your datafile.

RMAN-06071 could not open datafile string

Cause: An error was encountered when trying to open the specified datafile.

Action: Ensure that the datafile exists and is accessible.

RMAN-06073 file header is corrupt for datafile string

Cause: Oracle detected a corruption in the file header. A media failure has probably occurred.

Action: RESTORE the datafile to a new location, then do a SWITCH, and then retry the RECOVER command.

RMAN-06074 file string is not an ORACLE datafile

Cause: The file header indicates that this file is not a datafile. The file may have been overlaid or corrupted.

Action: RESTORE the datafile to a new location, then do a SWITCH, and then retry the RECOVER command.

RMAN-06075 datafile string does not belong to this database

Cause: The file header indicates that this file belongs to some other Oracle database.

Action: RESTORE the datafile to a new location, then do a SWITCH, and then retry the RECOVER command.

RMAN-06076 datafile string contains wrong datafile

Cause: The datafile header indicates the file contains a different datafile number.

Action: RESTORE the datafile, and then retry the RECOVER command.

RMAN-06077 datafile string is a different version than contained in the controlfile

Cause: The control file entry for this datafile specifies a different version of this datafile. Different versions of a datafile can exist when a tablespace is dropped, and a new tablespace is created which reuses the same datafile numbers.

Action: If the datafile is correct, the fix the control file by using the SWITCH command. Otherwise, RESTORE the correct version of this datafile and retry the RECOVER command.

RMAN-06078 the controlfile is older than datafile string

Cause: The control file appears to be older than the specified datafile, but it is not marked as a backup control file. This indicates that the control file has been replaced with an older version. This error does not occur when a backup control file which was created via Recovery Manager or the ALTER DATABASE BACKUP CONTROLFILE command is restored because such control files are marked as backups.

Action: RESTORE a control file and perform RECOVER DATABASE.

RMAN-06079 database must be mounted to perform recovery

Cause: A RECOVER command was issued, but the target database is not mounted.

Action: Issue ALTER DATABASE MOUNT.

RMAN-06080 SWITCH required for datafile string

Cause: The control file record for this datafile is for an older incarnation of the datafile.

Action: Issue a SWITCH command to update the control file before doing RECOVER.

RMAN-06081 error reading datafile header for datafile string, code string

Cause: X$KCVFH returned the specified code in the HXERR column when it was queried for the specified datafile.

Action: Ensure the datafile exists and is readable. Using a newer release of Recovery Manager may return a more meaningful error message. If you have no newer version of Recovery Manager, contact Oracle Support Services.

RMAN-06082 datafilecopy tag string is ambiguous

Cause: The specified tag refers to multiple datafile copies belonging to different datafiles.

Action: Specify the datafile copy by file name rather than by tag.

RMAN-06083 error when loading stored script string

Cause: The recovery catalog database returned an error. This error explains the cause of the problem.

Action: Correct the problem and retry.

RMAN-06084 the target database may not be mounted when issuing REPLICATE

Cause: A REPLICATE command was issued, but the target database is already mounted.

Action: dismount the target database control file by issuing ALTER DATABASE CLOSE and ALTER DATABASE DISMOUNT via Enterprise Manager or Server Manager.

RMAN-06085 must use SET NEWNAME command to restore datafile string

Cause: A RESTORE command for the specified datafile could not find a destination name for the specified datafile.

Action: Add a SET NEWNAME command prior to the RESTORE command to specify the restore destination for this file.

RMAN-06086 offline files may only be skipped in a datafile backup set

Cause: The SKIP OFFLINE option was specified for an archive log backup set.

Action: Use this option only for datafile backup sets.

RMAN-06087 read-only files may only be skipped in a datafile backup set

Cause: The SKIP READONLY option was specified for an archive log backup set.

Action: Use this option only for datafile backup sets.

RMAN-06088 datafile copy string not found or out of sync with catalog

Cause: The indicated file is not found, or is found but is not the same file that the recovery catalog thinks it is. It is likely that some operation outside of Recovery Manager has altered the file, or that Recovery Manager has not resynchronized with the target database.

Action: Re-catalog the file and retry the operation.

RMAN-06089 archived log string not found or out of sync with catalog

Cause: The indicated file is not found, or is found but is not the same file that the recovery catalog thinks it is. It is likely that some operation outside of Recovery Manager has altered the file, or that Recovery Manager has not resynchronized with the target database.

Action: Re-catalog the file and retry the operation.

RMAN-06090 error while looking up controlfile copy: string

Cause: An error occurred while looking up the specified control file copy in the recovery catalog or target database control file.

Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the file name is entered correctly. If the control file copy was created when the recovery catalog was not available, then a RESYNC CATALOG must be done to update the recovery catalog.

RMAN-06091 no channel allocated for maintenance (of an appropriate type)

Cause: A command was entered that requires a maintenance channel, and no maintenance channel is allocated, or none of the appropriate type.

Action: Use ALLOCATE CHANNEL FOR MAINTENANCE before deleting backup pieces, or using the CROSSCHECK or DELETE EXPIRED commands. Proxy copies require a non-DISK channel.

RMAN-06092 error while looking up backup piece

Cause: An error occurred while looking up the specified backup piece in the recovery catalog or target database control file.

Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the name or key is entered correctly. If the backup piece was created when the recovery catalog was not available, then a RESYNC CATALOG must be done to update the recovery catalog.

RMAN-06093 recovery catalog contains obsolete version of datafile string

Cause: The specified datafile number was dropped and then reused. The control file mounted by the target database contains the newer version of the datafile, but the recovery catalog contains information about only the older version.

Action: Issue a RESYNC command to update the recovery catalog, then reissue the failing command. If the error persists, contact Oracle Support Services.

RMAN-06094 datafile string must be restored

Cause: A RECOVER command was issued, and the recovery catalog indicates the specified datafile should be part of the recovery, but this datafile is not listed in the control file, and cannot be found on disk.

Action: Issue a RESTORE command for this datafile, using the same UNTIL clause specified to the RECOVER command (if any), then reissue the RECOVER.

RMAN-06095 a backup controlfile must be restored to recover datafile string

Cause: The control file currently mounted by the target database contains a newer incarnation of the datafile than the recovery catalog indicates is appropriate for the point-in-time being recovered to.

Action: Restore the control file, using the same UNTIL clause specified on the failing RECOVER command, then reissue the command. If no control file can be restored, then you should issue a CREATE CONTROLFILE command.

RMAN-06096 SWITCH required for newname of datafile string to take effect

Cause: A SET NEWNAME was issued for this datafile, but no SWITCH command was issued before the RECOVER command.

Action: Issue a SWITCH command to make the new name take effect before doing RECOVER.

RMAN-06097 text of failing SQL statement: string

Cause: This is an informational message to accompany message 6003 or 6004.

Action: No action required.

RMAN-06098 the target database must be mounted when issuing a BACKUP command

Cause: A BACKUP command was issued, but the target database control file is not mounted.

Action: Mount the target database control file by issuing ALTER DATABASE MOUNT via Enterprise Manager or Server Manager.

RMAN-06099 error occurred in source file: string, line: number

Cause: See accompanying error.

Action: See accompanying error.

RMAN-06100 no channel to restore a backup or copy of datafile number

Cause: A datafile, tablespace, or database restore could not proceed because the backup of the indicated file exists on a device type that was not allocated for restore.

Action: No action required. This is an informational message. See message 6026 for further details.

RMAN-06101 no channel to restore a backup or copy of the controlfile

Cause: A control file restore could not proceed because the backup of the indicated file exists on a device type that was not allocated for restore.

Action: No action required. This is an informational message. See message 6026 for further details.

RMAN-06102 no channel to restore a backup or copy of log thread number seq number scn string

Cause: An archive log restore could not proceed because the backup of the indicated file exists on a device type that was not allocated for restore.

Action: No action required. This is an informational message. See message 6026 for further details.

RMAN-06103 duplicate qualifier found in REPORT command: string

Cause: The indicated qualifier appears more than once in a REPORT qualifier list.

Action: Delete the duplicate qualifier.

RMAN-06104 auxiliary name for datafile number unset

Cause: This message is issued in response to a SET AUXNAME FOR datafile TO NULL command. This is an informational message.

Action: No action required.

RMAN-06105 duplicate qualifier found in LIST command: string

Cause: The indicated qualifier appears more than once in a LIST qualifier list.

Action: Delete the duplicate qualifier.

RMAN-06106 this command requires that target database be mounted

Cause: A command was issued that requires the target database to be mounted, but the target database is not mounted.

Action: Mount the target database control file by issuing ALTER DATABASE MOUNT via Enterprise Manager or Server Manager.

RMAN-06107 WARNING: controlfile is not current for REPORT NEED BACKUP DAYS

Cause: The REPORT NEED BACKUP DAYS command may report some files as requiring backups when they really do not, because the most current online status of the file is not known unless a current control file is mounted.

Action: No action required, however, a current control file should be mounted, if possible, to get the most accurate REPORT output.

RMAN-06108 changed datafile copy unvailable

Cause: This is an informational message.

Action: No action required.

RMAN-06109 changed archivelog unavailable

Cause: This is an informational message.

Action: No action required.

RMAN-06110 changed controlfile copy unavailable

Cause: This is an informational message.

Action: No action required.

RMAN-06111 changed backup piece unavailable

Cause: This is an informational message.

Action: No action required.

RMAN-06112 changed datafile copy available

Cause: This is an informational message.

Action: No action required.

RMAN-06113 changed archivelog available

Cause: This is an informational message.

Action: No action required.

RMAN-06114 changed controlfile copy available

Cause: This is an informational message.

Action: No action required.

RMAN-06115 changed backup piece available

Cause: This is an informational message.

Action: No action required.

RMAN-06116 datafile copy cannot be found on disk, return code string

Cause: The CHANGE DATAFILECOPY AVAILABLE command was used, but the datafilecopy cannot be found on disk.

Action: If the storage containing the datafilecopy has been removed from the host, restore it and retry the command. If the datafilecopy is permanently gone, then issue the CHANGE DATAFILECOPY DELETE command for this datafile.

RMAN-06117 archivelog cannot be found on disk, return code string

Cause: The CHANGE ARCHIVELOG AVAILABLE command was used, but the archive log cannot be found on disk.

Action: If the storage containing the archive log has been removed from the host, restore it and retry the command. If the archive log is permanently gone, then issue the CHANGE ARCHIVELOG DELETE command for this archive log.

RMAN-06118 control file copy cannot be found on disk, return code string

Cause: The CHANGE CONTROLFILECOPY AVAILABLE command was used, but the control file copy cannot be found on disk.

Action: If the storage containing the control file copy has been removed from the host, restore it and retry the command. If the control file copy is permanently gone, then issue the CHANGE CONTROLFILECOPY DELETE command for this datafile.

RMAN-06119 uncataloged datafile copy

Cause: This is an informational message.

Action: No action required.

RMAN-06120 uncataloged archivelog

Cause: This is an informational message.

Action: No action required.

RMAN-06121 uncataloged controlfile copy

Cause: This is an informational message.

Action: No action required.

RMAN-06122 CHANGE .. UNCATALOG not supported for BACKUPSET/BACKUPPIECE

Cause: The CHANGE BACKUPPIECE/BACKUPSET .. UNCATALOG command was entered. The UNCATALOG operation is not supported with backup pieces.

Action: Use CHANGE BACKUPPIECE/BACKUPSET .. DELETE instead.

RMAN-06123 operation not supported without the recovery catalog

Cause: A command was used which requires a connection to a recovery catalog database. The command cannot be used when your backup repository is the target database control file.

Action: If a recovery catalog database is available, then connect to the recovery catalog and retry the command, otherwise enter a different command.

RMAN-06124 error while looking up datafilecopy key: number

Cause: An error occurred while looking up the specified datafile copy key in the recovery catalog.

Action: This error is accompanied by other errors describing the reason for the failure.

RMAN-06125 error while looking up archivelog key: number

Cause: An error occurred while looking up the specified archive log key in the recovery catalog.

Action: This error is accompanied by other errors describing the reason for the failure.

RMAN-06126 skipping offline file string

Cause: The indicated file will not be included in the backup set because it is offline and the SKIP OFFLINE option was specified.

Action: No action required. This is an informational message only.

RMAN-06127 skipping read only file string

Cause: The indicated file will not be included in the backup set because it is read only and the SKIP READONLY option was specified.

Action: No action required. This is an informational message only.

RMAN-06128 skipping inaccessible file string

Cause: The indicated file will not be included in the backup set because it could not be read, and the SKIP INACCESSIBLE option was specified.

Action: No action required. This is an informational message only.

RMAN-06129 invalid reserved channel ID: string

Cause: The specified channel ID is invalid. DELETE and DEFAULT are reserved channel names and may not be specified by users.

Action: Specify a different channel ID.

RMAN-06130 snapshot controlfile name set to: string

Cause: The snapshot control file name was not set, so RMAN set it to the default value.

Action: No action required. This is an informational message only.

RMAN-06131 skip offline/readonly only allowed with current controlfile

Cause: The SKIP OFFLINE and SKIP READONLY options are only permitted when the target database control file is current. When the target control file is not current, it is not possible to obtain a datafile's offline/read-only status.

Action: Remove the skip option or mount a current control file on the target database.

RMAN-06132 cannot backup datafile string because it is not in the controlfile

Cause: A backup command was issued that includes the specified datafile, but the datafile is not listed in the control file. The control file is not current (it is a backup or a created control file).

Action: Recover the control file to make it current, then retry the backup command.

RMAN-06133 recovery catalog may have obsolete data for datafile string

Cause: A RESTORE UNTIL was issued, and the recovery catalog choose an older incarnation of the datafile than is listed in the control file.

Action: If the recovery catalog has correct data for the datafile, then restore a backup control file using the same UNTIL clause, then retry the datafile restore. Otherwise, restore a backup of the incarnation of the datafile listed in the control file.

RMAN-06134 host command complete

Cause: An operating system command has completed.

Action: No action required. This is an informational message.

RMAN-06135 error executing host command: string

Cause: A host command returned a non-zero return code.

Action: Correct the offending command.

RMAN-06136 ORACLE error from auxiliary database: string

Cause: This message should be accompanied by other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-06137 must have recovery catalog for REPORT SCHEMA AT TIME

Cause: A REPORT SCHEMA at_clause command was issued, but there is no recovery catalog database.

Action: If you are not using a recovery catalog, then you may only issue the REPORT SCHEMA command with no at_clause.

RMAN-06138 controlfile not mounted - must specify AT clause with REPORT command

Cause: A REPORT SCHEMA with no at_clause was issued, and there is no recovery catalog, and there is also no control file mounted at the target database, so there is no place to get the information about the current list of files comprising the database.

Action: Use a recovery catalog or mount a control file at the target database.

RMAN-06139 WARNING: controlfile is not current for REPORT SCHEMA

Cause: A REPORT SCHEMA with no at_clause was issued, and there is no recovery catalog, and the control file mounted by the target instance is not current, so the information about the current list of datafiles may not be current.

Action: Use a recovery catalog or mount a current control file.

RMAN-06140 cannot specify TAG option with LIST INCARNATION

Cause: The TAG option was specified with LIST INCARNATION. This is not permitted because there is no TAG associated with a database incarnation.

Action: Remove the TAG option and re-run the LIST command.

RMAN-06141 cannot specify ARCHIVELOG LIKE option with RESTORE

Cause: The ARCHIVELOG LIKE option was specified with RESTORE. This is not permitted because recovery catalog contains only those records that are not deleted from disk.

Action: Remove the ARCHIVELOG LIKE option and re-run the command.

RMAN-06142 DEVICE TYPE may only be specified with LIST BACKUP

Cause: The DEVICE TYPE option was specified with a LIST COPY, LIST INCARNATION, CROSSCHECK, or DELETE EXPIRED command. This is not permitted because only backup sets may reside on different types of devices and CROSSCHECK and DELETE EXPIRED commands must use the same device type as was specified in the ALLOCATE CHANNEL FOR MAINTENANCE/DELETE command.

Action: Remove the DEVICE TYPE option and re-run the command.

RMAN-06143 LIKE may only be specified with COPY

Cause: The LIKE option was specified with a RMAN command. This is not permitted because only copies of datafiles, control files, or archive logs have file names that may be tested with a LIKE operand.

Action: Remove the LIKE option and re-run the RMAN command.

RMAN-06144 FROM or UNTIL may not be specified with LIST INCARNATION

Cause: The FROM or UNTIL option was specified with LIST INCARNATION. This is not permitted because there is no time associated with a database incarnation.

Action: Remove the FROM or UNTIL option and re-run the LIST command.

RMAN-06145 controlfile is not current - obsolete file list may be incomplete

Cause: A CHANGE or REPORT command needs to compute the list of backups that are redundant and may be deleted. If the mounted control file is not current, it may not be possible to determine if a satisfactory backup exists for files which have been offline since the last OPEN RESETLOGS. This is an informational message.

Action: No action required. To ensure a complete report of obsolete backups, mount a current control file.

RMAN-06146 changes found for file number beyond offline SCN

Cause: A CHANGE or REPORT command needs to compute the list of backups that are redundant and may be deleted. A backup was found for a file which is shown as offline in the target database control file, but the backup contains changes beyond the SCN when the file went offline. This is most likely because the target database control file is not really current, but is a restored copy of an older control file.

Action: Mount a current control file or a backup control file.

RMAN-06147 no obsolete backups found

Cause: A CHANGE or REPORT command could find no files that meet the specified criteria for obsoleteness. This is an informational message.

Action: No action required.

RMAN-06148 redundancy count must be greater than zero

Cause: The REDUNDANCY operand specified for a CHANGE or REPORT OBSOLETE command was zero.

Action: Specify a REDUNDANCY operand value greater than or equal to 1.

RMAN-06150 auxiliary name for datafile number set to: string

Cause: This message is issued in response to a SET AUXNAME command. This is an informational message.

Action: No action required.

RMAN-06151 datafile string creation scn string

Cause: This is an informational message. It should be accompanied by other messages.

Action: No action required.

RMAN-06152 CHANGE VALIDATE not supported for backup pieces or backup sets

Cause: The CHANGE VALIDATE command may not be performed on a backup piece.

Action: The CHANGE VALIDATE command may only be performed on datafile copies and archived logs. To verify the contents of a backup set, use the VALIDATE BACKUPSET command, which must be use inside of an RMAN RUN command.

RMAN-06153 validation failed for datafile copy

Cause: The CHANGE DATAFILE COPY VALIDATE command found that the datafile copy could not be found or no longer contains the same data, so its record was deleted from the recovery catalog. This is an informational message.

Action: No action required.

RMAN-06154 validation succeeded for datafile copy

Cause: The CHANGE DATAFILE COPY VALIDATE command found that the datafile copy still matches its data in the recovery catalog. This is an informational message.

Action: No action required.

RMAN-06155 validation failed for controlfile copy

Cause: The CHANGE CONTROLFILECOPY VALIDATE command found that the control file copy could not be found or no longer contains the same data, so its record was deleted from the recovery catalog. This is an informational message.

Action: No action required.

RMAN-06156 validation succeeded for controlfile copy

Cause: The CHANGE CONTROLFILECOPY VALIDATE command found that the control file copy still matches its data in the recovery catalog. This is an informational message.

Action: No action required.

RMAN-06157 validation failed for archived log

Cause: The CHANGE ARCHIVELOG VALIDATE command found that the archived log could not be found or no longer contains the same data, so its record was deleted from the recovery catalog. This is an informational message.

Action: No action required.

RMAN-06158 validation succeeded for archived log

Cause: The CHANGE ARCHIVED LOG VALIDATE command found that the archived log still matches its data in the recovery catalog. This is an informational message.

Action: No action required.

RMAN-06159 error while looking up backup set

Cause: An error occurred while looking up the specified backup set in the recovery catalog or target database control file.

Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the key is entered correctly. If the backup set was created when the recovery catalog was not available, then a RESYNC CATALOG must be done to update the recovery catalog.

RMAN-06160 no backup pieces found for backup set key: number

Cause: No backup pieces for the requested backup set were found in the recovery catalog, or the target database control file.

Action: Specify an existing backup set.

RMAN-06161 error when inspecting auxiliary filename: string

Cause: This error is accompanied by other errors explaining the cause.

Action: Correct the auxiliary file name if it is wrong via the SET AUXNAME command.

RMAN-06162 sql statement: string

Cause: This is the SQL statement about to be executed for a SQL command. This is an informational message.

Action: No action required.

RMAN-06163 some datafiles cannot be recovered, aborting the RECOVER command

Cause: This message should be followed by one or more 6162 or 6164 messages.

Action: Refer to the accompanying messages.

RMAN-06164 no channel of required type allocated to recover datafile number

Cause: A RECOVER command could not proceed because incremental backup sets or archive log backup sets exist on a device type that has not been allocated.

Action: Use the LIST command to determine which device type is needed, then allocate a channel of that type.

RMAN-06165 datafile string is too old to recover, restore a more recent copy

Cause: The archived logs and/or incremental backup sets required to recover the datafile do not exist, but a more recent backup of the datafile exists which can be recovered.

Action: Issue a RESTORE for the datafile, then reissue the RECOVER command.

RMAN-06166 datafile string cannot be recovered

Cause: Incremental backups or archived redo logs needed to recover the datafile cannot be found, and no recoverable full backup or datafile copy exists.

Action: Use the LIST command to see if there is a backup set or datafile copy that can be made AVAILABLE. If not, then the datafile is unrecoverable. If a full or datafile copy exists, then a point-in-time recovery may be possible.

RMAN-06167 already connected

Cause: A CONNECT command was issued, but RMAN is already connected to the specified database.

Action: RMAN has no DISCONNECT command, so to connect to a different instance, exit RMAN and start it again.

RMAN-06168 no backup pieces with this tag found: string

Cause: A tag was used to specify a list of backup pieces, but no backup pieces with this tag could be found.

Action: Make sure the tag is specified correctly.

RMAN-06169 could not read file header for datafile string error reason string

Cause: The specified datafile could not be accessed. The reason codes are:

  • 1 - file name is missing in the control file
  • 2 - file is offline
  • 3 - file is not verified
  • 4 - DBWR could not find the file
  • 5 - unable to open file
  • 6 - I/O error during read
  • 7 - file header is corrupt
  • 8 - file is not a datafile
  • 9 - file does not belong to this database
  • 10 - file number is incorrect
  • 12 - wrong file version
  • 15 - control file is not current

Action: If the error can be corrected, do so and retry the operation. The SKIP option can be used to ignore this error during a backup.

RMAN-06170 no controlfile copy found with offline range recid string stamp string datafile string

Cause: This offline range is needed for recovering the specified datafile, but the offline range record has aged out of the current control file and no control file copy with the record could be accessed. At least one control file copy containing the offline range was found in the recovery catalog and was in AVAILABLE status.

Action: Query the RC_CONTROLFILE_COPY view for the names of all control file copies, then issue a CHANGE CONTROLFILECOPY... VALIDATE; command for them. Then reissue the RECOVER command.

RMAN-06171 not connected to target database

Cause: A command was issued but no connection to the target database has been established.

Action: Issue a CONNECT TARGET command to connect to the target database.

RMAN-06172 no autobackup found or specified handle is not a valid copy or piece

Cause: A restore could not proceed because no autobackup was found or the specified handle is not a valid copy or backup piece. In case of restore from autobackup, it may be the case that a backup exists, but it does not satisfy the criteria specified in the user's restore operands. In case of restore from handle, it may be the handle is not a backup piece or controlfile copy. It may be that it does not exist.

Action: Modify autobackup search criteria or verify the handle.

RMAN-06173 no set newname command has been issued for datafile string when restore auxiliary

Cause: Auxiliary type was specified for the control file, but no SET NEWNAME command has been previously issued for a datafile.

Action: Issue SET NEWNAME command for every datafile in the recovery set.

RMAN-06174 not connected to auxiliary database

Cause: A auxiliary command was issued but no connection to an auxiliary database has been established.

Action: Issue a CONNECT AUXILIARY command to connect to the auxiliary database.

RMAN-06175 deleted script: string

Cause: A DELETE SCRIPT command was executed.

Action: No action required.

RMAN-06176 no recovery required; all files are readonly or offline

Cause: A RECOVER DATABASE command does not need to recover any files because all of the files to be recovered are offline or read only. This can only occur when the SKIP clause includes the system tablespace. This is an informational message.

Action: No action required.

RMAN-06177 restore not done; all files readonly, offline, or already restored

Cause: A RESTORE command does not need to restore any files, because all of the files to be restored are offline, read only, or are already restored to their correct destinations. This is an informational message.

Action: No action required.

RMAN-06178 datafile number not processed because file is offline

Cause: A RESTORE DATABASE or RECOVER DATABASE command omitted processing the indicated datafile because it is offline clean at the desired point in time. This is an informational message.

Action: No action required.

RMAN-06179 datafile number not processed because file is read only

Cause: A RESTORE DATABASE or RECOVER DATABASE command omitted processing the indicated datafile because it is part of a read-only tablespace at the desired point in time. This is an informational message.

Action: No action required.

RMAN-06180 incremental backups require Enterprise Edition

Cause: A BACKUP command with INCREMENTAL LEVEL > 0 was specified.

Action: Use FULL or INCREMENTAL LEVEL=0.

RMAN-06181 multiple channels require Enterprise Edition

Cause: Attempt to allocate more than one channel in a job.

Action: Remove all except one ALLOCATE CHANNEL command.

RMAN-06182 archivelog larger than SETSIZE: thread string seq string string

Cause: A BACKUP ARCHIVELOG command specified the SETSIZE operand too low. The specified archive log is larger than SETSIZE will allow.

Action: Increase the SETSIZE limit.

RMAN-06183 datafile or datafilecopy larger than SETSIZE: file# string string

Cause: A BACKUP DATAFILE(copy) command specified the SETSIZE operand too low. The specified datafile is larger than SETSIZE will allow.

Action: Increase the SETSIZE limit.

RMAN-06184 duplicate object in backup specifier: string string

Cause: A backup command specifies the same datafile or copy of a datafile multiple times.

Action: Eliminate the duplicates.

RMAN-06185 Recovery Manager incompatible with string database: RMAN number.number.number to number.number.number required

Cause: This version of Recovery Manager is incompatible with the indicated database or the DBMS_BACKUP_RESTORE package installed in the indicated database.

Action: If the database has been upgraded from an earlier version, ensure that the CATXXXX.SQL script has been run successfully. Re-install DBMSBKRS.SQL and PRVTBKRS.PLB if necessary. Otherwise, use a version of RMAN within the range specified in the error message.

RMAN-06186 PL/SQL package string.string version string in string database is too old

Cause: The specified PL/SQL package is a version that is too old to work with this version of the Recovery Manager (RMAN).

Action: If the database indicated is RCVCAT, then you can use the UPGRADE CATALOG command to upgrade the recovery catalog to the most current version. If the database is TARGET or AUXILIARY, then you must either upgrade the specified database or use an older version of RMAN.

RMAN-06187 controlfile copy string not found or out of sync with catalog

Cause: The indicated file is not found, or is found but is not the same file that the recovery catalog thinks it is. It is likely that some operation outside of Recovery Manager has altered the file, or that Recovery Manager has not resynchronized with the target database.

Action: Re-catalog the file and retry the operation.

RMAN-06188 cannot use command when connected to a mounted target database

Cause: An attempt was made to issue a command that can be used only when there is no connection to the target database or when the target database is not mounted.

Action: Dismount the database or restart RMAN and use the command before connecting to the target database.

RMAN-06189 current DBID number does not match target mounted database (number)

Cause: SET DBID was used to set a DBID that does not match the DBID of the database to which RMAN is connected.

Action: If the current operation is a restore to copy the database, do not mount the database. Otherwise, avoid using the SET DBID command, or restart RMAN.

RMAN-06190 PL/SQL package string.string version string in string database is not current

Cause: RMAN detected an old version of the specified package. RMAN will execute in backwards-compatible mode.

Action: No action is required, but certain features and bug fixes may not be available when RMAN runs in backwards-compatible mode. If the database is RCVCAT, then you can use the UPGRADE CATALOG command to upgrade the recovery catalog to the most current version. If the database is TARGET or AUXILIARY, then you must either upgrade the specified database or use an older version of RMAN. The files that must be run to upgrade the target or auxiliary database are DBMSRMAN.SQL and PRVTRMAN.PLB.

RMAN-06191 PL/SQL package string.string version string in string database is too new

Cause: RMAN detected an incompatible version of the specified package.

Action: Use a newer version of Recovery Manager. Message 6439 indicates the minimum required version of Recovery Manager.

RMAN-06192 maximum value for piecesize or setsize must be between 1 Kb and 2048 Gb

Cause: Input size for maxpiecesize or maxsetsize was out of range.

Action: Specify a valid size and retry the command.

RMAN-06193 connected to target database (not started)

Cause: The database must be started before any other RMAN commands are issued. This is an informational message.

Action: No action required.

RMAN-06194 target database instance not started

Cause: A command was issued that requires the target database instance be started.

Action: Issue a STARTUP command to start the instance.

RMAN-06195 auxiliary database not started

Cause: A command was issued that requires the auxiliary database instance be started.

Action: Issue a STARTUP AUXILIARY command.

RMAN-06196 Oracle instance started

Cause: A STARTUP command completed successfully. This is an informational message.

Action: No action required.

RMAN-06200 List of Archived Log Copies

Cause: See RMAN-06203.

Action: No action required.

RMAN-06201 Key Thrd Seq S Completion time Name

Cause: See RMAN-06203.

Action: No action required.

RMAN-06202 ------- ---- ------- - --------------- ------------------------------------

Cause: See RMAN-06203.

Action: No action required.

RMAN-06203 string string string string string string

Cause: This message is issued in response to a LIST COPY OF ARCHIVELOG command. If a recovery catalog is in use, then the information comes from the recovery catalog, otherwise it comes from the target database control file. The following fields are shown for each archived log:

  • Key: This is the unique key which identifies this archived log in the recovery catalog. This value can be used in a CHANGE command to change the status of the log. If the target database control file is being used as the recovery catalog, then this field is zero.
  • Thrd: This is the thread number of the log.
  • Seq: This is the sequence number, within the thread, of the log.
  • S: This is the status of the file. Possible values are:
    • A - Available,
    • U - Unavailable
    • D - Deleted Status.

    'U' will not be used if the target database control file is being used as the recovery catalog.

  • Completion time: This is the date and time when the log was archived or copied. This column will be printed in the default Oracle date format, unless overridden with a NLS_DATE_FORMAT environment variable.
  • Name: This is the file name of the log.

Action: No action required.

RMAN-06210 List of Datafile Copies

Cause: See RMAN-06213.

Action: No action required.

RMAN-06211 Key File S Completion time Ckp SCN Ckp time Name

Cause: See RMAN-06213.

Action: No action required.

RMAN-06212 ------- ---- - --------------- ---------- --------------- ------

Cause: See RMAN-06213.

Action: No action required.

RMAN-06213 string string string string string string string

Cause: This message is issued in response to a LIST COPY OF DATABASE/TABLESPACE/DATAFILE command. If a recovery catalog is in use, then the information comes from the recovery catalog, otherwise it comes from the target database control file. The following fields are shown for each datafile copy:

  • Key: This is the unique key which identifies this datafile copy in the recovery catalog. This value can be used in a CHANGE command to change the status of the copy. If the target database control file is being used as the recovery catalog, then this field uniquely identifies this copy in the control file.
  • File: The file number that this file was copied from. S: This is the status of the file. Possible values are:
    • A - Available
    • U - Unavailable
    • D - Deleted Status

    'U' will not be used if the target database control file is being used as the recovery catalog.

  • Completion time: This is the date and time when the datafile copy was created. This column will be printed in the default Oracle date format, unless overridden with a NLS_DATE_FORMAT environment variable.
  • Ckp SCN: This is the checkpoint SCN of the datafile copy. The file contains all changes made at or before this SCN.
  • Ckp time: This is the time that the file was last checkpointed.
  • Name: This is the file name of the datafile copy.

Action: No action required.

RMAN-06220 List of Archived Logs Included

Cause: See RMAN-06223.

Action: No action required.

RMAN-06221 Thrd Seq Low SCN Next SCN Low Time Next Time

Cause: See RMAN-06223.

Action: No action required.

RMAN-06222 ---- ------- ---------- ---------- --------------- ---------------

Cause: See RMAN-06223.

Action: No action required.

RMAN-06223 string string string string string string

Cause: This message is issued in response to a LIST BACKUP OF ARCHIVELOG command. If a recovery catalog is in use, then the information comes from the recovery catalog, otherwise it comes from the target database control file. To be included in the report, at least one complete copy of the backup set must exist. If the DEVICE TYPE option is specified on the report command, then the list includes only those backup sets which reside on the specified devices, otherwise all available backup sets are listed. The following fields are shown for each archive log which is included in a backup set:

  • Key: This is the unique key which identifies this backup set in the recovery catalog. If the target database control file is being used as the recovery catalog, then this field is a unique identifier which identifies this backup set in the target database control file.
  • Thrd: This is the thread number of the log.
  • Seq: This is the sequence number, within the thread, of the log.
  • Completion time: This is the date and time when the backup set was created. This column will be printed in the default Oracle date format, unless overridden with a NLS_DATE_FORMAT environment variable.

Action: No action required.

RMAN-06230 List of Backup Sets

Cause: See RMAN-06233.

Action: No action required.

RMAN-06231 Key Recid Stamp LV Set Stamp Set Count Completion Time

Cause: See RMAN-06233.

Action: No action required.

RMAN-06232 ------- ---------- ---------- -- ---------- ---------- ----------------------

Cause: See RMAN-06233.

Action: No action required.

RMAN-06233 string string string string string string string

Cause: This message is issued in response to a LIST BACKUP OF DATABASE/TABLESPACE/DATAFILE command. If a recovery catalog is in use, then the information comes from the recovery catalog, otherwise it comes from the target database control file. To be included in the report, at least one complete copy of the backup set must exist. If the DEVICE TYPE option is specified on the report command, then the list includes only those backup sets which reside on the specified devices, otherwise all available backup sets are listed. The following fields are shown for each datafile which is included in a backup set:

  • Key: This is the unique key which identifies this backup set in the recovery catalog. If the target database control file is being used as the recovery catalog, then this field is a unique identifier which identifies this backup set in the target database control file.
  • File: The file number of the file that was backed up.
  • Type: The type of backup. Possible values are:
    • Full: full (or an incremental level 0) backup.
    • Incremental: incremental backup
    • Cumulative: cumulative incremental backup
  • LV: This is the incremental backup level.
  • Completion time: This is the date and time when the backup set was created. This column will be printed in the default Oracle date format, unless overridden with a NLS_DATE_FORMAT environment variable.

Action: No action required.

RMAN-06234 List of Backup Pieces

RMAN-06235 Key Pc# Cp# Status Completion Time Piece Name

RMAN-06236 ------- --- --- ----------- ---------------------- ------------------------

RMAN-06237 string string string string string string

RMAN-06238 List of Datafiles Included

RMAN-06239 File Name LV Type Ckp SCN Ckp Time

RMAN-06240 ---- ------------------------------------- -- ---- ---------- -------------

RMAN-06241 string string string string string string

RMAN-06242 Controlfile Included

RMAN-06243 Ckp SCN Ckp time

RMAN-06244 ---------- ---------------

RMAN-06245 string string

RMAN-06246 List of Database Incarnations

Cause: See RMAN-06249.

Action: No action required.

RMAN-06247 DB Key Inc Key DB Name DB ID CUR Reset SCN Reset Time

Cause: See RMAN-06249.

Action: No action required.

RMAN-06248 ------- ------- -------- ---------------- --- ---------- ----------

Cause: See RMAN-06249.

Action: No action required.

RMAN-06249 string string string string string string string

Cause: This message is issued in response to a LIST INCARNATION OF DATABASE command. The following fields are shown for each database that is registered with the recovery catalog:

  • DB Key: This is the unique key which identifies this database in the recovery catalog.
  • Inc Key: This is the unique key which identifies this incarnation of the database in the recovery catalog.
  • DB Name: The name of the database.
  • DB ID: The database ID. This is a number which remains the same for the life of the database, even if the database name is changed.
  • CUR: 'YES' if this is the current incarnation of this database, otherwise 'NO'.
  • Reset SCN: SCN of the most recent resetlogs operation.
  • Reset Time: Time of the most recent resetlogs operation.

Action: No action required.

RMAN-06250 Report of files that need backup due to unrecoverable operations

Cause: See RMAN-06253.

Action: See RMAN-06253.

RMAN-06251 File Type of Backup Required Name

Cause: See RMAN-06253.

Action: See RMAN-06253.

RMAN-06252 ---- ----------------------- -----------------------------------

Cause: See RMAN-06253.

Action: See RMAN-06253.

RMAN-06253 string string string

Cause: An unlogged change (such as 'create table unrecoverable') has been made to this file, and the most recent backup of the file does not contain those changes.

Action: Take a backup of this file. If this file is lost before a backup is taken, then the unlogged modifications will be lost. The message indicates whether a full backup is required or whether a incremental backup will suffice.

RMAN-06260 Report of files that need more than number incrementals during recovery

Cause: See RMAN-06263.

Action: See RMAN-06263.

RMAN-06261 File Incrementals Name

Cause: See RMAN-06263.

Action: See RMAN-06263.

RMAN-06262 ---- ------------ ----------------------------------------------

Cause: See RMAN-06263.

Action: See RMAN-06263.

RMAN-06263 string string string

Cause: This message is issued in response to the REPORT NEED BACKUP INCREMENTAL command, for those files which would use more than the specified number of incremental backups during recovery.

Action: To reduce the number of incremental backups which would be used during recovery of this datafile, take a new full backup of this file now.

RMAN-06270 Report of files whose recovery needs more than number days of archived logs

Cause: See RMAN-06273.

Action: See RMAN-06273.

RMAN-06271 File Days Name

Cause: See RMAN-06273.

Action: See RMAN-06273.

RMAN-06272 ---- ----- -----------------------------------------------------

Cause: See RMAN-06273.

Action: See RMAN-06273.

RMAN-06273 string string string

Cause: This message is issued in response to the REPORT NEED BACKUP DAYS command for those files which need more than the specified number of days' archived logs for recovery.

Action: To reduce the number of log files needed for recovery of this datafile, take a new full or incremental backup now.

RMAN-06280 Report of obsolete backups and copies

Cause: See RMAN-06285.

Action: See RMAN-06285.

RMAN-06281 Type Key Completion Time Filename/Handle

Cause: See RMAN-06285.

Action: See RMAN-06285.

RMAN-06282 -------------------- ------ ------------------ --------------------

Cause: See RMAN-06285.

Action: See RMAN-06285.

RMAN-06283 Datafile Copy string string string

Cause: See RMAN-06285.

Action: See RMAN-06285.

RMAN-06284 Backup Set string string

Cause: See RMAN-06285.

Action: See RMAN-06285.

RMAN-06285 Backup Piece string string string

Cause: This message is issued in response to the REPORT OBSOLETE command. Each of the files listed is obsolete because it is more redundant than the level of redundancy specified in the REPORT command.

Action: No action required.

RMAN-06290 Report of database schema

Cause: See RMAN-06293.

Action: See RMAN-06293.

RMAN-06291 File K-bytes Tablespace RB segs Name

Cause: See RMAN-06293.

Action: See RMAN-06293.

RMAN-06292 ---- ---------- -------------------- ------- -------------------

Cause: See RMAN-06293.

Action: See RMAN-06293.

RMAN-06293 string string string string string

Cause: This message is issued in response to the REPORT SCHEMA command. The report shows the physical schema of the database at the indicated time. The following fields are shown for each datafile:

  • File: The file number.
  • K-bytes: The size of the file.
  • Tablespace: The name of the tablespace which contains this file.
  • RB segs: YES if this file is part of a tablespace containing rollback segments, otherwise NO.
  • Name: The file name.

Action: No action required.

RMAN-06300 Report of files with less than number redundant backups

Cause: See RMAN-06303.

Action: See RMAN-06303.

RMAN-06301 File #bkps Name

Cause: See RMAN-06303.

Action: See RMAN-06303.

RMAN-06302 ---- ----- -----------------------------------------------------

Cause: See RMAN-06303.

Action: See RMAN-06303.

RMAN-06303 string string string

Cause: This message is issued when the REPORT NEED BACKUP REDUNDANCY command is used for those files which have less than the specified number of backups which can be used for recovery.

Action: Take another backup of the datafiles listed.

RMAN-06310 List of Proxy Copies

Cause: See RMAN-06313.

Action: See RMAN-06313.

RMAN-06311 Key File S Completion time Ckp SCN Ckp time Handle

Cause: See RMAN-06313.

Action: See RMAN-06313.

RMAN-06312 ------- ---- - --------------- ---------- --------------- ------

Cause: See RMAN-06313.

Action: See RMAN-06313.

RMAN-06313 string string string string string string string

Cause: This message is issued in response to a LIST BACKUP DATABASE/TABLESPACE/DATAFILE command when some backups were taken with the PROXY option. If a recovery catalog is in use, then the information comes from the recovery catalog, otherwise it comes from the target database control file. The following fields are shown for each proxy datafile backup.

  • Key: This is the unique key which identifies this proxy backup in the recovery catalog. This value can be used in a CHANGE command to change its status. If the target database control file is being used as the recovery catalog, then this field uniquely identifies this copy in the control file.
  • File: The file number that this file was copied from.
  • S: This is the status of the file. Possible values are:
    • A - Available
    • U - Unavailable
    • D - Deleted
    • X - Expired

    Status 'U' will not be used if the target database control file is being used as the recovery catalog.

  • Completion time: This is the date and time when the backup was created. This column will be printed in the default Oracle date format, unless overridden with a NLS_DATE_FORMAT environment variable.
  • Ckp SCN: This is the checkpoint SCN of the backup. The file contains all changes made at or before this SCN.
  • Ckp time: This is the time that the file was last checkpointed.
  • Handle: This is the media manager handle of the proxy backup.

Action: No action required.

RMAN-06400 database opened

Cause: This is an informational message.

Action: No action required.

RMAN-06401 database is already started

Cause: A STARTUP command without the FORCE option was issued, but the target database is already started.

Action: Use the FORCE option if you want to restart the database.

RMAN-06402 Oracle instance shut down

Cause: This is an informational message.

Action: No action required.

RMAN-06403 could not obtain a fully authorized session

Cause: The most likely cause of this error is that one of the databases to which RMAN had previously connected is not started or has been shut down. Other error messages should identify exactly which database is the problem.

Action: Start the database that is causing the problem.

RMAN-06404 database dismounted

Cause: This is an informational message.

Action: No action required.

RMAN-06405 database closed

Cause: This is an informational message.

Action: No action required.

RMAN-06406 deleted archivelog

Cause: This is an informational message.

Action: No action required.

RMAN-06408 recovery catalog upgraded to version string

Cause: This is an informational message issued by the UPGRADE CATALOG command. It indicates the version of the recovery catalog schema to which the recovery catalog was just upgraded. Note that this version number may not reflect the version number of your RMAN executable or target database, because the recovery catalog schema is not changed with each Oracle release.

Action: No action required.

RMAN-06409 LIKE clause in LIST BACKUP OF ARCHIVELOG is not supported

Cause: LIST BACKUP OF ARCHIVELOG LIKE was used, which is not supported.

Action: Remove LIKE clause from command.

RMAN-06410 cannot use command when channels are allocated

Cause: An attempt was made to issue a command that can be used only when there are no allocated channels.

Action: Do not use the command, or de-allocate channels and use the command when no channels are allocated.

RMAN-06411 duplex setting out of range (1-4): number

Cause: An attempt was made to set duplexing to an invalid value.

Action: Use a value in the specified range.

RMAN-06412 no proxy copy channel found

Cause: A proxy copy was started, but no allocated channel supports proxy copy. This could be because the media management software used by the target database does not support proxy copy, or because all of the allocated channels are of type DISK, which never support proxy copy.

Action: If this is a backup, then either allocate a non-disk channel, or do not use the PROXY option. If this is a restore, then a channel of the same type which created the proxy backup was allocated, but now does not support proxy copy. If proxy copy is no longer supported by the media management software at the target database, the CROSSCHECK or CHANGE commands should be used so that those backups will not be considered for further restores.

RMAN-06413 channel string does not support proxy copy

Cause: The channel which was specified for this backup or restore does not support proxy copy. This could be because the media management software used by the target database does not support proxy copy, or because the channel is of type DISK, which never supports proxy copy.

Action: If this is a backup, then either allocate a non-disk channel, or do not use the PROXY option. If this is a restore, then a channel of the same type which created the proxy backup was allocated, but now does not support proxy copy. If proxy copy is no longer supported by the media management software at the target database, the CROSSCHECK command should be used so that those backups will not be considered for further restores.

RMAN-06414 target database COMPATIBLE option does not support proxy copy

Cause: PROXY was specified, and the target database uses a media manager that supports proxy copy, but the COMPATIBLE initialization parameter of the target database must be 8.1.0 or greater to create proxy backups. If the database is downgraded to the earlier release that is specified in the COMPATIBLE parameter, then it will no longer be able to restore proxy backups.

Action: Either take a non-proxy backup or change the target database COMPATIBLE parameter.

RMAN-06415 file string cannot be proxy backed up

Cause: The PROXY option was specified, but the media management software used by the target database cannot back up the specified file using proxy copy. If PROXY ONLY was specified, then the backup is terminated. If PROXY was specified, then this file will be placed into a non-proxy backup set.

Action: Remove the ONLY option to place the files into a regular backup set, or contact the media management vendor if you believe that the media management software should support proxy copy of this file.

RMAN-06416 PROXY ONLY was specified and some files could not be proxy copied

Cause: PROXY ONLY was specified, and some of the files to be backed up could not be backed up by the media management software used by the target database. Message 6415 is issued for each file that cannot be proxy copied.

Action: Remove the ONLY option to place the files into a regular backup set, or contact the media management vendor if you believe that the media management software should support proxy copy of these files.

RMAN-06417 proxy backup of archive logs not supported

Cause: The BACKUP PROXY ARCHIVELOG command was entered. Proxy backup of archive logs is not yet supported.

Action: Enter a different command.

RMAN-06418 proxy incremental backups with level > 0 not supported

Cause: PROXY was specified for a non-level-zero incremental backup. Proxy backups may only be full or level 0 backups.

Action: Remove one of the conflicting options.

RMAN-06419 file string cannot be proxy restored from handle string

Cause: The media management software used by the target database indicated that it cannot restore the specified file from the specified backup handle.

Action: Consult the media management software documentation to find out why this restriction exists or contact the media management vendor.

RMAN-06420 some files could not be proxy restored - aborting restore

Cause: Some of the files to be restored could not be restored by the media management software used by the target database. Message 6419 is issued for each file that cannot be restored.

Action: Contact the media management vendor if you believe that the media management software should support proxy copy of these files. The CROSSCHECK or CHANGE commands can be used to remove these proxy copies from the catalog to prevent the RESTORE command from trying to restore from these proxy backups.

RMAN-06421 sent command to channel: string

Cause: This is an informational message.

Action: No action required.

RMAN-06422 no channels found for SEND command

Cause: No channels with the specified names or device types were found. If no channel qualifiers were specified, then no channels were allocated.

Action: Specify a different channel type or allocate a channel of the desired type.

RMAN-06423 requested limit of number exceeds vendor limit of number

Cause: A SETLIMIT CHANNEL command was used to set the backup piece size limit, but the media management software used by the target database cannot create backup pieces that large.

Action: Specify a smaller backup piece limit.

RMAN-06424 error while looking up proxy copy

Cause: An error occurred while looking up the specified proxy copy in the recovery catalog or target database control file.

Action: This error is accompanied by other errors describing the reason for the failure. Ensure that the name or key is entered correctly. If the proxy copy was created when the recovery catalog was not available, then a RESYNC CATALOG must be done to update the recovery catalog.

RMAN-06425 datafile_pathname_not_available

Cause: This is an informational message.

Action: No action required.

RMAN-06426 RECOVERY_CATALOG_OWNER role must be granted to user string

Cause: The CREATE CATALOG or UPGRADE CATALOG command was used, but the userid that was supplied in the RCVCAT connect string does not have the RECOVERY_CATALOG_OWNER role granted as a DEFAULT role.

Action: Grant the RECOVERY_CATALOG_OWNER role to the recovery catalog owner.

RMAN-06427 recovery catalog already exists

Cause: The CREATE CATALOG command cannot be used when the recovery catalog already exists.

Action: Use the UPGRADE CATALOG command to upgrade your recovery catalog to the most current release without losing any existing backup data. Use the DROP CATALOG command to remove an existing recovery catalog.

RMAN-06428 recovery catalog is not installed

Cause: A recovery catalog database connection has been made, but the recovery catalog tables and views have not been installed.

Action: If you incorrectly typed the recovery catalog owner USERID, then correct the userid and reconnect to the recovery catalog. If this is the first time that you have signed on to Recovery Manager with this recovery catalog owner userid, then use the CREATE CATALOG command to create the recovery catalog schema.

RMAN-06429 string database is not compatible with this version of RMAN

Cause: The indicated database is not compatible with this version of the Recovery Manager (RMAN). Other messages have also been issued which detail the cause of the error.

Action: See the other messages. If the database is RCVCAT, then you may be able to use the CREATE CATALOG or UPGRADE CATALOG commands to correct the problem. If the database is TARGET or AUXILIARY, then you must either upgrade the target database or use a newer version of the RMAN executable.

RMAN-06430 recovery catalog userid cannot be SYS

Cause: A recovery catalog connection was made to userid SYS. The recovery catalog must be created in a userid other than SYS.

Action: Specify a different userid in the RCVCAT connect string.

RMAN-06431 recovery catalog created

Cause: This is an informational message issued by the CREATE CATALOG command.

Action: No action required.

RMAN-06432 recovery catalog dropped

Cause: This is an informational message issued by the DROP CATALOG command.

Action: No action required.

RMAN-06433 error installing recovery catalog

Cause: An error was received from the recovery catalog database while it was being installed. Another error message shows the error message from the server.

Action: The most common reasons for failure to install the recovery catalog are:

  • Lack of space in the recovery catalog database: allocate more space, use the DROP CATALOG command to remove any partially installed recovery catalog, and retry the command.
  • Object already exists: This is caused by a partial recovery catalog installation. Use the DROP CATALOG command to remove the partially installed recovery catalog and retry the command.

RMAN-06434 some errors occurred while removing recovery catalog

Cause: Some errors were received from the recovery catalog database while removing the recovery catalog.

Action: Correct the error(s) and retry the command. Note that the Recovery Manager intercepts and ignores common errors, such as 'object not found', which can happen while removing a partially installed recovery catalog. Only serious errors will be displayed while removing the recovery catalog.

RMAN-06435 recovery catalog owner is string

Cause: This is an informational message issued by the UPGRADE CATALOG and DROP CATALOG commands.

Action: No action required.

RMAN-06436 enter DROP CATALOG command again to confirm catalog removal

Cause: The DROP CATALOG command deletes the recovery catalog, rendering all database backups unusable, and should be used with care. The command must be entered twice to ensure that this is really what you want to do.

Action: If you really want to remove the recovery catalog, then enter the DROP CATALOG command again.

RMAN-06437 cannot drop catalog - catalog is newer than this RMAN

Cause: The DROP CATALOG command was entered, but the recovery catalog was created by a newer version of the Recovery Manager (RMAN). This version of RMAN may not be able to drop the entire recovery catalog.

Action: Use the version of RMAN which most recently created or upgraded the recovery catalog.

RMAN-06438 error executing package DBMS_RCVMAN in string database

Cause: Recovery Manager requires the DBMS_RCVMAN package in the SYS schema of the indicated database. Normally this package is installed during database creation.

Action: To re-create the package, run the files DBMSRMAN.SQL and PRVTRMNS.PLB.

RMAN-06439 RMAN must be upgraded to version string to work with this package

Cause: This message indicates the minimum version of Recovery Manager required to use the package which was specified in message 6191.

Action: A newer version of RMAN must be used with this package.

RMAN-06441 cannot upgrade catalog - catalog is already newer than this RMAN

Cause: The recovery catalog is already at a version level that is greater than this version of the Recovery Manager. The UPGRADE CATALOG command is not needed.

Action: Either upgrade to a more recent Recovery Manager, or continue to use the current version. Message 6191 will be issued if the recovery catalog is too new to work with this version of Recovery Manager.

RMAN-06442 enter UPGRADE CATALOG command again to confirm catalog upgrade

Cause: The UPGRADE CATALOG command alters the recovery catalog schema. Although the recovery catalog is designed to be compatible with older versions of the Recovery Manager (RMAN), it is possible that an upgrade will remove support for older versions of RMAN.

Action: If you really want to upgrade the recovery catalog, then enter the UPGRADE CATALOG command again. If you are not going to use an older version of RMAN with this recovery catalog, then compatibility is not an issue. If you plan to also continue using an older version of RMAN with this recovery catalog then, before upgrading, consult Oracle9i Database Migration or the migration guide for the current Oracle release to determine if upgrading to the current version of the recovery catalog will remove support for older versions of RMAN.

RMAN-06443 error upgrading recovery catalog

Cause: An error was received from the recovery catalog database while upgrading the recovery catalog.

Action: Correct the error and retry the command. Note that the Recovery Manager intercepts and ignores common errors, such as 'column already exists,' which can happen if the recovery catalog has already been partially upgraded. Only serious errors will be displayed while upgrading the recovery catalog.

RMAN-06444 string created with compilation errors

Cause: During the CREATE CATALOG or UPGRADE CATALOG command, the indicated PL/SQL package specification or body could not be created because of PL/SQL compilation errors.

Action: The PL/SQL packages used by the recovery catalog are located in the RECOVER.BSQ library file, and should never be modified. Make sure that the RECOVER.BSQ file has not been modified or damaged, and then if this error persists, contact Oracle Support Services. Connect to the recovery catalog owner and query the USER_ERRORS view to find out the details of the compilation errors.

RMAN-06445 cannot connect to recovery catalog after NOCATALOG has been used

Cause: The CONNECT CATALOG command was used after the user had already specified the NOCATALOG option.

Action: Re-start RMAN if you wish to use a recovery catalog.

RMAN-06446 changed proxy copy unavailable

Cause: This is an informational message.

Action: No action required.

RMAN-06447 changed proxy copy available

Cause: This is an informational message.

Action: No action required.

RMAN-06448 uncataloged proxy copy

Cause: This is an informational message.

Action: No action required.

RMAN-06449 deleted proxy copy

Cause: This is an informational message.

Action: No action required.

RMAN-06450 crosschecked proxy copy: found to be 'string'

Cause: This is an informational message.

Action: No action required.

RMAN-06451 proxy copy handle=string recid=string stamp=string

Cause: This is an informational message.

Action: No action required.

RMAN-06452 string package upgraded to version string

Cause: This is an informational message issued by the UPGRADE CATALOG command. It indicates the version to which the indicated package was just upgraded. Note that this version number may not reflect the version number of your RMAN executable or target database, because the recovery catalog packages are not changed with each Oracle release.

Action: No action required.

RMAN-06453 RECOVERABLE may only be used with datafile objects

Cause: An attempt was made to use LIST ... RECOVERABLE ... with OF CONTROLFILE or OF ARCHIVELOG.

Action: Remove the RECOVERABLE keyword and try again.

RMAN-06454 duplexed backups requires Enterprise Edition

Cause: The SET DUPLEX command was specified.

Action: Remove the SET DUPLEX command.

RMAN-06455 point-in-time tablespace recovery requires Enterprise Edition

Cause: A point-in-time tablespace recovery was attempted, but Enterprise Edition is not installed.

Action: Do not do point-in-time tablespace recovery.

RMAN-06456 command is obsolete

Cause: This is an informational message only.

Action: No action required.

RMAN-06457 UNTIL scn (string) is ahead of last scn in archived logs (string)

Cause: UNTIL scn cannot be more than the last scn of the last archived log.

Action: Check the UNTIL scn.

RMAN-06459 BACKUP VALIDATE is not supported with PROXY

Cause: BACKUP VALIDATE and PROXY were specified in the same backup command.

Action: Remove the incompatible option.

RMAN-06462 no backupsets found on device DISK that match specification

Cause: A backupset record specifier did not match a backupset on device DISK in the recovery catalog.

Action: Resubmit the command with a different backupset record specifier. The rman LIST command can be used to display all backupsets that Recovery Manager knows about.

RMAN-06463 BACKUP BACKUPSET is not supported with PROXY option

Cause: BACKUP BACKUPSET and PROXY were specified in the same backup command.

Action: Resolve the conflict.

RMAN-06464 BACKUP BACKUPSET is not supported with VALIDATE option

Cause: BACKUP BACKUPSET and VALIDATE were specified in the same backup command.

Action: To VALIDATE BACKUPSET use 'validate' or 'restore validate' command.

RMAN-06465 configuration not implemented: string

Cause: The configuration is not implemented in the current release.

Action: Avoid using the command.

RMAN-06466 error parsing configuration string (string)

Cause: Unsupported configuration string is stored in recovery catalog or target database controlfile.

Action: Check compatibility matrix rman executable and target database and recover catalog. Use dbms_backup_restore.deleteConfig to remove problematic configuration.

RMAN-06467 could not translate DBA: number

Cause: An error was received when calling dbms_rcvman.

Action: This message should be accompanied by other error messages indicating the cause of the error.

RMAN-06468 Invalid Data Block Address: number

Cause: The DBA specified doesn't belong to the mentioned tablespace.

Action: Check the DBA.

RMAN-06469 could not translate corruption list

Cause: An error was received when calling dbms_rcvman.

Action: This message should be accompanied by other error messages indicating the cause of the error.

RMAN-06470 DEVICE TYPE is supported only when automatic channels are used

Cause: The DEVICE TYPE option was specified with a BACKUP, RESTORE, RECOVER, DUPLICATE, CHANGE, VALIDATE, CROSSCHECK, or DELETE EXPIRED command. This option is allowed only when automatically allocated channels are used.

Action: Remove the DEVICE TYPE option and re-run the command, or Remove all ALLOCATE commands and re-run the script so that channels are automatically allocated.

RMAN-06471 no configuration found to allocate channels for string

Cause: Device type configuration was not found in recovery catalog.

Action: Set up device type configuration using configure command for required device type.

RMAN-06472 channel id string is automatically allocated

Cause: Channel ID was used on ALLOCATE/RELEASE command.

Action: Use other channel id that does not belong to reserved channel ID's namespace.

RMAN-06474 maintenance channels are not allocated

Cause: RELEASE CHANNEL was used without allocating any maintenance channels.

Action: Allocate maintenance channel before executing this command.

RMAN-06475 parallelism setting out of range (1-254): number

Cause: Parallelism for the device type in CONFIGURE PARALLELISM command is out of range.

Action: Enter value of parallelism that is within the allowed range.

RMAN-06476 channel number out of range (1-254): number

Cause: Channel number entered in CONFIGURE CHANNEL command is out of range.

Action: Enter channel number within allowed range for this device and retry the command.

RMAN-06477 configuration value length exceeds 1024

Cause: CONFIGURE CHANNEL command entered has configuration value greater than 1024 bytes.

Action: Reduce the length of CONFIGURE CHANNEL command options.

RMAN-06478 datafile copy 'string' cannot be found on disk

Cause: The CHANGE DATAFILECOPY AVAILABLE command was used, but the datafilecopy cannot be found on disk.

Action: If the storage containing the datafilecopy has been removed from the host, then restore it and retry the command. If the datafilecopy is permanently gone, then issue the CHANGE DATAFILECOPY DELETE command for this datafile.

RMAN-06479 control file copy 'string' cannot be found on disk

Cause: The CHANGE CONTROLFILECOPY AVAILABLE command was used, but the control file copy cannot be found on disk.

Action: If the storage containing the control file copy has been removed from the host, then restore it and retry the command. If the control file copy is permanently gone, then issue the CHANGE CONTROLFILECOPY DELETE command for this control file.

RMAN-06480 archivelog 'string' cannot be found on disk

Cause: The CHANGE ARCHIVELOG AVAILABLE command was used, but the archivelog cannot be found on disk.

Action: If the storage containing the archivelog has been removed from the host, then restore it and retry the command. If the archivelog is permanently gone, then issue the CHANGE ARCHIVELOG DELETE command for this archivelog.

RMAN-06481 backup piece 'string' cannot be found on the storage medium

Cause: The CHANGE BACUKPPIECE AVAILABLE command was used, but the backup piece cannot be found on the storage medium.

Action: If the storage containing the backup piece has been removed from the host, then restore it and retry the command. If the backup piece is permanently gone, then issue the CHANGE BACKUPPIECE DELETE command for this backup piece.

RMAN-06482 proxy copy 'string' cannot be found on the storage medium

Cause: The CHANGE PROXY AVAILABLE command was used, but the proxy copy cannot be found on disk.

Action: If the storage containing the proxy copy has been removed from the host, then restore it and retry the command. If the proxy copy is permanently gone, then issue the CHANGE PROXY DELETE command for this proxy copy.

RMAN-06483 changed datafile copy expired

Cause: This is an informational message.

Action: No Action Required.

RMAN-06484 changed controlfile copy expired

Cause: This is an informational message.

Action: No Action Required.

RMAN-06485 changed archivelog expired

Cause: This is an informational message.

Action: No Action Required.

RMAN-06486 changed backup piece expired

Cause: This is an informational message.

Action: No Action Required.

RMAN-06487 changed proxy copy expired

Cause: This is an informational message.

Action: No Action Required.

RMAN-06488 restore from autobackup does not allow any other modifiers

Cause: A controlfile or SPFILE restore from autobackup was attempted and other restore options were used.

Action: Do not specify any other options for the controlfile autobackup restore.

RMAN-06489 no configuration found to allocate clone channel number for device type string

Cause: Target channel configuration could not be used for clone channel as it contains CONNECT option.

Action: Setup clone channel configuration using CONFIGURE CLONE command for required channel number and device type.

RMAN-06490 WARNING: limit of autobackups for the day has been reached

Cause: No more controlfile autobackups are possible during this day.

Action: This is a warning message. No action is required.

RMAN-06491 controlfile autobackup format "string" contains more than one "string" format specifier

Cause: A controlfile autobackup format cannot have more than one reserved format specifier.

Action: Specify only one reserved format specifier or use an alternative format.

RMAN-06492 controlfile autobackup format "string" must specify a "string" format specifier

Cause: A reserved format specifier was not specified for the controlfile autobackup format.

Action: Add a specifier to the controlfile autobackup format.

RMAN-06493 only UNTIL TIME clause is allowed when performing a restore from autobackup, found: string

Cause: For restoring a controlfile autobackup only SET UNTIL TIME can be used. It is not possible to translate the others to a precise day.

Action: Specify SET UNTIL TIME to indicate the day to start the restore of a controlfile autobackup.

RMAN-06494 string = string is out of range (string-string)

Cause: The specified parameter for restoring a controlfile autobackup is out of the valid range.

Action: Change the parameter value to a valid number or do not specify it.

RMAN-06495 must explicitly specify DBID with SET DBID command

Cause: Restore of a controlfile autobackup was attempted when the database is not mounted.

Action: Specify the DBID of the database using SET DBID or mount the database.

RMAN-06496 must use the TO clause when the database is mounted or open

Cause: A controlfile restore was attempted when the database is mounted or open and no alternate destination was specified.

Action: Specify an alternate destination with the TO clause or dismount the database.

RMAN-06497 WARNING: controlfile is not current, controlfile autobackup skipped

Cause: Controlfile autobackup is not possible without a current controlfile.

Action: This is a warning message. No action is required.

RMAN-06498 skipping datafile string; already backed up string time(s)

Cause: The indicated datafile will not be included in the backup set. It is already backed up on the device requested and file is offline/read-only datafile. Use the FORCE option to override backup optimization.

Action: No action required.

RMAN-06499 skipping archive log file string; already backed up string time(s)

Cause: The indicated log file will not be included in the backup set because it is already backed up on the device requested. Use FORCE option to override backup optimization.

Action: No action required.

RMAN-06500 skipping backupset key string; already backed up string time(s)

Cause: The indicated backupset will not be copied because it is already backed up on the device requested. Use FORCE option to override backup optimization.

Action: No action required.

RMAN-06501 skipping datafile string; already backed up on string

Cause: The indicated datafile will not be included in the backup set. It is already been backed up once, or before the since time specified.

Action: No action required.

RMAN-06502 skipping archive log file string; already backed on string

Cause: The indicated log file will not be included in the backup set. It is already been backed up once, or before the since time specified.

Action: No action required.

RMAN-06503 skipping backupset key string; already backed up on string

Cause: The indicated backupset will not be backed up. It has already been backed up on the device once, or before the since time specified.

Action: No action required.

RMAN-06504 PROXY option with multiple backup copies is not supported

Cause: Multiple backup copies and PROXY option were specified in BACKUP command.

Action: Resolve the conflict.

RMAN-06506 the MAXSETSIZE option cannot be used with a backup backupset

Cause: The MAXSETSIZE option was specified for a backup backupset command.

Action: Remove the option and resubmit the command.

RMAN-06507 trying alternate file for archivelog thread number, sequence number

Cause: This is an informational message, appearing when an archivelog was found out of sync with catalog database.

Action: No Action Required.

RMAN-06508 MAXSETSIZE string kbytes should be greater than blocksize string bytes

Cause: MAXSETSIZE configured or specified in backup command should be greater than database blocksize.

Action: Specify a larger MAXSETSIZE limit.

RMAN-06509 only SPFILE or controlfile can be restored from autobackup

Cause: A datafile or archived log restore from autobackup was attempted.

Action: Do not specify DATAFILE or ARCHIVELOG for restore from autobackup.

RMAN-06510 RMAN retention policy is set to recovery window of number days

Cause: This is an informational message.

Action: No Action Required.

RMAN-06511 RMAN retention policy is set to redundancy number

Cause: This is an informational message.

Action: No Action Required.

RMAN-06512 copy will be obsolete on date string

Cause: This is an informational message.

Action: No Action Required.

RMAN-06513 copy will never be obsolete

Cause: This is an informational message.

Action: No Action Required.

RMAN-06514 archived logs required to recover from this copy will not be kept

Cause: This is an informational message.

Action: No Action Required.

RMAN-06515 archived logs required to recover from this copy will expire when this copy expires

Cause: This is an informational message.

Action: No Action Required.

RMAN-06516 time specified in KEEP UNTIL clause must be after today

Cause: KEEP UNTIL support only a future time.

Action: Correct the time and retry the command.

RMAN-06517 KEEP option is not supported for archive log backups

Cause: The KEEP option is not supported for archive logs.

Action: Either remove KEEP option and retry the command or don't specify archive logs for this backup.

RMAN-06518 backup will be obsolete on date string

Cause: This is an informational message.

Action: No Action Required.

RMAN-06519 backup will never be obsolete

Cause: This is an informational message.

Action: No Action Required.

RMAN-06520 archived logs required to recover from this backup will not be kept

Cause: This is an informational message.

Action: No Action Required.

RMAN-06521 archived logs required to recover from this backup will expire when this backup expires

Cause: This is an informational message.

Action: No Action Required.

RMAN-06522 KEEP FOREVER option is not supported without the recovery catalog

Cause: The KEEP FOREVER option was used, but it requires a connection to a recovery catalog database. The KEEP FOREVER option cannot be used when the backup repository is the target database controlfile. This is because information about this backup cannot be permanently stored. If information is stored just in the controlfile it will be aged out depending on the CONTROL_FILE_RECORD_KEEP_TIME initialization parameter.

Action: If a recovery catalog database is available, then connect to the recovery catalog and retry the command. Otherwise, use a different KEEP option.

RMAN-06524 RMAN retention policy will be applied to the command

Cause: This is an informational message.

Action: No Action Required.

RMAN-06525 RMAN retention policy is set to none

Cause: Command DELETE OBSOLETE and REPORT OBSOLETE requires that either:

  • RMAN retention policy is not NONE
  • RMAN retention policy is specified with REPORT/DELETE command

Action: Either configure RMAN retention policy with CONFIGURE command or specify it at the end of DELETE/REPORT command.

RMAN-06526 KEEP option cannot be used with incremental backup

Cause: The KEEP option was specified for an incremental backup.

Action: Remove the option and resubmit the command.

RMAN-06527 KEEP option is not supported for backup of backup sets

Cause: The KEEP option is not supported for backup of backup sets.

Action: Either remove KEEP option and retry the command or don't specify backup sets for this backup.

RMAN-06528 CHANGE ... KEEP not supported for BACKUPPIECE

Cause: The CHANGE BACKUPPIECE ... KEEP command was entered. KEEP attributes cannot be specified for backup pieces.

Action: Use CHANGE BACKUPSET ... KEEP instead.

RMAN-06529 CHANGE ... KEEP not supported for ARCHIVELOG

Cause: The CHANGE ARCHIVELOG ... KEEP command was entered. KEEP attributes cannot be specified for archive logs.

Action: Use CHANGE BACKUPSET ... KEEP instead.

RMAN-06530 CHANGE ... KEEP not supported for backup set which contains archive logs

Cause: The CHANGE BACKUPSET ... KEEP command was entered, but the BACKUPSET contains archive logs. Backup sets with archive logs cannot have KEEP attributes.

Action: Do not specify backup set with archive logs for the CHANGE BACKUPSET ... KEEP command.

RMAN-06531 CHANGE ... KEEP not supported for incremental BACKUPSET

Cause: The CHANGE BACKUPSET ... KEEP command was entered, but the BACKUPSET is an incremental backup set. Incremental backup sets cannot have KEEP attributes.

Action: Do not specify backup set with archive logs for the CHANGE BACKUPSET ... KEEP command.

RMAN-06532 redundancy count must be greater than zero

Cause: The REDUNDANCY operand specified for the retention policy was zero.

Action: Specify a REDUNDANCY operand of 1 or greater.

RMAN-06533 KEEP ... NOLOGS option is not supported when database is open

Cause: The KEEP ... NOLOGS option was specified for a backup or copy of on open database. This kind of backup requires archive logs for recovery, so archive logs must be kept.

Action: Remove the KEEP ... NOLOGS option and resubmit the command.

RMAN-06534 KEEP ... CONSISTENT option is not supported

Cause: The KEEP ... CONSISTENT option was specified but the option is not supported.

Action: Remove the option and resubmit the command.

RMAN-06535 LIST COPY OF SPFILE is not supported

Cause: LIST COPY OF SPFILE was used, which is not supported because SPFILE cannot have a copy.

Action: Remove SPFILE from the command.

RMAN-06536 BACKED UP ... TIMES option is supported only for archived logs

Cause: The BACKUP UP ... TIMES option was used as a qualifier. This option is supported only for archived logs.

Action: Remove the option and resubmit the command.

RMAN-06540 tablespace string will be excluded from future whole database backups

Cause: This is an informational message.

Action: No Action Required.

RMAN-06541 tablespace string will be included in future whole database backups

Cause: This is an informational message.

Action: No Action Required.

RMAN-06542 file string is excluded from whole database backup

Cause: The indicated file will not be included in the backup set because it's tablespace is configured as excluded from backup.

Action: No action required.

RMAN-06543 duplicate or conflicting LIST options: string and string

Cause: The indicated options conflict with each other or appear more than once in a LIST command.

Action: remove the duplicate/conflicting option from the command.

RMAN-06544 Do you really want to delete the above objects (enter YES or NO)?

Cause: This is a user prompt.

Action: Answer the question to proceed.

RMAN-06545 "string" is an invalid response - please re-enter.

Cause: An incorrect response was entered.

Action: Enter a correct response.

RMAN-06546 Error occurred getting response - assuming NO response

Cause: An error occurred reading user response.

Action: No action required. This is an informational message.

RMAN-06547 tablespace SYSTEM cannot be excluded from whole database backup

Cause: The SYSTEM tablespace must be included in whole database backup.

Action: Remove the SYSTEM tablespace from the CONFIGURE ... EXCLUDE and retry the operation.

RMAN-06548 connected to auxiliary database: string (DBID=string)

Cause: This is an informational message.

Action: No action required.

RMAN-06549 connected to auxiliary database: string (not mounted)

Cause: This is an informational message.

Action: No action required.

RMAN-06550 clone database not mounted and db_name not set in initialziation parameter file

Cause: The clone database initialization parameter file does not specify the DB_NAME parameter.

Action: Add the DB_NAME parameter to the clone database initialization parameter file and restart the instance.

RMAN-06551 error while looking up datafilecopy for file number: string

Cause: An error occurred while looking up the specified datafilecopy in the recovery catalog or target database controlfile.

Action: This error is accompanied by other errors describing the reason for the failure. If the datafilecopy was created during a RESTORE with a new name, then ensure that the RESTORE completed successfully.

RMAN-06552 newname for datafile number was set to NEW, but file was not restored

Cause: A SWITCH command was specified for a datafile, but the newname was set to NEW and the file was not restored. If newname is set to NEW, then the file must be restored before issuing a SWITCH command.

Action: Correct and resubmit the SWITCH command.

RMAN-06553 DB_CREATE_FILE_DEST must be set for SET NEWNAME ... TO NEW

Cause: The SET NEWNAME ... TO NEW option was specified but the OMF destination initialization parameter DB_CREATE_FILE_DEST is not set.

Action: Supply a full name to the SET NEWNAME command or set DB_CREATE_FILE_DEST at the target database.

RMAN-06554 WARNING: file string is in backup mode

Cause: A file which is being backed up or copied is in backup mode. RMAN will back up the file anyway, but files do not need to be put into backup mode before backing them up with RMAN.

Action: Use the ALTER TABLESPACE ... END BACKUP statement, at the target database server, to take the files out of backup mode.

RMAN-06555 datafile string must be restored from backup created before string

Cause: An incomplete recovery session was started, but the file is newer than the UNTIL TIME clause.

Action: Check the UNTIL TIME clause or restore the file from a sufficient old backup.

RMAN-06556 datafile string must be restored from backup older than scn string

Cause: An incomplete recovery session was started, but the file is newer than the UNTIL clause.

Action: Check the UNTIL clause or restore the file from a sufficient old backup.

RMAN-06557 unable to restore archived log thread number, sequence number

Cause: Restore of the specified archived log failed because the size of the archived log is larger than MAXSIZE specified in the RECOVERY command.

Action: Specify a larger MAXSIZE limit. See message RMAN-06558 for further details.

RMAN-06558 an archived log size of number KB is bigger than MAXSIZE limit of number KB

Cause: This is an informational message only.

Action: No action required. See message RMAN-06557 for further details.

RMAN-06559 MAXSIZE must be larger than 1 KB

Cause: The MAXSIZE parameter is out of range.

Action: Specify a valid size and retry the command.

RMAN-06560 WARNING: backup set with key number will be read number times

Cause: Backup set size is bigger than MAXSIZE limit, so it will be read more than once. This can cause slower restore performance.

Action: Increase the MAXSIZE parameter and retry the command.

RMAN-06561 MAXSIZE must be larger than number KB

Cause: Recovery failed because it requires disk space larger than MAXSIZE specified in the RECOVERY command.

Action: Increase the MAXSIZE parameter and retry the command.

RMAN-06562 set MAXSIZE to number KB to avoid reading the backupsets multiple times

Cause: This is aninformational message.

Action: No action required.

RMAN-06563 controlfile or SPFILE must be restored using FROM AUTOBACKUP

Cause: RESTORE CONTROLFILE or RESTORE SPFILE was specified without the FROM AUTOBACKUP option when RMAN is not connected to the recovery catalog.

Action: If the recovery catalog is available, then connect to the recovery catalog and retry the restore. If the recovery catalog is not available, then the following is the procedure to restore controlfile or SPFILE:

  1. Specify the DBID of the database with the SET DBID command.
  2. If the autobackup was created with non-default autobackup format, then specify the autobackup format using the SET CONTROLFILE AUTOBACKUP FORMAT command.
  3. If the backup was created with SBT device, then allocate an SBT channel using the ALLOCATE CHANNEL command.
  4. Restore controlfile or SPFILE by starting the RESTORE ... FROM AUTOBACKUP command.

RMAN-06564 must use the TO clause when the instance is started with SPFILE

Cause: A restore of the SPFILE from autobackup was attempted when the instance is started with SPFILE and no alternate destination was specified.

Action: Specify an alternate destination with the TO clause.

RMAN-06565 WARNING: string: sqlcode number was caught, automatic retry #number

Cause: The RMAN client caught a transient error and will automatically retry several times.

Action: No action required. This is an informational message.

RMAN-08000 channel string: copied datafile string

Cause: A datafile copy operation completed successfully.

Action: No action required. This is an informational message only.

RMAN-08001 restore not complete

Cause: All of the backup pieces have been successfully applied, but X$DBMS_BACKUP_RESTORE indicates that the restore conversation is not complete. This usually means that the backup set contained corrupt data.

Action: Restore the files from a different backup set, if possible. The Recovery Manager CHANGE BACKUPPIECE UNAVAILABLE can be used to prevent Recovery Manager from attempting to restore from the corrupt backup piece(s).

RMAN-08002 starting full resync of recovery catalog

Cause: This is an informational message.

Action: No action required.

RMAN-08004 full resync complete

Cause: This is an informational message.

Action: No action required.

RMAN-08006 database registered in recovery catalog

Cause: This is an informational message.

Action: No action required.

RMAN-08007 channel string: copied datafilecopy of datafile string

Cause: This is an informational message.

Action: No action required.

RMAN-08008 channel string: starting string datafile backupset

Cause: This is an informational message.

Action: No action required.

RMAN-08009 channel string: starting archivelog backupset

Cause: This is an informational message.

Action: No action required.

RMAN-08010 channel string: specifying datafile(s) in backupset

Cause: This is an informational message.

Action: No action required.

RMAN-08011 including current controlfile in backupset

Cause: This is an informational message.

Action: No action required.

RMAN-08012 including controlfile copy in backup set

Cause: This is an informational message.

Action: No action required.

RMAN-08014 channel string: specifying archivelog(s) in backup set

Cause: This is an informational message.

Action: No action required.

RMAN-08015 datafile string switched to datafile copy

Cause: This is an informational message.

Action: No action required.

RMAN-08016 channel string: starting datafile backupset restore

Cause: This is an informational message.

Action: No action required.

RMAN-08017 channel string: starting archivelog restore to default destination

Cause: This is an informational message.

Action: No action required.

RMAN-08018 channel string: starting archivelog restore to user-specified destination

Cause: This is an informational message.

Action: No action required.

RMAN-08019 channel string: restoring datafile string

Cause: This is an informational message.

Action: No action required.

RMAN-08021 channel string: restoring controlfile

Cause: This is an informational message.

Action: No action required.

RMAN-08022 channel string: restoring archivelog

Cause: This is an informational message.

Action: No action required.

RMAN-08023 channel string: restored backup piece string

Cause: This is an informational message.

Action: No action required.

RMAN-08024 channel string: restore complete

Cause: This is an informational message.

Action: No action required.

RMAN-08025 channel string: copied controlfile copy

Cause: This is an informational message.

Action: No action required.

RMAN-08026 channel string: copied archivelog

Cause: This is an informational message.

Action: No action required.

RMAN-08027 channel string: copied current controlfile

Cause: This is an informational message.

Action: No action required.

RMAN-08028 channel string: copy current controlfile failed

Cause: This is an informational message.

Action: No action required.

RMAN-08029 snapshot controlfile name set to default value: string

Cause: This is an informational message.

Action: No action required.

RMAN-08030 allocated channel: string

Cause: This is an informational message.

Action: No action required.

RMAN-08031 released channel: string

Cause: This is an informational message.

Action: No action required.

RMAN-08032 channel string: recid string stamp string does not match recovery catalog

Cause: The record that identifies the source file for a copy or backup database does not contain the same data as is stored in the recovery catalog.

Action: Perform a full resync and retry the operation. If the problem persists, then contact Oracle Support Services.

RMAN-08033 channel string: including datafilecopy of datafile string in backupset

Cause: This is an informational message.

Action: No action required.

RMAN-08034 full resync skipped, target database not mounted

Cause: This is an informational message.

Action: No action required.

RMAN-08035 partial resync skipped, target database not mounted

Cause: This is an informational message.

Action: No action required.

RMAN-08036 channel string: could not create controlfile record for string string

Cause: The record identifying the named file was no longer present in the target database control file, and repeated attempts to inspect the file were unsuccessful in creating the record. This could be because the circular-reuse section of the control file which holds information about the specified type of file is too small and there is other database activity which is causing the record to be overwritten before it can be used.

Action: Try increasing either the size of the control file circular-reuse section for this file type (datafile copy or archived log, as indicated in the error message, or the CONTROL_FILE_RECORD_KEEP_TIME initialization parameter. If neither of those remedies works then contact Oracle Support Services.

RMAN-08037 channel string: unexpected validation return code string

Cause: This is an internal error that should never be issued.

Action: Contact Oracle Support Services.

RMAN-08039 channel string: starting incremental datafile backupset restore

Cause: This is an informational message.

Action: No action required.

RMAN-08040 full resync skipped, controlfile is not current or backup

Cause: This is an informational message.

Action: No action required.

RMAN-08041 partial resync skipped, controlfile is not current or backup

Cause: This is an informational message.

Action: No action required.

RMAN-08050 cataloged datafile copy

Cause: This is an informational message.

Action: No action required.

RMAN-08051 cataloged archivelog

Cause: This is an informational message.

Action: No action required.

RMAN-08052 cataloged controlfile copy

Cause: This is an informational message.

Action: No action required.

RMAN-08054 starting media recovery

Cause: This is an informational message.

Action: No action required.

RMAN-08055 media recovery complete

Cause: This is an informational message.

Action: No action required.

RMAN-08056 skipping datafile string because it has not changed

Cause: The specified datafile has not had its checkpoint advanced since the previous backup, therefore it does not need a new incremental backup.

Action: This message is informational only.

RMAN-08057 channel string: backup cancelled because all files were skipped

Cause: All datafiles for this incremental backup set were skipped, therefore no backup set is created.

Action: This message is informational only.

RMAN-08058 replicating controlfile

Cause: This is an informational message.

Action: No action required.

RMAN-08059 media recovery failed

RMAN-08060 unable to find archivelog

RMAN-08066 database reset to incarnation string in recovery catalog

Cause: This is an informational message.

Action: No action required.

RMAN-08070 deleted datafile copy

Cause: This is an informational message.

Action: No action required.

RMAN-08071 channel string: deleting archivelog(s)

Cause: This is an informational message.

Action: No action required.

RMAN-08072 deleted controlfile copy

Cause: This is an informational message.

Action: No action required.

RMAN-08073 deleted backup piece

Cause: This is an informational message.

Action: No action required.

RMAN-08074 crosschecked backup piece: found to be 'string'

Cause: This is an informational message.

Action: No action required.

RMAN-08085 created script string

Cause: This is an informational message.

Action: No action required.

RMAN-08086 replaced script string

Cause: This is an informational message.

Action: No action required.

RMAN-08087 channel string: started backup set validation

Cause: This is an informational message.

Action: No action required.

RMAN-08088 applied offline range to datafile string

Cause: This is an informational message.

Action: No action required.

RMAN-08089 channel string: specifying datafile(s) to restore from backup set

Cause: This is an informational message.

Action: No action required.

RMAN-08090 channel string: starting proxy datafile restore

Cause: This is an informational message.

Action: No action required.

RMAN-08091 channel string: specifying datafile(s) for proxy backup

Cause: This is an informational message.

Action: No action required.

RMAN-08092 channel string: specifying datafilecopy of datafile string for proxy backup

Cause: This is an informational message.

Action: No action required.

RMAN-08093 specifying current controlfile for proxy backup

Cause: This is an informational message.

Action: No action required.

RMAN-08094 channel string: specifying datafile(s) for proxy restore

Cause: This is an informational message.

Action: No action required.

RMAN-08096 channel string: starting validation of datafile backupset

Cause: This is an informational message.

Action: No action required.

RMAN-08097 channel string: starting validation of archivelog backupset

Cause: This is an informational message.

Action: No action required.

RMAN-08098 channel string: validation complete

Cause: This is an informational message.

Action: No action required.

RMAN-08099 specifying standby controlfile for proxy backup

Cause: This is an informational message.

Action: No Action Required.

RMAN-08100 channel string: starting proxy validation

Cause: This is an informational message.

Action: No action required.

RMAN-08101 channel string: proxy validation complete

Cause: This is an informational message.

Action: No action required.

RMAN-08102 channel string: located backup piece: string

Cause: This is an informational message.

Action: No action required.

RMAN-08103 channel string: could not locate backup piece: string

Cause: This is an informational message.

Action: No action required.

RMAN-08104 input backupset count=string stamp=string creation_time=string

Cause: This is an informational message.

Action: No Action Required.

RMAN-08105 channel string: backup cancelled because no pieces were found

Cause: All backupsets specified has no pieces. Therefore, no backup set is created.

Action: This message is informational only.

RMAN-08106 channel string: restoring block(s)

Cause: This is an informational message.

Action: No Action Required.

RMAN-08107 channel string: block restore complete

Cause: This is an informational message.

Action: No Action Required.

RMAN-08108 channel string: specifying block(s) to restore from backup set

Cause: This is an informational message.

Action: No Action Required.

RMAN-08111 some blocks not recovered: See trace file for details

Cause: Some blocks were not recovered due to errors.

Action: See trace file for details of the problem.

RMAN-08112 archivelog failover was done on string, check alert log for more info

Cause: This is an informational message to indicate the server found a corrupted block in an archivelog and had to switch to another archivelog with same logseq in alternate archivelog destination to get corresponding un-corrupted block.

Action: If backup is done with delete input option, then nothing needs to be done. Otherwise, delete the archivelog that has corrupted blocks as recovery on applying this log would fail. alert log contains name of the log that has corrupted blocks.

RMAN-08113 including current SPFILE in backupset

Cause: This is an informational message.

Action: No Action Required.

RMAN-08114 channel string: restoring SPFILE to PFILE

Cause: This is an informational message.

Action: No Action Required.

RMAN-08115 channel string: restoring SPFILE

Cause: This is an informational message.

Action: No Action Required.

RMAN-08116 output filename is original SPFILE location

Cause: This is an informational message.

Action: No Action Required.

RMAN-08117 channel string: the autobackup does not contain SPFILE. Trying older autobackup...

Cause: The requested autobackup does not contain a SPFILE. This is because the instance was not started with a SPFILE when the autobackup was created.

Action: No Action Required. RMAN will try three older autobackups before signaling ORA-19687.

RMAN-08118 WARNING: could not delete the following archived redo log

Cause: The routine deleteArchivedLog() could not delete an archived redo log on the target instance.

Action: Check the accompanying file specification and the associated error messages. The file specification indicates what archived redo log on the target instance RMAN was trying to delete and the error messages indicate why RMAN was unable to delete it. Resolve the problem by first confirming that the archived redo log in question has been backed up, do the deletion manually, and then do a crosscheck so that RMAN is aware of the deletion.

RMAN-08119 skipping backup piece handle string; already exists

Cause: A BACKUP command does not need to backup controlfile autobackup pieces, because they already exist.

Action: This is an informational message. No action required.

RMAN-08120 WARNING: archive log not deleted, not yet applied by standby

Cause: This is an informational message to alert the user that an archivelog that should have been deleted was not as it has not been applied to the standby database. The next message identifies the archivelog.

Action: Archivelog can be deleted after it has been applied to standby database.

RMAN-08500 channel string: sid=string devtype=string

Cause: This is an informational message.

Action: No action required.

RMAN-08501 output filename=string recid=string stamp=string

Cause: This is an informational message.

Action: No action required.

RMAN-08502 set_count=string set_stamp=string creation_time=string

Cause: This is an informational message.

Action: No action required.

RMAN-08503 piece handle=string comment=string

Cause: This is an informational message.

Action: No action required.

RMAN-08504 input archivelog thread=string sequence=string recid=string stamp=string

Cause: This is an informational message.

Action: No action required.

RMAN-08505 output filename=string

Cause: This is an informational message.

Action: No action required.

RMAN-08506 input filename=string

Cause: This is an informational message.

Action: No action required.

RMAN-08507 input datafilecopy recid=string stamp=string filename=string

Cause: This is an informational message.

Action: No action required.

RMAN-08508 archivelog destination=string

Cause: This is an informational message.

Action: No action required.

RMAN-08509 destination for restore of datafile string: string

Cause: This is an informational message.

Action: No action required.

RMAN-08510 archivelog thread=string sequence=string

Cause: This is an informational message.

Action: No action required.

RMAN-08511 piece handle=string params=string

Cause: This is an informational message.

Action: No action required.

RMAN-08512 waiting for snapshot controlfile enqueue

Cause: This is an informational message.

Action: No action required.

RMAN-08513 datafile copy filename=string recid=string stamp=string

Cause: This is an informational message.

Action: No action required.

RMAN-08514 archivelog filename=string recid=string stamp=string

Cause: This is an informational message.

Action: No action required.

RMAN-08515 archivelog filename=string thread=string sequence=string

Cause: This is an informational message.

Action: No action required.

RMAN-08516 controlfile copy filename=string recid=string stamp=string

Cause: This is an informational message.

Action: No action required.

RMAN-08517 backup piece handle=string recid=string stamp=string

Cause: This is an informational message.

Action: No action required.

RMAN-08518 channel string: scanning controlfile copy string

Cause: This is an informational message.

Action: No action required.

RMAN-08519 channel string: scanning datafilecopy string

Cause: This is an informational message.

Action: No action required.

RMAN-08520 channel string: scanning archivelog string

Cause: This is an informational message.

Action: No action required.

RMAN-08521 offline range recid=string stamp=string

Cause: This is an informational message.

Action: No action required.

RMAN-08522 input datafile fno=string name=string

Cause: This is an informational message.

Action: No action required.

RMAN-08523 restoring datafile string to string

Cause: This is an informational message.

Action: No action required.

RMAN-08524 input controlfilecopy name=string

Cause: This is an informational message.

Action: No action required.

RMAN-08526 channel string: string

Cause: This is an informational message.

Action: No action required.

RMAN-08527 channel string: starting string proxy datafile backup at string

Cause: This is an informational message.

Action: No action required.

RMAN-08528 channel string: proxy copy complete, elapsed time: string

Cause: This is an informational message.

Action: No action required.

RMAN-08529 proxy file handle=string

Cause: This is an informational message.

Action: No action required.

RMAN-08531 channel string: proxy copy string is string in media management catalog

Cause: This is an informational message.

Action: No action required.

RMAN-10000 error parsing target database connect string "string"

Cause: An invalid target connect string was supplied.

Action: Specify a valid connect string and re-run the job.

RMAN-10001 error parsing recovery catalog connect string "string"

Cause: An invalid recovery catalog connect string was supplied.

Action: Specify a valid connect string and re-run the job.

RMAN-10002 ORACLE error: string

Cause: The specified Oracle error was received. This message should be accompanied by other error messages indicating the cause of the error.

Action: Check the accompanying errors.

RMAN-10003 unable to connect to target database using connect string "string"

Cause: Recovery manager was unable to connect to the target database. This message should be accompanied by other error messages indicating the cause of the error.

Action: Ensure that the target database is started and that the connect string is valid.

RMAN-10004 unable to connect to recovery catalog using connect string: string

Cause: Recovery manager was unable to connect to the recovery catalog. This message should be accompanied by other error messages indicating the cause of the error.

Action: Ensure that the recovery catalog is started and that the connect string is valid.

RMAN-10005 error opening cursor

Cause: An error was received while trying to open a cursor. This message should be accompanied by other error messages indicating the cause of the error.

Action: If the associated Oracle error message indicates a condition that can be corrected, then correct the condition. Otherwise, contact Oracle Support Services.

RMAN-10006 error running sql statement: string

Cause: An error message was received while running the specified SQL statement.

Action: If the associated Oracle error message indicates a condition that can be corrected, then correct the condition. Otherwise, contact Oracle Support Services.

RMAN-10007 error closing cursor

Cause: An error was received while trying to close a cursor. This message should be accompanied by other error messages indicating the cause of the error.

Action: If the associated Oracle error message indicates a condition that can be corrected, then correct the condition. Otherwise, contact Oracle Support Services.

RMAN-10008 could not create channel context

Cause: An error was received while trying to create a channel context. This message should be accompanied by other error messages indicating the cause of the error.

Action: If the associated Oracle error message indicates a condition that can be corrected, then correct the condition. Otherwise, contact Oracle Support Services.

RMAN-10009 error logging off of Oracle

Cause: An error was received while disconnecting from Oracle. This message should be accompanied by other error messages indicating the cause of the error. This is an informational message.

Action: No action required.

RMAN-10010 error while checking for RPC completion

Cause: Recovery Manager's channel context had an error while checking to see if a remote procedure call had completed. This message should be accompanied by other error messages indicating the cause of the error.

Action: If other error messages indicate a condition that can be corrected, then correct the condition. Otherwise, contact Oracle Support Services.

RMAN-10011 synchronization error while polling for rpc number, action=string

Cause: Recovery Manager could not synchronize properly with a remote procedure call. This is an internal error that should not be issued.

Action: Contact Oracle Support Services.

RMAN-10012 KGU error: string

Cause: An error occurred while initializing the KGU subsystem. This is an internal error that should not be issued.

Action: Contact Oracle Support Services.

RMAN-10013 error initializing PL/SQL

Cause: An error occurred while initializing the PL/SQL subsystem. This is an internal error that should not be issued.

Action: Contact Oracle Support Services.

RMAN-10014 PL/SQL error number on line number column number: string

Cause: PL/SQL error.

Action: The text of this message will be issued by the PL/SQL subsystem.

RMAN-10015 error compiling PL/SQL program

Cause: An error occurred while compiling a PL/SQL program. This is an internal error that should not be issued.

Action: Contact Oracle Support Services.

RMAN-10016 error creating PL/SQL runtime context

Cause: An error occurred while creating a PL/SQL run time context. This is an internal error that should not be issued.

Action: Contact Oracle Support Services.

RMAN-10018 error cleaning up channel context

Cause: An error was received during inter-step cleanup of a channel context. This is an internal error that should not be issued.

Action: Contact Oracle Support Services.

RMAN-10020 error initializing Recovery Manager execution layer

Cause: An error was received while initializing the Recovery Manager execution layer in preparation for running a job. This message should be accompanied by other error messages indicating the cause of the error.

Action: If other error messages indicate a condition that can be corrected, then correct the condition. Otherwise, contact Oracle Support Services.

RMAN-10022 error in system-dependant sleep routine

Cause: An error was received while waiting for a remote RPC to complete. The error occurred in the system-dependent sleep routine. This is an internal error that should not be issued.

Action: Contact Oracle Support Services.

RMAN-10023 RPC attempted to unrecognized package

Cause: The Recovery Manager internal RPC router received a package name that it could not understand. This is an internal error that should not be issued.

Action: Contact Oracle Support Services.

RMAN-10024 error setting up for rpc polling

Cause: The Recovery Manager could not create the RPC polling context which is required to test for RPC completion. This message should be accompanied by other error messages indicating the cause of the error.

Action: If other error messages indicate a condition that can be corrected, then correct the condition. Otherwise, contact Oracle Support Services.

RMAN-10025 connection is already registered for events

Cause: The Recovery Manager could not enable the target database connection to test for RPC completion. This is an internal error that should not be issued.

Action: Contact Oracle Support Services.

RMAN-10026 network error number-number occurred registering connection

Cause: A network error occurred while attempting to register the target database connection to test for RPC completion. This is an internal error that should not be issued.

Action: The message numbers are issued by the SQL*Net layer. Contact Oracle Support Services.

RMAN-10027 could not locate network layer context

Cause: Recovery Manager could not locate a necessary context area while attempting to register the target database connection to test for RPC completion. This is an internal error that should not be issued.

Action: Contact Oracle Support Services.

RMAN-10028 network error number-number occurred during remote RPC

Cause: A network error occurred while waiting for a remote RPC to complete. This is an internal error that should not be issued.

Action: The message numbers are issued by the SQL*Net layer. Contact Oracle Support Services.

RMAN-10029 unexpected return code number from PL/SQL execution

Cause: PL/SQL returned an unexpected return code while executing one channel program. This is an internal error that should not be issued.

Action: Contact Oracle Support Services.

RMAN-10030 RPC call appears to have failed to start on channel string

Cause: An RPC to a target database instance was issued, but was not observed to start within 5 timeouts.

Action: This error is probably accompanied by other error messages giving the precise cause of the failure.

RMAN-10031 RPC Error: ORA-number occurred during call to string.string

Cause: An RPC to the target database or recovery catalog database encountered an error.

Action: This error is accompanied with the error message from the server where the error occurred.

RMAN-10032 unhandled exception during execution of job step number: string

Cause: An unhandled PL/SQL exception occurred during a job step.

Action: This error is accompanied by the error messages describing the exception.

RMAN-10033 error during compilation of job step number: string

Cause: PL/SQL detected a problem during the compilation of a job step.

Action: This error message is accompanied by the error messages describing the exception.

RMAN-10034 unhandled exception during execution of job step number, error unknown

Cause: PL/SQL detected an unhandled exception during execution of a job step, but no further information available

Action: Contact Oracle Support Services.

RMAN-10035 exception raised in RPC: string

Cause: A call to a remote package resulted in an exception.

Action: The exception should indicate what went wrong.

RMAN-10036 RPC call ok on channel string

Cause: This is just an informational message. It should be preceded by message 10030.

Action: No action required.

RMAN-10037 RPC anomaly detected on channel string, upinblt=number

Cause: This is an debugging message and can be ignored.

Action: No action required.

RMAN-10038 database session for channel string terminated unexpectedly

Cause: The database connection for the specified channel no longer exists. Either the session was terminated by some external means or the channel terminated because of an internal error.

Action: Check for an Oracle trace file for detailed information on why the session terminated.

RMAN-10039 error encountered while polling for RPC completion on channel string

Cause: This error should be accompanied by other errors giving the cause of the polling error.

Action: No action required.

RMAN-10040 asynchronous support not detected, RMAN will run synchronously

Cause: The database connection does not support asynchronous operation, so RMAN will not multi-task work among multiple channels. Multiple channels can still be allocated, but they will not run work concurrently.

Action: Use a connection type that supports asynchronous operations.

RMAN-11000 message number number not found in recovery manager message file

Cause: Recovery manager message file is out of date.

Action: Make sure that the Recovery Manager error message file is current and installed in the correct location.

RMAN-11001 Oracle Error: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-11002 could not open a cursor to the target database

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-11003 failure during parse/execution of SQL statement: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-11004 format requires %c when duplexing

Cause: SET_DUPLEX=ON was specified, but %c was not part of the format.

Action: Include %c in format, or use %U.

RMAN-12000 execution layer initialization failed

Cause: This message should be accompanied by other error messages indicating the cause of the error.

Action: See accompanying messages.

RMAN-12001 could not open channel string

Cause: An ALLOCATE CHANNEL command could not be processed.

Action: This message should be accompanied by other error messages indicating the cause of the error.

RMAN-12005 error during channel cleanup

Cause: This message should be accompanied by other error messages indicating the cause of the error.

Action: See accompanying messages.

RMAN-12007 cannot allocate more than number channels

Cause: The maximum number of RMAN channels has been exceeded. Note that one channel is reserved for RMAN.

Action: Allocate fewer channels. Contact Oracle Support Services if you have a need for more channels in a single job.

RMAN-12008 could not locate backup piece string

Cause: There was at least 1 backup set that could not be accessed by any of the allocated channels.

Action: Allocate additional channels on other nodes of the cluster.

RMAN-12009 command aborted because some backup pieces could not be located

Cause: There was at least 1 backup set that could not be accessed by any of the allocated channels.

Action: Allocate additional channels on other nodes of the cluster.

RMAN-12010 automatic channel allocation initialization failed

Cause: This message should be accompanied by other error messages indicating the cause of the error.

Action: See accompanying messages.

RMAN-12011 multiple records for default device type found in catalog

Cause: Configuration for default device type not consistent.

Action: Re-run CONFIGURE DEFAULT DEVICE TYPE command to set device type.

RMAN-12012 multiple records for string parallelism found in catalog

Cause: Configuration for device parallelism is not consistent.

Action: Re-run CONFIGURE PARALLELISM command for device to set parallelism.

RMAN-12013 multiple records for string channel number found in catalog

Cause: Configuration for the channel is not consistent.

Action: Re-run CONFIGURE CHANNEL command to configure this channel.

RMAN-12014 multiple records for default channel configuration for string found in catalog

Cause: Configuration for the channel is not consistent.

Action: Re-run CONFIGURE CHANNEL command to configure the channel.

RMAN-12015 configuration for string channel number is ignored

Cause: This is an informational message. Parallelism for the device is less than the associated channel number.

Action: To use this configuration, increase parallelism for this device. to clear this configuration, use CONFIGURE CHANNEL ... CLEAR command.

RMAN-12016 using channel string

Cause: This is an informational message.

Action: No action required.

RMAN-12017 could not locate pieces of backupset key string

Cause: No copies of the specified backupset key can be accessed on any of the allocated channels.

Action: Allocate additional channels on other nodes of the cluster, or if the backup pieces have been deleted, then use the CROSSCHECK BACKUP command to correct the recovery catalog entries.

RMAN-20000 abnormal termination of job step

Cause: A job step encountered an error and could not recover.

Action: This error should be followed by other errors indicating the cause of the problem.

RMAN-20001 target database not found in recovery catalog

Cause: Target database is not found in the recovery catalog.

Action: Make sure that the target database is registered in the recovery catalog.

RMAN-20002 target database already registered in recovery catalog

Cause: Target database is already registered in the recovery catalog.

Action: If the target database is really registered, there is no need to register it again. Note that the recovery catalog enforces that all databases have a unique DBID. If the new database was created by copying files from an existing database, it will have the same DBID as the original database and cannot be registered in the same recovery catalog.

RMAN-20003 target database incarnation not found in recovery catalog

Cause: Resetlogs change# and/or time of the target database does not match any database incarnation in the recovery catalog.

Action: If target database was opened with resetlogs option then use RESET DATABASE to register the new incarnation.

RMAN-20004 target database name does not match name in recovery catalog

Cause: Name of the target database does not match the one stored in the recovery catalog. This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20005 target database name is ambiguous

Cause: Two or more databases in the recovery catalog match the DB_NAME initialization parameter of the instance and the target database is not mounted, so RMAN cannot get its DBID.

Action: Mount the target database then retry the operation.

RMAN-20006 target database name is missing

Cause: The target database instance is not started or the value of the DB_NAME initialization parameter is not set.

Action: Start the instance and make sure that the value of the DB_NAME initialization parameter is set.

RMAN-20007 target database id is missing

Cause: This an internal error.

Action: Contact Oracle Support Services.

RMAN-20008 database incarnation key is missing

Cause: The database incarnation key was not specified.

Action: Specify a valid database incarnation key.

RMAN-20009 database incarnation already registered

Cause: This incarnation is already registered in the recovery catalog. This is an informational message.

Action: No action required.

RMAN-20010 database incarnation not found

Cause: Database incarnation does not match any database incarnation in the recovery catalog.

Action: Specify a valid database incarnation key.

RMAN-20011 target database incarnation is not current in recovery catalog

Cause: The database incarnation that matches the resetlogs change# and time of the mounted target database control file is not the current incarnation of the database.

Action: If RESET DATABASE TO INCARNATION key was used to make an old incarnation current, then restore the target database from a backup that matches the incarnation and mount it. You will need to do STARTUP NOMOUNT before you can restore the control file using RMAN. Otherwise use RESET DATABASE TO INCARNATION key to make the intended incarnation current in the recovery catalog.

RMAN-20020 database incarnation not set

Cause: This an internal error.

Action: Contact Oracle Support Services.

RMAN-20021 database not set

Cause: This an internal error.

Action: Contact Oracle Support Services.

RMAN-20029 cannot make a snapshot controlfile

Cause: Another operation that needs the snapshot control file is in progress.

Action: Try again later if necessary.

RMAN-20030 resync in progress

Cause: This procedure cannot be called while a resync is in progress. This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20031 resync not started

Cause: This procedure can only be called in a resync. This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20032 checkpoint change# too low

Cause: The checkpoint change# is less than the one of the previous resync or the checkpoint change# is null.

Action: Make sure that the right control file is used.

RMAN-20033 controlfile sequence# too low

Cause: The control file sequence is less than the one of the previous resync.

Action: Make sure that the right control file is used.

RMAN-20034 resync not needed

Cause: The control file has not changed since the previous resync.

Action: No action required since the recovery catalog is in synchronization.

RMAN-20035 invalid high recid

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20036 invalid record order

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20037 invalid last recid

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20039 format requires character when duplexing

Cause: SET_DUPLEX=ON was specified, but character was not part of the format.

Action: Include character in format, or use number.

RMAN-20040 tablespace resync not started

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20041 tablespace resync not completed

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20042 invalid tablespace creation change#

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20043 invalid tablespace create time

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20044 invalid tablespace name

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20050 datafile resync not started

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20051 datafile resync not completed

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20052 invalid datafile create SCN

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20053 invalid datafile create time

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20054 invalid datafile ts#

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20061 thread resync not started

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20070 invalid log history sequence#

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20071 invalid log history low SCN

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20080 invalid archived log name

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20085 invalid offline range file#

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20086 invalid offline range offline_scn

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20087 invalid offline range online_scn

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20090 invalid backup set type

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20091 invalid backup set level

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20092 invalid backup set completion time

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20093 invalid backup piece number

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20094 missing backup set

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20095 invalid backup/copy controlfile checkpoint scn

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20096 invalid backup/copy datafile file#

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20097 invalid backup/copy datafile create scn

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20098 invalid backup redo log low scn

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20100 invalid status

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20101 datafile copy missing

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20102 archived log missing

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20103 controlfile copy missing

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20104 backup piece missing

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20105 datafile missing

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20106 proxy copy missing

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20200 invalid restore source

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20201 datafile not found in the recovery catalog

Cause: The specified datafile is not found in the recovery catalog.

Action: Make sure that the datafile name is correct and that the recovery catalog is up-to-date.

RMAN-20202 tablespace not found in the recovery catalog

Cause: The specified tablespace is not found in the recovery catalog.

Action: Make sure that the tablespace name is correct and that the recovery catalog is up-to-date.

RMAN-20203 translation in progress

Cause: This procedure cannot be called when name translation is in progress. This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20204 translation not started

Cause: getDatafile procedure was called before translateTablespace. This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20205 incomplete UNTIL clause

Cause: The sequence# was NULL. This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20206 log sequence not found in the repository

Cause: The specified log sequence does not exists in log history of the current database incarnation.

Action: Check the THREAD and LOGSEQ. If the database needs to be recovered to a log sequence number before the current database incarnation, use RESET DATABASE TO INCARNATION command first.

RMAN-20207 UNTIL TIME is before RESETLOGS time

Cause: UNTIL TIME cannot be less than the database creation time or RESETLOGS time.

Action: Check the UNTIL TIME. If the database needs to be restored to an old incarnation, use the RESET DATABASE TO INCARNATION command.

RMAN-20208 UNTIL CHANGE is before RESETLOGS change

Cause: UNTIL CHANGE cannot be less than the database RESETLOGS change.

Action: Check the UNTIL CHANGE. If the database needs to be restored to an old incarnation, use the RESET DATABASE TO INCARNATION command.

RMAN-20209 duplicate datafile name

Cause: Two datafiles have the same name. This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20210 invalid archived log range, thread number is null

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20211 FROM TIME is before RESETLOGS time

Cause: FROM TIME cannot be less than the database creation time or RESETLOGS time.

Action: Check the FROM TIME. If the database needs to be restored to an old incarnation, use the RESET DATABASE TO INCARNATION command.

RMAN-20212 ambiguous proxy copy recid

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20215 backup set is missing

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20216 backup piece is missing

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20217 datafile not part of the database

Cause: The datafile does not exist or did not exist at until time/SCN. This is an internal error for restore database or tablespace.

Action: Check the datafile name or number. Contact Oracle Support Services.

RMAN-20218 datafile not found in recovery catalog

Cause: This is an internal error.

Action: Contact Oracle Support Services.

RMAN-20220 controlfile copy not found in the recovery catalog

Cause: The specified control file is not in the recovery catalog or it has been marked deleted.

Action: Check the file name.

RMAN-20221 ambiguous controlfile copy name

Cause: More than one control file copy in the recovery catalog matches the specified name.

Action: Use the control file copy key to uniquely specify the control file copy.

RMAN-20222 datafilename not found in recovery catalog or is ambiguous

Cause: The specified datafile name is not the name of a datafile that is currently part of the target database, or an UNTIL clause has been specified and the file name was for a different datafile at the time specified by the UNTIL clause than it is now.

Action: Use a datafile number to specify the datafile you want to RESTORE or RECOVER.

RMAN-20230 datafile copy not found in the recovery catalog

Cause: The specified datafile is not in the recovery catalog or it has been marked deleted.

Action: Check the datafile copy name or key.

RMAN-20231 ambiguous datafilecopy name

Cause: More than one control file copy in the recovery catalog match the specified name.

Action: Use the datafile copy key to uniquely specify the datafile copy.

RMAN-20232 tag does not match any datafile copy in the recovery catalog

Cause: The specified TAG does not match any datafile copy in the recovery catalog.

Action: Check the tag.

RMAN-20240 archived log not found in the recovery catalog

Cause: The specified archived log was not found in the recovery catalog or it has been marked deleted.

Action: Check the archived log name or key.

RMAN-20241 ambiguous archived log name

Cause: More than one archived log in the recovery catalog match the specified name.

Action: Use the archived log key to uniquely specify the archived log.

RMAN-20242 specification does not match any archivelog in the recovery catalog

Cause: No archive logs in the specified archive log range could be found.

Action: Check the archive log specifier.

RMAN-20250 offline range not found in the recovery catalog

Cause: The specified offline was not found in the recovery catalog.

Action: Check that the recovery catalog is current.

RMAN-20260 backup piece not found in the recovery catalog

Cause: The specified backup piece is not in the recovery catalog or it has been marked deleted.

Action: Check the backup piece handle or key.

RMAN-20261 ambiguous backup piece handle

Cause: More than one backup piece in the recovery catalog match the specified handle.

Action: Use the backup piece key to uniquely specify the backup piece.

RMAN-20270 invalid incremental backup level

Cause: An illegal incremental backup level was requested.

Action: Valid incremental backup levels are 1 through 4. Specify a valid level.

RMAN-20271 invalid incremental cumulative option

Cause: An internal error occurred.

Action: Contact Oracle Support Services.

RMAN-20272 no parent backup found for the incremental backup

Cause: No available backup or copy that could be used as the parent of the incremental backup was found in the recovery catalog.

Action: Take a level 0 backup or copy of the datafile first.

RMAN-20280 too many device types

Cause: More than 8 device types were allocated.

Action: Make sure that the job allocates at most 8 different device types.

RMAN-20298 DBMS_RCVCAT package not compatible with the recovery catalog

Cause: The version of the recovery catalog tables does not work with this version of the DBMS_RCVCAT package.

Action: Check that the recovery catalog packages and schema are installed correctly. The UPGRADE CATALOG command can be used to upgrade the recovery catalog tables and packages to the most current version.

RMAN-20299 DBMS_RCVMAN package not compatible with the recovery catalog

Cause: The version of the recovery catalog tables does not work with this version of the DBMS_RCVMAN package.

Action: Check that the recovery catalog packages and schema are installed correctly. The UPGRADE CATALOG command can be used to upgrade the recovery catalog tables and packages to the most current version.

RMAN-20300 operation not supported without the recovery catalog

Cause: An operation that requires a recovery catalog was requested, but no recovery catalog is in use.

Action: If a recovery catalog is available, restart RMAN and specify the a connect string for the recovery catalog database via the RCVCAT parameter.

RMAN-20310 proxy copy not found in the recovery catalog

Cause: The specified proxy copy is not in the recovery catalog or it has been marked deleted.

Action: Check the proxy copy handle or key.

RMAN-20311 ambiguous proxy copy handle

Cause: More than one proxy copy in the recovery catalog matches the specified handle.

Action: Use the proxy copy key to uniquely specify the proxy copy.

RMAN-20400 stored script not found

Cause: A CREATE SCRIPT or DELETE SCRIPT specified a script name that could not be found.

Action: Check the script name.

RMAN-20401 script already exists

Cause: A CREATE SCRIPT was issued, but a script with the specified name already exists.

Action: Use a different name or use REPLACE SCRIPT.

RMAN-20500 media recovery aborted

RMAN-20501 redo logs from parent database incarnation cannot be applied

Cause: A RESTORE or RECOVER of a datafile was requested, but recovery of the datafile would require applying redo logs that were generated before the most recent OPEN RESETLOGS.

Action: If a full backup or datafilecopy from the current database incarnation exists, then ensure that it is marked AVAILABLE and that a channel of the correct device type is allocated. It may also be necessary to remove the FROM BACKUPSET, FROM DATAFILECOPY, or FROM TAG operands if these have been specified.

RMAN-20502 DELETE EXPIRED cannot delete objects that exist - run CROSSCHECK

Cause: A DELETE EXPIRED command was run, but the object was actually found to exist. This means the recovery catalog or controlfile is out of sync.

Action: Run CROSSCHECK.

RMAN-20503 DELETE cannot delete expired objects - run CROSSCHECK or DELETE EXPIRED

Cause: A DELETE command was run without the EXPIRED option, but the object doesn't exist. This means the recovery catalog or controlfile is out of sync.

Action: Run CROSSCHECK.

RMAN-20504 corruption list not found in recovery catalog

Cause: The corruption list is empty.

Action: Make sure that one or more blocks are marked corrupt in V$COPY_CORRUPTION and V$BACKUP_CORRUPTION, and that the recovery catalog is up-to-date.


Core Library Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Part IV
Core Library Messages

This part contains the following chapters:

  • Chapter 26, "Parameter Messages (LRM)"
  • Chapter 27, "BFILE-Related Messages (LFI)"


Parameter Messages (LRM)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

26
Parameter Messages (LRM)

LRM-00100 internal error [number]

Cause: An internal error has occurred.

Action: Contact Oracle Support Services and report the error.

LRM-00101 unknown parameter name 'string'

Cause: The parameter name was misspelled.

Action: Spell the parameter name correctly.

LRM-00102 'string' is not in the legal range for 'string'

Cause: The value of the parameter is not within the legal range.

Action: Refer to the manual for the allowable values for this parameter.

LRM-00103 'string' contains an illegal integer radix for 'string'

Cause: An illegal integer radix specification was found.

Action: Only 'd', 'h', 'D', and 'H' may be used as radix specifications.

LRM-00104 'string' is not a legal integer for 'string'

Cause: The value is not a valid integer.

Action: Specify only valid integers for this parameter.

LRM-00105 'string' is not a legal Boolean for 'string'

Cause: The value is not a valid Boolean.

Action: Refer to the manual for allowable Boolean values.

LRM-00106 out of memory

Cause: The operating system has run out of memory.

Action: Take action to make more memory available to the program.

LRM-00107 parameter name abbreviation 'string' is not unique

Cause: The given abbreviation was not unique.

Action: Use a longer abbreviation to make the parameter name unique.

LRM-00108 invalid positional parameter value 'string'

Cause: An invalid positional parameter value has been entered.

Action: Remove the invalid positional parameter.

LRM-00109 could not open parameter file 'string'

Cause: The parameter file does not exist.

Action: Create an appropriate parameter file.

LRM-00110 syntax error at 'string'

Cause: A syntax error was detected.

Action: Change the input so that the correct syntax is used.

LRM-00111 no closing quote for value 'string'

Cause: A quoted string was started but not finished.

Action: Put a closing quote in the proper location.

LRM-00112 multiple values not allowed for parameter 'string'

Cause: An attempt was made to specify multiple values for a parameter which can take only one value.

Action: Do not specify more than one value for this parameter.

LRM-00113 error when processing file 'string'

Cause: A problem occurred when processing this file.

Action: Examine the additional error messages and correct the problem.

LRM-00114 error when processing from command line

Cause: A problem occurred when processing the command line.

Action: Examine the additional error messages and correct the problem.

LRM-00115 error when processing an environment variable

Cause: A problem occurred when processing an environment variable.

Action: Examine the additional error messages and correct the problem.

LRM-00116 syntax error at 'string' following 'string'

Cause: A syntax error was detected.

Action: Change the input so that the correct syntax is used.

LRM-00117 syntax error at 'string' at the start of input

Cause: A syntax error was detected.

Action: Change the input so that the correct syntax is used.

LRM-00118 syntax error at 'string' at the end of input

Cause: A syntax error was detected.

Action: Change the input so that the correct syntax is used.

LRM-00119 unable to obtain a valid value for 'string'

Cause: No valid value was obtained for this parameter.

Action: Rerun the application and enter a valid value.

LRM-00120 'string' is not a legal Oracle number for 'string'

Cause: The value is not a valid Oracle number.

Action: Refer to the manual for allowable Oracle number values.

LRM-00121 'string' is not an allowable value for 'string'

Cause: The value is not a legal value for this parameter.

Action: Refer to the manual for allowable values.

LRM-00122 value 'string' for 'string' must be between 'number' and 'number'

Cause: The value of the parameter is not within the legal range.

Action: Specify a value that is within the legal range.

LRM-00123 invalid character number found in the input file

Cause: A character that is invalid was found in the input file.

Action: Specify an input file that contains only valid characters.


BFILE-Related Messages (LFI)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

27
BFILE-Related Messages (LFI)

LFI-00000 Normal, successful completion.

Cause: An operation has completed normally, having met no exceptions.

Action: No action required.

LFI-00001 File IO Internal Error #number

Cause: An internal error occurred.

Action: Contact the development organization.

LFI-00002 Out of memory. string

Cause: The file I/O package failed in trying to dynamically allocate memory. function name is used for additional comments to indicate where, when and why the error occurred.

Action: Perform whatever actions necessary to make more memory available to the executing program.

LFI-00003 Internal exception code. icode = [string], [string].

Cause: Indicated by the parameters in the message. The first 'string' gives the internal exception code; the second is for any other additional comments.

Action: Report to the appropriate development group.

LFI-00004 Call to string failed.

Cause: A function call has failed. This error is a generic message to show that the exception has occurred in a particular function name. This allows the client to know the trace runtime calling sequence by examining the exception stack.

Action: See the accompanying error messages for more information.

LFI-00005 Free some memory failed in string.

Cause: A call to free some memory in function name has failed.

Action: See the accompanying error messages for more information and contact Oracle Support Services immediately.

LFI-00006 Invalid parameter to function string.

Cause: The function was called with an invalid parameter.

Action: Check the function call to make sure that the correct parameters are being passed.

LFI-00007 NLSRTL's call failed. string.

Cause: LX calls return failure.

Action: Check if the parameters are correct. Contact the appropriate group immediately if the parameters are valid.

LFI-00008 SLTS's initializing/terminating mutex failed for string.

Cause: SLTS's call return failure in function 'string'.

Action: Contact the appropriate development group.

LFI-00100 Unable to perform operation, file not opened in string.

Cause: The file has not been successfully opened at the time the operation is attempted.

Action: Check to make sure that the file exists (for read) or that the program has access to the write a file (for write). It is also possible that the file was just never opened.

LFI-00101 Write failed, file cannot be written to.

Cause: The buffer write operation failed. Possibly due to incorrect parameters being passed in.

Action: Check the underlying error for more information.

LFI-00102 Unable to seek in sequentially accessed file.

Cause: The file was opened with the flag LFILFA_SEQ for sequential file operations. Use seek only on files that are opened with the LFILFA_RANDOM flag for random access.

Action: Check to see how the file is being opened and accessed and make the two operations consistent (that is, make them both operations either sequential or random).

LFI-00103 Seek operation failed.

Cause: The buffer seek operation failed. Probably due to incorrect parameters or flags.

Action: Check syntax of the seek command and retry the operation.

LFI-00104 Read operation failed.

Cause: The buffer read operation failed. Probably due to incorrect parameters or flags.

Action: Check syntax of the read command and retry the operation.

LFI-00105 Unable to add path.

Cause: One of the following:

  • the current path might not be in the proper format
  • the directory might not be in the proper format
  • the name object might not have been initialized properly

Action: Check the format of the current path and the new directory; check that the name object was initialized properly.

LFI-00106 Path object holds more than one path.

Cause: The path object passed to LFIPPTH() holds more than one path.

Action: Make sure that the path object used in LFIPPTH() holds only one path.

LFI-00107 Open does not expect the file [string][string] to exist.

Cause: The flags specified for the open indicate that the file does not exist. However, the file does exist.

Action: Check to make sure that the options that were specified for the file are correct and that you do not expect that the file should exist. If so then find out why the file does exist.

LFI-00108 Open expect the file [string][string] to exist.

Cause: The flags specified for the open indicate that the file is expected to exist and it does not.

Action: Check to make sure that the options that were specified for the file are correct and that you expect that the file should exist. If so, then find out why the file does not.

LFI-00109 Unable to open file [string][string]. string.

Cause: Either:

  • the process does not have the proper access rights to open the file or
  • the file is already open

Action: Check to make sure the proper access permissions are assigned. If they are and the file still cannot be opened, then contact Oracle Support Services.

LFI-00110 Unable to initialize the Buffer Manager.

Cause: The Buffer Manager initialization routine failed, probably because memory was exhausted.

Action: See the accompanying error messages for more information.

LFI-00111 No other flags allowed in fixed length format.

Cause: Other options are specified with the fixed length format.

Action: Clear other options from flag.

LFI-00112 Invalid Standard File ID Descriptor.

Cause: The function LFIGFO() was called with an invalid File ID Descriptor. The valid File ID Descriptors are LFISTDIN, LFISTDOUT, and LFISTDERR.

Action: Check the call to LFIGFO() to make sure it is correct.

LFI-00113 Unable to initialize the Standard File object string.

Cause: The call to open the standard file object failed.

Action: Check the underlying errors for more information.

LFI-00114 Append is not allowed with string.

Cause: An attempt was made to append using certain options.

Action: Check the flag options to verify its usage.

LFI-00115 Buffer free failed.

Cause: The buffer flush failed.

Action: See the accompanying error messages for more information.

LFI-00116 Unable to close file in operation string.

Cause: The file close operation failed.

Action: See the accompanying error messages for more information.

LFI-00117 Unable to rename file.

Cause: The rename operation failed. Rename is called when a file is protected by operating on a temporary file.

Action: Check to make sure that the process has the correct access rights to perform a rename.

LFI-00118 Unable to change type to Unknown.

Cause: The function LFICHTY() was called to change the file extension to LFIEXUNK (Unknown). This is not a valid operation.

Action: Check why you are doing this. If the extension is already unknown then you do not need to do this. If you just want no extension then use the extension type LFIEXNONE.

LFI-00119 Unable to Abort an Unprotected file.

Cause: The Abort function LFIABT() was called on a file that was not opened as a protected file. As such the abort operation is not valid.

Action: Check to see if you intended to open the file as a protected file.

LFI-00120 Unable to parse root filename string.

Cause: The root file name that was given to LFIMKNAM() is not in a format that this platform understands.

Action: Check the format of the file name and retry the operation.

LFI-00121 Only one of REPLACE, or PROT allowed for opty.

Cause: Both of the following open type options were specified for the LFILINI() function: LFILOPTY_REPLACE or LFILOPTY_PROT.

Action: Remove one of the options so that you are only passing in one option.

LFI-00122 Can only delete a file if we create it.

Cause: The delete file flag was specified for a file that was not created by this file operation. The ability to delete a file is not portable. As such, the only deletion that is allowed by this package is if Oracle knows the file should be deleted when Oracle created it.

Action: You can only delete a file that you create. If you need to delete a file that you do not create then you will have to find another means of doing so.

LFI-00123 Cannot access file Sequentially and Randomly.

Cause: Both the LFILFA_SEQ (sequential) and LFILFA_RANDOM (random) flags were specified during the file object creation. This is not allowed. Only one of the two may be specified.

Action: Choose how you wish to access the file. If you choose random you can still access sequentially by just not using the repositioning functions.

LFI-00124 No access mode was specified, default is sequential.

Cause: Neither LFILFA_SEQ (sequential) or LFILFA_RANDOM (random) were specified during file object creation.

Action: The default is sequential but this should be explicitly set.

LFI-00125 Random access only allowed on fixed length record files.

Cause: The LFILFA_RANDOM flag was specified on a file that was not organized into fixed-length records. Random access is only allowed on fixed-length record files.

Action: Determine if the organization of your data needs to be in variable-length records and if you need to have random access to the file. If both conditions are true then you might need to buffer the entire file or enough of it to remove your need for random access. Another option is to close and rescan the file although this is not the optimal solution.

LFI-00126 Record format can only be one of Fixed or Variable.

Cause: Both LFILRF_FIXED (fixed) and LFILRF_VAR (variable) were specified during file object creation. Only one of the two is allowed for a given file.

Action: Determine how the file is organized and choose the option that matches.

LFI-00127 No Record Format was specified, default is variable.

Cause: Neither LFILRF_FIXED (fixed) or LFILRF_VAR (variable) were specified for record format. One of the two must be specified for each file.

Action: The default is LFILRF_VAR, but this should be explicitly set during file object creation.

LFI-00128 Carriage Control is only valid for Standard file objects.

Cause: The Carriage Control option is only valid for the standard file objects (LFISTDIN, LFISTDOUT, LFISTDERR). You may not specify this option for any other type of file.

Action: Choose between LFILRF_FIXED and LFILRF_VAR for the record format.

LFI-00129 Invalid option string were specified on an input only file.

Cause: The file was opened as input only but the output mode option LFILRF_WR_ASIS or delete option LFLOPTY_DELETE was specified.

Action: Check to see how you intend to open this file and make the necessary changes.

LFI-00130 Input option specified on output only file.

Cause: The file was opened as output only but one of the input mode options (LFILRF_READ_NL or LFILRF_FORCE_NL) or was specified.

Action: Check to see how you intend to open this file and make the necessary changes.

LFI-00131 No open type specified.

Cause: The file object was created without an open type (that is, LFILOPTY_INPUT, LFILOPTY_OUTPUT, and so on).

Action: Decide how the file should be accessed and specify one of the open types.

LFI-00132 Record length string is greater than max length of string.

Cause: The record length specified for the file is greater than the maximum supported by this platform.

Action: Decrease the record length.

LFI-00133 Trying to create file string that already exists.

Cause: The file object was initialized with LFILOPTY_OUTPUT and without LFILOPTY_REPLACE and yet a file by this name already exists.

Action: Check to make sure that you are creating the right file. If you intend to overwrite the file if it exists that specify the replace option LFILOPTY_REPLACE when initializing the file object.

LFI-00134 Unable to protect a file for an append operation.

Cause: The LFILOPTY_APPEND and LFILOPTY_PROT options were both specified for the file. This is currently not allowed because it would require copying the entire file at open time.

Action: Decide if you really need to protect the file for append. If so then think about making a copy of it before appending.

LFI-00135 Unable to remove temporary file.

Cause: A temporary file was created to protect a file. When the temporary file was no longer needed, LFI attempted to remove it and was unable to do so.

Action: Check the permissions and where the temporary files are being created.

LFI-00136 Unable to change type of open file.

Cause: The function LFICHTY() was called on an opened file.

Action: This is a bug in the client code. LFICHTY() cannot be used in this case.

LFI-00137 Unable to perform string on a file object that is string.

Cause: Unable to perform an LFI operation on a file object for the given reason.

Action: Take the appropriate corrective measure. For example if a file is supposed to be opened before the operation can be performed, client code will need to open the file first.

LFI-00138 Unable to perform string on a name object that is string.

Cause: Unable to perform an LFI operation on a name object for the given reason.

Action: Take the appropriate corrective measure.

LFI-00139 Option string cannot be used with option string in calling string.

Cause: First option cannot be used with second option in such a function call.

Action: Re-examine code to determine which option is needed.

LFI-00140 Invalid option string were specified on input-output file.

Cause: The file was opened as input-output and one of the mode options (LFIOPTY_DELETE or non-LFIOPTY_RANDOM) was specified.

Action: Check to see how you intend to open this file and make the necessary changes.

LFI-00141 Unable to abort file in operation string.

Cause: The abort operation failed.

Action: Check the underlying errors for more information.

LFI-00142 Unable to delete an existing file [string][string] not owned by Oracle.

Cause: The file was not created by Oracle.

Action: Change owner of file to Oracle or give Oracle access privileges to delete it.

LFI-00143 Unable to delete non-existent file string.

Cause: The file to be deleted does not exist.

Action: Check the underlying errors for more information.

LFI-00144 File [string][string] does not exist

Cause: The file does not exist.

Action: Check to make sure the file exists and retry the operation.

LFI-00145 User buffer too short.

Cause: The buffer that was passed is not large enough.

Action: Allocate a larger buffer and retry the operation.

LFI-00146 copy does not expect the file string.string to exist

Cause: The destination file was not expected to exist and it does.

Action: Find out why the file does exist.

LFI-00147 File string.string does not exist

Cause: The file does not exist.

Action: Check to make sure the file exists and retry the operation.

LFI-00148 string can be called only on files opened in byte mode

Cause: A routine that should be used only for files in byte mode was called for a file that was opened in record mode.

Action: In order to use this function, the file should be opened in byte mode.

LFI-00149 Error on destroying hash table in function string

Cause: The cache path object was expected and it does not exist.

Action: In order to use this function, the path object should be the cache path object.

LFI-00150 Error on creating hash table in function string

Cause: A routine failed to create path object hash table.

Action: Make sure that the value of STARTSIZE is less than or equal to the value of LHTQMAXSLOTS.

LFI-00151 Error on inserting into hash table in function string

Cause: A routine failed to insert into the hash table.

Action: Make sure there is enough memory for allocation and that the hash table exists.

LFI-00152 Read operation (byte mode) failed.

Cause: Byte mode read operation failed. Probably due to incorrect parameters or flags, or trying to read beyond end of file.

Action: Check syntax of the read command and size of file.

LFI-01000 Unable to write line to file.

Cause: The file being written to may no longer be open or the end of the file may have been reached.

Action: Examine underlying errors for more information.

LFI-01001 Unable to write string bytes to file.

Cause: The file being written to may no longer be open or the end of the file may have been reached.

Action: Examine underlying errors for more information.

LFI-01002 Unable to read line from file.

Cause: The file being read from may no longer be open.

Action: Examine underlying errors for more information.

LFI-01003 Unable to read string bytes from file.

Cause: The file being read from may no longer be open.

Action: See the accompanying error messages for more information.

LFI-01004 Unable to empty buffer.

Cause: The Buffer Manager is probably unable to write to the underlying file.

Action: Examine underlying errors for more information.

LFI-01005 Unable to fill buffer.

Cause: The Buffer Manager is probably unable to read from the underlying file.

Action: See the accompanying error messages for more information.

LFI-01006 File ends in partial character in string.

Cause: A line ends in a partial character.

Action: Examine underlying errors for more information.

LFI-01007 Line is too long; encountered in function string.

Cause: The length of the line exceeds the maximum length.

Action: Examine underlying errors for more information.

LFI-01500 Error condition on call to OSD function string.

Cause: An error condition arises in calling an OSD function. This message occurs if calls to MALLOC or free functions failed.

Action: Contact Oracle Support Services.

LFI-01501 tmpnam() fails to generate temporary file name.

Cause: Operating system was unable to create temporary file name.

Action: Contact the development organization.

LFI-01502 Base filename does not exist.

Cause: The file name that was parsed had no base file. It was either all path or extension.

Action: Check the file name being passed in to make sure it is correct.

LFI-01503 Max filename size exceeded generating filename.

Cause: While building a file name, the buffer allocated to hold the new file name was exceeded.

Action: Contact the development organization.

LFI-01504 fseek() failed(OSD return value = string) in string.

Cause: The function FSEEK() returned an error condition.

Action: Contact Oracle Support Services.

LFI-01505 fclose() failed(OSD return value = string) in string.

Cause: The function FCLOSE() returned an error condition.

Action: Contact Oracle Support Services.

LFI-01506 fflush() failed(OSD return value = string).

Cause: The function FFLUSH() returned an error condition.

Action: Contact the development organization.

LFI-01507 fwrite() failed(OSD return value = string) in string.

Cause: File pointer may be null or may not be opened for write.

Action: Contact the development organization.

LFI-01508 access() failed.

Cause: Call to ACCESS() failed.

Action: Contact the development organization.

LFI-01509 fopen() failed(OSD return value = string).

Cause: Call to FOPEN() failed.

Action: Contact Oracle Support Services.

LFI-01510 fread() failed(OSD return value = string) in string.

Cause: Call to FREAD() failed.

Action: Contact Oracle Support Services.

LFI-01511 unlink() failed(OSD errno = string) in string.

Cause: Call to UNLINK() failed.

Action: Contact the development organization.

LFI-01512 stat() failed

Cause: Call to STAT() failed.

Action: Contact Oracle Support Services.

LFI-01514 ftell() failed in string

Cause: The FTELL() function returned an error.

Action: Contact Oracle Support Services.

LFI-01515 truncate() failed.

Cause: The function TRUNCATE() returned an error condition.

Action: Contact the development organization.

LFI-01516 read() failed (OSD return value = string) in string.

Cause: Call to READ() failed.

Action: Contact the development organization.

LFI-01517 open() failed(OSD return value = string).

Cause: Call to OPEN() failed.

Action: Contact the development organization.

LFI-01518 write() failed(OSD return value = string) in string.

Cause: Call to WRITE() failed.

Action: Contact the development organization.

LFI-01519 llseek() failed(OSD return value = string) in string.

Cause: The LLSEEK() function returned an error.

Action: Contact Oracle Support Services.

LFI-01520 close() failed(OSD return value = string) in string.

Cause: The function CLOSE() returned an error condition.

Action: Contact the development organization.

LFI-01521 fsync() failed(OSD return value = string) in string.

Cause: The function FSYNC() returned an error condition.

Action: Contact the development organization.

LFI-01522 opendir() failed.

Cause: The function OPENDIR() returned an error condition.

Action: Contact the development organization.

LFI0-01523 rename() failed.

Cause: The function RENAME() returned an error condition.

Action: Contact the development organization.


PL/SQL Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Part V
PL/SQL Messages

This part contains the following chapter:

  • Chapter 28, "PL/SQL and FIPS Messages (PLS)"


PL/SQL and FIPS Messages (PLS)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

28
PL/SQL and FIPS Messages (PLS)

This chapter lists messages generated by PL/SQL. For more information about PL/SQL, refer to the PL/SQL User's Guide and Reference.

PLS-00102 parser stack overflow because nesting is too deep

Cause: The parser, which checks the syntax of PL/SQL statements, uses a data structure called a stack; the number of levels of nesting in the PL/SQL block exceeded the stack capacity.

Action: Reorganize the block structure to avoid nesting at too deep a level. For example, move the lowest-level sub-block to a higher level.

PLS-00103 found 'string' but expected one of the following: 'string'"},

Cause: This error message is from the parser. It found a token (language element) that is inappropriate in this context.

Action: Check previous tokens as well as the one given in the error message. The line and column numbers given in the error message refer to the end of the faulty language construct.

PLS-00104 empty argument list in call of procedure 'string' must be omitted

Cause: In a subprogram call, the name of the subprogram was followed by an empty parameter list. For example, procedure P was called as P(). This is not allowed.

Action: Remove the empty parameter list. In the example, change the procedure call to P.

PLS-00105 at most one forward declaration of type 'string' is permitted

Cause: More than one forward declaration of a type is redundant.

Action: Remove all but one forward declaration.

PLS-00108 declarative units must be a single variable declaration

Cause: While checking a declarative unit (a top-level declare block without the BEGIN...END), PL/SQL found that there was more than one item declared or that the item was not a variable declaration. A table is a common variable declaration at the unit level. To define a TABLE, compile a DECLARE compilation unit, but only one at a time is allowed.

Action: Declare variables in separate declarative units.

PLS-00109 unknown exception name 'string' in PRAGMA EXCEPTION_INIT

Cause: No declaration for the exception name referenced in an EXCEPTION_INIT pragma was found within the scope of the pragma.

Action: Make sure the pragma follows the exception declaration and is within the same scope.

PLS-00110 bind variable 'string' not allowed in this context

Cause: A bind variable, that is, an identifier prefixed with a colon, was found in an inappropriate context.

Action: Remove the colon or replace the bind variable with the appropriate object.

PLS-00111 end-of-file in comment

Cause: A Comment had a comment initiator (/*), but before the Comment terminator (*/) was found, an end-of-file marker was encountered.

Action: Remove the Comment initiator or add a comment terminator. The line and column numbers accompanying the error message refer to the beginning of the last legal token before the Comment initiator.

PLS-00112 end-of-line in quoted identifier

Cause: A quoted identifier had a beginning quote ("), but before the ending quote (") was found, an end-of-line marker was encountered.

Action: Remove the beginning quote or add the ending quote. The line and column numbers accompanying the error message refer to the beginning of the quoted identifier.

PLS-00113 END identifier 'string' must match 'string' at line string, column string

Cause: Following the keyword END, which terminates some language constructs (such as loops, blocks, functions, and procedures), you can optionally place the name of that construct. For example, at the end of the definition of loop L you might write END L. This error occurs when the optional name does not match the name given to the language construct. It is usually caused by a misspelled identifier or by faulty block structure.

Action: Make sure the spelling of the END identifier matches the name given to the language construct and that the block structure is correct.

PLS-00114 identifier 'string' too long

Cause: The name of a PL/SQL variable is longer than 30 characters. Legal identifiers (including quoted identifiers) have a maximum length of 30 characters. A string literal might have been mistakenly enclosed in double quotes instead of single quotes, in which case PL/SQL considers it a quoted identifier.

Action: Shorten the identifier.

PLS-00115 this PRAGMA must follow the declaration of 'string'

Cause: The pragma refers to a PL/SQL object that was not declared or is not within the scope of the reference. Identifiers must be declared before they are used in a pragma; forward references are not allowed.

Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.

PLS-00116 Duplicate where-clause in table expression

Cause: Two or more WHERE clauses were found in a DELETE, SELECT, or UPDATE statement. The WHERE clause specifies a condition under which rows in a table are processed. The condition can contain several logical expressions connected by AND or OR, but a statement can contain only one WHERE clause.

Action: Remove one of the WHERE clauses and, if necessary, connect logical expressions by AND or OR.

PLS-00117 Duplicate connect-by clause in table expression

Cause: Two or more CONNECT BY clauses were found in a SELECT statement. The CONNECT BY clause defines a relationship used to return rows in a hierarchical order. The relationship can contain two expressions separated by a relational operator (such as = or !=), but a statement can contain only one CONNECT BY clause.

Action: Remove one of the CONNECT BY clauses and, if necessary, separate expressions by a relational operator.

PLS-00118 Duplicate group-by clause in table expression

Cause: Two or more GROUP BY clauses were found in a SELECT statement. The GROUP BY clause lists column expressions used to form a summary row for each group of selected rows. The list can contain several column expressions separated by commas, but a statement can contain only one GROUP BY clause.

Action: Remove one of the GROUP BY clauses and, if necessary, separate column expressions by commas.

PLS-00119 Duplicate having-clause in table expression

Cause: Two or more HAVING clauses were found in a SELECT statement. The HAVING clause specifies a condition under which groups of rows (formed by the GROUP BY clause) are included in the result. The condition can include several logical expressions connected by AND or OR, but a statement can contain only one HAVING clause.

Action: Remove one of the HAVING clauses and, if necessary, connect logical expressions by AND or OR.

PLS-00120 inappropriate argument in OPEN statement

Cause: The CURSOR_NAME parameter in an OPEN statement is misspelled or does not refer to a legally declared cursor.

Action: Check the spelling of the CURSOR_NAME parameter. Make sure the cursor was declared properly.

PLS-00121 only the set function COUNT may take * as an argument

Cause: The asterisk (*) option was used in the argument list of a SQL group function other than COUNT. For example, the code might look like:

SELECT SUM(*) INTO emp_count FROM emp;  -- should be COUNT(*)

Only COUNT permits the use of the asterisk option, which returns the number of rows in a table.

Action: Remove the asterisk option from the argument list and replace it with an expression that refers to one or more database columns.

PLS-00122 string as separator is allowed only with specific built-in functions

Cause: A few built-in functions use keywords (instead of commas) as argument separators. A function different from one of these built-in functions is using a keyword as an argument separator.

Action: Correct the argument list or change the function name.

PLS-00123 program too large

Cause: PL/SQL was designed primarily for robust transaction processing. One consequence of the special-purpose design is that the PL/SQL compiler imposes a limit on block size. The limit depends on the mix of statements in the PL/SQL block. Blocks that exceed the limit cause this error.

Action: The best solution is to modularize the program by defining subprograms, which can be stored in an Oracle database. Another solution is to break the program into two sub-blocks. Have the first block INSERT any data the second block needs into a temporary database table. Then, have the second block SELECT the data from the table.

PLS-00124 name of exception expected for first arg in exception_init pragma

Cause: The first argument passed to the EXCEPTION_INIT pragma was something other than an exception name. The first argument must be the name of a legally declared exception.

Action: Replace the first argument with the name of a legally declared exception.

PLS-00125 type name expected

Cause: When a constant or variable was declared, its datatype was not specified. For example, the code might look like:

pi  CONSTANT := 3.14159;  -- should be CONSTANT REAL := 3.14159

Every constant and variable must have a datatype, which specifies a storage format, constraints, and valid range of values.

Action: Supply the type name.

PLS-00126 selector ALL is not allowed

Cause: The ALL shortcut for specifying system privileges or statement options was used in a SQL statement. PL/SQL does not support the ALL shortcut.

Action: Remove the ALL shortcut from the SQL statement.

PLS-00127 Pragma string is not a supported pragma

Cause: The named pragma (compiler directive) is not among those supported by PL/SQL. The pragma name might be misspelled, or the pragma syntax might be faulty.

Action: Check the spelling of the pragma name, and make sure the proper syntax was used.

PLS-00128 Illegal number of arguments for pragma string

Cause: The number of arguments (actual parameters) passed to the named pragma (compiler directive) is incorrect. A required argument was omitted from the argument list, or the pragma syntax is faulty (for example, a comma might be missing between two parameters).

Action: Supply the missing argument, or correct the faulty syntax.

PLS-00129 Pragma INTERFACE only supports C as its first argument

Cause: The first parameter passed to pragma INTERFACE specified a host language other than C. Currently, C is the only host language supported. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action: Check the spelling of the first parameter, which should be C, and make sure the proper syntax was used.

PLS-00130 Pragma string expects 1st argument to be a procedure/function/package/cursor

Cause: The first argument (actual parameter) passed to the named pragma (compiler directive) was not the name of a subprogram, package, or cursor, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action: Check the spelling of the first parameter, and make sure the proper syntax was used.

PLS-00131 Pragma string expects 2nd argument to be a procedure

Cause: The second argument (actual parameter) passed to the named pragma (compiler directive) was not the name of a procedure, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action: Check the spelling of the second parameter, and make sure the proper syntax was used.

PLS-00132 Pragma RESTRICT_REFERENCES does not support string

Cause: One of the parameters passed to pragma RESTRICT_REFERENCES was not among the following, as required: WNDS, WNPS, RNDS, RNPS. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters)

Action: Check the spelling of all the parameters, and make sure the proper syntax was used.

PLS-00133 Pragma string expects 1st argument to be an identifier or string-literal

Cause: The first argument (actual parameter) passed to the named pragma (compiler directive) was not an identifier or string literal, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action: Check the spelling of the first parameter, and make sure the proper syntax was used.

PLS-00134 Pragma string expects 2nd argument to be an identifier or string-literal

Cause: The second argument (actual parameter) passed to the named pragma (compiler directive) was not an identifier or string literal, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action: Check the spelling of the second parameter, and make sure the proper syntax was used.

PLS-00135 Pragma string expects 3rd argument to be an identifier, string or numeric literal

Cause: The third argument (actual parameter) passed to the named pragma (compiler directive) was not an identifier or string literal, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action: Check the spelling of the third parameter, and make sure the proper syntax was used.

PLS-00138 Precision for a binary type must be one of 8, 16, or 32

Cause: Invalid precision was specified for a signed or unsigned binary type.

Action: Specify precision as one of 8, 16, or 32.

PLS-00139 duplicate external NAME specification in subprogram expression

Cause: The subprogram was found to have two external NAME specifications.

Action: Remove one of the external NAME specifications.

PLS-00140 duplicate external LIBRARY specification in subprogram expression

Cause: The subprogram was found to have two external LIBRARY specifications.

Action: Remove one of the external LIBRARY specifications.

PLS-00141 duplicate external PARAMETER STYLE specification in subprogram expression

Cause: The subprogram was found to have two external PARAMETER STYLE specifications.

Action: Remove one of the external PARAMETER STYLE specifications.

PLS-00142 duplicate external PARAMETER list specification in subprogram expression

Cause: The subprogram was found to have two external PARAMETER STYLE specifications.

Action: Remove one of the external PARAMETER STYLE specifications.

PLS-00143 duplicate external LANGUAGE specification in subprogram expression

Cause: The subprogram was found to have two external LANGUAGE specifications.

Action: Remove one of the external LANGUAGE specifications.

PLS-00144 duplicate external CALLING STANDARD specification in subprogram expression

Cause: The subprogram was found to have two external CALLING STANDARD specifications.

Action: Remove one of the external CALLING STANDARD specifications.

PLS-00145 duplicate external WITH CONTEXT specification in subprogram expression

Cause: The subprogram was found to have two external WITH CONTEXT specifications.

Action: Remove one of the external WITH CONTEXT specifications.

PLS-00146 duplicate external TRUSTED/UNTRUSTED specification in subprogram expression

Cause: The subprogram was found to have two external TRUSTED/UNTRUSTED specifications.

Action: Remove one of the external TRUSTED/UNTRUSTED specifications.

PLS-00147 LIBRARY file specification string is empty

Cause: A zero-length string was found for the LIBRARY file specification.

Action: Specify a non-zero length string for the LIBRARY file specification.

PLS-00148 Only 1 pragma of this type is allowed per subprogram

Cause: The subprogram was found to have two PRAGMA RESTRICT_REFERENCES.

Action: Remove one of the PRAGMA RESTRICT_REFERENCES.

PLS-00150 found: string but expected : INTEGER

Cause: This error happens in the creation of a PL/SQL external type: [SIGNED | UNSIGNED] BINARY INTEGER (precision). It may be referenced only in a create type statement. Such types are non-queryable. Something other than 'INTEGER' was supplied.

Action: Use a different type and retry the operation.

PLS-00151 Expression or Variable is an illegal type to PLS/QL: string

Cause: A type was used which does not belong PL/SQL. This type can only be referenced in CREATE TYPE statements, and is a non-queryable data type.

Action: Use a different type and retry the operation.

PLS-00152 POINTER type may only reference an object type.

Cause: A POINTER type which does not belong to PL/SQL can only refer to an object type. This type can only be referenced in CREATE TYPE statements, and is a non-queryable data type.

Action: Use a different type and retry the operation.

PLS-00153 A string type may only be used as an object type attribute.

Cause: A POINTER or [SIGNED/UNSIGNED] BINARY INTEGER can only be used as attributes of object types. These types can only be referenced in CREATE TYPE statements, and are non-queryable data types. One of these external PL/SQL types outside of an object type.

Action: Use a different type and retry the operation.

PLS-00154 An object type may have only 1 MAP or 1 ORDER method.

Cause: More than one map or order function was declared. An object type can have only one map function or one order function, but not both.

Action: Delete all but one of the MAP or ORDER functions on the type.

PLS-00155 Only a function may be a MAP, ORDER or CONSTRUCTOR method.

Cause: A procedure was declared as a MAP, ORDER, or CONSTRUCTOR method. Only functions can be MAP, ORDER, or CONSTRUCTOR methods.

Action: Change the procedure to a function.

PLS-00156 Null constraints not supported for object attributes.

Cause: A null constraint was specified for an attribute in an object. This is not supported.

Action: Remove the constraint.

PLS-00157 AUTHID only allowed on schema-level programs

Cause: An AUTHID clause was specified for a subprogram inside a package or type. These clauses are only supported for top-level stored procedures, packages, and types.

Action: Remove the clause.

PLS-00160 AUTHID must specify CURRENT_USER or DEFINER

Cause: The only two allowed options for AUTHID are CURRENT_USER and DEFINER.

Action: Fix the AUTHID clause to specify CURRENT_USER or DEFINER.

PLS-00161 Pragma string expects 3rd argument to be an identifier or a string literal

Cause: The third argument (actual parameter) passed to the named pragma (compiler directive) was not an identifier or a string literal when there is a fourth argument to the pragma. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action: Check the spelling of the third parameter, and make sure the proper syntax was used.

PLS-00162 Pragma string expects 4th argument to be a positive integer literal

Cause: The fourth argument (actual parameter) passed to the named pragma (compiler directive) was not a numeric literal, as required. The parameter might be misspelled, or the pragma syntax might be faulty (for example, a comma might be missing between two parameters).

Action: Check the spelling of the fourth parameter, and make sure the proper syntax was used.

PLS-00164 cursor subqueries are not supported in this release

Cause: This feature is not yet implemented.

Action: No action required.

PLS-00165 call statement is not supported in PL/SQL

Cause: A CALL statement was found in PL/SQL source.

Action: Use an ordinary PL/SQL function or procedure call.

PLS-00166 bad format for date, time, or timestamp literal

Cause: The contents of the date, time, or timestamp literal did not match the expected format 'yyyy-mm-dd hh24:mi:ssxfftzh:tzm'.

Action: Use a correctly-formatted datetime literal.

PLS-00167 keyword BULK is used in a wrong context

Cause: Keyword BULK is used illegally. For example, BULK is used without INTO clause.

Action: Remove the BULK keyword.

PLS-00168 duplicate modifier specification 'string'

Cause: A method or object type modifier was specified more than once.

Action: Remove all but one occurrence of the duplicate modifier.

PLS-00169 modifier 'string' conflicts with prior 'string' specification

Cause: The method or object type modifier specified conflicts with an earlier modifier. For example, a FINAL modifier cannot be combined with a NOT FINAL modifier.

Action: Remove one of the conflicting modifiers.

PLS-00170 the SQL statement in an OPEN statement or FOR loop must be a SELECT

Cause: An OPEN cursor statement or cursor FOR loop can only invoke a SELECT statement, not an UPDATE, INSERT, or DELETE.

Action: Use only SELECT statements in OPEN or cursor FOR loops.

PLS-00171 duplicate dedicated AGENT specification in subprogram expression

Cause: The subprogram was found to have two dedicated AGENT specifications.

Action: Remove one of the dedicated AGENT specifications.

PLS-00201 identifier 'string' must be declared

Cause: An attempt was made to reference either an undeclared variable, exception, procedure, or other item, or an item to which no privilege was granted or an item to which privilege was granted only through a role.

Action:

  1. Check your spelling and declaration of the referenced name.
  2. Verify that the declaration for the referenced item is placed correctly in the block structure.
  3. If the referenced item is indeed declared but you do not have privileges to refer to that item, for security reasons, you will be notified only that the item is not declared.
  4. If the referenced item is indeed declared and you believe that you have privileges to refer to that item, check the privileges; if the privileges were granted only via a role, then this is expected and documented behavior.

Stored objects (packages, procedures, functions, triggers, views) run in the security domain of the object owner with no roles enabled except PUBLIC. Again, you will be notified only that the item was not declared.

PLS-00202 type 'string' must be declared

Cause: An attempt was made to reference an undefined type. Either the type specifier was not declared or it is not within the scope of the reference.

Action: Check the spelling and declaration of the type specifier. Also confirm that the declaration is placed correctly in the block structure.

PLS-00203 function DECODE must be called with at least 3 non-boolean arguments

Cause: Less than three arguments were passed to the built-in function DECODE. Though DECODE takes a variable number of (non-Boolean) arguments, at least three arguments must be passed.

Action: Call DECODE with three or more arguments.

PLS-00204 function or pseudo-column 'string' may be used inside a SQL statement only

Cause: A pseudocolumn or proscribed function was used in a procedural statement. The SQL pseudocolumns (CURRVAL, LEVEL, NEXTVAL, ROWID, ROWNUM) can be used only in SQL statements. Likewise, certain functions such as DECODE, DUMP, and VSIZE and the SQL group functions (AVG, MIN, MAX, COUNT, SUM, STDDEV, VARIANCE) can be used only in SQL statements.

Action: Remove the pseudocolumn reference or function call from the procedural statement. Or, replace the procedural statement with a SELECT INTO statement; for example, replace:

bonus := DECODE(rating, 1, 5000, 2, 2500, ...);

with the following statement:

SELECT DECODE(rating, 1, 5000, 2, 2500, ...) INTO bonus FROM dual;

PLS-00205 Aggregate not allowed here

Cause: An aggregate, that is, a parenthesized list of values such as (7788, 'SCOTT', 20), was found in an inappropriate context.

Action: Remove or relocate the aggregate.

PLS-00206 %TYPE must be applied to a variable, column, field or attribute, not to "string"

Cause: The program object declared using the %TYPE datatype attribute is not of the appropriate class. It must be a variable, column, record component, subprogram formal parameter, or other object to which values can be assigned.

Action: Declare an object of the appropriate class or define the datatype in another way (for example, use %ROWTYPE).

PLS-00207 identifier 'string', applied to implicit cursor SQL, is not a legal cursor attribute

Cause: An identifier that is not a cursor attribute was applied to the identifier SQL. For example, this error occurs if the cursor attribute is misspelled.

Action: Check the spelling of the cursor attribute name. Make sure the attribute is one of these: %NOTFOUND, %FOUND, %ROWCOUNT, %ISOPEN.

PLS-00208 identifier 'string' is not a legal cursor attribute

Cause: An identifier not declared as a cursor attribute was applied to an identifier declared as a cursor. For example, this error occurs if the cursor attribute is misspelled.

Action: Check the spelling of the cursor attribute name. Make sure the attribute is one of these: %NOTFOUND, %FOUND, %ROWCOUNT, %ISOPEN.

PLS-00209 table 'string' is not in FROM clause

Cause: In a query, a table referenced by the select list is not named in the FROM clause.

Action: Check the spelling of the table names, make sure each column in the select list refers to a table in the FROM clause, then re-execute the query.

PLS-00210 an OTHERS clause is required in this CASE statement

Cause: Unless the clauses of a CASE statement mention all values of the type of the selecting expression, an OTHERS clause must be provided as the last clause of the CASE statement. It is impossible to cover all values of type INTEGER (or NUMBER), so an OTHERS clause is always required when the expression following the keyword CASE is of type INTEGER (or NUMBER).

Action: No action required since CASE statement not supported in releases 1.x,2.x, or 3.x.

PLS-00211 CASE labels or ranges must not be duplicated in different WHEN clauses

Cause: In this CASE statement, a value appears in more than one WHEN clause. A value may appear in at most one WHEN clause of a CASE statement.

Action: No action required since CASE statement not supported in releases 1.x,2.x, or 3.x.

PLS-00212 could not obtain enough memory to compile CASE statement

Cause: The CASE statement is too big. The compiler did not have enough storage to process it.

Action: No action required since CASE statement not supported in releases 1.x,2.x, or 3.x.

PLS-00213 package STANDARD not accessible

Cause: The PL/SQL compiler could not find package STANDARD in the current Oracle database. To compile a program, PL/SQL needs package STANDARD.

Action: Make sure that package STANDARD is available in the current Oracle database, then retry the operation.

PLS-00214 BEGIN...END block nesting is too deep

Cause: The number of levels of nesting in the PL/SQL block is too large. Blocks can be nested up to 255 levels deep, depending on the availability of system resources such as memory.

Action: Reorganize the block structure to avoid nesting at too deep a level. For example, move the lowest-level sub-block to a higher level.

PLS-00215 String length constraints must be in range (1 .. 32767)

Cause: When a character variable was declared, a length outside the legal range was specified. For example, the following declarations are illegal:

flag CHAR(0);        -- illegal; zero length name  VARCHAR2(-10);  -- illegal; negative length

Action: Change the length constraint, making sure that it lies in the range 1 .. 32767.

PLS-00216 NUMBER precision constraint must be in range (1 .. 38)

Cause: A NUMBER variable was declared with a precision that is outside the legal range. Declarations such as N NUMBER(800) or N NUMBER(123,10) are not supported.

Action: Change the illegal NUMBER precision constraint, making sure that it lies in the range 1 .. 38.

PLS-00217 NUMBER scale constraint must be in range (-84 .. 127)

Cause: A NUMBER variable was declared with a scale that is outside the legal range. Declarations such as N NUMBER(10,345) or N NUMBER(10,-100) are not supported.

Action: Change the illegal NUMBER scale constraint, making sure that it lies in the range -84 .. 127.

PLS-00218 a variable declared NOT NULL must have an initialization assignment

Cause: In general, variables that have no initialization clause in their declaration are automatically initialized to NULL. This is illogical for NOT NULL variables; therefore, an initialization clause is required.

Action: Add an initialization clause to the variable declaration. If the initialization is too complicated for the syntax, one can add a function call (in a later release).

PLS-00219 label 'string' reference is out of scope

Cause: A block or loop label was used to qualify a variable (as in outer_block.date) that was not declared or is not within the scope of the label. The variable name might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.

Action: Check the spelling and declaration of the variable name. Also confirm that the declaration is placed correctly in the block structure.

PLS-00220 simple name required in this context

Cause: A qualified name such as A.B or A.B.C is not permitted here.

Action: Use a simple name such as A instead.

PLS-00221 'string' is not a procedure or is undefined

Cause: An identifier being referenced as a procedure was not declared or actually represents another object (for example, it might have been declared as a function).

Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.

PLS-00222 no function with name 'string' exists in this scope

Cause: An identifier being referenced as a function was not declared or actually represents another object (for example, it might have been declared as a procedure).

Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.

PLS-00223 paramaterless procedure 'string' used as function

Cause: An identifier being referenced as a parameterless function actually represents a procedure.

Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure. If necessary, change the declaration of the identifier or change the reference so that it does not require a return value.

PLS-00224 object 'string' must be of type function or array to be used this way

Cause: An identifier being referenced as a function or an array actually represents an object (a number or date, for example) that cannot be referenced in this way.

Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.

PLS-00225 subprogram or cursor 'string' reference is out of scope

Cause: A subprogram or cursor references a variable that was not declared or is not within the scope of the subprogram or cursor. The variable name might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.

Action: Check the spelling and declaration of the variable name. Also confirm that the declaration is placed correctly in the block structure.

PLS-00226 package 'string' used as variable reference

Cause: A package was referenced in an expression as if it were a variable or function. Either the name of the variable or function is misspelled or the reference is not fully qualified. For example, to call the function my_function, which is stored in package my_package, dot notation must be used, as follows:

... my_package.my_function ...

Action: Correct the spelling of the variable or function name or use dot notation to reference the packaged variable or function.

PLS-00227 subprogram 'in' formal string is not yet denotable

Cause: When the formal parameters of a subprogram were declared, one parameter was used to initialize another, as in:

PROCEDURE my_proc (j NUMBER, k NUMBER := j) IS ...

The first parameter has no value until run time, so it cannot be used to initialize another parameter.

Action: Remove the illegal formal parameter reference.

PLS-00228 Illegal declaration of variable of type LONG

Cause: An attempt was made to declare a variables to be of type LONG. Only columns can be of type LONG.

Action: Remove the offending variable definition.

PLS-00229 Attribute expression within SQL expression

Cause: An attribute expression, such as SQL%NOTFOUND, was used in a SQL statement, but attribute expressions are allowed only in procedural statements.

Action: To workaround this limitation, assign the value of the attribute expression to a variable, then use the variable in the SQL statement. For example, replace the statement:

INSERT INTO audits VALUES (c1%ROWCOUNT, ...);

with the following statements:

row_count := c1%ROWCOUNT;INSERT INTO audits VALUES (row_count, ...);

PLS-00230 OUT and IN OUT formal parameters may not have default expressions

Cause: When the formal parameters of a procedure were declared, an OUT or IN OUT parameter was initialized to a default value, as in:

PROCEDURE calc_bonus (bonus OUT REAL := 00000, ...) IS ...

However, only IN parameters can be initialized to default values.

Action: Remove the illegal default expression.

PLS-00231 function 'string' may not be used in SQL

Cause: A proscribed function was used in a SQL statement. Certain functions such as SQLCODE and SQLERRM can be used only in procedural statements.

Action: Remove the function call from the SQL statement. Or, replace the function call with a local variable. For example, the following statement is illegal:

INSERT INTO errors VALUES (SQLCODE, SQLERRM);

However, you can assign the values of SQLCODE and SQLERRM to local variables, then use the variables in the SQL statement, as follows:

err_num := SQLCODE;err_msg := SQLERRM;  INSERT INTO errors VALUES (err_num, err_msg);

PLS-00232 nested packages not permitted

Cause: A package was declared inside another package, but package declarations are allowed only at the top level. In other words, packages cannot be nested.

Action: Move the package declaration outside the enclosing package.

PLS-00233 function name used as an exception name in when clause

Cause: The WHEN clause in an exception handler contains a function call instead of an exception name. A valid exception handler consists of a WHEN clause, which must specify an exception, followed by a sequence of statements to be executed when that exception is raised.

Action: Check the spelling of the identifier in the WHEN clause, then replace the function call with an exception name.

PLS-00234 PARAMETER STYLE SQL may not be specified with a PARAMATERS list

Cause: A subprogram cannot specify both PARAMETER STYLE SQL and an explicit PARAMETERS list. Use PARAMETER STYLE GENERAL to supply default PARAMETERS list types.

Action: Change the subprogram specification.

PLS-00235 the external type is not appropriate for the parameter

Cause: An unsuccessful attempt was made to convert a parameter to the specified external parameter type.

Action: Specify a different external type or parameter type.

PLS-00236 Invalid external type specification for string.

Cause: The external type specified is not valid for one of the following: INDICATOR, LENGTH, MAXLEN, TDO, DURATION, CHARSETID, or CHARSETFORM.

Action: Check PL/SQL User's Guide and Reference and specify an appropriate external type.

PLS-00237 invalid BY VALUE indicator or length specification

Cause: BY VALUE was specified with an indicator or length parameter that is being passed in OUT or IN OUT mode. Only IN mode parameters may be passed by value.

Action: Remove the BY VALUE specification or change it to IN mode.

PLS-00238 external parameter name string not found in formal parameter list

Cause: An external parameter name was specified that does not match one in the formal parameter list.

Action: Correct the external parameter name.

PLS-00239 invalid external type specification for SQLCODE

Cause: An inappropriate external parameter type was specified for the SQLCODE parameter.

Action: Correct the SQLCODE parameter specification.

PLS-00240 Invalid type specification for RETURN indicator, length, tdo, duration

Cause: An inappropriate external parameter type was specified for the RETURN indicator, LENGTH, TDO, or DURATION.

Action: Correct the RETURN parameter specification.

PLS-00241 invalid external type specification for SQLSTATE

Cause: An inappropriate external parameter type was specified for the SQLSTATE parameter.

Action: Correct the SQLSTATE parameter specification.

PLS-00242 invalid external type specification for CONTEXT

Cause: An inappropriate external parameter type was specified for the CONTEXT parameter.

Action: Correct the CONTEXT parameter specification.

PLS-00243 invalid external type specification for SQLNAME

Cause: An inappropriate external parameter type was specified for the SQLNAME parameter.

Action: Correct the SQLNAME parameter specification.

PLS-00244 Multiple declarations in foreign function formal parameter list

Cause: There are multiple declarations of at least one the following FORMAL, INDICATOR, LENGTH, MAXLENGTH, or CONTEXT. PL/SQL allows only one declaration of the above for each formal parameter in the PARAMETERS clause.

Action: Correct the PARAMETERS clause.

PLS-00245 Formals used in the 'parameters' clause must appear exactly once

Cause: There are multiple declarations of the formal parameter in the PARAMETERS clause. PL/SQL allows only one declaration of the formal parameter in the PARAMETERS clause.

Action: Correct the PARAMETERS clause.

PLS-00246 PARAMETER STYLE is unsupported

Cause: A PARAMETER STYLE clause was placed in the external subprogram body.

Action: Remove the PARAMETER STYLE clause.

PLS-00247 LIBRARY name must be specified

Cause: The LIBRARY name is missing from the external subprogram body.

Action: Specify the LIBRARY name in the external subprogram body.

PLS-00248 Invalid Library Syntax

Cause: The LIBRARY syntax was entered incorrectly.

Action: Correct the LIBRARY syntax and recompile.

PLS-00249 Invalid WITH CONTEXT Syntax

Cause: CONTEXT was used in a WITH CONTEXT or a PARAMETERS clause. This is invalid.

Action: Check if WITH CONTEXT is used without specifying CONTEXT in the PARAMETERS clause or vice versa. The PARAMETERS clause must be complete. Thus if WITH CONTEXT is specified, then CONTEXT must be referenced in the PARAMETERS clause (if there is one).

PLS-00250 Incorrect Usage of string in parameters clause.

Cause: The usage of Keywords such as MAXLEN, LENGTH, CHARSETID, CHARSETFORM RETURN in the parameters clause was incorrect

Action: This error occurs if keywords like MAXLEN, LENGTH, TDO, DURATION, CHARSETID, or CHARSETFORM cannot be used with PL/SQL formal parameters or the mode of the formal parameter. For example, MAXLEN can only be declared for a CHAR or VARCHAR2 PL/SQL variable and its use is allowed only for OUT or INOUT PL/SQL variables. Also, RETURN was specified in the parameters clause for a PL/SQL PROCEDURE. For example:

CREATE PROCEDURE proc IS EXTERNAL NAME ... LIBRARY ... PARAMETERS(RETURN INDICATOR SHORT, RETURN);

PLS-00251 RETURN, for actual function return, must be last in the parameters clause

Cause: RETURN specification for the actual function return, used within the parameters clause must hold the very last position. Example: The following will give this error since the RETURN specification for the actual function return in the parameters clause is not the last.

FUNCTION myexternalfunc (var1 BINARY_INTEGER, var2 BINARY_INTEGER)RETURN BINARY_INTEGER IS EXTERNALNAME "myexternalfunc" LIBRARY somelibPARAMETERS (var1 LONG, var2 SHORT, RETURN INT, RETURN INDICATOR SHORT);

The correct syntax is the following. Note that RETURN for actual function return is the last specification in the parameters clause.

FUNCTION myexternalfunc (var1 BINARY_INTEGER, var2 BINARY_INTEGER)RETURN BINARY_INTEGER IS EXTERNAL NAME "myexternalfunc"LIBRARY somelibPARAMETERS (var1 LONG, var2 SHORT, RETURN INDICATOR SHORT, RETURN INT);

Action: Correct the syntax of the RETURN specification in the parameters clause.

PLS-00252 reference to the wrong copy of package STANDARD

Cause: A reference is made to the fixed package version of STANDARD when the database is open, or to the on-disk version when the database is closed. Explicit use of a SYS.X$ package name can lead to this. One might also see this from a compilation that begins while the database is closed but has the bad luck to have another session open the database before compilation is complete. Another possible cause is having SET SERVEROUTPUT ON through SVRMGRL when doing an ALTER DATABASE CLOSE.

Action: Make use of on-disk versions of packages when the database is open and fixed (preloaded) versions when the database is closed. Do not attempt to use the wrong set. It should be quite hard to reference the wrong set, except by using SYS.X$ package names explicitly. Also, be sure to SET SERVEROUTPUT OFF before doing an ALTER DATABASE CLOSE.

PLS-00253 Formal parameter string missing in the parameters clause

Cause: The parameter clause does not have a matching parameter for a parameter specified in the formal parameter list.

Action: Provide a matching parameter in parameters clause for every formal parameter.

PLS-00254 OUT and IN/OUT modes cannot be used in this context

Cause: Actual parameter mode (OUT, or IN/OUT) is not used properly in USING clause. For USING clause in an OPEN statement, only IN mode is allowed.

Action: Change the parameter mode in the USING clause to an appropriate mode.

PLS-00255 CALL Specification parameters cannot have default values

Cause: CALL Specification formal parameters default values are disallowed.

Action: Remove the default values in the formal parameter list (specification or body) and compile again.

PLS-00256 string is not a valid external library

Cause: The supplied external library name in the external clause is not a valid alias library.

Action: Provide the name of a valid alias library that has been previously declared.

PLS-00257 illegal use of EXTERNAL clause in a TYPE or PACKAGE specification

Cause: An EXTERNAL Clause was detected in a TYPE Specification or a PACKAGE specification.

Action: Remove the EXTERNAL Clause and use the new CALL Specification syntax.

PLS-00258 constrained datatypes disallowed in CALL Specifications

Cause: A call specification for C or Java cannot have constraints on the PL/SQL formal parameter types. PL/SQL types which have constraints are NATURAL, NATURALN, POSITIVE, POSITIVEN, SIGNTYPE, INTEGER, INT, SMALLINT, DECIMAL, NUMERIC, DEC. This includes NOT NULL constraints from POSITIVEN, NATURALN.

Action: Use the unconstrained type for that PL/SQL formal declaration that is, NUMBER, BINARY_INTEGER or PLS_INTEGER

PLS-00259 rights model (AUTHID) must be specified

Cause: It is mandatory to specify the rights model if a PL/SQL PROCEDURE, FUNCTION, PACKAGE OR TYPE HAS CALL-Specifications.

Action: Add the AUTHID clause indicating the rights model.

PLS-00260 Datetime/Interval constraints must be in range (0 .. 9)

Cause: A Datetime/Interval variable or attribute was declared with a constraint outside the legal range.

Action: Change the illegal constraint.

PLS-00261 Java CALL Specification not yet allowed as a method in an object type

Cause: A call specification declaring that an implementation is in Java has been found for a method of an object or opaque type. This usage is not yet supported.

Action: Implement the method using a language other than Java. A PL/SQL method implementation is permitted to call to Java through a call specification provided as a schema-level procedure or in a package; such a call specification can only target a static Java method, however.

PLS-00302 component 'string' must be declared

Cause: In a reference to a component (for example, in the name "A.B", "B" is a component of "A"), the component has not been declared. The component might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.

Action: Check the spelling and declaration of the component. Also confirm that the declaration is placed correctly in the block structure.

PLS-00303 qualifier 'string' must be declared

Cause: In a name such as "A.B", "A" is the qualifier, and "B" is a component of the qualifier. This error occurs when no declaration for the qualifier is found. The qualifier might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.

Action: Check the spelling and declaration of the qualifier. Also confirm that the declaration is placed correctly in the block structure.

PLS-00304 cannot compile body of 'string' without its specification

Cause: The compiled package specification required to compile a package body could not be found. Some possible causes follow:

  • the package name is misspelled
  • the package specification was never compiled
  • the compiled package specification is not accessible

The package specification must be compiled before compiling the package body, and the compiler must have access to the compiled specification.

Action: Check the spelling of the package name. Compile the package specification before compiling the package body. Also, make sure the compiler has access to the compiled specification.

PLS-00305 previous use of 'string' (at line string) conflicts with this use

Cause: While looking for prior declarations of a cursor, procedure, function, or package, the compiler found another object with the same name in the same scope. Or, the headers of subprogram in a package specification and body do not match word for word.

Action: Check the spelling of the cursor, procedure, function, or package name. Also check the names of all constants, variables, parameters, and exceptions declared in the same scope. Then, remove or rename the object with the duplicate name. Or, change the headers of the packaged subprogram so that they match word for word.

PLS-00306 wrong number or types of arguments in call to 'string'

Cause: This error occurs when the named subprogram call cannot be matched to any declaration for that subprogram name. The subprogram name might be misspelled, a parameter might have the wrong datatype, the declaration might be faulty, or the declaration might be placed incorrectly in the block structure. For example, this error occurs if the built-in square root function SQRT is called with a misspelled name or with a parameter of the wrong datatype.

Action: Check the spelling and declaration of the subprogram name. Also confirm that its call is correct, its parameters are of the right datatype, and, if it is not a built-in function, that its declaration is placed correctly in the block structure.

PLS-00307 too many declarations of 'string' match this call

Cause: The declaration of a subprogram or cursor name is ambiguous because there was no exact match between the declaration and the call and more than one declaration matched the call when implicit conversions of the parameter datatypes were used. The subprogram or cursor name might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.

Action: Check the spelling and declaration of the subprogram or cursor name. Also confirm that it's call is correct, it's parameters are of the right datatype, and, if it is not a built-in function, that it's declaration is placed correctly in the block structure.

PLS-00308 this construct is not allowed as the origin of an assignment

Cause: The construct or expression does not designate a value that can be assigned to a variable. For example, the datatype name NUMBER cannot appear on the right hand side of an assignment statement as in X := NUMBER.

Action: Correct the illegal assignment statement.

PLS-00309 with %LAST attribute, 'string' must be a variable of an enumerated type

Cause: The "%LAST" attribute must be applied to an identifier that has been declared as a variable of an enumerated type (or subtype of an enumerated type). This error occurs when "%LAST" follows some identifier that has not been so declared.

Action: Make sure that %LAST follows an enumerated type (or subtype of an enumerated type).

PLS-00310 with %ROWTYPE attribute, 'string' must name a table, cursor or cursor-variable

Cause: The %ROWTYPE attribute must be applied to an identifier declared as a cursor, cursor variable, or database table. This error occurs when %ROWTYPE follows some identifier that has not been so declared.

Action: Change the declaration or do not apply the %ROWTYPE attribute to the identifier.

PLS-00311 the declaration of "string" is incomplete or malformed

Cause: This occurrence of the identifier cannot be compiled because its type has not been properly defined.

Action: Correct the faulty datatype declaration.

PLS-00312 a positional parameter association may not follow a named association

Cause: When a list of parameters is passed to a subprogram or cursor, if both positional and named associations are used, all positional associations must be placed in their declared order and before all named associations, which can be in any order.

Action: Reorder the parameter list to meet the requirements or use named association only.

PLS-00313 'string' not declared in this scope

Cause: There is no declaration for the given identifier within the scope of reference. The identifier might be misspelled, its declaration might be faulty, or the declaration might be placed incorrectly in the block structure.

Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.

PLS-00314 TABLE declarations are not allowed as PL/SQL local variables

Cause: In a precompiled program, the DECLARE TABLE statement was mistakenly used inside an embedded PL/SQL block. If an embedded PL/SQL block refers to a database table that does not yet exist, use the DECLARE TABLE statement to tell the precompiler what the table will look like. However, DECLARE TABLE statements are allowed only in the host program.

Action: Move the DECLARE TABLE statement outside the embedded PL/SQL block. If you want a variable that can store an entire row of data selected from a database table or fetched from a cursor or cursor variable, use the %ROWTYPE attribute.

PLS-00315 Implementation restriction: unsupported table index type

Cause: In the INDEX BY clause of a PL/SQL table declaration, a datatype other than BINARY_INTEGER, PLS_INTEGER, or VARCHAR2 was specified. PL/SQL tables can have one column and a primary key. The column can have any scalar type, but the primary key must be either a binary integer type or VARCHAR2.

Action: Use one of the supported key types in the INDEX BY clause.

PLS-00316 PL/SQL TABLEs must use a single index

Cause: In the INDEX BY clause of a PL/SQL table declaration, a composite primary key was specified. PL/SQL tables must have a simple, unnamed primary key of a binary integer or VARCHAR2 type.

Action: Use one of the supported key types in the INDEX BY clause.

PLS-00317 incomplete type "string" was not completed in its declarative region

Cause: An incomplete type declaration was not completed in the declarative region where it was declared.

Action: Complete the type appropriately, then retry the operation.

PLS-00318 type "string" is malformed because it is a non-REF mutually recursive type

Cause: A type-declaration such as:

-- non-REF recursive typetype t is record (a t);

or

-- non-REF mutually dependent typestype t1;type t2 is record (a t1);type t1 is record (a t2);

was entered.

Action: Use another type to remove the recursion.

PLS-00319 subquery in an IN or NOT IN clause must contain exactly one column

Cause: An invalid expression such as X IN (SELECT A,B ...) was used. When a [NOT]IN clause is used with a subquery, it does not test for set membership. The number of expressions in the [NOT]IN clause and the subquery select list must match. So, in the example above, the subquery must specify at most one column.

Action: Change the subquery to select only one column.

PLS-00320 the declaration of the type of this expression is incomplete or malformed

Cause: In a declaration, the name of a variable or cursor is misspelled or the declaration makes a forward reference. Forward references are not allowed in PL/SQL. A variable or cursor must be declared before it is referenced it in other statements, including other declarative statements. For example, the following declaration of dept_rec raises this exception because it refers to a cursor not yet declared:

DECLAREdept_rec  dept_cur%ROWTYPE; CURSOR dept_cur IS SELECT ...  ...

Action: Check the spelling of all identifiers in the declaration. If necessary, move the declaration so that it makes no forward references.

PLS-00321 expression 'string' is inappropriate as the left hand side of an assignment statement

Cause: The expression does not designate a variable that can have a value assigned to it. For example, the function SYSDATE cannot appear on the left hand side of an assignment statement such as:

SYSDATE := '01-JAN-1990';

Action: Correct the illegal assignment statement.

PLS-00322 declaration of a constant 'string' must contain an initialization assignment

Cause: A constant declaration lacks the assignment of an initial value. For example, in the following declaration" := 3.14159" is the initialization clause:

"pi constant number := 3.14159;"

Action: Correct the constant declaration by supplying the missing initialization assignment.

PLS-00323 subprogram or cursor 'string' is declared in a package specification and must be defined in the package body

Cause: A subprogram specification was placed in a package specification, but the corresponding subprogram body was not placed in the package body. The package body implements the package specification. So, the package body must contain the definition of every subprogram declared in the package specification.

Action: Check the spelling of the subprogram name. If necessary, add the missing subprogram body to the package body.

PLS-00324 cursor attribute may not be applied to non-cursor 'string'

Cause: This error occurs when a cursor-attribute ("%FOUND", "%NOTFOUND", "%ROWS", "%IS_OPEN", and so on) appears following an identifier that is not declared as a cursor or cursor variable. It occurs, for example, if the variable name my_cur in my_cur%FOUND was not properly declared as a cursor or if the variable declaration was placed incorrectly in the block structure.

Action: Check the spelling and declaration of the identifier. Also confirm that the declaration is placed correctly in the block structure.

PLS-00325 non-integral numeric literal string is inappropriate in this context

Cause: A non-integral numeric literal was used in a context that requires an integer (a number with no digits to the right of its decimal point).

Action: Replace the inappropriate literal with an integer literal.

PLS-00326 IN clause must contain same number of expressions as subquery

Cause: The number of expressions in an IN clause did not equal the number of expressions in a corresponding subquery select list. For example, the following statement is invalid because the IN clause contains two expressions, but the subquery select list contains just one:

... WHERE (ename, sal) IN (SELECT sal FROM emp);

Action: Check the number of expressions in each set, then revise the statement to make the numbers equal.

PLS-00327 "string" is not in SQL scope here

Cause: In a SQL statement, a reference was made to an out-of-scope database object. The referenced object might be misspelled, or the reference might be mixed, as in the following example:

CURSOR c1 IS SELECT dept.dname FROM emp;

Action: Check the spelling of all database objects in the SQL statement, and make sure all references are to objects within the current scope.

PLS-00328 A subprogram body must be defined for the forward declaration of string.

Cause: A subprogram specification was declared, but the corresponding subprogram body was not defined. Write the subprogram specification and body as a unit. An alternative solution is to separate the specification from its body, which is necessary when you want to define mutually recursive subprograms or you want to group subprograms in a package.

Action: Check the spelling of the subprogram name. If necessary, supply the missing subprogram body.

PLS-00329 schema-level type has illegal reference to string

Cause: An attempt was made to make a reference from a schema-level type to something other than a schema-level type.

Action: Replace the illegal reference and retry the operation.

PLS-00330 invalid use of type name or subtype name

Cause: A datatype or subtype specifier was mistakenly used in place of a constant, variable, or expression. For example, the code might look like:

IF emp_count > number THEN ... -- illegal; NUMBER is a datatype specifier

Action: Replace the datatype or subtype specifier with a valid constant, variable, or expression.

PLS-00331 illegal reference to string

Cause: One of the following:

  • An illegal reference to some object in user SYS. to use one of them in an illegal way
  • An illegal reference to a remote object type

Action: Remove the reference.

PLS-00332 "string" is not a valid prefix for a qualified name

Cause: A malformed qualified name was specified because the prefix is not valid.

Action: Remove or change the reference.

PLS-00333 "string" must match an object-table alias in this context

Cause: The name, appearing in the context of a REF or VALUE, did not resolve to an object-table alias.

Action:

  1. If there is no object table in the scope, then remove the REF or VALUE; or provide the missing object table reference.
  2. If there is an object table in the scope, but you are not referring to it, add the reference.

PLS-00334 "string" matches table or view without an alias

Cause: A reference was made to a table or view name without an alias.

Action: Replace the reference with a reference to an object-table alias.

PLS-00335 a package name conflicts with an existing object

Cause: In a CREATE PACKAGE statement, a package (which is a database object that groups logically related PL/SQL types, objects, and subprograms) was given the same name as an existing database object.

Action: Give the package a unique name.

PLS-00336 non-object-table "string" illegal in this context

Cause: A REF or VALUE modifier was specified for a non-object-table. This is not allowed in this context.

Action: Replace the reference with a reference to an object-table alias.

PLS-00337 "string" matches too many object table aliases

Cause: An ambiguous reference was made to an object-table alias; there are at least two object-table aliases in the same scope.

Action: Remove all but one of the references or change the alias names of the remaining.

PLS-00338 unable to resolve "string" as a column or row expression

Cause: A reference was made to a name that could not be resolved as a column or row expression. This occurred in an update or insert statement involving an object-table.

Action: If this is an update statement and you intended to code this as a column reference, fix it as such. If you intended to code this as a row expression, change this to refer to an alias of an object-table.

PLS-00339 "string" matches object-table without a REF or VALUE modifier

Cause: An object-table name was specified without a REF or VALUE modifier.

Action: If you intended to code this with a REF or VALUE modifier, add the modifier; if you intended to code this as a column reference, change the reference appropriately; otherwise, remove the reference.

PLS-00341 declaration of cursor 'string' is incomplete or malformed

Cause: A cursor declaration is improper or an identifier referenced in the cursor declaration was not properly declared. A return type that does not refer to an existing database table or a previously declared cursor or cursor variable might have been specified. For example, the following cursor declaration is illegal because c1 is not yet fully defined:

CURSOR c1 RETURN c1%ROWTYPE IS SELECT ...  -- illegal

In this case, a return type does not have to be specified because it is implicit.

Action: Check the spelling and declaration of the cursor name and any identifiers referenced in the cursor declaration. Also confirm that the declaration is placed correctly in the block structure. If a return type was specified, make sure that it refers to an existing database table or a previously declared cursor or cursor variable.

PLS-00351 Not logged onto database 'string'

Cause: An attempt was made to access an Oracle database without being logged on. Probably, an invalid username or password was entered.

Action: Log on to Oracle with a correctly spelled username and password before trying to access the database.

PLS-00352 Unable to access another database 'string'

Cause: An attempt was made to reference an object in a database other than the current local or remote Oracle database.

Action: Correct the reference and make sure the object is in the current Oracle database.

PLS-00353 'string' must name a user in the database

Cause: This error occurs when the username was misspelled or when the user does not exist in the database.

Action: Check the spelling of the username and make sure the user exists.

PLS-00354 username must be a simple identifier

Cause: A qualified username such as scott.accts is not permitted in this context.

Action: Specify a simple username such as scott instead.

PLS-00355 use of pl/sql table not allowed in this context

Cause: A PL/SQL table was referenced in the wrong context (for example, with a remote link).

Action: Remove the PL/SQL table reference or change the context.

PLS-00356 'string' must name a table to which the user has access

Cause: The named table is not accessible to the user. This error occurs when the table name or username was misspelled, the table and/or user does not exist in the database, the user was not granted the necessary privileges, or the table name duplicates the name of a local variable or loop counter.

Action: Check the spelling of the table name and username. Also confirm that the table and user exist, the user has the necessary privileges, and the table name does not duplicate the name of a local variable or loop counter.

PLS-00357 Table,View Or Sequence reference 'string' not allowed in this context

Cause: A reference to database table, view, or sequence was found in an inappropriate context. Such references can appear only in SQL statements or (excluding sequences) in %TYPE and %ROWTYPE declarations. Some valid examples follow:

SELECT ename, emp.deptno, dname INTO my_ename, my_deptno, my_deptFROM emp, dept WHERE emp.deptno = dept.deptno;DECLARElast_name  emp.ename%TYPE; dept_rec   dept%ROWTYPE;

Action: Remove or relocate the illegal reference.

PLS-00358 column 'string' exists in more than one table; use qualifier

Cause: The statement is ambiguous because it specifies two or more tables having the same column name. For example, the following statement is ambiguous because deptno is a column in both tables:

SELECT deptno, loc INTO my_deptno, my_loc FROM emp, dept;

Action: Precede the column name with the table name (as in emp.deptno) so that the column reference is unambiguous.

PLS-00359 assignment target in 'string' must have components

Cause: An assignment target was declared that lacks the components needed to store the assigned values. For example, this error occurs if you try to assign a row of column values to a variable instead of a record, as follows:

DECLARE dept_rec  dept%ROWTYPE;my_deptno dept.deptno%TYPE;...      BEGIN SELECT deptno, dname, loc INTO my_deptno  -- invalid FROM dept WHERE ...

Action: Check the spelling of the names of the assignment target and all its components. Make sure the assignment target is declared with the required components and that the declaration is placed correctly in the block structure.

PLS-00360 cursor declaration without body needs return type

Cause: A cursor declaration lacks either a body (SELECT statement) or a return type. If you want to separate a cursor specification from its body, a return type must be supplied, as in:

CURSOR c1 RETURN emp%ROWTYPE;

Action: Add a SELECT statement or return type to the cursor declaration.

PLS-00361 IN cursor 'string' cannot be OPEN'ed

Cause: A cursor parameter with mode IN cannot be modified, and therefore cannot be opened.

Action: Change the cursor parameter to be IN OUT or OUT.

PLS-00362 invalid cursor return type; 'string' must be a record type

Cause: In a cursor specification or REF CURSOR type definition, a non-record type such as NUMBER or TABLE was specified as the return type. This is not allowed. Only the following return types are allowed:

  • record_type_name
  • record_name%TYPE
  • table_name%ROWTYPE
  • cursor_name%ROWTYPE
  • cursor_variable_name%ROWTYTPE

Action: Revise the cursor specification or REF CURSOR type definition so that it specifies one of the above return types.

PLS-00363 expression 'string' cannot be used as an assignment target

Cause: A literal, constant, IN parameter, loop counter, or function call was mistakenly used as the target of an assignment. For example, the following statement is illegal because the assignment target, 30, is a literal:

SELECT deptno INTO 30 FROM dept WHERE ...  -- illegal

Action: Correct the statement by using a valid assignment target.

PLS-00364 loop index variable 'string' use is invalid

Cause: A reference to a loop counter was found in an inappropriate context. For example, the following statement is illegal because the loop counter is used as the terminal value in its own range expression:

FOR j IN 1 .. j LOOP ...  -- illegal

Action: Change the loop range expression so that it does not reference the loop counter. If you want to refer in the range expression to another variable with the same name as the loop counter, change either name or qualify the variable name with a label.

PLS-00365 'string' is an OUT parameter and cannot be read

Cause: An attempt was made to assign the value of an OUT parameter to another parameter or variable. Inside a procedure, an OUT parameter acts like an uninitialized variable; therefore, its value cannot be read. For example, the following assignments are illegal:

PROCEDURE calc_bonus (bonus OUT REAL, ...) IS     rating  REAL;     wages   REAL;    BEGIN     ...     IF rating > 90 THEN        bonus := bonus * 2;  -- illegal         SELECT sal + bonus INTO wages FROM emp ...  -- illegal        ...    END IF;    ...     END calc_bonus;

Action: Use an IN OUT parameter instead of the OUT parameter. Inside a procedure, an IN OUT parameter acts like an initialized variable; therefore, its value can be read.

PLS-00366 subtype of a NOT NULL type must also be NOT NULL

Cause: After a subtype was defined as NOT NULL, it was used as the base type for another subtype defined as NULL. That is not allowed. For example, the code might look like:

DECLARESUBTYPE Weekday IS INTEGER NOT NULL; SUBTYPE Weekend IS Weekday NULL;  -- illegal

instead of:

DECLARE SUBTYPE Weekday IS INTEGER NOT NULL; SUBTYPE Weekend IS Weekday;

Action: Revise the subtype definitions to eliminate the conflict.

PLS-00367 a RAISE statement with no exception name must be inside an exception handler

Cause: A RAISE statement not followed by an exception name was found outside an exception handler.

Action: Delete the RAISE statement, relocate it to an exception handler, or supply the missing exception name.

PLS-00368 in RAISE statement, 'string' must be an exception name

Cause: The identifier in a RAISE statement is not a valid exception name.

Action: Make sure the identifier in the RAISE statement was declared as an exception and is correctly placed in the block structure. If you are using the name of a PL/SQL predefined exception, check its spelling.

PLS-00369 no choices may appear with choice OTHERS in an exception handler

Cause: A construct of the form:

WHEN excep1 OR OTHERS =>

was encountered in the definition of an exception handler. The OTHERS handler must appear by itself as the last exception handler in a block.

Action: Remove the identifier that appears with OTHERS or write a separate exception handler for that identifier.

PLS-00370 OTHERS handler must be last among the exception handlers of a block

Cause: One or more exception handlers appear after an OTHERS handler. However, the OTHERS handler must be the last handler in a block or subprogram because it acts as the handler for all exceptions not named specifically.

Action: Move the OTHERS handler so that it follows all specific exception handlers.

PLS-00371 at most one declaration for 'string' is permitted in the declaration section

Cause: A reference to an identifier is ambiguous because there are conflicting declarations for it in the declarative part of a block, procedure, or function. At most one declaration of the identifier is permitted in a declarative part.

Action: Check the spelling of the identifier. If necessary, remove all but one declaration of the identifier.

PLS-00372 In a procedure, RETURN statement cannot contain an expression

Cause: In a procedure, a RETURN statement contains an expression, which is not allowed. In functions, a RETURN statement must contain an expression because its value is assigned to the function identifier. However, in procedures, a RETURN statement lets you exit before the normal end of the procedure is reached.

Action: Remove the expression from the RETURN statement, or redefine the procedure as a function.

PLS-00373 EXIT label 'string' must label a LOOP statement

Cause: The label in an EXIT statement does not refer to a loop. An EXIT statement need not specify a label. However, if a label is specified (as in EXIT my_label), it must refer to a loop statement.

Action: Make sure the label name is spelled correctly and that it refers to a loop statement.

PLS-00374 illegal EXIT statement; it must appear inside the loop labeled 'string'

Cause: An EXIT statement need not specify a label. However, if a label is specified (as in EXIT my_label), the EXIT statement must be inside the loop designated by that label.

Action: Make sure the label name is spelled correctly; if necessary, move the EXIT statement inside the loop to which the label refers.

PLS-00375 illegal GOTO statement; this GOTO cannot branch to label 'string'

Cause: The line and column numbers accompanying the error message refer to a GOTO that branches from outside a construct (a loop or exception handler, for example) that contains a sequence of statements to a label inside that sequence of statements. Such a branch is not allowed.

Action: Either move the GOTO statement inside the sequence of statements or move the labeled statement outside the sequence of statements.

PLS-00376 illegal EXIT statement; it must appear inside a loop

Cause: An EXIT statement was found outside of a loop construct. The EXIT statement is used to exit prematurely from a loop and so must always appear within a loop.

Action: Either remove the EXIT statement or place it inside a loop.

PLS-00377 internal type PLS_INTEGER is not included in this release of PL/SQL

Cause: The type-name INTEGER was used in a declaration.

Action: Do not use.

PLS-00378 invalid compilation unit for this release of PL/SQL

Cause: A compilation unit is a file containing PL/SQL source code that is passed to the compiler. Only compilation units containing blocks, declarations, statements, and subprograms are allowed. This error occurs when some other language construct is passed to the compiler.

Action: Make sure the compilation unit contains only blocks, declarations, statements, and subprograms.

PLS-00379 CASE statements are not included in this release of PL/SQL

Cause: The unit being compiled contains a CASE statement. However, the current release of PL/SQL does not support CASE statements.

Action: Remove the CASE statement from the compilation unit.

PLS-00380 functions and procedures are not included in this release of PL/SQL

Cause: The program being compiled contains a declaration of a FUNCTION or PROCEDURE.

Action: Do not use.

PLS-00381 type mismatch found at 'string' between column and variable in subquery or INSERT

Cause: The datatypes of a column and a variable do not match. The variable was encountered in a subquery or INSERT statement.

Action: Change the variable datatype to match that of the column.

PLS-00382 expression is of wrong type

Cause: An expression has the wrong datatype for the context in which it was found.

Action: Change the datatype of the expression. You might want to use datatype conversion functions.

PLS-00383 type mismatch found at 'string' inside an IN or NOT IN clause

Cause: In a test for set membership such as X NOT IN (SELECT Y ... ), the expressions X and Y do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.

Action: Change the expressions so that their datatypes match. You might want to use datatype conversion functions in the select list.

PLS-00384 type mismatch found at 'string' in UPDATE's SET clause

Cause: The column to the left of the equal sign in the SET clause of an UPDATE statement does not match in datatype with the column, expression, or subquery to the right of the equal sign, and it is unclear which implicit conversion is required to correct the mismatch.

Action: Change the expressions so that their datatypes match. You might want to use datatype conversion functions in the SET clause.

PLS-00385 type mismatch found at 'string' in SELECT...INTO statement

Cause: The expressions to the left and right of the INTO clause in a SELECT...INTO statement do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.

Action: Change the expressions so that their datatypes match. You might want to use datatype conversion functions in the select list.

PLS-00386 type mismatch found at 'string' between FETCH cursor and INTO variables

Cause: An assignment target in the INTO list of a FETCH statement does not match in datatype with the corresponding column in the select list of the cursor declaration, and it is unclear which implicit conversion is required to correct the mismatch.

Action: Change the cursor declaration or change the datatype of the assignment target. You might want to use datatype conversion functions in the select list of the query associated with the cursor.

PLS-00387 INTO variable cannot be a database object

Cause: An item in the INTO list of a FETCH or SELECT statement was found to be a database object. INTO introduces a list of user-defined variables to which output values are assigned. Therefore, database objects cannot appear in the INTO list.

Action: Check the spelling of the INTO list item. If necessary, remove the item from the INTO list or replace it with a user-defined output variable.

PLS-00388 undefined column 'string' in subquery

Cause: A subquery contains a column name that was not defined in the specified table.

Action: Change the expression to specify a column that was defined.

PLS-00389 table, view or alias name "string" not allowed in this context

Cause: A table, view or alias name name corresponding to a regular (non-object) table appeared in an inappropriate context.

Action: Remove the reference, or, if you intended to code this as a column reference, fix it as such.

PLS-00390 undefined column 'string' in INSERT statement

Cause: An INSERT statement contains an undefined column name.

Action: Check the spelling of the column name, then change the expression so that it refers only to defined columns.

PLS-00391 undefined column 'string' in UPDATE statement

Cause: An UPDATE statement refers to a column not defined for the table or view being updated.

Action: Check the spelling of the column name, then revise the statement so that it refers only to defined columns.

PLS-00392 Type mismatch in arguments to BETWEEN

Cause: In a comparison such as X BETWEEN Y AND Z, the expressions X, Y, and Z do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.

Action: Change the expressions so that their datatypes match. You might want to use datatype conversion functions.

PLS-00393 wrong number of columns in SELECT...INTO statement

Cause: The number of columns selected by a SELECT...INTO statement does not match the number of variables in the INTO clause.

Action: Change the number of columns in the select list or the number of variables in the INTO clause so that the numbers match.

PLS-00394 wrong number of values in the INTO list of a FETCH statement

Cause: The number of variables in the INTO clause of a FETCH statement does not match the number of columns in the cursor declaration.

Action: Change the number of variables in the INTO clause or the number of columns in the cursor declaration so that the numbers match.

PLS-00395 wrong number of values in VALUES clause of INSERT statement

Cause: The number of columns in an INSERT statement does not match the number of values in the VALUES clause. For example, the following statement is faulty because no column is specified for the value 20:

INSERT INTO emp (empno, ename) VALUES (7788, 'SCOTT', 20);

Action: Change the number of items in the column list or the number of items in the VALUES list so that the numbers match.

PLS-00396 INSERT statement's subquery yields wrong number of columns

Cause: The number of columns in an INSERT statement does not match the number of columns in a subquery select list. For example, the following statement is faulty because no corresponding column is specified for col3:

INSERT INTO emp (ename, empno) SELECT col1, col2, col3 FROM ...

Action: Change the number of items in the column list of the INSERT statement or the number of items in the select list so that the numbers match.

PLS-00397 Type mismatch in arguments to IN

Cause: In a test for set membership such as X IN (Y, Z), the expressions X, Y, and Z do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.

Action: Change the expressions so that their datatypes match. You might want to use datatype conversion functions.

PLS-00398 wrong number of columns in UNION, INTERSECT, or MINUS expression

Cause: The SELECT clauses to the left and right of a UNION, INTERSECT, or MINUS expression do not select the same number of columns. For example, the following statement is faulty because the select lists do not contain the same number of items:

CURSOR my_cur IS SELECT ename FROM emp INTERSECT SELECT ename, empno FROM emp;

Action: Change the select lists so that they contain the same number of items.

PLS-00399 different types of columns in UNION, INTERSECT, or MINUS expression

Cause: The select lists to the left and right of a UNION, INTERSECT, or MINUS expression select at least one column that is mismatched in datatype. For example, the following statement is faulty because the constant 3 has datatype NUMBER, whereas SYSDATE has datatype DATE:

CURSOR my_cur IS SELECT 3 FROM emp  INTERSECT SELECT SYSDATE FROM emp;

Action: Change the select lists so that they match in datatype. You might want to use datatype conversion functions in the select list of one or more queries.

PLS-00400 different number of columns between cursor SELECT statement and return value

Cause: In a cursor declaration, a return type (such as RETURN emp%ROWTYPE) was specified, but the number of returned column values does not match the number of select-list items.

Action: Change the cursor return type or the select list so that the number of returned column values matches the number of select-list items.

PLS-00401 different column types between cursor SELECT statement and return value found at 'string'

Cause: In a cursor declaration, a return type (such as RETURN emp%ROWTYPE) was specified, but a returned column value and its corresponding select-list item have different datatypes.

Action: Change the cursor return type or the select list so that each returned column value and its corresponding select-list item have the same datatype.

PLS-00402 alias required in SELECT list of cursor to avoid duplicate column names

Cause: A cursor was declared with a SELECT statement that contains duplicate column names. Such references are ambiguous.

Action: Replace the duplicate column name in the select list with an alias.

PLS-00403 expression 'string' cannot be used as an INTO-target of a SELECT/FETCH statement

Cause: A FETCH statement was unable to assign a value to an assignment target in its INTO list because the target is not a legally formed and declared variable. For example, the following assignment is illegal because 'Jones' is a character string, not a variable:

FETCH my_cur INTO 'Jones';

Action: Check the spelling and declaration of the assignment target. Make sure that the rules for forming variable names are followed.

PLS-00404 cursor 'string' must be declared with FOR UPDATE to use with CURRENT OF

Cause: The use of the CURRENT OF cursor_name clause is legal only if cursor_name was declared with a FOR UPDATE clause.

Action: Add a FOR UPDATE clause to the definition of the cursor or do not use the CURRENT OF cursor_name clause.

PLS-00405 subquery not allowed in this context

Cause: A subquery was used in an inappropriate context, such as:

if (SELECT deptno FROM emp WHERE ... ) = 20 then ...

Subqueries are allowed only in SQL statements.

Action: The same result can be obtained by using a temporary variable, as in:

SELECT deptno INTO temp_var FROM emp WHERE ...; IF temp_var = 20 THEN ...

PLS-00406 length of SELECT list in subquery must match number of assignment targets

Cause: A query select list is not the same length as the list of targets that will receive the returned values. For example, the following statement is faulty because the subquery returns two values for one target:

UPDATE emp SET ename = (SELECT ename, empno FROM emp WHERE ename = 'SMITH') ...

Action: Change one of the lists so that they contain the same number of items.

PLS-00407 '*' not allowed here; a list of columns is required

Cause: An asterisk (*) was used as an abbreviation for a list of column names. However, in this context the column names must be written out explicitly.

Action: Replace the asterisk with a list of column names.

PLS-00408 duplicate column 'string' not permitted in INSERT or UPDATE

Cause: An UPDATE or INSERT statement has a column list that contains duplicate column names.

Action: Check the spelling of the column names, then eliminate the duplication.

PLS-00409 duplicate variable 'string' in INTO list is not permitted

Cause: The same variable appears twice in the INTO list of a SELECT or FETCH statement.

Action: Remove one of the variables from the INTO list.

PLS-00410 duplicate fields in RECORD,TABLE or argument list are not permitted

Cause: When a user-defined record was declared, the same name was given to two fields. Like column names in a database table, field names in a user-defined record must be unique.

Action: Check the spelling of the field names, then remove the duplicate.

PLS-00411 Number of values in aggregate and in subquery don't match

Cause: In a statement of the form aggregate = subquery, the numbers of values in the aggregate and subquery are unequal. For example, the code might look like:

... WHERE (10,20,30) = (SELECT empno,deptno FROM emp WHERE...);

Action: Revise the aggregate or subquery so that the numbers of values match.

PLS-00412 list of values not allowed as argument to this function or procedure

Cause: A parenthesized list of values separated by commas (that is, an aggregate) was used in the wrong context. For example, the following usage is invalid:

WHERE (col1, col2) > (SELECT col3, col4 FROM my_table ...)

However, an equal sign can take a list of values and a subquery as left- and right-hand-side arguments, respectively. So, the following usage is valid:

WHERE (col1, col2) = (SELECT col3, col4 FROM my_table ...)

Action: Rewrite the expression. For example, the clause:

WHERE (col1, col2) > (SELECT col3, col4 FROM my_table ...)

can be rewritten as:

WHERE col1 > (SELECT col3 FROM my_table ...) AND col2 > (SELECT col4 FROM my_table ...)

PLS-00413 identifier in CURRENT OF clause is not a cursor name

Cause: The identifier in a CURRENT OF clause names an object other than a cursor.

Action: Check the spelling of the identifier. Make sure that it names the cursor in the DELETE or UPDATE statement and that it names the cursor itself, not a FOR-loop variable.

PLS-00414 no column 'string' in table

Cause: A table name or alias was used to qualify a column reference, but the column was not found in that table. Either the column was never defined or the column name is misspelled.

Action: Confirm that the column was defined and check the spelling of the column name.

PLS-00415 'string' is an OUT parameter and cannot appear in a function

Cause: An OUT or IN OUT formal parameter was used in a function specification.

Action: Change the parameter to an IN parameter.

PLS-00416 The third argument of DECODE cannot be NULL

Cause: The third argument of DECODE is NULL.

Action: Enter an argument with a proper type and value.

PLS-00417 unable to resolve "string" as a column

Cause: A database table, view, or column was specified in a SQL statement that does not exist, or the privileges required to access the table or view were not granted.

Action: Check the spelling of the table (or view) and column names; make sure the table and columns exist. If necessary, ask the database administrator to grant the privileges required to access the table.

PLS-00418 array bind type must match PL/SQL table row type

Cause: A host array was passed (by an Oracle Precompiler program, for example) to a PL/SQL subprogram for binding to a PL/SQL table parameter. However, the datatypes of the array elements and PL/SQL table rows are incompatible. So, the binding failed.

Action: Change the datatype of the array elements or PL/SQL table rows to make the datatypes compatible.

PLS-00419 reference to remote attribute not permitted

Cause: An attempt was made to reference a remote cursor attribute, which is not allowed. For example, the code might look like:

IF SQL%NOTFOUND@newyork THEN ...

Action: Do not try to reference a remote cursor attribute.

PLS-00420 can't call builtin routines remotely

Cause: An attempt was made to call a built-in PL/SQL function remotely, which is not allowed. For example, the code might look like:

my_sqlerrm := SQLERRM@newyork;

or

INSERT INTO emp VALUES (my_empno, STANDARD.RTRIM@newyork(my_ename), ...);

Action: Always call built-in functions locally; never specify a database link.

PLS-00421 synonym definitions nested too deeply; possible loop in synonyms

Cause: Directly or indirectly, a synonym was defined in terms of itself, creating a circular definition. Or, a chain of synonyms, too long for the PL/SQL compiler to handle, was defined.

Action: Redefine the synonyms to eliminate the circular definition. If necessary, shorten the chain of synonyms.

PLS-00422 no PL/SQL translation for the bindtype given for this bind variable

Cause: A host variable was passed (by an Oracle Precompiler program, for example) to PL/SQL for binding. However, its datatype is not compatible with any PL/SQL datatype. So, the binding failed.

Action: Change the datatype of the host variable to make it compatible with a PL/SQL datatype.

PLS-00423 ORDER BY item must be the number of a SELECT-list expression

Cause: A column alias was used in the ORDER BY clause of a SELECT statement that uses a UNION, INTERSECT, or MINUS set operator. This is not allowed. In such cases, expressions in the ORDER BY clause must be unsigned integers that designate the ordinal positions of select-list items.

Action: Change the alias in the ORDER BY clause to an unsigned integer that designates the ordinal position of the select item in question.

PLS-00424 RPC defaults cannot include Package State

Cause: An attempt was made to call a remote subprogram whose defaulted parameters depend on package state, which is not allowed. When calling remote subprograms, the actual parameters must be passed explicitly if the corresponding formal parameters depend on package state.

Action: Call the remote subprogram by passing each actual parameter explicitly.

PLS-00425 in SQL, function argument and return types must be SQL type

Cause: When a stored function was called from a SQL statement, parameters of the wrong type were passed. To be callable from SQL statements, a stored function must meet several requirements, one of which is that its arguments have SQL datatypes such as CHAR, DATE, or NUMBER. None of the arguments can have non-SQL types such as BOOLEAN, TABLE, or RECORD.

Action: Make sure all the arguments in the function call have SQL datatypes.

PLS-00426 cursor variable OUT parameter 'string' cannot be FETCH'ed or CLOSE'd

Cause: When a cursor variable was declared as the formal parameter of a subprogram that will FETCH from and/or CLOSE the cursor variable, the OUT parameter mode was specified. This is not allowed. In such cases, the IN or IN OUT mode must be specified.

Action: Change the parameter mode from OUT to IN or IN OUT.

PLS-00427 RPC defaults cannot use builtins when versions of STANDARD differ

Cause: An attempt was made to call a remote subprogram whose defaulted parameter value is calculated using a builtin operation. If the calling system uses a different version of package STANDARD than does the called system, a defaulted expression must be either a simple numeric or string literal, NULL, or a direct call to a user-written function.

Action: Call the remote subprogram by passing each actual parameter value explicitly.

PLS-00428 an INTO clause is expected in this SELECT statement

Cause: The INTO clause of a SELECT INTO statement was omitted. For example, the code might look like:

SELECT deptno, dname, loc FROM dept WHERE ...

instead of:

SELECT deptno, dname, loc INTO dept_rec FROM dept WHERE ...

In PL/SQL, only a subquery is written without an INTO clause.

Action: Add the required INTO clause.

PLS-00429 unsupported feature with RETURNING clause

Cause: One of the following:

  • INTO clause and RETURNING clause cannot be use in the same statement
  • RETURNING clause is currently not supported for object typecolumns, LONG columns, records, %rowtypes, remote tables and INSERT with subquery.

This is as ORA-28815.

Action: Use a separate select statement to get the values.

PLS-00430 FORALL iteration variable string is not allowed in this context

Cause: FORALL iteration variable can only be used as a subscript. It cannot be used directly or as a part of an expression.

Action: Use FORALL variable only as a collection subscript.

PLS-00431 bulk SQL attributes must use a single index

Cause: More than one index specified to access SQL bulk attribute.

Action: Use a single index of integer datatype.

PLS-00432 implementation restriction: cannot use FORALL and BULK COLLECT INTO together in SELECT statements

Cause: SELECT statement contains both the FORALL and BULK COLLECT INTO phrases.

Action: Do not use FORALL and BULK COLLECT INTO together in SELECT statements.

PLS-00433 inconsistent package STANDARD

Cause: PL/SQL compiler could not find the entries (such as type declarations) that should exist in the package STANDARD.

Action: Make sure that the correct version of package STANDARD is available in the current Oracle database, then retry compilation.

PLS-00434 record field has unsupported type: "string"

Cause: An attempt was made to use an unsupported type for a record field. In this release, the use of the SQL92 datetime types (time, timestamp, time with time zone, timestamp with time zone, interval year to month, interval day to second) are not supported in record fields.

Action: Use only supported types for record fields.

PLS-00435 DML statement without BULK In-BIND cannot be used inside FORALL

Cause: The DML (SELECT/INSERT/DELETE/UPDATE) statement inside the FORALL statement does not contain BULK IN-BIND variables.

Action: The DML (SELECT/INSERT/DELETE/UPDATE) statement inside the FORALL statement must contain BULK IN-BIND variables.

PLS-00436 implementation restriction: cannot reference fields of BULK In-BIND table of records

Cause: The table(bulk_index).field is not supported at run-time yet.

Action: Use FOR loop with plain FORALL DML statement (SELECT/INSERT/DELETE/UPDATE) instead.

PLS-00437 FORALL bulk index cannot be used in string clause

Cause: RETURNING table(bulk_index) is not supported.

Action: Use RETURNING BULK COLLECT instead.

PLS-00438 value in LIMIT clause: 'string' use is invalid

Cause: The evaluation value in the LIMIT clause of a bulk fetch was found in an inappropriate context. For example, the following statement is illegal because the LIMIT clause in a bulk fetch expects a numeric value.

Action: Change the expression of the LIMIT clause so that the evaluation result is compatible to a numeric value.

PLS-00439 A LIMIT clause must be used within a BULK FETCH

Cause: A LIMIT clause is used within a non-bulk fetch.

Action: Do not use a LIMIT clause when a non-bulk fetch is used.

PLS-00450 a variable of this private type cannot be declared here

Cause: A variable declaration uses a type that is declared PRIVATE in some other compilation unit.

Action: Do not use this type in a PRIVATE variable declaration.

PLS-00452 Subprogram 'string' violates its associated pragma

Cause: A packaged function cannot be called from SQL statements unless its purity level is asserted by coding a RESTRICT_REFERENCES pragma in the package specification. The pragma, which is used to control side effects, tells the PL/SQL compiler to deny the packaged function read/write access to database tables, public packaged variables, or both. A SQL statement that violates the pragma will cause a compilation error.

Action: Raise the purity level of the function, or relax the pragma restrictions.

PLS-00453 remote operations not permitted on object tables or user-defined type columns

Cause: A reference to a remote object tables or user-defined type column was found.

Action: Do not refer to it.

PLS-00454 with a returning into clause, the table expression cannot be remote or a subquery

Cause: A reference to a remote table or subquery was found in a SQL statement with a returning into clause.

Action: Do not refer to it, or do use a subsequent select statement.

PLS-00455 cursor 'string' cannot be used in dynamic SQL OPEN statement

Cause: A REF CURSOR was dynamically opened that has RETURN type. However, only REF CURSOR without RETURN type can be opened by an embedded dynamic OPEN statement.

Action: define a REF CURSOR without return type, and use it in the statement.

PLS-00456 item 'string' is not a cursor

Cause: The given variable is not a cursor and therefore cannot be OPENed or FETCHed from.

Action: Check the spelling and declaration for the given variable.

PLS-00457 expressions have to be of SQL types

Cause: An expression of the wrong type is in USING or dynamic RETURNING clause. In USING or dynamic RETURNING clause, an expression cannot be of non-SQL types such as BOOLEAN, INDEX TABLE, and record.

Action: Change the expression type to a SQL type.

PLS-00458 subprogram 'string' cannot be called from a REPEATABLE subprogram

Cause: The subprogram is not REPEATABLE and cannot be called from a REPEATABLE subprogram.

Action: Delete the call or delete REPEATABLE.

PLS-00459 this feature is not allowed in REPEATABLE subprogram

Cause: One of the following features were specified in the REPEATABLE subprogram: dynamic SQL statements or autonomous transaction.

Action: Delete the statements or delete REPEATABLE.

PLS-00460 REPEATABLE subprogram 'string' has to be RNDS, WNDS, RNPS, and WNPS

Cause: Repeatable subprogram can neither read database state (RNDS), write database state (WNDS), read package state (RNPS), nor write package state (WNPS).

Action: Make the subprogram to be RNDS, WNDS, RNPS, and WNPS or delete REPEATABLE.

PLS-00461 mismatch REPEATABLE information between specification and body of 'string'

Cause: REPEATABLE is declared at the subprogram's specification, but not at its body, or vice versa.

Action: Make sure both specification and body are declared as REPEATABLE.

PLS-00462 nested subprogram 'string' has to be REPEATABLE

Cause: The nested subprogram of a REPEATABLE subprogram is not declared as REPEATABLE. If a subprogram is REPEATABLE, all of its nested subprograms has to be declared as REPEATABLE.

Action: Declared the nested subprogram as REPEATABLE.

PLS-00483 exception 'string' may appear in at most one exception handler in this block

Cause: An exception appears in two different WHEN clauses (that is, two different exception handlers) in the exception-handling part of a PL/SQL block or subprogram.

Action: Remove one of the references to the exception.

PLS-00484 redundant exceptions 'string' and 'string' must appear in same exception handler

Cause: The EXCEPTION_INIT pragma was used and different exceptions were initialized to the same Oracle error number. Then, they were referenced in different exception handlers within the same exception-handling part. Such references conflict.

Action: Remove one of the exceptions or initialize it to a different Oracle error number.

PLS-00485 in exception handler, 'string' must be an exception name

Cause: An identifier not declared as an exception appears in an exception handler WHEN clause. Only the name of an exception is valid in a WHEN clause.

Action: Check the spelling of the exception name and make sure the exception was declared properly.

PLS-00486 select list cannot be enclosed in parentheses

Cause: In a SELECT statement, the select list was enclosed in parentheses, as in:

SELECT (deptno, dname, loc) FROM dept INTO ...

This breaks the rules of SQL syntax. Parentheses are not required because the keywords SELECT and FROM delimit the select list.

Action: Remove the parentheses enclosing the select list.

PLS-00487 Invalid reference to variable 'string'

Cause: A variable was referenced in a way that is inconsistent with its datatype. For example, a scalar variable might have been mistakenly referenced as a record, as follows:

DECLARECURSOR emp_cur IS SELECT empno, ename, sal FROM emp; emp_rec emp_cur%ROWTYPE; my_sal  NUMBER(7,2); BEGIN    ...    total_sal := total_sal + my_sal.sal;  -- invalid ...

Action: Check the spelling of the variable name. Make sure the variable was declared properly and that the declaration and reference are consistent regarding datatype.

PLS-00488 invalid variable declaration: object 'string' must be a type or subtype

Cause: The datatype specifier in a variable declaration does not designate a legal type. For example, the %TYPE attribute might not have been added to a declaration, as in:

DECLARE my_sal   emp.sal%TYPE; my_ename emp.ename;    -- missing %TYPE ...

When declaring a constant or variable, to provide the datatype of a column automatically, use the %TYPE attribute. Likewise, when declaring a record, to provide the datatypes of a row automatically, use the %ROWTYPE attribute.

Action: Make sure the datatype specifier designates a legal type. Remember to use the %TYPE and %ROWTYPE attributes when necessary.

PLS-00489 invalid table reference: 'string' must be a column in this expression

Cause: In a query, a select-list item refers to a table in the FROM clause but not to a database column.

Action: Check the spelling of the column names, make sure each column in the select list refers to a table in the FROM clause, then re-execute the query.

PLS-00490 illegal statement

Cause: A constant, variable, function call, or incomplete statement was used where a statement was expected. For example, instead of calling a function from an expression, it might have been called as a statement (as if it were a procedure).

Action: Check the statement, making sure that its commands, identifiers, operators, delimiters, and terminator form a complete and valid PL/SQL statement.

PLS-00491 numeric literal required

Cause: A constant or variable was used where a numeric literal is required. For example, the code might look like:

my_ename  VARCHAR2(max_len);

instead of

my_ename  VARCHAR2(15);

When specifying the maximum length of a VARCHAR2 variable, an integer literal must be used.

Action: Replace the identifier with a numeric literal.

PLS-00492 variable or constant initialization may not refer to functions declared in the same package

Cause: If a package specification p declares a function f, that function may not be used in any variable declarations in that same package specification. This is because of a circular instantiation problem: in order to fully instantiate the package specification, the variable must be initialized. To initialize the variable, the function body code in the package body must be executed. That requires that the package body be instantiated. However, the package body cannot be instantiated until the package specification is fully instantiated.

Action: Remove the reference to the function from the variable initialization. A technique which often works is to move the variable initialization from the variable declaration (in the package specification) to the package body initialization block.

PLS-00493 invalid reference to a server-side object or function in a local context

Cause: A reference to a server-side object (for example, a table column) or function (a group function such as SUM, AVG, MIN, MAX, ... ) was found in a context where only PL/SQL objects may be present, such as within the parameter list of a local function or as the index of a (local) PL/SQL table.

Action: Rewrite the offending statement; or, if a local function call is the problem context, make the function non-local (either packaged or top-level).

PLS-00494 coercion into multiple record targets not supported

Cause: The INTO list of a SELECT or FETCH specified more than a single record- type target and the column types required coercion into a record to match the INTO list. This is type checked as correct, but not yet supported.

Action: Create a new record type to hold all of the column types or code the SELECT with an INTO target for every source column.

PLS-00495 too many columns in SELECT...INTO statement after bursting record targets

Cause: Type checking indicated the columns in a SELECT or FETCH were being collected into a record in the INTO list. The record was burst into its fields. There were not enough fields in the record for each of the columns.

Action: Change the number of columns or the record variable(s) in the INTO clause so that they match.

PLS-00496 too few columns in SELECT...INTO statement after bursting record targets

Cause: Type checking indicated the columns in a SELECT or FETCH were being collected into a record in the INTO list. The record was burst into its fields. There were not enough columns to fill all of the fields in the record.

Action: Change the number of columns or the record variable(s) in the INTO clause so that they match.

PLS-00497 cannot mix between single row and multi-row (BULK) in INTO list

Cause: One of the following:

  • When BULK syntax (for example, BULK COLLECT INTO) is used to retrieve data, every variable in the INTO list has to be of type that is a collection of the type of the corresponding column.
  • When BULK is NOT used, every variable in the INTO list has to be of compatible type with the corresponding column.

Action: Change the INTO list so that all variables have correct data types.

PLS-00498 illegal use of a type before its declaration

Cause: A variable or constant was declared to be of a type whose declaration appears later in the compilation unit; or, a type or subtype was declared in terms of another type whose declaration appears later in the compilation unit.

Action: Ensure that the type declaration precedes its use in the variable/ constant/type declaration.

PLS-00499 coercion into collection of records not supported

Cause: A SELECT or FETCH may specify a column list to be coerced into a variable which is a collection of records. This is type checked as correct, but not yet supported because of the implicit layout change required.

Action: Express the SELECT with an object constructor around the columns and use a collection of objects as an INTO variable. Or, build the collection one row at a time coercing each row into a record which happens to be an element. Or, use a record of collections.

PLS-00500 invalid operator binding

Cause: An operator binding function cannot be found in the specified scope.

Action: Provide the correct number and types of parameters for the operator binding function. Or, specify the correct names for schema, package, or type containing the operator binding function.

PLS-00503 RETURN value statement required for this return from function

Cause: In a function body, a RETURN statement was used that contains no expression. In procedures, a RETURN statement contains no expression because the statement returns control to the caller. However, in functions, a RETURN statement must contain an expression because its value is assigned to the function identifier.

Action: Add an expression to the RETURN statement.

PLS-00504 type string_BASE may not be used outside of package STANDARD

Cause: In a declaration, the datatype NUMBER_BASE (for example) was mistakenly specified. The datatypes CHAR_BASE, DATE_BASE, MLSLABEL_BASE, and NUMBER_BASE are for internal use only.

Action: Specify (for example) the datatype NUMBER instead of NUMBER_BASE.

PLS-00505 User Defined Types may only be defined as PLSQL Tables or Records

Cause: An attempt was made to define a type other than TABLE or RECORD, but these are the only user- defined types allowed in this release of PL/SQL. For example, the following type definition is illegal:

TYPE Byte IS INTEGER(2);  -- illegal

Action: Remove the type definition, or revise it to specify a TABLE or RECORD type.

PLS-00506 User Defined Constrained Subtypes are disallowed

Cause: An attempt was made to define a constrained subtype, but only unconstrained subtypes are allowed in this release of PL/SQL. For example, the following type definition is illegal:

SUBTYPE Acronym IS VARCHAR2(5);  -- illegal

Action: Remove the illegal type constraint.

PLS-00507 a PLSQL Table may not contain a table or a record with composite fields

Cause: In a TABLE type definition, a nested record type was specified as the element type. This is not allowed. All fields in the record must be scalars.

Action: Remove the TABLE type definition, or replace the nested record type with a simple record type.

PLS-00508 The expression in a RETURN statement cannot be a type

Cause: A datatype specifier was used instead of an expression in the RETURN statement of a user-defined function, as shown in the example below. Do not confuse the RETURN statement, which sets the function identifier to the result value, with the RETURN clause, which specifies the datatype of the result value.

FUNCTION credit-rating (acct_no NUMBER) RETURN BOOLEAN IS BEGIN ...  RETURN NUMBER;  -- should be an expressionEND;

Action: Replace the datatype specifier in the RETURN statement with an appropriate expression.

PLS-00509 Implementation Restriction : Pass a returned record to a temporary identifier before selecting a field

Cause: Illegal syntax was used to call a parameter-less function that returns a record or a PL/SQL table of records. When calling a function that takes parameters and returns a record, you use the following syntax to reference fields in the record:

function_name(parameters).field_name

However, you cannot use the syntax above to call a parameter-less function because PL/SQL does not allow empty parameter lists. That is, the following syntax is illegal:

function_name().field_name  -- illegal; empty parameter list

The empty parameter list cannot be dropped because the following syntax is also illegal:

function_name.field_name  -- illegal; no parameter list

Action: Declare a local record or PL/SQL table of records to which you can assign the function result, then reference its fields directly.

PLS-00510 Float cannot have scale

Cause: When a FLOAT variable was declared, its precision and scale were specified, as shown in the following example:

DECLARE Salary FLOAT(7,2);

However, a scale for FLOAT variables cannot be specified; only a precision can be specified, as in:

salary FLOAT(7);

Action: Remove the scale specifier from the declaration, or declare a NUMBER variable instead.

PLS-00511 a record may not contain a PL/SQL table of records

Cause: In a RECORD definition, one of the fields was declared as a PL/SQL table of records. This is not allowed. A record can be the component of another record (that is, records can be nested), but a PL/SQL table of records cannot be the component of a record.

Action: Remove the field declaration, or revise it to specify a simple record type.

PLS-00512 Implementation Restriction: 'string': Cannot directly access remote package variable or cursor

Cause: An attempt was made to reference a remote packaged variable or cursor. This is not allowed. Instead, add to the remote package a function that returns the value of the variable or cursor.

Action: Remove the illegal reference.

PLS-00513 PL/SQL function called from SQL must return value of legal SQL type

Cause: In a SQL statement, a PL/SQL function was called that has a return type that cannot be handled by SQL. For example, type BOOLIAN, records and indexed-tables are not supported by SQL and functions returning such values cannot be called from SQL.

Action: Change the return type and retry the operation.

PLS-00514 INSERT statement with REF INTO clause requires a typed table

Cause: This INSERT statement provides REF INTO clause, which is only legal when the table specified in the INTO clause is an object table.

Action: Remove REF INTO clause and retry the operation.

PLS-00515 The type of the REF INTO variable 'string' must be REF to the table's type

Cause: In INSERT statement with REF INTO clause, the type of the data item must be REF to the type of the table used in INTO clause.

Action: Use variable or column of appropriate type.

PLS-00516 Type mismatch between object table and value 'string' in INSERT statement.

Cause: In the INSERT statement operating on typed tables (tables of objects), the type of a non-aggregate value did not match the object type of the table.

Action: Provide a value of appropriate type.

PLS-00517 Type mismatch between a select list element 'string' and corresponding table column in INSERT statement with a subquery

Cause: In an INSERT statement with subquery, at lease one of the elements of the select list was not type-compatible with the corresponding column of the table in the INTO clause. This error indicates that the subquery should be rewritten to match the structure of the target table.

Action: Provide a select list element of compatible type.

PLS-00518 This INSERT statement requires VALUES clause containing a parenthesised list of values

Cause: A VALUES clause was entered without a list of SQL data items in parentheses. In all INSERT statements with an explicit column list, the VALUES clause must contain a list of SQL data items in parentheses. For example:

INSERT INTO my_tab (a,b,c) VALUES (1,2,my_variable);

Action: Rewrite the statement to include a list of SQL data items in parentheses.

PLS-00519 This INSERT statement requires a VALUES clause containing an object type expression, not a list of values

Cause: In an INSERT statement with typed tables, an aggregate was used when an object type item was expected.

Action: Replace the aggregate with an object constructor or other object type expression.

PLS-00520 MAP methods must be declared without any parameters other than (optional) SELF.

Cause: A MAP member function was declared with a parameter. Map member functions can have only one parameter: the default SELF parameter. Map methods must be declared without any parameters. The compiler adds the SELF parameter.

Action: Remove the parameter from the map member function.

PLS-00521 ORDER methods must be declared with 1 (one) parameter in addition to (optional) SELF.

Cause: An order member function was declared without the user-specified parameter. Order member functions have two parameters, one is the default SELF parameter which is added by the compiler. the second parameter is added by the user and must declare an order method which must be the same type as the containing object type.

Action: Check and correct the way the parameter is specified.

PLS-00522 MAP methods must return a scalar type.

Cause: The MAP member function was written such that it returns something other than a scalar type.

Action: Rewrite the MAP function such that it returns a scalar type.

PLS-00523 ORDER methods must return an INTEGER.

Cause: An order member function was written such that it returns something other than an integer type.

Action: Rewrite the ORDER method such that it returns an integer type.

PLS-00524 The parameter type in an ORDER method must be the containing object type.

Cause: An order member function was declared without the user- specified parameter. Order member functions have two parameters, one is the default SELF parameter which is added by the compiler. the second parameter is added by the user and must declare an order method which must be the same type as the containing object type.

Action: Check and correct the way the parameter is specified.

PLS-00525 Within SQL statements, only equality comparisons of objects are allowed without a map or order function.

Cause: A map or order function was not provided for a relational comparison. Only equality comparisons may be used when a map or order function is not supplied.

Action: Supply either a map or order function for the object. Otherwise change the program to use only equality comparisons.

PLS-00526 A MAP or ORDER function is required for comparing objects in PL/SQL.

Cause: Within stand alone PL/SQL, an attempt was made to compare objects without a map or order function.

Action: Provide a map or order function and retry the operation.

PLS-00527 MAP or ORDER functions require a PRAGMA RESTRICT_REFERENCES specifying :WNDS,WNPS,RNPS,RNDS.

Cause: Either a PRAGMA RESTRICT_REFERENCES was not specified or it was specified without one of the following: WNDS, WNPS, RNPS, or RNDS.

Action: Add or correct the PRAGMA and retry the operation.

PLS-00528 The parameters to an ORDER function must have IN mode

Cause: A parameter was declared to an ORDER function to have OUT or IN OUT mode.

Action: Correct the parameter to use IN mode only.

PLS-00529 Bad column name string in INSERT statement (must be an identifier)

Cause: In an INSERT statement, an attempt was made to use a column name that is not an identifier. In any INSERT statement with explicit column list a column name must be a simple identifier.

Action: Rewrite the INSERT statement, using a simple identifier for the column name.

PLS-00530 Illegal type used for object type attribute: 'string'.

Cause: An attempt was made to use an invalid type for an object type attribute.

Action: Use only supported types for the object type attribute.

PLS-00531 Unsupported type in a VARRAY or TABLE type: 'string'.

Cause: An attempt was made to use an unsupported type in a VARRAY or TABLE type.

Action: Use only supported types in a VARRAY or TABLE type.

PLS-00532 Target of REF must be a complete or incomplete object type.

Cause: The target of a REF can only be a complete or an incomplete object type.

Action: If a REF is to be used, change the type; otherwise, remove the REF.

PLS-00533 Tables of non_queryable types are not supported.

Cause: An attempt was made to create a table of a type which cannot be queried. Tables of such types are not supported.

Action: Create an object type containing the non-queryable type. Then create a table of the object type.

PLS-00534 A Table type may not contain a nested table type or VARRAY.

Cause: An attempt was made to do one of the following: define a table type which contained nested collection types. or define an object table that has (perhaps nested) another table type or VARRAY type.

Action: Check the table definitions to be sure that they do not contain nested tables or VARRAYs.

PLS-00535 A VARRAY type may not contain a NESTED TABLE, VARRAY or LOB

Cause: An attempt was made to do one of the following: define a VARRAY type containing a nested collection type or LOB or define a VARRAY type of an object type that has a nested attribute which is one of NESTED TABLE, VARRAY or LOB type.

Action: Check the VARRAY definitions to be sure that they do not contain nested collection types, LOBs or nested attributes.

PLS-00536 Navigation through REF variables is not supported in PL/SQL.

Cause: The expression of the form REFVAR.FIELD was entered. This is not supported in this version of PL/SQL.

Action: This navigation is only supported for database objects. The REF variable can be used to insert into a database column of the same type, or select from it. However, you will not be able to navigate through it. Remove the navigation.

PLS-00537 A VARRAY must have a positive limit

Cause: A VARRAY type was declared with a non-positive limit, for example VARRAY(0).

Action: Declare the VARRAY with a positive limit and retry the operation.

PLS-00538 subprogram or cursor 'string' is declared in an object type specification and must be defined in the object type body

Cause: The specified subprogram is declared in an object type's specification, but is not defined in the object type body.

Action: Define the subprogram in the object type body, or remove the declaration from the specification.

PLS-00539 subprogram 'string' is declared in an object type body and must be defined in the object type specification

Cause: The specified subprogram is declared in an object type's body, but is not defined in the object type's specification. Notice cursor bodies can exist without a specification.

Action: Define the subprogram in the object type's specification, or remove the declaration from the body.

PLS-00540 object not supported in this context.

Cause: An object was declared inside a local scope (Function, Procedure, or anonymous block), or in a package scope which is not supported.

Action: Declare the type in a global or data base scope.

PLS-00541 size or length specified is too large.

Cause: A length or size that is too large was specified for a data item.

Action: Specify a smaller value and retry the operation.

PLS-00542 CLOB and NCLOB cannot use varying-width character sets in the server

Cause: A server type is being created with an embedded CLOB or NCLOB attribute which uses a varying-width character set.

Action: Use VARCHAR2 instead of CLOB, or use a fixed-width character set.

PLS-00543 a PLSQL Table may not contain a nested table type or VARRAY.

Cause: An attempt was made to define a PL/SQL table that contained a (possibly deeply) nested table type or VARRAY. Nested collection types are not supported.

Action: Remove the nested table type or VARRAY from the table. Then retry the operation.

PLS-00546 SELF may not be declared as a REF parameter.

Cause: SELF was declared as a REF parameter to a member function or procedure. SELF is not supported as a REF.

Action: Redeclare SELF as a value parameter.

PLS-00548 invalid use of operator.

Cause: A name of an operator is used as a qualifier or appears outside from SQL context.

Action: Eliminate the use of operator name as a qualifier or place it in a SQL clause.

PLS-00550 character set specification is not allowed for this type

Cause: A character set specification was made on a type that does not require one.

Action: Remove the character set specification, or change the type.

PLS-00551 character set ANY_CS is only allowed on a subprogram parameter

Cause: The character set ANY_CS was specified when it is not allowed.

Action: Change or remove the character set specification.

PLS-00552 flexible character set is not allowed on component element

Cause: ANY_CS or %CHARSET was used to reference an ANY_CS parameter which is not a CHAR, VARCHAR2, or CLOB type. ANY_CS or %CHARSET is not allowed for fields of a record, object, elements of a collection, and so on.

Action: Change or remove the character set specification.

PLS-00553 character set name is not recognized

Cause: An unrecognized name appears in a character set specification.

Action: Change or remove the character set specification.

PLS-00554 character set has already been determined

Cause: A redundant or conflicting character set was specified.

Action: Remove the CHARACTER SET specification, or change the character set specified.

PLS-00555 default expressions are not allowed for SQL operators

Cause: A default expression has been specified for a SQL operator.

Action: Eliminate the default expression from the operator.

PLS-00560 character set mismatch

Cause: An expression was used that has the wrong character set for this context.

Action: Adjust the expression, using TRANSLATE(... USING ...) or by rethinking the logic.

PLS-00561 character set mismatch on value for parameter 'string'

Cause: An expression was used that contains an incorrect character set. The actual argument has a character set conflict. If a default argument value is being used, it might be in conflict with some actual argument that must have the same character set.

Action: Adjust the expression, using TRANSLATE(... USING ...) or change the character set.

PLS-00562 a function must return a type.

Cause: The current function was defined to return something other than a data type.

Action: Make sure the function is returning a data type.

PLS-00563 illegal use of CAST expression

Cause: CAST (in PL/SQL) was used outside of a DML scope.

Action: Do not use CAST outside DML statements.

PLS-00564 lob arguments are not permitted in calls to remote server

Cause: Use of lob argument in call to remote server.

Action: Do not use LOBs in call to remote server.

PLS-00565 string must be completed as a potential REF target (object type)

Cause: Incomplete library units that are potential targets of REF dependencies must be completed so that they continue to remain potential targets of REF dependencies (since there might be library units with REF dependencies on this library unit). Potential REF targets include complete and incomplete object types. This error occurred because an attempt was made to complete a potential REF target as something other than a potential REF target.

Action: Use another name for this library unit, or drop the original incomplete library unit.

PLS-00566 type name "string" cannot be constrained

Cause: A LOB, date, boolean, ROWID, or MLSLABEL type was constrained with a length specification. For example:

X BLOB(5);

Action: Remove the constraint.

PLS-00567 cannot pass NULL to a NOT NULL constrained formal parameter

Cause: An attempt was made to pass NULL to a NOT NULL constrained parameter.

Action: Pass a NOT NULL expression instead.

PLS-00568 cannot access rows from a non-nested table item

Cause: An attempt was made to use TABLE expression, from a non-nested table.

Action: Pass the correct parameter.

PLS-00569 numeric overflow or underflow

Cause: A constant literal is either too large or too small to fit in an Oracle number.

Action: Change the value of the literal.

PLS-00570 different number of columns in the multiset and cast expressions

Cause: Number of columns in the collection returned by MULTISET and the number of columns for the CAST type do not match. For example:

create type tab_obj as object (n number);create type tab1 as table of tab_obj; create table tab2 (col1 number, col2 number); select CAST(MULTISET(select col1, col2 from tab2) as tab1) from tab2;

Action: Make sure the number of columns matches.

PLS-00571 method access through data base link not yet supported on client side

Cause: Remote link is used with on client side.

Action: Create a dummy function to call symbolic link on server side or wait till it is implemented.

PLS-00572 improper constraint form used

Cause: "number" types cannot have a range. user-defined aggregate types and integer types cannot have scale or precision specified. Example: "x number(5,3)" is acceptable but "x number range 1..10" is not.

Action: Remove the constraint.

PLS-00573 cannot constrain scale, precision, or range of an anchored type declaration

Cause: A variable declared with %TYPE or %ROWTYPE cannot have a scale, precision, or range constraint. Example: x y%TYPE(10) is not acceptable. It is legal to add "NOT NULL" or non-conflicting CHARACTER SET constraints to anchored type declarations.

Action: Remove the constraint or use a type name instead of an anchored type.

PLS-00580 supertype must be an object type

Cause: An attempt was made to declare an object type to have a supertype, but the specified supertype was not itself an object type. Object types can inherit only from other object types.

Action: Remove the supertype specification, or change it to refer to an object type. If the declaration appears correct, make sure the supertype has compiled correctly.

PLS-00581 inheritance is not supported for opaque types

Cause: An attempt was made to declare an opaque type with a supertype.

Action: Remove the supertype specification.

PLS-00582 attribute declarations are not allowed in opaque types

Cause: An attempt was made to declare an attribute in an opaque type.

Action: Remove the attribute declaration.

PLS-00583 size must be specified if opaque type is fixed-length

Cause: An attempt was made to declare a fixed-length opaque type without specifying an explicit size.

Action: Specify an explicit size, or change the declaration to be varying-length.

PLS-00584 size of an opaque type must be between 1 and 4000 bytes

Cause: An attempt was made to specify an explicit size for an opaque type, but the specified size was out of the valid range.

Action: Change the explicit size to be between 1 and 4000 bytes, or change the declaration to be varying-length without an explicit size.

PLS-00585 declared support library for opaque type is not a library

Cause: An attempt was made to name a support library for an opaque type, but the name refers to an object that is not a library.

Action: Change the declaration to name a valid library.

PLS-00586 a static method cannot declare a parameter named SELF

Cause: An attempt was made to name a parameter SELF when declaring a static method. SELF is reserved as a parameter name in methods, to hold the object instance on which the method is applied. A parameter named SELF is not allowed in static methods because static methods do not apply to a particular object instance.

Action: Change the name of the parameter in the declaration.

PLS-00587 a static method cannot be invoked on an instance value

Cause: An attempt was made to use an object instance value, not a type name, as the qualifier of the name of a method invocation, but only a type name can be used as the qualifier when calling a static method.

Action: Use the type name, not an object instance value, to qualify the name of a method if the method is static.

PLS-00588 unqualified instance attribute references allowed only in member methods

Cause: An attempt was made to use the name of an object instance attribute in the body of a static method, or in an initialization default value on another attribute. If the instance attribute is not qualified with a particular object instance that supplies a value, the instance attribute can be named only when it is inside a member method.

Action: Qualify the attribute reference with the name of an object value, or change the containing method to a member method rather than a static method.

PLS-00589 no attributes found in object type "string"

Cause: Table of non-ADT type is defined.

Action: Table of type should be of ADT type only.

PLS-00590 attempting to create a subtype UNDER a FINAL type

Cause: An attempt was made to create a subtype UNDER a FINAL type.

Action: Avoid deriving a subtype from this FINAL type.

PLS-00591 this feature is not supported in client-side programs

Cause: One of the following features was used in a wrong context:

  • pragma AUTONOMOUS_TRANS
  • dynamic SQL statements (for example, EXECUTE IMMEDIATE)
  • bulk binds

These listed features can only be used in server-side programs but not client-side programs.

Action: Remove it or define a server-side subprogram to do the work and call the subprogram from the client.

PLS-00592 the type of a object table must be an object type

Cause: A typed-table of a non-object type was defined.

Action: Replace the non-object type with an object-type.

PLS-00593 default value of parameter 'string' in body must match that of spec

Cause: The default value initialization of a parameter in a subprogram body contained in a package body did not match that of the corresponding subprogram specification in the corresponding package specification.

Action: Change the default initialization of the parameter in body to match that of the specification.

PLS-00594 the SELF parameter can be declared only as IN or as IN OUT

Cause: The SELF parameter was declared as an OUT parameter.

Action: Declare the SELF parameter as either an IN or an IN OUT parameter.

PLS-00595 the TABLE operator is not allowed in this context

Cause: The TABLE operator was used as an argument to a SELECT or CAST statement.

Action: Remove the TABLE operator from the SELECT list items or from argument of CAST operator. Make sure that the TABLE operator appears only in the FROM clause.

PLS-00597 expression string in the INTO list is of wrong type

Cause: This exception is raised for the following errors:

  • the expression in INTO clause of OPEN or RETURNING statement is neither of legal SQL datatypes nor of PL/SQL RECORD datatype
  • a collection of records is used in INTO clause of OPEN or RETURNING statement.
  • a record or a collection of records is used in BULK COLLECT INTO

Action: Use expression with correct datatype in the INTO clause.

PLS-00598 comparison of object with NULL using string is not allowed

Cause: An object is compared with NULL using a relational operator.

Action: Use IS NULL comparison operator.

PLS-00599 SAMPLE percentage must be in the range [0.000001,100)

Cause: The percentage number is not in the range [0.000001,100).

Action: Use a percentage number in the range [0.000001,100).

PLS-00600 SAMPLE cannot be applied to a remote object

Cause: SAMPLE applying to a remote object is not supported.

Action: Do not use SAMPLE with a remote object.

PLS-00601 partition extended object names may only be used with tables

Cause: User attempted to use a partition-extended object name with an object which is not a table.

Action: Avoid using partition-extended name syntax with objects which are not tables.

PLS-00602 CUBE and ROLLUP may appear only in a GROUP BY clause

Cause: User attempted to use the keywords CUBE or ROLLUP outside a GROUP BY clause.

Action: Avoid using the keywords CUBE and ROLLUP outside the GROUP BY clause.

PLS-00603 GROUPING function supported only with GROUP BY CUBE or ROLLUP

Cause: User attempted to use the GROUPING function without GROUP BY CUBE or GROUP BY ROLLUP.

Action: Avoid using the GROUPING function without GROUP BY CUBE or GROUP BY ROLLUP.

PLS-00604 aggregate function is not allowed here

Cause: One of the functions, such as AVG, COUNT, MAX, MIN, SUM, STDDEV, or VARIANCE, was used in a WHERE or GROUP BY clause.

Action: Remove the group function from the WHERE or GROUP BY clause. The desired result may be achieved by including the function in a subquery or HAVING clause.

PLS-00605 set operators are not yet supported as an argument to a MULTISET operator

Cause: A set operator was used in a subquery that was the argument to a MULTISET operator.

Action: Rewrite the SQL statement so that it does not use a set operator in the subquery that is the argument to the MULTISET operator.

PLS-00606 cursor subquery is not supported on client side in this release

Cause: A query that contains a cursor subquery is being used from client side.

Action: Use this feature from server side only.

PLS-00607 SQLJ Object Types can have only SQLJ Types as its supertype or subtype

Cause: You were trying to create a SQLJ Object Type under a non-SQLJ Object Type.

Action: Recreate the type as a SQLJ Object Type.

PLS-00608 the value of the USING clause must match that of the supertype

Cause: You were trying to create a SQLJ Object Type with a different value of the USING clause from the USING clause specified in its supertype.

Action: Change the value of the USING clause to match the USING clause in its supertype.

PLS-00609 the OVERRIDING clause is not valid for SQLJ Object Types

Cause: You were trying to a SQLJ Object Type method that override an inherited method.

Action: Change the SQLJ Object Type definition by removing the OVERRIDING method.

PLS-00610 ROW can be used only once in SET clause of UPDATE statement

Cause: You were trying to use ROW more than once in UPDATE statement.

Action: Remove all the additional ROW in set clause of UPDATE statement.

PLS-00611 right hand side can be only the variables of record type

Cause: With ROW on LHS, only PL/SQL records or %ROWTYPE variables are allowed on right hand side.

Action: Make appropriate changes, so that right hande side should only have variables of record or %ROWTYPE.

PLS-00612 Number of attributes do not match in SET clause

Cause: Number of columns do not match with number of attributes on record type on rhs.

Action: Make sure that number of columns match with the number of attributes in record on rhs.

PLS-00613 only one item is allowed, when using variables of record type

Cause: You are trying to use more than one value in VALUES clause or RETURNING INTO clause, when one of the value is of record type.

Action: Specify only one variable of record type, or don't use variables of record type.

PLS-00614 creating a FINAL NOT INSTANTIABLE type

Cause: An attempt was made to create a FINAL NOT INSTANTIABLE type. No useful operation can be performed with this type.

Action: Avoid using the keywords FINAL and NOT INSTANTIABLE together when creating types.

PLS-00615 type mismatch found at 'string' between CASE operand and WHEN operands

Cause: In a simple CASE statement or expression, the CASE operand and WHEN operands do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.

Action: Change the CASE operand and WHEN operands so that their datatypes match. Consider using datatype conversion functions in either the CASE operand or WHEN operands.

PLS-00616 type mismatch found at 'string' among result expressions in a CASE expression

Cause: In a CASE expression, the result expressions do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.

Action: Change the result expressions so that their datatypes match. Consider using datatype conversion functions in the result expressions.

PLS-00617 at least one result in the CASE expression must not be NULL

Cause: All the results in the CASE expression are the literal NULL.

Action: Change at least one result in the CASE expression to be non-NULL.

PLS-00618 type mismatch found at 'string' between operands in a NULLIF expression

Cause: In a NULLIF expression, the two operands do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.

Action: Change the operands so that their datatypes match. Consider using datatype conversion functions in the operands.

PLS-00619 the first operand in the NULLIF expression must not be NULL

Cause: The first operand in the NULLIF expression is the literal NULL.

Action: Change the first operand in the NULLIF expression to be non-NULL.

PLS-00620 type mismatch found at 'string' among operands in a COALESCE expression

Cause: In a COALESCE expression, the operands do not match in datatype, and it is unclear which implicit conversion is required to correct the mismatch.

Action: Change the operands so that their datatypes match. Consider using datatype conversion functions in the operands.

PLS-00621 at least one operand in the COALESCE expression must not be NULL

Cause: All the operands in the COALESCE expression are the literal NULL.

Action: Change at least one operand in the COALESCE expression to be non-NULL.

PLS-00622 range constraints must be between -2147483647 and 2147483647

Cause: The range constraints specified for a pls_integer or binary_integer declaration did not fall between -2147483647 and 2147483647.

Action: Use range constraints between -2147483647 and 2147483647.

PLS-00623 FLOAT precision constraint must be between 1 and 126

Cause: The precision specified for a FLOAT, REAL, or DOUBLE PRECISION did not fall between 1 and 126.

Action: Use precision constraints between 1 and 126.

PLS-00624 USING clause must be used with either aggregate or pipelined functions

Cause: USING clause cannot be used with functions that are not declared with AGGREGATE or PIPELINED properties.

Action: Define function body in PL/SQL or some other language (using external callout call specification).

PLS-00625 PARTITION/CLUSTER/ORDER-BY clause can only be used with IN parameters

Cause: A PARTITION/CLUSTER/ORDER-BY clause was used with an OUT or IN OUT ref-cursor parameter.

Action: Change the parameter mode to IN or use some other parameter with the PARTITION/CLUSTER/ORDER-BY clause.

PLS-00626 partitioned/clustered/ordered parameter must be a function argument

Cause: A partitioning or clustering/ordering specification specified on an argument that is not one of the function arguments.

Action: Specify partitioning/clustering/ordering based on the function ref-cursor formal argument.

PLS-00627 'string' must be a strongly typed ref cursor

Cause: A partitioning or clustering/ordering specification specified on an argument that is not a strongly typed ref cursor.

Action: Specify partitioning/clustering/ordering based on the function ref-cursor formal argument.

PLS-00628 'string' must be a valid record attribute

Cause: A partitioning or clustering/ordering specification must use only valid record attributes.

Action: Specify partitioning/clustering/ordering based on valid record attributes.

PLS-00629 PIPE statement cannot be used in non-pipelined functions

Cause: A PIPE statement was used in a non-pipelined function.

Action: Use PIPE statements only in pipelined functions.

PLS-00630 pipelined functions must have a collection return type

Cause: A pipelined function was specified with a non-collection return type.

Action: Specify a collection type as the pipelined function return type.

PLS-00631 PARTITION-BY and CLUSTER/ORDER-BY clauses must be used with the same function argument

Cause: PARTITION-BY and CLUSTER/ORDER-BY clauses are specified on different function arguments.

Action: Use the same argument in both PARTITION-BY and CLUSTER/ORDER-BY clauses.

PLS-00632 NOT INSTANTIABLE method cannot have a body

Cause: An attempt was made to provide an implementation for a NOT INSTANTIABLE method.

Action: Remove the implementation for the NOT INSTANTIABLE method.

PLS-00633 RETURN statement in a pipelined function cannot contain an expression

Cause: A RETURN statement in a pipelined function contains an expression, which is not allowed. Pipelined functions must send back values to the caller by using the PIPE statement.

Action: Remove the expression from the RETURN statement and use a PIPE statement to return values. Alternatively, convert the function into a non-pipelined function.

PLS-00634 type with NOT INSTANTIABLE methods must be declared NOT INSTANTIABLE

Cause: The type being created contains NOT INSTANTIABLE methods, either declared or inherited. The type must be explicitly declared NOT INSTANTIABLE.

Action: Explicitly specify the NOT INSTANTIABLE keyword or provide implementations for all the NOT INSTANTIABLE methods.

PLS-00635 method does not override

Cause: The method specification contains the OVERRIDING keyword but the method does not override a method in the ancestor types.

Action: Check the method specification.

PLS-00636 overriding method requires OVERRIDING keyword

Cause: An attempt was made to provide an overriding method specification but the OVERRIDING keyword was not specified.

Action: Modify the method specification and specify the OVERRIDING keyword.

PLS-00637 FINAL method cannot be overriden or hidden

Cause: An attempt was made to override a FINAL MEMBER method or hide a FINAL STATIC method.

Action: Avoid overriding FINAL MEMBER methods or hiding FINAL STATIC methods.

PLS-00638 cannot overload MAP method

Cause: The MAP method does override the inherited one.

Action: Make the specifications match.

PLS-00639 NCHAR/NVARCHAR2 cannot be byte length semantics

Cause: NCHAR/NVARCHAR can only be codepoint length sematics. BYTE qualifiers used with NCHAR are illegal:

nc NCHAR(7 BYTE);

name NVARCHAR2(10 byte);

Action: Remove BYTE qualifier to make it as codepoint length semantics.

PLS-00640 a pipelined function cannot be called from PL/SQL context

Cause: A pipelined function was invoked from a PL/SQL expression.

Action: Use the pipelined function in the FROM clause of a SQL query.

PLS-00641 INTO clause not allowed for this SELECT statement

Cause: A SELECT statement in a cursor definition, an OPEN statement, or a cursor FOR loop has an erroneous INTO clause.

Action: Remove the INTO clause.

PLS-00642 local collection types not allowed in SQL statements

Cause: A locally-defined (that is not schema level) collection type was used in a SQL statement. The type must be defined in a schema to be accepted in a SQL statement.

Action: Define the collection type in your schema, not inside a PL/SQL subprogram.

PLS-00643 booleans, index tables, records and cursors not allowed in SQL statements

Cause: Items of type boolean, table of foo index by binary_integer, record and static cursors cannot be used in SQL statements.

Action: Remove expressions of these types from the SQL statement.

PLS-00644 character set mismatch found at 'string' among result expressions in a CASE expression

Cause: In a CASE expression, the result expressions do not match in character set, and it is unclear which implicit conversion is required to correct the mismatch.

Action: Change the result expressions so that their character sets match.

PLS-00645 character set mismatch found at 'string' among operands in a COALESCE expression

Cause: In a COALESCE expression, the operands do not match in character set and it is unclear which implicit conversion is required to correct the mismatch.

Action: Change the operands so that their character sets match.

PLS-00646 MAP or ORDER method must be defined in the root of the subtype hierarchy

Cause: An attempt was made to define a MAP or ORDER method in a subtype.

Action: Define the MAP or ORDER method in the root of the subtype hierarchy. You can override MAP methods in subtypes.

PLS-00647 attribute by name "string" conflicts with method by same name

Cause: While creating a subtype, some attribute name conflicted with a method name.

Action: Use a different name for attribute or method in the type being created.

PLS-00648 type of supertype attribute "string" can not be a subtype or reference to a subtype in this release

Cause: User tried to complete a type, Tsub as a subtype of another type, Tsuper where Tsuper contained an attribute of type Tsub or of type REF to Tsub. This is an implementation restriction.

Action: Change the design of code to not use any type with attribute whose type is of subtype or REF to subtype.

PLS-00649 method "string" can be overridden only once per object type

Cause: User tried to override the method more than once in the same subtype.

Action: Either make this an extra overload by removing the OVERRIDING keyword where the method signature is different. The argument types should be reconsidered otherwise.

PLS-00650 invalid type for PARTITION/CLUSTER/ORDER BY clause

Cause: An attempt was made to use an invalid type for either PARTITION BY, ORDER BY, or CLUSTER BY clauses.

Action: Use legal, allowed types.

PLS-00651 implementation type in Aggregate/Table function should be a valid type

Cause: An attempt was made to use some other database object, such as a package, to define an implementation type of an aggregate/table function.

Action: Use a valid user-defined type as an implementation type.

PLS-00652 aggregate functions should have exactly one argument

Cause: An attempt was made to create an aggregate function with either 0 or more than one arguments.

Action: Do not create aggregate functions with 0 or more than one arguments.

PLS-00653 aggregate/table functions are not allowed in PL/SQL scope

Cause: An attempt was made to use a table/aggregate function in PL/SQL scope.

Action: Do not use table/aggregate functions in PL/SQL scope.

PLS-00654 PARTITION/ORDER/CLUSTER BY is only allowed for with PARALLEL_ENABLE

Cause: An attempt was made to use either PARTITION BY, ORDER BY, or CLUSTER BY clauses without parallel enable clause in table function.

Action: Specify parallel enable also when using PARTITION BY, CLUSTER BY, or ORDER BY clauses.

PLS-00655 only functions can be declared as PIPELINED

Cause: An attempt was made to declare a procedure to be a pipelined function.

Action: Declare a function instead of a procedure to be a pipelined function.

PLS-00656 field 'string' not available in input argument

Cause: An EXTRACT operation specified a field that was not present. For example, an attempt was made to extract the YEAR field from a TIME variable.

Action: Specify a legal field in the call to EXTRACT.

PLS-00657 Implementation restriction: bulk SQL with associative arrays with VARCHAR2 key is not supported.

Cause: Variable or expression of associative array type was used as bulk SQL bind or define.

Action: Use collection types supported by bulk SQL.

PLS-00658 constructor method name must match type name

Cause: The name of the object type constructor does not match the type name.

Action: Change the name of the constructor method to match the type name.

PLS-00659 constructor method must return SELF AS RESULT

Cause: The return clause of the constructor method did not specify SELF AS RESULT.

Action: Change the return clause to include RETURN SELF AS RESULT.

PLS-00660 SELF parameter of constructor method must be IN OUT

Cause: The mode of the SELF parameter of the constructor was not IN OUT.

Action: Change the mode of the SELF parameter to be IN OUT.

PLS-00661 RETURN statement in a CONSTRUCTOR cannot include an expression

Cause: An attempt was made to include an expression in the RETURN statement of a CONSTRUCTOR body.

Action: Remove the expression from the RETURN statement.

PLS-00662 Non-external object types containing external mapped attributes are not allowed

Cause: An attempt was made to create a non-external object, whose attributes are mapped externally.

Action: Create the object as an external object.

PLS-00663 the NEW keyword is not allowed in this context

Cause: The NEW keyword is not followed by a call to a constructor method.

Action: Remove the NEW keyword, or make sure the expression following it is a constructor call.

PLS-00664 Both ORDER BY and CLUSTER BY can not be specified for the same table function

Cause: An attempt was made to specify both ORDER BY and CLUSTER BY for the same table function.

Action: Specify either ORDER BY or CLUSTER BY for a table function, but not both.

PLS-00700 PRAGMA EXCEPTION_INIT of string must follow declaration of its exception in the same declarative part

Cause: An EXCEPTION_INIT pragma was not declared in the same block as its exception. They must be declared in the proper order in the same block, with the pragma declaration following the exception declaration.

Action: Place the EXCEPTION_INIT pragma directly after the exception declaration referenced by the pragma.

PLS-00701 illegal ORACLE error number string for PRAGMA EXCEPTION_INIT

Cause: The error number passed to an EXCEPTION_INIT pragma was out of range. The error number must be in the range -9999 .. -1 (excluding -100) for Oracle errors or in the range -20000 .. -20999 for user-defined errors.

Action: Use a valid error number.

PLS-00702 second argument to PRAGMA EXCEPTION_INIT must be a numeric literal

Cause: The second argument passed to an EXCEPTION_INIT pragma was something other than a numeric literal (a variable, for example). The second argument must be a numeric literal in the range -9999 .. -1 (excluding -100) for Oracle errors or in the range -20000 .. -20999 for user-defined errors.

Action: Replace the second argument with a valid error number.

PLS-00703 multiple instances of named argument in list

Cause: Two or more actual parameters in a subprogram call refer to the same formal parameter.

Action: Remove the duplicate actual parameter.

PLS-00704 'string' must be declared as an exception

Cause: The EXCEPTION_NAME parameter passed to an EXCEPTION_INIT pragma is misspelled or does not refer to a legally declared exception. Or, the pragma is misplaced; it must appear in the same declarative section, somewhere after the exception declaration.

Action: Check the spelling of the EXCEPTION_NAME parameter. Then, check the exception declaration, making sure the exception name and the keyword EXCEPTION are spelled correctly. Also make sure the pragma appears in the same declarative section somewhere after the exception declaration.

PLS-00705 exception 'string' used in expression requiring return type

Cause: An exception was referred to in an expression. Exceptions have names but not values and therefore cannot contribute values to an expression. For example, the following RETURN statement is illegal:

FUNCTION credit_limit (cust_no INTEGER) RETURN NUMBER ISlimit       NUMBER; over_limit  EXCEPTION;...      BEGIN... RETURN over_limit;  -- illegal END;

Action: Check the spelling of the identifiers in the expression, then rewrite the expression so that it does not refer to an exception.

PLS-00706 Exception string cannot be used as prefix of a selected component

Cause: An exception name was mistakenly used to qualify a reference to a component. For example, when dot notation was used to specify fields within a record, an exception name might have been coded instead of the record name.

Action: Rewrite the component reference using a valid prefix (for example, the name of a package, record, or schema).

PLS-00707 unsupported construct or internal error [string]

Cause: At run time, this is an internal error. At compile time, it indicates one of the following problems:

  • A call was made to a remote subprogram that has a parameter type or default expression not supported at the calling site.
  • An incomplete upgrade or downgrade was done to a database that has stored procedures. Perhaps incorrect versions of system packages such as STANDARD.SQL were installed.
  • A compiler bug was encountered. In such cases, legal PL/SQL syntax will fail to compile.

Action: Either report the internal error to Oracle Support Services or, depending on the problem, take one of the following actions:

  • Revise the logic of the application to use parameter types and default expressions that are supported at both the local and remote sites.
  • Complete the upgrade or downgrade properly, making sure to install correct versions of all system packages.
  • Report the legal-syntax error to Oracle Support Services. If there are line and column numbers displayed with the error message, they might help you find a workaround. For example, try recoding the offending line to avoid the bug.

PLS-00708 Pragma string must be declared in a package specification

Cause: The named pragma was not declared in a package specification, as required. For example, the pragma RESTRICT_REFERENCES must be declared in a package specification.

Action: Remove or relocate the misplaced pragma.

PLS-00709 pragma string must be declared in package specification and body

Cause: The named pragma was declared in a package specification but not in the corresponding package body or vice-versa, as well as the package body.

Action: Add the pragma to that part of the package declaration that does not have the pragma.

PLS-00710 PRAGMA AUTONOMOUS_TRANS*Action cannot be declared here

Cause: The PRAGMA was declared in an inappropriate context. This PRAGMA has to be declared in the declarative section of a procedure, a function, a top level anonymous block.

Action: Remove or relocate the misplaced pragma.

PLS-00711 PRAGMA AUTONOMOUS_TRANS*Action cannot be declared twice

Cause: The PRAGMA was declared twice in the same block.

Action: Remove the duplicate declaration of the PRAGMA.

PLS-00712 illegal option for subprogram string

Cause: Only top level subprograms or subprogram declarations in PACKAGE or TYPE specifications are allowed to have the options DETERMINISTIC or PARALLEL_ENABLE. For example, this error would be raised if the options are used in PACKAGE or TYPE body.

Action: Remove the option.

PLS-00713 attempting to instantiate a type that is NOT INSTANTIABLE

Cause: An attempt was made to instantiate a type that is defined as NOT INSTANTIABLE.

Action: Avoid instantiating variables of this NOT INSTANTIABLE type; derive an INSTANTIABLE subtype from it and instantiate variables of the subtype.

PLS-00714 supertypes's AUTHID is DEFINER but supertype and subtype are not in same schema

Cause: The supertype's AUTHID is DEFINER, but the supertype and subtype are defined in different schemas. SQL statements executed in dynamically dispatched methods can potentially pick up different values from database tables in the two schemas.

Action: Create the subtype in the same schema as the supertype.

PLS-00715 attribute or method by name 'string' does not exist

Cause: An attempt was made to drop a nonexistant method or attribute from the type being altered.

Action: Check the spelling of the attribute or method name. Make sure it is locally defined in the type and not inherited.

PLS-00716 Attribute/method 'string' can occur only once in an ALTER TYPE statement

Cause: User attempted more than one of ADD, DROP, or MODIFY on an attribute in a single ALTER TYPE statement. User attempted more than one of ADD or DROP on a method in a single ALTER TYPE statement.

Action: Do only one ADD, DROP, or MODIFY for an attribute in a single ALTER TYPE statement. Do only one ADD or DROP for a method in a single ALTER TYPE statement.

PLS-00717 method 'string' does not have matching signature among existing methods

Cause: The method to be dropped matches the name of some existing method but does not match it in signature.

Action: Make sure that a matching method signature is provided for dropping a method.

PLS-00718 type of attribute 'string' does not allow modifications to the attribute

Cause: The type of the attribute to modify is not one of VARCHAR2, NUMBER, or RAW.

Action: Only VARCHAR2, NUMBER and RAW type attributes are allowed to be modified.

PLS-00719 only widening of attribute 'string' constraints is allowed

Cause: Modification to the attribute did not widen its constraints or attempted to change the type of the attribute. For NUMBER type attributes, scale and precision can be changed to allow increase in number of digits after and before the decimal point. For VARCHAR2 and RAW type attributes the size can be increased. Other type attributes are not allowed to be modified. Change of type of attribute is also not allowed.

Action: Change the constraint specification so as to widen the existing constraints.To narrow the constraints or to change the type of the attribute, you must drop the attribute and add it with new constraints or new type. In that case you must also take appropriate steps to preserve your existing data based on the type (if you want to preserve it).Typically this will involve backing up the data and restoring it after the ALTER TYPE.

PLS-00720 type 'string' has evolved

Cause: The type has evolved. The version of the type used by the compiled code is not the same as the latest version of the type.

Action: Recompile the code to use the latest version of the type.

PLS-00721 'string' formed a non-REF mutually-dependent cycle with 'string'

Cause: This compilation was aborted because the library unit that was compiled would have formed a non-REF mutually-dependent cycle with some other library units. This happens when an attempt is made to compile types that have attributes of other types that may participate in a cycle with this type.

create type t1;create type t2 (a t1);create type t1 (a t2);

Action: Break the cycle (possibly by adding a REF or by using another type).

PLS-00722 supertypes's AUTHID is different than subtype's AUTHID

Cause: The subtype's AUTHID must be the same as the supertype's AUTHID.

Action: Create the subtype with the AUTHID of its supertype or do not specify an AUTHID for the subtype.

PLS-00723 package body cannot be compiled native if its spec was compiled non-native

Cause: The package body is being compiled to native code whereas the corresponding package specification was compiled to interpreted bytecode.

Action: Compile the package body to the same target (native code or interpreted bytecode) as its spec.

PLS-00724 package body cannot be compiled to bytecode if its spec was compiled native

Cause: The package body is being compiled to interpreted bytecode whereas the corresponding package specification was compiled to native code.

Action: Compile the package body to the same target (native code or interpreted bytecode) as its spec.

PLS-00725 type 'string' must be a supertype or subtype of the TREAT expression

Cause: In TREAT(expr AS type), type must be a supertype or subtype of expr.

PLS-00751 cannot find PACKAGE SYS_STUB_FOR_PURITY_ANALYSIS

Cause: A top level subprogram (function or procedure) cannot be created if the system package SYS_STUB_FOR_PURITY_ANALYSIS is missing in the Oracle database.

Action: Make sure the package is in the database, and retry the creation.

PLS-00801 internal error [string]

Cause: This is a generic internal error that might occur during compilation or execution. The first parameter is the internal error number.

Action: Report this error as a bug to Oracle Support Services.

PLS-00900 can't find body of unit 'string'

Cause: At run time, the body of a program unit could not be found. This can happen for one of two reasons.

  • There may be a unit 'a' which calls a module 'b', where the specification for 'b' exists but not the body. In this case, since the specification is present, there will be no compile-time errors.
  • This can occur if there is a reference to a sequence outside of the proper context such as a SQL statement. In this case, the specification of the sequence reference can be found, but it is invalid to actually run code which references the sequence outside a SQL statement, as in:
    i := seq.nextval;

Action: If caused by the first reason, create a body for the object that is being referenced. If caused by the second reason, move the sequence into a SQL statement. For example, i := seq.nextval; can be replaced by:

select seq.nextval into temp from dual; i := temp;

PLS-00901 the data type of column 'string' of table 'string' is not supported

Cause: A column in a database table belongs to a datatype that is not supported by the current release of PL/SQL.

Action: Remove the offending column from the table or copy the desired columns to another table.

PLS-00902 A READ-ONLY bind variable used in OUT or IN-OUT context

Cause: A host variable that is protected from update was used in a context that allows an update.

Action: Check the context and change the use of the host variable, or assign the value of the host variable to a PL/SQL local variable, then use the local variable instead.

PLS-00904 insufficient privilege to access object string

Cause: An attempt was made to operate on a database object without the required privilege. This error occurs, for example, if an attempt was made to UPDATE a table for which only SELECT privileges were granted.

Action: Ask the database administrator to perform the operation or to grant you the required privilege.

PLS-00905 object string is invalid

Cause: An invalid package specification or stored subprogram was referenced. A package specification or stored subprogram is invalid if its source code or any database object it references has been DROPped, REPLACEd, or ALTERed since it was last compiled.

Action: Find out what invalidated the package specification or stored subprogram, then make sure that Oracle can recompile it without errors.

PLS-00906 Compilation is not possible

Cause: The PL/SQL compiler cannot run properly because its operating environment is corrupted. For example, its error message file might be inaccessible.

Action: Check the PL/SQL operating environment, making sure that all files required by the compiler are accessible.

PLS-00907 cannot load library unit string (referenced by string)

Cause: PL/SQL is unable to find and load a library unit that was previously available. This typically happens when you try to load a unit which references another library unit that is non-existent or invalid.

Action: Provide the needed library unit.

PLS-00908 The stored format of string is not supported by this release

Cause: PL/SQL cannot understand the stored format of a library unit. It has been compiled or shrink-wrapped with a version of PL/SQL either too new or too old for this version to understand it.

Action: Recompile the library unit for this version of PL/SQL.

PLS-00909 object string is not declared or insufficient privileges to access object string

Cause: An object from the operator declaration is not declared, or it is declared but there is no sufficient privileges to access that object.

Action: Declare the object, or ask the database administrator to grant the privileges required to access the object.

PLS-00910 insufficient privilege to inherit from type string

Cause: An attempt was made to inherit from a type without the required UNDER privilege.

PLS-00920 parameter plsql_native_library_dir is not set

Cause: A PL/SQL program is being compiled natively, but the compiler parameter plsql_native_library_dir, which denotes the directory to store the native shared objects (DLL), is not set.

Action: The database administrator should set this parameter.

PLS-00921 parameter plsql_native_make_utility is not set

Cause: A PL/SQL program is being compiled natively, but the compiler parameter plsql_native_make_utility, which denotes the full path name of the make utility to make the native shared objects (DLL), is not set.

Action: The database administrator should set this parameter.

PLS-00922 parameter plsql_native_make_file_name is not set

Cause: A PL/SQL program is being compiled natively, but the compiler parameter plsql_native_make_file_name, which denotes the full path name of the make file to make the native shared objects (DLL), is not set.

Action: The database administrator should set this parameter.

PLS-00923 native compilation failed: string: string: string

Cause: The native compilation of the PL/SQL program has failed because the native shared object (DLL) could not be created successfully.

Action: The database administrator should ensure that the parameters plsql_native_c_compiler and plsql_native_linker are set correctly.

PLS-00924 native compilation is not supported on this platform

Cause: Native compilation of PL/SQL programs is not supported on this platform.

Action: Compile the PL/SQL program to bytecode by setting the PLSQL_COMPILER_FLAGS initialization parameter to INTERPRETED.

PLS-00950 In this version, PL/SQL tables can not be used in this SQL statement.

Cause: An attempt was made to create a subtype UNDER a FINAL type.

SELECT ename_tab.COUNT INTO name_count WHERE ...

Action: Remove the incorrect reference from the SQL statement.

PLS-00951 string Feature is not supported by this release

Cause: PL/SQL cannot understand something in an imported library unit. It uses some feature either too new or too old for this version to understand it.

Action: Recompile the imported library unit with this version of PL/SQL, to discover more precisely what feature is not supported.

PLS-00960 RPCs cannot use variables with schema level user-defined types in this release

Cause: Schema level user-defined types, or types which recursively use such types, cannot be used in RPCs. For example:

create type foo as object (...) create package my_pack istype my_tab is table of foo; -- on a remote server: x my_pack.my_tab@rpc;  -- illegal attempt to use type my_tab

Action: Use only PL/SQL-defined types for RPC calls. It may be necessary to add extra code to element-wise copy top-level types into local types in order to move such data through an RPC.

PLS-00970 The class name of a method must match that of EXTERNAL NAME clause in the type header

Cause: The class name defined as part of the method signature does not match the one defined in the type header in the EXTERNAL NAME clause.

create type foo as object EXTERNAL NAME 'foo' LANGUAGE JAVA (...MEMBER FUNCTION my (number) return numberEXTERNAL NAME 'bar.func(oracle.sql.NUMBER) return oracle.sql.NUMBER',...);

Action: Either omit the class name from the method signature or use the one defined in the type header.

PLS-00989 Cursor Variable in record, object, or collection is not supported by this release

Cause: A cursor variable was entered in a record, object, or collection. This is not supported in this PL/SQL release.

Action: Rewrite your application using stand-alone cursor variables and/or parameters, or, for usage in records, consider a downgrade to PL/SQL 2.3.

PLS-00990 Index Tables of Cursor Variables are disallowed

Cause: An attempt was made to build a PL/SQL index table using cursor variables.

Action: Rewrite your application, using standalone cursor variables and procedure parameters, PL/SQL index tables of records and loops.

PLS-00992 Cursor Variables cannot be FETCH'ed from

Cause: An attempt was made to perform a FETCH from a cursor variable.

Action: Consider an upgrade to PL/SQL 2.3, where this restriction is not present, or rewrite your application using OCI or precompiler for FETCH.

PLS-00993 Cursor Variables cannot be passed as RPC arguments or results

Cause: An attempt was made to pass a cursor variable to or from a remote subprogram, which is not allowed. For example, a remote procedure cannot be used to open a cursor variable because remote subprograms cannot return the values of cursor variables.

Action: Change the subprogram call to reference a local database.

PLS-00994 Cursor Variables cannot be declared as part of a package

Cause: An attempt was made to declare a cursor variable in a package specification, which is not allowed. Although REF CURSOR types can be defined in a PL/SQL block, subprogram, or package, cursor variables can be declared only in a block or subprogram.

Action: Move the cursor variable declaration into a PL/SQL block or subprogram.

PLS-00995 unhandled exception # string

Cause: An exception was raised for which no handler was found. If it cannot find a handler for a raised exception, PL/SQL returns an unhandled exception to the host environment. The number embedded in the message is an Oracle error code listed in this manual.

Action: Fix the condition that raised the exception, write an appropriate exception handler, or use the OTHERS handler. If there is an appropriate handler in the current block, the exception was raised in a declaration or exception handler, and therefore propagated immediately to the enclosing block.

PLS-00996 out of memory

Cause: A request from PL/SQL for more memory failed.

Action: Make sure that you are not referencing the wrong row in a PL/SQL table and that the program is not recursing too deeply.

PLS-00997 no cursor return types allowed in this beta version

Cause: Not available at this time.

Action: Do not use.

PLS-01400 Use of '||' token

Cause: Use of '||' token in expressions is not in ANSI's grammar. This corresponds to the "binary_add_op"'s reduction to a "CAT_" in plsql.y.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01401 Identifier over 18 characters long

Cause: Identifiers over 18 characters long are not allowed under the ANSI grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01402 Use of quoted identifier

Cause: The use of quoted identifiers is a PL/SQL extension and is not allowed under the ANSI grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01403 Comment delimiters /* */

Cause: C-style comments (introduced with the '/' and '*' characters) are not part of the ANSI grammar. To conform with ANSI, comments must be preceded by the ANSI comment introducer, '--' , and must not contain a newline.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01404 ANSI Identifiers can only consist of letters, digits, and the underscore character

Cause: ANSI identifiers can only consist of letters, digits, and the underscore character. PL/SQL allows "#" and "$" in identifiers, but these are not ANSI.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01405 Under ANSI's grammar, numeric data represented in exponent notationmust use an uppercase E

Cause: Under ANSI's grammar, numeric data represented in exponent notation must use an uppercase "E". Example: 3.45E-6 is ANSI, but 3.45e-6 is not.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01406 An identifier has been found that is considered a keyword in ANSI's grammar but not in PL/SQL's

Cause: An identifier has been found that is considered a keyword in ANSI's grammar but not in PL/SQL's.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01407 One of the identifiers CHAR, CHARACTER, or INTEGER has been redefined by the programmer

Cause: One of the identifiers "CHAR", "CHARACTER", or "INTEGER" (all ANSI keywords) has been redefined by the programmer.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01408 Use of '&' token

Cause: Use of '&' token in expressions is not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992for details.

PLS-01409 Use of 'PRIOR_' token

Cause: Use of 'PRIOR_' token in expressions is not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01410 Use of 'MOD' token

Cause: Use of 'MOD' token in expressions is not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01411 Use of 'REM' token

Cause: Use of 'REM' token in expressions is not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01412 Use of 'EXP' token

Cause: Use of 'EXP' token in expressions is not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01413 Use of NULL an expression

Cause: Use of NULL an expression not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01414 Use of qualified expression here

Cause: Use of qualified expression here is not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01415 Use of aggregate value here

Cause: Use of aggregate value here is not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01416 Use of id (value...) here

Cause: Use of id (value...) here is not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01417 Use of %attribute

Cause: Use of %attribute value here is not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01418 Subquery cannot include set operators in ANSI's grammar

Cause: Subquery cannot include set operators in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01419 Subquery must have either '*' or exactly one column in its select list

Cause: Subquery must have either '*' or exactly one column in its select list according to ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01420 INTERSECT and MINUS set operators are not ANSI

Cause: INTERSECT and MINUS set operators are not ANSI.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01421 FOR UPDATE clause

Cause: FOR UPDATE clause is not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01422 Aliases

Cause: Aliases are not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01423 Subquery on right-hand-side in set clause

Cause: Subquery on right-hand-side in set clause is not in ANSI's grammar.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01424 Non-ANSI order of clauses

Cause: ANSI specifies an ordering to clauses in a table-expression which PL/SQL does not. The ordering according to ANSI must be:

  1. from clause
  2. where clause
  3. group-by clause
  4. having clause In PL/SQL, the from clause must come first, and the clauses after it can appear in any order (with the addition of the non-ANSI connect-by clause).

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01425 Connect-by clause

Cause: ANSI does not allow connect-by clauses.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01450 This value_expression contains a nonconforming data type

Cause: This value_expression contains a nonconforming data type. Section 4.2 of X3H2, "Data types" states that: "A non-null value is either a character string or a number." Many built-in functions in STANDARD will be flagged with this warning by means of a pragma.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01451 The data types of these value_expressions must be comparable

Cause: The data types of these value_expressions must be comparable. Section 4.2 of X3H2, "Data types", states that: "A character string and a number are not comparable values." Many built-in functions in STANDARD will be flagged with this warning by means of a pragma. This warning will be place on data-type coercion functions, for example, TO_CHAR(number), that are inserted in Oracle SQL to allow non-conforming data type combinations.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01452 This function is not part of the ANSI standard

Cause: This function is not part of the ANSI standard. This warning is used to flag such functions as "POWER" that are not mentioned in the ANSI specifications.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01453 This procedure is not part of the ANSI standard

Cause: This procedure is not part of the ANSI standard. This warning is used to flag such procedures as "STOP" that are not mentioned in the ANSI specifications.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01454 No operator may be used with values of data type CHAR

Cause: No operator may be used with values of data type "character string". Section 5.9, "value_expression", syntax rule 3, of X3H2 states: "If the data type of a primary is character string, then the value_expression shall not include any operators." This warning is placed on many functions in STDBASE that take CHAR arguments.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01455 The predicates IS NULL and IS NOT NULL are defined only for column specifications

Cause: The predicates "IS NULL" and "IS NOT NULL" are defined only for column specifications, not for any other expressions. Section 5.15, "null_predicate", indicates that in the predicate "x IS NULL", x must be a column, and may not be any other kind of expression.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01456 Name length cannot exceed 3.

Cause: Name length cannot exceed 3.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01458 The set clause in an UPDATE statement requires a column name of length 1

Cause: The set clause in an UPDATE statement requires a column name of length 1.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01460 Cannot access object on a remote host

Cause: Cannot access object on a remote host.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01463 STDDEV is not a standard set function

Cause: STDDEV is not a standard set function.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01464 VARIANCE is not a standard set function

Cause: VARIANCE is not a standard set function.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01466 Null strings are not allowed

Cause: Null strings are not allowed.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01467 The value list of the IN predicate, if not a subquery, must contain only value_specifications

Cause: The value list of the IN predicate, if not a subquery, must contain only value_specifications (that is, literals and PL/SQL or embedded variables).

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01468 The first argument of the like-predicate must be a column of type character string

Cause: The first argument of the like-predicate must be a column of type character string.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01469 ANSI standard does not permit records

Cause: ANSI standard does not permit records.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01470 The escape character in the like-predicate must be a literal or a variable of type CHAR

Cause: The escape character in the like-predicate must be a literal or a variable of type character.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01471 The keyword DISTINCT must be present in a COUNT(DISTINCT sim_expr)

Cause: The keyword DISTINCT must be present in a COUNT(DISTINCT sim_expr).

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01472 In a set_function_specification, if DISTINCT is present, the expression must be a column_specification

Cause: In a set_function_specification, if DISTINCT is present, the expression must be a column_specification.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01473 Use <> instead of != or ~=

Cause: Use <> instead of != or ~=.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01474 Use of ANY is non_ANSI

Cause: Due to the combining of comparison_predicate and quantified_predicate, we may have something like sim_expr = ANY_ sim_expr, which is nonetheless accepted by kernel.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01500 Unions are not allowed in the definition of a view

Cause: Unions are not allowed in the definition of a view.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01501 Options in CREATE TABLE statement is non-ANSI.

Cause: CREATE TABLE allows only the definition of the structure of a table. None of the .SPACE__name. .PCTFREE__numeric_literal. .cluster. is ANSI.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01502 Constraint name and constraint status are non-ANSI.

Cause: Constraint name and constraint status are non-ANSI.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01503 The expression in a SET clause must not include a set function

Cause: The expression in a SET clause must not include a set function.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01504 Use of AS phase in CREATE TABLE statement is non_ANSI

Cause: CREATE TABLE allows only the definition of the structure of a table. Use of AS phase in CREATE TABLE statement is non-ANSI.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01505 ALTER is non-ANSI

Cause: ALTER is non-ANSI.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01506 CREATE INDEX is non-ANSI

Cause: CREATE INDEX is non-ANSI.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01507 DROP is non-ANSI

Cause: DROP is non-ANSI.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01701 Illegal syntax in ROLLBACK WORK statement

Cause: Illegal syntax in ROLLBACK WORK statement.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01702 Illegal syntax in COMMIT WORK statement

Cause: Illegal syntax in COMMIT WORK statement.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01703 Cursor name in CLOSE statment must be of length 1

Cause: Cursor name in CLOSE statement must be of length 1.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01704 The expressions in a sort clause must be column specs or unsigned integers, with optional ASC or DESC

Cause: The expressions in a sort clause may only be column specifications or unsigned integers, followed by optional ASC or DESC.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01705 table specified by a cursor not updatable if cursor specification has a UNION or ORDER_BY

Cause: The table specified by a cursor is not updatable if the cursor specification contains a UNION or ORDER_BY.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01707 In positioned DELETE or UPDATE statement, table must be identified in specification of cursor

Cause: In a positioned DELETE or UPDATE statement, the table deleted from or updated must be identified in the specification of the cursor.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01708 In searched DELETE, UPDATE or INSERT, table must not appear in FROM clause of subqueries in search condition

Cause: In a searched DELETE, UPDATE or INSERT statement, the table affected must not appear in a FROM clause in any of the subqueries in the search condition.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01709 value list of INSERT statement, if specified with value list rather than subquery, must be value specification

Cause: In an INSERT statement, the insert value list, if specified with a value list rather than a subquery, must be value specifications, that is, no compound expressions or column references.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01710 In a positioned DELETE or UPDATE statement, the cursor name must be of length 1

Cause: In a positioned DELETE or UPDATE statement, the cursor name must be of length 1.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01711 A SELECT statement may not contain ORDER_BY, HAVING, or GROUP_BY clause

Cause: A SELECT statement may not contain ORDER_BY, HAVING, or GROUP_BY clause.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01712 ANSI does not allow bind variables as INDICATORS

Cause: ANSI does not allow bind variables as INDICATORS.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01713 The constraints on these types do not match

Cause: The constraints on these types do not match.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01714 ANSI expects a column name not a literal value here

Cause: ANSI expects a column name not a literal value here.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01715 ANSI does not accept SAVEPOINTs

Cause: ANSI does not accept SAVEPOINTs.

Action: Refer to ANSI document ANSI X3.135-1992 for details.

PLS-01900 : character to number conversion error

Cause: There was a failure while converting a character string into a numeric value.

Action: Verify that all character strings assigned to number variables have valid numeric value interpretations.

PLS-01901 : host bind array too small

Cause: PL/SQL was unable to transfer data into a host array because the array is too small.

Action: Increase the size of the host array.

PLS-01902 : hex to raw conversion error

Cause: There was a failure while converting a hexadecimal string to a raw.

Action: Verify that the hexadecimal variable to be converted contains a valid hexadecimal value.

PLS-01903 : non-integer error number

Cause: SQLERRM() was called with a non-integer value.

Action: Make sure SQLERRM() is called with an integer value.

PLS-01904 : NULL index table key value

Cause: An attempt was made to index into a PL/SQL index table with a NULL key value.

Action: Make sure key values used to index into PL/SQL index tables are non-NULL.

PLS-01905 : character string buffer too small

Cause: An error was encountered while moving a character string from a source to a destination. This error occurs if, for example, an attempt is made to move a character string of 10 characters into a 1 character buffer. The cause of this error may not always be obvious. For example, the following will result in this error:

a varchar2(1); b number;b := 10; a := b;

An error results because an implicit conversion causes the number 10 to become the character string '10', which does not fit in the character buffer of 1 allocated for the variable a.

Action: First, look for character string assignment statements where the buffer size is mismatched. If there are none found, then consider the implicit conversion case illustrated in the example above.

PLS-01906 : raw variable length too long

Cause: The length of a raw variable being copied or assigned was too long to fit into its destination.

Action: Make sure the raw variable length is correct.

PLS-01907 : number precision too large

Cause: The number begin copied or assigned had too many digits to the left of the decimal and did not fit into its destination. In other words, there is a number precision mismatch. This error may also occur if, for example, an attempt is made to assign a character string to a number, as demonstrated below.

a varchar2(4);b number(1,1); a := '10.1'; b := a;

Action: First, check explicit number precision value mismatches. If none are found, then consider implicit conversions of other types to numbers, including conversions performed during binds.

PLS-01908 : RETURNING INTO buffer too small

Cause: PL/SQL determined that a server side DML with a RETURNING INTO clause does not use a buffer that is large enough to hold the data being returned.

Action: Increase the size of the RETURNING INTO clause buffer.

PLS-01909 : cannot assign supertype instance to subtype

Cause: An attempt was made to assign or copy a supertype instance to a container (destination) that can only hold a subtype instance.

Action: Make sure the runtime type of the source of the assignment or copy is the same type as the destination or is a subtype of the destination type.

PLS-01910 : associative array shape is not consistent with session parameters

Cause: NLS parameters affecting comparison of keys have been altered dynamically. The associative array's index is invalid.

Action: Avoid using associative arrays with string keys in applications which require frequent changes of NLS_COMP or NLS_SORT.

PLS-01911 : associative array key violates its type constraints

Cause: The key value of an element being inserted into an associative array violates the key type constraints.

Action: Relax the constraints if the key value is meant to be acceptable. Otherwise, apply a valid key value when inserting an element.

PLS-01912 instance must be of type 'string'

Cause: The run-time type of the instance is not the declared type. That is, the return value of a user defined constructor is wrong.

Action: Return the correct type.

PLS-01913 instance must be of type 'string' or one of its subtypes

Cause: The run-time type of the instance is the not declared type or one of its subtypes. That is, TREAT(supertype AS subtype) fails.

Action: Catch the exception.


Oracle OLAP Catalog Metadata Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Part VI
Oracle OLAP Catalog Metadata Messages

This part contains the following chapter:

  • Chapter 29, "Oracle OLAP Catalog Metadata Messages (AMD)"


Oracle OLAP Catalog Metadata Messages (AMD)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

29
Oracle OLAP Catalog Metadata Messages (AMD)

This chapter lists Oracle OLAP Catalog Metadata messages. For more information about Oracle OLAP, refer to the Oracle9i OLAP User's Guide.

AMD-00100 not found: string "string"

Cause: A metadata entity could not be found in the OLAP Catalog.

Action: Check that the metadata entity name and owner are properly specified. Refer to the OLAP Catalog union views named with the OLAP2U prefix) for existing OLAP metadata entity names.

AMD-00101 cannot create string "string"; metadata entity already exists

Cause: A metadata entity could not be created, because it already exists in the OLAP Catalog.

Action: When creating a new metadata entity, specify an entity name that is unique for the entity owner. Refer to the OLAP Catalog union views (named with the OLAP2U prefix) for existing OLAP metadata entity names.

AMD-00102 invalid metadata entity: string "string"

Cause: An OLAP metadata entity was found to be invalid.

Action: Check the mapping to columns in your data warehouse tables or views.

AMD-00103 string "string" does not have a string

Cause: A required child entity was not found for a metadata entity.

Action: Refer to the Oracle9i OLAP User's Guide to determine which metadata entities require dependent entities.

AMD-00104 Level "string" cannot be added to the hierarchy; parent and child parameters represent the same level

Cause: The same level name was specified for both the parent and the child parameters of the ADD_LEVEL_TO_HIERARCHY procedure.

Action: Determine which level should be the parent of the new level being added to the hierarchy. Specify the parent in the parent parameter and the new level in the child parameter of the ADD_LEVEL_TO_HIERARCHY procedure. Re-run the procedure.

AMD-00105 Level "string" cannot be added to the hierarchy; the specified parent level "string" is already the parent of "string"

Cause: The level specified as the parent in the ADD_LEVEL_TO_HIERARCHY procedure could not be used, because it was the parent of another level within the hierarchy.

Action: In the ADD_LEVEL_TO_HIERARCHY procedure, specify a parent that is not already a parent of another level within a hierarchy.

AMD-00106 parent string "string" must be removed before child string "string" can be removed

Cause: A metadata entity could not be removed, because it was the child of another metadata entity.

Action: Remove the parent metadata entity. All the dependent entities will be removed with the parent.

AMD-00107 no root level in hierarchy: "string"

Cause: A hierarchy was found to have no root level.

Action: Use the ADD_LEVEL_TO_HIERARCHY procedure to add a level to the hierarchy. Specify the root level in the child parameter and leave the parent parameter blank.

AMD-00108 Dimension "string" is improperly mapped; the dimension has string hierarchies mapped, but hierarchy level "string" has string columns mapped

Cause: Dimension table columns could not be accessed, because dimension hierarchies were incorrectly mapped.

Action: Add or remove dimension hierarchies or hierarchy level mappings. The number of dimension hierarchies must equal the number of hierarchy level columns.

AMD-00109 Parent metadata entity has too many child entities. string "string" has more than string string

Cause: A metadata entity was found to have too many dependent entities of another type.

Action: Add the required mapping.

AMD-00110 parameter string of "string" not valid

Cause: A parameter was found to be invalid.

Action: Ensure that the parameter is correctly formed and valid.

AMD-00111 PROCEDURE string, invalid directory: "string"

Cause: Directory name provided to a procedure was found to be invalid.

Action: Ensure that the directory name represents a valid directory.

AMD-00112 PROCEDURE string, invalid mode

Cause: UTL_FILE.INVALID_MODE: An error occurred when accessing a file.

Action: Check that files being accessed have correct permissions, then retry.

AMD-00113 PROCEDURE string, invalid operation

Cause: UTL_FILE.INVALID_OPERATION: An error occurred when accessing a file.

Action: Check that the file being accessed is not already opened by another program, then retry.

AMD-00114 PROCEDURE string, internal error

Cause: UTL_FILE.INTERNAL_ERROR: Possible hardware or software problem when accessing a file.

Action: Verify that hardware is functioning normally, then retry. Contact Oracle Support Services if needed.

AMD-00115 PROCEDURE string, invalid file handle

Cause: UTL_FILE.INVALID_FILEHANDLE: Possible software or hardware problem when accessing a file.

Action: Verify that hardware is functioning normally, then retry. Contact Oracle Support Services if needed.

AMD-00116 PROCEDURE string, read error

Cause: UTL_FILE.READ_ERROR: Possible software or hardware problem when accessing a file.

Action: Verify that hardware is functioning normally, then retry. Contact Oracle Support Services if needed.

AMD-00117 input file "string" not found

Cause: The input text file was not found in the specified location.

Action: Copy the input text file to the specified location, then retry.

AMD-00118 output file "string" already exists

Cause: The output file already exists in the specified location.

Action: Delete or rename the file, then retry.

AMD-00119 analytic workspace dimensions not specified in input

Cause: Either the input text file or the input string did not specify an analytic workspace dimension.

Action: Add one or more dimensions to the input text file or the input string. At least one dimension is required.

AMD-00120 dimension #string: analytic workspace dimension name not specified

Cause: Dimension name was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing dimension name.

AMD-00121 dimension #string: analytic workspace hierarchy not specified

Cause: Hierarchy for this dimension was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing hierarchy.

AMD-00122 dimension #string: analytic workspace hierarchy dimension not specified

Cause: Hierarchy dimension for this dimension was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing hierarchy dimension.

AMD-00123 dimension #string: analytic workspace hierarchy dimension value not specified

Cause: Hierarchy dimension value for this dimension was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing hierarchy dimension value.

AMD-00124 dimension #string: analytic workspace GID variable not specified

Cause: Analytic workspace GID variable for this dimension was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing Analytic Workspace GID variable.

AMD-000125 dimension #string: analytic workspace column level dimension not specified

Cause: Analytic workspace column level dimension for this dimension was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing analytic workspace column level dimension.

AMD-00126 dimension #string: analytic workspace column level relation not specified

Cause: Analytic workspace column level relation for this dimension was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing analytic workspace column level dimension.

AMD-00127 dimension #string: RDBMS dimension column not specified

Cause: RDBMS dimension column for this dimension was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing RDBMS dimension column.

AMD-00128 dimension #string: RDBMS parent column not specified

Cause: RDBMS parent column for this dimension was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing RDBMS parent column.

AMD-00129 dimension #string: RDBMS GID column not specified

Cause: RDBMS GID column for this dimension was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing RDBMS GID column.

AMD-00130 dimension #string: RDBMS dimension column data type not specified

Cause: RDBMS dimension column data type for this dimension was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing RDBMS dimension column data type.

AMD-00131 dimension #string: RDBMS parent column data type not specified

Cause: RDBMS dimension column data type for this dimension was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing RDBMS dimension column data type.

AMD-00132 dimension #string: RDBMS GID column data type not specified

Cause: RDBMS dimension column data type for this dimension was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing RDBMS dimension column data type.

AMD-00133 measure #string: analytic workspace measure name not specified

Cause: Analytic workspace measure name for this measure was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing analytic workspace measure name.

AMD-00134 measure #string: RDBMS measure column name not specified

Cause: RDBMS measure column name for this measure was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing RDBMS measure column name.

AMD-00135 measure #string: RDBMS measure column data type not specified

Cause: RDBMS measure column data type for this measure was not specified in either the input text file or the input string.

Action: Modify the input text file or the input string to include the missing RDBMS measure column data type.

AMD-00136 Generation of SQL script "string" failed

Cause: There was a program error or a system resource limit was exceeded.

Action: Verify that sufficient system resources are available, then retry.

AMD-00137 prefix "string" exceeds maximum permitted length of string characters

Cause: A prefix supplied to an API call was too long.

Action: Change the prefix so that it is within the permitted length, then re-issue the API call.

AMD-00138 level names parameter not null or defaulted

Cause: Level names were provided to the LEVELS_LIST parameter, but the LEVELS parameter did not specify the number of levels.

Action: Either set the LEVELS_LIST parameter to null (the default) or set the LEVELS parameter to the number of levels.

AMD-00139 level names parameter not valid

Cause: The number of names in the LEVELS_LIST parameter did not equal the number specified by the LEVELS parameter.

Action: Ensure that the LEVELS_LIST parameter is correctly formed and that it holds the number of names specified by the LEVELS parameter.

AMD-00140 internal error: [string] [string] [string] [string] [string]

Cause: This is an internal error.

Action: Contact Oracle Support Services.

AMD-00141 parameter string of "string" not valid starting around "string"

Cause: A parameter was found to be invalid.

Action: Ensure that the parameter is correctly formed and valid.


Network Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Part VII
Network Messages

This part contains the following chapters:

  • Chapter 30, "Oracle Net Messages (TNS)"
  • Chapter 31, "Oracle Names Client Messages (NNC)"
  • Chapter 32, "Oracle Names Server Messages (NNO)"
  • Chapter 33, "Oracle Names Control Utility Messages (NNL)"
  • Chapter 34, "Oracle Names Server Network Presentation Layer Messages (NPL)"
  • Chapter 35, "External Naming Messages (NNF)"
  • Chapter 36, "Simple Network Management Protocol Messages (NMP)"
  • Chapter 37, "Remote Operation Messages (NCR)"
  • Chapter 38, "Network Security Messages (NZE)"

For more information about network topics, refer to:

  • Oracle9i Net Services Administrator's Guide
  • Oracle Advanced Security Administrator's Guide


Oracle Net Messages (TNS)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

30
Oracle Net Messages (TNS)

TNS-00001 INTCTL: error while getting command line from the terminal

Cause: Improper standard input connection from the terminal.

Action: Normally not visible to the user. Start the INTCTL program again. If the error persists, contact Oracle Support Services.

TNS-00002 INTCTL: error while starting the Interchange

Cause: The Interchange could not be started.

Action: Check the Interchange configuration files (INTCHG.ORA, TNSNET.ORA and TNSNAV.ORA) for errors and confirm that no other programs are using the ADDRESS(es) specified. If the error continues, turn on tracing in the Interchange components and examine the trace files to determine the cause of the problem. Be sure to turn tracing off when the problem has been resolved.

TNS-00003 INTCTL: error while sending request to the Interchange

Cause: Improper command sent to the Interchange or the Interchange is not responding. This message is not normally visible to the user.

Action: Verify that the command sent to the Interchange is valid. Also check that the Interchange is running by using the INTCTL STATUS command. If necessary, start the Interchange using the INTCTL START command.

TNS-00004 INTCTL: error while starting the Navigator

Cause: The Navigator could not be started.

Action: Check to make sure that executables for the Navigator (NAVGATR) are present in the Oracle executable directory on your platform. Check the configuration files TNSNET.ORA and TNSNAV.ORA for errors. If the error continues, turn on tracing in the Interchange components and examine the trace files to determine the cause of the problem. Be sure to turn tracing off when the problem has been resolved.

TNS-00005 INTCTL: error while sending request to the Navigator

Cause: The Navigator is not responding. Either the Navigator is not running or another process is responding.

Action: Check that the Navigator is running by using the STATUS command of the Interchange Control Utility. Verify that the correct addresses are listed in the TNSNAMES.ORA, TNSNET.ORA, and TNSNAV.ORA configuration files.

TNS-00006 INTCTL: HOST variable is not defined

Cause: The HOST variable was not set.

Action: Set the variable HOST properly and restart the INTCTL program.

TNS-00007 INTCTL: unknown host

Cause: The pointer HOST is set to an unknown host name.

Action: Set the pointer HOST properly and restart INTCTL program.

TNS-00008 INTCTL: could not contact destination Navigator

Cause: Connection could not be properly established to a Navigator. This may be because the Navigator specified is not running or the Navigator addresses are incorrect.

Action: Check that the Navigator is running by using the STATUS command of the Interchange Control Utility; if necessary, start the Navigator using the START command of the Interchange Control Utility. If it is running and the error persists, contact Oracle Support Services.

TNS-00009 INTCTL: could not contact destination Connection Manager

Cause: Connection could not be properly established to a Connection Manager. This may be because the Connection Manager (Interchange) specified is not running or the Connection Manager addresses are incorrect.

Action: Make sure the Connection Manager is running by using the STATUS command of the Interchange Control Utility; if necessary, start the Connection Manager using the START command of the Interchange Control Utility. If it is running and the error persists, contact Oracle Support Services.

TNS-00010 Error while flushing NS context

Cause: Internal NS error; connection may be lost.

Action: Make sure the connection is properly established. If the error persists, then contact Oracle Support Services.

TNS-00011 INTCTL: error while starting the Connection Manager

Cause: The Connection Manager could not be started.

Action: Assure that the executable can be found in the standard Oracle executable area. Check the configuration file INTCHG.ORA for errors and confirm that no other process is using the ADDRESS(es) for this Connection Manager as specified in TNSNET.ORA. Tracing can also be turned on in the Connection Manager and detailed information about the reason for the error determined. Consult the MultiProtocol Interchange Administrator's Guide for how to turn on tracing.

TNS-00012 INTCTL: error while processing Connection Manager request

Cause: An improper command was sent to the Connection Manager or it is not responding. This message is not normally visible to the user.

Action: Verify that the correct addresses are listed in the TNSNAMES.ORA, TNSNET.ORA, and TNSNAV.ORA configuration files. Also check that the Connection Manager is running by using the STATUS command of the Interchange Control Utility. If the error persists, contact Oracle Support Services.

TNS-00013 INTCTL: error while performing NS disconnect command

Cause: Internal NS error. Error in closing down connections.

Action: Make sure the networking protocol being used is properly installed on the machine. If the error persists, contact Oracle Support Services.

TNS-00014 INTCTL: error while opening terminal input channel

Cause: Could not open standard terminal input. This is an internal error.

Action: Normally not visible to the user. Restart the INTCTL program. If the error persists, contact Oracle Support Services.

TNS-00015 INTCTL: error while closing terminal input channel

Cause: Could not close terminal input channel. This is an internal error.

Action: Normally not visible to the user. Restart the INTCTL program. If the error persists, contact Oracle Support Services.

TNS-00016 INTCTL: error while performing NS send command

Cause: This is an internal NS error. Connection may be lost.

Action: If the error persists contact Oracle Support Services.

TNS-00017 INTCTL: error while performing NS receive command

Cause: Internal NS error. Connection may be lost.

Action: If the error persists contact Oracle Support Services.

TNS-00018 INTCTL: TNS_ADMIN not defined

Cause: The TNS_ADMIN pointer is improperly set.

Action: No action necessary; TNS_ADMIN need only be set if you want to use a different network environment.

TNS-00019 INTCTL: error initializing the national language interface

Cause: The message file could not be found.

Action: Make sure that the Oracle environment is set and that the message file is in the correct place.

TNS-00020 INTCTL: missing NAVIGATOR_DATA in TNSNAV.ORA

Cause: TNSNAV.ORA does not contain the NAVIGATOR_DATA component.

Action: Define the ADDRESS(es) for the Navigator, then restart the INTCTL program.

TNS-00021 INTCTL: missing INTERCHANGE_DATA in INTCHG.ORA

Cause: INTCHG.ORA does not contain an INTERCHANGE_DATA component.

Action: Define the correct data for the Connection Manager, then restart the INTCTL program.

TNS-00022 INTCTL: missing CMANAGER_NAME in INTCHG.ORA

Cause: INTCHG.ORA does not contain a CMANAGER_NAME component.

Action: Define the correct name for the CMANAGER_NAME, then restart the INTCTL program.

TNS-00023 INTCTL: missing ADDRESS(es) in config files

Cause: Configuration files do not contain an ADDRESS/ADDRESS_LIST component.

Action: Define the Connection Manager ADDRESS(es) in the TNSNET.ORA file and check the Navigator ADDRESS(es) in the TNSNAV.ORA file, then restart the INTCTL program.

TNS-00024 INTCTL: Unable to contact Navigator to obtain Connection Manager address

Cause: The Navigator is not running.

Action: Verify that the Navigator is running by doing a status request on the Navigator (use the Interchange Control Utility command STATUS). If necessary, start the Navigator using the Interchange Control Utility. Verify that the network is properly configured; if the error persists, contact Oracle Support Services.

TNS-00025 INTCTL: The ORACLE environment is not set up correctly

Cause: The Oracle environment is incorrectly set up.

Action: Refer to the Oracle operating system-specific documentation for your platform for information on how the Oracle environment should be set. Correct it and rerun INTCTL. Make sure the Oracle environment includes the correct directories.

TNS-00026 INTCTL: TNS_ADMIN directory set, and is being used

Cause: The TNS_ADMIN environment variable is set properly. INTCTL will use the TNS_ADMIN directory. This is only an informative message.

Action: If you do not want it to be used, and want the default directory to be used instead, then unset TNS_ADMIN and re-execute.

TNS-00027 INTCTL: Could not resolve Navigator's name/address

Cause: The Navigator's name to address definition is missing.

Action: Check TNSNAMES.ORA file and make sure to include a definition for the name specified.

TNS-00028 INTCTL: Could not resolve Connection Manager's name/address

Cause: The Connection Manager's name does not have a definition that the Navigator knows about, nor is the name/address available in the TNSNAMES.ORA file. The name may also be incorrect in the INTCHG.ORA file.

Action: Verify that the Connection Manager's name is in the TNSNET.ORA file read by the Navigator or in the TNSNAMES.ORA file. Be sure that INTCHG.ORA is correct.

TNS-00031 INTCTL: internal NT error

Cause: Problem interfacing to the protocol adapters installed.

Action: Normally not visible to the user. Try starting INTCTL again. If the error persists, check the product installation. If it is correct, contact Oracle Support Services.

TNS-00032 INTCTL: internal NS error

Cause: Problem interfacing with TNS.

Action: Normally not visible to the user. Try starting INTCTL again. If the error persists, check the product installation. If it is correct, contact Oracle Support Services.

TNS-00033 INTCTL: internal NL error

Cause: Problem with internal TNS module NL.

Action: Normally not visible to the user. Try starting INTCTL again. If the error persists, check the product installation. If it is correct, contact Oracle Support Services.

TNS-00034 INTCTL: internal NR error

Cause: Problem with internal Interchange routines.

Action: Normally not visible to the user. Try starting INTCTL again. If the error persists, check the product installation. If it is correct, contact Oracle Support Services.

TNS-00035 INTCTL: error while constructing full file name

Cause: Problem while constructing the full path for a file name because the path name to the file or the environment variables are incorrect. Files looked up include TNSNAMES.ORA, TNSNAV.ORA, INTCHG.ORA and the error files for the Navigator and Connection Manager.

Action: Check that all environment variables are defined correctly and that all configuration files exist in their correct places.

TNS-00036 INTCTL: error reading from Navigator or Connection Manager error files

Cause: Problem while reading from Navigator or Connection Manager error files generated by the Navigator or Connection Manager when they fail to start.

Action: Check that a standard Network Error directory exists and that all privileges on the directory are appropriate.

TNS-00037 INTCTL: error opening Navigator or Connection Manager error files

Cause: Failed to open Navigator or Connection Manager error files when they have failed to start.

Action: Check that a Network Error directory exists and that all privileges on the directory are appropriate.

TNS-00038 INTCTL: Poorly formed address or command string

Cause: An unacceptable string was encountered while attempting to send a message to either the Navigator or Connection Manager. The addresses provided for either the Navigator or Connection Manager may be incorrectly constructed.

Action: Check all address strings in configuration files (TNSNAMES.ORA, TNSNAV.ORA or TNSNET.ORA) and assure that they are properly formed. Regenerate the files, if possible. If all is correct, contact Oracle Support Services.

TNS-00039 INTCTL: error while spawning a process

Cause: An error was encountered while spawning a process due to an internal operating system dependent problem. Machine resources may be limited.

Action: Retry the command. Check permissions on Interchange executables and the current setting of the search path. If necessary, terminate other applications to free up machine resources. If the error persists, contact Oracle Support Services.

TNS-00040 INTCTL: failed to initialize trace context- Continuing anyway

Cause: Problem while opening specified trace file because of errors in INTCHG.ORA or because the user has incorrect privileges, or the file does not exist.

Action: Check the privileges on the configuration files and ensure that all of them exist in their proper locations.

TNS-00041 INTCTL: Navigator already running. Start operation cancelled

Cause: There is a Navigator already running and listening on the same addresses.

Action: No action required. The Navigator is already running.

TNS-00042 INTCTL: CMANAGER already running. Start operation cancelled

Cause: There is a Connection Manager already running and listening on the same addresses.

Action: No action required. The Connection Manager is already running.

TNS-00043 The CMANAGER has active connections, do you still want to stop it (y/n)?

Cause: The CMANAGER that is being stopped has active connections going through. This is the confirmation message.

Action: Respond by pressing y or n. Answering y will cause the active database connection to be dropped; this is not generally recommended.

TNS-00044 INTCTL: You must have an INTCHG.ORA file to contact the Connection Manager

Cause: There was an attempt to contact a default Connection Manager (Interchange) where there was no INTCHG.ORA present in the correct directory.

Action: Create an INTCHG.ORA file. Make sure it is placed in the correct directory and includes the correct name for the Connection Manager you wish to contact.

TNS-00045 INTCTL: Could not contact the Navigator on address

Cause: There was an attempt to contact a Navigator on a specific address which is not responding.

Action: Check the TNSNAV.ORA file for that address. Or check that the Navigator is actually listening on that address.

TNS-00046 INTCTL: Could not contact the CMANAGER on address

Cause: There was an attempt to contact a CMANAGER on a specific address which is not responding.

Action: Verify that the TNSNET.ORA file contains that address. Also check that the CMANAGER is actually listening on that address by using the INTCTL STATUS command. If necessary, start the Connection Manager using the INTCTL START command.

TNS-00060 INTCTL: Bad command: only the STATUS command can be used on remote Interchanges

Cause: A command was entered that does not exist, or a request other than STATUS was made to a remote Interchange.

Action: Check the MultiProtocol Interchange Administrator's Guide for a list of INTCTL commands or type HELP for a list of valid commands.

TNS-00061 INTCTL: Bad command or syntax error: You must specify a trace level

Cause: A trace level was not specified.

Action: Specify a trace level and retry the command.

TNS-00062 INTCTL: Bad command or syntax error: For help type help/h/?

Cause: An invalid command was entered.

Action: Check the MultiProtocol Interchange Administrator's Guide or type HELP for a list of valid commands.

TNS-00063 INTCTL: Failed to allocate memory for buffers

Cause: INTCTL was unable to allocate memory for internal buffers.

Action: Check the amount of available memory on your machine to ensure that there is enough memory to run this executable. If necessary, free up memory by running fewer programs, then try again.

TNS-00064 INTCTL: Failed to find CMANAGER_NAME in INTCHG.ORA

Cause: INTCTL was unable to find the CMANAGER_NAME parameter in INTCHG.ORA.

Action: Check that the INTCHG.ORA file is properly constructed.

TNS-00065 INTCTL: Command cannot be executed remotely

Cause: A command other than status and version has been attempted remotely.

Action: If you desire execute any command other than status and version, you must run INTCTL on the interchange machine.

TNS-00070 INTCTL usage: [intctl] command process_name [argument]

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00071 where command is one of following:

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00072 * start - start up process_name

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00073 * stop/abort - stop the process_name

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00074 * status - get statistics from the process_name

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00075 NOTE: the user may get the status info of a remote

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00076 component by specifying the component name in

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00077 the argument field

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00078 * log_on - ask process_name to turn logging on

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00079 * log_off - ask process_name to turn logging off

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00080 * force_log - ask process_name to dump its state

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00081 * trace_on - ask process name to turn tracing on

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00082 NOTE: the user MUST specify a trace level

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00083 (USER or ADMIN) in the argument field

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00084 * trace_off - ask process name to turn tracing off

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00085 * reread - ask the process name to reread parameter files

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00086 * reload - ask the Navigator to reload TNSNET.ORA

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00087 * version - ask the process name to display its version number

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00088 * exit - quit the Interchange controller

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00089 process_name is one of Interchange, CMANAGER, or Navigator

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00090 * Interchange - will ask the Interchange

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00091 * Navigator (or navgatr) - will ask the Navigator only

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00092 * CMANAGER (or intlsnr) - will ask the Cmanager only

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00093 argument is only supplied to either status or trace_on

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00094 * to status - argument is considered the remote process_name

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00095 * to trace_on - argument is considered the trace level

Cause: Help message displayed by INTCTL.

Action: No action required.

TNS-00100 Unable to allocate memory

Cause: Out of memory on the machine.

Action: Add more memory or run fewer processes.

TNS-00101 File operation error

Cause: Error in accessing reading or writing a particular file.

Action: Check existence of or operating system access to the log and trace file locations.

TNS-00102 Keyword-Value binding operation error

Cause: This message is not normally visible to the user. May indicate a shortage of memory.

Action: If the error persists, contact Oracle Support Services.

TNS-00103 Parameter file load error

Cause: Parameter file process failed.

Action: Check to make sure that all parameter files necessary for the Interchange are present (TNSNAV.ORA, TNSNET.ORA and INTCHG.ORA). If these files are present and properly configured, turn on tracing and repeat the operation. Turn off tracing when the trace is complete. Look in the trace file for errors in the parameter loading process. If the error persists, contact Oracle Support Services.

TNS-00104 Data stream open/access error

Cause: Unable to open or access data stream for either log or trace files for the Interchange.

Action: Check read/write permissions on Oracle files and directories.

TNS-00105 Could not initialize tracing

Cause: The INTCHG.ORA file is improperly configured. Verify the trace parameters specified.

Action: If the error persists, contact Oracle Support Services.

TNS-00106 Failed to open log file

Cause: Unable to access or obtain write permission to create log file.

Action: Check existence of or access to log file directory.

TNS-00107 Unable to initialize TNS global data

Cause: This message is not normally visible to the user.

Action: If the error persists, contact Oracle Support Services.

TNS-00108 TNS_ADMIN not defined

Cause: TNS_ADMIN pointer is not set.

Action: Set the TNS_ADMIN pointer before running application.

TNS-00109 Message could not be printed; not enough memory

Cause: Printing of message failed due to lack of memory. Not normally visible to the user.

Action: Increase the resources on your machine. If the error persists, contact Oracle Support Services.

TNS-00110 Could not initialize network from file TNSNET.ORA

Cause: Poorly formed network information in network file.

Action: Fix network configuration data to assure that at least one Interchange is defined in TNSNET.ORA.

TNS-00111 Failed to get configuration data from file

Cause: Poorly formed configuration information in network files TNSNET.ORA or TNSNAV.ORA.

Action: Check TNSNET.ORA and TNSNAV.ORA and confirm that they are correct.

TNS-00112 Failed to find configuration file name

Cause: Name specified for configuration file was incorrect.

Action: Check for presence of the configuration file.

TNS-00113 Failed to open error log file

Cause: Could not open log file during startup of Navigator or Connection Manager due to read or write permission problems or non-existent error directory.

Action: Create the standard error directory or assure that if one is present the Interchange executables can write to it.

TNS-00114 Internal error- Allocation of addresses not performed

Cause: This is an internal error. Should not normally occur.

Action: Contact Oracle Support Services.

TNS-00115 Could not allocate pump global buffers

Cause: Not enough memory to allocate pump buffers.

Action: Decrease the number of PUMP_BUFFERS in INTCHG.ORA.

TNS-00116 Pump failed during initial bequeath

Cause: Error in assigning connection to a new pump. This error may be caused by insufficient machine resources.

Action: Attempt the connection again. The pump should recover from such a failure. If machine resources appear to be the problem, add more resources or shut down some active applications. If problem persists, contact Oracle Support Services.

TNS-00117 Internal error- No data passed through pump

Cause: This is an internal error. Data expected has not arrived yet.

Action: If the error persists, contact Oracle Support Services.

TNS-00119 Missing PUMP_CONNECTIONS in INTCHG.ORA

Cause: No PUMP_CONNECTIONS parameter specified in INTCHG.ORA.

Action: Add PUMP_CONNECTIONS parameter to INTCHG.ORA.

TNS-00120 Missing PUMPS in INTCHG.ORA

Cause: No PUMPS parameter specified.

Action: Add an appropriate number of PUMPS to INTCHG.ORA.

TNS-00121 Missing CMANAGER_NAME in INTCHG.ORA

Cause: No CMANAGER_NAME parameter specified.

Action: Define the CMANAGER_NAME parameter in INTCHG.ORA; it must match the CMANAGER_NAME parameter used in TNSNET.ORA for that Interchange.

TNS-00122 Missing ADDRESS(es) in TNSNET.ORA file

Cause: No ADDRESS or ADDRESS_LIST parameter specified in TNSNET.ORA.

Action: Define a valid set of ADDRESSes for the Connection Manager in the TNSNET.ORA file.

TNS-00123 Unable to perform a listen on configured ADDRESS(es)

Cause: Another process is already listening on this address or the ADDRESS is incorrectly defined.

Action: Check the ADDRESS(es) defined in TNSNET.ORA (for the Connection Manager) for errors. Verify that another program is not using them.

TNS-00124 Internal error - Unable to create empty address

Cause: This is an internal error. Should not normally occur.

Action: If the error persists, contact Oracle Support Services.

TNS-00125 Failed to get number of Interchanges in TNSNET.ORA

Cause: Error in the TNSNET.ORA file.

Action: Check the contents of TNSNET.ORA and eliminate errors. Regenerate the configuration files.

TNS-00126 Missing Connection Manager name and address in TNSNET.ORA

Cause: The Interchange name specified in INTCHG.ORA is not defined in the TNSNET.ORA file.

Action: Define one Connection Manager name and set of addresses for each Interchange in the network. Regenerate the configuration files.

TNS-00127 Missing Connection Manager name in TNSNET.ORA

Cause: One or more Connection Manager names are missing.

Action: Ensure that each Connection Manager name is defined in TNSNET.ORA. Regenerate TNSNET.ORA.

TNS-00128 Missing COMMUNITY in TNSNET.ORA

Cause: One or more ADDRESSes does not have a COMMUNITY assigned.

Action: Ensure that all addresses have a COMMUNITY defined in TNSNET.ORA.

TNS-00129 Internal error - Failed to create new community

Cause: This is an internal error. Should not normally occur. There may be a resource limitation problem on the machine.

Action: Stop and restart Interchange. If possible, make more memory available on the machine. If problem persists, contact Oracle Support Services.

TNS-00130 Failed to create Interchange's internal address

Cause: There is an error in one of the addresses listed in TNSNET.ORA.

Action: Check the file for errors in defining Interchanges.

TNS-00131 Missing COMMUNITY in COMMUNITY_COST_LIST in TNSNET.ORA

Cause: A COMMUNITY keyword-value pair is missing within the COMMUNITY_COST_LIST in TNSNET.ORA.

Action: Define the communities with a COMMUNITY name and associated COST in COMMUNITY_COST_LIST.

TNS-00132 COST value must be an integer greater than 0

Cause: A community has been defined in TNSNET.ORA with a COST of 0.

Action: Assign an alternate value that is greater than 0.

TNS-00133 Missing LOCAL_COMMUNITIES field in TNSNAV.ORA

Cause: Improperly configured TNSNAV.ORA file.

Action: Define the LOCAL_COMMUNITIES fields correctly in TNSNAV.ORA.

TNS-00134 Missing COMMUNITY component in addresses for the Navigator in TNSNAV.ORA

Cause: The addresses specified for the Navigator have no COMMUNITY name.

Action: Ensure that all addresses in the NAVIGATOR_ADDRESSES field have a COMMUNITY entry in the TNSNAV.ORA file.

TNS-00135 Missing TNS error message file

Cause: No error message file present.

Action: Ensure that the Oracle environment is correctly set for your platform and that there is a message directory that contains the correct error message file.

TNS-00136 Did not register product/facility for TNS error message

Cause: Error message file error.

Action: Ensure that the Oracle environment is correctly set for your platform and that there is a message directory that contains the correct error message file.

TNS-00137 Failed to get TNS error message file entry

Cause: No TNS error message file present.

Action: Ensure that the Oracle environment is correctly set for your platform and that there is a message directory that contains the correct error message file.

TNS-00138 Failed to find ORACLE executable directory

Cause: The Oracle environment is not correctly set.

Action: Ensure that the Oracle environment is correctly set and the error messages file is in the correct place.

TNS-00139 Internal - Data passed from the Interchange listener is poorly formed

Cause: An internal error occurred in Interchange.

Action: Check that you are using compatible components of the Interchange product, using the INTCTL VERSION command. If the problem persists, contact Oracle Support Services.

TNS-00140 Interchange specified was not found in network tables

Cause: Could not find the Interchange specified in a control request.

Action: Check that the Interchange specified is indeed in TNSNET.ORA.

TNS-00141 Failed to get file stream information

Cause: Error in the file stream package.

Action: No action required.

TNS-00142 Community mismatch in TNSNAV.ORA

Cause: The communities in the LOCAL_COMMUNITIES entry in TNSNAV.ORA do not correspond with all the communities in the NAVIGATOR_ADDRESSES entry.

Action: Assure that all communities in the NAVIGATOR_ADDRESSES correspond to those in the LOCAL_COMMUNITIES component.

TNS-00143 Illegal PREFERRED_CMANAGERS entry in TNSNAV.ORA

Cause: PREFERRED_CMANAGERS entry in the TNSNAV.ORA used by the Connection Manager. There should only be a PREFERRED_NAVIGATORS entry in the TNSNAV.ORA on an Interchange.

Action: Remove the PREFERRED_CMANAGERS entry from TNSNAV.ORA and assure that either no PREFERRED_NAVIGATORS entry is present or that it is correct.

TNS-00144 PUMP_CONNECTIONS value in INTCHG.ORA is too large.

Cause: The number of PUMP_CONNECTIONS specified in INTCHG.ORA is too large to be supported on this platform.

Action: Consult the Oracle operating system specific manual for the maximum value for the number of PUMP_CONNECTIONS.

TNS-00145 PUMPS value in INTCHG.ORA is too large.

Cause: The number of PUMPS specified in INTCHG.ORA is too large to be supported on this platform.

Action: Consult the Oracle operating system specific manual for the maximum value for the number of PUMPS.

TNS-00146 Internal-- Retry data request withing pump.

Cause: The data space provided in order to receive data from the pump is to small.

Action: Retry the operation with a larger buffer.

TNS-00147 Failed to start a pre-spawned pump.

Cause: The Connection Manager was unable to start a pump during startup.

Action: Check all configuration parameters and assure that they are correct. Turn on tracing to determine the area that the failure occurred in.

TNS-00200 Unable to do nsanswer on contextresult=string

Cause: Requester of service may have aborted or options negotiation failed.

Action: Try making the connection again. If the problem persists, contact Oracle Support Services.

TNS-00201 Unable to read answer connection data :string:

Cause: Improperly formed connect data sent to the Interchange listener.

Action: If the problem persists, check the application using the Interchange (it may be closing down or crashing). Contact Oracle Support Services if the problem cannot be located.

TNS-00202 Failure in redirecting call : Original to string Redirect to string

Cause: This is an internal error. Could not redirect call to a pump or other Interchange listener. The cause may be insufficient network or machine resources.

Action: Add resources or close some running applications in order to free up resources. If the error persists, contact Oracle Support Services.

TNS-00203 Unable to start tracing in intlsnr

Cause: Failure in setting up tracing for Interchange listener.

Action: Check file permissions in Network trace directory also check to make sure that if trace file names and directories are specified in INTCHG.ORA, they are correct.

TNS-00204 Started tracing in intlsnr

Cause: Internal message. Successfully started tracing information.

Action: No action required.

TNS-00205 Turning off tracing in intlsnr

Cause: Internal message. Turned off tracing in the Interchange listener.

Action: No action required.

TNS-00206 Status Information for Interchange string:

Cause: Message sent back by Interchange as header for status request.

Action: No action required.

TNS-00207 Uptime : number days number hr. number min. number sec

Cause: Part of status request.

Action: No action required.

TNS-00208 Logging : string

Cause: Part of status request.

Action: No action required.

TNS-00209 Tracing : string

Cause: Part of status request Interchange.

Action: No action required.

TNS-00210 Total Pumps Available : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00211 Total Active Pumps : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00212 Total Pumps Started : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00213 Available Connections : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00214 Total Connections in Use : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00215 Total Successful Connections : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00216 Total Failed Connections : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00217 Total Bytes of Data : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00218 Current Bytes/Sec. : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00219 Pump Strategy : string

Cause: Part of status request.

Action: No action required.

TNS-00220 Pump Breakdown--------------

Cause: Part of status request.

Action: No action required.

TNS-00221 Pump Connections Total Data Bytes/Second

Cause: Part of status request.

Action: No action required.

TNS-00222 -------------------------------------------------------------------

Cause: Part of status request.

Action: No action required.

TNS-00223 numbernumbernumbernumber

Cause: Part of status request.

Action: No action required.

TNS-00224 No more connections available

Cause: More connections were made to the Interchange than are configured in INTCHG.ORA.

Action: Wait until the Interchange is not as busy or change the number of connections allowed in INTCHG.ORA and restart the Interchange.

TNS-00225 Unable to bequeath connection to pump

Cause: Unable to start a pump because either the executable cannot be found or too many processes aare currently running on a particular machine.

Action: Reduce the number of processes on the machine or increase the resources on the machine.

TNS-00226 Unable to contact pump number to send broadcast message string

Cause: Could not call a particular pump.

Action: No action required. However, if the problem persists, contact Oracle Support Services.

TNS-00227 Unable to contact pump; Connection Manager declared pump dead

Cause: A pump became an orphaned process. A protocol adapter is not working properly or machine network resources are being over used.

Action: This error is not immediately fatal; the orphaned pump may continue to function. Restart the Interchange when convenient. If the problem persists, contact Oracle Support Services.

TNS-00228 Failure in finding pump data

Cause: Internal problem with data passed back from pump.

Action: No action required.

TNS-00229 Error in call: unable to deliver message:string:stringstringstring

Cause: Destination for call is unavailable.

Action: No action required.

TNS-00230 Cannot start new pump process:stringstringProtocol Adapter errors:number

Cause: Unable to create a new process; possibly there are too many processes on the machine.

Action: Free machine resources by exiting other applications on the Interchange machine. If the problem continues you may need more memory on the machine. If you believe there are sufficient resources on the machine but the problem persists, contact Oracle Support Services.

TNS-00231 Pump is alive

Cause: Pump log message sent to Interchange listener.

Action: No action required.

TNS-00232 Unable to setup connection

Cause: Error log message sent from pump to indicate failure in initiating connection because of errors in the call string: network problem or resource limitations.

Action: No action required.

TNS-00233 Interchange failed to make contact with destination with errors:stringstringstring

Cause: Pump call to destination failed.

Action: Check destination.

TNS-00234 Connect data for failed call:CALL DATA =stringRECEIVE DATA = :string:

Cause: Connect data supplied for error 00233.

Action: No action required.

TNS-00235 Aborting connection:Protocol Apapter errors:string;number,numberstring;number,number

Cause: Pump aborting connection because connection has been up too long, or some other network error on the connection.

Action: No action required.

TNS-00236 Failed to initialize tracing

Cause: Pump failed to initialize tracing.

Action: Check that INTCHG.ORA is properly configured.

TNS-00237 Failed to refuse connection

Cause: Connection may have aborted before error took place in Pump.

Action: No action required.

TNS-00238 Pump number @: string:

Cause: Prepended message to all pump log messages.

Action: No action required.

TNS-00239 Connection Manager has been stopped

Cause: Message sent back to control program from Interchange.

Action: No action required.

TNS-00240 Connection Manager: Logging is now ON

Cause: Message sent back to control program from Interchange.

Action: No action required.

TNS-00241 Connection Manager: Logging is now OFF

Cause: Message sent back to control program from Interchange.

Action: No action required.

TNS-00242 Connection Manager: Tracing is now ON

Cause: Message sent back to control program from Interchange.

Action: No action required.

TNS-00243 Connection Manager: Tracing is now OFF

Cause: Message sent back to control program from Interchange.

Action: No action required.

TNS-00244 Connection Manager: Request Failed

Cause: Message sent back to control program from Interchange.

Action: No action required.

TNS-00245 Connection Manager: Failed to open log file

Cause: Message sent back to control program from Interchange.

Action: No action required.

TNS-00246 Connection Manager: Failed to start tracing

Cause: Message sent back to control program from Interchange.

Action: No action required.

TNS-00247 Unable to allocate memory for configuration data from TNSNET.ORA file

Cause: Navigator failed to allocate enough memory for TNSNET.ORA configuration file.

Action: Increase machine resources available for running the Interchange or remove some other running applications from the machine.

TNS-00248 Unable to get information from file :string:Exiting with NR error:number

Cause: TNSNAV.ORA poorly configured or addresses provided are already being used by another application.

Action: Check the syntax of the TNSNAV.ORA file; if necessary, assign new addresses.

TNS-00249 Unable to read network configuration data from file string with error: string

Cause: Network configuration file TNSNET.ORA is missing or poorly configured.

Action: Check to make sure that TNSNET.ORA is properly configured.

TNS-00250 Navigator has been started

Cause: Message to log file on Navigator startup.

Action: No action required.

TNS-00251 Failure in nstest:

Cause: NS test operation failed due to an internal error.

Action: If the problem persists, there may be a network problem or resource limitations on the machine. If these do not seem to be causing the problem, contact Oracle Support Services.

TNS-00252 Unable to handle route request:string

Cause: Command requested did not exist.

Action: No action required.

TNS-00253 Error in reading network configuration data from file string with errorstring

Cause: TNSNET.ORA is poorly configured or non-existent.

Action: Check to make sure that TNSNET.ORA is properly configured.

TNS-00254 Navigator has been stopped

Cause: Message sent to Interchange control program by Navigator confirming it has been stopped.

Action: No action required.

TNS-00255 Closing down log, stopping Navigator

Cause: Log message when Navigator is stopped.

Action: No action required.

TNS-00256 Status of Navigator:

Cause: Navigator status message component.

Action: No action required.

TNS-00257 Number of Successful Requests : number

Cause: Navigator status message component.

Action: No action required.

TNS-00258 Number of Failed Requests : number

Cause: Navigator status message component.

Action: No action required.

TNS-00259 Disabled Interchange list:

Cause: Navigator status message component

Action: No action required.

TNS-00260 -------------------------------------------------------------------

Cause: Navigator status message component

Action: No action required.

TNS-00261 Interchange Name Community Link Down Time Remaining (secs)

Cause: Navigator status message component

Action: No action required.

TNS-00262 stringstringnumber

Cause: Navigator status message component

Action: No action required.

TNS-00263 Navigator: Request Failed

Cause: Response from Navigator when a particular request failed.

Action: No action required.

TNS-00264 Navigator: Failed to reload configuration data

Cause: Message sent to the Interchange control program when reload of network configuration failed. TNSNET.ORA Poorly configured or missing.

Action: No action required.

TNS-00265 Navigator: Reloaded network configuration data

Cause: Message sent to Interchange control program when reload of network is successful.

Action: No action required.

TNS-00266 Navigator: Unknown Request

Cause: Request was made to Navigator that it knows nothing about.

Action: No action required.

TNS-00267 Navigator: Internal Error

Cause: Generated when a request was made to the Navigator it knows nothing about.

Action: No action required.

TNS-00268 ON

Cause: On component of message.

Action: No action required.

TNS-00269 OFF

Cause: Off component of message.

Action: No action required.

TNS-00270 string: Terminal Errorstring

Cause: Message put out in error file of executable when it fails to start.

Action: No action required.

TNS-00271 Connection Manager

Cause: Name of the Connection Manager.

Action: No action required.

TNS-00272 Navigator

Cause: Name for the Navigator.

Action: No action required.

TNS-00273 Navigator: Logging is now ON

Cause: Message sent back to control program from Navigator.

Action: No action required.

TNS-00274 Navigator: Logging is now OFF

Cause: Message sent back to control program from Navigator.

Action: No action required.

TNS-00275 Navigator: Tracing is now ON

Cause: Message sent back to control program from Navigator.

Action: No action required.

TNS-00276 Navigator: Tracing is now OFF

Cause: Message sent back to control program from Navigator.

Action: No action required.

TNS-00277 Navigator: Request Failed

Cause: Message sent back to control program from Navigator.

Action: No action required.

TNS-00278 Navigator: Failed to Open Log file

Cause: Message sent back to control program from Navigator.

Action: No action required.

TNS-00279 Navigator: Failed to Start Tracing

Cause: Message sent back to control program from Navigator.

Action: No action required.

TNS-00280 Max Avg Bytes/Sec : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00281 Connection Manager: Forced Log output

Cause: Message sent back to control program from Connection Manager.

Action: No action required.

TNS-00282 Connection Manager: Failed to force log, logging is off

Cause: Message sent back to control program from Connection Manager.

Action: No action required.

TNS-00283 Listening on the following TNS addresses:

Cause: Message sent back to control program from Connection Manager.

Action: No action required.

TNS-00284 Imm Max Avg Bytes/Sec : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00285 Avg Connect Time (secs) : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00286 Max Connect Time (secs) : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00287 Min Connect Time (secs) : number

Cause: Part of status request for Connection Manager.

Action: No action required.

TNS-00288 Navigator: Failed to Disable Interchange

Cause: Message sent back to control program from Navigator.

Action: No action required.

TNS-00289 Navigator: Disabled Interchange

Cause: Message sent back to control program from Navigator.

Action: No action required.

TNS-00290 Navigator: Failed to Enable Interchange

Cause: Message sent back to control program from Navigator.

Action: No action required.

TNS-00291 Navigator: Enabled Interchange

Cause: Message sent back to control program from Navigator.

Action: No action required.

TNS-00292 Log File Name :string

Cause: Message sent back to control program showing log file name.

Action: No action required.

TNS-00293 Trace File Name :string

Cause: Message sent back to control program showing trace file name.

Action: No action required.

TNS-00294 Connection Manager: Security is enabled, you cannot STOP the Interchange

Cause: Message sent back to control program indicating that the connection manager is secure.

Action: No action required.

TNS-00295 Navigator: Security is enabled, you cannot STOP the Navigator

Cause: Message sent back to control program indicating that the Navigator is secure.

Action: No action required.

TNS-00296 Stoppable : string

Cause: Message sent back to control program indicating whether program can be stopped.

Action: No action required.

TNS-00297 Logging Level : string

Cause: Message sent back to control program indicating whether program can be stopped.

Action: No action required.

TNS-00298 Request to Navigator:string

Cause: Log entry for request to Navigator.

Action: No action required.

TNS-00299 Response from Navigator:string

Cause: Log entry for request to Navigator.

Action: No action required.

TNS-00300 ***Disabling Interchange : string

Cause: Log entry for disabling a particular Interchange.

Action: No action required.

TNS-00301 ***Enabling Interchange : string

Cause: Log entry for enabling a particular Interchange.

Action: No action required.

TNS-00302 Connection Manager: Unknown Request

Cause: Request sent by Interchange control program is unknown.

Action: No action required.

TNS-00303 Connection Manager: Reread parameter data

Cause: Request sent by control manager to control programming indicating that parameter data was read.

Action: No action required.

TNS-00304 Status Information for Connection Manager:

Cause: Message sent back by Interchange as header for status request.

Action: No action required.

TNS-00305 The Navigator encountered an invalid/unknown trace level

Cause: Message sent back by the Navigator indicating an invalid trace level.

Action: Reattempt the request with a correct trace level.

TNS-00306 Connection Manager encountered an invalid/unknown trace level

Cause: Message sent back by the Connection Manager indicating an invalid trace level.

Action: Reattempt the request with a correct trace level.

TNS-00307 Navigator: Reread parameter data

Cause: Request sent by the Navigator to control program indicating that parameter data was read.

Action: No action required.

TNS-00308 Navigator: Failed to open log while rereading parameter data

Cause: Request sent by the Navigator to control program indicating that it could not reopen log file after rereading parameter data.

Action: No action required.

TNS-00309 Connection Manager: Failed to open log while re-reading parameter data

Cause: Request sent by the Connection Manager to control program indicating that it could not reopen log file after rereading parameter data.

Action: No action required.

TNS-00310 Navigator: Failed to start tracing after rereading parameter data

Cause: Message sent back to control program from Navigator.

Action: No action required.

TNS-00311 Connection Manager: Failed to start tracing after rereading parameter data

Cause: Message sent back to control program from Connection Manager.

Action: No action required.

TNS-00312 Connection Manager: Failed to get version information

Cause: Message sent back to control program from Connection Manager.

Action: No action required.

TNS-00313 Navigator: Failed to get version information

Cause: Message sent back to control program from Connection Manager.

Action: No action required.

TNS-00314 Protocol Adapter Errors: number,number

Cause: Protocol Adapter errors which go with message 233.

Action: No action required.

TNS-00315 Failed to allocate larger connect data area for getting pump data: number

Cause: Could not allocate a large enough area to get pump statistics; continue without them.

Action: No action required.

TNS-00316 Ran out of data buffers in the pump

Cause: The Interchange is resource limited by having too few data buffers in the pump.

Action: If the problem persists (that is, there are a lot of log messages), increase the number of pump buffers by increasing the value of the parameter PUMP_BUFFERS in INTCHG.ORA. Then shut down and restart the Interchange to make the changes take effect.

TNS-00317 Failed to contact Connection Manager

Cause: Connection Manager is not running.

Action: Start the Connection Manager and retry.

TNS-00501 Cannot allocate memory

Cause: Sufficient memory could not be allocated to perform the desired activity.

Action: Either free some resource for TNS or add more memory to the machine. For further details, turn on tracing and re-execute the operation.

TNS-00502 Invalid argument

Cause: An internal function received an invalid parameter. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-00503 Illegal ADDRESS parameters

Cause: An illegal set of protocol adapter parameters was specified.

Action: Check the parameters within the ADDRESS section of the TNSNAMES.ORA file. It may be helpful to turn on tracing and look at the addresses specified in the trace file, checking for spelling or other errors. Be sure to turn tracing off when the trace is complete.

TNS-00504 Operation not supported

Cause: An internal function received a request to perform an operation that is not supported (on this machine). This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-00505 Operation timed out

Cause: The requested operation could not be completed within the timeout period.

Action: For further details, turn on tracing and re-execute the operation.

TNS-00506 Operation would block

Cause: An internal operation did not commence because to do so would block the current process and the user has requested that operations be non-blocking. This is an informational message.

Action: No action required.

TNS-00507 Connection closed

Cause: Normal "end of file" condition has been reached; partner has disconnected. This is an informational message.

Action: No action required.

TNS-00508 No such protocol adapter

Cause: The protocol adapter requested for this connection does not exist.

Action: Install the protocol adapter or use one that is available. Be sure that the correct protocols are listed in the configuration files.

TNS-00509 Buffer overflow

Cause: Too much data for buffer.

Action: Re-execute with larger receive buffer or smaller send buffer.

TNS-00510 Internal limit restriction exceeded

Cause: Too many files or sockets open simultaneously (or some other resource has been depleted).

Action: For further details, trace the operation for protocol details.

TNS-00511 No listener

Cause: The connect request could not be completed because no application is listening on the address specified, or the application is unable to service the connect request in a sufficiently timely manner.

Action: Ensure that the supplied destination address matches one of the addresses used by the listener. Compare the TNSNAMES.ORA entry with appropriate LISTENER.ORA file (or TNSNAV.ORA if the connection is to go by way of an Interchange. Start the listener on the remote machine.

TNS-00512 Address already in use

Cause: Specified listener address is already being used.

Action: Start your listener with an unused address.

TNS-00513 Destination host unreachable

Cause: Contact cannot be made with remote party.

Action: Make sure the network driver is functioning and the network is up.

TNS-00514 Contexts have different wait/test functions

Cause: Two protocol adapters have conflicting wait/test functions. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-00515 Connect failed because target host or object does not exist

Cause: The address specified is not valid, or the program being connected to does not exist.

Action: Ensure the ADDRESS parameters have been entered correctly; the most likely incorrect parameter is the node name. Ensure that the executable for the server exists (perhaps "oracle" is missing).

TNS-00516 Permission denied

Cause: User has insufficient privileges to perform the requested operation.

Action: Acquire necessary privileges and try again.

TNS-00517 Lost contact

Cause: Partner has unexpectedly gone away.

Action: Investigate partner application for abnormal termination.

TNS-00518 Incomplete read or write

Cause: A data send or receive failed. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-00519 Operating system resource quota exceeded

Cause: The current user has exceeded the allotted resource assigned in the operating system.

Action: Acquire more operating system resource, or perform a different function.

TNS-00520 Syntax error

Cause: The supplied connect descriptor contains illegal syntax.

Action: Check the syntax of the connect descriptor for correct syntax.

TNS-00521 Missing keyword

Cause: The supplied connect descriptor is missing one or more TNS keywords.

Action: Check the syntax, and ensure all required keywords are present.

TNS-00522 Operation was interrupted

Cause: An internal operation was interrupted and could not complete. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-00523 Previous operation was busy

Cause: Operation tried could not be successfully completed because the requested resource was busy.

Action: Attempt the operation again. If the error persists, contact Oracle Support Services.

TNS-00524 Current operation is still in progress

Cause: Internal operation is still in progress but will complete.

Action: No action required. Wait for the operation to complete.

TNS-00525 Insufficient privilege for operation

Cause: Operating system failed to complete operation because user lacked sufficient privileges.

Action: Check your platform-specific privileges.

TNS-00526 No caller (false async event)

Cause: This is an internal error.

Action: For further details, turn on tracing and re-execute the operation.

TNS-00527 Protocol Adapter not loadable

Cause: On some platforms (for example OS/2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter is missing or one of its supporting libraries is missing, then this error is returned.

Action: For further details, turn on tracing and re-execute the operation. The trace file will have the name of the shared library (or DLL) that could not be loaded.

TNS-00528 Protocol Adapter not loaded

Cause: On some platforms (for example OS/2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter has not been loaded, then this error is returned.

Action: For further details, turn on tracing and re-execute the operation. The trace file will have the name of the shared library (or DLL) that has not been loaded.

TNS-00530 Protocol adapter error

Cause: A generic protocol adapter error occurred.

Action: For further details, turn on tracing and re-execute the operation.

TNS-00532 No previous async operation to wait on

Cause: Internal protocol adapter error.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-00533 Connection dissolved or not yet made

Cause: Internal protocol adapter error.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-00534 Failed to grant connection ownership to child

Cause: Internal protocol adapter error.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-00535 Failed to send or receive disconnect message

Cause: Internal protocol adapter error.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-00536 Connection entered inappropriate state

Cause: Internal protocol adapter error.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-00537 Index into protocol adapter table is out of legal range

Cause: Internal protocol adapter error.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-00539 Network or Protocol services are down

Cause: The Network services on or from your node are not running or have stopped running.

Action: Restart your network or protocol services on this platform. If the error persists, contact Oracle Support Services.

TNS-00540 SSL protocol adapter failure

Cause: The SSL protocol adapter encountered an error.

Action: In most cases, this error should only be paired with a more meaningful ORA- error.

TNS-00541 underlying transport does not exist

Cause: The SSL protocol adapter was unable to locate an adapter for the protocol that it is going to use as the data transport.

Action: In most cases, the underlying transport is TCP. Make sure that the Oracle Net TCP/IP adapter was installed.

TNS-00542 SSL Handshake failed

Cause: The SSL protocol adapter was unable to connect to another process.

Action: This error can be caused by a variety of problems including the termination of the peer process. Enable Oracle Net tracing and attempt the connection again. The trace file should give some clues as to what the exact problem is.

TNS-00543 internal error

Cause: The SSL protocol adapter encountered an unexpected error.

Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle Support Services.

TNS-00544 unsupported operation

Cause: The SSL adapter could not perform a given command.

Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle Support Services.

TNS-00545 parameter retrieval failure

Cause: The SSL protocol adapter was not able to retrieve a configuration parameter.

Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle Support Services.

TNS-00546 control failure

Cause: The SSL protocol adapter was unable to perform a command.

Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle Support Services.

TNS-00547 user information retrieval failed

Cause: The SSL protocol adapter was unable to retrieve information about the remote user.

Action: Examine the first error in the error stack. It should describe the error in more detail.

TNS-00548 value specified for client authentication parameter is not boolean

Cause: The value specified for the parameter that specifies that SSL client authentication is to be used was not boolean.

Action: Specify a correct value for the parameter.

TNS-00549 value specified for the SSL version is not valid

Cause: The value specified for the SSL version is not valid.

Action: Specify a valid value for the SSL version.

TNS-00550 disconnection error

Cause: The SSL protocol adapter encountered an error when the underlying transport disconnected.

Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle Support Services.

TNS-00551 underlying transport connection failed

Cause: The underlying transport adapter used by the SSL adapter failed to connect.

Action: Enable Oracle Net tracing and try the connection again. If the connection fails, examine the trace file to determine the cause.

TNS-00552 no valid cipher suites were specified

Cause: SSL cipher specs were specified, but none were valid.

Action: Specify correct cipher suites.

TNS-00553 read failed

Cause: The SSL adapter failed to read data from its connection.

Action: Examine the contents of sqlnet.log for more information. Enable Oracle Net tracing and try the connection again. If the connection fails, examine the trace file to determine the cause.

TNS-00554 write failed

Cause: The SSL adapter failed to send data over its connection.

Action: Examine the contents of sqlnet.log for more information. Enable Oracle Net tracing and try the connection again. If the connection fails, examine the trace file to determine the cause.

TNS-00555 no directory specified for wallet resource locator

Cause: It was specified that a file was to be used from which to retrieve a wallet, but no directory was specified for the wallet.

Action: Specify the directory where the wallet is located.

TNS-00556 no method specified for wallet retrieval

Cause: A wallet resource locator was specified, but no method was given for the retrieval of the wallet.

Action: Specify the method by which the method is to be retrieved.

TNS-00557 unsupported wallet retrieval method

Cause: The method specified for wallet retrieval is not supported. Currently, only files are supported for wallet retrieval.

Action: Specify "FILE" as the wallet retrieval method.

TNS-00558 Entrust login failed

Cause: Entrust failed to authenticate the username, password, and/or profile name that was presented.

Action: Specify correct values for the username, password or profile name. If no data was prompted for, contact Oracle Support Services.

TNS-00559 load of Entrust certificate failed

Cause: An error occurred while attempting to validate the provided Entrust certificate.

Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle Support Services.

TNS-00560 extraction of name from Entrust certificate failed

Cause: An error occurred while attempting to extract a name from an Entrust certificate.

Action: This error is not normally visible to users. Enable Oracle Net tracing and attempt to reproduce the error. If it occurs, contact Oracle Support Services.

TNS-01000 spawn [listener_name] spawn_alias [(ARGUMENTS='arg0, arg1,...')]

Cause: Control program usage message.

Action: No action required.

TNS-01001 start [listener_name] : start listener

Cause: Control program usage message.

Action: No action required.

TNS-01002 stop [listener_name] : stop listener

Cause: Control program usage message.

Action: No action required.

TNS-01003 status [listener_name] : get the status of listener

Cause: Control program usage message.

Action: No action required.

TNS-01004 reload [listener_name] : reload the parameter files and SIDs

Cause: Control program usage message.

Action: No action required.

TNS-01005 trace OFF | USER | ADMIN | SUPPORT [listener_name] : set tracing to the specified level

Cause: Control program usage message.

Action: No action required.

TNS-01006 set password : set the password for subsequent calls

Cause: Control program usage message.

Action: No action required.

TNS-01007 quit | exit : exit LSNRCTL

Cause: Control program usage message.

Action: No action required.

TNS-01008 version [listener_name] : get the version information of the listener

Cause: Control program usage message.

Action: No action required.

TNS-01009 service [listener_name] : get the service information of the listener

Cause: Control program usage message.

Action: No action required.

TNS-01013 set|show trc_{ } [value]: set|show trace parameters of current listener

Cause: Control program usage message.

Action: No action required.

TNS-01014 set|show log_{ } [value]: set|show log parameters of current listener

Cause: Control program usage message.

Action: No action required.

TNS-01015 set|show parm_name [value]: sets|shows current listener parm values

Cause: Control program usage message.

Action: No action required.

TNS-01016 change_password [listener_name]: changes the password of the listener

Cause: Control program usage message.

Action: No action required.

TNS-01017 set|show current_listener [listener_name]: sets|shows current listener

Cause: Control program usage message.

Action: No action required.

TNS-01018 save_config [listener_name]: saves configuration changes to parameter file

Cause: Control program usage message.

Action: No action required.

TNS-01019 set rawmode ON | OFF: set output mode for services and status commands

Cause: Control program usage message.

Action: No action required.

TNS-01020 STATUS of the LISTENER

Cause: Control program status message.

Action: No action required.

TNS-01021 ------------------------

Cause: Control program status message.

Action: No action required.

TNS-01022 Alias string

Cause: Control program status message.

Action: No action required.

TNS-01023 Version string

Cause: Control program status message.

Action: No action required.

TNS-01024 Trace Level string

Cause: Control program status message.

Action: No action required.

TNS-01025 Security string

Cause: Control program status message.

Action: No action required.

TNS-01026 Start Date string

Cause: Control program status message.

Action: No action required.

TNS-01027 Listener Trace File string

Cause: Control program status message.

Action: No action required.

TNS-01028 Listener Log File string

Cause: Control program status message.

Action: No action required.

TNS-01029 Services Summary...

Cause: Control program status message.

Action: No action required.

TNS-01030 The listener supports no services

Cause: Control program status message.

Action: No action required.

TNS-01033 Listener Parameter File string

Cause: Control program status message.

Action: No action required.

TNS-01034 Uptime number days number hr. number min. number sec

Cause: Control program status message.

Action: No action required.

TNS-01036 string established:string refused:string

Cause: Control program status message.

Action: No action required.

TNS-01037 "string" established: string refused: string

Cause: Control program status message.

Action: No action required.

TNS-01038 string established:string refused:string current:string max:string state:string

Cause: Control program status message.

Action: No action required.

TNS-01039 stringhas string service handler(s)

Cause: Control program status message.

Action: No action required.

TNS-01040 SNMP string

Cause: Control program status message.

Action: No action required.

TNS-01041 string parameter "string" set to string

Cause: Control program status message.

Action: No action required.

TNS-01042 Current Listener is string

Cause: Control program status message.

Action: No action required.

TNS-01043 Password changed for string

Cause: Control program status message.

Action: No action required.

TNS-01044 string(Registered) has string service handler(s)

Cause: Control program status message.

Action: No action required.

TNS-01045 string(Not Registered) has string service handler(s)

Cause: Control program status message.

Action: No action required.

TNS-01046 Saved string configuration parameters.

Cause: Control program status message.

Action: No action required.

TNS-01047 Old Parameter File string

Cause: Control program status message.

Action: No action required.

TNS-01048 No changes to save for string.

Cause: Control program status message.

Action: No action required.

TNS-01049 string (string) has string service handler(s)

Cause: Control program status message.

Action: No action required.

TNS-01050 string

Cause: Control program general message.

Action: No action required.

TNS-01052 The command completed successfully

Cause: Control program general message.

Action: No action required.

TNS-01053 Connecting to string

Cause: Control program general message.

Action: No action required.

TNS-01054 Contacted the listener successfully

Cause: Control program general message.

Action: No action required.

TNS-01055 Successfully stopped the listener

Cause: Control program general message.

Action: No action required.

TNS-01057 Program name: string

Cause: Control program general message.

Action: No action required.

TNS-01058 Arguments : string

Cause: Control program general message.

Action: No action required.

TNS-01059 Environment : string

Cause: Control program general message.

Action: No action required.

TNS-01060 The password has has been set to: string

Cause: Control program general message.

Action: No action required.

TNS-01061 The password has not been set

Cause: Control program general message.

Action: No action required.

TNS-01062 The db subagent is already running.

Cause: Control program general message.

Action: No action required.

TNS-01063 The db subagent is not started.

Cause: Control program general message.

Action: No action required.

TNS-01064 Listener configuration changes will not be persistent

Cause: Configuration changes to the listener will not be visible when the listener starts up again as the check-pointing has been turned off in LISTENER.ORA.

Action: Edit LISTENER.ORA setting USE_CKPFILE_LISTENER=true.

TNS-01065 Raw mode is string

Cause: Control program general message.

Action: No action required.

TNS-01066 Presentation: string

Cause: Listener starting message.

Action: No action required.

TNS-01067 Service display mode is string

Cause: Control program general message.

Action: No action required.

TNS-01070 Starting string: please wait...

Cause: Listener starting message.

Action: No action required.

TNS-01071 string is set to string

Cause: Listener starting message.

Action: No action required.

TNS-01072 Started at string

Cause: Listener starting message.

Action: No action required.

TNS-01073 Listening on: string

Cause: Listener starting message.

Action: No action required.

TNS-01074 Error listening on: string

Cause: Listener starting message.

Action: No action required.

TNS-01075 Opened log file: string

Cause: Listener starting message.

Action: No action required.

TNS-01076 Opened trace file: string

Cause: Listener starting message.

Action: No action required.

TNS-01077 Opened parameter file: string

Cause: Listener starting message.

Action: No action required.

TNS-01078 Opened name lookup file: string

Cause: Listener starting message.

Action: No action required.

TNS-01079 Attempted to bequeath: string

Cause: Listener starting message.

Action: No action required.

TNS-01080 Listener failed to start. See the error message(s) above...

Cause: Listener starting message.

Action: No action required.

TNS-01081 Started with pid=string

Cause: Listener starting message.

Action: No action required.

TNS-01090 No longer listening on: string

Cause: Listener logging message.

Action: No action required.

TNS-01093 string * string * number

Cause: Listener logging message.

Action: No action required.

TNS-01094 string * number

Cause: Listener logging message.

Action: No action required.

TNS-01095 string * string * string * number

Cause: Listener logging message.

Action: No action required.

TNS-01096 string * string * string * string * string * number

Cause: Listener logging message.

Action: No action required.

TNS-01097 TIMESTAMP * CONNECT DATA [* PROTOCOL INFO] * EVENT [* SID] * RETURN CODE

Cause: Listener logging message.

Action: No action required.

TNS-01098 TIMESTAMP * TYPE * COMMAND * CONNECT INFO * CLIENT ADDR * PROTOCOL STACK * EFFECTS * ERROR

Cause: Listener logging message.

Action: No action required.

TNS-01099 string * string * string * string * string * string * string * string

Cause: Listener logging message.

Action: No action required.

TNS-01100 TNS returned error number when attempting to start the listener

Cause: The bequeath (BEQ) mechanism that LSNRCTL uses to start the listener failed.

Action: Check to ensure that the BEQ driver is installed. If it is not, then the NSERROR code returned will be 12538 (NSENODRIVER). To fix this, reinstall Net8 and make sure that the BEQ driver is selected when it is installed. If this is not the problem then the error is probably caused by the fact that the TNSLSNR executable cannot be found in the place expected in your platform's Oracle environment. Verify that the full path name of the TNSLSNR executable as displayed by LSNRCTL is correct.

TNS-01101 Could not find service name string

Cause: The service name could not be resolved by name-lookup.

Action: Verify that the listener name or service name specified to LSNRCTL has the correct name and address defined in LISTENER.ORA or in TNSNAMES.ORA.

TNS-01102 TNS application contacted was not the listener

Cause: Another TNS application such as the Interchange was listening at the address contacted. There may be another TNS application listening at the address contacted and the data returned is not in the appropriate format.

Action: Verify that the listener name or service name specified to LSNRCTL has the correct name and address defined in LISTENER.ORA or in TNSNAMES.ORA.

TNS-01103 Protocol specific component of the address is incorrectly specified

Cause: The ADDRESS used to contact the listener is not correctly specified. This error occurs because the address fails to specify the destination of the listener. The address is well formed (for example, there are no missing parentheses) but it is missing a protocol specific component. For example, this is the error returned when the HOST component is missing from a TCP/IP address string.

Action: Edit the ADDRESS in LISTENER.ORA to include the required protocol-specific keywords. For more information about the keywords required by different protocol adapters, see the Oracle operating system specific-documentation for your platform.

TNS-01106 Listener using listener name string has already been started

Cause: Another listener is already listening on one of the ADDRESSes specified.

Action: Shut down the previous listener specified by the listener name before starting this one.

TNS-01107 A valid trace level was not specified

Cause: Failed to specify a valid trace level for the LSNRCTL trace command.

Action: Specify one of OFF, USER, ADMIN, or SUPPORT. Type "LSNRCTL help trace" for more information.

TNS-01108 Listener password prompt failed

Cause: Password not entered via TTY.

Action: Enter the listener password on a TTY device.

TNS-01109 Listener password encryption failed

Cause: Possibly garbled password entered.

Action: Re-enter the listener password, using valid ASCII characters. If problem persists, contact Oracle Support Services.

TNS-01110 Mismatch - password unchanged

Cause: New password and re-entered new password are different.

Action: Re-enter the listener password, make sure that New password and re-entered new password are the same.

TNS-01111 Log status can either be ON or OFF

Cause: Failed to specify a log status value for the LSNRCTL log_status command.

Action: Specify one of ON or OFF. Type "LSNRCTL help set log_status" for more information.

TNS-01112 Plug and play can either be ON or OFF

Cause: Failed to specify a valid value for the LSNRCTL use_plugandplay command.

Action: Specify one of ON or OFF. Type "LSNRCTL help set use_plugandplay" for more information.

TNS-01113 save_config_on_stop can either be ON or OFF

Cause: Failed to specify a valid value for the LSNRCTL save_config_on_stop command.

Action: Specify one of ON or OFF. Type "LSNRCTL help set save_config_on_stop" for more information.

TNS-01150 The address of the specified listener name is incorrect

Cause: The address on which the listener attempted to listen contains a syntax error.

Action: For the listener name or service name specified to LSNRCTL, check that the address or connect descriptor is well-formed. You can find the listener name in LISTENER.ORA, or you can access the listener through the service name is TNSNAMES.ORA.

TNS-01151 Missing listener name, string, in LISTENER.ORA

Cause: The listener could not find the listener name specified.

Action: Make sure valid addresses on which to listen are specified for the listener name in LISTENER.ORA.

TNS-01152 All addresses specified for the listener name, string, failed

Cause: The listener failed to listen on any of the specified addresses.

Action: Make sure that another application is not listening on the addresses specified or check that the appropriate protocol adapters are installed. Turn on tracing and execute again for more information.

TNS-01154 SID detected in old format that is no longer supported

Cause: One of the SIDs was specified in an obsolete format.

Action: Check LISTENER.ORA for a line of the form:

sid = (SID=(ORACLE_HOME=oracle_home))

or

sid = (SID_DESC=(ORACLE_HOME=oracle_home))

The above format is no longer supported and SID_LIST_listener_name format described in the Oracle9i Net Services Administrator's Guide should be used. For example:

SID_LIST_LISTENER = (SID_LIST=(SID_DESC=(SID_NAME=sid)(ORACLE_HOME=oracle_home)))

TNS-01155 Incorrectly specified SID_LIST_string parameter in LISTENER.ORA

Cause: SID_LIST_listener_name in LISTENER.ORA has an error in it.

Action: Be sure this parameter is specified as described in the Oracle9i Net Services Administrator's Guide. For example:

SID_LIST_LISTENER = (SID_LIST=(SID_DESC=(SID_NAME=sid)(ORACLE_HOME=oracle_home)))

TNS-01156 Missing or inappropriate PROTOCOL, TIMEOUT or POOL_SIZE parameter from PRESPAWN_DESC

Cause: PRESPAWN_DESC in each SID_DESC does not have required fields.

Action: Be sure the parameters required for PRESPAWN_DESC are specified in each SID_DESC. For example:

SID_LIST_LISTENER = (SID_LIST=(SID_DESC=(SID_NAME=sid)(PRESPAWN_MAX=5)(ORACLE_HOME=oracle_home)(PRESPAWN_DESC=(PROTOCOL=tcp)(POOL_SIZE=10)(TIMEOUT=30))))

Add or correct these parameters in the LISTENER.ORA file.

TNS-01157 Can only listen on number addresses - ignoring string

Cause: Too many addresses were given to listen on.

Action: Reduce the number of addresses to listen on and use another listener to listen on the remaining addresses.

TNS-01158 Internal connection limit reached, preventing dispatcher from connecting

Cause: The internal SQL*Net connection list is full. Too many dispatchers are connected to the listener; therefore, no more dispatchers are allowed to connect.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-01159 Internal connection limit has been reached; listener has shut down

Cause: The internal SQL*Net connection list is full. The listener is configured to use too many SQL*Net connections.

Action: Reduce the number of listen addresses or services connected to the listener. For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-01167 The command string is not supported by the listener contacted

Cause: The listener does not recognize the command.

Action: This is caused when a newer version of LSNRCTL contacts an old listener. Upgrade listener if executing this command is important.

TNS-01168 Cannot allocate memory

Cause: Sufficient memory could not be allocated to perform the desired activity.

Action: Either free some resource for TNS, or add more memory to the machine. For further details, turn on tracing and re-execute the operation.

TNS-01169 The listener has not recognized the password

Cause: The security feature of the listener is preventing the intended operation.

Action: Some commands like stopping the listener are only intended to be done by database administrators. A client can only use LSNRCTL to get the status of a listener and the version of the listener software running. The command that the client attempted may not have been appropriate. If a database administrator is attempting the command then use the "set password" command at the LSNRCTL prompt with one of the appropriate passwords in the PASSWORDS_listener_name entry in LISTENER.ORA. If you do not know a password then you are trying to execute an inappropriate command.

TNS-01170 Event detection broke for address: string

Cause: The event detection mechanism for the address specified returned an error.

Action: Future attempts to detect events on this address will fail. The listener will deallocate the listen address and connections will no long be accepted for this address. This message is not normally visible to the user. For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-01171 Event detection broke for dispatcher: string

Cause: The event detection mechanism for the dispatcher specified returned an error.

Action: Future attempts to detect events on this dispatcher will fail. The listener will deallocate the dispatcher and connections will no long be redirected to this dispatcher. This message is not normally visible to the user. For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-01172 Listener has shut down since all listen addresses have been deallocated

Cause: The event detection mechanism broke and caused all listen addresses to be removed.

Action: Error 1170 has occurred and caused all the listen addresses to be deallocated. Since all the listen addresses have been removed, no more connections can be established to this listener so it shuts itself down. This message is not normally visible to the user. For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-01173 Missing or inappropriate PRESPAWN_MAX parameter from SID_DESC

Cause: PRESPAWN_MAX in each SID_DESC does not have required fields.

Action: Be sure the parameters required for SID_DESC are specified in each SID_DESC. For example:

SID_LIST_LISTENER = (SID_LIST=(SID_DESC=(SID_NAME=sid)(PRESPAWN_MAX=15)(ORACLE_HOME=oracle_home)(PRESPAWN_DESC=(PROTOCOL=tcp)(POOL_SIZE=10)(TIMEOUT=30))))

Add or correct these parameters in the LISTENER.ORA file.

TNS-01174 The sum of the POOL_SIZEs from each PRESPAWN_DESC is greater than the PRESPAWN_MAX

Cause: The minimum value for PRESPAWN_MAX should be the sum of the POOL_SIZEs.

Action: Be sure the parameters required for PRESPAWN_DESC are specified in each SID_DESC. For example:

SID_LIST_LISTENER = (SID_LIST=(SID_DESC=(SID_NAME=sid)(PRESPAWN_MAX=15)(ORACLE_HOME=oracle_home)(PRESPAWN_DESC=(PROTOCOL=tcp)(POOL_SIZE=10)(TIMEOUT=30))(PRESPAWN_DESC=(PROTOCOL=ipc)(POOL_SIZE=5)(TIMEOUT=15))))

Add or correct these parameters in the LISTENER.ORA file.

TNS-01175 Password unchanged

Cause: Unable to set the new password.

Action: Be sure to see that the new password has legal ASCII characters. Try to set the password again.

TNS-01176 Error in loading the new parameter value

Cause: Illegal values given for the parameters.

Action: Make sure that the parameter values are valid refer to the manual for the legal values for parameters.

TNS-01177 Log Status is OFF. Log file/directory unchanged

Cause: Log status needs to be set ON for changing the log file.

Action: Use the command set log_status ON to set the log status of the listener ON.

TNS-01178 Trace Level is 0. Trace file/directory unchanged

Cause: Trace Level needs to be set for changing the trace file/directory.

Action: Use the command set trc_level ON to set the trace level.

TNS-01179 Listener cannot load instance class "string"

Cause: Instance tried to register as a class unknown to listener.

Action: Check LISTENER.ORA and/or instance configuration, and reference platform documentation to find the instance classes available for the listener on this platform.

TNS-01180 Missing listener object string in Directory Server

Cause: The listener could not find the listener object specified.

Action: Make sure the listener object is present in the Directory Server.

TNS-01200 The listener must be suid root

Cause: The ownership privileges of the TNSLSNR executable are incorrect.

Action: Contact your database administrator or system administrator to change the ownership of the file to be SUID root and restart the listener. This action is necessary because the user that started the process should claim ownership.

TNS-01201 Listener cannot find executable string for SID string

Cause: The executable for the Oracle dedicated server process cannot be found.

Action: Check the appropriate SID_DESC in LISTENER.ORA to make sure that the ORACLE_HOME component is pointing to a valid location. If this component is not set, then check the value of the ORACLE_HOME environment variable.

TNS-01202 Missing the dba group (string) specified by DBA_GROUP in SID_DESC

Cause: The dba group specified is missing from /etc/group.

Action: Check the DBA_GROUP parameter in the SID_DESC in LISTENER.ORA and verify it has a valid entry in /etc/group.

TNS-01203 Missing the account (string) specified by DEFAULT_USER_ACCOUNT in SID_DESC

Cause: The unprivileged operating system account is missing from /etc/passwd.

Action: Check the DEFAULT_USER_ACCOUNT parameter in the SID_DESC in LISTENER.ORA and verify it has a valid entry in /etc/passwd. This is the account that the Oracle shadow process will be started with if the connecting client has database privileges or does not exist on this machine.

TNS-01204 Unprivileged account (string) is in dba group (string)

Cause: The unprivileged account has DBA privileges. The unprivileged account specified by DEFAULT_USER_ACCOUNT in the SID_DESC in LISTENER.ORA is a member of the dba group specified by DBA_GROUP in SID_DESC. The unprivileged account cannot belong to the dba group because this would be a security violation with OPS$ logins.

Action: Remove the unprivileged account from the dba group.

TNS-01300 ERROR at string

Cause: Listener logging message.

Action: No action required.

TNS-01301 TNS error structure:

Cause: Listener logging message.

Action: No action required.

TNS-01302 nr err code: number

Cause: Listener logging message.

Action: No action required.

TNS-01303 ns main err code: number

Cause: Listener logging message.

Action: No action required.

TNS-01304 ns secondary err code: number

Cause: Listener logging message.

Action: No action required.

TNS-01305 nt main err code: number

Cause: Listener logging message.

Action: No action required.

TNS-01306 nt secondary err code: number

Cause: Listener logging message.

Action: No action required.

TNS-01307 nt OS err code: number

Cause: Listener logging message.

Action: No action required.

TNS-01400 Instance: "string" has number handlers

Cause: Control program status message.

Action: No action required.

TNS-01401 Class: string

Cause: Control program status message.

Action: No action required.

TNS-01402 TYPE: string

Cause: Control program status message.

Action: No action required.

TNS-01403 Load: string

Cause: Control program status message.

Action: No action required.

TNS-01404 Max Load: string

Cause: Control program status message.

Action: No action required.

TNS-01405 Host: string

Cause: Control program status message.

Action: No action required.

TNS-01406 ID: string

Cause: Control program status message.

Action: No action required.

TNS-01407 Status: string Total handlers: string Relevant handlers: string

Cause: Control program status message.

Action: No action required.

TNS-01408 Instance "string", status string, has string handler(s) for this service

Cause: Control program status message.

Action: No action required.

TNS-01409 Instance "string"

Cause: Control program status message.

Action: No action required.

TNS-01410 Service "string" has number instances

Cause: Control program status message.

Action: No action required.

TNS-01411 Service "string" has number instance(s)

Cause: Control program status message.

Action: No action required.

TNS-01412 Handler(s)

Cause: Control program status message.

Action: No action required.

TNS-01413 "string" established: string refused: string current: string max: string state: string

Cause: Control program status message.

Action: No action required.

TNS-01414 "string", state string, established string, refused string, current string, max string

Cause: Control program status message.

Action: No action required.

TNS-01415 Listening Endpoints Summary

Cause: Control program status message.

Action: No action required.

TNS-01416 Process ID string

Cause: Control program status message.

Action: No action required.

TNS-01417 "string" established:string refused:string state:string

Cause: Control program status message.

Action: No action required.

TNS-01420 Presentation: string

Cause: Control program status message.

Action: No action required.

TNS-01421 Session: string

Cause: Control program status message.

Action: No action required.

TNS-02020 set displaymode RAW | COMPAT | NORMAL | VERBOSE: output mode for lsnrctl display

Cause: Control program usage message.

Action: No action required.

TNS-02021 DIRECT_HANDOFF can be either ON or OFF.

Cause: Invalid value for the LSNRCTL DIRECT_HANDOFF parameter.

Action: Specify either ON or OFF.

TNS-02401 gbname string too long, allowed number characters

Cause: GBNAME or domain name too long.

Action: Check the GBNAME parameter in LISTENER.ORA, shorten it.

TNS-02402 Bad CLBGNAMES parameter in tnsnames.ora

Cause: CLBGNAMES parameter in TNSNAMES.ORA is bad.

Action: Check the CLBGNAMES parameter format and correct it. Make sure that the TNSNAMES.ORA file is there.

TNS-02403 Bad alias string or alias not present in tnsnames.ora

Cause: An alias was expected in TNSNAMES.ORA but was not found or was not correctly formed.

Action: Check the TNSNAMES.ORA for the alias and make sure it is correctly formed.

TNS-02404 Service string contains no local handlers

Cause: The listener found no suitable handler to redirect to.

Action: Make sure that there is at least one handler for this node.

TNS-02405 GMS call failed, check GMS logs.

Cause: A GMS call made by the listener failed.

Action: Check if the GMS is up and running. See GMS-client trace files for more information.

TNS-02501 Authentication: no more roles

Cause: When a process attempted to retrieve a role from the authentication service, no more were available.

Action: No action required. This error is used internally and occurs in the normal course of events.

TNS-02502 Authentication: unable to find initialization function

Cause: The native authentication service was unable to call the initialization function for the specified service because it does not exist.

Action: If this service adaptor came directly from Oracle, contact Oracle Support Services, as this error should never happen. Otherwise, add an initialization function for the service being used.

TNS-02503 Parameter retrieval failed

Cause: The native service layer was unable to retrieve a parameter from a configuration file.

Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Support Services.

TNS-02504 Parameter count retrieval failed

Cause: The native service layer was unable to determine the number of arguments given for a configuration parameter.

Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Support Services.

TNS-02505 Authentication: null context pointer provided

Cause: The function NAU_INI() was passed a null pointer as the pointer to the context that it is supposed to use.

Action: Call NAU_INI() with a pointer to a context structure.

TNS-02506 Authentication: no type string

Cause: An authentication context structure does not contain a string that describes the authentication service being used.

Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Support Services.

TNS-02507 Encryption: algorithm not installed

Cause: After picking an algorithm, the server was unable to find an index for it in its table of algorithms. This should be impossible because the algorithm was chosen (indirectly) from that list. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-02508 Encryption: server negotiation response in error

Cause: The server's response in negotiation was in error. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-02509 Authentication: invalid process state

Cause: The state in which a process is running does not correspond to any of the values which are valid.

Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Support Services.

TNS-02510 Invalid numeric data type

Cause: The type of a piece of numeric data that was received does not correspond to one of the valid values.

Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Support Services.

TNS-02511 Invalid data type

Cause: The type of a piece of data that was received or to be transmitted did not correspond to any of the correct values.

Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Support Services.

TNS-02512 Invalid status received

Cause: A process received a value as a status flag which was unknown.

Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Support Services.

TNS-02513 Requested data type does not match retrieved type

Cause: A service requested data whose type does not match that of the segment which was sent from the other process.

Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Support Services.

TNS-02514 Invalid packet received

Cause: A process received a data packet which was not meant for the native services layer.

Action: If it is possible, enable tracing and attempt to reproduce the problem. In any event, contact Oracle Support Services.

TNS-02515 Encryption/crypto-checksumming: unknown control type

Cause: An encryption or crypto-checksumming algorithm "control" function was called, but did not recognize the "type" argument it was given. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-02516 No data available

Cause: A native service attempted to retrieve data but no data was available to be received.

Action: The error is not normally visible as it usually is only used to signal the end of a data stream. If the error becomes visible, enable tracing to reproduce the problem and contact Oracle Support Services.

TNS-02517 key smaller than requested size

Cause: The key returned by negotiation was smaller than the size requested by some service (either encryption or crypto-checksumming).

Action: The error is not normally visible. If the error persists, enable tracing to reproduce the problem and contact Oracle Support Services.

TNS-02518 key negotiation error

Cause: An error occurred while the two sides of the connection were negotiating an encryption or crypto-checksumming key.

Action: The error is not normally visible. If the error persists, enable tracing to reproduce the problem and contact Oracle Support Services.

TNS-02519 no appropriate key-negotiation parameters

Cause: No appropriate key-negotiation parameters are available for the key size requested either by encryption or by crypto- checksumming.

Action: The error is not normally visible. Enable tracing to reproduce the problem and contact Oracle Support Services.

TNS-02520 encryption/crypto-checksumming: no Diffie-Hellman seed

Cause: The sqlnet.crypto_seed parameter is missing from the SQLNET.ORA parameters file for SQL*Net.

Action: Add this line to SQLNET.ORA:

sqlnet.crypto_seed = "randomly-chosen text"

TNS-02521 encryption/crypto-checksumming: Diffie-Hellman seed too small

Cause: The sqlnet.crypto_seed parameter in the SQLNET.ORA parameter file for SQL*Net is too small.

Action: Add more randomly-chosen text to it.

TNS-02524 Authentication: privilege check failed

Cause: An error occurred when the SQL*Net authentication service attempted to verify that a user had a specific database privilege.

Action: This error should not happen normally. Enable tracing and attempt to repeat the error. Contact Oracle Support Services.

TNS-02525 encryption/crypto-checksumming: self test failed

Cause: The ANO encryption/crypto-checksumming service detected an error while running tests on the active encryption or checksumming algorithm.

Action: Contact Oracle Support Services.

TNS-02526 server proxy type does not match client type

Cause: The authentication type selected by the server does not match that picked by the client.

Action: Contact Oracle Support Services.

TNS-03501 OK

Cause: The operation succeeded.

Action: No action necessary.

TNS-03502 Insufficient arguments. Usage: tnsping address [count]

Cause: Some required command-line arguments are missing.

Action: Re-enter the command using the correct arguments.

TNS-03503 Could not initialize NL

Cause: The network library could not be initialized. This is an internal error which should not normally be visible.

Action: Ensure that memory is available to run the application and that there are no other operating system problems, and then attempt the command again.

TNS-03504 Service name too long

Cause: The service name you are attempting to ping is too long.

Action: Re-enter the command using the correct service name.

TNS-03505 Failed to resolve name

Cause: The service name you provided could not be found in TNSNAMES.ORA, an Oracle Names server, or a native naming service.

Action: Verify that you entered the service name correctly. You may need to ensure that the name was entered correctly into the network configuration.

TNS-03506 Failed to create address binding

Cause: The TNSPING utility found the requested address or service name, but received an internal error when trying to use it. This is an internal error which should not normally be visible.

Action: Ensure that memory is available to run the application and that there are no other operating system problems, and then attempt the command again.

TNS-03507 Failure looking for ADDRESS keyword

Cause: The TNS address did not contain an ADDRESS keyword.

Action: If you entered the TNS address on the command line, be sure that the syntax is correct. If you entered a service name on the command line, the address contains the wrong information. You should verify that the information was entered correctly.

TNS-03508 Failed to create address string

Cause: The TNSPING utility received an internal error when generating an address. This is an internal error which should not normally be visible.

Action: Ensure that memory is available to run the application and that there are no other operating system problems, and then attempt the command again.

TNS-03509 OK (number msec)

Cause: The operation succeeded, in this amount of time.

Action: No action necessary.

TNS-03510 Failed due to I/O error

Cause: An I/O operation failed, perhaps due to a resource failure or premature window termination. This is an internal error which should not normally be visible.

Action: Do not close the TNSPING window before all I/O operations have completed.

TNS-03511 Used parameter files: string

Cause: Prints out the path of the parameter files(sqlnet.ora,tnsnames.ora) used in the process of resolving the NAME.

TNS-03512 Used string adapter to resolve the alias

Cause: Prints out the name of the adapter which resolved the TNS alias.

TNS-03601 Failed in route information collection

Cause: The route could either not connect, or encountered an unsupported version of SQL*Net.

Action: Check if SQL*Net along all nodes is version 2.3 or greater.

TNS-03602 Insufficient arguments. Usage: trcroute address

Cause: Some required command-line arguments are missing.

Action: Re-enter the command using the correct arguments.

TNS-03603 Encountered a node with pre-2.3 version of SQL*Net

Cause: Any version of SQL*Net before 2.3 does not support TRCROUTE.

Action: Find the node that is not responding to TRCROUTE.

TNS-04001 CMCTL: error while getting command line from the terminal

Cause: Improper standard input connection from the terminal.

Action: Normally not visible to the user. Start the CMCTL program again. If the error persists, contact Oracle Support Services.

TNS-04002 CMCTL: error while starting the Connection Manager

Cause: The Connection Manager could not be started.

Action: Check the Connection Manager configuration file for errors and confirm that no other programs are using the ADDRESS(es) specified. If the error continues, turn on tracing in the Connection Manager and examine the trace files to determine the cause of the problem. Be sure to turn tracing off when the problem has been resolved.

TNS-04003 CMCTL: error while sending request to the Connection Manager

Cause: Improper command sent to the Connection Manager or the Connection Manager is not responding. This message is not normally visible to the user.

Action: Verify that the command sent to the Connection Manager is valid. Also check that the Connection Manager is running by using the CMCTL STATUS command. If necessary, start the Connection Manager using the CMCTL START command.

TNS-04004 CMCTL: error while starting the Connection Manager Admin

Cause: The Connection Manager Admin could not be started.

Action: Check to make sure that executable for the Connection Manager Admin (CMADMIN) exist in the Oracle home directory. If the error continues, turn on tracing in the Connection Manager Admin and examine the trace file to determine the cause of the problem. Be sure to turn tracing off when the problem has been resolved.

TNS-04005 CMCTL: error while sending request to the Connection Manager Admin

Cause: The Connection Manager Admin is not responding or is not running.

Action: Check that the Connection Manager Admin is running by using the CMCTL STATUS command. If necessary, start the Connection Manager Admin using the CMCTL START command.

TNS-04006 CMCTL: HOST variable is not defined

Cause: The HOST variable was not set.

Action: Set the variable HOST properly and restart the CMCTL program.

TNS-04007 CMCTL: unknown host

Cause: The pointer HOST is set to an unknown host name.

Action: Set the pointer HOST properly and restart CMCTL program.

TNS-04008 CMCTL: could not contact the Connection Manager

Cause: Connection could not be properly established to a Connection Manager. This may be because the Connection Manager specified is not running.

Action: Check that the Connection Manager is running by using the STATUS command. If necessary, start the Connection Manager using the START command. If it is running and the error persists, contact Oracle Support Services.

TNS-04009 CMCTL: could not contact the Connection Manager Admin

Cause: Connection could not be properly established to a Connection Manager Admin. This may be because the Connection Manager Admin specified is not running.

Action: Make sure the Connection Manager Admin is running by using the STATUS command. If necessary, start the Connection Manager Admin using the START command. If it is running and the error persists, contact Oracle Support Services.

TNS-04010 Error while flushing NS context

Cause: Internal NS error; connection may be lost.

Action: Make sure the connection is properly established. If the error persists, then contact Oracle Support Services.

TNS-04011 CMCTL: error while performing NS disconnect command

Cause: Internal NS error. Error in closing down connections.

Action: Make sure the networking protocol being used is properly installed on the machine. If the error persists contact Oracle Support Services.

TNS-04012 CMCTL: error while opening terminal input channel

Cause: Could not open standard terminal input. This is an internal error, not normally visible to the user.

Action: Restart the CMCTL program. If the error persists, contact Oracle Support Services.

TNS-04013 CMCTL: error while closing terminal input channel

Cause: Could not close terminal input channel. This is an internal error, not normally visible to the user.

Action: Restart the CMCTL program. If the error persists, contact Oracle Support Services.

TNS-04014 CMCTL: error while performing NS send command

Cause: This is an internal NS error. Connection may be lost.

Action: If the error persists, contact Oracle Support Services.

TNS-04015 CMCTL: error while performing NS receive command

Cause: This is an internal NS error. Connection may be lost.

Action: If the error persists, contact Oracle Support Services.

TNS-04016 CMCTL: error initializing the national language interface

Cause: The message file could not be found.

Action: Make sure that the Oracle environment is set and that the message file is in the correct place.

TNS-04017 CMCTL: missing Connection Manager data in CMAN.ORA

Cause: CMAN.ORA does not contain Connection Manager data.

Action: Define the correct data for the Connection Manager, then restart the CMCTL program.

TNS-04018 CMCTL: missing Connection Manager name, string, in cman.ora

Cause: CMAN.ORA does not contain a CMANAGER_NAME component.

Action: Define the correct name for the CMANAGER_NAME, then restart the CMCTL program.

TNS-04019 CMCTL: missing ADDRESS(es) in config files

Cause: Configuration files do not contain an ADDRESS/ADDRESS_LIST component.

Action: Define the Connection Manager ADDRESS(es) in the CMAN.ORA file and then restart the CMCTL program.

TNS-04020 CMCTL: Unable to contact the Connection Manager Admin

Cause: The Connection Manager Admin is not running.

Action: Verify that the Connection Manager Admin is running by doing a status request on the Connection Manager Admin. If necessary, start the Connection Manager Admin using the START command.

TNS-04021 CMCTL: The ORACLE environment is not set up correctly

Cause: The Oracle environment is set up incorrectly.

Action: Refer to the Oracle operating system-specific documentation for your platform for information on how the Oracle environment should be set. Correct it and rerun CMCTL. Make sure the Oracle environment includes the correct directories.

TNS-04022 CMCTL: Could not resolve Connection Manager's name/address

Cause: The Connection Manager's name to address definition is missing.

Action: Check TNSNAMES.ORA file and make sure to include a definition for the name specified.

TNS-04023 CMCTL: Could not resolve Connection Manager Admin's name/address

Cause: The Connection Manager Admin's name to address definition is missing.

Action: Check TNSNAMES.ORA file and make sure to include a definition for the name specified.

TNS-04031 CMCTL: internal NT error

Cause: Problem interfacing to the protocol adapters installed.

Action: Normally not visible to the user. Try starting CMCTL again. If the error persists, check the product installation. If it is correct, contact Oracle Support Services.

TNS-04032 CMCTL: internal NS error

Cause: Problem interfacing with TNS.

Action: Normally not visible to the user. Try starting CMCTL again. If the error persists, check the product installation. If it is correct, contact Oracle Support Services.

TNS-04033 CMCTL: internal NL error

Cause: Problem with internal TNS module NL.

Action: Normally not visible to the user. Try starting CMCTL again. If the error persists, check the product installation. If it is correct, contact Oracle Support Services.

TNS-04034 CMCTL: internal NFP error

Cause: Problem with internal Connection Manager.

Action: Normally not visible to the user. Try starting CMCTL again. If the error persists, check the product installation. If it is correct, contact Oracle Support Services.

TNS-04035 CMCTL: error while constructing full file name

Cause: Problem while constructing the full path for a file name because the path name to the file or the environment variables are incorrect. Files looked up include CMAN.ORA and the error files for the Connection Manager and Connection Manager Admin.

Action: Check that all environment variables are defined correctly and that all configuration files exist in their correct places.

TNS-04036 CMCTL: error reading from Connection Manager error files

Cause: Problem while reading from Connection Manager or Connection Manager Admin error files generated by the Connection Manager or Connection Manager Admin when they have failed to start.

Action: Check that a standard Network Error directory exists and that all privileges on the directory are appropriate.

TNS-04037 CMCTL: error opening Connection Manager error files

Cause: Failed to open Connection Manager or Connection Manager Admin error files when they have failed to start.

Action: Check that a Network Error directory exists and that all privileges on the directory are appropriate.

TNS-04038 CMCTL: Poorly formed address or command string

Cause: An unacceptable string was encountered while attempting to send a message to either the Connection Manager or Connection Manager Admin. The addresses provided for either the Connection Manager or Connection Manager Admin may be incorrectly constructed.

Action: Check all address strings in configuration file (TNSNAMES.ORA) and assure that they are properly formed. If all is correct, contact Oracle Support Services.

TNS-04039 CMCTL: error while spawning a process

Cause: An error was encountered while spawning a process due to an internal operating system dependent problem. Machine resources may be limited.

Action: Retry the command. Check permissions on Connection Manager executables (CMADMIN, CMGW) and the current setting of the search path. If necessary, terminate other applications to free up machine resources. If the error persists, contact Oracle Support Services.

TNS-04040 CMCTL: failed to initialize trace context- Continuing anyway

Cause: Problem while opening specified trace file because of errors in CMAN.ORA or because the user has incorrect privileges, or the file does not exist.

Action: Check the privileges on the configuration files and ensure that all of them exist in their proper locations.

TNS-04041 CMCTL: Connection Manager already running. Start operation cancelled

Cause: There is a Connection Manager already running and listening on the same addresses.

Action: No action required. The Connection Manager is already running.

TNS-04042 CMCTL: Connection Manager Admin already running. Start operation cancelled

Cause: There is a Connection Manager Admin already running and listening on the same addresses.

Action: No action required. The Connection Manager Admin is already running.

TNS-04043 The Connection Manager has active connections. Do you still want to stop it (y/n)?

Cause: The Connection Manager that is being stopped has active connections going through. This is the confirmation message.

Action: Respond by typing "y" or "n". Answering "y" will cause the active database connection to be dropped; this is not generally recommended.

TNS-04044 CMCTL: You must have an CMAN.ORA file to contact the Connection Manager

Cause: There was an attempt to contact a default Connection Manager where there was no CMAN.ORA present in the correct directory.

Action: Create an CMAN.ORA file. Make sure it is placed in the correct directory and includes the correct name for the Connection Manager you wish to contact.

TNS-04045 CMCTL: Could not contact the Connection Manager on address

Cause: There was an attempt to contact a Connection Manager on a specific address which is not responding.

Action: Check that the Connection Manager is actually listening on that address.

TNS-04046 CMCTL: Could not contact the Connection Manager Admin on address

Cause: There was an attempt to contact a Connection Manager Admin on a specific address which is not responding.

Action: Check that the Connection Manager Admin is actually listening on that address.

TNS-04047 CMCTL: Could not create the Connection Manager Admin IPC address

Cause: There was an attempt to contact a Connection Manager Admin using the IPC address which is not responding.

Action: Check that the Connection Manager Admin is actually running.

TNS-04060 CMCTL: Bad command: only the STATUS command can be used on remote Connection Manager

Cause: A command was entered that does not exist, or request other than STATUS was made to a remote Connection Manager.

Action: Check the Oracle9i Net Services Administrator's Guide for a list of CMCTL commands or type HELP for a list of valid commands.

TNS-04061 CMCTL: Bad command or syntax error: You must specify a trace level

Cause: A trace level was not specified.

Action: Specify a trace level and retry the command.

TNS-04062 CMCTL: Bad command or syntax error: For help type help/h/?

Cause: An invalid command was entered.

Action: Check the Oracle9i Net Services Administrator's Guide or type HELP for a list of valid commands.

TNS-04063 CMCTL: Failed to allocate memory for buffers

Cause: CMCTL was unable to allocate memory for internal buffers.

Action: Check the amount of available memory on your machine to ensure that there is enough memory to run this executable. If necessary, free up memory by running fewer programs, then try again.

TNS-04064 CMCTL: Failed to find CMANAGER_NAME in CMAN.ORA

Cause: CMCTL was unable to find the CMANAGER_NAME parameter in CMAN.ORA.

Action: Check that the CMAN.ORA file is properly constructed.

TNS-04065 CMCTL: Command cannot be executed remotely

Cause: A command other than status and version has been attempted remotely.

Action: If you desire execute any command other than status and version, you must run CMCTL on the Connection Manager machine.

TNS-04070 CMCTL usage: [cmctl] command process_name [argument]

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04071 where command is one of following:

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04072 * start - start up process_name

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04073 * stop - stop the process_name

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04074 * status - get status from the process_name

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04075 * stats - get statistics from the process_name

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04076 * version - ask version number of CMCTL control program

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04077 * exit - quit the CMCTL control program

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04078 process_name is one of cman, cm process or adm process

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04079 * cman - will ask the Connection Manager (both cman and adm)

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04080 * cm - will ask the Connection Manager process only

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04081 * adm - will ask the Connection Manager Admin process only

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04082 * log_on - ask process_name to turn logging on

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04083 * log_off - ask process_name to turn logging off

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04084 * trace_on - ask process name to turn tracing on

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04085 NOTE: the user MUST specify a trace level

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04086 (USER or ADMIN) in the argument field

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04087 * trace_off - ask process name to turn tracing off

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04088 argument is only supplied trace_on

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04089 * to trace_on - argument is considered the trace level

Cause: Help message displayed by CMCTL.

Action: No action required.

TNS-04090 string

Cause: Control program general message.

Action: No action required.

TNS-04091 accept_connections [ON|OFF] : acc/deny subsequent connections (default is ON)

Cause: Control program usage message.

Action: No action required.

TNS-04092 show address : displays address list CMAN is listening on

Cause: Control program usage message.

Action: No action required.

TNS-04093 show ALL : displays all information about current CMAN

Cause: Control program usage message.

Action: No action required.

TNS-04094 set authentication_level [0|1]: default is 0

Cause: Control program usage message.

Action: No action required.

TNS-04095 change_password [<cman name>] : changes the password of the CMAN

Cause: Control program usage message.

Action: No action required.

TNS-04096 close_relay {number | ALL} : forces relay(s) to be shut down

Cause: Control program usage message.

Action: No action required.

TNS-04097 set|show current_cman [<cman_name>]: sets|shows current CMAN

Cause: Control program usage message.

Action: No action required.

TNS-04098 set|show displaymode [COMPAT|VERB] : sets|shows display mode

Cause: Control program usage message.

Action: No action required.

TNS-04099 set log_level [0-4] : default is 0

Cause: Control program usage message.

Action: No action required.

TNS-04100 set password : set the password for subsequent calls

Cause: Control program usage message.

Action: No action required.

TNS-04101 show profile : shows the parameter profile of the current CMAN

Cause: Control program usage message.

Action: No action required.

TNS-04102 set relay_statistics [ON|OFF] : default is OFF

Cause: Control program usage message.

Action: No action required.

TNS-04103 show relay {number|ACTive}: shows the status of relay(s) in the current CMAN

Cause: Control program usage message.

Action: No action required.

TNS-04104 reload_rules : re-reads rule list from profile

Cause: Control program usage message.

Action: No action required.

TNS-04105 set|show remote_admin ON|OFF : sets|shows remote administration capability

Cause: Control program usage message.

Action: No action required.

TNS-04106 show rules : shows rule list used by current CMAN for connection filtering

Cause: Control program usage message.

Action: No action required.

TNS-04107 save_config [<cman_name>] : saves configuration changes to parameter file

Cause: Control program usage message.

Action: No action required.

TNS-04108 shutdown [NORMAL|ABORT] [cman] : stops CMAN in NORMAL or ABORT modes

Cause: Control program usage message.

Action: No action required.

TNS-04109 start [cm|adm|cman] : starts selected CMAN process(es)

Cause: Control program usage message.

Action: No action required.

TNS-04110 stats [cm|cman] : shows connection statistics

Cause: Control program usage message.

Action: No action required.

TNS-04111 status [cm|adm|cman] : shows current status of selected CMAN process(es)

Cause: Control program usage message.

Action: No action required.

TNS-04112 stop [cm|adm|cman] : stops CMAN process(es) interactively

Cause: Control program usage message.

Action: No action required.

TNS-04113 stopnow [cm|adm|cman] : aborts CMAN process(es)

Cause: Control program usage message.

Action: No action required.

TNS-04114 set TNS_info [ON|OFF] : turns on/off TNS logging (default is off)

Cause: Control program usage message.

Action: No action required.

TNS-04115 set trc_level [<value>] : sets trace level of current CMAN

Cause: Control program usage message.

Action: No action required.

TNS-04116 version [cman] : displays CMAN version information

Cause: Control program usage message.

Action: No action required.

TNS-04117 show _dev_info <relay_num> : shows detailed device information about the relay

Cause: Control program usage message.

Action: No action required.

TNS-04118 quit | exit : exits CMCTL

Cause: Control program usage message.

Action: No action required.

TNS-04119 CMAN password encryption failed

Cause: Possibly garbled password entered.

Action: Re-enter the CMAN password, using valid ASCII characters. If the problem persists, contact Oracle Support Services.

TNS-04120 Current CMAN is string

Cause: Control program status message.

Action: No action required.

TNS-04121 The command completed successfully

Cause: Control program general message.

Action: No action required.

TNS-04122 CMAN state not running

Cause: Control program status message.

Action: No action required.

TNS-04123 ADMIN state not running

Cause: Control program status message.

Action: No action required.

TNS-04124 Current display mode is string

Cause: Control program status message.

Action: No action required.

TNS-04125 The command was unsuccessful

Cause: Control program status message.

Action: No action required.

TNS-04126 string Version string

Cause: Control program status message.

Action: No action required.

TNS-04127 Connecting to string

Cause: Control program status message.

Action: No action required.

TNS-04128 STATUS of the string

Cause: Control program status message.

Action: No action required.

TNS-04129 Start-up time string

Cause: Control program status message.

Action: No action required.

TNS-04130 Current state string

Cause: Control program status message.

Action: No action required.

TNS-04131 Starting string: please wait...

Cause: Control program status message.

Action: No action required.

TNS-04132 STATISTICS of CMAN

Cause: Control program status message.

Action: No action required.

TNS-04133 Total number of connections handled string

Cause: Control program status message.

Action: No action required.

TNS-04134 Number of currently active relays string

Cause: Control program status message.

Action: No action required.

TNS-04135 Peak active relays string

Cause: Control program status message.

Action: No action required.

TNS-04136 Total refusals due to max_relays exceeded string

Cause: Control program status message.

Action: No action required.

TNS-04137 Total number of connections refused string

Cause: Control program status message.

Action: No action required.

TNS-04139 Profile of the CMAN

Cause: Control program status message.

Action: No action required.

TNS-04140 MAXIMUM_RELAYS = string

Cause: Control program status message.

Action: No action required.

TNS-04141 RELAY_STATISTICS = string

Cause: Control program status message.

Action: No action required.

TNS-04142 AUTHENTICATION_LEVEL = string

Cause: Control program status message.

Action: No action required.

TNS-04143 LOG_LEVEL = string

Cause: Control program status message.

Action: No action required.

TNS-04144 SHOW_TNS_INFO = string

Cause: Control program status message.

Action: No action required.

TNS-04145 ANSWER_TIMEOUT = string

Cause: Control program status message.

Action: No action required.

TNS-04146 MAXIMUM_CONNECT_DATA = string

Cause: Control program status message.

Action: No action required.

TNS-04147 USE_ASYNC_CALL = string

Cause: Control program status message.

Action: No action required.

TNS-04148 TRACING = string

Cause: Control program status message.

Action: No action required.

TNS-04149 TRACE_DIRECTORY = string

Cause: Control program status message.

Action: No action required.

TNS-04150 MAX_FREELIST_BUFFERS = string

Cause: Control program status message.

Action: No action required.

TNS-04151 REMOTE_ADMIN = string

Cause: Control program status message.

Action: No action required.

TNS-04152 Relay Information

Cause: Control program status message.

Action: No action required.

TNS-04153 Relay number string

Cause: Control program status message.

Action: No action required.

TNS-04154 Src string

Cause: Control program status message.

Action: No action required.

TNS-04155 Dest string

Cause: Control program status message.

Action: No action required.

TNS-04156 Number of IN bytes string

Cause: Control program status message.

Action: No action required.

TNS-04157 Number of IN packets string

Cause: Control program status message.

Action: No action required.

TNS-04158 Number of IN DCD probes string

Cause: Control program status message.

Action: No action required.

TNS-04159 Number of OUT bytes string

Cause: Control program status message.

Action: No action required.

TNS-04160 Number of OUT packets string

Cause: Control program status message.

Action: No action required.

TNS-04161 Number of OUT DCD probes string

Cause: Control program status message.

Action: No action required.

TNS-04162 Address List

Cause: Control program status message.

Action: No action required.

TNS-04163 Active Relays

Cause: Control program status message.

Action: No action required.

TNS-04164 Rule List

Cause: Control program status message.

Action: No action required.

TNS-04165 Relay is not active

Cause: Control program status message.

Action: No action required.

TNS-04201 Trace Assistant Usage ERROR: Missing File name

Cause: Trace file name argument is missing.

Action: Put the trace file name as the last command line argument for this tool.

TNS-04202 Trace Assistant Usage ERROR: Not enough arguments

Cause: The file_name and/or the options arguments are missing.

Action: Put the right number of command line arguments.

TNS-04203 Trace Assistant Usage ERROR: Invalid options

Cause: The options provided are not valid.

Action: Check the valid options for this tool.

TNS-04204 Trace Assistant Internal ERROR: Couldn't Open trace file

Cause: The trace file name given does not exist or it is not accessible for this user.

Action: Check the spelling, and permissions of the trace file.

TNS-04205 Trace Assistant Internal ERROR: Memory

Cause: Possible memory problem.

Action: Verify the amount of available memory on the system.

TNS-04206 Trace Assistant Internal ERROR: Packet Type

Cause: The packet type read by trcAsst is not valid.

Action: Verify that your trace file is not corrupted. If trace file looks normal, with no unexpected characters in it, contact Oracle Support Services and have the trace file ready.

TNS-04207 Trace Assistant Internal ERROR: Packet Length

Cause: The packet being decode is corrupted.

Action: Verify that your trace file is not corrupted. If trace file looks normal, with no unexpected characters in it, contact Oracle Support Services and have the trace file ready.

TNS-04208 Trace Assistant Internal ERROR: Fatal

Cause: Fatal internal error.

Action: Contact Oracle Support Services.

TNS-04209 Trace Assistant Internal ERROR: Type Error

Cause: Internal type error.

Action: Contact Oracle Support Services.

TNS-04210 Trace Assistant Internal ERROR: End of File

Cause: Reached the end of file too soon. The trace file appears to be truncated. This trace file cannot be decoded.

Action: Generate another trace file.

TNS-04211 Trace Assistant Internal ERROR: CORE

Cause: Internal System Error.

Action: Contact Oracle Support Services.

TNS-04212 Trace Assistant Internal ERROR: NACOM Type Error

Cause: Not able to decode Network Authentication information.

Action: Contact Oracle Support Services.

TNS-04231 Trace Assistant WARNING: Assuming Oracle trace format

Cause: This trace file may not be a Network trace file. The default format (Oracle Trace) will be assumed.

Action: No action required.

TNS-04232 Trace Assistant WARNING: Not retrieving all rows

Cause: Trace Assistant will not retrieve all the rows' data.

Action: No action required.

TNS-04233 Trace Assistant WARNING: Going beyond Packet length

Cause: An attempt was made to read beyond packet length. The trace file may be corrupted.

Action: No action required.

TNS-04234 Trace Assistant WARNING: won't decode TTC

Cause: Trace assistant does not have enough information to decode TTC data. This maybe an old trace file or from a platform that trace assistant does not understand.

Action: No action required.

TNS-04235 Trace Assistant WARNING: Unknown TTC protocol

Cause: Trace Assistant has reached a point in which the TTC protocol cannot be understood.

Action: No action required.

TNS-12150 TNS:unable to send data

Cause: Unable to send data. Connection probably disconnected.

Action: Re-establish connection. If the error is persistent, turn on tracing and re-execute the operation.

TNS-12151 TNS:received bad packet type from network layer

Cause: This is an internal error, not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12152 TNS:unable to send break message

Cause: Unable to send break message. Connection probably disconnected.

Action: Re-establish connection. If the error is persistent, turn on tracing and re-execute the operation.

TNS-12153 TNS:not connected

Cause: Not currently connected to a remote host.

Action: Re-establish connection.

TNS-12154 TNS:could not resolve service name

Cause: The service name specified is not defined correctly in the TNSNAMES.ORA file.

Action: Make the following checks and correct the error:

  • Verify that a TNSNAMES.ORA file exists and is in the proper place and accessible. See the operating system specific manual for details on the required name and location.
  • Check to see that the service name exists in one of the TNSNAMES.ORA files and add it if necessary.
  • Make sure there are no syntax errors anywhere in the file. Particularly look for unmatched parentheses or stray characters. Any error in a TNSNAMES.ORA file makes it unusable. See the Oracle9i Net Services Administrator's Guide. If possible, regenerate the configuration files using the Oracle Network Manager.

TNS-12155 TNS:received bad datatype in NSWMARKER packet

Cause: An internal error occurred during break handling, This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12156 TNS:tried to reset line from incorrect state

Cause: An internal error occurred during break handling. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12157 TNS:internal network communication error

Cause: An internal error occurred during network communication. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12158 TNS:could not initialize parameter subsystem

Cause: Unable to locate parameter file.

Action: Verify that a valid parameter file exists, and is readable.

TNS-12159 TNS:trace file not writeable

Cause: The trace file to be generated is not writeable by this user.

Action: If the user does not have write permissions in the directory to which the trace file will be written, contact the database administrator to get the proper permissions or use TRACE_DIRECTORY_CLIENT in SQLNET.ORA to specify a directory the user can write to.

TNS-12160 TNS:internal error: Bad error number

Cause: Corrupt error reporting subsystem. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12161 TNS:internal error: partial data received

Cause: The connection may be terminated.

Action: Reconnect and try again. For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12162 TNS:service name is incorrectly specified

Cause: The connect descriptor corresponding to the service name in TNSNAMES.ORA is incorrectly specified.

Action: Make sure there are no syntax errors in the connect descriptor. Particularly look for unmatched parentheses or stray characters. Any error in a TNSNAMES.ORA file makes it unusable. See the Oracle9i Net Services Administrator's Guide.

TNS-12163 TNS:connect descriptor is too long

Cause: The connect descriptor corresponding to the service name in TNSNAMES.ORA is too long.

Action: The maximum length for a connect descriptor is 512 bytes and this limit has been exceeded. Use a smaller connect descriptor. If this is not possible, contact Oracle Support Services.

TNS-12164 TNS:Sqlnet.fdf file not present

Cause: The SQLNET.FDF file does not exist in $ORACLE_HOME/network/admin.

Action: The SQLNET.FDF file is required for Oracle Tracing to occur. Either install the SQLNET.FDF file in $ORACLE_HOME/network/admin or turn off tracing in your ORA file.

TNS-12165 TNS:Trying to write trace file into swap space.

Cause: Oracle Trace does not allow writing trace information into your swap space.

Action: Oracle Trace cannot write trace information into swap space so either disable tracing or redirect trace files to be written to another area of your disk.

TNS-12166 TNS:Client can not connect to HO agent.

Cause: NVstring contained DESCRIPTION/HO.

Action: Call HO agent from integrating server.

TNS-12168 TNS:Unable to contact Directory Server.

Cause: Configured to use LDAP based Directory Server.

Action: Bring the Directory Server up or change configuration to LOCAL.

TNS-12169 TNS:Given net_service_name is too long

Cause: The net_service_name you are attempting to resolve is too long.

Action: The maximum length of the net_service_name is 255 bytes and this limit has been exceeded. Use a smaller alias. If this is not possible, then contact Oracle Support Services.

TNS-12170 TNS:Connect timeout occurred

Cause: The server shut down because connection establishment with a client failed to complete within the allotted time interval. This may be a result of network/system delays; or this may indicate that a malicious client is trying to cause a Denial of Service attack on the server.

Action: If the error occurred because of a slow network/system, then reconfigure the "sqlnet.connect_timeout" parameter in sqlnet.ora to a larger value. If a malicious client is suspected, then use the address in sqlnet.log to identify the source and restrict access. Note that logged addresses may not be reliable as they can be forged (that is, in TCP/IP).

TNS-12196 TNS:received an error from TNS

Cause: The navigation layer received an error from TNS.

Action: See the error log file for the specific TNS error.

TNS-12197 TNS:keyword-value resolution error

Cause: The navigation layer received an error while trying to look up a value for a keyword.

Action: Check the syntax of the connect descriptor.

TNS-12198 TNS:could not find path to destination

Cause: Could not navigate a path through Interchanges to the destination. This error occurs if an invalid community is in the address string, or the address includes a protocol that is not available or the TNSNAV.ORA file does not have a correct CMANAGER address specified or the Interchange is down.

Action: Assure that Interchanges necessary to get to the desired destination are up and have available capacity for an additional connection. Also check that the correct community and protocol have been specified in the CMANAGER address used.

TNS-12200 TNS:could not allocate memory

Cause: Out of memory on machine.

Action: Reconfigure machine to have more storage or run fewer applications while the Interchange is running.

TNS-12201 TNS:encountered too small a connection buffer

Cause: TNS connection buffer supplied by the application was too small to retrieve the data sent back.

Action: Supply a larger connection buffer. If problem persists, then contact Oracle Support Services.

TNS-12202 TNS:internal navigation error

Cause: Internal navigation error. This message is not normally visible to the user.

Action: For further details, contact Oracle Support Services.

TNS-12203 TNS:unable to connect to destination

Cause: Invalid TNS address supplied or destination is not listening. This error can also occur because of underlying network transport problems.

Action: Verify that the service name you entered on the command line was correct. Ensure that the listener is running at the remote node and that the ADDRESS parameters specified in TNSNAMES.ORA are correct. Finally, check that all Interchanges needed to make the connection are up and running.

TNS-12204 TNS:received data refused from an application

Cause: The application using the Interchange or Connection Manager refused the connection at the listener.

Action: Make sure that the application listener at the destination is functioning correctly. If it is and the problem persists, contact Oracle Support Services.

TNS-12205 TNS:could not get failed addresses

Cause: Internal navigation error. This message is not normally visible to the user.

Action: For further details, contact Oracle Support Services.

TNS-12206 TNS:received a TNS error during navigation

Cause: Internal navigation error because of an unexpected TNS error.

Action: Look at the log file to find the TNS error. If necessary, turn on tracing and repeat the operation.

TNS-12207 TNS:unable to perform navigation

Cause: Improperly configured navigation file TNSNAV.ORA.

Action: Check the syntax of the TNSNAV.ORA file on the application`s machine, and verify that it lists the correct communities.

TNS-12208 TNS:could not find the TNSNAV.ORA file

Cause: Either the Oracle environment is not set up correctly, or the TNSNAV.ORA file is not present.

Action: Ensure that the Oracle environment is set up appropriately on your platform and that a TNSNAV.ORA file is present.

TNS-12209 TNS:encountered uninitialized global

Cause: Application calling navigation routine has not properly configured the global variables. There are no TNSNAV.ORA files available, or they are defective. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12210 TNS:error in finding Navigator data

Cause: Application calling navigation routine has not properly configured the TNSNAV.ORA file.

Action: Check the syntax of the TNSNAV.ORA file.

TNS-12211 TNS:needs PREFERRED_CMANAGERS entry in TNSNAV.ORA

Cause: TNSNAV.ORA does not have a PREFERRED_CMANAGERS defined.

Action: Add a PREFERRED_CMANAGERS entry to the TNSNAV.ORA file.

TNS-12212 TNS:incomplete PREFERRED_CMANAGERS binding in TNSNAV.ORA

Cause: The PREFERRED_CMANAGERS binding in the client's TNSNAV.ORA file does not have a CMANAGER_NAME specified.

Action: Define the CMANAGER_NAME as part of the PREFERRED_CMANAGERS binding. Use of the Oracle Network Manager should eliminate this error.

TNS-12213 TNS:incomplete PREFERRED_CMANAGERS binding in TNSNAV.ORA

Cause: The PREFERRED_CMANAGERS binding in the client's TNSNAV.ORA file does not have an ADDRESS specified.

Action: Define the ADDRESS as part of the PREFERRED_CMANAGERS binding.

TNS-12214 TNS:missing local communities entry in TNSNAV.ORA

Cause: There is no LOCAL_COMMUNITIES entry in TNSNAV.ORA.

Action: Define the LOCAL_COMMUNITIES for this node in the TNSNAV.ORA file.

TNS-12215 TNS:poorly formed PREFERRED_NAVIGATORS Addresses in TNSNAV.ORA

Cause: Address binding for PREFERRED_NAVIGATORS entry is improperly entered. entry.

Action: Check your PREFERRED_NAVIGATORS entry and fix it in TNSNAV.ORA.

TNS-12216 TNS:poorly formed PREFERRED_CMANAGERS addresses in TNSNAV.ORA

Cause: Address binding for the PREFERRED_CMANAGERS entry in the client's TNSNAV.ORA file is improperly entered.

Action: Define the ADDRESS as part of the PREFERRED_CMANAGERS binding.

TNS-12217 TNS:could not contact PREFERRED_CMANAGERS in TNSNAV.ORA

Cause: There is a syntax error in the PREFERRED_CMANAGERS entry, or addresses specified are wrong, or the intended Connection Managers are unavailable.

Action: Check the PREFERRED_CMANAGERS entries in the client's TNSNAV.ORA file and correct them or talk with your network administrator to determine if the specified Connection Managers are available. Verify that the Interchanges are active by using the INTCTL STATUS command.

TNS-12218 TNS:unacceptable network configuration data

Cause: Poorly formed network configuration data. For example, a PREFERRED_CMANAGERS entry may have an incorrect CMANAGER_NAME in the client's TNSNAV.ORA file. Or an Interchange downtime parameter (TIMEOUT_INTERVAL) on the Navigator may be set to zero in INTCHG.ORA.

Action: Check the entries in TNSNAV.ORA and the Interchange configuration files and correct them. If necessary, talk with your network administrator to determine if the specified Interchanges (Connection Managers) are available and properly configured. Use the Oracle Network Manager to generate the configuration files if necessary.

TNS-12219 TNS:missing community name from address in ADDRESS_LIST

Cause: This error occurs when an ADDRESS_LIST has some ADDRESSes in it that have no COMMUNITY component and others that do have a COMMUNITY component.

Action: Check that in the connect descriptors you are using either all the ADDRESSes have a COMMUNITY component or all do not.

TNS-12221 TNS:illegal ADDRESS parameters

Cause: An illegal set of protocol adapter parameters was specified. In some cases, this error is returned when a connection cannot be made to the protocol transport.

Action: Verify that the destination can be reached using the specified protocol. Check the parameters within the ADDRESS section of TNSNAMES.ORA. Legal ADDRESS parameter formats may be found in the Oracle operating system-specific documentation for your platform. Protocols that resolve names at the transport layer (such as DECnet object names) are vulnerable to this error if not properly configured or names are misspelled.

TNS-12222 TNS:no such protocol adapter

Cause: The protocol adapter requested (by way of the "(PROTOCOL=..)" keyword-value pair in a TNS address) is unknown. If the supplied address is typographically correct then the protocol adaptor is not installed.

Action: Install the protocol adapter or correct typographically error, as appropriate. Note: if the supplied address was derived from resolving the service name, check the address in the appropriate file (TNSNAMES.ORA, LISTENER.ORA or TNSNET.ORA).

TNS-12223 TNS:internal limit restriction exceeded

Cause: Too many TNS connections open simultaneously.

Action: Wait for connections to close and retry.

TNS-12224 TNS:no listener

Cause: The connection request could not be completed because the listener is not running.

Action: Ensure that the supplied destination address matches one of the addresses used by the listener. Compare the TNSNAMES.ORA entry with the appropriate LISTENER.ORA file (or TNSNAV.ORA if the connection is to go by way of an Interchange). Start the listener on the remote machine.

TNS-12225 TNS:destination host unreachable

Cause: Contact cannot be made with remote party.

Action: Make sure the network driver is functioning and the network is up.

TNS-12226 TNS:operating system resource quota exceeded

Cause: The current user has exceeded the allotted resource assigned in the operating system.

Action: Acquire more operating system resources, or perform a different function.

TNS-12227 TNS:syntax error

Cause: The supplied connect descriptor contains illegal syntax.

Action: Check the syntax of the connect descriptor in TNSNAMES.ORA.

TNS-12228 TNS:protocol adapter not loadable

Cause: On some platforms (such as OS/2), protocol adapters are loaded at run time. If the shared library (or DLL) for the protocol adapter is missing, or one of its supporting libraries is missing, then this error is returned.

Action: For further details, turn on tracing and re-execute the operation. The trace file will include the name of the shared library (or DLL) that could not be loaded.

TNS-12229 TNS:Interchange has no more free connections

Cause: One or more Interchanges along the path to the destination desired has no more free connections available to be used for this call.

Action: Try again later when the Interchanges are less busy, or contact your network administrator to have him determine which interchange it is, and increase the number of connections available on that interchange.

TNS-12230 TNS:Severe Network error ocurred in making this connection

Cause: This error is reported by an interchange which fails to make contact with the destination due to a physical network error while calling a destination.

Action: Try again later when the network service may have been fixed or report the problem to your Network Administrator.

TNS-12231 TNS:No connection possible to destination

Cause: This error is reported by an interchange which fails to find a possible connection along the path to the destination.

Action: Report the problem to your Network Administrator so that he may fix the problem.

TNS-12232 TNS:No path available to destination

Cause: This error is reported by an interchange which fails to find a possible path to the destination.

Action: Report the problem to your Network Administrator.

TNS-12233 TNS:Failure to accept a connection

Cause: This error is reported by an interchange which fails to accept a connection due to a redirect failure.

Action: Report the problem to your Network Administrator so that the interchange problem can be isolated.

TNS-12234 TNS:Redirect to destination

Cause: This error is reported by an interchange which determines that this interchange is not the right gateway and needs to redirect the connection to another gateway along the path to the destination.

Action: No action required.

TNS-12235 TNS:Failure to redirect to destination

Cause: This error is reported by an interchange which fails to redirect a connection to another interchange along the path to the destination.

Action: Report the problem to your Network Administrator.

TNS-12236 TNS:protocol adapter not loaded

Cause: On some platforms (such as OS/2) protocol adapters are loaded at run-time. If the shared library (or DLL) for the protocol adapter has not been loaded, then this error is returned.

Action: For further details, turn on tracing and re-execute the operation. The trace file will have the name of the shared library (or DLL) that has not been loaded.

TNS-12500 TNS:listener failed to start a dedicated server process

Cause: The process of starting up a dedicated server process failed. The executable could not be found or the environment may be set up incorrectly.

Action: Turn on tracing at the ADMIN level and re-execute the operation. Verify that the Oracle Server executable is present and has execute permissions enabled. Ensure that the Oracle environment is specified correctly in LISTENER.ORA. The Oracle Protocol Adapter that is being called may not be installed on the local hard drive. Check that the correct Protocol Adapter are successfully linked. If the error persists, contact Oracle Support Services.

TNS-12502 TNS:listener received no CONNECT_DATA from client

Cause: No CONNECT_DATA was passed to the listener.

Action: Check that the service name resolved from TNSNAMES.ORA has the CONNECT_DATA component of the connect descriptor.

TNS-12504 TNS:listener was not given the SID in CONNECT_DATA

Cause: The SID was missing from CONNECT_DATA.

Action: Check that the connect descriptor corresponding to the service name in TNSNAMES.ORA has an SID component in CONNECT_DATA.

TNS-12505 TNS:listener could not resolve SID given in connect descriptor

Cause: The SID in CONNECT_DATA was not found in the listener's tables.

Action: Check to make sure that the SID specified is correct. The SIDs that are currently registered with the listener can be obtained by typing "LSNRCTL SERVICES listener_name". These SIDs correspond to SID_NAMEs in TNSNAMES.ORA, or DB_NAMES in the INIT.ORA file.

TNS-12509 TNS:listener failed to redirect client to service handler

Cause: The dispatcher terminated unexpectedly.

Action: Attempt to connect again and if the same error occurs, contact the database administrator to check the state of the dispatchers for this SID. If the problem persists, turn on tracing in the listener to determine the TNS error caused by the redirect.

TNS-12510 TNS:database temporarily lacks resources to handle the request

Cause: The dispatchers appear to be busy handling other requests.

Action: Attempt the connection again. If the error persists, ask the database administrator to increase the number of dispatchers and/or dispatchers' limit on the number of connections/sessions that they can accept.

TNS-12511 TNS:service handler found but it is not accepting connections

Cause: The dispatchers notified the listener that they temporarily do not accept new connections.

Action: Attempt the connection again. If the error persists, contact the database administrator to check the state of the dispatchers and/or increase the number of dispatchers.

TNS-12512 TNS:service handler found but it has not registered a redirect address

Cause: The dispatcher just came up and has not had time yet to register the address that a client should be redirected to.

Action: Attempt the connection again. If the error persists, ask the database administrator to increase the number of dispatchers.

TNS-12513 TNS:service handler found but it has registered for a different protocol

Cause: The dispatchers registered for this service are connected to the listener by way of a different network protocol than that of the client.

Action: Contact the database administrator to register a dispatcher on your protocol.

TNS-12514 TNS:listener could not resolve SERVICE_NAME given in connect descriptor

Cause: The SERVICE_NAME in the CONNECT_DATA was not found in the listener's tables.

Action: Check to make sure that the SERVICE_NAME specified is correct.

TNS-12515 TNS:listener could not find a handler for this presentation

Cause: None of the listener's known service handlers are registered as supporting the presentation protocol required by the connecting client.

Action: Check that the destination service is configured to accept the presentation protocol.

TNS-12516 TNS:listener could not find available handler with matching protocol stack

Cause: None of the known and available service handlers for the given SERVICE_NAME support the client's protocol stack: transport, session, and presentation protocols.

Action: Check to make sure that the service handlers (for example, dispatchers) for the given SERVICE_NAME are registered with the listener, are accepting connections, and that they are properly configured to support the desired protocols.

TNS-12517 TNS:listener could not find service handler supporting direct handoff

Cause: None of the known service handlers are registered as supporting direct handoff as required for this client connection.

Action: Check that the instance(s) are configured properly for direct handoff, and are versions of Oracle that support direct handoff.

TNS-12518 TNS:listener could not hand off client connection

Cause: The process of handing off a client connection to another process failed.

Action: Turn on listener tracing and re-execute the operation. Verify that the listener and database instance are properly configured for direct handoff. If the problem persists, contact Oracle Support Services.

TNS-12519 TNS:no appropriate service handler found

Cause: The listener could not find any available service handlers that are appropriate for the client connection.

Action: Run "lsnrctl services" to ensure that the instance(s) have registered with the listener, and are accepting connections.

TNS-12520 TNS:listener could not find available handler for requested type of server

Cause: None of the known and available service handlers for requested type of server (dedicated or shared) are appropriate for the client connection.

Action: Run "lsnrctl services" to ensure that the instance(s) have registered with the listener and that the appropriate handlers are accepting connections.

TNS-12521 TNS:listener could not resolve INSTANCE_NAME given in connect descriptor

Cause: The INSTANCE_NAME in the CONNECT_DATA was not found in the listener's tables for the specified SERVICE_NAME.

Action: Check to make sure that the specified INSTANCE_NAME is correct.

TNS-12522 TNS:listener could not find available instance with given INSTANCE_ROLE

Cause: There are not any available and appropriate database instances registered with the listener, that are part of the service identified by SERVICE_NAME given in the connect descriptor and that have the specified INSTANCE_ROLE (and INSTANCE_NAME, if specified).

Action: Check to make sure that the specified INSTANCE_ROLE is correct. Run "lsnrctl services" to ensure that the instance(s) have registered with the listener and that they are ready to accept connections.

TNS-12523 TNS:listener could not find instance appropriate for the client connection

Cause: The listener could not find any available (database) instances, that are appropriate for the client connection.

Action: Run "lsnrctl services" to ensure that the instance(s) are registered with the listener, and have READY status.

TNS-12524 TNS:listener could not resolve HANDLER_NAME given in connect descriptor

Cause: The HANDLER_NAME in the CONNECT_DATA was not found in the listener's tables for the specified SERVICE_NAME and INSTANCE_NAME.

Action: Check to make sure that the specified HANDLER_NAME is correct.

TNS-12531 TNS:cannot allocate memory

Cause: Sufficient memory could not be allocated to perform the desired activity.

Action: Either free some resource for TNS, or add more memory to the machine. For further details, turn on tracing and re-execute the operation.

TNS-12532 TNS:invalid argument

Cause: An internal function received an invalid parameter. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12533 TNS:illegal ADDRESS parameters

Cause: An illegal set of protocol adapter parameters was specified. In some cases, this error is returned when a connection cannot be made to the protocol transport.

Action: Verify that the destination can be reached using the specified protocol. Check the parameters within the ADDRESS section of TNSNAMES.ORA. Legal ADDRESS parameter formats may be found in the Oracle operating system-specific documentation for your platform. Protocols that resolve names at the transport layer (such as DECnet object names) are vulnerable to this error if not properly configured or names are misspelled.

TNS-12534 TNS:operation not supported

Cause: An internal function received a request to perform an operation that is not supported (on this machine). This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12535 TNS:operation timed out

Cause: The requested connection could not be completed within the timeout period specified by the CONNECT_TIMEOUT parameter in LISTENER.ORA. This error arises from the TNSLSNR.

Action: Either reconfigure CONNECT_TIMEOUT to be 0, which means wait indefinitely, or reconfigure CONNECT_TIMEOUT to be some higher value. Or, if the timeout is unacceptably long, turn on tracing for further information.

TNS-12536 TNS:operation would block

Cause: An internal operation did not commence because to do so would block the current process and the user has requested that operations be non-blocking. This is an informational message.

Action: No action required.

TNS-12537 TNS:connection closed

Cause: "End of file" condition has been reached; partner has disconnected. This is an informational message.

Action: No action required.

TNS-12538 TNS:no such protocol adapter

Cause: The protocol adapter requested (by way of the "(PROTOCOL=..)" keyword-value pair in a TNS address) is unknown. If the supplied address is typographically correct then the protocol adaptor is not installed.

Action: Install the protocol adapter or correct the typographical error, as appropriate. Note: if the supplied address was derived from resolving the service name, check the address in the appropriate file (TNSNAMES.ORA, LISTENER.ORA or TNSNET.ORA).

TNS-12539 TNS:buffer over- or under-flow

Cause: Buffer too small for incoming data or too large for outgoing data.

Action: This restriction (which is associated with CONNECT DATA) is not normally visible to the user. For further details, turn on tracing and re-execute the operation; contact Oracle Support Services.

TNS-12540 TNS:internal limit restriction exceeded

Cause: Too many TNS connections open simultaneously.

Action: Wait for connections to close and retry.

TNS-12541 TNS:no listener

Cause: The connection request could not be completed because the listener is not running.

Action: Ensure that the supplied destination address matches one of the addresses used by the listener. Compare the TNSNAMES.ORA entry with the appropriate LISTENER.ORA file (or TNSNAV.ORA if the connection is to go by way of an Interchange). Start the listener on the remote machine.

TNS-12542 TNS:address already in use

Cause: Specified listener address is already being used.

Action: Start your listener with a unique address.

TNS-12543 TNS:destination host unreachable

Cause: Contact cannot be made with remote party.

Action: Make sure the network driver is functioning and the network is up.

TNS-12544 TNS:contexts have different wait/test functions

Cause: Two protocol adapters have conflicting wait/test functions. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12545 Connect failed because target host or object does not exist

Cause: The address specified is not valid, or the program being connected to does not exist.

Action: Ensure the ADDRESS parameters have been entered correctly; the most likely incorrect parameter is the node name. Ensure that the executable for the server exists (perhaps "oracle" is missing). If the protocol is TCP/IP, edit the TNSNAMES.ORA file to change the host name to a numeric IP address and try again.

TNS-12546 TNS:permission denied

Cause: User has insufficient privileges to perform the requested operation.

Action: Acquire necessary privileges and try again.

TNS-12547 TNS:lost contact

Cause: Partner has unexpectedly gone away, usually during process startup.

Action: Investigate partner application for abnormal termination. On an Interchange, this can happen if the machine is overloaded.

TNS-12548 TNS:incomplete read or write

Cause: A data send or receive failed. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12549 TNS:operating system resource quota exceeded

Cause: The current user has exceeded the allotted resource assigned in the operating system.

Action: Acquire more operating system resources, or perform a different function.

TNS-12550 TNS:syntax error

Cause: The supplied connect descriptor contains illegal syntax.

Action: Check the syntax of the connect descriptor in TNSNAMES.ORA.

TNS-12551 TNS:missing keyword

Cause: The supplied connect descriptor is missing one or more TNS keywords.

Action: Check the syntax, and ensure all required keywords are present.

TNS-12552 TNS:operation was interrupted

Cause: An internal operation was interrupted and could not complete. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12554 TNS:current operation is still in progress

Cause: An internal operation is still in progress. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12555 TNS:permission denied

Cause: User has insufficient privileges to perform the requested operation.

Action: Acquire necessary privileges and try again.

TNS-12556 TNS:no caller

Cause: TNS detected an incoming connect request but there was no caller. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12557 TNS:protocol adapter not loadable

Cause: On some platforms (such as OS/2), protocol adapters are loaded at run time. If the shared library (or DLL) for the protocol adapter is missing, or one of its supporting libraries is missing, then this error is returned.

Action: For further details, turn on tracing and re-execute the operation. The trace file will include the name of the shared library (or DLL) that could not be loaded.

TNS-12558 TNS:protocol adapter not loaded

Cause: On some platforms (such as OS/2), protocol adapters are loaded at run time. If the shared library (or DLL) for the protocol adapter has not been loaded, then this error is returned.

Action: For further details, turn on tracing and re-execute the operation. The trace file will have the name of the shared library (or DLL) that has not been loaded.

TNS-12560 TNS:protocol adapter error

Cause: A generic protocol adapter error occurred.

Action: Check addresses used for proper protocol specification. Before reporting this error, look at the error stack and check for lower level transport errors.For further details, turn on tracing and re-execute the operation. Turn off tracing when the operation is complete.

TNS-12561 TNS:unknown error

Cause: A generic protocol error occurred.

Action: For further details, turn on tracing and re-execute the operation.

TNS-12562 TNS:bad global handle

Cause: Bad 'gbh' argument passed to TNS from caller. System may have been linked with old libraries. This is an internal error. This message is not normally visible to the user.

Action: Contact Oracle Support Services.

TNS-12564 TNS:connection refused

Cause: The connect request was denied by the remote user (or TNS software). This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation.

TNS-12566 TNS:protocol error

Cause: An unexpected TNS protocol error has occurred.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12569 TNS:packet checksum failure

Cause: The data received is not the same as the data sent.

Action: Attempt the transaction again. If the error is persistent, turn on tracing and re-execute the operation.

TNS-12570 TNS:packet reader failure

Cause: An error occurred during a data receive. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12571 TNS:packet writer failure

Cause: An error occurred during a data send. This message is not normally visible to the user.

In addition, this message could occur when any of the following SQL*Plus commands have been issued:

  • SHUTDOWN ABORT
  • SHUTDOWN IMMEDIATE
  • SHUTDOWN TRANSACTIONAL

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12574 TNS:redirection denied

Cause: The connect request failed because it would have required redirection and the caller has requested no redirections. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12582 TNS:invalid operation

Cause: An internal function received an invalid request. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12583 TNS:no reader

Cause: A send operation has been requested but partner has already disconnected. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12585 TNS:data truncation

Cause: A receive operation has completed with insufficient data to satisfy the user's request. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12589 TNS:connection not bequeathable

Cause: An attempt to hand-off a connection from one process to another has failed because the protocol provider does not support it. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12590 TNS:no I/O buffer

Cause: An attempt to perform an I/O operation failed because no buffer was available. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12591 TNS:event signal failure

Cause: The TNS software is unable to signal an event occurrence.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12592 TNS:bad packet

Cause: An ill-formed packet has been detected by the TNS software.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12593 TNS:no registered connection

Cause: An attempt to solicit network event activity has failed because no connections are registered for event notification. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12595 TNS:no confirmation

Cause: TNS is unable to get requested confirmation acknowledgment from remote partner. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12596 TNS:internal inconsistency

Cause: TNS has detected an internal inconsistency. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation and contact Oracle Support Services.

TNS-12597 TNS:connect descriptor already in use

Cause: Illegal use of connect descriptor. This is an internal error. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12598 TNS:banner registration failed

Cause: The registration of a product banner with the Oracle server failed.

Action: Enable tracing and attempt to repeat the error. If it occurs again, contact Oracle Support Services.

TNS-12599 TNS:cryptographic checksum mismatch

Cause: The data received is not the same as the data sent.

Action: Attempt the transaction again. If the error persists, check (and correct) the integrity of your physical connection.

TNS-12600 TNS: string open failed

Cause: The creation of a string in Oracle NLS format failed. This is an internal error.

Action: Enable tracing and attempt to repeat the error. If it occurs again, contact Oracle Support Services.

TNS-12601 TNS:information flags check failed

Cause: The TNS information flags set by the process prior to connection negotiation were not present after the negotiation was finished. This is an internal error.

Action: Enable tracing and attempt to repeat the error. If it occurs again, contact Oracle Support Services.

TNS-12602 TNS: Connection Pooling limit reached

Cause: The operation failed because maximum active current connections has been reached. It may not be a real error when the Connection Pooling feature is enabled. It is possible that the application later re-issues the operation and successfully grabs the connection pool slot and proceeds.

Action: This is an internal error. Enable tracing and attempt to repeat the error. If it occurs again, then contact Oracle Support Services.

TNS-12604 TNS: Application timeout occurred

Cause: The operation was aborted because it did not complete within the specified allotted time interval.

Action: This is an error which does not normally appear at the high level. The action to take is application specific, and is detailed in the higher level error description.

TNS-12611 TNS:operation is not portable

Cause: Attempted operation is not portable. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12612 TNS:connection is busy

Cause: Attempted operation failed because it conflicts with an on-going action or status of the connection. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12615 TNS:preempt error

Cause: A request to service an event failed because no event notification has yet been posted. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12616 TNS:no event signals

Cause: The TNS software is unable to enable event signals. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12617 TNS:bad 'what' type

Cause: The operation failed because the type of data specified is unknown. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12618 TNS:versions are incompatible

Cause: The two machines are running incompatible versions of TNS.

Action: Check the version numbers, and upgrade the machine with the smaller one.

TNS-12619 TNS:unable to grant requested service

Cause: The connect request failed because requested service could not be provided by the local TNS software.

Action: If appropriate, re-execute with reduced service requirements.

TNS-12620 TNS:requested characteristic not available

Cause: The connect request failed because a requested transport characteristic could not be supported by the remote TNS software.

Action: If appropriate, re-execute with reduced requirements.

TNS-12622 TNS:event notifications are not homogeneous

Cause: An attempt to register a connection for event notification failed because the event notification type conflicts with existing registrations. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation and contact Oracle Support Services.

TNS-12623 TNS:operation is illegal in this state

Cause: Connection is half-duplex and a full-duplex operation was attempted. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation. If the error persists, contact Oracle Support Services.

TNS-12624 TNS:connection is already registered

Cause: An attempt to register a connection for event notification failed because the connection is already registered. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation and contact Oracle Support Services.

TNS-12625 TNS:missing argument

Cause: An operation failed because an argument was missing. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation and contact Oracle Support Services.

TNS-12626 TNS:bad event type

Cause: An attempt to register a connection for event notification failed because the event type is unknown. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation and contact Oracle Support Services.

TNS-12628 TNS:no event callbacks

Cause: An attempt to register a connection for event notification failed because asynchronous callbacks are not available. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation and contact Oracle Support Services.

TNS-12629 TNS:no event test

Cause: An attempt to register a connection for event notification failed because the ability to test for events is not available. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the operation and contact Oracle Support Services.

TNS-12630 Native service operation not supported

Cause: An operation requested by a user is not supported by the native services component.

Action: This may be an internal error if the operation should have been supported.

TNS-12631 Username retrieval failed

Cause: The authentication service failed to retrieve the name of a user.

Action: Enable tracing to determine which routine is failing.

TNS-12632 Role fetch failed

Cause: The authentication service failed to retrieve one of the user's roles.

Action: Enable tracing to determine which routine is failing.

TNS-12633 No shared authentication services

Cause: The list of authentication services specified by the user does not match those supported by the process.

Action: Either specify another list or relink the executable with the desired services.

TNS-12634 Memory allocation failed

Cause: Process was unable to allocate memory.

Action: Terminate other processes in order to reclaim needed memory.

TNS-12635 No authentication adapters available

Cause: The executable was not linked with any authentication service adapters but the SQLNET.ORA parameter that determines whether or not authentication is required was set to true.

Action: Either disable the parameter or relink the executable with service adapters.

TNS-12636 Packet send failed

Cause: A process was unable to send a packet to another process. Possible causes are: 1. The other process was terminated. 2. The machine on which the other process is running went down. 3. Some other communications error occurred.

Action: If the cause is not obvious, contact Oracle Support Services.

TNS-12637 Packet receive failed

Cause: A process was unable to receive a packet from another process. Possible causes include:

  • The other process was terminated.
  • The machine on which the other process is running went down.
  • Some other communications error occurred.

Action: If the cause is not obvious, contact Oracle Support Services.

TNS-12638 Credential retrieval failed

Cause: The authentication service failed to retrieve the credentials of a user.

Action: Enable tracing to determine the exact error.

TNS-12639 Authentication service negotiation failed

Cause: No match was found between the types of authentication services that the client supports and those that the server is using.

Action: Possible solutions include:

  • Change the entry in SQLNET.ORA that determines which services are to be used.
  • Relink the client with at least one of the authentication service adapters that the server supports.
  • Relink the server with at least one of the authentication service adapters that the client supports.
  • Disable authentication on both the client and server.

TNS-12640 Authentication adapter initialization failed

Cause: The function specified in the authentication table entry for the service failed.

Action: Enable tracing to determine the exact error.

TNS-12641 Authentication service failed to initialize

Cause: The authentication service failed during initialization.

Action: Enable tracing to determine the exact error.

TNS-12642 No session key

Cause: A process has no session key associated with it because the authentication service being used does not use one.

Action: If a session key is required, use another authentication service.

TNS-12643 Client received internal error from server

Cause: The client process received an error from the server that indicated that an internal SQL*Net native services error had occurred.

Action: Enable tracing on both processes and attempt to re-create the problem. If successful in recreating the problem, contact Oracle Support Services.

TNS-12644 Authentication service initialization failed

Cause: The routine called to initialize the authentication adapter failed.

Action: Enable tracing to determine the exact error. A likely cause is that memory is exhausted.

TNS-12645 Parameter does not exist.

Cause: A SQLNET.ORA parameter from which a value was needed does not exist.

Action: Set the parameter in the parameter file.

TNS-12646 Invalid value specified for boolean parameter

Cause: The value specified for a parameter was set to a value other than true/false or on/off.

Action: Correct the value of the parameter.

TNS-12647 Authentication required

Cause: The parameter that controls whether authentication is required was set to true, but the executable does not have an authentication service linked in.

Action: Either re-link the executable with an authentication service adapter or disable the parameter.

TNS-12648 Encryption or data integrity algorithm list empty

Cause: A SQL*Net list-of-algorithms parameter was empty; for example, "()".

Action: Change the list to contain the name of at least one installed algorithm, or remove the list entirely if every installed algorithm is acceptable.

TNS-12649 Unknown encryption or data integrity algorithm

Cause: A SQL*Net list-of-algorithms parameter included an algorithm name that was not recognized.

Action: Either remove that algorithm name, correct it if it was misspelled, or install the driver for the missing algorithm.

TNS-12650 No common encryption or data integrity algorithm

Cause: The client and server have no algorithm in common for either encryption or data integrity or both.

Action: Choose sets of algorithms that overlap. In other words, add one of the client's algorithm choices to the server's list or vice versa.

TNS-12651 Encryption or data integrity algorithm unacceptable

Cause: The algorithm the server chose to use for encryption or data integrity was not one of the choices acceptable to the client. This is either the result of an internal error, of a network data transmission error, or of deliberate tampering with the transmitted data.

Action: For further details, turn on tracing, re-execute the operation, and contact Oracle Support Services.

TNS-12652 String truncated

Cause: Not enough memory was allocated for a string so it had to be truncated

Action: If it is not a problem that the string is truncated, then it is not an error. Otherwise, call the routine that reported the error again with a larger string buffer.

TNS-12653 Authentication control function failed

Cause: The control function utilized by the authentication service driver failed.

Action: Enable tracing to determine the exact error.

TNS-12654 Authentication conversion failed

Cause: The authentication service was unable to convert the credentials of a user from the format specific to the format into the Oracle format.

Action: Enable tracing to determine the exact error.

TNS-12655 Password check failed

Cause: The authentication service being used was unable to verify the provided password.

Action: Enable tracing to determine the exact error.

TNS-12656 Cryptographic checksum mismatch

Cause: The cryptographic checksum received with a packet of incoming data did not match the checksum computed by the receiving end. This indicates that the packet was tampered with or otherwise corrupted in transit.

Action: Look for sources of data corruption, perhaps including deliberate tampering.

TNS-12657 No algorithms installed

Cause: The near side of the connection required the use of a service (either encryption or checksumming) when no algorithms for that service were installed.

Action: Remove the "ON" requirement for that service.

TNS-12658 ANO service required but TNS version is incompatible

Cause: A client process that is running an earlier version of TNS attempted to connect but the connection failed because the server process required that an ANO service (authentication, encryption, and so on) be used.

Action: Relink the calling executable and retry the connection or eliminate the requirement that the service be used on the server side.

TNS-12659 Error received from other process

Cause: An error was received by one or more services from the process on the other side of the connection.

Action: Enable tracing to determine the exact error(s). The error(s) is (are) not returned directly because an error generated by a server may not make sense on the client side and vice-versa.

TNS-12660 Encryption or crypto-checksumming parameters incompatible

Cause: One side of the connection specified "REQUIRED" for encryption or crypto-checksumming, while the other side specified "REJECTED".

Action: Change the "REQUIRED" side to "REQUESTED" if the you want encryption or crypto-checksumming to be optional, or change the "REJECTED" side to "ACCEPTED" if you do not want the service to be optional.

TNS-12661 Protocol authentication to be used

Cause: The SQL*Net authentication service has determined that the SQL*Net transport protocol in use is to be utilized to authenticate a user's identity.

Action: This error is used solely to communicate information between the authentication service and the SQL*Net session layer and should not be visible to the user. If the error is seen, contact Oracle Support Services.

TNS-12662 proxy ticket retrieval failed

Cause: The authentication adapter used by SQL*Net failed to retrieve the credentials needed to authenticate a database link.

Action: Enable tracing to determine the exact error.

TNS-12663 Services required by client not available on the server

Cause: Service(s) that was (were) required by the client process were not available on the server process.

Action: Configure the server with the services required by the client (best solution) or delete the requirement from the configuration file of the client (least secure).

TNS-12664 Services required by server not available on the client

Cause: Service(s) that was (were) required by the server process were not available on the client process.

Action: Configure the client with the services required by the server (best solution) or delete the requirement from the configuration file of the server (least secure).

TNS-12665 NLS string open failed

Cause: A native service was unable to make a string available for use by the National Language Support component.

Action: Make sure the National Language Support component has been properly. If it has, enable tracing and report the problem to Oracle Support Services.

TNS-12666 Dedicated server: outbound transport protocol different from inbound

Cause: The protocol specified for an externally-identified outbound connection from a dedicated server (database link) was not the same as that used for the inbound connection. It is not possible for SQL*Net to authenticate a proxy connection that uses a protocol that is different from that which was used for the connection to the dedicated server.

Action: Specify the same protocol in the SQL*Net connect string or alias for the outbound connection as that used for the inbound connection.

TNS-12667 Shared server: outbound transport protocol different from inbound

Cause: The protocol specified for an externally-identified outbound connection from a shared server (database link) was not the same as that used for the inbound connection. It is not possible for SQL*Net to authenticate a proxy connection that uses a protocol that is different from that which was used for the connection to the shared server.

Action: Specify the same protocol in the SQL*Net connect string or alias for the outbound connection as that used for the inbound connection.

TNS-12668 Dedicated server: outbound protocol does not support proxies

Cause: The protocol specified to perform an externally-identified proxy connection (database link) from a dedicated server does not support proxy connections.

Action: Specify a protocol in the SQL*Net connect string or alias used for the connection that does support externally-authenticated proxy connections. NOTE: Because of a limitation in SQL*Net, the protocol used for the proxy connection must the same as that used for the connection from the client to the server.

TNS-12669 Shared server: outbound protocol does not support proxies

Cause: The protocol specified to perform an externally-identified proxy connection (database link) from a shared server does not support proxy connections.

Action: Specify a protocol in the SQL*Net connect string or alias used for the connection that does support externally-authenticated proxy connections. NOTE: Because of a limitation in SQL*Net, the protocol used for the proxy connection must the same as that used for the connection from the client to the server.

TNS-12670 Incorrect role password

Cause: A password supplied for a role could not be validated by the authentication service.

Action: Supply the correct password.

TNS-12671 Shared server: adapter failed to save context

Cause: The adapter for the authentication service failed when it tried to save the data needed for proxy connections (database links) through the multi-threaded server.

Action: Enable tracing to determine the exact error. Contact Oracle Support Services if the reason is not obvious.

TNS-12672 Database logon failure

Cause: The authentication service adapter in use encountered an error it attempted to validate the logon attempt of a user.

Action: Enable tracing to determine the exact error encountered by the adapter.

TNS-12673 Dedicated server: context not saved

Cause: A connection was marked as being a proxy connection (database link) from a dedicated server but no inbound context was present.

Action: This error should not normally be visible to the user. Contact Oracle Support Services.

TNS-12674 Shared server: proxy context not saved

Cause: A connection was marked as being a proxy connection (database link) from a shared server but no inbound context was present.

Action: This error should not normally be visible to the user. Contact Oracle Support Services.

TNS-12675 External user name not available yet

Cause: The authentication service in use was not able to return the external name of a user of the Oracle server because it is not available to the service yet.

Action: This is just an informational message and should not normally be visible to the user. If the error does appear, contact Oracle Support Services.

TNS-12676 Server received internal error from client

Cause: The server process received an error from the client which indicated that an internal SQL*Net native services error had occurred.

Action: Enable tracing on both processes and attempt to re-create the problem. If the problem recurs, contact Oracle Support Services.

TNS-12677 Authentication service not supported by database link

Cause: The authentication service used by the proxy process (database link) was unable to find the adapter being used by the client in its list of authentication mechanisms.

Action: Specify an authentication adapter that is shared by the client and the server being used for the database link.

TNS-12678 Authentication disabled but required

Cause: The configuration parameters that control whether SQL*Net authentication is disabled or required were both set to TRUE.

Action: Set one or both of the parameters to FALSE.

TNS-12679 Native services disabled by other process but required

Cause: The remote process has disabled native services but the local process requires them.

Action: Enable native services on the remote process or disable them locally.

TNS-12680 Native services disabled but required

Cause: The process has disabled native services but at least one service is required.

Action: Enable native services or change the configuration file so that none of the available services are required.

TNS-12681 Login failed: the SecurID card does not have a pincode yet

Cause: The SecurID card that is used to logon to Oracle, does not have a pin code assigned to it.

Action: Use one of the programs supplied by Security Dynamics to assign a pin code to the card.

TNS-12682 Login failed: the SecurID card is in next PRN mode

Cause: The SecurID card and the SecurID server are out of sync and the server requires the next card code to resynchronize the card.

Action: Use one of the programs supplied by Security Dynamics to resynchronize the SecurID card.

TNS-12683 encryption/crypto-checksumming: no Diffie-Hellman seed

Cause: The sqlnet.crypto_seed parameter is missing from the SQLNET.ORA parameters file for SQL*Net.

Action: Add this line to SQLNET.ORA:

sqlnet.crypto_seed = "randomly-chosen text"

TNS-12684 encryption/crypto-checksumming: Diffie-Hellman seed too small

Cause: The sqlnet.crypto_seed parameter in the SQLNET.ORA parameter file for SQL*Net is too small.

Action: Add more randomly-chosen text to it, perhaps using Network Manager.

TNS-12685 Native service required remotely but disabled locally

Cause: A native service is required by the remote process but native services have been disabled locally.

Action: Enable native services locally or change the configuration parameters on the remote host so that no native services are required.

TNS-12686 Invalid command specified for a service

Cause: An operation which does not exist was specified for a native service. This is a programming error and should not normally be visible to the user.

Action: Contact Oracle Support Services.

TNS-12687 Database link failed: credentials expired

Cause: The credentials that are used to authenticate the user for the requested database link have expired.

Action: Renew your credentials. Refer to the documentation specific for your Network Authentication Adapter on how to do this.

TNS-12688 Login failed: the SecurID server rejected the new pincode

Cause: There are a number of reasons why the SecurID server would refuse a pin code:

  • The user might not have permission to make up his own pin code.
  • The pin code was either too short or too long. Valid pin codes consist of minimal four, but no more than eight characters.
  • The pin code contains any non alpha-numeric characters.

Action: Re-execute the operation and make sure to use a pin code that satisfies the above requirements. If the problem persists, turn on tracing at the Oracle Server side of the connection and examine the trace file for the exact error.

TNS-12689 Server Authentication required, but not supported

Cause: Server Authentication is required for this connection, but not supported by both sides of the connection.

Action: Make sure both sides of the connection have the correct version of Advanced Networking Option, and that the Authentication Adapter supports Server Authentication.

TNS-12690 Server Authentication failed, login cancelled

Cause: Server Authentication is required, but the server's credentials were found invalid by the client.

Action: Make sure that the server has a valid set of credentials. Refer to your authentication adapter specific documentation on how to do this.

TNS-12696 Double Encryption Turned On, login disallowed

Cause: A Secure Protocol Adapter was used that has Encryption turned ON as well as ASO Encryption.

Action: Turn OFF either ASO Encryption or the Protocol Adapter Encryption if possible. Refer to the Oracle Advanced Security Administrator's Guide for information about how to do this.

TNS-12699 Native service internal error

Cause: An internal error occurred in the native services component.

Action: Enable tracing to determine the exact error. Contact Oracle Support Services.


Oracle Names Client Messages (NNC)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

31
Oracle Names Client Messages (NNC)

NNC-00000 normal, successful completion

Cause: An operation has completed normally, having met no exceptions.

Action: No action required.

NNC-00001 maximum number of connections already open

Cause: All available name service connections are handling requests.

Action: If the problem occurs when running a name server, increase the values of NAMES.MAX_OPEN_CONNECTIONS. If the problem occurs in a client program, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00002 error listening on stream string

Cause: The name server was asked to listen on the specified address, and failed, probably because the address is malformed, or because it uses a SQL*Net protocol adaptor which has not been installed.

Action: Make sure the address is properly formed, and that it uses a protocol adaptor which has been installed on your system.

NNC-00003 error opening stream string

Cause: A name server or client program attempted to open a connection to another server and failed, either because the server is down, or because the network path to that server is not working. This error is usually displayed underneath an error which describes the problem in more detail.

Action: Make sure that the server being connected to is listening on the address used, and that there is network connectivity between the two end-points.

NNC-00004 connection is broken

Cause: The connection from a name server or client program to another server has been broken, either because that server has shut down, or because the network path to the server has stopped working. This error is usually displayed underneath an error which describes the problem in more detail.

Action: Make sure that the server being connected to is running and listening on the address used, and that there is network connectivity between the two end-points.

NNC-00005 cannot initialization stream subsystem

Cause: The name service stream subsystem could not be started, probably because of a missing TNS error message file.

Action: Check that SQL*Net has been installed properly and that all message files are in their proper locations.

NNC-00050 message format error

Cause: A corrupted name server message was received by a name server or the name server program interface. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00051 message content error

Cause: A corrupted name server message was received by a name server or the name server program interface. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00052 client and server protocol versions are incompatible

Cause: A name server message with an incompatible protocol version was received by a name server or the name server program interface. This problem will occur when there are clients and servers with widely varying protocol versions that are trying to communicate.

Action: Upgrade older client and server software so it is compatible with newer software.

NNC-00053 ASN.1 error encountered while sending or receiving message

Cause: The name server or the name server program interface attempted to send or receive a message and failed because of an ASN.1 error. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00400 memory exhausted

Cause: The program interface has run out of memory.

Action: Add more memory or run fewer processes.

NNC-00401 program interface initialization failed

Cause: The name server program interface could not be initialized, probably because of a missing TNS or name server error message file.

Action: Check that SQL*Net has been installed properly and that all message files are in their proper locations.

NNC-00402 program interface de-initialization failed

Cause: An internal error occurred while the name server program interface was being de-initialized by an internal function. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00403 program interface has not been initialised

Cause: An internal function has attempted to de-initialize the name service program interface when it has not yet been initialized. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00404 supplied buffer of size string is smaller than minimum size string

Cause: A caller supplied the name server program interface with a memory buffer too small for the interface's requirements. This error is usually displayed underneath an error which describes the problem in more detail. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00405 network failure

Cause: The network connection between the client program and the name server has failed, either because the server has shut down, or because the network path to the server has stopped working. This error is usually displayed underneath an error which describes the problem in more detail.

Action: Contact your name server administrator to make sure that the server being connected to is running and listening on the address used, and that there is network connectivity between the two end-points.

NNC-00406 name "string" does not exist

Cause: A request was made for information associated with a global name that does not exist.

Action: Retry the failing operation with a global name that exists.

NNC-00407 alias loop in name request

Cause: The name service detected an "alias loop" when trying to retrieve information associated with a global name. An alias loop occurs when an alias name X points to another alias name Y, which in turn points back to X, rather than eventually to a global name which contains data.

Action: Contact your name server administrator to have the alias loop investigated and fixed.

NNC-00408 name "string" exists but desired data does not

Cause: A request was made for information associated with a global name. The name in question exists, but does not contain the desired type of information.

Action: Retry the failing operation with a type which the desired name does contain.

NNC-00409 temporary name service failure

Cause: There are no name servers available to handle a client request, or a name server was temporarily unable to handle a client request. This situation is almost always temporary, and occurs when the program interface has issued a name server request and not received a timely response from any of its preferred servers. Such delays can occur due to transient network or name server outages or heavy load.

Action: Retry the failing operation. If the error persists, make sure there is network connectivity between the client and its preferred name servers, and contact your name server administrator to make sure that those name servers are running.

NNC-00410 invalid preferred server address list

Cause: The NAMES.PREFERRED_SERVERS parameter in SQLNET.ORA is malformed.

Action: Make sure the address list is properly formatted.

NNC-00411 invalid default domain name "string"

Cause: The NAMES.DEFAULT_DOMAIN parameter in SQLNET.ORA is invalid.

Action: Make sure the parameter value is a valid global name. See your documentation for the characters which may be used in a global name.

NNC-00412 invalid name "string"

Cause: The name server program interface was given an invalid global name to process.

Action: Supply a valid domain name. If the error is caused by an internal function, contact Oracle Support Services.

NNC-00413 general failure

Cause: A name server program interface error occurred which did not fall under the heading of any other more specific error condition. The error will usually be followed by more specific lower-level information. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00414 invalid name-value binding string "string"

Cause: A caller provided the name server program interface with an invalid name-value binding string value.

Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a valid name-value binding string argument. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00415 section identifier string is invalid, must be between string and string

Cause: An internal function has called the name server program interface with illegal arguments. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00416 user callback function returned error number string

Cause: An internal function has called the name server program interface with illegal arguments. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00417 name "string" already exists

Cause: A caller has attempted to create a new global name, and that name already exists.

Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a name that does not already exist. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00418 name "string" cannot be modified because it has children

Cause: A caller has attempted to delete or rename a global name, and that name cannot be modified because it has child names underneath it in the name space.

Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a name that is a leaf node. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00419 authoritative server is unreachable

Cause: A name server request cannot be processed because the server which received the operation does not own the name specified in the request and cannot locate the server which does own the name. The error is almost always transient, and occurs either because the path between the server receiving the request and the request's final destination has been interrupted, or because the final destination is down.

Action: Not normally visible to the user, except when using the name server control program. Because the error is typically a transient one, retrying the failing operation will usually work. If the failure persists, the name server which is allowed to process the failing operation is probably shut down or unreachable. Contact your name server administrator to make sure that your site's name servers are running, and are properly configured.

NNC-00420 operation not allowed

Cause: A name server request cannot be processed because the server which received the operation is not allowed to process it. The problem typically occurs when an administrator has disabled request processing at a particular server for some reason.

Action: Contact your name server administrator to determine why server request processing has been disabled.

NNC-00421 invalid modification directive string, must be between string and string

Cause: An internal function has called the name server program interface with illegal arguments. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00422 invalid data type name "string"

Cause: A caller has provided an invalid data type name to the name server program interface.

Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a valid type name. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00423 invalid data item syntax code string

Cause: A caller has provided an invalid data type code to the name server program interface.

Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a valid type name. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00424 invalid address "string"

Cause: A caller provided the name server program interface with an invalid address value.

Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a valid address argument. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00425 meta-data violation

Cause: A caller issued a name server modification request and that request cannot be processed because it would violate data type meta-data constraints.

Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, examine the meta-data constraints for the data type being operated upon and don't violate them. Examples of typical constraint violations are attempts to add a new data item to a name which already contains alias information, or attempts to add alias information to a name which already contains other data, or attempts to replace a data item with another item that has the wrong syntax. If the error occurs outside the control program, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00426 no such data type

Cause: A caller attempted to create a data item, and could not because the data item's type does not exist.

Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the operation with an existent data type. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00427 server does not support this version of the protocol

Cause: A name server message with an incompatible protocol version was received by a name server or the name server program interface. This problem will occur when there are clients and servers with widely varying protocol versions that are trying to communicate.

Action: Upgrade the older client and server software so it is compatible with newer software.

NNC-00428 invalid meta-data data item

Cause: A caller provided the name server program interface with an invalid meta-data data item.

Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a valid meta-data argument. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00429 invalid octet string literal "string"

Cause: A caller provided the name server program interface with an invalid octet string value.

Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, retry the failing operation with a valid octet string argument. Otherwise, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNC-00430 Database not accessible

Cause: When a database is used for consistency between different name servers, any modify operation should not only modify the cache but also the database. And if the database is not accessible, this error occurs.

Action: Not normally visible to the user, except when using the name server control program. If the error occurs when using the control program, make sure database is available and then re-execute the operation. If error persists, contact Oracle Support Services.

NNC-00431 NS address does not match any of the current addresses

Cause: When delegating a domain, the address of the name server is provided by the client. If the name server already exists, then it already has address(es) associated with it. So, the address supplied by the client must match one of them. Otherwise, this error occurs.

Action: Not normally visible to the user, except when using name server control program. If the error occurs when using the control program, either provide an one of the existing addresses of the name server or delegate the domain to a new name server.

NNC-00500 warning: "string" parameter value is illegal, setting to string

Cause: The named parameter value is invalid.

Action: Make sure the parameter value is formatted correctly. Valid choices for boolean parameter values are TRUE, FALSE, YES, NO, ON, and OFF.

NNC-00501 warning: "string" parameter value must be between number and number, setting to number

Cause: The named parameter value is invalid or outside legal boundary values.

Action: Make sure the parameter value is a number, and falls between valid minimum and maximum values, as specified in the error text.


Oracle Names Server Messages (NNO)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

32
Oracle Names Server Messages (NNO)

NNO-00000 normal, successful completion

Cause: An operation has completed normally, having met no exceptions.

Action: No action required.

NNO-00050 serious errors in configuration data, server cannot run

Cause: The server's configuration data has a problem of some sort which prevents the server from starting.

Action: Previous error messages in the log file will specify the exact problems leading to the shutdown. The problem most frequently occurs when the network is broken up into multiple administrative regions and the delegation points are incorrect. Read the Oracle Names documentation sections on region delegation and ensure that their directions are being followed correctly.

NNO-00051 domain count number exceeds maximum of number, first number will be loaded

Cause: The server's configuration contains more domains than the server can support. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00052 invalid domain description list

Cause: The server's configuration contains an invalid domain description list. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00053 duplicate domain description for domain "string"

Cause: The server's configuration contains duplicate domain descriptions in the domain description list. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00054 invalid domain name "string"

Cause: The server's configuration contains a domain description with an invalid name. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00055 invalid domain minimum TTL "string"

Cause: The server's configuration contains a domain description with an invalid minimum TTL. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00056 warning: domain minimum TTL must be between number and number, set to number seconds

Cause: The server's configuration contains a domain description with an invalid minimum TTL. This error is not fatal; the server will automatically set the TTL to a default value which is suitable for most uses. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00057 loading and verifying topology data

Cause: An informational message written to the log file during normal server startup.

Action: No action required.

NNO-00058 cannot load topology data from configuration database

Cause: An error was encountered while trying to load the server's topology data from the configuration database. If more information is available, it will appear under this error. This error will cause the server to shut down.

Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the NAMES.NO_REGION_DATABASE parameter set to TRUE. If no checkpoint data is available, the server will shut down.

NNO-00059 cannot construct topology checkpoint file name

Cause: The server could not construct a system-dependent file name. This is an internal error, not normally visible to the user.

Action: For further details, turn on tracing and restart the server. If the error persists, contact Oracle Support Services.

NNO-00060 loading server topology from checkpoint file "string"

Cause: An informational message written to the log file when the server has been forced to load from its most recent topology checkpoint file, by setting the NAMES.NO_REGION_DATABASE parameter to TRUE.

Action: No action required.

NNO-00061 loading data for domain "string"

Cause: An informational message written to the log file during normal server startup.

Action: No action required.

NNO-00062 cannot load domain data from configuration database

Cause: An error was encountered while trying to load the server's domain data from the configuration database. If more information is available, it will appear under this error. This error will cause the server to shut down.

Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the NAMES.NO_REGION_DATABASE parameter set to TRUE. If no checkpoint data is available, the server will shut down.

NNO-00063 cannot construct domain checkpoint file name

Cause: The server could not construct a system-dependent file name. This is an internal error, not normally visible to the user.

Action: For further details, turn on tracing and restart the server. If the error persists, contact Oracle Support Services.

NNO-00064 loading domain data from checkpoint file "string"

Cause: An informational message written to the log file when the server has been forced to load from its most recent domain checkpoint file, by setting the NAMES.NO_REGION_DATABASE parameter to TRUE.

Action: No action required.

NNO-00065 loading cached data from checkpoint file "string"

Cause: An informational message written to the log file during normal server startup.

Action: No action required.

NNO-00066 server will perform reload check of administrative region in number seconds

Cause: An informational message written to the log file whenever the Net8 Assistant or the Oracle Names control program send a reload request to the server.

Action: No action required.

NNO-00067 server reload check countdown aborted

Cause: An informational message written to the log file whenever the Oracle Names control program halts a reload request previously sent to the server

Action: No action required.

NNO-00068 warning: administrative region check failed, next check in number seconds

Cause: This warning is issued whenever the server fails to connect to the configuration database to see if any configuration data has changed. The server will automatically begin reissuing reload checks more frequently, and will eventually give up if connections fail continuously for three days.

Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database.

NNO-00069 warning: too many administrative region check failures, checking disabled

Cause: A warning issued whenever the server has continuously failed for three days in its attempts to connect to the configuration database. The server disables reload checking. Reload checking can later be re-enabled from the Net8 Assistant or the Oracle Names control program.

Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the NAMES.NO_REGION_DATABASE parameter set to TRUE. If no checkpoint data is available, the server will shut down.

NNO-00070 administrative region has changed, reloading domain data

Cause: An informational message written to the log file whenever the server's configuration has changed, and the server is reloading the new configuration from the configuration database.

Action: No action required.

NNO-00071 cannot construct cache checkpoint file name

Cause: the server could not construct a system-dependent file name.

Action: An internal error not normally visible to the user. For further details, turn on tracing and restart the server. If the error persists, contact Oracle Support Services.

NNO-00072 loading from region database

Cause: This is an internal error, not normally visible to the user.

Action: Enable tracing and restart the server. If the error persists, contact Oracle Support Services.

NNO-00073 loading server config from region database

Cause: An informational message written to the log file during normal server startup.

Action: No action required.

NNO-00074 downloading region from server string

Cause: An informational message written to the log file during normal server startup.

Action: No action required.

NNO-00080 domain "string" cannot be delegated because its parent is already delegated

Cause: An internal delegation error has occurred. Delegation is controlled by the Oracle Network Manager, which enforces correct delegation rules. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00081 domain "string" has no name servers

Cause: An internal configuration error has occurred. The Oracle Network Manager is responsible for configuring Oracle Names servers correctly. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00082 domain "string" is missing my name "string" as a name server

Cause: An internal configuration error has occurred. The Oracle Network Manager is responsible for configuring Oracle Names servers correctly. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00083 domain "string" server "string" has no addresses

Cause: An internal configuration error has occurred. The Oracle Network Manager is responsible for configuring Oracle Names servers correctly. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00084 domain "string" is not in the authoritative domain list

Cause: An internal configuration error has occurred. The Oracle Network Manager is responsible for configuring Oracle Names servers correctly. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00104 line string: syntax error, data ignored

Cause: The server found a syntax error its domain data. This message will also appear if the server's internal checkpoint files become corrupted. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00105 line string: invalid name "string", data ignored

Cause: The server found an invalid global name in its domain data. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00106 line string: invalid TTL "string", data ignored

Cause: The server found an invalid TTL in its domain data. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00107 line string: ignoring stale checkpoint data

Cause: An informational message which appears during server startup when the server detects out-of-date cached data in its cache checkpoint file. The message is part of normal server startup.

Action: No action required.

NNO-00108 line number: TTL of number seconds below domain minimum number, using minimum

Cause: The server found an invalid TTL value in its domain data. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00109 line string: invalid data type name "string", data ignored

Cause: The server found an invalid data type name in its domain data. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00110 line string: unknown data type "string", data ignored

Cause: The server found an unknown data type in its domain data. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00111 line string: data type "string" has syntax "string", should be "string", data ignored

Cause: The server found an invalid data type syntax in its domain data. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00112 line string: ignored duplicate data of type "string"

Cause: The server found a duplicate record in its domain data. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00113 line string: alias data already exists, all other data ignored

Cause: The server found a alias and non-alias data with the same global name in its domain data. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00114 line string: other data exists, alias data ignored

Cause: The server found a alias and non-alias data with the same global name in its domain data. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00115 line string: single-value data type "string", other instances ignored

Cause: The server found more than one record with the same name and type, when the type allows only a single record with a particular name. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00116 warning: data type "string" in string load

Cause: The server found a record with an invalid data type in its domain data.

Action: No action required; adjustments to data will eliminate the warning.

NNO-00117 line string: missing data type, data ignored

Cause: The server found a record with a missing data type in its domain data. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00118 line string: data length string exceeds maximum of string, data ignored

Cause: The server found a record whose length exceeds an internal limit. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00119 line string: server not authoritative for name "string", data ignored

Cause: The server found a global name in its domain data for which it is not authoritative. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00120 line string: topology name "string" not allowed here

Cause: The server found an invalid record in its domain data. The record in question is not loaded, but the server continues to load data. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00121 LDIF file string open failed: error = number

Cause: the server found an invalid record in its domain data. The record in question is not loaded, but the server continues to load data.

Action: An internal error not normally visible to the user. Contact Oracle Support Services.

NNO-00122 invalid name, data ignored: entry: string

Cause: the server found an invalid global name in its domain data. The record in question is not loaded, but the server continues to load data.

Action: Contact Oracle Support Services.

NNO-00123 node "string" has no authoritative parent, data ignored

Cause: an object in the domain data is apparently not in the domains which the server is authoritative for. The record in question is not loaded, but the server continues to load data.

Action: Check for inconsistencies in the data and correct any errors in topology definition or domain data outside of authoritative domains.

NNO-00150 warning: invalid hint list, no hints loaded

Cause: The server's configuration contains an invalid hint description list. The server will continue to run, but will not load any hints. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00151 warning: ignoring hint for domain "string", server is authoritative

Cause: The server's configuration contained a hint for a domain in the server's administrative region. The hint is ignored and the server continues to run. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00152 warning: hint count number exceeds maximum of number, first number will be loaded

Cause: There are too many hints in the server's hint list. The server will load a specified maximum number of hints, ignore the rest, and continue running. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00153 warning: hint domain number has invalid name "string", hint domain ignored

Cause: The server's configuration contains a hint domain with an invalid name. The domain is ignored and the server continues to run. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00154 warning: hint number has invalid server name "string", hint ignored

Cause: The server's configuration contains a hint with an invalid server name. The hint is ignored and the server continues to run. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00155 warning: hint number has missing address, hint ignored

Cause: The server's configuration contains a hint with no server address. The hint is ignored and the server continues to run. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00156 warning: hint number address length number exceeds maximum of number, hint ignored

Cause: The server's configuration contains a hint whose address length exceeds an internal limit. The hint is ignored and the server continues to run. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00157 warning: hint number has invalid address, hint ignored

Cause: The server's configuration contains a hint with an invalid address. The hint is ignored and the server continues to run. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00158 warning: hint domain count number exceeds maximum of number, first number will be loaded

Cause: The server's hint domain list is too long. The server will load a specified maximum number of hint domains, ignore the rest, and continue running. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00159 warning: ignoring duplicate hint domain number name "string"

Cause: The server's hint domain list contains a duplicate domain. The duplicate is ignored and the server continues running. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00160 warning: ignoring duplicate hint server "string"

Cause: The server's hint server list contains a duplicate server. The duplicate is ignored and the server continues running. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00250 invalid administrative region description

Cause: The server encountered an invalid administrative region description during startup. This error will prevent the server from starting. The administrative region description is stored in the server's NAMES.ORA configuration file.

Action: Make sure that the NAMES.ADMIN_REGION parameter in NAMES.ORA is correct. The NAMES.ORA file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Oracle Support Services.

NNO-00251 missing administrative region parameter string

Cause: The server's administrative region description is missing a required parameter. This error will prevent the server from starting. The administrative region description is stored in the server's NAMES.ORA configuration file.

Action: Make sure that the NAMES.ADMIN_REGION parameter in NAMES.ORA is correct. The NAMES.ORA file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Oracle Support Services.

NNO-00252 invalid administrative region parameter string value "string"

Cause: The server encountered an invalid administrative region parameter. This error will prevent the server from starting. The administrative region description is stored in the server's NAMES.ORA configuration file.

Action: Make sure that the NAMES.ADMIN_REGION parameter in NAMES.ORA is correct. The NAMES.ORA file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Oracle Support Services.

NNO-00253 administrative region parameter string length string exceeds maximum of string

Cause: The server encountered an administrative region parameter whose length exceeds an internal limit. This error will prevent the server from starting. The administrative region description is stored in the server's NAMES.ORA configuration file.

Action: Make sure that the NAMES.ADMIN_REGION parameter in NAMES.ORA is correct. The NAMES.ORA file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Oracle Support Services.

NNO-00254 warning: parameter string value must be between number and number, set to number seconds

Cause: The server encountered an administrative region parameter with an invalid value. The value is set to a default suitable for most applications, and the server continues running. The administrative region description is stored in the server's NAMES.ORA configuration file.

Action: Make sure that the NAMES.ADMIN_REGION parameter in NAMES.ORA is correct. The NAMES.ORA file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Oracle Support Services.

NNO-00255 cannot initialize ROS

Cause: The server was unable to initialize ROS during startup. The error prevents the server from running. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00256 using administrative region "string"

Cause: An informational message which appears during server startup, and notes the name of the administrative region for future diagnostic use by administrators. The message is part of normal server startup.

Action: No action required.

NNO-00257 warning: cannot get serial number from region store

Cause: The server encountered an error while trying to get the configuration database's serial number. The error occurs almost always because the server is unable to access the configuration database. If the error occurs during server startup, the server will shut down. If the error occurs during server operation (the server checks the serial number periodically to see if it should reload itself), then the server assumes a transient failure has occurred and repeats the operation a short while later. If the repetitions continue to fail for three days, the server will log another error and stop issuing the serial number load operation.

Action: First make sure that the NETADMIN program has exported a server configuration for this name server. Next, make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. If the error occurs during server startup, you can force startup anyway, with checkpoint data, by starting the server with the NAMES.NO_REGION_DATABASE parameter set to TRUE. If no checkpoint data is available, the server will shut down.

NNO-00258 cannot load configuration from configuration database

Cause: An error was encountered while trying to load the server's configuration from the configuration database. If more information is available, it will appear under this error. This error will cause the server to shut down.

Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the NAMES.NO_REGION_DATABASE parameter set to TRUE. If no checkpoint data is available, the server will shut down.

NNO-00259 configuration tables have not been installed or are inaccessible

Cause: The configuration database has not been properly installed.

Action: Make sure the Oracle Network Manager and its database have been properly installed

NNO-00260 loading configuration data from checkpoint file "string"

Cause: An informational message written to the log file when the server has been forced to load from its most recent configuration checkpoint file, by setting the NAMES.NO_REGION_DATABASE parameter to TRUE.

Action: No action required.

NNO-00261 cannot construct configuration checkpoint file name

Cause: The server could not construct a system-dependent file name. This is an internal error, not normally visible to the user.

Action: For further details, turn on tracing and restart the server. If the error persists, contact Oracle Support Services.

NNO-00262 warning: cannot write checkpoint file "string"

Cause: The server was unable to write the named checkpoint file. This problem is typically due to the file system's protection settings. The error is not fatal; it means the server will not create any checkpoint data. Note, however, that if the configuration database is ever unavailable during a future server startup, the lack of checkpoint data means you will be unable to force a startup from checkpoint data with the NAMES.NO_REGION_DATABASE parameter.

Action: Check to see that the server has permission to write the file named in the error message.

NNO-00263 error from configuration database

Cause: The server encountered an error while accessing the configuration database. The error can occur when the database is unavailable, or SQL*Net connectivity to the database is interrupted.

Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the NAMES.NO_REGION_DATABASE parameter set to TRUE. If no checkpoint data is available, the server will shut down.

NNO-00264 configuration database query returned no data

Cause: The server attempted to fetch data from the configuration database and no data was found.

Action: The error generally appears underneath a more specific error which will tell you the exact nature of the problem.

NNO-00265 warning: cannot load data from checkpoint file

Cause: The server was started using checkpoint data, and was unable to read that data. The remaining errors below this one on the error stack provide more specific information about the problem.

Action: Check to see that the named file exists and that the server has permission to read it.

NNO-00266 cannot find document "string" in configuration database

Cause: The server encountered an error while trying to get its configuration ID from the configuration database. The error can occur any time the server is unable to access the configuration database. This error will cause the server to shut down.

Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the NAMES.NO_REGION_DATABASE parameter set to TRUE. If no checkpoint data is available, the server will shut down.

NNO-00267 warning: configuration database contains no data for server "string"

Cause: The server successfully contacted the configuration database, but was unable to find any configuration information associated with the server's name. The name is specified in the server's NAMES.ORA configuration file. The error occurs almost always because the server configuration has not been exported from the NETADMIN program.

Action: Make sure that the NETADMIN program has exported a server configuration for this name server.

NNO-00268 warning: configuration database is not used, using checkpoint data instead

Cause: An informational message indicating that the server has been started with the NAMES.NO_REGION_DATABASE parameter set to TRUE, and that it will use checkpoint data rather than attempting to contact the configuration database.

Action: No action required.

NNO-00269 configuration database is version string, server requires at least version string

Cause: The server cannot use the specified configuration database because it is of an incorrect version.

Action: Run the document conversion utility supplied with the Network Manager and re-export your network. The conversion utility will upgrade old documents to a version which can be understood by the name server.

NNO-00270 ORACLE error string

Cause: An ORACLE error was encountered while accessing the configuration database. The error can occur when the database is unavailable, or SQL*Net connectivity to the database is interrupted.

Action: Make sure that the database is running, that its name and password as specified in the Oracle Network Manager are accurate, and that there is SQL*Net connectivity between the Oracle Names server and the database. To force the server to start up anyway, using its checkpoint data, start the server with the NAMES.NO_REGION_DATABASE parameter set to TRUE. If no checkpoint data is available, the server will shut down.

NNO-00271 warning: names.ora region is version string, network definition is version string

Cause: The region description in NAMES.ORA is out of synch with the network definition.

Action: No action is required unless the name server cannot run with the network definition. To be safe NAMES.ORA should be updated with one which is consistent with the network definition.

NNO-00272 line string; invalid DIT/DN

Cause: There is a syntax error in the DIT/DN provided in the region description.

Action: Correct the error and restart the server.

NNO-00300 no listen addresses specified, at least one is required

Cause: The server's configuration is missing addresses on which to listen. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00301 server will shut down in number seconds

Cause: An informational message written to the log file when the server receives a shutdown request from the Oracle Names control program.

Action: No action required.

NNO-00302 server stopped

Cause: An informational message written to the log file when the server shuts down.

Action: No action required.

NNO-00303 server "string" started with process ID number

Cause: An informational message written to the log file when the server successfully starts up.

Action: No action required.

NNO-00304 listen address string length string exceeds maximum of string

Cause: The length of one of the server's listen addresses exceeds an internal limit. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00305 trace level changed from number to number

Cause: An informational message written to the log file when the server changes its trace level in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00306 server shutdown countdown aborted

Cause: An informational message written to the log file whenever the Oracle Names control program halts a shutdown request previously sent to the server

Action: No action required.

NNO-00307 invalid server name "string"

Cause: The server's name is invalid. The name is specified in the server's NAMES.ORA configuration file.

Action: Make sure that the NAMES.SERVER_NAME parameter in NAMES.ORA is correct. The NAMES.ORA file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Oracle Support Services.

NNO-00308 server will restart in number seconds

Cause: An informational message written to the log file when the server receives a restart request from the Oracle Names control program.

Action: No action required.

NNO-00309 server restarting

Cause: An informational message written to the log file when the server restarts.

Action: No action required.

NNO-00310 server restart countdown aborted

Cause: An informational message written to the log file whenever the Oracle Names control program halts a restart request previously sent to the server

Action: No action required.

NNO-00311 invalid listen address list

Cause: The server's configuration contains an invalid listen address list. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00312 listen address string is invalid

Cause: The server's configuration contains an invalid listen address. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00313 server password length string exceeds maximum of string

Cause: The server's password length exceeds an internal limit. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00314 error changing trace level from number to number, level change ignored

Cause: The server encountered an error while changing its trace level in response to a request from the Oracle Names control program. This is an internal error, not normally visible to the user.

Action: For further details, turn on tracing and restart the server. If the error persists, contact Oracle Support Services.

NNO-00315 server is listening on address string

Cause: An informational message written to the log file during server startup.

Action: No action required.

NNO-00316 statistic counter reset disabled

Cause: An informational message written to the log file when the server disables statistic counter resetting in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00317 statistic counter reset interval changed to number seconds

Cause: An informational message written to the log file when the server changes its statistic counter reset interval in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00318 overriding next statistic counter reset, resetting in number seconds

Cause: An informational message written to the log file when the server resets its statistic counters in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00320 missing server name parameter

Cause: The server could not find a NAMES.SERVER_NAME parameter. The name is specified in the server's NAMES.ORA configuration file.

Action: Make sure that the NAMES.SERVER_NAME parameter in NAMES.ORA is correct. The NAMES.ORA file is automatically generated by the Oracle Network Manager, but administrators can edit the file at any time, introducing errors. If the file was never changed, contact Oracle Support Services.

NNO-00321 statistic counter dump disabled

Cause: An informational message written to the log file when the server disables statistics dumping in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00322 statistic counter dump interval changed to number seconds

Cause: An informational message written to the log file when the server changes its statistic dump interval in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00323 overriding next statistic counter dump, dumping in number seconds

Cause: An informational message written to the log file when the server dumps its statistic counters in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00326 server statistic counter dump follows

Cause: An informational message written to the log file at the beginning of a statistic dump. The message is followed by a set of server statistics, and ends with another informational message indicating the dump has finished.

Action: No action required.

NNO-00327 server statistic counter dump ends

Cause: An informational message written to the log file at the end of a statistic dump. The message is preceded by a set of server statistics.

Action: No action required.

NNO-00328 server has reset statistic counters to zero

Cause: An informational message written to the log file when the server resets its statistic counters to zero in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00329 server will save the config file in number seconds

Cause: An informational message written to the log file when the server saves the configuration to the configuration file in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00330 server saved the config file "string".

Cause: An informational message written to the log file when the server saves the configuration to a configuration file in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00331 error saving new value string of string to the save config table.

Cause: An informational message written to the log file when the a set operation is performed and the change cannot be saved in the save configuration table, but should be.

Action: No action required.

NNO-00332 warning: region store serial number reduced from number to number

Cause: An informational message written to the log file when the server finds the region database has it's serial number set lower than it was when the server previously loaded the region data. This is an unnatural condition--every update to the region should increment the serial number so a reduction of the serial number might reflect tampering or accidental manual alteration this and possibly other region tables.

Action: Administrators should find out how and why the serial number decreased.

NNO-00333 warning: ROS admin_region types obsolete; using SQL

Cause: the value set in names.admin_region is an obsolete ROS type.

Action: No action is necessary; administrators should set the value to the correct type (SQL, LDAP, or LDIF).

NNO-00334 region load failure: ROS admin_region type number unsupported

Cause: the value set in names.admin_region is an obsolete ROS type.

Action: No action is necessary; administrators should set the value to the correct type (SQL, LDAP, or LDIF).

NNO-00600 warning: forwarder count number exceeds maximum of number, first number will be loaded

Cause: The server's configuration contains too many default forwarders. The server loads a specified maximum number of forwarders, ignores the rest, and continues running. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00601 warning: no forwarders, DEFAULT-FORWARDERS-ONLY mode ignored

Cause: The server's configuration enables DEFAULT-FORWARDERS-ONLY mode but the configuration contains no default forwarders. The server ignores the request and continues running. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00602 warning: forwarder number has invalid address, forwarder ignored

Cause: One of the forwarders in the default forwarder list has an invalid address. The forwarder definition is ignored and the server continues running. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00603 enabling all request processing

Cause: An informational message written to the log file when the server enables request processing in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00604 disabling all request processing

Cause: An informational message written to the log file when the server disables request processing in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00605 enabling modification requests

Cause: An informational message written to the log file when the server enables modification-request processing in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00606 disabling modification requests

Cause: An informational message written to the log file when the server disables modification-request processing in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00607 server will forward to default forwarders only

Cause: An informational message written to the log file when the server's configuration enables DEFAULT-FORWARDERS-ONLY mode.

Action: No action required.

NNO-00608 received corrupted message

Cause: The server received a corrupted request. The request is ignored.

Action: corrupted requests are usually caused by transient network problems. If many corrupted messages are received, turn on tracing for further information. If the errors persist, contact Oracle Support Services.

NNO-00609 warning: forwarder number address length number exceeds maximum of number, ignored

Cause: The server's configuration contains a forwarder address whose length exceeds an internal limit. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00610 detected possible alias loop involving name "string"

Cause: The server detected an alias loop involving the specified name. An alias loop occurs when an alias "X" points to another alias "Y", which points back to "X" rather than to an address or other name server data. The loop can contain more hops but the basic idea remains the same. Loops occur when administrators incorrectly enter network data, particularly when an alias in one administrative region points to data in another administrative region.

Action: Use the Oracle Names control program to query for the specified name. The control program will describe the alias path, and you can use that information to find which names are incorrect and what administrative regions the incorrect data belongs to.

NNO-00611 disabling request forwarding

Cause: An informational message written to the log file when the server disables request forwarding in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00612 enabling request forwarding

Cause: An informational message written to the log file when the server enables request forwarding in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00613 disabling FORWARDING-DESIRED on system queries

Cause: An informational message written to the log file when the server disables the FORWARDING-DESIRED attribute on queries that it generates. The message comes in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00614 enabling FORWARDING-DESIRED on system queries

Cause: An informational message written to the log file when the server enables the FORWARDING-DESIRED attribute on queries that it generates. The message comes in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00615 disabling DEFAULT-FORWARDERS-ONLY mode

Cause: An informational message written to the log file when the server disables DEFAULT-FORWARDERS-ONLY mode in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00616 enabling DEFAULT-FORWARDERS-ONLY mode

Cause: An informational message written to the log file when the server enables DEFAULT-FORWARDERS-ONLY mode in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00617 enabling AUTHORITY-REQUIRED on system queries

Cause: An informational message written to the log file when the server enables the AUTHORITY-REQUIRED attribute on queries that it generates. The message comes in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00618 disabling AUTHORITY-REQUIRED on system queries

Cause: An informational message written to the log file when the server disables the AUTHORITY-REQUIRED attribute on queries that it generates. The message comes in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00622 warning: too many auto-refresh failures for name "string", query expired

Cause: If an auto-refresh query is issued and continuously returns an error for three days, the query is removed from the auto-refresh queue and a warning logged. The query can be restarted from the Oracle Names control program.

Action: this message will be preceded by numerous warnings that the query in question is failing. Use the Oracle Names control program to describe the failing query. Make sure the server being queried is running and that there is network connectivity between the querying server and the server being queried.

NNO-00623 setting auto-refresh retry interval to number seconds

Cause: An informational message written to the log file when the server changes its auto-refresh retry interval in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00624 setting auto-refresh expiration period to number seconds

Cause: An informational message written to the log file when the server changes its auto-refresh expiration period in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00625 overriding auto-refresh of name "string", type "string", refresh in number seconds

Cause: An informational message written to the log file when the server changes the time when an auto-refresh query is next issued. The message comes in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00626 cannot enable DEFAULT-FORWARDERS-ONLY mode, no default forwarders exist

Cause: The Oracle Names control program issued a request to enable DEFAULT-FORWARDERS-ONLY mode, and the request was ignored because the server has no default forwarders.

Action: No action required.

NNO-00627 cancelling auto-refresh of name "string", type "string"

Cause: An informational message written to the log file when the server removes a query from the auto-refresh queue in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00628 setting maximum reforwards per query to number

Cause: An informational message written to the log file when the server changes its maximum-reforward count in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00629 warning: invalid forwarder list, no default forwarders loaded

Cause: The server's configuration contains an invalid forwarder description list. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00630 setting request-processing delay to number seconds

Cause: An informational message written to the log file when the server sets an artificial request-processing delay in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00631 warning: forwarder number has invalid name "string", forwarder ignored

Cause: The server's configuration contains a forwarder description with an invalid server name. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00632 warning: forwarder number has missing address, forwarder ignored

Cause: The server's configuration contains a forwarder description with a missing address. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00633 detected fatal delegation loop involving server "string"

Cause: The server detected a fatal delegation loop while forwarding a request. A loop occurs when the server's topology data indicates that it should forward a request to itself. The server immediately shuts down in response to this error. This is an internal error, not normally visible to the user.

Action: For further details, turn on tracing and restart the server. If the error persists, contact Oracle Support Services.

NNO-00634 received authoritative name "string" when we are its authority

Cause: A server "X" received authoritative data from another server "Y" when server "X" is also authoritative for the data. Such situations should never arise because if server "X" is authoritative for the requested data, it should never forward the request to another server. This is an internal error, not normally visible to the user.

Action: For further details, turn on tracing and restart the server. If the error persists, contact Oracle Support Services.

NNO-00635 warning: ignoring duplicate forwarder "string"

Cause: The server's default forwarder list contains a duplicate server. The duplicate is ignored and the server continues running. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNO-00700 warning: cannot checkpoint the cache, trying again in number seconds

Cause: The server was unable to perform its normal periodic cache checkpointing, typically because the cache checkpoint file could not be written. The cache checkpoint file name appears as an informational message during server startup.

Action: Check to see that the server has permission to write the cache checkpoint file, and that there is sufficient disk space for the file to be written.

NNO-00701 warning: cannot construct checkpoint file name, checkpointing disabled

Cause: The server could not construct a system-dependent file name. This is an internal error, not normally visible to the user.

Action: For further details, turn on tracing and restart the server. If the error persists, contact Oracle Support Services.

NNO-00702 cache checkpointing disabled

Cause: An informational message written to the log file when the server disables cache checkpointing in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00703 checkpoint interval changed to number seconds

Cause: An informational message written to the log file when the server changes its cache checkpoint interval in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00705 warning: cannot open checkpoint file "string", checkpointing disabled

Cause: The server was unable to open the named checkpoint file for writing. This problem is typically due to the file system's protection settings. The error is not fatal; it means the server will not checkpoint its cache.

Action: Check to see that the server has permission to write the file named in the error message.

NNO-00706 overriding next cache checkpoint, checking in number seconds

Cause: An informational message written to the log file when the server checkpoints its cache in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00707 server's cache will be flushed in number seconds

Cause: An informational message written to the log file when the server flushes its cache in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00708 cache flush countdown aborted

Cause: An informational message written to the log file whenever the Oracle Names control program halts a cache flush request previously sent to the server

Action: No action required.

NNO-00709 failed delete of cache checkpoint file "string", cache flush may not work

Cause: The server attempted to flush its cache, which also deletes the cache checkpoint file. The file deletion failed, although the rest of the cache flush succeeded. Accompanying errors describe the reason for the deletion failure.

Action: This error typically occurs when two cache-flush operations are issued in succession without an intervening cache checkpoint operation (which would re-create the file). The first deletes the cache file, the second attempts to do so, but fails since the file has already been deleted. In such cases, the message is harmless and can be ignored. If, however, the error occurs because the server lacks permission to delete the file, then you must change the file system permissions so the server is allowed to delete the file.

NNO-00710 server's cache will be dumped to the trace file in number seconds

Cause: An informational message written to the log file when the server dumps its cache to the trace file in response to a request from the Oracle Names control program.

Action: No action required.

NNO-00711 cache dump countdown aborted

Cause: An informational message written to the log file whenever the Oracle Names control program halts a cache dump request previously sent to the server

Action: No action required.

NNO-00712 warning: group string cache checkpoint failed

Cause: The server was unable to perform its normal periodic cache checkpointing, typically because the cache checkpoint file could not be written. The cache checkpoint file name appears as an informational message during server startup.

Action: Check to see that the server has permission to write the cache checkpoint file, and that there is sufficient disk space for the file to be written.

NNO-00800 Error: cannot read version from config database

Cause: The query for the region database version failed. The database may be shut down, or the tables may not exist in the schema specified in NAMES.ORA.

Action: Correct any access problems accordingly.

NNO-00801 Error: OCI_SUCCESS_WITH_INFO: string

Cause: Diagnostic information was returned from OCI during region database access.

Action: No action required.

NNO-00802 Error: OCI_NEED_DATA

Cause: The server did not provide sufficient data to the OCI interface while accessing the region database. This is an internal error.

Action: Contact Oracle Support Services.

NNO-00803 Error: OCI_INVALID_HANDLE

Cause: The server called OCI with an invalid handle whilc accessing the region database. This is an internal error.

Action: Contact Oracle Support Services.

NNO-00804 Error: OCI_STILL_EXECUTE

Cause: An OCI operation between the server and the database is still in progress.

Action: No action required.

NNO-00806 Error: OCI_ERROR: string

Cause: An OCI occurred while accessing the region database. More specific details will be written to the log file.

Action: Find the appropriate entry in the log file and correct the cause of the failure if possible. Otherwise contact Oracle Support Services.

NNO-00807 End of Fetch: OCI_NO_DATA

Cause: All rows have been returned from the region table.

Action: No action required.

NNO-00850 Error: LDAP query returns string

Cause: The LDAP API returned an error. More specific details will be written to the log file.

Action: Find the appropriate entry in the log file and correct the cause of the failure if possible. Otherwise contact Oracle Support Services.

NNO-00851 LDAP open/bind failed: error = number

Cause: the server failed to connect to the LDAP directory.

Action: Find the cause of the error and correct it and restart the server.

NNO-00852 failed to get LDAP entry: error = number

Cause: the server could not retrieve query entries from the LDAP API.

Action: Find the cause of the error and correct it and restart the server.

NNO-00853 failed to get LDAP attribute/value: error = number

Cause: the server failed to connect to the LDAP directory.

Action: Find the cause of the error and correct it and restart the server.

NNO-00854 error unbinding LDAP: error = number

Cause: the server failed to connect to the LDAP directory.

Action: Find the cause of the error, correct it, and restart the server.


Oracle Names Control Utility Messages (NNL)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

33
Oracle Names Control Utility Messages (NNL)

NNL-00000 normal, successful completion

Cause: An operation has completed normally, having met no exceptions.

Action: No action required.

NNL-00001 request argument "string" is invalid

Cause: The user entered an invalid request command argument.

Action: Supply a valid argument.

NNL-00002 request argument "string" is not allowed with this operation

Cause: The user entered a request command argument which is not valid with the particular request command.

Action: Supply a valid argument.

NNL-00003 memory exhausted

Cause: The program has run out of memory

Action: Check the amount of available memory on your machine to ensure that there is enough memory to run this executable. If necessary, free up memory by running fewer programs, then try again.

NNL-00004 invalid command argument "string"

Cause: The user entered an invalid command argument.

Action: Supply a valid argument.

NNL-00005 no server has been set. Use the "SET SERVER" command first

Cause: An attempt was made to issue a command which requires that a default managed Oracle Names server be set first.

Action: Use the SET SERVER command to set your default server, then reissue the command. Alternatively, if the command allows, re-issue it with a specific server name so the control program does not need to use the default.

NNL-00006 timeout, server is not responding

Cause: The control program issued a request to an Oracle Names server and no response arrived in a timely fashion. The network connection between the control program and the server may be faulty, the server may be very heavily loaded, or there may be substantial network delays between the control program and the server. The latter is especially true for WAN links.

Action: Reissue the command; if it continues to fail, check to see that the server being managed is running correctly and that the network connection between the server and the control program is working correctly.

NNL-00007 server responded with an error

Cause: The control program issued a request to an Oracle Names server and the server responded with an error.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNL-00008 request not understood by server

Cause: The control program issued a request to an Oracle Names server and the server did not understand the request.

Action: If the server and the control program have different versions, they may be unable to communicate. Check your documentation for version compatibility constraints. If the server and control program are compatible, turn on tracing for further details, and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNL-00009 encryption of server password failed

Cause: The control program attempted and failed to encrypt a server password, supplied either through the SET PASSWORD command or the NAMESCTL.SERVER_PASSWORD configuration parameter. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNL-00010 error getting address for server "string"

Cause: The control program attempted to translate a server name to its corresponding address, and failed. There are a large number of possible causes for the failure. The control program's SQLNET.ORA file must exist in the correct system-specific location, and must be readable by the control program. The file must contain a NAMES.PREFERRED_SERVERS entry with valid name server addresses. If the user has changed managed servers with the SET SERVER command, the new server must be running, and must be able to resolve the address or forward the request to another server which can resolve the address. Alternatively, a TNSNAMES.ORA file with valid name server names and addresses must exist in the correct system-specific location.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNL-00011 no server with name "string" exists

Cause: The user issued a SET SERVER request and the current managed Oracle Names server was unable to translate that name into an address. Alternatively, the user issued a control program request to a specific server, and that server's name could not be translated into an address. Both problems are almost always caused by incorrectly typing the server name.

Action: Re-issue the request with a valid server name.

NNL-00012 invalid "string" value "string"

Cause: The first argument is a data type, the second is a value. The user supplied an invalid data value of the specified type.

Action: Re-issue the failing operation with correct data.

NNL-00013 not performed, permission denied for supplied password

Cause: The user issued a request to an Oracle Names server, and the password supplied with the request was incorrect.

Action: Check to see that the password sent by the control program to the server is correct for that server. You can set a new password with the SET PASSWORD control program command.

NNL-00014 unknown data type "string"

Cause: The user issued a name server request which contained an unknown data type.

Action: It is possible that the server had no information on the type, but automatically fetched it in response to the failing request. Re-issue the failing request; if the server has in the meantime fetched the appropriate data type information, the error will go away. If the error persists, the data type is probably invalid.

NNL-00015 type "string" has "string" syntax, which has no textual representation

Cause: Not all data type syntaxes can be represented as text. This message indicates that the user issued a name server request for a type with an non-textual representation.

Action: Re-issue the operation with a data type that has a syntax with a textual representation.

NNL-00016 cannot start server, error getting program directory's name

Cause: The user issued a STARTUP request, but the control program was unable to start the server because it was unable to find the name of the directory where the server executable resides. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNL-00017 cannot start server, program "string" does not exist

Cause: The user issued a STARTUP request, but the control program was unable to start the server because it was unable to find the server executable.

Action: Make sure that a copy of the server executable exists in your system's Oracle executable directory.

NNL-00018 warning: could not contact default name server

Cause: The control program was unable to contact its default name server during startup. There are a number of possible causes for this error. The control program's SQLNET.ORA file must exist in the correct system-specific location, and must be readable by the control program. The file must contain a NAMES.PREFERRED_SERVERS entry with valid name server addresses. The first server in the preferred-server list must be running, and there must be network connectivity between the control program and that server.

Action: Check to see that all of the above are true. If the control program is still unable to contact its default server, turn on tracing and restart the control program. If the error persists, contact Oracle Support Services.

NNL-00019 warning: server either changed or ignored your request

Cause: The user issued a request to an Oracle Names server and that request was altered in some way. Typically the user specified an invalid argument of some sort, and the server either ignored the request, or replaced the invalid argument with a reasonable default.

Action: Use the control program to check the current state of the value that you attempted to change. The server's log file may also contain information about the exact cause of the problem. Re-issue the operation with correct arguments.

NNL-00020 warning: no TNSNAMES.ORA file and no preferred name servers in SQLNET.ORA

Cause: The control program was unable to find a TNSNAMES.ORA file and was unable to find a default name server in SQLNET.ORA. The control program will operate in this state, but will be unable to resolve any names until a default server has been set, and that server must be set using its raw TNS address.

Action: The control program's SQLNET.ORA file must exist in the correct system-specific location, and must be readable by the control program. The file must contain a NAMES.PREFERRED_SERVERS entry with valid name server addresses. The first server in the preferred-server list must be running, and there must be network connectivity between the control program and that server. Alternatively, a TNSNAMES.ORA file with valid name server information must exist in the correct system-specific location.

NNL-00022 error changing trace level from string to string, level change ignored

Cause: An attempt was made to change the control program's local trace level, and the program encountered an error while changing the level. Usually the problem is that tracing was enabled for the first time (by changing the trace level from OFF to something else) and the trace file is not writeable by the control program.

Action: Check to see that the trace file is writeable. Your documentation will tell you the name of the trace file.

NNL-00023 SET command is missing an argument

Cause: An attempt was made to issue a SET command with no argument.

Action: Supply a valid argument to the SET command.

NNL-00024 warning: no preferred name servers in SQLNET.ORA

Cause: The control program was unable to find any preferred name servers in SQLNET.ORA, and will therefore not connect to a default server.

Action: Make sure that the SQLNET.ORA file contains a valid NAMES.PREFERRED_SERVERS entry.

NNL-00035 File string or nested IFILEs not found.

Cause: Error in loading from the TNSFILE.

Action: No action required.

NNL-00036 No records loaded

Cause: No loadable data.

Action: No action required.

NNL-00037 Error number while sequencing through parameter table.

Cause: The NL Parameter system reported an error while retrieving the next name from the table. This is an internal error, not normally visible to the user.

Action: Contact Oracle Support Services.

NNL-00038 Distinguished Name syntax error

Cause: Distinguished Name incorrectly specified.

Action: Supply a valid DN.

NNL-00039 no RRs

Cause: Object has no relevant RRs to be mapped to LDAP objects.

Action: No action required.

NNL-00040 Distinguished Name exceeds buffer length: string

Cause: Distinguished Name derived from Domain Name is too long.

Action: Either move the object to a domain whose name is shorter or manually update the LDAP object.

NNL-00041 Object string not in domain string

Cause: Object has no relevant RRs to be mapped to LDAP objects.

Action: No action required.

NNL-00042 LDAP bind failure: number, string

Cause: Call to LDAP_BIND failed with return set to given number.

Action: Correct user/pwd parameters or definitions.

NNL-00043 LDAP open failure

Cause: LDAP server could not be contacted.

Action: Correct connect information or server unavailability.

NNL-00044 Unsupported data type string not mapped

Cause: ONames data type could not be mapped to LDAP attributes. This is an internal error.

Action: Contact Oracle Support Services.

NNL-00045 No host given for LDAP server

Cause: LDAP open will dump core without a host.

Action: Provide appropriate host with '-h' option.

NNL-00046 Name string exceeds DN template depth

Cause: There are more domains in the name than are specified in the DN template.

Action: Add fields to the template or migrate subdomains with separate dump operations.

NNL-00047 LDAP modify returned error: number, string

Cause: LDAP failed with the return code shown.

Action: Refer to LDAP documentation for the meaning of the error.

NNL-00048 Error opening file: string

Cause: Named file cannot be opened.

Action: Provide for access to the file.

NNL-00049 Output in string cannot be renamed to string

Cause: The given file cannot be created.

Action: Ensure that the specified file can be created before running the command, or use the temporary file itself.

NNL-00201 Shutdown occurs in string

Cause: Control program general message.

Action: No action required.

NNL-00202 No shutdown currently scheduled

Cause: Control program general message.

Action: No action required.

NNL-00203 Scheduled shutdown to occur in string

Cause: Control program general message.

Action: No action required.

NNL-00204 Cancelled shutdown

Cause: Control program general message.

Action: No action required.

NNL-00205 Reload check occurs in string

Cause: Control program general message.

Action: No action required.

NNL-00206 No reload check currently scheduled

Cause: Control program general message.

Action: No action required.

NNL-00207 Scheduled reload check to occur in string

Cause: Control program general message.

Action: No action required.

NNL-00208 Cancelled reload check

Cause: Control program general message.

Action: No action required.

NNL-00209 Cache checkpoint interval is currently string

Cause: Control program general message.

Action: No action required.

NNL-00210 Cache checkpointing is currently disabled

Cause: Control program general message.

Action: No action required.

NNL-00211 Cache checkpoint interval is now string

Cause: Control program general message.

Action: No action required.

NNL-00212 Cache checkpointing is now disabled

Cause: Control program general message.

Action: No action required.

NNL-00213 No entry with specified index number, try "SHOW SYSTEM_QUERIES"

Cause: Control program general message.

Action: No action required.

NNL-00214 Next auto-refresh for specified index number occurs in string

Cause: Control program general message.

Action: No action required.

NNL-00215 Scheduled specified index number's next auto-refresh to occur in string

Cause: Control program general message.

Action: No action required.

NNL-00216 Disabled auto-refresh for specified index number

Cause: Control program general message.

Action: No action required.

NNL-00217 Controller is sleeping for number seconds

Cause: Control program general message.

Action: No action required.

NNL-00218 Ignoring spurious trailing text "string"

Cause: Control program general message.

Action: No action required.

NNL-00219 Statistic counter logging interval is currently string

Cause: Control program general message.

Action: No action required.

NNL-00220 Statistic counter logging is currently disabled

Cause: Control program general message.

Action: No action required.

NNL-00221 Statistic counter logging interval is now string

Cause: Control program general message.

Action: No action required.

NNL-00222 Statistic counter logging is now disabled

Cause: Control program general message.

Action: No action required.

NNL-00223 Statistic counters are next logged in string

Cause: Control program general message.

Action: No action required.

NNL-00224 Scheduled statistic counters to be logged in string

Cause: Control program general message.

Action: No action required.

NNL-00225 Currently managing name server "string"

Cause: Control program general message.

Action: No action required.

NNL-00226 Current request-processing delay is string

Cause: Control program general message.

Action: No action required.

NNL-00227 Request-processing delay is currently disabled

Cause: Control program general message.

Action: No action required.

NNL-00228 Request-processing delay is now string

Cause: Control program general message.

Action: No action required.

NNL-00229 Request-processing delay is now disabled

Cause: Control program general message.

Action: No action required.

NNL-00230 Controller NOCONFIRM mode is currently string

Cause: Control program general message.

Action: No action required.

NNL-00231 Controller NOCONFIRM mode is now string

Cause: Control program general message.

Action: No action required.

NNL-00232 Auto-refresh failure-retry interval is currently string

Cause: Control program general message.

Action: No action required.

NNL-00233 Auto-refresh failure-retry interval is now string

Cause: Control program general message.

Action: No action required.

NNL-00234 Auto-refresh failure-retry expiration period is currently string

Cause: Control program general message.

Action: No action required.

NNL-00235 Auto-refresh failure-retry expiration period is now string

Cause: Control program general message.

Action: No action required.

NNL-00236 Statistic counter reset interval is currently string

Cause: Control program general message.

Action: No action required.

NNL-00237 Resetting of statistic counters is currently disabled

Cause: Control program general message.

Action: No action required.

NNL-00238 Statistic counter reset interval is now string

Cause: Control program general message.

Action: No action required.

NNL-00239 Resetting of statistic counters is now disabled

Cause: Control program general message.

Action: No action required.

NNL-00240 Starting "string"...

Cause: Control program general message.

Action: No action required.

NNL-00241 Processing of modification requests is currently enabled

Cause: Control program general message.

Action: No action required.

NNL-00242 Processing of modification requests is currently disabled

Cause: Control program general message.

Action: No action required.

NNL-00243 Processing of modification requests is now enabled

Cause: Control program general message.

Action: No action required.

NNL-00244 Processing of modification requests is now disabled

Cause: Control program general message.

Action: No action required.

NNL-00245 General request processing is currently enabled

Cause: Control program general message.

Action: No action required.

NNL-00246 General request processing is currently disabled

Cause: Control program general message.

Action: No action required.

NNL-00247 General request processing is now enabled

Cause: Control program general message.

Action: No action required.

NNL-00248 General request processing is now disabled

Cause: Control program general message.

Action: No action required.

NNL-00249 DEFAULT-FORWARDERS-ONLY mode is currently enabled

Cause: Control program general message.

Action: No action required.

NNL-00250 DEFAULT-FORWARDERS-ONLY mode is currently disabled

Cause: Control program general message.

Action: No action required.

NNL-00251 DEFAULT-FORWARDER-ONLY mode is now enabled

Cause: Control program general message.

Action: No action required.

NNL-00252 DEFAULT-FORWARDER-ONLY mode is now disabled

Cause: Control program general message.

Action: No action required.

NNL-00253 Server-generated requests currently request forwarding

Cause: Control program general message.

Action: No action required.

NNL-00254 Server-generated requests currently do not request forwarding

Cause: Control program general message.

Action: No action required.

NNL-00255 Server-generated requests now request forwarding

Cause: Control program general message.

Action: No action required.

NNL-00256 Server-generated requests now do not request forwarding

Cause: Control program general message.

Action: No action required.

NNL-00257 Server-generated requests currently require authoritative answers

Cause: Control program general message.

Action: No action required.

NNL-00258 Server-generated requests currently do not require authoritative answers

Cause: Control program general message.

Action: No action required.

NNL-00259 Server-generated requests now require authoritative answers

Cause: Control program general message.

Action: No action required.

NNL-00260 Server-generated requests now do not require authoritative answers

Cause: Control program general message.

Action: No action required.

NNL-00261 Request forwarding is currently enabled

Cause: Control program general message.

Action: No action required.

NNL-00262 Request forwarding is currently disabled

Cause: Control program general message.

Action: No action required.

NNL-00263 Request forwarding is now enabled

Cause: Control program general message.

Action: No action required.

NNL-00264 Request forwarding is now disabled

Cause: Control program general message.

Action: No action required.

NNL-00266 Round trip time is string

Cause: Control program general message.

Action: No action required.

NNL-00267 Address is string

Cause: Control program general message.

Action: No action required.

NNL-00268 Enter name server password:

Cause: Prompt for password after user has issued SET PASSWORD.

Action: Type password, invisibly.

NNL-00270 Current default domain is "string"

Cause: Control program general message.

Action: No action required.

NNL-00271 Default domain is now "string"

Cause: Control program general message.

Action: No action required.

NNL-00272 Removed name "string" from caches along the following path:

Cause: Control program general message.

Action: No action required.

NNL-00273 server successfully started

Cause: Control program general message.

Action: No action required.

NNL-00274 server not started, errors follow

Cause: Control program general message.

Action: No action required.

NNL-00275 Trace level is currently number

Cause: Control program general message.

Action: No action required.

NNL-00276 Trace level is now number

Cause: Control program general message.

Action: No action required.

NNL-00277 Maximum number of times a request can be reforwarded is currently number

Cause: Control program general message.

Action: No action required.

NNL-00278 Maximum number of times a request can be reforwarded is now number

Cause: Control program general message.

Action: No action required.

NNL-00279 Restart occurs in string

Cause: Control program general message.

Action: No action required.

NNL-00280 No restart currently scheduled

Cause: Control program general message.

Action: No action required.

NNL-00281 Scheduled restart to occur in string

Cause: Control program general message.

Action: No action required.

NNL-00282 Cancelled restart

Cause: Control program general message.

Action: No action required.

NNL-00283 Next cache checkpoint occurs in string

Cause: Control program general message.

Action: No action required.

NNL-00284 Scheduled cache checkpoint to occur in string

Cause: Control program general message.

Action: No action required.

NNL-00285 Server has no queued system queries

Cause: Control program general message.

Action: No action required.

NNL-00286 Server does not own any domains

Cause: Control program general message.

Action: No action required.

NNL-00287 Cache flush occurs in string

Cause: Control program general message.

Action: No action required.

NNL-00288 No cache flush currently scheduled

Cause: Control program general message.

Action: No action required.

NNL-00289 Scheduled cache flush to occur in string

Cause: Control program general message.

Action: No action required.

NNL-00290 Cancelled cache flush

Cause: Control program general message.

Action: No action required.

NNL-00291 Statistic counters are next reset in string

Cause: Control program general message.

Action: No action required.

NNL-00292 Scheduled statistic counters to be reset in string

Cause: Control program general message.

Action: No action required.

NNL-00293 Controller's trace level remains unchanged

Cause: Control program general message.

Action: No action required.

NNL-00294 No entries found

Cause: Control program general message.

Action: No action required.

NNL-00295 Controller's local trace level is currently number

Cause: Control program general message.

Action: No action required.

NNL-00296 Controller's local trace level changed from number to number

Cause: Control program general message.

Action: No action required.

NNL-00297 Cache will be dumped to trace file in string

Cause: Control program general message.

Action: No action required.

NNL-00298 No cache dump currently scheduled

Cause: Control program general message.

Action: No action required.

NNL-00299 Scheduled server cache dump to occur in string

Cause: Control program general message.

Action: No action required.

NNL-00300 Cancelled server cache dump

Cause: Control program general message.

Action: No action required.

NNL-00301 Server shutting down

Cause: Control program general message.

Action: No action required.

NNL-00302 Server restarting

Cause: Control program general message.

Action: No action required.

NNL-00303 Server checking for reload

Cause: Control program general message.

Action: No action required.

NNL-00304 Server flushing its cache

Cause: Control program general message.

Action: No action required.

NNL-00305 Server dumping statistics to the log file

Cause: Control program general message.

Action: No action required.

NNL-00306 Server setting all statistic counters to zero

Cause: Control program general message.

Action: No action required.

NNL-00307 Server checkpointing its cache

Cause: Control program general message.

Action: No action required.

NNL-00308 Server dumping its cache to the trace file

Cause: Control program general message.

Action: No action required.

NNL-00309 Specified index number's next auto-refresh will occur immediately

Cause: Control program general message.

Action: No action required.

NNL-00340 Trace file name is currently string

Cause: Control program general message.

Action: No action required.

NNL-00341 Trace file name is now string

Cause: Control program general message.

Action: No action required.

NNL-00342 Log file name is currently string

Cause: Control program general message.

Action: No action required.

NNL-00343 Log file name is now string

Cause: Control program general message.

Action: No action required.

NNL-00344 Save_config_on_stop is currently ON

Cause: Control program general message.

Action: No action required.

NNL-00345 Save_config_on_stop is currently OFF

Cause: Control program general message.

Action: No action required.

NNL-00346 Save_config_on_stop is now ON

Cause: Control program general message.

Action: No action required.

NNL-00347 Save_config_on_stop is now OFF

Cause: Control program general message.

Action: No action required.

NNL-00348 Server saving the config file now

Cause: Control program general message.

Action: No action required.

NNL-00349 Configuration will be saved in string

Cause: Control program general message.

Action: No action required.

NNL-00350 No save config currently scheduled

Cause: Control program general message.

Action: No action required.

NNL-00351 Scheduled configuration save to occur in string

Cause: Control program general message.

Action: No action required.

NNL-00352 Cancelled save config

Cause: Control program general message.

Action: No action required.

NNL-00353 Not allowed

Cause: Control program general message.

Action: No action required.

NNL-00400 Response status:

Cause: Control program general message.

Action: No action required.

NNL-00401 Authoritative answer: string

Cause: Control program general message.

Action: No action required.

NNL-00402 Authoritative server: string

Cause: Control program general message.

Action: No action required.

NNL-00403 Number of answers: number

Cause: Control program general message.

Action: No action required.

NNL-00404 TTL: string

Cause: Control program general message.

Action: No action required.

NNL-00405 Forwarding information:

Cause: Control program general message.

Action: No action required.

NNL-00406 Canonical name: string

Cause: Control program general message.

Action: No action required.

NNL-00407 Alias translations:

Cause: Control program general message.

Action: No action required.

NNL-00408 Answers:

Cause: Control program general message.

Action: No action required.

NNL-00409 data type is "string"

Cause: Control program general message.

Action: No action required.

NNL-00410 Average response time: string

Cause: Control program general message.

Action: No action required.

NNL-00411 Minimum response time: string

Cause: Control program general message.

Action: No action required.

NNL-00412 Number of requests: number

Cause: Control program general message.

Action: No action required.

NNL-00413 Total response time: string

Cause: Control program general message.

Action: No action required.

NNL-00414 Maximum response time: string

Cause: Control program general message.

Action: No action required.

NNL-00415 Name: string

Cause: Control program general message.

Action: No action required.

NNL-00416 Last timestamp: number

Cause: Control program general message.

Action: No action required.

NNL-00417 Distinguished Name: string

Cause: Control program general message.

Action: No action required.

NNL-00418 Attributes Mapped: number

Cause: Control program general message.

Action: No action required.

NNL-00500 Shows information on domains served by this server

Cause: Control program help text.

Action: No action required.

NNL-00501 set|show log_stats_interval [seconds] [server_list] :set|show the server's statistic counter logging interval

Cause: Control program help text.

Action: No action required.

NNL-00502 Shows, sets, or cancels when the server next dumps its statistic counters

Cause: Control program help text.

Action: No action required.

NNL-00503 repeat number command [args] : repeat a command number times

Cause: Control program help text.

Action: No action required.

NNL-00505 log_stats [server_list] : write Names server statistics to the log file

Cause: Control program help text.

Action: No action required.

NNL-00506 reset_stats [server_list] : reset Names server statistics

Cause: Control program help text.

Action: No action required.

NNL-00507 Shows, sets, or cancels the time when an auto-refresh query is next issued

Cause: Control program help text.

Action: No action required.

NNL-00508 show system_queries [server_list] : show system query information

Cause: Control program help text.

Action: No action required.

NNL-00509 set|show cache_checkpoint_interval [seconds] [server_list] :set|show the server's cache checkpoint interval

Cause: Control program help text.

Action: No action required.

NNL-00510 Adds a data record to an existing name

Cause: Control program help text.

Action: No action required.

NNL-00511 Shows or sets the server's system query authority requirements

Cause: Control program help text.

Action: No action required.

NNL-00512 Shows or sets the server's auto-refresh expiration period

Cause: Control program help text.

Action: No action required.

NNL-00513 Shows or sets the server's auto-refresh failure retry interval

Cause: Control program help text.

Action: No action required.

NNL-00514 Creates a new name with a default TTL

Cause: Control program help text.

Action: No action required.

NNL-00515 Deletes a name and its data

Cause: Control program help text.

Action: No action required.

NNL-00516 Displays complete server status

Cause: Control program help text.

Action: No action required.

NNL-00517 Insert-replaces a data item under an existing name

Cause: Control program help text.

Action: No action required.

NNL-00518 Shows or sets the maximum number of times a server can reforward a request

Cause: Control program help text.

Action: No action required.

NNL-00519 Shows, enables, or disables modification request processing

Cause: Control program help text.

Action: No action required.

NNL-00520 Changes an existing name's TTL

Cause: Control program help text.

Action: No action required.

NNL-00521 Shows or sets the server's system query forwarding requirements

Cause: Control program help text.

Action: No action required.

NNL-00522 Removes a data item from a name by value or by type

Cause: Control program help text.

Action: No action required.

NNL-00523 Renames an existing name

Cause: Control program help text.

Action: No action required.

NNL-00524 Replaces a data item with another data item

Cause: Control program help text.

Action: No action required.

NNL-00525 Shows or sets the server's default-forwarding status

Cause: Control program help text.

Action: No action required.

NNL-00526 Starts a server using a non-standard executable and optional arguments

Cause: Control program help text.

Action: No action required.

NNL-00527 Shows, sets, or cancels the time when the server next checkpoints its cache

Cause: Control program help text.

Action: No action required.

NNL-00528 [set] password password : set the password for subsequent calls

Cause: Control program help text.

Action: No action required.

NNL-00529 set|show default_domain [domain_name] : set|show the current default domain

Cause: Control program help text.

Action: No action required.

NNL-00530 quit|exit : exit the names control program

Cause: Control program help text.

Action: No action required.

NNL-00531 flush_name name :removes a name from caches along a route to an authoritative server

Cause: Control program help text.

Action: No action required.

NNL-00532 set|show forwarding_available [on|off] [server_list] :enable, disable or show server request forwarding

Cause: Control program help text.

Action: No action required.

NNL-00533 ping [server_list] : ping one or more Names servers

Cause: Control program help text.

Action: No action required.

NNL-00534 query name [type] : query for a desired name and RR type

Cause: Control program help text.

Action: No action required.

NNL-00535 reload [server_list] : reload server cache data if there are changes

Cause: Control program help text.

Action: No action required.

NNL-00536 set|show requests_enabled [on|off] [server_list] :enable, disable or show server request processing

Cause: Control program help text.

Action: No action required.

NNL-00537 set|show server [server_name] : set|show the currently managed server

Cause: Control program help text.

Action: No action required.

NNL-00538 stop|shutdown [server_list] : stop one or more Names servers

Cause: Control program help text.

Action: No action required.

NNL-00539 start|startup [args] : start the Names server with optional arguments

Cause: Control program help text.

Action: No action required.

NNL-00540 [show] status [server_list] : display server status summary

Cause: Control program help text.

Action: No action required.

NNL-00541 set|show trace_level [level] [server_list] :set|show the server's tracing level

Cause: Control program help text.

Action: No action required.

NNL-00542 restart [server_list] : restart one or more Names servers

Cause: Control program help text.

Action: No action required.

NNL-00543 [show] version [server_list] :show the name and version of one or more Names servers

Cause: Control program help text.

Action: No action required.

NNL-00544 Displays operations statistics

Cause: Control program help text.

Action: No action required.

NNL-00545 Displays query request statistics

Cause: Control program help text.

Action: No action required.

NNL-00546 Displays delete request statistics

Cause: Control program help text.

Action: No action required.

NNL-00547 Displays rename request statistics

Cause: Control program help text.

Action: No action required.

NNL-00548 Displays update request statistics

Cause: Control program help text.

Action: No action required.

NNL-00549 Displays stream usage statistics

Cause: Control program help text.

Action: No action required.

NNL-00550 flush [server_list] : flush one or more servers' cache(s)

Cause: Control program help text.

Action: No action required.

NNL-00551 Displays cache statistics

Cause: Control program help text.

Action: No action required.

NNL-00553 Displays forwarding statistics

Cause: Control program help text.

Action: No action required.

NNL-00555 Displays meta data statistics

Cause: Control program help text.

Action: No action required.

NNL-00556 set|show reset_stats_interval [seconds] [server_list] :set|show server statistic counter reset interval

Cause: Control program help text.

Action: No action required.

NNL-00557 Causes the controller to sleep for N seconds

Cause: Control program help text.

Action: No action required.

NNL-00558 set|show namesctl_trace_level : set|show the controller's tracing level

Cause: Control program help text.

Action: No action required.

NNL-00559 Shows, sets, or cancels the time for the next cache dump to the trace file

Cause: Control program help text.

Action: No action required.

NNL-00560 Shows or sets the server's request-processing delay

Cause: Control program help text.

Action: No action required.

NNL-00561 register name [-ttype] [-daddress] [-hhostname] [-llistener_name] :register an object with Oracle Names

Cause: Control program help text.

Action: No action required.

NNL-00562 unregister name [-daddress] [-llistener_name] :unregister an object with Oracle Names

Cause: Control program help text.

Action: No action required.

NNL-00563 timed_query [timestamp] : query all objects in the Names server's cache

Cause: Control program help text.

Action: No action required.

NNL-00565 set trace_file_name [filename] [server_list] :set|show the server's trace file name

Cause: Control program help text.

Action: No action required.

NNL-00566 set|show log_file_name [filename] [server_list] :set|show the log file name on one or more servers

Cause: Control program help text.

Action: No action required.

NNL-00567 reorder_ns [server_address] : Generate the enhanced discovery file

Cause: Control program help text.

Action: No action required.

NNL-00568 delegate_domain domain_name NS_name NS_Addr : Delegate the given domain to the given nameserver

Cause: Control program help text.

Action: No action required.

NNL-00569 domain_hint domain_name NS_name NS_Addr : Provide hint of a nameserver for a given domain

Cause: Control program help text.

Action: No action required.

NNL-00570 save_config [server_list] : saves server configuration to parameter file

Cause: Control program help text.

Action: No action required.

NNL-00571 set|show save_config_on_stop [on|off]

Cause: Control program help text.

Action: No action required.

NNL-00572 set|show save_config_interval [seconds] [server_list] : set time of next config save

Cause: Control program help text.

Action: No action required.

NNL-00573 load_tnsnames [file, ... ] : load tnsnames into ONames

Cause: Control program help text.

Action: No action required.

NNL-00574 dump_tnsnames [<file>]: dump ONames addresses into tnsnames file

Cause: Control program help text.

Action: No action required.

NNL-00575 list_objects: list all objects in a domain or subtree

Cause: Control program help text.

Action: No action required.

NNL-00576 list_delegated: list all delegated domains in the region or subtree

Cause: Control program help text.

Action: No action required.

NNL-00577, 00000, "list_domains: list authoritative domains in the region or subtree

Cause: Control program help text.

Action: No action required.

NNL-00578 dump_ldap: dump addresses in the domain or region to LDAP

Cause: Control program help text.

Action: No action required.

NNL-00579 _scan: find objects/records matching the given types

Cause: Control program help text.

Action: No action required.

NNL-00580 register_ns: <name server> <address> <domain>

Cause: Control program help text.

Action: No action required.

NNL-00581 unregister_ns: <name server> <domain>

Cause: Control program help text.

Action: No action required.

NNL-00582 dump_alias: dump aliases in the domain or region to LDAP

Cause: Control program help text.

Action: No action required.

NNL-00800 Query requests received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00801 Queries received, type ANY: number

Cause: Control program statistic description.

Action: No action required.

NNL-00802 Queries received, type ADDRESS: number

Cause: Control program statistic description.

Action: No action required.

NNL-00803 Queries received, type ALIAS: number

Cause: Control program statistic description.

Action: No action required.

NNL-00804 Queries received, type META-DATA: number

Cause: Control program statistic description.

Action: No action required.

NNL-00805 Queries received, type NAME-SERVER: number

Cause: Control program statistic description.

Action: No action required.

NNL-00806 Queries received, type RELATED-INFO: number

Cause: Control program statistic description.

Action: No action required.

NNL-00807 Queries received, type SOA: number

Cause: Control program statistic description.

Action: No action required.

NNL-00808 Queries received, all user-defined types: number

Cause: Control program statistic description.

Action: No action required.

NNL-00809 Queries received, multiple types: number

Cause: Control program statistic description.

Action: No action required.

NNL-00810 Queries received with no type: number

Cause: Control program statistic description.

Action: No action required.

NNL-00811 Fastest query processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00812 Slowest query processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00813 Average query processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00814 Total query processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00830 Delete requests received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00831 Deletes refused, name is not a leaf name: number

Cause: Control program statistic description.

Action: No action required.

NNL-00832 Deletes refused, name is a topology name: number

Cause: Control program statistic description.

Action: No action required.

NNL-00833 Fastest delete processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00834 Slowest delete processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00835 Average delete processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00836 Total delete processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00850 Rename requests received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00851 Renames refused, name is not a leaf name: number

Cause: Control program statistic description.

Action: No action required.

NNL-00852 Renames refused, name is a topology name: number

Cause: Control program statistic description.

Action: No action required.

NNL-00853 Renames refused, new name already exists: number

Cause: Control program statistic description.

Action: No action required.

NNL-00854 Fastest rename processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00855 Slowest rename processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00856 Average rename processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00857 Total rename processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00870 Update requests received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00871 Updates refused, name is a topology name: number

Cause: Control program statistic description.

Action: No action required.

NNL-00872 Updates refused, data is topology data: number

Cause: Control program statistic description.

Action: No action required.

NNL-00873 Fastest update processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00874 Slowest update processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00875 Average update processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00876 Total update processing time: string

Cause: Control program statistic description.

Action: No action required.

NNL-00890 Messages received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00891 Corrupted messages received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00892 Duplicate requests received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00893 Similar requests received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00894 Requests refused, permission denied: number

Cause: Control program statistic description.

Action: No action required.

NNL-00895 Requests refused, processing disabled: number

Cause: Control program statistic description.

Action: No action required.

NNL-00896 Requests refused, modifications disabled: number

Cause: Control program statistic description.

Action: No action required.

NNL-00897 Messages sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00898 Responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00899 OK responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00900 NO SUCH NAME responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00901 CONTENT ERROR responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00902 ALIAS LOOP responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00903 SERVER FAILURE responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00904 NAME EXISTS responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00905 NOT AUTHORITY responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00906 NOT A LEAF NAME responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00907 NOT ALLOWED responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00908 UNKNOWN TYPE responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00909 META VIOLATION responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00910 VERSION SKEW responses sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00911 Responses sent with invalid error code: number

Cause: Control program statistic description.

Action: No action required.

NNL-00912 Alias loops detected: number

Cause: Control program statistic description.

Action: No action required.

NNL-00913 Server-generated requests sent: number

Cause: Control program statistic description.

Action: No action required.

NNL-00914 Forwarding desired on server queries: string

Cause: Control program statistic description.

Action: No action required.

NNL-00915 Authority required on server queries: string

Cause: Control program statistic description.

Action: No action required.

NNL-00916 Modification requests enabled: string

Cause: Control program statistic description.

Action: No action required.

NNL-00917 Artificial request processing delay: string

Cause: Control program statistic description.

Action: No action required.

NNL-00918 Time until server restart: string

Cause: Control program statistic description.

Action: No action required.

NNL-00919 Time until server shutdown: string

Cause: Control program statistic description.

Action: No action required.

NNL-00920 Time until next config save: string

Cause: Control program statistic description.

Action: No action required.

NNL-00930 Requests refused, unknown data type: number

Cause: Control program statistic description.

Action: No action required.

NNL-00931 Requests refused, no cached meta-data: number

Cause: Control program statistic description.

Action: No action required.

NNL-00932 Requests refused, type syntax mismatch: number

Cause: Control program statistic description.

Action: No action required.

NNL-00933 Requests refused, OTHER-DATA violation: number

Cause: Control program statistic description.

Action: No action required.

NNL-00934 Requests refused, ALIAS-EXISTS violation: number

Cause: Control program statistic description.

Action: No action required.

NNL-00935 Requests refused, SINGLE-VALUE violation: number

Cause: Control program statistic description.

Action: No action required.

NNL-00936 Requests refused, DATA-EXISTS violation: number

Cause: Control program statistic description.

Action: No action required.

NNL-00950 Cache lookup requests: number

Cause: Control program statistic description.

Action: No action required.

NNL-00951 Names created on lookup: number

Cause: Control program statistic description.

Action: No action required.

NNL-00952 Cache lookup failures: number

Cause: Control program statistic description.

Action: No action required.

NNL-00953 Cache lookup exact matches: number

Cause: Control program statistic description.

Action: No action required.

NNL-00954 Hash tables created: number

Cause: Control program statistic description.

Action: No action required.

NNL-00955 Hash tables enlarged: number

Cause: Control program statistic description.

Action: No action required.

NNL-00956 Hash tables freed: number

Cause: Control program statistic description.

Action: No action required.

NNL-00957 Name nodes created: number

Cause: Control program statistic description.

Action: No action required.

NNL-00958 Name nodes freed: number

Cause: Control program statistic description.

Action: No action required.

NNL-00959 Time until cache dump to trace file: string

Cause: Control program statistic description.

Action: No action required.

NNL-00960 Time until cache flush: string

Cause: Control program statistic description.

Action: No action required.

NNL-00961 Cache checkpoints: number

Cause: Control program statistic description.

Action: No action required.

NNL-00962 Cache checkpoint failures: number

Cause: Control program statistic description.

Action: No action required.

NNL-00963 Timeouts, name TTL expired: number

Cause: Control program statistic description.

Action: No action required.

NNL-00970 System query index number: number

Cause: Control program statistic description.

Action: No action required.

NNL-00971 Query ID: number

Cause: Control program statistic description.

Action: No action required.

NNL-00972 Query next issued in: string

Cause: Control program statistic description.

Action: No action required.

NNL-00973 Query state: number

Cause: Control program statistic description.

Action: No action required.

NNL-00974 Name: string

Cause: Control program statistic description.

Action: No action required.

NNL-00975 Desired data type: string

Cause: Control program statistic description.

Action: No action required.

NNL-00980 Forwarding failures: number

Cause: Control program statistic description.

Action: No action required.

NNL-00981 Timeouts, server not responding: number

Cause: Control program statistic description.

Action: No action required.

NNL-00982 Not forwarded, no servers found: number

Cause: Control program statistic description.

Action: No action required.

NNL-00983 Name-to-hint translations: number

Cause: Control program statistic description.

Action: No action required.

NNL-00984 Name-to-hint translations failed: number

Cause: Control program statistic description.

Action: No action required.

NNL-00985 Requests reforwarded using referrals: number

Cause: Control program statistic description.

Action: No action required.

NNL-00986 Reforwarded requests expired: number

Cause: Control program statistic description.

Action: No action required.

NNL-00987 Authoritative answers when authority: number

Cause: Control program statistic description.

Action: No action required.

NNL-00988 Non-authoritative NACKs received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00989 Objects received with no TTL: number

Cause: Control program statistic description.

Action: No action required.

NNL-00990 DEFAULT-FORWARDERS-ONLY mode: string

Cause: Control program statistic description.

Action: No action required.

NNL-00991 Maximum number of reforwards per request: number

Cause: Control program statistic description.

Action: No action required.

NNL-00992 Auto-refresh failure retry interval: string

Cause: Control program statistic description.

Action: No action required.

NNL-00993 Auto-refresh failure retry expiration: string

Cause: Control program statistic description.

Action: No action required.

NNL-00994 Responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00995 Unmatched responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00996 OK responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00997 NO SUCH NAME responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00998 CONTENT ERROR responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-00999 ALIAS LOOP responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-01000 SERVER FAILURE responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-01001 NAME EXISTS responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-01002 NOT AUTHORITY responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-01003 NON LEAF responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-01004 NOT ALLOWED responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-01005 UNKNOWN TYPE responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-01006 META VIOLATION responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-01007 VERSION SKEW responses received: number

Cause: Control program statistic description.

Action: No action required.

NNL-01008 Outbound message contexts allocated: number

Cause: Control program statistic description.

Action: No action required.

NNL-01009 Outbound message contexts freed: number

Cause: Control program statistic description.

Action: No action required.

NNL-01010 Forwarding contexts allocated: number

Cause: Control program statistic description.

Action: No action required.

NNL-01011 Forwarding contexts freed: number

Cause: Control program statistic description.

Action: No action required.

NNL-01030 Domain index number: number

Cause: Control program statistic description.

Action: No action required.

NNL-01031 Name: string

Cause: Control program statistic description.

Action: No action required.

NNL-01032 Minimum TTL: string

Cause: Control program statistic description.

Action: No action required.

NNL-01040 Data streams opened by server: number

Cause: Control program statistic description.

Action: No action required.

NNL-01041 Data stream open failures: number

Cause: Control program statistic description.

Action: No action required.

NNL-01042 Data streams answered by server: number

Cause: Control program statistic description.

Action: No action required.

NNL-01043 Data stream answer failures: number

Cause: Control program statistic description.

Action: No action required.

NNL-01044 Errors reading data stream: number

Cause: Control program statistic description.

Action: No action required.

NNL-01045 Errors writing data stream: number

Cause: Control program statistic description.

Action: No action required.

NNL-01050 Version banner is "string"

Cause: Control program statistic description.

Action: No action required.

NNL-01051 Server name: string

Cause: Control program statistic description.

Action: No action required.

NNL-01052 Server has been running for: string

Cause: Control program statistic description.

Action: No action required.

NNL-01053 Request processing enabled: string

Cause: Control program statistic description.

Action: No action required.

NNL-01054 Request forwarding enabled: string

Cause: Control program statistic description.

Action: No action required.

NNL-01055 Requests received: number

Cause: Control program statistic description.

Action: No action required.

NNL-01056 Requests forwarded: number

Cause: Control program statistic description.

Action: No action required.

NNL-01057 Foreign data items cached: number

Cause: Control program statistic description.

Action: No action required.

NNL-01058 Region data next checked for reload in: string

Cause: Control program statistic description.

Action: No action required.

NNL-01059 Region data reload check failures: number

Cause: Control program statistic description.

Action: No action required.

NNL-01060 Cache next checkpointed in: string

Cause: Control program statistic description.

Action: No action required.

NNL-01061 Cache checkpoint interval: string

Cause: Control program statistic description.

Action: No action required.

NNL-01062 Cache checkpoint file name: string

Cause: Control program statistic description.

Action: No action required.

NNL-01063 Statistic counters next reset in: string

Cause: Control program statistic description.

Action: No action required.

NNL-01064 Statistic counter reset interval: string

Cause: Control program statistic description.

Action: No action required.

NNL-01065 Statistic counters next logged in: string

Cause: Control program statistic description.

Action: No action required.

NNL-01066 Statistic counter logging interval: string

Cause: Control program statistic description.

Action: No action required.

NNL-01067 Trace level: number

Cause: Control program statistic description.

Action: No action required.

NNL-01068 Trace file name: string

Cause: Control program statistic description.

Action: No action required.

NNL-01069 Log file name: string

Cause: Control program statistic description.

Action: No action required.

NNL-01070 System parameter file name: string

Cause: Control program statistic description.

Action: No action required.

NNL-01071 Command-line parameter file name: string

Cause: Control program statistic description.

Action: No action required.

NNL-01072 Administrative region name: string

Cause: Control program statistic description.

Action: No action required.

NNL-01073 Administrative region description: string

Cause: Control program statistic description.

Action: No action required.

NNL-01074 ApplTable Index: number

Cause: Control program statistic description.

Action: No action required.

NNL-01075 Contact string

Cause: Control program statistic description.

Action: No action required.

NNL-01076 Operational Status number

Cause: Control program statistic description.

Action: No action required.

NNL-01077 Save Config on Stop string

Cause: Control program statistic description.

Action: No action required.

NNL-01078 Access/Create File Error: string

Cause: Failed to access/create the named file or its backup File due to incorrect permissions.

Action: Provide correct access to the file.


Oracle Names Server Network Presentation Layer Messages (NPL)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

34
Oracle Names Server Network Presentation Layer Messages (NPL)

NPL-00000 normal, successful completion

Cause: An operation has completed normally, having met no exceptions.

Action: No action required.

NPL-00100 cannot initialize ASN.1 context

Cause: The ASN.1 program interface could not be initialized, probably because its error message file could not be found.

Action: Check that SQL*Net has been installed properly and that all message files are in their proper locations.

NPL-00101 uninitialized ASN.1 context

Cause: The ASN.1 program interface received an uninitialized ASN.1 handle.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00102 missing stream functions in ASN.1 context initialization

Cause: An internal function improperly attempted to initialize an ASN.1 handle.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00103 unusable ASN.1 context

Cause: The ASN.1 program interface received an unusable ASN.1 handle.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00300 maximum ASN.1 element nesting depth string exceeded on read

Cause: An ASN.1 construct is too complex for the program interface to read.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00301 maximum ASN.1 element nesting depth string exceeded on write

Cause: An ASN.1 construct is too complex for the program interface to write.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00302 ASN.1 type tag is greater than maximum of 16383

Cause: An internal function attempted to create an illegal ASN.1 construct.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00303 uninitialized ASN.1 class attribute

Cause: An internal function attempted to create an illegal ASN.1 construct.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00304 uninitialized ASN.1 tag attribute

Cause: An internal function attempted to create an illegal ASN.1 construct.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00305 unsupported ASN.1 "UNIV" type string

Cause: An internal function attempted to create an illegal ASN.1 construct.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00307 ASN.1 sequence has already been ended on write

Cause: An internal function attempted to end an ASN.1 construct prematurely.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00308 requested ASN.1 class string does not match received class string

Cause: An internal function requested an ASN.1 construct different from that received by the ASN.1 protocol engine.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00309 requested ASN.1 type tag string does not match received type tag string

Cause: An internal function requested an ASN.1 construct different from that received by the ASN.1 protocol engine.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00310 ASN.1 sequence has already been ended on read

Cause: An internal function attempted to finish reading an ASN.1 construct which has already been completely read.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services

NPL-00311 cannot end constructed ASN.1 encoding, string encoding octets unread

Cause: An internal function attempted to finish reading an ASN.1 construct prematurely.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00312 attempt to put ASN.1 "UNIV" type with illegal tag string

Cause: An internal function attempted to create an illegal ASN.1 construct.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00313 requested form string does not match actual form string

Cause: An internal function received an ASN.1 construct different from that expected.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00410 incoming ASN.1 value too large (string octets) to store locally

Cause: The ASN.1 protocol engine was unable to translate an ASN.1 construct to its host representation because the construct was too big.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00411 incoming ASN.1 NULL encoding has nonzero length of string

Cause: The ASN.1 protocol engine received a corrupted ASN.1 construct.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00412 incoming ASN.1 BOOLEAN encoding has incorrect length of string

Cause: The ASN.1 protocol engine received a corrupted ASN.1 construct.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00413 incoming ASN.1 encoding has length string, maximum allowed is string

Cause: The ASN.1 protocol engine received an ASN.1 construct too large for it to process.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00414 incoming ASN.1 type tag is greater than maximum of 16383

Cause: The ASN.1 protocol engine received an illegal ASN.1 construct.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00415 received unsupported ASN.1 INDEFINITE-LENGTH encoding

Cause: The ASN.1 protocol engine received an ASN.1 encoding which it could not process because its implementation does not support it.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00416 received illegal ASN.1 encoding length of string

Cause: The ASN.1 protocol engine received a corrupted ASN.1 construct.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00417 received ASN.1 length octet count greater than maximum of string

Cause: The ASN.1 protocol engine received an ASN.1 encoding which it could not process because its implementation does not support it.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00418 received malformed ASN.1 object identifier

Cause: The ASN.1 protocol engine received a corrupted ASN.1 construct.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00419 received ASN.1 object identifier with sub-identifier that is too large

Cause: The ASN.1 protocol engine received an ASN.1 encoding which it could not process because its implementation does not support it.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NPL-00420 received ASN.1 object identifier with more than 256 sub-identifiers

Cause: The ASN.1 protocol engine received an ASN.1 encoding which it could not process because its implementation does not support it.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.


External Naming Messages (NNF)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

35
External Naming Messages (NNF)

NNF-00000 normal, successful completion

Cause: An operation has completed normally, having met no exceptions.

Action: No action required.

NNF-00001 Not a TNS address

Cause: While asking to read an address, the name service returned a record which was not an address.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNF-00002 Invalid value passed to function call

Cause: An invalid value was passed to an interface function.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNF-00003 Naming adapter string does not exist

Cause: The requested name service adapter was not found in the current adapter table.

Action: Check the spelling of the adapter requested. Verify that the adapter runs on this platform, and the adapter is compiled into the adapter table linked into the executable.

NNF-00004 Operation not supported in string

Cause: The operation requested is not supported under this adapter.

Action: Verify that the operation being performed is not under restriction, such as writing to read-only name service. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNF-00005 Functionality not implemented

Cause: The operation requested is not supported in this implementation.

Action: If this is retrieved from a production release, contact Oracle Support Services. Otherwise, check the release notes as to the restrictions in this release.

NNF-00501 Shows or sets the current native naming adapter

Cause: Test program help text.

Action: No action required.

NNF-00502 Display the information retrieved by the last query

Cause: Test program help text.

Action: No action required.

NNF-00503 Shows or sets internal buffer sizes

Cause: Test program help text.

Action: No action required.

NNF-00504 Shows or sets the control flags for name service operations

Cause: Test program help text.

Action: No action required.

NNF-00505 Shows or sets the current data used for the next modify operation

Cause: Test program help text.

Action: No action required.

NNF-00506 Loads the addresses found in a TNSNAMES.ORA file into DCE CDS

Cause: Test program help text.

Action: No action required.

NNF-00507 Deletes a name and all its attributes

Cause: Test program help text.

Action: No action required.

NNF-00508 Shows or sets the current default domain

Cause: Test program help text.

Action: No action required.

NNF-00509 Loads addresses found in the given file into the current adapter

Cause: Test program help text.

Action: No action required.

NNF-00510 Modifies the contents of a name

Cause: Test program help text.

Action: No action required.

NNF-00511 Retrieves addresses associated with a name via the directory path

Cause: Test program help text.

Action: No action required.

NNF-00512 Qualifies an unqualified name as per the current adapter

Cause: Test program help text.

Action: No action required.

NNF-00513 Queries a name with the current adapter

Cause: Test program help text.

Action: No action required.

NNF-00514 Exits the program

Cause: Test program help text.

Action: No action required.

NNF-00515 Rename a name with the current adapter

Cause: Test program help text.

Action: No action required.

NNF-00516 Shows or sets the replace data used for the next modify operation

Cause: Test program help text.

Action: No action required.

NNF-00517 Verify that a name is valid with the current adapter

Cause: Test program help text.

Action: No action required.

NNF-00518 Shows or sets the search path used by show_entry

Cause: Test program help text.

Action: No action required.

NNF-00519 Show the contents of an entry (address, profile, etc.). For 8.1+ NNFG API.Usage: show_entry name type

Cause: Test program help text.

Action: No action required.

NNF-00520 Update entry (address, profile, etc.). For 8.1+ NNFG API.Usage: update_entry name <c,a,r,d> [type] {attr value}

Cause: Test program help text.

Action: No action required.

NNF-00521 Shows or sets the authentication info.Usage: set authinfo type {[param]}

Cause: Test program help text.

Action: No action required.

NNF-00531 Shows or sets internal address buffer size

Cause: Test program help text.

Action: No action required.

NNF-00532 Shows or sets internal name buffer size

Cause: Test program help text.

Action: No action required.

NNF-00533 Shows or sets internal cname buffer size

Cause: Test program help text.

Action: No action required.

NNF-00540 Failed to insert name: string

Cause: Failed to insert name into the native service.

Action: Verify that the name is not already in the native namespace and the appropriate access permissions are set for the namespace.

NNF-01001 ds_initialize: workspace initialization failed

Cause: The DCE workspace as set up by DS_INITIALIZE() failed to initialize.

Action: Verify that conditions necessary for a successful DS_INITIALIZE() call are present on this platform (for example, is there enough memory?). Check that there is not another workspace user in this program. For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNF-01002 DCE could not open configuration file

Cause: A DCE call returned an error that it could not access its configuration file.

Action: Check that the DCE configuration file for this platform is present and accessible. On UNIX, this file is DCE_CF.DB. Check if a simple call to DCE_CF_GET_CELL_NAME() succeeds.

NNF-01003 DCE could not find cell name

Cause: A DCE call returned an error that it could not find the cell name in its configuration file.

Action: Check that this machine has been configured for a DCE cell. Check that the DCE configuration file is not corrupted. On UNIX, this file is DCE_CF.DB. Check if a simple call to DCE_CF_GET_CELL_NAME() succeeds.

NNF-01004 DCE returned unspecified error string

Cause: A DCE call returned an status that was not in this implementation's list of possible status values for this DCE call.

Action: Verify that this platform's DCE release is not beyond those supported by this Oracle application. If the error persists, contact Oracle Support Services.

NNF-01005 Internal XOM class violation

Cause: A DCE XOM call returned statuses inconsistent with the class definitions in the DCE documentation.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNF-01006 Attribute string not available

Cause: An insertion call attempted to use an attribute which did not have a translation to a DCE attribute.

Action: Use another attribute, or insert the translation into DCE.

NNF-01007 DCE long strings are not supported

Cause: A query returned a object which has a XOM OM_S_LONG_STRING. The current implementation does not support such objects.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNF-01008 XDS attribute syntax string incorrect for Oracle Names syntax string

Cause: The syntax as specified in the XDS object is different than that which is expected for the given Oracle names syntax.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NNF-01009 Unknown DCE class

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01010 DCE problem code number does not match XDS class string

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01011 DCE reported OS error

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01012 DCE generic security failure

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01100 DS_C_COMMUNICATIONS_ERROR

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01101 DS_C_LIBRARY_ERROR

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01102 DS_C_NAME_ERROR (matched string)

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01103 DS_C_SECURITY_ERROR

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01104 DS_C_SERVICE_ERROR

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01105 DS_C_SYSTEM_ERROR

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01106 DS_C_UPDATE_ERROR

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01107 DS_C_ATTRIBUTE_PROBLEM

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01108 DS_C_ABANDON_FAILED

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01109 DS_C_ATTRIBUTE_ERROR (object name string)

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01110 Class unknown

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01500 Normal, successful xds call

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01501 ADMIN_LIMIT_EXCEEDED

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01502 AFFECTS_MULTIPLE_DSAS

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01503 ALIAS_DEREFERENCING_PROBLEM

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01504 ALIAS_PROBLEM

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01505 ATTRIBUTE_OR_VALUE_EXISTS

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01506 BAD_ARGUMENT

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01507 BAD_CLASS

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01508 BAD_CONTEXT

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01509 BAD_NAME

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01510 BAD_SESSION

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01511 BAD_WORKSPACE

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01512 BUSY

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01513 CANNOT_ABANDON

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01514 CHAINING_REQUIRED

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01515 COMMUNICATIONS_PROBLEM

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01516 CONSTRAINT_VIOLATION

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01517 DIT_ERROR

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01518 ENTRY_EXISTS

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01519 INAPPROP_AUTHENTICATION

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01520 INAPPROP_MATCHING

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01521 INSUFFICIENT_ACCESS_RIGHTS

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01522 INVALID_ATTRIBUTE_SYNTAX

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01523 INVALID_ATTRIBUTE_VALUE

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01524 INVALID_CREDENTIALS

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01525 INVALID_REF

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01526 INVALID_SIGNATURE

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01527 LOOP_DETECTED

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01528 MISCELLANEOUS

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01529 MISSING_TYPE

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01530 MIXED_SYNCHRONOUS

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01531 NAMING_VIOLATION

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01532 NO_INFO

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01533 NO_SUCH_ATTRIBUTE_OR_VALUE

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01534 NO_SUCH_OBJECT

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01535 NO_SUCH_OPERATION

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01536 NOT_ALLOWED_ON_NON_LEAF

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01537 NOT_ALLOWED_ON_RDN

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01538 NOT_SUPPORTED

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01539 OBJECT_CLASS_MOD_PROHIB

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01540 OBJECT_CLASS_VIOLATION

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01541 OUT_OF_SCOPE

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01542 PROTECTION_REQUIRED

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01543 TIME_LIMIT_EXCEEDED

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01544 TOO_LATE

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01545 TOO_MANY_OPERATIONS

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01546 TOO_MANY_SESSIONS

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01547 UNABLE_TO_PROCEED

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01548 UNAVAILABLE

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01549 UNAVAILABLE_CRIT_EXT

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01550 UNDEFINED_ATTRIBUTE_TYPE

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01551 UNWILLING_TO_PERFORM

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01590 XOM error while manipulating DS error object

Cause: A DCE XDS error occurred for an unknown XDS class.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing, and what the error code is. You can then use this information to look up the error in your DCE documentation.

NNF-01600 Normal, successful xom call

Cause: An operation has completed normally, having met no exceptions.

Action: No action required.

NNF-01601 ENCODING_INVALID

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01602 FUNCTION_DECLINED

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01603 FUNCTION_INTERRUPTED

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01604 MEMORY_INSUFFICIENT

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01605 NETWORK_ERROR

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01606 NO_SUCH_CLASS

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01607 NO_SUCH_EXCLUSION

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01608 NO_SUCH_MODIFICATION

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01609 NO_SUCH_OBJECT

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01610 NO_SUCH_RULES

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01611 NO_SUCH_SYNTAX

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01612 NO_SUCH_TYPE

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01613 NO_SUCH_WORKSPACE

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01614 NOT_AN_ENCODING

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01615 NOT_CONCRETE

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01616 NOT_PRESENT

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01617 NOT_PRIVATE

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01618 NOT_THE_SERVICES

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01619 PERMANENT_ERROR

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01620 POINTER_INVALID

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01621 SYSTEM_ERROR

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01622 TEMPORARY_ERROR

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01623 TOO_MANY_VALUES

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01624 VALUES_NOT_ADJACENT

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01625 WRONG_VALUE_LENGTH

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01626 WRONG_VALUE_MAKEUP

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01627 WRONG_VALUE_NUMBER

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01628 WRONG_VALUE_POSITION

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01629 WRONG_VALUE_SYNTAX

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01630 WRONG_VALUE_TYPE

Cause: A DCE XDS/XOM routine encountered an error.

Action: For further details, turn on tracing and re-execute the failing operation. The tracing should provide the details about which XDS/XOM routine is failing with the above error code. You can then use this information to look up the error in your DCE documentation.

NNF-01901 Name parameter string not found. No name resolved.

Cause: The TNS alias specified was not found in CDS.

Action: Use DCELOAD to insert the name and re-execute the operation. If the error persists, contact Oracle Support Services.

NNF-02001 NIS client error string: string

Cause: A call to an NIS (YP) function failed. This message contains the text of the NIS error code returned.

Action: Should only be visible when returned as part of another error. If the error persists, contact Oracle Support Services.

NNF-02002 NIS value does not conform to adapter schema: string

Cause: The values in the maps used by the NIS adapter must conform to a specific set of internal formatting rules. This value returned did not conform to those rules.

Action: Should not be visible, unless you are attempting to create your own maps. If the error persists, contact Oracle Support Services.

NNF-02003 Unknown NIS error code: string

Cause: An error code returned by a NIS (YP) function was not in the list expected by this program.

Action: Verify that the error is generated by the YP functions on this platform. Notify Oracle Support Services of the error.

NNF-02004 NIS map string does not exist

Cause: The requested attribute does not exist.

Action: For an unused attribute, no action is required, as this is the expected error. Otherwise, add the attribute and reload the NIS (YP) maps.

NNF-02005 NIS key string does not exist in map string

Cause: The requested name was not found.

Action: For an unused name, no action is required, as this is the expected error. Otherwise, add the name to the map and reload the NIS (YP) maps.

NNF-03002 Unknown BIND error code: string

Cause: The return code in the BIND (DNS) query response did not conform to those values listed in RFC 1035.

Action: Verify that the error is generated by the BIND functions on this platform. Notify Oracle Support Services of the error.

NNF-03003 Format error parsing server response

Cause: The query response packet returned from the BIND (DNS) API did not conform to the format listed in RFC 1035.

Action: Verify that the error is generated by the BIND functions on this platform. Notify Oracle Support Services of the error.

NNF-03004 DNS Class mismatch (string)

Cause: The query response packet returned a class different from the ones expected by the interface.

Action: Verify that the error is generated by the BIND functions on this platform. Notify Oracle Support Services of the error.

NNF-04000 File succesfully converted

Cause: The requested conversion is performed.

Action: Normal condition, no action necessary.

NNF-04001 Error converting input file

Cause: The input file contains lines that cannot be converted by the conversion program.

Action: Check that the syntax of the input file is correct.

NNF-04002 Outputfile already exists

Cause: An old output file already exists in the current directory.

Action: Remove the existing file, and restart the conversion tool.

NNF-04003 Entry in inputfile is too long

Cause: The MAKEDBM program limits entries in map files to 1017 characters. Therefore, the conversion tool will not process TNS addresses which are longer than 1017 characters.

Action: Shorten the offending entry.

NNF-04004 Invalid string in inputfile

Cause: The input file contains invalid lines.

Action: Check that the syntax of the input file is correct.

NNF-04005 Cannot open inputfile

Cause: The specified input file could not be found.

Action: Restart the conversion tool with the correct input file.

NNF-04006 Could not create outputfile

Cause: An output file could not be created in the current working directory.

Action: Change the permissions of the current directory and restart the conversion tool.

NNF-04007 Error reading input file

Cause: A problem while reading the input file. This could be caused by an unexpected end of file in the input file.

Action: Check that the file is intact and that the syntax of the input file is correct.

NNF-04008 Error writing outputfile

Cause: An error occurred while writing to the output file.

Action: Check available disk space. If the error persists, contact Oracle Support Services.

NNF-04009 Usage: tns2nis filename

Cause: The conversion tool was not invoked properly. The filename should either be TNSNAMES.ORA or NATIVE.ORA.

Action: Restart the conversion tool with the proper parameter.


Simple Network Management Protocol Messages (NMP)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

36
Simple Network Management Protocol Messages (NMP)

NMP-00000 normal, successful completion

Cause: An operation has completed normally, having met no exceptions.

Action: No action required.

NMP-00001 value too big

Cause: The SNMP program interface received a value too large for it to process. This error is usually displayed underneath an error which describes in more detail the value which caused the problem.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NMP-00002 no such SNMP variable name

Cause: An SNMP request was not processed because the one or more of the variable names in the request does not exist. This error is not normally visible to the user except in a trace file, where it is usually part of a "soft" error condition which is normal.

Action: The error may indicate that a managed server does not support an operation requested by its control program, perhaps because of version incompatibility. For further details, turn on tracing and re-execute the failing operation. If the error persists, and does not occur as part of a "soft" error condition as noted in the trace file, contact Oracle Support Services.

NMP-00003 bad SNMP variable value

Cause: The SNMP program interface received a variable value which has an unsupported data type. This error may occur if a standard SNMP network monitor is sending requests to an Oracle service through an SNMP-to-TNS gateway, and that service cannot understand the requests.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, and occurs when an Oracle control program sends requests to an Oracle service, contact Oracle Support Services.

NMP-00004 SNMP variable is read only

Cause: An attempt was made to change a variable value at a remote server, and that variable is read only. This error is usually displayed underneath an error which describes the problem in more detail.

Action: Read-only variables may never be modified.

NMP-00005 general SNMP error

Cause: An SNMP error occurred which did not fall under the heading of any other more specific error condition. This error may occur if a standard SNMP network monitor is sending requests to an Oracle service through an SNMP-to-TNS gateway, and that service cannot understand the requests.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, and occurs when an Oracle control program sends requests to an Oracle service, contact Oracle Support Services.

NMP-00006 uninitialized SNMP context

Cause: An internal function attempted to use an uninitialized SNMP handle.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.

NMP-00007 I/O failure

Cause: The SNMP program interface attempted to send or receive an SNMP request and was unable to do so because of a network failure of some sort. This error is usually displayed underneath an error which describes the problem in more detail. The problem typically occurs when a control program is attempting to communicate with a service and either that service has unexpectedly terminated or the network path between the control program and the service has been interrupted.

Action: Ensure that the management platform in question is sending SNMP requests with the correct version number. If the error persists, and occurs when an Oracle control program sends requests to an Oracle service, contact Oracle Support Services.

NMP-00008 SNMP message has incorrect version, version 0 is required

Cause: The SNMP program interface received a protocol request with an illegal version number. This error may occur if a standard SNMP network monitor is sending malformed requests to an Oracle service through an SNMP-to-TNS gateway.

Action: Ensure that the management platform in question is sending SNMP requests with the correct version number. If the error persists, and occurs when an Oracle control program sends requests to an Oracle service, contact Oracle Support Services.

NMP-00009 SNMP initialization failure

Cause: The SNMP program interface could not be initialized, either because its error message file could not be found, or because there is a malformed SNMP.COMMUNITIES parameter value in the parameter table.

Action: Check that SQL*Net has been installed properly and that all message files are in their proper locations. Turn on tracing and look for parameter table load errors.

NMP-00010 memory exhausted

Cause: The program interface has run out of memory.

Action: Add more memory or run fewer processes.

NMP-00011 internal SNMP program interface error

Cause: An internal error occurred inside the SNMP program interface. This error is usually displayed underneath an error which describes the problem in more detail. This message is not normally visible to the user.

Action: For further details, turn on tracing and re-execute the failing operation. If the error persists, contact Oracle Support Services.


Remote Operation Messages (NCR)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

37
Remote Operation Messages (NCR)

NCR-00001 NCR: Could not allocate memory

Cause: Insufficient swap space or system memory.

Action: Increase swap space or system memory.

NCR-00002 NCR: Invalid usage

Cause: Bad function parameter.

Action: Check function call.

NCR-00003 NCR: Initialization failure

Cause: Usually insufficient swap space or system memory.

Action: Increase swap space or system memory.

NCR-01003 NCRS: Read error.

Cause: Failed to read data from an input device.

Action: Check the input device driver return code for further information.

NCR-01004 NCRS: Write error.

Cause: Failed to write data to an output device.

Action: Check the output device driver return code for further information.

NCR-01005 NCRS: Failed to flush the output buffer.

Cause: Failed to write data in the output buffer to an output device.

Action: Check the output device driver return code for further information.

NCR-01006 NCRS: Data buffer overflow.

Cause: An attempt to read or write data outside of a given data buffer.

Action: Check data buffer size.

NCR-01007 NCRS: Operation is not supported in a given mode.

Cause: An attempt was made to perform an operation which is not supported for the current mode.

Action: See documentation for a list of work modes and supported operations.

NCR-01008 NCRS: Failed to obtain transport parameters.

Cause: Could not identify transport layer parameters.

Action: Check the transport layer return code for further information.

NCR-01009 NCRS: Record handling error.

Cause: Encountered an invalid record or an attempt to read beyond last record.

Action: See documentation for description of record handling methods.

NCR-01010 NCRS: Invalid network address length.

Cause: Network address size is set to 0.

Action: See documentation for valid network address sizes.

NCR-01011 NCRS: Send message failure.

Cause: Failed to send a message over network.

Action: Check the network interface return code for further information.

NCR-01012 NCRS: Receive message failure.

Cause: Failed to receive a network message.

Action: Check the network interface return code for further information.

NCR-01013 NCRS: Unvalid connection type.

Cause: Connection type is other than stream or message.

Action: See documentation for description of connection types.

NCR-01018 NCRS: Encryption failure.

Cause: Cannot do the encryption for the data.

Action: See the SNS documentation for more information.

NCR-01019 NCRS: Checksumming failure.

Cause: Can not add the checksumming for the data.

Action: See the SNS documentation for more information.

NCR-01020 NCRS: Operation would block.

Cause: An I/O operation returned with no data read/written because the transport connection is "non-blocking" and, to succeed, the operation would have needed to block.

Action: This is a soft error; retry the operation.

NCR-02003 NCRF: Invalid type passed to format interpreter.

Cause: The format interpreter was given a data type it did not recognize.

Action: Check the types returned to the interpreter from either the type callback routine or from the type context structure.

NCR-02004 NCRF: Invalid format interpreter type context

Cause: The format interpreter was given an invalid type context.

Action: This error usually happens due to an improperly described aggregate. For example, declaring NCRF_END_STRUCT_DATA_TYPE within a context, without a complementary NCRF_STRUCT_DATA_TYPE, is invalid.

NCR-02005 NCRF: Invalid session mode

Cause: The data format layer received a session mode other than GET,PUT or FREE.

Action: No action required.

NCR-02006 NCRF: Invalid floating point representation received

Cause: The data format layer received a floating point representation it did not recognize.

Action: Check incoming format descriptor for errors.

NCR-02007 NCRF: Invalid format descriptor received

Cause: The data format layer received an improperly formed format descriptor. Subsequent data could not be formatted.

Action: Check for data integrity on receipt from remote host.

NCR-02008 NCRF: Error within stream processing in format interpreter

Cause: An error occurred while the interpreter was processing an NCRF_STREAM_DATA_TYPE.

Action: Check for data integrity, or for stream existence.

NCR-02009 NCRF: Unable to open trace file

Cause: Failed to open tracing file.

Action: Make sure that this is a legal file name and that the user has write access.

NCR-03002 NCRO: Maximum number of contexts has been reached

Cause: An attempt to create either a call context or a service context has failed because all context slots are in use.

Action: Free context slots by destroying those contexts no longer required, or, reconfigure NCRO with more context slots.

NCR-03003 NCRO: Unexpected message

Cause: Message read from service connection is not of the expected type. This is an application error.

Action: Debug and fix the application.

NCR-03004 NCRO: Unknown message

Cause: Message read from service connection is of unknown type. This is an internal error.

Action: Contact Oracle Support Services.

NCR-03005 NCRO: Orphan message

Cause: Message read from service connection is for a call context that no longer exists. This is an application error.

Action: Debug and fix the application.

NCR-03006 NCRO: Invalid operation

Cause: Attempted operation over call context is invalid. For example, attempting to send IN arguments for a procedure which is defined to have none. This is an application error.

Action: Debug and fix the application.

NCR-03007 NCRO: Context is busy

Cause: Attempted operation failed because service/call context is busy performing a previous operation. This is an application error.

Action: Debug and fix the application.

NCR-03008 NCRO: Call rejected

Cause: An attempt to execute a remote procedure has failed because the server has rejected the procedure ID.

Action: If wrong procedure ID, send the correct one. If the wrong server was contacted, then contact the right one.

NCR-03009 NCRO: Protocol version mismatch

Cause: Client and server NCRO layers are at incompatible versions levels.

Action: Upgrade to latest NCRO version.

NCR-03010 NCRO: Transfer callback error

Cause: Application transfer callback function has returned a "FAILED" status.

Action: Debug the transfer callback function.

NCR-03012 NCRO: Invalid session mode

Cause: Attempted operation has failed because the session context is in an invalid state. This is an internal error.

Action: Contact Oracle Support Services.

NCR-03013 NCRO: Operation not supportd

Cause: Attempted operation is not supported on this service connection because it is incompatible with the NCRO version level of the remote application.

Action: Link remote application with latest NCR library.

NCR-03014 NCRO: Bad transport address

Cause: A service context cannot be created because the transport address descriptor (contained in the binding context) is invalid. This is an application error.

Action: Initialize the transport address descriptor correctly.

NCR-03015 NCRO: No transport address

Cause: A service context cannot be created because no transport address was provided (in the binding context) and the transport protocol uses datagrams. This is an application error.

Action: Provide a transport address.

NCR-03016 NCRO: Message has bad address

Cause: Message read from service connection has bad address information. This is an internal error.

Action: Contact Oracle Support Services.

NCR-03017 NCRO: Transport type RSLV not supported

Cause: Support for transport type RSLV has not been built.

Action: Re-compile the NCR library with NCR_USE_RSLV defined.

NCR-03018 NCRO: Failed to make RSLV connection

Cause: Failure to make RSLV connection usually means that the name resolution failed or the resolved TNS address is bad.

Action: Make sure that the name is in TNSNAMES.ORA and that it is set to the correct TNS address.

NCR-03019 NCRO: Unable to initialize thread support

Cause: Attempt to initialize the Core thread package has failed. This is an internal error.

Action: Contact Oracle Support Services.

NCR-03020 NCRO: Invalid call context

Cause: The call context is not an valid call context.

Action: Call context was destroyed, probably because the Break was received

NCR-03021 NCRO: Reset the in-band line

Cause: An Oracle partner is asking to reset the in-band line, after receiving a break.

Action: Reset the in-band line.

NCR-03022 NCRO: Cannot send the break

Cause: An error occurred when sending the break using the side-band channel.

Action: Read the documentation regarding to side-band break support issues.

NCR-03023 NCRO: Cannot receive the break

Cause: An error occurred when receiving the break using the side-band channel.

Action: Read the documentation regarding to side-band break support issues.

NCR-03024 NCRO: Transport type LIST not supported

Cause: Support for transport type LIST has not been built.

Action: Re-compile the NCR library with NCR_USE_LIST defined.

NCR-03025 NCRO: Failed to make LIST connection(s)

Cause: Failed to make LIST connection(s). This usually means one of the following:

  • Address list syntax error
  • Could not connect with supplied addresses

Action: Check address list syntax and make sure that there is a 'listener' process for each (or some) of the supplied addresses.

NCR-03026 NCRO: The result buffer has overflowed

Cause: The result buffer for holding the pickling result is too small.

Action: Enlarge the result buffer and try again.

NCR-03027 NCRO: No remote service session set up yet.

Cause: Sender-makes-right needs the remote FID.

Action: Set up the remote session before using the Send Make's Right option.

NCR-03028 NCRO: Partner refused request for sender-makes-right.

Cause: Sender-makes-right was requested by the current side, but was refused by the server.

Action: Check the server side to see why it refused SMR.

NCR-04002 NCRR: Invalid interface descriptor

Cause: An attempt to register an interface has failed because of an invalid interface descriptor.

Action: Check the interface descriptor passed into the NCRRRI_REGISTER_INTERFACE call.

NCR-04003 NCRR: Interface exists

Cause: An attempt to register an interface has failed because an interface already exists. This is an application error.

Action: Register a new interface, destroy the old one, or indicate that the old one must be replaced.

NCR-04004 NCRR: Invalid interface instance handle

Cause: A service registration API call failed because of an invalid instance handle. This is an application error.

Action: Debug and fix the application.

NCR-04005 NCRR: Invalid procedure handle

Cause: A procedure/object registration failed because of an invalid procedural handle. This is an application error.

Action: Debug and fix the application.

NCR-04006 NCRR: Invalid argument descriptor

Cause: A procedure registration failed because of an invalid argument descriptor. This is an application error.

Action: Debug and fix the application.

NCR-04007 NCRR: Invalid object handle

Cause: A service registration API call failed because of an invalid object handle, for example, one that does not exist. This is an application error.

Action: Debug and fix the application.

NCR-04008 NCRR: Procedure exists

Cause: An attempt to register a remote procedure failed because the procedure already exists in this interface. This is an application error.

Action: Register a new procedure, destroy the old one, or indicate that the old one must be replaced.

NCR-04009 NCRR: Object exists

Cause: An attempt to register an object failed because the object already exists in this interface. This is an application error.

Action: Register a new object, destroy the old one, or indicate that the old one must be replaced.

NCR-04010 NCRR: Unable to contact Oracle Names Server

Cause: Service export or import failed to contact Names Server.

Action: Ensure the Oracle Names configuration is correct. If still no success, turn on Names tracing and/or contact Oracle Support Services.

NCR-04011 NCRR: Oracle Names error

Cause: Service export or import failed during interaction with Names Server.

Action: Turn on Names tracing and/or contact Oracle Support Services.

NCR-04012 NCRR: Invalid address descriptor

Cause: An NCRREI_EXPORT_INTERFACE call failed because of an invalid address descriptor. This is an application error.

Action: Debug and fix the application.

NCR-04013 NCRR: Insufficient authorization

Cause: Attempted Names Server operation has failed because of insufficient authorization.

Action: Contact Oracle Support Services.

NCR-04014 NCRR: Invalid instance name

Cause: Service export or import failed because of an invalid instance name. This is an application error.

Action: Debug and fix the application.

NCR-04015 NCRR: Invalid interface name

Cause: Service export or import failed because of an invalid interface name. This is an application error.

Action: Debug and fix the application.

NCR-04016 NCRR: Last interface instance handle

Cause: The instance handle passed in is the last instance handle in the list. This is an informational message indicating that the end of the list has been reached.

Action: No action required.

NCR-04017 NCRR: Unable to find the interface instance handle

Cause: The instance handle corresponding to the instance name was not found. This is an application error.

Action: Debug and fix the application.

NCR-04018 NCRR: Unable to create the TNS address list

Cause: Unable to create the TNS address list from the interface instance list. This is an application error.

Action: Debug and fix the application.

NCR-04019 NCRR: Interface or instance name already exists

Cause: Service export failed because the name already exists with the name server. This is an application error.

Action: Debug and fix the application.

NCR-04020 NCRR: Interface or instance name does not exist

Cause: Service expunge/query failed because the name does not exist in the name server.

Action: Turn on Names tracing and/or contact Oracle Support Services.

NCR-04021 NCRR: Pickler errors

Cause: Service export/query failed because of pickler errors.

Action: Contact Oracle Support Services.

NCR-04022 NCRR: Invalid procedure descriptor

Cause: A procedure registration failed because of an invalid procedural descriptor. This is an application error.

Action: Debug and fix the application.

NCR-04023 NCRR: Invalid object descriptor

Cause: An object registration failed because of an invalid object descriptor. This is an application error.

Action: Debug and fix the application.


Network Security Messages (NZE)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

38
Network Security Messages (NZE)

NZE-28750 Unknown error occurred

Cause: Some Oracle Security Server error occurred of an unspecified type. This error should not be visible to applications.

Action: Contact Oracle Support Services.

NZE-28751 Memory allocation failed

Cause: The allocation of memory failed due to exhaustion of system memory.

Action: Terminate other processes to free up memory or add memory to the system.

NZE-28752 Failed to initialize data source

Cause: The initialization of a data source failed.

Action: Enable Oracle Net tracing to determine the exact cause of the error. Frequently, this error is caused by the exhaustion of system resources.

NZE-28753 Failed to terminate use of data source

Cause: The termination of the use of a data source failed.

Action: Enable Oracle Net tracing to determine the exact cause of the error. The error may be caused by the corruption of memory or disk, among other things.

NZE-28754 Storage of object failed

Cause: This is an internal error.

Action: No action required.

NZE-28755 object retrieval failed

Cause: Failure to retrieve subject information from a file or database.

Action: Check if the data source exists or check for the correct subject information.

NZE-28756 Callback failed to allocate memory

Cause: A function supplied by the caller failed to allocate memory.

Action: This error could be due to system memory exhaustion.

NZE-28757 Attempted to allocate 0 bytes of memory

Cause: No more memory.

Action: This error could be due to system memory exhaustion.

NZE-28758 Memory release failed

Cause: The release of memory fragment failed. This may be caused by corruption of memory either within the application or the Oracle Security Server library.

Action: Enable Oracle Net tracing to determine the reason why the operation failed.

NZE-28759 Failed to open file

Cause: The opening of the specified file failed.

Action: Enable Oracle Net tracing to determine the name of the file that could not be opened and the reason.

NZE-28760 List creation failed

Cause: This is an internal error.

Action: No action required.

NZE-28761 Failed to create element

Cause: This is an internal error.

Action: No action required.

NZE-28762 Failed to add element

Cause: This is an internal error.

Action: No action required.

NZE-28763 Invalid parameter type

Cause: Possible error in parameter in SQLNET.ORA.

Action: Check the SQLNET.ORA file for this parameter value.

NZE-28764 Configuration parameter retrieval failed

Cause: The retrieval of a configuration parameter failed.

Action: Supply the needed configuration parameter.

NZE-28765 Data method list does not exist

Cause: This is an internal error.

Action: No action required.

NZE-28766 Failed to terminate use of data source

Cause: An error occurred when attempting to end use of a data source. This could be due to a system error.

Action: Enable tracing to see what the exact error is.

NZE-28767 Invalid version number

Cause: Version number of the file is incorrect.

NZE-28768 Bad magic number

Cause: An invalid magic number was specified in a data file.

Action: This could be due to disk corruption or some other process overwriting the file. Enable tracing to determine what the exact error is.

NZE-28769 Specified method does not exist

Cause: The data access method specified in the configuration file is not supported.

Action: Specify a supported method. Consult the Oracle Security Server documentation to determine the supported types.

NZE-28770 Data source already initialized

Cause: The caller attempted to initialize a data source which was already initialized.

Action: This is a programming error. An application should not attempt to initialize a data source more than once.

NZE-28771 Data source not yet initialized

Cause: The caller attempted to use a data source which had not been initialized yet. This is a programming error. The application must always initialize the data source.

Action: Correct the error.

NZE-28772 Invalid file ID

Cause: This is an internal error.

Action: No action required.

NZE-28773 Write of magic and version numbers failed

Cause: The write of both the magic and version numbers failed.

Action: This error usually occurs because disk space has been exhausted.

NZE-28774 Write of file to disk failed

Cause: The output of a file failed.

Action: This error usually occurs because disk space has been exhausted.

NZE-28775 Close of file failed

Cause: The close of a file used by a data access method failed.

Action: This error usually indicates an error such as memory corruption or a system error. Enable tracing and examine the trace file to see what the exact error.

NZE-28776 Output buffer supplied is too small

Cause: The data to be returned by a function is too large for the supplied buffer.

Action: Call the routine again with a larger buffer.

NZE-28777 Binding creation failed

Cause: The creation of a binding for use in the parsing of a parameter value failed. This error can be caused by the parameter value being in an incorrect format, for example, a right parenthesis was not supplied where expected, or the exhaustion of system memory.

Action: Make sure that the parameter is specified in the correct format. If the format is correct, free up system memory by terminating processes or add more memory.

NZE-28778 Parameter not specified in proper format

Cause: The configuration parameter was specified in the proper format.

Action: Consult the Oracle Security Server documentation for a description of the proper format for this parameter.

NZE-28779 No data access method specified in parameter

Cause: No method for data access was specified in the parameter value.

Action: Specify a parameter method. Consult the Oracle Security Server documentation for the supported data access methods for this data type.

NZE-28780 Invalid method specified by parameter

Cause: The data access method specified by the parameter value is not supported.

Action: Specify a data access method. Consult the Oracle Security Server documentation for the supported data access methods for this data type.

NZE-28781 no method data specified in parameter

Cause: No data was specified in the parameter for use with the specified access method.

Action: Consult the Oracle Security Server documentation for the data that must be specified for the access method.

NZE-28782 Data source not allocated

Cause: No memory was allocated for a data source.

Action: The application should call in the data source initialization function.

NZE-28783 Invalid parameter

Cause: No match for parameter name in the configuration file.

Action: Check your SQLNET.ORA file for the parameter.

NZE-28784 File name translation failed

Cause: The translation of a file name from Oracle format to native format failed.

Action: Specify a correct name. Consult your Oracle documentation for the correct file name format.

NZE-28785 Parameter does not exist

Cause: A configuration parameter does not exist in a parameter file.

Action: Supply the required parameter.

NZE-28786 Decryption of encrypted private key failed

Cause: Use of incorrect password for decryption.

Action: Type in the correct password.

NZE-28787 Encryption of private key failed

Cause: Possible error in parameter for MKWALLET in SQLNET.ORA.

Action: Check your SQLNET.ORA file. Also turn on tracing and check the MKTOKEN.TRC file for other errors.

NZE-28788 Invalid information provided by the user or unknown error

Cause: Incorrect input by the user in response to a prompt or an unknown error.

Action: Provide the correct input or enable tracing and check the trace file for errors.

NZE-28789 Name type not found

Cause: This is an internal error.

Action: No action required.

NZE-28790 NLS string open failed

Cause: The opening of a string for use by the NLS subsystem failed.

Action: Enable Oracle Net tracing to determine the exact error.

NZE-28791 Certificate verification failed

Cause: Verification of the certificate supplied by the user failed.

Action: Enable Oracle Net tracing to determine the exact error.

NZE-28792 PL/SQL operation failed

Cause: A PL/SQL operation attempted by the Oracle Security Server failed. This is an internal error.

Action: Enable Oracle Net and try the operation again. Contact Oracle Support Services for assistance.

NZE-28793 Variable bind failed

Cause: This is an internal error.

Action: No action required.

NZE-28794 Attribute initialization data type failed

Cause: The initialization of the attribute data type failed.

Action: Enable tracing to determine the exact error. This error may be caused by the exhaustion of system resources.

NZE-28795 Attribute data type termination failed

Cause: The termination of the use of the attribute data type subsystem failed.

Action: Enable Oracle Net tracing to determine the exact error.

NZE-28796 Unsupported access method

Cause: The method specified to access data is not supported.

Action: Use a supported access method.

NZE-28797 Invalid data type

Cause: The type specified for a key is not supported.

Action: Correct the key type.

NZE-28798 Number of sub-keys to bind does not match that in key

Cause: The number of keys passed by the application to bind does not match the number used to create the key. This is an internal programming exception.

Action: Contact Oracle Support Services.

NZE-28799 Failed to allocate shared memory

Cause: The allocation of shared memory for use in operations involving the shared server failed.

Action: Enable Oracle Net tracing to determine the exact error. This error is probably caused by the exhaustion of the memory heap supplied by the Oracle server.

NZE-28800 Open failed

Cause: Failed to open the data source (file or database).

Action: Enable Oracle Net tracing to determine the exact error.

NZE-28801 Invalid object type

Cause: This is an internal error.

Action: No action required.

NZE-28802 Invalid mode specified

Cause: Mode or data source specified in configuration file is incorrect.

Action: Check the SQLNET.ORA file for method parameter. Else enable Oracle Net tracing to determine the exact error.

NZE-28803 Input/output operation failed

Cause: Failed to access a data source (file or database).

Action: Enable Oracle Net tracing to determine the exact error.

NZE-28804 Close failed

Cause: Failed to close the data source (file or database).

Action: Enable Oracle Net tracing to determine the exact error.

NZE-28805 Retrieve failed

Cause: Failed to retrieve information from the data source (file or database).

Action: Enable Oracle Net tracing to determine the exact error.

NZE-28806 Store failed

Cause: Failed to write to the data source (file or database).

Action: Enable Oracle Net tracing to determine the exact error.

NZE-28807 Update failed

Cause: Failed to update a data source (file or database).

Action: Enable Oracle Net tracing to determine the exact error.

NZE-28808 Retrieval of method information failed

Cause: Failed to retrieve method (file/database) information.

Action: Check the SQLNET.ORA file for method configuration parameters. Else enable Oracle Net tracing to determine the exact error.

NZE-28809 Deletion failed

Cause: Failed to delete information from data source.

Action: Enable Oracle Net tracing to determine the exact error.

NZE-28810 Creation failed

Cause: Failed to create a key descriptor.

Action: Enable Oracle Net tracing to determine the exact error.

NZE-28811 Invalid access descriptor

Cause: This is an internal error.

Action: No action required.

NZE-28812 Record operation failed

Cause: This is an internal error.

Action: No action required.

NZE-28813 Invalid record type

Cause: This is an internal error.

Action: No action required.

NZE-28814 Conversion of number in Oracle format to native failed

Cause: The conversion of a number which was specified in Oracle format to native format failed. This is an internal programming exception.

Action: Enable Oracle Net tracing and attempt to reproduce the problem. Contact Oracle Support Services and supply the trace file.

NZE-28815 Conversion of native number to Oracle format failed

Cause: The conversion of a number which was specified in native format to Oracle portable format failed. This is an internal programming exception.

Action: Enable Oracle Net tracing and attempt to reproduce the problem. Contact Oracle Support Services and supply the trace file.

NZE-28816 No password provided

Cause: A required password was not passed to a PL/SQL function. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28817 PL/SQL function returned an error

Cause: A PL/SQL function returned an error unexpectedly. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28818 no package context provided

Cause: The context that holds the state of the security package was not passed to a function or procedure that was expecting it. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28819 no distinguished name provided

Cause: The user's distinguished name was not provided to a PL/SQL function or procedure. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28820 state not provided

Cause: The state of either a signature or decryption/encryption was not passed to a PL/SQL function or procedure. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28821 no input buffer provided

Cause: A PL/SQL function or procedure was not passed an expected buffer. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28822 no seed

Cause: No seed was specified to the PL/SQL seed initialization function. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28823 number of bytes not specified

Cause: The number of random bytes to generate was not specified to the PL/SQL random number generator. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28824 invalid encryption/decryption/signature state

Cause: An invalid state was passed to a PL/SQL encryption, decryption or signature procedure or function.

Action: Specify a correct state value.

NZE-28825 no cryptographic engine function

Cause: No function was specified for the cryptographic engine. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28826 invalid cryptographic engine function

Cause: An incorrect cryptographic engine function was passed to a PL/SQL function or procedure.

Action: Specify a correct engine function.

NZE-28827 invalid cipher type

Cause: An incorrect cipher type was passed to a PL/SQL function or procedure.

Action: Specify a correct cipher type.

NZE-28828 invalid identity type

Cause: An incorrect identity type was passed to a PL/SQL function or procedure.

Action: Specify a correct identity type.

NZE-28829 no cipher type specified

Cause: No cipher type was passed to a PL/SQL function or procedure. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28830 no identity type specified

Cause: No identity type was passed to a PL/SQL function or procedure. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28831 no data unit format

Cause: No data unit format was passed to a PL/SQL function or procedure. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28832 invalid data unit format

Cause: An incorrect data unit format was passed to a PL/SQL function or procedure.

Action: Specify a data unit format.

NZE-28833 not enough info provided

Cause: Not enough info (usually parameters) provided to a PL/SQL function. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28834 buffer too small

Cause: Buffer provided by PL/SQL to a Oracle Security Server toolkit function is too small for the data to be returned. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28835 identity descriptor not present or too small

Cause: An identity descriptor passed to a PL/SQL function or descriptor was not provided or does not have the correct size. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28836 wallet not open

Cause: The wallet to be used has not been opened yet.

Action: Call the function that opens the wallet.

NZE-28837 no wallet descriptor

Cause: No wallet descriptor was specified to a PL/SQL function or procedure. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28838 no identity descriptor

Cause: No identity descriptor was specified to a PL/SQL function or procedure. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28839 no persona descriptor

Cause: No persona descriptor was specified to a PL/SQL function or procedure. This is an internal error.

Action: Contact Oracle Support Services.

NZE-28840 wallet already open

Cause: An attempt was made to open a wallet that had already been opened. This is a programming error. A wallet should only be opened once.

Action: Correct the error.

NZE-28841 operation not supported

Cause: An attempt was made to perform an operation that is not supported. This is a programming error.

Action: Correct the error.

NZE-28854 memory allocation failure

Cause: The allocation of memory failed due to exhaustion of system memory.

Action: Terminate other processes to free up memory or add memory to the system.

NZE-28855 unsupported SSL operation

Cause: An unsupported operation was attempted, for example, an unknown cipher specification or an incorrect version.

Action: Specify a correct value.

NZE-28856 overflow error

Cause: A buffer overflowed during the SSL handshake.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28857 unknown SSL error

Cause: An unknown SSL error occurred.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28858 SSL protocol error

Cause: An error occurred during the SSL handshake between two processes.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28859 SSL negotiation failure

Cause: An error occurred during the negotiation done between two processes as part of the SSL protocol. This error will occur if the two sides to the connection do not support a common cipher suite or if the SSL versions on both sides are incompatible.

Action: Configure each process so they support a common cipher suite and compatible versions and then attempt the connection again.

NZE-28860 fatal SSL error

Cause: An error occurred during the SSL connection.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28861 SSL connection would block

Cause: This error is informational only. It should never be communicated to the user.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28862 SSL connection failed

Cause: This error can occur when one side of the connection fails for one reason or another. For example, the process might have been terminated.

Action: Attempt the connection again.

NZE-28863 SSL session not found

Cause: This error is informational only. It indicates that a specified session does not exist.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28864 SSL connection closed gracefully

Cause: This error is informational only. It indicates that the connection closed without error.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28865 SSL connection closed

Cause: The SSL connection closed because of an error in the underlying transport or because the destination process unexpectedly quit.

Action: Enable tracing and attempt the connection again. The trace output should indicate how the failure occurred.

NZE-28866 invalid certificate encoding

Cause: The presented certificate had a field that could not be recognized.

Action: Verify that the certificate is correct. If it is, enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28867 integer value is too big

Cause: The certificate presented had an integer field whose value was too large.

Action: Verify that the certificate is correct. If it is, enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28868 certificate chain check failed

Cause: The check of the certificate list presented by the remote process failed. This could be caused by a number of problems including:

  1. The expiration of one of the certificates.
  2. A certificate authority in a certificate was not recognized as a trust point.
  3. The signature in a certificate could not be verified.

Action: Make sure that:

  1. All of the certificates installed in your wallet are current.
  2. All of the necessary certificates are loaded into your wallet.
  3. All of the certificates have valid signatures.

NZE-28869 certificate expired

Cause: The certificate being used to authenticate a client or server has expired.

Action: Obtain a certificate which has not expired and attempt the connection again.

NZE-28870 name comparison failed

Cause: A comparison between the names contained within two certificates failed.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28871 certificate chain is incomplete

Cause: The certificate chain presented was not incomplete. In other words, the chain did not end with a self-signed root certificate.

Action: Make sure that the certificate specified as the root is self-signed.

NZE-28872, 00000, "invalid certificate format

Cause: The certificate presented by the other process does not conform to the X.509v3 standard.

Action: Obtain a certificate that conforms to the standard and attempt the connection again.

NZE-28873 invalid parameter

Cause: A function was presented with a null parameter.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28874 SSL: I/O closed - override goodbye kiss

Cause: This error is informational only. It indicates that a specified session does not exist.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28875 SSL: use server-gated crypto suites

Cause: This error is used as a internal status indicator and not really an error.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28876 Internet Explorer SGC Error

Cause: An error occurred when processing a certificate sent from Microsoft Internet Explorer.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28879 no protocol side set

Cause: An application attempted to provide credentials to an SSL connection but had not previously stated whether the process was a client or server.

Action: This error is not normally visible to the user. Enable tracing and attempt the connection again. If the error persists, contact Oracle Support Services.

NZE-28884 invalid cipher suite

Cause: An application attempted to convert a cipher suite to a string representation but the value did not correspond to a known cipher suite.

Action: Specify a correct value for the cipher suite. If, however, this error is returned by the Oracle Net SSL protocol adapter, it should be reported to Oracle Support Services as this error should not be returned by the adapter.

NZE-28890 Entrust Login Failed

Cause: An application's attempt to login to Entrust Profile failed. This could be caused by a number of problems including:

  1. Entrust Admin/Authority is not online.
  2. Invalid password for Entrust profile specified.
  3. Invalid path to Entrust profile specified.
  4. Invalid Entrust initialization file specified.
  5. Entrust Server Login program not executed (server-side only).

Action: Make sure that:

  1. Entrust Authority is online.
  2. Password for Entrust profile is specified correctly.
  3. Path to Entrust profile is specified correctly.
  4. A valid Entrust initialization file is provided.
  5. Entrust Server Login program is run before the database startup.

For more information, enable tracing and the trace output should indicate the exact Entrust failure codes.

NZE-29002 SSL Transport detected invalid or obsolete server certificate

Cause: Client detects mismatched Distinguished Name from server's certificate. Server's Distinguished Name does not reflect its SID or ServiceName.

Action: It may not be safe to connect to the server. Contact your administrator to update the server's certificate to reflect server's database name or service name.

NZE-29003 SSL Transport detected mismatched server certificate

Cause: Client detects mismatch from server's DN and the security configuration.

Action: It may not be safe to connect to the server. Contact your administrator to configure client TNS connect data to reflect the server Distinguished Name.

NZE-29228 the number of bytes for output could not be calculated

Cause: The cryptographic engine is confused about the algorithm.

Action: Check the parameters being used with the cryptographic functions.

NZE-29229 the magic number found in the header does not match expected

Cause: The input TDU has either been corrupted or it is not being used correctly.

Action: Check that the TDU is being used from the beginning. If possible, compare the size of the TDU upon generation to the size trying to be used.

NZE-29230 the header length is not sufficient for message header

Cause: The input TDU has either been corrupted or it is not being used correctly.

Action: Check that the TDU is being used from the beginning. If possible, compare the size of the TDU upon generation to the size trying to be used.

NZE-29231 the cryptographic engine failed to initialize

Cause: During initialization of the cryptographic engine, some failure occurred. This includes running out of memory and trying to seed the random number generator.

Action: Make sure the executable has been linked with compatible library versions, and that you are not running out of swap space.

NZE-29232 the cryptographic engine key initialization failed

Cause: During initialization of a key for cryptography, some failure occurred. This includes running out of memory and passing illegal arguments.

Action: Make sure the executable has been linked with compatible library versions, and that the correct parameters are being used for the cryptographic functions.

NZE-29233 the key object could not be encoded

Cause: The key object may be corrupted or may be an unsupported type.

Action: Check the key object being passed to the encoding routine.

NZE-29234 a key object was not extracted from encoding

Cause: The encoding may be corrupted or may not be a key object at all.

Action: Check the encoding and parameters passed to decoding routine.

NZE-29235 the key information could not be retrieved

Cause: The key may be corrupted or may be an unsupported type.

Action: Check the parameters being used with the cryptographic functions.

NZE-29236 the random number generator will not accept seed

Cause: The cryptographic engine may have run out of memory.

Action: Make sure the executable has been linked with compatible library versions.

NZE-29237 the cryptographic engine could not finish the algorithm

Cause: The cryptographic engine does not have enough information to correctly finish applying the algorithm.

Action: Check the parameters being used with the cryptographic functions.

NZE-29238 the cryptographic engine could not apply the algorithm

Cause: The cryptographic engine does not have enough information to correctly apply the algorithm.

Action: Check the parameters being used with the cryptographic functions.

NZE-29239 the cryptographic engine could not initialize the algorithm

Cause: The cryptographic engine does not have enough information to correctly initialize the algorithm.

Action: Check the parameters being used with the cryptographic functions.

NZE-29240 the cryptographic engine does not recognize the algorithm

Cause: The application is probably passing the wrong parameters.

Action: Check the parameters being used with the cryptographic functions.

NZE-29241 a buffer block needs to more space but its length is fixed

Cause: The application has pre-allocated an output buffer that is too short for the operation and has specified that the buffer should not grow as needed.

Action: Either pre-allocate a larger buffer or allow the toolkit to grow the output buffer as needed.

NZE-29242 the asymmetric key is too short to be used with the data.

Cause: An asymmetric key must be at least 11 bytes longer than the data it is being used to encrypt.

Action: Use an asymmetric key with more bits or break the data into smaller pieces.

NZE-29243 the toolkit does not recognize the type of key being used

Cause: The application is probably passing the wrong parameters.

Action: Check the parameters being used with the toolkit functions.

NZE-29245 the toolkit does not recognize the function being used

Cause: The application is probably passing the wrong parameters.

Action: Check the parameters being used with the toolkit functions.

NZE-29246 the toolkit could not parse the tdu

Cause: The TDU could be corrupted.

Action: Check the parameters being used with the toolkit functions.

NZE-29247 an unopen toolkit object was used before it was opened

Cause: Some toolkit objects must be opened before they can be used.

Action: Check the parameters being used with the toolkit functions.

NZE-29248 an unrecgonized WRL was used to open a wallet

Cause: WRLs have a specific set of types and must be formatted correctly.

Action: Check the parameters being used with the toolkit functions.

NZE-29249 an unrecognized state was passed to a cryptographic function

Cause: The application is probably passing the wrong parameters.

Action: Check the parameters being used with the toolkit functions.


Precompiler Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Part VIII
Precompiler Messages

This part contains the following chapters:

  • Chapter 39, "SQL*Module Messages (MOD)"
  • Chapter 40, "Object Type Translator Type File Messages (O2F)"
  • Chapter 41, "Object Type Translator Initialization Messages (O2I)"
  • Chapter 42, "Object Type Translator Unparser Messages (O2U)"
  • Chapter 43, "Pro*COBOL Messages (PCB)"
  • Chapter 44, "PCF FIPS Messages (PCF)"
  • Chapter 45, "Pro*C/C++ Messages (PCC)"
  • Chapter 46, "SQL Runtime Messages (SQL)"


SQL*Module Messages (MOD)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

39
SQL*Module Messages (MOD)

MOD-00001 unable to open file string

Cause: SQL*Module was unable to open a temporary file for internal use. There might be insufficient disk space, too many files, or read-only protection on the output directory.

Action: Check that there is enough disk space, that the limit for open files is set high enough (check with the system manager) and that protection on the directory allows opening a file for writing.

MOD-00002 invalid syntax at column number in line number of file string

Cause: There is a syntax error in the SQL statement or the statement is not properly terminated in the module file.

Action: Correct the syntax of the SQL statement. If the error occurred at the end of the input file, check that the last SQL statement is properly terminated.

MOD-00003 invalid SQL Identifier at column number in line number of file string

Cause: The symbol in a SQL descriptor is invalid.

Action: Check the statement syntax and spelling of the identifier and check that a reserved word was not accidentally used. If necessary, define the identifier in the declaration section of the module file.

MOD-00004 unsupported datatype in line number of file string

Cause: A host variable defined in the procedure definition of the module file has an unsupported datatype or has a scale or precision outside the supported range.

Action: Redefine the host variable using a supported datatype. Check that the scale and precision of a numeric variable are in the accepted range.

MOD-00005 invalid include file name at column number in line number of file string

MOD-00006 invalid host variable at column number in line number of file string

Cause: A host variable used in SQL statement was not defined in the procedure definition or has an unsupported datatype.

Action: Declare the host variable in the procedure definition of the module file, making sure it has one of the supported datatypes.

MOD-00007 unable to open a cursor at line number in file string

Cause: The syntax in the SQL statement is faulty. The module compiler was expecting a host variable, but found something else.

Action: Check the syntax and the spelling, then correct the SQL statement.

MOD-00008 unable to open include file "string" at line number in file string

MOD-00009 unable to open input file "string"

Cause: SQL*Module is not able to open the input file that was specified with the INAME option. This error can result from any of the following:

  • The file does not exist.
  • The file exists, but in a directory not on the path specified.
  • You do not have the permissions or access rights required to read the file.

Action: Check that the appropriate permission to read the file has been granted. Check that the name and directory hierarchy have been specified correctly. Rerun the compiler.

MOD-00010 unable to open listing file "string"

Cause: SQL*Module is not able to create the listing output file. This usually happens when write permissions do not exist on the current directory or on the directory specified for the LNAME option. It can also happen if the name or directory path is not legal or a directory on the path does not exist.

Action: Check the permissions on the specified path and file, or on the current directory if the LNAME option is not used.

MOD-00011 unable to open output file "string"

Cause: SQL*Module is not able to create an output file, such as the specification file or the output code file. This usually happens when write permissions on the current directory or on the directory specified for the ONAME or SNAME options do not exist. It can also happen if the name or directory path is not legal or a directory on the path does not exist.

Action: Check the permissions on the specified path and file, or on the current directory if the ONAME or SNAME options are not used.

MOD-00012 unable to parse statement at line number in file string

Cause: This is caused by a syntax error in the Module Language file. For example, if the SQL statement

SELECT ename INTO :name FORM emp WHERE ...

is in a module procedure, this message is raised. This message is not triggered by semantic errors. See MOD-00075.

Action: Correct the syntax error, then recompile.

MOD-00013 expected "string", but found "string" at line number in file string

Cause: The syntax in a SQL statement is faulty. The module compiler found an unexpected or illegal token.

Action: Check the syntax and the spelling, then correct the SQL statement.

MOD-00014 unable to obtain bind variables at line number in file string

Cause: The module compiler was unable to find information about an input host variable (bind variable) used in a SQL statement.

Action: Check that the input host variable is declared in the procedure definition of the module file and used properly in the SQL statement.

MOD-00015 Oracle Error: string

Cause: This message results from an internal error: an invalid value for the mode of a bind variable.

Action: Contact Oracle Support Services.

MOD-00016 out of space - unable to allocate number bytes

Cause: SQL*Module could not allocate enough memory to run or to perform some required action.

Action: Try killing some non-essential processes, then rerunning SQL*Module. On some operating systems, there may be a quota for the amount of memory the processes can allocate. See the system administrator. If necessary, increase memory for the machine.

MOD-00017 unable to connect to Oracle with "string:string/string". Oracle error number: number

Cause: The database connection or the username or the password that was specified was not correct. This message can result from an incorrect command-line specification or an incorrect specification of the username and/or password in the module AUTHORIZATION clause.

Action: Look up the error number in the ORA message chapters of this manual for more specific information on the failure. Correct the identifiers, then rerun SQL*Module.

MOD-00018 unable to disconnect from Oracle

Cause: An Oracle connection error occurred while the module was trying to log off, probably because Oracle has been shut down.

Action: Check that Oracle is available, then retry.

MOD-00019 indicator variable "string" has wrong type or length at line number in file string

Cause: An indicator variable was not declared in the procedure definition as a 2-byte integer. Indicator variables must be defined as 2-byte integers.

Action: Redefine the indicator variable as a 2-byte integer.

MOD-00020 option "string" not legal as EXEC ORACLE OPTION

Cause: A precompiler option was specified inline in an EXEC ORACLE statement. Some options can be specified only on the command line. For example, INAME cannot be specified inline.

Action: Respecify the precompiler option on the command line, instead of in an EXEC ORACLE statement. To see an online display of the precompiler options, enter the precompiler command (with no options) at the operating-system prompt.

MOD-00021 ambiguous option "string"

Cause: The name of module command line option is used ambiguously.

Action: Respecify the full option name or an unambiguous abbreviation. To see an online display of module options, enter the MODADA command (with no options) at the operating system prompt.

MOD-00022 invalid operand "string" for option "string"

Cause: The value specified for the module option is incorrect. That value is not appropriate for this module option.

Action: Respecify the option value appropriately.

MOD-00023 invalid option "string"

Cause: The module compiler found an invalid module option name. Some possible causes follow:

  • The option name is misspelled.
  • The specified option does not exist.
  • The equal sign (=) between the option name and value is missing or has space around it.

Action: Check that the option exists and that its name is spelled correctly. To see an online display of the module options, enter the MODADA command (with no options) at the operating system prompt. Also check there is an equal sign between the option name and value.

MOD-00024 missing operand for option "string"

Cause: No value was specified for a module option. Either the value is missing or there is space around the equal sign.

Action: Check that a value for each option has been specified and there is no space around the equal sign.

MOD-00025 unable to create access module

Cause: The module was unable to open the output file specified in the module option.

Action: Check that the search path to the file is correct, that sufficient privileges have been granted to access the file, and it is not locked by another user. Also check there is enough disk space and that the limit for open files is set high enough (check with the system manager).

MOD-00026 no host language specified

Cause: The host language name is not specified in the LANGUAGE clause of the module file.

Action: Specify Ada (case is not significant) for the LANGUAGE clause.

MOD-00027 no input file name specified

Cause: The STORE_PACKAGE=YES option was entered, but an input file using the INAME option was not specified.

Action: Use INAME on the command line.

MOD-00028 array host variable is illegal in this SQL statement

Cause: A host variable used in a SQL statement was not declared in the procedure definition or has an unsupported datatype.

Action: Declare the host variable in the procedure definition, making sure it has one of the supported datatypes.

MOD-00029 VARCHAR string at number is larger than 65533 line number in file string

Cause: The declared size of VARCHAR host variable exceeds the module limit of 65533 bytes.

Action: Check the declarations, making sure the size of each VARCHAR variable does not exceed the limit of 65533 bytes.

MOD-00030 both CURSOR and STATEMENT have AT clauses at line number of file string.

Cause: Two AT clauses, one in a DECLARE STATEMENT statement, the other in a DECLARE CURSOR statement, pertain to the same SQL statement. The AT clause may be specified with either DECLARE STATEMENT or DECLARE CURSOR, but not with both.

Action: Remove the AT clause from one of the statements.

MOD-00031 error at line number, column number. PLS-number: string

Cause: The module found an error in a SQL statement or PL/SQL block.

Action: Refer to the indicated PL/SQL error message to correct the SQL statement or PL/SQL block.

MOD-00032 illegal syntax, PL/SQL not allowed! Found statement at line number of file string.

Cause: The module found a PL/SQL block when expecting a SQL statement.

Action: Rewrite the statement using SQL syntax by replacing PL/SQL block.

MOD-00033 Ireclen exceeded. Line number in file string truncated.

Cause: While reading the input file, the module found a line longer than IRECLEN.

Action: Either shorten the input line or specify a larger IRECLEN value on the command line.

MOD-00034 insufficient authorization to run string

Cause: The authorization or license to run the MODADA compiler has expired.

Action: Call Oracle Support Services for assistance.

MOD-00035 your string authorization is about to expire

Cause: The authorization or license to run the MODADA compiler is about to expire.

Action: Call Oracle Support Services for assistance.

MOD-00036 internal programming exception

Cause: An internal error occurred.

Action: Contact Oracle Support Services.

MOD-00037 end of SQL statement or PL/SQL block not found

Cause: The module expected to find a statement terminator at the end of SQL statement or PL/SQL block but found something else. This can happen if tabs were embedded in the module file.

Action: If tabs are embedded in the source code, replace them with spaces. Check the statement syntax and check that each SQL statement has a terminator.

MOD-00038 module name required when output language is Ada

Cause: A MODULE clause was not specified in the module source file, or a name for the module was not provided.

Action: Specify the module name in the module file.

MOD-00039 unable to open specifications file "string"

Cause: SQL*Module is not able to create the specifications (header) output file. This usually happens when write permissions on the current directory or on the directory specified for the SNAME option do not exist. It can also happen if the name or directory path is not legal, a directory on the path does not exist, or the disk or file system is full.

Action: Check the permissions on the specified path and file or on the current directory if the SNAME options are not used. Check that the disk or file system is not full.

MOD-00040 no output language specified; compilation aborted

Cause: The LANGUAGE clause is not specified in the module source file.

Action: Specify the language clause in the module file.

MOD-00041 ANSI violation at line number, column number: string

Cause: FIPS=YES was specified, and part of the module code was not compliant with the ANSI SQL92 Entry Level standard.

Action: Specify FIPS=NO (the default) or correct the code.

MOD-00042 cannot declare cursor "string" more than once

Cause: The cursor named in the message was declared more than once in the module file.

Action: Check that each cursor names (not just in the module file, but in the entire application) is unique.

MOD-00043 cannot declare procedure "string" more than once

Cause: A procedure named X was declared more than once in the module file.

Action: Check that each procedure name (not just in the module file, but in the entire application) is unique.

MOD-00044 cannot declare parameter "string" in procedure "string" more than once

Cause: In the procedure named in the message, a parameter was declared with a name that duplicates another parameter's name.

Action: Check that each parameter name in a procedure is unique.

MOD-00045 a character string length of number is illegal

Cause: For a char[n] host variable, a length of less than 2 characters was specified. The length must be at least 2 characters.

Action: Correct the declaration so that it specifies the length of at least 2 characters.

MOD-00046 cursor "string" has not been declared

Cause: In the module file, an OPEN, FETCH, or CLOSE was attempted on a cursor that had not yet been declared.

Action: Insert an appropriate cursor declaration in the module file. Remember that cursors must be declared in the file before they are acted upon.

MOD-00047 an open statement already exists for cursor "string"

Cause: More than one procedure in this module contains an OPEN command on the named cursor.

Action: Remove one of the OPEN commands, as there is no need for redundancy.

MOD-00048 cursor "string" was never opened.

Cause: No OPEN command exists in the module for the cursor named in this message.

Action: Add an OPEN command or remove the cursor if it is not needed.

MOD-00049 unable to initialize PL/SQL

Cause: This message usually results when SQL*Module cannot connect to the database, using the username and password mentioned either in the module's AUTHORIZATION clause or on the command line with the USERID option.

Action: If connection is made using Net8, check that a listener process is running and that the service name specified in the AUTHORIZATION clause or on the command line is in the TNSNAMES.ORA file. If the connect parameters are correct and this problem persists, contact Oracle Support Services.

MOD-00050 formal parameter "string" is not used in procedure "string"

Cause: A formal parameter was declared in a procedure, but never used.

Action: Remove the parameter declaration or use it in the procedure.

MOD-00051 invalid reference mode specified for parameter "string"

Cause: The mode of this parameter is illegal. The mode should be one of IN, OUT, or IN OUT.

Action: Correct the reference mode to one of IN, OUT, or IN OUT appropriately.

MOD-00052 STORE_PACKAGE database does not match connection host

Cause: The module was not able to store the package in the database.

MOD-00053 duplicate macro definition does not match

MOD-00054 reference "string" is not a valid cursor reference

Cause: An attempt was made to OPEN a cursor that had not been declared.

Action: Declare the cursor or remove the erroneous reference to it.

MOD-00055 preprocessor directive is not understood

MOD-00056 array bound must be greater than 0

Cause: Incorrect array index was specified.

Cause: Respecify the array index by making sure that the index must be greater than 0.

MOD-00057 cannot find macro's argument list

MOD-00058 wrong number of arguments in macro invocation

MOD-00059 INTO variable "string" is not listed as a formal parameter

Cause: The target of an INTO clause in a SELECT statement is not a parameter of the procedure.

Action: Declare the parameter using the correct datatype in the procedure's parameter list.

MOD-00060 PL/SQL error in compiling package specification

Cause: A semantic error occurred in the PL/SQL parse phase when running SQL*Module.

Action: Check that all database objects are valid. To get more information, rerun SQL*Module with OUTPUT=PACKAGE, and check the output PL/SQL code specification file (it has a .pks extension). See the PL/SQL User's Guide and Reference for more information.

MOD-00061 PL/SQL error in compiling package body

Cause: A semantic error occurred in the PL/SQL parse phase when running SQL*Module.

Action: Check that all database objects are valid. To get more information, rerun SQL*Module with OUTPUT=PACKAGE, and check the output PL/SQL code file (it has a .pkb extension). See the PL/SQL User's Guide and Reference for more information.

MOD-00062 host variable for indicator is not recognized

Cause: A host variable that was used as an indicator variable was not declared.

Action: Declare the host variable or, if possible, remove the indicator variable from the SQL statement.

MOD-00063 procedure string, parameter string: illegal interface type "string"

Cause: When attempting to generate an interface procedures (stubs) file, the WITH INTERFACE PROCEDURE clause in the referenced stored package or stored procedure contained a parameter having an illegal datatype.

Action: Correct the datatype. Datatypes in a WITH INTERFACE clause must be SQL datatypes, not PL/SQL datatypes.

MOD-00064 procedure string: extra parameter "string" in interface

Cause: An unused parameter was declared in the WITH INTERFACE clause of a stored package or a stored procedure.

Action: Correct the WITH INTERFACE clause in the package.

MOD-00065 interface definition missing for procedure string

Cause: An attempt was made to generate stubs for a package that does not contain a WITH INTERFACE clause for one or more procedures.

Action: Add the WITH INTERFACE clause to the package specification.

MOD-00066 unable to load package "string" from database

Cause: The package name that was specified using the PNAME option is not correct, or SQL*Module could not access the database schema required.

Action: Check that the specified package exists and has a valid status. Check the STATUS column of the USER_OBJECTS table for that schema to check that the package is valid.

MOD-00067 package name is required but not specified

Cause: The options and values RPC_GENERATE=YES and STORE_PACKAGE=YES were specified, but a package name using the PNAME option was not specified.

Action: Add the PNAME option.

MOD-00068 could not find or open system configuration file

Cause: This is a warning message. SQL*Module is not able to find the system configuration file or is not able to open the file. The location of the system configuration file is system specific. See your operating system-specific documentation for the location on your system.

Action: Check that the file exists and that read permission or the appropriate access rights are set for it. The file must exist to avoid this warning message; however, it can be empty.

MOD-00069 Oracle error number while attempting to store package

Cause: SQL*Module's attempt to store the package in the database failed.

Action: Look up the error number in this manual and correct the problem.

MOD-00070 procedure string interface is missing declaration for string

Cause: An indicator variable was specified in the WITH INTERFACE clause, but the associated main variable was not declared there.

Action: Modify the WITH INTERFACE clause. Either remove the indicator variable or declare a host variable for it.

MOD-00071 PNAME option is required but not set

Cause: The name of a package stored in the database was not mentioned. This is required to generate stubs out of stored packages.

Action: Specify the name of the package stored in the database.

MOD-00072 PNAME option is specified but not meaningful

Cause: The PNAME option was used when there was no need for it. The PNAME option is only required when you specify RPC_GENERATE, STORE_PACKAGE, or both.

Action: Correct the command line.

MOD-00073 INAME option is specified but not meaningful

Cause: The INAME option was used when it was not required. For example, INAME is not required when RPC_GENERATE=YES and the PNAME option are specified.

Action: Do not use the INAME option.

MOD-00074 ONAME option is specified but not meaningful

Cause: The ONAME option was used when it was not required. For example, the ONAME option is not required when RPC_GENERATE=NO, and STORE_PACKAGE=YES, or the OUTPUT values list does not contain the CODE value.

Action: Do not use the ONAME option.

MOD-00075 error at line number. PLS-number: string

Cause: A semantic error occurred in the PL/SQL parse phase when running SQL*Module.

Action: Check that all database objects are valid. To get more information, rerun SQL*Module with OUTPUT=PACKAGE, and check the output PL/SQL code file (it has a .pkb extension). See the PL/SQL User's Guide and Reference for more information.

MOD-00076 ANSI violation at line number. PLS-number: string

Cause: FIPS=YES was specified and part of the module code is not compliant with the ANSI SQL92 Entry Level standard.

Action: Specify FIPS=NO (the default) or correct the code.

MOD-00077 mandatory status parameter, such as SQLCODE or SQLSTATE,is missing

Cause: Include a status parameter -- SQLCODE, SQLSTATE, or both -- in every parameter definition.

Action: Include SQLCODE or SQLSTATE.

MOD-00078 must specify a user if generating stubs from stored package

Cause: Because no USERID was specified, SQL*Module cannot connect to the server to create stubs (an interface procedures file) from the stored package.

Action: Specify the service name (if not connecting to the default database), and the username and password. Do this either on the command line or in a configuration file.

MOD-00079 SQLCHECK must be SEMANTICS when RPC=yes

Cause: SQLCHECK=SYNTAX (or SQLCHECK=NONE) cannot be specified when creating a stubs file.

Action: Remove the SQLCHECK=SYNTAX or SQLCHECK=NONE specification from the command line or the configuration file.

MOD-00080 error extracting stored package source

Cause: OUTPUT=PACKAGE was requested on the command line or in a configuration file, and a package of the name specified does not exist in the schema or is marked as INVALID.

Action: Check that the named package exists and is valid.

MOD-00081 failed assertion

Cause: Some part of the input to SQL*Module caused an error or warning condition. This message always follows a specific error or warning message.

Action: No action required for this message. Correct the previous errors.

MOD-00082 [compiling package body...]

Cause: This is an informational message.

Action: No action is required.

MOD-00083 [package body compiled]

Cause: This is an informational message.

Action: No action is required.

MOD-00084 [compiling package specification...]

Cause: This is an informational message.

Action: No action is required.

MOD-00085 [package specification compiled]

Cause: This is an informational message.

Action: No action is required.

MOD-00086 error: could not install username; aborted...

Cause: The server rejected a username.

Action: If the username is valid, contact Oracle Support Services.

MOD-00087 [storing package in dB]

Cause: This is an informational message.

Action: No action is required.

MOD-00088 feature not implemented yet

Cause: SQL*Module encountered a SQL statement that it can compile, but that uses a feature not yet implemented.

Action: Contact Oracle Languages Product Management.

MOD-00089 in procedure string: string

Cause: This is an informational message.

Action: No action is required.

MOD-00090 in cursor string : string

Cause: This is an informational message.

Action: No action is required.

MOD-00091 [generating RPC calls to stored package...]

Cause: This is an informational message.

Action: No action is required.

MOD-00092 [RPC calls generated]

Cause: This is an informational message.

Action: No action is required.

MOD-00093 SNAME option is specified but not meaningful

Cause: The SNAME option was used when it was not required. For example, no SNAME option is required if the values list of the OUTPUT option does not include the value SPECIFICATION.

Action: Do not use the SNAME option.

MOD-00094 extension in PNAME option is specified but not meaningful

Cause: A filename extension was included in the value of a PNAME option. Packages are database objects, not files.

Action: Remove the extension.

MOD-00095 datatype "string" is not valid for this host language.

Cause: A datatype was used that is not supported for the host language. For example, NUMERIC is not a supported datatype for Ada and C.

Action: Refer to your language-specific Precompiler Programmer's Guide for a list of the datatypes supported in each host language.

MOD-00096 LNAME option is specified but not meaningful

Cause: The OUTPUT option list does not contain the value LIST.

Action: Add LIST to the list of values of the OUTPUT option.

MOD-00097 with-interface must be specified for this host language

Cause: A PL/SQL package or function specification did not have a WITH INTERFACE clause. Currently, MODADA requires the WITH INTERFACE clause to be present in order to create calls to a PL/SQL function or package.

Action: Rewrite PL/SQL package or function specification to include a WITH INTERFACE clause. Alternatively, write a PL/SQL package or function specification which has a WITH INTERFACE clause and have it call the original PL/SQL package.

MOD-00098 with-interface may only be defaulted when bind=late

Cause: A Command line option, "bind=early" was specified while creating calls to a PL/SQL package or function without a WITH INTERFACE clause.

Action: Change the command line option to "bind=late", or include a WITH INTERFACE clause in the PL/SQL specification (see error 97 action).

MOD-00099 type string is invalid when storing a module, store=yes

Cause: The module contained a type for which there is currently no equivalent PL/SQL type; it may not be stored in the database.

Action: Set the command line option to STORE=NO or move the procedures containing the offending type to another module and compile that module with STORE=NO.


Object Type Translator Type File Messages (O2F)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

40
Object Type Translator Type File Messages (O2F)

O2F-00301 Error attempting to read from the INTYPE file

Cause: An operating system error occurred while attempting to read from the INTYPE file.

Action: Try opening the INTYPE file with an editor to make sure you are able to access the file.

O2F-00302 Unable to allocate memory

Cause: OTT was unable to allocate memory.

Action: Contact Oracle Support Services.

O2F-00303 No INTYPE file was specified

Cause: The required option INTYPE was not specified.

Action: Set the INTYPE option to the name of the file containing names of types for OTT to translate. The INTYPE option may be specified on the command line or in a CONFIG file.

O2F-00304 Invalid filename for the INTYPE file

Cause: The file name specified for the INTYPE file is not syntactically correct.

Action: Make sure you spelled the file name of the INTYPE file correctly.

O2F-00305 Error opening the INTYPE file for reading

Cause: An operating system error occurred while attempting to open the INTYPE file.

Action: Make sure you spelled the file name of the INTYPE file correctly. Try opening the INTYPE file with an editor to make sure you have access to the file.

O2F-00306 Unable to close the INTYPE file

Cause: An operating system error occurred while attempting to close the INTYPE file.

Action: Try opening the INTYPE file with an editor to make sure you are able to access the file.

O2F-00307 Unable to read the INTYPE file

Cause: The first token of the INTYPE file was not read. Either an operating system error occurred while attempting to read from the INTYPE file, or all lines of the INTYPE file are blank lines or comment lines.

Action: Try opening the INTYPE file with an editor to make sure you are able to access the file. Make sure the INTYPE file contains one or more type specifications.

O2F-00308 No type specifications were seen in the INTYPE file

Cause: Either there are no type specifications in the INTYPE file, or the first type specification could not be read due to a previously reported error.

Action: Fix any previously reported errors. Make sure there are one or more type specifications in the INTYPE file.

O2F-00309 Name of user-defined type is illegal or missing

Cause: The name of a user-defined type is expected following the keyword TYPE at the beginning of a type specification. No legal type name was seen.

Action: Make sure that the type specification is syntactically correct, and that the type name is spelled correctly.

O2F-00310 Illegal or missing identifier name

Cause: A legal C or C++ identifier was expected following AS, but was not seen.

Action: Use a legal C or C++ identifier, consisting of letters, digits, and underscores not beginning with a digit.

O2F-00311 Illegal or missing file name

Cause: A legal file name was expected, but was not seen.

Action: Make sure your TYPE file syntax is correct. Use a correct file name.

O2F-00312 Illegal or missing type version string

Cause: A type version name was expected, but was not seen.

Action: Make sure your TYPE file syntax is correct. Use a correct version name.

O2F-00313 Illegal or missing attribute name

Cause: An attribute name was expected in the INTYPE file, but was not seen.

Action: Make sure your TYPE file syntax is correct. Use a correct attribute name.

O2F-00314 AS expected but not seen in the INTYPE file

Cause: Incorrect syntax in the INTYPE file.

Action: Make sure your TYPE file syntax is correct.

O2F-00315 An attribute of a type is listed twice in a type specification

Cause: An attribute of a user-defined type is listed twice in a type specification in the INTYPE file. The second occurrence is ignored.

Action: Remove one of the two occurrences of the attribute.

O2F-00316 An unexpected token was seen at the end of a type specification

Cause: There is a syntax error in the INTYPE file.

Action: Check your documentation to make sure the type specifications in the INTYPE file are syntactically correct.

O2F-00317 Error opening the ERRTYPE file for writing

Cause: An operating system error occurred while attempting to open the ERRTYPE file for writing.

Action: Make sure you spelled the ERRTYPE file name correctly. Try creating or modifying the ERRTYPE file to make sure you have write access to the file.

O2F-00318 Error writing to the OUTTYPE file

Cause: An operating system error occurred when attempting to write to the OUTTYPE file.

Action: Make sure you have operating system permission to write to the file. Also, make sure disk space is available.

O2F-00319 No OUTTYPE file specified

Cause: The required option OUTTYPE was not specified.

Action: Set the OUTTYPE option to the name of the file to which the TYPE file produced by OTT should be written. The OUTTYPE option may be specified on the command line or in a CONFIG file.

O2F-00320 Invalid filename for the OUTTYPE file

Cause: The file name specified for the OUTTYPE file is not syntactically correct.

Action: Make sure you spelled the name of the OUTTYPE file correctly.

O2F-00321 Error opening the OUTTYPE file for writing

Cause: An operating system error occurred while attempting to open the OUTTYPE file.

Action: Make sure you spelled the name of the OUTTYPE file correctly. Make sure you have operating system permission to open the file.

O2F-00322 Unable to close the OUTTYPE file

Cause: An operating system error occurred while attempting to close the OUTTYPE file.

Action: Try opening the OUTTYPE file with an editor to make sure you are able to access the file.

O2F-00323 Internal error in OTT facility O2F

Cause: An internal OTT error occurred in the O2F component of OTT.

Action: Contact Oracle Support Services.

O2F-00324 Unable to convert from the database character set to the compiler character set

Cause: The name of a type, attribute, or method cannot be converted from the client character set in effect when OTT was invoked to the compiler character set (typically ASCII or EBCDIC).

Action: A name is translated first from the database character set to the client character set, and then from the client character set to the compiler character set. The client character set is specified in a platform-dependent manner. On UNIX platforms, the client character set is specified by setting the NLS_LANG environment variable. Use a client character set that can be translated to the compiler character set. The compiler character set itself is one such character set. Specify synonyms in the INTYPE file for any names of database objects that cannot be successfully translated to the client character set.

O2F-00325 None of the characters in a name were legal identifier characters

Cause: None of the characters in the name of a database entity could be translated to a character that may begin a C or C++ identifier, such as a letter or an underscore.

Action: Specify an explicit translation for the name in the INTYPE file.

O2F-00326 Some characters in this name were not legal identifier characters

Cause: One or more characters in the name of a database entity could not be translated to a character that may appear in a C or C++ identifier, such as a letter, an underscore, or a digit. The characters that could not be translated were replaced with underscores.

Action: Make sure that the name is spelled correctly, and that it is terminated by a blank, the end of a line, or an equals sign ("="). You may use the translated name with added underscores, or you may specify an explicit translation for the name in the INTYPE file.

O2F-00327 CASE option has an illegal value

Cause: The value given for the CASE option in the INTYPE file is not legal.

Action: Change the value given for the CASE option to one of the following legal values: SAME, LOWER, UPPER, or OPPOSITE.

O2F-00328 Illegal INITFUNC name

Cause: The function name given for the INITFUNC option in the INTYPE file is not a legal C or C++ identifier.

Action: Specify the name of the INITFUNC function as a legal C or C++ identifier. This name can be given in the INTYPE file, given on the command line, or derived from the INITFILE name.

O2F-00329 Type or option specification expected

Cause: A type or option specification was expected in the INTYPE file, but was not seen.

Action: Check the INTYPE file for syntax errors. Supply a type or option specification. A type specification begins with the word TYPE. An option specification begins with the word CASE, INITFILE, or INITFUNC.

O2F-00330 Name exceeds 265 bytes in length

Cause: A name seen in the INTYPE file exceeds 265 bytes in length.

Action: Choose a shorter name.

O2F-00331 A syntactically illegal name was seen in the INTYPE file

Cause: A syntax error occurred in a name used in the INTYPE file.

Action: If the name is quoted, make sure that the quotes are at the beginning and at the end of the name. If a period (which separates a schema name from a type name) appears, make sure that the schema name and the type name are both present.

O2F-00332 A database link may not appear in the name of a user-defined type

Cause: A database link was seen in the name of a user-defined type. This feature is not yet supported.

Action: Declare the user-defined type in the database to which OTT connects.

O2F-00333 An unexpected token appeared where a keyword was expected in the INTYPE file

Cause: A keyword such as TYPE was expected in the INTYPE file, but an incorrect or misspelled keyword was seen.

Action: Verify that your TYPE specification obeys the syntax described in your documentation. Verify that your keyword is spelled correctly.

O2F-00334 A user-defined type is listed more than once in the INTYPE file

Cause: The same name of a user-defined type appears in more than one type specification. The duplicate specifications of the type name will be ignored.

Action: Put all of the information about the type, including all type name and attribute name translations, in a single TYPE specification, and eliminate the duplicate TYPE specifications.

O2F-00335 Internal error in O2F component of OTT

Cause: A request was made to generate declarations for all the types in the database schema. An internal error occurred in the O2F component of OTT.

Action: List the types to be processed in an INTYPE file. Contact Oracle Support Services.

O2F-00336 Error reported by subsystem:

Cause: A request was made to generate declarations for all the types in a database schema. An error occurred in a subsystem when accessing the database.

Action: Examine the error message reported by the subsystem to determine its cause. List the types to be processed in an INTYPE file.

O2F-00337 Schema not found, or no types found in schema

Cause: A request was made to generate declarations for all the types in a database schema. Either the schema was not found, no user-declared types were found in the schema, or unable to connect to Oracle.

Action: Ensure that a login/password string was specified for OTT and that the Oracle database can be accessed with it. Ensure that the USER_TYPES table contains at least one row.

O2F-00338 Illegal or missing package name

Cause: A legal Java package name was expected following IN or PACKAGE or IN PACKAGE, but was not seen.

Action: Use a legal Java package name.

O2F-00339 CODE option has an illegal value

Cause: The value given for the CODE option in the INTYPE file is not legal.

Action: Change the value given for the CODE option to one of the following legal values: C, ANSI_C, KR_C, JAVA, NATIVE_JAVA, ORACLE_JAVA.

O2F-00340 Name was null

Cause: A name had a length of 0 characters.

Action: This error should never be reported to the user. Contact Oracle Support Services.

O2F-00341 An error occurred for which no message is available

Cause: The cause of this error was not reported.

Action: Contact Oracle Support Services.


Object Type Translator Initialization Messages (O2I)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

41
Object Type Translator Initialization Messages (O2I)

O2I-00101 Invalid value for the USERID parameter

Cause: The value supplied for the USERID parameter is not a legal username/password[@databasename] string.

Action: Set the USERID option to the correct username/password or username/password@database_name combination to use when connecting to the database. If you have an OPS$ account, you may instead omit the USERID option, in which case OTT will attempt to connect to the database using the userid OPS$username. The USERID option may be specified on the command line or in a CONFIG file.

O2I-00102 Unable to connect to Oracle

Cause: OTT could not connect to Oracle with the username, password, and, if applicable, database link that was supplied. Either the USERID option value was incorrect, or, if the USERID was not supplied, the userid OPS$username was not accepted.

Action: Check that the username and password are current and correct. Run another program that connects to Oracle to verify that you can connect using that username and password.

O2I-00103 Two file names refer to the same HFILE file in the INTYPE file

Cause: Two different file names have been used in the INTYPE file to refer to the same HFILE file, or different file names have been used to refer to the same HFILE file on the command line and in the INTYPE file.

Action: Consistently refer to each HFILE file using the same file name.

O2I-00110 Internal error in OTT component O2I

Cause: An internal OTT error occurred in the O2I component of OTT.

Action: Contact Oracle Support Services.

O2I-00111 Unable to allocate memory

Cause: OTT was unable to allocate memory.

Action: Contact Oracle Support Services.

O2I-00112 Unable to write to the HFILE file

Cause: An operating system error occurred when attempting to write to the HFILE file.

Action: Make sure you have operating system permission to write to the file. Also, make sure disk space is available.

O2I-00113 No HFILE specified

Cause: The HFILE file to which C declarations generated by OTT are written was not specified.

Action: Specify the global HFILE option on the command line or in a CONFIG file. You may choose a different HFILE for a particular type by specifying a different HFILE in the INTYPE file entry describing the type. If every INTYPE file entry specifies an HFILE, and if none of the types in the HFILE require declarations of types not mentioned there, the global HFILE option may be omitted. An INTYPE file generated by a previous invocation of OTT satisfies these conditions.

O2I-00114 Invalid HFILE file name

Cause: An HFILE file name was specified that is not syntactically correct.

Action: Make sure the HFILE file name is spelled correctly.

O2I-00115 Error opening the HFILE file

Cause: An operating system error occurred while attempting to open the HFILE file for writing.

Action: Make sure the HFILE file name is spelled correctly. Try creating or modifying the HFILE to make sure you have write access to the file.

O2I-00116 Unable to close the HFILE file

Cause: An operating system error occurred while attempting to close the HFILE file.

Action: Try creating or modifying the HFILE file to make sure you are able to access the file.

O2I-00117 Internal error: No message file for component O2U

Cause: The message file for the internal OTT component O2U was not found. OTT may not be correctly installed.

Action: Contact Oracle Support Services.

O2I-00118 This user-defined type was not found in the database

Cause: A user-defined type specified in the INTYPE file was not found in the database.

Action: Make sure the name of the type is spelled correctly. Make sure the type is actually declared in the database.

O2I-00119 Warning reported by subsystem:

Cause: A subsystem invoked by OTT reported a warning. This warning immediately follows the "Warning reported by subsystem" message.

Action: Examine the warning reported by the subsystem to determine its cause.

O2I-00120 Error reported by subsystem:

Cause: A subsystem invoked by OTT reported an error. This error immediately follows the "Error reported by subsystem" message.

Action: Examine the error message reported by the subsystem to determine its cause.

O2I-00121 No value was specified for the CODE option

Cause: The required CODE option was not specified on the command line or in a configuration file.

Action: Specify the CODE option on the command line or in a configuration file. Currently, the following values of the CODE option are supported: CODE=ANSI_C, CODE=KR_C, CODE=C.

O2I-00122 Invalid filename for the INITFILE file

Cause: The file name specified for the INITFILE file is not syntactically correct.

Action: Make sure the file name of the INITFILE file is spelled correctly.

O2I-00123 Unable to close the INITFILE file

Cause: An operating system error occurred while attempting to close the INITFILE file.

Action: Try opening the INITFILE file with an editor to make sure the file can be accessed.

O2I-00124 Error opening the INITFILE file for writing

Cause: An operating system error occurred while attempting to open the INITFILE file for writing.

Action: Make sure the INITFILE file name is spelled correctly. Try creating or modifying the INITFILE file to make sure you have write access to the file.

O2I-00125 Error writing to the INITFILE file

Cause: An operating system error occurred when attempting to write to the INITFILE file.

Action: Make sure you have operating system permission to write to the file. Also, make sure disk space is available.

O2I-00126 You must specify an INTYPE file with SCHEMA_NAMES=FROM_INTYPE

Cause: The option SCHEMA_NAMES=FROM_INTYPE requests that schema names be written to the OUTTYPE file as given in the INTYPE file. However, an INTYPE file was not specified.

Action: Either supply the name of an INTYPE file, or specify the SCHEMA_NAMES option ALWAYS or IF_NEEDED.

O2I-00127 Illegal INITFUNC name

Cause: The name of the INITFUNC function is not a legal C or C++ identifier.

Action: Specify the name of the INITFUNC function as a legal C or C++ identifier. This name may be given in the INTYPE file, given on the command line, or derived from the INITFILE name.

O2I-00128 Unable to write to the Java file

Cause: An operating system error occurred when attempting to write to a Java source file.

Action: Make sure you have operating system permission to write to the file. Also, make sure disk space is available.

O2I-00129 No Java file specified

Cause: The file to which Java declarations generated by OTT are written was not specified.

Action: This message should never be seen, because Java files are named after the classes declared within them. Contact Oracle Support Services.

O2I-00130 Invalid Java file name

Cause: A Java file name was specified that is not syntactically correct.

Action: Make sure the Java file name is spelled correctly.

O2I-00131 Error opening a Java file

Cause: An operating system error occurred while attempting to open a Java file for writing.

Action: Make sure the file name is spelled correctly. Try creating or modifying the file to make sure you have write access to the file.

O2I-00132 Unable to close a Java file

Cause: An operating system error occurred while attempting to close a Java file.

Action: Try creating or modifying the Java file to make sure you are able to access the file.

O2I-00133 An error occurred for which no message is available

Cause: The cause of this error was not reported.

Action: Contact Oracle Support Services.


Object Type Translator Unparser Messages (O2U)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

42
Object Type Translator Unparser Messages (O2U)

O2U-00200 Internal error in OTT facility O2U

Cause: An internal OTT error occurred in the O2U facility of OTT.

Action: Contact Oracle Support Services.

O2U-00201 Illegal arguments to function o2upt()

Cause: Illegal arguments were passed to the function O2UPT(). This is an internal error that should not be encountered by an end user.

Action: Contact Oracle Support Services.

O2U-00202 Invalid data passed to function

Cause: Arguments with incorrect values were passed to the function O2UPT(). This is an internal error that should not be encountered by an end user.

Action: Contact Oracle Support Services.

O2U-00203 Type to be declared must be an object type or a named collection type

Cause: OTT was asked to generate code for a type it does not support. When generating Java code, OTT will only generate code for object types. When generating C declarations, OTT will only generate declarations for object types and named collection types.

Action: You are probably asking OTT to declare a built-in type, or, if you are generating Java code, a named collection type. Do not ask OTT to generate a declaration for this type.

O2U-00204 Unable to convert from the database character set to the compiler character set

Cause: The name of a type, attribute, or method cannot be converted from the client character set in effect when OTT was invoked to the compiler character set (typically ASCII or EBCDIC).

Action: A name is translated first from the database character set to the client character set, and then from the client character set to the compiler character set. The client character set is specified in a platform-dependent manner (On UNIX platforms, the client character set is specified by setting the NLS_LANG environment variable.) Use a client character set that includes the character set of the INTYPE file and can be translated to the compiler character set. The database character set is one such character set. Specify synonyms in the INTYPE file for any names of database objects that cannot be successfully translated to the client character set.

O2U-00205 None of the characters in a type name were legal identifier characters

Cause: None of the characters in the name of a user-defined type could be translated to a character that can begin a C or C++ identifier, such as a letter or an underscore.

Action: Specify an explicit translation for the type name in the INTYPE file.

O2U-00206 Some characters in a type name were not legal identifier characters

Cause: One or more characters in the name of a user-define type could not be translated to a character that can appear in a C or C++ identifier, such as a letter, an underscore, or a digit. The characters that could not be translated were replaced with underscores.

Action: Specify an explicit translation for the type name in the INTYPE file, or just use the translated type name with added underscores.

O2U-00207 None of the characters in an attribute name were legal identifier characters

Cause: None of the characters in the name of an attribute of a type could be translated to a character that can begin a C or C++ identifier, such as a letter or an underscore. To find the affected attribute, look in the declaration generated for this type for data member names that are obviously incorrect.

Action: Specify an explicit translation for the attribute name in the INTYPE file.

O2U-00208 One or more characters in an attribute name were not legal identifier characters

Cause: If an attribute name contains one or more characters that can not be translated to a legal C or C++ identifier character, the characters that can not be translated are replaced with underscores. To find the affected attribute or attributes, look in the declaration generated for this type for data member names that have extra underscores not present in the original attribute names.

Action: Specify explicit translations for the affected attribute names in the INTYPE file, or just use the translated attribute names with added underscores.

O2U-00209 Attribute or function name to be translated was not found

Cause: This name, for which a translation was requested, is not the name of an attribute or a function of the current type.

Action: Make sure that the name is spelled correctly, and is the name of an attribute or function defined in the current type.

O2U-00210 Unable to allocate memory

Cause: OTT was unable to allocate memory.

Action: Contact Oracle Support Services.

O2U-00211 A type without attributes was translated

Cause: OTT translated a type without attributes. The corresponding C-type will be a struct without any components, which is not legal C. The empty type in the database may be the result of an error during type creation. Additionally, incomplete types may be used temporarily in the creation of types that reference one another.

Action: Re-create a full version of the type in the database and then re-run OTT.

O2U-00212 An error occurred for which no message is available

Cause: The cause of this error was not reported.

Action: Contact Oracle Support Services.


Pro*COBOL Messages (PCB)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

43
Pro*COBOL Messages (PCB)

For information about Pro*COBOL, refer to the Pro*COBOL Precompiler Programmer's Guide.

PCB-00001 string

Cause: This is a generic error message from the command-line processor.

Action: Correct the indicated error.

PCB-00002 Command line processor severe error

Cause: The command line processor encountered a severe error.

Action: After making sure that all the command-line options are specified correctly, call Oracle Support Services with a full account of all the options and configuration files used.

PCB-00003 Value of DBMS option invalid with given value of MODE option

Cause: When MODE={ANSI14 | ANSI13}, DBMS=V7 or V8 was specified, or when MODE=ANSI, DBMS=v6 was specified. These option settings are incompatible. Note that the DBMS option was not available before release 1.5 of the Oracle Precompilers.

Action: With DBMS=V7 or V8, instead of MODE={ANSI14 | ANSI13}, specify MODE={ANSI | ORACLE}. With DBMS=V6, instead of MODE=ANSI, specify MODE={ANSI14 | ANSI13 | ORACLE}, but MODE=ORACLE is recommended.

PCB-00004 UNSAFE_NULL=YES must be used with DBMS=V7 or V8 and MODE=ORACLE

Cause: The option UNSAFE_NULL=YES has been used with DBMS=V6 or DBMS=NATIVE (the default) or has been used with MODE=ANSI/ANSI14/ANSI13.

Action: Use DBMS=V7 or V8 and MODE=ORACLE (the default) when using UNSAFE_NULL=YES or do not use UNSAFE_NULL=YES.

PCB-00005 Command line option MODE=ANSI required with option NLS_LOCAL=YES

Cause: The precompiler option NLS_LOCAL=YES was used without also specifying MODE=ANSI. The precompiler option MODE=ANSI must be specified if NLS_LOCAL=YES.

Action: Set the precompiler option MODE=ANSI in addition to NLS_LOCAL=YES or do not set NLS_LOCAL=YES.

PCB-00006 Userid only used when SQLCHECK=FULL, userid ignored.

Cause: The USERID option was specified when SQLCHECK={SYNTAX | NONE}. This is unnecessary.

Action: Specify the USERID option only when SQLCHECK=SEMANTICS.

PCB-00007 string

Cause: This is a generic error message from the command-line processor.

Action: Correct the indicated error.

PCB-00008 Must use option SQLCHECK=SEMANTICS(FULL) when there is embedded PL/SQL

Cause: The precompiler tried to parse an embedded PL/SQL block when SQLCHECK={SYNTAX | NONE}. PL/SQL blocks can be parsed only when SQLCHECK=SEMANTICS is specified.

Action: Remove the PL/SQL block or specify SQLCHECK=SEMANTICS.

PCB-00009 Cannot change MAXLITERAL after an EXEC SQL statement

Cause: The MAXLITERAL option has been used in an inline EXEC ORACLE OPTION statement after and EXEC SQL, EXEC TOOLS, or EXEC IAF statement. This is not allowed.

Action: Use the MAXLITERAL option only on the command line or in an EXEC ORACLE OPTION statement placed at the beginning of the input source file.

PCB-00010 SQLCHECK value in EXEC ORACLE statement exceeds command line value

Cause: The SQLCHECK option was entered inline and specified a level of checking higher than the level specified (or accepted by default) on the command line. This is not allowed. For example, if SQLCHECK={SYNTAX | LIMITED} is specified on the command line, SQLCHECK={SEMANTICS | FULL} cannot be specified inline. This informational message is; the precompiler ignores the inline value and continues processing.

Action: Revise the EXEC ORACLE statement or specify a lower level of checking on the command line.

PCB-00011 DBMS=V6 no longer supported; using DBMS=NATIVE

Cause: V6 compatibility is no longer supported. The precompiler will precompile as though DBMS=NATIVE was specified.

Action: Revise the specified DBMS option value from v6 to another value as desired.

PCB-00012 Command line option DYNAMIC=ANSI required with option TYPE_CODE=ANSI

Cause: The precompiler option TYPE_CODE=ANSI was used without also specifying DYNAMIC=ANSI. The precompiler option DYNAMIC=ANSI must be specified if TYPE_CODE=ANSI.

Action: Set the precompiler option DYNAMIC=ANSI in addition to TYPE_CODE=ANSI or do not set TYPE_CODE=ANSI.

PCB-00100 Unable to reopen temporary file string

Cause: The precompiler was unable to reopen a temporary file. Some possible causes follow:

  • File access privileges are insufficient.
  • Another user has locked the file.
  • There is not enough disk space.
  • There are too many open files.

Action: Check that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).

PCB-00101 Could not find or open system configuration file

Cause: The precompiler was unable to open the system configuration file. The system configuration file does not exist or is not in the proper directory.

Action: Check that the system configuration file is in the proper directory. See Oracle installation documentation for where this should be. Put a new copy of PCCCOB.CFG with desired default options in the proper directory.

PCB-00102 Input file name length exceeds the maximum length

Cause: The file name length specified exceeded the maximum length. Some operating systems have a maximum file name length.

Action: Use a file name of length less than or equal to the maximum platform specific file name length.

PCB-00104 Unable to open input file "string"

Cause: The precompiler was unable to open the input file specified by the INAME precompiler option. Some possible causes follow:

  • The filename is misspelled.
  • The file does not exist.
  • The search path to the file is incorrect.
  • File access privileges are insufficient.
  • Another user has locked the file.
  • There is not enough disk space.
  • There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check with the system administrator to make sure that there is enough disk space and that the limit for open files is set high enough.

PCB-00105 Included file name "string" exceeds name limit of number characters

Cause: The file name length specified exceeded the maximum length. Some operating systems have a maximum file name length.

Action: Use a file name of length less than or equal to the maximum platform specific file name length.

PCB-00106 Unable to open INCLUDE file "string"

Cause: The precompiler was unable to open the input file specified in the INCLUDE statement. Some possible causes follow:

  • The filename is misspelled.
  • The file does not exist.
  • The search path to the file is incorrect.
  • File access privileges are insufficient.
  • There is not enough disk space.
  • There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges to access the file have been granted, and that it is not locked by another user. Also, check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).

PCB-00108 Unable to open list file "string"

Cause: The precompiler was unable to open the list file specified by the LNAME precompiler option. Some possible causes follow:

  • The filename is misspelled.
  • The file does not exist.
  • The search path to the file is incorrect.
  • File access privileges are insufficient.
  • Another user has locked the file.
  • There is not enough disk space.
  • There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager). If a listing file is not needed, specify LTYPE=NONE on the command line.

PCB-00109 Unable to open generated source file "string"

Cause: The precompiler was unable to open the output file specified by the ONAME precompiler option. Some possible causes follow:

  • The filename is misspelled.
  • The file does not exist.
  • The search path to the file is incorrect.
  • File access privileges are insufficient.
  • Another user has locked the file.
  • There is not enough disk space.
  • There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).

PCB-00110 Unable to open temporary file "string"

Cause: The precompiler was unable to open a file for temporary use. Some possible causes follow:

  • File access privileges are insufficient.
  • A file of the same name already exists and is locked.
  • There is not enough disk space.
  • There are too many open files.

Action: Check that the file exists, that sufficient privileges have been granted to access the file, and that it is not locked. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager).

PCB-00200 Cannot equivalence PIC N or PIC G variable "string"

Cause: A PIC N/G variable, an implicit VARCHAR group item with a PIC N/G elementary item, or a group item with a PIC N/G elementary item was used in an EXEC SQL VAR statement. This is not allowed.

Action: Do not use the PIC N variable in an EXEC SQL VAR statement. If you want an equivalence to an Oracle type using an EXEC SQL VAR statement, use a PIC X variable, instead of a PIC N variable.

PCB-00201 Indicator variable string not a group item

Cause: The host variable is a group item containing tables. Indicator variables used with this type of host variable must be group items of tables of indicators corresponding the tables in the group item host variable.

Action: Change the indicator variable to be a group item of indicator tables.

PCB-00202 Indicator variable string not a group item or table

Cause: The host variable is a group item. Indicator variables used with this type of host variable must be a group item or table of indicator variables.

Action: Use a group item or table of indicator variables.

PCB-00203 Nested group item "string" not supported

Cause: The variable used as a host variable was a group item which itself contained other group items.

Action: Remove any group items from the group item to be used as a host variable.

PCB-00204 Group items cannot be used except in INTO or VALUES clause

Cause: A group item host variable was used outside of an INTO or VALUES clause. A group item host variable may be used only in an INTO or VALUES clause.

Action: Do not use a group item outside of an INTO or VALUES clause.

PCB-00205 Cannot use PIC N or PIC G variable in PL/SQL when NLS_LOCAL=YES

Cause: A PIC N or PIC G variable was used in an embedded PL/SQL block when the precompiler option NLS_LOCAL=YES was used. A PIC N or PIC G variable is not supported in this situation.

Action: Do not use the PIC N or PIC G variable within the PL/SQL block or use precompiler option NLS_LOCAL=NO.

PCB-00206 Cannot use N quoted literal in PL/SQL when NLS_LOCAL=YES

Cause: A "N" literal (a literal of the form N'...') was used within a PL/SQL block when the precompiler option NLS_LOCAL=YES was used. N literals are not supported in this situation.

Action: Use an ordinary literal (one without the "N") within the PL/SQL block or use precompiler option NLS_LOCAL=NO.

PCB-00207 Invalid use of PIC N or PIC G table variable when NLS_LOCAL=YES

Cause: A PIC N variable was declared using an OCCURS clause. Tables of PIC N variables are not supported when NLS_LOCAL=YES.

Action: Declare the PIC N variable without an OCCURS clause or, do not use the PIC N variable in any SQL statements.

PCB-00208 Incorrect type for host variable "string"

Cause: A variable of unsupported datatype was used in a SQL statement or embedded PL/SQL block.

Action: Use a host variable of a supported datatype.

PCB-00209 Scale is not supported for host variable "string"

Cause: A variable whose format does not support scaling was used in a SQL statement or embedded PL/SQL block. The following formats do not support scaling:

PIC S9(n) COMP PIC S9(n) COMP-4 PIC S9(n) COMP-5 PIC S9(n) BINARY PIC 9(n) COMP

Action: Remove the scale or use a datatype that support scaling.

PCB-00210 DISPLAY-1 only allowed with PIC G and PIC N variables "string"

Cause: A variable declared with DISPLAY-1 in the usage clause without PIC G or PIC N in the picture clause was used in a SQL statement.

Action: Replace DISPLAY-1 with DISPLAY or change the picture clause to use PIC N or PIC G.

PCB-00211 VARYING not supported with PIC N or PIC G variable "string"

Cause: The keyword VARYING was used in a PIC N variable declaration.

Action: Remove the keyword VARYING from the variable declaration. If you want to declare a PIC N VARCHAR variable, specify the precompiler option VARCHAR=YES and declare the variable as an implicit VARCHAR group item as illustrated by the following example:

EXEC SQL BEGIN DECLARE SECTION END-EXEC.    ...           01  ENAME.               05  ENAME-LEN  PIC S9(4) COMP.           05  ENAME-ARR  PIC N(20).  ...EXEC SQL END DECLARE SECTION END-EXEC.

PCB-00212 PICTURE clause not allowed for host variable "string"

Cause: A variable declared with a PIC clause and COMP-1 or COMP-2 was used in a SQL statement or embedded PL/SQL block.

Action: Remove the PIC clause or use a datatype other than COMP-1 or COMP-2 in the declaration of the variable.

PCB-00214 JUSTIFIED clause not allowed for host variable "string"

Cause: A variable declared with a JUSTIFIED clause was used in a SQL statement or embedded PL/SQL block.

Action: Remove the JUSTIFIED clause from the variable declaration.

PCB-00215 OCCURS TO TIMES clause not allowed for host variable "string"

Cause: A variable declared with an OCCURS clause with the TO TIMES subclause was used in a SQL statement or embedded PL/SQL block.

Action: Remove the TO TIMES subclause from the variable declaration.

PCB-00216 OCCURS ASCENDING/DESCENDING clause not allowed for "string"

Cause: A variable declared with an OCCURS clause with the ASCENDING or DESCENDING KEY IS subclause was used in a SQL statement or embedded PL/SQL block.

Action: Remove the ASCENDING or DESCENDING KEY IS subclause from the variable declaration.

PCB-00217 OCCURS INDEXED clause not allowed for host variable "string"

Cause: A variable declared with an OCCURS INDEXED clause was used in a SQL statement or embedded PL/SQL block.

Action: Remove the OCCURS INDEXED clause from the variable declaration.

PCB-00218 RENAMES clause not allowed for host variable "string"

Cause: A variable declared with a RENAMES clause was used in a SQL statement or embedded PL/SQL block.

Action: Remove the RENAMES clause from the declaration.

PCB-00219 Invalid size specified in EXEC SQL VAR statement

Cause: A size which is specified which is not valid for the specified data type.

Action: Specify a size which is valid for the specified type.

PCB-00220 Invalid scale specified in EXEC SQL VAR statement

Cause: A scale which is specified which is not valid for the specified data type.

Action: Specify a scale which is valid for the specified type.

PCB-00221 OCCURS DEPENDING ON clause not allowed for host variable "string"

Cause: A variable declared with an OCCURS clause with the DEPENDING ON subclause was used in a SQL statement or embedded PL/SQL block.

Action: Remove the DEPENDING ON subclause from the variable declaration.

PCB-00222 Size for host variable string exceeds maximum size

Cause: A variable declared with PIC S9(n), with n greater than what is allowed on the given platform, was used in an embedded SQL statement. On 32 bit machines n must not exceed 9, and on 64 bit machines, n must not exceed 18.

Action: Use a smaller number in the picture clause that does not exceed the maximum allowed size on your platform or use COMP-3.

PCB-00223 Undeclared variable "string"

Cause: A variable used in a SQL statement was not declared or its name is misspelled or if option DECLARE_SECTION=YES the declaration was not in a DECLARE SECTION.

Action: Add or correct the variable declaration.

PCB-00224 Ambiguously referenced variable "string"

Cause: There is more than one variable of the same name and the qualification given was insufficient to determine which variable the reference was to.

Action: Use more complete qualification in the variable reference.

PCB-00225 Undeclared SQL identifier "string"

Cause: The name of a descriptor, statement, or cursor was not declared or is misspelled, or was declared as a different kind of SQL identifier.

Action: Add or correct the descriptor, statement, or cursor declaration.

PCB-00226 SQL identifier "string" already defined

Cause: The SQL identifier (cursor name, statement name, and so on) has already been defined in another way.

Action: Use a different name for this use of the name.

PCB-00227 Undeclared indicator variable "string"

Cause: An indicator variable used in a SQL statement was not declared in the Declare Section or its name is misspelled.

Action: Add or correct the indicator variable declaration.

PCB-00228 Invalid group item variable "string"

Cause: An unacceptable group item variable was used in a SQL statement. or its name is misspelled.

Action: Correct the group item variable declaration or its use in the SQL statement.

PCB-00229 Indicator variable "string" has wrong type or length

Cause: An indicator variable was not declared in the Declare Section as a 2-byte integer. Indicator variables must be defined as 2-byte integers.

Action: Redefine the indicator variable as a 2-byte integer.

PCB-00230 Indicator table size must not be less than its host variable

Cause: A host variable array was used with an indicator array declared with a smaller dimension. For example:

EXEC SQL BEGIN DECLARE SECTION END-EXEC.01  EMP-NUM       OCCURS 4 TIMES PIC S9(4) COMP.01  EMP-NUM-IND   OCCURS 2 TIMES PIC S9(4) COMP.EXEC SQL END DECLARE SECTION END-EXEC....SELECT ... INTO EMP-NUM:EMP-NUM-IND ...

Action: Increase the size of the indicator array.

PCB-00231 Host and indicator variables may not have the same name.

Cause: In an EXEC SQL statement, an indicator variable had the same name as a host variable. The names of a host variable and its associated indicator variable must be different. Also, an indicator variable cannot be used as a host variable.

Action: Rename the host or indicator variable.

PCB-00232 Tables not allowed as input bind variables in SELECT statement

Cause: A host table was used in the WHERE clause of a SELECT-INTO statement or in the SELECT list of a SELECT-INTO statement.

Action: Rewrite the SELECT statement without using tables or use a cursor.

PCB-00233 Table size mismatch in INTO/USING. Minimum is: number

Cause: The size of an table variable in an INTO/USING clause is too small for the number of rows processed.

Action: Declare all table variables in the INTO/USING clause to have at least the minimum dimension given.

PCB-00234 FOR variable "string" is invalid type

Cause: The count variable in a FOR clause has the wrong datatype. The datatype must be NUMBER or LONG (or be compatible with NUMBER or LONG).

Action: Check the declaration and check that the count variable has a datatype of NUMBER or LONG (or a compatible Oracle or host-language datatype).

PCB-00235 Table size mismatch in INTO/USING. Minimum is: number

Cause: The size of a table variable in an INTO/USING clause of a dynamic EXECUTE statement has been ARRAYLEN...EXECUTE'd while the other host variable has not and is not a table of dimension 1 or a plain non-table host variable. Example:

01 X PIC X(10) OCCURS 10.01 Y PIC S9(4) COMP OCCURS 10.01 Z PIC S9(4) COMP. ...  EXEC SQL ARRAYLEN X (DIM) EXECUTE END-EXEC.... EXEC SQL EXECUTE S1 USING :X, :Y END-EXEC.  <-- error EXEC SQLEXECUTE S1 USING :X, :Z END-EXEC.  <-- ok

Please note that this error differs from 233 in that it is an error and not a warning.

Action: ARRAYLEN...EXECUTE all of the table variables in the INTO/USING clause or those host variables not ARRAYLEN...EXECUTEd need to be of dimension 1.

PCB-00236 Cannot use PIC N/G variable. NLS_NCHAR not set or set incorrectly.

Cause: To use PIC N or PIC G variables as host variables, both of the environment variables NLS_LANG and NLS_NCHAR must be set with correct values. One of the following problems has occurred which prevents Pro*COBOL from accepting PIC N and PIC G variables as host variables:

  • One or both of NLS_LANG and NLS_NCHAR are not set at all.
  • NLS_LANG is not set with a valid language, territory, or character set.
  • NLS_NCHAR is not set to a valid NCHAR character set.
  • The character set specified by NLS_NCHAR is not a fixed width character set. Pro*COBOL can only use fixed width character sets for PIC N or PIC G host variables.

Action: Set the NLS_NCHAR environment variable to a valid fixed width character set name. Set NLS_LANG with a valid language, territory, and character set.

PCB-00237 Declaration of "string" cannot have a level number greater than 48

Cause: A VARYING or SQL-CURSOR declaration has been encountered which has the level number greater than 48.

Action: Change the level to 48 or less.

PCB-00238 Element of this table group item host variable cannot be a table

Cause: A group item that is a table and having an element that is a table was used in a SQL statement.

Action: Remove the OCCURS clause from the element of the group item.

PCB-00239 Element of a table group item indicator cannot be table or group item

Cause: A group item that is a table and used as an indicator has an element that is a table or group item.

Action: Change the nested table or group item in the indicator so that it is an elementary item.

PCB-00240 Group item containing this host variable cannot be table

Cause: An elementary item belonging to a group item with an OCCURS clause has been referenced. This is not allowed.

Action: Change the elementary item used to an item that is not an element of a table of group items.

PCB-00241 A host variable is required here

Cause: The COUNT item in the dynamic SQL statement must be a host variable but is not.

Action: Use a host variable in the COUNT item of the dynamic SQL statement.

PCB-00242 A host variable or exact numeric constant is required here

Cause: The particular item in the dynamic SQL statement is required to be a host variable or exact numeric (integer) constant, but is not.

Action: Change the item in the dynamic SQL statement to use a host variable or exact numeric constant.

PCB-00300 Datatype for host variable not supported by ANSI "string"

Cause: An Oracle extension to the ANSI/ISO standard was used. Specifically, a pointer or nonconforming datatype such as VARCHAR was used. For example, the offending code might look like:

EXEC SQL BEGIN DECLARE SECTION END-EXEC.01 USERNAME          PIC X(10) VARYING.EXEC SQL END DECLARE SECTION END-EXEC.

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required.

PCB-00301 Use of non-ANSI function is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a non-ANSI function was used. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use this function.

PCB-00302 This statement is not supported by ANSI

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a nonconforming SQL statement such as PREPARE was used. For example, the offending code might look like:

EXEC SQL PREPARE SQL-STMT FROM :HV END-EXEC.

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the nonconforming statement.

PCB-00303 Dynamic SQL and PL/SQL are Oracle extensions to ANSI SQL

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, dynamic SQL or embedded PL/SQL was used. For example, the offending code might look like:

EXEC SQL EXECUTE BEGIN SELECT ... END; END-EXEC.

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use dynamic SQL or embedded PL/SQL.

PCB-00304 Oracle extension to the WHENEVER statement

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a nonconforming keyword such as NOTFOUND, STOP, RAISE, or DO was used in the WHENEVER statement. (Note that NOT FOUND is ANSI-compliant.) For example, the offending code might look like:

EXEC SQL WHENEVER SQLERROR STOP END-EXEC.

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the nonconforming keyword.

PCB-00305 Oracle extension to the COMMIT and ROLLBACK statements

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the parameter RELEASE, COMMENT, or FORCE were used in a COMMIT or ROLLBACK statement. For example, the offending code might look like:

EXEC SQL ROLLBACK RELEASE END-EXEC.

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the nonconforming parameter.

PCB-00306 CREATE FUNCTION/PROCEDURE/PACKAGE/TRIGGER are Oracle extensions

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, one of the following statements was used:

  • CREATE FUNCTION
  • CREATE PROCEDURE
  • CREATE PACKAGE
  • CREATE TRIGGER

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use any of these statements.

PCB-00307 DROP TABLE statement is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the DROP TABLE statement was used. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use the DROP statement.

PCB-00308 FOR clause is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the FOR clause was used in an table-processing SQL statement. For example, the offending code might look like:

EXEC SQL FOR :LIMIT INSERT INTO EMP (EMPNO, JOB, DEPTNO) VALUES (:EMPNUM, :JOB, :DEPTNO) END-EXEC.

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the FOR clause.

PCB-00309 The CONNECT statement is Oracle implementation dependent

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the CONNECT statement was used to log on to Oracle. For example, the offending code might look like:

EXEC SQL CONNECT:USERNAME IDENTIFIED BY:PSSWORD END-EXEC.

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, specify the AUTO_CONNECT command-line option instead of using a CONNECT statement.

PCB-00310 AT clause is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the AT db_name clause was used in a SQL statement. For example, the offending code might look like:

EXEC SQL AT oracle3 COMMIT RELEASE END-EXEC.

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the AT db_name clause.

PCB-00311 Datatype equivalencing is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the EXEC SQL VAR statement was used.

Action: No action required. However, for ANSI/ISO compliance, do not use the EXEC SQL VAR statement.

PCB-00312 Keyword WORK required here by ANSI

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the keyword WORK was used in a COMMIT or ROLLBACK statement. For example, the offending code might look like:

EXEC SQL COMMIT WORK RELEASE END-EXEC.

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the keyword WORK.

PCB-00313 TO SAVEPOINT clause is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the TO SAVEPOINT save_id clause was used in a ROLLBACK statement.

Action: No action required. However, for ANSI/ISO compliance, do not use the TO SAVEPOINT clause.

PCB-00314 DECLARE DATABASE is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the DECLARE DATABASE statement was used.

Action: No action required. However, for ANSI/ISO compliance, do not use this statement.

PCB-00315 DECLARE TABLE is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the DECLARE TABLE statement was used.

Action: No action required. However, for ANSI/ISO compliance, do not use this statement.

PCB-00316 SQL FORMS statements are Oracle extensions

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the one of the following statements was used:

  • EXEC IAF GET
  • EXEC IAF PUT
  • EXEC TOOLS GET
  • EXEC TOOLS SET

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use any of these statements.

PCB-00317 Group item host variables are Oracle extensions

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a group item variable was used as a host variable. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use group items as host variables.

PCB-00318 ARRAYLEN is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the ARRAYLEN statement was used. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use this statement.

PCB-00319 EXEC ORACLE statements are an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, an EXEC ORACLE statement was used. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use this statement.

PCB-00320 VARYING host variable "string" is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a variable declared of VARYING type was used in a SQL statement. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use this statement.

PCB-00321 Implicit varchar host variables are an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, an implicit varchar variable was used in a SQL statement. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use this statement.

PCB-00322 EXEC SQL LOB statements an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, an EXEC SQL LOB statement was used. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use this statement.

PCB-00400 string

Cause: A syntax error was found.

Action: Do the appropriate action to fix the indicated error.

PCB-00401 Character string not properly terminated

Cause: The character string was not terminated with a quote or apostrophe as appropriate or line continuation was not correct.

Action: Check that the character string is terminated properly and that line continuation syntax is correct.

PCB-00402 Pseudo-text not properly terminated

Cause: A block of pseudo-text has not been properly terminated with "==".

Action: Terminate the pseudo-text at the appropriate place with "==".

PCB-00403 EXEC statement cannot begin in Area A

Cause: An EXEC statement began in Area A (before column 12).

Action: Shift the EXEC statement to the right to start it in Area B (in or after column 12).

PCB-00404 string

Cause: A syntax error was found.

Action: Do the appropriate action to fix the indicated error.

PCB-00500 No EXEC SQL CONTEXT USE statement encountered

Cause: No EXEC SQL CONTEXT USE statement was encountered and the option THREADS=YES was requested.

Action: Ensure that the necessary context variable (of type SQL-context) has been declared, ALLOCATEd, and USEd prior to any executable SQL statements.

PCB-00501 Runtime context variable "string" not of correct type

Cause: The runtime context variable referenced in an EXEC SQL CONTEXT USE statement is not of type SQL_CONTEXT.

Action: Declare your runtime context variable of type SQL_CONTEXT.

PCB-00502 This statement can only be used with THREADS=YES

Cause: EXEC SQL ENABLE THREADS has been used, even though option THREADS is set to NO.

Action: Specify option THREADS=YES or remove the EXEC ENABLE THREADS statement from the source code.

PCB-00525 Use of the AT clause is not permitted here

Cause: An explicit AT clause was used with an ALLOCATE statement or a FETCH/CLOSE statement also using a SQL-cursor declaration.

Action: Remove the AT clause.

PCB-00550 Unable to log on to ORACLE with "string". ORACLE error number: number

Cause: The precompiler was unable to log on to Oracle with the specified username and password. An Oracle error with given number occurred when the logon was attempted.

Action: Lookup indicated Oracle database error message and take appropriate action.

PCB-00551 The SQLCA has already been included

Cause: The precompiler has encountered an include SQLCA statement after SQLCA has already been included. The SQLCA can only be included once.

Action: Remove the duplicate include SQLCA statement.

PCB-00552 The SQLCA and a SQLCODE variable cannot both be used

Cause: The SQLCA has been included and a SQLCODE variable has been declared. This is not allowed as references to the SQLCODE variable are ambiguous and will result in COBOL compiler errors.

Action: Use either the SQLCA or the SQLCODE variable. Remove either the include of the SQLCA or the SQLCODE variable declaration.

PCB-00553 FOR clause not allowed on this statement

Cause: A FOR clause was used with a SELECT, LOB, or DEALLOCATE DESCRIPTOR statement. A FOR clause cannot be used with these statements. In the case of a SELECT statement, data returned from the last loop in the execution of the SELECT would overwrite data returned in a previous loop.

Action: Remove the FOR clause from the statement. Use a host language construct to iteratively execute the statement.

PCB-00554 Must include SQLCA when mode=ANSI and WHENEVER SQLWARNING used

Cause: When MODE={ANSI | ANSI14}, an attempt was made to use the WHENEVER SQLWARNING statement without declaring the SQLCA. When MODE={ANSI | ANSI14}, declaring the SQLCA is optional, but to use the WHENEVER SQLWARNING statement, the SQLCA must be declared.

Action: Remove all WHENEVER SQLWARNING statements from the program or declare the SQLCA by hard-coding it or copying it into the program with the INCLUDE statement.

PCB-00555 Using WHERE CURRENT OF on cursor defined without FOR UPDATE clause

Cause: If mode=ORACLE, then a cursor defined with a WHERE CURRENT OF clause must also have a FOR UPDATE clause.

Action: Rewrite the cursor definition.

PCB-00556 Unrecoverable error. Fix previous errors and re-precompile

Cause: A fatal parsing error or token stack overflow error has been encountered.

Action: Fix the syntax error that is causing the parsing error.

PCB-00557 USING clause can only be used on a PREPAREd dynamic statement

Cause: A severe semantics error occurred because the USING clause was used with the OPEN cursor statement and the cursor declaration is not for a PREPAREd statement. The correct sequence of statements should be like:

EXEC SQL prepare sv from :sel_stmt END-EXEC.EXEC SQL declare csv cursor for sv END-EXEC.EXEC SQL open csv USING :hv1, :hv2 END-EXEC.

Action: Use the prepare statement for the SQL statement and use that in the declare cursor statement.

PCB-00558 Invalid external datatype specified in EXEC SQL VAR statement

Cause: An invalid external datatype was specified in the EXEC SQL VAR statement.

Action: Specify a valid external datatype.

PCB-00575 PLS-number: string

Cause: Refer to the indicated PL/SQL error message for the indicated condition.

Action: Refer to the indicated PL/SQL error message to correct the SQL statement or embedded PL/SQL block.

PCB-00576 PLS-number: string

Cause: The precompiler found an error in an embedded SQL statement or PL/SQL block.

Action: Refer to the indicated PL/SQL error message to correct the SQL statement or embedded PL/SQL block.

PCB-00577 Use of ARRAYLEN with host tables in SQL statements is ignored

Cause: ARRAYLEN is only valid with PL/SQL.

Action: Use an appropriate table type.

PCB-00578 Variable "string" must be a table

Cause: In an ARRAYLEN statement, the name of a previously declared host table was not specified. The first host variable in an ARRAYLEN statement must be a table. The second host variable, which specifies an array dimension, must be a 4-byte integer. The correct syntax follows:

EXEC SQL ARRAYLEN HTABLE (DIM) END-EXEC.

The ARRAYLEN statement must appear along with, but somewhere after, the declarations of HOST_TABLE and dimension.

Action: Check the spelling of both identifiers in the ARRAYLEN statement. If necessary, supply the missing host table name.

PCB-00579 Invalid ARRAYLEN length variable type for "string"

Cause: A valid table dimension was not specified in an ARRAYLEN statement. The table dimension must be specified using a previously declared 4-byte integer host variable, not a literal or expression. For example, the offending code might look like:

EXEC SQL ARRAYLEN ETABLE (25) END-EXEC.  -- illegal dimension

Action: Supply a valid table dimension. If necessary, declare a 4-byte integer host variable for use in the ARRAYLEN statement.

PCB-00580 Previous use of host variable "string" uses different indicator

Cause: Within a PL/SQL statement, a host variable was used with two different indicator variables or was used with an indicator variable in one instance and without an indicator in another instance.

Action: Change all references to the host variable so that they all use the same indicator variable or all use no indicator variable.

PCB-00581 "string" used as both host variable and indicator

Cause: Within a PL/SQL statement, the variable was used as both a host variable and an indicator variable.

Action: Use different variables for host variables and indicator variables.

PCB-00600 indicators are not allowed in EXEC IAF statements

Cause: Indicator variables associated with host variables cannot be used in EXEC IAF statements such as GET and PUT in a user exit.

Action: Eliminate the indicator variables. If feasible (for example with Forms V4), use EXEC TOOLS statements, which do allow indicator variables. See the Pro*COBOL Precompiler Programmer's Guide for more information about the EXEC IAF and EXEC TOOLS statements.

PCB-00603 An EXEC TOOLS MESSAGE host variable is not a character type

Cause: If a host variable is used to specify the message in an EXEC TOOLS MESSAGE statement, that host variable must be of a CHAR type.

Action: Declare the message to a host variable of a CHAR type.

PCB-00625 An indicator variable is not required with this attribute

Cause: In a LOB DESCRIBE, an indicator variable was used with a host variable when retrieving a LOB attribute that does not require one.

Action: Remove the indicator variable.

PCB-00626 Incompatible LOB types

Cause: A LOB operation was attempted between LOBs whose types were not compatible. For example, When ASSIGNing one LOB to another, both LOBs must be of the same type. If they are not, this error results.

Action: Correct the LOB operation by having it function between LOBs of the same type. This may require a redeclaration of one of the LOBs used in the LOB statement performing the specified operation.

PCB-00627 Host variable is not of character type

Cause: The given host variable was not declared to be of the required character type. In this case, one of several possible character types would have been accepted. However, the host variable type did not match any of them.

Action: Redeclare the problematic host variable, using one of the permitted character types.

PCB-00628 Buffer type is incompatible with LOB type

Cause: This error can occur in either of the following situations:

  • An attempt to READ from a LOB into a buffer whose type was not compatible with the LOB type.
  • An attempt to WRITE a buffer into a LOB whose type was not compatible with the buffer type.

Action: Either the LOB type or the buffer type needs to be changed so that the LOB and buffer types become compatible for the specified operation.

PCB-00629 Host variable is not of Internal LOB type

Cause: The given host variable was not declared to be an internal LOB. BLOB, CLOB or NCLOB are internal lob types.

Action: Redeclare the host variable using one of the internal LOB types.

PCB-00630 Host variable is not of LOB type

Cause: The given host variable was not declared to be any type of LOB, Internal or External. BLOB, CLOB or NCLOB are internal lob types. BFILE is an external type.

Action: Redeclare the host variable using any of the LOB types, Internal or External.

PCB-00631 Host variable is not an External LOB

Cause: The given host variable was not declared to be an External LOB. BFILE is an external type.

Action: Redeclare the host variable using an External LOB type (BFILE).

PCB-00632 Cannot open an External LOB in READ WRITE mode

Cause: An attempt was made to OPEN a BFILE in READ WRITE mode. Writable BFILEs are currently not supported so this operation is considered erroneous.

Action: Do not open BFILEs using READ WRITE mode. BFILEs can only be OPENed in READ ONLY mode.

PCB-00633 Invalid host variable and attribute pairing

Cause: The host variable and attribute pairing in a LOB DESCRIBE was invalid. Most likely, this was due to some problem with the host variable. For example, this error could occur if the host variable was not declared.

Action: Usually, other, more specific, errors will accompany this one. Correcting some or all of those problems should resolve this error.

PCB-00635 This attribute is only valid for Internal LOB types

Cause: A request for a LOB attribute was made in a LOB DESCRIBE statement in which the given LOB was not of some Internal LOB type.

Action: Replace the LOB host variable in the LOB DESCRIBE with one that was declared to be an Internal LOB.

PCB-00636 This attribute is only valid for External LOB types

Cause: A request for a LOB attribute was made in a LOB DESCRIBE statement in which the given LOB was not an External LOB type (BFILE).

Action: Use an External LOB (BFILE) host variable in the LOB DESCRIBE statement.

PCB-00637 Host variable is not an exact binary integer

Cause: A host variable was given that was not declared to be of some acceptable exact binary integer type. Generally, when this error occurs, a signed or unsigned integer type was expected. Floating point or otherwise imprecise numeric types are considered erroneous.

Action: Replace the problematic host variable with one that was declared using a proper binary integer type.

PCB-00638 This attribute is only valid for internal or external LOB types

Cause: A request for a LOB attribute was made in a LOB DESCRIBE statement in which the given source was not an internal or external LOB type.

Action: Use a LOB host variable in the LOB DESCRIBE statement.

PCB-00639 Cannot specify destination offset in a LOB WRITE APPEND

Cause: A destination offset was specified in a LOB WRITE APPEND statement. The destination offset is assumed to be the end of the LOB so specifying an explicit destination offset is erroneous.

Action: Remove the destination offset from the LOB WRITE APPEND statement.

PCB-00700 This statement can only be used with DYNAMIC=ANSI

Cause: One of the following statements was used without specifying DYNAMIC=ANSI:

  • EXEC SQL ALLOCATE/DEALLOCATE/GET/SET DESCRIPTOR
  • EXEC SQL DESCRIBE OUTPUT/INPUT ... USING ... descriptor_name
  • EXEC SQL EXECUTE ... INTO ...
  • EXEC SQL EXECUTE ... USING... descriptor_name
  • EXEC SQL OPEN ... INTO ...
  • EXEC SQL OPEN ... USING... descriptor_name
  • SCROLL in DECLARE CURSOR
  • EXEC SQL FETCH orientation ... where orientation is NEXT, PRIOR, FIRST, LAST, ABSOLUTE, or RELATIVE

Action: Specify DYNAMIC=ANSI or remove statement(s) like those above.

PCB-00701 MAX OCCURRANCES must be between 1 and 65535

Cause: The value specified in the WITH MAX clause of an EXEC SQL ALLOCATE DESCRIPTOR statement was less than 1 or greater than 65535.

Action: Specific a value between 1 and 65535.

PCB-00702 Out-of-range item number

Cause: The value specified in the VALUES clause of an EXEC SQL GET/SET DESCRIPTOR statement was less than one or greater than 65535.

Action: Specify a value between 1 and 65535.

PCB-00901 Pro*COBOL internal error condition detected (Code = number)

Cause: Pro*COBOL has detected an abnormal condition in its internal data structures. This error message should not normally be produced. Contact Oracle Support Services to report the error.

Action: Correct any other errors which have been reported. If the internal error still exists, examine the source code where the condition was detected and try modifying in some way. Possibly this will alleviate the internal error condition.

PCB-00902 Unable to read message file, facility PCB

Cause: Pro*COBOL was unable to access the message file containing message text. The file is possibly corrupt.

Action: Contact Oracle Support Services for information on reinstalling the Pro*COBOL message files.

PCB-00903 Pro*COBOL is unable to initialize its parser function

Cause: Pro*COBOL was unable to access the message file containing message text. The file is possibly corrupt.

Action: Contact Oracle Support Services for information on reinstalling the Pro*COBOL message files.


PCF FIPS Messages (PCF)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

44
PCF FIPS Messages (PCF)

This chapter contains messages that are generated when you specify the precompiler command-line option FIPS=YES and use an Oracle extension to the ANSI/ISO embedded SQL standard. If you wish your code to comply with the standard, do not use the Oracle extension described in the message.

PCF-00251 SQLCODE is a deprecated feature

PCF-00252 use of the C preprocessor within SQL

PCF-00253 use of the AT clause

PCF-00254 use of the FOR clause

PCF-00255 use of the CONNECT statement

PCF-00256 SQLCODE returns non-standard values

PCF-00257 keyword WORK required after COMMIT

PCF-00258 keyword WORK required after ROLLBACK

PCF-00259 use of TO SAVEPOINT clause

PCF-00260 use of RELEASE clause

PCF-00261 use of dynamic SQL

PCF-00262 use of PL/SQL

PCF-00263 use of SQLWARN within WHENEVER clause

PCF-00264 use of NOTFOUND within WHENEVER clause

PCF-00265 use of COMMENT clause with COMMIT

PCF-00266 use of STOP within WHENEVER clause

PCF-00267 use of FORCE TRANSACTION clause

PCF-00268 use of DO within WHENEVER clause

PCF-00269 use of DECLARE TABLE statement

PCF-00270 use of DECLARE DATABASE statement

PCF-00271 use of EXEC SQL INCLUDE

PCF-00272 use of datatype equivalencing

PCF-00273 use of SQL FORMS statement

PCF-00274 use of EXEC ORACLE statement

PCF-00275 invalid datatype

PCF-00276 use of DROP TABLE statement

PCF-00277 use of non-ANSI function

PCF-00278 use of the ALLOCATE statement

PCF-00279 use of CREATE to build PL/SQL objects

PCF-00280 use of OBJECT Navigational Interface

PCF-00281 use of LOB statement

PCF-00282 use of COLLECTION statement


Pro*C/C++ Messages (PCC)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

45
Pro*C/C++ Messages (PCC)

For information about Pro*C/C++, refer to the Pro*C/C++ Precompiler Programmer's Guide.

PCC-00001 Unable to open file string

Cause: The precompiler was unable to open a temporary file for internal use. There might be insufficient disk space, too many open files, or read-only protection on the output directory.

Action: Check that there is enough disk space, that the limit for open files is set high enough (check with the system manager) and that protection on the directory allows opening a file for writing.

PCC-00002 Invalid syntax at column number in line number of file string

Cause: There is a syntax error in an EXEC statement or the statement is not properly terminated.

Action: Correct the syntax of the EXEC statement. If the error occurred at the end of the input file, check that the last EXEC statement is properly terminated.

PCC-00003 Invalid SQL Identifier at column number in line number of file string

Cause: The symbol in a conditional precompilation statement (such as EXEC ORACLE IFDEF) is invalid, or the name of a SQL descriptor, statement, or cursor is invalid or was not properly declared.

Action: Check the statement syntax and spelling of the identifier and check that a reserved word was not accidentally used. If necessary, define the identifier in a variable declaration or DECLARE statement ahead of the line in error.

PCC-00004 Mismatched IF/ELSE/ENDIF block at line number in file string

Cause: There is an EXEC ORACLE ELSE or EXEC ORACLE ENDIF statement without a matching EXEC ORACLE IFDEF statement.

Action: Add the missing EXEC ORACLE IFDEF statement or delete or move the EXEC ORACLE ELSE or EXEC ORACLE ENDIF statement.

PCC-00005 Unsupported datatype in line number of file string

Cause: A host variable defined in the DECLARE section has an unsupported datatype or has a scale or precision outside the supported range.

Action: Redefine the host variable using a supported datatype. Check that the scale and precision of a numeric variable are in the accepted range.

PCC-00007 Invalid WHENEVER condition at column number in line number of file string

Cause: A condition other than SQLERROR, SQLWARNING, or NOT FOUND was specified in an EXEC SQL WHENEVER statement, or one of these was used, but spelled incorrectly.

Action: Correct the spelling of the WHENEVER condition or use a host- language IF statement to test the special condition.

PCC-00008 Invalid WHENEVER action at column number in line number of file string

Cause: At lease one of the following:

  • An action other than CONTINUE, DO, GOTO, or STOP was specified in an EXEC SQL WHENEVER statement.
  • One of the specified actions was spelled incorrectly.
  • The host language does not allow the action (STOP is illegal in Pro*Pascal programs).
  • A GOTO label is invalid.

Action: Check that the host language allows the specified WHENEVER action. If necessary, correct the spelling of the WHENEVER action or correct the GOTO label.

PCC-00009 Invalid host variable at column number in line number of file string

Cause: A host variable used in an EXEC SQL statement was not declared in the DECLARE section or has an unsupported datatype.

Action: Declare the host variable in the DECLARE section, making sure it has one of the supported datatypes.

PCC-00010 Statement out of place at line number in file string

Cause: An EXEC statement was not placed properly in the host program. For example, there might be a data manipulation statement in the DECLARE section. In a Pro*COBOL program, the DECLARE section might be outside the WORKING-STORAGE or LINKAGE SECTION.

Action: Remove or relocate the statement.

PCC-00011 Already in a declare section at line number in file string

Cause: A BEGIN DECLARE SECTION statement was found inside a DECLARE section.

Action: Remove the extra BEGIN DECLARE SECTION statement.

PCC-00012 Not in a declare section at line number in file string

Cause: An END DECLARE SECTION statement without a matching BEGIN DECLARE SECTION statement was found. Either the BEGIN DECLARE SECTION statement is missing or misspelled or the END DECLARE SECTION statement is an extra.

Action: Add or correct the BEGIN DECLARE SECTION statement or remove the extra END DECLARE SECTION statement.

PCC-00013 Unable to open include file "string" at line number in file string

Cause: The precompiler was unable to open the input file specified in the INCLUDE statement. Some possible causes follow:

  • The file name is misspelled.
  • The file does not exist.
  • The search path to the file is incorrect.
  • File access privileges are insufficient.
  • There is not enough disk space.
  • There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges to access the file have been granted, and that it is not locked by another user. Also, check with the system manager to make sure there is enough disk space and that the limit for open files is set high enough.

PCC-00014 Undeclared SQL Identifier "string" at line number in file string

Cause: The name of a descriptor, statement, or cursor was not declared or is misspelled.

Action: Add or correct the descriptor, statement, or cursor declaration.

PCC-00015 Unrecognized Host Language syntax ignored at line number in file string

Cause: The host language syntax used to define a host variable in the DECLARE section is incorrect.

Action: Check the syntax and the spelling, then correct the declaration.

PCC-00016 Unable to open a cursor at line number in file string

Cause: The syntax in a SQL statement is faulty. The precompiler was expecting a host variable, but found something else.

Action: Check the syntax and the spelling, then correct the SQL statement.

PCC-00017 Unable to parse statement at line number in file string

Cause: There is a syntax error in an array declaration. The precompiler was expecting a right bracket (]) but found something else.

Action: Check the syntax, then correct the array declaration.

PCC-00018 Expected "string", but found "string" at line number in file string

Cause: The syntax in a SQL statement is faulty. The precompiler found an unexpected or illegal token.

Action: Check the syntax and the spelling, then correct the SQL statement.

PCC-00019 Unable to obtain bind variables at line number in file string

Cause: The precompiler was unable to find information about an input host variable (bind variable) used in a SQL statement.

Action: Check that the input host variable is declared in the DECLARE section and used properly in the SQL statement.

PCC-00020 Unable to obtain define variables at line number in file string

Cause: The precompiler was unable to find information about an output host variable (define variable) used in a SQL statement.

Action: Check that the output host variable is declared in the DECLARE section and used properly in the SQL statement.

PCC-00021 Oracle Error: string

Cause: An Oracle error occurred.

Action: Refer to the indicated message in the ORA message chapters of this manual.

PCC-00022 Out of space - unable to allocate number bytes

Cause: The precompiler process ran out of memory.

Action: Allocate more memory to the process, then retry.

PCC-00023 Unable to log off from ORACLE

Cause: An Oracle connection error occurred while the precompiler was trying to log off, probably because Oracle has been shut down.

Action: Check that Oracle is available, then retry.

PCC-00024 Indicator variable "string" has wrong type or length at line number in file string

Cause: An indicator variable was not declared in the DECLARE section as a 2-byte integer. Indicator variables must be defined as 2-byte integers.

Action: Redefine the indicator variable as a 2-byte integer.

PCC-00025 Undeclared indicator variable "string" at line number in file string

Cause: An indicator variable used in a SQL statement was not declared in the DECLARE section or its name is misspelled.

Action: Add or correct the indicator variable declaration.

PCC-00026 Invalid host variable "string" at line number in file string

Cause: A host variable used in a SQL statement was not declared properly. Some possible causes follow:

  • It was not declared in the DECLARE section.
  • Its datatype is not supported.
  • Its name is misspelled.
  • It is a COBOL group item; in Pro*COBOL, only elementary items are allowed in a SQL statement.

Action: Add or correct the host variable declaration.

PCC-00027 Redeclared SQL Identifier "string" at line number in file string

Cause: The name of a SQL descriptor, statement, or cursor was re-declared (that is, declared twice).

Action: Check the spelling of the identifier, then, if necessary, remove the extra declaration.

PCC-00028 Option "string" not legal as EXEC ORACLE OPTION

Cause: A precompiler option was specified inline in an EXEC ORACLE statement. Some options can be specified only on the command line. For example, INAME cannot be specified inline.

Action: Respecify the precompiler option on the command line, instead of in an EXEC ORACLE statement. To see an online display of the precompiler options, enter the precompiler command (with no options) at the operating-system prompt.

PCC-00029 Ambiguous option "string"

Cause: The name of a precompiler option was abbreviated ambiguously. For example, MAX= might refer to MAXLITERAL or MAXOPENCURSORS.

Action: Respecify the full option name or an unambiguous abbreviation. To see an online display of the precompiler options, enter the precompiler command (with no options) at the operating-system prompt.

PCC-00031 Invalid value given for option "string"

Cause: The value specified for a precompiler option is invalid, probably because the value is misspelled (as in LTYPE=HORT) or out of range (as in PAGELEN=-55).

Action: Check the value, making sure it is spelled correctly and within the legal range.

PCC-00032 Invalid option "string"

Cause: The precompiler found an invalid precompiler option name. Some possible causes follow:

  • The option name is misspelled.
  • The specified option does not exist.
  • The equal sign (=) between the option name and value is missing or has space around it.

Action: Check that the option exists and that its name is spelled correctly. To see an online display of the precompiler options, enter the precompiler command (with no options) at the operating- system prompt. Also check that there is an equal sign between the option name and value.

PCC-00033 Missing operand for option "string"

Cause: No value was specified for a precompiler option. Either the value is missing or there is space around the equal sign (as in LTYPE =SHORT).

Action: Check that a value for each option has been specified and there is no space around the equal sign.

PCC-00036 No input file name specified

Cause: The input file was not specified on the command line.

Action: Use the INAME command-line option to specify the input file.

PCC-00037 Unable to log on to ORACLE with "string". ORACLE error number: number

Cause: The precompiler was unable to log on to ORACLE with the specified username and password. An ORACLE error with given number occurred when the logon was attempted.

Action: Refer to the indicated message in the ORA message chapters of this manual.

PCC-00038 Unable to open a cursor

Cause: This is an internal error message not usually issued.

Action: Call Oracle Support Services for assistance. If the application does not require syntactic or semantic checking of SQL statements and does not use PL/SQL, specify SQLCHECK=NONE on the command line.

PCC-00039 Unable to open input file "string"

Cause: The precompiler was unable to open the input file specified by the INAME precompiler option. Some possible causes follow:

  • The file name is misspelled.
  • The file does not exist.
  • The search path to the file is incorrect.
  • File access privileges are insufficient.
  • Another user has locked the file.
  • There is not enough disk space.
  • There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Check with the system administrator to make sure that there is enough disk space and that the limit for open files is set high enough.

PCC-00040 Unable to open listing file "string"

Cause: The precompiler was unable to open the listing file specified by the LNAME precompiler option. Some possible causes follow:

  • The file name is misspelled.
  • The file does not exist.
  • The search path to the file is incorrect.
  • File access privileges are insufficient.
  • Another user has locked the file.
  • There is not enough disk space.
  • There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Also check that there is enough disk space and that the limit for open files is set high enough (check with the system manager). If a listing file is not needed, specify LTYPE=NONE on the command line.

PCC-00041 Unable to open output file "string"

Cause: The precompiler was unable to open the listing file specified by the ONAME precompiler option. Some possible causes follow:

  • The file name is misspelled.
  • The file does not exist.
  • The search path to the file is incorrect.
  • File access privileges are insufficient.
  • Another user has locked the file.
  • There is not enough disk space.
  • There are too many open files.

Action: Check that the file exists, that the search path to the file is correct, that sufficient privileges have been granted to access the file, and that it is not locked by another user. Check with the system administrator to make sure that there is enough disk space and that the limit for open files is set high enough.

PCC-00042 Must EXEC SQL INCLUDE SQLCA when mode=ANSI and WHENEVER SQLWARNING used

Cause: When MODE={ANSI | ANSI14}, an attempt was made to use the WHENEVER SQLWARNING statement without declaring the SQLCA. When MODE={ANSI | ANSI14}, declaring the SQLCA is optional, but to use the WHENEVER SQLWARNING statement, the SQLCA must be declared.

Action: Remove all WHENEVER SQLWARNING statements from the program or declare the SQLCA by hardcoding it or copying it into the program with the INCLUDE statement.

PCC-00044 Array size mismatch in INTO/USING. Minimum is: string(number:number)

Cause: The size of an array variable in an INTO/USING clause is too small for the number of rows processed.

Action: Declare all array variables in the INTO/USING clause to have at least the minimum dimension given.

PCC-00045 string clause inappropriate at line number in file string. Ignored.

Cause: There is a misplaced clause at the end of an EXEC SQL statement (an AT clause at the end of a SELECT statement, for example), or the action specified in a FOR clause is invalid (for example, FOR :loop INTO...).

Action: Check the statement syntax, then relocate or correct the misplaced or invalid clause.

PCC-00047 Unterminated comment/string constant beginning near line number in file string

Cause: A string constant is missing an ending quotation mark, or a comment is missing an ending delimiter.

Action: Check that all comments are delimited and all string constants are enclosed by quotation marks.

PCC-00050 Unable to generate descriptor in program unit ending line number in file string

Cause: The precompiler was unable to generate a descriptor for the compilation unit. This can occur from either of the following:

  • A non-existent or improperly implemented DECLARE section
  • Undetected syntax errors near the beginning of the source file or just before the END DECLARE SECTION statement

Action: Verify that the DECLARE section is properly implemented. Then check for syntax errors at the beginning of the compilation unit and before any END DECLARE SECTION statement, and correct as appropriate.

PCC-00051 Size of VARCHAR string is larger than 65533 in line number in file string

Cause: The declared size of a VARCHAR host variable exceeds the precompiler limit of 65533 bytes.

Action: Check the DECLARE section, making sure the size of each VARCHAR variable does not exceed the limit of 65533 bytes.

PCC-00053 FOR variable string is invalid type at line number in file string

Cause: The count variable in a FOR clause has the wrong datatype. The datatype must be NUMBER or LONG (or be compatible with NUMBER or LONG).

Action: Check the declaration and check that the count variable has a datatype of NUMBER or LONG (or a compatible Oracle or host-language datatype).

PCC-00054 Expected End-of-Statement at column number in line number of file string

Cause: The precompiler expected to find a statement terminator at the end of an EXEC statement but found something else. This can happen if tabs were embedded in the source code (because the precompiler has no way of knowing how many spaces a tab represents).

Action: If tabs are embedded in the source code, replace them with spaces. Check the statement syntax and check that each EXEC statement has a terminator. For embedded CREATE {FUNCTION | PROCEDURE | PACKAGE} statements and for embedded PL/SQL blocks, check that the statement terminator is END-EXEC.

PCC-00055 Array "string" not allowed as bind variable at line number in file string

Cause: A host array was used as a bind (input) variable in the WHERE clause of a SELECT statement. This is not allowed.

Action: Remove the host array or replace it with a simple host variable.

PCC-00056 FOR clause not allowed on SELECT statement at line number in file string.

Cause: A FOR clause was used with a SELECT statement. This is not allowed as data returned from the last loop in the execution of the SELECT overwrites data returned in a previous loop.

Action: Remove the FOR clause from the SELECT statement and use a host- language construct to iteratively execute the SELECT statement.

PCC-00060 Both CURSOR and STATEMENT have AT clauses at line number of file string.

Cause: Two AT clauses, one in a DECLARE STATEMENT statement, the other in a DECLARE CURSOR statement, pertain to the same SQL statement. The AT clause may be specified with either DECLARE STATEMENT or DECLARE CURSOR, but not with both.

Action: Remove the AT clause from one of the statements.

PCC-00061 Error at line number, column number. PLS-number: string

Cause: The precompiler found an error in an embedded SQL statement or PL/SQL block.

Action: Refer to the indicated PL/SQL error message to correct the SQL statement or embedded PL/SQL block.

PCC-00062 Must use option SQLCHECK=SEMANTICS(FULL) when there is embedded PL/SQL

Cause: The precompiler tried to parse an embedded PL/SQL block when SQLCHECK={SYNTAX | NONE}. PL/SQL blocks can be parsed only when SQLCHECK=SEMANTICS is specified.

Action: Remove the PL/SQL block or specify SQLCHECK=SEMANTICS.

PCC-00063 Reached end of file string before End-of-Statement at line number!

Cause: The precompiler encountered an end-of-file while parsing a PL/SQL block.

Action: Add the appropriate statement terminator (;) or end-of-block statement (END;) to the PL/SQL block.

PCC-00064 All uses of a given host variable must use identical indicator variables.

Cause: Two or more occurrences of a host variable in an EXEC SQL statement were associated with different indicator variables. This is not allowed.

Action: Rename the indicator variables so that each occurrence of the host variable is associated with the same indicator variable.

PCC-00065 Userid required, but not specified.

Cause: The SQLCHECK=SEMANTICS option was specified, but the USERID option on the command line was not specified.

Action: Specify USERID=username/password or enter a username and password when prompted or specify SQLCHECK={SYNTAX | NONE}.

PCC-00066 Userid only used when SQLCHECK = FULL, userid ignored.

Cause: The USERID option was specified when SQLCHECK={SYNTAX | NONE}. This is unnecessary.

Action: Specify the USERID option only when SQLCHECK=SEMANTICS.

PCC-00067 Ireclen exceeded. Line number in file string truncated.

Cause: While reading the input file, the precompiler found a line longer than IRECLEN.

Action: Either shorten the input line or specify a larger IRECLEN value on the command line.

PCC-00068 Host and indicator variables may not have the same name.

Cause: In an EXEC SQL statement, an indicator variable had the same name as a host variable. The names of a host variable and its associated indicator variable must be different. Also, an indicator variable cannot be used as a host variable.

Action: Rename the host or indicator variable.

PCC-00069 Host variable "string" has unsupported datatype at line number in file string

Cause: A host variable had an unsupported datatype. For a list of supported datatypes, see the language-specific Precompiler Programmer's Guide.

Action: Redefine the host variable in the DECLARE section, giving it a supported datatype.

PCC-00070 Illegal syntax, Exponential value in SQL statement: string

Cause: The precompiler found a syntax error while parsing a number coded in scientific notation. The precompiler expected to find a signed integer following the exponentiation indicator (E), but found something else.

Action: Reformat the number correctly.

PCC-00071 Unable to open message file.

Cause: The precompiler was unable to open the message file containing the messages that can be issued by the precompiler. This can happen if there are too many open files or if there were problems with installation of the precompiler.

Action: Check that the limit for open files is high enough (check with the system manager). Otherwise, contact Oracle Support Services.

PCC-00072 Input file name length exceeds the maximum length

Cause: The file name length specified exceeded the maximum length. Some operating systems have a maximum file name length.

Action: Use a file name of length less than or equal to the maximum platform specific file name length.

PCC-00073 Cursor is declared but never OPENed at line number in file string.

Cause: A cursor was DECLAREd but was not referenced in an OPEN statement. This is only an informational message.

Action: Remove the cursor declaration or code an OPEN statement for the cursor.

PCC-00075 ":" expected before indicator variable

Cause: An indicator variable was not prefixed with a colon, as required.

Action: Prefix a colon to the indicator variable in question.

PCC-00076 DISPLAY type must be SIGN LEADING SEPARATE

Cause: This message is issued only by Pro*COBOL. DISPLAY SIGN LEADING SEPARATE is the only DISPLAY type supported by Pro*COBOL.

Action: Check the spelling of the variable declaration. If necessary, remove the reference to the unsupported DISPLAY type.

PCC-00077 Colon usage with numeric label in WHENEVER statement is not ANSI

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a numeric WHENEVER ... GOTO label was prefixed with a colon. For example the code might have looked like:

EXEC SQL WHENEVER SQLERROR GOTO :99;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, prefix alphanumeric (but not numeric) WHENEVER ... GOTO labels with a colon.

PCC-00078 FIPS warning: Invalid ANSI SQL Identifier

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the name given to a host variable:

  • is longer than 18 characters,
  • does not begin with a letter, or
  • contains consecutive or trailing underscores

In the following Pro*C example, the host variable name is 19 characters long and therefore non-compliant:

EXEC SQL BEGIN DECLARE SECTION;int department_location:  -- not ANSI/ISO compliantEXEC SQL END DECLARE SECTION;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, change the host variable name so that it is less than or equal to 18 characters long, begins with a letter, and does not contain consecutive or trailing underscores.

PCC-00079 ANSI requires colon on label in WHENEVER statement

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, an alphanumeric WHENEVER ... GOTO label was not prefixed with a colon. For example the offending code might look like:

EXEC SQL WHENEVER NOT FOUND GOTO NO_MORE;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, prefix alphanumeric (but not numeric) WHENEVER ... GOTO labels with a colon.

PCC-00080 TYPE identifier already TYPEd

Cause: The identifier being TYPEd in an EXEC SQL TYPE statement appeared in a previous EXEC SQL TYPE statement. A given identifier can appear in only one EXEC SQL TYPE statement.

Action: Check the spelling of the identifiers. Use different identifiers in the EXEC SQL TYPE statements, or remove one of the EXEC SQL TYPE statements.

PCC-00081 Scale specification not allowed for given datatype

Cause: The Oracle external datatype referenced in an EXEC SQL VAR or EXEC SQL TYPE statement does no allow a scale specification.

Action: Check the precision specification and remove the scale specification.

PCC-00082 Length and scale specifications must be an integer

Cause: A floating point number or a non-number to specify a length or scale was used. Only integers can be used.

Action: Correct or remove the length and/or scale specification.

PCC-00083 Bind and define variables not allowed in CREATE statement

Cause: Host variables cannot appear in a CREATE statement. If the makeup of a CREATE statement cannot be known until run time, a dynamic SQL statement must be used to execute it. That is, the program must accept or build the CREATE statement at run time, store it in a host string, then EXECUTE it.

Action: Correct or remove the erroneous CREATE statement.

PCC-00085 Error writing to file string

Cause: The precompiler was unable to write to the named output file. Some possible causes follow:

  • Sufficient file access privileges were not defined.
  • Another user has locked the file.
  • There is not enough disk space.
  • There are too many open files.

Action: Check that sufficient privileges exist to access the file and that it is not locked by another user. Check with the system administrator to make sure that there is enough disk space and that the limit for open files is set high enough.

PCC-00086 Source file string has zero length

Cause: The source file specified on the command line contains no code. Consequently, there is nothing for the precompiler to process.

Action: Specify a valid source file containing embedded SQL statements.

PCC-00087 EXEC SQL TYPE statement not allowed for this host language

Cause: An EXEC SQL TYPE statement was used with a host language that does not support user-defined datatype equivalencing. This feature is available only in Pro*C and Pro*Pascal.

Action: Remove the offending EXEC SQL TYPE statement.

PCC-00088 User defined type identifier expected

Cause: The user-defined datatype name in an EXEC SQL TYPE statement is missing or misspelled, is a reserved word, is not a legal identifier in the host-language or conflicts with a base datatype in that language.

Action: Check the spelling of the user-defined datatype name. If necessary, declare a valid user-defined datatype. User-defined datatype equivalencing is available only in Pro*C and Pro*Pascal.

PCC-00089 Invalid Oracle TYPE specification

Cause: The Oracle external datatype name in an EXE SQL TYPE or EXEC SQL VAR statement is missing or misspelled.

Action: Check the spelling of the external datatype name. If necessary, supply the missing datatype name.

PCC-00090 Precision/scale specification must be given for DECIMAL datatype

Cause: A precision and/or scale specification for the Oracle external datatype DECIMAL in an EXEC SQL TYPE or EXEC SQL VAR statement was omitted.

Action: Add the precision and/or scale specification to the EXEC SQL TYPE or EXEC SQL VAR statement.

PCC-00091 TYPE statement requires format specification for this Oracle datatype

Cause: A length, precision, and/or scale specification for an Oracle external datatype in an EXEC SQL TYPE or EXEC SQL VAR statement was omitted.

Action: Add the length, precision, and/or scale specification for the external datatype to the EXEC SQL TYPE or EXEC SQL VAR statement.

PCC-00092 Length and/or scale incompatible with specified Oracle datatype

Cause: An invalid length or scale for an Oracle external datatype in an EXEC SQL TYPE or EXEC SQL VAR statement was specified.

Action: Check that a length large enough to accommodate the external datatype is specified. If a scale is specified, check that it lies in the range -84 to 99.

PCC-00093 Invalid or obsolete option, ignored

Cause: The precompiler found an option available in a prior version or different host language but not in the current version or host language.

Action: Remove the option specification.

PCC-00094 Array length for char[n] datatype must be >= 2

Cause: When MODE={ANSI | ANSI14}, a length of less than 2 characters for a char[n] host variable was specified or a simple char variable was specified. When MODE={ANSI | ANSI14}, the length must be at least 2 characters. This message is issued only by the Pro*C precompiler.

Action: Correct the declaration so that it specifies a length of at least 2 characters.

PCC-00095 Missing PROGRAM, SUBROUTINE, FUNCTION, or BLOCK DATA statement

Cause: FORTRAN source files are expected to have at least one PROGRAM, SUBROUTINE, FUNCTION, or BLOCK DATA statement, which the precompiler uses to detect the beginning of a routine or compilation unit.

Action: Add one of these statements to the source file.

PCC-00096 Array FETCH not allowed for mode=ANSI14

Cause: When MODE=ANSI14, an array SELECT or FETCH was attempted. However, array operations are not allowed with MODE=ANSI14.

Action: If MODE=ANSI14 must be specified, place the SELECT or FETCH statement in a host-language loop, instead of using the array interface.

PCC-00097 Use of DECIMAL and DISPLAY types allowed only for COBOL and PL/I

Cause: The DECIMAL and DISPLAY external datatype was used in an EXEC SQL VAR or EXEC SQL TYPE statement with an Oracle precompiler other than Pro*COBOL or PRO*PL/I. These external datatypes are available only in Pro*COBOL and PRO*PL/I.

Action: Remove the reference to the DECIMAL or DISPLAY external datatype from the EXEC SQL TYPE or EXEC SQL VAR statement.

PCC-00098 Scale specification cannot be used in this context

Cause: In a Pro*C, Pro*FORTRAN, Pro*Pascal program, scale in an EXEC SQL TYPE or EXEC SQL VAR statement in the current context cannot be specified.

Action: Remove the scale specification from the EXEC SQL TYPE or EXEC SQL VAR statement.

PCC-00099 Length cannot be given for types ROWID, DATE, or MLSLABEL

Cause: A length for the ROWID, DATE, or MLSLABEL external datatype was specified in an EXEC SQL TYPE or EXEC SQL VAR statement. This is unnecessary because those are fixed length types.

Action: Remove the length specification from the EXEC SQL TYPE or EXEC SQL VAR statement.

PCC-00100 Non integer label is not ANSI

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a non-integer WHENEVER ... GOTO label was in a Pro*Pascal program. For example, the offending code might look like:

EXEC SQL WHENEVER NOT FOUND GOTO quit;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, use only integer WHENEVER... GOTO labels in a Pro*Pascal program.

PCC-00101 Lower case 'e' in floating point number is not ANSI

Cause: A Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a lowercase 'e' was used in scientific notation. For example, the offending code might look like:

maxnum = 10e38;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, use an uppercase 'E' in scientific notation.

PCC-00102 FOR UPDATE is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the FOR UPDATE OF clause was used in a cursor declaration. For example, the offending code might look like:

EXEC SQL DECLARE emp_cursor CURSOR FOR SELECT ENAME, SAL FROM EMP WHERE DEPTNO = :dept_number FOR UPDATE OF SAL;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the FOR UPDATE OF clause.

PCC-00103 AT clause is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the AT db_name clause was used in a SQL statement. For example, the offending code might look like:

EXEC SQL AT oracle3 COMMIT RELEASE;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the AT db_name clause.

PCC-00104 FOR clause is an Oracle extension

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the FOR clause was used in an array-processing SQL statement. For example, the offending code might look like:

EXEC SQL FOR :limit INSERT INTO EMP (EMPNO, JOB, DEPTNO) VALUES (:emp_number, :job_title, :dept_number);

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the FOR clause.

PCC-00105 Keyword WORK required here by ANSI

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the keyword WORK was used in a COMMIT or ROLLBACK statement. For example, the offending code might look like:

EXEC SQL COMMIT WORK RELEASE;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the keyword WORK.

PCC-00106 RELEASE is an Oracle extension to the COMMIT and ROLLBACK statements

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the parameter RELEASE was used in a COMMIT or ROLLBACK statement. For example, the offending code might look like:

EXEC SQL ROLLBACK RELEASE;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the parameter RELEASE;

PCC-00107 The CONNECT statement is Oracle implementation dependent

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, the CONNECT statement was used to log on to ORACLE. For example, the offending code might look like:

EXEC SQL CONNECT :username IDENTIFIED BY :password;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, specify the AUTO_CONNECT command-line option instead of using a CONNECT statement.

PCC-00108 This statement is not supported by ANSI

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a nonconforming SQL statement such as PREPARE was used. For example, the offending code might look like:

EXEC SQL PREPARE sql_statement FROM :sql_string;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the nonconforming statement.

PCC-00109 Dynamic SQL and PL/SQL are Oracle extensions to ANSI SQL

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, dynamic SQL or embedded PL/SQL was used. For example, the offending code might look like:

EXEC SQL EXECUTE BEGIN SELECT ... END; END-EXEC;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use dynamic SQL or embedded PL/SQL.

PCC-00110 Oracle extension to the WHENEVER statement

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a nonconforming keyword such as NOTFOUND, STOP, RAISE, or DO was used in the WHENEVER statement. (Note that NOT FOUND is ANSI-compliant.) For example, the offending code might look like:

EXEC SQL WHENEVER SQLERROR STOP;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use the nonconforming keyword.

PCC-00111 SQLCHECK value in EXEC ORACLE statement exceeds command line value

Cause: The SQLCHECK option was entered inline and specified a level of checking higher than the level specified (or accepted by default) on the command line. This is not allowed. For example, if SQLCHECK={SYNTAX | LIMITED} is specified on the command line, SQLCHECK={SEMANTICS | FULL} cannot be specified inline.

Action: Revise the EXEC ORACLE statement or specify a lower level of checking on the command line.

PCC-00112 Datatype not supported by ANSI

Cause: An Oracle extension to the ANSI/ISO standard was used. Specifically, a pointer or nonconforming datatype such as VARCHAR was used. For example, the offending code might look like:

EXEC SQL BEGIN DECLARE SECTION;VAECHAR username[20];EXEC SQL END DECLARE SECTION;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use pointers or nonconforming datatypes.

PCC-00113 Value of DBMS option invalid with given value of MODE option

Cause: When MODE={ANSI14 | ANSI13}, DBMS=V7 was specified, or when MODE=ANSI, DBMS=v6 was specified. These option settings are incompatible. Note that the DBMS option was not available before release 1.5 of the Oracle Precompilers.

Action: With DBMS=V7, instead of MODE={ANSI14 | ANSI13}, specify MODE={ANSI | ORACLE}. With DBMS=V6, instead of MODE=ANSI, specify MODE={ANSI14 | ANSI13 | ORACLE}, but MODE=ORACLE is recommended.

PCC-00114 Length spec required in EXEC SQL VAR statements for VARxxx types

Cause: In an EXEC SQL VAR statement, a VARCHAR or VARRAW external datatype was specified without a length. Unlike other types, the maximum length of the data field must be specified for VARCHAR and VARRAW.

Action: Add a length specification to the EXEC SQL VAR statement.

PCC-00115 Array required here

Cause: In an ARRAYLEN statement, the name of a previously declared host array was not specified. The first host variable in an ARRAYLEN statement must be an array. The second host variable, which specifies an array dimension, must be a 4-byte integer. The correct syntax follows:

EXEC SQL ARRAYLEN host_array (dimension);

The ARRAYLEN statement must appear in the DECLARE section along with, but somewhere after, the declarations of host_array and dimension.

Action: Check the spelling of both identifiers in the ARRAYLEN statement. If necessary, supply the missing host array name.

PCC-00116 This array already given in an ARRAYLEN statement

Cause: The same host array was specified in two different ARRAYLEN statements. A given host array cannot be specified in more than one ARRAYLEN statement.

Action: Check the spelling of the host array names in both ARRAYLEN statements. Change one of the names so that they refer to different host arrays or remove one of the ARRAYLEN statements.

PCC-00117 Invalid ARRAYLEN length variable type

Cause: A valid array dimension was not specified in an ARRAYLEN statement. The array dimension must be specified using a previously declared 4-byte integer host variable, not a literal or expression. For example, the offending code might look like:

EXEC SQL ARRAYLEN ename_array (25);  -- illegal dimension

Action: Supply a valid array dimension. If necessary, declare a 4-byte integer host variable for use in the ARRAYLEN statement.

PCC-00118 Use of host variable initialization not supported by ANSI SQL

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a host variable was initialized in its declaration, as shown in the following Pro*C example:

EXEC SQL BEGIN DECLARE SECTION;int dept_number = 20;  -- not ANSI/ISO-compliantEXEC SQL END DECLARE SECTION;

This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not initialize host variables in their declarations.

PCC-00119 Value of const variable in INTO clause will be modified

Cause: A variable declared with the type specifier "const" was used in an INTO clause. Such variables should not be modified and should not be used in an INTO clause.

Action: Check the spelling of all identifiers in the INTO clause. If necessary, remove "const" from the host variable declaration or use a different host variable.

PCC-00120 File I/O error during code generation

Cause: A file I/O error occurred during code generation. This may be caused by insufficient disk space.

Action: Check that there is enough disk space.

PCC-00121 Arrays of VARCHAR pointers are not supported

Cause: An array of pointers was declared, which is not allowed. However, pointers to scalar types are allowed. With Pro*C, declare pointers to char[n] and varchar[n] variables as pointers to CHAR or VARCHAR (with no length specification).

Action: Correct or remove the declaration.

PCC-00122 Input file name and output file name are identical

Cause: On the command line, the same path name for INAME and ONAME was specified, which designates the precompiler input and output files, respectively.

Action: Change one of the path/file names.

PCC-00123 Entire VARCHAR declaration must be on same line

Cause: In a Pro*C program, a VARCHAR declaration spans more than one line, which is not allowed.

Action: Revise the declaration so that it uses only one line.

PCC-00124 COMMON_NAME option is specified too late

Cause: In a FORTRAN program, subroutine, or function, the precompiler option COMMON_NAME was mistakenly specified after the PROGRAM, SUBROUTINE, or FUNCTION statement. If COMMON_NAME is specified inline, its EXEC ORACLE OPTION statement must precede the PROGRAM SUBROUTINE, or FUNCTION statement.

Action: Relocate the EXEC ORACLE OPTION statement or specify COMMON_NAME on the command line.

PCC-00126 Could not find or open system configuration file

Cause: The precompiler was unable to find or open the system configuration file (a text file containing preset command-line options, which the precompiler uses by default). Some possible causes follow:

  • The file does not exist.
  • The search path to the file is incorrect.
  • File access privileges are insufficient.
  • There are too many open files.

However, this message is just a warning. Processing continues even if the system configuration file does not exist.

Action: Check that the file exists, that the search path to the file is correct, and that sufficient privileges exist to access the file. Also check that the limit for open files is set high enough (check with the system manager).

PCC-00127 string

Cause: This is a generic error message from the command-line processor.

Action: Correct the indicated error.

PCC-00128 Command line processor severe error

Cause: The command line processor encountered a severe error.

Action: After making sure that all the command-line options are specified correctly, call Oracle Support Services with a full account of all the options and configuration files used.

PCC-00129 Option "string" must be given

Cause: A required command-line option is missing. For example, the INAME option, which specifies the name of the input file, might be missing.

Action: Supply the missing command-line option.

PCC-00132 Indicator array size must not be less than its host variable

Cause: An host variable array was used with an indicator array declared with a smaller dimension. For example:

EXEC SQL BEGIN DECLARE SECTION; int   dept_no[20]; short dept_no_ind[10]; EXEC SQL END DECLARE SECTION; ... SELECT ... INTO dept_no:dept_no_ind ...

Action: Increase the size of the indicator array.

PCC-00133 Command line option MODE=ANSI required with option NLS_LOCAL=YES

Cause: The precompiler option NLS_LOCAL=YES was used without also specifying MODE=ANSI. The precompiler option MODE=ANSI must be specified if NLS_LOCAL=YES.

Action: Set the precompiler option MODE=ANSI in addition to NLS_LOCAL=YES or do not set NLS_LOCAL=YES.

PCC-00135 Result Set Cursor usage is not standard SQL

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, an Oracle Result Set Cursor has been used. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action required. However, for ANSI/ISO compliance, do not use Result Set Cursors.

PCC-00136 Invalid SQL_CURSOR declaration

Cause: An array of SQL_CURSOR host variables was declared or, if Pro*COBOL, a PICTURE clause was specified in the SQL-CURSOR declaration. In Pro*FORTRAN, a length specification (that is, "*n") on the SQL_CURSOR declaration could have been specified. These usages are not supported.

Action: Check that the SQL_CURSOR variable is not declared as an array or, if Pro*COBOL, that no PICTURE clause is specified for the SQL_CURSOR. In Pro*FORTRAN, check that there is no length specification (that is, "*n") for the SQL_CURSOR.

PCC-00137 Invalid use of SQL cursor host variable

Cause: A SQL_CURSOR variable was used in an INTO or WHERE clause. SQL_CURSOR variables can be used only where ordinary cursor identifiers would be used or, in a PL/SQL block, where a cursor would normally be used.

Action: Remove the SQL cursor variable reference from the INTO clause or WHERE clause, or use a host variable of another type in the INTO or WHERE clause.

PCC-00138 Result Set Cursors are not implemented in this precompiler

Cause: There was an attempt to reference a host variable as a cursor reference. Cursor variables are not implemented in PRO*Pascal or Pro*PL/I.

Action: Rewrite your host-language code to use standard SQL cursors.

PCC-00139 Cannot change MAXLITERAL after an EXEC SQL statement

Cause: The MAXLITERAL option has been used in an inline EXEC ORACLE OPTION statement after and EXEC SQL, EXEC TOOLS, or EXEC IAF statement. This is not allowed.

Action: Use the MAXLITERAL option only on the command line or in an EXEC ORACLE OPTION statement placed at the beginning of the input source file.

PCC-00140 CREATE FUNCTION/PROCEDURE/PACKAGE/TRIGGER are Oracle extensions

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, one of the following statements was used:

  • CREATE FUNCTION
  • CREATE PROCEDURE
  • CREATE PACKAGE
  • CREATE TRIGGER

These statements are Oracle extensions to the ANSI/ISO SQL standards. This informational message is issued by the FIPS Flagger when FIPS=YES.

Action: No action is required. However, for ANSI/ISO compliance, do not use any of these statements.

PCC-00141 Thread Safety is not implemented in this precompiler

Cause: There has been an attempt to use CONTEXT SQL statements. The thread safety feature is not implemented in PRO*Pascal, Pro*PL/I, or Pro*C 1.x.

Action: Rewrite your host-language code to not use contexts.

PCC-00142 No EXEC SQL CONTEXT USE statement encountered

Cause: No EXEC SQL CONTEXT USE statement was encountered and the option THREADS=YES was requested.

Action: Ensure that the necessary context variable (of type SQL_CONTEXT) has been declared, ALLOCATEd, and USEd prior to any executable SQL statements.

PCC-00143 Runtime context variable not of correct type

Cause: The runtime context variable referenced in an EXEC SQL CONTEXT USE statement is not of type SQL_CONTEXT.

Action: Declare your runtime context variable of type SQL_CONTEXT.

PCC-00144 UNSAFE_NULL=YES must be used with DBMS=V7 and MODE=ORACLE

Cause: The option UNSAFE_NULL=YES has been used with DBMS=V6 or DBMS=NATIVE (the default) or has been used with MODE=ANSI/ANSI14/ANSI13.

Action: Either specify DBMS=V7 and MODE=ORACLE (the default) when using UNSAFE_NULL=YES or do not use UNSAFE_NULL=YES.

PCC-00145 This statement can only be used with THREADS=YES

Cause: EXEC SQL ENABLE THREADS or one of the EXEC SQL CONTEXT statements has been used, even though option THREADS is set to NO.

Action: Specify option THREADS=YES or remove the EXEC SQL ENABLE THREADS or EXEC SQL CONTEXT statement from the source code.

PCC-00146 Illegal value for host option, ignored

Cause: An invalid host language was specified using the command-line host option. The host option valid values are Pro* language-specific. For example, for PROFOR, the only valid value is FORTRAN. For PROCOB, the only valid values are COBOL and COB74.

Action: Specify a valid host language with the host option.

PCC-00147 DBMS=V6 no longer supported; using DBMS=NATIVE

Cause: V6 compatibility is no longer supported. The precompiler will precompile as though DBMS=NATIVE was specified.

Action: Revise the specified DBMS option value from v6 to another value as desired.

PCC-01000 You are not authorized to run Pro*COBOL

Cause: The authorization or license to run the Pro*COBOL Precompiler has expired.

Action: Call Oracle Support Services for assistance.

PCC-01001 Your Pro*COBOL authorization is about to expire

Cause: The authorization or license to run the Pro*COBOL Precompiler is about to expire.

Action: Call Oracle Support Services for assistance.

PCC-01002 Invalid character "character" in indicator area at line number in file string

Cause: In a Pro*COBOL Precompiler program, only a blank, hyphen (-), asterisk (*), slash (/), or letter "D" is allowed in the indicator area, but the precompiler found another character.

Action: Remove or replace the invalid character. If the FORMAT=ANSI option is specified, check for an end-of-line in column 7.

PCC-01003 Invalid continuation at line number in file string

Cause: In a PRO*COBOL program, a continuation line was completely blank, except for the continuation character.

Action: Remove or replace the empty continuation line.

PCC-01004 In an EXEC statement at end-of-file

Cause: In a Pro*COBOL input file, the last EXEC statement was not terminated properly.

Action: Terminate the last EXEC statement with an END-EXEC.

PCC-01005 PROCEDURE DIVISION not found

Cause: The precompiler could not find the PROCEDURE DIVISION header in a Pro*COBOL program. Some possible causes follow:

  • A keyword in the header is missing or misspelled.
  • There is an apostrophe in the REMARKS section (the precompiler mistook the apostrophe for the beginning of a string literal).
  • There is an unterminated literal in the WORKING-STORAGE SECTION.
  • The wrong value for the FORMAT option was specified.

Action: Check that the PROCEDURE DIVISION header is in place and spelled correctly, that there is no apostrophe in the REMARKS section, that all literals in the WORKING-STORAGE SECTION are terminated, and that the right value for the FORMAT option is specified.

PCC-01006 EXEC statement cannot begin in Area A at line number in file string

Cause: In a Pro*COBOL program, EXEC statements must begin in Area B, but the precompiler found a statement beginning in Area A.

Action: Move the statement rightward so that it begins in Area B.

PCC-01007 WORKING-STORAGE SECTION not found

Cause: The precompiler could not find the WORKING-STORAGE SECTION header in a Pro*COBOL program, probably because a keyword is missing or misspelled, or the wrong value for the FORMAT option might have been specified.

Action: Check that the WORKING-STORAGE SECTION header is in place and spelled correctly and that the right value for the FORMAT option is specified.

PCC-01008 Multiple element records not allowed in DECLARE section

Cause: A few COBOL compilers do not allow group items to be passed as parameters in a CALL statement. (Check the COBOL compiler user's guide.) If the compiler is one of these, group items within the DECLARE section can contain only one elementary item.

Action: Assign each host variable its own group item.

PCC-01009 For hostlan = COB74, a SQL statement must be followed by ELSE or "."

Cause: In a Pro*COBOL program, an EXEC SQL statement is followed by another statement in the same sentence. An EXEC SQL statement must be the last statement in a COBOL-74 sentence and so must be terminated by the keyword ELSE or a period.

Action: Change the program logic, making the EXEC SQL statement the last statement in the sentence.

PCC-01010 Invalid use of NULL character in character literal

Cause: A null character (binary zero) was found in a string literal. This is not allowed by Pro*COBOL.

Action: Remove the null character from the string literal.

PCC-01011 USAGE IS BINARY clause must be terminated by "." on same line

Cause: The period terminating the USAGE IS BINARY clause must be on the same line as the USAGE clause. This message only occurs on systems that support the COMP5=YES command line option of Pro*COBOL, where COMP-5 is substituted for BINARY.

Action: Check that the period terminating the USAGE IS BINARY clause is on the same line as the USAGE clause.

PCC-01012 DATA DIVISION not found

Cause: The Pro*COBOL precompiler did not find a DATA DIVISION in the input source file. Pro*COBOL applications are required to have a DATA DIVISION.

Action: Add a DATA DIVISION to the input source file.

PCC-01013 Invalid use of PIC N array variable "string" at line number in file string

Cause: A PIC N variable was declared using an OCCURS clause. Tables of PIC N variables are not supported by the Pro*COBOL precompiler.

Action: Declare the PIC N variable without an OCCURS clause or, if the PIC N variable is not used in any SQL statements, declare it outside the DECLARE section.

PCC-01014 "VARYING" not supported with PIC N PICTURE clause

Cause: The keyword VARYING was used in a PIC N variable declaration.

Action: Remove the keyword VARYING from the variable declaration. If you want to declare a PIC N VARCHAR variable, specify the precompiler option VARCHAR=YES and declare the variable as an implicit VARCHAR group item as illustrated by the following example:

EXEC SQL BEGIN DECLARE SECTION END-EXEC....01 ENAME.05 ENAME-LEN  PIC S9(4) COMP.05 ENAME-ARR  PIC N(20)....EXEC SQL END DECLARE SECTION END-EXEC.

PCC-01015 Cannot equivalence PIC N variable string

Cause: A PIC N variable or an implicit VARCHAR group item (with a PIC N variable as an elementary item) was used in an EXEC SQL VAR statement. This is not allowed.

Action: Do not use the PIC N variable in an EXEC SQL VAR statement. If you want an equivalence to an Oracle type using an EXEC SQL VAR statement, use a PIC X variable, instead of a PIC N variable.

PCC-01016 "N" character literals not supported in embedded PL/SQL

Cause: An "N" character literal was used within a PL/SQL block

Action: Remove the "N" character literal from the PL/SQL block.

PCC-01017 The SQLCA and a SQLCODE variable cannot both be used

Cause: The SQLCA has been included and a SQLCODE variable has been declared. This is not allowed as references to the SQLCODE variable are ambiguous and will result in COBOL compiler errors.

Action: Use either the SQLCA or the SQLCODE variable. Remove either the include of the SQLCA or the SQLCODE variable declaration.

PCC-01018 Conversion buffer size can only be specified for character types

Cause: A CONVBUFSZ clause has been used in an EXEC SQL VAR statement where the variable is not of a character datatype.

Action: Remove the CONVBUFSZ clause from the EXEC SQL VAR statement.

PCC-01019 Invalid conversion buffer size

Cause: The size specified in a CONVBUFSZ clause must be an integer in the range 1 to 32765. Either the size given is not an integer or is outside the required range.

Action: Specify an integer in the range 1 to 32765.

PCC-01100 You are not authorized to run Pro*FORTRAN

Cause: The authorization or license to run the Pro*FORTRAN Precompiler has expired.

Action: Call Oracle Support Services for assistance.

PCC-01101 Your Pro*FORTRAN authorization is about to expire

Cause: The authorization or license to run the Pro*FORTRAN Precompiler is about to expire.

Action: Call Oracle Support Services for assistance.

PCC-01102 Invalid label at line number in file string

Cause: The Pro*FORTRAN Precompiler found an invalid FORTRAN statement label in columns 1 through 6.

Action: Correct or remove the statement label.

PCC-01200 You are not authorized to run Pro*C

Cause: The authorization or license to run the Pro*C Precompiler has expired.

Action: Call Oracle Support Services for assistance.

PCC-01201 Your Pro*C authorization is about to expire

Cause: The authorization or license to run the Pro*C Precompiler is about to expire.

Action: Call Oracle Support Services for assistance.

PCC-01202 Identifier "string" truncated to 31 characters

Cause: A host identifier (the name of a host variable, for example) was truncated to the maximum length (31 characters) allowed by the precompiler. This is an informational message.

Action: No action required.

PCC-01300 You are not authorized to run Pro*PL/I

Cause: The authorization or license to run the Pro*PL/I Precompiler has expired.

Action: Call Oracle Support Services for assistance.

PCC-01301 Your Pro*PL/I authorization is about to expire

Cause: The authorization or license to run the Pro*PL/I Precompiler is about to expire.

Action: Call Oracle Support Services for assistance.

PCC-01400 You are not authorized to run Pro*Pascal

Cause: The authorization or license to run the Pro*Pascal Precompiler has expired.

Action: Call Oracle Support Services for assistance.

PCC-01401 Your Pro*Pascal authorization is about to expire

Cause: The authorization or license to run the Pro*Pascal Precompiler is about to expire.

Action: Call Oracle Support Services for assistance.

PCC-01500 You are not authorized to run Pro*Ada

Cause: The authorization or license to run the Pro*Ada Precompiler has expired.

Action: Call Oracle Support Services for assistance.

PCC-01501 Your Pro*Ada authorization is about to expire

Cause: The authorization or license to run the Pro*Ada Precompiler is about to expire.

Action: Call Oracle Support Services for assistance.

PCC-01510 No Package, Procedure or Function statement seen in string

Cause: Every Ada source file must have a package, procedure, or function statement. The precompiler did not find one.

Action: Add the appropriate statement(s) to the source file and rerun Pro*Ada.

PCC-01511 Identifier on line number in file string too long for code generated in file string

Cause: An identifier used in the host program is of a length that causes precompiler-generated code to exceed the length limitation on source lines.

Action: Use a shorter identifier or use the ORECLEN option to increase the allowed line length.

PCC-01512 Invalid EXEC SQL INCLUDE of file string found at line number in file string

Cause: The EXEC SQL INCLUDE statement is not allowed in Pro*Ada.

Action: Embed required source text directly in the Pro*Ada file. Use the "with" context clause to include required packages.

PCC-01513 FIPS warning: Unsupported datatype in line number of file string

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a host variable was declared with a non-ANSI/ISO standard type.

Action: No action required. However, for ANSI/ISO compliance, use only ANSI/ISO standard types.

PCC-01515 FIPS warning: Undeclared host variable "string" at line number in file string

Cause: An Oracle extension to the ANSI/ISO SQL standard was used. Specifically, a host variable was declared outside of a DECLARE section.

Action: No action required. However, for ANSI/ISO compliance, declare the host variable within a DECLARE section.

PCC-02010 found end-of-file while scanning string literal

Cause: A string in a SQL statement, which should be delimited by single quotation marks, was not terminated properly.

Action: Check that all strings are delimited.

PCC-02011 found identifier greater than 128 characters (truncated)

Cause: The precompiler found an identifier that was too long.

Action: Shorten the identifier. SQL identifiers should be limited to 128 characters.

PCC-02012 did not find matching quote for char constant

Cause: A character constant with a single quotation mark was not terminated.

Action: Terminate the character constant.

PCC-02013 unknown escape sequence

Cause: The precompiler found an escape sequence that it could not process inside a string literal. This error can arise when multibyte character strings that can contain shift-in or shift-out escape sequences are used.

Action: Correct the string representation.

PCC-02014 Syntax error at line number, column number, file string:

Cause: The precompiler detected an error in C or embedded SQL syntax. This message is followed by a more specific error message.

Action: Correct the syntax error.

PCC-02015 unable to open include file

Cause: The precompiler could not open a header file that was specified using the #include preprocessor directive or the EXEC SQL INCLUDE statement. This can happen if the file specification is inaccurate or if read permission or read access rights on the file or on one or more of the directories in the path were not granted.

Action: Make sure the file specification is correct, that the file exists, and that read permission has been granted so that the file can be read.

PCC-02016 include file pathname is too long

Cause: The path name for include files exceeded the maximum length of 80 characters.

Action: Move the include file, or create an environment variable or logical to shorten the path name.

PCC-02017 unable to open output file

Cause: The precompiler could not open an output file. This could be a generated code output file (.c file) or a listing file. This message can result from many causes. For example:

  • A path name for a specified output file contains a non-existent directory.
  • An operating-system error occurred because the file system or disk is full.
  • Write permission on the specified directory or directories in the path do not exist.

Action: Track down the cause of the error, as suggested above, and correct it.

PCC-02018 found end-of-file while scanning comment

Cause: A C comment either in C code or in an embedded SQL statement, was not terminated.

Action: Find the unterminated comment and terminate it with */.

PCC-02019 Preprocessor warning at line number, column number, file string:

Cause: A warning condition occurred as the precompiler was doing the preprocessor pass. A more specific warning message will follow this message.

Action: Correct the condition according to the action specified for the message that follows.

PCC-02020 Preprocessor error at line number, column number, file string:

Cause: An error condition occurred as the precompiler was in the preprocessing phase. A more specific error message will follow this message.

Action: Correct the error according to the action specified for the message that follows.

PCC-02021 Found newline while scanning string literal

Cause: A string constant contains a newline character, For example:

char x[] = "Hello world";

Action: Remove the newline character.

PCC-02022 Found end of file while scanning a SQL statement

Cause: The precompiler encountered an end of file while parsing an EXEC SQL statement.

Action: Add statement terminator(;) or complete the EXEC SQL statement.

PCC-02023 Found end of file while scanning a PL/SQL statement

Cause: The precompiler encountered an end of file while parsing a PL/SQL statement (EXEC SQL EXECUTE ...).

Action: Complete the PL/SQL statement.

PCC-02035 CMD-LINE: CONFIG= option is invalid in a config file

Cause: A user configuration file inside a user configuration file cannot be specified. That is, nested configuration files cannot be nested.

Action: If there are nested configuration files, move the options from the nested files to the top levels.

PCC-02040 CMD-LINE: Option selected, but no value provided

Cause: An option on the command line was specified, but a value for it was not included. For example, the offending code might look like:

proc iname=sample1.pc oname=

Action: Provide a value for the option.

PCC-02041 CMD-LINE: Option does not exist:

Cause: A non-existent option was specified on the command line.

Action: Refer to your language-specific Precompiler Programmer's Guide for a list of the valid command line options and their possible values.

PCC-02043 CMD-LINE: Option syntax is incorrect

Cause: A value for a command line option was incorrectly specified.

Action: Refer to your language-specific Precompiler Programmer's Guide for the correct syntax for specifying command line option values.

PCC-02044 CMD-LINE: Illegal or out of range value for option:

Cause: A value specified for a command line option was not within the accepted range. For example, the range for the MAXOPENCURSORS option is 5 to 256. If a value outside the range is specified, the message is triggered.

Action: Refer to your language-specific Precompiler Programmer's Guide for the ranges that option values can take.

PCC-02045 CMD-LINE: Option is not unique:

Cause: An option name was partially specified on the command line that made it non unique. For example, in:

% proc in=t.pc

the "in" option can imply either the INAME or INCLUDE option.

Action: Provide sufficient characters on the command line to make the option name unique.

PCC-02046 CMD-LINE: Unable to open config file:

Cause: A non-existent user configuration file was specified on the command line with the configuration option.

Action: Provide a valid filename for the configuration file.

PCC-02047 CMD-LINE: Option is not allowed inline:

Cause: An option was entered inline that can only be entered on the command line or in a configuration file. For example, the offending code might look like:

EXEC ORACLE OPTION (NLS_CHAR=name);

The NLS_CHAR option can only be entered on the command line or in a configuration file.

Action: Remove the option from the source file, and specify it on the command line.

PCC-02066 CMD-LINE: Could not find or could not open system config file

Cause: The system configuration file has a standard name (PMSCFG.H) and a location that is operating system-dependent. On UNIX systems, it is located in the ORACLE_HOME/proc directory. If a file named PMSCFG.H is not found in the standard location, this warning message is issued.

Action: Create a system configuration file in the standard location. The file can be empty. See also the operating system-specific Oracle documentation.

PCC-02081 CMD-LINE: Unterminated option value list or value list was truncated.

Cause: An option that takes a list of values was entered. The value list did not have a closing parenthesis. This error may also occur if the list of values entered on a single line was too long and Pro*C truncated it.

Action: Ensure that all value lists are terminated with a closing parenthesis. Split long value lists into individual entries.

PCC-02100 Unable to initialize PL/SQL

Cause: The precompiler connected to Oracle but could not invoke the PL/SQL engine. This error can result if an earlier release of Oracle7 is used without the Procedural Option.

Action: To use PL/SQL, upgrade to a more recent release of Oracle7.

PCC-02101 Unable to open input file

Cause: The precompiler could not open the input file. This is the .pc file specified in the INAME=option. This means that the file does not exist, that a directory was incorrectly specified in the path name, or that the person running the precompiler does not have read permission for the file. This message could also result from operating-system errors. For example, an unmounted file system or disk I/O errors, could trigger this error.

Action: Check that permission to read the file exists and that the full path name has been specified correctly. Check for operating system problems. See also the operating system-specific Oracle documentation.

PCC-02102 Fatal error while doing C preprocessing

Cause: The precompiler issues this message after a more specific message.

Action: Correct the problem specified in the previous message or messages.

PCC-02103 Password:

Cause: The username was specified on the command line without a password. For example:

proc sqlcheck=full iname=sample1.pc userid=scott

Action: Re-enter the command line, and include the password or specify the password when prompted.

PCC-02104 Unable to connect to Oracle

Cause: The precompiler could not connect to Oracle with the username, password, and, if applicable, database link that was supplied. Note that this is a precompiler message, not a runtime message. This means that the USERID option value, either on the command line or in a configuration file, was incorrect.

Action: Check that the username and password are current and correct. Run SVRMGR or SQL*Plus and verify that connection can be made using that username and password.

PCC-02105 Unable to open list file

Cause: The precompiler could not open the listing file. This message can result from many causes. For example:

  • A path name for a specified listing file contains a non-existent directory.
  • An operating-system error occurred because the file system or disk is full.
  • Write permission on the specified directory has not been granted.

Action: Track down the cause of the error, as suggested above, and correct it.

PCC-02106 Userid only used when SQLCHECK = FULL, userid ignored.

Cause: The USERID option was specified on the command line, but SQLCHECK was not equal to FULL or SEMANTICS. The USERID has no effect, unless SQLCHECK=FULL or SQLCHECK=SEMANTICS. This is a warning message only.

Action: No action required.

PCC-02107 You may not specify PARSE = FULL when CODE = CPP

Cause: The PARSE=FULL and CODE=CPP options were both specified on the command line. The PARSE=FULL option invokes the C parser which does not understand any C++ constructs generated by the precompiler with CODE=CPP option.

Action: Set the PARSE option to either NONE or PARTIAL if the CODE=CPP option is specified.

PCC-02108 UNSAFE_NULL=YES allowed if MODE=ORACLE and DBMS=V7 or V8

Cause: UNSAFE_NULL=YES was specified on the command line, but either the MODE was not ORACLE or the DBMS was not V7 or V8.

Action: Specify MODE=ORACLE and DBMS=V7 or V8 when using UNSAFE_NULL=YES.

PCC-02109 SQLCHECK=NONE is no longer supported.. using SYNTAX

Cause: SQLCHECK=NONE was specified on the command line but is no longer a supported option. SQLCHECK=SYNTAX was used instead.

Action: This is a warning message only. To avoid this warning, specify SQLCHECK=SYNTAX or SQLCHECK=SEMANTICS.

PCC-02110 DBMS=V6_CHAR is deprecated. Use CHAR_MAP=VARCHAR2, DBMS=V7 instead

Cause: DBMS=V6_CHAR was specified on the command line but is no longer a supported option. The options CHAR_MAP=VARCHAR2 and DBMS=V7 were used instead.

Action: This is a warning message only. To avoid this warning, specify CHAR_MAP=VARCHAR2 and, if required, DBMS=V7.

PCC-02111 CHAR_MAP option ignored. Only CHAR_MAP=VARCHAR2 allowed for DBMS=V6

Cause: DBMS=V6 was specified, and CHAR_MAP was specified with a value other than VARCHAR2. The CHAR_MAP value is ignored.

Action: This is a warning message only. To avoid this warning, specify a DBMS value other than DBMS=V6 or use CHAR_MAP=VARCHAR2.

PCC-02112 OBJECTS option ignored. OBJECTS=YES is not allowed for DBMS=V6 or V7.

Cause: OBJECTS=YES was specified on the Pro*C command line, but the DBMS option value was not valid.

Action: This is a warning message only. To avoid this warning for OBJECTS=YES, use DBMS=V8 or DBMS=NATIVE with a V8 database.

PCC-02113 DBMS=V6 no longer supported; using DBMS=NATIVE, CHAR_MAP=VARCHAR2.

Cause: DBMS=V6 was specified on the command line, but is no longer a supported option value. The options DBMS=NATIVE and CHAR_MAP=VARCHAR2 were used instead.

Action: Check your program to verify that you are not depending on any V6 behavior. Refer to the Pro*C/C++ Precompiler Programmer's Guide for effects of specifying DBMS=V6.

PCC-02114 Command line argument MODE=ANSI may not be used with DBMS=V6

Cause: The semantics of certain operations (such as character comparison) in Oracle version ^ are not 100% compliant with the ANSI/ISO SQL standards. When V6 semantics are requested, using the DBMS=V6 or DBMS=V6_CHAR option, precompilation with MODE=ANSI is not permitted.

Action: Do not use ANSI mode with V6 options.

PCC-02115 Unable to open output file for writing

Cause: An attempt was made to precompile a header file where the output data file could not be opened (or created) for writing.

Action: Check for appropriate permissions on the directory and possibly file objects (if a data file already exists) to make sure that write permissions have been granted.

PCC-02116 You must specify a file extension using the HEADER option

Cause: An attempt was made to precompile a header file without specifying the name of the extension to use when creating the generated data file.

Action: Use the HEADER option to specify the name of a file extension to use when creating a data file for a precompiled header.

PCC-02129 CMD-LINE: Client supplied static options table is invalid

Cause: This is an internal error message not usually issued.

Action: Call Oracle Support Services.

PCC-02132 CMD-LINE: Could not allocate memory

Cause: This is an internal error message not usually issued.

Action: Call Oracle Support Services.

PCC-02133 CMD-LINE: Error in string processing function

Cause: This is an internal error message not usually issued. It indicates that a C string function, such as STRCPY or STRLEN, returned an error.

Action: Call Oracle Support Services.

PCC-02134 CMD-LINE: Null option supplied

Cause: A zero length option was specified on the command line.

Action: Re-enter the command line with a valid option.

PCC-02135 CMD-LINE: User asked for help

Cause: This is a final message that the precompiler issues when information about the command line options has been requested. For example, if the command proc ? is issued to get a list of current default values for the command line options, this message appears at the end of the list.

Action: No action required.

PCC-02138 CMD-LINE: Internal consistency error

Cause: This is an internal message for program exceptions. An unexpected condition was encountered by the command-line processor and a consistency check failed. Some possible causes of this message include:

  • invalid command-line options
  • memory corruption

Action: Report this error to Oracle Support Services after gathering the following information:

  • the events that led to the error
  • the attempted operations that led to the error
  • any unusual circumstances prior to this error

PCC-02144 CMD-LINE: Blank characters are not allowed on either side of an equal sign (=)

Cause: An equal sign (=) was either immediately preceded or followed by a blank character.

Action: Precompile your program again without blank characters on either side of any equal sign (=) on the command line.

PCC-02150 Error at line number, column number in file string

Cause: An error was encounter at the given location.

Action: Check the named source file and correct the error using the additional information which follows this error message.

PCC-02151 Line number column number file string:

Cause: An error was encounter at the given location.

Action: Check the listed source file and correct the error using the additional information which follows this error message.

PCC-02152 Unable to open file string to display or list the source line number

Cause: The file contains an error, but could not be reopened to list or display the incorrect line.

Action: Check that the file is intact and it has read permission. Then rerun the operation.

PCC-02153 Open file: string

Cause: A new source file was opened while producing the list file.

Action: No action required; this is an informational message.

PCC-02154 Close file: string

Cause: A source file was closed while producing the list file.

Action: No action required; this is an informational message.

PCC-02200 found unrecognized punctuation sequence

Cause: The error indicates that the precompiler parser encountered a badly-formed identifier or keyword.

Action: Correct the syntax.

PCC-02201 Found syntax error

Cause: This general message precedes one or more specific messages that detail the nature of the error.

Action: No action required. Correct the errors diagnosed in the following message(s).

PCC-02202 No typedef name was given

Cause: The precompiler parser encountered a TYPEDEF statement that had no name after the type specification. For example:

typedef int;

Action: Correct the syntax.

PCC-02203 found end of file when not expected

Cause: The parser can emit this message when a general syntax error occurs, for example, an unmatched '{' or '('.

Action: Correct the syntax.

PCC-02204 EXEC SQL INCLUDE not permitted from within an included file

Cause: EXEC SQL INCLUDE statements cannot be nested. Also, EXEC SQL INCLUDE statement cannot be put inside a file that is included using the #include preprocessor command.

Action: Recode the program so that the nested include statement is not required.

PCC-02205 Parser error at line number, column number, file string:

Cause: The precompiler parser encountered a syntax error, either in C code or in SQL code. A more specific message should follow.

Action: No action required for this message. Take the appropriate action for any following messages.

PCC-02206 Host variables are not permitted within a DDL statement

Cause: A Data Definition Language statement cannot use host variables. For example, the statement:

CREATE TABLE :table_name  (c1 char(10));

is illegal, because the name of the table in a CREATE TABLE statement cannot be represented using host variable.

Action: Use dynamic SQL to create the names of database objects (tables, views, columns, and so on) at runtime. See the language-specific Precompiler Programmer's Guide for information about dynamic SQL.

PCC-02207 Invalid macro name

Cause: The precompiler parser encountered a #define directive that had no macro name associated with it. For example:

#define

Action: Correct the syntax.

PCC-02208 No filename specified in #include statement

Cause: The precompiler parser encountered a #include directive that had no filename associated with it. For example:

#include

Action: Specify appropriate filename with the #include directive, or correct the syntax.

PCC-02209 Macro invocation has incorrect number of arguments

Cause: A macro invocation in the source does not have the same number of arguments as the macro definition in the #define line.

Action: Correct the macro reference or the macro definition.

PCC-02210 C++ punctuation sequences are not permitted

Cause: C++ punctuation sequences are not supported by the ProC/C++ precompiler.

Action: Rewrite your C++ code without using punctuation sequences and precompile it again.

PCC-02301 cannot reopen input file for reading

Cause: The semantic analysis phase of the precompiler could not reopen the input file to generate the output code.

Action: Check that the input file and its directory protection and privileges do not change during precompilation.

PCC-02302 cannot open code generation output file "string"

Cause: Pro*C was unable to open one or both temporary files required for code generation. The user executing the precompiler must have write permission (and/or the appropriate privileges) on the current directory.

Action: Check that permission exists to create files in the directory where you precompile.

PCC-02303 cannot open include file

Cause: The precompiler was not able to open a header file specified using the #INCLUDE preprocessor directive or the EXEC SQL INCLUDE statement. This can happen if the file specification is inaccurate or if read permission or read-access rights on the file or on one or more of the directories in the path have not been granted.

Action: Recheck that the file specification is correct, that the file exists, and that read permission has been granted so that the file can be read.

PCC-02304 invalid declaration of C function

Cause: A C function using invalid syntax was declared.

Action: Consult a C programming manual and correct the declaration.

PCC-02305 illegal mixing of new and old style C function declarations

Cause: All C functions using either the traditional style (K&R style) function declarations or the new (ANSI) style must be declared; the two styles cannot be mixed.

Action: Adopt a consist declaration style for functions.

PCC-02306 illegal name of C function

Cause: A C function was declared with a name that is not a legal C identifier.

Action: Use legal C identifiers for all function names.

PCC-02307 void can only be used when single parameter

Cause: A function can be declared or defined using the following syntax:

int func1(void)

to indicate that the function has no parameters. void can be used only once in this case.

Action: Remove the extra voids in the function definition or declaration.

PCC-02308 identifier required in this function declaration

Cause: A function definition written in ANSI C must have both the name and the type for all parameters.

Action: Rewrite the function definition so that it contains the name of each parameter.

PCC-02309 illegal formal parameter declaration

Cause: A formal parameter to a function was specified without giving its type.

Action: Rewrite the function declaration and include types of all parameters in function declarations.

PCC-02310 formal parameter VARCHARs should be declared as pointers

Cause: Many C compilers allow structures to be passed to and returned from functions. Although a VARCHAR is implemented as a C struct, VARCHARs must be passed to a function as pointers.

Action: Take the address of a VARCHAR when it is passed to a function. See the Pro*C/C++ Precompiler Programmer's Guide for more information.

PCC-02311 cannot have VARCHAR bit fields

Cause: Host variables cannot contain bit fields.

Action: Recode the application to remove the bit fields.

PCC-02312 arrays of VARCHAR greater than 2 dimensions not allowed

Cause: A VARCHAR variable having more that 2 dimensions was declared. Multidimensional arrays are not supported as host variables.

Action: Recode the application to remove multidimensional array usage.

PCC-02313 malformed VARCHAR declaration - missing length

Cause: When a VARCHAR is declared, a length specification is mandatory. For example, the following VARCHAR declaration is meaningless, hence illegal:

VARCHAR v1[];

Action: Specify the length for each declared VARCHAR.

PCC-02314 cannot evaluate constant sizeof expression

Cause: A SIZEOF operator was used where a precompiler expression was expected. For example, as the length of a varchar.

Action: Eliminate the SIZEOF operator in this instance.

PCC-02315 cannot evaluate expression as constant

Cause: The specified expression does not evaluate to a constant. Such expressions are required, for example, as the length of a VARCHAR.

Action: Replace the expression with one that does evaluate to a constant integer.

PCC-02316 illegal operator in constant expression

Cause: A non-arithmetic operator was present in a constant expression.

Action: Rewrite the expression to eliminate the non-arithmetic operator.

PCC-02317 illegal cast type expression

Cause: An illegal cast is present in the expression.

Action: Remove the illegal cast.

PCC-02318 missing type expression

Cause: The specified expression is missing the declaration of a type.

Action: Specify a type for the expression.

PCC-02319 expression type does not match usage

Cause: The type of a variable does not match is usage. For example, in dynamic SQL, a host variable containing the text of a SQL statement must be declared as a C character type or be equivalenced to the SQL type STRING.

Action: Remove the declaration.

PCC-02320 arithmetic expression does not have correct operand types

Cause: The arithmetic expression must be specified with integral types.

Action: Rewrite the expression using integral types.

PCC-02321 only subtraction between two pointers is permitted

Cause: Pointer values cannot be added, multiplied, or divided. The only arithmetic operation permitted with pointers is subtraction.

Action: Recode to avoid this error message.

PCC-02322 found undefined identifier

Cause: An identifier used in a SQL statement was not defined. For example, a cursor name was referenced that had not been declared, or in a DECLARE CURSOR statement, a statement name was used that had not been PREPAREd.

Action: Check that all SQL identifiers, such as cursor names and statement names, have been defined before use. Provide a declaration for the variable and/or its type identifier.

PCC-02323 found typedef name used in an expression (expecting a value)

Cause: The name of a TYPEDEF was found where a variable was expected.

Action: Rewrite the expression and remove the reference to the TYPEDEF.

PCC-02324 found variable name used as a typedef name

Cause: The name of a variable was found where a TYPEDEF was expected.

Action: Rewrite the expression and specify the correct TYPEDEF reference.

PCC-02325 illegal indirection operation

Cause: An attempt was made to use a non-pointer type as a pointer.

Action: Rewrite the expression.

PCC-02326 illegal structure reference operation

Cause: A structure component using invalid syntax was referenced. For example, a -> operator was used instead of a required `.' operator.

Action: Correct the invalid reference.

PCC-02327 struct or struct pointer required

Cause: A scalar host variable was used in a context where a structure (or its pointer) is required.

Action: Make the host variable a structure or add more scalar host variables to satisfy the SQL syntax requirements.

PCC-02328 undefined struct member

Cause: A structure component was referenced that was not declared as part of the structure.

Action: Redefine the structure member.

PCC-02329 found reference to undeclared function

Cause: A function was referenced that was not declared. All function references must be declared.

Action: Declare the function.

PCC-02330 expecting an expression of integer type

Cause: The expression does not evaluate to an integer. For example, a SQL FOR expression must evaluate to an integral type.

Action: Rewrite the expression.

PCC-02331 undefined SQL identifier

Cause: All SQL identifiers must be declared before they are used. This message can result when a CURSOR or STATEMENT is not declared (defined) before being referenced.

Action: Define the SQL identifier before it is used.

PCC-02332 attempted to redefine SQL identifier

Cause: A SQL identifier (such as a cursor name) can be defined only once.

Action: Do not redefine the SQL identifier. Use a different name.

PCC-02333 SQL identifier was not declared as a statement

Cause: A SQL statement identifier was referenced in a DECLARE... CURSOR statement that was not PREPAREd.

Action: Check that all SQL statement names have been declared. Remember that SQL statement names are identifiers, not variables, and that they are local to the precompilation unit.

PCC-02334 SQL identifier was not declared as a cursor

Cause: A cursor name was used in an OPEN, FETCH, or CLOSE statement that had not been DECLAREd.

Action: Check that all SQL cursor names have been declared. Remember that cursors are identifiers, not variables, and that they are local to the precompilation unit.

PCC-02335 body of cursor must name statement identifier

Cause: In a Dynamic SQL Method 4 application, the DECLARE... CURSOR statement must name a statement identifier that has been PREPAREd in a preceding statement. The PREPARE statement must physically (not logically) precede the DECLARE command.

Action: This error message is followed by another message that gives the line and column of the reference to the statement. Recode the application.

PCC-02336 host variable expression has invalid type

Cause: The host variable was declared using a C type that is not permitted as a host variable. See the Pro*C/C++ Precompiler Programmer's Guide for a list of the permissible C types for host variables.

Action: Use a permissible host variable type.

PCC-02337 cannot declare multi-dimensioned array for this type

Cause: Host variable arrays of scalars with more than 1 dimension cannot be declared. The only host variables allowed to be multi-dimensioned are CHAR and VARCHAR.

Action: Rewrite the variable declaration.

PCC-02338 structure contains a nested struct or union

Cause: A structure used as a host variable may not have structures or unions nested within it.

Action: Rewrite the variable declaration.

PCC-02339 host variables cannot be of union types

Cause: A C union as a host variable cannot be used.

Action: This error message is followed by another message that gives the line and column of the reference to the illegal union. Recode, using a struct or individual scalar host variables.

PCC-02340 structure contains a bit field

Cause: Bit fields are not allowed in host variables because they are meaningless for database DML operations.

Action: This error message is followed by another message that gives the line and column of the reference to the offending host variable. Recode the application.

PCC-02341 host variable has illegal type

Cause: A host variable has an type that is not permitted (that is, ENUM, VOID, and so on).

Action: Rewrite the host variable declaration, using a permissible host variable type.

PCC-02342 using WHERE CURRENT OF on cursor defined without FOR UPDATE clause

Cause: When MODE=Oracle, a cursor defined with a WHERE CURRENT OF clause must also have a FOR UPDATE clause.

Action: Rewrite the cursor definition.

PCC-02343 body of cursor must be a query expression

Cause: A cursor definition must be a SELECT statement.

Action: Rewrite the cursor definition.

PCC-02344 Host variable array size mismatch. Using minimum: number

Cause: Host variable arrays in a single statement should all be of equal size.

Action: Redefine the bind variable array lengths to all be the same size.

PCC-02345 SQLCHECK=SEMANTICS must be given when embedded PL/SQL blocks are used

Cause: Embedded PL/SQL blocks require that the command-line flag SQLCHECK=SEMANTICS is used.

Action: Use the SQLCHECK=SEMANTICS option. This also requires that the USERID connect option be given.

PCC-02346 PL/SQL found semantic errors

Cause: A database entity, such as a table or column name, was referenced, that does not exist. This is a compile time error, not a runtime error.

Action: Check that all referenced objects in PL/SQL statements actually exist and that the necessary access permission on them have been granted.

PCC-02347 PL/SQL found syntax errors

Cause: A PL/SQL statement was used illegally.

Action: Check the PL/SQL User's Guide and Reference for the correct syntax.

PCC-02348 indicators are not allowed in EXEC IAF statements

Cause: Indicator variables associated with host variables cannot be used in EXECIAF statements such as GET and PUT in a user exit.

Action: Eliminate the indicator variable. If feasible (for example with Forms V4), use EXEC TOOLS statements, which do allow indicator variables. See the Pro*C/C++ Precompiler Programmer's Guide for more information.

PCC-02349 precision must be specified for this type

Cause: In a VAR or TYPE statement, certain Oracle types require that the precision be specified. For example, VARCHAR2 or CHAR.

Action: Indicate the precision.

PCC-02350 cannot equivalence this SQL type

Cause: Datatype or variable equivalencing to the datatypes NUMBER or DECIMAL cannot be used. See the Pro*C/C++ Precompiler Programmer's Guide for more information.

Action: Use the appropriate datatype for the application.

PCC-02351 illegal datatype equivalencing operation

Cause: The datatype specified could not be equivalenced, or the syntax was incorrect in the VAR or TYPE statement.

Action: See the Pro*C/C++ Precompiler Programmer's Guide for a list of the datatypes that can be equivalenced and the correct syntax of the VAR or TYPE statement.

PCC-02352 out of bounds bind position from PL/SQL

Cause: PL/SQL requested a bind position that does not exist.

Action: Contact Oracle Support Services.

PCC-02353 Semantic error at line number, column number, file string:

Cause: This error message precedes a more specific error message.

Action: No action required. Correct the error(s) reported in the following message(s).

PCC-02354 A file included with #include may not contain SQL statements

Cause: The Pro*C Precompiler reads header files referenced in #INCLUDE directives and uses the values defined in them. But the precompiler never generates code using statements in header files, so use of SQL statements in these files is illegal.

Action: Move the SQL statement(s) into the main body of the application or use EXEC SQL INCLUDE to check that the included file is precompiled.

PCC-02355 Invalid or obsolete option, ignored

Cause: A command-line option that is not used in Pro*C Release 2.0 was specified. For example, the option AREASIZE is no longer valid with precompilers used with the Oracle7 Server.

Action: No action required. This is an informational message.

PCC-02356 Warning at line number, column number, file string:

Cause: This is a generic warning message. It precedes a more specific warning.

Action: No action required. Correct the error(s) indicated in the following message(s).

PCC-02357 Function calls may not be used as host variable expressions

Cause: Only objects that are LVALUES (that resolve to an address) can be host variables. Because a function call is not an LVALUE, one cannot be used in place of a host variable.

Action: Recode the application.

PCC-02358 Identifier following ARRAYLEN must be the name of an array

Cause: A declared array must be specified as the argument for an ARRAYLEN statement. Declare the array textually before the ARRAYLEN statement. See the Pro*C/C++ Precompiler Programmer's Guide for the syntax of the ARRAYLEN statement.

Action: Correct the statement, specifying a host array as the argument.

PCC-02359 Identifier specifying ARRAYLEN must be a 4-byte integer

Cause: The expression that specifies the ARRAYLEN dimension must evaluate to an integer. For example, the statement EXEC SQL ARRAYLEN my_array(1,3) cannot be parsed.

Action: Correct the statement, using an integral dimension.

PCC-02360 This array type is invalid for use with ARRAYLEN statement

Cause: Arrays of some host variables types are not allowed and hence also cannot be used in ARRAYLEN statements. VARCHAR and DATE are examples.

Action: Specify an array with a datatype that can be used in host arrays.

PCC-02361 Use of ARRAYLEN with SQL bind arrays is ignored

Cause: ARRAYLEN is only valid with arrays that can be bound in PL/SQL blocks.

Action: Use an appropriate array type.

PCC-02362 Host variable not declared within SQL DECLARE section

Cause: When MODE=ANSI is specified at precompile time, all host variables must be declared inside Declare Sections. Remember that MODE=ANSI refers to ANSI SQL, not ANSI C.

Action: Add the EXEC SQL BEGIN DECLARE SECTION... EXEC SQL END DECLARE SECTION statements around all host variable declarations.

PCC-02363 Indicator variable must be a structure

Cause: If a host variable is a structure, the associated indicator variable must also be a structure.

Action: Recode the application to create an indicator variable as a structure.

PCC-02364 Host struct and its indicator must have the same number of fields

Cause: When a structure containing indicator variables is declared and associated with a host structure, the indicator structure must contain the same number of fields as the host structure. This is so even when some of the indicators will not be used or even when it would not make sense to do so (for fields constrained as NON NULL, for example).

Action: Redeclare the indicator variable with the correct number of fields.

PCC-02365 Indicator array size cannot be smaller than host array size

Cause: An indicator array must have dimension greater than or equal to the corresponding host variable array dimension.

Action: Change the dimension of the indicator array.

PCC-02366 Command line argument MODE=ANSI may not be used with DBMS=V6

Cause: The semantics of certain operations (such as character comparison) in Oracle version ^ are not 100% compliant with the ANSI/ISO SQL standards. When V6 semantics are requested, using the DBMS=V6 or DBMS=V6_CHAR option, precompilation with MODE=ANSI is not permitted.

Action: Do not use ANSI mode with V6 options.

PCC-02367 This indicator variable must be declared as type short

Cause: An indicator for a host variable of this type must have the C type short. An array of such indicators must be an array of shorts.

Action: Declare the indicator variable or indicator array as type short.

PCC-02368 An EXEC TOOLS host variable context name is not type char

Cause: If a host variable is used to define a context name in an EXEC TOOLS GET CONTEXT or EXEC TOOLS SET CONTEXT statement, that host variable must be of a character type.

Action: Redeclare the context name to a host variable of a char type.

PCC-02369 An EXEC TOOLS host pointer variable is not a pointer

Cause: The host variable specifying an EXEC TOOLS context must be a pointer type.

Action: Redeclare the variable, making sure that it is a pointer.

PCC-02370 An EXEC TOOLS MESSAGE host variable is not type char

Cause: f a host variable is used to define a context name in an EXEC TOOLS GET CONTEXT or EXEC TOOLS SET CONTEXT statement, that host variable must be of a character type.

Action: Declare the message to a host variable of a char type.

PCC-02371 Illegal FOR clause

Cause: The argument of a FOR clause must be specified as an integer or as an identifier containing an integer.

Action: Rewrite the FOR clause.

PCC-02372 FOR clause not allowed in SELECT statement

Cause: A SQL statement containing a SELECT command cannot contain a FOR clause. The meaning of such a statement would be unclear.

Action: Rephrase the SELECT statement, removing the FOR clause.

PCC-02373 Invalid declaration in EXEC SQL DECLARE section

Cause: An improper declaration was placed in a DECLARE section. This message is usually caused by including an EXEC SQL TYPE or EXEC SQL VAR declaration in a DECLARE section.

Action: Move the declaration outside of the SQL DECLARE section.

PCC-02374 SQLCHECK value exceeds command line value

Cause: The value given to the SQLCHECK option in an EXEC ORACLE statement in a program was greater than the value given either on the command line or greater than the default value if no SQLCHECK option was given on the command line. The order of the option values is SEMANTICS>SYNTAX>NONE. When this warning message is issued, the original value of SQLCHECK (the default or the command-line value) stays in effect.

Action: Remove or recode the EXEC Oracle option(s) in the .PC source file to avoid this warning message.

PCC-02375 SQL statement found outside the body of a function

Cause: A SQL statement other than a declarative, datatype equivalence or WHENEVER statement was found outside the body of a function when PARSE=FULL.

Action: Move the SQL statement inside the body of a function.

PCC-02376 You may not declare SQLCODE when DEF_SQLCODE = TRUE

Cause: The DEF_SQLCODE option may not be specified if a SQLCODE declaration already explicitly appears in the program.

Action: Remove the SQLCODE declaration from the program or specify DEF_SQLCODE=NO (the default).

PCC-02377 Arrays of implicit varchars are not permitted

Cause: An array of implicit VARCHARS was declared when HOST_VARCHAR=TRUE.

Action: Rewrite the implicit VARCHAR declaration without using arrays.

PCC-02378 Invalid type for National Language character variable

Cause: A variable declared as a National Language character using the NLS_CHAR option was not declared as a char or implicit VARCHAR.

Action: Declare the variable as a char or implicit VARCHAR or do not specify using the NLS_CHAR option.

PCC-02379 Cannot equivalence National Language character variables

Cause: A National Language character variable (specified using the NLS_CHAR option) has undergone datatype equivalencing using either the EXEC SQL VAR or TYPE statements.

Action: Do not equivalence National Language character variables.

PCC-02380 Cannot specify a connect mode when altering a user password

Cause: An attempt was made to connect in either SYSOPER or SYSDBA mode while at the same time trying to change passwords using the ALTER AUTHORIZATION clause in the same CONNECT statement.

Action: Changing passwords while connecting in SYSOPER or SYSDBA mode is prohibited. Rewrite the connect statement by either removing the ALTER AUTHORIZATION clause or the CONNECT MODE clause.

PCC-02382 You must specify MODE=ANSI when using NLS_LOCAL=YES

Cause: NLS_CHAR was used to specify NLS multi-byte character variables without specifying MODE=ANSI.

Action: Specify MODE=ANSI on the command line when using NLS_LOCAL=TRUE.

PCC-02383 Expecting an expression of type OCIExtProcContext

Cause: The type of the bind variable given in a REGISTER CONNECT USING statement was not (pointer to) OCIExtProcContext.

Action: Declare a variable having type (pointer to) OCIExtProcContext and use it in the REGISTER CONNECT USING statement.

PCC-02384 Missing array length specifier

Cause: An array declaration was given without an array length specifier.

Action: Provide the length for the array declaration.

PCC-02385 CHAR_MAP disallowed when using NLS_CHAR and NLS_LOCAL=TRUE

Cause: The CHAR_MAP option was specified while indicating which host variables are to be treated by the precompiler as NLS multi-byte character variables. This mapping cannot be performed with the option NLS_LOCAL=TRUE. This error also occurs when DBMS=V6 is used in conjunction with NLS_CHAR and NLS_LOCAL=TRUE.

Action: Remove either the CHAR_MAP option or set NLS_LOCAL=FALSE. Ensure that DBMS is not set to V6.

PCC-02386 Use of the AT clause is not permitted here

Cause: An explicit AT clause was used with an ALLOCATE statement or a FETCH/CLOSE statement also using a SQL_CURSOR declaration.

Action: Remove the AT clause.

PCC-02387 Expecting an expression of type sql_cursor

Cause: A host bind variable was used in an ALLOCATE, FETCH or CLOSE statement that was not declared as a result set SQL_CURSOR.

Action: Declare the variable to be of type SQL_CURSOR.

PCC-02388 Arrays not allowed in FROM/WHERE clause of SELECT statement

Cause: A host array was used in the WHERE clause of a SELECT-INTO statement.

Action: Rewrite the SELECT statement without using arrays or use a cursor.

PCC-02389 Arrays not allowed as input bind variables in SELECT list

Cause: A host array was used in the SELECT list of a SELECT-INTO statement.

Action: Rewrite the SELECT statement without using arrays in SELECT list.

PCC-02390 No EXEC SQL CONTEXT USE statement encountered

Cause: No EXEC SQL CONTEXT USE statement was encountered and the option THREADS=YES was requested.

Action: Ensure that the necessary context variable (of type SQL_CONTEXT) has been declared and that has been ALLOCATEd and USEd prior to any executable SQL statements.

PCC-02391 Runtime context variable not of correct type

Cause: The host variable in a EXEC SQL CONTEXT USE statement or in the RETURNING clause of a REGISTER CONNECT statement was not declared to be of type SQL_CONTEXT.

Action: Declare the runtime context variable to be of type SQL_CONTEXT.

PCC-02392 You are already in an EXEC SQL DECLARE SECTION

Cause: A SQL DECLARE SECTION appears nested inside another one.

Action: Do not nest DECLARE SECTIONS. Remove any nested inner ones.

PCC-02393 SQL statement found inside an EXEC SQL DECLARE SECTION

Cause: An executable SQL statement appears inside a DECLARE SECTION.

Action: Move the SQL statement into the body of a function.

PCC-02394 Input file name and output filename are identical

Cause: The values of INAME and ONAME are the same or the default output filename is the same as that specified by ONAME.

Action: Use ONAME to specify a different filename for the output file.

PCC-02395 Using arrays of structs requires that the struct be named

Cause: An array of some unnamed struct was used as a host variable. When using arrays of structs, the struct requires a name or tag.

Action: Provide a name for the struct.

PCC-02396 Illegal use of arrays inside an array of structs

Cause: An array of a struct that contained arrays of scalars or two-dimensional char or VARCHAR fields was used as a host variable.

Action: Rewrite the struct so that there are no scalar arrays or two-dimensional char or VARCHAR fields.

PCC-02397 VARCHAR declarations not permitted in #include file

Cause: A VARCHAR declaration was found in a file included using a #include form.

Action: Use the EXEC SQL INCLUDE form to include files with VARCHAR declarations instead.

PCC-02398 Indicator ignored in this statement for this type

Cause: An indicator variable was used in a host/indicator variable pair for some type in a statement that did not require or need one. Typically, indicator variables are not used in ALLOCATE and FREE statements for types other than object or collection types. They are also not used in OBJECT CREATE/DEREF statements for REF types.

Action: Remove the use of the indicator for the type in the specified statement. It will be ignored otherwise.

PCC-02399 Illegal CHAR_MAP option value for DBMS=V6. Option ignored.

Cause: A CHAR_MAP option other than CHAR_MAP=VARCHAR2 was specified inline. Since DBMS=V6, this option is ignored for a character or string variable in the offending statement.

Action: Either set DBMS to something other than V6, or specify CHAR_MAP=VARCHAR2.

PCC-02400 This host variable must be declared as a pointer type

Cause: The specified host variable was not declared as a pointer type.

Action: Declare the host variable to be a pointer type.

PCC-02401 Host variable arrays of this type are currently not supported

Cause: Host variable arrays of the specified type are not supported.

Action: Rewrite your program so that there are no arrays of this type.

PCC-02402 Pro*C option OBJECTS=YES is required when using the object cache

Cause: The object cache will be used for this host variable, but OBJECTS=NO was specified on the Pro*C command line.

Action: Specify OBJECTS=YES on the Pro*C command line when using the object cache.

PCC-02403 Invalid indicator variable type for this host variable

Cause: The type of the indicator variable is not appropriate for the specified host variable.

Action: Change the type of the indicator variable to a valid type. Refer to the Pro*C/C++ Precompiler Programmer's Guide for a discussion of appropriate indicator variable declarations.

PCC-02404 This indicator variable must be declared as a pointer type

Cause: The specified indicator variable was not declared as pointer type.

Action: Declare the indicator variable to be a pointer type.

PCC-02405 Variable is of undefined type

Cause: No declaration was found for the type identifier of the variable.

Action: Provide a valid declaration for the type of the host variable. If using objects in your program, check that the OTT-generated header for the object type was #included and that the type file was specified in the INTYPE option on the Pro*C command line.

PCC-02406 Expecting the form 'RETURN[ING] REF INTO :ref' only

Cause: When using the RETURNING clause in an OBJECT CREATE statement, only a single 'REF INTO :host_variable' is expected. This error occurs if the expression list to which REF belongs is greater than one or if there are more than one host variables supplied in the into list.

Action: Rewrite the RETURNING clause as per the given specification.

PCC-02407 Object and REF types do not match

Cause: In an OBJECT CREATE or DEREF statement, the types of the given Object and its associated REF do not match.

Action: Make sure that the Object and its REF have the same type. The type information is generated by OTT and should appear in the header file which OTT creates.

PCC-02408 Expecting an expression of some Object type

Cause: The expression is not an Object type. For example, many host variable expressions in the Navigational statements require that the variable be declared of some Object type.

Action: Rewrite the expression or declare the variable to be an Object.

PCC-02409 Expecting an expression of some REF type

Cause: The expression is not a REF type. For example, some host variables in the Navigational CREATE and DEREF statements are required to be declared of some REF type.

Action: Rewrite the expression or declare the variable to be a REF.

PCC-02410 Expecting an expression of some Collection type.

Cause: The expression is not a Collection type. A VARRAY or Nested Table object was expected, but the given host variable did not resolve to a valid Collection type.

Action: Check that the OTT-generated header for the Collection type was properly #included in the Pro*C/C++ program and that the type file was specified in the INTYPE option on the Pro*C/C++ command line.

PCC-02411 Invalid type for INDICATOR descriptor item host variable

Cause: The type of the host variable paired with the INDICATOR descriptor item was invalid. The only permissible types for the INDICATOR item are a signed 2 byte numeric type or an indicator struct generated by the Object Type Translator for a user defined object type.

Action: Either replace the INDICATOR host variable with a valid one having an acceptable type or redeclare the existing host variable to be of a valid type.

PCC-02412 FOR clause not permitted in OBJECT GET or SET statement

Cause: An explicit FOR clause was used in an OBJECT GET or OBJECT SET statement. Use of the FOR clause is illegal for these statements.

Action: Remove the FOR clause.

PCC-02413 Number of attributes does not match number of host variables

Cause: The number of attributes supplied in the attribute list of an OBJECT SET of GET statement does not match the total number of host variables also supplied in that statement.

Action: Either remove some attributes or remove some host variables from the statement in order to make the total count for each the same.

PCC-02414 This attribute does not exist in the specified Object

Cause: An attribute given in the attribute list of an OBJECT SET or GET statement is not a member of the specified object in that statement.

Action: Remove the attribute from the list.

PCC-02415 Cannot manipulate Object attributes in an OBJECT GET or SET

Cause: An attempt was made to either GET or SET an attribute of an Object that itself was an Object or REF type.

Action: Remove the attribute from the attribute list in the statement.

PCC-02416 The Object in an OBJECT GET or SET must not be an array

Cause: The Object specified in an OBJECT GET or SET statement is an array which is illegal.

Action: Redeclare the Object so that it is not an array or subscript the Object so that only a single element of the Object array is specified.

PCC-02417 Illegal type conversion between attribute and host variable

Cause: An illegal type conversion was attempted in a Navigational GET or SET statement between the type of the Attribute and the type of the Host Variable.

Action: Change the type of either the Attribute or the Host Variable.

PCC-02418 Array size mismatch between Object and REF host variables

Cause: The array sizes of the Object and REF variables in an OBJECT CREATE or DEREF do not match.

Action: Adjust the array dimensions of the two host variables so that they are equal to one another.

PCC-02419 Host variable arrays not allowed in an OBJECT SET or GET

Cause: An array was found in the host variable list of an OBJECT SET or GET statement.

Action: Only scalars are allowed (except for single dimensioned char or varchar variables) in the host variable list of an OBJECT SET or GET. Make sure to use only scalars in these statements.

PCC-02420 Incomplete (or missing) type specification

Cause: An incomplete or perhaps missing type specification was given when declaring a host variable used in some SQL statement.

Action: Provide a complete type definition when declaring host variables intended for use inside any SQL statements.

PCC-02421 This host variable requires the use of an indicator variable

Cause: No indicator variable was provided (or matched) with a specific host variable where one was explicitly required.

Action: Provide an indicator variable for use with the specified host variable in the given SQL statement.

PCC-02422 Invalid value specified for the given context option

Cause: An illegal value was given for the specified runtime context option in the CONTEXT option OPTION SET (or GET) statement.

Action: Use a valid option value in the statement for the specified option being manipulated by the statement.

PCC-02423 Host variable has an invalid type for this option value

Cause: The type of the host variable corresponding to a specific option value in a CONTEXT option OPTION SET (or GET) statement is invalid for that particular value.

Action: Use a type suitable for the specific value being manipulated.

PCC-02424 The number of values and host variables does not match

Cause: There is a mismatch between the number of values specified and the number of valid host variables given in a CONTEXT option OPTION SET (or GET) statement.

Action: Use the same number of host variables as there are values given in that particular statement.

PCC-02425 An indicator variable is not required with this attribute

Cause: In a LOB or Collection DESCRIBE, an Indicator Variable was used with a Host Variable when retrieving a LOB attribute that doesn't require one.

Action: Remove the Indicator Variable.

PCC-02426 Incompatible LOB types

Cause: A LOB operation was attempted between LOBs whose types were not compatible. For example, When ASSIGNing one LOB to another, both LOBs must be of the same type. If they are not, this error results.

Action: Correct the LOB operation by having it function between LOBs of the same type. This may require a redeclaration of one of the LOBs used in the LOB statement performing the specified operation.

PCC-02427 Expression is not of the correct character string type

Cause: The given host variable expression was not declared to be of the required character type. In this case, one of several possible character types would have been accepted. However, the host variable type did not match any of them.

Action: Redeclare the problematic host variable, using one of the permitted character types.

PCC-02428 Buffer type is incompatible with LOB type

Cause: This error can occur in either of the following situations 1. An attempt to READ from a LOB into a buffer whose type was not compatible with the LOB type. 2. An attempt to WRITE a buffer into a LOB whose type was not compatible with the buffer type.

Action: Either the LOB type or the buffer type needs to be changed so that the LOB and buffer types become compatible for the specified operation.

PCC-02429 Expecting an expression of some internal LOB type

Cause: The given host variable was not declared to be an Internal LOB. BLOB, CLOB or NCLOB would have been accepted, however, the type of the host variable did not match any of these.

Action: Redeclare the host variable using one of the Internal LOB types.

PCC-02430 Expecting an expression of some arbitrary LOB type

Cause: The given host variable was not declared to be any type of LOB, Internal or External. In addition to any Internal LOB type, BFILE would also have been accepted, however, the type of the host variable did not match any of these.

Action: Redeclare the host variable using any of the LOB types, Internal or External.

PCC-02431 Expecting an expression of type external LOB (BFILE)

Cause: The given host variable was not declared to be an External LOB. Only BFILE would have been accepted in this case.

Action: Redeclare the host variable using an External LOB type (BFILE).

PCC-02432 Cannot open an external LOB (BFILE) in READ WRITE mode

Cause: An attempt was made to OPEN a BFILE in READ WRITE mode. Writable BFILEs are currently not supported so this operation is considered erroneous.

Action: Do not open BFILEs using READ WRITE mode. BFILEs can only be OPENed in READ ONLY mode.

PCC-02433 Invalid host variable and attribute pairing

Cause: The host variable and attribute pairing in a LOB or Collection DESCRIBE is invalid. Most likely, this was due to some problem with the host variable. For example, this error could occur if the host variable was not declared or is otherwise not provided.

Action: Usually, other, more specific, errors will accompany this one. Correcting some or all of those problems should resolve this error.

PCC-02434 FOR clause not permitted in any LOB statement

Cause: An explicit FOR clause was used in some LOB statement. The use of the FOR clause in LOB statements is erroneous.

Action: Remove the FOR clause.

PCC-02435 This attribute is only valid for internal LOB types

Cause: A request for a LOB attribute was made in a LOB DESCRIBE statement in which the given LOB was not of some Internal LOB type.

Action: Replace the LOB host variable in the LOB DESCRIBE with one that was declared to be an Internal LOB.

PCC-02436 This attribute is only valid for external LOB types (BFILEs)

Cause: A request for a LOB attribute was made in a LOB DESCRIBE statement in which the given LOB was not an External LOB type (BFILE).

Action: Use an External LOB (BFILE) host variable in the LOB DESCRIBE statement.

PCC-02437 Expecting an expression having binary integral type

Cause: A host variable was given that was not declared to be of some acceptable binary numeric integral type. Generally, when this error occurs, a signed or unsigned integral type was expected. Floating point or otherwise imprecise numeric types are considered erroneous.

Action: Replace the problematic host variable with one that was declared using a proper exact numeric integral type.

PCC-02438 Arrays of collection objects are not allowed

Cause: An array of collections was given in a COLLECTION statement. Only scalar (non-array) collection objects are allowed in any of the COLLECTION statements.

Action: Change the declaration of the Collection host variable so that it is not an array.

PCC-02439 FOR clause not allowed in this COLLECTION statement

Cause: An illegal FOR clause was used in a COLLECTION statement that did not allow one, particularly, one of either the TRIM or DESCRIBE COLLECTION statements.

Action: Remove the FOR clause from the statement.

PCC-02440 This attribute is valid for either internal or external LOBs

Cause: A request for a LOB attribute was made in a LOB DESCRIBE statement in which the given LOB host variable was neither an Internal an External LOB (BFILE) type.

Action: Use either an Internal or External LOB host variable in the LOB DESCRIBE statement.

PCC-02441 Number of attributes does not match number of host variables

Cause: There is a mismatch between the number of attributes and the number of valid host variables in the LOB or Collection DESCRIBE.

Action: Make sure that for each attribute being requested there is at most a single valid host variable given to hold its value.

PCC-02442 Expecting a value between 1 and 65535 inclusive

Cause: The value specified in the WITH MAX clause of an ALLOCATE DESCRIPTOR statement or the VALUE clause of a GET/SET DESCRIPTOR statement was either less than 1 or greater than 65535.

Action: Specify a value between 1 and 65535.

PCC-02443 This usage is only valid when DYNAMIC=ANSI is specified

Cause: One of the following statements was used without specifying a DYNAMIC=ANSI command line option setting:

  • EXEC SQL ALLOCATE/DEALLOCATE/GET/SET DESCRIPTOR
  • EXEC SQL DESCRIBE OUTPUT/INPUT ... USING ... descriptor
  • EXEC SQL EXECUTE ... INTO ...
  • EXEC SQL EXECUTE ... USING ... descriptor
  • EXEC SQL OPEN ... INTO ...
  • EXEC SQL OPEN ... USING ... descriptor

Action: Specify DYNAMIC=ANSI or remove statements like those above from the program.

PCC-02444 Invalid combination of descriptor and non-descriptor clauses

Cause: There was a mixing of descriptor and non-descriptor clauses in an ANSI Dynamic SQL statement.

Action: Do not mix descriptors and non-descriptors in the ANSI statement in question.

PCC-02445 USING clause valid only on a PREPAREd dynamic statement

Cause: The USING clause was used with an OPEN cursor statement where the cursor declaration was not for a PREPAREd statement. The correct sequence of statements should be as follows:

EXEC SQL PREPARE s FROM :stmt; EXEC SQL DECLARE c CURSOR FOR s;EXEC SQL OPEN c USING ...;

Action: Use the PREPARE statement for the SQL statement and use that in the DECLARE CURSOR statement.

PCC-02446 FOR clause not allowed in a DEALLOCATE statement

Cause: An explicit FOR clause was used in a DEALLOCATE DESCRIPTOR statement.

Action: Remove the FOR clause from the statement.

PCC-02447 Cannot specify destination offset in a LOB WRITE APPEND

Cause: A destination offset was specified in a LOB WRITE APPEND statement. The destination offset is assumed to be the end of the LOB so specifying an explicit destination offset is erroneous.

Action: Remove the destination offset from the LOB WRITE APPEND statement.

PCC-02448 Cannot specify a UCS2 variable in the NLS_NCHAR option

Cause: A variable declared as UTEXT, UVARCHAR, or LONGUVARCHAR was specified in the NLS_NCHAR command line option.

Action: Re-precompile without specifying the variable in an NLS_NCHAR command line option.

PCC-02449 Cannot type equivalence a UCS2 type

Cause: A UCS2 type has been type equivalenced in an EXEC SQL TYPE statement or a variable of UCS2 type has been type equivalenced in an EXEC SQL VAR statement.

Action: Remove the EXEC SQL TYPE or EXEC SQL VAR statement.

PCC-02450 Cursor was not declared in scrollable mode

Cause: A cursor which was not DECLAREd in SCROLL mode was used in scrollable mode in the FETCH statement.

Action: Declare the cursor in scroll mode using the SCROLL keyword.

PCC-02451 Value of offset cannot be negative in ABSOLUTE orientation mode

Cause: The offset for the FETCH ABSOLUTE statement is negative.

Action: Value of offset should be positive.


SQL Runtime Messages (SQL)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

46
SQL Runtime Messages (SQL)

SQL-02100 Out of memory (i.e., could not allocate)

Cause: SQLLIB was unable to allocate enough memory to execute the program.

Action: Allocate more memory to the user session, then rerun the program. If the error persists, call Oracle Support Services for assistance.

SQL-02101 Inconsistent cursor cache. Unit cursor/global cursor mismatch

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

SQL-02102 Inconsistent cursor cache. No global cursor entry.

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

SQL-02103 Inconsistent cursor cache. Out of range cursor cache reference

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

SQL-02104 Inconsistent host cache. No cursor cache available

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

SQL-02105 Inconsistent cursor cache. Global cursor not found

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

SQL-02106 Inconsistent cursor cache. Invalid Oracle cursor number

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

SQL-02107 Program too old for runtime library; please re-precompile it

Cause: The program was precompiled by an older version of the Oracle Precompilers, which is incompatible with this release of SQLLIB.

Action: Precompile the program with a newer version of the Oracle Precompilers.

SQL-02108 Invalid descriptor passed to run-time library

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

SQL-02109 Inconsistent host cache. Host reference is out of range

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

SQL-02110 Inconsistent host cache. Invalid host cache entry type

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

SQL-02111 Heap consistency error

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

SQL-02112 SELECT..INTO returns too many rows

Cause: A SELECT...INTO statement returned more rows than can be stored in the host variable provided.

Action: There are three possible solutions:

  • Use the precompiler option SELECT_ERROR=NO.
  • Declare a host variable with a larger array dimension.
  • Declare a cursor or cursor variable for the select statement.

SQL-02113 Unable to open message file

Cause: SQLLIB was unable to find or open the SQLLIB message file, SQL*.MSB.

Action: Check that this file exists in the MESG directory and that it is readable.

SQL-02114 Invalid SQL Cursor usage: trying to CLOSE a CLOSEd cursor

Cause: An attempt was made to CLOSE a cursor that was already CLOSEd with MODE={ANSI|ANSI14}. A CLOSEd cursor can be re-CLOSEd only when MODE={ORACLE|ANSI13}.

Action: When MODE={ANSI|ANSI14}, verify that a cursor is not already CLOSEd before trying to CLOSE it. Specify MODE={ORACLE|ANSI13} if a CLOSEd cursor is to be re-CLOSEd.

SQL-02115 Code interpretation problem -- check COMMON_NAME usage

Cause: With PRO*FORTRAN, this error occurs if the precompiler option COMMON_NAME is specified incorrectly. With other Oracle Precompilers, this error occurs when the precompiler cannot generate a section of code.

Action: With Pro*FORTRAN, when using COMMON_NAME to precompile two or more source modules, make sure to specify a different common name for each module. With other Oracle Precompilers, if the error persists, call Oracle Support Services for assistance.

SQL-02116 FATAL ERROR: Reentrant code generator gave invalid context

Cause: This internal error typically indicates a memory-related error.

Action: Check the program for memory-related errors, such as invalid pointers or array-bounds violations.

SQL-02117 Invalid SQL Cursor usage: trying to OPEN an OPENed cursor

Cause: An attempt was made to OPEN a cursor that was already OPENed with MODE={ANSI|ANSI14|ANSI13}. An open cursor can be re-OPENed only when MODE=ORACLE.

Action: When MODE={ANSI|ANSI14|ANSI13}, verify that a cursor is not already OPENed before trying to OPEN it. Specify MODE=ORACLE if an OPENed cursor is to be re-OPENed.

SQL-02118 Invalid row for a WHERE CURRENT OF operation

Cause: An attempt was made to reference a nonexistent row using the CURRENT OF clause in an UPDATE or DELETE statement. This happens when no FETCH has been executed or when FETCH returns a "no data found" error that the program fails to trap.

Action: Check that the last cursor operation succeeded and that the current row of the cursor is valid. The outcome of a cursor operation can be checked in two ways: implicit checking with the WHENEVER statement or explicit checking of SQLCODE in the SQLCA.

SQL-02119 Invalid HSTDEF argument

Cause: A non-null pointer was given for a hstdef as the second argument to a call to SQLRCN when the first argument was also used. Either the first or the second argument to SQLRCN must be null.

Action: Pass a null pointer in either the first or second argument to SQLRCN.

SQL-02120 First and second arguments to SQLRCN both null

Cause: Both the first and second arguments to SQLRCN were null. An HSTDEF must be passed into SQLRCN in either the form of an OCI lda (first argument) or as an HSTDEF pointer itself (second argument).

Action: Pass in either an OCI LDA or an HSTDEF, but not both.

SQL-02121 Invalid host name

Cause: The host name passed into a SQLFCN call was not used in a previous call to SQLRCN.

Action: Use the same identifier used in the corresponding SQLRCN call.

SQL-02122 Invalid OPEN or PREPARE for this database connection

Cause: An attempt was made to execute an OPEN or a PREPARE statement using a cursor that is currently open for another database connection and, therefore, cannot be used for this connection.

Action: Close the cursor to make it available for this connection or use a different cursor for this connection.

SQL-02123 Context referenced in EXEC TOOLS GET CONTEXT statement not found

Cause: The context name given in the EXEC TOOLS GET CONTEXT statement was never stored with an EXEC TOOLS SET CONTEXT statement.

Action: Use the EXEC TOOLS SET CONTEXT statement to save any contexts to be retrieved later.

SQL-02124 NULL value returned by EXEC TOOLS statement

Cause: A NULL value was returned by EXEC TOOLS for a host variable that lacks an indicator variable. This error is returned only when MODE=ANSI. When MODE=ORACLE, although the value of the host variable is indeterminate, no error is generated.

Action: Associate an indicator variable with each host variable to which nulls might be returned.

SQL-02125 Connect error, can't get error text

Cause: No connection (not even to the default host) was available, so SQLLIB could not get the message text for the Oracle error that occurred. However, SQLLIB returns the Oracle error number, which can be used to look up the message.

Action: Look up the appropriate message in this manual, and follow the Cause and Action information provided.

SQL-02126 Count of array elements cannot be negative (i.e. < 0)

Cause: The precompiler found a negative number of array elements in the N or F element of the SQLDA (SQL Descriptor Area, which is used with dynamic SQL Method 4). Before executing the DESCRIBE statement, N must be set to the dimension of the descriptor arrays. After executing the DESCRIBE statement, N must be reset to the actual number of variables DESCRIBEd, which is stored in the F variable.

Action: Check that the N or F variables are set to non-negative values.

SQL-02127 Precompiler/SQLLIB version mismatch

Cause: The program was linked to an older version of SQLLIB, which is incompatible with this release of the Oracle Precompilers.

Action: Relink the program with a newer version of SQLLIB

SQL-02128 Sessions still exist, not logged off

Cause: A host was not removed ("logged off") from SQLLIB because XA still has sessions associated with that host.

Action: Before calling SQLXDH to drop a host, XA must either drop all sessions for that host or set the "doit_anyway" flag.

SQL-02129 Fetched number of bytes is odd.

Cause: The program tried to FETCH an invalid column value into a multi-byte NLS host variable. Specifically, the column did not contain valid double-byte data.

Action: Make sure the column contains only double-byte data. To verify this, use SQL*Plus or Server Manager.

SQL-02130 EXEC TOOLS interface is not available.

Cause: An attempt was made to link with a version of an Oracle tool that does not support the EXEC TOOLS interface. EXEC TOOLS interface.

Action: Either upgrade the Oracle tool, or use the EXEC IAF interface.

SQL-02131 Runtime context in use

Cause: Your application attempted to execute a SQL statement using a runtime context that is already in use.

Action: Rewrite the application to either wait for one thread to complete before executing another SQL statement with the same runtime context, or to allocate and use a separate runtime context for each thread.

SQL-02132 Unable to allocate runtime context sdfla asdjklfajs jfja ajsdf

Cause: An attempt to allocate a runtime context failed.

Action: This error typically occurs when the process memory is low. Allocate more memory and run the application again.

SQL-02133 Unable to initialize process for use with threads

Cause: This is an internal error.

Action: Call Oracle Support Services.

SQL-02134 Invalid runtime context

Cause: The runtime context associated with this statement has not been properly allocated.

Action: Rewrite the application to execute the EXEC SQL CONTEXT ALLOCATE statement before executing any SQL statements.

SQL-02135 Unable to initialize date format using supplied mask

Cause: The runtime library was unable to issue a set date format statement with the date format mask supplied.

Action: Check the validity of the date format and correct if necessary. Check the ORA error number for further information.

SQL-02136 Invalid NCHAR character set id

Cause: An attempt was made to bind or define an NCHAR host variable, and the NLS_NCHAR variable was not set correctly.

Action: Set the NLS_NCHAR environment variable to a valid fixed width character set id and run the application again.

SQL-02137 Multi-threaded agent with no RETURNING clause present

Cause: The EXEC SQL REGISTER CONNECT statement does not contain a RETURNING clause and the agent is running in threaded mode.

Action: Re-code the statement to use a RETURNING clause that references a declared SQL_CONTEXT host variable.

SQL-02138 No external procedure context exists

Cause: The external procedure context passed in the EXEC SQL REGISTER CONNECT statement is not valid.

Action: Ensure that you have done the following:

  1. Created the PL/SQL procedure/function with a CONTEXT parameter.
  2. Included OCIExtProcContext in the formal parameter list of the external procedure.
  3. Correctly passed the OCIExtProcContext to the EXEC SQL REGISTER CONNECT statement.

Cause: The call to OCIExtProcGetEnv failed.

Action: Ensure that the OCIExtProcContext that the external procedure has been created with a CONTEXT parameter and that this context is correctly referenced in the EXEC SQL REGISTER CONNECT statement.

SQL-02140 An unnamed connection already exists

Cause: An attempt to register an external procedure context was made when an unnamed connection already exists for the runtime context.

Action: Do not attempt to establish any connections with the EXEC SQL CONNECT statement from external procedures.

SQL-02141 Collection descriptor has not been allocated

Cause: An unallocated collection descriptor was referenced in a COLLECTION SET or COLLECTION GET statement.

Action: Allocate the collection descriptor with the EXEC SQL ALLOCATE statement (for example, EXEC SQL ALLOCATE :coldesc_p;).

SQL-02142 Collection is NULL

Cause: The collection referenced in an EXEC SQL COLLECTION statement is null.

Action: Check the status of the associated indicator variable prior to executing an EXEC SQL COLLECTION statement.

SQL-02143 Target object has not been properly allocated

Cause: An attempt was made to retrieve elements from a collection into an unallocated object pointer.

Action: Allocate the object pointer with the EXEC SQL ALLOCATE statement.

SQL-02144 Invalid ANSI dynamic usage

Cause: An ANSI allocate, deallocate, get or set descriptor statement was encountered when dynamic option was not set.

Action: Precompile your source with option DYNAMIC=ANSI.

SQL-02145 Invalid dynamic descriptor

Cause: An attempt to access an unallocated or invalid descriptor was encountered.

Action: For ANSI descriptors, check that descriptor name is valid and descriptor has been allocated and not previously deallocated. Or if using Oracle descriptors (SQLDA) with MODE=ANSI also use DYNAMIC=ORACLE.

SQL-02146 Attempt to allocate an existing descriptor

Cause: An attempt allocated a descriptor which has previously been allocated was encountered.

Action: Use a unique descriptor name or deallocate the descriptor before attempting to reallocate it.

SQL-02147 ANSI Dynamic occurrence value out of range

Cause: The value clause in a dynamic GET or SET statement is less than one or greater than MAX given for descriptor allocation.

Action: Supply a number for the VALUE clause between 1 and the MAX occurrences supplied when the descriptor was allocated.

SQL-02148 ANSI Dynamic count value out of range

Cause: The count in a dynamic GET or SET statement is less than one or greater than MAX given for descriptor allocation.

Action: Supply a number for the COUNT clause between 1 and the MAX occurrences supplied when the descriptor was allocated.

SQL-02149 ANSI Dynamic insufficient item descriptor areas

Cause: The SQL statement being described contains more output items (or columns) than were allocated in the descriptor.

Action: Increase the MAX number of occurrences when allocating the descriptor.

SQL-02150 Encountered zero length in ANSI dynamic SET statement

Cause: An invalid length of zero was encountered in an ANSI dynamic statement.

Action: Set the length to a non-zero value.

SQL-02151 Invalid host variable for exact numeric SET statement item

Cause: An host variable with an invalid type or length was used to get or set an exact numeric item in an ANSI dynamic statement.

Action: Make sure your host variable is an int or short for C or for COBOL, S9(4) or S9(9) binary/comp/display sign leading separate.

SQL-02152 Invalid numeric variable for use in an array GET/SET statement

Cause: An host variable with type other than int or short for C or S9(4) or S9(9) binary or comp was used for an exact numeric with and array size > 1.

Action: Use only int or short for C or S9(4) or S(9) binary or comp for COBOL when supplying an exact numeric in conjunction with the for clause to indicate arrays. Specifically, display sign leading separate is not allowed in this context.

SQL-02153 Invalid character variable for use in a GET/SET statement

Cause: An host variable with type other than character, string or varchar was found as an item name (other than DATA item) in an ANSI Dynamic GET or SET descriptor statement.

Action: Host variable types for character items (other than the DATA item) in ANSI dynamic GET or SET descriptor statements must not be of type LONG or LONG VARCHAR. Redeclare the variable to be character, string or varchar type.

SQL-02154 Invalid or unset data type for host variable in ANSI Dynamic

Cause: An ANSI Dynamic SET statement with item name DATA was encountered with out a valid TYPE having been previously set and option MODE=ANSI was used.

Action: With MODE=ANSI, you must set the TYPE before setting the DATA. Issue a SET statement with correct item TYPE or, for output issue a DESCRBE to set the item type. Or use mode=oracle which allows the type to default to the type of the bind/define host variable.

SQL-02155 Date Time Interval only valid with Dynamic=ANSI

Cause: An attempt to access the datetime interval code or precision was encountered when TYPE_CODE option not set to ANSI.

Action: Use precompiler option TYPE_CODE=ANSI to access the date time interval code or date time interval precision.

SQL-02156 Invalid type for Indicator or Returned Length

Cause: A host variable associated with the item Indicator or Returned Length must be of type short or s9(4) comp. If value semantics and scalar, they may also be gotten into display sign leading separate host variables.

Action: Use signed short for indicator, ref indicator and returned length, ref returned length host variables in C. For COBOL use s9(4) comp. for GETs only with non-arrays and you may use display sign leading separate host variables.

SQL-02157 Source or destination lob is invalid

Cause: One of the LOBs used in the LOB append call is invalid or possibly null.

Action: Make sure the LOBs used in the append call are non-null.


interMedia Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Part IX
interMedia Messages

This part contains the following chapters:

  • Chapter 47, "interMedia Audio Messages (AUD)"
  • Chapter 48, "interMedia Image Messages (IMG)"
  • Chapter 49, "interMedia Video Messages (VID)"


interMedia Audio Messages (AUD)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

47
interMedia Audio Messages (AUD)

For information about the interMedia Audio option, refer to the Oracle interMedia User's Guide and Reference.

AUD-00702 unable to initialize audio processing environment

Cause: The initialization of the audio processing procedure failed.

Action: See the database administrator to make sure that enough memory has been allocated to JServer. If JServer does have enough memory, contact Oracle Support Services.

AUD-00703 unable to read audio data

Cause: An error occurred while accessing the audio source.

Action: Make sure the audio source is valid. For external sources, make sure all access privileges are granted.

AUD-00704 invalid input format

Cause: The audio data in the source was not in the format specified by the format field of the audio object. In some unusual case, the audio data is actually corrupted.

Action: Provide a correct value in the format field. If the correct value is unknown, put NULL in the format field to invoke the DEFAULT format plug-in.

AUD-00705 unsupported input format

Cause: The file format of the audio data was not supported. This error can only occur in the DEFAULT format plug-in package.

Action: Refer to the Oracle interMedia User's Guide and Reference for supported formats.

AUD-00706 unsupported or corrupted input format

Cause: The audio data was either corrupted or the file format was not supported.

Action: Refer to the Oracle interMedia User's Guide and Reference for supported formats. If the audio data is not corrupted and is in a supported file format, contact Oracle Support Services.

AUD-00713 internal error while parsing audio data

Cause: An internal error occurred during parsing.

Action: Contact Oracle Support Services.

AUD-00714 internal error

Cause: An internal error occurred.

Action: Contact Oracle Support Services.

AUD-00802 name of index is limited to 22 characters

Cause: An index name was specified that is more than 22 characters in length.

Action: Drop this index and issue the CREATE INDEX statement again with a name that is at most 22 characters in length.

AUD-00803 internal error while processing WHERE clause

Cause: The WHERE clause could not be properly processed.

Action: Contact Oracle Support Services.

AUD-00806 first argument to SpeechContains must be a column

Cause: The first argument to SpeechContains is not a column. This is not allowed.

Action: Make sure that the first argument to SpeechContains is a column in a database table.

AUD-00807 SpeechContains: index of indextype ORDSpeechIndex is required

Cause: SpeechContains was used without an associated index of indextype ORDSpeechIndex.

Action: Make sure that SpeechContains is used in the context of an index of indextype ORDSpeechIndex. See documentation for sample usage scenarios.

AUD-00808 ORDSpeechIndex: unable to CREATE internal Text index

Cause: CREATE INDEX for ORDSpeechIndex failed when trying to create internal Text index.

Action: Make sure that you are supplying a valid parameter string. See SpeechIndexing and Oracle Text documentation for descriptions of a valid parameter string for CREATE INDEX. To return to a consistent state, issue a DROP INDEX statement.

AUD-00809 ORDSpeechIndex: unable to ALTER REBUILD internal Text index

Cause: ALTER INDEX REBUILD for ORDSpeechIndex failed when trying to alter rebuild internal Text index.

Action: Make sure that you are supplying a valid parameter string. See SpeechIndexing and Oracle Text documentation for descriptions of a valid parameter string for ALTER INDEX REBUILD. To return to a consistent state, issue a ALTER INDEX REBUILD PARAMETERS('optimize full') statement.


interMedia Image Messages (IMG)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

48
interMedia Image Messages (IMG)

For information about the interMedia Image option, refer to the Oracle interMedia User's Guide and Reference.

IMG-00001 unable to initialize Oracle interMedia environment

Cause: The image processing external procedure initialization process failed.

Action: Contact Oracle Support Services.

IMG-00002 unrecoverable error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

IMG-00502 invalid scale value

Cause: An invalid scale value was found while parsing the parameters for the image process function.

Action: Correct the statement by using a valid scale value. Refer to the Oracle interMedia User's Guide and Reference for a description of the correct usage and syntax for the image processing command string.

IMG-00505 missing value in CUT rectangle

Cause: An incorrect number of values was used to specify a rectangle.

Action: Use exactly four integer values for the lower left and upper right vertices.

IMG-00506 extra value in CUT rectangle

Cause: An incorrect number of values was used to specify a rectangle.

Action: Use exactly four integer values for the lower left and upper right vertices.

IMG-00510 string

Cause: A syntax error was found while parsing the parameters for the image process function.

Action: Correct the statement by using valid parameter values. Refer to the Oracle interMedia User's Guide and Reference for a description of the correct usage and syntax for the image processing command string.

IMG-00511 string

Cause: An error was found while accessing image data.

Action: Contact Oracle Support Services.

IMG-00512 multiple incompatible scaling parameters found

Cause: Multiple incompatible scaling parameters were found in the image process command string. With the exception of XSCALE and YSCALE which can be used together in a process command string, scaling functions are mutually exclusive and cannot be combined.

Action: Remove scaling functions until only one remains (or two, if they are XSCALE and YSCALE).

IMG-00513 missing value in scaling operation

Cause: An incorrect number of values was used to specify image dimensions. FixedScale and maxScale require exactly two integer values for the X and Y dimensions of the desired image.

Action: Use two values for fixedScale and maxScale.

IMG-00514 extra value in scaling operation

Cause: An incorrect number of values was used to specify image dimensions. FixedScale and maxScale require exactly two integer values for the X and Y dimensions of the desired image.

Action: Use two values for fixedScale and maxScale.

IMG-00515 incorrect number of input channels

Cause: An incorrect number of values was used to specify input channels. InputChannels requires either one or three channel numbers for the gray or red, green, and blue channel assignments.

Action: Use either one or three values to specify the input channels.

IMG-00516 default channel out of range

Cause: An incorrect value was used to specify the default channel selection.

Action: Use a channel number which is less than or equal to the number of bands and greater than zero.

IMG-00517 height or width not present in parameter string

Cause: Height and or width were not specified in the setProperties parameter string.

Action: Specify both the height and width.

IMG-00518 invalid value for height or width

Cause: Height and or width must be positive integers.

Action: Specify both the height and width as positive integers.

IMG-00519 illegal combination of parameters

Cause: Other than height, width, dataOffset, and userString, no other parameters may be specified in the setProperties parameter string when CCITTG3 or CCITTG4 is used as the compressionFormat.

Action: Supply only the height and width when compressionFormat is either CCITTG3 or CCITTG4. The dataOffset and userString may optionally be supplied as well.

IMG-00520 invalid value for numberOfBands

Cause: NumberOfBands must be a positive integer.

Action: Specify numberOfBands as a positive integer.

IMG-00521 invalid value for dataOffset

Cause: DataOffset must be a positive integer.

Action: Specify dataOffset as a positive integer.

IMG-00522 invalid format for parameter value

Cause: A floating point value was specified where an integer is required, or a character value was specified where a numeric value is required.

Action: Specify the correct type of values for process parameters.

IMG-00523 invalid process verb

Cause: A process verb was specified that is not understood by interMedia.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of valid process verbs.

IMG-00524 mismatched quotes

Cause: Quotes used within a process command string were not matched.

Action: Ensure that quotes occur in pairs.

IMG-00525 locale error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

IMG-00526 error parsing foreign image description

Cause: An internal error occurred while processing a foreign image.

Action: Use SetProperties to correct the foreign image description. Contact Oracle Support Services.

IMG-00530 internal error while parsing command

Cause: An internal error occurred while parsing the command passed to the image processing function or the foreign image setproperties function.

Action: Check the command passed to the function. Refer to the Oracle interMedia User's Guide and Reference for a description of the correct usage and syntax for the image processing command string or the foreign image setproperties function. If you are certain that your command is correct, then contact Oracle Support Services.

IMG-00531 empty or null image processing command

Cause: An empty or null image processing command was passed to the image process function.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of the correct usage and syntax for the image processing command string.

IMG-00540 contentFormat and interleave conflict

Cause: Interleave values were specified using both the contentformat and interleave verbs.

Action: Specify interleave using either contentformat or interleave but not both.

IMG-00541 invalid contentFormat specified

Cause: The specified contentFormat was not valid.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of valid contentFormat specifications.

IMG-00542 contentFormat includes invalid extra information

Cause: The specified contentFormat included invalid characters at the end of the parameter string.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of valid contentFormat specifications.

IMG-00543 invalid compressionFormat specified

Cause: The specified compression format was not valid.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of valid compressionFormat specifications.

IMG-00544 invalid compressionQuality specified

Cause: The specified compression quality was not valid.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of valid compressionQuality specifications.

IMG-00545 invalid cut values specified

Cause: An invalid value was found while parsing the parameters for the cut operation.

Action: Correct the statement by using a valid values for cut. Specify non-negative values for cut. Refer to the Oracle interMedia User's Guide and Reference for a description of the correct usage and syntax for the image processing command string.

IMG-00546 invalid page number specified

Cause: An invalid page number was specified.

Action: Specify non-negative page numbers.

IMG-00547 invalid channelOrder specified

Cause: The specified channel order was not valid.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of valid channelOrder specifications.

IMG-00548 invalid interleave specified

Cause: The specified interleave was not valid.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of valid interleave specifications.

IMG-00549 invalid pixelOrder specified

Cause: The specified pixel order was not valid.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of valid pixelOrder specifications.

IMG-00550 invalid scanlineOrder specified

Cause: The specified scanline order was not valid.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of valid scanlineOrder specifications.

IMG-00551 invalid dither type specified

Cause: The specified dither type was not valid.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of valid dither specifications.

IMG-00552 invalid inputChannels specified

Cause: An invalid value was specified for the inputChannels verb.

Action: Specify non-negative values for inputChannels. Refer to the Oracle interMedia User's Guide and Reference for a description of the correct usage and syntax for the image processing command string.

IMG-00560 input format does not support page selection

Cause: The page verb was specified for an input format that does not support selecting pages.

Action: Remove the page selection verb. Refer to the Oracle interMedia User's Guide and Reference for a description of which image formats support page selection.

IMG-00561 input format does not support channel selection

Cause: The inputChannels verb was specified for an input format that does not support selecting channels.

Action: Remove the inputChannels verb. Refer to the Oracle interMedia User's Guide and Reference for a description of which image formats support input channel selection.

IMG-00580 specified format does not support output

Cause: The output format specified by fileFormat does not support output.

Action: Change the specified fileFormat to one that supports output. Refer to the Oracle interMedia User's Guide and Reference for a description of which formats support output.

IMG-00581 output format does not support the specified contentFormat

Cause: The specified contentFormat is not supported by the explicitly or implicitly specified output format.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of which contentFormat values are supported for each output format.

IMG-00582 output format does not support the specified interleave

Cause: The specified interleave is not supported by the explicitly or implicitly specified output format.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of which interleave values are supported for each output format.

IMG-00583 output format does not support the specified compressionFormat

Cause: The specified compressionFormat is not supported by the explicitly or implicitly specified output format.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of which compressionFormat values are supported for each output format.

IMG-00584 output format does not support the specified compressionQuality

Cause: The specified compressionQuality is not supported by the explicitly or implicitly specified output format.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of which compressionQuality values are supported for each output format.

IMG-00585 output format does not support the specified channelOrder

Cause: The specified channelOrder is not supported by the explicitly or implicitly specified output format.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of which channelOrder values are supported for each output format.

IMG-00586 output format does not support the specified pixelOrder

Cause: The specified pixelOrder is not supported by the explicitly or implicitly specified output format.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of which pixelOrder values are supported for each output format.

IMG-00587 output format does not support the specified scanlineOrder

Cause: The specified scanlineOrder is not supported by the explicitly or implicitly specified output format.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of which scanlineOrder values are supported for each output format.

IMG-00599 internal error

Cause: An internal error has occurred.

Action: Contact Oracle Support Services.

IMG-00601 out of memory while copying image

Cause: Operating system process memory has been exhausted while copying the image.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00602 unable to access image data

Cause: An error occurred while reading or writing image data.

Action: Contact your system administrator.

IMG-00603 unable to access source image data

Cause: The source image SOURCE attribute is invalid.

Action: Ensure that the SOURCE attribute of the source image is populated with image data.

IMG-00604 unable to access destination image data

Cause: The destination image SOURCE attribute is invalid.

Action: Ensure that the SOURCE attribute of the destination image is populated with image data.

IMG-00606 unable to access image data

Cause: An attempt was made to access an invalid image.

Action: Ensure that the SOURCE attribute of the image is populated with image data.

IMG-00607 unable to write to destination image

Cause: The destination image SOURCE attribute is invalid.

Action: Ensure that the SOURCE attribute of the destination image is initialized correctly and that you have sufficient tablespace.

IMG-00609 unable to read image stored in a BFILE

Cause: The image stored in a BFILE cannot be opened for reading.

Action: Ensure that the access privileges of the image file and the image file's directory allow read access.

IMG-00701 unable to set the properties of an empty image

Cause: There is no data in the image object.

Action: Refer to the Oracle interMedia User's Guide and Reference for information on how to populate image data into the image object.

IMG-00702 unable to initialize image processing environment

Cause: The image processing external procedure initialization process failed.

Action: Contact Oracle Support Services.

IMG-00703 unable to read image data

Cause: There is no image data in the image object.

Action: Refer to the Oracle interMedia User's Guide and Reference for information on how to populate image data into the image object.

IMG-00704 unable to read image data

Cause: There is no image data in the image object.

Action: Refer to the Oracle interMedia User's Guide and Reference for information on how to populate image data into the image object.

IMG-00705 unsupported or corrupted input format

Cause: This is an internal error.

Action: Contact Oracle Support Services.

IMG-00706 unsupported or corrupted output format

Cause: This is an internal error.

Action: Contact Oracle Support Services.

IMG-00707 unable to access image data

Cause: An error occurred while reading or writing image data.

Action: Contact your system administrator.

IMG-00710 unable to write to destination image

Cause: The destination image is invalid.

Action: Ensure that the SOURCE attribute of the destination image is initialized and that you have sufficient tablespace.

IMG-00711 unable to set properties of destination image

Cause: This is an internal error.

Action: Contact Oracle Support Services.

IMG-00712 unable to write to destination image

Cause: The destination image is invalid.

Action: Ensure that the SOURCE attribute of the destination image is initialized and that you have sufficient tablespace. Ensure the row containing the destination image has been locked (this doesn't apply to temporary BLOBs).

IMG-00713 unsupported destination image format

Cause: A request was made to convert an image to a format that is not supported.

Action: Refer to the Oracle interMedia User's Guide and Reference for supported formats.

IMG-00714 internal error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

IMG-00715 unable to open image stored in a BFILE

Cause: The image stored in a BFILE could not be opened for reading.

Action: Ensure that the access privileges of the image file and the image file's directory allow read access.

IMG-00716 source image format does not support process options

Cause: A request was made to apply a processing option not supported by the source image format.

Action: Refer to the Oracle interMedia User's Guide and Reference for a discussion of supported processing options.

IMG-00717 destination image format does not support process options

Cause: A request was made to apply a processing option not supported by the destination image format.

Action: Refer to the Oracle interMedia User's Guide and Reference for a discussion of supported processing options.

IMG-00718 the same Temporary LOB cannot be used as both source and destination

Cause: A call was made to processCopy with the same Temporary LOB being specified as both the source and destination.

Action: Specify a different LOB for parameter "dest".

IMG-00719 image processing internal error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

IMG-00720 image processing internal error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

IMG-00730 unable to process empty image

Cause: There is no data in the input image object.

Action: Refer to the Oracle interMedia User's Guide and Reference for information on how to populate image data into the image object.

IMG-00731 specified page could not be found in input image

Cause: The specified page does not exist in the input image.

Action: Restrict the value of the page parameter to values specifying pages that exist within the input image object.

IMG-00732 specified inputChannels could not be found in input image

Cause: The specified input channel does not exist in the input image.

Action: Restrict the value of the inputChannels parameter to values specifying channels that exist within the input image object.

IMG-00800 internal error while parsing attribute string

Cause: An internal error occurred while parsing the attribute string containing the weights of the attributes.

Action: Check the command passed to the function. Refer to the Oracle interMedia User's Guide and Reference for a description of the correct usage and syntax for the attributes string for image matching. If you are certain that your command is correct, then contact Oracle Support Services.

IMG-00801 cannot extract height and width

Cause: Height and width are not set in the image object.

Action: Set the properties of the image object by calling setProperties and then generate signature.

IMG-00802 empty or null attribute string

Cause: An empty or null attributes string was passed to the image matching operators.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of the correct usage and syntax of the attributes string.

IMG-00803 invalid attribute value

Cause: An invalid value was found while parsing the attribute string for the image matching operators.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of the correct usage and syntax for the attributes string. The weight values should be between 0.0 and 1.0.

IMG-00804 Syntax error in attribute string

Cause: A syntax error was found while parsing the attribute string for the image matching operators.

Action: Refer to the Oracle interMedia User's Guide and Reference for a description of the correct usage and syntax of the attributes string.

IMG-00805 SIGNATURE data has been corrupted or is invalid

Cause: The data in the signature is not a valid signature.

Action: Re-create the signature using the generateSignature method.

IMG-00806 invalid input image

Cause: The image data is either corrupt or is in an unsupported format.

Action: Repopulate the image object, set properties of the image, and generate the signature.

IMG-00807 no weights specified in weight string

Cause: All weights passed were zero. At least one attribute must be weighted.

Action: Specify a non-zero weight for at least one attribute.

IMG-00808 unable to read an empty image

Cause: There is no data in the image object.

Action: Refer to the Oracle interMedia User's Guide and Reference for information on how to populate the image object with image data.

IMG-00809 usage of IMGSimilar is incorrect

Cause: Syntax error while using IMGSimilar.

Action: Refer to the Oracle interMedia User's Guide and Reference for information on how to use the IMGSimilar operator. Check whether the value returned by IMGSimilar is compared to the value 1.

IMG-00810 Boundary queue initialization failed

Cause: Operating system process memory has been exhausted while initializing the boundary queue.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00811 Fail queue initialization failed

Cause: Operating system process memory has been exhausted while initializing the fail queue.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00812 Merged area queue initialization failed

Cause: Operating system process memory has been exhausted while initializing the merged area queue.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00813 Boundary queue free failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00814 fail queue free failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00815 Merged area queue free failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00820 Area 0 queue clear failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00821 Area N queue clear failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00822 Area queue reset failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00823 Boundary queue pop failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00824 fail queue pop failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00825 Merged area queue pop failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00830 Boundary queue is full

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00831 Boundary queue size exceeds expected size

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00832 fail queue is full

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00833 Boundary queue size exceeds expected size

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00834 Merged area queue is full

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00835 Merged area queue size exceeds expected size

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00836 Area queue merge failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00840 Image structure allocation failed

Cause: Operating system process memory has been exhausted while initializing the image structure.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00841 Image data allocation failed

Cause: Operating system process memory has been exhausted while initializing the image data.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00842 Image index allocation failed

Cause: Operating system process memory has been exhausted while initializing the image index.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00843 Internal Image structure allocation failed

Cause: Operating system process memory has been exhausted while initializing the internal image structure.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00844 Internal Image data allocation failed

Cause: Operating system process memory has been exhausted while initializing the internal image data.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00845 Internal Image index allocation failed

Cause: Operating system process memory has been exhausted while initializing the internal image index.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00846 Adjacency matrix allocation failed

Cause: Operating system process memory has been exhausted while initializing the adjacency matrix.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00847 Area list allocation failed

Cause: Operating system process memory has been exhausted while initializing the area list.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00850 Image structure free failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00851 Image data free failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00852 Image index free failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00853 Internal Image structure free failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00854 Internal Image data free failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00855 Internal Image index free failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00856 Adjacency matrix free failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00857 Area list free failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number.

IMG-00860 assert failure, number of region exceeds allocated

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00861 assert failure, inconsistency in area merge operation

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00862 assert failure, inconsistency in merged area labels

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00870 unsupported aspect ratio or image size

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00871 unexpected number of seeds

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00872 unsupported image model

Cause: An internal error has occurred.

Action: Contact Oracle Support Services with the error number and the image causing this problem.

IMG-00899 signature cannot be generated

Cause: The generateSignature method could not generate the signature.

Action: Verify that the input image is a format supported by interMedia.

IMG-00901 VIR signature version mismatch

Cause: Two signatures to be compared have different versions.

Action: Recompute signatures on the same platform and repeat signature comparison.

IMG-00902 VIR signature free failed

Cause: An internal error has occurred.

Action: Contact Oracle Support Services.

IMG-00910 Allocation of basic data structure failed

Cause: Operating system process memory has been exhausted while copying the image.

Action: See the database administrator or operating system administrator to increase process memory quota.

IMG-00911 Free basic data structure failed

Cause: Operating system process memory has been exhausted while copying the image.

Action: Contact Oracle Support Services.

IMG-00921 Threshold out of range

Cause: Threshold should be between 0 and 100.

Action: Use a threshold between 0 and 100 and retry the query.

IMG-00922 Location specified without feature

Cause: Specification of location only is not valid.

Action: Specify at least one other parameter (color, texture, or shape) along with location. Refer to the Oracle interMedia User's Guide and Reference for more details.

IMG-00923 Signature is empty

Cause: Signature has not been generated.

Action: Generate the signature for the image by calling the generateSignature method.


interMedia Video Messages (VID)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

49
interMedia Video Messages (VID)

For information about the interMedia Video option, refer to the Oracle interMedia User's Guide and Reference.

VID-00702 unable to initialize video processing environment

Cause: The initialization of the video processing procedure failed.

Action: See the database administrator to make sure that enough memory has been allocated to JServer. If JServer does have enough memory, contact Oracle Support Services.

VID-00703 unable to read video data

Cause: An error occurred while accessing the video source.

Action: Make sure the video source is valid. For external sources, make sure all access privileges are granted.

VID-00704 invalid input format

Cause: The video data in the source was not in the format specified by the format field of the video object. In some unusual case, the video data is actually corrupted.

Action: Provide a correct value in the format field. If the correct value is unknown, put NULL in the format field to invoke the DEFAULT format plug-in.

VID-00705 unsupported input format

Cause: The file format of the video data was not supported. This error can only occur in the DEFAULT format plug-in package.

Action: Refer to the Oracle interMedia User's Guide and Reference for supported formats.

VID-00706 unsupported or corrupted input format

Cause: The video data was either corrupted or the file format was not supported.

Action: Refer to the Oracle interMedia User's Guide and Reference for supported formats. If the video data is not corrupted and is in a supported file format, contact Oracle Support Services.

VID-00713 internal error while parsing video data

Cause: An internal error occurred during parsing.

Action: Contact Oracle Support Services.

VID-00714 internal error

Cause: An internal error occurred.

Action: Contact Oracle Support Services.


Oracle Text Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Part X
Oracle Text Messages

This part contains the following chapter:

  • Chapter 50, "Oracle Text Messages (DRG)"


Oracle Text Messages (DRG)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

50
Oracle Text Messages (DRG)

For information about the Oracle Text option, refer to:

  • Oracle Text Reference
  • Oracle Text Application Developer's Guide

DRG-10000 failed to read column string

Cause: Error during read of specified text column.

Action: Check the existence and privileges of the column.

DRG-10001 can not access result table string

Cause: Specified table does not exist or server does not have write privileges.

Action: Check the result table.

DRG-10002 can not insert into result table

Cause: Text server is not privileged to insert, tablespace is exhausted.

Action: Check privileges and tablespace.

DRG-10011 invalid object name string

Cause: A table, column or procedure name specified had an invalid format. It is either too long or contains illegal characters. Probably you are passing in incorrect parameters.

Action: Check parameter values.

DRG-10015 id exceeds limit(2147483642) of a number

Cause: The limit of an ID is 2147483642.

Action: Use an ID with value 214748364 or lower.

DRG-10016 you must be the owner to modify this object

Cause: An attempt was made to modify an object which you do not own.

Action: Have the owner modify the object.

DRG-10017 you must be string to do this: string

Cause: An attempt was made to modify an object which you have no privilege.

Action: Ask the owner modify the object.

DRG-10100 invalid argument found: string

Cause: Invalid command argument was specified.

Action: Check the documentation for the legal arguments and re-execute the command.

DRG-10101 no value for argument: string

Cause: This argument requires value(s).

Action: Re-execute the command with the correct argument value(s).

DRG-10102 mandatory argument missing: string

Cause: This argument is mandatory.

Action: Re-execute the command and specify the argument.

DRG-10103 illegal value for argument: string

Cause: An illegal value was passed to this argument.

Action: Check the documentation for the legal values for this argument.

DRG-10200 invalid server personality mask: string

Cause: The specification for the server personality mask is invalid.

Action: Check the documentation and specify the correct mask.

DRG-10202 server failed to register

Cause: The server failed to register itself with the data dictionary.

Action: Look at the next error on the stack.

DRG-10203 server named string does not exist

Cause: Update was called with the name of a server that does not exist.

Action: Correct the name of the server.

DRG-10204 server update failed

Cause: The attempt to update the server failed.

Action: Look at the next error on the stack.

DRG-10205 server deregister failed

Cause: The attempt to deregister the server from the data dictionary failed.

Action: Look at the next error on the stack.

DRG-10206 failed to perform recovery for a server or client

Cause: The attempt to perform recovery for a server or client failed.

Action: Contact Oracle Support Services.

DRG-10301 timed out waiting for responses from servers

Cause: Not enough servers are running to handle the current system load, and a large backlog of commands has accumulated; perhaps no servers are running. This message could also indicate an internal error where one of the servers has crashed trying to process a given request.

Action: Check that enough servers are running, and that they are processing commands of the correct type. For instance, a DDL command might timeout if all the servers are setup to exclusively process query commands. Also, check the server log files.

DRG-10302 interrupted waiting for responses from servers

Cause: User interrupted the request before it was completed.

Action: Restart the request.

DRG-10303 could not queue given commands to be processed

Cause: The given command or commands could not (all) be queued. This could indicate an extremely high system load, but it is more likely an internal error.

Action: Check if any servers are running to process the command.

DRG-10304 unexpected error sending command(s) to Oracle Text server

Cause: There was an unexpected error sending commands to the server.

Action: Contact Oracle Support Services.

DRG-10305 pipe string is full

Cause: Could not send command to pipe, because the pipe was full.

Action: Check if any servers are running to process the commands on that pipe.

DRG-10306 server terminated unexpectedly while processing command

Cause: The server shut down during execution of your command. This could be caused by a SHUTDOWN ABORT, or by an internal error in the server.

Action: If the server terminated had an internal error, then contact Oracle Support Services.

DRG-10307 no servers running

Cause: Could not process command because no servers are running with the correct personality mask.

Action: Start some servers with correct personality mask.

DRG-10308 no server with the required string personality mask is running

Cause: Could not process command because no servers are running with the correct personality mask.

Action: Start some servers with correct personality mask.

DRG-10309 not enough job queue processes

Cause: Could not process command because no servers with the correct personality mask are running.

Action: Increase the JOB_QUEUE_PROCESSES initialization parameter or reduce the parallel degree for this statement.

DRG-10310 servers were shutdown before processing request

Cause: The command could not be completed because the servers were shut down or terminated before processing the request.

Action: Start another server with the correct personality mask.

DRG-10311 remote send not supported

Cause: An attempt was made to specify a database link in an index specification.

Action: Specify only local index names.

DRG-10312 logfile name must be specified

Cause: An attempt was made to start logging without specifying a log file name.

Action: Specify a log file name.

DRG-10313 logging has already been started

Cause: An attempt was made to start logging even though logging has already been started.

Action: Stop logging first or ignore this message.

DRG-10314 logging has not been started

Cause: An attempt was made to stop logging even though logging has not been started.

Action: Start logging first or ignore this message.

DRG-10315 logging is not supported on MTS

Cause: You tried to start logging on MTS

Action:

DRG-10500 CREATE_INDEX failed: column spec string

Cause: Failed to create text index on the specified column.

Action: See the next errors on stack and take appropriate action.

DRG-10501 invalid stopword: string

Cause: The stopword specified could be lexed into multiple tokens with current lexer preference.

Action: Check lexer preference and respecify the stopword.

DRG-10502 index string does not exist

Cause: The specified index does not exist or you do not have access to it.

Action: Check the name of the index and your access to it.

DRG-10503 table string cannot be indexed because it has no primary key

Cause: A text key needs to be a single column unique key whose length does not exceed 64 bytes. no such key was defined as an unique index or declared as a primary or unique key constraint.

Action: Create a suitable text key for the table or specify it explicitly in this procedure call.

DRG-10504 primary key is required when using the DETAIL_DATASTORE

Cause: you tried to use the detail datastore to index a table with no primary key constraint

Action: Add a primary key constraint on the table

DRG-10506 table does not exist: string

Cause: The table, view, or synonym specified does not exist. There may also be a permissions problem reading the table.

Action: Reinvoke the operation with the correct table name.

DRG-10507 duplicate index name: string

Cause: The specified index already exists in the dictionary.

Action: This index can be updated or deleted, however this is only allowed if there is no text index available on the text column.

DRG-10509 invalid text column: string

Cause: The column specified is not valid.

Action: Check that the following are valid:

  • Text column is of supported datatype
  • Valid table name, column name in the specification

DRG-10510 stopword is missing

Cause: The stopword to be added was not specified.

Action: Specify the stopword.

DRG-10511 index string does not exist or is incomplete

Cause: Index creation is not complete.

Action: Create index before performing this operation.

DRG-10513 index string metadata is corrupt

Cause: Dictionary contains bad preferences for this index.

Action: Contact your database administrator.

DRG-10516 failed to perform DDL operation due to an Oracle error

Cause: The DDL operation requested has failed because of an Oracle error.

Action: See the Oracle error on the stack and take the appropriate action.

DRG-10517 index string is already valid

Cause: The index was in a valid state and did not need the requested operation.

Action: Check the requested operation.

DRG-10518 an operation is in progress which conflicts with string request

Cause: Another session is operating on this index. It could be:

  • DML is requested and DDL is in progress or
  • DDL is requested and DML is in progress operation on the index

Action: Try again later.

DRG-10520 failed to drop index: string

Cause: Failed to drop index on the specified index.

Action: See the Oracle error on the stack and take the appropriate action.

DRG-10525 missing REBUILD keyword

Cause: All Oracle Text alter index options required the REBUILD keyword.

Action: Specify alter index with the REBUILD keyword.

DRG-10528 primary keys of type string are not allowed

Cause: An attempt was made to create an index on a table with an illegal primary key datatype.

Action: Change the text key to one of the followings: VARCHAR2, NUMBER, VARCHAR, DATE, CHAR, MLSLABEL.

DRG-10531 parallel parameter must be > 0

Cause: You called create index with parallel = 0.

Action: Specify with value > 0.

DRG-10532 table is not partitioned

Cause: You called parallel create index on nonpartitioned table

Action: recreate the table with partitions or remove the PARALLEL clause

DRG-10533 invalid user name: string

Cause: You specified a user name that is invalid.

Action: Specify the correct user name.

DRG-10535 failed to optimize text index string

Cause: The optimize operation requested has failed because of an Oracle error.

Action: See the Oracle error on the stack and take the appropriate action.

DRG-10549 length of the object name string exceeded the limit

Cause: Object name has exceeded the maximum length of 30 bytes.

Action: Reduce the length of the object name if you want to re-create it.

DRG-10550 illegal syntax for index, preference, source or section name

Cause: Name may have additional periods(.).

Action: Check the syntax of the name.

DRG-10553 illegal syntax for column specification string

Cause: Column specification may have additional periods(.).

Action: Check the syntax of column specification if you want to re-create it.

DRG-10561 index string is not valid for requested operation

Cause: The index was not in a valid state due to some prior error.

Action: Drop index and create index again.

DRG-10562 missing alter index parameter

Cause: The parameter string was missing.

Action: Provide correct parameter string with regard to the requested alter index operation.

DRG-10569 table or column does not exist: string

Cause: The table, view, synonym or column specified does not exist. There may also be a permissions problem reading the table.

Action: Reinvoke the operation with the correct table name or column name.

DRG-10573 index string is obsolete

Cause: An obsolete index was specified.

Action: Perform UPGRADE_INDEX on the index.

DRG-10574 failed to upgrade text index string

Cause: The upgrade operation has failed because of an Oracle error.

Action: See the Oracle error on the stack and take the appropriate action.

DRG-10579 must provide text query criteria

Cause: Text query criteria is mandatory.

Action: Provide text query criteria.

DRG-10580 parallel indexing is not supported: string

Cause: An attempt was made to create index with parallel servers.

Action: Drop index and set parallel to 1 in create index.

DRG-10581 indirect datastores cannot be used with long or lob text columns

Cause: An attempt was made to create an index on a log or LOB column using an indirect datastore such as the file or URL datastores.

Action: Use a direct datastore or a VARCHAR column.

DRG-10582 column string does not exist in table string

Cause: An invalid column was specified.

Action: Specify a valid column.

DRG-10583 TRUNCATE INDEX failed: string

Cause: Failed to truncate the specified index.

Action: See the next errors on the stack and take appropriate action.

DRG-10584 failed to string string string due to an Oracle error

Cause: A DDL operation on an index object failed due to SQL error.

Action: See the accompanying error.

DRG-10595 ALTER INDEX string failed

Cause: Failed to alter index.

Action: See the next errors on stack and take appropriate action.

DRG-10597 invalid rebuild online operation

Cause: REBUILD ONLINE is not supported for requested operation.

Action: Alter index without the online option.

DRG-10598 invalid parallel operation

Cause: PARALLEL is not supported for requested operation.

Action: Alter index without the parallel option.

DRG-10599 column is not indexed

Cause: The column specified is not indexed.

Action: Create an index on the column before performing this operation.

DRG-10601 failed to remove pending DML for this index

Cause: The system could not remove triggers setup to monitor updates to the requested table.

Action: See next error on stack to determine course of action. Contact Oracle Support Services if necessary. Until this error is fixed, updates to all text columns in the given table may not be indexed.

DRG-10602 failed to queue DML change to column string for primary key string

Cause: The system could not record that a change had been made to the given column.

Action: See next error on stack to determine course of action. Contact Oracle Support Services if necessary. Until this error is fixed, updates to all text columns in the given table may not be indexed.

DRG-10606 server failed to access the DML Queue

Cause: The server was had an error accessing the DML Queue.

Action: See next error on stack.

DRG-10700 preference does not exist: string

Cause: The preference name specified does not exists.

Action: Retry with the correct preference name.

DRG-10701 preference string already exists

Cause: The specified preference already exists.

Action: Drop the preference if you want to re-create it.

DRG-10702 cannot create or modify preference in another user's schema

Cause: An attempt was made to create or modify in another user's schema.

Action: Owner or CTXSYS or a user who has CTXADMIN role should create preference.

DRG-10703 invalid framework object string

Cause: You specified an invalid object type.

Action: Use a valid framework object.

DRG-10704 preference string does not have an attribute named string

Cause: An attempt was made to set value for a invalid attribute (not supported by the object.

Action: Specify the correct attribute name.

DRG-10705 invalid value string for attribute string

Cause: An attempt was made to set an illegal value for an attribute.

Action: Specify the correct attribute value for the datatype of the attribute.

DRG-10706 length of string exceeds maximum size of string

Cause: Parameter is too many bytes.

Action: Correct preference setting and resubmit.

DRG-10707 a value is required for attribute string of preference string

Cause: A required attribute was not provided.

Action: Correct preference setting and resubmit.

DRG-10708 invalid class id string for preference string

Cause: The specified class ID is not correct for the specified preference.

Action: Specify the correct class ID.

DRG-10709 this preference is referenced by string and cannot be dropped

Cause: The specified preference is used as part of another preference and cannot be dropped until the referring preference is modified.

Action: Modify the referring preference.

DRG-10750 unknown parameter string

Cause: Unrecognized parameter.

Action: Specify correct parameter.

DRG-10751 invalid value for parameter

Cause: Wrong data type or out of range.

Action: Specify correct parameter value.

DRG-10752 DEFAULT_INDEX_MEMORY cannot be greater than MAX_INDEX_MEMORY

Cause: An attempt was made to set DEFAULT_INDEX_MEMORY to a value higher than the maximum set in MAX_INDEX_MEMORY.

Action: Specify a lower value.

DRG-10753 invalid memory size string string

Cause: An incorrectly formatted memory string was specified.

Action: Specify a correctly formatted memory string.

DRG-10754 memory size must be between string and string

Cause: A memory size outside the allowed range was specified.

Action: Specify a memory size within the allowed range.

DRG-10755 string and string have characters in common

Cause: The join character sets cannot have characters in common.

Action: Correct the attribute values and resubmit.

DRG-10756 neither text indexing nor theme indexing has been selected

Cause: INDEX_TEXT and INDEX_THEMES preferences both cannot be FALSE.

Action: Set either of INDEX_TEXT or INDEX_THEMES or both to TRUE.

DRG-10757 stoplist cannot have more than 4096 stopwords

Cause: A stop list cannot have more than 4096 stopwords. This includes stop themes.

Action: Do not use more than 4096 stopwords.

DRG-10758 index owner does not have the privilege to use this preference

Cause: Index owner does not have the role defined in FILE_DATATSTORE_ROLE.

Action: Grant index owner the appropriate role.

DRG-10759 invalid role

Cause: The role does not exist in the database.

Action: Check the role name or create the role.

DRG-10800 query failed: string string string

Cause: Failed to process the query.

Action: Check the errors on stack and take appropriate action.

DRG-10801 cannot create an SQE for another user

Cause: An attempt was made to create an SQE for another use.

Action: Remove the owner from the SQE name specification.

DRG-10816 display/highlight call failed

Cause: See the next error on the stack.

Action: See the next error on the stack.

DRG-10817 CONTAINS term consists of stopword or phrase of stopwords: string

Cause: One or more terms within a CONTAINS query consist of just a stopword or a phrase of just stopwords.

Action: Replace the stopword or use stopwords within phrases containing non-stopwords.

DRG-10819 could not open contains cursor

Cause: An error occurred while trying to open a contains cursor.

Action: See accompanying error messages in the stack.

DRG-10820 invalid contains cursor id

Cause: An attempt was made to fetch or close a contains cursor with an ID which does not exist.

Action: Review fetch or close invocation.

DRG-10821 contains cursor is not open

Cause: An attempt was made to fetch from a contains cursor which was not open.

Action: Open the cursor before performing the fetch.

DRG-10822 duplicate query name

Cause: An attempt was made to create a stored query with a name already used.

Action: Use a different name.

DRG-10823 invalid query name

Cause: The query name specified is not valid.

Action: Check the query name.

DRG-10825 stored query does not exist: string

Cause: The specified stored query does not exist.

Action: Check the query name.

DRG-10826 no document with the specified textkey is found

Cause: There is no document with the specified text key.

Action: Check the text key.

DRG-10827 open_con must be performed before count_last

Cause: LAST_COUNT returns hit from in-memory query, so an in-memory query must be run before you can use COUNT_LAST.

Action: Execute OPEN_CON before you run COUNT_LAST.

DRG-10828 token string is longer than maximum length for column string

Cause: A token to be inserted in the feedback table is longer than the maximum allowed column size.

Action: Modify the query, or the column size for feedback table, or feedback procedure arguments accordingly.

DRG-10829 feedback id string is longer than the maximum length of string bytes

Cause: FEEDBACK_ID is longer than the maximum allowed length for the FEEDBACK_ID column.

Action: Use a smaller FEEDBACK_ID.

DRG-10830 SHARELEVEL is not 0 or 1

Cause: You specified an invalid value for SHARELEVEL.

Action: Use SHARELEVEL equal to 0 or 1 only.

DRG-10831 can not insert into feedback table string

Cause: Not privileged to insert.

Action: Check privileges.

DRG-10832 can not delete from feedback table string

Cause: Not privileged to delete.

Action: Check privileges.

DRG-10833 feedback failed

Cause: Failed to process feedback request.

Action: Check the errors on stack and take appropriate action.

DRG-10834 upper-case form of section name string too long

Cause: Upper-case form of the section name is longer then supported length.

Action: Reduce length of section name when adding section.

DRG-10835 WITHIN operator not supported for theme index

Cause: WITHIN operator used in theme index query.

Action: Rewrite query without WITHIN operator.

DRG-10836 field section and attribute section can not be nested

Cause: A field section or a attribute section is specified in a nested section search.

Action: Rewrite query without nested field sections.

DRG-10837 section string does not exist

Cause: The given section name does not exist in USER_SECTIONS.

Action: Rewrite query with valid section name.

DRG-10838 invalid SPAN argument supplied to NEAR

Cause: An invalid value was supplied for SPAN argument to NEAR.

Action: Provide a valid SPAN. Valid values are integers from 0 to 100.

DRG-10839 invalid ORDER argument supplied to NEAR

Cause: An invalid value was supplied for ORDER argument to NEAR.

Action: Provide a valid ORDER. Valid values are T, TRUE, F, FALSE (case insensitive).

DRG-10840 CONTAINS predicate including 0 is not supported by FIRST_ROWS hint

Cause: An attempt was made to issue a query with the CONTAINS predicate including 0 with the FIRST_ROWS hint.

Action: Remove the FIRST_ROWS hint.

DRG-10841 invalid SCORE argument supplied to FUZZY

Cause: An invalid value was supplied for SCORE argument to FUZZY.

Action: Provide a valid SCORE. Valid values are integers from 0 to 80.

DRG-10842 invalid NUMRESULTS argument supplied to FUZZY

Cause: An invalid value was supplied for NUMRESULTS argument to FUZZY.

Action: Provide a valid NUMRESULTS. Valid values are integers from 0 to 5000.

DRG-10843 invalid WEIGHT argument supplied to FUZZY

Cause: An invalid value was supplied for WEIGHT argument to FUZZY.

Action: Set WEIGHT to WEIGHT or NOWEIGHT.

DRG-10844 index cannot execute this structured predicate efficiently

Cause: An attempt was made to specify a combination of condition and ORDER BY columns in a CATSEARCH query which cannot be executed by the index's index set efficiently.

Action:

DRG-10845 column string is not indexed

Cause: A column was specified in a condition or ORDER BY which is not part of the CTXCAT index.

Action:

DRG-10846 order by columns must be all ascending or all descending

Cause: An ORDER BY clause was specified which has some columns ascending and some descending. This is not currently supported by CATSEARCH.

Action:

DRG-10847 catsearch requires prefix index for this type of queries

Cause: For efficient execution of this VGRAM query, a prefix index is required.

Action: Create a prefix index.

DRG-10848 invalid structured clause

Cause: An invalid structured clause was specified.

Action:

DRG-10849 catsearch does not support functional invocation

Cause: The query plan for your query is invoking a CATSEARCH operator functionally rather than as an index rowsource. The CATSEARCH operator does not support functional invocation.

Action: Add optimizer hints so that all CATSEARCH operators are performed through index scans.

DRG-10850 CTXRULE indextype does not support the operator

Cause: An operator was specified that is not supported by CTXRULE. Currently only AND, NEAR, phrase, NOT, WITHIN, OR, ABOUT, EQUIVALENCE, STEM, and THESAURUS operators are supported.

Action: Rewrite the query without this operator.

DRG-10851 Invalid grammar string specified for query template

Cause: Incorrect grammar specification.

Action: Rewrite the query specifying a valid grammar name.

DRG-10852 Invalid scoring type string specified for query template

Cause: Incorrect scoring type specification.

Action: Rewrite the query specifying a valid scoring type (integer/float).

DRG-10853 Catsearch does not support this operator

Cause: An unsupported operator was specified.

Action: Rewrite the query using valid operators.

DRG-10900 out of memory

Cause: Cannot allocate more memory.

Action: Contact your system administrator.

DRG-11000 invalid keyword string

Cause: An invalid keyword was specified.

Action: Respecify the parameter string with correct keyword.

DRG-11001 missing keyword when expecting one of string

Cause: A keyword was missing.

Action: Respecify the parameter string with keyword.

DRG-11002 missing value for string

Cause: A value for the argument was missing.

Action: Respecify the parameter string with value.

DRG-11003 invalid value string for string

Cause: An invalid value was specified for the argument.

Action: Specify a valid value.

DRG-11004 duplicate or conflicting value for string

Cause: More than one value was specified for the argument.

Action: Check parameter string and correct the problem parameter.

DRG-11005 invalid create index parameter string

Cause: The supplied parameter string is not correct.

Action: Drop and re-create the index with the correct parameters.

DRG-11006 invalid alter index parameter string

Cause: An invalid parameter string was specified.

Action: Re-issue the statement with the correct parameter string.

DRG-11007 multiple stopwords specified

Cause: An attempt was made to add more than one stopword.

Action: Specify one stopword at a time.

DRG-11008 invalid create index partition parameter string

Cause: The parameter string was invalid.

Action: Drop the index and recreate it with correct parameters.

DRG-11100 unable to connect to the database

Cause: Failed to connect to Oracle database.

Action: Check the Oracle error and connect string.

DRG-11101 failed to open file string

Cause: Failed to open a file.

Action: Check whether the file exist or access permission available.

DRG-11102 assigned lexer can not operate on string language setting

Cause: Single byte lexer selected in multibyte language setting.

Action: Check RDBMS language setting or text columns lexer setting.

DRG-11104 Oracle Text error:

Cause: See the next error on the stack.

Action: See the next error on the stack.

DRG-11106 user database session has terminated during this operation

Cause: This database session does not exist or has terminated.

Action: Determine why the user database session terminated while the operation was still being carried out.

DRG-11107 invalid path specification: string

Cause: The path specified is not valid.

Action: Check the path specification.

DRG-11108 invalid filename specified: string

Cause: The file name specified is not valid.

Action: Check the file name for beginning or trailing spaces, invalid characters, or other such problems.

DRG-11109 assigned lexer does not support string query operator

Cause: This lexer does not support this query operator.

Action: Do not use the operator in your query.

DRG-11110 string

DRG-11111 value of string must be between string and string

Cause: A value for the parameter was specified that is out of range.

Action: Specify a value for that parameter that is in the correct range.

DRG-11112 length of string exceeds maximum of string

Cause: A value for the parameter was specified that is too long.

Action: Specify a value for the parameter that is the correct length.

DRG-11113 value of string must be one of string

Cause: A value for the parameter was specified that is invalid.

Action: Specify a valid parameter value.

DRG-11114 result table format is not correct for this operation

Cause: A result table was specified which has the wrong number, type, or names of columns for this operation.

Action: Check result table. Refer to the documentation for the correct format for each operation.

DRG-11115 a value for string must be specified

Cause: A value for the parameter was not specified.

Action: Specify a value for the parameter.

DRG-11116 value of string must be less than or equal to value of string

Cause: The values specified for the two parameters are invalid.

Action: Specify valid values for the parameters.

DRG-11117 name is already used by an existing object

Cause: You tried to create an object whose name conflicts with an object of that type which already exists.

Action: Specify a new name.

DRG-11118 object string does not exist

Cause: An attempt was made to modify or drop an object that does not exist.

Action: Specify the correct object name.

DRG-11119 operation is not supported by this index type

Cause: An attempt was made to invoke an operation on an index that is not supported by the index type.

Action:

DRG-11120 failed to write to file string

Cause: Failed to write to a file.

Action: Check whether the file exists or access permission is available.

DRG-11121 failed to read from file string

Cause: Failed to read from a file.

Action: Check whether the file exists or access permission is available.

DRG-11122 unsupported section group

Cause: An unsupported section group was specified for functional contains.

Action: Change the section group to NULL_SECTION_GROUP.

DRG-11123 theme indexing is not supported

Cause: Theme indexing is on in the lexer preference for functional contains.

Action: Turn off theme indexing.

DRG-11203 INSO filter not supported on this platform

Cause: An attempt was made to use the INSO filter on a platform that does not support it.

Action: Do not use the INSO filter.

DRG-11204 user filter command is too long

Cause: The user filter command must be 32 characters or less.

Action: Use 32 characters or less for the user filter command.

DRG-11205 user filter command contains illegal characters

Cause: The user filter command cannot contain special characters such as slashes, parentheses, semicolons, and so on.

Action: Do not use special characters in the user filter command.

DRG-11206 user filter command string could not be executed

Cause: The user filter command could not be executed.

Action: Check that the command exists in $ORACLE_HOME/ctx/bin, and that it is executable.

DRG-11207 user filter command exited with status string

Cause: The user filter command exited with the given error status.

Action: No action required.

DRG-11208 ORACLE_HOME is not set

Cause: ORACLE_HOME is not set.

Action: Make sure ORACLE_HOME is set when running CTXSRV.

DRG-11209 filename for string exceeds maximum length of string

Cause: Value of the file name is too long.

Action: Specify a value for the file name that is not too long.

DRG-11210 format column must be a char, varchar, or varchar2 type

Cause: A format column was specified which is not a char, varchar, or varchar2 type.

Action: Specify a format column of the correct type.

DRG-11211 charset column must be a char, varchar, or varchar2 type

Cause: A charset column was specified which is not a char, varchar, or varchar2 type.

Action: Specify a charset column of the correct type.

DRG-11211 charset column must be a char, varchar, or varchar2 type

Cause: you specified a charset column which is not a char, varchar, or varchar2 type.

Action: specify a charset column of correct type

DRG-11212 procedure filter procedure name contains a semicolon

Cause: The procedure name specified had a semicolon.

Action: Remove semicolon or rename procedure. The correct format is PACKAGENAME.PROCEDURE_NAME.

DRG-11213 CTXSYS does not own procedure filter stored procedure: string

Cause: CTXSYS does not have execute privilege to the procedure filter stored procedure.

Action: Make sure the package is owned by CTXSYS and the procedure exists.

DRG-11214 execution of procedure filter stored procedure has failed

Cause: An error occur while executing the procedure filter stored procedure.

Action: Check or debug the stored procedure.

DRG-11215 index owner does not have access to filter stored procedure: string

Cause: The index owner does not have execute privilege on the procedure.

Action: CTXSYS to grant execute privilege of the procedure to index owner.

DRG-11216 length of datastore data exceeds limit

Cause: The length of the datastore data passed to the filter stored procedure is longer than the maximum length (32767 bytes).

Action: Check primary key parameter.

DRG-11217 INSO safe callout failed

Cause: The INSO safe callout cannot be executed.

Action: Check the Oracle errpr.

DRG-11301 error while indexing document

Cause: An error was encountered while indexing the document. The error may have occurred during lexing, parsing for sections, or other action during document tokenization.

Action: Review document and update with valid data. Note that the document contents may have been partially indexed, so it may be returned by some queries.

DRG-11303 secondary indexes are not supported by this indextype

Cause: An attempt was made to create an index on an index-organized table, but the indextype does not support this action.

DRG-11304 function-based indexes are not supported by this indextype

Cause: An attempt was made to create a function-based index but the indextype does not support this action.

DRG-11305 create/alter index string is in progress in another session

Cause: An attempt was made to mark the index from INPROGRESS to FAILURE but create/alter on the same index is in progress in another session.

DRG-11306 operation cannot be performed on a policy

Cause: An attempt was made to perform an operation on a policy, but the operation is only valid for an index.

DRG-11307 operation cannot be performed on an index

Cause: An attempt was made to perform an operation on an index, but the operation is only valid for a policy.

DRG-11400 failed to parse document with key string

Cause: The document specified for linguistic extraction could not be parsed. This could indicate that the document is not well-formed English.

Action: Check the document contents.

DRG-11403 primary key value too long

Cause: The primary key value parameter passed to the service request is longer than the maximum primary key length (64 bytes).

Action: Check primary key parameter.

DRG-11404 no primary key value specified

Cause: The primary key value parameter passed to the service request is null.

Action: Check primary key parameter.

DRG-11410 could not insert into string result table

Cause: An Oracle error occurred while linguistic output was being inserted into the result table.

Action: Take action appropriate to the Oracle error code.

DRG-11418 insufficient document content for linguistic parser

Cause: The document specified for linguistic extraction was parsed but the document content was insufficient for linguistic extraction by the specified parser.

Action: Check the document contents or try modifying linguistic settings.

DRG-11422 linguistic initialization failed

Cause: Linguistic services initialization failed.

Action: Check to see if knowledge base files are present for the language.

DRG-11425 gist level string is invalid

Cause: An invalid gist level was specified.

Action: Specify a valid gist level.

DRG-11427 valid gist level values are string

Cause: This is an informational message.

Action: No action required.

DRG-11432 file error while accessing knowledge base

Cause: An oracle error was encountered during knowledge base access

Action: Check to see if knowledge base files are present for the language.

DRG-11435 primary key value is invalid

Cause: The primary key value parameter passed to the service request is not valid.

Action: Check primary key parameter.

DRG-11439 index name length exceeds maximum of string bytes

Cause: The length of the index name is longer than the maximum index name size.

Action: Drop the index and re-create it with a shorter index name.

DRG-11440 operation not supported for the string language

Cause: The requested operation is not supported for the current language.

Action: Use only supported operations.

DRG-11441 gist numParagraphs string is invalid

Cause: An invalid value for gist numParagraphs was used.

Action: Use only valid values for gist numParagraphs.

DRG-11442 valid gist numParagraphs values are string

Cause: An invalid value for gist numParagraphs was used.

Action: Note the valid values for gist numParagraphs provided by this message.

DRG-11443 gist maxPercent string is invalid

Cause: An invalid value for gist maxPercent was used.

Action: Use only valid values for gist maxPercent.

DRG-11444 valid gist maxPercent values are string

Cause: An invalid value for gist maxPercent was used.

Action: Note the valid values for gist maxPercent provided by this message.

DRG-11445 rowid value is invalid: string

Cause: The ROWID value parameter passed to the service request is not valid.

Action: Check the ROWID parameter.

DRG-11500 column name expected, found string on line string

Cause: Possibly misspelled a column name or keyword.

Action: Check spellings and punctuation around specified line.

DRG-11501 identifier string found in place of column name on line string

Cause: Possibly misspelled column name.

Action: Check spellings around specified line.

DRG-11502 read of file failed at line string for file string

Cause: Bad file name, wrong FILE_TYPE or file system error.

Action: Check file name, type and/or file integrity.

DRG-11503 insert statement overflows maximum statement size

Cause: Total length of statement exceeds database maximum.

Action: Reduce length of column names or number of columns.

DRG-11504 invalid longsize parameter of string specified

Cause: Invalid option argument.

Action: Specify long buffer size in kbytes above 0.

DRG-11505 long data on line string not found or invalid

Cause: Either bad data or bad datafile.

Action: Check whether the file exists and is accessible, if separate.

DRG-11506 record ignored on line string because of error(s)

Cause: An error occurred parsing this row's data.

Action: Move and amend line in error to alternate load file.

DRG-11507 file error trying to read file string

Cause: File not found or could not be read.

Action: Check name and location of file.

DRG-11508 bad or missing string token on line string

Cause: Token expected was not found.

Action: Move and amend record affected to error load file.

DRG-11509 value expected on line string

Cause: Could not make sense of text where value expected.

Action: Move and amend record affected to error load file.

DRG-11510 encountered unrecoverable error on line string

Cause: See previous messages.

Action: See previous message.

DRG-11511 specified table does not contain a LONG RAW column

Cause: Text must be inserted into a LONG RAW type column.

Action: Check table and type of data.

DRG-11512 bad syntax for thesaurus load file at line string

Cause: Load file must have specific format for loading thesaurus.

Action: Check documentation for description of correct format.

DRG-11513 unable to open or write to file string

Cause: An attempt to open or to write to the given file failed.

Action: Check with system administrator.

DRG-11514 user string does not have UPDATE or SELECT privilege on string

Cause: User has not been granted UPDATE or SELECT privilege.

Action: Check privilege on the user.

DRG-11515 not enough text key values

Cause: Number of values provided does not match the number of text keys.

Action: Provide same number of values as the number of text keys.

DRG-11516 user must be at least in role CTXUSER to perform this operation

Cause: User does not have CTXUSER, CXAPP or CTXADMIN role.

Action: Grant user the proper role.

DRG-11517 error when validating text objects

Cause: See accompanying Oracle error.

Action: See accompanying Oracle error.

DRG-11518 text table string does not have a LONG or LONG RAW column

Cause: Table specified does not have a LONG or LONG RAW column.

Action: Check the table.

DRG-11519 encounter error when exporting a LONG or LONG RAW column

Cause: See accompanying error message.

Action: See accompanying error message.

DRG-11520 error writing to file

Cause: File does not exist.

Action: Make sure file exists.

DRG-11521 encounter error when updating a LONG or LONG RAW column

Cause: See accompanying error message.

Action: See accompanying error message.

DRG-11522 no row exists for the text key(s) specified

Cause: No row in the table has the text key(s) specified.

Action: Use a valid text key(s).

DRG-11523 unable to lock the specified row for update

Cause: Some other process has a lock on the row.

Action: Release the lock or wait until the lock is released.

DRG-11524 primary key value is missing

Cause: Primary key value is not provided.

Action: Provide the primary key value(s).

DRG-11525 invalid commitafter parameter of string specified

Cause: Invalid option argument.

Action: Specify commit after above 0.

DRG-11526 filename exceeds maximum length

Cause: Value of the file name is too long.

Action: Use a file name value that does not exceed the maximum length.

DRG-11527 end token not found on line string

Cause: <TEXTEND> not found at end of record.

Action: Processing discontinued; amend the record.

DRG-11528 LONG or LONG RAW column defintion found in structure data

Cause: Could be misplaced.

Action: Remove reference to LONG or LONG RAW column from structure data.

DRG-11529 token exceeds maximum length

Cause: Value of the column name or value is too long.

Action: Processing discontinued; amend the record.

DRG-11530 token exceeds maximum length

Cause: Value of the phrase or relation word is too long.

Action: Processing discontinued; amend the record.

DRG-11531 start token not found on line string

Cause: <TEXTSTART: not found at start of record.

Action: Processing discontinued; amend the record.

DRG-11532 error reading through end of line string for file string

Cause: Characters encountered while reading through end of line.

Action: Remove extraneous characters.

DRG-11533 improper value of column string

Cause: Value of the column is too long or mismatched quote.

Action: Processing discontinued; amend the record.

DRG-11534 invalid column string

Cause: Column does not exist or it is misspelled.

Action: Processing discontinued; amend the record.

DRG-11535 error writing phrase or qualifier: string on line string to memory

Cause: Not enough memory

Action: Allocate more memory; contact Oracle Support Services if the problem persists.

DRG-11600 URL store: string has permanently moved

Cause: The document referred to by the URL has permanently moved.

Action: Find the new address, if any, of the document.

DRG-11601 URL store: bad syntax on request for string

Cause: Client did not make correct request.

Action: Contact Oracle Support Services.

DRG-11602 URL store: access to string requires authentication

Cause: User has to provide password or other authentication.

Action: Get required access, or check URL.

DRG-11603 URL store: payment required to access string

Cause: Payment is required before the URL can be accessed.

Action: Check URL, or pay if required if access necessary.

DRG-11604 URL store: access to string is denied

Cause: Access to the URL is denied.

Action: Check URL; if correct, do not try to access URL again.

DRG-11605 URL store: document specified by string not found

Cause: The document was be found on the host specified.

Action: Check the URL.

DRG-11606 URL store: access to string timed out waiting for client request

Cause: Client did not make response within timeout period.

Action: Contact Oracle Support Services.

DRG-11607 URL store: access to string was denied due to garbled response

Cause: Web server identified in URL does not obey HTTP protocol.

Action: Contact the Web administrator of the remote host.

DRG-11608 URL store: host portion of string specified incorrectly

Cause: Host portion of the URL could not be parsed.

Action: Check the URL.

DRG-11609 URL store: unable to open local file specified by string

Cause: Attempt to open local file failed.

Action: Check the URL.

DRG-11610 URL store: unable to read local file specified by string

Cause: Attempt to read local file failed.

Action: Contact the system administrator.

DRG-11611 URL store: unknown protocol specified in string

Cause: The protocol parsed is neither HTTP or file.

Action: Check the URL.

DRG-11612 URL store: unknown host specified in string

Cause: The address of the host specified could not be resolved.

Action: Check the URL.

DRG-11613 URL store: connection refused to host specified by string

Cause: Attempt to connect to host was forcibly refused.

Action: Check the URL.

DRG-11614 URL store: communication with host specified in string timed out

Cause: A network operation timed out.

Action: Try again later; network connection may be down to Web server.

DRG-11615 URL store: write failed sending to string over network

Cause: Unknown error writing request to Web server.

Action: Check the network connection.

DRG-11616 URL store: too many redirections trying to access string

Cause: Too long a chain of HTTP redirections given the URL.

Action: Contact the Web administrator of the remote host.

DRG-11617 URL store: URL string is too long

Cause: The length of the URL string is longer than URLSIZE.

Action: Set URLSIZE attribute to a larger value.

DRG-11618 URL store: document identified by string is too large

Cause: Document larger than user-set maximum size.

Action: Do not access URL, or increase document size limit.

DRG-11619 URL store: row in table is empty

Cause: Row deleted or otherwise missing.

Action: Check the table if necessary.

DRG-11620 URL store: thread operation error

Cause: Thread operation failed.

Action: Contact the system administrator.

DRG-11621 URL store: socket open error for string

Cause: Socket open failed; probably too many open file descriptors.

Action: Reduce the maximum number of threads started.

DRG-11622 URL store: unknown HTTP error getting string

Cause: An unexpected HTTP error has occurred.

Action: Consult HTTP error codes; if valid, then contact Oracle Support Services.

DRG-11623 URL store: unknown error getting string

Cause: An unexpected error has occurred.

Action: Contact Oracle Support Services.

DRG-11624 invalid attribute string for string: proper range string to string

Cause: An unexpected error has occurred.

Action: Change attribute value.

DRG-11625 MAXURLS * URLSIZE must be less than string

Cause: MAXURLS * URLSIZE cannot be larger than the limit.

Action: Lower either MAXURLS or URLSIZE.

DRG-11700 thesaurus string already exists

Cause: Thesaurus with same name exists.

Action: Use another name.

DRG-11701 thesaurus string does not exist

Cause: Thesaurus does not exist.

Action: Use another thesaurus or create it.

DRG-11702 string

Cause: Error while parsing thesaurus operator in query term.

Action: See error message for details.

DRG-11703 user string must have at least CTXAPP role to execute this function

Cause: Privilege is not sufficient.

Action: Grant user CTXAPP role.

DRG-11704 phrase string does not exist

Cause: Phrase does not exist.

Action: Use another phrase or create it.

DRG-11705 multilevel jump from string to string

Cause: The thesaurus load file has a multilevel jump which could not be parsed.

Action: Correct thesaurus file.

DRG-11706 invalid relation string

Cause: An invalid relation was specified.

Action: The set of valid relations will be displayed. Additionally, you may be able to specify a translation, which has the syntax languagename, where languagename can be any string up to 10 bytes. Specify a valid relation and resubmit.

DRG-11707 valid relations: string

Cause: An invalid relation was specified.

Action: The set of valid relations will be displayed. Additionally, you may be able to specify a translation, which has the syntax languagename, where languagename can be any string up to 10 bytes.

DRG-11708 too many thesauri

Cause: CTXKBTC cannot compile more than 16 thesauruses.

Action: Specify 16 or fewer thesauruses.

DRG-11709 too many terms in thesaurus

Cause: Number of thesaurus terms exceeds maximum.

Action: Use fewer terms.

DRG-11710 thesaurus term string too long

Cause: Knowledge base does not permit terms longer than 80 characters.

Action: Do not use any terms than are longer than 80 characters.

DRG-11711 too much data for term string

Cause: Internal limit on size of data per term.

Action: Redesign thesaurus.

DRG-11712 multiple Broader Terms for term string

Cause: Multiple broader terms are not allowed for a term.

Action: Make sure each term has only one broader term.

DRG-11713 multiple Preferred Terms per synonym ring

Cause: Multiple preferred terms are not allowed for a synonym ring.

Action: Make sure each synonym ring has only one preferred term.

DRG-11714 synonyms have different Broader Terms

Cause: All synonyms must have the same broader term.

Action: Make sure all synonyms have the same broader term.

DRG-11715 attempt to add a BT relation between 2 KB categories string and string

Cause: BT relation cannot be between two existing knowledge base categories.

Action: Redesign the BT hierarchy.

DRG-11716 attempt to add Narrower Term string for non-Preferred Term string

Cause: Only a PT can have NTs.

Action: Attach the NT to the preferred term.

DRG-11717 attempt to add Related Term string to non-Preferred Term string

Cause: Only a PT can have RTs.

Action: Attach the RT.

DRG-11718 multiple Preferred Terms for term string

Cause: Multiple preferred terms are not allowed for a term.

Action: Make sure each term has only one preferred term.

DRG-11719 Broader Term hierarchy too deep

Cause: The broader term hierarchy is too deep.

Action: Flatten the hierarchy for best results.

DRG-11720 too many synonyms per synonym ring

Cause: Too many synonyms for a single preferred term.

Action: Introduce further distinctions to deepen the hierarchy.

DRG-11721 thesaurus string is empty

Cause: No entries in thesaurus.

Action: Add some entries or drop the thesaurus.

DRG-11722 invalid language specification

Cause: Language specification cannot be more than 10 characters.

Action: Reduce language specification to less or equal to 10 characters.

DRG-11723 phrase cannot be NULL

Cause: An attempt was made to add a NULL phrase to the thesaurus.

Action: Specify a valid phrase.

DRG-11724 phrase string already exists

Cause: A phrase with the same name already exists.

Action: Use another name.

DRG-11725 phrase does not have any synonyms

Cause: An attempt was made to nominate a phrase with no synonyms to be the preferred term, or an attempt was made to drop SYN from a phrase with no synonyms.

Action: No action required.

DRG-11726 phrase is not a preferred term

Cause: An attempt was made to remove the preferred term relation from a phrase which is not a preferred term.

Action: No action required.

DRG-11727 phrase does not have any related terms

Cause: An attempt was made to drop a relation that does not exist.

Action: No action required.

DRG-11728 phrase does not have any broader terms of this type

Cause: An attempt was made to drop a relation that does not exist.

Action: No action required.

DRG-11729 phrase does not have any narrower terms of this type

Cause: An attempt was made to drop a relation that does not exist.

Action: No action required.

DRG-11730 relation does not exist

Cause: An attempt was made to drop a relation that does not exist.

Action: No action required.

DRG-11731 translation does not exist

Cause: An attempt was made to drop a translation that does not exist.

Action: No action required.

DRG-11732 phrase does not have any translations

Cause: An attempt was made to drop translations which do not exist.

Action: No action required.

DRG-11733 more than one translation for the term in the specified language

Cause: The term has more than one translation in the specified language.

Action: Specify a translation.

DRG-11801 Continue

Cause: Ask user to decide if continue is necessary (HTTP_ERROR = 100).

Action: Upon positive response, continue the original operation.

DRG-11802 Switching Protocols

Cause: Telling client a protocol switching just happened (HTTP_ERROR = 101).

Action: The user agent takes proper actions.

DRG-11803 OK

Cause: Telling client things are ok (HTTP_ERROR = 200).

Action: The user agent takes proper actions.

DRG-11804 Created

Cause: Telling client things are created (HTTP_ERROR = 201).

Action: The user agent takes proper actions.

DRG-11805 Accepted

Cause: Telling client things are accepted but not committed (HTTP_ERROR = 202).

Action: The user agent takes proper actions.

DRG-11806 Non-authoritative Information

Cause: The returned meta-information is not the definitive set (HTTP_ERROR = 203).

Action: The user agent knows the information is Non-authoritative.

DRG-11807 No Content

Cause: Request has been fulfilled but no new information found (HTTP_ERROR = 204).

Action: The user agent takes proper actions.

DRG-11808 Reset Content

Cause: Telling client to reset the document view (HTTP_ERROR = 205).

Action: The user agent takes proper actions.

DRG-11809 Partial Content

Cause: Telling client document content is a partial content (HTTP_ERROR = 206).

Action: The user agent takes proper actions.

DRG-11810 Partial Update OK

Cause: Telling client document is partially updated (HTTP_ERROR = 207).

Action: The user agent takes proper actions.

DRG-11811 Multiple Choices

Cause: Telling client multiple choices of resources is possible (HTTP_ERROR = 300).

Action: The user agent takes proper actions.

DRG-11812 Moved Permanently

Cause: The URI has been assigned a new permanent URI (HTTP_ERROR = 301).

Action: The user agent takes proper actions.

DRG-11813 Moved Temporarily

Cause: The URI resides temporarily under a different URI (HTTP_ERROR = 302).

Action: The user agent takes proper actions.

DRG-11814 See Other

Cause: The URI can be found using GET METHOD under a different URI (HTTP_ERROR = 303).

Action: The user agent takes proper actions.

DRG-11815 Not Modified

Cause: Response to conditional GET, indicating document not modified (HTTP_ERROR = 304).

Action: The user agent takes proper actions.

DRG-11816 Use Proxy

Cause: The client should use specified proxy to repeat the request (HTTP_ERROR = 305).

Action: The user agent takes proper actions.

DRG-11818 Temporary Redirect

Cause: The resource is temporarily under a different URI (HTTP_ERROR = 307).

Action: The user agent takes proper actions.

DRG-11819 Bad Request

Cause: The URL syntax is incorrect. Request rejected by server (HTTP_ERROR = 400).

Action: The user agent takes proper actions.

DRG-11820 Unauthorized

Cause: The request requires further authentication (HTTP_ERROR = 401).

Action: The user agent takes proper actions.

DRG-11822 Forbidden

Cause: The server refuses to fulfill the request from client (HTTP_ERROR = 403).

Action: The user agent takes proper actions.

DRG-11823 Not Found

Cause: The server cannot find the requested URI (HTTP_ERROR = 404).

Action: The user agent takes proper actions.

DRG-11824 Method Not Allowed

Cause: The user agent specified method not allowed (HTTP_ERROR = 405).

Action: The user agent reads allow header to decide alternatives.

DRG-11825 Not Acceptable

Cause: Requested resource is not acceptable according to request header (HTTP_ERROR = 406).

Action: The user agent should query the user for the next action.

DRG-11826 Proxy Authentication Required

Cause: The client must authenticate itself with the proxy (HTTP_ERROR = 407).

Action: The user agent takes proper actions.

DRG-11827 Request Timeout

Cause: The server is tired of waiting for the request (HTTP_ERROR = 408).

Action: The user agent repeats the request.

DRG-11828 Conflict

Cause: The request conflicts with the current state of the URI (HTTP_ERROR = 409).

Action: The user agent takes proper actions.

DRG-11829 Gone

Cause: The resource is no longer available and there is no forwarding address (HTTP_ERROR = 410).

Action: The user agent takes proper actions.

DRG-11830 Length Required

Cause: The server must receive a content-length header (HTTP_ERROR = 411).

Action: The user agent takes proper actions.

DRG-11831 Precondition Failed

Cause: Telling the user agent that the resource failed preconditions (HTTP_ERROR = 412).

Action: The user agent takes proper actions.

DRG-11832 Request Entity Too Large

Cause: Request rejected because request entity is too large (HTTP_ERROR = 413).

Action: If Retry-After header found, the user agent should retry.

DRG-11833 Request-URI Too Big

Cause: The server is refusing to accept the URI which is too big (HTTP_ERROR = 414).

Action: The user agent takes proper actions.

DRG-11834 Unsupported Media Type

Cause: The server is refusing the request because of media type (HTTP_ERROR = 415).

Action: The user agent takes proper actions.

DRG-11835 Requested Range Not Satisfiable

Cause: The byte range request cannot be satisfied by the resource extent (HTTP_ERROR = 416).

Action: The user agent reads content-range header in the response.

DRG-11836 Expectation Failed

Cause: Server cannot meet the user agent's expectation (HTTP_ERROR = 417).

Action: The user agent takes proper actions.

DRG-11839 Internal Server Error

Cause: The server encountered internal error in fulfilling the request (HTTP_ERROR = 500).

Action: The user agent takes proper actions.

DRG-11840 Not Implemented

Cause: The server cannot support a request feature which has yet to be implemented (HTTP_ERROR = 501).

Action: The user agent takes proper actions.

DRG-11841 Bad Gateway

Cause: In serving the request, the server received invalid response from gateway (HTTP_ERROR = 502).

Action: The user agent takes proper actions.

DRG-11842 Service Unavailable

Cause: Server overloaded or in maintenance mode (HTTP_ERROR = 503).

Action: If retry-after header is in the response, retry the request.

DRG-11843 Gateway Timeout

Cause: Upstream server did not respond to the gateway server in a timely way (HTTP_ERROR = 504).

Action: The user agent takes proper actions.

DRG-11844 HTTP Version Not Supported

Cause: The HTTP version in the request header is rejected by the server (HTTP_ERROR = 505).

Action: The user agent takes proper actions.

DRG-11846 Response Is Stale

Cause: The user agent knows the returned response is stale (HTTP_CACHE_ERROR = 10).

Action: The user agent client takes proper actions.

DRG-11847 Revalidation Failed

Cause: User agent's attempt to revalidate a stale response failed (HTTP_CACHE_ERROR = 11).

Action: The user agent client takes proper actions.

DRG-11848 Disconnected Operation

Cause: The cache is intentionally disconnected for a time period (HTTP_CACHE_ERROR = 12).

Action: The user agent client takes proper actions.

DRG-11849 Heuristic Expiration

Cause: Cache freshness lifetime and response age both greater than 24 hours (HTTP_CACHE_ERROR = 13).

Action: The user agent client takes proper actions.

DRG-11850 Transformation Applied

Cause: Telling cache manager that content encoding/media type has been changed in cache (HTTP_CACHE_ERROR = 14).

Action: The user agent takes proper actions.

DRG-11851 Cache Related Warning

Cause: Arbitrary information about cache to be presented to logger (HTTP_CACHE_ERROR = 99).

Action: The user agent client must not take any automated action.

DRG-11852 Can't Locate Remote Host

Cause: Connection to remote host failed (USER_AGENT_ERROR).

Action: The user agent client takes proper actions.

DRG-11853 No Host Name Found

Cause: The host name is not specified in URI (USER_AGENT_ERROR).

Action: The user agent client takes proper action.

DRG-11854 No File Name Found Or File Not Accessible

Cause: Unable to open the file specified (USER_AGENT_ERROR).

Action: The user agent client takes proper actions.

DRG-11855 FTP Server Replies

Cause: FTP server responds to the agent request (USER_AGENT_ERROR).

Action: The user agent client takes proper actions.

DRG-11856 FTP Server Doesn't Reply

Cause: No response from FTP server during operation (USER_AGENT_ERROR).

Action: The user agent client takes proper actions.

DRG-11857 Server Timed Out

Cause: Server operation timed out (USER_AGENT_ERROR).

Action: The user agent client takes proper actions.

DRG-11858 Gopher Server Replies

Cause: Gopher server responds to the agent request (USER_AGENT_ERROR).

Action: The user agent client takes proper actions.

DRG-11859 Data Transfer Interrupted

Cause: Processing of URL request was interrupted (USER_AGENT_ERROR).

Action: The user agent client takes proper actions.

DRG-11860 Connection Establishment Interrupted

Cause: Connection operation was interrupted (USER_AGENT_ERROR).

Action: The user agent client takes proper actions.

DRG-11861 CSO-server Replies

Cause: Telling client things are ok (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11862 This Is Probably A HTTP Server 0.9 Or Less

Cause: A very old web server (USER_AGENT_ERROR).

Action: The user agent client takes proper actions.

DRG-11863 Bad, Incomplete, Or Unknown Response

Cause: The server is numbering something not understandable (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11864 Unknown Access Authentication Scheme

Cause: The server is using an unknown access authentication scheme (USER_AGENT_ERROR).

Action: The user agent client takes proper actions.

DRG-11865 News Server Replies

Cause: News Server is responding (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11866 Please Try `ftp://' Instead Of `file://'

Cause: Wrong access scheme is used (USER_AGENT_ERROR).

Action: The user agent client takes proper actions.

DRG-11867 Method Not Suited For Automatic Redirection

Cause: Telling client things are ok (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11868 Too Many Redirections

Cause: The web server setup configured too many redirections (USER_AGENT_ERROR).

Action: The user agent client should take proper actions.

DRG-11869 Premature End Of File Detected

Cause: Detected end of file is unexpected (USER_AGENT_ERROR).

Action: The user agent client takes proper actions.

DRG-11870 Response From WAIS Server Too Large -- Extra Lines Ignored

Cause: Response from WAIS caused buffer overflow (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11871 WAIS Server Doesn't Return Any Data

Cause: Bad WAIS Server (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11872 Can't Connect To WAIS Server

Cause: Connect to WAIS server failed (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11873 System Call Replies

Cause: Register what system call replies (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11874 Wrong Or Unknown Access Scheme

Cause: Protocol class is wrongfully connected to the server (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11875 Access Scheme Is Not Allowed

Cause: Telling client things are ok (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11876 When Your Are Connected, You Can Log In

Cause: Pass information to telnet agent (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11877 This Cache Version Has Expired And Will Be Automatically Reloaded

Cause: Need to tell user that cache entry has been reloaded (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11878 Loading New Rules Must Be Explicitly Acknowledged

Cause: Let user agent client be aware of new rule loading (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-11879 Automatic Proxy Redirection Msut Be Explicitly Acknowledged

Cause: Let user agent client be aware of proxy redirection (USER_AGENT_ERROR).

Action: The user agent takes proper actions.

DRG-12001 Please enter username:

Cause: Prompt user for name (W3CLIB_MSG = 0).

Action: The user agent client takes proper actions.

DRG-12002 Please enter username for proxy authentication:

Cause: Prompt user for name (W3CLIB_MSG = 1).

Action: The user agent client takes proper actions.

DRG-12003 Please enter username for this FTP server:

Cause: Prompt user for name (W3CLIB_MSG = 2).

Action: The user agent client takes proper actions.

DRG-12004 Password:

Cause: Prompt user for password (W3CLIB_MSG = 3).

Action: The user agent client takes proper actions.

DRG-12005 Please give name of file to save in:

Cause: Prompt user for file name (W3CLIB_MSG = 4).

Action: The user agent client takes proper actions.

DRG-12006 Plase enter account:

Cause: Prompt user for account (W3CLIB_MSG = 5).

Action: The user agent client takes proper actions.

DRG-12007 You might not be allowed to use this method here, continue?

Cause: Warn user of deny of service (W3CLIB_MSG = 6).

Action: The user agent client takes proper actions.

DRG-12008 Location has moved, continue?

Cause: Warn user of location changes (W3CLIB_MSG = 7)

Action: The user agent client takes proper actions.

DRG-12009 A new set of rules is requested to be added to your setup - continue?

Cause: Warn user of rule changes (W3CLIB_MSG = 8).

Action: The user agent client takes proper actions.

DRG-12010 This file already exists - replace existing file?

Cause: Warn user of pending replacement (W3CLIB_MSG = 9).

Action: The user agent client takes proper actions.

DRG-12011 Authentication failed - retry?

Cause: Warn user of authentication failure (W3CLIB_MSG = 10).

Action: The user agent client takes proper actions.

DRG-12012 Proxy authentication failed - retry?

Cause: Warn user of proxy authentication failure (W3CLIB_MSG = 11).

Action: The user agent client takes proper actions.

DRG-12013 This method has already been performed - repeat operation?

Cause: Warn user the repetition of previous method used (W3CLIB_MSG = 12).

Action: The user agent client takes proper actions.

DRG-12014 This document is very big - continue operation?

Cause: Warn user of big document processing (W3CLIB_MSG = 13).

Action: The user agent client takes proper actions.

DRG-12015 The source document for this operation has moved - continue?

Cause: Warn user of location changes (W3CLIB_MSG = 14).

Action: The user agent client takes proper actions.

DRG-12016 The target document for this operation has moved - continue?

Cause: Warn user of destination document changes (W3CLIB_MSG = 15).

Action: The user agent client takes proper actions.

DRG-12017 A redirection may change the behavior of this method - proceed anyway?

Cause: Warn user of redirection effects on method (W3CLIB_MSG = 16).

Action: The user agent client takes proper actions.

DRG-12018 Encountered an automatic request for changing proxy - continue?

Cause: Warn user of automatic proxy change (W3CLIB_MSG = 17).

Action: The user agent client takes proper actions.

DRG-12201 section group string already exists

Cause: Section group with the same name already exists.

Action: Use another name or delete the existing one first.

DRG-12202 error while creating section group

Cause: Detect an Oracle error while creating section group.

Action: See the accompanying Oracle error and take appropriate action.

DRG-12203 section group string does not exist

Cause: Section group provided does not exist.

Action: Provide an existing section group.

DRG-12204 error while dropping section group string

Cause: Detected an Oracle error while dropping a section group.

Action: See the accompanying Oracle error and take appropriate action.

DRG-12206 tag string already exists in section group string

Cause: The start tag provided already exists in the same section.

Action: Provide another start tag.

DRG-12210 error while adding section string

Cause: Detected an Oracle error while adding a section.

Action: See the accompanying Oracle error and take appropriate action.

DRG-12211 section or section id string does not exist

Cause: Section name or section ID to be dropped does not exist.

Action: Provide an existing section name or section ID.

DRG-12212 error while dropping section string

Cause: Detected an Oracle error while dropping a section.

Action: See the accompanying Oracle error and take appropriate action.

DRG-12213 cannot create/drop section group or sections for other user

Cause: You can only create/drop section group objects of your own.

Action: Have the other user create/drop his/her own objects.

DRG-12217 tags cannot be more than 64 bytes

Cause: Maximum limit of start and end tag is 64 bytes.

Action: Provide a shorter start and end tag.

DRG-12218 section group name missing

Cause: A section group name must be provided.

Action: Provide a section group name when creating section or section group.

DRG-12219 section name missing

Cause: A section name must be provided when creating a section.

Action: Provide a section name.

DRG-12220 a valid tag must be provided

Cause: A tag must be provided when adding a section to a section group.

Action: Provide a tag.

DRG-12223 section name string is a reserved name

Cause: An attempt was made to name a section a reserved name.

Action: Do not use the reserved name.

DRG-12224 use ctx_ddl.create_section_group to create section groups

Cause: An attempt was made to use CTX_DDL.CREATE_PREFERENCE to create a section group.

Action: Use CTX_DDL.CREATE_SECTION_GROUP.

DRG-12225 this type of section cannot be added to this section group

Cause: An attempt was made to add sections to the null section group, add a stop section to a non-auto section group, or add a zone or field section to the auto section group.

Action: Do not add this type of section to this section group.

DRG-12226 a field section named string already exists in this section group

Cause: An attempt was made to name an attribute or zone section the same name as an existing field section.

Action: Use another name.

DRG-12227 a zone section named string already exists in this section group

Cause: An attempt was made to name an attribute or zone section the same name as an existing field section.

Action: Use another name.

DRG-12228 maximum number of field sections (string) exceeded

Cause: A section group has more than the maximum number of unique field sections.

Action: Use fewer unique field sections.

DRG-12229 special section string already exists in this section group

Cause: An attempt was made to add a special section which already exists.

Action: No action required.

DRG-12230 special section name must be one of string

Cause: An attempt was made to add an invalid special section.

Action: Use a valid special section.

DRG-12231 an attr section named string already exists in this section group

Cause: An attempt was made to name a field or zone section the same name as an existing attribute section.

Action: Use another name.

DRG-12232 invalid attribute tag format

Cause: A tag was specified for use as an attribute tag which did not have the correct format. An attribute tag must have the form TAG@ATTR.

Action: Use the correct format.

DRG-12233 xml sections cannot co-exist with other section types

Cause: An attempt was made to add an xml section to a section group or index which already has zone, field, attr, or special sections. Or, you tried to add a zone, field, attr, or special section to a section group or index which already has xml sections.

Action:

DRG-12300 an index with this column list already exists in the index set

Cause: An attempt was made to add an index to an index set, but an index with the specified column list already exists.

Action:

DRG-12301 index does not exist in index set

Cause: An attempt was made to remove an index from an index set, but the specified index was not found.

Action:

DRG-12302 invalid column list

Cause: An invalid column list was specified -- it may have a syntax error, duplicate columns, or invalid column names.

Action:

DRG-12303 cannot add more than 99 indexes to an index set

Cause: An attempt was made to add too many indexes to the index set.

Action:

DRG-12304 index set string does not exist

Cause: An invalid index set name was specified.

Action:

DRG-12305 column string data type is not supported for index set columns

Cause: An attempt was made to specify a column in the column list of an index of an index set which does not have a valid datatype.

Action: Use only DATE, NUMBER, CHAR, or VARCHAR2 columns in index column lists.

DRG-12306 column string is too long for index set columns

Cause: An attempt was made to specify a column in the column list of an index of an index set which is too long.

Action: CHAR and VARCHAR2 columns must be 30 bytes or less max length.

DRG-12307 column string is NULL and cannot be indexed

Cause: An attempt was made to index a row where at least one of the meta columns was NULL.

Action: Provide a value for the meta column and reindex the row.

DRG-12308 use ctx_ddl.create_index_set to create index sets

Cause: An attempt was made to use CTX_DDL.CREATE_PREFERENCE to create an index set.

Action: Use CTX_DDL.CREATE_INDEX_SET.

DRG-12400 template string is empty

Cause: The template is empty.

Action: Check the template was installed successfully.

DRG-12401 invalid template: query within a loop

Cause: A CTX EXEC tag cannot occur within a CTX REPEAT tag.

Action: Remove the CTX EXEC tag.

DRG-12402 error processing template string, line string

Cause: An error occurred when processing a template.

Action: See other errors on the stack and take the appropriate action.

DRG-12403 template string was not found

Cause: The template does not exist.

Action: Check the name of the template and check that it is installed.

DRG-12404 more than one template string found

Cause: More than one template with the same name was found.

Action: Remove templates as appropriate.

DRG-12405 error occurred processing CTX REDIRECT or CTX LABEL tag

Cause: Error in syntax of a tag.

Action: Correct the syntax of the tag.

DRG-12406 invalid CTX EXEC tag attribute (string)

Cause: The specified attribute is incorrectly specified.

Action: Check the syntax of the specified attribute.

DRG-12407 invalid CTX REPEAT tag attribute (string)

Cause: The specified attribute is incorrectly specified.

Action: Check the syntax of the specified attribute.

DRG-12408 invalid variable reference: string

Cause: The variable referenced does not exist.

Action: Check the label and column name.

DRG-12409 syntax error for label in string

Cause: The SQL in a CTX EXEC tag has incorrect syntax for a label or label type.

Action: Check the SQL attribute of the CTX EXEC tag.

DRG-12410 could not process CTX EXEC tag

Cause: An error occurred when processing the SQL attribute of a CTX EXEC tag.

Action: See other errors on the stack and take the appropriate action.

DRG-12411 SQL processing error: string

Cause: Error executing SQL from SQL attribute of CTX EXEC tag.

Action: Check the SQL in the SQL attribute.

DRG-12412 missing or invalid Template Processor attribute (string)

Cause: The specified attribute was missing or invalid in a HTML input field.

Action: Check the Template Processor-specific attributes in the INPUT, SELECT, RADIO and CHECKBOX tags of the template.

DRG-12422 write to client failed

Cause: See the following messages.

Action: Contact the administrator.

DRG-12430 mandatory argument missing: string

Cause: This argument is mandatory.

Action: Re-submit the URL with this argument supplied.

DRG-12431 configuration section string not found

Cause: Specified configuration argument is invalid.

Action: Re-submit the URL with this argument corrected.

DRG-12432 configuration file string not found or unreadable

Cause: An error occurred when processing the configuration file.

Action: Contact the administrator.

DRG-12433 load of string JDBC driver class failed

Cause: Driver class is invalid.

Action: Contact the administrator to modify configuration.

DRG-12434 connection failed using configuration string information

Cause: Configuration information is not correct.

Action: Contact the administrator to modify configuration.

DRG-12435 highlight table allocation failed

Cause: See the following messages.

Action: Contact the administrator.

DRG-12436 document table allocation failed

Cause: See the following messages.

Action: Contact the administrator.

DRG-12437 highlight table release failed

Cause: See the following messages.

Action: Contact the administrator.

DRG-12438 document table release failed

Cause: See the following messages.

Action: Contact the administrator.

DRG-12439 highlight table read failed

Cause: See the following messages.

Action: Contact the administrator.

DRG-12440 document table read failed

Cause: See the following messages.

Action: Contact the administrator.

DRG-12441 counting the number of highlights failed

Cause: See the following messages.

Action: Contact the administrator.

DRG-12500 stoplist string already exists

Cause: The specified stop list already exists.

Action: Remove the duplicate stop list if you want to re-create it.

DRG-12501 null stoplist is not allowed

Cause: The specified stop list is null.

Action: Specify a valid stop list.

DRG-12502 cannot modify stoplists owned by other users

Cause: You can only create/drop Stop List or Stop Word objects of your own.

Action: Have the other user create/drop his/her own objects.

DRG-12503 error while creating or dropping stoplist

Cause: Detected an Oracle error while creating Stop List.

Action: See the accompanying Oracle error and take appropriate action.

DRG-12504 stoplist string does not exist

Cause: The specified stop list does not exist.

Action: Check that the Stop List is valid.

DRG-12505 error while adding or removing a stop word

Cause: Detected an Oracle error while adding or removing Stop Word.

Action: See the accompanying Oracle error and take appropriate action.

DRG-12506 stop word string does not exist in stoplist string

Cause: The specified Stop word does not exist.

Action: Check that the Stop Word is valid.

DRG-12507 stop word string already exists in this stoplist

Cause: The specified stop word already exists.

Action: Remove the duplicate word if you want to re-create it.

DRG-12508 null stop words are not allowed

Cause: The specified stop word is null.

Action: Remove the null stop word if you want to re-create it.

DRG-12509 length of the stop word string exceeded the limit of string bytes

Cause: A stop list entry has exceeded the maximum length.

Action: Reduce the length of the stop list entry.

DRG-12511 use ctx_ddl.create_stoplist to create stoplists

Cause: An attempt was made to use CTX_DDL.CREATE_PREFERENCE to create a stop list.

Action: Use CTX_DDL.CREATE_STOPLIST.

DRG-12512 invalid stop class string

Cause: You specified an invalid stop class.

Action: Specify a valid stop class.

DRG-12513 valid stop classes are: string

Cause: You specified an invalid stop class.

Action: The valid stop class are listed.

DRG-12514 languages must be specified for stopwords in a MULTI_STOPLIST

Cause: An attempt was made to add a stopword to a MULTI_STOPLIST without specifying the language of the stopword.

Action: Specify the language of the stopword.

DRG-12515 cannot specify language for stopwords in a BASIC_STOPLIST

Cause: An attempt was made to add a language-specific stopword to a BASIC_STOPLIST.

Action: Do not specify language for the stopword.

DRG-12516 language column must be specified when using the multi stoplist

Cause: An attempt was made to create an index using a MULTI_STOPLIST but a language column was not specified.

Action: Specify a language column.

DRG-12517 cannot add stopthemes to a MULTI_STOPLIST

Cause: An attempt was made to add a stoptheme to a MULTI_STOPLIST. This is not supported in this version.

Action:

DRG-12600 user datastore procedure contains a semicolon

Cause: The procedure name specified included a semicolon.

Action: Remove the semicolon or rename the procedure. The correct format is packagename.procedure_name.

DRG-12601 invalid user datastore procedure name: string

Cause: The format of the procedure name is invalid. It should be in the form packagename.procedurename or procedurename.

Action: Make sure the PROCEDURE attribute has the format packagename.procedurename or procedurename.

DRG-12602 index owner does not have access to user datastore procedure: string

Cause: The index owner does not have execute privilege for the procedure.

Action: Use CTXSYS to grant execute privilege for the procedure to the index owner.

DRG-12603 CTXSYS does not own user datastore procedure: string

Cause: CTXSYS does not have execute privilege to the user datastore procedure.

Action: Make sure the package is owned by CTXSYS and the procedure exists.

DRG-12604 execution of user datastore procedure has failed

Cause: An error occurred while executing the user datastore procedure.

Action: Check the datastore procedure.

DRG-12605 datatype of column number in COLUMNS list is not supported

Cause: One or more of the columns in the column list of the multi datastore are of a type which the multi datastore is unable to process.

Action: Change the column list of the multi datastore to contain only supported types. PL/SQL functions can be used in the column list to convert unsupported types to supported types.

DRG-12606 error encountered while parsing COLUMNS list

Cause: An oracle error was encountered while parsing the columns list of the multi datastore.

Action: See next error on stack and take appropriate action.

DRG-12607 only ctxsys can create MULTI_COLUMN preferences

Cause: In order to create a MULTI_COLUMN datastore preference, the effective user must be CTXSYS.

Action: Contact your DBA to create the preference as CTXSYS.

DRG-12700 seed word must be a single word

Cause: Seed word is not a single word.

Action: Use a single-word seed word.

DRG-12800 Attribute NESTED_TYPE must have owner name as prefix

Cause: The attribute NESTED_TYPE does not have an owner name prefix.

Action: Reset the attribute NESTED_TYPE to include owner name prefix.

DRG-12801 invalid type: string

Cause: Invalid nested_type.

Action: Check the owner and the type attribute names.

DRG-12802 invalid type column: string

Cause: Column specified does not exist in the type table.

Action: Check the type table.

DRG-12803 invalid text datatype

Cause: LONG and LONG RAW are not supported in nested table.

Action: Change text column to a supported data type.

DRG-12900 Operation: string for index: string has already been started

Cause: The specified operation has been started.

Action: No action required.

DRG-13000 error while adding or removing a sub lexer

Cause: See next error.

Action: See next error.

DRG-13001 sub lexer and multi lexer must have the same owner

Cause: A sub lexer was specified which is not owned by the owner of the enclosing multi-lingual lexer preference.

Action: Specify a sub lexer owned by the owner of the multi-lexer preference.

DRG-13002 preference string is not a MULTI_LEXER

Cause: An attempt was made to add a sub lexer to a lexer preference which cannot accept sub lexers. Only multi-lingual lexers can accept sub lexers.

Action: Specify a multi-lingual lexer.

DRG-13003 preference string cannot be used as a sub lexer

Cause: A preference was specified for sub lexer which is not a lexer, or is a multi-lingual lexer.

Action: Specify a sub lexer which is not a multi-lingual lexer.

DRG-13004 language is invalid

Cause: An invalid language was specified for the sub lexer or stopword.

Action: Specify a valid language. See Oracle9i Database Globalization Support Guide for a list of valid languages.

DRG-13005 alt_value cannot be an NLS language name

Cause: An NLS language name was specified as the alt value.

Action: Specify a non-NLS value.

DRG-13006 sub lexer for this language is not defined

Cause: An attempt was made to remove a sub lexer for a language, but no sub lexer was defined for that language.

Action: No action required.

DRG-13007 cannot define an alternate value for the DEFAULT sub lexer

Cause: An attempt was made define an alternate value for the DEFAULT sub lexer.

Action: No action required.

DRG-13008 cannot remove the DEFAULT sub lexer

Cause: An attempt was made to remove the DEFAULT sub lexer.

Action: No action required.

DRG-13009 multi lexer preference does not have a DEFAULT sub lexer

Cause: An attempt was made to use a multi lexer preference which does not have a DEFAULT sub lexer defined.

Action: Add a DEFAULT sub lexer to the multi lexer preference and retry.

DRG-13010 alt_value is already used by another sub lexer

Cause: An attempt was made to specify an alt value which is already in use by another sub lexer in the lexer preference.

Action: Specify a different alt value.

DRG-13011 language column must be specified when using the multi lexer

Cause: An attempt was made to create an index using a multi lexer preference, but you did not specify a language column.

Action: Specify a language column.

DRG-13012 language column must be a char, varchar, or varchar2 type

Cause: A language column was specified which is not a char, varchar, or varchar2 type.

Action: Specify a language column of correct type.

DRG-13100 index is not partitioned

Cause: An attempt was made to invoke a partition-level operation on an index which is not partitioned.

Action: Invoke the appropriate index-level operation.

DRG-13101 partition string does not exist in this index

Cause: A partition name was specified which does not exist.

Action: Specify the correct partition name.

DRG-13102 index partition name must be specified

Cause: An attempt was made to invoke a partition-level operation on a partitioned index without specifying the partition name.

DRG-13103 index table string is partitioned

Cause: An attempt was made to perform an exchange partition including indexes, but one or more of the internal index tables are partitioned.

Action: Specify EXCLUDING INDEXES on the exchange partition, then manually rebuild the indexes.

DRG-13104 indexes do not have equivalent settings for string

Cause: An attempt was made to perform an exchange partition including indexes, but the specified metadata setting is not equivalent across the two indexes, so the data cannot be exchanged.

Action: Specify EXCLUDING INDEXES on the exchange partition, then manually rebuild the indexes.

DRG-13200 failed to load dictionary file string

Cause: Failed to load a dictionary file.

Action: Check whether the dictionary file exists in ORACLE_HOME/ctx/data/kolx or access permission is available.

DRG-13300 document size bigger than string bytes

Cause: Size of the document being indexed is larger than the maximum supported size for the VARCHAR2 interface of stored procedure.

Action: Use the CLOB interface for the stored procedure.

DRG-13301 syntax error in token data when expecting string, at line string

Cause: Token data returned by the user-defined lexer procedure is incorrect.

Action: Modify the user-defined lexer procedure to return expected data.

DRG-13302 number of wildcard offsets must be in the range string..string, at line string

Cause: Number of wildcard offsets specified as value for the wildcard attribute does not meet the supported range.

Action: Modify the user-defined lexer query procedure to return a valid number of wildcard offsets.

DRG-13303 value of wildcard offset must be in the range string..string, at line string

Cause: Value of pre-normalized wildcard offset or post-normalized wildcard offset specified as value for the wildcard attribute does not meet the supported range.

Action: Modify the user-defined lexer query procedure to return valid value for wildcard offset.

DRG-13304 character referenced by wildcard attribute is not a wildcard character, at line string

Cause: The wildcard attribute value specified the offset of a wildcard character. The character at the specified offset is neither the '%' character nor the '_' character.

Action: Modify the user-defined lexer query procedure.

DRG-13305 'off' attribute value must be in the range string..string, at line string

Cause: Value of the 'off' attribute does not meet the supported range.

Action: Modify user-defined lexer index procedure to return valid value for the 'off' attribute.

DRG-13306 'len' attribute value must be in the range string..string, at line string

Cause: Value of the 'len' attribute does not meet the supported range.

Action: Modify the user-defined lexer index procedure to return valid value for the 'len' attribute.

DRG-13307 'off'=string and 'len'=string references character past end-of-file of string character document, at line string

Cause: Value of 'off' attribute plus value of 'len' attribute is greater than the number of characters in the document.

Action: Modify the user-defined lexer index procedure to return valid values for the 'off' and 'len' attributes.

DRG-13308 query operator ABOUT not supported by USER_LEXER

Cause: The query contains an ABOUT operator while using USER_LEXER lexer type.

Action: Remove the ABOUT operator from the query or use a lexer type other than USER_LEXER.

DRG-13309 operation not supported by USER_LEXER

Cause: USER_LEXER does not support this operation.

Action: Stop the operation or use an alternate lexer type.

DRG-13310 index owner does not have EXECUTE privilege on USER_LEXER stored procedure string

Cause: User CTXSYS did not grant EXECUTE privilege on USER_LEXER stored procedure to the index owner.

Action: User CTXSYS must grant EXECUTE privilege on USER_LEXER stored procedure to index owner.

DRG-13311 USER_LEXER stored procedure name contains a semicolon

Cause: The procedure name contains a semicolon character.

Action: Remove the semicolon from the procedure name or rename the stored procedure.

DRG-13312 user CTXSYS does not own USER_LEXER stored procedure string

Cause: CTXSYS does not have EXECUTE privilege on the USER_LEXER stored procedure.

Action: Make sure the stored procedure exists and is owned by CTXSYS.

DRG-50000 requested size larger than pagesize

Cause: The requested memory size is larger than page size.

Action: Contact Oracle Support Services.

DRG-50100 CORE LSF error: string

Cause: Detect a CORE LSF error.

Action: Look up the core error and take appropriate action.

DRG-50101 CORE LEM error: string

Cause: Detected a CORE LEM error while reading the error stack.

Action: Contact Oracle Support Services.

DRG-50300 error sending message from server to client

Cause: Internal database error or internal Text error.

Action: Contact Oracle Support Services.

DRG-50301 server error reading request queue

Cause: Database error or internal Text error.

Action: Contact Oracle Support Services.

DRG-50302 server error reading OOB break queue; cannot detect interrupts

Cause: Database error or internal Text error.

Action: Contact Oracle Support Services.

DRG-50303 error in bufout

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50304 error in execute()

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50305 getcmd() called when one of the queue names is NULL

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50400 maximum number of fuzzy match candidates exceeded: string

Cause: This is an internal error, probably the result of a large number of indexed words.

Action: Contact Oracle Support Services.

DRG-50401 failed to retrieve fuzzy match candidates from db: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50600 assertion failed

Cause: An internal check-condition has been violated.

Action: Contact Oracle Support Services.

DRG-50601 fatal error

Cause: A fatal error has occurred.

Action: Contact Oracle Support Services.

DRG-50603 unrecognized operation code string

Cause: Bad operation code was encountered (reached switch default:).

Action: Check .h files versions.

DRG-50607 failed to obtain column info for cid string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50608 unexpected end of data

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50609 pipe internal error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50610 internal error: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50700 unknown command (args=queue, command)

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50701 error in listener.get_cmd()

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50702 error in drtlsleep()

Cause: This is an internal error in a testing function.

Action: Contact Oracle Support Services.

DRG-50703 listener startup error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50704 Net8 listener is not running or cannot start external procedures

Cause: Oracle Text needs to call external code to complete your request, and could not start the EXTPROC agent process.

Action: Start the listener if it is configured for external procedures and is not running. If your listener is running, then configure it for starting external procedures and restart it. Consult the Oracle9i Net Services Administrator's Guide for details.

DRG-50800 failed to open cursor

Cause: Too many cursors open for internal queries.

Action: Implement cursor cleanup routine.

DRG-50801 failed to parse cursor

Cause: Parse error on an internal query.

Action: Check versions of code.

DRG-50802 failed to bind input

Cause: Bind error on an internal query.

Action: Check versions of code.

DRG-50803 failed to define output

Cause: Define error on an internal query.

Action: Check versions of code.

DRG-50804 failed to exec cursor

Cause: Exec error on an internal query.

Action: Debug code.

DRG-50805 failed to close cursor

Cause: Cursor close error on an internal query.

Action: Check versions of code.

DRG-50806 failed to rollback

Cause: Transaction rollback error.

Action: Contact Oracle Support Services.

DRG-50807 failed to commit

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50850 string

Cause: This is an ORA error.

Action: See the ORA chapters of this book.

DRG-50851 SQL execute failed

Cause: Failed to execute a SQL statement.

Action: Report to Oracle Support Services.

DRG-50852 failed to turn SQL trace on

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50853 fetch error

Cause: Fetch error on an internal query.

Action: Check versions of code.

DRG-50855 logoff fail

Cause: Failed to logoff from the database.

Action: Check versions of code.

DRG-50857 oracle error in string

Cause: This is an informational message.

Action: No action required.

DRG-50858 OCI error: string

Cause: A generic OCI error occurred.

Action: Contact Oracle Support Services.

DRG-50859 failed to allocate statement handle

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50860 failed to prepare statement

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50861 failed to obtain type descriptor

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50862 failed to create new Oracle object

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50863 string assignment failed

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50864 number assignment failed

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50865 failed to append to collection

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50866 failed to resize string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50867 failed to free Oracle object

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50868 failed to free statement handle

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50900 text query parser error on line string, column string

Cause: Bad query.

Action: Correct the query.

DRG-50901 text query parser syntax error on line string, column string

Cause: Bad query.

Action: Correct the query.

DRG-50902 unexpected character string

Cause: Bad query.

Action: Correct the query.

DRG-50903 invalid weight string

Cause: Invalid weight.

Action: Correct the query.

DRG-50904 weight string outside valid range 0.1 to 10.0

Cause: Invalid weight.

Action: Correct the query.

DRG-50905 invalid score threshold string

Cause: Invalid score threshold.

Action: Correct the query.

DRG-50906 score threshold string is not an integer

Cause: Invalid score threshold.

Action: Correct the query.

DRG-50907 score threshold string outside valid range 1 to 100

Cause: Invalid score threshold.

Action: Correct the query.

DRG-50908 invalid maximum number of documents string

Cause: Invalid maximum number of documents.

Action: Correct the query.

DRG-50909 maximum number of documents string is not an integer

Cause: Invalid maximum number of documents.

Action: Correct the query.

DRG-50910 max documents requested string outside valid range 1 to 65535

Cause: Invalid maximum number of documents.

Action: Correct the query.

DRG-50911 invalid first document number string

Cause: Invalid first document number.

Action: Correct the query.

DRG-50912 first document number string is not an integer

Cause: Invalid first document number.

Action: Correct the query.

DRG-50913 first document requested string is not a positive number

Cause: Invalid first document number.

Action: Correct the query.

DRG-50914 invalid last document number string

Cause: Invalid last document number.

Action: Correct the query.

DRG-50915 last document number string is not an integer

Cause: Invalid last document number.

Action: Correct the query.

DRG-50916 last document string is less than first document

Cause: Invalid last document number.

Action: Correct the query.

DRG-50917 escape on at end of text query string

Cause: Unbalanced escape characters.

Action: Turn escape off.

DRG-50918 mismatched close escape character

Cause: No matching open escape character for close escape.

Action: Match open and close escapes.

DRG-50919 NEAR operand not a phrase, equivalence or another NEAR expression

Cause: Invalid operand type for NEAR operator.

Action: Correct the operand type.

DRG-50920 part of phrase not itself a phrase or equivalence

Cause: Invalid type of expression which is part of phrase.

Action: Correct the query.

DRG-50921 EQUIV operand not a word or another EQUIV expression

Cause: Invalid operand type for EQUIV operator.

Action: Correct the operand type.

DRG-50922 PL/SQL execution failed for string

Cause: PL/SQL function may not exist or is returning bad value.

Action: PL/SQL may not exist or is returning bad value.

DRG-50923 could not rewrite PL/SQL for execution

Cause: This is a parser internal error.

Action: Contact Oracle Support Services.

DRG-50924 PL/SQL inside PL/SQL not supported

Cause: PL/SQL function call returned another PL/SQL call.

Action: Remove the recursive PL/SQL.

DRG-50925 could not parse return value of PL/SQL

Cause: String returned by PL/SQL function could not be parsed.

Action: Correct the PL/SQL function being called.

DRG-50926 invalid text query string

Cause: Query string empty or made up of invalid characters.

Action: Correct the query.

DRG-50927 parser failed on line string on column string

Cause: An internal error occurred.

Action: Contact Oracle Support Services.

DRG-50928 reserved failure on line string on column string

Cause: An internal error occurred.

Action: Contact Oracle Support Services.

DRG-50929 parser internal on line string on column string

Cause: An internal error occurred.

Action: Contact Oracle Support Services.

DRG-50930 parser memory failure on line string on column string

Cause: Memory allocation or freeing error.

Action: Contact Oracle Support Services.

DRG-50931 parser not opened

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50932 parser preference initialization failed

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50933 parser hash insert failure

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50934 parser hash create failure

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50935 parser component failure

Cause: This is an internal error.

Action: Look for other errors.

DRG-50936 query word string is too complex for index

Cause: This is an internal error.

Action: Look for other errors.

DRG-50937 query too complex

Cause: Query is too complex for the query evaluator.

Action: Make the query smaller.

DRG-50938 parser already bound

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50939 parser not set

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50940 parser not parsed

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-50941 PL/SQL function string cannot be executed

Cause: PL/SQL function may not exist or cannot be executed by user.

Action: Rewrite the PL/SQL function specified in query.

DRG-50942 errors: stringstring

Cause: PL/SQL function encountered an error; this is the error message.

Action: See error message.

DRG-50943 query token too long on line string on column string

Cause: A query token is longer than 256 bytes.

Action: Rewrite the query.

DRG-50944 NEAR operator not supported for theme index

Cause: NEAR operator used in theme index query.

Action: Rewrite the query without NEAR operator.

DRG-50945 Illegal phrase in query for theme index

Cause: Phrase incorrectly defined in theme index query.

Action: Rewrite the query.

DRG-50946 Invalid unary operator for theme index

Cause: Stemming, fuzzy match and soundex not allowed for theme index.

Action: Rewrite the query.

DRG-50947 ABOUT clause not allowed without a theme index

Cause: The query contains an ABOUT clause, but there is no theme index to support it.

Action: Rewrite the query.

DRG-50948 ABOUT clause required in the absence of a text index

Cause: There is no text index, but the query does not contain any about clause. With only a theme index present, each query term must belong to an ABOUT clause.

Action: Rewrite the query.

DRG-50949 too many SQEs

Cause: Too many SQEs to expand.

Action: Rewrite query or SQE.

DRG-50950 circular SQE found

Cause: Circular SQE reference is found.

Action: Rewrite query or SQE.

DRG-50951 Unable to resolve element name for attribute string

Cause: XPATH expression such as A/*/@B or A//@B is not supported.

Action: Rewrite query.

DRG-50952 Section is not PATH section group

Cause: XPATH expression has section which is not created using PATH section group.

Action: Rewrite query not to use XPATH expression or create the index with PATH section group.

DRG-50953 Unable to determin section name

Cause: XPATH expression should not end with . or *.

Action: Rewrite the path expression to not use . or * at the end.

DRG-50954 Theme index is required for CTXCAT about queries

Cause: There is no theme index, but the catsearch query contains about clause. You must create a theme index before using ABOUT query against CTXCAT index.

Action: Create theme index.

DRG-51002 unexpected component failure

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51017 unable to open storage buffer for fuzzy match candidates

Cause: This is an internal error, probably insufficient memory.

Action: Contact Oracle Support Services.

DRG-51019 unable to open or illegal format for fuzzy match data file: string

Cause: Unable to open operating system file containing fuzzy matching information or the file was not of the correct format.

Action: Consult the Oracle Text Application Developer's Guide for correct location of the fuzzy match information files and check for file damage.

DRG-51020 out of memory in fuzzy matcher

Cause: Cannot allocate more memory.

Action: Contact your system administrator.

DRG-51021 undefined error in fuzzy matcher

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51022 undefined error in stemmer

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51023 stemmer file cannot be opened

Cause: Unable to open operating system file containing stemmer lexicon, or the file contents were not correct.

Action: Consult the Oracle Text Application Developer's Guide for the correct location of the stemmer lexicons and check for file damage.

DRG-51024 out of memory in stemmer

Cause: Cannot allocate more memory.

Action: Contact your system administrator.

DRG-51025 an invalid character was passed to the stemmer

Cause: Invalid character in word input to the stemmer.

Action: Remove invalid character from word to be stemmed.

DRG-51028 unexpected error in fuzzy match expansion: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51029 unexpected error in stemmer expansion: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51030 wildcard query expansion resulted in too many terms

Cause: This is a user error.

Action: Make wildcard query narrower.

DRG-51100 invalid program argument index

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51101 argument processing callback failed

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51200 open keymap failed for index id = string

Cause: Failed to initialize the key map for the column ID specified.

Action: Check index ID. Contact Oracle Support Services if caused by internal errors.

DRG-51201 failed to perform DDL operation: database object string

Cause: Text key mapping service failed on DDL operation.

Action: Check Oracle error and take corrective action.

DRG-51202 invalid key mapping operation mode : string

Cause: Invalid key map mode value found. This is an internal error.

Action: Contact Oracle Support Services.

DRG-51203 found doc ids without mappings during get maps

Cause: Found doc IDs without mappings during get mapping by doc IDs, the index data and key map service are out of synch.

Action: Contact Oracle Support Services.

DRG-51300 error getting dml Queue lock

Cause: A server must have hung while processing the DML Queue, leaving it locked.

Action: Contact Oracle Support Services.

DRG-51301 error releasing dml Queue lock

Cause: Internal database error, or perhaps someone dropped the lock while we were using it.

Action: Contact Oracle Support Services.

DRG-51309 Get_batch() failed

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51310 batch_done() failed

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51311 DML lock handle previously allocated

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51312 DML lock internal error string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51403 New index name not provided by kernel

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51801 failed to seek in file: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51802 failed to read from file: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51803 failed to open file: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-51804 failed to write to file: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52100 string returned internal error code string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52101 an invalid session handle was passed to Oracle Text

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52102 an invalid transaction handle was passed to Oracle Text

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52103 the Oracle Text environment could not reset

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52104 the Oracle Text environment could not initialize

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52105 no delete function found

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52106 Oracle Text service results could not be committed

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52107 ctxkbtc internal error

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52108 failed to delete knowledge base user extension

Cause: This is an internal error.

Action: Check file permissions or contact Oracle Support Services.

DRG-52109 error in reading thesaurus

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52110 error in writing extended knowledge base

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52111 error in knowledge base cache

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52200 invalid state during export

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52201 incompatible Oracle Text versions

Cause: An attempt was made to import an incompatible version of Oracle Text's data.

Action: Make sure source and target Oracle Text's versions are compatible.

DRG-52202 invalid class name: string

Cause: The specified class name is not valid.

Action: Specify a valid class name.

DRG-52203 invalid object name: string

Cause: The specified object name is not valid.

Action: Specify a valid object name.

DRG-52204 error while registrating index

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52205 class string and object string already exists for this index

Cause: Duplicate entry of class and object.

Action: Contact Oracle Support Services.

DRG-52206 error while registrating index object

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52207 the specified attribute does not exist: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52208 the specified attribute already exist: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.

DRG-52210 error while registrating value for attribute: string

Cause: This is an internal error.

Action: Contact Oracle Support Services.


XML Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Part XI
XML Messages

This part contains the following chapters:

  • Chapter 51, "XML Parser Messages (LPX)"
  • Chapter 52, "XML Schema Processor Messages (LSX)"


XML Parser Messages (LPX)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

51
XML Parser Messages (LPX)

LPX-00000 normal, successful completion

Cause: Normal exit.

Action: No action required.

LPX-00001 NULL pointer

Cause: A NULL pointer was detected as an internal error condition.

Action: This is a programming error by the caller of the XML parser. Contact someone who can fix the problem.

LPX-00002 out of memory

Cause: The operating system has run out of memory.

Action: Make more memory available to the program.

LPX-00003 duplicate entry in hash table

Cause: An internal error has occurred (a key was requested to be placed in a hash table but was already there).

Action: Contact Oracle Support Services and report the error.

LPX-00004 internal error "string"

Cause: An internal error has occurred.

Action: Contact Oracle Support Services and report the error.

LPX-00005 string buffer overflow, maximum size is number bytes

Cause: A name, quoted string, URL, or other document component was too long.

Action: Restrict the component to the maximum size shown.

LPX-00006 invalid child type for parent node

Cause: An attempt was made to add an invalid node-type to a parent node.

Action: Correct the code.

LPX-00007 unexpected end-of-file encountered

Cause: The documented ended unexpectedly, perhaps due to truncation.

Action: Verify that the document is complete.

LPX-00008 invalid memory callback

Cause: The memory callback structure passed to xmlinit was missing the allocate or free functions (or both).

Action: Provide both functions in the callback structure.

LPX-00012 Unicode data alignment error

Cause: An input Unicode (UCS2) datum was not aligned properly.

Action: UCS2 data consists of an array of shorts which must be aligned on an even-byte boundary.

LPX-00013 wrong node type

Cause: The wrong node type was given as argument to a DOM call.

Action: Review the failing function call, consult the documentation, and make sure the node types passed are correct.

LPX-00014 context is not clean

Cause: An operation was performed on a context that has already been used (so is not "clean").

Action: Some functions must be performed on a newly initialized context before being used for parsing. For example, setting a shared DTD. Change the code and do the call before parsing.

LPX-00100 root element "string" does not match DTD root "string"

Cause: Validity Constraint 2.8 failed:

"The Name in the document type declaration must match the element type of the root element."

<?xml version="1.0"?><!DOCTYPE greeting [ <!ELEMENT greeting (#PCDATA)> ]><salutation>Hello!</salutation>

The document's root element, salutation, does not match the root element declared in the DTD (greeting).

Action: Correct the document.

LPX-00101 parameter-entity markup cannot be split up

Cause: Validity Constraint 2.8 failed:

"Parameter-entity replacement text must be properly nested with markup declarations."

<?xml version="1.0"?><!DOCTYPE greeting [<!ENTITY % e "<!ELEMENT ">%e; greeting (#PCDATA)>]><greeting>Hello!</greeting>

The parameter entity 'e' contains markup which may not be split up; the entire ELEMENT (or ATTLIST or ENTITY) definition must be present in one piece.

Action: Correct the document.

LPX-00102 standalone document declaration should be "no"

Cause: Validity Constraint 2.9 failed:

"Standalone document declaration must have the value 'no' if any external markup declarations contain declarations of:"

  • Attributes with default values
  • Entities
  • Attributes with values subject to normalization
  • Element types with element content.

Action: Correct the document.

LPX-00103 document structure does not match DTD

Cause: Validity Constraint 3 failed:

"An element is valid if there is a declaration matching elementdecl where the Name matches the element type, and one of the following holds:"

  • The declaration matches EMPTY and the element has no content
  • The declaration matches children and the sequence of child elements belongs to the language generated by the regular expression in the content model, with optional white space (characters matching the nonterminal S) between each pair of child elements.
  • The declaration matches Mixed and the content consists of character data and child elements whose types match names in the content model.
  • The declaration matches ANY, and the types of any child elements have been declared.

Action: Correct the document.

LPX-00104 element "string" is not declared in the DTD

Cause: Validity Constraint 3 failed:

The named element has no matching elementdecl in the DTD.

Action: Correct the document.

LPX-00105 element "string" is not empty as required by the DTD

Cause: Validity Constraint 3 failed:

The named element is declared as EMPTY in the DTD but contains sub-elements in the document.

Action: Correct the document.

LPX-00106 attribute "string" of element "string" is undefined

Cause: Validity Constraint 3.1 failed.

Action: Correct the document.

LPX-00107 element "string" has multiple declarations

Cause: Validity Constraint 3.2 failed:

"No element type may be declared more than once."

Action: Correct the DTD.

LPX-00108 parameter-entity parenthetical cannot be split up

Cause: Validity Constraint 3.2.1 failed:

"Parameter-entity replacement text must be properly nested with parenthesized groups. For interoperability, if a parameter-entity reference appears in a choice, seq, or Mixed construct, its replacement text should not be empty, and neither the first nor last non-blank character of the replacement text should be a connector (| or ,).

<?xml version="1.0"?><!DOCTYPE foo [<!ELEMENT greeting (#PCDATA)><!ENTITY % e "(#PCDATA|"><!ELEMENT foo %e; greeting)>]><greeting>Hello!</greeting>

The parenthetical content of the 'e' entity may not be split up into sections: both open and close parentheses must be in the same declaration.

Action: Correct the DTD.

LPX-00109 duplicate name "string" in mixed-content declaration

Cause: Validity Constraint 3.2.2 failed:

"The same name must not appear more than once in a single mixed-content declaration."

<!ELEMENT p (#PCDATA|a|b|c|d|a)>

'a' occurs more than once in the mixed-content declaration.

Action: Correct the DTD.

LPX-00110 invalid string "string" (not a Name)

Cause: Validity Constraint 3.3.1 failed:

Given thing is not a Name

Action: Correct the document.

LPX-00111 invalid string "string" (not a Nmtoken)

Cause: Validity Constraint 3.3.1 failed:

Given thing is not a Nmtoken

Action: Correct the document.

LPX-00112 element "string" has multiple ID attributes

Cause: Validity Constraint 3.3.1 failed:

"No element type may have more than one ID attribute specified."

Action: Correct the document.

LPX-00113 element "string" ID attribute "string" must be #IMPLIED or #REQUIRED

Cause: Validity Constraint 3.3.1 failed:

"An ID attribute must have a declared default of #IMPLIED or #REQUIRED."

Action: Correct the document.

LPX-00114 element "string" attribute "string" has invalid enumeration value "string"

Cause: Validity Constraint 3.3.1 failed:

"Values of this type must match one of the Nmtoken tokens in the declaration."

Action: Correct the document.

LPX-00115 element "string" is missing required attribute "string"

Cause: Validity Constraint 3.3.2 failed:

"If the default declaration is the keyword #REQUIRED, then the attribute must be specified for all elements of the type in the attribute-list declaration."

Action: Correct the document.

LPX-00116 element "string" attribute "string" has invalid value "string", must be "string"

Cause: Validity Constraint 3.3.2 failed:

"If an attribute has a default value declared with the #FIXED keyword, instances of that attribute must match the default value."

Action: Correct the document.

LPX-00118 undefined entity "string"

Cause: Validity Constraint 4.1 failed:

"In a document with an external subset or external parameter entities with "standalone='no'", the Name given in the entity reference must match that in an entity declaration."

Action: Correct the document.

LPX-00119 element "string" attribute "string" must be an unparsed entity

Cause: The attribute value must be an unparsed entity.

Action: Correct the document.

LPX-00120 entity "string" NDATA (notation) "string" is undefined

Cause: Entity's NDATA (notation) is undefined.

Action: Correct the document.

LPX-00121 undefined notation "string"

Cause: Notation is not known.

Action: Correct the document.

LPX-00122 undefined ID "string" in IDREF

Cause: Validity Constraint 3.3.1 failed:

"A name must not appear more than once in an XML document as a value of this type; that is, ID values must uniquely identify the elements which bear them."

Action: Correct the document.

LPX-00123 duplicate ID "string"

Cause: An ID was used twice; they must be unique.

Action: Correct the document.

LPX-00124 attribute value should be one or more tokens

Cause: An attribute with tokenized type (IDREFS, ENTITIES, NMTOKENS) did not contain any tokens.

Action: Value must contain one or more tokens, separated by spaces.

LPX-00125 duplicate entity "string" (ignored)

Cause: A general or parameter entity was declared more than once.

Action: This is a warning, not an error. The first entity declaration is in force, subsequent are ignored. Remove duplicate entity declarations or ignore the warning.

LPX-00200 could not convert from encoding string to string

Cause: The conversion cannot be made between the specified encodings.

Action: Choose a data encoding which can represent all expected input encoding (such as a Unicode-based encoding, UTF-8 or UTF-16).

LPX-00201 unknown encoding "string"

Cause: The specified encoding was not known. It should be an IANA or Oracle encoding name.

Action: Use an appropriate encoding.

LPX-00202 could not open file "string"

Cause: The file does not exist.

Action: Create an appropriate file.

LPX-00203 could not read from file "string"

Cause: Data could not be read from the file.

Action: Take appropriate action to allow data to be read.

LPX-00204 syntax error

Cause: A syntax error was found.

Action: Check the XML document line and correct it.

LPX-00205 expected "<!--" at the start of comment

Cause: Bad syntax detected when processing a comment.

Action: Fix the comment syntax.

LPX-00206 invalid CDATA section

Cause: Bad syntax detected when processing CDATA. Proper format is '<![CDATA[' data ']]>'.

Action: Correct the CDATA syntax.

LPX-00207 expected "[" at the start of conditional section

Cause: Bad syntax detected when processing a conditional section.

Action: Fix the conditional section syntax.

LPX-00208 unknown DTD keyword "string"

Cause: An unknown keyword was found in the DTD.

Action: Use a proper keyword.

LPX-00209 PI names starting with XML are reserved

Cause: Processing instruction starting with XML was found.

Action: Use another name for the processing instruction.

LPX-00210 expected 'character' instead of 'character'

Cause: A syntax error was detected.

Action: Use proper syntax.

LPX-00211 attribute default must be REQUIRED, IMPLIED, or FIXED

Cause: Attribute default was invalid.

Action: Default must be REQUIRED, IMPLIED, or FIXED.

LPX-00212 comment must not contain "--"

Cause: A syntax error was detected in the comment.

Action: Use '--' only when specifying the end of the comment.

LPX-00213 comment did not end in "-->"

Cause: A syntax error was detected in the comment.

Action: Be sure to end the comment with '-->'.

LPX-00214 CDATA section did not end in "]]>"

Cause: A syntax error was detected in the CDATA section.

Action: Be sure to end the CDATA section with ']]>'.

LPX-00215 processing instruction did not end in "?>"

Cause: A syntax error was detected in the PI section.

Action: Be sure to end the PI with '?>'.

LPX-00216 invalid character number (number)

Cause: An invalid multibyte character was found.

Action: Use only characters allowed by the XML specification.

LPX-00217 invalid character number (number)

Cause: An invalid Unicode character was found.

Action: Use only characters allowed by the XML specification.

LPX-00218 invalid character number ('character')

Cause: An invalid native (ASCII/EBCDIC) character was found.

Action: Use only characters allowed by the XML specification.

LPX-00219 invalid digit 'character' in character reference

Cause: An invalid digit was found in a character reference.

Action: Character references are either &#DDD; where D's are decimal// digits, or &#xHHH; where H's are hexadecimal digits.

LPX-00220 the string "]]>" cannot occur in character data

Cause: Found ']]>' in character data.

Action: Do not use ']]>' in character data.

LPX-00221 the character "<" cannot occur in attribute values

Cause: Found '<' in an attribute value.

Action: Do not use '<' in attribute values.

LPX-00222 error received from SAX callback function

Cause: An error was received from the SAX callback function.

Action: Examine the additional error messages and take corrective action.

LPX-00223 external entity "string" found in an attribute value

Cause: An external entity reference was found in an attribute value.

Action: Use only references to internal or character entities in attribute values.

LPX-00224 multiple occurrences of attribute "string" found

Cause: An attribute occurred multiple times in the same start-tag or empty-element tag.

Action: Make sure that the attributes are unique.

LPX-00225 end-element tag "string" does not match start-element tag "string"

Cause: An element tag was not ended properly.

Action: Make sure that the correct end element tag is used.

LPX-00226 entity "string" is not declared

Cause: An entity is not declared.

Action: Declare the entity before referencing it.

LPX-00227 entity "string" is not a parsed entity

Cause: An entity reference contained the name of an unparsed entity.

Action: Only reference parsed entities.

LPX-00228 entity reference "string" refers to itself

Cause: An entity reference contains a recursive reference to itself.

Action: Modify the contents of the entity reference to remove this recursion.

LPX-00229 input source is empty

Cause: An XML input file has no contents.

Action: The XML file representing a document must contain at least one element.

LPX-00230 invalid character number (number) found in a Name or Nmtoken

Cause: An invalid character was found in a NAME or NMTOKEN.

Action: Use only the characters allowed for NAMES and NMTOKENS by the XML specification.

LPX-00231 invalid character number ('character') found in a Name or Nmtoken

Cause: An invalid character was found in a NAME or NMTOKEN.

Action: Use only the characters allowed for NAMES and NMTOKENS by the XML specification.

LPX-00232 invalid use of a parameter entity reference

Cause: A parameter entity reference was found in an improper location in the internal DTD subset.

Action: Use a parameter entity reference only where markup declarations can occur in the internal DTD subset, in the external DTD subset, or in an external entity.

LPX-00233 namespace prefixes starting with "xml" are reserved

Cause: Namespace prefix starting with XML was found.

Action: Use another name for the namespace prefix.

LPX-00234 namespace prefix "string" is not declared

Cause: Namespace prefix is not declared.

Action: Declare the prefix in an attribute list.

LPX-00235 invalid XML version, must be 1.0 or 2.0

Cause: Only versions 1.0 and 2.0 of the XML specification are supported.

Action: Use the 1.0 or 2.0 specification & set version# accordingly.

LPX-00236 invalid character number ('character') found in public identifier

Cause: An invalid character was found in a public identifier.

Action: Use only the characters allowed for public identifiers by the XML specification.

LPX-00237 invalid condition section keyword, must be INCLUDE or IGNORE

Cause: A conditional section <![ keyword [ markup ]]> had invalid keyword, must be either "IGNORE" or "INCLUDE".

Action: Correct condition section usage in document.

LPX-00238 unterminated conditional section

Cause: A conditional section was not properly terminated with ]]>.

Action: Verify conditional nesting in document and correct.

LPX-00239 invalid attribute type "string"

Cause: The attribute type is not valid. Options are CDATA, ID, IDREF, IDREFS, ENTITY, ENTITIES, NMTOKEN, or NMTOKENS.

Action: Check and correct attribute declaration.

LPX-00240 element-start tag is not well formed

Cause: A start-element tag was improperly formed.

Action: Check and correct the start-element syntax.

LPX-00241 entity reference is not well formed

Cause: An entity reference (general or parameter) was not formed properly.

Action: Form entity reference correctly as "&name;" or "%name;".

LPX-00242 invalid use of ampersand ('&') character (use &amp;)

Cause: The ampersand character is used only to start entity or character references.

Action: To include an ampersand character as data, use the built-in &amp; general entity.

LPX-00243 element attribute value must be enclosed in quotes

Cause: An attribute defined in an element's start-tag must be enclosed in single ('') or double ("") quotes.

Action: Enclose the attribute value in quotes.

LPX-00244 invalid use of less-than ('<') character (use &lt;)

Cause: The less-than character ('<') is not permitted as data.

Action: Use the built-in entity &lt; instead. Check for mismatched quotes ("') in case the '<' is part of subsequent markup.

LPX-00245 extra data after end of document

Cause: After the close of the top-level element, more data was found.

Action: The end-element tag for the top-level element must be the last thing in the document.

LPX-00246 missing system ID after public ID

Cause: In an external ID declaration, the public ID literal was not followed by the system ID literal as required.

Action: Provide with public *and* system IDs for 'PUBLIC' type.

LPX-00247 invalid Document Type Declaration (DTD)

Cause: Problems were encountered in the DTD declaration.

Action: Review the DTD and correct the problems.

LPX-00248 invalid entity declaration

Cause: Problems were encountered parsing an entity declaration.

Action: Check and correct the declaration syntax.

LPX-00249 invalid external ID declaration

Cause: Problems were encountered parsing an external ID declaration.

Action: Check and correct the declaration syntax.

LPX-00250 invalid attribute declaration

Cause: Problems were encountered parsing an attribute declaration.

Action: Check and correct the declaration syntax.

LPX-00251 conditional sections are valid only in external DTDs

Cause: A condition section is not permitted in internal DTDs.

Action: Remove the condition section.

LPX-00252 invalid entity replacement-text nesting

Cause: Markup included from an entity must nest/group properly. That is, open/close markup must occur within the same entity. For example:

<!DOCTYPE doc [ <!ENTITY e "</foo><foo>"> ]><doc><foo>&e;</foo></doc>

Is invalid since foo's start-tag occurs in the top-level document, but the close-tag is provided by the "e" entity. Both start and end must be provided by the same source.

Action: Examples, such as the ones above, are not permitted.

LPX-00253 missing required version number in XML declaration

Cause: An XML declaration was missing the required version#.

Action: Always provide a version#, which must come first in the declaration. XML is case sensitive, so only "version" (not "Version", and so on) is valid.

LPX-00254 invalid XML declaration

Cause: Problems were encountered parsing an XML declaration.

Action: Check and correct the declaration syntax.

LPX-00255 XML standalone declaration must be "yes" or "no"

Cause: The "standalone" parameter in the XML declaration had an invalid value.

Action: standalone must be set to either "yes" or "no". Case is sensitive, so "Yes", "YES", and so on, are invalid.00256 invalid element declaration

Cause: Problems were encountered parsing an element declaration.

Action: Check and correct the declaration.

LPX-00257 invalid children specification in element declaration

Cause: The 'children' specification in an element declaration was invalid.

Action: Check and correct the declaration.

LPX-00258 invalid "Mixed" specification in element declaration

Cause: The 'Mixed' specification in an element declaration was invalid.

Action: Check and correct the declaration.

LPX-00259 invalid notation declaration

Cause: Problems were encountered parsing a notation declaration.

Action: Check and correct the declaration syntax.

LPX-00260 invalid xml:space attribute declaration

Cause: The xml:space attribute must be declared as an enumeration with choices "default" and "preserve". For example, <!ATTLIST foo xml:space (default|preserve) 'preserve').

Action: Declare the special attribute as above.

LPX-00261 invalid URL string

Cause: The specified URL was invalid and could not be parsed.

Action: Correct the URL; consult RFC-2396.

LPX-00262 unsupported protocol string

Cause: An URL was encountered which requested a protocol not supported by the XML parser. Only HTTP and file are currently allowed.

Action: Make the data available through the filesystem or HTTP.

LPX-00263 couldn't connect to host string port number

Cause: A TCP connection couldn't be opened to the named host.

Action: Verify the hostname and connectivity to the host.

LPX-00264 send failed to host string

Cause: An error occurred trying to send data over a TCP connection.

Action: Verify network connectivity, and so on.

LPX-00265 read failed from to host string

Cause: An error occurred trying to read data from a TCP connection.

Action: Verify network connectivity, and so on.

LPX-00266 invalid language specification string

Cause: The given language specification was invalid.

Action: Language specification has the format <language>_<territory>.<character set>. For example, "French_France".

LPX-00267 could not resolve relative URL string

Cause: The named relative URL couldn't be resolved against its parent.

Action: Make sure the relative makes sense in relation to its parent URL; see RFC-2396 sections 4, 5, and appendix C.

LPX-00268 invalid access method number, must be 0 to number

Cause: The provided access code was not in the valid range.

Action: The code should be one of the XMLACCESS_xxx codes defined in oraxml.h, in the range shown in the error message.

LPX-00269 all three access functions (open/close/read) must be provided

Cause: An attempt was made to set the access method callbacks, but all three functions were not provided.

Action: All three callback functions (open, close, and read) are required. They must all be provided, even if they are stub functions which do nothing.

LPX-00270 FTP error: string

Cause: An error was returned from the FTP server while trying to retrieve a file. See the specific message for details.

Action: Corrective action depends on the error.

LPX-00271 FTP login failed: string

Cause: The username/password combination was invalid for FTP login.

Action: Specify a valid pair.

LPX-00272 FTP server unavailable: string

Cause: The FTP server is unavailable for use.

Action: No action is possible from the client side. See server's error message.

LPX-00273 failed to initialize TCP/IP

Cause: The TCP/IP package could not be initialized.

Action: Check with system administrator to see if this is a configuration problem or a connectivity problem.

LPX-00274 can't import node type

Cause: Some node types (DOCUMENT_NODE & DOCUMENT_TYPE_NODE) cannot be imported with importNode().

Action: No action required.

LPX-00275 can't set output/data encoding AFTER parsing

Cause: Output/data encoding must be set after initialization but BEFORE any parsing has taken place.

Action: Set encoding before parsing any documents.

LPX-00276 bad HTTP/Mime header

Cause: An HTTP reply contained an invalid Mime header.

Action: Verify HTTP reply for accuracy. See RFC 2616.

LPX-00277 no closing quote was seen

Cause: A quoted string was started but not finished.

Action: Put a closing quote in the proper location.

LPX-00278 invalid string proxy "string"

Cause: The proxy specification for the given protocol was invalid.

Action: Check and correct the proxy specification. For HTTP, this is the environment variable "http_proxy".

LPX-00279 invalid no_proxy "string"

Cause: The no_proxy specification was invalid.

Action: Check and correct it. no_proxy is a comma- or space-separated list of machine or domain names, with an optional port part. If no port part is present, then it applies to all ports on that domain.

LPX-00280 HTTP error string

Cause: An HTTP protocol error occurred.

Action: Corrective action depends on the error.

LPX-00281 unsupported encoding "string"

Cause: The specified encoding is known but not supported by the parser.

Action: Try a different encoding.

LPX-00282 document cannot have both internal/external and shared DTDs

Cause: A parser context which had a shared DTD set was used to parse a document which also contained a DTD. You cannot use both a shared DTD and and internal/external one.

Action: If a shared DTD is to be used, then the documents parsed must not contain or reference a DTD.

LPX-00283 document encoding is string-based but default input encoding is not

Cause: The input document was detected to be ASCII (or EBCDIC) based, but no encoding was specified in the XMLDecl and the default input coding was not ASCII (or EBCDIC) based, so could not be applied.

Action: Add an explicit encoding specification to the XMLDecl so the default input encoding is not needed, or pick a default encoding which matches the input document.

LPX-00300 no name in attribute set

Cause: The name attribute was not found in the attribute-set element.

Action: Add a name attribute for this element.

LPX-00301 error in XPATH evaluation

Cause: The XPATH evaluation returns an error.

Action: Check specified XPATH expression to determine the error.

LPX-00302 Incorrect stylesheet. The node is not valid.

Cause: The child node is of invalid type or has invalid name for this particular location in stylesheet, rendering the stylesheet as invalid XSLT.

Action: Fix the stylesheet by using valid nodes only.

LPX-00303 attribute value "string" not expected for string

Cause: Attribute is found but its value is not the expected value.

Action: Set the attribute value to the correct value.

LPX-00304 input parameter to function is null

Cause: An input parameter passed into this function is null when it is not supposed to.

Action: Make sure the caller function is not passing null for this parameter.

LPX-00305 missing token

Cause: An expected token is not found.

Action: Check the input string to make sure the expected token is present.

LPX-00306 inputed string ended with no corresponding closing \xd5 }\xd5

Cause: A closing '}' is expected.

Action: Add the closing '}' to the input string or remove the extra opening '{'.

LPX-00307 namespace prefix string used but not declared

Cause: Namespace prefix is used but not declared.

Action: Either declare the namespace or don't use this namespace prefix.

LPX-00308 attribute string not found in string

Cause: The expected attribute for this node is not found.

Action: Need to add this attribute to the node.

LPX-00309 cannot initialize XPATH

Cause: XPATH context could not be initialized.

Action: Check the initialization function LpxsutInitXpathCtx().

LPX-00310 element string not found in string

Cause: The expected element is not found.

Action: Check the initialization function LpxsutInitXpathCtx().

LPX-00311 unsupported feature: string

Cause: This feature is not supported.

Action: Do not use this feature.

LPX-00312 cannot construct XML PI with content: string

Cause: The content of XML PI node might be invalid.

Action: Make necessary changes to make the node valid according to spec.

LPX-00313 cannot construct XML comment with content: string

Cause: The content of XML comment node might be invalid.

Action: Make necessary changes to make the node valid according to spec.

LPX-00314 an internal failure occurred

Cause: An internal error occurred in the code.

Action: Contact the appropriate developer.

LPX-00315 extension function string not supported

Cause: This extension function is not supported.

Action: Either contact the appropriate developer for more information or don't use this extension function.

LPX-00316 invalid value string for string attribute string

Cause: The value for the specified attribute is invalid.

Action: Consult the XSL spec; use only legal values.

LPX-00317 undefined decimal-format "string"

Cause: The named decimal-format is undefined (the name "#default" means the default format).

Action: Define the desired decimal-format before trying to use it.

LPX-00318 duplicate xsl:decimal-format "string"

Cause: The named decimal-format was declared more than once.

Action: Make sure there is only a single declaration.

LPX-00319 The node specified is not valid

Cause: The node specified is not of expected type.

Action: Use only the nodes of legal type.

LPX-00320 No more attributes can be added to a non-empty element

Cause: The element to which an attribute was being added is non-empty and hence can not add anymore attributes to it.

Action: Modify the XSLT stylesheet so that all the attributes are added to an element before anything else is added to it. If you absolutely can not do that then select your output method to be DOM based rather then a stream or SAX based output which you are using presently.

LPX-00321 None of the output methods (DOM, SAX, Stream) are selected

Cause: User is trying to process an XML file with out selecting any mechanism for output.

Action: User must select one of the output mechanisms (SAX/DOM/Stream) before attempting to process the XML file.

LPX-00322 A doc referred by XSLT stylesheet could not be opened : string

Cause: Either an import,include or document() function tried to open a document and failed.

Action: Make sure that document is present and can be opened.

LPX-00323 illegal apply-imports because of no current template: string

Cause: apply-imports was used even when there was no current template possibly with in for-each.

Action: Make sure that apply-imports are invoked only if there is a current template and it is not in a xsl:for-each.

LPX-00400 an internal error has occurred in XPATH

Cause: An internal error has occurred in XPATH.

Action: Contact the appropriate developer.

LPX-00401 invalid QName in the XSL file

Cause: An invalid QName was passed to the XPATH parser.

Action: See whether there are any invalid QNames in the XSL file.

LPX-00402 invalid axisname in the XSL file

Cause: An invalid axis name was passed to the XPATH parser.

Action: See whether all axis names in the XSL file are correct.

LPX-00403 unmatched quote in the XSL file

Cause: An unmatched quote was found in the XSL file.

Action: Check for unmatched quotes in the XSL file.

LPX-00404 unable to resolve namespace URI

Cause: The namespace URI may not be valid.

Action: Make sure that the name space URIs are valid.

LPX-00405 unable to allocate memory

Cause: May be out of memory.

Action: Try increasing virtual memory.

LPX-00406 object of incorrect type passed to the function

Cause: An object of incorrect type was passed to the XPATH/XSL function.

Action: Do the required conversion before passing in an object of type which is different from the expected type.

LPX-00407 right square bracket missing in the XSL file

Cause: Right square bracket missing in the XSL file.

Action: Check for unmatched square bracket in the XSL file.

LPX-00408 right parenthesis missing in the XSL file

Cause: Right parenthesis missing in the XSL file.

Action: Check for unmatched parenthesis in the XSL file.

LPX-00409 incorrect token encountered while parsing

Cause: An unexpected token was encountered while parsing the expression/pattern.

Action: Check the syntax of the expressions/patterns.

LPX-00410 unable to resolve the variable reference

Cause: Variable reference may not be valid.

Action: Check whether the variable references are valid.

LPX-00411 unknown function name encountered

Cause: The function is not supported at this time or the name is invalid.

Action: Check the function names. If valid and this error occurs, then avoid using them at this time.


XML Schema Processor Messages (LSX)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

52
XML Schema Processor Messages (LSX)

LSX-00001 NULL pointer

Cause: A NULL pointer was detected as an internal error condition.

Action: This is a programming error by the caller of the Schema processor. Contact someone who can fix the problem.

LSX-00002 root element is not <schema>

Cause: The top-level element of an XML Schema must be <schema>.

Action: Correct the Schema; consult the Schema specification.

LSX-00003 invalid attribute "string" for element "string"

Cause: The named Schema element had an invalid attribute.

Action: Correct the Schema; consult the Schema specification.

LSX-00004 unexpected XML node type

Cause: Schema contains an XML node other than element, text (or CDATA), comment, or PI.

Action: Other node types are not permitted; remove them.

LSX-00008 feature "string" is not implemented

Cause: An attempt was made to use a feature that is not yet implemented.

Action: Make an enhancement request for the feature.

LSX-00009 data missing for type "string"

Cause: Data is missing for an element or attribute of a simple type.

Action: Add data in the element or attribute.

LSX-00010 extra elements at end of "string"

Cause: Extra elements exist at the end of schema component declarations.

Action: Remove the extra elements.

LSX-00011 internal error: string

Cause: Implementation error.

Action: File a bug.

LSX-00013 element "string" not from Schema of Schemas

Cause: Bogus element exists in the schema file. Its name is not from Schema of Schemas.

Action: Remove the bogus element.

LSX-00014 empty instance document

Cause: Instance document to be Schema validated was empty (no top-level element).

Action: Provide a complete XML instance document.

LSX-00015 failed to parse document

Cause: Failed to parse the schema document using the given URI.

Action: Provide the correct URI and make sure that the schema document is valid.

LSX-00020 unknown type "string"

Cause: A specified type was unknown (not defined in any loaded Schemas).

Action: Make sure the type was defined and that the type usage referenced the correct Schema.

LSX-00021 undefined element "string"

Cause: Element is undefined in the specified namespace.

Action: If the element name is misspelled, correct the spelling.

LSX-00022 unknown namespace prefix "string"

Cause: Prefix in a QName is undefined in the current scope.

Action: Correct the prefix name if it's misspelled.

LSX-00023 unknown namespace URI "string"

Cause: Namespace URI is unknown to the schema processor.

Action: Correct the namespace URI if it's misspelled.

LSX-00024 unknown attribute group "string"

Cause: The name of attribute group is unknown to the schema processor in the current scope.

Action: Correct the name of attribute group if it's misspelled.

LSX-00025 unknown group "string"

Cause: The name of group is unknown to the schema processor in the current scope.

Action: Correct the name of group if it's misspelled.

LSX-00026 unknown attribute "string"

Cause: The name of attribute is unknown to the schema processor in the current scope.

Action: Correct the name of attribute if it's misspelled.

LSX-00102 duplicate element "string"

Cause: Element declaration is not unique within its scope.

Action: Rename the element.

LSX-00103 duplicate group "string"

Cause: Group declaration is not unique within its scope.

Action: Rename the group.

LSX-00104 duplicate type "string"

Cause: Type definition is not unique within its scope.

Action: Rename the type.

LSX-00105 duplicate attribute group "string"

Cause: Attribute group declaration is not unique within its scope.

Action: Rename the attribute group.

LSX-00106 duplicate attribute "string"

Cause: Attribute declaration is not unique within its scope.

Action: Rename the attribute.

LSX-00110 facet "string" should have single value attribute

Cause: A facet declaration did not have a value attribute.

Action: Each facet declaration must contain one and only one value attribute.

LSX-00111 type "string" contains invalid facets

Cause: A specified facet was invalid for a type. Each datatype has a different set of facets which may apply.

Action: Use only applicable facets for the type.

LSX-00112 facet "string" duplicated

Cause: A facet (other than "enumeration") was specified more than once.

Action: Only the enumeration facet may be used more than once for a type.

LSX-00113 facet "string" has invalid value "string"

Cause: Facet value contains illegal characters or its value is out of range.

Action: Remove illegal characters.

LSX-00114 facet "string" not in schema schema

Cause: Facets are not defined in the XMLSchema namespace.

Action: Remove illegal facet declarations.

LSX-00116 mutually exclusive facets are not allowed

Cause: Mutual exclusiveness violations were found for facets. For example, both "length" and either "minLength" or "maxLength" are not allowed to be facets.

Action: Remove the facets that are at fault.

LSX-00117 "minLength" should not be greater than "maxLength"

Cause: The value of "minLength" must be less than or equal to the value of "maxLength".

Action: Correct either "minLength" or "maxLength".

LSX-00118 fixed facet value cannot be changed

Cause: The value of a fixed facet in the base type definition should remain the same.

Action: Remove the fixed facet specification in the parent's type for the erroneous facet component.

LSX-00123 base type is required

Cause: Missing base type declaration in the type definition.

Action: Define a base type.

LSX-00124 "list" element is improperly defined

Cause: A "list" element either must have its "itemType" attribute set or have one of its children be a "simpleType" element, but both conditions cannot exist.

Action: Remove the erroneous condition.

LSX-00125 "restriction" element is improperly defined

Cause: A "restriction" element either must have its "base" attribute set or have one of its children be a "simpleType" element, but both conditions cannot exist.

Action: Remove the erroneous condition.

LSX-00130 attribute "processContents" has invalid value "string"

Cause: Attribute "processContents" in the "any" element or "anyAttribute" declaration has an invalid value.

Action: Specify one of the following values: lax, skip, or strict.

LSX-00132 attribute "string" has invalid occurrences value "string"

Cause: A minOccurs or maxOccurs attribute had an invalid value (not a integer or less than zero).

Action: Use a legal "occurs" value.

LSX-00133 attribute "use" has invalid value "string"

Cause: A "use" attribute had an invalid value. Choices for "use" are "default", "fixed", "optional", "prohibited", or "required".

Action: Change the attribute to one of the above values.

LSX-00134 attribute "string" has invalid qualification "string"

Cause: An attribute that specifies qualification (form, attributeFormDefault, elementFormDefault) was invalid; it must be one of "qualified" or "unqualified".

Action: Change the attribute to one of the above values.

LSX-00135 invalid min/max Occurs for <all> element, must be 0/1

Cause: "minOccurs" has a value other than 0/1 or "maxOccurs" has a value other than 1.

Action: Specify 0/1 for "minOccurs" or "maxOccurs".

LSX-00136 "maxOccurs" is less than "minOccurs"

Cause: The value of the "maxOccurs" specification is less than the value of the "minOccurs" specification.

Action: Correct "minOccurs" or "maxOccurs".

LSX-00141 ID type may only be used in attributes

Cause: For backward compatibility with DTD, ID type may only be used in attributes.

Action: Remove the ID type.

LSX-00142 invalid sub-element "string" for element "string"

Cause: Invalid sub-element in the content of either attribute or element declaration.

Action: Remove the sub-element.

LSX-00143 element "string" must have type or ref

Cause: A Schema element was declared but was neither type or reference.

Action: One of type or reference must be specified.

LSX-00144 attribute "string" invalid derivation-restriction value "string"

Cause: An attribute which specifies a derivation-restriction setting (block, content, final) had an invalid value. Choices are "#all", "extension", or "restriction".

Action: Change the attribute to one of the above values.

LSX-00145 attribute "string" invalid derived value "string"

Cause: A derivedBy attribute had an invalid value. Choices are "extension" or "restriction".

Action: Change the attribute to one of the above values.

LSX-00146 element or attribute is improperly defined

Cause: An element or attribute definition must have either its "type" attribute set or must have one of its children be a "simpleType" or "complexType" element but both conditions cannot exist.

Action: Remove the erroneous condition.

LSX-00147 "string" cannot contain "string"

Cause: An invalid schema component exists in the current declaration.

Action: Remove the schema component.

LSX-00148 annotation must come first in "string"

Cause: "annotation" element must be the first in the content.

Action: Make "annotation" the first element.

LSX-00150 attributeGroup reference shouldn't have children

Cause: A reference-to-attributeGroup element has children. It is suppose to be empty except for annotations.

Action: Remove the children.

LSX-00151 invalid combination of attributes "ref" and "name"

Cause: If the item's parent is not <schema>, then either the "ref" or the "name" attribute must be present, but not both. Top-level elements or attributes must have a name.

Action: Specify either the "ref" or "name" attribute.

LSX-00152 only "minOccurs", "maxOccurs", or "id" is allowed

Cause: If the item's parent is not <schema> and "ref" is present, then "complexType", "simpleType", "key", "keyref", "unique", "nillable", "default", "fixed", "form", "block", and "type" must be absent.

Action: Remove the prohibited attribute.

LSX-00153 invalid combination of default and fixed attributes

Cause: It is an error for a declaration to contain both fixed and default attributes.

Action: Remove either the default or the fixed attributes.

LSX-00154 attribute "use" must have its value set to "optional"

Cause: If "default" and "use" are both present, use must have its value set to "optional".

Action: Remove the default attribute or change the value of the "use" attribute.

LSX-00155 invalid use of attribute "ref"

Cause: If the item's parent is not <schema> and the attribute "ref" is present, then the element "simpleType" and the attributes "form" and "type" must be absent.

Action: Remove the prohibited items.

LSX-00156 type is final and no derivations are allowed

Cause: Derivation from a type that is declared to be final occurred.

Action: Remove the final declaration from the base type.

LSX-00200 element "string" not empty

Cause: Content of the element must be empty.

Action: Remove any schema components in the content.

LSX-00201 contents of "string" should be elements only

Cause: Node with type other than "element", "processing instruction", or "comment" exists in the content of the violating element.

Action: Remove the offending nodes.

LSX-00202 contents of "string" should be text only

Cause: Node with type other than "text", "processing instruction", or "comment" exists in the content of the violating element.

Action: Remove the offending nodes.

LSX-00204 extra data at end of complex element

Cause: Extra nodes exist at the end of an element with a complex type definition.

Action: Remove the offending nodes or check the definition of the complex type.

LSX-00210 value "string" out of range for type "string"

Cause: Value is out of range for the data with a specific type.

Action: Fix the value.

LSX-00211 value "string" whose fractional digits exceeds number

Cause: Too many fractional digits after the decimal point.

Action: Remove the extra fractional digits.

LSX-00212 value "string" whose total digits exceeds number

Cause: Too many digits in the decimal data.

Action: Remove the extra digits.

LSX-00213 only number occurrences of particle "string", minimum is number

Cause: Too few occurrences of particles in the node.

Action: Specify more particles.

LSX-00214 too many occurrences of particle "string", maximum is number

Cause: Too many occurrences of particles in the node.

Action: Remove extra ones.

LSX-00220 "string" is wrong length, should be number

Cause: Data of simple type has invalid length.

Action: Fix the length of the data.

LSX-00221 "string" is too short (minimum length is number)

Cause: The length of the data is too short.

Action: Prepend extra characters (such as zeros or blank characters) to make the data longer.

LSX-00222 "string" is too long (maximum length is number)

Cause: The length of the data is too long.

Action: Remove extra characters from the data.

LSX-00229 item type is not a valid type for a list simple type

Cause: The specified item type must not itself be a list type, and must be one of the types identified in [XML Schemas: Datatypes] as a suitable item type for a list simple type.

Action: Change the list schema component's declaration.

LSX-00230 invalid integer "string"

Cause: Illegal characters exist in the "integer" or its derivative type declarations.

Action: Remove illegal characters.

LSX-00231 invalid unsigned integer "string"

Cause: Illegal characters exist in the "unsignedLong", "unsignedInt", "unsignedShort", or "unsignedByte" declarations.

Action: Remove illegal characters.

LSX-00232 invalid unsigned long "string"

Cause: Illegal characters exist in the "unsignedLong" declaration.

Action: Remove illegal characters.

LSX-00233 invalid long "string"

Cause: Illegal characters exist in the "long" declaration.

Action: Remove illegal characters.

LSX-00234 invalid decimal "string"

Cause: Illegal characters exist in the "decimal" declaration.

Action: Remove illegal characters.

LSX-00235 invalid URI "string"

Cause: Invalid URI specification for data of "anyURI" type.

Action: Remove illegal characters.

LSX-00237 invalid Name "string"

Cause: Invalid XML name.

Action: Remove illegal characters.

LSX-00238 invalid Nmtoken "string"

Cause: Invalid Nmtoken.

Action: Remove illegal characters.

LSX-00240 bad float "string"

Cause: Invalid value for "float" type data.

Action: Remove illegal characters.

LSX-00241 bad double "string"

Cause: Invalid value for "double" type data.

Action: Remove illegal characters.

LSX-00242 bad Boolean "string"

Cause: Boolean data must have a value from the following set: "1", "0", "true", or "false".

Action: Specify one of "1", "0", "true", or "false".

LSX-00243 invalid date "string"

Cause: Invalid value for data of "date" type.

Action: Remove illegal characters.

LSX-00244 invalid NCName "string"

Cause: Invalid value for data of "NCName" type.

Action: Remove illegal characters.

LSX-00245 invalid ID "string"

Cause: Data specified is not of "NCName" type.

Action: Remove illegal characters.

LSX-00246 invalid QName "string"

Cause: Invalid value for data of "QName" type.

Action: Remove illegal characters.

LSX-00247 invalid language specification "string"

Cause: Invalid value for data of "language" type.

Action: Remove illegal characters.

LSX-00248 invalid duration "string"

Cause: Invalid value for data of "duration" type.

Action: Remove illegal characters.

LSX-00249 invalid date or time "string"

Cause: Invalid value for data of "dateTime", "time", "gYearMonth", "gYear", "gMonthDay", "gDay", or "gMonth" type.

Action: Remove illegal characters.

LSX-00250 invalid normalizedString "string"

Cause: Invalid value for data of "normalizedString" type.

Action: Remove illegal characters.

LSX-00251 invalid token "string"

Cause: Invalid value for data of "token" type.

Action: Remove illegal characters.

LSX-00252 invalid union "string"

Cause: Data of simple type is not one of the union type.

Action: Use one of the union type as its type.

LSX-00253 branch is empty

Cause: The pattern specification "branch1 | branch2" has either "branch1" or "branch2" missing.

Action: Remove '|' or add either "branch1" or "branch2".

LSX-00255 mismatched parentheses

Cause: ")" found without a matching "(" in a pattern specification.

Action: Add "(" to the pattern specification.

LSX-00256 empty character class expression

Cause: "[]" found when processing a character class expression.

Action: Specify the character group within the brackets.

LSX-00257 atom specification is missing

Cause: A quantifier was found without an atom specification.

Action: Add an atom specification in front of the quantifier.

LSX-00258 invalid escape character

Cause: "x" in "is not a valid escape character.

Action: Change "x" to a valid escape character.

LSX-00259 invalid character found in the pattern

Cause: An unexpected character was found in the pattern.

Action: Fix the pattern.

LSX-00260 unexpected end of pattern

Cause: Something is missing at the end of the pattern.

Action: Fix the pattern.

LSX-00261 invalid character property

Cause: An error occurred when processing the character property. For example, "{" is missing after "p" or "P".

Action: Fix the character property.

LSX-00262 attribute "string" cannot have complex type "string"

Cause: The type of the attribute is "complex".

Action: Specify the type of the attribute to be "simple".

LSX-00263 undefined attribute "string"

Cause: Violating attribute is not defined in the current scope.

Action: Correct the attribute name if it's misspelled.

LSX-00264 attribute "string" is prohibited (may not occur)

Cause: Global declarations cannot contain the attributes "ref", "minOccurs", or "maxOccurs", or the use of this attribute is explicitly declared as "prohibited" by the schema.

Action: Remove the attribute.

LSX-00265 attribute "string" value "string" is wrong (must be "string")

Cause: Attribute has a value other than its fixed value.

Action: Use fixed value as its value.

LSX-00266 missing required attribute "string"

Cause: A required attribute is missing.

Action: Add the required attribute.

LSX-00270 hex-encoded binary has odd length

Cause: Data of "hexBinary" type has odd number of digits.

Action: Add missing digits as appropriate.

LSX-00271 invalid character "character" in hex-encoded binary

Cause: Data of "hexBinary" type has invalid characters.

Action: Remove illegal characters.

LSX-00272 BASE64-encoded binary grouped improperly (not 4's)

Cause: Number of digits is not a multiple of four.

Action: Add missing digits as appropriate.

LSX-00273 invalid character "character" in base64-encoded binary

Cause: Data of "base64Binary" type has invalid characters.

Action: Remove illegal characters.

LSX-00274 invalid padding in base64-encoded binary

Cause: Invalid padding characters at the end of data.

Action: Use "=" as the padding characters.

LSX-00280 duplicate ID "string"

Cause: ID name is not unique within the schema scope.

Action: Rename the ID.

LSX-00281 referenced ID "string" is not defined

Cause: Referenced ID name is not defined within the schema scope.

Action: Define the ID.

LSX-00282 duplicate notation name "string"

Cause: The name of the "notation" element is not unique within the schema scope.

Action: Rename the element.

LSX-00283 referenced notation "string" is not defined

Cause: Referenced notation name is not defined within the schema scope.

Action: Define the element.

LSX-00284 duplicate constraint name "string"

Cause: Each constraint declaration has a name which exists in a single symbol space for constraints.

Action: Choose a different name.

LSX-00285 referenced key "string" is not defined

Cause: Referenced key name is not defined within the schema scope.

Action: Define the key.

LSX-00290 invalid enumeration choice "string"

Cause: The value of the data is not one of the enumeration choice.

Action: Select one of the enumeration choices as its value.

LSX-00291 value "string" is less than minimum "string" (string)

Cause: Data has a value less than required minimum.

Action: Increase the value.

LSX-00292 value "string" is greater than maximum "string" (string)

Cause: Data has a value greater than maximum.

Action: Decrease the value.

LSX-00300 group must have name or ref but not both

Cause: "ref" or "name" attributes are either both missing or have both been specified.

Action: Specify either "ref", "name", but not both.

LSX-00310 local element or attribute should be namespace qualified

Cause: Element or attribute name is not namespace qualified.

Action: Add prefix or default namespace URI declaration.

LSX-00311 local element or attribute shouldn't be namespace qualified

Cause: Element or attribute name is namespace qualified.

Action: Remove prefix or default namespace URI declaration from itself or ancestors.

LSX-00320 missing required elements in <all>

Cause: Some required elements in "all" particle are missing.

Action: Add the missing elements.

LSX-00330 missing range start character

Cause: Missing range start character in a character range specification.

Action: Add the missing characters.

LSX-00331 missing comma

Cause: A comma is missing in a range specification.

Action: Add the missing characters.

LSX-00332 bad decimal digits in a quantifier specification

Cause: Quatifier has invalid characters.

Action: Remove illegal characters.

LSX-00333 literal "string" is not valid with respect to the pattern

Cause: Literal is not valid with respect to the pattern.

Action: Choose correct characters in the literal.

LSX-00340 improper namespace value for the imported element

Cause: If the namespace attribute is present, then its actual value must not match the actual value of the enclosing schema's targetNamespace attribute. If the namespace attribute is not present, then the enclosing schema must have a targetNamespace attribute.

Action: Match namespace value.

LSX-00341 ENTITY or ENTITIES type may only be used in attributes

Cause: For compatibility, ENTITY or ENTITIES should be used only on attributes.

Action: Remove the ENTITY or ENTITIES.

LSX-00342 value of attribute "base" must be a complex type definition

Cause: If the "complexContent" alternative is chosen, then the type definition resolved to by the actual value of the attribute "base" must be a complex type definition.

Action: Choose a complex type definition as its base type.


Oracle Trace Messages

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

Part XII
Oracle Trace Messages

This part contains the following chapter:

  • Chapter 53, "Oracle Trace Collection Services Messages (EPC)"


Oracle Trace Collection Services Messages (EPC)

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents 		Go To Index
Index
Master Index
Feedback

Go to previous page Go to next page

53
Oracle Trace Collection Services Messages (EPC)

The errors in this chapter are Oracle Trace Collection Services messages including the CLI, services, formatter, and reporter.

Contacting Oracle Support Services About Oracle Trace

When contacting Oracle Support Services about Oracle Trace, please have the following information available:

  • Version of Oracle Trace being used.
  • If an error occurred for a database collection, specify that database version.
  • Version of Oracle Intelligent Agent.
  • Operating system and version being used, for both the client and server.
  • Operation being performed when the error occurred; steps to reproduce error.
  • Any further details for the error if logged to EPC_ERROR.LOG and information in the Oracle Trace Manager logging window.
  • Configuration information, for example, are there one or more ORACLE_HOMES present? Are there one or more databases present?
  • Were collection .cdf and .dat files created? If so, what are their sizes?

EPC-00000 to EPC-00358

EPC-00001: invalid event flags passed

Cause: This is an Oracle Trace internal error; if it is returned it may indicate that some lower level routine has returned a status of 1 which the Oracle Trace code has not handled.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00002: invalid product ID passed

Cause: An invalid product ID was passed.

Action: Supply a valid product ID between 1 and 999999.

EPC-00003: invalid product version passed

Cause: An invalid product version number was passed.

Action: Supply a product version number not greater than 11 bytes in length.

EPC-00004: invalid product registration ID

Cause: An invalid product registration ID was passed.

Action: Supply a product registration ID not greater than 256 bytes in length.

EPC-00006: collection has been disabled

Cause: The collection of Oracle Trace data has been disabled through the use of the EPC_DISABLED environment variable.

Action: No action required.

EPC-00007: product version required

Cause: A product version number was not specified.

Action: Specify a product version number.

EPC-00008: epc_init routine called twice for this product

Cause: The epc_init routine has already been called for the product.

Action: Check the code to verify that the EPC_INIT routine is being called only once and that the call to the EPC_INIT routine is in the correct location.

EPC-00014: no product number specified

Cause: No product number argument was supplied to the Oracle Trace API routine, for example, EPC_EVENT routine.

Action: Specify a product number.

EPC-00015: not enough memory

Cause: Memory allocation failed; system has run short of available memory.

Action: Try executing a similar Oracle Trace collection with fewer processes running; your system may be short of memory.

EPC-00020: Oracle Trace cannot access memory

Cause: This error indicates that Oracle Trace is unable to extend the size of one of its memory mapped administrative .dat files, when the file has become full. This is only a Windows NT issue. On other platforms, the files are extended as needed with no user action needed.

Action: Wait for currently running Oracle Trace collections to be completed before freeing up space on the *.dat files. If no Oracle Trace collections are running (and Oracle database processes are no longer attached to the files), then run the otrccref image to create new, empty .dat files, and if desired, specify larger file sizes when otrccref is run, for example, otrccref -f200 -c32 -r400.

EPC-00023: product not collecting data

Cause: A collection is active, but the specified instrumented product is not part of the collection.

Action: Verify the correct product version was specified for the collection.

EPC-00030: collection not found

Cause: An Oracle Trace operation (for example, cancel) was attempted for a collection that is not currently known to Oracle Trace Collection Services.

Action: Supply the name of a collection that exists.

EPC-00035: illegal record length

Cause: An illegal record length was encountered on the EPC_EVENT call.

Action: Refer to the Oracle Trace User's Guide for information on valid record lengths in the epc_event call.

EPC-00036: invalid event passed

Cause: An invalid event number was passed.

Action: Supply a valid event number.

EPC-00037: invalid event number

Cause: A 0 was specified for the event.

Action: Supply a valid event number.

EPC-00038: no handle specified

Cause: A null handle argument was specified on the START_EVENT or END_EVENT call.

Action: Supply a handle address on the call.

EPC-00039: event specified not collecting

Cause: The product is collecting, but the event is not.

Action: No action required.

EPC-00040: error writing to data collection file

Cause: The data cannot be written to the data collection file.

Action: Verify that there is enough disk space and that file protections are correct.

EPC-00043: error obtaining data file lock

Cause: An unusually high contention for updating the collection data file prevents acquiring write lock on the file.

Action: Retry when fewer processes are taking part in the collection.

EPC-00046: general error message

Cause: Typically this error is returned through Oracle Trace Manager when an underlying error value is out of range of values handled. Under unusual conditions, it may also be used to report an error for which cause could not be determined.

Action: Look for error details, if any, in the EPC_ERROR.LOG file, and find cause/action descriptions for those errors. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00047: invalid context value passed

Cause: An invalid context value was passed to the Oracle Trace API routine, for example, EPC_EVENT.

Action: Supply a valid context argument to the API routine calls.

EPC-00048: no context passed; one is expected

Cause: There was no context passed to the Oracle Trace API routine and one was expected.

Action: Pass a context.

EPC-00049: thread_id is not current thread

Cause: Context to the current thread has not been set.

Action: Set context to the current thread.

EPC-00053: registration ID already exists

Cause: The optional registration string specified in the EPC_INIT call is a duplicate.

Action: Correct the instrumented code.

EPC-00054: product limit exceeded

Cause: The limit of 5 products per collection was exceeded.

Action: No action required. However, you lose the connection to the oldest collection.

EPC-00055: error opening data collection file

Cause: Oracle Trace encountered an error while attempting to open the data collection file (.dcf).

Action: Verify that collection files exist and check file protections. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00056: error opening collection definition file

Cause: Oracle Trace encountered an error while attempting to open the collection definition file (.cdf).

Action: Verify that the collection's collection definition file (.cdf) exists and check file protections. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00057: invalid cross-product item number

Cause: An invalid cross-product item number was specified, for example, in the EPC_CF_VALUE call.

Action: Supply a cross-product number from 1 through 14.

EPC-00058: epc_init call required

Cause: An EPC_INIT call was expected, but not found.

Action: Check the code to verify a call to EPC_INIT is made in the correct place.

EPC-00060: data collection file required

Cause: The data collection file was not specified, for example, for the epc_collect call.

Action: Verify the instrumented code.

EPC-00061: product definition file required

Cause: The product definition file (.fdf) was not specified, for example, for the epc_collect call.

Action: Verify the instrumented code.

EPC-00062: collection already active

Cause: The specified collection is already active.

Action: No action required.

EPC-00063: error reading product definition file

Cause: An error was encountered while trying to read the product definition file (.fdf) specified, for example, on the EPC_COLLECT call.

Action: Verify that the product definition file exists and check file protections. Also check directory protections, definition for ORACLE_HOME, and Oracle Trace parameter settings. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00064: error creating data collection file

Cause: An error was encountered while trying to create the data collection file (.dcf).

Action: Check protection settings on the Oracle Trace admin/cdf directory. Also check the definition for ORACLE_HOME and Oracle Trace parameter settings. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00065: error creating collection definition file

Cause: An error was encountered while creating the specified collection definition file (.cdf).

Action: Check protection settings on the Oracle Trace admin/cdf directory. Also check the definition for ORACLE_HOME and Oracle Trace parameter settings. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00066: error writing collection definition file

Cause: An error was encountered while writing to the specified collection definition file (.cdf).

Action: Check that there is enough disk space and that file protections are correct. Also check directory protections, definition for ORACLE_HOME, and Oracle Trace parameter settings. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00067: error opening product definition file

Cause: An error was encountered while opening the product definition file.

Action: Verify that the product definition file (.fdf) exists and if so, check file protections. Also check directory protections, definition for ORACLE_HOME, and Oracle Trace parameter settings. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00068: seek error in collection definition file

Cause: A seek error was encountered in the collection definition file (.cdf).

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00069: error obtaining platform/system information, e.g., OS name and version

Cause: The operating system could not be identified.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00070: get host name error; host cannot be identified

Cause: The host name could not be identified; platform-specific call to obtain host failed.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00071: invalid maximum event specified

Cause: An invalid maximum event was specified.

Action: Supply a maximum event greater than 0 but less than 128.

EPC-00072: returned_eflags parameter required

Cause: The returned event flags parameter was expected but not found on the EPC_INIT call.

Action: Supply the required information on the EPC_INIT call.

EPC-00073: invalid offset value specified

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00075: file name required

Cause: A file name was expected but not found, for example, an .fdf file name is required to start a collection.

Action: Supply a file name.

EPC-00076: predefined_eventflags parameter required on epc_init call

Cause: The PREDEFINED_EVENTFLAGS parameter was expected but a NULL pointer was passed on the EPC_INIT call.

Action: Supply the required information on the EPC_INIT call.

EPC-00077: invalid event key option value specified on epc_init call

Cause: An invalid event key option was specified on the EPC_INIT call.

Action: Supply a valid event key option argument on the EPC_INIT call.

EPC-00078: feature not yet implemented

Cause: This feature is not yet implemented.

Action: Do not use this feature. No action required.

EPC-00080: file append seek failed

Cause: File I/O seek to start (or end) file during append operation failed. This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00081: append write failed

Cause: Disk space was exceeded during a file append operation, for example, while creating the collection definition file (.cdf).

Action: Increase disk space.

EPC-00082: append read failed

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00083: error creating product definition file

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00084: file memory mapping failed

Cause: Most often this indicates that a mismatch exists between Oracle Trace Collection Services and other components (for example, database server version). Memory mapping of Oracle Trace admin .dat files can also generate errors if files are not located on a locally mounted disk device.

Action: Refer to the Oracle Trace documentation or contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00085: memory unmapping failed

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00086: memory mapping required before memory unmapping

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00087: beginning CLI job

Cause: This condition is used to signal the beginning of an Oracle Trace CLI job (that is, executed by the Oracle Intelligent Agent on behalf of Oracle Trace). It is not an error.

Action: No action required. For Oracle Server release 7.3.3, the error message read "Cannot allocate process record in PRO file." This often occurs in conjunction with error EPC-00084.

EPC-00088: call to string formatting package failed

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00089: value of event_id exceeds epc_init max_event

Cause: The EVENT_ID parameter supplied in the EPC_EVENT call is greater than the maximum previously specified on the EPC_INIT call.

Action: Supply a valid EVENT_ID.

EPC-00090: error writing version record

Cause: The system may be out of disk space.

Action: Verify that the drive where ORACLE_HOME is located has enough disk space. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00094: system timestamp call failed

Cause: Oracle Trace could not get the system timestamp.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00095: error adding new registration ID record

Cause: The system may be out of disk space.

Action: Verify that the drive where ORACLE_HOME is located has enough disk space. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00096: error closing registration ID file

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00097: error creating new registration ID file

Cause: User may not have write access to the directory where Oracle Trace admin .dat files are to be located, for example, $ORACLE_HOME/otrace/admin; or available disk space may be insufficient.

Action: Provide access to the directory or additional free disk space. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00098: error deleting registration ID record

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00099: error deleting registraton ID detail record

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00100: error finding free slot for new registration ID detail record

Cause: The system may be out of disk space.

Action: Verify that the drive where ORACLE_HOME is located has enough disk space. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00101: error finding primary registration ID record for specified process

Cause: Oracle Trace was unable to open its admin REGID.DAT file.

Action: Verify that the file is present in the Oracle Trace admin directory and that file protections allow access. If that fails, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00103: invalid registration ID context

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00104: invalid or inconsistent registration ID data

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00105: invalid registration ID string, e.g. too long

Cause: The registration ID string supplied is invalid (probably too long).

Action: Supply a valid registration ID string.

EPC-00106: error finding next registration ID record

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00107: error finding next registration ID detail record

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00108: error opening registration ID file

Cause: Oracle Trace was unable to open its admin REGID.DAT file.

Action: Verify that the file is present in the Oracle Trace admin directory and that file protections allow access. If that fails, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00109: error reading a registration ID record

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00110: error reading registration ID file header

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00112: error setting file extend_count parameter

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00113: error during addition of new collection record

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00114: error during close of collection file

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00116: collection already exists in collect.dat file

Cause: The collection name has already been used and currently exists in the Oracle Trace admin COLLECT.DAT file. If the collection is inactive, this record will eventually be discarded.

Action: Specify a new collection name or force clean up of Oracle Trace admin .dat files by executing the otrccref image (once all processes have detached from these files).

EPC-00117: error creating collect.dat file

Cause: User may not have write access to the directory where Oracle Trace admin .dat files are to be located, for example, $ORACLE_HOME/otrace/admin; or available disk space may be insufficient; or an instrumented process may still be accessing the .dat files.

Action: Provide access to the directory or additional free disk space. Verify that no processes are currently using Oracle Trace .dat files, for example, the database. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00118: error deleting collect.dat record

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00119: error finding specified collect.dat record

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00120: invalid or undefined collect.dat context

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00121: invalid or undefined collection name

Cause: For Oracle Trace operations such as "start collection", a user-supplied collection name is required, but may not have been provided.

Action: Make sure a collection name has been supplied. If so, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00122: error getting next collect.dat record

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00123: error during opening of collect.dat file

Cause: Oracle Trace Collection Services cannot access the admin collect.dat file in the expected location, that is $ORACLE_HOME/admin.

Action: Verify that the Oracle Trace admin collect.dat file exists and check for file protection problems. Also check directory protections, definition for ORACLE_HOME, and Oracle Trace parameter settings. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00124: error reading collect.dat record

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00125: error reading collect.dat file header

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00126: error setting collect.dat file extend_count

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00133: completed CLI job

Cause: This condition is used to signal the completion of an Oracle Trace CLI job (that is, executed by Oracle Intelligent Agent on behalf of Oracle Trace). It is not an error.

Action: No action required.

EPC-00146: " "

Cause: Used by Oracle Trace command-line interpreter (CLI); part of normal, successful Oracle Trace job output.

Action: No action required.

EPC-00147: job ID not specified

Cause: User-provided job ID for CLI start and stop collection functions was not supplied; else internal Oracle Trace error.

Action: If Oracle Trace CLI was executed without specifying job ID value, try operation again with the correct command-line parameters. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00148: collection status is: active

Cause: This is a success return status for the Oracle Trace CLI "check collection" operation, assuming the specified collection exists and is active.

Action: No action required.

EPC-00149: collection status is: not active

Cause: This is a success message.

Action: No action required.

EPC-00150: collection status is: undefined

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00151: deleted collection definition and data collection files

Cause: This is a success message.

Action: No action required.

EPC-00153: invalid or ambiguous CLI command specified

Cause: Oracle Trace CLI was provided with incorrect or incomplete command verb, or no command at all.

Action: Provide complete CLI command verb, for example "start" (plus other required command-line parameters) to start a collection.

EPC-00155: maximum number of restrictions exceeded

Cause: More than the maximum number of restriction records was provided as input by CLI user (maximum is currently 5).

Action: Reduce input restrictions provided as CLI parameters.

EPC-00156: ORACLE_HOME parameter not supplied

Cause: The ORACLE_HOME environment variable has not been defined and is required by the Oracle Trace CLI.

Action: Define ORACLE_HOME and rerun CLI function.

EPC-00157: collection started

Cause: This is a success message.

Action: No action required.

EPC-00158: collection completed

Cause: This is a success message.

Action: No action required.

EPC-00159: user name or password (or service name) not supplied

Cause: For Oracle database access, for example, to format Oracle Trace data, the user must supply a valid database account user name, password, and database service name to form a complete Oracle database connect string.

Action: Supply the missing connect string component.

EPC-00160: error activating collection

Cause: If the regid.dat file was not accessible at collection activation, Oracle Trace could not activate the collection. This is an internal error.

Action: Verify that the regid.dat file is accessible, otherwise contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00163: error translating ORACLE_HOME

Cause: An error occurred while translating the environment logical ORACLE_HOME.

Action: Check your ORACLE_HOME definition and that the otrace/admin directory exists and is accessible. Otherwise, see your database administrator (DBA).

EPC-00164: error in product admin directory name translation

Cause: An error occurred while determining the path to the Oracle Trace admin directory.

Action: Check your ORACLE_HOME definition and that the otrace/admin directory exists and is accessible. Otherwise, see your database administrator (DBA).

EPC-00166: error canceling collection

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00167: collection file reached limit

Cause: The maximum file size specified when the collection was started has been exceeded.

Action: No action required. For future collections, increase the maximum file size.

EPC-00169: error deleting collection definition file

Cause: Signaled by Oracle Trace CLI if an error occurred while attempting to delete a collection's .cdf file, most likely caused by file not existing (that is, already deleted), or file protection; or file may still be held by one or more processes that took part in the Oracle Trace collection, that is, database processes.

Action: Verify that the file exists; fix protection if necessary. If database processes have the file held open, wait for the processes to release the files (on the next database action for each process).

EPC-00170: error deleting collection data file

Cause: Signaled by Oracle Trace CLI if an error occurred while attempting to delete a collection's .dat file, most likely caused by file not existing (that is, already deleted), or file protection; or file may still be held by one or more processes that took part in the Oracle Trace collection, that is database processes.

Action: Verify that the file exists; fix protection if necessary. If database processes have the file held open, wait for the processes to release the files (on the next database action for each process).

EPC-00172: parameter parsing error

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00173: command-line argument list parse failed

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00174: input parameter file parse failed

Cause: This error can occur if you provided Oracle Trace CLI with incorrect input parameters. Otherwise, this is an Oracle Trace internal error.

Action: Correct the CLI input parameters, otherwise contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00175: Oracle Trace CLI otrccol image not found or not executable

Cause: The Oracle Trace CLI image otrccol does not exist in ORACLE_HOME/bin, or access to it is denied.

Action: If the image exists, set protection to allow execution. If the image does not exist, check with the person responsible for Oracle installations on that system. If you have multiple ORACLE_HOME definitions, verify that the correct ORACLE_HOME is being used. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00176: format completed

Cause: This is a success message.

Action: No action required.

EPC-00177: format started

Cause: This is a success message.

Action: No action required.

EPC-00179: collection stopped by user action or maximum file size (or error)

Cause: This message indicates that the user has explicitly stopped a collection before its scheduled completion, or the collection has been terminated due to specified maximum file size having been reached (or a full disk), or some error condition has forced the collection to stop.

Action: If the user did not stop the collection, check disk use. Check maximum file size in INIT.ORA file or Oracle Trace Manager. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00180: deletion of formatted data started

Cause: This is a success message.

Action: No action required.

EPC-00181: deletion of formatted data completed

Cause: This is a success message.

Action: No action required.

EPC-00182: OCI database access error occurred

Cause: Error occurred during Oracle Trace CLI database access.

Action: See EPC_ERROR.LOG file for additional failure information and error messages. If the problem persists, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00183: invalid epcfctx parameter

Cause: Invalid facility context argument was passed to the Oracle Trace API routine, for example, EPC_EVENT.

Action: Supply a facility context argument.

EPC-00184: invalid collection definition file pointer

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00185: file version not current Oracle Trace version

Cause: An attempt was made to access collection files created by an incompatible version of Oracle Trace.

Action: Use the correct version of Oracle Trace to access the collection files.

EPC-00186: error starting collection

Cause: An error occurred in setting the collection status to active in the collect.dat file. This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00189: active collection limit exceeded

Cause: The maximum number of collections for this product was exceeded. The current maximum is 5 collections.

Action: Retry the collection later.

EPC-00190: invalid facility.dat file context; internal error

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00191: error adding product record to facility.dat file

Cause: Error occurred while adding record for this instrumented product to the FACILITY.DAT file.

Action: Verify the existence and accessibility of the FACILITY.DAT file. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00192: error creating facility.dat file

Cause: Error occurred during creation of FACILITY.DAT file by the OTRCCREF image.

Action: Verify that the Oracle Trace admin directory exists and is accessible, and that the FACILITY.DAT file is not currently in use.

EPC-00193: error setting file extent in the facility.dat file

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00194: error updating product record in facility.dat file

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00195: error finding next product record in facility.dat file

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00196: error reading header record from facility.dat file

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00197: error reading from facility.dat file

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00198: error deleting product record from facility.dat file

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00199: error closing facility.dat file

Cause: This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00200: error opening facility.dat file

Cause: Error occurred while opening the FACILITY.DAT file.

Action: Verify that the FACILITY.DAT file is accessible, else contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00220: could not find item

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. Have the .cdf and .dat files available. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00224: error writing to a report file

Cause: Oracle Trace could not write data to the report output file, for example, col_name*.txt.

Action: Check that there is enough disk space and that file protections are correct.

EPC-00226: localtime() error.

Cause: The Oracle Trace reporter could not determine the size required for the local representation of dates.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00227: seek error trying to find first product registration ID

Cause: The Oracle Trace reporter encountered a seek error while looking for the first product registration ID.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00228: could not find matching product

Cause: The Oracle Trace reporter could not find the specified product.

Action: Contact Oracle Support Services. Have the collection definition file (.cdf) and data (.dat) files available. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00229: event item record found before event record

Cause: The Oracle Trace reporter found an item record before an event record.

Action: Contact Oracle Support Services. Have the collection definition file (.cdf) and data (.dat) files available. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00230: event record not found

Cause: The Oracle Trace reporter could not find the event record.

Action: Contact Oracle Support Services. Have the collection definition file (.cdf) and data (.dat) files available. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00233: error allocating in-memory structure in routine

Cause: A memory allocation error has occurred.

Action: Check the use of memory in your application. If there is no problem there, Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00234: could not allocate memory

Cause: A memory allocation error (calloc) has occurred.

Action: Check the use of memory in your application. If there is no problem there, Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00235: data collection file filename.dat not found

Cause: The data file could not be found, probably because it was deleted and no longer exists.

Action: No action required.

EPC-00236: collection definition file filename.cdf not found

Cause: The collection definition file (.cdf) could not be found, or could not be accessed due to file protection.

Action: No action required if the .cdf file no longer exists. If the .cdf file exists, verify the file protections.

EPC-00237: unknown record in collection definition file

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. Have the collection definition file (.cdf) and data (.dat) files available. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00238: error reading collection definition file

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. Have the collection definition file (.cdf) and data (.dat) files available. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00239: program-supplied string

Cause: This is not an error. This information is used to output arbitrary text strings.

Action: No action required.

EPC-00240: invalid justification in insert field

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. Have the collection definition file (.cdf) and data (.dat) files available. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00241: consistency error in insert field

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. Have the collection definition file (.cdf) and data (.dat) files available. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00256: error checking file status

Cause: The attempt to determine the file size failed. This is an Oracle Trace internal error.

Action: Contact Oracle Support Services. Have the .cdf and .dat files available. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00257: read error

Cause: Oracle Trace has encountered an error while trying to read a file.

Action: If the file protections are correct and the problem still occurs, then this is an Oracle Trace internal error. Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00258: write error in filename

Cause: Oracle Trace has encountered an error while trying to write a file.

Action: If the file protections are correct and the problem still occurs, then this is an Oracle Trace internal error. Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00259: seek error in filename

Cause: Oracle Trace has encountered an error while trying to read a file.

Action: If the file protections are correct and the problem still occurs, then this is an Oracle Trace internal error. Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00260: error extending file

Cause: Oracle Trace could not extend the file.

Action: Check that there is sufficient disk space and that file protections are set correctly.

EPC-00261: map read error in filename

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00297: error writing to data collection file filename

Cause: The data file has protection problems or is full.

Action: Correct any protection problems if necessary. Otherwise, this is an Oracle Trace internal error and you should contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00306: no data to report from file filename

Cause: This is an Oracle Trace Reporter error that indicates there could be protection problems on the .dat file or that there were no processes running from which to collect data.

Action: Check the protections on the .dat file. Otherwise, no action required.

EPC-00307: error during Oracle commit

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00308: error executing Oracle statement

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00309: error parsing SQL statement

Cause: This error is typically seen during the format of Oracle Trace data into a database. This error indicates that format tables may not exist in the database or current format table definitions are out of sync with an Oracle Trace image trying to perform the format operation. Oracle Trace releases 7.3.4 and 8.0.4 (and higher) are able to create and update metadata describing format tables automatically but older versions do not have this ability.

Action: If necessary, update the Oracle Trace format table definitions in the target database by running the Oracle Trace formatter SQL scripts. However, it may be necessary to use a different database and or database user account for formatted data in the situation where a newer version of Oracle Trace has already formatted data to a database or database user account. Incompatible older Oracle Trace versions will never be able to format to this same database or database user account due to format table differences. See the Oracle Trace User's Guide for the explanation about the otrcfmt image.

EPC-00310: error opening message file

Cause: This error could indicate a protection problem on the message file, for example, the EPCUS.MSB file.

Action: Check that the message file protections are correct. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00314: error reading body of data collection file

Cause: This is an Oracle Trace internal error. It should never be returned.

Action: Contact Oracle Support Services. Have the collection definition file (.cdf) and data (.dat) files available. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00319: missing required schedule collection user information

Cause: If you are running Oracle Trace CLI from the command line to start a collection, then this error indicates that required information has not been provided in the CLI input parameter file. In other cases, this is an Oracle Trace internal error and should never be returned.

Action: Correct the CLI input parameter file, if you are running the CLI in command-line mode. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00322: error creating process report file

Cause: This indicates that the Process report could not be created. It could be due to a disk space or protection problem.

Action: Check that there is enough disk space and that protections are set correctly. Otherwise, contact Oracle Support Services. See the section titled "Contacting Oracle Support Services About Oracle Trace" for additional information.

EPC-00337: usage: command [-w[wid] -l[len] -P -p[pid] -h -a -d] input_file [output_dir]

Cause: The Oracle Trace Report command was incorrectly used.

Action: Resubmit the command using the correct parameters in the correct order.

EPC-00342: ID for collection ID not found in database; rerun with -f option

Cause: The Oracle Formatter could not find the specified collection ID in the data file.

Action: Rerun the format and specify the -f option to format the entire data file.

EPC-00343: usage: formatter image [-f] input_file [username [password [service]]]

Cause: This is an invalid format command.

Action: Reenter the format command.

EPC-00344: no new data to format; exiting

Cause: An attempt was made to format a data file that contains no new data.

Action: No action required.

EPC-00350: aborting format of collection_id ID; delete from database and reformat

Cause: There are several causes for this message. It could be just an informational message and not an error message if the user canceled the Format operation.

Action: Check the EPC_ERROR.LOG for other underlying error messages, for example, failure to resolve database service name supplied to the formatter. (This could mean that the TNSNAMES.ORA file on the local node where the format code is executing does not contain an entry for the specified format database.) If the collection ID given in the error message is less than 0, then format processing probably did not get as far as accessing the format database. Retry the Format command and specify the -f parameter (that is, full rather than partial format) to reformat data that had already been formatted before the abort took place.

EPC-00351: format canceled by user

Cause: The Oracle Trace Format operation was stopped.

Action: No action required.

EPC-00352: file already exists; select a new name

Cause: The file name specified already exists.

Action: Supply a new file name, that is, collection name.

EPC-00357: tried to add a duplicate callback routine for same cross-product item

Cause: An attempt was made to add a duplicate callback routine for the same cross-product item.

Action: Correct the code.

EPC-00358: tried to remove a non-existent cross-product callback routine

Cause: An attempt was made to remove a non-existent cross-product callback routine.

Action: Correct the code.


Oracle9i Database Error Messages -- Index

Part Number A96525-01
Go To Documentation Library
Home 		Go To Product List
Book List 		Go To Table Of Contents
Contents
Master Index
Feedback

Go to previous page

Index

A B D E I K L M N O P Q R S T U V

A

AMD, 29-1
AUD, 47-1

B

BACKGROUND_DUMP_DEST initialization parameter, 1-5

D

DBV, 21-1
DRG, 50-1

E

EPC, 53-1
EXP, 17-1

I

IMG, 48-1
IMP, 18-1
initialization parameters
BACKGROUND_DUMP_DEST, 1-5
USER_DUMP_DEST, 1-5

K

KUP, 20-1

L

LCD, 23-1
LFI, 27-1
LPX, 51-1
LRM, 26-1
LSX, 52-1

M

message stacks, 1-3
MOD, 39-1

N

NCR, 37-1
NID, 22-1
NMP, 36-1
NNC, 31-1
NNF, 35-1
NNL, 33-1
NNO, 32-1
NPL, 34-1
NZE, 38-1

O

O2F, 40-1
O2I, 41-1
O2U, 42-1
ORA-00000 to ORA-00899, 2-1
ORA-00900 to ORA-01499, 3-1
ORA-01500 to ORA-02099, 4-1
ORA-02100 to ORA-04099, 5-1
ORA-04100 to ORA-07499, 6-1
ORA-07500 to ORA-09857, 7-1
ORA-09858 to ORA-12299, 8-1
ORA-12300 to ORA-12399, 9-1
ORA-12400 to ORA-12699, 10-1
ORA-12700 to ORA-19399, 11-1
ORA-19400 to ORA-24279, 12-1
ORA-24280 to ORA-29249, 13-1
ORA-29250 to ORA-32799, 14-1
ORA-32800 to ORA-32999, 15-1
ORA-33000 to ORA-65535, 16-1

P

PCB, 43-1
PCC, 45-1
PCF, 44-1
PLS, 28-1

Q

QSM, 24-1

R

RMAN, 25-1

S

SQL, 46-1
SQL*Loader, 19-1

T

TNS, 30-1

U

USER_DUMP_DEST initialization parameter, 1-5

V

variable text in messages, 1-3
VID, 49-1
Go to previous page


Oracle Corporation

Copyright Information
Copyright © 1994-2002 Oracle Corporation. All rights reserved.

Trademark Information
Oracle is a registered trademark of Oracle Corporation.


Documentation Feedback

We are constantly improving the content and delivery of our documentation. Tell us what you think. Comments sent to infodev_us@oracle.com will be delivered to the appropriate person. The address is for documentation comments only. Contact Oracle Support Services for software support.

 Oracle
Copyright © 2002 Oracle Corporation.
All Rights Reserved.
Home