Backup&Recovery
2008-07-03
ORA-00704 与 bootstrap 错误
今天有一个客户在升级数据库到10g之后遇到了如下错误:
ORA-00704: bootstrap process failure
ORA-00604: error occurred at recursive SQL level 1
ORA-01406: fetched column value was truncated
Error 704 happened during db open, shutting down database
USER: terminating instance due to error 704
Instance terminated by USER, pid = 20971
ORA-1092 signalled during: ALTER DATABASE OPEN...
一般来说,见到bootstrap错误都是很严重的故障,bootstrap过程失败数据库肯定就无法打开。很多时候bootstrap$表损坏也会导致bootstrap失败。
以上一系列错误说明在升级的过程中出现问题,升级是不完全的,从而导致数据库无法bootstrap。
可以尝试从备份中恢复数据库,再次进行升级。
记以录之。
-The End-
历史上的今天
- 2017-07-03 Oracle 11.2.0.4 和 12c 安装 INS-30131 临时位置权限解决
- 2011-07-03 Oracle Exadata在全球部署超过1000台
- 2007-07-03 《循序渐进Oracle》内容简介
- 2006-07-03 招聘Oracle DBA一名
- 2005-07-03 王小慧作品
- 2005-07-03 如何使用sqlldr的WHEN判断加载数据到不同的数据表
- 2005-07-03 如何从备份集中恢复归档日志
- 2004-07-03 Oracle中临时表产生过量Redo的说明
- 2004-07-03 安装10g以后Oracle9i的DBCA无法启动问题之解决
直接用dbua升级是比较危险的.
看来,最好的还是先建好环境,在imp/impdp进数据好些.
这个是未startup upgrade打开造成的,只要以升级模式打开实例,执行脚本就行了。
是的,有些时候是升级遗漏了upgrade步骤导致的。
我的数据库出现这个问题了:
先是提示ora-01172:recovery of thread stuck at block 9 of file 1
然后用_allow_resetlogs_corruption=true
RECOVER时还是出错,
直接alter database open resetlogs
就出现这个问题。
郁闷啊,数据库为非归档的。