eygle Eygle.
Oracle12c/11g 2019-01-16

Oracle 12.2 DBCA 使用 Silent 建库

许久没有用 Silent 方式建库了,非常顺畅,建立一个 12.2 非多租户的数据库:

[oracle12c@iz2zeezinabu7k6olgelwez ~]$ dbca -silent -createDatabase \

> -templateName General_Purpose.dbc \

> -gdbname eygle -sid eygle -responseFile NO_VALUE \

> -characterSet AL32UTF8 \

> -sysPassword OraPasswd1 \

> -systemPassword OraPasswd1 \

> -createAsContainerDatabase false \

> -databaseType MULTIPURPOSE \

> -automaticMemoryManagement false \

> -totalMemory 1536 \

> -storageType FS \

> -datafileDestination "/u01/oracle12c/db/oradata/" \

> -redoLogFileSize 50 \

> -emConfiguration NONE \

> -ignorePreReqs

[WARNING] [DBT-11207] Specified SGA size is greater than the shmmax on the system. This might make database creation to fail with ORA-27125 - Unable to create shared memory segment error.

ACTION: Specify SGA size lesser than or equal to the shmmax on the system.

Copying database files

1% complete

2% complete

18% complete

33% complete

Creating and starting Oracle instance

35% complete

40% complete

44% complete

49% complete

50% complete

53% complete

55% complete

Completing Database Creation

56% complete

57% complete

58% complete

62% complete

65% complete

66% complete

Executing Post Configuration Actions

100% complete

Look at the log file "/u01/oracle12c/db/cfgtoollogs/dbca/eygle/eygle.log" for further details.

如果是多租户,增加几个参数,类似如下:

dbca -silent -createDatabase \
-templateName General_Purpose.dbc \
-gdbname cdb01 -sid cdb01 -responseFile NO_VALUE \
-characterSet AL32UTF8 \
-sysPassword OraPasswd1 \
-systemPassword OraPasswd1 \
-createAsContainerDatabase true \
-numberOfPDBs 1 \
-pdbName pdb3 \
-pdbAdminPassword OraPasswd1 \
-databaseType MULTIPURPOSE \
-automaticMemoryManagement false \
-totalMemory 1536 \
-storageType FS \
-datafileDestination "/u01/app/oracle/oradata/" \
-redoLogFileSize 50 \
-emConfiguration NONE \
-ignorePreReqs

操作很简单.

By eygle 2019-01-16 21:16 评论 (0)
eygle
eygle

前Oracle ACE Director,云和恩墨创始人。技术为骨,历史为脉,人文为魂。

返回首页 →