Backup&Recovery · Case
2010-02-04
ORA-00600 4000 及 4194 错误小记
刚刚帮朋友处理一则CURRENT日志损坏的恢复,当然是使用到了:
_allow_resetlogs_corruption= TRUE
在初期恢复时出现了ORA-600 4000号错误,这个错误以前写过几个案例,一般没有好的办法,只能通过bbed修复。
不过4000号错误不一定非要用bbed修改坏块,有时候经过反复几次重新启动数据库,就可以暂时规避,尝试将数据导出。
首先出现的是:
多次重启后,出现4194错误:
但是数据此时可以导出,4194错误出现在回滚段2上,当然也可以解决,这个都是大家所熟悉的了。
-The End-
_allow_resetlogs_corruption= TRUE
在初期恢复时出现了ORA-600 4000号错误,这个错误以前写过几个案例,一般没有好的办法,只能通过bbed修复。
不过4000号错误不一定非要用bbed修改坏块,有时候经过反复几次重新启动数据库,就可以暂时规避,尝试将数据导出。
首先出现的是:
Thu Feb 04 13:36:58 2010
Errors in file D:\oracle\admin\orcl\udump\ORA00592.TRC:
ORA-00600: internal error code, arguments: [4000], [3], [], [], [], [], [], []
SMON: disabling cache recovery
Thu Feb 04 13:36:59 2010
ORA-704 signalled during: alter database open resetlogs
多次重启后,出现4194错误:
Thu Feb 04 21:24:41 2010
SMON: enabling cache recovery
SMON: enabling tx recovery
Thu Feb 04 21:24:42 2010
Completed: alter database open
Thu Feb 04 21:24:43 2010
Errors in file D:\oracle\admin\orcl\bdump\orclSMON.TRC:
ORA-00600: internal error code, arguments: [4194], [14], [4], [], [], [], [], []
Thu Feb 04 21:24:44 2010
Recovery of Online Redo Log: Thread 1 Group 2 Seq 2 Reading mem 0
Mem# 0 errs 0: D:\ORACLE\ORADATA\ORCL\REDO02.LOG
Thu Feb 04 21:24:44 2010
Errors in file D:\oracle\admin\orcl\bdump\orclSMON.TRC:
ORA-01595: error freeing extent (7) of rollback segment (2))
ORA-00600: internal error code, arguments: [4194], [14], [4], [], [], [], [], []
但是数据此时可以导出,4194错误出现在回滚段2上,当然也可以解决,这个都是大家所熟悉的了。
-The End-
历史上的今天
- 2016-02-04 新春贺礼:云和恩墨大讲堂期刊第二期
- 2009-02-04 ORA-07445 kprball()+483错误之原因分析
- 2009-02-04 《深入解析Oracle》一书脚本包下载
- 2009-02-04 2009回家过年及香港之行-纵横四海篇
- 2008-02-04 回家的感觉就在那不远的前方
- 2007-02-04 ITPUB年会回顾-阿里巴巴的数据库管理优化体系
- 2006-02-04 回京的路相当的曲折
- 2005-02-04 写给朋友的一封信-新年快乐
导出的数据导入时还是报错了 有两个表的数据有错误,差了半天数据,imp报数据太大到导入不进去 让业务手工补单子去了