Advanced
2008-09-02
Oracle10g DataGuard中ORA-16026错误解决
今天配置一个Oracle 10g DataGuard的环境,遇到一个如下错误:
Tue Sep 2 08:21:26 2008
Errors in file /home/oracle/admin/ora10g/udump/ora10g_ora_32028.trc:
ORA-16026: parameter LOG_ARCHIVE_DEST_1 contains an invalid attribute value
ORA-16026是因为主库没有设置参数log_archive_config参数,正确设置这个参数可以解决这个问题。
这个参数的设置格式类似:
*.log_archive_config='dg_config=(primary,standby)'
也可以在命令行设置:
SQL> alter system set LOG_ARCHIVE_CONFIG='DG_CONFIG=(primary,standby)';System altered.
SQL> show parameter log_archive_config
NAME TYPE VALUE
------------------------------------ ----------- ------------------------------
log_archive_config string DG_CONFIG=(primary,standby)
这里的 DG_CONFIG=(primary,standby) 包含的是主库与备库的db_unique_name.
其实我犯的还不是这个错误:
SQL> show parameter db_uni NAME TYPE VALUE
------------------------------------ ----------- ------------------------------
db_unique_name string priamry
是因为一不留神,PRIMARY被我拼写错误,小的错误也犯不得,在小的地方,同样需要警惕。
-The End-
历史上的今天
- 2013-09-02 恩墨学院:有时回忆不是过往 - BeyondVisible的OCM历程
- 2010-09-02 Oracle 11g默认用户密码增强-default_pwd$
- 2009-09-02 11gR2新特性之一-列式压缩(Columnar Compression)
- 2009-09-02 并行查询的 PX Deq: reap credit 等待
- 2009-09-02 Oracle 11g R2 For Linux发布 - 2009-08-31
- 2007-09-02 转载新闻一则--一只小野鸭的超能量
- 2006-09-02 《深入浅出Oracle》技术交流会圆满结束
- 2005-09-02 Oracle10gR2:New Features-drop empty datafile
- 2005-09-02 Oracle 10g Release 2 all available
小的错误也犯不得,在小的地方,同样需要警惕。
---同感,细节决定成败。
我现在有个小疑问,就是关于这个参数的
LOG_ARCHIVE_CONFIG,就是当switch over以后,这个参数的值用不用改?